SolidWorks 安装管理程序下载文件夹

SolidWorks 安装管理程序可将所需的安装文件下载到您指定的文件夹中。该主题提供对下载文件夹常见问题的回答。

  1. 我如何安装此文件夹中的文件？
  2. 我可以使用 msiexec 或一些其它应用程序手动从此文件夹安装 MSI 文件吗？
  3. 我可为每个安装的版本选取同一下载文件夹吗？
  4. 我从 Dassault Systèmes SolidWorks Corporation 网站手动下载了一些产品。安装管理程序可安装这些内容吗？
  5. 我下载的文件可被其他用户共享吗？
  6. 我如何知道有新版本 SolidWorks 产品可用？
  7. 安装管理程序只显示 SW2006 或 SW2007 安装，而非当前版本。
  8. 安装管理程序不让我选取安装某产品的另一个 service pack。
  9. 安装管理程序被阻止下载文件。
  10. 我的 SolidWorks 产品并未全部更新到最新的 service pack，但“检查更新”却告诉我说我已经拥有了最新版本？
  11. 我可以将 DVD 复制到下载文件夹中吗？

我如何安装此文件夹中的文件？

运行 setup.exe。如果您选择安装以前没有下载的项目，您可能仍需要下载某些文件。

不要使用 msiexec 进行安装（参阅下文）。

回到页首

我可以使用 msiexec 或一些其它应用程序手动从此文件夹安装 MSI 文件吗？

否。安装管理程序不下载在运行 msiexec 时所需的某些文件。

回到页首

我可为每个安装的版本选取同一下载文件夹吗？

下载文件夹是版本特定的。从 SolidWorks 2010 开始，SolidWorks 安装管理程序会自动在指定的文件夹内创建版本特定的子文件夹。

回到页首

我从 Dassault Systèmes SolidWorks Corporation 网站手动下载了一些产品。安装管理程序可安装这些内容吗？

从 SW2009 开始，SolidWorks 安装管理程序可以使用手动下载的文件。但最好是运行 SolidWorks 安装管理程序，然后选择文件下载选项。SolidWorks 安装管理程序会根据您的安装内容来显示所需的文件，并提供下载每个文件的链接。当内置的下载页面不能正常运行时（很有可能是代理服务器施加了下载限制），可以使用此选项。
如果在下载或安装过程中 Microsoft Internet Explorer 问您是保存还是运行文件，始终选择保存。

回到页首

我下载的文件可被其他用户共享吗？

是。若要共享，下载到网络共享中。然后，每个客户端即可从共享处运行 SolidWorks 安装管理程序进行安装。

无需另外下载，除非用户选择下载在初始下载时未选择的某些项，或者使用此下载内容进行安装的计算机上的必备组件集与初始下载的计算机上的必备组件集不同。

如果您在代表他人进行下载但不进行安装，请在安装时选择只下载选项。无论您的系统上安装什么项目，该选项将让您选取产品。然而，此选项不能用来下载修补程序，也不能用来生成管理映像。

回到页首

我如何知道有新版本 SolidWorks 产品可用？

在以下情况下，当有新版本可用时将会通知您：
  • 当您运行“检查更新”（开始 > 所有程序 > SolidWorks 安装管理程序 > 检查更新）时
  • 如果您已启用 SolidWorks 后台下载程序。
  • 如果您在 Windows 的添加/删除程序中选择了一个已安装的 SolidWorks 版本并单击更改
  • 如果您从下载文件夹运行安装管理程序 (sldIM.exe) 的旧版本
在这些情况下，您可选择下载新版本。SolidWorks 安装管理程序将下载并运行自身的新版本，而不是任何安装文件。在 SolidWorks 安装管理程序的新版本运行后，您可选取一组安装操作。然后，SolidWorks 安装管理程序将决定需要哪些安装文件（以前没有下载过）并主动下载这些文件。

回到页首

SolidWorks 安装管理程序只显示 SW2006 或 SW2007 安装，而非当前版本。

您在运行在当前版本中不再受支持的 SolidWorks 安装管理程序旧版本。它只可为 SW2006 和 SW2007 版本下载 service packs。

回到页首

SolidWorks 安装管理程序不让我选取安装某产品的另一个 service pack。

此为特意设计。每个 SolidWorks 安装管理程序仅用于安装 SolidWorks 产品的特定版本。如果您想安装另一 service pack，您需要运行该版本的 SolidWorks 安装管理程序。要查找可供使用的最新版本，请参阅我如何知道有新版本 SolidWorks 产品可用？

回到页首

SolidWorks 安装管理程序被阻止下载文件。

如果代理服务器的限制阻止应用程序下载文件，则 SolidWorks 安装管理程序无法自动下载文件。

您可以手动下载文件，然后使用 SolidWorks 安装管理程序安装这些文件。在 SolidWorks 安装管理程序中选择用于单独下载文件的选项（例如下载选项页面中的进行手动下载）。根据您的产品选择和系统要求，将在单独的窗口中显示网页，其中包含所有手动下载文件的链接。这些链接与 SolidWorks Customer Portal（客户门户）提供的链接一致，但是您不必搜索这些文件。

回到页首

我的 SolidWorks 产品并未全部更新到最新的 service pack，但“检查更新”却告诉我说我已经拥有了最新版本？

“检查更新”只告诉您是否您已安装有（或在运行）SolidWorks 安装管理程序的最新版本。

如果您想将所有产品都更新到安装的最新版本，请在添加/删除程序中选择 SolidWorks 的最新安装版本，然后单击更改。

回到页首

我可以将 DVD 复制到下载文件夹中吗？

是，但安装可能失败，除非您为该平台（x86 或 x64）复制每张 DVD 提供的全部内容。SolidWorks 安装管理程序通过查找文件 swdata*.id 来确定版本。如果这些文件不存在，它将无法识别您所复制的任何安装文件，并要求将之下载。

回到页首


法律通告

© 1995-2011, Dassault Systèmes SolidWorks Corporation 属于 Dassault Systèmes S.A. 公司。175 Wyman Street, Waltham, Mass. 02451 USA。保留所有权利。

本文档中提及的信息和软件如有更改，恕不另行通知，Dassault Systèmes SolidWorks Corporation (DS SolidWorks) 对此概不负责。

未经 DS SolidWorks 明确书面许可，不得以任何形式或通过任何手段（电子或手工方式）以及出于任何目的翻印或传播任何相关资料。

本文档中提及的软件受许可证协议限制，只能根据本许可证协议的条款使用或拷贝。DS SolidWorks 对该软件和文档提供的所有保证均在许可协议中阐明，此文档及其内容中提及或暗示的任何内容，均不会视为许可协议中任何条款（包括保证）的修改和补充。

专利通告

SolidWorks® 3D 机械 CAD 软件受美国专利 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 以及外国专利(如 EP 1,116,190 及 JP 3,517,643) 保护。

eDrawings® 软件受美国专利 7,184,044; 美国专利 7,502,027; 以及加拿大专利 2,318,706 保护。

还有正在申请中的美国和外国专利。

SolidWorks 产品和服务的商标和产品名称

SolidWorks、3D PartStream.NET、3D ContentCentral、eDrawings 和 eDrawings 徽标是注册商标，FeatureManager 是 DS SolidWorks 的合营注册商标。

CircuitWorks、FloXpress、TolAnalyst 及 XchangeWorks 是 DS SolidWorks 的商标。

FeatureWorks 是 Geometric Ltd 的注册商标。

SolidWorks 2012、SolidWorks Enterprise PDM、SolidWorks Workgroup PDM、SolidWorks Simulation、SolidWorks Flow Simulation、eDrawings Professional、以及 SolidWorks Sustainability 是 DS SolidWorks 的产品名称。

其它商标或产品名称分别是其所有者的商标或注册商标。

商用计算机软件 - 所有权

软件按照在 48 C.F.R. 12.212 (1995 年 10 月)中所定义的术语属"商用项目"，并按照在 48 C.F.R. 12.212 (1995 年 10 月) 中所定义的术语由"商用计算机软件"和"商用软件文献"所组成并提供给美国政府， (a) 依照 48 C.F.R. 12.212 中设定的政策被或代表民事机构而持有；(b) 依照 48 C.F.R. 227.7202-1 (1995 年 6 月) 和 227.7202-4 (1995 年 6 月)中所设定政策被或代表国防部有关单位而持有。

如果您收到美国政府任何机构的请求，要求提供超出以上所述权利的软件，您可通知 DS SolidWorks 有关请求的范围， DS SolidWorks 将在五个 (5) 工作日内酌情考虑接受或不接受如此请求。合同方/制作商：Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US。

SolidWorks Standard、Premium、Professional、以及 Education 产品的版权通告

本软件一部分归 © 1986-2011 Siemens Product Lifecycle Management Software Inc.。保留所有权利。

本指南中涉及 Siemens Industry Software Limited 拥有的以下软件：

D-Cubed™ 2D DCM © 2011。Siemens Industry Software Limited。保留所有权利。

D-Cubed™ 3D DCM © 2011。Siemens Industry Software Limited。保留所有权利。

D-Cubed™ PGM © 2011. Siemens Industry Software Limited。保留所有权利。

D-Cubed™ CDM © 2011。Siemens Industry Software Limited。保留所有权利。

D-Cubed™ AEM © 2011。Siemens Industry Software Limited。保留所有权利。

本软件一部分 (C) 1998-2011 Geometric Ltd。

本软件一部分属 © 1996-2011 Microsoft Corporation。保留所有权利。

该软件一部分并入了 NVIDIA 的 PhysX™, 2006-2010。

本软件一部分 © 2001-2011 Luxology, LLC.保留所有权利，专利待定。

本软件一部分 (C) 2007-2011 DriveWorks Ltd.

版权所有 1984-2010 Adobe Systems Inc. 及其许可方。保留所有权利。受美国专利 5,929,866；5,943,063；6,289,364；6,563,502；6,639,593；6,754,382 和申请中的专利保护。

Adobe、Adobe 徽标、Acrobat、Adobe PDF 徽标、Distiller 及 Reader 是 Adobe Systems Inc. 在美国或其它国家中的注册商标或商标。

有关 SolidWorks® 详细的版权信息，请参阅帮助 > 关于 SolidWorks。

SolidWorks Simulation 产品的版权通告

本软件一部份属 © 2008, Solversoft Corporation。

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. 保留所有权利。

SolidWorks Enterprise PDM 产品的版权通告

Outside In® Viewer Technology，© 1992-2011 Oracle

© 2011，Microsoft Corporation。保留所有权利。

eDrawings 产品的版权通告

本软件一部分属 © 2000-2011 Tech Soft 3D。

本软件一部分属 © 1995-1998 Jean-Loup Gailly and Mark Adler。

本软件一部分属 (C) 1998-2001 3Dconnexion。

本软件一部分属 © 1998-2011 Open Design Alliance。保留所有权利。

本软件一部分属 (C) 1995-2010 Spatial Corporation。

此软件部分基于 Independent JPEG Group 的创作。