SolidWorks Installation Manager Download Folder

SolidWorks Installation Manager can download the installation files it needs to a folder that you specify. This topic provides answers to frequently asked questions about the download folder.

  1. How do I install the files in this folder?
  2. Can I install MSI files manually from this folder using msiexec or some other application?
  3. Can I select the same download folder for each version I install?
  4. I downloaded some products manually from the Dassault Systèmes SolidWorks Corporation Web site. Can the Installation Manager install these?
  5. Can the files I download be shared by other users?
  6. How do I know when a new version of SolidWorks products becomes available?
  7. The Installation Manager shows only SW2006 or SW2007 installs, but not the current version.
  8. The Installation Manager does not let me select a different service pack of a product to install.
  9. The Installation Manager is prevented from downloading files.
  10. Not all of my SolidWorks products are updated to the latest service pack, but Check For Updates tells me I have the latest version?
  11. Can I copy a DVD to a download folder?

How do I install the files in this folder?

Run setup.exe. You may still be required to download some files if you select to install items that were not downloaded previously.

Do not install using msiexec (see below).

Back to Top

Can I install MSI files manually from this folder using msiexec or some other application?

No. The Installation Manager does not download some files that would be required when running msiexec.

Back to Top

Can I select the same download folder for each version I install?

Download folders are version-specific. Starting in SolidWorks 2010, SolidWorks Installation Manager automatically creates a version-specific sub-folder within the specified folder.

Back to Top

I downloaded some products manually from the Dassault Systèmes SolidWorks Corporation Web site. Can the Installation Manager install these?

Starting in SW2009, files downloaded manually can be used by SolidWorks Installation Manager. However, it is better to run SolidWorks Installation Manager, selecting the option to download files. SolidWorks Installation Manager shows which files you need based on what you are installing, providing links to download each file. This option can be used when the built-in download page does not work (most likely because of downloading restrictions enforced by a proxy server).
If Microsoft Internet Explorer asks whether you want to save or run files during a download or installation, always specify save.

Back to Top

Can the files I download be shared by other users?

Yes. To do so, download to a network share. Each client can then run SolidWorks Installation Manager from the share to install.

No further downloads will be required unless a user selects some items to install that were not selected during the initial download or if a computer that uses this download to install has a different set of prerequisites than the computer to which you downloaded the files.

If you are downloading on behalf of others but are not installing, select the Download Only option when installing. This option will allow you to select products regardless of what may be installed on your system. However, this option cannot be used to download patches or to create administrative images.

Back to Top

How do I know when a new version of SolidWorks products becomes available?

You will be informed when a new version is available in the following cases:
  • If you run Check for Updates ( Start > All Programs > SolidWorks Installation Manager > Check For Updates)
  • If you have enabled SolidWorks Background Downloader.
  • If you select an installed version of SolidWorks in Windows Add/Remove Programs and click Change
  • If you run an older version of the Installation Manager (sldIM.exe) from a download folder
In these cases, you may select to download the newer version. SolidWorks Installation Manager will download and run the newer version of itself, and not any installation files. After the newer version of SolidWorks Installation Manager runs, you may select a set of installation actions. SolidWorks Installation Manager will then determine which installation files are needed (and not downloaded previously) and will offer to download those files.

Back to Top

SolidWorks Installation Manager shows only SW2006 or SW2007 installs, but not the current version.

You are running an older version of SolidWorks Installation Manager that is no longer supported for the current release. It can only download service packs for SW2006 and SW2007 versions.

Back to Top

SolidWorks Installation Manager does not let me select a different service pack of a product to install.

That is by design. Each version of SolidWorks Installation Manager is designed to install only a specific version of SolidWorks products. If you want to install a different service pack, you need to run that version of SolidWorks Installation Manager. To find the latest version available, see How do I know when a new version of SolidWorks products becomes available?

Back to Top

SolidWorks Installation Manager is prevented from downloading files.

If proxy server restrictions prevent applications from downloading files, SolidWorks Installation Manager cannot download files automatically.

You can download files manually and then install them using SolidWorks Installation Manager. Select the option in SolidWorks Installation Manager to download individual files (for example, Conduct manual download on the Download Options page). Based on your product selections and system requirements, a web page appears in a separate window containing links to download all required files manually. These links are identical to those provided by the SolidWorks Customer Portal, but you do not need to search for the files.

Back to Top

Not all of my SolidWorks products are updated to the latest service pack, but Check For Updates tells me I have the latest version?

Check For Updates only tells you whether you have installed (or are running) the latest version of SolidWorks Installation Manager.

If you want to update all products to the latest version that is installed, in Add/Remove Programs, select the latest installed version of SolidWorks and click Change.

Back to Top

Can I copy a DVD to a download folder?

Yes, but installations may fail unless you copy the entire contents of each DVD released for that platform (x86 or x64). SolidWorks Installation Manager looks for the files swdata*.id to determine the version. If these files are not present, it will fail to recognize any of the installation files that you copied and will require that they be downloaded.

Back to Top


Legal Notices

© 1995-2011, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SolidWorks Products and Services

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, TolAnalyst, and XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Workgroup PDM, SolidWorks Simulation, SolidWorks Flow Simulation, eDrawings Professional, and SolidWorks Sustainability are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995).

In the event that you receive a request from any agency of the U.S. government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

Copyright Notices for SolidWorks Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2011 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. All Rights Reserved.

Portions of this software © 1998-2011 Geometric Ltd.

Portions of this software © 1996-2011 Microsoft Corporation. All rights reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2011 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more SolidWorks® copyright information, see Help > About SolidWorks.

Copyright Notices for SolidWorks Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SolidWorks Enterprise PDM Product

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2011 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2011 Open Design Alliance. All rights reserved.

Portions of this software © 1995-2010 Spatial Corporation.

This software is based in part on the work of the Independent JPEG Group.