SolidWorksのインストールと管理（SolidWorks Installation and Administration）

このガイドはSolidWorks製品の個人インストレーションと複数インストレーションの両方におけるインストレーション、ライセンス管理、アップグレード、管理について説明します。

個人インストレーション | 複数インストレーションの展開
インストレーション(Installation) 1台または数台のコンピュータへのインストレーション。 | インストレーション(Installation) 複数のクライアント コンピュータに展開するアドミニストレーティブ イメージの作成。
ライセンス（Licensing） ライセンス アクティベーションまたはネットワーク ライセンス。 | ライセンス（Licensing） ライセンス アクティベーションまたはネットワーク ライセンス。
アップグレード（Upgrades） 各コンピュータを新しいリリース版に移行。 | アップグレード（Upgrades） コンピュータへのインストールに使用したアドミニストレーティブ イメージのアップデートにより複数のコンピュータを新しいリリース版に移行。
アドミニストレーション（Administration） インストレーションの変更、修復、削除、および新しいリリースへのアップグレード。 | アドミニストレーション（Administration） アドミニストレーティブ イメージとクライアントのアップグレード、ネットワーク ライセンス管理、Workgroup PDMのボルト管理。

SolidWorks Installation Managerは、SolidWorks、SolidWorks Toolbox、PhotoView 360、Workgroup PDM、およびSolidWorks SolidNetWork License Managerを含むSolidWorks製品コンポーネントの設定を構成できるようにします。

Workgroup PDMは、SolidWorks環境内で、あるいはスタンドアロン アプリケーションとしてSolidWorks Explorer内で動作する、製品データ管理ソフトウェアです。Workgroup PDMは、プロジェクトのチェックアウト/チェックイン/リビジョン管理の手順、またその他の管理作業をコントロールします。

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

  • 個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
    SolidWorks製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに1コマンドでインストールしますか?
  • SolidWorksインストレーションの開始（Initiating SolidWorks Installation）
    SolidWorksインストレーションを開始するには、ローカル コンピュータでDVDを読み込むか、共有インストレーション ディレクトリにアクセスするか、またはSolidWorksからダウンロードします。


個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

SolidWorks製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに1コマンドでインストールしますか?

一台のコンピュータのみにインストールする場合や数百台のコンピュータにインストールする場合、この選択は明らかです。それ以外の場合は、次の比較を参考にしてください。

個人インストレーション | アドミニストレーティブ イメージ
各ユーザーが個人的にSolidWorksを管理できます。 | システム管理者はオプション エディタを使って、複数のインストレーションをカスタマイズすることができます。新規インストレーションを作成したり、あるいは既存のものを更新するインストレーション オプションを指定したり、アドミニストレーティブ ユーザーとして起動したり、インストレーションの前後に外部コマンドを実行したり、異なる製品のグループ分けを行います。
インストレーションを実行する個人が、コンピュータに物理的にアクセスできなければなりません。 | クライアント コンピュータが同じネットワーク上でアクセス可能な限り、物理的な距離は問題ありません。
異なるバージョン、ServicePack、製品を、別々のコンピュータ上に独自の設定でインストールできます。 | オプション エディタを使って、アドミニストレーティブ イメージはバージョン、Service Pack、製品、設定の一貫性を維持することができます。
ServicePackを適用する際、ソース メディア（DVD）が必要です。 | ServicePackを適用する際、メディア ドライブは必要ありません。
コンピュータは、ネットワーク上にある必要はありません。 | アプリケーションを展開するには、ローカル ネットワークが接続されている必要があります。クライアント コンピュータ上にメディア ドライブは必要ありません。
 | クライアントは自動的にアップデートされます。 同じアドミニストレーティブ イメージから展開されたすべてのクライアントが同じServicePackになります。複数のバージョンを維持するには、複数のアドミニストレーティブ イメージを作成します。
 | ライセンスのアクティベーションを自動的に行うことができます。
 | アドミニストレーティブ イメージは、サーバー上の追加のディスク容量を必要とします。クライアントは、個別インストレーションと同じ容量を必要とします。
親トピック: SolidWorksのインストールと管理（SolidWorks Installation and Administration）


SolidWorksインストレーションの開始（Initiating SolidWorks Installation）

SolidWorksインストレーションを開始するには、ローカル コンピュータでDVDを読み込むか、共有インストレーション ディレクトリにアクセスするか、またはSolidWorksからダウンロードします。

  • SolidWorksインストールを開始するは、次のいずれかを行います。
    • ローカル コンピュータにディスクからインストールするには、適切なディスクをディスク ドライブに挿入します。
    • ダウンロード ディレクトリからインストールするには、 ディレクトリまで移動し、 setup.exeをダブルクリックします。
    • SolidWorksからダウンロードしてインストールするには、以下を行います。
      1. SolidWorks Webサイトまで参照します。
      2. Subscriptionサービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SolidWorksシリアル番号を入力します。
      3. Self Service（セルフ サービス）で Download Software and Updates（ソフトウェアとアップデートのダウンロード）をクリックします。
      4. Download Software（ソフトウェアのダウンロード）で ダウンロードするSolidWorksのバージョンとServicePackを選択します。
親トピック: SolidWorksのインストールと管理（SolidWorks Installation and Administration）


個人インストレーション（Individual Installations）

  • 個人コンピュータでのインストール（Installation on Individual Computers）
    SolidWorksは、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。
  • 個人インストレーションの管理（Administration of Individual Installations）
    通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。


個人コンピュータでのインストール（Installation on Individual Computers）

SolidWorksは、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。

SolidWorks Installation Managerはインストレーションを購入した製品に合うように調整し、インストレーションを実行します。インストレーションを開始する前に、以下を行います。

  • SolidWorksシリアル番号をお手元に準備してください。
  • インターネット接続された環境であることを確認してください。
SolidWorks Installation Managerは、Microsoft Windowsインストーラ、Office Webコンポーネント、Microsoft Visual Studio Tools for Applications、および.NET Frameworkを含むさまざまなMicrosoftコンポーネントを必要とします。すべてのWindows前提条件コンポーネントの正しいバージョンがコンピュータにインストールされていない場合、SolidWorks Installation ManagerはSolidWorks製品をインストールする前に、これらのコンポーネントを自動的にインストールします。
インストレーション方法 プロセスの概要
SolidWorksインストレーション メディアを使用 適切なDVDディスクをコンピュータのディスク ドライブに挿入します。
SolidWorksインストレーション メディアでは、32-bitおよび64-bit Windowsインストレーション用に別々のDVDが提供されています。
サーバー上のダウンロード ディレクトリを使用 ダウンロード ディレクトリでsetup.exeをダブルクリックします。
ダウンロード ディレクトリは、SolidWorks製品をインストールするコンピュータからアクセス可能であり、インストレーションの開始前にすべてのSolidWorksインストレーション ファイルが含められている必要があります。SolidWorks Installation Managerは、ダウンロード ディレクトリに対するインターネット アクセスと書き込みアクセスがある場合、見つからないファイルを探すのに役立ちます。
これはアドミニストレーティブ イメージではありません。アドミニストレーティブ イメージからクライアント コンピュータにインストールするには、SolidWorks管理者から送信されるHTMLページ上のリンクをクリックする方法のみ有効です。
アップデート チェック(Check for Updates) を使用して既存のSolidWorksインストレーションを更新 次のいずれかを行います：
  • SolidWorksでヘルプ > アップデート チェックをクリックします。
  • Windowsでスタート > すべてのプログラム > SolidWorks Installation Manager > アップデート チェックをクリックします。
インターネット接続されている必要があります。

Workgroup PDMクライアントはVaultの更新を自動的に検出します。ServicePackをダウンロードしてクライアントをアップデートする必要はありません。詳細については、Workgroup PDMオンライン ヘルプ（Workgroup PDM online help）のクライアントのアップデート（Update Clients）を参照してください。

SolidWorks customer Webサイトからのダウンロード
  1. SolidWorks Webサイトまで参照します。
  2. Subscriptionサービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SolidWorksシリアル番号を入力します。
  3. Self Service（セルフサービス）で、Download Software and Updates（ソフトウェアとアップデートのダウンロード）をクリックします。
  4. Download Software（ソフトウェアのダウンロード）で、インストールしたいSolidWorks バージョンを選択します。
インターネット接続されている必要があります。

Customer Portalサイトに対するログイン権限のあるSubscription契約ユーザーである必要があります。

インストレーションが完了したら、SolidWorksアプリケーションを開始し、ライセンス アクティベーション（activate the license）を行います。

親トピック: 個人インストレーション（Individual Installations）


個人インストレーションの管理（Administration of Individual Installations）

通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。

  • インストレーションの変更（Modifying an Installation）
    インストールされていない製品をインストールできるように、インストレーションを変更できます。
  • インストールの修復（Repairing an Installation）
    もしインストールされたSolidWorks 製品の問題があるならば、SolidWorks インストールマネージャーをインストールを修復するために使うことができます。
  • 個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
    個人インストレーションを現在のメジャー リリース ファミリー内の以前のServicePackリリースにロールバックするには、コンピュータに現在インストールされているServicePackバージョンをアンインストールしてから、以前のバージョンを再インストールします。
  • インストレーションの削除（Removing an Installation）
    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。
  • 新しいリリースへのアップグレード（Upgrading to a New Release）
    個人インストレーションを新しいSolidWorksリリースにアップグレードする方法は、いくつかあります。
  • 製品の共存ルール（Product Coexistence Rules）
    製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。
親トピック: 個人インストレーション（Individual Installations）


インストレーションの変更（Modifying an Installation）

インストールされていない製品をインストールできるように、インストレーションを変更できます。

SolidWorksはインストール済みでアドインを後から購入した場合は、新規のアドインが含まれるようにインストレーションを変更できます。アドインは各コンピュータにインストールする必要があります。

元のSolidWorksを変更してSolidWorks ProfessionalまたはSolidWorks Premiumのパッケージを含めるように指定すると、Workgroup PDMはインストールされません。
  1. アクティブなSolidWorksのセッションがないことを確認します。
  2. Windows Vista かそれ以降で スタート > コントロール パネル >プログラムと機能 をクリックします。

    以前の Windows ではスタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。

  3. 変更したいSolidWorksインストレーションを選択してから、変更（Change）をクリックします。
  4. SolidWorks Installation Managerへようこそ（Welcome to the SolidWorks Installation Manager）画面で個人インストレーションの変更（このコンピュータ上で実行します）（Modify the individual installation （on this computer））をクリックします。
  5. シリアル番号（Serial Number）画面で適切なシリアル番号が指定されていることを確認します。
  6. 製品選択（Product Selection）画面でインストールまたは削除する製品を選択します。

    インストレーションの変更は以下のようになります。

    • 新しいシリアル番号を指定した場合も、デフォルトでインストールまたは削除される製品はありません。それぞれの製品や機能コンポーネントのインストール動作を変更する必要があります。
    • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
    • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。（たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
    • 初期の指定からコンポーネントのインストール動作を変更すると、アスタリスク（*）がリスト内のそのコンポーネントの横に表示されます。
    • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
    • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

  7. サマリー（Summary）画面で今すぐ変更（Modify Now）をクリックします。
  8. インストレーション完了（Installation is Complete）画面で、終了（Finish）をクリックします。
親トピック: 個人インストレーションの管理（Administration of Individual Installations）


インストールの修復（Repairing an Installation）

もしインストールされたSolidWorks 製品の問題があるならば、SolidWorks インストールマネージャーをインストールを修復するために使うことができます。

個人インストレーションは修復できます。 アドミニストレーティブ イメージは修復できません； アドミニストレーティブ イメージをアンインストールして、次に再インストールしなければなりません。
  1. Windows Vista かそれ以降で スタート > コントロール パネル > プログラム >プログラムと機能 をクリックします。

    以前の Windows ではスタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。

  2. 修復する SolidWorks バージョンを選択し、変更（Change）をクリックします。
  3. SolidWorks Installation Managerへようこそ（Welcome to the SolidWorks Installation Manager）画面で個人インストレーションの修復（このコンピュータ上で実行します）（Repair the individual installation (on this computer)）をクリックします。
  4. 修復する製品(Products to Repair)画面で、修復する製品を選択します。
  5. スクリーン上で残りの製品を選択解除します。
  6. 修復（Repair）をクリックします。
親トピック: 個人インストレーションの管理（Administration of Individual Installations）
親トピック: インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）


個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

個人インストレーションを現在のメジャー リリース ファミリー内の以前のServicePackリリースにロールバックするには、コンピュータに現在インストールされているServicePackバージョンをアンインストールしてから、以前のバージョンを再インストールします。

親トピック: 個人インストレーションの管理（Administration of Individual Installations）


インストレーションの削除（Removing an Installation）

個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  1. アクティブなSolidWorksのセッションがないことを確認します。
  2. SolidWorksライセンスを別のコンピュータにトランスファーする場合は、コンピュータからSolidWorksインストレーションを削除する前にライセンスを別のコンピュータにトランスファーしてください。

    SolidWorksライセンスのトランスファーに関する情報については、ライセンス トランスファー（Transferring a License）を参照してください。

  3. Windows Vista かそれ以降で スタート > コントロール パネル > プログラム >プログラムと機能 をクリックします。

    以前の Windows ではスタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。

  4. 削除する製品を選択します。

    場合によっては、特定のメジャー リリース バージョンに対して複数のSolidWorks ServicePackコンポーネントが存在するかもしれません。 SolidWorks メジャー リリースを削除するには、そのメジャー リリースに対するすべての SevicePack 要素を削除します。

  5. アンインストール（Uninstall）スクリーンで次を行います:
    1. 削除する製品を選択します。 すべての製品コンポーネントがデフォルトで選択されています。
    2. 削除したくない製品を選択解除します。
    3. カスタム アンインストールか完全なアンインストールを選択します。 SolidWorks Installation Manager では、デフォルトで一般的なアンインストールが実行され、プログラム ファイルとフォルダが削除されます。

      1. 変更（Change）を詳細設定オプション（Advanced Options）でクリックします。

        詳細設定オプション（Advanced Options）がスクリーンに表示されます。プログラム ファイルとフォルダのオプションが選択されています。

      2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
      3. サマリーに戻る（Back to Summary）をクリックします。
      4. サマリー（Summary）の画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法を表示します。

    4. アイテムを削除（Remove Items）をクリックします。
親トピック: 個人インストレーションの管理（Administration of Individual Installations）


新しいリリースへのアップグレード（Upgrading to a New Release）

個人インストレーションを新しいSolidWorksリリースにアップグレードする方法は、いくつかあります。

次の場合に新しいリリースにアップグレードすることができます。
  • 新しいインストレーション メディアを受け取った
  • SolidWorksの開始時にアップグレードが通知された
  • マニュアルでのアップデート チェックを行った
  • 新しいインスタンスのSolidWorks Installation Managerを開始した

新しいメジャー リリースのインストール時には、前にインストールしたメジャー リリースをアップグレードするか、または新しいリリースを並行してインストールできます。インストール済みのメジャー リリースに対するServicePackリリースをインストールする場合、このリリースは自動的にアップデートされます。

  • マニュアルでのアップデート チェック（Checking for Updates Manually）
    現在インストールされているSolidWorksリリースのアップデート チェックは、以下のいずれかの方法を使用して行えます。
  • Workgroup PDMクライアントのアップグレード（Upgrading Workgroup PDM Clients）
    Vault（ボルト）がアップデートされている場合、Workgroup PDMクライアントはそれを検知します。ServicePackをダウンロードしてクライアントをアップデートする必要はありません。
  • アップグレードの注意点（Upgrade Caveats）
    メジャー バージョンが異なる複数のインストレーションが許可される製品の場合は、メジャー アップグレードがサポートされない、あるいは次のメジャー バージョンへのアップグレードが一度の作業で可能でない場合があります。
親トピック: 個人インストレーションの管理（Administration of Individual Installations）


マニュアルでのアップデート チェック（Checking for Updates Manually）

現在インストールされているSolidWorksリリースのアップデート チェックは、以下のいずれかの方法を使用して行えます。

  • SolidWorksでヘルプ > アップデート チェックをクリックします。
  • Microsoft Windowsでスタート > プログラム > SolidWorks Installation Manager > アップデート チェックをクリックします。
親トピック: 新しいリリースへのアップグレード（Upgrading to a New Release）


Workgroup PDMクライアントのアップグレード（Upgrading Workgroup PDM Clients）

Vault（ボルト）がアップデートされている場合、Workgroup PDMクライアントはそれを検知します。ServicePackをダウンロードしてクライアントをアップデートする必要はありません。

説明については、Workgroup PDMオンライン ヘルプ（Workgroup PDM online help）のクライアントのアップデート（Update Clients）を参照してください。

親トピック: 新しいリリースへのアップグレード（Upgrading to a New Release）
親トピック: Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）


アップグレードの注意点（Upgrade Caveats）

メジャー バージョンが異なる複数のインストレーションが許可される製品の場合は、メジャー アップグレードがサポートされない、あるいは次のメジャー バージョンへのアップグレードが一度の作業で可能でない場合があります。

このような場合、SolidWorks Installation Managerは先ず新規バージョンをインストールし、続いて古いバージョンを削除することにより、アップグレードを実行しようします。現時点では、SolidWorks のコア製品はメジャー バージョンのアップグレードをサポートしますが、その他の製品はサポートしません。

この結果、以下のようになります。
  • SolidWorks のコア製品のメジャー バージョン アップグレードを行う場合:
    • 既存のインストレーション場所は変更しません。
    • アップグレード中にエラーが発生したり、キャンセルをした場合、アップグレードをロールバックできます。
  • その他の製品のメジャー バージョン アップグレードを行う場合:
    • 各製品は、先ず新規製品として新しい場所にインストールされ、続いて元のインストレーションが削除されます。
    • 一度アップグレードを開始すると、エラーが発生したり、キャンセルをした場合でも、アップグレードをロールバックすることはできません。
親トピック: 新しいリリースへのアップグレード（Upgrading to a New Release）


製品の共存ルール（Product Coexistence Rules）

製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

ルール | 例
SolidWorksコア製品の複数のメジャー リリース バージョンもServicePackまたはメジャー リリースにかかわらず使用できます（以下に述べる3つの製品は例外となります）。 SolidWorks 2010 SP3.0 と SolidWorks 2011 SP0.0 は1台のコンピュータに共存できます。

しかし、SolidWorks 2011 SP0.0 がインストールされているコンピュータに SolidWorks 2011 SP1.0 をインストールすると、SolidWorks Installation Manager は SP0.0 バージョンを新しい SP1.0 バージョンで置き換えます。

SolidWorks 2011 SP0.0 と 2011 SP1.0 は1台のコンピュータに共存できません。

次の製品は、1台のコンピュータで1つのバージョンのみが許可されます。
  • Workgroup PDM Server
  • SolidNetWork License Manager
 SolidWorks 2011 SP0.0 がインストールされている場合（それ以前の SolidWorks メジャー リリースがコンピュータ上に残っている場合でも）、Workgroup PDM Server は 2011 SP0.0 にアップグレードされます。
SolidWorksに含まれる製品は、各メジャー リリースの1つのバージョンのみが許可されます。 | SolidWorks 2011 SP0.0 を 2010 SP1.0 にアップデートした場合、SolidWorks Explorer 2011 SP0.0 も自動的に 2011 SP1.0 にアップグレードされます。ただし、同じコンピュータ上に SolidWorks Explorer 2010 SP4.0 も共存できます。
親トピック: 個人インストレーションの管理（Administration of Individual Installations）


複数インストレーション（Multiple Installations）

  • 複数クライアントへの展開（Deploying to Multiple Clients）
    アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントにSolidWorks製品をインストールできます。
  • アドミニストレーティブ イメージの使用（Using Administrative Images）
    アドミニストレーティブ イメージは、単一のネットワーク位置からのSolidWorks製品の設定可能なインストレーションを可能にします。
  • コマンドラインによる展開（Command-Line Deployment）
    コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。
  • 複数インストレーションの管理（Administration of Multiple Installations）
    複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。


複数クライアントへの展開（Deploying to Multiple Clients）

アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントにSolidWorks製品をインストールできます。

複数クライアントに展開する手順は、以下のようになります。
  1. アドミニストレーティブ イメージを作成します。
    • SolidWorks Installation Managerを使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SolidWorks Installation Manager）
    • コマンドラインからのアドミニストレーティブ イメージの作成（Creating an Administrative Image from the Command Line）
  2. アドミニストレーティブ イメージをクライアントに展開します。
    • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
    • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
  3. ライセンス管理（licensing）を行います。
    • 個人ライセンスの管理（Administering Individual Licenses）
    • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
親トピック: 複数インストレーション（Multiple Installations）


アドミニストレーティブ イメージの使用（Using Administrative Images）

アドミニストレーティブ イメージは、単一のネットワーク位置からのSolidWorks製品の設定可能なインストレーションを可能にします。

ネットワーク上のクライアント コンピュータを含む任意のコンピュータから、アドミニストレーティブ イメージをインストールできます。
  • アドミニストレーティブ イメージは必ず共有フォルダに保存してください。
  • すべての製品を含むと、アドミニストレーティブ イメージには7GB かそれ以上のディスク容量が必要です。
  • アドミニストレーティブをアップグレードするときに、共有名を更新した場合、クライアントは、次の機会にアプリケーションを開始すると、アップグレードされます。詳細については、アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）を参照してください。
  • クライアント インストレーションに対して別ユーザーとしてインストレーションを実行（Run the installation as a different user）オプションが指定されていない限り、クライアントは各自のコンピュータでアドミン権限を持っていなくてはなりません。
    このオプションは、Windows Vista以降ではサポートされません。

アドミニストレーティブ イメージを作成すれば、アドミニストレーティブ イメージ オプション エディタを用い、そのイメージからインストールするユーザーとグループに対するインストレーション オプション設定を管理することが可能です。詳細は アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor） を参照してください。

  • SolidWorks Installation Managerを使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SolidWorks Installation Manager）
    SolidWorksを複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。
  • アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
    アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。
  • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
    共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。
  • クライアントへのアドミニストレーティブ イメージのアドバタイズ（Advertising an Administrative Image to Clients）
    コマンドを実行し、新しいアドミニストレーティブ イメージ インストレーションをクライアントにアドバタイズすることが可能です。
親トピック: 複数インストレーション（Multiple Installations）


SolidWorks Installation Managerを使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SolidWorks Installation Manager）

SolidWorksを複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

  1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
  2. ようこそ(Welcome) スクリーンで、アドミニストレーティブ イメージ(Administrative image)をクリックします。

    アドミニストレーティブ イメージの作成オプションが表示されます。

    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings）
    デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.）
    現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。参照（Browse）をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
    両方 (32-bit と 64-bit) のアドミニストレーティブ イメージを作成します。（Create both 32-bit and 64-bit administrative images.）
    単一のコンピュータ上で、32 ビットと 64 ビットの両方のアドミニストレーティブ イメージを作成することも、お使いのコンピュータ アーキテクチャに対応したイメージのみを作成することもできます。両方のイメージを作成するには、32 ビットと 64 ビットの両方のインストール メディアに対するアクセスが必要です。

  3. 画面上の指示に従います。
親トピック: アドミニストレーティブ イメージの使用（Using Administrative Images）


アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

アドミニストレーティブ イメージを作成した後で、SolidWorks Installation Managerはオプション エディタを開始するように要求します。オプション エディタは、アドミニストレーティブ イメージ フォルダにあるsldAdminOptionEditor.exeをダブルクリックにより、後から起動することも可能です。

マシンのグループや個々のマシンに異なるインストレーション設定を指定するには、オプション エディタでグループとマシンを追加し、次にそれらのグループとマシンのインストレーション オプションを指定します。

  • グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
    アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。
  • オプション設定の表示と編集（Viewing and Editing Option Settings）
    SolidWorksアドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。
  • 32ビット イメージと64ビット イメージの切り替え（Switching Between 32-Bit and 64-Bit Images）
    アドミニストレーション イメージのインストール ディレクトリに32ビットと64ビットの両方に対するイメージが存在する場合、オプション エディタでは両イメージの処理が可能です。
  • オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
    インストールを開始する電子メールの指示を用いて、オプション エディタから直接インストレーションを展開することが可能です。
  • オプション エディタの終了（Exiting the Option Editor）
    オプション エディタを閉じるには、OKまたは閉じるをクリックします。
  • オプション エディタに対するデスクトップ ショートカットの作製
    特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。
親トピック: アドミニストレーティブ イメージの使用（Using Administrative Images）


グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

例えば、いくつかのマシンではイメージに含まれる使用可能な製品コンポーネントの特定のサブセットを使用するように設定したいが、その一方で別のグループは異なる製品コンポーネントのサブセットを使用する場合もあります。オプション エディタのグループ設定は1つのアドミニストレーティブ イメージを使用しているにもかかわらず、異なるマシンのグループに異なる製品のサブセットをインストールできるようにします。

グループを追加するには:
  1. グローバル設定（Global Settings）を右クリックし、グループ追加（Add Group）をクリックします。
  2. グループ名を入力します。
マシンを追加するには:
  1. 既存のグループまたはグローバル設定（Global Settings）を右クリックし、マシン追加（Add Machine）をクリックします。
    既存のグループを右クリックした場合、マシンはそのグループに追加されます。他の場合、マシンはトップレベルに追加されます。
  2. 次のいずれかを行います。
    • マシン名（Machine Name）で1つ以上のマシン名を入力します。

      複数のマシンが改行、スペース、タブ、カンマ、ピリオド、コロン、あるいはセミコロンによって分けられます。外部ファイルからマシン名のリストをコピー/ペーストすることができます。

      マシンはドメイン名を含むことができません。例えば、pluto.solidworks.comは無効です。

    • 複数のマシン追加（Add Multiple Machines）をクリックして、ネットワークからマシンを選択します。
既存のマシンをグループに移動するには: グループにマシンをドラッグします。
既存のマシンをグループ外に移動するには: グローバル設定（Global Settings）にマシンをドラッグするか、他のグループにドラッグします。
グループ、マシンを削除するには: グループまたはマシンを右クリックし、グループ削除（Delete Group）またはマシン削除（Delete Machine）をクリックします。
グループを削除した場合、グループ内のすべてのマシンは削除されます。
すべてのグループとマシンを削除するには: グローバル設定（Global Settings）を右クリックし、全削除（Delete All）をクリックします。
親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


オプション設定の表示と編集（Viewing and Editing Option Settings）

SolidWorksアドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタを最初に起動すると、オプション設定が読み取り専用モードで表示されます。編集アイコンは押された状態になっていません： .
    グローバル設定（Global Settings）、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定のサマリが表示されます：
    スコープ | 表示されるオプション設定
    グローバル設定 | アドミニストレーティブ イメージに対して指定されたすべてのオプション設定
    グループ | グローバル設定と比較してグループ設定で変更された内容
    マシン | グループ設定と比較してマシン設定で変更された内容
  • オプション設定を変更するには、編集アイコンをクリックします。アイコン表示が押された状態（ [image] ）になり、より詳細なオプション設定の一覧が表示されます。

    グローバル設定（Global Settings）、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定が変更可能です。変更により、グローバル設定やグループ設定から継承された設定とは異なったオプション設定は、ハイライト表示が行われます。

    編集アイコンを再度クリックすると、表示は読み取り専用モードに戻ります。

    変更を行った場合は、オプション エディタの終了時に、それらの保存または破棄が要求されます。

  • グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
    すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。
  • グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
    グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。
親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  1. オプション エディタで、修正するオブジェクト（グローバル設定（Global Settings）、グループ、またはマシン）をクリックします。
  2. 右側の編集アイコン [image] をクリックします。

    編集アイコンが押された状態（ [image] ）になり、より詳細なオプション設定の一覧が表示されます。

  3. 左側で選択されたアイテムに対する右側のオプション設定をクリックすることにより、それらを変更します。

    グローバル設定（Global Settings）やグループ設定をオーバーライドするオプション設定の変更は、ハイライト表示されます。

  4. OKまたは閉じる（Close）をクリックして、変更内容を保存します。

    OK
    変更内容が保存され、オプション エディタが終了します。
    閉じる（Close）
    変更内容を保存するか否かについてユーザーに質問を行い、その対応を受けた後、オプション エディタを終了します。

  • アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）
    オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。
親トピック: オプション設定の表示と編集（Viewing and Editing Option Settings）


アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

シリアル番号（Serial Numbers）

クライアント マシンにインストールされる製品のシリアル番号を入力します。
SolidWorks製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 例えば、 SolidWorks シリアル番号は、個々の SolidWorks Simulation シリアル番号を入力しないで SolidWorks Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。
ライセンス管理をSolidNetWorkライセンスを用いて行っている場合：
  • 最初のシリアル番号フィールドにSolidNetWorkのシリアル番号を入力します。
  • SNLサーバー ポート@サーバー（SNL Server port@server）フィールドにSolidNetWork License Managerのサーバー名とポートをnnnnn@サーバー名の形式で入力します。 複数のエントリはセミコロンにより区切ってください。

SolidNetWorkライセンスに関する詳細は、SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）を参照してください。

クライアント インストレーション オプション（Client Installation Options）

ﾒｼﾞｬｰ ﾊﾞｰｼﾞｮﾝのｸﾗｲｱﾝﾄ ｲﾝｽﾄｰﾙをどの方法で行いますか?
クライアントのインストールでは、インストール済みの古いメジャー バージョンの取り扱い方法を指定できます：
  • 既存のﾒｼﾞｬｰ ﾊﾞｰｼﾞｮﾝ (存在する場合) をｱｯﾌﾟｸﾞﾚｰﾄﾞします。

    インストール済みの古いメジャー バージョンを新しいバージョンのインストールで置き換えるには、このオプションを指定します。

  • 新規ﾒｼﾞｬｰ ﾊﾞｰｼﾞｮﾝを作成します。

    インストール済みの古いメジャー バージョンを保持したまま、新しいメジャー バージョンをインストールするには、このオプションを指定します。

    新しいバージョンのインストール先を指定するには、参照（Browse）をクリックします。

新しいメジャー バージョンをインストールする前に、最も最新の前のバージョンをアンイストールしますか?
インストール済みの古いメジャー バージョンをアンインストールするかどうかを指定できます:
  • いいえ、最初にアンインストールしません:

    古いメジャー バージョンを保持する場合に選択します。

  • はい、カスタム アンインストールを実行します:
    次のアイテムを削除する場合に選択します:
    • プログラム ファイルとフォルダ
    • レジストリ エントリ
    • データ ファイルとフォルダ
SolidWorks 設定をどのように適用しますか?
クライアントのインストールでは、SolidWorksの設定をクライアント マシンのSolidWorks設定と設定のコピーウィザードからエクスポートされたSolidWorks設定のどちらに基づいて行うかを指定できます。
  • 現在の設定（存在する場合は）を使用するか、SolidWorks 2011 デフォルト設定を使用します（Use current settings （if they exist） or use SolidWorks default settings）

    クライアント マシンに定義済みのSolidWorks設定が存在する場合は、それらを維持します。 （クライアントで特に定義されていない設定に対しては、デフォルトのSolidWorks設定が使用されます。）

  • 設定のｺﾋﾟｰ ｳｨｻﾞｰﾄﾞで出力した設定ﾌｧｲﾙを使用します。
    本オプションを選択すると、設定のコピー ウィザードの既存ファイルを用いてオプションを設定できます。 （一般的に、ファイル名は solidworkssettings.sldreg です。）
    • 参照（Browse）をクリックし、既存の設定ファイルを見つけます。
    • 新規（New）をクリックし、 設定のコピー ウィザードを開始し、新しい設定ファイルを作成します。
ｸﾗｲｱﾝﾄ ｲﾝｽﾄﾚｰｼｮﾝはどの方法でｱｸﾃｨﾌﾞ化しますか?
ライセンスのアクティブ化は、インストール後に自動で完了するか、あるいはユーザーが手動で行うかを選択することが可能です。
  • 各ｸﾗｲｱﾝﾄ ｲﾝｽﾄﾚｰｼｮﾝが完了した時点で自動的にｱｸﾃｨﾍﾞｰｼｮﾝを行います。
    オプションを選択すると、アクティベーションは SolidWorks 製品アクティベーション ファイルを使用して自動的に実行されます。 （一般的に、ファイル名は AutoActivation.xml です。）
    • 参照（Browse）をクリックし、既存のアクティベーション ファイルを見つけます。
    • 新規（New）をクリックし、SolidWorks 製品アクティベーションを開始し、新しいアクティベーション ファイルを作成します。
  • 自動的にｱｸﾃｨﾌﾞ化しません。

    オプションを選択すると、製品は自動的にアクティブ化されません。 クライアントは、インストレーション後に製品をアクティブ化します。

自動的な製品のアクティブ化を指定した場合、インストレーション後にクライアントが初めて SolidWorks を実行する際、共有ネットワーク上にアドミニストレーティブ イメージが準備されている必要があります。 アドミニストレーティブ イメージからインストールしたクライアントがアドミニストレーティブ イメージにアクセスできない場合、クライアントは自動的に製品をアクティブ化することができません。 SolidWorks 製品をマニュアルでアクティブ化しない限り、SolidWorks を実行することができません。

アドミニストレーティブ オプション（Administrative Options）

各インストレーションに対して診断ログ ファイルを作成します
クライアントのインストールでは、インストール時に発生した問題のトラブルシューティングに利用可能な診断ログを作成できます。 このログを作成すると、クライアントのインストール速度が遅くなります。
別ﾕｰｻﾞｰとしてｲﾝｽﾄﾚｰｼｮﾝを実行。
クライアントのインストールは異なるユーザーで実行できます。 本オプションは、個別のユーザーが使用中のマシンでSolidWorks製品のインストールに必要なローカル管理権限を持っていない場合に有効であるかもしれません。
このオプションは、Windows Vista、Windows 7、およびそれ以降ではサポートされません。
インストレーションの前後に実行するプログラム
クライアントのインストール前後におけるユーザー定義プログラムの実行を指定できます。
ｸﾗｲｱﾝﾄはﾕｰｻﾞｰ ﾊﾟﾌｫｰﾏﾝｽ ﾌｨｰﾄﾞﾊﾞｯｸ ﾌﾟﾛｸﾞﾗﾑに参加しますか?
クライアント マシンのSolidWorks ユーザー パフォーマンス フィードバック プログラムへの参加を指定できます。 パフォーマンス インフォメーションが、製品改善の手助けの為に SolidWorks Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 詳細は Customer Experience Improvement Program Web サイト を参照してください。

インストールするソフトウェア

インストールするSolidWorks製品は指定することが可能です。
  • クライアントのインストール中にインストールされる製品コンポーネントを指定するには、コンポーネントの隣にあるチェックボックスを選択します。
  • チェックボックスの選択を解除すると、そのコンポーネントはインストールされません。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
言語（Languages）はインストールされる言語を SolidWorks 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 例えば、SolidWorks eDrawings(R)、SolidWorks Workgroup PDM、SolidWorks Explorer ではすべての言語版がインストールされます。

Toolbox オプション

クライアントのインストールに対しては、サポートする規格とデフォルトの Toolbox の場所を指定することが可能です。

Toolboxへのアクセスはネットワーク上のフォルダを、UNCパス、共有フォルダ、共通のネットワーク ドライブ指定等を用い、複数のユーザーで共有することが一般的です。

該当する場所に古いメジャー バージョンのToolboxが存在する場合は、クライアントのインストール時に新しいメジャー バージョンのToolboxにアップグレードされます。 このファイルは、古いメジャー バージョンのSolidWorksとの互換性を持ちません。
一部のユーザーが古いバージョンのSolidWorksを継続使用する場合等、そのバージョン用のToolboxを保持したい場合には、新しいバージョンにアップグレードするためのToolbox用に異なるネットワーク ロケーションを指定する必要があります。

SolidWorks Toolboxの管理に関する詳細は、SolidWorksヘルプのToolbox情報を参照してください。

親トピック: グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）


グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

例：
  • グローバル設定（Global Settings）に定義された設定は、すべてのグループとマシンに継承されます。
  • グループのために定義された設定は、そのグループの中ですべてのマシンに継承されます。

マシン、またはグループのオプション設定で、デフォルトを上書きするか、設定を継承するかを変更することができます。オプション設定をデフォルト、またはその継承された値から変えるとき、そのオプションはハイライトされます。

オプション設定を元の継承された値に戻すには、グループまたはマシンを右クリックしてからグローバル設定に戻す（Revert to Global Settings）（グループ メンバーではないグループまたはマシンの場合）、あるいはグループ設定に戻す（Revert to Group Settings）（グループ メンバーであるマシンの場合）をクリックします。
親トピック: オプション設定の表示と編集（Viewing and Editing Option Settings）


32ビット イメージと64ビット イメージの切り替え（Switching Between 32-Bit and 64-Bit Images）

アドミニストレーション イメージのインストール ディレクトリに32ビットと64ビットの両方に対するイメージが存在する場合、オプション エディタでは両イメージの処理が可能です。

  • オプション エディタにおいて32または64をクリックすることにより、処理対象となる32ビットまたは64ビットのイメージを選択します。

    セットアップ（Setup）または 展開（Deploy）をクリックすることにより、該当イメージに対する オプション設定の表示や変更、あるいはインストールの展開が行えます。

32ビットと64ビットの両方に対するイメージが存在する場合は、グローバル設定、グループ定義とグループ設定、および個々のマシン設定をそれぞれのイメージに対して行う必要があります。
親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

インストールを開始する電子メールの指示を用いて、オプション エディタから直接インストレーションを展開することが可能です。

アドミニストレーティブ イメージのインストール ディレクトリをWindowsの共有ディレクトリに変更し、\\マシン\共有ディレクトリのように、ネットワークを通して利用可能にする必要があります。

  1. オプション エディタで展開（Deploy）をクリックします。
  2. このアドミニストレーティブ イメージのインストール ディレクトリに32ビットのイメージと64ビットのイメージが存在する場合には、32または64をクリックし、それらに対応するマシンを確認します。

    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。

  3. メール送信（Send Email）をクリックします。
  4. アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク パスを指定します。

    一般的にアドミニストレーティブ イメージのインストール ディレクトリに対するディレクトリ パスは、初期状態において、C:\SolidWorks Admin\SolidWorks 2011 SP0のようなWindowsのファイル パスで表示されます。ダイアログボックスにはこのパスはネットワーク パスではありません（This path is not a network path）と表示されます。

    1. 参照（Browse）をクリックし、このアドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーションを指定してください。
    2. アドミニストレーティブ イメージがインストールされたコンピュータを探し、アドミニストレーティブ イメージに対するWindowsの共有ディレクトリを選択します。

      アドミニストレーティブ イメージの共有ディレクトリの内部（32bitや64bitのサブディレクトリ等）を選択してはいけません。

    3. OK をクリックします。

      ダイアログボックスにはこのパスはネットワーク パスです（This path is a network path）と表示されます。

    電子メールが作成されます。このメールは、アドミニストレーティブ イメージ内のStartSWInstall.htaファイルに対するネットワーク ロケーションを用いてアドミニストレーティブ イメージからのインストールを実施する方法を該当するマシンのユーザーに伝えるものです。

  5. SolidWorksのインストール権限を持つユーザーに電子メールを送信してください。

ユーザーは電子メールに記述されたStartSWInstall.htaに対するネットワーク ロケーションのリンクをダブルクリックすることで、アドミニストレーティブ イメージからのSolidWorksインストールを実施できます。

オプション エディタには次のようなインストレーション ステータス（Installation Status）が表示されます：
保留中（Pending）
ユーザーによる該当マシンへのインストールは未だ実施されていません。
成功（Successful）
ユーザーによる該当マシンへのインストールは無事完了しています。
失敗（Failed）
ユーザーによる該当マシンへのインストールが実施されましたが、失敗しました。
  • アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）
    アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。
親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）

アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。

たとえば、アドミニストレーティブ イメージの共有ディレクトリにU:ドライブを割り当てた場合は、電子メールによりfile://U:\StartSWIOnstall.htaのクリックがユーザーに対して指示されます。電子メールを受け取ったユーザーは、U:ドライブがアドミニストレーティブ イメージに対するUNCロケーション（\\マシン名\共有名）に割り当てられていれば、問題なくインストールすることが可能です。

親トピック: オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


オプション エディタの終了（Exiting the Option Editor）

オプション エディタを閉じるには、OKまたは閉じるをクリックします。

  • 変更内容を適用し、オプション エディタを閉じるにはOK、閉じる（Close）、あるいはWindowsアプリケーションの閉じるボタンをクリックします。
    • OKをクリックすると、オプション設定の変更内容が適用され、オプション エディタが終了します。
    • 閉じる（Close）をクリックすると、オプション エディタが終了します。

      適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。

    • Windowsアプリケーションの閉じるボタン（X）をクリックします。適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。
親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


オプション エディタに対するデスクトップ ショートカットの作製

特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

  1. オプション エディタを起動します。

    たとえばWindowsエクスプローラにおいて、アドミニストレーティブ イメージのインストール ディレクトリに移動し、sldAdminOptionEditor.exeをダブルクリックします。

  2. デスクトップにこのオプション エディタへのショートカットを作成（Create Desktop Shortcut to this Option Editor）をクリックします。

    該当するアドミニストレーティブ イメージに対するオプション エディタへのショートカットが、Windowsデスクトップに作成されます。

親トピック: アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

アドミニストレーティブ イメージ ディレクトリは、他のコンピュータからアクセス可能なマシン（例えば、UNCパス経由）で共有されるように設定します。

すべてのクライアントにadmin_image_install_dir\StartSWInstall.htaへのリンクを含む電子メールを送信できます。 その後、クライアントはこのリンクをクリックし、続いてInstall SolidWorks products now（Install SolidWorks products now）をクリックし、アドミニストレーティブ イメージからのインストレーションを開始します。

新しいSolidWorksバージョンのアドミニストレーティブ イメージをアップグレードしている場合は、そのイメージを使用して前にインストールしたクライアントが自動的にアップグレードされるように、アドミニストレーティブ イメージの場所と共有プロパティを設定できます。 詳細は アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images） を参照してください。
親トピック: アドミニストレーティブ イメージの使用（Using Administrative Images）


クライアントへのアドミニストレーティブ イメージのアドバタイズ（Advertising an Administrative Image to Clients）

コマンドを実行し、新しいアドミニストレーティブ イメージ インストレーションをクライアントにアドバタイズすることが可能です。

電子メールによる展開は、クライアントに新しいSolidWorksインストレーションを知らせる際の一般的な方法です。詳細は 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email） を参照してください。

しかし、代わりにコマンドを実行して新しいインストレーションをクライアントへアドバタイズすることもできます。例えば、普段はSolidWorksアプリケーションを使用しない従業員へアドバタイズすることもできます。

SolidWorksをアドバタイズすると、ユーザーのコンピュータのスタート（Start）メニューにSolidWorksアプリケーションへのショートカットが追加され、サーバー上にアドミニストレーティブ イメージと関連するファイルが作成されます。最初の段階では、実行形式ファイルはインストールされません。インストレーションは、ユーザーがアプリケーションを初めて必要とした場合に実行されます。

ユーザーがショートカット、またはSolidWorksのドキュメントをダブルクリックすると、インストレーションが開始され、SolidWorksが実行されます。

アドミニストレーティブ イメージからアドバタイズするには、以下を行います。

  1. アドミニストレーティブ イメージを作成して設定します。
  2. SolidWorksアプリケーションをインストールする各マシンに対して製品をアドバタイズします。

    例：

    msiexec /jm path_to_msi_file_of_admin_image

    ここで、path_to_msi_file_of_admin_imageは、アドミニストレーティブ イメージ ディレクトリへのUNCパスです。

親トピック: アドミニストレーティブ イメージの使用（Using Administrative Images）


コマンドラインによる展開（Command-Line Deployment）

コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

  • コマンドラインからのアドミニストレーティブ イメージの作成（Creating an Administrative Image from the Command Line）
    アドミニストレーティブ イメージは、SolidWorks Installation ManagerまたはMS-DOSコマンドラインを使用して作成できます。
  • アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
    アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。
  • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
    コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。
  • コマンドライン プロパティ（Command-Line Properties）
    ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。
  • Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
    Microsoft Active Directoryによる展開では、SolidWorksコア製品のクライアントへの展開もサポートされます。
親トピック: 複数インストレーション（Multiple Installations）


コマンドラインからのアドミニストレーティブ イメージの作成（Creating an Administrative Image from the Command Line）

アドミニストレーティブ イメージは、SolidWorks Installation ManagerまたはMS-DOSコマンドラインを使用して作成できます。

コマンドラインでアドミニストレーティブ イメージを作成した場合は、各SolidWorks製品毎にそのコンポーネントの.msiファイルを実行してイメージを作成し、展開する必要があります。英語以外の言語を指定してインストールするには、その言語の.msiファイルを実行して、各言語毎にイメージを作成し、展開する必要があります。.msiファイルの位置の詳細については、アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）を参照してください。
  1. コマンド プロンプト ウィンドウを開きます。
    1. Windowsでスタート > ファイル名を指定して実行をクリックします。
    2. cmdと入力し、OKをクリックします。
  2. 次のコマンドを入力します。

    msiexec /a Msi_パス

    ここで、Msi_パスは、使用するオペレーティング システムの.msiファイルのパスとファイル名になります。SolidWorks.msiは、インストール ディレクトリのswwi\dataサブディレクトリにあります。

    例:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. SolidWorks設定ウィザードでは、画面の指示に従います。
  4. 英語以外の言語向けにSolidWorks製品をインストールする際には、次のコマンドを使って言語毎のアドミニストレーティブ イメージを作成します：

    msiexec /a 言語の_Msi_パス

    ここで、言語の_Msi_パスは、使用する言語の.msiファイルのパスとファイル名になります。たとえば、french.msiは、インストール ディレクトリのswwi\lang\frenchサブディレクトリにあります。

    例:

    msiexec /a F:\swwi\lang\french\french.msi

親トピック: コマンドラインによる展開（Command-Line Deployment）


アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

これらのWindowsコンポーネントのマニュアル インストールは、コマンドラインの使用またはMicrosoft Active Directoryによってマニュアルで作成したアドミニストレーティブ イメージからのインストールする場合のみに必要となります。SolidWorks Installation Managerでアドミニストレーティブ イメージを作成してインストールする場合、これらのWindowsコンポーネントは自動的にインストールされます。
以下は、Windowsコンポーネント内のSolidWorksの必要とするファイルをまとめたものです。
Windows Installer
SolidWorks Simulation Premiumのインストレーションを実行するのに必要なファイルを含みます。
Office Webコンポーネント
DriveWorksに必要なCOMコントロールを含みます。
Visual C++ 2005と2008再頒布可能パッケージ
Microsoft Visual C++の実行に必要なランタイム コンポーネントを含みます。
2005と2008バージョンの両方がインストールされている必要があります。
Visual Studio Tools for Applications
Visual Studioアプリケーションをサポートするツール セットを含みます。
Visual Studioリモート デバッガ
64-ビット オペレーティング システムのデバッグ環境を提供します。
.NET Framework
.NET Frameworkアプリケーションの実行に必要な共通語のランタイムと.NET Frameworkコンポーネントを含みます。
Windowsデスクトップ サーチ（オプション）
異なるデータ ソースと場所（ローカル コンピュータと共有ネットワークを含む）におけるファイルとデータの素早い検索をサポートします。
Windowsデスクトップ サーチ ファイルは、言語固有のものです。詳細は Windowsデスクトップ サーチの言語版サポート（Windows Desktop Search Language Support） を参照してください。
Visual C++再頒布可能パッケージと.NET Framework 3.5は、コアSolidWorks製品だけではなく、すべてのSolidWorks製品に必要です。

これらのコンポーネントはアドミニストレーティブ イメージのサブディレクトリに含める必要があります。

以下のテーブルには、サポートされる各オペレーティング システムで必要となる特定のファイルが示されています。
オペレーティング システム: Windows 2003 32-bit1
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | （適用不可）
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）:
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lang.exe
オペレーティング システム: Windows 2003 64-bit1
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の64-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）:
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
オペレーティング システム: Windows 2008 32-bit1
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | （適用不可）
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）: |  | Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
オペレーティング システム: Windows 2008 64-bit1
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の64-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）: |  | Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
オペレーティング システム: Windows XP 32-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | （適用不可）
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）:
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lang.exe
オペレーティング システム: Windows XP 64-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）:
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
オペレーティング システム: Windows XP 64-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の64-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）:
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
オペレーティング システム: Windows Vista 32-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | （適用不可）
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）: |  | Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
オペレーティング システム: Windows Vista 64-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の64-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windowsデスクトップ サーチ（オプション）: |  | Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
オペレーティング システム: Windows 7 32-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の32-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | （適用不可）
 | .NET Framework: |  | .NET Framework と Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
 | Windowsデスクトップ サーチ（オプション）:
オペレーティング システム: Windows 7 64-bit
SolidWorksメディア: Windows XP、Windows Vista、Windows 7の64-bitバージョン
 | Windows Installer: |  | （適用不可）
 | Office Web コンポーネント: |  | owc11.exe
 | Visual C++ 2005再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual C++ 2008再頒布可能パッケージ: |  | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studioリモート デバッガ: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework と Windows デスクトップ サーチはオペレーティング システムに含まれる機能です。
 | Windowsデスクトップ サーチ（オプション）:
1Windows 2003またはWindows 2008上のインストレーションはWorkgroup PDM ServerとSolidNetWork License (SNL) Serverのみでサポートされています。
  • 32-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 32-bit Operating Systems）
    次の手順に従い、32-bitバージョンのWindowsでコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのためにWindows前提条件をインストールします。
  • 64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）
    次の手順に従い、64-bitバージョンのWindowsでコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのためにWindows前提条件をインストールします。
  • SolidWorks検索とMicrosoft Windowsデスクトップ サーチ（SolidWorks Search and Microsoft Windows Desktop Search）
    SolidWorks検索はMicrosoft® Windows®デスクトップ サーチと統合されています。
親トピック: コマンドラインによる展開（Command-Line Deployment）


32-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 32-bit Operating Systems）

次の手順に従い、32-bitバージョンのWindowsでコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのためにWindows前提条件をインストールします。

1回のインストール作業で複数のコンポーネントをインストールするには、次の手順にあるコマンドでバッチ ファイルを作成し、コンポーネントをクライアント コンピュータにインストールします。

  1. ターゲットのコンピュータに最低290 MBの空き容量と、有効なTEMPディレクトリがあることを確認します。
  2. 次のコマンドを実行し、Office Webコンポーネントをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\OfficeWeb_11\owc11.exe

  3. Windows XPの場合、Windows Installerをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Windows XP以外のバージョンのWindowsには、Windows installerをインストールする必要はありません。

  4. Visual C++ 2005再頒布可能パッケージをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Visual C++ 2008再頒布可能パッケージをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Windows XPおよびWindows Vistaの場合、Windows Server Update Servicesを使用してMicrosoft .NET Framework 3.5をインストールします。

    Windows 7以降の場合.NET Frameworkイメージをインストールする必要はありません。

  7. Visual Studio Tools for Applicationsをインストールします：

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_VSTA\vsta_aide.msi

親トピック: アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

次の手順に従い、64-bitバージョンのWindowsでコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのためにWindows前提条件をインストールします。

1回のインストール作業で複数のコンポーネントをインストールするには、次の手順にあるコマンドでバッチ ファイルを作成し、コンポーネントをクライアント コンピュータにインストールします。

  1. ターゲットのコンピュータに最低620 MBの空き容量と、有効なTEMPディレクトリがあることを確認します。
  2. 次のコマンドを実行し、Office Webコンポーネントをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\OfficeWeb_11\owc11.exe

  3. Visual C++ 2005再頒布可能パッケージをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    32-bitバージョンと64-bitバージョンの両方をインストールする必要があります。

  4. Visual C++ 2008再頒布可能パッケージをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    32-bitバージョンと64-bitバージョンの両方をインストールする必要があります。

  5. Windows XPおよびWindows Vistaの場合、Windows Server Update Servicesを使用してMicrosoft .NET Framework 3.5をインストールします。

    Windows 7以降の場合.NET Frameworkイメージをインストールする必要はありません。

  6. Visual Studio Tools for Applicationsをインストールします：

    アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_VSTA\vsta_aide.msi

  7. Visual Studioリモート デバッガをインストールします。

    アドミニストレーティブ_イメージ_ディレクトリ\VSRemoteDebugger\install.exe /Q

親トピック: アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


SolidWorks検索とMicrosoft Windowsデスクトップ サーチ（SolidWorks Search and Microsoft Windows Desktop Search）

SolidWorks検索はMicrosoft® Windows®デスクトップ サーチと統合されています。

正しいバージョンのWindowsデスクトップ サーチがコンピュータにインストールされていない場合、そのインストールまたはアップグレードがSolidWorksインストレーション中に求められます。

アドミニストレーティブ イメージを作成している場合、そのディレクトリにはWindowsデスクトップ サーチは含まれません。アドミニストレーティブ イメージからSolidWorksをインストールしたクライアント コンピュータでSolidWorks検索を使用する場合には、Microsoft Windowsデスクトップ サーチを手動でインストールする必要があります。

親トピック: アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

サイレント インストールを行うには:
  1. コマンド プロンプト ウィンドウを開きます（Windowsでスタート > ファイル名を指定して実行をクリックします）。
  2. msiexec.exeコマンドを/iと/qbオプションを使用して入力し、デフォルト値とは異なる値を指定する任意のオプションのプロパティを設定します。
インストール コンポーネントのコマンドライン プロパティには次が含まれます：
  • コマンドラインの機能プロパティ（Command-Line Feature Properties）
  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）
  • SolidWorks eDrawingsコマンドライン プロパティ（SolidWorks eDrawings Command Line Properties）
  • SolidWorks Explorer/Workgroup PDMコマンドライン プロパティ（SolidWorks Explorer/Workgroup PDM Command-Line Properties）
  • SolidWorks Flow Simulationコマンドライン プロパティ（SolidWorks Flow Simulation Command Line Properties）
次の例をサイレント インストレーションのテンプレートとして使用してください。
SolidWorks クライアント
  • SolidWorks コア (英語)
  • Toolboxアドイン
  • フィードバック プログラムに参加
  • フランス語

32-bitバージョンのSolidWorksを32-bitオペレーティング システムにインストールする場合:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

32-bitバージョンのSolidWorksを64-bitオペレーティング システムにインストールする場合:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

64-bitバージョンのSolidWorksを64-bitオペレーティング システムにインストールする場合:

msiexec /i "64-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

SolidWorksフランス語インストール コンポーネントは個別にインストールする必要があります:
  • 32-bitバージョン：

    msiexec /i "32-bit_admin_image_path\SolidWorks French\french.msi" /qb

  • 64-bit 版：

    msiexec /i "64-bit_admin_image_path\SolidWorks French\french.msi" /qb

SolidWorks言語コンポーネントのインストールコマンドを指定する際には、コマンドライン引数を指定しないでください。
eDrawings クライアント
  • ログ パフォーマンス
  • すべての機能

msiexec /i "admin_image_path\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks ExplorerとWorkgroup PDMアドイン
  • SolidWorks ExplorerとWorkgroup PDMアドイン

msiexec /i "admin_image_path\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\your_folder" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
親トピック: コマンドラインによる展開（Command-Line Deployment）


コマンドライン プロパティ（Command-Line Properties）

ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

  • コマンドラインの機能プロパティ（Command-Line Feature Properties）
    SolidWorksのインストレーションでは、コマンドラインによる展開のADDLOCALプロパティをサポートしています。
  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）
    各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。
  • SolidWorks eDrawingsコマンドライン プロパティ（SolidWorks eDrawings Command Line Properties）
    これらのコマンドライン プロパティはeDrawings特有のものです。
  • SolidWorks Explorer/Workgroup PDMコマンドライン プロパティ（SolidWorks Explorer/Workgroup PDM Command-Line Properties）
    これらのコマンドライン プロパティはSolidWorks ExplorerとSolidWorks Workgroup PDM特有のものです。
  • SolidWorks Flow Simulationコマンドライン プロパティ（SolidWorks Flow Simulation Command Line Properties）
    これらのコマンドライン プロパティはSolidWorks Flow Simulation特有のものです。
  • アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）
    コマンドラインからアドミニストレーティブ イメージを作成する際、product .msiファイルはSolidWorksメディアの次の場所に保存されています。
  • Windowsデスクトップ サーチの言語版サポート（Windows Desktop Search Language Support）
    Windowsデスクトップ サーチ ファイル名にはプラットフォームと言語情報が含まれています。
親トピック: コマンドラインによる展開（Command-Line Deployment）


コマンドラインの機能プロパティ（Command-Line Feature Properties）

SolidWorksのインストレーションでは、コマンドラインによる展開のADDLOCALプロパティをサポートしています。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 （32-bit SolidWorks を 32-bit オペレーティング システムにインストール）
  • Intel_Modules_AgeiaX64 （32-bit SolidWorks を 64-bit オペレーティング システムにインストール）
  • マニュアル
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
コマンドライン インストールのプロパティを指定する際の注意：
  • SolidWorksはADDSOURCEオプションを使用したインストレーションはサポートしません。
  • プロパティでは、大文字と小文字が識別されます。 またコマンドラインには、スペースやダッシュを含むことはできず、コンマで区切る必要があります。
  • SolidWorks アプリケーションを正確にインストールするには、SolidWorks を指定する必要があります。
親トピック: コマンドライン プロパティ（Command-Line Properties）


コマンドラインのグローバル プロパティ（Command-Line Global Properties）

各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

プロパティ | 説明
ENABLEPERFORMANCE SolidWorks 社に自動的にパフォーマンス データを送信するかどうかを指定します。

パフォーマンス データを送信する場合は 1 、送信しない場合は 0 を指定します。
INSTALLDIR SolidWorks インストレーション フォルダーです。

個人インストレーションのみ。
INSTALLWDS Microsoft Windows テスクトップ サーチ エンジンを使用する SolidWorks 拡張子をインストールします。詳細については、アドミニストレーティブ イメージ インストレーションのためのクライアント準備（Preparing Clients for Installation from an Administrative Image）を参照してください。

拡張子をインストールするには 1 を、インストールしない場合は 0 を指定します。
MOTIONSERIALNUMBER | SolidWorks Motion製品のシリアル番号です。
OFFICEOPTION インストールする製品パッケージを指定します:
0
SolidWorks クライアント
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL 現在インストールされている機能すべてを更新するには、ALL を指定します。
このプロパティは、同一メジャーリリース内のサービスパック リリースへの更新 (たとえば、既存の SolidWorks 2011 SP01 から SolidWorks 2011 SP02 への更新) にのみ指定してください。
REINSTALLMODE Microsoft Installerの再インストール オプションです。

たとえば、あるサービスパック リリースから別のサービス パックへ、同じメジャーリリース内でアップグレードする場合にはREINSTALLMODE=vomusを指定します。

REINSTALLMODE の設定についての詳細は、www.microsoft.comにあるWindows Installerの関連ドキュメントをご覧ください。

このプロパティは、同一メジャーリリース内のサービスパック リリースへの更新 (たとえば、既存の SolidWorks 2011 SP01 から SolidWorks 2011 SP02 への更新) にのみ指定してください。このプロパティは、SolidWorksの新しいメジャーリリースを最初にインストールする際には指定しないでください。
SERVERLIST SolidNetWorkサーバー リストです。
SolidNetWork サーバー リストは、セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します：

xxxxx@サーバー_名1;yyyyy@サーバー_名2;&

ここで、xとyは1桁の数字です。リスト内の最後のサーバーの後にはセミコロンを追加しないでください。

個人インストレーションのみ。
SIMULATIONSERIALNUMBER | SolidWorks Simulation製品のシリアル番号です。
SOLIDWORKSSERIALNUMBER | SolidWorks製品のシリアル番号です（すべてのアドインが含まれます）。
SWMIGRATE アップグレードするSolidWorksのバージョンを指定します。このリストは SolidWorksインストレーションの選択 ダイアログ ボックスに表示されます。例:

SWMIGRATE="SolidWorks 2011 SP01"

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。このプロパティは、同じメジャー リリース内で1つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
TARGETDIR SolidWorks インストレーション フォルダーです。

アドミニストレーティブ インストレーションのみ。
TOOLBOXFOLDER SolidWorks Toolboxファイルのインストレーション フォルダーです。

個人インストレーションのみ。
TRANSFORMS 次の形式で言語固有のアイテムを含めます。
TRANSFORMS number.mst
  • 中国語（台湾）（1028）
  • 中国語（中国）（2052）
  • チェコ語（1029）
  • 英語（1033）
  • フランス語（1036）
  • ドイツ語（1031）
  • イタリア語（1040）
  • 日本語（1041）
  • 韓国語（1042）
  • ポーランド語（1045）
  • ポルトガル語（ブラジル）（1046）
  • ロシア語（1049）
  • スペイン語（1034）
  • トルコ語（1055）
UPGRADESWINSTALL
既存の SolidWorks のバージョンを現在のバージョンにアップグレードするかどうかを指定します。
0
新規インストレーション、アップデートなし
1
アップデート

個人インストレーションのみ。

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。このプロパティは、同じメジャー リリース内で1つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
親トピック: コマンドライン プロパティ（Command-Line Properties）


SolidWorks eDrawingsコマンドライン プロパティ（SolidWorks eDrawings Command Line Properties）

これらのコマンドライン プロパティはeDrawings特有のものです。

プロパティ | 説明
ADDLOCAL インストールするSolidWorks eDrawingsのアプリケーション機能を指定します。

All が推奨オプションです。
コマンドライン構文 | 機能
All | 全機能をインストールします。 eDrawings はインストール済みの SolidWorks と AutoCAD の Publisher を検索し、インストールを有効にします。
eDrawingsViewer | eDrawings やその他のファイルを表示します。
PublisherForAutoCADR14 | AutoCAD R14 アプリケーションで eDrawings ファイルを作成します。
PublisherForAutoCAD2000 | AutoCAD 2000 アプリケーションで eDrawings ファイルを作成します。
PublisherForAutoCAD2004 | AutoCAD 2004 アプリケーションで eDrawings ファイルを作成します。
PublisherForAutoCAD2005 | AutoCAD 2005 アプリケーションで eDrawings ファイルを作成します。
PublisherForAutoCAD2006 | AutoCAD 2006 アプリケーションで eDrawings ファイルを作成します。
DXFDWGTranslator | eDrawings Viewer で DXF/DWG ファイルを表示します。
Shortcuts | デスクトップ ショートカットをインストールします。
XML3D | eDrawings Viewer で 3DXML ファイルを表示します。
INSTALLDIR | SolidWorks eDrawings のためのインストレーション フォルダを指定します。
LOGPERFORMANCE SolidWorks 社に自動的にパフォーマンス データを送信するかどうかを指定します。
1
パフォーマンス データを送信する
0
送信しない
SNLSERVER SolidNetWorkライセンス サーバーのポート@サーバー名を入力します。 複数のポート@サーバー名の組み合わせはセミコロンで区切ります。

ポート サーバー名SNLSERVERは、SolidWorks SNLサーバーコンフィギュレーションでのみ必要です。ポート_の_リスト@サーバー_ストリングは、セミコロンで区切られたストリングのリストで、各ストリングは、次のフォーマットのサーバー上のポート番号を示しています。

xxxxx@サーバー_名1; yyyyy@サーバー_名2;

ここで、xとyは1桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック: コマンドライン プロパティ（Command-Line Properties）


SolidWorks Explorer/Workgroup PDMコマンドライン プロパティ（SolidWorks Explorer/Workgroup PDM Command-Line Properties）

これらのコマンドライン プロパティはSolidWorks ExplorerとSolidWorks Workgroup PDM特有のものです。

SolidWorks Explorer/Workgroup PDMクライアントの場合:
クライアント プロパティ | 説明
EXPLORERORPDM
0
SolidWorks Explorer のみ
1
Workgroup PDM機能インストール可能
ADDLOCAL
  • Standalone
  • Client
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone は Contributor で、Client は SolidWorks Explorer サイレント インストレーションの SolidWorks アドインです。

AutoCADを指定する場合、システムにAutoCADをインストールしておく必要があります。Workgroup PDM は、適切なAutoCADのバージョンを検知します。複数の AutoCAD バージョンを指定できます:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64とDocMgr64は64-bitのSolidWorks Explorerインストレーションのみで使用できます。
INSTALLDIR | Workgroup PDMのインストレーション フォルダーを指定します。
ACTIVSERIALNUMBER | Solidworksシリアル番号を指定します。
Workgroup PDMサーバーの場合:
サーバー プロパティ | 説明
ADDLOCAL
  • Vault
  • WebPortal
  • API

WebPortal（Viewer）を指定した場合は VAULTNAME も指定する必要があります。
INSTALLDIR | Workgroup PDMのインストレーション フォルダーを指定します。
LICENSE_SERVER | ライセンス サーバーが保存されているコンピュータ名を指定します。
VAULTDATA  | ボルトのフォルダー名とパス名を指定します。
VAULTNAME | ボルトが保存されているコンピュータ名を指定します。
親トピック: コマンドライン プロパティ（Command-Line Properties）


SolidWorks Flow Simulationコマンドライン プロパティ（SolidWorks Flow Simulation Command Line Properties）

これらのコマンドライン プロパティはSolidWorks Flow Simulation特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER SolidWorks Flow Simulationスタンドアロン シリアル番号です。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

CWUPGRADEINSTALL 特定のSolidWorks Flow Simulationアプリケーション ソフトウェアの既存バージョンをアップグレードします。
1
アップデート
2
新規インストレーション、新規ディレクトリにインストール

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

INSTALLDIR 特定のSolidWorks Flow Simulationアプリケーション ソフトウェアのインストレーションを指定します。

（個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;&ここで、xとyは1桁の数字です。リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
SOLIDWORKSPATH SolidWorksソフトウェアのインストール フォルダーを指定します。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

TARGETDIR 特定のSolidWorks Flow Simulationアプリケーション ソフトウェアのインストレーションを指定します。

（アドミニストレーティブ イメージ インストレーションのみ）。
親トピック: コマンドライン プロパティ（Command-Line Properties）


アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

コマンドラインからアドミニストレーティブ イメージを作成する際、product .msiファイルはSolidWorksメディアの次の場所に保存されています。

製品 | メディアの場所
SolidWorks（コア製品、英語版） | swwi\data\SolidWorks.msi
SolidWorks（英語以外の言語コンポーネント） | 中国語（台湾） | swwi\lang\chinese\chinese.msi
 | 中国語（中国） | swwi\lang\chinese-simplified\chinese-simplified.msi
 | チェコ語 | swwi\lang\czech\czech.msi
 | フランス語 | swwi\lang\french\french.msi
 | ドイツ語 | swwi\lang\german\german.msi
 | イタリア語 | swwi\lang\italian\italian.msi
 | 日本語 | swwi\lang\japanese\japanese.msi
 | 韓国語 | swwi\lang\korean\korean.msi
 | ポーランド語 | swwi\lang\polish\polish.msi
 | ポルトガル語(ブラジル) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | ロシア語 | swwi\lang\russian\russian.msi
 | スペイン語 | swwi\lang\spanish\spanish.msi
 | トルコ語 | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
SolidWorks Simulation製品 | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Workgroup PDM Server | pdmwserver\SolidWorks Workgroup PDM Server.msi
SolidWorks アクティべーション ウィザード | swactwizard\Activation Wizard.msi
DocManager APIs | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork License Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
親トピック: コマンドライン プロパティ（Command-Line Properties）


Windowsデスクトップ サーチの言語版サポート（Windows Desktop Search Language Support）

Windowsデスクトップ サーチ ファイル名にはプラットフォームと言語情報が含まれています。

プラットフォーム／アーキテクチャ：
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32-bit Windows
x64 | 64-bit Windows
言語:
chs | 中国語（中国）
cht | 中国語(台湾)
csy | チェコ語
deu | ドイツ語
enu | 英語
esn | スペイン語
fra | フランス語
ita | イタリア語
jpn | 日本語
kor | 韓国語
plk | ポーランド語
ptb | ポルトガル語（ブラジル）
rus | ロシア語
trk | トルコ語
親トピック: コマンドライン プロパティ（Command-Line Properties）


Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

Microsoft Active Directoryによる展開では、SolidWorksコア製品のクライアントへの展開もサポートされます。

Microsoft Active Directoryはネットワーク環境にあるクライアントとサーバーを管理するためのディレクトリ サービスです。 これにより、管理、移行、展開がシンプルになります。

  1. SolidWorks Installation Managerまたはコマンドラインを使用し、アドミニストレーティブ イメージを作成します。
  2. コマンドラインを使用してアドミニストレーティブ イメージを作成した場合は、Microsoft Active Directoryを使用したアドミニストレーティブ イメージからのインストレーションのためにWindows前提条件をインストールします。 詳細は Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory） を参照してください。

    このステップはコマンドラインを使用してイメージをマニュアルで作成した場合のみ実行します。 SolidWorks Installation Managerを使用してイメージを作成した場合は、すべてのWindows前提条件は自動的にインストールされます。

  3. トランスフォーム ファイルを作成してSolidWorksソフトウェアをユーザー定義します。
    1. コマンド プロンプト ウィンドウを開きます。
    2. アドミニストレーティブ イメージを含むフォルダーでSWCreateMST.exeをコマンド プロンプト ウィンドウ内にドラッグします。

      コマンドは、次のフォーマットにする必要があります。

      アドミニストレーティブ_イメージ_ディレクトリ\SWCreateMST.exe アドミニストレーティブ_イメージ_の_MSI_ファイル_へ_の_パス プロパティ_の_リスト

      プロパティは、機能プロパティまたはグローバルプロパティになります。 詳細は コマンドラインの機能プロパティ（Command-Line Feature Properties） 、コマンドラインのグローバル プロパティ（Command-Line Global Properties） を参照してください。

      次の例テンプレートとして使用してください:

      • SolidWorks（32-bitバージョン）を32-bitオペレーティング システムにインストールする場合:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@選択_サーバー"

      • SolidWorks（32-bitバージョン）を64-bitオペレーティング システムにインストールする場合:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@選択_サーバー"

      • SolidWorks（64-bit バージョン）を64-bitオペレーティング システムにインストールする場合:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@選択_サーバー"

      トランスフォーム ファイルSolidWorks.mstは、アドミニストレーティブ イメージを含むフォルダーに作成されます。

  4. Active Directoryでグループ、または複数グループのPublished Appsポリシーを編集してSolidWorksソフトウェアを展開します。
  5. グループ ポリシー ダイアログ ボックスでコンピュータの構成とソフトウェアの設定を展開します。
  6. ソフトウェア インストールを右クリックし、新規作成 > パッケージを選択します。
  7. アドミニストレーティブ イメージまで参照し、開く（Open）をクリックします。
  8. ソフトウェアの展開（Deploy Software）ダイアログ ボックスで公開または割り当て時の詳細設定（Advanced published or assigned）を選択し、OKをクリックします。
  9. SolidWorksのプロパティ ダイアログ ボックスの変更タブで次を行います。
    1. 追加（Add）をクリックします。
    2. .mstファイルまで参照します。
    3. 開く（Open）をクリックします。
  10. OK をクリックします。
  • Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）
    次の手順に従い、Microsoft Windows Active Directoryを使用してクライアント コンピュータにSolidWorksをインストールする既存のアドミニストレーティブ イメージを用意します。
親トピック: コマンドラインによる展開（Command-Line Deployment）


Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）

次の手順に従い、Microsoft Windows Active Directoryを使用してクライアント コンピュータにSolidWorksをインストールする既存のアドミニストレーティブ イメージを用意します。

これらの手順では、展開するSolidWorksバージョンに適切なコマンドを使用してください。

  1. 2005 Visual C++再頒布可能パッケージ インストーラー ファイルを抽出してインストールします。
    1. 以下のいずれかのコマンドを実行します。

      32-bitバージョンのWindowsの場合:

      アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_target_directory}

      64-bitバージョンのWindowsの場合:

      アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_target_directory}

    2. Microsoft C++ 2005再頒布可能モジュールをインストールするためのポリシーを作成します。

      {2005_C++_target_directory}\vcredist.msi –

      このインストレーションでは、トランスフォーム ファイルは必要ありません。

  2. 2008 Visual C++再頒布可能パッケージ インストーラー ファイルを抽出してインストールします。
    1. 以下のいずれかのコマンドを実行します。

      32-bitバージョンのWindowsの場合:

      アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_target_directory}

      64-bitバージョンのWindowsの場合:

      アドミニストレーティブ_イメージ_ディレクトリ\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_target_directory}

    2. Microsoft C++ 2008再頒布可能モジュールをインストールするためのポリシーを作成します。

      {2008_C++_target_directory}\vcredist.msi –

      このインストレーションでは、トランスフォーム ファイルは必要ありません。

  3. Windows Server Update Servicesを使用し、Microsoft .NET Framework 3.5をインストールします。

    Windows 7以降の場合.NET Frameworkイメージをインストールする必要はありません。

  4. Office Webコンポーネント ファイルを抽出し、インストールします。
    1. 次のコマンドを実行します:

      アドミニストレーティブ_イメージ_ディレクトリ\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_directory}

    2. Office Webコンポーネントをインストールするためのポリシーを作成します：

      {Office_Web_components_directory}\owc11.MSI

      このインストレーションでは、トランスフォーム ファイルは必要ありません。

  5. 次のポリシーを作成し、Visual Studio Tools for Applications（VSTA）をインストールします。

    {Microsoft_VSTA_directory}\vsta_aide.MSI

    このインストレーションでは、トランスフォーム ファイルは必要ありません。

  6. 次のポリシーを作成し、Visual Studioリモート デバッガ（64-bitバージョンのみ）をインストールします。

    {Microsoft_remote_debugger_directory}\rdbgexp.MSI

    このインストレーションでは、トランスフォーム ファイルは必要ありません。

親トピック: Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


複数インストレーションの管理（Administration of Multiple Installations）

複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。

  • 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
    アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。
  • ServicePack製品アップデートの管理（Service Pack Product Update Administration）
    ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。
  • インストレーションの削除（Removing an Installation）
    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。
親トピック: 複数インストレーション（Multiple Installations）


新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

SolidWorks Installation Manager をインターネットから実行し、正しいファイルが参照されるようにします。SolidWorks Installation Managerは自動的にリダイレクトされますが、SolidWorks Downloads Webサイト（http://www.solidworks.com/sw/support/downloads.htm）からアップデートを直接実行することもできます。

アドミニストレーティブ イメージをアップデートすると（新しいイメージのコピーが作成されます）、新しいアドミニストレーティブ イメージのコピーを参照することによってクライアントを更新できます。

クライアントが、前のバージョンのネットワークドライブに割り当てられている、または共有ディレクトリにあるアドミニストレーティブ イメージを参照していた場合、ネットワークドライブに割り当てられている、または共有ディレクトリのアドミニストレーティブ イメージの位置を更新することによって再定義することができます。
  • アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
    SolidWorks Installation Managerはアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。
  • アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）
    アドミニストレーティブ イメージをアップグレードするため、SolidWorks Installation Managerは新しいイメージ ディレクトリを作成します。その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。
  • アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
    SolidWorks Installation Managerはアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。
親トピック: 複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

SolidWorks Installation Managerはアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  1. DVDをメディアに挿入し、SolidWorks Installation Managerを開始します。
  2. ようこそ(Welcome) スクリーンで、アドミニストレーティブ イメージ(Administrative image)をクリックします。
  3. シリアル番号（Serial Number）画面でSolidWorksシリアル番号を入力します。

    SolidWorks Installation Managerは、ライセンスのある製品と使用可能なServicePackがSolidWorks Webサイトにあるかどうかをチェックします。

  4. 利用可能なより新しいバージョン（Newer Version Available）画面が表示されたら、 はい、新しいバージョンをダウンロードﾞしてインストールします：バージョン（Yes, download and install a newer version: version）を選択します。

    SolidWorks Installation Managerが新しいバージョンをインストールするためのセッションを新たに開始します。

  5. ダウンロード フォルダーに問題がある場合は、ダウンロード オプション（Download Options）が表示されるかもしれません。この場合は、新しいインストレーション ファイルのデフォルトのディレクトリを確定するか、または新しいディレクトリ名を入力します。

    ディレクトリが存在しない旨を伝えるメッセージが表示された場合は、はい（Yes）をクリックしてディレクトリを作成します。

  6. ダウンロード完了（Download Complete）画面で閉じる（Close）をクリックして現在のインストーラを閉じ、新規バージョンのインストーラを開始します。
親トピック: 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）


アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

アドミニストレーティブ イメージをアップグレードするため、SolidWorks Installation Managerは新しいイメージ ディレクトリを作成します。その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

このプロセスは、アドミニストレーティブ イメージのすべてのアップデートされたインストレーション ファイルのダウンロードが行われていることを前提とします。詳細は アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images） を参照してください。

  1. SolidWorks Installation Managerを起動します。詳細は SolidWorksインストレーションの開始（Initiating SolidWorks Installation） を参照してください。
  2. ようこそ(Welcome) スクリーンで、アドミニストレーティブ イメージ(Administrative image)をクリックします。

    アドミニストレーティブ イメージの作成オプションが表示されます。

    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings）
    デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.）
    現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。参照（Browse）をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
    両方 (32-bit と 64-bit) のアドミニストレーティブ イメージを作成します。（Create both 32-bit and 64-bit administrative images.）
    単一のコンピュータ上で、32 ビットと 64 ビットの両方のアドミニストレーティブ イメージを作成することも、お使いのコンピュータ アーキテクチャに対応したイメージのみを作成することもできます。両方のイメージを作成するには、32 ビットと 64 ビットの両方のインストール メディアに対するアクセスが必要です。

  3. シリアル番号（Serial Number）画面でシリアル番号を確認します。
  4. サマリー（Summary）（イメージ作成の準備完了（Ready to Create Image））画面でアドミニストレーティブ イメージ オプションが正しいことを確認します。

    個々のアドミニストレーティブ イメージとインストレーション オプションの詳細については、変更（CHANGE）をクリックしてオプション ページに移動してから、ヘルプ（Help）をクリックします。

  5. アドミニストレーティブ イメージの新しいバージョンを作成するには、今すぐ作成（Create Now）をクリックします。

これで、この新しいバージョンのアドミニストレーティブ イメージへのクライアントのアップグレードを行えるようになります。詳細は アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images） を参照してください。

親トピック: 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）


アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

SolidWorks Installation Managerはアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

通常、アドミニストレーティブ イメージはサーバー上のフォルダーにまとめられています。クライアントの自動アップグレードをサポートするためには、アドミニストレーティブ イメージが共有フォルダーにある必要があります。

アドミニストレーティブ イメージのアップグレードを行うと、元のインストレーションが1つのフォルダーに保存され、更新されたインストレーションが別のフォルダーに保存されます。アップグレードされたインストレーションを使用するには、元のアドミニストレーティブ イメージ フォルダーの共有オプションを解除します。続いてアップグレードされたアドミニストレーティブ イメージ フォルダーに共有オプションを追加します。

元のアドミニストレーティブ イメージからインストールしたSolidWorksをクライアント マシンで起動すると、新しいバージョンが識別されてクライアントがアップグレードされます。

  • 元のアドミニストレーティブ イメージ フォルダからの共有オプションの解除（Removing the Sharing Option from the Original Administrative Image Folder）
    共有フォルダからアクセスされるアドミニストレーティブ イメージをアップグレードする際は、元のフォルダから共有オプションを解除する必要があります。
  • アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）
    アドミニストレーティブ イメージ フォルダーを作成してアップデートし、元のアドミニストレーティブ イメージ フォルダーの共有を無効にしたら、新しいフォルダーに共有オプションを追加してアドミニストレーティブ イメージを再び有効にする必要があります。
  • コマンドラインを使用したアドミニストレーティブ イメージのクライアントのマニュアル アップグレード（Upgrading Clients of Administrative Images Manually Using the Command Line）
    アドミニストレーティブ イメージをアップグレードした後は、コマンドラインを使用してクライアントをマニュアルでアップグレードできます。
親トピック: 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）


元のアドミニストレーティブ イメージ フォルダからの共有オプションの解除（Removing the Sharing Option from the Original Administrative Image Folder）

共有フォルダからアクセスされるアドミニストレーティブ イメージをアップグレードする際は、元のフォルダから共有オプションを解除する必要があります。

  1. 元のアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブでこのフォルダを共有しない（Do not share this folder）を選択し、OKをクリックします。

次に、アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）の手順に従い、アップグレードされたアドミニストレーティブ フォルダに共有オプションを追加します。

親トピック: アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）

アドミニストレーティブ イメージ フォルダーを作成してアップデートし、元のアドミニストレーティブ イメージ フォルダーの共有を無効にしたら、新しいフォルダーに共有オプションを追加してアドミニストレーティブ イメージを再び有効にする必要があります。

  1. アップグレードされたアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブで、適切な共有プロパティを業務グループ用に指定し、共有名を元のアドミニストレーティブ イメージ フォルダ名に変更します。
元のアドミニストレーティブ イメージの共有場所からインストールしたコンピュータは、SolidWorksの起動時に新しいバージョンに自動的にアップグレードされます。
親トピック: アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


コマンドラインを使用したアドミニストレーティブ イメージのクライアントのマニュアル アップグレード（Upgrading Clients of Administrative Images Manually Using the Command Line）

アドミニストレーティブ イメージをアップグレードした後は、コマンドラインを使用してクライアントをマニュアルでアップグレードできます。

  1. すべてのクライアントが同じ前リリースのサービス パックを使用していることを確認します。（アプリケーションがインストールされていないクライアントはアップグレードされません）。
  2. 必要に応じて、いずれかのクライアント システムで設定のコピー ウィザードを実行し、現在のSolidWorksオプションを出力します。
  3. SolidWorks Installation Managerまたはコマンドラインを使用し、新しいアドミニストレーティブ イメージを作成します。

    前のイメージのアップグレード/上書きはしないでください。
    英語版以外のSolidWorksインストレーションをアップグレードする場合には、その言語のインストレーション コンポーネントに対する新しいアドミニストレーティブ イメージを作成する必要があります。

  4. 以下の指定でmsiexecコマンドを使用し、すべてのクライアントを新規バージョンにアップグレードします。

    • /Iおよびqb msiexecコマンドライン オプションを含める。
    • 必要な機能とグローバル コマンドライン プロパティをすべて指定します。詳細は コマンドライン プロパティ（Command-Line Properties） を参照してください。

    例えば、SolidWorksの既存のバージョンをアップグレードするには、以下を指定します。

    msiexec /I Msi_パス" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks version servicepack" /qb

    英語版以外のSolidWorksインストレーションをアップグレードする場合には、SolidWorksコンポーネントをアップグレードした後でその言語のコンポーネントをアップグレードする必要があります。

親トピック: アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


ServicePack製品アップデートの管理（Service Pack Product Update Administration）

ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

次の2つの方法で製品アップデートを入手できます。

現在のバージョンのSolidWorksの場合:
SolidWorks Installation Managerを使用して、ダウンロードとインストールの更新をチェックできます。

SolidWorks Installation Managerをマニュアルで開始するか、アップデート チェックが定期的に行われるようにスケジュールします。

SolidWorks 2008以前のバージョンの場合:
Service PackをSolidWorksのWebサイトからマニュアルでダウンロードします。

ServicePackはソフトウェアの既存バージョンにパッチとして適用されます。例えば、SolidWorks 2007 SP1.0はSolidWorks 2007 SP0.0のServicePackです。これらのServicePackはSolidWorks 2007 Installation Managerを使用してインストールします。SolidWorks 2008、またはそれ以降のSolidWorks Installation Managerを使用してインストールすることはできません。

ServicePackのダウンロードとインストールの詳細手順については、アップデートしているSolidWorksバージョンのインストレーション ドキュメントを参照してください。

  • アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）
    アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。ディスクからSolidWorksをインストールした場合、特定のServicePackまでロールバックするには、元のディスクが必要です。以前のアドミニストレーティブ イメージの保存コピーが必要です。
  • Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）
    Microsoft Active Directoryを使用してSolidWorksソフトウェアをインストールした場合、ServicePackも同様にクライアントに適用することができます。
親トピック: 複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。ディスクからSolidWorksをインストールした場合、特定のServicePackまでロールバックするには、元のディスクが必要です。以前のアドミニストレーティブ イメージの保存コピーが必要です。

一度アップグレードしたアドミニストレーティブ イメージを前回バージョンのService Packへとロールバックすることはできません。SolidWorks InstallationManager以外の方法で作成したアドミニストレーティブ イメージを以前のバージョンにロールバックすることはできません。これらのアドミニストレーティブ イメージからインストールしたクライアントは、アンインストールしてから前のバージョンで作成したアドミニストレーティブ イメージを使用して再インストールする必要があります。
  1. 現在のアドミニストレーティブ イメージを含むフォルダーを削除します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。

    rmdir /s/q 現在の_アドミニストレーティブ_イメージ_への_パス

  2. アドミニストレーティブ イメージのバックアップ コピーを現在のアドミニストレーティブ イメージを削除した場所へ移動します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。

    move バックアップした_アドミニストレーティブ_イメージ_への_パス 現在の_アドミニストレーティブ_イメージ_への_パス

    アドミニストレーティブ イメージをロールバックすると、次回SolidWorksを実行した時にクライアント コンピュータは自動的にロールバックされます。

親トピック: ServicePack製品アップデートの管理（Service Pack Product Update Administration）


Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）

Microsoft Active Directoryを使用してSolidWorksソフトウェアをインストールした場合、ServicePackも同様にクライアントに適用することができます。

  1. 次のコマンドラインでアドミニストレーティブ イメージを新規フォルダーにコピーします。

    xcopy path_to_current_administrative_image path_to_backup_administrative_image /s/i/v

  2. アドミニストレーティブ イメージのコピーにServicePackを適用します。
  3. SolidWorksソフトウェアのアップグレード インストレーションを指定するために、新規トランスフォーム ファイルを作成するには以下を行います。
    1. コマンド プロンプト ウィンドウを開きます。
    2. アドミニストレーティブ イメージを含むフォルダーでSWCreateMST.exeをコマンド プロンプト ウィンドウ内にドラッグします。

      コマンド フォーマットは次のようになります。

      アドミニストレーティブ_イメージ_への_パス\SWCreateMST.exe アドミニストレーティブ_イメージ_の_MSI_ファイル_へ_の_パス プロパティ_の_リスト

      コマンドラインには、元のMSTファイルを作成した際に使用したすべてのパラメータが含まれていなくてはなりません。また、グローバル プロパティの UPGRADESWINSTALLとSWMIGRATEも必要です。

      例えば、元のコマンドが次の場合:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー

      アップデート コマンドは次のようにする必要があります。

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\選択_フォルダー" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks version service_pack"

      トランスフォーム ファイルSolidWorks.mstは、アドミニストレーティブ イメージを含むフォルダーに作成されます。

      上の例にある元のコマンドとアップデートのコマンドは32-bitバージョンのSolidWorksを32-bitバージョンのオペレーティング システムにインストールする場合に使用します。32-bitバージョンのSolidWorksを64-bitオペレーティング システムにインストールする場合は、"Intel_Modules_AgeiaX64"を"Intel_Modules_AgeiaX86"の代わりに使用してください。64-bit バージョンのSolidWorksを64-bitオペレーティング システムにインストールする場合は、"Intel_Modules_AgeiaX86”や“Intel_Modules_AgeiaX64"は使用しません。

  4. Active Directoryでグループ、または複数グループのPublished Appsを編集してSolidWorksを展開します。
  5. グループ ポリシー（Group Policy）ダイアログ ボックスでコンピュータの構成とソフトウェアの設定（Computer Configuration and Software Settings）を展開します。
  6. ソフトウェア インストール（Software installation）を右クリックし、新規作成 > パッケージを選択します。
  7. アドミニストレーティブ イメージまで参照し、開く（Open）をクリックします。
  8. ソフトウェアの展開（Deploy Software）ダイアログ ボックスで公開または割り当て時の詳細設定（Advanced published or assigned）を選択し、OKをクリックします。
  9. SolidWorksのプロパティ（SolidWorks Properties）ダイアログ ボックスの変更（Modifications）タブで次を行います。
    1. 追加（Add）をクリックします。
    2. .mstファイルまで参照します。
    3. 開く（Open）をクリックします。
  10. OK をクリックします。
親トピック: ServicePack製品アップデートの管理（Service Pack Product Update Administration）


Workgroup PDM

Workgroup PDM アプリケーションは、SolidWorks 環境内で、あるいはスタンドアロン アプリケーションとして SolidWorks Explorer 内で動作する、製品データ管理ソフトウェアです。 Workgroup PDMは、プロジェクトのチェックアウト/チェックイン/リビジョン管理の手順、またその他の管理作業をコントロールします。

下記は Workgroup PDM を図解したものです:

  • １つのコンピュータで使用できるボルトは１つだけです。
  • Vault（ボルト）ディレクトリに非表示や読み取り専用のディレクトリは使用できません。
  • クライアント/サーバー アプリケーションとして、Workgroup PDM のパフォーマンスは、強力なネットワーク環境に依存します。
  • 多数のドキュメントを維持する必要がある場合は、少数のプロジェクト（各プロジェクトに属するドキュメント数が多い）で維持するのではなく、プロジェクトやサブプロジェクトの数を増やす（各プロジェクトに属するドキュメント数が少ない）とパフォーマンスが改善されます。

インストレーション(Installation)

  • Clients と VaultAdmin、API と Viewer は、Vault（ボルト）が存在するコンピュータにインストールすることも、また別のコンピュータにインストールすることもできます。
  • クライアント API をインストールする際、Workgroup PDM Server をインストールする必要はありません。 Workgroup PDM Client をインストールする際、クライアント API もインストールされるようになりました。
  • ボルト フォルダをリモート位置に設定するには、サーバー先を指定する時に、UNC(一般的な命名規則)に従ったパス名全体を入力します。 （詳細は UNCフォーマット（UNC Format） を参照してください。）
  • ボルトのインストールや更新には、コンピュータを再起動させる必要があります。
  • 再起動後、Workgroup PDM Server サービスが自動的に実行されない場合は、マニュアルで開始させる必要があります。 Windows エクスプローラで pdmwvault.exe を実行します（install_dir\SolidWorks Workgroup PDM\Vault）。
  • Workgroup PDMクライアントをインストールする場合、各コンピュータにsolidworksexplorer.exeをインストールする必要があります。 この実行ファイルは、共有ドライブから実行できます。 Workgroup PDM の Vault（ボルト）、Viewer（ビューア）、API Client（API クライアント）、VaultAdmin（ボルト アドミン）は、各クライアント コンピュータにはインストールされません。

ライセンス（Licenses）

  • Workgroup PDM API のライセンスは SolidWorks クライアントと Explorer クライアントのライセンスに含まれています。 Check-in APIs（チェックイン API）にはクライアント ライセンスが必要です。
  • Viewer を有効にするには、Workgroup PDM Viewer のライセンスをボルトと共にインストールする必要があります。

権限(Permissions)

  • ボルト アドミン管理者には、インストレーションとボルト フォルダーへの書き込み許可を与えてください。
  • ボルト アドミン管理者は、ボルト フォルダを VaultAdmin から（Windows エクスプローラからではありません）管理してください。
  • ユーザーには、Windows エクスプローラでボルト フォルダーへの書き込み許可を与えないでください。

セキュリティ、ポート、デュプレックス設定（Security, Ports, and Duplex Settings）

  • 他のアプリケーションによってサービスをブロックまたはフィルターされないように、Workgroup PDM は必ず Windows サービスとしてインストールしてください。 例えば、Microsoft AntiSpyware などのスパイウェア対策ツールによって、インストレーション過程でユーザーの承諾を求める警告メッセージがプロンプトされたら、許可する（Allow）をクリックし、Workgroup PDM Server を Windows のサービスとしてインストールしてください。
  • Workgroup PDM を Windows XP システム（Service Pack 2）、Windows 2003 サーバー（Service Pack 1）、ファイアウォールがアクティブに設定されたコンピュータにインストールした場合、ファイアウォールの Workgroup PDM ポートが例外として実行されるように設定する必要があります。

    通常、ポートは次のようになります。

    • 20000（VaultAdmin）
    • 30000（Data）
    • 40000（Request）
    • 80（Viewer）
    ポート設定を変更する方法の詳細についてはWorkgroup PDMとSolidWorks Explorerヘルプの ボルト管理のトラブルシューティング（Troubleshooting for Vault Administrators）およびセキュリティ センター（Security Center）のMicrosoft Windowsヘルプを参照してください。 Workgroup PDM Vault（ボルト）と Viewer を同時にインストールするには、セットアップ　タイプ（Setup Type） ダイアログボックスのカスタム （Custom）オプションを使用します。
  • サーバーと対応するポートにおけるデュプレックス設定（二重の設定）は、一致する必要があります（例えば、両方が100MB全二重通信（100MB Full）、または自動検出（Auto）であるなど）。

SolidWorks Toolboxドキュメント（SolidWorks Toolbox Documents）

SolidWorks Toolbox ドキュメントは、ほとんどの場合、リビジョン コントロールを必要とせず、Workgroup PDM Vault にチェックインされない共有構成部品です。 SolidWorks Toolboxやその他の規格ライブラリのコンフィギュレーションに関する詳細はWorkgroup PDMオンライン ヘルプを参照してください。

  • Workgroup PDM Viewer
    Workgroup PDMソフトウェアはMicrosoftインターネット インフォメーション サービス（IIS）を使用してインストール中に自動的にバーチャル ディレクトリを設定します。
  • Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
    Workgroup PDM Server をインストールすると、Workgroup PDMボルトが作成されます。これは管理する SolidWorks プロジェクトを保存するためのデータベースです。
  • クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）
    Workgroup PDMサーバー ボルトをインストールした後で、クライアント用のボルトを設定できます。
  • Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
    SolidWorks Workgroup PDM Web サーバーと Workgroup PDM Viewer を境界ネットワーク（DMZ）にインストールすると、ファイアウォールに影響を及ぼします。
  • Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
    Workgroup PDMクライアントはMicrosoft Windowsのログイン アクセス コントロールを使用してWorkgroup PDM Viewer経由でWebにアクセスし、Workgroup PDM Vaultがアップデートされると自動的にアップデートされます。
  • Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
    Workgroup PDMがインストールされた後で、ボルト管理者は以下を行うべきです。


Workgroup PDM Viewer

Workgroup PDMソフトウェアはMicrosoftインターネット インフォメーション サービス（IIS）を使用してインストール中に自動的にバーチャル ディレクトリを設定します。

Viewerをインストールする前に、必ずMicrosoftインターネット インフォメーション サービス（IIS）をインストールしてください。
次のコンポーネントが必要です：
  • Web Management Tools
    • IIS Management Console
  • World Wide Web Services:Application Development Features
    • .NET Extensibility
    • ASP.NET
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
IISのインストレーション手順については、Microsoftのドキュメントを参照してください。
Workgroup PDM Viewerのインストレーションには、以下の制約があります。
  • Web Site Content Directoryは、Viewerのインストレーション フォルダです。
  • Viewerをホストするマシンの名前にアンダースコア文字は使用できません。
  • ViewerをWindows XP Service Pack 2にインストールした場合は、WindowsファイアウォールでHTTP（ポート 80）が実行されるように設定する必要があります。
  • Viewerは、常に1つのVault（ボルト）のみに接続できます。

Internet Explorerのアドレス フィールドに次のURLを入力するとWorkgroup PDM Viewerにアクセスできます。

http://ViewerComputerName/pdmweb/

親トピック: Workgroup PDM


Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）

Workgroup PDM Server をインストールすると、Workgroup PDMボルトが作成されます。これは管理する SolidWorks プロジェクトを保存するためのデータベースです。

  1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
  2. ようこそ（Welcome）画面で以下を選択します。

    • サーバー製品
    • SolidWorks Workgroup PDM Server (ボルト)をこのコンピュータにインストールする

  3. サマリー（Summary）の画面で変更（Change）をクリックし、検証コードを取得してください。 次の方法でコードを取得できます:
    • インターネット接続:
      1. SolidWorks シリアル番号と電子メール アドレスを入力します。
      2. 自動的に検証（Validate automatically）を選択し、コード取得（Get Code）をクリックします。
    • 電子メール
      1. インターネットに接続できない場合は、電子メールを使用して検証（Validate manually by email）をクリックします。 Installation Manager によって検証リクエスト ファイルが作成されます。
      2. 保存（Save）をクリックし、ファイルをローカル システム上に保存します。
      3. 画面に表示される手順に従い、検証コードを入力します。
  4. サマリーに戻る（Back to Summary）をクリックします。
  5. サマリー画面で今すぐインストール（Install Now）をクリックします。
親トピック: Workgroup PDM


クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）

Workgroup PDMサーバー ボルトをインストールした後で、クライアント用のボルトを設定できます。

  1. VaultAdmin（SolidWorks Explorerと共にインストールされます）にデフォルトのユーザー名とパスワードでログインします。
  2. VaultAdminでユーザーとグループのアカウント、プロジェクト フォルダー、許可権限などを設定します。

    手順については、Workgroup PDMヘルプ（Workgroup PDM Help）を参照してください。

  3. クライアントのユーザー名、パスワード（通常、Microsoft Windowsのユーザー名やパスワードとは異なります）の情報を、サーバー コンピュータ名でクライアントに電子メールで送信します。
  • Workgroup PDM Viewerを別のボルトの場所に接続するための設定（Configuring the Workgroup PDM Viewer to Connect to a Different Vault Location）
    Windowsレジストリを使用してWorkgroup PDM Viewerを別のボルトの場所に接続するように設定できます。
  • ドキュメント ダウンロードのMIMEタイプの設定（Configuring Mime Types for Document Downloading）
    Windowsレジストリの設定を使用し、ドキュメント ダウンロードのMIMEタイプを設定できます。
親トピック: Workgroup PDM


Workgroup PDM Viewerを別のボルトの場所に接続するための設定（Configuring the Workgroup PDM Viewer to Connect to a Different Vault Location）

Windowsレジストリを使用してWorkgroup PDM Viewerを別のボルトの場所に接続するように設定できます。

  1. Vault Computerの値を変更し、レジストリ パスを更新します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Workgroup PDM Viewerを再インストールします。ボルト コンピュータ名（Vault Computer Name）ダイアログ ボックスで新しいコンピュータ名を入力します。
親トピック: クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）


ドキュメント ダウンロードのMIMEタイプの設定（Configuring Mime Types for Document Downloading）

Windowsレジストリの設定を使用し、ドキュメント ダウンロードのMIMEタイプを設定できます。

デフォルトで、Viewerは一般的なMIMEタイプのapplication/octet-streamと共にドキュメントを開く（Open Document）リクエストを送信します。続いてMicrosoft Internet Explorerにより、リクエストされた、提供されたファイル拡張子のあるドキュメントが開かれます。追加のMIMEタイプをマッピングする、またはMIMEタイプのマッピングを中止するには、WindowsレジストリでMIMEタイプ レジストリのサブキーを変更します。

  • 追加のMIMEタイプをマッピングするには、このレジストリ サブキーの下に追加のストリング値を作成します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    次のフォームを使用します。

    "ext" = "mime type"

    例えば:

    "dxf" = "image/vnd.dxf"

    値を追加する前にこのレジストリのサブキーをマニュアル操作で作成する必要があります。

    MIMEタイプのマッピングを中止するには、Use Custom MIME Typesレジストリの値を0（ゼロ）に変更します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    この設定を有効にするために、Web サーバーを再起動する必要はありません。

親トピック: クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）


Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）

SolidWorks Workgroup PDM Web サーバーと Workgroup PDM Viewer を境界ネットワーク（DMZ）にインストールすると、ファイアウォールに影響を及ぼします。

Workgroup PDM Viewer クライアントは、Web サーバーと HTTP あるいは HTTPS ポートを使用して通信するため、Web サーバーがインストールされている IIS (Internet Information Server) でこれらのポートがオープンでなくてはなりません。

  • HTTP プロトコールの場合、デフォルト ポートは 80 です。
  • HTTPS プロトコール（SSL）の場合、デフォルト ポートは 443 です。

Web Viewer クライアント自身は、ファイアウォールの例外を構成する必要はありません。

Web サーバー システムが次のデフォルト ポートを使用して Vault サーバーと通信できることを確認する必要があります:

  • 30000（Data）
  • 40000（Request）
  • 境界ネットワークにおける Workgroup PDM Viewer のネットワーク コンフィギュレーション（Network Configuration for Workgroup PDM Viewer in a Perimeter Network）
    ネットワーク構成は、環境ネットワーク サーバー設定（環境サブネット上）と、その内部ネットワークと外部ネットワークへの通信を表しています。
  • Workgroup PDM Web Server と Viewer のインストレーションとコンフィギュレーション（Installing and Configuring the Workgroup PDM Web Server and Viewer）
    Workgroup PDM Web サーバーを環境ネットワークで設定する場合は、コンポーネントをインストールする場所が重要になります。
親トピック: Workgroup PDM


境界ネットワークにおける Workgroup PDM Viewer のネットワーク コンフィギュレーション（Network Configuration for Workgroup PDM Viewer in a Perimeter Network）

ネットワーク構成は、環境ネットワーク サーバー設定（環境サブネット上）と、その内部ネットワークと外部ネットワークへの通信を表しています。

環境ネットワーク サーバーは、内部ファイアウォールを介して LAN と通信します。 外部ネットワークには、外部ファイアウォール、ルーター、ロード バランサーのクラスターを介して通信します。

Internet Explorer クライアントは、Workgroup PDM Viewer/IIS サーバーに、ポート 80 （SSL を使用する場合は 443） を介してつながります。 続いて、Workgroup PDM Viewer は、 Vault サーバーに、 ポート 30000 またはポート 40000 を使用してつながります。 Vault サーバーがリクエストされた情報を Workgroup PDM Viewer まで送信し、そこから Internet Explorer クライアントまで情報がフィードされます。

環境ネットワーク Web サーバーには2つの IP アドレスがあります:

  • 内部 IP アドレス （LAN）
  • パブリック IP アドレス （ISP）

Web サーバー（環境ネットワーク内）は、ロード バランサーのクラスターの後にあります。 直接 Web サーバーにアクセスできますが（管理タスクを行う場合など）、すべての Web サービス トラフィックは環境ネットワークのサーバーに集められ、ロード バランサーによって処理されます。

ロード バランサーは、公開されているネットワーク部分で、サーバー ハードウェアの IP アドレスを仮想 IP（VIP）に変換します。 ネットワークにつながっている間に、VIP あるいは Web サーバー URL を参照すると、サイトを見ることができます。

外部ファイアウォールは、ロード バランサー VIP を公開された、ルーティング可能なアドレスに変換します。

親トピック: Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）


Workgroup PDM Web Server と Viewer のインストレーションとコンフィギュレーション（Installing and Configuring the Workgroup PDM Web Server and Viewer）

Workgroup PDM Web サーバーを環境ネットワークで設定する場合は、コンポーネントをインストールする場所が重要になります。
  • IIS が有効な Web サーバーを環境サブネットにインストールします。
  • IIS が有効な Workgroup PDM Viewer を環境サブネットにインストールします。
  • Workgroup PDM Vault をプライマリ ドメインか内部ネットワーク（ローカル イントラネット上）にインストールします。

Workgroup PDM Viewer を環境ネットワーク上にインストールし、設定するための前提条件は:

  • Microsoft IIS 6.0 以降
  • ユーザーの ISP プロバイダーによって指定された、Web サーバーへのパブリック IP アドレス（環境サブネット上）

Workgroup PDM コンポーネントをインストールし、設定するには:

  1. Microsoft IIS を環境サブネット サーバー システムにインストールします。
  2. SolidWorks Workgroup PDM Server インストレーションを2回行います:
    1. 最初に、Vault コンポーネントを Vault サーバー上にインストールします。
    2. 2度目のインストーラーを実行し、Workgroup PDM Viewer と Viewer ライセンス コンポーネントを IIS Web サーバー上にインストールします。 ボルト サーバーのコンピュータ名を入力し、Web ポータルが Vault サーバー サービスを見つけることができるようにします。

    インストレーションを実行すると、PDMWeb アプリケーションがデフォルト IIS Web サイトに自動的に追加されます。

  3. 内部ネットワークのファイアウォールが、ポート 30000 とポート 40000 をオープンにしていることを確認してください。
  4. 内部サーバーに固定 IP アドレスがある場合は、環境サーバー システム上で C:\Windows\system32\drivers\etc\hosts ファイルを編集します。 IP アドレスのシステム名を作成し、環境サーバーが内部サーバーと通信できるようにマッピングします:
    1. hosts ファイルをメモ帳などのテキスト エディタで開きます。
    2. Vault サーバー IP アドレスと名前の新しい列に追加します。
    3. hosts ファイルを保存します。
親トピック: Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）


Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）

Workgroup PDMクライアントはMicrosoft Windowsのログイン アクセス コントロールを使用してWorkgroup PDM Viewer経由でWebにアクセスし、Workgroup PDM Vaultがアップデートされると自動的にアップデートされます。

Workgroup PDMクライアントとしてログインするには: | Workgroup PDMのクライアントのユーザー名とパスワードは、Microsoft Windowsのログインのものとは異なります。ログインするための情報に関しては、お客様のシステム管理者にお問い合わせください。
Workgroup PDM Viewerに接続するには: | Viewerに接続するためのURLに関しては、お客様のシステム管理者にお問い合わせください。
Workgroup PDMクライアントをアップデートするには: | Vault（ボルト）がアップデートされている場合、Workgroup PDMクライアント（SolidWorksアドインとコントリビュータ）はそれを検知します。ServicePackをダウンロードしてクライアントをアップデートする必要はありません。
親トピック: Workgroup PDM


Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）

Workgroup PDMがインストールされた後で、ボルト管理者は以下を行うべきです。

  • VaultAdminへログインする。
  • ボルト管理者用のパスワードを変更する。
  • ユーザー アカウントを作成する。
  • 各ユーザーにアカウント名とパスワードを通知する。

詳細については、SolidWorks本体のヘルプにあるSolidWorks Workgroup PDMを参照してください。

  • Workgroup PDM VaultAdminへの初回ログイン（Initial Login to Workgroup PDM VaultAdmin）
    Workgroup PDM VaultAdminへの初回ログイン時には、Workgroup PDM管理者名とパスワード、およびWorkgroup PDM Vaultをホストするコンピュータ名を指定します。
  • Workgroup PDM Vault Serverのアップグレード（Upgrading the Workgroup PDM Vault Server）
    Workgroup PDM Vault ServerをアップグレードするにはSolidWorksのアップデート チェック、SolidWorksインストレーションDVD、またはローカル フォルダーにマニュアルでダウンロードしたWorkgroup PDMアップグレード ファイルを使用します。
  • Workgroup PDMクライアントのアップグレード（Upgrading Workgroup PDM Clients）
    Vault（ボルト）がアップデートされている場合、Workgroup PDMクライアントはそれを検知します。ServicePackをダウンロードしてクライアントをアップデートする必要はありません。
親トピック: Workgroup PDM


Workgroup PDM VaultAdminへの初回ログイン（Initial Login to Workgroup PDM VaultAdmin）

Workgroup PDM VaultAdminへの初回ログイン時には、Workgroup PDM管理者名とパスワード、およびWorkgroup PDM Vaultをホストするコンピュータ名を指定します。

  1. Windowsでスタート > すべてのプログラム > SolidWorks version > Workgroup PDM VaultAdminをクリックします。
  2. ダイアログ ボックスで、次の情報を入力します。

    名前 | pdmwadmin
    パスワード | pdmwadmin
    ボルト コンピュータ | ボルトがインストールされているコンピュータのホスト名です。ボルトがインストールされているコンピュータでVaultAdminを実行する場合、localhostと入力します。

  3. ログイン（Login）をクリックします。
セキュリティ上の理由から、できるだけ早い時期に管理者のパスワードを変更することを推奨します。VaultAdminでユーザーとグループ（Users and Groups）タブを選択します。
親トピック: Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）


Workgroup PDM Vault Serverのアップグレード（Upgrading the Workgroup PDM Vault Server）

Workgroup PDM Vault ServerをアップグレードするにはSolidWorksのアップデート チェック、SolidWorksインストレーションDVD、またはローカル フォルダーにマニュアルでダウンロードしたWorkgroup PDMアップグレード ファイルを使用します。

Workgroup PDM Vault Serverは1つのバージョンのみをインストールできます。
  1. すべてのユーザーをWorkgroup PDMボルトからログアウトさせ、ロックします。
  2. ボルト データをバックアップします。
  3. Microsoft Windowsコントロール パネルのプログラムの追加と削除（Add/Remove Programs）を使用し、現在のバージョンのWorkgroup PDM Serverを削除します。
  4. 新しいバージョンのWorkgroup PDM Serverをインストールします。
    • SolidWorksのアップデート チェックを使用するには、以下を行います。
      1. Windowsでスタート > すべてのプログラム > SolidWorks Installation Manager > アップデート チェックをクリックします。
      2. 利用可能なより新しいバージョン（Newer Versions Available）ダイアログ ボックスで、新しいバージョンのダウンロードとインストール（Download and install a new version）を選択し、インストールするバージョンを選択してから、次へ（Next）をクリックします。

        新しいバージョンのSolidWorks Installation Managerがダウンロードされ、実行されます。

    • SolidWorksインストレーションDVDを使用するには、ドライブにDVDを挿入し、SolidWorks Installation Managerの指示に従います。
    • マニュアルでダウンロードしたWorkgroup PDMインストレーション ファイル（pdmwserver.exe）を使用するには、ファイルをダブルクリックし、手順に従ってWorkgroup PDM Serverをアップグレードします。
  5. SolidWorksタスク スケジューラを使用して、ボルトにあるWorkgroup PDMファイルをアップデートします。
  6. ボルトをロック解除してから、ユーザーに使用できる状態に戻ったことを連絡します。
親トピック: Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）


ライセンス管理（License Administration）

インストレーション後にSolidWorksライセンスをアクティブ化するには、個人コンピュータでのアクティブ化（ライセンス アクティベーション）、またはサーバーでのフローティング ネットワーク ライセンスのインストールとアクティブ化（SolidNetWorkライセンス）のいずれかを行います。

一般的に、個人コンピュータで行うインストレーションではライセンス アクティベーションを使用します。しかし、ソフトウェアを個別にインストールしてからライセンスをSolidNetWork License Managerでコントロールすることもできます。逆に、大規模な環境では一般的にフローティング ネットワーク ライセンスが使用されますが、アドミニストレーティブ イメージからインストレーションを展開し、シリアル番号を各コンピュータからアクティブ化することもできます。

  • 個人ライセンスの管理（Administering Individual Licenses）
    通常、個人ライセンスの管理は直接SolidWorksからのライセンスのアクティベーションとトランスファーで構成されます。
  • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
    SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。


個人ライセンスの管理（Administering Individual Licenses）

通常、個人ライセンスの管理は直接SolidWorksからのライセンスのアクティベーションとトランスファーで構成されます。

SolidWorksスタンドアロン ライセンス（SolidNetWorkライセンスではありません）において、製品のライセンスを取得して登録するプロセスを「アクティベーション」と呼びます。一般に製品のライセンスがアクティブ化されていない場合、SolidWorksは製品の開始時にライセンスをアクティブ化しようとします。

また、個人ライセンスをトランスファーするには、SolidWorksでヘルプ > ライセンス トランスファーをクリックします。

  • ライセンス アクティベーション（Activating a License）
    SolidWorks製品を個人コンピュータで実行する前に、そのコンピュータに対するライセンスをアクティブ化する必要があります。
  • ライセンス トランスファー（Transferring a License）
    ライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。
親トピック: ライセンス管理（License Administration）


ライセンス アクティベーション（Activating a License）

SolidWorks製品を個人コンピュータで実行する前に、そのコンピュータに対するライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SolidWorks 製品全体のソフトウェア ライセンスをアクティブ化します。
  • ライセンス権を別のコンピュータへトランスファー（移動）します。
  • オフィスのコンピュータ一台と自宅のコンピュータ一台に SolidWorks 製品をインストールし、アクティブ化します。
  • その場で実行する（推奨）ことも、インストレーション後 30日以内に実行することもできます。
  • ドングル（ハードウェア ロック）が不必要になります。しかし、アクティベーションを利用しない、以前のバージョンの SolidWorks 製品をご使用の場合は、ドングルが必要です。

複数のシリアル番号を管理するシステム管理者の場合、アドミニストレーティブ イメージ オプション エディタを参照してください。詳細は アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor） を参照してください。

ライセンスをアクティブ化するには:

  1. SolidWorks アプリケーションを開始します。
  2. 以下のいずれかの方法を使用し、SolidWorks製品のアクティベーション（SolidWorks Product Activation）を開始します。
    • このコンピュータのライセンスがアクティブ化されていない場合、SolidWorks製品のアクティベーション（SolidWorks Product Activation）ウィンドウはSolidWorksの開始時に自動的に表示されます。
    • SolidWorks製品のアクティベーション（SolidWorks Product Activation）ウィンドウが自動的に表示されない場合、ヘルプ > ライセンス アクティブ化をクリックしてアクティベーションを開始します。
  3. 製品（Product）リストをクリックし、ライセンスをアクティブ化する製品を指定します。
  4. インターネット経由の自動アクティベーションまたは電子メール使用のマニュアル アクティベーションを指定します。
  5. 電子メールの連絡先を入力します。
  6. 次へ（Next）をクリックし、続行します。
    • インターネットの場合:アクティベーションは自動的に行われます。
    • 電子メールの場合:保存（Save）をクリックしてリクエスト ファイルを作成し、ファイルをactivation@solidworks.comまで電子メールで送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く（Open）をクリックしてファイルを読み込みます。
      必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。
  7. 完了（Finish）をクリックします。
親トピック: 個人ライセンスの管理（Administering Individual Licenses）


ライセンス トランスファー（Transferring a License）

ライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。

ライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーできない場合（例えば、ハードドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。そうでない場合は、お客様の代理店にお問い合わせください。

ライセンスをトランスファーしてサーバーに戻すには、以下を行います。

  1. SolidWorksでヘルプ > ライセンス トランスファーをクリックし、指示に従います。
  2. 再アクティブ化するには、新しいまたはアップグレードしたコンピュータで初期のアクティベーションと同じようにライセンス アクティベーションを行います。詳細は ライセンス アクティベーション（Activating a License） を参照してください。
親トピック: 個人ライセンスの管理（Administering Individual Licenses）


SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

次のイメージは、SolidNetWorkライセンスのインストレーションを表しています。

このイメージは、以下を明らかにします。
  • SolidNetWork License Managerソフトウェアは、ライセンス マネージャー コンピュータ上のみにインストールされ、アクティブ化されます。
  • ライセンス クラインアント コンピュータには、SolidNetWork特有のソフトウェアはインストールされていません。

    インストール時にSolidNetWorkライセンスのシリアル番号を指定すると、SolidWorks Installation ManagerはそのコンピュータをSolidNetWorkライセンス クライアントとして認識します。SolidWorks Installation Managerはクライアントをライセンス マネージャーと接続させるために、SolidNetWorkライセンス マネージャー コンピュータ名とポート番号を求めるプロンプトを表示します。

  • ライセンス マネージャーとすべてのライセンス クライアントは、TCP/IP（Transmission Control Protocol/Internet Protocol）接続を必要とします。
  • SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）
    ユーザーがSolidWorks製品を各自の個人コンピュータで実行する前に、SolidNetWork License ManagerコンピュータでSolidNetWorkライセンスをアクティブ化する必要があります。
  • SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）
    SolidNetWorkライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。
  • SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
    SolidNetWorkライセンスの設定は、ライセンス マネージャー コンピュータにSolidNetWork License ManagerをインストールしてからSolidNetWorkライセンスのシリアル番号を使用してクライアント コンピュータにSolidWorksをインストールすることで構成されます。
  • SolidNetWorkライセンス管理（SolidNetWork License Administration）
    タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの取得、借入、返却が含まれます。
親トピック: ライセンス管理（License Administration）


SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）

ユーザーがSolidWorks製品を各自の個人コンピュータで実行する前に、SolidNetWork License ManagerコンピュータでSolidNetWorkライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SolidWorks製品全体のSolidNetWorkライセンスと共にSolidWorks SolidNetWork License Managerをアクティブ化します。
  • 1台のSolidNetWork License Managerコンピュータから別のコンピュータへSolidNetWorkライセンス権限をトランスファーできるようにします。
  • 1台のSolidNetWork License ManagerコンピュータにSolidNetWorkライセンス権限をインストールしてアクティブ化できるようにします。
  • SolidNetWorkライセンスを使用する前に、実行する必要があります。
  • ドングル（ハードウェア ロック）が不必要になります。このバージョンのSolidWorksのSolidNetWorkライセンスをアクティブ化すると、前のバージョンのSolidWorksのSolidNetWorkライセンスもアクティブ化されます。（ドングルを保持する必要はなくなります）。

SolidNetWorkライセンスをアクティブ化するには、以下を行います。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. まだSolidNetWorkライセンスをアクティブ化していない場合は、今すぐライセンスをアクティブ化するかどうかを確認するプロンプトが表示されます。はい（Yes）をクリックしてアクティブ化します。
  3. どのようにアクティブ化しますか?（How would you like to activate?）でインターネットを自動的に使用（推奨）（Automatically over the internet (recommended)）を選択します。
  4. 連絡情報（Contact Information）で連絡先の電子メール アドレスを指定します。
アクティベーション/再アクティベーションに成功しました（Activation/Reactivation Succeeded）ダイアログ ボックスにアクティブ化された製品の名前が表示されます。
親トピック: SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）

SolidNetWorkライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。

ライセンスをDassault Systèmes SolidWorks Corporationのライセンス キー サーバーにトランスファーできない場合（例えば、ハードドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。そうでない場合は、お客様の代理店にお問い合わせください。

SolidNetWorkライセンスをトランスファーしてサーバーに戻すには、以下を行います。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。

  2. ライセンス情報（License Information）で変更（Modify）をクリックします。SolidWorks製品のアクティベーション（SolidWorks Product Activation）ウィザードが開始されます。
  3. 何を行いますか?（What would you like to do?）でソフトウェア ライセンスのトランスファー（Transfer a software license）を選択してから、次へ（Next）をクリックします。
  4. どのようにトランスファーしますか?（How would you like to transfer?）でインターネットを自動的に使用（推奨）（Automatically over the internet (recommended)）を選択します。
  5. 連絡情報（Contact Information）で連絡先の電子メール アドレスを指定します。
  6. 次へ（Next）をクリックします。これで、製品ライセンスのトランスファーが完了します。
親トピック: SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）

SolidNetWorkライセンスの設定は、ライセンス マネージャー コンピュータにSolidNetWork License ManagerをインストールしてからSolidNetWorkライセンスのシリアル番号を使用してクライアント コンピュータにSolidWorksをインストールすることで構成されます。

  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
    SolidNetWork License Managerは、複数のラインセンス クライアント コンピューターをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。
  • ライセンス クライアントのインストール（Installing a License Client）
    SolidWorksをSolidNetWorkライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によってSolidNetWorkライセンス クライアントとして識別されます。
  • ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
    SolidNetWorkライセンス クライアント コンピュータをインストールする前に、少なくとも1台のコンピュータにSolidNetWork License Managerをインストールして設定する必要があります。
  • トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。
  • SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
    コンピュータでファイアウォールを使用している場合は、SolidNetWorkライセンスをサポートするようにポートを構成する必要があります。
親トピック: SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


License Managerのインストールとアクティベーション（Installing and Activating a License Manager）

SolidNetWork License Managerは、複数のラインセンス クライアント コンピューターをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

ライセンスのアクティベーション にハードウェア ドングルを使用した以前のバージョンの SolidNetWork License Manager をアップグレードする場合は、新しいバージョンの SolidNetWork License Manager をインストールする前にハードウェア ドングルを取り外してください。

  1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
    1. インストレーションのタイプには、以下を選択します。

      • サーバー製品（Server products）
      • SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）

    2. SolidNetWork License Manager オプション（SolidNetWork License Manager Options）ページで、SolidNetWork Licenseシリアル番号とSolidNetWork License Managerインストール オプションを指定します。
    3. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックしてSolidWorks Installation Managerのプロセスを完了します。
  2. SolidNetWorkライセンスをアクティブ化するには、以下を行います。
    1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
    2. アクティブ化を求めるプロンプトが表示されたら、はい（Yes）をクリックします。
    3. SolidNetWorkライセンス サーバー情報（SolidNetWork License Server Information）画面で以下を行います。

      • 会社でファイアウォールを使用している場合は、このサーバーのファイアウォールは使用中です（A firewall is in use on this server）を選択します。

        詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

      • ポート番号（Port Number）（およびファイアウォールを使用している場合はベンダー デーモン ポート番号（Vendor Daemon Port Number））にはデフォルト値を使用するか、または会社で使用しているポート番号を指定します。
        ポート番号は、1024 - 60000の範囲内のTCP/IPポート番号で、これは他のプロセスでは使用できません。 通常、デフォルト（25734）が好ましく、現在ライセンス マネージャー コンピュータ上にある他の FLEXnet サーバーのプロセスと一致する可能性が少ないといえます。

    4. SolidWorks製品のアクティブ化（Activate Your SolidWorks Product）画面で以下を行います。

      • インターネットか電子メールのプロセスを選択します。
      • 電子メールの連絡先を入力します。
      • 次へ（Next）をクリックし、続行します。
        • インターネットの場合: アクティベーションは自動的に行われます。
        • 電子メールの場合: 保存（Save）をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com まで送信します。 レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く（Open）をクリックしてファイルを読み込みます。
          必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。

  3. 完了（Finish）をクリックします。
親トピック: SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）


ライセンス クライアントのインストール（Installing a License Client）

SolidWorksをSolidNetWorkライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によってSolidNetWorkライセンス クライアントとして識別されます。

  1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
  2. ようこそ画面で、今回がこのメジャー リリースの初めてのSolidWorksインストレーションである場合は個人（このコンピュータ上）をクリックします。

    既存のリリースからアップグレードして個人ライセンスからSolidNetWorkライセンスに変更する場合は、個人インストレーションの変更（このコンピュータ上で実行します）（Modify the individual installation (on this computer)）をクリックします。詳細は 個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing） を参照してください。

  3. シリアル番号を求めるプロンプトが表示されたら、SolidNetWorkライセンスのシリアル番号を入力します。
  4. サーバーの追加（Add Server）ダイアログ ボックスで、SolidNetWork License Managerのアドレスを次の形式で入力します。

    port@ComputerName

    ポート番号は、ライセンス マネージャー コンピュータで使用しているものと同じでなければなりません。デフォルトは25734です（License Managerのインストールとアクティベーション（Installing and Activating a License Manager）の説明のとおりです）。

    SolidWorks Installation Managerは、このSolidNetWork License Managerがアクセス可能であることを検証しようとします。まだライセンス マネージャーをインストールしていない場合、この検証には失敗します。しかし、それでもライセンス クライアントのインストレーションは続行できます。

  5. SolidWorks Installation Managerの指示に従い、SolidWorksインストレーションを完了します。
親トピック: SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）


ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）

SolidNetWorkライセンス クライアント コンピュータをインストールする前に、少なくとも1台のコンピュータにSolidNetWork License Managerをインストールして設定する必要があります。

SolidNetWorkライセンスのシリアル番号でインストールするときに、SolidWorks Installation ManagerはSolidNetWork License Managerコンピュータ名とポート番号の入力を求めるプロンプトを表示した後で、この情報を検証しようとします。

SolidNetWork License Managerが指定したコンピュータにインストールされていない場合は、検証に失敗します。しかし、この場合、検証の失敗は正しいライセンス マネージャー情報が提供されているかどうかを示すものではありません。ライセンス マネージャーがインストールされている場合、検証の失敗は指定したライセンス マネージャー情報が間違っていることを示します。

親トピック: SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）


トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

トライアド ライセンス マネージャーの使用条件は、以下のとおりです。
  • 3個のハードウェア ドングルが必要です。
  • トライアド ライセンス マネージャーは、頻繁に再起動、またはシャットダウンがスケジュールされたコンピュータではなく、安定したコンピュータのみにインストールしてください。
  • トライアド ライセンス マネージャー コンピュータは同一のサブネット上になければなりません。トライアド ライセンス マネージャーは、通信状態の悪い状態、またはダイアルアップ リンクで構成しないでください。
  • ライセンス マネージャー コンピュータがダウンした場合、システム管理者が早急に検知でき、再起動できる状態になければなりません。
    2台のライセンス マネージャー コンピュータのみが実行されている場合、2台のコンピュータ共に問題があることになるため、ライセンス マネージャー コンピュータが1台のみの場合よりも好ましくない状況にあるといえます。
  • 最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）
    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの最初のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。
  • 残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）
    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの2台目と3台目のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。
親トピック: SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）


最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの最初のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

  1. 最初のトライアド ライセンス マネージャー コンピュータで、SolidWorks Installation Managerを使用してSolidNetWorkをインストールします。
    1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
    2. インストレーションのタイプには、以下を選択します。

      • サーバー製品（Server products）
      • SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）

    3. SolidNetWork License Manager オプション（SolidNetWork License Manager Options）ページで、SolidNetWork Licenseシリアル番号とSolidNetWork License Managerインストール オプションを指定します。
    4. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックしてSolidWorks Installation Managerのプロセスを完了します。
  2. SolidNetWork License Managerを使用し、最初のトライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
    2. いいえ（No）をクリックします。

      SolidWorks SolidNetWork License Managerのサーバー アドミニストレーション タブが表示されます。

    3. 詳細設定オプション（Advanced Options）でオプション（Options）をクリックします。

      詳細設定オプション（Advanced Options）ダイアログ ボックスが表示されます。

    4. SolidNetWorkライセンス モードでライセンス ファイル使用（Use a License File）をクリックし、OKをクリックします。

      詳細設定オプション（Advanced Options）ダイアログ ボックスが閉じます。

    5. ライセンス情報（License Information）で変更（Modify）をクリックします。

      SolidNetWorkライセンス ファイル ウィザードが表示されます。

    6. サーバー タイプ（Server Type）で3サーバー（Triad）を選択し、次へ（Next）をクリックします。
    7. サーバー情報パネルで最初のトライアド ライセンス マネージャー コンピュータのコンピュータ名、ドングルID、ポート番号が正しいことを確認し、次へ（Next）をクリックします。

      コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

    8. Triad Partner Server Information（Triad Partner Server Information）画面で、他の2台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とドングルIDの値を入力します。

      この方法では、1台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの2台のサーバーからライセンスを取得できます。

    9. ライセンス（Licenses）画面で読み取り（Read）をクリックし、SolidNetWorkライセンス ファイルまで参照し、これを開きます。

      SolidNetWorkライセンス ファイル ウィザード（SolidNetWork License File wizard）にライセンスが表示されます。

    10. 完了（Finish）をクリックします。
    11. OKをクリックしSolidNetWorkライセンス ファイル ウィザード（SolidNetWork License File wizard）を終了してから、終了（Finish）をクリックしてSolidNetWork License Managerを終了します。
親トピック: トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの2台目と3台目のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

既に別のコンピュータに少なくとも1つのトライアド ライセンス マネージャーがインストールされていることを前提とします。詳細は 最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager） を参照してください。

  1. トライアド ライセンス マネージャー コンピュータで、SolidWorks Installation Managerを使用してSolidNetWorkをインストールします。
    1. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
    2. インストレーションのタイプには、以下を選択します。

      • サーバー製品（Server products）
      • SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）

    3. SolidNetWork License Manager オプション（SolidNetWork License Manager Options）ページで、SolidNetWork Licenseシリアル番号とSolidNetWork License Managerインストール オプションを指定します。
    4. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックしてSolidWorks Installation Managerのプロセスを完了します。
  2. SolidNetWork License Managerを使用し、トライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。

      このコンピュータでSolidNetWork License Managerを実行するのは今回が初めてであるため、今すぐアクティブ化するかどうかを確認するプロンプトが表示されます。

    2. いいえ（No）をクリックします。

      SolidWorks SolidNetWork License Managerのサーバー アドミニストレーション タブが表示されます。

    3. 詳細設定オプション（Advanced Options）でオプション（Options）をクリックします。

      詳細設定オプション（Advanced Options）ダイアログ ボックスが表示されます。

    4. SolidNetWorkライセンス モードでライセンス ファイル使用（Use a License File）をクリックし、OKをクリックします。

      詳細設定オプション（Advanced Options）ダイアログ ボックスが閉じます。

    5. ライセンス情報（License Information）で変更（Modify）をクリックします。

      SolidNetWorkライセンス ファイル ウィザードが表示されます。

    6. サーバー タイプ（Server Type）で3サーバー（Triad）と同期サーバー/ライセンス情報（Synchronize server/license information）を選択してから、次へ（Next）をクリックします。
    7. サーバー情報パネルで、このトライアド ライセンス マネージャー コンピュータのコンピュータ名、ドングルID、ポート番号が正しいことを確認し、次へ（Next）をクリックします。

      コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

    8. Triad Partner Server Information（Triad Partner Server Information）画面で、他の2台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とドングルIDの値を入力します。

      この方法では、1台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの2台のサーバーからライセンスを取得できます。

    9. ライセンス（Licenses）画面で読み取り（Read）をクリックし、SolidNetWorkライセンス ファイルまで参照し、これを開きます。

      通常、ライセンス ファイルは設定した最初のトライアド ライセンス マネージャー コンピュータの\licenses\sw_d.licにあります。

      SolidNetWorkライセンス ファイル ウィザード（SolidNetWork License File wizard）にライセンスが表示されます。

    10. 完了（Finish）をクリックします。

      SolidNetWorkライセンス ファイル ウィザードの警告が表示されます。

    11. OKをクリックしSolidNetWorkライセンス ファイル ウィザード（SolidNetWork License File wizard）を終了してから、終了（Finish）をクリックしてSolidNetWork License Managerを終了します。

2台目のトライアド ライセンス マネージャー コンピュータを設定したら、このプロセスを3台目のトライアド ライセンス マネージャー コンピュータに対しても繰り返してください。

親トピック: トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

コンピュータでファイアウォールを使用している場合は、SolidNetWorkライセンスをサポートするようにポートを構成する必要があります。

ファイアウォールのソフトウェアで、2つのSolidNetWorkライセンス ポート（例えば、SNL-in-portとSNL-out-port）をファイアウォールの例外リストに追加する必要があります。これらのポートを構成する方法の詳細については、システム管理者に相談してください。

Windows XP SP2およびWindows Server 2003 SP1でWindowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでポートを変更し、SolidNetWorkライセンス ファイルを変更してライセンスをライセンス クライアント コンピュータに配布する必要があります。

  • Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）
    Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。
  • WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）
    Windowsファイアウォールを使用している場合は、ファイアウォールのポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWorkライセンス ファイルを変更する必要があります。
親トピック: SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）


Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。

  1. Windowsでコントロール パネルを開き、セキュリティ センター（Security Center）をダブル クリックします。
  2. Windows ファイアウォール（Windows Firewall）をクリックします。
  3. 例外（Exceptions）タブでポートの追加（Add Port）をクリックします。
  4. 名前（Name）（例えば、SNL-in-port）とポート番号（Port Number）（例えば、25734）を入力してから、OKをクリックします。
  5. 2つ目のポートのために、例外（Exceptions）タブのポートの追加（Add Port）を再びクリックし、残りのポートの名前と番号（例えば、SNL-out-portと25735）を指定してから、OKをクリックします。後からSolidNetWorkライセンス ファイルを変更する際等に参照ができるように、ポート番号をメモしてください。

    Workgroup PDMを使用する場合は、Workgroup PDMのポート番号をWindowsファイアウォールで変更する必要があります。通常、これらのポートは20000（VaultAdmin）、30000（Data）、40000（Request）、および80（Viewer）となります。

  6. Windowsセキュリティ センターとコントロール パネルを閉じます。
親トピック: SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

Windowsファイアウォールを使用している場合は、ファイアウォールのポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWorkライセンス ファイルを変更する必要があります。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. サーバー アドミニストレーション（Server Administration）タブのライセンス サーバー（License Server）で停止（Stop）をクリックします。（確認を求めるプロンプトが表示されたら、はい（Yes）とOKをクリックし、ライセンス サーバーの停止を完了します）。
  3. ライセンス情報（License Information）で変更（Modify）をクリックします。
  4. サーバー タイプ（Server Type）でネットワークのサーバー配置（単一（Single）または3サーバー（Triad））を選択してから、次へ（Next）をクリックします。
  5. サーバー情報（Server Information）で以下を行います。
    1. このサーバーのファイアウォールは使用中です（A firewall is in use on this server）を選択します。
    2. ポート番号とベンダー デーモン ポート番号には、Windowsファイアウォールに指定したポート番号が含まれていなければなりません（詳細については、Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）を参照してください）。
    3. 次へ（Next）をクリックし、終了（Finish）をクリックします。
  6. サーバー アドミニストレーション（Server Administration）タブのライセンス サーバー（License Server）で開始（Start）をクリックします。
  7. OKをクリックしてSolidNetWork License Managerを閉じます。
親トピック: SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


SolidNetWorkライセンス管理（SolidNetWork License Administration）

タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの取得、借入、返却が含まれます。

  • SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
    SolidNetWork License ManagerはWindowsのスタート（Start）メニューから開始できます。
  • SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
    SolidWorksメジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWorkライセンスの再アクティブ化で構成されます。
  • SolidNetWorkライセンス ファイルの削除（Deleting SolidNetWork License Files）
    新しいSolidNetWorkライセンス ファイルにアップグレードする前に、古いまたは有効期限の切れたファイルを削除してください。
  • クライアント ライセンスの回収（Retrieving Client Licenses）
    クライアントのSolidNetWork接続を終了するために、システム管理者はライセンスを停止し、これをフリーのライセンス プールに戻すことができます。
  • SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。
  • ライセンスのアイドル状態の監視（Monitoring License Idle Time）
    SolidWorksはSolidNetWork License Managerのアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。
  • 一時的なライセンスのインストール（Installing Temporary Licenses）
    一時的な"ANY"ライセンスは、オリジナルのSolidNetWorkライセンスが使用できない場合に一時的に使用できます。
  • 個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）
    SolidWorks個人ライセンスからSolidNetWorkライセンスにコンピュータをアップグレードするには、SolidWorks Installation ManagerでSolidNetWorkライセンスのシリアル番号を指定します。
  • SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
    SolidNetWork License Managerを使用し、SolidWorksコア アドイン製品（例えば、FeatureWorks、Workgroup PDM Serverなど）のライセンスを配布できます。
  • ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
    ネットワーク上の1台のコンピュータがSolidNetWorkライセンスを配布するライセンス マネージャー、およびユーザーがそこからSolidWorksソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。
  • FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）
    SolidNetWorkライセンスは、FLEXnet Publisher®ライセンス管理に基づいています。
親トピック: SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

SolidNetWork License ManagerはWindowsのスタート（Start）メニューから開始できます。

  • Windowsで次のコマンドを実行します： スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager.
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

SolidWorksメジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWorkライセンスの再アクティブ化で構成されます。

新しいリリース用のライセンス マネージャーは、以前のリリースを保持しているクライアント コンピュータのライセンスも配布できます。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスの使用状況（License Usage）タブで、SolidWorksを実行しているクライアント コンピュータがネットワーク上にないことを確認します。
  3. 古いライセンス マネージャーをアンインストールします。詳細は SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager） を参照してください。
  4. 新しいライセンス マネージャーをインストールし、ライセンス マネージャー コンピュータでSolidNetWorkライセンスを再アクティブ化します。詳細は License Managerのインストールとアクティベーション（Installing and Activating a License Manager） を参照してください。

SolidWorksアプリケーションを同時に実行しているコンピュータでSolidNetWork License Managerをアップグレードする場合は、そのコンピュータにSolidWorksアプリケーションの新しいServicePackをインストールする前にSolidNetWorkライセンス マネージャーとクライアントをアップグレードします。

アドミニストレーティブ イメージをホストするコンピュータでライセンス マネージャーをアップグレードする場合は、アドミニストレーティブ イメージをアップグレードする前にライセンス マネージャーをアップグレードします。詳細は ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations） を参照してください。

  • SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager）
    SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager）

SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. SolidWorksを実行しているクライアント コンピュータがネットワーク上にないことを確認します。

    ライセンスの使用状況（License Usage）タブにはSolidWorksを実行しているクライアントが表示されます。

  3. SolidNetWorkライセンスを別のコンピュータにトランスファーする場合は、コンピュータからSolidNetWork License Managerを削除する前にライセンスを別のコンピュータにトランスファーしてください。

    SolidNetWorkライセンスのトランスファーに関する情報については、SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）を参照してください。

  4. サーバー アドミニストレーション（Server Administration）タブのライセンス サーバー（License Server）で停止（Stop）をクリックします。
  5. OKをクリックし、ライセンス マネージャーを閉じます。
  6. Windowsでコントロール パネル > プログラムの追加と削除を開きます。
  7. SolidWorks SolidNetWork License Managerを選択し、削除（Remove）をクリックして削除を確認します。
  8. WindowsエクスプローラでSolidWorks SolidNetWork License Managerのフォルダーを削除します。

    （通常、このフォルダーはSolidWorksインストレーション ディレクトリのProgram Filesにあります）。

これで、新しいバージョンのライセンス マネージャーのインストールを行う準備が整いました。 詳細は License Managerのインストールとアクティベーション（Installing and Activating a License Manager） を参照してください。

SolidNetWork License Manager コンピュータにハードウェア ドングルが取り付けられている場合は、新しいバージョンの SolidNetWork License Manager をインストールする前に、ハードウェア ドングルを取り外します。
親トピック: SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）


SolidNetWorkライセンス ファイルの削除（Deleting SolidNetWork License Files）

新しいSolidNetWorkライセンス ファイルにアップグレードする前に、古いまたは有効期限の切れたファイルを削除してください。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. サーバー アドミニストレーション（Server Administration）タブのライセンス ファイル（License File）で変更（Modify）をクリックします。続いて次へ（Next）をライセンス（Licenses）画面が表示されるまでクリックします。
  3. ライセンス（Licenses）画面で古いまたは期限の切れたSolidNetWorkライセンス ファイルを選択してから、削除（Remove）をクリックします。
  4. 終了（Finish）をクリックし、次にOKをクリックします。
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


クライアント ライセンスの回収（Retrieving Client Licenses）

クライアントのSolidNetWork接続を終了するために、システム管理者はライセンスを停止し、これをフリーのライセンス プールに戻すことができます。

  • クライアントは、最低2分はライセンス マネージャーに接続している必要があります。
  • SolidNetWorkのタイムアウト機能は、最低15分に設定できます。15分のアイドル状態の後で、そのライセンスはフリーのライセンス プールに戻されます。

詳細については、SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdfを参照してください。

  1. スタート > ファイル名を指定して実行をクリックし、cmdと入力してから、OKをクリックしてWindowsのコマンド ウィンドウを開きます。
  2. コマンド ウィンドウで次を入力します。

    cd SolidNetWork_License_Manager_install_dir\utils lmutil lmremove feature user computer display

    ここで、feature、user、computer、およびdisplayは、SolidNetWork License Managerのライセンスの使用状況タブに表示される項目です。

    例えば:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    各アドイン製品（PhotoView 360、FeatureWorksなど）のライセンスは個別に終了する必要があります。

親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

借入ライセンスは、借りたシステムでのみ有効で、トランスファーすることはできません。

ライセンスは指定期間中（30日間まで）、（またはシステム管理者によって定義された日数）貸し出すことができ、ライセンスは使用可能なライセンスのプールから取り除かれます。

システム管理者はライセンスの借入を次のようにカスタマイズできます。
  • ライセンスを借りることのできるユーザーやグループを定義する
  • 借りることのできないライセンスの数を設定する

詳細については、SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdfを参照してください。

  • SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）
    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。
  • 借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）
    借りたSolidNetWorkライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。

ライセンスを借りるには（使用は必須ではありません）、SolidNetWorkライセンス マネージャーに接続している必要があります。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスを借りるタブで以下を行います。
    1. 借りる期限（Borrow until）で日付を指定します。
    2. 借りる製品ライセンスを選び、借りる（Borrow）をクリックし、続いてはい（Yes）もクリックして確認します。
    3. 更新（Refresh）をクリックします。期限切れ期日（Expire Date）列は、ライセンスの期限を示します。
  3. OK をクリックします。
SolidWorksを実行するには、SolidWorksライセンスを借りる必要があります。SolidWorks ProfessionalとSolidWorks Premiumのライセンスは、パッケージと関連付けられたアドインのみを有効にします（SolidWorksアプリケーションは有効になりません）。
親トピック: SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）


借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

借りたSolidNetWorkライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  1. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスを借りるタブで以下を行います。
    1. 戻す製品ライセンスを選び、戻す（Return）をクリックし、確認のためにはい（Yes）をクリックします。
    2. 更新（Refresh）をクリックします。期限切れ期日（Expire Date）は空欄になり、ライセンスが戻されたことを示します。
  3. OK をクリックします。
有効期限が過ぎたライセンスを戻す必要はありません。有効期限最終日の真夜中になると、ライセンスは自動的にSolidNetWorkライセンス マネージャーのライセンス プールに戻され、リモート システム上にあるアプリケーションは実行できなくなります。
親トピック: SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）


ライセンスのアイドル状態の監視（Monitoring License Idle Time）

SolidWorksはSolidNetWork License Managerのアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. ファイルに次のラインを追加します。

    TIMEOUTALL seconds

    ここで、secondsは900（15分）（許容最少時間）、またはそれ以上の数値となります。

親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


一時的なライセンスのインストール（Installing Temporary Licenses）

一時的な"ANY"ライセンスは、オリジナルのSolidNetWorkライセンスが使用できない場合に一時的に使用できます。

"ANY"ライセンス ファイルのインストールにより、お客様は Dassault Systèmes SolidWorks Corporation から SolidNetWork ライセンスを受け取った際、従来のライセンスの履行に同意することになります。この場合も、ライセンス制限への応諾が必要となります。

"ANY"ライセンスをインストールするには、以下を行います。

  1. 既存のSolidNetWorkユーザーである場合、SolidNetWork License Managerのアンインストールを行い、インストレーション フォルダーを削除します。詳細は SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager） を参照してください。
  2. SolidWorks Installation Managerを開始します（SolidWorksインストレーションの開始（Initiating SolidWorks Installation）の手順に従います）。
    1. インストレーションのタイプには、以下を選択します。

      • サーバー製品（Server products）
      • SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）

    2. SolidNetWork License Manager オプション（SolidNetWork License Manager Options）ページで、SolidNetWork Licenseシリアル番号とSolidNetWork License Managerインストール オプションを指定します。
    3. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックしてSolidWorks Installation Managerのプロセスを完了します。
  3. SolidNetWork License Managerを開始します（スタート > すべてのプログラム > SolidWorks バージョン > SolidNetWork License Manager > SolidNetWork License Manager）。
  4. アクティブ化を求めるプロンプトが表示される場合は、いいえ（No）をクリックします。

    SolidWorks SolidNetWork License Managerのサーバー アドミニストレーション タブが表示されます。

  5. 詳細設定オプション（Advanced Options）でオプション（Options）をクリックします。

    詳細設定オプション（Advanced Options）ダイアログ ボックスが表示されます。

  6. SolidNetWorkライセンス モードでライセンス ファイル使用（Use a License File）をクリックし、OKをクリックします。

    詳細設定オプション（Advanced Options）ダイアログ ボックスが閉じます。

  7. ライセンス情報（License Information）で変更（Modify）をクリックします。

    SolidNetWorkライセンス ファイル ウィザードが表示されます。

  8. サーバー タイプ（Server Type）で単一（Single）を選択し、次へ（Next）をクリックします。
  9. 次のメッセージが表示される場合は、以下を行います。

    ドングルのID番号が読み取れませんでした。（Could not read the dongle ID number.）
    キャンセル（Cancel）をクリックします。
    IDとして"ANY"が自動的に表示されます。
    コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

  10. インストレーションを続行します。
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

SolidWorks個人ライセンスからSolidNetWorkライセンスにコンピュータをアップグレードするには、SolidWorks Installation ManagerでSolidNetWorkライセンスのシリアル番号を指定します。

コンピュータにSolidWorksがインストールされていない場合は、SolidWorks Installation ManagerでインストールするときにSolidNetWorkシリアル番号を入力することでSolidNetWorkライセンスを指定できます。

SolidWorksが既にインストールされたコンピュータで個人ライセンスからSolidNetWorkライセンスに切り替える場合は、クライアント コンピュータのインストレーションの変更を行い、SolidWorks Installation Managerの実行時に個人ライセンスのシリアル番号の代わりにSolidNetWorkライセンスのシリアル番号を指定します。詳細は インストレーションの変更（Modifying an Installation） を参照してください。

親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

SolidNetWork License Managerを使用し、SolidWorksコア アドイン製品（例えば、FeatureWorks、Workgroup PDM Serverなど）のライセンスを配布できます。

  • SolidWorksソフトウェアのライセンス数とSolidWorksアドインのライセンス数が同じである必要はありません。
  • アドイン製品のライセンスをチェックアウトするには、最初にSolidWorksのライセンスをチェックアウトする必要があります。
  • アドイン製品ライセンスを借りるには、SolidWorks ソフトウェア ライセンスと、アドイン製品を含む SolidWorks 製品ライセンスの両方を借りる必要があります。 例えば、SolidWorks Professional あるいは SolidWorks Premium 製品のライセンスを借りる必要があります。
  • アドイン製品ライセンスをリリースするには、以下を行います。
    • SolidWorksでツール > アドインをクリックし、アドインを選択解除します。
    • SolidWorksを終了します。
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

ネットワーク上の1台のコンピュータがSolidNetWorkライセンスを配布するライセンス マネージャー、およびユーザーがそこからSolidWorksソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

クライアント コンピュータはライセンス マネージャーからライセンスを入手し、次に同じコンピュータからSolidWorksをインストールできます。

このコンフィギュレーションでは、同じコンピューターにライセンス マネージャーとアドミニストレーティブ イメージ の両方をインストールする必要があります。最初にライセンス マネージャーのインストールを行い、次にアドミニストレーティブ イメージの作成と展開を行います。
詳細は次を参照してください：
  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
  • 複数クライアントへの展開（Deploying to Multiple Clients）
親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）

SolidNetWorkライセンスは、FLEXnet Publisher®ライセンス管理に基づいています。

FLEXnet Publisherライセンス管理の詳細については、SolidNetWork License Managerインストレーション ディレクトリにあるFLEXnet Publisher License Administration Guide（SolidNetwork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

FLEXnet Publisherライセンス管理の最新情報については、Acresso® Softwareまでお問い合わせください。

親トピック: SolidNetWorkライセンス管理（SolidNetWork License Administration）


トラブルシューティング（Troubleshooting）

インストレーションの問題のトラブルシューティングに役立てるため、これらのトピックを参考にしてください。

  • SolidWorks Installation Managerログ ファイル（SolidWorks Installation Manager Log Files）
    SolidWorks Installation Managerログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。
  • SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）
    SolidWorks Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。このトピックには、ダウンロード フォルダーに関するよくある質問（FAQ）とそれに対する回答が掲載されています。
  • SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
    SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。
  • アップグレードのトラブル シューティング（Troubleshooting Upgrades）
    新しいSolidWorksリリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。


SolidWorks Installation Managerログ ファイル（SolidWorks Installation Manager Log Files）

SolidWorks Installation Managerログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

これらのログ ファイルは、その他のSolidWorksアプリケーションのログ ファイルと同じ場所にあります。
  • Windows Vista 移行の場合：

    C:\Users\ユーザー名\AppData\Roaming\SolidWorks\Installation Logs\installed_version

  • Vistaより前のWindowsオペレーティング システム バージョンの場合：

    C:\Documents and Settings\ユーザー名\Application Data\SolidWorks\Installation Logs\installed_version\

ログ ファイルのディレクトリを表示するには、Windowsのフォルダ オプションをすべてのファイルとフォルダを表示する（Show hidden files and folders）に設定する必要があるかもしれません。

アプリケーション データがC:以外のドライブにある場合は、これに応じて適切にディレクトリ パスを調整してください。

このディレクトリには、SolidWorks Installation Managerプログレスの全般的なログであるSummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txtファイルがあります。

Other Logsサブディレクトリには、より詳細なインストレーション ログ情報が含まれています。

親トピック: トラブルシューティング（Troubleshooting）


SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）

SolidWorks Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。このトピックには、ダウンロード フォルダーに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

  1. このフォルダーにあるファイルをインストールするには?
  2. msiexecや他のアプリケーションを使用してMSIファイルをこのフォルダーからマニュアルでインストールできますか?
  3. 各々のバージョンのインストールに同じダウンロード フォルダーを選択して良いですか?
  4. 一部の製品はDassault SystèmesのSolidWorks Corporation Webサイトからダウンロードしてあります。これらもInstallation Managerでインストールできますか?
  5. ダウンロードしたファイルは他のユーザーと共有できますか?
  6. いつ新しいバージョンのSolidWorksを使用できるか知りたいのですが?
  7. Installation ManagerではSW2006やSW2007のインストールのみが表示され、現在のバージョンが表示されません。
  8. Installation Managerで別の製品のServicePackのインストールを指定することができません。
  9. Installation Managerによるファイルのダウンロードが妨げられます。
  10. 一部のSolidWorks製品が最新のServicePackバージョンまでアップデートされませんでしたが、アップデート チェック（Check For Updates）を実行すると、最新バージョンになっていると伝えてきます。
  11. DVDをダウンロード フォルダーにコピーして良いですか?

このフォルダーにあるファイルをインストールするには?

setup.exeを実行します。以前ダウンロードされたことの無いアイテムをインストールするように選択した場合は、追加ファイルのダウンロードが必要な場合があります。

msiexecを使用してインストールしないでください（下記参照）。

上に戻る

msiexecや他のアプリケーションを使用してMSIファイルをこのフォルダーからマニュアルでインストールできますか?

いいえ、Installation Managerではmsiexecの実行に必要なファイルの一部がダウンロードされません。

上に戻る

各々のバージョンのインストールに同じダウンロード フォルダーを選択して良いですか?

ダウンロード フォルダーはバージョン固有のものです。SolidWorks 2010を開始すると、SolidWorks Installation Managerは指定されたフォルダー内にバージョン固有のサブフォルダーを自動的に作成します。

上に戻る

一部の製品はDassault SystèmesのSolidWorks Corporation Webサイトからダウンロードしてあります。これらもInstallation Managerでインストールできますか?

SW2009から、マニュアルでダウンロードしたファイルをSolidWorks Installation Managerで使うことができます。しかし、ファイルをダウンロードするオプションを選択して、SolidWorks Installation Managerを実行するほうが適切です。SolidWorks Installation Managerは各ファイルをダウンロードするためにリンクを提供し、インストールしているものに基づいてどのファイルを必要とするかを表示します。組み込みのダウンロードページが機能しないとき、このオプションを使用してください（プロキシ サーバによって実施されたダウンロード制限などがあるときです）。
Microsoft Internet Explorerによってダウンロードまたはインストレーション中にファイルを保存するか、または実行するかを確認された場合は、必ず保存を指定してください。

上に戻る

ダウンロードしたファイルは他のユーザーと共有できますか?

はい。そのためには、共有ネットワーク上にダウンロードします。続いて、各クライアントが共有ネットワークからSolidWorks Installation Managerを実行し、インストールすることができます。

初期のダウンロードに含まれていないアイテムがユーザーによって選択されていない、またはダウンロードをインストールに使用するコンピュータがファイルをダウンロードするコンピュータとは異なる前提条件のセットを持っていない限り、追加のダウンロードは必要ありません。

インストールは行わず、他のユーザーのためにダウンロードを行う場合は、インストール時にダウンロードのみ（Download Only）オプションを選択します。このオプションを選択すると、システム上にインストールされていない製品も選択することができます。ただし、パッチをダウンロードする場合、アドミニストレーティブ イメージを作成する場合は、このオプションを使用することはできません。

上に戻る

いつ新しいバージョンのSolidWorksを使用できるか知りたいのですが?

次の場合において、新しいバージョンが使用できるようになった際に通知を受けることができます。
  • アップデート チェックを実行した場合（スタート > すべてのプログラム > SolidWorks Installation Manager > アップデート チェック）
  • SolidWorksバックグラウンド ダウンローダーを有効にした場合
  • Windowsのプログラムの追加と削除（Add/Remove programs）でインストールされているSolidWorksのバージョンを選択し、変更（Change）をクリックした場合。
  • ダウンロード フォルダーで古いバージョンのInstallation Manager（sldIM.exe）を実行した場合。
これらの場合、新しいバージョンのダウンロードを選択することができます。SolidWorks Installation Managerは新しいバージョンのInstallation Manager（インストレーション ファイルでは無く）をダウンロードし、実行します。新しいバージョンのSolidWorks Installation Managerが実行された後、インストレーションの詳細を指定することができます。続いて、SolidWorks Installation Managerによって必要なインストレーション ファイル（これまでにダウンロードされていないファイル）が確定され、これらのファイルをダウンロードするかどうかを尋ねられます。

上に戻る

SolidWorks Installation Manager では SW2006 や SW2007 のインストールのみが表示され、現在のバージョンが表示されません。

現在のリリースではサポートされない古いバージョンのSolidWorks Installation Managerが実行されています。古いバージョンのInstallation ManagerではSW2006とSW2007のServicePackのみをダウンロードできます。

上に戻る

SolidWorks Installation Managerで別の製品のServicePackのインストールを指定することができません。

意図的にそうなっています。それぞれのバージョンのSolidWorks Installation Managerは、特定バージョンのSolidWorks製品のみをインストールするように設計されています。別のバージョンのServicePackをインストールするには、そのバージョンのSolidWorks Installation Managerを実行する必要があります。利用可能な最新のバージョンを検索するには、 いつ新しいバージョンのSolidWorksを使用できるか知りたいのですが?（How do I know when a new version of SolidWorks products becomes available?）を参照してください。

上に戻る

SolidWorks Installation Managerによるファイルのダウンロードが妨げられます。

プロキシサーバの制限がアプリケーションがファイルをダウンロードするのを妨げる場合、SolidWorks Installation Managerは自動的にファイルをダウンロードすることができません。

マニュアルでファイルをダウンロードして、次にSolidWorks Installation Managerを使ってそれらをインストールすることができます。個々のファイルをダウンロードするにはSolidWorks Installation Managerのオプションを選択します（例えば、ダウンロード オプション（Download Options）ページのマニュアル ダウンロード実行（Conduct manual download））。製品選択とシステム必要条件に基づいて、マニュアルでダウンロードするすべての必要なファイルのリンクを含むWebページが、別のウィンドウに表示されます。これらのリンクはSolidWorks Customer Portalによって提供されたものとまったく同じです。しかしファイルを探す必要はありません。

上に戻る

一部のSolidWorks製品が最新のServicePackバージョンまでアップデートされませんでしたが、アップデート チェック（Check For Updates）を実行すると、最新バージョンになっていると伝えてきます。

アップデート チェック（Check For Updates）は最新バージョンのSolidWorks Installation Managerがインストールされているか（あるいは実行されているか）のみを伝えてきます。

すべての製品を最新バージョンまでアップデートしたい場合は、プログラムの追加と削除（Add/Remove Programs）でインストールされているSolidWorksの最新バージョンを選択し、変更（Change）をクリックしてください。

上に戻る

DVDをダウンロード フォルダーにコピーして良いですか?

はい、しかし該当するプラットフォーム（x86またはx64）用にリリースされた各DVDの全内容をコピーしない限り、インストレーションが失敗する場合があります。SolidWorks Installation Managerはバージョンを決定するためにファイルswdata*.idを探します。これらのファイルが無い場合は、コピーした、ダウンロードが必要なインストレーション ファイルが認識されません。

上に戻る

親トピック: トラブルシューティング（Troubleshooting）


SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

  • SolidNetWorkライセンス ログ ファイルへのアクセス（Accessing the SolidNetWork License log files）
    ライセンス エラーの原因は、ほとんどの場合、SNL_Manager_インストール_ディレクトリ\lmgrd.logファイルに表示されています。
  • SolidWorksのライセンスを取得できない場合。（Could not obtain a license for SolidWorks.）ライセンス サーバーに接続できない場合。(Cannot connect to license server.)
    一般に、この問題はポートの設定によって生じます。
親トピック: トラブルシューティング（Troubleshooting）


SolidNetWorkライセンス ログ ファイルへのアクセス（Accessing the SolidNetWork License log files）

ライセンス エラーの原因は、ほとんどの場合、SNL_Manager_インストール_ディレクトリ\lmgrd.logファイルに表示されています。

親トピック: SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）


SolidWorksのライセンスを取得できない場合。（Could not obtain a license for SolidWorks.）ライセンス サーバーに接続できない場合。(Cannot connect to license server.)

一般に、この問題はポートの設定によって生じます。

  • SolidNetWorkライセンス マネージャーとライセンス クライアントとで一致していないポート設定を使用している場合が考えられます。
  • 複数バージョンのSolidNetWorkライセンス マネージャーで必要な追加のポート設定が指定されていない場合が考えられます。
SolidNetWorkライセンス マネージャーとクライアントのポート設定に関する詳細については、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。
親トピック: SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）


アップグレードのトラブル シューティング（Troubleshooting Upgrades）

新しいSolidWorksリリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

  • 移動されたソースからアップグレードする場合（Upgrading from a Source That Has Moved）
    SolidWorksがインストールされると、SolidWorks Installation Managerはインストレーション ソース（ディスク メディア、ネットワーク上のディスク イメージなど）を記憶します。更新する際、このソースがアクセス可能であることを前提とします。
親トピック: トラブルシューティング（Troubleshooting）


移動されたソースからアップグレードする場合（Upgrading from a Source That Has Moved）

SolidWorksがインストールされると、SolidWorks Installation Managerはインストレーション ソース（ディスク メディア、ネットワーク上のディスク イメージなど）を記憶します。更新する際、このソースがアクセス可能であることを前提とします。

ソースが移動/削除されている、あるいはソース メディアが変更されている場合、SolidWorks Installation Manager はエラーメッセージを表示します。しかし、必要なすべてのソース ファイルが同じフォルダー階層で移動されている場合は、そこまで参照し、アップグレードを続行できます。

親トピック: アップグレードのトラブル シューティング（Troubleshooting Upgrades）


SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）

SolidWorks Installation Manager は SolidWorks 製品をインストール/更新する、スタンドアロン アプリケーションです。

SolidWorks Installation Manager は、次のように実行することができます:
  • SolidWorks DVD、共有ソース、またはダウンロード フォルダー（新規バージョンのインストール時）あら
  • コントロール パネルのプログラムの追加と削除ページ（既存のバージョンの変更または削除時）から
  • スケジュールまたはマニュアルによるアップデート チェック（新規リリース バージョンの検出、ダウンロード、インストール時）を介して

各バージョンのSolidWorksには、そのバージョン特有のSolidWorks Installation Managerがあります。

SolidWorks 2008より前のバージョンでは、SolidWorks 2007のInstallation Managerを使用してください。または、SolidWorksサポート ウェブサイトからマニュアルで製品バージョンをダウンロードしてください。
  • SolidWorksバックグラウンド ダウンローダー（SolidWorks Background Downloader）
    SolidWorksバックグラウンド ダウンローダーは、新しいサービスパックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。
  • アップデート チェックの結果（Check for Updates Results）
    アップデート チェックは、SolidWorksの最新バージョンを探します。
  • アドミニストレーティブ イメージ位置（Administrative Image Location）
    アドミニストレーティブ イメージのインストール場所を指定します。
  • ダウンロード オプション（Download Options）
    ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。
  • SolidWorks Installation Managerファイルのダウンロード オプション（Download Options for SolidWorks Installation Manager Files）
    より新しいバージョンのSolidWorks Installation Managerをダウンロードします。この画面で、ファイルをどこからどのようにダウンロードするかを指定します。
  • 製品のインストレーション ファイルをダウンロード（Download Product Installation Files）
    指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。
  • ダウンロードの進捗状況（Download Progress）
    SolidWorks Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。
  • ダウンロード結果（Download Results）
    ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。
  • インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
    インストレーションでエラーが発生し、キャンセルされました。
  • インストレーション完了（Installation Is Complete）
    SolidWorks Installation Managerは、その処理を完了しました。
  • インストール先（Installation Location）
    SolidWorksのインストール先を指定します。
  • 更新オプション（Upgrade Options）
    現在、このコンピュータには1つまたは複数の古いSolidWorksメジャー バージョンがインストールされています。 最も新しい既存のバージョンを新しいバージョンにアップグレードするか、または新しいバージョンのために新しいインストレーションを作成するかを選択します。
  • インストールの進行状況（Installation Progress）
    この画面にはインストレーションの進捗状況が表示されます。
  • インストレーション タイプ（Installation Type）
    新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。
  • 複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）
    SolidWorks Installation Managerは複数コンピュータのインストールと管理のために次のツールを提供します。
  • マニュアル ダウンロード（Manual Download）
    ファイルをマニュアルでダウンロードすることを選択しました（または最後にSolidWorks Installation Managerを実行したときにマニュアルでダウンロードすることを選択しました）。
  • 利用可能なより新しいバージョン（Newer Version Available）
    Installation Managerは、より新しいバージョンのSolidWorks製品を検知します。オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。
  • 利用可能な新しいバージョンはありません（No New Versions Available）
    ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。
  • 検出されたプロセス（Processes Detected）
    SolidWorks Installation Managerは正常なインストレーションを妨げる可能性のあるプロセスを検出しました。
  • 製品選択（Product Selection）
    インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。
  • ダウンロードする製品（Products to Download）
    指定された場所にダウンロードするように SolidWorks 製品を選択します。
  • 修復する製品（Products to Repair）
    このインストレーションを修復（Repair this installation）を指定すると、画面にはこのバージョンのSolidWorks Installation Managerで修復可能なSolidWorks製品名とバージョン番号が表示されます。
  • シリアル番号（Serial Numbers）
    シリアル番号（パッケージ上にあります）は、購入したSolidWorks製品をご使用のコンピュータに関連付けます。
  • サーバー インストール（Server Installation）
    インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。
  • SolidNetWork License Manager
    SolidNetWork License Managerサーバー製品のインストール オプションを指定します。
  • サマリー（Summary）
    SolidWorks Installation Managerには、インストレーション作業を完了するために必要な情報がすべてあります。
  • システム チェックの警告（System Check Warnings）
    システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。ほとんどの場合は、SolidWorks Installation Managerを続行できるはずです。
  • 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
    SolidWorks Toolboxがインストールされている場合、SolidWorksは穴タイプと汎用部品の標準ライブラリを含みます。
  • 製品のアンインストール（Uninstall Products）
    削除（Remove）あるいはアンインストール（Uninstall）をコントロール パネル（Control Panel）から選択すると、画面にはこのバージョンの SolidWorks Installation Manager でアンインストールできる SolidWorks 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。
  • Workgroup PDM Serverオプション（Workgroup PDM Server Options）
    SolidWorks Workgroup PDM Server 製品のインストール オプションを指定します。


SolidWorksバックグラウンド ダウンローダー（SolidWorks Background Downloader）

SolidWorksバックグラウンド ダウンローダーは、新しいサービスパックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。

SolidWorksバックグラウンド ダウンローダーは、SolidWorks Installation Managerを用いてSolidWorksのインストールを行うと、デフォルトで有効になります。

インストールやダウンロードのためにSolidWorks Installation Managerを実行している間は、SolidWorksバックグラウンド ダウンローダーは一時停止します。たとえば、実行中のダウンロードを一時停止し、新たなダウンロードの開始やダウンロード フォルダ指定の変更等を禁止します。

SolidWorksバックグラウンド ダウンローダーは、SolidWorksのインストール時にデフォルトで有効になります。SolidWorksのインストール時にサマリー ページのダウンロード オプションを変更（バックグラウンド ダウンローダーを使用しますか?（Do you want to use the Background Downloader?）オプションを選択解除）すると、SolidWorksバックグラウンド ダウンローダーを無効にすることが可能です。

有効な場合には、Windowsのシステム トレイに次のアイコンが表示されます：

このアイコンをクリックすると、次のオプションが有効になります：
  • バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）
  • ダウンロード一時停止（Pause Download）
  • ダウンロード再開（Resume Download）
  • ダウンロード キャンセル（Cancel Download）
  • インストレーション オプション（Installation Options）
  • ダウンロード先の変更（Change Download Location）
  • アップデート チェック（Check for Updates）
  • アップデートを自動的にチェック（Automatically Check for Updates）
  • アップデート自動ダウンロード（Automatically Download Updates）
  • バックグラウンド ダウンローダー無効化（Disable Background Downloader）

バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）

SolidWorksインストレーション ガイド（SolidWorks Installation Guide）内のバックグラウンド ダウンローダーに対する本ヘルプ トピックを開きます。

ダウンロード一時停止/再開（Pause/Resume Download）

バックグラウンドでダウンロードを実行している場合は、ダウンロード一時停止（Pause Download）のクリックによりダウンロードの一時停止が行えます。このダウンロードはダウンロード再開（Resume Download）のクリックにより再開できます。

ダウンロード キャンセル（Cancel Download）

実行中のダウンロードを停止し、バックグラウンド ダウンローダーがダウンロードしたすべてのファイルを削除します。
キャンセルしたダウンロードは再開できません。

インストレーション オプション（Installation Options）

ダウンロードが完了したら、次のオプションが選択できます：
  • 今すぐインストール（Install now）：ダウンロードしたファイルをインストールします。
  • 後で通知（Remind me later）：ダウンロードしたファイルをインストールせず、後から実行を促すための通知メッセージを設定します。
  • このダウンロードﾞを削除（Delete this download）：ダウンロードしたファイルをインストールせずに削除します。（本機能は、ダウンロードしたファイルのインストールが無用となった場合に有効です。）

ダウンロード先の変更（Change Download Location）

バックグラウンド ダウンローダーによるファイルのダウンロード先を変更します。

ダウンロードの実行中や一時停止中には、本オプションは利用できません。

アップデート チェック（Check for Updates）

SolidWorks Installation Managerのアップデート チェック（Check for Updates）機能を実行します。

アップデートを自動的にチェック（Automatically Check for Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には通知します。

アップデート自動ダウンロード（Automatically Download Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には、それらをダウンロードします。

SolidWorksバックグラウンド ダウンローダーの無効化と再有効化（Disabling and Re-Enabling SolidWorks Background Downloader）

アイコンをクリックし、バックグラウンド ダウンローダー無効化（Disable Background Downloading）を選択することにより、バックグラウンド ダウンローダーを無効にすることが可能です。

バックグラウンド ダウンローダーを再度有効にするには、スタート > すべてのプログラム > SolidWorks Installation Manager > SolidWorksバックグラウンド ダウンローダーをクリックします。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


アップデート チェックの結果（Check for Updates Results）

アップデート チェックは、SolidWorksの最新バージョンを探します。

アップデート チェックは、マニュアルで実行できます。
  • Windowsでスタート > プログラム > SolidWorks Installation Manager > アップデート チェックをクリックします。
  • SolidWorksでヘルプ > アップデート チェックをクリックします。
アップデート チェックは、アドミニストレーティブ イメージからインストールしたクライアントでは利用できません。

利用可能なより新しいバージョン（Newer Version Available）

SolidWorks Installation Managerは、より新しいバージョンのSolidWorks製品を検知します。より新しいバージョンのSolidWorks Installation Managerを選択することで、新しいバージョンに更新できます。

より新しいバージョンでは、インストレーションで指定した製品に基づいてインストレーション ファイルをダウンロードできます。ダウンロードしたファイルはSolidWorks Installation Managerを使用してインストールを行う他のユーザーと共有することができます。

これらのダウンロードは、SolidWorks Installation Managerのみで利用できます。
次のオプションを利用できます。
  • 複数のバージョンが利用可能な場合、リストから選択できます。
  • このバージョンの詳細については、アップグレードに含まれるアイテムのチェック（Check to see what this upgrade includes）をクリックします。
次へ（Next）をクリックすると、選択したバージョンのSolidWorks Installation Managerを入手して実行します。

利用可能な新しいダウンロードはありません/新しいバージョンをチェックすることができません（No New Downloads Available/Unable to Check for New Versions）

SolidWorks Installation ManagerはSolidWorks製品の新しいバージョンを見つけられません。これは、利用可能な最新のバージョンがインストール済みであるか、またはSolidWorksのサイトに接続してチェックできなかったかのどちらかです。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


アドミニストレーティブ イメージ位置（Administrative Image Location）

アドミニストレーティブ イメージのインストール場所を指定します。

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置（New image location）
これは、SolidWorks Installation Managerが新規イメージを作成するディレクトリ位置です。
この位置には、既存のアドミニストレーティブ イメージを含められません。アドミニストレーティブ イメージは、クライアント向けに共有可能なフォルダにある必要があります。
イメージ作成に必要なスペースの推定サイズ（Estimated space required for image creation）
これは、アドミニストレーティブ イメージに必要となる追加スペースです。
インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元（Create image from）
これは、SolidWorks製品のインストール元となるディレクトリ位置です。
このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。詳細は ダウンロード オプション（Download Options） を参照してください。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


ダウンロード オプション（Download Options）

ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

SolidWorks Installation ManagerはESD（electronic software distribution、電子ソフトウェア配布）方式をサポートします。SolidWorksをDVDからインストールしない場合は、インストールするSolidWorks製品のソースを指定する必要があります。

ダウンロード フォルダーに関する質問の答えについては、SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）を参照してください。

何を行いますか?（What do you want to do?）

次のいずれかを選択します。
ダウンロードとインストール/ダウンロードとイメージ作成
ダウンロードの完了後、SolidWorks Installation Managerはダウンロード ファイルを使用してインストレーションを実行します。
ダウンロードのみ。ダウンロードを1度行い、ダウンロード ファイルを複数コンピュータで共有できます。
SolidWorks Installation Managerはダウンロードの完了後にインストレーションを実行しません。

通常、このオプションは複数のコンピュータ間で共有するインストレーション ファイル セットを構成するためにファイルをダウンロードする場合のみに指定します。

このオプションを指定すると、ダウンロードする2つのファイル セットからの選択を求められます。
  • 当コンピュータ用のファイル（Files for THIS computer）：ダウンロードには、現在コンピュータ上にあるインストレーション ファイル セットにないファイルのみが含められます。
    このダウンロードには以下が含まれるため、そのサイズは小さくなるはずです。
    • 製品選択ページで選択した製品のファイルのみ
    • コンピュータに必要な未インストールの前提条件ファイルのみ

    しかし、このダウンロード ファイル セットを別のコンピュータで使用してインストレーションを実行しようとすると、いくつかのファイルが見つからないかもしれません（なぜなら、別のコンピュータ上のインストレーション ファイル セットがこのコンピュータのものと異なる可能性があるからです）。このダウンロード ファイルを使用して別のコンピュータへインストールすることは可能ですが、インストレーションの実行時に追加のファイルをダウンロードし、そのコンピュータのインストレーション ファイル セットを完全にする必要があるかもしれません。

  • 任意のコンピュータで共有できるファイル（Files to share with ANY computer）：ダウンロードには、このバージョンを任意のコンピュータにインストールするために使用できる完全なインストレーション ファイル セットが含まれます。

    このダウンロードには、このバージョンの任意の製品を任意のコンピュータにインストールするために使用できる完全なファイル セットが含まれているため、そのサイズは大きくなります。

    限られた製品セットをダウンロードするように指定している場合、このオプションはその指定を無視して製品リリースに含まれるすべての製品をダウンロードします。

    ダウンロードには、個人インストレーションを実行するために必要となるファイルだけでなく、アドミニストレーティブ イメージを作成するために必要となるすべてのファイルが含まれます。

インストールのみ/イメージ作成のみ。必要なインストレーション ファイルは既にすべて持っています。
SolidWorks Installation Managerはファイルをいっさいダウンロードしないで、選択したディレクトリにあるファイルを使用します。

参照（Browse）をクリックし、別の場所に移動します。例えば、その場所に必要なファイルがすべて含まれている場合は、インストレーションDVDまたはダウンロード フォルダーまで参照します。

すべてのインストレーション ファイルがその場所にあると思われたのに、フォルダーが不完全であるとするメッセージが表示される場合は、以下が考えられます。
  • 前にダウンロードされなかったインストーレーションのコンポーネントを選択したか、またはそのコンポーネントがデフォルトで選択された。
  • ファイルはシステム必要条件の異なる設定で別のコンピュータにダウンロードされた。
  • 以前はクライアント インストレーションを実行しており、今回は多くのファイル セットが必要となるアドミニストレーティブ イメージを作成している。

すべてのファイルを含むフォルダー（例えば、DVD）まで参照するか、またはダウンロード オプションのいずれかを選択できます。

必要なファイルをどこにダウンロードしますか?（Where do you want to download the required files?）

これは、ダウンロード フォルダーの場所です。

場合によっては、このオプションが無効になった状態で表示されることもあります。例えば、インストールのみ（Install only）を指定した場合、SolidWorks Installation Managerは個別のダウンロード フォルダーを使用するのではなく、そのオプションに対して指定されたディレクトリのダウンロード ファイルをインストールします。

これらのファイルをダウンロードする場合、あるいは独自の位置からアクセスしている場合でも、すべてのファイルを同じダウンロード フォルダーにダウンロードする必要があります。

推定ダウンロード サイズ（Estimated download size）

推定ダウンロードの必要なディスク スペースは、これが新規のダウンロードであるか、または前のセッションからのダウンロードを再開しているかどうかにかかわらず、選択された完全なコンポーネント リストに基づいています。

例えば、もし前回のダウンロードを再開しているなら、SolidWorks Installation Managerはただダウンロードされなかったファイルだけを処理します。ダウンロード時間は推定より短くなる可能性があります。

前回のダウンロードでファイルのダウンロードが完了している場合も、そのサイズは推定に含められません。したがって、推定は実際のダウンロード サイズよりも大きい可能性があります。

どのようにダウンロードしますか?（How do you want to download?）

2つのオプションがあります。
マニュアル ダウンロード実行
場合によっては、プロキシ サーバーによってSolidWorks Installation Managerからの自動ダウンロードが禁止されていることもあります。
このオプションを選択することで、WebページからファイルをマニュアルでダウンロードしてからSolidWorks Installation Managerを続行し、インストレーション動作を完了できます。このWebページは、インストレーションの完了に必要なファイルのみがダウンロードされるようにSolidWorks Installation Managerによってユーザー定義されます。
ネットワークの高帯域幅を使用してダウンロード速度を向上
ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。

場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。

このオプションは自動ダウンロードのみに適用されます。マニュアル ダウンロードには影響しません。

SolidWorksバックグラウンド ダウンローダーの使用（Using SolidWorks Background Downloader）

ダウンロード処理の完全実行や、SolidWorksのサービスパックがリリースされた際のダウンロードには、SolidWorksバックグラウンド ダウンローダー用いることが可能です。

SolidWorksバックグラウンド ダウンローダーでは、新しいサービスパックの検出とダウンロードをバンクグラウンドで実行することが可能です。ダウンロードが完了し、ファイルのインストール準備が整うと、その内容が通知されます。詳細は SolidWorksバックグラウンド ダウンローダー（SolidWorks Background Downloader） を参照してください。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


SolidWorks Installation Managerファイルのダウンロード オプション（Download Options for SolidWorks Installation Manager Files）

より新しいバージョンのSolidWorks Installation Managerをダウンロードします。この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

ダウンロード フォルダーに関する質問の答えについては、SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）を参照してください。

この画面はデフォルトのダウンロード フォルダーに問題がある場合のみに表示されます（例えば、書き込みアクセスまたはネットワーク アクセスを利用できない場合など）。通常、続行するには代替のダウンロード ディレクトリをただ指定するだけです。

ダウンロード ディレクトリ（Download Directory）

SolidWorks Installation Managerファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード アクセラレータを使用（Use Download Acceleration）

このオプションを選択した場合、ダウンロード速度を速くするためのアルゴリズムが使用されます。

ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になります。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

SolidWorks Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

このスクリーンをキャンセルすると、残りのインストレーション シーケンスもキャンセルされます。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラー（Installation Errors）を参照してください。

ダウンロード ディレクトリ（Download Directory）

ダウンロード ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード フォルダーに関する質問の答えについては、SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）を参照してください。

ダウンロード オプション（Download Options）

ネットワークの高帯域幅を使用してダウンロード速度を向上
ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。

場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。

ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になる場合もあります。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


ダウンロードの進捗状況（Download Progress）

SolidWorks Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

ダウンロードを実行中にキャンセルするにはキャンセル（Cancel）をクリックします。

ダウンロードをキャンセルするかまたはダウンロードに失敗すると、ダウンロード中止（Download Canceled）またはダウンロードの問題（Download Problem）画面にどのダウンロードが完了されていないかが表示され、ダウンロードを再開するかまたはアプリケーションを終了できるようになります。

ダウンロード フォルダーに関する質問の答えについては、SolidWorks Installation Managerダウンロード フォルダ（SolidWorks Installation Manager Download Folder）を参照してください。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


ダウンロード結果（Download Results）

ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

ダウンロードの問題/ダウンロード中止（Download Problem/Download Cancelled）

ダウンロードの問題（Download Problem）は、SolidWorks Installation Managerがダウンロードの完了を妨げる問題と遭遇した場合に表示されます。

ダウンロード中止（Download Cancelled）は、ユーザーがダウンロードが完了する前に中止した場合に表示されます。

続行するには、以下を行います。

自動ダウンロードの再試行/再開
中止した時点から自動ダウンロードを再開するには、このオプションを選択してダウンロードを再試行（Retry Download）またはダウンロードを再開（Resume Download）をクリックします。
Webブラウザで個々のファイルをダウンロード
場合によっては、プロキシ サーバーによってSolidWorks Installation Managerからの自動ダウンロードが禁止されていることもあります。
このオプションを選択することで、WebページからファイルをマニュアルでダウンロードしてからSolidWorks Installation Managerを続行し、インストレーション動作を完了できます。このWebページは、インストレーションの完了に必要なファイルのみがダウンロードされるようにSolidWorks Installation Managerによってユーザー定義されます。

ダウンロード完了（Download Complete）

ダウンロード完了画面は、ダウンロードのみ（Download Only）オプションを指定した場合にダウンロードが完了すると表示されます。

終了（Finish）をクリックし、SolidWorks Installation Managerを終了します。

これらの製品のマニュアル インストールは試みないでください。必ずSolidWorks Installation Managerを使用してダウンロードしたファイルをインストールしてください。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

インストレーションでエラーが発生し、キャンセルされました。

エラーまたはキャンセルが発生した場合は:
  • エラーまたはキャンセルが発生する前にインストールされた製品はコンピュータに残ります。
  • エラーまたはキャンセルが発生した際にインストールされていた製品は、可能な場合はロールバックされ、部分的なインストレーションが残らないようにします。
  • 残りの製品はインストールされないか、またはアンインストールされます。まだ実行されていません（Not Yet Attempted）の下にリストが表示されます。

    これらの製品をインストールを再開するか、またはアンインストールするには、表示されたリンクをクリックします。

SolidWorks Installation Managerはまずコンピュータにインストールされていないすべての前提条件（例えば .NET Framework など）をインストールします。続いて、選択されている製品が次の順番でインストールされます:
  1. SolidWorks
  2. eDrawings
  3. SolidWorks 検索
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • 失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）
    インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。
  • インストールの修復（Repairing an Installation）
    もしインストールされたSolidWorks 製品の問題があるならば、SolidWorks インストールマネージャーをインストールを修復するために使うことができます。
  • 代理店への問い合わせ（Contacting the SolidWorks Reseller）
    インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の代理店までご連絡ください。SolidWorks Installation Managerのログ ファイルをZip圧縮して提供する必要がある場合もあります。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）

インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。

  1. インストレーションが失敗した場合は、インストレーション エラー（Installation Errors）およびインストレーションのキャンセル（Installation Cancelled）画面に表示されるエラー メッセージと製品コード番号を記録してください。

    既存のSolidWorksインストレーションを変更していないときにソース ファイルに対するプロンプトが表示される場合は、インストレーションまたはコンピュータが破損している可能性があります。お客様の代理店までご連絡ください。

  2. コンピューターを再起動します。
  3. SolidWorks製品が実行されていないことを確認するために、WindowsでCtr+Alt+Delキーを押してタスク マネージャを開きます。
  4. プロセス（Processes）タブでイメージ名（Image Name）に次のいずれかのプロセスが表示されている場合は、選択し、プロアセスの終了（End Process）をクリックします。

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. アプリケーションが既にインストールされており、変更/削除する場合は、インストレーションの修復を試みます。詳細は インストールの修復（Repairing an Installation） を参照してください。
  6. Windows Vista かそれ以降で スタート > コントロール パネル >プログラムと機能 をクリックします。 以前の Windows では スタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。
  7. 失敗したバージョンの SolidWorks を選択します。

    インストールするSolidWorksのバージョンが表示されない場合は、インストレーション プロセスを繰り返してください。

  8. 次のいずれかを行います：
    • 再試行するには、変更（Change）をクリックし、インストールに失敗した、あるいはインストレーション中にスキップされたすべての製品を選択します。

    • 失敗したインストレーションをスキップするには、変更（Change）をクリックし、インストレーション中にスキップされたすべての製品を選択します。インストールに失敗した製品を選択解除します。

    • インストレーションを中止するには、削除（Remove）をクリックし、インストールされたすべての製品を選択します。

    このプロセスでは、アップグレードしていた製品の前バージョンまでは回復されません。

親トピック: インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）


代理店への問い合わせ（Contacting the SolidWorks Reseller）

インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の代理店までご連絡ください。SolidWorks Installation Managerのログ ファイルをZip圧縮して提供する必要がある場合もあります。

  1. ログ ファイルを探します：
    • Vistaより前のWindowsオペレーティング システム バージョンの場合：

      C:\Documents and Settings\ユーザー名\Application Data\SolidWorks\Installation Logs\installed_version\

    • Windows Vista 移行の場合：

      C:\Users\ユーザー名\AppData\Roaming\SolidWorks\Installation Logs\installed_version\

    フォルダーが見つからない場合は、隠しフォルダーになっている場合があります。Windowsエクスプローラでツール > フォルダ オプションをクリックします。表示（View）タブの詳細設定（Advanced Settings）で、ファイルとフォルダの表示（Hidden files and folders）ですべてのファイルとフォルダを表示する（Show hidden files and folders）を選択します。

  2. サブフォルダーを含め、このフォルダーのすべてのコンテンツをZip圧縮します。
親トピック: インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）


インストレーション完了（Installation Is Complete）

SolidWorks Installation Managerは、その処理を完了しました。

以下の1つまたは複数のオプションが表示されるかもしれません。

新規機能（What's New）

個人インストレーションの場合は、インストレーション手順を完了した際に、SolidWorksとアドイン製品の新規機能を説明するドキュメントが表示されます。

アドミニストレーティブ イメージ インストレーションの場合は、クライアントがインストレーションを完了した際に、クライアントのコンピュータ上にドキュメントが表示されます。

アンケート（Survey）

インストレーション プロセスに関する短いアンケートにご協力ください。

SolidWorks ユーザー パフォーマンス フィードバック プログラム（Join the SolidWorks Customer Experience Improvement Program）

パフォーマンス インフォメーションが、製品改善の手助けの為に SolidWorks Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 以下のいずれかを選択します:
  • はい、参加します
  • いいえ、参加しません
  • 後で通知
詳細については、Customer Experience Improvement Program Web サイトを参照してください。

アドミニストレーティブ イメージの作成が完了しました（Administrative Image Creation Is Complete）

アドミニストレーティブ イメージの作成が完了したら、イメージのカスタマイズ（Customize Image）をクリックすることによりアドミニストレーティブ イメージ オプション エディタを起動し、イメージをカスタマイズすることが可能です。

オプション エディタの使用方法を表示するには、クライアントにイメージをインストールする方法を表示します。（Show me how to install this image on a client.）をクリックしてください。

オプション エディタを使用してアドミニストレーティブ イメージを設定する方法の詳細については、アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）を参照してください。

アドミニストレーティブ イメージ オプション エディタを起動し、アドミニストレーティブ イメージに対するオプション設定をカスタマイズするには、イメージのカスタマイズ（Customize Image）をクリックします。
オプション エディタは、アドミニストレーティブ イメージのインストール ディレクトリにあるsldAdminOptionEditor.exeをダブルクリックにより、後から起動することも可能です。
  • SolidWorksに対するアップデート チェック（Checking for Updates to SolidWorks）
    SolidWorks Installation Managerを使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。
  • SolidWorks ユーザー パフォーマンス フィードバック プログラム（SolidWorks Customer Experience Improvement Program）
    SolidWorksのインストール時には、SolidWorks Corporationにパフォーマンス情報を送信し製品改良に役立てることが選べます。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


SolidWorksに対するアップデート チェック（Checking for Updates to SolidWorks）

SolidWorks Installation Managerを使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  1. 次のいずれかを実行してSolidWorks Installation Managerを開始します:

    • SolidWorksアプリケーションで、ヘルプ > アップデート チェックをクリックします。

    • Windowsでスタート > プログラム > SolidWorks Installation Manager > アップデート チェックをクリックします。

    SolidWorks Installation Managerは利用できるアップデートがあるかどうかを通知します。

  2. 利用できるアップデートがある場合は、ダウンロードしてインストールするかどうかを選びます。
  3. 定期的な自動アップデート チェックを有効にするには、SolidWorks Installation Managerがそのプロセスを完了したときに___日毎に更新をチェックします（Check for Updates every __ days）を選択し、チェックの頻度を指定します。
親トピック: インストレーション完了（Installation Is Complete）


SolidWorks ユーザー パフォーマンス フィードバック プログラム（SolidWorks Customer Experience Improvement Program）

SolidWorksのインストール時には、SolidWorks Corporationにパフォーマンス情報を送信し製品改良に役立てることが選べます。

SolidWorksはこの情報を製品の使用と品質に関する傾向を特定するために使用します。SolidWorksのゴールは最高品質の製品を提供することにあり、パフォーマンス ログをその実現に有効なツールです。

このプロセスでは透明性が確保されています。ログ ファイルに含まれるすべての情報は機密情報として扱われます。その他の目的で使用されることは無く、お客様に連絡が入ることもありません。

詳細については、Customer Experience Improvement Program Web サイトを参照してください。

親トピック: インストレーション完了（Installation Is Complete）


インストール先（Installation Location）

SolidWorksのインストール先を指定します。

アドミニストレーティブ イメージの作成を除いて、インストレーションには以下のオプションが適用されます。
選択製品を次へインストールします（Install selected products to）
これは、SolidWorksをインストールするディレクトリの場所です。
インストレーションのアップグレードまたは変更時には、すべてのファイルをそのインストレーションの既存の場所にインストールする必要があります。この場合、既存のSolidWorksインストレーションの場所は変更できません。
インストレーションに必要なスペースの推定サイズ（Estimated space required for installation）
これは、インストレーションまたは変更のために選択された製品に対して必要となる追加スペースです。
インストール先のディスクにインストレーションの要件をサポートするのに十分な空きスペースがあることを確認してください。
インストール元（Install from）
これは、SolidWorksのインストール元となるディレクトリ位置です。
このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。詳細は ダウンロード オプション（Download Options） を参照してください。
どちらのSolidWorksインストール位置についても変更する前に、システム管理者に相談してください。

アドミニストレーティブ イメージの位置（Administrative Image Locations）

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置（New image location）
これは、SolidWorks Installation Managerが新規イメージを作成するディレクトリ位置です。
この位置には、既存のアドミニストレーティブ イメージを含められません。
イメージ作成に必要なスペースの推定サイズ（Estimated space required for image creation）
これは、アドミニストレーティブ イメージに必要となる追加スペースです。
インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元（Create image from）
これは、SolidWorks製品のインストール元となるディレクトリ位置です。
このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。詳細は ダウンロード オプション（Download Options） を参照してください。
既存イメージ位置（Existing image location）
既存のアドミニストレーティブ イメージをアップグレードするとき、SolidWorks Installation Managerは既存のイメージの設定に基づいて新規イメージを作成します。この既存のイメージは変更されません。これは、ようこそ（Welcome）画面で指定した元のイメージの場所を示します。

特定のバージョンのディレクトリ パスの使用回避（Avoid Using Version-Specific Directory Paths）

インストレーション ディレクトリの位置にバージョン番号を指定してから（例えば、C:\Program Files\SolidWorks Corp\SolidWorks 2010\）このインストレーションをSolidWorks 2011にアップグレードすると、SolidWorks 2011のインストレーション ディレクトリにSolidWorks 2010というラベルが付きます。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


更新オプション（Upgrade Options）

現在、このコンピュータには1つまたは複数の古いSolidWorksメジャー バージョンがインストールされています。 最も新しい既存のバージョンを新しいバージョンにアップグレードするか、または新しいバージョンのために新しいインストレーションを作成するかを選択します。

この選択は、このメジャー リリースの以前のバージョンがコンピュータにインストールされていない場合のみ表示されます。 このメジャー リリースの以前のバージョンがインストールされている場合、SolidWorks Installation Managerは必ずそのインストレーションをアップデートします。

（SolidWorks 2010以降、同じメジャー リリースの複数のServicePackのパラレル インストレーションはサポートされなくなりました）。

アップグレード時には、以下が行われます。
  • 指定したすべての製品がアップグレードされます。
  • インストール済みのすべての製品がデフォルトで選択されます。
  • 製品を選択解除すると、その製品はアップグレードされません。
    製品コンポーネントを選択解除しても、そのコンポーネントを削除するようにSolidWorks Installation Managerに指定したわけではありません。 製品コンポーネントを削除するには、インストレーションの削除（Removing an Installation）の説明にあるように、プログラムの追加と削除（Add/Remove Programs）を使用します。

適切なオプションを選択し、次へ（Next）をクリックして続行します。

SolidWorks versionの新規インストレーションを作成します。

このオプションを選択すると、このメジャー バージョンの新しいインストレーションが作成されるほか、古いメジャー バージョン インストレーションが保持されます。

これは、新しいバージョンのインストール後もSolidWorksの古いバージョンにアクセスしたい場合に役立ちます。 例えば、古いバージョンを実行し続けている他のユーザーとファイルを共有する場合、新しいバージョンを使用して保存したファイルのバージョンの互換性の問題を回避できます。

SolidWorks previous_major_versionからSolidWorks current_major_versionへアップグレードします。

このオプションを選択すると、古いバージョンのインストレーションが新しいバージョンにアップグレードされます。
インストレーションの完了後、古いSolidWorksバージョンはこのコンピュータで利用できなくなります。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


インストールの進行状況（Installation Progress）

この画面にはインストレーションの進捗状況が表示されます。

インストレーションの開始後にキャンセルするには、キャンセル（Cancel）をクリックします。

キャンセルの影響や中断されたインストレーションを完了するための手順については、インストレーション エラー（Installation Errors）を参照してください。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


インストレーション タイプ（Installation Type）

新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。

個人（Individual）

SolidWorks製品をこのコンピュータへインストールします。

このオプションは、このバージョンがコンピュータにインストールされていない場合のみに表示されます。

個人インストレーションの変更（Modify the individual installation）

既存のSolidWorksインストレーションをこのコンピュータ上で変更します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
変更には以下が含まれます。
  • SolidWorks製品コンポーネントの追加または削除
  • 異なるSolidWorksパッケージへの変更（例えば、SolidWorks Professional、SolidWorks Premiumなど）
  • SolidWorksシリアル番号設定の変更
    前回のインストレーションでSolidWorksシリアル番号を既に指定している場合も、SolidWorks Installation Managerはシリアル番号の指定を求めるかもしれません。SolidWorks Installation Managerによって仮定されたシリアル番号を変更するには、このオプションを選択する必要があります。

個人インストレーションの修復（Repair the individual installation）

既存のSolidWorksインストレーションをこのコンピュータ上で修復します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。
個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを使用して再インストールする必要があります。

アドミニストレーティブ イメージ（Administrative image）

このコンピュータでアドミニストレーティブ イメージの作成または更新を行います。

アドミニストレーティブ イメージを使用し、複数のコンピュータにインストールできます。アドミニストレーティブ イメージを使用して複数のクライアントにSolidWorksをインストールする方法については、アドミニストレーティブ イメージの使用（Using Administrative Images）を参照してください。

アドミニストレーティブ イメージを作成またはアップデートするときは、以下を行えます。
  • 既存イメージのインストレーション設定を使用し、新規またはアップデートされたイメージを設定するか、あるいはデフォルトのSolidWorksインストレーション設定を使用できます。
  • 既存のイメージをアップデートする場合:
    • アップデートする場合も、SolidWorks Installation Managerはイメージの新規コピーを作成します。元のイメージは変更されません。
    • アップデートする既存のイメージのファイルを使用し、アップデートされたイメージを作成できます。この結果、ダウンロード サイズが小さくなります。
    以前のイメージをアップデートするためにServicePackリリースを利用できるイメージを指定しなかった場合、サイズの小さいダウンロードを利用することはできません。
  • コンピュータには32ビットおよび64ビットのアドミニストレーティブ イメージが作成できます。または、コンピュータのハードウェア アーキテクチャに対応するイメージのみを作成することも可能です。
    32ビットと64ビットのイメージを両方指定する場合は、インストールを完了するまでに両方のアーキテクチャ用のSolidWorksインストレーション メディアが必要となります。

サーバー製品（Server products）

SolidWorksアドミニストレーティブ サーバー製品には、SolidWorks Workgroup PDM Server（Vault）とSolidNetWork License Managerが含まれます。

これらの製品の詳細については、次を参照してください：
  • Workgroup PDM
  • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

ダウンロードのみ（Download only）

製品をインストールしないで、選択した SolidWorks 製品のインストレーション ファイルをダウンロードします。

このオプションはDVDからインストレーションを行っているときは表示されません。

ダウンロード ファイルの内容は、SolidWorksインストレーションDVDで利用できるファイルと同じものです。このオプションを選択すると、どのファイルが既にコンピュータにインストールされているかにかかわらず、インストール ファイルの完全なセットがダウンロードされます。

この方法を使用してサーバーをセット アップし、このサーバーからユーザーはインストレーションを実行できます。これはアドミニストレーティブ イメージを作成することとは異なります。

コンピュータと異なるSolidWorksアーキテクチャのインストール（Installing the wrong SolidWorks architecture for this computer）

使用しているコンピュータのアーキテクチャと異なるSolidWorksインストレーション メディアを用いてインストールを試みた（たとえば、32ビットのコンピュータに64ビットのSolidWorksをインストール使用した）場合、インストレーション パネルには問題が報告されます。

インストレーションを継続するには：
  1. このSolidWorks Installation Managerセッションを終了します。
  2. 使用中のコンピュータのアーキテクチャとシステム要件を確認します。
  3. このコンピュータのアーキテクチャに対応するSolidWorksインストレーション メディア用い、再度インストールを実施します。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


マニュアル ダウンロード（Manual Download）

ファイルをマニュアルでダウンロードすることを選択しました（または最後にSolidWorks Installation Managerを実行したときにマニュアルでダウンロードすることを選択しました）。

リンクをクリックし、ダウンロードを完了するために必要なファイルの完全なリストを含む自動生成されたWebページを開きます。

サマリー ページで指定したフォルダーにダウンロードする必要があります。インストレーションは、すべてのファイルがフォルダーにダウンロードされるまで開始できません。

マニュアル ダウンロードを終えたら、次へ（Next）をクリックして続行します。

自動的にダウンロードしたい場合は、サマリー ページに戻ってダウンロード オプションを変更することでオプションを変更できます。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


利用可能なより新しいバージョン（Newer Version Available）

Installation Managerは、より新しいバージョンのSolidWorks製品を検知します。オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

DVDからインストールする場合（If You Are Installing from a DVD）

より新しいバージョンを使用しますか?（Would you like to use the newer version?）で以下のいずれかを選択します。
  • いいえ、このDVDからのversionのインストールを継続します。その後で少量のダウンロードを行って更新することができます。（No, continue installing version from this DVD. You can update afterwards with a smaller download.）

    このオプションは、現在のInstallation Managerを使用してインストレーションを続行する場合に選択します。

    インストレーションが完了した後は、Installation Managerを使用してアップデートをチェックしてインストールすることができます。アップデートをチェックするには、スタート > SolidWorks Installation Manager > アップデート チェックを実行します。

    この場合の利点は、ダウンロードが最小限になることです。不利な点は、これが2ステップの過程になり、ダウンロードしたファイルが特定のバージョン用になる点です（他のバージョンを使用しているユーザーと共有はできません）。

  • はい、このDVDを使用してインストールを行います。続いて、ダウンロードして次までのアップデートを行います version（Yes, perform installation using this DVD, then download and update to version）

    SolidWorks製品の最新のバージョンをインストールするために、このオプションを選択し、最新のバージョンのInstallation Managerをダウンロードして起動します。

    小さなServicePackリリースを利用してDVDバージョンをアップデートできる場合、Installation Managerは最初にDVDから元のバージョンをインストールし、次にServicePackアップデートを適用します。この結果、ダウンロード サイズが小さくなります。

    DVDからインストールを続行するオプションを選択してから、後日アップデートを適用しても同じ結果を得られます。

    このオプションの利点は、これが1ステップの過程であることです。

通常、完全なバージョンをDVDからインストールし、Installation Managerを使用して更新をチェックし、インストールすることが最小限のファイルをダウンロードする点で推奨されます。

ダウンロードからインストールする場合（If You Are Installing from a Download）

次のいずれかを選択します。
  • versionのインストールを続行します。（Continue installing version.）

    このオプションを選択し、初期のダウンロードに含まれるバージョンのインストールを続行します。

  • 新しいバージョンのダウンロードとインストール: version（Download and install a new version: version）

    このオプションを選択し、新しいバージョンをダウンロードし、インストールします。もし複数の新しいバージョンがあるなら、ダウンロードしてインストールするバージョンを選択できます。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


検出されたプロセス（Processes Detected）

SolidWorks Installation Managerは正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • インストレーションを続行するには、以下のいずれかを行います。
    • 例えば、Microsoft Windowsタスク マネージャを使用してプロセスを終了してから、再試行（Retry）をクリックします。
    • 無視（Ignore）をクリックし、プロセスを終了しないまま続行します。
  • インストレーションを中止するには、キャンセル（Cancel）をクリックします。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


製品選択（Product Selection）

インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。

製品リストは以下のようになります。
  • 製品リストは、製品リスト上で指定されたパッケージで利用できる製品の完全なリストです。
  • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
  • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。（たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
  • インストレーションの変更を行っている場合、製品選択で変更を行うとアスタリスク（*）がコンポーネントの左に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

ServicePack を適用している場合、SolidWorks の下に表示される FeatureWorks などの SolidWorks 機能は選択できません。 これは、このタイプの更新を行う時に、機能の追加/削除ができないためです。

SolidWorks Installation Manageは製品の共存ルール（product coexistence rules）に従って機能します。 詳細は 製品の共存ルール（Product Coexistence Rules） を参照してください。

SolidWorks Installation Managerは以下の製品をデフォルトで選択します。
  • アップグレードまたはSevicePackアップデートを実行している場合、SolidWorks Installation Managerは現在インストールされている製品を選択します。
  • そうでない場合、SolidWorks Installation Managerは権限のあるすべての製品を選択します。
インストレーションまたはダウンロードの時間と必要なディスク スペースを減らすために、製品コンポーネントを展開して不要なコンポーネントのチェックボックスを選択解除します。

SolidWorks Installation Managerが権限のある製品を確認できない場合、別のパッケージ/製品の選択（Select different packages or products）をクリックしてインストールまたは変更する製品のパッケージ（例えば、SolidWorks ProfessionalまたはSolidWorks Premiumなど）のリストを変更できます。 SolidWorks Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上のSolidWorks 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

SolidWorks 検索

SolidWorks 検索機能は、SolidWorks ドキュメント、 Workgroup PDM ボルトと 3D ContentCentral の強力で完全なテキスト検索を提供します。 検索機能は、プレビューとファイルの場所と名前を示します。

インストレーションの後で、 SolidWorks 検索は、より速い検索のために SolidWorks ドキュメントにインデックスを付けます。 デフォルトでは、SolidWorks ファイルのインデックス ファイルのみが作成されます。

SolidWorks検索はWindowsデスクトップ サーチがすでにコンピュータの上にインストールされていない場合、自動的にそれをインストールします。

言語サポート（Language Support）

SolidWorks 製品と言語（Language）コンポーネントを展開し、インストール可能な言語版を表示します。

言語（Languages）はインストールされる言語を SolidWorks 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 例えば、SolidWorks eDrawings(R)、SolidWorks Workgroup PDM、SolidWorks Explorer ではすべての言語版がインストールされます。

必要なスペース（Space Needed）

SolidWorks Installation Manager はページの一番下に合計のインストレーションサイズ、あるいは、合計のダウンロードサイズを表示します。

  • ダウンロードのみ（Download Only）オプションを選択した場合は、ダウンロード サイズが表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。
    インストレーションに必要なすべてのファイルは合計のダウンロード サイズに含まれます。 もしいくつかのファイルが既に現在のダウンロードフォルダにダウンロードされている場合、それらは再びダウンロードされません。 結果として、実際のダウンロードサイズは表示された合計サイズより小さくなることがあります。または、まったくファイルのダウンロードが必要ないときもあります。
  • そうでない場合、インストレーションサイズ(installation size)が現れます。 インストレーション サイズは、このインストレーションを完了したときに生じるディスク スペース使用量で変わります。 ファイル圧縮のため、これらの数字は推定です。

    既存のインストレーションをアップグレード、または削除する場合、インストレーション サイズは0（ゼロ）になります。

    表示される数字は、インストレーションに必要である場合もファイルをダウンロードする、または解凍するために必要なスペースを含みません。

    ダウンロードが必要で、同じドライブにダウンロードしている場合、実際に必要とされるディスク スペースは表示されるインストレーション サイズよりも著しく大きくなります。

    将来の更新作業でのダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


ダウンロードする製品（Products to Download）

指定された場所にダウンロードするように SolidWorks 製品を選択します。

ダウンロードで利用可能な製品は与えられたシリアルナンバーによって決まります：

  • 各コンポーネントに対して行われるアクションは、各項目の右側に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
  • 各コンポーネントの左にあるチェックボックスをクリックし、SolidWorks Installation Managerが行う処理を指定します。
指定しない場合、SolidWorks Installation Managerは使用権があるすべての製品のコンポーネントをダウンロードします。 ダウンロード時間と必要なディスク スペースを減らすために、製品コンポーネントを展開し、ダウンロードする必要のないコンポーネントを指定します。

SolidWorks Installation Managerが権限のある製品を確認できない場合、SolidWorksパッケージをダウンロードするように選ぶことができます。 SolidWorks Installation Manager は、選択するパッケージと互換性があるすべての SolidWorks 製品をリストします。

SolidWorks Installation Managerが権限のある製品を確認できない場合、別のパッケージ/製品の選択（Select different packages or products）をクリックしてインストールまたは変更する製品のパッケージ（例えば、SolidWorks ProfessionalまたはSolidWorks Premiumなど）のリストを変更できます。 SolidWorks Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上のSolidWorks 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

言語サポート（Language Support）

言語（Languages）はインストールされる言語を SolidWorks 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 例えば、SolidWorks eDrawings(R)、SolidWorks Workgroup PDM、SolidWorks Explorer ではすべての言語版がインストールされます。

必要なスペース（Space Needed）

選択する製品に基づいて、ダウンロードを行なうために必要なスペースが表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。

将来の更新やパッチを当てる作業でダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


修復する製品（Products to Repair）

このインストレーションを修復（Repair this installation）を指定すると、画面にはこのバージョンのSolidWorks Installation Managerで修復可能なSolidWorks製品名とバージョン番号が表示されます。

修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。

修復（Repair）をクリックし、選択した製品の修復を開始します。

個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを再インストールする必要があります。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


シリアル番号（Serial Numbers）

シリアル番号（パッケージ上にあります）は、購入したSolidWorks製品をご使用のコンピュータに関連付けます。

既にインストールされているSolidWorks製品のシリアル番号は、デフォルトで表示されます。
  • シリアル番号が表示されていない場合は、SolidWorksシリアル番号を入力します。
  • SolidWorksライセンスに含まれていない製品のシリアル番号を持っている場合は、その他のシリアル番号をお持ちですか?（Do You Have Other Serial Numbers?）の下にある製品項目をクリックし、その製品のシリアル番号を入力します。

インターネットに接続している場合、入力したシリアル番号はインストレーション プロセスを続ける際に権限のある製品を決定します。

SolidWorks製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 例えば、 SolidWorks シリアル番号は、個々の SolidWorks Simulation シリアル番号を入力しないで SolidWorks Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


サーバー インストール（Server Installation）

インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

サーバー インストレーション ステータス（Server Installation Status）

サーバー製品のインストレーションは、外部インストレーション アプリケーションによって実行されます。このアプリケーションを開いていない場合はインストレーションを完了するため、このアプリケーションに切り替える必要があります。

サーバー製品のインストレーションを中止するには、キャンセル（Cancel）をクリックします。

サーバー インストレーション完了（Server Installation Complete）

外部インストレーション アプリケーションは正常に終了しました。

終了（Finish）、または 次へ（Next）をクリックします。
  • その他のアドミニストレーティブ製品をインストールする場合（例えば、SolidWorksアドミニストレーティブ イメージ）、そのインストレーションが続きます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SolidWorks Installation Managerは閉じられます。

サーバー インストレーションのキャンセルまたは失敗（Server Installation Cancelled or Failed）

サーバー製品のインストレーションに失敗したか、または開始後にキャンセルされた場合、インストールが完了しなかったサーバーがリストに表示されます。

閉じる（Close）または次へ（Next）をクリックします。
  • 別のアドミニストレーティブ製品のインストレーションが指定されている場合、SolidWorks Installation Managerは再開されます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SolidWorks Installation Managerは閉じられます。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


SolidNetWork License Manager

SolidNetWork License Managerサーバー製品のインストール オプションを指定します。

シリアル番号（Serial numbers）

SolidNetWork Licenseのシリアル番号を指定します。複数のシリアル番号をカンマで区切って入力できます。
SolidNetWork シリアル番号はSolidWorksシリアル番号とは異なります。

インストレーション場所（Installation location）

SolidNetWork License Managerをインストールする場所を指定します。

既存のSolidNetWork License Managerを更新する場合、既存のインストレーション場所にインストールする必要があります。

詳細情報

SolidNetWork License Managerのインストール、設定、使用の詳細については、 SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）を参照してください。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


サマリー（Summary）

SolidWorks Installation Managerには、インストレーション作業を完了するために必要な情報がすべてあります。

続行するには: | 今すぐ action ボタンをクリックしてインストレーション作業を開始します（例えば、今すぐインストール（Install Now）、今すぐ作成（Create Now）、すぐにダウンロード（Download Now）、今すぐ変更（Modify Now））。
インストレーション設定を変更するには: | 変更したいセクションに対して変更（CHANGE） [image] をクリックします（例えば、製品（Products）、インストレーション位置（Installation Location）、Toolbox オプション（Toolbox Options））。
キャンセルするには: | キャンセル（Cancel） [image] をクリックし、インストレーション コンポーネントを変更することなくSolidWorks Installation Managerを終了します。
前のページに戻るには: | 戻る（Back） [image] をクリックし、SolidWorks Installation Managerの前のページに戻ります。
特定のインストレーション オプション セット（例えば、製品（Products）、インストレーション位置（Installation Location）、Toolbox オプション（Toolbox Options）など）の情報については、以下を行います。
  1. 情報を希望するセクションの横にある変更（CHANGE） [image] をクリックします。
  2. 表示される詳細ページでヘルプ（Help） [image] をクリックし、これらのインストレーション オプションの設定に関する情報を入手します。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


システム チェックの警告（System Check Warnings）

システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。ほとんどの場合は、SolidWorks Installation Managerを続行できるはずです。

下記にこの段階で遭遇する可能性のある警告を解決方法と共に一覧します。

シリアル番号検証に関する問題
The Installation Manager was not able to check for new versions because it could not validate your serial number. If you are connected and entered a valid serial number, this could indicate a temporary problem on our server. Try again later.

Serial Number Validation: The Installation Manager could not validate your serial number to determine which products you are entitled to install. You will still be able to choose the products you want to install, but you will not be able to download any installation files. You will need to provide a complete set of download source files or a DVD from which to install.

解決策:
  • インターネットの接続を確認してください。シリアル番号のチェックには、有効なインターネット接続が必要です。
  • 入力したシリアル番号が、インストールを試みている製品に対して正しいことを確認してください。
  • 一部のインストールでは、バージョンのリリース時に適切な契約を交わす必要があります。詳細は、SolidWorks代理店までお問い合わせください。
  • 大部分のケースでは、DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。
より新しいバージョンの存在
利用可能なより新しいバージョン

利用可能な新しいバージョン

製品のより新しいバージョンをダウンロードして利用できます。

解決策:アップデート チェックの実行時には、SolidWorksからのダウンロードにより利用可能な新しいバージョンのインストールを促される場合があります。この処理は最初に指定したバージョンを用い継続することも、あるいは利用可能なより新しいバージョンをダウンロードし、そのバージョンを用いて継続することも可能です。

最新バージョンの存在
これはご利用可能な最新のバージョンです。「次へ」をｸﾘｯｸして続行してください。

利用可能な新しいﾀﾞｳﾝﾛｰﾄﾞはありません

解決策:このメッセージには、インストールや変更の間、アップデートをチェックしている際に遭遇する可能性があります。このメッセージは、利用可能な最新バージョンをインストール中であること、あるいは最新バージョンが既にインストール済みであることを示すものです。

インターネット接続に関する問題
Internet Connection: The Installation Manager could not connect to the SolidWorks server to determine which products you are entitled to install. You will still be able to choose the products you want to install, but you will not be able to download any installation files. You need to provide source files on DVD or a previously downloaded file set.

Unable to Check for New Versions

The Installation Manager was not able to check for new versions because it could not connect to the server.

解決策:
  • インターネットの接続を確認してください。
  • DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

SolidWorks Toolboxがインストールされている場合、SolidWorksは穴タイプと汎用部品の標準ライブラリを含みます。

SolidWorks Toolboxの設定、拡張、使用の詳細については、SolidWorksでヘルプ > Toolbox ヘルプをクリックします。
このヘルプを表示するには、ツール > アドインを使用してToolboxアドインを開始する必要があります。

SolidWorks Toolboxを使用する前に、企業やグループのポリシーに従って適切に設定されていることを確認します。ほとんどの場合は、グループが中央Toolboxを設定および管理します。SolidWorksのインストレーション中にToolboxを指定する方法のガイダンスについては、SolidWorks管理者に確認してください。

選択したSolidWorks Toolboxは、インストレーション後に変更できます。SolidWorksでツール > オプションをクリックします。システム オプション（Systems Options）タブの穴ウィザード/Toolbox（Hole Wizard/Toolbox）をクリックします。

次のセクションでは、あらゆる設定に対して画面に表示されるすべてのオプションについて説明します。実際に表示されるToolboxオプションは、コンピュータにある既存のSolidWorksとToolboxの設定、および、これまでに指定したSolidWorks Installation Managerの選択内容によって異なります。

新しいnew-version Toolboxの作成（Create a new new-version Toolbox）

このコンピュータでSolidWorks Toolboxの新しいバージョンを作成します。

製品選択 (Product Selection) 画面で新しいバージョンを作成する場合、SolidWorks > SolidWorks Toolbox の順に展開し、Toolbox に対してどの規格をサポートするか選択します。デフォルトでは、すべての規格が選択されます。

このコンピュータにある既存のToolboxは、いっさい変更されません。

既存のToolboxの参照またはアップグレード（Reference or upgrade an existing Toolbox）

既存のToolboxを使用します。参照（Browse）をクリックし、このインストレーションで使用するToolboxの位置を指定します。

  • Toolboxが以前のSolidWorksメジャー リリース バージョン用に設定されている場合は、現在のバージョンにアップグレードされます。前のToolboxに対して行われたユーザー定義はすべて、アップグレードされたToolboxでも保持されます。
    Toolboxを新しいSolidWorksメジャー リリース バージョンにアップグレードすると、このToolboxは以前のSolidWorksメジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。
  • Toolboxが現在のSolidWorksバージョン用に設定されている場合（既にアップグレードされた共有ネットワークToolboxを指定した場合）、そのToolboxに対するアップグレードは行われません。
  • Enterprise PDM環境でToolboxをアップグレードする場合には、追加的な手順が必要となります。詳細は SolidWorks Enterprise PDM環境にあるToolboxをアップグレード（Upgrading Toolbox in a SolidWorks Enterprise PDM Environment） を参照してください。

このオプションは、アドミニストレーティブ イメージの作成を除く、すべてのインストレーション シナリオで表示されます。

previous-version Toolboxのアップグレード（Upgrade a previous-version Toolbox）

以前のメジャー リリース バージョン用に設定されたToolboxを新しい位置にコピーし、このコピーを現在のバージョンにアップグレードします。

このオプションは、以前のSolidWorksメジャー リリース バージョンがコンピュータにインストールされているが、そのインストレーションを現在のリリースにアップグレードしないことを選択した場合に表示されます。
このオプションの目的は、古いバージョンのToolboxを使用しているユーザーに影響を与えずに、以前のSolidWorksメジャー リリース バージョン用のToolboxをアップグレードすることです。

Enterprise PDM環境でToolboxをアップグレードする場合には、追加的な手順が必要となります。詳細は SolidWorks Enterprise PDM環境にあるToolboxをアップグレード（Upgrading Toolbox in a SolidWorks Enterprise PDM Environment） を参照してください。

インストールされている previous-version Toolboxのアップグレード（Upgrade this installed previous-version Toolbox）

より新しいバージョンにToolboxをアップグレードします。
Toolboxを新しいSolidWorksメジャー リリース バージョンにアップグレードすると、このToolboxは以前のSolidWorksメジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

このオプションは、以前のSolidWorksメジャー リリース バージョンを現在のバージョンにアップグレードする際に、以前のリリース用に設定されたToolboxがコンピュータ上で見つかった場合に表示されます。

Enterprise PDM環境でToolboxをアップグレードする場合には、追加的な手順が必要となります。詳細は SolidWorks Enterprise PDM環境にあるToolboxをアップグレード（Upgrading Toolbox in a SolidWorks Enterprise PDM Environment） を参照してください。

インストールされている current-version Toolboxの使用（Use the installed current-version Toolbox）

SolidWorks Installation Managerは、このコンピュータ上に現在のSolidWorksメジャー リリース バージョン用に設定されたToolboxがあることを検出しました。

このオプションを選択すると、SolidWorksはこのToolboxを使用します。アップグレードは行われません。

このオプションは、以前のSolidWorksメジャー リリース バージョンがコンピュータにインストールされているが、Toolboxは現在のバージョン用に設定されている場合に表示されます。このような状況は、古いSolidWorksバージョンを実行し続けているコンピュータに共有Toolboxが作成された場合に生じる可能性があります。

クライアント コンピュータのToolbox位置を指定（Specify the Toolbox location for the client computer）

アドミニストレーティブ イメージからのクライアント インストール時に、デフォルトのToolbox位置としてネットワークまたはディレクトリ位置を指定します。
クライアント インストレーションの実行時に、この位置に以前のSolidWorksメジャー リリース バージョン用に設定されたToolboxが存在する場合、SolidWorks Installation ManagerはそのToolboxをアップグレードします。

このオプションは、新しいアドミニストレーティブ イメージを作成するときに表示されます。

クライアント コンピュータ用に、アップグレードするか、既存のイメージで参照されているToolboxを使用します（Upgrade or use the Toolbox referenced in the existing image for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたToolbox位置を使用します。
クライアント インストレーションの実行時に、この位置に以前のSolidWorksメジャー リリース バージョン用に設定されたToolboxが存在する場合、SolidWorks Installation ManagerはそのToolboxをアップグレードします。

クライアント コンピュータ用に別のToolbox位置を選択します（Select a different Toolbox location for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたものとは異なるToolbox位置を指定します。
クライアント インストレーションの実行時に、この位置に以前のSolidWorksメジャー リリース バージョン用に設定されたToolboxが存在する場合、SolidWorks Installation ManagerはそのToolboxをアップグレードします。
  • SolidWorks Toolboxの設定に関する注記（Notes About Configuring SolidWorks Toolbox）
    SolidWorks Toolboxは、強力かつ複雑な機能です。ここでは、SolidWorks Installation Managerを使用してToolboxを設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。
  • UNCフォーマット（UNC Format）
    UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


SolidWorks Toolboxの設定に関する注記（Notes About Configuring SolidWorks Toolbox）

SolidWorks Toolboxは、強力かつ複雑な機能です。ここでは、SolidWorks Installation Managerを使用してToolboxを設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。

SolidWorks Toolboxの詳細情報（Finding More Information About SolidWorks Toolbox）

SolidWorks Toolboxの設定、拡張、使用の詳細については、SolidWorksでヘルプ > Toolbox ヘルプをクリックします。
このヘルプを表示するには、ツール > アドインを使用してToolboxアドインを開始する必要があります。

共有Toolboxの使用（Using a Shared Toolbox）

Toolbox をインストールするとき、ローカルコンピュータ上、あるいは共有されたネットワーク上でToolbox データを持つことができます。Toolbox データをネットワーク上に保管することが推奨されます。共通の場所を使うことによって、すべての SolidWorks ユーザーは一貫したファスナー情報を共有します。

今回が最初のインストールである場合、Toolbox をインストールする新しい共有された場所を参照してください。

既存のToolboxのアップグレード（Upgrading an Existing Toolbox）

Toolboxを新しいSolidWorksメジャー リリース バージョンにアップグレードすると、このToolboxは以前のSolidWorksメジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

他のコンピュータが以前のメジャー リリースのままであり、以前のリリース用に設定されたToolboxを必要とする場合は、このToolboxのコピーを作成し、そのコピーをアップグレードするべきです。新規のSolidWorksインストレーションはToolboxのコピーをアップグレードし、以前のSolidWorksインストレーションは古いToolboxを使用し続けます。

Toolboxアクセスの設定（Configuring Toolbox Access）

インストレーション後に、Toolbox コンポーネントにアクセスするとき、 SolidWorks はどのようにToolbox を配置したかをチェックし、アクセスとパフォーマンスを改善するために提案をします。

共有ネットワークToolbox（推奨）にアクセスする場合、共有Toolboxのインストールされたサーバーに対するUNCパスを使用します。詳細は UNCフォーマット（UNC Format） を参照してください。

アドミニストレータ（管理者）はToolboxのパスワードを作成し、ワークグループの権限と優先権を設定できます。コンフィギュレーションへのアクセスを限定することと、共通の優先権を設定することは安定した Toolbox データを保証します。

SolidWorks Enterprise PDM環境にあるToolboxをアップグレード（Upgrading Toolbox in a SolidWorks Enterprise PDM Environment）

Enterprise PDMボルト内の Toolbox フォルダにアクセスする最初の SolidWorks インストレーションをアップグレードする前に：
  1. Windows エクスプローラで、Enterprise PDM ボルトの Toolbox フォルダまでナビゲートします。
  2. Toolbox フォルダを右クリックし、最新バージョンを取得（Get Latest Version）をクリックします。

    これにより、SolidWorks Installation Managerが部品をアップグレードする必要があるか検証できるようになります。

  3. Toolbox フォルダをチェックアウトします。

    SolidWorks Installation Manager が Toolbox をアップデートできるよう、Toolbox フォルダーをチェックアウトしておく必要があります。

  4. アップデート後、Toolbox フォルダーをチェックインします。

これでボルト内のToolboxライブラリがアップグレードされました。

その後のSolidWorksアップグレードでは、アップグレードを開始する前に、Enterprise PDMクライアントがボルトのToolboxフォルダーの最新バージョンを取得（最新バージョンを取得により）するようにします。これにより、SolidWorks Installation Managerはファイルが最新であることを確認できます。

SolidWorks Enterprise PDM における Toolbox コンフィギュレーションに関する詳細は Toolbox の設定 （Configuring Toolbox）を SolidWorks Enterprise PDM アドミニストレーション ツール ヘルプで参照してください。

親トピック: 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）


UNCフォーマット（UNC Format）

UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

\\サーバー\ボリューム\パス

例えば:

\\Disk_Server\SolidWorks\AdminImage

親トピック: 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）


製品のアンインストール（Uninstall Products）

削除（Remove）あるいはアンインストール（Uninstall）をコントロール パネル（Control Panel）から選択すると、画面にはこのバージョンの SolidWorks Installation Manager でアンインストールできる SolidWorks 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

一般的なアンインストールでは、SolidWorks 製品のプログラム ファイルとフォルダが削除されます。 デフォルトで、選択したリリースのすべての SolidWorks 製品のアンインストールが指定されます。

カスタム インストールでは、次のアイテムのいくつかを削除できます: プログラム ファイルとフォルダ、レジストリ キー、SolidWorks Toolbox などのデータ フォルダ、元のダウンロード位置からのファイルとフォルダ。

完全なアンインストールではインストール ディレクトリ、レジストリ キー、データ フォルダが削除されます。

製品をアンインストールするには:
  1. アンインストール（Uninstall）の画面で、製品が選択されていることを確認してください。

    すべての製品をアンインストールすると、Solidworks Installation Manager もアンインストールされます。

  2. 削除したくない製品を選択解除します。

    1つでも製品を保持すると、SolidWorks Installation Manager も削除されません。

  3. カスタム アンインストールか完全なアンインストールを選択します。
    1. 変更（Change）を詳細設定オプション（Advanced Options）でクリックします。

      詳細設定オプション(Advanced Options)画面が表示されます。 プログラム ファイルとフォルダのオプションが選択されています。

    2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
    3. サマリーに戻る（Back to Summary）をクリックします。
    4. サマリー（Summary）の画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法を表示します。
  4. アイテムを削除 [image] （Remove Items）をクリックします。
アイテムを削除（Remove Items）をクリックすると、SolidWorks Installation Managerは直ちに製品の削除を開始します。
親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


Workgroup PDM Serverオプション（Workgroup PDM Server Options）

SolidWorks Workgroup PDM Server 製品のインストール オプションを指定します。

インストール先（Installation Location）

Workgroup PDM Server 製品のインストール先を指定します。

インストールする製品（Products to install）

インストールするWorkgroup PDM Server製品を指定します：
Workgroup PDM ボルト（Workgroup PDM Vault）
Workgroup PDMボルトデータの場所を指定します。Viewerを有効にするには、Workgroup PDM Viewerのライセンスをボルトと共にインストールする必要があります。
Workgroup PDM Viewer
Workgroup PDM Viewerをインストールする際、ViewerがアクセスするWorkgroup PDM Vaultコンピュータの名前またはIPアドレスを指定する必要があります。
Workgroup PDM API.

Workgroup PDM APIのライセンスはSolidWorksクライアントとExplorerクライアントのライセンスに含まれています。チェックインAPI（Check-in APIs）にはクライアント ライセンスが必要です。

詳細情報

Workgroup PDM をインストールする詳細については Workgroup PDM を参照してください。

Workgroup PDMの使い方の詳細については、 SolidWorks ヘルプ の Workgroup PDM を参照してください。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


著作権に関する注意書き

© 1995-2011, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA.All Rights Reserved.

本ドキュメントに記載されている情報とソフトウェアは予告なく変更されることがあり、Dassault Systèmes SolidWorks Corporation (DS SolidWorks) の保証事項ではありません。

この製品を DS SolidWorks の書面上の許可なしにその目的、方法に関わりなく複製、頒布はできません。

本ドキュメントに記載されているソフトウェアは使用許諾に基づくものであり、当該使用許諾の条件の下でのみ使用あるいは複製が許可されています。 DS SolidWorks がソフトウェアとドキュメントに関して付与するすべての保証は、ライセンス契約書に規定されており、本ドキュメントまたはその内容に記載、あるいは黙示されているいかなる事項もそれらの保証、その変更あるいは補完を意味するものではありません。

特許

SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

SolidWorks 製品とサービスの商標と製品名

SolidWorks、3D PartStream.NET、3D ContentCentral、eDrawings、eDrawings のロゴは DS SolidWorks の登録商標です。FeatureManager は DS SolidWorks が共同所有する登録商標です。

CircuitWorks、FloXpress、TolAnalyst、および XchangeWorks は DS SolidWorks の商標です。

FeatureWorks は、Geometric Ltd. の登録商標です。

SolidWorks 2012、SolidWorks Enterprise PDM、SolidWorks Workgroup PDM、SolidWorks Simulation、SolidWorks Flow Simulation、eDrawings Professiona、および SolidWorks Sustainability は DS SolidWorks の製品名です。

その他、記載されているブランド名、製品名は各社の商標及び登録商標です。

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

本ソフトウェアは、48 C.F.R. 2.101 (OCT 1995) に定義されている「商用品」であり、48 C.F.R. 12.212 (SEPT 1995) で使用されている「商用コンピュータ ソフトウェア」および「商用コンピュータ ソフトウェア ドキュメンテーション」で構成されます。本ソフトウェアは、48 C.F.R. 12.212 に規定された政策に従って、民間機関による、またはそれに代わる取得のため、あるいは (b) 48 C.F.R. 227.7202-1 (JUN 1995) および 227.7202-4 (JUN 1995) に既定された政策に従って、国防総省の一部門による、またはそれに代わる取得のために、米国政府に対して提供されます。

米国政府機関から、上記の規定を超える権利と共にソフトウェアを提供するように要求された場合は、DS SolidWorks にその要求の範囲を通知するものとします。DS SolidWorks は、5 営業日以内に、独自の判断により、そのような要求を受け入れるか拒絶するかを決定します。Contractor/Manufacturer:Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

SolidWorks Standard、Premium、Professional、Education 製品における著作権

Portions of this software © 1986-2011 Siemens Product Lifecycle Management Software Inc. All rights reserved.

この製品には、Siemens Industry Software Limited が所有する、次のソフトウェアが含まれています。

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited.All Rights Reserved.

Portions of this software © 1998-2011 Geometric Ltd.

Portions of this software © 1996-2011 Microsoft Corporation. All rights reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2011 Luxology, LLC.All rights reserved, patents pending.

Portions of this software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors.All rights reserved.Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe、Adobeのロゴ、Acrobat、Adobe PDFのロゴ、Distiller、Reader は米国およびその他の国において Adobe Systems Inc. の登録商標または商標です。

SolidWorks® の詳細な著作権情報については、ヘルプ（ヘルプ） > About SolidWorks（SolidWorksについて）を参照してください。

SolidWorks Simulation 製品における著作権

Portions of this software (c) 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. All rights reserved.

SolidWorks Enterprise PDM 製品における著作権

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation.All rights reserved.

eDrawings 製品における著作権

Portions of this software © 2000-2011 Tech Soft 3D.

Portions of this software (c) 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software (c) 1998-2001 3Dconnexion.

Portions of this software (c) 1998-2011 Open Design Alliance.All rights reserved.

Portions of this software (c) 1995-2010 Spatial Corporation.

このソフトウエアは部分的に Independent JPEG Group の研究に依存しています。


複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

SolidWorks Installation Managerは複数コンピュータのインストールと管理のために次のツールを提供します。

SolidWorksアドミニストレーティブ イメージ（SolidWorks Administrative Images）

SolidWorksを複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

Workgroup PDM Server

Workgroup PDMアプリケーションは、SolidWorks環境内で、あるいはスタンドアロン アプリケーションとしてSolidWorks Explorer内で動作する、製品データ管理ソフトウェアです。Workgroup PDMは、プロジェクトのチェックアウト/チェックイン/リビジョン管理の手順、またその他の管理作業をコントロールします。Workgroup PDM Serverをインストールすると、Workgroup PDMボルトが作成されます。これは管理するSolidWorksプロジェクトを保存するためのデータベースです。

SolidNetWork License Manager

SolidNetWork License Managerでは、ライセンスの使用をフロートすることにより、実際のライセンス数よりも多数のユーザーを許可します。使用されていないクライアント ライセンスは、他のSolidWorksユーザーが使用できます。

また、SolidNetWork License Managerを使用し、SolidWorksコア アドイン製品（例えば、FeatureWorks）のライセンスを配布できます。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）


利用可能な新しいバージョンはありません（No New Versions Available）

ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

インストレーションを続けるには次へ（Next）をクリックします。

親トピック: SolidWorks Installation Managerアプリケーション ヘルプ（SolidWorks Installation Manager Application Help）