Instalação e Administração do SolidWorks

Este manual descreve a instalação, as licenças, a atualização e a administração dos produtos SolidWorks para instalações individuais e múltiplas.

Instalações individuais | Distribuir múltiplas instalações
Instalação Instalação em um ou poucos computadores. | Instalação Criar uma imagem administrativa que é distribuída para determinado número de computadores clientes.
Licenças Ativação de licenças ou licenças de rede | Licenças Ativação de licenças ou licenças de rede
Atualizações de versão Mudança para uma nova versão principal em computadores individuais | Atualizações de versão Mudança para uma nova versão principal de vários computadores através da atualização da imagem administrativa usada para a instalação nesses computadores.
Administração Modificação, reparo e remoção de instalações, atualização para novas versões. | Administração Atualização de imagens administrativas e clientes, administração da licença de rede, administração do vault do Workgroup PDM.

O Gerenciador de Instalação do SolidWorks permite definir as configurações dos componentes de produtos SolidWorks, incluindo o SolidWorks, SolidWorks Toolbox, PhotoView 360, Workgroup PDM e o SolidNetWork License Manager.

O Workgroup PDM é um software de gerenciamento de dados de projeto que é executado no ambiente do SolidWorks ou como um aplicativo independente no SolidWorks Explorer. O Workgroup PDM controla projetos com procedimentos para check-out, check-in, controle de revisões e outras tarefas administrativas.

O SolidNetWork License Manager tem suporte para múltiplas licenças de cliente distribuindo essas licenças os clientes pela rede. Isso permite que o número de usuários exceda o número de licenças usando licenças flutuantes.

  • Instalação individual ou Imagem administrativa
    Você pretende instalar os produtos SolidWorks em cada computador individualmente ou prefere criar uma imagem administrativa e distribuir a instalação para todos os clientes com um único comando?
  • Iniciar a instalação do SolidWorks
    Você pode iniciar a instalação do SolidWorks carregando um DVD no computador local, acessando um diretório de instalação compartilhado ou fazendo o download do site da SolidWorks.


Instalação individual ou Imagem administrativa

Você pretende instalar os produtos SolidWorks em cada computador individualmente ou prefere criar uma imagem administrativa e distribuir a instalação para todos os clientes com um único comando?

Se você está instalando em um único computador, ou se você gerencia dezenas ou centenas de computadores, a escolha é óbvia. Para situações intermediárias, considere as seguintes comparações.

Instalação individual | Imagem administrativa
Os usuários podem eles mesmos fazer a administração do SolidWorks. | O administrador do sistema pode personalizar múltiplas instalações usando o Editor de Opções, especificando as opções de instalação, por exemplo, criar uma nova instalação ou atualizar uma instalação existente, executar a instalação como um usuário administrativo, executar comandos externos antes ou depois da instalação, selecionar diferentes grupos de produtos, etc.
Os computadores precisam ser fisicamente acessíveis pela pessoa que executa a instalação. | Os computadores clientes podem estar localizados remotamente contanto que estejam acessíveis pela mesma rede.
Você pode instalar versões, service packs ou produtos diferentes em vários computadores, com configurações independentes. | Usando o Editor de Opções, as imagens administrativas podem manter a consistência das versões, service packs, produtos e configurações em múltiplas instalações.
A mídia de origem (DVD) é necessária quando se aplicam service packs. | As unidades de mídia não são necessárias quando se aplicam service packs.
O computador não precisa estar em uma rede. | Uma conexão de rede local é necessária para a distribuição do aplicativo; não são necessárias unidades de mídia nos computadores clientes.
 | Os clientes podem ser atualizados manualmente. Todos os clientes que usam a mesma imagem administrativa têm o mesmo service pack. Para manter várias versões, você pode criar várias imagens administrativas.
 | A ativação da licença pode ser automática.
 | Uma imagem administrativa requer espaço adicional em disco no servidor; os clientes requerem o mesmo espaço que as instalações individuais.
Tópico pai: Instalação e Administração do SolidWorks


Iniciar a instalação do SolidWorks

Você pode iniciar a instalação do SolidWorks carregando um DVD no computador local, acessando um diretório de instalação compartilhado ou fazendo o download do site da SolidWorks.

  • Para iniciar a instalação do SolidWorks, siga um destes procedimentos:
    • Para instalar em um computador local a partir do disco, insira o disco apropriado na unidade de disco do computador.
    • Para instalar a partir de um diretório de download, acesse o diretório e clique duas vezes em setup.exe.
    • Para instalar fazendo o download do site da SolidWorks:
      1. Acesse o site da SolidWorks na Internet.
      2. Faça o login como Cliente do Serviço de Assinatura, usando seu endereço de e-mail e senha ou seu número de série do SolidWorks.
      3. Em Self Service (Autoatendimento), clique em Download Software and Updates (Fazer o download do software e atualizações).
      4. Em Download Software (Download do software), selecione a versão do SolidWorks e o service pack para o download.
Tópico pai: Instalação e Administração do SolidWorks


Instalações individuais

  • Instalação em computadores individuais
    Você pode instalar o SolidWorks em um computador individual usando diversos métodos de instalação.
  • Administração de instalações individuais
    Normalmente, a administração de instalações individuais consiste em modificar, reparar, remover e atualizar instalações.


Instalação em computadores individuais

Você pode instalar o SolidWorks em um computador individual usando diversos métodos de instalação.

O Gerenciador de Instalação do SolidWorks executa a instalação, adaptando-a para os produtos que você adquiriu. Antes de iniciar a instalação:

  • Tenha disponível o seu número de série do SolidWorks.
  • Certifique-se de ter uma conexão com a internet ativa.
O Gerenciador de Instalação do SolidWorks requer vários componentes da Microsoft, incluindo o Microsoft Windows Installer, Office Web Components, Microsoft Visual Studio Tools for Applications e .NET Framework. Se as versões corretas de todos os componentes de pré-requisitos do Windows não estiverem instaladas no computador, o Gerenciador de Instalação do SolidWorks as instalará automaticamente antes de instalar os produtos SolidWorks.
Método de instalação Resumo do processo
Usando a mídia de instalação do SolidWorks Insira o DVD apropriado na unidade de disco do computador.
A mídia de instalação do SolidWorks fornece DVDs individuais para instalações no Windows de 32 bits e de 64 bits.
Usando um diretório de download em um servidor No diretório de download, clique duas vezes em setup.exe.
O diretório de download precisa estar acessível no computador que está executando a instalação dos produtos SolidWorks e deve conter todos os arquivos de instalação do SolidWorks antes do início da instalação. O Gerenciador de Instalação do SolidWorks pode ajudá-lo a encontrar os arquivos que faltam caso você tenha acesso à Internet e acesso de gravação ao diretório de download.
Isto não é uma imagem administrativa. A única maneira de instalar um computador cliente a partir de uma imagem administrativa é clicando no link na página HTML distribuída pelo administrador do SolidWorks.
Atualizar uma instalação existente do SolidWorks usando a opção Verificar atualizações Siga um destes procedimentos:
  • No SolidWorks, clique em Ajuda > Verificar atualizações.
  • No Windows, clique em Iniciar > Todos os programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações
Você precisa ter uma conexão ativa com a internet.

Os clientes do Workgroup PDM detectam automaticamente as atualizações do vault. Você não precisa fazer o download de um service pack para atualizar os clientes. Para obter mais detalhes, consulte Atualizar clientes na Ajuda on-line do Workgroup PDM.

Fazer o download no site de clientes da SolidWorks.
  1. Navegue até o site da SolidWorks na Web.
  2. Faça o login como Cliente do Serviço de Assinatura, usando seu endereço de e-mail e senha ou seu número de série do SolidWorks.
  3. Sublinhado Self Service (autosserviço), clique em Download Software and Updates (Download do software e de atualizações).
  4. Em Download Software (Download do software), clique na versão do SolidWorks que deseja instalar.
Você precisa ter uma conexão ativa com a internet.

Além disso, você precisa ser cliente do Serviço de Assinatura com um login de acesso ao Portal do Cliente.

Quando a instalação estiver concluída, inicie o aplicativo SolidWorks e ative sua licença.

Tópico pai: Instalações individuais


Administração de instalações individuais

Normalmente, a administração de instalações individuais consiste em modificar, reparar, remover e atualizar instalações.

  • Modificar uma instalação
    Você pode modificar uma instalação para instalar produtos que ainda não foram instalados ou para remover produtos.
  • Reparar uma instalação
    Se você tiver problemas com um produto SolidWorks instalado, pode usar o Gerenciador de Instalação do SolidWorks para reparar a instalação.
  • Reverter uma instalação individual para um Service Pack anterior
    Para reverter uma instalação individual para uma versão de service pack anterior na família da versão principal atual, desinstale a versão do service pack instalada atualmente no computador e reinstale a versão anterior.
  • Remover uma instalação
    Você pode remover uma instalação de um computador individual ou em um ambiente servidor/cliente.
  • Atualizar para uma nova versão principal
    Existem vários métodos para atualizar uma instalação individual com uma nova versão do SolidWorks.
  • Regras de coexistência de produtos
    Essas regras de coexistência de produtos determinam como os novos produtos são instalados e os produtos existentes atualizados.
Tópico pai: Instalações individuais


Modificar uma instalação

Você pode modificar uma instalação para instalar produtos que ainda não foram instalados ou para remover produtos.

Se você instalou o SolidWorks e posteriormente adquiriu um suplemento, pode modificar a instalação para incluir o novo suplemento. Você precisa instalar o suplemento em cada computador individualmente.

O Workgroup PDM não é instalado se você está modificando seu pacote SolidWorks original para incluir o SolidWorks Professional ou o SolidWorks Premium.
  1. Certifique-se de que não há nenhuma sessão do SolidWorks ativa.
  2. No Windows Vista ou posterior, clique em Iniciar > Painel de controle > Adicionar ou remover programas.

    Em versões anteriores do Windows, clique em Iniciar > Painel de controle > Adicionar ou remover programas.

  3. Selecione a instalação do SolidWorks que deseja modificar e clique em Alterar.
  4. Na tela Bem-vindo ao Gerenciador de Instalação do SolidWorks, clique em Modificar a instalação individual (neste computador).
  5. Na tela Número de Série, verifique se os números de série apropriados estão especificados.
  6. Na tela Seleção de produtos, selecione os produtos a serem instalados ou removidos.

    Quando modificar uma instalação:

    • Nenhum produto é instalado ou removido por padrão, mesmo que você especifique um novo número de série. Você precisa modificar a ação de instalação para cada componente de produto ou recurso.
    • Para visualizar a ação projetada para um componente específico, clique no nome do componente (mas não na caixa de seleção). A ação de instalação pretendida é exibida no campo de informação, abaixo da lista de produtos.
    • Você pode clicar na caixa de seleção próxima ao componente de produto para alterar a respectiva ação de instalação. (Por exemplo, se você estiver instalando ou removendo componentes, marcar a caixa de seleção especificará que o componente deverá ser instalado ou removido e desmarcar a caixa de seleção especificará que o componente não deverá ser instalado ou removido.)
    • Quando você altera a ação de instalação de um componente, mudando sua especificação inicial, um asterisco (*) é exibido próximo a esse componente na lista.
    • Se um componente contiver subcomponentes de instalação opcional, um ícone + aparecerá próximo ao componente. Para ver os subcomponentes disponíveis para um componente, clique no ícone + .
    • Se um componente tiver sido expandido para mostrar seus subcomponentes opcionais, um ícone - aparecerá próximo ao componente. Para recolher a lista de subcomponentes, clique no ícone - .

  7. Na tela Resumo, clique em Modificar agora.
  8. Na tela A instalação está completa, clique em Concluir.
Tópico pai: Administração de instalações individuais


Reparar uma instalação

Se você tiver problemas com um produto SolidWorks instalado, pode usar o Gerenciador de Instalação do SolidWorks para reparar a instalação.

Você pode reparar uma instalação individual. Entretanto, não pode reparar uma imagem administrativa; é necessário desinstalar e repetir a instalação.
  1. No Windows Vista ou posterior, clique em Iniciar > Painel de controle > Programas > Programas e Recursos.

    Em versões anteriores do Windows, clique em Iniciar > Painel de controle > Adicionar ou remover programas.

  2. Selecione a versão do SolidWorks que deseja reparar e clique em Alterar.
  3. Na tela Bem-vindo ao Gerenciador de Instalação do SolidWorks, clique em Reparar a instalação individual (neste computador).
  4. Na tela Produtos a reparar, selecione o produto a ser reparado.
  5. Desmarque os outros produtos na tela.
  6. Clique em Reparar.
Tópico pai: Administração de instalações individuais
Tópico pai: Erros de instalação/Instalação cancelada


Reverter uma instalação individual para um Service Pack anterior

Para reverter uma instalação individual para uma versão de service pack anterior na família da versão principal atual, desinstale a versão do service pack instalada atualmente no computador e reinstale a versão anterior.

Tópico pai: Administração de instalações individuais


Remover uma instalação

Você pode remover uma instalação de um computador individual ou em um ambiente servidor/cliente.

  1. Certifique-se de que não há nenhuma sessão do SolidWorks ativa.
  2. Se quiser transferir a licença do SolidWorks para outro computador, faça a transferência da licença antes de remover a instalação do SolidWorks do computador antigo.

    Para obter informações sobre a transferência de licenças do SolidWorks, consulte Transferir uma licença.

  3. No Windows Vista ou posterior, clique em Iniciar > Painel de controle > Programas > Programas e Recursos.

    Em versões anteriores do Windows, clique em Iniciar > Painel de controle > Adicionar ou remover programas.

  4. Selecione o produto a ser removido.

    Em alguns casos, você pode encontrar vários componentes do Service Pack do SolidWorks relacionados a uma determinada versão principal. Para remover uma versão principal do SolidWorks, remova todos os elementos do Service Pack da versão principal.

  5. Na tela Desinstalar:
    1. Selecione os produtos a serem removidos. Por padrão, todos os produtos componentes são selecionados.
    2. Desmarque os produtos que você não quer remover.
    3. Escolha entre executar uma desinstalação personalizada ou completa. Por padrão, o Gerenciador de instalação do SolidWorks executa uma desinstalação padrão e remove os arquivos e pastas do programa.

      1. Clique em Alterar em Opções avançadas.

        A tela Opções avançadas aparece e a opção Arquivos e pastas do programa é selecionada

      2. Selecione uma ou mais opções para executar uma desinstalação personalizada ou selecione todas as opções para executar uma desinstalação completa.
      3. Clique em Voltar ao resumo.
      4. Na tela Resumo, expanda Opções avançadas para exibir o método de desinstalação e as entradas.

    4. Clique em Remover itens.
Tópico pai: Administração de instalações individuais


Atualizar para uma nova versão principal

Existem vários métodos para atualizar uma instalação individual com uma nova versão do SolidWorks.

Você pode atualizar com uma nova versão quando:
  • Recebe uma nova mídia de instalação
  • É notificado sobre atualizações quando inicia o SolidWorks
  • Verifica manualmente se há atualizações
  • Iniciar uma nova instância do Gerenciador de Instalação do SolidWorks

Quando instala uma nova versão principal, você pode atualizar a versão principal anterior já instalada ou instalar uma nova versão em paralelo. Se estiver instalando uma versão de Service Pack de uma versão principal que já está instalada, ela é atualizada automaticamente.

  • Verificar manualmente se há atualizações
    Você pode verificar se há atualizações para uma versão do SolidWorks atualmente instalada usando um destes métodos.
  • Atualizar clientes do Workgroup PDM
    Os clientes do Workgroup PDM detectam quando o vault foi atualizado. Você não precisa fazer o download de um service pack para atualizar os clientes.
  • Advertências da atualização
    Os produtos que têm várias instalações com diferentes versões principais nem sempre têm suporte para atualizações de versão ou a capacidade de aceitar atualizações entre versões principais em uma única operação.
Tópico pai: Administração de instalações individuais


Verificar manualmente se há atualizações

Você pode verificar se há atualizações para uma versão do SolidWorks atualmente instalada usando um destes métodos.

  • No SolidWorks, clique em Ajuda > Verificar atualizações.
  • No Windows, clique em Iniciar > Todos os programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações
Tópico pai: Atualizar para uma nova versão principal


Atualizar clientes do Workgroup PDM

Os clientes do Workgroup PDM detectam quando o vault foi atualizado. Você não precisa fazer o download de um service pack para atualizar os clientes.

Para obter instruções, consulte Atualizar clientes na Ajuda on-line do Workgroup PDM.

Tópico pai: Atualizar para uma nova versão principal
Tópico pai: Administração do VaultAdmin do Workgroup PDM


Advertências da atualização

Os produtos que têm várias instalações com diferentes versões principais nem sempre têm suporte para atualizações de versão ou a capacidade de aceitar atualizações entre versões principais em uma única operação.

Neste caso, o Gerenciador de Instalação do SolidWorks simula a atualização, instalando a nova versão primeiro e removendo a antiga depois. Neste momento, o produto SolidWorks central tem suporte para atualização de versões principais, enquanto os outros produtos não têm.

As consequências disso são as seguintes:
  • Quando você atualiza o produto SolidWorks principal de uma versão principal para outra:
    • O local da sua instalação existente não muda.
    • A atualização pode ser revertida se um erro ocorrer ou se você cancelar a atualização.
  • Quando outros produtos são atualizados entre versões principais:
    • Cada produto é instalado primeiro como um novo produto em um novo local, depois a instalação original é removida.
    • Uma vez iniciada, a atualização não pode ser revertida se um erro ocorrer ou se você cancelar a atualização.
Tópico pai: Atualizar para uma nova versão principal


Regras de coexistência de produtos

Essas regras de coexistência de produtos determinam como os novos produtos são instalados e os produtos existentes atualizados.

Regra | Exemplos
São permitidas múltiplas versões principais do produto SolidWorks principal, seja qual for a versão principal ou service pack (com exceção dos três produtos mencionados abaixo). O SolidWorks 2010 SP3.0 e o SolidWorks 2011 SP0.0 podem coexistir no mesmo computador.

No entanto, se o SolidWorks 2011 SP0.0 estiver instalado em um computador e você instalar o SolidWorks 2011 SP1.0, o Gerenciador de Instalação do SolidWorks substituirá a versão SP0.0 pela nova versão SP1.0.

O SolidWorks 2011 SP0.0 e o 2011 SP1.0 não coexistem no mesmo computador.

Somente uma versão dos seguintes produtos é permitida no computador:
  • Servidor do Workgroup PDM
  • SolidNetWork License Manager
 Se o SolidWorks 2011 SP0.0 for instalado, o Servidor do Workgroup PDM será atualizado com a versão 2011 SP0.0, mesmo que uma versão principal anterior do SolidWorks permaneça no computador.
Somente uma versão de um produto incluído pode ser instalada para qualquer versão principal. | Se o SolidWorks 2011 SP0.0 for atualizado para o 2011 SP1.0, o SolidWorks Explorer 2011 SP0.0 será automaticamente atualizado para o 2011 SP1.0; contudo, o SolidWorks Explorer 2010 SP4.0 também pode existir no computador.
Tópico pai: Administração de instalações individuais


Instalações múltiplas

  • Distribuição para múltiplos clientes
    Você pode instalar o produto SolidWorks em múltiplos clientes criando uma imagem administrativa e, depois, distribuindo a instalação para os clientes.
  • Uso de Imagens administrativas
    Uma imagem administrativa permite criar instalações configuráveis dos produtos SolidWorks a partir de um único local na rede.
  • Distribuição pela linha de comando
    Você pode distribuir automaticamente uma imagem administrativa usando o prompt de comando ou um arquivo batch (instalação silenciosa).
  • Administração de múltiplas instalações
    Para múltiplas instalações, as tarefas administrativas incluem a atualização de imagens administrativas com novas versões principais, a aplicação de atualizações de service packs e a remoção de instalações.


Distribuição para múltiplos clientes

Você pode instalar o produto SolidWorks em múltiplos clientes criando uma imagem administrativa e, depois, distribuindo a instalação para os clientes.

O processo de distribuição para múltiplos clientes consiste em:
  1. Criar uma imagem administrativa
    • Criação de uma imagem administrativa com o Gerenciador de Instalação do SolidWorks
    • Criar uma imagem administrativa a partir da linha de comando
  2. Distribuir a imagem administrativa para os clientes.
    • Distribuir uma imagem administrativa aos clientes por e-mail
    • Instalação a partir da imagem administrativa usando a linha de comando
  3. Implementar a licença.
    • Administração de licenças individuais
    • Administração de licenças usando o SolidNetWork License Manager
Tópico pai: Instalações múltiplas


Uso de Imagens administrativas

Uma imagem administrativa permite criar instalações configuráveis dos produtos SolidWorks a partir de um único local na rede.

Você pode instalar a imagem administrativa a partir de qualquer computador da rede, incluindo um computador cliente.
  • A imagem administrativa precisa estar em uma pasta compartilhada.
  • Se você incluir todos os produtos o espaço em disco necessário da imagem administrativa pode chegar a 7GB ou mais.
  • Se você atualizar o nome compartilhado quando atualiza a imagem administrativa, o cliente é atualizado automaticamente da próxima vez que o aplicativo for iniciado. Para obter mais detalhes, consulte Atualização de clientes a partir de imagens administrativas.
  • Os clientes precisam ter privilégios administrativos em seus computadores, a menos que a opção Executar a instalação como outro usuário esteja especificada para a instalação cliente.
    Esta opção não tem suporte no Windows Vista ou posterior.

Uma vez criada uma imagem administrativa, o Editor de Opções de Imagem Administrativa poderá gerenciar as configurações de opção de instalação para os usuários e grupos que estiverem instalando tal imagem. Para obter detalhes, consulte Editor de Opções de Imagem Administrativa.

  • Criação de uma imagem administrativa com o Gerenciador de Instalação do SolidWorks
    Se você está instalando o SolidWorks em múltiplos computadores, pode criar uma imagem administrativa e então distribuir o aplicativo aos outros computadores.
  • Editor de Opções de Imagem Administrativa
    O Editor de Opções de Imagem Administrativa permite personalizar as configurações de parâmetros da instalação em uma imagem administrativa para computadores individuais e grupos de computadores.
  • Distribuir uma imagem administrativa aos clientes por e-mail
    Ao criar um diretório da imagem administrativa compartilhado, você pode notificar os clientes por e-mail.
  • Divulgar uma imagem administrativo para os clientes
    Você pode executar um comando para divulgar uma nova instalação de imagem administrativa para os clientes.
Tópico pai: Instalações múltiplas


Criação de uma imagem administrativa com o Gerenciador de Instalação do SolidWorks

Se você está instalando o SolidWorks em múltiplos computadores, pode criar uma imagem administrativa e então distribuir o aplicativo aos outros computadores.

  1. Inicie o Gerenciador de Instalação do SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
  2. Na tela Bem-vindo, selecione Imagem administrativa.

    As opções de criação de imagem administrativa são exibidas:

    Criar uma nova imagem usando as configurações predeterminadas.
    Criar a imagem usando as definições da configuração padrão (isto é, sem se basear nas definições atualmente estabelecidas para uma imagem administrativa em seu local).
    Criar uma nova imagem usando as configurações e arquivos de uma imagem existente.
    Criar a imagem usando as definições de configuração especificadas para uma imagem administrativa em seu local. Clique em Procurar para especificar o diretório de instalação da imagem administrativa existente.
    Criar imagens administrativas de 32 bits e de 64 bits.
    Você pode criar imagens de 32 e 64 bits em um mesmo computador ou somente a imagem que corresponda à arquitetura do computador em questão. Criar ambas as imagens requer acesso à mídia de instalação de 32 e 64 bits.

  3. Siga as instruções exibidas na tela.
Tópico pai: Uso de Imagens administrativas


Editor de Opções de Imagem Administrativa

O Editor de Opções de Imagem Administrativa permite personalizar as configurações de parâmetros da instalação em uma imagem administrativa para computadores individuais e grupos de computadores.

Depois de criar uma imagem administrativa, o Gerenciador de Instalação do SolidWorks pergunta se você quer iniciar o Editor de Opções. Você pode também iniciar o Editor de Opções clicando duas vezes em sldAdminOptionEditor.exe na pasta da imagem administrativa.

Para especificar configurações de instalação diferentes para grupos ou computadores individuais, adicione os grupos e computadores no Editor de Opções e depois especifique as opções de instalação para eles.

  • Adicionar ou excluir grupos e computadores
    O Editor de Imagem Administrativa permite especificar diferentes configurações de instalação para grupos de computadores e para computadores individuais.
  • Visualizar e editar configurações de opção
    O Editor de opções de Imagem Administrativa do SolidWorks permite visualizar e alterar as configurações de opção para grupos e computadores especificados para a imagem.
  • Alternar entre imagens de 32 e 64 bits
    Se você criou imagens de 32 e de 64 bits no diretório de instalação de imagem administrativa, o Editor de opções poderá operar em ambas as imagens.
  • Distribuir instalações a partir do Editor de Opções
    Você pode distribuir instalações diretamente do Editor de Opções usando instruções por e-mail para iniciar a instalação.
  • Sair do Editor de Opções
    Você pode clicar em OK ou Fechar para sair do Editor de opções.
  • Criar um atalho na Área de Trabalho para o Editor de opções
    Você pode criar de dentro do aplicativo um atalho de área de trabalho do Windows que leva ao Editor de opções para uma determinada imagem administrativa.
Tópico pai: Uso de Imagens administrativas


Adicionar ou excluir grupos e computadores

O Editor de Imagem Administrativa permite especificar diferentes configurações de instalação para grupos de computadores e para computadores individuais.

Por exemplo, você pode querer configurar várias máquinas para utilizar um subconjunto específico dos componentes dos produtos disponíveis na imagem, enquanto outro grupo pode usar um subconjunto diferente de componentes dos produtos. Embora você esteja utilizando uma imagem administrativa, as configurações de grupo do Editor de Opções permitem a instalação de diferentes subconjuntos de produtos em diferentes grupos de máquinas.

Para adicionar um grupo:
  1. Clique com o botão direito do mouse em Configurações globais e clique em Adicionar grupo.
  2. Insira o nome do grupo.
Para adicionar computadores:
  1. Clique com o botão direito do mouse em um grupo existente ou em Configurações globais e clique em Adicionar computador.
    Se você clicar com o botão direito em um grupo existente, os computadores são adicionados ao grupo. Caso contrário, eles são adicionados no nível superior.
  2. Escolha uma das opções a seguir:
    • Insira os nomes de um ou mais computadores em Nome do computador.

      Vários nomes podem ser separados por quebras de linha, espaços, tabulações, vírgulas, ponto-e-vírgula ou dois-pontos. Você pode copiar e colar a lista de nomes de computadores de um arquivo externo.

      Os nomes dos computadores não podem incluir classificadores de domínio. Por exemplo, pluto.solidworks.com é inválido.

    • Clique em Adicionar vários computadores para selecionar os computadores da rede.
Para mover um computador existente para um grupo: Arraste o computador para o grupo.
Para remover um computador de um grupo: Arraste o computador para Configurações globais ou para outro grupo.
Para excluir um grupo ou computador: Clique com o botão direito do mouse no grupo ou computador e clique em Excluir grupo ou Excluir computador.
Se você excluir um grupo, todos os computadores contidos nele serão excluídos.
Para excluir todos os grupos e computadores: Clique com o botão direito do mouse em Configurações globais e clique em Excluir todos.
Tópico pai: Editor de Opções de Imagem Administrativa


Visualizar e editar configurações de opção

O Editor de opções de Imagem Administrativa do SolidWorks permite visualizar e alterar as configurações de opção para grupos e computadores especificados para a imagem.

  • Quando você inicia o Editor de opções pela primeira vez, as configurações de opção são exibidas em modo somente para leitura. O ícone Editar não aparece sombreado: .
    Clicar em Configurações globais, em um grupo ou em um computador exibirá um resumo das configurações de opção do item em questão:
    Escopo | Configurações de opção exibidas
    Configurações globais | Todas as configurações de opção especificadas para a imagem administrativa
    Grupo | Alterações nas configurações do grupo referentes às Configurações globais
    Máquina | Alterações nas configurações do computador referentes ao grupo
  • Para alterar essas configurações de opção, clique no ícone Editar. O ícone fica sombreado ( [image]) e uma lista mais detalhada de configurações de opção é exibida.

    Clicar em Configurações globais, em um grupo ou em um computador permitirá que você altere as configurações de opção do item em questão. Quando você altera uma configuração de opção que difere das Configurações globais herdadas ou das configurações do grupo, essa configuração de opção fica realçada.

    Se você clicar novamente no ícone Editar, a exibição voltará ao modo somente para leitura.

    Se você fizer alterações, o Editor de opções solicitará que você as salve ou ignore ao sair.

  • Especificar as configurações de opção para grupos e computadores
    Você pode especificar configurações de opção para todos os computadores (Configurações globais), para grupos de computadores ou para computadores individuais.
  • Herança de configurações de opção globais e de grupo
    As configurações de opção para Configurações globais ou grupos são herdadas pelos itens que estão abaixo destes.
Tópico pai: Editor de Opções de Imagem Administrativa


Especificar as configurações de opção para grupos e computadores

Você pode especificar configurações de opção para todos os computadores (Configurações globais), para grupos de computadores ou para computadores individuais.

  1. No Editor de Opções, clique no objeto a ser modificado (Configurações globais, um grupo ou um computador).
  2. Clique no ícone Editar [image] à direita.

    O ícone Editar fica sombreado ( [image]) e uma lista mais detalhada de configurações de opção é exibida.

  3. Faça alterações clicando nas configurações de opção à direita, para o item selecionado à esquerda.

    As alterações em configurações de opção que substituem as Configurações globais ou de grupo são realçadas.

  4. Clique em OK ou Fechar para salvar suas alterações.

    OK
    O Editor de Opções salva suas alterações e se fecha.
    Fechar
    O Editor de Opções pergunta se você deseja salvar suas alterações e então se fecha.

  • Configurações de opção de imagem administrativa
    O Editor de Opções permite especificar as configurações de opções de clientes individuais ou grupos, incluindo números de série, opções de instalação de cliente, quais componentes do software devem ser instalados e o local do Toolbox.
Tópico pai: Visualizar e editar configurações de opção


Configurações de opção de imagem administrativa

O Editor de Opções permite especificar as configurações de opções de clientes individuais ou grupos, incluindo números de série, opções de instalação de cliente, quais componentes do software devem ser instalados e o local do Toolbox.

Números de série

Insira os números de série dos produtos a serem instalados nos computadores clientes.
Como há várias maneiras de adquirir produtos SolidWorks, alguns números de série podem cobrir dois ou mais produtos. Por exemplo, um número de série do SolidWorks pode permitir que você instale o SolidWorks Simulation sem inserir um número de série separado para o SolidWorks Simulation. Além disso, alguns produtos não requerem um número de série. Se tiver dúvidas sobre seus números de série, consulte seu VAR.
Se estiver gerenciando licenças usando o Licenciamento SolidWorks:
  • No primeiro campo de número de série, insira o número de série do SolidWorks.
  • No campo porta@servidor do Servidor SNL, insira o nome do servidor do SolidNetWork License Manager e a porta no formato nnnnn@nomeservidor. Separe as entradas diferentes usando ponto-e-vírgula.

Para obter detalhes sobre o licenciamento do SolidNetWork, consulte Instalar e configurar a licença SolidNetWork.

Opções de instalação de cliente

Como deseja executar as instalações das versões principais nos clientes?
Você pode especificar como as instalações de clientes tratarão a existência prévia de uma versão principal anterior:
  • Atualizar uma versão principal existente (se houver).

    Especifique essa opção para substituir a instalação da versão principal anterior com a instalação da nova versão

  • Criar uma nova versão principal.

    Especifique essa opção para manter a versão principal anterior e criar uma nova instalação para a nova versão principal.

    Para especificar um local para a instalação da nova versão, clique em Procurar.

Deseja desinstalar a versão anterior mais recente antes de instalar uma nova versão principal?
Você pode especificar se desinstalará a instalação da versão principal anterior:
  • Não, não desinstalar antes.

    Especifique essa opção para manter a instalação da versão principal anterior.

  • Sim, executar uma desinstalação personalizada.
    Selecione essa opção para remover os itens:
    • Arquivos e pastas de programas.
    • Entradas do registro
    • Arquivos e pastas de dados
Como deseja aplicar as Configurações do SolidWorks?
Você pode especificar que as instalações de clientes ajustem as configurações do SolidWorks com base nas configurações do SolidWorks definidas no computador cliente ou nas configurações do SolidWorks exportadas do Assistente de Cópia de Configurações.
  • Usar as configurações atuais (se existirem) ou usar as configurações predeterminadas do SolidWorks

    Se o computador cliente tiver definido configurações do SolidWorks, mantenha essas configurações (para quaisquer configurações que não estejam definidas especificamente no cliente, o processo de instalação no cliente usará a configuração predeterminada do SolidWorks).

  • Usar um arquivo de configurações exportado do Assistente de Cópia de Configurações.
    Selecionar essa opção permite especificar as configurações de opção para um arquivo de exportação existente do Assistente de Cópia de Configurações. (Em geral, esse arquivo é chamado solidworkssettings.sldreg.)
    • Clique em Procurar para encontrar um arquivo de configurações existente.
    • Clique em Novo para iniciar o Assistente de Cópia de Configurações e criar um novo arquivo de configurações.
Como deseja ativar as instalações de cliente?
Você pode especificar se quer concluir a ativação do produto automaticamente depois de executar a instalação ou solicitar que o usuário execute manualmente a ativação do produto após a instalação.
  • Ativar automaticamente quando cada instalação de cliente for concluída.
    Selecionar essa configuração de opção especifica que a ativação do produto é executada automaticamente usando um arquivo da Ativação de Produtos SolidWorks. (Em geral, esse arquivo tem o nome AutoActivation.xml.)
    • Clique em Procurar para encontrar um arquivo de ativação existente.
    • Clique em Novo para iniciar a Ativação de Produtos SolidWorks e criar um novo arquivo de ativação.
  • Não ativar automaticamente.

    Selecionar essa configuração de opção especifica que não deve ocorrer uma ativação de produto automática. O usuário cliente executa a ativação do produto após a instalação.

Se você especificar a ativação de produto automática, a imagem administrativa precisa estar disponível no local de compartilhamento da rede na primeira vez que os clientes executam o SolidWorks depois da instalação. Se a imagem administrativa não estiver disponível para os clientes que instalaram a partir dela, eles não poderão concluir a ativação automática do produto. Eles não poderão executar o SolidWorks a menos que executem a Ativação de Produtos SolidWorks manualmente.

Opções administrativas

Criar um arquivo de log de diagnóstico durante cada instalação
Uma instalação de cliente pode criar um log de diagnóstico que pode ser usado para resolver problemas de instalação. A criação desse log pode fazer com que a instalação de cliente seja executada mais lentamente.
Executar a instalação como outro usuário.
Uma instalação de cliente pode ser executada como um usuário diferente. Essa opção pode ser útil quando usuários individuais não possuem permissões administrativas locais em seus computadores (necessárias para a instalação de produtos SolidWorks).
Não há suporte para esse recurso no Windows Vista nem no Windows 7 ou posterior.
Executar um programa antes ou depois da instalação
Você pode especificar que um programa personalizado seja executado antes ou depois da instalação de cliente.
Quer que os clientes participem do Programa de Experiência do Cliente SolidWorks?
Você pode especificar que os computadores clientes participem do Programa de experiência do Cliente da SolidWorks. As informações de desempenho são enviadas à SolidWorks Corporation para ajudar no aperfeiçoamento do produto. O processo é transparente e confidencial. Para obter detalhes, consulte o site do Programa de Aprimoramento da Experiência do Cliente.

Software a instalar

Você pode especificar quais componentes do produto SolidWorks deseja instalar.
  • Marcar a caixa de seleção próxima ao componente especificará que este será instalado durante a instalação de cliente.
  • Desmarcar a caixa de seleção especificará que o componente não será instalado.
  • Se um componente contiver subcomponentes de instalação opcional, um ícone + aparecerá próximo ao componente. Para ver os subcomponentes disponíveis para um componente, clique no ícone + .
  • Se um componente tiver sido expandido para mostrar seus subcomponentes opcionais, um ícone - aparecerá próximo ao componente. Para recolher a lista de subcomponentes, clique no ícone - .
A especificação Idiomas, somente no produto SolidWorks, limita os idiomas que são instalados. As instalações de outros produtos não são afetadas por essa especificação. Por exemplo, para o SolidWorks eDrawings®, o SolidWorks Workgroup PDM, e o SolidWorks Explorer todos os idiomas são instalados.

Opções do Toolbox

Você pode especificar que padrões suportar e o local do Toolbox padrão para instalações de clientes.

É comum ter vários usuários acessando um Toolbox compartilhado, normalmente através de um local de rede (por exemplo, um caminho UNC, uma pasta compartilhada ou uma unidade de rede comum).

Se o local contiver uma versão principal mais antiga do Toolbox, a instalação de cliente atualizará esse Toolbox com a nova versão principal. Os arquivos não mais serão compatíveis com as versões principais anteriores do SolidWorks.
Se quiser manter o Toolbox para a versão mais antiga do SolidWorks (por exemplo, se alguns clientes quiserem continuar usando a versão mais antiga), você terá que especificar um local de rede diferente do Toolbox para clientes que estiverem atualizando para a nova versão.

Para obter detalhes sobre a administração do Toolbox do SolidWorks, consulte as informações sobre Toolbox na Ajuda do SolidWorks.

Tópico pai: Especificar as configurações de opção para grupos e computadores


Herança de configurações de opção globais e de grupo

As configurações de opção para Configurações globais ou grupos são herdadas pelos itens que estão abaixo destes.

Por exemplo:
  • As configurações definidas em Configurações globais são herdadas por todos os grupos e computadores.
  • As configurações definidas para um grupo são herdadas por todos os computadores no grupo.

Você pode alterar as configurações para um computador ou grupo para sobrescrever os valores predeterminados ou as configurações herdadas. Quando você altera o valor predeterminado ou herdado da configuração de uma opção, a opção é realçada.

Para reverter a opção aos valores herdados originais, clique com o botão direito no grupo ou computador e selecione Reverter para as configurações globais (para um grupo ou computador que não é membro de um grupo) ou Reverter para as configurações do grupo (para um computador que é membro de um grupo).
Tópico pai: Visualizar e editar configurações de opção


Alternar entre imagens de 32 e 64 bits

Se você criou imagens de 32 e de 64 bits no diretório de instalação de imagem administrativa, o Editor de opções poderá operar em ambas as imagens.

  • No Editor de opções, clique em 32 ou 64 para operar na imagem de 32 bits ou na imagem de 64 bits.

    Clicar em Configurar ou Distribuir permitirá que você veja e modifique as configurações de opção ou distribua instalações para a respectiva imagem.

Se você tiver imagens de 32 bits e de 64 bits, terá que especificar Configurações Globais, grupos e configurações de grupo, bem como configurações de computador individual separadamente para cada imagem.
Tópico pai: Editor de Opções de Imagem Administrativa


Distribuir instalações a partir do Editor de Opções

Você pode distribuir instalações diretamente do Editor de Opções usando instruções por e-mail para iniciar a instalação.

É preciso alterar o diretório de instalação de imagem administrativa para um diretório Windows compartilhado, de forma que ele esteja disponível através de um local de rede (por exemplo, \\computador\diretorio_compartilhado).

  1. No Editor de Opções, clique em Distribuição.
  2. Se tiver imagens de 32 e 64 bits configuradas para esse diretório de instalação de imagem administrativa, clique em 32 ou 64 para ver os computadores para a imagem de 32 ou 64 bits.

    A disponibilidade da instalação e o status de cada computador serão exibidos.

  3. Clique em Enviar e-mail.
  4. Especifique o caminho de rede até o diretório de instalação da imagem administrativa.

    Normalmente, o caminho até o diretório de instalação de imagem administrativa é exibido inicialmente como um caminho de arquivo do Windows (por exemplo, C:\SolidWorks Admin\SolidWorks 2011 SP0). A caixa de diálogo indica Este não é um caminho da rede.

    1. Clique em Procurar para especificar o local de rede deste diretório de instalação de imagem administrativa.
    2. Acesse o computador onde a imagem administrativa está instalada e selecione o diretório compartilhado do Windows especificado para o diretório de instalação de imagem administrativa.

      Não navegue dentro do diretório compartilhado de imagem administrativa (por exemplo, nos subdiretórios 32bit ou 64bit).

    3. Clique em OK.

      A caixa de diálogo indica Este é um caminho da rede.

    Um e-mail é criado para instruir o proprietário do computador a instalar a partir da imagem administrativa usando o local de rede para o arquivo StartSWInstall.hta na imagem administrativa.

  5. Envie o e-mail aos usuários responsáveis por instalar o SolidWorks.

Os usuários podem clicar duas vezes no link do e-mail que leva ao local do StartSWInstall.hta na rede para instalar o SolidWorks a partir da imagem administrativa.

No Editor de Opções, o Status da instalação mostra:
Pendente
O usuário ainda não executou a instalação neste computador.
Concluído com êxito
O usuário conclui com êxito a instalação neste computador.
Falhou
O usuário executou a instalação neste computador, mas ela falhou.
  • Usar uma unidade mapeada para distribuir uma imagem administrativa
    Um caminho UNC (\\nome_do_computador\nome_compartilhamento) é o método recomendado para especificar um local de rede para o diretório de instalação de imagem administrativa. No entanto, você pode usar uma unidade mapeada como local do arquivo StartSWInstall.hta na imagem administrativa (por exemplo, U:\StartSWInstall.hta), desde que todos os usuários instaladores tenham essa mesma letra de unidade mapeada para o diretório compartilhado de imagem administrativa.
Tópico pai: Editor de Opções de Imagem Administrativa


Usar uma unidade mapeada para distribuir uma imagem administrativa

Um caminho UNC (\\nome_do_computador\nome_compartilhamento) é o método recomendado para especificar um local de rede para o diretório de instalação de imagem administrativa. No entanto, você pode usar uma unidade mapeada como local do arquivo StartSWInstall.hta na imagem administrativa (por exemplo, U:\StartSWInstall.hta), desde que todos os usuários instaladores tenham essa mesma letra de unidade mapeada para o diretório compartilhado de imagem administrativa.

Por exemplo, se você mapear a unidade U: para o diretório compartilhado de imagem administrativa, o e-mail de notificação instruirá os usuários a clicar em um link file://U:\StartSWIOnstall.hta. Os usuários que receberem o e-mail poderão efetuar a instalação com êxito, desde que a unidade U: esteja mapeada para o local UNC da imagem administrativa (\\nome_do_computador\share_namenome_compartilhamento).

Tópico pai: Distribuir instalações a partir do Editor de Opções


Sair do Editor de Opções

Você pode clicar em OK ou Fechar para sair do Editor de opções.

  • Clique em OK, Fechar ou use o botão Fechar do Windows para aplicar alterações e sair do Editor de opções.
    • Clique em OK para aplicar qualquer alteração efetuada em configuração de opção e sair do Editor de opções.
    • Clique em Fechar para sair do Editor de opções.

      Se houver alterações a serem aplicadas, será perguntado se você deseja salvá-las.

    • Clique no botão Fechar do Windows (X). Se houver alterações a serem aplicadas, será perguntado se você deseja salvá-las.
Tópico pai: Editor de Opções de Imagem Administrativa


Criar um atalho na Área de Trabalho para o Editor de opções

Você pode criar de dentro do aplicativo um atalho de área de trabalho do Windows que leva ao Editor de opções para uma determinada imagem administrativa.

  1. Inicie o Editor de opções.

    Por exemplo, no Windows Explorer, acesse o diretório de instalação de imagem administrativa e clique duas vezes em sldAdminOptionEditor.exe.

  2. Clique em Criar atalho na Área de Trabalho para esse Editor de Opções.

    Um atalho que leva ao Editor de opções para a imagem administrativa aparecerá na área de trabalho do Windows.

Tópico pai: Editor de Opções de Imagem Administrativa


Distribuir uma imagem administrativa aos clientes por e-mail

Ao criar um diretório da imagem administrativa compartilhado, você pode notificar os clientes por e-mail.

Configure o diretório da imagem administrativa a ser compartilhado em um computador que está disponível para outros computadores (por exemplo, através de um caminho UNC).

Você pode enviar um e-mail contendo um link para diretório_de_instalação_da_imagem_administrativa\StartSWInstall.hta a todos os clientes. Depois disso, os clientes podem clicar nesse link e em Instalar os produtos SolidWorks agora para iniciar a instalação a partir da imagem administrativa.

Se estiver atualizando uma imagem administrativa para uma nova versão do SolidWorks, você pode configurar o local da imagem e as propriedades de compartilhamento para que qualquer cliente que fez a instalação anteriormente usando aquela imagem seja atualizado automaticamente. Para obter detalhes, consulte Atualização de clientes a partir de Imagens Administrativas.
Tópico pai: Uso de Imagens administrativas


Divulgar uma imagem administrativo para os clientes

Você pode executar um comando para divulgar uma nova instalação de imagem administrativa para os clientes.

Distribuição por e-mail é o método geralmente usado para notificar os clientes sobre uma nova instalação do SolidWorks. Para obter detalhes, consulte Distribuir uma imagem administrativa aos clientes por e-mail.

Entretanto, como alternativa, você pode executar um comando para divulgar uma nova instalação para os clientes. Por exemplo, você pode divulgar a instalação para os empregados que normalmente não usam o aplicativo SolidWorks.

A divulgação do SolidWorks cria um atalho para o aplicativo SolidWorks no menu Iniciar no computador do cliente e cria uma associação de arquivo com a imagem administrativa no servidor. Inicialmente, os arquivos executáveis não são instalados. A instalação ocorre somente quando o usuário precisa usar pela primeira vez o aplicativo.

Quando o usuário clica no atalho ou clica duas vezes em um documento do SolidWorks, a instalação começa e o aplicativo SolidWorks é executado.

Para divulgar uma imagem administrativa:

  1. Crie e configure a imagem administrativa.
  2. Publique o produto em cada computador onde o aplicativo SolidWorks está sendo instalado.

    Por exemplo:

    msiexec /jm caminho_para_o_arquivo_msi_da_imagem_administrativa

    onde caminho_para_o_arquivo_msi_da_imagem_administrativa representa um caminho UNC para o diretório da imagem administrativa.

Tópico pai: Uso de Imagens administrativas


Distribuição pela linha de comando

Você pode distribuir automaticamente uma imagem administrativa usando o prompt de comando ou um arquivo batch (instalação silenciosa).

  • Criar uma imagem administrativa a partir da linha de comando
    Você pode criar uma imagem administrativa usando o Gerenciador de Instalação do SolidWorks ou a linha de comando do MS-DOS.
  • Preparar clientes para a instalação pela linha de comando a partir de uma imagem administrativa
    Depois de criar a imagem administrativa e antes de notificar os clientes, você precisa instalar os componentes do Microsoft Windows que não podem ser instalados pelas imagens administrativas criadas com a linha de comando ou com o Microsoft Active Directory.
  • Instalação a partir da imagem administrativa usando a linha de comando
    Você pode distribuir instalações a partir de uma imagem administrativa usando a linha de comando.
  • Propriedades de linha de comando
    As propriedades de linha de comando descritas aqui incluem as propriedades de recursos, globais, específicas dos produtos e as convenções de locais do Windows.
  • Distribuição de uma imagem administrativa usando o Microsoft Active Directory
    A Distribuição pelo Microsoft Active Directory tem suporte para a distribuição do produto central SolidWorks aos clientes.
Tópico pai: Instalações múltiplas


Criar uma imagem administrativa a partir da linha de comando

Você pode criar uma imagem administrativa usando o Gerenciador de Instalação do SolidWorks ou a linha de comando do MS-DOS.

Ao criar imagens administrativas a partir da linha de comando, é preciso criar e distribuir uma imagem separada para cada componente de produto SolidWorks executando o arquivo .msi de cada componente. Se estiver instalando idiomas diferentes do inglês, você terá que criar e distribuir uma imagem separada para cada idioma que não o inglês executando o arquivo .msi da cada idioma. Para obter detalhes sobre a localização dos arquivos .msi, consulte Locais dos arquivos MSI para imagens administrativas.
  1. Abra uma janela de Prompt de comando .
    1. No Windows, clique em Iniciar > Executar.
    2. Digite cmd e clique em OK.
  2. Digite o comando:

    msiexec /a Caminho_do_arquivo_msi

    onde Caminho_do_arquivo_msi é a localização do arquivo .msi no seu sistema operacional. O SolidWorks.msi está localizado no subdiretório swwi\data no diretório de instalação.

    Por exemplo:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. No Assistente de Instalação do SolidWorks, siga as instruções apresentadas na tela.
  4. Se estiver instalando produtos SolidWorks para idiomas diferentes do inglês, crie uma imagem administrativa separada para cada idioma usando esse comando:

    msiexec /a Caminho_do_arquivo_msi_para_idioma

    onde Caminho_do_arquivo_msi_para_idioma é a localização do arquivo .msi para o idioma em questão. Por exemplo, french.msi está localizado no subdiretório swwi\lang\french dentro do diretório de instalação.

    Por exemplo:

    msiexec /a F:\swwi\lang\french\french.msi

Tópico pai: Distribuição pela linha de comando


Preparar clientes para a instalação pela linha de comando a partir de uma imagem administrativa

Depois de criar a imagem administrativa e antes de notificar os clientes, você precisa instalar os componentes do Microsoft Windows que não podem ser instalados pelas imagens administrativas criadas com a linha de comando ou com o Microsoft Active Directory.

A instalação manual desses componentes do Windows só é necessária se a instalação é feita a partir de uma imagem administrativa que foi criada manualmente, usando a linha de comando ou o Microsoft Active Directory. Se você usar o Gerenciador de Instalação do SolidWorks para criar e instalar a imagem administrativa, esses componentes do Windows serão instalados automaticamente.
Este é um resumo dos arquivos requeridos pelo SolidWorks nos componentes Windows:
Windows Installer:
Contém os arquivos necessários para executar a instalação do SolidWorks Simulation Premium.
Office Web Components
Contém os controles COM necessários para o DriveWorks.
Visual C++ Redistributable Package 2005 e 2008
Contém os componentes de tempo de execução para o Microsoft Visual C++.
Tanto a versão 2005 como a 2008 precisam estar instaladas.
Visual Studio Tools for Applications
Contém um conjunto de ferramentas com suporte para os aplicativos Visual Studio.
Visual Studio Remote Debugger
Fornece um ambiente de depuração para sistemas operacionais de 64 bits.
.NET Framework
Contém a linguagem de tempo de execução comum e os componentes .NET Framework necessários para executar os aplicativos .NET Framework.
Windows Desktop Search (opcional)
Fornece o suporte para pesquisas rápidas de arquivos e dados em todos os locais e origens de dados, incluindo o computador local e as redes compartilhadas.
Os arquivos do Windows Desktop Search são específicos do idioma. Para obter detalhes, consulte Suporte para idiomas do Windows Desktop Search.
O Visual C++ Redistributable Package e o .NET Framework 3,5 são necessários para todos os produtos SolidWorks, não apenas para o produto SolidWorks principal.

Esses componentes precisam ser incluídos em subdiretórios do diretório da imagem administrativa.

Esta tabela identifica os arquivos específicos necessários para cada sistema operacional com suporte.
Sistema operacional: Windows 2003 de 32 bits1
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (não se aplica)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional)
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-idioma.exe
Sistema operacional: Windows 2003 de 64 bits1
Mídia do SolidWorks: versão de 64 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional)
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operacional: Windows 2008 de 32 bits1
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (não se aplica)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional) |  | O Windows Desktop Search é um recurso do sistema operacional.
Sistema operacional: Windows 2008 de 64 bits1
Mídia do SolidWorks: versão de 64 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional) |  | O Windows Desktop Search é um recurso do sistema operacional.
Sistema operacional: Windows XP de 32 bits
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (não se aplica)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional)
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-idioma.exe
Sistema operacional: Windows XP de 64 bits
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional)
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operacional: Windows XP de 64 bits
Mídia do SolidWorks: versão de 64 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional)
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operacional: Windows Vista de 32 bits
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (não se aplica)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional) |  | O Windows Desktop Search é um recurso do sistema operacional.
Sistema operacional: Windows Vista de 64 bits
Mídia do SolidWorks: versão de 64 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opcional) |  | O Windows Desktop Search é um recurso do sistema operacional.
Sistema operacional: Windows 7 de 32 bits
Mídia do SolidWorks: versão de 32 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (não se aplica)
 | .NET Framework: |  | .NET Framework e Windows Desktop Search são recursos do sistema operacional.
 | Windows Desktop Search (opcional)
Sistema operacional: Windows 7 de 64 bits
Mídia do SolidWorks: versão de 64 bits do Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (não se aplica)
 | Office Web Components: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Ambos precisam estar instalados.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework e Windows Desktop Search são recursos do sistema operacional.
 | Windows Desktop Search (opcional)
1A instalação no Windows 2003 ou Windows 2008 só tem suporte para o Servidor do Workgroup PDM e o Servidor de Licenças SolidNetWork (SNL).
  • Instalar os pré-requisitos do Windows a partir da linha de comando em sistemas operacionais de 32 bits
    Siga este processo para instalar os pré-requisitos do Windows para instalações de imagens administrativas usando a linha de comando em versões do Windows de 32 bits.
  • Instalar os pré-requisitos do Windows a partir da linha de comando em sistemas operacionais de 64 bits
    Siga este processo para instalar os pré-requisitos do Windows para instalações de imagens administrativas usando a linha de comando em versões do Windows de 64 bits.
  • Pesquisa do SolidWorks e Microsoft Windows Desktop Search
    A Pesquisa do SolidWorks está integrada ao Microsoft® Windows® Desktop Search.
Tópico pai: Distribuição pela linha de comando


Instalar os pré-requisitos do Windows a partir da linha de comando em sistemas operacionais de 32 bits

Siga este processo para instalar os pré-requisitos do Windows para instalações de imagens administrativas usando a linha de comando em versões do Windows de 32 bits.

Para instalar múltiplos componentes em uma só operação de instalação, crie um arquivo de lote (batch) com os comandos fornecidos nos procedimentos descritos a seguir para inserir (push) os componentes nos computadores clientes.

  1. Certifique-se de que o computador alvo tem pelo menos 290 MB de espaço disponível em disco e um diretório TEMP válido.
  2. Instale o Office Web Components executando o seguinte comando:

    diretório_da_imagem_administrativa\OfficeWeb_11\owc11.exe

  3. No Windows XP, instale o Windows Installer:

    diretório_da_imagem_administrativa\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Não é necessário instalar o Windows Installer em nenhuma outra versão do Windows além do Windows XP.

  4. Instale o Visual C++ 2005 Redistributable Package:

    diretório_da_imagem_administrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Instale o Visual C++ 2008 Redistributable Package:

    diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. No Windows XP e no Windows Vista, instale o Microsoft .NET Framework 3.5 usando os serviços Windows Server Update Services.

    Não é necessário instalar a imagem do .NET Framework no Windows 7 ou posterior.

  7. Instale o Visual Studio Tools for Applications:

    diretório_da_imagem_administrativa\Microsoft_VSTA\vsta_aide.msi

Tópico pai: Preparar clientes para a instalação pela linha de comando a partir de uma imagem administrativa


Instalar os pré-requisitos do Windows a partir da linha de comando em sistemas operacionais de 64 bits

Siga este processo para instalar os pré-requisitos do Windows para instalações de imagens administrativas usando a linha de comando em versões do Windows de 64 bits.

Para instalar múltiplos componentes em uma só operação de instalação, crie um arquivo de lote (batch) com os comandos fornecidos nos procedimentos descritos a seguir para inserir (push) os componentes nos computadores clientes.

  1. Certifique-se de que o computador alvo tem pelo menos 620 MB de espaço disponível em disco e um diretório TEMP válido.
  2. Instale o Office Web Components executando o seguinte comando:

    diretório_da_imagem_administrativa\OfficeWeb_11\owc11.exe

  3. Instale o Visual C++ 2005 Redistributable Package:

    diretório_da_imagem_administrativa\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    diretório_da_imagem_administrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Ambas as versões para 32 bits e para 64 bits deste pacote precisam ser instaladas.

  4. Instale o Visual C++ 2008 Redistributable Package:

    diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Ambas as versões para 32 bits e para 64 bits deste pacote precisam ser instaladas.

  5. No Windows XP e no Windows Vista, instale o Microsoft .NET Framework 3.5 usando os serviços Windows Server Update Services.

    Não é necessário instalar a imagem do .NET Framework no Windows 7 ou posterior.

  6. Instale o Visual Studio Tools for Applications:

    diretório_da_imagem_administrativa\Microsoft_VSTA\vsta_aide.msi

  7. Instale o Visual Studio Remote Debugger:

    diretório_da_imagem_administrativa\VSRemoteDebugger\install.exe /Q

Tópico pai: Preparar clientes para a instalação pela linha de comando a partir de uma imagem administrativa


Pesquisa do SolidWorks e Microsoft Windows Desktop Search

A Pesquisa do SolidWorks está integrada ao Microsoft® Windows® Desktop Search.

Se a versão correta do Windows Desktop Search ainda não estiver instalada em seu computador, você deve instalá-la e atualizá-la durante a instalação do SolidWorks.

Se estiver criando uma imagem administrativa, o Windows Desktop Search não estará incluído no diretório da imagem administrativa. O Microsoft Windows Desktop Search precisa ser instalado manualmente nos computadores que instalam o SolidWorks a partir de uma imagem administrativa, caso se deseje usar a Pesquisa do SolidWorks nesses computadores.

Tópico pai: Preparar clientes para a instalação pela linha de comando a partir de uma imagem administrativa


Instalação a partir da imagem administrativa usando a linha de comando

Você pode distribuir instalações a partir de uma imagem administrativa usando a linha de comando.

Para executar uma instalação silenciosa:
  1. Abra uma janela de prompt de comando (no Windows, clique em Iniciar > Executar.
  2. Digite o comando msiexec.exe com as chaves /i e /qb e defina as propriedades para quaisquer opções que não sejam os valores predeterminados, como descrito abaixo.
As propriedades de linha de comando de componentes de instalação individuais incluem:
  • Propriedades de recurso da linha de comando
  • Propriedades globais da linha de comando
  • Propriedades de linha de comando do SolidWorks eDrawings
  • Propriedades da linha de comando do SolidWorks Explorer/Workgroup PDM
  • Propriedades da linha de comando do SolidWorks Flow Simulation
Use os seguintes exemplos como modelo para sua instalação silenciosa.
SolidWorks Client
  • SolidWorks principal (em inglês)
  • Suplemento Toolbox
  • Participação no programa de resposta de desempenho
  • Idioma francês

Versão de 32 bits do SolidWorks em sistema operacional de 32 bits:

msiexec /i "caminho_imagem_admin_32-bits\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Arquivos de programa\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

Versão de 32 bits do SolidWorks em sistema operacional de 64 bits:

msiexec /i "caminho_imagem_admin_32-bits\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Arquivos de programa\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

Versão de 64 bits do SolidWorks em sistema operacional de 64 bits:

msiexec /i "caminho_imagem_admin_64-bits\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Arquivos de programa\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

O componente de instalação do idioma francês do SolidWorks deve ser instalado separadamente.
  • Versão de 32 bits:

    msiexec /i "caminho_imagem_admin_32-bits\SolidWorks French\french.msi" /qb

  • Versão de 64 bits:

    msiexec /i "caminho_imagem_admin_64-bits\SolidWorks French\french.msi" /qb

Ao especificar comandos de instalação de componente de idioma do SolidWorks, não inclua argumentos de linha comando.
eDrawings Client
  • Log de desempenho
  • Todos os recursos

msiexec /i "caminho_imagem_admin\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Arquivos de programa\sua_pasta" LOGPERFORMANCE=1 SNLSERVER=servidor_eDrawings_SNL TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer e suplemento Workgroup PDM
  • SolidWorks Explorer com o suplemento Workgroup PDM

msiexec /i "caminho_imagem_admin\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Arquivos de programa\sua_pasta" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
Tópico pai: Distribuição pela linha de comando


Propriedades de linha de comando

As propriedades de linha de comando descritas aqui incluem as propriedades de recursos, globais, específicas dos produtos e as convenções de locais do Windows.

  • Propriedades de recurso da linha de comando
    A instalação do SolidWorks oferece suporte a estas propriedades ADDLOCAL para a distribuição pela linha de comando.
  • Propriedades globais da linha de comando
    Cada propriedade é definida para instalações administrativas ou individuais, a menos que indicado de outra forma. Os números de série podem ser passados tanto para uma instalação administrativa como para uma individual usando propriedades globais.
  • Propriedades de linha de comando do SolidWorks eDrawings
    Essas propriedades de linha de comando são específicas do eDrawings.
  • Propriedades da linha de comando do SolidWorks Explorer/Workgroup PDM
    Essas propriedades de linha de comando são específicas do SolidWorks Explorer e SolidWorks Workgroup PDM.
  • Propriedades da linha de comando do SolidWorks Flow Simulation
    Essas propriedades de linha de comando são específicas do SolidWorks Flow Simulation.
  • Locais dos arquivos MSI para imagens administrativas
    Para criar imagens administrativas a partir da linha de comando, os arquivos .msi do componente de produto são armazenados nesses locais na mídia do SolidWorks.
  • Suporte para idiomas do Windows Desktop Search
    Os nomes de arquivos no Windows Desktop Search indicam informações de plataforma e idioma.
Tópico pai: Distribuição pela linha de comando


Propriedades de recurso da linha de comando

A instalação do SolidWorks oferece suporte a estas propriedades ADDLOCAL para a distribuição pela linha de comando.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (para SolidWorks de 32 bits em sistemas operacionais de 32 bits)
  • Intel_Modules_AgeiaX64 (para SolidWorks de 32 bits em sistemas operacionais de 64 bits)
  • Manuais
  • Movimento
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
Ao especificar propriedades para instalação pela linha de comando:
  • O SolidWorks não oferece suporte para a instalação do produto usando a opção ADDSOURCE.
  • As propriedades diferenciam maiúsculas e minúsculas, não podem conter espaços ou traços, e precisam ser separadas por vírgulas.
  • SolidWorks precisa ser especificado para que o aplicativo SolidWorks seja instalado corretamente.
Tópico pai: Propriedades de linha de comando


Propriedades globais da linha de comando

Cada propriedade é definida para instalações administrativas ou individuais, a menos que indicado de outra forma. Os números de série podem ser passados tanto para uma instalação administrativa como para uma individual usando propriedades globais.

Propriedade | Descrição
ENABLEPERFORMANCE Se o aplicativo deve automaticamente enviar e-mails com dados de desempenho à SolidWorks Corporation.

1 para enviar os dados de desempenho, 0 para não enviar.
INSTALLDIR A pasta de instalação para o SolidWorks.

Somente instalações individuais.
INSTALLWDS Instale as extensões do SolidWorks que usam o Microsoft Windows Desktop Search Engine. Para obter detalhes, consulte Preparar clientes para a instalação com uma imagem administrativa,

1 para instalar as extensões, 0 para não instalar.
MOTIONSERIALNUMBER | O número de série do produto SolidWorks Motion
OFFICEOPTION Especifique o pacote do produto a ser instalado:
0
SolidWorks Client
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL SpecifIque ALL para atualizar todos os recursos atualmente instalados.
Especifique esta propriedade somente quando estiver atualizando uma versão de Service Pack dentro de uma mesma versão principal existente (por exemplo, atualização de uma instalação existente do SolidWorks 2011 SP01 para o SolidWorks 2011 SP02).
REINSTALLMODE Opções de reinstalação do Microsoft Installer.

Por exemplo, ao fazer a atualização de uma versão de Service Pack para outra dentro de uma mesma versão principal de instalação, você deve especificar REINSTALLMODE=vomus.

Para obter detalhes sobre as configurações de REINSTALLMODE, consulte a documentação do Windows Installer em www.microsoft.com.

Especifique esta propriedade somente quando estiver atualizando uma versão de Service Pack dentro de uma mesma versão principal existente (por exemplo, atualização de uma instalação existente do SolidWorks 2011 SP01 para o SolidWorks 2011 SP02). Não especifique essa propriedade na primeira vez que instalar uma versão principal do SolidWorks.
SERVERLIST Lista do Servidor SolidNetWork.
A lista de servidores SolidNetWork é uma lista de strings delimitadas por ponto-e-vírgula, sendo que cada uma se refere a um número de porta de um servidor, no formato:

xxxxx@nome_do_servidor1; yyyyy@nome_do_servidor2;&

onde x e y são dígitos únicos. Não inclua um ponto-e-vírgula após o nome do último servidor na lista.

Somente instalações individuais.
SIMULATIONSERIALNUMBER | O número de série do produto SolidWorks Simulation
SOLIDWORKSSERIALNUMBER | O número de série do produto SolidWorks, que inclui todos os suplementos.
SWMIGRATE Versão do SolidWorks a ser atualizada, como deve ser mostrado na lista da caixa de diálogo da Opção de instalação do SolidWorks. Por exemplo:

SWMIGRATE="SolidWorks 2011 SP01"

Especifique essa propriedade somente quando estiver instalando uma versão principal e já houver outra versão principal anterior instalada. Não especifique essa propriedade ao atualizar de uma versão de Service Pack para outra dentro de uma mesma versão principal.
TARGETDIR A pasta de instalação para o SolidWorks.

Somente imagem administrativa.
TOOLBOXFOLDER A pasta de instalação para os arquivos do SolidWorks Toolbox.

Somente instalações individuais.
TRANSFORMS Contém itens específicos do idioma no formato:
TRANSFORMS número.mst
  • Chinês (1028)
  • Chinês simplificado (2052)
  • Tcheco (1029)
  • Inglês (1033)
  • Fancês (1036)
  • Alemão (1031)
  • Italiano (1040)
  • Japonês (1041)
  • Coreano (1042)
  • Polonês (1045)
  • Português brasileiro (1046)
  • Russo (1049)
  • Espanhol (1034)
  • Turco (1055)
UPGRADESWINSTALL
Especifique se deve ser atualizada uma versão existente do SolidWorks com a versão atual.
0
Nova instalação, sem atualização
1
Atualizar

Somente instalações individuais.

Especifique essa propriedade somente quando estiver instalando uma versão principal e já houver outra versão principal anterior instalada. Não especifique essa propriedade ao atualizar de uma versão de Service Pack para outra dentro de uma mesma versão principal.
Tópico pai: Propriedades de linha de comando


Propriedades de linha de comando do SolidWorks eDrawings

Essas propriedades de linha de comando são específicas do eDrawings.

Propriedade | Descrição
ADDLOCAL Especifica que parte do aplicativo SolidWorks eDrawings deve ser instalada.

All (todos) é a opção recomendada.
Sintaxe da linha de comando: Recurso:
All | Instala todos os recursos. O aplicativo eDrawings procura aplicativos de editor do SolidWorks e do AutoCAD instalados para validar a instalação.
eDrawingsViewer | Exibe arquivos do eDrawings e outros tipos de arquivo.
PublisherForAutoCADR14 | Cria arquivos do eDrawings a partir do aplicativo AutoCAD R14.
PublisherForAutoCAD2000 | Cria arquivos do eDrawings a partir do aplicativo AutoCAD 2000.
PublisherForAutoCAD2004 | Cria arquivos do eDrawings a partir do aplicativo AutoCAD 2004.
PublisherForAutoCAD2005 | Cria arquivos do eDrawings a partir do aplicativo AutoCAD 2005.
PublisherForAutoCAD2006 | Cria arquivos do eDrawings a partir do aplicativo AutoCAD 2006.
DXFDWGTranslator | Exibe arquivos DXF/DWG no eDrawings Viewer.
Atalhos | Instala o atalho na área de trabalho.
XML3D | Exibe arquivos 3DXML no eDrawings Viewer.
INSTALLDIR | Especifica a pasta de instalação para o SolidWorks eDrawings.
LOGPERFORMANCE Especifica se o aplicativo deve automaticamente enviar e-mails com dados de desempenho à SolidWorks Corporation.
1
Envia dados de desempenho
0
Não envia
SNLSERVER Especifique a porta@nome_do_servidor do seu servidor de licenças SolidNetWork. Use ponto-e-vírgula para separar várias combinações de porta@nome_do_servidor.

O nome da porta do servidor para SNLSERVER só é necessário para a configuração do servidor SolidWorks SNL. lista_de_portas@strings_do_servidor é uma lista de strings delimitadas por ponto-e-vírgula, sendo que cada string se refere ao número de uma porta em um servidor, no formato:

xxxxx@nome_do_servidor1; yyyyy@nome_do_servidor2;

onde x e y são dígitos únicos. Não inclua um ponto-e-vírgula após o nome do último servidor na lista.
Tópico pai: Propriedades de linha de comando


Propriedades da linha de comando do SolidWorks Explorer/Workgroup PDM

Essas propriedades de linha de comando são específicas do SolidWorks Explorer e SolidWorks Workgroup PDM.

Para clientes do SolidWorks Explorer/Workgroup PDM:
Propriedade de cliente | Descrição
EXPLORERORPDM
0
Somente para o SolidWorks Explorer
1
Os recursos do Workgroup PDM podem ser instalados
ADDLOCAL
  • Standalone
  • Cliente
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone é o Contributor e Client é o suplemento do SolidWorks para as instalações silenciosas do SolidWorks Explorer.

Se você especificar AutoCAD, o AutoCAD precisa estar instalado no seu sistema. O Workgroup PDM localiza a versão apropriada do AutoCAD. Você pode especificar mais de uma versão do AutoCAD:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 e DocMgr64 só funcionam com instalações do SolidWorks Explorer de 64 bits.

INSTALLDIR | Especifica a pasta de instalação para o Workgroup PDM.
ACTIVSERIALNUMBER | Especifica o número de série do SolidWorks.
Para o Workgroup PDM Server:
Propriedade de servidor | Descrição
ADDLOCAL
  • Vault
  • WebPortal
  • API

Se especificar WebPortal (o Viewer), você terá que especificar também VAULTNAME.
INSTALLDIR | Especifica a pasta de instalação para o Workgroup PDM.
LICENSE_SERVER | Especifica o nome do computador onde o servidor de licenças reside.
VAULTDATA | Especifica o caminho e a pasta do vault.
VAULTNAME | Especifica o nome do computador onde o vault reside.
Tópico pai: Propriedades de linha de comando


Propriedades da linha de comando do SolidWorks Flow Simulation

Essas propriedades de linha de comando são específicas do SolidWorks Flow Simulation.

Propriedade | Descrição
ACTIVSERIALNUMBER Número de série do SolidWorks Flow Simulation standalone.

(instalações individuais e de cliente a partir de uma imagem administrativa)
CWUPGRADEINSTALL Atualiza uma versão existente de um determinado software do aplicativo SolidWorks Flow Simulation.
1
Atualizar
2
Nova instalação; instalar em um novo diretório

(instalações individuais e de cliente a partir de uma imagem administrativa)
INSTALLDIR Especifica a instalação de um determinado software do aplicativo SolidWorks Flow Simulation.

(somente instalações individuais)
SERVERLIST | Lista de cadeias de caracteres delimitadas por ponto-e-vírgula, cada uma se referindo a um número de porta de um servidor, no formato: xxxxx@nome_do_servidor1; yyyyy@nome_do_servidor2;& onde x e y são dígitos únicos. Não inclua um ponto-e-vírgula após o nome do último servidor na lista.
SOLIDWORKSPATH Especifica a pasta onde o software SolidWorks está instalado.

(instalações individuais e de cliente a partir de uma imagem administrativa)
TARGETDIR Especifica a instalação de um determinado software do aplicativo SolidWorks Flow Simulation.

(somente instalações por imagem administrativa)
Tópico pai: Propriedades de linha de comando


Locais dos arquivos MSI para imagens administrativas

Para criar imagens administrativas a partir da linha de comando, os arquivos .msi do componente de produto são armazenados nesses locais na mídia do SolidWorks.

Produto | Local da mídia
SolidWorks (produto principal,em inglês) | swwi\data\SolidWorks.msi
SolidWorks (componentes de idioma diferente do inglês) | Chinês tradicional | swwi\lang\chinese\chinese.msi
 | Chinês simplificado | swwi\lang\chinese-simplified\chinese-simplified.msi
 | Tcheco | swwi\lang\czech\czech.msi
 | French (francês) | swwi\lang\french\french.msi
 | Alemão | swwi\lang\german\german.msi
 | Italiano | swwi\lang\italian\italian.msi
 | Japonês | swwi\lang\japanese\japanese.msi
 | Korean (coreano) | swwi\lang\korean\korean.msi
 | Polonês | swwi\lang\polish\polish.msi
 | Português brasileiro | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | Russo | swwi\lang\russian\russian.msi
 | Espanhol | swwi\lang\spanish\spanish.msi
 | Turco | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
Produtos SolidWorks Simulation | COSMOSM\COSMOSM_idioma.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Servidor do Workgroup PDM | pdmwserver\SolidWorks Workgroup PDM Server.msi
Assistente de Ativação do SolidWorks | swactwizard\Activation Wizard.msi
DocManager APIs | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork License Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
Tópico pai: Propriedades de linha de comando


Suporte para idiomas do Windows Desktop Search

Os nomes de arquivos no Windows Desktop Search indicam informações de plataforma e idioma.

Plataforma/arquitetura:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | Windows de 32 bits
x64 | Windows de 64 bits
Idioma:
chs | Chinês simplificado
cht | Chinês
csy | Tcheco
deu | Alemão
enu | Portuguese-Brazilian
esn | Espanhol
fra | French (francês)
ita | Italiano
jpn | Japonês
kor | Korean (coreano)
plk | Polonês
ptb | Português brasileiro
rus | Russo
trk | Turco
Tópico pai: Propriedades de linha de comando


Distribuição de uma imagem administrativa usando o Microsoft Active Directory

A Distribuição pelo Microsoft Active Directory tem suporte para a distribuição do produto central SolidWorks aos clientes.

O Microsoft Active Directory é um serviço de diretório para gerenciamento de clientes e servidores em ambientes de rede. Ele simplifica o gerenciamento, a migração e a distribuição.

  1. Crie uma imagem administrativa usando o Gerenciador de Instalação do SolidWorks ou a linha de comando.
  2. Se você criou a imagem administrativa usando a linha de comando, instale os pré-requisitos do Windows para instalação a partir de uma imagem administrativa usando o Microsoft Active Directory. Para obter detalhes, consulte Instalar os pré-requisitos do Windows usando o Microsoft Active Directory.

    Execute esta etapa somente se tiver criado a imagem manualmente usando a linha de comando. Se você criou e instalou a imagem com o Gerenciador de Instalação do SolidWorks, todos os pré-requisitos do Windows foram instalados automaticamente.

  3. Crie um arquivo de transformação para personalizar o software SolidWorks:
    1. Abra a janela Prompt de comando.
    2. Na pasta que contém a imagem administrativa, arraste SWCreateMST.exe para a janela Prompt de comando.

      O comando deve estar no formato:

      diretório_da_imagem_administrativa\SWCreateMST.exe caminho_para_o_ arquivo_MSI_de_uma_imagem_administrativa lista_de_propriedades

      As propriedades podem ser de recursos ou globais. Para obter detalhes, consulte Propriedades de recurso da linha de comando e Propriedades globais da linha de comando.

      Use os seguintes exemplos como templates:

      • Se você está instalando o SolidWorks (versão de 32 bits) em um sistema operacional de 32 bits:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@seu_servidor"

      • Se você está instalando o SolidWorks (versão de 32 bits) em um sistema operacional de 64 bits:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@seu_servidor"

      • Se você está instalando o SolidWorks (versão de 64 bits) em um sistema operacional de 64 bits:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@seu_servidor"

      O arquivo de transformação, SolidWorks.mst, é criado na pasta que contém a imagem administrativa.

  4. No Active Directory, edite a política Published Apps para o grupo ou grupos, para distribuir o software SolidWorks.
  5. Na caixa de diálogo Group Policy, expanda Computer Configuration e Software Settings.
  6. Clique com o botão direito em Software installation e selecione New > Package.
  7. Navegue até a imagem administrativa e clique em Open.
  8. Na caixa de diálogo Deploy Software (Distribuir software), selecione Advanced published or assigned (Divulgação avançada ou atribuição) e clique em OK.
  9. Na caixa de diálogo Propriedades do SolidWorks, na guia Modificações:
    1. Clique em Adicionar.
    2. Procure o arquivo .mst.
    3. Clique em Abrir.
  10. Clique em OK.
  • Instalar os pré-requisitos do Windows usando o Microsoft Active Directory
    Siga este processo para preparar uma imagem administrativa existente que irá instalar o SolidWorks em computadores clientes usando o Microsoft Windows Active Directory.
Tópico pai: Distribuição pela linha de comando


Instalar os pré-requisitos do Windows usando o Microsoft Active Directory

Siga este processo para preparar uma imagem administrativa existente que irá instalar o SolidWorks em computadores clientes usando o Microsoft Windows Active Directory.

Nos procedimentos descritos, use o comando apropriado para a versão do SolidWorks que você está distribuindo.

  1. Extraia os arquivos do programa de instalação do Visual C++ Redistributable Package 2005 e instale-os:
    1. Execute um dos seguintes comandos:

      Para as versões de 32 bits do Windows:

      diretório_da_imagem_administrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{diretório_alvo_C++}

      Para as versões de 64 bits do Windows:

      diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{diretório_alvo_C++}

    2. Crie uma política para a instalação do módulo redistribuível Microsoft C++ 2005:

      {diretório_alvo_C++_2005}\vcredist.msi –

      Nenhum arquivo de transformação é necessário para esta instalação.

  2. Extraia os arquivos do programa de instalação do Visual C++ Redistributable Package 2008 e instale-os:
    1. Execute um dos seguintes comandos:

      Para as versões de 32 bits do Windows:

      diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{diretório_alvo_C++}

      Para as versões de 64 bits do Windows:

      diretório_da_imagem_administrativa\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{diretório_alvo_C++}

    2. Crie uma política para a instalação do módulo redistribuível Microsoft C++ 2008:

      {diretório_alvo_C++_2008}\vcredist.msi –

      Nenhum arquivo de transformação é necessário para esta instalação.

  3. Usando o Windows Server Update Services, instale o Microsoft .NET Framework 3,5.

    Não é necessário instalar a imagem do .NET Framework no Windows 7 ou posterior.

  4. Extraia os arquivos do Office Web Components e instale-os.
    1. Execute este comando:

      diretório_da_imagem_administrativa\OfficeWeb_11\owc11.exe /extract:{diretório_do_Office_Web_Components}

    2. Crie uma política para instalar o Office Web Components:

      {diretório_do_Office_Web_Components}\owc11.MSI

      Nenhum arquivo de transformação é necessário para esta instalação.

  5. Instale o Visual Studio Tools for Applications (VSTA), criando esta política:

    {diretório_do_Microsoft_VSTA}\vsta_aide.MSI

    Nenhum arquivo de transformação é necessário para esta instalação.

  6. Instale o Visual Studio Remote Debugger (somente para a versão de 64 bits), criando esta política:

    {diretório_do_Microsoft_Remote_Debugger}\rdbgexp.MSI

    Nenhum arquivo de transformação é necessário para esta instalação.

Tópico pai: Distribuição de uma imagem administrativa usando o Microsoft Active Directory


Administração de múltiplas instalações

Para múltiplas instalações, as tarefas administrativas incluem a atualização de imagens administrativas com novas versões principais, a aplicação de atualizações de service packs e a remoção de instalações.

  • Atualizar imagens administrativas com uma nova versão principal
    Para atualizar os clientes que realizaram a instalação a partir de uma imagem administrativa, primeiro atualize a imagem administrativa e, depois, configure os clientes para fazer referência à nova cópia da imagem.
  • Administração de atualizações de produtos com Service Packs
    As atualizações de Service Packs podem conter atualizações para a confiabilidade do sistema, compatibilidades do programa, segurança, entre outras.
  • Remover uma instalação
    Você pode remover uma instalação de um computador individual ou em um ambiente servidor/cliente.
Tópico pai: Instalações múltiplas


Atualizar imagens administrativas com uma nova versão principal

Para atualizar os clientes que realizaram a instalação a partir de uma imagem administrativa, primeiro atualize a imagem administrativa e, depois, configure os clientes para fazer referência à nova cópia da imagem.

Execute o Gerenciador de Instalação do SolidWorks a partir da internet para que os arquivos corretos sejam referenciados. O Gerenciador de Instalação do SolidWorks se redirecionará para fazer isso, ou você poderá executar a atualização diretamente do site de downloads da SolidWorks (http://www.solidworks.com/sw/support/downloads.htm).

Depois de atualizar a imagem administrativa (o que cria uma nova cópia da imagem), você pode atualizar os clientes fazendo com que eles tenham a referência para a nova cópia da imagem administrativa.

Se os clientes referenciavam a versão anterior da imagem administrativa por meio de uma unidade de disco mapeada ou um diretório compartilhado, você pode redefinir o mapeamento ou o diretório compartilhado usando o local da cópia atualizada da imagem administrativa.
  • Fazer o Download de arquivos de instalação atualizados para imagens administrativas
    O Gerenciador de Instalação SolidWorks pode detectar quando você precisa de arquivos de instalação atualizados durante a atualização de versão de uma imagem administrativa.
  • Atualizar uma imagem administrativa
    Para atualizar uma imagem administrativa, o Gerenciador de Instalação SolidWorks cria um novo diretório para a imagem. Você então orienta os clientes a usar o novo diretório de imagem administrativa para atualizar com essa versão do produto.
  • Atualização de clientes a partir de Imagens Administrativas
    O Gerenciador de Instalação do SolidWorks pode atualizar automaticamente os computadores clientes a partir de uma imagem administrativa.
Tópico pai: Administração de múltiplas instalações


Fazer o Download de arquivos de instalação atualizados para imagens administrativas

O Gerenciador de Instalação SolidWorks pode detectar quando você precisa de arquivos de instalação atualizados durante a atualização de versão de uma imagem administrativa.

  1. Inicie o Gerenciador de Instalação do SolidWorks inserindo o DVD.
  2. Na tela Bem-vindo, selecione Imagem administrativa.
  3. Na tela Número de série, digite o número de série do SolidWorks.

    O Gerenciador de Instalação do SolidWorks verifica o site da SolidWorks para obter os produtos e os service packs disponíveis que estão incluídos na sua licença.

  4. Se a tela Versão mais recente disponível for aberta, selecione Sim, fazer o download e instalar uma versão mais recente: versão.

    O Gerenciador de Instalação do SolidWorks inicia uma nova sessão para instalar a versão mais nova.

  5. Se houver algum problema na pasta de download, Opções de download pode ser exibida e, neste caso, aceite o diretório predeterminado para os arquivos da nova instalação, ou insira o nome de um novo diretório.

    Se você receber uma mensagem dizendo que o diretório não existe, clique em Sim para criá-lo.

  6. Na tela Download concluído, clique em Fechar para fechar o programa de instalação atual e iniciar a nova versão.
Tópico pai: Atualizar imagens administrativas com uma nova versão principal


Atualizar uma imagem administrativa

Para atualizar uma imagem administrativa, o Gerenciador de Instalação SolidWorks cria um novo diretório para a imagem. Você então orienta os clientes a usar o novo diretório de imagem administrativa para atualizar com essa versão do produto.

Esse processo considera que você já fez o download de todos os arquivos de instalação atualizados da imagem administrativa. Para obter detalhes, consulte Fazer o Download de arquivos de instalação atualizados para imagens administrativas.

  1. Inicie o Gerenciador de Instalação do SolidWorks. Para obter detalhes, consulte Iniciar a instalação do SolidWorks.
  2. Na tela Bem-vindo, selecione Imagem administrativa.

    As opções de criação de imagem administrativa são exibidas:

    Criar uma nova imagem usando as configurações predeterminadas.
    Criar a imagem usando as definições da configuração padrão (isto é, sem se basear nas definições atualmente estabelecidas para uma imagem administrativa em seu local).
    Criar uma nova imagem usando as configurações e arquivos de uma imagem existente.
    Criar a imagem usando as definições de configuração especificadas para uma imagem administrativa em seu local. Clique em Procurar para especificar o diretório de instalação da imagem administrativa existente.
    Criar imagens administrativas de 32 bits e de 64 bits.
    Você pode criar imagens de 32 e 64 bits em um mesmo computador ou somente a imagem que corresponda à arquitetura do computador em questão. Criar ambas as imagens requer acesso à mídia de instalação de 32 e 64 bits.

  3. Na tela Número de série, verifique o número de série.
  4. Na tela Resumo (Pronto para criar imagem), verifique se as opções para a imagem administrativa estão corretas.

    Para obter detalhes sobre opções individuais de imagem administrativa e instalação, clique em ALTERAR para ir para a página da opção, então clique em Ajuda.

  5. Para criar a nova versão da imagem administrativa, clique em Criar agora.

Depois disso, você pode atualizar os clientes com esta nova versão da imagem administrativa. Para obter detalhes, consulte Atualização de clientes a partir de Imagens Administrativas.

Tópico pai: Atualizar imagens administrativas com uma nova versão principal


Atualização de clientes a partir de Imagens Administrativas

O Gerenciador de Instalação do SolidWorks pode atualizar automaticamente os computadores clientes a partir de uma imagem administrativa.

Em geral, as imagens administrativas são organizadas em pastas num servidor. Para oferecer suporte à atualização automática de clientes, a imagem administrativa precisa estar localizada em uma pasta compartilhada.

Depois da atualização da imagem administrativa, a instalação original estará em uma pasta e a instalação atualizada, em outra. Para usar o programa de instalação atualizado, remova a opção de compartilhamento da pasta da imagem administrativa original e então ativar a opção de compartilhamento na pasta da imagem atualizada.

Quando o SolidWorks é iniciado em um computador cliente que fez a instalação a partir da imagem administrativa original, ele verifica a versão e atualiza o cliente.

  • Remover a opção de compartilhamento da pasta da imagem administrativa original
    Quando atualiza a versão de uma imagem administrativa que é acessada em uma pasta compartilhada, você precisa remover a opção de compartilhamento da pasta original.
  • Adicionar a opção de compartilhamento a uma pasta de imagem administrativa atualizada
    Depois de criar a pasta de imagem administrativa atualizada e desabilitado o compartilhamento da pasta da imagem administrativa original, você precisa adicionar a opção de compartilhamento à nova pasta para reabilitar a imagem administrativa.
  • Atualizar clientes de imagens administrativas manualmente usando a linha de comando
    Uma vez atualizada uma imagem administrativa, você pode atualizar manualmente os clientes usando a linha de comando.
Tópico pai: Atualizar imagens administrativas com uma nova versão principal


Remover a opção de compartilhamento da pasta da imagem administrativa original

Quando atualiza a versão de uma imagem administrativa que é acessada em uma pasta compartilhada, você precisa remover a opção de compartilhamento da pasta original.

  1. Navegue até a pasta onde estão os arquivos da imagem administrativa original.
  2. Clique com o botão direito na pasta e selecione Propriedades.
  3. Na guia Compartilhamento selecione Não compartilhar esta pasta, então clique em OK.

Em seguida, ative a opção de compartilhamento na pasta da imagem administrativa atualizada, como descrito em Adicionar a opção de compartilhamento a uma pasta de imagem administrativa atualizada.

Tópico pai: Atualização de clientes a partir de Imagens Administrativas


Adicionar a opção de compartilhamento a uma pasta de imagem administrativa atualizada

Depois de criar a pasta de imagem administrativa atualizada e desabilitado o compartilhamento da pasta da imagem administrativa original, você precisa adicionar a opção de compartilhamento à nova pasta para reabilitar a imagem administrativa.

  1. Navegue até a pasta onde estão os arquivos da imagem administrativa atualizada.
  2. Clique com o botão direito na pasta e selecione Propriedades.
  3. Na guia Compartilhamento, especifique as propriedades de compartilhamento apropriadas para a sua organização ou grupo, e mude o nome compartilhado para o que era usado pela pasta da imagem administrativa original.
Os computadores que executaram a instalação a partir do local compartilhado da imagem administrativa original serão atualizados automaticamente com a nova versão quando os usuários iniciarem o SolidWorks.
Tópico pai: Atualização de clientes a partir de Imagens Administrativas


Atualizar clientes de imagens administrativas manualmente usando a linha de comando

Uma vez atualizada uma imagem administrativa, você pode atualizar manualmente os clientes usando a linha de comando.

  1. Certifique-se de que todos os clientes estão no mesmo pacote de serviços da versão anterior (os clientes que ainda não têm o aplicativo instalado não estão atualizados).
  2. Opcionalmente, em um dos sistemas de cliente, execute o Assistente de Cópia de Configurações para capturar as opções atuais do SolidWorks.
  3. Crie uma nova imagem administrativa usando o Gerenciador de Instalação do SolidWorks ou a linha de comando.

    Não atualize nem substitua a imagem anterior.
    Se estiver atualizando uma instalação do SolidWorks em idioma diferente do inglês, você terá que criar uma nova imagem administrativa para o componente de instalação de idioma diferente do inglês.

  4. Atualize todos os clientes com a nova versão usando o comando msiexec, com estas especificações:

    • Inclua as opções da linha de comando msiexec /I e qb .
    • Especifique as propriedades de linha de comando de recursos e global necessárias. Para obter detalhes, consulte Propriedades de linha de comando.

    Por exemplo, para atualizar uma versão existente do SolidWorks:

    msiexec /I Caminho_do_arquivo_msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks versão servicepack" /qb

    Se estiver atualizando uma instalação do SolidWorks que não esteja em inglês, você terá que atualizar o componente de idioma diferente do inglês após atualizar os componentes do SolidWorks.

Tópico pai: Atualização de clientes a partir de Imagens Administrativas


Administração de atualizações de produtos com Service Packs

As atualizações de Service Packs podem conter atualizações para a confiabilidade do sistema, compatibilidades do programa, segurança, entre outras.

Você pode adquirir essas atualizações de duas maneiras:

Para as versões atuais do SolidWorks:
Usando o Gerenciador de Instalação do SolidWorks para verificar se há atualizações, fazer o download e instalá-las.

Você pode iniciar o Gerenciador de Instalação do SolidWorks manualmente ou programar a verificação periódica de atualizações.

Para versões do SolidWorks anteriores à versão 2008:
Fazendo o download dos service packs manualmente do site de suporte da SolidWorks.

Os service packs são aplicados como correções (patches) a uma versão existente do software. Por exemplo, o SolidWorks 2007 SP1.0 é um service pack para o SolidWorks 2007 SP0.0. Você pode instalar esses service packs usando o Gerenciador de Instalação do SolidWorks 2007; não é possível instalá-los usando o Gerenciador de Instalação do SolidWorks 2008 ou posterior.

Para obter instruções sobre como fazer o download e instalar os service packs, consulte a documentação da instalação da versão do SolidWorks que você quer atualizar.

  • Reverter Service Packs em uma imagem administrativa
    Você pode reverter uma imagem administrativa para um service pack instalado anteriormente. Se você instalou o software SolidWorks usando discos, precisará dos discos originais para restaurar um service pack. Você precisa ter salvo uma cópia da imagem administrativa anterior.
  • Aplicar Service Packs a clientes distribuídos com o Microsoft Active Directory
    Se você instalou o software SolidWorks usando o Microsoft Active Directory, pode usá-lo para aplicar os service packs aos clientes.
Tópico pai: Administração de múltiplas instalações


Reverter Service Packs em uma imagem administrativa

Você pode reverter uma imagem administrativa para um service pack instalado anteriormente. Se você instalou o software SolidWorks usando discos, precisará dos discos originais para restaurar um service pack. Você precisa ter salvo uma cópia da imagem administrativa anterior.

As imagens administrativas que foram atualizadas não podem ser revertidas para um service pack anterior. As imagens administrativas criadas com qualquer método que não o Gerenciador de Instalação do SolidWorks não podem ser revertidas para uma versão anterior. Os clientes instalados por essas imagens administrativas devem ser desinstalados e reinstalados usando uma imagem administrativa criada a partir da versão anterior.
  1. Exclua a pasta que contém a imagem administrativa atual. Para fazer isso, abra a janela Prompt de comando e digite:

    rmdir /s/q caminho_para_a_imagem_administrativa_atual

  2. Mova a cópia de backup da imagem administrativa para o local de onde excluiu a imagem administrativa atual. Para fazer isso, abra a janela Prompt de comando e digite:

    move caminho_para_a_imagem_administrativa_de_backup caminho_para_a_imagem_administrativa_atual

    Quando você reverte uma imagem administrativa, os computadores clientes são automaticamente revertidos na próxima vez que executarem o software SolidWorks.

Tópico pai: Administração de atualizações de produtos com Service Packs


Aplicar Service Packs a clientes distribuídos com o Microsoft Active Directory

Se você instalou o software SolidWorks usando o Microsoft Active Directory, pode usá-lo para aplicar os service packs aos clientes.

  1. Copie a imagem administrativa para uma nova pasta usando a seguinte linha de comando:

    xcopy caminho_para_a_imagem_administrativa_atual caminho_para_a_imagem_administrativa_de_backup /s/i/v

  2. Aplique o service pack à cópia da imagem administrativa.
  3. Crie um novo arquivo de transformação para especificar uma instalação de atualização do software SolidWorks:
    1. Abra a janela Prompt de comando.
    2. Na pasta que contém a imagem administrativa, arraste SWCreateMST.exe para a janela Prompt de comando.

      O formato do comando é:

      caminho_da_imagem_administrativa\SWCreateMST.exe caminho_do_arquivo_MSI_de_uma_imagem_administrativa lista_de_propriedades

      A linha de comando precisa incluir todos os parâmetros usados para criar o arquivo de transformação original, mais as propriedades globaisUPGRADESWINSTALL e SWMIGRATE.

      Por exemplo, se o comando original era:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@seu_servidor

      o comando de atualização deve ser:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Arquivos de programas\sua_pasta" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@seu_servidor UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks versão service_pack"

      O arquivo de transformação, SolidWorks.mst, é criado na pasta que contém a imagem administrativa.

      Os comandos original e atualizado neste exemplo são para a instalação da versão de 32 bits do SolidWorks na versão de 32 bits do sistema operacional. Se estiver instalando a versão de 32 bits do SolidWorks em um sistema operacional de 64 bits, você deve usar "Intel_Modules_AgeiaX64" em vez de "Intel_Modules_AgeiaX86". Se você está instalando a versão de 64 bits do SolidWorks em um sistema operacional de 64 bits, não deve usar "Intel_Modules_AgeiaX86” nem “Intel_Modules_AgeiaX64".

  4. No Active Directory, edite a política Published Apps para o grupo ou grupos para os quais vai distribuir o software SolidWorks.
  5. Na caixa de diálogo Group Policy, expanda Computer Configuration and Software Settings.
  6. Clique com o botão direito em Software installation e selecione New > Package.
  7. Navegue até a imagem administrativa e clique em Open.
  8. Na caixa de diálogo Deploy Software, selecione Advanced published or assigned e clique em OK.
  9. Na caixa de diálogo Propriedades do SolidWorks, na guia Modificações:
    1. Clique em Adicionar.
    2. Procure o arquivo .mst.
    3. Clique em Abrir.
  10. Clique em OK.
Tópico pai: Administração de atualizações de produtos com Service Packs


Workgroup PDM

O aplicativo Workgroup PDM é um software de gerenciamento de dados de produtos que é executado dentro do ambiente do SolidWorks ou como um aplicativo independente dentro do SolidWorks Explorer. O Workgroup PDM controla projetos com procedimentos para check-out, check-in, controle de revisões e outras tarefas administrativas.

Um sistema Workgroup PDM é representado na ilustração a seguir:

  • Um computador pode conter somente um vault.
  • O diretório do vault não pode ser oculto ou somente para leitura.
  • Com um aplicativo cliente/servidor, o desempenho do Workgroup PDM depende de uma rede robusta.
  • Se seus usuários mantiverem um grande número de documentos, o desempenho será melhorado se você criar mais projetos ou subprojetos com menos documentos por projeto, em vez de manter os documentos em um número menor de projetos, com mais documentos por projeto.

Instalação

  • Os clientes e o VaultAdmin, o API e o Viewer podem ser instalados no mesmo computador do Vault, ou em outros computadores.
  • Não é necessário instalar o Servidor do Workgroup PDM para instalar o cliente API. O cliente API é instalado durante a instalação do Cliente Workgroup PDM.
  • Para configurar a pasta do vault em um local remoto, digite o caminho UNC (Universal Naming Convention) quando solicitado a informar o destino do servidor. (para obter detalhes, consulte Formato UNC).
  • Instalar ou atualizar o vault requer a reinicialização do computador.
  • Se o serviço do Servidor Workgroup PDM não for iniciado automaticamente após a reinicialização, você terá que iniciá-lo manualmente. No Windows Explorer, execute pdmwvault.exe na pasta diretório_de_instalação\SolidWorks Workgroup PDM\Vault
  • Quando você instala um cliente do Workgroup PDM, precisa instalar o arquivo solidworksexplorer.exe em cada computador. Este executável pode estar em uma unidade de disco compartilhada. O Vault, o Visualizador, a API do Cliente e o VaultAdmin do Workgroup PDM não são instalados em todos os computadores clientes.

Licenças

  • Uma licença para a API do Workgroup PDM é incluída com as licenças dos clientes SolidWorks e Explorer. O check-in de APIs requer licenças de cliente.
  • Uma licença do Visualizador do Workgroup PDM precisa estar instalada com o vault para ativar o visualizador.

Permissões

  • O administrador do vault deve ter permissão de gravação para a instalação e para a pasta do vault.
  • O administrador do vault deve gerenciar a pasta do vault a partir do VaultAdmin e não com o Windows Explorer.
  • Os usuários nunca devem ter permissão de gravação no Windows Explorer para a pasta do vault.

Configurações de segurança, portas e duplex

  • É necessário que o Workgroup PDM possa ser instalado como um serviço do Windows, de forma que outros aplicativos não possam bloquear ou filtrar o serviço. Por exemplo, se ferramentas antispyware, como o Microsoft AntiSpyware, exibirem um alerta durante o processo de instalação, clique em Permitir para que o Servidor do Workgroup PDM seja instalado como um Windows Service.
  • Se você instalar o Workgroup PDM em um sistema Windows XP com o Service Pack 2, um servidor Windows 2003 com o Service Pack 1, ou em um computador com uma firewall ativa, precisará ativar as portas do Workgroup PDM como exceções na configuração do firewall.

    Tipicamentie, essas portas são:

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Request)
    • 80 (Viewer)
    Para obter informações sobre como alterar as configurações de porta, consulte Solução de problemas para administradores do vault na Ajuda do Workgroup PDM e do SolidWorks Explorer, e na Ajuda do Windows para o Centro de segurança. Para instalar o Vault e o Visualizador do Workgroup PDM ao mesmo tempo, use a opção Personalizar na caixa de diálogo Tipo de Configuração.
  • A configuração duplex para servidores e suas portas correspondentes deve ser a mesma; por exemplo, ambas podem ser100 MB Integral ou Auto.

Documentos do SolidWorks Toolbox

Os documentos do SolidWorks Toolbox são componentes de hardware comuns que normalmente não requerem controle de revisão e não é feito o seu check-in no Vault do Workgroup PDM. Consulte a Ajuda on-line do Workgroup PDM para obter detalhes sobre a configuração do SolidWorks Toolbox e outras bibliotecas padrão.

  • Workgroup PDM Viewer
    O software Workgroup PDM configura automaticamente um diretório virtual durante a instalação, usando o Microsoft Internet Information Services (IIS).
  • Instalar o Workgroup PDM Server
    Instalar o Workgroup PDM Server cria um vault do Workgroup PDM, que é o banco de dados que armazena os projetos gerenciados do SolidWorks.
  • Configuração do Workgroup PDM para clientes
    Após instalar o vault do servidor do Workgroup PDM, você pode configurar o vault para clientes.
  • Instalação do Workgroup PDM Server e Viewer em uma rede de perímetro
    Instalar o servidor Web do SolidWorks Workgroup PDM e o Workgroup PDM Viewer em uma rede de perímetro (DMZ) tem implicações para o firewall.
  • Acesso de Cliente do Workgroup PDM
    Os clientes do Workgroup PDM utilizam o controle de acesso de login do Microsoft Windows, têm acesso ao Workgroup PDM Viewer e são atualizados automaticamente sempre que o vault do Workgroup PDM é atualizado.
  • Administração do VaultAdmin do Workgroup PDM
    Depois que o Workgroup PDM for instalado, os administradores do vault deverão executar as seguintes tarefas:


Workgroup PDM Viewer

O software Workgroup PDM configura automaticamente um diretório virtual durante a instalação, usando o Microsoft Internet Information Services (IIS).

Você precisa instalar o Internet Information Services (IIS) da Microsoft para instalar o Viewer.
Os componentes obrigatórios incluem:
  • Ferramentas de Gerenciamento da Web
    • Console de Gerenciamento do IIS
  • Serviços da World Wide Web: Recursos de Desenvolvimento de Aplicativos
    • Extensibilidade .NET
    • ASP.NET
    • CGI
    • Extensões ISAPI
    • Filtros ISAPI
Consulte a documentação da Microsoft para obter instruções de instalação do IIS.
A instalação do Workgroup PDM Viewer está sujeita às seguintes restrições:
  • O Diretório de conteúdo do site é a pasta de instalação do Viewer.
  • Você não pode usar o caractere de sublinhado no nome do computador que é o hosts do Viewer.
  • Se você instalar o Viewer no Windows XP Service Pack 2, precisará habilitar uma porta no Windows Firewall para HTTP (porta 80).
  • O Viewer pode apontar para somente um vault por vez.

Os usuários acessam o Workgroup PDM Viewer digitando este URL no campo de endereço do Internet Explorer:

http://ViewerComputerName/pdmweb/

Tópico pai: Workgroup PDM


Instalar o Workgroup PDM Server

Instalar o Workgroup PDM Server cria um vault do Workgroup PDM, que é o banco de dados que armazena os projetos gerenciados do SolidWorks.

  1. Inicie o Gerenciador de Instalação SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
  2. Na tela Bem-vindo, selecione o seguinte:

    • Produtos de Servidor
    • Instalar o software SolidWorks Workgroup PDM Server (vault) neste computador.

  3. Na tela Resumo, clique em Alterar para adquirir um código de validação. você pode adquirir o código usando um dos métodos a seguir:
    • Conexão com a internet
      1. Insira o número de série do SolidWorks e um endereço de e-mail nos campos fornecidos.
      2. Selecione Validar automaticamente e clique em Obter código.
    • E-mail
      1. Se o computador não tiver acesso a uma conexão à Internet, clique em Validar manualmente por e-mail. O Gerenciador de instalação gera um arquivo de solicitação de validação.
      2. Clique em Salvar para armazenar o arquivo localmente no sistema.
      3. Siga as instruções a na tela e insira o código de validação.
  4. Clique em Voltar ao resumo.
  5. Na tela Resumo, clique em Instalar agora.
Tópico pai: Workgroup PDM


Configuração do Workgroup PDM para clientes

Após instalar o vault do servidor do Workgroup PDM, você pode configurar o vault para clientes.

  1. Faça login no VaultAdmin (instalado com o SolidWorks Explorer) usando o nome de usuário e a senha predeterminados
  2. No VaultAdmin, configure as contas de usuários e grupos, pastas de projetos, permissões, etc.

    Para obter instruções, consulte a Ajuda do Workgroup PDM.

  3. Envie e-mails aos usuários clientes com o nome do computador servidor e seus nomes e senhas de usuário, que geralmente são diferentes dos nomes e senhas que eles usam no Microsoft Windows.
  • Configuração do Workgroup PDM Viewer para conexão a um local de vault diferente
    Você pode configurar o Workgroup PDM Viewer para se conectar a um local de vault diferente usando o Registro do Windows.
  • Configurar tipos Mime para o download de documentos
    Você pode configurar os tipos mime para o download de documentos usando as configurações do Registro do Windows.
Tópico pai: Workgroup PDM


Configuração do Workgroup PDM Viewer para conexão a um local de vault diferente

Você pode configurar o Workgroup PDM Viewer para se conectar a um local de vault diferente usando o Registro do Windows.

  1. Atualize o caminho do registro alterando o valor de Computador do vault:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Reinstale o Workgroup PDM Viewer. Na caixa de diálogo Nome do computador do vault, digite o nome do novo computador.
Tópico pai: Configuração do Workgroup PDM para clientes


Configurar tipos Mime para o download de documentos

Você pode configurar os tipos mime para o download de documentos usando as configurações do Registro do Windows.

Por padrão, o Viewer envia solicitações de Abrir documento com o tipo mime genérico "application/octet-stream." Em seguida, o Microsoft Internet Explorer abre o documento solicitado com a extensão de arquivo fornecida. Você pode mapear tipos mime adicionais ou desativar mapeamentos de tipo mime modificando as subchaves de registro dos tipos mime no Registro do Windows.

  • Para mapear tipos mime adicionais, crie valores de string adicionais na subchave de registro:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    no formato:

    "ext" = "tipo de mime"

    Por exemplo:

    "dxf" = "image/vnd.dxf"

    Você precisa criar manualmente essa subchave do registro para adicionar os valores.

    Para desativar mapeamentos de tipo mime, mude o valor de registro Use Custom MIME Types (Usar tipos MIME personalizados) para 0 (zero).

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Não é necessário reiniciar o servidor da web para ativar essa configuração.

Tópico pai: Configuração do Workgroup PDM para clientes


Instalação do Workgroup PDM Server e Viewer em uma rede de perímetro

Instalar o servidor Web do SolidWorks Workgroup PDM e o Workgroup PDM Viewer em uma rede de perímetro (DMZ) tem implicações para o firewall.

Como os clientes Workgroup PDM Viewer se comunicam com o servidor Web pelas portas HTTP ou HTTPS, essas portas precisam ser abertas no sistema Internet Information Server (IIS) onde o servidor Web está instalado.

  • Para o protocolo HTTP a porta predeterminada é a 80.
  • Para o protocolo HTTPS (SSL) a porta predeterminada é a 443.

Os clientes Web Viewer propriamente não precisam de exceções de firewall.

Você precisa assegurar que o sistema do servidor Web tem acesso ao servidor Vault por meio dessas portas predeterminadas:

  • 30000 (Data)
  • 40000 (Request)
  • Configuração de rede para o Workgroup PDM Viewer em uma rede de perímetro
    A configuração de rede mostra um servidor de rede de perímetro configurado em uma sub-rede de perímetro e suas comunicações com as redes interna e externa.
  • Instalação e configuração do servidor Web e do Workgroup PDM Viewer
    Quando você configura um servidor Web do Workgroup PDM em uma rede de perímetro, o local da instalação dos componentes é importante.
Tópico pai: Workgroup PDM


Configuração de rede para o Workgroup PDM Viewer em uma rede de perímetro

A configuração de rede mostra um servidor de rede de perímetro configurado em uma sub-rede de perímetro e suas comunicações com as redes interna e externa.

O servidor de rede de perímetro se comunica com a LAN por meio de um firewall interno. Ele se comunica com a rede externa por meio de um firewall externo, um router e um cluster de balanceadores de carga.

O cliente Internet Explorer se conecta ao servidor Workgroup PDM Viewer/IIS pela porta 80 (ou 443 se configurado para usar SSL). O Workgroup PDM Viewer em seguida se conecta ao servidor do vault usando portas 30000 ou 40000. O servidor do vault envia as informações solicitadas de volta ao Workgroup PDM Viewer, que então transmite de volta as informações ao cliente Internet Explorer.

O servidor Web de rede de perímetro tem dois endereços IP:

  • O endereço IP interno na LAN
  • O endereço IP público fornecido pelo ISP

O servidor Web na rede de perímetro está localizado atrás de um cluster de balanceadores de carga. Embora você possa acessar diretamente o servidor Web para executar tarefas administrativas, todo o tráfego de serviços da web para os servidores na rede de perímetro é processado por meio dos balanceadores de carga.

Os balanceadores de carga convertem o endereço IP do hardware do servidor em um IP virtual (VIP) no segmento da rede que é exposto ao público. Se você navegar até o URL do VIP ou do servidor Web estando conectado à rede, poderá ver o site.

O firewall externo converte o VIP do balanceador de carga em um endereço público roteável.

Tópico pai: Instalação do Workgroup PDM Server e Viewer em uma rede de perímetro


Instalação e configuração do servidor Web e do Workgroup PDM Viewer

Quando você configura um servidor Web do Workgroup PDM em uma rede de perímetro, o local da instalação dos componentes é importante.
  • Instale o servidor Web habilitado para IIS na sub-rede de perímetro.
  • Instale o Workgroup PDM Viewer habilitado para IIS na sub-rede de perímetro.
  • Instale o vault do Workgroup PDM no domínio principal ou rede interna na intranet local.

Os pré-requisitos para a instalação e configuração do Workgroup PDM Viewer em uma rede de perímetro são os seguintes:

  • Microsoft IIS 6.0 ou posterior
  • Um endereço IP público para o servidor Web na sub-rede de perímetro, atribuído pelo seu fornecedor de ISP

Para instalar e configurar os componentes do Workgroup PDM:

  1. Instale o Microsoft IIS no sistema servidor da sub-rede de perímetro.
  2. Execute duas instalações do SolidWorks Workgroup PDM Server:
    1. Primeiro instale o componente Vault no servidor de vault.
    2. Execute o programa de instalação uma segunda vez para instalar o Workgroup PDM Viewer e os componentes de licença do Viewer no servidor Web do IIS. Insira o nome do servidor de vault para que o portal Web saiba onde encontrar o serviço do servidor de vault.

    Quando você executa a instalação, o aplicativo PDMWeb é adicionado automaticamente no web site do IIS predeterminado.

  3. Certifique-se de que o firewall da rede interna tem as portas 30000 e 40000 abertas.
  4. Se o servidor interno tem um endereço IP fixo, no sistema servidor de perímetro, edite o arquivo C:\Windows\system32\drivers\etc\hosts. Crie um mapeamento do nome do sistema para o endereço IP de maneira que o servidor de perímetro possa se comunicar com o servidor interno:
    1. Abra o arquivo hosts em um editor de texto como o Bloco de Notas.
    2. Adicione uma nova linha para o nome e endereço IP do servidor de Vault.
    3. Salve o arquivo hosts.
Tópico pai: Instalação do Workgroup PDM Server e Viewer em uma rede de perímetro


Acesso de Cliente do Workgroup PDM

Os clientes do Workgroup PDM utilizam o controle de acesso de login do Microsoft Windows, têm acesso ao Workgroup PDM Viewer e são atualizados automaticamente sempre que o vault do Workgroup PDM é atualizado.

Para fazer login como um cliente do Workgroup PDM: | Os nomes e senhas de login dos usuários clientes não são iguais no Workgroup PDM e no Microsoft Windows. Consulte o administrador do seu sistema para obter as informações de login.
Para se conectar ao Workgroup PDM Viewer: | Consulte o administrador do seu sistema para obter o URL para conexão com o Viewer.
Para atualizar os clientes do Workgroup PDM: | Os clientes do Workgroup PDM (suplemento do SolidWorks e Contributor) detectam quando o vault foi atualizado. Você não precisa fazer o download de um service pack para atualizar os clientes.
Tópico pai: Workgroup PDM


Administração do VaultAdmin do Workgroup PDM

Depois que o Workgroup PDM for instalado, os administradores do vault deverão executar as seguintes tarefas:

  • Fazer login no VaultAdmin.
  • Alterar a senha de administrador do vault.
  • Criar as contas dos usuários.
  • Notificar os usuários sobre os nomes e senhas de suas contas.

Para obter detalhes, consulte SolidWorks Workgroup PDM na ajuda principal do SolidWorks.

  • Login inicial no Workgroup PDM VaultAdmin
    Ao fazer login pela primeira vez no VaultAdmin do Workgroup PDM, especifique a senha e o nome do administrador do Workgroup PDM e o nome do computador que hospeda o vault do Workgroup PDM.
  • Atualizar o servidor do vault do Workgroup PDM
    Você pode atualizar o servidor do vault do Workgroup PDM usando a funcionalidade Verificar atualizações do SolidWorks, um DVD de instalação do SolidWorks ou um arquivo de atualização do Workgroup PDM carregado manualmente na pasta local.
  • Atualizar clientes do Workgroup PDM
    Os clientes do Workgroup PDM detectam quando o vault foi atualizado. Você não precisa fazer o download de um service pack para atualizar os clientes.
Tópico pai: Workgroup PDM


Login inicial no Workgroup PDM VaultAdmin

Ao fazer login pela primeira vez no VaultAdmin do Workgroup PDM, especifique a senha e o nome do administrador do Workgroup PDM e o nome do computador que hospeda o vault do Workgroup PDM.

  1. No Windows, clique em Iniciar > Todos os programas > SolidWorks versão > Workgroup PDM VaultAdmin.
  2. Na caixa de diálogo, insira as seguintes informações:

    Nome | pdmwadmin
    Senha | pdmwadmin
    Computador do vault | O nome do computador onde o vault está instalado. Se você executar o VaultAdmin no computador onde o vault está instalado, digite localhost.

  3. Clique em Login.
Por questões de segurança, recomendamos que você altere a senha do administrador assim que possível. Selecione a guia Usuários e grupos no VaultAdmin.
Tópico pai: Administração do VaultAdmin do Workgroup PDM


Atualizar o servidor do vault do Workgroup PDM

Você pode atualizar o servidor do vault do Workgroup PDM usando a funcionalidade Verificar atualizações do SolidWorks, um DVD de instalação do SolidWorks ou um arquivo de atualização do Workgroup PDM carregado manualmente na pasta local.

Você pode instalar apenas uma versão do servidor do vault do Workgroup PDM
  1. Peça a todos os usuários para se desconectarem do vault do Workgroup PDM e bloqueie-o.
  2. Faça o backup dos dados do vault.
  3. Use o recurso Adicionar/Remover programas no Painel de controle do Windows para remover a versão atual do servidor do Workgroup PDM.
  4. Instale a nova versão do Servidor do Workgroup PDM.
    • Para utilizar o recurso Verificar atualizações do SolidWorks:
      1. No Windows, clique em Iniciar > Todos os programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações
      2. Na caixa de diálogo Versão mais recente disponível, selecione Fazer o download e instalar uma nova versão, selecione a versão a instalar e clique em Avançar.

        A nova versão do Gerenciador de Instalação do SolidWorks é carregada e executada.

    • Para utilizar um DVD de instalação do SolidWorks, insira o DVD na unidade e siga as instruções do Gerenciador de Instalação do SolidWorks.
    • Para utilizar o arquivo de instalação (pdmwserver.exe) do Workgroup PDM que foi carregado manualmente, clique duas vezes no arquivo e siga as instruções para atualizar o servidor do Workgroup PDM.
  5. Use o Agendador de Tarefas do SolidWorks para atualizar os arquivos do Workgroup PDM no vault.
  6. Desbloqueie o vault e notifique os usuários de que eles podem voltar a usá-lo.
Tópico pai: Administração do VaultAdmin do Workgroup PDM


Administração de licenças

Após a instalação, você pode ativar as licenças SolidWorks seja nos computadores individuais (ativação da licença) ou instalando e ativando licenças flutuantes de rede em um servidor (Licença SolidNetWork).

Em geral, as instalações em computadores individuais usam a ativação da licença; contudo, você pode instalar o software individualmente e depois controlar as licenças com o SolidNetWork License Manager. Inversamente, embora locais maiores em geral usem as licenças de rede flutuante, você pode distribuir as instalações a partir de uma imagem administrativa e depois ativar os números de série a partir dos computadores individuais.

  • Administração de licenças individuais
    Normalmente, a administração de licenças individuais consiste em ativar e transferir licenças diretamente no SolidWorks.
  • Administração de licenças usando o SolidNetWork License Manager
    O SolidNetWork License Manager oferece suporte aos clientes de múltiplas licenças distribuindo as licenças a esses clientes na rede. Isso permite que o número de usuários exceda o número de licenças usando licenças flutuantes.


Administração de licenças individuais

Normalmente, a administração de licenças individuais consiste em ativar e transferir licenças diretamente no SolidWorks.

A ativação é um processo de registro e licenciamento de produtos para licenças standalone do SolidWorks, ou seja, licenças que não são de rede (Licenças SolidNetWork). Geralmente, se a licença do seu produto ainda não foi ativada, o SolidWorks tenta ativá-la no momento em que você inicia o produto.

Também é possível transferir licenças individuais clicando em Ajuda > Transferir licenças no SolidWorks.

  • Ativar uma licença
    Para executar os produtos SolidWorks em um computador individual, você precisa ativar a licença no computador.
  • Transferir uma licença
    Para transferir uma licença para um computador novo ou atualizado, primeiro transfira-a para o servidor de chave de licença da Dassault Systèmes SolidWorks Corporation e depois ative-a novamente no outro computador.
Tópico pai: Administração de licenças


Ativar uma licença

Para executar os produtos SolidWorks em um computador individual, você precisa ativar a licença no computador.

A ativação requer que você tenha acesso à Internet ou a correio eletrônico. Após a ativação, você não precisa estar on-line para usar os produtos. Se você não tem acesso a e-mails no computador onde usa este produto, pode salvar o arquivo de ativação e enviá-lo por outro computador.

Este processo:
  • Ativa todas as licenças do software para toda a linha de produtos SolidWorks.
  • Permite transferir os direitos de licença de um computador para outro.
  • Permite instalar e ativar os produtos SolidWorks em um computador no escritório e outro na sua residência.
  • Pode ser executado imediatamente (recomendado) ou dentro de 30 dias após a instalação.
  • Elimina a necessidade de dongles. Contudo, se você executa versões anteriores do SolidWorks que não usam a ativação, você precisará manter seu dongle.

No caso de administradores de sistema que controlam vários números de série, você pode utilizar o Editor de Opções de Imagem Administrativa. Para obter detalhes, consulte Editor de Opções de Imagem Administrativa.

Para ativar uma licença:

  1. Inicie o aplicativo SolidWorks.
  2. Inicie a Ativação de Produtos SolidWorks usando um dos seguintes métodos:
    • Se você ainda não ativou a licença neste computador, a janela Ativação de Produtos SolidWorks é exibida automaticamente quando o SolidWorks é iniciado.
    • Se a janela Ativação de Produtos SolidWorks não for exibida automaticamente, inicie a ativação clicando em Ajuda > Ativar licenças.
  3. Clique na lista de Produtos para especificar o produto cuja licença deseja ativar.
  4. Especifique a ativação automática pela Internet ou a ativação manual por e-mail.
  5. Forneça as informações de e-mail para contato.
  6. Clique em Avançar para prosseguir.
    • Internet: A ativação ocorre automaticamente.
    • E-mail: Clique em Salvar para criar um arquivo de solicitação; em seguida, envie o arquivo para activation@solidworks.com. Quando receber o e-mail contendo o arquivo de resposta, extraia o arquivo do e-mail e clique em Abrir para carregá-lo.
      Se necessário, você pode sair do procedimento de ativação e executá-lo novamente para abrir o arquivo de resposta.
  7. Clique em Concluir.
Tópico pai: Administração de licenças individuais


Transferir uma licença

Para transferir uma licença para um computador novo ou atualizado, primeiro transfira-a para o servidor de chave de licença da Dassault Systèmes SolidWorks Corporation e depois ative-a novamente no outro computador.

Se você não pôde transferir a licença para a Dassault Systèmes SolidWorks Corporation (devido a uma falha do disco rígido, por exemplo), na maioria dos casos a reativação ainda será bem-sucedida. Caso contrário, consulte seu VAR para obter ajuda.

Para transferir uma licença de volta ao servidor:

  1. No SolidWorks, clique em Ajuda > Transferir licenças e siga as instruções.
  2. Para reativar, vá para o computador novo ou atualizado e ative a licença, como fez durante a ativação inicial. Para obter detalhes, consulte Ativar uma licença.
Tópico pai: Administração de licenças individuais


Administração de licenças usando o SolidNetWork License Manager

O SolidNetWork License Manager oferece suporte aos clientes de múltiplas licenças distribuindo as licenças a esses clientes na rede. Isso permite que o número de usuários exceda o número de licenças usando licenças flutuantes.

Esta imagem ilustra uma instalação de licença típica do SolidNetWork:

Esta imagem ilustra:
  • O software do SolidNetWork License Manager só está instalado e ativado no computador gerenciador de licenças.
  • Os computadores clientes de licenças não têm nenhum software adicional específico do SolidNetWork instalado.

    Se você especificar um número de série da licença SolidNetWork ao realizar a instalação, o Gerenciador de Instalação do SolidWorks identifica esse computador como um cliente de licença SolidNetWork. O Gerenciador de Instalação do SolidWorks solicita que você informe o número de porta e o nome do computador gerenciador de licenças do SolidNetWork para conectar o cliente ao gerenciador de licenças.

  • O gerenciador de licenças e todos os clientes de licença precisam ter conectividade TCP/IP (Transmission Control Protocol/Internet Protocol).
  • Ativar uma licença SolidNetWork
    Para que os usuários possam executar os produtos SolidWorks em seus computadores individuais, você precisa ativar uma licença SolidNetWork no computador com o SolidNetWork License Manager.
  • Transferir uma licença SolidNetWork
    Para transferir uma licença SolidNetWork para um computador novo ou atualizado, primeiro transfira-a para o servidor de chave de licença da Dassault Systèmes SolidWorks Corporation e, depois, ative-a novamente no outro computador.
  • Instalar e configurar a licença SolidNetWork
    A configuração da licença SolidNetWork consiste na instalação do SolidNetWork License Manager no computador gerenciador de licenças e, depois, a instalação do SolidWorks nos computadores clientes usando o número de série da licença SolidNetWork.
  • Administração de Licenças SolidNetWork
    As tarefas incluem iniciar, atualizar e desinstalar o gerenciador de licenças, além de recuperar, emprestar e devolver as licenças.
Tópico pai: Administração de licenças


Ativar uma licença SolidNetWork

Para que os usuários possam executar os produtos SolidWorks em seus computadores individuais, você precisa ativar uma licença SolidNetWork no computador com o SolidNetWork License Manager.

A ativação requer que você tenha acesso à Internet ou a e-mails. Após a ativação, você não precisa estar on-line para usar os produtos. Se você não tem acesso a e-mails no computador onde usa este produto, pode salvar o arquivo de ativação e enviá-lo por outro computador.

Este processo:
  • Ativa o SolidNetWork License Manager do SolidWorks com licenças SolidNetWork de todos os produtos SolidWorks.
  • Permite transferir os direitos de licença SolidNetWork de um computador SolidNetWork License Manager para outro.
  • Permite instalar e ativar os direitos de licenças SolidNetWork em um computador SolidNetWork License Manager.
  • Precisa ser executado para que você possa usar licenças SolidNetWork.
  • Elimina a necessidade de dongles. Se você ativar uma licença SolidNetWork para esta versão do SolidWorks, as licenças SolidNetWork para versões anteriores do SolidWorks são ativadas (não é mais necessário manter o dongle).

Para ativar uma licença SolidNetWork:

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Se você ainda não ativou a licença SolidNetWork, será perguntado se você deseja ativá-la agora. Clique em Sim para ativá-la.
  3. Em Como você gostaria de fazer a ativação?, selecione Automaticamente pela Internet (recomendado).
  4. Em Informações sobre contato, especifique um endereço de e-mail para contato.
A caixa de diálogo Ativação/Reativação com êxito apresenta os produtos que foram ativados.
Tópico pai: Administração de licenças usando o SolidNetWork License Manager


Transferir uma licença SolidNetWork

Para transferir uma licença SolidNetWork para um computador novo ou atualizado, primeiro transfira-a para o servidor de chave de licença da Dassault Systèmes SolidWorks Corporation e, depois, ative-a novamente no outro computador.

Se você não pôde transferir a licença para a Dassault Systèmes SolidWorks Corporation (devido a uma falha do disco rígido, por exemplo), na maioria dos casos a reativação ainda será bem-sucedida. Caso contrário, consulte seu VAR para obter ajuda.

Para transferir uma licença SolidNetWork de volta ao servidor:

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).

  2. Em Informações de licença, clique em Modificar. O assistente de Ativação de Produtos SolidWorks é iniciado.
  3. Em O que você gostaria de fazer?, selecione Transferir uma licença de software e clique em Avançar.
  4. Em Como você gostaria de fazer a transferência?, selecione Automaticamente pela Internet (recomendado).
  5. Em Informações sobre contato, especifique um endereço de e-mail para contato.
  6. Clique em Avançar. A transferência da licença do produto é concluída.
Tópico pai: Administração de licenças usando o SolidNetWork License Manager


Instalar e configurar a licença SolidNetWork

A configuração da licença SolidNetWork consiste na instalação do SolidNetWork License Manager no computador gerenciador de licenças e, depois, a instalação do SolidWorks nos computadores clientes usando o número de série da licença SolidNetWork.

  • Instalar e ativar um Gerenciador de Licenças
    O SolidNetWork License Manager tem suporte para clientes com múltiplas licenças. Ele distribui licenças aos clientes na rede.
  • Instalar uma licença de cliente
    Quando instala o SolidWorks em computadores com uma licença de cliente SolidNetWork, o número de série identifica esse computador como sendo um Cliente de Licença SolidNetWork.
  • Instalar os SolidNetWork License Managers antes de instalar os clientes de licenças
    Você deve instalar e configurar o SolidNetWork License Manager em pelo menos um computador antes de instalar qualquer computador cliente de licença do SolidNetWork.
  • Instalação do gerenciador de licenças em tríade
    Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Se o computador que está administrando o arquivo de licença não estiver disponível, um dos outros dois computadores assume o comando.
  • Utilização das licenças SolidNetWork com firewalls
    Se o seu computador utiliza um firewall, você precisa configurar as portas para fornecer suporte à licença SolidNetWork.
Tópico pai: Administração de licenças usando o SolidNetWork License Manager


Instalar e ativar um Gerenciador de Licenças

O SolidNetWork License Manager tem suporte para clientes com múltiplas licenças. Ele distribui licenças aos clientes na rede.

Se você está atualizando uma versão anterior do SolidNetWork License Manager que usava um hardware dongle para a ativação da licença, remova o dongle antes de instalar a nova versão do SolidNetWork License Manager.

  1. Inicie o Gerenciador de Instalação do SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
    1. Como tipo de instalação, selecione o seguinte:

      • Produtos de Servidor
      • Instalar o SolidNetWork License Manager (distribuição de licenças) neste computador.

    2. Na página Opções do SolidNetWork License Manager, especifique o número de série da licença SolidNetWork e o local de instalação do SolidNetWork License Manager.
    3. Na página Resumo, clique em Instalar agora para concluir o processo do Gerenciador de Instalação do SolidWorks.
  2. Para ativar a licença SolidNetWork:
    1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Quando solicitado a ativar, clique em Sim.
    3. Na tela Informações do Servidor de Licenças SolidNetWork:

      • Se a sua companhia usa um firewall, selecione Um firewall está sendo usado neste servidor.

        Para obter mais informações, consulte Utilização das licenças SolidNetWork com firewalls.

      • Use os valores predeterminados de Número da porta (e Número da porta Daemon do fornecedor, se é usado um firewall) ou especifique os números de porta que sua empresa utiliza.
        Esse número é um número de porta TCP/IP, no intervalo de 1024 a 60000, usado exclusivamente por este processo. O valor predeterminado (25734) normalmente é adequado e é improvável que seja igual a qualquer outro processo de servidor FLEXnet atualmente no computador gerenciador de licenças.

    4. Na tela Ativar seu produto SolidWorks:

      • Selecione o procedimento pela internet ou por e-mail.
      • Forneça as informações de e-mail para contato.
      • Clique em Avançar para prosseguir.
        • Internet: A ativação ocorre automaticamente.
        • E-mail: Pressione Salvar para criar um arquivo de solicitação, então envie esse arquivo para activation@solidworks.com. Quando você receber o e-mail contendo o arquivo de resposta, extraia este arquivo do e-mail e clique em Abrir para carregá-lo.
          Se necessário, você pode sair do procedimento de ativação e executá-lo novamente para abrir o arquivo de resposta.

  3. Clique em Concluir.
Tópico pai: Instalar e configurar a licença SolidNetWork


Instalar uma licença de cliente

Quando instala o SolidWorks em computadores com uma licença de cliente SolidNetWork, o número de série identifica esse computador como sendo um Cliente de Licença SolidNetWork.

  1. Inicie o Gerenciador de Instalação SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
  2. Na tela de boas-vindas, clique em Individual (neste computador) se essa for a primeira instalação dessa versão principal do SolidWorks nesse computador.

    Se estiver atualizando uma versão existente e estiver mudando de uma licença individual para uma licença SolidNetWork, clique em Modificar a instalação individual (neste computador). Para obter detalhes, consulte Atualizar uma licença individual para uma licença SolidNetWork.

  3. Quando for solicitado um número de série, insira o número de série da Licença SolidNetWork.
  4. Na caixa de diálogo Adicionar servidor, digite o endereço do Gerenciador de Licenças do SolidNetWork no formato:

    porta@Nome_do_computador

    O número da porta precisa ser igual ao usado para o computador gerenciador de licenças. O padrão é 25734 (como descrito em Instalar e ativar um Gerenciador de Licenças).

    O Gerenciador de Instalação do SolidWorks vai tentar confirmar se esse Gerenciador de Licenças do SolidNetWork está disponível. Se você ainda não instalou um gerenciador de licenças, essa confirmação falhará; no entanto, você pode continuar a instalação do cliente de licença.

  5. Conclua a instalação do SolidWorks seguindo as instruções do Gerenciador de Instalação do SolidWorks.
Tópico pai: Instalar e configurar a licença SolidNetWork


Instalar os SolidNetWork License Managers antes de instalar os clientes de licenças

Você deve instalar e configurar o SolidNetWork License Manager em pelo menos um computador antes de instalar qualquer computador cliente de licença do SolidNetWork.

Ao realizar a instalação com um número de série de licença SolidNetWork, o Gerenciador de Instalação do SolidWorks pede para você inserir o número de porta e o nome do computador do SolidNetWork License Manager e, em seguida, tenta validar essas informações.

Se você ainda não tiver instalado o SolidNetWork License Manager no computador que especificou, essa validação não é bem-sucedida. No entanto, neste caso, a falha na validação não indica se você forneceu as informações corretas do gerenciador de licenças. Se o gerenciador de licenças estiver instalado, a falha da validação indica que você especificou informações incorretas do gerenciador de licenças.

Tópico pai: Instalar e configurar a licença SolidNetWork


Instalação do gerenciador de licenças em tríade

Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Se o computador que está administrando o arquivo de licença não estiver disponível, um dos outros dois computadores assume o comando.

A seguir, apresentamos os requisitos para a utilização de gerenciadores de licenças em tríade:
  • São necessários três dongles de hardware.
  • Instale os gerenciadores de licenças em tríade apenas em computadores estáveis que não estejam programados para interrupções freqüentes de operação.
  • Os três computadores gerenciadores de licenças devem estar na mesma sub-rede. Nunca configure gerenciadores de licenças em tríade que usem comunicações lentas ou conexão dial-up.
  • O administrador do sistema deve detectar quando um computador gerenciador de licenças é desligado e deve reiniciá-lo assim que possível.
    Se somente dois computadores gerenciadores de licenças estiverem em execução, a situação é pior que ter um único computador gerenciador de licenças, pois nesse caso há dois pontos de falha.
  • Instalar o Gerenciador de Licenças em Tríade inicial
    Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Este processo mostra como instalar o SolidNetWork License Manager no primeiro computador da tríade.
  • Instalar o Gerenciador de Licenças em Tríade nos computadores seguintes
    Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Este processo mostra como instalar o SolidNetWork License Manager no segundo e no terceiro computador da tríade.
Tópico pai: Instalar e configurar a licença SolidNetWork


Instalar o Gerenciador de Licenças em Tríade inicial

Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Este processo mostra como instalar o SolidNetWork License Manager no primeiro computador da tríade.

  1. No primeiro computador gerenciador de licenças em tríade, instale o SolidNetWork License Manager usando o Gerenciador de Instalação do SolidWorks:
    1. Inicie o Gerenciador de Instalação do SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
    2. Como tipo de instalação, selecione o seguinte:

      • Produtos de Servidor
      • Instalar o SolidNetWork License Manager (distribuição de licenças) neste computador.

    3. Na página Opções do SolidNetWork License Manager, especifique o número de série da licença SolidNetWork e o local de instalação do SolidNetWork License Manager.
    4. Na página Resumo, clique em Instalar agora para concluir o processo do Gerenciador de Instalação do SolidWorks.
  2. Usando o SolidNetWork License Manager, configure o computador gerenciador de licenças em tríade inicial:
    1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Clique em Não.

      A guia Administração de Servidores do SolidNetWork License Manager do SolidWorks é exibida.

    3. Em Opções avançadas, clique em Opções.

      A caixa de diálogo Opções avançadas é exibida.

    4. No Modo de Licença do Servidor SolidNetWork, clique em Usar um arquivo de licença e em OK.

      A caixa de diálogo Opções avançadas é fechada.

    5. Em Informações de licença, clique em Modificar.

      O Assistente de Arquivo de Licença SolidNetWork é exibido.

    6. Em Tipo de servidor, selecione Tríade e clique em Avançar.
    7. No painel de Informações do servidor, verifique se o nome do computador, o ID do dongle e o número da porta do computador gerenciador de licenças em tríade inicial estão corretos e clique em Avançar.

      Se o seu computador usa um firewall, pode ser necessário fazer algumas especificações adicionais nesta tela. Para obter mais informações, consulte Utilização das licenças SolidNetWork com firewalls.

    8. Na tela Informações de servidor em tríade do parceiro, insira o nome do computador e os valores de ID dos dongles dos outros dois computadores gerenciadores de licença em tríade.

      Isso assegura que, se um gerenciador de licenças não estiver disponível, os computadores clientes podem obter uma licença dos dois outros servidores.

    9. Na tela Licenças, clique em Ler para procurar e abrir o arquivo SolidNetWork.

      As licenças são exibidas no assistente Arquivo de Licença SolidNetWork.

    10. Clique em Concluir.
    11. Clique em OK para fechar o assistente Arquivo de Licença SolidNetWork e em Concluir para sair do SolidNetWork License Manager.
Tópico pai: Instalação do gerenciador de licenças em tríade


Instalar o Gerenciador de Licenças em Tríade nos computadores seguintes

Os gerenciadores de licença em tríade usam três computadores para maior estabilidade. Este processo mostra como instalar o SolidNetWork License Manager no segundo e no terceiro computador da tríade.

Considera-se que você já tenha instalado pelo menos um gerenciador de licenças em tríade em outro computador. Para obter detalhes, consulte Instalar o Gerenciador de Licenças em Tríade inicial.

  1. No computador gerenciador de licenças em tríade, instale o SolidNetWork License Manager usando o Gerenciador de Instalação do SolidWorks:
    1. Inicie o Gerenciador de Instalação do SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
    2. Como tipo de instalação, selecione o seguinte:

      • Produtos de Servidor
      • Instalar o SolidNetWork License Manager (distribuição de licenças) neste computador.

    3. Na página Opções do SolidNetWork License Manager, especifique o número de série da licença SolidNetWork e o local de instalação do SolidNetWork License Manager.
    4. Na página Resumo, clique em Instalar agora para concluir o processo do Gerenciador de Instalação do SolidWorks.
  2. Usando o SolidNetWork License Manager, configure o computador gerenciador de licenças em tríade:
    1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager.

      Como você está executando o SolidNetWork License Manager pela primeira vez nesse computador, será perguntado se você deseja ativar o gerenciador agora.

    2. Clique em Não.

      A guia Administração de Servidores do SolidNetWork License Manager do SolidWorks é exibida.

    3. Em Opções avançadas, clique em Opções.

      A caixa de diálogo Opções avançadas é exibida.

    4. No Modo de Licença do Servidor SolidNetWork, clique em Usar um arquivo de licença e em OK.

      A caixa de diálogo Opções avançadas é fechada.

    5. Em Informações de licença, clique em Modificar.

      O Assistente de Arquivo de Licença SolidNetWork é exibido.

    6. Em Tipo de servidor, selecione Tríade e Sincronizar informações de servidor/licença e clique em Avançar.
    7. No painel de Informações do servidor, verifique se o nome do computador, o ID do dongle e o número da porta deste computador gerenciador de licenças em tríade estão corretos e clique em Avançar.

      Se o seu computador usa uma firewall, pode ser necessário fazer algumas especificações adicionais nesta tela. Para obter mais informações, consulte Utilização das licenças SolidNetWork com firewalls.

    8. Na tela Informações de servidor em tríade do parceiro, insira o nome do computador e os valores de ID dos dongles dos outros dois computadores gerenciadores de licença em tríade.

      Isso assegura que, se um gerenciador de licenças não estiver disponível, os computadores clientes podem obter uma licença dos dois outros servidores.

    9. Na tela Licenças, clique em Ler para procurar e abrir o arquivo SolidNetWork.

      Geralmente, o arquivo de licenças está localizado em \licenses\sw_d.lic no primeiro computador da tríade que você configurou.

      As licenças são exibidas no assistente Arquivo de Licença SolidNetWork.

    10. Clique em Concluir.

      Um aviso do Assistente de Arquivo de Licença SolidNetWork é exibido.

    11. Clique em OK para fechar o assistente Arquivo de Licença SolidNetWork e em Concluir para sair do SolidNetWork License Manager.

Se você estiver configurando o segundo computador da tríade, repita este processo para o terceiro computador da tríade de gerenciadores de licenças.

Tópico pai: Instalação do gerenciador de licenças em tríade


Utilização das licenças SolidNetWork com firewalls

Se o seu computador utiliza um firewall, você precisa configurar as portas para fornecer suporte à licença SolidNetWork.

No software de firewall, você precisa adicionar duas portas de licença SolidNetWork (por exemplo, porta_de_entrada_SNL e porta_de_saída_SNL) à lista de exceções do firewall. Para obter detalhes sobre a configuração dessas portas, entre em contato com o administrador do sistema.

Se você está usando o firewall do Windows no Windows XP SP2 e no Windows Server 2003 SP1, terá que modificar as portas no computador gerenciador de licenças SolidNetWork e modificar o arquivo de licença SolidNetWork para distribuir licenças aos computadores clientes.

  • Modificar as portas do computador Gerenciador de Licenças para o firewall do Windows
    Se estiver usando o firewall do Windows, você precisa modificar as configurações de porta do firewall no computador gerenciador de licenças do SolidNetWork.
  • Modificar as configurações do SolidNetWork License Manager para o firewall do Windows
    Se estiver usando o firewall do Windows, você precisa modificar o arquivo de licença SolidNetWork para usar as portas do firewall para distribuir as licenças aos computadores clientes.
Tópico pai: Instalar e configurar a licença SolidNetWork


Modificar as portas do computador Gerenciador de Licenças para o firewall do Windows

Se estiver usando o firewall do Windows, você precisa modificar as configurações de porta do firewall no computador gerenciador de licenças do SolidNetWork.

  1. No Windows, abra o Painel de controle e clique duas vezes em Central de segurança.
  2. Clique em Firewall do Windows.
  3. Na guia Exceções, clique em Adicionar porta.
  4. Digite um Nome (por exemplo, porta_de_entrada_SNL) e um Número de porta (por exemplo, 25734) e clique em OK.
  5. Na segunda porta, clique em Adicionar porta novamente na guia Exceções; especifique os outros número e nome de porta (por exemplo, porta_de_saída_SNL e 25735) e clique em OK. Anote o número da porta, pois você vai precisar indicá-lo posteriormente, quando modificar o arquivo de licença do SolidNetWork.

    Se usar o Workgroup PDM, você precisa modificar os números de porta do Workgroup PDM no firewall do Windows. Geralmente, essas portas são 20000 (VaultAdmin), 30000 (Data), 40000 (Request) e 80 (Viewer).

  6. Feche a Central de segurança do Windows e o Painel de controle.
Tópico pai: Utilização das licenças SolidNetWork com firewalls


Modificar as configurações do SolidNetWork License Manager para o firewall do Windows

Se estiver usando o firewall do Windows, você precisa modificar o arquivo de licença SolidNetWork para usar as portas do firewall para distribuir as licenças aos computadores clientes.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Na guia Administração de Servidores, sob Servidor de Licenças, clique em Parar. (clique em Sim quando for solicitada a confirmação e em OK para concluir a interrupção do servidor de licenças).
  3. Em Informações de licença, clique em Modificar.
  4. Em Tipo de servidor, selecione a disposição de servidores da sua rede (Único ou Tríade) e clique em Avançar.
  5. Em Informações do servidor:
    1. Selecione Um firewall está sendo usado neste servidor.
    2. O Número da Porta e o Número da porta Daemon do fornecedor devem conter os números de portas especificados no firewall do Windows (para obter detalhes, consulte Modificar as portas do computador Gerenciador de Licenças para o firewall do Windows).
    3. Clique em Avançar e em Concluir.
  6. Na guia Administração de servidores, em Servidor de licenças, clique em Parar.
  7. Clique em OK para fechar o SolidNetWork License Manager.
Tópico pai: Utilização das licenças SolidNetWork com firewalls


Administração de Licenças SolidNetWork

As tarefas incluem iniciar, atualizar e desinstalar o gerenciador de licenças, além de recuperar, emprestar e devolver as licenças.

  • Iniciar o SolidNetWork License Manager
    Você pode iniciar o SolidNetWork License Manager no menu Iniciar do Windows.
  • Atualizar o SolidNetWork License Manager
    Para versões principais do SolidWorks, atualizar o gerenciador de licenças consiste em desinstalar o gerenciador de licenças antigo, instalar o novo e reativar a licença SolidNetWork.
  • Excluir arquivos de licença SolidNetWork
    Exclua os arquivos SolidNetWork antigos e vencidos antes de fazer a atualização para os novos.
  • Obter licenças de cliente
    Para encerrar a conexão SolidNetWork de um cliente, um administrador do sistema pode interromper a licença e devolvê-la ao pool de licenças disponíveis.
  • Empréstimo e devolução de licenças SolidNetWork
    Você pode pegar uma licença SolidNetWork emprestada para usar o software em um local remoto. Como a licença é removida do pool de licenças disponíveis, a licença emprestada deve ser devolvida para ficar disponível novamente.
  • Monitorar o tempo ocioso da licença
    O SolidWorks pode registrar o tempo ocioso com o SolidNetWork License Manager, para que as licenças que não foram utilizadas por um determinado período sejam devolvidas ao pool de licenças disponíveis.
  • Instalar licenças temporárias
    A licença temporária "ANY" pode ser usada temporariamente quando a licença SolidNetWork original não estiver disponível.
  • Atualizar uma licença individual para uma licença SolidNetWork
    Você pode atualizar um computador que usa uma licença SolidWorks individual para uma licença SolidNetWork especificando o número de série da licença SolidNetWork no Gerenciador de Instalação do SolidWorks.
  • Uso das licenças SolidNetWork com produtos suplementares
    Você pode usar o SolidNetWork License Manager para distribuir licenças para produtos suplementares principais do SolidWorks (como o FeatureWorks e o Workgroup PDM Server, por exemplo).
  • Utilização do mesmo computador para as instalações da imagem administrativa e do gerenciador de licenças
    Você pode configurar um computador de uma rede para agir como o gerenciador de licenças que vai distribuir as licenças SolidNetWork e como um local de imagem administrativa a partir do qual os usuários podem instalar o software SolidWorks.
  • Gerenciamento de licenças FLEXnet Publisher
    A licença SolidNetWork se baseia no gerenciamento de licenças FLEXnet Publisher®.
Tópico pai: Administração de licenças usando o SolidNetWork License Manager


Iniciar o SolidNetWork License Manager

Você pode iniciar o SolidNetWork License Manager no menu Iniciar do Windows.

  • No Windows, execute este comando: Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager.
Tópico pai: Administração de Licenças SolidNetWork


Atualizar o SolidNetWork License Manager

Para versões principais do SolidWorks, atualizar o gerenciador de licenças consiste em desinstalar o gerenciador de licenças antigo, instalar o novo e reativar a licença SolidNetWork.

O gerenciador de licenças para uma versão mais nova pode distribuir licenças para os computadores clientes que ainda estão com a versão anterior.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Na guia Utilização da licença, para confirmar que nenhum computador cliente na rede está executando o SolidWorks.
  3. Desinstale o gerenciador de licenças antigo. Para obter detalhes, consulte Desinstalar o SolidNetWork License Manager.
  4. Instale o novo gerenciador de licenças e reative a licença SolidNetWork no computador gerenciador de licenças. Para obter detalhes, consulte Instalar e ativar um Gerenciador de Licenças.

Se estiver atualizando o SolidNetWork License Manager em um computador que também executa o aplicativo SolidWorks, atualize os clientes e gerenciadores de licença SolidNetWork antes de instalar qualquer novo service pack de aplicativo SolidWorks nesse computador.

Se estiver atualizando o gerenciador de licenças em um computador que hospeda imagens administrativas, atualize o gerenciador de licenças antes de atualizar as imagens administrativas. Para obter detalhes, consulte Utilização do mesmo computador para as instalações da imagem administrativa e do gerenciador de licenças.

  • Desinstalar o SolidNetWork License Manager
    Quando atualizar o SolidNetWork License Manager, você precisa desinstalar o gerenciador antigo antes de instalar o novo.
Tópico pai: Administração de Licenças SolidNetWork


Desinstalar o SolidNetWork License Manager

Quando atualizar o SolidNetWork License Manager, você precisa desinstalar o gerenciador antigo antes de instalar o novo.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Certifique-se de que nenhum computador cliente na rede está executando o SolidWorks.

    A guia Utilização de licenças mostra os clientes que estão executando o SolidWorks.

  3. Se quiser transferir a licença SolidNetWork para outro computador, faça a transferência da licença antes de remover o SolidNetWork License Manager desse computador.

    Para obter informações sobre a transferência de licenças SolidNetWork, consulte Transferir uma licença SolidNetWork.

  4. Na guia Administração de Servidores, em Servidor de Licenças, clique em Parar.
  5. Clique em OK para sair do gerenciador de licenças.
  6. No Windows, abra Painel de controle > Adicionar ou remover programas.
  7. Selecione SolidNetWork License Manager do SolidWorks, clique em Remover e confirme a exclusão.
  8. No Windows Explorer, exclua a pasta SolidNetWork License Manager do SolidWorks

    (geralmente, essa pasta está localizada em Arquivos de programas no diretório de instalação do SolidWorks).

Agora, você está pronto para instalar uma nova versão do gerenciador de licenças. Para obter detalhes, consulte Instalar e ativar um Gerenciador de Licenças.

Se o computador com o SolidNetWork License Manager tem um hardware dongle conectado, remova o dongle antes de instalar a nova versão do SolidNetWork License Manager.
Tópico pai: Atualizar o SolidNetWork License Manager


Excluir arquivos de licença SolidNetWork

Exclua os arquivos SolidNetWork antigos e vencidos antes de fazer a atualização para os novos.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Na guia Administração de Servidores, em Arquivo de licença, clique em Modificar e depois em Avançar até chegar à tela Licenças.
  3. Na tela Licenças, selecione o arquivo SolidNetWork antigo ou vencido e clique em Remover.
  4. Clique em Concluir e em OK.
Tópico pai: Administração de Licenças SolidNetWork


Obter licenças de cliente

Para encerrar a conexão SolidNetWork de um cliente, um administrador do sistema pode interromper a licença e devolvê-la ao pool de licenças disponíveis.

  • O cliente precisa estar conectado ao gerenciador de licenças há, pelo menos, dois minutos.
  • Você pode configurar o recurso de tempo limite do SolidNetWork para o mínimo de 15 minutos. Após 15 minutos de tempo ocioso, essa licença é devolvida ao pool de licenças disponíveis.

Para obter detalhes, consulte diretório_de_instalação_do_SolidNetWork_License_Manager\Docs\flexuser\licensingenduserguide.pdf.

  1. Clique em Iniciar > Executar, digite cmd e clique em OK para abrir uma janela de comando do Windows.
  2. Na janela de comando, digite:

    cd diretório_de_instalação_do_SolidNetWork_License_Manager\utils lmutil lmremove recurso usuário computador exibição

    onde recurso, usuário, computador e exibição são termos exibidos na guia de Utilização de licenças do SolidNetWork License Manager.

    Por exemplo:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    Você precisa encerrar a licença para para cada produto suplementar (PhotoView 360, FeatureWorks, etc.) separadamente.

Tópico pai: Administração de Licenças SolidNetWork


Empréstimo e devolução de licenças SolidNetWork

Você pode pegar uma licença SolidNetWork emprestada para usar o software em um local remoto. Como a licença é removida do pool de licenças disponíveis, a licença emprestada deve ser devolvida para ficar disponível novamente.

As licenças emprestadas são válidas somente no sistema de onde foram pedidas emprestadas; não podem ser transferidas.

O empréstimo da licença dura um período específico de até 30 dias (ou como definido pelo administrador do sistema) e a licença é removida do pool de licenças disponíveis.

Os administradores de sistema podem personalizar o empréstimo para:
  • Definir os usuários ou grupos que têm permissão para tomar licenças emprestadas.
  • Definir o número de licenças que não podem ser emprestadas.

Para obter detalhes, consulte diretório_de_instalação_do_Gerenciador_de_Licenças_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

  • Empréstimo de licenças SolidNetWork
    Você pode tomar emprestada uma licença do SolidWorks para usar o software em um local remoto.
  • Devolver uma licença SolidNetWork emprestada
    Como uma licença SolidNetWork emprestada é removida do pool de licenças disponíveis, ela precisa ser devolvida para se tornar disponível novamente.
Tópico pai: Administração de Licenças SolidNetWork


Empréstimo de licenças SolidNetWork

Você pode tomar emprestada uma licença do SolidWorks para usar o software em um local remoto.

Você precisa estar conectado ao gerenciador de licenças SolidNetWork para tomar emprestada a licença, mas não necessariamente para usá-la.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Na guia Empréstimo de licenças:
    1. Selecione uma data em Tomar emprestado até.
    2. Selecione os produtos para o empréstimo e clique em Pedir emprestado, depois em Sim para confirmar.
    3. Clique em Atualizar. A coluna Data de vencimento indica quando a licença deve ser devolvida.
  3. Clique em OK.
Para executar o SolidWorks, você precisa tomar emprestada uma licença do SolidWorks. As licenças do SolidWorks Professional e do SolidWorks Premium habilitam somente os suplementos associados ao pacote, não o aplicativo SolidWorks.
Tópico pai: Empréstimo e devolução de licenças SolidNetWork


Devolver uma licença SolidNetWork emprestada

Como uma licença SolidNetWork emprestada é removida do pool de licenças disponíveis, ela precisa ser devolvida para se tornar disponível novamente.

  1. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Na guia Empréstimo de licenças:
    1. Selecione os produtos a serem devolvidos, clique em Devolver e em Sim para confirmar.
    2. Clique em Atualizar. A coluna Data de vencimento fica em branco, indicando que as licenças foram devolvidas.
  3. Clique em OK.
Não é necessário devolver as licenças depois da data de vencimento. A licença é devolvida ao pool do gerenciador de licenças do SolidNetWork à meia-noite da data de vencimento e os aplicativos no local remoto não podem mais ser executados.
Tópico pai: Empréstimo e devolução de licenças SolidNetWork


Monitorar o tempo ocioso da licença

O SolidWorks pode registrar o tempo ocioso com o SolidNetWork License Manager, para que as licenças que não foram utilizadas por um determinado período sejam devolvidas ao pool de licenças disponíveis.

  1. No diretório de instalação do SolidNetwork License Manager, crie um arquivo de texto:

    diretório_de_instalação_do_SolidNetwork License Manager\Licenses\sw_d.opt

  2. Insira no arquivo a linha a seguir:

    TIMEOUTALL segundos

    onde segundos é um número maior ou igual a 900 (15 minutos), que é o tempo mínimo permitido.

Tópico pai: Administração de Licenças SolidNetWork


Instalar licenças temporárias

A licença temporária "ANY" pode ser usada temporariamente quando a licença SolidNetWork original não estiver disponível.

Quando instala o arquivo de licença "ANY", você concorda em implementar o arquivo de licença tradicional ao receber uma licença SolidNetWork da Dassault Systèmes SolidWorks Corporation. Ainda se aplicam as restrições da licença.

Para instalar uma licença "ANY":

  1. Se você for um usuário existente do SolidNetWork, desinstale o Gerenciador de Licenças SolidNetWork e exclua a pasta de instalação. Para obter detalhes, consulte Desinstalar o SolidNetWork License Manager.
  2. Inicie o Gerenciador de Instalação do SolidWorks (como descrito em Iniciar a instalação do SolidWorks).
    1. Como tipo de instalação, selecione o seguinte:

      • Produtos de Servidor
      • Instalar o SolidNetWork License Manager (distribuição de licenças) neste computador.

    2. Na página Opções do SolidNetWork License Manager, especifique o número de série da licença SolidNetWork e o local de instalação do SolidNetWork License Manager.
    3. Na página Resumo, clique em Instalar agora para concluir o processo do Gerenciador de Instalação do SolidWorks.
  3. Inicie o SolidNetWork License Manager (Iniciar > Programas > SolidWorks versão > SolidNetWork License Manager > SolidNetWork License Manager).
  4. Se você for solicitado a ativar, clique em Não.

    A guia Administração de Servidores do SolidNetWork License Manager do SolidWorks é exibida.

  5. Em Opções avançadas, clique em Opções.

    A caixa de diálogo Opções avançadas é exibida.

  6. No Modo de Licença do Servidor SolidNetWork, clique em Usar um arquivo de licença e em OK.

    A caixa de diálogo Opções avançadas é fechada.

  7. Em Informações de licença, clique em Modificar.

    O Assistente de Arquivo de Licença SolidNetWork é exibido.

  8. Em Tipo de servidor, selecione Único e clique em Avançar.
  9. Quando esta mensagem for exibida:

    Não foi possível ler o número de ID do dongle.
    clique em Cancelar.
    O ID "ANY" é exibido automaticamente.
    Se o seu computador usa um firewall, pode ser necessário fazer algumas especificações adicionais nesta tela. Para obter mais informações, consulte Utilização das licenças SolidNetWork com firewalls.

  10. Continue a instalação.
Tópico pai: Administração de Licenças SolidNetWork


Atualizar uma licença individual para uma licença SolidNetWork

Você pode atualizar um computador que usa uma licença SolidWorks individual para uma licença SolidNetWork especificando o número de série da licença SolidNetWork no Gerenciador de Instalação do SolidWorks.

Se o SolidWorks não estiver instalado no computador, você pode especificar a licença SolidNetWork inserindo o número de série do SolidNetWork durante a instalação com o Gerenciador de Instalação do SolidWorks.

Se o computador já tiver o SolidWorks instalado e você estiver mudando de uma licença individual para uma licença SolidNetWork, você pode modificar a instalação para o computador cliente e especificar o número de série da licença SolidNetWork em vez do número de série da licença individual ao executar o Gerenciador de Instalação do SolidWorks. Para obter detalhes, consulte Modificar uma instalação.

Tópico pai: Administração de Licenças SolidNetWork


Uso das licenças SolidNetWork com produtos suplementares

Você pode usar o SolidNetWork License Manager para distribuir licenças para produtos suplementares principais do SolidWorks (como o FeatureWorks e o Workgroup PDM Server, por exemplo).

  • Não é necessário ter um número igual de licenças do software SolidWorks e de suplementos do SolidWorks.
  • Para fazer o check-out de uma licença para um produto suplementar, você precisa primeiro fazer o check-out de uma licença para o SolidWorks.
  • Para pedir emprestada uma licença para um produto suplementar, você precisa pedir emprestadas licenças do software SolidWorks e do produto SolidWorks que inclui o suplemento. Por exemplo, você pode precisar pedir emprestada uma licença do SolidWorks Professional ou do SolidWorks Premium.
  • Para liberar a licença de um produto suplementar:
    • No SolidWorks, clique em Ferramentas > Suplementos e demarque o suplemento.
    • Saia do SolidWorks.
Tópico pai: Administração de Licenças SolidNetWork


Utilização do mesmo computador para as instalações da imagem administrativa e do gerenciador de licenças

Você pode configurar um computador de uma rede para agir como o gerenciador de licenças que vai distribuir as licenças SolidNetWork e como um local de imagem administrativa a partir do qual os usuários podem instalar o software SolidWorks.

Os computadores clientes podem obter licenças no gerenciador de licenças e, depois, instalar o SolidWorks a partir do mesmo computador.

Essa configuração requer que o gerenciador de licenças e a imagem administrativa estejam instalados no mesmo computador. Instale o gerenciador de licenças primeiro e, depois, crie e distribua a imagem administrativa.
Para obter mais detalhes, consulte:
  • Instalar e ativar um Gerenciador de Licenças
  • Distribuição para múltiplos clientes
Tópico pai: Administração de Licenças SolidNetWork


Gerenciamento de licenças FLEXnet Publisher

A licença SolidNetWork se baseia no gerenciamento de licenças FLEXnet Publisher®.

Para obter mais informações sobre o gerenciamento de licenças FLEXnet Publisher, consulte o Manual de Administração de Licenças do FLEXnet Publisher no diretório de instalação do SolidNetWork License Manager (diretório_de_instalação_do_SolidNetWork_License_Manager\Docs\flexuser\licensingenduserguide.pdf).

Para obter as informações mais recentes sobre o gerenciamento de licenças FLEXnet Publisher, consulte Acresso® Software.

Tópico pai: Administração de Licenças SolidNetWork


Solução de problemas

Os tópicos a seguir podem ser úteis para identificar e solucionar problemas de instalação.

  • Arquivos de log do Gerenciador de Instalação do SolidWorks
    Os arquivos de log do Gerenciador de Instalação do SolidWorks estão disponíveis para auxiliá-lo na resolução de problemas de instalação.
  • Pasta de download do Gerenciador de Instalação do SolidWorks
    O Gerenciador de Instalação do SolidWorks pode fazer o download dos arquivos de instalação necessários e colocá-los na pasta que você especificar. Este tópico fornece respostas às dúvidas mais frequentes sobre a pasta de download.
  • Solução de problemas de licenças SolidNetWork
    Se a instalação do SolidNetWork License Manager falhar, verifique essas possíveis explicações.
  • Solução de problemas de atualizações
    Se tiver problemas durante a atualização para uma nova versão do SolidWorks, verifique essas possíveis explicações.


Arquivos de log do Gerenciador de Instalação do SolidWorks

Os arquivos de log do Gerenciador de Instalação do SolidWorks estão disponíveis para auxiliá-lo na resolução de problemas de instalação.

Esses arquivos de log estão localizados com os outros arquivos de log do aplicativo SolidWorks.
  • No Windows Vista ou posterior:

    C:\Users\nome_do_usuário\AppData\Roaming\SolidWorks\Installation Logs\versão_instalada

  • Nas versões do sistema operacional Windows anteriores ao Vista:

    C:\Documents and Settings\nome do usuário\Application Data\SolidWorks\Installation Logs\versão_instalada\

Para ver esses diretórios de arquivos de log, você precisa ter configurado as opções de pasta do Windows como Exibir arquivos e pastas ocultos.

Se os dados de aplicativos estiverem localizados em uma unidade de disco que não a unidade C:, ajuste o caminho do diretório com a unidade correta.

Esse diretório contém o arquivo SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, um log geral do progresso do Gerenciador de Instalação do SolidWorks.

O subdiretório Other Logs contém informações mais detalhadas de log de instalação.

Tópico pai: Solução de problemas


Pasta de download do Gerenciador de Instalação do SolidWorks

O Gerenciador de Instalação do SolidWorks pode fazer o download dos arquivos de instalação necessários e colocá-los na pasta que você especificar. Este tópico fornece respostas às dúvidas mais frequentes sobre a pasta de download.

  1. Como instalar os arquivos nesta pasta?
  2. Posso instalar arquivos MSI manualmente a partir desta pasta usando msiexec ou algum outro aplicativo?
  3. Posso selecionar a mesma pasta de download para todas as versões que instalar?
  4. Fiz manualmente o download de alguns produtos do site da Dassault Systèmes SolidWorks Corporation. O Gerenciador de Instalação pode instalar esses produtos?
  5. Os arquivos que eu obtive por download podem ser compartilhados com outros usuários?
  6. Como sei quando há uma nova versão dos produtos SolidWorks disponível?
  7. O Gerenciador de Instalação mostra somente as instalações SW2006 ou SW2007, mas não a versão atual.
  8. O Gerenciador de Instalação não permite que eu selecione outro service pack de um produto para instalar.
  9. O Gerenciador de Instalação é impedido de fazer o download dos arquivos.
  10. Nem todos os meus produtos SolidWorks estão atualizados com o último service pack, mas Verificar atualizações indica que eu tenho a versão mais recente.
  11. Posso copiar um DVD para uma pasta de download?

Como instalar os arquivos nesta pasta?

Execute o arquivo setup.exe. Ainda pode ser necessário fazer o download de alguns arquivos se você selecionar a instalação de itens cujo download não foi feito anteriormente.

Não instale usando msiexec (veja abaixo).

Voltar ao início

Posso instalar arquivos MSI manualmente a partir desta pasta usando msiexec ou algum outro aplicativo?

Não. O Gerenciador de Instalação não faz o download de alguns arquivos que são necessários quando msiexec é executado.

Voltar ao início

Posso selecionar a mesma pasta de download para todas as versões que instalar?

As pastas de download são específicas da versão. A partir do SolidWorks 2010, o Gerenciador de Instalação do SolidWorks cria uma subpasta específica da versão dentro da pasta especificada.

Voltar ao início

Fiz manualmente o download de alguns produtos do site da Dassault Systèmes SolidWorks Corporation. O Gerenciador de Instalação pode instalar esses produtos?

A partir da versão SW2009, os arquivos carregados por download manual podem ser usados pelo Gerenciador de Instalação do SolidWorks. Contudo, é melhor executar o Gerenciador de Instalação do SolidWorks selecionando a opção de fazer o download dos arquivos. O Gerenciador de Instalação do SolidWorks mostra quais arquivos são necessários com base no produto que você está instalando, fornecendo links para o download de cada arquivo. Esta opção pode ser usada quando a página de download embutida não funciona (mais provavelmente devido a restrições de download impostas pelo seu servidor proxy).
Se o Microsoft Internet Explorer perguntar se você deseja salvar ou executar os arquivos durante um download ou instalação, sempre escolha salvar.

Voltar ao início

Os arquivos que eu obtive por download podem ser compartilhados com outros usuários?

Sim. Para que isso seja possível, faça o download em uma rede compartilhada. Cada cliente pode então executar o Gerenciador de Instalação do SolidWorks para fazer a instalação a partir da pasta compartilhada.

Não serão necessários downloads adicionais, a menos que um usuário decida instalar alguns itens que não foram selecionados durante o download inicial ou se o computador que usa esse download para fazer a instalação tem um conjunto de pré-requisitos diferente do computador onde você fez o download dos arquivos.

Se você está fazendo o download para outros usuários, mas não está executando a instalação, selecione a opção Somente download durante a instalação. Essa opção permite selecionar produtos sem considerar o que de fato pode ser instalado no seu sistema. Contudo, esta opção não pode ser usada para o download de correções (patches) ou para criar imagens administrativas.

Voltar ao início

Como sei quando há uma nova versão dos produtos SolidWorks disponível?

Você será informado quando uma nova versão estiver disponível nos seguintes casos:
  • Se você executar a opção Verificar atualizações (Iniciar > Todos os programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações)
  • Se você ativou o Aplicativo de Download Automático do SolidWorks.
  • Se você selecionar uma versão instalada do SolidWorks em Adicionar/Remover programas no Windows e clicar em Alterar
  • Se você executar uma versão mais antiga do Gerenciador de Instalação (sldIM.exe) a partir de uma pasta de download
Nestes casos, você pode optar por fazer o download da versão mais recente. O Gerenciador de Instalação do SolidWorks fará o download e executará sua versão mais recente, mas não obterá nenhum arquivo de instalação. Depois que a nova versão do Gerenciador de Instalação do SolidWorks for executada, você poderá selecionar uma série de ações de instalação. O Gerenciador de Instalação do SolidWorks determinará então quais arquivos de instalação são necessários (e ainda não foram carregados) e apresentará a opção de fazer o download desses arquivos.

Voltar ao início

O Gerenciador de Instalação do SolidWorks mostra as instalações SW2006 ou SW2007, mas não mostra a versão atual.

Você está executando uma versão antiga do Gerenciador de Instalação do SolidWorks para a qual a versão atual não oferece mais suporte. Ele só pode fazer o download de service packs para as versões SW2006 e SW2007.

Voltar ao início

O Gerenciador de Instalação do SolidWorks não permite que eu selecione outro service pack de um produto para instalar.

Isso é proposital. Cada versão do Gerenciador de Instalação do SolidWorks foi projetada para instalar somente uma versão específica de produtos SolidWorks. Se quiser instalar um service pack diferente, você terá que executar a versão correspondente do Gerenciador de Instalação do SolidWorks. Para saber qual a versão mais recente disponível, consulte Como sei quando há uma nova versão dos produtos SolidWorks disponível?

Voltar ao início

O Gerenciador de Instalação do SolidWorks é impedido de fazer o download dos arquivos.

Se restrições do servidor proxy impedirem os aplicativos de fazer o download de arquivos, o Gerenciador de Instalação do SolidWorks não poderá fazer o download automático.

Você pode fazer o download manual e depois instalar os arquivos usando o Gerenciador de Instalação do SolidWorks. No Gerenciador de Instalação do SolidWorks, selecione a opção para o download individual de arquivos (por exemplo, Executar um download manual na página de Opções de download). Com base nas suas seleções de produtos e requisitos de sistema, uma página da web é aberta em uma janela separada contendo links para o download manual de todos os arquivos necessários. Esses links são idênticos aos fornecidos pelo Portal do Cliente SolidWorks, mas você não precisa procurar os arquivos.

Voltar ao início

Nem todos os meus produtos SolidWorks estão atualizados com o último service pack, mas Verificar atualizações indica que eu tenho a versão mais recente.

A opção Verificar atualizações apenas informa se você tem ou não instalada (ou se está executando) a versão mais recente do Gerenciador de Instalação do SolidWorks.

Se quiser atualizar todos os produtos com a versão mais recente que está instalada, em Adicionar/Remover programas, selecione a última versão instalada do SolidWorks e clique em Alterar.

Voltar ao início

Posso copiar um DVD para uma pasta de download?

Sim, mas as instalações podem falhar a menos que você copie o conteúdo integral de todos os DVDs para a sua plataforma (x86 ou x64). O Gerenciador de Instalação do SolidWorks procura os arquivos swdata*.id para determinar a versão. Se esses arquivos não estiverem presentes, ele não reconhecerá nenhum dos arquivos de instalação que você copiou e solicitará que você faça o download desses arquivos.

Voltar ao início

Tópico pai: Solução de problemas


Solução de problemas de licenças SolidNetWork

Se a instalação do SolidNetWork License Manager falhar, verifique essas possíveis explicações.

  • Acessar os arquivos de log de Licenças SolidNetWork
    Quando ocorre um erro de licença, a solução freqüentemente é encontrada no arquivo diretório_de_instalação_do_SNL_Manager\lmgrd.log.
  • Não foi possível obter uma licença para o SolidWorks. Não é possível conectar ao servidor de licenças.
    Geralmente, este problema é causado pelas configurações de porta.
Tópico pai: Solução de problemas


Acessar os arquivos de log de Licenças SolidNetWork

Quando ocorre um erro de licença, a solução freqüentemente é encontrada no arquivo diretório_de_instalação_do_SNL_Manager\lmgrd.log.

Tópico pai: Solução de problemas de licenças SolidNetWork


Não foi possível obter uma licença para o SolidWorks. Não é possível conectar ao servidor de licenças.

Geralmente, este problema é causado pelas configurações de porta.

  • As configurações de porta entre o SolidNetWork License Manager e o cliente de licenças podem não corresponder.
  • É possível que não tenham sido especificadas configurações de porta adicionais para múltiplas versões do SolidNetWork License Manager.
Para obter detalhes sobre configurações de porta para clientes e gerenciadores de licenças SolidNetWork, consulte Utilização das licenças SolidNetWork com firewalls.
Tópico pai: Solução de problemas de licenças SolidNetWork


Solução de problemas de atualizações

Se tiver problemas durante a atualização para uma nova versão do SolidWorks, verifique essas possíveis explicações.

  • Atualizar uma origem que foi movida
    Quando o SolidWorks é instalado, o Gerenciador de Instalação do SolidWorks registra o local das origens da instalação (mídia em disco, imagem administrativa em uma rede, etc). Quando executa atualizações, ele espera que essa origem ainda esteja disponível no mesmo local.
Tópico pai: Solução de problemas


Atualizar uma origem que foi movida

Quando o SolidWorks é instalado, o Gerenciador de Instalação do SolidWorks registra o local das origens da instalação (mídia em disco, imagem administrativa em uma rede, etc). Quando executa atualizações, ele espera que essa origem ainda esteja disponível no mesmo local.

Se a origem for movida ou excluída, ou se for usada outra mídia, o Gerente de Instalação do SolidWorks vai gerar uma mensagem de erro. Contudo, você pode continuar a atualização navegando até outro local contanto que ele contenha a mesma estrutura de pastas e arquivos.

Tópico pai: Solução de problemas de atualizações


Ajuda do aplicativo Gerenciador de Instalação do SolidWorks

O Gerenciador de Instalação do SolidWorks é um aplicativo independente que instala e atualiza seus produtos SolidWorks.

Você pode executar o Gerenciador de Instalação do SolidWorks:
  • A partir de um DVD do SolidWorks ou de uma pasta de download ou de origem compartilhada (quando uma nova versão é instalada)
  • No Painel de controle, na página Adicionar ou remover programas (ao modificar ou remover uma versão existente)
  • Por meio de uma verificação de atualização programada ou manual (quando é feita a detecção, download e instalação de uma nova versão principal)

Cada versão do SolidWorks tem uma versão específica do Gerenciador de Instalação do SolidWorks.

Para versões anteriores ao SolidWorks 2008, use o Gerenciador de Instalação do SolidWorks 2007 ou faça o download manual das versões dos produtos no site de suporte da SolidWorks.
  • Aplicativo de Download Automático do SolidWorks
    O Aplicativo de Download Automático do SolidWorks executa o download automático de arquivos (quando, por exemplo, uma nova versão de Service Pack é encontrada) usando processos em segundo plano, o que permite que você continue trabalhando durante o download. Quando o download é concluído, o aplicativo pergunta se você quer executar a instalação agora ou posteriormente, ou se que remover os arquivos carregados.
  • Verificar os resultados da atualização
    A opção Verificar atualizações procura versões posteriores do SolidWorks.
  • Local da Imagem Administrativa
    Especifique o local de instalação para a imagem administrativa.
  • Opções de download
    Especifique os detalhes para a conclusão da operação de download; por exemplo, o local para os arquivos obtidos, como executar o download de arquivos e se esses arquivos devem ou não ser instalados.
  • Opções de download para arquivos do Gerenciador de Instalação do SolidWorks
    Você optou por fazer o download de uma versão posterior do Gerenciador de Instalação do SolidWorks. Use esta tela para especificar onde e como ele será carregado.
  • Fazer o download dos arquivos de instalação de produto
    Especifique como fazer o download dos arquivos que faltam para o produto especificado.
  • Andamento do download
    O Gerenciador de Instalação do SolidWorks faz o download, verifica e extrai todos os arquivos em paralelo durante este processo.
  • Resultados do download
    Indica se o download foi concluído com êxito, falhou durante a operação ou foi cancelado.
  • Erros de instalação/Instalação cancelada
    A instalação encontrou um erro ou foi cancelada.
  • A instalação está completa
    O Gerenciador de Instalação do SolidWorks concluiu seu processamento.
  • Local de instalação
    Especifique os locais de instalação do SolidWorks.
  • Opções de atualização de software
    Uma ou mais versões principais mais antigas do SolidWorks estão atualmente instaladas neste computador. Escolha entre atualizar a versão existente mais recente com a nova versão ou criar um nova instalação para a nova versão.
  • Progresso da Instalação
    Esta tela mostra o andamento da instalação.
  • Tipo de instalao
    Especifique a operao de instalao que voc gostaria de executar, como, por exemplo, criao de uma nova instalao, modificao ou reparo de uma instalao existente, criao de uma imagem administrativa, instalao de produtos de servidor administrativo ou a realizao de downloads de arquivos sem a necessidade de instalao.
  • Instalação e gerenciamento em múltiplos computadores
    O Gerenciador de Instalação do SolidWorks fornece as seguintes ferramentas para instalar e gerenciar múltiplos computadores com o SolidWorks.
  • Download manual
    Você optou por fazer o download dos arquivos de modo manual (ou pode ter escolhido fazer o download de modo manual na última vez em que executou o Gerenciador de Instalação do SolidWorks).
  • Versão mais recente disponível
    O Gerenciador de Instalação detectou uma versão mais recente de produtos SolidWorks. Você pode optar por instalar a versão contida no DVD ou download da instalação original ou fazer o download e instalar a versão mais recente.
  • Nenhuma nova versão disponível
    Não há versões mais novas disponíveis para download. Continue instalando a versão especificada.
  • Processos detectados
    O Gerenciador de Instalação do SolidWorks detectou processos neste computador que podem impedir uma instalação bem-sucedida.
  • Seleção do produto
    Especifique os componentes dos produtos a serem instalados, modificados, carregados ou removidos.
  • Produtos para download
    Selecione os produtos SolidWorks para fazer seu download em um local especificado.
  • Produtos a reparar
    Quando você especifica Reparar esta instalação, essa tela mostra os produtos SolidWorks, e seus números de versão, que podem ser reparados por esta versão do Gerenciador de Instalação do SolidWorks.
  • Números de série
    Os números de série, que se encontram na caixa em que o produto é distribuído, associa seu computador aos produtos SolidWorks que você adquiriu.
  • Instalação de servidor
    Os produtos de servidor que você está tentando instalar são listados, juntamente com os resultados das instalações.
  • SolidNetWork License Manager
    Especifique as opções de instalação para o produto de servidor SolidNetWork License Manager.
  • Resumo
    O Gerenciador de Instalação do SolidWorks tem todas as informações necessárias para concluir a operação de instalação.
  • Avisos de verificação do sistema
    A verificação do sistema relatou problemas que podem afetar a maneira como você continua a instalação. Na maioria dos casos, você deve poder continuar com o Gerenciador de Instalação do SolidWorks.
  • Opções do Assistente de Perfuração/Toolbox
    Se o SolidWorks Toolbox for instalado, o SolidWorks inclui uma biblioteca de tipos padrão de furos e ferragens.
  • Desinstalação de produtos
    Quando você seleciona Remover ou Desinstalar no Painel de controle, essa tela exibe os produtos SolidWorks (com seus números de versão) que podem ser desinstalados por essa versão do Gerenciador de instalação do SolidWorks. Você pode optar por executar uma desinstalação padrão, personalizada ou completa.
  • Opções do Servidor do Workgroup PDM
    Especifique opções de instalação para o produto de servidor SolidWorks Workgroup PDM.


Aplicativo de Download Automático do SolidWorks

O Aplicativo de Download Automático do SolidWorks executa o download automático de arquivos (quando, por exemplo, uma nova versão de Service Pack é encontrada) usando processos em segundo plano, o que permite que você continue trabalhando durante o download. Quando o download é concluído, o aplicativo pergunta se você quer executar a instalação agora ou posteriormente, ou se que remover os arquivos carregados.

O Aplicativo de Download Automático do SolidWorks é ativado de forma predeterminada quando você instala o Gerenciador de Instalação do SolidWorks.

Quando o Gerenciador de Instalação do SolidWorks está sendo executado, seja em uma operação de instalação ou download, o Aplicativo de Download Automático do SolidWorks sofre uma pausa. Por exemplo, ele pausará qualquer download em execução, não permitirá que qualquer download seja iniciado nem permitirá que você altere a especificação da pasta de download.

O Aplicativo de Download Automático do SolidWorks é ativado de forma predeterminada quando você instala o SolidWorks. Você pode desativar o Aplicativo de Download Automático do SolidWorks durante a instalação do SolidWorks alterando as Opções de download na página Resumo (desmarque a opção Quer usar o Aplicativo de Download Automático?).

Quando ativado, o ícone aparecerá na bandeja do sistema do Windows, na barra de tarefas:

Clicar nesse ícone ativará estas operações:
  • Ajuda do Aplicativo de Download Automático
  • Pausar o download
  • Retomar download
  • Cancelar o download
  • Opções de instalação
  • Alterar o local de download
  • Verificar atualizações
  • Verificar atualizações automaticamente
  • Fazer o download de atualizações automaticamente
  • Desativar Aplicativo de Download Automático

Ajuda do Aplicativo de Download Automático

Abra esse tópico de ajuda do Aplicativo de Download Automático no Manual de Instalação do SolidWorks.

Pausar/Retomar o download

Se um download estiver sendo executado em segundo plano, clique em Pausar o download para pausá-lo, com a possibilidade de retomar posteriormente clicando em Retomar download.

Cancelar o download

Se um download estiver em execução, ele será interrompido e quaisquer arquivos que o Aplicativo de Download Automático já tiver carregado serão excluídos.
Não é possível retomar um download cancelado.

Opções de instalação

Quando um download é concluído, você pode escolher entre as seguintes opções:
  • Instalar agora: instala os arquivos carregados.
  • Lembrar mais tarde: não instala os arquivos carregados, mas configura uma mensagem para lembrá-lo posteriormente.
  • Excluir esse download: não instala os arquivos carregados e os exclui (é útil quando você decide que não deseja mais instalar os arquivos carregados).

Alterar o local de download

Altera o local onde o Aplicativo de Download Automático armazena os arquivos carregados.

Essa opção não fica disponível quando um download está em execução ou pausado.

Verificar atualizações

Executa o recurso Verificar atualizações do Gerenciador de Instalação do SolidWorks.

Verificar atualizações automaticamente

Executa periodicamente o recurso Verificar atualizações e emite uma notificação quando há atualizações disponíveis para download.

Fazer o download de atualizações automaticamente

Executa periodicamente o recurso Verificar atualizações e faz o download de atualizações quando se tornam disponíveis.

Ativar e desativar o Aplicativo de Download Automático do SolidWorks

Você pode desativar o Aplicativo de Download Automático clicando no ícone e selecionando Desativar Aplicativo de Download Automático.

Para reativar o Aplicativo de Download Automático, clique em Iniciar > Todos os programas > Gerenciador de Instalação do SolidWorks > Aplicativo de Download Automático do SolidWorks.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Verificar os resultados da atualização

A opção Verificar atualizações procura versões posteriores do SolidWorks.

Você pode executar a opção Verificar atualizações manualmente:
  • No Windows, clique em Iniciar > Programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações
  • No SolidWorks, clique em Ajuda > Verificar atualizações.
A opção Verificar atualizações não está disponível em clientes instalados a partir de imagens administrativas.

Versão mais recente disponível

O Gerenciador de Instalação do SolidWorks detectou uma versão mais recente de produtos SolidWorks. Você pode atualizar para uma versão mais nova selecionando o Gerenciador de Instalação do SolidWorks daquela versão.

Essa versão mais nova pode fazer o download dos arquivos de instalação com base nos produtos que você especificar na instalação. Você pode compartilhar os arquivos carregados com outros usuários que instalam usando o Gerenciador de Instalação do SolidWorks.

Esses downloads são para uso exclusivo do Gerenciador de Instalação do SolidWorks.
As opções disponíveis são:
  • Se existirem várias atualizações disponíveis, você pode selecionar uma versão na lista.
  • Para obter detalhes sobre a versão, clique em Verificar o que é incluído nesta atualização.
Clicando em Avançar, você obtém e executa a versão selecionada do Gerenciador de Instalação do SolidWorks.

Nenhum novo download disponível/Não é possível verificar se há novas versões

O Gerenciador de Instalação do SolidWorks não encontrou uma versão mais recente dos produtos SolidWorks; isso pode ter acontecido porque você está instalando a versão mais recente disponível ou porque o Gerenciador não pôde se conectar ao site da SolidWorks para fazer a verificação.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Local da Imagem Administrativa

Especifique o local de instalação para a imagem administrativa.

Quando você cria uma imagem administrativa, aplicam-se as seguintes opções:
Local da nova imagem
É o local do diretório no qual o Gerenciador de Instalação do SolidWorks criará a nova imagem.
Este local não pode conter uma imagem administrativa existente. A imagem administrativa precisa estar em uma pasta que possa ser compartilhada para fins de distribuição a clientes.
Espaço estimado necessário para a criação de imagens
Este é o espaço adicional necessário para a imagem administrativa.
Verifique se o disco no qual você está fazendo a instalação tem espaço livre suficiente para atender os requisitos da imagem.
Criar imagem a partir de
Este é o diretório de onde você está instalando produtos SolidWorks.
Esta opção é exibida somente quando a opção Somente instalação foi selecionada. Para obter detalhes, consulte Opções de download.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Opções de download

Especifique os detalhes para a conclusão da operação de download; por exemplo, o local para os arquivos obtidos, como executar o download de arquivos e se esses arquivos devem ou não ser instalados.

O Gerenciador de Instalação do SolidWorks tem suporte para a distribuição eletrônica de software (ESD). Se não estiver instalando a partir de um DVD da SolidWorks, você será solicitado especificar a origem dos produtos SolidWorks a serem instalados.

Para obter respostas para questões relacionadas à pasta de download, consulte Pasta de download do Gerenciador de Instalação do SolidWorks.

O que você quer fazer?

Selecione um dos seguintes:
Fazer o download e instalar/Fazer o download e criar imagens
Após a conclusão do download, o Gerenciador de Instalação do SolidWorks executa uma instalação usando o arquivo carregado.
Somente download. Você pode fazer o download uma vez e depois compartilhar os arquivos obtidos com vários computadores.
O Gerenciador de Instalação do SolidWorks não executa a instalação após o download ser concluído.

Normalmente, você especifica essa opção quando faz o download de arquivos para configurar um conjunto de arquivos de instalação que será compartilhado entre vários computadores.

Se especificar essa opção, você é solicitado a escolher entre dois conjuntos de arquivos para download:
  • Arquivos para ESTE computador: O download conterá somente os arquivos que não estão presentes no conjunto de arquivos de instalação atualmente neste computador.
    O download deve ser menor, porque contém:
    • Somente os arquivos para os produtos selecionados na página Seleção de produtos
    • Somente os arquivos que são pré-requisitos para a instalação neste computador, mas que ainda não foram instalados

    No entanto, se você tentar usar esse conjunto de arquivos em outro computador para executar uma instalação, alguns arquivos podem faltar (pois o conjunto de arquivos de instalação no outro computador pode ser diferente). Você pode instalar esses arquivos obtidos por download em outro computador, mas quando a instalação começar, pode ser necessário fazer o download de arquivos adicionais para completar o conjunto de arquivos de instalação no outro computador.

  • Arquivos para compartilhar com QUALQUER computador: O download conterá o conjunto completo de arquivos de instalação que pode ser usado para instalar essa versão em qualquer computador.

    Esse download é maior porque contém um conjunto completo de arquivos ,que pode ser usado para instalar esta versão de qualquer produto em qualquer computador.

    Se você especificou um conjunto limitado de produtos para o download, essa opção ignora os produtos especificados e faz o download de todos os produtos contidos na versão.

    O download conterá todos os arquivos necessários para a criação de uma imagem administrativa, não apenas os arquivos necessários para a execução de uma instalação individual.

Somente instalação/Somente criar a imagem. Eu já tenho todos os arquivos de instalação necessários.
O Gerenciador de Instalação do SolidWorks não faz o download de nenhum arquivo, mas utiliza os arquivos do diretório selecionado.

Clique em Procurar para navegar até outro local. Por exemplo, você pode navegar até um DVD de instalação ou uma pasta de download, desde que esse local contenha todos os arquivos necessários.

Se você receber uma mensagem de erro informando que a pasta está incompleta, mas esperava que todos os arquivos de instalação estivessem presentes naquele local, as explicações possíveis são as seguintes:
  • Você selecionou um componente para instalação que não foi carregado anteriormente ou que foi selecionado por padrão.
  • Os arquivos foram carregados em outro computador, com um conjunto de requisitos de sistema diferente.
  • Você executou uma instalação de cliente anteriormente e agora está criando uma imagem administrativa, que requer um conjunto maior de arquivos.

Você pode procurar em uma pasta que contém todos os arquivos (por exemplo, um DVD) ou selecionar uma das opções de download.

Onde você quer fazer o download dos arquivos necessários?

Este é o local da pasta de download.

Em alguns casos, essa opção pode estar visível, mas desativada. Por exemplo, se a opção Somente instalação estiver especificada, o Gerenciador de Instalação do SolidWorks instalará todos os arquivos carregados no diretório especificado para essa opção, em vez de usar uma pasta de download independente.

Quer você esteja fazendo o download desses arquivos ou acessando-os no seu próprio local, todos os arquivos precisam estar na mesma pasta de download.

Tamanho estimado do download

Os requisitos de espaço em disco estimados são baseados nas opções selecionadas na lista de componentes, quer o download seja executado do início ou a partir de uma sessão anterior.

Por exemplo, se você está retomando um download anterior, o Gerenciador de Instalação do SolidWorks processará somente os arquivos que ainda não foram carregados. O tempo de download pode ser menor que o estimado.

Se o download de um arquivo foi concluído no download anterior, seu tamanho não é incluído nessa estimativa. Portanto, a estimativa pode ser maior que o tamanho real do download.

Como você quer fazer o download?

Existem duas opções:
Executar um download manual
Em alguns casos, um servidor proxy pode proibir os downloads automáticos do Gerenciador de Instalação do SolidWorks.
Selecionando essa opção você pode fazer o download dos arquivos manualmente de uma página da web e depois continuar o processo no Gerenciador de Instalação do SolidWorks para concluir as operações de instalação. Essa página da web é personalizada pelo Gerenciador de Instalação do SolidWorks para fazer o download somente dos arquivos necessários para a conclusão da instalação.
Acelerar o download usando maior largura de banda da rede
O programa de download usa um algoritmo para aumentar a velocidade do download aumentando a largura de banda da rede usada para o download.

Em alguns casos, isso pode afetar o desempenho da rede. Se ocorrerem problemas durante o download, é possível que essa opção não tenha suporte no seu servidor proxy. Tente desmarcar esta opção e repetir o download. Para obter detalhes, consulte o administrador da sua rede.

Essa opção só se aplica a downloads automáticos. Não afeta os downloads manuais.

Aplicativo de Download Automático do SolidWorks

Você pode usar o Aplicativo de Download Automático do SolidWorks para concluir essa operação de download ou para o download de versões de Service Packs do SolidWorks futuras conforme ela se tornam disponíveis.

O Aplicativo de Download Automático do SolidWorks pode detectar automaticamente novos Service Packs em segundo plano, notificando-o quando o download é concluído e os arquivos estão prontos para instalação. Para obter detalhes, consulte Aplicativo de Download Automático do SolidWorks.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Opções de download para arquivos do Gerenciador de Instalação do SolidWorks

Você optou por fazer o download de uma versão posterior do Gerenciador de Instalação do SolidWorks. Use esta tela para especificar onde e como ele será carregado.

Para obter respostas para questões relacionadas à pasta de download, consulte Pasta de download do Gerenciador de Instalação do SolidWorks.

Esta tela é exibida somente se houver um problema com a pasta predeterminada de download (por exemplo, se o acesso de gravação ou o acesso à rede não estiver disponível). Normalmente, só é necessário especificar um diretório alternativo de download para poder continuar.

Diretório de download

Procure a pasta de destino para os arquivos do Gerenciador de Instalação do SolidWorks.

O tamanho do download e a quantidade de espaço necessário são exibidos. A quantidade de espaço necessário inclui o espaço adicional para a descompactação de determinados downloads e é maior que o espaço real do download.

Usar a aceleração de download

Se você escolher essa opção, é usado um algoritmo para acelerar a velocidade do download.

A aceleração de download aumenta a largura de banda e pode afetar o desempenho da rede. Consulte o administrador da sua rede antes de habilitar a aceleração de download.

Se a aceleração de download não tiver suporte no servidor proxy, essa opção é automaticamente desabilitada.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Fazer o download dos arquivos de instalação de produto

Especifique como fazer o download dos arquivos que faltam para o produto especificado.

O Gerenciador de Instalação do SolidWorks faz o download, verifica e extrai todos os arquivos em paralelo durante o processo de download.

O cancelamento do programa nesta tela cancela o restante da sequência de instalação.

Para conhecer as consequências do cancelamento e as instruções para concluir instalações interrompidas, consulte Erros de instalação.

Diretório de download

Procure a pasta de destino para os arquivos carregados.

O tamanho do download e o espaço necessário são exibidos. A quantidade de espaço necessário inclui o espaço adicional para a descompactação de determinados downloads e é maior que o espaço real do download.

Para obter respostas para questões relacionadas à pasta de download, consulte Pasta de download do Gerenciador de Instalação do SolidWorks.

Opções de download

Acelerar o download usando maior largura de banda da rede
O programa de download usa um algoritmo para aumentar a velocidade do download aumentando a largura de banda da rede usada para o download.

Em alguns casos, isso pode afetar o desempenho da rede. Se ocorrerem problemas durante o download, é possível que essa opção não tenha suporte no seu servidor proxy. Tente desmarcar esta opção e repetir o download. Para obter detalhes, consulte o administrador da sua rede.

A aceleração de download aumenta a largura de banda e pode afetar o desempenho da rede. Consulte o administrador da sua rede antes de habilitar a aceleração de download.

Se a aceleração de download não tiver suporte no servidor proxy, essa opção pode ser automaticamente desabilitada.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Andamento do download

O Gerenciador de Instalação do SolidWorks faz o download, verifica e extrai todos os arquivos em paralelo durante este processo.

Para cancelar o download depois de começado, clique em Cancelar.

Se você cancelar o download ou se o download falhar, a tela Download cancelado ou Problema de download indica quais downloads não foram concluídos e permite retomar o download ou fechar o aplicativo.

Para obter respostas para questões relacionadas à pasta de download, consulte Pasta de download do Gerenciador de Instalação do SolidWorks.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Resultados do download

Indica se o download foi concluído com êxito, falhou durante a operação ou foi cancelado.

Problema de download/Download cancelado

Se você observar um aviso de Problema com o download, o Gerenciador de Instalação do SolidWorks encontrou problemas que impediram a conclusão do download.

Se você observar um aviso de Download cancelado, você cancelou o download antes que ele pudesse ser concluído.

Para prosseguir:

Repetir/Retomar downloads automáticos
Para continuar o download automático de onde você o cancelou, selecione essa opção e clique em Repetir o download ou Retomar o download.
Fazer o download de arquivos individualmente em um navegador da internet
Em alguns casos, um servidor proxy pode proibir os downloads automáticos do Gerenciador de Instalação do SolidWorks.
Selecionando essa opção você pode fazer o download dos arquivos manualmente de uma página da web e depois continuar o processo no Gerenciador de Instalação do SolidWorks para concluir as operações de instalação. Essa página da web é personalizada pelo Gerenciador de Instalação do SolidWorks para fazer o download somente dos arquivos necessários para a conclusão da instalação.

Download concluído

A tela Download concluído é exibida quando o download é concluído, caso você tenha especificado a opção Somente download.

Clique em Concluir para sair do Gerenciador de Instalação do SolidWorks.

Não tente instalar nenhum desses produtos manualmente. Sempre use o Gerenciador de Instalação do SolidWorks para instalar os arquivos carregados.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Erros de instalação/Instalação cancelada

A instalação encontrou um erro ou foi cancelada.

Se ocorrer um erro ou o processo for cancelado:
  • Os produtos que foram instalados antes do erro ou cancelamento permanecem no computador.
  • O produto que estava sendo instalado no momento do cancelamento é revertido, se possível, para que não existam instalações parciais.
  • Os produtos restantes não são instalados ou desinstalados. Uma lista é fornecida em Ainda não tentado.

    Para continuar a instalação ou para desinstalar esses produtos, clique no link fornecido.

O Gerenciador de Instalação do SolidWorks instala primeiro os pré-requisitos que ainda não estão instalados no seu computador, como o .NET Framework. Em seguida, instala os produtos selecionados, nesta ordem:
  1. SolidWorks
  2. eDrawings
  3. Pesquisa do SolidWorks
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Recuperar uma instalação que falhou ou foi cancelada
    Se ocorrer um erro ou um cancelamento durante a instalação, quando você executar novamente a instalação, pode retomá-la do ponto onde foi interrompida.
  • Reparar uma instalação
    Se você tiver problemas com um produto SolidWorks instalado, pode usar o Gerenciador de Instalação do SolidWorks para reparar a instalação.
  • Consultar o revendedor SolidWorks
    Se a tentativa de modificar ou reparar a instalação falhar, consulte seu revendedor SolidWorks local e forneça as informações obtidas nesta tela. Você talvez tenha de fornecer um arquivo zip com os arquivos de log do Gerenciador de Instalação do SolidWorks.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Recuperar uma instalação que falhou ou foi cancelada

Se ocorrer um erro ou um cancelamento durante a instalação, quando você executar novamente a instalação, pode retomá-la do ponto onde foi interrompida.

  1. Registre a mensagem de erro e o código do produto cuja instalação falhou, como mostrado nas telas Erros de instalação ou Instalação cancelada.

    Se for solicitado que você indique um arquivo de origem e você não está modificando uma instalação existente do SolidWorks, a instalação ou o computador podem estar corrompidos. Consulte seu revendedor SolidWorks.

  2. Reinicialize o computador.
  3. Para ter certeza de que nenhum produto SolidWorks está sendo executado, no Windows, pressione Ctrl+Alt+Del para abrir o Gerenciador de Tarefas.
  4. Na guia Processos, se qualquer um dos seguintes processos aparecer em Nome da imagem, selecione-os e clique em Finalizar processo.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Se o aplicativo já está instalado e você está tentando modificá-lo ou removê-lo, tente reparar a instalação. Para obter detalhes, consulte Reparar uma instalação.
  6. No Windows Vista ou posterior, clique em Iniciar > Painel de controle > Adicionar ou remover programas. Em versões anteriores do Windows, clique em Iniciar > Painel de controle > Adicionar ou remover programas.
  7. Selecione a versão do SolidWorks que falhou.

    Se não houver entrada para a versão do SolidWorks que você está tentando instalar, repita o processo de instalação.

  8. Siga um destes procedimentos:
    • Para tentar novamente, clique em Alterar e selecione todos os produtos que falharam ou foram ignorados durante a instalação.

    • Para ignorar a instalação que falhou, clique em Alterar e selecione todos os produtos que foram ignorados durante a instalação. Desmarque os produtos que não foram instalados corretamente.

    • Para cancelar a instalação, clique em Remover e selecione todos os produtos que foram instalados.

    Isso não vai restaurar a versão anterior de todos os produtos que você estava atualizando.

Tópico pai: Erros de instalação/Instalação cancelada


Consultar o revendedor SolidWorks

Se a tentativa de modificar ou reparar a instalação falhar, consulte seu revendedor SolidWorks local e forneça as informações obtidas nesta tela. Você talvez tenha de fornecer um arquivo zip com os arquivos de log do Gerenciador de Instalação do SolidWorks.

  1. Localize os arquivos de log:
    • Nas versões do sistema operacional Windows anteriores ao Vista:

      C:\Documents and Settings\nome do usuário\Application Data\SolidWorks\Installation Logs\versão_instalada\

    • No Windows Vista ou posterior:

      C:\Users\nome do usuário\AppData\Roaming\SolidWorks\Installation Logs\versão_instalada\

    Se você não conseguir encontrar essa pasta, ela pode estar oculta. No Windows Explorer, clique em Ferramentas > Opções de pastas. Na guia Exibir, em Configurações avançadas, selecione Mostrar pastas e arquivos ocultos para Arquivos e pastas ocultos.

  2. Compacte o conteúdo inteiro dessa pasta em um arquivo .zip, incluindo as subpastas.
Tópico pai: Erros de instalação/Instalação cancelada


A instalação está completa

O Gerenciador de Instalação do SolidWorks concluiu seu processamento.

Uma ou mais dessas opções podem ser exibidas.

Novidades

Para instalações individuais, quando o processo termina, é exibido um documento descrevendo as novas funcionalidades do SolidWorks e seus produtos suplementares.

Para as instalações de imagens administrativas, o documento é exibido nos computadores dos clientes quando eles concluem a instalação.

Pesquisa

Dê sua opinião sobre o processo de instalação respondendo a uma pesquisa curta.

Participe do Programa de Aprimoramento da Experiência do Cliente (Customer Experience Improvement Program) da SolidWorks

As informações de desempenho são enviadas à SolidWorks Corporation para ajudar no aperfeiçoamento do produto. O processo é transparente e confidencial. Selecione um dos seguintes:
  • Sim, desejo participar
  • Não, obrigado
  • Lembrar mais tarde
Para obter mais informações, acesse o site do Programa de Aprimoramento da Experiência do Cliente.

A criação da Imagem Administrativa foi concluída

Quando você concluir a criação da imagem administrativa, pode clicar em Personalizar imagem para executar o Editor de Opções de Imagem Administrativa e personalizar a imagem.

Clique em Mostre como instalar esta imagem em um cliente para ver as instruções de como usar o Editor de Opções.

Para obter detalhes sobre a configuração de uma imagem administrativa usando o Editor de opções, consulte Editor de Opções de Imagem Administrativa.

Clique em Personalizar imagem para iniciar o Editor de Opções de Imagem Administrativa e personalizar as configurações de opção para essa imagem administrativa.
Você pode iniciar o Editor de Opções mais tarde, clicando duas vezes no arquivo sldAdminOptionEditor.exe no diretório de instalação da Imagem Administrativa.
  • Verificar se há atualizações do SolidWorks
    Você pode usar o Gerenciador de Instalação do SolidWorks para verificar manualmente se há atualizações ou para configurar verificações periódicas automáticas.
  • Programa de Aprimoramento da Experiência do Cliente da SolidWorks
    Quando instala o SolidWorks, você pode especificar que as informações de desempenho sejam enviadas à SolidWorks Corporation para ajudar a melhorar o produto.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Verificar se há atualizações do SolidWorks

Você pode usar o Gerenciador de Instalação do SolidWorks para verificar manualmente se há atualizações ou para configurar verificações periódicas automáticas.

  1. Inicie a o Gerenciador de Instalação do SolidWorks executando uma destas ações:

    • No aplicativo SolidWorks, clique em Ajuda > Verificar atualizações.

    • No Windows, clique em Iniciar > Programas > Gerenciador de Instalação do SolidWorks > Verificar atualizações.

    O Gerenciador de Instalação do SolidWorks informa se há alguma atualização disponível no momento.

  2. Se houver atualizações disponíveis, escolha se quer fazer o download e instalá-las.
  3. Para habilitar verificações de atualizações periódicas e automáticas, quando o Gerenciador de Instalação do SolidWorks concluir seu processamento, selecione Verificar atualizações a cada __ dias e especifique a frequência das verificações.
Tópico pai: A instalação está completa


Programa de Aprimoramento da Experiência do Cliente da SolidWorks

Quando instala o SolidWorks, você pode especificar que as informações de desempenho sejam enviadas à SolidWorks Corporation para ajudar a melhorar o produto.

A SolidWorks usa essas informações para determinar tendências relacionadas ao uso e qualidade do produto. Nossa meta é fornecer produtos da mais alta qualidade e os logs (arquivos de registro) de desempenho são uma ferramenta muito útil neste processo.

O processo é transparente. Todas as informações contidas nos arquivos de log são tratadas como confidenciais. Essas informações não são usadas para nenhum outro propósito e ninguém tentará entrar em contato com você.

Para obter mais informações, acesse o site do Programa de Aprimoramento da Experiência do Cliente.

Tópico pai: A instalação está completa


Local de instalação

Especifique os locais de instalação do SolidWorks.

As seguintes opções se aplicam a todas as instalações, exceto a de imagem administrativa:
Instalar os produtos selecionados em
Este é o local do diretório no qual você está instalando o SolidWorks.
Quando uma instalação é modificada ou atualizada, todos os arquivos precisam ser instalados no local da instalação existente. Neste caso, você não quer alterar o local da instalação existente do SolidWorks.
Espaço estimado necessário para a instalação
Este é o espaço adicional necessário para a instalação ou modificação dos produtos selecionados.
Verifique se o disco no qual você está fazendo a instalação tem espaço livre suficiente para atender os requisitos da instalação.
Instalar a partir de
Este é o diretório de onde você está instalando o SolidWorks.
Esta opção é exibida somente quando a opção Somente instalação foi selecionada. Para obter detalhes, consulte Opções de download.
Consulte o administrador do seu sistema antes de alterar qualquer local de instalação do SolidWorks.

Local da Imagem Administrativa

Quando você cria uma imagem administrativa, aplicam-se as seguintes opções:
Local da nova imagem
É o local do diretório no qual o Gerenciador de Instalação do SolidWorks criará a nova imagem.
Este local não pode conter uma imagem administrativa existente.
Espaço estimado necessário para a criação de imagens
Este é o espaço adicional necessário para a imagem administrativa.
Verifique se o disco no qual você está fazendo a instalação tem espaço livre suficiente para atender os requisitos da imagem.
Criar imagem a partir de
Este é o diretório de onde você está instalando produtos SolidWorks.
Esta opção é exibida somente quando a opção Somente instalação foi selecionada. Para obter detalhes, consulte Opções de download.
Local da imagem existente
Quando atualizar uma imagem administrativa existente, o Gerenciador de Instalação do SolidWorks cria uma nova imagem com base nas configurações da imagem existente. A imagem original não é modificada. O local indicado é o local que você especificou para a imagem original na tela Bem-vindo.

Evite usar caminhos de diretórios específicos da versão

Se você especificar um número de versão em um local de diretório de instalação (por exemplo, C:\Arquivos de programas\SolidWorks Corp\SolidWorks 2010\) e depois atualizar essa instalação para o SolidWorks 2011, o diretório de instalação do SolidWorks 2011 será nomeado como SolidWorks 2010.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Opções de atualização de software

Uma ou mais versões principais mais antigas do SolidWorks estão atualmente instaladas neste computador. Escolha entre atualizar a versão existente mais recente com a nova versão ou criar um nova instalação para a nova versão.

Essa opção só é exibida se nenhuma versão anterior dessa versão principal estiver instalada neste computador. Se uma versão anterior dessa versão principal estiver instalada, o Gerenciador de Instalação do SolidWorks sempre atualiza esta instalação

(a partir do SolidWorks 2010, as instalações paralelas de vários Service Pack da mesma versão principal não têm mais suporte).

Na atualização:
  • Todos os produtos especificados são atualizados.
  • Todos os produtos instalados são selecionados por padrão.
  • Se você desmarcar um produto, ele não será atualizado.
    Se desmarcar um componente do produto, você não estará especificando que o Gerenciador de Instalação do SolidWorks remova esse componente. Para remover o componente de um produto, utilize a opção Adicionar/Remover programas, como descrito em Remover uma instalação.

Selecione a opção adequada e clique em Avançar para continuar.

Criar uma nova instalação do SolidWorks versão.

Selecionar essa opção preserva a instalação da versão principal antiga e cria uma nova instalação para a nova versão principal.

Isso pode ser útil se você quer ter acesso à versão antiga do SolidWorks, mesmo depois de instalar a versão mais nova. Por exemplo, se você compartilha arquivos com usuários que ainda usam a versão antiga, você pode evitar a incompatibilidade de versão com os arquivos salvos na nova versão.

Atualizar o SolidWorks versão_principal_anterior para o SolidWorks versão_principal_atual.

Selecionar essa opção atualiza a instalação da versão antiga com a versão mais recente.
Quando a instalação estiver concluída, a versão antiga do SolidWorks não estará mais disponível neste computador.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Progresso da Instalação

Esta tela mostra o andamento da instalação.

Para cancelar a instalação depois de começada, clique em Cancelar.

Para conhecer as conseqüências do cancelamento e as instruções para concluir instalações interrompidas, consulte Erros de instalação.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Tipo de instalao

Especifique a operao de instalao que voc gostaria de executar, como, por exemplo, criao de uma nova instalao, modificao ou reparo de uma instalao existente, criao de uma imagem administrativa, instalao de produtos de servidor administrativo ou a realizao de downloads de arquivos sem a necessidade de instalao.

Individual

Instala os produtos SolidWorks neste computador.

Esta opo s exibida se esta verso ainda no foi instalada neste computador.

Modificar a instalao individual

Modificar a instalao do SolidWorks existente neste computador.

Esta opo s exibida se esta verso j foi instalada neste computador.
As modificaes so as seguintes:
  • Adicionar ou remover componentes do produto SolidWorks
  • Mudar para outro pacote SolidWorks (por exemplo, SolidWorks Professional, SolidWorks Premium, etc.)
  • Mudar a configurao do nmero de srie do SolidWorks
    Se voc j especificou um nmero de srie do SolidWorks durante uma instalao anterior, o Gerenciador de Instalao do SolidWorks no o solicitar novamente. Para mudar o nmero de srie definido pelo Gerenciador de Instalao do SolidWorks, voc deve selecionar essa opo.

Reparar a instalao individual

Reparar a instalao do SolidWorks existente neste computador.

Esta opo s exibida se esta verso j foi instalada neste computador.
A reparao verifica se todos os arquivos esto presentes e registrados corretamente e repara qualquer problema encontrado. Os dados que voc criou no so afetados.
  • Para reparar um produto, certifique-se que ele est selecionado.
  • Desmarque as caixas de seleo dos produtos que voc no quer reparar.
Voc pode reparar uma instalao individual. Entretanto, no pode reparar uma instalao de imagem administrativa; necessrio reinstalar usando a imagem administrativa.

Imagem administrativa

Criar ou atualizar uma imagem administrativa neste computador.

Voc pode usar uma imagem administrativa para executar a instalao em vrios computadores. Para obter detalhes sobre como instalar o SolidWorks em vrios clientes usando imagens administrativas, consulte Uso de Imagens administrativas.

Quando criar ou atualizar imagens administrativas:
  • Voc pode usar as configuraes de instalao de uma imagem existente para configurar a imagem nova ou atualizada, ou usar as configuraes predeterminadas de instalao do default SolidWorks.
  • Se voc est atualizando uma imagem existente:
    • O Gerenciador de Instalao do SolidWorks cria uma nova cpia da imagem, mesmo se voc estiver atualizando. A imagem original no modificada.
    • Voc pode criar a imagem atualizada usando arquivos da imagem existente que voc est atualizando. Isso resulta em um download menor.
    Se voc no especificar uma imagem para a qual est disponvel um Service Pack de atualizao, no poder aproveitar o download menor.
  • Voc pode criar uma imagem administrativa de 32 bits e uma imagem de 64 bits neste computador. Caso contrrio, somente a imagem que corresponde arquitetura do hardware deste computador ser criada.
    Se voc especificar a criao de ambas imagens, de 32 e de 64 bits, a mdia de instalao do SolidWorks para ambas as arquiteturas ser necessria para concluir a instalao.

Produtos de Servidor

Os produtos de servidor administrativo do SolidWorks incluem o Servidor do Workgroup PDM (vault) e o SolidNetWork License Manager da SolidWorks.

Para obter detalhes sobre esses produtos, consulte:
  • Workgroup PDM
  • Administração de licenças usando o SolidNetWork License Manager

Somente download

Fazer o download dos arquivos de instalao para os produtos SolidWorks selecionados sem instal-los.

Esta opo no fica disponvel quando a instalao feita a partir de um DVD.

O contedo dos arquivos obtidos por download o mesmo dos arquivos que esto disponveis no DVD de instalao do SolidWorks. Selecione esta opo para carregar por download o conjunto completo dos arquivos de instalao, sem considerar quais arquivos podem j estar instalados no seu computador.

Voc pode usar este mtodo para configurar um servidor do qual seus usurios podem executar instalaes. Isso diferente de criar uma imagem administrativa.

Instalando a arquitetura do SolidWorks incorreta para este computador

Se voc est tentando instalar usando a mdia de instalao do SolidWorks incorreta pra a arquitetura deste computador (por exemplo, se voc est tentando instalar o SolidWorks de 64 bits em um computador de 32 bits) este painel de instalao indicar o problema.

Para continuar a instalao:
  1. Cancele essa sesso do Gerenciador de Instalao do SolidWorks.
  2. Verifique a arquitetura e os requisitos do sistema deste computador.
  3. Reinstale usando a mdia de instalao do SolidWorks correta para a arquitetura deste computador.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Download manual

Você optou por fazer o download dos arquivos de modo manual (ou pode ter escolhido fazer o download de modo manual na última vez em que executou o Gerenciador de Instalação do SolidWorks).

Clique no link para abrir uma página da web gerada automaticamente e que contém uma lista completa dos arquivos necessários para concluir seu download.

Você deve fazer o download na pasta especificada na página de Resumo. A instalação não pode começar até que todos os arquivos sejam carregados nessa pasta.

Ao concluir os downloads manuais, clique em Avançar para continuar.

Se quiser fazer o download automaticamente, você pode alterar a opção acessando a página de Resumo e alterando as Opções de download.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Versão mais recente disponível

O Gerenciador de Instalação detectou uma versão mais recente de produtos SolidWorks. Você pode optar por instalar a versão contida no DVD ou download da instalação original ou fazer o download e instalar a versão mais recente.

Se estiver fazendo a instalação a partir de um DVD

Em Gostaria de usar a versão mais recente?, selecione uma das seguintes opções:
  • Não, continuar a instalação versão a partir deste DVD. Você pode atualizar posteriormente, com um download menor.

    Selecione essa opção para continuar a instalação usando o Gerenciador de Instalação atual.

    Quando a instalação estiver concluída, você pode verificar se há atualizações usando o Gerenciador de Instalação. Para verificar se há atualizações, execute Iniciar > Gerenciador de Instalação do SolidWorks > Verificar atualizações.

    A vantagem desse método é que o volume do download é menor. As desvantagens são que esse processo tem duas etapas e os arquivos que você carrega são de uma versão específica (e não podem ser compartilhados com outros usuários que usam versões diferentes).

  • Sim, instale usando este DVD, depois faça o download e atualize para versão.

    Selecione essa opção para fazer o download e executar uma versão posterior do Gerenciador de Instalação para instalar os produtos SolidWorks dessa versão.

    Se uma pequena nova versão do Service Pack estiver disponível para atualizar a versão do DVD, o Gerenciador de Instalação primeiro instala a versão original a partir do DVD e, depois, aplica a atualização do Service Pack. Isso gera um download menor.

    Você pode obter o mesmo resultado selecionando a opção para continuar instalando a partir do DVD e aplicar a atualização mais tarde.

    A vantagem dessa opção é que ela é um processo de uma única etapa.

Na maioria dos casos, instalar a versão completa a partir do DVD e depois usar o Gerenciador de Instalação para verificar se há atualizações e instalá-las é preferível porque requer downloads menores.

Se estiver fazendo a instalação a partir de um download

Selecione um dos seguintes:
  • Continuar instalando versão.

    Selecione essa opção para continuar instalando a versão contida no download inicial.

  • Fazer o download e instalar uma nova versão: versão

    Selecione essa opção para fazer o download da nova versão e instalá-la. Se houver várias novas versões disponíveis, você pode selecionar a versão que quer carregar e instalar.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Processos detectados

O Gerenciador de Instalação do SolidWorks detectou processos neste computador que podem impedir uma instalação bem-sucedida.

  • Para continuar a instalação, siga um destes procedimentos:
    • Encerre esses processos (por exemplo, usando o Gerenciador de Tarefas do Microsoft Windows) e pressione Repetir.
    • Clique em Ignorar para continuar sem ter de encerrar os processos.
  • Para interromper a instalação, pressione Cancelar.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Seleção do produto

Especifique os componentes dos produtos a serem instalados, modificados, carregados ou removidos.

Na lista de produtos:
  • Esta é a lista completa dos produtos que estão disponíveis no pacote especificado acima da lista.
  • Para visualizar a ação projetada para um componente específico, clique no nome do componente (mas não na caixa de seleção). A ação de instalação pretendida é exibida no campo de informação, abaixo da lista de produtos.
  • Você pode clicar na caixa de seleção próxima ao componente de produto para alterar a respectiva ação de instalação. (Por exemplo, se você estiver instalando ou removendo componentes, marcar a caixa de seleção especificará que o componente deverá ser instalado ou removido e desmarcar a caixa de seleção especificará que o componente não deverá ser instalado ou removido.)
  • Se você está realizando uma instalação de Modificação, um asterisco (*) é exibido à esquerda dos componentes quando você faz alguma alteração na seleção do produto.
  • Se um componente contiver subcomponentes de instalação opcional, um ícone + aparecerá próximo ao componente. Para ver os subcomponentes disponíveis para um componente, clique no ícone + .
  • Se um componente tiver sido expandido para mostrar seus subcomponentes opcionais, um ícone - aparecerá próximo ao componente. Para recolher a lista de subcomponentes, clique no ícone - .

Se você está aplicando um Service Pack, os recursos do SolidWorks que são exibidos sob o SolidWorks (por exemplo o FeatureWorks), não podem ser selecionados. Isso ocorre porque você não pode adicionar ou remover recursos quando executa este tipo de atualização.

As ações executadas pelo Gerenciador de Instalação do SolidWorks são controladas por um conjunto de regras de coexistência de produtos Para obter detalhes, consulte Regras de coexistência de produtos.

O Gerenciador de Instalação do SolidWorks seleciona esses componentes de produtos de forma predeterminada:
  • Se você está fazendo uma atualização ou uma atualização de Service Pack, o Gerenciador de Instalação do SolidWorks seleciona os produtos instalados atualmente.
  • Caso contrário, o Gerenciador de Instalação do SolidWorks seleciona todos os produtos aos quais você tem direito.
Para reduzir o tempo de instalação ou de download e os requisitos de espaço em disco, expanda os componentes dos produtos e desmarque a caixa de seleção dos componentes de que não precisa.

Se o Gerenciador de Instalação do SolidWorks não puder verificar a que produtos você tem direito, você poderá clicar em Selecionar diferentes pacotes ou produtos para alterar a lista de pacotes de produtos (como o SolidWorks Professional ou o SolidWorks Premium) a instalar ou modificar. O Gerenciador de Instalação do SolidWorks listará na sua mídia de instalação todos os produtos SolidWorks que são compatíveis com o pacote que você selecionar. Você pode selecionar quaisquer produtos que adquiriu ou que está qualificado para avaliar.

Pesquisa do SolidWorks

O produto Pesquisa do SolidWorks fornece uma potente e completa pesquisa de texto em documentos do SolidWorks, no vault do Workgroup PDM e no 3D ContentCentral. Ele exibe o local, o nome e uma visualização do arquivo.

Depois de instalada, a Pesquisa do SolidWorks indexa os documentos do SolidWorks para tornar as pesquisas mais rápidas. Por padrão, somente os arquivos do SolidWorks são indexados.

A instalação da Pesquisa do SolidWorks instala automaticamente o Windows Desktop Search se ele ainda não estiver instalado no seu computador.

Suporte de idioma

Expanda o produto SolidWorks e o componente Idiomas para ver os idiomas que você pode instalar.

A especificação Idiomas, somente no produto SolidWorks, limita os idiomas que são instalados. As instalações de outros produtos não são afetadas por essa especificação. Por exemplo, para o SolidWorks eDrawings®, o SolidWorks Workgroup PDM, e o SolidWorks Explorer todos os idiomas são instalados.

Espaço necessário

O Gerenciador de Instalação do SolidWorks informa o tamanho total da instalação ou do download na base da tela.

  • Se você selecionou a opção Somente download, tamanho do download é exibido. O tamanho do download é o espaço total em disco necessário para todos os arquivos carregados (sem incluir o espaço adicional necessário para descompactar os arquivos após o download). Este valor é relativo.
    Todos os arquivos necessários para a instalação são incluídos no tamanho total do download. Se alguns arquivos já tiverem sido carregados para a pasta de download atual, eles não serão carregados novamente. Desta forma, o tamanho real do download pode ser menor que o tamanho total mostrado, ou você pode não precisar fazer o download de nenhum arquivo.
  • Caso contrário, é exibido o tamanho da instalação. O tamanho da instalação é a diferença do espaço em disco utilizado após concluída a instalação. Devido à compactação de arquivos, estes números são estimados.

    Se você estiver atualizando ou removendo uma instalação existente, o tamanho da instalação pode ser zero.

    O número mostrado não inclui nenhum espaço necessário para o download ou a extração de arquivos, se isso for necessário para a instalação.

    Se forem necessários downloads e você estiver carregando os arquivos na mesma unidade de disco, os requisitos reais de espaço podem ser significativamente maiores que o tamanho da instalação que é exibido.

    Para reduzir o tempo de download ou instalação para futuras atualizações ou correções, não exclua os arquivos carregados depois de concluir a instalação. As atualizações e correções posteriores normalmente requerem o acesso ao conjunto de arquivos da última instalação completa.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Produtos para download

Selecione os produtos SolidWorks para fazer seu download em um local especificado.

Os produtos disponíveis são determinados pelo número de série que você forneceu:

  • A ação a ser executada para cada componente aparece à direita de cada item.
  • Se um componente contiver subcomponentes de instalação opcional, um ícone + aparecerá próximo ao componente. Para ver os subcomponentes disponíveis para um componente, clique no ícone + .
  • Se um componente tiver sido expandido para mostrar seus subcomponentes opcionais, um ícone - aparecerá próximo ao componente. Para recolher a lista de subcomponentes, clique no ícone - .
  • Clique na caixa de seleção à esquerda de cada componente para selecionar como ele deve ser tratado pelo Gerenciador de Instalação do SolidWorks.
O Gerenciador de Instalação do SolidWorks faz o download de todos os componentes dos produtos aos quais você tem direito, a menos que você especifique algo diferente. Para reduzir o tempo do download e os requisitos de espaço em disco, expanda os componentes dos produtos e selecione os componentes que você não precisa.

Se o Gerenciador de Instalação do SolidWorks não puder verificar a que produtos você tem direito, você poderá selecionar um pacote do SolidWorks para o download. O Gerenciador de Instalação do SolidWorks listará todos os produtos SolidWorks compatíveis com o pacote que você selecionar.

Se o Gerenciador de Instalação do SolidWorks não puder verificar a que produtos você tem direito, você poderá clicar em Selecionar diferentes pacotes ou produtos para alterar a lista de pacotes de produtos (como o SolidWorks Professional ou o SolidWorks Premium) a instalar ou modificar. O Gerenciador de Instalação do SolidWorks listará na sua mídia de instalação todos os produtos SolidWorks que são compatíveis com o pacote que você selecionar. Você pode selecionar quaisquer produtos que adquiriu ou que está qualificado para avaliar.

Suporte de idioma

A especificação Idiomas, somente no produto SolidWorks, limita os idiomas que são instalados. As instalações de outros produtos não são afetadas por essa especificação. Por exemplo, para o SolidWorks eDrawings®, o SolidWorks Workgroup PDM, e o SolidWorks Explorer todos os idiomas são instalados.

Espaço necessário

Com base nos produtos que você selecionar, o espaço necessário para executar o download é indicado. O tamanho do download é o espaço total em disco necessário para todos os arquivos carregados (sem incluir o espaço adicional necessário para descompactar os arquivos após o download). Este valor é relativo.

Para reduzir o tempo do download ou da instalação de futuras atualizações ou correções, não exclua os arquivos carregados depois de concluir a instalação. As atualizações e correções posteriores normalmente requerem o acesso ao conjunto de arquivos da última instalação completa.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Produtos a reparar

Quando você especifica Reparar esta instalação, essa tela mostra os produtos SolidWorks, e seus números de versão, que podem ser reparados por esta versão do Gerenciador de Instalação do SolidWorks.

A reparação verifica se todos os arquivos estão presentes e registrados corretamente e repara qualquer problema encontrado. Os dados que você criou não são afetados.
  • Para reparar um produto, certifique-se que ele está selecionado.
  • Desmarque as caixas de seleção dos produtos que você não quer reparar.

Clique em Reparar para começar a reparar os produtos selecionados.

Você pode reparar uma instalação individual. Entretanto, você não pode reparar uma instalação de imagem administrativa; é necessário reinstalar a imagem administrativa.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Números de série

Os números de série, que se encontram na caixa em que o produto é distribuído, associa seu computador aos produtos SolidWorks que você adquiriu.

Se os produtos SolidWorks já estão instalados no seu computador, seus números de série são exibidos como valores predeterminados.
  • Se o seu número de série do SolidWorks não for exibido, digite-o.
  • Se você possui números de série de produtos que não estão incluídos na sua licença do SolidWorks, clique na entrada do produto abaixo de Você tem outros números de série? e digite o número de série do produto.

Se você tem uma conexão à Internet, os números de série que você fornecer determinarão os produtos aos quais você tem direito no processo de instalação.

Como há várias maneiras de adquirir produtos SolidWorks, alguns números de série podem cobrir dois ou mais produtos. Por exemplo, um número de série do SolidWorks pode permitir que você instale o SolidWorks Simulation sem inserir um número de série separado para o SolidWorks Simulation. Além disso, alguns produtos não requerem um número de série. Se tiver dúvidas sobre seus números de série, consulte seu VAR.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Instalação de servidor

Os produtos de servidor que você está tentando instalar são listados, juntamente com os resultados das instalações.

Status de instalação do servidor

As instalações dos produtos de servidor são realizadas por um aplicativo de instalação externo. Se não estiver atualmente nesse aplicativo, você deve abri-lo para concluir a instalação.

Clique em Cancelar para interromper as instalações de produtos de servidor.

Instalação do servidor concluída

O aplicativo de instalação externo foi concluído com sucesso.

Clique em Concluir ou em Avançar.
  • Se você estiver instalando outros produtos administrativos (por exemplo, uma imagem administrativa do SolidWorks), a instalação continuará.
  • Se as instalações do produto de servidor eram as únicas operações de instalação, o Gerenciador de Instalação do SolidWorks será encerrado.

Instalação do servidor cancelada ou sem êxito

Se a instalação de um produto de servidor falhou ou foi cancelada depois de ter começado, os servidores que não foram instalados são listados.

Clique em Fechar ou em Avançar.
  • Se você especificou outras instalações de produtos administrativos, o Gerenciador de Instalação do SolidWorks continuará seus procedimentos.
  • Se as instalações do produto de servidor eram as únicas operações de instalação, o Gerenciador de Instalação do SolidWorks será encerrado.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


SolidNetWork License Manager

Especifique as opções de instalação para o produto de servidor SolidNetWork License Manager.

Números de série

Especifique os números de série do SolidNetWork License. Você pode especificar vários números de série separados por vírgulas.
Os números de série do SolidNetWork são diferentes dos números de série do SolidWorks.

Local de instalação

Especifique o local de instalação do SolidNetWork License Manager.

Se se tratar de uma atualização de um SolidNetWork License Manager, instale-o no local de instalação da versão existente.

Para obter mais informações

Para obter detalhes de instalação, configuração e uso do SolidNetWork License Manager, consulte Administração de licenças usando o SolidNetWork License Manager.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Resumo

O Gerenciador de Instalação do SolidWorks tem todas as informações necessárias para concluir a operação de instalação.

Para continuar: | Clique no botão ação Agora para iniciar a operação de instalação (por exemplo, Instalar agora, Criar agora, Fazer o download agora, Modificar agora).
Para alterar as configurações de instalação: | Clique em ALTERAR [image] na seção que deseja mudar (por exemplo, Produtos, Local de instalação, Opções do Toolbox).
Para cancelar: | Clique em Cancelar [image] para sair do Gerenciador de Instalação do SolidWorks sem alterar os componentes de instalação.
Para voltar a uma página anterior: | Clique em Voltar [image] para retornar a uma página anterior do Gerenciador de Instalação do SolidWorks.
Para obter informações sobre um conjunto específico de opções de instalação (por exemplo, Produtos, Local de instalação, Opções do toolbox, etc.):
  1. Clique em ALTERAR [image] próximo à seção sobre a qual deseja obter informações.
  2. Na página de detalhe exibida, clique em Ajuda [image] para obter informações sobre as configurações de opção de instalação.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Avisos de verificação do sistema

A verificação do sistema relatou problemas que podem afetar a maneira como você continua a instalação. Na maioria dos casos, você deve poder continuar com o Gerenciador de Instalação do SolidWorks.

Os avisos que você encontra neste estágio estão listado abaixo, com sugestões sobre como prosseguir.

Problemas de validação do número de série
O Gerenciador de Instalação não pôde verificar se há novas versões porque não pôde validar seu número de série. Se você está conectado e inseriu um número de série válido, isso pode indicar um problema temporário em nosso servidor. Tente novamente mais tarde.

Validação do número de série: O Gerenciador de Instalação não pôde validar seu número de série para determinar quais produtos você tem direito de instalar. Você ainda poderá escolher os produtos que quer instalar, mas não poderá fazer o download dos arquivos de instalação. Você terá que fornecer um conjunto completo de arquivos de origem de download ou um DVD a partir de onde executar a instalação.

Resolução:
  • Verifique a conexão com a internet. A verificação do número de série exige uma conexão válida com a internet.
  • Verifique se o número de série informado é válido para os produtos que você está tentando instalar.
  • Algumas instalações exigem que você tenha uma assinatura válida que estava ativa no momento em que a versão foi lançada. Para obter detalhes, consulte seu revendedor SolidWorks.
  • Na maioria dos casos, você pode prosseguir com a instalação desde que esteja instalando a partir de um DVD ou de um conjunto de arquivos carregado previamente.
Versão mais recente disponível
Versão mais recente disponível

Novas versões disponíveis

Uma versão mais nova deste produto está disponível para download.

Resolução: Ao executar a operação Verificar atualizações, a instalação pode perguntar se você deseja instalar uma versão posterior disponível por meio de download da SolidWorks. Você pode continuar essa operação usando a versão que especificou inicialmente ou pode fazer o download da versão mais nova e prosseguir com ela.

Versão mais recente disponível
Esta é a versão mais recente disponível. Clique em Avançar para continuar.

Nenhum novo download disponível

Resolução: Essa mensagem pode aparecer quando você estiver verificando a existência de atualizações durante uma instalação ou modificação. Ela indica que você está instalando (ou já instalou) a versão mais recente disponível.

Problemas de conexão com a internet
Conexão com a internet: O Gerenciador de Instalação não pôde se conectar ao servidor SolidWorks para determinar quais produtos você tem direito de instalar. Você ainda poderá escolher os produtos que quer instalar, mas não poderá fazer o download dos arquivos de instalação. Você terá que fornecer os arquivos de origem em um DVD ou um conjunto de arquivos carregados anteriormente.

Não é possível verificar se há novas versões

O Gerenciador de Instalação não pôde verificar se há novas versões porque não pode se conectar ao servidor.

Resolução:
  • Verifique a conexão com a internet.
  • Você pode prosseguir com a instalação, desde que esteja instalando a partir de um DVD ou de um conjunto de arquivos carregado previamente.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Opções do Assistente de Perfuração/Toolbox

Se o SolidWorks Toolbox for instalado, o SolidWorks inclui uma biblioteca de tipos padrão de furos e ferragens.

Para mais detalhes sobre configuração, extensão e uso do SolidWorks Toolbox, clique em Ajuda > Ajuda do Toolbox no SolidWorks.
Para ver essa Ajuda, você pode ter que ativar o suplemento Toolbox, usando Ferramentas > Suplementos.

Antes de usar o SolidWorks Toolbox, certifique-se de que ele está configurado corretamente de acordo com as políticas da sua empresa ou grupo. Em muitos casos, um grupo de usuários configura e mantém uma instalação central do Toolbox. Consulte o administrador do SolidWorks para obter uma orientação sobre como especificar o Toolbox durante a instalação do SolidWorks.

Você pode alterar o SolidWorks Toolbox selecionado depois de concluir a instalação. No SolidWorks, clique em Ferramentas > Opções. Na guia Opções do sistema, clique em Assistente de Perfuração/Toolbox.

As seções seguintes descrevem todas as opções que você pode encontrar nessa tela, para todas as configurações. As opções reais do Toolbox que você vê dependem das configurações pré-existentes do SolidWorks e do Toolbox neste computador e das opções do Gerenciador de Instalação do SolidWorks que você especificou até agora.

Criar um novo Toolbox nova-versão

Crie uma nova versão do SolidWorks Toolbox neste computador.

Ao criar uma nova versão, na tela Seleção do produto, expanda SolidWorks > SolidWorks Toolbox e selecione quais padrões serão suportados pelo Toolbox. Todos os padrões são selecionados por padrão.

Quaisquer Toolboxes existentes neste computador não são modificados.

Referência a ou atualização de um toolbox existente

Usar um Toolbox existente. Clique em Procurar para especificar o local do Toolbox que você quer usar com esta instalação.

  • Se o Toolbox estiver configurado pra uma versão principal anterior do SolidWorks, ele será atualizado com esta versão. Qualquer personalização feitas nesse Toolbox é preservada no Toolbox atualizado.
    Atualizar uma instalação do Toolbox com uma nova versão principal do SolidWorks torna esse Toolbox incompatível com os computadores que executam versões principais anteriores do SolidWorks.
  • Se o Toolbox estiver configurado para esta versão do SolidWorks (como pode ser o caso se você especificar um Toolbox compartilhado na rede que já foi atualizado), ele não será atualizado.
  • Se você estiver atualizando um Toolbox em um ambiente do Enterprise PDM, são necessários procedimentos adicionais. Para obter detalhes, consulte Atualizar o Toolbox em um ambiente do SolidWorks Enterprise PDM.

Esta opção é exibida em todos os cenários de instalação, exceto quando é criada uma imagem administrativa.

Atualizar um Toolbox versão-anterior

Copie um Toolbox configurado de uma versão principal anterior em um novo local e atualize essa cópia para a nova versão.

Esta opção é exibida quando há uma versão principal anterior do SolidWorks já instalada no computador, mas você optou por não atualizar essa instalação para a versão mais recente.
O propósito desta opção é atualizar o Toolbox para uma versão principal anterior do SolidWorks que já está instalada, sem afetar os usuários que estão trabalhando com a versão anterior do Toolbox.

Se você estiver atualizando um Toolbox em um ambiente do Enterprise PDM, são necessários procedimentos adicionais. Para obter detalhes, consulte Atualizar o Toolbox em um ambiente do SolidWorks Enterprise PDM.

Atualizar o Toolbox versão-anterior que já está instalado

Atualiza este Toolbox com a versão mais recente.
Atualizar uma instalação do Toolbox com uma nova versão principal do SolidWorks torna esse Toolbox incompatível com os computadores que executam versões principais anteriores do SolidWorks.

Esta opção é exibida quando você está atualizando uma versão principal anterior do SolidWorks com esta nova versão e foi encontrado no computador um Toolbox configurado para essa versão anterior.

Se você estiver atualizando um Toolbox em um ambiente do Enterprise PDM, são necessários procedimentos adicionais. Para obter detalhes, consulte Atualizar o Toolbox em um ambiente do SolidWorks Enterprise PDM.

Usar o Toolbox versão-atual que já está instalado

O Gerenciador de Instalação do SolidWorks detectou neste computador um Toolbox configurado para esta versão principal do SolidWorks.

Se você selecionar esta opção, o SolidWorks usará o Toolbox que já está instalado. Não ocorrerá nenhuma atualização.

Esta opção é exibida quando uma versão principal anterior do SolidWorks é instalada no computador, mas o Toolbox já está configurado para essa versão. Isso pode ocorrer quando um Toolbox compartilhado é criado em um computador que ainda está executando uma versão anterior do SolidWorks.

Especifique o local do Toolbox para o computador cliente

Especifique um local em um diretório ou na rede como o local predeterminado para o Toolbox quando os clientes fizerem a instalação a partir de uma imagem administrativa.
Se o local contiver um Toolbox configurado para uma versão principal anterior do SolidWorks no momento em que a instalação do cliente ocorrer, o Gerente de Instalação do SolidWorks atualizará o Toolbox.

Esta opção é exibida quando você está criando uma nova imagem administrativa.

Atualizar ou usar o Toolbox referido na imagem existente para o computador cliente

Use o local do Toolbox que foi especificado na imagem administrativa existente que você está atualizando.
Se o local contiver um Toolbox configurado para uma versão principal anterior do SolidWorks no momento em que a instalação do cliente ocorrer, o Gerente de Instalação do SolidWorks atualizará o Toolbox.

Selecione outro local do Toolbox para o computador cliente

Especifique para o Toolbox um local diferente do que foi especificado na imagem administrativa existente que você está atualizando.
Se o local contiver um Toolbox configurado para uma versão principal anterior do SolidWorks no momento em que a instalação do cliente ocorrer, o Gerente de Instalação do SolidWorks atualizará o Toolbox.
  • Notas sobre a configuração do SolidWorks Toolbox
    O SolidWorks Toolbox é um recurso poderoso e complexo. Este tópico resume alguns conceitos a serem considerados antes de configurar um Toolbox usando o Gerenciador de Instalação do SolidWorks.
  • Formato UNC
    O formato de Convenção de Nomeação Uniforme (ou Universal) especifica um formato de sintaxe de nome de arquivo para descrever uma localidade de arquivos compartilhados.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Notas sobre a configuração do SolidWorks Toolbox

O SolidWorks Toolbox é um recurso poderoso e complexo. Este tópico resume alguns conceitos a serem considerados antes de configurar um Toolbox usando o Gerenciador de Instalação do SolidWorks.

Mais informações sobre o SolidWorks Toolbox

Para mais detalhes sobre configuração, extensão e uso do SolidWorks Toolbox, clique em Ajuda > Ajuda do Toolbox no SolidWorks.
Para ver essa Ajuda, você pode ter que ativar o suplemento Toolbox, usando Ferramentas > Suplementos.

Uso de um Toolbox compartilhado

Quando instala o Toolbox, você pode ter os dados do Toolbox no seu computador ou em um local compartilhado da rede. É recomendável armazenar os dados do Toolbox em um local da rede. Usando um local comum, todos os usuários do SolidWorks compartilham um conjunto consistente de informações de componentes de fixação.

Se esta é a primeira instalação, navegue até o novo local compartilhado onde deseja instalar o Toolbox.

Atualizar um Toolbox existente

Atualizar uma instalação do Toolbox com uma nova versão principal do SolidWorks torna esse Toolbox incompatível com os computadores que executam versões principais anteriores do SolidWorks.

Se outros computadores continuam usando versão anterior e precisam do Toolbox configurado para aquela versão, você deve fazer uma cópia daquele Toolbox e atualizar a cópia. A nova instalação do SolidWorks atualizará a cópia do Toolbox e as instalações anteriores do SolidWorks continuarão usando o Toolbox antigo.

Configuração do acesso ao Toolbox

Depois da instalação, quando você acessar os componentes do Toolbox, o SolidWorks verificará como você configurou o Toolbox e fará sugestões para melhorar o acesso e o desempenho.

Para acessar o Toolbox compartilhado na rede (recomendado), use um caminho UNC para o servidor onde o Toolbox compartilhado foi instalado. Para obter detalhes, consulte Formato UNC.

Um administrador pode criar uma senha para o Toolbox e definir permissões e preferências para o grupo de trabalho. A restrição do acesso à configuração e a definição de preferências comuns asseguram dados consistentes do Toolbox.

Atualizar o Toolbox em um ambiente do SolidWorks Enterprise PDM

Antes de atualizar a primeira instalação do SolidWorks que acessa a pasta Toolbox de um vault do Enterprise PDM:
  1. No Windows Explorer, navegue até a pasta do Toolbox no vault do Enterprise PDM.
  2. Clique com o botão direito na pasta do Toolbox e selecione Obter versão mais recente.

    Isso permite que o Gerenciador de Instalação do SolidWorks verifique se as peças precisam ser atualizadas.

  3. Verifique a pasta Toolbox.

    A pasta do Toolbox precisa estar em check-out para que o Gerenciador de Instalação do SolidWorks possa atualizar o Toolbox.

  4. Após a atualização, faça o check-in na pasta do Toolbox.

A Biblioteca do Toolbox no vault agora está atualizada.

Para atualizações subsequentes do SolidWorks, antes de iniciar a atualização, os clientes do Enterprise PDM precisam obter a versão mais recente da pasta do Toolbox no vault (usando Obter a versão mais recente). Isso permite que o Gerenciador de Instalação do SolidWorks verifique se os arquivos estão atualizados.

Para obter mais detalhes sobre a configuração do Toolbox no SolidWorks Enterprise PDM, consulte Configurar o Toolbox na Ajuda da Ferramenta de Administração do SolidWorks Enterprise PDM.

Tópico pai: Opções do Assistente de Perfuração/Toolbox


Formato UNC

O formato de Convenção de Nomeação Uniforme (ou Universal) especifica um formato de sintaxe de nome de arquivo para descrever uma localidade de arquivos compartilhados.

\\servidor\volume\caminho

Por exemplo:

\\Disco_do_Servidor\SolidWorks\AdminImage

Tópico pai: Opções do Assistente de Perfuração/Toolbox


Desinstalação de produtos

Quando você seleciona Remover ou Desinstalar no Painel de controle, essa tela exibe os produtos SolidWorks (com seus números de versão) que podem ser desinstalados por essa versão do Gerenciador de instalação do SolidWorks. Você pode optar por executar uma desinstalação padrão, personalizada ou completa.

A desinstalação padrão remove arquivos e pastas de programa de um produto SolidWorks. Por padrão, todos os produtos SolidWorks da versão selecionada são marcados para desinstalação padrão.

Uma desinstalação padrão remove um ou mais dos seguintes itens: Arquivos e pastas do programa, chaves de registro, como o SolidWorks Toolbox, e arquivos e pastas do local de download original.

Uma desinstalação completa remove os diretórios de instalação, chaves de registro e pastas de dados.

Para desinstalar um produto:
  1. Na tela Desinstalar, verifique se o produto está selecionado.

    Se você desinstalar todos os produtos, o Gerenciador de instalação do Solidworks também é desinstalado.

  2. Desmarque os produtos que você não quer remover.

    Se você mantiver algum produto, o Gerenciador de instalação do SolidWorks não será removido.

  3. Escolha entre executar uma desinstalação personalizada ou completa.
    1. Clique em Alterar em Opções avançadas.

      A caixa de diálogo Opções avançadas é aberta. A opção Arquivos e pastas do programa está marcada.

    2. Selecione uma ou mais opções para executar uma desinstalação personalizada ou selecione todas as opções para executar uma desinstalação completa.
    3. Clique em Voltar ao resumo.
    4. Na tela Resumo, expanda Opções avançadas para exibir o método de desinstalação e as entradas.
  4. Clique em Remover itens [image].
Quando você clica em Remover itens, o Gerenciador de Instalação do SolidWorks começa a remover os produtos imediatamente.
Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Opções do Servidor do Workgroup PDM

Especifique opções de instalação para o produto de servidor SolidWorks Workgroup PDM.

Local de instalação

Especifique o local de instalação dos produtos de servidor Workgroup PDM.

Produtos a instalar

Especifique os produtos de servidor Workgroup PDM que devem ser instalados:
Vault do Workgroup PDM
Especifique o local dos dados do Vault do Workgroup PDM. Uma licença do Visualizador do Workgroup PDM precisa estar instalada com o vault para ativar o visualizador.
Workgroup PDM Viewer
Ao instalar o Workgroup PDM Viewer, especifique o nome ou o endereço IP do computador Vault do Workgroup PDM a ser acessado pelo Viewer.
API do Workgroup PDM

Uma licença para a API do Workgroup PDM é incluída com as licenças dos clientes SolidWorks e Explorer. O check-in de APIs requer licenças de cliente.

Para obter mais informações

Para obter os detalhes da instalação do Workgroup PDM, consulte Workgroup PDM.

Para obter detalhes de utilização do Workgroup PDM, consulte Workgroup PDM na Ajuda do SolidWorks.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Avisos legais

© 1995-2011, Dassault Systèmes SolidWorks Corporation, uma empresa da Dassault Systèmes S.A., 175 Wyman Street, Waltham, Massachusetts, 02451 EUA. Todos os direitos reservados.

As informações e o software discutidos neste documento estão sujeitos a modificações sem aviso e não constituem compromissos da Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

Nenhum material pode ser reproduzido ou transmitido sob qualquer forma ou por qualquer meio, eletrônico ou mecânico, para qualquer finalidade, sem a expressa permissão por escrito da DS SolidWorks.

O software discutido neste documento é fornecido sob licença e poderá ser utilizado ou copiado apenas de acordo com os termos da licença. Todas as garantias fornecidas pela DS SolidWorks referentes a software e documentação estão estabelecidas no Contrato de Licença, e nada que estiver declarado ou implícito neste documento ou seu conteúdo deve ser considerado ou julgado como modificações ou alterações de quaisquer termos, incluindo as garantias, do contrato de licença.

Avisos de patentes

O programa de CAD mecânico SolidWorks® 3D está protegido pelas patentes norte-americanas 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 e por patentes estrangeiras (p.ex., EP 1,116,190 e JP 3,517,643).

O software eDrawings® é protegido pelas patentes americanas 7.184.044 e 7.502.027, e pela patente canadense 2.318.706.

Patentes pendentes nos EUA e no exterior.

Marcas comerciais e nomes de produtos dos produtos e servidos SolidWorks

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings e o logotipo eDrawings são marcas comerciais registradas da DS SolidWorks, e FeatureManager é uma marca registrada de co-propriedade da DS SolidWorks.

CircuitWorks, FloXpress, TolAnalyst e XchangeWorks são marcas comerciais da DS SolidWorks.

FeatureWorks é marca comercial registrada da Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Workgroup PDM, SolidWorks Simulation, SolidWorks Flow Simulation, eDrawings Professional, e SolidWorks Sustainability são nome de produtos da DS SolidWorks.

Outras marcas ou nomes de produtos são marcas comerciais ou registradas de seus respectivos proprietários.

SOFTWARE PARA COMPUTADOR COMERCIAL - PROPRIETÁRIO

O Software é um “item comercial” segundo a definição do termo em 48 C.F.R. 2.101 (OUT 1995), consistindo em “software comercial para computador” e “documentação de software comercial” conforme a utilização dos termos em 48 C.F.R. 12.212 (SET 1995), sendo fornecido ao Governo dos EUA (a) para aquisição por órgãos civis ou em seus respectivos nomes, em conformidade com as políticas estabelecidas em 48 C.F.R. 12.212; ou (b) para aquisição por unidades do departamento de Defesa dos EUA ou em seus respectivos nomes, em conformidade com as políticas estabelecidas em 48 C.F.R. 227.7202-1 (JUN 1995) e 227.7202-4 (JUN 1995).

Na eventualidade de receber uma solicitação de qualquer agência do Governo dos EUA para fornecer o Software com direitos além daqueles estabelecidos acima, você deverá notificar a DS SolidWorks sobre o escopo da solicitação e a SolidWorks terá cinco (5) dias úteis para, segundo seu exclusivo critério, aceitar ou rejeitar tal solicitação. Contratante/fabricante: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 EUA.

Avisos sobre direitos autorais dos produtos SolidWorks Standard, Premium, Professional e Education

Partes deste software © 1986-2011 Siemens Product Lifecycle Management Software Inc. Todos os direitos reservados.

Este trabalho contém os seguintes programas de computador de propriedade da Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Todos os direitos reservados.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. Todos os direitos reservados.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Todos os direitos reservados.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. Todos os direitos reservados.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Todos os direitos reservados.

Partes deste software © 1998-2011 Geometric Ltd.

Partes deste software © 1996-2011 Microsoft Corporation. Todos os direitos reservados.

Partes deste software incorporam o PhysX™ by NVIDIA, 2006-2010.

Partes deste software © 2001-2011 Luxology, LLC. Todos os direitos reservados, patentes pendentes.

Partes deste software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. e seus licenciadores. Todos os direitos reservados. Protegido pelas patentes nos EUA 5.929.866; 5.943.063; 6.289.364; 6.563.502; 6.639.593; 6.754.382; patentes pendentes.

Adobe, o logotipo Adobe, Acrobat, o logotipo Adobe PDF, Distiller e Reader são marcas registradas ou marcas comerciais da Adobe Systems Inc. nos EUA e em outros países.

Para obter mais informações sobre direitos autorais ®, consulte Ajuda do Solidworks > Sobre o SolidWorks.

Avisos sobre direitos autorais dos produtos SolidWorks Simulation

Partes deste software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications e System Integration, Inc. Todos os direitos reservados.

Avisos sobre direitos autorais do produto SolidWorks Enterprise PDM

Outside In® Viewer Technology, © Copyright 1992-2011, Oracle.

© Copyright 2011, Microsoft Corporation. Todos os direitos reservados.

Avisos sobre direitos autorais dos produtos eDrawings

Partes deste software © 2000-2011 Tech Soft 3D.

Partes deste software © 1995-1998 Jean-loup Gailly e Mark Adler

Partes deste software © 1998-2001 3Dconnexion.

Partes deste software © 1998-2011 Open Design Alliance Todos os direitos reservados.

Partes deste software © 1995-2010 Spatial Corporation.

Este software é baseado em parte no trabalho do Independent JPEG Group.


Instalação e gerenciamento em múltiplos computadores

O Gerenciador de Instalação do SolidWorks fornece as seguintes ferramentas para instalar e gerenciar múltiplos computadores com o SolidWorks.

Imagens Administrativas do SolidWorks

Se você está instalando o SolidWorks em múltiplos computadores, pode criar uma imagem administrativa e então distribuir o aplicativo aos outros computadores.

Servidor do Workgroup PDM

O aplicativo Workgroup PDM é um software de gerenciamento de dados de projeto que é executado no ambiente do SolidWorks ou como um aplicativo independente no SolidWorks Explorer. O Workgroup PDM controla projetos com procedimentos para check-out, check-in, controle de revisões e outras tarefas administrativas. Instalar o Workgroup PDM Server cria um vault do Workgroup PDM, que é o banco de dados que armazena os projetos gerenciados do SolidWorks.

SolidNetWork License Manager

O SolidNetWork License Manager permite que o número de usuários exceda o número de licenças, pois torna flutuante o uso das licenças. Quando uma licença de cliente não está sendo usada, ela fica disponível para outro usuário do SolidWorks.

Você pode também usar o SolidNetWork License Manager para distribuir licenças para produtos principais do SolidWorks e seus suplementos (por exemplo, o FeatureWorks).

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks


Nenhuma nova versão disponível

Não há versões mais novas disponíveis para download. Continue instalando a versão especificada.

Para continuar a instalação, clique em Avançar.

Tópico pai: Ajuda do aplicativo Gerenciador de Instalação do SolidWorks