SolidWorks 安裝及系統管理

本指南描述 SolidWorks 產品的單機安裝與多個安裝時的安裝、使用許可、升級與管理。

單機安裝 | 部署多個安裝
安裝 在一台或多台電腦上的安裝。 | 安裝 產生可部署至數台客戶端電腦的管理安裝點。
使用許可 使用許可的啟動或網路授權使用許可。 | 使用許可 使用許可的啟動或網路授權使用許可。
升級 將單機的電腦移動到新的版本。 | 升級 更新用於安裝在電腦上的管理安裝點，將多個電腦移動到新的版本。
管理 修改、修復及移除安裝，升級至新版本。 | 管理 升級管理安裝點和客戶端，網路使用許可管理，Workgroup PDM 資料保險箱管理。

SolidWorks 安裝管理員可以讓您組態 SolidWorks 產品元件的設定，包括 SolidWorks、SolidWorks Toolbox、PhotoView 360、Workgroup PDM 和 SolidWorks SolidNetWork 使用許可管理員。

Workgroup PDM 是在 SolidWorks 內部環境執行的專案資料管理軟體，或作為 SolidWorks Explorer 內部單獨的應用程式。Workgroup PDM 使用取出、存回、修訂版控制的程序及其他系統管理的操作來控制專案。

SolidNetWork 使用許可管理員可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。透過浮動使用許可，可允許使用者的數目超過使用許可的數目。

  • 單機安裝或管理安裝點
    您應該在每部電腦上個別安裝 SolidWorks 產品，還是應該產生一個管理安裝點，然後透過一個命令在所有客戶端上部署安裝呢？
  • 初始化 SolidWorks 安裝
    您可以從載入本機電腦的 DVD、存取共用安裝目錄或是從 SolidWorks 下載以初始化 SolidWorks 安裝。


單機安裝或管理安裝點

您應該在每部電腦上個別安裝 SolidWorks 產品，還是應該產生一個管理安裝點，然後透過一個命令在所有客戶端上部署安裝呢？

如果您僅安裝一台電腦，或如果您管理的是數十台或數百台電腦，應做何種選擇是相當明顯的。對介於兩者之間的情況，請考慮下列的比較。

單機安裝 | 管理安裝點
使用者可以執行自己的 SolidWorks 管理。 | 系統管理員可以使用選項編輯器來自訂多機安裝，指定如產生新安裝或升級現有安裝、以管理員使用者的身分執行安裝、在安裝之前或之後執行外部命令、或指定不同的產品群組等安裝選項。
執行安裝的個人必須實際上可存取電腦。 | 客戶端電腦可處在遠方，只要可從相同的網路存取它們。
您可以在不同的電腦上以獨立的設定安裝不同的版本、service pack 或產品。 | 使用選項編輯器，管理安裝點可以在多機安裝間維持在版本、service pack、產品及設定間的一致性。
應用 service pack 時需要有原始來源媒體 (DVD)。 | 應用 service pack 時不需要媒體磁碟機。
電腦無需位在網路上。 | 需要有本機的網路連線來部署應用程式；在客戶端電腦上不需要媒體磁碟機。
 | 客戶端可自動更新。所有從相同管理安裝點部署的客戶端是在相同的 service pack 上。要維持多個版本，您可以產生多個管理安裝點。
 | 使用許可的啟動可以是自動的。
 | 管理安裝點在伺服器上需要有額外的磁碟空間；客戶端需要有與單機安裝相同的空間。
父主題： SolidWorks 安裝及系統管理


初始化 SolidWorks 安裝

您可以從載入本機電腦的 DVD、存取共用安裝目錄或是從 SolidWorks 下載以初始化 SolidWorks 安裝。

  • 要初始化 SolidWorks 的安裝，請執行下列操作之一：
    • 要從磁碟安裝在本機電腦上，請在電腦的硬碟機中插入適當的磁碟。
    • 要從下載的目錄安裝，請導覽至 目錄然後連按兩下 setup.exe。
    • 從 SolidWorks 下載來安裝：
      1. 瀏覽至 SolidWorks 網站。
      2. 使用您的電子郵件及密碼或您的 SolidWorks 序號來以訂閱服務的客戶身分登入。
      3. 在 Self Service 之下，按 Download Software and Updates。
      4. 在 下載軟體，選擇 選擇要下載的 SolidWorks 版本及 service pack。
父主題： SolidWorks 安裝及系統管理


單機安裝

  • 在個別電腦上安裝
    您可以使用幾種安裝方法將 SolidWorks 安裝在個別電腦上。
  • 單機安裝的管理
    一般而言，單機安裝的管理包括修改、修復、移除與升級安裝。


在個別電腦上安裝

您可以使用幾種安裝方法將 SolidWorks 安裝在個別電腦上。

SolidWorks 安裝管理員會執行安裝，根據您購買的產品執行適當的安裝。在您開始安裝前：

  • 請準備好您的 SolidWorks 序號。
  • 請確認您的 Internet 可正常的連線。
SolidWorks 安裝管理員需要不同的 Microsoft 元件，包括 Microsoft Windows Installer、Office Web Components、Microsoft Visual Studio Tools for Applications 和 .NET Framework。如果電腦中並未安裝所有 Windows 必要元件的正確版本，SolidWorks 安裝管理員會在安裝 SolidWorks 產品前自動安裝這些元件。
安裝方法 程序摘要
使用 SolidWorks 安裝媒體 將正確的 DVD 光碟插入電腦的光碟機中。
SolidWorks 安裝媒體提供不同的 DVD 光碟，可分別進行 32 位元和 64 位元的 Windows 安裝。
使用伺服器上的下載目錄 在下載目錄中，連按兩下 setup.exe。
安裝 SolidWorks 產品的電腦必須要能夠存取下載目錄，同時下載目錄必須包含所有 SolidWorks 安裝檔案，如此安裝才能開始。如果您可以存取網際網路，並且對下載目錄擁有寫入權限，SolidWorks 安裝管理員可以幫助您尋找遺失的檔案。
這不 是 管理安裝點。從管理安裝點安裝客戶端電腦的唯一方法是按一下 SolidWorks 管理員所散佈的 HTML 網頁中的連結。
使用以下方法更新現有的 SolidWorks 安裝 檢查更新 執行下列操作之一︰
  • 在 SolidWorks 中，按一下說明 > 檢查更新。
  • 在 Windows 中，按一下開始 > 所有程式 > SolidWorks 安裝管理員 > 檢查更新。
您必須有可正常運作的網際網路連線。

Workgroup PDM 客戶端會自動偵測 Vault 的更新。您不需要下載 service pack 來更新客戶端。詳細資訊請參閱 Workgroup PDM 線上說明中的更新客戶端。

從 SolidWorks 客戶網站下載。
  1. 瀏覽至 SolidWorks 網站。
  2. 使用您的電子郵件及密碼或您的 SolidWorks 序號來以訂閱服務的客戶身分登入。
  3. 在 Self Service 之下，按 Download Software and Updates。
  4. 在 Download Software 之下，按一下 想要安裝的 SolidWorks 版本。
您必須有可正常運作的網際網路連線。

您必須是訂閱服務的客戶，並且能夠登入 Customer Portal 站台。

當安裝完成時，啟動 SolidWorks 應用程式並啟動使用許可。

父主題： 單機安裝


單機安裝的管理

一般而言，單機安裝的管理包括修改、修復、移除與升級安裝。

  • 修改安裝
    您可以修改一個安裝來安裝未被安裝的產品或移除產品。
  • 修復安裝
    如果您已安裝的 SolidWorks 產品有問題，您可以使用 SolidWorks 安裝管理員來修復安裝。
  • 將單機安裝回溯至之前的 Service Pack
    若要將單機安裝回溯至目前主要版本系統中的前一個 service pack 版本，請解除安裝目前安裝在電腦中的 service pack 版本，然後重新安裝先前的版本。
  • 移除安裝
    您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。
  • 升級至新版本
    有幾種方法可以將單機安裝升級為新的 SolidWorks 版本。
  • 產品共存規則
    這些產品共存規則決定新產品的安裝方式以及現有產品的升級方式。
父主題： 單機安裝


修改安裝

您可以修改一個安裝來安裝未被安裝的產品或移除產品。

如果您安裝 SolidWorks 並在之後購買附加軟體，您可以修改安裝以包括新的附加程式。您必須在個別的機器上安裝附加軟體。

如果您修改您原始的 SolidWorks 套裝軟體來包括 SolidWorks Professional 或 SolidWorks Premium，Workgroup PDM 不會被安裝。
  1. 請確定沒有使用中的 SolidWorks 作業進程。
  2. 在 Windows Vista 或之後的版本中，按一下開始 > 控制台 > 程式與功能。

    對於較早的 Windows 版本，按一下開始 > 控制台 > 新增或移除程式。

  3. 選擇 想要修改的 SolidWorks 安裝，然後按一下變更。
  4. 在歡迎使用 SolidWorks 安裝管理員螢幕中，按一下修改單機安裝 (在此電腦上)。。
  5. 在序號螢幕中，確認已指定正確的序號。
  6. 在產品選擇螢幕中，選擇要安裝或移除的產品。

    修改安裝時：

    • 根據預設，即使您指定了新的序號，仍然不會安裝或移除任何產品。您必須變更每個產品或功能元件的安裝動作。
    • 若要檢視對特定元件的動作，請按一下元件名稱（但不是核取方塊）。預定安裝動作會出現在產品清單下方的資訊欄位中。
    • 您可以按一下產品元件旁邊的核取方塊以變更該元件的安裝目錄。（例如，如果您要安裝或移除元件，選擇核取方塊則指定安裝或移除元件，清除核取方塊則指定不安裝或移除元件。）
    • 當您從初始規格變更元件安裝動作時，在清單中該元件的旁邊會出現一個星號 (*)。
    • 如果元件中具有可選的安裝子元件，+ 圖示將會出現在元件旁邊。要查看元件可用的子元件，請按一下 + 圖示。
    • 如果元件已經展開而顯示子元件，- 圖示將會出現在元件旁邊。要摺疊子元件清單，請按一下 - 圖示。

  7. 在摘要螢幕中，按一下現在修改。
  8. 在安裝完成螢幕中，按一下完成。
父主題： 單機安裝的管理


修復安裝

如果您已安裝的 SolidWorks 產品有問題，您可以使用 SolidWorks 安裝管理員來修復安裝。

您可以修復一個單機安裝。您無法修復一個管理安裝點；您必須解除管理安裝點的安裝然後再次安裝。
  1. 在 Windows Vista 或之後的版本中，按一下開始 > 控制台 > 程式 >程式與功能。

    對於較早的 Windows 版本，按一下開始 > 控制台 > 新增或移除程式。

  2. 選擇您想要修復的 SolidWorks 版本，然後按一下變更。
  3. 在歡迎使用 SolidWorks 安裝管理員螢幕中，按一下修復單機安裝 (在此電腦上)。。
  4. 在要修復的產品 螢幕中，選擇要修復的產品。
  5. 清除在螢幕上的其餘產品。
  6. 按一下修復。
父主題： 單機安裝的管理
父主題： 安裝錯誤/安裝取消


將單機安裝回溯至之前的 Service Pack

若要將單機安裝回溯至目前主要版本系統中的前一個 service pack 版本，請解除安裝目前安裝在電腦中的 service pack 版本，然後重新安裝先前的版本。

父主題： 單機安裝的管理


移除安裝

您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。

  1. 請確定沒有使用中的 SolidWorks 作業進程。
  2. 如果您要將 SolidWorks 的使用許可轉移到另一台電腦上，在移除此電腦的 SolidWorks 安裝之前，先將使用許可轉移到該電腦。

    關於轉移 SolidWorks 使用許可的資訊，請參閱轉移使用許可。

  3. 在 Windows Vista 或之後的版本中，按一下開始 > 控制台 > 程式 >程式與功能。

    對於較早的 Windows 版本，按一下開始 > 控制台 > 新增或移除程式。

  4. 選擇要移除的產品元件。

    在某些情況下，您可能會在提供的主要發行版本中發現有多個 SolidWorks Service Pack 元件。要移除 SolidWorks 的主要版本，請移除該主要版本的所有 Service Pack 元件。

  5. 在解除安裝的螢幕中：
    1. 選擇要移除的產品。根據預設，將會選取所有產品元件。
    2. 清除您不要移除的產品。
    3. 選擇要執行自訂或完整的解除安裝。根據預設，SolidWorks 安裝管理員會執行標準的解除安裝並移除程式檔案與資料夾。

      1. 按一下進階選項中按一下變更。

        進階選項的螢幕出現，已選擇了程式檔案與資料夾的選項。

      2. 選擇一或多個選項來執行自訂的解除安裝，或選擇所有的選項來執行一個完整的解除安裝。
      3. 按一下回到摘要。
      4. 在摘要的螢幕中，展開進階選項來顯示解除安裝的方法與項目。

    4. 按一下移除項目。
父主題： 單機安裝的管理


升級至新版本

有幾種方法可以將單機安裝升級為新的 SolidWorks 版本。

您可以在下列情況升級至一個新的版本：
  • 獲得新的安裝媒體
  • 啟動 SolidWorks 時獲得升級的通知
  • 手動檢查更新
  • 啟動 SolidWorks 安裝管理員的新副本

安裝新的主要版本時，您可以升級先前安裝的主要版本或是安裝類似的新版本。如果您在先前已安裝的主要版本中安裝 Service Pack 版本，該版本會自動更新。

  • 手動檢查更新
    您可以使用以下其中一個方法檢查目前目前安裝的 SolidWorks 是否有更新版本。
  • 升級 Workgroup PDM 客戶端
    當資料保險箱被更新時，Workgroup PDM 客戶端會偵測到。您不需要下載 service pack 來更新客戶端。
  • 升級警告
    可以安裝多個不同主要版本的產品並不永遠支援主要的升級，或不支援以單一操作在主要版本之間升級的能力。
父主題： 單機安裝的管理


手動檢查更新

您可以使用以下其中一個方法檢查目前目前安裝的 SolidWorks 是否有更新版本。

  • 在 SolidWorks 中，按一下說明 > 檢查更新。
  • 在 Microsoft Windows 中，按一下開始 > 所有程式 > SolidWorks 安裝管理員 > 檢查更新。
父主題： 升級至新版本


升級 Workgroup PDM 客戶端

當資料保險箱被更新時，Workgroup PDM 客戶端會偵測到。您不需要下載 service pack 來更新客戶端。

如需說明，請參閱 Workgroup PDM 線上說明中的更新客戶端。

父主題： 升級至新版本
父主題： Workgroup PDM VaultAdmin 管理


升級警告

可以安裝多個不同主要版本的產品並不永遠支援主要的升級，或不支援以單一操作在主要版本之間升級的能力。

在此狀況下，SolidWorks 安裝管理員會先安裝新版本，然後移除舊版本，以模擬升級。此時，核心 SolidWorks 產品支援主要升級，而其他產品則不支援。

此種情形的結果會是：
  • 在主要版本之間升級核心 SolidWorks 產品時：
    • 您現有的安裝位置不會改變。
    • 如果發生了錯誤或您於升級的過程中取消安裝，升級可被回溯。
  • 當其他產品在主要版本之間升級時：
    • 每個產品會先以新產品被安裝至新位置中，然後原始的安裝會移除。
    • 一但開始之後，如果發生了錯誤或您於升級的過程中取消安裝，升級無法回溯。
父主題： 升級至新版本


產品共存規則

這些產品共存規則決定新產品的安裝方式以及現有產品的升級方式。

規則 | 範例
允許有多個核心 SolidWorks 產品的主要發行版本，不論是 service pack 或主要版本（但是下面提到的三個產品例外）。 SolidWorks 2010 SP3.0 和 SolidWorks 2011 SP0.0 可以共同存在於同一部電腦上。

但是如果 SolidWorks 2011 SP0.0 已經安裝在電腦中，而您安裝了 SolidWorks 2011 SP1.0，則 SolidWorks 安裝管理員會將 SP0.0 版本以新的 SP1.0 版本取代。

SolidWorks 2011 SP0.0 和 2011 SP1.0 不會共同存在於同一部電腦上。
只允許在一部電腦中有下列產品的其中一個版本：
  • Workgroup PDM Server
  • SolidNetWork License Manager
 如果已經安裝 SolidWorks 2011 SP0.0，即使電腦中仍然有較早的 SolidWorks 主要版本，Workgroup PDM Server 仍然會升級為 2011 SP0.0。
僅能為任何主要的版本安裝所包括產品的一個版本。 | 如果 SolidWorks 2011 SP0.0 已升級為 2011 SP1.0，SolidWorks Explorer 2011 SP0.0 將會自動升級為 2011 SP1.0。但是 SolidWorks Explorer 2010 SP4.0 也能夠存在於電腦中。
父主題： 單機安裝的管理


多個安裝

  • 部署至多個客戶端
    您可以產生一個管理安裝點來在多個客戶端上安裝 SolidWorks 產品，然後部署安裝至客戶端。
  • 使用管理安裝點
    管理安裝點可允許自單一網路位置的 SolidWorks 產品的可組態安裝。
  • 命令列部署
    您可以使用命令列提示或批次檔案（無訊息安裝）來自動部署管理安裝點。
  • 多個安裝的管理
    在多個安裝中，管理工作包括將管理安裝點升級至新的版本，套用 service pack 更新以及移除安裝。


部署至多個客戶端

您可以產生一個管理安裝點來在多個客戶端上安裝 SolidWorks 產品，然後部署安裝至客戶端。

部署至多個客戶端的程序為：
  1. 產生管理安裝點。
    • 產生來自 SolidWorks 安裝管理員的管理安裝點
    • 從指令列產生管理安裝點
  2. 部署管理安裝點至客戶端。
    • 透過電子郵件部署管理安裝點至客戶端
    • 使用指令列從管理安裝點安裝
  3. 執行使用許可。
    • 管理個別的使用許可
    • 使用 SolidNetWork 使用許可管理員來管理使用許可
父主題： 多個安裝


使用管理安裝點

管理安裝點可允許自單一網路位置的 SolidWorks 產品的可組態安裝。

您可以從網路上的任何電腦（包括客戶端電腦）安裝管理安裝點。
  • 管理安裝點必須在一共用的資料夾中。
  • 如果您包括所有產品，管理安裝點磁碟空間需求可能是 7GB 或更多。
  • 如果當您升級管理安裝點時更新共用的名稱，則下一次客戶端應用程式啟動時會自動升級。詳細資訊請參閱從管理安裝點升級客戶端。
  • 客戶端在其電腦中必須擁有管理權限，除非已為客戶端安裝指定以不同的使用者執行安裝選項。
    在 Windows Vista 或之後的版本不支援此選項。

在產生管理安裝點之後，管理安裝點選項編輯器可以管理安裝選項設定，以便使用者與群組從該安裝點安裝。詳細資訊請參閱管理安裝點選項編輯器。

  • 產生來自 SolidWorks 安裝管理員的管理安裝點
    如果您在多台電腦上安裝 SolidWorks，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。
  • 管理安裝點選項編輯器
    管理安裝點選項編輯器讓您為個別的機器或一組機器自訂在管理安裝點中的安裝參數。
  • 透過電子郵件部署管理安裝點至客戶端
    一旦您產生了共用管理安裝點目錄，便可透過電子郵件通知客戶端。
  • 將管理安裝點即時安裝至客戶端
    您可以執行一個指令，將新的管理安裝點安裝即時安裝至客戶端。
父主題： 多個安裝


產生來自 SolidWorks 安裝管理員的管理安裝點

如果您在多台電腦上安裝 SolidWorks，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。

  1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
  2. 在歡迎畫面中，選擇管理安裝點。

    管理安裝點的產生選項出現：

    使用預設的設定產生一個新的安裝點。
    使用預設的組態設定產生安裝點（即不根據目前為您的站點之現有管理安裝點建立的設定）。
    使用來自現有安裝點的設定及檔案來產生一個新的安裝點。
    使用為您所在站點之現有管理安裝點指定的組態設定產生安裝點。按一下瀏覽為現有的管理安裝點指定安裝目錄。
    同時產生 32 位元與 64 位元的管理安裝點。
    可以在一台電腦上產生 32 位元及 64 位元安裝點，或者只產生與該電腦架構對應的安裝點。產生兩個安裝點不需要存取 32 位元及 64 位元安裝媒體。

  3. 按照螢幕上的指示操作。
父主題： 使用管理安裝點


管理安裝點選項編輯器

管理安裝點選項編輯器讓您為個別的機器或一組機器自訂在管理安裝點中的安裝參數。

在產生管理安裝點之後，SolidWorks 安裝管理員會詢問您是否要啟動選項編輯器。您也可以連按兩下在管理安裝點資料夾中的 sldAdminOptionEditor.exe 來開啟選項編輯器。

若要為機器群組或個別的機器指定不同的安裝組態，請在選項編輯器中新增群組與機器，然後為這些群組與機器指定安裝選項。

  • 新增及刪除小組和機器
    管理安裝點選項編輯器讓您為一群機器或個別的機器指定不同的安裝組態。
  • 檢視及編輯選項設定
    SolidWorks 管理安裝點選項編輯器可讓您檢視及變更用於群組的選項設定以及為安裝點指定的機器。
  • 在 32 位元及 64 位元安裝點之間切換
    如果在管理安裝點安裝目錄中同時產生了 32 位元及 64 位元安裝點，選項編輯器可在兩個安裝點中作業。
  • 從選項編輯器部署安裝
    您可以使用電子郵件指示啟動安裝，直接從選項編輯器部署安裝。
  • 結束選項編輯器
    您可以按一下「確定」或「關閉」來結束選項編輯器。
  • 產生至選項編輯器的桌面捷徑
    您可以從應用程式內為特定管理安裝點產生選項編輯器的 Windows 桌面捷徑。
父主題： 使用管理安裝點


新增及刪除小組和機器

管理安裝點選項編輯器讓您為一群機器或個別的機器指定不同的安裝組態。

舉例來說，您可以將數台機器組態為使用安裝點中的一種產品元件子集，而另一組的機器則可以使用另一種產品元件子集。即使您只有使用一個管理安裝點，選項編輯器小組設定仍然能夠讓您將不同的產品子集安裝至不同的機器小組。

加入一個小組：
  1. 用滑鼠右鍵按一下整體設定，然後按新增小組。
  2. 輸入小組的名稱。
新增機器：
  1. 用滑鼠右鍵按一下現有小組或整體設定，然後按新增機器。
    如果您用滑鼠右鍵按一下現有小組，則會將機器加入該小組。否則，其被加入至最上層。
  2. 執行下列操作之一：
    • 在機器名稱之下輸入一或多個機器名稱。

      可以用分行、空格、tab 鍵、逗號、句點、冒號、或分號來分隔多台機器。您可以從外部的檔案複製及貼上機器名稱的清單。

      機器名稱不能包括網域識別符號。例如，pluto.solidworks.com 是無效的。

    • 按一下新增多台機器來從網路中選擇機器。
將現有機器移至小組中： 拖曳機器到小組中。
將機器移出小組： 拖曳機器到整體設定或不同的小組中。
刪除一個小組或機器︰ 用滑鼠右鍵按一下小組或機器，然後按一下刪除小組或刪除機器。
如果您刪除了一個小組，則該小組中的所有機器都將被刪除。
刪除所有小組和機器： 用滑鼠右鍵按一下整體設定，然後按全部刪除。
父主題： 管理安裝點選項編輯器


檢視及編輯選項設定

SolidWorks 管理安裝點選項編輯器可讓您檢視及變更用於群組的選項設定以及為安裝點指定的機器。

  • 第一次啟動選項編輯器時，選項設定以唯讀模式顯示。編輯圖示無陰影： .
    按一下整體設定、群組或機器將顯示該品項之選項設定摘要：
    範圍 | 顯示的選項設定
    整體設定 | 所有為管理安裝點指定的選項設定
    群組 | 變更與整體設定相關的群組設定
    機器 | 變更與群組相關的機器設定
  • 要變更選項設定，請按一下「編輯」圖示。圖示將變為帶陰影 ( [image]) 且顯示更詳細的選項設定清單。

    按一下整體設定、群組或機器可讓您變更該品項的選項設定。變更與繼承之整體設定或群組設定不同的選項設定時，該選項設定會強調顯示。

    如果再按一下「編輯」圖示，顯示將回復至唯讀模式。

    如果進行變更，選項編輯器在您結束時會提示您儲存或捨棄變更。

  • 為小組及機器指定選項設定
    您可以為所有機器（整體設定）、群組的機器及個別的機器指定選項設定。
  • 整體及群組選項設定的繼承
    整體設定或群組的選項設定由其底下的品項繼承。
父主題： 管理安裝點選項編輯器


為小組及機器指定選項設定

您可以為所有機器（整體設定）、群組的機器及個別的機器指定選項設定。

  1. 在選項編輯器中，按一下要修改的物件（整體設定、一個群組或一台機器）。
  2. 在右側，按一下「編輯」圖示 [image] 。

    「編輯」圖示將變為帶陰影 ( [image]) 且顯示更詳細的選項設定清單。

  3. 按一下左側所選品項右邊的選項設定以進行變更。

    取代整體設定或群組設定的選項設定之變更將會強調顯示。

  4. 按一下確定或關閉來儲存您的變更。

    確定
    選項編輯器將會儲存您的變更並結束。
    關閉
    選項編輯器詢問您是否要儲存變更，然後結束。

  • 管理安裝點選項設定
    選項編輯器可讓您指定個別客戶端或群組的選項設定，包括序號、客戶端安裝選項、要安裝的軟體元件，以及 toolbox 的位置。
父主題： 檢視及編輯選項設定


管理安裝點選項設定

選項編輯器可讓您指定個別客戶端或群組的選項設定，包括序號、客戶端安裝選項、要安裝的軟體元件，以及 toolbox 的位置。

序號

輸入要安裝於客戶端機器之產品的序號。
由於購買 SolidWorks 產品的管道有很多，因此某些序號可能會適用於兩種或多種產品。例如，SolidWorks 序號可讓您安裝 SolidWorks Simulation 而不需輸入個別的 SolidWorks Simulation 序號。此外，有些產品並不需要序號。如果您對於序號有任何問題，請聯絡您的 VAR。
如果您使用 SolidNetWork Licensing 管理使用許可：
  • 在第一個序號欄位中，輸入 SolidNetWork 的序號。
  • 在 SNL Server port@server 欄位中，以 nnnnn@servername 的形式輸入 SolidNetWork License Manager 伺服器的名稱與連接埠。使用分號來將多行的輸入分開。

如需有關 SolidNetWork 使用許可的詳細資訊，請參閱安裝與組態 SolidNetWork 使用許可。

客戶端安裝選項

您要如何在客戶端上執行主要版本的安裝？
您可以指定客戶端安裝如何處理現有的較舊主要版本安裝：
  • 升級一個現有的主要版本（如果有的話）。

    指定此選項以將較舊主要版本安裝取代為較新版本安裝

  • 產生一個新的主要版本。

    指定此選項以保留較舊的主要版本，並為較新的主要版本產生一個新的安裝。

    要為較新版本的安裝指定位置，請按一下瀏覽。

在安裝新的主要版本之前，您是否要解除之前最新版本的安裝？
您可以指定是否要解除現有之前主要版本的安裝：
  • 否，不要先解除安裝。

    指定此選項來保留之前主要版本的安裝。

  • 是，執行自訂的解除安裝。
    選擇此選項來移除這些項目：
    • 程式檔案及資料夾
    • 登錄項目
    • 資料檔案及資料夾
您要如何套用 SolidWorks 的設定？
您可以指定客戶端安裝根據在客戶端機器上組態的 SolidWorks 設定或者從「複製設定精靈」輸出的 SolidWorks 設定來組態 SolidWorks 設定。
  • 使用目前的設定（如果存在的話）或使用 SolidWorks 預設設定

    如果客戶端機器定義了 SolidWorks 設定，則保留這些設定。（對於沒有在客戶端上特別指定的任何設定，客戶端安裝會使用預設的 SolidWorks 設定。）

  • 使用由複製設定精靈輸出的設定檔案。
    選擇此選項設定可讓您從現有的複製設定精靈輸出檔案中指定選項設定。（通常此檔案的名稱是 solidworkssettings.sldreg）。
    • 按一下瀏覽找出現有的設定檔案。
    • 按一下新增來開始複製設定精靈以產生新的設定檔案。
您要如何啟動客戶端的安裝？
您可以指定是否在執行安裝後自動完成產品的啟動，或要求在安裝後由使用者手動執行產品啟動。
  • 當每個客戶端安裝完成時自動啟動。
    選擇此選項設定指定使用 SolidWorks 產品動檔案來自動執行產品啟動。（通常此檔案是名為 AutoActivation.xml）。
    • 按一下瀏覽找出現有的啟動檔案。
    • 按一下新增來開始 SolidWorks 產品啟動以產生新的啟動檔案。
  • 不要自動啟動。

    選擇此選項設定來指定不要有自動的產品啟動。客戶端使用者在安裝後執行產品啟動。

如果您指定自動的產品啟動，在安裝後客戶端第一次執行 SolidWorks 時，管理安裝點必須可經由共用的網路位置存取。如果客戶端無法存取從該安裝點安裝的管理安裝點，這些客戶端將無法完成自動的產品啟動。除非其手動執行 SolidWorks 產品啟動，否則無法執行 SolidWorks。

系統管理選項

在每個安裝的過程中產生一個診斷記錄檔
客戶端安裝會產生診斷記錄檔，可用於排解安裝問題。產生此記錄檔可能會使客戶端安裝速度變慢。
以不同的使用者執行安裝。
客戶端安裝可以執行為不同的使用者。如果個別使用者對其機器沒有本機系統管理權限（安裝 SolidWorks 產品需要此權限），則此選項很有用。
在 Windows Vista、Windows 7 或之後的版本不支援此選項。
在安裝之前或之後執行一個程式
您可以指定自訂程式在客戶端安裝之前或之後執行。
您是否要讓客戶端參與 SolidWorks Customer Experience Program？
您可以指定客戶端機器參與 SolidWorks 客戶經驗改進計劃。效能資訊被送至 SolidWorks Corporation 以幫助改進產品。此過程是透明和保密的。詳細資訊請參考 Customer Experience Improvement Program 的網站。

要安裝的軟體

您可以要安裝哪些 SolidWorks 產品元件。
  • 選擇產品元件旁邊的核取方塊可指定在客戶端安裝期間安裝該元件。
  • 清除核取方塊則指定不安裝該元件。
  • 如果元件中具有可選的安裝子元件，+ 圖示將會出現在元件旁邊。要查看元件可用的子元件，請按一下 + 圖示。
  • 如果元件已經展開而顯示子元件，- 圖示將會出現在元件旁邊。要摺疊子元件清單，請按一下 - 圖示。
語言的指定會限制僅為 SolidWorks 產品安裝該語言。其他的產品不受此指定的影響。例如，SolidWorks eDrawings®、SolidWorks Workgroup PDM、及 SolidWorks Explorer 會安裝所有的語言。

Toolbox 選項

您可以指定客戶端安裝的支援標準以及預設的 Toolbox 位置。

通常有多個使用者存取一個共用的 Toolbox，一般是透過網路位置（例如 UNC 路徑、共用資料夾或公用網路磁碟機）存取。

如果該位置包含 Toolbox 的較舊主要版本，客戶端安裝會將該 Toolbox 升級至較新的主要版本。這些檔案將不再與 SolidWorks 的較舊主要版本相容。
如果要保留較舊 SolidWorks 版本的 Toolbox（例如，如果某些客戶端可能繼續使用較舊版本），則必須為升級至較新版本的客戶端指定不同的 Toolbox 網路位置。

如需 SolidWorks Toolbox 管理的詳細資訊，請參閱 SolidWorks 說明中的 Toolbox 資訊。

父主題： 為小組及機器指定選項設定


整體及群組選項設定的繼承

整體設定或群組的選項設定由其底下的品項繼承。

例如：
  • 為整體設定所定義的設定會被所有小組及機器繼承。
  • 為小組定義的設定會被在該小組內的所有機器繼承。

您可以變更一台機器或一個小組的選項設定來取代預設或繼承的設定。當您變更來自預設或繼承值的選項設定時，該選項會被強調顯示。

若要將選項設定回復到原始繼承值，請用滑鼠右鍵按一下小組或機器，然後按一下回復到整體設定（不屬於小組成員的小組或機器）或回復到小組設定（屬於小組成員的機器）。
父主題： 檢視及編輯選項設定


在 32 位元及 64 位元安裝點之間切換

如果在管理安裝點安裝目錄中同時產生了 32 位元及 64 位元安裝點，選項編輯器可在兩個安裝點中作業。

  • 在選項編輯器中，按一下 32 或 64 以在 32 位元或 64 位元安裝點中作業。

    按一下設定或部署可讓您檢視並修改選項設定，或為該安裝點部署安裝。

如果有 32 位元及 64 位元影像，則必須指定整體設定、群組及群組設定，以及單獨用於每個安裝點的個別機器設定。
父主題： 管理安裝點選項編輯器


從選項編輯器部署安裝

您可以使用電子郵件指示啟動安裝，直接從選項編輯器部署安裝。

必須將管理安裝點的安裝目錄變更為 Windows 共用目錄，如此才可透過網路位置（例如 \\machine\shared_directory）使用。

  1. 在選項編輯器中，按一下部署。
  2. 如果您有為此管理安裝點安裝目錄組態的 32 位元及 64 位元安裝點，按一下 32 或 64 以檢視用於 32 位元或 64 位元安裝點的機器。

    安裝可用性及每台機器的狀態將會出現。

  3. 按一下傳送電子郵件。
  4. 指定管理安裝點安裝目錄的網路路徑。

    通常，管理安裝點安裝目錄的目錄路徑最初顯示為 Windows 檔案路徑（例如 C:\SolidWorks Admin\SolidWorks 2011 SP0）。對話方塊指示此路徑並非一網路路徑。

    1. 按一下瀏覽為此管理安裝點安裝目錄指定網路位置。
    2. 導覽至其中安裝有管理安裝點的電腦，並選擇為管理安裝點安裝目錄指定的 Windows 共用目錄。

      不要在管理安裝點共用目錄內導覽（例如導覽至 32bit 或 64bit 子目錄）。

    3. 按一下確定。

      對話方塊指示此路徑是一網路路徑。

    將會產生一封電子郵件，指示機器所有者如何使用管理安裝點中的 StartSWInstall.hta 檔案之網路位置從管理安裝點安裝。

  5. 將此電子郵件傳送至負責安裝 SolidWorks 的使用者。

使用者可以連按兩個電子郵件中 StartSWInstall.hta 之網路位置的連結，以從管理安裝點安裝 SolidWorks。

在選項編輯器中，安裝狀態顯示：
擱置中
使用者尚未在此機器上執行安裝。
成功
使用者已在此機器上成功完成安裝。
失敗
使用者在此機器上執行了安裝，但失敗了。
  • 使用對應的磁碟機部署管理安裝點
    UNC 路徑 (\\machine_name\share_name) 是建議用於為管理安裝點安裝目錄指定網路位置的方法。但是，如果安裝使用者將同一磁碟機字母對應至管理安裝點共用目錄，您可以使用對應的磁碟機作為管理安裝點中 StartSWInstall.hta 檔案的位置（例如 U:\StartSWInstall.hta）。
父主題： 管理安裝點選項編輯器


使用對應的磁碟機部署管理安裝點

UNC 路徑 (\\machine_name\share_name) 是建議用於為管理安裝點安裝目錄指定網路位置的方法。但是，如果安裝使用者將同一磁碟機字母對應至管理安裝點共用目錄，您可以使用對應的磁碟機作為管理安裝點中 StartSWInstall.hta 檔案的位置（例如 U:\StartSWInstall.hta）。

例如，如果您將 U: 磁碟機對應至管理安裝點共用目錄，通知電子郵件將指示使用者按一下到 file://U:\StartSWIOnstall.hta 的連結。如果 U: 磁碟機對應至管理安裝點的 UNC 位置 (\\machine_name\share_name)，收到電子郵件的使用者可以成功安裝。

父主題： 從選項編輯器部署安裝


結束選項編輯器

您可以按一下「確定」或「關閉」來結束選項編輯器。

  • 按一下確定、關閉或使用 Windows 應用程式的「關閉」按鈕來套用變更並結束選項編輯器。
    • 按一下確定套用任何選項設定變更並結束選項編輯器。
    • 按一下關閉結束選項編輯器。

      如果有變更要套用，會詢問您是否要儲存這些變更。

    • 按一下 Windows 應用程式的「關閉」按鈕 (X)。如果有變更要套用，會詢問您是否要儲存這些變更。
父主題： 管理安裝點選項編輯器


產生至選項編輯器的桌面捷徑

您可以從應用程式內為特定管理安裝點產生選項編輯器的 Windows 桌面捷徑。

  1. 啟動選項編輯器。

    例如，在 Windows 檔案總管中，導覽至管理安裝點安裝目錄，並連按兩下 sldAdminOptionEditor.exe。

  2. 按一下產生至此選項編輯器的桌面捷徑。

    管理安裝點的選項編輯器之捷徑出現在 Windows 桌面上。

父主題： 管理安裝點選項編輯器


透過電子郵件部署管理安裝點至客戶端

一旦您產生了共用管理安裝點目錄，便可透過電子郵件通知客戶端。

將管理安裝點目錄組態為在其他電腦可存取的電腦上共用（例如透過 UNC 路徑）。

您可以將包含管理安裝點安裝目錄\StartSWInstall.hta 連結的電子郵件傳送給所有客戶端。客戶端可以按一下此連結，然後按一下馬上安裝 SolidWorks 產品來從管理安裝點開始安裝。

如果您將管理安裝點升級至新的 SolidWorks 版本，您可以設定管理安裝點位置並且共用屬性，讓先前使用該安裝點安裝的任何客戶端自動升級。詳細資訊請參閱從管理安裝點升級客戶端。
父主題： 使用管理安裝點


將管理安裝點即時安裝至客戶端

您可以執行一個指令，將新的管理安裝點安裝即時安裝至客戶端。

電子郵件部署是通常用於通知客戶端有新的 SolidWorks 安裝的方法。詳細資訊請參閱透過電子郵件部署管理安裝點至客戶端。

但是您也可以選擇執行命令，將新的安裝即時安裝至客戶端。例如，您可以對不經常使用 SolidWorks 應用程式的員工即時安裝。

即時安裝 SolidWorks 是在使用者電腦的開始功能表上產生一個至 SolidWorks 應用程式的捷徑，並產生與在伺服器上管理安裝點的檔案關聯。一開始，並未安裝可執行檔案。安裝僅於使用者第一次需要應用程式時發生。

當使用者按一下捷徑或連按兩下 SolidWorks 文件時，安裝開始並執行 SolidWorks 應用程式。

從管理安裝點即時安裝：

  1. 產生與設定管理安裝點。
  2. 在即將安裝 SolidWorks 應用程式的每台機器上通告此產品。

    例如：

    msiexec /jm 到管理安裝點 msi 檔案的路徑

    其中到管理安裝點 msi 檔案的路徑為至管理安裝點目錄的 UNC 路徑。

父主題： 使用管理安裝點


命令列部署

您可以使用命令列提示或批次檔案（無訊息安裝）來自動部署管理安裝點。

  • 從指令列產生管理安裝點
    您可以使用 SolidWorks 安裝管理員或從 MS-DOS 指令列產生管理安裝點。
  • 準備客戶端以便從管理安裝點進行指令列安裝
    在產生管理安裝點並且通知客戶端之前，必須安裝 Microsoft Windows 元件，使用指令列或 Microsoft Active Directory 產生的管理安裝點無法安裝這些元件。
  • 使用指令列從管理安裝點安裝
    您可以部署使用指令列從管理安裝點安裝。
  • 命令列屬性
    此處描述的命令列屬性包括特徵屬性、整體屬性、產品指定屬性和 Windows 位置慣例。
  • 使用 Microsoft Active Directory 部署管理安裝點
    Microsoft Active Directory Deployment 支援 SolidWorks 核心產品對客戶端的部署。
父主題： 多個安裝


從指令列產生管理安裝點

您可以使用 SolidWorks 安裝管理員或從 MS-DOS 指令列產生管理安裝點。

從指令列產生管理安裝點時，必須執行每個 SolidWorks 產品元件的 .msi 檔案，為該元件產生並部署單獨的安裝點。如果安裝非英文語言，必須執行各種非英文語言的 .msi 檔案，為該語言產生並部署單獨的安裝點。如需 .msi 檔案位置的詳細資訊，請參閱管理安裝點的 MSI 檔案位置。
  1. 開啟 命令提示字元 視窗。
    1. 在 Windows 中，按一下開始 > 執行。
    2. 輸入 cmd，然後按一下確定。
  2. 輸入此指令：

    msiexec /a Msi_path

    其中 Msi_path 是您作業系統的 .msi 檔案位置。SolidWorks.msi 位於安裝目錄的 swwi\data 子目錄中。

    例如：

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. 在 SolidWorks 安裝精靈中，遵循螢幕上的指示操作。
  4. 如果安裝非英文語言的 SolidWorks 產品，請使用此指令為該語言產生單獨的管理安裝點：

    msiexec /a Msi_path_for_language

    其中 Msi_path_for_language 是語言的 .msi 檔案位置。例如，french.msi 位於安裝目錄的 swwi\lang\french 子目錄中。

    例如：

    msiexec /a F:\swwi\lang\french\french.msi

父主題： 命令列部署


準備客戶端以便從管理安裝點進行指令列安裝

在產生管理安裝點並且通知客戶端之前，必須安裝 Microsoft Windows 元件，使用指令列或 Microsoft Active Directory 產生的管理安裝點無法安裝這些元件。

只有當您是從使用指令列或透過 Microsoft Active Directory 手動產生的管理安裝點安裝時，才會需要手動安裝這些 Windows 元件。如果您使用 SolidWorks 安裝管理員產生與安裝管理安裝點，這些 Windows 元件會自動安裝。
以下是 SolidWorks 在 Windows 元件中所需要的檔案摘要：
Windows Installer
包含執行 SolidWorks Simulation Premium 安裝所需要的檔案。
Office Web Components
包含 DriveWorks 需要的 COM 控制項。
Visual C++ 2005 和 2008 Redistributable Package
包含 Microsoft Visual C++ 的執行階段元件。
必須安裝 2005 和 2008 兩個版本。
Visual Studio Tools for Applications
包含支援 Visual Studio 應用程式的工具組。
Visual Studio Remote Debugger
提供 64 位元作業系統的除錯環境。
.NET Framework
包含執行 .NET Framework 應用程式所需的共同語言執行階段和 .NET Framework 元件。
Windows Desktop Search（選用）
支援在不同資料來源和位置上的快速搜尋檔案與資料，包括本機電腦和共用網路。
Windows Desktop Search 檔案為語言特定。詳細資訊請參考Windows Desktop Search 的語言支援。
所有 SolidWorks 產品都需要 Visual C++ Redistributable Package 和 .NET Framework 3.5，不只是核心 SolidWorks 產品。

這些元件必須包括在管理安裝點目錄的子目錄中。

此表標出每個支援的作業系統所需要的特定檔案。
作業系統： Windows 2003 32 位元1
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | （不適用）
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）：
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lang.exe
作業系統： Windows 2003 64 位元1
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 64 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）：
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
作業系統： Windows 2008 32 位元1
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | （不適用）
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）： |  | Windows Desktop Search 是作業系統的一項功能。
作業系統： Windows 2008 64 位元1
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 64 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）： |  | Windows Desktop Search 是作業系統的一項功能。
作業系統： Windows XP 32 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | WindowsInstaller-KB893803-v2-x86.exe
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | （不適用）
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）：
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lang.exe
作業系統： Windows XP 64 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）：
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
作業系統： Windows XP 64 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 64 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）：
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
作業系統： Windows Vista 32 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | （不適用）
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）： |  | Windows Desktop Search 是作業系統的一項功能。
作業系統： Windows Vista 64 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 64 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | dotnetfx35.exe
 | Windows Desktop Search（選用）： |  | Windows Desktop Search 是作業系統的一項功能。
作業系統：Windows 7 32 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 32 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | （不適用）
 | .NET Framework： |  | .NET Framework 及 Windows Desktop Search 是作業系統的功能。
 | Windows Desktop Search（選用）：
作業系統：Windows 7 64 位元
SolidWorks 媒體：Windows XP、Windows Vista 及 Windows 7 的 64 位元版本
 | Windows Installer： |  | （不適用）
 | Office Web Components： |  | owc11.exe
 | Visual C++ 2005 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual C++ 2008 Redistributable Package： |  | vcredist_x86.exe vcredist_x64.exe 兩者皆需安裝。
 | Visual Studio Tools for Applications： |  | vsta_aide.msi
 | Visual Studio Remote Debugger： |  | rdbgexp.msi
 | .NET Framework： |  | .NET Framework 及 Windows Desktop Search 是作業系統的功能。
 | Windows Desktop Search（選用）：
1只有 Workgroup PDM Server 和 SolidNetWork License (SNL) Server 才支援 Windows 2003 或 Windows 2008 上的安裝。
  • 32 位元作業系統中從指令列安裝 Windows 必要元件
    遵照以下程序使用 32 位元 Windows 版本的指令列安裝 Windows 必要元件以取得管理安裝點安裝。
  • 64 位元作業系統中從指令列安裝 Windows 必要元件
    遵照以下程序使用 64 位元的 Windows 版本的指令列安裝 Windows 必要元件以取得管理安裝點安裝。
  • SolidWorks 搜尋與 Microsoft Windows 桌面搜尋
    SolidWorks 搜尋與 Microsoft® Windows® 桌面搜尋相整合。
父主題： 命令列部署


32 位元作業系統中從指令列安裝 Windows 必要元件

遵照以下程序使用 32 位元 Windows 版本的指令列安裝 Windows 必要元件以取得管理安裝點安裝。

如果要在一個安裝作業中安裝多個元件，請使用下列程序中提供的指令建立一個批次檔，然後用它將元件推至客戶端電腦。

  1. 請確定目標電腦至少有 290 MB 的可用空間及有效的 TEMP 目錄。
  2. 執行此指令來安裝 Office Web Components：

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. 如果是 Windows XP 版本，請安裝 Windows Installer：

    administrative_image_directory\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    不需要在 Windows XP 以外的其他任何 Windows 版本上安裝 Windows Installer。

  4. 安裝 Visual C++ 2005 Redistributable Package：

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. 安裝 Visual C++ 2008 Redistributable Package：

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. 如果是 Windows XP 和 Windows Vista，請使用 Windows Server Update Services 安裝 Microsoft .NET Framework 3.5。

    不需要在 Windows 7 或之後的版本上安裝 .NET Framework 安裝點。

  7. 安裝 Visual Studio Tools for Applications：

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

父主題： 準備客戶端以便從管理安裝點進行指令列安裝


64 位元作業系統中從指令列安裝 Windows 必要元件

遵照以下程序使用 64 位元的 Windows 版本的指令列安裝 Windows 必要元件以取得管理安裝點安裝。

如果要在一個安裝作業中安裝多個元件，請使用下列程序中提供的指令建立一個批次檔，然後用它將元件推至客戶端電腦。

  1. 請確定目標電腦至少有 620 MB 的可用空間及有效的 TEMP 目錄。
  2. 執行此指令來安裝 Office Web Components：

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. 安裝 Visual C++ 2005 Redistributable Package：

    administrative_image_directory\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    此套裝軟體的 32 位元與 64 位元版本都必須安裝。

  4. 安裝 Visual C++ 2008 Redistributable Package：

    administrative_image_directory\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    此套裝軟體的 32 位元與 64 位元版本都必須安裝。

  5. 如果是 Windows XP 和 Windows Vista，請使用 Windows Server Update Services 安裝 Microsoft .NET Framework 3.5。

    不需要在 Windows 7 或之後的版本上安裝 .NET Framework 安裝點。

  6. 安裝 Visual Studio Tools for Applications：

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

  7. 安裝 Visual Studio Remote Debugger：

    administrative_image_directory\VSRemoteDebugger\install.exe /Q

父主題： 準備客戶端以便從管理安裝點進行指令列安裝


SolidWorks 搜尋與 Microsoft Windows 桌面搜尋

SolidWorks 搜尋與 Microsoft® Windows® 桌面搜尋相整合。

如果正確的 Windows 桌面搜尋版本並未安裝在您的電腦中，系統會在 SolidWorks 安裝期間要求您安裝或更新。

如果產生管理安裝點，Windows 桌面搜尋未包含在管理安裝點目錄中。如果從管理安裝點安裝 SolidWorks 的客戶端電腦要使用 SolidWorks 搜尋，必須在這些電腦中手動安裝 Microsoft Windows 桌面搜尋。

父主題： 準備客戶端以便從管理安裝點進行指令列安裝


使用指令列從管理安裝點安裝

您可以部署使用指令列從管理安裝點安裝。

無訊息安裝：
  1. 開啟「命令提示字元」視窗（在 Windows 中，按一下開始 > 執行）。
  2. 輸入 msiexec.exe 指令以及 /i 和 /qb 選項，然後設定非如下所示之預設值的任何選項屬性。
個別安裝元件指令列屬性包括：
  • 命令列功能屬性
  • 指令列整體屬性
  • SolidWorks eDrawings 命令列屬性
  • SolidWorks Explorer/Workgroup PDM 指令列屬性
  • SolidWorks Flow Simulation 命令列屬性
使用下列的範例做為無訊息安裝的範本。
SolidWorks 客戶端
  • SolidWorks 核心（英文）
  • Toolbox 附加程式
  • 參予回饋計畫
  • 法文

在 32 位元作業系統上的 SolidWorks 32 位元版本：

msiexec /i "32 位元管理安裝點路徑\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

在 64 位元作業系統上的 SolidWorks 32 位元版本：

msiexec /i "32 位元管理安裝點路徑\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

在 64 位元作業系統上的 SolidWorks 64 位元版本：

msiexec /i "64 位元管理安裝點路徑\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

SolidWorks 法文安裝元件必須單獨安裝：
  • 32 位元版本：

    msiexec /i "32 位元管理安裝點路徑\SolidWorks French\french.msi" /qb

  • 64 位元版本：

    msiexec /i "64 位元管理安裝點路徑\SolidWorks French\french.msi" /qb

在指定 SolidWorks 語言元件安裝指令時，不要指定指令列引數。
eDrawings 客戶端
  • 記錄效能
  • 所有特徵

msiexec /i "管理安裝點路徑\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\您的資料夾" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL 伺服器 TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer 和 Workgroup PDM 附加程式
  • 有 Workgroup PDM 附加程式的 SolidWorks Explorer

msiexec /i "管理安裝點路徑\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\您的資料夾" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
父主題： 命令列部署


命令列屬性

此處描述的命令列屬性包括特徵屬性、整體屬性、產品指定屬性和 Windows 位置慣例。

  • 命令列功能屬性
    SolidWorks 安裝支援命令列部署的這些 ADDLOCAL 屬性。
  • 指令列整體屬性
    除非另有說明，每個屬性是為系統管理安裝或單機安裝而定義。使用整體屬性，序號可以同時傳至系統管理安裝及單機安裝。
  • SolidWorks eDrawings 命令列屬性
    這些命令列屬性是 eDrawings 所特有的。
  • SolidWorks Explorer/Workgroup PDM 指令列屬性
    這些指令列屬性是 SolidWorks Explorer 和 SolidWorks Workgroup PDM 所特有的。
  • SolidWorks Flow Simulation 命令列屬性
    這些命令列屬性是 SolidWorks Flow Simulation 所特有的。
  • 管理安裝點的 MSI 檔案位置
    為了從指令列產生管理安裝點，.msi 檔案儲存在 SolidWorks 媒體中的下列位置。
  • Windows Desktop Search 的語言支援
    Windows Desktop Search 檔案名稱指示平台及語言資訊。
父主題： 命令列部署


命令列功能屬性

SolidWorks 安裝支援命令列部署的這些 ADDLOCAL 屬性。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86（針對在 32 位元作業系統上的 32 位元 SolidWorks）
  • Intel_Modules_AgeiaX64（針對在 64 位元作業系統上的 32 位元 SolidWorks）
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
為命令列安裝指定屬性時：
  • SolidWorks 不支援使用 ADDSOURCE 選項安裝產品。
  • 屬性需注意大小寫，不能包含空格或破折號，且必須用逗點分開。
  • 必須指明 SolidWorks，SolidWorks 應用程式才會正確安裝。
父主題： 命令列屬性


指令列整體屬性

除非另有說明，每個屬性是為系統管理安裝或單機安裝而定義。使用整體屬性，序號可以同時傳至系統管理安裝及單機安裝。

屬性 | 說明
ENABLEPERFORMANCE 應用程式是否應自動傳送效能資料至 SolidWorks 公司。

1 會傳送效能資料，0 則不會。
INSTALLDIR SolidWorks 的安裝資料夾。

僅單機安裝。
INSTALLWDS 安裝使用 Microsoft Windows 桌面搜尋引擎的 SolidWorks 擴充。詳細資訊請參閱為從管理安裝點安裝而準備客戶端。

1 是安裝擴充，0 則不安裝。
MOTIONSERIALNUMBER | SolidWorks Motion 產品的序號
OFFICEOPTION 指定要安裝的產品套件：
0
SolidWorks 客戶端
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL 指定 ALL 以更新目前安裝的所有功能。
僅當更新現有主要版本中的 Service Pack 版本時才指定此屬性 (例如，將現有的 SolidWorks 2011 SP01 安裝更新為 SolidWorks 2011 SP02)。
REINSTALLMODE Microsoft Installer 重新安裝選項。

例如，將安裝從一個 Service Pack 版本升級至同一主要版本中的另一個版本時，應指定 REINSTALLMODE=vomus。

如需 REINSTALLMODE 設定的詳細資訊，請參閱 www.microsoft.com 上的 Windows Installer 文件。

僅當更新現有主要版本中的 Service Pack 版本時才指定此屬性 (例如，將現有的 SolidWorks 2011 SP01 安裝更新為 SolidWorks 2011 SP02)。第一次安裝新的 SolidWorks 主要版本時，不要指定此屬性。
SERVERLIST SolidNetWork 伺服器清單。
SolidNetWork 伺服器清單是以分號分隔字串的清單，每個字串代表伺服器上的連接埠號碼，其格式為：

xxxxx@server_name1;yyyyy@server_name2;&

其中 x 和 y 為一個數字。在清單中的最後一個伺服器之後，不要輸入分號。

僅單機安裝。
SIMULATIONSERIALNUMBER | SolidWorks Simulation 產品的序號
SOLIDWORKSSERIALNUMBER | 包括附加程式的 SolidWorks 產品的序號。
SWMIGRATE 要升級的 SolidWorks 版本，會顯示在下列項目的清單中 SolidWorks 安裝選擇 對話方塊。例如：

SWMIGRATE="SolidWorks 2011 SP01"

僅當目前已安裝有舊主要版本而又要安裝新主要版本時，才指定此屬性。將一個 Service Pack 版本升級至同一主要版本中的另一個版本時，不要指定此屬性。
TARGETDIR SolidWorks 的安裝資料夾。

僅管理安裝點安裝。
TOOLBOXFOLDER SolidWorks Toolbox 檔案的安裝資料夾。

僅單機安裝。
TRANSFORMS 包含語言特定的形式項目：
TRANSFORMS number.mst
  • 中文 (1028)
  • 簡體中文 (2052)
  • 捷克文 (1029)
  • 英文 (1033)
  • 法文 (1036)
  • 德文 (1031)
  • 義大利文 (1040)
  • 日文 (1041)
  • 韓文 (1042)
  • 波蘭文 (1045)
  • 巴西葡萄牙文 (1046)
  • 俄文 (1049)
  • 西班牙文 (1034)
  • 土耳其文 (1055)
UPGRADESWINSTALL
指定是否升級現有的 SolidWorks 版本至目前的版本。
0
新的安裝，不更新
1
更新

僅單機安裝。

僅當目前已安裝有舊主要版本而又要安裝新主要版本時，才指定此屬性。將一個 Service Pack 版本升級至同一主要版本中的另一個版本時，不要指定此屬性。
父主題： 命令列屬性


SolidWorks eDrawings 命令列屬性

這些命令列屬性是 eDrawings 所特有的。

屬性 | 描述
ADDLOCAL 指定要安裝哪些部分的 SolidWorks eDrawings 應用程式。

All 是建議的選項。
命令列語法： 功能：
All | 安裝所有的功能。eDrawings 應用程式會搜尋已安裝的 SolidWorks 及 AutoCAD publisher 應用程式來查驗安裝的有效性。
eDrawingsViewer | 檢視 eDrawings 及其他檔案。
PublisherForAutoCADR14 | 從 AutoCAD R14 應用程式中產生 eDrawings 檔案。
PublisherForAutoCAD2000 | 從 AutoCAD 2000 應用程式中產生 eDrawings 檔案。
PublisherForAutoCAD2004 | 從 AutoCAD 2004 應用程式中產生 eDrawings 檔案。
PublisherForAutoCAD2005 | 從 AutoCAD 2005 應用程式中產生 eDrawings 檔案。
PublisherForAutoCAD2006 | 從 AutoCAD 2006 應用程式中產生 eDrawings 檔案。
DXFDWGTranslator | 以 eDrawings Viewer 檢視 DXF/DWG 檔案。
Shortcuts | 安裝桌面捷徑。
XML3D | 以 eDrawings Viewer 檢視 3DXML 檔案。
INSTALLDIR | 指定 SolidWorks eDrawings 的安裝資料夾。
LOGPERFORMANCE 指定應用程式是否應自動傳送效能電子郵件至 SolidWorks 公司。
1
傳送效能資料
0
不傳送
SNLSERVER 輸入 連接埠@伺服器名稱作為您的 SolidNetWork License 伺服器。使用分號來分隔多個 連接埠@伺服器名稱 的組合。

只有 SolidWorks SNL 伺服器組態時才需要 SNLSERVER 的連接埠伺服器名稱。連接埠清單@伺服器字串 是以分號隔開的字串清單，每個字串指的是在伺服器上的連接埠號碼，格式如下：

xxxxx@伺服器名稱1; yyyyy@伺服器名稱2;

其中 x 和 y 為一個數字。在清單中的最後一個伺服器之後，不要輸入分號。
父主題： 命令列屬性


SolidWorks Explorer/Workgroup PDM 指令列屬性

這些指令列屬性是 SolidWorks Explorer 和 SolidWorks Workgroup PDM 所特有的。

SolidWorks Explorer/Workgroup PDM 客戶端：
客戶端屬性 | 說明
EXPLORERORPDM
0
只有 SolidWorks Explorer
1
可以安裝 Workgroup PDM 特徵
ADDLOCAL
  • Standalone
  • Client
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone 是 Contributor，Client 是對 SolidWorks Explorer 無訊息安裝的 SolidWorks 附加程式。

如果您指定 AutoCAD，則必須在您的系統上安裝有 AutoCAD。Workgroup PDM 會找出 AutoCAD 的適當版本。您可以指定一種以上的 AutoCAD 版本：

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 和 DocMgr64 僅能用於 64 位元 SolidWorks Explorer 安裝。
INSTALLDIR | 指定 Workgroup PDM 的安裝資料夾。
ACTIVSERIALNUMBER | 指定 Solidworks 序號。
Workgroup PDM Server：
伺服器屬性 | 說明
ADDLOCAL
  • Vault
  • WebPortal
  • API

如果您指定 WebPortal（即 Viewer），同時必須指定 VAULTNAME。
INSTALLDIR | 指定 Workgroup PDM 的安裝資料夾。
LICENSE_SERVER | 指定使用許可伺服器所在的電腦名稱。
VAULTDATA | 指定資料保險箱的路徑及資料夾。
VAULTNAME | 指定資料保險箱所在的電腦名稱。
父主題： 命令列屬性


SolidWorks Flow Simulation 命令列屬性

這些命令列屬性是 SolidWorks Flow Simulation 所特有的。

屬性 | 描述
ACTIVSERIALNUMBER SolidWorks Flow Simulation 單機序號。

（來自管理安裝點的單機安裝及客戶端安裝）
CWUPGRADEINSTALL 升級 SolidWorks Flow Simulation 應用程式軟體的現有版本。
1
更新
2
新安裝；安裝在新目錄中

（來自管理安裝點的單機安裝及客戶端安裝）
INSTALLDIR 指定 SolidWorks Flow Simulation 應用程式軟體的安裝。

(僅單機安裝)
SERVERLIST | 是以分號分隔的字串清單，每個字串代表的是伺服器上的連接埠號碼，其格式為：xxxxx@server_name1; yyyyy@server_name2;& 其中 x 和 y是單一位數。在清單中的最後一個伺服器之後，不要輸入分號（;）。
SOLIDWORKSPATH 指定安裝 SolidWorks 軟體的資料夾。

（來自管理安裝點的單機安裝及客戶端安裝）
TARGETDIR 指定 SolidWorks Flow Simulation 應用程式軟體的安裝。

（僅管理安裝點安裝）
父主題： 命令列屬性


管理安裝點的 MSI 檔案位置

為了從指令列產生管理安裝點，.msi 檔案儲存在 SolidWorks 媒體中的下列位置。

產品 | 媒體位置
SolidWorks（核心產品，英文） | swwi\data\SolidWorks.msi
SolidWorks（非英文元件） | 繁體中文 | swwi\lang\chinese\chinese.msi
 | 簡體中文 | swwi\lang\chinese-simplified\chinese-simplified.msi
 | 捷克文 | swwi\lang\czech\czech.msi
 | 法文 | swwi\lang\french\french.msi
 | 德文 | swwi\lang\german\german.msi
 | 義大利文 | swwi\lang\italian\italian.msi
 | 日文 | swwi\lang\japanese\japanese.msi
 | 韓文 | swwi\lang\korean\korean.msi
 | 波蘭文 | swwi\lang\polish\polish.msi
 | 巴西葡萄牙文 | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | 俄文 | swwi\lang\russian\russian.msi
 | 西班牙文 | swwi\lang\spanish\spanish.msi
 | 土耳其文 | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
SolidWorks Simulation 產品 | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Workgroup PDM Server | pdmwserver\SolidWorks Workgroup PDM Server.msi
SolidWorks 啟動精靈 | swactwizard\Activation Wizard.msi
DocManager API | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork License Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
父主題： 命令列屬性


Windows Desktop Search 的語言支援

Windows Desktop Search 檔案名稱指示平台及語言資訊。

平台/架構：
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32 位元 Windows
x64 | 64 位元 Windows
語言：
chs | 簡體中文
cht | 繁體中文
csy | 捷克文
deu | 德文
enu | 英文
esn | 西班牙文
fra | 法文
ita | 義大利文
jpn | 日文
kor | 韓文
plk | 波蘭文
ptb | 巴西葡萄牙文
rus | 俄文
trk | 土耳其文
父主題： 命令列屬性


使用 Microsoft Active Directory 部署管理安裝點

Microsoft Active Directory Deployment 支援 SolidWorks 核心產品對客戶端的部署。

Microsoft Active Directory 是一個用來管理網路環境中的客戶端及伺服端的目錄服務。它可以簡化管理、移轉及部署。

  1. 使用 SolidWorks 安裝管理員或指令列產生管理安裝點。
  2. 如果您已經使用指令列產生管理安裝點，請安裝 Windows 必要元件以便使用 Microsoft Active Directory 從管理安裝點進行安裝。詳細資訊請參閱使用 Microsoft Active Directory 安裝 Windows 必要元件。

    只有在您已經使用指令列手動產生安裝點時才執行此步驟。如果您是使用 SolidWorks 安裝管理員產生及安裝安裝點，將會自動安裝所有 Windows 必要元件。

  3. 產生一個轉換檔案來自訂 SolidWorks 的軟體：
    1. 開啟命令提示字元的視窗。
    2. 在包含管理安裝點的資料夾中，拖曳 SWCreateMST.exe 至命令提示字元的視窗中。

      指令的格式應如下：

      管理安裝點目錄\SWCreateMST.exe 至管理安裝點 MSI 檔案的路徑 屬性清單

      屬性可以是特徵屬性或整體屬性。詳細資訊請參閱命令列功能屬性 and 指令列整體屬性。

      使用下列範例作為範本：

      • 如果您在 32 位元的作業系統上安裝 SolidWorks（32 位元版本）：

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@您的伺服器"

      • 如果您在 32 位元的作業系統上安裝 SolidWorks（64 位元版本）：

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@您的伺服器"

      • 如果您在 64 位元的作業系統上安裝 SolidWorks（64 位元版本）：

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@您的伺服器"

      SolidWorks.mst 轉換檔案會在包含管理安裝點的資料夾中產生。

  4. 在 Active Directory 中，為要部署 SolidWorks 軟體的小組編輯 Published Apps 的原則。
  5. 在「群組原則」對話方塊中，展開「電腦設定」及「軟體設定」。
  6. 在軟體安裝上按右鍵，並選擇新增 > 封裝。
  7. 瀏覽至管理安裝點，然後按一下開啟。
  8. 在調配軟體對話方塊中，選擇進階發行的或指派的，然後按一下確定。
  9. 在 SolidWorks 內容對話方塊中的「修改」標籤上：
    1. 按一下加入。
    2. 瀏覽至 .mst 檔案。
    3. 按一下開啟。
  10. 按一下確定。
  • 使用 Microsoft Active Directory 安裝 Windows 必要元件
    遵照此程序以準備現有的管理安裝點，以便使用 Microsoft Windows Active Directory 將 SolidWorks 安裝至客戶端的電腦。
父主題： 命令列部署


使用 Microsoft Active Directory 安裝 Windows 必要元件

遵照此程序以準備現有的管理安裝點，以便使用 Microsoft Windows Active Directory 將 SolidWorks 安裝至客戶端的電腦。

在這些程序中，請使用適合正在部署的 SolidWorks 版本的指令。

  1. 擷取 2005 Visual C++ Redistributable Package 安裝程式然後安裝它們。
    1. 執行以下其中一個指令：

      32 位元的 Windows 版本：

      administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_target_directory}

      64 位元的 Windows 版本：

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_target_directory}

    2. 建立安裝 Microsoft C++ 2005 重新分配模組的政策：

      {2005_C++_target_directory}\vcredist.msi –

      此安裝中不需要轉換檔案。

  2. 擷取 2008 Visual C++ Redistributable Package 安裝程式然後安裝它們。
    1. 執行以下其中一個指令：

      32 位元的 Windows 版本：

      administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_target_directory}

      64 位元的 Windows 版本：

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_target_directory}

    2. 建立安裝 Microsoft C++ 2008 重新分配模組的政策：

      {2008_C++_target_directory}\vcredist.msi –

      此安裝中不需要轉換檔案。

  3. 使用 Windows Server Update Services，安裝 Microsoft .NET Framework 3.5。

    不需要在 Windows 7 或之後的版本上安裝 .NET Framework 安裝點。

  4. 擷取 Office Web Components 檔案然後安裝它們。
    1. 執行此指令：

      administrative_image_directory\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_directory}

    2. 產生一個安裝 Office Web Components 的政策：

      {Office_Web_components_directory}\owc11.MSI

      此安裝中不需要轉換檔案。

  5. 建立以下政策以安裝 Visual Studio Tools for Applications (VSTA)：

    {Microsoft_VSTA 目錄}\vsta_aide.MSI

    此安裝中不需要轉換檔案。

  6. 建立以下政策以安裝 Visual Studio Remote Debugger（只有 64 位元的版本）：

    {Microsoft_remote_debugger_目錄}\rdbgexp.MSI

    此安裝中不需要轉換檔案。

父主題： 使用 Microsoft Active Directory 部署管理安裝點


多個安裝的管理

在多個安裝中，管理工作包括將管理安裝點升級至新的版本，套用 service pack 更新以及移除安裝。

  • 升級管理安裝點至新版本
    若要更新從管理安裝點安裝的客戶端，請先更新管理安裝點，然後組態客戶端以參考安裝點的新副本。
  • Service Pack 產品更新管理
    Service Pack 產品更新可以包含對系統穩定性、程式相容性、安全性等的更新。
  • 移除安裝
    您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。
父主題： 多個安裝


升級管理安裝點至新版本

若要更新從管理安裝點安裝的客戶端，請先更新管理安裝點，然後組態客戶端以參考安裝點的新副本。

從網際網路執行 SolidWorks 安裝管理員，以便參考正確的檔案。SolidWorks 安裝管理員會將本身重新導向至此，或者您可以直接從 SolidWorks 下載網站 (http://www.solidworks.com/sw/support/downloads.htm) 執行更新。

一旦您更新了管理安裝點（會產生安裝點的新副本），您可以讓客戶端參考管理安裝點的新複製來更新客戶端。

如果客戶端使用對應的磁碟機或共用的目錄來參考之前版本的管理安裝點，您可以使用管理安裝點更新版本的位置來重新定義對應的磁碟機或共用目錄。
  • 為管理安裝點下載更新的安裝檔
    在升級管理安裝點時，如果您需要更新的安裝檔，SolidWorks 安裝管理員可以幫您偵測出來。
  • 升級管理安裝點
    若要升級管理安裝點，SolidWorks 安裝管理員會產生一個新的安裝點目錄。接著您可以指定客戶端使用新的管理安裝點目錄以升級至該產品版本。
  • 從管理安裝點升級客戶端
    SolidWorks 安裝管理員可以自動從管理安裝點升級客戶端電腦。
父主題： 多個安裝的管理


為管理安裝點下載更新的安裝檔

在升級管理安裝點時，如果您需要更新的安裝檔，SolidWorks 安裝管理員可以幫您偵測出來。

  1. 插入 DVD 來啟動 SolidWorks 安裝管理員。
  2. 在歡迎畫面中，選擇管理安裝點。
  3. 在序號畫面中輸入 SolidWorks 序號。

    SolidWorks 安裝管理員會為您所許可使用的產品及可用的 service packs 檢查 SolidWorks 網站。

  4. 如果出現有較新版本可用畫面，請選擇是，下載及安裝較新的版本: 版本。

    SolidWorks 安裝管理員啟動一個新的作業階段來安裝較新版本。

  5. 如果下載資料夾發生問題，可能會顯示下載選項。如果下載選項顯示，請接受新安裝檔案的預設目錄或是輸入新的目錄名稱。

    如果出現目錄不存在的訊息，請按一下是來產生目錄。

  6. 在下載完成的螢幕中，按一下關閉關閉目前的安裝程式並啟動新版本的安裝程式。
父主題： 升級管理安裝點至新版本


升級管理安裝點

若要升級管理安裝點，SolidWorks 安裝管理員會產生一個新的安裝點目錄。接著您可以指定客戶端使用新的管理安裝點目錄以升級至該產品版本。

此程序會假設您已經為管理安裝點下載更新的安裝檔。詳細資訊請參閱為管理安裝點下載更新的安裝檔。

  1. 啟動 SolidWorks 安裝管理員。詳細資訊請參閱初始化 SolidWorks 安裝。
  2. 在歡迎畫面中，選擇管理安裝點。

    管理安裝點的產生選項出現：

    使用預設的設定產生一個新的安裝點。
    使用預設的組態設定產生安裝點（即不根據目前為您的站點之現有管理安裝點建立的設定）。
    使用來自現有安裝點的設定及檔案來產生一個新的安裝點。
    使用為您所在站點之現有管理安裝點指定的組態設定產生安裝點。按一下瀏覽為現有的管理安裝點指定安裝目錄。
    同時產生 32 位元與 64 位元的管理安裝點。
    可以在一台電腦上產生 32 位元及 64 位元安裝點，或者只產生與該電腦架構對應的安裝點。產生兩個安裝點不需要存取 32 位元及 64 位元安裝媒體。

  3. 在序號畫面中檢查序號。
  4. 在摘要（已準備好產生安裝點）畫面中，檢查管理安裝點選項是否正確。

    如需有關個別管理安裝點與安裝選項的詳細資訊，請按一下變更進入選項頁，然後按一下說明。

  5. 若要產生管理安裝點的新版本，請按一下現在產生。

您現在可以升級客戶端為管理安裝點的新版本。詳細資訊請參閱從管理安裝點升級客戶端。

父主題： 升級管理安裝點至新版本


從管理安裝點升級客戶端

SolidWorks 安裝管理員可以自動從管理安裝點升級客戶端電腦。

管理安裝點通常安排在一個伺服器的資料夾中。要支援客戶端的自動升級，管理安裝點必須位於共用的資料夾中。

在升級管理安裝點之後，原始的安裝會在一個資料夾中，而升級的安裝在另一個資料夾中。要使用升級的安裝，您必須先從原始的管理安裝點資料夾中移除共用的選項，然後將共用的選項加入至升級的管理安裝點資料夾中。

當從原始管理安裝點安裝的 SolidWorks 在客戶端機器上啟動時，會看到新的版本並升級客戶端。

  • 從原始的管理安裝點資料夾中移除共用的選項
    在升級從共用資料夾存取的管理安裝點時，您必須從原始資料夾中移除共用的選項。
  • 將共用選項新增至升級的管理安裝點資料夾
    一旦您產生了更新的管理安裝點資料夾並且停用原始管理安裝點資料夾的共用，您必須將共用選項新增至新資料夾以便重新啟用管理安裝點。
  • 使用指令行手動升級管理安裝點的客戶端
    一旦您升級了管理安裝點，可以使用指令行手動升級客戶端。
父主題： 升級管理安裝點至新版本


從原始的管理安裝點資料夾中移除共用的選項

在升級從共用資料夾存取的管理安裝點時，您必須從原始資料夾中移除共用的選項。

  1. 瀏覽至原始管理安裝點檔案所在的資料夾。
  2. 用右鍵按一下資料夾並選擇內容。
  3. 在共用標籤中選擇不共用此資料夾，然後按一下確定。

現在將共用的選項加入至升級的管理安裝點資料夾中，如將共用選項新增至升級的管理安裝點資料夾中所述。

父主題： 從管理安裝點升級客戶端


將共用選項新增至升級的管理安裝點資料夾

一旦您產生了更新的管理安裝點資料夾並且停用原始管理安裝點資料夾的共用，您必須將共用選項新增至新資料夾以便重新啟用管理安裝點。

  1. 瀏覽至升級的管理安裝點檔案所在的資料夾。
  2. 用右鍵按一下資料夾並選擇內容。
  3. 在共用的標籤中，指定您組織或群組的共用屬性，並變更共用的名稱為原始管理安裝點資料夾使用的名稱。
啟動 SolidWorks 時，從原始管理安裝點共用位置安裝的電腦將會自動升級為新的版本。
父主題： 從管理安裝點升級客戶端


使用指令行手動升級管理安裝點的客戶端

一旦您升級了管理安裝點，可以使用指令行手動升級客戶端。

  1. 請確定所有客戶端皆擁有先前版本的相同 service pack。（尚未安裝應用程式的客戶端將不會升級。）
  2. 可選擇性的在其中一個客戶端的系統上執行複製設定精靈來擷取目前的 SolidWorks 選項。
  3. 使用 SolidWorks 安裝管理員或指令列產生新的管理安裝點。

    不要升級或覆寫先前的安裝點。
    如果要升級非英文 SolidWorks 安裝，必須為非英文安裝元件產生一個新的管理安裝點。

  4. 使用 msiexec 指令及以下規格將所有客戶端升級至新的版本：

    • 包括 /I 和 qb msiexec 指令行選項。
    • 指定任何必要的特徵和整體指令行屬性。詳細資訊請參閱命令列屬性。

    例如，要升級現有的 SolidWorks 版本：

    msiexec /I Msi 路徑" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks 版本 servicepack" /qb

    如果要升級非英文 SolidWorks 安裝，必須在升級 SolidWorks 元件之後升級非英文元件。

父主題： 從管理安裝點升級客戶端


Service Pack 產品更新管理

Service Pack 產品更新可以包含對系統穩定性、程式相容性、安全性等的更新。

您可以以兩種方式獲得產品更新：

對於目前的 SolidWorks 版本：
透過使用 SolidWorks 安裝管理員檢查、下載與安裝更新。

您可以手動啟動 SolidWorks 安裝管理員，或排定它定期檢查更新。

對於 2008 之前的 SolidWorks 版本：
從 SolidWorks 支援網站手動下載 service pack：

Service packs 是以修補程式的方式套用至現有的軟體版本上。例如，SolidWorks 2007 SP1.0 是供 SolidWorks 2007 SP0.0 使用的 service pack。您可以使用 SolidWorks 2007 安裝管理員安裝這些 service pack；您無法使用 SolidWorks 2008 或以後版本的安裝管理員安裝它們。

關於下載及安裝 service packs 的說明，請參考您所更新 SolidWorks 版本的安裝文件。

  • 以管理安裝點回溯 Service Pack
    您可以將管理安裝點回溯至較早安裝的 service pack。如果您使用磁碟片來安裝 SolidWorks 軟體，您需要原始的磁碟才能回復 service pack。您必須已儲存了較早管理安裝點影像的複製。
  • 套用 Service Pack 至以 Microsoft Active Directory 部署的客戶端
    如果您已經使用 Microsoft Active Directory 安裝 SolidWorks 軟體，可以將 service pack 套用至客戶端。
父主題： 多個安裝的管理


以管理安裝點回溯 Service Pack

您可以將管理安裝點回溯至較早安裝的 service pack。如果您使用磁碟片來安裝 SolidWorks 軟體，您需要原始的磁碟才能回復 service pack。您必須已儲存了較早管理安裝點影像的複製。

已被升級的管理安裝點不能回溯至前一個 service pack。以 SolidWorks 安裝管理員以外的任何方法建立的管理安裝點無法被回溯至之前的版本。必須先解除安裝從這些管理安裝點安裝的客戶端，然後再使用從先前版本建立的管理安裝點重新安裝。
  1. 刪除包含目前管理安裝點的資料夾。要執行此操作，請開啟命令提示字元視窗並輸入：

    rmdir /s/q 至目前管理安裝點的路徑

  2. 將管理安裝點的備份副本移至您剛才刪除的目前管理安裝點的所在位置。要執行此操作，請開啟命令提示字元視窗並輸入：

    move 至備份管理安裝點的路徑 至目前管理安裝點的路徑

    在您回溯管理安裝點之後，下一次客戶端電腦執行 SolidWorks 軟體時，會自動回溯。

父主題： Service Pack 產品更新管理


套用 Service Pack 至以 Microsoft Active Directory 部署的客戶端

如果您已經使用 Microsoft Active Directory 安裝 SolidWorks 軟體，可以將 service pack 套用至客戶端。

  1. 使用下面的指令列來複製管理安裝點至一個新的資料夾：

    xcopy 至目前管理安裝點的路徑 至備份管理安裝點的路徑 /s/i/v

  2. 套用 service pack 至管理安裝點的複製。
  3. 產生一個新的轉換檔案來指定 SolidWorks 軟體的升級安裝：
    1. 開啟命令提示字元的視窗。
    2. 在包含管理安裝點的資料夾中，拖曳 SWCreateMST.exe 至命令提示字元的視窗中。

      指令的格式是：

      至管理安裝點的路徑\SWCreateMST.exe 至管理安裝點 msi 檔案的路徑 屬性清單

      命令列必須包括用來產生原始轉換檔案的所有參數，加上整體屬性 UPGRADESWINSTALL 和 SWMIGRATE。

      例如，如果原始指令是：

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@您的伺服器

      更新的指令必須是：

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\您的資料夾" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@您的伺服器 UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks 版本 service_pack"

      SolidWorks.mst 轉換檔案會在包含管理安裝點的資料夾中產生。

      此範例中的原始與更新命令是用於在 32 位元版本的作業系統上安裝 32 位元的 SolidWorks 版本。如果您是在 64 位元的操作系統上安裝 SolidWorks 32 位元的版本，您應該使用 Intel_Modules_AgeiaX64 來取代 Intel_Modules_AgeiaX86。如果您在 64 位元的作業系統上安裝 64 位元版本的 SolidWorks，您不會使用 Intel_Modules_AgeiaX86 或 Intel_Modules_AgeiaX64。

  4. 在 Active Directory 中，為要部署 SolidWorks 軟體的群組編輯 Published Apps 的原則。
  5. 在群組原則對話方塊中，展開電腦設定及軟體設定。
  6. 在軟體安裝上按右鍵，並選擇新增 > 套裝。
  7. 瀏覽至管理安裝點，然後按一下開啟。
  8. 在調配軟體對話方塊中，選擇進階發行的或指派的，然後按一下確定。
  9. 在SolidWorks 內容對話方塊中的修改標籤上：
    1. 按一下加入。
    2. 瀏覽至 .mst 檔案。
    3. 按一下開啟。
  10. 按一下確定。
父主題： Service Pack 產品更新管理


Workgroup PDM

Workgroup PDM 應用程式是在 SolidWorks 環境內部執行的產品資料管理軟體，或作為在 SolidWorks Explorer 內的單獨應用程式。Workgroup PDM 使用取出、存回、修訂版控制的程序及其他系統管理的操作來控制專案。

Workgroup PDM 的系統如下圖所示：

  • 一部電腦只能包含一個資料保險箱。
  • 資料保險箱的目錄不能為隱藏或唯讀的目錄。
  • 作為一個客戶端/伺服器的應用程式，Workgroup PDM 的效能是取決於網路的穩健程度。
  • 如果您的使用者保持了相當多數量的文件，若您產生各專案有較少文件的更多專案或子專案，而非將文件保持在各專案有較多文件的較少專案中，則效能會有所提昇。

安裝

  • 客戶端及 VaultAdmin、API、與 Viewer 可以安裝在與資料保險箱相同的電腦上，或在不同的電腦上。
  • 不需要安裝 Workgroup PDM Server 才能安裝客戶端 API。會在安裝 Workgroup PDM Client 的過程中安裝客戶端 API。
  • 要將資料保險箱資料夾組態在一個遠端的位置，請於提示伺服器目的地時，輸入完整的通用命名慣例 (UNC) 路徑。（詳細資訊請參考UNC 格式）。
  • 安裝或升級資料保險箱需要將電腦重新開機。
  • 如果 Workgroup PDM Server Service 在重新開機之後並未自動開始，您必須手動將其啟動。在 Windows 檔案總管中，執行在安裝目錄\SolidWorks Workgroup PDM\Vault 資料夾中的 pdmwvault.exe。
  • 當您安裝 Workgroup PDM 客戶端時，您必須在每台電腦上安裝 solidworksexplorer.exe。此可執行檔可以是在共用的磁碟機上。Workgroup PDM Vault、Viewer、API Client、及 VaultAdmin 不是安裝在每個客戶端的電腦上。

使用許可

  • Workgroup PDM API 的使用許可是包括在 SolidWorks 客戶端及 Explorer 客戶端的使用許可中。存回 API 需要客戶端的使用許可。
  • 一個 Workgroup PDM Viewer 的使用許可必須與資料保險箱一起安裝才能啟用 Viewer。

許可權限

  • 資料保險箱管理員應對安裝及資料保險箱資料夾有寫入的權限。
  • 資料保險箱管理員應從 VaultAdmin 中管理資料保險箱，而不是從 Windows 檔案總管中。
  • 使用者絕不應在 Windows 檔案總管中對資料保險箱資料夾有寫入的權限。

安全性、連接埠及雙工的設定

  • Workgroup PDM 必須能夠作為 Windows 的服務來安裝，因此其他的應用程式不允許阻斷或過濾服務。例如，如果在安裝的過程中如 Microsoft AntiSpyware 等的防間諜軟體顯示要求准許的警告，請按一下 Allow 來使得 Workgroup PDM Server 可安裝為一個 Windows Service。
  • 如果您在有 Service Pack 2 的 Windows XP 系統、有 Service Pack 1 的 Windows 2003 伺服器、或有使用中防火牆的電腦上安裝 Workgroup PDM，您必須在防火牆的設定中啟用 Workgroup PDM 連接埠為例外狀況。

    一般而言，連接埠為：

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Request)
    • 80 (Viewer)
    關於變更連接埠設定的資訊，請參考 Workgroup PDM 中的 資料保險箱管理員疑難排解和 SolidWorks Explorer 說明，以及 Microsoft Windows 說明中有關資訊安全中心的部分。要同時安裝 Workgroup PDM Vault 及 Viewer，請使用安裝類型對話方塊中的自訂安裝選項。
  • 對伺服器及其相對應連接埠的雙工設定應為相同的；例如，兩者可以同時是 100MB Full，或皆為 Auto。

SolidWorks Toolbox 文件

SolidWorks Toolbox 文件是一般的硬體零組件，通常不需要修訂版的控制及並不存回至 Workgroup PDM Vault 中。有關組態 SolidWorks Toolbox 以及其他標準資料庫的詳細資訊，請參考 Workgroup PDM 線上說明。

  • Workgroup PDM Viewer
    在安裝過程中，Workgroup PDM 軟體使用 Microsoft Internet Information Services (IIS) 來自動設定一個虛擬目錄。
  • 安裝 Workgroup PDM 伺服器
    安裝 Workgroup PDM Server 會產生 Workgroup PDM 資料保險箱，此為儲存所管理的 SolidWorks 專案的資料庫。
  • 為客戶端組態 Workgroup PDM
    在您安裝了 Workgroup PDM 伺服器資料保險箱之後，您可以為客戶端組態資料保險箱。
  • 在周邊網路上安裝 Workgroup PDM 伺服器與 Viewer
    在牽涉有防火牆的周邊網路 (DMZ) 上安裝 SolidWorks Workgroup PDM Web 伺服器與 Workgroup PDM Viewer。
  • Workgroup PDM 客戶端存取
    Workgroup PDM 客戶端使用 Microsoft Windows 登入存取控制，透過 Workgroup PDM Viewer 存取網路，並且會在更新 Workgroup PDM Vault 之後自動更新。
  • Workgroup PDM VaultAdmin 管理
    在安裝 Workgroup PDM 之後，資料保險箱管理員應該會執行這些工作。


Workgroup PDM Viewer

在安裝過程中，Workgroup PDM 軟體使用 Microsoft Internet Information Services (IIS) 來自動設定一個虛擬目錄。

在安裝 Viewer 之前，您必須在電腦上安裝 Microsoft Internet Information Services (IIS)。
必要的元件包括：
  • Web Management Tools
    • IIS Management Console
  • World Wide Web Services：Application Development Features
    • .NET Extensibility
    • ASP.NET
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
IIS 安裝說明請參閱 Microsoft 的文件。
Workgroup PDM Viewer 安裝受到以下限制：
  • Web Site Content Directory 是 Viewer 的安裝資料夾。
  • 您不能為代管 Viewer 的機器名稱使用加底線的字元。
  • 如果您在 Windows XP Service Pack 2 上安裝 Viewer，必須在 Windows Firewall for HTTP (port 80) 中啟用連接埠。
  • Viewer 在任何時候只能指向一個單一的資料保險箱。

使用者可以在 Internet Explorer 位址的欄位輸入此 URL 來存取 Workgroup PDM Viewer：

http://ViewerComputerName/pdmweb/

父主題： Workgroup PDM


安裝 Workgroup PDM 伺服器

安裝 Workgroup PDM Server 會產生 Workgroup PDM 資料保險箱，此為儲存所管理的 SolidWorks 專案的資料庫。

  1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
  2. 在歡迎的螢幕中，選擇下列項目：

    • 伺服器產品
    • 在此電腦上安裝 SolidWorks Workgroup PDM Server (資料保險箱)。

  3. 在摘要螢幕中，按一下變更來取得一個驗證碼。您可以使用下列方法之一來取得驗證碼：
    • Internet 連線
      1. 在提供的欄位中輸入 SolidWorks 的序號及電子郵件地址。
      2. 選擇自動驗證，然後按一下取得驗證碼。
    • 電子郵件
      1. 如果您的電腦沒有 Internet 的連線，按一下手動經電子郵件驗證。安裝管理員會產生一個驗證要求檔案。
      2. 按一下儲存來於本機系統上儲存檔案。
      3. 根據螢幕上的指示來操作並輸入一個驗證碼。
  4. 按一下回到摘要。
  5. 在摘要的螢幕中，按一下現在安裝。
父主題： Workgroup PDM


為客戶端組態 Workgroup PDM

在您安裝了 Workgroup PDM 伺服器資料保險箱之後，您可以為客戶端組態資料保險箱。

  1. 使用預設的使用者名稱及密碼登入至 VaultAdmin（與 SolidWorks Explorer 一起安裝）。
  2. 在 VaultAdmin 中，設定使用者與群組帳號、專案資料夾、權限等。

    有關說明，請參考 Workgroup PDM 說明。

  3. 將帶有伺服器電腦名稱及客戶端使用者名稱與密碼的電子郵件寄給客戶端使用者，使用者名稱與密碼通常與 Microsoft Windows 的使用者名稱與密碼不同。
  • 設定 Workgroup PDM Viewer 連接至不同的資料保險箱位置
    您可以使用 Windows 登錄，將 Workgroup PDM Viewer 設定為連接至不同的資料保險箱位置。
  • 設定文件下載的 Mime Type
    您可以使用 Windows 登錄設定值為文件下載設定 Mime Type。
父主題： Workgroup PDM


設定 Workgroup PDM Viewer 連接至不同的資料保險箱位置

您可以使用 Windows 登錄，將 Workgroup PDM Viewer 設定為連接至不同的資料保險箱位置。

  1. 變更 Vault Computer 的值來更新登錄的路徑：

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. 重新安裝 Workgroup PDM Viewer。在資料保險箱電腦名稱對話方塊中輸入新的電腦名稱。
父主題： 為客戶端組態 Workgroup PDM


設定文件下載的 Mime Type

您可以使用 Windows 登錄設定值為文件下載設定 Mime Type。

根據系統預設，Viewer 使用一般的 mime type“application/octet-stream”傳送 Open Document 的要求。然後 Microsoft Internet Explorer 會以所提供的副檔名來開啟要求的文件。您可以在 Windows 登錄中修改 Mime Types 登錄代用鍵，以對應其他 mime type 或關閉 mime type 對應。

  • 若要對應其他的 mime type，請在登錄代用鍵底下產生其他的字串值：

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    在此表現形式中：

    "ext" = "mime type"

    例如：

    "dxf" = "image/vnd.dxf"

    在您加入值之前，必須手動產生此登錄代用鍵（sub-key）。

    若要關閉 mime type 對應，請將 Use Custom MIME Types 登錄值變更為 0 (零)。

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    不需要重新啟動 Web 伺服器來啟動此設定。

父主題： 為客戶端組態 Workgroup PDM


在周邊網路上安裝 Workgroup PDM 伺服器與 Viewer

在牽涉有防火牆的周邊網路 (DMZ) 上安裝 SolidWorks Workgroup PDM Web 伺服器與 Workgroup PDM Viewer。

因為 Workgroup PDM Viewer 客戶端是透過 HTTP 或 HTTPS 連接埠與 Web 伺服器溝通，這些連接埠在安裝 Web 伺服器的 Internet Information Server (IIS) 系統上必須是開啟的。

  • 對於 HTTP 通訊協定，預設的連接埠是 80。
  • 對於 HTTPS 通訊協定 (SSL)，預設的連接埠是 443。

Web Viewer 客戶端本身不需要有防火牆例外。

您必須確定 Web 伺服器系統可以經由這些預設的連接埠連線 Vault 伺服器：

  • 30000 (Data)
  • 40000 (Request)
  • 在周邊網路上 Workgroup PDM Viewer 的網路設定
    網路設定顯示周邊網路伺服器是設定在一周邊子網路上，並顯示其與內部及外部網路的溝通。
  • 安裝與設定 Workgroup PDM Web 伺服器 與 Viewer
    當您在周邊網路 中設定一個 Workgroup PDM Web 伺服器時，元件的安裝位置是很重要的。
父主題： Workgroup PDM


在周邊網路上 Workgroup PDM Viewer 的網路設定

網路設定顯示周邊網路伺服器是設定在一周邊子網路上，並顯示其與內部及外部網路的溝通。

周邊網路伺服器透過一內部防火牆與 LAN 溝通。其透過外部防火牆、路由器、與叢集的負載平衡器與外部網路溝通。

Internet Explorer 客戶端藉由連接埠 80（如果設定為使用 SSL 的話則為 443）與 Workgroup PDM Viewer/IIS 伺服器連線。然後 Workgroup PDM Viewer 則使用連接埠 30000 或 40000 與 Vault 伺服器連線。Vault 伺服器將要求的資訊傳送回 Workgroup PDM Viewer 中，之後再將資訊送回至 Internet Explorer 客戶端。

周邊網路 Web 伺服器有兩個 IP 位址：

  • 在 LAN 上的內部 IP 位址
  • 由 ISP 所提供的公用 IP 位址

在周邊網路上的 Web 伺服器是在位叢集的負載平衡器後方。雖然您可以為管理的工作直接到 Web 伺服器上，但在周邊網路上至伺服器的所有 Web 服務流量都是經由負載平衡器來處理的。

負載平衡器將伺服器硬體 IP 位址轉譯為一在開放於公眾的網路 leg 上的虛擬 IP (VIP)。如果您連接至網路時瀏覽至 VIP 或 Web 伺服器的 URL，您可以看到網站。

外部防火牆會將負載平衡器 VIP 轉譯為一公開、可路由的位址。

父主題： 在周邊網路上安裝 Workgroup PDM 伺服器與 Viewer


安裝與設定 Workgroup PDM Web 伺服器 與 Viewer

當您在周邊網路 中設定一個 Workgroup PDM Web 伺服器時，元件的安裝位置是很重要的。
  • 在周邊子網路上安裝啟用 IIS 的 Web 伺服器。
  • 在周邊子網路上安裝啟用 IIS 的 Workgroup PDM Viewer。
  • 在網域主控站或近端內部網路的內部網路上安裝 Workgroup PDM Vault。

在周邊網路上安裝與設定 Workgroup PDM Viewer 的先決條件是：

  • Microsoft IIS 6.0 或之後的版本
  • 在周邊網路上對 Web 伺服器的公用 IP 位址 ，其是由您的 ISP 供應商所指派的。

安裝及設定 Workgroup PDM 元件：

  1. 在周邊子網路I伺服器系統上安裝 Microsoft IIS。
  2. 執行兩個 SolidWorks Workgroup PDM 伺服器安裝：
    1. 請先在 Vault 伺服器上安裝 Vault 元件。
    2. 再次執行安裝安裝程式，然後在 IIS Web 伺服器上安裝 PDM Viewer 及 Viewer 使用許可元件。輸入資料保險箱伺服器電腦的名稱，來使得 Web portal 知道應於何處尋找 Vault 伺服器的服務。

    當您執行安裝時，會自動將 PDMWeb 應用程式加入至預設的 IIS Web 網站。

  3. 請確定至內部網路的防火牆有連接埠 30000 及 40000 是開啟的。
  4. 如果內部伺服器有固定的 IP 位址，在,周邊伺服器系統上，編輯 C:\Windows\system32\drivers\etc\hosts 檔案。產生一個對應至 IP 位址的系統名稱，來使得周邊伺服器可以與內部的伺服器溝通：
    1. 在如記事本的文字編輯器中開啟 hosts 檔案。
    2. 為 Vault 伺服器 IP 位址與名稱新增一行。
    3. 儲存 hosts 檔案。
父主題： 在周邊網路上安裝 Workgroup PDM 伺服器與 Viewer


Workgroup PDM 客戶端存取

Workgroup PDM 客戶端使用 Microsoft Windows 登入存取控制，透過 Workgroup PDM Viewer 存取網路，並且會在更新 Workgroup PDM Vault 之後自動更新。

以 Workgroup PDM 客戶端的身分登入： | 在 Workgroup PDM客戶端的使用者名稱及密碼與 Microsoft Windows 登入的帳號及密碼不同。請聯絡您的系統管理員以獲得登入的資訊。
連接至 Workgroup PDM Viewer： | 請聯絡您的系統管理員以獲得連接至 Viewer 的 URL。
更新 Workgroup PDM 客戶端： | 當資料保險箱被更新時，Workgroup PDM 客戶端（SolidWorks 附加程式及 Contributor）會偵測到。您不需要下載 service pack 來更新客戶端。
父主題： Workgroup PDM


Workgroup PDM VaultAdmin 管理

在安裝 Workgroup PDM 之後，資料保險箱管理員應該會執行這些工作。

  • 登入至 VaultAdmin。
  • 變更資料保險箱管理員的密碼。
  • 產生使用者帳號。
  • 通知使用者其帳號名稱與密碼。

詳細資訊請參閱主要 SolidWorks 說明中的 SolidWorks Workgroup PDM。

  • 初次登入 Workgroup PDM VaultAdmin
    當您第一次登入 Workgroup PDM VaultAdmin 時，請指定 Workgroup PDM 管理員名稱與密碼，以及代管 Workgroup PDM Vault 的電腦名稱。
  • 升級 Workgroup PDM Vault Server
    您可以使用 SolidWorks 的檢查更新、SolidWorks 安裝 DVD，或是 Workgroup PDM 升級檔案手動下載至本機資料夾，以升級 Workgroup PDM Vault Server。
  • 升級 Workgroup PDM 客戶端
    當資料保險箱被更新時，Workgroup PDM 客戶端會偵測到。您不需要下載 service pack 來更新客戶端。
父主題： Workgroup PDM


初次登入 Workgroup PDM VaultAdmin

當您第一次登入 Workgroup PDM VaultAdmin 時，請指定 Workgroup PDM 管理員名稱與密碼，以及代管 Workgroup PDM Vault 的電腦名稱。

  1. 在 Windows 中，按一下開始 > 所有程式 > SolidWorks 版本 > Workgroup PDM VaultAdmin。
  2. 在對話方塊中輸入下列資訊：

    名稱 | pdmwadmin
    密碼 | pdmwadmin
    資料保險箱電腦 | 安裝資料保險箱的電腦主機名稱。如果您在安裝資料保險箱的電腦上執行 VaultAdmin，請鍵入 localhost。

  3. 按一下登入。
為了安全起見，我們建議您盡快變更管理員的密碼。在 VaultAdmin 中選擇使用者及小組的標籤。
父主題： Workgroup PDM VaultAdmin 管理


升級 Workgroup PDM Vault Server

您可以使用 SolidWorks 的檢查更新、SolidWorks 安裝 DVD，或是 Workgroup PDM 升級檔案手動下載至本機資料夾，以升級 Workgroup PDM Vault Server。

您只能安裝 Workgroup PDM Vault Server 的其中一個版本
  1. 要求所有使用者登出 Workgroup PDM 資料保險箱並鎖定資料保險箱。
  2. 備份資料保險箱的資料。
  3. 使用 Microsoft Windows 控制台中的新增/移除程式移除目前的 Workgroup PDM Server 版本。
  4. 安裝 Workgroup PDM Server 的新版本。
    • 使用 SolidWorks 檢查更新：
      1. 在 Windows 中，按一下開始 > 所有程式 > SolidWorks 安裝管理員 > 檢查更新。
      2. 在有較新的版本可用對話方塊中，選擇下載及安裝新的版本，選擇要安裝的版本，然後按下一步。

        下載並執行 SolidWorks 安裝管理員的新版本。

    • 若要使用 SolidWorks 安裝 DVD，請將 DVD 放入光碟機中，並且遵照 SolidWorks 安裝管理員的指示。
    • 若要使用手動下載的 Workgroup PDM 安裝檔 (pdmwserver.exe)，請連按兩下檔案，並且遵照指示升級 Workgroup PDM Server。
  5. 使用 SolidWorks 工作排程器更新資料保險箱中的 Workgroup PDM 檔案。
  6. 解除鎖定資料保險箱並通知使用者可以繼續使用。
父主題： Workgroup PDM VaultAdmin 管理


使用許可管理

在安裝之後，您可以透過以下兩種方式啟動 SolidWorks 使用許可：啟動單機電腦（使用許可啟動），或是在伺服器上安裝並啟動浮動網路使用許可（SolidNetWork 使用許可）。

一般而言，在單機電腦上的安裝通常使用使用許可啟動；不過，您可以個別的安裝軟體，然後用 SolidNetWork 使用許可管理員來控制使用許可。反之，雖然大型的場所通常使用浮動的網路使用許可，但您可以從管理安裝點部署安裝，然後從個別的電腦上啟動序號。

  • 管理個別的使用許可
    一般而言，個別使用許可的管理包括直接從 SolidWorks 啟動和轉移使用許可。
  • 使用 SolidNetWork 使用許可管理員來管理使用許可
    SolidNetWork 使用許可管理員可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。透過浮動使用許可，可允許使用者的數目超過使用許可的數目。


管理個別的使用許可

一般而言，個別使用許可的管理包括直接從 SolidWorks 啟動和轉移使用許可。

啟動（Activation）是 SolidWorks 單套（非 SolidNetWork License）使用許可的產品授權及註冊的過程。通常如果您的產品使用許可尚未啟動，當您啟動產品時，SolidWorks 會嘗試將它啟動。

按一下 SolidWorks 中的說明 > 轉移使用許可，也能夠轉移個別的使用許可。

  • 啟動使用許可
    在您能夠在個別電腦上執行 SolidWorks 產品之前，必須啟動該電腦的使用許可。
  • 轉移使用許可
    要將使用許可轉移至新的或是已升級的電腦上，請先將其轉移至在 Dassault Systèmes SolidWorks Corporation 的使用許可授權碼伺服器上，然後在另一台電腦上重新啟動。
父主題： 使用許可管理


啟動使用許可

在您能夠在個別電腦上執行 SolidWorks 產品之前，必須啟動該電腦的使用許可。

您必須要有網際網路連線或是能使用電子郵件才能進行啟動。在啟動之後，您不需連線至網路來使用產品。如果您在使用此產品的電腦上沒有辦法使用電子郵件，您可以儲存啟動的檔案並從另一台電腦來傳送。

此過程：
  • 啟動跨越 SolidWorks 產品線的所有軟體使用許可。
  • 讓您可將使用許可的權利由一台電腦轉移至另一台電腦上。
  • 讓您能夠在一台工作電腦及一台住家電腦上安裝及啟動 SolidWorks 產品。
  • 能夠立刻執行安裝（建議）或是在 30 天內安裝。
  • 不需要使用硬體鎖。不過，如果您執行並未使用啟動的先前的 SolidWorks 產品版本，則您需要保留硬體鎖。

如果系統管理員有多個序號需要管理，您可以使用管理安裝點選項編輯器。詳細資訊請參閱管理安裝點選項編輯器。

啟動使用許可：

  1. 啟動 SolidWorks 應用程式。
  2. 使用以下方法之一啟動 SolidWorks 產品啟動：
    • 如果您尚未啟動此電腦的使用許可，當您啟動 SolidWorks 時，SolidWorks 產品啟動視窗會自動出現。
    • 如果 SolidWorks 產品啟動視窗並未自動出現，請按說明 > 啟動使用許可以開始啟動。
  3. 按一下產品清單以指定您要啟動其使用許可的產品。
  4. 指定在網際網路上自動啟動或使用電子郵件手動啟動。
  5. 提供電子郵件聯絡資訊。
  6. 按一下下一步繼續。
    • 網際網路：啟動會自動進行。
    • 電子郵件 :按儲存來產生一個要求檔案，然後將檔案以電子郵件寄至 activation@solidworks.com。當您收到包含回覆檔的電子郵件時，請從電子郵件取得檔案，然後按一下開啟將檔案載入。
      如果需要，您可以退出然後重新執行啟動程序以開啟回覆檔。
  7. 按一下完成。
父主題： 管理個別的使用許可


轉移使用許可

要將使用許可轉移至新的或是已升級的電腦上，請先將其轉移至在 Dassault Systèmes SolidWorks Corporation 的使用許可授權碼伺服器上，然後在另一台電腦上重新啟動。

如果您無法將使用許可轉移至 Dassault Systèmes SolidWorks Corporation（例如，由於硬碟機的問題），在大部分的情況中仍可成功的重新啟動。如果不行，請聯絡您的 VAR 來尋求協助。

將使用許可轉回至伺服器中：

  1. 在 SolidWorks 中，按一下說明 > 轉移使用許可，然後遵照指示進行。
  2. 要重新啟動，請於新的或升級的電腦上根據初始啟動的程序啟動使用許可。詳細資訊請參閱啟動使用許可。
父主題： 管理個別的使用許可


使用 SolidNetWork 使用許可管理員來管理使用許可

SolidNetWork 使用許可管理員可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。透過浮動使用許可，可允許使用者的數目超過使用許可的數目。

本圖描述典型的 SolidNetWork 使用許可安裝：

該圖片說明：
  • 已經安裝 SolidNetWork 使用許可管理員軟體，並且只在使用許可管理員的電腦上啟動。
  • 使用許可客戶端電腦沒有安裝任何其他特定的 SolidNetWork 軟體。

    如果您在安裝時指定了 SolidNetWork 使用許可的序號，SolidWorks 安裝管理員會將該電腦識別為 SolidNetWork 使用許可客戶端。SolidWorks 安裝管理員會提示您輸入 SolidNetWork 使用許可管理員電腦名稱，以及將客戶端與使用許可管理員連接的連接埠號碼。

  • 使用許可管理員以及所有使用許可客戶端必須擁有 TCP/IP（傳輸控制協定/網際網路協定）連線能力。
  • 啟動 SolidNetWork 使用許可
    在使用者能夠在單機電腦上執行 SolidWorks 產品之前，您必須在 SolidNetWork 使用許可管理員電腦上啟動 SolidNetWork 使用許可。
  • 轉移 SolidNetWork 使用許可
    要將 SolidNetWork 使用許可轉移至新的或是已升級的電腦上，請先將使用許可轉移至在 Dassault Systèmes SolidWorks Corporation 的使用許可授權碼伺服器上，然後在另一台電腦上重新啟動。
  • 安裝與組態 SolidNetWork 使用許可
    組態 SolidNetWork 使用許可包括在使用許可管理員電腦上安裝 SolidNetWork 使用許可管理員，然後使用 SolidNetWork 使用許可序號在客戶端電腦上安裝 SolidWorks。
  • SolidNetWork 使用許可管理
    工作包括啟動、升級以及解除安裝使用許可管理員，以及復取、借用與歸還使用許可。
父主題： 使用許可管理


啟動 SolidNetWork 使用許可

在使用者能夠在單機電腦上執行 SolidWorks 產品之前，您必須在 SolidNetWork 使用許可管理員電腦上啟動 SolidNetWork 使用許可。

您必須要有網際網路連線或是能使用電子郵件才能進行啟動。在啟動之後，您不需連線至網路來使用產品。如果您在使用此產品的電腦上沒有辦法使用電子郵件，您可以儲存啟動的檔案並從另一台電腦來傳送。

此過程：
  • 在 SolidWorks 產品中啟動 SolidWorks SolidNetWork 使用許可管理員與 SolidNetWork 使用許可。
  • 讓您可將 SolidNetWork 使用許可的權利由一台 SolidNetWork 使用許可管理員電腦轉移至另一台電腦上。
  • 讓您在 SolidNetWork 使用許可管理員電腦上安裝與啟動 SolidNetWork 使用許可。
  • 必須先執行這個動作，您才能使用 SolidNetWork 使用許可。
  • 不需要使用硬體鎖。如果您為此 SolidWorks 版本啟動了 SolidNetWork 使用許可，則先前 SolidWorks 版本的 SolidNetWork 使用許可也會啟動。（您不再需要保留硬體鎖。）

啟動 SolidNetWork 使用許可：

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 如果您尚未啟動 SolidNetWork 使用許可，系統會詢問您是否要現在啟動。按一下是以繼續。
  3. 在您要如何啟動？之下，選擇自動在 Internet 上 (建議使用)。
  4. 在聯絡人資訊之下，指定一個電子郵件聯絡人位址。
啟動/重新啟動成功對話方塊會顯示已經啟動的產品。
父主題： 使用 SolidNetWork 使用許可管理員來管理使用許可


轉移 SolidNetWork 使用許可

要將 SolidNetWork 使用許可轉移至新的或是已升級的電腦上，請先將使用許可轉移至在 Dassault Systèmes SolidWorks Corporation 的使用許可授權碼伺服器上，然後在另一台電腦上重新啟動。

如果您無法將使用許可轉移至 Dassault Systèmes SolidWorks Corporation（例如，由於硬碟機的問題），在大部分的情況中仍可成功的重新啟動。如果不行，請聯絡您的 VAR 來尋求協助。

將 SolidNetWork 使用許可轉回至伺服器中：

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。

  2. 在使用許可資訊之下，按一下修正。SolidWorks 產品啟動精靈將會啟動。
  3. 在您想執行的工作？之下，選擇轉移軟體使用許可然後按下一步。
  4. 在您要如何轉移？之下，選擇自動在 Internet 上 (建議使用)。
  5. 在聯絡人資訊之下，指定一個電子郵件聯絡人位址。
  6. 按一下下一步。產品使用許可轉移完成。
父主題： 使用 SolidNetWork 使用許可管理員來管理使用許可


安裝與組態 SolidNetWork 使用許可

組態 SolidNetWork 使用許可包括在使用許可管理員電腦上安裝 SolidNetWork 使用許可管理員，然後使用 SolidNetWork 使用許可序號在客戶端電腦上安裝 SolidWorks。

  • 安裝與啟動使用許可管理員
    SolidNetWork 使用許可管理員支援多個使用許可客戶端。它可以將使用許可分配到網路中的客戶端上。
  • 安裝使用許可客戶端
    在 SolidNetWork 使用許可客戶端電腦上安裝 SolidWorks 時，序號會將該電腦識別為 SolidNetWork 使用許可客戶端。
  • 在安裝使用許可客戶端前安裝 SolidNetWork 使用許可管理員
    在安裝任何 SolidNetWork 使用許可客戶端電腦之前，您應該在至少一台電腦上安裝與組態 SolidNetWork 使用許可管理員。
  • 三合一 (Triad ) 使用許可管理員安裝
    三合一使用許可管理員使用三台電腦以獲得額外的穩定。如果無法使用管理使用許可檔案的電腦，另外的兩台電腦可以取代。
  • 使用 SolidNetWork 使用許可與防火牆
    如果您的電腦有使用防火牆，您必須設定連接埠以支援 SolidNetWork 使用許可。
父主題： 使用 SolidNetWork 使用許可管理員來管理使用許可


安裝與啟動使用許可管理員

SolidNetWork 使用許可管理員支援多個使用許可客戶端。它可以將使用許可分配到網路中的客戶端上。

如果您是從因產品啟動而使用硬體鎖的 SolidNetWork License 管理員先前版本來升級，請在安裝新版本的 SolidNetWork License 管理員之前先移除硬體鎖。

  1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
    1. 至於安裝類型，請選擇下列：

      • 伺服器產品
      • 在此電腦上安裝 SolidNetWork License Manager（分配的使用許可）。

    2. 在 SolidNetWork License Manager 選項頁面中，指定 SolidNetWork License 序號及 SolidNetWork License Manager 安裝位置。
    3. 在摘要頁面中，按一下馬上安裝完成 SolidWorks 安裝管理員程序。
  2. 啟動 SolidNetWork 的使用許可：
    1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
    2. 當系統提示您啟動時，按一下是。
    3. 在 SolidNetWork 使用許可伺服器資訊畫面中：

      • 如果您的公司使用防火牆，請選擇在此伺服器上有正在使用的防火牆。

        詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。

      • 使用連接埠號碼（及 Vendor Daemon 連接埠號碼－如果您有防火牆的話）的預設值，或指定您公司使用的連接埠號碼。
        連接埠號碼為介於 1024-60000 範圍的 TCP/IP 連接埠號碼，由此程序專用。通常預設值 (25734) 是適當且較不可能與目前在使用許可管理員伺服器上的其他 FLEXnet 伺服器處理程序相同。

    4. 在啟動您的 SolidWorks 產品畫面中：

      • 選擇 Internet 或電子郵件的程序。
      • 提供電子郵件聯絡資訊。
      • 按一下下一步繼續。
        • Internet：啟動會自動進行。
        • 電子郵件：按儲存以產生一個要求檔，然後將檔案傳送至 activation@solidworks.com。當您收到包含回覆檔的電子郵件時，請從電子郵件取得檔案，然後按一下開啟將檔案載入。
          如果需要，您可以退出然後重新執行啟動程序以開啟回覆檔。

  3. 按一下完成。
父主題： 安裝與組態 SolidNetWork 使用許可


安裝使用許可客戶端

在 SolidNetWork 使用許可客戶端電腦上安裝 SolidWorks 時，序號會將該電腦識別為 SolidNetWork 使用許可客戶端。

  1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
  2. 如果這是這台電腦第一次安裝 SolidWorks 的主要版本，在歡迎畫面上按一下單機安裝 (在此電腦上)。

    如果您正在從現有的版本升級，同時要從單機使用許可變更為 SolidNetWork 使用許可，請按一下修改單機安裝 (在此電腦上)。。詳細資訊請參閱從單機使用許可升級為 SolidNetWork 使用許可。

  3. 當系統提示您輸入序號時，請輸入 SolidNetWork 使用許可序號。
  4. 在新增伺服器對話方塊中，以下列的形式輸入 SolidNetWork 使用許可管理員的位址：

    連接埠號碼@電腦名稱

    連接埠號碼必須與使用許可管理員電腦所使用的相同。預設號碼為 25734（如安裝與啟動使用許可管理員所述）。

    SolidWorks 安裝管理員會嘗試驗證此 SolidNetWork 使用許可管理員是否可存取。如果您尚未安裝使用許可管理員，則此項驗證將會失敗；然而您仍然可以繼續使用許可客戶端安裝。

  5. 遵照 SolidWorks 安裝管理員指示完成 SolidWorks 安裝。
父主題： 安裝與組態 SolidNetWork 使用許可


在安裝使用許可客戶端前安裝 SolidNetWork 使用許可管理員

在安裝任何 SolidNetWork 使用許可客戶端電腦之前，您應該在至少一台電腦上安裝與組態 SolidNetWork 使用許可管理員。

使用 SolidNetWork 使用許可序號安裝時，SolidWorks 安裝管理員會提示您輸入 SolidNetWork 使用許可管理員電腦名稱與連接埠號碼，然後嘗試驗證該資訊。

如果您尚未在指定的電腦上安裝 SolidNetWork 使用許可管理員，此項驗證將不會成功。然而在此情況下，驗證失敗並不會指出您提供的使用許可管理員資訊是否正確。如果已經安裝使用許可管理員，驗證失敗表示您指定了不正確的使用許可管理員資訊。

父主題： 安裝與組態 SolidNetWork 使用許可


三合一 (Triad ) 使用許可管理員安裝

三合一使用許可管理員使用三台電腦以獲得額外的穩定。如果無法使用管理使用許可檔案的電腦，另外的兩台電腦可以取代。

使用三合一使用許可管理員的要求條件：
  • 需要三個硬體鎖。
  • 只能在穩定而不會常被關機的電腦上安裝三合一使用許可管理員。
  • 三台使用許可管理員電腦應該是在同一個子網路上，絕對不要使用慢速傳輸或是電話撥接組態三合一使用許可管理員。
  • 當使用許可管理員電腦當機時，系統管理者應該偵測出來並且儘快地重新啟動。
    如果只有兩台使用許可管理員電腦在執行，這個狀況比使用單一使用許可管理員電腦更糟，因為存在了兩個失敗點。
  • 安裝初始三合一使用許可管理員
    三合一使用許可管理員使用三台電腦以獲得額外的穩定。此程序會顯示如何將 SolidNetWork 使用許可管理員安裝在三合一電腦中的第一台電腦上。
  • 在後續的電腦上安裝三合一使用許可管理員
    三合一使用許可管理員使用三台電腦以獲得額外的穩定。此程序會顯示如何將 SolidNetWork 使用許可管理員安裝在三合一電腦中的第二台與第三台電腦上。
父主題： 安裝與組態 SolidNetWork 使用許可


安裝初始三合一使用許可管理員

三合一使用許可管理員使用三台電腦以獲得額外的穩定。此程序會顯示如何將 SolidNetWork 使用許可管理員安裝在三合一電腦中的第一台電腦上。

  1. 在第一台三合一使用許可管理員電腦中，使用 SolidWorks 安裝管理員來安裝 SolidNetWork 使用許可管理員：
    1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
    2. 至於安裝類型，請選擇下列：

      • 伺服器產品
      • 在此電腦上安裝 SolidNetWork License Manager（分配的使用許可）。

    3. 在 SolidNetWork License Manager 選項頁面中，指定 SolidNetWork License 序號及 SolidNetWork License Manager 安裝位置。
    4. 在摘要頁面中，按一下馬上安裝完成 SolidWorks 安裝管理員程序。
  2. 使用 SolidNetWork 使用許可管理員，組態初始三合一使用許可管理員電腦：
    1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
    2. 按一下否。

      SolidWorks SolidNetwork 使用許可管理員的伺服器管理標籤會出現。

    3. 在進階選項之下，按一下選項。

      進階選項對話方塊出現。

    4. 在 SolidNetWork 伺服器使用許可之下，按一下使用使用許可檔案，然後按確定。

      進階選項對話方塊關閉。

    5. 在使用許可資訊之下，按一下修正。

      SolidNetWork 使用許可檔案精靈出現。

    6. 在伺服器類型之下，選擇三合一，然後按一下下一步。
    7. 在伺服器資訊窗格中，確認初始三合一使用許可管理員電腦的名稱、硬體鎖 ID 以及連接埠號碼是正確的，然後按下一步。

      如果您的電腦有使用防火牆，您可能需要在螢幕上訂出某些其他規格。詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。

    8. 在三合一搭配伺服器資訊畫面中，為其他兩台三合一使用許可管理員電腦輸入電腦名稱以及硬體鎖 ID 值。

      如此可確保如果有一個使用許可管理員無法使用，客戶端電腦仍然能夠從其他兩台伺服器取得使用許可。

    9. 在使用許可畫面中，按一下讀取以瀏覽及開啟 SolidNetWork 使用許可檔案。

      使用許可出現在 SolidNetWork 使用許可檔案精靈中。

    10. 按一下完成。
    11. 按一下確定以結束 SolidNetWork 使用許可檔案精靈，然後按完成以結束 SolidNetWork 使用許可管理員。
父主題： 三合一 (Triad ) 使用許可管理員安裝


在後續的電腦上安裝三合一使用許可管理員

三合一使用許可管理員使用三台電腦以獲得額外的穩定。此程序會顯示如何將 SolidNetWork 使用許可管理員安裝在三合一電腦中的第二台與第三台電腦上。

在此假設您已經在其他電腦中安裝了至少一個三合一使用許可管理員。詳細資訊請參閱安裝初始三合一使用許可管理員。

  1. 在三合一使用許可管理員電腦中，使用 SolidWorks 安裝管理員來安裝 SolidNetWork 使用許可管理員：
    1. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
    2. 至於安裝類型，請選擇下列：

      • 伺服器產品
      • 在此電腦上安裝 SolidNetWork License Manager（分配的使用許可）。

    3. 在 SolidNetWork License Manager 選項頁面中，指定 SolidNetWork License 序號及 SolidNetWork License Manager 安裝位置。
    4. 在摘要頁面中，按一下馬上安裝完成 SolidWorks 安裝管理員程序。
  2. 使用 SolidNetWork 使用許可管理員，組態三合一使用許可管理員電腦：
    1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。

      由於這是您第一次在此電腦上執行 SolidNetWork 使用許可管理員，系統會詢問您是否要現在啟動。

    2. 按一下否。

      SolidWorks SolidNetwork 使用許可管理員的伺服器管理標籤會出現。

    3. 在進階選項之下，按一下選項。

      進階選項對話方塊出現。

    4. 在 SolidNetWork 伺服器使用許可之下，按一下使用使用許可檔案，然後按確定。

      進階選項對話方塊關閉。

    5. 在使用許可資訊之下，按一下修正。

      SolidNetWork 使用許可檔案精靈出現。

    6. 在伺服器類型之下，選擇三合一和同步化伺服器/使用許可資訊，然後按下一步。
    7. 在伺服器資訊窗格中，確認此三合一使用許可管理員電腦的名稱、硬體鎖 ID 以及連接埠號碼是正確的，然後按下一步。

      如果您的電腦有使用防火牆，您可能需要在螢幕上訂出某些其他規格。詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。

    8. 在三合一搭配伺服器資訊畫面中，為其他兩台三合一使用許可管理員電腦輸入電腦名稱以及硬體鎖 ID 值。

      如此可確保如果有一個使用許可管理員無法使用，客戶端電腦仍然能夠從其他兩台伺服器取得使用許可。

    9. 在使用許可畫面中，按一下讀取以瀏覽及開啟 SolidNetWork 使用許可檔案。

      使用許可檔案通常是位於您組態的第一台三合一使用許可管理員電腦中的 \licenses\sw_d.lic。

      使用許可出現在 SolidNetWork 使用許可檔案精靈中。

    10. 按一下完成。

      SolidNetWork 使用許可檔案精靈警告出現。

    11. 按一下確定以結束 SolidNetWork 使用許可檔案精靈，然後按完成以結束 SolidNetWork 使用許可管理員。

如果您正在組態第二台三合一使用許可管理員電腦，請在第三台三合一使用許可管理員電腦中重複此程序。

父主題： 三合一 (Triad ) 使用許可管理員安裝


使用 SolidNetWork 使用許可與防火牆

如果您的電腦有使用防火牆，您必須設定連接埠以支援 SolidNetWork 使用許可。

在防火牆軟體中，您必須將兩個 SolidNetWork 使用許可連接埠（例如 SNL-in-port 和 SNL-out-port）新增至防火牆例外清單中。如需有關組態這些連接埠的詳細資訊，請向系統管理員詢問。

如果您是在 Windows XP SP2 和 Windows Server 2003 SP1 作業系統中使用 Windows 防火牆，您必須在 SolidNetWork 使用許可管理員電腦上修改連接埠，然後修改 SolidNetWork 使用許可檔案，將使用許可傳送至使用許可客戶端電腦。

  • 修改 Windows 防火牆的使用許可管理員電腦連接埠
    如果您正在使用 Windows 防火牆，您必須在 SolidNetWork 使用許可管理員電腦上修改防火牆連接埠的設定。
  • 修改 Windows 防火牆中的 SolidNetWork 使用許可管理員設定
    如果您有使用 Windows 防火牆，您必須修改 SolidNetWork 使用許可檔案，以便使用防火牆連接埠將使用許可散佈至使用許可客戶端電腦。
父主題： 安裝與組態 SolidNetWork 使用許可


修改 Windows 防火牆的使用許可管理員電腦連接埠

如果您正在使用 Windows 防火牆，您必須在 SolidNetWork 使用許可管理員電腦上修改防火牆連接埠的設定。

  1. 在 Windows 中開啟控制台，然後連按兩下資訊安全中心。
  2. 按一下 Windows 防火牆。
  3. 在例外 標籤中，按一下 新增連接埠。
  4. 輸入名稱（例如 SNL-in-port）和連接埠號碼（例如 25734）然後按一下確定。
  5. 在第二個連接埠中，再次按一下例外標籤中的新增連接埠，指定連接埠號碼的名稱與號碼（例如 SNL-out-port 和 25735），然後按一下確定。記下連接埠號碼，因為以後修改 SolidNetWork 使用許可檔案時需要參考它。

    如果您使用 Workgroup PDM，您必須在 Windows 防火牆中修改 Workgroup PDM 連接埠號碼。通常這些連接埠為 20000 (VaultAdmin)、30000 (Data)、40000 (Request) 和 80 (Viewer)。

  6. 關閉 Windows 資訊安全中心以及控制台。
父主題： 使用 SolidNetWork 使用許可與防火牆


修改 Windows 防火牆中的 SolidNetWork 使用許可管理員設定

如果您有使用 Windows 防火牆，您必須修改 SolidNetWork 使用許可檔案，以便使用防火牆連接埠將使用許可散佈至使用許可客戶端電腦。

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 在伺服器管理標籤中的使用許可伺服器之下，按一下停止。（系統提示確認時按一下是然後按確定完成停止使用許可伺服器。）
  3. 在使用許可資訊之下，按一下修正。
  4. 在伺服器類型之下，選擇您網路的伺服器安排（單機或三合一），然後按下一步。
  5. 在伺服器資訊之下：
    1. 選擇在此伺服器上有正在使用的防火牆。
    2. 連接埠號碼和 Vendor Daemon 連接埠號碼應該包含為 Windows 防火牆指定的連接埠號碼（詳細資訊請參閱修改 Windows 防火牆的使用許可管理員電腦連接埠）。
    3. 按一下下一步，然後按一下完成。
  6. 在伺服器管理標籤中的使用許可伺服器之下，按一下開始。
  7. 按一下確定以關閉 SolidNetWork 使用許可管理員。
父主題： 使用 SolidNetWork 使用許可與防火牆


SolidNetWork 使用許可管理

工作包括啟動、升級以及解除安裝使用許可管理員，以及復取、借用與歸還使用許可。

  • 啟動 SolidNetWork 使用許可管理員
    您可以從 Windows 開始功能表啟動 SolidNetWork 使用許可管理員。
  • 升級 SolidNetWork 使用許可管理員
    在 SolidWorks 的主要版本中，升級使用許可管理員包括解除安裝舊的使用許可管理員，安裝新的使用許可管理員，以及重新啟動 SolidNetWork 使用許可。
  • 刪除 SolidNetWork 使用許可檔案
    在升級至新檔案之前，請先刪除舊的和已過期的 SolidNetWork 使用許可檔案。
  • 復取客戶端使用許可
    若要終止客戶端 SolidNetWork 連線，系統管理員可以停止使用許可，並且將它歸還至免費的使用許可池中。
  • 借用與歸還 SolidNetWork 使用許可
    您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。由於使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。
  • 監控使用許可閒置時間
    SolidWorks 能讓您在 SolidNetWork 使用許可管理員上登記許可閒置的時間，所以使用許可在一段特定時間未被使用後，可以重新回到自由許可的控制池內。
  • 安裝暫時性的使用許可
    如果原始的 SolidNetWork 使用許可無法使用，可以使用暫時性的 "ANY" 使用許可。
  • 從單機使用許可升級為 SolidNetWork 使用許可
    在 SolidWorks 安裝管理員中指定 SolidNetWork 使用許可序號，您就可以將電腦從單機 SolidWorks 使用許可升級為 SolidNetWork 使用許可。
  • 使用有附加產品的 SolidNetWork 使用許可
    您可以使用 SolidNetWork 使用許可管理員來分配 SolidWorks 的核心附加產品的使用許可（例如 FeatureWorks、Workgroup PDM Server 等等）。
  • 在使用許可管理員和管理安裝點安裝時使用同一部電腦
    您可以在網路上將一台電腦設定為散佈 SolidNetWork 使用許可的使用許可管理員，以及作為管理安裝點的位置（使用者可以透過它安裝 SolidWorks 軟體）。
  • FLEXnet Publisher 使用許可管理
    SolidNetWork 使用許可是以 FLEXnet Publisher® 使用許可管理為基礎。
父主題： 使用 SolidNetWork 使用許可管理員來管理使用許可


啟動 SolidNetWork 使用許可管理員

您可以從 Windows 開始功能表啟動 SolidNetWork 使用許可管理員。

  • 在 Windows 中，執行此指令：開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員。
父主題： SolidNetWork 使用許可管理


升級 SolidNetWork 使用許可管理員

在 SolidWorks 的主要版本中，升級使用許可管理員包括解除安裝舊的使用許可管理員，安裝新的使用許可管理員，以及重新啟動 SolidNetWork 使用許可。

較新版本的使用許可管理員也可以為仍然使用先前版本的客戶端電腦散佈使用許可。

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 在使用許可使用的標籤中，確認在網路上沒有客戶端電腦執行 SolidWorks。
  3. 解除安裝舊的使用許可管理員。詳細資訊請參閱解除安裝 SolidNetWork 使用許可管理員。
  4. 安裝新的使用許可管理員以及在使用許可管理員電腦上重新啟動 SolidNetWork 使用許可。詳細資訊請參閱安裝與啟動使用許可管理員。

如果您在升級 SolidNetWork 使用許可管理員時使用的電腦同時也有執行 SolidWorks 應用程式，請先升級 SolidNetWork 使用許可管理員和客戶端，然後再在該電腦上安裝任何新的 SolidWorks 應用程式 service pack。

如果您在代管管理安裝點的電腦上升級使用許可管理員，請先升級使用許可管理員然後再升級管理安裝點。詳細資訊請參閱在使用許可管理員和管理安裝點安裝時使用同一部電腦。

  • 解除安裝 SolidNetWork 使用許可管理員
    在升級 SolidNetWork 使用許可管理員時，您必須解除安裝舊的使用許可管理員，然後才能安裝新的管理員。
父主題： SolidNetWork 使用許可管理


解除安裝 SolidNetWork 使用許可管理員

在升級 SolidNetWork 使用許可管理員時，您必須解除安裝舊的使用許可管理員，然後才能安裝新的管理員。

  1. 啟動 SolidNetwork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 請確認網路上沒有客戶端電腦正在執行 SolidWorks。

    使用許可使用標籤顯示正在執行 SolidWorks 的客戶端。

  3. 如果您想要將 SolidNetWork 使用許可轉移至其他電腦，請先將使用許可轉移至該電腦，然後再從此電腦移除 SolidNetWork 使用許可管理員。

    如需有關轉移 SolidNetWork 使用許可的資訊，請參閱轉移 SolidNetWork 使用許可。

  4. 在伺服器管理標籤中的使用許可伺服器之下，按一下停止。
  5. 按一下確定來離開使用許可管理員。
  6. 在 Windows 中，開啟控制台 > 新增或移除程式。
  7. 選擇 SolidWorks SolidNetWork 使用許可管理員，按一下移除，然後確認刪除。
  8. 在 Windows 檔案總管中，刪除 SolidWorks SolidNetWork 使用許可管理員資料夾。

    （此資料夾通常是位於 SolidWorks 安裝目錄中的 Program Files 之下。）

您現在已經準備好安裝新的使用許可管理員版本。詳細資訊請參閱安裝與啟動使用許可管理員。

如果 SolidNetWork License 管理員電腦有一附加的硬體鎖，請在安裝新版本的 SolidNetWork License 管理員之前先移除硬體鎖。
父主題： 升級 SolidNetWork 使用許可管理員


刪除 SolidNetWork 使用許可檔案

在升級至新檔案之前，請先刪除舊的和已過期的 SolidNetWork 使用許可檔案。

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 在伺服器管理員標籤的使用許可檔案之下，按一下修改，然後持續按下一步直到您到達使用許可畫面。
  3. 在使用許可畫面中，選擇舊的或過期的 SolidNetWork 使用許可檔案，然後按一下移除。
  4. 按一下完成，然後按一下確定。
父主題： SolidNetWork 使用許可管理


復取客戶端使用許可

若要終止客戶端 SolidNetWork 連線，系統管理員可以停止使用許可，並且將它歸還至免費的使用許可池中。

  • 客戶端必須至少連線至使用許可管理員中兩分鐘。
  • 您可以將 SolidNetWork 終止時間功能設定為 15 分鐘的最小值。在 15 分鐘的閒置時間之後，該使用許可會回到可用的使用許可池中。

詳細資訊請參閱SolidNetWork 使用許可管理員安裝目錄\Docs\flexuser\licensingenduserguide.pdf。

  1. 按一下開始 > 執行，輸入 cmd 然後按確定以開啟 Windows 命令視窗。
  2. 在命令視窗中輸入：

    cd SolidNetWork 使用許可管理員安裝目錄\utils lmutil lmremove 特徵 使用者 電腦 顯示器

    其中 '特徵'、'使用者'、'電腦' 和 '顯示器' 都是 SolidNetWork 使用許可管理員的使用許可使用標籤上顯示的名詞。

    例如：

    lmutil lmremove solidworks carlos designcmp1 corpserver

    您必須分別為每個附加產品（PhotoView 360、FeatureWorks 等）終止使用許可。

父主題： SolidNetWork 使用許可管理


借用與歸還 SolidNetWork 使用許可

您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。由於使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

借出的使用許可只有在借用的系統中有效；借出的使用許可無法被轉移。

使用許可可被借出一段特定的時間，最多 30 天（或由您的系統管理員來定義），使用許可會從可用的使用許可控制池中被移除。

系統管理員可以自訂借用來：
  • 定義可借用使用許可的使用者或小組。
  • 設定無法被借出的使用許可數量

詳細資訊請參閱SolidNetWork 使用許可管理員安裝目錄\Docs\flexuser\licensingenduserguide.pdf。

  • 借用 SolidNetWork 使用許可
    您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。
  • 歸還借用的 SolidNetWork 使用許可
    由於借用的 SolidNetWork 使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。
父主題： SolidNetWork 使用許可管理


借用 SolidNetWork 使用許可

您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。

您必須連線至 SolidNetWork 使用許可管理員才能借用使用許可，但是並不一定要使用。

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 在使用許可的借用標籤中：
    1. 在借用直至中選擇一個日期。
    2. 選擇要借用的產品，然後按一下借用，然後按一下是來確認。
    3. 按一下重新整理。失效日期欄位表示使用許可到期歸還的時間。
  3. 按一下確定。
若要執行 SolidWorks，您必須借用 SolidWorks 使用許可。SolidWorks Professional 及 SolidWorks Premium 使用許可僅啟用與其相關的附加程式，而不是 SolidWorks。
父主題： 借用與歸還 SolidNetWork 使用許可


歸還借用的 SolidNetWork 使用許可

由於借用的 SolidNetWork 使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

  1. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  2. 在使用許可的借用標籤中：
    1. 選擇要歸還的產品，然後按一下歸還，然後按一下是來確認。
    2. 按一下重新整理。失效日期欄位變為空白，表示使用許可已被歸還。
  3. 按一下確定。
在失效日期之後就不需要歸還使用許可。使用許可會在失效日期的午夜歸還至 SolidNetWork 使用許可管理員池中，而遠端系統中的應用程式將不再執行。
父主題： 借用與歸還 SolidNetWork 使用許可


監控使用許可閒置時間

SolidWorks 能讓您在 SolidNetWork 使用許可管理員上登記許可閒置的時間，所以使用許可在一段特定時間未被使用後，可以重新回到自由許可的控制池內。

  1. 在 SolidNetwork 使用許可管理員安裝目錄中，產生一個文字檔：

    SolidNetWork 使用許可管理員安裝目錄\Licenses\sw_d.opt

  2. 加入下列的各行至檔案中：

    TIMEOUTALL 秒

    其中秒是大於或等於 900（即 15 分鐘，15 分鐘是所允許的最小時間）的數字。

父主題： SolidNetWork 使用許可管理


安裝暫時性的使用許可

如果原始的 SolidNetWork 使用許可無法使用，可以使用暫時性的 "ANY" 使用許可。

安裝 "ANY" 使用許可檔案，即表示您同意在從 Dassault Systèmes SolidWorks Corporation 收到 SolidNetWork 使用許可時執行傳統的使用許可。仍然需要遵守使用許可的限制。

安裝 "ANY" 使用許可：

  1. 如果您已經是 SolidNetWork 的使用者，請解除安裝 SolidNetWork 使用許可管理員，然後刪除安裝資料夾。詳細資訊請參閱解除安裝 SolidNetWork 使用許可管理員。
  2. 啟動 SolidWorks 安裝管理員（如初始化 SolidWorks 安裝所述）。
    1. 至於安裝類型，請選擇下列：

      • 伺服器產品
      • 在此電腦上安裝 SolidNetWork License Manager（分配的使用許可）。

    2. 在 SolidNetWork License Manager 選項頁面中，指定 SolidNetWork License 序號及 SolidNetWork License Manager 安裝位置。
    3. 在摘要頁面中，按一下馬上安裝完成 SolidWorks 安裝管理員程序。
  3. 啟動 SolidNetWork 使用許可管理員（開始 > 程式集 > SolidWorks 版本 > SolidNetWork 使用許可管理員 > SolidNetWork 使用許可管理員）。
  4. 如果系統提示您啟動，請按一下否。

    SolidWorks SolidNetwork 使用許可管理員的伺服器管理標籤會出現。

  5. 在進階選項之下，按一下選項。

    進階選項對話方塊出現。

  6. 在 SolidNetWork 伺服器使用許可之下，按一下使用使用許可檔案，然後按確定。

    進階選項對話方塊關閉。

  7. 在使用許可資訊之下，按一下修正。

    SolidNetWork 使用許可檔案精靈出現。

  8. 在伺服器類型之下，選擇單一機型（Single）然後按一下下一步。
  9. 當您看見此訊息：

    無法讀取硬體鎖 ID 號碼。
    按一下取消。
    ID "ANY" 自動出現。
    如果您的電腦有使用防火牆，您可能需要在螢幕上訂出某些其他規格。詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。

  10. 繼續安裝。
父主題： SolidNetWork 使用許可管理


從單機使用許可升級為 SolidNetWork 使用許可

在 SolidWorks 安裝管理員中指定 SolidNetWork 使用許可序號，您就可以將電腦從單機 SolidWorks 使用許可升級為 SolidNetWork 使用許可。

如果電腦中並沒有安裝 SolidWorks，當您在使用 SolidWorks 安裝管理員進行安裝時，可以輸入 SolidNetWork 序號以指定 SolidNetWork 使用許可。

如果電腦中已經安裝 SolidWorks，同時您正在從單機使用許可轉換為 SolidNetWork 使用許可，您可以在執行 SolidWorks 安裝管理員時為客戶端電腦修改安裝並且指定 SolidNetWork 使用許可序號，以取代單機使用許可序號。詳細資訊請參閱修改安裝。

父主題： SolidNetWork 使用許可管理


使用有附加產品的 SolidNetWork 使用許可

您可以使用 SolidNetWork 使用許可管理員來分配 SolidWorks 的核心附加產品的使用許可（例如 FeatureWorks、Workgroup PDM Server 等等）。

  • 不需要有相同數量的 SolidWorks 軟體使用許可與 SolidWorks 附加程式使用許可。
  • 若要查看附加產品的使用許可，您必須先查看 SolidWorks 的使用許可。
  • 若要借用附加產品的使用許可，您必須同時借用 SolidWorks 軟體使用許可以及包括附加的 SolidWorks 產品使用許可。例如，您可能需要借用 SolidWorks Professional 或 SolidWorks Premium 的產品使用許可。
  • 釋放一個附加的產品的使用許可：
    • 在 SolidWorks 中，按一下工具 > 附加然後清除附加產品。
    • 離開 SolidWorks。
父主題： SolidNetWork 使用許可管理


在使用許可管理員和管理安裝點安裝時使用同一部電腦

您可以在網路上將一台電腦設定為散佈 SolidNetWork 使用許可的使用許可管理員，以及作為管理安裝點的位置（使用者可以透過它安裝 SolidWorks 軟體）。

客戶端電腦可以從使用許可管理員獲得使用許可，然後從同一部電腦安裝 SolidWorks。

此種組態要求使用許可管理員及管理安裝點安裝在同一部電腦上。先安裝使用許可管理員，然後產生與部署管理安裝點。
詳細資訊請參閱：
  • 安裝與啟動使用許可管理員
  • 部署至多個客戶端
父主題： SolidNetWork 使用許可管理


FLEXnet Publisher 使用許可管理

SolidNetWork 使用許可是以 FLEXnet Publisher® 使用許可管理為基礎。

如需更多有關 FLEXnet Publisher 使用許可管理的資訊，請參閱 SolidNetwork 使用許可管理員安裝目錄（SolidNetwork 使用許可管理員安裝目錄\Docs\flexuser\licensingenduserguide.pdf）中的 FLEXnet Publisher 使用許可管理指南。

如需有關 FLEXnet Publisher 使用許可管理的最新資訊，請聯絡 Acresso® Software。

父主題： SolidNetWork 使用許可管理


疑難排解

請參閱這些主題以協助您解決安裝問題。

  • SolidWorks 安裝管理員記錄檔案
    SolidWorks 安裝管理員記錄檔案能夠協助您解決安裝上的問題。
  • SolidWorks 安裝管理員下載資料夾
    SolidWorks 安裝管理員可下載其所需要的安裝檔案至您指定的資料夾中。這些主題提供您關於下載資料夾常見問題的答案。
  • SolidNetWork 使用許可疑難排解
    如果 SolidNetWork 使用許可管理員安裝失敗，請檢查這些可能的說明。
  • 升級的疑難排解
    如果您在升級新的 SolidWorks 版本時遇到問題，請查看這些可能有用的說明。


SolidWorks 安裝管理員記錄檔案

SolidWorks 安裝管理員記錄檔案能夠協助您解決安裝上的問題。

這些記錄檔案的位置與其他 SolidWorks 應用程式記錄檔案的位置相同。
  • 對於 Windows Vista 或之後的版本：

    C:\Users\使用者名稱\AppData\Roaming\SolidWorks\Installation Logs\安裝的版本

  • 對於 Vista 之前的 Windows 作業系統版本：

    C:\Documents and Settings\使用者名稱\Application Data\SolidWorks\Installation Logs\安裝的版本\

要查看記錄檔案目錄，您可以將 Windows 資料夾選項設定為顯示隱藏的檔案及資料夾。

如果應用程式資料並非位於 C: 磁碟機，請根據情況調整目錄路徑。

此目錄包含 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 檔案，該檔案是 SolidWorks 安裝管理員進度的一般記錄。

Other Logs 子目錄中包含更多詳細的安裝記錄資訊。

父主題： 疑難排解


SolidWorks 安裝管理員下載資料夾

SolidWorks 安裝管理員可下載其所需要的安裝檔案至您指定的資料夾中。這些主題提供您關於下載資料夾常見問題的答案。

  1. 如何安裝在此資料夾中的檔案？
  2. 我可以使用 msiexec 或某些其他應用程式從此資料夾手動安裝 MSI 檔案嗎？
  3. 可以為安裝的每個版本選擇相同的下載資料夾嗎？
  4. 我從 Dassault Systèmes SolidWorks Corporation 網站手動下載了某些產品。安裝管理員可以安裝這些產品嗎？
  5. 下載的檔案可與其他使用者共享嗎？
  6. 如何知道是否有新的 SolidWorks 產品版本？
  7. 安裝管理員僅顯示 SW2006 或 SW2007 的安裝，但沒有目前的版本。
  8. 安裝管理員不讓我選擇要安裝產品的不同 service pack。
  9. 安裝管理員無法下載檔案。
  10. 並非所有的 SolidWorks 產品都被更新至最新的 service pack，可是檢查更新顯示此已是最新的版本？
  11. 可以複製 DVD 到下載資料夾中嗎？

如何安裝在此資料夾中的檔案？

執行 setup.exe。如果您選擇安裝過去沒有下載的項目，您可能仍然需要下載某些檔案。

請勿使用 msiexec 安裝（請參閱下方）。

回到最上方

我可以使用 msiexec 或某些其他應用程式從此資料夾手動安裝 MSI 檔案嗎？

不可以，安裝管理員並不會下載執行 msiexec 時需要的某些檔案。

回到最上方

可以為安裝的每個版本選擇相同的下載資料夾嗎？

下載資料夾為版本特定。從 SolidWorks 2010 開始，SolidWorks 安裝管理員會自動在指定資料夾中建立版本特定的子資料夾。

回到最上方

我從 Dassault Systèmes SolidWorks Corporation 網站手動下載了某些產品。安裝管理員可以安裝這些產品嗎？

從 SW2009 開始，手動下載的檔案可被 SolidWorks 安裝管理員使用。不過，最好還是執行 SolidWorks 安裝管理員，選擇選項來下載檔案。SolidWorks 安裝管理員會根據您正安裝的項目決定需要的檔案，並提供下載每個檔案的連結。當內建的下載頁面無法作用時（主要有可能是代理伺服器強制的限制），可以使用此選項。
如果在下載或安裝時 Microsoft Internet Explorer 詢問您是要儲存還是執行檔案，請始終指定儲存。

回到最上方

下載的檔案可與其他使用者共享嗎？

有。要如此操作，請下載至網路共用處。每個客戶端接著可以從共用處執行 SolidWorks 安裝管理員以下載。

除非使用者選擇要安裝的部份項目在最初下載並未選取，或者如果使用此下載安裝的電腦的必要項目與下載檔案電腦的必要項目不同，否則不需要進一步的下載。

如果您是代替其他人下載而不是要安裝，請在安裝時選擇只要下載選項。這個選項可允許您選擇產品，不論它是否能安裝在您的系統中。不過，此選項不能用來下載修補程式。

回到最上方

如何知道是否有新的 SolidWorks 產品版本？

在下列的情況下，可能會通知您有新的版本：
  • 如果您執行檢查更新（開始 > 所有程式 > SolidWorks 安裝管理員 > 檢查更新）
  • 如果您已啟用 SolidWorks 背景下載程式。
  • 如果您在 Windows 新增/移除程式選擇已安裝的 SolidWorks 版本，然後按一下變更
  • 如果您從下載資料夾執行舊版的安裝管理員 (sldIM.exe)
在這些狀況下，您可以選擇下載較新的版本。SolidWorks 安裝管理員將會下載與執行較新的安裝管理員版本，不會有任何安裝檔案。在新版的 SolidWorks 安裝管理員版本執行之後，您可以選擇一組安裝動作。SolidWorks 安裝管理員將會決定需要哪些安裝檔案（先前沒有下載的）並且會提供下載這些檔案。

回到最上方

SolidWorks 安裝管理員僅顯示 SW2006 或 SW2007 的安裝，但沒有目前的版本。

您執行的是不支援目前版本的舊 SolidWorks 安裝管理員版本。它僅能下載 SW2006 及 SW2007 版本的 service packs。

回到最上方

SolidWorks 安裝管理員不讓我選擇要安裝產品的不同 service pack。

設計上就是如此。SolidWorks 安裝管理員的每個版本設計為只安裝特定版本的 SolidWorks 產品。如果您想要安裝不同的 service pack，需要執行該版本的 SolidWorks 安裝管理員。要找出可用的最新版本，請參考如何知道是否有新的 SolidWorks 產品版本？

回到最上方

SolidWorks 安裝管理員無法下載檔案。

如果代理伺服器限制應用程式下載檔案，SolidWorks 安裝管理員無法自動下載檔案。

您可以手動下載檔案，然後使用 SolidWorks 安裝管理員安裝檔案。在 SolidWorks 安裝管理員中選擇下載個別檔案的選項（例如下載選項頁面中的執行手動下載）。根據您產品的選擇及系統的需求，一網頁會出現在個別的視窗中，其中包含手動下載所需檔案的連結。這些連結與 SolidWorks Customer Portal 中所提供的連結相同，但是您不需要搜尋檔案。

回到最上方

並非所有的 SolidWorks 產品都被更新至最新的 service pack，可是檢查更新顯示此已是最新的版本？

檢查更新只能告知您是否安裝了（或正執行）最新的 SolidWorks 安裝管理員版本。

如果您想要將所有產品更新為已安裝的最新版本，請在新增/移除程式中選擇 SolidWorks 最新安裝的版本，然後按一下變更。

回到最上方

可以複製 DVD 到下載資料夾中嗎？

可以，但除非您複製為該作業平台（x86 或 x64）所發行 DVD 的整個內容，否則安裝有可能失敗。SolidWorks 安裝管理員會尋找檔案 swdata*.id 以判定版本。如果這些檔案不是最新的，它將無法識別您複製的任何安裝檔案，因此需要下載它們。

回到最上方

父主題： 疑難排解


SolidNetWork 使用許可疑難排解

如果 SolidNetWork 使用許可管理員安裝失敗，請檢查這些可能的說明。

  • 存取 SolidNetWork 使用許可記錄檔案
    當使用許可發生錯誤時，答案經常出現在 SNL_Manager_安裝目錄\lmgrd.log 檔案中。
  • 無法獲得 SolidWorks 的使用許可。無法連接至伺服器。
    這個問題通常是由於連接埠設定所造成的。
父主題： 疑難排解


存取 SolidNetWork 使用許可記錄檔案

當使用許可發生錯誤時，答案經常出現在 SNL_Manager_安裝目錄\lmgrd.log 檔案中。

父主題： SolidNetWork 使用許可疑難排解


無法獲得 SolidWorks 的使用許可。無法連接至伺服器。

這個問題通常是由於連接埠設定所造成的。

  • 在 SolidNetWork 使用許可管理員與使用許可客戶端之間的連接埠設定可能不符。
  • 可能沒有為 SolidNetWork 使用許可管理員的多個版本指定額外的連接埠設定。
有關 SolidNetWork 使用許可管理員與客戶端的連接埠設定的詳細資訊，請參閱使用 SolidNetWork 使用許可與防火牆。
父主題： SolidNetWork 使用許可疑難排解


升級的疑難排解

如果您在升級新的 SolidWorks 版本時遇到問題，請查看這些可能有用的說明。

  • 從已經移動的來源升級
    安裝 SolidWorks 時，SolidWorks 安裝管理員會記住安裝來源（磁碟媒體、在伺服器上的磁碟安裝點等等）的位置。當更新時，安裝管理員預期來源是在相同的位置。
父主題： 疑難排解


從已經移動的來源升級

安裝 SolidWorks 時，SolidWorks 安裝管理員會記住安裝來源（磁碟媒體、在伺服器上的磁碟安裝點等等）的位置。當更新時，安裝管理員預期來源是在相同的位置。

如果來源移動或被刪除，或來源媒體變更，SolidWorks 安裝管理員會產生一個錯誤訊息。不過，您可以瀏覽至另一個位置來繼續升級，只要該位置包含所有相同的檔案及資料夾結構。

父主題： 升級的疑難排解


SolidWorks 安裝管理員應用程式說明

SolidWorks 安裝管理員是可安裝及更新您 SolidWorks 產品的獨立應用程式。

您可以執行 SolidWorks 安裝管理員：
  • 從 SolidWorks DVD 或共用的來源或下載資料夾（安裝新版本時）
  • 從控制台新增或移除程式頁（修改或移除現有版本時）
  • 透過排定或手動更新檢查（刪除、下載與安裝新的發行版本時）

SolidWorks 的每個版本都具有特定於該 SolidWorks 版本的 SolidWorks 安裝管理員版本。

如需 SolidWorks 2008 之前的版本，請使用 SolidWorks 2007 安裝管理員或是從 SolidWorks 支援網站手動下載產品版本。
  • SolidWorks 背景下載程式
    SolidWorks 背景下載程式使用背景程序執行自動化檔案下載（例如，找到新的 Service Pack 版本時），可讓您在下載時繼續其他工作。當下載完成時，會詢問您是否要馬上安裝，暫緩下載，或移除下載。
  • 檢查更新結果
    檢查更新會尋找 SolidWorks 的更新版本。
  • 管理安裝點位置
    指定管理安裝點的安裝位置。
  • 下載選項
    指定完成下載作業的詳細資訊，例如下載的檔案位置、如何下載檔案，以及是否安裝下載的檔案。
  • SolidWorks 安裝管理員檔案的下載選項
    您選擇要下載 SolidWorks 安裝管理員較新的版本。使用此螢幕指定下載的位置與方式。
  • 下載產品安裝檔案
    為特定的產品指定於何處及如何下載遺失的檔案。
  • 下載進度
    SolidWorks 安裝管理員在此過程中，平行處理所有檔案的下載、確認及擷取。
  • 下載結果
    指出下載是否順利完成，在操作期間失敗或是已經取消。
  • 安裝錯誤/安裝取消
    安裝時發生錯誤或是已經取消。
  • 安裝完成
    SolidWorks 安裝管理員已完成其處理。
  • 安裝位置
    指定 SolidWorks 安裝位置。
  • 升級選項
    一個或多個較舊的 SolidWorks 版本目前安裝在此電腦中。選擇是否要將最近的現有版本升級為新的版本，或是為新版本產生新的安裝。
  • 安裝進度
    此螢幕顯示安裝的進度。
  • 安裝類型
    指定您想要執行的安裝作業，例如產生新安裝、修改或修復現有安裝、產生管理安裝點、安裝管理伺服器產品，或是下載檔案而不安裝。
  • 安裝及管理多台電腦
    SolidWorks 安裝管理員提供下列的工具來安裝與管理多個 SolidWorks 電腦。
  • 手動下載
    您已經選擇手動下載檔案（或者您在上次執行 SolidWorks 安裝管理員時已經選擇手動下載）。
  • 有較新的版本可用
    安裝管理員偵測到有較新版本的 SolidWorks 產品。您可以選擇安裝包含在原始安裝 DVD 中的版本或下載，或您可以選擇下載及安裝較新的版本。
  • 沒有新的版本可用
    沒有較新的版本可供下載。繼續安裝指定的版本。
  • 偵測到的程序
    SolidWorks 安裝管理員在這台電腦上偵測到可能會使得安裝不成功的程序。
  • 產品選擇
    指定要安裝、修改、下載或移除的產品元件。
  • 下載的產品
    選擇要下載至特定位置的 SolidWorks 產品。
  • 要修復的產品
    指定修復此安裝時，此螢幕會顯示此 SolidWorks 安裝管理員版本能夠修復的 SolidWorks 產品以及版本號碼。
  • 序號
    可在包裝盒上找到的序號，將您的電腦與所購買的 SolidWorks 產品相關聯。
  • 伺服器安裝
    會列出您嘗試安裝的伺服器產品，並有安裝的結果。
  • SolidNetWork License Manager
    指定 SolidNetWork License Manager 伺服器產品的安裝選項。
  • 摘要
    SolidWorks 安裝管理員擁有完成安裝作業所需的所有資訊。
  • 系統檢查警告
    系統檢查所報告的問題會影響您繼續安裝的方式。在多數的情況下，您應該能夠繼續使用 SolidWorks 安裝管理員。
  • 異型孔精靈/Toolbox 選項
    如果已經安裝 SolidWorks Toolbox，SolidWorks 會包括鑽孔類型與硬體的標準資料庫。
  • 解除安裝產品
    當您從控制台中選擇移除或解除安裝程式時，螢幕會顯示可以由此版本 SolidWorks 安裝管理員可以解除安裝的 SolidWorks 產品（包含版本編號）。 您可以選擇要執行標準、自訂或完整的解除安裝。
  • Workgroup PDM 伺服器選項
    指定 SolidWorks Workgroup PDM 伺服器產品的安裝選項。


SolidWorks 背景下載程式

SolidWorks 背景下載程式使用背景程序執行自動化檔案下載（例如，找到新的 Service Pack 版本時），可讓您在下載時繼續其他工作。當下載完成時，會詢問您是否要馬上安裝，暫緩下載，或移除下載。

在使用 SolidWorks 安裝管理員安裝 SolidWorks 時，SolidWorks 背景下載程式預設啟用。

當 SolidWorks 安裝管理程式執行時，無論是對於安裝或下載作業，SolidWorks 背景下載程式都會暫停。例如，它會暫停任何執行中的下載，不允許開始任何新的下載，並且不允許變更下載資料夾的指定。

在安裝 SolidWorks 時，SolidWorks 背景下載程式預設啟用。您可以在「摘要」頁面上變更「下載選項」，使 SolidWorks 背景下載程式在 SolidWorks 安裝期間停用。（清除您要使用背景下載程式嗎？選項。）

啟用後，此圖示出現在工具列中的 Windows 系統匣中：

按一下此圖示可啟用下列作業：
  • 背景下載程式的說明
  • 暫停下載
  • 繼續下載
  • 取消下載
  • 安裝選項
  • 變更下載位置
  • 檢查更新
  • 自動檢查更新
  • 自動下載更新
  • 停用背景下載程式

背景下載程式的說明

在 SolidWorks 安裝指南中開啟背景下載程式的這一說明主題。

暫停/繼續下載

如果下載在背景中執行，按一下暫停下載以暫停該下載，稍後按一下繼續下載又可繼續。

取消下載

如果下載在執行中，停止該下載並刪除背景下載程式已經下載的任何檔案。
取消後的下載無法再繼續。

安裝選項

下載完成後，您可以選擇下列選項：
  • 馬上安裝：安裝下載的檔案。
  • 稍後再提醒我：不安裝下載的檔案，但設定稍後以訊息提醒您。
  • 刪除此下載：不安裝下載的檔案，而將其刪除。（如果您決定不再安裝下載的檔案，此選項很有用。）

變更下載位置

變更背景下載程式下載檔案的位置。

如果下載正在執行或已暫停，此選項不可用。

檢查更新

執行 SolidWorks 安裝管理員的檢查更新功能。

自動檢查更新

定期執行檢查更新，在有更新可供下載時通知您。

自動下載更新

定期執行檢查更新，在有更新時進行下載。

停用及重新啟用 SolidWorks 背景下載程式

您可以按一下圖示並選擇停用背景下載以停用背景下載程式。

要重新啟用背景下載程式，按一下開始 > 所有程式 > SolidWorks 安裝管理員 > SolidWorks 背景下載程式。

父主題： SolidWorks 安裝管理員應用程式說明


檢查更新結果

檢查更新會尋找 SolidWorks 的更新版本。

您可以手動執行檢查更新：
  • 在 Windows 中，按一下開始 > 程式 > SolidWorks 安裝管理員 > 檢查更新
  • 在 SolidWorks 中，按一下說明 > 檢查更新。
從管理安裝點安裝的客戶端上無法使用檢查更新。

有較新的版本可用

SolidWorks 安裝管理員偵測到較新的 SolidWorks 產品版本。您可以選擇該版本的 SolidWorks 安裝管理員來更新至較新的版本。

這個較新的版本可以根據您在安裝中指定的產品下載安裝檔案。您可以與其他使用 SolidWorks 安裝管理員來安裝的使用者共用下載的檔案。

這些下載僅供 SolidWorks 安裝管理員使用。
可用的選項有︰
  • 如果有多個版本可用，您可以從清單中選擇一個版本。
  • 關於此版本的詳細資訊，按一下查看此升級包含的項目。
按下一步可取得並執行所選的 SolidWorks 安裝管理員版本。

沒有可用的新下載/無法檢查是否有新的版本

SolidWorks 安裝管理員沒有找到更新的 SolidWorks 產品版本，可能是由於您安裝的是最新版本，或者 SolidWorks 安裝管理員無法連線至 SolidWorks 站台進行檢查。

父主題： SolidWorks 安裝管理員應用程式說明


管理安裝點位置

指定管理安裝點的安裝位置。

在產生管理安裝點時，這些選項適用：
新的安裝點位置
此為 SolidWorks 安裝管理員產生新安裝點的目錄位置。
這個位置不能夠包含現有的管理安裝點。管理安裝點必須位於可供客戶端部署共用的資料夾中。
估計產生安裝點所需的磁碟空間
此為管理安裝點所需的額外空間。
請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝點需求。
產生安裝點自
此為您安裝 SolidWorks 產品的目錄位置。
只有在只要安裝選項指定時，這個選項才會出現。詳細資訊請參閱下載選項。
父主題： SolidWorks 安裝管理員應用程式說明


下載選項

指定完成下載作業的詳細資訊，例如下載的檔案位置、如何下載檔案，以及是否安裝下載的檔案。

SolidWorks 安裝管理員支援電子軟體通路 (ESD)。如果您不是使用 SolidWorks DVD 來安裝，將提示您指明所要安裝 SolidWorks 產品的來源。

關於下載資料夾問題的答案，請參閱SolidWorks 安裝管理員下載資料夾。

您所要執行的操作為何？

選擇下列其中一項：
下載及安裝/下載及產生安裝點
在下載完成之後，SolidWorks 安裝管理員會使用下載的檔案執行安裝。
只要下載。您可以下載一次然後將下載的檔案與多部電腦共用。
SolidWorks 安裝管理員在下載完成後不執行安裝。

一般而言，如果您要下載檔案並且組態為多部電腦共用安裝檔案集，您需要指定這個選項。

如果您指定這個選項，系統接著會要求您在兩組要下載的檔案中做選擇：
  • 對此台電腦的檔案：下載僅包含目前在此電腦缺少的安裝檔案集的檔案。
    這應該會是較小的下載，因為它只包含：
    • 在產品選擇頁中所選取的產品檔案
    • 您的電腦需要但是尚未安裝的先決要件檔案

    但是，如果您嘗試在執行安裝的其他電腦上使用此下載的檔案集，可能會缺少某些檔案（因為其他電腦上的安裝檔案集可能與這部電腦的不同）。您可以使用這些下載檔案在其他電腦上進行安裝，但是在安裝執行時，您可能需要下載其他檔案以完成該電腦上的安裝檔案集。

  • 與任何電腦共用的檔案：下載會包含完整的安裝檔案集，可用來將此版本安裝在任何電腦上。

    這會是較大下載，因為它包含了完整的檔案集，您可以用來在任何電腦上安裝任何產品的此版本。

    如果您指定下載有限的產品集，這個選項會忽略該規格並且下載包含在產品版本中的所有產品。

    下載將會包含產生管理安裝點所需的所有檔案，而不只是執行單機安裝所需要的檔案。

只要安裝/只要產生安裝點。我已經有需要的所有安裝檔。
SolidWorks 安裝管理員不會下載任何檔案，而是使用所選目錄中的檔案。

按一下瀏覽來瀏覽至不同的位置。例如，您可以瀏覽至安裝 DVD 或下載資料夾，只要位置中包含所有必要的檔案。

如果您接收到資料夾是不完整的錯誤訊息，但您認為所有的安裝檔案都應該在該位置時，可能的原因包括：
  • 您選擇了一個之前未下載的元件來安裝，或預設選擇安裝該元件。
  • 檔案下載至有不同系統需求的另一電腦上。
  • 您之前執行的是客戶端的安裝，但現在要產生一個需要較大檔案集的管理安裝點。

您可以瀏覽至包含所有檔案的資料夾（例如 DVD），或是選擇其中一個下載選項。

您要將要求的檔案下載至何處？

這是下載資料夾位置。

在某些情況下，這個選項雖然看得見，但是為停用狀態。舉例來說，如果指定只要安裝，SolidWorks 安裝管理員將會從該選項指定的目錄安裝任何下載的檔案，而不是使用另外的下載資料夾。

不論您是下載這些檔案或從您自己的位置來存取這些檔案，所有的檔案必須被下載至相同的下載資料夾中。

估計下載大小

不論這是新的下載或您繼續之前工作階段的下載，所估計的下載磁碟空間需求是根據列出的完整所選元件而定。

例如，如果您繼續之前的下載，SolidWorks 安裝管理員將僅處理尚未下載的檔案。下載的時間會少於估計的時間。

如果檔案在先前的下載中已經完成下載，其大小不會包含在此次估計當中。因此，估計的大小可能會高於實際的下載大小。

您要如何下載？

有兩個選項：
執行手動下載
在某些情況下，代理伺服器可能會禁止從 SolidWorks 安裝管理員自動下載。
透過選擇此選項，您可以透過網頁手動下載檔案，然後在 SolidWorks 安裝管理員中繼續完成安裝作業。此網頁是由 SolidWorks 安裝管理員自訂，僅下載完成安裝所需的檔案。
使用較多的網路頻寬來加速下載
下載程式使用一演算法來藉由於下載過程中增加網路的頻寬以加快下載的速度。

在某些狀況中，這可能會干擾網路的效能。如果下載有困難，此選項可能不為代理伺服器所支援。嘗試清除此選項然後再次下載。詳細資訊可與您的網路管理員查詢。

這個選項僅適用於自動下載。它對於手動下載沒有影響。

使用 SolidWorks 背景下載程式

您可以使用 SolidWorks 背景下載程式來完成此下載的操作或下載未來的 SolidWorks Service Pack 版本（當其可用時）。

Solidworks 背景下載程式可於背景中自動偵測及下載新的 Service Pack 更新，並於下載完成檔案準備好可供安裝時通知您。詳細資訊請參閱SolidWorks 背景下載程式。

父主題： SolidWorks 安裝管理員應用程式說明


SolidWorks 安裝管理員檔案的下載選項

您選擇要下載 SolidWorks 安裝管理員較新的版本。使用此螢幕指定下載的位置與方式。

關於下載資料夾問題的答案，請參閱SolidWorks 安裝管理員下載資料夾。

這個畫面只有在預設下載資料夾發生問題時才會出現（例如如果沒有寫入權限或網路存取權限）。一般而言，您只需指定替代下載目錄即可繼續。

下載目錄

瀏覽至 SolidWorks 安裝管理員檔案的目的地。

下載大小以及需要的空間數量將會顯示。所需空間的量包括解壓縮某些下載所需的額外空間，這是比實際的下載大小更大。

使用下載加速程式

如果您選擇此選項，下載工具會使用一演算法來增加下載的速度。

下載加速程式會增加頻寬的使用，因此可能會干擾網路效能。在啟用下載加速程式之前，請與您的網路管理員確認。

如果代理伺服器不支援下載加速程式，此選項會自動停用。

父主題： SolidWorks 安裝管理員應用程式說明


下載產品安裝檔案

為特定的產品指定於何處及如何下載遺失的檔案。

SolidWorks 安裝管理員在下載的過程中，平行處理所有檔案的下載、確認及擷取。

取消此畫面將會取消其餘的安裝程序。

關於取消安裝的影響及如何完成被中斷安裝的說明，請參閱安裝錯誤。

下載目錄

瀏覽至下載檔案的目的地。

將會顯示下載大小及所需的空間。所需空間的量包括解壓縮某些下載所需的額外空間，這比實際的下載大小更大。

關於下載資料夾問題的答案，請參閱SolidWorks 安裝管理員下載資料夾。

下載選項

使用較多的網路頻寬來加速下載
下載程式使用一演算法來藉由於下載過程中增加網路的頻寬以加快下載的速度。

在某些狀況中，這可能會干擾網路的效能。如果下載有困難，此選項可能不為代理伺服器所支援。嘗試清除此選項然後再次下載。詳細資訊可與您的網路管理員查詢。

下載加速程式會增加頻寬的使用，因此可能會干擾網路效能。在啟用下載加速程式之前，請與您的網路管理員確認。

如果代理伺服器不支援下載加速程式，此選項可能會自動停用。

父主題： SolidWorks 安裝管理員應用程式說明


下載進度

SolidWorks 安裝管理員在此過程中，平行處理所有檔案的下載、確認及擷取。

要在下載開始之後取消它，請按一下取消。

如果您取消下載或是下載失敗，下載取消或下載問題螢幕會指出哪些下載尚未完成，讓您繼續下載或關閉應用程式。

關於下載資料夾問題的答案，請參閱SolidWorks 安裝管理員下載資料夾。
父主題： SolidWorks 安裝管理員應用程式說明


下載結果

指出下載是否順利完成，在操作期間失敗或是已經取消。

下載問題/下載取消

如果您看見下載問題，表示 SolidWorks 安裝管理員遇到問題，使得下載無法完成。

如果您看見下載取消，表示您在下載完成前已經取消下載。

繼續：

重試/繼續自動下載
若要從您取消下載的時間點繼續自動下載，請選擇此選項然後按一下重試下載或繼續下載。
在 Web 瀏覽器中分別下載檔案
在某些情況下，代理伺服器可能會禁止從 SolidWorks 安裝管理員自動下載。
透過選擇此選項，您可以透過網頁手動下載檔案，然後在 SolidWorks 安裝管理員中繼續完成安裝作業。此網頁是由 SolidWorks 安裝管理員自訂，僅下載完成安裝所需的檔案。

下載完成

如果您指定只要下載選項，當下載完成時，會出現下載完成畫面。

按一下完成結束 SolidWorks 安裝管理員。

請勿嘗試手動安裝任何這些產品。始終使用 SolidWorks 安裝管理員安裝下載的檔案。
父主題： SolidWorks 安裝管理員應用程式說明


安裝錯誤/安裝取消

安裝時發生錯誤或是已經取消。

如果錯誤或取消發生：
  • 在錯誤或取消之前安裝的產品會保留在電腦上。
  • 如果可能，取消時正在安裝的產品會被回溯，因此不會有部分的安裝。
  • 其餘產品未安裝或取消安裝。在尚未嘗試之下會出現一個清單。

    若要繼續安裝或取消安裝這些產品，請按一下提供的連結。

SolidWorks 安裝管理員會先安裝尚未安裝在此電腦上的任何先決要件，例如 .NET framework。接著會將所選產品以下列順序安裝：
  1. SolidWorks
  2. eDrawings
  3. SolidWorks 搜尋
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360(P)
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • 復原失敗或取消的安裝
    如果在安裝期間發生錯誤或取消安裝，您可以透過重新執行安裝的方式從該點復原。
  • 修復安裝
    如果您已安裝的 SolidWorks 產品有問題，您可以使用 SolidWorks 安裝管理員來修復安裝。
  • 聯絡 SolidWorks 經銷商
    如果修改或修復安裝失敗，請聯絡您當地的 SolidWorks 經銷商，並提供從螢幕中收集到的資訊。您可能會被要求提供 SolidWorks 安裝管理員記錄檔的 zip 檔案。
父主題： SolidWorks 安裝管理員應用程式說明


復原失敗或取消的安裝

如果在安裝期間發生錯誤或取消安裝，您可以透過重新執行安裝的方式從該點復原。

  1. 為失敗的安裝記錄下錯誤訊息及產品碼，這些會出現在安裝錯誤或安裝取消螢幕中。

    如果提示要求提供來源檔案，且您不是修改現有的 SolidWorks 安裝，安裝或電腦可能有所損壞。請聯絡您的 SolidWorks 經銷商。

  2. 重新啟動電腦。
  3. 若要確定沒有 SolidWorks 產品正在執行中，請於 Windows 中按下 Ctr+Alt+Del 來開啟工作管理員。
  4. 在處理程序標籤中，如果在影像名稱之下有任何下列的處理程序，請選擇它們並按下結束處理程序。

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. 如果應用程式已被安裝，且您嘗試修改或移除它，請嘗試使用修復安裝。詳細資訊請參閱修復安裝。
  6. 在 Windows Vista 或之後的版本中，按一下開始 > 控制台 > 程式與功能。對於較早的 Windows 版本，按一下開始 > 控制台 > 新增或移除程式。
  7. 選擇失敗的 SolidWorks 版本。

    如果您嘗試安裝的 SolidWorks 版本中沒有項目，請重複安裝程序。

  8. 執行下列操作之一︰
    • 要重新嘗試，請按一下變更然後選擇所有安裝失敗或於安裝過程中跳過的產品。

    • 要略過失敗的安裝，按一下變更並選擇在安裝過程中跳過的所有產品。清除安裝失敗的產品。

    • 要放棄安裝，請按一下移除並選擇任何已安裝的產品。

    這樣並不會將目前正在升級的任何產品回復為先前版本。

父主題： 安裝錯誤/安裝取消


聯絡 SolidWorks 經銷商

如果修改或修復安裝失敗，請聯絡您當地的 SolidWorks 經銷商，並提供從螢幕中收集到的資訊。您可能會被要求提供 SolidWorks 安裝管理員記錄檔的 zip 檔案。

  1. 找到記錄檔案：
    • 對於 Vista 之前的 Windows 作業系統版本：

      C:\Documents and Settings\使用者名稱\Application Data\SolidWorks\Installation Logs\安裝的版本\

    • 對於 Windows Vista 或之後的版本：

      C:\Users\使用者名稱\AppData\Roaming\SolidWorks\Installation Logs\安裝的版本\

    如果您找不到資料夾，它可能是隱藏起來了。在 Windows 檔案總管中，按一下工具 > 資料夾選項。在檢視標籤的進階設定之下，選擇隱藏檔案和資料夾中的顯示隱藏的檔案和資料夾。

  2. 將此資料夾的整個內容（包括子資料夾）壓縮成 Zip 檔案。
父主題： 安裝錯誤/安裝取消


安裝完成

SolidWorks 安裝管理員已完成其處理。

可能會顯示其中一個或多個選項。

新增功能

對於單機安裝，當您完成安裝的過程時，會有一描述在 SolidWorks 及其附加產品中新功能的文件出現。

對於管理安裝點的安裝，當客戶端完成安裝時，文件會出現在客戶端電腦上。

問卷調查

回答一個簡短的問卷來告訴我們您對於安裝過程的意見。

參加 SolidWorks Customer Experience Improvement Program

效能資訊被送至 SolidWorks Corporation 以幫助改進產品。此過程是透明和保密的。選擇下列之一︰
  • 是，我願意參加
  • 否，謝謝
  • 稍後再提醒我
詳細資訊請參考 Customer Experience Improvement Program 的網站。

管理安裝點的產生已完成

當您完成管理安裝點的產生時，您可以按一下自訂安裝點來回到管理安裝點選項中以自訂安裝點。

按一下顯示如何在一客戶端上安裝此安裝點。來顯示如何使用選項編輯器的說明。

如需有關使用選項編輯器組態管理安裝點的詳細資訊，請參閱管理安裝點選項編輯器。

按一下自訂安裝點啟動管理安裝點選項編輯器，以為此管理安裝點自訂選項設定。
您可以之後連按兩下在管理安裝點目錄中的 sldAdminOptionEditor.exe 來啟動選項編輯器。
  • 檢查 SolidWorks 更新
    您可以使用 SolidWorks 安裝管理員手動檢查更新，或是設定定期自動檢查更新。
  • SolidWorks Customer Experience Improvement Program
    在安裝 SolidWorks 時，可以指定傳送效能資訊至 SolidWorks Corporation 以協助改善產品。
父主題： SolidWorks 安裝管理員應用程式說明


檢查 SolidWorks 更新

您可以使用 SolidWorks 安裝管理員手動檢查更新，或是設定定期自動檢查更新。

  1. 執行下列之一來啟動 SolidWorks 安裝管理員：

    • 在 SolidWorks 應用程式中，按一下說明 > 檢查更新。

    • 在 Windows 中，按一下開始 > 程式 > SolidWorks 安裝管理員 > 檢查更新。

    SolidWorks 安裝管理員會告訴您目前是否有可用更新。

  2. 如果有可用的更新，選擇是否要下載並安裝它們。
  3. 若要啟用自動定期檢查更新，請在 SolidWorks 安裝管理員完成處理時選擇每 __ 天檢查更新然後指定檢查頻率。
父主題： 安裝完成


SolidWorks Customer Experience Improvement Program

在安裝 SolidWorks 時，可以指定傳送效能資訊至 SolidWorks Corporation 以協助改善產品。

SolidWorks 使用這些資訊來決定關於產品使用及品質的趨勢。我們的目標是提供最高品質的產品，效能記錄檔是在此過程中相當有用的工具。

此過程是透明不可見的。包含在記錄檔中所有的資訊都是保密的。資訊不會用於其他的目的，且沒有人會與您聯絡。

詳細資訊請參考 Customer Experience Improvement Program 的網站。

父主題： 安裝完成


安裝位置

指定 SolidWorks 安裝位置。

對於管理安裝點產生以外的安裝，以下選項將適用：
安裝所選產品至：
此為您安裝 SolidWorks 的目錄位置。
在升級或修改安裝時，必須將所有檔案安裝至該安裝的現有位置。在此狀況下，您無法變更現有 SolidWorks 安裝的位置。
估計安裝所需的磁碟空間
此為安裝或修改所選產品所需的額外空間。
請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝需求。
安裝來源
此為您安裝 SolidWorks 的來源目錄位置。
只有在只要安裝選項指定時，這個選項才會出現。詳細資訊請參閱下載選項。
在變更 SolidWorks 安裝位置之前，請向您的系統管理員詢問。

管理安裝點位置

在產生管理安裝點時，這些選項適用：
新的安裝點位置
此為 SolidWorks 安裝管理員產生新安裝點的目錄位置。
這個位置不能夠包含現有的管理安裝點。
估計產生安裝點所需的磁碟空間
此為管理安裝點所需的額外空間。
請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝點需求。
產生安裝點自
此為您安裝 SolidWorks 產品的目錄位置。
只有在只要安裝選項指定時，這個選項才會出現。詳細資訊請參閱下載選項。
現有安裝點的位置
在升級現有的管理安裝點時，SolidWorks 安裝管理員會根據該現有安裝點的設定產生新的安裝點。此現有安裝點未修改。這樣會顯示您在歡迎畫面中指定的原始安裝點的位置。

避免使用版本特定的目錄路徑

如果您在安裝目錄位置（例如 C:\Program Files\SolidWorks Corp\SolidWorks 2010\）中指定了一個版本號碼，接著將該安裝升級至 SolidWorks 2011，您會有一個 SolidWorks 2011 安裝目錄，名稱為 SolidWorks 2010。

父主題： SolidWorks 安裝管理員應用程式說明


升級選項

一個或多個較舊的 SolidWorks 版本目前安裝在此電腦中。選擇是否要將最近的現有版本升級為新的版本，或是為新版本產生新的安裝。

只有當此主要版本的先前版本沒有安裝在此電腦時，這個選項才會出現。如果已經安裝此主要版本的先前版本，SolidWorks 安裝管理員會始終更新該安裝。

（從 SolidWorks 2010 開始，已經不再支援平行安裝相同主要版本的多個 Service Pack 版本。)

升級時：
  • 所有指定的產品都會升級。
  • 根據預設，所有安裝的產品都會選取。
  • 如果您取消選取某個產品，則該產品將不會升級。
    如果您取消選取一個產品元件，您將不會指定 SolidWorks 安裝管理員移除該元件。若要移除產品元件，請使用新增/移除程式，如同移除安裝當中所述。

選擇適當的選項，然後按下一步繼續。

產生一個 SolidWorks 版本的新安裝。

選擇這個選項可保留較舊的主要版本安裝，並且為此主要版本產生新的安裝。

如果您在安裝新版本之後仍然希望可以存取舊版的 SolidWorks，這個選項就很有用。例如，如果您與仍然在執行舊版 SolidWorks 的其他使用者共用檔案，就可以避免使用較新的版本儲存檔案時的版本不相容性。

將 SolidWorks 先前主要版本升級為 SolidWorks 目前主要版本。

選擇此選項可將較舊的版本安裝升級至較新的版本。
一旦安裝完成，此電腦將無法再使用較舊的 SolidWorks 版本。
父主題： SolidWorks 安裝管理員應用程式說明


安裝進度

此螢幕顯示安裝的進度。

要在安裝開始之後取消安裝，請按一下取消。

關於取消安裝的影響及如何完成被中斷安裝的說明，請參考安裝錯誤。

父主題： SolidWorks 安裝管理員應用程式說明


安裝類型

指定您想要執行的安裝作業，例如產生新安裝、修改或修復現有安裝、產生管理安裝點、安裝管理伺服器產品，或是下載檔案而不安裝。

單機型

在此電腦上安裝 SolidWorks 產品。

只有當這個版本沒有安裝在此電腦上時，這個選項才會出現。

修改單機安裝

修改此電腦上現有的 SolidWorks 安裝

只有當這個版本已安裝在此電腦上時，這個選項才會出現。
修改包括：
  • 新增或移除 SolidWorks 產品元件
  • 變更至不同的 SolidWorks 套裝軟體（例如 SolidWorks Professional、SolidWorks Premium 等）
  • 變更 SolidWorks 序號設定
    如果您在先前的安裝期間已經指定一個 SolidWorks 序號，SolidWorks 安裝管理員可能不會重新提示。若要變更 SolidWorks 安裝管理員所採用的序號，您必須選擇這個選項。

修復單機安裝

修復此電腦上現有的 SolidWorks 安裝。

只有當這個版本已安裝在此電腦上時，這個選項才會出現。
修復會確認所有的檔案都存在且被適當的登錄，並修復任何發現的問題。您所產生的資料不會受影響。
  • 要修復一個產品，請確定有將其選取。
  • 清除您所不要修復產品的核取方塊。
您可以修復一個單機安裝。您無法修復一個管理安裝點的安裝；您必須使用管理安裝點再次安裝。

管理安裝點

在此電腦上產生或更新管理安裝點。

您可以使用管理安裝點在多個電腦上進行安裝。如需有關使用管理安裝點在多個客戶端上安裝 SolidWorks 的詳細資訊，請參閱使用管理安裝點。

產生或更新管理安裝點時：
  • 您可以使用現有安裝點中的安裝設定來組態新的或更新的安裝點，或者您可以使用預設的 SolidWorks 安裝設定。
  • 如果您更新現有的安裝點：
    • 即使您正在更新，SolidWorks 安裝管理員仍然會產生一個新的安裝點副本。原始的安裝點不會修改。
    • 您可以使用正在更新的現有安裝點中的檔案產生更新的安裝點。這樣會產生較小的下載。
    如果您沒有指定 Service Pack 版本可以用來更新先前安裝點的安裝點，您無法利用較小下載的優點。
  • 您可以在此電腦上產生一個 32 位元及一個 64 位元的安裝點。否則，只會產生相對應於此電腦硬體架構的安裝點。
    如果您沒有指定同時產生 32 位元及 64 位元的安裝點，會要求同時要有兩種架構的 SolidWorks 安裝媒體才能完成安裝。

伺服器產品

SolidWorks 管理伺服器產品包括 SolidWorks Workgroup PDM Server（資料保險箱）和 SolidNetWork 使用許可管理員。

如需有關這些產品的詳細資訊，請參閱：
  • Workgroup PDM
  • 使用 SolidNetWork 使用許可管理員來管理使用許可

只要下載

下載所選的 SolidWorks 產品的安裝檔案而不安裝產品。

如果您是從 DVD 安裝，這個選項將不會出現。

下載檔案的內容跟 SolidWorks 安裝 DVD 可取得的檔案內容相同。選擇此選項下載完整的安裝檔案集，不論您的電腦上已經安裝什麼檔案。

您可以使用此方法來設定一個伺服器讓您的使用者可以從伺服器執行安裝。這與產生一個管理安裝點不同。

為此電腦安裝了錯誤的 SolidWorks 架構

如果您嘗試使用錯誤的 SolidWorks 安裝媒體來在此電腦架構上安裝（例如，如果您嘗試在 32 位元的電腦上安裝 64 位元的 SolidWorks），安裝窗格會指出此問題。

要繼續安裝：
  1. 取消此 SolidWorks 安裝管理員的工作階段。
  2. 檢查此電腦的電腦架構及系統需求。
  3. 使用對此電腦架構正確的 SolidWorks 安裝媒體來重新安裝。
父主題： SolidWorks 安裝管理員應用程式說明


手動下載

您已經選擇手動下載檔案（或者您在上次執行 SolidWorks 安裝管理員時已經選擇手動下載）。

按一下連結以開啟自動產生的網頁，其中包含完成下載所需的完整檔案清單。

您必須下載至摘要頁中指定的資料夾。安裝必須等到所有檔案下載至該資料夾之後才會開始。

一旦您完成手動下截，請按下一步繼續。

如果您想要自動下載，可以返回摘要頁並變更下載選項以變更選項。

父主題： SolidWorks 安裝管理員應用程式說明


有較新的版本可用

安裝管理員偵測到有較新版本的 SolidWorks 產品。您可以選擇安裝包含在原始安裝 DVD 中的版本或下載，或您可以選擇下載及安裝較新的版本。

如果您從 DVD 中安裝

在您是否要使用較新的版本？之下，選擇其中一個選項：
  • 否，繼續從此 DVD 安裝版本。您之後可以用較小的下載來更新。

    選擇此選項來使用目前的安裝管理員繼續安裝。

    在安裝完成之後，您可以使用安裝管理員來檢查及安裝更新。要檢查更新，請執行開始 > SolidWorks 安裝管理員 > 檢查更新。

    此種方法的好處是會產生較小的下載。缺點是這是一個兩步驟的過程，且您下載的檔案是特定於該版本的（無法與使用不同版本的其他使用者共用）。

  • 是，使用此 DVD 執行安裝，然後下載並更新至版本。

    選擇此選項來下載及執行安裝管理員的較新版本以安裝該版本的 SolidWorks 產品。

    如果可以取得小的 Service Pack 版本以更新 DVD 版本，安裝管理員首先會從 DVD 安裝原始版本，然後套用 Service Pack 更新。這樣會產生較小的下載。

    選擇從 DVD 繼續安裝的選項，然後在日後套用更新，同樣能達成相同結果。

    這個選項的優點是它只有一個步驟的過程。

在大部分的狀況中，較理想的方式是從 DVD 中安裝完整的版本，然後使用安裝管理員來檢查與安裝更新，因為這樣只需較小的下載。

如果您從下載中安裝

選擇下列其中一項：
  • 繼續安裝版本。

    選擇此選項來繼續安裝包含在初始下載中的版本。

  • 下載及安裝新的版本：版本

    選擇此選項來下載新版本及安裝它。如果有多個新版本可用，您可以選擇要下載及安裝的版本。

父主題： SolidWorks 安裝管理員應用程式說明


偵測到的程序

SolidWorks 安裝管理員在這台電腦上偵測到可能會使得安裝不成功的程序。

  • 要繼續安裝，請執行下列操作之一：
    • 關閉這些程序（例如使用 Microsoft Windows 工作管理員），然後按重試。
    • 按一下忽略繼續而不關閉程序。
  • 若要停止安裝，請按取消。
父主題： SolidWorks 安裝管理員應用程式說明


產品選擇

指定要安裝、修改、下載或移除的產品元件。

在產品清單中：
  • 產品清單是產品的完整清單，可在產品清單上方指定的套裝軟體中取得。
  • 若要檢視對特定元件的動作，請按一下元件名稱（但不是核取方塊）。預定安裝動作會出現在產品清單下方的資訊欄位中。
  • 您可以按一下產品元件旁邊的核取方塊以變更該元件的安裝目錄。（例如，如果您要安裝或移除元件，選擇核取方塊則指定安裝或移除元件，清除核取方塊則指定不安裝或移除元件。）
  • 如果您執行的是修改安裝，當您在產品選擇中進行任何變更時，在元件的左邊會出現一個星號 (*)。
  • 如果元件中具有可選的安裝子元件，+ 圖示將會出現在元件旁邊。要查看元件可用的子元件，請按一下 + 圖示。
  • 如果元件已經展開而顯示子元件，- 圖示將會出現在元件旁邊。要摺疊子元件清單，請按一下 - 圖示。

如果您正在套用 Service Pack，則無法選擇出現在 SolidWorks 底下的 SolidWorks 功能（例如 FeatureWorks）。這是因為執行此類型的升級時，您無法新增或移除功能。

SolidWorks 安裝管理員所執行的動作是由一組產品共存規則所控制。詳細資訊請參閱產品共存規則。

SolidWorks 安裝管理員會根據預設選擇這些產品元件：
  • 如果您執行的是升級或 Service Pack 更新，SolidWorks 安裝管理員會選擇目前已安裝的產品。
  • 否則，SolidWorks 安裝管理員會選擇您有資格安裝的所有產品。
要減少您安裝或下載的時間及所需的磁碟空間，請展開產品元件並清除不需要的元件的核取方塊。

如果 SolidWorks 安裝管理員無法確認您有資格安裝的產品，您可以按一下選擇不同的套件或產品來變更要安裝或修改的產品套裝軟體（例如 SolidWorks Professional 或 SolidWorks Premium）清單。SolidWorks 安裝管理員列出在您安裝媒體中與所選套裝軟體相容的所有 SolidWorks 產品。您可以選擇已購買或是有資格評估的任何產品。

SolidWorks 搜尋

SolidWorks 搜尋提供對 SolidWorks 文件、Workgroup PDM 資料保險箱及 3D ContentCentral 強大的全文搜尋。搜尋顯示預覽及檔案位置與名稱。

在安裝之後，SolidWorks 搜尋編制 SolidWorks 文件的索引以供更快的搜尋。預設僅編制 SolidWorks 檔案的索引。

安裝 SolidWorks 搜尋時也同時會自動安裝 Windows 桌面搜尋 － 如果您的電腦尚未安裝的話。

支援的語言

展開 SolidWorks 產品及語言元件來查看您可以安裝的語言。

語言的指定會限制僅為 SolidWorks 產品安裝該語言。其他的產品不受此指定的影響。例如，SolidWorks eDrawings®、SolidWorks Workgroup PDM、及 SolidWorks Explorer 會安裝所有的語言。

所需空間

SolidWorks 安裝管理員於頁面的下方報告總安裝大小或總下載的大小。

  • 如果您選擇只要下載選項，螢幕上會出現下載大小。下載大小是所有下載檔案所需磁碟空間的總量（不包括在下載完成之後解壓縮所需要的額外空間）。數字只是一個估計值。
    安裝所需要的所有檔案會被包括在總下載大小中。如果某些檔案已被下載至目前的下載資料夾中，則其不會再被下載。因此，您實際的下載大小可能小於所示的整體下載大小，或您可能不需要下載讓何檔案。
  • 否則，安裝大小會出現。安裝大小是當您完成此安裝時，會發生的磁碟空間使用量的變化。由於檔案的壓縮，這些數字只是估計值。

    如果您升級或移除一現有的安裝，安裝的大小將會是零。

    所示的數字不包括任何下載或解壓縮所需要的空間（如果需要安裝的話）。

    如果需要下載，且您要下載至相同的磁碟中，實際的磁碟空間需求可以遠大於所示的安裝大小。

    要減少未來修改的下載或安裝時間，請於安裝之後不要刪除下載的檔案。隨後的升級及修補程式通常需要存取最後完整的安裝檔案集。

父主題： SolidWorks 安裝管理員應用程式說明


下載的產品

選擇要下載至特定位置的 SolidWorks 產品。

可供下載的產品是根據您提供的序號而定：

  • 為每個元件執行的動作出現在每個項目的右側。
  • 如果元件中具有可選的安裝子元件，+ 圖示將會出現在元件旁邊。要查看元件可用的子元件，請按一下 + 圖示。
  • 如果元件已經展開而顯示子元件，- 圖示將會出現在元件旁邊。要摺疊子元件清單，請按一下 - 圖示。
  • 按一下每個元件左側的核取方塊來選擇 SolidWorks 安裝管理員應如何處理元件。
除非您另有指定，否則 SolidWorks 安裝管理員會下載所有您有資格使用的產品。要減少您下載的時間及所需的磁碟空間，請展開產品元件並選擇您不需要的元件。

如果 SolidWorks 安裝管理員無法確定您有資格使用的產品，您可以選擇下載 SolidWorks 套裝軟體。SolidWorks 安裝管理員列出與您所選套裝軟體相容的所有 SolidWorks 產品。

如果 SolidWorks 安裝管理員無法確認您有資格安裝的產品，您可以按一下選擇不同的套件或產品來變更要安裝或修改的產品套裝軟體（例如 SolidWorks Professional 或 SolidWorks Premium）清單。SolidWorks 安裝管理員列出在您安裝媒體中與所選套裝軟體相容的所有 SolidWorks 產品。您可以選擇已購買或是有資格評估的任何產品。

支援的語言

語言的指定會限制僅為 SolidWorks 產品安裝該語言。其他的產品不受此指定的影響。例如，SolidWorks eDrawings®、SolidWorks Workgroup PDM、及 SolidWorks Explorer 會安裝所有的語言。

所需空間

根據您選擇的產品，會顯示執行下載所需的空間。下載大小是所有下載檔案所需磁碟空間的總量（不包括在下載完成之後解壓縮所需要的額外空間）。數字只是一個估計值。

要減少未來升級及修補程式的下載或安裝時間，請於安裝之後不要刪除下載的檔案。隨後的升級及修補程式通常需要存取最後完整的安裝檔案集。
父主題： SolidWorks 安裝管理員應用程式說明


要修復的產品

指定修復此安裝時，此螢幕會顯示此 SolidWorks 安裝管理員版本能夠修復的 SolidWorks 產品以及版本號碼。

修復會確認所有的檔案都存在且被適當的登錄，並修復任何發現的問題。您所產生的資料不會受影響。
  • 要修復一個產品，請確定有將其選取。
  • 清除您所不要修復產品的核取方塊。

按一下修復開始修復所選的產品。

您可以修復一個單機安裝。您無法修復一個管理安裝點的安裝；您必須重新安裝管理安裝點。
父主題： SolidWorks 安裝管理員應用程式說明


序號

可在包裝盒上找到的序號，將您的電腦與所購買的 SolidWorks 產品相關聯。

如果電腦中已經安裝有 SolidWorks 產品，依預設會顯示它們的序號。
  • 如果序號沒有顯示的話，請輸入您的 SolidWorks 序號。
  • 如果您的產品序號沒有包括在 SolidWorks 使用許可，請在您有其他的序號嗎？之下按一下產品項目，然後輸入該產品的序號。

如果您有 internet 連線，在您後續的安裝過程中，您提供的序號將決定您有資格安裝的產品。

由於購買 SolidWorks 產品的管道有很多，因此某些序號可能會適用於兩種或多種產品。例如，SolidWorks 序號可讓您安裝 SolidWorks Simulation 而不需輸入個別的 SolidWorks Simulation 序號。此外，有些產品並不需要序號。如果您對於序號有任何問題，請聯絡您的 VAR。
父主題： SolidWorks 安裝管理員應用程式說明


伺服器安裝

會列出您嘗試安裝的伺服器產品，並有安裝的結果。

伺服器安裝狀態

伺服器產品安裝是由外部安裝應用程式所執行。如果您目前沒有在該應用程式中，您必須切換至該應用程式以完成安裝。

按一下取消以停止伺服器產品安裝。

伺服器安裝完成

外部安裝應用程式已經成功完成。

按一下完成或下一步。
  • 如果您安裝的是其他的管理產品（例如 SolidWorks 管理安裝點），則該安裝會繼續。
  • 如果伺服器產品安裝是唯一的安裝作業，SolidWorks 安裝管理員將會關閉。

伺服器安裝已取消或失敗

如果伺服器產品安裝失敗或是在安裝開始後被取消，會列出未被安裝的伺服器。

按一下關閉或下一步。
  • 如果您指定了其他管理產品安裝，SolidWorks 安裝管理員將會繼續。
  • 如果伺服器產品安裝是唯一的安裝作業，SolidWorks 安裝管理員將會關閉。
父主題： SolidWorks 安裝管理員應用程式說明


SolidNetWork License Manager

指定 SolidNetWork License Manager 伺服器產品的安裝選項。

序號

指定 SolidNetWork License 的序號。您可以用逗號分隔來指定多個序號。
SolidNetWork 的序號與 SolidWorks 的序號不同。

安裝位置

指定 SolidNetWork License Manager 的安裝位置。

如果要更新現有的 SolidNetWork License Manager，必須安裝至現有的安裝位置。

詳細資訊

如需安裝、設定和使用 SolidNetWork License Manager 的詳細資訊，請參閱使用 SolidNetWork 使用許可管理員來管理使用許可。

父主題： SolidWorks 安裝管理員應用程式說明


摘要

SolidWorks 安裝管理員擁有完成安裝作業所需的所有資訊。

要繼續： | 按一下現在動作按鈕以初始化安裝作業（例如現在安裝、現在產生、現在下載、現在修改）。
變更安裝的設定︰ | 在您要變更的部分按一下變更 [image] （例如產品、安裝位置、Toolbox 選項)。
要取消： | 按一下取消 [image] 以結束 SolidWorks 安裝管理員而不變更安裝元件。
回復上一頁： | 按上一步 [image] 返回 SolidWorks 安裝管理員的上一頁。
如需有關特別安裝選項集的資訊（例如產品、安裝位置、Toolbox 選項等）：
  1. 按一下所需資訊部分旁邊的變更 [image] 。
  2. 在出現的詳細資料頁面中，按一下說明 [image] 以取得有關這些安裝選項設定的資訊。
父主題： SolidWorks 安裝管理員應用程式說明


系統檢查警告

系統檢查所報告的問題會影響您繼續安裝的方式。在多數的情況下，您應該能夠繼續使用 SolidWorks 安裝管理員。

您在此階段可能遇到的警告列於下面，同時列出了如何繼續操作的建議。

序號驗證問題
安裝管理員無法檢查是否有新的版本，因為其無法驗證您的序號。如果您已連接並輸入有效的序號，這可能表示我們的伺服器暫時有問題。請稍後再試。

序號驗證：安裝管理員無法驗證您的序號來確定您有權安裝哪些產品。您仍然能夠選擇要安裝的產品，但無法下載任何安裝檔案。您需要下載一套完整的來源檔案或提供 DVD 以供安裝。

解決辦法：
  • 檢查 internet 連線。序號檢查需要有效的 internet 連線。
  • 檢查您輸入的序號是否對您要安裝的產品有效。
  • 有些安裝要求您在版本發行時具備有效的訂閱。如需詳細資訊，請洽詢您的 SolidWorks 經銷商。
  • 大多數情況下，如果從 DVD 或之前下載的檔案集安裝，您可以繼續安裝。
有較新的版本可用
有較新的版本可用

有新的版本可用

此產品有一個較新的版本可供下載。

解決辦法：執行「檢查更新」作業時，安裝可能會提示您從 SolidWorks 下載安裝更新的版本。您可以使用起始指定的版本繼續此作業，或者下載較新的版本，並使用該版本繼續作業。

有最新版本可用
這是可用的最新版本。按一下「下一步」來繼續。

沒有可用的新下載

解決辦法：此訊息在您於安裝或修改期間檢查更新時可能會出現。它表示您目前正在安裝（或已安裝）可用的最新版本。

Internet 連線問題
Internet 連線：安裝管理員無法連接至 SolidWorks 伺服器來確定您有權安裝哪些產品。您仍然能夠選擇要安裝的產品，但無法下載任何安裝檔案。您必須以 DVD 提供來源檔案或之前下載的檔案集。

無法檢查是否有新的版本

安裝管理員無法檢查是否有新的版本因為其無法與伺服器連線。

解決辦法：
  • 檢查 internet 連線。
  • 如果從 DVD 或之前下載的檔案集安裝，您可以繼續安裝。
父主題： SolidWorks 安裝管理員應用程式說明


異型孔精靈/Toolbox 選項

如果已經安裝 SolidWorks Toolbox，SolidWorks 會包括鑽孔類型與硬體的標準資料庫。

如需有關組態、延伸與使用 SolidWorks Toolbox 的詳細資訊，請按一下 SolidWorks 中的說明 > Toolbox 說明。
若要檢視此說明，可能需要使用工具 > 附加來啟動 Toolbox 附加程式。

在使用 SolidWorks Toolbox 之前，請確定已經根據貴公司政策或群組原則將其正確組態。在許多情況下，群組將會集中組態與維護一個 Toolbox。請向 SolidWorks 管理員尋求協助，了解如何在 SolidWorks 安裝期間指定 Toolbox。

您可以在安裝之後變更所選的 SolidWorks Toolbox。在 SolidWorks 中，按一下工具 > 選項。在系統選項標籤上，按一下異型孔精靈/Toolbox。

以下幾節將說明您在此畫面的所有模型組態中會遇到的所有選項。您能看見的實際 Toolbox 選項需視此電腦上預先存在的 SolidWorks 和 Toolbox 組態，以及您指定至此點的 SolidWorks 安全管理員選擇而定。

產生一個新的新版本 Toolbox

在此電腦上產生一個新的 SolidWorks Toolbox 版本。

當您產生一個新版本時，在「產品選擇」畫面中，請展開 SolidWorks > SolidWorks Toolbox 並選取要支援 Toolbox 的標準。依預設會選取所有的標準。

此電腦中任何現有的 Toolboxe 都不會修改。

參考或升級現有的 Toolbox

使用現有的 Toolbox。按一下瀏覽以指定想要和此安裝一起使用的 Toolbox 位置。

  • 如果已經為先前的 SolidWorks 主要發行版本組態 Toolbox，則會升級至此版本。對於該 Toolbox 所做的任何自訂會保留在升級的 Toolbox 中。
    升級 Toolbox 成為新的 SolidWorks 主要發行版本會使得 Toolbox 與執行前一個主要發行 SolidWorks 版本的電腦無法相容。
  • 如果已經為此 SolidWorks 版本設定 Toolbox（如果您指定了已經升級的共用網路 Toolbox 則會出現此情況），則不會升級至該 Toolbox。
  • 如果您升級在 Enterprise PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱在 SolidWorks Enterprise PDM 的環境中升級 Toolbox。

這個選項會出現在所有安裝狀況中，但是產生管理安裝點時不會出現。

升級舊版本 Toolbox

將為先前主要發行版本所組態的 Toolbox 複製到新的位置，並且將該副本升級為此版本。

如果此電腦中已經安裝先前的 SolidWorks 主要發行版本，但是您選擇不要將該安裝升級至此版本，這個選項就會出現。
這個選項的目的是為先前已經安裝的主要 SolidWorks 版本升級 Toolbox，但是不會影響使用較舊 Toolbox 版本的使用者。

如果您升級在 Enterprise PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱在 SolidWorks Enterprise PDM 的環境中升級 Toolbox。

升級此安裝的舊版本 Toolbox

升級此 Toolbox 至較新的版本。
升級 Toolbox 成為新的 SolidWorks 主要發行版本會使得 Toolbox 與執行前一個主要發行 SolidWorks 版本的電腦無法相容。

如果您將先前的 SolidWorks 主要發行版本升級為此版本，而在此電腦上發現為該版本組態的 Toolbox，這個選項就會出現。

如果您升級在 Enterprise PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱在 SolidWorks Enterprise PDM 的環境中升級 Toolbox。

使用安裝的目前版本 Toolbox

SolidWorks 安裝管理員在此電腦上偵測到為此 SolidWorks 主要發行版本組態的 Toolbox。

如果您選擇這個選項，SolidWorks 將會使用此 Toolbox。不會發生升級。

如果已經在此電腦上安裝先前的 SolidWorks 主要發行版本，但是已經為此版本組態 Toolbox，這個選項就會出現。如果在仍然執行舊版 SolidWorks 的電腦上產生共用 Toolbox，就可能會發生此情況。

為客戶端電腦指定 Toolbox 的位置

當客戶端從管理安裝點安裝時，將網路或目錄位置指定為預設的 Toolbox 位置。
如果位置包含了在客戶端安裝發生時，為先前的 SolidWorks 主要發行版本所組態的 Toolbox，SolidWorks 安裝管理員會升級該 Toolbox。

這個選項會在您產生新的管理安裝點時出現。

為客戶端電腦升級或使用於現有安裝點被參考的 Toolbox

使用您在更新現有管理安裝點時指定的 Toolbox 位置。
如果位置包含了在客戶端安裝發生時，為先前的 SolidWorks 主要發行版本所組態的 Toolbox，SolidWorks 安裝管理員會升級該 Toolbox。

為客戶端電腦選擇一個不同的 Toolbox 位置

指定一個與您在更新現有管理安裝點時指定的位置不同的 Toolbox 位置。
如果位置包含了在客戶端安裝發生時，為先前的 SolidWorks 主要發行版本所組態的 Toolbox，SolidWorks 安裝管理員會升級該 Toolbox。
  • 關於組態 SolidWorks Toolbox 的注意事項
    SolidWorks Toolbox 是一個功能強大而又複雜的功能。本主題列舉了一些在使用 SolidWorks 安裝管理員組態 Toolbox 之前應該考量的概念。
  • UNC 格式
    標準 (或通用) 命名慣例格式可指定檔案名稱語法格式以描述共用檔案位置。
父主題： SolidWorks 安裝管理員應用程式說明


關於組態 SolidWorks Toolbox 的注意事項

SolidWorks Toolbox 是一個功能強大而又複雜的功能。本主題列舉了一些在使用 SolidWorks 安裝管理員組態 Toolbox 之前應該考量的概念。

尋找更多有關 SolidWorks Toolbox 的資訊

如需有關組態、延伸與使用 SolidWorks Toolbox 的詳細資訊，請按一下 SolidWorks 中的說明 > Toolbox 說明。
若要檢視此說明，可能需要使用工具 > 附加來啟動 Toolbox 附加程式。

使用共用的 Toolbox

當您安裝 Toolbox 時，可以讓 Toolbox 資料存放於您的本機電腦或是共用的網路位置中。建議將 Toolbox 資料儲存於網路位置。透過使用共同位置的方式，所有 SolidWorks 使用者都可分享一致的扣件資訊。

如果這是第一次安裝，請瀏覽至您要安裝 Toolbox 的共用位置。

升級現有的 Toolbox

升級 Toolbox 成為新的 SolidWorks 主要發行版本會使得 Toolbox 與執行前一個主要發行 SolidWorks 版本的電腦無法相容。

如果其他電腦仍然維持使用前一個主要版本，而且繼續需要 Toolbox 為該版本組態，您應該製作該 Toolbox 的一份複本，然後升級該複本。新的 SolidWorks 安裝將會升級 Toolbox 的複本，而先前的 SolidWorks 安裝將會繼續使用舊的 Toolbox。

組態 Toolbox 的存取

在安裝之後，當您存取 Toolbox 零組件時，SolidWorks 會檢查您如何組態 Toolbox，並對改善存取及效能做出建議。

如需存取共用的網路 Toolbox（建議），請使用連接安裝共用 Toolbox 的伺服器的 UNC 路徑。詳細資訊請參閱UNC 格式。

管理員可以為 Toolbox 建立一個密碼，並且為工作群組設定權限與喜好設定。限制模型組態的存取權限以及設定共同喜好設定可確保一致性的 Toolbox 資料。

在 SolidWorks Enterprise PDM 的環境中升級 Toolbox

在您升級從 Enterprise PDM 資料保險箱存取 Toolbox 資料夾的第一個 SolidWorks 安裝之前：
  1. 在 Windows 檔案總管中，導覽至 Enterprise PDM 資料保險箱中的 Toolbox 資料夾。
  2. 用右鍵按一下 Toolbox 資料夾，然後按一下取得最新的版本。

    這樣可讓 SolidWorks 安裝管理員確認零件是否需要更新。

  3. 取出 Toolbox 資料夾。

    Toolbox 資料夾必須取出，SolidWorks 安裝管理員才能更新 Toolbox。

  4. 升級之後，請存回 Toolbox 資料夾。

在資料保險箱中的 Toolbox 資料庫即會升級。

對於之後的 SolidWorks 升級，在開始升級之前，Enterprise PDM 客戶端必須取得資料保險箱 Toolbox 資料夾的最新版本（使用取得最新的版本）。這樣可讓 SolidWorks 安裝管理員確認檔案是否為最新。

關於在 SolidWorks Enterprise PDM 中 Toolbox 組態的詳細資訊，請參閱 SolidWorks Enterprise PDM 管理工具說明中的組態 Toolbox。

父主題： 異型孔精靈/Toolbox 選項


UNC 格式

標準 (或通用) 命名慣例格式可指定檔案名稱語法格式以描述共用檔案位置。

\\伺服器\磁碟區\路徑

例如：

\\Disk_Server\SolidWorks\AdminImage

父主題： 異型孔精靈/Toolbox 選項


解除安裝產品

當您從控制台中選擇移除或解除安裝程式時，螢幕會顯示可以由此版本 SolidWorks 安裝管理員可以解除安裝的 SolidWorks 產品（包含版本編號）。 您可以選擇要執行標準、自訂或完整的解除安裝。

標準的解除安裝會移除 SolidWorks 產品的程式檔案與資料夾。根據預設，所選版本的所有 SolidWorks 產品皆指定為標準的解除安裝。

自訂的解除安裝會移除一或多個下列項目：程式檔案與資料夾、登錄碼與資料資料夾，例如 SolidWorks Toolbox 以及來自原始下載位置的檔案與資料夾。

完整的解除安裝會移除安裝目錄、登錄碼以及資料資料夾。

解除一個產品的安裝：
  1. 在解除安裝的螢幕中，請確定選擇了該產品。

    如果您要解除所有產品的安裝， Solidworks 安裝管理員同時也會被解除安裝。

  2. 清除您不要移除的產品。

    如果您要保留任何產品，SolidWorks 安裝管理員不會被移除。

  3. 選擇要執行自訂或完整的解除安裝。
    1. 按一下進階選項中按一下變更。

      進階選項的螢幕出現。程式檔案及資料夾的選項被核取。

    2. 選擇一或多個選項來執行自訂的解除安裝，或選擇所有的選項來執行一個完整的解除安裝。
    3. 按一下回到摘要。
    4. 在摘要的螢幕中，展開進階選項來顯示解除安裝的方法與項目。
  4. 按一下移除項目 [image] 。
按一下移除項目時，SolidWorks 安裝管理員會立即開始移除產品。
父主題： SolidWorks 安裝管理員應用程式說明


Workgroup PDM 伺服器選項

指定 SolidWorks Workgroup PDM 伺服器產品的安裝選項。

安裝位置

指定 Workgroup PDM 伺服器產品的安裝位置。

要安裝的產品

指定要安裝哪些 Workgroup PDM 伺服器產品：
Workgroup PDM Vault
指定用於 Workgroup PDM Vault 資料的位置。一個 Workgroup PDM Viewer 的使用許可必須與資料保險箱一起安裝才能啟用 Viewer。
Workgroup PDM Viewer
安裝 Workgroup PDM Viewer 時，必須指定 Viewer 將要存取的 Workgroup PDM Vault 電腦之名稱或 IP 位址。
Workgroup PDM API

Workgroup PDM API 的使用許可是包括在 SolidWorks 客戶端及 Explorer 客戶端的使用許可中。存回 API 需要客戶端的使用許可。

詳細資訊

安裝 Workgroup PDM 的詳細資訊請參閱Workgroup PDM。

如需使用 Workgroup PDM 的詳細資訊，請參閱 SolidWorks 說明中的 Workgroup PDM。

父主題： SolidWorks 安裝管理員應用程式說明


法律注意事項

© 1995-2011, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA.All Rights Reserved.

本文件中提及的資訊和軟體如有更改，恕不另行通知，Dassault Systèmes SolidWorks Corporation (DS SolidWorks) 不負任何責任。

未經 DS SolidWorks 明確書面許可，不得以任何形式或通過任何手段（電子或手動），以及為任何目的，重製或傳播任何有關資料。

本文件中提及的軟體受使用許可的限制，只能按照使用許可協議書的條款進行使用或複製。所有 DS SolidWorks 對軟體和文件提供的保固均在使用許可協議書中闡明，對於其中沒有提及或暗示的，此文件及其內容將被視為使用許可協議中任何條款，包括保固的修改和補充。

專利注意事項

SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

SolidWorks 產品及服務的商標與產品名稱

SolidWorks、3D PartStream.NET、3D ContentCentral、eDrawings、和 eDrawings 標誌是 SolidWorks 的註冊商標，FeatureManager 是 DS SolidWorks 共同所有的註冊商標。

CircuitWorks、FloXpress、TolAnalyst 及 XchangeWorks 是 DS SolidWorks 的商標。

FeatureWorks 是 Geometric Ltd. 的註冊商標。

SolidWorks 2012、SolidWorks Enterprise PDM、SolidWorks Workgroup PDM、SolidWorks Simulation、SolidWorks Flow Simulation、eDrawings Professional、及 SolidWorks Sustainability 是 DS SolidWorks 的產品名稱。

其他商標或產品名稱是各自所有者的商標或註冊商標。

商用電腦軟體 - 所有權

軟體是“commercial item”，該詞定義於 48 C.F.R. 2.101 (OCT 1995)， 是由“commercial computer software” 及“commercial software documentation” 所組成，這些詞用於 48 C.F.R. 12.212 (SEPT 1995) 並提供給美國政府 (a) 在符合 48 C.F.R. 12.212 中所設定的政策下由民間機構或其代表取得；或 (b) 在符合 48 C.F.R. 227.7202-1 (JUN 1995) 及 227.7202-4 (JUN 1995) 中所設定的政策下由國防部的單位取得。

在任何情況下，如果您收到來自美國政府單位要求提供超過上列所給的軟體權力，您應通知 DS SolidWorks 所收到要求的內容範圍，而 DS SolidWorks 將在五 （5）個工作天之內單獨決定接受或拒絕該要求。承包商/製造商︰Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

SolidWorks Standard、Premium、Professional、及 Education 產品的著作權注意事項

Portions of this software © 1986-2011 Siemens Product Lifecycle Management Software Inc. All rights reserved.

此作品包含 Siemens Industry Software Limited 所擁有的下列軟體：

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited.All Rights Reserved.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited.All Rights Reserved.

Portions of this software © 1998-2011 Geometric Ltd.

Portions of this software © 1996-2011 Microsoft Corporation.All rights reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2011 Luxology, LLC.All rights reserved, patents pending.

Portions of this software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. 及其授權人。All rights reserved.Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe、Adobe 標誌、Acrobat、Adobe PDF 標誌、Distiller 和 Reader 是 Adobe Systems Inc. 在美國與其他國家的註冊商標或商標。

要獲得更多關於 SolidWorks® 版權的資訊，請參考說明 > 關於 SolidWorks。

SolidWorks Simulation 產品的著作權注意事項

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. All rights reserved.

SolidWorks Enterprise PDM 產品的著作權注意事項

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation.All rights reserved.

eDrawings 產品的著作權注意事項

Portions of this software © 2000-2011 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software c 1998-2001 3Dconnexion.

Portions of this software © 1998-2011 Open Design Alliance.All rights reserved.

Portions of this software © 1995-2010 Spatial Corporation.

本軟體的部分是根據 Independent JPEG Group 的成果。


安裝及管理多台電腦

SolidWorks 安裝管理員提供下列的工具來安裝與管理多個 SolidWorks 電腦。

SolidWorks 管理安裝點

如果您在多台電腦上安裝 SolidWorks，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。

Workgroup PDM Server

Workgroup PDM 應用程式是在 SolidWorks 環境內部執行的專案資料管理軟體，或作為 SolidWorks Explorer 中的單獨應用程式。Workgroup PDM 使用取出、存回、修訂版控制的程序及其他系統管理的操作來控制專案。安裝 Workgroup PDM Server 會產生 Workgroup PDM 資料保險箱，此為儲存所管理之 SolidWorks 專案的資料庫。

SolidNetWork License Manager

SolidNetWork License 管理員透過浮動使用許可，允許使用者的數目超過使用許可的數目。當客戶端使用許可不在使用中時，其他的 SolidWorks 使用者可使用此使用許可。

您也可以使用 SolidNetWork License 管理員配送 SolidWorks 核心附加產品（例如 FeatureWorks）的使用許可。

父主題： SolidWorks 安裝管理員應用程式說明


沒有新的版本可用

沒有較新的版本可供下載。繼續安裝指定的版本。

要繼續安裝，按一下下一步。

父主題： SolidWorks 安裝管理員應用程式說明