Instalace a správa programu SolidWorks

Tato nápověda obsahuje informace o instalaci, licencích a správě produktů SolidWorks pro individuální instalace i pro násobné instalace.

Individuální instalace | Zavádění násobných instalací
Instalace Instalace na jednom nebo na více počítačích. | Instalace Vytvoření administrativní kopie, která se zavádí na více klientských počítačů.
Licencování Aktivace licence nebo síťové licence. | Licencování Aktivace licence nebo síťové licence.
Upgrady Instalace nové verze na individuálních počítačích. | Upgrady Instalace nové verze na více počítačích aktualizací administrativní kopie používané k instalaci na těchto počítačích.
Správa Změny, opravy a odstraňování instalací, upgrady na nové verze. | Správa Upgrady administrativních kopií a klientů, správa síťových licencí, správa úschovny Workgroup PDM.

Manažer instalací SolidWorks vám umožní konfigurovat nastavení pro produkty SolidWorks, včetně SolidWorks, SolidWorks Toolbox, PhotoView 360, Workgroup PDM a SolidWorks licenční server SolidNetWork.

Aplikace Workgroup PDM je program pro správu dat projektů. Běží buď uvnitř prostředí programu SolidWorks, nebo jako samostatná aplikace v rámci Průzkumníka SolidWorks. Workgroup PDM řídí projekty pomocí procesů pro vyzvednutí, odevzdání, kontrolu revizí a další správní úkony.

Manažer licencí SolidNetWor podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

  • Individuální instalace nebo administrativní kopie
    Měli byste nainstalovat produkty SolidWorks na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?
  • Zahájení instalace SolidWorks
    Můžete zahájit instalaci SolidWorks načtením z DVD na místním počítači s přístupem ke sdílené instalační složce nebo stahováním ze SolidWorks.


Individuální instalace nebo administrativní kopie

Měli byste nainstalovat produkty SolidWorks na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?

Volba je závislá na počtu počítačů, na kterých provádíte instalaci. U nerozhodných situací zvažte následující porovnání.

Individuální instalace | Administrativní kopie
Uživatelé mohou provádět vlastní správu SolidWorks. | Správce systému může upravit vícečetné instalace za použití Editoru možností. Určuje přitom možnosti instalace jako je vytvoření nové instalace nebo aktualizace stávající instalace, spuštění instalace jako administrativní uživatel, spuštění externích povelů před nebo po instalaci, různé seskupení produktů atd.
Počítače musí být fyzicky přístupné uživateli, který provádí instalaci. | Klientské počítače nemusí být fyzicky dostupné, ale musí být dostupné ze stejné sítě.
Můžete nainstalovat různé verze, aktualizace Service Pack, nebo produkty na různých počítačích s rozdílnými nastaveními. | S použitím Editoru možností mohou administrativní kopie udržet konzistentní verze, aktualizace Service Pack, produkty a nastavení pro vícečetné instalace.
Při instalaci aktualizace Service Pack je vyžadováno originální zdrojové medium (DVD). | Při instalaci aktualizace Service Pack není vyžadováno originální zdrojové medium.
Počítač nemusí být na síti. | Ke spuštění programu je vyžadováno připojení k místní síti. Zdrojové médium není vyžadováno na klientských počítačích.
 | Klientské počítače mohou být aktualizovány automaticky. Klientské počítače, na nichž je program nainstalován ze stejné administrativní kopie, používají stejnou aktualizaci service pack. Pokud chcete udržovat různé verze, můžete vytvořit různé administrativní kopie.
 | Lze nastavit automatickou aktivaci licence.
 | Administrativní kopie vyžaduje dodatečné místo na disku na serveru. Klienti vyžadují stejné místo jako individuální instalace.
Nadřazené téma: Instalace a správa programu SolidWorks


Zahájení instalace SolidWorks

Můžete zahájit instalaci SolidWorks načtením z DVD na místním počítači s přístupem ke sdílené instalační složce nebo stahováním ze SolidWorks.

  • Spustit instalaci programu SolidWorks můžete jedním z následujících způsobů:
    • K instalaci na místní disk počítače vložte odpovídající disk do diskové jednotky.
    • Pro instalaci z adresáře pro stahování přejděte k adresáři a poklepejte na setup.exe.
    • Instalace stažením z webové stránky SolidWorks:
      1. Přejděte na webovou stránku společnosti SolidWorks.
      2. Přihlaste se jako Subscription Service Customer (Zákazník předplacené služby), zadejte svoji emailovou adresu a heslo, nebo sériové číslo SolidWorks.
      3. Pod Self Service, klepněte na Stažení a aktualizace.
      4. Pod Pod Download Software, klepněte na verzi SolidWorks a servisní balíček pro stažení.
Nadřazené téma: Instalace a správa programu SolidWorks


Individuální instalace

  • Instalace na individuálních počítačích
    Můžete nainstalovat SolidWorks na individuálním počítači za použití několika instalačních metod.
  • Správa individuálních instalací
    Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.


Instalace na individuálních počítačích

Můžete nainstalovat SolidWorks na individuálním počítači za použití několika instalačních metod.

Manažer instalací SolidWorks přizpůsobí instalaci produktům, které jste zakoupili. Před instalací:

  • Připravte si sériové číslo SolidWorks.
  • Ujistěte se, že máte připojení k internetu.
Manažer instalací SolidWorks vyžaduje různé komponenty aplikace Microsoft, včetně Microsoft Windows Installer, Office Web Components, Microsoft Visual Studio Tools pro aplikace a .NET Framework. Pokud nejsou nainstalovány správné verze předpokladů Windows, Manažer instalací SolidWorks je automaticky nainstaluje před instalací programů SolidWorks.
Metoda instalace Stručné souhrnné informace o postupu
Za použití instalačního média SolidWorks Vložte vhodný DVD do jednotky na počítači.
Instalační médium SolidWorks obsahuje dvě oddělené DVD pro 32bitové a 64bitové Windows instalace.
Použití adresáře pro stahování na serveru V adresáři pro stahování poklepejte na setup.exe.
Tento adresář pro stahování musí být přístupná z počítače, na kterém instalujete produkty SolidWorks a musí obsahovat všechny instalační soubory SolidWorks než může začít instalace. Manažer instalací SolidWorks vám může pomoci najít chybějící soubory, pokud máte přístup na internet a možnost psaní v adresáři pro stahování.
Toto není Administrativní kopie. Jediným způsobem, jak provést instalaci na klientském počítači z administrativní kopie, je prostřednictvím odkazu na stránce .html zaslané správcem SolidWorks.
Aktualizovat stávající instalaci SolidWorks za použití Zjistit aktualizace Proveďte jeden z následujících úkonů:
  • V SolidWorks klepněte na položku Nápověda > Zjistit aktualizace.
  • V systému Windows klepněte na Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace.
Ujistěte se, že máte funkční připojení k internetu.

Klienti Workgroup PDM zaznamenají, že došlo k aktualizaci úschovny. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack. Bližší informace viz Aktualizace klientů v online nápovědě PDM Workgroup.

Stažení ze zákaznické webové stránky SolidWorks.
  1. Přejděte na webovou stránku společnosti SolidWorks.
  2. Přihlaste se jako Subscription Service Customer (Zákazník předplacené služby), zadejte svoji emailovou adresu a heslo, nebo sériové číslo SolidWorks.
  3. Pod Self Service, klepněte na Download Software and Updates.
  4. Pod Download Software, klepněte na verzi SolidWorks, kterou chcete nainstalovat.
Ujistěte se, že máte funkční připojení k internetu.

Musíte být Zákazníkem předplacené služby s přístupem na stránku Zákaznický portál.

Po dokončení instalace, spusťte program SolidWorks a aktivujte licenci.

Nadřazené téma: Individuální instalace


Správa individuálních instalací

Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.

  • Změna instalace
    Instalaci můžete změnit tak, aby se nainstalovaly produkty, které ještě nebyly nainstalovány nebo aby se produkty odstranily.
  • Oprava instalace
    Pokud zaznamenáte problém s nainstalovaným produktem SolidWorks, můžete pomocí Manažera instalací SolidWorks instalaci opravit.
  • Vrácení samostatné instalace na předchozí servisní balíček
    Chcete-li vrátit individuální instalaci na předchozí verzi servisního balíčku v aktuálním souhrnu hlavní verze, odinstalujte aktuální verzi servisního balíčku na počítači a pak znovu nainstalujte předchozí verzi.
  • Odstranění instalace
    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.
  • Upgrade na novou verzi
    Upgrade individuální instalace nové verze SolidWorks lze provést několika způsoby.
  • Pravidla koexistence produktu
    Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.
Nadřazené téma: Individuální instalace


Změna instalace

Instalaci můžete změnit tak, aby se nainstalovaly produkty, které ještě nebyly nainstalovány nebo aby se produkty odstranily.

Pokud jste nainstalovali SolidWorks a později zakoupili doplňkový modul, instalaci můžete změnit a zahrnout tento nový doplňkový modul. Doplňkový modul musíte nainstalovat na každém počítači zvlášť.

Pokud upravujete původní sadu SolidWorks pro zahrnutí SolidWorks Professional nebo SolidWorks Premium, Workgroup PDM není zahrnut.
  1. Přesvědčte se, že žádné relace SolidWorks nejsou aktivní.
  2. V systému Windows Vista nebo novějším klepněte na Start > Ovládací panely > Programy a funkce.

    V dřívějších verzích systému Windows klepněte na Start > Ovládací panely > Přidat nebo odebrat programy.

  3. Vyberte možnost Instalace SolidWorks, kterou chcete změnit a pak klepněte na Změnit.
  4. Na obrazovce Vítejte v Manažeru instalací SolidWorks klepněte na Změnit individuální instalaci (na tomto počítači)..
  5. Na obrazovce Sériové číslo ověřte, že jsou určena správná sériová čísla.
  6. Na obrazovce Výběr produktu vyberte produkty k instalaci nebo odstranění.

    Když upravujete instalaci:

    • Standardně nejsou instalovány nebo odstraněny žádné produkty, dokonce ani když určíte nové sériové číslo. Musíte změnit instalační operaci každého produktu nebo součásti.
    • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klepněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
    • Chcete-li změnit akci instalace pro danou součást, můžete klepnout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
    • Pokud změníte instalaci součástí z původní specifikace, vedle této součásti v seznamu se objeví hvězdička (*).
    • Pokud součást zahrnuje volitelné dílčí součásti pro instalaci, objeví se vedle součásti ikona + . Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu + .
    • Pokud jste rozbalili součást tak, aby se u ní zobrazily volitelné dílčí součásti, zobrazí se vedle součásti ikona - . Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu - .

  7. Na obrazovce Souhrn, klepněte na Nyní upravit.
  8. Na obrazovce Instalace je dokončena klepněte na Dokončit.
Nadřazené téma: Správa individuálních instalací


Oprava instalace

Pokud zaznamenáte problém s nainstalovaným produktem SolidWorks, můžete pomocí Manažera instalací SolidWorks instalaci opravit.

Je možné opravit individuální instalaci. Administrativní kopii nelze opravit. Musíte ji nejprve odinstalovat a pak nainstalovat novou administrativní kopii.
  1. V systému Windows Vista nebo novějším klepněte na Start > Ovládací panely > Programy > Programy a funkce.

    V dřívějších verzích systému Windows klepněte na Start > Ovládací panely > Přidat nebo odebrat programy.

  2. Vyberte verzi SolidWorks, kterou chcete opravit a klepněte na Změnit.
  3. Na obrazovce Vítejte v Manažeru instalací SolidWorks klepněte na Opravit individuální instalaci (na tomto počítači)..
  4. Na obrazovce Produkty k opravě vyberte produkty, které chcete opravit.
  5. Zrušte výběr všech ostatních produktů.
  6. Klepněte na Opravit.
Nadřazené téma: Správa individuálních instalací
Nadřazené téma: Chyby během instalace / Instalace byla zrušena


Vrácení samostatné instalace na předchozí servisní balíček

Chcete-li vrátit individuální instalaci na předchozí verzi servisního balíčku v aktuálním souhrnu hlavní verze, odinstalujte aktuální verzi servisního balíčku na počítači a pak znovu nainstalujte předchozí verzi.

Nadřazené téma: Správa individuálních instalací


Odstranění instalace

Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

  1. Přesvědčte se, že žádné relace SolidWorks nejsou aktivní.
  2. Chcete-li převést licenci SolidWorks na jiný počítač, nejprve ji převeďte a pak teprve odstraňte instalaci SolidWorks z původního počítače.

    Více informací o převodu licencí SolidWorks najdete na odkazu Převedení licence.

  3. V systému Windows Vista nebo novějším klepněte na Start > Ovládací panely > Programy > Programy a funkce.

    V dřívějších verzích systému Windows klepněte na Start > Ovládací panely > Přidat nebo odebrat programy.

  4. Vyberte součásti produktu, které chcete odebrat.

    V některých případech možná najdete několik součástí aktualizace Service Pack SolidWorks pro danou hlavní verzi. Pro odstranění hlavní verze softwaru SolidWorks odstraňte všechny prvky aktualizace Service Pack pro tuto hlavní verzi.

  5. Na obrazovce Odinstalace proveďte následující:
    1. Vyberte produkty, které chcete odebrat. Všechny instalované produkty jsou standardně vybrány .
    2. Zrušte výběr produktů, které nechcete odstranit.
    3. Určete, zda se má provést vlastní nebo úplná odinstalace. Ve výchozím nastavení provede Manažer instalací SolidWorks standardní odinstalaci a odstraní programové soubory a složky.

      1. Klepněte na možnost Změnit v části Upřesňující možnosti.

        Zobrazí se okno Upřesňující možnosti a je vybrána možnost Programové soubory a složky.

      2. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
      3. Klepněte na Zpět na souhrnné informace.
      4. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.

    4. Klepněte na Odstranit položky.
Nadřazené téma: Správa individuálních instalací


Upgrade na novou verzi

Upgrade individuální instalace nové verze SolidWorks lze provést několika způsoby.

Můžete provést upgrade na novou verzi, když:
  • obdržíte nové instalační médium
  • obdržíte oznámení o upgradech, když spouštíte SolidWorks.
  • Zjistit aktualizace ručně
  • Spusťte novou instanci Manažera instalací SolidWorks

Když instalujete novou verzi programu, můžete upgradovat předchozí hlavní verzi nebo paralelně nainstalovat novou verzi. Pokud je instalována verze servisního balíčku pro předchozí finální hlavní verzi, tato verze se aktualizuje automaticky.

  • Zjistit aktualizace ručně
    Aktualizace verzí aktuálně instalované verze SolidWorks můžete zjistit za použití jedné z těchto metod.
  • Provedení upgrade u klientů Workgroup PDM
    Klienti Workgroup PDM zaznamenají, že došlo k aktualizaci úschovny. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack.
  • Rizika upgradu
    Produkty vyžadující několik instalací v rámci hlavních verzí nepodporují vždy hlavní upgrady, nebo schopnost provádět upgrade mezi hlavními verzemi prostřednictvím jedné operace.
Nadřazené téma: Správa individuálních instalací


Zjistit aktualizace ručně

Aktualizace verzí aktuálně instalované verze SolidWorks můžete zjistit za použití jedné z těchto metod.

  • V SolidWorks klepněte na položku Nápověda > Zjistit aktualizace.
  • V systému Microsoft Windows klepněte na Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace.
Nadřazené téma: Upgrade na novou verzi


Provedení upgrade u klientů Workgroup PDM

Klienti Workgroup PDM zaznamenají, že došlo k aktualizaci úschovny. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack.

Bližší informace viz Aktualizace klientů v online nápovědě PDM Workgroup.

Nadřazené téma: Upgrade na novou verzi
Nadřazené téma: Workgroup PDM VaultAdmin správy úschovny


Rizika upgradu

Produkty vyžadující několik instalací v rámci hlavních verzí nepodporují vždy hlavní upgrady, nebo schopnost provádět upgrade mezi hlavními verzemi prostřednictvím jedné operace.

V tomto případě Manažer instalací SolidWorks simuluje upgrade instalací nové verze a odstraněním staré verze. V současné době podporují hlavní produkty SolidWorks hlavní upgrady, ale ostatní produkty ne.

Následky:
  • Když se provádí upgrade hlavních produktů SolidWorks mezi hlavními verzemi:
    • Stávající umístění instalace se nemění.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, můžete ho vrátit zpět.
  • Když jsou ostatní produkty upgradovány mezi hlavními verzemi:
    • Každý produkt je nejprve nainstalován jako nový produkt do nového umístění a poté je původní instalace odstraněna.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, nelze ho vrátit zpět.
Nadřazené téma: Upgrade na novou verzi


Pravidla koexistence produktu

Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.

Pravidlo | Příklady
Je povoleno více hlavních finálních verzí základního produktu SolidWorks bez ohledu na servisní balíček nebo hlavní verzi (s výjimkou tří produktů uvedených níže). SolidWorks 2010 SP3.0 a SolidWorks 2010 SP0.0 mohou být instalovány na stejném počítači.

Pokud je SolidWorks 2011 SP0.0 nainstalován na počítači a instalujete SolidWorks 2011 SP1.0, Manažer instalací SolidWorks nahrazuje verzi SP0.0 novou verzí SP1.0.

SolidWorks 2011 SP1.0 a 2011 SP1.0 nemohou být zároveň nainstalovány na stejném počítači.

Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • Server Workgroup PDM
  • Manažer licencí SolidNetWork
 Pokud je nainstalován SolidWorks 2011 SP0.0, bude Workgroup PDM Server upgradován na 2011 SP0.0, i když starší hlavní verze programu SolidWorks zůstane na počítači.
S jakoukoliv hlavní verzí může být nainstalována pouze jedna verze zahrnutého produktu. | Pokud je software SolidWorks 2011 SP0.0 upgradován na 2011 SP1.0, Průzkumník SolidWorks 2011 SP0.0 bude automaticky upgradován na 2011 SP1.0. Průzkumník SolidWorks 2010 SP4.0 však může být na počítači instalován také.
Nadřazené téma: Správa individuálních instalací


Násobné instalace

  • Zavádění více klientů
    Program SolidWorks můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.
  • Použití administrativní kopie
    Administrativní kopie umožňuje konfigurovatelné instalace produktů SolidWorks z jediného místa v síti.
  • Zavedení pomocí příkazového řádku
    Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).
  • Správa násobných instalací
    Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.


Zavádění více klientů

Program SolidWorks můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.

Zavedení na klientské počítače probíhá následovně:
  1. Vytvoření administrativní kopie.
    • Vytvoření administrativní kopie pomocí Manažera instalací SolidWorks
    • Vytvoření administrativní kopie pomocí příkazového řádku
  2. Oznámení o administrativní kopii klientům.
    • Oznámení o administrativní kopii klientům e-mailem
    • Instalace z administrativní kopie s použitím příkazového řádku
  3. Provedenísprávy licencí.
    • Správa jednotlivých součástí
    • Správa licencí za použití manažera licencí SolidNetWork
Nadřazené téma: Násobné instalace


Použití administrativní kopie

Administrativní kopie umožňuje konfigurovatelné instalace produktů SolidWorks z jediného místa v síti.

Administrativní kopii můžete nainstalovat z kteréhokoli počítače v síti, včetně klientského počítače.
  • Administrativní kopie se musí nacházet ve sdílené složce.
  • Pokud zahrnete všechny produkty, může požadavek na místo na disku administrativní kopie dosáhnout 7GB a více.
  • Pokud aktualizujete název sdílení, když aktualizujete administrativní kopii, klient se automaticky aktualizuje při příštím spuštění aplikace. Detaily najdete na odkazu Upgrade klientů z administrativních kopií.
  • Klienti musí mít oprávnění správce na svých počítačích, pokud není pro klientské instalace specifikována možnost Spustit instalaci jako jiný uživatel.
    Tato možnost není podporována na Windows Vista nebo v pozdějších verzích.

Po vytvoření administrativní kopie může Editor možností administrativní kopie spravovat nastavení možností instalace pro uživatele a skupiny, kteří provádí instalaci z dané kopie. Podrobnosti najdete v Editor možností administrativní kopie.

  • Vytvoření administrativní kopie pomocí Manažera instalací SolidWorks
    Pokud instalujete program SolidWorks na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.
  • Editor možností administrativní kopie
    Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.
  • Oznámení o administrativní kopii klientům e-mailem
    Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.
  • Oznámení o administrativní kopii klientům
    Můžete spustit příkaz pro oznámení klientům o nové instalaci administrativní kopie.
Nadřazené téma: Násobné instalace


Vytvoření administrativní kopie pomocí Manažera instalací SolidWorks

Pokud instalujete program SolidWorks na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

  1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.

    Objeví se možnosti pro vytvoření administrativní kopie:

    Vytvořit novou kopii pomocí výchozích nastavení.
    Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie.
    Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
    Vytvořte 32-bitovou a 64-bitovou administrativní kopii.
    Můžete vytvořit jak 32-bitovou, tak i 64-bitovou kopii na jednom počítači, nebo jednoduše vytvořit kopii, která bude odpovídat architektuře daného počítače. K vytvoření obou kopií potřebujete mít přístup k 32-bitovým i 64-bitovým instalačním médiím.

  3. Postupujte podle návodu na obrazovce.
Nadřazené téma: Použití administrativní kopie


Editor možností administrativní kopie

Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.

Když vytváříte administrativní kopii, Manažer instalace SolidWorks vás vyzve ke spuštění Editoru možností. Editor možností můžete také spustit poklepáním na sldAdminOptionEditor.exe ve složce administrativní kopie.

Pro určení různých instalačních konfigurací pro skupiny počítačů nebo individuální počítače přidejte skupiny a počítače v Editoru možností a pak určete možnosti instalace pro tyto skupiny a počítače.

  • Probíhá přidávání a odstraňování skupin a počítačů
    Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.
  • Zobrazení a úpravy nastavení možnosti
    Editor možností administrativní kopie SolidWorks umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.
  • Přepínání mezi 32-bitovými a 64-bitovými kopiemi
    Pokud jste v instalačním adresáři administrativní kopie vytvořili jak 32-bitovou, tak i 64-bitovou kopii, Editor možností může pracovat s oběma kopiemi.
  • Zavádění instalací z editoru možností
    Instalace můžete zavádět přímo z Editoru možností pomocí pokynů v e-mailu k zahájení instalace.
  • Ukončení editoru možností
    Editor možností můžete ukončit klepnutím na OK nebo Zavřít.
  • Vytvoření zástupce pro Editor možností na ploše
    Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.
Nadřazené téma: Použití administrativní kopie


Probíhá přidávání a odstraňování skupin a počítačů

Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.

Například pokud chcete konfigurovat několik počítačů pro použití zvláštní podskupiny součástí produktu, které jsou dostupné v kopii, zatímco jiná skupina může použít jinou podskupinu součástí produktu. I když používáte administrativní kopii, nastavení skupina Editora možností vám umožní instalovat různé podskupiny produktů pro různé skupiny počítačů.

Chcete-li přidat skupinu:
  1. Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Přidat skupinu.
  2. Zadejte název souboru.
Přidat počítače:
  1. Klepněte pravým tlačítkem na stávající skupinu nebo Globální nastavení a pak klepněte na Přidat počítač.
    Pokud klepnete pravým tlačítkem na existující skupinu, budou k této skupině přidány počítače. Jinak jsou přidány na nejvyšší úroveň.
  2. Proveďte jeden z následujících kroků:
    • Vyberte jeden nebo více názvů počítačů pod Název počítače.

      Více počítačů může být odděleno zalomením řádky, mezerou, tabulátorem, čárkou, tečkou, dvojtečkou nebo středníkem. Můžete nakopírovat a vložit seznam názvů počítačů z externího souboru.

      Názvy počítačů nemohou zahrnovat určovatele domény. Například je název pluto.solidworks.com chybný.

    • Klepněte na položku Přidat více počítačů pro výběr počítačů ze sítě.
Návod na přesunutí existujícího počítače do skupiny: Přetáhněte počítač do skupiny.
Návod na přesunutí počítače ze skupiny: Přetáhněte počítač na Globální nastavení nebo do jiné skupiny.
Chcete-li smazat skupinu nebo počítač: Klepněte pravým tlačítkem na skupinu nebo počítač a klepněte na Odstranit skupinu nebo Odstranit počítač.
Pokud odstraníte skupinu, budou smazány všechny počítače uvnitř této skupiny.
Pro odstranění všech skupin a počítačů: Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Odstranit vše.
Nadřazené téma: Editor možností administrativní kopie


Zobrazení a úpravy nastavení možnosti

Editor možností administrativní kopie SolidWorks umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.

  • Když poprvé spustíte editor možností, zobrazí se nastavení možností v režimu jen pro čtení. Ikona Upravit není stínována: .
    Klepnutím na Globální nastavení se pro skupinu nebo počítač zobrazí shrnutí nastavení možností pro danou položku:
    Rozsah | Zobrazené nastavení možností
    Globální nastavení | Všechna nastavení možností zadaná pro administrativní kopii
    Skupina | Změny v nastavení skupin vzhledem ke globálním nastavením
    Počítač | Změny v nastavení počítače vzhledem ke skupině
  • Chcete-li provést změny v nastavení možností, klepněte na ikonu Upravit. Ikona se změní na stínovanou ( [image]) a zobrazí se podrobnější výpis nastavení možností.

    Klepnutím na Globální nastavení budete moci pro skupinu nebo počítač změnit nastavení možností pro danou položku. Když provedete změnu nastavení možností, která se liší od zděděných globálních nastavení nebo nastavení skupiny, bude toto nastavení možností zvýrazněno.

    Když znovu klepnete na ikonu Upravit, zobrazení se vrátí zpět do režimu jen pro čtení.

    Když provedete změny, Editor možností vás vyzve, abyste je před skončením uložili nebo zrušili.

  • Určení nastavení možností pro skupiny a počítače
    Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.
  • Dědičnost globálních nastavení a nastavení možností skupin
    Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.
Nadřazené téma: Editor možností administrativní kopie


Určení nastavení možností pro skupiny a počítače

Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.

  1. Klepněte na objekt, který chcete změnit (například Globální nastavení, skupinu, nebo počítač).
  2. Vpravo klepněte na ikonu Upravit [image].

    Ikona Upravit se změní na stínovanou ( [image]) a zobrazí se podrobnější výpis nastavení možností.

  3. Proveďte změny nastavení možností klepnutím na nastavení možností vpravo pro položku vybranou vlevo.

    Změny v nastavení možností, které potlačí Globální nastavení nebo nastavení skupin, jsou zvýrazněny.

  4. Klepnutím na OK nebo Zavřít uložte provedené změny.

    OK
    Editor možností uloží vaše změny a ukončí aplikaci.
    Zavřít
    Editor možností se zeptá, zda chcete uložit provedené změny a poté ukončí aplikaci.

  • Možnost nastavení administrativní kopie
    Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.
Nadřazené téma: Zobrazení a úpravy nastavení možnosti


Možnost nastavení administrativní kopie

Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.

Sériová čísla

Zadejte sériová čísla pro produkty, které budete instalovat na klientské počítače.
Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SolidWorks. Například sériové číslo SolidWorks vám umožní nainstalovat SolidWorks Simulation bez zadání sériového čísla SolidWorks Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoliv dotazy ohledně sériových čísel, kontaktujte místního prodejce.
Pokud spravujete licence pomocí správy licencí SolidNetWork:
  • Do prvního pole pro sériové číslo zadejte sériové číslo SolidNetWork.
  • Do pole SNL Server port@server zadejte název serveru Manažera licencí SolidNetWork a port ve formátu nnnnn@název serveru. Více položek oddělte středníkem.

Více informací o správě licencí SolidNetWork viz Instalace a konfigurace licencí SolidNetWork.

Možnosti klientské instalace

Jakým způsobem provést klientské instalace hlavních verzí?
Můžete určit, jak budou klientské instalace nakládat se stávající instalací hlavní verze:
  • Upgradovat stávající hlavní verzi (pokud existuje).

    Určete tuto možnost, pokud chcete nahradit předchozí hlavní verzi instalací nové verze.

  • Vytvořit novou hlavní verzi.

    Určete tuto možnost, pokud chcete zachovat předchozí hlavní verzi a vytvořit novou instalaci pro novou hlavní verzi.

    Chcete-li zadat umístění pro instalaci nové verze, klepněte na Procházet.

Chcete nejprve odinstalovat předchozí verzi než nainstalujete novou hlavní verzi?
Můžete určit, zda se má odinstalovat stávající instalace předchozí hlavní verze:
  • Ne, neodinstalovat.

    Tuto možnost vyberte, chcete-li zachovat předchozí instalaci hlavní verze.

  • Ano, provést vlastní odinstalování.
    Tuto možnost vyberte, pokud chcete odstranit následující položky:
    • Programové soubory a složky
    • Položky registru
    • Datové soubory a složky
Jakým způsobem se mají aplikovat nastavení programu SolidWorks?
Můžete určit, zda mají klientské instalace nakonfigurovat nastavení SolidWorks podle nastavení SolidWorks nakonfigurovaných na klientském počítači nebo podle nastavení SolidWorks vyexportovaných z Průvodce kopírováním nastavení.
  • Použít aktuální nastavení (pokud existují) nebo použít výchozí nastavení SolidWorks

    Pokud klientský počítač nadefinoval nastavení SolidWorks, zachovejte tato nastavení. (Pro všechna nastavení, která nejsou specificky nadefinována na klientovi, použije klientská instalace výchozí nastavení SolidWorks.)

  • Použít soubor nastavení exportovaný z Průvodce kopírováním nastavení.
    Výběr nastavení této možnosti vám umožňuje určit nastavení možnosti ze stávajícího souboru exportu Průzkumníka kopírováním nastavení. (Tento soubor se většinou jmenuje solidworkssettings.sldreg.)
    • Klepnutím na Vyhledat vyhledejte existující soubor nastavení.
    • Klepnutím na Nový spusťte Průvodce kopírováním nastavení a vytvořte nový soubor nastavení.
Jak aktivovat klientské instalace?
Můžete určit, zda chcete dokončit aktivaci produktu automaticky po spuštění instalace, nebo zda má aktivaci produktu provést po instalaci ručně uživatel.
  • Aktivovat automaticky po dokončení každé klientské instalace.
    Výběr tohoto nastavení možnosti určuje, že k aktivaci produktu dochází automaticky pomocí souboru Aktivace produktu SolidWorks. (Tento soubor se většinou jmenuje AutoActivation.xml.)
    • Klepnutím na Vyhledat vyhledejte existující soubor aktivace.
    • Klepnutím na Nový spusťte Aktivace produktu SolidWorks a vytvořte nový soubor aktivace.
  • Neaktivovat automaticky.

    Výběr této možnosti znamená, že nedojde k žádné automatické aktivaci produktu. Uživatel klienta provede aktivaci produktu po instalaci.

Pokud zvolíte automatickou aktivaci produktu, musí být administrativní kopie dostupná ve sdíleném umístění na síti, když klienti po instalaci poprvé spustí SolidWorks. Pokud nebude administrativní kopie dostupná klientům, kteří z ní nainstalovali, nebudou moci dokončit automatickou aktivaci produktu. Tito klienti nebudou moci spustit SolidWorks, pokud neprovedou ruční aktivaci produktu SolidWorks.

Možnosti správy

Během každé instalace vytvořte soubor protokolu pro diagnostiku.
Klientská instalace může vytvořit diagnostický protokol, který lze použít k řešení problémů s instalací. Vytvoření tohoto protokolu může zpomalit klientskou instalaci.
Spustit instalaci jako jiný uživatel.
Klientská instalace může běžet jako jiný uživatel. Tato volba může být užitečná, když jednotliví uživatelé nemají na svých počítačích místní oprávnění správce (která jsou nutná k instalaci produktů SolidWorks).
Tato možnost není podporována na Windows Vista, Windows 7 nebo v pozdějších verzích.
Před nebo po instalaci spusťte program.
Můžete určit, že se má před nebo po klientské instalaci spustit vlastní program.
Chcete se zúčastnit Programu zkušeností zákazníka SolidWorks?
Můžete určit, že se klientské počítače mají účastnit Programu zkušeností zákazníků SolidWorks. Informace o výkonu jsou zasílány společnosti SolidWorks Corporation ke zlepšení programu. Tento proces je transparentní a důvěrný. Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Software k instalaci

Můžete určit, které součásti produktu SolidWorks se mají nainstalovat.
  • Výběrem zaškrtávacího políčka vedle součásti produktu určíte, že se má daná součást nainstalovat během klientské instalace.
  • Je-li výběr zaškrtávacího políčka zrušen, součást nebude nainstalována.
  • Pokud součást zahrnuje volitelné dílčí součásti pro instalaci, objeví se vedle součásti ikona + . Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu + .
  • Pokud jste rozbalili součást tak, aby se u ní zobrazily volitelné dílčí součásti, zobrazí se vedle součásti ikona - . Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu - .
Specifikace Jazyky omezuje jazyky, které jsou naistalovány jen pro produkt SolidWorks. Toto nastavení nemá vliv na instalace ostatních produktů. Například SolidWorks eDrawings®, SolidWorks Workgroup PDM a SolidWorks Explorer jsou nainstalovány ve všech jazycích.

Možnosti Toolbox

Můžete určit, které normy mají být podporovány, a výchozí umístění Toolbox pro klientské instalace.

Je běžné, že má více uživatelů přístup ke sdílené knihovně Toolbox, typicky prostřednictvím síťového umístění (například cesty UNC, sdílené složky nebo určené obecné síťové jednotky).

Pokud umístění obsahuje starší hlavní verzi Toolbox, klientská instalace upgraduje daný Toolbox na novou hlavní verzi. Soubory již nebudou kompatibilní s předchozími hlavními verzemi SolidWorks.
Pokud chcete zachovat Toolbox pro starší verzi SolidWorks (například pokud někteří klienti nadále používají starší verzi), musíte určit jiné síťové umístění pro klienty, kteří upgradují na novější verzi.

Podrobnosti o správě SolidWorks Toolbox viz informace o Toolbox v Nápovědě SolidWorks.

Nadřazené téma: Určení nastavení možností pro skupiny a počítače


Dědičnost globálních nastavení a nastavení možností skupin

Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.

Příklad:
  • Nastavení definovaná pro Globální nastavení dědí všechny skupiny a počítače.
  • Nastavení definovaná pro skupiny dědí všechny počítače uvnitř této skupiny.

Můžete změnit nastavení možností pro počítač nebo skupinu počítačů tak, aby se přepsala výchozí nebo zděděná nastavení. Když změníte nastavení možností z výchozí nebo zděděné hodnoty, volba je zvýrazněna.

Chcete-li vrátit nastavení na původní zděděné hodnoty, klepněte pravým tlačítkem myši na skupinu nebo počítač a klepněte na Obnovit globální nastavení (pro skupinu nebo počítač, který není členem skupiny) nebo Obnovit skupinová nastavení (pro počítač, který je členem skupiny).
Nadřazené téma: Zobrazení a úpravy nastavení možnosti


Přepínání mezi 32-bitovými a 64-bitovými kopiemi

Pokud jste v instalačním adresáři administrativní kopie vytvořili jak 32-bitovou, tak i 64-bitovou kopii, Editor možností může pracovat s oběma kopiemi.

  • V Editoru možností klepněte na 32 nebo 64, podle toho, zda chcete pracovat s 32-bitovou nebo 64-bitovou kopií.

    Klepnutím na Instalovat nebo Zavést si můžete zobrazit a změnit nastavení možností nebo zavést instalace pro danou kopii.

Pokud máte jak 32-bitovou, tak i 64-bitovou kopii, musíte pro každou z nich samostatně určit Globální nastavení, skupiny a nastavení skupin a jednotlivá nastavení počítače.
Nadřazené téma: Editor možností administrativní kopie


Zavádění instalací z editoru možností

Instalace můžete zavádět přímo z Editoru možností pomocí pokynů v e-mailu k zahájení instalace.

Musíte změnit instalační adresář administrativní kopie na sdílený adresář Windows, aby byl k dispozici prostřednictvím síťového umístění (například \\počítač\sdílený_adresář).

  1. V Editoru možností klepněte na Zavést.
  2. Máte-li 32-bitové a 64-bitové kopie nakonfigurované na tento instalační adresář administrativní kopie, klepnutím na 32 nebo 64 si zobrazíte počítače pro 32-bitovou a 64-bitovou kopii.

    Objeví se dostupnost instalace a stav pro jednotlivé počítače.

  3. Klepněte na Odeslat e-mail.
  4. Zadejte síťovou cestu k instalačnímu adresáři administrativní kopie.

    Typicky se cesta k instalačnímu adresáři administrativní kopie zobrazuje nejprve jako cesta k souboru Windows (například C:\SolidWorks Admin\SolidWorks 2011 SP0). V dialogovém okně se zobrazí Tato cesta není síťová cesta.

    1. Klepněte na Procházet a určete síťové umístění pro tento instalační adresář pro administrativní kopii.
    2. Vyhledejte počítač, na němž je nainstalována administrativní kopie a vyberte sdílený adresář Windows, který jste specifikovali jako instalační adresář pro administrativní kopii.

      Nepřecházejte do sdíleného adresáře administrativní kopie (například do podadresářů 32bit nebo 64bit).

    3. Klepněte na OK.

      V dialogovém okně se zobrazí Tato cesta je síťová cesta.

    Vygeneruje se e-mail s pokyny pro majitele počítače ohledně instalace z administrativní kopie v síťovém umístění pro soubor administrativní kopie StartSWInstall.hta.

  5. Odešlete tento e-mail uživatelům odpovědným za instalaci SolidWorks.

Uživatelé mohou nainstalovat SolidWorks z administrativní kopie poklepáním na odkaz na síťové umístění pro soubor StartSWInstall.hta v e-mailu.

V Editoru možností se zobrazí tento Stav instalace:
Čeká na vyřízení
Uživatel zatím nespustil na tomto počítači instalaci.
Úspěšně
Uživatel úspěšně dokončil instalaci na tomto počítači.
Neúspěšně
Uživatel spustil instalaci na tomto počítači, ale ta selhala.
  • Použití namapovaného disku k zavedení administrativní kopie
    Doporučenou metodou pro určení síťového umístění pro instalační adresář administrativní kopie je cesta UNC (\\název_počítače\název_sdíleného_adresáře). Namapovaný disk však můžete použít jako umístění pro soubor StartSWInstall.hta v administrativní kopii (například U:\StartSWInstall.hta), za předpokladu, že mají všichni instalující uživatelé namapovánu jednotku se stejným písmenem na sdílený adresář administrativní kopie.
Nadřazené téma: Editor možností administrativní kopie


Použití namapovaného disku k zavedení administrativní kopie

Doporučenou metodou pro určení síťového umístění pro instalační adresář administrativní kopie je cesta UNC (\\název_počítače\název_sdíleného_adresáře). Namapovaný disk však můžete použít jako umístění pro soubor StartSWInstall.hta v administrativní kopii (například U:\StartSWInstall.hta), za předpokladu, že mají všichni instalující uživatelé namapovánu jednotku se stejným písmenem na sdílený adresář administrativní kopie.

Pokud například namapujete jednotku U: na sdílený adresář administrativní kopie, e-mail s oznámením informuje uživatele o tom, že mají klepnout na odkaz na file://U:\StartSWIOnstall.hta. Uživatelé, kteří e-mail dostanou, mohou úspěšně provést instalaci, za předpokladu, že je disk U: namapován na umístění UNC pro administrativní kopii (\\název_počítače\název_sdíleného_adresáře).

Nadřazené téma: Zavádění instalací z editoru možností


Ukončení editoru možností

Editor možností můžete ukončit klepnutím na OK nebo Zavřít.

  • Klepněte na OK, Zavřít nebo zavřete okno pomocí tlačítka Zavřít ve Windows. Dojde k aplikaci změn a ukončení Editoru možností.
    • Klepnutím na OK aplikujete změny nastavení možností a ukončíte Editor možností.
    • Klepnutím na Zavřít ukončíte Editor možností.

      Pokud se mají použít nějaké změny, budete dotázáni, zda je chcete uložit.

    • Klepněte na tlačítko Zavřít v aplikaci (X). Pokud se mají použít nějaké změny, budete dotázáni, zda je chcete uložit.
Nadřazené téma: Editor možností administrativní kopie


Vytvoření zástupce pro Editor možností na ploše

Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.

  1. Spusťte Editor možností.

    V Průzkumníku Windows vyhledejte instalační adresář administrativní kopie a poklepejte na soubor sldAdminOptionEditor.exe.

  2. Klepněte na Vytvořit zástupce na ploše pro tento Editor možností.

    Na ploše Windows se objeví zástupce Editoru možností administrativní kopie.

Nadřazené téma: Editor možností administrativní kopie


Oznámení o administrativní kopii klientům e-mailem

Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.

Nakonfigurujte adresář administrativní kopie tak, aby byl sdílen na počítači, který je přístupná jiným počítačům (například pomocí cesty UNC).

Můžete zaslat všem klientům mail obsahující odkaz na instalační_adresář_administrativní_kopie\StartSWInstall.hta. Klienti poté mohou klepnutím na tento odkaz a výběrem Nyní instalovat SolidWorks spustit instalaci z administrativní kopie.

Chcete-li upgradovat administrativní kopii na novou verzi SolidWorks, můžete konfigurovat místo vaší administrativní kope a sdílené vlastnosti tak, že všichni klienti, kteří byli nainstalováni předtím za použití kopie, budou upgradováni automaticky. Podrobnosti najdete v Upgradování klientů z administrativní kopie.
Nadřazené téma: Použití administrativní kopie


Oznámení o administrativní kopii klientům

Můžete spustit příkaz pro oznámení klientům o nové instalaci administrativní kopie.

Oznámení e-mailem je všeobecně používaný způsob oznámení uživatelům o nové instalaci SolidWorks. Podrobnosti najdete v Oznámení o administrativní kopii klientům e-mailem.

Alternativním způsobem je oznámení klientům o nové instalaci spuštěním příkazu. Například můžete novou instalaci oznámit zaměstnancům, kteří obvykle program SolidWorks nepoužívají.

Oznámení SolidWorks vloží zástupce aplikace SolidWorks do nabídky Start na počítači uživatele a vytvoří asociaci souboru s administrativní kopií na serveru. Spustitelné soubory nejsou hned instalovány. K instalaci dojde pouze, když uživatel poprvé potřebuje program.

když uživatel klepne na zástupce nebo poklepne na dokument SolidWorks, začne instalace a je spuštěn program SolidWorks.

Návod na oznámení z administrativní kopie:

  1. Vytvoření nebo konfigurace administrativní kopie.
  2. Inzerujte produkt na každém počítači, který má nainstalovanou aplikaci SolidWorks.

    Příklad:

    msiexec /jm cesta_k_souboru_msi_administrativní_kopie

    kde cesta_k_souboru_msi_administrativní_kopie je cesta UNC do adresáře administrativní kopie.

Nadřazené téma: Použití administrativní kopie


Zavedení pomocí příkazového řádku

Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).

  • Vytvoření administrativní kopie pomocí příkazového řádku
    Administrativní kopii můžete vytvořit pomocí Manažera instalací SolidWorks nebo pomocí příkazového řádku MS-DOS.
  • Příprava klientů na instalaci z příkazového řádku z administrativní kopie
    Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.
  • Instalace z administrativní kopie s použitím příkazového řádku
    Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.
  • Vlastnosti v příkazovém řádku
    Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.
  • Zavádění administrativní kopie pomocí Microsoft Active Directory
    Zavedení pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SolidWorks na klientské počítače.
Nadřazené téma: Násobné instalace


Vytvoření administrativní kopie pomocí příkazového řádku

Administrativní kopii můžete vytvořit pomocí Manažera instalací SolidWorks nebo pomocí příkazového řádku MS-DOS.

Pokud vytváříte administrativní kopie z příkazového řádku, musíte vytvořit a zavést zvláštní kopii pro každou součást produktu SolidWorks spuštěním souboru .msi pro tuto součást. Pokud instalujete neanglické jazyky, musíte vytvořit a zavést zvláštní kopii pro každý neanglický jazyk spuštěním souboru .msi pro tento jazyk. Podrobné informace o umístění souborů .msinajdete v Umístění souboru MSI administrativní kopie.
  1. Otevřete Příkazový řádek .
    1. Ve Windows klepněte naStart > Spustit.
    2. Zadejte cmd a klepněte na OK.
  2. Zadejte tento příkaz:

    msiexec /a Msi_path

    kde Msi_path je umístění souboru .msi pro váš operační systém. Soubor SolidWorks.msi je umístěn v podadresáři swwi\data v instalačním adresáři.

    Příklad:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. V Průvodci instalací SolidWorks postupujte podle návodu na obrazovce.
  4. Pokud instalujete produkty SolidWorks pro neanglické jazyky, vytvořte zvláštní administrativní kopii pro tento jazyk za použití tohoto příkazu:

    msiexec /a Msi_path_for_language

    kde Msi_path_for_language je umístění souboru .msi pro jazyk. Například je soubor french.msi umístěn v podadresáři swwi\lang\french v instalačním adresáři.

    Příklad:

    msiexec /a F:\swwi\lang\french\french.msi

Nadřazené téma: Zavedení pomocí příkazového řádku


Příprava klientů na instalaci z příkazového řádku z administrativní kopie

Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.

Ruční instalace těchto komponentů Windows je nutná pouze tehdy, pokud instalujete z administrativní kopie, která byla vytvořena za použití příkazového řádku nebo pomocí Microsoft Active Directory. Pokud použijete Manažera instalací SolidWorks pro vytvoření a instalaci administrativní kopie, tyto komponenty Windows se instalují automaticky.
Zde je souhrn souborů požadovaných SolidWorks v komponentech Windows:
Instalační služba Windows Installer
Obsahuje soubory potřebné ke spuštění instalace SolidWorks Simulation Premium.
Součásti Office Web
Obsahují ovladače COM potřebné pro DriveWorks.
Balíček k opětovné distribuci Visual C++ 2005 a 2008
Obsahuje komponenty typu runtime pro Microsoft Visual C++.
Musí být instalovány obě verze 2005 a 2008.
Nástroje Visual Studio pro aplikace
Obsahuje sadu nástrojů podporující aplikace Visual Studio.
Vzdálený ladící program Visual Studio
Poskytuje ladící prostředí pro 64bitové operační systémy.
.NET Framework
Obsahuje společný jazykový modul runtime a komponenty.NET Framework, které jsou zapotřebí pro spuštění aplikací .NET Framework.
Windows Desktop Search (volitelně)
Podporuje rychlé vyhledávání souborů a dat v různých zdrojích a umístěních dat, včetně místního počítače a sdílených položek na síti.
Soubory Windows Desktop Search jsou specifické podle jazyka. Podrobnosti najdete v Jazyková podpora Windows Desktop Search.
Balíček k opětovné distribuci Visual C++ a .NET Framework 3,5 jsou nutné pro všechny produkty SolidWorks, ne pouze pro hlavní program SolidWorks.

Tyto součásti musí být zahrnuty v podsložkách administrativní kopie.

Tato tabulka určuje specifické soubory požadované pro každý podporovaný operační systém.
Operační systém: Windows 2003 32-bit1
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | (nepoužitelný)
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-<lang.exe
Operační systém: Windows 2003 64-bit1
Média SolidWorks: 64bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Operační systém: Windows 2008 32-bit1
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | (nepoužitelný)
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné): |  | Windows Desktop Search je funkce operačního systému.
Operační systém: Windows 2008 64-bit1
Média SolidWorks: 64bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné): |  | Windows Desktop Search je funkce operačního systému.
Operační systém:Windows XP 32-bit
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | (nepoužitelný)
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné):
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-<lang.exe
Operační systém:Windows XP 64-bit
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Operační systém:Windows XP 64-bit
Média SolidWorks: 64bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Operační systém: Windows Vista 32-bit
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | (nepoužitelný)
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné): |  | Windows Desktop Search je funkce operačního systému.
Operační systém: Windows Vista 64-bit
Média SolidWorks: 64bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | dotnetfx35.exe
 | Windows Desktop Search (volitelné): |  | Windows Desktop Search je funkce operačního systému.
Operační systém: Windows 7 32bitová verze
Média SolidWorks: 32bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | (nepoužitelný)
 | .NET Framework |  | .NET Framework a Windows Desktop Search jsou funkce operačního systému.
 | Windows Desktop Search (volitelné):
Operační systém: Windows 7 64bitová verze
Média SolidWorks: 64bitová verze pro Windows XP, Windows Vista a Windows 7
 | Instalační služba Windows Installer: |  | (nepoužitelný)
 | Součásti Office Web: |  | owc11.exe
 | Balíček k opětovné distribuci Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Balíček k opětovné distribuci Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
 | Nástroje Visual Studio pro aplikace: |  | vsta_aide.msi
 | Vzdálený ladící program Visual Studio: |  | rdbgexp.msi
 | .NET Framework |  | .NET Framework a Windows Desktop Search jsou funkce operačního systému.
 | Windows Desktop Search (volitelné):
1Instalace na operačním systému Windows 2003, nebo na Windows 2008 je podporována pouze pro PDM Workgroup Server a licenční server SolidNetWork (SNL).
  • Předpoklady instalace ve Windows z příkazového řádku na 32bitových operačních systémech
    Při instalaci předpokladů ve Windows pro instalace administrativní kopie za použití příkazového řádku na 32bitových verzích Windows postupujte podle těchto pokynů.
  • Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech
    Při instalaci předpokladů ve Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows postupujte podle těchto pokynů.
  • Vyhledávání v SolidWorks a v Microsoft Windows Desktop
    Vyhledávání SolidWorks je začleněno do vyhledávání Microsoft® Windows® Desktop.
Nadřazené téma: Zavedení pomocí příkazového řádku


Předpoklady instalace ve Windows z příkazového řádku na 32bitových operačních systémech

Při instalaci předpokladů ve Windows pro instalace administrativní kopie za použití příkazového řádku na 32bitových verzích Windows postupujte podle těchto pokynů.

Pokud chcete jednou instalační operací nainstalovat několik součástí, vytvořte dávkový soubor s příkazy obsaženými v následujících pokynech. Poté tento soubor použijte k instalaci součástí na klientské počítače.

  1. Ujistěte se, že je na cílovém počítači alespoň 290 MB volného místa na disku a platná složka TEMP.
  2. Nainstalujte součásti Office Web spuštěním tohoto příkazu:

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. Pro Windows XP, nainstalujte Instalační službu systému Windows:

    administrative_image_directory\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Není zapotřebí instalovat instalační službu systému Windows na jiné verzi Windows než je Windows XP.

  4. Nainstalujte balíček k opětovné distribuci Visual C++ 2005:

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Nainstalujte balíček k opětovné distribuci Visual C++ 2008:

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Pro Windows XP a Windows Vista nainstalujte .NET Framework 3.5 za použití aktualizačních služeb serveru Windows.

    .NET Framework nemusíte instalovat na Windows 7 nebo pozdější verze.

  7. Nainstalujte nástroje Visual Studio pro aplikace:

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

Nadřazené téma: Příprava klientů na instalaci z příkazového řádku z administrativní kopie


Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech

Při instalaci předpokladů ve Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows postupujte podle těchto pokynů.

Pokud chcete jednou instalační operací nainstalovat několik součástí, vytvořte dávkový soubor s příkazy obsaženými v následujících pokynech. Poté tento soubor použijte k instalaci součástí na klientské počítače.

  1. Ujistěte se, že je na cílovém počítači alespoň 620 MB volného místa na disku a platná složka TEMP.
  2. Nainstalujte součásti Office Web spuštěním tohoto příkazu:

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. Nainstalujte balíček k opětovné distribuci Visual C++ 2005:

    administrative_image_directory\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Musí být nainstalovány obě 32bitová i 64bitová verze tohoto balíčku.

  4. Nainstalujte balíček k opětovné distribuci Visual C++ 2008:

    administrative_image_directory\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Musí být nainstalovány obě 32bitová i 64bitová verze tohoto balíčku.

  5. Pro Windows XP a Windows Vista nainstalujte .NET Framework 3.5 za použití aktualizačních služeb serveru Windows.

    .NET Framework nemusíte instalovat na Windows 7 nebo pozdější verze.

  6. Nainstalujte nástroje Visual Studio pro aplikace:

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

  7. Nainstalujte vzdálený ladící program Visual Studio:

    administrative_image_directory\VSRemoteDebugger\install.exe /Q

Nadřazené téma: Příprava klientů na instalaci z příkazového řádku z administrativní kopie


Vyhledávání v SolidWorks a v Microsoft Windows Desktop

Vyhledávání SolidWorks je začleněno do vyhledávání Microsoft® Windows® Desktop.

Pokud nemáte nainstalovánu správnou verzi Microsoft Windows Desktop Search na vašem počítači, budete během instalace SolidWorks vyzváni, abyste tuto službu nainstalovali, nebo aktualizovali.

Když vytváříte administrativní kopii, není Windows Desktop Search zahrnut do adresáře administrativní kopie. Microsoft Windows Desktop Search se musí nainstalovat ručně na klientských počítačích, které instalují SolidWorks z administrativní kopie, pokud chtějí tyto počítače používat vyhledávání v SolidWorks.

Nadřazené téma: Příprava klientů na instalaci z příkazového řádku z administrativní kopie


Instalace z administrativní kopie s použitím příkazového řádku

Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.

Návod na tichou instalaci:
  1. Otevřete okno s příkazovým řádkem (klepněte ve Windows na Start > Spustit.
  2. V okně zadejte příkaz msiexec.exe s parametry /i a /qb a nastavte vlastnosti pro jakékoliv možnosti, které nejsou součástí výchozích hodnot zobrazených níže.
Vlastnosti individuální instalace příkazového řádku součásti zahrnuje:
  • Vlastnosti funkcí v příkazovém řádku
  • Globální vlastnosti v příkazovém řádku
  • SolidWorks eDrawings - vlastnosti v příkazovém řádku
  • Průzkumník SolidWorks/Workgroup PDM - vlastnosti v příkazovém řádku
  • SolidWorks Simulation - vlastnosti v příkazovém řádku
Použijte následující příklady jako šablony pro bezobslužnou (tichou) instalaci.
SolidWorks klient
  • SolidWorks (hlavní část) (anglicky)
  • Doplňkový modul Toolbox
  • Účast v programu zpětné vazby zákazníků
  • Francouzština

32-bitová verze SolidWorks na 32-bitovém operačním systému:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

32bitová verze SolidWorks na 64bitovém operačním systému:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

64bitová verze SolidWorks na 64bitovém operačním systému:

msiexec /i "64-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

Součást instalace SolidWorks ve francouzštině musí být instalována zvlášť:
  • 32bitová verze:

    msiexec /i "32-bit_admin_image_path\SolidWorks French\french.msi" /qb

  • 64bitová verze:

    msiexec /i "64-bit_admin_image_path\SolidWorks French\french.msi" /qb

Při zadávání povelů jazykové součásti instalace SolidWorks nezadávejte argumenty v příkazovém řádku:
eDrawings klient
  • Protokol o výkonu
  • Všechny funkce

msiexec /i "admin_image_path\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb
Průzkumník SolidWorks a doplňkový modul PDM
  • Průzkumník SolidWorks s doplňkovým modulem PDM Workgroup

msiexec /i "admin_image_path\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\your_folder" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
Nadřazené téma: Zavedení pomocí příkazového řádku


Vlastnosti v příkazovém řádku

Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.

  • Vlastnosti funkcí v příkazovém řádku
    Instalace SolidWorks podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.
  • Globální vlastnosti v příkazovém řádku
    Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.
  • SolidWorks eDrawings - vlastnosti v příkazovém řádku
    Tyto vlastnosti příkazového řádku jsou specifické pro eDrawings.
  • Průzkumník SolidWorks/Workgroup PDM - vlastnosti v příkazovém řádku
    Tyto vlastnosti v příkazovém řádku jsou specifické pro Průzkumník SolidWorks a SolidWorks Workgroup PDM.
  • SolidWorks Simulation - vlastnosti v příkazovém řádku
    Tyto vlastnosti příkazového řádku jsou specifické pro SolidWorks Flow Simulation.
  • Umístění souboru MSI administrativní kopie
    Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SolidWorks.
  • Jazyková podpora Windows Desktop Search
    Názvy souborů Windows Desktop Search označují platformu a jazyk.
Nadřazené téma: Zavedení pomocí příkazového řádku


Vlastnosti funkcí v příkazovém řádku

Instalace SolidWorks podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (pro 32-bitovou verzi SolidWorks na 32-bitových operačních systémech)
  • Intel_Modules_AgeiaX64 (pro 32-bitovou verzi SolidWorks na 64-bitových operačních systémech)
  • Příručky
  • Pohyb
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulace
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
Při zadávání vlastností pro instalaci příkazového řádku:
  • SolidWorks nepodporuje instalaci produktu pomocí možnosti ADDSOURCE.
  • Parametry rozlišují malá a velká písmena, nesmějí obsahovat mezery nebo pomlčky a musí být odděleny čárkami.
  • Zadejte SolidWorks, aby se program SolidWorks nainstaloval správně.
Nadřazené téma: Vlastnosti v příkazovém řádku


Globální vlastnosti v příkazovém řádku

Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.

Vlastnost | Popis
ENABLEPERFORMANCE Určuje, zda má program automaticky odeslat emailem data o výkonu společnosti SolidWorks Corporation.

1 pro odeslání dat o výkonu, jinak 0.
INSTALLDIR Instalační složka pro SolidWorks.

Pouze pro individuální instalace.
INSTALLWDS Nainstalujte rozšířené prostředí SolidWorks, které používá vyhledávací stroj Microsoft Windows Desktop. Detaily najdete na odkaze Příprava klientů na instalaci z administrativní kopie.

1 pro instalaci rozšířeného prostředí, jinak 0.
MOTIONSERIALNUMBER | Sériové číslo pro produkt SolidWorks Motion
OFFICEOPTION Určete produktový balíček, který chcete nainstalovat:
0
SolidWorks klient
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
NOVÁ INSTALACE Vyberte ALL pro aktualizace všech funkcí, které byly nyní instalovány.
Zadejte tuto vlastnost pouze tehdy, když aktualizujete na nový service pack v rámci stávající verze (například aktualizace stávající instalace SolidWorks 2011 SP01 na SolidWorks 2011 SP02).
REINSTALLMODE Možnosti nové instalace aplikace Microsoft Installer.

Když například aktualizujete instalaci z jednoho vydání service pack na jiné uvnitř stejného hlavního vydání, měli byste specifikovat REINSTALLMODE=vomus.

Podrobnosti o možnostech REINSTALLMODE najdete v dokumentaci Windows Installer na stránce www.microsoft.com.

Zadejte tuto vlastnost pouze tehdy, když aktualizujete na nový service pack v rámci stávající verze (například aktualizace stávající instalace SolidWorks 2011 SP01 na SolidWorks 2011 SP02). Nezadávejte tuto vlastnost, pokud poprvé instalujete hlavní verzi SolidWorks.
SERVERLIST Určuje seznam serverů SolidNetWork.
Seznam serverů SolidNetWork je seznam řetězců oddělených středníkem, z nichž každý je přiřazen číslu portu na serveru v následujícím formátu:

xxxxx@server_name1;yyyyy@server_name2;&

kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.

Pouze pro individuální instalace.
SIMULATIONSERIALNUMBER | Sériové číslo pro produkt SolidWorks Motion
SOLIDWORKSSERIALNUMBER | Sériové číslo pro produkt SolidWorks, které zahrnuje všechny doplňkové moduly.
SWMIGRATE Verze SolidWorks pro inovaci, jak by byla zobrazena v seznamu v dialogovém okně Výběr instalace SolidWorks . Příklad:

SWMIGRATE="SolidWorks 2011 SP01"

Zadejte tuto vlastnost pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze service packu na jinou v rámci té samé hlavní verze.
TARGETDIR Instalační složka pro SolidWorks.

Pouze pro administrativní instalace.
TOOLBOXFOLDER Instalační složka pro SolidWorks Toolbox soubory.

Pouze pro individuální instalace.
TRANSFORMS Obsahuje položky specifické pro jazyk v podobě:
TRANSFORMS number.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Určuje, zda je nutné provést upgrade stávající verzi SolidWorks na aktuální verzi.
0
Nová instalace, neprovádějte upgrade
1
Aktualizovat

Pouze pro individuální instalace.

Zadejte tuto vlastnost pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze service pack na jinou v rámci té samé hlavní verze.
Nadřazené téma: Vlastnosti v příkazovém řádku


SolidWorks eDrawings - vlastnosti v příkazovém řádku

Tyto vlastnosti příkazového řádku jsou specifické pro eDrawings.

Vlastnost | Popis
ADDLOCAL Určuje, která část aplikace SolidWorks eDrawings má být nainstalována.

All je doporučená možnost.
Syntaxe příkazového řádku: Prvek:
Všechny | Nainstaluje všechny funkce. Program eDrawings hledá nainstalované programy Publisher SolidWorks a AutoCAD a ověří instalaci.
eDrawingsViewer | Zobrazení souborů eDrawings a ostatních souborů.
PublisherForAutoCADR14 | Vytvoření souborů eDrawings z aplikace AutoCAD R14.
PublisherForAutoCAD2000 | Vytvoření souborů eDrawings z aplikace AutoCAD 2000.
PublisherForAutoCAD2004 | Vytvoření souborů eDrawings z aplikace AutoCAD 2004.
PublisherForAutoCAD2005 | Vytvoření souborů eDrawings z aplikace AutoCAD 2005.
PublisherForAutoCAD2006 | Vytvoření souborů eDrawings z aplikace AutoCAD 2006.
DXFDWGTranslator | Zobrazení souborů DXF/DWG v prohlížeči eDrawings.
Shortcuts | Instalace zástupce na ploše.
XML3D | Zobrazení souborů 3DXML v prohlížeči eDrawings.
INSTALLDIR | Určuje instalační složku pro SolidWorks eDrawings.
LOGPERFORMANCE Určuje, zda má program automaticky odeslat emailem data o výkonu společnosti SolidWorks Corporation.
1
Odeslání dat o výkonu
0
Jinak
SNLSERVER Zadejte port@servername pro váš licenční server SolidNetWork. Použijte středníky pro rozdělení více kombinací port@servername.

Pro konfiguraci serveru SolidWorks SNL je požadován pouze název serveru portu pro SNLSERVER. list_of_port@server_strings je seznam textových řetězců ohraničených středníky, z nichž každý odkazuje formátem na číslo portu na serveru:

xxxxx@server_name1; yyyyy@server_name2;

kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma: Vlastnosti v příkazovém řádku


Průzkumník SolidWorks/Workgroup PDM - vlastnosti v příkazovém řádku

Tyto vlastnosti v příkazovém řádku jsou specifické pro Průzkumník SolidWorks a SolidWorks Workgroup PDM.

Pro klienta aplikace Průzkumník SolidWorks/Workgroup PDM:
Parametr klienta | Popis
EXPLORERORPDM
0
Pouze pro aplikaci Průzkumník SolidWorks
1
Je možné instalovat funkce Workgroup PDM
ADDLOCAL
  • Samostatná verze
  • Klient
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone je Contributor a Klient je doplňkový modul SolidWorks pro tiché instalace Průzkumníka SolidWorks 2008.

Pokud vyberete AutoCAD, AutoCAD musí být nainstalován na vašem počítači. PDM Workgroup najde vhodnou verzi AutoCAD. Můžete určit více než jednu verzi programu AutoCAD:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 a DocMgr64 pracují pouze se 64bitovými instalacemi Průzkumník SolidWorks.

INSTALLDIR | Určuje instalační složku pro Workgroup PDM.
ACTIVSERIALNUMBER | Určuje sériové číslo SolidWorks.
Pro server Workgroup PDM.
Parametr serveru | Popis
ADDLOCAL
  • Úschovna
  • WebPortal
  • API

Pokud zadáte WebPortal (Viewer), musíte také určit VAULTNAME.
INSTALLDIR | Určuje instalační složku pro Workgroup PDM.
LICENSE_SERVER | Určuje název počítače, na kterém je licenční server.
VAULTDATA  | Určuje cestu a složku úschovny.
VAULTNAME | Určuje název počítače, na kterém je úschovna.
Nadřazené téma: Vlastnosti v příkazovém řádku


SolidWorks Simulation - vlastnosti v příkazovém řádku

Tyto vlastnosti příkazového řádku jsou specifické pro SolidWorks Flow Simulation.

Vlastnost | Popis
ACTIVSERIALNUMBER Sériové číslo individuální instalace programu SolidWorks Flow Simulation.

(Individuální instalace a klientské instalace z administrativní kopie)

CWUPGRADEINSTALL Upgraduje existující verzi určité aplikace programu SolidWorks Flow Simulation.
1
Aktualizovat
2
Nová instalace; nainstalovat v novém adresáři

(Individuální instalace a klientské instalace z administrativní kopie)

INSTALLDIR Určuje instalační složku pro instalaci určité aplikace programu SolidWorks Flow Simulation.

(Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@server_název1; yyyyy@server_název2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
SOLIDWORKSPATH Určuje složku, ve které je nainstalován program SolidWorks.

(Individuální instalace a klientské instalace z administrativní kopie)

TARGETDIR Určuje instalační složku pro instalaci určité aplikace programu SolidWorks Flow Simulation.

(Pouze pro administrativní instalace)
Nadřazené téma: Vlastnosti v příkazovém řádku


Umístění souboru MSI administrativní kopie

Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SolidWorks.

Produkt | Umístění média
SolidWorks (hlavní produkt, angličtina) | swwi\data\SolidWorks.msi
SolidWorks (neanglické jazykové součásti) | Tradiční čínština | swwi\lang\chinese\chinese.msi
 | Zjednodušená čínština | swwi\lang\chinese-simplified\chinese-simplified.msi
 | čeština | swwi\lang\czech\czech.msi
 | francouzština | swwi\lang\french\french.msi
 | němčina | swwi\lang\german\german.msi
 | italština | swwi\lang\italian\italian.msi
 | japonština | swwi\lang\japanese\japanese.msi
 | korejština | swwi\lang\korean\korean.msi
 | polština | swwi\lang\polish\polish.msi
 | portugalština (Brazílie) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | ruština | swwi\lang\russian\russian.msi
 | španělština | swwi\lang\spanish\spanish.msi
 | turečtina | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
Produkty SolidWorks Simulation | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
Projektory materiálů eDrawings | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Server Workgroup PDM | pdmwserver\SolidWorks Workgroup PDM Server.msi
Průvodce aktivací SolidWorks | swactwizard\Activation Wizard.msi
DocManager APIs | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
Manažer licencí SolidNetWork | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
Nadřazené téma: Vlastnosti v příkazovém řádku


Jazyková podpora Windows Desktop Search

Názvy souborů Windows Desktop Search označují platformu a jazyk.

Platforma/architektura:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32bitová verze Windows
x64 | 64bitová verze Windows
Jazyk:
chs | Zjednodušená čínština
cht | čínština
csy | čeština
deu | němčina
enu | angličtina
esn | španělština
fra | francouzština
ita | italština
jpn | japonština
kor | korejština
plk | polština
ptb | brazilská portugalština
rus | ruština
trk | turečtina
Nadřazené téma: Vlastnosti v příkazovém řádku


Zavádění administrativní kopie pomocí Microsoft Active Directory

Zavedení pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SolidWorks na klientské počítače.

Služba Microsoft Active Directory je adresářová služba ke správě klientů a serverů na síti. Zjednodušuje správu, přenesení a zavádění.

  1. Administrativní kopii můžete vytvořit pomocí Manažera instalací SolidWorks nebo pomocí příkazového řádku.
  2. Po vytvoření administrativní kopie za použití příkazového řádku, nainstalujte předpoklady pro Windows instalaci z administrativní kopie za použití Microsoft Active Directory. Podrobnosti najdete v Předpoklady instalace ve Windows pomocí Microsoft Active Directory.

    Proveďte tento krok pouze tehdy, když vytváříte kopii ručně za použití příkazového řádku. Pokud jste vytvořili a nainstalovali kopii za použití Manažera instalace SolidWorks, všechny předpoklady pro Windows budou nainstalovány automaticky.

  3. Vytvořte transformační soubor, který slouží k vlastní úpravě programu SolidWorks:
    1. Otevřete okno Příkazový řádek.
    2. Ve složce, která obsahuje administrativní kopii, přetáhněte SWCreateMST.exe do okna Příkazového řádku.

      Příkaz by měl být ve formátu:

      administrative_image_directory\SWCreateMST.exe path_to_MSI_file_of_an_administrative_image list_of_properties

      Vlastnosti mohou být buď vlastnosti funkcí nebo globální vlastnosti. Podrobnosti viz Vlastnosti funkcí v příkazovém řádku a Globální vlastnosti v příkazovém řádku.

      Použijte následující příklady jako šablonu:

      • Pokud instalujete SolidWorks (32bitovou verzi) na 32bitovém operačním systému, použijte

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • Pokud instalujete SolidWorks (32bitovou verzi) na 64bitovém operačním systému, použijte

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • Pokud instalujete SolidWorks (64bitovou verzi) na 64bitovém operačním systému, použijte

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      Transformační soubor SolidWorks.mst je vytvořen ve složce, která obsahuje administrativní kopii.

  4. V aktivním adresáři upravte zásady Publikovaných aplikací pro skupinu nebo skupiny, které zavádějí program SolidWorks.
  5. V dialogovém okně Zásady skupiny rozbalte nabídku Konfigurace počítače a Nastavení softwaru.
  6. Klepněte pravým tlačítkem myši na Instalaci softwaru a vyberte Nový > Balíček.
  7. Vyhledejte administrativní kopii a klepněte na Otevřít.
  8. V dialogovém okně Zavedení aplikace vyberte Upřesnit vlastnosti publikování nebo přiřazení a klepněte na OK.
  9. V dialogovém okně Vlastnosti SolidWorks na záložce Změny:
    1. Klepněte na Přidat.
    2. Vyhledejte soubor .mst.
    3. Klepněte na Otevřít.
  10. Klepněte na OK.
  • Předpoklady instalace ve Windows pomocí Microsoft Active Directory
    Při přípravě stávající administrativní kopie, která nainstaluje SolidWorks na klientské počítače pomocí Microsoft Active Directory postupujte podle těchto pokynů.
Nadřazené téma: Zavedení pomocí příkazového řádku


Předpoklady instalace ve Windows pomocí Microsoft Active Directory

Při přípravě stávající administrativní kopie, která nainstaluje SolidWorks na klientské počítače pomocí Microsoft Active Directory postupujte podle těchto pokynů.

V těchto postupech použijte příkaz, který odpovídá verzi SolidWorks, kterou zavádíte.

  1. Proveďte extrahování souborů instalační služby balíčku k opětovné distribuci 2005 Visual C++.
    1. Spusťte jeden z následujících příkazů:

      Pro 32bitové verze Windows:

      administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_target_directory}

      Pro 64bitové verze Windows:

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_target_directory}

    2. Vytvořte zásadu k instalaci opětovně distributovatelného modulu Microsoft C++ 2005:

      {2005_C++_target_directory}\vcredist.msi –

      Pro tuto instalaci není zapotřebí žádný transformační soubor.

  2. Proveďte extrahování souborů instalační služby balíčku k opětovné distribuci 2008 Visual C++.
    1. Spusťte jeden z následujících příkazů:

      Pro 32bitové verze Windows:

      administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_target_directory}

      Pro 64bitové verze Windows:

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_target_directory}

    2. Vytvořte zásadu k instalaci opětovně distributovatelného modulu Microsoft C++ 2008:

      {2008_C++_target_directory}\vcredist.msi –

      Pro tuto instalaci není zapotřebí žádný transformační soubor.

  3. Použijte aktualizačních služeb serveru Windows, instalujte Microsoft .NET Framework 3,5.

    .NET Framework nemusíte instalovat na Windows 7 nebo pozdější verze.

  4. Proveďte extrahování souborů součástí Office Web a instalujte je.
    1. Spusťte tento příkaz:

      administrative_image_directory\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_directory}

    2. Vytvořte zásadu pro instalaci součástí Office Web:

      {Office_Web_components_directory}\owc11.MSI

      Pro tuto instalaci není zapotřebí žádný transformační soubor.

  5. Nainstalujte nástroje Visual Studio pro aplikace (VSTA) vytvořením této zásady:

    {Microsoft_VSTA_directory}\vsta_aide.MSI

    Pro tuto instalaci není zapotřebí žádný transformační soubor.

  6. Instalujte Visual Studio Remote Debugger (jen 64bitové verze) vytvořením této zásady:

    {Microsoft_remote_debugger_directory}\rdbgexp.MSI

    Pro tuto instalaci není zapotřebí žádný transformační soubor.

Nadřazené téma: Zavádění administrativní kopie pomocí Microsoft Active Directory


Správa násobných instalací

Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.

  • Upgrade administrativních kopií na novou verzi
    Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.
  • Správa aktualizace produktu servisního balíčku
    Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.
  • Odstranění instalace
    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.
Nadřazené téma: Násobné instalace


Upgrade administrativních kopií na novou verzi

Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.

Spusťte Manažera instalací SolidWorks z internetu, aby byly použity správné soubory. Manažer instalací SolidWorks se sám přesměruje, nebo můžete spustit aktualizaci přímo z webové stránky SolidWorks Downloads (http://www.solidworks.com/sw/support/downloads.htm).

Poté, co aktualizujete administrativní kopii (čímž se vytvoří nová kopie), můžete aktualizovat klienty tak, že je odkážete na nově vytvořenou administrativní kopii.

Pokud mají klienti namapovanou jednotku, nebo sdílenou složku s původní administrativní kopií, můžete znovu namapovat jednotku, nebo sdílenou složku nově aktualizované administrativní kopie.
  • Stažení aktualizovaných instalačních souborů pro administrativní kopie
    Manažer instalací SolidWorks může rozpoznat, když potřebujete aktualizované instalační soubory při upgrade administrativní kopie.
  • Upgrade administrativní kopie
    Pro upgrade administrativní kopie vytvoří Manažer instalací SolidWorks nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.
  • Upgradování klientů z administrativní kopie
    Manažer instalací SolidWorks může automaticky aktualizovat klientské počítače instalované z administrativní kopie.
Nadřazené téma: Správa násobných instalací


Stažení aktualizovaných instalačních souborů pro administrativní kopie

Manažer instalací SolidWorks může rozpoznat, když potřebujete aktualizované instalační soubory při upgrade administrativní kopie.

  1. Spusťte Manažera instalací SolidWorks vložením DVD do jednotky.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.
  3. Na obrazovce Sériové číslo zadejte sériové číslo SolidWorks.

    Manažer instalací SolidWorks na webové stránce SolidWorks zjistí vaše licencované produkty a dostupné aktualizace Service Pack.

  4. Pokud se zobrazí obrazovka Je k dispozici novější verze zvolte Ano, stáhnout a nainstalovat novější verzi: verze.

    Manažer instalace SolidWorks spustí novou relaci a nainstaluje novější verzi.

  5. Pokud se vyskytne problém se složkou pro stahování , může se objevit okno Možnosti instalace – v takovém případě odsouhlaste výchozí složku pro nové instalační soubory nebo zadejte název nového adresáře.

    Pokud se zobrazí zpráva, že adresář neexistuje, vytvořte ho klepnutím na Ano.

  6. Na obrazovce Stahování dokončeno klepnutím na Zavřít ukončete aktuální instalační službu a spusťte instalační službu pro novou verzi.
Nadřazené téma: Upgrade administrativních kopií na novou verzi


Upgrade administrativní kopie

Pro upgrade administrativní kopie vytvoří Manažer instalací SolidWorks nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.

Předpokladem tohoto postupu je, že máte stažené všechny aktualizované instalační soubory v administrativní kopii. Podrobnosti najdete v Stažení aktualizovaných instalačních souborů pro administrativní kopie.

  1. Spusťte Manažer instalací SolidWorks. Podrobnosti najdete v Zahájení instalace SolidWorks.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.

    Objeví se možnosti pro vytvoření administrativní kopie:

    Vytvořit novou kopii pomocí výchozích nastavení.
    Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie.
    Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
    Vytvořte 32-bitovou a 64-bitovou administrativní kopii.
    Můžete vytvořit jak 32-bitovou, tak i 64-bitovou kopii na jednom počítači, nebo jednoduše vytvořit kopii, která bude odpovídat architektuře daného počítače. K vytvoření obou kopií potřebujete mít přístup k 32-bitovým i 64-bitovým instalačním médiím.

  3. Na obrazovce Sériové číslo zadejte sériové číslo.
  4. Na obrazovce Souhrn (Připraveno k vytvoření kopie), zkontrolujte, že jsou možnosti administrativní kopie správné.

    Podrobnosti o individuální administrativní kopii a možnostech instalace získáte, když klepnete na ZMĚNA a dostanete se na stránku možností a pak klepnete na Nápověda.

  5. Pro vytvoření nové verze administrativní kopie klepněte na Vytvořit nyní.

Nyní můžete upgradovat klienty na tuto novou verzi administrativní kopie. Podrobnosti najdete v Upgradování klientů z administrativní kopie.

Nadřazené téma: Upgrade administrativních kopií na novou verzi


Upgradování klientů z administrativní kopie

Manažer instalací SolidWorks může automaticky aktualizovat klientské počítače instalované z administrativní kopie.

Obvykle jsou administrativní kopie na serveru umístěné ve složkách. Administrativní kopie musí být ve sdílené složce, aby mohlo dojít k automatické aktualizaci klientů.

Po provedení upgradu administrativní kopie, bude původní instalace v jedné složce a upgradovaná instalace ve druhé složce. Chcete-li použít upgradovanou instalační službu, musíte nejprve odstranit možnost sdílení ze složky původní administrativní kopie a poté umožnit sdílení složky s upgradovanou administrativní kopií.

Po spuštění SolidWorks na klientském počítači, který byl instalován z originální administrativní kopie, program zaznamená novou verzi a upgraduje klienta.

  • Odstranění možnosti sdílení ze složky s původní administrativní kopií
    Když provádíte upgrade administrativní kopie, na kterou je přístup ze sdílené složky, musíte odstranit možnost sdílení z původní složky.
  • Přidání možnosti sdílení ze složky s upgradovanou administrativní kopií
    Poté, co jste vytvořili nebo aktualizovali složku administrativní kopie a deaktivovali sdílení původní složky administrativní kopie, musíte přidat možnost sdílení nové složce, aby se administrativní kopie znovu aktivovala.
  • Ruční upgrade klientů z administrativních kopií s použitím příkazového řádku
    Po provedení upgrade u administrativní kopie můžete provést ručně upgrade za použití příkazového řádku.
Nadřazené téma: Upgrade administrativních kopií na novou verzi


Odstranění možnosti sdílení ze složky s původní administrativní kopií

Když provádíte upgrade administrativní kopie, na kterou je přístup ze sdílené složky, musíte odstranit možnost sdílení z původní složky.

  1. Vyhledejte složku, ve které jsou umístěny soubory původní administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení vyberte Nesdílet tuto složku a klepněte na OK.

Nyní přidejte možnost sdílení do složky nové administrativní kopie jak je popsáno v Přidání možnosti sdílení ze složky s upgradovanou administrativní kopií.

Nadřazené téma: Upgradování klientů z administrativní kopie


Přidání možnosti sdílení ze složky s upgradovanou administrativní kopií

Poté, co jste vytvořili nebo aktualizovali složku administrativní kopie a deaktivovali sdílení původní složky administrativní kopie, musíte přidat možnost sdílení nové složce, aby se administrativní kopie znovu aktivovala.

  1. Vyhledejte složku, ve které jsou umístěny soubory upgradované administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení určete vlastnosti sdílení vhodné pro vaši společnost nebo skupinu a změňte název sdílení na název používaný pro původní složku administrativní kopie.
Na počítačích instalovaných z původního sdíleného umístění administrativní kopie se provede upgrade na novou verzi automaticky, když spustíte SolidWorks.
Nadřazené téma: Upgradování klientů z administrativní kopie


Ruční upgrade klientů z administrativních kopií s použitím příkazového řádku

Po provedení upgrade u administrativní kopie můžete provést ručně upgrade za použití příkazového řádku.

  1. Ujistěte se, že všichni klienti mají nainstalovaný stejný service pack předchozí verze programu. (U klientů, kteří ještě aplikaci instalovanou nemají, se upgrade neprovede.)
  2. Volitelně můžete na klientském počítači spustit Průvodce kopírováním nastavení a zkopírujte aktuální možnosti SolidWorks.
  3. Vytvořte novou administrativní kopii pomocí Manažera instalací SolidWorks nebo pomocí příkazového řádku.

    Starou kopii by jste neměli upgradovat, ani přepsat.
    Pokud provádíte upgrade instalace SolidWorks, která není v angličtině, musíte vytvořit novou administrativní kopii pro neanglickou jazykovou součást instalace.

  4. Proveďte upgrade u všech klientů na novou verzi pomocí příkazu msiexec s těmito specifikacemi:

    • Vložte možnosti příkazového řádku /I a qb msiexec.
    • Určete jakoukoliv požadovanou funkci a globální vlastnosti příkazového řádku. Podrobnosti najdete v Vlastnosti v příkazovém řádku.

    Například, pokud chcete upgradovat existující verzi Solid Works, zadejte příkaz:

    msiexec /I Msi_path" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks version servicepack" /qb

    Pokud provádíte upgrade instalace SolidWorks, která není v angličtině, musíte po provedení upgrade součástí SolidWorks provést upgrade neanglické jazykové součásti.

Nadřazené téma: Upgradování klientů z administrativní kopie


Správa aktualizace produktu servisního balíčku

Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.

Aktualizace produktů můžete provést dvěma způsoby:

Pro aktuální verze SolidWorks:
Pomocí Manažera instalací SolidWorks zjistit, stáhnout a nainstalovat aktualizace.

Manažera instalací SolidWorks můžete spustit ručně, nebo naplánovat pravidelné zjišťování aktualizací.

Pro verze SolidWorks před verzí 2008:
Ručním stažením aktualizací Service Pack z webové stránky podpory SolidWorks.

Aktualizace Service Pack je instalována jako oprava existující verze softwaru. Například SolidWorks 2007 SP1.0 je aktualizace Service Pack pro SolidWorks 2007 SP0.0. Tyto aktualizace Service Pack můžete nainstalovat pomocí Manažera instalací SolidWorks 2007, nemůžete je nainstalovat pomocí Manažera instalací verze SolidWorks 2008 nebo vyšší.

Další informace o stahování a instalaci aktualizace Service Pack najdete v dokumentaci pro verzi programu SolidWorks, kterou se snažíte aktualizovat.

  • Návrat na předchozí aktualizaci Service Pack v administrativní kopii
    Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci Service Pack. Pokud jste program SolidWorks nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.
  • Použití servisních balíčků pro klienty pomocí Microsoft Active Directory
    Pokud jste nainstalovali program SolidWorks pomocí služby Microsoft Active Directory, můžete tuto službu také využít při instalaci aktualizací Service Pack.
Nadřazené téma: Správa násobných instalací


Návrat na předchozí aktualizaci Service Pack v administrativní kopii

Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci Service Pack. Pokud jste program SolidWorks nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.

Upgradované administrativní kopie nelze vrátit na předchozí aktualizaci Service Pack. Administrativní kopie vytvořené jiným způsobem, než pomocí Manažera instalací SolidWorks, nelze vrátit zpět na předchozí verzi. Klienti instalovaní z této administrativní kopie musí být odinstalováni a pak znovu nainstalováni pomocí administrativní kopie vytvořené z dřívější verze.
  1. Odstraňte složku obsahující aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:

    rmdir /s/q cesta_k_aktuální_administrativní_kopii

  2. Přesuňte záložní kopii administrativní kopie na místo, ze kterého jste odstranili aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:

    move cesta_k_záložní_administrativní_kopii cesta_k_aktuální_administrativní_kopii

    Po vrácení administrativní kopie zpět na předchozí verzi se klientské počítače aktualizují při příštím spuštění programu SolidWorks.

Nadřazené téma: Správa aktualizace produktu servisního balíčku


Použití servisních balíčků pro klienty pomocí Microsoft Active Directory

Pokud jste nainstalovali program SolidWorks pomocí služby Microsoft Active Directory, můžete tuto službu také využít při instalaci aktualizací Service Pack.

  1. Zkopírujte administrativní kopii do nové složky prostřednictvím následujícího příkazového řádku:

    xcopy cesta_k_aktuální_administrativní_kopii cesta_k_záložní_administrativní_kopii /s/i/v

  2. Nainstalujte aktualizaci Service Pack do kopie administrativní kopie.
  3. Vytvořte nový transformační soubor, který stanoví instalaci upgradu pro program SolidWorks:
    1. Otevřete okno Příkazový řádek.
    2. Ve složce, která obsahuje administrativní kopii, přetáhněte SWCreateMST.exe do okna Příkazového řádku.

      Příkaz by měl být ve tvaru:

      cesta_k_administrativní_kopii\SWCreateMST.exe cesta_k_souboru_MSI_administrativní_kopie seznam_vlastností

      Na příkazovém řádku musí být uvedeny všechny parametry použité při vytváření původního transformačního souboru a také globální parametry UPGRADESWINSTALL a SWMIGRATE

      Například, pokud původní příkaz byl:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\vaše_složka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@váš_server

      příkaz aktualizace musí být:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\vaše_složka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@váš_server UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks verze service_pack"

      Transformační soubor SolidWorks.mst je vytvořen ve složce, která obsahuje administrativní kopii.

      Původní příkaz a příkaz pro aktualizaci jsou ukázkami pro instalaci 32bitové verze SolidWorks na operačním systému 32bitové verze. Pokud instalujete 32bitovou verzi SolidWorks na 64bitovém operačním systému, musíte použít "Intel_Modules_AgeiaX64" místo "Intel_Modules_AgeiaX86" Pokud instalujete 64bitovou verzi SolidWorks na 64bitovém operačním systému, nepoužijete "Intel_Modules_AgeiaX86” ani “Intel_Modules_AgeiaX64".

  4. V aktivním adresáři upravte zásady Publikovaných aplikací pro skupinu nebo skupiny, které zavádějí program SolidWorks.
  5. V dialogovém okně Zásady skupiny rozbalte nabídku Konfigurace počítače a Nastavení softwaru.
  6. Klepněte pravým tlačítkem myši na Instalaci softwaru a vyberte Nový > Balíček.
  7. Vyhledejte administrativní kopii a klepněte na Otevřít.
  8. V dialogovém okně Zavedení aplikace vyberte Upřesnit vlastnosti publikování nebo přiřazení a klepněte na OK.
  9. V dialogovém okně Vlastnosti SolidWorks na záložce Změny:
    1. Klepněte na Přidat.
    2. Vyhledejte soubor .mst.
    3. Klepněte na Otevřít.
  10. Klepněte na OK.
Nadřazené téma: Správa aktualizace produktu servisního balíčku


Workgroup PDM

Aplikace Workgroup PDM je program pro správu dat produktů. Běží buď uvnitř prostředí programu SolidWorks, nebo jako samostatná aplikace v rámci Průzkumníka SolidWorks. Workgroup PDM řídí projekty pomocí procesů pro vyzvednutí, odevzdání, kontrolu revizí a další správní úkony.

Následuje ilustrace systému PDM Workgroup:

  • Počítač může obsahovat jen jednu úschovnu.
  • Adresář úschovny nemůže být skrytý adresář nebo adresář pouze pro čtení.
  • Výkon programu PDM Workgroup závisí na robustní síti, protože se jedná o aplikaci klient/server.
  • Pokud uživatelé spravují velký počet dokumentů, dosáhnete lepšího výkonu vytvořením více projektů nebo podprojektů obsahujících méně dokumentů, místo projektů s velkým množstvím dokumentů.

Instalace

  • Klienty, Správu úschovny, API a Prohlížeč je možné nainstalovat na stejném počítači jako je úschovna nebo na jiných počítačích.
  • Při instalaci PDM Workgroup serveru není nutné také instalovat klienta API. Klient API je nainstalován jako součást instalace PDM Workgroup klienta.
  • Jako umístění serveru zadejte úplný název UNC (Universal Naming Convention) serveru, pokud chcete nakonfigurovat složku úschovny na vzdáleném umístění. (Podrobnosti najdete v Formát UNC.)
  • Instalace nebo aktualizace úschovny vyžaduje restartování počítače.
  • Pokud se služba PDM Workgroup Server nespustí automaticky po restartování počítače, bude nutné tuto službu spustit ručně. V Průzkumníku Windows spusťte soubor pdmwvault.exe ve složce instalační_adresář\SolidWorks Workgroup PDM\Vault folder.
  • Při instalaci klienta PDM Workgroup musíte na každém počítači instalovat soubor solidworksexplorer.exe. Tento spustitelný soubor může být na sdílené jednotce. PDM Workgroup úschovna, Viewer, API klient a Správa úschovny VaultAdmin nejsou nainstalovány na každém klientském počítači.

Licence

  • Licence na Workgroup PDM API je zahrnuta v licencích pro klienty SolidWorks a klienty Průzkumníka. API pro odevzdávání vyžadují licence pro klienty.
  • Licence prohlížeče Workgroup PDM musí být nainstalována společně s úschovnou, aby bylo možné aktivovat Prohlížeč.

Oprávnění

  • Správce úschovny by měl mít oprávnění pro zápis k instalační složce a ke složce úschovny.
  • Správce úschovny by měl úschovnu spravovat ze správy úschovny VaultAdmin, ne z Průzkumníka Windows.
  • Uživatele by nikdy neměli mít oprávnění pro zápis v Průzkumníku Windows ke složce úschovny.

Zabezpečení, porty a nastavení duplexního přenosu

  • PDM Workgroup je nutné instalovat jako službu systému Windows, tak aby jiné aplikace nemohly blokovat nebo filtrovat tuto službu. Například pokud nástroje, které chrání před spywarem, jako např. Microsoft AntiSpyware, zobrazí během instalace výstrahu vyžadující souhlas, klepněte na Povolit, aby se PDM Workgroup Server mohl nainstalovat jako služba systému Windows.
  • Pokud instalujete PDM Workgroup na počítač s operačními systémy jako Windows XP s aktualizací Service Pack 2, Windows 2003 server s aktualizací Service Pack 1 nebo na počítač s aktivní bránou firewall, je nutné nastavit PDM Workgroup porty jako výjimky při instalaci brány firewall.

    Nastavení portů je většinou:

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Request)
    • 80 (Viewer)
    Informace o změnách nastavení portu najdete na odkaze Řešení problémů pro správce úschovny v Nápovědě PDM Workgroup a Průzkumníka SolidWorks a v nápovědě Microsoft Windows Zabezpečení systému Windows. Chcete-li nainstalovat PDM Workgroup úschovnu a Viewer současně, vyberte možnost Vlastní v dialogovém okně Typ instalace.
  • Zdvojené nastavení pro servery a jejich odpovídající porty by měly být stejné, například oba by mohly být Plné 100MB, nebo Automatické.

Dokumenty SolidWorks Toolbox

Dokumenty SolidWorks Toolbox jsou běžné hardwarové součásti, které ve většině případů nevyžadují kontrolu oprav a nejsou odevzdávány do úschovny PDM Workgroup. Další informace o tom, jak nakonfigurovat SolidWorks Toolbox a ostatní standardní knihovny jsou k dispozici v online nápovědě pro PDM Workgroup.

  • Prohlížeč Workgroup PDM
    Program PDM Workgroup automaticky nastaví virtuální adresář během instalace pomocí služeb Microsoft Internet Information Services (IIS).
  • Instalace Workgroup PDM Server
    Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SolidWorks.
  • Konfigurace PDM Workgroup pro klienty
    Po instalaci úschovny serveru Workgroup PDM můžete konfigurovat úschovnu pro klienty.
  • Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
    Instalace Webového serveru SolidWorks Workgroup PDM a Prohlížeče Workgroup PDM na hraniční síti (DMZ) má dopady na bránu firewall.
  • Přístup klientského počítače k Workgroup PDM
    Klienti Workgroup PDM používají kontrolu přístupu Microsoft Windows, mají přístup na webové stránky pomocí Workgroup PDM Viewer a automaticky se aktualizují kdykoliv se úschovna Workgroup PDM aktualizuje.
  • Workgroup PDM VaultAdmin správy úschovny
    Po ukončení instalace PDM Workgroup by správci úschovny měli provést následující:


Prohlížeč Workgroup PDM

Program PDM Workgroup automaticky nastaví virtuální adresář během instalace pomocí služeb Microsoft Internet Information Services (IIS).

Než nainstalujete PDMWorks Workgroup Viewer, je nutné nainstalovat internetovou informační službu Microsoft (IIS).
Mezi požadované součásti patří:
  • Nástroje pro správu webu
    • IIS Management Console
  • Webové služby: Funkce pro vývoj aplikací
    • .NET Extensibility
    • ASP.NET
    • CGI
    • Rozšíření ISAPI
    • Filtry ISAPI
Návod na instalaci IIS můžete nalézt v dokumentaci Microsoft.
Instalace Workgroup PDM Viewer musí probíhat podle těchto omezení:
  • Adresář obsahu webové stránky je instalační složka pro Viewer.
  • V názvu počítače hostitele Viewer nemůžete používat podtržítko.
  • Pokud instalujete Viewer na systému Windows XP Service Pack 2, musíte zapnout port v bráně Windows Firewall pro HTTP (port 80).
  • Viewer může být současně napojený pouze na jednu úschovnu.

Uživatelé přistupují k prohlížeči PDM Workgroup zadáním následující adresy do pole Adresa v Internet Explorer:

http://ViewerComputerName/pdmweb/

Nadřazené téma: Workgroup PDM


Instalace Workgroup PDM Server

Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SolidWorks.

  1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
  2. Na obrazovce Uvítání vyberte následující:

    • Produkty Server
    • Na tomto počítači nainstalovat SolidWorks Workgroup PDM Server (úschovna).

  3. Na obrazovce Souhrnné informace, klepněte na tlačítko Změnit; získáte ověřovací kód. Kód můžete získat jedním z následujících způsobů:
    • Internetové připojení
      1. Zadejte do příslušných polí sériové číslo softwaru SolidWorks a e-mailovou adresu.
      2. Vyberte možnost Ověřit automaticky a klepněte na Získat kód.
    • Email
      1. Nemá-li váš počítač přístup k síti Internet, klepněte na možnost Ověřit ručně přes e-mail. Manažer instalací vytvoří soubor s požadavkem na ověření.
      2. Klepnutím na tlačítko Uložit tento soubor uložte do systému.
      3. Postupujte podle pokynů na obrazovce a zadejte ověřovací kód.
  4. Klepněte na Zpět na souhrnné informace.
  5. Na obrazovce Souhrnné informace, klepněte na tlačítko Nainstalovat.
Nadřazené téma: Workgroup PDM


Konfigurace PDM Workgroup pro klienty

Po instalaci úschovny serveru Workgroup PDM můžete konfigurovat úschovnu pro klienty.

  1. Přihlaste se do správy úschovny VaultAdmin (nainstalováno společně s Průzkumníkem SolidWorks) pomocí výchozího uživatelského jména a hesla.
  2. Ve správě úschovny VaultAdmin nastavte uživatelské a skupinové účty, složky projektu, oprávnění, atd.

    Bližší informace viz Workgroup PDM Workgroup PDM Help.

  3. Zašlete email klientským uživatelům obsahující název počítače serveru, jejich uživatelská jména a hesla, která jsou obvykle jiná než jejich uživatelská jména a hesla v systému Microsoft Windows.
  • Konfigurace Workgroup PDM Viewer pro připojení na jiné umístění úschovny
    Můžete konfigurovat Workgroup PDM Viewer, aby byl napojen na jiné umístění úschovny pomocí registru Windows.
  • Konfigurace typů MIME pro stahování dokumentů
    Můžete konfigurovat typy MIME pro stahování dokumentů pomocí nastavení registru Windows.
Nadřazené téma: Workgroup PDM


Konfigurace Workgroup PDM Viewer pro připojení na jiné umístění úschovny

Můžete konfigurovat Workgroup PDM Viewer, aby byl napojen na jiné umístění úschovny pomocí registru Windows.

  1. Aktualizujte cestu registru změnou hodnoty Vault Computer (Počítač úschovny):

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Nainstalujte Workgroup PDM Viewer znovu. V dialogu Název počítače úschovny zadejte název nového počítače.
Nadřazené téma: Konfigurace PDM Workgroup pro klienty


Konfigurace typů MIME pro stahování dokumentů

Můžete konfigurovat typy MIME pro stahování dokumentů pomocí nastavení registru Windows.

Ve výchozím nastavení Viewer zašle požadavky Otevřít dokument s obecným typem MIME "application/octet-stream." Microsoft Internet Explorer potom otevře požadovaný dokument s dodanou příponou souboru. Můžete mapovat další typy MIME nebo vypnout mapování typů MIME úpravou typů MIME v dílčím klíči registru Windows.

  • Pro mapování dalších typů MIME vytvořte dodatečné řetězcové hodnoty v dílčím klíči registru:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    v podobě:

    "ext" = "typ mime"

    Příklad:

    "dxf" = "image/vnd.dxf"

    Nejprve musíte ručně vytvořit tento dílčí klíč registru a poté vložit hodnoty.

    Vypněte mapování typu MIME, změňte hodnotu Use Custom MIME Types registru na 0 (nula).

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Pro aktivaci tohoto nastavení není potřeba restartovat web server.

Nadřazené téma: Konfigurace PDM Workgroup pro klienty


Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti

Instalace Webového serveru SolidWorks Workgroup PDM a Prohlížeče Workgroup PDM na hraniční síti (DMZ) má dopady na bránu firewall.

Protože klienti Prohlížeče Workgroup PDM komunikují s Webovým serverem přes porty HTTP nebo HTTPS, musí být tyto porty otevřeny na systému Serveru služby IIS, na kterém je Webový server nainstalován.

  • Pro protokol HTTP je výchozím portem 80.
  • Pro protokol HTTPS (SSL) je výchozím portem 443.

Klienti Webového serveru nepotřebují výjimky brány firewall.

Musíte zajistit, aby se systém Webového serveru mohl spojit se serverem Úschovny přes tyto výchozí porty.

  • 30000 (Data)
  • 40000 (Request)
  • Konfigurace sítě pro Prohlížeč Workgoup PDM na hraniční síti
    Konfigurace sítě představuje nastavení serveru hraniční sítě na dílčí hraniční síti a její komunikaci s interními a externími sítěmi.
  • Instalace a konfigurace Webového serveru a Prohlížeče Workgroup PDM
    Při nastavování Webového serveru Workgroup PDM na hraniční síti je důležité umístění instalace součástí.
Nadřazené téma: Workgroup PDM


Konfigurace sítě pro Prohlížeč Workgoup PDM na hraniční síti

Konfigurace sítě představuje nastavení serveru hraniční sítě na dílčí hraniční síti a její komunikaci s interními a externími sítěmi.

Server hraniční sítě komunikuje s LAN prostřednictvím interní brány firewall. S externími sítěmi komunikuje prostřednictvím externí brány firewall, směrovače a clusteru rozložení zátěže.

Klient prohlížeče Internet Explorer se s Prohlížečem Workgroup PDM/IIS serverem spojuje přes port 80 (nebo 443, pokud používá SSL). Prohlížeč Workgroup PDM se poté spojuje se serverem úschovny prostřednictvím portů 30000 nebo 40000. Server úschovny odešle požadované informace zpět do Prohlížeče Workgroup PDM, který je následně předává zpět klientovi prohlížeče Internet Explorer.

Hraniční síť webového serveru má dvě IP adresy:

  • Interní IP adresu na LAN
  • Veřejnou IP adresu poskytovanou poskytovatelem ISP

Webový server na hraniční síti je umístěný za clusterem rozložení zátěže. I když je možné získat přístup k webovému serveru přímo pro administrativní úkoly, všechen provoz webových služeb na hraniční síti je zpracováván přes rozložení zátěže.

Rozložení zátěže přeloží IP adresu hardwaru serveru na virtuální IP (VIP) na části sítě, která je přístupná veřejnosti. Když přejdete na VIP nebo na URL webového serveru během připojení k síti, webová stránka se zobrazí.

Externí brána firewall přeloží VIP rozložení zátěže na veřejnou route-able adresu.

Nadřazené téma: Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti


Instalace a konfigurace Webového serveru a Prohlížeče Workgroup PDM

Při nastavování Webového serveru Workgroup PDM na hraniční síti je důležité umístění instalace součástí.
  • Na dílčí hraniční síti nainstalujte Webový server se službou IIS.
  • Na dílčí hraniční síti nainstalujte Prohlížeč Workgroup PDM se službou IIS.
  • Na hlavní doméně nebo na interní síti na místním intranetu nainstalujte Úschovnu Workgroup PDM.

Předpoklady pro instalování a konfiguraci Prohlížeče Workgroup PDM na hraniční síti jsou:

  • Microsoft IIS 6.0 nebo novější
  • Veřejná adresa IP na Webový server na dílčí hraniční síti přiřazená vašim poskytovatelem ISP

Návod na instalaci a konfiguraci součástí Workgroup PDM:

  1. Na systému dílčího hraničního serveru nainstalujte službu Microsoft IIS.
  2. Proveďte dvě instalace SolidWorks Workgroup PDM Serveru:
    1. Nejprve na Serveru úschovny nainstalujte součást Úschovny.
    2. Spusťte instalační službu podruhé a nainstalujte Prohlížeč Workgroup PDM a součásti licence Prohlížeče na Webovém serveru služby IIS. Zadejte název počítače serveru úschovny, aby webový portál věděl, kde vyhledat službu serveru úschovny.

    Během instalace je PDMWeb aplikace přidána automaticky na výchozí webovou stránku služby IIS.

  3. Ujistěte se, že má brána firewall na interní síti porty 30000 a 40000 otevřené.
  4. Pokud má interní server fixní IP adresu na systému hraničního serveru, upravte soubor C:\Windows\system32\drivers\etc\hosts. Vytvořte název systému mapování IP adresy, aby mohl hraniční server komunikovat s interním serverem.
    1. Otevřete soubor hosts v textovém editoru, například v Poznámkovém bloku.
    2. Vložte nový řádek pro IP adresu a název serveru úschovny.
    3. Uložte hosts soubor.
Nadřazené téma: Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti


Přístup klientského počítače k Workgroup PDM

Klienti Workgroup PDM používají kontrolu přístupu Microsoft Windows, mají přístup na webové stránky pomocí Workgroup PDM Viewer a automaticky se aktualizují kdykoliv se úschovna Workgroup PDM aktualizuje.

Návod na přihlášení jako PDM Workgroup klient: | Uživatelská jména a hesla účtů klientů nejsou v PDMWorks Workgroup shodná s přihlášením do Microsoft Windows. Kontaktujte správce systému ohledně informací o přihlášení.
Návod na připojení k Workgroup PDM Viewer: | Kontaktujte správce systému ohledně URL pro připojení do Viewer.
Návod na aktualizaci PDM Workgroup klientů: | Klienti PDM Workgroup (doplňkový modul SolidWorks Klient a Contributor) rozpoznají, když byla úschovna aktualizována. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack.
Nadřazené téma: Workgroup PDM


Workgroup PDM VaultAdmin správy úschovny

Po ukončení instalace PDM Workgroup by správci úschovny měli provést následující:

  • Přihlásit se do správy úschovny VaultAdmin.
  • Změnit heslo správce úschovny
  • Vytvořit uživatelské účty.
  • Oznámit uživatelům názvy a hesla jejich účtů.

Bližší informace viz SolidWorks Workgroup PDM v hlavní nápovědě SolidWorks.

  • První přihlášení do Workgroup PDM VaultAdmin
    Když se poprvé přihlašujete do Workgroup PDM VaultAdmin, určete jméno a heslo administrátora Workgroup PDM a název počítače, na kterém je úschovna Workgroup PDM.
  • Provedení upgrade serveru úschovny Workgroup PDM
    Můžete provést upgrade serveru úschovny Workgroup PDM pomocí funkce SolidWorks Zjistit aktualizace, instalačního DVD SolidWorks nebo ručního upgradu souboru Workgroup PDM, staženého do lokální složky.
  • Provedení upgrade u klientů Workgroup PDM
    Klienti Workgroup PDM zaznamenají, že došlo k aktualizaci úschovny. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack.
Nadřazené téma: Workgroup PDM


První přihlášení do Workgroup PDM VaultAdmin

Když se poprvé přihlašujete do Workgroup PDM VaultAdmin, určete jméno a heslo administrátora Workgroup PDM a název počítače, na kterém je úschovna Workgroup PDM.

  1. V systému Windows klepněte na nabídku Start > Programy > SolidWorksversion > Workgroup PDM VaultAdmin.
  2. V dialogovém okně zadejte následující informace:

    Název | pdmwadmin
    Heslo | pdmwadmin
    Počítač úschovny | Název hostitele počítače, na kterém je nainstalovaná úschovna. Pokud spouštíte VaultAdmin správu úschovny na počítači, na kterém je úschovna nainstalovaná, zadejtelocalhost.

  3. Klepněte na Přihlášení.
Z bezpečnostních důvodů doporučujeme okamžitou změnu hesla správce. Ve správě úschovny VaultAdmin vyberte záložku Uživatelé a skupiny.
Nadřazené téma: Workgroup PDM VaultAdmin správy úschovny


Provedení upgrade serveru úschovny Workgroup PDM

Můžete provést upgrade serveru úschovny Workgroup PDM pomocí funkce SolidWorks Zjistit aktualizace, instalačního DVD SolidWorks nebo ručního upgradu souboru Workgroup PDM, staženého do lokální složky.

Můžete nainstalovat pouze jednu verzi PDM Workgroup Server.
  1. Požádejte všechny uživatele, aby se odhlásili z úschovny Workgroup PDM a pak ji zamkněte.
  2. Vytvořte záložní kopii dat úschovny.
  3. Pomocí Ovládacích panelů Microsoft Windows Přidat/Odebrat programy odstraňte aktuální verzi programu PDM Workgroup Server.
  4. Nainstalujte novou verzi PDM Workgroup Server.
    • Použití funkce SolidWorks Zjistit aktualizace:
      1. V systému Windows klepněte na Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace.
      2. V dialogu Novější verze jsou k dispozici pro stažení vyberte Stáhnout a nainstalovat novou verzi, vyberte verzi, kterou chcete nainstalovat a klepněte na Další.

        Bude stažena a spuštěna nová verze Manažera instalací SolidWorks.

    • Chcete-li použít pro instalaci SolidWorks DVD, vložte DVD do jednotky a postupujte podle pokynů Manažera instalací SolidWorks.
    • Pro použití ručně stahovaného instalačního souboru Workgroup PDM (pdmwserver.exe) poklepejte na soubor a pak postupujte podle instrukcí pro upgrade Workgroup PDM Server.
  5. Použijte Plánovač úloh SolidWorks k aktualizaci souborů PDM Workgroup v úschovně.
  6. Odemkněte úschovnu a informujte uživatele, že se mohou vrátit do úschovny.
Nadřazené téma: Workgroup PDM VaultAdmin správy úschovny


Administrace licencí

Po instalaci můžete aktivovat licence SolidWorks buď aktivací individuálních počítačů (aktivace licence) nebo instalací a aktivací plovoucích síťových licencí na serveru (Licence SolidNetWork).

Zpravidla instalace na individuálních počítačích používají aktivaci licence, ale je také možné nainstalovat program samostatně a poté spravovat licence pomocí manažera licencí SolidNetWork. V opačném případě můžete zavést instalace z administrativní kopie a poté aktivovat sériová čísla na jednotlivých počítačích, i když na velkých pracovištích zpravidla používají plovoucí síťové licence.

  • Správa jednotlivých součástí
    Správa individuálních licencí se obvykle skládá z aktivace a převodu licencí přímo ze SolidWorks.
  • Správa licencí za použití manažera licencí SolidNetWork
    Manažer licencí SolidNetWork podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.


Správa jednotlivých součástí

Správa individuálních licencí se obvykle skládá z aktivace a převodu licencí přímo ze SolidWorks.

Aktivace je licencování produktu a registrační proces pro licence samostatného programu SolidWorks (ne pro síťové licence SolidNetWork). Pokud jste ještě neaktivovali licenci pro tento počítač, SolidWorks se obvykle pokouší ji aktivovat, když spustíte SolidWorks.

Můžete také převést individuální licence klepnutím na Nápověda > Převod licencí v SolidWorks.

  • Aktivace licence
    Abyste mohli spustit produkty SolidWorks na jednotlivém počítači, musíte pro tento počítač aktivovat licenci.
  • Převedení licence
    Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SolidWorks Corporation a poté ho znovu aktivovat na jiném počítači.
Nadřazené téma: Administrace licencí


Aktivace licence

Abyste mohli spustit produkty SolidWorks na jednotlivém počítači, musíte pro tento počítač aktivovat licenci.

K aktivaci je potřeba připojení k internetu nebo přístup k emailové službě. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje všechny programové licence pro celou řadu SolidWorks produktů.
  • Vám umožní převést licenční práva z jednoho počítače na druhý.
  • Vám umožní nainstalovat a aktivovat SolidWorks produkt na jednom pracovním počítači a na jednom domácím počítači.
  • Můžete provést ihned (doporučujeme) nebo nejpozději do 30 dnů po instalaci.
  • Vyloučí potřebu používat hardwarové klíče. Avšak, pokud stále používáte starší verze SolidWorks produktů, které nepoužívají aktivaci, musíte si ponechat hardwarový klíč.

Správci systému, kteří spravují několik sériových čísel, mohou najít užitečné informace na odkazu Editor možností administrativní kopie. Podrobnosti najdete v Editor možností administrativní kopie.

Návod na aktivaci licence:

  1. Spusťte program SolidWorks.
  2. Spusťte Aktivaci produktu SolidWorks za použití jedné z těchto metod:
    • Pokud jste ještě neaktivovali licenci pro tento počítač, okno Aktivace produktu SolidWorks se objeví automaticky, když spustíte SolidWorks.
    • Pokud se okno Aktivace produktu SolidWorks neobjeví automaticky, spusťte aktivaci klepnutím na Nápověda > Aktivovat licence.
  3. Klepněte na seznam Produkta určete produkt, jehož licenci chcete aktivovat.
  4. Určete automatickou aktivaci přes internet nebo ruční aktivaci za použití e-mailu.
  5. Zadejte kontaktní e-mailovou informaci.
  6. Klepněte na Další pro pokračování.
    • Internet: K aktivaci dojde automaticky.:
    • Email: Stisknutím tlačítka Uložit vytvoříte požadovaný soubor, který odešlete na emailovou adresu activation@solidworks.com. Když obdržíte e-mail se souborem s odpovědí, soubor z e-mailu klepnutím na Otevřít načtěte.
      Pokud je to nutné, můžete tento krok ukončit a novu spustit aktivační postup pro otevření souboru s odpovědí.
  7. Klepněte na Dokončit.
Nadřazené téma: Správa jednotlivých součástí


Převedení licence

Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SolidWorks Corporation a poté ho znovu aktivovat na jiném počítači.

Pokud se vám nepodaří převést licenci zpět na SolidWorks (například v důsledku selhání disku), ve většině případech je reaktivace stále úspěšná. Pokud ne, kontaktujte vašeho místního prodejce.

Návod na převod licence zpět na server:

  1. V SolidWorks klepněte na Nápověda > Převedení licence.
  2. Reaktivaci proveďte na novém nebo upgradovaném počítači a aktivujte licenci jako v počáteční aktivaci. Podrobnosti najdete v Aktivace licence.
Nadřazené téma: Správa jednotlivých součástí


Správa licencí za použití manažera licencí SolidNetWork

Manažer licencí SolidNetWork podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

Tento obrázek znázorňuje typickou instalaci správy licencí SolidNetWork

Tento obrázek ilustruje:
  • Manažer licencí SolidNetWork je instalován a aktivován pouze na počítači manažera licencí.
  • Počítače licenční klientů nemají nainstalován žádný dodatečný program patřící SolidNetWork.

    Pokud určujete při instalaci sériové číslo licence SolidNetWork, Manažer licencí SolidWorks identifikuje počítač jako klienta s licencí SolidNetWork. Manažer instalací SolidWorks vás vyzve, abyste zadali název počítače a číslo portu manažera licencí SolidNetWork pro spojení klienta s manažerem licencí.

  • Manažer licencí a všichni klienti s licencí musí mít spojení TCP/IP (Transmission Control Protocol/Internet Protocol).
  • Aktivace licence SolidNetWork
    Abyste mohli spustit produkty SolidWorks na jednotlivém počítači, musíte pro tento počítač aktivovat licenci SolidNetWork na počítači manažera licencí SolidNetWork.
  • Převedení licence SolidNetWork
    Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SolidWorks Corporation a poté ho znovu aktivovat na jiném počítači.
  • Instalace a konfigurace licencí SolidNetWork
    Konfigurace licencí SolidNetWork se skládá z instalace manažera licencí SolidNetWork na počítači manažera licencí a následné instalace SolidWorks na klientských počítačích pomocí sériového čísla SolidNetWork.
  • Správa licencí SolidNetWork
    Úkoly zahrnují spuštění, upgrade a odinstalování manažeru licencí a načítání, půjčování a vrácení licencí.
Nadřazené téma: Administrace licencí


Aktivace licence SolidNetWork

Abyste mohli spustit produkty SolidWorks na jednotlivém počítači, musíte pro tento počítač aktivovat licenci SolidNetWork na počítači manažera licencí SolidNetWork.

K aktivaci je potřeba připojení k internetu nebo přístup k emailové službě. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje Manažera licencí SolidNetWork pomocí licencí SolidNetWork pro jednotlivé produkty SolidWorks.
  • Umožní vám převést licenční práva SolidNetWork z jednoho počítače manažera licencí SolidNetWork na druhý.
  • Umožní vám instalovat a aktivovat licenční práva SolidNetWork na počítači Manažera licencí SolidNetWork.
  • Musí být provedena než začnete používat licence SolidNetWork.
  • Vyloučí potřebu používat hardwarové klíče. Pokud aktivujete licenci SolidNetWork pro tuto verzi SolidWorks, licence SolidNetWork pro dřívější verze SolidWorks jsou aktivovány. (Už si nemusíte nechávat hardwarový klíč.)

Návod na aktivaci licence SolidNetWork:

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Pokud jste ještě neaktivovali licenci SolidNetWork , budete požádáni, abyste ji aktivovali nyní. Aktivujte klepnutím na Ano.
  3. Pod Jakým způsobem chcete provést převedení?, zvolte Automaticky přes Internet (doporučeno).
  4. Pod Kontaktní informace zadejte e-mailovou kontaktní adresu.
V dialogu Aktivace/Reaktivace byla úspěšná se zobrazí produkty, které byly aktivovány.
Nadřazené téma: Správa licencí za použití manažera licencí SolidNetWork


Převedení licence SolidNetWork

Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SolidWorks Corporation a poté ho znovu aktivovat na jiném počítači.

Pokud se vám nepodaří převést licenci zpět na SolidWorks (například v důsledku selhání disku), ve většině případech je reaktivace stále úspěšná. Pokud ne, kontaktujte vašeho místního prodejce.

Návod na převod licence SolidNetWork zpět na server:

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.

  2. Pod možností Informace o licenci klepněte na Upravit. Spustí se průvodce Aktivaci SolidWorks produktu.
  3. Pod možností Co chcete udělat? zvolte Převést licenci softwaru a pak klepněte na Další.
  4. Pod Jakým způsobem chcete provést převedení?, zvolte Automaticky přes Internet (doporučeno).
  5. Pod Kontaktní informace zadejte e-mailovou kontaktní adresu.
  6. Klepněte na Další. Převedení licence produktu se dokončuje.
Nadřazené téma: Správa licencí za použití manažera licencí SolidNetWork


Instalace a konfigurace licencí SolidNetWork

Konfigurace licencí SolidNetWork se skládá z instalace manažera licencí SolidNetWork na počítači manažera licencí a následné instalace SolidWorks na klientských počítačích pomocí sériového čísla SolidNetWork.

  • Instalace a aktivace licenčního klienta
    Manažer licencí SolidNetWork podporuje několik klientů licence. Tento server distribuuje licence klientům na síti.
  • Instalace licenčního klienta
    Pokud instalujete SolidWorks na počítačích licenčních klientů SolidNetWork, sériové číslo identifikuje počítač jako klienta s licencí SolidNetWork.
  • Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
    Manažera licencí SolidNetWork byste měli instalovat a konfigurovat nejpozději jeden počítači před instalací jakékoliv licence SolidNetWork na počítače s klientskou licencí.
  • Instalace Manažera licencí triády
    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.
  • Použití licencí SolidNetWork s firewall
    Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:
Nadřazené téma: Správa licencí za použití manažera licencí SolidNetWork


Instalace a aktivace licenčního klienta

Manažer licencí SolidNetWork podporuje několik klientů licence. Tento server distribuuje licence klientům na síti.

Pokud upgradujete z předchozí verze Manažera licencí SolidNetWork, která používala hardwarové klíče pro aktivaci licence, odstraňte je před instalací nové verze Manažera licencí SolidNetWork.

  1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
    1. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Nainstalovat Manažera licencí SolidNetWork (distribuované licencování) na tento počítač

    2. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    3. Na stránce Shrnutí dokončete proces Manažera instalace SolidWorks klepnutím na Instalovat nyní.
  2. Návod na aktivaci licencování SolidNetWork:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
    2. Budete-li vyzváni k aktivaci, klepněte na Ano.
    3. Na obrazovce Informace o licenčním serveru SolidNetWork :

      • Pokud vaše společnost používá bránu firewall, vyberte Na tomto serveru se používá brána firewall.

        Další informace viz Použití licencí SolidNetWork s firewall.

      • Použijte výchozí hodnoty pro Číslo portu (a Číslo portu dodavatele Demon, pokud máte bránu firewall), nebo zadejte čísla portu používané vaší společností.
        Číslo portu je číslo portu TCP/IP v rozmezí 1024-60000 a je používáno pouze tímto procesem. Výchozí hodnota (25734) je většinou vhodná a pravděpodobně odlišná od jiných procesů serveru FLEXnet na řídícím počítači licenčního serveru.

    4. Na obrazovce Aktivovat/převést váš produkt SolidWorks:

      • Zvolte aktivaci na internetu, nebo emailem.
      • Zadejte kontaktní e-mailovou informaci.
      • Klepněte na Další pro pokračování.
        • Internet: K aktivaci dojde automaticky.
        • Email: Stiskněte Uložit pro vytvoření požadovaného souboru, pak pošlete soubor na activation@solidworks.com. Když obdržíte e-mail se souborem s odpovědí, soubor z e-mailu klepnutím na Otevřít načtěte.
          Pokud je to nutné, můžete tento krok ukončit a novu spustit aktivační postup pro otevření souboru s odpovědí.

  3. Klepněte na Dokončit.
Nadřazené téma: Instalace a konfigurace licencí SolidNetWork


Instalace licenčního klienta

Pokud instalujete SolidWorks na počítačích licenčních klientů SolidNetWork, sériové číslo identifikuje počítač jako klienta s licencí SolidNetWork.

  1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
  2. Na uvítací obrazovce klepněte na Individuální instalace (na tomto počítači.), pokud je to první instalace na tomto počítači pro tuto hlavní verzi.

    Pokud provádíte upgrade existující verze a měníte z individuální licence na licenci SolidWorks, klepněte na Změnit individuální instalaci (na tomto počítači).. Podrobnosti najdete v Provedení upgrade z individuální licence na licenci SolidNetWork.

  3. Po výzvě zadejte sériové číslo licence SolidNetWork.
  4. V dialogovém okně Přidat server zadejte adresu licenčního serveru v tomto tvaru:

    port@NázevPočítače

    Číslo portu se musí shodovat s číslem použitým pro počítač manažera licencí. Výchozí nastavení je 25734 tak, jak je popsáno v Instalace a aktivace licenčního klienta.

    Manažer instalace SolidWorks se pokusí ověřit, jestli je Manažer licencí SolidNetWork dostupný. Pokud jste ještě neinstalovali Manažera licencí, tato validace se nepodaří; ovšem můžete dále instalovat klienta s licencí.

  5. Dokončete instalaci SolidWorks podle následujících pokynů Manažera instalace SolidWorks.
Nadřazené téma: Instalace a konfigurace licencí SolidNetWork


Instalace manažerů licencí SolidNetWork před instalací licenčních klientů

Manažera licencí SolidNetWork byste měli instalovat a konfigurovat nejpozději jeden počítači před instalací jakékoliv licence SolidNetWork na počítače s klientskou licencí.

Pokud instalujete pomocí sériového čísla SolidNetWork, Manažer instalací SolidWorks vás vyzve k zadání názvu počítače a čísla portu manažera licencí SolidNetWork a pak se pokusí ověřit tyto informace.

Pokud jste ještě neinstalovali Manažera licencí SolidWorks na určeném počítači, toto ověření nemůže být úspěšné. V tomto případě ale selhání ověření nesděluje, zda jste zadali správné informace manažera licencí. V tomto případě ale selhání ověření nesděluje, zda jste zadali správné informace manažera licencí.

Nadřazené téma: Instalace a konfigurace licencí SolidNetWork


Instalace Manažera licencí triády

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.

Požadavky pro použití manažera licencí triády:
  • Jsou vyžadovány tři hardwarové klíče.
  • Nainstalujte triády na stabilní počítače, které nevyžadují časté restartování.
  • Všechny tři počítače manažera licencí by měly být na stejné dílčí síti. Nikdy nekonfigurujte triády prostřednictvím pomalého nebo telefonického připojení.
  • Správce systému by měl zjistit, když počítač manažera licencí selže a měl by jej okamžitě restartovat.
    Pokud jsou spuštěny dva počítače manažera licencí, situace je horší než pokud je spuštěn jeden server, protože může dojít k selhání na dvou místech.
  • Instalace prvního manažera licencí triády
    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na prvním počítači triády.
  • Instalaci manažera licencí triád na následných počítačích
    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na druhém a třetím počítači triády.
Nadřazené téma: Instalace a konfigurace licencí SolidNetWork


Instalace prvního manažera licencí triády

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na prvním počítači triády.

  1. Nainstalujte manažera licencí SolidNetWork na prvním počítači manažera licencí triády za použití manažera instalací SolidWorks.
    1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
    2. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Nainstalovat Manažera licencí SolidNetWork (distribuované licencování) na tento počítač

    3. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    4. Na stránce Shrnutí dokončete proces Manažera instalace SolidWorks klepnutím na Instalovat nyní.
  2. Za použití Manažera licencí SolidNetWork nakonfigurujte první počítač manažera licencí triády:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
    2. Klepněte na Ne.

      Objeví se záložka Správa serveru programu SolidWorks Manažera licencí SolidNetWork.

    3. V nabídce Upřesňující možnosti vyberte Možnosti.

      Zobrazí se dialogové okno Upřesňující možnosti.

    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

      Dialogové okno Upřesňující možnosti se zavře.

    5. Pod možností Informace o licenci klepněte na Upravit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    6. Pod položkou Typ serveru vyberte Triáda a klepněte na Další.
    7. Na stránce s informacemi o serveru zkontrolujte, jestli je Název počítače, ID hardwarového klíče a číslo portu pro tento počítač manažera licencí triády správný a klepněte na Další.

      Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.

    8. Na obrazovce Informace o serveru partnerské triády zadejte název počítače a ID hardwarového klíče a pro druhé dva počítače manažera licencí triády.

      Tímto je zajištěno, že pokud není jeden server k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.

    9. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.

      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork.

    10. Klepněte na Dokončit.
    11. Klepnutím na OK ukončíte průvodce Licenčním souborem SolidNetWork a pak klepnutím na Ukončitopustíte Manažer licencí SolidNetWork.
Nadřazené téma: Instalace Manažera licencí triády


Instalaci manažera licencí triád na následných počítačích

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na druhém a třetím počítači triády.

Předpokladem je, že jste již instalovali alespoň jednoho manažera licencí triády na jiném počítači. Podrobnosti najdete v Instalace prvního manažera licencí triády.

  1. Nainstalujte manažera licencí SolidNetWork na počítači manažera licencí triády za použití manažera instalací SolidWorks.
    1. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
    2. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Nainstalovat Manažera licencí SolidNetWork (distribuované licencování) na tento počítač

    3. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    4. Na stránce Shrnutí dokončete proces Manažera instalace SolidWorks klepnutím na Instalovat nyní.
  2. Za použití Manažera licencí SolidNetWork nakonfigurujte počítač manažera licencí triády:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).

      Protože je to poprvé, kdy spouštíte manažera licencí SolidNetWork na tomto počítači, zeptá se vás, jestli ho chcete nyní aktivovat.

    2. Klepněte na Ne.

      Objeví se záložka Správa serveru programu SolidWorks Manažera licencí SolidNetWork.

    3. V nabídce Upřesňující možnosti vyberte Možnosti.

      Zobrazí se dialogové okno Upřesňující možnosti.

    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

      Dialogové okno Upřesňující možnosti se zavře.

    5. Pod možností Informace o licenci klepněte na Upravit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    6. Pod položkou Typ serveru vyberte Triáda a Synchronizujte serverové/licenční informacea pak klepněte na Další.
    7. Na stránce s informacemi o serveru zkontrolujte, jestli je Název počítače, ID hardwarového klíče a číslo portu pro tento počítač manažera licencí triády správný a klepněte na Další.

      Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.

    8. Na obrazovce Informace o serveru partnerské triády zadejte název počítače a ID hardwarového klíče a pro druhé dva počítače manažera licencí triády.

      Tímto je zajištěno, že pokud není jeden server k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.

    9. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.

      Licenční soubor je obvykle umístěn na \licenses\sw_d.lic na prvním počítači manažera licencí triády, který konfigurujete.

      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork.

    10. Klepněte na Dokončit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    11. Klepnutím na OK ukončíte průvodce Licenčním souborem SolidNetWork a pak klepnutím na Ukončitopustíte Manažer licencí SolidNetWork.

Pokud nakonfigurujete druhý počítač manažera licencí triády, opakujte tento postup i pro třetí počítač manažera licencí triády.

Nadřazené téma: Instalace Manažera licencí triády


Použití licencí SolidNetWork s firewall

Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:

V software firewall musíte přidat dva porty licencí SolidNetWork (například SNL-in-port a SNL-out-port) do seznamu výjimek firewall. O bližší informace o konfiguraci těchto portů požádejte správce vaší sítě.

Pokud používáte bezpečnostní bránu Windows Firewall on Windows XP SP2 a Windows Server 2003 SP1 musíte změnit porty na počítači manažeru licencí SolidNetWork a upravte licenční soubor SolidNetWork pro distribuci licencí na licenční klientské počítače.

  • Úprava portů počítače Manažera licencí pro Windows Firewall
    Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na počítači manažera licencí SolidNetWork.
  • Úprava Manažera licencí SolidNetWork pro Windows Firewall
    Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na licenčním serveru a změnit licenční soubor SolidNetWork tak, aby distribuoval licence na počítače klientů.
Nadřazené téma: Instalace a konfigurace licencí SolidNetWork


Úprava portů počítače Manažera licencí pro Windows Firewall

Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na počítači manažera licencí SolidNetWork.

  1. Ve Windows otevřete Ovládací panely a poklepejte na Centrum zabezpečení.
  2. Klepněte na Brána firewall systému Windows.
  3. Na záložce Výjimky klepněte na Přidat port.
  4. Zadejte v dialogu Název (například, SNL-in-port) a Číslo portu (například, 25734) a pak klepněte na OK.
  5. Pro druhý port klepněte na Přidat port na záložce Výjimky zadejte název a číslo jiného portu (například, SNL-out-port a 25735), a pak klepněte na OK. Poznamenejte si číslo portu, protože je budete potřebovat později, když budete měnit licenční soubor SolidNetWork.

    Pokud používáte program PDM Workgroup, musíte změnit čísla portů PDMWorkgroup ve Windows Firewall. Tyto porty jsou většinou 20000 (Správa úschovny VaultAdmin), 30000 (Data), a 40000 (Request (Požadavek)).

  6. Uzavřete Centrum zabezpečení a Ovládací panely.
Nadřazené téma: Použití licencí SolidNetWork s firewall


Úprava Manažera licencí SolidNetWork pro Windows Firewall

Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na licenčním serveru a změnit licenční soubor SolidNetWork tak, aby distribuoval licence na počítače klientů.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit. (Klepněte na Ano, když jste vyzváni k potvrzení a na OK pro zastavení licenčního serveru.
  3. Pod možností Informace o licenci klepněte na Upravit.
  4. Pod Typem serveru zvolte uspořádání serveru pro vaši síť (Samostatný nebo Triáda) a pak klepněte na Další.
  5. Pod Informace o serveru:
    1. Vyberte Na tomto serveru se používá brána firewall.
    2. Číslo portu a číslo portu Vendor Daemon by měla obsahovat čísla portu určená pro Windows Firewall (podrobnosti viz Úprava portů počítače Manažera licencí pro Windows Firewall).
    3. Klepněte na Další a potom klepněte na Dokončit.
  6. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit.
  7. Klepnutím na OK ukončíte Manažera licencí SolidNetWork .
Nadřazené téma: Použití licencí SolidNetWork s firewall


Správa licencí SolidNetWork

Úkoly zahrnují spuštění, upgrade a odinstalování manažeru licencí a načítání, půjčování a vrácení licencí.

  • Spuštění Manažera licencí SolidNetWork
    Můžete spustit Manažera licencí SolidNetWork z nabídky Windows Start.
  • Upgrade Manažera licence SolidNetWork
    V případě hlavních verzí programu SolidWorks se upgrade manažera licencí skládá z odinstalování starého manažera licencí a instalace nového a nové aktivace licence SolidNetWork.
  • Odstranění licenčních souborů SolidNetWork
    Před provedením upgrade na nové soubory, odstraňte staré a neplatné licenční soubory SolidNetWork.
  • Načítání licencí klienta
    Pro ukončení připojení klienta SolidNetWork, správce systému může zastavit licenci a vrátit ji zpět do fondu licencí.
  • Zapůjčení a navrácení licencí SolidNetWork
    Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.
  • Monitorování doby nečinnosti licence
    SolidWorks může registrovat dobu nečinnosti licence SolidNetWork na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.
  • Instalace dočasných licencí
    Dočasnou licenci "ANY" je možno použití dočasně, když není k dispozici originální licence SolidNetWork.
  • Provedení upgrade z individuální licence na licenci SolidNetWork
    Můžete provést upgrade počítače z individuální licence SolidWorks na licenci SolidNetWork zadáním sériového čísla licence SolidNetWork v Manažeru licencí SolidWorks.
  • Použití licencí SolidNetWork a doplňkových modulů
    Můžete použít Manažera licencí SolidNetWork k distribuci licencí pro doplňkové moduly jádra SolidWorks (jako FeatureWorks, Workgroup PDM Server, atd.)
  • Použití stejného počítače pro manažera licencí a instalace administrativní kopie
    Můžete nakonfigurovat jeden počítač na síti, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SolidWorks.
  • Správa licencí FLEXnet Publisher
    Správa licencí SolidNetWork je založena na správě licencí FLEXnet Publisher®.
Nadřazené téma: Správa licencí za použití manažera licencí SolidNetWork


Spuštění Manažera licencí SolidNetWork

Můžete spustit Manažera licencí SolidNetWork z nabídky Windows Start.

  • Ve Windows spusťte tento příkaz: Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
Nadřazené téma: Správa licencí SolidNetWork


Upgrade Manažera licence SolidNetWork

V případě hlavních verzí programu SolidWorks se upgrade manažera licencí skládá z odinstalování starého manažera licencí a instalace nového a nové aktivace licence SolidNetWork.

Manažer licence pro novější verzi může distribuovat licence pro klientské počítače, které také zůstávají u předchozí verze.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Na záložce Použití licencí ověřte, že žádný klientský počítač na sítí nemá spuštěný SolidWorks.
  3. Návod na odinstalování starší licence manažera. Podrobnosti najdete v Odinstalování Manažera licencí SolidNetWork.
  4. Nainstalujte nového manažera licencí a znovu aktivujte licenci SolidNetWork na počítači manažera licencí. Podrobnosti najdete v Instalace a aktivace licenčního klienta.

Pokud provádíte upgrade Manažera licencí na počítači, na kterém také běží aplikace SolidWorks, proveďte upgrade manažera licencí SolidNetWork a klientů, než budete instalovat jakoukoliv novou aplikaci servisního balíčku SolidWorks na tomto počítači.

Pokud provádíte upgrade manažera licencí na počítači, na němž jsou umístěny administrativní kopie, proveďte upgrade manažera licencí než provedete upgrade administrativních kopií. Podrobnosti najdete v Použití stejného počítače pro manažera licencí a instalace administrativní kopie.

  • Odinstalování Manažera licencí SolidNetWork
    Pokud provádíte upgrade manažera licencí SolidNetWork , musíte odinstalovat starého manažera licencí před instalací nového.
Nadřazené téma: Správa licencí SolidNetWork


Odinstalování Manažera licencí SolidNetWork

Pokud provádíte upgrade manažera licencí SolidNetWork , musíte odinstalovat starého manažera licencí před instalací nového.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Ověřte, zda žádný z klientských počítačů na síti nemá spuštěnou aplikaci SolidWorks.

    Záložka Použití licencí zobrazí klienty se spuštěným SolidWorks.

  3. Chcete-li převést licenci SolidNetWork na jiný počítač, nejprve ji převeďte a pak teprve odstraňte manažera licencí SolidNetWork z původního počítače.

    Více informací o převodu licencí SolidNetWork najdete na odkaze Převedení licence SolidNetWork.

  4. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit.
  5. Klepnutím na OK ukončíte Manažera licencí.
  6. Ve Windows otevřete Ovládací panely > Přidat nebo odebrat programy.
  7. Vyberte SolidWorks Správce licencí SolidNetWork, klepněte na Odstranit a potvrďte odstranění.
  8. V Průzkumníku Windows odstraňte složku SolidWorks Manažer licencí SolidNetWork.

    (Tato složka je obvykle umístěna v nabídce Programy v instalačním adresáři SolidWorks).

Nyní můžete instalovat novou verzi manažera licencí. Podrobnosti najdete v Instalace a aktivace licenčního klienta.

Pokud má počítač s Manažerem licencí SolidNetWork připojený hardwarový klíč, odstraňte jej před instalací nové verze Manažera licencí SolidNetWork.
Nadřazené téma: Upgrade Manažera licence SolidNetWork


Odstranění licenčních souborů SolidNetWork

Před provedením upgrade na nové soubory, odstraňte staré a neplatné licenční soubory SolidNetWork.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Na záložce Správa serveru v poli Licenční soubor klepněte na Upravit a poté na Další, až přejdete na obrazovku Licence.
  3. Na obrazovce Licence vyberte starý nebo neplatný licenční soubor SolidNetWork a klepněte na Odstranit.
  4. Klepněte na Dokončit a pak na OK.
Nadřazené téma: Správa licencí SolidNetWork


Načítání licencí klienta

Pro ukončení připojení klienta SolidNetWork, správce systému může zastavit licenci a vrátit ji zpět do fondu licencí.

  • Klient musí být připojený k manažeru licencí alespoň dvě minuty.
  • Můžete nakonfigurovat funkci časového limitu na 15 minut jako minimum. Po15 minutách nečinnosti se tato licence vrátí do fondu volných licencí.

Bližší údaje viz SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf.

  1. klepněte na Start > Spustit, zadejte cmd, a pak klepněte na OK pro otevření příkazového okna Windows..
  2. V okně zadejte:

    cd SolidNetWork_License_Manager_install_dir\utils lmutil lmremove feature user computer display

    kde funkce, uživatel, počítač a zobrazení jsou termíny uvedené na záložce Použití licencí manažera licencí SolidNetWork.

    Příklad:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    Musíte ukončit licenci pro každý doplňkový modul (PhotoView 360, FeatureWorks, atd.) zvlášť.

Nadřazené téma: Správa licencí SolidNetWork


Zapůjčení a navrácení licencí SolidNetWork

Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

Vypůjčené licence jsou platné pouze pro systém, na kterém byly vypůjčeny. Vypůjčené licence nelze převádět.

Daná licence je zapůjčena na vymezené časové období až do 30 dnů (nebo na jiný počet dnů definovaný správcem systému) a odebrána z fondu dostupných licencí.

Správci systému mohou upravit půjčování za účelem:
  • Definovat uživatele nebo skupiny uživatelů, kteří si mohou půjčovat licence.
  • Nastavit počet licencí, které nelze půjčovat.

Bližší údaje viz SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf.

  • Zapůjčení licencí SolidNetWork
    Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění.
  • Vrácení půjčené licence SolidNetWork
    Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.
Nadřazené téma: Správa licencí SolidNetWork


Zapůjčení licencí SolidNetWork

Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění.

Musíte být připojeni k Manažeru licencí SolidNetWork, abyste si mohli půjčit licenci, ale připojení není nutné k používání. licence.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Na záložce Půjčování licence:
    1. Zadejte datum v poli Vypůjčit do.
    2. Vyberte produkty, jejichž licence si chcete půjčit. Poté klepněte na Vypůjčit a klepnutím na Ano potvrďte půjčení.
    3. Klepněte na Obnovit. Sloupec Platnost končí označuje datum, do kterého se licence musí vrátit.
  3. Klepněte na OK.
Chcete-li spustit program SolidWorks, musíte si půjčit licenci SolidWorks. SolidWork Professional a SolidWorks Premium umožní spuštění doplňkových modulů jen s balíčkem, ale ne spuštění programu SolidWorks.
Nadřazené téma: Zapůjčení a navrácení licencí SolidNetWork


Vrácení půjčené licence SolidNetWork

Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  2. Na záložce Půjčování licence:
    1. Vyberte produkty k navrácení, klepněte na Vrátit a pak klepněte na Ano pro potvrzení.
    2. Klepněte na Obnovit. Sloupec Platnost končí je prázdný a tím označuje, že byly licence vráceny.
  3. Klepněte na OK.
Vypůjčené licence nemusí být po vypršení lhůty vráceny zpět. O půlnoci ve dne uplynutí půjčení licence SolidNetWork licenční soubor na vzdáleném počítači již neumožní spuštění programu SolidWorks a licence je automaticky vrácena do fondu volných licencí na licenčním serveru.
Nadřazené téma: Zapůjčení a navrácení licencí SolidNetWork


Monitorování doby nečinnosti licence

SolidWorks může registrovat dobu nečinnosti licence SolidNetWork na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.

  1. V manažeru licencí SolidNetwork vytvořte textový soubor:

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. Do souboru vložte následující řádek:

    TIMEOUTALL seconds

    kde seconds je číslo větší nebo rovno 900 (15 minut), což je minimální povolená doba.

Nadřazené téma: Správa licencí SolidNetWork


Instalace dočasných licencí

Dočasnou licenci "ANY" je možno použití dočasně, když není k dispozici originální licence SolidNetWork.

Instalováním licenčního souboru "ANY" souhlasíte s tím, že použijete tradiční licenci, jakmile ji obdržíte od společnosti Dassault Systemes SolidWorks Corporation. Musíte stále dodržovat licenční podmínky.

Návod na instalaci licence "ANY":

  1. Pokud jste stávající uživatel SolidNetWork, klepněte na Odinstalovat Manažera licencí SolidNetWork a odstraňte instalační složku. Podrobnosti najdete v Odinstalování Manažera licencí SolidNetWork.
  2. Spusťte Manažera instalací (jak je popsáno v Zahájení instalace SolidWorks).
    1. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Nainstalovat Manažera licencí SolidNetWork (distribuované licencování) na tento počítač

    2. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    3. Na stránce Shrnutí dokončete proces Manažera instalace SolidWorks klepnutím na Instalovat nyní.
  3. Spusťte Manažera licencí SolidNetWork (Start > Programy > SolidWorks verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
  4. Budete-li vyzváni k aktivaci, klepněte na Ne.

    Objeví se záložka Správa serveru programu SolidWorks Manažera licencí SolidNetWork.

  5. V nabídce Upřesňující možnosti vyberte Možnosti.

    Zobrazí se dialogové okno Upřesňující možnosti.

  6. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

    Dialogové okno Upřesňující možnosti se zavře.

  7. Pod možností Informace o licenci klepněte na Upravit.

    Objeví se průvodce licenčním souborem SolidNetWork.

  8. Pod položkou Typ serveru vyberte Samostatný a klepněte na Další.
  9. Pokud se zobrazí tato zpráva:

    Nelze načíst ID hardwarového klíče.
    Klepněte na Storno.
    Automaticky je zobrazeno ID "ANY".
    Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.

  10. Pokračujte v instalaci.
Nadřazené téma: Správa licencí SolidNetWork


Provedení upgrade z individuální licence na licenci SolidNetWork

Můžete provést upgrade počítače z individuální licence SolidWorks na licenci SolidNetWork zadáním sériového čísla licence SolidNetWork v Manažeru licencí SolidWorks.

Pokud na počítači nebyl nainstalován program SolidWorks, můžete určit licenci SolidNetWork zadáním sériového čísla licence SolidNetWork při instalaci pomocí Manažera instalace SolidWorks.

Pokud je již na počítači nainstalován SolidWorks a přecházíte z individuální licence na licenci SolidNetWork, můžete upravit instalaci pro klientský počítač a určit sériové číslo licence SolidNetWork místo sériového čísla individuální licence, když spouštíte Manažera instalace SolidWorks. Podrobnosti najdete v Změna instalace.

Nadřazené téma: Správa licencí SolidNetWork


Použití licencí SolidNetWork a doplňkových modulů

Můžete použít Manažera licencí SolidNetWork k distribuci licencí pro doplňkové moduly jádra SolidWorks (jako FeatureWorks, Workgroup PDM Server, atd.)

  • Není vyžadován stejný počet licencí programu SolidWorks a licencí doplňkových modulů.
  • Chcete-li vyzvednout licenci pro doplňkový modul, musíte nejprve vyzvednout licenci pro program SolidWorks.
  • Pro zapůjčení licence doplňkového modulu, musíte zapůjčit obě licence, licenci programu SolidWorks a licenci produktu SolidWorks, který obsahuje doplňkový modul. Například budete muset zapůjčit licenci na produkt SolidWorks Professional nebo SolidWorks Premium.
  • Návod na uvolnění licence doplňkového modulu:
    • V SolidWorks klepněte na Nástroje > Doplňkové moduly, a zrušte výběr doplňkového modulu.
    • Ukončete aplikaci SolidWorks.
Nadřazené téma: Správa licencí SolidNetWork


Použití stejného počítače pro manažera licencí a instalace administrativní kopie

Můžete nakonfigurovat jeden počítač na síti, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SolidWorks.

Klientské počítače obdrží licence od manažera licencí a pak instalují SolidWorks z téhož počítače.

Tato konfigurace vyžaduje, aby manažer licencí a administrativní kopie byly na stejném počítači. Nainstalujte nejprve manažera licencí a pak vytvořte a distribuujte administrativní kopii.
Podrobnosti najdete na odkazu:
  • Instalace a aktivace licenčního klienta
  • Zavádění více klientů
Nadřazené téma: Správa licencí SolidNetWork


Správa licencí FLEXnet Publisher

Správa licencí SolidNetWork je založena na správě licencí FLEXnet Publisher®.

Více informací ohledně správy licencí FLEXnet Publisher viz FLEXnet Publisher Průvodce správou licencí v instalačním adresáři manažera licencí SolidNetwork (SolidNetwork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf).

Nejnovější informace o správě licencí FLEXnet Publisher získáte na kontaktu Acresso® Software..

Nadřazené téma: Správa licencí SolidNetWork


Řešení potíží

Zkonzultujte tato témata, která vám pomohou při odstranění potíží při instalaci.

  • Soubory protokolu Manažera instalací SolidWorks
    Soubory protokolu Manažera instalací SolidWorks jsou k dispozici jako pomoc při odstranění instalačních problémů.
  • Složka pro stažení Manažera instalací SolidWorks
    Manažer instalací SolidWorks stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.
  • Odstranění potíží s licencemi SolidNetWork
    Pokud se instalace Manažera licencí SolidNetWork nezdaří, zkontrolujte tato možná vysvětlení.
  • Řešení potíží s upgrady
    Pokud se setkáte s problémy během provedení upgrade nové verze SolidWorks, zkontrolujte tato možná vysvětlení.


Soubory protokolu Manažera instalací SolidWorks

Soubory protokolu Manažera instalací SolidWorks jsou k dispozici jako pomoc při odstranění instalačních problémů.

Soubory protokolu Manažera instalací SolidWorks jsou umístěné se soubory protokolu jiných aplikací SolidWorks.
  • Pro Windows Vista nebo novější operační systémy:

    C:\Users\uživatelské jméno\AppData\Roaming\SolidWorks\Installation Logs\nainstalovaná_verze

  • Pro verze operačního systému Windows před Windows Vista:

    C:\Documents and Settings\uživatelské jméno\Application Data\SolidWorks\Installation Logs\nainstalovaná_verze\

Pro zobrazení adresářů souborů protokolu budete možná muset nakonfigurovat možnosti složky Windows na Zobrazit skryté soubory a složky.

Pokud jsou data aplikací umístěna na jiné jednotce než C:, přizpůsobte podle toho cestu.

Tento adresář obsahuje soubor SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, všeobecný protokol o průběhu Manažera instalací SolidWorks.

Podadresář Jiné protokoly obsahuje soubory protokolů s podrobnějšími informacemi.

Nadřazené téma: Řešení potíží


Složka pro stažení Manažera instalací SolidWorks

Manažer instalací SolidWorks stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.

  1. Jakým způsobem nainstalovat soubory v této složce?
  2. Je možné z této složky ručně nainstalovat soubory MSI pomocí msiexec nebo jiné aplikace?
  3. Je možné zadat stejnou složku pro stažení pro každou nainstalovanou verzi?
  4. Některé produkty byly ručně staženy z webové stránky Dassault Systemes SolidWorks Corporation. Může je Manažer instalací také nainstalovat?
  5. Mohou být stažené soubory sdílené s jinými uživateli?
  6. Jak je možné zjistit, že jsou dostupné nové verze produktů SolidWorks?
  7. Manažer instalací zobrazuje pouze SW2006 nebo SW2007, ale ne aktuální verzi.
  8. Manažer instalací neumožňuje výběr jiné aktualizace service pack produktu k instalaci.
  9. Manažer instalací nemůže stahovat soubory.
  10. Ne všechny nainstalované produkty SolidWorks jsou aktualizované na poslední aktualizaci service pack, ale příkaz Zjistit aktualizace informuje, že na počítači je nainstalovaná aktuální verze?
  11. Je možné zkopírovat DVD do složky pro stažení?

Jakým způsobem nainstalovat soubory v této složce?

Spusťte setup.exe. Pokud zvolíte instalaci položek, které ještě nebyly staženy, budete muset stáhnout některé soubory.

Neinstalujte pomocí msiexec (viz níže).

Zpět na začátek

Je možné z této složky ručně nainstalovat soubory MSI pomocí msiexec nebo jiné aplikace?

Ne. Manažer instalací nestahuje určité soubory, které jsou vyžadovány při spuštění msiexec.

Zpět na začátek

Je možné zadat stejnou složku pro stažení pro každou nainstalovanou verzi?

Složky stažení jsou specifické podle verze. Počínaje SolidWorks 2010, Manažera instalací SolidWorks automaticky vytvoří podsložku specifickou pro tuto verzi uvnitř specifické složky.

Zpět na začátek

Některé produkty byly ručně staženy z webové stránky Dassault Systemes SolidWorks Corporation. Může je Manažer instalací také nainstalovat?

Počínaje SW2009 se soubory stažené ručně mohou používat k instalaci pomocí Manažera instalací SolidWorks. Ovšem je lepší spustit Manažera instalací SolidWorks a vybrat možnost pro stažení souborů. Manažer instalací SolidWorks ukáže na základě toho, co instalujete, který soubor potřebujete a poskytne odkazy pro stažení každého souboru. Zvolte tuto možnost, pokud vestavěná stránka pro stažení nefunguje (zřejmě z důvodu stahování i přes omezení uplatňovaná proxy serverem).
Pokud se Microsoft Internet Explorer zeptá, jestli chcete uložit nebo provést soubory během spuštění nebo instalace, vždy vyberte uložit.

Zpět na začátek

Mohou být stažené soubory sdílené s jinými uživateli?

Ano. Pokud chcete soubory sdílet, stáhněte je na místo v síti. Každý klient může spustit Manažera instalací SolidWorks z tohoto sdíleného umístění v síti.

Nebude již potřeba stáhnout další soubory, pokud uživatel nevybere k instalaci položky, které nebyly během počátečního stažení vybrány nebo pokud počítač, který to využívá k instalaci, má jinou sadu předpokladů než počítač, na který soubory stahujete.

Pokud provádíte pouze stažení za jiné, ale ne instalaci, vyberte při instalaci možnost Pouze stáhnout. Tato možnost vám umožní vybrat produkty nezávisle na tom, co je nainstalováno na vašem počítači. Tuto možnost však nelze použít pro instalaci oprav nebo pro vytvoření administrativních kopií.

Zpět na začátek

Jak je možné zjistit, že jsou dostupné nové verze produktů SolidWorks?

V těchto případech budete informování o nové verzi:
  • Pokud spustíte Zjistit aktualizace (Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace)
  • Pokud jste povolili SolidWorks Nástroj pro stahování na pozadí.
  • Pokud vyberete nainstalovanou verzi programu SolidWorks ve Windows v části Přidat/Odebrat programy a klepnete na Změnit
  • Pokud ze složky pro stažení spustíte starší verzi Manažera instalací (sldIM.exe).
V těchto případech můžete stáhnout novější verzi. Manažer instalací SolidWorks stáhne a spustí novou verzi manažera, ale ne žádné instalační soubory. Po spuštění nové verze Manažera instalací SolidWorks můžete vybrat ze sady instalačních operací. Manažer instalací SolidWorks určí požadované instalační soubory (a soubory, které ještě nebyly staženy) a nabídne je ke stažení.

Zpět na začátek

Manažer instalací SolidWorks zobrazuje pouze SW2006 nebo SW2007, ale ne aktuální verzi.

Máte spuštěnou starší verzi Manažera instalací SolidWorks, která již není podporována v aktuální verzi. Tato verze Manažera instalací může stáhnout aktualizace service pack pouze pro verzi SW2006 a SW2007.

Zpět na začátek

Manažer instalací SolidWorks neumožňuje výběr jiné aktualizace Service Pack produktu k instalaci.

To je určeno návrhem. Každá verze Manažera instalací SolidWorks je určena k instalaci pouze konkrétní verze produktů SolidWorks. Pokud chcete instalovat jinou aktualizaci Service Pack, musíte spustit Manažera instalací SolidWorks odpovídající verze. Pro zjištění poslední dostupné verze, vizJak je možné zjistit, že jsou dostupné nové verze produktů SolidWorks?

Zpět na začátek

Manažer instalací SolidWorks nemůže stahovat soubory.

Pokud omezení proxy serveru zabraňují programům ve stahování souborů, Manažer instalací SolidWorks nemůže automaticky stahovat soubory.

Můžete stahovat soubory ručně a pak je instalovat pomocí Manažera instalací SolidWorks. Zvolte v Manažeru instalací SolidWorks možnost pro stažení individuálních souborů (například, Provést ruční stažení na stránce Možnosti instalace). Podle vašeho výběru produktu a požadavků systému se objeví webová stránka ve zvláštním okně a obsahuje odkazy pro manuální stažení všech požadovaných souborů. Tyto odkazy jsou identické s těmi, které poskytuje Zákaznický portál SolidWorks, ale soubory nemusíte hledat.

Zpět na začátek

Ne všechny nainstalované produkty SolidWorks jsou aktualizované na poslední aktualizaci service pack, ale příkaz Zjistit aktualizace informuje, že na počítači je nainstalovaná aktuální verze?

Spuštěním příkazu Zjistit aktualizace se dozvíte, zda máte nainstalovanou a nebo spuštěnou aktuální verzi Manažera instalací SolidWorks.

Pokud chcete aktualizovat všechny produkty podle poslední verze, která byla instalována, v programechPřidat/Odstranit programy zvolte poslední instalovanou verzi SolidWorks a klepněte naZměnit.

Zpět na začátek

Je možné zkopírovat DVD do složky pro stažení?

Ano, ale instalace mohou selhat, pokud nezkopírujete celý obsah každého DVD vydaného pro odpovídající platformu (x86 nebo x64). Manažer instalací SolidWorks hledá soubory swdata*.id pro určení verze. Pokud tyto soubory nejsou k dispozici, nebude moci rozpoznat zkopírované instalační soubory a bude vyžadovat jejich stažení.

Zpět na začátek

Nadřazené téma: Řešení potíží


Odstranění potíží s licencemi SolidNetWork

Pokud se instalace Manažera licencí SolidNetWork nezdaří, zkontrolujte tato možná vysvětlení.

  • Přístup na soubory protokolu licencí SolidNetWork
    Když dojde k chybě v licenci, většinou se odpověď zobrazí v souboru protokolu SNL_Manager_install_dir\lmgrd.log .
  • Nepodařilo se získat licenci pro SolidWorks. Nepodařilo se připojit k licenčnímu serveru.
    Tento problém je většinou způsoben nastaveními portu.
Nadřazené téma: Řešení potíží


Přístup na soubory protokolu licencí SolidNetWork

Když dojde k chybě v licenci, většinou se odpověď zobrazí v souboru protokolu SNL_Manager_install_dir\lmgrd.log .

Nadřazené téma: Odstranění potíží s licencemi SolidNetWork


Nepodařilo se získat licenci pro SolidWorks. Nepodařilo se připojit k licenčnímu serveru.

Tento problém je většinou způsoben nastaveními portu.

  • Nastavení portu mezi manažerem licencí SolidNetWork a licenčním klientem se zřejmě neshoduje.
  • Další nastavení portu pro násobné verze Manažera licence SolidNetWork nebyly pravděpodobně určeny.
Bližší informace o nastavení portu pro manažery licencí SolidNetWork a klienty, viz Použití licencí SolidNetWork s firewall.
Nadřazené téma: Odstranění potíží s licencemi SolidNetWork


Řešení potíží s upgrady

Pokud se setkáte s problémy během provedení upgrade nové verze SolidWorks, zkontrolujte tato možná vysvětlení.

  • Upgrade z přemístěného zdroje
    Při instalaci programu SolidWorks si Manažer instalací SolidWorks zapamatuje umístění zdrojů (disk, kopie disku na síti, atd.). Manažer instalací očekává tyto zdroje ve stejném umístění během aktualizace.
Nadřazené téma: Řešení potíží


Upgrade z přemístěného zdroje

Při instalaci programu SolidWorks si Manažer instalací SolidWorks zapamatuje umístění zdrojů (disk, kopie disku na síti, atd.). Manažer instalací očekává tyto zdroje ve stejném umístění během aktualizace.

Pokud dojde k přemístění nebo odstranění zdroje, nebo pokud se změní médium zdroje, zobrazí Manažer instalace SolidWorks chybovou hlášku. Pokud vyhledáte jiné umístění obsahující stejné soubory a strukturu složky, můžete pokračovat v upgradu.

Nadřazené téma: Řešení potíží s upgrady


Nápověda aplikace Manažera instalací SolidWorks

Manažer instalací SolidWorks je samostatný program, který nainstaluje a aktualizuje produkty SolidWorks.

Manažera instalací SolidWorks můžete spustit následujícími způsoby:
  • Z DVD SolidWorks nebo ze sdílené zdrojové složky nebo složky pro stažení (když instalujete novou verzi).
  • Ze stránky Ovládací panel Přidat nebo Odebrat programy (když měníte nebo odstraňujete stávající verzi)
  • Prostřednictvím naplánovaného nebo ručního zjišťování aktualizací (najít, stáhnout a nainstalovat nové finální verze).

Každá verze SolidWorks má verzi Manažera instalací SolidWorks, která je specifická pro danou verzi SolidWorks.

Pro verze předcházející verzi SolidWorks 2008 použijte Manažera instalací SolidWorks 2007 nebo stáhněte ručně verze produktu z webové stránky podpory SolidWorks.
  • SolidWorks Nástroj pro stahování na pozadí
    SolidWorks Nástroj pro stahování na pozadí provádí automatizované stahování souborů (například když je nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se zobrazí dotaz, zda chcete instalovat nyní, odložit nebo odstranit stahování.
  • Výsledky zjištění aktualizací
    Zjistit aktualizace hledá novější verze SolidWorks.
  • Umístění administrativní kopie
    Určete umístění instalace administrativní kopie.
  • Možnosti stažení
    Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.
  • Možnosti stažení pro soubory Manažera instalací SolidWorks
    Zvolili jste stáhnout novější verzi Manažera instalací SolidWorks. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.
  • Stažení instalačních souborů produktu
    Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.
  • Průběh stahování
    Během tohoto procesu Manažer instalací SolidWorks stáhne, ověří a extrahuje paralelně všechny soubory.
  • Výsledky stahování
    Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.
  • Chyby během instalace / Instalace byla zrušena
    Při instalaci došlo k chybě nebo byla instalace zrušena.
  • Instalace je dokončena
    Manažer instalací SolidWorks dokončil proces instalace.
  • Umístění instalace
    Určete umístění instalace SolidWorks.
  • Možnosti upgradu
    Na tomto počítači je nainstalována jedna nebo více starších hlavních verzí SolidWorks. Vyberte, jestli provedete upgrade poslední existující verze na novou verzi nebo vytvoříte novou instalaci pro novou verzi.
  • Průběh instalace
    Tato obrazovka uvádí průběh instalace.
  • Typ instalace
    Určete operaci instalace, kterou chcete spustit, jako je vytvoření nové instalace, úprava nebo oprava existující instalace, vytvoření administrativní kopie, instalace administrativních produktů serveru nebo stažení souborů bez instalace.
  • Instalace a správa několika počítačů
    Manažer instalací SolidWorks poskytuje následující nástroje na instalaci a správu několika počítačů SolidWorks.
  • Ruční stahování
    Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SolidWorks).
  • K dispozici je novější verze
    Manažer instalací zaznamenal novější verzi produktů SolidWorks. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.
  • Nejsou k dispozici novější verze
    Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.
  • Zjištěné procesy
    Manažer instalací SolidWorks zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.
  • Výběr produktu
    Určete součásti produktu, které chcete nainstalovat, upravit nebo odebrat.
  • Produkty ke stažení
    Vyberte produkty SolidWorks, které se mají stáhnout do určitého umístění.
  • Produkty k opravě
    Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SolidWorks spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SolidWorks.
  • Sériová čísla
    Sériová čísla, která se nacházejí na balení, přiřazují zakoupené produkty SolidWorks k vašemu počítači.
  • Instalace serveru
    Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.
  • Manažer licencí SolidNetWork
    Zadejte instalační volby pro produkt pro server Manažer licencí SolidNetWork.
  • Souhrnné informace
    Manažer instalací SolidWorks má všechny potřebné informace pro dokončení instalace.
  • Upozornění kontroly systému
    Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SolidWorks.
  • Možnosti Průvodce dírami/Toolbox
    Pokud je Toolbox SolidWorks instalován, SolidWorks obsahuje knihovnu standardních typů děr stejně jako hardware.
  • Odinstalování produktů
    Zvolíte-li v Ovládacích panelech možnost Odstranit nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SolidWorks (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SolidWorks. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.
  • Možnosti serveru Workgroup PDM
    Zadejte instalační volby pro produkt pro server SolidWorks Workgroup PDM.


SolidWorks Nástroj pro stahování na pozadí

SolidWorks Nástroj pro stahování na pozadí provádí automatizované stahování souborů (například když je nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se zobrazí dotaz, zda chcete instalovat nyní, odložit nebo odstranit stahování.

SolidWorks Nástroj pro stahování na pozadí je standardně povolen, když instalujete SolidWorks pomocí Manažera instalací SolidWorks.

Když běží Manažer instalací SolidWorks, je SolidWorks Nástroj pro stahování na pozadí pozastaven, bez ohledu na to, zda provádí instalaci nebo stahování. Dojde tak například k pozastavení všech probíhajících stahování, nepovolí se zahájení nových stahování a není možné změnit určení složky pro stahování.

SolidWorks Nástroj pro stahování na pozadí je ve výchozím nastavení povolen, když instalujete SolidWorks. SolidWorks Nástroj pro stahování na pozadí můžete během instalace SolidWorks vypnout, a sice tak, že změníte Možnosti stahování na stránce Shrnutí. (Zrušte výběr položky Chcete použít Nástroj pro stahování na pozadí?.)

Když je nástroj povolen, objeví se v systémové oblasti Windows v hlavním panelu tato ikona:

Klepnutím na tuto ikonu aktivujete následující operace:
  • Nápověda pro Nástroj pro stahování na pozadí
  • Pozastavit stahování
  • Obnovit stahování
  • Zrušit stahování
  • Možnosti instalace
  • Změnit umístění pro stahování
  • Zjistit aktualizace
  • Zjišťovat aktualizace automaticky
  • Automaticky stáhnout aktualizace
  • Zakázat nástroj pro stahování na pozadí

Nápověda pro Nástroj pro stahování na pozadí

Otevřete toto téma nápovědy pro Nástroj pro stahování na pozadí pomocí Průvodce instalací SolidWorks.

Pozastavit/obnovit stahování

Pokud běží na pozadí stahování, klepnutím na Pozastavit stahování je pozastavíte a můžete je později kdykoli znovu obnovit klepnutím na Obnovit stahování.

Zrušit stahování

Pokud probíhá stahování, můžete je zastavit a odstranit veškeré soubory, které již Nástroj pro stahování na pozadí stáhl.
Zrušené stahování nemůžete obnovit.

Možnosti instalace

Když je stahování dokončeno, můžete si vybrat z následujících možností:
  • Nainstalovat: Nainstaluje stažené soubory.
  • Připomenout později: Nenainstaluje stažené soubory, ale sestaví zprávu, kterou vám připomene instalaci později.
  • Odstranit stažení: Nenainstaluje stažené soubory a odstraní je. (To je užitečné zejména v případě, že jste se rozhodli, že stažené soubory již nechcete instalovat.)

Změnit umístění pro stahování

Změní umístění, do něhož Nástroj pro stahování na pozadí stahuje soubory.

Tato volba není dostupná, pokud stahování buď běží nebo je pozastaveno.

Zjistit aktualizace

Spustí funkci Zjistit aktualizace Manažera instalací SolidWorks.

Zjišťovat aktualizace automaticky

Pravidelně spouští příkaz Zjistit aktualizace a upozorňuje, že jsou k dispozici aktualizace ke stažení.

Automaticky stáhnout aktualizace

Pravidelně spouští příkaz Zjistit aktualizace a stahuje dostupné aktualizace.

Vypnutí a opětovné zapnutí SolidWorks Nástroje pro stahování na pozadí

Nástroj pro stahování na pozadí můžete vypnout klepnutím na jeho ikonu a výběrem možnosti Zakázat nástroj pro stahování na pozadí.

Chcete-li Nástroj pro stahování na pozadí znovu povolit, klepněte na Start > Programy > Manažer instalace SolidWorks > SolidWorks Nástroj pro stahování na pozadí.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Výsledky zjištění aktualizací

Zjistit aktualizace hledá novější verze SolidWorks.

Můžete provést Zjistit aktualizace ručně:
  • V systému Windows klepněte na Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace
  • V SolidWorks klepněte na položku Nápověda > Zjistit aktualizace.
Zjistit aktualizace není k dispozici u klientů instalovaných z administrativních kopií.

Dostupná novější verze

Manažer instalací SolidWorks zaznamenal novější verzi produktů SolidWorks. Vyberte novou verzi Manažera instalací SolidWorks, což vám umožní aktualizovat na novější verzi.

Tato novější verze může stáhnout instalační soubory založené na produktech, které jste určili v instalaci. Stažené soubory můžete sdílet s ostatními uživateli, kteří používají k instalaci Manažera instalací SolidWorks.

Tato stažení lze použít pouze v Manažeru instalací SolidWorks.
K dispozici jsou tyto možnosti:
  • Pokud je k dispozici několik verzí, vyberte požadovanou verzi ze seznamu.
  • Detaily o verzi najdete v odkazu Zkontrolujte, co tento upgrade obsahuje.
Klepnutím na Další bude stažena a spuštěna nová verze Manažera instalací SolidWorks.

Žádná nová stažení/Nové verze není možné zjistit

Manažer instalací SolidWorks nezjistil nové verze produktů SolidWorks, buď protože jste instalovali nejnovější verzi, která je k dispozici nebo se nemohl připojit k serveru SolidWorks, aby provedl kontrolu.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Umístění administrativní kopie

Určete umístění instalace administrativní kopie.

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie
Toto je umístění adresáře, ve kterém Manažer instalací SolidWorks vytvoří novou kopii.
Toto umístění nemůže obsahovat existující administrativní kopii. Administrativní kopie musí být ve složce, kterou lze sdílet za účelem zavedení na klienty.
Odhadované místo na disku požadované pro vytvoření kopie
Toto je doplňkové místo požadované pro administrativní kopii.
Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z:
Toto je umístění adresáře, ze kterého instalujete produkty SolidWorks.
Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti najdete v Možnosti stažení.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Možnosti stažení

Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.

Manažer instalací SolidWorks podporuje způsob distribuce softwaru tzv. electronic software distribution (ESD). Pokud neprovádíte instalaci ze SolidWorks DVD, budete vyzváni k zadání zdroje pro produkty SolidWorks, které instalujete.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SolidWorks.

Co chcete udělat?

Vyberte jednu z následujících možností:
Stáhnout a instalovat/stáhnout a vytvořit kopii
Po dokončení stažení spustí Manažer instalací SolidWorks instalaci za použití stažených souborů.
Pouze stáhnout. Můžete stáhnout soubor jednou a pak sdílet stažené soubory s více počítači.
Manažer instalací SolidWorks nespustí instalaci po dokončení stažení.

Obvykle byste zadali tuto možnost, když byste stahovali soubory ke konfiguraci sady instalačních souborů, kterou použijete na více počítačích.

Pokud tuto možnost zvolíte, budete vyzváni, abyste si vybrali mezi dvěma sadami souborů, které chcete stáhnout:
  • Soubory pro TENTO počítač: Stažení bude obsahovat jen ty soubory, které chybí v sadě instalačních souborů aktuálně instalovaných na tomto počítači.
    Toto stažení by mělo být menší, protože obsahuje:
    • Pouze soubory pro produkty vybrané na stránce Výběr produktu
    • Pouze soubory předpokladů, které jsou požadovány pro váš počítač, ale ještě nejsou instalovány

    Pokud se ale pokusíte použít tuto stáhnutou sadu souborů na jiném počítači pro provedení instalace, některé soubory by mohly chybět (protože sada instalačních souborů na jiném počítači by mohla být rozdílná). Můžete použít tyto stažené soubory pro instalaci na jiném počítači, ale když instalace běží, budete možná muset stáhnout další soubory pro doplnění sady instalačních souborů na tomto počítači.

  • Soubory ke sdílení s JAKÝMKOLIV počítačem: Stažení bude obsahovat kompletní sadu instalačních souborů, kterou je možno použít k instalaci této verze na jakémkoliv počítači.

    Toto stažení je delší, protože obsahuje kompletní sadu souborů, kterou je možno použít k instalaci této verze jakéhokoliv produktu na jakémkoliv počítači.

    Pokud určíte omezenou sadu produktů, které se mají stáhnout, bude tato možnost toto určení ignorovat a stáhne všechny produkty obsažené v této verzi produktu.

    Stažení bude obsahovat všechny soubory nutné pro vytvoření administrativní kopie, nejenom ty soubory, které jsou nutné pro provedení individuální instalace.

Pouze instalovat/Vytvořit pouze kopii. Mám již všechny soubory, které jsou nutné k instalaci.
Manažer instalací SolidWorks nestahuje žádné soubory, ale používá soubory ve vybraném adresáři.

Vyhledejte jiné umístění klepnutím na Vyhledat. Můžete například přejít k instalačnímu DVD nebo ke složce stažení, za předpokladu, že toto místo obsahuje všechny požadované soubory.

Pokud obdržíte chybovou hlášku, že složka není kompletní a předpokládali jste, že obsahuje všechny instalační soubory, vysvětlení mohou být následující:
  • Vybrali jste k instalaci produkt, který nebyl ještě stažen, nebo byl vybrán automaticky.
  • Soubory byly staženy na jiném počítači s jinou sadou systémových požadavků.
  • Nejprve jste provedli klientskou instalaci a nyní vytváříte administrativní kopii, která vyžaduje větší sadu souborů.

Můžete buď vyhledat složku obsahující všechny tyto soubory (například DVD) nebo vyberte jednu z možností stažení.

Kam se mají stáhnout požadované soubory?

Toto je složka pro umístění stažení.

V některých případech může být tato možnost viditelná, ale vypnutá. Například pokud je zvoleno Pouze instalovat, Manažer instalací SolidWorks nainstaluje jakékoliv stažené soubory z adresáře určeného pro tuto možnost a nepoužije samostatnou složku pro stažení.

Ať již stahujete tyto soubory nebo k nim máte přístup z vašeho vlastního umístění, všechny soubory musí být staženy do stejné složky.

Odhadovaná velikost stažení

Odhadovaný požadavek na místo na disku při stažení je založen na vybraném celkovém seznamu součástí, bez ohledu na to, zda se jedná o nové stažení nebo o obnovení předchozí relace.

Například, pokud obnovíte předchozí stažení, Manažer instalací SolidWorks zpracuje pouze ty soubory, které ještě nebyly staženy. Doba stažení může být kratší než odhadovaná doba.

Pokud soubor dokončil stahování v předchozím stažení, jeho velikost není zahrnuta v tomto odhadu. Proto může být odhad vyšší než aktuální velikost stažení.

Jakým způsobem se má provést stažení?

Existují dvě možnosti:
Provést ruční stažení
V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SolidWorks.
Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SolidWorks a ukončit operace instalace. Tato webová stránka je přizpůsobena Manažerem instalací SolidWorks a stahuje pouze ty soubory, které jsou nutné pro dokončení instalace.
Zrychlete stahování využitím lepšího širokopásmového připojení.
Nástroj pro stahování používá algoritmus ke zrychlení stahování tak, že během stahování zvýší používání širokopásmového připojení.

V některých případech však může dojít k narušení výkonu sítě. Pokud budete mít během stahování potíže, může to znamenat, že tato možnost nemusí být podporována proxy serverem. Zrušte výběr této možnosti a proveďte stažení znovu. O detaily požádejte správce vaší sítě.

Tato možnost se vztahuje jen na automatické stahování.. Nemá žádný dopad na ruční stažení.

Používání SolidWorks nástroje pro stahování na pozadí

SolidWorks Nástroj pro stahování na pozadí slouží k dokončení této operace stahování, nebo ke stažení budoucích aktualizací service pack pro program SolidWorks, když budou k dispozici.

SolidWorks Nástroj pro stahování na pozadí automaticky zaznamená a stáhne nové aktualizace service pack na pozadí a upozorní vás, že je stahování dokončeno a soubory jsou připraveny k instalaci. Podrobnosti najdete v SolidWorks Nástroj pro stahování na pozadí.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Možnosti stažení pro soubory Manažera instalací SolidWorks

Zvolili jste stáhnout novější verzi Manažera instalací SolidWorks. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SolidWorks.

Tato obrazovka se objeví pouze tehdy, když existuje problém s výchozí složkou pro stažení (například pokud není přístup ke čtení nebo síti k dispozici). Obvykle můžete sami určit alternativní adresář pro stažení pro pokračování.

Složka pro stažení

Vyhledejte cílovou složku pro soubory Manažera instalace SolidWorks.

Zobrazí se požadované místo a aktuálně dostupné místo na disku. Toto číslo zahrnuje dodatečné místo pro dekomprimaci stažených souborů a je větší než velikost stažení.

Použít zrychlené stahování

Pokud je tato možnost vybrána, nástroj pro stahování používá algoritmus ke zrychlení stahování.

Zrychlené stahování zvyšuje požadavky na síť a může narušit její fungování. Poraďte se se správcem sítě, než povolíte zrychlené stahování.

Pokud není zrychlené stahování podporované proxy serverem, je tato možnost automaticky zakázána.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Stažení instalačních souborů produktu

Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.

Během stahování Manažer instalací SolidWorks stáhne, ověří a extrahuje paralelně všechny soubory.

Zrušením této obrazovky zrušíte zbytek posloupnosti instalace.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací najdete v tématu Chyby během instalace.

Složka pro stažení

Vyhledejte cílovou složku pro stažené soubory.

Je také zobrazena velikost stahování a požadované místo. Požadované místo zahrnuje jakékoliv místo navíc, které je zapotřebí pro dekomprimaci určitých stahování a je větší než aktuální stahovaná velikost.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SolidWorks.

Možnosti stažení

Zrychlete stahování využitím lepšího širokopásmového připojení.
Nástroj pro stahování používá algoritmus ke zrychlení stahování tak, že během stahování zvýší používání širokopásmového připojení.

V některých případech však může dojít k narušení výkonu sítě. Pokud budete mít během stahování potíže, může to znamenat, že tato možnost nemusí být podporována proxy serverem. Zrušte výběr této možnosti a proveďte stažení znovu. O detaily požádejte správce vaší sítě.

Zrychlené stahování zvyšuje požadavky na síť a může narušit její fungování. Poraďte se se správcem sítě, než povolíte zrychlené stahování.

Pokud není zrychlené stahování podporované proxy serverem, je tato možnost automaticky deaktivována.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Průběh stahování

Během tohoto procesu Manažer instalací SolidWorks stáhne, ověří a extrahuje paralelně všechny soubory.

Chcete-li v průběhu zrušit stahování, klepněte na Storno.

Pokud stahování zrušíte nebo se stahování nepodaří, obrazovka Stahování zrušeno nebo Problém při stahování vám oznámí, které stažení nebylo dokončeno a umožní vám obnovit stahování, nebo ukončit program.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SolidWorks.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Výsledky stahování

Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.

Problém se stahováním/Stahování zrušeno

Pokud vidíte Problém se stahováním, Manažer instalací SolidWorks narazil na problémy, které brání v dokončení stahování.

Pokud vidíte Stahování zrušeno, zrušili jste stahování před tím, než bylo dokončeno.

Pokračujte následovně:

Opakovat/Obnovit automatická stahování
Pro obnovení automatického stahování z místa, kde bylo zrušeno, zvolte tuto možnost a klepněte na Opakovat staženínebo Obnovit stažení.
Stáhnout soubory individuálně ve webovém prohlížeči
V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SolidWorks.
Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SolidWorks a ukončit operace instalace. Tato webová stránka je přizpůsobena Manažerem instalací SolidWorks a stahuje pouze ty soubory, které jsou nutné pro dokončení instalace.

Stahování dokončeno

Obrazovka Stahování dokončeno se objeví, když je stahování dokončeno, pokud jste určili možnost Pouze stáhnout.

Klepnutím na Dokončit ukončíte Manažera instalací SolidWorks.

Neinstalujte žádný z těchto produktů ručně. Vždy používejte k instalaci stažených souborů Manažera instalací SolidWorks.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Chyby během instalace / Instalace byla zrušena

Při instalaci došlo k chybě nebo byla instalace zrušena.

Pokud dojde k chybě, nebo ke zrušení:
  • Produkty, které byly nainstalovány než došlo k chybě nebo ke zrušení, zůstanou na počítači.
  • Instalace produktu, která probíhala v době zrušení, je vrácena zpět, je-li to možné, aby na počítači nebyly částečné instalace.
  • Zbylé produkty nejsou nainstalovány nebo odinstalovány. Seznam je k dispozici pod Nebyl proveden pokus.

    Chcete-li obnovit instalaci nebo tyto produkty odinstalovat, klepněte na odkazy, které jsou k dispozici.

Manažer instalací SolidWorks nejprve nainstaluje nutné předpoklady, které nejsou instalované na počítači, jako například .NET framework. Poté nainstaluje produkty v tomto pořadí:
  1. SolidWorks
  2. eDrawings
  3. SolidWorks vyhledávání
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Obnovení po nezdařené nebo zrušené instalaci
    Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětného spuštění instalace.
  • Oprava instalace
    Pokud zaznamenáte problém s nainstalovaným produktem SolidWorks, můžete pomocí Manažera instalací SolidWorks instalaci opravit.
  • Kontaktování prodejce SolidWorks
    Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SolidWorks a poskytněte jim informace z této obrazovky. Možná, že také budou potřebovat komprimovanou složku souborů protokolu Manažera instalací SolidWorks.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Obnovení po nezdařené nebo zrušené instalaci

Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětného spuštění instalace.

  1. Zaznamenejte chybovou hlášku a kód produktu pro každou nezdařenou instalaci tak, jak je zobrazeno na obrazovce Chyby během instalace nebo Instalace byla zrušena.

    Pokud jste vyzváni, abyste zadali zdroj souboru a neměníte stávající instalaci SolidWorks, instalace nebo váš počítač je možná poškozen. Obraťte se na prodejce SolidWorks.

  2. Restartujte počítač.
  3. Aby jste se ujistili, že nejsou spuštěny žádné produkty SolidWorks, stiskněte ve Windows klávesy Ctr+Alt+Del a otevře se Správce úloh.
  4. Na záložce Procesy, pokud se jakékoliv následující procesy objeví pod položkou Název procesu, vyberte je a klepněte na Ukončit proces.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Pokud je program již nainstalován a snažíte se ho změnit, nebo odstranit, zkuste opravit instalaci. Podrobnosti najdete v Oprava instalace.
  6. V systému Windows Vista nebo novějším klepněte na Start > Ovládací panely > Programy a funkce. V dřívějších verzích systému Windows klepněte na Start > Ovládací panely > Přidat nebo odebrat programy.
  7. Vyberte verzi programu SolidWorks, která selhala.

    Pokud pro verzi SolidWorks, kterou se snažíte nainstalovat, neexistuje žádná položka, zopakujte instalaci.

  8. Proveďte jeden z následujících úkonů:
    • Chcete-li instalaci zopakovat, klepněte na Změnit a vyberte všechny produkty, které během instalace selhaly, nebo byly přeskočeny.

    • Chcete-li přeskočit instalaci, která selhala, klepněte na Změnit a vyberte všechny produkty, které během instalace selhaly. Zrušte výběr produktů, které se nepodařilo nainstalovat.

    • Chcete-li instalaci přerušit, klepněte na Odstranit a vyberte produkty, které byly nainstalovány.

    Tímto se neobnoví předchozí verze produktů, u které jste chtěli provést upgrade.

Nadřazené téma: Chyby během instalace / Instalace byla zrušena


Kontaktování prodejce SolidWorks

Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SolidWorks a poskytněte jim informace z této obrazovky. Možná, že také budou potřebovat komprimovanou složku souborů protokolu Manažera instalací SolidWorks.

  1. Vyhledejte soubory protokolu:
    • Pro verze operačního systému Windows před Windows Vista:

      C:\Documents and Settings\uživatelské jméno\Application Data\SolidWorks\Installation Logs\nainstalovaná_verze\

    • Pro Windows Vista nebo novější operační systémy:

      C:\Users\uživatelské jméno\AppData\Roaming\SolidWorks\Installation Logs\nainstalovaná_verze\

    Pokud složku nemůžete najít, může být skryta. V Průzkumníku Windows klepněte na Nástroje > Možnosti složky. Na záložce Zobrazení, pod položkou Upřesnit nastavení, vyberte Zobrazovat skryté soubory a složky pro Skryté soubory a složky.

  2. Komprimujte veškerý obsah této složky včetně podsložek.
Nadřazené téma: Chyby během instalace / Instalace byla zrušena


Instalace je dokončena

Manažer instalací SolidWorks dokončil proces instalace.

Jedna nebo více těchto možností se zobrazí.

Co je nového

V případě individuálních instalací se po dokončení instalace zobrazí příručka popisující nové funkce v programu SolidWorks a v jeho doplňkových modulech.

V případě instalací administrativní kopie se tato příručka zobrazí na klientských počítačích po dokončení jejich instalací.

Průzkum

Zašlete nám váš názor na instalační proces prostřednictvím krátkého průzkumu.

Zúčastněte se programu na zlepšení zkušeností SolidWorks zákazníka

Informace o výkonu jsou zasílány společnosti SolidWorks Corporation ke zlepšení programu. Tento proces je transparentní a důvěrný. Vyberte jednu z následujících možností:
  • Ano, chci se účastnit
  • Ne, děkuji
  • Připomenout později
Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Administrativní kopie byla dokončena

Po dokončení vytváření administrativní kopie, můžete klepnutím na Přizpůsobit kopii spustit Editor možností administrativní kopie a upravit ji.

Klepnutím na Zobrazit návod, jak instalovat kopii na klientském počítači. se zobrazí návod na používání Editoru možností.

Detaily o konfiguraci administrativní kopie za použití Editora možností, viz Editor možností administrativní kopie.

Klepnutím na Přizpůsobit kopii spustíte Editor možností administrativní kopie, v němž můžete upravit nastavení možností pro danou administrativní kopii.
Editor možností můžete spustit později poklepáním na sldAdminOptionEditor.exe v instalačním adresáři administrativní kopie.
  • Zjistit aktualizace SolidWorks
    Pro kontrolu aktualizací ručně nebo pro konfiguraci automatické kontroly aktualizací můžete použít Manažera instalací SolidWorks.
  • Program na zlepšení zkušeností zákazníků SolidWorks
    Při instalaci SolidWorks můžete zadat, že se mají odesílat společnosti SolidWorks Corporation informace o výkonu za účelem vylepšení produktu.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Zjistit aktualizace SolidWorks

Pro kontrolu aktualizací ručně nebo pro konfiguraci automatické kontroly aktualizací můžete použít Manažera instalací SolidWorks.

  1. Spusťte Manažera instalací SolidWorks jedním z následujících způsobů:

    • V programu SolidWorks klepněte na Nápověda > Zjistit aktualizace.

    • V systému Windows klepněte na Start > Programy > Manažer instalací SolidWorks > Zjistit aktualizace.

    Manažer instalací SolidWorks vám sdělí, jestli jsou aktuálně nějaké aktualizace k dispozici.

  2. Pokud existují nějaké aktualizace, zvolte zda je chcete stáhnout a nainstalovat.
  3. Pokud chcete umožnit automatické pravidelné kontroly aktualizací, zvolte poté, když Manažer instalací SolidWorks dokončí proces, Kontrolovat aktualizace každých ___ dní a určete frekvenci kontrol.
Nadřazené téma: Instalace je dokončena


Program na zlepšení zkušeností zákazníků SolidWorks

Při instalaci SolidWorks můžete zadat, že se mají odesílat společnosti SolidWorks Corporation informace o výkonu za účelem vylepšení produktu.

SolidWorks používá tyto informace k určení trendů týkajících se používání produktu a jeho kvality. Naším cílem je poskytovat produkt nejlepší kvality a soubory protokolu o výkonu jsou velmi užitečným nástrojem v tomto procesu.

Tento proces je transparentní. Všechny informace obsažené v těchto souborech protokolu jsou zpracovávány důvěrně. Tyto soubory neslouží k jiným účelům a nikdo vás nebude kontaktovat.

Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Nadřazené téma: Instalace je dokončena


Umístění instalace

Určete umístění instalace SolidWorks.

Pro instalace kromě vytvoření administrativní kopie tyto možnosti zahrnují:
Nainstalovat vybrané produkty do
Toto je umístění adresáře, do kterého instalujete SolidWorks.
Když provádíte upgrade nebo měníte instalaci, všechny soubory musí být nainstalovány do existujícího místa pro tuto instalaci. V tomto případě nemůžete změnit místo stávající instalace SolidWorks.
Odhadované místo na disku požadované pro instalaci
Toto je doplňkové místo na disku potřebné pro instalaci nebo změnu vybraných součástí.
Ověřte, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Instalovat z
Toto je umístění adresáře, ze kterého instalujete SolidWorks.
Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti najdete v Možnosti stažení.
Kontaktujte správce systému než změníte umístění instalace SolidWorks.

Umístění administrativní kopie

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie
Toto je umístění adresáře, ve kterém Manažer instalací SolidWorks vytvoří novou kopii.
Toto umístění nemůže obsahovat existující administrativní kopii.
Odhadované místo na disku požadované pro vytvoření kopie
Toto je doplňkové místo požadované pro administrativní kopii.
Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z:
Toto je umístění adresáře, ze kterého instalujete produkty SolidWorks.
Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti najdete v Možnosti stažení.
Umístění stávající kopie
Když provádíte upgrade administrativní kopie, Manažer instalace SolidWorks vytvoří novou kopii založenou na nastaveních pro tuto existující kopii. Tato existující kopie se nemění. To ukazuje umístění původní kopie, kterou jste určili na obrazovce Uvítání.

Zabránění použití cest adresáře specifických pro verzi

Pokud určujete číslo verze v umístění adresáře instalace (například C:\Program Files\SolidWorks Corp\SolidWorks 2010\), a pak provádíte upgrade této instalace na SolidWorks 2011, budete mít adresář instalace SolidWorks 2011, který je označen jako SolidWorks 2010.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Možnosti upgradu

Na tomto počítači je nainstalována jedna nebo více starších hlavních verzí SolidWorks. Vyberte, jestli provedete upgrade poslední existující verze na novou verzi nebo vytvoříte novou instalaci pro novou verzi.

Tato možnost se objeví pouze tehdy, když není žádná předchozí verze této hlavní finální verze instalována na tomto počítači. Pokud je instalována předchozí finální hlavní verze, Manažer instalací SolidWorks vždy aktualizuje tuto instalaci.

(Když začnete v SolidWorks 2010, paralelní instalace více verzí aktualizací Service Pack stejné hlavní finální verze už nejsou podporovány.)

Když provádíte upgrade:
  • U všech určených produktů byl proveden upgrade.
  • Všechny instalované produkty jsou standardně vybrány .
  • Pokud produkt odeberete, na tomto produktu se již neprovede upgrade.
    Pokud odeberete součást produktu, neurčujete, že tento Manažer instalace SolidWorks odstraní tuto součást. Pro zobrazení součásti produktu použijte Přidat nebo odebrat programy jak je popsáno pod Odstranění instalace.

Vyberte vhodnou možnost a klepněte na Další pro pokračování.

Vytvořit novou instalaci SolidWorks verze.

Pokud si zvolíte tuto možnost, zůstane starší verze instalace zachována navíc k vytvořené nové instalaci této hlavní verze.

To může být užitečné především tehdy, pokud chcete mít přístup ke starší verzi SolidWorks i poté, kdy byla nainstalována novější verze. Pokud například sdílíte soubory s jinými uživateli, kteří stále používají starší verzi, můžete tak zabránit problému s kompatibilitou se soubory, uloženými s použitím novější verze.

Upgrade SolidWorks předchozí_hlavní_verze na SolidWorks aktuální_hlavní_verze.

Pokud vyberete tuto možnost, provede se upgrade starší verze instalace na novou verzi.
Jakmile je instalace kompletní, starší verze SolidWorks už nebude na tomto počítači k dispozici.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Průběh instalace

Tato obrazovka uvádí průběh instalace.

Chcete-li v průběhu zrušit instalaci, klepněte na Storno.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací, najdete na odkaze Chyby během instalace.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Typ instalace

Určete operaci instalace, kterou chcete spustit, jako je vytvoření nové instalace, úprava nebo oprava existující instalace, vytvoření administrativní kopie, instalace administrativních produktů serveru nebo stažení souborů bez instalace.

Individuální

Nainstaluje produkty SolidWorks na tento počítač.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.

Změnit individuální instalaci

Změnit stávající instalaci SolidWorks na tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.
Změny zahrnují:
  • Přidání nebo odebrání součástí produktu SolidWorks.
  • Změna na různé balíčky SolidWorks (například SolidWorks Professional, SolidWorks Premium atd.)
  • Změny nastavení sériového čísla Solidworks
    Pokud jste již zadali sériové číslo SolidWorks během předchozí instalace, Manažer instalací SolidWorks vás k tomu již nevyzve. Pro změnu sériového čísla, které předpokládá Manažer instalací SolidWorks, musíte vybrat tuto možnost.

Opravit individuální instalaci

Oprava stávající instalace SolidWorks na tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.
Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.
Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte ji znovu nainstalovat za použití nové administrativní kopie.

Administrativní kopie

Na tomto počítači vytvořte nebo aktualizujte administrativní kopii.

Můžete použít administrativní kopii pro instalaci na více počítačích. Podrobnosti o instalaci SolidWorks u více klientů za použití administrativních kopií, viz Použití administrativní kopie.

Když vytváříte nebo aktualizujete administrativní kopie:
  • Můžete použít nastavení instalací z existující kopie pro konfiguraci nové nebo aktualizované kopie nebo můžete použít výchozí nastavení instalace SolidWorks.
  • Pokud aktualizujete existující kopii:
    • Manažer instalací SolidWorks vytvoří novou kopii kopie, dokonce i pokud aktualizujete. Původní kopie se nemění.
    • Můžete vytvořit nebo aktualizovat kopii za použití souborů z existující kopie, kterou aktualizujete. Výsledkem je menší stažení.
    Pokud neurčíte kopii, pro kterou je k dispozici verze servisního balíčku pro aktualizaci předchozí kopie, nemůžete využít předností menšího stahování.
  • Na tomto počítači můžete vytvořit 32bitovou a 64bitovou administrativní kopii. Jinak se vytvoří jen kopie, která odpovídá architektuře hardwaru tohoto počítače.
    Pokud zadáte vytvoření obou kopií 32bitová a 64bitové, bude k dokončení instalace zapotřebí SolidWorks instalační médium pro obě architektury.

Produkty pro servery

Administrativní produkty serveru SolidWorks zahrnují SolidWorks Workgroup PDM Server (úschovna) a Manažer licencí SolidNetWork.

Podrobné informace o těchto produktech viz:
  • Workgroup PDM
  • Správa licencí za použití manažera licencí SolidNetWork

Pouze stáhnout

Stáhnout soubory instalací pro vybrané produkty SolidWorks bez jejich instalace.

Tato možnost není k dispozici, když instalujete z DVD.

Obsah stažených souborů je stejný jako souborů, které jsou k dispozici na instalačním DVD SolidWorks. Pokud vyberete tuto možnost, stáhne se plná sada instalačních souborů bez ohledu na to, které soubory již případně byly nainstalovány na vašem počítači.

Tento způsob je vhodný pro nastavení serveru, ze kterého mohou uživatelé provádět instalace. Tento způsob se liší od vytvoření administrativní kopie.

Instalování chybné SolidWorks architektury na tomto počítači

Pokud se snažíte provést instalaci pomocí chybného instalačního média pro architekturu tohoto počítače, (například, pokud instalujete 64bitový program SolidWorks na 32bitový počítač), měl by instalační panel nahlásit tento problém.

Pokračování v instalaci:
  1. Zrušte tuto relaci Manažera instalací SolidWorks.
  2. Zkontrolujte architekturu a systémové požadavky tohoto počítače.
  3. Znovu proveďte instalaci se správným instalačním médiem programu SolidWorks pro architekturu tohoto počítače.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Ruční stahování

Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SolidWorks).

Klepněte na odkaz pro otevření automaticky generované webové stránky, která obsahuje kompletní seznam souborů, které potřebujete ke stažení.

Musíte je stáhnout do složky určené na stránce Souhrn. Instalace nemůže začít dokud nejsou všechny soubory stažené do této složky.

Jakmile jste dokončili ruční stahování, klepněte na Další pro pokračování.

Pokud chcete provést stahování automaticky, můžete změnit možnost návratem na stránku Souhrn a změnou možnosti stažení.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


K dispozici je novější verze

Manažer instalací zaznamenal novější verzi produktů SolidWorks. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.

Instalace z DVD

Pod Chcete používat novější verzi?, vyberte následující:
  • Ne, pokračovat v instalaciversion z DVD. Je možné aktualizovat s menším stažením.

    Vyberte tuto možnost, pokud chcete pokračovat v instalaci prostřednictvím stávajícího Manažera instalací.

    Po dokončení instalace můžete zkontrolovat a nainstalovat aktualizace pomocí Manažera instalací. Chcete-li zjistit aktualizace, spusťte z nabídkyStart > Manažer instalací SolidWorks > Zjistit aktualizace.

    Výhodou této možnosti je, že stažení je menší. Nevýhodou je, že se jedná o dvou stupňový proces a stažené soubory jsou specifické pro určitou verzi (a nelze je sdílet s ostatními uživateli, kteří používají jiné verze).

  • Ano, provést instalaci pomocí tohoto DVD, pak stáhnout a aktualizovat naversion.

    Tato možnost slouží ke stažení a spuštění starší verze Manažera instalací, aby bylo možné nainstalovat produkty SolidWorks pro tuto verzi.

    Pokud je pro aktualizací verze DVD k dispozici malá verze servisního balíčku, Manažer instalací nejprve nainstaluje původní verzi z DVD a pak použije aktualizaci servisního balíčku. Výsledkem je menší stažení.

    Můžete dosáhnout stejného výsledku výběrem možnosti pokračovat v instalaci z DVD a pak později použít aktualizaci.

    Výhodou této možnosti je, že jde o jednorázový postup.

Ve většině případů je preferována instalace plné verzi z DVD a poté zjištění a instalace aktualizací pomocí Manažera instalací, protože tato možnost vyžaduje menší stažení.

Instalace ze stažení

Vyberte jednu z následujících možností:
  • Pokračovat v instalaci version.

    Vyberte tuto možnost a pokračujte v instalaci verze obsažené v počátečním stažení.

  • Stáhnout a nainstalovat novou verzi: version

    Vyberte tuto možnost, stáhněte novou verzi a nainstalujte ji. Pokud je k dispozici několik nových verzí, můžete vybrat verzi ke stažení a nainstalovat ji.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Zjištěné procesy

Manažer instalací SolidWorks zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.

  • Pro pokračování v instalaci proveďte jednu z následujících možností:
    • Ukončete tyto procesy (například za použití Správce úloh Microsoft Windows) a pak stiskněte Opakovat.
    • Klepněte na Ignorovat a pokračujte bez uzavření procesů.
  • Pro zastavení instalace stiskněte Storno.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Výběr produktu

Určete součásti produktu, které chcete nainstalovat, upravit nebo odebrat.

V seznamu produktů:
  • Seznam produktů je kompletní seznam, který je k dispozici v balíčku určeném nad seznamem produktů.
  • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klepněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
  • Chcete-li změnit akci instalace pro danou součást, můžete klepnout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
  • Pokud provádíte instalaci Úpravy, nalevo od součástí se objeví (*), když provedete jakoukoliv změnu u vybraného produktu.
  • Pokud součást zahrnuje volitelné dílčí součásti pro instalaci, objeví se vedle součásti ikona + . Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu + .
  • Pokud jste rozbalili součást tak, aby se u ní zobrazily volitelné dílčí součásti, zobrazí se vedle součásti ikona - . Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu - .

Pokud používáte servisní balíček, funkce SolidWorks, které se zobrazují pod položkou SolidWorks (například FeatureWorks), nelze vybrat. Pokud vyberete tento typ upgradu, není možné přidat nebo odstranit jednotlivé funkce.

Akce provedené Manažerem instalací SolidWorks jsou ovládané sadou pravidel koexistence produktu Podrobnosti najdete v Pravidla koexistence produktu.

Manažer instalací SolidWorks vybere standardně tyto součásti produktu:
  • Pokud provádíte upgrade servisního balíčku, Manažer instalací SolidWorks zvolí produkty, které jsou právě instalovány.
  • Jinak Manažer instalací SolidWorks vybere všechny produkty, ke kterým máte oprávnění.
Pro snížení času ke stažení a požadavků na místo na disku, rozbalte součásti produktu a u součástí, které nepotřebujete zrušte zaškrtnutí políčka.

Pokud Manažer instalací SolidWorks nebyl schopen ověřit produkty, které jste oprávněni používat, můžete klepnout na Vybrat jiný balíček nebo produkty, a změnit tak balíček produktů (jako například SolidWorks Professional nebo SolidWorks Premium), které jsou uvedeny v seznamu k instalaci nebo změně. Manažer instalací SolidWorks zobrazí seznam všech produktů SolidWorks na vašem instalačním médiu, jež jsou kompatibilní s vybranou sadou. Můžete vybrat jakékoliv produkty, které jste zakoupili nebo jste oprávněni hodnotit.

SolidWorks vyhledávání

SolidWorks vyhledávání poskytuje výkonné fulltextové vyhledávání dokumentů SolidWorks, dokumentů v úschovně PDM Workgroup a v 3D ContentCentral. Vyhledávání zobrazí náhled, umístění souborů a název.

Po dokončení instalace, SolidWorks vyhledávání indexuje dokumenty SolidWorks pro rychlejší vyhledávání. Pouze soubory SolidWorks jsou indexovány automaticky.

Instalace SolidWorks vyhledávání automaticky nainstaluje Windows Desktop Search, pokud ještě není nainstalován na vašem počítači.

Jazyková podpora

Rozbalením součásti produktu SolidWorks a položky Jazyky se zobrazí jazyky, které lze nainstalovat.

Specifikace Jazyky omezuje jazyky, které jsou naistalovány jen pro produkt SolidWorks. Toto nastavení nemá vliv na instalace ostatních produktů. Například SolidWorks eDrawings®, SolidWorks Workgroup PDM a SolidWorks Explorer jsou nainstalovány ve všech jazycích.

Potřebné místo na disku

Manažer instalací SolidWorks dole na stránce hlásí buď celkovou velikost instalace, nebo celkovou velikost stažení.

  • Pokud jste vybrali možnost Pouze stáhnout, objeví se velikost stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.
    V celkové velikosti stažení jsou zahrnuty všechny soubory potřebné k instalaci. Nebudou znovu staženy soubory, které jsou již obsaženy v aktuální složce pro stažení. To znamená, že velikost stažení může být menší než zobrazená celková velikost stažení, nebo nebudete muset stáhnout žádné soubory.
  • Jinak se zobrazí velikost instalace. Velikost instalace se rovná změně ve využití místa na disku, ke kterému dojde po dokončení instalace. V důsledku komprimace souboru se jedná pouze o odhady.

    Pokud upgradujete, nebo odstraňujete stávající instalaci, může se velikost instalace rovnat nule.

    Zobrazené číslo nezahrnuje místo potřebné ke stažení, nebo k extrahování souborů požadovaných k instalaci.

    Pokud je vyžadováno stažení a stahujete do stejné jednotky, mohou být požadavky na místo na disku daleko větší než je uvedená velikost instalace.

    Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Produkty ke stažení

Vyberte produkty SolidWorks, které se mají stáhnout do určitého umístění.

V závislosti na zadaném sériovém čísle se zobrazí odpovídající produkty ke stažení:

  • Operace, která má být provedena pro každou součást, se zobrazí na pravé straně.
  • Pokud součást zahrnuje volitelné dílčí součásti pro instalaci, objeví se vedle součásti ikona + . Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu + .
  • Pokud jste rozbalili součást tak, aby se u ní zobrazily volitelné dílčí součásti, zobrazí se vedle součásti ikona - . Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu - .
  • Klepnutím na ikonu umístěnou vlevo od součásti, vyberte způsob jakým ji Manažer instalací SolidWorks má zpracovat.
Pokud neurčíte jinak, Manažer instalací SolidWorks stáhne všechny součásti produktu, ke kterým máte oprávnění. Pro zkrácení doby stahování a zmenšení požadovaného místa na disku rozbalte součásti produktu a vyberte součásti, které nepotřebujete.

Pokud Manažer instalací SolidWorks nebyl schopen ověřit produkty, které jste oprávnění používat, můžete vybrat balík SolidWorks a provést instalaci. Manažer instalací SolidWorks zobrazí seznam všech produktů SolidWorks, jež jsou kompatibilní s vybranou sadou SolidWorks.

Pokud Manažer instalací SolidWorks nebyl schopen ověřit produkty, které jste oprávněni používat, můžete klepnout na Vybrat jiný balíček nebo produkty, a změnit tak balíček produktů (jako například SolidWorks Professional nebo SolidWorks Premium), které jsou uvedeny v seznamu k instalaci nebo změně. Manažer instalací SolidWorks zobrazí seznam všech produktů SolidWorks na vašem instalačním médiu, jež jsou kompatibilní s vybranou sadou. Můžete vybrat jakékoliv produkty, které jste zakoupili nebo jste oprávněni hodnotit.

Jazyková podpora

Nastavení Jazyky omezuje výběr jazyků, které jsou nainstalovány jen pro produkt SolidWorks. Toto nastavení nemá vliv na instalace ostatních produktů. Například SolidWorks eDrawings®, SolidWorks Workgroup PDM a SolidWorks Explorer jsou nainstalovány ve všech jazycích.

Potřebné místo na disku

V závislosti na vybraném produktu se zobrazí požadované místo ke stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.

Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Produkty k opravě

Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SolidWorks spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SolidWorks.

Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.

Klepnutím na Opravit zahájíte opravu vybraných produktů.

Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte znovu nainstalovat administrativní kopii.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Sériová čísla

Sériová čísla, která se nacházejí na balení, přiřazují zakoupené produkty SolidWorks k vašemu počítači.

Pokud jsou na vašem počítači již nainstalované produkty SolidWorks, budou jejich sériová čísla automaticky zobrazena.
  • Zadejte sériové číslo pro SolidWorks, pokud ještě není zobrazeno.
  • Pokud máte sériová čísla pro produkty, které ještě nebyly zahrnuty do vaší licence SolidWorks, klepněte na produkt pod Máte jiná sériová čísla? a zadejte sériové číslo tohoto produktu.

Pokud máte připojení k internetu, budou sériová čísla během instalace použita k zobrazení produktů, ke kterým máte oprávnění, abyste mohli vybrat produkty k instalaci.

Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SolidWorks. Například sériové číslo SolidWorks vám umožní nainstalovat SolidWorks Simulation bez zadání sériového čísla SolidWorks Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoliv dotazy ohledně sériových čísel, kontaktujte místního prodejce.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Instalace serveru

Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.

Stav instalace serveru

Instalace produktů serveru se provádějí pomocí externí instalační aplikace. Pokud se právě v této aplikace nenacházíte, musíte na ni přepnout, abyste instalaci dokončili.

Klepněte na Storno pro ukončení instalace produktů serveru.

Instalace serveru byla dokončena

Externí instalační aplikace byla úspěšně dokončena.

Klepněte na Dokončit nebo na Další.
  • Pokud instalujete jiné administrativní produkty (například administrativní kopii SolidWorks ), tato instalace pokračuje.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SolidWorks se zavře.

Instalace serveru byla zrušena nebo se nepodařila

Pokud se instalace serveru nepodařila nebo byla zrušena, na seznamu budou uvedeny servery, které nebyly nainstalovány.

Klepněte na Zavřít nebo na Další.
  • Pokud určujete jiné administrativní instalace produktů, Manažer instalací SolidWorks se obnoví.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SolidWorks se zavře.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Manažer licencí SolidNetWork

Zadejte instalační volby pro produkt pro server Manažer licencí SolidNetWork.

Sériová čísla

Zadejte sériová čísla licence SolidNetWork. Můžete zadat více sériových čísel a oddělit je čárkami.
Sériová čísla SolidNetWork jsou odlišná od sériových čísel SolidWorks.

Umístění instalace

Určete umístění instalace pro Manažera licencí SolidNetWork.

Pokud aktualizujete stávajícího Manažera licencí SolidNetWork, musíte jej nainstalovat do stávajícího umístění pro instalaci.

Pro více informací

Více informací o instalaci, konfiguraci a používání Manažera licencí SolidNetWork viz Správa licencí za použití manažera licencí SolidNetWork.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Souhrnné informace

Manažer instalací SolidWorks má všechny potřebné informace pro dokončení instalace.

Chcete-li pokračovat: | Klepněte na tlačítko akce Nyní pro zahájení instalace (například Instalovat nyní, Vytvořit nyní, Stáhnout nyní, Upravit nyní).
Postup při změně nastavení instalace: | Klepněte na ZMĚNA [image] pro část, kterou chcete změnit (například Produkty, Umístění instalace, Možnosti Toolbox).
Pro zrušení: | klepněte na Storno [image] pro ukončení Manažera instalací SolidWorks bez změny součástí instalace.
Pokud se chcete vrátit na předchozí stránku: | Klepněte na Zpět [image] pro návrat k předchozí stránce v Manažeru instalací SolidWorks.
Další informace o zvláštní sadě možností instalace (například Produkty, Umístění instalace, Možnosti Toolbox , atd.):
  1. klepněte na ZMĚNA [image] vedle části, pro kterou potřebujete informace.
  2. Na podrobné stránce, která se objeví, klepněte na Nápověda [image] pro získání informací o nastaveních možnosti instalace.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Upozornění kontroly systému

Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SolidWorks.

Níže jsou uvedena varování, s nimiž se můžete v této fázi setkat, spolu s doporučením, jak pokračovat.

Problém s ověřením sériového čísla
Manažer instalací nezjistil nové verze, protože nemohl ověřit vaše sériové číslo. Pokud jste připojeni a zadali jste platné sériové číslo, může se jednat o dočasný problém na našem serveru. Zkuste to znovu později.

Ověření sériového čísla: Manažer instalací nemohl ověřit vaše sériové číslo, a tím určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. K instalaci budete muset poskytnout kompletní sadu zdrojových souborů nebo DVD.

Řešení:
  • Zkontrolujte připojení k internetu. Kontrola sériového čísla vyžaduje platné internetové připojení.
  • Zkontrolujte, zda vámi zadané sériové číslo je platné pro produkty, které chcete instalovat.
  • Některé instalace vyžadují, abyste měli v době vydání příslušné verze aktivní předplatitelskou službu., Podrobnosti vám sdělí váš prodejce SolidWorks.
  • Ve většině případů můžete pokračovat v instalaci, za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.
Dostupná novější verze
Dostupná novější verze

Jsou k dispozici novější verze.

Novější verze tohoto produktu je k dispozici pro stažení.

Řešení: Když se provádí operace Zjistit aktualizace, instalace může zobrazit výzvu k instalaci novější verze, která je k dispozici ke stažení ze SolidWorks. V této operaci můžete pokračovat s použitím verze, kterou jste na počátku specifikovali, nebo můžete stáhnout tuto novější verzi a pokračovat v operaci s použitím této verze.

Nejnovější dostupná verze
Toto je nejnovější dostupná verze. Pokračujte klepnutím na Další.

Žádná nová stažení

Řešení: Tato zpráva se může objevit, když kontrolujete aktualizace během instalace nebo změny. Informuje o tom, že právě instalujete (nebo jste nainstalovali) nejnovější dostupnou verzi.

Problémy s internetovým připojením
Internetové připojení: Manažer instalací se nemohl připojit k serveru SolidWorks a určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. Bude potřeba poskytnout zdrojové soubory na DVD nebo z dříve stažené sady souborů.

Nepodařilo se zjistit nové verze

Manažer instalací nezjistil nové verze, protože se nemohl připojit k serveru.

Řešení:
  • Zkontrolujte připojení k internetu.
  • Můžete pokračovat v instalaci za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Možnosti Průvodce dírami/Toolbox

Pokud je Toolbox SolidWorks instalován, SolidWorks obsahuje knihovnu standardních typů děr stejně jako hardware.

Klepněte na Nápověda > Nápověda Toolbox v SolidWorks, pokud se chcete dozvědět podrobnosti o konfiguraci, rozšíření a použití SolidWorks Toolbox.
Pro zobrazení této nápovědy můžete nastartovat doplňkový modul Toolbox pomocí Nástroje > Doplňkové moduly.

Než začnete používat SolidWorks Toolbox, ujistěte se, že je správně nakonfigurovaný podle zásad vaší společnosti nebo skupiny. V mnoha případech se bude konfigurovat skupina a centrální Toolbox se zachová. Konzultujte s administrátorem SolidWorks informace, jak specifikovat Toolbox během instalace SolidWorks.

Zvolený SolidWorks Toolbox můžete po instalaci změnit. V SolidWorks klepněte na Nástroje > Možnosti. Na záložce Možnosti systému klepněte na Průvodce dírami/Toolbox.

Následující sekce popisuje všechny možnosti, se kterými se můžete setkat na této obrazovce pro všechny konfigurace. Aktuální možnosti Toolbox, které vidíte, závisejí na předchozích konfiguracích SolidWorks a Toolbox na tomto počítači a možnostech Manažeru instalací SolidWorks, které jste v tomto bodě určili.

Vytvořit nový Toolbox nová-verze

Vytvořte novou verzi SolidWorks Toolbox na tomto počítači.

Při vytváření nové verze rozbalte na obrazovce Výběr produktu SolidWorks > SolidWorks Toolbox a vyberte, které normy bude Toolbox podporovat. Všechny normy jsou standardně vybrány.

Jakékoliv již stávající Toolboxy na tomto počítači se nezmění.

Vytvořit odkaz nebo provést upgrade u stávajícího Toolbox

Použít stávající Toolbox Klepněte na Procházet pro určení místa Toolbox, který chcete použít s touto instalací.

  • Pokud je Toolbox konfigurován pro předchozí hlavní finální verzi SolidWorks, provede se upgrade na tuto verzi. Jakékoliv přizpůsobení provedené na tomto Toolbox je v upgradovaném Toolbox zachováno.
    Pokud provedete upgrade Toolbox na novou hlavní finální verzi SolidWorks, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SolidWorks .
  • Pokud je Toolbox konfigurován pro tuto verzi SolidWorks (což může být v případě, že jste určili sdílenou síť Toolbox, u které byl již proveden upgrade), na tomto Toolbox se upgrade neprovede.
  • Pokud provádíte upgrade na Toolbox v prostředí Enterprise PDM, je nutno provést další postupy. Podrobnosti najdete v Provedení upgrade v prostředí SolidWorks Enterprise PDM.

Tato možnost se objeví ve všech instalačních scénářích kromě vytvoření administrativní kopie.

Provést upgrade Toolbox předchozí-verze

Nakopírujte Toolbox konfigurovaný pro předchozí hlavní verzi do nového umístění a proveďte upgrade této kopie na tuto verzi.

Tato možnost se objeví, pokud je předchozí hlavní verze SolidWorks instalována na tomto počítači, ale vy jste se rozhodli, že u této instalace na tuto verzi upgrade neprovedete.
Účelem této možnosti je provést upgrade Toolbox pro předchozí hlavní verzi SolidWorks, která je instalována, aniž by to mělo dopad na uživatele starší verze Toolbox.

Pokud provádíte upgrade na Toolbox v prostředí Enterprise PDM, je nutno provést další postupy. Podrobnosti najdete v Provedení upgrade v prostředí SolidWorks Enterprise PDM.

Provést upgrade tohoto nainstalovaného Toolbox předchozí-verze

Proveďte upgrade tohoto Toolbox na novější verzi.
Pokud provedete upgrade Toolbox na novou hlavní finální verzi SolidWorks, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SolidWorks .

Tato možnost se objeví, pokud provádíte upgrade předchozí hlavní verze SolidWorks na tuto verzi a na počítači je nalezen Toolbox konfigurovaný pro tuto verzi.

Pokud provádíte upgrade na Toolbox v prostředí Enterprise PDM, je nutno provést další postupy. Podrobnosti najdete v Provedení upgrade v prostředí SolidWorks Enterprise PDM.

Použít nainstalovaný Toolbox aktuální-verze

Manažer instalací SolidWorks zjistil na tomto počítači Toolbox konfigurovaný pro tuto hlavní verzi SolidWorks.

Pokud vyberete tuto možnost, SolidWorks tento Toolbox použije. Nedojde k žádnému upgrade.

Tato možnost se objeví, pokud je předchozí hlavní verze SolidWorks instalována na tomto počítači, ale Toolbox je konfigurován pro tuto verzi. K tomu může dojít, pokud je Toobox vytvořen na počítači, na kterém stále běží starší verze SolidWorks.

Zadat umístění Toolbox pro klientský počítač

Určete síť nebo adresář jako výchozí umístění Toolbox, pokud klienti instalují z administrativní kopie.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SolidWorks v době, kdy dochází ke klientské instalaci, Manažer instalací SolidWorks provede upgrade tohoto Toolbox.

Tato možnost se objeví, pokud vytváříte novou administrativní kopii.

Proveďte upgrade nebo použijte Toolbox, na nějž se odkazuje ve stávající kopii pro klientský počítač

Použijte umístění Toolbox určené ve stávající administrativní kopii, kterou jste aktualizovali.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SolidWorks v době, kdy dochází ke klientské instalaci, Manažer instalací SolidWorks provede upgrade tohoto Toolbox.

Výběr jiného umístění Toolbox pro klientský počítač

Určete jiné umístění Toolbox určené ve stávající administrativní kopii, kterou jste aktualizovali.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SolidWorks v době, kdy dochází ke klientské instalaci, Manažer instalací SolidWorks provede upgrade tohoto Toolbox.
  • Upozornění ke konfiguraci SolidWorks Toolbox
    SolidWorks Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolbox za použití Manažera instalací.
  • Formát UNC
    Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Upozornění ke konfiguraci SolidWorks Toolbox

SolidWorks Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolbox za použití Manažera instalací.

Zdroje dodatečných informací o SolidWorks Toolbox

Klepněte na Nápověda > Nápověda Toolbox v SolidWorks, pokud se chcete dozvědět podrobnosti o konfiguraci, rozšíření a použití SolidWorks Toolbox.
Pro zobrazení této nápovědy můžete nastartovat doplňkový modul Toolbox pomocí Nástroje > Doplňkové moduly.

Použití sdíleného Toolbox

Když instalujete Toolbox, můžete mít data Toolbox na lokálním počítači nebo na sdíleném místě na síti. Doporučujeme uložení dat Toolbox na síti. Když použijete společné místo, všichni uživatelé SolidWorks používají společně konzistentní sadu informací o šroubech.

Pokud je to první instalace, přejděte k nově sdílenému umístění, kam chcete provést instalaci Toolbox.

Provedení upgrade existujícího Toolbox

Pokud provedete upgrade Toolbox na novou hlavní finální verzi SolidWorks, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SolidWorks .

Pokud na jiných počítačích zůstane tato předchozí finální verze a dále budou vyžadovat, aby byl Toolbox konfigurován na tuto verzi, zhotovte kopii tohoto Toolbox a u této kopie proveďte upgrade. Nová instalace SolidWorks provede upgrade nových souborů a předchozí instalace SolidWorks bude nadále používat starý Toolbox.

Konfigurace přístupu do Toolbox

Když po instalaci máte přístup k součástem Toolbox, SolidWorks kontroluje, jak jste nakonfigurovali Toolbox a navrhuje zlepšení přístupu a výkonu.

Pro přístup ke sdílené síti Toolbox (doporučeno) použijte cestu UNC k serveru, na kterém je instalován sdílený Toolbox. Podrobnosti najdete v Formát UNC.

Správce může vytvořit heslo pro Toolbox a nastavit oprávnění a předvolby pro pracovní skupinu. Omezení přístupu ke konfiguraci a nastavení všeobecných předvoleb zajišťuje konzistentní data Toolbox.

Provedení upgrade v prostředí SolidWorks Enterprise PDM

Než provedete upgrade první instalace SolidWorks, která má přístup do složky Toolbox v úschovně Enterprise PDM:
  1. V Průzkumníkovi Windows přejděte ke složce Toolbox v úschovně Enterprise PDM.
  2. Klepněte pravým tlačítkem na složku Toolbox a klepněte na Načíst nejnovější verzi.

    To umožňuje, aby Manažer instalace SolidWorks ověřil, jestli je nutno díly aktualizovat.

  3. Vyzvedněte složku Toolbox.

    Složka Toolbox musí být vyzvednut tak, že Manažer instalací SolidWorks může aktualizovat Toolbox.

  4. Po aktualizaci složku Toolbox odevzdejte.

U knihovny Toolbox v úschovně byl nyní proveden upgrade.

Pro následné upgrady SolidWorks musí klienti Enterprise PDM před zahájením upgrade načíst poslední verzi složky úschovny Toolbox (za použití Načíst poslední verzi). To umožňuje, aby Manažer instalace SolidWorks ověřil, jestli jsou tyto soubory aktuální.

Další detaily o konfiguraci Toolbox v SolidWorks Enterprise PDM najdete v tématu Konfigurace Toolbox v nápovědě Administrativního nástroje SolidWorks Enterprise PDM.

Nadřazené téma: Možnosti Průvodce dírami/Toolbox


Formát UNC

Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.

\\server\volume\path

Příklad:

\\Disk_Server\SolidWorks\AdminImage

Nadřazené téma: Možnosti Průvodce dírami/Toolbox


Odinstalování produktů

Zvolíte-li v Ovládacích panelech možnost Odstranit nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SolidWorks (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SolidWorks. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.

Při standardní odinstalaci budou odstraněny programové soubory a složky produktu SolidWorks. Ve výchozím nastavení jsou k odinstalování určeny všechny produkty SolidWorks pro vybranou verzi.

Při vlastní odinstalaci bude odstraněna jedna nebo více z následujících položek: programové soubory a složky, klíče registru a datové složky (např. SolidWorks Toolbox) a soubory a složky z původního umístění stažených dat.

Při úplné odinstalaci budou odstraněny instalační adresáře, klíče registru a datové složky.

Chcete-li odinstalovat produkt, postupujte takto:
  1. Zkontrolujte na obrazovce Odinstalace, zda je produkt vybrán.

    Pokud odinstalujete všechny produkty, bude odinstalován i Manažer instalací.

  2. Zrušte výběr produktů, které nechcete odstranit.

    Pokud zachováte kterýkoli produkt, Manažer instalací SolidWorks odinstalován nebude.

  3. Určete, zda se má provést vlastní nebo úplná odinstalace.
    1. Klepněte na možnost Změnit v části Upřesňující možnosti.

      Zobrazí se okno Upřesňující možnosti. Je zaškrtnuta možnost Programové soubory a složky.

    2. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
    3. Klepněte na Zpět na souhrnné informace.
    4. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.
  4. Klepněte na Odstranit položky [image].
Když klepnete na Odstranit položky, Manažer instalací SolidWorks začne okamžitě odstraňovat produkty.
Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Možnosti serveru Workgroup PDM

Zadejte instalační volby pro produkt pro server SolidWorks Workgroup PDM.

Umístění instalace

Zadejte instalační umístění pro produkty pro server SolidWorks Workgroup PDM.

Produkty k instalaci

Určete, které produkty pro server Workgroup PDM se mají instalovat:
Úschovna Workgroup PDM
Určete umístění pro data úschovny Workgroup PDM. Licence prohlížeče Workgroup PDM musí být nainstalována společně s úschovnou, aby bylo možné aktivovat Prohlížeč.
Prohlížeč Workgroup PDM
Při instalaci Prohlížeče Workgroup PDM musíte zadat název nebo IP adresu počítače s úschovnou Workgroup PDM, do níž bude Prohlížeč přistupovat.
Workgroup PDM API

Licence na Workgroup PDM API je zahrnuta v licencích pro klienty SolidWorks a klienty Průzkumníka. API pro odevzdávání vyžadují licence pro klienty.

Pro více informací

Detaily o instalaci Workgroup PDM viz Workgroup PDM.

Detaily o používání Workgroup PDM viz téma Workgroup PDM v Nápovědě SolidWorks.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Právní ustanovení

© 1995-2011, Dassault Systèmes SolidWorks Corporation, součást skupiny Dassault Systèmes S.A., 175 Wyman Street, Waltham, Mass. 02451 USA. Všechna práva vyhrazena.

Informace obsažené v tomto dokumentu a předmětný software se mohou bez předchozího upozornění změnit a neměly by proto být považovány za závazky společnosti Dassault Systemes SolidWorks Corporation (DS SolidWorks).

Žádný z materiálů nesmí být kopírován ani šířen v jakékoli podobě či jakýmkoli způsobem, elektronicky či ručně, bez výslovného písemného svolení společnosti DS SolidWorks.

Software, jehož se tento dokument týká, je šířen na základě licence a lze jej používat nebo kopírovat pouze v souladu s podmínkami licence. Veškeré záruky vztahující se k softwaru a dokumentaci k němu poskytnuté společností DS SolidWorks jsou upraveny v licenční smlouvě a žádné informace uvedené v tomto dokumentu nebo z něj vyplývající nesmí být považovány za změnu či doplnění těchto podmínek, včetně záruk v licenční smlouvě.

Patentová oznámení

Strojní 3D CAD software SolidWorks® je chráněn patenty USA 5 815 154, 6 219 049, 6 219 055, 6 611 725, 6 844 877, 6 898 560, 6 906 712, 7 079 990, 7 477 262, 7 558 705, 7 571 079, 7 590 497, 7 643 027, 7 672 822, 7 688 318, 7 694 238, 7 853 940 a zahraničními patenty (např. EP 1 116 190 a JP 3 517 643).

Software eDrawings® je chráněn patenty USA 7,184,044; 7,502,027 a kanadským patentem 2,318,706.

V USA a jiných zemích probíhá vyřizování dalších patentů.

Ochranné známky a názvy produktů pro produkty a služby SolidWorks

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings a logo eDrawings jsou registrované ochranné známky a FeatureManager je registrovaná ochranná známka ve společném vlastnictví společnosti DS SolidWorks.

CircuitWorks, FloXpress, TolAnalyst a XchangeWorks jsou ochranné známky společnosti DS SolidWorks.

FeatureWorks je registrovanou ochrannou značkou společnosti Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Workgroup PDM, SolidWorks Simulation, SolidWorks Flow Simulation, eDrawings Professional a SolidWorks Sustainability jsou názvy produktů společnosti DS SolidWorks.

Ostatní značky či názvy výrobků jsou ochrannými známkami nebo registrovanými ochrannými známkami příslušných vlastníků.

KOMERČNÍ POČÍTAČOVÝ SOFTWARE – CHRÁNĚNO PATENTY

Tento software je „komerční zboží“ a jako takové je definováno v 48 C.F.R. 2.101 (říjen 1995), obsahující „komerční počítačový software“ a „komerční softwarovou dokumentaci“, tak jak je použito v 48 C.F.R. 12.212 (září 1995) a je poskytováno americké vládě za účelem (a) pořízení pro správní úřady, v souladu se zásadami v 48 C.F.R. 12.212; nebo (b) pořízení pro útvary Ministerstva obrany v souladu se zásadami v 48 C.F.R. 227.7202-1 (červen 1995) a 227.7202-4 (červenec 1995).

V případě, že obdržíte objednávku jakéhokoliv úřadu americké vlády na tento software s právy, které překročují práva stanovená ve výše uvedeném paragrafu, oznámíte společnosti DS SolidWorks rozsah této žádosti a DS SolidWorks během pěti (5) pracovních dnů dle uvážení rozhodne, zda žádosti vyhojí nebo ji odmítne. Smluvní strana/výrobce: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

Autorské doložky pro produkty SolidWorks Standard, Premium, Professional a vzdělávací verzi

Části tohoto softwaru © 1986-2011 Siemens Product Lifecycle Management Software Inc. Všechna práva vyhrazena.

Tato práce obsahuje následující software, který je majetkem společnosti Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Všechna práva vyhrazena.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. Všechna práva vyhrazena.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Všechna práva vyhrazena.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. Všechna práva vyhrazena.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Všechna práva vyhrazena.

Součásti tohoto softwaru © 1998-2011 Geometric Ltd.

Součásti tohoto softwaru © 1996-2011 Microsoft Corporation. Všechna práva vyhrazena.

Součásti tohoto softwaru zahrnují PhysX™ by NVIDIA, 2006-2010.

Součásti tohoto softwaru © 2001-2011 Luxology, LLC. Všechna práva vyhrazena, patenty čekají na vyřízení.

Součásti tohoto softwaru © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. a držitelé její licence. Všechna práva vyhrazena. Chráněno patenty USA 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; probíhá vyřizování dalších patentů.

Adobe, logo Adobe, Acrobat, logo Adobe PDF, Distiller a Reader jsou registrovanými ochrannými známkami nebo ochrannými známkami společnosti Adobe Systems Inc. v USA a dalších zemích.

Další informace o autorských právech na software SolidWorks® viz Nápověda > O aplikaci SolidWorks.

Autorská práva pro produkty SolidWorks Simulation

Části tohoto softwaru © 2008, Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration Inc. Všechna práva vyhrazena.

Autorská práva pro produkt SolidWorks Enterprise PDM

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation. Všechna práva vyhrazena.

Autorská práva pro produkty eDrawings

Části tohoto programu © 2000-2011 Tech Soft 3D.

Části tohoto softwaru © 1995-1998 Jean-Loup Gailly and Mark Adler.

Součásti tohoto softwaru © 1998-2001 3Dconnexion.

Součásti tohoto softwaru © 1998–2011 Open Design Alliance. Všechna práva vyhrazena.

Součásti tohoto softwaru © 1995-2010 Spatial Corporation.

Tento software je částečně založen na práci Independent JPEG Group.


Instalace a správa několika počítačů

Manažer instalací SolidWorks poskytuje následující nástroje na instalaci a správu několika počítačů SolidWorks.

Administrativní kopie SolidWorks

Pokud instalujete program SolidWorks na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

Server Workgroup PDM

Aplikace Workgroup PDM je program pro správu dat projektů. Běží buď uvnitř prostředí programu SolidWorks, nebo jako samostatná aplikace v rámci Průzkumníka SolidWorks. Workgroup PDM řídí projekty pomocí procesů pro vyzvednutí, odevzdání, kontrolu revizí a další správní úkony. Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SolidWorks.

Manažer licencí SolidNetWork

Manažer licencí SolidNetWork umožňuje, aby počet uživatelů přesáhl počet licencí, pomocí plovoucích licencí. Pokud není klientská licence využívaná, je k dispozici pro jiného uživatele SolidWorks.

Můžete také použít Manažera licencí SolidNetWork k rozdělení licencí pro doplňkové moduly jádra SolidWorks (například FeatureWorks).

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks


Nejsou k dispozici novější verze

Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.

Pro pokračování v instalaci klepněte na Další.

Nadřazené téma: Nápověda aplikace Manažera instalací SolidWorks