SolidWorks Installation und Administration

Diese Anleitung beschreibt die Installation, Lizenzierung, Aktualisierung und Administration von SolidWorks Produkten für je Einzelinstallationen und mehrere Installationen.

Einzelinstallationen | Aktivierung mehrerer Installationen
Installation Installation auf einem oder mehreren Computern. | Installation Erstellung eines Administrator-Installationsabbildes, das auf einer bestimmte Anzahl von Client-Computern angewendet wird.
Lizenzierung Lizenzaktivierung oder Netzwerklizenzierung. | Lizenzierung Lizenzaktivierung oder Netzwerklizenzierung.
Upgrades (Aktualisierungen) Einzel-Computer auf eine neue Version aktualisieren. | Upgrades (Aktualisierungen) Aktualisieren von mehreren Computern auf eine neue Version durch Aktualisierung des Administrator-Installationsabbildes, das auf allen diesen Computern zur Installation benutzt wird.
Verwaltung Modifizieren, Reparieren oder Entfernen und Installationen, Aktualisieren auf neue Versionen. | Verwaltung Aktualisieren von Administrator-Installationsabbildern und Clients, Verwaltung der Netzwerklizenzierung, Workgroup PDM, Tresorverwaltung.

Der SolidWorks Installations-Manager ermöglicht das Konfigurieren von Einstellungen für SolidWorks Produktkomponenten einschließlich SolidWorks Toolbox, PhotoView 360, Workgroup PDM und SolidWorks SolidNetWork Lizenz-Manager.

Die Workgroup PDM Anwendung ist eine Projektdatenverwaltungssoftware, die innerhalb der SolidWorks-Umgebung oder als eine eigenständige Anwendung in SolidWorks Explorer ausgeführt wird. Mit Workgroup PDM können Sie für Projekte das Ein- und Auschecken, die Versionskontrolle und andere verwaltungstechnische Aufgaben steuern.

Der SolidNetWork Lizenz-Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

  • Einzelinstallation oder Administrator-Installationsabbild
    Sollten Sie SolidWorks Produkte auf jedem Computer separat installieren, oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?
  • SolidWorks Installation wird initiiert
    Sie können die Installation von SolidWorks durch Laden einer DVD in den lokalen Computer initiieren, durch Zugriff auf ein freigegebenes Installationsverzeichnis oder über einen Download von SolidWorks.


Einzelinstallation oder Administrator-Installationsabbild

Sollten Sie SolidWorks Produkte auf jedem Computer separat installieren, oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?

Wenn Sie nur auf einem Computer installieren, oder wenn Sie für Dutzende oder Hunderte Computer zuständig sind, ist es offensichtlich, welche Option zu wählen ist. In Fällen, die dazwischen liegen, sollten Sie die folgenden Vergleiche beachten.

Einzelinstallation | Administrator-Installationsabbild
Anwender können Ihre eigene SolidWorks Administration führen. | Der Systemadministrator kann mehrere Installationen mit dem Options-Editor anpassen, indem er Optionen wie die Erstellung einer neuen Installation oder die Aktualisierung einer bestehenden festlegt sowie die Ausführung der Installation als Administrator, die Ausführung externer Befehle vor oder nach der Installation, verschiedene Produktgruppierungen etc. festlegt.
Die Computer müssen für die Person, die die Installation ausführt, physisch zugreifbar sein. | Client-Computer können sich auch entfernt befinden, solange auf sie vom selben Netz zugegriffen werden kann.
Siee können verschiedene Versionen. Service Packs oder Produkte auf verschiedenen Computern mit separaten Einstellungen installieren. | Mit dem Options-Editor können Administrator-Installationsabbilder Konsistenz in Versionen, Service Packs, Produkten und Einstellungen gewährleisten.
Das ursprüngliche Quellmedium (DVD) ist erforderlich, wenn Service Packs angewendet werden sollen. | Medien-Laufwerke sind für das Anwenden von Service Packs nicht erforderlich.
Der Computer braucht nicht an ein Netz angeschlossen zu sein. | Eine lokale Netzwerk-Verbindung ist für die Bereitstellung der Anwendung erforderlich. Medien-Laufwerke auf Client-Computern sind nicht erforderlich.
 | Clients können automatisch aktualisiert werden. Alle Clients, auf denen vom selben Administrator-Installationsabbild installiert wurde, haben dasselbe Service Pack. Um mehrere Versionen zu verwalten, können Sie mehrere Administrator-Installationsabbilder erstellen.
 | Die Lizenzaktivierung kann automatisiert werden.
 | Für ein Administrator-Installationsabbild ist Speicherplatz auf dem Server erforderlich; Clients benötigen denselben Platz wie Einzelinstallationen.
Übergeordnetes Thema: SolidWorks Installation und Administration


SolidWorks Installation wird initiiert

Sie können die Installation von SolidWorks durch Laden einer DVD in den lokalen Computer initiieren, durch Zugriff auf ein freigegebenes Installationsverzeichnis oder über einen Download von SolidWorks.

  • Um die SolidWorks Installation zu initiieren, führen Sie einen der folgenden Schritte aus:
    • Um auf einen lokalen Computer von einem Datenträger aus zu installieren, legen Sie den entsprechenden Datenträger in das Laufwerk ein.
    • Um von einem Download-Verzeichnis zu installieren, navigieren Sie zum Verzeichnis und doppelklicken Sie auf setup.exe.
    • Durch Downloading von SolidWorks installieren:
      1. Rufen Sie die SolidWorks Website auf.
      2. Melden Sie sich als Subskriptionsdienst-Kunde mit Ihrer E-Mail-Adresse und Ihrem Passwort oder Ihrer SolidWorks Seriennummer an.
      3. Klicken Sie unter Selbstverwaltung auf Software und Aktualisierungen herunterladen.
      4. Wählen Sie unter Software herunterladen die SolidWorks Version und das Service Pack zum Herunterladen.
Übergeordnetes Thema: SolidWorks Installation und Administration


Einzelinstallationen

  • Installation auf Einzel-Computern
    Sie können SolidWorks mit mehreren Installationsmethoden auf einem Einzel-Computer installieren.
  • Verwaltung von Einzelplatzinstallationen
    Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.


Installation auf Einzel-Computern

Sie können SolidWorks mit mehreren Installationsmethoden auf einem Einzel-Computer installieren.

Die Installation erfolgt über den SolidWorks Installations-Manager, der die Installation auf die von Ihnen erworbenen Produkte anpasst. Bevor Sie mit der Installation beginnen:

  • Halten Sie Ihre SolidWorks Seriennummer bereit.
  • Stellen Sie sicher, dass Sie über einen funktionierenden Internet-Anschluss verfügen.
Der SolidWorks Installations-Manager benötigt verschiedene Microsoft-Komponente, wie den Microsoft Windows Installer, Office Web Components Microsoft Visual Studio Tools for Applications und .NET Framework. Wenn die korrekten Versionen aller von Windows vorausgesetzten Komponenten nicht auf dem Computer installiert sind, installiert der SolidWorks Installations-Manager diese automatisch vor der Installation der SolidWorks-Produkte.
Installationsmethode Übersicht über den Vorgang
Verwenden der SolidWorks-Installationsmedien Legen Sie den entsprechenden DVD-Datenträger in das Laufwerk ein.
Das SolidWorks-Installationsmedium liefert separate DVDs für 32-Bit- und 64-Bit-Windowsinstallationen.
Ein Download-Verzeichnis auf einem Server verwenden Doppelklicken Sie im Download-Verzeichnis auf setup.exe.
Man muss von dem Computer, auf dem Sie SolidWorks-Produkte installieren, auf das Download-Verzeichnis zugreifen können. Er muss des Weiteren alle SolidWorks-Installationsdateien enthalten, bevor Sie mit der Installation beginnen können. Mit dem SolidWorks Installations-Manager können Sie fehlende Dateien finden, wenn Sie Zugriff auf das Internet und Schreibrechte auf das Download-Verzeichnis haben.
Dies ist kein Administrator-Installationsabbild. Die einzige Methode, einen Client-Computer von einem Administrator-Installationsabbild zu installieren, besteht darin, auf den Link in der .html-Seite, die von Administrator verteilt wird, zu klicken.
Aktualisierung einer bestehenden SolidWorks-Installation mittels Nach Aktualisierungen suchen Führen Sie einen der folgenden Schritte aus:
  • Klicken Sie in SolidWorks auf Hilfe > Nach Aktualisierungen suchen.
  • Klicken Sie in Windows auf Start > Alle Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen.
Stellen Sie sicher, dass Sie über einen funktionierenden Internet-Anschluss verfügen.

Workgroup PDM Clients findet Tresor-Aktualisierungen automatisch. Sie brauchen kein Service Pack herunterzuladen, um Client-Anwendungen zu aktualisieren. Siehe Clients aktualisieren in der Workgroup PDM-Online-Hilfe.

Download von der SolidWorks Kunden-Website.
  1. Rufen Sie die SolidWorks Website auf.
  2. Melden Sie sich als Subskriptionsdienst-Kunde mit Ihrer E-Mail-Adresse und Ihrem Passwort oder Ihrer SolidWorks Seriennummer an.
  3. Wählen Sie unter Selbstverwaltung auf Software und Aktualisierungen herunterladen.
  4. Unter Software herunterladen, klicken Sie auf die SolidWorks-Version, die Sie installieren wollen.
Stellen Sie sicher, dass Sie über einen funktionierenden Internet-Anschluss verfügen.

Sie müssen ein Subskriptionsdienst-Kunde mit Zugriff auf die Kundenportal-Site sein.

Wenn die Installation abgeschlossen ist, starten Sie die SolidWorks-Anwendung, und aktivieren Sie die Lizenz.

Übergeordnetes Thema: Einzelinstallationen


Verwaltung von Einzelplatzinstallationen

Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.

  • Modifizieren einer Installation
    Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen.
  • Reparieren der Installation
    Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation über die Windows Systemsteuerung reparieren.
  • Einzelinstallation auf ein früheres Service Pack zurücksetzen
    Um eine Einzelinstallation auf ein früheres Service Packversion in der aktuellen Hauptversionsfamilie zurückzusetzen, die aktuell auf dem Computer installierte Service Pack-Version deinstallieren und die frühere Version installieren.
  • Entfernen einer Installation
    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.
  • Auf neue Version aktualisieren
    Es gibt mehrere Methoden, wie Sie eine Einzel-Installation auf eine neue SolidWorks-Version aktualisieren können.
  • Produkt-Koexistenzregeln
    Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.
Übergeordnetes Thema: Einzelinstallationen


Modifizieren einer Installation

Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen.

Wenn Sie die SolidWorks Anwendung installiert und eine Zusatzanwendung zu einem späteren Zeitpunkt erworben haben, können Sie die Installation ändern, um die neue Zusatzanwendung hinzuzufügen. Sie müssen die Zusatzanwendung auf jedem einzelnen Rechner installieren.

Workgroup PDM wird nicht installiert, wenn Sie Ihr ursprüngliches SolidWorks Paket ändern, sodass es SolidWorks Professional oder SolidWorks Premium umfasst.
  1. Stellen Sie sicher, dass keine SolidWorks Sitzung aktiv ist.
  2. Klicken Sie in Windows Vist oder später auf Start > Systemsteuerung >Software.

    Klicken Sie in früheren Versionen von Windows auf Start > Systemsteuerung > Programme.

  3. Wählen Sie die installierte SolidWorks-Software, die Sie ändern möchten, und klicken Sie auf Ändern.
  4. Klicken Sie auf dem Bildschirm Willkommen beim SolidWorks Installations-Manager auf Einzelinstallation (auf diesem Computer) ändern.
  5. Verifizieren Sie auf dem Bildschirm Seriennummer, dass die für Ihre Installation passenden Seriennummern angegeben sind.
  6. Wählen Sie auf dem Bildschirm Produktauswahl die zu installierenden oder entfernenden Produkte aus.

    Falls Sie eine Installation modifizieren:

    • Es werden standardmäßig keine Produkte installiert oder entfernt, auch wenn Sie eine neue Seriennummer festlegen. Sie müssen die Installationsaktion für jedes Produkt oder jede Feature-Komponente ändern.
    • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
    • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
    • Wenn Sie eine Komponenteninstallationsaktion aus der ursprünglichen Wahl ändern, erscheint in der Auflistung ein Sternchen (*) neben der Komponente.
    • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
    • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.

  7. Klicken Sie auf dem Bildschirm Zusammenfassung auf Jetzt modifizieren.
  8. Klicken Sie auf dem Bildschirm Installation vollständig auf Fertig stellen.
Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen


Reparieren der Installation

Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation über die Windows Systemsteuerung reparieren.

Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild deinstallieren und erneut installieren.

Installation reparieren:

  1. Klicken Sie in Windows Vist oder später auf Start > Systemsteuerung >Software. Klicken Sie in früheren Versionen von Windows auf Start > Systemsteuerung > Programme.
  2. Wählen Sie die SolidWorks Version, die fehlgeschlagen ist, aus, und klicken Sie auf Ändern.

    Der SolidWorks Installations-Manager wird gestartet.

  3. Klicken Sie auf dem Willkommensbildschirm auf Einzelinstallation reparieren (auf diesem Computer). und klicken Sie dann auf Weiter.
  4. Wählen Sie die Produkte aus, die nicht installiert oder nicht entfernt wurden, und klicken Sie auf Reparieren.
Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen
Übergeordnetes Thema: Installationsfehler / Installation abgebrochen


Einzelinstallation auf ein früheres Service Pack zurücksetzen

Um eine Einzelinstallation auf ein früheres Service Packversion in der aktuellen Hauptversionsfamilie zurückzusetzen, die aktuell auf dem Computer installierte Service Pack-Version deinstallieren und die frühere Version installieren.

Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen


Entfernen einer Installation

Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

  1. Stellen Sie sicher, dass keine SolidWorks Sitzung aktiv ist.
  2. Wenn Sie die SolidWorks-Lizenz auf einen anderen Computer übertragen möchten, tun Sie dies, bevor Sie die SolidWorks Installation auf diesem Computer entfernen.

    Informationen über das Übertragen von SolidWorks Lizenzen finden Sie unter Eine Lizenz übertragen.

  3. Klicken Sie in Windows Vista oder höher auf Start > Systemsteuerung > Programme > Programme und Funktionen.

    Klicken Sie in früheren Versionen von Windows auf Start > Systemsteuerung > Programme.

  4. Wählen Sie die Produktkomponente aus, die entfernt werden sollen.

    In eineigen Fällen könnten Sie mehrere SolidWorks Service Pack-Komponente für eine bestimmte Hauptversion vorfinden. Entfernen Sie, um eine Hauptversion von SolidWorks zu entfernen, alle Service Pack-Elemente dieser Hauptversion.

  5. Auf dem Deinstallieren-Bildschirm:
    1. wählen Sie die Produkte aus, die entfernt werden sollen. Standardmäßig werden alle Produktkomponente selektiert.
    2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.
    3. Wählen Sie, ob eine benuterzdefinierte oder vollständige Deinstallation durchgeführt werden soll. Der SolidWorks Installations-Manager führt eine Standard-Deinstallation durch und entfernt Programmdateien und Ordner.

      1. Klicken Sie auf Ändern in Erweiterte Optionen.

        Der Bildschirm Erweiterte Optionen wird eingeblendet und die Programmdateien und Ordner-Option ist ausgewählt.

      2. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen, um eine vollständige Deinstallation durchzuführen.
      3. Klicken Sie auf Zurück zu Übersicht.
      4. Klappen Sie auf dem Bildschirm Übersicht Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.

    4. Klicken Sie auf Elemente entfernen.
Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen


Auf neue Version aktualisieren

Es gibt mehrere Methoden, wie Sie eine Einzel-Installation auf eine neue SolidWorks-Version aktualisieren können.

Sie können auf eine neue Version aktualisieren, wenn Sie:
  • Neue Installationsmedien erhalten
  • Wenn Sie nach dem Start von SolidWorks über Upgrades benachrichtigt werden.
  • Manuell nach Aktualisierungsergebnissen suchen
  • Eine neue Kopie des SolidWorks Installations-Managers starten

Wenn Sie eine neue Version installieren, können Sie die aktuelle Installation aktualisieren oder die neue Version parallel installieren. Wenn Sie eine Service Pack-Version für eine aktuelle Hauptversion installieren, dann wird die Version automatisch aktualisiert.

  • Manuell nach Aktualisierungen suchen
    Sie können mit einer der folgenden Methoden nach Aktualisierungen für eine bereits installierte SolidWorks-Version suchen.
  • Workgroup PDM Clients aktualisieren
    Clients werden bei der ersten Anmeldung nach der Tresoraktualisierung zur Aktualisierung aufgefordert. Zum Aktualisieren von Clients ist kein Service Pack erforderlich.
  • Vorbehalte betreffend Aktualisierungen
    Produkte, die mehrere Installationen mit verschiedenen Hauptversionen haben können, unterstützen nicht in jedem Fall Hauptaktualisierungen oder die Möglichkeit, von einer Hauptversionen auf die nächste in einer Einzeloperation zu aktualisieren.
Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen


Manuell nach Aktualisierungen suchen

Sie können mit einer der folgenden Methoden nach Aktualisierungen für eine bereits installierte SolidWorks-Version suchen.

  • Klicken Sie in SolidWorks auf Hilfe > Nach Aktualisierungen suchen.
  • Klicken Sie in Windows auf Start > Alle Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen.
Übergeordnetes Thema: Auf neue Version aktualisieren


Workgroup PDM Clients aktualisieren

Clients werden bei der ersten Anmeldung nach der Tresoraktualisierung zur Aktualisierung aufgefordert. Zum Aktualisieren von Clients ist kein Service Pack erforderlich.

Client-Status relativ zum Tresor | Aktion
Gleiche Version wie Tresor | Kein
Selbe Hauptversion, neuere als Tresor | Kein
Neuere Hauptversion, neuer als Tresor | Anmeldung ist gesperrt
Selbe Hauptversion, älter als Tresor | Optionale Aktualisierung
Ältere Hauptversion, älter als Tresor | Aktualisierung erforderlich

Details zur Aktualisierung von Workgroup PDM-Clients, siehe Clients aktualisieren in der Workgroup PDM-Hilfe.

Übergeordnetes Thema: Auf neue Version aktualisieren
Übergeordnetes Thema: Workgroup PDM VaultAdmin Administration


Vorbehalte betreffend Aktualisierungen

Produkte, die mehrere Installationen mit verschiedenen Hauptversionen haben können, unterstützen nicht in jedem Fall Hauptaktualisierungen oder die Möglichkeit, von einer Hauptversionen auf die nächste in einer Einzeloperation zu aktualisieren.

In diesem Fall simuliert der SolidWorks Installations-Manager die Aktualisierung, indem zunächst die neue Version installiert und dann die alte entfernt wird. Zur Zeit unterstützen das SolidWorks Kernprodukt und Hauptaktualisierungen, während dies auf andere Produkte nicht zutrifft.

Daraus ergeben sich folgende Konsequenzen:
  • Wenn Sie das SolidWorks Kernprodukt von einer Hauptversion auf die nächste aktualisieren:
    • Die bestehenden installierten Speicherplätze ändern sich nicht.
    • Die Aktualisierung kann zurückgesetzt werden, wenn ein Fehler auftritt oder während der Aktualisierung abgebrochen wird.
  • Wenn andere Produkte von einer Hauptversion auf die nächste aktualisiert werden:
    • Jedes Produkt wird zunächst als neues Produkt an einem neuen Speicherplatz installiert. Danach wird die ursprüngliche Installation entfernt.
    • Sobald die Aktualisierung gestartet wurde, kann sie nicht mehr zurückgesetzt werden, wenn ein Fehler auftritt oder wenn der Aktualisierungsvorgang abgebrochen wird.
Übergeordnetes Thema: Auf neue Version aktualisieren


Produkt-Koexistenzregeln

Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.

Regel | Beispiele
Mehrere Hauptversionen eines SolidWorks Kernprodukts können unabhängig von Service Pack oder Hauptversion (mit Ausnahme der drei unten genannten Produkte) koexistieren. SolidWorks 2010 SP3.0 und SolidWorks 2011 SP0.0 können auf demselben Computer installiert sein.

Wenn SolidWorks 2011 SP0.0 jedoch auf einem Computer installiert ist und Sie SolidWorks 2011 SP1.0 installieren, ersetzt der SolidWorks-Installations-Manager die SP0.0-Version durch die neue SP1.0-Version.

SolidWorks 2011 SP0.0 und 2011 SP1.0 können nicht gemeinsam auf dem gleichen Computer installiert sein.

Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • Workgroup PDM Server
  • SolidNetWork Lizenz-Manager
 Wenn SolidWorks 2011 SP0.0 installiert ist, wird Workgroup PDM Server auf 2011 SP0.0 aktualisiert, auch wenn eine frühere Hauptversion von SolidWorks auf dem Computer installiert bleibt.
Nur eine Version eines integrierten Produkts kann für eine Hauptversion installiert werden. | Wenn SolidWorks 2011 SP0.0 auf 2011 SP1.0 aktualisiert wird, wird SolidWorks Explorer 2011 SP0.0 automatisch auf 2011 SP1.0 aktualisiert. Es kann aber auch SolidWorks Explorer 2010 SP4.0 auf dem Computer installiert sein.
Übergeordnetes Thema: Verwaltung von Einzelplatzinstallationen


Mehrere Installationen

  • Bereitstellung für mehrere Clients
    Sie können das SolidWorks Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.
  • Administrator-Installationsabbilder verwenden
    Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SolidWorks-Produkten von einem einzigen Netzwerkbereich.
  • Befehlszeilenbereitstellung
    Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.
  • Verwaltung von mehreren Installationen
    Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.


Bereitstellung für mehrere Clients

Sie können das SolidWorks Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.

Der Vorgang zur Anwendung auf mehreren Clients ist wie folgt:
  1. Administrator-Installationsabbild erstellen.
    • Administrator-Installationsabbild vom SolidWorks Installations-Manager aus erstellen
    • Administrator-Installationsabbild von einer Eingabeaufforderung erstellen
  2. Wenden Sie das Administrator-Installationsabbild auf Clients an.
    • Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
    • Mit der Befehlszeile aus dem Administrator-Abbild installieren
  3. Implementieren Sie die Lizensierung.
    • Verwalten von Einzellizenzen
    • Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten
Übergeordnetes Thema: Mehrere Installationen


Administrator-Installationsabbilder verwenden

Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SolidWorks-Produkten von einem einzigen Netzwerkbereich.

Administrator-Installationsabbilder lassen sich von jedem Netzwerkcomputer, einschließlich einem Client-Computer, aus installieren.
  • Das Administrator-Installationsabbild muss sich in einem freigegebenen Ordner befinden.
  • Wenn Sie alle Produkte miteinbeziehen, können 7 GB oder mehr auf der Festplatte für das Administrator-Installationsabbild erforderlich werden.
  • Wenn Sie den Freigabenamen bei der Aktualisierung des Administrator-Installationsabbilds aktualisieren, wird der Client automatisch beim nächsten Starten der Anwendung aktualisiert. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.
  • Clients müssen über Administratorrechte auf ihren Computern verfügen, es sein denn, die Option Installation als anderer Anwender ausführen ist für die Client-Installation festgelegt.
    Diese Option wird nicht von Windows Vista oder späteren Versionen unterstützt.

Nachdem Sie ein Administrator-Installationsabbild erstellt haben, können Sie im Administrator-Installationsabbild Options-Editor Installationsoptionseinstellungen für Benutzer und Gruppen, die Installationen mithilfe des Abbilds durchführen, vornehmen. Einzelheiten finden Sie unter Administrator-Installationsabbild Options-Editor.

  • Administrator-Installationsabbild vom SolidWorks Installations-Manager aus erstellen
    Wenn Sie SolidWorks auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.
  • Administrator-Installationsabbild Options-Editor
    Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.
  • Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
    Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.
  • Verknüpfung eines Administrator-Installationsabbildes mit Clients
    Sie können einen Befehl ausführen, mit dem ein Administrator-Installationsabbild mit Clients verknüpft wird.
Übergeordnetes Thema: Mehrere Installationen


Administrator-Installationsabbild vom SolidWorks Installations-Manager aus erstellen

Wenn Sie SolidWorks auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

  1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
  2. Wählen Sie im Willkommens-Fenster das Administrator-Installationsabbild.

    Administrator-Installationsabbild-Optionen werden angezeigt:

    Neues Abbild mit Standardeinstellungen erstellen.
    Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der aktuellen Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen.
    Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
    Sowohl 32-Bit als auch 64-Bit-Administrator-Installationsabbilder erstellen.
    Sie können sowohl 32-Bit- als auch 64-Bit-Abbilder auf einem Computer erstellen oder Sie können einfach das Abbild erstellen, das der Computerarchitektur entspricht. Für die Erstellung beider Abbilder benötigen Sie Zugriff auf 32-Bit- und 64-Bit-Installationsmedien.

  3. Befolgen Sie die Anweisungen auf dem Bildschirm.
Übergeordnetes Thema: Administrator-Installationsabbilder verwenden


Administrator-Installationsabbild Options-Editor

Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.

Nach der Erstellung eines Administrator-Installationsabbilds werden Sie vom SolidWorks Installations-Manager zum Starten des Options-Editors aufgefordert. Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner doppelklicken.

Um verschiedene Installationskonfigurationen für Gruppen von Computern oder einzelne Computer festzulegen, fügen Sie Gruppen und Computer im Options-Editor hinzu und definieren Sie dann die Installationsoptionen für diese Gruppen und Computer.

  • Gruppen und Computer hinzufügen und löschen
    Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.
  • Anzeigen und Bearbeiten von Optionseinstellungen
    Der SolidWorks Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.
  • Umschalten zwischen 32-Bit- und 64-Bit-Administrator-Installationsabbildern
    Wenn Sie im Administrator-Installationsabbildverzeichnis sowohl 32-Bit- als auch 64-Bit-Abbilder erstellt haben, können Sie im Options-Editor zwischen diesen Abbildtypen wählen.
  • Bereitstellung von Installationen über den Options-Editor
    Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie mit E-Mail-Anweisungen die Installationen starten.
  • Beenden des Options-Editors
    Sie können auf OK oder "Schließen" klicken, um den Options-Editor zu beenden.
  • Erstellen einer Desktop-Verknüpfung zum Options-Editor
    Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.
Übergeordnetes Thema: Administrator-Installationsabbilder verwenden


Gruppen und Computer hinzufügen und löschen

Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.

Sie können z.B. u.U. etliche Computer so konfigurieren, dass sie einen bestimmten Teilsatz der Produktkomponenten verwenden, die im Abbild zur Verfügung stehen, während eine andere Gruppe u.U. einen anderen Teilsatz der Produktkomponenten verwendet. Obwohl Sie ein Administrator-Installationsabbild verwenden, ermöglichen es die Gruppeneinstellungen des Options-Editors, dass verschiedene Produkt-Teilsätze auf verschiedene Gruppen von Maschinen installiert werden können.

Hinzufügen einer Gruppe:
  1. Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Gruppe hinzufügen.
  2. Geben Sie den Gruppennamen ein.
Computer hinzufügen:
  1. Klicken Sie mit der rechten Maustaste auf eine bestehende Gruppe oder auf Globale Einstellungen und dann auf Computer hinzufügen.
    Wenn Sie auf eine bestehende Gruppe rechtsklicken, werden dieser Gruppe Computer hinzugefügt. Ansonsten werden sie auf der übergeordneten Ebene hinzugefügt.
  2. Führen Sie eine der folgenden Aktionen aus:
    • Geben Sie einen oder mehrere Computer-Namen unter Computer-Name ein.

      Mehrere Computer können durch einen Zeilenumbruch, einen Abstand, ein Tabstopp, Komma, einen Punkt, Doppelpunkt oder ein Semikolon getrennt sein. Sie können eine Liste von Computer-Namen aus einer externen Datei kopieren und einfügen.

      Computer-Namen dürfen keine Domain-Kennzeichner enthalten. pluto.solidworks.com ist z.B. ungültig.

    • Klicken Sie auf Mehrere Computer hinzufügen, um Computer aus dem Netzwerk auszuwählen.
Einen bestehenden Computer in eine Gruppe verschieben: Ziehen Sie den Computer in die Gruppe.
Einen Computer aus einer Gruppe verschieben: Ziehen Sie den Computer auf Globale Einstellungen oder in eine andere Gruppe.
Eine Gruppe oder Computer löschen: Klicken Sie mit der rechten Maustaste auf die Gruppe oder den Computer und dann auf Gruppe löschen oder Computer löschen.
Wenn Sie eine Gruppe löschen, werden alle Computer in dieser Gruppe gelöscht.
All Gruppen und Computer löschen: Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Alles löschen.
Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Anzeigen und Bearbeiten von Optionseinstellungen

Der SolidWorks Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.

  • Beim ersten Starten des Options-Editor werden die Optionseinstellungen schreibgeschützt angezeigt. Das Symbol "Bearbeiten" ist nicht schattiert: .
    Durch Klicken auf Globale Einstellungen wird eine Zusammenfassung der Optionseinstellungen für eine Gruppe oder einen Computer angezeigt:
    Bereich | Angezeigte Optionseinstellungen
    Globale Einstellungen | Alle Optionseinstellungen, die für das Administrator-Installationsabbild festgelegt wurden
    Gruppe | Änderungen bei den Gruppeneinstellungen bezüglich der globalen Einstellungen.
    Computer | Änderungen bei den Computereinstellungen bezüglich der Gruppe.
  • Um die Optionseinstellungen zu ändern, klicken Sie auf das Symbol "Bearbeiten". Das Symbol wird schattiert dargestellt ( [image]), und eine ausführlichere Optionseinstellungsliste wird angezeigt.

    Durch Klicken auf Globale Einstellungen können Sie Optionseinstellungen für eine Gruppe oder einen Computer ändern. Wenn Sie eine Optionseinstellung ändern, die sich von den übernommenen globalen oder Gruppeneinstellungen unterscheidet, wird diese Optionseinstellung hervorgehoben.

    Wenn Sie erneut auf das Symbol "Bearbeiten" klicken, wird die Anzeige wieder in den Schreibschutzmodus geschaltet.

    Beim Beenden des Options-Editors werden Sie aufgefordert, die Änderungen zu speichern oder zu verwerfen.

  • Optionseinstellungen für Gruppen und Computer festlegen
    Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.
  • Übernahme von globalen und Gruppenoptionseinstellungen
    Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.
Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Optionseinstellungen für Gruppen und Computer festlegen

Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.

  1. Klicken Sie im Options-Editor auf das zu ändernde Objekt (z. B. Globale Einstellungen, eine Gruppe oder einen Computer).
  2. Klicken Sie im rechten Fensterbereich auf das Bearbeitungssymbol [image].

    Das Bearbeitungssymbol wird schattiert dargestellt ( [image]), und eine ausführlichere Optionseinstellungsliste wird angezeigt.

  3. Ändern Sie Optionseinstellungen, indem Sie rechts auf die Optionseinstellungen für das auf der linken Seite ausgewählte Element klicken.

    Änderungen an den Optionseinstellungen, die Globale Einstellungen oder Gruppeneinstellungen überschreiben, werden hervorgehoben.

  4. Klicken Sie auf OK oder Schließen, um die Änderungen zu speichern.

    OK
    Die Änderungen werden gespeichert, und der Options-Editor wird geschlossen.
    Schließen
    Der Options-Editor fragt, ob Sie die Änderungen speichern möchten, und wird dann geschlossen.

  • Administrator-Installationsabbild-Optionseinstellungen
    Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.
Übergeordnetes Thema: Anzeigen und Bearbeiten von Optionseinstellungen


Administrator-Installationsabbild-Optionseinstellungen

Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.

Seriennummern

Geben Sie die Seriennummern der Produkte ein, die auf den Clientcomputern installiert werden sollen.
Da es viele Möglichkeiten gibt, SolidWorks Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SolidWorks Seriennummer es Ihnen beispielsweise gestatten, SolidWorks Simulation zu installieren, ohne eine separate SolidWorks Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.
Wenn Sie Lizenzen mit der SolidNetWork Lizenzierung verwalten:
  • Geben Sie die SolidNetWork-Seriennummer in das erste Seriennummerfeld ein.
  • Geben Sie den SolidNetWork-Lizenz-Manager-Servernamen und -port in das Feld SNL Server Port@Server im Format nnnnn@Servername ein. Geben Sie mehrere Einträge durch Semikolon getrennt ein.

Nähere Informationen über die SolidNetWork Lizenzierung finden Sie unter Installation und Konfiguration von SolidNetWork Lizenzen.

Client-Installationsoptionen

Wie sollen Client-Installationen von Hauptversionen ausgeführt werden?
Sie können festlegen, wie bei Clientinstallationen eine vorhandene Hauptversioninstallation behandelt wird:
  • Auf bestehende Hauptversion (sofern vorhanden) aktualisieren.

    Definieren Sie diese Option, um die frühere Hauptversionsinstallation durch die Installation der neuen Version zu ersetzen

  • Neue Hauptversion erstellen.

    Aktivieren Sie diese Option, wenn die vorherige Hauptversioninstallation erhalten bleiben soll und eine neue Installation für die neue Hauptversion erstellt werden soll.

    Um einen Speicherort für die Installation der neuen Version anzugeben, klicken Sie auf Durchsuchen.

Soll die letzte vorige Version deinstalliert werden, bevor eine neue Hauptversion installiert wird?
Sie können festlegen, ob die bestehende Version vor der Hauptversion deinstalliert werden soll:
  • Nein, nicht zuerst deinstallieren.

    Definieren Sie diese Option, um die Version vor der Hauptversion zu behalten.

  • Ja, eine benutzerdefinierte Deinstallation ausführen.
    Wählen Sie diese Option, um die folgenden Elemente zu entfernen:
    • Programmdateien und -ordner
    • Registrierungseinträge
    • Datendateien und -ordner
Wie sollen SolidWorks Einstellungen angewendet werden?
Sie können festlegen, dass bei Clientinstallationen die SolidWorks-Einstellungen basierend auf den SolidWorks-Einstellungen, die auf dem Clientcomputer konfiguriert sind, oder den SolidWorks-Einstellungen, die aus dem Assistenten zur Kopie der Anwendereinstellungen exportiert wurden, konfiguriert werden.
  • Aktuelle Einstellungen (sofern vorhanden) oder SolidWorks-Standardeinstellungen verwenden

    Wenn der Clientcomputer über definierte SolidWorks-Einstellungen verfügt, behalten Sie diese Einstellungen bei. (Die Einstellungen, die nicht auf dem Client definiert wurden, werden bei der Clientinstallation auf die Standard-SolidWorks-Einstellungen gesetzt.)

  • Benutzen Sie die vom Assistenten zur Kopie der Anwendereinstellungen exportierte Einstellungendatei.
    Die Auswahl dieser Optionseinstellungen ermöglicht die Festlegung der Optionseinstellungen von einer besthenden Exportdatei des Assistenten zur Kopie der Anwendereinstellungen. (In der Regel hat die Datei die Bezeichnung solidworkssettings.sldreg.)
    • Klicken Sie auf Durchsuchen, um nach einer vorhandenen Einstellungsdatei zu suchen.
    • Klicken Sie auf Neu, um den Assistenten zur Kopie der Anwendereinstellungen zu starten, um eine neue Einstellungendatei zu erstellen.
Wie sollen Client-Installationen aktiviert werden?
Sie können festlegen, ob Sie Produktaktivierung automatisch nach dem Ausführen der Installation ausführen möchten oder fordern, dass der Anwender die Produktaktivierung manuell nach der Installation ausführt.
  • Automatisch aktivieren, wenn alle Client-Installationen vollständig sind.
    Die Auwahl dieser Optionseinstellung definiert, dass das Produkt automatisch unter Verwendung einer SolidWorks Produktaktivierungsdatei ausgeführt wird. (In der Regel hat die Datei die Bezeichnung AutoActivation.xml.)
    • Klicken Sie auf Durchsuchen, um nach einer vorhandenen Aktivierungsdatei zu suchen.
    • Klicken Sie auf Neu, um die SolidWorks Produktaktivierung zu starten, um eine neue Aktivierungsdatei zu erstellen.
  • Nicht automatisch aktivieren.

    Die Auswahl dieser Optionseinstellung definiert, dass keine automatisierte Produktaktivierung erfolgt. Der Client-Anwender führt eine Produktaktivierung nach der Installation durch.

Wenn Sie eine automatische Produktaktivierung definierten, muss das Administrator-Installationsabbild durch eine freigegebene Netzwerkposition verfügbar sein, wenn die Clients SolidWorks zum ersten Mal nach der Installation ausführen. Wenn das Administrator-Installationsabbild für Clients, die von diesem Abbild installiert haben, nicht verfügbar ist, können diese Clients die automatische Produktaktivierung nicht ausführen. Sie sind nicht in der Lage, SolidWorks auszuführen, es sei denn, Sie führen die SolidWorks Produktaktivierung manuell aus.

Verwaltungsoptionen

Erstellen Sie ein Diagnose-Protokoll während jeder Installation.
Bei der Clientinstallation kann ein Diagnoseprotokoll erstellt werden, das bei der Beseitigung von Installationsproblemen helfen kann. Die Erstellung dieses Protokolls kann jedoch die Clientinstallation verlangsamen.
Installation als anderer Anwender ausführen.
Eine Clientinstallation kann als ein anderer Benutzer ausgeführt werden. Diese Option kann nützlich sein, wenn einzelne Benutzer keine lokalen Administratorrechte auf deren Computern besitzen (welche zur Installation der SolidWorks-Produkte erforderlich sind).
Diese Funktion wird auf Windows Vista, Windows 7 oder neueren Versionen nicht unterstützt.
Programm vor oder nach der Installation ausführen
Sie können festlegen, dass ein benutzerdefiniertes Programm vor oder nach der Clientinstallation ausgeführt wird.
Sollen Clients am SolidWorks Kunden-Feedback-Programm teilnehmen?
Außerdem können Sie festlegen, dass Clients am SolidWorks Kunden-Feedback-Programm teilnehmen. Daten über die Leistung werden an die SolidWorks Corporation gesendet, was zur Produktverbesserung beiträgt. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Nähere Informationen dazu finden Sie unter Anwendererfahrungs-Optimierungsprogramm – Website.

Zu installierende Software

Sie können festlegen, welche SolidWorks-Produktkomponenten installiert werden.
  • Durch die Markierung des Kontrollkästchens neben der Produktkomponente wird die Komponente während der Clientinstallation installiert.
  • Wird die Markierung entfernt, wird die entsprechende Komponente nicht installiert.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
Die Spezifikation Sprachen limitiert nur die Sprachen, die für das SolidWorks Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Für SolidWorks eDrawings®, SolidWorks Workgroup PDM und SolidWorks Explorer z. B. werden alle vorhandenen Sprachen installiert.

Toolbox Optionen

Sie können festlegen, welche Normen unterstützt werden sollen und das Toolbox Standardverzeichnis bei Client-Installationen festlegen.

In der Regel greifen mehrere Benutzer auf eine freigegebene Toolbox zu, die sich meistens in einem Netzwerkspeicherort befindet (z. B. UNC-Pfad, freigegebener Ordner oder ein gemeinsam verwendetes Netzwerklaufwerk).

Wenn am Speicherort bereits eine ältere Hauptversion der Toolbox vorhanden ist, wird bei der Clientinstallation ein Upgrade der Toolbox auf die neue Hauptversion ausgeführt. Die Dateien sind anschließend nicht mehr mit vorherigen Hauptversionen von SolidWorks kompatibel.
Wenn die Toolbox für die ältere SolidWorks-Version erhalten bleiben soll (z. B. wenn auf einigen Clients weiterhin die ältere Version verwendet werden soll), müssen Sie einen anderen Toolbox-Netzwerkspeicherort für die Clients angeben, für die ein Upgrade auf die neue Version ausgeführt wird.

Weitere Informationen zur Verwaltung der SolidWorks Toolbox finden Sie unter dem Thema Toolbox in der SolidWorks-Hilfe.

Übergeordnetes Thema: Optionseinstellungen für Gruppen und Computer festlegen


Übernahme von globalen und Gruppenoptionseinstellungen

Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.

Beispiel:
  • Einstellungen, die für Globale Einstellungen definiert sind, gelten für alle Gruppen und Computer.
  • Einstellungen, die für eine Gruppe definiert sind, gelten für alle Computer in dieser Gruppe.

Sie können Optionseinstellung für einen Computer oder eine Gruppe ändern, um Standardeinstellungen oder übertragene Einstellungen außer Kraft zu setzen. Wenn Sie eine Optionseinstellung vom Standardwert oder übernommenen Wert ändern, wird diese Option hervorgehoben.

Klicken Sie, um Optionseinstellungen auf die ursprünglichen Einstellungen zurückzusetzen, mit der rechten Maustaste auf die Gruppe oder den Computer und klicken Sie dann auf Auf globale Einstellungen zurücksetzen (für eine Gruppe oder einen Computer, der nicht Teil der Gruppe ist) oder auf Gruppeneinstellungen zurücksetzen (für einen Computer, der Teil der Gruppe ist).
Übergeordnetes Thema: Anzeigen und Bearbeiten von Optionseinstellungen


Umschalten zwischen 32-Bit- und 64-Bit-Administrator-Installationsabbildern

Wenn Sie im Administrator-Installationsabbildverzeichnis sowohl 32-Bit- als auch 64-Bit-Abbilder erstellt haben, können Sie im Options-Editor zwischen diesen Abbildtypen wählen.

  • Klicken Sie im Options-Editor auf 32 oder 64, um mit dem 32-Bit- bzw. 64-Bit-Abbild zu arbeiten.

    Durch Klicken auf Konfiguration oder Bereitstellung können Sie Optionseinstellungen anzeigen und ändern oder Installationen für das betreffende Abbild bereitstellen.

Wenn sowohl 32-Bit- als auch 64-Bit-Abbilder vorhanden sind, müssen Sie die globalen Einstellungen, Gruppendefinition und -einstellungen sowie die jeweiligen Computereinstellungen für jedes Abbild separat vornehmen.
Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Bereitstellung von Installationen über den Options-Editor

Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie mit E-Mail-Anweisungen die Installationen starten.

Sie müssen das Installationsverzeichnis des Administrator-Installationsabbildes in ein freigegebenes Windows-Verzeichnis ändern, so dass darauf über einen Netzwerkspeicherort (z. B. \\Computer\freigegebenes Verzeichnis) zugegriffen werden kann.

  1. Klicken Sie im Options-Editor auf Bereitstellen.
  2. Wenn Sie 32-Bit- und 64-Bit-Installationsabbilder für dieses Administrator-Installationsabbildverzeichnis konfiguriert haben, klicken Sie auf 32 bzw. 64, um die Computer für das 32-Bit- bzw. 64-Bit-Bild anzuzeigen.

    Für jeden Computer wird die Verfügbarkeit und der Status bezüglich der Installation angezeigt.

  3. Klicken Sie auf E-Mail senden.
  4. Geben Sie den Netzwerkpfad zum Administrator-Installationsabbildverzeichnis an.

    In der Regel wird der Verzeichnispfad zum Administrator-Installationsabbildverzeichnis anfänglich als Windows-Dateipfad angezeigt (z. B. C:\SolidWorks Admin\SolidWorks 2011 SP0). Im Dialogfeld wird der Hinweis Dieser Pfad ist kein Netzwerkpfad angezeigt.

    1. Klicken Sie auf Durchsuchen, um den Netzwerkspeicherort für dieses Administrator-Installationsabbildverzeichnis anzugeben.
    2. Navigieren Sie zu dem Computer, auf dem das Administrator-Installationsabbild installiert ist, und wählen Sie das freigegebene Windows-Verzeichnis aus, das für das Administrator-Installationsabbild-Verzeichnis festgelegt ist.

      Navigieren Sie nicht in Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses (z. B. in die Unterverzeichnisse 32bit oder 64bit).

    3. Klicken Sie auf OK .

      Im Dialogfeld wird nun der Hinweis Dieser Pfad ist ein Netzwerkpfad angezeigt.

    Es wird eine E-Mail erstellt, die den Eigentümer des Computers anleitet, wie aus dem Administrator-Installationsabbild installiert wird, und zwar unter Verwendung des Netzwerkspeicherorts für die Datei StartSWInstall.hta im Administrator-Installationsabbild.

  5. Senden Sie die E-Mail an die Benutzer, die für die SolidWorks-Installation verantwortlich sind.

Benutzer können in der E-Mail auf den Link zum Netzwerkspeicherort für StartSWInstall.hta klicken, um SolidWorks aus dem Administrator-Installationsabbild zu installieren.

Im Options-Editor lautet der Installationsstatus:
Noch nicht erledigt
Der Benutzer hat die Installation noch nicht auf dem betreffenden Computer ausgeführt.
Erfolgreich
Der Benutzer hat die Installation erfolgreich auf dem betreffenden Computer ausgeführt.
Fehlgeschlagen
Der Benutzer hat versucht, die Installation auf dem betreffenden Computer auszuführen, sie ist jedoch fehlgeschlagen.
  • Verwenden eines zugeordneten Laufwerks, um ein Administrator-Installationsabbild bereitzustellen
    Zur Definition eines Netzwerkspeicherorts für das Administrator-Installationsabbildverzeichnis wird ein UNC-Pfad (\\Computername\Freigabename) empfohlen. Sie können aber auch ein zugeordnetes Laufwerk als Speicherort für die Datei StartSWInstall.hta im Administrator-Installationsabbild verwenden (z. B. U:\StartSWInstall.hta). Voraussetzung ist, dass bei allen Benutzern, die Installationen ausführen, dem Administrator-Installationsabbildverzeichnis der gleiche Laufwerksbuchstabe zugeordnet ist.
Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Verwenden eines zugeordneten Laufwerks, um ein Administrator-Installationsabbild bereitzustellen

Zur Definition eines Netzwerkspeicherorts für das Administrator-Installationsabbildverzeichnis wird ein UNC-Pfad (\\Computername\Freigabename) empfohlen. Sie können aber auch ein zugeordnetes Laufwerk als Speicherort für die Datei StartSWInstall.hta im Administrator-Installationsabbild verwenden (z. B. U:\StartSWInstall.hta). Voraussetzung ist, dass bei allen Benutzern, die Installationen ausführen, dem Administrator-Installationsabbildverzeichnis der gleiche Laufwerksbuchstabe zugeordnet ist.

Beispiel: Sie haben dem Administrator-Installationsabbildverzeichnis das Laufwerk U: zugeordnet. In diesem Fall wird die Benachrichtigungs-E-Mail die Benutzer anweisen, auf den Link zu file://U:\StartSWIOnstall.hta zu klicken. Die Installation kann nur dann erfolgreich ausgeführt werden, wenn das Laufwerk U: dem UNC-Speicherort für das Administrator-Installationsabbild (\\Computername\Freigabename) zugeordnet ist.

Übergeordnetes Thema: Bereitstellung von Installationen über den Options-Editor


Beenden des Options-Editors

Sie können auf OK oder "Schließen" klicken, um den Options-Editor zu beenden.

  • Klicken Sie auf OK, Schließen, oder verwenden Sie die Schaltfläche "Schließen" der Windows-Anwendung, um Änderungen zu übernehmen, und beenden Sie den Options-Editor.
    • Klicken Sie auf OK, um die Optionseinstellungsänderungen zu übernehmen, und beenden Sie den Options-Editor.
    • Klicken Sie auf Schließen, um den Options-Editor zu schließen.

      Wenn Änderungen vorgenommen wurden, werden Sie gefragt, ob Sie diese Änderungen speichern möchten.

    • Klicken Sie auf die Schließ-Schaltfläche (X) der Windows-Anwendung. Wenn Änderungen vorgenommen wurden, werden Sie gefragt, ob Sie diese Änderungen speichern möchten.
Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Erstellen einer Desktop-Verknüpfung zum Options-Editor

Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.

  1. Starten Sie den Options-Editor.

    Beispiel: Im Windows Explorer navigieren Sie zum Administrator-Installationsabbildverzeichnis und doppelklicken auf sldAdminOptionEditor.exe.

  2. Klicken Sie auf Desktop-Verknüpfung zu diesem Options-Editor erstellen.

    Es wird dann eine Verknüpfung zum Options-Editor für das Administrator-Installationsabbild auf dem Windows-Desktop angezeigt.

Übergeordnetes Thema: Administrator-Installationsabbild Options-Editor


Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen

Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.

Konfigurieren Sie das auf einem Computer freigegebene Administrator-Installationsabbild-Verzeichnis und auf den andere Computer zugreifen können auf einem Computer (z.B., über einen UNC-Pfad).

Sie können eine E-Mail mit einem Link an admin_image_install_dir\StartSWInstall.hta all Clients schicken. Die Clients können dann auf diesen Link klicken und dann auf SolidWorks Produkte jetzt installieren klicken, um die Installation vom Administrator-Installationsabbild aus zu starten.

Wenn Sie ein Administrator-Installationsabbild auf eine neue SolidWorks Version aktualisieren, können Sie den Administrator-Installationsabbildbereich konfigurieren und Eigenschaften freigeben, so dass Clients, die früher mit diesem Abbild installiert haben, automatisch aktualisiert werden. Einzelheiten finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.
Übergeordnetes Thema: Administrator-Installationsabbilder verwenden


Verknüpfung eines Administrator-Installationsabbildes mit Clients

Sie können einen Befehl ausführen, mit dem ein Administrator-Installationsabbild mit Clients verknüpft wird.

Bereitstellung per E-Mail ist die Methode, die im Allgemeinen verwendet wird, um Clients über eine SolidWorks Installation in Kenntnis zu setzen. Einzelheiten finden Sie unter Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen.

Als Alternative können Sie jedoch einen Befehl ausführen, um Clients von einer neuen Installation in Kenntnis zu setzen. Sie können z.B. auch Mitarbeiter benachrichtigen, die die SolidWorks Anwendung normalerweise nicht einsetzen.

Die Erstellung einer Programmverknüpfung zur SolidWorks Anwendung bedeutet, dass eine Verknüpfung zur Anwendung in das Start-Menü auf dem Computer des Anwenders platziert wird und dass eine Dateiverknüpfung mit dem Administrator-Installationsabbild auf dem Server erstellt wird. Die ausführbaren Dateien werden nicht gleich installiert. Zur Installation kommt es erst, wenn der Anwender die Anwendung zum ersten Mal benötigt.

Wenn der Anwender die Verknüpfung verwendet oder auf ein SolidWorks Dokument doppelklickt, beginnt die Installation und die SolidWorks Anwendung wird ausgeführt.

Verknüpfen von einem Administrator-Installationsabbild:

  1. Administrator-Installationsabbild erstellen und konfigurieren.
  2. Erstellen Sie auf jedem Rechner, auf dem die SolidWorks Anwendung installiert werden soll, eine Programmverknüpfung.

    Beispiel:

    msiexec /jm Pfad_zur_MSI-Datei_eines_Administrator_Installationsabbildes

    wobei Pfad_zur_MSI-Datei_eines_Administrator_Installationsabbildes ein UNC-Pfad zum Administrator-Installationsabbild-Verzeichnis ist.

Übergeordnetes Thema: Administrator-Installationsabbilder verwenden


Befehlszeilenbereitstellung

Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.

  • Administrator-Installationsabbild von einer Eingabeaufforderung erstellen
    Sie können ein Administrator-Installationsabbild erstellen, indem Sie den SolidWorks-Installations-Manager oder die MS-DOS-Eingabeaufforderung verwenden.
  • Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
    Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.
  • Mit der Befehlszeile aus dem Administrator-Abbild installieren
    Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.
  • Befehlszeileneigenschaften
    Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.
  • Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren
    Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SolidWorks Kernprodukte an Clients unterstützt.
Übergeordnetes Thema: Mehrere Installationen


Administrator-Installationsabbild von einer Eingabeaufforderung erstellen

Sie können ein Administrator-Installationsabbild erstellen, indem Sie den SolidWorks-Installations-Manager oder die MS-DOS-Eingabeaufforderung verwenden.

Wenn Sie ein Administrator-Installationsabbild von der Befehlszeile aus erstellen, müssen Sie ein separates Abbild für jedes SolidWorks Produkt erstellen und bereitstellen, indem Sie die .msi-Datei für die jeweilige Komponente ausführen. Wenn Sie eine Installation für andere Sprachen als Englisch durchführen, müssen Sie ein separates Abbild für jede Sprache erstellen und bereitstellen, indem Sie die .msi-Datei für die jeweilige Sprache ausführen. Details über Speicherorte von .msi-Dateien finden Sie unter MSI Dateipositionen für Administrator-Installationsabbilder.
  1. Öffnen Sie ein Befehlszeilen- Fenster.
    1. Klicken Sie in Windows auf Start > Ausführen.
    2. Geben Sie cmd ein, und klicken Sie anschließend auf OK.
  2. Geben Sie diesen Befehl ein:

    msiexec /a Msi_Pfad

    Die Variable Msi_Pfad steht für den Speicherort der .msi-Datei für Ihr Betriebssystem. Die SolidWorks.msi -Datei befindet sind im swwi\data Unterverzeichnis im Installationsverzeichnis.

    Beispiel:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. Befolgen Sie im SolidWorks Setup-Assistenten die Anweisungen auf dem Bildschirm.
  4. Wenn Sie SolidWorks-Produkte für andere Sprachen als Englisch installieren, erstellen Sie mit dem folgenden Befehl ein separates Administrator-Installationsabbild für die jeweilige Sprache:

    msiexec /a Msi-Pfad_für_Sprache

    Die Variable Msi-Pfad_für_Sprache steht für den Speicherort der .msi-Datei für die jeweilige Sprache. Beispiel: Die Datei french.msi befindet sind im Unterverzeichnis swwi\lang\french des Installationsverzeichnisses.

    Beispiel:

    msiexec /a F:\swwi\lang\french\french.msi

Übergeordnetes Thema: Befehlszeilenbereitstellung


Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus

Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.

Die Installation dieser Windows-Komponenten is nur dann erforderlich, wenn Sie von einem Administrator-Installationsabbild installieren, das manuell mit der Befehlszeile oder über das Microsoft Active Directory erstellt wurde. Wenn Sie den SolidWorks-Installations-Manager für die Erstellung und Installation eines Administrator-Installationsabbilds verwenden, werden diese Windows-Komponenten automatisch installiert.
Hier ist eine Zusammenfassung der Dateien, die von SolidWorks für die Windows-Komponenten erforderlich sind:
Windows Installer
Enthält Dateien, die für die Installation von SolidWorks Simulation Premium notwendig sind.
Office Web Components
Enthält COM-Steuerung, die für DriveWorks ist.
Visual C++ 2005 und 2008 Redistributable Package
Enthält die Laufzeit-Komponenten für Microsoft Visual C++.
Es müssen je die 2005 und 2008 Versionen installiert sein.
Visual Studio Tools for Applications
Umfasst ein Tool-Set zur Unterstützung von Visual Studio Anwendungen.
Visual Studio Remote Debugger
Bietet eine Debugging-Umgebung für 64-Bit-Betriebssysteme.
.NET Framework
Enthält die gemeinsamen Sprach-Laufzeit- und .NET Framework Komponenten, die für die Ausführung von .NET Framework Anwendungen erforderlich sind.
Windows Desktopsuche (optional)
Unterstützt das schnelle Durchsuchen von Dateien und Daten in verschiedenen Datenquellen und Positionen auf dem lokalen Computer und den freigegebenen Netzen.
Windows Desktop Suche-Dateien sind sprachspezifisch. Einzelheiten finden Sie unter Windows Desktopsuche - Sprachunterstützung.
Visual C++ Redistributable Package und .NET Framework 3.5 sind für alle SolidWorks Produkte, nicht nur die SolidWorks Kernprodukte, erforderlich.

Diese Komponenten müssen in die Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses mit einbezogen sein.

Die folgende Tabelle listet die Dateien auf, die für die unterstützten Betriebssysteme erforderlich sind.
Betriebssystem: Windows 2003 32-bit1
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (Nicht zutreffend)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lang.exe
Betriebssystem: Windows 2003 64-bit1
SolidWorks Datenträger 64-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Betriebssystem: Windows 2008 32-bit1
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (Nicht zutreffend)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional): |  | Die Windows-Desktop-Suche ist eine Funktion des Betriebssystems.
Betriebssystem: Windows 2008 64-bit1
SolidWorks Datenträger 64-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional): |  | Die Windows-Desktop-Suche ist eine Funktion des Betriebssystems.
Betriebssystem: Windows XP 32-bit
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (Nicht zutreffend)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional):
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lang.exe
Betriebssystem: Windows XP 64-bit
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Betriebssystem: Windows XP 64-bit
SolidWorks Datenträger 64-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Betriebssystem: Windows Vista 32-bit
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (Nicht zutreffend)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional): |  | Die Windows-Desktop-Suche ist eine Funktion des Betriebssystems.
Betriebssystem: Windows Vista 64-bit
SolidWorks Datenträger 64-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktopsuche (optional): |  | Die Windows-Desktop-Suche ist eine Funktion des Betriebssystems.
Betriebssystem: Windows 7 32-Bit
SolidWorks Datenträger 32-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (Nicht zutreffend)
 | .NET Framework: |  | .NET Framework und die Windows-Desktopsuche sind Funktionen des Betriebssystems.
 | Windows Desktopsuche (optional):
Betriebssystem: Windows 7 64-Bit
SolidWorks Datenträger 64-Bit-Version für Windows XP, Windows Vista und Windows 7
 | Windows Installer: |  | (Nicht zutreffend)
 | Office Web Komponenten: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
 | Visual Studio Tools for Applications: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework und die Windows-Desktopsuche sind Funktionen des Betriebssystems.
 | Windows Desktopsuche (optional):
1Installation auf Windows 2003 oder Windows 2008 wird nur für Workgroup PDM Server und SolidNetWork Lizenz-Server (SNL) unterstützt.
  • Windows-Voraussetzungen von der Befehlszeile auf 32-Bit-Betriebssystemen installieren
    Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile auf 32-Bit-Betriebssystemen zu installieren.
  • Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren
    Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile auf 64-Bit-Betriebssystemen zu installieren.
  • SolidWorks Suche und Microsoft Windows Desktopsuche
    SolidWorks Suche ist in Microsoft® Windows® Desktopsuche integriert.
Übergeordnetes Thema: Befehlszeilenbereitstellung


Windows-Voraussetzungen von der Befehlszeile auf 32-Bit-Betriebssystemen installieren

Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile auf 32-Bit-Betriebssystemen zu installieren.

Um mehrere Komponenten in einer Installationsoperation zu installieren, erstellen Sie eine Stapeldatei mit den Befehlen, die in den folgenden Vorgehensweisen genannt werden und verwenden Sie sie, um die Komponenten den Client-Computern zuzuweisen.

  1. Stellen Sie sicher, dass der Ziel-Computer über mindestens 290 MB freien Speicherplatz und ein gültiges TEMP-Verzeichnis verfügt.
  2. Installieren Sie Office Web Components mit dem folgenden Befehl:

    Administrator_Installationsabbild_Verzeichnis\OfficeWeb_11\owc11.exe

  3. Installieren Sie Windows Installer für Windows XP:

    Administrator_Installationsabbild_Verzeichnis\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Es ist nicht notwendig, Windows Installer auf einer anderen Version von Windows als Windows XP zu installieren.

  4. Visual C++ 2005 Redistributable Package installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Visual C++ 2008 Redistributable Package installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Installieren Sie für Windows XP und Windows Vista mithilfe von Windows Server-Aktualisierungsdienste das Microsoft .NET Framework 3.5.

    Es ist nicht erforderlich, das .NET Framework Abbild auf Windows 7 oder höher zu installieren.

  7. Visual Studio Tools for Applications installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_VSTA\vsta_aide.msi

Übergeordnetes Thema: Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus


Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren

Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile auf 64-Bit-Betriebssystemen zu installieren.

Um mehrere Komponenten in einer Installationsoperation zu installieren, erstellen Sie eine Stapeldatei mit den Befehlen, die in den folgenden Vorgehensweisen genannt werden und verwenden Sie sie, um die Komponenten den Client-Computern zuzuweisen.

  1. Stellen Sie sicher, dass der Ziel-Computer über mindestens 620 MB freien Speicherplatz und ein gültiges TEMP-Verzeichnis verfügt.
  2. Installieren Sie Office Web Components mit dem folgenden Befehl:

    Administrator_Installationsabbild_Verzeichnis\OfficeWeb_11\owc11.exe

  3. Visual C++ 2005 Redistributable Package installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Sowohl die 32-Bit- als auch die 64-Bit-Versionen dieses Pakets müssen installiert werden.

  4. Visual C++ 2008 Redistributable Package installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Sowohl die 32-Bit- als auch die 64-Bit-Versionen dieses Pakets müssen installiert werden.

  5. Installieren Sie für Windows XP und Windows Vista mithilfe von Windows Server-Aktualisierungsdienste das Microsoft .NET Framework 3.5.

    Es ist nicht erforderlich, das .NET Framework Abbild auf Windows 7 oder höher zu installieren.

  6. Visual Studio Tools for Applications installieren:

    Administrator_Installationsabbild_Verzeichnis\Microsoft_VSTA\vsta_aide.msi

  7. Visual Studio Remote Debugger installieren:

    Administrator_Installationsabbild_Verzeichnis\VSRemoteDebugger\install.exe /Q

Übergeordnetes Thema: Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus


SolidWorks Suche und Microsoft Windows Desktopsuche

SolidWorks Suche ist in Microsoft® Windows® Desktopsuche integriert.

Sie werden aufgefordert, Microsoft Windows Desktopsuche während der SolidWorks Installation zu installieren oder sie zu aktualisieren, wenn die korrekte Version nicht bereits auf Ihrem Computer installiert ist.

Wenn Sie ein Administrator-Installationsabbild erstellen, ist die Windows-Desktop-Suche nicht im Administrator-Installationsabbildverzeichnis enthalten. Microsoft Windows Desktopsuche muss auf Client-Computern, auf denen SolidWorks aus einem Administrator-Installationsabbild installiert wird, manuell installiert werden, wenn auf den Clients die SolidWorks Suche verwendet werden soll.

Übergeordnetes Thema: Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus


Mit der Befehlszeile aus dem Administrator-Abbild installieren

Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.

Still installieren:
  1. Öffnen Sie ein Eingabeaufforderungsfenster (klicken Sie in Windows auf Start > Ausführen.
  2. Geben Sie in das Fenster den Befehl msiexec.exe mit den Schaltern /i und /qb ein, und legen Sie die Eigenschaften für Optionen, die nicht Standardwerte sind, wie unten gezeigt fest.
Die einzelnen Installations-Komponenten-Befehlszeilen-Eigenschaften sind:
  • Befehlszeilen-Feature-Eigenschaften
  • Befehlszeile - Globale Eigenschaften
  • SolidWorks eDrawings Befehlszeileneigenschaften
  • SolidWorks Explorer/Workgroup PDM Befehlszeileneigenschaften
  • SolidWorks Flow Simulation Befehlszeileneigenschaften
Verwenden Sie die folgenden Beispiele als Vorlagen für eine stille Installation.
SolidWorks Client
  • SolidWorks-Kernprodukt (Englisch)
  • Zusatzanwendung Toolbox
  • Teilnahme am Feedback-Programm
  • Sprache Französisch

32-Bit-Version von SolidWorks auf 32-Bit-Betriebssystem:

msiexec /i "32-Bit-Administrator-Installationsabbild-Pfad\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

32-Bit-Version von SolidWorks auf 64-Bit-Betriebssystem:

msiexec /i "32-Bit-Administrator-Installationsabbild-Pfad\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

64-Bit-Version von SolidWorks auf 64-Bit-Betriebssystem:

msiexec /i "64-Bit-Administrator-Installationsabbild-Pfad\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

Die SolidWorks-Installationskomponente für Französisch muss separat installiert werden:
  • 32-Bit-Version:

    msiexec /i "32-Bit-Administrator-Installationsabbild-Pfad\SolidWorks French\french.msi" /qb

  • 64-Bit-Version:

    msiexec /i "64-Bit-Administrator-Installationsabbild-Pfad\SolidWorks French\french.msi" /qb

Eingaben von SolidWorks-Sprach-Komponenten-Installationsbefehlen dürfen keine Befehlszeilenargumente umfassen.
eDrawings Client
  • Leistungsprotokoll
  • Alle Features

msiexec /i "Administrator-Installationsabbild-Pfad\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer mit Workgroup PDM Zusatzanwendung
  • SolidWorks Explorer mit Workgroup PDM Zusatzanwendung

msiexec /i "Administrator-Installationsabbild-Pfad\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
Übergeordnetes Thema: Befehlszeilenbereitstellung


Befehlszeileneigenschaften

Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.

  • Befehlszeilen-Feature-Eigenschaften
    Die SolidWorks-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.
  • Befehlszeile - Globale Eigenschaften
    Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.
  • SolidWorks eDrawings Befehlszeileneigenschaften
    Diese Befehlszeileneigenschaften sind eDrawings-spezifisch.
  • SolidWorks Explorer/Workgroup PDM Befehlszeileneigenschaften
    Verwenden Sie diese Befehlszeileneigenschaften, um SolidWorks Explorer und SolidWorks Workgroup PDM bereitzustellen.
  • SolidWorks Flow Simulation Befehlszeileneigenschaften
    Diese Befehlszeileneigenschaften sind spezifisch für SolidWorks Explorer Flow Simulation .
  • MSI Dateipositionen für Administrator-Installationsabbilder
    Um Administrator-Installationsabbilder von der Befehlszeile aus zu erstellen, werden die Produkt .msi-Dateien an diesen Positionen auf dem SolidWorks-Medium abgelegt.
  • Windows Desktopsuche - Sprachunterstützung
    Windows Desktopsuche-Dateinamen enthalten Angaben zur Plattform und Sprache.
Übergeordnetes Thema: Befehlszeilenbereitstellung


Befehlszeilen-Feature-Eigenschaften

Die SolidWorks-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • Hilfedateien
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (für 32-Bit-SolidWorks auf 32-Bit-Betriebssystemen)
  • Intel_Modules_AgeiaX64 (für 32-Bit-SolidWorks auf 64-Bit-Betriebssystemen)
  • Handbücher
  • Bewegung
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
Wenn Eigenschaften für die Befehlszeilen-Installation angegeben werden:
  • olidWorks unterstützt nicht die Produktinstallation unter Verwendung der ADDSOURCE Option.
  • Bei den Eigenschaften muss die Groß- und Kleinschreibung beachtet werden. Die Befehle dürfen keine Leerzeichen oder Bindestriche enthalten und müssen durch Kommas getrennt sein.
  • SolidWorks muss definiert sein, damit die SolidWorks Anwendung korrekt installiert wird.
Übergeordnetes Thema: Befehlszeileneigenschaften


Befehlszeile - Globale Eigenschaften

Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.

Eigenschaft | Beschreibung
ENABLEPERFORMANCE Legt fest, ob die Anwendung automatisch Leistungs-E-Mails an die SolidWorks Corporation senden soll.

1 zum Senden der Leistungsangaben, 0 wenn nicht.
INSTALLDIR Installationsordner für SolidWorks.

Nur Einzelinstallationen.
INSTALLWDS Installieren Sie die SolidWorks Erweiterungen, die Microsoft Windows Desktopsuche-Engine verwenden. Weitere Informationen finden Sie unter Vorbereitung von Clients für Installationen von einem Administrator-Installationsabbild.

1 zur Installation der Erweiterungen, 0 wenn nicht.
MOTIONSERIALNUMBER | Seriennummer für das SolidWorks Motion-Produkt
OFFICEOPTION Festlegen des zu installierenden Produktpakets.
0
SolidWorks Client
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL Geben Sie ALL an, um alle derzeit installierten Funktionen zu aktualisieren.
Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Aktualisierung einer vorhandenen SolidWorks 2011 SP01-Installation auf SolidWorks 2011 SP02).
REINSTALLMODE Microsoft-Installationsprogramm-Neuinstallationsoptionen.

Beispiel: Wenn eine Installation von einer Service Pack-Version auf eine andere innerhalb derselben Hauptversion aktualisiert wird, müssen Sie REINSTALLMODE=vomus angeben.

Details zu den REINSTALLMODE-Einstellungen finden Sie in der Windows-Installationsprogramm-Dokumentation unter www.microsoft.com.

Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Aktualisierung einer vorhandenen SolidWorks 2011 SP01-Installation auf SolidWorks 2011 SP02). Geben Sie diese Eigenschaft nicht an, wenn Sie zum ersten Mal eine neue Hauptversion von SolidWorks installieren.
SERVERLIST SolidNetWork Server-Liste.
Die SolidNetWork-Serverliste ist eine Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf einem Server im Format:

xxxxx@Server_Name1; yyyyy@Server_Name2;

wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.

Nur Einzelinstallationen.
SIMULATIONSERIALNUMBER | Seriennummer für das SolidWorks Simulation-Produkt
SOLIDWORKSSERIALNUMBER | Seriennummer für das SolidWorks Produkt, das alle Zusatzanwendungen enthält.
SWMIGRATE Zu aktualisierende SolidWorks Version, wie sie in der Liste im Dialogfeld "SolidWorks Installations-Auswahl" gezeigt würde . Beispiel:

SWMIGRATE="SolidWorks 2011 SP01"

Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie von einer Service Pack-Version auf eine andere Version innerhalb derselben Hauptversion aktualisieren.
TARGETDIR Installationsordner für SolidWorks.

Nur Verwaltungsinstallationen.
TOOLBOXFOLDER Installationsordner für SolidWorks Toolbox Dateien.

Nur Einzelinstallationen.
TRANSFORMS Enthält sprachspezifische Elemente in der Form:
TRANSFORMS Nummer.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Legt fest, ob eine bestehende SolidWorks Version auf die aktuelle Version aufgerüstet werden soll.
0
Neue Installation, nicht aktualisieren
1
Aktualisierung

Nur Einzelinstallationen.

Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie von einer Service Pack-Version auf eine andere Version innerhalb derselben Hauptversion aktualisieren.
Übergeordnetes Thema: Befehlszeileneigenschaften


SolidWorks eDrawings Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind eDrawings-spezifisch.

Eigenschaft | Beschreibung
ADDLOCAL Definiert die zu installierende Teile der SolidWorks eDrawings Anwendung.

All ist die empfohlene Option.
Befehlszeilensyntax: Funktion:
Alle | Installiert alle Komponenten. Die eDrawings Anwendung sucht nach installierten SolidWorks und AutoCAD Publisher Anwendungen, um die Installation zu bestätigen.
eDrawingsViewer | Öffnen von eDrawings und anderer Dateien.
PublisherForAutoCADR14 | Erstellen von eDrawings Dateien aus der AutoCAD R14 Anwendung.
PublisherForAutoCAD2000 | Erstellen von eDrawings-Dateien aus der AutoCAD 2000-Anwendung.
PublisherForAutoCAD2004 | Erstellen von eDrawings-Dateien aus der AutoCAD 2004-Anwendung.
PublisherForAutoCAD2005 | Erstellen von eDrawings-Dateien aus der AutoCAD 2005-Anwendung.
PublisherForAutoCAD2006 | Erstellen von eDrawings-Dateien aus der AutoCAD 2006-Anwendung.
DXFDWGTranslator | Anzeige von DXF/DWG-Dateien im eDrawings Viewer.
Tastenkombinationen | Installation von Desktop-Verknüpfungen.
XML3D | Öffnen von 3DXML-Dateien im eDrawings-Viewer.
INSTALLDIR | Legt den Installationsordner für SolidWorks eDrawings fest.
LOGPERFORMANCE Legt fest, ob die Anwendung automatisch Leistungs-E-Mails an die SolidWorks Corporation senden soll.
1
Leistungsdaten senden
0
Anderes
SNLSERVER Geben Sie Anschluss@Servername für Ihren SolidNetWork Lizenz-Server ein. Verwenden Sie Semikolons zur Trennung mehrerer Anschluss@Servername -Kombinationen.

Ein Anschlussname für SNLSERVER ist nur für die SolidWorks SNL Serverkonfiguration erforderlich. Liste_von_Anschluss@Server_Zeichenketten ist eine Liste von Zeichenketten, die durch Semikolons getrennt sind, wobei sich jede Zeichenkette auf eine Anschlussnummer auf dem Server bezieht, und zwar im Format:

xxxxx@Server_Name1; yyyyy@Server_Name2;

wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema: Befehlszeileneigenschaften


SolidWorks Explorer/Workgroup PDM Befehlszeileneigenschaften

Verwenden Sie diese Befehlszeileneigenschaften, um SolidWorks Explorer und SolidWorks Workgroup PDM bereitzustellen.

Für SolidWorks Explorer/Workgroup PDM-Client:
CLIENT-Eigenschaft | Beschreibung
EXPLORERORPDM
0
Nur SolidWorks Explorer
1
Workgroup PDM features kann installiert werden
ADDLOCAL
  • Standalone
  • Kunde
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone ist der Contributor, und Client ist die SolidWorks Zusatzanwendung für SolidWorks Explorer stille Installationen.

Wenn Sie AutoCAD angeben, muss AutoCAD auf Ihrem System installiert sein. Workgroup PDM findet die entsprechende Version von AutoCAD. Sie können mehr als eine Version von AutoCAD festlegen:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 und DocMgr64 arbeiten nur mit 64-bit SolidWorks Explorer-Installationen.

INSTALLDIR | Bestimmt den Installationsordner für Workgroup PDM.
ACTIVSERIALNUMBER | Definiert die SolidWorks Seriennummer.
Für Workgroup PDM-Server
Server-Eigenschaft | Beschreibung
ADDLOCAL
  • Tresor
  • WebPortal
  • API

Wenn Sie WebPortal (den Viewer) definieren, müssen Sie auch VAULTNAME definieren.
INSTALLDIR | Bestimmt den Installationsordner für Workgroup PDM.
LICENSE_SERVER | Definiert den Namen des Computers, auf dem sich der Lizenz-Server befindet.
VAULTDATA  | Definiert den Pfad und Ordner des Tresors.
VAULTNAME | Definiert den Namen des Computers, auf dem sich der Tresor befindet.
Übergeordnetes Thema: Befehlszeileneigenschaften


SolidWorks Flow Simulation Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für SolidWorks Explorer Flow Simulation .

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER SolidWorks Flow Simulation Einzelplatzseriennummer.

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
CWUPGRADEINSTALL Aktualisiert eine bestehende Version einer bestimmten SolidWorks Flow Simulation Anwendungs-Software.
1
Aktualisieren
2
Neue Installation; Installation in ein neues Verzeichnis

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR Legt die Installation für eine bestimmte SolidWorks Flow Simulation Anwendungs-Software fest.

(Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
SOLIDWORKSPATH Gibt den Installationsordner der SolidWorks Software an.

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
TARGETDIR Legt die Installation für eine bestimmte SolidWorks Flow Simulation Anwendungs-Software fest.

(Nur Administrator-Installationsabbildungen)
Übergeordnetes Thema: Befehlszeileneigenschaften


MSI Dateipositionen für Administrator-Installationsabbilder

Um Administrator-Installationsabbilder von der Befehlszeile aus zu erstellen, werden die Produkt .msi-Dateien an diesen Positionen auf dem SolidWorks-Medium abgelegt.

Produkt | Ort des Mediums
SolidWorks (Kernprodukt, Englisch) | swwi\data\SolidWorks.msi
SolidWorks-Komponenten (nicht in Englisch) | Traditionelles Chinesisch | swwi\lang\chinese\chinese.msi
 | Vereinfachtes Chinesisch | swwi\lang\chinese-simplified\chinese-simplified.msi
 | Tschechisch | swwi\lang\czech\czech.msi
 | Französisch | swwi\lang\french\french.msi
 | Deutsch | swwi\lang\german\german.msi
 | Italienisch | swwi\lang\italian\italian.msi
 | Japanisch | swwi\lang\japanese\japanese.msi
 | Koreanisch | swwi\lang\korean\korean.msi
 | Polnisch | swwi\lang\polish\polish.msi
 | Portugiesisch (Brasilianisch) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | Russisch | swwi\lang\russian\russian.msi
 | Spanisch | swwi\lang\spanish\spanish.msi
 | Türkisch | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
SolidWorks Simulation-Produkte | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Workgroup PDM Server | pdmwserver\SolidWorks Workgroup PDM Server.msi
SolidWorks Aktivierungsassistent | swactwizard\Activation Wizard.msi
DocManager APIs | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork Lizenz-Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
Übergeordnetes Thema: Befehlszeileneigenschaften


Windows Desktopsuche - Sprachunterstützung

Windows Desktopsuche-Dateinamen enthalten Angaben zur Plattform und Sprache.

Plattform/Architektur:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32-Bit-Windows
x64 | 64-Bit-Windows
Sprache:
chs | Vereinfachtes Chinesisch
cht | Chinesisch
csy | Tschechisch
deu | Deutsch
enu | German
esn | Spanisch
fra | Französisch
ita | Italienisch
jpn | Japanisch
kor | Koreanisch
plk | Polnisch
ptb | Portugiesisch (Brasilianisch)
rus | Russisch
trk | Türkisch
Übergeordnetes Thema: Befehlszeileneigenschaften


Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren

Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SolidWorks Kernprodukte an Clients unterstützt.

Microsoft Active Directory ist ein Verzeichnisdienst zur Verwaltung von Clients und Servers in Netzwerkumgebungen. Es vereinfacht die Verwaltung, Migration und Aktivierung.

  1. Sie können ein Administrator-Installationsabbildes erstellen, indem Sie den SolidWorks Installations-Manager oder die Befehlzeile verwenden.
  2. Wenn Sie ein Administrator-Installationsabbild mit der Befehlszeile erstellt haben, sollten Sie die Windows-Installationsvoraussetzungen aus einem Administrator-Installationsabbild mittels Microsoft Active Directory installieren. Einzelheiten finden Sie unter Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren.

    Führen Sie diesen Schritt nur dann durch, wenn Sie das Abbild manuell über die Befehlszeile erstellt haben. Wenn Sie das Abbild mit dem SolidWorks Installation-Manager erstellt und installiert haben, werden alle Windows-Voraussetzungen automatisch installiert.

  3. Erstellen Sie eine Transformationsdatei, um die SolidWorks Software anzupassen:
    1. Öffnen Sie das Eingabeaufforderungsfenster.
    2. Ziehen Sie vom Ordner, in dem sich das Administrator-Installationsabbild befindet, die Datei SWCreateMST.exe in das Eingabeaufforderungsfenster.

      Der Befehl muss das folgende Format haben:

      Administrator_Installationsabbild_Verzeichnis\SWCreateMST.exe Pfad_zu_MSI_Datei_eines_Administrator_Installationsabbildes Liste_der_Eigenschaften

      Die Eigenschaften können Feature-Eigenschaften oder globale Eigenschaften sein. Details finden Sie unter Befehlszeilen-Feature-Eigenschaften und Befehlszeile - Globale Eigenschaften.

      Verwenden Sie das folgende Beispiel als Vorlagen:

      • Wenn Sie SolidWorks (32-Bit-Version) auf einem 32-Bit-Betriebssystem installieren, verwenden Sie:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@Ihr_Server"

      • Wenn Sie SolidWorks (32-Bit-Version) auf einem 64-Bit-Betriebssystem installieren, verwenden Sie:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@Ihr_Server"

      • Wenn Sie SolidWorks (64-Bit-Version) auf einem 64-Bit-Betriebssystem installieren, verwenden Sie:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@Ihr_Server"

      Die Transformdatei, SolidWorks.mst, wird in dem Ordner erstellt, der das Administrator-Installationsabbild enthält.

  4. Bearbeiten Sie in Active Directory die Richtlinie Published Apps für die Gruppe oder Gruppen, die die SolidWorks-Software aktivieren sollen.
  5. Expandieren Sie im Dialogfeld Gruppenrichtlinien die Einstellungen für Computerkonfiguration und Software.
  6. Klicken Sie mit der rechten Maustaste auf Softwareinstallation und selektieren Sie Neu > Paket.
  7. Wählen Sie das Administrator-Installationsabbild aus, und klicken Sie auf Öffnen.
  8. Wählen Sie im Dialogfeld Software bereitstellen die Option Erweiterte Methode von "Veröffentlicht" oder "Zugewiesen", und klicken Sie auf OK.
  9. Im Dialogfeld Eigenschaften von SolidWorks auf die Änderungen-Registerkarte:
    1. Klicken Sie auf Hinzufügen.
    2. Wählen Sie die .mst-Datei aus:
    3. Klicken Sie auf Öffnen .
  10. Klicken Sie auf OK.
  • Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren
    Befolgen Sie diese Anleitungen, um ein bestehendes Administrator-Installationsabbild vorzubereiten, das SolidWorks auf Client-Computern mittels Microsoft Windows Active Directory installiert.
Übergeordnetes Thema: Befehlszeilenbereitstellung


Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren

Befolgen Sie diese Anleitungen, um ein bestehendes Administrator-Installationsabbild vorzubereiten, das SolidWorks auf Client-Computern mittels Microsoft Windows Active Directory installiert.

Verwenden Sie in diesen Vorgängen den Befehl, der der SolidWorks Version, die Sie bereitstellen, entspricht.

  1. Visual C++ 2005 Redistributable Package Installationsdateien extrahieren und installieren.
    1. Führen Sie einen der folgenden Befehle aus:

      Für die 32-Bit-Versionen von Windows:

      Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_Ziel_Verzeichnis}

      Für die 64-Bit-Versionen von Windows:

      Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_Ziel_Verzeichnis}

    2. Erstellung einer Richtlinie für die Installation des Microsoft C++ 2005 weiterverteilbaren Moduls:

      {2005_C++_Ziel_Verzeichnis}\vcredist.msi –

      Für diese Installation ist keine Transformdatei erforderlich.

  2. Visual C++ 2008 Redistributable Package Installationsdateien extrahieren und installieren.
    1. Führen Sie einen der folgenden Befehle aus:

      Für die 32-Bit-Versionen von Windows:

      Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_Ziel_Verzeichnis}

      Für die 64-Bit-Versionen von Windows:

      Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_tZiel_Verzeichnis}

    2. Erstellung einer Richtlinie für die Installation des Microsoft C++ 2008 weiterverteilbaren Moduls:

      {2008_C++_Ziel_Verzeichnis}\vcredist.msi –

      Für diese Installation ist keine Transformdatei erforderlich.

  3. Installieren Sie Microsoft .NET Framework 3.5 mit den Windows Server-Aktualisierungsdiensten.

    Es ist nicht erforderlich, das .NET Framework Abbild auf Windows 7 oder höher zu installieren.

  4. Office Web Components-Dateien extrahieren und installieren.
    1. Führen Sie diesen Befehl aus:

      Administrator_Installationsabbild_Verzeichnis\OfficeWeb_11\owc11.exe /extract:{Office_Web_ Components_Verzeichnis}

    2. Erstellen einer Richtlinie für die Installation von Office Web Components:

      {Office_Web_Components_Verzeichnis}\owc11.MSI

      Für diese Installation ist keine Transformdatei erforderlich.

  5. Visual Studio Tools for Applications (VSTA) unter Erstellung dieser Richtlinie installieren:

    {Microsoft_VSTA_Verzeichnis}\vsta_aide.MSI

    Für diese Installation ist keine Transformdatei erforderlich.

  6. Den Visual Studio Remote Debugger (nur 64-Bit-Versionen) unter Erstellung dieser Richtlinie installieren:

    {Microsoft_remote_debugger_Verzeichnis}\rdbgexp.MSI

    Für diese Installation ist keine Transformdatei erforderlich.

Übergeordnetes Thema: Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren


Verwaltung von mehreren Installationen

Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.

  • Administrator-Installationsabbilder auf neue Version aktualisieren
    Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.
  • Administration von Service Pack-Produktaktualisierungen
    Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.
  • Entfernen einer Installation
    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.
Übergeordnetes Thema: Mehrere Installationen


Administrator-Installationsabbilder auf neue Version aktualisieren

Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.

Führen Sie den SolidWorks Installations-Manager vom Internet aus, damit die korrekten Dateien referenziert werden. Der SolidWorks Installations-Manager richtet sich selbst darauf aus, oder Sie führen die Aktualisierung direkt von der SolidWorks Download-Website (http://www.solidworks.com/sw/support/downloads.htm) aus.

Sobald Sie das Administrator-Installationsabbild aktualisiert haben (das eine neue Kopie des Abbilds erstellt), können Sie Clients aktualisieren, indem Sie eine Referenz auf die neue Kopie des Administrator-Installationsabbilds herstellen.

Wenn Clients eine Referenz auf die frühere Version des Administrator-Installationsabbilds über eine abgebildetes Laufwerk oder ein freigegebenes Verzeichnis hatten, könnten Sie das abgebildete Laufwerk oder das freigegebene Verzeichnis neu definieren, indem Sie den Ablageort der aktualisierten Kopie des Administrator-Installationsabbilds verwenden.
  • Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen
    SolidWorks Installations-Manager kann entdecken, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbildes benötigen.
  • Aktualisieren eines Administrator-Installationsabbildes
    Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SolidWorks Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.
  • Aktualisierung von Clients von Administrator-Installationsabbildern
    Der SolidWorks Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.
Übergeordnetes Thema: Verwaltung von mehreren Installationen


Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen

SolidWorks Installations-Manager kann entdecken, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbildes benötigen.

  1. Starten Sie den SolidWorks Installations-Manager, indem Sie eine DVD in das entsprechende Laufwerk einlegen.
  2. Klicken Sie auf dem Bildschirm Willkommen auf Administrator-Installationsabbild.
  3. Verifizieren Sie auf dem Seriennummer-Bildschirm die SolidWorks-Seriennummer.

    Der SolidWorks Installations-Manager prüft die SolidWorks Website auf Ihre lizenzierten Produkte und die verfügbaren Service Packs.

  4. Wenn der Bildschirm Neuere Version verfügbar erscheint, wählen Sie Ja, die neuere Version herunterladen und installieren: Version.

    Der SolidWorks Installations-Manager startet eine neue Sitzung, um die neuere Version zu installieren.

  5. Sollte es ein Problem mit dem Download-Ordner geben, könnte Download-Optionen erscheinen. Nehmen Sie in diesem Fall das Standardverzeichnis für die neuen Installationsdateien an oder geben Sie einen neuen Verzeichnisnamen ein.

    Wenn eine Meldung eingeblendet wird, dass das Verzeichnis nicht existiert, klicken Sie auf Ja, um das Verzeichnis zu erstellen.

  6. Klicken Sie auf dem Bildschirm Download abgeschlossen auf Schließen, um das aktuelle Installationsprogramm zu schließen und das Installationsprogramm für die neue Version zu starten.
Übergeordnetes Thema: Administrator-Installationsabbilder auf neue Version aktualisieren


Aktualisieren eines Administrator-Installationsabbildes

Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SolidWorks Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.

Dieser Vorgang setzt voraus, dass Sie alle aktualisierten Installationsdateien für das Administrator-Installationsabbild heruntergeladen haben. Einzelheiten finden Sie unter Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen.

  1. Starten Sie den SolidWorks Installations-Manager. Einzelheiten finden Sie unter SolidWorks Installation wird initiiert.
  2. Wählen Sie im Willkommens-Fenster das Administrator-Installationsabbild.

    Administrator-Installationsabbild-Optionen werden angezeigt:

    Neues Abbild mit Standardeinstellungen erstellen.
    Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der aktuellen Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen.
    Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
    Sowohl 32-Bit als auch 64-Bit-Administrator-Installationsabbilder erstellen.
    Sie können sowohl 32-Bit- als auch 64-Bit-Abbilder auf einem Computer erstellen oder Sie können einfach das Abbild erstellen, das der Computerarchitektur entspricht. Für die Erstellung beider Abbilder benötigen Sie Zugriff auf 32-Bit- und 64-Bit-Installationsmedien.

  3. Verifizieren Sie auf dem Seriennummer-Bildschirm die Seriennummer.
  4. Stellen Sie auf dem Bildschirm Zusammenfassung (Bereit zur Erstellung des Abbilds) sicher, dass die Administrator-Installationsabbildoptionen korrekt sind.

    Details über individuelle Administrator-Installationsabbild- und Installationsoptionen erhalten Sie, wenn Sie auf ÄNDERN klicken, um zur Optionsseite zu gelangen und dort auf Hilfe klicken.

  5. Klicken Sie, um die neue Version des Administrator-Installationsabbilds zu erstellen, auf Jetzt erstellen.

Jetzt können Sie Clients auf diese neue Version des Administrator-Installationsabbilds aktualisieren. Einzelheiten finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.

Übergeordnetes Thema: Administrator-Installationsabbilder auf neue Version aktualisieren


Aktualisierung von Clients von Administrator-Installationsabbildern

Der SolidWorks Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.

Normalerweise sind Administrator-Installationsabbilder in Ordnern auf einem Server organisiert. Um die automatische Aktualisierung von Clients zu unterstützen, muss sich das Administrator-Installationsabbild in einem freigegebenen Ordner befinden.

Nach der Aktualisierung des Administrator-Installationsabbilds wird sich die Original-Installation in einem Ordner befinden und die aktualisierte Installation in einem anderen Ordner. Um die aktualisierte Installation zu verwenden, entfernen Sie die Freigabeoption vom Originalordner des Administrator-Installationsabbilds und fügen Sie dann die Freigabeoption zum aktualisierten Administrator-Installationsabbild hinzu.

Wenn SolidWorks auf einem Client-Computer, der vom Original-Administrator-Installationsabbild installiert ist, gestartet wird, "sieht" die Anwendung die neue Version und aktualisiert den Client.

  • Freigabeoption vom Original-Administrator-Installationsabbildordner entfernen
    Bei der Aktualisierung eines Administrator-Installationsabbildes, auf den von einem freigegebenen Ordner aus zugegriffen wird, müssen Sie zunächst die Freigabeoption vom Originalordner des Administrator-Installationsabbilds entfernen.
  • Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen
    Sobald Sie einen aktualisierten Administrator-Installationsabbildordner erstellt und die Freigabe für den Original-Administrator-Installationsabbildordner deaktiviert haben, müssen Sie dem neuen Ordner die Freigabeoption hinzufügen, um das Administrator-Installationsabbild wieder zu aktivieren.
  • Manuelle Aktualisierung von Clients von Administrator-Installationsabbildern mit der Befehlszeile
    Sie können, sobald Sie ein Administrator-Installationsabbild aktualisiert haben, Clients manuell über die Befehlszeile aktualisieren.
Übergeordnetes Thema: Administrator-Installationsabbilder auf neue Version aktualisieren


Freigabeoption vom Original-Administrator-Installationsabbildordner entfernen

Bei der Aktualisierung eines Administrator-Installationsabbildes, auf den von einem freigegebenen Ordner aus zugegriffen wird, müssen Sie zunächst die Freigabeoption vom Originalordner des Administrator-Installationsabbilds entfernen.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Wählen Sie auf dem Register Freigeben und wählen Sie dann Diesen Ordner nicht freigeben, klicken Sie dann auf OK.

Fügen Sie jetzt die Freigabeoption dem aktualisierten Ordner des Administrator-Installationsabbilds wie in Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügenbeschrieben zu.

Übergeordnetes Thema: Aktualisierung von Clients von Administrator-Installationsabbildern


Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen

Sobald Sie einen aktualisierten Administrator-Installationsabbildordner erstellt und die Freigabe für den Original-Administrator-Installationsabbildordner deaktiviert haben, müssen Sie dem neuen Ordner die Freigabeoption hinzufügen, um das Administrator-Installationsabbild wieder zu aktivieren.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des aktualisierten Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Definieren Sie auf der Registerkarte Freigabe die Freigabeeigenschaften für Ihr Unternehmen oder Ihre Gruppe, und ändern Sie den Freigabenamen in den Namen, der für die Original-Administrator-Installationsabbild-Ordner verwendet wird.
Computer die vom ursprünglichen Administrator-Installationsimage-Freigabepfad aus installiert wurden werden automatisch beim nächsten Start von SolidWorks auf die neue Version aktualisiert.
Übergeordnetes Thema: Aktualisierung von Clients von Administrator-Installationsabbildern


Manuelle Aktualisierung von Clients von Administrator-Installationsabbildern mit der Befehlszeile

Sie können, sobald Sie ein Administrator-Installationsabbild aktualisiert haben, Clients manuell über die Befehlszeile aktualisieren.

  1. Stellen Sie sicher, dass alle Clients denselben Service Pack der vorherigen Version besitzen. (Clients, bei denen die Anwendung nicht bereits installiert war werden nicht aktualisiert.)
  2. Führen Sie bei Bedarf auf einem der Client-Systeme den Assistenten zur Kopie der Anwendereinstellungen aus, um die aktuellen SolidWorks Optionen zu übernehmen.
  3. Sie können ein neues Administrator-Installationsabbildes erstellen, indem Sie den SolidWorks Installations-Manager oder die Befehlzeile verwenden.

    Aktualisieren oder überschreiben Sie das alte Bild nicht.
    Wenn Sie eine Nicht-Englisch-SolidWorks-Installation aktualisieren, müssen Sie ein neues Administrator-Installationsabbild für die Nicht-Englisch-Installationskomponente erstellen.

  4. Aktualisieren Sie alle Clients auf die neue Version mit dem folgenden Befehl msiexec, mit diesen Spezifikationen:

    • Geben Sie auch die /I and qb msiexec Befehlszeilen-Optionen ein.
    • Spezifizieren Sie alle erforderlichen Eigenschaften und globale Befehlszeileneigenschaften. Einzelheiten finden Sie unter Befehlszeileneigenschaften.

    Befehlsbeispiel zur Aktualisierung einer bestehenden Version von SolidWorks:

    msiexec /I Msi_Pfad" INSTALLDIR="C:\Program Files\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks Version Service Pack" /qb

    Wenn Sie eine Nicht-Englisch-SolidWorks-Installation aktualisieren, müssen Sie die Nicht-Englisch-Installationskomponente aktualisieren, nachdem Sie die SolidWorks-Komponenten aktualisiert haben.

Übergeordnetes Thema: Aktualisierung von Clients von Administrator-Installationsabbildern


Administration von Service Pack-Produktaktualisierungen

Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.

Sie können Produktaktualisierungen auf zwei verschiedene Arten erhalten:

Für aktuelle SolidWorks Versionen:
Über die Verwendung des SolidWorks Installations-Managers für die Suche nach, den Download und die Installation von Aktualisierungen.

Sie können den SolidWorks Installations-Manager manuell initiieren oder einen Zeitplan für eine periodische Überprüfung nach Aktualisierungen festlegen.

Für SolidWorks Versionen vor 2008:
Durch manuelles Downloaden der Service Packs von der SolidWorks Website.

Service Packs werden als Patches auf die bestehende Software-Version angewendet. So ist SolidWorks 2007 SP1.0 ein Service Pack für SolidWorks 2007 SP0.0. Sie können diese Service Packs mit dem SolidWorks 2007 Installations-Manager installieren, nicht jedoch mit dem Installations-Manager in SolidWorks 2008 oder höher.

Anleitungen zum Download und der Installation von Service Packs finden Sie in der Installationsdokumentation für die SolidWorks Version, die Sie aktualisieren.

  • Zurücksetzen von Service Packs in einem Administrator-Installationsabbild
    Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SolidWorks Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.
  • Anwenden von Service Packs auf Clients, die mit Microsoft Active Directory aktualisiert wurden
    Wenn Sie die SolidWorks Software mit Microsoft Active Directory installiert haben, können Sie Service Packs auf Clients anwenden.
Übergeordnetes Thema: Verwaltung von mehreren Installationen


Zurücksetzen von Service Packs in einem Administrator-Installationsabbild

Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SolidWorks Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.

Administrator-Installationsabbilder, die aktualisiert wurden, können nicht auf ein früheres Service Pack zurückgesetzt werden. Administrator-Installationsabbilder, die mit einer anderen Methode als dem SolidWorks Installations-Manager erstellt wurden, können nicht auf eine frühere Version zurückgesetzt werden. Clients, die von einem Administrator-Installationsabbild installiert wurden müssen von einem Administrator-Installationsabbild einer früheren Version aus deinstalliert und wieder installiert werden.
  1. Löschen Sie den Ordner, der das aktuelle Administrator-Installationsabbild enthält. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:

    rmdir /s/q Pfad_zu_aktuellem_Administrator_Installationsabbild

  2. Verschieben Sie die Sicherungskopie des Administrator-Installationsabbildes an den Ort, an dem Sie das aktuelle Administrator-Installationsabbild gelöscht haben. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:

    move Pfad_zu_gesichertem_Administrator_Installationsabbild Pfad_zu_aktuellem_Administrator_Installationsabbild

    Nach der Zurücksetzung eines Administrator-Installationsabbildes werden Client-Computer automatisch beim nächsten Ausführen der SolidWorks Software zurückgesetzt.

Übergeordnetes Thema: Administration von Service Pack-Produktaktualisierungen


Anwenden von Service Packs auf Clients, die mit Microsoft Active Directory aktualisiert wurden

Wenn Sie die SolidWorks Software mit Microsoft Active Directory installiert haben, können Sie Service Packs auf Clients anwenden.

  1. Kopieren Sie das Administrator-Installationsabbild in einen neuen Ordner, indem Sie die folgende Befehlszeile verwenden:

    xcopy Pfad_zu_aktuellem_Administrator_Installationsabbild Pfad_zu_gesichertem_Administator_Installationsabbild /s/i/v

  2. Wenden Sie das Service Pack auf die Kopie des Administrator-Installationsabbildes an.
  3. Erstellen Sie eine neue Transformationsdatei, um eine Upgrade-Installation für die SolidWorks Software festzulegen:
    1. Öffnen Sie das Eingabeaufforderungsfenster.
    2. Ziehen Sie vom Ordner, in dem sich das Administrator-Installationsabbild befindet, die Datei SWCreateMST.exe in das Fenster "Eingabeaufforderung".

      Das Befehlsformat ist:

      Pfad_zu_Administrator-Installationsabbild\SWCreateMST.exe Pfad_zur_MSI_Datei_eines_Administrator-Installationsabbilds Liste_der_Eigenschaften

      Die Befehlszeile muss alle Parameter enthalten, die für die Erstellung der ursprünglichen Transformationsdatei verwendet wurden, sowie die globalen Eingenschaften UPGRADESWINSTALL und SWMIGRATE.

      Wenn z. B. der ursprüngliche Befehl folgendermaßen lautete:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@Ihr_Server

      dann muss der Aktualisierungsbefehl folgendermaßen lauten:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@your_server UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks Version Service_Pack"

      Die Transformdatei, SolidWorks.mst, wird in dem Ordner erstellt, der das Administrator-Installationsabbild enthält.

      Die Original- und Aktualisierungsbefehle in diesem Beispiel sind für die Installation der 32-Bit-Version von SolidWorks auf einem 32-Bit-Betriebssystem gedacht. Wenn Sie die 32-Bit-Version von SolidWorks auf einem 64-Bit-Betriebssystem installieren, verwenden Sie "Intel_Modules_AgeiaX64" anstatt "Intel_Modules_AgeiaX86". Wenn Sie die 64-Bit-Version von SolidWorks auf einem 64-Bit-Betriebssystem installieren, verwenden Sie weder Intel_Modules_AgeiaX86” noch “Intel_Modules_AgeiaX64".

  4. Bearbeiten Sie in Active Directory die Richtlinie Published Apps für die Gruppe oder Gruppen, die die SolidWorks Software bereitstellen sollen.
  5. Expandieren Sie in der Dialogbox Gruppenrichtlinien die Computerkonfigurations- und Software-Einstellungen.
  6. Klicken Sie mit der rechten Maustaste auf Software-Installation und wählen Sie Neu > Paket.
  7. Wählen Sie das Administrator-Installationsabbild aus, und klicken Sie auf Öffnen.
  8. Wählen Sie im Dialogfeld Software bereitstellen die Option Erweiterte Methode von "Veröffentlicht" oder "Zugewiesen", und klicken Sie auf OK.
  9. Im Dialogfeld Eigenschaften von SolidWorks auf der Registerkarte Änderungen:
    1. Klicken Sie auf Hinzufügen.
    2. Wählen Sie die .mst-Datei aus:
    3. Klicken Sie auf Öffnen.
  10. Klicken Sie auf OK .
Übergeordnetes Thema: Administration von Service Pack-Produktaktualisierungen


Workgroup PDM

Die Workgroup PDM Anwendung ist ein Programm für die Produktdatenverwaltung, das innerhalb der SolidWorks Software oder als eine eigenständige Anwendung in SolidWorks Explorer ausgeführt wird. Mit Workgroup PDM können Sie für Projekte das Ein- und Auschecken, die Versionskontrolle und andere verwaltungstechnische Aufgaben steuern.

Ein Workgroup PDM System kann folgendermaßen dargestellt werden:

  • Ein Computer kann nur einen Tresor haben.
  • Das Tresorverzeichnis kann nicht ausgeblendet oder schreibgeschützt sein.
  • Als eine Client-/Server-Anwendung hängt die Leistung von Workgroup PDM von der Leistungsfähigkeit des Netzes ab.
  • Wenn Ihre Anwender über eine Vielzahl von Dokumenten verfügen, kann die Leistung verbessert werden, indem Sie mehr Projekte oder Unterprojekte mit weniger Dokumenten pro Projekt erstellen, anstatt die Dokumente in weniger Projekten mit mehr Dokumenten pro Projekt abzulegen.

Installation

  • Clients und VaultAdmin, API und Viewer können auf demselben Computer wie der Tresor oder auf anderen Computern installiert werden.
  • Es ist nicht erforderlich, Workgroup PDM Server zu installieren, um das Client-API installieren zu können. Das Client-API wird während der Workgroup PDM Client Installation installiert.
  • Wenn Sie den Tresor-Ordner an einem externen Standort konfigurieren, geben Sie den vollständigen UNC-Pfad (Universal Naming Convention) ein, wenn Sie nach dem Zielordner des Servers gefragt werden. (Details finden Sie unter UNC-Format.)
  • Die Installierung oder Aktualisierung des Tresores erfordert einen Computer-Neustart.
  • Wenn der Workgroup PDM Server-Dienst nach einem Neustart nicht automatisch startet, müssen Sie ihn manuell starten. Führen Sie in Windows Explorerpdmwvault.exe im Ordner Installationsverzeichnis\SolidWorks Workgroup PDM\Tresor aus.
  • Wenn Sie eine Workgroup PDM Client-Anwendung installieren, müssen Soe auf jedem Computer die Datei solidworksexplorer.exe installieren. Diese ausführbare Datei kann sich auch auf einem freigegebenen Laufwerk befinden. Der Workgroup PDM Tresor, Viewer, API Client, und VaultAdmin werden nicht auf jedem Client-Computer installiert.

Lizenzen

  • Eine Lizenz für Workgroup PDM API ist in die Lizenzen für SolidWorks Clients und Explorer Clients integriert. Für APIs zum Einchecken sind Client-Lizenzen erforderlich.
  • Eine Workgroup PDM Viewer Lizenz muss mit dem Tresor installiert sein, damit der Viewer aktiviert werden kann.

Berechtigungen

  • Der Tresor-Administrator sollte Schreibberechtigung für die Installation und für die Tresor-Daten haben.
  • Der Tresor-Administrator sollte den Tresor-Ordner von VaultAdmin, nicht von Windows Explorer verwalten.
  • Anwender sollte niemals Schreibberechtigung in Windows Explorer für den Tresor-Ordner haben.

Sicherheit, Anschlüsse und Duplex-Einstellungen

  • Workgroup PDM muss als ein Windows Dienst installiert werden, damit andere Anwendungen den Dienst nicht blockieren oder filtern können. Wenn z. B. Anti-Spyware-Anwendungen wie Microsoft AntiSpyware eine Warnung, die eine Zustimmung erfordert, während des Installationsvorganges anzeigen, klicken Sie auf Zulassen, damit der Workgroup PDM Server als ein Windows Dienst installiert wird.
  • Wenn Sie Workgroup PDM auf Windows XP mit Service Pack 2, einem Windows 2003 Server mit Service Pack 1 oder einem Computer mit einer aktiven Firewall installieren, müssen Sie Workgroup PDM Anschlüsse im Firewall Setup aktivieren.

    In der Regel sind die Standardanschlüsse wie folgt:

    • 20000 (VaultAdmin)
    • 30000 (Daten)
    • 40000 (Anforderung)
    • 80 (Viewer)
    Informationen über das Ändern von Anschlusseinstellungen finden Sie in Problembehebung für Tresor-Administratoren in der Workgroup PDM und SolidWorks Explorer Hilfe und der Microsoft Windows-Hilfe für das Sicherheitscenterr. Um Workgroup PDM Vault und Viewer gleichzeitig zu installieren, verwenden Sie die Option Benutzerdefiniert im Dialogfeld Installationsart.
  • Die Duplexeinstellung für die Server und ihre entsprechenden Anschlüssen sollte die gleiche sein; beide sollten z.B 100MB Full or beide sollten Auto sein.

SolidWorks Toolbox-Dokumente

SolidWorks Toolbox Dokumente sind übliche Maschinenelementkomponenten, für die normalerweise keine Versionskontrolle erforderlich ist. Sie werden nicht in den Workgroup PDM Tresor eingecheckt. Genauere Information über die Konfiguration von SolidWorks Toolbox und anderen Normbibliotheken finden Sie in der Workgroup PDM Online-Hilfe.

  • Workgroup PDM Viewer
    Unter Verwendung von Microsoft Internet Information Services (IIS) richtet die Workgroup PDM Software während der Installation automatisch ein virtuelles Verzeichnis ein.
  • Workgroup PDM Server installieren
    Mit der Installation von Workgroup PDM Server wird ein Workgroup PDM Tresor erstellt, der die Datenbank für die verwalteten SolidWorks Projekte ist.
  • Workgroup PDM für Clients konfigurieren
    Nach der Installation des Workgroup PDM Server-Tresors kann der Tresor für Clients konfiguriert werden.
  • Installieren von Workgroup PDM Server und Viewer in einem Umkreis-Netzwerk
    Die Installation eines SolidWorks Workgroup PDM Webserver und Workgroup PDM Viewers in einem Umkreis-Netzwerk (DMZ) hat Firewall-Implikationen.
  • Workgroup PDM Client-Zugriff
    Workgroup PDM-Clients verwenden Microsoft Windows-Anmeldezugriffssteuerung, haben Zugriff auf das Intenet über den Workgroup PDM-Viewer und werden jedesmal automatisch aktualisiert, wenn der Workgroup PDM-Tresor aktualisiert wurde.
  • Workgroup PDM VaultAdmin Administration
    Nach der Installation von Workgroup PDM sollten Tresoradministratoren Folgendes tun:


Workgroup PDM Viewer

Unter Verwendung von Microsoft Internet Information Services (IIS) richtet die Workgroup PDM Software während der Installation automatisch ein virtuelles Verzeichnis ein.

Sie müssen Microsoft Internet Information Services (IIS) installieren, bevor Sie den Viewer installieren.
Benötigt werden folgende Komponenten:
  • Web Management Tools
    • IIS Management Console
  • World Wide Web Services: Application Development Features
    • .NET Extensibility
    • ASP.NET
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
IIS-Installationsanleitungen finden Sie in der Microsoft-Dokumentation.
Die Workgroup PDM Viewer-Installation unterleigt diesen Beschränkungen:
  • Das Verzeichnis Web Site Content Directory ist der Viewer Installationsordner.
  • Sie dürfen keine Unterstriche im Rechnernamen verwenden, der der Host-Computer für den Viewer ist.
  • Wenn Sie den Viewer auf Windows XP Service Pack 2 installieren, müssen Sie einen Anschluss in der Windows Firewall für HTTP (Anschluss 80) aktivieren.
  • Der Viewer kann jeweils nur mit einem Tresor verbunden sein.

Benutzer greifen auf den Workgroup PDM Viewer zu, indem Sie die folgende URL in das Adressenfeld von Internet Explorer eingeben:

http://ViewerComputerName/pdmweb/

Übergeordnetes Thema: Workgroup PDM


Workgroup PDM Server installieren

Mit der Installation von Workgroup PDM Server wird ein Workgroup PDM Tresor erstellt, der die Datenbank für die verwalteten SolidWorks Projekte ist.

  1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
  2. Wählen Sie auf dem Willkommen-Bildschirm Folgendes aus:

    • Server-Produkte
    • SolidWorks Workgroup PDM Server (Tresor) auf diesem Computer installieren.

  3. Kicken Sie auf dem Bildschirm Zusammenfassung auf Ändern, um einen Validierungscode zu erhalten. Sie erhalten den Code auf eine der folgenden Methoden:
    • Internetverbindung
      1. Geben Sie die Felder die SolidWorks Seriennummer und eine E-Mail-Adresse ein.
      2. Wählen Sie Automatisch validieren und klicken Sie auf Code abrufen.
    • E-Mail
      1. Wenn Ihr Computer keinen Zugriff auf Internet hat, klicken Sie auf Manuell per E-Mail validieren. Der Installations-Manager generiert eine Validierungs-Anforderungsdatei.
      2. Klicken Sie auf Speichern, um die Datei lokal auf dem System zu speichern.
      3. Folgen Sie den Anweisungen auf dem Bildschirm, und geben Sie den Validierungscode ein.
  4. Klicken Sie auf Zurück zu Übersicht.
  5. Klicken Sie auf dem Bildschirm Zusammenfassung auf Jetzt installieren.
Übergeordnetes Thema: Workgroup PDM


Workgroup PDM für Clients konfigurieren

Nach der Installation des Workgroup PDM Server-Tresors kann der Tresor für Clients konfiguriert werden.

  1. Melden Sie sich bei VaultAdmin (installiert mit SolidWorks Explorer) mit dem Standard-Anwendernamen und Passwort an.
  2. Erstellen Sie in VaultAdmin Anwender- und Gruppenkonten, Projektordner, Berechtigungen etc.

    Siehe Anleitungen in der SolidWorks Workgroup PDM Hilfe:

  3. E-Mailen Sie Client-Anwendern den Server-Computer-Namen und ihre Anwendernamen und Passwörter, die sich für gewöhnlich von den Microsoft Windows Anwendernamen und Passwörtern unterscheiden.
  • Workgroup PDM Viewer konfigurieren, um ein Verbindung mit einem anderen Tresorspeicherort herzustellen
    Sie können über die Windows Registrierung den Workgroup PDM Viewer konfigurieren, um ein Verbindung mit einem anderen Tresorspeicherort herzustellen.
  • Mime-Typen für das Herunterladen von Dokumenten konfigurieren
    Sie können Mime-Typen für das Herunterladen von Dokumenten über Windows Registrierungseinstellungen konfigurieren.
Übergeordnetes Thema: Workgroup PDM


Workgroup PDM Viewer konfigurieren, um ein Verbindung mit einem anderen Tresorspeicherort herzustellen

Sie können über die Windows Registrierung den Workgroup PDM Viewer konfigurieren, um ein Verbindung mit einem anderen Tresorspeicherort herzustellen.

  1. Aktualisieren Sie den Registrierungspfad, indem Sie den Wert für den Tresor-Computer ändern.

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Workgroup PDM Viewer wieder installieren. Geben Sie in das Dialogfeld Tresor-Computer-Name den neuen Computer-Namen ein.
Übergeordnetes Thema: Workgroup PDM für Clients konfigurieren


Mime-Typen für das Herunterladen von Dokumenten konfigurieren

Sie können Mime-Typen für das Herunterladen von Dokumenten über Windows Registrierungseinstellungen konfigurieren.

Standardmäßig sendet der Viewer Abfragen nach offenen Dokumenten mit dem generischen Mime-Typ "application/octet-stream." Microsoft Internet Explorer öffnet dann das angeforderte Dokument mit der angegebenen Dateinamenerweiterung. Sie können zusätzliche Mime-Typen abbilden oder Mime-Typ-Abbildungen ausschalten, indem Sie den Mime-Typen Registrierungsunterschlüssel in der Windows Registrierung modifizieren.

  • Erstellen Sie, um zusätzliche Mime-Typen abzubilden, zusätzliche Stringwerte unter diesem Registrierungsunterschlüssel:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    in folgender Form:

    "ext" = "Mime-Typ"

    Beispiel:

    "dxf" = "image/vnd.dxf"

    Bevor Sie die Werte hinzufügen, müssen Sie diesen Unterschlüssel in der Registrierung manuell erstellen.

    Ändern Sie, um Mime-Tup-Abbildungen abzuschalten, den Use Custom MIME Types Registrierungswert auf 0 (Null zero).

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Ein Neustart des Webservers ist für eine Aktivierung dieser Einstellung nicht erforderlich.

Übergeordnetes Thema: Workgroup PDM für Clients konfigurieren


Installieren von Workgroup PDM Server und Viewer in einem Umkreis-Netzwerk

Die Installation eines SolidWorks Workgroup PDM Webserver und Workgroup PDM Viewers in einem Umkreis-Netzwerk (DMZ) hat Firewall-Implikationen.

Da Workgroup PDM Viewer Clientsmit dem Webserver über die HTTP- oder HTTPS-Anschlüsse kommunizieren, müssen diese Anschlüsse auf dem Internet Information Server-System (IIS), auf dem der Webserver installiert ist, öffen sein.

  • Für das HTTP-Protokoll ist der Standardanschluss 80.
  • Für das HTTPS-Protokoll (SSL) ist der Standardanschluss 443.

Die Web Viewer Clients selbst brauche keine Firewall-Ausnahmen.

Sie müssen sicher stellen, dass das Webserver-System den Tresor-Server über die folgenden Standardanschlüsse erreichen kann:

  • 30000 (Daten)
  • 40000 (Anforderung)
  • Netzwerk-Konfiguration für Workgroup PDM Viewer in einem Umkreis-Netzwerk
    Die Netzwerk-Konfiguration zeigt einen Umkreis-Netzwerk-Server, der auf einem Umkreis-Subnetz eingerichtet ist, und seine Kommunikation mit den internen und externen Netzwerken.
  • Installieren und Konfigurieren des Workgroup PDM Webservers und Viewers
    Wenn Sie einen Workgroup PDM Webserver in einem Umkreisnetzwerk einrichten, ist der Installationsort der Komponenten von Bedeutung.
Übergeordnetes Thema: Workgroup PDM


Netzwerk-Konfiguration für Workgroup PDM Viewer in einem Umkreis-Netzwerk

Die Netzwerk-Konfiguration zeigt einen Umkreis-Netzwerk-Server, der auf einem Umkreis-Subnetz eingerichtet ist, und seine Kommunikation mit den internen und externen Netzwerken.

Der Umkreis-Netzwerk-Server kommuniziert mit dem LAN über eine interne Firewall. Er kommuniziert mit dem externen Netzwerk über eine externe Firewall, einen Router und einem Cluster von Lastenausgleichsmodulen.

Der Internet Explorer Client stellt eine Verbindung zum Workgroup PDM Viewer/IIS-Server über den Anschluss 80 her (oder 443, wenn die Verwendung eines SSL konfiguriert ist). Der Workgroup PDM Viewer stellt dann über die Anschlüsse 30000 oder 40000 eine Verbindung zum Tresor-Server her. Der Tresor-Server sendet die angeforderte Informationen zurück zum Workgroup PDM Viewer, der dann die Informationen zurück an den Internet Explorer Client sendet.

Der Umkreis-Netzwerk-Webserver hat zwei IP-Adressen:

  • Die interne IP-Adresse auf dem LAN
  • Die öffentliche IP-Adresse, die vom Internet-Anbieter zur Verfügung gestellt wird

Der Webserver im Umkreis-Netzwerk befindet sich hinter einem Cluster von Lastenausgleichsmodulen. Obwohl Sie für administrative Aufgaben direkt zum Webserver gelangen können, wird der gesamte Webservices-Verkehr zu den Servern im Umkreis-Netzwerk über die Lastenausgleichsmodule geleitet.

Die Lastenausgleichsmodule übertragen die Server-Hardware-IP-Adresse an eine virtuelle IP (VIP) auf jenem Netzwerkteil, der öffentlich ist. Wenn Sie entweder zur VIP oder der Webserver-URL gehen, während Sie sich auf dem Netzwerk befinden, können Sie die Site sehen.

Die externe Firewall überträgt die VIP des Lastenausgleichsmoduls auf eine öffentliche, weiterleitbare Adresse.

Übergeordnetes Thema: Installieren von Workgroup PDM Server und Viewer in einem Umkreis-Netzwerk


Installieren und Konfigurieren des Workgroup PDM Webservers und Viewers

Wenn Sie einen Workgroup PDM Webserver in einem Umkreisnetzwerk einrichten, ist der Installationsort der Komponenten von Bedeutung.
  • Installieren Sie den IIS-aktivierten Webserver auf dem Umkreis-Subnetz.
  • Installieren Sie den IIS-aktivierten Workgroup PDM Viewer auf dem Umkreis-Subnetz.
  • Installieren Sie den Workgroup PDM Tresor auf der primären Domäne oder dem internen Netzwerk au fdem lokalen Intranet.

Die Voraussetzungen für das Installieren und Konfigurieren des Workgroup PDM Viewer in einem Umkreisnetzwerk sind:

  • Microsoft IIS 6.0 oder höher
  • Eine öffentliche IP-Adresse auf dem Webserver auf dem Umkreis-Subnetz, zugewiesen von Ihrem Internet-Anbieter

Installieren und konfigurieren der Workgroup PDM Komponenten:

  1. Installieren Sie Microsoft IIS auf dem Umkreis-Subnetz-Server-System.
  2. Führen Sie zwei SolidWorks Workgroup PDM Server-Installationen aus:
    1. Installieren Sie zunächst die Tresorkomponente auf dem Tresor-Server.
    2. Führen Sie das Installationsprogramm ein zweites Mal aus, und installieren Sie die Workgroup PDM Viewer und Viewer Lizenzkomponenten auf dem IIS-Webserver. Geben Sie den Tresor-Server-Computer-Namen ein, damit das Webportal weiß, wo der Tresor-Server-Dienst zu suchen ist.

    Wenn Sie die Installation ausführen, wird die PDMWeb Anwendung automatisch zur Standard-IIS-Website hinzugefügt.

  3. Stellen Sie sicher, dass die Firewall zum internen Netzwerk die Anschlüsse 30000 und 40000 geöffnet hat.
  4. Wenn der interne Server eine fixe IP-Adresse hat, bearbeiten Sie auf dem Umkreis-Server-System die Datei C:\Windows\system32\drivers\etc\hosts.. Erstellen Sie einen Systemnamen für die IP-Adressenabbildung, damit der Umkreis-Server mit dem internen Server kommunizieren kann:
    1. Öffnen Sie die hosts-Datei in einem Texteditor wie Editor.
    2. Fügen Sie eine neue Zeile für die Tresor-Server-IP-Adresse und den Namen hinzu.
    3. Speichern Sie die hosts-Datei.
Übergeordnetes Thema: Installieren von Workgroup PDM Server und Viewer in einem Umkreis-Netzwerk


Workgroup PDM Client-Zugriff

Workgroup PDM-Clients verwenden Microsoft Windows-Anmeldezugriffssteuerung, haben Zugriff auf das Intenet über den Workgroup PDM-Viewer und werden jedesmal automatisch aktualisiert, wenn der Workgroup PDM-Tresor aktualisiert wurde.

Anmelden als Workgroup PDM Client: | Client Benutzernamen und Passwörter sind in Workgroup PDM nicht dieselben wie für die Microsoft Windows Anmeldung. Wenn Sie Anmeldeinformationen benötigen, wenden Sie sich an Ihren Systemadministrator.
Mit dem Workgroup PDM Viewer verbinden: | Fragen Sie Ihren Systemadministrator nach der URL, die für die Herstellung einer Verbindung zum Viewer erforderlich ist.
Workgroup PDM Clients aktualisieren: | Die Workgroup PDM Client-Anwendungen (SolidWorks Zusatzanwendung und Contributor) erkennen eine Aktualisierung des Tresors. Sie brauchen kein Service Pack herunterzuladen, um Client-Anwendungen zu aktualisieren.
Übergeordnetes Thema: Workgroup PDM


Workgroup PDM VaultAdmin Administration

Nach der Installation von Workgroup PDM sollten Tresoradministratoren Folgendes tun:

  • Sich bei VaultAdmin anmelden
  • Das Tresoradministrator-Passwort ändern.
  • Anwenderkonten erstellen.
  • Anwender über deren Kontonamen und -passwort informieren.

Details dazu finden Sie in SolidWorks Workgroup PDM in der SolidWorks Haupthilfe.

  • Erste Anmeldung zur Workgroup PDM VaultAdmin
    Spezifizieren Sie nach der ersten Anmeldung zum Workgroup PDM VaultAdmin, den Workgroup PDM-Administrator-Namen und das Passwort, und den Namen des Computers, auf dem sich der Workgroup PDM-Tresor lbefindet.
  • Aktualisierung des PDM Tresor-Servers
    Der Workgroup PDM Tresor-Server kann mit der SolidWorks-Funktion "Nach Aktualisierungen suchen" aktualisiert werden, oder mittels einer SolidWorks Installations-DVD oder einer Workgroup PDM-Aktualisierungsdatei, die manuell in einen lokalen Ordner heruntergeladen wurde.
  • Workgroup PDM Clients aktualisieren
    Clients werden bei der ersten Anmeldung nach der Tresoraktualisierung zur Aktualisierung aufgefordert. Zum Aktualisieren von Clients ist kein Service Pack erforderlich.
Übergeordnetes Thema: Workgroup PDM


Erste Anmeldung zur Workgroup PDM VaultAdmin

Spezifizieren Sie nach der ersten Anmeldung zum Workgroup PDM VaultAdmin, den Workgroup PDM-Administrator-Namen und das Passwort, und den Namen des Computers, auf dem sich der Workgroup PDM-Tresor lbefindet.

  1. Klicken Sie in Windows aufStart > Alle Programme > SolidWorks Version > Workgroup PDM VaultAdmin.
  2. Geben Sie in das Dialogfeld die folgenden Informationen ein:

    Name | pdmwadmin
    Passwort | pdmwadmin
    Tresor-Computer | Der Hostname des Computers, auf dem der Tresor installiert ist. Wenn Sie VaultAdmin auf dem Computer ausführen, auf dem Vault installiert ist, geben Sie localhost ein.

  3. Klicken Sie auf Anmelden.
Aus Sicherheitsgründen empfehlen wir, das Administratorkennwort so schnell wie möglich zu ändern. Wählen Sie in VaultAdmin die Registerkarte Benutzer und Gruppen.
Übergeordnetes Thema: Workgroup PDM VaultAdmin Administration


Aktualisierung des PDM Tresor-Servers

Der Workgroup PDM Tresor-Server kann mit der SolidWorks-Funktion "Nach Aktualisierungen suchen" aktualisiert werden, oder mittels einer SolidWorks Installations-DVD oder einer Workgroup PDM-Aktualisierungsdatei, die manuell in einen lokalen Ordner heruntergeladen wurde.

Sie können nur eine Version von Workgroup PDM Tresor-Server auf einen Computer installieren.
  1. Bitten Sie alle Anwender, sich vom Workgroup PDM Tresor abzumelden und sperren Sie ihn dann.
  2. Erstellen Sie eine Sicherungskopie der Tresordaten.
  3. Verwenden Sie die Systemsteuerung von Microsoft Windows Software, um die aktuelle Version von Workgroup PDM Server zu entfernen.
  4. Installieren Sie die neue Version von Workgroup PDM Server.
    • Verwenden der SolidWorks-Funktion "Nach Aktualisierungen suchen":
      1. Klicken Sie in Windows auf Start > Alle Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen.
      2. Klicken Sie im Dialogfeld Neuere Version verfügbar? auf Eine neue Version herunterladen und installieren, und wählen Sie die zu installierende Version und klicken Sie dann auf Weiter.

        The neue Version des SolidWorks Installations-Managers wird heruntergeladen und ausgeführt.

    • Um eine Installation mittels einer SolidWorks-Installations-DVD durchzuführen, schieben Sie die DVD in das Laufwerk und befolgen Sie die Anweisungen des SolidWorks Installations-Managers.
    • Um eine Installation mittels einer manuell heruntergeladenen Workgroup PDM Installationsdatei (pdmwserver.exe) durchzuführen, doppelklicken Sie auf die Datei und befolgen Sie dann die Anweisungen des zur Aktualisierung des Workgroup PDM Servers.
  5. Verwenden Sie den SolidWorks Task Scheduler, um die Workgroup PDM Dateien im Tresor zu aktualisieren.
  6. Heben Sie die Sperrung des Tresors auf, und benachrichtigen Sie die Anwender, das er nun wieder verwendet werden kann.
Übergeordnetes Thema: Workgroup PDM VaultAdmin Administration


Lizenz-Administration

Sie können nach der Installation die SolidWorks-Lizenzen aktivieren, indem Sie entweder einzelne Computer aktivieren (Lizenzaktivierung) oder variable Netzwerklizenzen auf einem Server (SolidNetWork-Lizensierung) aktivieren.

In der Regel Typischerweise wird für Installationen auf Einzel-Computern eine Lizenzaktivierung verwendet; Sie können aber die Software einzeln installieren und die Lizenzen über einen variablen SolidNetWork Lizenz-Manager steuern. Ebenso können Sie, obwohl an größeren Standorten normalerweise variable Netzwerklizenzen verwendet werden, die Installationen von einem Administrator-Installationsabbild verwenden, und dann die Seriennummern von den Einzel-Computern aus aktivieren.

  • Verwalten von Einzellizenzen
    In der Regel besteht die Verwaltung von Einzellizenzen daraus, die Lizenzen direkt von SolidWorks zu übertragen und aktivieren.
  • Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten
    Der SolidNetWork Lizenz-Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.


Verwalten von Einzellizenzen

In der Regel besteht die Verwaltung von Einzellizenzen daraus, die Lizenzen direkt von SolidWorks zu übertragen und aktivieren.

Die Aktivierung ist ein Vorgang der Produktlizenzierung und -registrierung für SolidWorks Einzelplatzlizenzen (nicht für SolidNetWork-Lizenzen). Wenn Ihre Produktlizenz noch nicht aktiviert wurde, versucht SolidWorks in der Regel, sie zu aktivieren, wenn Sie das produkt starten.

Sie können auch Einzellizenzen übertragen, indem Sie in SolidWorks auf Hilfe > Lizenzen übertragen klicken.

  • Aktivierung einer Lizenz
    Sie müssen die Lizenz für einen einzelnen Computer aktivieren bevor Sie SolidWorks-Produkte auf ihm laufen lassen können.
  • Eine Lizenz übertragen
    Um die Lizenz auf einen neuen oder aktualisierten Computer zu übertragen, transferieren Sie sie zunächst zurück an den Lizenzschlüssel-Server der Dassault Systèmes SolidWorks Corporation und reaktivieren Sie sie auf dem anderen Computer.
Übergeordnetes Thema: Lizenz-Administration


Aktivierung einer Lizenz

Sie müssen die Lizenz für einen einzelnen Computer aktivieren bevor Sie SolidWorks-Produkte auf ihm laufen lassen können.

Die Aktivierung erfordert einen Internetanschluss oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert alle Software-Lizenzen der gesamten SolidWorks Produktlinie.
  • Erlaubt es Ihnen, Lizenzen von einem Rechner auf einem anderen zu übertragen.
  • Erlaubt es Ihnen, die SolidWorks Produkte auf einem Rechner an Ihrem Arbeitsplatz und auf einem Rechner zu Hause zu installieren und zu aktivieren.
  • Kann sofort (empfohlen) oder innerhalb von 30 Tagen nach der Installation durchgeführt werden.
  • Macht Dongles überflüssig. Wenn Sie jedoch frühere Versionen von SolidWorks nutzen, die keine Aktivierung erfordern, benötigen Sie weiterhin Dongles.

Systemadministratoren, die mehrere Seriennummern zu verwalten haben, können den Administrator-Installationsabbild-Options-Editor verwenden. Einzelheiten finden Sie unter Administrator-Installationsabbild Options-Editor.

Aktivieren einer Lizenz:

  1. Starten Sie die SolidWorks-Anwendung.
  2. Starten Sie die SolidWorks Produktaktivierung mittels einer der folgenden Methoden:
    • Wenn Sie die Lizenz für diesen Rechner noch nicht aktiviert haben, dann erscheint das Fenster SolidWorks Produktaktivierung automatisch, wenn Sie SolidWorks starten.
    • Sollte das Fenster SolidWorks-Produktaktivierung nicht automatisch hochkommen, starten Sie die Aktivierung, indem Sie auf Hilfe > Lizenzen aktivierenklicken.
  3. Klicken Sie auf das Produkt -Listing, um das Produkt zu spezifizieren, dessen Lizenz Sie aktivieren möchten.
  4. Spezifizieren Sie automatische Aktivierung über das Internet oder manuelle Aktivierung mittels E-Mail.
  5. Geben Sie ihre Kontaktinformationen bekannt.
  6. Klicken Sie auf Weiter, um fortzufahren.
    • Internet: Die Aktivierung findet automatisch statt.
    • E-Mail: Klicken Sie auf Speichern, um eine Anforderungsdatei zu erstellen, und senden Sie die Datei an activation@solidworks.com. Wenn Sie die E-Mail mit dem Lizenzschlüssel erhalten, extrahieren Sie die Datei aus der E-Mail und klicken Sie auf Öffnen, um die Antwortdatei zu laden.
      Falls notwendig, können Sie die Anwendung beenden und den Aktivierungsvorgang nochmals ausführen, um die Antwortdatei zu öffnen.
  7. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Verwalten von Einzellizenzen


Eine Lizenz übertragen

Um die Lizenz auf einen neuen oder aktualisierten Computer zu übertragen, transferieren Sie sie zunächst zurück an den Lizenzschlüssel-Server der Dassault Systèmes SolidWorks Corporation und reaktivieren Sie sie auf dem anderen Computer.

Wenn Sie die Lizenz nicht an assault Systèmes SolidWorks Corporation zurückgeben konnten (z.B. aufgrund eines Festplattenfehlers) ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Falls nicht, wenden Sie sich bitte an Ihren Fachhändler.

Lizenzschlüssel an den Server zurückgeben:

  1. Klicken Sie in SolidWorks auf Hilfe > Lizenzen übertragen, und befolgen Sie die Anleitungen.
  2. Gehen Sie zur Reaktivierung zum neuen oder aktualisierten Computer und aktivieren Sie die Lizenz wie bei der ursprünglichen Aktivierung. Einzelheiten finden Sie unter Aktivierung einer Lizenz.
Übergeordnetes Thema: Verwalten von Einzellizenzen


Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten

Der SolidNetWork Lizenz-Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

Dieses Bild zeigt eine typische SolidNetWorks Lizensierungs-Installation:

Diese Abbildung zeigt:
  • SolidNetWork Lizenz-Manager-Software ist mur auf dem Lizenz-Manager-Compuuter installiert und aktiviert.
  • Auf Lizenz-Client-Computern ist keine zusätzliche SolidNetWork-spezifische Software installiert.

    Wenn Sie bei der Installation eine SolidNetWork-Lizenzseriennummer spezifizieren, identifizert der SolidWorks Installations-Manager diese als einen SolidNetWork Lizenz-Client. Der SolidWorks Installations-Manager fragt Sie nach dem Namen des SolidNetWork-Lizenz-Manager-Computers und der Anschlussnummer, um den Client mit dem Lizenz-Manager zu verbinden.

  • Beim Lizenz-Manager und allen Lizenz-Clients muss TCP/IP (Transmission Control Protocol/Internet Protocol)-Verbindung zur Verfügung stehen.
  • Aktivierung einer SolidNetWork Netzwerklizenz
    Bevor Anwender SolidWorks-produklte auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork-Lizenz auf dem SolidNetWork-Lizenz-Manager-Computer.
  • Eine SolidNetWork-Lizenz übertragen
    Um die Lizenz auf einen neuen oder aktualisierten Computer zu übertragen, transferieren Sie sie zunächst zurück an den Lizenzschlüssel-Server der Dassault Systèmes SolidWorks Corporation und reaktivieren Sie sie auf dem anderen Computer.
  • Installation und Konfiguration von SolidNetWork Lizenzen
    Eine SolidNetWork Lizenz zzu konfigurieren besteht daraus, den SolidNetWork Lizenz-Manager auf dem Lizenz-Manager-Computer zu installieren und dann SolidWorks auf den Cient-Computern mittels der SolidNetWork Lizenzseriennummer zu installieren.
  • SolidNetWork Lizenzverwaltung
    Die Aufgaben umfassen das Starten, Aktualisieren und die Deinstallation des Lizenz-Managers sowie das Holen, Leihen und die Zurückgabe von Lizenzen.
Übergeordnetes Thema: Lizenz-Administration


Aktivierung einer SolidNetWork Netzwerklizenz

Bevor Anwender SolidWorks-produklte auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork-Lizenz auf dem SolidNetWork-Lizenz-Manager-Computer.

Die Aktivierung erfordert einen Internetanschluss oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert den SolidWorks SolidNetWork Lizenz-Manager mit SolidNetWork-Lizenzen über SolidWorks-Produkte hinweg.
  • Erlaubt es Ihnen, SolidNetWork-Lizenzrechte von einem SolidNetWork-Lizenz-Manager-Computer auf einen anderen zu übertragen.
  • Damit können Sie SolidNetWork-Lizenzrechte auf einen SolidNetWork-Lizenz-Manager-Computer installieren und aktivieren.
  • Dies muss durchgeführt werden, bevor Sie die SolidNetWork-Lizenzen verwenden können.
  • Macht Dongles überflüssig. Wenn Sie eine SolidNetWork-Lizenz für diese Version von SolidWorks aktivieren, werden SolidNetWork-Lizenzen für vorherige Versionen von SolidWorks aktiviert. (Sie müssen den Dongle nicht weiterhin behalten).

Aktivieren einer SolidNetWork-Lizenz:

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager.
  2. Sollten Sie die SolidNetWork-Lizenz noch nicht aktiviert haben, werden Sie gefragt, ob Sie sie jetzt aktivieren möchten. Klicken Sie auf Ja, um sie zu aktivieren.
  3. Wählen Sie unter Wie möchten Sie aktivieren?, die Aussage Automatisch über das Internet (empfohlen).
  4. Spezifizieren Sie unter Kontaktinformationen eine E-Mailkontaktadresse.
Das Dialogfeld Aktivierung/Reaktivierung erfolgreich zeigt die Produkte an, die aktiviert wurden.
Übergeordnetes Thema: Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten


Eine SolidNetWork-Lizenz übertragen

Um die Lizenz auf einen neuen oder aktualisierten Computer zu übertragen, transferieren Sie sie zunächst zurück an den Lizenzschlüssel-Server der Dassault Systèmes SolidWorks Corporation und reaktivieren Sie sie auf dem anderen Computer.

Wenn Sie die Lizenz nicht an assault Systèmes SolidWorks Corporation zurückgeben konnten (z.B. aufgrund eines Festplattenfehlers) ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Falls nicht, wenden Sie sich bitte an Ihren Fachhändler.

Die SolidNetWork-Lizenz an den Server zurückgeben:

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).

  2. Klicken Sie unter Lizenzinformation auf Modifizieren. Der SolidWorks Produktaktivierungs- Assistent startet.
  3. Wählen Sie unter Was möchten Sie ausführen? die Aussage Eine Software-Lizenz übertragen und klicken Sie dann auf Weiter.
  4. Wählen Sie unter Wie möchten Sie aktivieren? die Aussage Automatisch über das Internet (empfohlen).
  5. Spezifizieren Sie unter Kontaktinformationen eine E-Mailkontaktadresse.
  6. Klicken Sie auf Weiter. Die Produktlizenz-Übertragung schließt ab.
Übergeordnetes Thema: Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten


Installation und Konfiguration von SolidNetWork Lizenzen

Eine SolidNetWork Lizenz zzu konfigurieren besteht daraus, den SolidNetWork Lizenz-Manager auf dem Lizenz-Manager-Computer zu installieren und dann SolidWorks auf den Cient-Computern mittels der SolidNetWork Lizenzseriennummer zu installieren.

  • Einen Lizenz-Manager installieren und aktivieren
    Der SolidNetWork Lizenz-Manager unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.
  • Einen Lizenz-Client installieren
    Bei der Installation von SolidWorks auf SolidNetWork Liczenz-Client-Computern identifiziert die Seriennummer diesen Computer als einen SolidNetWork Lizenz-Client.
  • SolidNetWork Lizenzmanager vor dem Installieren von Lizenz-Clients installieren
    Sie sollten SolidNetWork Lizenz-Manger auf mindestens einem Computer installieren und konfigurieren, bevor Sie irgendwelche SolidNetWork Lizenz-Client-Computer installieren.
  • Triaden-Lizenz-Manager-Installation
    Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.
  • SolidNetWork Lizenzen mit Firewalls verwenden
    Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Anschlüsse konfigurieren, damit sie SolidNetWork-Lizenzen unterstützen.
Übergeordnetes Thema: Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten


Einen Lizenz-Manager installieren und aktivieren

Der SolidNetWork Lizenz-Manager unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.

Wenn Sie von einer früheren Version des SolidNetWork Lizenz-Managers aktualisieren, der Hardware-Dongles zur Lizenzaktivierung verwendete, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version des SolidNetWork Lizenz-Managers installieren.

  1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
    1. Wählen Sie für Installationsart eine der folgenden Optionen aus:

      • Server-Produkte
      • SolidNetWork Lizenz-Server (verteilte Lizenzierung) auf diesen Computer installieren.

    2. Geben Sie auf der Seite SolidNetWork Lizenz-Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den Speicherort für den SolidNetWork Lizenz-Manager an.
    3. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SolidWorks Installations-Manager-Vorgang abzuschließen.
  2. So aktivieren Sie die SolidNetWork-Lizenzierung:
    1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
    2. Klicken Sie, wenn Sie zur Aktivierung aufgefordert werden, auf Yes.
    3. Auf dem SolidNetWork Lizenz-Server Informations-Bildschirm:

      • Wenn Ihr Unternehmen eine Firewall verwendet, wählen Sie Eine Firewall ist auf diesem Server aktiviert.

        Weitere Informationen dazu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

      • Verwenden Sie den Standardwert für Anschlussnummer (und Anschlussnummer der Händlerdomäne, wenn Sie eine Firewall haben), oder geben Sie die Anschlussnummern, die Ihr Unternehmen verwendet, ein.
        Die Anschlussnummer ist eine TCP/IP-Anschlussnummer im Bereich von 1024 – -60000, die nur von diesem Prozess verwendet werden kann. Die Standardeinstellung (25734) eignet sich in der Regel und ist meistens mit der des FLEXnet Server-Prozesses auf Ihrem Lizenz-Server nicht identisch.

    4. Auf dem Aktivieren Sie Ihr SolidWorks-Produkt-Bildschirm:

      • Wählen Sie eine Vorgehensweise über Internet oder E-Mail.
      • Geben Sie ihre Kontaktinformationen bekannt.
      • Klicken Sie auf Weiter, um fortzufahren.
        • Internet: Die Aktivierung findet automatisch statt.
        • E-Mail: Betätigen Sie Speichern, um eine Anforderungsdatei zu erstellen und schicken Sie die Datei dann an activation@solidworks.com. Wenn Sie die E-Mail mit der Antwortdatei erhalten, extrahieren Sie die Datei aus der E-Mail und klicken Sie Öffnen, um Sie zu laden.
          Falls notwendig, können Sie die Anwendung beenden und den Aktivierungsvorgang nochmals ausführen, um die Antwortdatei zu öffnen.

  3. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Installation und Konfiguration von SolidNetWork Lizenzen


Einen Lizenz-Client installieren

Bei der Installation von SolidWorks auf SolidNetWork Liczenz-Client-Computern identifiziert die Seriennummer diesen Computer als einen SolidNetWork Lizenz-Client.

  1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
  2. Klicken Sie auf dem Willkommen-Bildschirm auf Einzel (auf diesem Computer), wenn dies für diese Hauptversion die erste SolidWorks-Installation auf diesem Computer ist.

    Wenn Sie von einer aktuellen Version aktualisieren und von einer Einzellizenz auf SolidNetWork Lizenzierung wechseln, klicken Sie auf Einzelinstallation modifizieren (auf diesem Computer). Einzelheiten finden Sie unter Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren.

  3. Geben Sie, wenn Sie aufgefordert werden, eine Seriennummer einzugeben, die SolidNetWork-Lizenzseriennummer ein.
  4. Geben Sie im Dialogfeld Server hinzufügen die Adresse des SolidNetWork Lizenz-Managers in folgender Form ein:

    port@ComputerName

    Die Anschlussnummer muss dieselbe sein, die für den Lizenz-Manager verwendet wird. Der Standard ist 25734 (wie in Einen Lizenz-Manager installieren und aktivierenbeschrieben).

    Der SolidWorks Installations-Manager wird versuchen, zu validieren, ob auf diesen SolidNetWork Lizenz-Manager zugegriffen werden kann. Wenn Sie noch keinen Lizenz-manager installiert haben wird diese Validierung fehlschlagen. Sie können jedoch mit der Installation des Lizenz-Client fortfahren.

  5. Schließen Sie die SolidWorks-Installation ab, indem Sie die Anleitungen des SolidWorks Installations-Managers befolgen.
Übergeordnetes Thema: Installation und Konfiguration von SolidNetWork Lizenzen


SolidNetWork Lizenzmanager vor dem Installieren von Lizenz-Clients installieren

Sie sollten SolidNetWork Lizenz-Manger auf mindestens einem Computer installieren und konfigurieren, bevor Sie irgendwelche SolidNetWork Lizenz-Client-Computer installieren.

Bei der Installation mittels einer SolidNetWork Lizenzseriennummer fordert der SolidWorks Installations-Manager Sie auf, den Namen und die Anschlussnummer des Computers mit dem SolidNetWork Lizenz-Manager einzugeben und versucht dann, diese Informationen zu validieren.

Diese Validierung kann nicht erfolgreich verlaufen, wenn Sie den SolidNetWork Licenz-Manager noch nicht auf dem von Ihnen spezifizierten Computer installiert haben. In diesem Falle zeigt eine fehlgeschlagene Validierung jedoch nicht an, ob Sie die richtige Lizenz-Manager-Informationen angegeben haben. Wenn der Lizenz-Manager bereits installiert ist, zeigt ein Fehlschlagen der Validierungen an, dass Sie die falsche Lizenz-Manager-Informationen angegeben hatten.

Übergeordnetes Thema: Installation und Konfiguration von SolidNetWork Lizenzen


Triaden-Lizenz-Manager-Installation

Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.

Voraussetzungen für die Verwendung von Triaden-Lizenz-Managern:
  • Drei Hardware-Dongles sind erforderlich.
  • Installieren Sie Triaden-Lizenz-Manager auf stabilen Computern, die nicht oft heruntergefahren werden.
  • Die drei Lizenz-Manager sollten sich im selben Subnetz befinden. Sie sollten Triaden-Lizenz-Manager niemals mit langsamen Verbindungen oder Wählverbindungen konfigurieren.
  • In einer Triaden-Lizenz-Manager-Umgebung sollte der Systemadministrator sofort feststellen können, wenn ein Lizenz-Manager-Computer abstürzt und diesen so schnell wie möglich wieder starten.
    Wenn nur zwei Lizenz-Manager-Computer betrieben werden, ist dies ungünstiger als wenn nur ein einzelner Lizenz-Manager-Computer betrieben wird, da dann zwei Schwachpunkte für einen Ausfall vorliegen.
  • Installation des Anfangstriaden-Lizenzmanagers
    Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Dieser Vorgang zeigt, wie man SolidNetWork-Lizenz-Manager auf dem ersten Computer in der Triade installiert.
  • Den Triaden-Lizenz-Manager auf weiteren Computern installieren
    Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Dieser Vorgang zeigt, wie man SolidNetWork-Lizenz-Manager auf dem zweiten und dritten Computer in der Triade installiert.
Übergeordnetes Thema: Installation und Konfiguration von SolidNetWork Lizenzen


Installation des Anfangstriaden-Lizenzmanagers

Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Dieser Vorgang zeigt, wie man SolidNetWork-Lizenz-Manager auf dem ersten Computer in der Triade installiert.

  1. Installieren Sie mit dem SolidWorks Installations-Manager auf dem ersten Triaden-Lizenz-Manager-Computer den SolidNetWork-Lizenz-Manager:
    1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
    2. Wählen Sie für Installationsart eine der folgenden Optionen aus:

      • Server-Produkte
      • SolidNetWork Lizenz-Server (verteilte Lizenzierung) auf diesen Computer installieren.

    3. Geben Sie auf der Seite SolidNetWork Lizenz-Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den Speicherort für den SolidNetWork Lizenz-Manager an.
    4. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SolidWorks Installations-Manager-Vorgang abzuschließen.
  2. Konfigurieren Sie den ersten Triaden-Lizenz-Manager-Computer mit dem Lizenz-Manager-Computer:
    1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
    2. Klicken Sie auf Nein.

      Es erscheint die Registerkarte Server-Administration des SolidWorks SolidNetwork Lizenz-Managers.

    3. Klicken Sie in Erweiterte Optionen auf Optionen.

      Das Dialogfeld Erweiterte Optionen wird angezeigt.

    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.

      Das Dialogfeld Erwetierte Optionen wird angezeigt.

    5. Klicken Sie unter Lizenzinformation auf Modifizieren.

      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.

    6. Wählen Sie unter Server-Typ Einzel-Server aus, und klicken Sie auf Weiter.
    7. Verifizieren Sie im Server-Informationsbereich, dass der Computername, die Dongle-ID und die Anschlussnummer des ersten Triaden-Lizenz-Manager-Computers korrekt sind und klicken Sie dann auf Weiter.

      Wenn Ihr Computer mit einer Firewall arbeitet werden Sie u.U. einige zusätzliche Spezifizierungen auf diesem Bildschirm vornehmen müssen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

    8. Geben Sie auf dem Bildschirm Triaden-Partner-Server-Information den Computernamen und die Dongle-ID-Werte für die beiden anderen Triaden-Lizenz-Manager-Computer ein.

      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein Lizenz-Manager nicht verfügbar ist.

    9. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork-Lizenzdatei zu gelangen und sie zu öffnen.

      Die Lizenzen werden im Dialogfeld SolidNetWork-Lizenzdatei -Assistent aufgeführt.

    10. Klicken Sie auf Fertig stellen.
    11. Klicken Sie auf OK, um den SolidNetWork -Lizenzdatei -Assistenten zu schließen und dann auf Fertig stellen, um den SolidNetWork-Lizenz-Manager abzuschließen.
Übergeordnetes Thema: Triaden-Lizenz-Manager-Installation


Den Triaden-Lizenz-Manager auf weiteren Computern installieren

Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Dieser Vorgang zeigt, wie man SolidNetWork-Lizenz-Manager auf dem zweiten und dritten Computer in der Triade installiert.

Es wird angenommen, dass Sie bereits mindestens einen Triaden-Lizenz-Manager auf einem anderen Computer installiert haben. Einzelheiten finden Sie unter Installation des Anfangstriaden-Lizenzmanagers.

  1. Installieren Sie mit dem SolidWorks Installations-Manager auf dem Triaden-Lizenz-Manager-Computer den SolidNetWork-Lizenz-Manager:
    1. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
    2. Wählen Sie für Installationsart eine der folgenden Optionen aus:

      • Server-Produkte
      • SolidNetWork Lizenz-Server (verteilte Lizenzierung) auf diesen Computer installieren.

    3. Geben Sie auf der Seite SolidNetWork Lizenz-Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den Speicherort für den SolidNetWork Lizenz-Manager an.
    4. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SolidWorks Installations-Manager-Vorgang abzuschließen.
  2. Konfigurieren Sie den Triaden-Lizenz-Manager-Computer mit dem Lizenz-Manager-Computer:
    1. Starten Sie den SolidNetWork Lizenz-Manager (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).

      Da dies das erste Mal ist, dass Sie den SolidNetWork-Lizenz-Manager auf diesem Computer ausführen, werden Sie gefragt, ob Sie ihn jetzt aktivieren möchten.

    2. Klicken Sie auf Nein.

      Es erscheint die Registerkarte Server-Administration des SolidWorks SolidNetwork Lizenz-Managers.

    3. Klicken Sie in Erweiterte Optionen auf Optionen.

      Das Dialogfeld Erweiterte Optionen wird angezeigt.

    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.

      Das Dialogfeld Erwetierte Optionen wird angezeigt.

    5. Klicken Sie unter Lizenzinformation auf Modifizieren.

      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.

    6. Wählen Sie unter Server-Typ, dann Triad und Server-/Lizenzinformation abstimmen und klicken Sie anschließend auf Weiter.
    7. Verifizieren Sie im Server-Informationsbereich, dass der Computername, die Dongle-ID und die Anschlussnummer dieses Triaden-Lizenz-Manager-Computers korrekt sind und klicken Sie dann auf Weiter.

      Wenn Ihr Computer mit einer Firewall arbeitet werden Sie u.U. einige zusätzliche Spezifizierungen auf diesem Bildschirm vornehmen müssen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

    8. Geben Sie auf dem Bildschirm Triaden-Partner-Server-Information den Computernamen und die Dongle-ID-Werte für die beiden anderen Triaden-Lizenz-Manager-Computer ein.

      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein Lizenz-Manager nicht verfügbar ist.

    9. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork-Lizenzdatei zu gelangen und sie zu öffnen.

      In der Regel befindet sich die Lizenzdatei im \licenses\sw_d.lic auf dem ersten, von Ihnen konfigurierten Triaden-Lizenz-Manager-Computer.

      Die Lizenzen werden im Dialogfeld SolidNetWork-Lizenzdatei -Assistent aufgeführt.

    10. Klicken Sie auf Fertig stellen.

      Eine Warnung im Dialogfeld SolidNetWork Lizenzdatei-Assistent wird eingeblendet.

    11. Klicken Sie auf OK, um den SolidNetWork -Lizenzdatei -Assistenten zu schließen und dann auf Fertig stellen, um den SolidNetWork-Lizenz-Manager abzuschließen.

Wiederholen Sie diesen Vorgang, wenn Sie den zweiten Triaden-Lizenz-Computer konfigurieren und nochmals, wenn Sie den dritten konfigurieren.

Übergeordnetes Thema: Triaden-Lizenz-Manager-Installation


SolidNetWork Lizenzen mit Firewalls verwenden

Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Anschlüsse konfigurieren, damit sie SolidNetWork-Lizenzen unterstützen.

Sie müssen der Firewall-Software zwei SolidNetWork-Lizenzanschlüsse zur Firewall-Ausnahmenliste hinzufügen (z.B. SNL-in-port und SNL-out-port). Fragen Sie Ihren Systemadministrator nach Einzelheiten über die Konfiguration dieser Anschlüsse.

Wenn Sie eine Windows Firewall für Windows XP SP2 und Windows Server 2003 SP1 verwenden, müssen Sie die Anschlüsse auf dem SolidNetWork Lizenz-Manager-Computer sowie die Lizenzdatei modifizieren, um die Lizenzen auf die Lizenz-Client-Computer zu verteilen.

  • Lizenz-Manager Computer-Anschlüsse für eine Windows Firewall modifizieren
    Wenn Sie eine Windows Firewall verwenden, müssen Sie die Firewall-Anschlusseinstellungen auf dem SolidNetWork Lizenz-Manager-Computer modifizieren.
  • SolidNetWork Lizenz-Manager-Einstellungen für eine Windows Firewall modifizieren
    Wenn Sie eine Windows Firewall verwenden, müssen Sie die SolidNetWork Lizenzdatei modifizieren, um die Firewallanschlüsse für das Verteilen von Lizenzen auf Client-Computern nehmen zu können.
Übergeordnetes Thema: Installation und Konfiguration von SolidNetWork Lizenzen


Lizenz-Manager Computer-Anschlüsse für eine Windows Firewall modifizieren

Wenn Sie eine Windows Firewall verwenden, müssen Sie die Firewall-Anschlusseinstellungen auf dem SolidNetWork Lizenz-Manager-Computer modifizieren.

  1. Öffnen Sie in Windows die Systemsteuerung und doppelklicken Sie auf Sicherheitscenter.
  2. Klicken Sie auf Windows Firewall.
  3. Klicken Sie auf der Registerkarte Ausnahmen auf Anschluss hinzufügen.
  4. Geben Sie einen Namen ein (z.B., SNL-in-port) und eine Anschlussnummer (z.B., 25734) und klicken Sie dann auf OK.
  5. Klicken Sie für die zweite Anschlussnummer wieder auf Anschlussnummer hinzufügen auf der Registerkarte Ausnahmen und spezifizieren Sie den namen und die Nummer des anderen Anschlusses (z.B., SNL-out-port und 25735) und klicken Sie dann auf OK. Notieren Sie sich die Anschlussnummer, da Sie sie später benötigen, wenn Sie die SolidNetWork Lizenzdatei modifizieren.

    Wenn Sie die Workgroup PDM Anwendung benützen, müssen Sie die Workgroup PDM Anschlussnummern im Dialogfeld Windows Firewall modifizieren. In der Regel lauten diese Anschlüsse 20000 (VaultAdmin), 30000 (Data), 40000 (Request) und 80 (Viewer).

  6. Schießen Sie das Windows Sicherheitscenter und die Systemsteuerung.
Übergeordnetes Thema: SolidNetWork Lizenzen mit Firewalls verwenden


SolidNetWork Lizenz-Manager-Einstellungen für eine Windows Firewall modifizieren

Wenn Sie eine Windows Firewall verwenden, müssen Sie die SolidNetWork Lizenzdatei modifizieren, um die Firewallanschlüsse für das Verteilen von Lizenzen auf Client-Computern nehmen zu können.

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenz-Server auf Stopp. (Klicken Sie auf Ja, wenn Sie um eine Bestätigung gebeten werden und auf OK, um den Lizenz-Server vollkommen zu stoppen.)
  3. Klicken Sie unter Lizenzinformation auf Modifizieren.
  4. Wählen Sie unter Server-Typ das Server-Arrangement für Ihr Netzwerk aus (Einzel oder Triade) und klicken Sie dann auf Weiter.
  5. Unter Server-Information:
    1. Wählen Sie Eine Firewall ist auf diesem Server aktiviert.
    2. Die Anschlussnummer und die Anschlussnummer der Händlerdomäne sollten die Anschlussnummern enthalten, die für die Windows Firewall spezifiziert ist (Details finden Sie bitte in Lizenz-Manager Computer-Anschlüsse für eine Windows Firewall modifizieren).
    3. Klicken Sie auf Weiter und dann auf Fertig stellen.
  6. Klicken Sie auf der Registerkarte Server-Administration und unter Lizenz-Server auf Start.
  7. Klicken Sie auf OK, um den SolidNetWork Lizenz-Manager zu schließen.
Übergeordnetes Thema: SolidNetWork Lizenzen mit Firewalls verwenden


SolidNetWork Lizenzverwaltung

Die Aufgaben umfassen das Starten, Aktualisieren und die Deinstallation des Lizenz-Managers sowie das Holen, Leihen und die Zurückgabe von Lizenzen.

  • SolidNetWork Lizenz-Manager starten
    Sie können den SolidNetWork Lizenz-Manager vom Windows Start -Menü aus starten.
  • SolidNetWork Lizenz-Manager aktualisieren
    Für SolidWorks Hauptversionen besteht die Aktualisierung des Lizenz-Managers darin, den alten Lizenz-Manager zu deinstallieren, einen neuen zu installieren und die SolidNetWork-Lizenz zu aktivieren.
  • SolidNetWork-Lizenzdateien löschen
    Löschen Sie alte und abgelaufene SNL-Dateien, bevor Sie auf neue aktualisieren.
  • Client-Lizenzen abrufen
    Um die SolidNetWork-Verbindung eines Clients zu beenden, kann ein Systemadministrator die Lizenz anhalten und in den Pool zurückgeben.
  • Leihen und Rückgabe von SolidNetWork-Lizenzen
    Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.
  • Leerlaufzeit der Lizenz überwachen
    SolidWorks kann die Leerlaufzeit des SolidNetWork Lizenz-Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, zur Gruppe der verfügbaren Lizenzen hinzugefügt werden.
  • Temporäre Lizenzen installieren
    Die temporäre "ANY" -LizenzT kann vorübergehend benutzt werden, wenn die ursprüngliche SolidNetWork-Lizenz nicht zur Verfügung steht.
  • Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren
    Sie können einen Computer von einer SolidWorks Einzellizenz auf eine SolidNetWork-Lizenz aktualisieren, indem Sie die SolidNetWork Lizenzseriennummer in den SolidWorks Installations-Manager eingeben.
  • SolidNetWork-Lizenzen mit Zusatzanwendungen
    Sie können den SolidNetWork Lizenz-Manager auch dafür verwenden, Lizenzen für die wichtigsten SolidWorks Zusatzanwendungen (wie SFeatureWorks, Workgroup PDM Server etc.) zu verteilen.
  • Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
    Sie können einen Computer auf einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork-Lizenzen und als ein Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SolidWorks Software installieren können.
  • FLEXnet Publisher-Lizenzverwaltung
    Die Lizensierung von SolidNetWork basiert auf der FLEXnet Publisher® Lizenzverwaltung.
Übergeordnetes Thema: Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten


SolidNetWork Lizenz-Manager starten

Sie können den SolidNetWork Lizenz-Manager vom Windows Start -Menü aus starten.

  • In Windows führen Sie diesen Befehl aus: Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


SolidNetWork Lizenz-Manager aktualisieren

Für SolidWorks Hauptversionen besteht die Aktualisierung des Lizenz-Managers darin, den alten Lizenz-Manager zu deinstallieren, einen neuen zu installieren und die SolidNetWork-Lizenz zu aktivieren.

Ein Lizenz-Manager für eine neuere Version kann Lizenzen für Client Computer verteilen, die auch die frühere Version beibehalten.

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Auf der Registerkarte Lizenzverwendung stellen Sie sicher, dass keine Client-Computer im Netzwerk SolidWorks ausführen.
  3. Den alten Lizenz-Manager deinstallieren. Einzelheiten finden Sie unter SolidNetWork Lizenz-Manager deinstallieren.
  4. Installieren Sie den neuen Lizenz-Manager und reaktivieren Sie die SolidNetWork Lizenz auf dem Lizenz-Manager-Computer. Einzelheiten finden Sie unter Einen Lizenz-Manager installieren und aktivieren.

Wenn Sie den SolidNetWork Lizenz-Manager auf einem Computer aktualisieren, der auch die SolidWorks-Anwendung ausführt, müssen Sie die SolidNetWork Lizenz-Manager und Clienten aktualisieren, bevor Sie neue SolidWorks Anwendungs-Service-Packs auf diesem Computer installieren.

Wenn Sie den Lizenz-Manager auf einem Computer aktualisieren, der Administrator-Installationsabbilder hostet, müssen Sie den Lizenz-Manager aktualisieren, bevor Sie die Administrator-Installationsabbilder aktualisieren. Einzelheiten finden Sie unter Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden.

  • SolidNetWork Lizenz-Manager deinstallieren
    Vor der Aktualisierung des SolidNetWork Lizenz-Managers müssen Sie den alten Lizenz-Manager deinstallieren, bevor Sie den neuen installieren.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


SolidNetWork Lizenz-Manager deinstallieren

Vor der Aktualisierung des SolidNetWork Lizenz-Managers müssen Sie den alten Lizenz-Manager deinstallieren, bevor Sie den neuen installieren.

  1. Starten Sie den SolidNetWork Lizenz-Manager (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Verifizieren Sie, dass auf diesem Netzwerk Client-Computers nicht SolidWorks ausführen.

    Auf der Registerkarte Lizenzverwendung sind alle Clients aufgeführt, die SolidWorks ausführen.

  3. Wenn Sie die SolidWorks Lizenz auf einen anderen Computer übertragen möchten, tun Sie dies, bevor Sie den SolidWorks Lizenz-Manager von diesem Computer entfernen.

    Informationen über das Übertragen von SolidWorks Lizenzen finden Sie unterEine SolidNetWork-Lizenz übertragen.

  4. Klicken Sie auf der Registerkarte Server-Administration unter Lizenz-Server auf Stopp.
  5. Klicken Sie auf OK, um den Lizenz-Manager zu beenden.
  6. Öffnen Sie in WindowsSystemsteuerung > Software.
  7. Wählen Sie SolidWorks SolidNetWork Lizenz-Manager, klicken Sie auf Entfernen, und bestätigen Sie diesen Vorgang.
  8. Löschen Sie unter Verwendung von Windows Explorer den OrdnerSolidWorks SolidNetWork Lizenz-Manager.

    (In der Regel befindet sich dieser Ordner unter Programme im SolidWorks Installationsverzeichnis.)

Sie können jetzt eine neue Version des Lizenz-Managers installieren. Einzelheiten finden Sie unter Einen Lizenz-Manager installieren und aktivieren.

Wenn sich auf dem SolidNetWork Lizenz-Manager-Computer ein Hardware-Dongle befindet, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version des SolidNetWork Lizenz-Managers installieren.
Übergeordnetes Thema: SolidNetWork Lizenz-Manager aktualisieren


SolidNetWork-Lizenzdateien löschen

Löschen Sie alte und abgelaufene SNL-Dateien, bevor Sie auf neue aktualisieren.

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzdatei auf Modifizieren, dann auf Weiter, bis Sie den Bildschirm Lizenzen erreichen.
  3. Wählen Sie auf dem Bildschirm Lizenzen die alte oder abgelaufende SolidNetWork-Lizenzdatei aus, und klicken Sie auf Entfernen.
  4. Klicken Sie auf Fertig stellen und dann auf OK.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Client-Lizenzen abrufen

Um die SolidNetWork-Verbindung eines Clients zu beenden, kann ein Systemadministrator die Lizenz anhalten und in den Pool zurückgeben.

  • Der Client muss am Lizenz-Manager mindestens zwei Minuten lang angemeldet gewesen sein.
  • Sie können die SolidNetWork-Zeitsperrenoption auf das 15-Minuten-Minimum konfigurieren. Nach 15 Minuten Leerlaufzeit wird die Lizenz wieder zur Gruppe der verfügbaren Lizenzen hinzugefügt.

Weitere Details finden Sie unter SolidNetWork_Lizenz_Manager_Installationsverzeichnis\Docs\flexuser\licensingenduserguide.pdf.

  1. Klicken Sie auf Start > Ausführen, geben Sie cmd ein und klicken Sie dann auf OK, um ein Windows Eingabeaufforderungsfenster zu öffnen.
  2. Geben Sie in das Eingabeaufforderungsfenster Folgendes ein:

    cd SolidNetWork_Lizenz_Manager_Installationsverzeichnis\utils lmutil lmremove Feature Anwender Computer Anzeige

    wobei Feature, Anwender, Computer und Anzeige die Begriffe sind, die auf der Lizenz-Anwenderregisterkarte des SolidNetWork Lizenz-Managers gezeigt werden.

    Beispiel:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    Sie müssen die Lizenz für jede Zusatzanwendung (PhotoView 360, FeatureWorks, etc.) separat beenden.

Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Leihen und Rückgabe von SolidNetWork-Lizenzen

Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

Geliehene Lizenzen sind nur auf dem System gültig, für das sie ausgeliehen wurden; ein Transfer auf andere Computer ist nicht möglich.

Die Lizenz wird auf bestimmte Zeit bis maximal 30 Tage verliehen (oder laut Definition durch den Systemadministrator), und die Lizenz wird aus einem Pool verfügbarer Lizenzen entnommen.

Der Systemadministrator kann das Entleihen anpassen:
  • Er kann Anwender oder Gruppen definieren, die Lizenzen ausleihen dürfen
  • Er kann die Anzahl der Lizenzen festlegen, die ausgeliehen werden können

Weitere Details finden Sie unter SolidNetWork_Lizenz_Manager_Installationsverzeichnis\Docs\flexuser\licensingenduserguide.pdf.

  • SolidNetWork-Lizenzen ausleihen
    Sie können eine SolidNetWork-Lizenz ausleihen, um die Software von einem externen Standort aus zu verwenden.
  • Rückgabe einer geliehenen SolidNetWork-Lizenz
    Da die geliehene Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geliehene Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


SolidNetWork-Lizenzen ausleihen

Sie können eine SolidNetWork-Lizenz ausleihen, um die Software von einem externen Standort aus zu verwenden.

Sie müssen an den SolidNetWork-Lizenz-Manager angeschlossen sein, um die Lizenz auszuleihen, aber nicht unbedingt, um sie zu verwenden.

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz die folgenden Schritte aus:
    1. Wählen Sie ein Datum unter Ausleihen bis.
    2. Wählen Sie die auszuleihenden Produkte aus, und klicken Sie auf Ausleihen und zur Bestätigung auf Ja.
    3. Klicken Sie auf Aktualisieren. In der Spalte Ablaufdatum wird angezeigt, wann die Lizenzen wieder zurückgegeben werden müssen.
  3. Klicken Sie auf OK .
Um SolidWorks ausführen zu können, müssen Sie eine SolidWorks Lizenz ausleihen. SolidWorks Professional und SolidWorks Premium aktivieren nur die Zusatzanwendungen, die mit dem Paket assoziiert sind, nicht aber SolidWorks.
Übergeordnetes Thema: Leihen und Rückgabe von SolidNetWork-Lizenzen


Rückgabe einer geliehenen SolidNetWork-Lizenz

Da die geliehene Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geliehene Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

  1. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz die folgenden Schritte aus:
    1. Wählen Sie die auszuleihenden Produkte aus, und klicken Sie auf Zurückgeben und zur Bestätigung auf Ja.
    2. Klicken Sie auf Aktualisieren. Die Spalte Ablaufdatum ist leer, was darauf hinweist, dass die Lizenzen zurückgegeben wurden.
  3. Klicken Sie auf OK .
Es ist nicht erforderlich, Lizenzen nach dem Ablaufdatum zurückzugeben. Die Lizenz wird um Mitternacht des Ablaufdatums in die Gruppe der zurückgegebenen Lizenzen im SolidNetWork Lizenz-Manager zurückgegeben und die Anwendungen auf dem entfernten System können nicht mehr ausgeführt werden.
Übergeordnetes Thema: Leihen und Rückgabe von SolidNetWork-Lizenzen


Leerlaufzeit der Lizenz überwachen

SolidWorks kann die Leerlaufzeit des SolidNetWork Lizenz-Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, zur Gruppe der verfügbaren Lizenzen hinzugefügt werden.

  1. Erstellen Sie im Installationsverzeichnis des SolidNetwork Lizenz-Manager eine Textdatei:

    SolidNetWork_Lizenz_Manager_Installationsverzeichnis\Lizenzen\sw_d.opt

  2. Fügen Sie die folgende Zeile zur Datei hinzu:

    TIMEOUTALL Sekunden

    wobei Sekunden eine Zahl darstellt, die größer oder gleich 900 (15 Minuten) ist, was die erlaubte Mindestdauer ist.

Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Temporäre Lizenzen installieren

Die temporäre "ANY" -LizenzT kann vorübergehend benutzt werden, wenn die ursprüngliche SolidNetWork-Lizenz nicht zur Verfügung steht.

Mit der Installation der "ANY"-Lizenzdatei erklären Sie sich bereit, die herkömmliche Lizenz nach Erhalt einer SolidNetWork-Lizenz von der Dassault Systèmes SolidWorks Corporation zu implementieren. Die Einhaltung der Lizenzbeschränkungen ist weiterhin erforderlich.

Eine „ANY“-Lizenz installieren:

  1. Wenn Sie ein aktueller Anwender von SolidNetWork sind, deinstallieren Sie den SolidNetWork Lizenz-Manager und löschen Sie den Installationsordner. Einzelheiten finden Sie unter SolidNetWork Lizenz-Manager deinstallieren.
  2. Starten Sie den SolidWorks Installations-Manager (wie oben unter SolidWorks Installation wird initiiert beschrieben).
    1. Wählen Sie für Installationsart eine der folgenden Optionen aus:

      • Server-Produkte
      • SolidNetWork Lizenz-Server (verteilte Lizenzierung) auf diesen Computer installieren.

    2. Geben Sie auf der Seite SolidNetWork Lizenz-Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den Speicherort für den SolidNetWork Lizenz-Manager an.
    3. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SolidWorks Installations-Manager-Vorgang abzuschließen.
  3. Den SolidNetWork Lizenz-Manager starten (Start > Alle Programme > SolidWorks Version > SolidNetWork Lizenz-Manager > SolidNetWork Lizenz-Manager).
  4. Wenn Sie zur Aktivierung aufgefordert werden, klicken Sie auf Nein.

    Es erscheint die Registerkarte Server-Administration des SolidWorks SolidNetwork Lizenz-Managers.

  5. Klicken Sie in Erweiterte Optionen auf Optionen.

    Das Dialogfeld Erweiterte Optionen wird angezeigt.

  6. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.

    Das Dialogfeld Erwetierte Optionen wird angezeigt.

  7. Klicken Sie unter Lizenzinformation auf Modifizieren.

    Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.

  8. Wählen Sie unter Server-Typ die Aussage Einzel aus und klicken Sie auf Weiter.
  9. Wenn Sie folgende Meldung sehen:

    Konnte die Dongle-ID-Nummer nicht lesen.
    klicken Sie dann auf Abbrechen.
    The ID "ANY" wird automatisch eingeblendet.
    Wenn Ihr Computer mit einer Firewall arbeitet werden Sie u.U. einige zusätzliche Spezifizierungen auf diesem Bildschirm vornehmen müssen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

  10. Setzen Sie die Installation fort.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren

Sie können einen Computer von einer SolidWorks Einzellizenz auf eine SolidNetWork-Lizenz aktualisieren, indem Sie die SolidNetWork Lizenzseriennummer in den SolidWorks Installations-Manager eingeben.

Wenn auf einem Computer SolidWorks nicht installiert ist, können Sie SolidNetWork-Lizensierung spezifizieren, indem Sie die SolidNetWork Seriennummer eingeben, wenn Sie eine Installation mittels dem SolidWorks Installations-Manager vornehmen.

Wenn auf einem Computer SolidWorks bereits installiert ist und Sie von einer Einzellizenz auf SolidNetWork-Lizensierung umsteigen, dann können Sie für den Client-Computer die Installation modifizieren und die SolidNetWork Lizenzseriennummer anstatt der Einzellizenzseriennumer angeben, wenn Sie den SolidWorks Installations-Manager ausführen. Einzelheiten finden Sie unter Modifizieren einer Installation.

Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


SolidNetWork-Lizenzen mit Zusatzanwendungen

Sie können den SolidNetWork Lizenz-Manager auch dafür verwenden, Lizenzen für die wichtigsten SolidWorks Zusatzanwendungen (wie SFeatureWorks, Workgroup PDM Server etc.) zu verteilen.

  • Eine gleiche Anzahl von SolidWorks Software-Lizenzen und SolidWorks Zusatzanwendungslizenzen ist nicht erforderlich.
  • Um eine Lizenz für eine Zusatzanwendung auszuchecken, müssen Sie zuerst eine Lizenz für die SolidWorks auschecken.
  • Um eine Lizenz für eine Zusatzanwendung auszuleihen, müssen Sie sowohl die SolidWorks Software-Lizenz als auch die SolidWorks Produkt-Lizenz, die die Zusatzanwendung beinhaltet, ausleihen. So würden Sie entweder eine SolidWorks Office Professional oder SolidWorks Premium Produkt-Lizenz ausleihen.
  • Eine Zusatzanwendungslizenz freigeben:
    • Klicken Sie in SolidWorks auf Extras > Zusatzanwendungen und beenden Sie die Zusatzanwendung.
    • Beenden Sie SolidWorks.
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden

Sie können einen Computer auf einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork-Lizenzen und als ein Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SolidWorks Software installieren können.

Die Client-Computer können eine Lizenz vom Lizenz-Manager erhalten und dann die SolidWorks Anwendung vom selben Computer aus installieren.

Für diese Konfiguration müssen der Lizenz-Manager und das Administrator-Installationsabbild auf demselben Computer installiert sein. Den Lizenz-Manager zuerst installieren und dann das Administrator-Installationsabbilderstellen und verwenden.
Details finden Sie unter:
  • Einen Lizenz-Manager installieren und aktivieren
  • Bereitstellung für mehrere Clients
Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


FLEXnet Publisher-Lizenzverwaltung

Die Lizensierung von SolidNetWork basiert auf der FLEXnet Publisher® Lizenzverwaltung.

Weitere Informationen zur Lizenzverwaltung von FLEXnet Publisher finden Sie in der FLEXnet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetwork-Lizenz-Managers, (SolidNetwork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf).

Die jeweils neuesten Informationen über FLEXnet Publisher Lizenz-Management erhalten Sie bei Acresso® Software.

Übergeordnetes Thema: SolidNetWork Lizenzverwaltung


Problembehebung

Schlagen Sie unter diesen Themen nach, wenn Sie Hilfe bei der Problembehebung bei Installationsproblemen benötigen.

  • SolidWorks-Installations-Manager-Protokolldateien
    Die Protokolldateien des SolidWorks Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.
  • SolidWorks Installations-Manager Download-Ordner
    Der SolidWorks Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.
  • Problembehebung bei Netzwerklizenzen
    Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.
  • Problembehebung bei Aktualisierungen
    Wenn Sie während der Aktualisierung auf eine neue SolidWorks Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.


SolidWorks-Installations-Manager-Protokolldateien

Die Protokolldateien des SolidWorks Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.

Diese Protokolldateien befinden sich im gleichen Ordner wie die anderen SolidWorks-Anwendungsprotokolldateien.
  • Für Windows Vista oder höher:

    C:\Benutzer\Benutzername\AppData\Roaming\SolidWorks\Installation Logs\Installierte_Version

  • Für Windows Betriebssystemversionen vor Windows Vista:

    C:\Dokumente und Einstellungen\Benutzername\Anwendungsdaten\SolidWorks\Protokolldateien\Installierte_Version\

Um die Protokolldateienverzeichnisse sehen zu können, müssen Sie u.U. die Windows-Ordner-Option konfigurieren, sodass sie Alle Dateien und Ordner anzeigen.

Wenn die Anwendungsdaten auf einem anderen Laufwerk als C: liegen, dann muss der Verzeichnispfad dementsprechend angepasst werden.

Dieses Verzeichnis enthält die Datei SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, ein allgemeines Verzeichnis des Fortschritts des SolidWorks Installation-Managers.

Das Unterverzeichnis Andere Protokolldateien enthält weitere detaillierte Protokolldatei-Informationen.

Übergeordnetes Thema: Problembehebung


SolidWorks Installations-Manager Download-Ordner

Der SolidWorks Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.

  1. Wie werden die Dateien in diesen Ordner installiert?
  2. Kann ich MSI-Dateien manuell von diesem Ordner mit msiexec oder einer anderen Anwendung installieren?
  3. Kann ich denselben Download-Ordner für alle Versionen auswählen?
  4. Ich habe einige Produkte manuell von der Dassault Systèmes SolidWorks Corporation Website heruntergeladen. Kann der Installations-Manager diese installieren?
  5. Können die von mir heruntergeladenen Dateien von anderen Anwendern verwendet werden?
  6. Wie weiß ich, dass eine neue Version von SolidWorks Produkten verfügbar ist?
  7. Der Installations-Manager zeigt nur SW2006 oder SW2007-Installationen an, aber nicht die aktuelle Version.
  8. Der Installations-Manager lässt mich kein anderes Service Pack eines Produkts zur Installation auswählen.
  9. Der Installations-Manager hindert das Downloading von Dateien.
  10. Nicht alle meiner SolidWorks Produkte sind auf das letzte Service Pack aktualisiert, aber laut "Nach Aktualisierungen suchen" habe ich die letzte Version?
  11. Kann ich eine DVD in einen Download-Ordner kopieren?

Wie werden die Dateien in diesen Ordner installiert?

Führen Sie die Programmdatei setup.exe aus. U.U. müssen Sie noch einige Dateien herunterladen, wenn Sie Elemente zur Installation auswählen, die noch nicht heruntergeladen wurden.

Installieren Sie nicht msiexec (siehe unten).

Zurück zum Beginn

Kann ich MSI-Dateien manuell von diesem Ordner mit msiexec oder einer anderen Anwendung installieren?

Nein. Der Installations-Manager lädt einige Dateien nicht herunter, die für die Ausführung von msiexec benötigt würden.

Zurück zum Beginn

Kann ich denselben Download-Ordner für alle Versionen auswählen?

Heruntergeladenen Ordner sind versionsspezifisch. Angefangen mit SolidWorks 2010 erstellt der SolidWorks Installation-Manager automatische einen versionsspezifischen Unterordner im spezifizierten Ordner.

Zurück zum Beginn

Ich habe einige Produkte manuell von der Dassault Systèmes SolidWorks Corporation Website heruntergeladen. Kann der Installations-Manager auch diese installieren?

Ab SW2009 können manuell herunter geladene Dateien vom SolidWorks Installations-Manager verwendet werden. Es ist jedoch besser, den SolidWorks Installations-Manager auszuführen, wobei die Option zum Dateien-Download ausgewählt wird. Der SolidWorks Installations-Manager zeigt, welche Dateien Sie basierend auf Ihrer Installatio benötigen und bietet Links für den Download der einzelnen benötigten Dateien. Diese Option kann verwendet werden, wenn die integrierte Download-Seite nicht funktioniert (meist aufgrund von Download-Beschränkungen durch einen Proxy-Server).
Wenn der Microsoft Internet Explorer fragt, ob Sie während einem Download oder einer Installation die Dateien speichern oder ausführen wollen, immer speichern wählen.

Zurück zum Beginn

Können die von mir heruntergeladenen Dateien von anderen Anwendern verwendet werden?

Ja. Laden Sie dazu die Dateien auf ein freigegebenes Netzwerk. Jeder Client kann dann den SolidWorks Installations-Manager vom freigegebenen Netzwerk ausführen.

Keine weiteren Downloads sind erforderlich, es sei denn, ein Anwender wählt einige Elemente zur Installation aus, die während des ersten Downloads nicht ausgewählt waren oder wenn der Computer, der diesen Download zur Installation verwendet, einen anderen Satz von Voraussetzungen hat als der Computer, auf den Sie die Dateien heruntergeladen haben.

Wenn Sie im Namen anderer einen Download ausführen aber nicht installieren, wählen Sie bei der Installation die Option Nur Download . Diese Option ermöglicht es Ihnen, Produkte unabhängig davon auszuwählen, was auf Ihrem System installiert ist. Diese Option kann jedoch nicht für den Download von Patches oder die Erstellung von Administrator-Installationsabbildern verwendet werden.

Zurück zum Beginn

Wie weiß ich, dass eine neue Version von SolidWorks Produkten verfügbar ist?

Sie werden in den folgenden Fällen benachrichtigt, wenn eine neue Version verfügbar ist:
  • Wenn Sie nach Aktualisierungen suchen (Start > Alle Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen)
  • Wenn Sie den SolidWorks Hintergrund-Downloader aktiviert haben.
  • Wenn Sie eine installierte Version von SolidWorks in Software auswählen und auf Ändern klicken.
  • Wenn Sie eine ältere Version des Installations-Managers (sldIM.exe) von einem Download-Ordner ausführen.
In diesen Fällen haben Sie die Möglichkeit, eine neuere Version herunterzuladen. Der SolidWorks Installations-Manager wird die neuere Version von sich selbst und keine Installationsdateien herunterladen und ausführen. Sobald die neuere Version des SolidWorks Installations-Managers ausgeführt wird, können Sie einen Installationsoperationensatz auswählen. Der SolidWorks Installations-Manager wird dann feststellen, welche Installationsdateien benötigt werden (und früher noch nicht heruntergeladen wurden) und anbieten, diese Dateien herunterzuladen.

Zurück zum Beginn

Der SolidWorks Installations-Manager zeigt nur SW2006 oder SW2007-Installationen an, aber nicht die aktuelle Version.

Bei Ihnen läuft eine ältere Version des SolidWorks Installations-Managers, die für die aktuelle Version nicht mehr unterstützt wird. Diese kann nur Service Packs für die Versionen SW2006 und SW2007 herunterladen.

Zurück zum Beginn

Der SolidWorks Installations-Manager lässt mich kein anderes Service Pack eines Produkts zur Installation auswählen.

Dies ist so vorgesehen. Jede Version des SolidWorks Installations-Managers ist nur für die Installation einer bestimmten Version von SolidWorks Produkten entwickelt. Wenn Sie ein anderes Service Pack installieren möchten, müssen Sie den SolidWorks Installations-Manager dieser Version ausführen. Siehe Wie weiß ich, dass eine neue Version von SolidWorks Produkten verfügbar ist? um die jeweils neueste Version zu finden.

Zurück zum Beginn

Der SolidWorks Installations-Manager wird am Download von Dateien gehindert.

Wenn Proxy-Server-Beschränkungen Anwendungen am Download von Dateien hindern, kann der SolidWorks Installations-Manager Dateien nicht automatisch herunterladen.

Sie können Dateien manuell herunterladen und sie anschließend mit dem SolidWorks Installations-Manager installieren. Wählen Sie, um einzelne Dateien herunterzuladen, die Option im SolidWorks Installations-Manager (z.B. Manuellen Download durchführen auf der Download-Optionen Seite). Basierend auf Ihrer Produktauswahl und den Systemanforderungen, wird eine Webseite in einem separaten Fenster mit Links für den manuellen Download der erforderlichen Dateien angezeigt. Diese Links sind identisch mit jenen im SolidWorks Kundenportal, Sie brauchen aber nicht nach den Dateien zu suchen.

Zurück zum Beginn

Nicht alle meiner SolidWorks Produkte sind auf das letzte Service Pack aktualisiert, aber laut "Nach Aktualisierungen suchen" habe ich die letzte Version?

Die Option „Nach Aktualisierungen suchen“ informiert Sie darüber, ob Sie die letze Version des SolidWorks Installations-Managers installiert haben (oder ausführen).

Wenn Sie alle Produkte auf die letzte Version, die installiert ist, aktualisieren möchten, wählen Sie in Software die zuletzt installierte Version von SolidWorks aus, und klicken Sie auf Ändern.

Zurück zum Beginn

Kann ich eine DVD in einen Download-Ordner kopieren?

Ja, aber Installationen können fehlschlagen, wenn Sie nicht den gesamten Inhalt aller DVDs, die für ein bestimmtes Betriebssystem (x86 oder x64) freigegeben wurden, kopieren. Der SolidWorks Installations-Manager sucht nach der swdata*.id der Dateien, um die Version festzustellen. Wenn diese Dateien fehlen, können die Installationsdateien, die Sie kopiert haben, nicht erkannt werden. Ein Download wird gefordert.

Zurück zum Beginn

Übergeordnetes Thema: Problembehebung


Problembehebung bei Netzwerklizenzen

Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.

  • Zugriff auf SolidNetWork Lizenz-Protokolldateien
    Wenn ein Lizenzfehler auftritt, kann die Antwort oft in der Datei SNL_Manager_Installationsverzeichnis\lmgrd.log gefunden werden.
  • Konnte keine Lizenz für SolidWorks erhalten. Kann nicht zum Lizenz-Server verbinden.
    In der Regel wird dieses Problem durch die Anschlusseinstellungen verursacht.
Übergeordnetes Thema: Problembehebung


Zugriff auf SolidNetWork Lizenz-Protokolldateien

Wenn ein Lizenzfehler auftritt, kann die Antwort oft in der Datei SNL_Manager_Installationsverzeichnis\lmgrd.log gefunden werden.

Übergeordnetes Thema: Problembehebung bei Netzwerklizenzen


Konnte keine Lizenz für SolidWorks erhalten. Kann nicht zum Lizenz-Server verbinden.

In der Regel wird dieses Problem durch die Anschlusseinstellungen verursacht.

  • Anschlusseinstellungen zwischen dem SolidNetWork Lizenz-Manager und dem Lizenz-Client stimmen u.U. nicht überein.
  • Weitere Anschlusseinstellungen für mehrere Versionen des SolidNetWork Lizenz-Managers wurden u.U. nicht festgelegt.
Details zu den Anschlusseinstellungen für die SolidNetWork Lizenz-Manager und Clients finden Sie in SolidNetWork Lizenzen mit Firewalls verwenden.
Übergeordnetes Thema: Problembehebung bei Netzwerklizenzen


Problembehebung bei Aktualisierungen

Wenn Sie während der Aktualisierung auf eine neue SolidWorks Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.

  • Aktualisieren von einer Quelle, die an einen anderen Ort verschoben wurde
    Wenn SolidWorks installiert ist, merkt sich der SolidWorks Installations-Manager den Ort der Installationsquellen (Diskettenmedium, Diskettenabbildung auf einem Netz etc.). Beim Update erwartet der Manager, dass sich die Quelle an derselben Stelle befindet.
Übergeordnetes Thema: Problembehebung


Aktualisieren von einer Quelle, die an einen anderen Ort verschoben wurde

Wenn SolidWorks installiert ist, merkt sich der SolidWorks Installations-Manager den Ort der Installationsquellen (Diskettenmedium, Diskettenabbildung auf einem Netz etc.). Beim Update erwartet der Manager, dass sich die Quelle an derselben Stelle befindet.

Wenn die Quelle an einen anderen Ort verlagert oder gelöscht wurde oder sich das Quellmedium geändert hat, produziert der SolidWorks Installations-Manager eine Fehlermeldung. Sie können aber die Aktualisierung fortsetzen, indem Sie einen anderen Speicherort auswählen, vorausgesetzt, die Datei- und Ordnerstruktur ist da dieselbe.

Übergeordnetes Thema: Problembehebung bei Aktualisierungen


SolidWorks Installations-Manager-Anwendungshilfe

Der SolidWorks Installations-Manager ist eine eigenständige Anwendung, die Ihre SolidWorks Produkte installiert und aktualisiert.

Sie können den SolidWorks Installations-Manager von folgenden Orten aus ausführen:
  • Von einer SolidWorks DVD oder einem freigegebenen Quell- oder Download-Ordner (für die Installation einer neuen Version)
  • Von der Seite Systemsteuerung, Software (zum Modifizieren oder Entfernen einer bestehenden Version)
  • Über eine geplante oder manuelle Aktualisierungsüberprüfung (für das Ermitteln, den Download und die Installation neuer Versionen.

Jede SolidWorks-Version verfügt über eine zugehörige SolidWorks Installations-Manager-Version.

Verwenden Sie für Versionen vor SolidWorks 2008 den SolidWorks 2007 Installations-Manager, oder laden Sie die Produktversionen manuell von der SolidWorks Support-Website herunter.
  • SolidWorks Hintergrund-Downloader
    SolidWorks Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, werden Sie gefragt, ob Sie nun installieren möchten, den Download an einen anderen Zeitpunkt verschieben oder entfernen möchten.
  • Nach Aktualisierungsergebnissen suchen
    Die Option „Nach Aktualisierungsergebnissen suchen“ sucht nach neueren Versionen von SolidWorks.
  • Administrator-Installationsabbild-Position
    Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.
  • Download-Optionen
    Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.
  • Download-Optionen für SolidWorks-Installations-Manager-Dateien
    Sie haben beschlossen, eine spätere Version des SolidWorks Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.
  • Produkt-Installationsdateien herunterladen
    Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.
  • Download-Verlauf
    Der SolidWorks Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.
  • Download-Ergebnisse
    Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.
  • Installationsfehler / Installation abgebrochen
    Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.
  • Installation vollständig
    Der SolidWorks Installations-Manager hat die Verarbeitung abgeschlossen.
  • Installationsort
    Geben Sie an, wo SolidWorks installiert werden soll.
  • Aktualisierungsoptionen
    Auf diesem Computer ist derzeit eine oder mehrere SolidWorks Hauptversionen installiert. Wählen Sie aus, ob Sie die neueste vorhandene Version auf die neue Version aktualisieren oder eine neue Installation für die neue Version erstellen möchte.
  • Installationsfortschritt
    Dieser Bildschirm zeigt den Verlauf der Installation.
  • Installationstyp
    Geben Sie den Installationsvorgang an, den Sie ausführen möchten, z. B. Erstellen einer neuen Installation, Modifizieren oder Reparieren einer vorhandenen Installation, Erstellen eines Administrator-Installationsabbilds, Installieren von Administrator-Serverprodukten oder Herunterladen von Dateien ohne Installation.
  • Installieren und Verwalten mehrerer Computer
    Der SolidWorks Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren Computern und deren Verwaltung.
  • Manueller Download
    Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SolidWorks Installations-Manager zum letzten Mal ausgeführt haben).
  • Neuere Version verfügbar
    Der Installations-Manager hat eine neuere Version von SolidWorks Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.
  • Keine neuen Versionen verfügbar
    Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.
  • Festgestellte Prozesse
    Der SolidWorks Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.
  • Produktauswahl
    Geben Sie die Produktkomponenten an, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.
  • Produkte zum Herunterladen
    Wählen Sie SolidWorks Produkte zum Herunterladen an einen bestimmten Ablageort aus.
  • Zu reparierende Produkte
    Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SolidWorks Produkte mit den Versionsnummern an, die von dieser Verseion des SolidWorks Installations-Managers repariert werden können.
  • Seriennummern
    Seriennummern, die im Verteilungspool gefunden werden, assoziieren Ihren Computer mit den SolidWorks Produkten, die Sie erworben haben.
  • Server-Installation
    Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.
  • SolidNetWork Lizenz-Manager
    Legen Sie Installationsoptionen für das Server-Produkt "SolidNetWork Lizenz-Manager" fest.
  • Zusammenfassung
    Der SolidWorks Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.
  • Warnungen bei der Systemprüfung
    Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SolidWorks Installations-Manager fortfahren können.
  • Bohrungsassistent/Toolbox-Optionen
    Wenn SolidWorks Toolbox installiert ist, beinhaltet SolidWorks eine Standardbibliothek von Bohrungstypen und Maschinenteilen.
  • Produkte deinstallieren
    Wenn Sie Entfernen oder Programme Deinstallieren in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SolidWorks Produkte (mit Versionsnummern) an, die von dieser Version des SolidWorks Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.
  • Optionen des Workgroup PDM Server
    Legen Sie die Installationsoptionen für das Serverprodukt "SolidWorks Workgroup PDM" fest.


SolidWorks Hintergrund-Downloader

SolidWorks Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, werden Sie gefragt, ob Sie nun installieren möchten, den Download an einen anderen Zeitpunkt verschieben oder entfernen möchten.

SolidWorks Hintergrund-Downloader wird standardmäßig aktiviert, wenn Sie SolidWorks mit dem SolidWorks Installations-Manager installieren.

Wenn der SolidWorks Installations-Manager ausgeführt wurde, um eine Installation oder einen Download auszuführen, wird der SolidWorks Hintergrund-Downloader angehalten. Der Downloader hält jeden Download an und lässt nicht zu, dass neue Downloads gestartet werden und dass der Download-Zielordner geändert wird.

SolidWorks Hintergrund-Downloader wird standardmäßig aktiviert, wenn Sie SolidWorks installieren. Sie können den SolidWorks Hintergrund-Downloader während der SolidWorks-Installation deaktivieren, indem Sie die "Download-Optionen" auf der Registerkarte ändern. (Deaktivieren Sie die Option Soll der Hintergrund-Downloader verwendet werden?.)

Wenn die Option aktiviert ist, erscheint dieses Symbol in der Windows-Taskleiste:

Durch Klicken auf dieses Symbol kann auf folgende Optionen zugegriffen werden:
  • Hilfe für Hintergrund-Downloader
  • Download anhalten
  • Download wieder aufnehmen
  • Download abbrechen
  • Installationsoptionen
  • Download-Position ändern
  • Nach Aktualisierungen suchen
  • Automatisch nach Aktualisierungen suchen
  • Aktualisierungen automatisch herunterladen
  • Hintergrund-Downloader deaktivieren

Hilfe für Hintergrund-Downloader

Öffnen Sie dieses Hilfethema für den Hintergrund-Downloader in der SolidWorks Installationsanleitung.

Download anhalten/wieder aufnehmen

Wenn ein Download im Hintergrund ausgeführt wird, klicken Sie auf Download anhalten, um den Download anzuhalten. Wenn Sie den Download später fortsetzen wollen, klicken Sie auf Download wieder aufnehmen.

Download abbrechen

Wenn ein Download ausgeführt wird, brechen Sie den Download ab und löschen Sie alle bereits heruntergeladene Dateien.
Ein abgebrochener Download kann nicht wieder aufgenommen werden.

Installationsoptionen

Wenn ein Download abgeschlossen wurde, können Sie aus den folgenden Optionen auswählen:
  • Jetzt installieren: Heruntergeladene Dateien installieren.
  • Erinnere mich später: Heruntergeladene Dateien nicht installieren, aber eine Erinnerungsmeldung einrichten.
  • Diesen Download löschen: Heruntergeladene Dateien nicht installieren und löschen. (Diese Option sollte gewählt werden, wenn Sie sich entschieden haben, die heruntergeladenen Dateien nicht zu installieren.)

Download-Position ändern

Speicherort für die vom Hintergrund-Downloader heruntergeladenen Dateien ändern.

Diese Option ist nicht verfügbar, wenn ein Download läuft oder angehalten wurde.

Nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen des SolidWorks Installations-Managers wird ausgeführt.

Automatisch nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt, und Sie werden benachrichtigt, wenn Aktualisierungen zum Download bereit stehen.

Aktualisierungen automatisch herunterladen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt, und bereit gestellte Aktualisierungen werden heruntergeladen.

SolidWorks Hintergrund-Downloader deaktivieren und wieder aktivieren

Sie können den Hintergrund-Downloader deaktivieren, indem Sie auf das Symbol klicken und Hintergrund-Downloader deaktivieren wählen.

Um den Hintergrund-Downloader wieder zu aktivieren, klicken Sie auf Start > Alle Programme > SolidWorks Installations-Manager > SolidWorks Hintergrund-Downloader.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Nach Aktualisierungsergebnissen suchen

Die Option „Nach Aktualisierungsergebnissen suchen“ sucht nach neueren Versionen von SolidWorks.

Sie können diese Funktion manuell ausführen:
  • Klicken Sie in Windows auf Start > Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen
  • Klicken Sie in SolidWorks auf Hilfe > Nach Aktualisierungen suchen.
Die Funktion „Nach Aktualisierungen suchen“ ist bei Clients, die von Administrator-Installationsabbildern installiert wurden, nicht verfügbar.

Neuere Version verfügbar

Der SolidWorks Installations-Manager hat eine neuere Version von SolidWorks Produkten gefunden. Sie können auf eine neuere Version aktualisieren, indem Sie den SolidWorks Installations-Manager für diese Version auswählen.

Die neuere Version kann Installationsdateien auf der Basis der Produkte herunterladen, die Sie bei der Installation ausgewählt haben. Sie können die heruntergeladenen Dateien mit anderen Anwendern, die auch den SolidWorks Installations-Manager für die Installationen verwenden, gemeinsam verwenden.

Diese Downloads sind nur für die Verwendung durch den SolidWorks Installations-Manager geeignet.
Folgende Optionen stehen zur Verfügung:
  • Falls mehrere Versionen verfügbar sind, können Sie eine Version aus der Liste auswählen.
  • Für Details zu dieser Version klicken Sie auf Inhalt der Aktualisierung prüfen.
Durch Klicken auf Weiter wird die ausgewählte Version des SolidWorks Installations-Managers abgerufen und ausgeführt.

Keine neuen Downloads verfügbar/Es kann nicht nach neuen Versionen gesucht werden

Der SolidWorks Installations-Manager hat keine neuere Version von SolidWorks Produkten gefunden, entweder weil Sie bereits die aktuellste zur Verfügung stehende Version installieren oder weil die zur Überprüfung erforderliche Verbindung zur SolidWorks Website nicht hergestellt werden konnte.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Administrator-Installationsabbild-Position

Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position
Dies ist der Verzeichnisort, an dem der SolidWorks Installations-Manager das neue Installationsabbild erstellt.
Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten. Das Administratorabbild muss sich in einem freigegebenen Ordner befinden, damit es den Clients bereitgestellt werden kann.
Geschätzter erforderlicher Speicher für Abbilderstellung
Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher.
Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von
Die ist der Verzeichnisort, von dem aus Sie SolidWorks Produkte installieren.
Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Einzelheiten finden Sie unter Download-Optionen.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Download-Optionen

Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.

Der SolidWorks Installations-Manager unterstützt die elektronische Software-Bereitstellung (ESD). Wenn Sie nicht von einer SolidWorks DVD installieren, werden Sie aufgefordert, die Quelle für die SolidWorks Produkte, die Sie installieren, anzugeben.

Für Antworten zu Fragen über den Download-Ordner siehe SolidWorks Installations-Manager Download-Ordner.

Was möchten Sie ausführen?

Wählen Sie eine der folgenden Optionen aus:
Herunterladen und installieren/Download und Abbild erstellen
Nach erfolgtem Download führt der SolidWorks Installations-Manager eine Installation mit den heruntergeladenen Dateien aus.
Nur Download. Sie können einmal herunterladen und dann heruntergeladene Dateien auf mehreren Computern verwenden.
Der SolidWorks Installations-Manager führt nach Abschluss des Downloads keine Installation aus.

Normalerweise würden Sie diese Option dann auswählen, wenn Sie die Dateien zum Konfigurieren einer Installationsdatei herunterladen, die auf mehreren Computern verwendet werden soll.

Wenn Sie diese Option auswählen, werden Sie aufgefordert, einen von zwei Dateisätzen auszuwählen, der heruntergeladen werden soll:
  • Dateien für DIESEN Computer: Das Download umfasst nur die Dateien, die in dem aktuell auf diesem Computer befindlichen Installationsdateisatz fehlen.
    Dies sollte ein kleineres Download sein, weil es nur Folgendes enthält:
    • Nur Dateien für die auf der Seite „Produktauswahl“ ausgewählte Produkte
    • Nur die für Ihren Computer erforderlichen, aber noch nicht installierten Dateien

    Wenn Sie jedoch versuchen, diesen heruntergeladenen Dateisatz auf einem anderen Computer zu verwenden, um eine Installation vorzunehmen, könnten einige Dateien fehlen (da sich der Installationsdateisatz auf dem anderen Computer von diesem unterscheiden könnte). Mit diesen Download-Dateien können Sie die Installation auf einem anderen Computer durchführen, aber wenn die Installation ausgeführt wird, müssen Sie möglicherweise zusätzliche Dateien herunterladen, um den Installationsdateisatz auf diesem Computer zu vervollständigen.

  • Dateien für die Verwendung auf JEDEM Computer: Das Download umfasst den vollständigen Installationsdateisatz, mit dessen Hilfe diese Version auf jedem beliebigen Computer installiert werden kann.

    Dieses Download ist umfangreicher, weil es den vollständigen Dateisatz umfasst, den Sie zum Installieren dieser Version eines beliebigen Produkts auf jedem Computer verwenden können.

    Wenn Sie einen begrenzten Satz herunterzuladender Produkte angegeben haben, ignoriert diese Option diese Festlegung und lädt alle in der Produktversion enthaltenen Produkte herunter.

    Das Download enthält alle zum Erstellen eines Administrator-Installationsabbilds benötigten Dateien, also nicht nur diejenigen, die zur Durchführung einer individuellen Installation erforderlich sind.

Nur installieren/Nur Abbild erstellen. Ich habe bereits alle erforderlichen Installationsdateien.
Der SolidWorks Installations-Manager lädt keine Dateien herunter, sondern verwendet die im ausgewählten Verzeichnis befindlichen Dateien.

Klicken Sie auf Durchsuchen, um zu einem anderen Speicherort zu navigieren. So können Sie z. B. zu einer Installations-DVD oder einem Download-Ordner navigieren, solange sich an diesem Speicherort alle benötigten Dateien befinden.

Wenn Sie eine Fehlermeldung erhalten, dass der Ordner nicht vollständig ist, Sie aber davon ausgegangen sind, dass alle Installationsdateien vorhanden sind, sind mögliche Erklärungen folgende:
  • Sie habe eine Komponente zur Installation ausgewählt, die früher noch nicht heruntergeladen wurde, oder sie wurde standardmäßig ausgewählt.
  • Die Dateien wurden auf einem anderen Computer mit anderen Systemanforderungen heruntergeladen.
  • Sie haben früher eine Client-Installation ausgeführt und erstellen nun ein Administrator-Installationsabbild, für das ein größerer Dateisatz erforderlich ist.

Sie können entweder zu einem Ordner navigieren, der alle Dateien enthält (z. B. zu einer DVD), oder eine der Download-Optionen auswählen.

Wohin sollen die erforderlichen Dateien heruntergeladen werden?

Dies ist der Download-Ordner.

In manchen Fällen ist diese Option zwar sichtbar, aber deaktiviert. Wenn z. B. Nur installieren angegeben wird, installiert der SolidWorks Installations-Manager alle heruntergeladenen Dateien aus dem für diese Option ausgewählten Verzeichnis, anstatt einen eigenen Download-Ordner zu verwenden.

Ob Sie diese Dateien nun herunterladen oder auf sie von lokaler Stelle zugreifen – alle Dateien müssen in denselben Download-Ordner heruntergeladen werden.

Geschätzter Download-Umfang

Der geschätzte Festplattenspeicherbedarf für den Download basiert auf der vollständigen ausgewählten Liste, ungeachtet dessen, ob es sich um einen neuen Download handelt oder ob Sie einen Download von einer früheren Sitzung weiterführen.

Wenn Sie z.B. einen früheren Download wieder aufnehmen, verarbeitet der SolidWorks Installations-Manager nur diejenigen Dateien, die noch nicht heruntergeladen wurden. Die Download-Zeit könnte unter der Schätzung liegen.

Wenn eine Datei im Rahmen des vorherigen Downloads vollständig heruntergeladen wurde, ist ihre Größe in dieser Schätzung nicht enthalten. Daher ist die Schätzung möglicherweise größer als der tatsächliche Umfang des Downloads

Wie möchten Sie die Dateien herunterladen?

Dafür gibt es zwei Optionen:
Manueller Download
In manchen Fällen verhindert ein Proxy-Server vom SolidWorks-Installations-Manager initiierte automatische Downloads.
Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SolidWorks-Installations-Managers abschließen. Diese Webseite wird vom SolidWorks-Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.
Beschleunigen Sie die Downloads, indem Sie eine höhere Netzwerk-Bandbreite verwenden
Der Downloader verwendet einen Algorithmus zur Erhöhung der Download-Geschwindigkeit, indem die Netzwerkbandbreite während des Downloads erhöht wird.

In einigen Fällen kann das die Netzwerkleistung stören. Wenn Sie Probleme beim Download haben, wird diese Option vom Proxy-Server u. U. nicht unterstützt. Versuchen Sie, diese Option zu deaktivieren, und den Download zu wiederholen. Einzelheiten erfahren Sie von Ihrem Netzwerk-Administrator.

Diese Option trifft nur auf automatische Downloads zu. Sie hat keinerlei Auswirkung auf manuelle Downloads.

Verwenden des SolidWorks Hintergrund-Downloader

Sie können diesen Downloadvorgang mit dem SolidWorks Hintergrund-Downloader abschließen. Auch können Sie mit dem Downloader SolidWorks Service Pack-Versionen herunterladen, sobald sie zur Verfügung gestellt werden.

Der SolidWorks Hintergrund-Downloader kann neue Service Pack-Aktualisierungen automatisch im Hintergrund erkennen und herunterladen und benachrichtigt Sie, wenn der Download abgeschlossen ist und die Dateien installiert werden können. Einzelheiten finden Sie unter SolidWorks Hintergrund-Downloader.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Download-Optionen für SolidWorks-Installations-Manager-Dateien

Sie haben beschlossen, eine spätere Version des SolidWorks Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.

Für Antworten zu Fragen über den Download-Ordner siehe SolidWorks Installations-Manager Download-Ordner.

Dieser Bildschirm erscheint nur, wenn ein Problem mit den Download-Standardordner vorliegt (wenn z. B. kein Schreib- oder Netzwerkzugriff verfügbar ist). Normalerweise können Sie einfach ein alternatives Download-Verzeichnis angeben, um weitermachen zu können.

Download-Verzeichnis

Wählen Sie den Zielordner für die SolidWorks Installations-Manager Dateien aus.

Es werden der Umfang des Downloads sowie der benötigte Speicherplatz angezeigt. Die Menge des erforderlichen Speicherplatzes beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als die tatsächliche Größe des Downloads.

Download-Beschleuniger verwenden

Wenn Sie diese Option auswählen, verwendet der Downloader einen Algorithmus zur Erhöhung der Download-Geschwindigkeit.

Die Download-Beschleunigung erhöht die Bandbreite und kann die Netzwerkleistung stören. Kontaktieren Sie Ihren Netzwerk-Administrator, bevor Sie die Download-Beschleunigung aktivieren.

Wenn Download-Beschleunigung vom Proxy-Server nicht unterstützt wird, wird diese Option automatisch deaktiviert.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Produkt-Installationsdateien herunterladen

Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.

Der SolidWorks Installations-Manager lädt während des Download-Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Das Abbrechen dieses Bildschirm führt zum Abbruch der restlichen Installationssequenz.

Bezüglich der Konsequenzen eines Abbruchs und Anleitungen zum Abschließen von unterbrochenen Installationen siehe Installationsfehler.

Download-Verzeichnis

Wählen Sie den Zielordner für die heruntergeladenen Dateien aus.

Der Umfang des Downloads und der benötigte Speicherplatz auf der Festplatte werden angezeigt. Der erforderliche Speicherplatz beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als der tatsächliche Umfang des Downloads.

Für Antworten zu Fragen über den Download-Ordner siehe SolidWorks Installations-Manager Download-Ordner.

Download-Optionen

Beschleunigen Sie die Downloads, indem Sie eine höhere Netzwerk-Bandbreite verwenden
Der Downloader verwendet einen Algorithmus zur Erhöhung der Download-Geschwindigkeit, indem die Netzwerkbandbreite während des Downloads erhöht wird.

In einigen Fällen kann das die Netzwerkleistung stören. Wenn Sie Probleme beim Download haben, wird diese Option vom Proxy-Server u. U. nicht unterstützt. Versuchen Sie, diese Option zu deaktivieren, und den Download zu wiederholen. Einzelheiten erfahren Sie von Ihrem Netzwerk-Administrator.

Die Download-Beschleunigung erhöht die Bandbreite und kann die Netzwerkleistung stören. Kontaktieren Sie Ihren Netzwerk-Administrator, bevor Sie die Download-Beschleunigung aktivieren.

Wenn Download-Beschleunigung vom Proxy-Server nicht unterstützt wird, wird diese Option möglicherweise automatisch deaktiviert.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Download-Verlauf

Der SolidWorks Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Um den Download nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Wenn Sie den Download abbrechen oder der Download fehlschlägt, informiert Sie der Bildschirm Download abgebrochen oder Download-Problem darüber, welche Downloads nicht abgeschlossen wurden, und ermöglicht die Fortsetzung des Downloads oder das Schließen der Anwendung.

Für Antworten zu Fragen über den Download-Ordner siehe SolidWorks Installations-Manager Download-Ordner.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Download-Ergebnisse

Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.

Download-Problem/Download abgebrochen

Wenn Download-Problem angezeigt wird, ist der SolidWorks-Installations-Manager auf Probleme gestoßen, die die Durchführung des Downloads verhinderten.

Wenn Download abgebrochen wird, haben Sie den Herunterladevorgang vor seinem Abschluss abgebrochen.

Fahren Sie wie folgt fort:

Download wiederholen/Automatische Downloads wiederholen
Um den automatischen Download an der Stelle fortzusetzen, an der Sie ihn abgebrochen hatten, wählen Sie diese Option aus und klicken Sie auf Download wiederholen oder Download fortsetzen.
Dateien einzeln in einem Webbrowser downloaden
In manchen Fällen verhindert ein Proxy-Server vom SolidWorks-Installations-Manager initiierte automatische Downloads.
Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SolidWorks-Installations-Managers abschließen. Diese Webseite wird vom SolidWorks-Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.

Download abgeschlossen

Der Bildschirm „Download abgeschlossen“ erscheint, wenn der Download abgeschlossen ist und Sie die Option Nur Download ausgewählt haben.

Klicken Sie auf Fertigstellen, um den SolidWorks-Installations-Manager zu beenden.

Versuchen Sie nicht, diese Produkte manuell zu installieren. Verwenden Sie zum Installieren der heruntergeladenen Dateien den SolidWorks-Installations-Manager.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Installationsfehler / Installation abgebrochen

Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.

Wenn ein Fehler oder ein Abbruch eintritt:
  • Produkte, die vor dem Fehler oder Abbruch installiert wurden, bleiben auf dem Computer.
  • Das Produkt, das während des Abbruchs installiert wurde, wird, wenn möglich, zurückgesetzt, sodass keine teilweisen Installationen vorliegen.
  • Die übrigen Produkte werden weder installiert noch deinstalliert. Unter Noch nicht versucht wird eine Liste bereitgestellt.

    Um das Installieren oder Deinstallieren dieser Produkte fortzusetzen, klicken Sie auf den bereitgestellten Link.

Der SolidWorks Installations-Manager installiert zunächst erforderliche Dateien, die auf dem Computer noch nicht installiert sind, wie etwa .NET framework. Danach werden die ausgewählten Produkte in der folgenden Reihenfolge installiert:
  1. SolidWorks
  2. eDrawings
  3. SolidWorks Suche
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation
    Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.
  • Reparieren der Installation
    Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation über die Windows Systemsteuerung reparieren.
  • Kontaktaufnahme mit dem SolidWorks Fachhändler
    Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SolidWorks Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie auch eine Zip-Datei der Protokolldateien des SolidWorks Installations-Managers bereitstellen.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation

Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.

  1. Notieren Sie sich die Fehlermeldung und den Produktcode für die Installation, die fehlgeschlagen ist, so wie sie auf dem Bildschirm Installationsfehler oder Installation abgebrochen angezeigt werden.

    Wenn Sie nach einer Quelldatei gefragt werden und Sie keine vorhandene SolidWorks Installation modifizieren, ist u. U. die Installation oder der Computer defekt. Wenden Sie sich an Ihren SolidWorks Fachhändler.

  2. Starten Sie den Computer neu.
  3. Um sicherzustellen, dass keine SolidWorks Produkte ausgeführt werden, drücken Sie in Windows Strg+Alt+Entf, um den Task Manager zu öffnen.
  4. Wenn auf der Registerkarte Prozesse die folgenden Prozesse unter Name angezeigt werden, wählen Sie sie aus und klicken Sie auf Prozess beenden.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Wenn die Anwendung bereits installiert ist und Sie versuchen, sie zu ändern oder zu entfernen, versuchen Sie, die Installation zu reparieren. Einzelheiten finden Sie unter t_repairing_installation.htm#doc1292869659219.
  6. Klicken Sie in Windows Vist oder später auf Start > Systemsteuerung >Software. Klicken Sie in früheren Versionen von Windows auf Start > Systemsteuerung > Programme.
  7. Wählen Sie die SolidWorks Version aus, die fehlgeschlagen ist.

    Wenn kein Eintrag für die SolidWorks Version, die Sie zu installieren versuchen, vorliegt, wiederholen Sie den Installationsvorgang.

  8. Führen Sie einen der folgenden Schritte aus:
    • Um den Vorgang zu wiederholen, klicken Sie auf Ändern und wählen Sie alle Produkte aus, die nicht installiert oder während der Installation übersprungen wurden.

    • Um die fehlgeschlagene Installation zu überspringen, klicken Sie auf Ändern, und wählen Sie alle Produkte aus, die während der Installation übersprungen wurden. Deaktivieren Sie das Produkt, das nicht installiert wurde.

    • Um die Installation abzubrechen, klicken Sie auf Entfernen, und wählen Sie installierte Produkte aus.

    Dadurch wird eine frühere Version von Produkten, die aktualisiert werden, nicht wieder hergestellt.

Übergeordnetes Thema: Installationsfehler / Installation abgebrochen


Kontaktaufnahme mit dem SolidWorks Fachhändler

Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SolidWorks Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie auch eine Zip-Datei der Protokolldateien des SolidWorks Installations-Managers bereitstellen.

  1. Suchen Sie die Protokolldateien:
    • Für Windows Betriebssystemversionen vor Windows Vista:

      C:\Dokumente und Einstellungen\Benutzername\Anwendungsdaten\SolidWorks\Protokolldateien\Installierte_Version\

    • Für Windows Vista oder höher:

      C:\Benutzer\Benutzername\AppData\Roaming\SolidWorks\Installation Logs\installierte_Version\

    Wenn Sie den Ordner nicht finden können, ist er u. U. ausgeblendet. Klicken Sie in Windows Explorer auf Extras > Ordneroptionen. Wählen Sie auf der Registerkarte Ansicht unter Erweiterte Einstellungen Alle Dateien und Ordner anzeigen unter Versteckte Dateien und Ordner.

  2. Komprimieren Sie den vollständigen Inhalt des Ordners, einschließlich aller Unterordner.
Übergeordnetes Thema: Installationsfehler / Installation abgebrochen


Installation vollständig

Der SolidWorks Installations-Manager hat die Verarbeitung abgeschlossen.

Möglicherweise wird eine oder mehrere der folgenden Optionen angezeigt.

Neue Funktionen

Bei Einzelinstallationen wird bei Beenden des Installationsvorgangs ein Dokument angezeigt, das die neuen Funktionen in SolidWorks und den Zusatzanwendungen beschreibt.

Bei Installationen mit Administrator-Installationsabbild wird das Dokument auf den Client-Computern angezeigt, wenn diese die Installation abschließen.

Umfrage

Teilen Sie uns Ihre Meinung über den Installationsvorgang mit, indem Sie die Fragen in einer kurzen Umfrage beantworten.

Nehmen Sie am SolidWorks Anwendererfahrungs-Optimierungsprogramm teil

Daten über die Leistung werden an die SolidWorks Corporation gesendet, was zur Produktverbesserung beiträgt. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Wählen Sie eine der folgenden Optionen aus:
  • Ja, ich möchte teilnehmen
  • Nein danke
  • Erinnere mich später
Nähere Informationen dazu finden Sie unter Anwendererfahrungs-Optimierungsprogramm – Website.

Erstellung des Administrator-Installationsabbilds ist abgeschlossen

Nach Abschluss der Erstellung des Administrator-Installationsabbilds können Sie auf Customize Image (Abbild anpassen) klicken, um den Administrator-Installationsabbild Options-Editor auszuführen und das Abbild anzupassen.

Klicken Sie auf Anleitung für die Installation dieses Abbilds auf einem Client., um eine Anleitung zur Verwendung des Options-Editors anzuzeigen.

Für Details zur Konfiguration eines Administrator-Installationsabbilds mit dem Options-Editor siehe Administrator-Installationsabbild Options-Editor.

Klicken Sie auf Customize Image, um den Administrator-Installationsabbild Options-Editor zu starten und die Optionseinstellungen für dieses Administrator-Installationsabbild anzupassen.
Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner doppelklicken.
  • Suchen nach SolidWorks Aktualisierungen
    Mithilfe des SolidWorks Installations-Managers können Sie manuell nach eventuellen Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen der SolidWorks Website auf Aktualisierungen konfigurieren.
  • SolidWorks Anwendererfahrungs-Optimierungsprogramm
    Während der Installation von SolidWorks können Sie festlegen, dass Daten über die Leistung an die SolidWorks Corporation gesendet werden, was zur Produktverbesserung beiträgt.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Suchen nach SolidWorks Aktualisierungen

Mithilfe des SolidWorks Installations-Managers können Sie manuell nach eventuellen Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen der SolidWorks Website auf Aktualisierungen konfigurieren.

  1. Starten Sie den SolidWorks Installations-Manager, indem Sie einen der folgenden Vorgänge ausführen:

    • Klicken Sie in der SolidWorks Anwendung auf Hilfe > Nach Aktualisierungen suchen.

    • Klicken Sie in Windows auf Start > Programme > SolidWorks Installations-Manager > Nach Aktualisierungen suchen

    Der SolidWorks Installations-Manager gibt an, ob derzeit Aktualisierungen verfügbar sind.

  2. Wenn Aktualisierungen verfügbar sind, haben Sie die Wahl, ob sie heruntergeladen und installiert werden sollen.
  3. Um regelmäßige, automatische Überprüfungen der SolidWorks Website auf das Vorhandensein von Aktualisierungen zu aktivieren, wählen Sie, nachdem der SolidWorks Installations-Manager die Bearbeitung abschließt, die Option Nach Aktualisierungen alle __ Tage suchen aus, und geben Sie die Häufigkeit dieser Überprüfungen an.
Übergeordnetes Thema: Installation vollständig


SolidWorks Anwendererfahrungs-Optimierungsprogramm

Während der Installation von SolidWorks können Sie festlegen, dass Daten über die Leistung an die SolidWorks Corporation gesendet werden, was zur Produktverbesserung beiträgt.

SolidWorks verwendet diese Informationen, um Tendenzen bei der Produktnutzung und der Qualität festzustellen. Unser Ziel ist es, die höchstmögliche Produktqualität zu liefern, und die Leistungsprotokolle spielen eine wichtige Rolle in diesem Prozess.

Der Vorgang ist transparent. Alle Informationen in den Protokolldateien werden vertraulich behandelt. Sie werden für keine anderen Zwecke genutzt, und niemand wird Sie kontaktieren.

Nähere Informationen dazu finden Sie unter Anwendererfahrungs-Optimierungsprogramm – Website.

Übergeordnetes Thema: Installation vollständig


Installationsort

Geben Sie an, wo SolidWorks installiert werden soll.

Für Installationen mit Ausnahme der Administrator-Installationsabbilderstellung gelten die folgenden Optionen:
Ausgewählte Produkte installieren in
Die ist der Verzeichnisort, an dem Sie SolidWorks installieren.
Beim Aktualisieren oder Ändern einer Installation müssen alle Dateien in das bestehende Installationsverzeichnis installiert werden. In diesem Fall können Sie das Verzeichnis, in dem sich die vorhandene SolidWorks Installation befindet, nicht ändern.
Geschätzter erforderlicher Speicher für Installation
Dies ist der Speicherbedarf, der für die zur Installation oder Änderung der ausgewählten Produkte zusätzlich benötigt wird.
Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Installationsanforderungen zu erfüllen.
Installieren von
Die ist der Verzeichnisort, von dem aus Sie SolidWorks installieren.
Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Einzelheiten finden Sie unter Download-Optionen.
Fragen Sie bei Ihrem Systemadministrator nach, bevor Sie eines der SolidWorks-Installationsverzeichnisse ändern.

Administrator-Installationsabbild-Positionen

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position
Dies ist der Verzeichnisort, an dem der SolidWorks Installations-Manager das neue Installationsabbild erstellt.
Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten.
Geschätzter erforderlicher Speicher für Abbilderstellung
Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher.
Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von
Die ist der Verzeichnisort, von dem aus Sie SolidWorks Produkte installieren.
Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Einzelheiten finden Sie unter Download-Optionen.
Bestehende Installationsabbild-Position
Wenn ein vorhandenes Administrator-Installationsabbild aktualisiert wird, erstellt der SolidWorks Installations-Manager ein neues Installationsbild auf der Grundlage der Einstellungen für dieses bestehende Installationsabbild. Das bereits vorhandene Installationsabbild wird nicht geändert. Hier wird das Verzeichnis des ursprünglichen Installationsabbilds angezeigt, das Sie auf dem Willkommen-Bildschirm angegeben haben.

Versionsspezifische Verzeichnispfade vermeiden

Falls Sie eine Versionsnummer in einem Installationsverzeichnis angeben (z. B. C:\Programme\SolidWorks Corp\SolidWorks 2010\) und diese Installation dann auf SolidWorks 2011 aktualisieren, erhält das SolidWorks 2011 Installationsverzeichnis die Bezeichnung SolidWorks 2010.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Aktualisierungsoptionen

Auf diesem Computer ist derzeit eine oder mehrere SolidWorks Hauptversionen installiert. Wählen Sie aus, ob Sie die neueste vorhandene Version auf die neue Version aktualisieren oder eine neue Installation für die neue Version erstellen möchte.

Diese Wahlmöglichkeit wird nur dann angeboten, wenn auf diesem Computer keine ältere Hauptversion installiert ist. Wenn eine ältere Hauptversion installiert ist, wird diese Installation vom SolidWorks Installations-Manager stets aktualisiert.

(Beginnend mit SolidWorks 2010 werden parallele Installationen mehrerer Service Pack-Versionen der gleichen Hauptversion nicht mehr unterstützt.)

Hinweise zur Aktualisierung:
  • Alle angegebenen Produkte werden aktualisiert.
  • Alle installierten Produkte sind standardmäßig ausgewählt.
  • Wenn Sie die Auswahl eines Produkts aufheben, wird dieses Produkt nicht aktualisiert.
    Wenn Sie die Auswahl einer Produktkomponente aufheben, veranlassen Sie den SolidWorks Installations-Manager dadurch nicht, diese Komponenten zu entfernen. Verwenden Sie zum Entfernen einer Produktkomponente die Funktion Software gemäß der Beschreibung unter Entfernen einer Installation.

Wählen Sie die gewünschte Option aus und klicken Sie zum Fortfahren auf Weiter.

Erstellen einer neuer Installation von SolidWorks version.

Durch Auswahl dieser Option bleibt die ältere Hauptversionsinstallation erhalten; zusätzlich wird eine neue Installation für diese Hauptversion erstellt.

Dies kann von Vorteil sein, wenn Sie auf die ältere Version von SolidWorks zugreifen möchten, auch nachdem die neuere Version installiert ist. Wen Sie z. B. Dateien gemeinsam mit anderen Anwendern nutzen, die noch die ältere Version ausführen, können Sie mit Dateien, die in der neueren Version gespeichert wurden, Kompatibilitätsprobleme zwischen den beiden Versionen vermeiden.

Aktualisieren von SolidWorks previous_major_version auf SolidWorks current_major_version.

Bei Auswahl dieser Option wird die ältere Versionsinstallation auf die neuere Version aktualisiert.
Nach Abschluss der Installation steht die ältere SolidWorks Version auf diesem Computer nicht mehr zur Verfügung.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Installationsfortschritt

Dieser Bildschirm zeigt den Verlauf der Installation.

Um die Installation nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Bezüglich der Konsequenzen eines Abbruchs und Anleitungen zum Abschließen von unterbrochenen Installationen siehe Installationsfehler.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Installationstyp

Geben Sie den Installationsvorgang an, den Sie ausführen möchten, z. B. Erstellen einer neuen Installation, Modifizieren oder Reparieren einer vorhandenen Installation, Erstellen eines Administrator-Installationsabbilds, Installieren von Administrator-Serverprodukten oder Herunterladen von Dateien ohne Installation.

Einzelinstallation

Installiert SolidWorks Produkte auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell nicht auf diesem Computer installiert ist.

Einzelinstallation modifizieren

Modifizieren Sie die bestehende SolidWorks Installation auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell auf diesem Computer installiert ist.
Die folgenden Modifizierungen sind möglich:
  • Hinzufügen oder Entfernen von SolidWorks Produktkomponenten
  • Umsteigen zu einem anderen SolidWorks Paket (z. B. SolidWorks Professional, SolidWorks Premium usw.)
  • Ändern der SolidWorks Seriennummerneinstellung
    Wenn Sie bei einer früheren Installation bereits eine SolidWorks Seriennummer angegeben haben, werden Sie vom SolidWorks Installations-Manager möglicherweise nicht erneut zu deren Eingabe aufgefordert. Sie müssen diese Option auswählen, um die vom SolidWorks Installations-Manager angenommene Seriennummer zu ändern.

Einzelinstallation reparieren

Reparieren Sie die bestehende SolidWorks Installation auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell auf diesem Computer installiert ist.
Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.
Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen mithilfe des Administrator-Installationsabbilds eine Deinstallation vornehmen.

Administrator-Installationsabbild

Administrator-Installationsabbild auf diesem Computer erstellen oder aktualisieren.

Sie können ein Administrator-Installationsabbild zur Installation auf mehreren Computern verwenden. Für Einzelheiten zum Installieren von SolidWorks auf mehreren Clients mithilfe von Administrator-Installationsabbildern siehe Administrator-Installationsabbilder verwenden.

Beim Erstellen oder Aktualisieren von Administrator-Installationsabbildern:
  • Sie können zum Konfigurieren des neues oder aktualisierten Installationsabbilds die Installationseinstellungen eines bestehenden Installationsabbilds oder die standardmäßigen SolidWorks Installationseinstellungen verwenden.
  • Wenn Sie ein bestehendes Installationsabbild aktualisieren:
    • Der SolidWorks Installations-Manager erstellt eine neue Kopie des Installationsabbilds, auch wenn Sie eine Aktualisierung vornehmen. Das ursprüngliche Installationsabbild wird nicht modifiziert.
    • Sie können das aktualisierte Installationsabbild mit Dateien aus dem bestehenden, von Ihnen aktualisierten Installationsabbild erstellen. Dies hat einen kleineren Download zur Folge.
    Wenn Sie kein Installationsabbild angeben, für das ein Service Pack zum Aktualisieren des älteren Installationsabbilds verfügbar ist, können Sie die Vorteile des kleineren Downloads nicht nutzen.
  • Sie können ein 32-Bit-Administrator-Installationsabbild und ein 64-Bit-Administrator-Installationsabbild auf diesem Computer erstellen. Andernfalls wird nur ein Abbild erstellt, das der Hardwarearchitektur dieses Computers entspricht.
    Wenn Sie die Erstellung eines 32-Bit-Abbilds und eines 64-Bit-Abbilds festlegen, wird das SolidWorks-Installationsmedium für beide Architekturen benötigt, um die Installation auszuführen.

Server-Produkte

SolidWorks Administrator-Server-Produkte sind SolidWorks Workgroup PDM Server (Tresor) und SolidNetWork Lizenz-Manager.

Details zu diesen Produkten finden Sie unter:
  • Workgroup PDM
  • Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten

Nur Download

Laden Sie die Installationsdateien für ausgewählte SolidWorks Produkte herunter, ohne die Produkte zu installieren.

Diese Option erscheint nicht, wenn Sie von einer DVD installieren.

Der Inhalt der heruntergeladenen Dateien ist mit dem Inhalt der Dateien identisch, die auf der SolidWorks Installations-DVD verfügbar sind. Bei Auswahl dieser Option wird der vollständige Installationsdateisatz heruntergeladen, ungeachtet dessen, welche Dateien bereits auf dem Computer installiert sind.

Sie können diese Methode verwenden, um einen Server einzurichten, von dem Anwender Installationen ausführen können. Das unterscheidet sich von der Erstellung eines Administrator-Installationsabbilds.

Bei Installation der falschen SolidWorks-Architektur auf diesem Computer

Falls eine Installation mit dem falschen SolidWorks-Installationsmedium für diese Computerarchitektur versucht wird (wenn z. B. versucht wird, 64-Bit-SolidWorks auf einem 32-Bit-Computer zu installieren), sollte im Installationsfenster auf das Problem hingewiesen werden.

Um die Installation fortzusetzen:
  1. Brechen Sie die SolidWorks Installations-Manager-Sitzung ab.
  2. Überprüfen Sie die Computerarchitektur und die Systemanforderungen für diesen Computer.
  3. Wiederholen Sie die Installation mit dem korrekten SolidWorks-Installationsmedium für diese Computerarchitektur.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Manueller Download

Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SolidWorks Installations-Manager zum letzten Mal ausgeführt haben).

Klicken Sie auf den Link, um eine automatisch erzeugte Webseite zu öffnen, die eine vollständige Liste der Dateien enthält, die Sie zum Abschließen des Downloads benötigen.

Sie müssen die Dateien in einen auf der Seite „Zusammenfassung“ angegebenen Ordner herunterladen. Die Installation kann erst beginnen, wenn alle Dateien in diesen Ordner heruntergeladen wurden.

Nachdem Sie die Dateien manuell heruntergeladen haben, klicken Sie auf Weiter, um fortzufahren.

Wenn Sie einen automatischen Download wünschen, können Sie diese Option anders einstellen, indem Sie zur Seite „Zusammenfassung“ zurückkehren und unter „Download-Optionen“ die entsprechende Änderung vornehmen.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Neuere Version verfügbar

Der Installations-Manager hat eine neuere Version von SolidWorks Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.

Wenn Sie von einer DVD installieren

Wählen Sie unter Möchten Sie die neuere Version verwenden? eine der folgenden Optionen:
  • Nein, version weiter von dieser DVD installieren. Sie können danach mit einem kleineren Download aktualisieren.

    Wählen Sie diese Option aus, um mit der Installation mittels des aktuellen Installations-Managers fortzufahren.

    Nach der Installation können Sie mit dem Installations-Manager prüfen, ob Aktualisierungen vorhanden sind, und diese installieren. Klicken Sie auf Start > SolidWorks Installations-Manager > Nach Aktualisierungen suchen, um zu prüfen, ob Aktualisierungen zum Herunterladen verfügbar sind.

    Dies hat einen kleineren Download zur Folge. Andererseits handelt es sich hierbei um einen Zwei-Schritt-Vorgang und die heruntergeladenen Dateien sind versionsspezifisch (und können von anderen Anwendern, die andere Versionen verwenden, nicht genutzt werden).

  • Ja, Installation mit dieser DVD ausführen; dann herunterladen und auf version aktualisieren.

    Wählen Sie diese Option, um eine spätere Version des Installations-Managers herunterzuladen und auszuführen um SolidWorks Produkte für diese Version zu installieren.

    Wenn zur Aktualisierung der DVD-Version eine kleine Service Pack-Version verfügbar ist, installiert der Installations-Manager zuerst die Originalversion von der DVD und aktualisiert das Programm dann mit dem Service Pack. Dies hat einen kleineren Download zur Folge.

    Sie können das gleiche Ergebnis erzielen, wenn Sie die Option zur Fortsetzung der Installation von der DVD auswählen und die Aktualisierung später durchführen.

    Diese Option hat den Vorteil, dass sie nur einen einzigen Verfahrensschritt erfordert.

In den meisten Fällen ist die Installation der Vollversion von DVD und dann die Verwendung des Installations-Managers zur Prüfung und Installation der Aktualisierungen die bevorzugte Methode, da dafür kleinere Downloads erforderlich sind.

Wenn Sie von einem Download installieren

Wählen Sie eine der folgenden Optionen aus:
  • Installation von version fortsetzen.

    Wählen Sie diese Option aus, um die Version des ersten Downloads zu installieren.

  • Eine neue Version herunterladen und installieren: version

    Wählen Sie diese Option aus, um die neue Version herunterzuladen und zu installieren. Wenn mehrere neue Versionen verfügbar sind, können Sie die Version für den Download und die Installation auswählen.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Festgestellte Prozesse

Der SolidWorks Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.

  • Um die Installation fortzusetzen, führen Sie einen der folgenden Schritte aus:
    • Schließen Sie die betroffenen Prozesse (z. B. den Microsoft Windows Task-Manager) und klicken Sie auf Wiederholen.
    • Klicken Sie auf Ignorieren, um ohne Schließen der Prozesse fortzufahren.
  • Zum Beenden der Installation klicken Sie auf Abbrechen.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Produktauswahl

Geben Sie die Produktkomponenten an, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.

Auf der Produktliste:
  • Die Produktliste ist die Liste aller Produkte, die in dem über der Produktliste angegebenen Paket verfügbar sind.
  • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
  • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
  • Wenn Sie eine Modifizierungsinstallation durchführen, erscheint links von den einzelnen Komponenten ein Sternchen (*), wenn Sie eine Änderung an der Produktauswahl vornehmen.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.

Wenn Sie ein Service Pack anwenden, können SolidWorks Features (wie z.B. FeatureWorks), die unter SolidWorks erscheinen, nicht ausgewählt werden. Der Grund dafür ist, dass Sie ein Feature weder hinzufügen oder entfernen können, wenn Sie diese Art von Aktualisierung auswählen.

Die Operationen, die vom SolidWorks Installations-Manager ausgeführt werden, werden von einer Reihe von Produkt-Koexistenzregeln gesteuert. Einzelheiten finden Sie unter Produkt-Koexistenzregeln.

Der SolidWorks Installations-Manager wählt standardmäßig die folgenden Produktkomponenten aus:
  • Wenn Sie eine Aktualisierung oder Service Pack-Aktualisierung durchführen, wählt der SolidWorks Installations-Manager die aktuell installierten Produkte aus.
  • Andernfalls wählt der SolidWorks Installations-Manager alle Produkte aus, für die Sie eine Berechtigung besitzen.
Um die Installations- oder Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, klappen Sie die Produktkomponenten auf und entfernen Sie die Markierung aus dem Kontrollkästchen für die nicht benötigten Komponenten.

Wenn der SolidWorks Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Andere Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SolidWorks Professional oder SolidWorks Premium) für die Installation oder Modifikation zu bestimmen. Der SolidWorks Installations-Manager führt alle SolidWorks Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie käuflich erworben haben oder zu deren Evaluierung Sie berechtigt sind.

SolidWorks Suche

SolidWorks Suche bietet eine leistungsstarke Volltextsuche in SolidWorks Dokumenten, dem Workgroup PDM Tresor und 3D ContentCentral. Die Suche zeigt eine Vorschau und die Dateiposition und den -namen an.

Nach der Installation indiziert SolidWorks Such SolidWorks Dokumente, um schnellere Suchvorgänge zu gewährleisten. Nur SolidWorks Dateien werden standardmäßig indiziert.

Mit der Installation von SolidWorks Suche wird automatisch die Windows Desktopsuche installiert, wenn diese Funktion nicht bereits auf Ihrem Computer installiert ist.

Sprachunterstützung

Klappen Sie das SolidWorks Produkt und die Komponente Sprachen auf, um die Sprachen anzuzeigen, die installiert werden können.

Die Spezifikation Sprachen limitiert nur die Sprachen, die für das SolidWorks Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Für SolidWorks eDrawings®, SolidWorks Workgroup PDM und SolidWorks Explorer z. B. werden alle vorhandenen Sprachen installiert.

Benötigter Speicherplatz

Der SolidWorks Installations-Manager gibt entweder die Gesamtinstallationsgröße oder die Gesamt-Download-Größe unten auf der Seite an.

  • Wenn Sie die Option Nur Download ausgewählt haben, wird die Größe des Downloads angezeigt. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.
    Alle Dateien, die für die Installation erforderlich sind, sind in der Gesamt-Download-Größe erfasst. Wenn einige Dateien bereits in den aktuellen Download-Ordner heruntergeladen wurden, werden sie nicht erneut heruntergeladen. Folglich kann die aktuelle Download-Größe kleiner sein als die angezeigte Gesamt-Download-Größe oder es kann auch sein, dass Sie keine Dateien herunterladen müssen.
  • Ansonsten wird Installationsgröße angezeigt. Installationsgröße ist die Änderung des Festplattenspeicherbedarfs, die auftritt, wenn diese Installation abgeschlossen ist. Aufgrund der Dateikomprimierung sind diese Zahlen stets lediglich Schätzwerte.

    Wenn Sie eine bestehende Installation aktualisieren oder entfernen, kann die Installationsgröße Null sein.

    Die angezeigte Zahl beinhaltet nicht den Speicherplatz, der für den Download oder das Extrahieren der Installationsdateien erforderlich ist.

    Wenn Downloads erforderlich sind und Sie auf dasselbe Laufwerk herunterladen, könnte der tatsächliche Speicherbedarf bedeutend größer sein als die angezeigte Installationsgröße.

    Um die Download- oder Installationszeit für zukünftige Modifizierungen zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Produkte zum Herunterladen

Wählen Sie SolidWorks Produkte zum Herunterladen an einen bestimmten Ablageort aus.

Die Produkte, die heruntergeladen werden können, werden durch die Seriennummer, die Sie bereitgestellt haben, bestimmt:

  • Die Aktion, die für die einzelnen Komponenten ausgeführt werden soll, wird rechts von einem jeden Element angezeigt.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
  • Klicken Sie auf das Kontrollkästchen links von jeder Komponente, um auszuwählen, wie es vom SolidWorks Installations-Manager gehandhabt werden soll.
Der SolidWorks Installation-Manager lädt alle Produktkomponenten herunter, für die Sie eine Berechtigung haben, sofern Sie nichts anderes festlegen. Um die Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, klappen Sie die Produktkomponenten auf und wählen Sie die Komponenten, die Sie nicht benötigen.

Wenn der SolidWorks Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie ein SolidWorks Paket für den Download auswählen. Der SolidWorks Installations-Manager führt alle SolidWorks Produkte auf, die mit dem ausgewählten Paket kompatibel sind.

Wenn der SolidWorks Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Andere Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SolidWorks Professional oder SolidWorks Premium) für die Installation oder Modifikation zu bestimmen. Der SolidWorks Installations-Manager führt alle SolidWorks Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie käuflich erworben haben oder zu deren Evaluierung Sie berechtigt sind.

Sprachunterstützung

Die Spezifikation Sprachen limitiert nur die Sprachen, die für das SolidWorks Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Für SolidWorks eDrawings®, SolidWorks Workgroup PDM und SolidWorks Explorer z. B. werden alle vorhandenen Sprachen installiert.

Benötigter Speicherplatz

Basierend auf den ausgewählten Produkten wird der Speicherplatz angezeigt, der für die Durchführung des Downloads benötigt wird. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.

Um die Download- oder Installationszeit für zukünftige Aktualisierungen und Patches zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Zu reparierende Produkte

Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SolidWorks Produkte mit den Versionsnummern an, die von dieser Verseion des SolidWorks Installations-Managers repariert werden können.

Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.

Klicken Sie auf Reparieren, um mit dem Reparieren der ausgewählten Produkte zu beginnen.

Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild erneut installieren.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Seriennummern

Seriennummern, die im Verteilungspool gefunden werden, assoziieren Ihren Computer mit den SolidWorks Produkten, die Sie erworben haben.

Wenn SolidWorks Produkte bereits auf Ihrem Computer installiert sind, werden diese Seriennummern standardmäßig angezeigt.
  • Geben Sie Ihre SolidWorks Seriennummer ein, wenn Sie nicht bereits angezeigt wird.
  • Wenn Sie Seriennummern für Produkte haben, die nicht unter Ihre SolidWorks Lizenz fallen, klicken Sie auf den Produkteintrag unter Haben Sie andere Seriennummern? und geben Sie die Seriennummer des betreffenden Produkts ein.

Wenn Sie eine Internetverbindung haben, bestimmen die von Ihnen angegebenen Seriennummern, zu welchen Produkten Sie berechtigt sind, während Sie den Installationsprozess fortsetzen.

Da es viele Möglichkeiten gibt, SolidWorks Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SolidWorks Seriennummer es Ihnen beispielsweise gestatten, SolidWorks Simulation zu installieren, ohne eine separate SolidWorks Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Server-Installation

Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.

Server-Installationsstatus

Installationen von Server-Produkten werden über eine externe Installationsanwendung durchgeführt. Wenn diese Anwendung aktuell nicht geöffnet ist, müssen Sie zu ihr wechseln, um die Installation abzuschließen.

Klicken Sie auf Abbrechen, um die Server-Produkt-Installationen zu beenden.

Server-Installation abgeschlossen

Die externe Installationsanwendung wurde erfolgreich abgeschlossen.

Klicken Sie auf Fertig stellen oder auf Weiter.
  • Wenn Sie auch andere Administrator-Produkte (z. B. ein SolidWork Administrator-Installationsabbild) installieren, wird diese Installation fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SolidWorks Installations-Manager geschlossen.

Server-Installation abgebrochen oder fehlgeschlagen

Wenn die Installation eines Server-Produkts fehlschlug oder abgebrochen wurde, während sie bereits lief, werden die Server, die nicht installiert wurden, aufgeführt.

Klicken Sie auf Schließen oder Weiter.
  • Wen Sie Installationen weiterer Administrator-Produkte ausgewählt haben, wird der SolidWorks Installations-Manager fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SolidWorks Installations-Manager geschlossen.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


SolidNetWork Lizenz-Manager

Legen Sie Installationsoptionen für das Server-Produkt "SolidNetWork Lizenz-Manager" fest.

Seriennummern

Geben Sie SolidNetWork Lizenz-Seriennummern an. Sie können mehrere Seriennummern eingeben, indem Sie sie mit Kommas trennen.
SolidNetWork Seriennummern unterscheiden sich von SolidWorks Seriennummern.

Installationsort

Geben Sie den Installationsort für den SolidNetWork Lizenz-Manager an.

Wenn Sie einen vorhandenen SolidNetWork Lizenz-Manager aktualisieren, müssen Sie dafür den vorhandenen Installationsort verwenden.

Weitere Informationen

Details über die Installation, Konfiguration und Verwendung von SolidNetWork Lizenz-Manager finden Sie unter Lizenzen mit einem SolidNetWork Lizenz-Manager verwalten.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Zusammenfassung

Der SolidWorks Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.

Fahren Sie wie folgt fort: | Klicken Sie auf die Schaltfläche Jetzt action, um den Installationsvorgang zu starten (z. B. Jetzt installieren, Jetzt erstellen, Jetzt herunterladen, Jetzt modifizieren).
Ändern der Installationseinstellungen: | Klicken Sie für den Abschnitt, an dem Sie Änderungen vornehmen möchten, auf ÄNDERN [image] (z. B. Produkte, Installationsort, Toolbox Optionen).
Abbrechen:. | Klicken Sie auf Abbrechen [image] , um den SolidWorks Installations-Manager zu beenden, ohne Installationskomponenten zu ändern.
Zurückkehren zu einer vorherigen Seite: | Klicken Sie auf Zurück [image] , um zu einer vorhergehenden Seite im SolidWorks Installations-Manager zurückzukehren.
Anzeigen von Informationen über eine bestimmte Gruppe von Installationsoptionen (z. B. Produkte, Installationsort, Toolbox Optionen usw.):
  1. Klicken Sie neben dem Abschnitt, für den Sie Informationen einsehen möchten, auf ÄNDERN [image].
  2. Klicken Sie auf der daraufhin angezeigten Detailseite auf Hilfe [image], um Informationen über die Einstellungen dieser Installationsoption anzuzeigen.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Warnungen bei der Systemprüfung

Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SolidWorks Installations-Manager fortfahren können.

Es folgen Warnungen, die in diesem Stadium ausgegeben werden können, und entsprechende empfohlene Maßnahmen.

Probleme bei der Seriennummervalidierung
Der Installations-Manager konnte nicht nach neuen Versionen suchen, da Ihre Seriennummer nicht validiert werden konnte. Wenn Sie eine aktive Verbindung zum Server haben und eine gültige Seriennummer eingegeben haben, könnte dies auf ein temporäres Problem auf unserem Server hinweisen. Versuchen Sie es später noch einmal.

Seriennummervalidierung: Der Installations-Manager konnte Ihre Seriennummer nicht validieren, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen einen vollständigen Satz an Download-Quelldateien oder eine DVD für die Installation bereit stellen.

Lösung:
  • Prüfen Sie die Internetverbindung. Für die Seriennummervalidierung ist eine funktionierende Internetverbindung erforderlich.
  • Überprüfen Sie, ob die eingegebene Seriennummer für die Produkte gilt, die Sie installieren möchten.
  • Bei bestimmten Installationen ist es erforderlich, dass zum Zeitpunkt der Freigabe der Version ein gültiger Subskriptionsvertrag besteht. Nähere Informationen dazu erhalten Sie von Ihrem SolidWorks-Fachhändler.
  • In den meisten Fällen können Sie die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.
Neuere Version verfügbar
Neuere Version verfügbar

Neue Versionen verfügbar

Eine neuere Version dieses Produkts steht zum Download bereit.

Lösung: Beim Ausführen der Funktion "Nach Aktualisierungen suchen" werden Sie möglicherweise aufgefordert, eine neuere Version zu installieren, die zum Download auf der SolidWorks-Website bereit steht. Sie können den Vorgang mit der ursprünglich angegebenen Version fortsetzen, oder Sie können die neuere Version herunterladen und den Vorgang mit der neueren Version fortsetzen.

Neueste verfügbare Version
Dies ist die neueste verfügbare Version. Klicken Sie zum Fortfahren auf "Weiter".

Keine neuen Downloads verfügbar

Lösung: Diese Meldung kann erscheinen, wenn während einer Installation oder Modifizierung nach Aktualisierungen gesucht wird. Die Meldung weist darauf hin, dass Sie die neuste verfügbare Version installieren bzw. installiert haben.

Probleme mit der Internetverbindung
Internetverbindung: Der Installations-Manager konnte keine Verbindung zum SolidWorks-Server herstellen, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen Quelldateien auf DVD oder einen zuvor heruntergeladenen Dateisatz bereitstellen.

Es kann nicht nach neuen Versionen gesucht werden

Der Installations-Manager konnte nicht nach neuen Versionen suchen, da eine Verbindung zum Server nicht hergestellt werden konnte.

Lösung:
  • Prüfen Sie die Internetverbindung.
  • Sie können die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Bohrungsassistent/Toolbox-Optionen

Wenn SolidWorks Toolbox installiert ist, beinhaltet SolidWorks eine Standardbibliothek von Bohrungstypen und Maschinenteilen.

Wenn Sie nähere Einzelheiten zu Konfiguration, Erweiterung und Gebrauch von SolidWorks Toolbox wünschen, klicken Sie auf Hilfe > Toolbox Hilfe in SolidWorks.
Um diese Hilfe anzuzeigen, müssen Sie über Extras > Zusatzanwendungen möglicherweise die Toolbox Zusatzanwendung starten.

Bevor Sie SolidWorks Toolbox verwenden, sollten Sie überprüfen, ob die Anwendung gemäß den Firmen- oder Gruppenbestimmungen konfiguriert ist. In vielen Fällen konfiguriert und unterhält eine Gruppe eine zentrale Toolbox. Lassen Sie sich vom SolidWorks Administrator über die Auswahl einer Toolbox während der SolidWorks Installation beraten.

Sie können die ausgewählte SolidWorks Toolbox nach der Installation wieder ändern. Klicken Sie in SolidWorks auf Extras > Optionen. Klicken Sie auf der Registerkarte Systemoptionen auf Bohrungsassistent/Toolbox.

In den folgenden Abschnitten sind alle Optionen beschrieben, die auf diesem Bildschirm für alle Konfigurationen möglich sind. Die tatsächlich angezeigten Toolbox Optionen hängen von den bereits vorhandenen SolidWorks und Toolbox Konfigurationen auf diesem Computer und den bisher ausgewählten SolidWorks Installations-Manager-Optionen ab.

Erstellen einer neuen new-version Toolbox

Erstellen Sie eine neue Version von SolidWorks Toolbox auf diesem Computer.

Wenn Sie eine neue Version erstellen, erweitern Sie im Bildschirm für die Produktauswahl SolidWorks > SolidWorks Toolbox, und wählen Sie die Normen aus, die für die Toolbox unterstützt werden sollen. Alle Normen sind standardmäßig ausgewählt.

Keine der auf diesem Computer bereits vorhandenen Toolboxes werden modifiziert.

Referenzieren oder Aktualisieren einer vorhandenen Toolbox

Verwenden Sie eine bestehende Toolbox. Klicken Sie auf Durchsuchen, um den Ablageort der Toolbox festzulegen, die zusammen mit dieser Installation verwendet werden soll.

  • Wenn die Toolbox für eine ältere SolidWorks Hauptversion konfiguriert ist, wird sie auf diese Version aktualisiert. Alle an dieser Toolbox vorgenommenen Anpassungen bleiben in der aufgerüsteten Toolbox erhalten.
    Durch die Aktualisierung einer Toolbox auf eine neue SolidWorks Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SolidWorks Hauptversionen ausgeführt werden.
  • Wenn die Toolbox für diese SolidWorks Version konfiguriert ist (was der Fall sein könnte, wenn Sie eine bereits aktualisierte Toolbox auf einem freigegebenen Netz festlegen), findet keine Aktualisierung dieser Toolbox statt.
  • Wenn Sie eine Toolbox in einer Enterprise PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Aktualisieren von Toolbox in einer SolidWorks Enterprise PDM Umgebung.

Diese Option erscheint in allen Installationsszenarien mit Ausnahme des Szenarios für die Erstellung eines Administrator-Installationsabbilds.

Aktualisieren einer previous-version Toolbox

Kopieren Sie eine für eine ältere Hauptversion konfigurierte Toolbox an einen neuen Speicherort und aktualisieren Sie diese Kopie auf diese Version.

Diese Option erscheint, wenn auf diesem Computer eine ältere SolidWorks Hauptversion installiert ist, Sie aber entschieden haben, diese Installation dieser Version nicht zu aktualisieren.
Der Zweck dieser Option besteht in der Aktualisierung einer Toolbox für eine ältere installierte SolidWorks Hauptversion, ohne dass Anwender, die die ältere Toolbox Version verwenden, in ihrer Arbeit beeinträchtigt werden.

Wenn Sie eine Toolbox in einer Enterprise PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Aktualisieren von Toolbox in einer SolidWorks Enterprise PDM Umgebung.

Aktualisieren dieser installierten vorige Version Toolbox

Aktualisieren Sie diese Toolbox auf die neuere Version.
Durch die Aktualisierung einer Toolbox auf eine neue SolidWorks Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SolidWorks Hauptversionen ausgeführt werden.

Diese Option wird angezeigt, wenn Sie eine ältere SolidWorks Hauptversion auf diese Version aktualisieren und auf diesem Computer eine für diese ältere Version konfigurierte Toolbox vorgefunden wird.

Wenn Sie eine Toolbox in einer Enterprise PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Aktualisieren von Toolbox in einer SolidWorks Enterprise PDM Umgebung.

Gebrauch dieser installierten aktuelle Version Toolbox

Der SolidWorks Installations-Manager hat auf diesem Computer eine Toolbox festgestellt, die für diese SolidWorks Hauptversion konfiguriert ist.

Wenn Sie diese Option auswählen, verwendet SolidWorks diese Toolbox. Es findet keine Aktualisierung statt.

Diese Option erscheint, wenn auf diesem Computer eine ältere SolidWorks Hauptversion installiert ist, aber eine Toolbox für diese Version konfiguriert ist. Diese Situation kann eintreten, wenn auf einem Computer, auf dem noch eine ältere SolidWorks Version läuft, eine freigegebene Toolbox erstellt wird.

Toolbox Ablageort für den Client-Computer festlegen

Legen Sie einen Netzwerk- oder Verzeichnisort als Toolbox Standardablageort fest, wenn Clients eine Installation von einem Administrator-Installationsabbild aus durchführen.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SolidWorks Hauptversion konfiguriert ist, aktualisiert der SolidWorks Installations-Manager diese Toolbox.

Diese Option erscheint, wenn Sie ein neues Administrator-Installationsabbild erstellen.

Toolbox, auf die im bestehenden Installationsabbild für den Client-Computer Bezug genommen wird, aktualisieren oder verwenden

Verwenden Sie den Toolbox-Speicherort, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SolidWorks Hauptversion konfiguriert ist, aktualisiert der SolidWorks Installations-Manager diese Toolbox.

Anderen Toolbox Ablageort für den Client-Computer festlegen

Geben Sie einen anderen Toolbox-Speicherort als denjenigen an, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SolidWorks Hauptversion konfiguriert ist, aktualisiert der SolidWorks Installations-Manager diese Toolbox.
  • Hinweise zur Konfiguration von SolidWorks Toolbox
    SolidWorks Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SolidWorks Installations-Manager in Betracht zu ziehen sind.
  • UNC-Format
    Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Hinweise zur Konfiguration von SolidWorks Toolbox

SolidWorks Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SolidWorks Installations-Manager in Betracht zu ziehen sind.

Weitere Informationen über SolidWorks Toolbox

Wenn Sie nähere Einzelheiten zu Konfiguration, Erweiterung und Gebrauch von SolidWorks Toolbox wünschen, klicken Sie auf Hilfe > Toolbox Hilfe in SolidWorks.
Um diese Hilfe anzuzeigen, müssen Sie über Extras > Zusatzanwendungen möglicherweise die Toolbox Zusatzanwendung starten.

Gebrauch einer freigegebenen Toolbox

Bei der Installation von Toolbox können Toolbox Daten auf dem lokalen Computer oder in einem freigegebenen Verzeichnis gespeichert werden. Empfohlen wird die Speicherung der Toolbox Daten in einem freigegebenen Netzwerkverzeichnis. Durch die Verwendung eines gemeinsamen Verzeichnisses ist sichergestellt, dass alle SolidWorks Anwender dieselben Verbindungselementdaten verwenden.

Wenn dies eine Erstinstallation ist, gehen Sie zum neuen freigegebenen Verzeichnis, in dem Toolbox installiert werden soll.

Aktualisierung einer bestehenden Toolbox Anwendung

Durch die Aktualisierung einer Toolbox auf eine neue SolidWorks Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SolidWorks Hauptversionen ausgeführt werden.

Wenn andere Computer diese ältere Hauptversion weiterhin verwenden und auch weiterhin eine für diese Version konfigurierte Toolbox benötigen, sollten Sie eine Kopie dieser Toolbox anfertigen und diese Kopie dann aktualisieren. Die neue SolidWorks Installation aktualisiert dann die Kopie der Toolbox und die früheren SolidWorks Installationen verwenden weiterhin die alte Toolbox.

Toolbox Zugriff konfigurieren

Nach der Installation, wenn Sie auf Toolbox Komponenten zugreifen, prüft SolidWorks, wie Toolbox konfiguriert ist und macht Vorschläge für einen verbesserten Zugriff und eine erhöhte Leistung.

Verwenden Sie für den Zugriff auf Toolbox auf einem freigegebenen Netz (empfohlen), einen UNC-Pfad zum Server, auf dem die freigegebene Toolbox installiert wurde. Einzelheiten finden Sie unter UNC-Format.

Der Administrator kann ein Passwort für Toolbox erstellen sowie Zugriffsrechte und Anwendereinstellungen für die Arbeitsgruppe festlegen. Durch die Beschränkung des Zugriffs auf die Konfiguration und die Einrichtung gemeinsamer Anwendereinstellungen wird sichergestellt, dass konsistente Toolbox Daten verwendet werden.

Aktualisieren von Toolbox in einer SolidWorks Enterprise PDM Umgebung

Beachten Sie Folgendes, bevor Sie die erste SolidWorks Installation aktualisieren, mit der der Toolbox-Ordner in einem Enterprise PDM Tresor aufgerufen wird:
  1. Gehen Sie in Windows Explorer zum Toolbox Ordner im Enterprise PDM Tresor.
  2. Klicken Sie mit der rechten Maustaste auf den Toolbox Ordner, und klicken Sie auf Aktuellste Version aufrufen.

    Somit kann der SolidWorks Installations-Manager überprüfen, welche Teile aktualisiert werden müssen.

  3. Checken Sie den Toolbox-Ordner aus.

    Der Toolbox-Ordner muss ausgecheckt werden, damit der SolidWorks Installations-Manager die Toolbox aktualisieren kann.

  4. Checken Sie nach der Aktualisierung den Toolbox-Ordner ein.

Die Toolbox Bibliothek im Tresor ist jetzt aktualisiert.

Vor der Initiierung aller nachfolgenden SolidWorks Aktualisierungen müssen Enterprise PDM Clients die aktuellste Version des Toolbox Ordners im Tresor aufrufen (mit dem Befehl Aktuellste Version aufrufen). Auf diese Weise kann der SolidWorks Installations-Manager sicherstellen, dass die Dateien auf dem neuesten Stand sind.

Bezüglich Details zur Toolbox Konfiguration in SolidWorks Enterprise PDM siehe Toolbox konfigurieren in der SolidWorks Enterprise PDM Administrationswerkzeug-Hilfe.

Übergeordnetes Thema: Bohrungsassistent/Toolbox-Optionen


UNC-Format

Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.

\\Server\Datenträger\Pfad

Beispiel:

\\Disk_Server\SolidWorks\AdminImage

Übergeordnetes Thema: Bohrungsassistent/Toolbox-Optionen


Produkte deinstallieren

Wenn Sie Entfernen oder Programme Deinstallieren in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SolidWorks Produkte (mit Versionsnummern) an, die von dieser Version des SolidWorks Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.

Die Standarddeinstallation entfernt Programmdateien und Ordner eines SolidWorks Produkts. Standardmäßig werden alle SolidWorks Produkte für die ausgewählte Version für eine Standarddeinstallation festgelegt.

In einer benutzerdefinierten Deinstallation werden eines oder mehrere der folgenden Elemente entfernt: Programmdateien und Ordner, Registrierungsschlüssel und Datenordner, wie SolidWorks Toolbox, sowie Dateien und Ordner aus dem ursprünglichen Download-Verzeichnis.

In einer vollständigen Deinstallation werden die Installationsverzeichnisse, Registrierungsschlüssel und Datenordner entfernt.

Ein Produkt deinstallieren:
  1. Wählen Sie auf dem Bildschirm Deinstallieren das Produkt aus.

    Wenn Sie alle Produkte deinstallieren, wird auch der Solidworks Installations-Manager deinstalliert.

  2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.

    Wenn Sie ein Produkt behalten, wird der SolidWorks Installations-Manager nicht deinstalliert.

  3. Wählen Sie, ob eine benuterzdefinierte oder vollständige Deinstallation durchgeführt werden soll.
    1. Klicken Sie auf Ändern in Erweiterte Optionen.

      Der Bildschirm Erweiterte Optionen wird eingeblendet. Die Option Programmdateien und Ordner ist aktiviert.

    2. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen, um eine vollständige Deinstallation durchzuführen.
    3. Klicken Sie auf Zurück zu Übersicht.
    4. Klappen Sie auf dem Bildschirm Übersicht Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.
  4. Klicken Sie auf Elemente entfernen [image].
Wenn Sie auf Elemente entfernen klicken, beginnt der SolidWorks Installations-Manager unverzüglich mit dem Entfernen von Produkten.
Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Optionen des Workgroup PDM Server

Legen Sie die Installationsoptionen für das Serverprodukt "SolidWorks Workgroup PDM" fest.

Installationsort

Legen Sie den Installationsort für die Workgroup PDM-Serverprodukte fest.

Zu installierende Produkte

Geben Sie die zu installierenden Workgroup PDM-Serverprodukte an:
Workgroup PDM Tresor
Legen Sie den Speicherort für die Workgroup PDM Vault-Daten fest. Eine Workgroup PDM Viewer Lizenz muss mit dem Tresor installiert sein, damit der Viewer aktiviert werden kann.
Workgroup PDM Viewer
Wenn der Workgroup PDM Viewer installiert wird, müssen Sie den Namen oder die IP-Adresse des Workgroup PDM Vault-Computers angeben, auf den der Viewer zugreifen wird.
Workgroup PDM API

Eine Lizenz für Workgroup PDM API ist in die Lizenzen für SolidWorks Clients und Explorer Clients integriert. Für APIs zum Einchecken sind Client-Lizenzen erforderlich.

Weitere Informationen

Ausführliche Informationen zur Installation von Workgroup PDM finden Sie unter Workgroup PDM.

Ausführliche Informationen zur Verwendung von Workgroup PDM finden Sie unter Workgroup PDM in der SolidWorks-Hilfe.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Rechtliche Hinweise

© 1995-2011, Dassault Systèmes SolidWorks Corporation, ein Unternehmen der Dassault Systèmes S.A.-Gruppe, 175 Wyman Street, Waltham, Mass. 02451 USA. Alle Rechte vorbehalten.

Die Informationen in diesem Dokument sowie die behandelte Software können ohne Ankündigung geändert werden und stellen keine Verpflichtungen seitens der Dassault Systèmes SolidWorks Corporation (DS SolidWorks) dar.

Es ist untersagt, Material ohne ausdrückliche schriftliche Genehmigung von DS SolidWorks in irgendeiner Form oder auf irgendeine Weise, elektronisch oder manuell, für welchen Zweck auch immer, zu vervielfältigen oder zu übertragen.

Die in diesem Dokument behandelte Software wird unter einer Lizenz ausgeliefert und darf nur in Übereinstimmung mit den Lizenzbedingungen verwendet und kopiert werden. Alle Gewährleistungen, die von DS SolidWorks in Bezug auf die Software und Dokumentation übernommen werden, sind im vorliegenden Lizenzvertrag festgelegt, und nichts, was in diesem Dokument aufgeführt oder durch dieses Dokument impliziert ist, darf als Modifizierung oder Änderung dieser Gewährleistungen betrachtet werden.

Patenthinweise

Die SolidWorks®-3D-CAD-Software für Maschinenbau ist durch die US-amerikanischen Patente 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 und Patente anderer Länder (z. B. EP 1,116,190 und JP 3,517,643) geschützt.

Die eDrawings® Software ist durch die US-amerikanischen Patente 7,184,044 und 7,502,027; sowie das kanadische Patent 2,318,70 geschützt.

Weitere US-amerikanische Patente und Patente anderer Länder angemeldet.

Warenzeichen und Produktnamen für SolidWorks Produkte und Services

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings und das eDrawings Logo sind eingetragene Marken und FeatureManager ist eine eingetragene Gemeinschaftsmarke der DS SolidWorks Corporation.

CircuitWorks, FloXpress, TolAnalyst und XchangeWorks sind Marken von DS SolidWorks.

FeatureWorks ist eine eingetragene Marke von Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Workgroup PDM, SolidWorks Simulation, SolidWorks Flow Simulation, eDrawings Professional und SolidWorks Sustainability sind Produktnamen von DS SolidWorks.

Andere Marken- oder Produktbezeichnungen sind Marken oder eingetragene Marken der jeweiligen Eigentümer.

KOMMERZIELLE COMPUTER-SOFTWARE – EIGENTUMSRECHTE

Bei der Software handelt es sich um ein “Handelsgut” laut Begriffsdefinition unter 48 C.F.R. 2.101 (OCT 1995), bestehend aus “kommerzieller Computer-Software” und “kommerzieller Software- Dokumentation” laut Begriffsdefinition in 48 C.F.R. 12.212 (SEPT 1995) und wird der US-Regierung (a) zum Erwerb von oder im Namen von Zivilbehörden, laut der Bestimmung in 48 C.F.R. 12.212; oder (b) zum Erwerb von oder im Namen von Abteilungen des Verteidigungsministeriums, laut den Bestimmungen in 48 C.F.R. 227.7202-1 (JUN 1995) und 227.7202-4 (JUN 1995) bereit gestellt.

Falls Sie eine Anfrage einer der Behörden der US-Regierung zur Bereitstellung der Software mit Rechten, die die obengenannten überschreiten, erhalten, setzen Sie SolidWorks über das Ausmaß der Anfrage in Kenntnis, und SolidWorks verfügt über fünf (5) Werktage, um nach eigenem Ermessen eine solche Anfrage zu akzeptieren oder abzulehnen. Lieferant/Hersteller: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

Copyright-Vermerke für die Produkte SolidWorks Standard, Premium, Professional und Education

Teile dieser Software sind urheberrechtlich geschützt von Siemens Product Lifecycle Management Software Inc., © 1986-2011.

Dieses Werk enthält die folgende Software, die Siemens Industry Software Limited gehört:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Alle Rechte vorbehalten.

Teile dieser Software sind urheberrechtlich geschützt von Geometric Ltd., © 1998-2011.

Teile dieser Software sind urheberrechtlich geschützt von der Microsoft Corporation, © 1996-2011. Alle Rechte vorbehalten.

Teile dieser Software beinhalten PhysX™ von NVIDIA, 2006-2010.

Teile dieser Software sind urheberrechtlich geschützt von Luxology, LLC, © 2001-2011. Alle Rechte vorbehalten, Patente angemeldet.

Teile dieser Software sind urheberrechtlich geschützt durch DriveWorks Ltd., © 2007-2011

Urheberrechtlich geschützt von Adobe Systems Inc. und Lizenzgebern, © 1984-2010. Alle Rechte vorbehalten. Geschützt durch die US-amerikanischen Patente 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patente angemeldet.

Adobe, das Adobe Logo, Acrobat, das Adobe PDF Logo, Distiller und Reader sind eingetragene Marken oder Marken von Adobe Systems Inc. in den USA und anderen Ländern.

Weitere SolidWorks® Copyright-Information finden Sie unter Hilfe > SolidWorks Info.

Copyright-Vermerke für SolidWorks Simulation Produkte

Teile dieser Software sind urheberrechtlich geschützt durch die Solversoft Corporation, © 2008.

PCGLSS © 1992-2010 Computational Applications and System Integration Inc. Alle Rechte vorbehalten.

Copyright-Vermerke für das Produkt SolidWorks Enterprise PDM

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation. Alle Rechte vorbehalten.

Copyright-Vermerke für eDrawings Produkte

Teile dieser Software sind urheberrechtlich geschützt durch Tech Soft 3D, © 2000-2011.

Teile dieser Software sind urheberrechtlich geschützt durch Jean-Loup Gailly und Mark Adler, © 1995-1998.

Teile dieser Software sind urheberrechtlich geschützt durch 3Dconnexion, © 1998-2001.

Teile dieser Software sind urheberrechtlich geschützt von Open Design Alliance, © 1998-2011. Alle Rechte vorbehalten.

Teile dieser Software sind urheberrechtlich geschützt durch die Spatial Corporation, © 1995-2010.

Die Software basiert zum Teil auf der Arbeit der Independent JPEG Group.


Installieren und Verwalten mehrerer Computer

Der SolidWorks Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren Computern und deren Verwaltung.

SolidWorks Administrator-Installationsabbilder

Wenn Sie SolidWorks auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

Workgroup PDM Server

Die Workgroup PDM Anwendung ist ein Programm für die Projektdatenverwaltung, das innerhalb der SolidWorks Software oder in SolidWorks Explorer als eine eigenständige Anwendung ausgeführt wird. Mit Workgroup PDM können Sie für Projekte das Ein- und Auschecken, die Versionskontrolle und andere verwaltungstechnische Aufgaben steuern. Mit der Installation von Workgroup PDM Server wird ein Workgroup PDM Tresor erstellt, der die Datenbank für die verwalteten SolidWorks Projekte ist.

SolidNetWork Lizenz-Manager

Der SolidNetWork Lizenz-Manager ermöglicht durch den variablen Einsatz von Lizenzen, dass die Anzahl der Anwender über die Anzahl der Lizenzen hinausgeht. Wenn eine Client-Lizenz nicht in Verwendung ist, ist sie für einen anderen SolidWorks Anwender verfügbar.

Sie können den SolidNetWork Licenz-Manager auch dafür verwenden, Lizenzen für die wichtigsten SolidWorks Zusatzanwendungen (z. B. FeatureWorks) zu verteilen.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe


Keine neuen Versionen verfügbar

Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.

Um mit der Installation fortzufahren, klicken Sie auf Weiter.

Übergeordnetes Thema: SolidWorks Installations-Manager-Anwendungshilfe