Installazione e amministrazione di SolidWorks

Questa guida descrive l'installazione, la licenza, l'aggiornamento e l'amministrazione di prodotti SolidWorks per installazioni singole e multiple.

Installazioni individuali | Funzionamento delle installazioni multiple
Installazione Installazione su uno o alcuni computer. | Installazione Creazione di un'immagine amministrativa distribuita su un numero di computer client.
Licenze Attivazione della licenza o licenze in rete. | Licenze Attivazione della licenza o licenze in rete.
Aggiornamenti Migrazione di singoli computer a una nuova release. | Aggiornamenti Spostamento di più computer a una nuova release aggiornando l'immagine amministrativa utilizzata per l'installazione su tali computer.
Amministrazione Modifica, riparazione e rimozione di installazioni, aggiornamento alle nuove release. | Amministrazione Aggiornamento di immagini amministrative e client, amministrazione delle licenze di rete, amministrazione del vault Workgroup PDM.

La Gestione installazioni di SolidWorks consente di configurare le impostazioni dei componenti di prodotti SolidWorks, compresi SolidWorks, SolidWorks Toolbox, PhotoView 360, Workgroup PDM e SolidNetWork License Manager per SolidWorks.

Workgroup PDM è un software di gestione dati di progettazione in esecuzione nell'ambiente SolidWorks o come applicazione standalone all'interno di SolidWorks Explorer. Workgroup PDM controlla i progetti con le procedure di check-out, check-in, il controllo di revisione e altre operazioni amministrative.

SolidNetWork License Manager supporta più client di licenza con la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

  • Installazione individuale o Immagine amministrativa
    I prodotti SolidWorks devono essere installati su ogni computer individualmente o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un solo comando?
  • Inizio dell'installazione di SolidWorks
    È possibile iniziare l'installazione di SolidWorks da un DVD sul computer locale, accedendo a una directory di installazione condivisa o scaricando i file da SolidWorks.


Installazione individuale o Immagine amministrativa

I prodotti SolidWorks devono essere installati su ogni computer individualmente o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un solo comando?

Se si effettua l'installazione solo su un computer o si gestiscono dozzine o centinaia di computer, la scelta è ovvia. Per le altre situazioni, considerare quanto segue.

Installazione individuale | Immagine amministrativa
Gli utenti possono creare la loro amministrazione di SolidWorks. | L'amministratore di sistema può personalizzare installazioni multiple usando l'Editor opzioni, specificando le opzioni di installazione come la creazione di una nuova installazione o aggiornandone una esistente, eseguendo l'installazione come utente amministrativo, eseguendo comandi esterni prima o dopo l'installazione, raggruppamenti di prodotti diversi e così via.
I computer devono essere fisicamente accessibili alla persona che effettua l'installazione. | I computer client possono essere distanti ma devono essere accessibili dalla stessa rete.
Si possono installare versioni diverse, Service Pack o prodotti su computer diversi con impostazioni indipendenti. | Usando l'Editor opzioni, le immagini amministrative possono mantenere la coerenza nelle versioni, service pack, prodotti ed impostazioni per installazioni multiple.
Il DVD originale è necessario per l'applicazione dei Service Pack. | Le unità dei supporti non sono necessarie per l'applicazione dei Service Pack.
Il computer non ha bisogno di essere in rete. | La connessione di rete locale è necessaria per distribuire l'applicazione; le unità dei supporti non sono necessarie sui computer client.
 | I client possono essere aggiornati automaticamente. Tutti i client implementati dalla stessa immagine amministrativa hanno lo stesso Service Pack. Per mantenere versioni multiple, è possibile creare immagini amministrative multiple.
 | L'attivazione delle licenze può essere automatizzata.
 | Un'immagine amministrativa necessita di spazio disco addizionale sul server; i client hanno bisogno dello stesso spazio per le installazioni individuali.
Argomento principale: Installazione e amministrazione di SolidWorks


Inizio dell'installazione di SolidWorks

È possibile iniziare l'installazione di SolidWorks da un DVD sul computer locale, accedendo a una directory di installazione condivisa o scaricando i file da SolidWorks.

  • Per iniziare l'installazione di SolidWorks, adottare una delle seguenti metodologie:
    • per installare dal disco su un computer locale, inserire il disco appropriato nel drive apposito.
    • Per installare da una directory di download passare alla directory e fare doppio clic su setup.exe.
    • Per installare tramite download da SolidWorks:
      1. andare al sito Web di SolidWorks.
      2. Effettuare la connessione come utente del servizio di abbonamento, usando il proprio indirizzo di email e password o il proprio numero seriale SolidWorks.
      3. Sottolineato Self Service, fare clic su Download software e aggiornamenti.
      4. Sottolineato Download software, selezionare la versione di SolidWorks e il servizi pack per il download.
Argomento principale: Installazione e amministrazione di SolidWorks


Installazioni individuali

  • Installazione su singoli computer
    È possibile installare SolidWorks su un solo computer con vari metodi.
  • Amministrazione delle installazioni individuali
    Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.


Installazione su singoli computer

È possibile installare SolidWorks su un solo computer con vari metodi.

La Gestione installazioni di SolidWorks esegue l'installazione, adattandola ai prodotti acquistati. Prima di iniziare l'installazione:

  • preparare il proprio numero seriale SolidWorks.
  • Verificare che la connessione Internet sia operativa.
La Gestione installazioni di SolidWorks richiede la presenza di vari componenti Microsoft, compresi Microsoft Windows Installer, Office Web Components, Microsoft Visual Studio Tools for Applications e .NET Framework. Se non sono installate tutte le versioni corrette dei componenti Windows richiesti, la Gestione installazioni di SolidWorks li installa automaticamente prima di procedere all'installazione dei prodotti SolidWorks.
Metodo d'installazione Sintesi della procedura
Uso dei supporti di installazione di SolidWorks Inserire il DVD appropriato nell'unità del computer.
I supporti di installazione di SolidWorks sono composti di DVD distinti per le installazioni su Windows 32 bit e 64 bit.
Uso di una directory di download su un server Nella directory di download, fare doppio clic su setup.exe.
Tale directory deve essere accessibile dal computer sul quale si installano i prodotti SolidWorks e deve contenere tutti i file di installazione di SolidWorks prima di avviare la procedura. La Gestione installazioni di SolidWorks riesce anche a individuare i file mancanti se il computer ha accesso Internet e diritti di scrittura sulla directory di download.
Questa è non un'immagine amministrativa. Il solo modo per installare un computer client da un'immagine amministrativa è facendo clic sul link nella pagina HTML distribuita dall'amministratore SolidWorks.
Aggiornamento di un'installazione SolidWorks esistente mediante Verifica aggiornamenti Procedere in uno dei modi seguenti:
  • In SolidWorks, fare clic su ? > Verifica aggiornamenti.
  • In Windows, fare clic su Start > Tutti i programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti.
È necessaria una connessione ad Internet.

I client Workgroup PDM rilevano automaticamente gli aggiornamenti del vault. Non è necessario effettuare il download di un service pack per aggiornare i client. Per i dettagli, vedere Aggiornamento client nella Guida in linea di Workgroup PDM.

Scaricando dal sito per clienti di SolidWorks.
  1. andare al sito Web di SolidWorks.
  2. Effettuare la connessione come utente del servizio di abbonamento, usando il proprio indirizzo di email e password o il proprio numero seriale SolidWorks.
  3. Per Self Service, fare clic su Download software e aggiornamenti.
  4. In Download software, fare clic su una versione SolidWorks che si desidera installare.
È necessaria una connessione ad Internet.

È necessario disporre di un abbonamento valido per l'accesso al Portale clienti.

Al completamento dell'installazione, avviare l'applicazione SolidWorks e attivare la licenza.

Argomento principale: Installazioni individuali


Amministrazione delle installazioni individuali

Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.

  • Modifica di un'installazione
    Un'installazione può essere modificata per installare i prodotti che non sono stati installati o per rimuovere i prodotti.
  • Riparazione di un'installazione
    Nel caso di problemi con un Prodotto SolidWorks installato, usare la Gestione installazioni di SolidWorks per riparare l'installazione.
  • Ripristino di un'installazione individuale ad un Service Pack precedente
    Per ripristinare una singola installazione a un Service Pack precedente all'interno della release principale corrente, disinstallare il Service Pack attualmente installato sul computer e reinstallarne la versione precedente.
  • Rimozione di un'installazione
    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.
  • Aggiornamento a una nuova release
    Vi sono vari modi per aggiornare un'installazione individuale a una nuova release di SolidWorks.
  • Regole di coesistenza del prodotto
    Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.
Argomento principale: Installazioni individuali


Modifica di un'installazione

Un'installazione può essere modificata per installare i prodotti che non sono stati installati o per rimuovere i prodotti.

Se si installa SolidWorks e si acquista un'aggiunta in un secondo tempo, si potrà modificare l'installazione per includere la nuova aggiunta. Sarà necessario installare l'aggiunta su ogni singolo computer.

Workgroup PDM non viene installato se si modifica il proprio pacchetto originale SolidWorks per includere SolidWorks Professional o SolidWorks Premium.
  1. assicurarsi che non ci siano sessioni attive SolidWorks.
  2. in Windows Vista o versione successiva, fare clic su Start > Pannello di controllo > Programmi e Funzioni.

    Per le versioni precedenti a Windows, fare clic su Start > Pannello di controllo > Installazione applicazioni.

  3. Selezionare l'installazione di SolidWorks da modificare e fare clic su Cambia.
  4. Nella schermata Benvenuti nella Gestione installazioni di SolidWorks, fare clic su Modificare l'installazione individuale (su questo computer).
  5. Nella schermata Numero seriale, verificare che siano indicati i numeri di seriali appropriati.
  6. Nella schermata Selezione del prodotto, selezionare i prodotti da installare o rimuovere.

    Quando si modifica un'installazione:

    • Nessun prodotto viene installato o rimosso di default, anche Se si specifica un nuovo numero seriale. Cambiare l'azione dell'installazione di ogni prodotto o componente.
    • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione di installazione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
    • È possibile fare clic sulla casella di controllo accanto al componente del prodotto per modificare l'azione di installazione di tale componente. (Ad esempio, se si installano o rimuovono i componenti, la selezione della casella di controllo indica che il componente è da installare o da rimuovere, la deselezione indica invece che tale componente non deve essere installato o rimosso.)
    • Quando si cambia una selezione di prodotto dalle specifiche iniziali, accanto a tale componente in elenco si visualizza un asterisco (*).
    • Se un componente contiene sottocomponenti opzionali, l'icona + appare accanto a tale componente. Per visualizzare i sottocomponenti disponibili, fare clic sull'icona + di fianco.
    • Quando un componente è stato espanso per visualizzarne i sottocomponenti, l'icona - appare accanto a tale componente. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona - di fianco.

  7. Nella schermata Sintesi, fare clic su Modifica ora.
  8. Nella schermata Installazione è stata completata, fare clic su Fine.
Argomento principale: Amministrazione delle installazioni individuali


Riparazione di un'installazione

Nel caso di problemi con un Prodotto SolidWorks installato, usare la Gestione installazioni di SolidWorks per riparare l'installazione.

Un'installazione individuale può essere riparata. Non è possibile riparare un'immagine amministrativa; disinstallare e quindi installare nuovamente l'immagine amministrativa.
  1. In Windows Vista o versione successiva, fare clic su Start > Pannello di controllo > Programmi > Programmi e funzionalità.

    Per le versioni precedenti a Windows, fare clic su Start > Pannello di controllo > Installazione applicazioni.

  2. Selezionare la versione di SolidWorks da riparare e fare clic su Cambia.
  3. Nella schermata Benvenuti alla Gestione installazioni SolidWorks, fare clic su Ripara l'installazione individuale (su questo computer)..
  4. In Prodotti da riparare selezionare il prodotto desiderato.
  5. Deselezionare il resto dei prodotti.
  6. Fare clic su Ripara.
Argomento principale: Amministrazione delle installazioni individuali
Argomento principale: Errori di installazione / Installazione annullata


Ripristino di un'installazione individuale ad un Service Pack precedente

Per ripristinare una singola installazione a un Service Pack precedente all'interno della release principale corrente, disinstallare il Service Pack attualmente installato sul computer e reinstallarne la versione precedente.

Argomento principale: Amministrazione delle installazioni individuali


Rimozione di un'installazione

Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

  1. assicurarsi che non ci siano sessioni attive SolidWorks.
  2. Se si intende trasferire la licenza SolidWorks su un altro computer, trasferirla prima di rimuovere l'installazione SolidWorks su questo computer.

    Per informazioni sul trasferimento di licenze SolidWorks, vedere Trasferimento di una licenza.

  3. In Windows Vista o versione successiva, fare clic su Start > Pannello di controllo > Programmi > Programmi e funzionalità.

    Per le versioni precedenti a Windows, fare clic su Start > Pannello di controllo > Installazione applicazioni.

  4. Selezionare il componente del prodotto da rimuovere.

    In alcuni casi, potrebbero essere disponibili più componenti Service Pack di SolidWorks per una stesa versione di release maggiore. Per rimuovere una release maggiore di SolidWorks, rimuovere tutti gli elementi dei service pack per quella release maggiore.

  5. Nello schermo Disinstallare:
    1. selezionare i prodotti da rimuovere. Di default, sono selezionati tutti i componenti di prodotto.
    2. Deselezionare i prodotti che non devono essere rimossi.
    3. Scegliere se effettuare una disinstallazione personalizzata o completa. Di default, la Gestione installazioni SolidWorks effettua una disinstallazione standard e rimuove i File e cartelle del programma.

      1. Fare clic su Cambia in Opzioni avanzate.

        Apparirà lo schermo Opzioni avanzate e l'opzione File e cartelle del programma sarà selezionata

      2. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
      3. Fare clic su Torna alla Sintesi.
      4. Nello schermo Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le voci.

    4. Fare clic su Rimuovi elementi.
Argomento principale: Amministrazione delle installazioni individuali


Aggiornamento a una nuova release

Vi sono vari modi per aggiornare un'installazione individuale a una nuova release di SolidWorks.

Si può aggiornare ad una nuova release:
  • Mediante la ricezione di nuovi supporti di installazione
  • Alla notifica della disponibilità di aggiornamenti all'avvio di SolidWorks
  • Controllando manualmente la disponibilità di aggiornamenti
  • Avviando una nuova istanza della Gestione installazioni di SolidWorks

Quando si installa una nuova release maggiore, è possibile aggiornare una release maggiore già installata oppure installare parallelamente la nuova release. Se si installa una release Service Pack da una release precedente installata, tale release viene aggiornata automaticamente.

  • Verifica manuale degli aggiornamenti
    È possibile verificare se esistono aggiornamenti di una release SolidWorks già installata mediante uno di questi metodi.
  • Aggiornamento di client Workgroup PDM
    I client Workgroup PDM rilevano quando il vault è stato aggiornato. Non è necessario effettuare il download di un service pack per aggiornare i client.
  • Accorgimenti per l'aggiornamento
    I prodotti che possono avere installazioni multiple con versioni diverse non supportano sempre gli aggiornamenti maggiori, o la capacità di aggiornare tra le versioni maggiori in una sola operazione.
Argomento principale: Amministrazione delle installazioni individuali


Verifica manuale degli aggiornamenti

È possibile verificare se esistono aggiornamenti di una release SolidWorks già installata mediante uno di questi metodi.

  • In SolidWorks, fare clic su ? > Verifica aggiornamenti.
  • In Microsoft Windows, selezionare Start > Tutti i programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti.
Argomento principale: Aggiornamento a una nuova release


Aggiornamento di client Workgroup PDM

I client Workgroup PDM rilevano quando il vault è stato aggiornato. Non è necessario effettuare il download di un service pack per aggiornare i client.

Per le istruzioni, vedere Aggiornamento client nella Guida in linea di Workgroup PDM.

Argomento principale: Aggiornamento a una nuova release
Argomento principale: Amministrazione di Workgroup PDM VaultAdmin


Accorgimenti per l'aggiornamento

I prodotti che possono avere installazioni multiple con versioni diverse non supportano sempre gli aggiornamenti maggiori, o la capacità di aggiornare tra le versioni maggiori in una sola operazione.

In questo caso, la Gestione installazioni di SolidWorks simula l'aggiornamento installando prima la versione nuova, quindi rimuovendo quella precedente. Al momento, il prodotto principale SolidWorks supporta gli aggiornamenti maggiori, al contrario degli altri prodotti.

Le conseguenze di questa modalità sono:
  • Durante l'aggiornamento del prodotto principale SolidWorks tra versioni maggiori:
    • le ubicazioni esistenti installate non cambiano.
    • L'aggiornamento può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.
  • Quando gli altri prodotti vengono aggiornati tra le versioni maggiori:
    • ogni prodotto viene prima installato come prodotto nuovo in un punto nuovo, quindi l'installazione originale sarà rimossa.
    • Una volta iniziato, l'aggiornamento non può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.
Argomento principale: Aggiornamento a una nuova release


Regole di coesistenza del prodotto

Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.

Regola | Esempi
Sono ammesse versioni multiple di release maggiore di un prodotto principale SolidWorks, a prescindere dai Service Pack o dalla release maggiore (eccetto i tre prodotti sotto menzionati). SolidWorks 2010 SP3.0 e SolidWorks 2011 SP0.0 possono coesistere sullo stesso computer.

Tuttavia, se SolidWorks 2011 SP0.0 è installato su un computer sul quale si installa SolidWorks 2011 SP1.0, la Gestione installazioni sostituirà la versione SP0.0 con la nuova SP1.0.

SolidWorks 2011 SP0.0 e 2011 SP1.0 non coesisteranno sullo stesso computer.

Solo una versione dei seguenti prodotti è consentita sul computer:
  • Server di Workgroup PDM
  • SolidNetWork License Manager
 Se SolidWorks 2011 SP0.0 è installato, Workgroup PDM Server viene aggiornato a 2011 SP0.0, anche se una release precedente di SolidWorks rimane sul computer.
Solo una versione di un prodotto compreso potrà essere installata per qualsiasi versione maggiore. | Se SolidWorks 2011 SP0.0 viene aggiornato a 2011 SP1.0, SolidWorks Explorer 2011 SP0.0 sarà automaticamente aggiornato a 2011 SP1.0. Tuttavia, SolidWorks Explorer 2010 SP4.0 può esistere sul computer.
Argomento principale: Amministrazione delle installazioni individuali


Installazioni multiple

  • Distribuzione su più client
    Il prodotto SolidWorks può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.
  • Uso di immagini amministrative
    Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SolidWorks da un'unica posizione di rete.
  • Distribuzione dalla riga di comando
    È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).
  • Amministrazione delle installazioni multiple
    Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.


Distribuzione su più client

Il prodotto SolidWorks può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.

Segue la procedura per la distribuzione su più client:
  1. Creare un'immagine amministrativa.
    • Creazione di un'immagine amministrativa dalla Gestione installazioni di SolidWorks
    • Creazione dell'immagine amministrativa dalla riga di comando
  2. Distribuire l'immagine amministrativa ai client.
    • Distribuzione di un'immagine amministrativa ai client via email
    • Installazione da un'immagine amministrativa mediante la riga di comando
  3. Implementare le licenze.
    • Amministrazione di licenze individuali
    • Amministrazione delle licenze mediante SolidNetWork License Manager
Argomento principale: Installazioni multiple


Uso di immagini amministrative

Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SolidWorks da un'unica posizione di rete.

L'immagine amministrativa potrà essere installata da qualsiasi computer in rete, compreso il computer client.
  • L'immagine amministrativa deve essere in una cartella condivisa.
  • Se si includono tutti i prodotti, i requisiti di spazio disco dell'immagine amministrativa potrà essere 7GB o maggiore.
  • Se il nome di condivisione viene aggiornato con l'aggiornamento dell'immagine amministrativa, il client aggiornerà automaticamente all'avvio successivo dell'applicazione. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.
  • I client devono avere privilegi amministrativi sui loro computer, a meno che per l'installazione client non sia specificata l'opzione Esegui l'installazione come altro utente.
    Questa opzione non è supportata in Windows Vista o versioni successive.

Una volta creata un'immagine amministrativa, l'Editor opzioni può gestire le impostazioni di installazione per gli utenti e i gruppi che installano utilizzando tale immagine. Per i dettagli, vedere Editor opzioni immagine amministrativa.

  • Creazione di un'immagine amministrativa dalla Gestione installazioni di SolidWorks
    Se si installa SolidWorks su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.
  • Editor opzioni immagine amministrativa
    L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.
  • Distribuzione di un'immagine amministrativa ai client via email
    Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.
  • Segnalazione dell'immagine amministrativa ai client
    È possibile eseguire un comando che segnali la disponibilità di una nuova installazione dell'immagine amministrativa ai client.
Argomento principale: Installazioni multiple


Creazione di un'immagine amministrativa dalla Gestione installazioni di SolidWorks

Se si installa SolidWorks su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

  1. Avviare la Gestione installazioni di SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
  2. Nella schermata Benvenuto, fare clic su Immagine amministrativa.

    Si visualizzano le opzioni per la creazione di un'immagine amministrativa:

    Creare una nuova immagine utilizzando le impostazioni di default.
    Creare l'immagine utilizzando le impostazioni di configurazione di default (ossia, non quelle stabilite dalla propria azienda per le immagini amministrative esistenti).
    Creare una nuova immagine utilizzando le impostazioni e i file da un'immagine esistente.
    Creare l'immagine utilizzando le impostazioni di configurazione specificate per un'immagine amministrativa esistente presso la propria azienda. Fare clic Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
    Creare immagini amministrative a 32 bit e 64 bit.
    È possibile creare immagini amministrative a 32 bit e 64 bit su un solo computer oppure creare solo l'immagine corrispondente all'architettura del sistema. La creazione di entrambe le immagini non richiede l'accesso ai supporti di installazione per Il 32 bit e 64 bit.

  3. Seguire le istruzioni su schermo.
Argomento principale: Uso di immagini amministrative


Editor opzioni immagine amministrativa

L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.

Dopo avere creato un'immagine amministrativa, la Gestione installazioni di SolidWorks chiederà di avviare l'Editor opzioni. È anche possibile avviare l'Editor opzioni facendo doppio clic su sldAdmintOptionEditor.exe nella cartella dell'immagine amministrativa.

Per specificare diverse configurazioni d'installazione per gruppi di sistemi o sistemi individuali, aggiungere gruppi e sistemi nell'Editor opzioni e quindi specificare le opzioni di installazione per quei gruppi e sistemi.

  • Aggiunta ed eliminazione di gruppi e macchine
    L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.
  • Visualizzazione e modifica delle impostazioni
    L'Editor opzioni immagine amministrativa di SolidWorks consente di visualizzare e modificare le impostazioni di gruppi e sistemi specificati per l'immagine.
  • Passaggio tra immagini a 32 bit e 64 bit
    Se si sono create le versioni a 32 bit e 64 bit nella directory di installazione dell'immagine amministrativa, l'Editor opzioni può gestirle entrambe.
  • Distribuzione delle installazioni dall'Editor opzioni
    È possibile distribuire le installazioni direttamente dall'Editor opzioni utilizzando le istruzioni ricevute per e-mail per avviare l'installazione.
  • Uscita dall'Editor opzioni
    È possibile fare clic su OK o su Chiudi per uscire dall'Editor opzioni.
  • Creazione di un collegamento sul desktop per l'Editor opzioni
    È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.
Argomento principale: Uso di immagini amministrative


Aggiunta ed eliminazione di gruppi e macchine

L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.

Ad esempio, si può decidere di configurare diversi sistemi per l'uso di un sottoinsieme particolare dei componenti di prodotto disponibili nell'immagine mentre un altro gruppo di sistema potrebbe utilizzare un sottoinsieme diverso dei componenti. Anche utilizzando la stessa immagine amministrativa, le impostazioni del gruppo Editor opzioni consentono di installare diversi sottoinsiemi di prodotto su diversi gruppi di computer.

Per aggiungere un gruppo:
  1. Fare clic con il pulsante destro del mouse su Impostazioni globali e selezionare Aggiungi gruppo.
  2. Immettere il nome del gruppo.
Per aggiungere i sistemi:
  1. Fare clic con il pulsante destro del mouse su un gruppo esistente o su Impostazioni globali e selezionare Aggiungi macchina.
    Facendo clic con il pulsante destro del mouse su un gruppo esistente, i computer verranno aggiunti al gruppo. Altrimenti, saranno aggiunte al primo livello.
  2. Procedere in uno dei modi seguenti:
    • Immettere i nomi di una o più macchine in Nome macchina.

      Macchine multiple possono essere separate da un'interruzione di riga, spazio, tab, virgola, punto, due punti o punto e virgola. Un elenco di nomi di macchine può essere copiato ed incollato da un file esterno.

      I nomi della macchina non possono includere qualificatori di dominio. Per esempio, pluto.solidworks.com non è valido.

    • Fare clic su Aggiungi macchine multiple per selezionare le macchine dalla rete.
Per spostare un computer esistente ad un gruppo: trascinare la macchina in un gruppo.
Per spostare un computer da un gruppo: trascinare la macchina su Impostazioni globali o su un gruppo diverso.
Per eliminare un gruppo o computer: Fare clic con il pulsante destro del mouse sul gruppo o sistema e selezionare Elimina gruppo o Elimina macchina.
Eliminando un gruppo, tutte le macchine all'interno di quel gruppo saranno eliminate.
Per eliminare tutti i gruppi e computer: Fare clic con il pulsante destro del mouse su Impostazioni globali e selezionare Elimina tutto.
Argomento principale: Editor opzioni immagine amministrativa


Visualizzazione e modifica delle impostazioni

L'Editor opzioni immagine amministrativa di SolidWorks consente di visualizzare e modificare le impostazioni di gruppi e sistemi specificati per l'immagine.

  • Quando si apre l'editor per la prima volta, le impostazioni che appaiono sono di sola lettura. L'icona Modifica non è ombreggiata: .
    Fare clic su Impostazioni globali, su un gruppo o un sistema per visualizzare il riepilogo delle impostazioni di tale elemento:
    Ambito | Impostazioni visualizzate
    Impostazioni globali | Tutte le impostazioni specificate per l'immagine amministrativa
    Gruppo | Le modifiche alle impostazioni di gruppo relativamente alle Impostazioni globali
    Sistema | Le modifiche alle impostazioni di sistema relativamente al gruppo
  • Per modificare le impostazioni, fare clic sull'icona Modifica. L'icona diventa ombreggiata ( [image]) e compare un elenco di impostazioni dettagliato.

    Fare clic su Impostazioni globali, su un gruppo o un sistema per modificare le impostazioni di tale elemento. Quando si modifica un'impostazione che differisce dalle impostazioni globali ereditate o dalle impostazioni di gruppo, questa si evidenzia.

    Se si fa clic nuovamente sull'icona Modifica, la visualizzazione torna alla modalità di sola lettura.

    Se si apportano modifiche, l'Editor opzioni invita a salvarle o annullarle prima di uscire.

  • Specificazione delle impostazioni per gruppi e sistemi
    Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.
  • Eredità di impostazioni globali e di gruppo
    Gli elementi dipendenti da altri ereditano le Impostazioni globali o di gruppo dei loro padri.
Argomento principale: Editor opzioni immagine amministrativa


Specificazione delle impostazioni per gruppi e sistemi

Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.

  1. Nell'Editor opzioni, fare clic sull'oggetto da modificare (Impostazioni globali, un gruppo o un sistema).
  2. A destra, fare clic sull'icona Modifica [image].

    L'icona Modifica appare ombreggiata ( [image]) e si visualizza un elenco più dettagliato di impostazioni.

  3. Per apportare le modifiche, fare clic sulle impostazioni a destra corrispondenti all'elemento selezionato a sinistra.

    Le modifiche alle impostazioni che prevalgono sulle Impostazioni globali o sulle impostazioni di gruppo appaiono evidenziate.

  4. Fare clic su OK o su Chiudi per salvare le modifiche.

    OK
    L'Editor opzioni salva le modifiche e si chiude.
    Chiudere
    L'Editor opzioni invita a salvare le modifiche e alla fine si chiude.

  • Impostazioni opzione immagine amministrativa
    L'Editor delle opzioni permette di specificare le impostazioni di opzione per i client individuali o gruppi, compresi i numeri seriali, le opzioni di installazione client, quali componenti software installare e l'ubicazione toolbox.
Argomento principale: Visualizzazione e modifica delle impostazioni


Impostazioni opzione immagine amministrativa

L'Editor delle opzioni permette di specificare le impostazioni di opzione per i client individuali o gruppi, compresi i numeri seriali, le opzioni di installazione client, quali componenti software installare e l'ubicazione toolbox.

Numeri di serie

Digitare i numeri seriali per i prodotti da installare sulle macchine client.
Visto che esistono diverse modalità per l'acquisto dei prodotti SolidWorks, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SolidWorks può permettere di installare SolidWorks Simulation senza immettere un numero seriale separato per SolidWorks Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio VAR.
Se si gestiscono le licenze usando le licenze SolidNetWork:
  • nel primo campo del numero seriale, immettere il numero di serie SolidNetWork.
  • Nel campo SNL Server port@server, immettere il nome e porta del SolidNetWork License Manager nel formato nnnnn@servername. Separare voci multiple usando i punti e virgole.

Per i dettagli sulle licenze SolidNetWork, vedere Installazione e configurazione delle licenze SolidNetWork.

Opzioni di installazione client

Come effettuare le installazioni client delle versioni maggiori?
Specificare il modo in cui le installazioni client gestiranno un'installazione di versione maggiore già esistente:
  • Aggiornare la versione maggiore esistente (se esistente).

    Specificare questa opzione per sostituire l'installazione di versione maggiore precedente con l'installazione della nuova versione

  • Creare una nuova versione maggiore.

    Specificare questa opzione per mantenere la versione maggiore precedente e creare una nuova installazione per la nuova versione maggiore.

    Per specificare un'ubicazione per l'installazione della versione nuova, fare clic su Sfoglia.

Disinstallare la versione precedente più recente prima di installare una versione nuova?
Specificare se disinstallare l'installazione della versione maggiore esistente:
  • No, non effettuare la disinstallazione.

    Specificare questa opzione per mantenere l'installazione di versione maggiore precedente.

  • Sì, effettuare una disinstallazione personalizzata.
    Selezionare questa opzione per rimuovere questi elementi:
    • File e cartelle di programma
    • Voci di registro
    • File e cartelle dati
Come applicare le Impostazioni di SolidWorks?
L'utente può specificare che le installazioni client configurino le impostazioni SolidWorks in base alle impostazioni SolidWorks configurate sulla macchina client o che le impostazioni SolidWorks siano esportate dall'Impostazione guidata di copiatura.
  • Usare le impostazioni correnti (se esistenti) o usare le impostazioni di default di SolidWorks

    Se la macchina client ha definito le impostazioni SolidWorks, mantenere tali impostazioni. (Per qualsiasi impostazione non specificativamente definita sul client, l'installazione client utilizza le impostazioni di default di SolidWorks).

  • Usare un file di impostazione esportato dalle Impostazioni guidate per la copiatura.
    Selezionando l'impostazione di questa opzione permette di scegliere le impostazioni di opzione da un file di esportazione con Impostazione guidata di copiatura. (Di solito, questo file è denominato solidworkssettings.sldreg).
    • Fare clic su Sfoglia per trovare un file di impostazione esistente.
    • Fare clic su Nuovo per avviare l'Impostazione guidata di copiatura per creare un nuovo file di impostazione.
Come attivare le installazioni client?
L'utente può specificare se completare automaticamente l'attivazione del prodotto dopo l'esecuzione dell'installazione o richiedere che l'utente effettui l'attivazione del prodotto manualmente dopo l'installazione.
  • Attivare automaticamente al completamento di ogni installazione client.
    Selezionando l'impostazione di questa opzione si specifica che l'attivazione del prodotto viene eseguita automaticamente usando un file di Attivazione del prodotto SolidWorks. (Tipicamente, questo file è denominato AutoActivation.xml).
    • Fare clic su Sfoglia per trovare un file di attivazione esistente.
    • Fare clic su Nuovo per avviare l'Attivazione del prodotto SolidWorks per creare il file di una nuova attivazione.
  • Non attivare automaticamente.

    Selezionare l'impostazione di questa opzione specifica che non ci sarà nessuna attivazione automatizzata del prodotto. L'utente client effettua l'attivazione del prodotto dopo l'installazione.

Se si specifica l'attivazione del prodotto automatica, l'immagine amministrativa dovrà essere disponibile via il punto di rete condiviso alla prima esecuzione di SolidWorks da parte dei client dopo l'installazione. Se l'immagine amministrativa non è disponibile ai client che installano da quella immagine, questi client non potranno completare l'attivazione automatica del prodotto. Non potranno eseguire SolidWorks a meno che non venga eseguita manualmente l'Attivazione del prodotto SolidWorks.

Opzioni amministrative

Creare un log diagnostico durante ogni installazione.
L'installazione di un client può creare un log diagnostico che può essere usato per diagnosticare i problemi di installazione. Generando questo log l'esecuzione dell'installazione client rallenterà.
Eseguire l'installazione come altro utente.
L'installazione client potrà essere eseguita come utente diverso. Questa opzione può essere utile quando gli utenti individuali non hanno permessi amministrativi locali sulle lore macchine (necessari per installare i prodotti SolidWorks).
Questa funzione non è supportata in Windows Vista, Windows 7 o versioni successive.
Eseguire un programma prima o dopo l'installazione
Si può specificare che un programma personalizzato viene eseguito prima o dopo l'installazione client.
Specificare se il client deve partecipare al Programma SolidWorks Customer Experience.
Si può specificare che le macchine client partecipano nel programma SolidWorks Customer Experience. Le informazioni di prestazione vengono inviate alla SolidWorks Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Per i dettagli, vedere Sito web del Customer Experience Improvement Program.

Software da installare

Si potrà specificare quali componenti di prodotto SolidWorks installare.
  • Selezionare la casella accanto al componente del prodotto specificherà che il componente viene installato durante l'installazione client.
  • Deselezionare la casella specificherà che il componente non è installato.
  • Se un componente contiene sottocomponenti opzionali, l'icona + appare accanto a tale componente. Per visualizzare i sottocomponenti disponibili, fare clic sull'icona + di fianco.
  • Quando un componente è stato espanso per visualizzarne i sottocomponenti, l'icona - appare accanto a tale componente. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona - di fianco.
La specificazione Lingue limita le lingue installate per il solo prodotto SolidWorks. Altre installazioni del prodotto non saranno condizionate da questa specificazione. Per esempio, SolidWorks eDrawings®, SolidWorks Workgroup PDM e SolidWorks Explorer installeranno tutte le lingue.

Opzioni Toolbox

Specificare quali standard supportare e l'ubicazione di default di Toolbox per le installazioni client.

E' frequente avere utenti multipli che accedono ad un Toolbox condiviso, tipicamente attraverso un punto in rete (per esempio, un percorso UNC, una cartella condivisa o una specificazione di unità in rete comune).

Se l'ubicazione contiene una versione maggiore precedente di Toolbox, l'installazione client aggiornerà quella versione di Toolbox alla nuova versione maggiore. I file non saranno più compatibili con le versioni maggiori precedenti di SolidWorks.
Per mantenere Toolbox per la versione passata di SolidWorks (per esempio, se alcuni client vogliono continuare ad usare la versione precedente), specificare un'ubicazione in rete diversa di Toolbox per i client in via di aggiornamento alla versione più recente.

Per i dettagli relativi all'amministrazione di Toolbox, vedere le informazioni su Toolbox nella Guida in linea di SolidWorks.

Argomento principale: Specificazione delle impostazioni per gruppi e sistemi


Eredità di impostazioni globali e di gruppo

Gli elementi dipendenti da altri ereditano le Impostazioni globali o di gruppo dei loro padri.

Ad esempio:
  • Le impostazioni definite per Impostazioni globali derivano da tutti i gruppi e sistemi.
  • Le impostazioni definite per un gruppo derivano da tutti computer all'interno di quel gruppo.

Le impostazioni possono cambiare per un sistema o gruppo per sovrascrivere le impostazioni di default o quelle derivate. Quando si cambiano le impostazioni di default o il loro valore derivato, tale opzione viene evidenziata.

Per ripristinare le impostazioni ai valori originali, fare clic con il pulsante destro del mouse sul gruppo o sul sistema quindi fare clic su Inverti alle impostazioni globali (per un gruppo o sistema non membro del gruppo) o Inverti alle impostazioni di gruppo (per un sistema membro di gruppo).
Argomento principale: Visualizzazione e modifica delle impostazioni


Passaggio tra immagini a 32 bit e 64 bit

Se si sono create le versioni a 32 bit e 64 bit nella directory di installazione dell'immagine amministrativa, l'Editor opzioni può gestirle entrambe.

  • Nell'Editor opzioni, fare clic su 32 o 64 per attivare l'immagine corrispondente.

    Fare clic su Impostazione o Implementa per visualizzare e modificare le impostazioni o distribuire le installazioni di tale immagine.

Se si hanno entrambe le immagini a 32 bit e 64 bit, è necessario specificare le Impostazioni globali, di gruppo e individuali di sistema separatamente per ciascuna immagine.
Argomento principale: Editor opzioni immagine amministrativa


Distribuzione delle installazioni dall'Editor opzioni

È possibile distribuire le installazioni direttamente dall'Editor opzioni utilizzando le istruzioni ricevute per e-mail per avviare l'installazione.

È necessario cambiare la directory di installazione dell'immagine amministrativa a una directory condivisa Windows in modo che sia disponibile come posizione di rete (ad esempio, \\sistema\directory_condivisa).

  1. Nell'Editor opzioni, fare clic su Implementa.
  2. Se si sono configurate le immagini a 32 bit e 64 bit per questa directory di installazione dell'immagine amministrativa, fare clic su 32 o 64 per visualizzare i sistemi adatti a una o l'altra immagine.

    Si visualizza lo stato e la disponibilità di installazione di ogni sistema.

  3. Fare clic su Invia e-mail.
  4. Specificare il percorso di rete della directory di installazione dell'immagine amministrativa.

    Solitamente, questo percorso appare all'inizio come percorso Windows (ad esempio, C:\SolidWorks Admin\SolidWorks 2011 SP0). La finestra di dialogo indica che Questo percorso non è un percorso di rete.

    1. Fare clic su Sfoglia per specificare la posizione di rete per la directory di installazione dell'immagine amministrativa.
    2. Navigare al computer con l'immagine amministrativa installata e selezionare la directory condivisa Windows specificata come directory di installazione dell'immagine amministrativa.

      Non entrare nella directory condivisa dell'immagine amministrativa (ad esempio, nelle sottodirectory 32bit o 64bit).

    3. Fare clic su OK.

      La finestra di dialogo indica che Questo percorso è un percorso di rete.

    Viene creata automaticamente un'e-mail che spiega all'utente del sistema come eseguire l'installazione dall'immagine amministrativa utilizzando la posizione di rete del file StartSWInstall.hta.

  5. Inviare l'e-mail agli utenti responsabili dell'installazione di SolidWorks.

Gli utenti possono fare doppio clic sulla posizione di rete del file StartSWInstall.hta nel messaggio per installare SolidWorks dall'immagine amministrativa.

Nell'Editor opzioni, lo Stato dell'installazione indica:
In attesa
L'utente non ha ancora eseguito l'installazione su questo sistema.
Riuscito
L'utente ha completato l'installazione su questo sistema.
Non riuscito
L'utente ha eseguito l'installazione su questo sistema, ma non è riuscita.
  • Utilizzo di un'unità associata per distribuire un'immagine amministrativa
    Un percorso UNC (\\nome_sistema\nome_condiviso) è il metodo consigliato per specificare una posizione di rete come directory di installazione di un'immagine amministrativa. Tuttavia, è possibile utilizzare un'unità associata come posizione per il file StartSWInstall.hta dell'immagine amministrativa (es. U:\StartSWInstall.hta), a patto che tutti gli utenti che eseguono l'installazione abbiano associato la stessa lettera di unità alla directory condivisa dell'immagine amministrativa.
Argomento principale: Editor opzioni immagine amministrativa


Utilizzo di un'unità associata per distribuire un'immagine amministrativa

Un percorso UNC (\\nome_sistema\nome_condiviso) è il metodo consigliato per specificare una posizione di rete come directory di installazione di un'immagine amministrativa. Tuttavia, è possibile utilizzare un'unità associata come posizione per il file StartSWInstall.hta dell'immagine amministrativa (es. U:\StartSWInstall.hta), a patto che tutti gli utenti che eseguono l'installazione abbiano associato la stessa lettera di unità alla directory condivisa dell'immagine amministrativa.

Ad esempio, se si è associata l'unità U: alla directory condivisa dell'immagine amministrativa, l'e-mail di notifica istruirà gli utenti a fare clic sul link file://U:\StartSWIOnstall.hta. I destinatari dell'e-mail possono eseguire l'installazione solo se hanno associato l'unità U: alla posizione UNC dell'immagine amministrativa (\\nome_sistema\nome_condiviso).

Argomento principale: Distribuzione delle installazioni dall'Editor opzioni


Uscita dall'Editor opzioni

È possibile fare clic su OK o su Chiudi per uscire dall'Editor opzioni.

  • Fare clic su OK, Chiudi o utilizzare il pulsante Chiudi delle applicazioni Windows per applicare le modifiche e chiudere l'Editor opzioni.
    • Fare clic su OK per applicare le modifiche alle impostazioni e chiudere l'Editor opzioni.
    • Fare clic su OK per uscire dall'Editor opzioni.

      Se vi sono modifiche non applicate, un messaggio invita a salvarle prima di uscire.

    • Fare clic sul pulsante Chiudi delle applicazioni Windows (X). Se vi sono modifiche non applicate, un messaggio invita a salvarle prima di uscire.
Argomento principale: Editor opzioni immagine amministrativa


Creazione di un collegamento sul desktop per l'Editor opzioni

È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.

  1. Avviare l'Editor opzioni.

    Ad esempio, in Esplora risorse, aprire la directory di installazione dell'immagine amministrativa e fare doppio clic su sldAdminOptionEditor.exe.

  2. Fare clic su Creare collegamento sul desktop per questo editor delle opzioni.

    Sul desktop di Windows appare un collegamento all'Editor opzioni dell'immagine amministrativa.

Argomento principale: Editor opzioni immagine amministrativa


Distribuzione di un'immagine amministrativa ai client via email

Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.

Configurare la directory dell'immagine amministrativa da condividere su una macchina accessibile agli altri computer (es. con un percorso UNC).

È possibile inviare una mail con il link al percorso_installazione_immagine_amministrativa\StartSWInstall.hta a tutti i client. I client potranno quindi selezionare questo link e fare clic su Installa ora i prodotti SolidWorks per avviare l'installazione dall'immagine amministrativa.

Se si aggiorna un'immagine amministrativa ad una nuova versione di SolidWorks, si potrà configurare la posizione dell'immagine amministrativa e condividere le proprietà in modo che i client installati precedentemente usando quella immagine si aggiorneranno automaticamente. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.
Argomento principale: Uso di immagini amministrative


Segnalazione dell'immagine amministrativa ai client

È possibile eseguire un comando che segnali la disponibilità di una nuova installazione dell'immagine amministrativa ai client.

Distribuzione per email è il metodo generalmente usato per notificare i client di un'installazione SolidWorks. Per i dettagli, vedere Distribuzione di un'immagine amministrativa ai client via email.

Tuttavia, come alternativa, è possibile eseguire un comando per segnalare una nuova installazione ai client. Per esempio, sarà possibile pubblicizzare ai dipendenti che non usano normalmente l'applicazione SolidWorks.

Generare il collegamento a SolidWorks vuol dire creare un collegamento all'applicazione SolidWorks nel menu Start sul computer dell'utente e generare un'associazione di file con l'immagine amministrativa sul server. Inizialmente, i file eseguibili non saranno installati. L'installazione avviene solo quando l'utente necessita per primo dell'applicazione.

Quando l'utente farà clic su questo collegamento o doppio clic su un documento SolidWorks, avverrà l'installazione e SolidWorks verrà lanciato.

Per sollecitare da un'immagine amministrativa:

  1. Creare e configurare l'immagine amministrativa.
  2. Creare il collegamento al prodotto su ogni computer in cui SolidWorks è stato installato.

    Ad esempio:

    msiexec /jm percorso_file_msi_immagine_amministrativa

    dove percorso_file_msi_immagine_amministrativa è un percorso UNC alla directory dell'immagine amministrativa.

Argomento principale: Uso di immagini amministrative


Distribuzione dalla riga di comando

È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).

  • Creazione dell'immagine amministrativa dalla riga di comando
    È possibile creare un'immagine amministrativa usando la Gestione installazioni di SolidWorks o la riga di comando MS-DOS.
  • Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
    Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.
  • Installazione da un'immagine amministrativa mediante la riga di comando
    È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.
  • Proprietà della riga di comando
    Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.
  • Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory
    La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SolidWorks ai client.
Argomento principale: Installazioni multiple


Creazione dell'immagine amministrativa dalla riga di comando

È possibile creare un'immagine amministrativa usando la Gestione installazioni di SolidWorks o la riga di comando MS-DOS.

Quando si creano immagini amministrative dalla riga di comando, si deve creare e distribuire un'immagine distinta per ogni componente di prodotto SolidWorks, eseguendo il file .msi di tale componente. Se si installa una lingua diversa dall'inglese, è necessario creare e distribuire un'immagine distinta per ciascuna eseguendo il file .msi di tale lingua. Per informazioni sulle posizioni dei file .msi, vedere Posizioni dei file MSI per immagini amministrative.
  1. Aprire una finestra Prompt dei comandi .
    1. In Windows, fare clic su Start > Esegui.
    2. Immettere cmd e fare clic su OK.
  2. Immettere questo comando:

    msiexec /a percorso_msi

    dove percorso_msi è la posizione del file .msi per il proprio sistema operativo. SolidWorks.msi si trova nella sottodirectory swwi\data della directory di installazione.

    Ad esempio:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. Nell'Impostazione guidata di SolidWorks, seguire le istruzioni su schermo.
  4. Se si installano prodotti SolidWorks per lingue diverse dall'inglese, creare un'immagine amministrativa distinta per tale lingua con il comando:

    msiexec /a percorso_msi_lingua

    dove percorso_msi_lingua è la posizione del file .msi della lingua desiderata. Ad esempio, italian.msi si trova nella sottodirectory swwi\lang\italian della directory di installazione.

    Ad esempio:

    msiexec /a F:\swwi\lang\italian\italian.msi

Argomento principale: Distribuzione dalla riga di comando


Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa

Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.

L'installazione manuale di questi componenti Windows è necessaria solo se si installa da un'immagine amministrativa creata manualmente mediante la riga di comando o con Microsoft Active Directory. Se si usa la Gestione installazioni di SolidWorks per creare ed installare un'immagine amministrativa, questi componenti Windows saranno installati automaticamente.
Di seguito è fornito il riepilogo dei file necessari a SolidWorks nei componenti Windows:
Windows Installer
Contiene i file necessari per eseguire l'installazione di SolidWorks Simulation Premium.
Componenti Web Office
Contiene i controlli COM necessari per DriveWorks.
Visual C++ 2005 e 2008 Redistributable Package
Contiene i componenti runtime per Microsoft Visual C++.
Devono essere installate entrambe le versioni 2005 e 2008.
Strumenti Visual Studio per applicazioni
Contiene un gruppo di strumenti che supportano le applicazioni Visual Studio.
Visual Studio Remote Debugger
Fornisce un ambiente di debug per i sistemi operativi a 64 bit.
.NET Framework
Contiene il runtime di lingua comune e i componenti .NET Framework necessari per eseguire le applicazioni .NET Framework.
Windows Desktop Search (opzionale)
Supporta ricerche veloci dei file e dati attraverso origini di dati e posizioni diverse, compresi il computer locale e le reti condivise.
I file Windows Desktop Search sono specifici per la lingua. Per i dettagli, vedere Supporto internazionale di Windows Desktop Search.
Visual C++ Redistributable Package e .NET Framework 3,5 sono necessari per tutti i prodotti SolidWorks, non solo per il prodotto principale SolidWorks.

Questi componenti devono essere compresi nelle sottodirectory della directory con l'immagine amministrativa.

Questa tabella identifica i file necessari per ogni sistema operativo supportato.
Sistema operativo: Windows 2003 32 bit1
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (non pertinente)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lingua.exe
Sistema operativo: Windows 2003 64 bit1
Supporti SolidWorks: versione a 64 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operativo: Windows 2008 32 bit1
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (non pertinente)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale): |  | Windows Desktop Search è una funzione del sistema operativo.
Sistema operativo: Windows 2008 64 bit1
Supporti SolidWorks: versione a 64 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale): |  | Windows Desktop Search è una funzione del sistema operativo.
Sistema operativo: Windows XP 32 bit
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (non pertinente)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale):
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lingua.exe
Sistema operativo: Windows XP 64 bit
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operativo: Windows XP 64 bit
Supporti SolidWorks: versione a 64 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Sistema operativo: Windows Vista 32 bit
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (non pertinente)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale): |  | Windows Desktop Search è una funzione del sistema operativo.
Sistema operativo: Windows Vista 64 bit
Supporti SolidWorks: versione a 64 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opzionale): |  | Windows Desktop Search è una funzione del sistema operativo.
Sistema operativo: Windows 7 32 bit
Supporti SolidWorks: versione a 32 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | (non pertinente)
 | .NET Framework: |  | .NET Framework e Windows Desktop Search sono funzioni del sistema operativo
 | Windows Desktop Search (opzionale):
Sistema operativo: Windows 7 64 bit
Supporti SolidWorks: versione a 64 bit per Windows XP, Windows Vista e Windows 7
 | Windows Installer: |  | (non pertinente)
 | Componenti Web Office: |  | owc11.exe
 | Visual C++ 2005 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Visual C++ 2008 Redistributable Package: |  | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
 | Strumenti Visual Studio per applicazioni: |  | vsta_aide.msi
 | Visual Studio Remote Debugger: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework e Windows Desktop Search sono funzioni del sistema operativo
 | Windows Desktop Search (opzionale):
1L'installazione in Windows 2003 o Windows 2008 è supportata solo per Workgroup PDM Server e SolidNetWork License (SNL) Server.
  • Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 32 bit
    Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 32 bit di Windows.
  • Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit
    Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.
  • Ricerca SolidWorks e Microsoft Windows Desktop Search
    SolidWorks Search è integrato in Microsoft® Windows® Desktop Search.
Argomento principale: Distribuzione dalla riga di comando


Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 32 bit

Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 32 bit di Windows.

Per installare più componenti in una sola operazione, creare un file batch con i comandi forniti nelle seguenti procedure e usarlo per installare i componenti sui computer client.

  1. assicurarsi che il computer di destinazione abbia almeno 290 MB di spazio su disco e una directory TEMP valida.
  2. Installare Office Web Components eseguendo il seguente comando:

    directory_immagine_amministrativa\OfficeWeb_11\owc11.exe

  3. Per Windows XP, installare Windows Installer:

    directory_immagine_amministrativa\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Non è necessario installare Windows Installer su alcuna versione di Windows diversa da Windows XP.

  4. Installare Visual C++ 2005 Redistributable Package:

    directory_immagine_amministrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Installare Visual C++ 2008 Redistributable Package:

    directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Per Windows XP e Windows Vista, installare Microsoft .NET Framework 3.5 mediante Windows Server Update Services.

    Non è necessario installare .NET Framework su Windows 7 o versione successiva.

  7. Installare gli strumenti Visual Studio per applicazioni:

    directory_immagine_amministrativa\Microsoft_VSTA\vsta_aide.msi

Argomento principale: Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa


Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit

Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.

Per installare più componenti in una sola operazione, creare un file batch con i comandi forniti nelle seguenti procedure e usarlo per installare i componenti sui computer client.

  1. assicurarsi che il computer di destinazione abbia almeno 620 MB di spazio su disco e una directory TEMP valida.
  2. Installare Office Web Components eseguendo il seguente comando:

    directory_immagine_amministrativa\OfficeWeb_11\owc11.exe

  3. Installare Visual C++ 2005 Redistributable Package:

    directory_immagine_amministrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    directory_immagine_amministrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Devono essere installate sia la versione a 32 bit che quella a 64 bit di questo pacchetto.

  4. Installare Visual C++ 2008 Redistributable Package:

    directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Devono essere installate sia la versione a 32 bit che quella a 64 bit di questo pacchetto.

  5. Per Windows XP e Windows Vista, installare Microsoft .NET Framework 3.5 mediante Windows Server Update Services.

    Non è necessario installare .NET Framework su Windows 7 o versione successiva.

  6. Installare gli strumenti Visual Studio per applicazioni:

    directory_immagine_amministrativa\Microsoft_VSTA\vsta_aide.msi

  7. Installare Visual Studio Remote Debugger:

    directory_immagine_amministrativa\VSRemoteDebugger\install.exe /Q

Argomento principale: Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa


Ricerca SolidWorks e Microsoft Windows Desktop Search

SolidWorks Search è integrato in Microsoft® Windows® Desktop Search.

Se non è già installata la versione corretta di Windows Desktop Search sul computer, un messaggio invita a installarla o aggiornarla durante l'installazione di SolidWorks.

Quando si crea un'immagine amministrativa, Windows Desktop Search non è incluso nella directory dell'immagine amministrativa. Microsoft Windows Desktop Search deve essere installato manualmente sui computer client che installano SolidWorks da un'immagine amministrativa se questi dovranno utilizzare la funzionalità Ricerca SolidWorks.

Argomento principale: Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa


Installazione da un'immagine amministrativa mediante la riga di comando

È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.

Per un'installazione invisibile:
  1. Aprire una finestra Prompt dei comandi (in Windows, fare clic su Start > Esegui).
  2. Digitare il comando msiexec.exe con /i e /qb ed impostare le proprietà per qualsiasi opzione non compresa nei valori di default indicati di seguito.
Le proprietà per riga di comando dei singoli componenti di installazione comprendono:
  • Proprietà di funzione della riga di comando
  • Proprietà globali della riga di comando
  • Proprietà della riga di comando per SolidWorks eDrawings
  • Proprietà della riga di comando per SolidWorks Explorer/SolidWorks Workgroup PDM
  • Proprietà della riga di comando per SolidWorks Flow Simulation
Usare gli esempi seguenti come modelli per un'installazione invisibile.
Client di SolidWorks
  • Prodotto principale SolidWorks (Inglese)
  • Aggiunta Toolbox
  • Partecipazione nel programma feedback
  • Lingua francese

Versione a 32 bit di SolidWorks su un sistema operativo a 32 bit:

msiexec /i "percorso_immagine_amministrativa_32_bit\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

Versione a 32 bit di SolidWorks su un sistema operativo a 64 bit:

msiexec /i "percorso_immagine_amministrativa_32_bit\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

Versione a 64 bit di SolidWorks su un sistema operativo a 64 bit:

msiexec /i "percorso_immagine_amministrativa_64_bit\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

Il componente di installazione in lingua francese SolidWorks deve essere installato separatamente:
  • Versione a 32 bit:

    msiexec /i "percorso_immagine_amministrativa_32_bit\SolidWorks French\french.msi" /qb

  • Versione a 64 bit:

    msiexec /i "percorso_immagine_amministrativa_64_bit\SolidWorks French\french.msi" /qb

Quando si specificano i comandi per l'installazione di un componente di lingua SolidWorks, non specificare gli argomenti sulla riga di comando.
Client di eDrawings
  • Registra la prestazione
  • Tutte le funzioni

msiexec /i "percorso_immagine_amministrativa\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\cartella" LOGPERFORMANCE=1 SNLSERVER=server_SNL_eDrawings TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer e aggiunta Workgroup PDM
  • SolidWorks Explorer con Workgroup PDM

msiexec /i "percorso_immagine_amministrativa\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\cartella" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
Argomento principale: Distribuzione dalla riga di comando


Proprietà della riga di comando

Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.

  • Proprietà di funzione della riga di comando
    L'installazione di SolidWorks supporta queste proprietà ADDLOCAL per distribuzioni dalla riga di comando.
  • Proprietà globali della riga di comando
    Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.
  • Proprietà della riga di comando per SolidWorks eDrawings
    Queste proprietà della riga di comando sono specifiche a eDrawings.
  • Proprietà della riga di comando per SolidWorks Explorer/SolidWorks Workgroup PDM
    Queste proprietà della riga di comando sono specifiche a SolidWorks Explorer e SolidWorks Workgroup PDM.
  • Proprietà della riga di comando per SolidWorks Flow Simulation
    Queste proprietà della riga di comando sono specifiche a SolidWorks Flow Simulation.
  • Posizioni dei file MSI per immagini amministrative
    Per le immagini amministrative create dalla riga di comando, i file .msi dei componenti di prodotto vengono memorizzati nelle seguenti posizioni sui supporti SolidWorks.
  • Supporto internazionale di Windows Desktop Search
    I nomi dei file Windows Desktop Search indicano la piattaforma e la lingua.
Argomento principale: Distribuzione dalla riga di comando


Proprietà di funzione della riga di comando

L'installazione di SolidWorks supporta queste proprietà ADDLOCAL per distribuzioni dalla riga di comando.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (per SolidWorks 32 bit su sistemi operativi a 32 bit)
  • Intel_Modules_AgeiaX64 (per SolidWorks 32 bit su sistemi operativi a 64 bit)
  • Manuali
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
Quando si specificano le proprietà per le installazioni dalla riga di comando:
  • SolidWorks non supporta l'installazione del prodotto usando l'opzione ADDSOURCE.
  • Le proprietà distinguono le maiuscole dalle minuscole, non possono contenere spazi o trattini e devono essere separate dalla virgola.
  • SolidWorks deve essere specificato per poter installare l'applicazione SolidWorks in modo corretto.
Argomento principale: Proprietà della riga di comando


Proprietà globali della riga di comando

Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.

Proprietà | Descrizione
ENABLEPERFORMANCE Specifica se l'applicazione deve inviare automaticamente i dati relativi alle prestazioni a SolidWorks Corporation.

1 per inviare i dati di prestazione, 0 non inviare.
INSTALLDIR Cartella di installazione per SolidWorks.

Solo installazioni individuali.
INSTALLWDS Installare le estensioni SolidWorks che usano Microsoft Windows Desktop Search. Per i dettagli, vedere Preparazione dei client per l'installazione da un'immagine amministrativa.

1 per installare le estensioni, 0 non installare.
MOTIONSERIALNUMBER | Numero seriale del prodotto SolidWorks Motion
OFFICEOPTION Specificare il pacchetto del prodotto da installare:
0
Client di SolidWorks
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL Specificare ALL per aggiornare tutte le funzioni installate.
Specificare questa proprietà solo quando si esegue l'aggiornamento a un Service Pack all'interno di una release principale esistente (ad esempio, aggiornamento da un'installazione di SolidWorks 2011 SP01 a SolidWorks 2011 SP02).
REINSTALLMODE Opzioni di reinstallazione di Microsoft Installer.

Ad esempio, quando si aggiorna un'installazione da una release di Service Pack a un'altra nella stessa release maggiore, specificare REINSTALLMODE=vomus.

Per informazioni dettagliate sulle impostazioni REINSTALLMODE, vedere la documentazione di Windows Installer su www.microsoft.com.

Specificare questa proprietà solo quando si esegue l'aggiornamento a un Service Pack all'interno di una release principale esistente (ad esempio, aggiornamento da un'installazione di SolidWorks 2011 SP01 a SolidWorks 2011 SP02). Non specificare questa proprietà la prima volta che si installa una release principale di release SolidWorks.
SERVERLIST Elenco server di SolidNetWork.
Si tratta di un elenco di stringhe delimitato dal punto e virgola, ognuna delle quali fa riferimento ad un numero di porta su un server nel formato:

xxxxx@nome_server1;yyyyy@nome_server2;&

dove x e y sono singole cifre. Non aggiungere il punto e virgola dopo l'ultimo server nell'elenco.

Solo installazioni individuali.
SIMULATIONSERIALNUMBER | Numero seriale del prodotto SolidWorks Simulation
SOLIDWORKSSERIALNUMBER | Numero seriale del prodotto SolidWorks, aggiunte comprese.
SWMIGRATE Versione di SolidWorks da aggiornare come appare nell'elenco della finestra Scelta di installazione SolidWorks . Ad esempio:

SWMIGRATE="SolidWorks 2011 SP01"

Specificare questa proprietà solo quando si installa una nuova release maggiore mentre è già presente una release maggiore precedente. Non specificare questa proprietà se si aggiorna da una release Service Pack a un'altra all'interno della stessa release maggiore.
TARGETDIR Cartella di installazione per SolidWorks.

Solo installazioni amministrative.
TOOLBOXFOLDER Cartella di installazione per i file di SolidWorks Toolbox.

Solo installazioni individuali.
TRANSFORMS Contiene elementi specifici per la lingua nel formato:
TRANSFORMS numero.mst
  • Cinese (1028)
  • Cinese semplificato (2052)
  • Ceco (1029)
  • Inglese (1033)
  • Francese (1036)
  • Tedesco (1031)
  • Italiano (1040)
  • Giapponese (1041)
  • Coreano (1042)
  • Polacco (1045)
  • Portoghese brasiliano (1046)
  • Russo (1049)
  • Spagnolo (1034)
  • Turco (1055)
UPGRADESWINSTALL
Specificare se aggiornare una versione esistente di SolidWorks alla versione corrente.
0
Nuova installazione, non aggiornare
1
Aggiorna

Solo installazioni individuali.

Specificare questa proprietà solo quando si installa una nuova release maggiore mentre è già presente una release maggiore precedente. Non specificare questa proprietà se si aggiorna da una release Service Pack a un'altra all'interno della stessa release maggiore.
Argomento principale: Proprietà della riga di comando


Proprietà della riga di comando per SolidWorks eDrawings

Queste proprietà della riga di comando sono specifiche a eDrawings.

Proprietà | Descrizione
ADDLOCAL Specifica la porzione dell'applicazione SolidWorks eDrawings da installare.

Tutto è l'opzione raccomandata.
Sintassi della riga di comando | Funzione:
Tutto | Installa tutte le funzioni. L'applicazione eDrawings ricerca applicazioni publisher di SolidWorks e AutoCAD per validare l'installazione.
eDrawingsViewer | Visualizza eDrawings e altri file.
PublisherForAutoCADR14 | Creazione dei file eDrawings dall'applicazione AutoCAD R14.
PublisherForAutoCAD2000 | Creazione dei file eDrawings dall'applicazione AutoCAD 2000.
PublisherForAutoCAD2004 | Creazione dei file eDrawings dall'applicazione AutoCAD 2004.
PublisherForAutoCAD2005 | Creazione dei file eDrawings dall'applicazione AutoCAD 2005.
PublisherForAutoCAD2006 | Creazione dei file eDrawings dall'applicazione AutoCAD 2006.
DXFDWGTranslator | Visualizza i file DXF/DWG nell'eDrawings Viewer.
Shortcuts | Installa i collegamenti sul desktop.
XML3D | Visualizza i file 3DXML nell'eDrawings Viewer.
INSTALLDIR | Specifica la cartella di installazione per SolidWorks eDrawings.
LOGPERFORMANCE Specifica se l'applicazione deve inviare automaticamente via email i dati relativi alla prestazione alla SolidWorks Corporation.
1
Invia dati prestazionali
0
Altrimenti
SNLSERVER Immettere porta@nome_server del server di licenza SolidNetWork. Usare il punto e virgola per separare più stringhe di porta@nome_server.

Un nome di server di una porta per SNLSERVER è necessario solo per la configurazione del server SNL di SolidWorks. list_of_port@server_strings è un elenco di stringhe delimitate da punti e virogole ognuno dei quali si riferisce ad un numero di porta su un server con il formato:

xxxxx@nome_server1; yyyyy@nome_server2;

dove x e y sono singole cifre. Dopo l'ultimo server nell'elenco, non aggiungere un punto e virgola.
Argomento principale: Proprietà della riga di comando


Proprietà della riga di comando per SolidWorks Explorer/SolidWorks Workgroup PDM

Queste proprietà della riga di comando sono specifiche a SolidWorks Explorer e SolidWorks Workgroup PDM.

Per un client SolidWorks Explorer/Workgroup PDM:
Proprietà client | Descrizione
EXPLORERORPDM
0
Solo SolidWorks Explorer
1
Si possono installare le funzioni di SolidWorks PDM
ADDLOCAL
  • Standalone
  • Client
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone è il Contribuente e Client è l'aggiunta SolidWorks per le installazioni invisibili di SolidWorks Explorer.

Se si specifica AutoCAD, AutoCAD deve essere installato sul sistema. Workgroup PDM troverà la versione appropriata di AutoCAD. Si può specificare più di una versione di AutoCAD.

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 e DocMgr64 funzionano solamente su installazioni di SolidWorks Explorer a 64 bit.

INSTALLDIR | Specifica la cartella di installazione per Workgroup PDM.
ACTIVSERIALNUMBER | Specifica il numero seriale di SolidWorks.
Per Workgroup PDM Server:
Proprietà server | Descrizione
ADDLOCAL
  • Vault
  • WebPortal
  • API

Se si specifica WebPortal (Viewer), specificare anche VAULTNAME.
INSTALLDIR | Specifica la cartella di installazione per Workgroup PDM.
LICENSE_SERVER | Specifica il nome del computer sul quale risiede il server di licenza.
VAULTDATA | Specifica il percorso e la cartella del vault.
VAULTNAME | Specifica il nome del computer sul quale risiede il vault.
Argomento principale: Proprietà della riga di comando


Proprietà della riga di comando per SolidWorks Flow Simulation

Queste proprietà della riga di comando sono specifiche a SolidWorks Flow Simulation.

Proprietà | Descrizione
ACTIVSERIALNUMBER Numero seriale di SolidWorks Flow Simulation standalone.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
CWUPGRADEINSTALL Aggiorna una versione esistente di un particolare software SolidWorks Flow Simulation.
1
Aggiorna
2
Nuova installazione; installazione in una nuova directory

(Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR Specifica l'installazione per una particolare applicazione SolidWorks Flow Simulation.

(Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono singole cifre. Dopo l'ultimo server nell'elenco, non aggiungere un punto e virgola.
SOLIDWORKSPATH Specifica la cartella dove è installato il software SolidWorks.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
TARGETDIR Specifica l'installazione per una particolare applicazione SolidWorks Flow Simulation.

(Solo installazioni da immagine amministrativa)
Argomento principale: Proprietà della riga di comando


Posizioni dei file MSI per immagini amministrative

Per le immagini amministrative create dalla riga di comando, i file .msi dei componenti di prodotto vengono memorizzati nelle seguenti posizioni sui supporti SolidWorks.

Prodotto | Posizione sui supporti
SolidWorks (prodotto principale, inglese) | swwi\data\SolidWorks.msi
SolidWorks (componenti di lingua diversa dall'inglese) | Cinese tradizionale | swwi\lang\chinese\chinese.msi
 | Cinese semplificato | swwi\lang\chinese-simplified\chinese-simplified.msi
 | Ceco | swwi\lang\czech\czech.msi
 | Francese | swwi\lang\french\french.msi
 | Tedesco | swwi\lang\german\german.msi
 | Italiano | swwi\lang\italian\italian.msi
 | Giapponese | swwi\lang\japanese\japanese.msi
 | Coreano | swwi\lang\korean\korean.msi
 | Polacco | swwi\lang\polish\polish.msi
 | Portoghese (brasiliano) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | Russo | swwi\lang\russian\russian.msi
 | Spagnolo | swwi\lang\spanish\spanish.msi
 | Turco | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
Prodotti SolidWorks Simulation | COSMOSM\COSMOSM_lingua.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Server di Workgroup PDM | pdmwserver\SolidWorks Workgroup PDM Server.msi
Attivazione guidata di SolidWorks | swactwizard\Activation Wizard.msi
API DocManager | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork License Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
Argomento principale: Proprietà della riga di comando


Supporto internazionale di Windows Desktop Search

I nomi dei file Windows Desktop Search indicano la piattaforma e la lingua.

Piattaforma/architettura:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | Windows 32 bit
x64 | Windows 64 bit
Lingua:
chs | Cinese semplificato
cht | Cinese
csy | Ceco
deu | Tedesco
enu | English
esn | Spagnolo
fra | Francese
ita | Italiano
jpn | Giapponese
kor | Coreano
plk | Polacco
ptb | Portoghese brasiliano
rus | Russo
trk | Turco
Argomento principale: Proprietà della riga di comando


Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory

La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SolidWorks ai client.

Microsoft Active Directory è un servizio di directory per la gestione dei client e dei server negli ambienti in rete. Semplifica la gestione, la migrazione e l'utilizzo.

  1. Creare un'immagine amministrativa mediante la Gestione installazioni di SolidWorks o la riga di comando.
  2. Se si è utilizzata la riga di comando per creare l'immagine amministrativa, installare i prerequisiti di Windows per l'installazione da un'immagine amministrativa utilizzando Microsoft Active Directory. Per i dettagli, vedere Installazione dei prerequisiti di Windows con Microsoft Active Directory.

    Eseguire questo passaggio solo se si è creata l'immagine manualmente dalla riga di comando. Se si è creata l'immagine mediante la Gestione installazioni di SolidWorks, tutti i prerequisiti di Windows sono installati automaticamente.

  3. Creare un file di trasformazione per personalizzare il software SolidWorks:
    1. Aprire la finestra Prompt dei comandi.
    2. Nella cartella che contiene l'immagine amministrativa, trascinare SWCreateMST.exe nella finestra Prompt dei comandi.

      Il comando deve essere nel formato:

      directory_immagine_amministrativa\SWCreateMST.exe percorso_file_MSI_immagine_amministrativa elenco_proprietà

      Le proprietà possono essere proprietà di funzione o globali. Per i dettagli, vedere Proprietà di funzione della riga di comando e Proprietà globali della riga di comando.

      Usare i seguenti esempi come modelli:

      • Se si installa SolidWorks (versione a 32 bit) su un sistema operativo a 32 bit:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • Se si installa SolidWorks (versione a 32 bit) su un sistema operativo a 64 bit:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • Se si installa SolidWorks (versione a 64 bit) su un sistema operativo a 64 bit:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      Il file SolidWorks.mst viene creato nella cartella contenente l'immagine amministrativa.

  4. In Active Directory, modificare il criterio Applicazioni pubblicate del gruppo o dei gruppi per distribuire il software SolidWorks.
  5. Nella finestra di dialogo Criterio di gruppo, espandere Configurazione del computer e Impostazioni del software.
  6. Fare clic con il pulsante destro del mouse su Installazione del software e selezionare Nuovo > Pacchetto.
  7. Individuare l'immagine amministrativa e fare clic su Apri.
  8. Nella finestra di dialogo Deploy Software, selezionare Advanced published or assigned, quindi fare clic su OK.
  9. Nella finestra di dialogo Proprietà SolidWorks, selezionare la scheda Modifiche e:
    1. Fare clic su Aggiungi.
    2. Navigare al file .mst.
    3. Fare clic su Apri.
  10. Fare clic su OK.
  • Installazione dei prerequisiti di Windows con Microsoft Active Directory
    Attenersi alla seguente procedura per preparare un'immagine amministrativa esistente che dovrà installare SolidWorks sui computer client mediante Microsoft Windows Active Directory.
Argomento principale: Distribuzione dalla riga di comando


Installazione dei prerequisiti di Windows con Microsoft Active Directory

Attenersi alla seguente procedura per preparare un'immagine amministrativa esistente che dovrà installare SolidWorks sui computer client mediante Microsoft Windows Active Directory.

Nelle seguenti procedure, usare il comando appropriato alla versione di SolidWorks da distribuire.

  1. Estrarre i file di Visual C++ 2005 Redistributable Package ed installarli.
    1. Eseguire uno dei comandi seguenti.

      Per le versioni a 32 bit di Windows:

      directory_immagine_amministrativa\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{directory_destinazione_C++}

      Per le versioni a 64 bit di Windows:

      directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{directory_destinazione_C++}

    2. Creare un criterio per installare il modulo ridistribuibile di Microsoft C++ 2005:

      {directory_destinazione_2005_C++}\vcredist.msi –

      Non è necessario un file di trasformazione per questa installazione.

  2. Estrarre i file di Visual C++ 2008 Redistributable Package ed installarli.
    1. Eseguire uno dei comandi seguenti.

      Per le versioni a 32 bit di Windows:

      directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{directory_destinazione_C++}

      Per le versioni a 64 bit di Windows:

      directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{directory_destinazione_C++}

    2. Creare un criterio per installare il modulo ridistribuibile di Microsoft C++ 2008:

      {directory_destinazione_2008_C++}\vcredist.msi –

      Non è necessario un file di trasformazione per questa installazione.

  3. Utilizzando Windows Server Update Services, installare Microsoft .NET Framework 3,5.

    Non è necessario installare .NET Framework su Windows 7 o versione successiva.

  4. Estrarre i file di Office Web Components ed installarli.
    1. eseguire questo comando:

      directory_immagine_amministrativa\OfficeWeb_11\owc11.exe /extract:{directory_Office_Web_Components}

    2. Creare una direttiva per installare Office Web Components:

      {directory_Office_Web_Components}\owc11.MSI

      Non è necessario un file di trasformazione per questa installazione.

  5. Installare Visual Studio Tools for Applications (VSTA) creando il criterio seguente:

    {directory_Microsoft_VSTA}\vsta_aide.MSI

    Non è necessario un file di trasformazione per questa installazione.

  6. Installare Visual Studio Remote Debugger (solo versioni a 64 bit) creando il criterio seguente:

    {directory_Microsoft_remote_debugger}\rdbgexp.MSI

    Non è necessario un file di trasformazione per questa installazione.

Argomento principale: Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory


Amministrazione delle installazioni multiple

Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.

  • Aggiornamento di immagini amministrative a una nuova release
    Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.
  • Amministrazione aggiornamento del prodotto con Service Pack
    Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.
  • Rimozione di un'installazione
    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.
Argomento principale: Installazioni multiple


Aggiornamento di immagini amministrative a una nuova release

Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.

Eseguire la Gestione installazioni di SolidWorks da Internet in modo che i file corretti siano referenziati. La Gestione installazioni di SolidWorks si occuperà di questo, ma l'utente può eseguire l'aggiornamento direttamente dal sito web dei download di SolidWorks (http://www.solidworks.com/sw/support/downloads.htm).

Una volta aggiornata l'immagine amministrativa (che crea una nuova copia dell'immagine), i client possono essere aggiornati in modo da creare riferimenti alla nuova copia dell'immagine amministrativa.

Se i client fanno riferimento alla versione precedente dell'immagine amministrativa usando un'unità mappata o una directory condivisa, ridefinire quell'unità mappata o directory condivisa usando la posizione della copia aggiornata dell'immagine amministrativa.
  • Download dei file di installazione aggiornati per le immagini amministrative
    La Gestione installazioni di SolidWorks è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.
  • Aggiornamento di un'immagine amministrativa
    Per aggiornare un'immagine amministrativa, la Gestione installazioni di SolidWorks crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.
  • Aggiornamento dei client dalle immagini amministrative
    La Gestione installazioni di SolidWorks può aggiornare automaticamente i computer client installati da un'immagine amministrativa.
Argomento principale: Amministrazione delle installazioni multiple


Download dei file di installazione aggiornati per le immagini amministrative

La Gestione installazioni di SolidWorks è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.

  1. Avviare la Gestione installazioni di SolidWorks inserendo il DVD.
  2. Nella schermata Benvenuto, fare clic su Immagine amministrativa.
  3. Nella schermata Numero seriale, digitare il numero seriale di SolidWorks.

    La Gestione installazioni di SolidWorks verifica il sito web di SolidWorks per trovare i prodotti con licenza e i Service Pack disponibili.

  4. Se appare la schermata Versione più recente disponibile , selezionare Sì, scarica e installa la versione più recente: versione.

    La Gestione installazioni di SolidWorks inizia una nuova sessione per installare la versione più recente.

  5. In caso di problemi con la cartella di download, potrebbero apparire le Opzioni di download, nel qual caso accettare la directory di default per i nuovi file di installazione o immettere un nuovo nome di directory.

    Se appare un messaggio che la directory non esiste, fare clic su Sì per crearla.

  6. Nella schermata Download completato, fare clic su Chiudi per chiudere l'installatore corrente ed avviarlo per la nuova versione.
Argomento principale: Aggiornamento di immagini amministrative a una nuova release


Aggiornamento di un'immagine amministrativa

Per aggiornare un'immagine amministrativa, la Gestione installazioni di SolidWorks crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.

Questa procedura presume che si siano scaricati i file di installazione aggiornati per l'immagine amministrativa. Per i dettagli, vedere Download dei file di installazione aggiornati per le immagini amministrative.

  1. Avviare la Gestione installazioni di SolidWorks. Per i dettagli, vedere Inizio dell'installazione di SolidWorks.
  2. Nella schermata Benvenuto, fare clic su Immagine amministrativa.

    Si visualizzano le opzioni per la creazione di un'immagine amministrativa:

    Creare una nuova immagine utilizzando le impostazioni di default.
    Creare l'immagine utilizzando le impostazioni di configurazione di default (ossia, non quelle stabilite dalla propria azienda per le immagini amministrative esistenti).
    Creare una nuova immagine utilizzando le impostazioni e i file da un'immagine esistente.
    Creare l'immagine utilizzando le impostazioni di configurazione specificate per un'immagine amministrativa esistente presso la propria azienda. Fare clic Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
    Creare immagini amministrative a 32 bit e 64 bit.
    È possibile creare immagini amministrative a 32 bit e 64 bit su un solo computer oppure creare solo l'immagine corrispondente all'architettura del sistema. La creazione di entrambe le immagini non richiede l'accesso ai supporti di installazione per Il 32 bit e 64 bit.

  3. Nella schermata Numero seriale, controllare il numero seriale.
  4. Nella schermata Sintesi (Pronto a creare immagine), verificare che le opzioni dell'immagine amministrativa siano corrette.

    Per i dettagli sulle varie opzioni di un'immagine amministrativa e per l'installazione, fare clic su CAMBIA per aprire la pagina delle opzioni, quindi fare clic su ?.

  5. Per creare una nuova versione dell'immagine amministrativa, fare clic su Crea ora.

È ora possibile aggiornare i client a questa nuova versione dell'immagine amministrativa. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.

Argomento principale: Aggiornamento di immagini amministrative a una nuova release


Aggiornamento dei client dalle immagini amministrative

La Gestione installazioni di SolidWorks può aggiornare automaticamente i computer client installati da un'immagine amministrativa.

Tipicamente, le immagini amministrative sono organizzate in cartelle su un server. Per supportare l'aggiornamento automatico dei clienti, l'immagine amministrativa di SolidWorks dovrà trovarsi in una cartella condivisa.

Dopo l'aggiornamento dell'immagine amministrativa, l'installazione originale sarà in una cartella e l'installazione aggiornata sarà in un'altra. Per usare l'installazione aggiornata, rimuovere prima di tutto l'opzione di condivisione dalla cartella dell'immagine amministrativa originale ed aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata.

Quando SolidWorks si avvia su un client che lo ha installato dall'immagine amministrativa originale, rileva la presenza della nuova versione e aggiorna il client.

  • Rimozione dell'opzione Condivisione dalla cartella dell'immagine amministrativa originale
    Quando si aggiorna un'immagine amministrativa con accesso da una cartella condivisa, è necessario rimuovere la condivisione dalla cartella originale.
  • Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata
    Una volta creata la cartella aggiornata dell'immagine amministrativa e dopo aver disattivato la condivisione per la cartella originale, è necessario aggiungere l'opzione Condivisione alla nuova cartella per riattivare l'immagine amministrativa.
  • Aggiornamento manuale dei client di immagini amministrative mediante la riga di comando
    Una volta aggiornata un'immagine amministrativa, è possibile aggiornare i client manualmente dalla riga di comando.
Argomento principale: Aggiornamento di immagini amministrative a una nuova release


Rimozione dell'opzione Condivisione dalla cartella dell'immagine amministrativa originale

Quando si aggiorna un'immagine amministrativa con accesso da una cartella condivisa, è necessario rimuovere la condivisione dalla cartella originale.

  1. navigare alla cartella dove i file dell'immagine amministrativa originale sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, selezionare Non condividere questa cartella e fare clic su OK.

Aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata, come descritto in Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata.

Argomento principale: Aggiornamento dei client dalle immagini amministrative


Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata

Una volta creata la cartella aggiornata dell'immagine amministrativa e dopo aver disattivato la condivisione per la cartella originale, è necessario aggiungere l'opzione Condivisione alla nuova cartella per riattivare l'immagine amministrativa.

  1. navigare alla cartella dove i file dell'immagine amministrativa aggiornata sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, specificare le proprietà di condivisione appropriate per la propria azienda o gruppo e modificare il nome di condivisione con il nome usato per la cartella delle immagini amministrative.
I computer con installazione dalla posizione condivisa dell'immagine amministrativa originale si aggiorneranno automaticamente alla nuova versione all'avvio di SolidWorks.
Argomento principale: Aggiornamento dei client dalle immagini amministrative


Aggiornamento manuale dei client di immagini amministrative mediante la riga di comando

Una volta aggiornata un'immagine amministrativa, è possibile aggiornare i client manualmente dalla riga di comando.

  1. Assicurarsi che tutti i client abbiano lo stesso Service Pack della release precedente. (I client che non hanno già l'applicazione installata non vengono aggiornati.)
  2. A scelta, su un sistema del client, eseguire la Copiatura guidata delle impostazioni per registrare le opzioni SolidWorks.
  3. Creare una nuova immagine amministrativa mediante la Gestione installazioni di SolidWorks o la riga di comando.

    Non aggiornare o sovrascrivere l'immagine precedente.
    Se si aggiorna un'installazione di SolidWorks diversa dall'inglese, è necessario creare una nuova immagine amministrativa per il componente di installazione in tale lingua.

  4. Aggiornare tutti i client alla nuova versione mediante il comando msiexec, con queste specifiche:

    • Includere le opzioni /I e qb msiexec sulla riga di comando.
    • Specificare qualsiasi proprietà di caratteristica e globale necessaria sulla riga di comando. Per i dettagli, vedere Proprietà della riga di comando.

    Ad esempio, per aggiornare una versione esistente di SolidWorks:

    msiexec /I percorso_msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks versione servicepack" /qb

    Se si aggiorna un'installazione di SolidWorks diversa dall'inglese, è necessario aggiornare il componente di tale lingua dopo aver aggiornato i componenti di SolidWorks.

Argomento principale: Aggiornamento dei client dalle immagini amministrative


Amministrazione aggiornamento del prodotto con Service Pack

Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.

L'utente può acquisire gli aggiornamenti del prodotto in due modi:

Per le versioni correnti di SolidWorks:
Usando la Gestione installazioni di SolidWorks per verificare la disponibilità, scaricare ed installare gli aggiornamenti.

La Gestione installazioni di SolidWorks può essere avviata manualmente o pianificata periodicamente per controllare gli aggiornamenti.

Per le versioni di SolidWorks precedenti alla 2008:
Scaricando i Service Pack manualmente dal sito web del supporto SolidWorks.

I service pack vengono applicati come patch ad una versione esistente del software. Ad esempio, SolidWorks 2007 SP1.0 è un Service Pack per SolidWorks 2007 SP0.0. Questi Service Pack possono essere installati usando la Gestione installazioni di SolidWorks 2007; non è possibile installarli usando la Gestione installazioni di SolidWorks in SolidWorks 2008 o versione successiva.

Per le istruzioni o per scaricare ed installare i service pack, vedere la documentazione sull'installazione per la versione di SolidWorks in via di aggiornamento.

  • Annullamento dei Service Pack in un'immagine amministrativa
    Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SolidWorks viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.
  • Applicazione dei Service Pack ai client distribuiti con Microsoft Active Directory
    Se SolidWorks è stato installato con Microsoft Active Directory, sarà possibile utilizzare tale funzionalità per applicare i Service Pack ai client.
Argomento principale: Amministrazione delle installazioni multiple


Annullamento dei Service Pack in un'immagine amministrativa

Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SolidWorks viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.

Le immagini amministrative che sono state aggiornate non possono essere riportate ad un Service Pack precedente. Le immagini amministrative create con qualsiasi metodo diverso dalla Gestione installazioni di SolidWorks non potranno essere riportate ad una versione precedente. I client installati da queste immagini amministrative devono essere disinstallati e quindi reinstallati con un'immagine amministrativa creata dalla versione precedente.
  1. Cancellare la cartella che contiene l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:

    rmdir /s/q percorso_immagine_amministrativa_corrente

  2. Spostare la copia di backup dell'immagine amministrativa nella posizione in cui è stata eliminata l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:

    move percorso_backup_immagine_amministrativa percorso_immagine_amministrativa_corrente

    Dopo avere ripristinato la versione precedente di un'immagine amministrativa, i computer client saranno riportati la versione precedente all'esecuzione successiva del software SolidWorks.

Argomento principale: Amministrazione aggiornamento del prodotto con Service Pack


Applicazione dei Service Pack ai client distribuiti con Microsoft Active Directory

Se SolidWorks è stato installato con Microsoft Active Directory, sarà possibile utilizzare tale funzionalità per applicare i Service Pack ai client.

  1. Copiare l'immagine amministrativa su una nuova cartella usando la seguente riga di comando:

    xcopy percorso_immagine_amministrativa_corrente percorso_backup_immagine_amministrativa /s/i/v

  2. Applicare il service pack alla copia dell'immagine amministrativa.
  3. Creare un nuovo file di trasformazione per specificare un'installazione di aggiornamento per il software SolidWorks:
    1. Aprire la finestra Prompt dei comandi.
    2. Nella cartella che contiene l'immagine amministrativa, trascinare SWCreateMST.exe nella finestra del Prompt dei comandi.

      Il formato del comando è:

      percorso_immagine_amministrativa\SWCreateMST.exe percorso_file_MSI_immagine_amministrativa elenco_proprietà

      La riga di comando deve comprendere tutti i parametri usati per creare il file di trasformazione originale, oltre alle proprietà globali UPGRADESWINSTALL e SWMIGRATE.

      Per esempio, se il comando originale era:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@server

      il comando di aggiornamento deve essere:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\cartella" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@server UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks versione service_pack"

      Il file SolidWorks.mst viene creato nella cartella contenente l'immagine amministrativa.

      I comandi originale e di aggiornamento in questo esempio si riferiscono all'installazione della versione a 32 bit di SolidWorks in un sistema operativo versione a 32 bit. Se si sta installando la versione a 32 bit di SolidWorks su un sistema operativo a 64 bit, usare "Intel_Modules_AgeiaX64" al posto di "Intel_Modules_AgeiaX86". Se si sta installando la versione a 64 bit di SolidWorks su un sistema operativo a 64 bit, usare "Intel_Modules_AgeiaX86" o "Intel_Modules_AgeiaX64".

  4. In Active Directory, modificare il criterio Applicazioni pubblicate per il gruppo o gruppi per poter avviare il software SolidWorks.
  5. Nella finestra di dialogo Criteri di gruppo, espandere Configurazione del computer e impostazioni software.
  6. Fare clic con il pulsante destro del mouse su Installazione del software e selezionare Nuovo > Pacchetto.
  7. Individuare l'immagine amministrativa e fare clic su Apri.
  8. Nella finestra di dialogo Deploy Software, selezionare Advanced published or assigned, quindi fare clic su OK.
  9. Nella finestra di dialogo Proprietà SolidWorks, selezionare la scheda Modifiche.
    1. Fare clic su Aggiungi.
    2. Navigare al file .mst.
    3. Fare clic su Apri.
  10. Fare clic su OK.
Argomento principale: Amministrazione aggiornamento del prodotto con Service Pack


Workgroup PDM

Workgroup PDM è un software di gestione dati di progettazione in esecuzione nell'ambiente SolidWorks o come applicazione standalone all'interno di SolidWorks Explorer. Workgroup PDM controlla i progetti con le procedure di check-out, check-in, il controllo di revisione e altre operazioni amministrative.

Ecco illustrato di seguito un sistema Workgroup PDM:

  • un computer può contenere soltanto un vault.
  • La directory del vault non può essere nascosta o di sola lettura.
  • Per un'applicazione client/server, la prestazione di Workgroup PDM dipenderà da una rete solida.
  • Se gli utenti devono gestire un grande numero di documenti, la prestazione sarà migliore se si creano più progetti o sottoprogetti invece di gestire i documenti in un numero ristretto di progetti.

Installazione

  • I client e VaultAdmin, le API e Viewer possono essere installati sullo stesso computer del vault o su computer diversi.
  • Non è più necessario installare Workgroup PDM Server per installare l'API client. L'API client viene installata durante l'installazione del client di Workgroup PDM.
  • Per configurare la cartella del vault in una posizione remota, digitare l'intero percorso UNC (Universal Naming Convention) quando viene richiesta la destinazione del server. (Per i dettagli, vedere Formato UNC).
  • L'installazione o l'aggiornamento del vault richiedono il riavvio del computer.
  • Dopo il riavvio, se il Servizio del server di Workgroup PDM non inizia automaticamente, sarà necessario avviarlo manualmente. In Esplora risorse, eseguire pdmwvault.exe nella cartella directory_installazione\SolidWorks Workgroup PDM\Vault.
  • Quando si installa un client di Workgroup PDM, è necessario eseguire solidworksexplorer.exe su ogni computer. Questo eseguibile può essere su un'unità rigida condivisa. Il vault di Workgroup PDM, Viewer, l'API client e VaultAdmin non sono installati sul computer di ogni client.

Licenze

  • Una licenza per l'API di Workgroup PDM è compresa con le licenze dei client SolidWorks ed Explorer. Le API di check-in richiedono licenze client.
  • La licenza per Workgroup PDM Viewer deve essere installata con il vault per attivare il Viewer.

Permessi

  • L'amministratore del vault dovrebbe avere il permesso di scrittura per l'installazione e per la cartella del vault.
  • L'amministratore del vault deve gestire la cartella del vault da VaultAdmin, non con Esplora risorse.
  • Gli utenti non dovrebbero mai avere permesso di scrittura in Esplora risorse per la cartella del vault.

Sicurezza, Porte e Impostazioni Duplex

  • Workgroup PDM deve poter installare come servizio Windows, in modo che altre applicazioni non possano bloccare o filtrare il servizio. Se gli strumenti anti-spyware come AntiSpyware di Microsoft visualizzano un avvertimento che richiede un'approvazione durante il processo di installazione. Fare clic su Consenti in modo che il server di Workgroup PDM sia installato come servizio Windows.
  • Se Workgroup PDM viene installato su un sistema Windows XP con il Service Pack 2, su un server Windows 2003 con Service Pack 1 o su un computer con un firewall attivo, attivare le porte di Workgroup PDM come eccezioni nell'impostazione del firewall.

    Solitamente, le porte sono:

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Richiesta)
    • 80 (Visualizzatore)
    Per le informazioni sulla modifica delle impostazioni della porta, vedere Diagnostica per gli amministratori del vault nella Guida in linea di Workgroup PDM e SolidWorks Explorer e la Guida di Windows per il Centro di sicurezza. Per installare il vault di Workgroup PDM e allo stesso tempo il Viewer, usare l'opzione Personalizzata nella finestra Tipo di impostazione.
  • L'impostazione duplex per i server e le corrispondenti porte deve essere identica; ad esempio, entrambi possono essere 100MB Full o Automatico.

Documenti SolidWorks Toolbox

I documenti SolidWorks Toolbox sono componenti hardware comuni che generalmente non richiedono il controllo di revisione e non necessitano del check-in nel vault di Workgroup PDM. Vedere la Guida in linea di Workgroup PDM per i dettagli relativi alla configurazione di SolidWorks Toolbox e di altre librerie standard.

  • Workgroup PDM Viewer
    Il software Workgroup PDM imposta automaticamente una directory virtuale durante l'installazione usando Microsoft Internet Information Services (IIS).
  • Installazione di un server di Workgroup PDM
    L'installazione del server di Workgroup PDM crea un vault di Workgroup PDM che rappresenta il database dove sono conservati i progetti SolidWorks gestiti.
  • Configurazione di Workgroup PDM per i client
    Dopo aver installato il vault sul server di Workgroup PDM, è possibile configurarlo per i client.
  • Installazione del server Workgroup PDM e Viewer in una rete perimetrale
    Installare un server web di SolidWorks Workgroup PDM e Workgroup PDM Viewer in una rete perimetrale (DMZ) ha implicazioni di firewall.
  • Accesso al client di Workgroup PDM
    I client di Workgroup PDM utilizzano il controllo di accesso Microsoft Windows, hanno accesso Web a Workgroup PDM Viewer e vengono aggiornati automaticamente quando si aggiorna il vault Workgroup PDM.
  • Amministrazione di Workgroup PDM VaultAdmin
    Dopo l'installazione di Workgroup PDM, gli amministratori del vault devono eseguire queste operazioni:


Workgroup PDM Viewer

Il software Workgroup PDM imposta automaticamente una directory virtuale durante l'installazione usando Microsoft Internet Information Services (IIS).

È necessario installare Microsoft Internet Information Services (IIS) prima di installare Viewer.
I componenti necessari comprendono:
  • Strumenti per la gestione web
    • IIS Management Console
  • Servizi World Wide Web: Funzioni di sviluppo applicazioni
    • Estensibilità .NET
    • ASP.NET
    • CGI
    • Estensioni ISAPI
    • Filtri ISAPI
Vedere la documentazione Microsoft per le istruzioni relative all'installazione.
L'installazione di Workgroup PDM Viewer è soggetta alle seguenti restrizioni:
  • Web Site Content Directory è la cartella di installazione del Viewer.
  • Non si possono usare caratteri di sottolineatura nel nome del computer che ospita il Viewer.
  • Se si installa il Viewer su Windows XP Service Pack 2, è necessario attivare una porta nel firewall di Windows per HTTP (porta 80).
  • Il Viewer può essere rivolto solo verso un unico vault alla volta.

Gli utenti accedono a Workgroup PDM Viewer digitando il seguente URL nel campo indirizzo di Internet Explorer:

http://NomeComputerViewer/pdmweb/

Argomento principale: Workgroup PDM


Installazione di un server di Workgroup PDM

L'installazione del server di Workgroup PDM crea un vault di Workgroup PDM che rappresenta il database dove sono conservati i progetti SolidWorks gestiti.

  1. Avviare la Gestione installazioni SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
  2. Nella schermata Benvenuti, selezionare:

    • Prodotti del server
    • Installare il server di SolidWorks Workgroup PDM (vault) su questo computer.

  3. nello schermo Sintesi, fare clic su Cambia per ottenere un codice di autenticazione. Il codice di autenticazione si può ottenere usando uno dei seguenti metodi:
    • connessione internet
      1. Digitare il numero seriale SolidWorks e un indirizzo di email nei campi forniti.
      2. Selezionare Autenticare automaticamente e fare clic su Ottieni codice.
    • Email
      1. Se il proprio computer non ha accesso ad una connessione Internet, fare clic su Autentica manualmente via email. La Gestione installazioni genera un file di Richiesta autenticazione.
      2. Fare clic su Salva per sistemare il file localmente sul sistema.
      3. Seguire le istruzioni su schermo e immettere il codice di autenticazione.
  4. Fare clic su Torna alla Sintesi.
  5. Nella schermata Sintesi, fare clic su Installa ora.
Argomento principale: Workgroup PDM


Configurazione di Workgroup PDM per i client

Dopo aver installato il vault sul server di Workgroup PDM, è possibile configurarlo per i client.

  1. Accedere a VaultAdmin (installato con SolidWorks Explorer) con il nome utente e la password di default.
  2. In VaultAdmin, impostare gli account utente e gruppo, le cartelle di progetto, i permessi, ecc.

    Per le istruzioni, vedere la Guida di Workgroup PDM.

  3. Inviare agli utenti del client via email il nome del computer server e i loro nomi utente e password, generalmente diversi dai nomi utente e dalle password di Microsoft Windows.
  • Configurazione di Workgroup PDM Viewer per la connessione a un vault in una posizione diversa
    È possibile configurare Workgroup PDM Viewer per la connessione a un vault in una posizione diversa attraverso il registro di Windows.
  • Configurazione dei tipi mime per il download dei documenti
    È possibile configurare i tipi mime per il download dei documenti attraverso il registro di Windows.
Argomento principale: Workgroup PDM


Configurazione di Workgroup PDM Viewer per la connessione a un vault in una posizione diversa

È possibile configurare Workgroup PDM Viewer per la connessione a un vault in una posizione diversa attraverso il registro di Windows.

  1. Aggiornare il percorso del registro cambiando il valore Computer del vault:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Reinstallare Workgroup PDM Viewer. Nella finestra Nome del computer del vault, digitare il nuovo nome del computer.
Argomento principale: Configurazione di Workgroup PDM per i client


Configurazione dei tipi mime per il download dei documenti

È possibile configurare i tipi mime per il download dei documenti attraverso il registro di Windows.

Di default, il Viewer invia le richieste di Apri documento con il tipo generico di mime "application/octet-stream." Microsoft Internet Explorer apre il documento richiesto con l'estensione del file fornito. È possibile associare nuovi tipi mine o disattivare l'associazione dei tipi mime modificando la sottochiave Mime Types nel registro di Windows.

  • Per associare altri tipi mime, creare nuove stringhe con i valori in questa sottochiave:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    nel formato:

    "ext" = "mime type"

    Ad esempio:

    "dxf" = "image/vnd.dxf"

    questa sottochiave di registro deve essere creata manualmente prima di aggiungere i valori.

    Per disattivare l'associazione dei tipi mime, portare il valore di registro Use Custom MIME Types a 0 (zero).

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Il riavvio del server del web non è necessario per attivare questa impostazione.

Argomento principale: Configurazione di Workgroup PDM per i client


Installazione del server Workgroup PDM e Viewer in una rete perimetrale

Installare un server web di SolidWorks Workgroup PDM e Workgroup PDM Viewer in una rete perimetrale (DMZ) ha implicazioni di firewall.

Dal momento che i clienti di Workgroup PDM Viewer comunicano con il server web su porte HTTP o HTTPS, queste porte devono essere aperte sul sistema Internet Information Server (IIS) dove il server web è installato.

  • Per il protocollo HTTP, la porta di default è 80.
  • Per il protocollo HTTPS (SSL), la porta di default è 443.

I clienti del viewer web non hanno bisogno di eccezioni al firewall.

Assicurarsi che il sistema di server web possa raggiungere il server del vault su queste porte di default:

  • 30000 (Data)
  • 40000 (Richiesta)
  • Configurazione di rete per Workgroup PDM Viewer in una Rete di perimetro
    La configurazione di rete mostra l'impostazione del server in rete perimetrale su un sottogruppo di un perimetro e la relativa comunicazione alle reti interna ed esterna.
  • Installare e configurare il server web di Workgroup PDM e il Viewer
    Quando si imposta un server web di Workgroup PDM in una rete perimetrale, l'ubicazione dell'installazione dei componenti è importante.
Argomento principale: Workgroup PDM


Configurazione di rete per Workgroup PDM Viewer in una Rete di perimetro

La configurazione di rete mostra l'impostazione del server in rete perimetrale su un sottogruppo di un perimetro e la relativa comunicazione alle reti interna ed esterna.

Il server di rete perimetrale comunica al LAN attraverso un firewall interno. Comunica alla rete esterna attraverso un firewall esterno, un router e un cluster di equilibratori di carico.

Il client di Internet Explorer si connette al server di Workgroup PDM Viewer/IIS a mezzo della porta 80 (o 443 se configurato all'uso del SSL). Workgroup PDM Viewer si connette al server del vault usando le porte 30000 o 40000. Il server del vault invia le informazioni richieste a Workgroup PDM Viewer, il quale fornirà di conseguenza le informazioni al client di Internet Explorer.

Il server web della rete perimetrale ha due indirizzi IP:

  • l'indirizzo IP interno sul LAN
  • L'indirizzo IP pubblico fornito dall'ISP

Il server web nella rete perimetrale è ubicato dietro un cluster di equilibratori di carico. Sebbene si possa arrivare direttamente al server web per le operazioni amministrative, tutto il traffico dei servizi web ai server nella rete perimetrale viene elaborato attraverso gli equilibratori di carico.

Gli equilibratori di carico convertono l'indirizzo IP del server ad uno virtuale (VIP) sul ramo in rete esposto al pubblico. Se si naviga al VIP o all'URL del server web se collegato alla rete, sarà possibile visualizzare il sito.

Il firewall esterno converte il VIP dell'equilibratore di carico ad uno pubblico, indirizzo instradabile.

Argomento principale: Installazione del server Workgroup PDM e Viewer in una rete perimetrale


Installare e configurare il server web di Workgroup PDM e il Viewer

Quando si imposta un server web di Workgroup PDM in una rete perimetrale, l'ubicazione dell'installazione dei componenti è importante.
  • Installare il server web IIS abilitato sul sottogruppo del perimetro.
  • Installare Workgroup PDM Viewer IIS abilitato sul sottogruppo del perimetro.
  • Installare il Vault di Workgroup PDM sul dominio primario o rete interna su intranet locale.

I prerequisiti per installare e configurare Workgroup PDM Viewer in una rete di perimetro sono:

  • Microsoft IIS 6.0 o successiva
  • Un indirizzo IP pubblico al server web sul sottogruppo del perimetro, assegnato dal proprio provider ISP

Per installare e configurare i componenti Workgroup PDM:

  1. installare Microsoft IIS sul sistema di server del sottogruppo del perimetro.
  2. Effettuare due installazioni del server SolidWorks Workgroup PDM:
    1. prima di tutto, installare il componente del vault sul server del vault.
    2. Eseguire l'installer una seconda volta ed installare i componenti di licenza per Workgroup PDM Viewer e il Viewer nel server web IIS. Immettere il nome di computer del server del vault in modo che il portale Web sappia dove cercare per il servizio di server del vault.

    Quando si effettua l'installazione, l'applicazione PDMWeb viene aggiunta automaticamente al sito web IIS di default.

  3. Assicurarsi che il firewall alla rete interna abbia porte 30000 e 40000 aperte.
  4. Se il server interno ha un indirizzo IP fisso, sul sistema di server del perimetro, modificare il file C:\Windows\system32\drivers\etc\hosts. Creare un nome di sistema alla mappatura di indirizzo IP in modo che il server perimetrale possa comunicare con il server interno:
    1. Aprire il file hosts in un editor di testo, ad esempio, BloccoNote.
    2. Aggiungere una nuova linea per l'indirizzo IP del vault e il nome.
    3. Salvare il file hosts.
Argomento principale: Installazione del server Workgroup PDM e Viewer in una rete perimetrale


Accesso al client di Workgroup PDM

I client di Workgroup PDM utilizzano il controllo di accesso Microsoft Windows, hanno accesso Web a Workgroup PDM Viewer e vengono aggiornati automaticamente quando si aggiorna il vault Workgroup PDM.

Per connettersi al client di Workgroup PDM: | i nomi degli utenti client e le password non sono uguali in Workgroup PDM come nel login di Microsoft Windows. contattare l'amministratore del sistema per informazioni sul login.
Per connettersi al Workgroup PDM Viewer: | contattare il proprio amministratore di sistema per gli indirizzi URL per collegarsi al Viewer.
Per aggiornare i client di Workgroup PDM: | i client di Workgroup PDM (aggiunta SolidWorks e Contributor) identificano quando il vault è stato aggiornato. Non è necessario effettuare il download di un service pack per aggiornare i client.
Argomento principale: Workgroup PDM


Amministrazione di Workgroup PDM VaultAdmin

Dopo l'installazione di Workgroup PDM, gli amministratori del vault devono eseguire queste operazioni:

  • Accedere a VaultAdmin.
  • Cambiare la password dell'amministratore del vault.
  • Creare gli account degli utenti.
  • Notificare agli utenti i loro nomi e password.

Per i dettagli, vedere SolidWorks Workgroup PDM nella Guida principale di SolidWorks.

  • Accesso iniziale a Workgroup PDM VaultAdmin
    Quando si accede per la prima volta a Workgroup PDM VaultAdmin, specificare il nome dell'amministrazione di Workgroup PDM e la password, così come il nome del computer che ospita il vault Workgroup PDM.
  • Aggiornamento del server del vault Workgroup PDM
    È possibile aggiornare il server del vault Workgroup PDM mediante il comando Verifica aggiornamenti di SolidWorks, un DVD di installazione di SolidWorks o un file di aggiornamento per Workgroup PDM scaricato manualmente in una cartella locale.
  • Aggiornamento di client Workgroup PDM
    I client Workgroup PDM rilevano quando il vault è stato aggiornato. Non è necessario effettuare il download di un service pack per aggiornare i client.
Argomento principale: Workgroup PDM


Accesso iniziale a Workgroup PDM VaultAdmin

Quando si accede per la prima volta a Workgroup PDM VaultAdmin, specificare il nome dell'amministrazione di Workgroup PDM e la password, così come il nome del computer che ospita il vault Workgroup PDM.

  1. In Windows, selezionare Start > Tutti i programmi > SolidWorks versione > Workgroup PDM VaultAdmin.
  2. Nella finestra di dialogo digitare le seguenti informazioni:

    Nome | pdmwadmin
    Password | pdmwadmin
    Computer del vault | Il nome host del computer dove è installato il vault. Se si esegue il vaultAdmin sul computer dove è installato il vault, digitare localhost.

  3. Fare clic su Accedi.
Per questioni di sicurezza, si consiglia di cambiare la password dell'amministratore appena possibile. Nel vaultAdmin, selezionare la scheda Utenti e gruppi.
Argomento principale: Amministrazione di Workgroup PDM VaultAdmin


Aggiornamento del server del vault Workgroup PDM

È possibile aggiornare il server del vault Workgroup PDM mediante il comando Verifica aggiornamenti di SolidWorks, un DVD di installazione di SolidWorks o un file di aggiornamento per Workgroup PDM scaricato manualmente in una cartella locale.

È possibile installare solo una versione del server del vault Workgroup PDM
  1. chiedere a tutti gli utenti di disconnettersi dal vault Workgroup PDM e quindi bloccarlo.
  2. Effettuare un backup dei dati del vault.
  3. Utilizzare Installazione applicazioni nel Pannello di controllo di Windows per rimuovere la versione corrente del server di Workgroup PDM.
  4. Installare la nuova versione del server di Workgroup PDM.
    • Per utilizzare Verifica aggiornamenti di SolidWorks:
      1. In Windows, fare clic su Start > Tutti i programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti.
      2. Nella finestra di dialogo Versione più recente disponibile, selezionare Scarica ed installa una nuova versione, selezionare la versione da installare e fare clic su Avanti.

        La nuova versione della Gestione installazioni di SolidWorks si scarica e si esegue.

    • Per utilizzare un DVD di installazione di SolidWorks, inserire il DVD e attenersi alle istruzioni della Gestione installazioni di SolidWorks.
    • Per utilizzare un file di installazione per Workgroup PDM scaricato manualmente (pdmwserver.exe), fare doppio clic sul file e attenersi alle istruzioni per aggiornare il server di Workgroup PDM.
  5. Usare SolidWorks Task Scheduler per aggiornare i file di Workgroup PDM nel vault.
  6. Sbloccare il vault e notificare gli utenti che possono riprendere ad usarlo.
Argomento principale: Amministrazione di Workgroup PDM VaultAdmin


Amministrazione delle licenze

Dopo l'installazione, è possibile attivare le licenze SolidWorks singolarmente su ogni computer (attivazione della licenza) oppure installare e attivando licenze di rete flottanti (mobili) su un server (licenze SolidNetWork).

Di solito, le installazioni su computer individuali usano l'attivazione della licenza; tuttavia, è possibile installare il software individualmente e poi controllare le licenze con il Gestore di licenze SolidNetWork. Inoltre, sebbene i siti di grandi dimensioni di solito usano licenze in rete mobili, è possibile implementare le installazioni da un'immagine amministrativa e successivamente attivare i numeri seriali dai computer individuali.

  • Amministrazione di licenze individuali
    Solitamente, l'amministrazione di licenze individuali implica l'attivazione e il trasferimento delle licenze direttamente da SolidWorks.
  • Amministrazione delle licenze mediante SolidNetWork License Manager
    SolidNetWork License Manager supporta più client di licenza con la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.


Amministrazione di licenze individuali

Solitamente, l'amministrazione di licenze individuali implica l'attivazione e il trasferimento delle licenze direttamente da SolidWorks.

L'attivazione è un processo di registrazione e immatricolazione per le licenze standalone di SolidWorks (licenze non SolidNetWork). Se la licenza del prodotto non è stata ancora attivata, SolidWorks tenta di attivarla al primo avvio.

È anche possibile trasferire singole licenze selezionando ? > Trasferimento licenze in SolidWorks.

  • Attivazione di una licenza
    Prima di poter eseguire i prodotti SolidWorks su un computer particolare, è necessario attivare la licenza per tale computer.
  • Trasferimento di una licenza
    Per trasferire una licenza a un componente nuovo o aggiornato, trasferire prima la licenza sul server chiavi di licenza di Dassault Systèmes SolidWorks Corporation, quindi riattivarla sull'altro computer.
Argomento principale: Amministrazione delle licenze


Attivazione di una licenza

Prima di poter eseguire i prodotti SolidWorks su un computer particolare, è necessario attivare la licenza per tale computer.

L'attivazione richiede l'accesso ad Internet o all'email. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • attiva tutte le licenze del software per qualsiasi prodotto SolidWorks.
  • Consente di trasferire i diritti di licenza da un computer all'altro.
  • Permette di installare e attivare i prodotti SolidWorks sul computer dell'ufficio e su un computer a casa.
  • Può essere effettuata immediatamente (consigliato) o entro trenta giorni dall'installazione.
  • Elimina il bisogno dei dispositivi di sicurezza. Tuttavia, se si eseguono le versioni precedenti dei prodotti SolidWorks che non utilizzano l'attivazione, sarà necessario un dispositivo di sicurezza.

Per gli amministratori di sistema che devono gestire diversi numeri di seriali, vedere Editor opzioni dell'immagine amministrativa. Per i dettagli, vedere Editor opzioni immagine amministrativa.

Per attivare una licenza:

  1. Avviare l'applicazione SolidWorks.
  2. Avviare Attivazione del prodotto SolidWorks mediante uno dei metodi seguenti:
    • Se non si è ancora attivata su questo computer, all'avvio di SolidWorks si apre automaticamente la finestra Attivazione del prodotto SolidWorks.
    • Se la finestra Attivazione del prodotto SolidWorks non si apre automaticamente, avviare l'attivazione selezionando ? > Attivazione licenze.
  3. Fare clic sul Prodotto desiderato per attivare la licenza specifica.
  4. Selezionare l'attivazione automatica via Internet o l'attivazione manuale via email.
  5. Fornire le informazioni di contatto email.
  6. Fare clic su Avanti per continuare.
    • Internet: L'attivazione è automatica.
    • Email: Fare clic su Salva per creare un file di richiesta, quindi inviare il file all'indirizzo activation@solidworks.com. Quando si riceve l'email con il file di risposta, estrarre il file e fare clic su Apri per caricarlo.
      Se necessario, è possibile uscire e ripetere la procedura di attivazione per aprire il file della risposta.
  7. Fare clic su Fine.
Argomento principale: Amministrazione di licenze individuali


Trasferimento di una licenza

Per trasferire una licenza a un componente nuovo o aggiornato, trasferire prima la licenza sul server chiavi di licenza di Dassault Systèmes SolidWorks Corporation, quindi riattivarla sull'altro computer.

Nel caso non sia stato possibile trasferire la licenza a Dassault Systèmes SolidWorks Corporation (a causa di un difetto dell'unità rigida, per esempio), la riattivazione avverrà comunque nella maggior parte dei casi. In caso contrario, contattare il proprio rivenditore autorizzato per assistenza.

Per trasferire una licenza al server:

  1. In SolidWorks, fare clic su ? > Trasferimento licenze e attenersi alle istruzioni.
  2. Per riattivare, passare al computer nuovo o aggiornato e attivare la licenza come per l'attivazione iniziale. Per i dettagli, vedere Attivazione di una licenza.
Argomento principale: Amministrazione di licenze individuali


Amministrazione delle licenze mediante SolidNetWork License Manager

SolidNetWork License Manager supporta più client di licenza con la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

Questa immagine raffigura una tipica installazione di licenze SolidNetWork:

Questa immagine illustra:
  • Il software del Gestore di licenze Licenza SolidNetWork viene installato e attivato solamente sul componente del gestore di licenze.
  • I computer client di licenza non possiedono altro software specifico SolidNetWork.

    Se si specifica un numero seriale di licenza SolidNetWork all'installazione, la Gestione installazioni di SolidWorks identifica tale computer come un client di licenza SolidNetWork. La Gestione installazioni di SolidWorks invita a specificare il nome del computer del SolidNetWork License Manager e il numero di porta per connettere il client al gestore di licenze.

  • Il gestore di licenze e tutti i client di licenza devono avere connettività TCP/IP.
  • Attivazione di una licenza SolidNetWork
    Prima che gli utenti possano eseguire prodotti SolidWorks sui loro computer, è necessario attivare una licenza SolidNetWork sul computer del SolidNetWork License Manager.
  • Trasferimento di una licenza SolidNetWork
    Per trasferire una licenza SolidNetWork a un componente nuovo o aggiornato, trasferire prima la licenza sul server chiavi di licenza di Dassault Systèmes SolidWorks Corporation, quindi riattivarla sull'altro computer.
  • Installazione e configurazione delle licenze SolidNetWork
    La configurazione delle licenze SolidNetWork implica l'installazione del gestore di licenze SolidNetWork sul computer destinato a gestore di licenze e quindi l'installazione di SolidWorks sui computer client mediante il numero seriale della licenza SolidNetWork.
  • Amministrazione delle licenze SolidNetWork
    Le operazioni comprendono" riavvio, aggiornamento e disinstallazione del gestore di licenze, nonché recupero, presa in prestito e restituzione delle licenze.
Argomento principale: Amministrazione delle licenze


Attivazione di una licenza SolidNetWork

Prima che gli utenti possano eseguire prodotti SolidWorks sui loro computer, è necessario attivare una licenza SolidNetWork sul computer del SolidNetWork License Manager.

L'attivazione richiede l'accesso ad Internet o all'email. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • Attivare SolidNetWork License Manager per SolidWorks con le licenze valide per più prodotti SolidWorks.
  • Consente di trasferire i diritti di licenza SolidNetWork da un computer del SolidNetWork License Manager a un altro.
  • Consente di installare e attivare i diritti di licenza SolidNetWork su un computer del SolidNetWork License Manager.
  • Da eseguire prima di utilizzare le licenze SolidNetWork.
  • Elimina il bisogno dei dispositivi di sicurezza. Se si attiva una licenza SolidNetWork per questa versione di SolidWorks, le vengono attivate le licenze SolidNetWork per le versioni precedenti di SolidWorks. (Non è più necessario conservare il dispositivo di sicurezza.)

Per attivare una licenza SolidNetWork:

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Se non si è ancora attivata la licenza SolidNetWork, un messaggio chiede se lo si desidera fare ora. Fare clic su Sì per attivare.
  3. Sotto Come eseguire l'attivazione?, selezionare Automaticamente su Internet (consigliato).
  4. Sotto Informazioni di contatto, specificare un indirizzo email.
La finestra di dialogo Attivazione/Nuova attivazione riuscita mostra i prodotti attivati con successo.
Argomento principale: Amministrazione delle licenze mediante SolidNetWork License Manager


Trasferimento di una licenza SolidNetWork

Per trasferire una licenza SolidNetWork a un componente nuovo o aggiornato, trasferire prima la licenza sul server chiavi di licenza di Dassault Systèmes SolidWorks Corporation, quindi riattivarla sull'altro computer.

Nel caso non sia stato possibile trasferire la licenza a Dassault Systèmes SolidWorks Corporation (a causa di un difetto dell'unità rigida, per esempio), la riattivazione avverrà comunque nella maggior parte dei casi. In caso contrario, contattare il proprio rivenditore autorizzato per assistenza.

Per ritrasferire una licenza SolidNetWork al server:

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.

  2. In Informazioni sulla licenza, fare clic su Modifica. Si avvia la procedura guidata Attivazione del prodotto SolidWorks.
  3. In Che cosa vuoi fare?, selezionare Trasferire una licenza software e fare clic su Avanti.
  4. In Come eseguire il trasferimento?, selezionare Automaticamente su Internet (consigliato).
  5. Sotto Informazioni di contatto, specificare un indirizzo email.
  6. Fare clic su Avanti. La licenza del prodotto viene trasferita.
Argomento principale: Amministrazione delle licenze mediante SolidNetWork License Manager


Installazione e configurazione delle licenze SolidNetWork

La configurazione delle licenze SolidNetWork implica l'installazione del gestore di licenze SolidNetWork sul computer destinato a gestore di licenze e quindi l'installazione di SolidWorks sui computer client mediante il numero seriale della licenza SolidNetWork.

  • Installazione e attivazione di un gestore di licenze
    Il Gestore di licenze SolidNetWork supporta molteplici client di licenza. Distribuisce le licenze ai client in rete.
  • Installazione di un client di licenza
    Quando si installa SolidWorks su un computer client di licenza SolidNetWork, il numero seriale identifica tale computer come client di licenza SolidNetWork.
  • Installare i gestori di licenze SolidNetWork prima dei client di licenza
    Si consiglia di installare e configurare il Gestore di licenze SolidNetWork su almeno un computer prima di installare uno dei computer client di licenza SolidNetWork.
  • Installazione del Gestore di licenze a terna
    La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.
  • Uso di licenze SolidNetWork con i firewall
    Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.
Argomento principale: Amministrazione delle licenze mediante SolidNetWork License Manager


Installazione e attivazione di un gestore di licenze

Il Gestore di licenze SolidNetWork supporta molteplici client di licenza. Distribuisce le licenze ai client in rete.

Se si intende aggiornare da una versione precedente di SolidNetWork License Manager che usava i dongle per l'hardware per l'attivazione delle licenze, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager.

  1. Avviare la Gestione installazioni SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
    1. Come tipo di installazione, selezionare:

      • Prodotti server
      • Installare SolidNetWork License Manager (licenze distribuite) su questo computer.

    2. Nella pagina Opzioni di SolidNetWork License Manager, specificare il numero seriale della licenza di SolidNetWork e la posizione di installazione di SolidNetWork License Manager.
    3. Nella pagina Sintesi, fare clic su Installa ora per completare la procedura.
  2. Per attivare le licenze SolidNetWork:
    1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Quando un messaggio invita ad attivare, fare clic su Sì.
    3. Nella schermata Informazioni sul server di licenza SolidNetWork:

      • se la propria azienda usa un firewall, selezionare Un firewall è in uso su questo server.

        Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

      • Lasciare il valore di default per Numero porta (e per Numero porta Daemon venditore se è attivo un firewall) o digitare i numeri di porta utilizzati dall'azienda.
        Il numero della porta è un numero TCP/IP nel range 1024 - 60000 che non può essere usato da altri processi. In genere, il numero di default 25734 è adatto e con tutta probabilità sarà diverso da quello di un a qualsiasi altro processo di server FLEXnet attualmente in esecuzione sul computer di gestione delle licenze.

    4. Nella schermata Attivare il prodotto SolidWorks:

      • Selezionare la procedura via internet o email.
      • Fornire le informazioni di contatto email.
      • Fare clic su Avanti per continuare.
        • Internet: L'attivazione è automatica.
        • Email: Premere Salva per creare un file di richiesta, quindi inviarlo ad activation@solidworks.com. Quando si riceve una mail con il file di risposta, estrarre il file e fare clic su Apri per caricarlo.
          Se necessario, è possibile uscire e ripetere la procedura di attivazione per aprire il file della risposta.

  3. Fare clic su Fine.
Argomento principale: Installazione e configurazione delle licenze SolidNetWork


Installazione di un client di licenza

Quando si installa SolidWorks su un computer client di licenza SolidNetWork, il numero seriale identifica tale computer come client di licenza SolidNetWork.

  1. Avviare la Gestione installazioni di SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
  2. Nella schermata di benvenuto, fare clic su Individuale (su questo computer) se questa è la prima installazione di SolidWorks su questo computer per questa release maggiore.

    Se si aggiorna da una release esistente e si cambia da una licenza individuale alla licenza SolidNetWork, fare clic su Modificare l'installazione individuale esistente (su questo computer). Per i dettagli, vedere Aggiornamento da licenze individuali a licenze SolidNetWork.

  3. Quando viene richiesto il numero seriale, immettere il numero seriale della licenza SolidNetWork.
  4. Nella finestra di dialogo Aggiungi server, digitare l'indirizzo del SolidNetWork License Manager nel formato:

    porta@NomeComputer

    Il numero della porta deve essere identico a quello utilizzato per il computer del gestore di licenze. L'impostazione di default è 25734 (come descritto in Installazione e attivazione di un gestore di licenze).

    La Gestione installazioni di SolidWorks tenterà di confermare che questo SolidNetWork License Manager è accessibile. Se non si è ancora installato un gestore di licenze, questa autenticazione non andrà a buon fine ma si potrà comunque procedere con l'installazione del client di licenza.

  5. Completare l'installazione di SolidWorks attenendosi alle istruzioni della Gestione installazioni di SolidWorks.
Argomento principale: Installazione e configurazione delle licenze SolidNetWork


Installare i gestori di licenze SolidNetWork prima dei client di licenza

Si consiglia di installare e configurare il Gestore di licenze SolidNetWork su almeno un computer prima di installare uno dei computer client di licenza SolidNetWork.

Quando si installa mediante un numero seriale della licenza SolidNetWork, la Gestione installazioni di SolidWorks invita a specificare il nome e il numero di porta del computer del gestore di licenze SolidNetWork e quindi tenta di autenticare tali informazioni.

Se non si è installato il Gestore di licenze SolidNetWork sul computer specificato, l'autenticazione non riuscirà. In questo caso, tuttavia, una mancata autenticazione non indica se le informazioni fornite sul gestore di licenze siano corrette. Se il gestore di licenze è installato, la mancata autenticazione indica che sono state fornite informazioni inesatte sul gestore di licenze.

Argomento principale: Installazione e configurazione delle licenze SolidNetWork


Installazione del Gestore di licenze a terna

La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.

Requisiti per l'uso di gestori di licenze a terna:
  • Sono necessari tre dispositivi di sicurezza hardware.
  • Installare i gestori di licenze a terna su computer stabili non programmati per spegnimenti frequenti.
  • I tre computer dei gestori di licenze devono essere sulla stessa sottorete. Non configurare mai i gestori di licenze a terna con comunicazioni lente o con connessione remota.
  • L'amministratore di sistema deve intervenire immediatamente qualora un computer del gestore di licenze si porti fuori linea per riavviarlo non appena possibile.
    Se sono in esecuzione solo due computer del gestore di licenze, la situazione è peggiore rispetto al caso in cui è in esecuzione un solo computer del gestore di licenza perché le probabilità di guasto raddoppiano.
  • Installazione del gestore di licenze a terna iniziale
    La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.
  • Installazione del gestore di licenze a terna su altri computer
    La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Questa procedura dimostra come installare SolidNetWork License Manager su un secondo e terzo computer della terna.
Argomento principale: Installazione e configurazione delle licenze SolidNetWork


Installazione del gestore di licenze a terna iniziale

La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.

  1. Sul primo computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni di SolidWorks:
    1. Avviare la Gestione installazioni di SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
    2. Come tipo di installazione, selezionare:

      • Prodotti server
      • Installare SolidNetWork License Manager (licenze distribuite) su questo computer.

    3. Nella pagina Opzioni di SolidNetWork License Manager, specificare il numero seriale della licenza di SolidNetWork e la posizione di installazione di SolidNetWork License Manager.
    4. Nella pagina Sintesi, fare clic su Installa ora per completare la procedura.
  2. Utilizzando SolidNetWork License Manager, configurare il computer di gestione licenze iniziale della terna:
    1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
    2. Fare clic su No.

      Si apre la scheda Amministrazione del server del SolidNetWork License Manager.

    3. Sotto Opzioni avanzate, fare clic su Opzioni.

      Si visualizza la finestra di dialogo Opzioni avanzate.

    4. Sotto Modalità server di licenza SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.

      La finestra di dialogo Opzioni avanzate si chiude.

    5. In Informazioni sulla licenza, fare clic su Modifica.

      Compare la Creazione guidata del file di licenza SolidNetWork.

    6. In Tipo di server, selezionare Terna e fare clic su Avanti.
    7. Nel riquadro Informazioni sul server, verificare che il nome del computer, l'ID del dispositivo di sicurezza e il numero di porta del computer iniziale del gestore di licenze a terna siano corretti e fare clic su Avanti.

      Se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

    8. Nella schermata Informazioni sul server del Partner a terna, immettere il nome del computer e l'ID della chiave hardware degli altri due computer di gestione licenza della terna.

      Ciò assicura che qualora un server non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.

    9. Nella schermata Licenze, fare clic su Leggi per individuare e aprire il file di licenza SolidNetWork.

      Le licenze appaiono nella Creazione guidata del file di licenza SolidNetWork.

    10. Fare clic su Fine.
    11. Fare clic su OK per chiudere la Creazione guidata del file di licenza e quindi su Fine per uscire dal SolidNetWork License Manager.
Argomento principale: Installazione del Gestore di licenze a terna


Installazione del gestore di licenze a terna su altri computer

La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Questa procedura dimostra come installare SolidNetWork License Manager su un secondo e terzo computer della terna.

Il presupposto di partenza è che si sia già installato almeno un gestore di licenze a terna su un altro computer. Per i dettagli, vedere Installazione del gestore di licenze a terna iniziale.

  1. Sul computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni di SolidWorks:
    1. Avviare la Gestione installazioni di SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
    2. Come tipo di installazione, selezionare:

      • Prodotti server
      • Installare SolidNetWork License Manager (licenze distribuite) su questo computer.

    3. Nella pagina Opzioni di SolidNetWork License Manager, specificare il numero seriale della licenza di SolidNetWork e la posizione di installazione di SolidNetWork License Manager.
    4. Nella pagina Sintesi, fare clic su Installa ora per completare la procedura.
  2. Utilizzando SolidNetWork License Manager, configurare il computer del gestore di licenze a terna:
    1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.

      Dato che si tratta della prima volta che SolidNetWork License Manager viene eseguito su questo computer, un messaggio chiede se si desidera attivare ora.

    2. Fare clic su No.

      Si apre la scheda Amministrazione del server del SolidNetWork License Manager.

    3. Sotto Opzioni avanzate, fare clic su Opzioni.

      Si visualizza la finestra di dialogo Opzioni avanzate.

    4. Sotto Modalità server di licenza SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.

      La finestra di dialogo Opzioni avanzate si chiude.

    5. In Informazioni sulla licenza, fare clic su Modifica.

      Compare la Creazione guidata del file di licenza SolidNetWork.

    6. Sotto Tipo di server, selezionare Terna e Sincronizza delle informazioni su server/licenza e fare clic su Avanti.
    7. Nel riquadro Informazioni sul server, verificare che il nome del computer, l'ID del dispositivo di sicurezza e il numero di porta di questo computer del gestore di licenze a terna siano corretti e fare clic su Avanti.

      Se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

    8. Nella schermata Informazioni sul server del Partner a terna, immettere il nome del computer e l'ID della chiave hardware degli altri due computer di gestione licenza della terna.

      Ciò assicura che qualora un server non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.

    9. Nella schermata Licenze, fare clic su Leggi per individuare e aprire il file di licenza SolidNetWork.

      Solitamente, il file di licenza risiede in \licenses\sw_d.lic sul primo computer del gestore di licenze a terna configurato.

      Le licenze appaiono nella Creazione guidata del file di licenza SolidNetWork.

    10. Fare clic su Fine.

      Compare un'avvertenza della Creazione guidata del file di licenza SolidNetWork.

    11. Fare clic su OK per chiudere la Creazione guidata del file di licenza e quindi su Fine per uscire dal SolidNetWork License Manager.

Se si configura il secondo computer del gestore di licenze a terna, ripetere questa procedura per il terzo computer del gestore di licenze a terna.

Argomento principale: Installazione del Gestore di licenze a terna


Uso di licenze SolidNetWork con i firewall

Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.

Nel software del firewall, aggiungere due porte di licenza SolidNetWork (es. SNL-in-port e SNL-out-port) all'elenco di eccezioni del firewall. Per i dettagli sulla configurazione di queste porte, consultare l'amministratore del sistema.

Se si utilizza Windows Firewall su Windows XP SP2 o Windows Server 2003 SP1, è necessario modificare le porte sul computer del gestore di licenze SolidNetWork e modificare il file di licenza SolidNetWork per distribuire le licenze ai computer client.

  • Modifica delle porte computer del gestore di licenze per Windows Firewall
    Se si utilizza Windows Firewall, è necessario modificare le impostazioni della porta firewall sul computer del SolidNetWork License Manager.
  • Modifica delle impostazioni del SolidNetWork License Manager per Windows Firewall
    Se si utilizza Windows Firewall, è necessario modificare il file di licenza SolidNetWork in modo che utilizzi le porte del firewall per distribuire le licenze ai computer client.
Argomento principale: Installazione e configurazione delle licenze SolidNetWork


Modifica delle porte computer del gestore di licenze per Windows Firewall

Se si utilizza Windows Firewall, è necessario modificare le impostazioni della porta firewall sul computer del SolidNetWork License Manager.

  1. In Windows, aprire il Pannello di controllo e fare doppio clic su Centro di sicurezza.
  2. Fare clic su Windows Firewall.
  3. Nella scheda Eccezioni fare clic su Aggiungi porta.
  4. Digitare un Nome (es. SNL-in-port) e un Numero porta (es. 25734) e fare clic su OK.
  5. Per la seconda porta, fare clic su Aggiungi porta nella scheda Eccezioni, specificare il nome e il numero dell'altra porta (es. SNL-out-port e 25735) e fare clic su OK. Annotare il numero di porta, perché servirà in futuro per la modifica del file di licenza SolidNetWork.

    Se si utilizza Workgroup PDM, è necessario modificare i numeri di porta Workgroup PDM in Windows Firewall. Solitamente, queste porte sono 20000 (VaultAdmin), 30000 (Dati), 40000 (Richiesta) e 80 (Visualizzatore).

  6. Chiudere il Centro di sicurezza Windows e il Pannello di controllo.
Argomento principale: Uso di licenze SolidNetWork con i firewall


Modifica delle impostazioni del SolidNetWork License Manager per Windows Firewall

Se si utilizza Windows Firewall, è necessario modificare il file di licenza SolidNetWork in modo che utilizzi le porte del firewall per distribuire le licenze ai computer client.

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Nella scheda Amministrazione del server, in Server della licenza, fare clic su Ferma. (Fare clic su Sì quando un messaggio invita a confermare e su OK per arrestare il server di licenza.)
  3. In Informazioni sulla licenza, fare clic su Modifica.
  4. In Tipo di server, selezionare la disposizione dei server in rete (Singolo o Terna) e fare clic su Avanti.
  5. In Informazioni server:
    1. Selezionare Un firewall è in uso su questo server.
    2. Numero porta e Numero porta Daemon venditore dovrebbero contenere i numeri di porta specificati per Windows Firewall (per i dettagli, vedere Modifica delle porte computer del gestore di licenze per Windows Firewall).
    3. Fare clic su Avanti, quindi su Fine.
  6. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Inizia.
  7. Fare clic su OK per chiudere il SolidNetWork License Manager.
Argomento principale: Uso di licenze SolidNetWork con i firewall


Amministrazione delle licenze SolidNetWork

Le operazioni comprendono" riavvio, aggiornamento e disinstallazione del gestore di licenze, nonché recupero, presa in prestito e restituzione delle licenze.

  • Avvio del SolidNetWork License Manager
    È possibile avviare SolidNetWork License Manager dal menu Start di Windows.
  • Aggiornamento del SolidNetWork License Manager
    Per le release maggiori di SolidWorks, l'aggiornamento del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di quello nuovo e la riattivazione della licenza SolidNetWork.
  • Eliminazione dei file di licenza SolidNetWork
    Cancellare i file di licenza SolidNetWork precedenti e scaduti prima di aggiornare a quelli nuovi.
  • Recupero delle licenze client
    Per terminare la connessione SolidNetWork di un client, un amministratore di sistema può interrompere la licenza e restituirla al gruppo di licenze disponibili.
  • Presa in prestito e restituzione di licenze SolidNetWork
    Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.
  • Monitoraggio del tempo di inattività di una licenza
    SolidWorks può registrare il tempo di inattività con il Gestore di licenze SolidNetWork, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.
  • Installazione di licenze temporanee
    La licenza temporanea "ANY" può essere utilizzata provvisoriamente quando la licenza SolidNetWork originale non è disponibile.
  • Aggiornamento da licenze individuali a licenze SolidNetWork
    È possibile aggiornare un computer dalla modalità di licenza SolidWorks individuale alle licenze SolidNetWork specificando il numero seriale della licenza SolidNetWork nella Gestione installazioni di SolidWorks.
  • Uso delle licenze SolidNetWork con prodotti aggiuntivi
    È possibile utilizzare il Gestore di licenze SolidNetWork per distribuire le licenze di prodotti aggiuntivi principali di SolidWorks (come FeatureWorks, Workgroup PDM Server, ecc.).
  • Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
    È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SolidWorks.
  • Gestione delle licenze con FLEXnet Publisher
    Le licenze SolidNetWork si basano sulla gestione delle licenze con FLEXnet Publisher®.
Argomento principale: Amministrazione delle licenze mediante SolidNetWork License Manager


Avvio del SolidNetWork License Manager

È possibile avviare SolidNetWork License Manager dal menu Start di Windows.

  • In Windows, eseguire questo comando: Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
Argomento principale: Amministrazione delle licenze SolidNetWork


Aggiornamento del SolidNetWork License Manager

Per le release maggiori di SolidWorks, l'aggiornamento del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di quello nuovo e la riattivazione della licenza SolidNetWork.

Il gestore di licenze di una release più recente può distribuire licenze ai computer client che non aggiornano ma restano alla release precedente.

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Nella scheda Utilizzo della licenza, verificare che nessun client in rete abbia in esecuzione SolidWorks.
  3. Disinstallare la vecchia gestione licenze. Per i dettagli, vedere Disinstallazione di SolidNetWork License Manager.
  4. Installare il nuovo gestore di licenze e riattivare la licenza SolidNetWork sul computer del gestore di licenze. Per i dettagli, vedere Installazione e attivazione di un gestore di licenze.

Se si aggiorna SolidNetWork License Manager su un computer che esegue anche l'applicazione SolidWorks, aggiornare prima i gestori di licenze SolidNetWork ed i client e solo successivamente installare su tale computer eventuali Service Pack di SolidWorks.

Se si aggiorna il gestore di licenze su un computer che ospita immagini amministrative, aggiornare il gestore di licenze prima delle immagini amministrative. Per i dettagli, vedere Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa.

  • Disinstallazione di SolidNetWork License Manager
    Quando si aggiorna il Gestore di licenze SolidNetWork, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.
Argomento principale: Amministrazione delle licenze SolidNetWork


Disinstallazione di SolidNetWork License Manager

Quando si aggiorna il Gestore di licenze SolidNetWork, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.

  1. Avviare SolidNetwork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Verificare che nessun client in rete abbia in esecuzione SolidWorks.

    La scheda Uso della licenza mostra i client con SolidWorks in esecuzione.

  3. Se si intende trasferire la licenza SolidWorks su un altro computer, trasferirla prima di rimuovere il Gestore di licenze SolidWorks da questo computer.

    Per informazioni sul trasferimento di licenze SolidNetWork, vedere Trasferimento di una licenza SolidNetWork.

  4. Nella scheda Amministrazione del server, in Server della licenza, fare clic su Ferma.
  5. Fare clic su OK per uscire dal gestore di licenze.
  6. In Windows, selezionare Pannello di controllo > Installazione applicazioni.
  7. Selezionare Gestore di licenze SolidNetWork per SolidWorks, fare clic su Rimuovi e confermare l'eliminazione.
  8. In Esplora risorse, cancellare la cartella Gestore di licenze SolidNetWork per SolidWorks.

    Di solito questa cartella si trova in Program Files nella directory di installazione di SolidWorks.

È ora possibile procedere ad installare una nuova versione del gestore di licenze. Per i dettagli, vedere Installazione e attivazione di un gestore di licenze.

Se il computer di SolidNetwork License Manager ha un dongle hardware allegato, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager.
Argomento principale: Aggiornamento del SolidNetWork License Manager


Eliminazione dei file di licenza SolidNetWork

Cancellare i file di licenza SolidNetWork precedenti e scaduti prima di aggiornare a quelli nuovi.

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Nella scheda Amministrazione del server, in File di licenza, fare clic su Modifica, quindi su Avanti fino a raggiungere la schermata Licenze.
  3. Nella schermata Licenze, selezionare il file di licenza SolidNetWork vecchio o scaduto, quindi fare clic su Rimuovi.
  4. Fare clic su Fine, quindi su OK.
Argomento principale: Amministrazione delle licenze SolidNetWork


Recupero delle licenze client

Per terminare la connessione SolidNetWork di un client, un amministratore di sistema può interrompere la licenza e restituirla al gruppo di licenze disponibili.

  • Il client deve essere connesso al gestore di licenze per almeno due minuti.
  • È possibile configurare la scadenza SolidNetWork con un intervallo minimo di 15 minuti. Trascorsi 15 minuti di inattività, la licenza viene restituita al gruppo di licenze disponibili.

Per ulteriori informazioni, vedere directory_installazione_Gestore_licenze_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

  1. Fare clic su Start > Esegui, digitare cmd e fare clic su OK per aprire una finestra comandi Windows.
  2. Nella finestra comandi, digitare:

    cd directory_installazione_Gestore_licenze_SolidNetWork\utils lmutil lmremove funzione utente computer visualizzazione

    dove funzione, utente, computer e visualizzazione sono termini provenienti dalla scheda Uso della licenza del Gestore di licenze SolidNetWork.

    Ad esempio:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    È necessario terminare la licenza di ogni prodotto aggiunto (PhotoView 360, FeatureWorks, ecc.) separatamente.

Argomento principale: Amministrazione delle licenze SolidNetWork


Presa in prestito e restituzione di licenze SolidNetWork

Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

Le licenze in prestito sono valide solo per il sistema sul quale sono state prese in prestito e non possono essere trasferite.

La licenza viene prestata per un periodo di tempo specificato, fino a 30 giorni, (o come definito dall'amministratore del sistema) e la licenza viene rimossa dal gruppo di licenze disponibili.

L'amministratore del sistema può personalizzare il prestito per:
  • definire gli utenti o i gruppi che possono prendere in prestito le licenze:
  • Impostare il numero di licenze che non possono essere prese in prestito

Per ulteriori informazioni, vedere directory_installazione_Gestore_licenze_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

  • Presa in prestito di licenze SolidNetWork
    Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota.
  • Restituzione di una licenza SolidNetWork presa in prestito
    Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.
Argomento principale: Amministrazione delle licenze SolidNetWork


Presa in prestito di licenze SolidNetWork

Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota.

È necessario essere connessi al SolidNetWork License Manager per prendere in prestito la licenza, ma non necessariamente per utilizzarla.

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Nella scheda Prestito della licenza:
    1. selezionare una data in Prestito fino al.
    2. Selezionare i prodotti da prendere in prestito quindi, fare clic su Prendere in prestito e fare clic su Sì per confermare.
    3. Fare clic su Aggiorna. La colonna Data di scadenza indica la data di ritorno delle licenze.
  3. Fare clic su OK.
Per eseguire SolidWorks, prendere in prestito una licenza SolidWorks. SolidWorks Professional e SolidWorks Premium permettono solo le aggiunte associate al pacchetto e non l'applicazione di SolidWorks.
Argomento principale: Presa in prestito e restituzione di licenze SolidNetWork


Restituzione di una licenza SolidNetWork presa in prestito

Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

  1. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Nella scheda Prestito della licenza:
    1. Selezionare i prodotti da restituire quindi fare clic su Ritorno e fare clic su Sì per confermare.
    2. Fare clic su Aggiorna. La colonna Data di scadenza si svuota, ad indicare che le licenze sono state riconsegnate.
  3. Fare clic su OK.
Non è necessario restituire le licenze dopo la data di scadenza. La licenza viene restituita al gruppo sul SolidNetWork License Manager a mezzanotte della data di scadenza e le applicazioni sul sistema remoto non funzioneranno più.
Argomento principale: Presa in prestito e restituzione di licenze SolidNetWork


Monitoraggio del tempo di inattività di una licenza

SolidWorks può registrare il tempo di inattività con il Gestore di licenze SolidNetWork, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.

  1. Nella directory di installazione del Gestore di licenze SolidNetWork, creare un file di testo:

    directory_installazione_Gestore_licenze_SolidNetWork\Licenses\sw_d.opt

  2. Aggiungere la seguente linea al file:

    TIMEOUTALL secondi

    dove secondi è un numero maggiore o uguale a 900 (15 minuti), il tempo minimo consentito.

Argomento principale: Amministrazione delle licenze SolidNetWork


Installazione di licenze temporanee

La licenza temporanea "ANY" può essere utilizzata provvisoriamente quando la licenza SolidNetWork originale non è disponibile.

Installando il file di licenza "ANY", si accetta di implementare il file di licenza tradizionale al momento della ricezione di una licenza SolidNetWork da Dassault Systèmes SolidWorks Corporation. La conformità con le limitazioni della licenza è necessaria.

Per installare una licenza "ANY":

  1. Gli utenti di SolidNetWork esistenti devono disinstallare il SolidNetWork License Manager ed eliminare la cartella di installazione. Per i dettagli, vedere Disinstallazione di SolidNetWork License Manager.
  2. Avviare la Gestione installazioni di SolidWorks (come descritto in Inizio dell'installazione di SolidWorks).
    1. Come tipo di installazione, selezionare:

      • Prodotti server
      • Installare SolidNetWork License Manager (licenze distribuite) su questo computer.

    2. Nella pagina Opzioni di SolidNetWork License Manager, specificare il numero seriale della licenza di SolidNetWork e la posizione di installazione di SolidNetWork License Manager.
    3. Nella pagina Sintesi, fare clic su Installa ora per completare la procedura.
  3. Avviare SolidNetWork License Manager (Start > Tutti i programmi > SolidWorks versione > SolidNetWork License Manager > SolidNetWork License Manager.
  4. Se un messaggio invita ad attivare, fare clic su No.

    Si apre la scheda Amministrazione del server del SolidNetWork License Manager.

  5. Sotto Opzioni avanzate, fare clic su Opzioni.

    Si visualizza la finestra di dialogo Opzioni avanzate.

  6. Sotto Modalità server di licenza SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.

    La finestra di dialogo Opzioni avanzate si chiude.

  7. In Informazioni sulla licenza, fare clic su Modifica.

    Compare la Creazione guidata del file di licenza SolidNetWork.

  8. In Tipo di server, selezionare Singolo e fare clic su Avanti.
  9. Se appare questo messaggio:

    Impossibile leggere il numero di ID del dispositivo di sicurezza.
    fare clic su Annulla.
    Appare automaticamente l'ID "ANY".
    Se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

  10. Continuare con l'installazione.
Argomento principale: Amministrazione delle licenze SolidNetWork


Aggiornamento da licenze individuali a licenze SolidNetWork

È possibile aggiornare un computer dalla modalità di licenza SolidWorks individuale alle licenze SolidNetWork specificando il numero seriale della licenza SolidNetWork nella Gestione installazioni di SolidWorks.

Se un computer non ha SolidWorks installato, è possibile specificare le licenze SolidNetWork inserendo il numero seriale SolidNetWork quando si esegue l'installazione con la Gestione installazioni di SolidWorks.

Se un computer ha già installato SolidWorks e si passa da un tipo di licenza individuale alle licenze SolidNetWork, è possibile modificare l'installazione del computer client e specificare il numero seriale della licenza SolidNetWork al posto di quello della licenza individuale quando si esegue la Gestione installazioni di SolidWorks. Per i dettagli, vedere Modifica di un'installazione.

Argomento principale: Amministrazione delle licenze SolidNetWork


Uso delle licenze SolidNetWork con prodotti aggiuntivi

È possibile utilizzare il Gestore di licenze SolidNetWork per distribuire le licenze di prodotti aggiuntivi principali di SolidWorks (come FeatureWorks, Workgroup PDM Server, ecc.).

  • Un numero equo di licenze del software SolidWorks e delle licenze aggiuntive SolidWorks non è necessario.
  • Per prelevare una licenza di un prodotto aggiuntivo, l'utente deve prima prelevare una licenza del software SolidWorks.
  • Per prendere in prestito una licenza di un prodotto aggiuntivo, è necessario prendere in prestito sia la licenza del software SolidWorks che la licenza del prodotto SolidWorks che comprende l'aggiunta. Ad esempio sarà necessario prendere in prestito o una licenza SolidWorks Professional o una SolidWorks Premium.
  • Per rilasciare la licenza di un prodotto aggiuntivo:
    • In SolidWorks, fare clic su Strumenti > Aggiunte e cancellare l'aggiunta.
    • Uscire da SolidWorks.
Argomento principale: Amministrazione delle licenze SolidNetWork


Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa

È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SolidWorks.

I computer client possono ottenere le licenze dal gestore di licenze e quindi installare SolidWorks dallo stesso computer.

Per realizzare questa configurazione, il gestore di licenze e l'immagine amministrativa devono essere installati sullo stesso computer. Installare il gestore di licenze per primo e successivamente creare e distribuire l'immagine amministrativa.
Per i dettagli, vedere:
  • Installazione e attivazione di un gestore di licenze
  • Distribuzione su più client
Argomento principale: Amministrazione delle licenze SolidNetWork


Gestione delle licenze con FLEXnet Publisher

Le licenze SolidNetWork si basano sulla gestione delle licenze con FLEXnet Publisher®.

Per ulteriori informazioni sulla gestione delle licenze con FLEXnet Publisher, vedere la Guida amministrativa di FLEXnet Publisher in directory_installazione_gestore_licenze_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Per le informazioni più recenti sulla gestione delle licenze con FLEXnet Publisher, contattare Acresso® Software.

Argomento principale: Amministrazione delle licenze SolidNetWork


Diagnostica

Consultare questi argomenti per risolvere i problemi di installazione.

  • File di registro della Gestione installazioni di SolidWorks
    I file di registro della Gestione installazioni di SolidWorks sono disponibili per assistere nella risoluzione dei problemi di installazione.
  • Cartella del download della Gestione installazioni di SolidWorks
    La Gestione installazioni di SolidWorks può scaricare i file di installazione necessari in una cartella specificata. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.
  • Diagnostica delle licenze SolidNetWork
    Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.
  • Diagnostica aggiornamenti
    Se si riscontrano problemi durante l'aggiornamento a una nuova release di SolidWorks, verificare se esiste una soluzione tra queste spiegazioni.


File di registro della Gestione installazioni di SolidWorks

I file di registro della Gestione installazioni di SolidWorks sono disponibili per assistere nella risoluzione dei problemi di installazione.

Questi file si trovano in una directory con altri file di registro relativi all'applicazione SolidWorks.
  • Per Windows Vista o versione successiva:

    C:\Users\nome utente\AppData\Roaming\SolidWorks\Installation Logs\versione installata

  • Per le versioni del sistema operativo precedenti a Vista:

    C:\Documents and Settings\nome utente\Application Data\SolidWorks\Installation Logs\versione_installata\

Per visualizzare la directory dei file di registro, potrebbe essere necessario configurare le opzioni della cartella Windows attivando Mostra file e cartelle nascosti.

Se i dati dell'applicazione sono su un'unità diversa da C:, regolare il percorso in maniera corrispondente.

Questa directory contiene il file SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.TXT, un registro generale delle operazioni svolte dalla Gestione installazioni di SolidWorks.

La sottodirectory Other Logs contiene registri di installazione con informazioni più dettagliate.

Argomento principale: Diagnostica


Cartella del download della Gestione installazioni di SolidWorks

La Gestione installazioni di SolidWorks può scaricare i file di installazione necessari in una cartella specificata. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.

  1. Come installare i file in questa cartella?
  2. Posso installare i file MSI manualmente da questa cartella usando msiexec o altra applicazione?
  3. Posso selezionare la stessa cartella del download per ogni versione che installo?
  4. Ho scaricato alcuni prodotti manualmente dal sito web di Dassault Systèmes SolidWorks Corporation. La Gestione installazioni di SolidWorks può installare questi file?
  5. Posso condividere i file che ho scaricato con altri utenti?
  6. Come posso scoprire quando una nuova versione di SolidWorks diventa disponibile?
  7. La Gestione installazioni di SolidWorks mostra solo le installazioni SW2006 o SW2007 e non la versione corrente.
  8. La Gestione installazioni di SolidWorks non mi permette di selezionare un altro Service Pack da installare.
  9. La Gestione installazioni di SolidWorks non riesce a scaricare i file.
  10. Non tutti i miei prodotti SolidWorks vengono aggiornati al service pack più recente, ma l'opzione Controllo aggiornamenti mi dice che ho la versione più recente?
  11. Posso copiare un dvd su una cartella del download?

Come installare i file in questa cartella?

Eseguire setup.exe. Potrebbe essere necessario scaricare alcuni file se viene seleziona l'installazione di elementi ancora non ancora scaricati.

Non eseguire l'installazione con msiexec (vedere sotto).

Inizio

Posso installare i file MSI manualmente da questa cartella usando msiexec o altra applicazione?

No. La Gestione installazioni di SolidWorks non scarica alcuni dei file richiesti all'esecuzione di msiexec.

Inizio

Posso selezionare la stessa cartella del download per ogni versione che installo?

Le cartelle di download riportano il nome della versione. A partire da SolidWorks 2010, la Gestione installazioni di SolidWorks crea automaticamente una sottocartella specifica per la versione nella cartella specificata.

Inizio

Ho scaricato alcuni prodotti manualmente dal sito web di Dassault Systèmes SolidWorks Corporation. La Gestione installazioni di SolidWorks può installare questi file?

Con SW2009, i file scaricati manualmente possono essere usati dalla Gestione installazioni di SolidWorks. Tuttavia, sarà meglio eseguire la Gestione installazioni di SolidWorks scegliendo l'opzione per scaricare i file. La Gestione installazioni di SolidWorks mostra quali file sono necessari in base a cosa si sta installando, fornendo i link per scaricare ogni file. Questa opzione può essere usata quando la pagina di download in essa contenuta non funziona (a causa di limitazioni sul download gestite da un server proxy).
Se Microsoft Internet Explorer invita a salvare o eseguire i file durante il download o l'installazione, scegliere sempre Salva.

Inizio

Posso condividere i file che ho scaricato con altri utenti?

Sì. A tale fine, scaricare in una cartella condivisa in rete. Ogni client potrà eseguire la Gestione installazioni di SolidWorks dalla cartella condivisa.

Non è necessario scaricare altro a meno che non si scelgano alcuni elementi non selezionati durante il download iniziale oppure se il computer che utilizza questo download per l'installazione ha requisiti diversi da quello utilizzato per il download.

Nel caso si effettui il download per conto di un altro utente ma non l'installazione, selezionare l'opzione Solo download durante l'installazione. Questa opzione consentirà di selezionare i prodotti a prescindere da ciò che è installato sul proprio sistema. Tuttavia, questa opzione non può essere usata per scaricare le patch o per creare le immagini amministrative.

Inizio

Come posso scoprire quando una nuova versione di SolidWorks diventa disponibile?

L'utente sarà informato di ciò nei seguenti casi:
  • Se si esegue Verifica aggiornamenti ( Start > Tutti i programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti)
  • Se si è attivato SolidWorks Background Downloader.
  • Se viene selezionata una versione installata di SolidWorks in Installazione applicazioni e viene scelto Cambia
  • Se viene eseguita una versione precedente della Gestione installazioni di SolidWorks (sldIM.exe) da una cartella di download
In questi casi, è possibile selezionare di scaricare la versione più recente. La Gestione installazioni di SolidWorks scaricherà ed eseguirà la propria versione più recente, non un altro file di installazione qualsiasi. Dopo l'esecuzione della versione più recente di Gestione installazioni di SolidWorks, selezionare un gruppo di azioni di installazione. La Gestione installazioni di SolidWorks determinerà quali file di installazione sono necessari (e non scaricati precedentemente) e offrirà di scaricare questi file.

Inizio

La Gestione installazioni di SolidWorks mostra solo le installazioni SW2006 o SW2007 e non la versione corrente.

La versione in esecuzione della Gestione installazioni di SolidWorks non è più supportata per la release corrente. Si possono scaricare solo i Service Pack per le versioni SW2006 e SW2007.

Inizio

La Gestione installazioni di SolidWorks non mi permette di selezionare un altro Service Pack da installare.

Ciò è intenzionale. Ogni versione della Gestione installazioni di SolidWorks è intesa per installare solamente una specifica versione dei prodotti SolidWorks. Per installare un altro Service Pack, eseguire la Gestione installazioni di SolidWorks di quella versione. Per trovare la versione più recente disponibile, vedere Quando posso sapere se una versione nuova di SolidWorks diventa disponibile?

Inizio

La Gestione installazioni di SolidWorks non riesce a scaricare i file.

Se i limiti del server proxy impediscono il download dei file, la Gestione installazioni di SolidWorks non potrà scaricare i file automaticamente.

Scaricare i file manualmente e installarli usando la Gestione installazioni di SolidWorks. Selezionare l'opzione nella Gestione installazioni di SolidWorks per scaricare file individuali (es. Esegui download manuale nella pagina Opzioni di download). In base alle selezioni del proprio prodotto e requisiti di sistema, apparirà una pagina web in una finestra separata che contiene i link per scaricare tutti i file necessari manualmente. Questi link sono identici a quelli forniti dal Portale clienti SolidWorks, ma non sarà necessario cercare i file.

Inizio

Non tutti i miei prodotti SolidWorks vengono aggiornati al service pack più recente, ma l'opzione Controllo aggiornamenti mi dice che ho la versione più recente?

Controllo aggiornamenti evidenzia se è stata installata (o è in esecuzione) la versione più recente della Gestione installazioni di SolidWorks.

Per aggiornare tutti i prodotti alla versione più recente, in Installazione applicazioni, selezionare la versione installata più recente di SolidWorks e fare clic su Cambia.

Inizio

Posso copiare un dvd su una cartella del download?

Sì ma le installazioni possono fallire a meno che non venga copiato l'intero contenuto di ogni dvd rilasciato per quella piattaforma (x86 o x64). La Gestione installazioni di SolidWorks cerca i file swdata*.id per determinare la versione. Se questi file non sono presenti, non riconoscerà alcuno dei file di installazione copiati e sarà necessario scaricarli.

Inizio

Argomento principale: Diagnostica


Diagnostica delle licenze SolidNetWork

Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.

  • Accesso ai file di registro della licenza SolidNetWork
    Nel caso di errore relativo alla licenza, la soluzione spesso è indicata nel file directory_installazione_Gestore_SNL\lmgrd.log.
  • Impossibile ottenere una licenza per SolidWorks. Impossibile connettere al server di licenza.
    Solitamente, il problema è causato da impostazioni errate della porta.
Argomento principale: Diagnostica


Accesso ai file di registro della licenza SolidNetWork

Nel caso di errore relativo alla licenza, la soluzione spesso è indicata nel file directory_installazione_Gestore_SNL\lmgrd.log.

Argomento principale: Diagnostica delle licenze SolidNetWork


Impossibile ottenere una licenza per SolidWorks. Impossibile connettere al server di licenza.

Solitamente, il problema è causato da impostazioni errate della porta.

  • Le impostazioni della porta tra il gestore di licenza SolidNetWork e il client di licenza potrebbero non corrispondere.
  • Altre impostazioni della porta per versioni multiple dei Gestori di licenze SolidNetWork potrebbero non essere state specificate.
Per i dettagli sulle impostazioni della porta per i gestori di licenze SolidNetWork ed i client, vedere Uso di licenze SolidNetWork con i firewall.
Argomento principale: Diagnostica delle licenze SolidNetWork


Diagnostica aggiornamenti

Se si riscontrano problemi durante l'aggiornamento a una nuova release di SolidWorks, verificare se esiste una soluzione tra queste spiegazioni.

  • Aggiornamento da un'origine spostata
    Quando viene installato SolidWorks, la Gestione installazioni di SolidWorks ricorda la posizione delle origini d'installazione (supporto disco, immagine disco in rete, ecc.). Il sistema presuppone che le origini siano disponibili nella stessa posizione al momento dell'aggiornamento.
Argomento principale: Diagnostica


Aggiornamento da un'origine spostata

Quando viene installato SolidWorks, la Gestione installazioni di SolidWorks ricorda la posizione delle origini d'installazione (supporto disco, immagine disco in rete, ecc.). Il sistema presuppone che le origini siano disponibili nella stessa posizione al momento dell'aggiornamento.

Se si sposta o elimina l'origine, o se ne cambia il supporto, la Gestione installazioni di SolidWorks genererà un messaggio di errore. Tuttavia, si potrà continuare ad aggiornare navigando ad un'altra posizione mantenendo tutti gli stessi file e la struttura delle cartelle.

Argomento principale: Diagnostica aggiornamenti


Guida dell'applicazione Gestione installazioni di SolidWorks

La Gestione installazioni di SolidWorks è un'applicazione che installa e aggiorna i prodotti SolidWorks.

La Gestione installazioni di SolidWorks può essere eseguita:
  • Da un DVD di SolidWorks o una cartella di origine condivisa o una di download (per l'installazione di una nuova versione)
  • Dal Pannello di controllo Installazione applicazioni (per modificare o rimuovere una versione esistente)
  • Mediante un controllo degli aggiornamenti automatico o manuale (per rilevare, scaricare, installare le nuove versioni)

Ogni versione di SolidWorks ha una versione della Gestione installazioni di SolidWorks specifica.

Per le versioni precedenti a SolidWorks 2008, usare la Gestione installazioni di SolidWorks 2007 o scaricare le versioni del prodotto manualmente dal sito web SolidWorks Support.
  • SolidWorks Background Downloader
    SolidWorks Background Downloader esegue automaticamente il download dei file con processi in background (ad esempio, quando è disponibile una nuova versione di Service Pack), consentendo pertanto all'utente di proseguire nel lavoro durante il download. Al termine del download, un messaggio invita a installare i file, posticipare l'installazione o annullarla.
  • Risultati di Verifica aggiornamenti
    Verifica aggiornamenti cerca le versioni successive di SolidWorks.
  • Ubicazione immagine amministrativa
    Specificare la posizione di installazione dell'immagine amministrativa.
  • Opzioni di download
    Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.
  • Opzioni di download dei file della Gestione installazioni di SolidWorks
    Si è scelto di scaricare una versione successiva della Gestione installazioni di SolidWorks. Usare questa schermata per specificare dove e come scaricare.
  • Download dei file di installazione del prodotto
    Specificare dove e come scaricare i file mancanti per il prodotto specificato.
  • Avanzamento del download
    La Gestione installazioni di SolidWorks scarica, verifica ed estrae tutti i file in parallelo durante questo processo.
  • Risultati del download
    Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.
  • Errori di installazione / Installazione annullata
    L'installazione ha riscontrato un errore o è stata annullata.
  • Installazione completata
    La Gestione installazioni di SolidWorks ha completato la procedura.
  • Ubicazione installazione
    Specificare le posizioni di installazione di SolidWorks.
  • Opzioni di aggiornamento
    Una o più precedenti versioni maggiori di SolidWorks sono attualmente installate su questo computer. Decidere se aggiornare la versione esistente più recente alla nuova o se creare una nuova installazione della nuova versione.
  • Avanzamento dell'installazione
    Questo schermo mostra l'avanzamento dell'installazione.
  • Tipo di installazione
    Specificare l'azione di installazione da eseguire, ad esempio creare una nuova installazione, modificare o riparare un'installazione esistente, creare un'immagine amministrativa, installare prodotti server amministrativi o scaricare i file senza installarli.
  • Installazione e gestione di computer multipli
    La Gestione installazioni di SolidWorks fornisce i seguenti strumenti per installare e gestire multipli computer SolidWorks.
  • Download manuale
    Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SolidWorks).
  • Versione più recente disponibile
    La Gestione installazioni ha identificato una versione più recente dei prodotti SolidWorks. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.
  • Nessuna nuova versione disponibile
    Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.
  • Processi rilevati
    La Gestione installazioni di SolidWorks ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.
  • Selezione prodotti
    Specificare i componenti di prodotto da installare modificare, scaricare o rimuovere.
  • Prodotti da scaricare
    Selezionare i prodotti SolidWorks da scaricare in un punto specifico.
  • Prodotti da riparare
    Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SolidWorks con i numeri di versione che potranno essere riparati da questa versione della Gestione installazioni di SolidWorks.
  • Numeri di seriali
    I numeri di seriali, trovati nella casella di distribuzione, associano il proprio computer con i prodotti SolidWorks acquistati.
  • Installazione del server
    I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.
  • SolidNetWork License Manager
    Specificare le opzioni di installazione per il prodotto server SolidNetWork License Manager.
  • Sintesi
    La Gestione installazioni di SolidWorks ha tutte le informazioni necessarie per completare l'installazione.
  • Avvertimenti di controllo sistema
    Controllo sistema segnala i problemi riscontrati che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SolidWorks.
  • Creazione guidata fori/Opzioni Toolbox
    Se è installato SolidWorks Toolbox, SolidWorks includerà una libreria standard di tipi di foro e minuteria.
  • Disinstalla prodotti
    Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questo schermo visualizzerà i prodotti SolidWorks (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni SolidWorks. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.
  • Opzioni del server di Workgroup PDM
    Specificare le opzioni di installazione per il prodotto server di SolidWorks Workgroup PDM.


SolidWorks Background Downloader

SolidWorks Background Downloader esegue automaticamente il download dei file con processi in background (ad esempio, quando è disponibile una nuova versione di Service Pack), consentendo pertanto all'utente di proseguire nel lavoro durante il download. Al termine del download, un messaggio invita a installare i file, posticipare l'installazione o annullarla.

SolidWorks Background Downloader è attivo di default quando si installa SolidWorks con la Gestione installazioni di SolidWorks.

Quando la Gestione installazioni di SolidWorks è in esecuzione, per un'installazione o un download, SolidWorks Background Downloader si sospende. Ad esempio, sospende il download in esecuzione o impedisce l'avvio dei nuovi download e non consente di modificare la cartella di download.

SolidWorks Background Downloader è attivo di default quando si installa SolidWorks. È possibile disattivare SolidWorks Background Download durante l'installazione di SolidWorks cambiando le Opzioni di download nella pagina Sintesi. (Deselezionare Utilizzare Background Downloader?.)

Quando è attivo, l'icona appare nella barra delle applicazioni di Windows:

Fare clic su questa icona per abilitare le seguenti operazioni:
  • Guida di Background Downloader
  • Pausa download
  • Riprendi download
  • Annulla download
  • Opzioni di installazione
  • Cambia posizione di download
  • Verifica aggiornamenti
  • Verifica automatica degli aggiornamenti
  • Download automatico degli aggiornamenti
  • Disattiva Background Downloader

Guida di Background Downloader

Aprire questo argomento su Background Downloader nella Guida d'installazione di SolidWorks.

Pausa/Riprendi download

Se è in esecuzione un download in background, fare clic su Pausa download per sospenderlo e poterlo riprendere successivamente selezionando Riprendi download.

Annulla download

Se il download è in esecuzione, arrestarlo ed eliminare tutti i file che Background Downloader ha già scaricato.
Non è possibile riprendere un download annullato.

Opzioni di installazione

Al termine del download, è possibile scegliere una delle seguenti opzioni:
  • Installa ora: installa i file scaricati.
  • Chiedi nuovamente in futuro: non installa i file scaricati ma imposta un promemoria d'installazione.
  • Cancella questo download: non installa i file scaricati e li elimina. (Utile se si è deciso che non si desidera più installare i file scaricati.)

Cambia posizione di download

Cambiare la posizione in cui sono memorizzati i file scaricati da Background Downloader.

Questa opzione non è disponibile mentre il download è in esecuzione o in pausa.

Verifica aggiornamenti

Eseguire Verifica aggiornamenti dalla Gestione installazioni di SolidWorks.

Verifica automatica degli aggiornamenti

Eseguire periodicamente Verifica aggiornamenti, che avvisa quando sono disponibili nuovi aggiornamenti.

Download automatico degli aggiornamenti

Eseguire periodicamente Verifica aggiornamenti per scaricare gli aggiornamenti non appena si rendano disponibili.

Disattivazione ed attivazione di SolidWorks Background Downloader

È possibile disattivare Background Downloader facendo clic sull'icona e selezionando Disattiva Background Downloader.

Per riattivare Background Downloader, fare clic su Start > Tutti i programmi > Gestione installazioni di SolidWorks > SolidWorks Background Downloader.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Risultati di Verifica aggiornamenti

Verifica aggiornamenti cerca le versioni successive di SolidWorks.

È possibile eseguire Verifica aggiornamenti manualmente:
  • In Windows, fare clic su Start > Tutti i programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti
  • In SolidWorks, fare clic su ? > Verifica aggiornamenti.
Verifica aggiornamenti non è disponibile su client installati da immagini amministrative.

Versione più recente disponibile

La Gestione installazioni di SolidWorks ha identificato una versione più recente dei prodotti SolidWorks. Si potrà aggiornare ad una versione più recente selezionando la Gestione installazioni di SolidWorks per quella versione.

Questa versione più recente può scaricare i file di installazione in base ai prodotti specificati nell'installazione. Inoltre, sarà possibile condividere i file scaricati con altri utenti che installano usando la Gestione installazioni di SolidWorks.

Questi download sono solo per uso con la Gestione installazioni di SolidWorks.
Queste opzioni sono disponibili:
  • nel caso di multiple versioni disponibili, è possibile selezionare una versione dall'elenco.
  • Per i dettagli circa questa versione, fare clic su Verifica cosa comprende questo aggiornamento.
Fare clic su Avanti per ottenere ed eseguire la versione selezionata della Gestione installazioni di SolidWorks.

Nessun nuovo download disponibile/Impossibile verificare nuove versioni

La Gestione installazioni di SolidWorks non ha trovato una versione più recente dei prodotti SolidWorks, probabilmente perché si sta installando la versione più recente disponibile o perché non è collegata al sito SolidWorks.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Ubicazione immagine amministrativa

Specificare la posizione di installazione dell'immagine amministrativa.

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine
La posizione della directory nella quale la Gestione installazioni di SolidWorks creerà la nuova immagine.
Questa posizione non può contenere un'immagine amministrativa esistente. L'immagine amministrativa deve essere contenuta in una cartella condivisibile per la distribuzione ai client.
Spazio stimato necessario per la creazione dell'immagine
Spazio aggiuntivo necessario per l'immagine amministrativa.
Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da
Questa è la directory dalla quale si installano i prodotti SolidWorks.
Questa opzione compare solo se si sceglie l'opzione Solo installazione. Per i dettagli, vedere Opzioni di download.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Opzioni di download

Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.

La Gestione installazioni di SolidWorks supporta la distribuzione elettronica del software (ESD). Se non s'intende installare SolidWorks da un DVD, si dovrà specificare l'origine dei prodotti SolidWorks in via di installazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella del download della Gestione installazioni di SolidWorks.

Che cosa s'intende realizzare?

Scegliere una delle seguenti opzioni:
Download e installa/Download e crea immagini
Al termine del download, la Gestione installazioni di SolidWorks installa i file scaricati.
Solo download. È possibile scaricare i file una sola volta e poi condividerli su più computer.
La Gestione installazioni di SolidWorks non esegue un'installazione al termine del download.

Di solito, si specifica questa opzione se si scaricano i file per configurare una serie di file da condividere su più computer.

Se si sceglie questa opzione, un messaggio invita a selezionare uno tra due gruppi di file per il download:
  • File per QUESTO computer: il download conterrà solamente i file mancanti dal gruppo di installazione attualmente presente su questo computer.
    Il download dovrebbe avere dimensioni minori perché contiene:
    • Solo i file dei prodotti selezionati nella pagina Selezione prodotti
    • Solo i file di prerequisito necessari al computer e non ancora installati

    Tuttavia se per l'installazione si tenta di utilizzare questo gruppo di file scaricati su un altro computer, alcuni file potrebbero mancare perché i file di installazione per un computer non sono sempre identici a quelli per un altro computer. Si possono utilizzare i file scaricati per l'installazione su un altro computer ma mentre la procedura è in corso potrebbero essere scaricati altri file per completare il gruppo di installazione su tale computer.

  • File da condividere con QUALSIASI computer: il download conterrà il gruppo completo dei file di installazione, da utilizzare per installare questa versione su qualsiasi computer.

    Questo download avrà grandi dimensioni perché contiene tutti i file da usare per installare questa versione di un prodotto su un computer qualsiasi.

    Se si specifica un gruppo limitato di prodotti da installare, questa opzione ignora tale specifica e scarica tutti i prodotti contenuti nella release.

    Il download conterrà tutti i file necessari per creare un'immagine amministrativa, non solo quelli per eseguire un'installazione individuale.

Installa solo/Crea solo immagine. Possiedo già tutti i file di installazione necessari.
La Gestione installazioni di SolidWorks non scarica i file ma utilizza quelli presenti nella directory selezionata.

Fare clic su Sfoglia per selezionare una posizione diversa. Ad esempio, è possibile navigare al DVD di installazione o ad una cartella di download, a patto che tale posizione contenga tutti i file necessari.

Nel caso di messaggio di errore circa la cartella non completa mentre si presumevano tutti i file di installazione presenti in quel punto, i potenziali motivi sono:
  • è stato selezionato un componente per l'installazione non scaricato precedentemente o è stato selezionato di default.
  • I file sono stati scaricati su un altro computer con un gruppo diverso di requisiti di sistema.
  • L'utente ha effettuato un'installazione client e ora sta creando un'immagine amministrativa che richiede un gruppo di file più ampio.

È possibile navigare a una cartella contenente tutti i file (es. il DVD) oppure selezionare una delle opzione di download.

Dove scaricare i file necessari?

La posizione della cartella di download.

In alcuni casi, questa opzione potrebbe essere visibile ma ombreggiata e quindi non selezionabile. Ad esempio, se è selezionato Installa solo, la Gestione installazioni di SolidWorks installerà tutti i file scaricati dalla directory specificata nell'opzione e non utilizzare una directory di download distinta.

Tutti i file devono essere scaricati nella stessa cartella del download, sia che siano stati scaricati o prelevati da una propria ubicazione.

Dimensione stimata del download

I tempi stimati del download e i requisiti di spazio su disco si basano sull'elenco completo dei componenti scelti, a prescindere che si tratti di un download nuovo o di uno esistente ripreso da una sessione precedente.

Ad esempio, se si riprende un download precedente la Gestione installazioni di SolidWorks elaborerà solo quei file che non sono stati ancora scaricati. I tempi del download potranno essere minori di quelli calcolati.

Se un file è stato scaricato nel download precedente, la sua dimensione non è inclusa nella stima. La stima potrebbe dunque essere superiore alla dimensione effettiva del download.

Come decidere cosa scaricare?

e può essere eseguito in due modi:
Eseguire il download manuale
In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SolidWorks.
Selezionando questa opzione è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SolidWorks. Questa pagina Web è personalizzata dalla Gestione installazioni di SolidWorks al fine di scaricare solamente i file necessari per completare l'installazione.
Velocizza i download usando una maggiore banda di rete
Il downloader utilizza un algoritmo per incrementare la velocità del download aumentando la banda di rete usata durante il download.

In alcuni casi, ciò può disturbare la prestazione di rete. Nel caso di difficoltà durante il download, questa opzione potrà non essere supportata dal server proxy. Provare ad azzerare l'opzione e tentare nuovamente il download. Per i dettagli, contattare il proprio amministratore di rete.

Questa opzione vale solo per i download automatici e non ha conseguenze sui download manuali.

Utilizzo di SolidWorks Background Downloader

È possibile utilizzare SolidWorks Background Downloader per completare il download o per scaricare i futuri Service Pack di SolidWorks quando diverranno disponibili.

SolidWorks Background Downloader può rilevare automaticamente la disponibilità di nuovi Service Pack e scaricarli in background, avvisando l'utente al termine del download quando i file sono pronti per l'installazione. Per i dettagli, vedere SolidWorks Background Downloader.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Opzioni di download dei file della Gestione installazioni di SolidWorks

Si è scelto di scaricare una versione successiva della Gestione installazioni di SolidWorks. Usare questa schermata per specificare dove e come scaricare.

Per le risposte alle domande relative alla cartella del download, vedere Cartella del download della Gestione installazioni di SolidWorks.

Questa schermata compare solo se si è verificato un problema con la cartella di download di default (es. se manca il diritto di scrittura o l'accesso di rete). Di solito, è sufficiente specificare una directory di download alternativa per continuare.

Directory del download

Navigare alla destinazione per i file della Gestione installazioni di SolidWorks.

Sono visualizzate la dimensione del download e la quantità di spazio necessaria. La quantità di spazio necessario comprende lo spazio extra per estrarre certi download e sarà maggiore della dimensione del download attuale.

Usare l'accelerazione del download

Se si sceglie questa opzione, il download utilizzerà un algoritmo per incrementare la velocità del download.

L'accelerazione del download aumenta la larghezza di banda e potrà disturbare la prestazione di rete. Controllare con il proprio amministratore di rete prima di attivare l'accelerazione del download.

Se l'accelerazione del download non è supportata dal server proxy, questa opzione sarà automaticamente disattivata.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Download dei file di installazione del prodotto

Specificare dove e come scaricare i file mancanti per il prodotto specificato.

La Gestione installazioni di SolidWorks scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

Uscendo da questa schermata verrà annullato il resto della sequenza di installazione.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione.

Directory del download

Navigare alla destinazione per i file scaricati.

Sono indicati la dimensione del download e lo spazio necessario. La quantità di spazio necessario comprende lo spazio per estrarre certi download e sarà maggiore della dimensione del download attuale.

Per le risposte alle domande relative alla cartella del download, vedere Cartella del download della Gestione installazioni di SolidWorks.

Opzioni di download

Velocizza i download usando una maggiore banda di rete
Il downloader utilizza un algoritmo per incrementare la velocità del download aumentando la banda di rete usata durante il download.

In alcuni casi, ciò può disturbare la prestazione di rete. Nel caso di difficoltà durante il download, questa opzione potrà non essere supportata dal server proxy. Provare ad azzerare l'opzione e tentare nuovamente il download. Per i dettagli, contattare il proprio amministratore di rete.

L'accelerazione del download aumenta la larghezza di banda e potrà disturbare la prestazione di rete. Controllare con il proprio amministratore di rete prima di attivare l'accelerazione del download.

Se l'accelerazione del download non è supportata dal server proxy, questa opzione potrebbe essere disattivata automaticamente.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Avanzamento del download

La Gestione installazioni di SolidWorks scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

Per annullare il download dopo l'avvio, fare clic su Annulla.

Se si annulla il download o se questo non riesce, uno schermo Download annullato o Problema di download indicherà quali download non sono stati completati e consentirà di riprendere la procedura o di chiudere l'applicazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella del download della Gestione installazioni di SolidWorks.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Risultati del download

Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.

Problema di download/Download annullato

Se appare il messaggio Problema di download, la Gestione installazioni di SolidWorks ha riscontrato problemi che hanno impedito il buon esito del download.

Se appare il messaggio Download annullato, l'utente ha annullato il download prima che fosse completato.

Per continuare:

Riprova/Riprendi download automatici
Per riprendere un download automatico dal punto in cui è stato annullato, selezionare questa opzione e fare clic su Riprova download o Riprendi download.
Scarica i file singolarmente in un browser web
In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SolidWorks.
Selezionando questa opzione è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SolidWorks. Questa pagina Web è personalizzata dalla Gestione installazioni di SolidWorks al fine di scaricare solamente i file necessari per completare l'installazione.

Download completo

La schermata Download completato appare quando termina il download se si è specificata l'opzione Solo download.

Fare clic su Fine per chiudere la Gestione installazioni di SolidWorks.

Non tentare di installare uno di questi prodotti manualmente. Utilizzare sempre la Gestione installazioni di SolidWorks per installare i file scaricati.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Errori di installazione / Installazione annullata

L'installazione ha riscontrato un errore o è stata annullata.

Se si verifica un errore o un annullamento:
  • i prodotti installati prima dell'errore o annullamento rimarranno nel computer.
  • Il prodotto in via di installazione al momento dell'annullamento viene riportato allo stato precedente, in modo che non ci siano installazioni parziali.
  • I prodotti restanti non sono installati o sono stati disinstallati. L'elenco è fornito in Non ancora tentato.

    Per riprendere l'installazione o la disinstallazione di questi prodotti, fare clic sui link forniti.

La Gestione installazioni di SolidWorks installa prima qualsiasi prerequisito non presente sul computer, come ad esempio .NET Framework. Quindi installa i prodotti selezionati in questo ordine:
  1. SolidWorks
  2. eDrawings
  3. Ricerca SolidWorks
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Recupero da un'installazione non riuscita o annullata
    Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.
  • Riparazione di un'installazione
    Nel caso di problemi con un Prodotto SolidWorks installato, usare la Gestione installazioni di SolidWorks per riparare l'installazione.
  • Come contattare il rivenditore SolidWorks
    Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SolidWorks con le informazioni raccolte da questo schermo. Potrebbe essere richiesto di fornire un file zip dei file di registro della Gestione installazioni di SolidWorks.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Recupero da un'installazione non riuscita o annullata

Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.

  1. Registrare il messaggio di errore e il codice del prodotto per l'installazione fallita, nel modo illustrato in Errori di installazione o Installazione annullata

    Se viene richiesto un file di origine e non si sta modificando un'installazione esistente di SolidWorks, l'installazione o il computer potrebbero essere danneggiati. Rivolgersi al proprio rivenditore SolidWorks.

  2. Riavviare il proprio computer.
  3. Per assicurare che nessun prodotto SolidWorks sia in esecuzione, in Windows premere i tasti Ctr+Alt+Canc per aprire il Task Manager.
  4. Nella scheda Processi, se qualsiasi dei seguenti processi appare in Nome immagine, selezionarlo e fare clic su Termina processo.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Se l'applicazione è già installata e si è tentato di modificarla o rimuoverla, provare a riparare l'installazione. Per i dettagli, vedere Riparazione di un'installazione.
  6. in Windows Vista o versione successiva, fare clic su Start > Pannello di controllo > Programmi e Funzioni. Per le versioni precedenti a Windows, fare clic su Start > Pannello di controllo > Installazione applicazioni.
  7. Selezionare la versione di SolidWorks che è fallita.

    Se non esiste una voce corrispondente alla versione di SolidWorks in via di installazione, ripetere la procedura di installazione.

  8. Procedere in uno dei modi seguenti:
    • Per riprovare, fare clic su Cambia e selezionare tutti i prodotti con installazione non riuscita o prodotti saltati durante l'installazione.

    • Per saltare l'installazione non riuscita, fare clic su Cambia e selezionare tutti i prodotti saltati durante l'installazione. Deselezionare il prodotto con installazione non riuscita.

    • Per abbandonare l'installazione, fare clic su Rimuovi e selezionare qualsiasi prodotto già installato.

    Ciò non ripristinerà la versione precedente di qualsiasi prodotto in via di aggiornamento.

Argomento principale: Errori di installazione / Installazione annullata


Come contattare il rivenditore SolidWorks

Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SolidWorks con le informazioni raccolte da questo schermo. Potrebbe essere richiesto di fornire un file zip dei file di registro della Gestione installazioni di SolidWorks.

  1. Identificare i file di registro:
    • Per le versioni del sistema operativo precedenti a Vista:

      C:\Documents and Settings\nome utente\Application Data\SolidWorks\Installation Logs\versione_installata\

    • Per Windows Vista o versione successiva:

      C:\Users\nome utente\AppData\Roaming\SolidWorks\Installation Logs\versione installata\

    Se non si trova la cartella, potrebbe essere nascosta. In Esplora risorse, fare clic su Strumenti > Opzioni di cartella. Nella scheda Visualizza, in Impostazioni avanzate, selezionare Mostra file e cartelle nascosti per File e cartelle nascosti.

  2. Comprimere l'intero contenuto di questa cartella, comprese le sottocartelle.
Argomento principale: Errori di installazione / Installazione annullata


Installazione completata

La Gestione installazioni di SolidWorks ha completato la procedura.

Potrebbero visualizzarsi una o più di queste opzioni.

Novità

Per le installazioni individuali, alla fine del processo di installazione, apparirà un documento che descriverà la nuova funzionalità in SolidWorks e i relativi prodotti aggiuntivi.

Per le installazioni dall'immagine amministrativa, il documento apparirà sui computer client al completamento dell'installazione.

Sondaggio

Inviate le vostre opinioni relative al processo di installazione rispondendo ad un breve sondaggio.

Unisciti al Programma Customer Experience Improvement di SolidWorks

Le informazioni di prestazione vengono inviate alla SolidWorks Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Selezionare una delle opzioni seguenti:
  • Sì, voglio unirmi
  • No, grazie
  • Sollecitami nuovamente in futuro
Per ulteriori informazioni, vedere il Sito web del Customer Experience Improvement Program.

La creazione dell'immagine amministrativa è completata

Ultimata la creazione dell'immagine amministrativa, è possibile fare clic su Personalizza immagine per eseguire l'Editor opzioni dell'immagine amministrativa.

Fare clic su Dimostra come installare questa immagine su un client per visualizzare le istruzioni sull'uso dell'Editor opzioni.

Per i dettagli sulla configurazione di un'immagine amministrativa con l'Editor opzioni, vedere Editor opzioni immagine amministrativa.

Fare clic su Personalizza immagine per avviare l'Editor opzioni dell'immagine amministrativa e personalizzare le impostazioni di questa immagine amministrativa.
È possibile avviare l'Editor opzioni successivamente facendo doppio clic su sldAdminOptionEditor.exe nella directory di installazione dell'immagine amministrativa.
  • Verifica degli aggiornamenti per SolidWorks
    È possibile utilizzare la Gestione installazioni di SolidWorks per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.
  • Pragramma Customer Experience Improvement di SolidWorks
    Quando si installa SolidWorks, è possibile indicare che si desidera inviare informazioni sulle prestazioni del prodotto a SolidWorks Corporation perché siano analizzate e consentano di migliorare il prodotto.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Verifica degli aggiornamenti per SolidWorks

È possibile utilizzare la Gestione installazioni di SolidWorks per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.

  1. Avviare la Gestione installazioni di SolidWorks effettuando una delle seguenti operazioni:

    • In SolidWorks, fare clic su ? > Verifica aggiornamenti.

    • In Windows, fare clic su Start > Programmi > Gestione installazioni di SolidWorks > Verifica aggiornamenti.

    La Gestione installazioni di SolidWorks indica se sono disponibili nuovi aggiornamenti.

  2. Se sono disponibili, scegliere se scaricarli ed installarli.
  3. Per abilitare il controllo periodico e automatico degli aggiornamenti, al termine della Gestione installazioni di SolidWorks selezionare Verifica aggiornamenti ogni __ giorni e specificare la frequenza dei controlli.
Argomento principale: Installazione completata


Pragramma Customer Experience Improvement di SolidWorks

Quando si installa SolidWorks, è possibile indicare che si desidera inviare informazioni sulle prestazioni del prodotto a SolidWorks Corporation perché siano analizzate e consentano di migliorare il prodotto.

SolidWorks utilizza questi dati per determinare le abitudini relative all'uso del prodotto e alla qualità. Il nostro obiettivo è quello di fornire la massima qualità nel prodotto e i log della prestazione vengono appunto utilizzati in questo processo.

Il processo è trasparente. Tutte le informazioni contenute nei file di registro sono riservate. Non vengono utilizzate per altri scopi e l'utente non sarà contattato.

Per ulteriori informazioni, vedere il Sito web del Customer Experience Improvement Program.

Argomento principale: Installazione completata


Ubicazione installazione

Specificare le posizioni di installazione di SolidWorks.

Per tutte installazioni tranne la creazione di un'immagine amministrativa, valgono queste opzioni:
Installa i prodotti selezionati in
La directory nella quale si installa SolidWorks.
Quando si aggiorna o di modifica un'installazione, tutti i file devono essere installati nella posizione esistente di tale installazione. In questo caso, non è possibile cambiare al posizione dell'installazione esistente di SolidWorks.
Spazio stimato necessario per l'installazione
Si tratta di spazio aggiuntivo necessario per i prodotti selezionati per l'installazione o la modifica.
Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti di installazione.
Installa da
La directory dalla quale si installa SolidWorks.
Questa opzione compare solo se si sceglie l'opzione Solo installazione. Per i dettagli, vedere Opzioni di download.
Rivolgersi all'amministratore del sistema prima di cambiare la posizione di installazione di SolidWorks.

Ubicazioni immagine amministrativa

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine
La posizione della directory nella quale la Gestione installazioni di SolidWorks creerà la nuova immagine.
Questa posizione non può contenere un'immagine amministrativa esistente.
Spazio stimato necessario per la creazione dell'immagine
Spazio aggiuntivo necessario per l'immagine amministrativa.
Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da
Questa è la directory dalla quale si installano i prodotti SolidWorks.
Questa opzione compare solo se si sceglie l'opzione Solo installazione. Per i dettagli, vedere Opzioni di download.
Ubicazione immagine esistente
Quando si aggiorna un'immagine amministrativa esistente, la Gestione installazioni di SolidWorks crea una nuova immagine in base alle impostazioni dell'immagine esistente. Questa immagine esistente non viene modificata. Indica la posizione dell'immagine originale specificata nella schermata Benvenuti.

Evitare l'uso di percorsi di directory specifici per la versione

Se si specifica un numero di versione in una directory di installazione (es. C:\Program Files\SolidWorks Corp\SolidWorks 2010\) e successivamente si aggiorna tale installazione a SolidWorks 2011, risulterà una directory di installazione per SolidWorks 2011 di nome SolidWorks 2010.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Opzioni di aggiornamento

Una o più precedenti versioni maggiori di SolidWorks sono attualmente installate su questo computer. Decidere se aggiornare la versione esistente più recente alla nuova o se creare una nuova installazione della nuova versione.

Questa scelta appare solo se non esistono versioni precedenti di questa release maggiore su questo computer. Se invece è già installata una versione di una release maggiore, la Gestione installazioni di SolidWorks aggiungerà sempre tale installazione.

(A partire da SolidWorks 2010, non sono più supportate le installazioni parallele di diverse versioni Service Pack della stessa release maggiore.)

Quando si aggiorna:
  • Sono aggiornati tutti i prodotti specificati.
  • Sono selezionati di default tutti i prodotti installati.
  • Se si deseleziona un prodotto, questo non viene aggiornato.
    Se si deseleziona un componente di prodotto, non si indica alla Gestione installazioni di SolidWorks di rimuovere tale componente. Per rimuovere un componente di prodotto, utilizzare Installazione applicazioni, come descritto in Rimozione di un'installazione.

Selezionare l'opzione appropriata e fare clic su Avanti per continuare.

Crea una nuova installazione di SolidWorks versione.

Selezionare questa opzione per mantenere l'installazione della versione maggiore precedente in aggiunta a creare una nuova installazione per questa versione maggiore.

Ciò può essere utile per accedere alla versione precedente di SolidWorks anche dopo aver installato una versione più recente. Ad esempio, se si condividono i file con altri utenti che ancora utilizzano la versione precedente, utilizzare la versione più recente per evitare incompatibilità di file tra le versioni.

Aggiornare SolidWorks versione_maggiore_precedente a SolidWorks versione_maggiore_corrente.

Selezionare questa opzione per aggiornare l'installazione della versione precedente alla più recente.
Una volta completata l'installazione, la versione precedente di SolidWorks non sarà più disponibile sul computer.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Avanzamento dell'installazione

Questo schermo mostra l'avanzamento dell'installazione.

Per annullare l'installazione dopo l'avvio, fare clic su Annulla.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Tipo di installazione

Specificare l'azione di installazione da eseguire, ad esempio creare una nuova installazione, modificare o riparare un'installazione esistente, creare un'immagine amministrativa, installare prodotti server amministrativi o scaricare i file senza installarli.

Individuale

Installa i prodotti SolidWorks su questo computer.

Questa opzione compare solo se la versione corrente è installata su questo computer.

Modificare l'installazione individuale

Modificare l'installazione esistente di SolidWorks (su questo computer).

Questa opzione compare solo se la versione corrente è installata su questo computer.
Le modifiche comprendono:
  • Aggiunta o rimozione dei componenti di prodotto SolidWorks
  • Selezione di un pacchetto SolidWorks diverso (es. SolidWorks Professional, SolidWorks Premium, ecc.)
  • Modifica del numero seriale di SolidWorks
    Se si è già specificato un numero seriale di SolidWorks durante un'installazione precedente, la Gestione installazioni di SolidWorks potrebbe non visualizzare di nuovo la richiesta. Per cambiare il numero seriale ipotizzato dalla Gestione installazioni di SolidWorks, è necessario selezionare questa opzione.

Riparare l'installazione individuale

Riparare l'installazione individuale esistente (su questo computer).

Questa opzione compare solo se la versione corrente è installata su questo computer.
La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.
Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.

Immagine amministrativa

Creare o aggiornare un'immagine amministrativa su questo computer.

È possibile utilizzare un'immagine amministrativa per l'installazione su più computer. Per i dettagli sull'installazione di SolidWorks su più client con l'uso delle immagini amministrative, vedere Uso di immagini amministrative.

Quando si crea o aggiorna un'immagine amministrativa:
  • È possibile utilizzare le impostazioni di installazione dell'immagine esistente per configurare l'immagine nuova o aggiornata, oppure utilizzare le impostazioni di installazione di default di SolidWorks.
  • Se si aggiorna un'immagine esistente:
    • La Gestione installazioni di SolidWorks crea una nuova copia dell'immagine, anche se è in corso l'aggiornamento. L'immagine originale non viene modificata.
    • È possibile creare l'immagine aggiornata utilizzando i file dell'immagine esistente in fase di aggiornamento. Il download risultante è pertanto minore.
    Se non si specifica un'immagine per cui sia disponibile una release Service Pack per l'aggiornamento dell'immagine precedente, non è possibile utilizzare il download di dimensione più piccola.
  • È possibile creare immagini amministrative a 32 bit e 64 bit su questo computer. Diversamente, sarà creata solo l'immagine corrispondente all'architettura hardware del computer.
    Se si specifica la creazione dell'immagine a 32 bit e a 64 bit, si dovrà disporre del supporto di installazione di SolidWorks per entrambe le architetture al fine di completare l'installazione.

Prodotti server

I prodotti server amministrativi di SolidWorks comprendono SolidWorks Workgroup PDM Server (vault) e SolidNetWork License Manager.

Per i dettagli su questi prodotti, vedere:
  • Workgroup PDM
  • Amministrazione delle licenze mediante SolidNetWork License Manager

Solo download

Scaricare i file di installazione per i prodotti SolidWorks selezionati senza installare i prodotti.

Questa opzione non è disponibile se si utilizza un DVD per l'installazione.

Il contenuto dei file scaricati è identico ai file disponibili sul DVD di installazione di SolidWorks. Selezionare questa opzione per scaricare il gruppo completo dei file d'installazione, a prescindere da quali file possano già essere installati sul computer.

L'utente può utilizzare questo metodo per impostare un server dal quale sarà possibile effettuare le installazioni. Questa è una cosa diversa dal creare un'immagine amministrativa.

Installazione dell'architettura SolidWorks errata su questo computer

Se si tenta di installare con un supporto SolidWorks errato per l'architettura del computer (ad esempio, installando SolidWorks a 64 bit su un computer a 32 bit) il pannello di installazione dovrebbe indicare il problema.

Per continuare l'installazione:
  1. Annullare la sessione con la Gestione installazioni di SolidWorks.
  2. Controllare l'architettura del computer e i requisiti di sistema di questo computer.
  3. Reinstallare utilizzando i supporti SolidWorks corretti per l'architettura del computer.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Download manuale

Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SolidWorks).

Fare clic sul link per aprire una pagina web generata automaticamente con un elenco completo dei file necessari per il download.

È necessario scaricarli nella cartella indicata nella pagina di riepilogo. L'installazione non può iniziare se non sono stati scaricati tutti i file nella cartella.

Una volta completati i download manuali, fare clic su Avanti per continuare.

Per scaricarli manualmente, è possibile modificare l'opzione tornano alla pagina di riepilogo e modificando le opzioni di download.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Versione più recente disponibile

La Gestione installazioni ha identificato una versione più recente dei prodotti SolidWorks. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.

Se si installa da un DVD

In Utilizzare la versione più recente?, selezionare una delle risposte seguenti:
  • No, continua a installare versione da questo DVD. Si potrà aggiornare successivamente con un download di dimensioni minori.

    Selezionare questa opzione per continuare con l'installazione usando la Gestione installazioni corrente.

    Al completamento dell'installazione, sarà possibile selezionare ed installare gli aggiornamenti usando la Gestione installazioni. Per controllare gli aggiornamenti, selezionare Start > Gestione installazioni di SolidWorks > Verifica aggiornamenti.

    Il vantaggio è che questo genera un download più piccolo. Gli svantaggi sono rappresentati dal fatto che questa è una procedura a due fasi e i file scaricati sono specifici della versione (e non possono essere condivisi usando versioni diverse).

  • Sì, esegui l'installazione da questo DVD, quindi scarica e aggiorna a versione.

    Selezionare questa opzione per scaricare ed eseguire una versione più recente della Gestione installazioni per installare i prodotti SolidWorks per quella versione.

    Se è disponibile un piccolo Service Pack per aggiornare la versione su DVD, la Gestione installazioni installa anzitutto la versione originale dal DVD e quindi applica l'aggiornamento del Service Pack. Il download risultante è pertanto minore.

    È possibile ottenere lo stesso risultato selezionando l'opzione per continuare l'installazione da DVD e applicare l'aggiornamento in un momento successivo.

    Il vantaggio è che questa opzione è una procedura unica.

Nella maggior parte dei casi, è preferibile installare la versione completa dal DVD e quindi usare la Gestione installazioni per verificare ed installare gli aggiornamenti perché questo richiede dei download più piccoli.

Se si installa da un download

Scegliere una delle seguenti opzioni:
  • Continuare ad installare versione.

    Selezionare questa opzione per continuare ad installare la versione contenuta nel download iniziale.

  • Scaricamento ed installazione di una nuova versione: versione

    Selezionare questa opzione per fare il download della nuova versione ed installarla. Nel caso di versioni multiple disponibili, selezionare la versione da scaricare ed installare.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Processi rilevati

La Gestione installazioni di SolidWorks ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.

  • Per continuare l'installazione, adottare una delle seguenti metodologie:
    • Chiudere questi processi (es. l'uso del Task Manager in Microsoft Windows) e premere Riprova.
    • Fare clic su Ignora per procedere senza chiudere i processi.
  • Per interrompere l'installazione, premere Annulla.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Selezione prodotti

Specificare i componenti di prodotto da installare modificare, scaricare o rimuovere.

Nell'elenco prodotti:
  • L'elenco prodotti contiene tutti i prodotti disponibili nel pacchetto specificata sopra l'elenco stesso.
  • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione di installazione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
  • È possibile fare clic sulla casella di controllo accanto al componente del prodotto per modificare l'azione di installazione di tale componente. (Ad esempio, se si installano o rimuovono i componenti, la selezione della casella di controllo indica che il componente è da installare o da rimuovere, la deselezione indica invece che tale componente non deve essere installato o rimosso.)
  • Se si esegue Modifica installazione, appare un asterisco (*) a sinistra dei componenti dopo aver apportato modifiche alla selezione.
  • Se un componente contiene sottocomponenti opzionali, l'icona + appare accanto a tale componente. Per visualizzare i sottocomponenti disponibili, fare clic sull'icona + di fianco.
  • Quando un componente è stato espanso per visualizzarne i sottocomponenti, l'icona - appare accanto a tale componente. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona - di fianco.

Se si applica un Service Pack, non sarà possibile selezionare le funzioni che appaiono in corrispondenza di SolidWorks (ad esempio FeatureWorks). Ciò accade perchè non è possibile aggiungere o rimuovere una funzione quando si effettua questo tipo di aggiornamento.

Le azioni effettuate da SolidWorks Installation Manager sono controllate da un gruppo di regole di coesistenza del prodotto. Per i dettagli, vedere Regole di coesistenza del prodotto.

SolidWorks Installation Manager seleziona di default questi componenti di prodotto:
  • se si esegue un aggiornamento o si installa un Service Pack, SolidWorks Installation Manager seleziona i prodotti attualmente installati.
  • Diversamente, SolidWorks Installation Manager selezionerà tutti i prodotti cui ha diritto l'utente.
Per ridurre i tempi di installazione o download e i requisiti di spazio su disco, espandere i componenti del prodotto e selezionare la casella di controllo dei componenti non desiderati.

Se SolidWorks Installation Manager non ha potuto verificare i prodotti cui ha diritto l'utente, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (es. SolidWorks Professional o SolidWorks Premium) da installare o modificare. SolidWorks Installation Manager elenca tutti i prodotti SolidWorks sui media di installazione compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Ricerca SolidWorks

La Ricerca SolidWorks fornisce un mezzo di ricerca efficace dei documenti SolidWorks, il vault di Workgroup PDM e 3D ContentCentral. La ricerca visualizza un'anteprima e l'ubicazione del file e il nome.

Dopo l'installazione, Ricerca SolidWorks indicizza i documenti SolidWorks per ricerche più rapide. Solo i file SolidWorks sono indicizzati di default.

L'installazione di Ricerca SolidWorks installa automaticamente Windows Desktop Search se non è ancora installato sul proprio computer.

Supporto internazionale

Espandere il prodotto SolidWorks e il componente Lingue per vedere le lingue che possono essere installate.

La specificazione Lingue limita le lingue installate per il solo prodotto SolidWorks. Altre installazioni del prodotto non saranno condizionate da questa specificazione. Per esempio, SolidWorks eDrawings®, SolidWorks Workgroup PDM e SolidWorks Explorer installeranno tutte le lingue.

Spazio necessario

SolidWorks Installation Manager riporta la dimensione totale dell'installazione o quella totale del download nella pagina in basso.

  • Se si è selezionato Solo download, appare la dimensione del download. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.
    Tutti i file necessari per l'installazione sono compresi nella dimensione del download totale. Se alcuni file sono già stati scaricati nella cartella corrente del download, non saranno più scaricati. Quindi, la dimensione effettiva del download potrà essere minore della dimensione del download totale o potrà non essere necessario scaricare alcun file.
  • Altrimenti, apparirà la dimensione dell'installazione. La dimensione dell'installazione è la modifica nell'uso di spazio su disco necessaria al completamento di questa installazione. A causa della compressione del file, queste cifre sono approssimative.

    Nel caso di aggiornamento o rimozione di un'installazione esistente, la dimensione dell'installazione potrà essere zero.

    Il valore indicato non comprende lo spazio necessario per scaricare o estrarre i file se necessari per l'installazione.

    Se i download sono necessari e l'utente sta scaricando nella stessa unità, i requisiti di spazio su disco effettivi potranno essere significativamente maggiori rispetto alla dimensione dell'installazione che appare.

    Per ridurre i tempi del download o di installazione per le modifiche future, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Prodotti da scaricare

Selezionare i prodotti SolidWorks da scaricare in un punto specifico.

I prodotti disponibili per il download sono determinati dal numero seriale fornito:

  • l'azione da effettuare per ciascun componente appare alla destra di ogni elemento.
  • Se un componente contiene sottocomponenti opzionali, l'icona + appare accanto a tale componente. Per visualizzare i sottocomponenti disponibili, fare clic sull'icona + di fianco.
  • Quando un componente è stato espanso per visualizzarne i sottocomponenti, l'icona - appare accanto a tale componente. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona - di fianco.
  • Fare clic sulla casella a sinistra di ogni componente per scegliere come gestire la Gestione installazioni di SolidWorks.
La Gestione installazioni SolidWorks scarica tutti i componenti del prodotto ai quali si può avere accesso a meno che non sia diversamente specificato. Per ridurre i tempi del download e i requisiti di spazio su disco, espandere i componenti del prodotto e selezionare quei componenti non necessari.

Se SolidWorks Installation Manager non ha potuto verificare i prodotti assegnati all'utente, selezionare un pacchetto SolidWorks da scaricare. SolidWorks Installation Manager elenca tutti i prodotti SolidWorks compatibili con il pacchetto selezionato.

Se SolidWorks Installation Manager non ha potuto verificare i prodotti cui ha diritto l'utente, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (es. SolidWorks Professional o SolidWorks Premium) da installare o modificare. SolidWorks Installation Manager elenca tutti i prodotti SolidWorks sui media di installazione compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Supporto internazionale

La specificazione Lingue limita le lingue installate per il solo prodotto SolidWorks. Altre installazioni del prodotto non saranno condizionate da questa specificazione. Per esempio, SolidWorks eDrawings®, SolidWorks Workgroup PDM e SolidWorks Explorer installeranno tutte le lingue.

Spazio necessario

In base ai prodotti selezionati, lo spazio necessario per effettuare il download verrà visualizzato. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.

Per ridurre i tempi del download o di installazione per gli aggiornamenti futuri e le patch, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Prodotti da riparare

Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SolidWorks con i numeri di versione che potranno essere riparati da questa versione della Gestione installazioni di SolidWorks.

La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.

Fare clic su Ripara per iniziare a riparare i prodotti selezionati.

Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Numeri di seriali

I numeri di seriali, trovati nella casella di distribuzione, associano il proprio computer con i prodotti SolidWorks acquistati.

Se i prodotti SolidWorks sono già installati sul proprio computer, i relativi numeri di seriali appariranno di default.
  • Immettere il numero seriale di SolidWorks se non è già visualizzato.
  • Se si hanno numeri di seriali di prodotti non inclusi nella licenza di SolidWorks, fare clic sulla voce del prodotto in Si hanno altri numeri di seriali? e digitare tali numeri per il prodotto.

Con una connessione Internet, i numeri di seriali forniti determinano i prodotti ai quali ha diritto l'utente mentre si prosegue con l'installazione.

Visto che esistono diverse modalità per l'acquisto dei prodotti SolidWorks, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SolidWorks può permettere di installare SolidWorks Simulation senza immettere un numero seriale separato per SolidWorks Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio VAR.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Installazione del server

I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.

Stato di installazione del server

Le installazioni di prodotti server sono eseguite da un'applicazione esterna. Se tale applicazione non è attualmente in primo piano, è necessario attivarla per completare l'installazione.

Fare clic su Annulla per interrompere le installazioni di prodotti server.

Installazione server completata

L'applicazione esterna si è conclusa.

Fare clic su Fine o Avanti.
  • Se si installano altri prodotti amministrativi (es. un'immagine amministrativa SolidWorks), l'installazione continua.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SolidWorks si chiude.

Installazione server annullata o non riuscita

Se l'installazione di un prodotto server è stata annullata o non è riuscita dopo l'avvio, i server non installati saranno elencati.

Fare clic su Chiudi o Avanti.
  • Se si sono specificate altre installazioni di prodotti amministrativi, la Gestione installazioni di SolidWorks riprende.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SolidWorks si chiude.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


SolidNetWork License Manager

Specificare le opzioni di installazione per il prodotto server SolidNetWork License Manager.

Numeri di serie

Specificare i numeri di serie per la licenza di SolidNetWork. È possibile specificare più numeri di serie separandoli con la virgola.
I numeri di serie di SolidNetWork sono diversi da quelli di SolidWorks.

Ubicazione installazione

Specificare la posizione di installazione per SolidNetWork License Manager.

Se si sta aggiornando una versione esistente di SolidNetWork License Manager, l'installazione dovrà utilizzare la stessa posizione precedente.

Per ulteriori informazioni

Per i dettagli sull'installazione, la configurazione e l'uso di SolidNetWork License Manager, vedere Amministrazione delle licenze mediante SolidNetWork License Manager.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Sintesi

La Gestione installazioni di SolidWorks ha tutte le informazioni necessarie per completare l'installazione.

Per continuare: | Fare clic su azione ora per iniziare l'installazione (es. Installa ora, Crea ora, Download ora, Modifica ora).
Per modificare le impostazioni di installazione: | Fare clic su CAMBIA [image] nella sezione che si desidera modificare (es. Prodotti, Ubicazione installazione, Opzioni Toolbox).
Per annullare: | Fare clic su Annulla [image] per uscire dalla Gestione installazioni di SolidWorks senza cambiare i componenti dell'installazione.
Per tornare a una pagina precedente: | Fare clic su Indietro [image] per tornare a una pagina precedente nella Gestione installazioni di SolidWorks.
Per informazioni su un set di opzioni di installazione (es. Prodotti, Ubicazione di installazione, Opzioni Toolbox, ecc.):
  1. Fare clic su CAMBIA [image] in corrispondenza della sezione sulla quale ottenere maggiori informazioni.
  2. Nella pagina dei dettagli che appare, fare clic su ? per ottenere informazioni su quelle impostazioni.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Avvertimenti di controllo sistema

Controllo sistema segnala i problemi riscontrati che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SolidWorks.

Gli avvertimenti possono verificarsi in qualsiasi fase tra quelle sotto elencate e forniscono suggerimenti per continuare.

Problemi di convalida del numero seriale
La Gestione installazioni di SolidWorks non ha potuto controllare le nuove versioni perché non è riuscita a convalidare il numero seriale. Se la connessione è attiva e si è specificato un numero seriale valido, potrebbe trattarsi di un problema temporaneo di uno dei nostri server. Riprovare più avanti.

Convalida numero seriale: La Gestione installazioni di SolidWorks non ha potuto convalidare il numero seriale per stabilire quali prodotti possono essere installati. Si potrà comunque scegliere i prodotti da installare, ma non sarà possibile scaricare i file di installazione. È necessario procurarsi un gruppo completo dei file sorgente oppure il DVD di installazione.

Risoluzione:
  • Controllare la connessione Internet. Il controllo del numero seriale richiede una connessione Internet operativa.
  • Verificare che il numero seriale specificato sia valido per i prodotti che si desidera installare.
  • Alcune installazioni richiedono l'esistenza di un servizio di abbonamento relativo alla versione in uso. Per i dettagli, rivolgersi al proprio rivenditore SolidWorks.
  • Nella maggioranza dei casi, si potrà procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.
Versione più recente disponibile
Versione più recente disponibile

Nuove versioni disponibili

È disponibile per il download una versione più recente di questo prodotto.

Risoluzione: Durante la Verifica aggiornamenti, l'installazione potrebbe invitare a installare una versione successiva resa disponibile per il download da SolidWorks. È possibile continuare questa operazione usando la versione specificata inizialmente oppure scaricare la nuova versione.

Versione più recente disponibile
Questa è la versione più recente disponibile. Fare clic su Avanti per continuare.

Nessun nuovo download disponibile

Risoluzione: Questo messaggio può comparire quando si verifica la disponibilità di aggiornamenti durante un'installazione o una modifica. Indica che si sta installando (o si è installata) la versione più recente disponibile.

Problemi di connessione Internet
Connessione Internet: la Gestione installazioni di SolidWorks non ha potuto connettersi al server SolidWorks per stabilire quali prodotti siano autorizzati all'installazione. Si potrà comunque scegliere i prodotti da installare, ma non sarà possibile scaricare i file di installazione. Procurarsi i file sorgente su DVD o da un gruppo completo di file scaricati in precedenza.

Impossibile verificare nuove versioni

La Gestione installazioni di SolidWorks non ha potuto verificare la disponibilità di nuove versioni perché non è riuscita a connettersi al server.

Risoluzione:
  • Controllare la connessione Internet.
  • Si può procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Creazione guidata fori/Opzioni Toolbox

Se è installato SolidWorks Toolbox, SolidWorks includerà una libreria standard di tipi di foro e minuteria.

Per i dettagli sulla configurazione, estensione e sull'uso di SolidWorks Toolbox, in SolidWorks fare clic su ? > Guida di Toolbox.
Per aprire la Guida, potrebbe essere necessario avviare l'aggiunta Toolbox utilizzando il comando Strumenti > Aggiunte.

Prima di utilizzare SolidWorks Toolbox, assicurarsi che sia configurato secondo le direttive aziendali o del proprio gruppo. In molti casi, un gruppo configura e mantenere una installazione centrale di Toolbox. Consultare l'amministratore di SolidWorks per informazioni su come specificare l'installazione di Toolbox durante l'installazione di SolidWorks.

È possibile modificare il SolidWorks Toolbox selezionato dopo l'installazione. In SolidWorks, fare clic su Strumenti > Opzioni. Nella scheda Opzioni del sistema, fare clic su Creazione guidata fori/Toolbox.

Le sezioni seguenti descrivono tutte le opzioni che possono presentarsi in questa schermata per tutte le configurazioni. Le opzioni effettive di Toolbox dipendono da configurazioni preesistenti di SolidWorks e Toolbox su questo computer e sulle scelte della Gestione installazioni di SolidWorks specificata fino a questo punto.

Creare un nuovo Toolbox nuova-versione

Creare una nuova versione di SolidWorks Toolbox su questo computer.

Quando si crea una nuova versione, nella schermata Selezione prodotti, espandere SolidWorks > SolidWorks Toolbox e selezionare gli standard da supportare per Toolbox. Sono selezionati di default tutti gli standard.

Qualsiasi Toolbox esistente su questo computer non viene modificata.

Riferimento o aggiornamento di un Toolbox esistente

Usare un Toolbox esistente. Fare clic su Sfoglia per specificare la posizione di Toolbox da utilizzare per questa installazione.

  • Se Toolbox è configurato per una precedente release maggiore di SolidWorks, viene aggiornato a questa versione. Qualsiasi elemento personalizzato di Toolbox viene mantenuto nella versione aggiornata.
    L'aggiornamento di Toolbox a una nuova versione di release maggiore di SolidWorks rende Toolbox incompatibile con i computer che eseguono versioni di SolidWorks di release maggiore precedenti.
  • Se Toolbox è configurato per questa versione di SolidWorks (come se si specifica un Toolbox condiviso in rete già aggiornato), non viene aggiornato.
  • Se si aggiorna un Toolbox in ambiente Enterprise PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Aggiornamento di Toolbox in un ambiente SolidWorks Enterprise PDM.

Questa opzione appare in tutte le situazioni di installazione, tranne durante la creazione di un'immagine amministrativa.

Aggiornare a Toolbox versione-precedente

Copiare un Toolbox configurato per una versione di release maggiore precedente in una nuova posizione e aggiornare tale copia a questa versione.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SolidWorks, ma si è scelto di non aggiornare tale installazione a questa release.
Lo scopo di questa opzione è aggiornare un Toolbox di una precedente release maggiore di SolidWorks installato senza conseguenze per gli utenti che usano ancora la versione precedente di Toolbox.

Se si aggiorna un Toolbox in ambiente Enterprise PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Aggiornamento di Toolbox in un ambiente SolidWorks Enterprise PDM.

Aggiornare questa versione-precedente installata di Toolbox

Aggiornare questo Toolbox alla versione più recente.
L'aggiornamento di Toolbox a una nuova versione di release maggiore di SolidWorks rende Toolbox incompatibile con i computer che eseguono versioni di SolidWorks di release maggiore precedenti.

Questa opzione appare se si aggiorna una precedente release maggiore di SolidWorks a questa versione e un Toolbox configurato per tale release è già installato su questo computer.

Se si aggiorna un Toolbox in ambiente Enterprise PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Aggiornamento di Toolbox in un ambiente SolidWorks Enterprise PDM.

Usare il Toolbox esistente della versione-corrente

La Gestione installazioni di SolidWorks ha rilevato su questo computer un Toolbox configurato per questa versione di release maggiore di SolidWorks.

Se si seleziona questa opzione, SolidWorks userà questo Toolbox. Nessun aggiornamento.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SolidWorks, ma è configurato un Toolbox per questa versione. Potrebbe accadere se viene creato un Toolbox condiviso su un computer che ancora segue una versione precedente di SolidWorks.

Specificare la posizione di Toolbox per il computer client

Specificare una posizione di rete o una cartella come posizione di default di Toolbox quando i client installano da un'immagine amministrativa.
Se la posizione contiene un Toolbox configurato per una precedente versione di release maggiore di SolidWorks al momento dell'installazione del client, la Gestione installazioni di SolidWorks aggiorna tale Toolbox.

Questa opzione appare quando si crea una nuova immagine amministrativa.

Aggiornare o utilizzare il Toolbox referenziato nell'immagine esistente per il computer client

Usare la posizione di Toolbox specificata in un'immagine amministrativa esistente in aggiornamento.
Se la posizione contiene un Toolbox configurato per una precedente versione di release maggiore di SolidWorks al momento dell'installazione del client, la Gestione installazioni di SolidWorks aggiorna tale Toolbox.

Selezionare una posizione diversa di Toolbox per il computer client

Specificare una posizione diversa di Toolbox da quella indicata nell'immagine amministrativa in aggiornamento.
Se la posizione contiene un Toolbox configurato per una precedente versione di release maggiore di SolidWorks al momento dell'installazione del client, la Gestione installazioni di SolidWorks aggiorna tale Toolbox.
  • Note sulla configurazione di SolidWorks Toolbox
    SolidWorks Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni di SolidWorks.
  • Formato UNC
    Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Note sulla configurazione di SolidWorks Toolbox

SolidWorks Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni di SolidWorks.

Ulteriori informazioni su SolidWorks Toolbox

Per i dettagli sulla configurazione, estensione e sull'uso di SolidWorks Toolbox, in SolidWorks fare clic su ? > Guida di Toolbox.
Per aprire la Guida, potrebbe essere necessario avviare l'aggiunta Toolbox utilizzando il comando Strumenti > Aggiunte.

Uso di un Toolbox condiviso

Quando si installa Toolbox, è possibile salvare i dati di Toolbox sul proprio sistema o in una posizione in rete condivisa. Si consiglia di memorizzare i dati di Toolbox in una posizione di rete. Utilizzando una posizione condivisa, tutti gli utenti di SolidWorks potranno accedere agli stessi fissaggi.

Se questa è la prima installazione, navigare alla nuova ubicazione condivisa dove installare Toolbox.

Aggiornamento di Toolbox esistente.

L'aggiornamento di Toolbox a una nuova versione di release maggiore di SolidWorks rende Toolbox incompatibile con i computer che eseguono versioni di SolidWorks di release maggiore precedenti.

Se altri computer vengono mantenuti ad una release maggiore precedente e continuano a necessitare di un Toolbox configurato per tale release, si consiglia di creare una copia di tale Toolbox e di aggiornarla. La nuova installazione SolidWorks aggiornerà la copia di Toolbox e le precedenti installazioni SolidWorks continueranno ad usare il vecchio Toolbox.

Configurazione accesso a Toolbox

Dopo l'installazione, quando si accede ai componenti Toolbox, SolidWorks verificherà il modo in cui Toolbox è stato configurato e suggerisce come migliorare l'accesso e la prestazione.

Per accedere a Toolbox in rete condiviso (consigliato), usare un percorso UNC al server sul quale è installato il Toolbox condiviso. Per i dettagli, vedere Formato UNC.

Un amministratore può creare una password per l'accesso a Toolbox e definire i permessi e le preferenze per l'intero gruppo di lavoro. Limitare l'accesso alla configurazione e impostare preferenze comuni è un modo per assicurare che i dati di Toolbox utilizzati dall'intero gruppo di lavoro siano coerenti.

Aggiornamento di Toolbox in un ambiente SolidWorks Enterprise PDM

Prima di aggiornare la prima installazione di SolidWorks che accede alla cartella Toolbox in un vault Enterprise PDM:
  1. In Esplora risorse, individuare la cartella Toolbox nel vault Enterprise PDM.
  2. Fare clic con il pulsante destro del mouse sulla cartella Toolbox e selezionare Leggi l'ultima versione.

    Questo consente alla Gestione installazione di SolidWorks di verificare se le parti devono essere aggiornate.

  3. Controllare la cartella Toolbox.

    Si deve eseguire il check out della cartella Toolbox in modo che la Gestione installazioni di SolidWorks possa aggiornare Toolbox.

  4. Al termine dell'aggiornamento, eseguire il check in nella cartella Toolbox.

La libreria Toolbox nel vault risulta così aggiornata.

Per tutti gli aggiornamenti successivi di SolidWorks, prima di iniziare la procedura i client Enterprise PDM devono ottenere la versione più recente della cartella Toolbox nel vault (utilizzando il comando Leggi l'ultima versione). Ciò consente alla Gestione installazioni di SolidWorks di verificare che i file siano aggiornati.

Per i dettagli sulla configurazione Toolbox in SolidWorks Enterprise PDM, vedere Configurazione di Toolbox nella guida Strumento di amministrazione di SolidWorks Enterprise PDM.

Argomento principale: Creazione guidata fori/Opzioni Toolbox


Formato UNC

Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.

\\server\volume\percorso

Ad esempio:

\\Disk_Server\SolidWorks\AdminImage

Argomento principale: Creazione guidata fori/Opzioni Toolbox


Disinstalla prodotti

Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questo schermo visualizzerà i prodotti SolidWorks (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni SolidWorks. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.

La disinstallazione standard rimuove i File e cartelle del programma di un prodotto SolidWorks. Di default, tutti i prodotti SolidWorks per la release selezionata sono specificati per una disinstallazione standard.

Una disinstallazione personalizzata rimuove uno o più elementi: file e cartelle del programma, chiavi di registro e cartelle dati, come ad esempio SolidWorks Toolbox e i file e cartelle dall'ubicazione di download originale.

Una completa disinstallazione rimuove le directory di installazione, le chiavi di registro e le cartelle dati.

Per disinstallare un prodotto:
  1. nello schermo Disinstalla, assicurarsi che il prodotto sia selezionato.

    Se si disinstallano tutti i prodotti, la Gestione installazioni sarà anch'essa disinstallata.

  2. Deselezionare i prodotti che non devono essere rimossi.

    Se si mantengono dei prodotti, la Gestione installazioni non sarà rimossa.

  3. Scegliere se effettuare una disinstallazione personalizzata o completa.
    1. Fare clic su Cambia in Opzioni avanzate.

      Si visualizza la finestra di dialogo Opzioni avanzate. L'opzione File e cartelle del programma è selezionata.

    2. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
    3. Fare clic su Torna alla Sintesi.
    4. Nello schermo Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le voci.
  4. Fare clic su Rimuovi elementi [image].
Quando si fa clic su Rimuovi elementi, la Gestione installazioni di SolidWorks inizia subito a rimuovere i prodotti.
Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Opzioni del server di Workgroup PDM

Specificare le opzioni di installazione per il prodotto server di SolidWorks Workgroup PDM.

Ubicazione installazione

Specificare la posizione di installazione per i prodotti server di Workgroup PDM Prodotto.

Prodotti da installare

Specificare quali prodotti server di Workgroup PDM si desidera installare:
Vault di Workgroup PDM
Specificare la posizione per i dati del vault di Workgroup PDM. La licenza per Workgroup PDM Viewer deve essere installata con il vault per attivare il Viewer.
Workgroup PDM Viewer
Quando si installa Workgroup PDM Viewer, è necessario specificare il nome o l'indirizzo IP del computer del vault di Workgroup PDM per l'accesso da parte del visualizzatore.
API per Workgroup PDM

Una licenza per l'API di Workgroup PDM è compresa con le licenze dei client SolidWorks ed Explorer. Le API di check-in richiedono licenze client.

Per ulteriori informazioni

Per informazioni dettagliate sull'installazione di Workgroup PDM, vedere Workgroup PDM.

Per informazioni sull'uso di Workgroup PDM, vedere l'argomento Workgroup PDM nella Guida in linea di SolidWorks.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Avvisi legali

© 1995-2011, Dassault Systèmes SolidWorks Corporation, un'azienda del gruppo Dassault Systèmes S.A. 175 Wyman Street, Waltham, Mass. 02451 USA. Tutti i diritti riservati.

Le informazioni e il software ivi presentati sono soggetti a modifica senza preavviso e impegno da parte di Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

Nessun materiale può essere riprodotto o trasmesso sotto qualsiasi forma o attraverso qualsiasi mezzo, elettronico o meccanico, e per qualsiasi scopo senza il previo consenso scritto di DS SolidWorks.

Il software descritto in questo documento è fornito in base alla licenza e può essere usato o copiato solo in ottemperanza dei termini della stessa. Ogni garanzia fornita da DS SolidWorks relativamente al software e alla documentazione è stabilita nell'accordo di licenza e nessun'altra dichiarazione, esplicita o implicita in questo documento o nel suo contenuto dovrà essere considerata o ritenuta una correzione o revisione di tale garanzia.

Notifiche brevetti

Il software CAD meccanico 3D SolidWorks® è protetto dai brevetti U.S. 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238 e i brevetti stranieri, (e.g., EP 1,116,190 e JP 3,517,643).

Il software eDrawings® è protetto dal brevetto U.S. 7,184,044; brevetto U.S. 7,502,027; e dal brevetto canadese 2,318,706.

Altri brevetti USA e stranieri in corso di concessione.

Marchi commerciali e nomi di prodotto per i prodotti SolidWorks e Servizi

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, e il logo eDrawings sono marchi registrati e FeatureManager è un marchio registrato in comune proprietà di DS SolidWorks.

CircuitWorks, FloXpress, TolAnalyst e XchangeWorks sono marchi commerciali di DS SolidWorks.

FeatureWorks è un marchio depositato di Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Simulation, SolidWorks Flow Simulation e eDrawings Professional sono nomi di prodotti DS SolidWorks.

Altre nomi di marca o di prodotto sono marchi commerciali o marchi depositati dei rispettivi titolari.

SOFTWARE PER COMPUTER COMMERCIALE – PROPRIETÀ

Il Software è un "elemento commerciale" così come da definizione dal documento 48 C.F.R. 2.101 (OCT 1995), composto da "software per computer commerciale" e "documentazione del software commerciale" come da definizione dal documento 48 C.F.R. 12.212 (SEPT 1995) e fornito al governo Statunitense (a) per acquisizione di o da parte di agenzie civili, compatibile con la direttiva stabilita nel documento 48 C.F.R. 12.212; o (b) per l'acquisizione di o da parte di unità del Dipartimento della Difesa, compatibile con le direttive stabilite nei documenti 48 C.F.R. 227.7202-1 (JUN 1995) e 227.7202-4 (JUN 1995).

In caso di richiesta da parte di una qualsiasi agenzia del governo Statunitense di fornire il Software con diritti che eccedono quelli stabiliti sopra, notificare la DS SolidWorks dell'ambito della richiesta e la DS SolidWorks, a sua discrezione, accetterà o meno tale richiesta entro cinque giorni lavorativi. Appaltatore/Produttore: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

Note di diritti di autore per i prodotti SolidWorks Standard, Premium, Professional ed Education

Porzioni di questo software © 1986-2011 Siemens Product Lifecycle Management Software Inc. Tutti i diritti riservati.

This work contains the following software owned by Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Tutti i diritti riservati.

Porzioni di questo software © 1998-2011 Geometric Ltd.

Porzioni di questo software © 1996-2011 Microsoft Corporation. Tutti i diritti riservati.

Porzioni di questo software incorporano PhysX™ by NVIDIA 2006-2010.

Porzioni di questo software © 2001-2011 Luxology, LLC. Tutti i diritti riservati, brevetti in attesa di deposito.

Porzioni di questo software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. e suoi concessori di licenza. Tutti i diritti sono riservati. Protetto dai brevetti USA 5.929.866, 5.943.063, 6.289.364, 6.563.502, 6.639.593, 6.754.382. Altri brevetti in corso di concessione.

Adobe, il logo Adobe, Acrobat, il logo Adobe PDF, Distiller e Reader sono marchi depositati o marchi commerciali di Adobe Systems Inc. negli Stati Uniti e in altri paesi.

Per ulteriori informazioni sul diritto d'autore su SolidWorks®, vedere ? > Informazioni su SolidWorks.

Note diritti di autore per i prodotti SolidWorks Simulation

Porzioni di questo software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. Tutti i diritti riservati.

Note dei diritti di autore per il prodotto SolidWorks Enterprise PDM

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation. Tutti i diritti sono riservati.

Note diritti di autore per i prodotti eDrawings

Porzioni di questo software © 2000-2011 Tech Soft 3D.

Porzioni di questo software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Porzioni di questo software © 1998-2001 3Dconnexion.

Porzioni di questo software © 1998-2011 Open Design Alliance. Tutti i diritti sono riservati.

Porzioni di questo software © 1995-2010 Spatial Corporation.

Questo software si basa in parte sul lavoro del gruppo indipendente JPEG.


Installazione e gestione di computer multipli

La Gestione installazioni di SolidWorks fornisce i seguenti strumenti per installare e gestire multipli computer SolidWorks.

Immagini amministrative di SolidWorks

Se si installa SolidWorks su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

Server di Workgroup PDM

Workgroup PDM è un software di gestione dati di progettazione in esecuzione nell'ambiente SolidWorks o come applicazione standalone all'interno di SolidWorks Explorer. Workgroup PDM controlla i progetti con le procedure di check-out, check-in, il controllo di revisione e altre operazioni amministrative. L'installazione del server di Workgroup PDM crea un vault di Workgroup PDM che rappresenta il database dove sono conservati i progetti SolidWorks gestiti.

SolidNetWork License Manager

SolidNetWork License Manager consente al numero di utenti di eccedere il numero di licenze rendendo mobile l'uso delle licenze. Quando la licenza di un client non è in uso, è disponibile per un altro utente SolidWorks.

È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SolidWorks come ad esempio FeatureWorks.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks


Nessuna nuova versione disponibile

Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.

Per procedere con l'installazione, fare clic su Avanti.

Argomento principale: Guida dell'applicazione Gestione installazioni di SolidWorks