Обзор установки и администрирования SolidWorks

В данном руководстве описываются установка, лицензирование, обновление и администрирование продуктов для индивидуальных и нескольких установок.

Индивидуальные установки | Внедрение установок в многопользовательской среде
Установка Установка на одном или нескольких компьютерах. | Установка Создание администрирующего образа, который внедряется на многих клиентских компьютерах.
Лицензирование Активация лицензии или сетевые лицензии. | Лицензирование Активация лицензии или сетевые лицензии.
Обновления Обновление индивидуальных компьютеров до новой версии. | Обновления Обновление нескольких компьютеров до новой версии посредством обновления администрирующего образа, используемого для установки на данных компьютерах.
Администрирование Изменение, восстановление и удаление установок, обновление до новых версий. | Администрирование Обновление администрирующих образов и клиентов, администрирование сетевых лицензий и хранилища Workgroup PDM.

Менеджер установки SolidWorks позволяет задать настройки для компонентов продуктов SolidWorks, включая SolidWorks, SolidWorks Toolbox, PhotoView 360, Workgroup PDM и Менеджер лицензий SolidWorks SolidNetWork.

Workgroup PDM – это программное обеспечение управления данными проекта, которое работает в среде SolidWorks или как отдельное приложение в SolidWorks Explorer. Программа Workgroup PDM позволяет управлять проектами с помощью процедур разрегистрации, регистрации, контроля редакции, а также других администрирующих задач.

Менеджер лицензий SolidNetWork поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

  • Индивидуальная установка или Администрирующий образ
    Необходимо установить продукты SolidWorks отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?
  • Начало установки SolidWorks
    Установку SolidWorks можно начать с загрузки DVD на локальный компьютер для получения доступа к общему каталогу установки или с загрузки с узла SolidWorks.


Индивидуальная установка или Администрирующий образ

Необходимо установить продукты SolidWorks отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?

Если Вы проводите установку на одном компьютере или администрируете десятки или сотни компьютеров, Ваш выбор очевиден. Для менее явных ситуаций рассмотрите приведенные сравнения.

Индивидуальная установка | Администрирующий образ
Пользователи могут администрировать свои установки SolidWorks самостоятельно. | Системный администратор может настроить несколько установок с помощью Редактора параметров, указав параметры установки, такие как создание новой установки или обновление существующей, запуск установки в качестве административного пользователя, запуск внешних команд до или после установки, различные группы продуктов и т.д.
Компьютеры должны быть физически доступны для человека, проводящего установку. | Клиентские компьютеры могут быть удалены, если они доступны через сеть.
Пользователь может устанавливать разные версии, пакеты обновления и продукты на разных компьютерах, используя разные настройки. | С помощью Редактора параметров администрирующие образы могут сохранить последовательность в версиях, пакетах обновления, продуктах и настройках для нескольких установок.
Исходный носитель (DVD) необходим при применении пакетов обновления. | Носители не требуются при применении пакетов обновления.
Подключения компьютера к сети не обязательно. | Подключение к локальной сети необходимо для распространения программы; наличие носителей на клиентских компьютерах не требуется.
 | Клиенты можно обновить автоматически. Установка на всех клиентских компьютерах, проведенная с помощью одного администрирующего образа, распространяет единый пакет обновления на все компьютеры. Для поддержки нескольких версий пакетов обновления можно создать несколько администрирующих образов.
 | Лицензия может активироваться автоматически.
 | Администрирующий образ занимает дополнительное место на сервере; клиенты должны обладать таким же количеством свободного места, что и индивидуальные установки.
На уровень выше: Обзор установки и администрирования SolidWorks


Начало установки SolidWorks

Установку SolidWorks можно начать с загрузки DVD на локальный компьютер для получения доступа к общему каталогу установки или с загрузки с узла SolidWorks.

  • Чтобы запустить установку SolidWorks, выполните одно из следующих действий.
    • Чтобы установить на локальный компьютер с диска, вставьте диск в дисковод.
    • Чтобы запустить установку с каталога загрузки, перейдите в данный каталог и дважды нажмите файл setup.exe.
    • Чтобы установить путем загрузки с узла SolidWorks, выполните следующие действия.
      1. Перейдите на веб-узел SolidWorks.
      2. Войдите под учетной записью клиента, имеющего подписку на службы SolidWorks, используя адрес электронной почты и пароль или серийный номер для SolidWorks.
      3. В разделе Самообслуживание выберите Загрузка программ и обновлений.
      4. В разделе Загрузка программ выберите версию SolidWorks и пакет обновления, которые необходимо загрузить.
На уровень выше: Обзор установки и администрирования SolidWorks


Индивидуальные установки

  • Установка на отдельных компьютерах
    Программу SolidWorks можно установить на отдельном компьютере следующими способами.
  • Администрация индивидуальных установок
    Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.


Установка на отдельных компьютерах

Программу SolidWorks можно установить на отдельном компьютере следующими способами.

Менеджер установки SolidWorks выполняет установку, адаптируя ее для приобретенных продуктов. Перед началом установки необходимо:

  • Необходимо иметь Ваш серийный номер для SolidWorks.
  • Убедитесь, что у Вас есть работающее подключение к Интернету.
Для Менеджера установки SolidWorks необходимы различные компоненты Microsoft, включая установщик Microsoft Windows, веб-компоненты Microsoft Office, Microsoft Visual Studio Tools for Applications и платформу .NET Framework. Если на компьютере не установлены правильные версии всех компонентов требований Windows, Менеджер установки SolidWorks автоматически выполнит их установку перед установкой продуктов SolidWorks.
Метод установки Сводка по процессу
Установка с помощью носителя SolidWorks Вставьте соответствующий DVD-диск в дисковод.
Для установки 32-разрядной и 64-разрядной версий Windows предусмотрены отдельные DVD-диски.
Установка с помощью каталога загрузки на сервере В каталоге загрузки дважды нажмите setup.exe.
Каталог загрузки должен быть доступен с компьютера, на котором выполняется установка продуктов SolidWorks, и должен содержать все установочные файлы SolidWorks до начала процесса установки. Менеджер установки SolidWorks позволяет искать недостающие файлы при наличии доступа в Интернет и права записи в каталог загрузки.
Это не администрирующий образ. Установить клиентский компьютер с администрирующего образа можно единственным способом – щелкнув ссылку на странице HTML, размещенную администратором SolidWorks.
Обновление текущей версии SolidWorks с помощью Проверить наличие обновлений Выполните одно из следующих действий:
  • В SolidWorks выберите Справка > Проверить наличие обновлений.
  • В Windows выберите Пуск > Все программы > Менеджер установки SolidWorks > Проверить наличие обновлений.
Необходимо наличие рабочего подключения к Интернету.

Клиенты Workgroup PDM автоматически определяют время обновления хранилища. Не требуется загружать пакет обновления для обновления клиентов. Дополнительные сведения см. в разделе Обновление клиентов в оперативной справке Workgroup PDM.

Загрузка с клиентского веб-узла SolidWorks.
  1. Откройте веб-сайт SolidWorks.
  2. Войдите в качестве Пользователя абонентских услуг, используя адрес Вашей электронной почты и пароль или Ваш серийный номер для SolidWorks.
  3. Under Самообслуживание выберите Загрузка программ и обновлений.
  4. В разделе Загрузка программ выберите версию SolidWorks, которую требуется загрузить.
Необходимо наличие рабочего подключения к Интернету.

Клиент должен иметь подписку на службы и право доступа для входа на веб-узел портала пользователей.

После завершения установки запустите программу SolidWorks и активируйте лицензию.

На уровень выше: Индивидуальные установки


Администрация индивидуальных установок

Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.

  • Изменение установки
    Можно изменить установку для установки неустановленных продуктов или для удаления продуктов.
  • Подготовка установки
    Если во время установки возникнет ошибка или отмена, то для исправления установки можно использовать панель управления Windows.
  • Откат индивидуальной установки к предыдущей версии пакета обновления
    Чтобы выполнить откат индивидуальной установки к предыдущей версии пакета обновления в текущем семействе версий, удалите установленную на компьютере версию пакета обновления и переустановите более раннюю версию.
  • Удаление установки
    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.
  • Обновление до новой версии
    Выполнить обновление индивидуальной установки SolidWorks до новой версии можно несколькими способами.
  • Правила сосуществования продуктов
    Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.
На уровень выше: Индивидуальные установки


Изменение установки

Можно изменить установку для установки неустановленных продуктов или для удаления продуктов.

Если Вы установили SolidWorks и позднее приобрели приложение к программе, можно изменить установку, чтобы включить в нее новое приложение. Необходимо установить приложение на каждом отдельном компьютере.

Программа Workgroup PDM не установлена, если вносятся изменения в исходный пакет SolidWorks с целью добавления SolidWorks Professional или SolidWorks Premium.
  1. Убедитесь, что не существует текущих сеансов SolidWorks.
  2. В Windows Vista или более поздней версии выберите Пуск > Панель управления > Программы и компоненты.

    Для более ранних версий Windows выберите Пуск > Панель управления > Установка и удаление программ.

  3. Выберите версию SolidWorks, которую требуется удалить, и нажмите кнопку Изменить.
  4. На странице Добро пожаловать в Менеджер установки SolidWorks нажмите Изменение индивидуальной установки (на данном компьютере).
  5. На экране Серийный номер проверьте, указаны ли соответствующие серийные номера.
  6. На странице выбора продуктов выберите продукты для установки или удаления.

    При изменении установки:

    • продукты не устанавливаются и не удаляются по умолчанию, даже если указан новый серийный номер. Необходимо изменить установку каждого продукта или компонента.
    • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
    • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
    • При изменении действия по установке компонента, заданного в исходной спецификации, в списке рядом с этим компонентом отобразится звездочка (*).
    • Если компонент содержит дополнительные субкомпоненты для установки, рядом с компонентом отображается значок + . Для просмотра доступных субкомпонентов компонента щелкните на значке + .
    • Если список дополнительных субкомпонентов компонента раскрыт, рядом с компонентом отображается значок - . Чтобы свернуть список субкомпонентов, щелкните на значке - .

  7. На экране Сводная информация нажмите кнопку Изменить сейчас.
  8. На экране Установка завершена нажмите на кнопку Готово.
На уровень выше: Администрация индивидуальных установок


Подготовка установки

Если во время установки возникнет ошибка или отмена, то для исправления установки можно использовать панель управления Windows.

Можно исправить индивидуальную установку. Установку, созданную с помощью администрирующего образа, исправить нельзя; необходимо отменить установку и затем повторно установить администрирующий образ.

Чтобы исправить установку, выполните следующее.

  1. В Windows Vista или более поздней версии выберите Пуск > Панель управления > Программы и компоненты. Для более ранних версий Windows выберите Пуск > Панель управления > Установка и удаление программ.
  2. Выберите версию SolidWorks, установка которой не удалась, и нажмите на кнопку Изменить.

    Запустится Менеджер установки SolidWorks.

  3. На экране приветствия выберите вариант Исправление индивидуальной установки (на данном компьютере) и нажмите кнопку Далее.
  4. Выберите продукты, которые не удалось установить или удалить, и нажмите кнопку Исправить.
На уровень выше: Администрация индивидуальных установок
На уровень выше: Ошибки установки/Отмена установки


Откат индивидуальной установки к предыдущей версии пакета обновления

Чтобы выполнить откат индивидуальной установки к предыдущей версии пакета обновления в текущем семействе версий, удалите установленную на компьютере версию пакета обновления и переустановите более раннюю версию.

На уровень выше: Администрация индивидуальных установок


Удаление установки

Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

  1. Убедитесь, что не существует текущих сеансов SolidWorks.
  2. Если Вы хотите перенести лицензию SolidWorks на другой компьютер, переведите лицензию на такой компьютер до удаления установки SolidWorks с текущего компьютера.

    Для получения более подробной информации о переносе лицензий SolidWorks см. раздел Перенос лицензии.

  3. В Windows Vista или более поздней версии выберите Пуск > Панель управления > Программы > Программы и компоненты.

    Для более ранних версий Windows выберите Пуск > Панель управления > Установка и удаление программ.

  4. Выберите компонент продукта, который нужно удалить.

    В некоторых случаях можно обнаружить несколько компонентов пакета обновления SolidWorks для существующей основной версии. Чтобы удалить основной выпуск SolidWorks, удалите все элементы пакета обновления для данного основного выпуска.

  5. На экране Удалить:
    1. Выберите продукты для удаления. По умолчанию установлено значение "Все компоненты продуктов".
    2. Отмените выбор продуктов, которые вы не хотите удалять.
    3. Выберите для выполнения полную установку или настраиваемую пользователем. По умолчанию менеджер установки SolidWorks выполняет стандартную отмену установки и удаляет файлы и папки программ.

      1. Нажмите кнопку Изменить в разделе Дополнительные параметры.

        Откроется экран Дополнительные параметры с выбранным параметром «Файлы и папки программ»

      2. Выберите один или несколько параметров, чтобы выполнить настраиваемую пользователем отмену установки, или все параметры, чтобы выполнить полную отмену установки.
      3. Нажмите Назад в Сводку.
      4. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.

    4. Выберите Удалить объект.
На уровень выше: Администрация индивидуальных установок


Обновление до новой версии

Выполнить обновление индивидуальной установки SolidWorks до новой версии можно несколькими способами.

Выполнять обновление до новой версии можно в следующих случаях.
  • При получении нового установочного носителя;
  • при получении уведомления о наличии обновлений во время запуска SolidWorks.
  • Проверка наличия обновлений вручную
  • Запуск новой версии Менеджера установки SolidWorks

При установке новой основной версии можно обновить установленную ранее версию или установить новую параллельно с существующей версией. При установке версии пакета обновления для установленной ранее основной версии эта версия обновляется автоматически.

  • Проверка наличия обновлений вручную
    Проверку наличия обновлений для установленной версии SolidWorks можно выполнить одним из перечисленных ниже способов.
  • Обновление клиентов Workgroup PDM
    Клиенты должны обновить установку при первом входе в хранилище после того, как хранилище было обновлено. Для обновлений клиентов пакет обновления не требуется.
  • Предупреждения относительно обновления
    Продукты, допускающие множественные установки, принадлежащие разным основным выпускам, не всегда поддерживают основные обновления или возможность обновления до следующего основного выпуска посредством одного действия.
На уровень выше: Администрация индивидуальных установок


Проверка наличия обновлений вручную

Проверку наличия обновлений для установленной версии SolidWorks можно выполнить одним из перечисленных ниже способов.

  • В SolidWorks выберите Справка > Проверить наличие обновлений.
  • В Microsoft Windows выберите Пуск > Все программы > Менеджер установки SolidWorks > Проверить наличие обновлений.
На уровень выше: Обновление до новой версии


Обновление клиентов Workgroup PDM

Клиенты должны обновить установку при первом входе в хранилище после того, как хранилище было обновлено. Для обновлений клиентов пакет обновления не требуется.

Состояние клиентов по отношению к Хранилищу | Действие
Та же версия, что и хранилище | Нет
Тот же основной выпуск, новее, чем хранилище | Нет
Более новый основной выпуск, новее, чем хранилище | Вход заблокирован
Тот же основной выпуск, старше, чем хранилище | Необязательное обновление
Более старый основной выпуск, старше, чем хранилище | Обязательное обновление

Дополнительные сведения по обновлению клиентов Workgroup PDM см. в разделе Обновление клиентов в документе Справка Workgroup PDM.

На уровень выше: Обновление до новой версии
На уровень выше: Администрирование Workgroup PDM VaultAdmin


Предупреждения относительно обновления

Продукты, допускающие множественные установки, принадлежащие разным основным выпускам, не всегда поддерживают основные обновления или возможность обновления до следующего основного выпуска посредством одного действия.

В этом случае Менеджер установки SolidWorks имитирует обновление: сначала устанавливается новая версия, а затем удаляется более ранняя. В настоящее время только основной продукт SolidWorks поддерживают основные обновления.

Последствия таковы:
  • При обновлении основного продукта SolidWorks до следующей основной версии происходит следующее.
    • Текущее месторасположение установки не изменяется.
    • Обновление можно откатить назад при возникновении ошибки или при отмене процесса обновления во время его выполнения.
  • При обновлении других продуктов до следующего основного выпуска:
    • Каждый из продуктов сначала устанавливается в качестве нового продукта в новом месторасположении, а затем его исходная установка удаляется.
    • После запуска процесса обновления его нельзя откатить назад при возникновении ошибки или при отмене процесса обновления во время его выполнения.
На уровень выше: Обновление до новой версии


Правила сосуществования продуктов

Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.

Правило | Примеры
Разрешается устанавливать несколько основных версий базовых продуктов SolidWorks независимо от пакета обновления или номера версии (исключение составляют три перечисленных ниже продукта). На одном компьютере можно устанавливать SolidWorks 2010 SP3.0 и SolidWorks 2011 SP0.0.

Однако если на компьютере установлена версия SolidWorks 2011 SP0.0 и устанавливается SolidWorks 2011 SP1.0, Менеджер установки SolidWorks заменит версию SP0.0 новой версией SP1.0.

Версии SolidWorks 2011 SP0.0 и 2011 SP1.0 не могут работать на одном компьютере.

Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • Сервер Workgroup PDM
  • Менеджер лицензий SolidNetWork
 Если установлена версия SolidWorks 2011 SP0.0, сервер Workgroup PDM обновляется до версии 2011 SP0.0, даже если на данном компьютере сохраняется более ранняя версия программы SolidWorks.
Для каждой основной версии встроенного продукта можно установить только одну версию. | Если обновить SolidWorks 2011 SP0.0 до 2011 SP1.0, приложение SolidWorks Explorer 2011 SP0.0 автоматически обновляется до версии 2011 SP1.0. Однако на этом же компьютере может быть установлена версия SolidWorks Explorer 2010 SP4.0.
На уровень выше: Администрация индивидуальных установок


Множественные установки

  • Внедрение на нескольких клиентах
    Продукты SolidWorks можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.
  • Использование администрирующих образов
    Администрирующий образ позволяет настраивать установку продуктов SolidWorks из одной сетевой папки.
  • Внедрение с использованием командной строки
    Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).
  • Администрация множественных установок
    К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.


Внедрение на нескольких клиентах

Продукты SolidWorks можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.

Ниже дается описание процесса внедрения на нескольких клиентских компьютерах.
  1. Создайте администрирующий образ.
    • Создание администрирующего образа с помощью Менеджера установки SolidWorks
    • Создание администрирующего образа с использованием командной строки
  2. Внедрите администрирующий образ на клиентских компьютерах.
    • Внедрение администрирующего образа на клиентах через электронную почту
    • Установка администрирующего образа с использованием командной строки
  3. Выполните лицензирование.
    • Администрирование индивидуальных лицензий
    • Администрирование лицензий с помощью Менеджера лицензии SolidNetWork
На уровень выше: Множественные установки


Использование администрирующих образов

Администрирующий образ позволяет настраивать установку продуктов SolidWorks из одной сетевой папки.

Администрирующий образ можно установить с любого компьютера в сети, включая клиент.
  • Администрирующий образ должен находиться в папке общего использования.
  • При включении всех продуктов необходимый объем дискового пространства для создания администрирующего образа может составить 7 ГБ и больше.
  • Если обновить общее имя при обновлении администрирующего образа, клиент будет обновлен автоматически при следующем запуске приложения. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.
  • Клиенты должны обладать правами администратора на своих компьютерах, если только для выполнения клиентской установки не задан параметр Запустить установку как другой пользователь.
    Этот параметр не поддерживается в системе Windows Vista или более поздних.

Параметрами установки созданного администрирующего образа можно управлять при помощи Редактора параметров администрирующего образа, настраивая их для пользователей и групп, использующих данный образ для установки. Для получения дополнительной информации см. раздел Редактор параметров администрирующего образа.

  • Создание администрирующего образа с помощью Менеджера установки SolidWorks
    Если Вы устанавливаете программу SolidWorks на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.
  • Редактор параметров администрирующего образа
    С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.
  • Внедрение администрирующего образа на клиентах через электронную почту
    Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.
  • Извещение клиентов об администрирующем образе
    Можно запустить команду, с помощью которой клиенты будут оповещены об установке нового администрирующего образа.
На уровень выше: Множественные установки


Создание администрирующего образа с помощью Менеджера установки SolidWorks

Если Вы устанавливаете программу SolidWorks на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

  1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
  2. На экране Добро пожаловать выберите Администрирующий образ.

    На экране появятся параметры создания администрирующего образа:

    Создать новый образ с использованием параметров по умолчанию.
    Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя текущие параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа.
    Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
    Создайте 32-разрядный и 64-разрядный администрирующие образы.
    На одном компьютере можно создать и 32-разрядный, и 64-разрядный образы, либо создать только образ, соответствующей архитектуре компьютера. Чтобы создать оба образа, необходим доступ к 32-разрядной и 64-разрядной установочной версии.

  3. Следуйте инструкциям на экране.
На уровень выше: Использование администрирующих образов


Редактор параметров администрирующего образа

С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.

После создания администрирующего образа Менеджер установки SolidWorks выдает запрос на запуск Редактора параметров. Можно также запустить Редактор параметров, дважды нажав sldAdminOptionEditor.exe в папке администрирующего образа.

Чтобы задать различные конфигурации установки для групп компьютеров или отдельных компьютеров, добавьте группы или компьютеры в Редактор параметров, а затем укажите параметры установки для этих групп и компьютеров.

  • Добавление и удаление групп и компьютеров
    В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.
  • Просмотр и изменение значений параметров
    Редактор параметров администрирующего образа SolidWorks позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.
  • Переключение между 32-разрядными и 64-разрядными образами
    Если в каталоге установке администрирующего образа были созданы 32-разрядный и 64-разрядный образы, в Редакторе параметров можно работать с обоими образами.
  • Внедрение установок из Редактора параметров
    Установки можно разворачивать непосредственно из Редактора параметров, используя инструкции в сообщении электронной почты для запуска установки.
  • Выход из Редактора параметров
    Для выхода из Редактора параметров можно нажать кнопку «OK» или «Закрыть».
  • Создание ярлыка Редактора параметров на рабочем столе
    Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.
На уровень выше: Использование администрирующих образов


Добавление и удаление групп и компьютеров

В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.

Например, может потребоваться настройка нескольких компьютеров, на которых планируется использовать определенный набор компонентов продукта, доступных в образе. А на другой группе компьютеров планируется использовать другой набор компонентов продукта. Даже в случае использования одного администрирующего образа групповые настройки Редактора параметров позволяют устанавливать на разных группах машин разные наборы компонентов продукта.

Чтобы добавить группу, выполните следующее.
  1. Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Добавить группу.
  2. Введите имя группы.
Чтобы добавить компьютеры, выполните следующие действия.
  1. Нажмите правой кнопкой мыши существующую группу или пункт Глобальные настройки, а затем выберите Добавить компьютер.
    Если нажать существующую группу правой кнопкой мыши, компьютеры будут добавлены в эту группу. В противном случае они будут добавлены на верхний уровень.
  2. Выполните одно из следующих действий.
    • Введите одно или несколько имен компьютеров в поле Имя компьютера.

      Имена нескольких компьютеров можно разделить с помощью разрыва строки, пробела, символа табуляции, запятой, точки, двоеточия или точки с запятой. Можно скопировать и вставить список имен компьютеров из внешнего файла.

      Имена компьютеров не могут включать квалификаторы домена. Например, имя pluto.solidworks.com неверное.

    • Нажмите Добавить несколько компьютеров, чтобы выбрать компьютеры в сети.
Чтобы переместить существующий компьютер в группу, выполните следующее действие. | Перетащите компьютер в группу.
Чтобы переместить компьютер из группы, выполните следующее действие. | Перетащите компьютер в раздел Глобальные настройки или в другую группу.
Чтобы удалить группу или компьютер, выполните следующие действия. Нажмите правой кнопкой мыши группу или компьютер и выберите Удалить группу или Удалить компьютер.
При удалении группы удаляются все компьютеры, входящие в ее состав.
Чтобы удалить все группы и компьютеры, выполните следующие действия. | Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Удалить все.
На уровень выше: Редактор параметров администрирующего образа


Просмотр и изменение значений параметров

Редактор параметров администрирующего образа SolidWorks позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.

  • При первом запуске Редактора параметров настройки параметров отображаются в режиме только для чтения. Значок «Редактировать» не затенен: .
    При выборе параметра Глобальные настройки, группы или компьютера отобразится краткий перечень настроек параметра для данного элемента:
    Область | Отображаемые настройки параметров
    Глобальные настройки | Все настройки параметров, указанные для администрирующего образа
    Группы | Изменения настроек групп относительно глобальных настроек
    Компьютер | Изменения настроек компьютеров относительно группы
  • Для изменения настроек параметров щелкните значок «Редактировать». Значок становится затемненным ( [image]), и на экране отобразится более подробный список настроек параметров.

    При выборе параметра Глобальные настройки, группы или компьютера пользователь может изменять настройки параметра для данного элемента. При изменении настройки параметра, отличной от унаследованной глобальной настройки или настроек группы, эта настройка параметра будет выделена.

    При повторном щелчке на значке «Редактировать» содержимое на экране снова будет отображаться в режиме только для чтения.

    Если в «Редакторе параметров» были внесены изменения, перед выходом отобразится запрос об их сохранении или отмене.

  • Установка значений параметров для отдельных компьютеров и групп
    Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.
  • Наследование настроек глобальных и групповых параметров
    Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.
На уровень выше: Редактор параметров администрирующего образа


Установка значений параметров для отдельных компьютеров и групп

Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.

  1. В Редакторе параметров нажмите объект, который необходимо изменить (например, Глобальные настройки, группа, компьютер).
  2. Справа нажмите значок редактирования [image].

    Значок редактирования потемнеет ( [image]), и на экране появится более подробный список для настройки параметров.

  3. Измените настройки для параметров в левой части окна, выбирая необходимые значения справа.

    Изменения параметров, влияющие на Глобальные настройки или параметры группы, будут выделены.

  4. Нажмите OK или Закрыть, чтобы сохранить изменения.

    OK
    Изменения будут сохранены, а Редактор параметров будет закрыт.
    Закрыть
    На экран будет выдан запрос на сохранение изменений, после чего Редактор параметров будет закрыт.

  • Настройка параметров администрирующего образа
    Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и месторасположение Toolbox.
На уровень выше: Просмотр и изменение значений параметров


Настройка параметров администрирующего образа

Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и месторасположение Toolbox.

Серийные номера

Введите серийные номера продуктов, которые необходимо установить на клиентских компьютерах.
Поскольку существует множество способов приобретения продуктов SolidWorks, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SolidWorks дает возможность установить SolidWorks Simulation без ввода отдельного серийного номера SolidWorks Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.
При управлении лицензиями с помощью Лицензий SolidNetWork:
  • В первом поле для серийного номера введите серийный номер SolidNetWork.
  • В поле Порт сервера SNL@сервер введите имя сервера Менеджера лицензий SolidNetWork и порт следующим образом: nnnnn@имя сервера. В качестве разделителей между различными записями используйте точку с запятой.

Для получения более подробной информации о лицензировании SolidNetWork см. раздел Установка и настройка лицензии SolidNetWork.

Параметры установки клиента

Как вы хотите провести установку SolidWorks на клиентских компьютерах?
Можно указать, каким образом клиентские установки будут взаимодействовать с установкой существующей основной версии:
  • Обновить существующую установку (если есть).

    Выберите этот параметр для замены предыдущего основного выпуска версии на новый.

  • Создать новую установку.

    Выберите этот параметр, чтобы сохранить предыдущий основной выпуск и создать новую установку для нового основного выпуска.

    Чтобы указать местоположение установки новой версии, нажмите кнопку Обзор.

Хотите удалить установку последней предыдущей версии перед установкой новой основной версии?
Можно указать, отменять ли установку существующей прежней основной версии:
  • Нет, не нужно сначала отменять установку.

    Выберите этот вариант, чтобы сохранить прежнюю установку прежней основной версии.

  • Да, выполните настроенную пользователем отмену установки.
    Выберите этот вариант, чтобы удалить следующие элементы:
    • Файлы и папки программ
    • Записи реестра
    • Файлы и папки данных
Как Вы хотите применить Настройки SolidWorks?
Можно указать, что установки клиента выполняют настройку конфигурации SolidWorks на базе параметров SolidWorks, установленных на компьютере клиента, или настроек SolidWorks, экспортированных из Помощника копирования настроек.
  • Использовать текущие настройки (если есть) или использовать настройки SolidWorks по умолчанию

    Если на компьютере пользователя определены настройки SolidWorks, сохраните их. (Для параметров, которые не настроены на компьютере клиента, при установке клиента используются настройки SolidWorks по умолчанию.)

  • Использовать файл настроек, экспортированный из Помощника копирования настроек.
    Выбор этого параметра позволяет использовать настройки существующего файла Помощника копирования настроек. (Обычно этот файла называется solidworkssettings.sldreg.)
    • Нажмите кнопку Обзор, чтобы найти существующий файл настроек.
    • Выберите Создать, чтобы запустить Помощник копирования настроек и создать новый файл настроек.
Как Вы хотите активировать установки клиента?
Можно указать, следует ли после запуска установки продукта автоматически выполнять активацию продукта или пользователь должен вручную выполнять активацию продукта после установки.
  • Активировать автоматически после завершения каждой установки клиента.
    Выбор этого параметра указывает, что активация продукта запускается автоматически с помощью файла активации продукта SolidWorks. (Обычно этот файл называется AutoActivation.xml.)
    • Нажмите кнопку Обзор, чтобы найти существующий файл активации.
    • Выберите Создать, чтобы запустить активации продуктов SolidWorks и создать новый файл активации.
  • Не активировать автоматически.

    Выбор этого параметра указывает на отсутствие автоматической активации продуктов. Клиент производит активации продукта после установки.

При выборе автоматической активации продукта администрирующий образ должен быть доступен через сетевое месторасположения для запуска клиентами продукта SolidWorks впервые после установки. Если администрирующий образ не доступен клиентам, установленным с помощью этого образа, эти клиенты не смогут завершить процесс автоматической активации продукта. Они не смогут запустить SolidWorks до тех пор, пока они не запустят активацию продуктов SolidWorks вручную.

Административные настройки

Создайте журнал диагностики во время каждой установки.
При установке клиента может быть создан журнал диагностики, который можно использовать для исправления ошибок установки. Создание такого журнала может замедлить установку клиента.
Запустить установку как другой пользователь.
Установку клиента можно запустить от имени другого пользователя. Этот параметр необходим, если отдельные пользователи не имеют прав административного доступа на локальный компьютер (необходим для установки продуктов SolidWorks).
Этот параметр не поддерживается в системе Windows Vista, Windows 7 и более поздних.
Программы для запуска до или после установки
Можно указать, чтобы до установки клиента или после нее запускалась программа, указанная пользователем.
Вы хотите, чтобы клиенты участвовали в Программе отзывов клиентов SolidWorks?
Можно указать, что компьютеры клиентов могут принимать участие в Программе отзывов клиентов SolidWorks. Информация по быстродействию программы посылается в Корпорацию SolidWorks с целью улучшения продукта. Это несложная конфиденциальная процедура. Дополнительные сведения см. на веб-сайте улучшения качества программного обеспечения.

Программное обеспечение для установки

Можно указать, какие компоненты продукта SolidWorks следует установить.
  • Установленный флажок рядом с компонентом продукта означает, что компонент был установлен во время установки клиента.
  • Отсутствие флажка означает, что компонент не будет установлен.
  • Если компонент содержит дополнительные субкомпоненты для установки, рядом с компонентом отображается значок + . Для просмотра доступных субкомпонентов компонента щелкните на значке + .
  • Если список дополнительных субкомпонентов компонента раскрыт, рядом с компонентом отображается значок - . Чтобы свернуть список субкомпонентов, щелкните на значке - .
Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SolidWorks. Это не повлияет на установки других продуктов. Например, SolidWorks eDrawings®, SolidWorks Workgroup PDM и SolidWorks Explorer устанавливаются на всех поддерживаемых языках.

Параметры Toolbox

Можно указать поддерживаемые стандарты и местоположение Toolbox по умолчанию для установок клиентов.

Обычно к общей установке Toolbox , как правило в сети, имеют доступ несколько пользователей (например, указывается путь UNC, совместно используемая папка или общий сетевой диск).

Если в указанном месте расположен более ранний основной выпуск Toolbox, во время установки клиента этот Toolbox будет обновлен до нового основного выпуска. После этого файлы не будут распознаваться в предыдущих основных выпусках SolidWorks.
Если необходимо сохранить Toolbox для более раннего выпуска SolidWorks (например, если некоторые клиенты используют более ранний выпуск), необходимо указать иное сетевое местоположение Toolbox для клиентов, которые выполняют обновление до более нового выпуска.

Для получения более подробной информации об администрировании Toolbox SolidWorks см. раздел Toolbox в документе Справка SolidWorks.

На уровень выше: Установка значений параметров для отдельных компьютеров и групп


Наследование настроек глобальных и групповых параметров

Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.

Например:
  • Параметры, заданные в разделе Глобальные настройки, применяются ко всем группам и отдельным компьютерам.
  • Параметры, заданные для группы, применяются ко всем компьютерам, входящим в нее.

Наследуемые параметры и параметры по умолчанию можно заменить как для отдельных компьютеров, так и для целых групп. Если изменить наследуемый параметр или параметр по умолчанию, соответствующее значение выделяется.

Чтобы вернуть исходные унаследованные настройки параметра, нажмите правой кнопкой мыши группу или компьютер, а затем выберите Вернуть глобальные настройки (для группы или компьютера, не принадлежащего никакой группе) или Вернуться к настройкам группы (для компьютера, принадлежащего группе).
На уровень выше: Просмотр и изменение значений параметров


Переключение между 32-разрядными и 64-разрядными образами

Если в каталоге установке администрирующего образа были созданы 32-разрядный и 64-разрядный образы, в Редакторе параметров можно работать с обоими образами.

  • Выберите в Редакторе параметров 32 или 64 для работы с 32-разрядным или 64-разрядным образом.

    Параметры Установка или Развертывание позволяют просматривать и изменять настройки параметров или разворачивать установки для данного образа.

Если имеются и 32-разрядный и 64-разрядный образ, необходимо указать глобальные настройки, группы и настройки групп, а также некоторые настройки компьютера отдельно для каждого образа.
На уровень выше: Редактор параметров администрирующего образа


Внедрение установок из Редактора параметров

Установки можно разворачивать непосредственно из Редактора параметров, используя инструкции в сообщении электронной почты для запуска установки.

Необходимо изменить каталог установки администрирующего образа на совместно используемый каталог Windows, который доступен по сети (например, \\компьютер\совместно_используемый_каталог).

  1. Выберите элемент Развертывание в Редакторе параметров.
  2. Если в каталоге установки администрирующего образа имеются 32-разрядный и 64-разрядный образы, выберите элемент 32 или 64 для просмотра машин для 32-разрядного и 64-разрядного образов.

    На экране отобразятся сведения о возможности и состоянии установки для каждого компьютера.

  3. Нажмите Отправить сообщение.
  4. Укажите сетевой путь к каталогу установки администрирующего образа.

    Обычно, путь к каталогу установки администрирующего изображения отображается как путь к файлу Windows (например, C:\SolidWorks Admin\SolidWorks 2011 SP0). В диалоговом окне отобразится сообщение Данный путь не является сетевым.

    1. Для указания местоположения в сети для каталога установки администрирующего образа нажмите кнопку Обзор.
    2. Укажите путь к компьютеру, на котором установлен администрирующий образ, а затем укажите совместно используемый каталог Windows, указанный в качестве каталога установки администрирующего образа.

      Не переходите в общедоступный каталог для администрирующего образа (например, в подкаталог 32bit или 64bit).

    3. Нажмите кнопку OK .

      В диалоговом окне отобразится сообщение Данный путь является сетевым.

    Для владельцев компьютеров будет создано сообщение электронной почты с указаниями по выполнению установки из администрирующего образа с указанием сетевого местоположения файла StartSWInstall.hta в администрирующем образе.

  5. Отправьте данное электронное сообщение пользователям, ответственным за установку SolidWorks.

Для установки SolidWorks из администрирующего образа пользователь может дважды щелкнуть ссылку на сетевое местоположение файла StartSWInstall.hta, которая содержится в сообщении электронной почты.

В Редакторе параметров в разделе Статус установки отображаются состояния:
Ожидается
Пользователь еще не начал установку на данном компьютере.
Успешно
Пользователь успешно завершил установку на данном компьютере.
Сбой
Пользователь запустил установку на данном компьютере, однако установку не удалось выполнить.
  • Использование подключенного диска для развертывания администрирующего образа
    Для указания сетевого местоположения для каталога установки администрирующего образа рекомендуется использовать путь UNC (\\имя_компьютера\имя_совместно_используемого_ресурса). Однако можно использовать подключенный диск в качестве местоположения для файла StartSWInstall.hta в администрирующем образе (например, U:\StartSWInstall.hta), если все клиенты, выполняющие установку, имеют на своих компьютерах одинаковое буквенное обозначение для диска, соответствующего общему каталогу администрирующего образа.
На уровень выше: Редактор параметров администрирующего образа


Использование подключенного диска для развертывания администрирующего образа

Для указания сетевого местоположения для каталога установки администрирующего образа рекомендуется использовать путь UNC (\\имя_компьютера\имя_совместно_используемого_ресурса). Однако можно использовать подключенный диск в качестве местоположения для файла StartSWInstall.hta в администрирующем образе (например, U:\StartSWInstall.hta), если все клиенты, выполняющие установку, имеют на своих компьютерах одинаковое буквенное обозначение для диска, соответствующего общему каталогу администрирующего образа.

Например, если в совместно используется диск U:, в электронном уведомлении будет содержаться следующая ссылка на файл file://U:\StartSWIOnstall.hta. Клиенты, получившие электронное сообщение, смогут успешно выполнить установку при условии, что диск U: соответствует пути UNC для администрирующего образа (\\имя_компьютера\имя_совместно_используемого_ресурса).

На уровень выше: Внедрение установок из Редактора параметров


Выход из Редактора параметров

Для выхода из Редактора параметров можно нажать кнопку «OK» или «Закрыть».

  • Чтобы применить изменения и выйти из Редактора параметров, нажмите кнопку OK, Закрыть или кнопку закрытия приложения Windows.
    • Чтобы применить все изменения настроек параметров и выйти из Редактора параметров, нажмите кнопку OK.
    • Для выхода из Редактора параметров нажмите кнопку Закрыть.

      Если остались несохраненные изменения, появится запрос о необходимости сохранения изменений.

    • Нажмите кнопку закрытия приложений Windows (X). Если остались несохраненные изменения, появится запрос о необходимости сохранения изменений.
На уровень выше: Редактор параметров администрирующего образа


Создание ярлыка Редактора параметров на рабочем столе

Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.

  1. Запустите Редактор параметров.

    Например, в проводнике Windows перейдите к каталогу для установки администрирующего образа и дважды щелкните файл sldAdminOptionEditor.exe.

  2. Выберите Создать ярлык на Рабочем столе для данного Редактора параметров.

    На рабочем столе Windows отобразится ярлык Редактора параметров для администрирующего образа.

На уровень выше: Редактор параметров администрирующего образа


Внедрение администрирующего образа на клиентах через электронную почту

Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.

Настройте каталог администрирующего образа так, чтобы к компьютеру, на котором хранится этот каталог, имели доступ все другие компьютеры (например, по пути UNC).

Всем клиентам можно отправить электронные сообщения, содержащие ссылку на каталог каталог_установки_администрирующего_образа\StartSWInstall.hta. Клиенты могут щелкнуть эту ссылку и выбрать параметр Установить продукты SolidWorks сейчас, чтобы установка была запущена с использованием администрирующего образа.

При обновлении администрирующего образа до новой версии SolidWorks можно настроить его местоположение и общие свойства так, чтобы все клиенты, установленные ранее с помощью этого образа, были обновлены автоматически. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.
На уровень выше: Использование администрирующих образов


Извещение клиентов об администрирующем образе

Можно запустить команду, с помощью которой клиенты будут оповещены об установке нового администрирующего образа.

Внедрение по электронной почте – это метод, с помощью которого клиентам обычно сообщается о новой установке SolidWorks. Для получения дополнительной информации см. раздел Внедрение администрирующего образа на клиентах через электронную почту.

Однако для извещения клиентов о новой установке можно использовать и соответствующую команду. Например, в случае, если Вы хотите уведомить служащих, которые обычно не используют SolidWorks.

Размещение объявления о SolidWorks означает создание ярлыка программы SolidWorks в меню Пуск компьютера пользователя и установку связи с файлами администрирующего образа на сервере. Сначала исполняемые файлы не устанавливаются. Установка происходит только, когда пользователь впервые нуждается в ней.

Когда пользователь нажимает на ярлык или дважды нажимает на документ SolidWorks, выполняется установка и запускается программа SolidWorks.

Чтобы разместить объявления с помощью администрирующего образа:

  1. Создайте и настройте администрирующий образ.
  2. Разместите объявление о продукте на каждом компьютере, на котором будет установлена программа SolidWorks.

    Например:

    msiexec /jm путь_к_файлу_msi_администрирующего_образа,

    где путь_к_файлу_msi_администрирующего_образа – это путь UNC к каталогу администрирующего образа.

На уровень выше: Использование администрирующих образов


Внедрение с использованием командной строки

Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).

  • Создание администрирующего образа с использованием командной строки
    Администрирующий образ можно создать с помощью Менеджера установки SolidWorks или командной строки MS-DOS.
  • Подготовка клиентов для установки командной строки из администрирующего образа
    После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.
  • Установка администрирующего образа с использованием командной строки
    С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.
  • Свойства командной строки
    К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.
  • Развертывание администрирующего образа с помощью Microsoft Active Directory
    Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SolidWorks на клиентах.
На уровень выше: Множественные установки


Создание администрирующего образа с использованием командной строки

Администрирующий образ можно создать с помощью Менеджера установки SolidWorks или командной строки MS-DOS.

Если администрирующие образы создаются при помощи командной строки, необходимо создать и развернуть отдельный образ для каждого компонента SolidWorks. Чтобы это сделать, требуется запустить файл .msi для этого компонента. Если установка выполняется в системе, использующей языки, отличные от английского, необходимо создать и развернуть отдельный образ для каждого такого языка. Чтобы это сделать, нужно запустить файл .msi для требуемого языка. Подробнее о местоположении файлов .msi см. в разделе Месторасположение файла MSI для администрирующих образов.
  1. Откройте окно Командная строка .
    1. В Windows выберите Пуск > Выполнить.
    2. Введите cmd и нажмите кнопку ОК.
  2. Введите данную команду:

    msiexec /a путь_Msi,

    где путь_Msi обозначает местоположение файла .msi для используемой операционной системы. Файл SolidWorks.msi находится в подкаталоге swwi\data каталога установки.

    Например:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. В Мастере установки SolidWorks следуйте инструкциями на экране.
  4. При установке продуктов SolidWorks в системе, использующей языки, отличные от английского, создайте отдельный администрирующий образ для такого языка при помощи данной команды:

    msiexec /a Msi_path_for_language,

    где путь_Msi_для языка означает местоположение файла .msi для языка. Например, файл для французского языка french.msi размещен в подкаталоге swwi\lang\french каталога установки.

    Например:

    msiexec /a F:\swwi\lang\french\french.msi

На уровень выше: Внедрение с использованием командной строки


Подготовка клиентов для установки командной строки из администрирующего образа

После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.

Ручная установка данных компонентов Windows требуется только в том случае, если установка выполняется из администрирующего образа, который был создан вручную при использовании командной строки или через Microsoft Active Directory. Если для создания и установки администрирующего образа использовался Менеджер установки SolidWorks, это значит, что данные компоненты Windows были установлены автоматически.
Здесь представлен перечень файлов, которые при работе с компонентами Windows требуется использовать в SolidWorks:
Установщик Windows
Содержит файлы, необходимые для запуска установки SolidWorks Simulation Premium.
Веб-компоненты Microsoft Office
Содержит объекты COM, необходимые для программы DriveWorks.
Распространяемый пакет Visual C++ 2005 и 2008
Содержит компоненты времени исполнения программы для Microsoft Visual C++.
Требуется установить обе версии: 2005 и 2008.
Инструменты Visual Studio Tools для приложений
Содержит набор инструментов, поддерживающих приложения Visual Studio.
Удаленный отладчик Visual Studio
Создает среду отладки для 64-разрядных операционных систем.
.NET Framework
Содержит общие для языка программирования компоненты времени исполнения и компоненты .NET Framework, необходимые для работы приложений в .NET Framework.
Windows Desktop Search (необязательно)
Поддерживает быстрый поиск файлов и данных в различных источниках данных и месторасположениях, включая локальный компьютер и сетевые ресурсы.
Файлы Windows Desktop Search зависят от выбора языка. Для получения дополнительной информации см. раздел Языковая поддержка для Windows Desktop Search.
Распространяемый пакет Visual С++ и .NET Framework 3,5 требуются для всех продуктов SolidWorks, не только для базового продукта SolidWorks.

Эти компоненты должны быть включены в подкаталоги каталога администрирующего образа.

Следующая таблица определяет необходимые для поддерживаемых операционных систем файлы.
Операционная система: Windows 2003 32-разрядная система1
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | (неприменимо)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lang.exe
Операционная система: Windows 2003 64-разрядная система1
Носитель SolidWorks: 64-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Операционная система: Windows 2008 32-разрядная система1
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | (неприменимо)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно): |  | Windows Desktop Search является элементом операционной системы.
Операционная система: Windows 2008 64-разрядная система1
Носитель SolidWorks: 64-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно): |  | Windows Desktop Search является элементом операционной системы.
Операционная система: Windows XP 32-разрядная система
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | (неприменимо)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно):
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lang.exe
Операционная система: Windows XP 64-разрядная система
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Операционная система: Windows XP 64-разрядная система
Носитель SolidWorks: 64-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
Операционная система: Windows Vista 32-разрядная система
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | (неприменимо)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно): |  | Windows Desktop Search является элементом операционной системы.
Операционная система: Windows Vista 64-разрядная система
Носитель SolidWorks: 64-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (необязательно): |  | Windows Desktop Search является элементом операционной системы.
Операционная система: Windows 7 32-разрядная
Носитель SolidWorks: 32-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | (неприменимо)
 | .NET Framework: |  | .NET Framework и Windows Desktop Search являются элементами операционной системы.
 | Windows Desktop Search (необязательно):
Операционная система: Windows 7 64-разрядная
Носитель SolidWorks: 64-разрядная версия Windows XP, Windows Vista и Windows 7
 | Установщик Windows: |  | (неприменимо)
 | Веб-компоненты Microsoft Office: |  | owc11.exe
 | Распространяемый пакет Visual C++ 2005: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Распространяемый пакет Visual C++ 2008: |  | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
 | Инструменты Visual Studio Tools для приложений: |  | vsta_aide.msi
 | Удаленный отладчик Visual Studio: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework и Windows Desktop Search являются элементами операционной системы.
 | Windows Desktop Search (необязательно):
1Установка в системе Windows 2003 или Windows 2008 поддерживается только для сервера Workgroup PDM и сервера лицензий SolidNetWork (SNL).
  • Установка необходимых компонентов Windows с использованием командной строки в 32-разрядных операционных системах
    Чтобы в 32-разрядных версиях операционных систем Windows с помощью командной строки установить необходимые компоненты Windows, следуйте представленному ниже процессу.
  • Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах
    Чтобы в 64-разрядных версиях операционных систем Windows с помощью командной строки установить необходимые компоненты Windows, следуйте представленному ниже процессу.
  • Поиск SolidWorks и Microsoft Windows Desktop Search
    Поиск SolidWorks интегрирован в программу Microsoft® Windows® Desktop Search.
На уровень выше: Внедрение с использованием командной строки


Установка необходимых компонентов Windows с использованием командной строки в 32-разрядных операционных системах

Чтобы в 32-разрядных версиях операционных систем Windows с помощью командной строки установить необходимые компоненты Windows, следуйте представленному ниже процессу.

Чтобы установить несколько компонентов за одну операцию, создайте пакетный файл с командами, описанными в следующих процедурах, и используйте его для установки компонентов на клиентские компьютеры.

  1. Убедитесь, что на целевом компьютере объем свободного дискового пространства составляет минимум 290 МБ и имеется верный каталог TEMP.
  2. Установите веб-компоненты Microsoft Office с помощью следующей команды:

    каталог_администрирующего_образа\OfficeWeb_11\owc11.exe

  3. Для Windows XP требуется установить установщик Windows:

    каталог_администрирующего_образа\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    В других версиях Windows, отличных от Windows XP, установщик Windows устанавливать не требуется.

  4. Установите Распространяемый пакет Visual C++ 2005:

    каталог_администрирующего_образа\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Установите Распространяемый пакет Visual C++ 2008:

    каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Для Windows XP и Windows Vista требуется установить Microsoft .NET Framework 3.5, используя для этого Windows Server Update Services.

    В системе Windows 7 или более поздней устанавливать образ .NET Framework не требуется.

  7. Инструменты Visual Studio для приложений:

    каталог_администрирующего_образа\Microsoft_VSTA\vsta_aide.msi

На уровень выше: Подготовка клиентов для установки командной строки из администрирующего образа


Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах

Чтобы в 64-разрядных версиях операционных систем Windows с помощью командной строки установить необходимые компоненты Windows, следуйте представленному ниже процессу.

Чтобы установить несколько компонентов за одну операцию, создайте пакетный файл с командами, описанными в следующих процедурах, и используйте его для установки компонентов на клиентские компьютеры.

  1. Убедитесь, что на целевом компьютере объем свободного дискового пространства составляет минимум 620 МБ и имеется верный каталог TEMP.
  2. Установите веб-компоненты Microsoft Office с помощью следующей команды:

    каталог_администрирующего_образа\OfficeWeb_11\owc11.exe

  3. Установите Распространяемый пакет Visual C++ 2005:

    каталог_администрирующего_образа\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    каталог_администрирующего_образа\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Требуется установить обе версии данного пакета: 32-разрядную и 64-разрядную.

  4. Установите Распространяемый пакет Visual C++ 2008:

    каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Требуется установить обе версии данного пакета: 32-разрядную и 64-разрядную.

  5. Для Windows XP и Windows Vista требуется установить Microsoft .NET Framework 3.5, используя для этого Windows Server Update Services.

    В системе Windows 7 или более поздней устанавливать образ .NET Framework не требуется.

  6. Инструменты Visual Studio для приложений:

    каталог_администрирующего_образа\Microsoft_VSTA\vsta_aide.msi

  7. Установите Удаленный отладчик Visual Studio:

    каталог_администрирующего_образа\VSRemoteDebugger\install.exe /Q

На уровень выше: Подготовка клиентов для установки командной строки из администрирующего образа


Поиск SolidWorks и Microsoft Windows Desktop Search

Поиск SolidWorks интегрирован в программу Microsoft® Windows® Desktop Search.

Если на компьютере еще не установлена надлежащая версия Windows Desktop Search, то во время установки SolidWorks появится запрос на ее установку или обновление.

При создании административного образа Windows Desktop Search не включается в каталог администрирующего образа. Если на клиентских компьютерах, на которых SolidWorks устанавливается при помощи администрирующего образа, предполагается использовать поиск SolidWorks, на них необходимо вручную установить Панель поиска Windows.

На уровень выше: Подготовка клиентов для установки командной строки из администрирующего образа


Установка администрирующего образа с использованием командной строки

С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.

Чтобы провести автоматическую установку:
  1. Откройте окно «Командная строка» (в Windows выберите Пуск > Выполнить.
  2. Введите команду msiexec.exe с автоматическими ключами /i и /qb и укажите параметры для свойств, не являющихся свойствами по умолчанию.
Свойства командной строки для установки отдельных компонентов включают в себя:
  • Свойства элементов командной строки
  • Глобальные свойства командной строки
  • Свойства командной строки SolidWorks eDrawings
  • Свойства командной строки SolidWorks Explorer/Workgroup PDM
  • Свойства командной строки SolidWorks Flow Simulation
Используйте следующие примеры в качестве шаблона для автоматической установки.
Клиент SolidWorks
  • SolidWorks основной продукт (на английском языке)
  • Дополнительное приложение Toolbox
  • Участие в Программе отзывов клиентов
  • Поддержка французского языка

32-разрядная версия SolidWorks в 32-разрядной операционной системе:

msiexec /i "путь_к_32-разрядному_администрирующему_образу\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

32-разрядная версия SolidWorks в 64-разрядной операционной системе:

msiexec /i "путь_к_32-разрядному_администрирующему_образу\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

64-разрядная версия SolidWorks в 64-разрядной операционной системе:

msiexec /i "путь_к_64-разрядному_администрирующему_образу\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

Установка компонента поддержки французского языка SolidWorks должна быть проведена отдельно:
  • 32-разрядная версия:

    msiexec /i "путь_к_32-разрядному_администрирующему_образу\SolidWorks French\french.msi" /qb

  • 64-разрядная версия:

    msiexec /i "путь_к_64-разрядному_администрирующему_образу\SolidWorks French\french.msi" /qb

Не следует указывать аргументы командной строки вместе с командами установки компонента языковой поддержки SolidWorks.
Клиент eDrawings
  • Журнал эффективности
  • Все элементы

msiexec /i "путь_к_администрирующему образу\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\ваша_папка" LOGPERFORMANCE=1 SNLSERVER=сервер _лицензий_SolidWorks_для_eDrawings TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer с приложением Workgroup PDM
  • Проводник SolidWorks с приложением Workgroup PDM

msiexec /i "путь_к_администрирующему образу\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\ваша_папка" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
На уровень выше: Внедрение с использованием командной строки


Свойства командной строки

К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.

  • Свойства элементов командной строки
    Установка SolidWorks поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.
  • Глобальные свойства командной строки
    Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.
  • Свойства командной строки SolidWorks eDrawings
    Данные свойства командной строки присущи только программе eDrawings.
  • Свойства командной строки SolidWorks Explorer/Workgroup PDM
    Перечисленные здесь свойства командной строки присущи только SolidWorks Explorer и SolidWorks Workgroup PDM.
  • Свойства командной строки SolidWorks Flow Simulation
    Перечисленные здесь свойства командной строки присущи только SolidWorks Flow Simulation.
  • Месторасположение файла MSI для администрирующих образов
    Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SolidWorks.
  • Языковая поддержка для Windows Desktop Search
    В именах файлов Windows Desktop Search заключена информация о платформе и языке.
На уровень выше: Внедрение с использованием командной строки


Свойства элементов командной строки

Установка SolidWorks поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (для 32-разрядной версии SolidWorks на 32-разрядной операционной системе)
  • Intel_Modules_AgeiaX64 (для 32-разрядной версии SolidWorks на 64-разрядной операционной системе)
  • Manuals
  • Движение
  • PhotoView
  • RealViewGraphicsdisplay
  • Программа ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
При указании свойств для установки с использованием командной строки следует иметь в виду, что:
  • SolidWorks не поддерживает установку продукта с использованием параметра ADDSOURCE.
  • Свойства зависят от регистра, не должны содержать пробелы или дефисы и должны быть разделены запятыми.
  • Параметр SolidWorks должен быть указан, чтобы программа SolidWorks была правильно установлена.
На уровень выше: Свойства командной строки


Глобальные свойства командной строки

Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.

Свойство | Описание
ENABLEPERFORMANCE Указывает, должно ли приложение автоматически посылать данные по быстродействию корпорации SolidWorks.

1 - отправлять данные об эффективности программы, 0 - не отправлять.
INSTALLDIR Папка установки SolidWorks.

Только индивидуальные установки.
INSTALLWDS Устанавливает расширения SolidWorks, использующие Microsoft Windows Desktop Search Engine. Для получения дополнительной информации см. Подготовка клиентов для установки из администрирующего образа.

1 - установить расширения, 0 - не устанавливать.
MOTIONSERIALNUMBER | Серийный номер для продукта SolidWorks Motion
OFFICEOPTION Указывает пакет для установки:
0
Клиент SolidWorks
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL Укажите ALL, чтобы обновить все установленные компоненты.
Данное свойство требуется указывать только при обновлении версии пакета обновления в рамках одного и того же основного выпуска SolidWorks (например, при обновлении установленного пакета обновления SolidWorks 2011 версии 1 до версии 2)
REINSTALLMODE Параметры переустановки пакета установки Microsoft Installer.

Например, при обновлении установки, в случае замены одной версии пакета обновления на другую в рамках одного и того же выпуска SolidWorks, требуется указать REINSTALLMODE=vomus.

Подробнее о параметрах REINSTALLMODE см. документацию по установщику Windows на сайте www.microsoft.com.

Данное свойство требуется указывать только при обновлении версии пакета обновления в рамках одного и того же основного выпуска SolidWorks (например, при обновлении установленного пакета обновления SolidWorks 2011 версии 1 до версии 2) Не следует указывать данное свойство при первой установке нового основного выпуска SolidWorks.
SERVERLIST Список серверов SolidNetWork.
Список серверов SolidNetWork представляет собой список строк, разделенных точкой с запятой, каждая из которых ссылается на номер порта сервера и имеет следующий формат:

xxxxx@имя_сервера1;yyyyy@имя_сервера2;&

где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.

Только индивидуальные установки.
SIMULATIONSERIALNUMBER | Серийный номер для продукта SolidWorks Simulation
SOLIDWORKSSERIALNUMBER | Серийный номер продукта SolidWorks, который включает все дополнения.
SWMIGRATE Указывает версию SolidWorks для обновления так, как она будет отображаться в списке Диалоговое окно «Выбор установки SolidWorks» . Например:

SWMIGRATE=«SolidWorks 2011 SP01»

Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SolidWorks. Не следует указывать это свойство при замене одной версии пакета обновления на другую в рамках одного и того же основного выпуска SolidWorks.
TARGETDIR Папка установки SolidWorks.

Только административные установки.
TOOLBOXFOLDER Папка установки файлов SolidWorks Toolbox.

Только индивидуальные установки.
TRANSFORMS Содержит зависящие от языка элементы в следующем формате:
TRANSFORMS номер.mst
  • Китайский (1028)
  • Китайский (упрощенный) (2052)
  • Чешский (1029)
  • Английский (1033)
  • Французский (1036)
  • Немецкий (1031)
  • Итальянский (1040)
  • Японский (1041)
  • Корейский (1042)
  • Польский (1045)
  • Португальский (Бразилия) (1046)
  • Русский (1049)
  • Испанский (1034)
  • Турецкий (1055)
UPGRADESWINSTALL
Укажите, следует ли обновлять существующую версию SolidWorks до новейшей версии.
0
новая установка, не обновлять.
1
Обновление

Только индивидуальные установки.

Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SolidWorks. Не следует указывать это свойство при замене одной версии пакета обновления на другую в рамках одного и того же основного выпуска SolidWorks.
На уровень выше: Свойства командной строки


Свойства командной строки SolidWorks eDrawings

Данные свойства командной строки присущи только программе eDrawings.

Свойство | Описание
ADDLOCAL Указывает, какую часть приложения SolidWorks eDrawings требуется установить.

All является рекомендуемым параметром.
Синтаксис командной строки: Элемент:
All | Установка всех элементов. Приложение eDrawings осуществляет поиск установленных приложений опубликования SolidWorks и AutoCAD, чтобы проверить установку.
eDrawingsViewer | Просмотр файлов eDrawings и других файлов.
PublisherForAutoCADR14 | Создание файлов eDrawings из приложения AutoCAD R14.
PublisherForAutoCAD2000 | Создание файлов eDrawings из приложения AutoCAD 2000.
PublisherForAutoCAD2004 | Создание файлов eDrawings из приложения AutoCAD 2004.
PublisherForAutoCAD2005 | Создание файлов eDrawings из приложения AutoCAD 2005.
PublisherForAutoCAD2006 | Создание файлов eDrawings из приложения AutoCAD 2006.
DXFDWGTranslator | Просмотр файлов DXF/DWG в программе eDrawings Viewer.
Горячие клавиши | Установка ярлыка на Рабочем столе.
XML3D | Просмотр файлов 3DXML в eDrawings Viewer.
INSTALLDIR | Указывает папку для установки SolidWorks eDrawings.
LOGPERFORMANCE Указывает, должна ли программа автоматически отправлять данные об эффективности программы по электронной почте в корпорацию SolidWorks.
1
Отправлять данные об эффективности программы
0
Не отправлять
SNLSERVER Введите порт@имясервера для лицензионного сервера SolidNetWork. Чтобы разделить несколько комбинаций порт@имясервера, используйте точку с запятой.

Имя порта сервера для кода SNLSERVER требуется только для конфигурации сервера SolidWorks SNL. список_портов@строки_сервера – это список строк, разделенных точкой с запятой, каждая из которых соответствует номеру порта сервера в формате:

xxxxx@имя_сервера1; yyyyy@имя_сервера2;

где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше: Свойства командной строки


Свойства командной строки SolidWorks Explorer/Workgroup PDM

Перечисленные здесь свойства командной строки присущи только SolidWorks Explorer и SolidWorks Workgroup PDM.

Для SolidWorks Explorer/Клиента Workgroup PDM:
Параметр CLIENT | Описание
EXPLORERORPDM
0
Только SolidWorks Explorer
1
можно установить функции Workgroup PDM
ADDLOCAL
  • Standalone
  • Client
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone – это Contributor, а Client – это приложение SolidWorks для автоматической установки Проводника SolidWorks.

Если выбрана программа AutoCAD, она должна быть установлена на компьютере. Workgroup PDM выполняет обнаружение соответствующей версии AutoCAD. Можно указать больше, чем одну версию программы AutoCAD:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 и DocMgr64 можно запустить только при наличии 64-разрядной версии SolidWorks Explorer.

INSTALLDIR | Задание папки установки для Workgroup PDM.
ACTIVSERIALNUMBER | Указывается серийный номер SolidWorks.
Для сервера Workgroup PDM:
Параметр SERVER | Описание
ADDLOCAL
  • Хранилище
  • Веб Портал
  • API

Если вы указали Web-Портал (Viewer), необходимо также указать VAULTNAME.
INSTALLDIR | Задание папки установки для Workgroup PDM.
LICENSE_SERVER | Определяет имя компьютера, на котором размещен лицензионный сервер.
VAULTDATA  | Определяет путь и папку в хранилище.
VAULTNAME | Определяет имя компьютера, на котором размещено хранилище.
На уровень выше: Свойства командной строки


Свойства командной строки SolidWorks Flow Simulation

Перечисленные здесь свойства командной строки присущи только SolidWorks Flow Simulation.

Свойство | Описание
ACTIVSERIALNUMBER Отдельный серийный номер SolidWorks Flow Simulation.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
CWUPGRADEINSTALL Обновление существующей версии определенного программного обеспечения SolidWorks Flow Simulation.
1
Обновление
2
Новая установка; установка в новый каталог

(индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR Задание установки определенного программного обеспечения SolidWorks Flow Simulation.

(только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;&, где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
SOLIDWORKSPATH Указывает папку, в которой установлена программа SolidWorks.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
TARGETDIR Задание установки определенного программного обеспечения SolidWorks Flow Simulation.

(только установка администрирующего образа)
На уровень выше: Свойства командной строки


Месторасположение файла MSI для администрирующих образов

Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SolidWorks.

Продукт | Месторасположение
SolidWorks (основной продукт, англоязычная версия) | swwi\data\SolidWorks.msi
SolidWorks (версии компонентов для языков, отличных от английского) | Традиционный китайский | swwi\lang\chinese\chinese.msi
 | Упрощенный китайский | swwi\lang\chinese-simplified\chinese-simplified.msi
 | чешский | swwi\lang\czech\czech.msi
 | французский | swwi\lang\french\french.msi
 | немецкий | swwi\lang\german\german.msi
 | итальянский | swwi\lang\italian\italian.msi
 | Японский | swwi\lang\japanese\japanese.msi
 | корейский | swwi\lang\korean\korean.msi
 | польский | swwi\lang\polish\polish.msi
 | Португальский (Бразилия) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | Русский | swwi\lang\russian\russian.msi
 | Испанский | swwi\lang\spanish\spanish.msi
 | Турецкий | swwi\lang\turkish\turkish.msi
Комплект программ для разработчиков программных интерфейсов приложений SolidWorks | apisdk\SolidWorks API SDK.msi
Продукты SolidWorks Simulation | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
Средства построения теней eDrawings | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Сервер Workgroup PDM | pdmwserver\SolidWorks Workgroup PDM Server.msi
Помощник активации SolidWorks | swactwizard\Activation Wizard.msi
Интерфейсы API DocManager | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
Менеджер лицензий SolidNetWork | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
На уровень выше: Свойства командной строки


Языковая поддержка для Windows Desktop Search

В именах файлов Windows Desktop Search заключена информация о платформе и языке.

Платформа/архитектура:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32-разрядная версия Windows
x64 | 64-разрядная версия Windows
Язык:
chs | упрощенный китайский
cht | Китайский
csy | чешский
deu | немецкий
enu | английский
esn | испанский
fra | французский
ita | итальянский
jpn | японский
kor | корейский
plk | польский
ptb | португальский (Бразилия)
rus | русский
trk | турецкий
На уровень выше: Свойства командной строки


Развертывание администрирующего образа с помощью Microsoft Active Directory

Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SolidWorks на клиентах.

Microsoft Active Directory – это служба каталогов для управления клиентами и серверами в сетевой среде. Упрощает управление, миграцию и развертывание.

  1. Создайте администрирующий образ с помощью Менеджера установки SolidWorks или командной строки.
  2. Если администрирующий образ создан с использованием командной строки, установите необходимые компоненты Windows, чтобы выполнить установку из администрирующего образа с использованием Microsoft Active Directory. Для получения дополнительной информации см. раздел Установка требуемых компонентов Windows с помощью Microsoft Active Directory.

    Этот шаг необходим только в том случае, если образ был создан вручную с использованием командной строки. Если образ был создан и установлен с помощью Менеджера установки SolidWorks, значит, все необходимые компоненты Windows были установлены автоматически.

  3. Создайте файл преобразования для настройки программного обеспечения SolidWorks.
    1. Откройте окно «Командная строка».
    2. В папке, содержащей администрирующий образ, перетащите файл SWCreateMST.exe в окно «Командная строка».

      Команда должна иметь следующий формат:

      каталог_администрирующего_образа\SWCreateMST.exe путь_к_файлу_MSI_администрирующего_образа список_свойств

      Свойства могут быть глобальными или свойствами элемента. Подробнее см. в разделах Свойства элементов командной строки и Глобальные свойства командной строки.

      Используйте в качестве шаблонов следующие примеры:

      • Если программа SolidWorks (32-разрядная версия) устанавливается в 32-разрядной операционной системе:

        C:\admin\SWCreateMST.exe «c:\admin\SolidWorks.msi» INSTALLDIR=«C:\Program Files\ваша_папка» SOLIDWORKSSERIALNUMBER=«xxxx xxxx xxxx xxxx» ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=«25734@ваш_сервер»

      • Если программа SolidWorks (32-разрядная версия) устанавливается в 64-разрядной операционной системе:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@ваш_сервер"

      • Если программа SolidWorks (64-разрядная версия) устанавливается в 64-разрядной операционной системе:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@ваш_сервер"

      В папке, содержащей администрирующий образ, будет создан файл преобразования SolidWorks.mst.

  4. В окне Active Directory отредактируйте политику опубликованных приложений для группы или групп, чтобы можно было внедрить программное обеспечение SolidWorks.
  5. В диалоговом окне «Групповая политика» раскройте «Конфигурация компьютера» и «Конфигурация программ».
  6. Нажмите правой кнопкой мыши «Установка программного обеспечения» и выберите Создать > Пакет.
  7. Перейдите к администрирующему образу и нажмите Открыть.
  8. В диалоговом окне Deploy Software (Развертывание программы) выберите Advanced published or assigned (Дополнительные опубликованные или назначенные), затем нажмите OK.
  9. В диалоговом окне Свойства SolidWorks на вкладке «Изменения» выполните следующие действия.
    1. Нажмите кнопку Добавить.
    2. Найдите файл .mst.
    3. Нажмите Открыть.
  10. Нажмите кнопку OK .
  • Установка требуемых компонентов Windows с помощью Microsoft Active Directory
    Чтобы подготовить существующий администрирующий образ, с помощью которого программа SolidWorks будет установлена на клиентские компьютеры при участии Microsoft Windows Active Directory, следуйте представленному ниже процессу.
На уровень выше: Внедрение с использованием командной строки


Установка требуемых компонентов Windows с помощью Microsoft Active Directory

Чтобы подготовить существующий администрирующий образ, с помощью которого программа SolidWorks будет установлена на клиентские компьютеры при участии Microsoft Windows Active Directory, следуйте представленному ниже процессу.

В ходе выполнения данного процесса используйте команду, подходящую для внедряемой версии SolidWorks.

  1. Извлеките файлы для установки Распространяемого пакета Visual C++ 2005 и установите их.
    1. Запустите одну из следующих команд.

      Для 32-разрядных версий Windows:

      каталог_администрирующего_образа\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_целевой_каталог}

      Для 64-разрядных версий Windows:

      каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_целевой_каталог}

    2. Создайте процедуру установки модуля Microsoft C++ 2005 redistributable:

      {2005_C++_целевой_каталог}\vcredist.msi -

      Для этой установки файлы преобразования не требуются.

  2. Извлеките файлы для установки Распространяемого пакета Visual C++ 2008 и установите их.
    1. Запустите одну из следующих команд.

      Для 32-разрядных версий Windows:

      каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_целевой_каталог}

      Для 64-разрядных версий Windows:

      каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_целевой_каталог}

    2. Создайте процедуру установки модуля Microsoft C++ 2008 redistributable:

      {2008_C++_целевой_каталог}\vcredist.msi -

      Для этой установки файлы преобразования не требуются.

  3. Установите Microsoft .NET Framework 3,5, используя для этого Windows Server Update Services.

    В системе Windows 7 или более поздней устанавливать образ .NET Framework не требуется.

  4. Извлеките файлы компонентов Office Web и установите их.
    1. Запустите следующую команду:

      каталог_администрирующего_образа\OfficeWeb_11\owc11.exe /extract:{каталог_компонентов_Office_Web}

    2. Создайте процедуру установки Office Web Components:

      {каталог_компонентов_Office_Web}\owc11.MSI

      Для этой установки файлы преобразования не требуются.

  5. Установите инструменты Visual Studio Tools для приложений (VSTA), создав следующую политику:

    {каталог_Microsoft_VSTA}\vsta_aide.MSI

    Для этой установки файлы преобразования не требуются.

  6. Установите Удаленный отладчик Visual Studio (только для 64-разрядный версий), создав следующую политику:

    {каталог_удаленного_отладчика_Microsoft}\rdbgexp.MSI

    Для этой установки файлы преобразования не требуются.

На уровень выше: Развертывание администрирующего образа с помощью Microsoft Active Directory


Администрация множественных установок

К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.

  • Обновление администрирующих образов до новой версии
    Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.
  • Администрирование обновлений продуктов с помощью пакетов обновления
    Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.
  • Удаление установки
    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.
На уровень выше: Множественные установки


Обновление администрирующих образов до новой версии

Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.

Запустите Менеджер установки SolidWorks через Интернет, чтобы установились ссылки на верные файлы. Менеджер установки SolidWorks самостоятельно переадресуется в соответствии с задачей. Обновление также можно запустить напрямую с веб-страницы загрузки SolidWorks (http://www.solidworks.com/sw/support/downloads.htm).

После обновления администрирующего образа (что создает новую копию образа), можно обновить клиентов путем создания ссылки на новую копию администрирующего образа.

Если клиенты были связаны с предыдущей версией администрирующего образа через подключенный диск или общий каталог, то последние можно переопределить в соответствии с местоположением обновленной копии образа.
  • Загрузка обновленных файлов установки для администрирующих образов
    С помощью Менеджера установки SolidWorks можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.
  • Обновление администрирующего образа
    Для обновления администрирующего образа Менеджер установки SolidWorks создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.
  • Обновление клиентов с помощью администрирующих образов
    Менеджер установки SolidWorks позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.
На уровень выше: Администрация множественных установок


Загрузка обновленных файлов установки для администрирующих образов

С помощью Менеджера установки SolidWorks можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.

  1. Запустите Менеджер установки SolidWorks, вставив диск DVD в дисковод.
  2. На экране Добро пожаловать выберите Администрирующий образ.
  3. На экране Серийный номер введите серийный номер SolidWorks.

    Менеджер установки SolidWorks проверяет веб-сайт SolidWorks на наличие лицензированных Вам продуктов и доступных пакетов обновлений.

  4. Если появляется окно Доступные более новые версии, выберите Да, загрузить и установить новую версию: Версия.

    Менеджер установки SolidWorks запустит новый сеанс для установки более новой версии.

  5. При наличии проблемы с папкой загрузки может отобразиться сообщение Параметры загрузки. В этом случае для новых файлов установки выберите каталог по умолчанию или введите имя нового каталога.

    Если отобразится сообщение о том, что каталог не существует, выберите Да, чтобы его создать.

  6. На экране Загрузка завершена выберите Закрыть, чтобы закрыть текущую программу установки и запустить программу установки для новой версии.
На уровень выше: Обновление администрирующих образов до новой версии


Обновление администрирующего образа

Для обновления администрирующего образа Менеджер установки SolidWorks создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.

Данный процесс подразумевает, что для администрирующего образа загружены обновленные файлы установки. Для получения дополнительной информации см. раздел Загрузка обновленных файлов установки для администрирующих образов.

  1. Запустите SolidWorks Installation Manager. Для получения дополнительной информации см. раздел Начало установки SolidWorks.
  2. На экране Добро пожаловать выберите Администрирующий образ.

    На экране появятся параметры создания администрирующего образа:

    Создать новый образ с использованием параметров по умолчанию.
    Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя текущие параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа.
    Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
    Создайте 32-разрядный и 64-разрядный администрирующие образы.
    На одном компьютере можно создать и 32-разрядный, и 64-разрядный образы, либо создать только образ, соответствующей архитектуре компьютера. Чтобы создать оба образа, необходим доступ к 32-разрядной и 64-разрядной установочной версии.

  3. На экране Серийный номер отметьте серийный номер.
  4. На экране Суммарная информация (Готов к созданию образа) отметьте, что параметры администрирующего образа верны.

    Для получения подробной информации об отдельном администрирующем образе и о параметрах установки нажмите кнопку ИЗМЕНИТЬ, чтобы перейти на страницу параметров, а затем выберите Справка.

  5. Чтобы создать новую версию администрирующего образа, нажмите кнопку Создать сейчас.

Теперь можно обновить клиенты до этой новой версии администрирующего образа. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.

На уровень выше: Обновление администрирующих образов до новой версии


Обновление клиентов с помощью администрирующих образов

Менеджер установки SolidWorks позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.

Обычно администрирующие образы располагаются в папках на сервере. Для поддержки автоматических обновлений клиентов администрирующий образ должен располагаться в папке общего использования.

После обновления администрирующего образа исходные и обновленные файлы будут сохранены в две разные папки. Чтобы воспользоваться обновленными файлами установки, отключите параметр общего использования для папки с исходным администрирующим образом и активируйте его для папки с обновленным образом.

При запуске программы SolidWorks на клиентском компьютере, установленном с помощью исходного администрирующего образа, происходит автоматическое распознавание новой версии и обновление клиента.

  • Отмена общего доступа для папки с исходным администрирующим образом
    При обновлении администрирующего образа, доступ к которой осуществлялся из общей папки, необходимо отменить общий доступ для исходной папки.
  • Установка общего доступа для папки с обновленным администрирующим образом.
    После создания папки с обновленным администрирующим образом и отключения общего доступа для папки с исходным администрирующим образом параметр общего доступа необходимо задать для вновь созданной папки. Это необходимо для повторной активации администрирующего образа.
  • Ручное обновление клиентов администрирующих образов с помощью командной строки
    После обновления администрирующего образа можно вручную обновить клиенты, используя для этого командную строку.
На уровень выше: Обновление администрирующих образов до новой версии


Отмена общего доступа для папки с исходным администрирующим образом

При обновлении администрирующего образа, доступ к которой осуществлялся из общей папки, необходимо отменить общий доступ для исходной папки.

  1. Перейдите в папку, где располагаются файлы исходного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Общие выберите параметр Отменить общий доступ к этой папке, затем нажмите кнопку ОК.

Теперь задайте параметр общего доступа для папки с обновленным администрирующим образом, как описано в разделе Установка общего доступа для папки с обновленным администрирующим образом..

На уровень выше: Обновление клиентов с помощью администрирующих образов


Установка общего доступа для папки с обновленным администрирующим образом.

После создания папки с обновленным администрирующим образом и отключения общего доступа для папки с исходным администрирующим образом параметр общего доступа необходимо задать для вновь созданной папки. Это необходимо для повторной активации администрирующего образа.

  1. Перейдите в папку, где располагаются файлы обновленного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Совместное использование укажите параметры совместного использования, подходящие для Вашей организации или группы, и измените имя общего ресурса на имя, используемое в исходной папке администрирующего образа.
На компьютерах, установка на которых была выполнена из общей папки исходного администрирующего образа, при запуске программы SolidWorks произойдет автоматическое обновление до новой версии.
На уровень выше: Обновление клиентов с помощью администрирующих образов


Ручное обновление клиентов администрирующих образов с помощью командной строки

После обновления администрирующего образа можно вручную обновить клиенты, используя для этого командную строку.

  1. Убедитесь, что на все клиенты распространяется единый пакет обновления, принадлежащий предыдущей версии. (Клиенты, на которых приложение еще не установлено, обновлены не будут.)
  2. Кроме того, в одной из клиентских систем необходимо запустить Помощник копирования настроек, чтобы с его помощью скопировать текущие параметры SolidWorks.
  3. Создайте новый администрирующий образ, используя Менеджер установки SolidWorks или командную строку.

    Предыдущий образ обновлять или перезаписывать не требуется.
    Если обновляется установка не-англоязычной версии SolidWorks, необходимо создать новый администрирующий образ для компонента установки языка, отличного от английского.

  4. Обновите все клиенты до новой версии, используя команду msiexec и указав следующие спецификации.

    • Включите параметры командной строки /I и qb msiexec.
    • Укажите все требуемые глобальные свойства и свойства элементов командной строки. Для получения дополнительной информации см. раздел Свойства командной строки.

    Например, чтобы обновить существующую версию SolidWorks, укажите следующее:

    msiexec /I путь_Msi" INSTALLDIR="C:\Program Files\Ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks версия пакет_обновления" /qb

    При обновлении установки не-англоязычной версии SolidWorks, после обновления компонентов SolidWorks, необходимо обновить компонент поддержки языка, отличного от английского.

На уровень выше: Обновление клиентов с помощью администрирующих образов


Администрирование обновлений продуктов с помощью пакетов обновления

Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.

Обновления продуктов можно получать двумя способами.

Для текущих версий SolidWorks:
Проверка наличия, загрузка и установка обновлений с помощью Менеджера установки SolidWorks.

Менеджер установки SolidWorks можно запускать вручную или запрограммировать его на выполнение периодической проверки наличия обновлений.

Для версий SolidWorks до 2008:
Загрузка пакетов обновления вручную с веб-узла поддержки SolidWorks.

Пакеты обновления применяются как заплаты для существующей версии программного обеспечения. Например, SolidWorks 2007 SP1.0 – это пакет обновления для SolidWorks 2007 SP0.0. Эти пакеты обновления можно загрузить с помощью Менеджера установки SolidWorks 2007. Их нельзя установить с помощью Менеджера установки SolidWorks 2008 или более поздней версии.

Для получения более подробных инструкций по загрузке и установке пакетов обновления, см. документацию по установке версии SolidWorks, которую необходимо обновить.

  • Откат пакетов обновления в администрирующем образе
    Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SolidWorks было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.
  • Применение пакетов обновления для клиентов, внедренных с помощью Microsoft Active Directory
    Если программное обеспечение SolidWorks было установлено с помощью Microsoft Active Directory, с помощью этой программы можно также применить пакеты обновления к клиентам.
На уровень выше: Администрация множественных установок


Откат пакетов обновления в администрирующем образе

Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SolidWorks было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.

Администрирующие образы, прошедшие обновления, невозможно откатить до предыдущей версии пакета обновления. Администрирующие образы, созданные любым способом без использования Менеджера установки SolidWorks, невозможно откатить до предыдущей версии. Клиенты, установленные из таких администрирующих образов, должны удаляться и устанавливаться повторно с помощью администрирующего образа, созданного в предыдущей версии.
  1. Удалите папку, содержащую текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:

    rmdir /s/q путь_к_текущему_администрирующему_образу

  2. Переместите резервную копию администрирующего образа в папку, из которой был удален текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:

    move путь_к_резервной_копии_администрирующего_образа путь_к_текущему_администрирующему_образу

    После отката администрирующего образа откат на клиентских компьютерах будет выполнен автоматически при следующем запуске программы SolidWorks.

На уровень выше: Администрирование обновлений продуктов с помощью пакетов обновления


Применение пакетов обновления для клиентов, внедренных с помощью Microsoft Active Directory

Если программное обеспечение SolidWorks было установлено с помощью Microsoft Active Directory, с помощью этой программы можно также применить пакеты обновления к клиентам.

  1. Скопируйте администрирующий образ в новую папку с помощью следующей командной строки:

    xcopy путь_к_текущему_администрирующему_образу путь_к_резервной_копии_администрирующего_образа /s/i/v

  2. Примените пакет обновления к копии администрирующего образа.
  3. Создайте новый файл преобразования, чтобы указать обновление установки для программы SolidWorks:
    1. Откройте окно «Командная строка».
    2. В папке, содержащей администрирующий образ, перетащите файл SWCreateMST.exe в окно «Запрос команды».

      Формат команды следующий:

      путь_к_администрирующему_образу\SWCreateMST.exe путь_к_файлу_MSI_администрирующего_образа список_свойств

      Командная строка должна включать все параметры, которые использовались для создания исходного файла преобразования, а также глобальные свойства UPGRADESWINSTALL и SWMIGRATE.

      Например, если исходная команда выглядела следующим образом:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@ваш_сервер

      Обновленная команда должна выглядеть следующим образом:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@ваш_сервер UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks версия пакет_обновления"

      В папке, содержащей администрирующий образ, будет создан файл преобразования SolidWorks.mst.

      Исходная и обновленная команда в этом примере используются для установки 32-разрядной версии SolidWorks в 32-разрядной операционной системе. При установке 32-разрядной версии SolidWorks в 64-разрядной операционной системе требуется использовать «Intel_Modules_AgeiaX64», а не «Intel_Modules_AgeiaX86». При установке 64-разрядной версии SolidWorks в 64-разрядной операционной системе используется «Intel_Modules_AgeiaX86» или «Intel_Modules_AgeiaX64».

  4. В окне Active Directory отредактируйте политику Published Apps (Опубликованные приложения) для группы или групп, чтобы развернуть программное обеспечение SolidWorks.
  5. В диалоговом окне Групповая политика раскройте Конфигурация компьютера и Конфигурация программ.
  6. Нажмите правой кнопкой мыши Установка программного обеспечения и выберите Создать > Пакет.
  7. Перейдите к администрирующему образу и нажмите Открыть.
  8. В диалоговом окне Deploy Software (Развертывание программы) выберите Advanced published or assigned (Дополнительные опубликованные или назначенные), затем нажмите OK.
  9. В диалоговом окне Свойства SolidWorks на вкладке Изменения выполните следующие действия.
    1. Нажмите кнопку Добавить.
    2. Найдите файл .mst.
    3. Нажмите кнопку Открыть.
  10. Нажмите кнопку OK .
На уровень выше: Администрирование обновлений продуктов с помощью пакетов обновления


Workgroup PDM

Приложение Workgroup PDM – это программное обеспечение управления данными о продукции, которое используется в среде SolidWorks или как отдельное приложение в Проводнике SolidWorks. Программа Workgroup PDM позволяет управлять проектами с помощью процедур разрегистрации, регистрации, контроля редакции, а также других администрирующих задач.

Иллюстрация системы Workgroup PDM

  • Отдельная машина может содержать только одно хранилище.
  • Каталог хранилища не может находиться в скрытом каталоге или каталоге, доступном только для чтения.
  • Работа Workgroup PDM, приложения клиент-сервер, зависит от надежности сети.
  • При большом количестве документов у пользователей производительность будет улучшена, если создать больше проектов и подпроектов с меньшим количеством документов, вместо того чтобы хранить эти документы в небольшом количестве проектов с большим количеством документов.

Установка

  • Можно установить клиентов, а также VaultAdmin, API и Viewer на том же компьютере, что и хранилище, или на других компьютерах.
  • Для установки клиентского интерфейса программирования приложений (API) установка сервера Workgroup PDM не требуется. Клиентский API устанавливается во время установки клиента Workgroup PDM.
  • Чтобы сконфигурировать папку хранилища на удаленном компьютере, введите полный путь в формате Universal Naming Convention (UNC) при появлении запроса о месторасположении сервера. (Для получения дополнительной информации см. раздел Формат UNC.)
  • Установка или обновление хранилища требует перезагрузки компьютера.
  • Если служба сервера Workgroup PDM не запустится автоматически после перезагрузки, необходимо запустить ее вручную. В Проводнике Windows запустите файл pdmwvault.exe, который находится в папке каталог_установки\SolidWorks Workgroup PDM\Vault.
  • При установке клиента Workgroup PDM необходимо запустить файл solidworksexplorer.exe на каждом компьютере. Этот исполняемый файл может находиться на совместно используемом устройстве. Хранилище Workgroup PDM, программа просмотра, клиентский API и VaultAdmin устанавливаются не на каждом компьютере.

Лицензии

  • Лицензия для Workgroup PDM API включена в лицензии клиентов SolidWorks и Explorer. Для регистрации API требуются клиентские лицензии.
  • Для включения программы просмотра Workgroup PDM Viewer необходимо установить ее лицензию вместе с хранилищем.

Разрешения

  • Администратор хранилища должен обладать правом на запись для установки и для папки хранилища.
  • Администратор хранилища должен управлять папкой хранилища посредством VaultAdmin, а не Проводником Windows.
  • Пользователи не должны иметь право на запись для папки хранилища в Проводнике Windows.

Безопасность, порты и совместная настройка

  • Для Workgroup PDM должна быть возможность установки в качестве службы Windows, чтобы другие приложения не могли блокировать или фильтровать службу. Например, если средства защиты от шпионских программ, такие как Microsoft AntiSpyware, выдают предупреждение, требующее подтверждения в процессе установки, нажмите Разрешить, чтобы сервер Workgroup PDM был установлен в качестве службы Windows.
  • Для установки Workgroup PDM в системе Windows XP с пакетом обновления 2, в сервере Windows 2003 с пакетом обновления 1 или на компьютере с активным брандмауэром, необходимо отметить порты Workgroup PDM как исключения в настройке брандмауэра.

    Обычно это следующие порты:

    • 20000 (VaultAdmin);
    • 30000 (Данные);
    • 40000 (Запрос);
    • 80 (Программа просмотра).
    Для получения информации об изменении настроек портов см. раздел Поиск и устранение неисправностей для администраторов хранилища в справке Workgroup PDM и SolidWorks Explorer, а также в справке Windows для центра обеспечения безопасности. Для одновременной установки хранилища Workgroup PDM и программы просмотра выберите параметр Настройка пользователя в диалоговом окне Тип установки.
  • Совместная настройка серверов и соответствующих им портов должна быть одинаковой; например: оба могут пользоваться параметром 100MB Полная или Auto.

Документы SolidWorks Toolbox

Документы SolidWorks Toolbox являются общими аппаратными компонентами, для которых обычно не требуется контроль редакций и разрегистрация в хранилище Workgroup PDM. Для получения дополнительной информации о настройке SolidWorks Toolbox и других стандартных библиотек см. оперативную справку Workgroup PDM.

  • Программа Workgroup PDM Viewer
    Во время выполнения установки с помощью служб IIS (Microsoft Internet Information Services) программное обеспечение Workgroup PDM автоматически настраивает виртуальный каталог.
  • Установка сервера Workgroup PDM
    При установке сервера Workgroup PDM создается хранилище Workgroup PDM, являющееся базой данных, в которой хранятся управляемые проекты SolidWorks.
  • Настройка Workgroup PDM для клиентов
    После установки хранилища сервера Workgroup PDM можно настроить его на клиентских компьютерах.
  • Установка сервера и Viewer Workgroup PDM в сети периметра
    Установка SolidWorks Workgroup PDM Веб-сервера и Workgroup PDM Viewer в сети периметра (DMZ) влияет на брандмауэр.
  • Доступ к Workgroup PDM с клиентского компьютера
    Клиенты Workgroup PDM используют такое же управление входом, как и в системе Microsoft Windows, имеют доступ к веб-узлу через программу просмотра Workgroup PDM Viewer и автоматически обновляются всякий раз при обновлении хранилища Workgroup PDM.
  • Администрирование Workgroup PDM VaultAdmin
    После установки Workgroup PDM администраторы хранилища должны выполнить следующие действия.


Программа Workgroup PDM Viewer

Во время выполнения установки с помощью служб IIS (Microsoft Internet Information Services) программное обеспечение Workgroup PDM автоматически настраивает виртуальный каталог.

Необходимо установить службы IIS (Microsoft Internet Information Services) до установки Viewer.
Требуются следующие компоненты:
  • Веб-средства управления
    • Консоль управления IIS
  • Службы World Wide Web: Компоненты разработки приложений
    • Расширяемость .NET
    • ASP.NET
    • CGI
    • Расширения ISAPI
    • Фильтры ISAPI
См. инструкции по установке IIS в документации Microsoft.
Установка программы Workgroup PDM Viewer подпадает под действие следующих ограничений.
  • Каталог содержания Web-узла является папкой установки Viewer.
  • Нельзя использовать символы с подчеркиваниями в имени хост-компьютера Viewer.
  • При установке Viewer в системе Windows XP с пакетом обновления 2 необходимо включить порт в брандмауэре Windows для HTTP (порт 80).
  • Viewer может указывать только на одно хранилище.

Для доступа к программе Workgroup PDM Viewer пользователи вводят следующий URL-адрес в поле адреса обозревателя Internet Explorer:

http://ViewerComputerName/pdmweb/.

На уровень выше: Workgroup PDM


Установка сервера Workgroup PDM

При установке сервера Workgroup PDM создается хранилище Workgroup PDM, являющееся базой данных, в которой хранятся управляемые проекты SolidWorks.

  1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
  2. На экране Добро пожаловать выберите следующее:

    • Сервер
    • Установить сервер SolidWorks Workgroup PDM (хранилище) на этом компьютере.

  3. На экране Сводка нажмите кнопку Изменить, чтобы получить код проверки. Ниже описываются способы получения кода проверки.
    • Подключение к Интернету
      1. В предоставленных полях введите серийный номер SolidWorks и адрес электронной почты.
      2. Выберите Проверить автоматически и нажмите кнопку Получить код.
    • Эл. почта
      1. Если компьютер не подключен к Интернету, выберите Проверить вручную по эл. почте. Менеджер установки создаст файл запроса проверки.
      2. Нажмите кнопку Сохранить, чтобы сохранить файл локально в системе.
      3. Выполните инструкции на экране и введите код проверки.
  4. Нажмите Назад в Сводку.
  5. На экране "Сводка" нажмите кнопку Установить сейчас.
На уровень выше: Workgroup PDM


Настройка Workgroup PDM для клиентов

После установки хранилища сервера Workgroup PDM можно настроить его на клиентских компьютерах.

  1. Войдите в VaultAdmin (устанавливается вместе с SolidWorks Explorer), используя имя пользователя и пароль по умолчанию.
  2. В VaultAdmin настройте учетные записи пользователей и групп, папки проектов, разрешения и т. д.

    Инструкции см. в документе Справка Workgroup PDM.

  3. Пошлите по электронной почте клиентам имя компьютера сервера и их имена пользователей и пароли, которые обычно отличаются от имен пользователей и паролей, используемых для входа в систему Microsoft Windows.
  • Настройка программы Workgroup PDM Viewer с целью подключения к другой папке хранилища
    С помощью реестра Windows можно настроить программу Workgroup PDM Viewer для подключения к другой папке хранилища.
  • Настройка типов электронной корреспонденции для загрузки документов
    С помощью настроек реестра Windows можно настроить тип электронной корреспонденции для загрузки документов.
На уровень выше: Workgroup PDM


Настройка программы Workgroup PDM Viewer с целью подключения к другой папке хранилища

С помощью реестра Windows можно настроить программу Workgroup PDM Viewer для подключения к другой папке хранилища.

  1. Обновите путь реестра путем изменения значения параметра Компьютер хранилища:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Переустановите программу Workgroup PDM Viewer. В диалоговом окне Имя компьютера хранилища введите имя нового компьютера.
На уровень выше: Настройка Workgroup PDM для клиентов


Настройка типов электронной корреспонденции для загрузки документов

С помощью настроек реестра Windows можно настроить тип электронной корреспонденции для загрузки документов.

По умолчанию программа Viewer отправляет запросы на открытие документа с помощью электронной корреспонденции типа «application/octet-stream». После этого Microsoft Internet Explorer открывает запрашиваемый документ с указанным расширением файла. Можно включить отображение дополнительных типов электронной корреспонденции или отключить отображение типов, изменив подключ реестра типов электронной корреспонденции в реестре Windows.

  • Для отображения дополнительных типов электронной корреспонденции создайте дополнительные строки под подключом реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    в виде:

    «ext» = «mime type»

    Пример:

    «dxf» = «image/vnd.dxf»

    Этот подключ реестра необходимо создать перед добавлением хранилищ.

    Для отключения отображения типов электронной корреспонденции измените на 0 (ноль) значение реестра Use Custom MIME Types (Использовать типы электронной корреспонденции, настроенные пользователем).

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Повторный запуск web-сервера не требуется для активации этой настройки.

На уровень выше: Настройка Workgroup PDM для клиентов


Установка сервера и Viewer Workgroup PDM в сети периметра

Установка SolidWorks Workgroup PDM Веб-сервера и Workgroup PDM Viewer в сети периметра (DMZ) влияет на брандмауэр.

Т.к. клиенты Workgroup PDM Viewer обращаются к веб-серверу посредством портов HTTP или HTTPS, эти порты должны быть открыты в системе Internet Information Server (IIS), где установлен веб-сервер.

  • Для протокола HTTP порт по умолчанию - 80.
  • Для протокола HTTPS (SSL) порт по умолчанию - 443.

Клиенты Viewer не нуждаются в исключении брандмауэра.

Необходимо убедиться, что система Веб-сервера может обратиться к серверу хранилища посредством следующих портов:

  • 30000 (Данные);
  • 40000 (Запрос);
  • Сетевая конфигурация для Workgroup PDM Viewer в сети периметра
    Сетевая конфигурация иллюстрирует настройку сервера в подсети периметра и его связь с внутренними и внешними сетями.
  • Установка и конфигурация Веб-сервера и Viewer Workgroup PDM
    При настройке Веб-сервера Workgroup PDM в сети периметра важны месторасположения установки компонентов.
На уровень выше: Workgroup PDM


Сетевая конфигурация для Workgroup PDM Viewer в сети периметра

Сетевая конфигурация иллюстрирует настройку сервера в подсети периметра и его связь с внутренними и внешними сетями.

Сетевой сервер в сети периметра связывается с LAN посредством внутреннего брандмауэра. Он связывается с внешней сетью посредством внешнего брандмауэра, роутера и системы балансировки нагрузки.

Клиент Internet Explorer связывается с сервером Workgroup PDM Viewer/IIS посредством порта 80 (или 443 при использовании SSL). Workgroup PDM Viewer затем связывается с сервером хранилища посредством портов 30000 или 40000. Сервер хранилища посылает запрошенную информацию в Workgroup PDM Viewer, который в свою очередь передает эту информацию клиенту Internet Explorer.

Веб-сервер в сети периметра имеет два IP-адреса:

  • Внутренний IP-адрес в LAN
  • Общий IP-адрес, назначаемый поставщиком услуг Интернета

Веб-сервер в сети периметра расположен после системы балансировки нагрузки. Несмотря на то, что Вы можете напрямую обращаться к веб-серверу для выполнения административных задач, весь поток услуг сервера в сети периметра обрабатывается системой балансировки нагрузки.

Система балансировки нагрузки переводит IP-адрес оборудования сервера в виртуальный IP (VIP) в части сети, видимой для внешних пользователей. При просмотре VIP или URL веб-сервера, находясь в сети, Вы можете увидеть веб-сайт.

Внешний брандмауэр переводит VIP системы балансировки нагрузки в общий адрес.

На уровень выше: Установка сервера и Viewer Workgroup PDM в сети периметра


Установка и конфигурация Веб-сервера и Viewer Workgroup PDM

При настройке Веб-сервера Workgroup PDM в сети периметра важны месторасположения установки компонентов.
  • Установите поддерживающий IIS веб-сервер в подсети периметра.
  • Установите поддерживающий IIS Workgroup PDM Viewer в подсети периметра.
  • Установите хранилище Workgroup PDM в главном домене или внутренней сети в локальной сети.

Требования к установке и конфигурации Workgroup PDM Viewer в сети периметра:

  • Microsoft IIS 6.0 или новее
  • Общий IP-адрес для веб-сервера в подсети периметра, назначенный поставщиком услуг Интернета

Чтобы установить и сконфигурировать компоненты Workgroup PDM:

  1. Установите Microsoft IIS в сети периметра системы сервера.
  2. Выполните две установки сервера SolidWorks Workgroup PDM:
    1. Сначала установите компонент хранилища на сервере хранилища.
    2. Запустите программу установки во второй раз и установите Workgroup PDM Viewer и компоненты лицензии Viewer на веб-сервере IIS. Введите имя компьютера сервера хранилища, чтобы Веб-портал знал, куда обращаться для получения службы сервера хранилища.

    При проведении установки приложение PDMWeb автоматически добавляется в веб-сайт IIS по умолчанию.

  3. Убедитесь, что брандмауэр внутренней сети обладает открытыми портами 30000 и 40000.
  4. Если внутренний сервер обладает зафиксированным IP-адресом на системе сервера в сети периметра, отредактируйте файл C:\Windows\system32\drivers\etc\hosts. Создайте системное имя для сопоставления с IP-адресом, чтобы сервер в сети периметра могут связываться с внутренним сервером:
    1. Откройте файл hosts в текстовом редакторе, таком как Блокнот.
    2. Добавьте новую строку для IP-адреса и имени сервера хранилища.
    3. Сохраните файл hosts.
На уровень выше: Установка сервера и Viewer Workgroup PDM в сети периметра


Доступ к Workgroup PDM с клиентского компьютера

Клиенты Workgroup PDM используют такое же управление входом, как и в системе Microsoft Windows, имеют доступ к веб-узлу через программу просмотра Workgroup PDM Viewer и автоматически обновляются всякий раз при обновлении хранилища Workgroup PDM.

Чтобы войти в систему Workgroup PDM с клиентского компьютера, выполните следующие действия. | Имена и пароли пользователей клиентских компьютеров в Workgroup PDM отличаются от тех, которые используются для входа в систему Microsoft Windows. Свяжитесь со своим администратором системы для получения информации по входу.
Чтобы установить связь с программой Workgroup PDM, выполните следующие действия. | Обратитесь к вашему системному администратору для получения адреса URL для подсоединения с Viewer.
Для обновления клиентов Workgroup PDM выполните следующие действия. | Клиенты Workgroup PDM (приложение SolidWorks и Contributor) определяют время обновления хранилища. Для обновления клиентов пакет обновления загружать не требуется.
На уровень выше: Workgroup PDM


Администрирование Workgroup PDM VaultAdmin

После установки Workgroup PDM администраторы хранилища должны выполнить следующие действия.

  • Войти в VaultAdmin.
  • Изменить пароль администратора хранилища.
  • Создать учетные записи пользователей.
  • Сообщить клиентам их учетные записи и пароли.

Дополнительные сведения см. раздел SolidWorks Workgroup PDM в главной справке SolidWorks.

  • Инициация входа в Workgroup PDM VaultAdmin
    Во время первого входа в программу Workgroup PDM VaultAdmin, укажите имя и пароль администратора Workgroup PDM, а также имя компьютера, на котором находится хранилище Workgroup PDM.
  • Обновление сервера хранилища Workgroup PDM
    Обновление сервера хранилища Workgroup PDM можно выполнить несколькими способами, а именно: с помощь функции Проверить наличие обновлений SolidWorks; используя установочный DVD-диск SolidWorks; а также с помощью файла обновления Workgroup PDM, вручную загрузив его в локальную папку.
  • Обновление клиентов Workgroup PDM
    Клиенты должны обновить установку при первом входе в хранилище после того, как хранилище было обновлено. Для обновлений клиентов пакет обновления не требуется.
На уровень выше: Workgroup PDM


Инициация входа в Workgroup PDM VaultAdmin

Во время первого входа в программу Workgroup PDM VaultAdmin, укажите имя и пароль администратора Workgroup PDM, а также имя компьютера, на котором находится хранилище Workgroup PDM.

  1. В Windows выберите Пуск > Все программы > SolidWorks(версия) > Workgroup PDM VaultAdmin.
  2. В диалоговом окне введите следующие данные.

    Имя | pdmwadmin
    Пароль | pdmwadmin
    Компьютер хранилища | Имя хоста компьютера, на котором установлено хранилище. Если запуск программы VaultAdmin осуществляется на компьютере, на котором установлено хранилище, введите localhost.

  3. Нажмите Вход.
В целях безопасности рекомендуем изменить пароль для администратора как можно скорее. Выберите вкладку Пользователи и группы в VaultAdmin.
На уровень выше: Администрирование Workgroup PDM VaultAdmin


Обновление сервера хранилища Workgroup PDM

Обновление сервера хранилища Workgroup PDM можно выполнить несколькими способами, а именно: с помощь функции Проверить наличие обновлений SolidWorks; используя установочный DVD-диск SolidWorks; а также с помощью файла обновления Workgroup PDM, вручную загрузив его в локальную папку.

Можно установить только одну версию сервера хранилища Workgroup PDM.
  1. Попросите всех пользователей выйти из хранилища и затем заблокируйте его.
  2. Создать резервную копию данных хранилища.
  3. Для удаления текущей версии сервера Workgroup PDM в панели управления Microsoft Windows выберитеУстановка и удаление программ.
  4. Установите новую версию сервера Workgroup PDM.
    • Чтобы настроить проверку на наличие обновлений SolidWorks, выполните следующие действия.
      1. В Windows выберите Пуск > Все программы > Менеджер установки SolidWorks > Проверить наличие обновлений.
      2. В диалоговом окне Доступные более новые версии выберите параметр Загрузить и установить новую версию, укажите версию для установки и нажмите на кнопку Далее.

        Происходит загрузка новой версии Менеджера установки SolidWorks и ее запуск.

    • Чтобы выполнить обновление с помощью установочного DVD-диска, вставьте его в дисковод и следуйте инструкциям Менеджера установки SolidWorks.
    • Чтобы выполнить обновление сервера Workgroup PDM с помощью вручную загруженных установочных файлов Workgroup PDM(pdmwserver.exe), дважды нажмите необходимый файл и следуйте дальнейшим инструкциям.
  5. Используйте программу SolidWorks Task Scheduler для обновления файлов Workgroup PDM в хранилище.
  6. Разблокируйте хранилище и известите пользователей, что они могут далее его использовать.
На уровень выше: Администрирование Workgroup PDM VaultAdmin


Администрирование лицензий

После завершения установки можно активировать лицензии SolidWorks двумя способами: активировав отдельные компьютеры (активация лицензии) или установив и активировав плавающие сетевые лицензии на сервере (лицензии SolidNetWork).

Как правило, для установки на отдельные компьютеры выполняется активация лицензий; однако программное обеспечение можно установить отдельно и затем управлять лицензиями с помощью Менеджера лицензий SolidNetWork. И наоборот, несмотря на то, что крупные пользователи обычно используют плавающие сетевые лицензии, можно применить установки с администрирующих образов, а затем активировать серийные номера с индивидуальных компьютеров.

  • Администрирование индивидуальных лицензий
    Как правило, процедура администрирования индивидуальных лицензий состоит из активации и переноса лицензий непосредственно из SolidWorks.
  • Администрирование лицензий с помощью Менеджера лицензии SolidNetWork
    Менеджер лицензий SolidNetWork поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.


Администрирование индивидуальных лицензий

Как правило, процедура администрирования индивидуальных лицензий состоит из активации и переноса лицензий непосредственно из SolidWorks.

Активация – это процесс лицензирования и регистрации автономных лицензий SolidWorks (не лицензий SolidNetWork). Обычно, если лицензия на продукт не активирована, программа SolidWorks предпринимает попытку активировать ее при запуске продукта.

Можно выполнить перенос индивидуальных лицензий, выбрав Справка > Перенести лицензии в программе SolidWorks.

  • Активация лицензии
    Прежде чем запустить продукт SolidWorks на отдельном компьютере, необходимо активировать лицензию для данного компьютера.
  • Перенос лицензии
    Чтобы перенести лицензию на новый или обновленный компьютер, сначала перенесите ее на сервер лицензионных ключей корпорации Dassault Systcmes SolidWorks, затем активируйте ее на другом компьютере.
На уровень выше: Администрирование лицензий


Активация лицензии

Прежде чем запустить продукт SolidWorks на отдельном компьютере, необходимо активировать лицензию для данного компьютера.

Для активации необходим доступ в Интернет или к электронной почте. После активации не требуется подключения к Интернету для использования продуктов SolidWorks. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • Активирует лицензии на все продукты SolidWorks.
  • Позволяет передачу лицензионных прав от одного компьютера к другому.
  • Позволяет установку и активацию продуктов SolidWorks на одном рабочем и одном домашнем компьютере.
  • может выполняться немедленно (рекомендуется) или в течение 30 дней после установки;
  • Отменяет необходимость использования аппаратных ключей защиты. Однако если вы пользуетесь предыдущими версиями продуктов SolidWorks, которые не используют процесс активации, вы должны использовать ключ аппаратной защиты.

Системные администраторы, имеющие дело с несколькими серийными номерами, могут использовать Редактор параметров администрирующего образа. Для получения дополнительной информации см. раздел Редактор параметров администрирующего образа.

Чтобы активировать лицензию:

  1. Запустите программу SolidWorks.
  2. Запустите функцию SolidWorks Product Activation одним из перечисленных ниже способов.
    • Если лицензия для данного компьютера еще не активирована, при запуске программы SolidWorks автоматически отобразится окно Активация продукта SolidWorks.
    • Если окно Активация продукта SolidWorks не отображается автоматически, начните активацию, выбрав Справка > Активировать лицензии.
  3. Щелкните список Продукт, чтобы указать продукт, лицензию для которого требуется активировать.
  4. Укажите метод активации через Интернет или вручную с использованием электронной почты.
  5. Укажите адрес своей электронной почты.
  6. Для продолжения нажмите кнопку Далее.
    • Активация через Интернет: Активация выполняется автоматически.
    • Эл. почта: Нажмите кнопку Сохранить, чтобы создать файл запроса, а затем отправьте его на адрес электронной почты activation@solidworks.com. Получив сообщение электронной почты с файлом ответа, извлеките файл из сообщения и нажмите Открыть, чтобы загрузить его.
      При необходимости можно закрыть файл и повторно запустить процедуру активации, чтобы открыть файл ответа.
  7. Нажмите кнопку Готово.
На уровень выше: Администрирование индивидуальных лицензий


Перенос лицензии

Чтобы перенести лицензию на новый или обновленный компьютер, сначала перенесите ее на сервер лицензионных ключей корпорации Dassault Systcmes SolidWorks, затем активируйте ее на другом компьютере.

Если не удалось перенести лицензию на сервер Dassault Systcmes SolidWorks Corporation (например, из-за сбоя жесткого диска), во многих случаях можно выполнить повторную активацию. Если это не так, обратитесь к вашему реселлеру за помощью.

Чтобы перевести лицензию на сервер:

  1. В программе SolidWorks выберите Справка > Перенести лицензии и следуйте инструкциям.
  2. Чтобы повторно активировать лицензию, перейдите на новый или обновленный компьютер и активируйте лицензию, выполнив ту же последовательность действий, что и для исходной активации. Для получения дополнительной информации см. раздел Активация лицензии.
На уровень выше: Администрирование индивидуальных лицензий


Администрирование лицензий с помощью Менеджера лицензии SolidNetWork

Менеджер лицензий SolidNetWork поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

На данном рисунке проиллюстрирован обычный процесс установки лицензии SolidNetWork.

На данном рисунке отображается:
  • Установка и активация программы Менеджер лицензий SolidNetWork выполняются только на компьютере, предназначенном для установки этого приложения.
  • На клиентских компьютерах специальное дополнительное программное обеспечение SolidNetWork не устанавливается.

    Если при установке указан серийный номер лицензии SolidNetWork, Менеджер установки SolidWorks идентифицирует этот компьютер как лицензионного клиента SolidNetWork. Менеджер установки SolidWorks выводит запрос на имя компьютера с установленным Менеджером лицензий SolidNetWork и номер порта для подключения клиентского компьютера к данному компьютеру.

  • Менеджер лицензии и все лицензионные клиенты должны иметь возможность взаимодействия с протоколами TCP/IP (Transmission Control Protocol/Internet Protocol).
  • Активация лицензии SolidNetWork
    Прежде чем запустить продукт SolidWorks на отдельном компьютере, следует активировать лицензию SolidNetWork на компьютере с установленным Менеджером лицензий SolidNetWork.
  • Перенос лицензии SolidNetWork
    Чтобы перенести лицензию на новый или обновленный компьютер, сначала перенесите ее на сервер лицензионных ключей корпорации Dassault Systcmes SolidWorks, затем активируйте ее на другом компьютере.
  • Установка и настройка лицензии SolidNetWork
    Процедура настройки лицензии SolidNetWork состоит из установки Менеджера лицензий SolidNetWork на компьютер, предназначенный для установки этого приложения, и последующей установки программы SolidWorks на клиентские компьютеры посредством ввода серийного номера лицензии SolidNetWork.
  • Администрирование лицензии SolidNetWork
    В задачи администрирования входят запуск, обновление, удаление и управление лицензией, а также получение, заимствование и возврат лицензий.
На уровень выше: Администрирование лицензий


Активация лицензии SolidNetWork

Прежде чем запустить продукт SolidWorks на отдельном компьютере, следует активировать лицензию SolidNetWork на компьютере с установленным Менеджером лицензий SolidNetWork.

Для активации необходим доступ в Интернет или к электронной почте. После активации не требуется подключения к Интернету для использования продуктов SolidWorks. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • активирует Менеджер лицензий SolidNetWork программы SolidWorks с лицензиями SolidNetWork для всех продуктов SolidWorks;
  • позволяет переносить лицензионные права SolidNetWork с одного компьютера, на котором установлен Менеджер лицензий SolidNetWork, на другой;
  • позволяет устанавливать и активировать лицензионные права SolidNetWork на одном компьютере с установленным Менеджером лицензий SolidNetWork;
  • должен быть выполнен до использования лицензий SolidNetWork;
  • Отменяет необходимость использования аппаратных ключей защиты. При активации лицензии SolidNetWork для данной версии программы SolidWorks выполняется активация лицензий SolidNetWork для предыдущих версий SolidWorks. (Сохранять аппаратный ключ больше не требуется.)

Чтобы активировать лицензию SolidNetWork, выполните следующие действия.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork.
  2. Если лицензия SolidNetWork еще не активирована, появится запрос на активацию данной лицензии. Нажмите Да, чтобы активировать лицензию.
  3. В разделе Как вы хотите активировать? выберите Автоматически через Интернет (рекомендуется).
  4. В разделе Контактная информация укажите адрес электронной почты.
В диалоговом окне Активация/реактивация выполнена отобразятся активированные продукты.
На уровень выше: Администрирование лицензий с помощью Менеджера лицензии SolidNetWork


Перенос лицензии SolidNetWork

Чтобы перенести лицензию на новый или обновленный компьютер, сначала перенесите ее на сервер лицензионных ключей корпорации Dassault Systcmes SolidWorks, затем активируйте ее на другом компьютере.

Если не удалось перенести лицензию на сервер Dassault Systcmes SolidWorks Corporation (например, из-за сбоя жесткого диска), во многих случаях можно выполнить повторную активацию. Если это не так, обратитесь к вашему реселлеру за помощью.

Чтобы вернуть лицензию SolidNetWork на сервер, выполните следующие действия.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).

  2. В разделе Лицензионная информация выберите Изменить. Начнется запуск Помощника активации продуктов SolidWorks.
  3. В разделе Что необходимо сделать? выберите Перенос лицензии на программное обеспечение и нажмите кнопку Далее.
  4. В разделе Как вы хотите перенести? выберите Автоматически через Интернет (рекомендуется).
  5. В разделе Контактная информация укажите адрес электронной почты.
  6. Нажмите кнопку Далее. Выполняется перенос лицензии на продукт.
На уровень выше: Администрирование лицензий с помощью Менеджера лицензии SolidNetWork


Установка и настройка лицензии SolidNetWork

Процедура настройки лицензии SolidNetWork состоит из установки Менеджера лицензий SolidNetWork на компьютер, предназначенный для установки этого приложения, и последующей установки программы SolidWorks на клиентские компьютеры посредством ввода серийного номера лицензии SolidNetWork.

  • Установка и активация Менеджера лицензий
    Менеджер лицензий SolidNetWork поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.
  • Установка лицензионного клиента
    При установке программы SolidWorks на клиентских компьютерах серийный номер лицензии SolidNetWork указывает на то, что компьютер является лицензионным клиентом SolidNetWork.
  • Установка менеджеров лицензий SolidNetWork перед установкой лицензионных клиентов
    Перед установкой лицензионных клиентов следует установить и настроить Менеджер лицензий SolidNetWork хотя бы на одном компьютере.
  • Установка Менеджера лицензий для системы из трех компьютеров
    Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.
  • Использование SolidNetWork с брандмауэрами
    Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork.
На уровень выше: Администрирование лицензий с помощью Менеджера лицензии SolidNetWork


Установка и активация Менеджера лицензий

Менеджер лицензий SolidNetWork поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.

При обновлении предыдущей версии Менеджера лицензий SolidNetWork, использовавшей аппаратные ключи для активации лицензии, удалите аппаратный ключ перед установкой новой версии Менеджера лицензий SolidNetWork.

  1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
    1. В качестве типа установки выберите

      • Серверные продукты
      • Установка Менеджера лицензий SolidNetWork (распределение лицензий) на этом компьютере

    2. На странице Параметры Менеджера лицензий SolidNetWork укажите серийный номер лицензии SolidNetWork и каталог установки Менеджера лицензий SolidNetWork.
    3. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SolidWorks.
  2. Чтобы активировать лицензию SolidNetWork:
    1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
    2. При запросе на активацию нажмите Да.
    3. На странице Сведения о сервере лицензий SolidNetWork:

      • Если в вашей организации используется брандмауэр, выберите На этом сервере запущен брандмауэр.

        Для получения дополнительной информации см. раздел Использование SolidNetWork с брандмауэрами.

      • Для параметра Номер порта (а также для параметра Номера порта демона поставщика, если используется брандмауэр) выберите значение по умолчанию или укажите номера портов, используемые в вашей компании.
        Номер порта должен представлять собой номер порта TCP/IP в диапазоне 1024-60000 и должен использоваться исключительно только в этом процессе. Обычно подходит значение по умолчанию (25734), и оно наверняка не будет совпадать ни с каким значением из используемых в процессах сервера FLEXnet, запущенных в данный момент на компьютере с Менеджером лицензии.

    4. На странице Активация продуктов SolidWorks:

      • Выберите метод с использованием Интернета или электронной почты.
      • Укажите адрес своей электронной почты.
      • Для продолжения нажмите кнопку Далее.
        • Активация через Интернет: Активация выполняется автоматически.
        • Эл. почта: Нажмите кнопку Сохранить, чтобы создать файл запроса, а затем отправьте его на адрес электронной почты activation@solidworks.com. Получив сообщение электронной почты с файлом ответа, извлеките файл из сообщения и нажмите Открыть, чтобы загрузить его.
          При необходимости можно закрыть файл и повторно запустить процедуру активации, чтобы открыть файл ответа.

  3. Нажмите кнопку Готово.
На уровень выше: Установка и настройка лицензии SolidNetWork


Установка лицензионного клиента

При установке программы SolidWorks на клиентских компьютерах серийный номер лицензии SolidNetWork указывает на то, что компьютер является лицензионным клиентом SolidNetWork.

  1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
  2. На странице приветствия выберите Индивидуальная установка (на этом компьютере), если данная основная версия программы SolidWorks на этом компьютере устанавливается впервые.

    Если выполняется обновление существующей версии и замена индивидуальной лицензии на лицензию SolidNetWork, выберите Изменить существующую индивидуальную установку (на этом компьютере). Для получения дополнительной информации см. раздел Обновление индивидуальной лицензии до лицензии SolidNetWork.

  3. При запросе на ввод серийного номера укажите серийный номер лицензии SolidNetWork.
  4. В диалоговом окне Добавление сервера вручную введите адрес Менеджера лицензий SolidNetWork:

    port@ComputerName

    Номер порта должен совпадать с номером порта компьютера, на котором установлен Менеджер лицензий. Значением по умолчанию является 25734 (как описано в разделе Установка и активация Менеджера лицензий).

    Менеджер установки SolidWorks попытается проверить, доступен ли компьютер с установленным Менеджером лицензий SolidNetWork. Если Менеджер лицензий не еще установлен, проверка невозможна; однако установку лицензионного клиента по-прежнему можно продолжить.

  5. Завершите установку SolidWorks, следуя инструкциям Менеджера установки SolidWorks.
На уровень выше: Установка и настройка лицензии SolidNetWork


Установка менеджеров лицензий SolidNetWork перед установкой лицензионных клиентов

Перед установкой лицензионных клиентов следует установить и настроить Менеджер лицензий SolidNetWork хотя бы на одном компьютере.

При установке серийного номера лицензии SolidNetWork Менеджер установки SolidWorks выводит запрос на ввод имени компьютера, на котором установлен Менеджер лицензий SolidNetWork, и номера порта, а затем пытается проверить эту информацию.

Если на указанном компьютере Менеджер лицензий не еще установлен, проверка информации невозможна. В данном случае ошибка проверки не указывает на то, верная ли информация о Менеджере лицензий предоставлена. Если же Менеджер лицензий установлен, ошибки проверки свидетельствуют о том, что предоставлена неверная информация о Менеджере лицензий.

На уровень выше: Установка и настройка лицензии SolidNetWork


Установка Менеджера лицензий для системы из трех компьютеров

Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.

Требования к использованию Менеджеров лицензий для системы из трех компьютеров:
  • наличие трех аппаратных ключей;
  • Менеджеры лицензий для системы из трех компьютеров следует устанавливать только на стабильно работающих компьютерах, которые не планируется часто отключать.
  • Три компьютера, на которых установлен Менеджер лицензий, должны быть установлены в одной подсети. Нельзя настраивать Менеджеры лицензий для системы из трех компьютеров с низкоскоростными или коммутируемыми линиями связи.
  • Системный администратор должен определять, когда работа компьютера, на котором установлен Менеджер лицензий, замедляется, и перезагружать его как можно скорее.
    Ситуация, когда работают два компьютера, на которых установлен Менеджер лицензий, сложнее, чем, когда работает только один компьютер, поскольку в данном случае присутствуют два уязвимых звена.
  • Установка исходного Менеджера лицензий для системы из трех компьютеров
    Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Далее описан процесс установки Менеджера лицензий SolidNetWork на первый компьютер системы из трех компьютеров.
  • Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров
    Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Далее описан процесс установки Менеджера лицензий SolidNetWork на второй и третий компьютеры системы из трех компьютеров.
На уровень выше: Установка и настройка лицензии SolidNetWork


Установка исходного Менеджера лицензий для системы из трех компьютеров

Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Далее описан процесс установки Менеджера лицензий SolidNetWork на первый компьютер системы из трех компьютеров.

  1. С помощью Менеджера установки SolidWorks установите Менеджер лицензий SolidNetWork на первый компьютер системы, предназначенный для установки этого приложения.
    1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
    2. В качестве типа установки выберите

      • Серверные продукты
      • Установка Менеджера лицензий SolidNetWork (распределение лицензий) на этом компьютере

    3. На странице Параметры Менеджера лицензий SolidNetWork укажите серийный номер лицензии SolidNetWork и каталог установки Менеджера лицензий SolidNetWork.
    4. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SolidWorks.
  2. С помощью Менеджера лицензий SolidNetWork выполните настройку исходного компьютера системы, предназначенного для установки Менеджера лицензий, следующим образом.
    1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
    2. Нажмите Нет.

      Появится вкладка Администрация сервера Менеджера лицензий SolidWorks SolidNetwork.

    3. В разделе Дополнительные параметры выберите пункт Параметры.

      Появится диалоговое окно Дополнительные параметры.

    4. В разделе Лицензионный режим сервера SolidNetWork выберите Использовать файл лицензии и нажмите кнопку OK.

      Диалоговое окно Дополнительные параметры закроется.

    5. В разделе Лицензионная информация выберите Изменить.

      Отобразится диалоговое окно Лицензионный помощник SolidNetWork.

    6. В разделе Тип сервера выберите Сервер-тройка и нажмите кнопку Далее.
    7. На панели информации о сервере убедитесь, что указанные имя компьютера, идентификатор ключа и номер порта для исходного компьютера с установленным Менеджером лицензий верны и нажмите кнопку Далее.

      Если на компьютере используется брандмауэр, необходимо задать дополнительные требования. Для получения дополнительной информации см. раздел Использование SolidNetWork с брандмауэрами.

    8. На странице Информация о партнерском сервере-тройке введите имя компьютера и идентификатор ключа для двух других компьютеров системы.

      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы будет недоступен.

    9. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork и открыть его.

      Лицензии отобразятся в окне Лицензионного помощника SolidNetWork.

    10. Нажмите кнопку Готово.
    11. Нажмите кнопку OK, чтобы закрыть Лицензионного помощника SolidNetWork, а затем нажмите Готово для выхода из Менеджера лицензий SolidNetWork.
На уровень выше: Установка Менеджера лицензий для системы из трех компьютеров


Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров

Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Далее описан процесс установки Менеджера лицензий SolidNetWork на второй и третий компьютеры системы из трех компьютеров.

Предполагается, что хотя бы один Менеджер лицензий для системы из трех компьютеров установлен на другом компьютере системы. Для получения дополнительной информации см. раздел Установка исходного Менеджера лицензий для системы из трех компьютеров.

  1. С помощью Менеджера установки SolidWorks установите Менеджер лицензий SolidNetWork на компьютер системы, предназначенный для установки данного приложения.
    1. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
    2. В качестве типа установки выберите

      • Серверные продукты
      • Установка Менеджера лицензий SolidNetWork (распределение лицензий) на этом компьютере

    3. На странице Параметры Менеджера лицензий SolidNetWork укажите серийный номер лицензии SolidNetWork и каталог установки Менеджера лицензий SolidNetWork.
    4. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SolidWorks.
  2. С помощью Менеджера лицензий SolidNetWork выполните настройку компьютера, предназначенного для установки Менеджера лицензий для системы из трех компьютеров, следующим образом.
    1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).

      Поскольку на данном компьютере запуск Менеджера лицензий SolidNetWork выполняется впервые, появится запрос на активацию.

    2. Нажмите Нет.

      Появится вкладка Администрация сервера Менеджера лицензий SolidWorks SolidNetwork.

    3. В разделе Дополнительные параметры выберите пункт Параметры.

      Появится диалоговое окно Дополнительные параметры.

    4. В разделе Лицензионный режим сервера SolidNetWork выберите Использовать файл лицензии и нажмите кнопку OK.

      Диалоговое окно Дополнительные параметры закроется.

    5. В разделе Лицензионная информация выберите Изменить.

      Отобразится диалоговое окно Лицензионный помощник SolidNetWork.

    6. В разделе Тип сервера выберите Сервер-тройка, Синхронизировать информацию сервера/лицензии и нажмите кнопку Далее.
    7. На панели информации о сервере убедитесь, что указанные имя компьютера, идентификатор ключа и номер порта для этого компьютера с установленным Менеджером лицензий верны и нажмите кнопку Далее.

      Если на компьютере используется брандмауэр, необходимо задать дополнительные требования. Для получения дополнительной информации см. раздел Использование SolidNetWork с брандмауэрами.

    8. На странице Информация о партнерском сервере-тройке введите имя компьютера и идентификатор ключа для двух других компьютеров системы.

      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы будет недоступен.

    9. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork и открыть его.

      Обычно лицензионный файл находится в папке \licenses\sw_d.lic первого компьютера с установленным Менеджером лицензий.

      Лицензии отобразятся в окне Лицензионного помощника SolidNetWork.

    10. Нажмите кнопку Готово.

      Отобразится предупреждающее диалоговое окно Лицензионный помощник SolidNetWork.

    11. Нажмите кнопку OK, чтобы закрыть Лицензионного помощника SolidNetWork, а затем нажмите Готово для выхода из Менеджера лицензий SolidNetWork.

Если выполняется настройка второго компьютера для установки Менеджера лицензий для системы из трех компьютеров, повторите эти действия для настройки третьего компьютера системы.

На уровень выше: Установка Менеджера лицензий для системы из трех компьютеров


Использование SolidNetWork с брандмауэрами

Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork.

В программе брандмауэра следует добавить два порта лицензии SolidNetWork (например, входной порт SNL и выходной порт SNL) в список исключений брандмауэра. Для получения дополнительной информации о настройке этих портов обратитесь к системному администратору.

Если брандмауэр Windows используется в операционных системах Windows XP SP2 и Windows Server 2003 SP1, следует изменить настройку портов на компьютере с установленным Менеджером лицензий, и изменить файл лицензии SolidNetWork для выдачи лицензий клиентским компьютерам.

  • Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows
    Если используется брандмауэр Windows, следует изменить настройки портов на компьютере с установленным Менеджером лицензий SolidNetWork.
  • Изменение настроек Менеджера лицензий SolidNetWork для брандмауэра Windows
    Если используется брандмауэр Windows, следует изменить файл лицензии, чтобы использовать порты брандмауэра для выдачи лицензий клиентским компьютерам.
На уровень выше: Установка и настройка лицензии SolidNetWork


Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows

Если используется брандмауэр Windows, следует изменить настройки портов на компьютере с установленным Менеджером лицензий SolidNetWork.

  1. В Windows откройте панель управления и дважды нажмите Центр безопасности.
  2. Выберите Брандмауэр Windows.
  3. На вкладке Исключения выберите Добавить порт.
  4. Введите имя (например, входной порт SNL) и номер порта (например, 25734), а затем нажмите кнопку OK.
  5. Для изменения настроек второго порта снова выберите Добавить порт на вкладке Исключения и укажите имя и номер этого порта (например, выходной порт SNL и 25735), а затем нажмите кнопку OK. Запомните номер порта, так как Вам придется указывать его при изменении файла лицензии SolidNetWork.

    Если используется приложение Workgroup PDM, следует изменить номера портов Workgroup PDM в брандмауэре Windows. Обычно это порты 20000 (VaultAdmin), 30000 (Данные), 40000 (Запрос) и 80 (Программа просмотра).

  6. Закройте диалоговое окно Центр обеспечения безопасности Windows и Панель управления.
На уровень выше: Использование SolidNetWork с брандмауэрами


Изменение настроек Менеджера лицензий SolidNetWork для брандмауэра Windows

Если используется брандмауэр Windows, следует изменить файл лицензии, чтобы использовать порты брандмауэра для выдачи лицензий клиентским компьютерам.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. На вкладке Администрация сервера в разделе Лицензионный сервер выберите Стоп. (При запросе на подтверждение нажмите Да, затем нажмите кнопку OK, чтобы выполнить остановку лицензионного сервера.)
  3. В разделе Лицензионная информация выберите Изменить.
  4. В разделе Тип сервера выберите тип организации серверов в сети (Один или Сервер-тройка) и нажмите кнопку Далее.
  5. В разделе Сведения о сервере:
    1. Выберите параметр На этом сервере используется брандмауэр.
    2. Номер порта и номер порта демона поставщика должны содержать номера портов, указанные для брандмауэра Windows (дополнительную информацию см. в разделе Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows).
    3. Нажмите кнопку Далее, затем нажмите Готово.
  6. На вкладке Администрация сервера в разделе Лицензионный сервер нажмите Пуск.
  7. Нажмите кнопку OK, чтобы закрыть Менеджер лицензий SolidNetWork.
На уровень выше: Использование SolidNetWork с брандмауэрами


Администрирование лицензии SolidNetWork

В задачи администрирования входят запуск, обновление, удаление и управление лицензией, а также получение, заимствование и возврат лицензий.

  • Запуск Менеджера лицензий SolidNetWork
    Менеджер лицензий SolidNetWork можно запустить в меню Пуск операционной системы Windows.
  • Обновление Менеджера лицензий SolidNetWork
    Обновление основных версий SolidWorks включает удаление устаревшей версии Менеджера лицензий, установку новой версии и повторную активацию лицензии SolidNetWork.
  • Удаление файлов лицензии SolidNetWork
    Перед обновлением удалите устаревшие лицензионные файлы и файлы лицензий SolidNetWork, срок действия которых истек.
  • Получение клиентских лицензий
    Чтобы прервать соединение SolidNetWork клиента, системный администратор может приостановить действие лицензии и вернуть ее в пул свободных лицензий.
  • Заимствование и возврат лицензий SolidNetWork
    Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.
  • Контроль времени простоя лицензии
    С помощью Менеджера лицензий SolidNetWork программа SolidWorks может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.
  • Установка временных лицензий
    Можно временно использовать «ЛЮБУЮ» временную лицензию, если исходная лицензия SolidNetWork недоступна.
  • Обновление индивидуальной лицензии до лицензии SolidNetWork
    Можно выполнить обновление компьютера с индивидуальной лицензии SolidWorks до лицензии SolidNetWork, указав серийный номер лицензии SolidNetWork в Менеджере установки SolidWorks.
  • Использование лицензий SolidNetWork с приложениями
    Можно также использовать Менеджер лицензий SolidNetWork для выдачи лицензий для основных приложений SolidWorks, например FeatureWorks, сервер Workgroup PDM и т.д.).
  • Установка Менеджера лицензий и администрирующего образа на одном компьютере
    Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SolidWorks.
  • Система управления лицензиями FLEXnet Publisher
    Лицензирование SolidNetWork основано на системе управления лицензиями FLEXnet Publisher®.
На уровень выше: Администрирование лицензий с помощью Менеджера лицензии SolidNetWork


Запуск Менеджера лицензий SolidNetWork

Менеджер лицензий SolidNetWork можно запустить в меню Пуск операционной системы Windows.

  • Выполните следующую команду в Windows: Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork.
На уровень выше: Администрирование лицензии SolidNetWork


Обновление Менеджера лицензий SolidNetWork

Обновление основных версий SolidWorks включает удаление устаревшей версии Менеджера лицензий, установку новой версии и повторную активацию лицензии SolidNetWork.

Менеджер лицензий для более новой версии программы также может выдавать лицензии для клиентских компьютеров, на которых установлена предыдущая версия программы.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. Проверьте на вкладке Использование лицензий, не используется ли программа SolidWorks на сетевых клиентских компьютерах.
  3. Удалите устаревшую версию Менеджера лицензий. Для получения дополнительной информации см. раздел Удаление Менеджера лицензий SolidNetWork.
  4. Установите новую версию Менеджера лицензий и активируйте лицензию SolidNetWork на компьютере с установленным Менеджером лицензий. Для получения дополнительной информации см. раздел Установка и активация Менеджера лицензий.

При обновлении Менеджера лицензий SolidNetWork на компьютере, на котором также используется приложение SolidWorks, перед установкой новых пакетов обновления для приложения SolidWorks на данный компьютер рекомендуется выполнить обновление Менеджеров лицензий и клиентов SolidNetWork.

При обновлении Менеджера лицензий на компьютере, на котором установлены администрирующие образы, перед обновлением администрирующих образов выполните обновление Менеджера лицензий. Для получения дополнительной информации см. раздел Установка Менеджера лицензий и администрирующего образа на одном компьютере.

  • Удаление Менеджера лицензий SolidNetWork
    При обновлении Менеджера лицензий SolidNetWork необходимо удалить устаревшую версию Менеджера лицензий перед установкой новой версии.
На уровень выше: Администрирование лицензии SolidNetWork


Удаление Менеджера лицензий SolidNetWork

При обновлении Менеджера лицензий SolidNetWork необходимо удалить устаревшую версию Менеджера лицензий перед установкой новой версии.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. Убедитесь, что ни на одном из сетевых клиентских компьютеров не используется программа SolidWorks.

    На вкладке Использование лицензий отображаются клиентские компьютеры, использующие SolidWorks.

  3. Если требуется перенести лицензию SolidWorks на другой компьютер, перенесите лицензию на этот компьютер до удаления Менеджера лицензий SolidNetWork.

    Для получения более подробной информации о переносе лицензий SolidNetWork см. раздел Перенос лицензии SolidNetWork.

  4. На вкладке Администрация сервера в разделе Лицензионный сервер выберите Стоп.
  5. Нажмите кнопку OK, чтобы выйти из Менеджера лицензий.
  6. В Windows выберите Панель управления > Установка и удаление программ.
  7. Выберите Менеджер лицензий SolidWorks SolidNetWork, нажмите кнопку Удалить и подтвердите удаление.
  8. В Проводнике Windows удалите папку Менеджер лицензий SolidWorks SolidNetWork.

    (Обычно эта папка находится в разделе Программные файлы в каталоге установки SolidWorks.)

Теперь можно установить новую версию Менеджера лицензий. Для получения дополнительной информации см. раздел Установка и активация Менеджера лицензий.

Если компьютер с Менеджером лицензий SolidNetWork обладает аппаратным ключом, извлеките аппаратный ключ перед установкой новой версии Менеджера лицензий SolidNetWork.
На уровень выше: Обновление Менеджера лицензий SolidNetWork


Удаление файлов лицензии SolidNetWork

Перед обновлением удалите устаревшие лицензионные файлы и файлы лицензий SolidNetWork, срок действия которых истек.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. На вкладке Администрация сервера в разделе Файл лицензии выберите Изменить, а затем нажмите Далее. Откроется страница Лицензии.
  3. На странице Лицензии выберите устаревший файл лицензии SolidNetWork или файл лицензии с истекшим сроком действия и нажмите кнопку Удалить.
  4. Нажмите кнопку Готово, затем нажмите кнопку OK.
На уровень выше: Администрирование лицензии SolidNetWork


Получение клиентских лицензий

Чтобы прервать соединение SolidNetWork клиента, системный администратор может приостановить действие лицензии и вернуть ее в пул свободных лицензий.

  • Клиент должен быть подключен к Менеджеру лицензий в течение как минимум двух минут.
  • Для функции перерыва в работе SolidNetWork можно задать минимальное значение 15 минут. После 15 минут простоя лицензия возвращается в пул свободных лицензий.

Для получения дополнительных сведений см. каталог_установки_Менеджера_лицензий_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

  1. Выберите Пуск > Выполнить, введите cmd и нажмите кнопку OK, чтобы открыть окно команд Windows.
  2. В окне команд введите:

    cd каталог_установки_Менеджера_лицензий_SolidNetWork\utils lmutil lmremove feature user computer display,

    где «feature», «user», «computer», «display» – условия, отображающиеся на вкладке Использование лицензий Менеджера лицензий SolidNetWork.

    Пример:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    Необходимо прекратить действие лицензии для каждого приложения (PhotoView 360, FeatureWorks и т.д.) по отдельности.

На уровень выше: Администрирование лицензии SolidNetWork


Заимствование и возврат лицензий SolidNetWork

Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

Заимствованные лицензии действительны только для системы, для которой они были получены; их нельзя переносить.

Лицензия предоставляется на период времени до 30 дней (или на срок, определенный системным администратором). На это время лицензия извлекается из пула свободных лицензий.

Системный администратор может настроить процесс заимствования, чтобы:
  • определить пользователей или группы, которым разрешено заимствовать лицензии;
  • задать число лицензий, которые невозможно заимствовать.

Для получения дополнительных сведений см. каталог_установки_Менеджера_лицензий_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

  • Заимствование лицензий SolidNetWork
    Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения.
  • Возврат заимствованной лицензии SolidNetWork
    Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.
На уровень выше: Администрирование лицензии SolidNetWork


Заимствование лицензий SolidNetWork

Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения.

Чтобы заимствовать лицензию (при этом не обязательно ее использовать), необходимо подключиться к Менеджеру лицензий SolidNetWork.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. На вкладке Заимствование лицензий выберите следующие элементы.
    1. Выберите дату в поле Заимствовать до.
    2. Выберите продукты для заимствования, затем нажмите на Заимствовать и нажмите на Да для подтверждения.
    3. Выберите Обновить. В столбке Срок истекает отображается дата, когда лицензии должны быть возвращены.
  3. Нажмите кнопку OK .
Чтобы запустить SolidWorks, необходимо заимствовать лицензию SolidWorks. SolidWorks Professional и SolidWorks Premium позволяют использовать приложения, связанные с пакетом, но не с SolidWorks.
На уровень выше: Заимствование и возврат лицензий SolidNetWork


Возврат заимствованной лицензии SolidNetWork

Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

  1. Запустите Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  2. На вкладке Заимствование лицензий выберите следующие элементы.
    1. Выберите продукты, лицензии на которые требуется вернуть, нажмите кнопку Вернуть, затем нажмите Да, чтобы подтвердить возврат.
    2. Выберите Обновить. Столбец Дата истечения становится пустым, что свидетельствует о том, что лицензия возвращена.
  3. Нажмите кнопку OK .
Лицензии, срок действия которых истек, возвращать необязательно. Лицензии будут возвращены в пул лицензий в Менеджере лицензий SolidNetWork в полночь даты истечения срока действия, с этого момента приложения для удаленной системы запускаться не будут.
На уровень выше: Заимствование и возврат лицензий SolidNetWork


Контроль времени простоя лицензии

С помощью Менеджера лицензий SolidNetWork программа SolidWorks может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.

  1. В каталоге установки Менеджера лицензий SolidNetwork создайте текстовый файл:

    каталог_установки_менеджера_лицензии_SolidNetWork\Licenses\sw_d.opt

  2. Добавьте следующую строку в файл:

    TIMEOUTALL секунды,

    где секунды – минимальное допустимое время, выраженное числом, большим или равным 900 (15 минут).

На уровень выше: Администрирование лицензии SolidNetWork


Установка временных лицензий

Можно временно использовать «ЛЮБУЮ» временную лицензию, если исходная лицензия SolidNetWork недоступна.

Устанавливая файл «ЛЮБОЙ» лицензии, пользователь подтверждает свое согласие на реализацию традиционной лицензии при получении лицензии SolidNetWork от корпорации Dassault Systèmes SolidWorks Corporation. Требуется соблюдать лицензионные ограничения.

Для установки «ЛЮБОЙ» лицензии выполните следующие действия.

  1. Если вы являетесь существующим пользователем SolidNetWork, отмените установку Менеджера лицензий SolidNetWork и удалите папку установки. Для получения дополнительной информации см. раздел Удаление Менеджера лицензий SolidNetWork.
  2. Запустите Менеджер установки SolidWorks (как описано в разделе Начало установки SolidWorks).
    1. В качестве типа установки выберите

      • Серверные продукты
      • Установка Менеджера лицензий SolidNetWork (распределение лицензий) на этом компьютере

    2. На странице Параметры Менеджера лицензий SolidNetWork укажите серийный номер лицензии SolidNetWork и каталог установки Менеджера лицензий SolidNetWork.
    3. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SolidWorks.
  3. Запустить Менеджер лицензий SolidNetWork (Пуск > Все программы > версия SolidWorks > Менеджер лицензий SolidNetWork > Менеджер лицензий SolidNetWork).
  4. При запросе на активацию нажмите Нет.

    Появится вкладка Администрация сервера Менеджера лицензий SolidWorks SolidNetwork.

  5. В разделе Дополнительные параметры выберите пункт Параметры.

    Появится диалоговое окно Дополнительные параметры.

  6. В разделе Лицензионный режим сервера SolidNetWork выберите Использовать файл лицензии и нажмите кнопку OK.

    Диалоговое окно Дополнительные параметры закроется.

  7. В разделе Лицензионная информация выберите Изменить.

    Отобразится диалоговое окно Лицензионный помощник SolidNetWork.

  8. В разделе Тип сервера выберите Один и нажмите кнопку Далее.
  9. Если отобразится сообщение

    Не удалось прочитать идентификатор ключа,
    нажмите кнопку Отмена.
    Идентификатор «ЛЮБАЯ» отображается автоматически.
    Если на компьютере используется брандмауэр, необходимо задать дополнительные требования. Для получения дополнительной информации см. раздел Использование SolidNetWork с брандмауэрами.

  10. Продолжите установку.
На уровень выше: Администрирование лицензии SolidNetWork


Обновление индивидуальной лицензии до лицензии SolidNetWork

Можно выполнить обновление компьютера с индивидуальной лицензии SolidWorks до лицензии SolidNetWork, указав серийный номер лицензии SolidNetWork в Менеджере установки SolidWorks.

Если программа SolidWorks на компьютере не установлена, можно указать лицензию SolidNetWork, введя серийный номер лицензии SolidNetWork при установке с помощью Менеджера установки SolidWorks.

Если программа SolidWorks установлена и выполняется обновление индивидуальной лицензии до лицензии SolidNetWork, можно изменить установку для клиентского компьютера и при запуске Менеджера установки SolidWorks вместо серийного номера индивидуальной лицензии указать серийный номер лицензии SolidNetWork. Для получения дополнительной информации см. раздел Изменение установки.

На уровень выше: Администрирование лицензии SolidNetWork


Использование лицензий SolidNetWork с приложениями

Можно также использовать Менеджер лицензий SolidNetWork для выдачи лицензий для основных приложений SolidWorks, например FeatureWorks, сервер Workgroup PDM и т.д.).

  • Равное количество лицензий SolidWorks и лицензий для приложений SolidWorks не требуется.
  • Чтобы получить лицензию на приложение, следует сначала получить лицензию на программу SolidWorks.
  • Чтобы заимствовать лицензию на приложение, необходимо заимствовать лицензию на программное обеспечение SolidWorks и лицензию на продукт SolidWorks, включающий данное приложение. Например, требуется заимствовать лицензию на продукт SolidWorks Professional или SolidWorks Premium.
  • Чтобы освободить лицензию на приложение, выполните следующие действия.
    • В программе SolidWorks выберите Инструменты > Приложения и освободите приложение.
    • Выйдите из программы SolidWorks.
На уровень выше: Администрирование лицензии SolidNetWork


Установка Менеджера лицензий и администрирующего образа на одном компьютере

Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SolidWorks.

Клиентские компьютеры могут получить лицензии из Менеджера лицензий и затем установить программу SolidWorks с компьютера, на котором он установлен.

Для выполнения этой настройки Менеджер лицензий и администрирующий образ должны быть установлены на одном компьютере. Сначала установите Менеджер лицензий, а затем создайте и разверните администрирующий образ.
Для получения дополнительной информации см.:
  • Установка и активация Менеджера лицензий
  • Внедрение на нескольких клиентах
На уровень выше: Администрирование лицензии SolidNetWork


Система управления лицензиями FLEXnet Publisher

Лицензирование SolidNetWork основано на системе управления лицензиями FLEXnet Publisher®.

Дополнительную информацию о системе управления лицензиями FLEXnet Publisher см. в Руководстве по администрированию лицензий в каталоге установки Менеджера лицензий SolidNetwork (SolidNetwork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf).

Для получения последней информации о системе управления лицензиями FLEXnet Publisher обратитесь к Acresso® Software.

На уровень выше: Администрирование лицензии SolidNetWork


Устранение неполадок

Ознакомление с этими темами поможет в выявлении и устранении проблем, связанных с установкой.

  • Файлы журнала Менеджера установки SolidWorks
    Файлы журнала Менеджера установки SolidWorks помогают выявлять и устранять проблемы, связанные с установкой.
  • Папка загрузки Менеджера установки SolidWorks
    Менеджер установки SolidWorks может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.
  • Устранение проблем, связанных с лицензиями SolidNetWork
    Если не удается установить Менеджер лицензий SolidNetWork, возможны следующие причины.
  • Устранение неполадок, возникающих при обновлении программы
    Если во время обновления программы SolidWorks до новой версии возникают проблемы, возможны следующие причины.


Файлы журнала Менеджера установки SolidWorks

Файлы журнала Менеджера установки SolidWorks помогают выявлять и устранять проблемы, связанные с установкой.

Эти файлы хранятся вместе с файлами журналов других приложений SolidWorks.
  • Для Windows Vista и новее:

    C:\Users\имя_пользователя\AppData\Roaming\SolidWorks\Installation Logs\установленная_версия

  • Для версий операционной системы Windows до Windows Vista:

    C:\Documents and Settings\имя_пользователя\Application Data\SolidWorks\Installation Logs\установленная_версия\

Чтобы просмотреть каталоги файлов журнала, необходимо настроить параметры папки Windows для отображения скрытых файлов и папок.

Если данные приложения находятся на диске, отличном от C:, настройте путь к каталогу соответствующим образом.

Этот каталог содержит файл SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, общий журнал работы Менеджера установки SolidWorks.

Более подробная информация о журнале установки содержится в подкаталоге Другие журналы.

На уровень выше: Устранение неполадок


Папка загрузки Менеджера установки SolidWorks

Менеджер установки SolidWorks может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.

  1. Как установить файлы в этой папке?
  2. Можно установить файлы MSI вручную из этой папки, используя msiexec или какую-либо другую программу?
  3. Можно ли выбирать одну и ту же папку загрузки для каждой устанавливаемой мной версии?
  4. Я выполнил(а) загрузку некоторых продуктов вручную с веб-узла корпорации Dassault Systèmes SolidWorks. Можно ли установить это с помощью Менеджера установки?
  5. Могут ли загруженные мною файлы использоваться другими пользователями?
  6. Как узнать, когда появится новая версия продуктов SolidWorks?
  7. В Менеджере установки отображаются только SW2006 или SW2007, но не текущая версия.
  8. Менеджер установки не разрешает выбор другого пакета обновления продукта для установки.
  9. В Менеджере установки нельзя загрузить файлы.
  10. Не все продукты SolidWorks обновлены до последнего пакета обновления, но функциональность Проверить наличие обновлений сообщает, что я использую новейшую версию.
  11. Можно ли скопировать DVD в папку загрузки?

Как установить файлы в этой папке?

Запустите setup.exe. Если выбрана установка элементов, которые не были загружены ранее, возможно, потребуется загрузить некоторые файлы.

Не следует выполнять установку с помощью msiexec (см. ниже).

К началу

Можно установить файлы MSI вручную из этой папки, используя msiexec или какую-либо другую программу?

Нет. С помощью Менеджера установки нельзя загрузить некоторые файлы, которые потребуются при запуске msiexec.

К началу

Можно ли выбирать одну и ту же папку загрузки для каждой устанавливаемой мной версии?

Загруженные папки относятся к определенной версии. Начиная с выпуска SolidWorks 2010, Менеджер установки SolidWorks автоматически создает в указанной папке подпапку, относящуюся к соответствующей версии.

К началу

Я выполнил(а) загрузку некоторых продуктов вручную с веб-узла корпорации Dassault Systèmes SolidWorks. Можно ли установить это с помощью Менеджера установки?

Начиная с SW2009, загруженные вручную файлы можно использовать с помощью Менеджера установки SolidWorks. Однако лучше запустить Менеджер установки SolidWorks, выбрав вариант для загрузки файлов. В Менеджере установки SolidWorks отображаются необходимые файлы на основе устанавливаемых продуктов с предоставлением ссылок для загрузки каждого файла. Этот вариант можно использовать, когда встроенная страница загрузки не работает (чаще всего по причине ограничений загрузки, установленных полномочным сервером).
Если Microsoft Internet Explorer запрашивает, требуется ли сохранить или запустить файлы во время загрузки или установки, всегда указывайте сохранение.

К началу

Могут ли загруженные мною файлы использоваться другими пользователями?

Да. Для этого загрузите файлы в общедоступный сетевой ресурс. Каждый клиент сможет запустить Менеджер установки SolidWorks с этого ресурса для проведения локальной установки.

Дальнейшая загрузка не потребуется пока пользователь не выберет несколько элементов для установки, которые не были выбраны ранее во время первоначальной установки, или если компьютер, с которого выполняется загрузка файлов для установки, имеет набор требований, отличный от набора требований компьютера, на который выполняется загрузка файлов.

Если Вы загружаете файлы для других пользователей, но не устанавливаете их, выберите параметр Только загрузить при установке. Этот параметр позволяет выбирать продукты вне зависимости от того, какие из них пользователь может установить на своем компьютере. Однако этот вариант нельзя использовать для загрузки пакетов или создания администрирующих образов.

К началу

Как узнать, когда появится новая версия продуктов SolidWorks?

Вы будете извещены о наличии новых версий в следующих случаях:
  • при запуске функции Проверить наличие обновлений (Пуск > Все программы > Менеджер установки SolidWorks > Проверить наличие обновлений);
  • при использовании Фонового загрузчика SolidWorks;
  • при выборе установленной версии SolidWorks в Windows Установка и удаление программ и нажатии кнопки Изменить;
  • при запуске более ранней версии Менеджера установки (sldIM.exe) из папки загрузки.
В этих случаях можно выбрать загрузку более новой версии. Будут выполнены загрузка и запуск более новой версии Менеджера установки SolidWorks, а не установочных файлов. После запуска более новой версии Менеджера установки SolidWorks можно выбрать параметры установки. Менеджер установки SolidWorks определит необходимые установочные файлы, которые не были загружены ранее, и предложит загрузить эти файлы.

К началу

В Менеджере установки SolidWorks отображаются только SW2006 или SW2007, но не текущая версия.

Используется более старая версия Менеджера установки SolidWorks, которая больше не поддерживается для текущей версии. С его помощью можно только загружать пакеты обновления для версий SW2006 и SW2007.

К началу

Менеджер установки SolidWorks не разрешает выбор другого пакета обновления продукта для установки.

Так и должно быть. Каждая версия Менеджера установки SolidWorks предназначена для установки только определенной версии продуктов SolidWorks. Если Вы хотите установить другой пакет обновления, вы должны запустить соответствующую версию Менеджер установки SolidWorks. Чтобы найти последнюю версию, см. раздел Как узнать о доступности новой версии продуктов SolidWorks?

К началу

Менеджеру установки SolidWorks не удается загрузить файлы.

Если из-за ограничений полномочного сервера с помощью приложений нельзя загрузить файлы, Менеджер установки SolidWorks не может выполнить загрузку файлов автоматически.

Файлы можно загрузить вручную и затем установить их с помощью Менеджера установки SolidWorks. В Менеджере установки SolidWorks выберите параметр для загрузки отдельных файлов (например, Провести загрузку вручную на странице Параметры загрузки). На основе выбранного продукта и системных требований веб-страница отображается в отдельном окне, содержащем ссылки для загрузки всех необходимых фалов вручную. Эти ссылки идентичны ссылкам, предоставленным на портале для клиентов SolidWorks, но пользователю не требуется искать файлы.

К началу

Не все продукты SolidWorks обновлены до последнего пакета обновления, но функциональность Проверить наличие обновлений сообщает, что я использую новейшую версию.

Параметр Проверить наличие обновлений сообщает об установке (или запуске) последней версии Менеджера установки SolidWorks.

Если необходимо обновить все продукты до последних версий, в окне Добавление/удаление программ выберите последнюю установленную версию SolidWorks и нажмите Изменить.

К началу

Можно ли скопировать DVD в папку загрузки?

Да, но установка может дать сбой, если Вы не скопируете все содержимое каждого DVD, выпущенного для соответствующей платформы (x86 или x64). Менеджер установки SolidWorks выполняет поиск файлов swdata*.id для определения версии. При отсутствии этих файлов Менеджер установки не сможет распознать скопированные пользователем установочные файлы и потребует загрузить их.

К началу

На уровень выше: Устранение неполадок


Устранение проблем, связанных с лицензиями SolidNetWork

Если не удается установить Менеджер лицензий SolidNetWork, возможны следующие причины.

  • Доступ к файлам журнала лицензий SolidNetWork
    При возникновении ошибки лицензии ее возможные причины см. в файле Каталог_установки_Менеджера_SNL\lmgrd.log.
  • Не удалось получить лицензию SolidWorks. Не удается подключиться к лицензионному серверу.
    Обычно эта проблема возникает в результате неправильной настройки портов.
На уровень выше: Устранение неполадок


Доступ к файлам журнала лицензий SolidNetWork

При возникновении ошибки лицензии ее возможные причины см. в файле Каталог_установки_Менеджера_SNL\lmgrd.log.

На уровень выше: Устранение проблем, связанных с лицензиями SolidNetWork


Не удалось получить лицензию SolidWorks. Не удается подключиться к лицензионному серверу.

Обычно эта проблема возникает в результате неправильной настройки портов.

  • Настройки портов компьютера с установленным Менеджером лицензий SolidNetWork и клиентского компьютера могут не совпадать.
  • Для различных версий Менеджеров лицензий SolidNetWork могут быть не заданы дополнительные настройки портов.
Для получения подробной информации о настройках портов для Менеджеров лицензий и клиентов SolidNetWork см. раздел Использование SolidNetWork с брандмауэрами.
На уровень выше: Устранение проблем, связанных с лицензиями SolidNetWork


Устранение неполадок, возникающих при обновлении программы

Если во время обновления программы SolidWorks до новой версии возникают проблемы, возможны следующие причины.

  • Выполнение обновления из источника, который был перемещен
    Во время установки SolidWorks Менеджер установки SolidWorks запоминает месторасположение источника установки (носитель, образ в сети и т.д.). При обновлении ожидается, что источник будет находиться в том же местоположении.
На уровень выше: Устранение неполадок


Выполнение обновления из источника, который был перемещен

Во время установки SolidWorks Менеджер установки SolidWorks запоминает месторасположение источника установки (носитель, образ в сети и т.д.). При обновлении ожидается, что источник будет находиться в том же местоположении.

Если источник был перемещен или удален, или носитель изменился, Менеджер установки SolidWorks выводит сообщение об ошибке. Однако Вы можете продолжить процесс обновления путем перехода в другое месторасположение, если оно содержит те же файлы и структуру папок.

На уровень выше: Устранение неполадок, возникающих при обновлении программы


Справка менеджера установки SolidWorks

Менеджер установки SolidWorks является отдельным приложением, которое устанавливает и обновляет продукты SolidWorks.

Менеджер установки SolidWorks можно запустить следующим образом:
  • С диска SolidWorks DVD, из общей папки или папки загрузки (при установке новой версии)
  • Со страницы Установка и удаление программ панели управления (при изменении или удалении существующей версии)
  • При проверке в процессе запланированного или выполняемого вручную обновления (во время удаления, загрузки и установки новых версий)

Каждая версия SolidWorks имеет собственную особую версию Менеджера установки SolidWorks.

Для версий, предшествующих SolidWorks 2008, следует использовать Менеджер установки SolidWorks 2007 или загрузить версии продукта вручную с веб-узла поддержки SolidWorks.
  • SolidWorks Фоновый загрузчик
    Фоновый загрузчик SolidWorks автоматически загружает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время загрузки может заниматься другими делами. По завершении загрузки пользователю будет предложено выполнить установку немедленно, отложить установку или удалить загруженные файлы.
  • Проверить результаты обновлений
    При проверке обновлений выполняется поиск последних версий SolidWorks.
  • Месторасположение администрирующего образа
    Указывает месторасположение администрирующего образа.
  • Параметры загрузки
    Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.
  • Параметры загрузки файлов Менеджера установки SolidWorks
    Вы выбрали загрузить последнюю версию Менеджера установки SolidWorks. На этом экране можно указать место и способ загрузки.
  • Загрузка файлов установки продукта
    Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.
  • Статус загрузки
    Менеджер установки SolidWorks загружает, проверяет и извлекает все файлы во время процесса загрузки.
  • Результаты загрузки
    Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.
  • Ошибки установки/Отмена установки
    При установке обнаружена ошибка или она была отменена.
  • Установка завершена
    Менеджер установки SolidWorks завершил свою работу.
  • Местоположение установки
    Укажите местоположение для установки SolidWorks.
  • Параметры обновления
    В настоящее время на данном компьютере установлена одна или несколько более ранних основных версий SolidWorks. Можно выбрать один из двух вариантов: выполнить обновление последней существующей версии до новой версии или установить эту новую версию.
  • Ход выполнения установки
    Этот экран отображает ход выполнения установки.
  • Тип установки
    Укажите операцию установки, которую необходимо выполнить, например создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка административных серверов или загрузка файлов без установки.
  • Установка и управление множественными компьютерами
    Менеджер установки SolidWorks обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SolidWorks.
  • Загрузка вручную
    Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SolidWorks).
  • Доступные более новые версии
    Менеджер установки обнаружил более новую версию продуктов SolidWorks. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.
  • Новые версии не доступны
    Новые версии не доступны для загрузки. Продолжите установку указанной версии.
  • Обнаружены процессы
    Менеджер установки SolidWorks обнаружил на этом компьютер процессы, которые могут препятствовать установке.
  • Выбор продуктов
    Укажите компоненты продукта для установки, изменения, загрузки и удаления.
  • Продукты для загрузки
    Выберите продукты SolidWorks для загрузки в указанное месторасположение.
  • Продукты для исправления
    Если задан параметр Исправить эту установку, на экране отображаются те продукты SolidWorks с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SolidWorks.
  • Серийные номера
    Серийные номера, имеющиеся на распределительной коробке, связывают ваш компьютер с приобретенными продуктами SolidWorks.
  • Установка сервера
    При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.
  • Менеджер лицензий SolidNetWork
    Укажите параметры установки сервера Менеджера лицензий SolidNetWork.
  • Сводка
    В Менеджере установки SolidWorks имеется вся информация, необходимая для выполнения операции установки.
  • Предупреждения проверки системы
    При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SolidWorks.
  • Параметры Отверстия под крепеж/Toolbox
    В случае установки SolidWorks Toolbox в состав SolidWorks будет включена стандартная библиотека типов отверстий и оборудования.
  • Установка продуктов
    Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SolidWorks (с номерами версий), которые можно удалить с помощью данной версии менеджера установки SolidWorks. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.
  • Параметры сервера Workgroup PDM
    Укажите параметры установки сервера SolidWorks Workgroup PDM.


SolidWorks Фоновый загрузчик

Фоновый загрузчик SolidWorks автоматически загружает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время загрузки может заниматься другими делами. По завершении загрузки пользователю будет предложено выполнить установку немедленно, отложить установку или удалить загруженные файлы.

При установке SolidWorks средствами Менеджера установки Фоновый загрузчик активизируется по умолчанию.

При запуске Менеджера установки SolidWorks для выполнения установки или загрузки файлов работа Фонового загрузчика SolidWorks приостанавливается. В частности, будет приостановлена загрузка любых файлов, запрещены запуск новых загрузок и изменение выбранной папки загрузки

Фоновый загрузчик SolidWorks включается по умолчанию при установке SolidWorks. Фоновый загрузчик SolidWorks можно отключить во время установки SolidWorks, изменив параметры загрузки на странице «Сводка». (Снимите флажок Хотите воспользоваться Фоновым загрузчиком?)

Если Фоновый загрузчик включен, его значок появляется в области уведомлений на панели задач Windows:

Нажмите на этот значок, чтобы выполните следующие операции:
  • Помощь с Фоновым загрузчиком
  • Приостановка загрузки
  • Продолжить загрузку
  • Отмена загрузки
  • Параметры установки
  • Изменить месторасположение загрузки
  • Проверить наличие обновлений
  • Автоматически проверять наличие обновлений
  • Автоматически загружать обновления
  • Отключить Фоновый загрузчик

Помощь с Фоновым загрузчиком

Открывает раздел справки по Фоновому загрузчику в Руководстве по установке SolidWorks.

Приостановка/Продолжение загрузки

Если загрузка выполняется в фоновом режиме, щелкните Приостановка загрузки, чтобы приостановить загрузку данного фала. Загрузку можно возобновить позднее, нажав Продолжить загрузку.

Отмена загрузки

Позволяет остановить выполняемую загрузку и удалить любые файлы, которые уже были загружены при помощи Фонового загрузчика.
Возобновить отмененную загрузку невозможно.

Параметры установки

После завершения загрузки можно выбрать следующие действия:
  • Установить сейчас: Загруженные файлы устанавливаются.
  • Напомнить потом: Загруженные файлы не устанавливаются, однако настраивается сообщение с напоминанием.
  • Удалить загруженные файлы: Загруженные файлы не устанавливаются, а удаляются. (Этот параметр полезен, если пользователь передумал устанавливать загруженные файлы.)

Изменить месторасположение загрузки

Изменяет месторасположение файлов, загружаемых при помощи Фонового загрузчика.

Этот параметр недоступен, если загрузка выполняется или приостановлена.

Проверить наличие обновлений

Запускает средство Проверить наличие обновлений Менеджера установки SolidWorks.

Автоматически проверять наличие обновлений

Периодически запускает средство Проверить наличие обновлений, уведомляя пользователя о том, что обновления доступны для загрузки.

Автоматически загружать обновления

Периодически запускает средство Проверить наличие обновлений, загружающее доступные обновления.

Отключение и повторное включение Фонового загрузчика SolidWorks

Фоновый загрузчик можно отключить, нажав значок и выбрав Отключить Фоновый загрузчик.

Чтобы снова включить Фоновый загрузчик, нажмите Пуск > Все программы > Менеджер установки SolidWorks > SolidWorks Фоновый загрузчик.

На уровень выше: Справка менеджера установки SolidWorks


Проверить результаты обновлений

При проверке обновлений выполняется поиск последних версий SolidWorks.

Проверку обновлений можно запустить вручную.
  • В системе Windows выберите Пуск > Программы > Менеджер установки SolidWorks > Проверить наличие обновлений
  • В SolidWorks выберите Справка > Проверить наличие обновлений.
Функция «Проверить наличие обновлений» недоступна на клиентах, установленных с помощью администрирующих образов.

Доступные более новые версии

Менеджер установки SolidWorks обнаружил более новую версию продуктов SolidWorks. Можно выполнить обновление до более новой версии, выбрав Менеджер установки SolidWorks для этой версии.

С помощью этой более поздней версии можно загрузить файлы установки для продуктов, указанных в установке. Вы можете сделать загруженные файлы общими для других пользователей, которые используют для процесса установки Менеджер установки SolidWorks.

Эти загружаемые файлы предназначены только для Менеджера установки SolidWorks.
К ним относятся:
  • Если доступны несколько версий, то Вы сможете выбрать нужную Вам версию в списке.
  • Для получения более подробной информации об этой версии выберите Отметить, чтобы просмотреть, что включено в это обновление.
При нажатии кнопки Далее загружается и запускается выбранная версия Менеджера установки SolidWorks.

Нет доступных новых загрузок/Не удалось проверить наличие новых версий

Менеджер установки не нашел более позднюю версию продуктов SolidWorks, потому что устанавливается последняя версия или потому что не удалось установить подключение к сайту SolidWorks для проверки.

На уровень выше: Справка менеджера установки SolidWorks


Месторасположение администрирующего образа

Указывает месторасположение администрирующего образа.

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа
Это местоположение каталога, в котором Менеджер установки SolidWorks создаст новый образ.
Этот каталог не должен содержать существующий администрирующий образ. Администрирующий образ должен находиться в папке, которую можно совместно использовать для развертывания клиента.
Приблизительный объем свободного места на диске, необходимый для создания образа
Это дополнительное пространство, которое необходимо для администрирующего образа.
Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из
Это местоположение папки, из которой выполняется установка продуктов SolidWorks.
Этот параметр появляется, если задан параметр Только установка. Для получения дополнительной информации см. раздел Параметры загрузки.
На уровень выше: Справка менеджера установки SolidWorks


Параметры загрузки

Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.

Менеджер установки SolidWorks поддерживает электронное распределение программного обеспечения (ESD). Если Вы не производите установку с SolidWorks DVD, Вы получите запрос на указание источника устанавливаемых Вами продуктов SolidWorks.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SolidWorks.

Что необходимо сделать?

Выберите один из следующих вариантов.
Загрузить и установить/загрузить и создать образ
По завершении загрузки Менеджер установки SolidWorks запустит установку с использованием загруженных файлов.
Только загрузить. Файлы можно загрузить один раз, а затем использовать их на нескольких компьютерах.
Менеджер установки SolidWorks не запустит установку после завершения загрузки.

Как правило, этот параметр необходимо указать, если файлы загружаются для создания установочного набора файлов, который будет использоваться на нескольких компьютерах.

Если задан этот параметр, отобразится запрос на выбор одного из двух наборов файлов для загрузки.
  • Файлы для ДАННОГО компьютера Будут загружены только те файлы, которые отсутствуют в установочном наборе файлов на данном компьютере.
    Объем загруженных данных будет меньше, поскольку в пакет будут включены только следующие файлы:
    • файлы продуктов, выбранных на странице «Выбор продуктов»;
    • обязательные для установки на данном компьютере файлы, которые еще не были установлены.

    Однако при попытке установки загруженного установочного набора файлов на другом компьютере может оказаться, что некоторых файлов не хватает (поскольку установочный набор файлов на другом компьютере может отличаться от текущего). Эти загруженные файлы можно использовать для установки на другой компьютер, однако в ходе установки, возможно, потребуется загрузить дополнительные файлы, чтобы установить полный установочный набор файлов.

  • Файлы для использования на ЛЮБЫХ компьютерах: Будет загружен полный установочный набор файлов, который можно использовать для установки данной версии на любом компьютере.

    Объем загружаемого пакета будет больше, поскольку он содержит полный набор файлов, который можно использовать для установки данной версии продукта на любом компьютере.

    Если для загрузки определен ограниченный набор программных продуктов, при выборе этого параметра ограничение игнорируется и загружаются все программы данной версии.

    В пакет загрузки будут включены все файлы, необходимые для создания администрирующего образа, а не только те, которые требуются для индивидуальной установки.

Только установка/Только создание образа. У меня уже есть все необходимые для установки файлы.
Менеджер установки SolidWorks не загружает файлы, а использует файлы из выбранного каталога.

Нажмите кнопку Обзор, чтобы перейти в другой каталог. Например, можно перейти к установочному DVD-диску или папке загрузки, при условии что там находятся все необходимые файлы.

Если Вы получили сообщения об ошибке, в котором говорится о том, что папке не полная, и Вы ожидали, что все файлы установки будут содержаться в указанном месторасположении, возможными объяснениями могут быть:
  • Вы выбрали компонент для установки, который не был ранее загружен или был выбран по умолчанию.
  • Файлы были загружены на компьютер с другими системными требованиями.
  • Вы ранее провели установку клиента и теперь создаете администрирующий образ, который требует большего набора файлов.

Можно перейти в папку, содержащую все файлы (например, на DVD-диске) или выбрать один из вариантов загрузки.

Куда загрузить необходимые файлы?

Это местоположение папки загрузки.

В некоторых случаях этот параметр может отображаться, но быть неактивным. Например, если выбран параметр Только установка, Менеджер установки SolidWorks выполнит установку загруженных файлов из каталога, указанного для этого параметра, отдельная папка загрузки использоваться не будет.

Независимо от того, выполняется ли загрузка файлов или они уже имеются на компьютере, все файлы должны быть в одной папке загрузки.

Приблизительный размер пакета загрузки

Необходимый объем свободного пространства на диске зависит от того, какие компоненты выбраны для установки. При этом неважно, загружаются ли новые файлы или используются файлы из предыдущего сеанса.

Например, при восстановлении предыдущей загрузки Менеджер установки SolidWorks обрабатывает только те файлы, которые еще не были загружены. Загрузка может занять меньше времени, чем было заявлено ранее.

Если загрузка файла выполнена в предыдущем сеансе, его размер не учитывается при приблизительной оценке. Поэтому приблизительный объем может быть выше реального размера пакета загрузки.

Как проводить загрузку?

Возможны два варианта.
Провести загрузку вручную
В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SolidWorks.
При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SolidWorks. Эта веб-страница настроена с помощью Менеджера установки SolidWorks для загрузки только тех файлов, которые необходимы для выполнения установки.
Ускорьте загрузки с помощью добавочной полосы сетевого пропуска
Программа загрузки использует алгоритм для ускорения процесса загрузки с помощью использования добавочной полосы сетевого пропуска во время загрузки.

В некоторых случаях это может повлиять на быстродействие сети. Если при проведении загрузки возникли проблемы, этот параметр может не поддерживаться Вашим полномочным сервером. Попробуйте очистить этот параметр и провести загрузку снова. Для получения информации обратитесь к Вашему системному администратору.

Этот параметр применяется только при автоматической загрузке и не влияет на скорость при загрузке вручную.

Использование Фонового загрузчика SolidWorks

Для выполнения данной операции загрузки или для загрузки дальнейших версий пакетов обновления по мере их доступности можно использовать Фоновый загрузчик SolidWorks.

Фоновый загрузчик SolidWorks позволяет автоматически обнаруживать и загружать новые версии пакетов обновления в фоновом режиме. По завершению процесса пользователь уведомляется о том, что файлы загружены и готовы к установке. Для получения дополнительной информации см. раздел SolidWorks Фоновый загрузчик.

На уровень выше: Справка менеджера установки SolidWorks


Параметры загрузки файлов Менеджера установки SolidWorks

Вы выбрали загрузить последнюю версию Менеджера установки SolidWorks. На этом экране можно указать место и способ загрузки.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SolidWorks.

Этот экран открывается только в случае проблем с папкой загрузки по умолчанию (например, при отсутствии доступа для записи или сетевого доступа). Как правило, для продолжения можно указать другую папку загрузки.

Каталог загрузки

Перейдите к месторасположению для файлов Менеджера установки SolidWorks.

Будет показан размер пакета загрузки и требуемый объем свободного пространства. Необходимый объем включает дополнительный объем, необходимый для распаковки некоторых загрузок, и превышает объем самой загрузки.

Использовать акселерацию загрузки

Если Вы решите использовать этот параметр, программа загрузки использует алгоритм для ускорения загрузки.

При использовании функции акселерации загрузки увеличивается полоса пропускания, что может привести к нарушениям в работе сети. Посоветуйтесь с Вашим системным администратором до использования акселерации загрузки.

Если акселерация загрузки не поддерживается полномочным сервером, этот параметр будет автоматически отключен.

На уровень выше: Справка менеджера установки SolidWorks


Загрузка файлов установки продукта

Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.

Менеджер установки SolidWorks загружает, проверяет и извлекает все файлы во время процесса загрузки.

Если закрыть этот экран, невыполненные этапы последовательности установки будут отменены.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см. Ошибки установки.

Каталог загрузки

Перейдите в месторасположение загруженных файлов.

Будут показаны размер пакета загрузки и требуемое пространство. Требуемый объем свободного пространства определяется с учетом места, необходимого для распаковки, и превышает фактический размер пакета загрузки.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SolidWorks.

Параметры загрузки

Ускорьте загрузки с помощью добавочной полосы сетевого пропуска
Программа загрузки использует алгоритм для ускорения процесса загрузки с помощью использования добавочной полосы сетевого пропуска во время загрузки.

В некоторых случаях это может повлиять на быстродействие сети. Если при проведении загрузки возникли проблемы, этот параметр может не поддерживаться Вашим полномочным сервером. Попробуйте очистить этот параметр и провести загрузку снова. Для получения информации обратитесь к Вашему системному администратору.

При использовании функции акселерации загрузки увеличивается полоса пропускания, что может привести к нарушениям в работе сети. Посоветуйтесь с Вашим системным администратором до использования акселерации загрузки.

Если акселерация загрузки не поддерживается прокси-сервером, этот параметр будет автоматически отключен.

На уровень выше: Справка менеджера установки SolidWorks


Статус загрузки

Менеджер установки SolidWorks загружает, проверяет и извлекает все файлы во время процесса загрузки.

Чтобы отменить загрузку после ее запуска, выберите параметр Отмена.

При отмене или сбое загрузки на экране Отмена загрузки или Неполадка загрузки отображается список незагруженных файлов. Можно возобновить загрузку или закрыть приложение.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SolidWorks.
На уровень выше: Справка менеджера установки SolidWorks


Результаты загрузки

Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.

Неполадка загрузки/Загрузка отменена

Если отображается сообщение Неполадка загрузки, Менеджер установки SolidWorks обнаружил проблемы, препятствующие загрузке.

Если отображается сообщение Загрузка отменена, процесс загрузки был отменен до завершения.

Чтобы продолжить:

Повторить/Возобновить автоматические загрузки
Чтобы возобновить автоматическую загрузку с того места, где она была отменена, выберите этот параметр и нажмите Повторить загрузку или Возобновить загрузку.
Загрузить отдельные файлы в веб-браузере
В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SolidWorks.
При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SolidWorks. Эта веб-страница настроена с помощью Менеджера установки SolidWorks для загрузки только тех файлов, которые необходимы для выполнения установки.

Загрузка завершена

Экран «Загрузка завершена» отображается при завершении загрузки, если выбран параметр Только загрузить.

Нажмите кнопку Готово, чтобы выйти из Менеджера установки SolidWorks.

Не следует устанавливать эти продукты вручную. Для установки загруженных файлов всегда используйте Менеджер установки SolidWorks.
На уровень выше: Справка менеджера установки SolidWorks


Ошибки установки/Отмена установки

При установке обнаружена ошибка или она была отменена.

Если возникла ошибка или отмена:
  • Продукты, установленные до возникновения ошибки или отмены установки, остаются на компьютере.
  • Установка продуктов, устанавливаемых во время отмены установки, если возможно, откатывается так, чтобы не оставалось частично установленных продуктов.
  • Установка или отмена установки оставшихся продуктов выполняться не будет. Список отобразится в разделе Попытка не была сделана.

    Чтобы возобновить установку или отмену установки этих продуктов, щелкните предоставленную ссылку.

Менеджер установки SolidWorks сначала выполнит установку всех обязательных компонентов, не установленных на компьютере, например .NET framework. Затес устанавливаются выбранные продукты в следующем порядке:
  1. SolidWorks
  2. eDrawings
  3. Поиск SolidWorks
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Восстановление неудавшейся или отмененной установки
    Если во время установки возникнет ошибка или отмена, с этого момента процесс установки можно восстановить, если запустить его повторно.
  • Подготовка установки
    Если во время установки возникнет ошибка или отмена, то для исправления установки можно использовать панель управления Windows.
  • Обращение к реселлеру SolidWorks
    Если не удается провести изменение или исправление установки, обратитесь к реселлеру SolidWorks, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить сжатый фал, содержащий файлы журнала Менеджера установки SolidWorks.
На уровень выше: Справка менеджера установки SolidWorks


Восстановление неудавшейся или отмененной установки

Если во время установки возникнет ошибка или отмена, с этого момента процесс установки можно восстановить, если запустить его повторно.

  1. Запишите сообщение об ошибке и код продукта для неудавшейся установки, как показано на экране Ошибки установки или Отмена установки.

    Если появился запрос на исходный файл, а в существующую установку SolidWorks никакие изменения не вносятся, может быть нарушен процесс установки или повреждена программа компьютера. Обратитесь к своему реселлеру SolidWorks.

  2. Перезагрузите компьютер.
  3. Чтобы убедиться, что не запущены никакие продукты SolidWorks, в Windows нажмите сочетание клавиш Ctr+Alt+Del и откройте Диспетчер задач.
  4. Если на вкладке Процессы в разделе Имя образа отображается один из следующих процессов, выберите их и нажмите кнопку Завершить процесс.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Если программа уже установлена, и Вы пытаетесь ее изменить или удалить, попробуйте исправить установку. Для получения дополнительной информации см. раздел t_repairing_installation.htm#doc1292869659219.
  6. В Windows Vista или более поздней версии выберите Пуск > Панель управления > Программы и компоненты. Для более ранних версий Windows выберите Пуск > Панель управления > Установка и удаление программ.
  7. Выберите неисправную версию SolidWorks.

    Если для версии SolidWorks, которую вы пытаетесь установить, отсутствует запись, запустите процесс установки повторно.

  8. Выполните одно из следующих действий:
    • Чтобы повторить попытку, нажмите кнопку Изменить и выберите все продукты, пропущенные во время установки или установка которых не удалась.

    • Чтобы опустить неудавшиеся установки, нажмите на кнопку Изменить и выберите все продукты, пропущенные во время установки. Удалите продукт, установка которого не удалась.

    • Чтобы отменить установку, нажмите на кнопку Удалить и выберите любые установленные продукты.

    При этом предыдущая версия обновляемых продуктов восстановлена не будет.

На уровень выше: Ошибки установки/Отмена установки


Обращение к реселлеру SolidWorks

Если не удается провести изменение или исправление установки, обратитесь к реселлеру SolidWorks, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить сжатый фал, содержащий файлы журнала Менеджера установки SolidWorks.

  1. Найдите файлы журнала:
    • Для версий операционной системы Windows до Windows Vista:

      C:\Documents and Settings\имя_пользователя\Application Data\SolidWorks\Installation Logs\установленная_версия\

    • Для Windows Vista и новее:

      C:\Users\имя_пользователя\AppData\Roaming\SolidWorks\Installation Logs\установленная_версия\

    Если папку найти не удается, возможно, она скрыта. В Проводнике Windows выберите Сервис > Параметры папки. На вкладке Вид, в разделе Дополнительные параметры, выберите значение Показывать скрытые файлы и папки для параметра Скрытые файлы и папки.

  2. Выполните сжатие содержимого всей папки, включая и содержимое подпапок.
На уровень выше: Ошибки установки/Отмена установки


Установка завершена

Менеджер установки SolidWorks завершил свою работу.

Может отображаться один или несколько этих параметров.

Новые возможности

Для индивидуальных установок при завершении процесса установки отображается документ, описывающий новые функциональности в SolidWorks и его добавлениях.

Для установок с помощью администрирующего образа документ отображается на клиентских компьютерах при завершении ими установок.

Опрос

Поделитесь с нами Вашим мнением о процессе установки, заполнив короткий опрос.

Участие в программе улучшения качества программного обеспечения SolidWorks

Информация по быстродействию программы посылается в Корпорацию SolidWorks с целью улучшения продукта. Процесс является прозрачным и конфиденциальным. Выберите один из указанных ниже параметров:
  • Да, я хочу участвовать
  • Нет, спасибо
  • Напомнить потом
Дополнительную информацию см. на веб-сайте программы улучшения качества программного обеспечения.

Создание администрирующего образа завершено

По завершению создания администрирующего образа можно нажать Настройка образа для настройки параметров образа с помощью Редактора параметров администрирующего образа.

Чтобы просмотреть инструкции по использованию Редактора параметров, нажмите Показать мне, как установить этот образ на компьютере клиента.

Дополнительные сведения о настройке администрирующего образа с помощью Редактора параметров см. в разделе Редактор параметров администрирующего образа.

Нажмите Настройка образа, чтобы запустить Редактор параметров и настроить параметры администрирующего образа.
Редактор параметров можно запустить и позже, дважды нажав файл sldAdminOptionEditor.exe, расположенный в каталоге установки администрирующего образа.
  • Проверка наличия обновлений SolidWorks
    Проверку на наличие обновлений можно выполнять вручную, с помощью Менеджера установки SolidWorks. Можно также настроить автоматическую проверку на наличие обновлений.
  • Программа улучшения качества программного обеспечения SolidWorks
    При установке SolidWorks можно задать параметр отправки информации о производительности в корпорацию SolidWorks, которая поможет улучшить продукт.
На уровень выше: Справка менеджера установки SolidWorks


Проверка наличия обновлений SolidWorks

Проверку на наличие обновлений можно выполнять вручную, с помощью Менеджера установки SolidWorks. Можно также настроить автоматическую проверку на наличие обновлений.

  1. Запустите Менеджер установки SolidWorks, выполнив одно из следующих действий:

    • В приложении SolidWorks выберите Справка > Проверить наличие обновлений.

    • В Windows выберите Пуск > Программы > Менеджер установки SolidWorks > Проверить наличие обновлений.

    В окне Менеджера установки SolidWorks отобразятся сведения о том, имеются ли в данный момент какие-либо обновления.

  2. Если да, то выберите их загрузку или установку.
  3. Чтобы задать автоматические периодические проверки на наличие обновлений, по завершении обработки, выполняемой Менеджером установки SolidWorks, выберите Проверять наличие обновлений каждые __ дней и задайте периодичность проверок.
На уровень выше: Установка завершена


Программа улучшения качества программного обеспечения SolidWorks

При установке SolidWorks можно задать параметр отправки информации о производительности в корпорацию SolidWorks, которая поможет улучшить продукт.

SolidWorks использует информацию для нахождения тенденций использования продукта и его качества. Нашей целью является доставка продукта высочайшего качества, и журналы эффективности играют важную роль в этом процессе.

Процесс очень простой. Информация, содержащаяся в файлах журнала, является конфиденциальной. Эта информация не используется для иных целей, и никто не будет связываться с Вами по этому поводу.

Дополнительную информацию см. на веб-сайте улучшения качества программного обеспечения.

На уровень выше: Установка завершена


Местоположение установки

Укажите местоположение для установки SolidWorks.

В случае установки без создания администрирующего образа применимы следующие параметры.
Установить выбранные продукты в
Это местоположение папки, в которую выполняется установка SolidWorks.
При обновлении или изменении установки все файлы необходимо устанавливать в существующую папку установки. В этом случае невозможно изменить местоположение существующей установки SolidWorks.
Приблизительный объем свободного пространства, необходимый для установки
Это дополнительное пространство, которое необходимо для продуктов, выбранных для установки или изменения.
Проверьте наличие на диске установки необходимого свободного пространства.
Установить из
Это местоположение папки, из которой выполняется установка SolidWorks.
Этот параметр появляется, если задан параметр Только установка. Для получения дополнительной информации см. раздел Параметры загрузки.
Перед изменением папки установки обратитесь к системному администратору SolidWorks.

Местоположение администрирующего образа

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа
Это местоположение каталога, в котором Менеджер установки SolidWorks создаст новый образ.
Этот каталог не должен содержать существующий администрирующий образ.
Приблизительный объем свободного места на диске, необходимый для создания образа
Это дополнительное пространство, которое необходимо для администрирующего образа.
Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из
Это местоположение папки, из которой выполняется установка продуктов SolidWorks.
Этот параметр появляется, если задан параметр Только установка. Для получения дополнительной информации см. раздел Параметры загрузки.
Месторасположение существующего образа
При обновлении существующего администрирующего образа Менеджер установки SolidWorks создает новый образ с использованием параметров существующего образа. Существующий образ не изменяется. Этот параметр показывает местоположение исходного образа, указанного на экране приветствия.

Отказ от использования путей с указанием версии

Если в имени каталога установки указан номер версии (например, C:\Program Files\SolidWorks Corp\SolidWorks 2010\) и выполнено обновление установки до версии SolidWorks 2011, папка установки SolidWorks 2011 будет иметь имя SolidWorks 2010.

На уровень выше: Справка менеджера установки SolidWorks


Параметры обновления

В настоящее время на данном компьютере установлена одна или несколько более ранних основных версий SolidWorks. Можно выбрать один из двух вариантов: выполнить обновление последней существующей версии до новой версии или установить эту новую версию.

Такой выбор возможен только в том случае, если на данном компьютере не установлена предыдущая версия этого основного выпуска. Если предыдущая версия основного выпуска установлена, установка будет обновлена Менеджером установки SolidWorks.

(Начиная с версии SolidWorks 2010, параллельная установка нескольких версий пакета обновления одного и того же основного выпуска поддерживаться не будет.)

При обновлении требуется следовать представленным ниже правилам.
  • Обновляются все указанные продукты.
  • По умолчанию выбираются все установленные продукты.
  • Если выбор одного из продуктов отменен, он обновлен не будет.
    Если выбор одного из компонентов продукта отменен, удаление этого компонента не задается в Менеджере установки SolidWorks. Для удаления компонента продукта используйте параметр Установка и удаление программ (как описано в разделе Удаление установки).

Выберите соответствующий параметр и для продолжения нажмите кнопку Далее.

Создать новую установку SolidWorks (версия).

При выборе этого параметра создается новая установка этой основной версии и сохраняется установка более ранней основной версии.

Это может быть полезно в том случае, когда иногда требуется доступ к более ранней версии SolidWorks даже после установки более поздней версии. Например, те или иные файлы используются вами совместно с другими пользователями, у которых установлена более ранняя версия. При этом вы избегаете несовместимости версий, если работа с этими файлами выполняется на компьютере с более поздней версией программы.

Обновить SolidWorks предыдущая_основная_версия до SolidWorks текущая_основная_версия.

При выборе этого параметра установка более ранней версии обновляется до более поздней версии.
По завершении установки более ранняя версия SolidWorks на данном компьютере станет недоступной.
На уровень выше: Справка менеджера установки SolidWorks


Ход выполнения установки

Этот экран отображает ход выполнения установки.

Чтобы отменить установку после ее начала, нажмите кнопку Отмена.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см. Ошибки установки.

На уровень выше: Справка менеджера установки SolidWorks


Тип установки

Укажите операцию установки, которую необходимо выполнить, например создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка административных серверов или загрузка файлов без установки.

Индивидуальный

Устанавливает продукты SolidWorks на данном компьютере.

Он появляется, только если данная версия не установлена на компьютере.

Изменение индивидуальной установки

Используя этот параметр, можно изменить существующую установку SolidWorks на данном компьютере.

Он появляется, только если данная версия установлена на компьютере.
К изменениям относятся следующие действия:
  • добавление или удаление компонентов продукта SolidWorks;
  • установка другого пакета SolidWorks (например, SolidWorks Professional, SolidWorks Premium и др.);
  • изменение серийного номера SolidWorks.
    Если вы уже указали серийный номер SolidWorks при предварительной установке, Менеджер установки SolidWorks не будет запрашивать его повторно. Чтобы изменить серийный номер, используемый Менеджером установки, необходимо выбрать этот параметр.

Исправление индивидуальной установки

Этот параметр позволяет исправить существующую установку SolidWorks на данном компьютере.

Он появляется, только если данная версия установлена на компьютере.
Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.
Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.

Администрирующий образ

Этот параметр позволяет создать или обновить администрирующий образ на данном компьютере.

Администрирующий образ можно использовать для установки на нескольких компьютерах. Для получения сведений об установке SolidWorks на нескольких клиентах с использованием административных образов см. раздел Использование администрирующих образов.

При создании или обновлении администрирующих образов:
  • для настройки нового или обновленного образа можно использовать параметры установки существующего образа. Можно также использовать параметры установки SolidWorks по умолчанию.
  • При обновлении существующего изображения:
    • Менеджер установки SolidWorks создает новую копию изображения, даже если выполняется обновление. Исходный образ не изменяется.
    • Обновленный образ можно создать с использованием файлов существующего образа. При этом объем загружаемых данных будет меньше.
    Если образ, для которого можно применить пакет обновления, не указан, придется загрузить полный набор файлов.
  • На компьютере можно затребовать создание и 32-разрядного, и 64-разрядного администрирующего образа. В противном случае создается только тот образ, который совместим с архитектурой данного компьютера.
    Если задано создание 32-разрядного и 64-разрядного образа, для завершения установки потребуются установочные диски SolidWorks для соответствующей архитектуры.

Серверные продукты

К административным серверам SolidWorks относятся сервер SolidWorks Workgroup PDM (хранилище) и Менеджер лицензий SolidNetWork.

Для получения дополнительной информации об этих приложениях см.:
  • Workgroup PDM
  • Администрирование лицензий с помощью Менеджера лицензии SolidNetWork

Только загрузить

Этот параметр позволяет загрузить файлы установки для выбранных продуктов SolidWorks. При этом установка не выполняется.

Этот параметр не будет отображаться, если установка выполняется с DVD-диска.

Содержимое загруженных файлов совпадает с содержимым файлов на установочном DVD-диске SolidWorks. При выборе этого параметра загружается полный набор файлов установки, независимо от того, что некоторые файлы могут быть уже установлены на компьютере.

Можно использовать этот метод для установки сервера, с помощью которого пользователи смогут провести установки. Это отличается от создания администрирующего образа.

Установка на компьютер версии SolidWorks неподходящей архитектуры

При попытке установить на компьютер SolidWorks с установочного диска, имеющего неподходящую архитектуру (например, при попытке установить 64-разрядную версию SolidWorks на 32-разрядный компьютер), на панели установки появится сообщение об ошибке.

Для продолжения установки:
  1. Отмените сеанс Менеджера установки SolidWorks.
  2. Проверьте архитектуру компьютера и системные требования.
  3. Повторите установку, используя подходящий для компьютера с данной архитектурой установочный диск SolidWorks.
На уровень выше: Справка менеджера установки SolidWorks


Загрузка вручную

Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SolidWorks).

Щелкните ссылку, чтобы открыть автоматически созданную веб-страницу с полным списком файлов для загрузки.

Необходимо выполнить загрузку в папку, указанную на странице «Сводка». Невозможно начать установку, пока все файлы не будут загружены в эту папку.

По завершении выполнения загрузки вручную нажмите кнопку Далее, чтобы продолжить.

Если необходимо выполнить загрузку автоматически, можно указать другой параметр. Для этого необходимо вернуться на страницу «Сводка» и изменить параметры загрузки.

На уровень выше: Справка менеджера установки SolidWorks


Доступные более новые версии

Менеджер установки обнаружил более новую версию продуктов SolidWorks. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.

Если установка выполняется с DVD

В разделе Хотите использовать более новую версию? выберите один из следующих параметров.
  • Нет, продолжить установку версия с данного DVD. Вы можете провести обновление позже посредством небольшой загрузки.

    Выберите этот параметр для продолжения установки с помощью текущего Менеджера установки.

    После завершения установки можно проверить наличие и установить пакеты обновления с использованием Менеджера установки. Для проверки наличия обновлений выберите Пуск > Менеджер установки SolidWorks > Проверить наличие обновлений.

    Преимущество состоит в том, что объем загружаемых данных будет меньше. Недостатки заключаются в том, что это двух-шаговый процесс, и загруженные файлы принадлежат определенной версии (и не могут быть полезными для других пользователей, которые используют другие версии).

  • Да, провести установку с использованием этого DVD, затем загрузить и обновить до версия.

    Выберите этот параметр, чтобы загрузить и запустить более позднюю версию Менеджера установки для установки продуктов SolidWorks для этой версии.

    При наличии небольшого пакета обновления для версии DVD Менеджер установки сначала выполнит установку исходной версии с диска DVD, а затем установит пакет обновления. При этом объем загружаемых данных будет меньше.

    Такие же результаты будут, если выбрать продолжение установки с DVD-диска, а затем позднее установить пакет обновления.

    Преимущество заключается в том, что эта процедура выполняется в один этап.

В большинстве случаев установка полной версии с DVD с последующим использованием Менеджера установки для проверки наличия и установки обновлений предпочтительна, поскольку объем загружаемых данных при этом меньше.

Если установка выполняется через загрузку

Выберите один из следующих вариантов.
  • Продолжить установку версия.

    Выберите этот параметр для продолжения установки версии, содержащейся в исходной загрузке.

  • Загрузить и установить новую версию: версия

    Выберите этот параметр для загрузки новой версии и ее установки. При наличии нескольких более поздних версий, версию для загрузки и установки можно выбрать.

На уровень выше: Справка менеджера установки SolidWorks


Обнаружены процессы

Менеджер установки SolidWorks обнаружил на этом компьютер процессы, которые могут препятствовать установке.

  • Чтобы продолжить установку, выполните одно из следующих действий:
    • Завершите эти процессы (например, с помощью диспетчера задач Microsoft Windows), а затем нажмите кнопку Повторить.
    • Нажмите кнопку Игнорировать, чтобы продолжить, не завершая процессов.
  • Чтобы остановить установку, нажмите кнопку Отмена.
На уровень выше: Справка менеджера установки SolidWorks


Выбор продуктов

Укажите компоненты продукта для установки, изменения, загрузки и удаления.

В списке продуктов:
  • В списке продуктов перечислены все продукты пакета, указанного над этим списком.
  • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
  • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
  • Если выполняется изменение установки, при изменении выбранного продукта слева от компонентов отобразится звездочка (*).
  • Если компонент содержит дополнительные субкомпоненты для установки, рядом с компонентом отображается значок + . Для просмотра доступных субкомпонентов компонента щелкните на значке + .
  • Если список дополнительных субкомпонентов компонента раскрыт, рядом с компонентом отображается значок - . Чтобы свернуть список субкомпонентов, щелкните на значке - .

Если применяется пакет обновления, функции SolidWorks, отображающиеся под SolidWorks (например, FeatureWorks), выбрать невозможно. Это объясняется тем, что нельзя добавить или удалить элемент при выполнении данного типа обновления.

Действия Менеджера установки SolidWorks определяются набором правил сосуществования продуктов. Для получения дополнительной информации см. раздел Правила сосуществования продуктов.

Менеджер установки SolidWorks по умолчанию выбирает следующие компоненты:
  • Если выполняется модернизация или обновление, Менеджер установки SolidWorks выбирает продукты, установленные на компьютере в данный момент.
  • В противном случае, Менеджер установки выбирает все продукты, на которые пользователь имеет право.
Чтобы сократить время установки и загрузки и необходимый объем свободного пространства на диске, разверните список компонентов продукта и снимите флажки для компонентов, которые вам не требуются.

Если Менеджеру установки SolidWorks не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы изменить список пакетов (например, SolidWorks Professional или SolidWorks Premium) для установки или изменения. Менеджер установки отображает все продукты SolidWorks на носителе установки, которые совместимы с выбранным Вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Поиск SolidWorks

Поиск в SolidWorks – это мощный инструмент для выполнения текстового поиска в документах SolidWorks, хранилище Workgroup PDM и на веб-узле 3D ContentCentral. Поиск отображает предварительный просмотр, месторасположение и имя файла.

После установки Поиск SolidWorks индексирует документы SolidWorks для убыстрения последующего поиска. По умолчанию индексируются только файлы SolidWorks.

При установке Поиска SolidWorks выполняется автоматическая установка Windows Desktop Search, если это приложение еще не установлено на компьютере пользователя.

Языковая поддержка

Разверните продукт SolidWorks, и в параметре компонента Языки просмотрите, какие языки можно установить.

Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SolidWorks. Это не повлияет на установки других продуктов. Например, SolidWorks eDrawings®, SolidWorks Workgroup PDM и SolidWorks Explorer устанавливаются на всех поддерживаемых языках.

Требуемый объем свободного пространства

Менеджер установки SolidWorks дает отчет об общем размере установки или общем размере загрузки в нижней части страницы.

  • Если выбран параметр Только загрузить, отображается размер пакета загрузки. Объем загрузки является общим объемом пространства на диске, необходимого для всех загружаемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса загрузки). Это число является приблизительным.
    Общий размер пакета загрузки включает все файлы, необходимые для установки. Если некоторые файлы уже были загружены в текущую папку загрузки, они не будут загружаться повторно. В результате фактический объем загрузки может быть меньше, чем указанный общий объем, или Вам не придется загружать файлы.
  • В противном случае отображается объем установки. Объем установки - это изменение в использовании дискового пространства, возникающее после завершения процесса установки. Из-за сжатия файлов эти показатели являются приблизительными.

    При обновлении или удалении существующей установки, объем установки может быть равен нулю.

    В это число не входит объем свободного пространства, необходимого для загрузки или извлечения файлов, если это требуется для установки.

    Если загрузка файлов необходима и все файлы загружаются на один диск, необходимый объем свободного пространства на диске может значительно превышать объем установки.

    Чтобы сократить объем загрузки или время установки для следующих модификаций, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.

На уровень выше: Справка менеджера установки SolidWorks


Продукты для загрузки

Выберите продукты SolidWorks для загрузки в указанное месторасположение.

Доступные для загрузки продукты определяются введенным Вами серийным номером:

  • Действие, которое должно быть произведено над каждым из компонентов, отображается справа от объекта.
  • Если компонент содержит дополнительные субкомпоненты для установки, рядом с компонентом отображается значок + . Для просмотра доступных субкомпонентов компонента щелкните на значке + .
  • Если список дополнительных субкомпонентов компонента раскрыт, рядом с компонентом отображается значок - . Чтобы свернуть список субкомпонентов, щелкните на значке - .
  • Установите флажок слева от каждого компонента, чтобы выбрать, каким образом он будет обработан Менеджером установки SolidWorks.
Менеджер установки SolidWorks выполняет загрузку всех компонентов продуктов, на установку которых пользователь имеет право, если не указано иное. Чтобы уменьшить время загрузки и требование к количеству свободного места на диске, разверните список компонентов продукта и выберите «Не загружать» для компонентов, которые не нужны.

Если Менеджеру установки SolidWorks не удалось проверить, на какие продукты пользователь имеет право, можно выбрать пакет SolidWorks для установки. Менеджер установки указывает все продукты SolidWorks, совместимые с выбранным Вами пакетом.

Если Менеджеру установки SolidWorks не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы изменить список пакетов (например, SolidWorks Professional или SolidWorks Premium) для установки или изменения. Менеджер установки отображает все продукты SolidWorks на носителе установки, которые совместимы с выбранным Вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Языковая поддержка

Выбор значения параметра "Языки" ограничивает иностранные языки, устанавливаемые для продуктов SolidWorks. Это не повлияет на установки других продуктов. Например, SolidWorks eDrawings®, SolidWorks Workgroup PDM и SolidWorks Explorer устанавливаются на всех поддерживаемых языках.

Требуемый объем свободного пространства

В зависимости от выбранных Вами продуктов, отображается необходимый для загрузки объем свободного места. Объем загрузки является общим объемом пространства на диске, необходимого для всех загружаемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса загрузки). Это число является приблизительным.

Чтобы сократить объем загрузки или время установки следующих обновлений и пакетов, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.
На уровень выше: Справка менеджера установки SolidWorks


Продукты для исправления

Если задан параметр Исправить эту установку, на экране отображаются те продукты SolidWorks с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SolidWorks.

Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.

Чтобы начать исправление выбранных продуктов, нажмите кнопку Исправить.

Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.
На уровень выше: Справка менеджера установки SolidWorks


Серийные номера

Серийные номера, имеющиеся на распределительной коробке, связывают ваш компьютер с приобретенными продуктами SolidWorks.

Если продукты SolidWorks уже установлены на компьютере, их серийные номера отображаются по умолчанию.
  • Введите ваш серийный номер SolidWorks, если он еще не отображается.
  • Если отображаются серийные номера продуктов, на которые не распространяется ваша лицензия SolidWorks, выберите номер продукта ниже параметра У Вас есть другие серийные номера? и введите серийный номер такого продукта.

Если имеется соединение с сетью Интернет, серийные номера соответствуют продуктам, которые вы можете использовать в процессе установки.

Поскольку существует множество способов приобретения продуктов SolidWorks, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SolidWorks дает возможность установить SolidWorks Simulation без ввода отдельного серийного номера SolidWorks Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.
На уровень выше: Справка менеджера установки SolidWorks


Установка сервера

При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.

Статус установки сервера

Установка серверов выполняется внешним приложением установки. Если окно приложения закрыто, для завершения установки необходимо перейти в него.

Нажмите кнопку Отмена, чтобы остановить установку серверов.

Установка сервера завершена

Внешнее приложение установки успешно завершило процесс установки.

Нажмите кнопку Готово или Далее.
  • При установке других административных приложений (например, включенных в администрирующий образ SolidWorks), эта процедура установки будет продолжена.
  • Если устанавливались только серверы, Менеджер установки SolidWorks будет закрыт.

Отмена или ошибка установки сервера

В случае ошибки или отмены установки сервера после ее начала, отобразится список неустановленных серверов.

Нажмите кнопку Закрыть или Далее.
  • Если задана установка других административных приложений, Менеджер установки SolidWorks возобновит работу.
  • Если устанавливались только серверы, Менеджер установки SolidWorks будет закрыт.
На уровень выше: Справка менеджера установки SolidWorks


Менеджер лицензий SolidNetWork

Укажите параметры установки сервера Менеджера лицензий SolidNetWork.

Серийные номера

Укажите серийные номера лицензии SolidNetWork. Можно указать несколько серийных номеров, через запятую.
Серийные номера SolidNetWork отличаются от серийных номеров SolidWorks.

Месторасположение установки

Укажите местоположение установки Менеджера лицензий SolidNetWork.

В случае обновления Менеджера лицензий SolidNetWork его необходимо установить в папку существующей установки.

Для получения дополнительной информации

Подробнее об установке, настройке и использовании Менеджера лицензий SolidNetWork см. в разделеАдминистрирование лицензий с помощью Менеджера лицензии SolidNetWork.

На уровень выше: Справка менеджера установки SolidWorks


Сводка

В Менеджере установки SolidWorks имеется вся информация, необходимая для выполнения операции установки.

Чтобы продолжить, выполните следующие действия. | Нажмите кнопку действие Сейчас, чтобы начать операцию установки (например, Установить, Создать, Загрузить, Изменить).
Чтобы изменить параметры установки, выполните следующие действия. | Нажмите кнопку ИЗМЕНИТЬ [image] рядом с тем разделом, который требуется изменить (например, Продукты, Месторасположение установки, Параметры Toolbox).
Чтобы отменить установку, выполните следующие действия. | Нажмите кнопку Отмена [image] , чтобы выйти из Менеджера установки SolidWorks, не изменяя компоненты установки.
Чтобы вернуться на предыдущую страницу, выполните следующее. | Нажмите кнопку Назад [image] , чтобы вернуться на предыдущую страницу Менеджера установки SolidWorks.
Чтобы получить сведения об определенном наборе параметров установки (например, Продукты, Месторасположение установки, Параметры Toolbox и т.д.), выполните следующее.
  1. Нажмите кнопку ИЗМЕНИТЬ [image] рядом с разделом, о параметрах которого требуется получить информацию.
  2. На открывшейся странице сведений выберите Справка [image], чтобы получить сведения о данном параметре установке.
На уровень выше: Справка менеджера установки SolidWorks


Предупреждения проверки системы

При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SolidWorks.

Далее приведен список предупреждений, которые могут появляться на данном этапе, а также рекомендации по продолжению установки.

Проблемы с проверкой серийного номера
Менеджеру установки не удалось проверить наличие новых версий, так как не удалось проверить серийный номер. Если серийный номер введен правильно и Интернет-соединение установлено, возможно, на нашем сервере возникли временные проблемы. Повторите попытку позже.

Проверка серийного номера: Менеджеру установки не удалось проверить ваш серийный номер для определения продуктов, на установку которых Вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Для проведения установки Вам понадобятся ранее загруженный набор файлов или исходные файлы на DVD.

Разрешение:
  • Проверьте подключение к Интернету. Для проверки серийного номера требуется успешное подключение к Интернету
  • Проверьте, правильно ли указан серийный номер продукта, который вы пытаетесь установить.
  • В некоторых случаях для успешной установки требуется наличие действующей подписки на абонентские услуги на момент выпуска версии. За дополнительной информацией обратитесь к своему реселлеру SolidWorks.
  • В большинстве случаев Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.
Доступные более новые версии
Доступные более новые версии

Доступные новые версии

Более новая версия продукта доступна для загрузки.

Разрешение: Во время проверки наличия обновлений Вам может быть предложено установить более новую версию, доступную для загрузки с веб-сайта SolidWorks. Вы можете продолжить установку, используя ранее указанную версию, либо загрузить и установить вместо нее более позднюю версию.

Используется самая последняя версия
Эта новейшая доступная версия. Нажмите Далее, чтобы продолжить.

Нет доступных новых загрузок

Разрешение: Это сообщение может появиться во время проверки наличия обновлений при установке или изменении приложений. Это означает, что Вы устанавливаете (или уже установили) самую позднюю из имеющихся версий.

Проблемы с подключением к Интернету
Подключение к Интернету: Менеджер установки не может установить соединение с сервером SolidWorks для определения продуктов, на установку которых Вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Вам понадобятся исходные файлы на DVD или ранее загруженный набор файлов.

Не удалось проверить наличие новых версий

Менеджеру установки не удалось проверить наличие более новых версий, т.к. ему не удалось подсоединиться к серверу.

Разрешение:
  • Проверьте подключение к Интернету.
  • Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.
На уровень выше: Справка менеджера установки SolidWorks


Параметры Отверстия под крепеж/Toolbox

В случае установки SolidWorks Toolbox в состав SolidWorks будет включена стандартная библиотека типов отверстий и оборудования.

Для получения дополнительной информации о настройке, обновлении и использовании SolidWorks Toolbox в программе SolidWorks выберите Справка > Справка по Toolbox.
Чтобы просмотреть справку, необходимо запустить приложение Toolbox, выбрав Инструменты > Приложения.

Перед использованием SolidWorks Toolbox убедитесь, что приложение настроено в соответствии с политикой компании или группы. Во многих случаях группа отвечает за настройку и обслуживание центрального компонента Toolbox. Узнайте у администратора SolidWorks, каким образом следует задать настройки Toolbox во время установки программы SolidWorks.

Выбранные параметры SolidWorks Toolbox можно изменить и после установки. В SolidWorks выберите Инструменты > Параметры. На вкладке Настройки пользователя выберите Отверстия под крепеж/Toolbox.

В следующих разделах описаны все параметры, которые могут появиться на экране при работе в любой из конфигураций. Фактический набор отображаемых параметров Toolbox зависит от того, какие конфигурации SolidWorks и Toolbox ранее существовали на данном компьютере, а также от настроек Менеджера установки SolidWorks, заданных на данный момент.

Создать новый новая версия Toolbox

Создание новой версии SolidWorks Toolbox на данном компьютере.

При создании новой версии на экране "Выбор продуктов" разверните SolidWorks > SolidWorks Toolbox и выберите стандарты для поддержки Toolbox. По умолчанию выбираются все стандарты.

Любые компоненты Toolbox, уже существующие на данном компьютере, изменены не будут.

Создать ссылку или обновить существующий Toolbox

Использование существующего компонента Toolbox. Нажмите кнопку Обзор, чтобы указать местоположение Toolbox, которое требуется использовать для данной установки.

  • Если компонент Toolbox настроен для версии предыдущего основного выпуска SolidWorks, он будет обновлен до этой версии. Любые настройки, выполненные для данного компонента Toolbox, будут сохранены в обновленном компоненте Toolbox.
    При обновлении Toolbox до новой основной версии SolidWorks это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SolidWorks.
  • Если компонент Toolbox настроен для данной версии SolidWorks (например, указан Toolbox совместного пользования в сети, который уже обновлен), этот компонент уже не обновляется.
  • Если обновление Toolbox выполняется в среде Enterprise PDM, требуются дополнительные операции. Для получения дополнительной информации см. раздел Обновление Toolbox в среде SolidWorks Enterprise PDM.

Этот параметр отображается во всех сценариях установки, за исключением создания администрирующего образа.

Обновить предыдущая версия Toolbox

Скопируйте компонент Toolbox, настроенный для версии предыдущего основного выпуска, в новую папку и обновите эту копию до данной версии.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SolidWorks, однако вы не хотите обновлять установку до этого выпуска.
Цель использования данного параметра – обновление Toolbox для установленной предыдущей версии основного выпуска SolidWorks, минуя компьютеры пользователей, использующих более раннюю версию Toolbox.

Если обновление Toolbox выполняется в среде Enterprise PDM, требуются дополнительные операции. Для получения дополнительной информации см. раздел Обновление Toolbox в среде SolidWorks Enterprise PDM.

Обновить установленный предыдущая версия Toolbox

Обновление Toolbox до более поздней версии.
При обновлении Toolbox до новой основной версии SolidWorks это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SolidWorks.

Этот параметр отображается в том случае, если предыдущая версия основного выпуска SolidWorks обновляется до этой версии, а компонент Toolbox, настроенный для данного выпуска, найден на данном компьютере.

Если обновление Toolbox выполняется в среде Enterprise PDM, требуются дополнительные операции. Для получения дополнительной информации см. раздел Обновление Toolbox в среде SolidWorks Enterprise PDM.

Использовать установленный текущая версия Toolbox

Менеджер установки SolidWorks обнаружил на компьютере компонент Toolbox, настроенный для данной версии основного выпуска SolidWorks.

При выборе этого параметра в программе SolidWorks будет использоваться данный компонент Toolbox. Обновление не выполняется.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SolidWorks, однако компонент Toolbox настроен для данной версии. Это может иметь место в том случае, если Toolbox с общим доступом создан на компьютере, на котором все еще используется более ранняя версия SolidWorks.

Укажите месторасположение Toolbox для компьютера клиента

Указание сетевой папки или каталога в качестве месторасположения Toolbox по умолчанию, если клиенты устанавливаются из администрирующего образа.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SolidWorks, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SolidWorks.

Этот параметр отображается при создании нового администрирующего образа.

Обновить или использовать Toolbox, на который ссылается существующий образ на компьютере клиента

Использование месторасположения Toolbox, указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SolidWorks, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SolidWorks.

Выберите другое месторасположение Toolbox для компьютера клиента

Указание другого месторасположения Toolbox, отличного от указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SolidWorks, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SolidWorks.
  • Примечания о настройке SolidWorks Toolbox
    SolidWorks Toolbox – это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SolidWorks.
  • Формат UNC
    Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.
На уровень выше: Справка менеджера установки SolidWorks


Примечания о настройке SolidWorks Toolbox

SolidWorks Toolbox – это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SolidWorks.

Дополнительная информация о SolidWorks Toolbox

Для получения дополнительной информации о настройке, обновлении и использовании SolidWorks Toolbox в программе SolidWorks выберите Справка > Справка по Toolbox.
Чтобы просмотреть справку, необходимо запустить приложение Toolbox, выбрав Инструменты > Приложения.

Использование общего приложения Toolbox

При установке Toolbox данные Toolbox можно сохранить на локальном компьютере или в общей сетевой папке. Рекомендуется хранение данных Toolbox в сетевой папке. При использовании общей папки все пользователи SolidWorks будут иметь доступ к одному набору данных крепежей.

При первой установке перейдите к новой общей папке, в которой требуется выполнить установку Toolbox.

Обновление существующего компонента Toolbox

При обновлении Toolbox до новой основной версии SolidWorks это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SolidWorks.

Если на других компьютерах сохраняется более ранняя основная версия и требуется приложение Toolbox для этой версии, необходимо сделать копию этого приложения и обновить ее. При установке новой версии SolidWorks будет выполнено обновление копии Toolbox, а для более ранних установленных версий SolidWorks будет использоваться предыдущая версия Toolbox.

Настройка доступа к Toolbox

После установки при открытии компонентов Toolbox SolidWorks проверяет настройку Toolbox и предлагает варианты улучшения доступа и производительности.

Для доступа к общей сетевой установке Toolbox (рекомендуется) следует использовать путь UNC к серверу, на котором установлено это приложение. Для получения дополнительной информации см. раздел Формат UNC.

Администратор может создать пароль для Toolbox и задать разрешения и настройки для всей рабочей группы. Ограничение доступа к конфигурации и задание стандартных настроек обеспечивает стабильность данных Toolbox.

Обновление Toolbox в среде SolidWorks Enterprise PDM

Перед обновлением первой установки SolidWorks, при которой имеется доступ к папке Toolbox в хранилище Enterprise PDM:
  1. В Проводнике Windows перейдите к папке Toolbox в хранилище Enterprise PDM.
  2. Нажмите правой кнопкой мыши на папку Toolbox и выберите Получить последнюю версию.

    При этом Менеджер установки SolidWorks проверяет, требуется ли обновление деталей.

  3. Разрегистрируйте папку Toolbox.

    Папка Toolbox должна быть разрегистрирована для того, чтобы SolidWorks Installation Manager смог обновить Toolbox.

  4. После обновления зарегистрируйте папку Toolbox.

Теперь библиотека Toolbox в хранилище обновлена.

Если потребуется выполнить обновление SolidWorks в последствии, перед инициацией обновления клиенты Enterprise PDM должны получить последнюю версию папки с хранилищем Toolbox (выбрав параметр Получить последнюю версию). При этом Менеджер установки SolidWorks проверяет, не устарели ли файлы.

Для получения подробной информации о конфигурации Toolbox в SolidWorks Enterprise PDM см. раздел Настройка Toolbox в Справке инструмента администрирования SolidWorks Enterprise PDM.

На уровень выше: Параметры Отверстия под крепеж/Toolbox


Формат UNC

Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.

\\server\volume\path

Пример:

\\Disk_Server\SolidWorks\AdminImage

На уровень выше: Параметры Отверстия под крепеж/Toolbox


Установка продуктов

Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SolidWorks (с номерами версий), которые можно удалить с помощью данной версии менеджера установки SolidWorks. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.

При стандартной отмене установки удаляются программные папки и файлы продукта SolidWorks. Во время стандартной отмены установки по умолчанию выполняется удаление всех продуктов SolidWorks выбранного выпуска.

При отмене установки по выбору удаляются один или несколько из следующих элементов: программные файлы и папки, разделы реестра и папки данных, такие как SolidWorks Toolbox, а также файлы и папки из исходной папки загрузки.

При полной отмене установки удаляются каталоги установки, разделы реестра и папки данных.

Порядок отмены установки продукта
  1. На экране Отмена установки убедитесь, что выбран требуемый продукт.

    При удалении всех продуктов удаляется и менеджер установки SolidWorks.

  2. Отмените выбор продуктов, которые Вы не хотите удалять.

    В случае сохранения любого продукта менеджер установки SolidWorks не удаляется.

  3. Выберите для выполнения полную установку или настраиваемую пользователем.
    1. Нажмите кнопку Изменить в разделе Дополнительные параметры.

      Откроется экран Дополнительные параметры. Флажок "Файлы и папки программ" установлен.

    2. Выберите один или несколько параметров, чтобы выполнить отмену установки по выбору, или все параметры, чтобы выполнить полную отмену установки.
    3. Нажмите Назад в Сводку.
    4. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.
  4. Выберите Удалить объекты [image].
При нажатии кнопки Удалить объекты Менеджер установки SolidWorks немедленно запустит процесс удаления продуктов.
На уровень выше: Справка менеджера установки SolidWorks


Параметры сервера Workgroup PDM

Укажите параметры установки сервера SolidWorks Workgroup PDM.

Местоположение установки

Укажите местоположение установки сервера SolidWorks Workgroup PDM.

Продукты для установки

Укажите, какие серверные продукты Workgroup PDM следует установить:
Хранилище Workgroup PDM
Укажите место расположения данных хранилища Workgroup PDM. Для включения программы просмотра Workgroup PDM Viewer необходимо установить ее лицензию вместе с хранилищем.
Программа Workgroup PDM Viewer
При установке Workgroup PDM Viewer необходимо указать имя или IP-адрес компьютера, где размещено хранилище Workgroup PDM, к которому будет обращаться программа просмотра.
Workgroup PDM API

Лицензия для Workgroup PDM API включена в лицензии клиентов SolidWorks и Explorer. Для регистрации API требуются клиентские лицензии.

Для получения дополнительной информации

Подробнее об установке Workgroup PDM см. в разделеWorkgroup PDM.

Подробнее об использовании Workgroup PDM см. в разделе Workgroup PDM в документе Справка по SolidWorks.

На уровень выше: Справка менеджера установки SolidWorks


Юридическая информация

© Dassault Systèmes SolidWorks Corporation, компания Dassault Systèmes S.A., 175 Wyman Street, Waltham, Mass. 02451 USA, 1995-2011 гг. Все права защищены.

Информация и программное обеспечение, описываемое в настоящем документе, могут изменяться без предварительного уведомления со стороны корпорации Dassault Systemes SolidWorks Corporation (DS SolidWorks).

Никакая часть настоящего документа ни в каких целях не может быть воспроизведена или переделана в какой бы то ни было форме и какими бы то ни было средствами, будь то электронными или механическими, без письменного разрешения DS SolidWorks.

Описываемое в настоящем документе программное обеспечение поставляется по лицензии и может использоваться только в соответствии с условиями и положениями данной лицензии. Все гарантии, предоставляемые DS SolidWorks, как на программное обеспечение, так и документацию, сформулированы в лицензионном соглашении, и никакие замечания в содержании данного документа, как явные, так и подразумеваемые, не могут рассматриваться или считаться поправкой указанных положений, в том числе гарантий, данного лицензионного соглашения.

Патенты

Программное обеспечение SolidWorks® для трехмерного механического проектирования защищено патентами США5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 и иностранными патентами (например, EP 1,116,190 и JP 3,517,643).

Программное обеспечение eDrawings® защищено патентами США 7,184,044;7,502,027 и Канады 2,318,706.

Заявки на патенты США и иностранные патенты.

Товарные знаки и имена продуктов для продуктов и служб SolidWorks

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings и логотип eDrawings являются зарегистрированными товарными знаками DS SolidWorks, а FeatureManager – товарным знаком, находящимся в совместном владении с DS SolidWorks.

CircuitWorks, FloXpress, TolAnalyst и XchangeWorks являются товарными знаками Dassault Systèmes SolidWorks.

FeatureWorks является зарегистрированным товарным знаком компании Geometric Ltd.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Workgroup PDM, SolidWorks Simulation, SolidWorks Flow Simulation, eDrawings Professional и SolidWorks Sustainability являются именами продуктов Dassault Systèmes SolidWorks.

Остальные фабричные марки и названия продуктов являются товарными знаками или зарегистрированными товарными знаками, принадлежащими их владельцам.

КОММЕРЧЕСКОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ – ФИРМЕННОЕ

Программное Обеспечение является "коммерческим предметом", как определено в 48 C.F.R. 2.101 (OCT 1995), состоящим из "коммерческого программного обеспечения" и "коммерческой документации", как определено в 48 C.F.R. 12.212 (SEPT 1995), и предоставляется Правительству США для (а) покупки гражданскими агентствами в соответствии с правилами, описанными в 48 C.F.R. 12.212; или (б) покупки отделами Министерства Обороны в соответствии с правилами, описанными в 48 C.F.R. 227.7202-1 (JUN 1995) и 227.7202-4 (JUN 1995).

Если Вы получите требование от любого агентства Правительства США на предоставление Программного Обеспечения с правами, отличными от вышеуказанных, Вы должны направить описание такого требования компании DS SolidWorks, а компания DS SolidWorks в течение пяти (5) рабочих дней должна принять или отклонить Вашу просьбу. Подрядчик/Производитель: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 US.

Авторские права на продукты SolidWorks Standard, Premium, Professional и Образовательные версии

Части этого программного обеспечения © Siemens Product Lifecycle Management Software III (GB) Ltd., 1986-2011. Все права защищены.

Эта работа включает в себя следующее программное обеспечение, принадлежащее Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Все права защищены.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. Все права защищены.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Все права защищены.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. Все права защищены.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Все права защищены.

Части этого программного обеспечения © Geometric Ltd., 1998-2011.

Отдельные части этого программного обеспечения © Microsoft Corporation, 1996-2011. Все права защищены.

Отдельные части этого программного обеспечения используют PhysX™ компании NVIDIA, 2006-2010.

Отдельные части этого программного обеспечения © Luxology, LLC, 2001, 2011. Все права защищены, патенты ожидаются.

Отдельные части этого программного обеспечения © 2007-2011 DriveWorks Ltd.

Adobe Systems Inc. и ее лицензиары, 1984-2010. Все права защищены. Защищено патентами США 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; заявки на патенты рассматриваются.

Adobe, the Adobe logo, Acrobat, логотип Adobe PDF, Distiller и Reader являются зарегистрированными товарными знаками или товарными знаками Adobe Systems Inc. в США и других странах.

Дополнительные сведения об авторских правах SolidWorks® см. в Справке > SolidWorks "О программе SolidWorks".

Авторские права на продукты SolidWorks Simulation

Отдельные части этого программного обеспечения © 2008 Solversoft Corporation.

PCGLSS © Computational Applications and System Integration, Inc., 1992-2010. Все права защищены.

Авторские права на продукт SolidWorks Enterprise PDM

Outside In® Viewer Technology, © Oracle, 1992–2011.

© Microsoft Corporation, 2011. Все права защищены.

Авторские права на продукты eDrawings

Отдельные части этого программного обеспечения © Tech Soft 3D, 2000-2011.

Частичное авторское право © 1995-1998 Jean-Loup Gailly and Mark Adler.

Частичное авторское право © 1998-2001 3Dconnexion.

Частичное авторское право © 1998-2011 Open Design Alliance. Все права защищены.

Отдельные части этого программного обеспечения © Spatial Corporation, 1995-2010.

Это программное обеспечение частично основано на работах Independent JPEG Group.


Установка и управление множественными компьютерами

Менеджер установки SolidWorks обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SolidWorks.

Администрирующие образы SolidWorks

Если Вы устанавливаете программу SolidWorks на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

Сервер Workgroup PDM

Приложение Workgroup PDM – это программное обеспечение управления данными проекта, которое работает в среде SolidWorks или как отдельное приложение в Проводнике SolidWorks. Программа Workgroup PDM позволяет управлять проектами с помощью процедур разрегистрации, регистрации, контроля редакции, а также других администрирующих задач. При установке сервера Workgroup PDM создается хранилище Workgroup PDM, являющееся базой данных, в которой хранятся управляемые проекты SolidWorks.

Менеджер лицензий SolidNetWork

Менеджер лицензий SolidNetWork позволяет обеспечить работу пользователей количеством, превышающим количество лицензий, путем передачи лицензий в использование. В то время, когда клиентская лицензия не используется, она становится доступна для другого пользователя SolidWorks.

Кроме того, можно использовать менеджер лицензий SolidNetWork для распространения основных приложений SolidWorks (например, FeatureWorks).

На уровень выше: Справка менеджера установки SolidWorks


Новые версии не доступны

Новые версии не доступны для загрузки. Продолжите установку указанной версии.

Для продолжения установки нажмите кнопку Далее.

На уровень выше: Справка менеджера установки SolidWorks