SolidWorks Kurulum ve Yönetimi

Bu kılavuz, SolidWorks ürünlerinin hem bireysel hem de çoklu kurulumları için kurulum, lisans, yükseltme ve yönetilmelerini tanımlar.

Bireysel Kurulumlar | Birden Fazla Kurulumun Dağıtılması
Kurulum Bir yada birkaç bilgisayara kurulum. | Kurulum Bir çok istemci bilgisayara dağıtılan bir yönetim resminin oluşturulması.
Lisanslama Lisans aktivasyonu yada ağ lisanslaması. | Lisanslama Lisans aktivasyonu yada ağ lisanslaması.
Yükseltmeler Bireysel bilgisayarlar yeni bir sürüme geçirilir. | Yükseltmeler Birden fazla bilgisayar, o bilgisayarlarda kurulum yapmak için kullanılan yönetim resmini değiştirerek yeni sürüme geçirilir.
Yönetim Kurulumların değiştirilmesi, onarılması, kaldırılması ve yükseltilmesi. | Yönetim Yönetim resimlerinin ve istemcilerin yükseltilmesi, Ağ lisansı yönetimi, Workgroup PDM kasa yönetimi.

SolidWorks Kurulum Yöneticisi; SolidWorks, SolidWorks Toolbox, PhotoView 360, Workgroup PDM, ve SolidNetWork License Manager da dahil olmak üzere SolidWorks ürün bileşenlerinin ayar ve konfigürasyonlarının yapılmasına izin verir.

Workgroup PDM, SolidWorks ortamında veya SolidWorks Explorer içinde tek başına çalışan bir proje veri yönetimi yazılımıdır. Workgroup PDM projeleri, Teslim alma, teslim etme, revizyon kontrolü ve diğer yönetim görevleri için prosedürlerle yönetiyor.

SolidNetWork License Manager birden çok lisans istemcisini, lisansları ağ üzerinden dağıtarak destekler. Bu, yüzer lisanslar kullanarak kullanıcı sayısının lisans sayısını geçebilmesine imkan verir.

  • Bireysel Kurulum yada Yönetim Resmi
    SolidWorks ürünlerini her bilgisayara bireysel olarak mı kurmalısınız, yoksa bir yönetim resmi oluşturup tüm istemcilere kurulumu tek bir komut ile mi dağıtmalısınız?
  • SolidWorks Kurulumunu Başlatmak
    SolidWorks kurulumunu yerel bilgisayara bir DVD takarak, paylaşılan bir kurulum konumuna erişerel veya SolidWorks'ten indirerek başlayabilirsiniz.


Bireysel Kurulum yada Yönetim Resmi

SolidWorks ürünlerini her bilgisayara bireysel olarak mı kurmalısınız, yoksa bir yönetim resmi oluşturup tüm istemcilere kurulumu tek bir komut ile mi dağıtmalısınız?

Eğer yalnızca bir bilgisayara kuruyorsanız, yada düzineler veya yüzlerce bilgisayarı yönetiyorsanız seçenek belli. Aradaki durumlar için aşağıdaki karşılaştırmaları dikkate alın.

Bireysel kurulum | Yönetim resmi
Kullanıcılar kendi SolidWorks yönetimlerini gerçekleştirebilir. | Sistem yöneticisi çoklu kurulumları Seçenek düzenleyicisini kullanarak özelleştirerek, yeni bir kurulum oluşturmak veya varolan birini güncellemek, kurulumu bir yönetici olarak yürütmek, kurulumdan önce yada sonra dışarıdan komutlar yürütmek, değişik ürün gruplandırmaları ve bunlar gibi kurulum seçeneklerini belirleyebilir.
Bilgisayarlar, kurulumu gerçekleştiren kişi için, fiziken erişilebilir olmalılar. | İstemci bilgisayarlar, aynı ağ üzerinden erişilebilir oldukları sürece, ayrı ayrı konumlanmış olabilirler.
Değişik bilgisayarlara, bağımsız ayarlarla, değişik versiyonlar, servis paketleri veya ürünler kurabilirsiniz. | Seçenek Düzenleyiciyi kullanarak, yönetim resimleri çoklu kurulumlarda sürümler, servis paketleri, ürünler ve ayarlar arasında sürekliliği koruyabilir.
Servis paketlerini uygularken orijinal kaynak medya (DVD) gerekli. | Servis paketlerini uygularken medya sürücüleri gerekli değil.
Bilgisayarın bir ağ üzerinde bulunması gerekmez. | Uygulamayı dağıtmak için bir yerel ağ bağlantısı gereklidir; istemci bilgisayarda medya sürücüleri olmasına gerek yok.
 | İstemciler otomatik olarak güncellenebilir. Aynı yönetim resminden dağıtılan tüm istemciler aynı servis paketindeler. Çoklu sürümleri tutabilmek için, birden fazla yönetim resmi oluşturabilirsiniz.
 | Lisans aktivasyonu otomatik olabilir.
 | Bir yönetim resmisunucuda ek disk alanı gerektirir; istemciler aynı alana bireysel kurulumlarda ihtiyaç duyarlar.
Üst konu başlığ: SolidWorks Kurulum ve Yönetimi


SolidWorks Kurulumunu Başlatmak

SolidWorks kurulumunu yerel bilgisayara bir DVD takarak, paylaşılan bir kurulum konumuna erişerel veya SolidWorks'ten indirerek başlayabilirsiniz.

  • SolidWorks kurulumunu başlatmak için, aşağıdakilerden birini yapın:
    • Yerel bir bilgisayara diskten kurmak için, uygun diski bilgisayarın disk sürücüsüne takın.
    • Bir indirme dizininden kurmak için dizine göz atın ve setup.exe'yi çift tıklatın.
    • SolidWorks'ten indirerek kurmak için:
      1. SolidWorks web sayfasına gidin.
      2. Bir Abonelik Hizmeti Müşterisi olarak, e-mail ve şifreniz ile, veya SolidWorks seri numaranızla, oturum açın.
      3. Şunun altında, Self Servis, şuna tıklayın, Yazılım ve Güncellemeleri İndir.
      4. Şunun altında, Yazılım İndir'in altında, şunu tıklayın, indirilecek SolidWorks sürümü ve servis paketi.
Üst konu başlığ: SolidWorks Kurulum ve Yönetimi


Bireysel Kurulumlar

  • Bireysel Bilgisayarlarda Kurulum
    SolidWorks'ü bir bireysel bilgisayara birkaç değişik kurulum yöntemi ile kurabilirsiniz.
  • Bireysel Kurulumların Yönetimi
    Bireysel kurulumların yönetimi, tipik olarak kurulumların değiştirilmesi, onarılması, kaldırılması ve yükseltilmesinden oluşur.


Bireysel Bilgisayarlarda Kurulum

SolidWorks'ü bir bireysel bilgisayara birkaç değişik kurulum yöntemi ile kurabilirsiniz.

SolidWorks Kurulum Yöneticisi, kurulumu satın aldığınız ürünlere uyarlayarak gerçekleştirir. Kuruluma başlamadan önce:

  • SolidWorks seri numarasını hazır bulundurun.
  • Çalışan bir internet bağlantınız olduğundan emin olun.
SolidWorks Kurulum Yöneticisi, Microsoft Windows Installer, Office Web Components, Microsoft Visual Studio Tools for Applications, ve .NET Framework dahil olmak üzeredeğişik Microsoft bileşenlerine ihtiyaç duyar. Eğer Windows öngereksinim bileşenlerinin doğru sürümleri bilgisayarda kurulu değillerse, SolidWorks Kurulum Yöneticisi, SolidWorks ürünlerini kurmadan önce bunları otomatik olarak kurar.
Kurulum Yöntemi Sürecin Özeti
SolidWorks kurulm medyasını kullanarak Uygun DVD'yi bilgisayarın disk sürücüsüne yerleştirin.
SolidWorks kurulum medyası 32-bit ve 64-bit Windows kurulumları için ayrı DVD'ler sağlar.
Bir sunucuda indirme dizini kullanarak İndirme dizininde, setup.exe'yi çift tıklayın.
İndirme dizin, SolidWorks ürünlerini kurmakta olduğunuz bilgisayardan erişilebilir olmalı, ve kurulum başlamadan önce tüm kurulum dosyalarını içermeli. SolidWorks Kurulum Yöneticisi, eğer internet bağlantınız ve indirme dizinine yazım erişiminiz varsa, kayıp dosyaları bulmanıza yardımcı olabilir.
Bu bir yönetim resmi değildir. Bir istemci bilgisayarı kurmanın tek yolu SolidWorks yöneticisi tarafından dağıtılan HTML sayfasındaki bağlantıya tıklamaktır.
Varolan bir SolidWorks kurulmunu şunu kullanara güncellerken; Güncellemeleri Denetle Aşağıdakilerden birini yapın:
  • SolidWorks'de, Yardım > Güncellemeleri Denetle'yi tıklayın.
  • Microsoft Windows'da, Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.
Çalışan bir internet bağlantınız olmalı.

Workgroup PDM istemcileri, Kasanın güncellendiğini algılar. İstemcileri güncellemek için bir servis paketi indirmeniz gerekmez. Detaylar için Workgroup PDM online yardım'ında İstemcileri Güncelle'ye bakınız.

SolidWorks müşteri web sayfasından indirin.
  1. SolidWorks web sayfasına gidin.
  2. Bir Abonelik Hizmeti Müşterisi olarak, e-mail ve şifreniz ile, veya SolidWorks seri numaranızla, oturum açın.
  3. Şunun altında, Self Servis, şuna tıklayın, Yazılım ve Güncellemeleri İndir.
  4. Yazılım İndir'in altında, şunu tıklayın, Kurmak istediğiniz SolidWorks sürümü.
Çalışan bir internet bağlantınız olmalı.

Müşteri portalı sayfasına erişimi olan bir Abonelik Servisi Müşterisi olmalısınız.

Kurulum tamamlandığında, SolidWorks uygulamasını başlatın ve lisansı etkinleştirin.

Üst konu başlığ: Bireysel Kurulumlar


Bireysel Kurulumların Yönetimi

Bireysel kurulumların yönetimi, tipik olarak kurulumların değiştirilmesi, onarılması, kaldırılması ve yükseltilmesinden oluşur.

  • Bir Kurulumu Değiştirmek
    Kurulmamış ürünleri kurmak yada ürünleri kaldırmak için bir kurulumu değiştirebilirsiniz.
  • Bir Kurulumu Onarmak
    Eğer kurulu bir SolidWorks Ürünü ile bir sorun yaşarsanız, SolidWorks Kurulum yöneticisini kullanarak kurulumu onarabilirsiniz.
  • Bireysel bir Kurulumu Önceki bir Servis Paketine Geri Almak
    Bireysel bir kurulumu, aynı büyük sürümün içindeki daha önceki bir servis paketine geri almak için zaten kurulu olan servis paketini kaldırıp istenilen eski servis paketini kurun.
  • Bir Kurulumu Kaldırmak
    Bir kurulumu bireysel bir bilgisayardan veya bir istemci/sunucu ortamından kaldırabilirsiniz.
  • Yeni Sürüme Yükseltme
    Bireysel bir kurulumu daha yeni bir SolidWorks sürümüne yükseltmenin birkaç yöntemi vardır.
  • Ürünlerin Bir Arada Var Olma Kuralları
    Bu ürün bir arada var olma kuralları, yeni ürünlerin nasıl kurulduğunu ve varolan ürünlerin nasın yükseltildiğini belirler.
Üst konu başlığ: Bireysel Kurulumlar


Bir Kurulumu Değiştirmek

Kurulmamış ürünleri kurmak yada ürünleri kaldırmak için bir kurulumu değiştirebilirsiniz.

Eğer SolidWorks'ü kurup, bir eklentiyi daha sonra satın aldıysanız, krulumu yeni eklentiyi dahil edecek şekilde değiştirebilirsiniz. Eklentiyi her bireysel makinaya kurmalısınız.

Eğer orijinal SolidWorks paketinizi SolidWorks Professional veya SolidWorks Premium içerecek şekilde değiştirirseniz Workgroup PDM kurulmaz.
  1. Tum SolidWorks oturumlarının sonlandırılmış olduğundan emin olun.
  2. Windows Vista veya ilerisinde Başlat > Kontrol Paneli > Programlar ve Özellikler tıklayın.

    Daha öveki Windows sürümleri için Başlat > Kontrol Paneli > Program Ekle ve Kaldır tıklayın.

  3. Seçin, Değiştirmek istediğiniz SolidWorks kurulumunu seçin ve Değiştir'i tıklayın.
  4. SolidWorks Kurulum Yöneticisine Hoş Geldiniz ekranında, Bireysel kurulumu değiştir (bu bilgisayarda).'i tıklayın.
  5. Seri Numarası penceresinde, doğru seri numaralarının belirtilmiş olduğundan emin olun.
  6. Ürün Seçimi penceresinde kaldırılacak veya kurulacak ürünleri seçin.

    Bir Kurulumu Değiştirirken:

    • Yeni bir seri numarası da girseniz hiç bir ürün varsayılan olarak kaldırılmaz veya kurulmaz. Her ürün veya unsurun kurulum eylemini kendiniz değiştirmelisiniz.
    • Belirli bir bileşen için yansıtılan eylemi görmek için, bileşen adını tıklayın (ama işaret kutusunu değil). İstenilen kurulum işlemi ürün listesinin altındaki bilgi alanında görüntülenir.
    • Bir ürün bileşeninin yanındaki kutucuğu tıklayarak o bileşenin kurulum eylemini değiştirebilirsiniz. (Örneğin, eğer bileşenleri kuruyor veya kaldırıyorsanız, kutucuğu seçmek o bileşenin kurulmasını yada kaldırılmasını belirtirken kutucuğu temizlemek bileşenin kurulmamasını veya kaldırırlmamasını belirtir.)
    • Bir bileşen kurulum eylemini ilk belirtilenden değiştirdiğinizde, listede ürün bileşeninin yanında bir yıldız işareti (*) belirir.
    • Eğer bir bileşen opsiyonel kurulum alt bileşenleri içeriyorsa, bir + simgesi bileşenin yanında görünür. Bir bileşenin olası alt bileşenlerini görmek için, + simgesini tıklayın.
    • Eğer bir bileşen tüm alt bileşenlerini göstermek için genişletilmişse, bir - simgesi bileşenin yanında görünür. Alt bileşenler listesini daraltmak için, - simgesini tıklayın.

  7. Özety ekranında, Şimdi Değiştir'i tıklayın.
  8. Kurulum Tamamlandı ekranında, Bitir'i tıklayın.
Üst konu başlığ: Bireysel Kurulumların Yönetimi


Bir Kurulumu Onarmak

Eğer kurulu bir SolidWorks Ürünü ile bir sorun yaşarsanız, SolidWorks Kurulum yöneticisini kullanarak kurulumu onarabilirsiniz.

Biireysel bir kurulumu onarabilirsiniz. Bir yönetim resmini onaramazsınız; kurulumu kaldırıp yönetim resmini yeniden kurmalısınız.
  1. Windows Vista veya sonraki sürümlerde Başlat > Denetim Masası > Programlar > Programlar ve Özellikler öğesine tıklayın.

    Daha öveki Windows sürümleri için Başlat > Kontrol Paneli > Program Ekle ve Kaldır tıklayın.

  2. Onarmak istediğiniz soldWorks sürümünü seçin ve Değiştir'i tıklayın.
  3. SolidWorks Kurulum Yöneticisine Hoş Geldiniz ekranında, Bireysel kurulumu onar (bu bilgisayarda).'ı tıklayın.
  4. Onarılacak Ürünler ekranında, onarılacak ürünü seçin.
  5. Ekrandaki ürünlerin geri kalanını temizleyin.
  6. Onar'ı tıklayın.
Üst konu başlığ: Bireysel Kurulumların Yönetimi
Üst konu başlığ: Kurulum Hataları/Kurulum İptal Oldu


Bireysel bir Kurulumu Önceki bir Servis Paketine Geri Almak

Bireysel bir kurulumu, aynı büyük sürümün içindeki daha önceki bir servis paketine geri almak için zaten kurulu olan servis paketini kaldırıp istenilen eski servis paketini kurun.

Üst konu başlığ: Bireysel Kurulumların Yönetimi


Bir Kurulumu Kaldırmak

Bir kurulumu bireysel bir bilgisayardan veya bir istemci/sunucu ortamından kaldırabilirsiniz.

  1. Tum SolidWorks oturumlarının sonlandırılmış olduğundan emin olun.
  2. SolidWorks lisansını başka bir bilgisayara geçirmek istiyorsanız, SolidWorks kurulumunu bu bilgisayardan kaldırmadan önce lisansı diğer bilgisayara geçirin.

    SolidWorks lisanslarını transfer etmek hakkında daha fazla bilgi için, bakınız Bir Lisansın Transferi.

  3. Windows Vista veya sonraki sürümlerde Başlat > Denetim Masası > Programlar > Programlar ve Özellikler öğesine tıklayın.

    Daha öveki Windows sürümleri için Başlat > Kontrol Paneli > Program Ekle ve Kaldır tıklayın.

  4. Kaldırılacak ürün bileşenini seçin.

    Bazı durumlarda, belirli bir büyül sürüm versiyonu için birden fazla servis paketi bileşeni bulunabilir. SolidWorks kurulumunu kaldırmak için, tüm Servis Paketi elemanlarını da kaldırın.

  5. Kaldırma ekranında:
    1. Kaldırılacak ürünleri seçin: Varsayılan olarak tüm ürün bileşenleri seçilidir.
    2. Kaldırılmasını istemediğiniz ürünlerin işaretlerini kaldırın.
    3. Özel veya tam kaldırmayı seçin. Varsayılan olarak SolidWorks Kurulum Yöneticisi standart kaldırma uygular ve tüm Program Dosya ve Klasörlerini kaldırır.

      1. Gelişmiş Seçenekler'de Değiştir tıklayın

        Gelişmiş Seçenekler ekranı görünür ve Program Dosya ve Klasörleri seçilir

      2. Özel kaldırma için istediğiniz seçenekleri seçin.
      3. Özete Geri Dön'ü tıklayın.
      4. Özet ekranında Gelişmiş Seçenekler'i genişletin.

    4. Öğeleri Kaldır'ı tıklayın.
Üst konu başlığ: Bireysel Kurulumların Yönetimi


Yeni Sürüme Yükseltme

Bireysel bir kurulumu daha yeni bir SolidWorks sürümüne yükseltmenin birkaç yöntemi vardır.

Şunları yaptığınızda yeni sürüme yükseltebilirsiniz:
  • Yeni kurulum medyası alınca
  • SolidWorks başlatılırken yükseltmelerden haberdar edilince
  • Güncellemeleri el ile denetleyince
  • SolidWorks Kurulum Yöneticisinin yeni bir oturumunu başlatınca

Yeni bir büyük sürüm kurulurken, daha önce kurulmuş olan büyük sürümü yükseltebilir veya yeni sürümü paralel olarak kurabilirsiniz. Eğer daha önce kurulmuş bir büyük sürüm için bir Servis Paketi kuruyorsanız, o sürüm otomatik olarak güncellenir.

  • Güncellemelerin El İle Denetlenmesi
    Zaten kurulu olan SolidWorks sürümü için güncellemeleri bu yöntemlerden birini kullanarak denetleyebilirsiniz.
  • Workgroup PDM İstemcilerinin Yükseltilmesi
    İstemciler, kasa güncellendikten sonraki ilk bağlantılarında güncellenmeleri için uyarılırlar. İstemci güncellemeleri için servis paketi gerekmez.
  • Yükseltme Uyarıları
    Değişik büyük sürümlerle birden fazla kurulumu olabilen ürünler her zaman büyük yükseltmeleri, veya büyük sürümler arasında tek başına yükseltilmeyi desteklemeyebilirler.
Üst konu başlığ: Bireysel Kurulumların Yönetimi


Güncellemelerin El İle Denetlenmesi

Zaten kurulu olan SolidWorks sürümü için güncellemeleri bu yöntemlerden birini kullanarak denetleyebilirsiniz.

  • SolidWorks'de, Yardım > Güncellemeleri Denetle'yi tıklayın.
  • Microsoft Windows'da, Başlatt > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.
Üst konu başlığ: Yeni Sürüme Yükseltme


Workgroup PDM İstemcilerinin Yükseltilmesi

İstemciler, kasa güncellendikten sonraki ilk bağlantılarında güncellenmeleri için uyarılırlar. İstemci güncellemeleri için servis paketi gerekmez.

Kasaya Göre İstemci Durumu | Eylem
Kasa ile aynı sürüm | Hiçbiri
Aynı büyük sürüm, kasadan daha yeni | Hiçbiri
Daha yeni büyük sürüm, kasadan daha yeni | Bağlantı engellenir
Aynı büyük sürüm, kasadan daha eski | Tercihi güncelleme
Daha eski büyük sürüm, kasadan daha eski | Mecburi güncelleme

Workgroup PDM istemcilerini güncellemek konusunda daha fazla detay için Workgroup PDM Yardımı'nda İstemcilerin Güncellenmesi'ne bakın.

Üst konu başlığ: Yeni Sürüme Yükseltme
Üst konu başlığ: Workgroup PDM VaultAdmin Yönetimi


Yükseltme Uyarıları

Değişik büyük sürümlerle birden fazla kurulumu olabilen ürünler her zaman büyük yükseltmeleri, veya büyük sürümler arasında tek başına yükseltilmeyi desteklemeyebilirler.

Bu durumda, SolidWorks Kurulum Yöneticisi önce yeni sürümü kurup sonra eskisini kaldırarak simüle eder. Bu zamanda, ana SolidWorks ürünü büyük yükseltmeleri desteklerken diğer ürünler desteklemez.

Bunun sonuçları şunlardır:
  • Ana SolidWorks ürününü büyük sürümler arasındayken yükseltirken:
    • Varolan kurulum konumunuz değişmez.
    • Yükseltme bir sorun oluşursa veya yükseltme sırasında iptal ederseniz geri alınabilir.
  • Diğer ürünler büyük sürümler arasında yükseltilirlerse:
    • HEr ürün önce yeni bir ürün olarak yeni bir konuma kurulur, sonra orijinal kurulum kaldırılır.
    • Birkez başlandığında, bir hata olduğunda veya yükseltme sırasında iptal ederseniz, kurulum geri alınamaz.
Üst konu başlığ: Yeni Sürüme Yükseltme


Ürünlerin Bir Arada Var Olma Kuralları

Bu ürün bir arada var olma kuralları, yeni ürünlerin nasıl kurulduğunu ve varolan ürünlerin nasın yükseltildiğini belirler.

Kural | Örnekler
Bir ana SolidWorks ürününün birden fazla büyük sürümüne izin verilir, bu servis paketi veya büyük sürümden bağımsızdır (aşağıda belirtilen üç ürün hariç). SolidWorks 2010 SP3.0, ve SolidWorks 2011 SP0.0 aynı bilgisayarda bir arada var olabilirler.

Fakat, eğer SolidWorks 2011 SP0.0 bir bilgisayara kurulu ise ve siz SolidWorks 2011 SP1.0'ı kurarsanız SolidWorks Kurulum Yöneticisi SP0.0 sürümünü yeni SP1.0 sürümü ile değiştirir.

SolidWorks 2011 SP0.0 ve 2011 SP1.0 aynı bilgisayarda bir arada var olamazlar.

Bir bilgisayarda, aşağıdaki ürünlerin yalnızca bir versiyonuna izin verilir:
  • Workgroup PDM Server
  • SolidNetWork License Manager
 Eğer SolidWorks 2011 SP0.0 kurulu ise, Workgroup PDM Server 2011 SP0.0'a yükseltilir, SolidWorks'ün daha önceki bir büyük sürümü bilgisayarda kalsa dahi.
Herhangi bir büyük sürüm için eklenmiş bir ürünün yalnızca bir sürümü kurulabilir. | Eğer SolidWorks 2011 SP0.0, 2011 SP1.0'a yükseltilirse, SolidWorks Explorer 2011 SP0.0 otomatik olarak 2011 SP1.0'a yükseltilir. Fakat, SolidWorks Explorer 2010 SP4.0 aynı zamanda bu bilgisayarda var olabilir.
Üst konu başlığ: Bireysel Kurulumların Yönetimi


Birden Fazla Kurulum

  • Birden Fazla İstemciye Dağıtım
    SolidWorks ürününü birden fazla istemviye, bir yönetim resmi oluşturup kurulumu istemcilere dağıtarak kurabilirsiniz.
  • Yönetim Resimlerini Kullanmak
    Bir yönetim resmi SolidWorks ürünlerinin tek bir konumdan konfigüre edilebilir kurulumlarına izin verir.
  • Komut Satırı Dağıtımı
    Bir komut satırı veya toplu iş dosyası kullanarak otomatik olarak bir yönetim resmini dağıtabilirsiniz (sessiz kurulum).
  • Birden Fazla Kurulumun Yönetimi
    Birden fazla kurulum için yönetim görevleri, yönetim resimlerinin yeni sürümlere güncellenmesi, servis paketi güncellemelerinin uygulanması ve kurulumların kaldırılmasını içerir.


Birden Fazla İstemciye Dağıtım

SolidWorks ürününü birden fazla istemviye, bir yönetim resmi oluşturup kurulumu istemcilere dağıtarak kurabilirsiniz.

Birden fazla istemciye dağıtma süreci:
  1. Bir yönetim resmi oluşturun.
    • SolidWorks Kurulum Yöneticisinden Yönetim Resmi Oluşturmak
    • Komut Satırını Kullanarak Yönetim Resminden Kurulum
  2. Yönetim resmini istemcilere dağıtın.
    • Email ile İstemcilere bir Yönetim Resmi Dağıtmak
    • Komut Satırını Kullanarak Yönetim Resminden Kurulum
  3. Lisanslama'yı uygulayın.
    • Bireysel Lisansların Yönetimi
    • SolidNetWork License Manager'ı kullanarak Lisans Yönetimi
Üst konu başlığ: Birden Fazla Kurulum


Yönetim Resimlerini Kullanmak

Bir yönetim resmi SolidWorks ürünlerinin tek bir konumdan konfigüre edilebilir kurulumlarına izin verir.

Yönetim resmini ağ üzerindeki herhangi bir bilgisayardan, bir istemci de dahil olmak üzere, kurabilirsiniz.
  • Yönetim resmi paylaşılan bir klasörde olmalı.
  • Eğer tüm ürünleri eklerseniz, yönetim resmi disk alanı gereksinimi 7GB veya fazlası olabilir.
  • Eğer yönetim resmini yükselttiğinizde paylaşım ismini güncellerseniz, uygulama bir daha başlatıldığında istemci otomatik olarak yükseltilir. Ayrıntılar için bkz.İstemcileri Yönetim Resimlerinden Yükseltmek.
  • İstemcilerin kendi bilgisayarlarında yönetici ayrıcalıkları olmalı, yoksa Kurulumu farklı bir kullanıcı olarak yürüt. seçeneği de seçilmiş olmalı.
    Bu seçenek Windows Vista veya daha yenisinde desteklenmez.

Bir kez yönetim resmini oluşturunca, Yönetim Resmi Seçenek Düzenleyicisi kurulum seçenek ayarlarını o resmi kuran kullanıcı ve gruplar için yönetebilir. Ayrıntılar için bkz. Yönetim Resmi Seçenek Düzenleyicisi.

  • SolidWorks Kurulum Yöneticisinden Yönetim Resmi Oluşturmak
    Eğer SolidWorks'ü birden fazla bilgisayara kuruyorsanız, Bir yönetim resmi oluşturup uygulamayı diğer bilgisayarlara dağıtabilirsiniz.
  • Yönetim Resmi Seçenek Düzenleyicisi
    Yönetim Resmi Seçenek Düzenleyicisi bireysel makinalar ile makinalardan oluşan gruplar için farklı konfigürasyonlar belirlemenize izin verir.
  • Email ile İstemcilere bir Yönetim Resmi Dağıtmak
    Bir kez paylaşılan bir yönetim resmi oluşturduğunuzda, istemcileri email ile bilgilendirebilirsiniz.
  • İstemcilere bir Yönetim Resminin Reklamını Yapmak
    Yeni bir yönetim resminin kurulumunu istemcilere duyurmak için bir komut yürütebilirsiniz.
Üst konu başlığ: Birden Fazla Kurulum


SolidWorks Kurulum Yöneticisinden Yönetim Resmi Oluşturmak

Eğer SolidWorks'ü birden fazla bilgisayara kuruyorsanız, Bir yönetim resmi oluşturup uygulamayı diğer bilgisayarlara dağıtabilirsiniz.

  1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
  2. Goş Geldiniz ekranında, Yönetim resmini seçin.

    Yönetim resmi oluşturulması seçenekleri görünür:

    Yeni bir resmi, varsayılan ayarları kullanarak oluştur.
    Resmi varsayılan konfigürasyon seçeneklerini kullanarak oluştur (yani, varolan bir yönetim resminin zaten belirlenmiş ayarlarına göre değil).
    Varolan bir resimden ayar ve dosyaları kullanarak yeni bir resim oluşturun
    Resmi, varolan bir yönetim resmi için belirtilmiş olan konfigürasyon ayarlarını kullanarak oluştur. Varolan yönetim resminin kurulum dizinini belirtmek için Gözat'ı tıklayın.
    Hem 32-bit hem de 64-bit yönetim resimleri oluştur.
    Tek bir bilgisayarda hem 32-bit, hem 64-bit yönetim resimleri oluşturabilirsiniz yada yalnızca bilgisayar mimarinize denk gelen yönetim resmini kurabilirsiniz. Her iki resmi de oluşturmak, hem 32-bit hem de 64-bit kurulum medyasına erişiminiz olmasını gerektiriyor.

  3. Erandaki yönergeleri izleyin.
Üst konu başlığ: Yönetim Resimlerini Kullanmak


Yönetim Resmi Seçenek Düzenleyicisi

Yönetim Resmi Seçenek Düzenleyicisi bireysel makinalar ile makinalardan oluşan gruplar için farklı konfigürasyonlar belirlemenize izin verir.

Bir yönetim resminioluşturduktan sonra, SolidWorks Kurulum Yöneticisi seçenek Düzenleyiciyi başlatmanızı ister. Seçenek Düzenleyiciyi ayrıca, Yönetim Resmi kurulum dizininde, sldAdminOptionEditor.exe'ı çift tıklayarak başlatabilirsiniz.

Makina grupları veya bireysel makinalar için değişik kurulum konfigürasyonlarını belirtmek için, grup ve makina isimlerini Yönetim Resmi Seçenek Düzenleyicisine ekleyin ve sonra o grup ve makinalar için kurulum seçeneklerini belirleyin.

  • Grup ve Makinaları Eklemek ve Silmek
    Yönetim Resmi Seçenek Düzenleyicisi bireysel makinalar ile makinalardan oluşan gruplar için farklı konfigürasyonlar belirlemenize izin verir.
  • Seçenek Ayarlarını Görüntülemek ve Düzenlemek
    SolidWorks Yönetim Resmi Seçenel Düzenleyicisi resim için belirtilen grup ve makinalar için seçenek ayarlarını görüntülemenizi ve değiştirmenizi sağlar.
  • 32-Bit ve 64-Bit Resimler arasında Geçiş
    Eğer yönetim resmi kurulum dizininde hem 32-bit, hem 64-bit yönetim resimleri oluşturduysanız, Seçenek Düzenleyicisini her iki resimde de kullanabilirsiniz.
  • Kurulumları Seçenek Düzenleyicisi ile Dağıtmak
    Kurulumları doğrudan seçenek düzenleyicisinden email talimatları kullanarak dağıtabilirsiniz.
  • Seçenek Düzenleyicisinden Çıkış
    Seçenek Düzenleyicisinden çıkmak için Tamam veya Kapat'ı tıklayabilirsiniz.
  • Seçenek Düzenleyiciye bir Masaüstü Kısayolu Oluşturmak
    Belirli bir Yönetim Resmi için uygulamanın içinden bir Windows masaüstü kısayolu oluşturabilirsiniz.
Üst konu başlığ: Yönetim Resimlerini Kullanmak


Grup ve Makinaları Eklemek ve Silmek

Yönetim Resmi Seçenek Düzenleyicisi bireysel makinalar ile makinalardan oluşan gruplar için farklı konfigürasyonlar belirlemenize izin verir.

Örneğin, bazı makinaları belli bir ürün bileşeni seti kullanacak şekilde ayarlamak isterken diğerlerinin farklı bir ürün bileşenleri seti kullanmasını isteyebilirsiniz. Yönetim resmi kullanıyor olsanızda, Seçenek Düzenleyicisi grup ayarları değişik makinalara değişik ürün alt grupları kurmanıza olanak verir.

Bir grup eklemek için:
  1. Global Ayarlar'a sağ tıklayın sonra Grup Ekle'yi tıklayın.
  2. Grup adını girin.
Makina eklemek için:
  1. Varolan bir grubu veya Global Ayarlar'ı sağ tıklayın sonra Makina Ekle'yi tıklayın.
    Bir grubu sağ tıklarsanız makinalar o gruba eklenir. Yoksa üst seviyeden eklenirler.
  2. Aşağıdakilerden birini yapın:
    • Bileşenlerin seçilmesi için bir veya daha fazla makina adını Makina İsimleri arasından seçin.

      Birden çok makina adı, boşluk, tab, virgül, nokta, ik nokta üst üste veya noktalı virgül ile ayrılabilir. Makina isimlerinin listesini bir başka dosyadan kopyalayıp yapıştırabilirsiniz.

      Makina isimleri alan adı bielirticileri içermezler. Örneğin pluto.solidworks.com geçersizdir.

    • Ağdan bilgisayarları seçmek için Birden Fazla Makina Ekle'yi tıklayın.
Varolan bir makinayı bir gruba taşımak için: Makinayı grubun üstüne sürükleyin.
Bir makinayı bir gruptan çıkarmak için: Makinayı Global Ayarlar'a veya başka bir grubun üstüne sürükleyin.
Bir grup yada makinayı silmek için: Grup veya makinayı sağ tıklayıp Grubu Sil veya Makinayı Sil'i tıklayın.
Bir grubu silerseniz, o gruptaki tüm makinalar da silinir.
Tüm grup ve makinaları silmek için: Global Ayarlar'a sağ tıklayın sonra Tümünü Sil'i tıklayın.
Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Seçenek Ayarlarını Görüntülemek ve Düzenlemek

SolidWorks Yönetim Resmi Seçenel Düzenleyicisi resim için belirtilen grup ve makinalar için seçenek ayarlarını görüntülemenizi ve değiştirmenizi sağlar.

  • Seçenek Düzenleyiciyi ilk başlattığınızda, seçenek ayarları salt okunur olarak görüntülenirler. Düzenleme ikonu gölgeli değil: .
    Global Ayarlar'a tıklamak bir grup veya makinanın seçenek ayarlarının bir özetini gösterir:
    Kapsam | Gösterilen Seçenek Ayarı
    Global Ayarlar | Yönetim resmi için belirtilen tüm seçenekler
    Grup | Global ayarlara göre grup ayarlarındaki farklılıklar
    Makine | Grup ayarlarına göre makina ayarlarındaki farklılıklar
  • Seçenek ayarlarına değişiklikler yapmak için, Düzenle simgesine tıklayın. Simges gölgelenir ( [image]) ve daha detaylı bir seçenek ayarları listesi görüntülenir.

    Global Ayarlar'a tıklamak bir grup veya makinanın seçenek ayarlarını değiştirmenize izin verir. Bir seçenek ayarını miras alınan Global veya Grup ayarları değerinden değiştirirseniz o seçenek vurgulanır.

    Eğer düzeneleme simgesini tekrar tıklarsanız salt okunur duruma geri döner.

    Değişiklik yaparsanız Seçenek Düzenleyicisi değişiklikleri kaydetmek için sorar ve sonra çıkar.

  • Grup ve Makinalar için Seçenek Ayarlarının Belirlenmesi
    Tüm makinalar için (Global Ayarlar), makina grupları için ve tek makinalar için seçenek ayarları belirleyebilirsiniz.
  • Global ve Grup Seçenek Ayarlarının Miras Alınması
    Global Ayarlar veya gruplar için seçenek ayarları altlarındaki öğeler tarafından miras alınır.
Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Grup ve Makinalar için Seçenek Ayarlarının Belirlenmesi

Tüm makinalar için (Global Ayarlar), makina grupları için ve tek makinalar için seçenek ayarları belirleyebilirsiniz.

  1. Seçenek Düzenleyicide değiştirilecek objeyi tıklayın (Global Ayarlar, bir grup vaya bir makina).
  2. Sağda Düzenleme simgesini [image] tıklayın.

    Düzenleme simgesi gölgelenir ( [image]) ve daha detaylı bir seçenek ayarları listesi görüntülenir.

  3. Seçenek ayarlarında değişiklikleri solda seçilmiş öğe için sağda seçenek ayarlarını tıklayarak yapın.

    Global Ayarlar'ı değiştiren değişiklikler vurgulanır.

  4. Değişiklikleri kaydetmek için Tamam veya Kapat'ı tıklayın.

    Tamam
    Seçenek Düzenleyicisi değişiklikleri kaydeder ve çıkar.
    Kapat
    Seçenek Düzenleyicisi değişiklikleri kaydetmek için sorar ve sonra çıkar.

  • Yönetim Resmi Seçenek Ayarları
    Seçenek Düzenleyici, bireysel istemciler veya gruplar için, seri numaraları, istemci kurulum seçenekleri, kurulacak yazılım bileşenleri ve toolbox konumu da dahil olmak üzere seçenek ayarlarını belirtmenize izin verir.
Üst konu başlığ: Seçenek Ayarlarını Görüntülemek ve Düzenlemek


Yönetim Resmi Seçenek Ayarları

Seçenek Düzenleyici, bireysel istemciler veya gruplar için, seri numaraları, istemci kurulum seçenekleri, kurulacak yazılım bileşenleri ve toolbox konumu da dahil olmak üzere seçenek ayarlarını belirtmenize izin verir.

Seri Numaraları

İstemci makinalara kurulacak ürünlerin seri numaralarını girin.
SolidWorks ürünlerini satın almanın birden fazla yolu olduğu için bazı seri numaraları iki yada daha fazla ürünü kapsayabilir. Örneğin, bir SolidWorks seri numarası ayrı bir SolidWorks Simulation seri numarası girmeden SolidWork Simulation'ı kurmanıza olanak verebilir. Ek olarak, bazı ürünler seri numaraları gerektirmezler. Eğer seri numaralarınızla ilgili bir sorunuz var ise VAR'ınızla temasa geçin.
Eğer lisansları SolidNetWork ile yönetiyorsanız:
  • İlk seri numarası alanına SolidNetWork seri numaralarını girin.
  • SNL Server port@server alanına SolidNetWork License Manager sunucu adı ve bağlantı noktasını nnnnn@servername formatında girin. Birden çok girdiyi noktalı virgüller ile ayırın.

Daha fazla bilgi için, bakınızSolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak.

İstemci Kurulum Seçenekleri

Büyük sürümlerin istemci kurulumlarını nasıl gerçekleştirmek istiyorsunuz?
İstemci kurulumlarının varolan sürümlere nasıl davranacağını belirleyebilirsiniz:
  • Varolan bir büyük sürümü yükselt (eğer var ise).

    Bu seçeneği seçmek eski sürüm kurulumunu yenisine yükseltir

  • Yeni bir büyük sürüm oluştur.

    Bu seçeneği seçmek eski sürüm kurulumu koruyarak bu büyük sürüm için yeni kurulum oluşturur.

    Yeni sürüm kurulumu için bir konum belirleyin, Gözat'a tıklayın.

Yeni büyük sürümü kurmadan önce en son önceki sürümü kaldırmak istiyor musunuz?
Büyük sürümü kaldırmak isteyip istemediğinizi belirtebilirsiniz:
  • Hayır, önce kaldırma.

    Kaldırmamak için bunu seçin.

  • Evet, özel bir kaldırma uygula.
    Şunları kaldırmak için bunu seçin:
    • Program Dosya ve Klasörleri
    • Kayıt Girdileri
    • Veri Dosya ve Klasörleri
SolidWorks ayarlarını nasıl uygulamak istiyorsunuz?
SolidWorks kurulumlarının ayarlarını istemci makinadaki ayarlara göre belirleyebilir veya ayar kopyalama sihirbazı ile verebilirsiniz.
  • Geçerli ayarları (eğer varsa) kullanın yada SolidWorks varsayılan ayarlarını kullanın

    Eğer istemci makinada tanımlı SolidWorks ayarları varsa onları kullanın. (istemcide özellikle tanımlanmamış ayarlar için SolidWorks varsayılanları kullanılır.)

  • Ayar Kopyalama Sihirbazından verilmiş bir ayarlar dosyasını kullan.
    Bu seçeneği seçmekvarolan bir Ayar kopyalama Sihirbazı verme dosyasından seçenek ayarlarını belirtmenize izin verir. (Tipik olarak bu dosyanın adı solidworkssettings.sldreg.)
    • Gözat'a tıklayarak varolan bir ayarlar dosyasını bulun.
    • Yeni'yi tıklayarak sihirbazı başlatarak yeni bir ayar dosyası oluşturun.
İstemci kurulumlarını nasıl etkinleştirmek istiyorsunuz?
Ürünü otomatik olarak mı yoksa kullanıcı tarafından kurulum sonrası mı yapılacağını seçebilirsiniz.
  • Her istemci kurulumu tamamlandığında otomatik olarak etkinleştir.
    Bu seçeneği seçmek, ürün etkinleştirilmesinin otomatik olarak SolidWorks Ürün Aktivasyonu dosyasını kullanarak yürütülmesini belirtir. (Tipik olarak bu dosyanın adı AutoActivation.xml.)
    • Gözat'a tıklayarak varolan bir aktivasyon dosyasını bulun.
    • Yeni'yi tıklayarak sihirbazı başlatarak yeni bir aktivasyon dosyası oluşturun.
  • Otomatik olarak etkinleştirme.

    Bu seçeneği seçmek otomatik aktivasyon olmayacağını belirtir. İstemci, kurulumdan sonra ürün aktivasyonuu gerçekleştirir.

Eğer otomatik ürün aktivasyonu belirtirseniz, yönetim resmi paylaşılan ağ konumundan erişilebilir olmalı. İstemciler SolidWorks'ü kurulumdan sonra çalıştırırlar. Eğer yönetim resmine, o resimden kurulan istemciler erişemiyorsa, o istemciler otomatik aktivasyonu tamamlayamazlar. SolidWorks Ürün Aktivasyonu manüel olarak gerçekleştirilmeden SolidWorks'ü çalıştıramazlar.

Yönetim Seçenekleri

Her kurulum sırasında bir tanılama günlüğü oluştur
Bir istemci kurulumu bir tanılama günlüğü oluşturabilir ve bu kurulum sorunlarını gidermede kullanılabilir. Bu günlüğü oluşturmak istemci kurulumunu yavaşlatır.
Kurulumu farklı bir kullanıcı olarak yürütün.
İstemci kurulumu farklı bir kullanıcı olarak yürütülebilir. Bu seçenek bireysel kullanıcıların yerel makinalarında önetici izinleri yoksa faydalı olabilir.
Bu seçenek Windows Vista, Windows 7, veya daha yenisinde desteklenmez.
Kurulumdan önce veya sonra bir program çalıştır
İstemci kurulumundan önce veya sonra özel bir programın çalışmasını ayarlayabilirsiniz.
Müşterilerin SolidWorks Kullanıcı Deneyimi Programına katılmalarını istiyor musunuz?
Müşterilerin SolidWorks Kullanıcı Deneyimi Programına katılmalarını belirtebilirsiniz. Performans bilgisi, SolidWorks Corporation'a ürünü iyileştirmeye yardım etmek için yollanır. Bu süreç şeffaf ve gizlidir. Detaylar için, Müşteri Deneyimi Geliştirme Programı.

Kurulacak Yazılım

Kurulacak SolidWorks bileşenlerini belirtebilirsiniz.
  • Ürün bileşeninin yanındaki kutucuğu işaretlemek bileşenin istemci kurulumunda kurulacağını belirtir.
  • Kutucuğu işaretlememek de kurulmayacağını belirtir.
  • Eğer bir bileşen opsiyonel kurulum alt bileşenleri içeriyorsa, bir + simgesi bileşenin yanında görünür. Bir bileşenin olası alt bileşenlerini görmek için, + simgesini tıklayın.
  • Eğer bir bileşen tüm alt bileşenlerini göstermek için genişletilmişse, bir - simgesi bileşenin yanında görünür. Alt bileşenler listesini daraltmak için, - simgesini tıklayın.
Diller spesifikasyonu yalnızca SolidWorks ürünü için kurulan dilleri sınırlar. Diğer ürün kurulumları bu değişiklikten etkilenmezler Örneğin, SolidWorks eDrawings®, SolidWorks Workgroup PDM, ve SolidWorks Explorer tüm dilleri kurarlar.

Toolbox Seçenekleri

Hangi standartların destekleneceği ve varsayılan Toolbox klasör konumunu seçebilirsiniz.

Toolbox'a birden çok kullanıcının erişmesi normaldir.

Konum Toolbox'ın eski bir sürümünü içeriyorsa istemci kurulumu bunu yükseltir. Bu dosyalar eski SolidWorks sürümleri ile uyumlu olmazlar.
Eğer eski Toolbox sürümünü tutmak istiyorsanız başka bir Toolbox konumu belirtmelisiniz.

Detaylar için SolidWorks Yardım'da Toolbox'a bakın.

Üst konu başlığ: Grup ve Makinalar için Seçenek Ayarlarının Belirlenmesi


Global ve Grup Seçenek Ayarlarının Miras Alınması

Global Ayarlar veya gruplar için seçenek ayarları altlarındaki öğeler tarafından miras alınır.

Örneğin:
  • Global Ayarlar için tanımlanan ayarlar tüm grup ve makinalar tarafından miras alınır.
  • Bir grup için tanımlanan ayarlar o gruptaki tüm makinalar tarafından miras alınır.

Bir makina veya grup için eçenek ayarlarını varsayılan veya miras alınan ayarları değiştirecek şekilde değiştirebilirsiniz. Bir seçenek ayarını varsayılan veya miras alınan değerinden değiştirirseniz o seçenek vurgulanır.

Seçenek ayarlarını orijinal miras alınan değerlerine geri döndürmek için grup veya makinaya sağ tıklayın ve Global Ayarlara Geri Dön'ü yada Grup Ayarlarına Geri Dön'ü tıklayın.
Üst konu başlığ: Seçenek Ayarlarını Görüntülemek ve Düzenlemek


32-Bit ve 64-Bit Resimler arasında Geçiş

Eğer yönetim resmi kurulum dizininde hem 32-bit, hem 64-bit yönetim resimleri oluşturduysanız, Seçenek Düzenleyicisini her iki resimde de kullanabilirsiniz.

  • Seçenek Düzenleyicide 32 veya 64'ü tıklayarak 32-bit veya 64-bit resim üzerinde çalışın.

    Ayarla veya Dağıt'ı tıklamak o resim için seçenek ayarlarını görmeyi, değiştirmeyi veya kurulumları dağıtmayı sağlar.

Eğer hem 32-bit hemde 64-bit resimleriniz var ise, Global Ayarlar, gruplar ve grup ayarları, ve bireysel makina ayarlarınıher resim için ayrı ayrı belirtmelisiniz.
Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Kurulumları Seçenek Düzenleyicisi ile Dağıtmak

Kurulumları doğrudan seçenek düzenleyicisinden email talimatları kullanarak dağıtabilirsiniz.

Yönetim resmi kurulum dizinini bir Windows paylaşılan dizinine değiştirmelisiniz ki bir ağ konumundan erişilebilir olsun (örneğin \\machine\shared_directory).

  1. Seçenek Düzenleyicide Dağıt'ı tıklayın.
  2. Hem 32-bit hem de 64-bit yönetim resimleriniz varsa, 32 veya 64'e tıklayarak 32-bit veya 64-bit resim için makinaları görüntüleyin.

    Her bilgisayar için kurulum kullanılabilirliği ve durumu görüntülenir.

  3. Email Gönder'i tıklayın.
  4. Yönetim resmi kurulum dizinine ağ yolunu belirleyin.

    Tipik olarak, yönetim resmi kurulum dizinine giden dizin yolu ilk olarak bir Windows dosya yolu olarak gösterilir (örneğin C:\SolidWorks Admin\SolidWorks 2011 SP0). İletişim kutusu Bu, bir ağ yolu değildir der.

    1. Bu yönetim resmi kurulum dizini konumunu belirlemek için Gözat'ı tıklayın.
    2. Yönetim resminin kurulu olduğu bilgisayara gidin ve yönetim resmi kurulum dizini için seçilen Windows paylaşılan dizinini seçin.

      Yönetim resmi paylaşılan dizininin içine gezinmeyin (örneğin 32bit veya 64bit alt dizinlerine girmeyin)

    3. Tamam'a tıklayın.

      İletişim kutusu Bu, bir ağ yoludur der.

    Makina sahibini StartSWInstall.hta dosyası için olan ağ konumunu kullanarak yönetim resminden nasıl kurulum yapılacağı konusunde eğiten bir email oluşturulur.

  5. Emaili SolidWorks'ü kurmakla görevli kullanıcılara gönderin.

Kullanıcılar StartSWInstall.hta dosyası için olan ağ konumuna olan bağlantıyı çift tıklayarak yönetim resminden SolidWorks'ü kurabilirler.

Seçenek Düzenleyicide Kurulum Durumu şunları gösterir:
Bekliyor
Kullanıcı bu makinada henüz kurulumu çalıştırmamış.
Başarılı
Kullanıcı bu makinada kurulumu başarıyla tamamlamış.
Başarısız
Kullanıcı bu makinada kurulumu çalıştırmış fakat kurulum başarısız olmuş.
  • Bir Yönetim Resmini Dağıtmak için Haritalanmış Sürücü Kullanmak
    Bir UNC yolu (\\machine_name\share_name), yönetim resmi kurulum dizini için önerilen ağ konumu belirleme yöntemidir. Fakat, yönetim resmindeki StartSWInstall.hta dosyasının konumu için haritalanmış bir sürücü kullanabilirsiniz (örneğin, U:\StartSWInstall.hta), bunun için kuran tüm kullanıcıların paylaşılan yönetim resmi dizinine aynı sürücü harfini haritalamış olmaları gerekir.
Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Bir Yönetim Resmini Dağıtmak için Haritalanmış Sürücü Kullanmak

Bir UNC yolu (\\machine_name\share_name), yönetim resmi kurulum dizini için önerilen ağ konumu belirleme yöntemidir. Fakat, yönetim resmindeki StartSWInstall.hta dosyasının konumu için haritalanmış bir sürücü kullanabilirsiniz (örneğin, U:\StartSWInstall.hta), bunun için kuran tüm kullanıcıların paylaşılan yönetim resmi dizinine aynı sürücü harfini haritalamış olmaları gerekir.

Örneğin eğer U: harfi haritalandıysa bilgilendirme e-maili kullanıcıları file://U:\StartSWIOnstall.hta'ya yönlendirecek. E-mail'i alan kullanıcılar, U: sürücüsünün UNC konumuna haritalanmış olması şartı ile kurulumu gerçekleştirebilirler (\\machine_name\share_name).

Üst konu başlığ: Kurulumları Seçenek Düzenleyicisi ile Dağıtmak


Seçenek Düzenleyicisinden Çıkış

Seçenek Düzenleyicisinden çıkmak için Tamam veya Kapat'ı tıklayabilirsiniz.

  • Değişiklikleri uygulamak ve Seçenek Düzenleyiciden çıkmak için Tamam, Kapat veya Widows uygulaması Kapatma düğmesini tıklayın.
    • Değişiklikleri uygulamak ve Seçenek Düzenleyicisinden çıkmak için Tamam'a tıklayın.
    • Seçenek Düzenleyicisinden çıkmak için Kapat'a tıklayın.

      eğer uygulanacak değişiklikler varsa bunları kaydetmek isteyip istemediğiniz sorulur.

    • Windows uygulama Kapatma düğmesini (X) tıklayın. eğer uygulanacak değişiklikler varsa bunları kaydetmek isteyip istemediğiniz sorulur.
Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Seçenek Düzenleyiciye bir Masaüstü Kısayolu Oluşturmak

Belirli bir Yönetim Resmi için uygulamanın içinden bir Windows masaüstü kısayolu oluşturabilirsiniz.

  1. Seçenek Düzenleyicisini bşlatın.

    Örneğin, Windows Explorer'da, yönetim resmi kurulum dizinine gidip sldAdminOptionEditor.exe'yi çift tıklayın.

  2. Bu seçenek Düzenleyicisine Masaüstü Kısayolu Oluştur'u tıklayın.

    Yönetim resminin seçenek düzenleyicisi için bir kısayol Windows masaüstünde görünür.

Üst konu başlığ: Yönetim Resmi Seçenek Düzenleyicisi


Email ile İstemcilere bir Yönetim Resmi Dağıtmak

Bir kez paylaşılan bir yönetim resmi oluşturduğunuzda, istemcileri email ile bilgilendirebilirsiniz.

Yönetim resmini diğer bilgisayarlara erişilebilir şekilde paylaşıma açın (örneğin bir UNC yolu ile).

Tüm istemcilere admin_image_install_dir\StartSWInstall.hta adresine bağlantı içeren bir email atabilirsiniz. İstemciler dosyayı açıp SolidWorks ürünlerini şimdi kur'u tıklayarak yönetim resminden kurulumu başlatabilirler

Eğer bir yönetim resmini yeni bir SolidWorks sürümüne yükseltiyorsanız, yönetim resmi konum ve paylaşım özelliklerini konfigüre edebilirsiniz, böylece daha önce kurulmuş istemciler otomatik olarak yükseltilir. Ayrıntılar için bkz. İstemcileri Yönetim Resimlerinden Yükseltmek.
Üst konu başlığ: Yönetim Resimlerini Kullanmak


İstemcilere bir Yönetim Resminin Reklamını Yapmak

Yeni bir yönetim resminin kurulumunu istemcilere duyurmak için bir komut yürütebilirsiniz.

Email dağıtımı genellikle istemcileri bir SolidWorks kurulumundan haberdar etmek için kullanılan yöntemdir. Ayrıntılar için bkz. Email ile İstemcilere bir Yönetim Resmi Dağıtmak.

Fakat, alternatif olarak, yeni bir kurulumu istemcilere duyurmak için bir komut yürütebilirsiniz. Örneğin, normalde SolidWorks'ü kullanmayan çalışanlara reklam yapabilirsiniz.

SolidWorks'ün reklamını yapmak kullanıcının bilgisayarında Başlat menüsünde SolidWorks'e bir kısayol oluşturur ve sunucudaki yönetim resmi ile de bir dosya ilişkisi kurar. İlk olarak, yürütülebilir dosyalar kurulmaz. Kurulum yalnızca kullanıcı uygulamaya ilk ihtiyacı olduğunda gerçekleşir.

Kullanıcı kısayolu tıkladığında veya bir SolidWorks belgesini çift tıkladığında, kurulum başlar ve SolidWorks uygulaması yürütülür.

Bir yönetim resminden reklam yapmak için:

  1. Yönetim resmini oluşturun ve konfigüre edin.
  2. Ürünün reklamını SolidWorks uygulamasının kurulacağı her bilgisayarda yapın.

    Örneğin:

    msiexec /jm path_to_msi_file_of_admin_image

    burada path_to_msi_file_of_admin_image yönetim resmi dizininin UNC yolu dur.

Üst konu başlığ: Yönetim Resimlerini Kullanmak


Komut Satırı Dağıtımı

Bir komut satırı veya toplu iş dosyası kullanarak otomatik olarak bir yönetim resmini dağıtabilirsiniz (sessiz kurulum).

  • Komut Satırını Kullanarak Yönetim Resminden Kurulum
    SolidWorks Kurulum Yöneticisi veya MS-DOS komut satırını kullanarak bir yönetim resmi oluşturabilirsiniz.
  • Komut Satırını Kullanarak Yönetim Resminden Kurulum için İstemcileri Hazırlamak
    Yönetim resmini oluşturduktan sonra, ve istemcileri bilgilendirmeden önce, komut satırı kullanılarak oluşturulmuş yönetim resimleri veya Microsoft Active Directory tarafından kurulamayan Microsoft Windows bileşenlerini kurmalısınız.
  • Komut Satırını Kullanarak Yönetim Resminden Kurulum
    Komut Satırını Kullanarak Yönetim Resminden Kurulum
  • Komut Satırı Özellikleri
    Burada tanımlanan komut satırı özellikleri, unsur özellikleri, global özellikler, ürüne özel özellikler ve Windows konum konvansiyonlarını içerir.
  • Microsoft Active Directory Kullanarak bir Yönetim Resmi dağıtmak
    Microsoft Active Directory Dağıtımı ana SolidWorks ürünlerinin istemcilere dağıtılması için desteklenir.
Üst konu başlığ: Birden Fazla Kurulum


Komut Satırını Kullanarak Yönetim Resminden Kurulum

SolidWorks Kurulum Yöneticisi veya MS-DOS komut satırını kullanarak bir yönetim resmi oluşturabilirsiniz.

Eğer komut satırından bir yönetim resmi oluşturursanız, her SolidWorks ürün bileşeni için, o bileşenin .msi dosyasını yürüterek, farklı bir resim oluşturup dağıtmalısınız. Eğer İngilizce olmayan bir dili kuruyorsanız, her İngilizce olmayan dil için, o dilin .msi dosyasını yürüterek, farklı bir resim oluşturup dağıtmalısınız. .msi dosyalarının konumları hakkında detaylar için Yönetim Resimleri için MSI Dosya Konumları.
  1. Bir Komut İstemi penceresi açın.
    1. Windows'da Başlat > Çalıştır'ı tıklayın.
    2. cmd girin ve Tamam'ı tıklayın.
  2. Şu komutu girin:

    msiexec /a Msi_path

    burada Msi_path, işletim sisteminizin .msi konumudur. SolidWorks.msi, kurulum dizininin swwi\data alt dizininde bulunur.

    Örneğin:

    msiexec /a F:\swwi\data\SolidWorks.msi

  3. SolidWorks Kur Sihirbazı'nda, ekrandaki talimatları takip edin.
  4. Eğer İngilizce dışındaki diller için SolidWorks ürünlerini kuruyorsanız, o dil için ayrı bir yönetim resmini bu komutu kullanarak oluşturun:

    msiexec /a Msi_path_for_language

    burada Msi_path_for_language, o dilin .msi dosyasının konumudur. Örneğin, french.msi, kurulum dizininde swwi\lang\french alt klasöründe bulunur.

    Örneğin:

    msiexec /a F:\swwi\lang\french\french.msi

Üst konu başlığ: Komut Satırı Dağıtımı


Komut Satırını Kullanarak Yönetim Resminden Kurulum için İstemcileri Hazırlamak

Yönetim resmini oluşturduktan sonra, ve istemcileri bilgilendirmeden önce, komut satırı kullanılarak oluşturulmuş yönetim resimleri veya Microsoft Active Directory tarafından kurulamayan Microsoft Windows bileşenlerini kurmalısınız.

Bu Windows bileşenlerini el ile kurmak, yalnızca komut satırı veya Microsoft Active Directory kullanılarak el ile oluşturulmuş bir yönetim resminden kurulum yapıyorsanız gereklidir. Eğer yönetim resmini oluşturmak için SolidWorks Kurulum Yöneticisini kullanırsanız, bu Windows bileşenleri otomatik olarak kurulurlar.
Windows bileşenlerinden SolidWorks'ün ihtiyacı olan dosyaların bir özeti:
Windows Installer
SolidWorks Simulation Premium kurulumunu yürütmek için gerekli belgeleri içerir.
Office Web Bileşenleri
DriveWorks için gerekli COM kontrollerini içerir.
Visual C++ 2005 ve 2008 Yeniden Dağıtılabilir Paketi
Microsoft Visual C++ için runtime bileşenleri içerir.
Hem 2005 hem de 2008 sürümleri kurulmalı.
Uygulamalar için Visual Studio Tools
Visual Studio uygulamalarını destekleyen bir araç seti içerir.
Visual Studio Uzak Hata Ayıklayıcısı
Bir 64-bit işletim sisteminde hata ayıklama ortamı sağlar.
.NET Framework
Ortak dil runtime ve .NET Framework bileşenlerini içerir.
Windows Desktop Search (opsiyonel)
Değişik veri kaynak ve konumlarında, yerel bilgisayarlar ve paylaşılan ağlarda, hızlı dosya ve veri aramalarını destekler.
Windows Desktop Search dosyaları lisana özgüdür. Ayrıntılar için bkz. Windows Desktop Search Dil Desteği.
Visual C++ Redistributable Package ve .NET Framework 3,5 tüm SolidWorks ürünleri için gereklidir, sadece ana SolidWorks ürünü için değil.

Bu bileşenler yönetim resmi dizininin alt dizinlerinde bulunmalı.

Bu tablo her işletim sistemi için gerekli dosyaları belirtir.
İşletim sistemi: Windows 2003 32-bit1
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | (Uygulanamaz)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3-x86-lang.exe
İşletim sistemi: Windows 2003 64-bit1
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 64-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
İşletim sistemi: Windows 2008 32-bit1
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | (Uygulanamaz)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel): |  | Windows Desktop Search bu işletim sisteminin unsurlarındandır.
İşletim sistemi: Windows 2008 64-bit1
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 64-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel): |  | Windows Desktop Search bu işletim sisteminin unsurlarındandır.
İşletim sistemi: Windows XP 32-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | WindowsInstaller-KB893803-v2-x86.exe
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | (Uygulanamaz)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel):
 |  | WindowsDesktopSearch-KB917013-V301-XP-x86-lang.exe
İşletim sistemi: Windows XP 64-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
İşletim sistemi: Windows XP 64-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 64-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel):
 |  | WindowsDesktopSearch-KB917013-V301-Srv2K3_XP-x64-enu.exe
İşletim sistemi: Windows Vista 32-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | (Uygulanamaz)
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel): |  | Windows Desktop Search bu işletim sisteminin unsurlarındandır.
İşletim sistemi: Windows Vista 64-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 64-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | dotnetfx35.exe
 | Windows Desktop Search (opsiyonel): |  | Windows Desktop Search bu işletim sisteminin unsurlarındandır.
İşletim sistemi: Windows 7 32-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 32-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | (Uygulanamaz)
 | .NET Framework: |  | .NET Framework ve Windows Desktop Search bu işletim sisteminin unsurlarıdır.
 | Windows Desktop Search (opsiyonel):
İşletim sistemi: Windows 7 64-bit
SolidWorks Media: Windows XP, Windows Vista, ve Windows 7 için 64-bit
 | Windows Installer: |  | (Uygulanamaz)
 | Office Web Bileşenleri: |  | owc11.exe
 | Visual C++ 2005 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Visual C++ 2008 Yeniden Dağıtılabilir Paketi: |  | vcredist_x86.exe vcredist_x64.exe Her ikisi de yüklenmeli.
 | Uygulamalar için Visual Studio Tools: |  | vsta_aide.msi
 | Visual Studio Uzak Hata Ayıklayıcısı: |  | rdbgexp.msi
 | .NET Framework: |  | .NET Framework ve Windows Desktop Search bu işletim sisteminin unsurlarıdır.
 | Windows Desktop Search (opsiyonel):
1Windows 2003 veya Windows 2008'e kurulum yalnızca Workgroup PDM Server ve SolidNetWork License (SNL) Server için destekleniyor.
  • Windows Gereksinimlerini Komut Satırından 32-bit İşletim Sistemlerinde Kurmak
    Bu süreci takip ederek yönetim resmi kurulumları için Windows Gereksinimilerini komut satırı ile 32-bit Windows sürümlerinde kurun.
  • Windows Gereksinimlerini Komut Satırından 64-bit İşletim Sistemlerinde Kurmak
    Bu süreci takip ederek yönetim resmi kurulumları için Windows Gereksinimilerini komut satırı ile 64-bit Windows sürümlerinde kurun.
  • SolidWorks Arama ve Windows Masaüstü Araması
    SolidWorks Arama Microsoft® Windows® Desktop Search ile entegredir.
Üst konu başlığ: Komut Satırı Dağıtımı


Windows Gereksinimlerini Komut Satırından 32-bit İşletim Sistemlerinde Kurmak

Bu süreci takip ederek yönetim resmi kurulumları için Windows Gereksinimilerini komut satırı ile 32-bit Windows sürümlerinde kurun.

Bir kurulumda çoklu bileşenleri kurabilmek için, Bir yığın dosyası oluşturun ve bununla bileşenleri istemci bilgisayarlara itin.

  1. Hedef bilgisayarın en az 290 MB serbest disk alanı ve geçerli bir TEMP dosyasına sahip olduğundan emin olun.
  2. Office Web Bileşenlerini bu komutla kurun:

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. Windows XP için, Windows Installer'ı kurun:

    administrative_image_directory\WindowsInstaller\WindowsInstaller-KB893803-v2-x86.exe

    Windows installer'ı Windows XP dışında bir Windows sürümüne kurmak gerekmez.

  4. Visual C++ 2005 Yeniden Dağıtılabilir Paketini kurun:

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  5. Visual C++ 2008 Yeniden Dağıtılabilir Paketini kurun:

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

  6. Windows XP ve Windows Vista için, Microsoft .NET Framework 3,5'ı Windows Server Update Services'i kullanarak kurun.

    .NET Framework resmini Windows 7 ve sonrası sürümlere kurmak gerekmez.

  7. Uygulamalar için Visual Studio Tools kurun:

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

Üst konu başlığ: Komut Satırını Kullanarak Yönetim Resminden Kurulum için İstemcileri Hazırlamak


Windows Gereksinimlerini Komut Satırından 64-bit İşletim Sistemlerinde Kurmak

Bu süreci takip ederek yönetim resmi kurulumları için Windows Gereksinimilerini komut satırı ile 64-bit Windows sürümlerinde kurun.

Bir kurulumda çoklu bileşenleri kurabilmek için, Bir yığın dosyası oluşturun ve bununla bileşenleri istemci bilgisayarlara itin.

  1. Hedef bilgisayarın en az 620 MB serbest disk alanı ve geçerli bir TEMP dosyasına sahip olduğundan emin olun.
  2. Office Web Bileşenlerini bu komutla kurun:

    administrative_image_directory\OfficeWeb_11\owc11.exe

  3. Visual C++ 2005 Yeniden Dağıtılabilir Paketini kurun:

    administrative_image_directory\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

    Hem 32-bit hem de 64-bit sürümleri kurulmalı.

  4. Visual C++ 2008 Yeniden Dağıtılabilir Paketini kurun:

    administrative_image_directory\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q

    Hem 32-bit hem de 64-bit sürümleri kurulmalı.

  5. Windows XP ve Windows Vista için, Microsoft .NET Framework 3,5'ı Windows Server Update Services'i kullanarak kurun.

    .NET Framework resmini Windows 7 ve sonrası sürümlere kurmak gerekmez.

  6. Uygulamalar için Visual Studio Tools kurun:

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

  7. Visual Studio Uzak Hata Ayıklayıcısını Kurun:

    administrative_image_directory\VSRemoteDebugger\install.exe /Q

Üst konu başlığ: Komut Satırını Kullanarak Yönetim Resminden Kurulum için İstemcileri Hazırlamak


SolidWorks Arama ve Windows Masaüstü Araması

SolidWorks Arama Microsoft® Windows® Desktop Search ile entegredir.

Eğer Windows Desktop Search'ün doğru sürümleri bilgisayarda kurulu değillerse, SolidWorks Kurulumu sırasında bunu kurmanız veya güncellemeniz istenir.

Eğer bir yönetim resmi oluşturuyorsanız, Windows Desktop Search yönetim resmi dizinine dahil değildir. Microsoft Windows Desktop Search, istemci bilgisayarlara el ile kurulmalı, yoksa o bilgisayarlarda SolidWorks Arama kullanılamaz.

Üst konu başlığ: Komut Satırını Kullanarak Yönetim Resminden Kurulum için İstemcileri Hazırlamak


Komut Satırını Kullanarak Yönetim Resminden Kurulum

Komut Satırını Kullanarak Yönetim Resminden Kurulum

Sessiz kurulum için:
  1. Bir Komut İstemi Penceresi açın (Windows'da Başlat > Çalıştır tıklayın.
  2. msiexec.exe komutunu /i ve /qb seçenekleri ile yazın ve aşağıdaki varsayılan değerlerde olmayan tüm seçenekler için özellikleri ayarlayın.
Bireysel kurulum bileşen komut satırı özellikleri:
  • Komut Satırı Unsur Özellikleri
  • Komut Satırı Global Özellikleri
  • SolidWorks eDrawings Komut Satırı Özellikleri
  • SolidWorks Explorer/Workgroup PDM Komut Satırı Özellikleri
  • SolidWorks Flow Simulation Komut Satırı Süreci
Aşağıdaki örnekleri sessiz kurulum için şablon olarak kullan.
SolidWorks İstemci
  • SolidWorks ana ürün (İngilizce)
  • Toolbox eklentisi
  • Geribildirim programına katılım
  • Fransızca

32-bit işletim sisteminde SolidWorks'ün 32-bit versiyonu:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb

64-bit işletim sisteminde SolidWorks'ün 32-bit versiyonu:

msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX64 /qb

64-bit işletim sisteminde SolidWorks'ün 64-bit versiyonu:

msiexec /i "64-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

SolidWorks Fransızca kurulum bileşeni ayrı olarak kurulmalı:
  • 32-bit sürümü:

    msiexec /i "32-bit_admin_image_path\SolidWorks French\french.msi" /qb

  • 64-bit sürümü:

    msiexec /i "64-bit_admin_image_path\SolidWorks French\french.msi" /qb

SolidWorks dil bileşeni kurulum komutlarını belirtirken, komut satırı argümanlarını belirtmeyin.
eDrawings İstemcisi
  • Performans günlüğü
  • Tüm unsurlar

msiexec /i "admin_image_path\SolidWorks eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb
SolidWorks Explorer ve Workgroup PDM eklentisi
  • Workgroup PDM eklentili SolidWorks Explorer

msiexec /i "admin_image_path\SolidWorks Explorer\SolidWorks Explorer.msi" INSTALLDIR="C:\Program Files\your_folder" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb
Üst konu başlığ: Komut Satırı Dağıtımı


Komut Satırı Özellikleri

Burada tanımlanan komut satırı özellikleri, unsur özellikleri, global özellikler, ürüne özel özellikler ve Windows konum konvansiyonlarını içerir.

  • Komut Satırı Unsur Özellikleri
    Bu SolidWorks kurulumu bu ADDLOCAL özelliklerini komut satırı dağıtımı için destekler.
  • Komut Satırı Global Özellikleri
    Aksi belirtilmedikçe her özellik yönetim veya bireysel kurulumlar için tanımlıdır. Seri numaraları hem yönetim hem de bireysel kurulumlara global özellikler ile geçirilebilir.
  • SolidWorks eDrawings Komut Satırı Özellikleri
    Bu komut satırı özellikleri eDrawings'e özeldir.
  • SolidWorks Explorer/Workgroup PDM Komut Satırı Özellikleri
    Bu komut satırı özellikleri SolidWorks Explorer ve SolidWorks Workgroup PDM'e özeldir.
  • SolidWorks Flow Simulation Komut Satırı Süreci
    Bu komut satırı özellikleri SolidWorks Flow Simulation'a özeldir.
  • Yönetim Resimleri için MSI Dosya Konumları
    Komut satırı ile yönetim resimleri oluşturmak için, ürün bileşeni .msi dosyaları SolidWorks medyasında şu konumlarda saklanır.
  • Windows Desktop Search Dil Desteği
    Windows Desktop Search dosya isimleri platform ve lisan bilgisi belirtir.
Üst konu başlığ: Komut Satırı Dağıtımı


Komut Satırı Unsur Özellikleri

Bu SolidWorks kurulumu bu ADDLOCAL özelliklerini komut satırı dağıtımı için destekler.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • InstantWebsite
  • Intel_Modules_AgeiaX86 (32-bit işletim sisteminde SolidWorks'ün 32-bit versiyonu için)
  • Intel_Modules_AgeiaX64 (64-bit işletim sisteminde SolidWorks'ün 32-bit versiyonu için)
  • Manüeller
  • Hareket
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • XchangeWorks
Komut satırı kurulumu için özellikler belirlerken:
  • SolidWorks ADDSOURCE seçeneğini kullanarak ürün kurulumunu desteklemez.
  • Özellikler büyük-küçük harflere duyarlıdır. boşluk yada tire içeremez, virgüllerle ayrılmalılar.
  • SolidWorks uygulamasının doğru kurulabilmesi için SolidWorks belirtilmeli.
Üst konu başlığ: Komut Satırı Özellikleri


Komut Satırı Global Özellikleri

Aksi belirtilmedikçe her özellik yönetim veya bireysel kurulumlar için tanımlıdır. Seri numaraları hem yönetim hem de bireysel kurulumlara global özellikler ile geçirilebilir.

Özellik | Tanım
ENABLEPERFORMANCE Performans verisinin otomatik olarak SolidWorks Corporation'a email ile yollanmasını belirler.

1 yollamak için, 0 tam tersi.
INSTALLDIR SolidWorks Kurulum Klasörü

Yalnızca bireysel kurulumlar.
INSTALLWDS Microsoft Windows Desktop Search Engine kullanan SolidWorks uzantılarını kur. Ayrıntılar için bkz Yönetim Resminden Kurulum için İstemcileri Hazırlamak.

1 kurmak için, 0 tam tersi.
MOTIONSERIALNUMBER | SolidWorks Motion Seri Numarası
OFFICEOPTION Kurulacak ürün paketini seç:
0
SolidWorks İstemci
1
SolidWorks Office
2
SolidWorks Professional
3
SolidWorks Premium
REINSTALL Kurulu tüm unsurları güncellemek için ALL belirtin.
Bu özelliği yalnızca büyük bir sürüm içindeki Servis Paketi sürümüne güncellerken belirtin (örneğin SolidWorks 2011 SP01'den SolidWorks 2011 SP02'ye güncellerken).
REINSTALLMODE Microsoft Installer yeniden kurulum seçenekleri.

Örneğin aynı büyük sürüm içindeki bir servis paketinden ötekine yükseltirken REINSTALLMODE=vomus belirtmelisiniz.

REINSTALLMODE ayarları detayları için www.microsoft.com adresinden Windows Installer dokümentasyonuna bakın.

Bu özelliği yalnızca büyük bir sürüm içindeki Servis Paketi sürümüne güncellerken belirtin (örneğin SolidWorks 2011 SP01'den SolidWorks 2011 SP02'ye güncellerken). SolidWorks'ün yeni bir büyük sürümünü ilk kez kurarken bunu belirtmeyin.
SERVERLIST SolidNetWork Sunucu Listesi.
SolidNetWork sunucu listesi, noktalı virgüllerle ayrılmış bağlantı noktası numaralarına referans veren şu formatta bir listedir:

xxxxx@server_name1;yyyyy@server_name2;&

x ve y tek basamaklıdır. Listedeki son sunucudan sonra noktalı virgül koymayın.

Yalnızca bireysel kurulumlar.
SIMULATIONSERIALNUMBER | SolidWorks Simulation Seri Numarası
SOLIDWORKSSERIALNUMBER | Tüm eklentileri içeren SolidWorks Seri Numarası
SWMIGRATE Şuradaki listede gösterildiği şekilde güncellenecek SolidWorks sürümü: SolidWorks Install Choice diyalog kutusu. Örneğin:

SWMIGRATE="SolidWorks 2011 SP01"

Bu özelliği, yalnızca önceki büyük sürüm bulunurken yeni bir büyük sürüm kuracağınızda kullanın. Bunu aynı büyük sürüm içindeki bir servis paketinden ötekine yükseltirken belirtmeyin.
TARGETDIR SolidWorks Kurulum Klasörü

Yalnızca yönetim kurulumları.
TOOLBOXFOLDER SolidWorks toolbox dosyaları Kurulum Klasörü

Yalnızca bireysel kurulumlar.
TRANSFORMLAR Şu formda dile bağlı öğeler içerir.
TRANSFORMS number.mst
  • Çince (1028)
  • Çince-Basitleştirilmiş (2052)
  • Çekçe (1029)
  • İngilizce (1033)
  • Fransızca (1036)
  • Almanca (1031)
  • İtalyanca (1040)
  • Japonca (1041)
  • Korece (1042)
  • Lehçe (1045)
  • Portekizce-Brezilya (1046)
  • Rusça (1049)
  • İspanyolca (1034)
  • Türkçe (1055)
UPGRADESWINSTALL
Varolan bir SolidWorks sürümünü şimdiki sürüme yükseltmeyi belirtir.
0
Yeni kurulum, güncelleme
1
Güncelle

Yalnızca bireysel kurulumlar.

Bu özelliği, yalnızca önceki büyük sürüm bulunurken yeni bir büyük sürüm kuracağınızda kullanın. Bunu aynı büyük sürüm içindeki bir servis paketinden ötekine yükseltirken belirtmeyin.
Üst konu başlığ: Komut Satırı Özellikleri


SolidWorks eDrawings Komut Satırı Özellikleri

Bu komut satırı özellikleri eDrawings'e özeldir.

Özellik | Tanım
ADDLOCAL SolidWorks eDrawings uygulamasının hangi kısmının kurulacağını belirler.

Tümü önerilen seçenektir.
Komut Satırı Sözdizimi: Unsur:
Tüm | Tüm unsurları kurar. eDrawings uygulaması kurulumu doğrulamak için kurulu SolidWorks ve AutoCAD yayımlayıcı uygulamalarını arar.
eDrawingsViewer | eDrawings ve diğer dosyaları gösterir.
PublisherForAutoCADR14 | AutoCAD R14 uygulaması içinden eDrawings dosyaları oluşturur.
PublisherForAutoCAD2000 | AutoCAD 2000 içinden eDrawings dosyaları oluşturur.
PublisherForAutoCAD2004 | AutoCAD 2004 içinden eDrawings dosyaları oluşturur.
PublisherForAutoCAD2005 | AutoCAD 2005 içinden eDrawings dosyaları oluşturur.
PublisherForAutoCAD2006 | AutoCAD 2006 içinden eDrawings dosyaları oluşturur.
DXFDWGTranslator | DXF/DWG dosyalarını eDrawings Viewer'da gösterir
Kısayollar | Masaüstü kısayolu kur.
XML3D | 3DXML dosyalarını eDrawings Viewer'da gösterir.
INSTALLDIR | SolidWorks eDrawings için kurulum klasörü belirler.
LOGPERFORMANCE Performans verisinin otomatik olarak SolidWorks Corporation'a email ile yollanmasını belirler.
1
Performans verisi yolla
0
Aksi taktirde
SNLSERVER SolidWorks Lisans sunucunuz için bağlantınoktası@sunucuadı girin. Birden fazla bağlantınoktasıt@sunucuadı kombinasyonunu ayırmak için noktalı virgüller kullanın.

SNLSERVER için bir bağlantı noktası adı yalnızca SolidWorks SNL sunucu konfigürasyonu için gerekli. bağlantı_noktası_listesi@sunucu_dizesi, herbiri sunucuda ayrı bir bağlantı noktası numarasına referans veren noktalı virgüllerle ayrılmış dizelerin aşağıdaki formatta bir listesidir:

xxxxx@suncu_adı1; yyyyy@sunucu_adı2;

x ve y tek basamaklıdır. Listedeki son sunucudan sonra noktalı virgül koymayın.
Üst konu başlığ: Komut Satırı Özellikleri


SolidWorks Explorer/Workgroup PDM Komut Satırı Özellikleri

Bu komut satırı özellikleri SolidWorks Explorer ve SolidWorks Workgroup PDM'e özeldir.

SolidWorks Explorer/Workgroup PDM istemcisi için:
İstemci Özelliği | Tanım
EXPLORERORPDM
0
Yalnızca SolidWorks Explorer
1
Workgroup PDM unsurları kurulabilir
ADDLOCAL
  • Standalone
  • Müşteri
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone Katkıda bulunandır ve Client SolidWorks Explorer sessiz kurulumları için olan SolidWorks eklentisidir.

Eğer AutoCAD belirtirseniz, AutoCAD sisteminizde kurulu olmalı. Workgroup PDM, AutoCAD'in uygun versiyonunun konumunu bulur. AutoCAD'in birden fazla versiyonunu belirtebilirsiniz:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 ve DocMgr64 yalnızca 64-bit SolidWorks Explorer kurulumları ile çalışırlar.

INSTALLDIR | Workgroup PDM için kurulum klasörü belirler.
ACTIVSERIALNUMBER | SolidWorks seri numarasını belirler.
Workgroup PDM Sunucusu için:
Sunucu Özelliği | Tanım
ADDLOCAL
  • Kasa
  • WebPortal
  • API

Eğer WebPortal (Viewer) belirtirseniz, ayrıca VAULTNAME'i de belirtmelisiniz.
INSTALLDIR | Workgroup PDM için kurulum klasörü belirler.
LICENSE_SERVER | Lisans sunucusunun bulunduğu bilgisayarın adını belirtir.
VAULTDATA | Kasanın yol ve klasörünü belirtir.
VAULTNAME | Kasanın bulunduğu bilgisayarın adını belirtir.
Üst konu başlığ: Komut Satırı Özellikleri


SolidWorks Flow Simulation Komut Satırı Süreci

Bu komut satırı özellikleri SolidWorks Flow Simulation'a özeldir.

Özellik | Tanım
ACTIVSERIALNUMBER SolidWorks Flow Simulation seri numarası.

(Bireysel kurulumlar ve istemci kurulumları bir yönetim resminden)
CWUPGRADEINSTALL Varolan bir SolidWorks Flow Simulation sürümünü yükseltir.
1
Güncelle
2
Yeni kurulum; yeni bir dizine kurulum

(Bireysel kurulumlar ve istemci kurulumları bir yönetim resminden)
INSTALLDIR Belirli bir SolidWorks Flow Simulation sürümü için kurulumu belirler.

(Yalnızca bireysel kurulumlar)
SERVERLIST | Noktalı virgüllerle ayrılmış, her biri bir baplantı noktası numarasına denk gelen söz dizileri, şu formatta: xxxxx@server_name1; yyyyy@server_name2;& where x and y are single digits. Listedeki son sunucudan sonra noktalı virgül koymayın.
SOLIDWORKSPATH SplidWorks yazılımının kurulu olduğu klasörü belirtir.

(Bireysel kurulumlar ve istemci kurulumları bir yönetim resminden)
TARGETDIR Belirli bir SolidWorks Flow Simulation sürümü için kurulumu belirler.

(Yalnızca yönetim resimleri)
Üst konu başlığ: Komut Satırı Özellikleri


Yönetim Resimleri için MSI Dosya Konumları

Komut satırı ile yönetim resimleri oluşturmak için, ürün bileşeni .msi dosyaları SolidWorks medyasında şu konumlarda saklanır.

Ürün | Meyda Konumu
SolidWorks (ana ürün, İngilizce) | swwi\data\SolidWorks.msi
SolidWorks (İngilizce olmayan dil bileşenleri) | Geleneksel Çince | swwi\lang\chinese\chinese.msi
 | Basitleştirilmiş Çince | swwi\lang\chinese-simplified\chinese-simplified.msi
 | Çek Dili | swwi\lang\czech\czech.msi
 | Fransızca | swwi\lang\french\french.msi
 | Almanca | swwi\lang\german\german.msi
 | İtalyanca | swwi\lang\italian\italian.msi
 | Japonca | swwi\lang\japanese\japanese.msi
 | Kore Dili | swwi\lang\korean\korean.msi
 | Lehçe | swwi\lang\polish\polish.msi
 | Portekizce (Brezilya) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
 | Rusça | swwi\lang\russian\russian.msi
 | İspanyolca | swwi\lang\spanish\spanish.msi
 | Turkish | swwi\lang\turkish\turkish.msi
SolidWorks API SDK | apisdk\SolidWorks API SDK.msi
SolidWorks Simulation ürünleri | COSMOSM\COSMOSM_lang.msi
eDrawings | eDrawings\eDrawings.msi
eDrawings Shaders | eDrawingsShaders\eDrawings.msi
eDrawingsAPI SDK | eDrwAPISDK\eDrawings API SDK.msi
Flow Simulation | Flow Simulation\SolidWorks Flow Simulation.msi
Workgroup PDM Server | pdmwserver\SolidWorks Workgroup PDM Server.msi
SolidWorks Aktivasyon Sihirbazı | swactwizard\Activation Wizard.msi
DocManager APIs | swdocmgr\SolidWorks Document Manager API.msi
SolidWorks Explorer | swexplorer\SolidWorks Explorer.msi
SolidNetWork License Manager | swlicmgr\SolidWorks SolidNetWork License Manager.msi
SolidWorks Viewer | swviewer\SolidWorks Viewer.msi
Üst konu başlığ: Komut Satırı Özellikleri


Windows Desktop Search Dil Desteği

Windows Desktop Search dosya isimleri platform ve lisan bilgisi belirtir.

Platform/mimari:
srv2k3 | Windows Server 2003
xp | Windows XP
x86 | 32-bit Windows
x64 | 64-bit Windows
Lisan:
chs | Basitleştirilmiş Çince
cht | Çince
csy | Çek Dili
deu | Almanca
enu | İngilizce
esn | İspanyolca
fra | Fransızca
ita | İtalyanca
jpn | Japonca
kor | Kore Dili
plk | Lehçe
ptb | Brezilya Portekizcesi
rus | Rusça
trk | Turkish
Üst konu başlığ: Komut Satırı Özellikleri


Microsoft Active Directory Kullanarak bir Yönetim Resmi dağıtmak

Microsoft Active Directory Dağıtımı ana SolidWorks ürünlerinin istemcilere dağıtılması için desteklenir.

Microsoft Active Directory ağ ortamlarında istemci ve sunucuları yönetmek için bir dizin servisidir. Yönetim, geçiş ve dağıtımı kolaylaştırır.

  1. SolidWorks Kurulum Yöneticisi veya komut satırını kullanarak bir yönetim resmi oluşturun.
  2. Eğer komut satırını kullanarak bir yönetim resmi oluşturduysanız Microsoft Active Directory'i kullanarak Windows'un gereksinimlerini kurun. Ayrıntılar için bkz. Microsoft Active Directory Kullanarak Windows Gereksinimlerini Kurmak.

    Bu adımı yalnızca komut satırı kullanarak manüel olarak resmi oluşturduysanız kullanın. Eğer resmi SolidWorks Kurulum Yöneticisini kullanarak oluşturup kurduysanız bunlar otomatik olarak kurulmuşlardır.

  3. SolidWorks yazılımını özelleştirmek için bir dönüştürme dosyası oluşturun:
    1. Komut satırı penceresini açın.
    2. Yönetim resmini içeren klasörde, SWCreateMST.exe'yi komut satırına sürükleyin.

      Komut şu formatta olmalı:

      administrative_image_directory\SWCreateMST.exe path_to_MSI_file_of_an_administrative_image list_of_properties

      Özellikler unsur özellikleri veya global özellikler olabilir. Ayrıntılar için bkz.; Komut Satırı Unsur Özellikleri ve Komut Satırı Global Özellikleri.

      Aşağıdaki örnekleri şablon olarak kullanın:

      • 32-bit işletim sisteminde SolidWorks'ün 32-bit versiyonunu kuruyorsanız:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • 64-bit işletim sisteminde SolidWorks'ün 32-bit versiyonunu kuruyorsanız:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX64 OFFICEOPTION=0 SERVERLIST="25734@your_server"

      • 64-bit işletim sisteminde SolidWorks'ün 64-bit versiyonunu kuruyorsanız:

        C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      Dönüştürme dosyası SolidWorks.mst yönetim resmini içeren klasörde oluşturulur.

  4. Aktif Dizinde, SolidWorks yazılımının dağıtılacağı gruplar için Published Apps poliçesini düzenleyin.
  5. Group Policy diyaloğunda Computer Configuration and Software Settings'i genişletin.
  6. Software installation'ı sağ tıklayın ve New > Package'i seçin.
  7. Yönetim resmine gidin ve Aç'a tıklayın.
  8. Yazılımı Dağıt diyaloğunda Gelişmiş yayılmış veya atanmış'ı seçin, sonra Tamam'ı tıklayın.
  9. SolidWorks Özellikleri diyaloğunda Değişiklikler sekmesinde:
    1. Ekle'ye tıklayın.
    2. .mst dosyasına gözatın.
    3. Aç'a tıklayın.
  10. Tamam'a tıklayın.
  • Microsoft Active Directory Kullanarak Windows Gereksinimlerini Kurmak
    Bu süreci takip ederek varolan bir yönetim resmini Microsoft Windows Active Directory kullanarak SolidWorks'ü istemci bilgisayarlara kurmaya hazırlayın.
Üst konu başlığ: Komut Satırı Dağıtımı


Microsoft Active Directory Kullanarak Windows Gereksinimlerini Kurmak

Bu süreci takip ederek varolan bir yönetim resmini Microsoft Windows Active Directory kullanarak SolidWorks'ü istemci bilgisayarlara kurmaya hazırlayın.

Bu süreçlerde, dağıttığınız SolidWorks sürümüne uygun olan komutu kullanın.

  1. Visual C++ 2005 Yeniden Dağıtılabilir Paket kurulum dosyalarını ayıklayıp sonra kurun.
    1. Bu komutlardan birini yürütün.

      Windows'un 32-bit sürümleri için:

      administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T:{C++_target_directory}

      Windows'un 64-bit sürümleri için:

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /C /T:{C++_target_directory}

    2. Visual C++ 2005 Yeniden Dağıtılabilir modülünü kurmak için bir poliçe oluşturun:

      {2005_C++_target_directory}\vcredist.msi –

      Bu kurulum için dönüştürme dosyası gerekmez.

  2. Visual C++ 2008 Yeniden Dağıtılabilir Paket kurulum dosyalarını ayıklayıp sonra kurun.
    1. Bu komutlardan birini yürütün.

      Windows'un 32-bit sürümleri için:

      administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x:{C++_target_directory}

      Windows'un 64-bit sürümleri için:

      administrative_image_directory\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x:{C++_target_directory}

    2. Visual C++ 2008 Yeniden Dağıtılabilir modülünü kurmak için bir poliçe oluşturun:

      {2008_C++_target_directory}\vcredist.msi –

      Bu kurulum için dönüştürme dosyası gerekmez.

  3. Microsoft .NET Framework 3,5'ı Windows Server Update Services'i kullanarak kurun:

    .NET Framework resmini Windows 7 ve sonrası sürümlere kurmak gerekmez.

  4. Office Web Bileşenlerini ayıklayıp kurun.
    1. Bu komutu yürütün:

      administrative_image_directory\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_directory}

    2. Office Web Bileşenlerini kurmak için bir poliçe oluşturun:

      {Office_Web_components_directory}\owc11.MSI

      Bu kurulum için dönüştürme dosyası gerekmez.

  5. Uygulamalar için Visual Studio Tools (VSTA)'i bu poliçeyi oluşturarak kurun:

    {Microsoft_VSTA_directory}\vsta_aide.MSI

    Bu kurulum için dönüştürme dosyası gerekmez.

  6. Visual Studio Remote Debugger (64-bit)'i bu poliçeyi oluşturarak kurun:

    {Microsoft_remote_debugger_directory}\rdbgexp.MSI

    Bu kurulum için dönüştürme dosyası gerekmez.

Üst konu başlığ: Microsoft Active Directory Kullanarak bir Yönetim Resmi dağıtmak


Birden Fazla Kurulumun Yönetimi

Birden fazla kurulum için yönetim görevleri, yönetim resimlerinin yeni sürümlere güncellenmesi, servis paketi güncellemelerinin uygulanması ve kurulumların kaldırılmasını içerir.

  • Yönetim Resimlerini Yeni Sürüme Yükseltmek
    Yönetim resminden kurulum yapan istemcileri güncellemek için, önce yönetim resmini güncelleyin sonra istemcileri resmin yeni kopyasına referans verecek şekilde değiştirin.
  • Servis Paketi Ürün Güncelleme Yönetimi
    Servis Paketi ürün güncellemeleri sisten güvenirliği, program uyumluluğu, güvenlik vs. için güncellemeler içerebilir.
  • Bir Kurulumu Kaldırmak
    Bir kurulumu bireysel bir bilgisayardan veya bir istemci/sunucu ortamından kaldırabilirsiniz.
Üst konu başlığ: Birden Fazla Kurulum


Yönetim Resimlerini Yeni Sürüme Yükseltmek

Yönetim resminden kurulum yapan istemcileri güncellemek için, önce yönetim resmini güncelleyin sonra istemcileri resmin yeni kopyasına referans verecek şekilde değiştirin.

SolidWorks Kurulum Yöneticisini internet üzerinden çalıştırın ki doğru dosyalara referans verilsin. SolidWorks Installation Manager kendini bunu yapmak için yeniden yönlendirir, yada güncellemeyi doğrudan SolidWorks Downloads Web sitesinden indirebilirsiniz (http://www.solidworks.com/sw/support/downloads.htm).

Yönetim resmini bir kez güncellediğinizde (ki bu resmin yeni bir kopyasını oluşturur), istemcileri yeni kopyaya referans verdirerek güncelleyebilirsiniz.

Eğer istemciler yönetim resminin önceki versiyonuna haritalanmış bir sürücü veya paylaşılan bir dizin kullanarak referans veriyorlardıysa, o sürücü veya dizini yönetim resminin güncellenmiş konumunu kullanarak yeniden tanımlayabilirsiniz.
  • Yönetim Resimleri için Güncellenmiş Kurulum Dosyaları İndiriliyor
    SolidWork Kurulum Yöneticisi, bir yönetim resmini yükseltirken güncellenmiş kurulum dosyalarına ihtiyacınız olduğunda bunu otomatik olarak algılayabilir.
  • Bir Yönetim Resmini Yükseltmek
    Bir yönetim resmini yükseltmek için, SolidWorks Kurulum Yöneticisi yeni bir resim dizini oluşturur. Sonra istemcileri yeni yönetim resmi dizinini kullanarak ürün sürümünü yükseltmeye yönlendirirsiniz.
  • İstemcileri Yönetim Resimlerinden Yükseltmek
    SolidWork Kurulum Yöneticisi otomatik olarak yönetim resminden kurulmuş istemci bilgisayarları güncelleyebilir.
Üst konu başlığ: Birden Fazla Kurulumun Yönetimi


Yönetim Resimleri için Güncellenmiş Kurulum Dosyaları İndiriliyor

SolidWork Kurulum Yöneticisi, bir yönetim resmini yükseltirken güncellenmiş kurulum dosyalarına ihtiyacınız olduğunda bunu otomatik olarak algılayabilir.

  1. SolidWorks Kurulum Yöneticisini DVD'yi takarak başlatın.
  2. Goş Geldiniz ekranında, Yönetim resmini seçin.
  3. Seri Numarası ekranında, SolidWorks seri numarasını girin.

    SolidWorks Kurulum Yöneticisi, SolidWorks web sayfasını lisanslı ürünleriniz ve kullanılabilir servis paketleri için denetler.

  4. Eğer Daha Yeni Bir Sürüm Var ekranı görünürse Evet, daha yeni sürümü indir ve kur:'u seçin sürüm.

    SolidWorks Kurulum Yöneticisi yeni versiyonu kurmak için yeni bir oturum başlatır.

  5. Eğer indirme klasöründe bir sorun varsa, İndirme Seçenekleri görüntülenebilir, bu durumda varsayılan dizini kabul edin veya yeni bir dizin adı girin.

    Dizinin olmadığına dair bir mesaj görürseniz oluşturmak için Evet'i tıklayın.

  6. İndirme Tamamlandı ekranında Kapat'ı tıklayarak geçerli kurulumcuyu kapatıp yeni versiyon için kurulumcuyu çalıştırın.
Üst konu başlığ: Yönetim Resimlerini Yeni Sürüme Yükseltmek


Bir Yönetim Resmini Yükseltmek

Bir yönetim resmini yükseltmek için, SolidWorks Kurulum Yöneticisi yeni bir resim dizini oluşturur. Sonra istemcileri yeni yönetim resmi dizinini kullanarak ürün sürümünü yükseltmeye yönlendirirsiniz.

Bu süreç, yönetim resmi için tüm güncellenmiş kurulum dosyalarını indirdiğinizi varsayar. Ayrıntılar için bkz. Yönetim Resimleri için Güncellenmiş Kurulum Dosyaları İndiriliyor.

  1. SolidWorks Kurulum Yöneticisini Başlatın. Ayrıntılar için bkz. SolidWorks Kurulumunu Başlatmak.
  2. Goş Geldiniz ekranında, Yönetim resmini seçin.

    Yönetim resmi oluşturulması seçenekleri görünür:

    Yeni bir resmi, varsayılan ayarları kullanarak oluştur.
    Resmi varsayılan konfigürasyon seçeneklerini kullanarak oluştur (yani, varolan bir yönetim resminin zaten belirlenmiş ayarlarına göre değil).
    Varolan bir resimden ayar ve dosyaları kullanarak yeni bir resim oluşturun
    Resmi, varolan bir yönetim resmi için belirtilmiş olan konfigürasyon ayarlarını kullanarak oluştur. Varolan yönetim resminin kurulum dizinini belirtmek için Gözat'ı tıklayın.
    Hem 32-bit hem de 64-bit yönetim resimleri oluştur.
    Tek bir bilgisayarda hem 32-bit, hem 64-bit yönetim resimleri oluşturabilirsiniz yada yalnızca bilgisayar mimarinize denk gelen yönetim resmini kurabilirsiniz. Her iki resmi de oluşturmak, hem 32-bit hem de 64-bit kurulum medyasına erişiminiz olmasını gerektiriyor.

  3. Seri Numarası ekranında, seri numarasını kontrol edin.
  4. Özet (Resim Oluşturmaya Hazır)ekranında, yönetim resmi seçeneklerini kontrol edin.

    Bireysel yönetim resmi ve kurulum seçenekleri ile ilgili olarak DEĞİŞTİR'i tıklayarak seçenek penceresine gidin ve sonra Yardım'ı tıklayın.

  5. Yönetim resminin yeni bir versiyonunu oluşturmak için Şimdi Oluştur'u tıklayın.

Yönetim resminin bu yeni versiyonuna şimdi istemcileri yükseltebilirsiniz. Ayrıntılar için bkz. İstemcileri Yönetim Resimlerinden Yükseltmek.

Üst konu başlığ: Yönetim Resimlerini Yeni Sürüme Yükseltmek


İstemcileri Yönetim Resimlerinden Yükseltmek

SolidWork Kurulum Yöneticisi otomatik olarak yönetim resminden kurulmuş istemci bilgisayarları güncelleyebilir.

Tipik olarak, yönetim resimleri bir sunucuda klasörlerin içinde organize edilir. İstemcilerin otomatik yükseltmesini desteklemek için yönetim resmi paylaşılan bir klasörde olmalı.

Yönetim resmini yükselttikten sonra, orijinal kurulum bir klasörde, yükseltilmiş kurulum ise bir başka klasörde bulunur. Yükseltilmiş kurulumu kullanmak için paylaşım seçeneğini orijinal yönetim resmi klasöründen kaldırıp yükseltilmiş yönetim resmi klasörüne ekleyin.

SolidWorks, orijinal yönetim resminden kurulmuş bir istemci bilgisayarda başlatıldığında, yeni sürümü görür ve istemciyi yükseltir.

  • Paylaşım Seçeneğini Orijinal Yönetim Resmi Klasöründen Kaldırmak
    Paylaşılan bir klasörden erişilen bir yönetim resmini yükseltirken paylaşım seçeneğini orijinal klasörden kaldırmanız gerekir.
  • Yükseltilmiş bir Yönetim Resmi Klasörüne Paylaşım Seçeneğini Eklemek
    Yükseltilmiş bir Yönetim resmi klasörü oluşturup orijinal klasörün paylaşımını devre dışı bıraktığınızda, paylaşım seçeneğini yeni klasöre koyarak yönetim resmini yeniden etkinleştirmelisiniz.
  • Yönetim Resimlerinin İstemcilerini Komut Satırı Kullanarak Manüel Olarak Yükseltin
    Birkez bir yönetim resmini yükselttiğinizde, istemcileri komut satırı ile yükseltebilirsiniz.
Üst konu başlığ: Yönetim Resimlerini Yeni Sürüme Yükseltmek


Paylaşım Seçeneğini Orijinal Yönetim Resmi Klasöründen Kaldırmak

Paylaşılan bir klasörden erişilen bir yönetim resmini yükseltirken paylaşım seçeneğini orijinal klasörden kaldırmanız gerekir.

  1. Orijinal yönetim resmi dosyalarının olduğu klasöre gidin.
  2. Klasöre sağ tıklayın ve Özellikler'i seçin.
  3. Paylaşım sekmesinde, Bu klasörü paylaşma'yı seçip, Tamam'ı tıklayın.

Şimdi paylaşım seçeneğini Yükseltilmiş bir Yönetim Resmi Klasörüne Paylaşım Seçeneğini Eklemek başlığında anlatıldığı gibi yükseltilmiş yönetim resmine ekleyin.

Üst konu başlığ: İstemcileri Yönetim Resimlerinden Yükseltmek


Yükseltilmiş bir Yönetim Resmi Klasörüne Paylaşım Seçeneğini Eklemek

Yükseltilmiş bir Yönetim resmi klasörü oluşturup orijinal klasörün paylaşımını devre dışı bıraktığınızda, paylaşım seçeneğini yeni klasöre koyarak yönetim resmini yeniden etkinleştirmelisiniz.

  1. Yükseltilmiş yönetim resmi dosyalarının bulunduğu klasöre gidin.
  2. Klasöre sağ tıklayın ve Özellikler'i seçin.
  3. Paylaşım sekmesinde, şirket veya grubunuz için uygun olan paylaşım seçeneklerini seçin ve paylaşım adını orijinal yönetim resmi klasörü için kullanılana değiştirin.
Orijinal yönetim resmi paylaşım konumundan kurulmuş olan istemciler SolidWorks başlatıldığında otomatik olarak yükseltilecekler.
Üst konu başlığ: İstemcileri Yönetim Resimlerinden Yükseltmek


Yönetim Resimlerinin İstemcilerini Komut Satırı Kullanarak Manüel Olarak Yükseltin

Birkez bir yönetim resmini yükselttiğinizde, istemcileri komut satırı ile yükseltebilirsiniz.

  1. Tüm istemcilerin önceki sürümün aynı servis paketinde olduklarından emin olun. (uygulamanın zaten kurulmuş yada yükseltilmiş olmadığı istemciler.)
  2. Opsiyonel olarak istemci sistemlerden birinde Ayarları Kopyalama Sihirbazını çalıştırarak geçerli SolidWorks ayarlarını yakalayın.
  3. SolidWorks Kurulum Yöneticisi veya komut satırını kullanarak bir yönetim resmi oluşturun.

    Önceki resmi yükseltmeyin veya üzerine yazmayın.
    Eğer İngilizce dışındaki diller için SolidWorks kurulumunu yükseltiyorsanız, o dil için ayrı bir yönetim resmini oluşturmalısınız.

  4. Tüm istemcileri yeni versiyona msiexec komutunu kullanarak yükseltin:

    • /I ve qb msiexec komut satırı seçeneklerini ekleyin.
    • Gerekli unsur ve global komut satırı özelliklerini belirtin. Ayrıntılar için bkz. Komut Satırı Özellikleri.

    Örneğin, varolan bir SolidWorks sürümünü yükseltmek için:

    msiexec /I Msi_path" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks version servicepack" /qb

    Eğer İngilizce dışındaki diller için SolidWorks kurulumunu yükseltiyorsanız, İngilizce olmayan dil bileşenini, SolidWorks bileşenlerini yükselttikten sonra yükseltmelisiniz.

Üst konu başlığ: İstemcileri Yönetim Resimlerinden Yükseltmek


Servis Paketi Ürün Güncelleme Yönetimi

Servis Paketi ürün güncellemeleri sisten güvenirliği, program uyumluluğu, güvenlik vs. için güncellemeler içerebilir.

Ürün güncellemelerini iki şekilde alabilirsiniz:

SolidWorks'ün güncel sürümleri için:
SolidWorks Kurulum Yöneticisini güncellemeleri denetlemek, indirmek ve kurmak için kullanarak.

SolidWorks Kurulum Yöneticisini kendiniz başlatabilir veya güncellemeleri periyodik olarak denetlemesi için samanlayabilirsiniz.

SolidWorks'ün 2008 öncesi sürümleri için:
Servis paketlerini SolidWorks destek web sayfasından indirerek.

Servis paketleri, varolan yazılım versiyonuna yama gibi uygulanır. Örneğin, SolidWorks 2007 SP 1.0 SolidWorks 2007 SP 0.0'ın servis paketidir. Bu servis paketlerini SolidWorks 2007 Kurulum Yöneticisini kullanarak kurabilirsiniz, bunlayı SolidWorks 2008 Kurulum Yöneticisi veya daha yenisini kullanarak kuramazsınız.

Servis paketlerini indirmek ve kurmak hakkında talimatlar için güncellemekte olduğunuz SolidWorks sürümünün kurulum dokümentasyonuna göz atın.

  • Bir Yönetim Resminde Servis Paketlerini Geri Almak
    Bir yönetim resmini önceki bir servis paketine geri alabilirsiniz. Eğer SolidWorks yazılımını diskleri kullanarak kurduysanız, servis paketlerini geri almak için orijinal disklere ihtiyacınız var. Yönetim resminin kaydedilmiş bir kopyası olmalı.
  • Microsoft Active Directory ile Dağıtılmış İstemcilere Servis Paketlerinin Uygulanması
    Eğer SolidWorks yazılımını Microsoft Active Directory kullanarak kurduysanız, servis paketlerini de onunla uygulayabilirsiniz.
Üst konu başlığ: Birden Fazla Kurulumun Yönetimi


Bir Yönetim Resminde Servis Paketlerini Geri Almak

Bir yönetim resmini önceki bir servis paketine geri alabilirsiniz. Eğer SolidWorks yazılımını diskleri kullanarak kurduysanız, servis paketlerini geri almak için orijinal disklere ihtiyacınız var. Yönetim resminin kaydedilmiş bir kopyası olmalı.

Yükseltilmiş olan yönetim resimleri geri alınamaz. SolidWorks Kurulum Yöneticisi dışındaki bir yöntemle oluşturulmuş yönetim resimleri geri alınamaz. Bir yönetim resimlerinden kurulan istemciler kaldırılıp, daha önceki versiyonda bir yönetim resmi kullanılarak yeniden kurulmalılar.
  1. Geçerli yönetim resmini içeren klasörü silin. Bunu yapmak için komut satırı penceresini açın ve girin:

    rmdir /s/q path_to_current_administrative_image

  2. Yedekleme kopyasını geçerli yönetim resmini sildiğiniz konuma taşıyın. Bunu yapmak için komut satırı penceresini açın ve girin:

    move path_to_backup_administrative_image path_to_current_administrative_image

    Yönetim resmini geri aldıktan sonra, istemci bilgisayarlar otomatik olarak SolidWorks'ü bir sonraki çalışmalarında geri alırlar.

Üst konu başlığ: Servis Paketi Ürün Güncelleme Yönetimi


Microsoft Active Directory ile Dağıtılmış İstemcilere Servis Paketlerinin Uygulanması

Eğer SolidWorks yazılımını Microsoft Active Directory kullanarak kurduysanız, servis paketlerini de onunla uygulayabilirsiniz.

  1. Komut Satırını Kullanarak Yönetim Resmini yeni bir klasöre kopyalayın:

    xcopy path_to_current_administrative_image path_to_backup_administrative_image /s/i/v

  2. Servis paketini yönetim resminin kopyasına uygulayın.
  3. SolidWorks yazılımına bir yükseltme kurulumunu belirtmek için bir dönüştürme dosyası oluşturun:
    1. Komut satırı penceresini açın.
    2. Yönetim resmini içeren klasörde, SWCreateMST.exe'yi komut satırına sürükleyin.

      Komut formatı:

      path_to_administrative_image\SWCreateMST.exe path_to_MSI_file_of_an_administrative_image list_of_properties

      Komut satırı, orijinal dönüştürme dosyası için kullanılan tüm parametreleri ve ayrıca UPGRADESWINSTALL ile SWMIGRATE global özelliklerini içermeli.

      Örneğin, orijinal komut aşağıdaki gibi ise:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@your_server

      güncelleme komutu şöyle olmalı:

      C:\admin\SWCreateMST.exe "c:\admin\SolidWorks.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SolidWorks,Manuals,Intel_Modules_AgeiaX86 OFFICEOPTION=0 SERVERLIST=25734@your_server UPGRADESWINSTALL=1 SWMIGRATE="SolidWorks version service_pack"

      Dönüştürme dosyası SolidWorks.mst yönetim resmini içeren klasörde oluşturulur.

      Bu örnekteki orijinal ve güncelleme komutları 32-bit işletim sistemindeki 32-bit SolidWorks sürümü içindir. Eğer 64-bit işletim sistemine 32-bit SolidWorks kuruyorsanız "Intel_Modules_AgeiaX86" yerine "Intel_Modules_AgeiaX64" kullanırdınız. Eğer 64-bit işletim sistemine 64-bit SolidWorks kuruyorsanız ne "Intel_Modules_AgeiaX86" nede "Intel_Modules_AgeiaX64" kullanmazdınız.

  4. Aktif Dizinde, SolidWorks yazılımının dağıtılacağı gruplar için Published Apps poliçesini düzenleyin.
  5. Group Policy diyaloğunda Computer Configuration and Software Settings'i genişletin.
  6. Software installation'ı sağ tıklayın ve New > Package'i seçin.
  7. Yönetim resmine gidin ve Aç'a tıklayın.
  8. Yazılımı Dağıt diyaloğunda Gelişmiş yayılmış veya atanmış'ı seçin, sonra Tamam'ı tıklayın.
  9. SolidWorks Özellikleri diyaloğunda Değişiklikler dekmesinde:
    1. Ekle'ye tıklayın.
    2. .mst dosyasına gözatın.
    3. Aç'a tıklayın.
  10. Tamam'a tıklayın.
Üst konu başlığ: Servis Paketi Ürün Güncelleme Yönetimi


Workgroup PDM

Workgroup PDM uygulaması bir ürün veri yönetimi yazılımıdır ve SolidWorks ortamında veya SolidWorks Explorer'ın içinde tek başına çalışır. Workgroup PDM projeleri, Teslim alma, teslim etme, revizyon kontrolü ve diğer yönetim görevleri için prosedürlerle yönetiyor.

Bir Workgroup PDM sistemi şu şekilde gösterilebilir:

  • Bir bilgisayar yalnızca Kasayı içerebilir.
  • Kasa dizini gizli veya salt okunur olamaz.
  • Bir istemci/sunucu uygulaması olarak Workgroup PDM'in performansı iyi bir ağa bağlıdır.
  • Eğer kullanıcılarınız büyük miktarda belge tutuyorlarsa, az sayıda proje içinde proje başına çok belge tutmak yerine çok sayıda proje ve alt proje içinde proje başına az sayıda belge tutarak performansı iyileştirebilirsiniz.

Kurulum

  • İstemciler ve VaultAdmin, API ve Viewer Kasa ile aynı bilgisayara veya farklı bilgisayarlara kurulabilirler.
  • İstemci API'ı kurmak için Workgroup PDM'i kurmak gerekli değildir. İstemci API Workgroup PDM İstemci kurulumu sırasında kurulur.
  • Kasa klasörünü uzak bir konumda biçimlendirmek için sunucu hedefi tarafından sorulduğunda tam Evrensel Adlandırma Kuralı (UNC) yolunu yazın. (Ayrıntılar için bkz. UNC Formatı.)
  • Kasayı kurmak veya güncellemek bilgisayarı yeniden başlatmayı gerektirir.
  • Eğer Workgroup PDM Sunucu Hizmeti yeniden başlatmadan sonra otomatik olarak başlamazsa manüel olarak başlatmalısınız. Windows Explorer'da, install_dir\SolidWorks Workgroup PDM\Vault konumundaki pdmwvault.exe'ı yürütün.
  • Bir Workgroup PDM istemcisi kurduğunuzda her bilgisayara solidworksexplorer.exe'yi kurmalısınız. Bu yürütülebilir dosya paylaşılan bir sürücüde olabilir. Workgroup PDM Vault, VaultAdmin, API Istemcisi ve Viewer her istemci bilgisayara kurulmazlar.

Lisanslar

  • Workgroup PDM API için bir lisans SolidWorks istemcileri ve Explorer istemcileri lisansları ile birliktedir. Teslim etme API'ları istemci lisansları gerektirir.
  • Viewer'ı etkinleştirmek için bir Workgroup PDM Viewer lisansı kasa ile birlikte kurulmalıdır.

İzinler

  • Kasa yöneticisi, kurulum ve kasa klasörü için yazma iznine sahip olmalı.
  • Kasa yöneticisi kasa klasörünü VaultAdmin'den yönetmeli, Windows Explorer'dan değil.
  • Kullanıcılar hiçbir zaman kasa klasörü için Windows Explorer'da yazma iznine sahip olmamalı.

Güvenlik, Bağlantı Noktaları ve Dupleks Ayarları

  • Workgroup PDM, bir Windows servisi olarak kurulmalı ki diğer uygulamalar bu hizmeti engelleyemesin veya filtreleyemesin. Örneğin, Microsoft AntiSpyware gibi herhangi bir anti-spyware aracı kurulum sırasında onay gerektiren bir mesaj görüntülerse İzin Ver'i tıklayın ki Workgroup PDM Server bir Windows Servisi olarak kurulsun.
  • Eğer Workgroup PDM'i Windows XP Service Pack 2'de, Windows 2003 server Service Pack 1'de, veya aktif güvenlik duvarı olan bir bilgisayara kurarsanız, Workgroup PDM bağlantı noktalarını güvenlik duvarı için istisnalar olarak ayarlamalısınız.

    Tipik olarak bu bağlantı noktaları:

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Request)
    • 80 (Viewer)
    Bağlantı noktası ayarlarını değiştirmek hakkında bilgiler için Workgroup PDM ve SolidWorks Explorer yardımında Kasa Yöneticileri için Sorun Giderme'ye ve Microsoft Windows yardımında Güvenlik Merkezi'ne gözatın. Workgroup PDM Vault ve Viewer'ı aynı anda kurmak için Kurulum Tipi iletişim kutusunda Özel'i seçin.
  • Sunucukar ve eşleşen bağlantı noktaları için dupleks ayarları aynı olmalı; örneğin, her ikiside 100MB Full veya Auto olabilir.

SolidWorks Toolbox Belgeleri

SolidWorks Toolbox belgeleri revizyon kontrolü gerektirmeyen ve Workgroup PDM Kasasına teslim edilmeyen gündelik donanım bileşenleridir. SolidWorks Toolbox ve diğer standart kitaplıkların biçimlendirilmesi hakkında detaylı bilgi için Workgroup PDM online yardımına gözatın.

  • Workgroup PDM Viewer
    Workgroup PDM yazılımı otomatik olarak kurulum sırasında Microsoft Internet Information Services (IIS) kullanarak sanal bir dizin oluşturur.
  • Bir Workgroup PDM Sunucusunu Kurmak
    Workgroup PDM Sunucusunu kurmak Workgroup PDM kasasını oluşturur, bu da yönetilen SolidWorks projelerini barındıran veritabanıdır.
  • Workgroup PDM İstemcilerinin Konfigürasyonu
    Workgroup PDM sunucu kasasını kurduktan sonra kasayı istemciler için konfigüre edebilirsiniz.
  • Workgroup PDM Server ve Viewer'ı Çevresel Ağ İçinde Kurmak
    SolidWorks Workgroup PDM Web sunucusu ve Workgroup PDM Viewer'ı bir çevresel ağ (DMZ) içinde kurmanın güvenlik duvarı için sonuçları vardır.
  • Workgroup PDM İstemci Erişimi
    Workgroup PDM istemcileri Microsoft Windows oturum erişim kontrolleri kullanır, Workgroup PDM Viewer ile ağ erişine sahiptir ve Workgroup PDM kasası her güncellendiğinde otomatik olarak güncellenirler.
  • Workgroup PDM VaultAdmin Yönetimi
    Workgroup PDM kurulduktan sonra kasa yöneticileri şu görevleri icra etmelidir.


Workgroup PDM Viewer

Workgroup PDM yazılımı otomatik olarak kurulum sırasında Microsoft Internet Information Services (IIS) kullanarak sanal bir dizin oluşturur.

Viewer'ı kurmadan önce Microsoft Internet Information Services (IIS) kurmalısınız.
Gerekli bileşenler:
  • Web Yönetim Araçları
    • IIS Yönetim Konsolu
  • World Wide Web Servisleri: Uygulama Geliştirme Unsurları
    • .NET Genişleyebilirliği
    • ASP.NET
    • CGI
    • ISAPI Genişlemeleri
    • ISAPI Filtreleri
IIS Kurulum talimatları için Microsoft dokümentasyonuna bakın.
Workgroup PDM Viewer kurulumu şu sınırlandırmalara tabidir:
  • Web Sayfası İçerik Dizini Viewer kurulum klasörüdür.
  • Viewer'ı tutan bilgisayarın adında alt çizgi karakteri kullanılamaz.
  • viewer'ı Windows XP Service Pack 2'de kurarsanız Windows Firewall'da HTTP (port 80) için bir bağlantı noktasını etkinleştirmelisiniz.
  • Viewer bir kerede yalnızca bir kasaya işaret edebilir.

Kullanıcılar, Workgroup PDM Viewer'a bu URLi Internwet Explorer'a girerek erişir.

http://ViewerComputerName/pdmweb/

Üst konu başlığ: Workgroup PDM


Bir Workgroup PDM Sunucusunu Kurmak

Workgroup PDM Sunucusunu kurmak Workgroup PDM kasasını oluşturur, bu da yönetilen SolidWorks projelerini barındıran veritabanıdır.

  1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
  2. Hoş Geldiniz ekranında, şunu seçin:

    • Sunucu ürünleri
    • SolidWorks Workgroup PDM Sunucusu'nu (kasa) bu bilgisayara kur.

  3. Özet ekranında, Değiştir tıklayarak doğrulama kodu alın. Kodu şu yöntemlerle alabilirsiniz:
    • Internet bağlantısı
      1. SolidWorks seri numarası ve e-mail adresinizi girin.
      2. Otomatik Doğrula ve Kodu Al'ı seçin.
    • Email
      1. Eğer internet bağlantınız yoksa Manüel olarak email ile doğrula'yı seçin. Kurulum yöneticisi bir dosya hazırlar.
      2. Kaydet tıklayarak dosyayı kaydedin.
      3. Ekrandaki talimatları takip edin.
  4. Özete Geri Dön'ü tıklayın.
  5. Özet ekranında Şimdi Kur tıklayın.
Üst konu başlığ: Workgroup PDM


Workgroup PDM İstemcilerinin Konfigürasyonu

Workgroup PDM sunucu kasasını kurduktan sonra kasayı istemciler için konfigüre edebilirsiniz.

  1. VaultAdmin'e varsayılan kullanıcı adı ve şifre ile oturum açın.
  2. VaultAdmin'de kullanıcı grup ve hesaplarını, proje klasörlerini izinleri ve fazlasını ayarlayın .

    Talimatlar için bkz. Workgroup PDM Yardım.

  3. İstemci kullanıcılara, sunucu bilgisiyarın adını ve onların kullanıcı adları ve şifrelerini, ki genelde Microsoft Windows kullanıcı ad ve şifreleri ile aynı değildir, email ile yollayın.
  • Workgroup PDM Viewer Konfigürasyonunu Farklı bir Kasa Konumuna Bağlanacak Şekilde Yapmak
    Workgroup PDM Viewer'ı farklı bir kasa konumuna bağlanacak şekilde, Windows Kayıt Defterini kullanarak, konfigüre edebilirsiniz.
  • Belge İndirme için Mime Tiplerinin Konfigürasyonu
    Windows Kayıt Defteri kullanılarak belge indirmek için mime tipleri konfigüre edilebilir.
Üst konu başlığ: Workgroup PDM


Workgroup PDM Viewer Konfigürasyonunu Farklı bir Kasa Konumuna Bağlanacak Şekilde Yapmak

Workgroup PDM Viewer'ı farklı bir kasa konumuna bağlanacak şekilde, Windows Kayıt Defterini kullanarak, konfigüre edebilirsiniz.

  1. Kayıt yolunu Vault Computer değerini değiştirerek güncelleyin:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\Vault Computer

  2. Workgroup PDM Viewer'ı yeniden kurun. Vault Computer Name iletişim kutusunda, yeni bilgisayar adını yazın.
Üst konu başlığ: Workgroup PDM İstemcilerinin Konfigürasyonu


Belge İndirme için Mime Tiplerinin Konfigürasyonu

Windows Kayıt Defteri kullanılarak belge indirmek için mime tipleri konfigüre edilebilir.

Varsayılan olarak, Viewer Belge Aç istemlerini genel mime tipi "application/octet-stream" ile yollar. Microsoft Internet Explorer sonra istenilen belgeyi verilen dosya soneki ile açar. Mime Tipleri kayıt alt anahtarını Windows Kayıt Defterinde değiştirerek ek mime tiplerini haritalayabilir veya mime tip haritalarını kapayabilirsiniz.

  • Ek mime tiplerini haritalamak için bu kayıt alt anahtarı içinde ek söz dizisi değerleri oluşturun:

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Mime Types

    Şu biçimde:

    "ext" = "mime type"

    Örneğin:

    "dxf" = "image/vnd.dxf"

    Değerleri eklemeden önce bu kayıt alt anahtarını manüel olarak oluşturmalısınız.

    Mime tip haritalamalarını kapamak için Use Custom MIME Types kayıt defteri değerini 0'a (sıfır) değiştirin.

    HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\SolidWorks 2009\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Bu ayarı etkinleştirmek için ağ sunucusunu yeniden başlatmak gerekmez.

Üst konu başlığ: Workgroup PDM İstemcilerinin Konfigürasyonu


Workgroup PDM Server ve Viewer'ı Çevresel Ağ İçinde Kurmak

SolidWorks Workgroup PDM Web sunucusu ve Workgroup PDM Viewer'ı bir çevresel ağ (DMZ) içinde kurmanın güvenlik duvarı için sonuçları vardır.

Workgroup PDM Viewer istemcileri Web sunucusu ile HTTP veya HTTPS bağlantı noktaları üzerinden iletişim kurduğundan bu noktalar Internet Bilgi Sunucusunda (IIS) açık olmalılar.

  • HTTP protokolü için varsayılan bağlantı noktası 80'dir.
  • HTTPS protokolü (SSL) için varsayılan bağlantı noktası 443'dür.

Web Viewer istemcilerinin güvenlik duvarı istisnalarına ihtiyaçları yoktur.

Ağ sunucu sisteminin Kasa sunucusuna bu noktalardan erişebildiğinden emin olun:

  • 30000 (Data)
  • 40000 (Request)
  • Çevresel Ağ İçinde Workgroup PDM Viewer için Ağ Konfigürasyonu
    Ağ konfigürasyonu bir çevresel alt ağ üzerinde kurulu bir çevresel ağ sunucusunu ve onun iç ve dış ağlar ile iletişimini gösterir.
  • Workgroup PDM Ağ Sunucusunun ve Görüntüleyicisinin Kurulumu ve Konfigürasyonu.
    Bir Workgroup PDM Ağ sunucusunu bir çevresel ağ içinde kurunca, bileşenlerin kurulum konumları önemlidir.
Üst konu başlığ: Workgroup PDM


Çevresel Ağ İçinde Workgroup PDM Viewer için Ağ Konfigürasyonu

Ağ konfigürasyonu bir çevresel alt ağ üzerinde kurulu bir çevresel ağ sunucusunu ve onun iç ve dış ağlar ile iletişimini gösterir.

Çevresel ağ sunucusu LAN ile bir iç güvenlik duvarı içinden temas eder. Dış ağ ile bir dış güvenlik duvarı, bir yönlendirici, ve bir yük dengeleyiciler kümesi aracılığı ile temas eder.

Internet Explorer istemcisi Workgroup PDM Viewer/IIS sunucusuna bağ.nok 80 (SSL ise 443) ile bağlanır. Workgroup PDM Viewer sonra Kasa sunucusu ile bağ. nok. 30000 veya 40000 ile bağlanır. Kasa sunucusu istenilen bilgiyi Workgroup PDM Viewer'a gönderir, bu da bilgiyi Internet Explorer istemcisine besler.

Çevre Ağ Web suncusunun iki IP adresi var:

  • LAN üzerindeki iç IP adresi
  • ISP tarafından sağlanan genel IP adresi

Çevresel ağda Web sunucusu bir yük dengeleyicileri kümesinin arkasında bulunur. Yönetim görevleri için doğrudan Web sunucusuna gidebilseniz bile, çevresel ağdaki sunuculara olan tüm trafik yük dengeleyicilerden geçer.

Yük dengeleyicileri sunucu donanım IP adresini bir sanal IP adresine (VIP) kamuya açık bir ağ bacağında tercüme ederler. Eğer VIP veya Web sunucusu URL'ine gezinirseniz sayfayı görebilirsiniz.

Dış güvenlik duvarı, yük dengeleyici VIP'i kamuya açık yönlendirilebilir bir adrese tercüme eder.

Üst konu başlığ: Workgroup PDM Server ve Viewer'ı Çevresel Ağ İçinde Kurmak


Workgroup PDM Ağ Sunucusunun ve Görüntüleyicisinin Kurulumu ve Konfigürasyonu.

Bir Workgroup PDM Ağ sunucusunu bir çevresel ağ içinde kurunca, bileşenlerin kurulum konumları önemlidir.
  • IIS-etkinleştirilmiş Ağ sunucusunu çevresel altağda kurun.
  • IIS-etkinleştirilmiş Workgroup PDM Viewer'ı çevresel altağda kurun.
  • Workgroup PDM Vault'u yerel intranet'te iç ağa veya birincil alan adına kurun.

Workgroup PDM Viewer'ı bir çevresel ağda kurmanın ön koşulları:

  • Microsoft IIS 6.0 veya daha yenisi
  • Çevresel altağdaki Web sunucusuna, ISP sağlayıcı tarafından atanmış genel IP adresi

Workgroup PDM bileşenlerini Kurmak ve konfigüre etmek için:

  1. Microsoft IIS'i çevresel altağ sunucu sistemine kurun.
  2. İki SolidWorks Workgroup PDM Sunucu Kurulumı gerçekleştirin:
    1. Önce, Kasa bileşenini Kasa Sunucusuna kurun.
    2. Kurulumu ikinci defa çalıştırıp Workgroup PDM Viewer ve Viewer lisans bileşenlerini IIS Web sunucusuna kurun. Kasa sunucu bilgisayar adını girin ki Web portalı kasa sunucu hizmeti için nereye bakacağını bilsin.

    Kurulumu gerçekleştirdiğinizde, PDMWeb uygulaması otomatik olarak varsayılan IIS Web sayfasına eklenir.

  3. İç ağ güvenlik duvarının 30000 ve 40000 bağlantı noktalarının açık olduğundan emin olun.
  4. Eğer iç sunucunun sabit bir IP adresi varsa, çevre sunucu sisteminde C:\Windows\system32\drivers\etc\hosts dosyasını düzenleyin. IP adresi haritalamasına bir sistem adı oluşturun ki çevre sunucusu iç sunucu ile iletişim kurabilsin:
    1. hosts dosyasını Notepad gibi bir metin düzenleyicide açın.
    2. Kasa sunucusu IP adresi ve adı için yeni bir satır oluşturun.
    3. hosts dosyasını kaydedin.
Üst konu başlığ: Workgroup PDM Server ve Viewer'ı Çevresel Ağ İçinde Kurmak


Workgroup PDM İstemci Erişimi

Workgroup PDM istemcileri Microsoft Windows oturum erişim kontrolleri kullanır, Workgroup PDM Viewer ile ağ erişine sahiptir ve Workgroup PDM kasası her güncellendiğinde otomatik olarak güncellenirler.

Workgroup PDM istemcisi olarak oturum açmak için: | İstemci kullanıcı isimleri ve şifreleri Workgroup PDM'de Microsoft Windows oturumu ile ayn değildir. Oturum açma bilgileriniz için sistem yöneticinize danışın.
Workgroup PDM Viewer'a bağlanmak için: | Gerekli URL için sistem yöneticinize danışın.
Workgroup PDM istemcilerini güncellemek için: | Workgroup PDM istemcileri (SolidWorks eklentisi ve Contributor) Kasanın güncellendiğini algılar. İstemcileri güncellemek için bir servis paketi indirmeniz gerekmez.
Üst konu başlığ: Workgroup PDM


Workgroup PDM VaultAdmin Yönetimi

Workgroup PDM kurulduktan sonra kasa yöneticileri şu görevleri icra etmelidir.

  • VaultAdmin'e oturum açmak.
  • Kasa yöneticisi şifresini değiştirmek.
  • Kullanıcı hesapları oluşturmak.
  • Kullanıcıları hesap isim ve şifreleri konusunda bilgilendirmek.

Detaylar için ana SolidWorks yardımında SolidWorks Workgroup PDM'e bakın.

  • Workgroup PDM VaultAdmin'e İlk Oturum Açma
    Workgroup PDM VaultAdmin'e ilk defa oturum açarken, Workgroup PDM yönetici adı ve şifresini ve Workgroup PDM Vault'u barındıran bilgisayarın adını belirleyin.
  • Workgroup PDM Vault Sunucusunu Yükseltmek
    Workgroup PDM Vault Sunucusunu, SolidWorks Güncelleme Denetimini, bir SolidWorks kurulum DVD'sini veya yerel bir klasöre manüel olarak indirilmiş bir Workgroup PDM yükseltme dosyasını kullanarak yükseltebilirsiniz.
  • Workgroup PDM İstemcilerinin Yükseltilmesi
    İstemciler, kasa güncellendikten sonraki ilk bağlantılarında güncellenmeleri için uyarılırlar. İstemci güncellemeleri için servis paketi gerekmez.
Üst konu başlığ: Workgroup PDM


Workgroup PDM VaultAdmin'e İlk Oturum Açma

Workgroup PDM VaultAdmin'e ilk defa oturum açarken, Workgroup PDM yönetici adı ve şifresini ve Workgroup PDM Vault'u barındıran bilgisayarın adını belirleyin.

  1. Windows'da, Başlat > Tüm Programlar > SolidWorks version > Workgroup PDM VaultAdmin'i tıklayın.
  2. İletişim kutusunda, şu bilgileri girin:

    Ad | pdmwadmin
    Şifre | pdmwadmin
    Kasa bilgisayarı | Kasanın kurulu bulunduğu bilgisayarın adı. Eğer VaultAdmin'i kasanın bulunduğu bilgisayarda yürütüyorsanız localhost yazın.

  3. Oturum Aç'ı tıklayın.
Güvenlik sebebi ile yönetici için şifrenizi en kısa sürede değiştirmenizi öneririz. VaultAdmin'de Kullanıcılar ve Gruplar'ı seçin.
Üst konu başlığ: Workgroup PDM VaultAdmin Yönetimi


Workgroup PDM Vault Sunucusunu Yükseltmek

Workgroup PDM Vault Sunucusunu, SolidWorks Güncelleme Denetimini, bir SolidWorks kurulum DVD'sini veya yerel bir klasöre manüel olarak indirilmiş bir Workgroup PDM yükseltme dosyasını kullanarak yükseltebilirsiniz.

Workgroup PDM Vault Sunucusunun yalnızca bir sürümünü kurabilirsiniz
  1. Tüm kullanıcılardan Workgroup PDM kasasından çıkıp kilitlemelerini isteyin.
  2. Kasa verisini yedekleyin.
  3. Microsoft Windows Denetim Masası Program Ekle veya Kaldır'ı kullanarak geçerli Workgroup PDM Server sürümünü kaldırın.
  4. Yeni Workgroup PDM Sunucusu sürümünü kurun.
    • SolidWorks Güncelleme Denetimini kullanmak için:
      1. Microsoft Windows'da, Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.
      2. Daha Yeni Sürümler Var iletişim kutusunda, Daha yeni bir sürümü indir ve kur'u seçin, kurulacak sürümü seçin ve Sonraki'ni tıklayın.

        SolidWorks Kurulum Yöneticisinin yeni sürümü indirilir ve çalışır.

    • SolidWork kurulum DVD'si kullanmak için DVD'yi sürücüye takın ve SolidWorks Kurulum Yöneticisi talimatlarını takip edin.
    • Manüel olarak indirilmiş Workgroup PDM kurulum dosyasını (pdmwserver.exe) kullanmak için dosyayı çift tıklayın ve talimatları takip ederek Workgroup PDM Sunucusunu yükseltin.
  5. Workgroup PDM dosyalarını güncellemek için SolidWorks Görev Zamanlayıcıyı kullanın.
  6. Kasanın kilidini açın ve kullanıcılara, kullanmaya geri dönebileceklerini bildirin.
Üst konu başlığ: Workgroup PDM VaultAdmin Yönetimi


Lisans Yönetimi

Kurulumdan sonra, SolidWorks lisanslarını ya bireysel bilgisayarları etkinleştirerek (lisans etkinleştirme) yada bir sunucuya yüzen ağ lisansları kurup etkinleştirerek (SolidNetWork Lisanslama) etkinleştirebilirsiniz.

Tipik olarak bireysel bilgisayarlardaki kurulumlar lisans etkinleştirmesini kullanırlar, fakat yazılımı bireysel olarak kurup lisansları SolidNetWork Lisans Yöneticisi ile kontrol edebilirsiniz. Aynı şekilde, büyük alanlar tipik olarak yüzen ağ lisansları kullanırlarken, kurulumları bir yönetim resminden dağıtıp sonra seri numaralarını bireysel bilgisayarlardan etkinleştirebilirsiniz.

  • Bireysel Lisansların Yönetimi
    Tipik olarak bireysel lisansların yönetimi, lisansların doğrudan Solidworks'ten etkinleştirilmelerini ve transfer edilmelerinden oluşur.
  • SolidNetWork License Manager'ı kullanarak Lisans Yönetimi
    SolidNetWork License Manager birden çok lisans istemcisini, lisansları ağ üzerinden dağıtarak destekler. Bu, yüzer lisanslar kullanarak kullanıcı sayısının lisans sayısını geçebilmesine imkan verir.


Bireysel Lisansların Yönetimi

Tipik olarak bireysel lisansların yönetimi, lisansların doğrudan Solidworks'ten etkinleştirilmelerini ve transfer edilmelerinden oluşur.

Etkinleştirme, tek başına yeterli SolidWorks lisansları (SolidNetWork lisansı değil) için bir ürün lisanslama ve kayıt sürecidir. Tipik olarak, eğer ürün lisansınız etkinleştirilmemiş ise, SolidWorks ürünü başlattığınızda etkinleştirmeye çalışır.

Ayrıca bireysel lisansları transfer edebilirsiniz, bunun için SolidWorks'te Yardım > Lisansları Transfer Et'i tıklayın.

  • Bir Lisansın Etkinleştirilmesi
    SolidWorks ürünlerini bireysel bir bilgisayarda çalıştırmadan önce, lisansı o bilgisayar için etkinleştirmelisiniz.
  • Bir Lisansın Transferi
    Lisansı yeni yada yükseltilmiş bir bilgisayara transfer etmek için, önce Dassault Systèmes SolidWorks Corporation lisans anahtarı sunucusuna transfer edin, sonra bilgisayarda yeniden etkinleştirin.
Üst konu başlığ: Lisans Yönetimi


Bir Lisansın Etkinleştirilmesi

SolidWorks ürünlerini bireysel bir bilgisayarda çalıştırmadan önce, lisansı o bilgisayar için etkinleştirmelisiniz.

Etkinleştirme bir internet bağlantınızın veya bir e-mail adresinizin olmasını gerektirir. Etkinleştirmeden sonra ürünleri kullanmak için online olmanız gerekmez. Ürünü kullandığınız bilgisayarda e-mail erişiminiz yoksa, etkinleştirme dosyasını kaydedip başka bir bilgisayardan yollayabilirsiniz.

Bu süreç:
  • SolidWorks ürün yelpazesindeki yüm yazılım lisanslarını etkinleştirir.
  • Lisans haklarını bir bilgisayardan bir diğerine geçirmenize izin verir.
  • SolidWorks ürünlerini bir iş bilgisayarı ve bir ev bilgisayarına kurmanıza izin verir.
  • Hemen (önerilen) veya kurulumdan sonraki 30 gün içerisinde gerçekleştirilebilir.
  • Donanım kilidi gereksinimini ortadan kaldırır. Fakat, eğer SolidWorks ürünlerinin etkinleştirme kullanmayan daha eski sürümlerini kulanıyorsanız donanım kilidini tutmaya devam etmelisiniz.

Birden fazla seri numarasını yönetmeleri gereken sistem yöneticileri için Yönetim Resmi Seçenek Düzenleyicisi kullanılabilir. Ayrıntılar için bkz. Yönetim Resmi Seçenek Düzenleyicisi.

Bir lisansı etkinleştirmek için:

  1. SolidWorks uygulamasını başlatın.
  2. SolidWorks Ürün Aktivasyonu'nu bu yöntemlerden biri ile başlatın:
    • Eğer bu bilgisayar için lisansı henüz etkinleştirmediyseniz, SolidWorks Ürün Aktivasyonun penceresi, otomatik olarak, Solidworks'ü başlattığınızda açılır.
    • Eğer SolidWorks Ürün Aktivasyonu penceresi otomatik olarak görünmezse etkinleştirmeyi Yardım > Lisansları Etkinleştir'i tıklayarak başlatın.
  3. Ürün listesine tıklayarak lisansını etkinleştirmek istediğiniz ürünleri seçin.
  4. İnternet üzerinden otomatik yada email ile manüel etkinleştirmeyi belirtin.
  5. Email iletişim bilgisi sağlayın.
  6. İleri'ye tıklayarak devam edin.
    • Internet: Etkinleştirme otomatik olarak gerçekleşir.
    • Email: Kaydet'e basarak bir talep dosyası oluşturun, sonra dosyayı activation@solidworks.com adresine yollayın. Yanıt dosyasını içeren e-mail'i aldığınızda, dosyayı e-mailden çıkartıp yüklemek için Aç'ı tıklayın.
      Eğer gerekirse, etkinleştirme sürecinden çıkıp, yanıt dosyasını açmak için yeniden başlatabilirsiniz.
  7. Bitir'e tıklayın.
Üst konu başlığ: Bireysel Lisansların Yönetimi


Bir Lisansın Transferi

Lisansı yeni yada yükseltilmiş bir bilgisayara transfer etmek için, önce Dassault Systèmes SolidWorks Corporation lisans anahtarı sunucusuna transfer edin, sonra bilgisayarda yeniden etkinleştirin.

Eğer lisansı Dassault Systèmes SolidWorks Corporation'a transfer edemediyseniz (ördeğin sabit disk hatası yüzünden), yeniden etkinleştirme yine de çoğu koşulda başarılı olur. Eğer değilse yardım için Katma Değerli Tedarikçinizle(VAR) temasa geçin.

Lisansı sunucuya geri transfer etmek için:

  1. SolidWorks'de, Yardım > Lisansları Transfer Et'i tıklayın ve talimatları takip edin.
  2. Yeniden etkinleştirmek için yeni veya yükseltilmiş bilgisayara gidip ilk etkinleştirme gibi lisansı etkinleştirin. Ayrıntılar için bkz. Bir Lisansın Etkinleştirilmesi.
Üst konu başlığ: Bireysel Lisansların Yönetimi


SolidNetWork License Manager'ı kullanarak Lisans Yönetimi

SolidNetWork License Manager birden çok lisans istemcisini, lisansları ağ üzerinden dağıtarak destekler. Bu, yüzer lisanslar kullanarak kullanıcı sayısının lisans sayısını geçebilmesine imkan verir.

Bu resim tipik bir SolidNetWork lisanslama kurulumunu gösterir:

Bu resimde görülen:
  • SolidNetWork License Manager yazılımı yalnızca lisans yöneticisi bilgisayarda kurulur ve etkinleştirilir.
  • Lisans istemcisi bilgisayarlar başka SolidNetWork'e özel kurulmuş yazılım bulundurmazlar.

    Eğer kurulum sırasında bir SolidNetWork Lisans seri numarası belirtirseniz, SolidWorks Kurulum Yöneticisi o bilgisayarı SolidNetWork lisans istemcisi olarak tanımlar. İstemciyi lisans yöneticisine bağlamak için SolidWorks Kurulum Yöneticisi size SolidNetWork lisans yöneticisi bilgisayarın adını ve bağlantı noktası numarasını sorar.

  • Lisans yöneticisi ve tüm lisans istemcilerinin TCP/IP (Aktarma Kontrol Protokolü/İnternet Protokolü) bağlantısı olmalı.
  • Bir SolidNetWork Lisansının Etkinleştirilmesi
    Kullanıcılar SolidWorks ürünlerini bireysel bir bilgisayarda çalıştırmadan önce, o bilgisayar için SolidNetWork lisansını SolidNetWork License Manager bilgisayarında etkinleştirmelisiniz.
  • Bir SolidNetWork Lisansının Transferi
    SolidNetWork Lisansını yeni yada yükseltilmiş bir bilgisayara transfer etmek için, önce Dassault Systèmes SolidWorks Corporation lisans anahtarı sunucusuna transfer edin, sonra bilgisayarda yeniden etkinleştirin.
  • SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak
    SolidNetWork Lisanslamayı konfigüre etmek, SolidNetWork License Manager'ı lisans yöneticisi bilgisayara kurmayı ve SolidWorks'ü istemci bilgisayarlara SolidNetWork Lisans seri numarası ile kurmayı içerir.
  • SolidNetWork Lisans Yönetimi
    Görevler, lisans yöneticisini başlatmayı, yükseltmeyi, kaldırmayı ve lisansları almayı, ödünç almayı ve geri vermeyi içerir.
Üst konu başlığ: Lisans Yönetimi


Bir SolidNetWork Lisansının Etkinleştirilmesi

Kullanıcılar SolidWorks ürünlerini bireysel bir bilgisayarda çalıştırmadan önce, o bilgisayar için SolidNetWork lisansını SolidNetWork License Manager bilgisayarında etkinleştirmelisiniz.

Etkinleştirme bir internet bağlantınızın veya bir e-mail adresinizin olmasını gerektirir. Etkinleştirmeden sonra ürünleri kullanmak için online olmanız gerekmez. Ürünü kullandığınız bilgisayarda e-mail erişiminiz yoksa, etkinleştirme dosyasını kaydedip başka bir bilgisayardan yollayabilirsiniz.

Bu süreç:
  • SolidWorks SolidNetWork License Manager'ı SolidNetWork lisansları ile tüm SolidWorks ürünlerinde etkinleştirir.
  • SolidNetWork lisans haklarını bir SolidNetWork License Manager bilgisayarından ötekine geçirmenize izin verir.
  • SolidNetWork lisans haklarını bir SolidNetWork License Manager bilgisayarına kurmanıza izin verir.
  • SolidNetWork lisanslarını kullanabilmeniz için önce gerçekleştirilmeli.
  • Donanım kilidi gereksinimini ortadan kaldırır. Eğer bir SolidNetWork lisansını bu SolidWorks sürümü için etkinleştirirseniz, önceki sürümler için olan SolidNetWork lisansları etkinleşir. (Artık donanım anahtarını tutmanıza gerek yok)

Bir SolidNetWork lisansını etkinleştirmek için:

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager.
  2. Eğer SolidNetWork lisansını henüz etkinleştirmediyseniz, şimdi etkinleştirmek isteyip istemediğiniz sorulur. Etkinleştirmek için Evet'e tıklayın.
  3. Nasıl Etkinleştirmek İstesiniz?'in altında Otomatik olarak internet üzerinden (önerilen)'i seçin.
  4. İletişim Bilgisi altında bir email iletişim adresi belirtin.
Etkinleştirme/Yeniden Etkinleştirme Başarılı diyaloğu etkinleştirilen ürünleri gösterir.
Üst konu başlığ: SolidNetWork License Manager'ı kullanarak Lisans Yönetimi


Bir SolidNetWork Lisansının Transferi

SolidNetWork Lisansını yeni yada yükseltilmiş bir bilgisayara transfer etmek için, önce Dassault Systèmes SolidWorks Corporation lisans anahtarı sunucusuna transfer edin, sonra bilgisayarda yeniden etkinleştirin.

Eğer lisansı Dassault Systèmes SolidWorks Corporation'a transfer edemediyseniz (ördeğin sabit disk hatası yüzünden), yeniden etkinleştirme yine de çoğu koşulda başarılı olur. Eğer değilse yardım için Katma Değerli Tedarikçinizle(VAR) temasa geçin.

SolidNetWork Lisansını sunucuya geri transfer etmek için:

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).

  2. Lisans Bilgisi altında, Değiştir'i tıklayın. SolidWorks Ürün Aktivasyonu sihirbazı başlar.
  3. Ne yapmak istiyorsunuz? altında, Bir yazılım lisansını transfer et'i seçin ve İleri'yi tıklayın.
  4. Nasıl transfer etmek istersiniz?'in altında Otomatik olarak internet üzerinden (önerilen)'i seçin.
  5. İletişim Bilgisi altında bir email iletişim adresi belirtin.
  6. İleri'ye tıklayın. Lisans transferi başarıyla tamamlanır.
Üst konu başlığ: SolidNetWork License Manager'ı kullanarak Lisans Yönetimi


SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak

SolidNetWork Lisanslamayı konfigüre etmek, SolidNetWork License Manager'ı lisans yöneticisi bilgisayara kurmayı ve SolidWorks'ü istemci bilgisayarlara SolidNetWork Lisans seri numarası ile kurmayı içerir.

  • Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek
    SolidNetWork Lisans Yöneticisi birden çok lisans istemcisini destekler. Lisansları ağ üzerindeki istemcilere dağıtır.
  • Lisans İstemcisini Kurmak
    SolidWorks'ü SolidNetWork Lisans İstemci bilgisayarlara kurarken, seri numarası o bilgisayarı SolidNetWork Lisans İstemcisi olarak belirler.
  • SolidNetWork Lisans Yöneticilerini Lisans İstemcilerinden Önce Kurun
    SolidNetWork License Manager'ı, herhangi bir SolidNetWork lisans istemcisini kurmadan önce en az bir bilgisayara kurmalısınız.
  • Triad Lisans Yöneticisi Kurulumu
    Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Eğer lisansı yöneten bilgisayar kullanılamaz ise, diğer iki bilgisayardan biri görevi devralır.
  • SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak
    Eğer bilgisayarınız bir güvenlik duvarı kullanıyorsa, bağlantı noktalarını SolidNetWork Lisanslamasını destekleyecek şekilde ayarlamalısınız.
Üst konu başlığ: SolidNetWork License Manager'ı kullanarak Lisans Yönetimi


Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek

SolidNetWork Lisans Yöneticisi birden çok lisans istemcisini destekler. Lisansları ağ üzerindeki istemcilere dağıtır.

Eğer SolidNetWork License Manager'ın, lisans etkinleştirmesi için donanım kilidi kullanan önceki bir sürümünden yükseltiyorsanız, SolidNetWork License Manager'ın yeni sürümünü kurmadan önce donanom kilitlerini çıkartın.

  1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
    1. Kurulum tipi için şunu seçin:

      • Sunucu ürünleri
      • SolidNetWork License Manager'ı (dağıtılmış lisanslama) bu bilgisayara kurun.

    2. SolidNetWork License Manager Seçenekleri sayfasında, SolidNetWork lisans seri numarasını ve SolidNetWork License Manager kurulum konumunu belirtin.
    3. Özet sayfasında, Şimdi Kur'u tıklayarak SolidWorks Kurulum Yöneticisi sürecini tamamlayın.
  2. SolidNetWork Lisanslarını etkinleştirmek için:
    1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Etkinleştirmek için Evet'e tıklayın.
    3. SolidNetWork Lisans Sunucusu Bilgisi ekranında:

      • Şirketiniz bir güvenlik duvarı kullanıyorsa Bu sunucu üstünde bir güvenlik duvarı kullanılıyor'u seçin.

        Daha fazla bilgi için, bkz. SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak.

      • Bağlantı Noktası Numarası için (ve güvenlik duvarınız varsa Vendor Daemon Port Numarası için) varsayılan değeri kullanın veya şirketinizin bağlantı numaralarını belirtin.
        Bağlantı noktası numarası, 1024-60000 aralığında, yalnızca bu iş için kullanılan bir TCP/IP bağlantı noktası numarasıdır. Normalde varsayılan (25734) uygundur ve başka bir FLEXnet sunucu süreci ile aynı olma ihtimali düşüktür.

    4. SolidWorks ürününüzü Etkinleştirin ekranında:

      • İnternet veya email sürecini seçin.
      • Email iletişim bilgisi sağlayın.
      • İleri'ye tıklayarak devam edin.
        • Internet: Etkinleştirme otomatik olarak gerçekleşir.
        • Email: İstek dosyası oluşturmak için Kaydet'i tıklayın ve dosyayı activation@solidworks.com adresine yollayın. Yanıt dosyasını içeren e-mail'i aldığınızda, dosyayı e-mailden çıkartıp yüklemek için Aç'ı tıklayın.
          Eğer gerekirse, etkinleştirme sürecinden çıkıp, yanıt dosyasını açmak için yeniden başlatabilirsiniz.

  3. Bitir'e tıklayın.
Üst konu başlığ: SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak


Lisans İstemcisini Kurmak

SolidWorks'ü SolidNetWork Lisans İstemci bilgisayarlara kurarken, seri numarası o bilgisayarı SolidNetWork Lisans İstemcisi olarak belirler.

  1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
  2. Eğer bu bilgisayara bu büyük sürümün ilk kurulumu ise karşılama ekranında, Bireysel (bu bilgisayarda)'i tıklayın

    Eğer varolan bir sürümü yükseltiyorsanız ve bireysel lisanstan SolidNetWork lisansına geçiyorsanız, Bireysel kurulumu değiştir (bu bilgisayarda).'i tıklayın. Ayrıntılar için bkz. Bireysel Lisanstan SolidNetWork Lisansına Geçiş.

  3. Seri numaraları istendiğinde SolidNetWork Lisannsı seri numaralarını girin.
  4. Sunucu Ekle iletişim kutusunda, SolidNetWork License Manager'ın adresini şu şekilde girin:

    port@ComputerName

    Bağlantı noktası numarası lisans yöneticisi bilgisayarda kullanılanın aynısı olmalı. Varsayılan 25734 (Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek tanımlandığı gibi).

    SolidWorks Kurulum Yöneticisi, SolidNetWork License Manager'ın erişilebilirliğini doğrulamaya çalışacak. Eğer hala daha SolidNetWork License Manager'ı belirttiğiniz bilgisayara kurmadıysanız bu doğrulama başarısız olur, ama yinede kuruluma devam edebilirsiniz.

  5. SolidWorks Kurulum Yöneticisindeki talimatları takip ederek Kurulumu tamamlayın.
Üst konu başlığ: SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak


SolidNetWork Lisans Yöneticilerini Lisans İstemcilerinden Önce Kurun

SolidNetWork License Manager'ı, herhangi bir SolidNetWork lisans istemcisini kurmadan önce en az bir bilgisayara kurmalısınız.

SolidNetWork Lisans seri numarası ile kurarken, SolidWorks Kurulum Yöneticisi SolidNetWork License Manager bilgisayar adı ve bağlantı noktası numarasını girmenizi ister, ve o bilgiyi doğrulamaya çalışır.

Eğer hala daha SolidNetWork License Manager'ı belirttiğiniz bilgisayara kurmadıysanız bu doğrulama başarısız olur. Fakat, bu durumda doğrulama başarısızlığı doğru lisans yöneticisi bilgisi girip girmediğinizi belirtmez. Eğer lisans yöneticisi kurulu ise doğrulama başarıslıkları hatalı lisans yöneticisi bilgisini gösterir.

Üst konu başlığ: SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak


Triad Lisans Yöneticisi Kurulumu

Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Eğer lisansı yöneten bilgisayar kullanılamaz ise, diğer iki bilgisayardan biri görevi devralır.

Triad lisans yöneticisi kullanmanın gereksinimleri:
  • Üç donanım kilidi gereklidir.
  • Triad lisans yöneticileri sık sık kapatılmayacak bilgisayarlara kurulmalıdır.
  • Üç lisans yöneticisi bilgisayar aynı alt ağda olmalıdır. Triad lisans yöneticileri yavaş iletişim veya çevirmeli ağ bağlantıları ile konfigüre edilmemelidir.
  • Sistem yöneticisi bir lisans yöneticisi bilgisayar kapandığında bunu en kısa zamanda farkederek yeniden başlatmalı.
    Eğer sadece iki lisans yöneticisi bilgisayar çalışıyorsa, durum tek bir lisans bilgisayarının çalışmasından daha kötüdür, çünkü iki farklı hata noktası bulunur.
  • İlk Triad Lisans Yöneticisini Kurmak
    Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Bu süreç SolidNetWork License Manager'ı triaddaki ilk bilgisayara nasıl kuracağınızı gösterir.
  • Triad Lisans Yöneticisini Sonraki Bilgisayarlara Kurmak
    Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Bu süreç SolidNetWork License Manager'ı triaddaki iki ve üçüncü bilgisayara nasıl kuracağınızı gösterir.
Üst konu başlığ: SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak


İlk Triad Lisans Yöneticisini Kurmak

Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Bu süreç SolidNetWork License Manager'ı triaddaki ilk bilgisayara nasıl kuracağınızı gösterir.

  1. İlk triad lisans yöneticisi bilgisayarında, SolidNetWork License Manager'ı SolidWorks Kurulum Yöneticisini kullarak kurun:
    1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
    2. Kurulum tipi için şunu seçin:

      • Sunucu ürünleri
      • SolidNetWork License Manager'ı (dağıtılmış lisanslama) bu bilgisayara kurun.

    3. SolidNetWork License Manager Seçenekleri sayfasında, SolidNetWork lisans seri numarasını ve SolidNetWork License Manager kurulum konumunu belirtin.
    4. Özet sayfasında, Şimdi Kur'u tıklayarak SolidWorks Kurulum Yöneticisi sürecini tamamlayın.
  2. SolidNetWork License Manager'ı kullanarak ilk triad lisans yöneticisi bilgisayarı yapılandırın:
    1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Hayır'ı tıklayın.

      SolidNetWork License Manager'ın Sunucu Yönetimi sekmesi görünür.

    3. Gelişmiş Seçenekler'den Seçenekler'i tıklayın.

      Gelişmiş Seçenekler iletişim kutusu görüntülenir.

    4. SolidNetWork Server License Mode altında Bir lisans dosyası kullan'ı tıklayın ve Tamam'ı tıklayın.

      Gelişmiş Seçenekler iletişim kutusu kapanır.

    5. Lisans Bilgisi altında, Değiştir'i tıklayın.

      SolidNetWork Lisans Dosya Sihirbazı açılır.

    6. Sunucu Tipi altında Triad'ı seçip İleri'ye tıklayın.
    7. Sunucu Bilgi Panosunda, ilk triad lisans yöneticisi bilgisayarı için bilgisayar adı, donanım kilidi kimliği, ve bağlantı noktası numarasının doğru olduğunu doğrulayın ve Sonraki'ni tıklayın

      Eğer bilgisayarınız bir güvenlik duvarı kullanıyorsa, bu ekranda ek belirtmeler yapmanız gerekebilir. Daha fazla bilgi için, bkz. SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak.

    8. Triad Ortağı Sunucu Bilgi ekranında, diğer iki triad lisans yöneticisi bilgisayarlar için bilgisayar adı, donanım kilidi kimliği değerlerini girin.

      Bu, bir lisans yöneticisi kullanılamaz olduğunda, diğer sunucuların kulanılabilir olmasını sağlar.

    9. Lisanslar ekranında, Oku'yu tıklayarak SolidNetWork lisans dosyasını açın.

      LisanslarSolidNetWork Lisans Dosyası sihirbazında görünür.

    10. Bitir'e tıklayın.
    11. SolidNetWork Lisans Dosyası sihirbazından çıkmak için Tamam'ı sonrada SolidNetWork License Manager'dan çıkmak için Bitir'i tıklayın.
Üst konu başlığ: Triad Lisans Yöneticisi Kurulumu


Triad Lisans Yöneticisini Sonraki Bilgisayarlara Kurmak

Triad lisans yöneticileri ek stabilite için üç bilgisayar kullanır. Bu süreç SolidNetWork License Manager'ı triaddaki iki ve üçüncü bilgisayara nasıl kuracağınızı gösterir.

Zaten en az bir triad lisans yöneticisini başka bir bilgisayara kurduğunuz varsayılır. Ayrıntılar için bkz. İlk Triad Lisans Yöneticisini Kurmak.

  1. Triad lisans yöneticisi bilgisayarında, SolidNetWork License Manager'ı SolidWorks Kurulum Yöneticisini kullarak kurun:
    1. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
    2. Kurulum tipi için şunu seçin:

      • Sunucu ürünleri
      • SolidNetWork License Manager'ı (dağıtılmış lisanslama) bu bilgisayara kurun.

    3. SolidNetWork License Manager Seçenekleri sayfasında, SolidNetWork lisans seri numarasını ve SolidNetWork License Manager kurulum konumunu belirtin.
    4. Özet sayfasında, Şimdi Kur'u tıklayarak SolidWorks Kurulum Yöneticisi sürecini tamamlayın.
  2. SolidNetWork License Manager'ı kullanarak triad lisans yöneticisi bilgisayarı yapılandırın:
    1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager.

      Bu, SolidNetWork License Manager'ı bu bilgisayarda ilk kullanımınız olduğu için şimdi etkinleştirmek isteyip istemediğiniz sorulur.

    2. Hayır'ı tıklayın.

      SolidNetWork License Manager'ın Sunucu Yönetimi sekmesi görünür.

    3. Gelişmiş Seçenekler'den Seçenekler'i tıklayın.

      Gelişmiş Seçenekler iletişim kutusu görüntülenir.

    4. SolidNetWork Server License Mode altında Bir lisans dosyası kullan'ı tıklayın ve Tamam'ı tıklayın.

      Gelişmiş Seçenekler iletişim kutusu kapanır.

    5. Lisans Bilgisi altında, Değiştir'i tıklayın.

      SolidNetWork Lisans Dosya Sihirbazı açılır.

    6. Sunucu Tipi altında Triad'ı ve Sunucu/lisans bilgilerini senkronize et'i seçip İleri'ye tıklayın.
    7. Sunucu Bilgi Panosunda, bu triad lisans yöneticisi bilgisayarı için bilgisayar adı, donanım kilidi kimliği, ve bağlantı noktası numarasının doğru olduğunu doğrulayın ve Sonraki'ni tıklayın

      Eğer bilgisayarınız bir güvenlik duvarı kullanıyorsa, bu ekranda ek belirtmeler yapmanız gerekebilir. Daha fazla bilgi için, bkz. SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak.

    8. Triad Ortağı Sunucu Bilgi ekranında, diğer iki triad lisans yöneticisi bilgisayarlar için bilgisayar adı, donanım kilidi kimliği değerlerini girin.

      Bu, bir lisans yöneticisi kullanılamaz olduğunda, diğer sunucuların kulanılabilir olmasını sağlar.

    9. Lisanslar ekranında, Oku'yu tıklayarak SolidNetWork lisans dosyasını açın.

      Lisans dosyaları tipik olarak ilk triad lisans yöneticisi bilgisayarda \licenses\sw_d.lic konumunda bulunur.

      LisanslarSolidNetWork Lisans Dosyası sihirbazında görünür.

    10. Bitir'e tıklayın.

      Bir SolidNetWork Lisans Dosya Sihirbazı uyarısı açılır.

    11. SolidNetWork Lisans Dosyası sihirbazından çıkmak için Tamam'ı sonrada SolidNetWork License Manager'dan çıkmak için Bitir'i tıklayın.

Eğer ikinci triad lisans yöneticisi bilgisayarı biçimlendiriyorsanız, aynı süreci üçüncü triad lisans yöneticisi bilgisayarı için tekrarlayın.

Üst konu başlığ: Triad Lisans Yöneticisi Kurulumu


SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak

Eğer bilgisayarınız bir güvenlik duvarı kullanıyorsa, bağlantı noktalarını SolidNetWork Lisanslamasını destekleyecek şekilde ayarlamalısınız.

Güvenlik Duvarı yazılımında, güvenlik duvarı istisnaları listesine iki adet SolidNetWork Lisans bağlantı noktası eklemelisiniz (örneğin, SNL-in-port ve SNL-out-port). nu bağlantı noktalarını biçimlendirmek konusunda detaylar için sistem yöneticinize danışın.

Eğer Windows XP SP2 ve Windows Server 2003 SP1 üzerinde Windows Firewall'u kullanıyorsanız bağlantı noktalarını SolidNetWork lisans yöneticisi bilgisayarında değiştirimeli ve SolidNetWork lisans dosyasını lisansları bu lisans istemci bilgisayarla dağıtacak şekilde değiştirmelisiniz.

  • Lisans Yöneticisi Bilgisayar Bağlantı Noktalarını Windows Güvenlik Duvarı için Değiştirmek
    Eğer Windows Güvenlik Duvarı kullanıyorsanız, güvenlik duvarı bağlantı noktası ayarlarını SolidNetWork lisans yöneticisi bilgisayarda değiştirmelisiniz.
  • SolidNetWork License Manager Ayarlarını Windows Güvenlik Duvarı için Değiştirmek
    Eğer Windows Güvenlik Duvarı kullanıyorsanız, SolidNetWork lisans dosyasını güvenlik duvarı bağlantı noktalarını kullanarak lisansları istemcilere dağıtacak şekilde değiştirmelisiniz.
Üst konu başlığ: SolidNetWork Lisanslamayı Kurmak ve Konfigürasyonunu Yapmak


Lisans Yöneticisi Bilgisayar Bağlantı Noktalarını Windows Güvenlik Duvarı için Değiştirmek

Eğer Windows Güvenlik Duvarı kullanıyorsanız, güvenlik duvarı bağlantı noktası ayarlarını SolidNetWork lisans yöneticisi bilgisayarda değiştirmelisiniz.

  1. Windows'da, Denetim Masasını açıp Güvenlik Merkezi'ni çift tıklayın.
  2. Windows Güvenlik Duvarı'na tıklayın.
  3. İstisnalar sekmesinde, Bağlantı Noktası Ekle'yi tuklayın.
  4. Bir İsim girin (örneğin, SNL-in-port) ve bir Bağlantı Noktası Numarası (örneğin, 25734) girin ve sonra Tamam'ı tıklayın.
  5. İkinci bağlantı noktası için yine İstisnalar sekmesinde Bağlantı Noktası Ekle'yi tıklayın ve diğer bağlantı noktasının isim ve numarasını belirleyin (örneğin SNL-out-port ve 25735) ve sonra Tamam'ı tıklayın. Daha sonra SolidNetWork lisans dosyasını değiştirirken kullanacağınız için bağlantı noktası numarasını not edin.

    Eğer Workgroup PDM kullanıyorsanız Workgroup PDM bağlantı noktası numaralarını Windows Güvenlik Duvarında değiştirmelisiniz. Tipik olarak bu noktalar 20000 (VaultAdmin), 30000 (Data), 40000 (Request), ve 80 (Viewer)'dir.

  6. Windows Güvenlik Merkezi ve Denetim Masasını kapatın.
Üst konu başlığ: SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak


SolidNetWork License Manager Ayarlarını Windows Güvenlik Duvarı için Değiştirmek

Eğer Windows Güvenlik Duvarı kullanıyorsanız, SolidNetWork lisans dosyasını güvenlik duvarı bağlantı noktalarını kullanarak lisansları istemcilere dağıtacak şekilde değiştirmelisiniz.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. On the Sunucu Yönetimi sekmesinde, Lisans Sunucusu altında, Durdur'u tıklayın. (Sorulduğunda onaylamak için Evet'i ve lisans sunucusunu durdurmayı tamamlamak içinTamam'ı tıklayın.
  3. Lisans Bilgisi altında, Değiştir'i tıklayın.
  4. Sunucu Tipi altında ağınız için sunucu aranjmanını (Single veya Triad'ı) seçin ve İleri'ye tıklayın.
  5. Sunucu Bilgisi altında:
    1. Bu sunucu üstünde bir güvenlik duvarı kullanılıyor'u seçin.
    2. Bağlantı noktası numarası ve Vendor Daemon Bağlantı noktası numarası, windows Güvenlik Duvarı tarafından belirtilen Bağlantı noktası numaralarını içermeli (ayrıntılar için; Lisans Yöneticisi Bilgisayar Bağlantı Noktalarını Windows Güvenlik Duvarı için Değiştirmek).
    3. İleri'yi ve Bitir'i tıklayın.
  6. On the Sunucu Yönetimi sekmesinde, Lisans Sunucusu altında, Başlat'ı tıklayın.
  7. SolidNetWork License Manager'i kapatmak için Tamam'ı tıklayın.
Üst konu başlığ: SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak


SolidNetWork Lisans Yönetimi

Görevler, lisans yöneticisini başlatmayı, yükseltmeyi, kaldırmayı ve lisansları almayı, ödünç almayı ve geri vermeyi içerir.

  • SolidNetWork License Manager'ı Başlatmak
    SolidNetWork License Manager'ı windows Başlat menüsünden başlatabilirsiniz.
  • SolidNetWork License Manager'ı Yükseltmek
    SolidWorks'ün büyük sürümleri için lisans yöneticisini yükseltmek, eski lisans yöneticisini kaldırıp yeni birtanesini kurarak SolidNetWork lisansını yeniden etkinleştirmekten oluşur.
  • SolidNetWork Lisans Dosyalarını Silmek
    Eski ve tarihi geçmiş SolidNetWork lisans dosyalarını, yenilerine yükseltmeden önce silin.
  • İstemci Lisanslarını Almak
    Bir istemci SolidNetWork bağlantısını kesmek için, sistem yöneticisi lisansı durdurup havuza geri alabilir.
  • SolidNetWork Lisanslarını Ödünç Alma ve Geri Verme
    Yazılımı uzak bir konumdan kullanabilmek için bir SolidNetWork lisansı ödünç alabilirsiniz. Kullanılabilir lisanslar havuzundan çıkarıldığı için, ödünç alınan bir lisansın yeniden kullanılabilir olması için geri verilmesi gerekir.
  • Lisans Eylemsizlik Zamanını Gözlemlemek
    SolidWorks eylemsizlik zamanını SolidNetWork License Manager ile kaydedebilir böylece belli bir süre kullanılmayan lisanslar otomatik olarak lisans havuzuna geri dönebilir.
  • Geçici Lisanslar Kuruluyor
    Geçici "HERHANGİ" lisans orijinal SolidNetWork lisansı kullanılamazgen geçici olarak kullanılabilir.
  • Bireysel Lisanstan SolidNetWork Lisansına Geçiş
    Bir bilgisayarı bireysel SolidWorks lisanslamasından SolidNetWork lisanslamasına, SolidNetWork lisans seri numarasını SolidWorks Kurulum Yöneticisinde belirterek yükseltebilirsiniz.
  • SolidNetWork Lisanslarını Eklenti Ürünler ile Kullanmak
    SolidWorks ana eklenti ürünlerinin (FeatureWorks, Workgroup PDM Server, vs. gibi) lisanslarını dağıtmak için SolidNetWork License Manager'ı kullanabilirsiniz.
  • Lisans Yöneticisi ve Yönetim Resmi Kurulumları için Aynı Bilgisayarı Kullanmak
    Ağ üzerinde bir bilgisayarı hem lisans yöneticisi hem de yönetim resmi konumu olarak ayarlayabilirsiniz.
  • FLEXnet Publisher Lisans Yönetimi
    SolidNetWork Lisanslaması FLEXnet Publisher® lisans yönetimine dayanır.
Üst konu başlığ: SolidNetWork License Manager'ı kullanarak Lisans Yönetimi


SolidNetWork License Manager'ı Başlatmak

SolidNetWork License Manager'ı windows Başlat menüsünden başlatabilirsiniz.

  • Windows'da bu komutu yürütün: Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager.
Üst konu başlığ: SolidNetWork Lisans Yönetimi


SolidNetWork License Manager'ı Yükseltmek

SolidWorks'ün büyük sürümleri için lisans yöneticisini yükseltmek, eski lisans yöneticisini kaldırıp yeni birtanesini kurarak SolidNetWork lisansını yeniden etkinleştirmekten oluşur.

Yeni bir sürümün lisans yöneticisi, bir önceki sürümde kalan istemciler için lisans dağıtmaya devam edebilir.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Lisans Kullanımı sekmesinde, ağ üzerindeki istemci bilgisayarlardan hiç birinin SolidWorks'ü çalıştırmadığından emin olun.
  3. Eski lisans yöneticisini kaldır. Ayrıntılar için bkz. SolidNetWork License Manager'ı Kaldırmak.
  4. Yeni lisans yöneticisini kurun ve SolidNetWorkk lisansını lisans yöneticisi bilgisayarında etkinleştirin. Ayrıntılar için bkz. Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek.

Eğer SolidNetWork License Manager'ı aynı zamanda SolidWorks'ü yürüten bir bilgisayara kuruyorsanız, o bilgisayara herhangi yeni SolidWorks uygulaması servis paketleri yüklemeden önce SolidNetWork lisans yöneticilerini ve istemcilerini yükseltin.

Eğer lisans yöneticisini yönetim resimleri içeren bir bilgisayarda yükseltiyorsanız, yönetim resimlerini yükseltmeden önce lisans yöneticisini yükseltin. Ayrıntılar için bkz. Lisans Yöneticisi ve Yönetim Resmi Kurulumları için Aynı Bilgisayarı Kullanmak.

  • SolidNetWork License Manager'ı Kaldırmak
    SolidNetWork License Manager'ı yükseltirken eski lisans yöneticisini kaldırıp yeni sürümü ondan sonra kurmalısınız.
Üst konu başlığ: SolidNetWork Lisans Yönetimi


SolidNetWork License Manager'ı Kaldırmak

SolidNetWork License Manager'ı yükseltirken eski lisans yöneticisini kaldırıp yeni sürümü ondan sonra kurmalısınız.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Ağ üzerindeki istemci bilgisayarlardan hiç birinin SolidWorks'ü çalıştırmadığından emin olun.

    Lisans Kullanımı sekmesi SolidWorks'ü kullanmakta olan istemcileri gösterir.

  3. SolidNetWork lisansını başka bir bilgisayara geçirmek istiyorsanız, SolidNetWork kurulumunu bu bilgisayardan kaldırmadan önce lisansı diğer bilgisayara geçirin.

    SolidNetWork lisanslarını transfer etmek hakkında daha fazla bilgi için, bakınız Bir SolidNetWork Lisansının Transferi.

  4. On the Sunucu Yönetimi sekmesinde, Lisans Sunucusu altında, Durdur'u tıklayın.
  5. Lisans yöneticisini kapatmak için Tamam'ı tıklayın.
  6. Windows'da Denetim Masası > Program Ekle veya Kaldır'ı tıklayın.
  7. SolidWorks SolidNetWork License Manage'i seçin ve Kaldır'ı tıklayın.
  8. Windows Explorer'da, SolidWorks SolidNetWork License Manager klasörünü silin.

    (tipik olarak Program Files altında SolidWorks kurulum dizininde olur.)

Şindi yeni lisans yöneticisi sürümünü kurmaya hazırsınız. Ayrıntılar için bkz. Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek.

Eğer SolidNetWork License Manager bilgisayarına takılı bir donanım kilidi varsa, SolidNetWork License Manager'ın yeni sürümünü kurmadan önce donanım kilitlerini çıkartın.
Üst konu başlığ: SolidNetWork License Manager'ı Yükseltmek


SolidNetWork Lisans Dosyalarını Silmek

Eski ve tarihi geçmiş SolidNetWork lisans dosyalarını, yenilerine yükseltmeden önce silin.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Sunucu Yönetimi sekmesinde, Lisans Dosyası altında, Değiştir'i tıklayın, sonra Lisanslar ekranına ulaşıncaya kadar Sonraki'ni tıklayın.
  3. Lisanslars ekranında, eski veya tarihi geçmiş SolidNetWork lisans dosyasını seçip Kaldır'ı tıklayın.
  4. Bitir'i ve Tamam'ı tıklayın.
Üst konu başlığ: SolidNetWork Lisans Yönetimi


İstemci Lisanslarını Almak

Bir istemci SolidNetWork bağlantısını kesmek için, sistem yöneticisi lisansı durdurup havuza geri alabilir.

  • İstemci lisans yöneticisine en az iki dakika bağlı olmuş olmalıdır.
  • SolidNetWork zaman aşımı özelliğini en az olan 15 dakikaya ayarlayabilirsiniz. 15 dakika eylemsizlikten sonra lisans havuza geri döner.

Detaylar için SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf'e bakınız.

  1. Başlat > Çalıştır'ı tıklayın, cmd yazın, ve Tamam'ı tıklayarak Windows Komut Penceresini açın.
  2. Komut penceresinde yazın:

    cd SolidNetWork_License_Manager_install_dir\utils lmutil lmremove feature user computer display

    feature, user, computer, ve display SolidNetWork License Manager kullanım sekmesinde gösterilen bilgilerdir..

    Örneğin:

    lmutil lmremove solidworks carlos designcmp1 corpserver

    Her eklenti ürün için (PhotoView 360, FeatureWorks, vs.) lisansı ayrı ayrı sonlandırmalısınız.

Üst konu başlığ: SolidNetWork Lisans Yönetimi


SolidNetWork Lisanslarını Ödünç Alma ve Geri Verme

Yazılımı uzak bir konumdan kullanabilmek için bir SolidNetWork lisansı ödünç alabilirsiniz. Kullanılabilir lisanslar havuzundan çıkarıldığı için, ödünç alınan bir lisansın yeniden kullanılabilir olması için geri verilmesi gerekir.

Ödünç alınan lisanslar yalnızca ödünç alındıkları sistemde geçerlidirler, transfer edilemezler.

Lisans, 30 güne kadar (veya sistem yöneticisi tarafından belirlenen şekilde) belirli bir zaman süresi için ödünç verilir, ve lisans kullanılabilir lisanslar havuzundan çıkartılır.

Sistem yöneticileri ödünç almayı özelleştirebilirler:
  • Lisanslar ödünç alabilecek kullanıcı veya grupları tanımlamak
  • Ödünç alınamayacak lisans sayılarını belirlemek

Detaylar için SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf'e bakınız.

  • SolidNetWork Lisanslarını Ödünç Almak
    Yazılımı uzak bir konumdan kullanabilmek için bir SolidNetWork lisansı ödünç alabilirsiniz.
  • Ödünç Alınmış bir SolidNetWork Lisansını Geri Vermek
    Ödünç alınan SolidNetWork lisansları havuzundan çıkarıldığı için, ödünç alınan bir lisansın yeniden kullanılabilir olması için geri verilmesi gerekir.
Üst konu başlığ: SolidNetWork Lisans Yönetimi


SolidNetWork Lisanslarını Ödünç Almak

Yazılımı uzak bir konumdan kullanabilmek için bir SolidNetWork lisansı ödünç alabilirsiniz.

Lisansı ödünç alabilmek için SolidNetWork lisans yöneticisine bağlı olmanız gerekir, ama kullanmak için gerekmez.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Lisans ödünç alma sekmesinde:
    1. Şu tarihe kadar ödünç al'de bir tarih seçin.
    2. Ödünç alınacak ürünleri seçin, sonra Ödünç Al'ı tıklayın, ve Evet'i tıklayarak doğrulayın.
    3. Yenile'ye tıklayın. Bitiş Tarihi sütunu ne zaman geri teslim etmeniz gerektiğini belirtir.
  3. Tamam'a tıklayın.
SolidWorks'ü yürütmek için bir SolidWorks lisansı ödünç almalısınız. SolidWorks Professional ve SolidWorks Premium yalnızca paket ile ilgili eklentileri etkinleştirir, ama SolidWorks'ü değil.
Üst konu başlığ: SolidNetWork Lisanslarını Ödünç Alma ve Geri Verme


Ödünç Alınmış bir SolidNetWork Lisansını Geri Vermek

Ödünç alınan SolidNetWork lisansları havuzundan çıkarıldığı için, ödünç alınan bir lisansın yeniden kullanılabilir olması için geri verilmesi gerekir.

  1. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Lisans ödünç alma sekmesinde:
    1. Geri verilecek ürünleri seçin, sonra Geri Ver'ı tıklayın, ve Evet'i tıklayarak doğrulayın.
    2. Yenile'ye tıklayın. Bitiş Tarihi sütunu boş olarak lisansların geri verildiğini belirtir.
  3. Tamam'a tıklayın.
Bitiş tarihinden sonra lisansları geri vermeye gerek olmaz. Lisans, SolidNetWork lisans yöneticisi havuzuna bitiş tarihinin gece yarısında geri döner.
Üst konu başlığ: SolidNetWork Lisanslarını Ödünç Alma ve Geri Verme


Lisans Eylemsizlik Zamanını Gözlemlemek

SolidWorks eylemsizlik zamanını SolidNetWork License Manager ile kaydedebilir böylece belli bir süre kullanılmayan lisanslar otomatik olarak lisans havuzuna geri dönebilir.

  1. SolidNetWork License Manager kurulum dizininde bir metin dosyası oluşturun:

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. Dosyaya şu satırı ekleyin:

    TIMEOUTALL seconds

    seconds 900'e (15 dakika) eşit veya daha büyük bir sayıdır, ki bu da izin verilen minimum seçenektir.

Üst konu başlığ: SolidNetWork Lisans Yönetimi


Geçici Lisanslar Kuruluyor

Geçici "HERHANGİ" lisans orijinal SolidNetWork lisansı kullanılamazgen geçici olarak kullanılabilir.

"HERHANGİ" lisans dosyasını kurarak Dassault Systèmes SolidWorks Corporation'dan SolidNetWork lisansını aldığınızda geleneksel lisansı uygulayacağınızı taahüt edersiniz. Lisans sınırlandırmalarına uyum hala gereklidir.

"HERHANGİ" lisansını kurmak için:

  1. Eğer zaten bir SolidNetWork kullanıcısıysanız SolidNetWork License Manager'ı kaldırın ve kurulum klasörünü silin. Ayrıntılar için bkz. SolidNetWork License Manager'ı Kaldırmak.
  2. SolidWorks Kurulum Yöneticisini başlatın(SolidWorks Kurulumunu Başlatmak gösterildiği gibi).
    1. Kurulum tipi için şunu seçin:

      • Sunucu ürünleri
      • SolidNetWork License Manager'ı (dağıtılmış lisanslama) bu bilgisayara kurun.

    2. SolidNetWork License Manager Seçenekleri sayfasında, SolidNetWork lisans seri numarasını ve SolidNetWork License Manager kurulum konumunu belirtin.
    3. Özet sayfasında, Şimdi Kur'u tıklayarak SolidWorks Kurulum Yöneticisi sürecini tamamlayın.
  3. SolidNetWork License Manager'ı başlat (Başlat > Programlar > SolidWorks version > SolidNetWork License Manager > SolidNetWork License Manager).
  4. Etkinleştirmeniz istenirse, Hayır'ı tıklayın.

    SolidNetWork License Manager'ın Sunucu Yönetimi sekmesi görünür.

  5. Gelişmiş Seçenekler'den Seçenekler'i tıklayın.

    Gelişmiş Seçenekler iletişim kutusu görüntülenir.

  6. SolidNetWork Server License Mode altında Bir lisans dosyası kullan'ı tıklayın ve Tamam'ı tıklayın.

    Gelişmiş Seçenekler iletişim kutusu kapanır.

  7. Lisans Bilgisi altında, Değiştir'i tıklayın.

    SolidNetWork Lisans Dosya Sihirbazı açılır.

  8. Sunucu Tipi altında Tek'ı seçip İleri'ye tıklayın.
  9. Bu mesajı gördüğünüzde:

    Donanım kilidi kimlik numarası okunamadı.
    İptal'i tıklayın.
    "HERHANGİ" kimliği otomatik olarak görünür.
    Eğer bilgisayarınız bir güvenlik duvarı kullanıyorsa, bu ekranda ek belirtmeler yapmanız gerekebilir. Daha fazla bilgi için, bkz. SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak.

  10. Kuruluma devam edin.
Üst konu başlığ: SolidNetWork Lisans Yönetimi


Bireysel Lisanstan SolidNetWork Lisansına Geçiş

Bir bilgisayarı bireysel SolidWorks lisanslamasından SolidNetWork lisanslamasına, SolidNetWork lisans seri numarasını SolidWorks Kurulum Yöneticisinde belirterek yükseltebilirsiniz.

Eğer bir bilgisayarda SolidWorks kurulu değilse, SolidNetWork lisanslamasını SolidNetWork seri numarasını SolidWorks Kurulum Yöneticisini kurarken girerek belirtebilirsiniz.

Eğer bir bilgisayarda SolidWorks zaten kurulu ise ve bireysel lisanstan SolidNetWork Lisanslamasına geçiyorsanız istemci bilgisayar için kurulumu değiştirebilrisiniz ve SolidNetWork lisans seri numarasını SolidWorks Kurulum Yöneticisinde bireysel seri numarası yerine belirtebilirsiniz. Ayrıntılar için bkz. Bir Kurulumu Değiştirmek.

Üst konu başlığ: SolidNetWork Lisans Yönetimi


SolidNetWork Lisanslarını Eklenti Ürünler ile Kullanmak

SolidWorks ana eklenti ürünlerinin (FeatureWorks, Workgroup PDM Server, vs. gibi) lisanslarını dağıtmak için SolidNetWork License Manager'ı kullanabilirsiniz.

  • SolidWorks lisansları ve SolidWorks eklenti lisanslarının eşit sayıda olmaları gerekmez.
  • Bir eklenti ürünü için lisansı teslim alabilmek için önce bir SolidWorks lisansını ödünç almalısınız.
  • Bir eklenti ürün lisansı almak için hem SolidWorks yazılım lisansını hem de eklentiyi içeren SolidWorks ürün lisansını almalısınız. Örneğin, ya SolidWorks Professional yada SolidWorks Premium ürün lisansını ödünç almalısınız.
  • Bir eklenti ürün lisansını teslim etmek için:
    • SolidWorks'de Araçlar > Eklentiler'i tıklayın ve eklentinin işaretini kaldırın.
    • SolidWorks'ten çıkın
Üst konu başlığ: SolidNetWork Lisans Yönetimi


Lisans Yöneticisi ve Yönetim Resmi Kurulumları için Aynı Bilgisayarı Kullanmak

Ağ üzerinde bir bilgisayarı hem lisans yöneticisi hem de yönetim resmi konumu olarak ayarlayabilirsiniz.

İstemci bilgisayarlar lisansı lisans yöneticisinden alıp sonra SolidWorks'ü aynı bilgisayardan kurabilirler.

Bu konfigürasyon, Lisans yöneticisi ve yönetim resminin aynı bilgisayara kurulu olmasını gerektirir.. Önce lisans yöneticisini kurun sonra yönetim resmini oluşturun ve dağıtın.
Ayrıntılar için bkz.:
  • Bir Lisans Yöneticisini Kurmak ve Etkinleştirmek
  • Birden Fazla İstemciye Dağıtım
Üst konu başlığ: SolidNetWork Lisans Yönetimi


FLEXnet Publisher Lisans Yönetimi

SolidNetWork Lisanslaması FLEXnet Publisher® lisans yönetimine dayanır.

FLEXnet Publisher lisans yönetimi hakkında daha fazla bilgi için, SolidNetWork Lisans Yöneticisi kurulum dizinindeki FLEXnet Publisher Lisans Yönetim Kılavuzu'na bakın (SolidNetwork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf).

FLEXnet Publisherlisans yönetimi hakkında en son bilgiler için, Acresso® Software ile temasa geçin.

Üst konu başlığ: SolidNetWork Lisans Yönetimi


Sorun Giderme

Kurulum sorunlarını gidermek için bu dosyalara başvurun.

  • SolidWorks Kurulum Yöneticisi Günlük Dosyaları
    SolidWorks Kurulum Yöneticisi günlük dosyaları kurulum sorunlarını gidermenizde yardımcı olmak için varlar.
  • SolidWorks Kurulum Yöneticisi İndirme Klasörü
    SolidWorks Kurulum Yöneticisi ihtiyacı olan dosyaları belirteceğiniz bir klasöre indirebilir. Bu başlık indirme klasörü hakkında sıkça sorulan sorulara cevaplar içerir.
  • SolidNetWork Lisanslarının Sorunlarını Giderme
    Eğer SolidNetWork License Manager kurulumu başarısız olursa bu açıklamalara göz atın.
  • Yükseltmelerin Sorunlarını Giderme
    Eğer SolidWorks sürümünü yükseltirkenbir sorun olursa bu açıklamalara göz atın.


SolidWorks Kurulum Yöneticisi Günlük Dosyaları

SolidWorks Kurulum Yöneticisi günlük dosyaları kurulum sorunlarını gidermenizde yardımcı olmak için varlar.

Bu günlük dosyaları diğer SolidWorks uygulama günlük dosyaları ile birlikte tutulurlar.
  • Windows Vista veya daha yenisi için:

    C:\Users\username\AppData\Roaming\SolidWorks\Installation Logs\installed_version

  • Vista öncesi Windows işletim sistemleri için:

    C:\Documents and Settings\username\Application Data\SolidWorks\Installation Logs\installed_version\

Bu günlük dizinlerini görmek için Windows Klasör Seçeneklerini Gizli dosya ve klasörleri göster olarak değiştirmeniz gerekebilir.

Eğer uygulama verisi C:'den başka bir konumda ise dizin yolunu buna göre değiştirin.

Bu dizin, SolidWorks Kurulum Yöneticisi süreci ile ilgili genel bir günlük dosyası olan, SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt dosyasını içerir.

Other Logs alt dizini daha detaylı kurulum günlüğü bilgileri içerir.

Üst konu başlığ: Sorun Giderme


SolidWorks Kurulum Yöneticisi İndirme Klasörü

SolidWorks Kurulum Yöneticisi ihtiyacı olan dosyaları belirteceğiniz bir klasöre indirebilir. Bu başlık indirme klasörü hakkında sıkça sorulan sorulara cevaplar içerir.

  1. Bu klasördeki dosyaları nasıl kurarım?
  2. MSI dosyalarını bu klasörden msiexec veya başka bir uygulama ile manüel olarak kurabilir miyim?
  3. Kurduğum her sürüm için aynı indirme klasörünü kullanabilirmiyim?
  4. Bazı dosyaları Dassault Systemes SolidWorks Corporation Web sitesinden manüel olarak indirdim. Kurulum Yöneticisi bunları kurabilir mi?
  5. İndirdiğim dosyalar başka kullanıcılar tarafından paylaşılabilir mi?
  6. SolidWorks ürünlerinin daha yeni bir sürümü çıktığını nasıl öğrenirim?
  7. Kurulum Yöneticisi yalnızca SW2006 veya SW2007 kurulumlarını gösteriyorü ama şimdiki sürümü göstermiyor.
  8. Kyrulum Yöneticisi kurmak için bir ürünün başka bir servis paketini seçmeme izin vermiyor.
  9. Kurulum Yöneticisi dosyaları indiremiyor.
  10. Tüm SolidWorks ürünlerim son servis paketine yükseltilmediler, ama Güncellemeleri Denetle bana en son sürüme sahip olduğumu söylüyor.
  11. Bir DVD'yi indirme klasörüne indirebilir miyim?

Bu klasördeki dosyaları nasıl kurarım?

setup.exe'yi yürütün. Daha önce indirilmemiş ürünleri seçerseniz bazı dosyaları indirmeniz gerekebilir.

msiexec'i kullanarak kurmayın.

Başa Dön

MSI dosyalarını bu klasörden msiexec veya başka bir uygulama ile manüel olarak kurabilir miyim?

Hayır. Kurulum Yöneticisi msiexec'i yürütürken gerekebilecek bazı dosyaları indirmez.

Başa Dön

Kurduğum her sürüm için aynı indirme klasörünü kullanabilirmiyim?

İndirme klasörleri sürüme bağlıdır. SolidWorks 2010 ile başlayarak, SolidWorks Kurulum Yöneticisi belirtilen klasörün içinde sürüme bağlı bir alt klasör oluşturur.

Başa Dön

Bazı dosyaları Dassault Systèmes SolidWorks Corporation Web sitesinden manüel olarak indirdim. Kurulum Yöneticisi bunları kurabilir mi?

SW2009 ile başlayarak, manüel olarak indirilen dosyalar Kurulum Yöneticisi tarafından kullanılabilir. Fakat, Kurulum Yöneticisini yürütüp dosyaların indirilmesi seçeneğini seçmek daha iyidir. Kurulum Yöneticisi hangi dosyaların gerektiğini göstererek her dosyayı indirmek için bağlantıları gösterir. Bu seçenek indirme sayfası çalışmadığı zaman (bir proxy sunucusu tarafından engellenmesi gibi sebeplerle) kullanılabilir.
Eğer Microsoft Internet Explorer dosyaları ne yapmak istediğinizi sorarsa her zaman kaydetmeyi seçin.

Başa Dön

İndirdiğim dosyalar başka kullanıcılar tarafından paylaşılabilir mi?

Evet. Bunun için paylaşılacak bir ağa indirin. Her istemci paylaşımdan Kurulum Yöneticisini çalıştırarak kurabilir.

İlk indirme anında indirilmemiş ürünler seçilmediği sürece ek indirmelere gerek olmaz.

Eğer başkaları adına indiriyo fakat kurmuyorsanız kurarken Yalnızca İndir seçeneğini seçin. Bu seçenek sisteminizde ne kurulu olduğuna bakmaksızın ürünleri seçmenize olanak verir. Fakat bu seçenek yama indirmek veya yönetim resmi oluşturmak için kullanılamaz.

Başa Dön

SolidWorks ürünlerinin daha yeni bir sürümü çıktığını nasıl öğrenirim?

Şu durumlarda yeni bir sürümden haberdar edilirsiniz:
  • Eğer güncelleme denetimini yürütürseniz ( Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle)
  • Eğer SolidWorks Arkaplan İndiricisini etkinleştirdiyseniz.
  • Eğer Windows Programları Ekle/Kaldır'da kurulu bir SolidWorks sürümü seçip Değiştir'i tıklarsanız
  • Bir indirme klasöründen Kurulum Yöneticisinin eski bir sürümünü çalıştırırsanız (sldIM.exe)
Bu durumlarda yeni sürümü indirmeyi seçebilirsiniz. SolidWorks Kurulum Yöneticisi kendisinin yeni sürümünü indirir ve çalıştırır. SolidWorks Kurulum yöneticisinin yeni sürümü inip çalıştıktan sonra bir dizi kurulum eylemini seçebilirsiniz. SolidWorks Kurulum Yöneticisi sonra hangi kurulum dosyalarının gerekip zaten indirilmemiş olduklarına karar verip bunları indirmeyi önerir.

Başa Dön

Kurulum Yöneticisi yalnızca SW2006 veya SW2007 kurulumlarını gösteriyor, ama şimdiki sürümü göstermiyor.

SolidWorks Kurulum Yöneticisinin geçerli sürüm tarafından artık desteklenmeyen eski bir sürümünü yürütüyorsunuz. Yalnızca SW2006 ve SW2007 için servis paketlerini indirebilir.

Başa Dön

SolidWorks Kyrulum Yöneticisi kurmak için bir ürünün başka bir servis paketini seçmeme izin vermiyor.

Bu tasarım gereğidir. Her SolidWorks Kurulum Yöneticisi belirli SolidWorks ürünlerini kuracak şekilde yapılmıştır. Eğer başka bir servis paketi kurmak istiyorsanız o sürümün SolidWorks Kurulum Yöneticisini çalıştırmalısınız. Kullanılabilir son sürümü bulmak için SolidWorks ürünlerinin daha yeni bir sürümü çıktığını nasıl öğrenirim?'e bakın

Başa Dön

SolidWorks Kurulum Yöneticisi dosyaları indiremiyor.

Eğer proxy sunucusu sınırlandırmaları uygulamaların dosya indirmelerini engelliyorse SolidWorks Kurulum Yöneticisi otomatik olarak dosyaları indiremez.

Dosyaları el ile indirip sonra SolidWorks Kurulum Yöneticisi ile kurabilirsiniz. SolidWorks Kurulum yöneticisinde dosyaları tek tek indirmeyi seçin (örneğin İndirme Seçenekleri sayfasında El ile indirme gerçekleştirin). Ürün seçimlerinize bağlı olarak ayrı bir pencerede indirilecek dosyalara bağlantıları içeren bir sayfa açılacak. Bu bağlantılar SolidWorks Kullanıcı Portalındakiler ile birörnektirler.

Başa Dön

Tüm SolidWorks ürünlerim son servis paketine yükseltilmediler, ama Güncellemeleri Denetle bana en son sürüme sahip olduğumu söylüyor.

Güncelleme Denetimi sadece SolidWorks Kurulum Yöneticisinin son sürümünü çalıştırmakta olup olmadığınızı söyler.

Tüm ürünleri son sürüme güncellemek istiyorsanız Programları Ekle/Kaldır'da son SolidWorks sürümünü seçip Değiştir'i tıklayın.

Başa Dön

Bir DVD'yi indirme klasörüne indirebilir miyim?

Evet, ama o platform için (x86 veya x64) dağıtılmış her DVD'nin tüm içeriğini kopyalamazsanız kurulumda sorun olabilir. SolidWorks Kurulum Yöneticisi sürümü belirlemek için swdata*.id dosyasına bakar. Eğer bu dosyalar yoksa kurulum dosyalarını tanımaz ve indirilmelerini gerektirir.

Başa Dön

Üst konu başlığ: Sorun Giderme


SolidNetWork Lisanslarının Sorunlarını Giderme

Eğer SolidNetWork License Manager kurulumu başarısız olursa bu açıklamalara göz atın.

  • SolidNetWork Lisans Günlük Dosyaları
    Bir lisans sorunu olduğunda çözümü genellikle SNL_Manager_install_dir\lmgrd.log dosyasında bulunabilir.
  • SolidWorks için bir lisans sağlanamadı. Lisans sunucusuna bağlanılamıyor.
    Tipik olarak bu sorun bağlantı noktası ayarlarından kaynaklanır.
Üst konu başlığ: Sorun Giderme


SolidNetWork Lisans Günlük Dosyaları

Bir lisans sorunu olduğunda çözümü genellikle SNL_Manager_install_dir\lmgrd.log dosyasında bulunabilir.

Üst konu başlığ: SolidNetWork Lisanslarının Sorunlarını Giderme


SolidWorks için bir lisans sağlanamadı. Lisans sunucusuna bağlanılamıyor.

Tipik olarak bu sorun bağlantı noktası ayarlarından kaynaklanır.

  • SolidNetWork lisans yöneticisi ve lisans istemcisi arasındaki bağlantı noktaları eşleşmeyebilir.
  • SolidNetWork lisans yöneticilerinin değişik sürümleri için ek bağlantı noktası ayarları belirtilmemiş olabilir.
SolidNetWork lisans yöneticisi ve istemcileri için bağlantı noktası ayarları hakkında detaylar için SolidNetWork Lisanslarını Güvenlik Duvarları ile Kullanmak.
Üst konu başlığ: SolidNetWork Lisanslarının Sorunlarını Giderme


Yükseltmelerin Sorunlarını Giderme

Eğer SolidWorks sürümünü yükseltirkenbir sorun olursa bu açıklamalara göz atın.

  • Taşınmış bir Kaynaktan Yükseltmek
    SolidWorks kurulduğunda, SolidWorks Kurulum Yöneticisi kurulum kaynaklarının konumunu hatırlar (disk medya, ağ üzerinde disk resmi, vs.). Güncelleme sırasında kaynakların aynı konumda olmasını bekler.
Üst konu başlığ: Sorun Giderme


Taşınmış bir Kaynaktan Yükseltmek

SolidWorks kurulduğunda, SolidWorks Kurulum Yöneticisi kurulum kaynaklarının konumunu hatırlar (disk medya, ağ üzerinde disk resmi, vs.). Güncelleme sırasında kaynakların aynı konumda olmasını bekler.

Eğer kaynak taşınır veya silinir ise, veya kaynak medyası değişir ise, SolidWorks Kurulum Yöneticisi bir hata mesajı verir. Fakat, aynı dosya ve klasör yapısını koruması şartıyla başka bir konuma gözatarak kuruluma devam edebilirsiniz.

Üst konu başlığ: Yükseltmelerin Sorunlarını Giderme


SolidWorks Kurulum Yöneticisi Uygulaması Yardımı

SolidWorks Kurulum Yöneticisi, SolidWorks ürünlerini kuran ve güncelleyen, kendi başına duran bir uygulamadır.

SolidWorks Kurulum Yöneticisisini şu şekilde yürütebilirsiniz:
  • Bir SolidWorks DVD'sinden veya paylaşılan bir kaynak klasöründen (yeni bir sürüm kurarken).
  • Denetim Masasından Program Ekle veya Kaldır sayfasından (varolan bir SolidWorks kurukumunu değiştirirken yada kaldırırken).
  • Zamanlanmış yada manüel bir güncelleme denetiminden (yeni sürüm versiyonlarını algılar, indirir ve kurarken).

SolidWorks'ün her büyük sürümü, O sürüme özel bir Kurulum Yöneticisine sahiptir.

SolidWorks 2008 öncesi sürümler için SolidWorks 2007 Kurulum Yöneticisini kullanın veya ürün sürümlerini el ile SolidWorks Destek web sitesinden indirin.
  • SolidWorks Arkaplan İndiricisi
    SolidWorks Arkaplan İndiricisi, arkaplan süreçlerini kullanarak otomatik dosya indirmeleri (örneğin yeni bir Servis Paketi sürümü bulunduğunda) gerçekleştirir, ve böylece indirme sırasında başka işler yapabilmenize olanak tanır. İndirme tamamlandığında, şimdi mi kurmak, indirmeyi mi ertelemek yada indirimi mi kaldırmak istediğiniz sorulur.
  • Güncellemeleri Denetle Sonuçları
    Güncellemeleri Denetle, SolidWorks'ün ileriki sürümlerini denetler.
  • Yönetim resmi Konumu
    Yönetim resmi kurulumunun konumunu belirleyin.
  • İndirme Seçenekleri
    İndirme işlemini tamamlamak için indirilen dosyaların konumu, dosyaların nasıl indirileceği, ve indirilen dosyaların kurulması gibi detayları belirtin.
  • SolidWorks Kurulum Yöneticisi Dosyaları İçin İndirme Seçenekleri
    SolidWorks Kurulum Yöneticisinin daha ileri bir sürümünü indirmeye karar verdiniz. Nasıl ve nereye indirildiğini belirlemek için bu ekranı kullanın.
  • Ürün Kurulum Dosyalarını İndirmek
    Belirtilen ürün için eksik dosyaların nereye ve nasıl indirileceğini belirtin.
  • İndirme İlerlemesi
    SolidWorks Kurulum Yöneticisi bu süreç boyunca tüm dosyaları pararlel süreçlerle indirir, doğrular ve ayıklar.
  • İndirme Sonuçları
    İndirmenin başarıyla mı tamamlandığını, işlem sırasında başarısız mı olduğu yoksa iptal mi edildiğini gösterir.
  • Kurulum Hataları/Kurulum İptal Oldu
    Kurulum bir hata ile karşılaştı veya iptal edildi.
  • Kurulum Tamamlandı
    SolidWorks Kurulum Yöneticisi işlemesini tamamlamıştır.
  • Kurulum konumu
    SolidWorks kurulum konumlarını belirleyin.
  • Yükseltme Seçenekleri
    Bir yada daha çok eski büyük SolidWorks sürümü şu anda bu bilgisayara kuruludur. Varolan en son sürümü, yeni sürüme yükseltmeyi veya yeni sürüm için yeni bir kurulum oluşturmayı seçin.
  • Kurulum İlerlemesi:
    Bu ekran kurulumun ilerlemesini gösterir.
  • Kurulum Tipi
    Yürütmek istediğiniz kuruşum işlemini, örneğin yeni kurulum oluşturmak, varolan kurulumu değiştirmek veya onarmak, bir yönetim resmi oluşturmak, yönetim sunucu ürünlerini kurmak, veya kurmadan dosyaları indirmek gibi, seçin.
  • Birden Çok Bilgisayarı Kurmak ve Yönetmek
    SolidWork Kurulum Yöneticisi birden çok bilgisayara kurmak ve yönetmek için şu araçları sağlar.
  • Manüel İndirme
    Dosyaları el ile indirmeyi seçtiniz (veya SolidWorks Kurulum Yöneticisini son çalıştırdığınızda dosyaları el ile indirmeyi seçmişsiniz).
  • Daha Yeni Bir Sürüm Var
    SolidWorks Kurulum Yöneticisi SolidWorks ürünlerinin yeni bir sürümünü buldu. Orijinal kurulum DVD veya indirmesindeki sürümü kurmayı seçebilir, veya yeni sürümü indirip kurabilirsiniz.
  • Daha Yeni Sürümler Yok
    indirmek için daha yeni bir sürüm yok. Belirtilen sürümü kurmaya devam edin.
  • Süreçler Algılandı
    SolidWorks Kurulum Yöneticisi başarılı bir kurulumu engelleyebilecek süreçler algıladı.
  • Ürün Seçimi
    Kurulacak, değiştirilecek, indirilecek veya kaldırılacak ürün bileşenlerini belirtin.
  • İndirilecek Ürünler
    Belli bir konuma indirmek için SolidWorks ürünlerini seçin.
  • Onarılacak Ürünler
    Bu kurulumu onar'ı seçerseniz ekran, bu SolidWorks kurulum yöneticisi tarafından onarılabilecek ürünleri gösterir.
  • Seri Numaraları
    Dağıtım kutusunda bulunan seri numaraları bilgisayarınızı satın aldığınız SolidWorks ürünleri ile ilişkilendirir.
  • Sunucu Kurulumu
    Kurmaya çalıştığınız sunucu ürünleri, kurulum sonuçları ile listelenir.
  • SolidNetWork License Manager
    SolidNetWork License Manager sunucusu ürünü için kurulum seçeneklerini belirtin.
  • Özet
    SolidWorks Kurulum Yöneticisi, kurulumu tamamlamak için tüm bilgilere sahiptir.
  • Sistem Kontrolü Uyarıları
    Sistem Kontrolü kuruluma nasıl devam edeceğinizi etkileyebilecek durumları rapor eder. Çoğu durumda, SolidWorks Kurulum Yöneticisi ile devam edebilmelisiniz.
  • Delik Sihirbazı/Toolbox Seçenekleri
    Eğer SolidWorks Toolbox kurulursa, SolidWorks delik tipleri ve donanımın standart bir kitaplığını ekler.
  • Ürünleri Kaldırmak
    KControl Paneli'nden Kaldır or Kurulumu Kaldır'ı seçerseniz ekran, bu SolidWorks kurulum yöneticisi tarafından kaldırılabilecek ürünleri gösterir. Standart, Özel veya Tam kaldırma gerçekleştirebilirsiniz.
  • Workgroup PDM Sunucu Seçenekleri
    SolidWorks Workgroup PDM sunucusu ürünü için kurulum seçeneklerini belirtin.


SolidWorks Arkaplan İndiricisi

SolidWorks Arkaplan İndiricisi, arkaplan süreçlerini kullanarak otomatik dosya indirmeleri (örneğin yeni bir Servis Paketi sürümü bulunduğunda) gerçekleştirir, ve böylece indirme sırasında başka işler yapabilmenize olanak tanır. İndirme tamamlandığında, şimdi mi kurmak, indirmeyi mi ertelemek yada indirimi mi kaldırmak istediğiniz sorulur.

SolidWorks Arkaplan İndiricisi, SolidWorks'ü SolidWorks Kurulum Yöneticisi kullanarak kurduğunuzda otomatik olarak etkinleştirilir.

SolidWorks Kurulum Yöneticisi yürütülürken SolidWorks Arkaplan İndiricisi duraklatılır. Örneğin, tüm yürütülen indirmeleri duraklatır, yeni indirmelerin başlamasına izin vermez, ve indirme klasörü spesifikasyonunu değiştirmenizi engeller.

SolidWorks Arkaplan İndiricisi, SolidWorks'ü kurduğunuzda otomatik olarak etkinleştirilir. SolidWorks Arkaplan İndiricisini , SolidWorks kurulumu sırasında, Özet sayfasında İndirme Seçeneklerini değiştirerel devre dışı bırakabilirsiniz. (Arkaplan İndiricisini kullanmak ister misiniz? seçeneğinin işaretini kaldırın.)

Etkinleştirildiğinde, bu simge araç çubuğundaki Windows sistem tepsisinde görünür:

Bu simgeyi tıklamak şu işlemlere olanak tanır:
  • Arkaplan İndiricisi Yardımı
  • İndirmeyi Duraklat
  • İndirmeye Devam Et
  • İndirmeyi iptal et
  • Kurulum Seçenekleri
  • İndirme Konumunu Değiştir
  • Güncellemeleri Denetle
  • Güncellemeleri Otomatik Denetle
  • Güncellemeleri Otomatik İndir
  • Arkaplan İndiricisini Devre dışı bırak

Arkaplan İndiricisi Yardımı

Arkaplan İndiricisi için bu yardım başlığını SolidWorks Kurulum Kılavuzu'nda açın.

İndirmeyi Duraklat/Devam Et

Eğer bir indirme arkaplanda çalışıyorsa, İndirmeyi Duraklat'ı tıklayarak indirmeyi duraklatın, ve sonra İndirmeye Devam Et'e tıklayarak devam edin.

İndirmeyi iptal et

Eğer bir indirme yürütülüyorsa o indirmeyi durdurup zaten indirilmiş olan tüm dosyaları silin.
İptal edilmiş bir indirmeye sonra devam edemezsiniz.

Kurulum Seçenekleri

Bir indirme tamamlandığında, şu seçeneklerden birini seçebilirsiniz:
  • Şimdi Kur: İndirilmiş dosyaları kur.
  • Daha sonra hatırlat: İndirilmiş dosyaları kurma, ama daha sonra hatırlatmak için bir mesaj ayarla.
  • Bu indirmeyi sil: İndirilmiş dosyaları kurma ve sil. (Bu, indirilmiş dosyaları kurmak istemediğinize karar verdiğinizde faydalıdır.)

İndirme Konumunu Değiştir

Arkaplan İndiricisinin dosyaları indirdiği konumu değiştirirn.

Bu seçenek eğer bir indirme sürüyor veya duraklatılmış ise kullanılamaz.

Güncellemeleri Denetle

SolidWorks Kurulum Yöneticxisinin Güncellemeleri Denetle özelliğini çalıştırır.

Güncellemeleri Otomatik Denetle

Güncellemeleri Denetle'yi periyodik olarak yürüterek yeni güncellemeler algılanınca haber verir.

Güncellemeleri Otomatik İndir

Güncellemeleri Denetle'yi periyodik olarak yürüterek yeni güncellemeler algılanınca indirir.

SolidWorks Arkaplan İndiricisini Devre Dışı Bırakmak ve Yeniden Etkinleştirmek

Arkaplan İndiricisini, simgeyi tıklayıp Arkaplan İndirmesini Devre Dışı Bırak'ı seçerek devre dışı bırakabilirsiniz.

Arkaplan İndiricisini yeniden etkinleştirmek için, Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > SolidWorks Arkaplan İndiricisi'ni seçin.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Güncellemeleri Denetle Sonuçları

Güncellemeleri Denetle, SolidWorks'ün ileriki sürümlerini denetler.

Güncelleme denetimini manüel olarak başlatabilirsiniz:
  • Windows'da, Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.
  • SolidWorks'de, Yardım > Güncellemeleri Denetle'yi tıklayın.
Güncelleme denetimi, yönetim resmi ile kurulmuş istemcilerde bulunmaz.

Daha Yeni Bir Sürüm Var

SolidWorks Kurulum Yöneticisi SolidWorks ürünlerinin yeni bir sürümünü buldu. O sürüme özel bir Kurulum Yöneticisini seçerek yeni sürüme güncelleyebilirsiniz.

Yeni sürüm belirtilen ürünler için gerekli kurulum dosyalarını indirebilir. İndirilen dosyaları Kurulum Yöneticisini kullanan diğer kullanıcılarla paylaşabilirsiniz.

Bu indirmeler yalnızca Kurulum Yöneticisi tarafından kullanılmak içindir.
Seçenekler şunlardır:
  • Eğer birden çok sürüm varsa listeden seçebilirsiniz.
  • Bu sürümle ilgili detaylar için Bu yükseltmenin ne içerdiğine bakın'ı tıklayın.
İleri'yi tıklamak seçili sürümün kurulum yöneticisini alır ve yürütür.

Hiçbir Yeni İndirme Yok/Yeni Sürümler Denetlenemiyor

SolidWorks Kurulum Yöneticisi SolidWorks ürünlerinin daha yeni sürümünü bulamadı , ya en son sürümü kuruyorsunuz veya SolidWorks sayfasına bağlanılamadı.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Yönetim resmi Konumu

Yönetim resmi kurulumunun konumunu belirleyin.

Bir yönetim resmi oluştururken bu seçenekler uygulanır:
Yeni resim konumu
Burası SolidWorks Kurulum Yöneticisinin yeni resmi oluşturacağı dizin konumudur.
Bu konum varolan bir yönetim resmi içeremez. Yönetim resmi, istemci dağıtımı için, paylaşılan bir klasörde olmalı.
Resim oluşturma için gerekli tahmini yer
Bu, yönetim resmi için gerekli ek yerdir.
Kurduğunuz diskte, resim gereksinimlerini karşılamak için gerekli serbest yer olduğundan emin olun.
Şundan resim oluştur
Bu, SolidWorks ürünlerini kurduğunuz kaynak dizin konumudur.
Bu seçenek sadece Yalnızca Kur seçeneği belirtildiğinde görünür. Ayrıntılar için bkz. İndirme Seçenekleri.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


İndirme Seçenekleri

İndirme işlemini tamamlamak için indirilen dosyaların konumu, dosyaların nasıl indirileceği, ve indirilen dosyaların kurulması gibi detayları belirtin.

SolidWorks Kurulum Yöneticisi elektronik yazılım dağıtımını (ESD) destekler. Eğer bir SolidWorks DVD'sinden kurmuyorsanız, Kurmakta olduğunuz SoldWorks ürünlerinin kaynağını belirtmelisiniz.

İndirme klasöür ile ilgili soruların cevapları için SolidWorks Kurulum Yöneticisi İndirme Klasörü.

Ne yapmak istiyorsunuz?

Aşağıdakilerden birini seçin:
İndir ve kur/İndir ve resim oluştur
İndirme tamamlandıktan sonra, SolidWorks Kurulum Yöneticisi indirilmiş dosyaları kullanarak bir kurulum yürütür.
Yalnızca indir. Bir kere indirebilir ve sonra dosyaları birden çok bilgisayarla paylaşabilirsiniz.
İndirme tamamlandıktan sonra, SolidWorks Kurulum Yöneticisi bir kurulum yürütmez.

Tipik olarak bu seçeneği birden fazla bilgisayara kurulum için bir dosya seti oluşturmak için indiriyorsanız kullanırsınız.

Eğer bu seçeneği kullanırsanız, daha sonra indirmek için iki set dosyadan birini seçmeniz istenir:
  • BU bilgisayar için dosyalar: İndirme , yalnızca bu bilgisayarda eksik olan dosyalardan oluşur.
    Bu daha küçük bir indirme olmalı, çünkü içeriği:
    • Yalnızca Ürün Seçim sayfasında seçilen ürünlerin dosyaları
    • Yalnızca bilgisayarınız için gerekli ama henüz kurulmamış ön gereksinim dosyaları

    Fakat, eğer bu indirmeyi başka bir bilgisayarda kurulum için kullanırsanız, bazı dosyalar eksik olabilir (çünkü bir diğer bilgisayardaki varolan dosyalar farklı olabilir). Bu indirmeleri bir başka bilgisayarda kullanabilirsiniz, ama kurulum yürütüldüğünde eksikleri tamamlamak için ek dosyalar indirmek zorunda kalabilirsiniz.

  • HERHANGİ bir bilgisyarla paylaşmak için dosyalar: İndirme , bu sürümü herhangi bir bilgisayarda kurmaya yarayacak eksiksiz bir kurulum dosyaları seti içerir.

    Bu daha büyük bir indirme olur çünkü bu sürümü herhangi bir bilgisayarda kurmaya yarayacak eksiksiz bir kurulum dosyaları seti içerir.

    Eğer indirmek için sınırlı sayıda ürünler belirlediyseniz, bu seçenek o belrlemeyi yok sayar ve ürün sürümüne dahil olan tüm ürünleri indirir.

    Ürün sadece bireysel bir kurulum için değil bir yönetim resmi oluşturmak için de gerekli hangi dosyalar varsa içerir.

Yalnızca Kur/Yalnızca resim oluştur. Gerekli kurulum dosyalarının tümü zaten mevcut.
SolidWorks Kurulum Yöneticisi dosya indirmez ama seçili dizindeki dosyaları kullanır.

Gözat'a tıklayın ve başka bir konuma gidin. Örneğin bir kurulum DVD'sine veya indirme klasörüne, o konumda gerekli tüm dosyaların olması şartıyla, gidebilirsiniz.

Eğer dosyanın eksik olduğuna dair bir hata mesajı alırsanız, ve tüm kurulum dosyalarının o konumda bulunmasını bekliyorduysanız olası açıklamaların bir kısmı:
  • Daha önce indirirlmemiş olan bir bileşeni kurulum için seçtiniz veya varsayılan olarak seçilmiş.
  • Dosyalar başka bir dizi gereksinimleri olan farklı bir bilgisayarda indirilmişler.
  • Daha önce bir istemci kurdunuz, ve şimdi daha çok dosyaya ihtiyacı olan bir yönetim resmi kuruyorsunuz.

Ya tüm dosyaları içeren bir klasöre gözatabilirsiniz (örneğin bir DVD) veya bu seçeneklerden birini seçebilirsiniz.

Gerekli dosyaların nereye indirilmesini istersiniz?

Bu indirme klasörü konumudur.

Bazı durumlarda, bu seçenek görünür ama devre dışı olabilir. Örneğin, eğer Yalnızca Kur belirtilirse, SolidWorks Kurulum Yöneticisi ayrı bir indirme klasörü kullanmak yerine tüm indirilen dosyaları o seçenek için belirtilen klasörden kurar.

Bu dosyaları indirsenizde kendi konumunuzdan erişsenizde tüm dosyalar aynı indirme klasörüne indirilmelidir.

Tahmini indirme boyutu

Tahmini indirme disk alanı gereksinimleri seçili tam bileşen listesine dayanır, bunun yeni bir indirme veya önceki bir indirmenin devamı olmasından bağımsızdır.

Örneğin, eğer önceki bir indirime devam ediyorsanız SolidWorks Kurulum Yöneticisi yalnızca daha indirilmemiş olan dosyaları işler. İndirme süresi tahmin edilenden kısa olabilir.

Eğer bir dosya önceki indirimde tamamlandıysa boyu bü tahmine eklenmez. Bu yüzden tahmin, esas indirme boyundan büyük olabilir.

Nasıl indirmek istiyorsunuz?

İki seçenek var:
Manüel indirme yürüt
Bazı durumlarda, bir proxy sunucusu SolidWorks Kurulum Yöneticisinden otomatik indirmeleri engelleyebilir.
Bu seçeneği seçerek dosyaları manüel olarak bir web sayfasından indirebilir ve sonra SolidWorks Kurulum Yöneticisi ile kurulum işlemlerini tamamlayabilirsiniz. Bu web sayfası SolidWorks Kurulum Yöneticisi tarafından yalnızca kurulumu tamamlamak için gerekli dosyaları indirmek için özelleştirilmiştir.
Daha fazla ağ bant genişliği kullanarak indirmeleri hızlandır
İndirici, indirme sırasında kullanılan ağ bant genişliğini arttırarak indirme hızını arttırmak için bir algoritma kullanır.

Bazı durumlarda bu ağ performansını etkileyebilir. Eğer indirmede sorun yaşıyorsanız, bu seçenek proxy sunucusu tarafından desteklenmiyor olabilir. Seçeneği kaldırıp tekrar indirmeyi deneyin. Detaylar için ağ yöneticinize danışın.

Bu seçenek yalnızca otomatik indirmelere uygulanır. Manüel indirmelere hiçbir etkisi yoktur.

SolidWorks Arkaplan İndiricisini Kullanmak

Bu indirme işlemini tamamlamak veya ileriki SolidWorks Servis Paketi sürümlerinin indirilmeleri için SolidWorks Arkaplan İndiricisini kullanabilirsiniz.

SolidWorks Arkaplan İndiricisi otomatik olarak yeni servis paketleri güncellemelerini arkaplanda algılayabilir ve indirebilir, ve indirme tamamlanıp dosyalar kuruluma hazır olduğunda sizi uyarabilir. Ayrıntılar için bkz. SolidWorks Arkaplan İndiricisi.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


SolidWorks Kurulum Yöneticisi Dosyaları İçin İndirme Seçenekleri

SolidWorks Kurulum Yöneticisinin daha ileri bir sürümünü indirmeye karar verdiniz. Nasıl ve nereye indirildiğini belirlemek için bu ekranı kullanın.

İndirme klasöür ile ilgili soruların cevapları için SolidWorks Kurulum Yöneticisi İndirme Klasörü.

Bu ekran yalnızca varsayılan indirme klasörü ile ilgili bir sorun varsa görünür (örneğin yazım erişimi veya ağ erişimi yoksa) Tipik olarak bir alternatif indirme dizini belirterek devam edebilirsiniz.

İndirme Dizini

SolidWorks Kurulum Yöneticisi dosyalarının hedefine gözatın.

İndirmenin boyutu ve gerekli alan gösterilir. Gerekli alan, belli dosyaların ayrıştırılmaları için gereken alanı da içerir ve esas indirme boyundan büyüktür.

İndirme Hızlandırmayı Kullan

Eğer bu seçeneği kullanırsanız, indirici, indirmenin hızını arttırmak için bir algoritma kullanır.

İndirme hızlandırma bant genişliğini arttırır ve ağ performansını bozabilir. İndirme hızlandırmayı etkinleştirmeden önce ağ yöneticinize danışın.

Eğer hızlandırma proxy sunucusu tarafından desteklenmiyorsa bu seçenek otomatik olarak devre dışı kalır.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Ürün Kurulum Dosyalarını İndirmek

Belirtilen ürün için eksik dosyaların nereye ve nasıl indirileceğini belirtin.

SolidWorks Kurulum Yöneticisi indirme süreci boyunca tüm dosyaları pararlel süreçlerle indirir, doğrular ve ayıklar.

Bu ekrandan iptal ederek çıkmak kurulum sürecinin geri kalanını da iptal eder.

iptal etmenin sonuçları ve kesilen kurulumlara devam etmek ile ilgili olarak Kurulum Hataları'na bakın.

İndirme Dizini

İmdirilen dosyalar için hedef klasöre gözatın.

İndirme boyu ve gerekli alan gösterilir. Gerekli alan, belli dosyaların ayrıştırılmaları için gereken alanı da içerir ve esas indirme boyundan büyüktür.

İndirme klasöür ile ilgili soruların cevapları için SolidWorks Kurulum Yöneticisi İndirme Klasörü.

İndirme Seçenekleri

Daha fazla ağ bant genişliği kullanarak indirmeleri hızlandır
İndirici, indirme sırasında kullanılan ağ bant genişliğini arttırarak indirme hızını arttırmak için bir algoritma kullanır.

Bazı durumlarda bu ağ performansını etkileyebilir. Eğer indirmede sorun yaşıyorsanız, bu seçenek proxy sunucusu tarafından desteklenmiyor olabilir. Seçeneği kaldırıp tekrar indirmeyi deneyin. Detaylar için ağ yöneticinize danışın.

İndirme hızlandırma bant genişliğini arttırır ve ağ performansını bozabilir. İndirme hızlandırmayı etkinleştirmeden önce ağ yöneticinize danışın.

Eğer hızlandırma proxy sunucusu tarafından desteklenmiyorsa bu seçenek otomatik olarak devre dışı kalabilir.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


İndirme İlerlemesi

SolidWorks Kurulum Yöneticisi bu süreç boyunca tüm dosyaları pararlel süreçlerle indirir, doğrular ve ayıklar.

İndirmeyi başladıktan sonra iptal etmek için İptal'e tıklayın.

Eğer indirmeyi iptal ederseniz veya indirme başarısız olursa, bir İndirme İptal Edildi veya İndirme Sorunu ekranı hangi indirmelerin tamamlanmadığını gösterir ve indirmeye devam etmenize yada ekranı kapamanıza olanak tanır.

İndirme klasöür ile ilgili soruların cevapları için SolidWorks Kurulum Yöneticisi İndirme Klasörü.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


İndirme Sonuçları

İndirmenin başarıyla mı tamamlandığını, işlem sırasında başarısız mı olduğu yoksa iptal mi edildiğini gösterir.

İndirme Sorunu/İndirme İptal Edildi

Eğer İndirme Sorunu görürseniz, SolidWorks Kurulum Yöneticisi indirmenin tamamlanmasını engelleyen bir sorun ile karşılaşmıştır.

Eğer İndirme İptal Edildi görürseniz indirmeyi tamamlanamadan iptal etmişsinizdir.

Devam etmek için:

Otomatik indirmelere yeniden dene/devam et
Otomatik indirmeye iptal ettiğiniz yerden devam etmek için İndirmeyi Tekrar Dene veya İndirmeyeye Devam Et'i seçin.
Dosyaları tek tek bir Web tarayıcısında indirin
Bazı durumlarda, bir proxy sunucusu SolidWorks Kurulum Yöneticisinden otomatik indirmeleri engelleyebilir.
Bu seçeneği seçerek dosyaları manüel olarak bir web sayfasından indirebilir ve sonra SolidWorks Kurulum Yöneticisi ile kurulum işlemlerini tamamlayabilirsiniz. Bu web sayfası SolidWorks Kurulum Yöneticisi tarafından yalnızca kurulumu tamamlamak için gerekli dosyaları indirmek için özelleştirilmiştir.

İndirme Tamamlandı

İndirme Tamamlandı ekranı Yalnızca İndir seçeneğini seçtiyseniz indirme tamamlandığında gösterilir.

SolidWorks Kurulum Yöneticisinden çıkmak için Bitir'i tıklayın.

Bu ürünlerin hiçbirini el ile kurmaya çalışmayın. İndirilmiş dosyaları kurmak için her zaman SolidWorks Kurulum Yöneticisini kullanın.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Kurulum Hataları/Kurulum İptal Oldu

Kurulum bir hata ile karşılaştı veya iptal edildi.

Eğer bir hata veya iptal olursa:
  • Hata veya iptalden önce kurulan ürünler bilgisayarda kalır.
  • İptal anında kurulmakta olan ürün, mümkünse, geri alınır böylece yarım kurulumlar kalmaz.
  • Geri kalan ürünler kurulmaz yada kaldırılmaz. Daha Kalkışılmadı altında bir liste verilir.

    Bu ürünleri kurmaya veya kaldırmaya devam etmek için verilen bağlantıyı tıklayın.

SolidWork kurulum yöneticisi önce bilgisayarda olmayan öngereksinimleri kurar, örneğin .NET framework. Sonra seçili ürünleri şu sırayla kurar:
  1. SolidWorks
  2. eDrawings
  3. SolidWorks Arama
  4. SolidWorks Explorer/Workgroup PDM
  5. PhotoView 360
  6. SolidWorks Flow Simulation
  7. COSMOSM
  • Başarısız veya İptal Edilmiş Kurulumları Kurtarmak
    Eğer kurulum sırasında bir hata veya iptal olursa, kurulumu yeniden yürüterek o noktadan kurtarabilirsiniz.
  • Bir Kurulumu Onarmak
    Eğer kurulu bir SolidWorks Ürünü ile bir sorun yaşarsanız, SolidWorks Kurulum yöneticisini kullanarak kurulumu onarabilirsiniz.
  • SolidWorks Tedarikçisi ile Temasa Geçmek
    Eğer kurulumu değiştirmek veya onarmak başarısız olursa, yerel SolidWorks tedarikçiniz ile bu ekrandan toplanan bilgilr ile beraber temasa geçin. Ayrıca SolidWorks Kurulum Yöneticisi günlük dosyalarını içeren bir zip dosyası vermeniz de istenebilir.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Başarısız veya İptal Edilmiş Kurulumları Kurtarmak

Eğer kurulum sırasında bir hata veya iptal olursa, kurulumu yeniden yürüterek o noktadan kurtarabilirsiniz.

  1. Başarısız olan kurulum için hata mesajını ve ürün kodunu, Kurulum Hataları veya Kurulum İptal Edildi ekranında gösterildiği şekilde, kaydedin

    Eğer bir kaynak alanı sorulursa ve varolan bir SolidWorks kurulumunu güncellemiyorsanız, kurulum bilgisayarı bozuk olabilir. SolidWorks tedarikçisi ile temasa geçin.

  2. Bilgisayarı yeniden başlatın.
  3. Hiçbir SolidWorks ürününün çalışmadığından emin olmak için Windows'da Ctr+Alt+Del'e basarak Görev Yöneticisini başlatın.
  4. Süreçler sekmesinde, eğer aşağıdaki süreçlerden herhangi birisi Yansıma Adı altında görünürse, bunları seçip İşlemi Sonlandır'ı tıklayın.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Eğer uygulama zaten kuruluysa ve değiştirmeyi veya kaldırmayı deniyorduysanız, kurulumu onarmayı deneyin. Ayrıntılar için bkz. Bir Kurulumu Onarmak.
  6. Windows Vista veya ilerisinde Başlat > Kontrol Paneli > Programlar ve Özellikler tıklayın. Daha öveki Windows sürümleri için Başlat > Kontrol Paneli > Program Ekle ve Kaldır tıklayın.
  7. Başarısız olan SolidWorks sürümünü seçin.

    Eğer kurmaya çalıştığınız SolidWorks sürümü için hiçbir girdi yoksa kurulumu tekrarlayın.

  8. Aşağıdakilerden birini yapın:
    • Yeniden denemek için Değiştir'i tıklayın ve kurulumsırasında atlanan veya başarısız olan ürünleri seçin.

    • Başarısız kurulumu atlamak için Değiştir'i tıklayın ve kurulum sırasında atlanan tüm ürünleri seçin. Kurulumu başarılamayan ürünü temizleyin.

    • Kurulumu terketmek için Kaldır'ı tıklayın ve kurulan tüm ürünleri seçin.

    Bu, yükseltmekte olduğunuz ürünlerin eski sürümlerini kurtarmaz.

Üst konu başlığ: Kurulum Hataları/Kurulum İptal Oldu


SolidWorks Tedarikçisi ile Temasa Geçmek

Eğer kurulumu değiştirmek veya onarmak başarısız olursa, yerel SolidWorks tedarikçiniz ile bu ekrandan toplanan bilgilr ile beraber temasa geçin. Ayrıca SolidWorks Kurulum Yöneticisi günlük dosyalarını içeren bir zip dosyası vermeniz de istenebilir.

  1. Günlük dosyalarını bulmak:
    • Vista öncesi Windows işletim sistemleri için:

      C:\Documents and Settings\username\Application Data\SolidWorks\Installation Logs\installed_version\

    • Windows Vista veya daha yenisi için:

      C:\Users\username\AppData\Roaming\SolidWorks\Installation Logs\installed_version\

    Klasörü bulamazsanız, gizli olabilir. Windows Explorer'da, Araçlar > Klasör Seçenekleri'ni tıklayın. Görünüm sekmesinde, Gelişmiş Ayarlar'ın altında, Gizli Dosya ve Klasörler için Gizli dosya ve klasörleri göster'i seçin.

  2. Bu klasörün tüm içeriğini, alt klasörler ile birlikte, zip haline getirin.
Üst konu başlığ: Kurulum Hataları/Kurulum İptal Oldu


Kurulum Tamamlandı

SolidWorks Kurulum Yöneticisi işlemesini tamamlamıştır.

Bu seçeneklerden biri veya fazlası görünebilir.

What's New

Bireysel kurulumlar için, kurulumu bitirdiğinizde, SolidWorks ve eklenti ürünlerin yeni özelliklerini anlatan bir belge görüntülenir.

Yönetim Resmi kurulumları için belge istemci bilgisayarlar kurulumlarını tamamladığında görüntülenir.

Anket

Kurulum süreci ile ilgili düşüncelerinizi kısa bir anket ile bize bildirin.

SolidWorks Müşteri Deneyimi Geliştirme Programı

Performans bilgisi, SolidWorks Corporation'a ürünü iyileştirmeye yardım etmek için yollanır. Bu süreç şeffaf ve gizlidir. Aşağıdakilerden birini seçin:
  • Evet, katılmak istiyorum
  • Hayır, teşekkür ederim
  • Daha sonra hatırlat
Daha fazla bilgi için, Müşteri Deneyimi GeliştirmeProgramı Web Sayfası'na bakın.

Yönetim resmi Oluşturulması Tamamlandı

Yönetim resmini kurmanız tamamlandığında Resmi Özelleştir'i tıklayarak Yönetim Resmi Seçenek Düzenleyicisini çalıştırabilirsiniz.

Bu resmi bir istemciye nasıl kuracağımı göster.'i tıklayarak Seçenek Düzenleyici ile ilgili talimatları görüntüleyin.

Bir yönetim resminin konfigürasyonunu Seçenek Düzenleyicisi ile yapmak konusunda detaylar için Yönetim Resmi Seçenek Düzenleyicisi.

Bu yönetim resminin seçenek ayarlarını özelleştirmek için Yönetim Resmi Seçenek Düzenleyicisini başlatmak için Resmi Özelleştir'i tıklayın.
Seçenek Düzenleyiciyi, Yönetim Resmi kurulum dizininde, sldAdminOptionEditor.exe'ı çift tıklayarak başlatabilirsiniz.
  • SolidWorks Güncellemelerini Denetle
    SolidWorks Kurulum Yöneticisini kullanarak güncellemeleri manüel olarak denetleyebilir veya periyodik olarak otomatik denetlemesini ayarlayabilirsiniz.
  • SolidWorks Müşteri Deneyimi Geliştirme Programı
    SolidWorks kurulurken, performans bilgilerininin olarak SolidWorks Corporation'a ürün iyileştirme amacı ile yollanmasını seçebilirsiniz.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


SolidWorks Güncellemelerini Denetle

SolidWorks Kurulum Yöneticisini kullanarak güncellemeleri manüel olarak denetleyebilir veya periyodik olarak otomatik denetlemesini ayarlayabilirsiniz.

  1. SolidWorks Kurulum Yöneticisini şu şekilde başlatın:

    • SolidWorks uygulamasında, Yardım > Güncellemeleri Denetle'yi tıklayın.

    • Windows'da, Başlat > Tüm Programlar > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.

    SolidWorks Kurulum Yöneticisi size o anda kullanılabilir güncelleme olup olmadığını gösterir.

  2. Eğer güncellemeler var ise, indirip indirmemeyi ve kurup kurmamayı seçin.
  3. Otomatik olarak güncellemeleri denetlemek için, SolidWorks Kurulum Yöneticisi işlemini tamamladığında Güncellemeleri her __ günde bir denetle'yi seçin ve denetleme frekansını belirleyin.
Üst konu başlığ: Kurulum Tamamlandı


SolidWorks Müşteri Deneyimi Geliştirme Programı

SolidWorks kurulurken, performans bilgilerininin olarak SolidWorks Corporation'a ürün iyileştirme amacı ile yollanmasını seçebilirsiniz.

SolidWorks bu bilgileri ürün kullanımı ve kalite ile ilgili trendleri tespit etmek için kullanır. Amacımız en yüksek kalitedeki ürünü sunmak ve performans günlükleri bu süreçte önemli bir araçtır.

Bu süreç şeffaftır. Günlük dosyalarındaki tüm bilgiler gizlilikle ele alınır. Başka hiçbir amaç için kullanılmazlar ve kimse sizinle temasa geçmez.

Daha fazla bilgi için, Müşteri Deneyimi GeliştirmeProgramı Web Sayfası'na bakın.

Üst konu başlığ: Kurulum Tamamlandı


Kurulum konumu

SolidWorks kurulum konumlarını belirleyin.

Yönetim resmi oluşturma hariç kurulumlar için bu seçenekler geçerlidir:
Seçili ürünleri şuraya kur
Bu, SolidWorks'ü kurduğunuz dizin konumudur.
Bir kurulum değiştirilirken veya yükseltilirken, tüm dosyalar varolan kurulum konumuna kurulmalıdır. Bu durumda varolan SolidWorks kurulumunun konumunu değiştiremezsiniz.
Kurulum için gerekli tahmini yer
Bu kurulum veya değiştirme için seçilen ürünler için gerekli ek alandır.
Kurduğunuz diskte, kurulum gereksinimlerini karşılamak için gerekli serbest yer olduğundan emin olun.
Şuradan kur
Bu, SolidWorks'ü kurduğunuz kaynak dizin konumudur.
Bu seçenek sadece Yalnızca Kur seçeneği belirtildiğinde görünür. Ayrıntılar için bkz. İndirme Seçenekleri.
SolidWorks kurulum konumlarını değiştirmeden önce sistem yöneticinize danışın.

Yönetim resmi Konumları

Bir yönetim resmi oluştururken bu seçenekler uygulanır:
Yeni resim konumu
Burası SolidWorks Kurulum Yöneticisinin yeni resmi oluşturacağı dizin konumudur.
Bu konum varolan bir yönetim resmi içeremez.
Resim oluşturma için gerekli tahmini yer
Bu, yönetim resmi için gerekli ek yerdir.
Kurduğunuz diskte, resim gereksinimlerini karşılamak için gerekli serbest yer olduğundan emin olun.
Şundan resim oluştur
Bu, SolidWorks ürünlerini kurduğunuz kaynak dizin konumudur.
Bu seçenek sadece Yalnızca Kur seçeneği belirtildiğinde görünür. Ayrıntılar için bkz. İndirme Seçenekleri.
Varolan resim konumu
Varolan bir yönetim resmini yükseltirken için, SolidWorks Kurulum Yöneticisi, varolan resmin ayarlarıona dayanarak yeni bir resim oluşturur. Bu varolan resim değiştirilmez. Bu Hoş Geldiniz eklranında belirttiğiniz orijinal resim konumunu gösterir.

Sürüme Özel Dizin Yolları Kullanmaktan Çekinin

Eğer bir kurulum dizini konumunda bir sürüm numarası belirtirseniz ( örneğin, C:\Program Files\SolidWorks Corp\SolidWorks 2010\) ve sonra kurulumu SolidWorks 2011'e yükseltirseniz, SolidWorks 2011 kurulum dizininizin adı SolidWorks 2010 olacak.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Yükseltme Seçenekleri

Bir yada daha çok eski büyük SolidWorks sürümü şu anda bu bilgisayara kuruludur. Varolan en son sürümü, yeni sürüme yükseltmeyi veya yeni sürüm için yeni bir kurulum oluşturmayı seçin.

Bu seçenek, eğer bu bilgisayarda bu büyük sürümün hiçbir kopyası kurulmamışsa görünür. Eğer bu büyük sürümün başka bir kopyası kurulu ise SolidWorks Kurulum Yöneticisi her zaman o kurulumu günceller.

(SolidWorks 2010'dan başlayarak, servis paketlerinin aynı büyük sürüm ile paralel kurulumları artık desteklenmiyor.)

Yükseltirken:
  • Tüm belirtilen ürünler yükseltilir.
  • Tüm kurulu ürünler otomatik olarak seçilir.
  • Eğer bir ürünü seçmezseniz yükseltilmez.
    Eğer bir ürün bileşenini seçmezseniz, SolidWorks Kurulum Yöneticisine o bileşeni kaldırmasını söylemiş olmazsınız. Bir ürün bileşenini kaldırmak için Program Ekle veya Kaldır'ı kullanın, Bir Kurulumu Kaldırmak.

Uygun seçeneği seçin ve İleri'ye tıklayın.

SolidWorks version için yeni bir kurulum oluşturun.

Bu seçeneği seçmek eski sürüm kurulumu koruyarak bu büyük sürüm için yeni kurulum oluşturur.

Bu, yenisini kurduktan sonra bile eski sürüm SolidWorks'e erişmek isterseniz faydalı olur. Örneğin, hala eski sürümü kullanan kullanıcılar ile dosyalar paylaşıyorsanız, Yeni sürüm ile kaydedilmiş dosyalar ile sürüm uyumsuzluğunun önüne geçebilirsiniz.

SolidWorks previous_major_version'ı SolidWorks current_major_version'a yükselt.

Bu seçeneği seçmek eski sürüm kurulumunu yenisine yükseltir.
Kurulum tamamlandığında, Eski SolidWorks sürümü artık bu bilgisayarda kullanılamaz.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Kurulum İlerlemesi:

Bu ekran kurulumun ilerlemesini gösterir.

Kurulumu başladıktan sonra iptal etmek için İptal'e tıklayın.

iptal etmenin sonuçları ve kesilen kurulumlara devam etmek ile ilgili olarak Kurulum Hataları'na bakın.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Kurulum Tipi

Yürütmek istediğiniz kuruşum işlemini, örneğin yeni kurulum oluşturmak, varolan kurulumu değiştirmek veya onarmak, bir yönetim resmi oluşturmak, yönetim sunucu ürünlerini kurmak, veya kurmadan dosyaları indirmek gibi, seçin.

Bireysel

Bu bilgisayardaki SolidWorks ürünlerini kurun.

Bu seçenek sadece bu sürüm bilgisayarınızda kurulu değilse görünür.

Bireysel kurulumu değiştir

B bu bilgisayarda varolan bireysel SolidWorks kurulumunu değiştirin.

Bu seçenek sadece bu sürüm bilgisayarınızda kurulu ise görünür.
Değişiklikler şunları içerir:
  • SolidWorks ürün bileşenlerini eklemek veya kaldırmak
  • Farklı bir SolidWorks paketine geçmek (örneğin, SolidWorks Professional, SolidWorks Premium, gibi)
  • SolidWorks seri numarası ayarını değiştirmek
    Eğer önceki bir kurulum sırasında bir SolidWorks seri numarası belirttiyseniz, SolidWorks kurulum Yöneticisi birdaha istemeyebilir. SolidWorks tarafından varsayılan seri numarasını değiştirmek için bu seçeneği seçmelisiniz.

Bireysel kurulumu onar

B bu bilgisayarda varolan SolidWorks kurulumunu onarın.

Bu seçenek sadece bu sürüm bilgisayarınızda kurulu ise görünür.
Onarım bütün dosyaların olduğunu ve doğru kaydedildiğini denetler ve bulduğu sorunları onarır. Sizin oluşturduğunuz veri etkilenmez.
  • Bir ürünü onarmak için seçtiğinizden emin olun.
  • Onarmak istemediğiniz ürünlerin işaretlerini kaldırın.
Biireysel bir kurulumu onarabilirsiniz. Bir yönetim resmini onaramazsınız; kurulumu kaldırıp yönetim resmini yeniden kurmalısınız.

Yönetim resmi

Bu bilgisayarda bir yönetim resmi oluşturun veya güncelleyin.

Bir yönetim resmini birden fazla bilgisayara kurulum yapmak için kullanabilirsiniz. SolidWorks'ü bir yönetim resmi ile istemci bilgisayarlara kurmak hakkında detaylı bilgi için, Yönetim Resimlerini Kullanmak.

Yönetim resimlerini oluştururken veya güncellerken:
  • Varolan bir resimden kurulum ayarlarını kullanarak yeni veya güncellenmiş resmi ayarlayabilirsiniz, veya varsayılan SolidWorks kurulum ayarlarını kullanabilirsiniz.
  • Eğer varolan bir resmi güncelliyorsanız:
    • SolidWork Kurulum Yöneticisi, güncelliyor da olsanız, resmin yeni bir kopyasını oluşturur. Orijinal resim değiştirilmez.
    • Varolan bir resimden ayar ve dosyaları kullanarak yeni bir resim oluşturabilirsiniz. Bu, daha küçük bir indirme sağlar.
    Eğer bir Servis Paketi bulunan bir resmi belirtmezseniz daha küçük indirme olanağından faydalanamazsınız.
  • Bu bilgisayarda hem 32-bit, hem de 64-bit yönetim resimleri oluşturabilirsiniz. Yoksa yalnızca donanım mimarisine uyumlu yönetim resmi oluşturulur.
    Eğer hem 32-bit hem 64-bit yönetim resminin oluşturulmasını belirtirseniz Her iki mimari için SolidWorks kurulum medyasından kurulumu tamamlaması beklenir.

Sunucu ürünleri

SolidWorks yönetim sunucu ürünleri SolidWorks Workgroup PDM Server (Vault) ve SolidNetWork License Manager'ı içerir.

Bu ürünlerle ilgili detaylar için bkz.:
  • Workgroup PDM
  • SolidNetWork License Manager'ı kullanarak Lisans Yönetimi

Yalnızca indir

Seçili SolidWorks ürünleri için kurulum dosyalarını indirir ama ürünleri kurmaz

Bu seçenek, bir DVD'den kuruyorsanız görünmez.

İndirilen dosyaların içeriği SolidWorks kurulum DVD'sinin içeriği ile aynıdır. Bu seçeneği seçmek tüm kurulum dosyalarını indirir, bilgisayarınızda neyin zaten kurulu olduğundan bağımsızdır.

Bu yöntemi kullanıcıların kurulmlarını yapabilecekleri bir sunucu oluştururken kullanabilirsiniz. Bu bir yönetim resmi oluşturmaktan farklıdır.

Bu bilgisayar için yanlış olan SolidWorks mimarisini kurmak

Eğer yanlış SolidWorks kurulum medyası ile kurmaya çalışıyorsanız (örneğin 64-bit SolidWorks'ü 32-bit bilgisayara kurmaya çalışıyorsanız) bu kurulum paneli bu sorunu göstermeli.

Kuruluma devam etmek için:
  1. SolidWorks Kurulum Yöneticisi oturumunu iptal edin.
  2. Bilgisayar mimarisini ve bu bilgisayar için sistem gereksinimlerini kontrol edin.
  3. Doğru SolidWorks kurulum medyasını kullanarak yeniden kurun.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Manüel İndirme

Dosyaları el ile indirmeyi seçtiniz (veya SolidWorks Kurulum Yöneticisini son çalıştırdığınızda dosyaları el ile indirmeyi seçmişsiniz).

Otomatik olarak oluşturulmuş, indirilmesi gereken dosyaların listesini içeren web sayfasını açmak için tıklayın.

Özet sayfasında belitilen klasöre indirmelisiniz. Tüm dosyalar o klasöre indirilmeden kurulum başlayamaz.

Manüel indirmeyi tamamladığınızda devam etmek için İleri'yi tıklayın.

Otomatik olarak indirmek için seçeneği Özet Sayfasına geri gidip değiştirebilirsiniz.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Daha Yeni Bir Sürüm Var

SolidWorks Kurulum Yöneticisi SolidWorks ürünlerinin yeni bir sürümünü buldu. Orijinal kurulum DVD veya indirmesindeki sürümü kurmayı seçebilir, veya yeni sürümü indirip kurabilirsiniz.

Eğer bir DVD'den kuruyorsanız

Daha yeni sürümü kullanmak ister misiniz?'in altında bunlardan birini seçin:
  • Hayır, version'ı bu DVD'den kurmaya devam edin. Daha sonra güncelleyebilirsiniz.

    Bu seçeneği, geçerli kurulum yöneticisi ile devam etmek için seçin.

    Kurulum tamamlandıktan sonra Kurulum yöneticisini kullanarak güncellemeleri yükleyebilirsiniz. Güncellemeleri denetlemek için, Başlat > SolidWorks Kurulum Yöneticisi > Güncellemeleri Denetle'yi tıklayın.

    Avantajı, daha küçük bir indirme sağlar. Dezavantajı, bu iki aşamalı bir kurulum olur ve indirdiğiniz dosyalar farklı sürüm kullanan kullanıcılar ile paylaşılamaz.

  • Evet, kurulumu bu DVD'yi kullanarak gerçekleştirin, sonra version'a indirip güncelleyin.

    Bu seçeneği Kurulum Yöneticisinin daha yeni bir sürümünü indirip kullanarak o sürümün SolidWorks ürünlerini kurmak için kullanın.

    Eğer bir küçük servis paketi sürümü ile DVD güncellenebilecekse, Kurulum Yöneticisi önce orijinal sürümü DVD'den kurar sonra da Servis Paketi güncellemesini uygular. Bu, daha küçük bir indirme sağlar.

    Aynı sonuca DVD'deki sürümü kurmayı seçip güncellemeyi ileriki bir tarihte yaparak da gerçekleştirebilirsiniz.

    Bu seçeneğin avantajı bir adımda olmasıdır.

Çoğu durumda, DVD'den tam sürümü kurmak ve sonra kurulum yöneticisini kullanarak güncellemeleri kurmak daha küçük indirmeler gerektirdiği için tercih edilier.

Eğer bir İndirmeden kuruyorsanız

Aşağıdakilerden birini seçin:
  • Kuruluma devam et version.

    İl indirmedeki sürümü kurmaya devam etmek için seçin.

  • Daha yeni sürümü indir ve kur: version

    Daha yeni sürümü indirip onu kurmak için bunu seçin. Eğer birden fazla yeni sürüm varsa seçip istediğinizi kurabilirsiniz.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Süreçler Algılandı

SolidWorks Kurulum Yöneticisi başarılı bir kurulumu engelleyebilecek süreçler algıladı.

  • Kuruluma devam etmek için şunlardan birini yapın:
    • Süreci sonlandırın (örneğin Microsoft Windows Görev Yöneticisini kullanarak) sonra Yeniden Deneyi tıklayın.
    • Yoksay'ı tıklayarak devam edin.
  • Kurulumu durdurmak için İptal'i tıklayın.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Ürün Seçimi

Kurulacak, değiştirilecek, indirilecek veya kaldırılacak ürün bileşenlerini belirtin.

Ürün listesinde:
  • Ürün listesi, üzerinde belirtilen paket için varolan tüm ürünlerin tam bir listesidir.
  • Belirli bir bileşen için yansıtılan eylemi görmek için, bileşen adını tıklayın (ama işaret kutusunu değil). İstenilen kurulum işlemi ürün listesinin altındaki bilgi alanında görüntülenir.
  • Bir ürün bileşeninin yanındaki kutucuğu tıklayarak o bileşenin kurulum eylemini değiştirebilirsiniz. (Örneğin, eğer bileşenleri kuruyor veya kaldırıyorsanız, kutucuğu seçmek o bileşenin kurulmasını yada kaldırılmasını belirtirken kutucuğu temizlemek bileşenin kurulmamasını veya kaldırırlmamasını belirtir.)
  • Eğer bir değiştirme kurulumu gerçekleştiriyorsanız, ürün seçiminde bir değişiklik yaptığınızda listede ürün bileşenlerinin yanında bir yıldız işareti (*) belirir.
  • Eğer bir bileşen opsiyonel kurulum alt bileşenleri içeriyorsa, bir + simgesi bileşenin yanında görünür. Bir bileşenin olası alt bileşenlerini görmek için, + simgesini tıklayın.
  • Eğer bir bileşen tüm alt bileşenlerini göstermek için genişletilmişse, bir - simgesi bileşenin yanında görünür. Alt bileşenler listesini daraltmak için, - simgesini tıklayın.

Eğer bir Servis Paketi uyguluyorsanız, SolidWorks'ün altında göründen SolidWorks unsurları (örneğin FeatureWorks) seçilemez. Bunun sebebi, bu tarz bir yükseltme yaparken ürün ekleyip çıkartamazsınız.

SolidWorks Kurulum Yöneticisi tarafından yapılan eylemler bir dizi birlikte varolma kuralı ile yönetilir. Ayrıntılar için bkz. Ürünlerin Bir Arada Var Olma Kuralları.

SolidWorks Kurulum Yöneticisi şu ürün bileşenlerini varsayılan olarak seçer:
  • Eğer bir Yükseltme veya Servis Paketi güncellemesi yapıyorsanız, SolidWorks Kurulum Yöneticisi şu anda kurulu olan ürünleri seçer.
  • Yoksa, SolidWorks Kurulum Yöneticisi hakkınız olan tüm ürünleri seçer.
İndirme zamanı ve disk alanı gereksinimlerinizi azaltmak için, ürün bileşenlerini genişletip ihtiyacınız olmayan bileşenler için işaret kutusunu temizleyin.

Eğer SolidWorks Kurulum Yöneticisi hakkınız olan ürünleri doğrulayamadıysa, Farklı paketler yada ürünler seçin'i tıklayarak ürün paketini (SolidWorks Professional yada SolidWorks Premium gibi) değiştirebilirsiniz SolidWorks Kurulum Yöneticisi, kurulum medyanızda, seçtiğiniz paketle uyumlu olan tüm ürünleri gösterir. Satın aldığınız veya denemeye hakkınız olan tüm ürünleri seçebilirsiniz.

SolidWorks Arama

SolidWorks Arama SolidWorks belgelerinin, Workgroup PDM kasasının ve 3D ContentCentral'ın tam metin aranmalarını sağlar. Arama bir ön izleme ve dosya konumunu gösterir.

Kurulumdan sonra, SolidWorks Arama SolidWorks belgelerini daha hızlı aramalar için indeksler. Yalnızca SolidWorks dosyaları varsayılan olarak indekslenir.

SolidWorks Aramayı kurmak, eğer zaten yoksa, Windows Desktop Search otomatik olarak kurar.

Dil Desteği

SolidWorks ürününü ve Diller bileşenini genişleterek kurabileceğiniz dilleri görün.

Diller spesifikasyonu yalnızca SolidWorks ürünü için kurulan dilleri sınırlar. Diğer ürün kurulumları bu değişiklikten etkilenmezler Örneğin, SolidWorks eDrawings®, SolidWorks Workgroup PDM, ve SolidWorks Explorer tüm dilleri kurarlar.

Gerekli Alan

SolidWorks Kurulum Yöneticisi ya toplam kurulum boyunu yada toplam indirme boyunu sayfanın sonunda belirtir.

  • Eğer Yalnızca İndir seçeneğini seçtiyseniz, İndirme Boyu Görünür. İndirme boyu, tüm indirilen dosyalar için gerekli disk alanıdır ( indirme tamamlandıktan sonra sıkıştırılmış dosyaları ayıklamak için gerekli alan dahil değildir). Bu sayı bir tahmindir.
    Toplam indirme boyuna, kurulum için gerekli tüm dosyalar dahildir. Eğer bazı dosyalar zaten indirildiyse tekrar indirilmezler. Bu yüzden esas indirme boyunuz gösterilenden az olabilir, veya hiç bir dosyayı indirmek zorunda olmayabilirsiniz.
  • Yoksa Kurulum Boyu görünür. Kurulum boyu, kurulumu tamamladığınızda disk alanında oluşacak olan değişikliktir. Dosya sıkıştırmasından dolayı bu sayılar tahmindirler.

    Eğer varolan bir kurulumu güncelliyor veya kaldırıyorsanız, kurulum boyu sıfır olabilir.

    Gösterilen sayı, eğer kurulum sırasında gerekirse dosya indirmek veya ayıklamak için gerekli alan içermez.

    Eğer indirmeler gerekirse ve aynı sürücüye indiriyorsanız, gerçek disk alanı gereksinimkeri görünenden çok daha büyük olabilir.

    Gelecekteki indirme ve kurulum zamanlarını azaltmak için kurulumdan sonra indirilen dosyaları silmeyin. Sonraki güncellemeler ve yamalar tipik olarak bu son tam kurulum dosya setine ihtiyaç duyar.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


İndirilecek Ürünler

Belli bir konuma indirmek için SolidWorks ürünlerini seçin.

İndirebileceğiniz ürünler verdiğiniz seri numarasına göre belirlenir:

  • Her bileşen için yapılacak eylem o öğenin sağında gösterilie.
  • Eğer bir bileşen opsiyonel kurulum alt bileşenleri içeriyorsa, bir + simgesi bileşenin yanında görünür. Bir bileşenin olası alt bileşenlerini görmek için, + simgesini tıklayın.
  • Eğer bir bileşen tüm alt bileşenlerini göstermek için genişletilmişse, bir - simgesi bileşenin yanında görünür. Alt bileşenler listesini daraltmak için, - simgesini tıklayın.
  • SolidWorks Kurulum Yöneticisi tarafından nasıl davranılacağını belirlemek için her bileşenin solundaki kutuyu işaretleyin.
SolidWorks Kurulum Yöneticisi hakkınız olan tüm ürün bileşenlerini, aksini belirtmediğiniz sürece, indirir. İndirme süresi ve disk alanı gereksinimlerinizi azaltmak için, ihtiyacınız olmayan bileşenleri seçin.

Eğer SolidWorks Kurulum Yöneticisi hakkınız olan ürünleri doğrulayamadıysa, bir SolidWorks paketi seçebilirsiniz. SolidWorks Kurulum Yöneticisi, seçtiğiniz paketle uyumlu olan tüm ürünleri gösterir.

Eğer SolidWorks Kurulum Yöneticisi hakkınız olan ürünleri doğrulayamadıysa, Farklı paketler yada ürünler seçin'i tıklayarak ürün paketini (SolidWorks Professional yada SolidWorks Premium gibi) değiştirebilirsiniz SolidWorks Kurulum Yöneticisi, kurulum medyanızda, seçtiğiniz paketle uyumlu olan tüm ürünleri gösterir. Satın aldığınız veya denemeye hakkınız olan tüm ürünleri seçebilirsiniz.

Dil Desteği

Diller spesifikasyonu yalnızca SolidWorks ürünü için kurulan dilleri sınırlar. Diğer ürün kurulumları bu değişiklikten etkilenmezler Örneğin, SolidWorks eDrawings®, SolidWorks Workgroup PDM, ve SolidWorks Explorer tüm dilleri kurarlar.

Gerekli Alan

Seçtiğiniz ürünlere bağlı olarak indirmeyi gerçekleştirmek için gerekli alan gösterilir. İndirme boyu, tüm indirilen dosyalar için gerekli disk alanıdır ( indirme tamamlandıktan sonra sıkıştırılmış dosyaları ayıklamak için gerekli alan dahil değildir). Bu sayı bir tahmindir.

Gelecekteki indirme ve kurulum zamanlarını azaltmak için kurulumdan sonra indirilen dosyaları silmeyin. Sonraki güncellemeler ve yamalar tipik olarak bu son tam kurulum dosya setine ihtiyaç duyar.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Onarılacak Ürünler

Bu kurulumu onar'ı seçerseniz ekran, bu SolidWorks kurulum yöneticisi tarafından onarılabilecek ürünleri gösterir.

Onarım bütün dosyaların olduğunu ve doğru kaydedildiğini denetler ve bulduğu sorunları onarır. Sizin oluşturduğunuz veri etkilenmez.
  • Bir ürünü onarmak için seçtiğinizden emin olun.
  • Onarmak istemediğiniz ürünlerin işaretlerini kaldırın.

Seçili ürünleri onarmak için Onar'ı seçin.

Biireysel bir kurulumu onarabilirsiniz. Bir yönetim resmini onaramazsınız; kurulumu kaldırıp yönetim resmini yeniden kurmalısınız.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Seri Numaraları

Dağıtım kutusunda bulunan seri numaraları bilgisayarınızı satın aldığınız SolidWorks ürünleri ile ilişkilendirir.

Eğer SolidWorks ürünleri zaten bilgisayarınıza kurulularsa onların seri numaraları otomatik olarak görüntülenir.
  • Eğer zaten görünmüyorsa, SolidWorks seri numaranızı girin.
  • Eğer SolidWorks lisansında bulunmayan ürünler için seri numaralarınız varsa Başka Seri Numaralarınız Var mı? altındaki ürünü tıklayıp seri numarasını girin.

Eğer bir internet bağlantınız varsa, Kurulumda ilerledikçe girmiş olduğunuz seri numaraları kurma hakkınız olan ürünlerin kurulacak ürünleri seçerken görüntülenmesini sağlar.

SolidWorks ürünlerini satın almanın birden fazla yolu olduğu için bazı seri numaraları iki yada daha fazla ürünü kapsayabilir. Örneğin, bir SolidWorks seri numarası ayrı bir SolidWorks Simulation seri numarası girmeden SolidWork Simulation'ı kurmanıza olanak verebilir. Ek olarak, bazı ürünler seri numaraları gerektirmezler. Eğer seri numaralarınızla ilgili bir sorunuz var ise VAR'ınızla temasa geçin.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Sunucu Kurulumu

Kurmaya çalıştığınız sunucu ürünleri, kurulum sonuçları ile listelenir.

Sunucu Kurulum Durumu

Sunucu ürün kurulumları dışarıdan kurulum uygulaması ile yapılır. Şu anda o uygulamada değilseniz, kurulumu tamamlamak için ona geçmelisiniz.

Sunucu ürün kurulumunu durdurmak için İptal'i tıklayın.

Sunucu Kurulum Tamamlandı

Dış kurulum uygulaması başarıyla tamamlanamadı.

Bitir'e veya İleri'ye tıklayın.
  • Eğer başka yönetim ürünleri kuruyorsanız (örneğin SolidWorks Kurulum Resmi) o kurulum devam eder.
  • Eğer sunucu ürün kurulumları tek kurulum işlemi idiyse Kurulum Yöneticisi kapanır.

Sunucu Kurulumu İptal Edildi veya Başarısız Oldu

eğer bir sunucu ürünü kurulumu başarısız olur veya iptal edilirse, kurulamayan sunuxular listelenir.

Kapat'ı veya İleri'i tıklayın.
  • Eğer başka yönetim resim kurulumları belirttiyseniz Kurulum Yöneticisi devam eder.
  • Eğer sunucu ürün kurulumları tek kurulum işlemi idiyse Kurulum Yöneticisi kapanır.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


SolidNetWork License Manager

SolidNetWork License Manager sunucusu ürünü için kurulum seçeneklerini belirtin.

Seri numaraları

SolidNetWork seri numaralarını belirtin. Birden çok seri numarasını virgülle ayırarak ekleyebilirsiniz.
SolidNetWork seri numaraları SolidWorks seri numaralarından farklıdır.

Kurulum konumu

SolidNetWork License Manager için kurulum konumunu belirtin.

Eğer zaten varolan bir SolidNetWork License Manager kurulumunu yükseltiyorsanız aynı konuma kurmalısınız.

Daha fazla bilgi için

SolidNetWork lisans yöneticisi kurulumu konfigürasyonu ve kullanımı hakkında detaylar için SolidNetWork License Manager'ı kullanarak Lisans Yönetimi.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Özet

SolidWorks Kurulum Yöneticisi, kurulumu tamamlamak için tüm bilgilere sahiptir.

Devam etmek için: | Şimdi action düğmesine basarak işlemi başlatın (örneğin, Şimdi Kur, Şimdi Oluştur, Şimdi İndir, Şimdi Değiştir).
Kurulum ayarlarını değiştirmek için: | Değiştirmek istediğiniz seçenek için Değiştir [image] 'i tıklayın (örneğin, Ürünler, Kurulum Konumu, Toolbox Seçenekleri).
İptal etmek için: | İptal'i [image] tıklayıp SolidWorks Kurulum Yöneticisinden Çıkın.
Daha önceki bir sayfaya geri dönmek için: | Geri'yi [image] tıklayın.
Belli bir seçenek seti için (örneğin Ürünler, Kurulum Konumu, Toolbox Seçenekleri gibi):
  1. DEĞİŞTİR'İ [image] tıklayın.
  2. Çıkan detaylar sayfasında Yardım'ı [image] tıklayarak o kurulum seçenekleri ile ilgili bilgi edinebilirsiniz.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Sistem Kontrolü Uyarıları

Sistem Kontrolü kuruluma nasıl devam edeceğinizi etkileyebilecek durumları rapor eder. Çoğu durumda, SolidWorks Kurulum Yöneticisi ile devam edebilmelisiniz.

Bu aşamada karşılaşabileceğiniz uyarılar, bazı önerilerle birlikte aşağıda sıralanmıştır.

Seri Numarası Doğrulama Sorunları
Kurulum Yöneticisi, sunucuya bağlanamadığı için, daha yeni sürümlerin varlığını denetleyemedi. Eğer internete bağlı ve doğru bir seri numarası girdiyseniz, bu bizim sunucumuzda geçici bir soruna işaret ediyor olabilir. Daha sonra tekrar deneyin.

Seri Numarası Doğrulaması: Kurulum Yöneticisi, hangi ürünleri kurmaya hakkınız olduğunu belirleyebilmek için seri numaranızı doğrulayamadı. Dosyaları kurabilecek ama indiremeyeceksiniz. Kurulum için eksiksiz bir kaynak dosyaları seti yada bir DVD sağlamalısınız.

Çözünürlük:
  • İnternet bağlantısını kontrol edin. Seri numarasının denetimi geçerli bir internet bağlantısı gerektirir.
  • Girdiğiniz seri numarasının kurmaya çalıştığınız ürünler için geçerli olduğuna emin olun.
  • Bazı kurulumlar sürümün çıktığı anda geçerli bir aboneliğinizin olmuş olmasını gerektirir. Detaylar için SolidWorks tedarikçiniz ile temasa geçin.
  • Eğer bir DVD'den veya daha önceden indirilmiş bir dosya setinden kuruyorsanız, çoğu durumda kuruluma devam edebilirsiniz,
Daha Yeni Bir Sürüm Var
Daha Yeni Bir Sürüm Var

Daha Yeni Sürümler Var

Bu ürünün daha yeni bir sürümü indirmek için mevcut.

Çözünürlük: Bir Yükseltmeleri Denetle işlemi gerçekleştirilirken, kurulum SolidWorks'ten indirilebilecek daha yeni bir sürümü kurmanızı söyleyebilir. İşleme, ilk başladığınız sürümü kullanarak veya yeni sürümü indirerek devam edebilirsiniz.

Kullanılabilir Son Sürüm
Bu varolan en son sürüm. Devam etmek için Sonraki'ni tıklayın.

Hiçbir Yeni İndirme Yok

Çözünürlük: Bu mesaj bir kurulum veya dseğiştirme sırasında güncellemeleri denetlerken görülebilir. Kullanılabilir en son sürümü kurduğunuzu gösterir.

İnternet Bağlantı Sorunları
İnternet Bağlantısı: Kurulum Yöneticisi SolidWorks sürücüsüne, hangi ürünleri kurmaya hakkınız olduğunu belirleyebilmek için bağlanamadı. Dosyaları kurabilecek ama indiremeyeceksiniz. Kurulum için eksiksiz bir kaynak dosyaları seti yada bir DVD sağlamalısınız.

Yeni Sürümler Denetlenemiyor

Kurulum Yöneticisi, sunucuya bağlanamadığı için, daha yeni sürümlerin varlığını denetleyemedi.

Çözünürlük:
  • İnternet bağlantısını kontrol edin.
  • Eğer bir DVD'den veya daha önceden indirilmiş bir dosya setinden kuruyorsanız, kuruluma devam edebilirsiniz,
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Delik Sihirbazı/Toolbox Seçenekleri

Eğer SolidWorks Toolbox kurulursa, SolidWorks delik tipleri ve donanımın standart bir kitaplığını ekler.

SolidWorks Toolbox konfigürasyonu, genişletilmesi ve kullanımı hakkında detaylar için SolidWorks'te Yardım > Toolbox Yardımı'nı tıklayın.
Bu yardımı görmek için Toolbox eklentisini, Araçlar > Eklentiler'i kullanarak başlatmanız gerekebilir.

Bir SolidWorks Toolbox kullanmadan önce, şirket veya grup tercihlerinizle tutarlı olarak ayarlandığından emin olun. Çoğu durumda, bir grup merkezi bir Toolbox'ın konfigürasyonunu yapar ve saklar. SolidWorks kurulumu sırasında bir Toolbox'ın nasıl belirtileceğini SolidWorks yöneticisine danışın.

Seçili SolidWorks Toolbox'ı kurulumdan sonra değiştirebilirsiniz. SolidWorks'te, Araçlar > Seçenekler'i tıklayın. Sistem Seçenekleri sekmesinde, Delik Sihirbazı/Toolbox'a tıklayın.

Aşağıdaki bölümler bu ekranda tüm künfigürasyonlar için karşılaşabileceğiniz tüm seçenekleri tanımlıyor. Gerçekte gördüğünüz Toolbox seçenekleri, bilgisayarda önceden varolan SolidWorks ve Toolbox konfigürasyonlarına ve bu noktayakadar yapmış olduğunuz SolidWorks Kurulum Yöneticisi seçimlerine bağlıdır.

Yeni bir new-version Toolbox Oluşturun

Bu bilgisayarda SolidWorks Toolbox'ın yeni bir versiyonunu oluşturun.

Yeni bir sürüm oluşturduğunuzda, Ürün Seçim ekranında, SolidWorks > SolidWorks Toolbox genişletin ve Toolbox'ı destekleyen standartları seçin. Tüm standartlar seçili varsayılır.

Bilgisayarda zaten varolan Toolbox'lar değiştirilmez.

Varolan bir Toolbox'ı yükseltmek veya referans vermek

Varolan bir Toolbox'ı kullanın. Bu kurulumla kullanmak istediğiniz Toolbox'ın konumunu belirlemek için Gözat'ı tıklayın.

  • Eğer Toolbox daha önceki bir SolidWorks büyük sürümü için konfigüre edilmişse bu sürüme yükseltilir. O Toolbox'a yapılmış olan tüm özelleştirmeler yükseltilmiş Toolbox'ta saklanır.
    Bir Toolbox'ı yeni bir SolidWorks büyük sürümüne yükseltmek o Toolbox'ı daha önceki büyük SolidWorks sürümleri ile uyumsuz yapar.
  • Eğer Toolbox bu SolidWorks sürümü için konfigüre edilmişse (örneğin, zaten yükseltilmiş olan bir paylaşılan ağ Toolbox'ı belirttiğinizde) Toolbox yükseltilmez.
  • Eğer Toolbox'ı bir Enterprise PDM ortamında yükseltiyorsanız ek prosedürler gerekir. Ayrıntılar için bkz. Toolbox'ı SolidWorks Enterprise PDM Ortamında Yükseltmek.

Bu seçenek, yönetim resmi oluşturmak hariç, tüm kurulum senaryolarında mevcuttur.

Bir previous-version Toolbox'ı Yükseltin

Daha önceki bir SolidWorks büyük sürümü için konfigüre edilmiş bir Toolbox'ı yeni bir konuma kopyalayıp, bu kopyayı yeni sürüme yükseltin.

Bu seçenek, eğer SolidWorks ün önceki bir büyük sürümü bilgisayarda kurulu ise ama bunu yükseltmemeyi seçtiyseniz görünür.
Bunun amacı, önceki sürümün Toolbox'ını, eski sürümü kullanan kullanıcıları etkilemeden yükseltmektir.

Eğer Toolbox'ı bir Enterprise PDM ortamında yükseltiyorsanız ek prosedürler gerekir. Ayrıntılar için bkz. Toolbox'ı SolidWorks Enterprise PDM Ortamında Yükseltmek.

Bu kurulu previous-version Toolbox'ı Yükseltin

Bu Toolbox'ı yeni sürüme yükseltin.
Bir Toolbox'ı yeni bir SolidWorks büyük sürümüne yükseltmek o Toolbox'ı daha önceki büyük SolidWorks sürümleri ile uyumsuz yapar.

Bu seçenek, eğer SolidWorks ün önceki bir büyük sürümü yükseltiyorsanız ve o sürümün Toolbo'ı bilgisayarda bulunduysa görünür.

Eğer Toolbox'ı bir Enterprise PDM ortamında yükseltiyorsanız ek prosedürler gerekir. Ayrıntılar için bkz. Toolbox'ı SolidWorks Enterprise PDM Ortamında Yükseltmek.

Kurulu current-version Toolbox'ı kullanın

SolidWorks Kurulum Yöneticisi bu bilgisayarda, bu SolidWorks büyük sürümü için konfigürasyonu yapılmış bir Toolbox algıladı.

Bu seçeneği seçerseniz, SolidWorks bu Toolbox'ı kullanır. Yükseltme gerçekleşmez.

Bu seçenek, eğer SolidWorks ün önceki bir büyük sürümü bilgisayarda kurulu ise ama Toolbox konfigürasyonu şimdiki sürüme göre yapılmışsa görünür. Bu, hala eski sürümü kullanan bir bilgisayarda paylaşılan Toolbox oluşturulduysa gerçekleşebilir.

İstemci bilgisayarı için Toolbox konumunu belirleyin

İstemciler bir yönetim resminden kurduklarında varsayılan Toolbox konumu olarak bir ağ veya dizin konumu belirtin.
Eğer konum önceki bir SolidWorks sürümü için konfigürasyonu yapılmış bir Toolbox içeriyorsa, Kurulum Yöneticisi bunu yükseltir.

Bu seçenek yeni bir yönetim resmi oluştururken görünür.

İstemci bilgisayar için varolan resimde referans verilen Toolbox'ı yükselt yada kullan

Güncellemekte olduğunuz yönetim resminde belirtilen Toolbox konumunu kullanın.
Eğer konum önceki bir SolidWorks sürümü için konfigürasyonu yapılmış bir Toolbox içeriyorsa, Kurulum Yöneticisi bunu yükseltir.

İstemci bilgisayarı için farklı bir Toolbox konumunu belirleyin

Güncellemekte olduğunuz yönetim resminde belirtilenden farklı bir Toolbox konumunu kullanın belirtin.
Eğer konum önceki bir SolidWorks sürümü için konfigürasyonu yapılmış bir Toolbox içeriyorsa, Kurulum Yöneticisi bunu yükseltir.
  • SolidWorks Toolbox Konfigürasyonu Hakkında Notlar
    SolidWorks Toolbox güçlü ve kompleks bir özelliktir. Bu başlık, SolidWorks Kurulum Yöneticisini kullanarak Toolbox'ın konfigürasyonunu yapmadan çnce aklınızda bulunması için bazı konseptleri özetler.
  • UNC Formatı
    Birörnek (veya Evrensel) Adlandırma Kuralı formatı, paylaşılan bir dosya konumunu tanımlamak içi bir dosya adı sözdizimi formatı belirler.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


SolidWorks Toolbox Konfigürasyonu Hakkında Notlar

SolidWorks Toolbox güçlü ve kompleks bir özelliktir. Bu başlık, SolidWorks Kurulum Yöneticisini kullanarak Toolbox'ın konfigürasyonunu yapmadan çnce aklınızda bulunması için bazı konseptleri özetler.

SolidWorks Toolbox Hakkında Daha Fazla Bilgi Bulmak

SolidWorks Toolbox konfigürasyonu, genişletilmesi ve kullanımı hakkında detaylar için SolidWorks'te Yardım > Toolbox Yardımı'nı tıklayın.
Bu yardımı görmek için Toolbox eklentisini, Araçlar > Eklentiler'i kullanarak başlatmanız gerekebilir.

Paylaşılan bir Toolbox'ı Kullanmak

Toolbox'ı kurduğunuzda, Toolbox verisini yerel bilgisayarda veya paylaşılan bir ağ konumunda tutabilirsiniz. Toolbox verisini bir ağ konumunda saklamak önerilir. Ortak bir konum kullanarak, tüm SolidWorks kullanıcıları tutarlı bir dizi bağlantı elemanı bilgisini paylaşır.

Eğer bu ilk kurulum ise, Toolbox'ı kurmak istediğiniz yeni bir paylaşılan konuma gidin.

Varolan bir Toolbox'ı Yükseltmek

Bir Toolbox'ı yeni bir SolidWorks büyük sürümüne yükseltmek o Toolbox'ı daha önceki büyük SolidWorks sürümleri ile uyumsuz yapar.

Eğer diğer bilgisayarlar o önceki büyük sürümde kalırlarsa ve o sürüm için konfigüre edilmiş bir Toolbox'a gereksinim duyarlarsa o Toolbox'ın bir kopyasını yapıp kopyayı yükseltmelisiniz. Yeni SolidWorks kurulumu Toolibox'ın kopyasını yükseltecek ve eski solidWorks kurulumları eski Toolbox'ı kullanmaya devam edecekler.

Toolbox Erişiminin Konfigürasyonu

Kurulumdan sonra, Toolbox bileşenlerinde eriştiğinizde, SolidWorks Toolbox konfigürasyonunu nasıl yaptığınızı denetler ve performansı geliştirmek için önerilerde bulunur.

Paylaşılan ağ Toolbox'ına (önerilen) erişmek için, Toolbox'ın kurulmuş olduğu sürücüye bir UNC yolu kullanın. Ayrıntılar için bkz. UNC Formatı.

Bir yönetici Toolbox için bir şifre oluşturabilir ve çalışma grubu için izin ve tercihler ayarlayabilir. Konfigürasyona erişimi sınırlandırmak ve ortak tercihler ayarlamak tutarlı Toolbox verisini sağlar.

Toolbox'ı SolidWorks Enterprise PDM Ortamında Yükseltmek

Toolbox klasörüne Enterprise PDM klasöründen erişen ilk SolidWorks kurulumunu yükseltmeden önce:
  1. Windows Explorer'da Enterprise PDM kasasındaki Toolbox klasörine gidin.
  2. Toolbox klasörüne sağ tıklayın ve Son Sürümü Al'ı tıklayın.

    Bu SolidWorks Kurulum Yöneticisinin parçaların güncellenmesi gerektiğini doğrulamasına izin verir.

  3. Toolbox klasörüne göz atın.

    Toolbox klasörü teslim alınmış olmalı ki SolidWorks Kurulum Yöneticisi tarafından güncellenebilsin.

  4. Yükselttikten sonra, Tollbox klasörünü teslim edin.

Böylece kasadaki Toolbox kitaplığı yükseltilmiş oldu.

Sonraki SolidWorks yükseltmeleri için, yükseltmeyi başlatmadan önce, Enterprise PDM istemcileri kasa Toolbox klasörünün en son sürümünü almalılar (Son Sürümü Al'ı kullanarak). Bu SolidWorks Kurulum Yöneticisinin dosyaların güncelliğini doğrulamasına izin verir.

SolidWorks Enterprise PDM'de Toolbox konfigürasyonu hakkında detaylar için SolidWorks Enterprise PDM Yönetim Aracı yardımı içindeki Toolbox Konfigürasyonu başlığına bakın.

Üst konu başlığ: Delik Sihirbazı/Toolbox Seçenekleri


UNC Formatı

Birörnek (veya Evrensel) Adlandırma Kuralı formatı, paylaşılan bir dosya konumunu tanımlamak içi bir dosya adı sözdizimi formatı belirler.

\\server\volume\path

Örneğin:

\\Disk_Server\SolidWorks\AdminImage

Üst konu başlığ: Delik Sihirbazı/Toolbox Seçenekleri


Ürünleri Kaldırmak

KControl Paneli'nden Kaldır or Kurulumu Kaldır'ı seçerseniz ekran, bu SolidWorks kurulum yöneticisi tarafından kaldırılabilecek ürünleri gösterir. Standart, Özel veya Tam kaldırma gerçekleştirebilirsiniz.

Standart kaldırma Program Dosya ve Klasörlerini kaldırır. Varsayılan olarak seçili sürüm için tüm SolidWorks ürünleri standart kaldırılmak için seçilidir.

Özel kaldırma şunlardan bir veya fazlasını kaldırır: Program Dosya ve Klasörleri, kayıt anahtarları ve veri klasörleri, SolidWorks Toolbox, ve orijinal indirilmiş dosya ve klasörler.

Tam kaldırma kurulum dizinlerini kayıt anahtarlarını ve veri klasörlerini kaldırır.

Ürünü kaldırmak için:
  1. Kaldır ekranında, ürünün seçili olduğundan emin olun.

    Eğer tüm ürünleri kaldırırsanız, SolidWork kurulum yöneticisi de kaldırılır.

  2. Kaldırılmasını istemediğiniz ürünlerin işaretlerini kaldırın.

    Eğer bir ürünü tutarsanız, SolidWorks Kurulum Yöneticisi kaldırılmaz.

  3. Özel veya tam kaldırmayı seçin.
    1. Gelişmiş Seçenekler'de Değiştir tıklayın

      Helişmiş Seçenekler ekranı açılır. Program Dosya ve Klasörleri seçeneği işaretli.

    2. Özel kaldırma için istediğiniz seçenekleri seçin.
    3. Özete Geri Dön'ü tıklayın.
    4. Özet ekranında Gelişmiş Seçenekler'i genişletin.
  4. Öğeleri Kaldır'ı [image] tıklayın.
Öğeleri Kaldır'ı tıkladığınızda SolidWork Kurulum Yöneticisi ürünleri anında kaldırmaya başlar.
Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Workgroup PDM Sunucu Seçenekleri

SolidWorks Workgroup PDM sunucusu ürünü için kurulum seçeneklerini belirtin.

Kurulum konumu

SolidWorks Workgroup PDM sunucu ürünleri için kurulum konumunu belirtin.

Kurulacak ürünler

Hangi Workgroup PDM Sunucusu ürünlerinin kurulacağını seçin:
Workgroup PDM Vault
SolidWorks Workgroup PDM Vault verisi için konum belirtin. Viewer'ı etkinleştirmek için bir Workgroup PDM Viewer lisansı kasa ile birlikte kurulmalıdır.
Workgroup PDM Viewer
Workgroup PDM Viewer'ı kurarken, Viewer'ın erişeceği Workgroup PDM Vault'u barındıran bilgisayarın adını veya IP adresini belirtmelisiniz.
Workgroup PDM API

Workgroup PDM API için bir lisans SolidWorks istemcileri ve Explorer istemcileri lisansları ile birliktedir. Teslim etme API'ları istemci lisansları gerektirir.

Daha fazla bilgi için

Workgroup PDM kurulum talimatları için bkz. Workgroup PDM.

Workgroup PDM kullanmak konusunda daha fazla detay için SolidWorks Yardım'ında Workgroup PDM'e bakın.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Yasal Uyarılar

© 1995-2011, Dassault Systèmes SolidWorks Corporation, bir Dassault Systèmes S.A. şirketi, 175 Wyman Street, Waltham, Mass. 02451 ABD. Tüm Hakları Saklıdır.

Bu belgedeki bilgiler ve açıklanan yazılım, önceden bildirilmeksizin değiştirilebilir ve Dassault Systèmes SolidWorks Corporation'ın (DS SolidWorks) taahhütlerini oluşturmaz.

Hiçbir materyal DS SolidWorks'ün açık yazılı izni alınmadan, elektronik veya mekanik olsun herhangi bir biçimde veya araçla, herhangi bir amaçla çoğaltılamaz veya iletilemez.

Bu belgede açıklanan yazılım, bir lisans altında sağlanmaktadır ve yalnızca bu lisansın şartlarına uygun olarak kullanılabilir veya kopyalanabilir. DS SolidWorks tarafından yazılımı ve dokümantasyona ilişkin verilen tüm garantiler, SolidWorks Corporation Lisans ve Abonelik Hizmeti Anlaşması'nda belirtilmiştir ve işbu belgede veya içeriğinde belirtilen veya ima edilen hiçbir husus, bu garantilerde bir değişiklik veya tadilat olarak görülemez veya yorumlanamaz.

Patent Uyarıları

SolidWorks® 3B mekanik CAD yazılımı; ABD. Patentleri 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940 ve yabancı patentler, (örn., EP 1,116,190 ve JP 3,517,643) tarafından korunmaktadır.

eDrawings® yazılımı A.B.D. Patenti 7,184,044; A.B.D. Patenti 7,502,027; ve Kanada Patenti 2,318,706 tarafından korunur.

Beklemede A.B.D. patentleri ve yabancı patentler vardır.

SolidWorks Ürün ve Hizmetleri için Ürün İsimleri ve Ticari Markalar

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, ve eDrawings logosu, DS SolidWorks'ün, tescilli ticari markaları ve FeatureManager ortak tescilli ticari markasıdır.

CircuitWorks, FloXpress, TolAnalyst, ve XchangeWorks DS SolidWorks'e ait tescilli markalardır.

FeatureWorks, Geometric Ltd.'nin bir tescilli ticari markasıdır.

SolidWorks 2012, SolidWorks Enterprise PDM, SolidWorks Simulation, SolidWorks Flow Simulation, ve eDrawings Professional DS SolidWorks'ün ürün isimleridir.

Diğer marka ve ürün adları, kendi sahiplerinin ticari markaları veya tescilli ticari markalarıdır.

TİCARİ BİLGİSAYAR YAZILIMI - ÖZEL

Yazılım, 48 C.F.R. 12.212'de (EYLÜL 1995) kullanılan anlamlarıyla “ticari bilgisayar yazılımı” ve “ticari yazılım dokümantasyonu”nu kapsayan, 48 C.F.R. 2.101 (EKİM 1995)’de kullanıldığı anlamıyla bir “ticari kalem”dir ve ABD Hükümeti’ne (a) 48 C.F.R. 12.212’de belirtilen politika uyarınca sivil kurumlar tarafından veya adına iktisap edilmek üzere veya (b) 48 C.F.R. 227.7202-1 (HAZİRAN 1995) ve 227.7202-4'te (HAZİRAN 1995) belirtilen politikalar uyarınca Savunma Bakanlığı’nın birimleri tarafından veya adına iktisap edilmek üzere temin edilir.

ABD hükümetinin herhangi bir kurumundan Yazılım’ın yukarıda belirtilenlerin ötesinde haklarla temin edilmesi yönünde bir talep almanız halinde, talebin kapsamını DS SolidWorks’e bildirirsiniz ve DS SolidWorks, tek takdir yetkisi kendinde olmak üzere, söz konusu talebi beş (5) işgünü içinde kabul eder veya reddeder. Yüklenici/İmalatçı: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 ABD.

SolidWorks Standard, Premium, Professional, ve Education Ürünleri için Telif Hakları Uyarıları

Bu yazılımın bazı bölümleri © 1986-2011 Siemens Product Lifecycle Management Software Inc.'e aittir. Tüm hakları saklıdır.

Bu çalışma, Siemens Industry Software Limited'in sahibi olduğu aşağıdaki yazılımı içermektedir:

D-Cubed™ 2D DCM © 2011. Siemens Industry Software Limited. Tüm Hakları Saklıdır.

D-Cubed™ 3D DCM © 2011. Siemens Industry Software Limited. Tüm Hakları Saklıdır.

D-Cubed™ PGM © 2011. Siemens Industry Software Limited. Tüm Hakları Saklıdır.

D-Cubed™ CDM © 2011. Siemens Industry Software Limited. Tüm Hakları Saklıdır.

D-Cubed™ AEM © 2011. Siemens Industry Software Limited. Tüm Hakları Saklıdır.

Bu yazılımın bir kısmı © 1998-2011 Geometric Ltd.

Bu yazılımın bir kısmı © 1996-2011 Microsoft Corporation. Tüm hakları saklıdır.

Bu yazılımın bir kısmı PhysX™by NVIDIA, 2006-2010 içeriyor.

Bu yazılımın bir kısmı © 2001-2011 Luxology, LLC. Tüm hakları saklıdır, patentler bekleniyor.

Bu yazılımın bir kısmı © 2007-2011 DriveWorks Ltd.

Telif Hakkı 1984-2010 Adobe Systems Inc. ve lisans verenleri. Tüm hakları saklıdır. 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382 A.B.D. Patentlerinin koruması altındadır; Beklemede Patentler Vardır.

Adobe, Adobe logosu, Acrobat, Adobe PDF logosu, Distiller ve Reader, Adobe Systems Inc.'ın A.B.D.'de ve başka ülkelerde tescilli ticari markaları veya ticari markalarıdır.

Daha fazla SolidWorks® telif hakkı bilgisi için Yardım > SolidWorks Hakkında.

SolidWorks Simulation Ürünleri için Telif Hakkı Uyarıları

Bu yazılımın bazı bölümlerinin telif hakkı © 2008 Solversoft Corporation'a aittir.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. Tüm hakları saklıdır.

SolidWorks Enterprise PDM Ürünü için Telif Hakkı Uyarıları

Outside In® Viewer Technology, © 1992-2011 Oracle

© 2011, Microsoft Corporation. Tüm hakları saklıdır.

eDrawings Ürünleri için Telif Hakkı Uyarıları

Bu yazılımın bir kısmı © 2000-2011 Tech Soft 3D.

Bu yazılımın bir kısmı © 1995-1998 Jean-Loup Gailly ve Mark Adler.

Bu yazılımın bir kısmı © 1998-2001 3Dconnexion.

Bu yazılımın bir kısmı © 1998-2011 Open Design Alliance. Tüm hakları saklıdır.

Bu yazılımın bir kısmı © 1995-2010 Spatial Corporation.

Bu yazılımın bir kısmı Independent JPEG Group'un çalışmalarına dayanmaktadır.


Birden Çok Bilgisayarı Kurmak ve Yönetmek

SolidWork Kurulum Yöneticisi birden çok bilgisayara kurmak ve yönetmek için şu araçları sağlar.

SolidWorks Yönetim Resimleri

Eğer SolidWorks'ü birden fazla bilgisayara kuruyorsanız, Bir yönetim resmi oluşturup uygulamayı diğer bilgisayarlara dağıtabilirsiniz.

Workgroup PDM Server

Workgroup PDM uygulaması bir ürün veri yönetimi yazılımıdır ve SolidWorks ortamında veya SolidWorks Explorer'ın içinde tek başına çalışır. Workgroup PDM projeleri, Teslim alma, teslim etme, revizyon kontrolü ve diğer yönetim görevleri için prosedürlerle yönetiyor. Workgroup PDM Sunucusunu kurmak Workgroup PDM kasasını oluşturur, bu da yönetilen SolidWorks projelerini barındıran veritabanıdır.

SolidNetWork License Manager

SolidNetWork License Manager kullanıcı sayısının lisans sayısını aşmasını, yüzen lisanslar kullanarak sağlar. Bir istemci lisansı kullanılmadığında, başka bir kullanıcı tarafından kullanılabilir.

SolidNetWork License Manager'ı ayrıca ana SolidWorks eklentilerini (örn. FeatureWorks) dağıtmak için kullanabilirsiniz.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı


Daha Yeni Sürümler Yok

indirmek için daha yeni bir sürüm yok. Belirtilen sürümü kurmaya devam edin.

İleri'yi tıklayarak devam edin.

Üst konu başlığ: SolidWorks Kurulum Yöneticisi Uygulaması Yardımı