Compile Date

 Compile Date: 2001-06-12


Smart card overview

A smart card is a credit card sized device you can use for storing sign-in passwords, public and private keys, and other personal information. Smart cards provide tamper-resistant and portable security solutions for tasks such as securing e-mail and logging on to a domain.

Support for smart cards is a feature of the public key infrastructure (PKI) that Microsoft has integrated into XOX.

Smart cards provide:

  • Tamper-resistant storage for protecting private keys and other forms of personal information.
  • Isolation of security-critical computations involving authentication, digital signatures, and key exchange.
  • A way to take logon information and other private information with you for use on computers at work, home, or on the road.

XOX

Related Topics


Install a smart card reader on a computer

Microsoft Windows graphic

To install a smart card reader on a computer

  1. Depending on the type of reader you have purchased, attach your reader to an available serial or USB port or insert the PC card reader into an available PCMCIA slot.
  2. If you connected a serial port reader, restart the computer to detect it and then log on.
  3. Do one of the following:
    • If the device driver for the smart card reader is available as part of XOX, the installation of the driver takes place without any prompting by the user. This may take a few minutes.
    • If the device driver for the smart card reader is not available as part of XOX, the Add Hardware Wizard starts. Follow the directions for installing the device driver software.

Important

  • Smart card readers generally come with setup instructions from the manufacturer. If your reader comes with instructions, you should use those. If not, then use these general procedures.

Notes

  • You can confirm that the installation was successful by confirming that the reader appears in the Device Manager tree.
  • If the smart card reader is not installed automatically or the Add Hardware Wizard does not start automatically, then your smart card reader may not be compliant with Plug and Play specifications. You should contact the smart card reader manufacturer for the device driver and the instructions on how to install and configure the device.
  • When using the Add Hardware Wizard to install a smart card reader, you need the device driver. Contact the manufacturer of the smart card reader. Alternatively, your administrator may provide the driver.


Understanding smart cards

Logging on to a network with a smart card provides a strong form of authentication because it uses cryptography-based identification and proof of possession when authenticating a user to a domain.

For example, if a malicious person obtains a user's password, that person can assume the user's identity on the network simply through use of the password. Many people choose passwords they can remember easily, which makes passwords inherently weak and open to attack.

In the case of smart cards, that same malicious person would have to obtain both the user's smart card and the personal identification number (PIN) to impersonate the user. This combination makes an attack less likely because an additional layer of information is needed to impersonate a user. An additional benefit is that a smart card is locked after the PIN is entered incorrectly several times in a row, making a dictionary attack against a smart card extremely difficult. (Note that a PIN does not have to be a series of numbers, it can also use other alphanumeric characters.) Attacks against a smart card do not go undetected, since the malicious person must have the smart card in his or her possession and the rightful owner of the smart card would notice that it was missing.


Logging on to a computer with a smart card

To log on to a computer with a smart card, users do not need to press CTRL+ALT+DEL. They simply insert the smart card into the smart card reader, and they are prompted for their personal identification number (PIN) instead of their user name and password (and domain, if applicable).

Related Topics


Log on to a computer with a smart card

Microsoft Windows graphic

To log on to a computer with a smart card

  1. At the XOX logon screen, insert your smart card into the smart card reader.
  2. Type the personal identification number (PIN) for the smart card when prompted by your computer.

Notes

  • If the PIN you enter is recognized as legitimate, this logs you on to the computer and to the XOX domain, based on the permissions assigned to your user account by the domain administrator.
  • If you enter the incorrect PIN for a smart card several times in a row, you will be unable to log on to the computer using that smart card. The number of allowable invalid log on attempts before lock out occurs varies according to the smart card manufacturer. Contact your administrator for assistance.

Related Topics