Windows Time service

Windows Time service is a component of Windows XP that automates the synchronization of computers on a Windows XP network.

  • For tips about using the Windows Time service, see Best practices.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.


Best practices

  • Synchronize your domain with an accurate external time source.

    Synchronized clocks are necessary on all computers on the network for the proper operation of many services. You must also ensure that the synchronized time is correct. By default, the computers on the network obtain the time from their authenticating domain controller. The domain controllers on a network obtain their time from their domain's primary domain controller (PDC) operations master or an explicitly configured time source. Because of this, you must ensure that the PDC operations master in each domain is set to the correct time.

    There are many computers on the Internet that provide accurate time information. One such source is the National Institute of Standards and Technology (NIST), which provides the NIST Network Time Service.

  • Check Event Viewer.

    When Windows Time service encounters errors, it writes events to the system log, so check Event Viewer periodically for messages regarding the Windows Time service. For more information, see Event Viewer.


How to…

Microsoft Windows graphic

How to...

  • Synchronize the client time with a time server
  • Synchronize an internal time server with an external time source


Synchronize the client time with a time server

Microsoft Windows graphic

To synchronize the client time with a time server

  1. Open Command Prompt.
  2. Type:

    w32tm /resync

Notes

  • XOX
  • This procedure only works on computers that are joined to a domain. For information about synchronizing computers that are not joined to a domain, see Related Topics.

Related Topics


Synchronize an internal time server with an external time source

Microsoft Windows graphic

To synchronize an internal time server with an external time source

  1. Open Command Prompt.
  2. Type the following, where PeerList is a comma-separated list of Domain Name System (DNS) names or IP addresses of the desired time sources:

    w32tm /config /syncfromflags:manual /manualpeerlist:PeerList

  3. Type:

    w32tm /config /update

Notes

  • XOX
  • The most common use of this procedure is to synchronize the internal network's authoritative time source with a very precise external time source. However, this procedure can be run on any computer running Windows XP.
  • If the computer cannot reach the servers, the procedure fails and an entry is written to the Event Log.

Related Topics


Concepts

This section provides general background information about the Windows Time service:

  • Windows Time service overview


Windows Time service overview

Computers keep the time on their internal clocks, which allows them to perform any function that requires the date or time. However, for scheduling purposes, the clocks must be set to the correct date and time, and they must be synchronized with the other clocks in the network. Without some other method in place, these clocks must be set manually.

With time synchronization, computers set their clocks automatically to match another computer's clock. One computer maintains very accurate time, and then all other computers set their clocks to match that computer. In this way, you can set accurate time on all computers.

How the Windows Time service works

In Windows XP, the Windows Time service automatically synchronizes the local computer's time with other computers on the network. The time source for this synchronization varies, depending on whether the computer is joined to a Windows XP Active Directory domain or a workgroup.

When the computers are part of a workgroup, you must manually configure the time synchronization settings. One or more computers might be identified as a locally reliable time source by configuring the Windows Time service on those computers to use a known accurate time source, either by using special hardware or a time source available on the Internet. All other workgroup computers can be configured manually to synchronize their time with these local time sources.

When the computers belong to a Windows XP Active Directory domain, the Windows Time service configures itself automatically, using the Windows Time service that is available on domain controllers. The Windows Time service configures a domain controller within its domain as a reliable time source and synchronizes itself periodically with this source. These settings can be modified or overwritten, depending on specific needs.

Benefits of the Windows Time service

To function correctly, a number of Windows XP components rely on accurate and synchronized time. For example, without clocks that are synchronized to the correct time on all computers, Windows XP authentication might falsely interpret logon requests as intrusion attempts and deny access to users.

Another important benefit of time synchronization is the ability to correlate events on different computers in an enterprise. With synchronized clocks on all of your computers, you ensure that you can correctly analyze events that happen in sequence on multiple computers for success or failure.


Troubleshooting

What problem are you having?

Clients are not synchronized with servers

Cause: The Windows Time service has been stopped manually.

Solution: Start the Windows Time service. To start the Windows Time service, follow these steps:

  1. Open Command Prompt.
  2. Type:

    net start w32time

See also: Start, stop, pause, resume, or restart a service; Configure how a service is started