Raytrix Lightfield API

  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Data Structures
  • Files
Raytrix Lightfield API

Copyright (C) 2010-2012 by Raytrix GmbH. All rights reserved.

This is the documentation of the Raytrix Lightfield API. It covers image capturing from Raytrix cameras, loading and saving of lightfield images in the .ray format, and processing of such lightfield images for refocussing, depth estimation and more. To use the Raytrix Lightfield API you need an appropriate dongle, which enables a certain set of features, depending on your licence. If you want to use the Raytrix LF API in a third party product, then please contact Raytrix (info@.nosp@m.rayt.nosp@m.rix.d.nosp@m.e) for further details on licencing.

After the installation you may need to log off and on again for the environment variables to take effect!

Contents

  • Preparation
  • Example Projects
  • Programming with the Lightfield API
  • C++ API
    • Lightfield API function reference
    • Core function reference
  • .NET API
    • Lightfield API function reference
    • Core function reference
  • Change Log

The API function reference can also be accessed by selecting the tab 'Modules' at the top of the page.

Preparation

Prerequesites

Before you install this software package ensure that you have the following software installed on your machine:

  • Your graphics card must support NVIDIA CUDA with computing capability 1.2 or higher and at least 500Kb ram. You should also install the latest display driver (at least v304.79).

  • Visual Studio 2010 SP1.

Environment Variables

The main environment variable that is installed is RX_PATH_APILF. It points to the SDK installation directory. The SDK installer also adds the path to the Raytrix shared DLLs to the PATH environment variable of the system, so that the API LF DLLs are found automatically. The .NET assemblies are registered in the global assembly cache (GAC). The following paths are needed for building a project:

  • RX_PATH_APILF\include: The include path. The headers are in various sub-directories.

  • RX_PATH_APILF\lib: The library path for linking the API C++ DLLs. Note that the DLL names contain the version number as well as the architecture in their name, so that you cannnot link to a wrong DLL version by accident.

Example Projects

Example projects are installed to the path you selected during installation.

Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:23 by Raytrix GmbH


Change Log

  • Namespaces
  • Data Structures
  • Files
Change Log

Contents

  • Version 2.7.0, 7. August 2012

Version 2.7.0, 7. August 2012

There have been quite a number of changes compared to the 2.2 version. In particular, the namespaces have changed to clearly separate the various parts of the library functionalities.


Programming with the Lightfield API

Programming with the Lightfield API

Contents

  • Standard ray image processing
  • Camera capture ray image processing

Standard ray image processing

The fundamental concept behind the Raytrix lightfield API is shown in the following diagram.

Standard ray image processing

A ray image loaded from disc with RxRayLoad() is first of all stored in the Raytrix API DLL. The function RxRayLoad() does not return the ray image itself, but a handle to the ray image. Before any calculations can be performed with the ray image, it has to be copied to the CUDA device, since all operations are performed by CUDA. Copying the ray image to the CUDA device is done by the function RxRayBind(). After this function is called, all ray image processing operations act on the bound ray image, without the need for repeated copying operations of the ray image to the CUDA device.

The diagram shows two example operations on a bound ray image: RxFocusOnPlane() to generate a resultant image focused to a particular plane and RxDepth() to calculate the scene depth from the ray image. These two algorithms write to specific result images that are held on the CUDA device. All result images are listed in Rx::ApiLF::EImgID. The reason for keeping the result images initially on the CUDA device is, that they can then be processed further by algorithms running on the CUDA device and that they can be displays directly by the graphics card used using OpenGL. For more details on the CUDA/OpenGL interop. see CUDA/OpenGL interop. functions.

The result images can also be copied back to the host device using RxGetImage(). They are then available for further processing by an image processing library of your choice.

If a ray image is unbound it is not deleted internally. That is, it can be bound again, or saved. Make sure to delete ray images that are no longer needed with RxRayDelete(). Otherwise the memory may fill up rather quickly. If you call RxFinalize() all ray images in memory are deleted, all cameras are closed and any memory allocated on the CUDA device is freed. However, you cannot call any API functions except for RxInit() after a call of RxFinalize().

Camera capture ray image processing

Before you can capture images from a Raytrix camera you have to do the following preparations:

  • Initialize the available camera drivers with RxCamDriverInit().
  • Register the available cameras with RxCamRegister().
  • Open a camera with RxCamOpen().
  • Start the capture process with RxCamStartCapture().

When all of this was successful, images can be captured with RxCamDoCapture().

For the ray image processing algorithms to be able to work with captured ray images, the ray image calibration has to be known. Such a calibration contains information on where the image of the central microlens is located in the image, the rotation of the microlens array with respect to the sensor coordinate system and a scaling of the microimages. These parameters not only change for different lenses mounted on a camera, they also vary as the lens focus and/or focal length is changed.

Important
It is important to realize that the effective aperture of a Raytrix camera is fixed. This implies that as the focus of a lens is changed, the aperture setting of the aperture ring has to be adjusted such that the effective aperture is constant. See the RxLive user manual for examples of this.

Since there are different calibration settings for each setting of each lens used, the Raytrix API implements a calibration database that keeps all this data. Particular calibration datasets are selected from the calibration database using the function RxCamGetPar() with parameter IDs RxPar_CamCal_LensIdx and RxPar_CamCal_LensSetIdx which are defined in Rx::ApiLF::EPar::ID. With the first parameter a lens is selected in the calibration database and with the second parameter the lens setting of the currently selected lens is selected. The name and ID of the currently selected lens can be read with RxCamGetPar() and the parameter IDs RxPar_CamCal_LensName and RxPar_CamCal_LensID, respectively. Similarly, the f-stop and focus of the currently selected lens setting can be read with the parameter IDs RxPar_CamCal_LensSetFStop and RxPar_CamCal_LensSetFocus, respectively.

The processing of ray image data captured with a Raytrix camera is shown in the following diagram.

Camera capture image processing

The function RxCamDoCapture() captures a camera image into a ray image held by the Raytrix API DLL. This ray image is also automatically copied to the CUDA device. That is, there is no need to call RxRayBind() explicitly. The ray image on the CUDA device can then be used by the various ray image processing algorithms. The result images of the ray image algortihms may be copied back to the host with RxGetImage().


Modules

Modules
Here is a list of all modules:
[detail level 123]
\ C++ | Raytrix API
o Raytrix Lightfield API | The Raytrix Lightfield API
| o CUDA API functions | Functions for selecting a CUDA device
| o CUDA/OpenGL interop. functions | Functions to exchange data between CUDA and OpenGL
| o Enumerations | Lightfield API enumerations
| o Lightfield Image API functions | Functions for working with lightfield images
| o Lightfield Image Sequence API functions | Functions for working with lightfield sequences
| o Lightfield computation API functions | Functions to perform computations with ray images
| o Main API functions | Functions for fundamental API operations like initialization
| o Parameter API functions | Functions to get/set API parameters
| o Raytrix Camera API functions | Functions for working with Raytrix cameras
| \ Time Functions | Functions to measure time or to pause API thread
\ The Raytrix Core Classes API | The Raytrix core classes currently offer classes to hold image data of various pixel and data types
o Image classes. |
\ Tool classes. |


C++

Modules
C++

Raytrix API. More...

Modules

Raytrix Lightfield API
The Raytrix Lightfield API.
The Raytrix Core Classes API
The Raytrix core classes currently offer classes to hold image data of various pixel and data types.

Detailed Description

Raytrix API.


Raytrix Lightfield API

Modules | Data Structures | Macros | Typedefs | Functions
Raytrix Lightfield API
C++

The Raytrix Lightfield API. More...

Modules

CUDA API functions
Functions for selecting a CUDA device.
CUDA/OpenGL interop. functions
Functions to exchange data between CUDA and OpenGL.
Enumerations
Lightfield API enumerations.
Lightfield Image API functions
Functions for working with lightfield images.
Lightfield Image Sequence API functions
Functions for working with lightfield sequences.
Lightfield computation API functions
Functions to perform computations with ray images.
Main API functions
Functions for fundamental API operations like initialization.
Parameter API functions
Functions to get/set API parameters.
Raytrix Camera API functions
Functions for working with Raytrix cameras.
Time Functions
Functions to measure time or to pause API thread.

Data Structures

class | Rx::ApiLF::CStatusMessageDelegateList
struct | Rx::ApiLF::SStatusMessageDelegate

Macros

#define RX_TRY(theFunc)
Macro to test whether an API function was executed successfully. More...

Typedefs

typedef void(__stdcall * Rx::ApiLF::TFuncStatusMessageCallback )(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue, void *pvContext)
Function pointer type of the status message callback function. More...

Functions

RXLF_API bool | Rx::ApiLF::RxAddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RxLogConsoleAddMessage (Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSource, const char *pcMessage, int iValue)
RXLF_API bool | Rx::ApiLF::RxLogConsoleClose ()
RXLF_API bool | Rx::ApiLF::RxLogConsoleShow ()
RXLF_API bool | Rx::ApiLF::RxRemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)

Detailed Description

The Raytrix Lightfield API.

Not all functions described here may be available. This depends on which features are currently licenced. The licence is typically enforced by a dongle that has to be attached to the system the library runs on.

To test which features are currently available use the function RxHasFeature() together with the IDs defined as RX_API_FEAT_* defines. You can also OR various feature IDs in the call to RxHasFeature().

Macro Definition Documentation

#define RX_TRY ( theFunc )
Value:
if ( !theFunc ) \
{ \
Rx::CRxString sxError; \
int iError = RxGetLastError( sxError ); \
std::cerr << "Error " << iError << ": " << sxError.ToCString() << std::endl; \
throw iError; \
}

Macro to test whether an API function was executed successfully.

You can use this macro to simplify the error checking of API functions. You need to enclose any calls using this macro in a try{} block. The macro throws an integer with the error number as exception and prints the error text to std::cerr. To make the latter available you have to include iostream of the standard C++ library.

Typedef Documentation

typedef void(__stdcall* Rx::ApiLF::TFuncStatusMessageCallback)(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue, void *pvContext)

Function pointer type of the status message callback function.

Function Documentation

RXLF_API bool Rx::ApiLF::RxAddStatusMessageHandler | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
RXLF_API bool Rx::ApiLF::RxLogConsoleAddMessage | ( | Rx::ApiLF::EStatusSource::ID | eSource,
 |  | Rx::ApiLF::EStatusMessage::ID | eMsg,
 |  | const char * | pcSource,
 |  | const char * | pcMessage,
 |  | int | iValue
 | ) |  |
RXLF_API bool Rx::ApiLF::RxLogConsoleClose ( )
RXLF_API bool Rx::ApiLF::RxLogConsoleShow ( )
RXLF_API bool Rx::ApiLF::RxRemoveStatusMessageHandler | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |


CUDA API functions

Functions
CUDA API functions
Raytrix Lightfield API

Functions for selecting a CUDA device. More...

Functions

RXLF_API bool | Rx::ApiLF::RxCudaDeviceCount (int &iDeviceCount)
Returns the number of CUDA devices installed. More...
RXLF_API bool | Rx::ApiLF::RxCudaDeviceMemInfo (unsigned &uFreeMem, unsigned &uTotalMem)
Return free and total amount of memory on the selected CUDA device. More...
RXLF_API bool | Rx::ApiLF::RxCudaDeviceProp (int iDevice, Rx::CRxString &sxName, unsigned &iCCMajor, unsigned &iCCMinor)
Get the name and the compute capability major and minor version for a CUDA device. More...
RXLF_API bool | Rx::ApiLF::RxCudaSelectDevice (int iDevice=-1, bool bUseGL=false)
Select a CUDA device. More...

Detailed Description

Functions for selecting a CUDA device.

Function Documentation

RXLF_API bool Rx::ApiLF::RxCudaDeviceCount ( int & iDeviceCount )

Returns the number of CUDA devices installed.

Parameters
iDeviceCount Contains the number of CUDA devices on return.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCudaDeviceMemInfo | ( | unsigned & | uFreeMem,
 |  | unsigned & | uTotalMem
 | ) |  |

Return free and total amount of memory on the selected CUDA device.

Parameters
uFreeMem | On return contains the amount of free memory in bytes.
uTotalMem | On return contains the amount of total memory in bytes.
Attention
Note that this function returns with an error if called before the first call of RxRayBind().
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCudaDeviceProp | ( | int | iDevice,
 |  | Rx::CRxString & | sxName,
 |  | unsigned & | iCCMajor,
 |  | unsigned & | iCCMinor
 | ) |  |

Get the name and the compute capability major and minor version for a CUDA device.

Parameters
iDevice | Zero-based ID of the CUDA device.
sxName | On return contains the name of the CUDA device.
iCCMajor | On return contains the major version of the CUDA device compute capability.
iCCMinor | On return contains the minor version of the CUDA device compute capability.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCudaSelectDevice | ( | int | iDevice = -1,
 |  | bool | bUseGL = false
 | ) |  |

Select a CUDA device.

Parameters
iDevice | The zero-based CUDA device ID or -1 for automatic selection.
bUseGL | Flag indicating whether to initialize CUDA for OpenGL interop. or not.
Attention
This function must be called once and only once per process. The selected CUDA device cannot be changed during runtime.

Use the functions RxCudaDeviceCount() and RxCudaDeviceProp() to obtain information about the installed CUDA devices and then select the most appropriate CUDA device with this function. If iDevice is set to -1, the first appropriate CUDA device is selected.

To exchange image data generated by CUDA directly with an OpenGL rendering context on the same device, bUseGL has to be set to true and the CUDA device has to support OpenGL 3.0 or higher. Note that CUDA/DirectX interop. is currently not supported.

For further details on CUDA/OpenGL interop. see CUDA/OpenGL interop. functions.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().


CUDA/OpenGL interop. functions

Functions
CUDA/OpenGL interop. functions
Raytrix Lightfield API

Functions to exchange data between CUDA and OpenGL. More...

Functions

RXLF_API bool | Rx::ApiLF::RxGlGetVersion (int &iMajor, int &iMinor)
Get OpenGL version of current OpenGL rendering context. More...
RXLF_API bool | Rx::ApiLF::RxGlUpdateTex (unsigned uIntImgIDs)
Copy CUDA result images to OpenGL textures. More...

Detailed Description

Functions to exchange data between CUDA and OpenGL.

CUDA/OpenGL interop. works as follows. After calling RxCudaSelectDevice() with bUseGL set to true, create an OpenGL rendering context. It is then possible for the Raytrix API to write directly to textures defined by OpenGL, which can in turn be displayed through OpenGL. This avoids having to copy CUDA result images from the CUDA device to host memory and then back again to display them.

For the Raytrix API to be able to write to an OpenGL texture, it has to know the corresponding texture name (id) as generated by OpenGL with glGenTextures(). Suppose iTexID contains the texture name of a texture that is to be used to display the standard refocused image. As a first step store iTexID in the Raytrix API via RxSetPar( EPar::Gl_TexFocusLeftID, iTexID ). Then generate the refocused image, for example, using RxFocusOnPlane(). The result of this operation is stored on the device. It is copied to the OpenGL texture by calling RxGlUpdateTex(EImgID::FocusLeft). Call the RxGlUpdateTex() function each time the internal refocused image has changed.

On the OpenGL side you have to display the texture by mapping it to a plane or some other geometric object. However, note that CUDA currently only supports writing to unnormalized textures, which means that you have to define a shader to display a texture written to by the Raytrix API. The texture is initialized by the Raytrix API with the appropriate size and type, the first time RxGlUpdateTex() is called, or if the internal result image size of the Raytrix API has changed. For example, for an RGBA image with 8bit per color channel, and dimensions iWidth by iHeight, the texture is created internally as

glTexImage2D( GL_TEXTURE_2D, 0, GL_RGBA8UI,
iWidth, iHeight, 0,
GL_RGBA_INTEGER, GL_UNSIGNED_BYTE, pImageData );

The most basic shader to display such a texture on the OpenGL side is shown below. First of all, the vertex shader:

varying out vec2 vTexPos;
void main()
{
vec2 texpos = gl_MultiTexCoord0.st;
vTexPos = vec4( texpos, 0.0, 0.0 );
gl_Position = ftransform();
}

The fragment shader for color images:

#version 130
in vec2 vTexPos;
out vec4 gl_FragColor;
// The image texture
uniform usampler2D texImg;
void main()
{
vec3 vCol = vec3(textureLod(texImg, vTexPos, 0).xyz) / 255.0;
gl_FragColor = vec4(vCol, 1.0);
}

The fragment shader for luminance images:

#version 130
in vec2 vTexPos;
out vec4 gl_FragColor;
// The image texture
uniform usampler2D texImg;
void main()
{
float fCol = float(textureLod(texImg, vTexPos, 0).x) / 255.0;
gl_FragColor = vec4(fCol, fCol, fCol, 1.0);
}

Function Documentation

RXLF_API bool Rx::ApiLF::RxGlGetVersion | ( | int & | iMajor,
 |  | int & | iMinor
 | ) |  |

Get OpenGL version of current OpenGL rendering context.

Parameters
iMajor | On return contains the OpenGL major version.
iMinor | On return contains the OpenGL minor version.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function only return a meaningful result if it is called within an active OpenGL rendering context.
RXLF_API bool Rx::ApiLF::RxGlUpdateTex ( unsigned uIntImgIDs )

Copy CUDA result images to OpenGL textures.

Parameters
uIntImgIDs Internal image ID. A number of internal image IDs can be combined with OR operation.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The internal image IDs that can be used with this function are those declared inRx::ApiLF::EImgID. Combining a number of image IDs by OR, updates all the related textures. Note that you first need to register the correponding OpenGL texture names with RxSetPar( EPar::Gl_*, iTexName ).


Enumerations

Namespaces
Enumerations
Raytrix Lightfield API

Lightfield API enumerations. More...

Namespaces

namespace | Rx::ApiLF::ECalibGridMode
Grid calibration modes for parameter CalibGrid_Mode.
namespace | Rx::ApiLF::ECameraTriggerMode
namespace | Rx::ApiLF::EDepthImageType
Depth image output type. Use these value for the parameter Depth_ImageType.
namespace | Rx::ApiLF::EError
Error IDs of Raytrix API.
namespace | Rx::ApiLF::EFeature
Values that represent EError.
namespace | Rx::ApiLF::EImgID
Internal image IDs.
namespace | Rx::ApiLF::EPar
This enum contains the parameters IDs for various library and camera parameters.
namespace | Rx::ApiLF::EParGrp
Parameter group IDs.
namespace | Rx::ApiLF::ERadDistType
Radial distortion types of raw images.
namespace | Rx::ApiLF::ERaySeqMode
Ray sequence file modes.
namespace | Rx::ApiLF::EStatusMessage
Values that represent EStatusCode.
namespace | Rx::ApiLF::EStatusMsgGrp
Values that represent EStatusCode.
namespace | Rx::ApiLF::EStatusSource
Values that represent EStatusCodeGroup.
namespace | Rx::ApiLF::EWarning
Values that represent EWarning.

Detailed Description

Lightfield API enumerations.


Rx::ApiLF::ECalibGridMode Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • ECalibGridMode
Enumerations
Rx::ApiLF::ECalibGridMode Namespace Reference
Enumerations

Grid calibration modes for parameter CalibGrid_Mode. More...

Enumerations

enum ID { PosScale = 0, PosScaleRot, Count }
Calibration modes More...

Detailed Description

Grid calibration modes for parameter CalibGrid_Mode.

Enumeration Type Documentation

enum Rx::ApiLF::ECalibGridMode::ID

Calibration modes

Perwass, 07.08.2012.

Enumerator
PosScale | Calibrate only center position of grid and microimage scale.
PosScaleRot | In addition to center position and microimage scale also calibrate the microimage grid angle.
Count | Number of calibration modes.


Rx::ApiLF::ECameraTriggerMode Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • ECameraTriggerMode
Enumerations
Rx::ApiLF::ECameraTriggerMode Namespace Reference
Enumerations

Enumerations

enum ID { None = 0, Camera_FreeRun = 0x0100, Software_SnapShot = 0x0200, Extern_Impulse = 0x0300 }
Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode. More...

Enumeration Type Documentation

enum Rx::ApiLF::ECameraTriggerMode::ID

Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode.

Perwass, 07.08.2012.

Enumerator
None |
Camera_FreeRun | The camera triggers new frames itself.
Software_SnapShot | The camera captures a single frame triggered by the software.
Extern_Impulse | The camera waits for an external trigger signal and records a single frame using the current exposure settings.


Rx::ApiLF::EDepthImageType Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EDepthImageType
Enumerations
Rx::ApiLF::EDepthImageType Namespace Reference
Enumerations

Depth image output type. Use these value for the parameter Depth_ImageType. More...

Enumerations

enum ID { Standard = 0, Virtual, Relative, Affine, Count }
Depth image types. More...

Detailed Description

Depth image output type. Use these value for the parameter Depth_ImageType.

Enumeration Type Documentation

enum Rx::ApiLF::EDepthImageType::ID

Depth image types.

Perwass, 07.08.2012.

Enumerator
Standard | The standard format in which depth data is stored internally. This format maps all depths to the range [0,1] and is comparable between different cameras. Note that for standard Raytrix cameras the effective depth range is [0.5,1].
Virtual | Virtual depths lie in the range [0,infinity] and basically give the number of microlenses each refocused point is seen in. The relation between standard and virtual depth is $d_{std} = 1 - 1 / d_{virt}$ .
Relative | The relative depth depends on the Raytrix camera that is used and maps the effective depth range of the camera to the range [0,1]. These depths are not necessarily comparable between different camera types, but they are well suited for displaying depth.
Affine | Under development! Do not use! The depth values are related to the metric depth values by a scalar factor. The result of this depth image depends on the values of the parameters Depth_Affine_Offset and Depth_Affine_FocalLength.
Count | Number of depth image types.


Rx::ApiLF::EError Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EError
Enumerations
Rx::ApiLF::EError Namespace Reference
Enumerations

Error IDs of Raytrix API. More...

Enumerations

enum ID {
NONE = 0, COMPUTE = -1, OUTOFMEMORY = -100, OUTOFRANGE = -101, INVALID_POINTER = -102, INSTALL = -103, INTERNAL = -104, API_INIT = -1000,
API_NOINIT = -1001, API_LOADFILE = -1002, API_INVALID_IMGID = -1003, API_NOLFIBOUND = -1004, API_INVALID_IMAGE = -1005, API_SAVEFILE = -1006, API_INITAGAIN = -1007, API_UNKNOWN = -1008,
API_INSTPATH = -1009, API_DONGLE = -1010, API_FEATURE = -1011, API_INVALID_GLTEX = -1012, API_INVALID_IMGTYPE = -1013, API_INVALID_VALUE = -1014, API_LFI_BIND = -1015, API_LFI_BOUND = -1016,
API_VERSION = -1017, PAR_EXIST = -2000, PAR_TYPE = -2001, PAR_ACSREAD = -2002, PAR_ACSWRITE = -2003, PAR_READ = -2004, PAR_WRITE = -2005, PAR_VALUE = -2006,
PAR_NOCONSTR = -2007, PAR_INVCONSTR = -2008, PAR_GRPEXIST = -2009, PAR_NOTSUPPORTED = -2010, PAR_NOTAVAILABLE = -2011, CUDA_MAX = -3000, CUDA_INIT = -3000, CUDA_NODEVICE = -3001,
CUDA_CAPA = -3002, CUDA_ALGO = -3003, CUDA_INITAGAIN = -3004, CUDA_NOINIT = -3005, CUDA_INVDEVID = -3006, CUDA_MIN = -3999, CAMDRV_INIT = -4000, CAMDRV_INITAGAIN = -4001,
CAMDRV_NOINIT = -4002, CAMDRV_INVCAMID = -4003, CAMERA_OPEN = -4100, CAMERA_CLOSE = -4101, CAMERA_STARTCAP = -4102, CAMERA_STOPCAP = -4103, CAMERA_CAPACTIVE = -4104, CAMERA_CAPNOTACTIVE = -4105,
CAMERA_CAPTURE = -4106, CAMERA_ACTIVE = -4107, CAMERA_NOTACTIVE = -4108, CAMERA_NOCALFILE = -4109, CAMERA_INVCALFILE = -4110, CAMERA_STORECALFILE = -4111, CAMERA_LENSSETNEW = -4112, CAMERA_LENSSETEXIST = -4113,
CAMERA_LENSSETDEL = -4114, CAMERA_LENSNEW = -4115, CAMERA_LENSIDEXIST = -4116, CAMERA_LENSDEL = -4117, CAMERA_STOREIMGWHITE = -4118, CAMERA_NOIMGWHITE = -4119, CAMERA_UPDATECALIB = -4120, CAMERA_SUSPENDCAP = -4121,
CAMERA_CALFILEEXIST = -4122, CAMERA_CREATECALFILE = -4123, CAMERA_LENSDEL_LAST_LENS = -4124, CAMERA_TIMEOUT = -4125, CAMERA_TRIGGERMODE_NOT_AVAILABLE = -4126, CAMERA_CAPTURE_STOPPED_UNEXPECTED = -4127, CAMERA_CAPTURE_EXCEPTION = -4128, CAMERA_CAPTURE_INTERNAL_API = -4129,
CAMCAL_NOLENS = -4200, CAMCAL_NOLENSSET = -4201, CAMCAL_INVLENSIDX = -4202, CAMCAL_INVLENSSETIDX = -4203, GL_NOINTEROP = -5000, GL_TEXNOTSUPPORTED = -5001, IMG_NOTSUPPORTED = -6000, IMG_DITNOTSUPPORTED = -6001,
RAYSEQ_OPENREAD = -7000, RAYSEQ_OPENWRITE = -7001, RAYSEQ_READ = -7002, RAYSEQ_WRITE = -7003, RAYSEQ_INVALID = -7004, RAYSEQ_VERSION = -7005, RAYSEQ_CLOSE = -7006, RAYSEQ_NOTOPEN = -7007,
RAYSEQ_EOF = -7008, RAYSEQ_SOF = -7009, RAYSEQ_COMPRESS = -7010, RAYSEQ_UNCOMPRESS = -7011, RAYSEQ_UNKOWNCOMP = -7012, RAYSEQ_UNSUPPIXTYPE = -7013, RAYSEQ_WHITEIMAGE = -7014, RAYSEQ_BIND = -7015,
RAYSEQ_IMAGEFORMAT = -7016, RAYSEQ_WRITEINIT = -7017, RAYSEQ_SETFRAMEIDX = -7018, RAYSEQ_AUTOWRITE = -7094, RAYSEQ_NOREAD = -7095, RAYSEQ_NOWRITE = -7096, RAYSEQ_NOT_BOUND = -7097, RAYSEQ_ALREADY_BOUND = -7098,
RAYSEQ_INVALID_ID = -7099, RAYSEQ_INTERNAL = -7100
}
Error IDs. More...

Detailed Description

Error IDs of Raytrix API.

If an API function returns false, information on the error that occured can be obtained by calling RxGetLastError(). The returned error string contains a standard error text, plus additional information separated by colons (':').

Enumeration Type Documentation

enum Rx::ApiLF::EError::ID

Error IDs.

Perwass, 07.08.2012.

Enumerator
NONE | No Error.
COMPUTE | Error in internal computation.
OUTOFMEMORY | Out of memory.
OUTOFRANGE | One of the given parameters is out of range.
INVALID_POINTER | A given pointer is invalid.
INSTALL | Installation is corrupted.
INTERNAL | Internal error. This should not happen. If it does, please report to info@.nosp@m.rayt.nosp@m.rix.d.nosp@m.e.
API_INIT | Error initializing Raytrix API.
API_NOINIT | Raytrix API not initialized.
API_LOADFILE | Error loading file.
API_INVALID_IMGID | Invalid image ID.
API_NOLFIBOUND | No light field image bound.
API_INVALID_IMAGE | Given image is invalid.
API_SAVEFILE | Error saving file.
API_INITAGAIN | Raytrix API already initialized.
API_UNKNOWN | Unexpected error in Raytrix API. This should not happen. If it does, please report to info@.nosp@m.rayt.nosp@m.rix.d.nosp@m.e.
API_INSTPATH | Raytrix API installation path not found in registry.
API_DONGLE | Invalid dongle or no dongle found.
API_FEATURE | Feature not supported by current dongle licence.
API_INVALID_GLTEX | Given GL texture is invalid.
API_INVALID_IMGTYPE | Given image is of invalid type.
API_INVALID_VALUE | Invalid parameter.
API_LFI_BIND | Error binding light field image.
API_LFI_BOUND | Ray image currently bound.
API_VERSION | Current dongle does not support this API version.
PAR_EXIST | Parameter does not exist.
PAR_TYPE | Wrong data type for parameter.
PAR_ACSREAD | Parameter has no read access.
PAR_ACSWRITE | Parameter has no write access.
PAR_READ | Error reading parameter.
PAR_WRITE | Error writing parameter.
PAR_VALUE | Invalid parameter value.
PAR_NOCONSTR | Parameter has no constraint.
PAR_INVCONSTR | Parameter constraint is of different type.
PAR_GRPEXIST | Parameter group does not exist.
PAR_NOTSUPPORTED | Parameter not supported.
PAR_NOTAVAILABLE | Parameter not available.
CUDA_MAX | Minimal CUDA error number.
CUDA_INIT | Error initializing CUDA.
CUDA_NODEVICE | No CUDA device present.
CUDA_CAPA | Insufficient CUDA compute capability.
CUDA_ALGO | Error in CUDA algorithm.
CUDA_INITAGAIN | CUDA device already selected.
CUDA_NOINIT | CUDA not initialized.
CUDA_INVDEVID | Invalid CUDA device ID.
CUDA_MIN | Maximal CUDA error number.
CAMDRV_INIT | Error initializing camera drivers.
CAMDRV_INITAGAIN | Camera drivers already initialized.
CAMDRV_NOINIT | Camera drivers not initialized.
CAMDRV_INVCAMID | Invalid camera ID.
CAMERA_OPEN | Error opening camera.
CAMERA_CLOSE | Error closing camera.
CAMERA_STARTCAP | Error starting camera capture.
CAMERA_STOPCAP | Error stopping camera capture.
CAMERA_CAPACTIVE | Camera capture already active.
CAMERA_CAPNOTACTIVE | Camera capture not active.
CAMERA_CAPTURE | Error capturing image from camera device.
CAMERA_ACTIVE | Camera is already active.
CAMERA_NOTACTIVE | Camera is not active.
CAMERA_NOCALFILE | Camera calibration file not found.
CAMERA_INVCALFILE | Invalid camera calibration file.
CAMERA_STORECALFILE | Error storing camera calibration data in file.
CAMERA_LENSSETNEW | Error creating new calibration lens setting.
CAMERA_LENSSETEXIST | Lens setting already exists.
CAMERA_LENSSETDEL | Error deleting lens setting.
CAMERA_LENSNEW | Error creating new calibration lens data.
CAMERA_LENSIDEXIST | Lens ID already exists.
CAMERA_LENSDEL | Error deleting lens data.
CAMERA_STOREIMGWHITE | Error storing calibration white image.
CAMERA_NOIMGWHITE | No white image available for calibration setting.
CAMERA_UPDATECALIB | Error updating camera calibration.
CAMERA_SUSPENDCAP | Error suspending camera capture.
CAMERA_CALFILEEXIST | Camera calibration file already exists.
CAMERA_CREATECALFILE | Camera calibration file could not be created.
CAMERA_LENSDEL_LAST_LENS | Error deleting lens data (Last available lens)
CAMERA_TIMEOUT | Camera timeout.
CAMERA_TRIGGERMODE_NOT_AVAILABLE | The selected camera trigger mode is not available for the current camera.
CAMERA_CAPTURE_STOPPED_UNEXPECTED | Camera stopped capturing images unexpectedly. Capturing had not been stopped through API.
CAMERA_CAPTURE_EXCEPTION | Exception during camera capture.
CAMERA_CAPTURE_INTERNAL_API | Internal error in API during image capture.
CAMCAL_NOLENS | No lens defined in camera calibration file.
CAMCAL_NOLENSSET | No lens setting defined for currently selected lens in camera calibration file.
CAMCAL_INVLENSIDX | Invalid lens index for camera calibration.
CAMCAL_INVLENSSETIDX | Invalid lens setting index for currently selected lens for camera calibration.
GL_NOINTEROP | Cuda/OpenGL interoperability not available.
GL_TEXNOTSUPPORTED | Texture ID not supported.
IMG_NOTSUPPORTED | Internal image with given ID not supported.
IMG_DITNOTSUPPORTED | Depth image type not supported.
RAYSEQ_OPENREAD | Error opening ray sequence for reading.
RAYSEQ_OPENWRITE | Error opening ray sequence for writing.
RAYSEQ_READ | Error reading from ray sequence.
RAYSEQ_WRITE | Error writing to ray sequence.
RAYSEQ_INVALID | The file is not a ray sequence file.
RAYSEQ_VERSION | Can not read this ray sequence file type version.
RAYSEQ_CLOSE | Error closing ray sequence.
RAYSEQ_NOTOPEN | Ray sequence file not open.
RAYSEQ_EOF | Ray sequence end of file.
RAYSEQ_SOF | Ray sequenece start of file.
RAYSEQ_COMPRESS | Error compressing frame in ray sequence.
RAYSEQ_UNCOMPRESS | Error uncompressing frame in ray sequence.
RAYSEQ_UNKOWNCOMP | Unknown compression type in ray sequence.
RAYSEQ_UNSUPPIXTYPE | Unsupported ray sequence pixel type.
RAYSEQ_WHITEIMAGE | Invalid ray sequence white image.
RAYSEQ_BIND | Error binding ray sequence.
RAYSEQ_IMAGEFORMAT | The image format of the ray sequence is incompatible with that of the given image.
RAYSEQ_WRITEINIT | Error initializing ray sequence for writing.
RAYSEQ_SETFRAMEIDX | Error setting frame index in ray sequence.
RAYSEQ_AUTOWRITE | Auto write mode is active.
RAYSEQ_NOREAD | Ray sequence is not in read mode.
RAYSEQ_NOWRITE | Ray sequence is not in write mode.
RAYSEQ_NOT_BOUND | No ray sequence is bound.
RAYSEQ_ALREADY_BOUND | A ray sequence is already bound.
RAYSEQ_INVALID_ID | Invalid ray sequence id.
RAYSEQ_INTERNAL | Internal ray sequence error.


Rx::ApiLF::EFeature Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EFeature
Enumerations
Rx::ApiLF::EFeature Namespace Reference
Enumerations

Values that represent EError. More...

Enumerations

enum ID { None = 0, Standard = 0x0001, MultiView = 0x0002, FocusOnSurface = 0x0004, Calculate3D = 0x0008, Calibrate = 0x0010, RawImage = 0x0020, Save = 0x0040 }
Available features of the lightfield API. More...

Detailed Description

Values that represent EError.

Enumeration Type Documentation

enum Rx::ApiLF::EFeature::ID

Available features of the lightfield API.

Perwass, 24.07.2012.

Enumerator
None | No feature.
Standard | Test whether a dongle is present. Check with RxHasFeature().
MultiView | Multiview feature. All functions that allow the generation of images from different viewpoints only run if this feature is enabled. Check availability with RxHasFeature().
FocusOnSurface | Focus on surface. All functions that use a focus surface to generate an output are only available if this feature is enabled. Check availability with RxHasFeature().
Calculate3D | Calculate 3D depth. All functions that evaluate the scene depth are only available if this feature is enabled. Check availability with RxHasFeature().
Calibrate | Calibration. All functions that modify the calibration of a lightfield or a Raytrix camera are only available if this feature is enabled. Check availability with RxHasFeature().
RawImage | Raw image. All functions that output the raw lightfield image are only available if this feature is enabled. Check availability with RxHasFeature().
Save | Save images. All functions that save a lightfield image are only available if this feature is enabled. Check availability with RxHasFeature().


Rx::ApiLF::EImgID Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EImgID
Enumerations
Rx::ApiLF::EImgID Namespace Reference
Enumerations

Internal image IDs. More...

Enumerations

enum ID {
None = 0x0000, Ray = 0x0001, RayDepth = 0x0002, Focus = 0x0004, FocusLeft = 0x0004, FocusRight = 0x0008, Depth = 0x0010, DepthLeft = 0x0010,
DepthRight = 0x0020, DepthCol = 0x0040, DepthColLeft = 0x0040, DepthColRight = 0x0080, RayGrid = 0x0100, RayProc = 0x0200, RayWhite = 0x0400
}
Image IDs. More...

Detailed Description

Internal image IDs.

Enumeration Type Documentation

enum Rx::ApiLF::EImgID::ID

Image IDs.

Perwass, 07.08.2012.

Enumerator
None |
Ray | Internal ray image.
RayDepth | Internal ray depth image.
Focus | Internal focus result image.
FocusLeft | Internal focus result image for left view.
FocusRight | Internal focus result image for right view.
Depth | Internal depth result image.
DepthLeft | Internal depth result image for left view.
DepthRight | Internal depth result image for right view.
DepthCol | Internal depth color result image.
DepthColLeft | Internal depth color result image for left view.
DepthColRight | Internal depth color result image for right view.
RayGrid | Internal grid result image.
RayProc | Internal pocessed ray image.
RayWhite | Internal ray calibration (white) image.


Rx::ApiLF::EPar Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EPar
Enumerations
Rx::ApiLF::EPar Namespace Reference
Enumerations

This enum contains the parameters IDs for various library and camera parameters. More...

Enumerations

enum ID {
None = 0, Cuda_DeviceName = 0x00010000, Cuda_DeviceID, Cuda_CapaMajor, Cuda_CapaMinor, Cuda_VersionRuntime, Cuda_VersionDriver, Cuda_TotalGlobalMem,
Cuda_RegsPerBlock, Cuda_WarpSize, Cuda_MemPitch, Cuda_MaxThreadsPerBlock, Cuda_TotalConstMem, Cuda_DeviceOverlap, Cuda_MultiProcessorCount, Cuda_ComputeMode,
Cuda_MaxTex2DSizeX, Cuda_MaxTex2DSizeY, Cuda_MaxTex2DArraySizeX, Cuda_MaxTex2DArraySizeY, Cuda_ConcurrentKernels, Cuda_TCCDriver, Cam_Count = 0x00020000, Cam_Name,
Cam_Type, Cam_ID, Cam_Exposure, Cam_TapBalance, Cam_Gain, Cam_GainRed, Cam_GainGreen, Cam_GainBlue,
Cam_IsColor, Cam_IsBayer, Cam_Width, Cam_Height, Cam_OffsetX, Cam_OffsetY, Cam_AutoUpdateGlTex, Cam_FramesPerSecond,
Cam_ActualFramesPerSecond, Cam_Focus, Cam_Iris, Cam_Func_CalibMainLens, Cam_TapBalanceMode, Cam_PIVMode, Cam_IsOpen, Cam_IsCapturing,
Cam_Temperature, Cam_TriggerMode, CamCal_LensCnt = 0x00030000, CamCal_LensSetCnt, CamCal_LensIdx, CamCal_LensSetIdx, CamCal_LensName, CamCal_LensID,
CamCal_LensSetFStop, CamCal_LensSetFocus, CamCal_MainLensIris, CamCal_MainLensFocus, CamCap_Timeout_Video = 0x0003F000, CamCap_Timeout_Single, CamCap_Timeout_Extern, CamCap_Frames_Lost = 0x0003F020,
CamCap_AutoLum_MaxSaturatedPixelPercentage = 0x0003F100, CamCap_AutoGain_Enabled = 0x0003F200, CamCap_AutoGain_Active, CamCap_AutoGain_MinValue, CamCap_AutoGain_MaxValue, CamCap_AutoExposure_Enabled = 0x0003F300, CamCap_AutoExposure_Active, CamCap_AutoExposure_MinValue,
CamCap_AutoExposure_MaxValue, Ray_Width = 0x00040000, Ray_Height, Ray_PixelType, Ray_DataType, Ray_ApplyWhiteImage, Ray_ConvBayer, Ray_MLI_Rotation,
Ray_MLI_Diameter, Ray_MLI_Border, Ray_MLI_OffsetX, Ray_MLI_OffsetY, Ray_MLI_PixelSizeX, Ray_MLI_PixelSizeY, Ray_MLI_BaseRotation, Ray_MLI_BaseReflectX,
Ray_MLI_BaseReflectY, Ray_MLI_BaseVecXX, Ray_MLI_BaseVecXY, Ray_MLI_BaseVecYX, Ray_MLI_BaseVecYY, Ray_MLI_SubGridBaseX, Ray_MLI_SubGridBaseY, Ray_MLI_LensTypeCount,
Ray_MLI_LensTypeIdx, Ray_MLI_LensTypeVirtDepthMin, Ray_MLI_LensTypeVirtDepthMax, Ray_MLI_LensTypeOffsetX, Ray_MLI_LensTypeOffsetY, Ray_MLI_RadDistType, Ray_MLI_RadDistParCnt, Ray_MLI_RadDistOffsetX,
Ray_MLI_RadDistOffsetY, Ray_MLI_RadDistPar1, Ray_MLI_RadDistPar2, Ray_MLI_RadDistPar3, Ray_MLI_RadDistPar4, Ray_MLI_RadDistPar5, Ray_MLI_NeedWhiteImage, Ray_ApplyFileSettings = 0x00047000,
Gl_TexRayID = 0x00050000, Gl_TexFocusLeftID, Gl_TexFocusRightID, Gl_TexDepthLeftID, Gl_TexDepthRightID, Gl_TexDepthColLeftID, Gl_TexDepthColRightID, Gl_TexGridID,
Gl_TexFocusLeftID2, Gl_TexFocusRightID2, Gl_TexRayProcID, Gl_TexRayWhiteID, Gl_TexRayDepthID, RaySeq_AutoStoreCamFrames = 0x00060000, RaySeq_ApplyFileSettings, RaySeq_AutoStoreCamFrameCnt,
PreProc_Std_Enable = 0x00100000, PreProc_Std_Brightness, PreProc_Std_ContrastCenter, PreProc_Std_ContrastScale, PreProc_Sharp1_Enable = 0x00102000, PreProc_Sharp1_BlurStdDev, PreProc_Sharp1_Factor, PreProc_Sharp1_OnlyCalc,
PreProc_Demosaic_Enable = 0x00104000, PreProc_Demosaic_R, PreProc_Demosaic_G, PreProc_Demosaic_B, PreProc_DenoiseNLM_Enable = 0x00105000, PreProc_DenoiseNLM_FilterDia, PreProc_DenoiseNLM_NoiseLevel, PreProc_DenoiseNLM_BlendFactor,
Depth_Algo = 0x00200000, Depth_ResImgDiv, Depth_ImageType, Depth_DefaultValue, Depth_Affine_Offset = 0x00201000, Depth_Affine_FocalLength, Depth_Std_BlockCnt = 0x00202000, Depth_Std_PatchRad,
Depth_Std_MedianRad, Depth_Std_MeanRad, Depth_Std_SizeDiv, Depth_Std_MinTrust, Depth_Std_MaxInvCor, Depth_Std_MinStdDev, Depth_Std_PixelStep, Depth_Std_RawMedianRad,
Depth_Std_RawMeanRad, Depth_Std_RawMeanMaxBlackPart, Depth_Std_Fuse_DepthDeltaMax, Depth_Std_Fuse_DepthOptRangeMax, Depth_Path_BlockCnt = 0x00203000, Depth_Path_NearResLevel, Depth_Path_SparseLensSet, Depth_Path_MaxVirtDepth,
Depth_Path_LensTypeIdx = 0x00203100, Depth_Path_LT_PixelStep, Depth_Path_LT_MinStdDev, Depth_Path_LT_MinCor, Depth_Path_LT_MinPolyParAbs, Depth_Path_LT_MaxPolyCtrDelta, Depth_Path_LT_PatchDia, Depth_Path_LT_PatchStride,
Depth_PathPiv_BlockCnt = 0x00203200, Depth_PathPiv_NearResLevel, Depth_PathPiv_LensTypeIdx = 0x00203300, Depth_PathPiv_LT_PixelStep, Depth_PathPiv_LT_MinCor, Depth_PathPiv_LT_BPSigma, Depth_PathPiv_LT_BPMinCor, Depth_PathPiv_LT_BPMinMean,
Depth_PathPiv_LT_MinPolyParAbs, Depth_PathPiv_LT_MaxPolyCtrDelta, Depth_PathPiv_LT_PatchDia, Depth_PathPiv_LT_PatchStride, Depth_Fuse_MedianRad = 0x00205000, Depth_Fuse_MeanRad, Depth_Fuse_MeanMaxBlackPart, Depth_Fuse_LensTypeIdx = 0x00205100,
Depth_Fill_Enabled = 0x00207000, Depth_Fill_IterCnt, Depth_Fill_IterSize, Depth_Fill_Complete, Depth_Fill_MedianRad, Depth_Fill_MeanRad, Depth_Fill_NLM_Enabled, Depth_Fill_NLM_FilterDia,
Depth_Fill_NLM_NoiseLevel, Depth_Fill_NLM_BlendFactor, Depth_Fill_Bilateral_Enabled, Depth_Fill_Bilateral_FilterRad, Depth_Fill_Bilateral_SigmaR, Depth_Fill_Bilateral_SigmaS, Focus_ResImgDiv = 0x00220000, Focus_MaxLensContribRad,
Focus_ViewOffset_VirtDepthMin, Focus_ViewOffset_VirtDepthMax, Focus_ViewOffset_Gamma, Focus_ViewOffset_Radial, Focus_ViewOffset_VirtDepthCollPlane, Focus_ViewOffset_X, Focus_ViewOffset_Y, Focus_DefaultFocus,
Focus_Focus, Focus_Stereo_Enabled, Focus_Stereo_EyeSep, Focus_Stereo_Rot, Focus_DefocusBlur_Enable = 0x00221000, Focus_DefocusBlur_VirtDOF, Focus_DefocusBlur_Gradient, Focus_DefocusBlur_MaxBlurRad,
Focus_DefocusBlur_DefaultDepth, Grid_ResImgDiv = 0x00230000, Calib_Grid_Mode = 0x00240000
}
LF API parameters More...

Detailed Description

This enum contains the parameters IDs for various library and camera parameters.

There are three possible types the parameters can have: unsigned integer, double or string. Furthoremore, parameters can be read-only (RO), write-only (WO) or read-write (RW). The parameter type and the access type are indicated for each parameter.

Enumeration Type Documentation

enum Rx::ApiLF::EPar::ID

LF API parameters

Perwass, 07.08.2012.

Enumerator
None
Cuda_DeviceName

The name of the cuda device (string, RO)

Cuda_DeviceID

The device ID of the selected CUDA device (unsigned, RO)

Cuda_CapaMajor

The compute capability major version (unsigned, RO)

Cuda_CapaMinor

The compute capability minor version (unsigned, RO)

Cuda_VersionRuntime

CUDA device runtime version.

Cuda_VersionDriver

CUDA device driver version.

Cuda_TotalGlobalMem

CUDA device total global memory.

Cuda_RegsPerBlock

CUDA device registers per block.

Cuda_WarpSize

CUDA device warp size.

Cuda_MemPitch

CUDA device memory pitch.

Cuda_MaxThreadsPerBlock

CUDA device maximal number of threads per block.

Cuda_TotalConstMem

CUDA device total constant memory.

Cuda_DeviceOverlap

CUDA device concurrent memory copy and kernel execution.

Cuda_MultiProcessorCount

CUDA device number of processors.

Cuda_ComputeMode

CUDA device compute mode.

Cuda_MaxTex2DSizeX

CUDA device maximum 2D texture size x-dimension.

Cuda_MaxTex2DSizeY

CUDA device maximum 2D texture size y-dimension.

Cuda_MaxTex2DArraySizeX

CUDA device maximum 2D array texture size x-dimension.

Cuda_MaxTex2DArraySizeY

CUDA device maximum 2D array texture size y-dimension.

Cuda_ConcurrentKernels

CUDA device can execute kernels concurrently.

Cuda_TCCDriver

CUDA device is a Tesla device using a TCC driver.

Cam_Count

Number of cameras available (unsigned, RO)

Cam_Name

(deprecated, returns same value as Cam_Type) Name of a camera (string, RO)

Cam_Type

Camera type (string, RO)

Cam_ID

Camera ID (string, RO)

Cam_Exposure

Camera exposure in milliseconds (double, RW)

Cam_TapBalance
Cam_Gain

Camera gain in range [0,100] (double, RW)

Cam_GainRed

Camera gain for red color channel in range [0,100] (double, RW)

Cam_GainGreen

Camera gain for green color channel in range [0,100] (double, RW)

Cam_GainBlue

Camera gain for blue color channel in range [0,100] (double, RW)

Cam_IsColor

If camera is a color camera this is set to 1, otherwise to 0 (unsigned, RO)

Cam_IsBayer

If camera is in bayer mode this is set to 1, otherwise to 0 (unsigned, RO)

Cam_Width

Width of image returned by camera (unsigned, RO)

Cam_Height

Height of image returned by camera (unsigned, RO)

Cam_OffsetX

Offset in X-direction (unsigned, RO)

Cam_OffsetY

Offset in Y-direction (unsigned, RO)

Cam_AutoUpdateGlTex

Automatically update ray image texture (unsigned, RW)

Cam_FramesPerSecond

Target for captured frames per second.

Cam_ActualFramesPerSecond

Actual captured frames per second.

Cam_Focus

Main lens focus setting (double, RW)

Cam_Iris

Main lens iris setting (double, RW)

Cam_Func_CalibMainLens

Execute main lens calibration for controllable lenses (unsigned, RW)

Cam_TapBalanceMode

Tap Balance Mode.

Cam_PIVMode

PIV Mode (unsigned, RW)

Cam_IsOpen

Test whether a camera is open (unsigned, RO)

Cam_IsCapturing

Test whether a camera is in capture mode (unsigned, RO)

Cam_Temperature

Temperature of camera (double, RO)

Cam_TriggerMode

Sets the camera trigger mode. This replaces the old Cam_IsVideoMode. See ECameraTriggerMode for the available trigger modes. (unsigned, RW)

CamCal_LensCnt

Number of lenses stored in camera calibration database (unsigned, RO)

CamCal_LensSetCnt

Number of lens settings stored for currently selected lens in camera calibration database (unsigned, RO)

CamCal_LensIdx

The currently selected lens in the camera calibration database (unsigned, RW)

CamCal_LensSetIdx

The currently selected lens setting in the camera calibration database (unsigned, RW)

CamCal_LensName

The name of the currently selected lens (string, RW)

CamCal_LensID

The ID of the currently selected lens (string, RO)

CamCal_LensSetFStop

The f-stop value of the currently selected lens setting (double, RO)

CamCal_LensSetFocus

The focus value of the currently selected lens setting (double, RO)

CamCal_MainLensIris

The internal iris setting of the main lens for controllable lenses, of the currently selected lens setting (double, RW)

CamCal_MainLensFocus

The internal focus setting of the main lens for controllable lenses, of the currently selected lens setting (double, RW)

CamCap_Timeout_Video

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in video mode. Default is zero. (unsigned, RW)

CamCap_Timeout_Single

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in single capture mode. Default is 10000. (unsigned, RW)

CamCap_Timeout_Extern

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in external trigger mode. Default is zero. (unsigned, RW)

CamCap_Frames_Lost

Number of lost frames since last image capture start.

CamCap_AutoLum_MaxSaturatedPixelPercentage

The maximal percentage of pixels that are allowed to be overexposed before the luminance (gain and/or shutter) is reduced (double, [0.0, 10.0], RW).

CamCap_AutoGain_Enabled

If set to 1 auto gain is enabled. Captured images are processed by the API and the camera gain is adjusted appropriately. (unsigned, [0,1], RW)

CamCap_AutoGain_Active

This value is set by the API to indicate whether the auto gain algorithm is currently adapting the camera gain. (unsigned, [0,1], RO)

CamCap_AutoGain_MinValue

The minimal gain value set by the auto gain. (unsigned, [0, 100], RW)

CamCap_AutoGain_MaxValue

The maximal gain value set by the auto gain. (unsigned, [0, 100], RW)

CamCap_AutoExposure_Enabled

If set to 1 auto exposure is enabled. Captured images are processed by the API and the camera shutter speed is adjusted appropriately. (unsigned, [0,1], RW)

CamCap_AutoExposure_Active

This value is set by the API to indicate whether the auto gain algorithm is currently adapting the camera exposure time. (unsigned, [0,1], RO).

CamCap_AutoExposure_MinValue

The minimal exposure time in milliseconds. (double, [0, 1000000], RW)

CamCap_AutoExposure_MaxValue

The maximal exposure time in milliseconds. (double, [0, 1000000], RW)

Ray_Width

The width of the currently bound ray image (unsigned, RO)

Ray_Height

The height of the currently bound ray image (unsigned, RO)

Ray_PixelType

The pixel type of the currently bound ray image (unsigned, RO)

Ray_DataType

The data type of the currently bound ray image (unsigned, RO)

Ray_ApplyWhiteImage

Flag whether to apply a white image to the raw ray image or not (unsigned, RW)

Ray_ConvBayer

Flag whether to apply.

Ray_MLI_Rotation

MLA rotation anti-clockwise in radians (double, RW)

Ray_MLI_Diameter

Diameter in pixels of microimage of central microlens (double, RW)

Ray_MLI_Border

Microimage border in pixels (double, RW)

Ray_MLI_OffsetX

X-offset of center of central microimage from image center in pixels (double, RW)

Ray_MLI_OffsetY

Y-offset of center of central microimage from image center in pixels (double, RW)

Ray_MLI_PixelSizeX

Horizontal size of pixel on image sensor in mm (double, RW)

Ray_MLI_PixelSizeY

Vertical size of pixel on image sensor in mm (double, RW)

Ray_MLI_BaseRotation

Base rotation of the MLA as number of 90 degree steps (unsigned, RW)

Ray_MLI_BaseReflectX

Flag whether lens grid is reflected in x-axis (unsigned, RW)

Ray_MLI_BaseReflectY

Flag whether lens grid is reflected in y-axis (unsigned, RW)

Ray_MLI_BaseVecXX

X-component of basis vector of neighboring lenses in x-direction in lens units (double, RW)

Ray_MLI_BaseVecXY

Y-component of basis vector of neighboring lenses in x-direction in lens units (double, RW)

Ray_MLI_BaseVecYX

X-component of basis vector of neighboring lenses in y-direction in lens units (double, RW)

Ray_MLI_BaseVecYY

Y-component of basis vector of neighboring lenses in y-direction in lens units (double, RW)

Ray_MLI_SubGridBaseX

X-component of vector between orthogonal sub grids in lens units (double, RW)

Ray_MLI_SubGridBaseY

Y-component of vector between orthogonal sub grids in lens units (double, RW)

Ray_MLI_LensTypeCount

Number of different lens types. Changing this value also changes the values of Ray_MLI_SubGridBaseX, Ray_MLI_SubGridBaseY, Ray_MLI_BaseVecXX, Ray_MLI_BaseVecXY, Ray_MLI_BaseVecYX, Ray_MLI_BaseVecYY, Ray_MLI_LensTypeOffsetX, Ray_MLI_LensTypeOffsetY appropriately. (unsigned, RW)

Ray_MLI_LensTypeIdx

Currently selected lens type (unsigned, RW)

Ray_MLI_LensTypeVirtDepthMin

Minimal virtual depth of currently selected lens type (double, RW)

Ray_MLI_LensTypeVirtDepthMax

Maximal virtual depth of currently selected lens type (double, RW)

Ray_MLI_LensTypeOffsetX

X-offset to currently selected lens type central lens in lens units (double, RW)

Ray_MLI_LensTypeOffsetY

Y-offset to currently selected lens type central lens in lens units (double, RW)

Ray_MLI_RadDistType

Radial Distortion Type of microimages (unsigned, RW)

Ray_MLI_RadDistParCnt

Number of parameters used in radial distortion (unsigned, RW)

Ray_MLI_RadDistOffsetX

X-offset of radial distortion center from image center (double, RW)

Ray_MLI_RadDistOffsetY

Y-offset of radial distortion center from image center (double, RW)

Ray_MLI_RadDistPar1
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar2
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar3
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar4
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar5
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_NeedWhiteImage

Flag whether raw image needs white image to obtain proper processed raw image (unsigned, [0,1], RW)

Ray_ApplyFileSettings

Flag whether parameter settings stored in ray file are applied when loading image (unsigned, [0,1], RW)

Gl_TexRayID

OpenGL texture name for ray image (unsigned, WO)

Gl_TexFocusLeftID

OpenGL texture name for standard focus and left focus image (unsigned, WO)

Gl_TexFocusRightID

OpenGL texture name for right focus image (unsigned, WO)

Gl_TexDepthLeftID

OpenGL texture name for standard depth and left depth image (unsigned, WO)

Gl_TexDepthRightID

OpenGL texture name for right depth image (unsigned, WO)

Gl_TexDepthColLeftID

OpenGL texture name for standard depth color and left depth color image (unsigned, WO)

Gl_TexDepthColRightID

OpenGL texture name for right depth color image (unsigned, WO)

Gl_TexGridID

OpenGL texture name for grid image (unsigned, WO)

Gl_TexFocusLeftID2
  1. OpenGL texture name for standard focus and left focus image (unsigned, WO)
Gl_TexFocusRightID2
  1. OpenGL texture name for right focus image (unsigned, WO)
Gl_TexRayProcID

OpenGL texture name for processed raw image.

Gl_TexRayWhiteID

OpenGL texture name for raw white image.

Gl_TexRayDepthID

OpenGL texture name for raw depth image.

RaySeq_AutoStoreCamFrames

Automatically store frames captured from a camera into the bound ray sequence in write mode (unsigned, RW)

RaySeq_ApplyFileSettings

Flag whether parameter settings stored in ray sequence file are applied when loading sequence (unsigned, [0,1], RW)

RaySeq_AutoStoreCamFrameCnt

Number of frames that are stored when RaySeq_AutoStoreCamFrames is set to 1. If value is zero, then there is no limit on the number of frames stored. If value is larger than zero, the value is decremented for each frame recorded. When the value reaches zero, RaySeq_AutoStoreCamFrames is set to zero and no more frames are stored. (unsigned, [0,max], RW)

PreProc_Std_Enable

Enable Standard Preprocessing of ray image (unsigned, RW)

PreProc_Std_Brightness

Standard preprocessing: brightness gain [0,1e5] (double, RW)

PreProc_Std_ContrastCenter

Standard preprocessing: contrast center [0,1] (double, RW)

PreProc_Std_ContrastScale

Standard preprocessing: contrast scale [0,2] (double, RW)

PreProc_Sharp1_Enable

Enable sharpness algortithm 1: unsharp masking (unsigned, RW)

PreProc_Sharp1_BlurStdDev

Sharpness Algo1: Standard deviation of Gauss blurred image [0,10] (double, RW)

PreProc_Sharp1_Factor

Sharpness Algo1: Mixing factor of blurred image with original image as pixel * factor + blurred * (1 - factor). [-2,3] (double, RW)

PreProc_Sharp1_OnlyCalc

Use sharpness only for depth calculation (not for output image) (unsigned, RW)

PreProc_Demosaic_Enable

Enable demosaic balance parameters (unsigned, RW)

PreProc_Demosaic_R

Red balance [0,1] (double, RW)

PreProc_Demosaic_G

Green balance [0,1] (double, RW)

PreProc_Demosaic_B

Blue balance [0,1] (double, RW)

PreProc_DenoiseNLM_Enable

Enable Non-Local-Means denoising of raw image (unsigned, [0,1], RW)

PreProc_DenoiseNLM_FilterDia

Denoise filter diameter in pixels (unsigned, [2,8], RW)

PreProc_DenoiseNLM_NoiseLevel

Noise level (double, [0.01, 2.0], RW)

PreProc_DenoiseNLM_BlendFactor

Blending factor (double, [0, 0.3], RW)

Depth_Algo

Depth evaluation algorithm type name. (string, ["standard", "depth_path", "depth_path_piv"], RW)

Depth_ResImgDiv

Result image size divisor for depth evaluation (double, [2.0, 10.0], RW)

Depth_ImageType

Depth image output type. Valid values are listed in Rx::ApiLF::EDepthImageType::ID.

Depth_DefaultValue

Default depth value for output depth images. This value is used for all pixel, where the internal depth map has no result.

Depth_Affine_Offset

Under development! Do not use! Offset value for affine depth values in millimeter.

Depth_Affine_FocalLength

Under development! Do not use! Focal length of main lens in millimeter for calculation of affine depth.

Depth_Std_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_Std_PatchRad

Correlation patch radius (unsigned, [1,10], RW)

Depth_Std_MedianRad

Post process median radius (unsigned, [0,10], RW)

Depth_Std_MeanRad

Post process mean radius (unsigned, [0,10], RW)

Depth_Std_SizeDiv

Size divisor for ray depth image. Should be half the value of Depth_ResImgDiv (unsigned, [1,8], RW)

Depth_Std_MinTrust

Trust threashold (double, [0,1], RW)

Depth_Std_MaxInvCor

Maximal inverse correlation threshold (double, [0,1], RW)

Depth_Std_MinStdDev

Minimal standard deviation of correlation patch (double, [0,1], RW)

Depth_Std_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_Std_RawMedianRad

Post process raw depth image with median filter of given radius. Depth fusion is done after this filter. (unsigned, [0,5], RW)

Depth_Std_RawMeanRad

Post process raw depth image with mean filter of given radius. Depth fusion is done after this filter. (unsigned, [0,5], RW)

Depth_Std_RawMeanMaxBlackPart

Post process raw depth image with mean filter. Mean filter is only applied if the percentage of pixels with unknown depth does not exceed this limit. (double, [0,1], RW)

Depth_Std_Fuse_DepthDeltaMax

Maximum delta of depth values in depth fusion for the depth value to be considered as a result. (double, [0,1], RW)

Depth_Std_Fuse_DepthOptRangeMax

Maximum range of good depth fuse values whose delta lies below Depth_Std_Fuse_DepthDeltaMax. (double, [0,5], RW)

Depth_Path_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_Path_NearResLevel

The resolution level for near objects. The higher the number the finer the depth resolution for near objects. (unsigned, [2,5], RW)

Depth_Path_SparseLensSet

Flag whether to use a sparse set of microlenses to calculate depth. (unsigned, [0,1], RW)

Depth_Path_MaxVirtDepth

Maximum virtual depth for depth estimation (double, [6.0, 100.0], RW)

Depth_Path_LensTypeIdx

Current lens type for which parameter values are read/set (unsigned, [0, 11], RW). All parameters starting with Depth_Path_LT_ are influenced by this setting.

Depth_Path_LT_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_Path_LT_MinStdDev

Minimal standard deviation of correlation patch (double, [0,1], RW)

Depth_Path_LT_MinCor

Minimal correlation threshold (double, [0,1], RW)

Depth_Path_LT_MinPolyParAbs

Absolute polynom parameter threshold. The larger the value the stronger the extremum has to be to be accepted. (double, [0,1], RW)

Depth_Path_LT_MaxPolyCtrDelta

Maximum delta of polynom fit extremum position to central position (double, [0,1], RW)

Depth_Path_LT_PatchDia

Correlation patch radius (unsigned, [2,5], RW)

Depth_Path_LT_PatchStride

Correlation patch stride (unsigned, [1,5], RW)

Depth_PathPiv_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_PathPiv_NearResLevel

The resolution level for near objects. The higher the number the finer the depth resolution for near objects. (unsigned, [2,5], RW)

Depth_PathPiv_LensTypeIdx

Current lens type for which parameter values are read/set (unsigned, [0, 11], RW). All parameters starting with Depth_PathPiv_LT_ are influenced by this setting.

Depth_PathPiv_LT_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_PathPiv_LT_MinCor

Minimal correlation threshold (double, [0,1], RW)

Depth_PathPiv_LT_BPSigma

Standard deviation of Gauss intensity distribution of target base patch (double, [0.5, 10.0], RW)

Depth_PathPiv_LT_BPMinCor

Minimal correlation threshold with target base patch (double, [0,1], RW)

Depth_PathPiv_LT_BPMinMean

Minimal mean intensity threshold for base patch (double, [0,1], RW)

Depth_PathPiv_LT_MinPolyParAbs

Absolute polynom parameter threshold. The larger the value the stronger the extremum has to be to be accepted. (double, [0,1], RW)

Depth_PathPiv_LT_MaxPolyCtrDelta

Maximum delta of polynom fit extremum position to central position (double, [0,1], RW)

Depth_PathPiv_LT_PatchDia

Correlation patch radius (unsigned, [2,5], RW)

Depth_PathPiv_LT_PatchStride

Correlation patch stride (unsigned, [1,5], RW)

Depth_Fuse_MedianRad

Radius of median filter applied after fusion of raw depth image (unsigned, [0,10], RW)

Depth_Fuse_MeanRad

Radius of mean filter applied after fusion of raw depth image (unsigned, [0,10], RW)

Depth_Fuse_MeanMaxBlackPart

Mean filter is only applied for a black central pixel if the percentage of pixels within patch with unknown depth does not exceed this limit. (double, [0,1], RW)

Depth_Fuse_LensTypeIdx

The lens type to which the parameters starting with Depth_Fuse_LT_ relate to. (unsigned, [0,11], RW)

Depth_Fill_Enabled

Flag whether filling of depth map is enabled.

Depth_Fill_IterCnt

Number of iterations used for filling the depth map. (unsigned, [0,10], RW)

Depth_Fill_IterSize

Size of unknown depth border filled per iteration in pixels. (unsigned, [1, 100], RW)

Depth_Fill_Complete

Flag to indicate whether the remaining unknown depth areas are to be filled after the iterations. (unsigned, [0,1], RW)

Depth_Fill_MedianRad

Radius of median filter that is applied after filling the depth map. (unsigned, [0,4], RW)

Depth_Fill_MeanRad

Radius of mean filter that is applied after filling the depth map. (unsigned, [0,10], RW)

Depth_Fill_NLM_Enabled

Enable Denoise "Non Local Means" (NLM) algorithm after filling depth image (unsigned, [0,1], RW)

Depth_Fill_NLM_FilterDia

NLM filter diameter (unsigned, [2,8], RW)

Depth_Fill_NLM_NoiseLevel

NLM noise level (double, [0.01, 2.0], RW)

Depth_Fill_NLM_BlendFactor

NLM blend factor (double, [0,0.3], RW)

Depth_Fill_Bilateral_Enabled

Flag whether bilateral filtering of depth map is enabled. (unsigned, [0,1], RW)

Depth_Fill_Bilateral_FilterRad

Bilateral filter radius (unsigned, [1,20], RW)

Depth_Fill_Bilateral_SigmaR

Bilateral filter sigma R (edge) (double, [0.01,0.2], RW)

Depth_Fill_Bilateral_SigmaS

Bilateral filter sigma S (distance) (double, [1.0,20.0], RW)

Focus_ResImgDiv

Result image size division factor (double, RW)

Focus_MaxLensContribRad

Maximal radius in which lenses contribute to a resultant pixel (double, [1,10], RW)

Focus_ViewOffset_VirtDepthMin

Virtual Depth of furthest depth plane for view offset calculation (double, [1,30], RW)

Focus_ViewOffset_VirtDepthMax

Virtual Depth of closest depth plane for view offset calculation (double, [1,30], RW)

Focus_ViewOffset_Gamma

Gamma value for view offset function along z-direction (double, [0.1,10.0], RW)

Focus_ViewOffset_Radial

Radial view offset scale factor. (double, [-2,2], RW)

Focus_ViewOffset_VirtDepthCollPlane

Virtual depth of collimation plane. (double, [1,30], RW)

Focus_ViewOffset_X

View offset X. (double, [-1.0,1.0], RW)

Focus_ViewOffset_Y

View offset Y. (double, [-1.0,1.0], RW)

Focus_DefaultFocus

Default focus value. (double, [0.0,1.0], RW)

Focus_Focus

Focus value. (double, [0.0,1.0], RW)

Focus_Stereo_Enabled

Flag whether stereo view is enabled.

Focus_Stereo_EyeSep

Stereo eye separation. (double, [0.05,1.0], RW)

Focus_Stereo_Rot

Stereo image rotation. (double, [-180.0,180.0], RW)

Focus_DefocusBlur_Enable

Enable blurring of out-of-focus areas for focusing. (int, [0,1], RW)

Focus_DefocusBlur_VirtDOF

Depth of field for defocus blur as virtual depth delta (double, [0.0,100.0], RW)

Focus_DefocusBlur_Gradient

Gradient of defocus blur. Linear factor for blurring radius depending on virtual depth difference. (double, [0.1,100], RW)

Focus_DefocusBlur_MaxBlurRad

Maximum blur radius for defocusing. (int, [0,100], RW)

Focus_DefocusBlur_DefaultDepth

Default relative depth value used for areas where no depth could be calculated. (double, [0,1], RW)

Grid_ResImgDiv

Result image size division factor (double, RW)

Calib_Grid_Mode

Auto Grid calibration type (unsigned, RW)


Rx::ApiLF::EParGrp Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EParGrp
Enumerations
Rx::ApiLF::EParGrp Namespace Reference
Enumerations

Parameter group IDs. More...

Enumerations

enum ID {
None = 0, Cuda = 0x00010000, Camera = 0x00020000, CamCal = 0x00030000, CamCap = 0x0003F000, Ray = 0x00040000, Gl = 0x00050000, RaySeq = 0x00060000,
PreProc = 0x00100000, Depth = 0x00200000, Depth_Path = 0x00203000, Depth_PathPiv = 0x00203200, Focus = 0x00220000, Grid = 0x00230000, Calib = 0x00240000
}
Parameter group IDs. More...

Detailed Description

Parameter group IDs.

Enumeration Type Documentation

enum Rx::ApiLF::EParGrp::ID

Parameter group IDs.

Perwass, 07.08.2012.

Enumerator
None |
Cuda | CUDA parameter group.
Camera | Camera parameter group.
CamCal | Camera calibration parameter group.
CamCap | Camera capture parameter group.
Ray | Ray image parameter group.
Gl | OpenGL parameter group.
RaySeq | Ray sequence parameters.
PreProc | PreProcessing parameter group.
Depth | Depth evaluation parameter group.
Depth_Path | Depth Path algorithm.
Depth_PathPiv | Depth Path PIV algorithm.
Focus | Focus evaluation parameter group.
Grid | Grid display parameter group.
Calib | Calibration parameters.


Rx::ApiLF::ERadDistType Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • ERadDistType
Enumerations
Rx::ApiLF::ERadDistType Namespace Reference
Enumerations

Radial distortion types of raw images. More...

Enumerations

enum ID { Constant = 0, Polynom4, Inversion2 }
Radial image distortion types. More...

Detailed Description

Radial distortion types of raw images.

Enumeration Type Documentation

enum Rx::ApiLF::ERadDistType::ID

Radial image distortion types.

Perwass, 07.08.2012.

Enumerator
Constant | No radial distortion.
Polynom4 | Radial distortion with polynomial of degree 4.
Inversion2 | Radial distortion with inversion of degree 2.


Rx::ApiLF::ERaySeqMode Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • ERaySeqMode
Enumerations
Rx::ApiLF::ERaySeqMode Namespace Reference
Enumerations

Ray sequence file modes. More...

Enumerations

enum ID { None = 0x0000, Read = 0x0001, Write = 0x0002, Compress_Zip = 0x0100 }

Detailed Description

Ray sequence file modes.

    These enums can be used as a bit mask to combine various modes.

Perwass, 07.08.2012.

Enumeration Type Documentation

enum Rx::ApiLF::ERaySeqMode::ID
Enumerator
None | Empty ray sequence mode.
Read | A ray sequence opened for reading.
Write | A ray sequence opened for writing.
Compress_Zip | When writing to a ray sequence, compress frames with zip compression.


Rx::ApiLF::EStatusMessage Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EStatusMessage
Enumerations
Rx::ApiLF::EStatusMessage Namespace Reference
Enumerations

Values that represent EStatusCode. More...

Enumerations

enum ID {
None = 0, Debug = int(EStatusMsgGrp::Text), Info, Error, Assertion, Exception, Fatal, Warning,
Progress_Init = int(EStatusMsgGrp::Progress), Progress_Value, Progress_Step, Progress_Finished
}

Detailed Description

Values that represent EStatusCode.

Enumeration Type Documentation

enum Rx::ApiLF::EStatusMessage::ID
Enumerator
None |
Debug |
Info |
Error |
Assertion |
Exception |
Fatal |
Warning |
Progress_Init | The number of steps in the process is passed in the iValue parameter.
Progress_Value | The new value of the progress is passed in the iValue parameter.
Progress_Step | Increment the progress by the number passed in iValue.
Progress_Finished | Process is finished.


Rx::ApiLF::EStatusMsgGrp Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EStatusMsgGrp
Enumerations
Rx::ApiLF::EStatusMsgGrp Namespace Reference
Enumerations

Values that represent EStatusCode. More...

Enumerations

enum ID { None = 0, Text = 0x00010000, Progress = 0x00020000 }

Detailed Description

Values that represent EStatusCode.

Enumeration Type Documentation

enum Rx::ApiLF::EStatusMsgGrp::ID
Enumerator
None
Text
Progress


Rx::ApiLF::EStatusSource Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EStatusSource
Enumerations
Rx::ApiLF::EStatusSource Namespace Reference
Enumerations

Values that represent EStatusCodeGroup. More...

Enumerations

enum ID { Unknown = 0, API, Camera, CameraDriver, Compute, App }

Detailed Description

Values that represent EStatusCodeGroup.

Enumeration Type Documentation

enum Rx::ApiLF::EStatusSource::ID
Enumerator
Unknown |
API | Message originates from the API.
Camera | Messages originate from cameras.
CameraDriver |
Compute |
App |


Rx::ApiLF::EWarning Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • EWarning
Enumerations
Rx::ApiLF::EWarning Namespace Reference
Enumerations

Values that represent EWarning. More...

Enumerations

enum ID { NONE = 0, GENERAL = 1, CAMERA_CORRUPTDB = 4100, CAMERA_CAPTURE_NOIMAGE = 4101, CAMERA_INVWHITETYPE = 4102, CAMERA_CAPTURE_STOPPED = 4103, CAMERA_TYPE_MISMATCH = 4104 }

Detailed Description

Values that represent EWarning.

Enumeration Type Documentation

enum Rx::ApiLF::EWarning::ID
Enumerator
NONE | No Warning.
GENERAL | A function could finish successfully but issued a warning. The function returns with true but the last error is set to this value.
CAMERA_CORRUPTDB | Corrupted camera database has been corrected.
CAMERA_CAPTURE_NOIMAGE | No image currently available from camera.
CAMERA_INVWHITETYPE | Invalid white image type.
CAMERA_CAPTURE_STOPPED | Camera capturing has stopped while waiting for frame.
CAMERA_TYPE_MISMATCH | Camera's type does not match with current camera driver.


Lightfield Image API functions

Functions
Lightfield Image API functions
Raytrix Lightfield API

Functions for working with lightfield images. More...

Functions

RXLF_API bool | Rx::ApiLF::RxRayBind (unsigned hRay)
Bind a ray image to perform computations on. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibLoad (unsigned hRay, const Rx::CRxString &sxFilename)
Load calibration data of ray image from XML file. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibNew (unsigned hRay, int iLensTypeCount, double dLensDia, double dPixSize, double dOffsetX, double dOffsetY, double dRotDeg, double dLensBorder, int iRot90Cnt, bool bReflectX, bool bReflectY)
Create a new calibration data set. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibSave (unsigned hRay, const Rx::CRxString &sxFilename)
Save calibration data of ray image in XML format. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibXmlGet (unsigned hRay, Rx::CRxString &sxXml)
Get the calibration data of the given ray image as XML string. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibXmlSet (unsigned hRay, const Rx::CRxString &sxXml)
Set the calibration data of the given ray image from an XML string. More...
RXLF_API bool | Rx::ApiLF::RxRayDelete (unsigned hRay)
Delete the image with the given ID. More...
RXLF_API bool | Rx::ApiLF::RxRayGetFormat (unsigned hRay, Rx::CRxImageFormat &xF)
Get the image format of a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetFormatEx (unsigned hRay, Rx::CRxImageFormat &xF, void *pData)
Get extended format information on ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetMetaData (unsigned uImgID, Rx::CRxMetaData &xMetaData)
Get meta data of a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetRaw (unsigned hRay, Rx::CRxImage &xRawImage)
Get the ray image as Rx::CRxImage instance. More...
RXLF_API bool | Rx::ApiLF::RxRayGetRaw (unsigned hRay, Rx::IImage *pRawImage, bool bCreate)
Get the ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayLoad (unsigned &hRay, const Rx::CRxString &sxFilename)
Load a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayNew (unsigned &hRay, const Rx::CRxImageFormat &xF)
Create a new ray image. More...
RXLF_API bool | Rx::ApiLF::RxRaySave (unsigned hRay, const Rx::CRxString &sxFilename)
Save a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRaySetMetaData (unsigned uImgID, const Rx::CRxMetaData &xMetaData)
Set meta data of a ray image. More...

Detailed Description

Functions for working with lightfield images.

Lightfield images, called ray images in the following, are always held internally by the API. The user can reference the internal ray images by handles that are returned by the API. Since all processing of ray images is performed on a CUDA device, the ray images have to be copied to the CUDA device at some point. Since this copying process is fairly time consuming, the Raytrix API is designed such that this copying process only has to be done once for each image.

A ray image can be create either by loading it from disc with RxRayLoad() or by capturing into it with a Raytrix camera. In both cases a ray image handle is returned, which can be used for further processing. If a ray image has been loaded with RxRayLoad() it initially only resides in host memory. Before any processing can be done with it, it has to be copied to the CUDA device. This is done by binding the ray image with the function RxRayBind(). RxRayBind() copies the image to the CUDA device and locks it in host memory, so that it cannot be deleted. All lightfield operations like refocusing or depth evaluation now use the bound ray image. If a new image is bound by RxRayBind() the old image is unlocked in the host memory but not deleted.

The results of the lightfield algorithms are stored in result images on the CUDA device. These result images can then either be copied into host memory or to an OpenGL texture for immediate display.

If images are captured from a Raytrix camera the ray image handle returned by RxCamStartCapture() is automatically bound. Whenever a new image is captured with RxCamDoCapture() the image is captured into the ray image referenced by the returned ray image handle and it is directly copied to the CUDA device.

Function Documentation

RXLF_API bool Rx::ApiLF::RxRayBind ( unsigned hRay )

Bind a ray image to perform computations on.

Parameters
hRay The ID of the light field image that is to be used for calculations.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

If hRay is set to zero, then any previously bound light field image is unbound.

RXLF_API bool Rx::ApiLF::RxRayCalibLoad | ( | unsigned | hRay,
 |  | const Rx::CRxString & | sxFilename
 | ) |  |

Load calibration data of ray image from XML file.

Parameters
hRay | The ID of the ray image whose calibration data is to be overwritten by the loaded calibration data.
sxFilename | The filename of the XML file from which to load the data.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayCalibNew | ( | unsigned | hRay,
 |  | int | iLensTypeCount,
 |  | double | dLensDia,
 |  | double | dPixSize,
 |  | double | dOffsetX,
 |  | double | dOffsetY,
 |  | double | dRotDeg,
 |  | double | dLensBorder,
 |  | int | iRot90Cnt,
 |  | bool | bReflectX,
 |  | bool | bReflectY
 | ) |  |

Create a new calibration data set.

Perwass, 07.08.2012.

Parameters
hRay | The ray image ID.
iLensTypeCount | Number of different microlens types.
dLensDia | Microlens diameter in pixels.
dPixSize | Pixel pitch in millimeters.
dOffsetX | Horizontal offset of central lens of type 1 from image center in pixels.
dOffsetY | Vertical offset of central lens of type 1 from image center in pixels.
dRotDeg | Anti-clockwise rotation of microlens array about central lens in degrees.
dLensBorder | Border radius of pixels that should not be used in a lens.
iRot90Cnt | Rotation of microlens array in 90 degree steps.
bReflectX | Reflection of microlens grid about x-axis.
bReflectY | Reflection of microlens grid about y-axis.
Returns
true if it succeeds, false if it fails.
RXLF_API bool Rx::ApiLF::RxRayCalibSave | ( | unsigned | hRay,
 |  | const Rx::CRxString & | sxFilename
 | ) |  |

Save calibration data of ray image in XML format.

Parameters
hRay | The ID of the ray image whose calibration data is to be saved.
sxFilename | The filename under which to save the data.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayCalibXmlGet | ( | unsigned | hRay,
 |  | Rx::CRxString & | sxXml
 | ) |  |

Get the calibration data of the given ray image as XML string.

Parameters
hRay | The ID of the ray image whose calibration data is to be saved.
sxXml | On successful return contains the XML string.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayCalibXmlSet | ( | unsigned | hRay,
 |  | const Rx::CRxString & | sxXml
 | ) |  |

Set the calibration data of the given ray image from an XML string.

Parameters
hRay | The ID of the ray image whose calibration data is to be saved.
sxXml | The XML string specifying the calibration settings.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayDelete ( unsigned hRay )

Delete the image with the given ID.

Parameters
hRay The handle of the ray image to delete.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the ray image referenced by hRay is currently bound by a previous call to RxRayBind() or RxCamStartCapture(), the image is not deleted and the function returns false.
RXLF_API bool Rx::ApiLF::RxRayGetFormat | ( | unsigned | hRay,
 |  | Rx::CRxImageFormat & | xF
 | ) |  |

Get the image format of a ray image.

Parameters
hRay | The ray image handle.
xF | On return contains the image format of the ray image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayGetFormatEx | ( | unsigned | hRay,
 |  | Rx::CRxImageFormat & | xF,
 |  | void * | pData
 | ) |  |

Get extended format information on ray image.

Parameters
hRay | The ray image handle.
xF | On return contains the ray image format.
pData | Pointer to data structure with extended information.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is reserver for future use. Currently use RxRayGetFormat() instead.
RXLF_API bool Rx::ApiLF::RxRayGetMetaData | ( | unsigned | uImgID,
 |  | Rx::CRxMetaData & | xMetaData
 | ) |  |

Get meta data of a ray image.

Parameters
uImgID | The ray image handle.
xMetaData | Contains the ray image meta data on return.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The meta data class Rx::CRxMetaData can contain any number of meta data elements of types unsigned, double and Rx::CRxString. You can get, set and add elements to the meta data instance and store this together with the ray image.

RXLF_API bool Rx::ApiLF::RxRayGetRaw | ( | unsigned | hRay,
 |  | Rx::CRxImage & | xRawImage
 | ) |  |

Get the ray image as Rx::CRxImage instance.

Parameters
hRay | The ray image handle.
xRawImage | On return contains the ray image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::RawImage is enabled.
RXLF_API bool Rx::ApiLF::RxRayGetRaw | ( | unsigned | hRay,
 |  | Rx::IImage * | pRawImage,
 |  | bool | bCreate
 | ) |  |

Get the ray image.

Parameters
hRay | The ray image handle.
pRawImage | Pointer to an IImage interface.
bCreate | Flag whether to create image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::RawImage is enabled.

If bCreate is true, the necessary memory for the image is created with a call to IImage::Create(), otherwise it is expected that pRawImage is already allocated with the correct amount of memory.

RXLF_API bool Rx::ApiLF::RxRayLoad | ( | unsigned & | hRay,
 |  | const Rx::CRxString & | sxFilename
 | ) |  |

Load a ray image.

Parameters
hRay | On return contains the ray image handle of the ray image.
sxFilename | The ray image filename.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRayNew | ( | unsigned & | hRay,
 |  | const Rx::CRxImageFormat & | xF
 | ) |  |

Create a new ray image.

Parameters
hRay | On successful return contains the handle of the new ray image.
xF | The ray image format.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

Note that the allowed pixel types of ray images are Rx::EPixelType::RGBA, Rx::EPixelType::Lum, Rx::EPixelType::LumA, Rx::EPixelType::BayerBG, Rx::EPixelType::BayerGB, Rx::EPixelType::BayerGR, Rx::EPixelType::BayerRG.

RXLF_API bool Rx::ApiLF::RxRaySave | ( | unsigned | hRay,
 |  | const Rx::CRxString & | sxFilename
 | ) |  |

Save a ray image.

Parameters
hRay | The ID of the ray image to save.
sxFilename | The filename under which to save the ray image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxRaySetMetaData | ( | unsigned | uImgID,
 |  | const Rx::CRxMetaData & | xMetaData
 | ) |  |

Set meta data of a ray image.

Parameters
uImgID | The ray image handle.
xMetaData | The ray image meta data to set.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The meta data class Rx::CRxMetaData can contain any number of meta data elements of types unsigned, double and Rx::CRxString. You can get, set and add elements to the meta data instance and store this together with the ray image.


Lightfield Image Sequence API functions

Functions
Lightfield Image Sequence API functions
Raytrix Lightfield API

Functions for working with lightfield sequences. More...

Functions

RXLF_API bool | Rx::ApiLF::RxRaySeqBind (unsigned uRaySeqID, unsigned &uImgID)
Bind a ray sequence for use by other API functions. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqClose (unsigned uRaySeqID)
Close a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFileSize (unsigned uRaySeqID, unsigned __int64 &uFileSize)
Get the total file size of the ray sequence in bytes. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameBufferUsedCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frame buffers in use. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frames in ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameIndex (unsigned uRaySeqID, unsigned &uFrameIdx)
Get current frame index of ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqMoveFrameIndex (unsigned uRaySeqID, int iStep)
Move the frame index relative to the current position in the ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqOpen (unsigned &uRaySeqID, const Rx::CRxString &sxFilename, unsigned uMode, unsigned uFrameBufferCount)
Open a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqRead ()
Read a frame from the currently bound ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqSetFrameIndex (unsigned uRaySeqID, unsigned uFrameIdx)
Set the current frame index of ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqUnbind (unsigned uRaySeqID)
Unbind a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqWrite ()
Write currently bound ray image to currently bound ray sequence. More...

Detailed Description

Functions for working with lightfield sequences.

Function Documentation

RXLF_API bool Rx::ApiLF::RxRaySeqBind | ( | unsigned | uRaySeqID,
 |  | unsigned & | uImgID
 | ) |  |

Bind a ray sequence for use by other API functions.

Parameters
uRaySeqID | The id of the ray sequence.
uImgID | The ray image id of the newly bound ray image.

Only one ray sequence for reading and one ray sequence for writing can be bound at a time.

When a ray sequence is bound for reading, then any currently bound ray image is unbound, a new prototype ray image of the format of the ray sequence is created and bound and the first image of the ray sequence is loaded into the bound ray image. The ID of the newly created ray image is returned in uImgID. No new ray image can be bound until the ray sequence is unbound using RaySeqUnbind(). If a camera capture is started while a ray sequence is bound for reading, the ray sequence is automatically unbound. While a camera is in capture mode, no ray sequence can be bound for reading.

When a ray sequence is bound for writing a ray image must already be bound. If the ray sequence is empty up to now, the ray sequence is created for the currently bound image type and only ray images of the same format can be written to the ray sequence. Also only ray images of the same format can be bound while the ray sequence is bound. If the ray sequence already contains images, it can only be bound if the currently bound ray image format is of the same format as the ray sequence. If a ray sequence in write mode is bound and camera capture is started the ray sequence is also unbound if the image formats do not agree. To capture frames from a camera, first start the camera capture, then bind the ray sequence in write mode and set the parameter EPar::RaySeq_AutoStoreCamFrames to 1.

The value returned in uImgID is the ray image ID of the currently bound ray image.

RXLF_API bool Rx::ApiLF::RxRaySeqClose ( unsigned uRaySeqID )

Close a ray sequence.

Parameters
uRaySeqID The id of the ray sequence.

Closing a ray sequence also unbinds the corresponding ray sequence. The ray sequence ID becomes invalid once the ray sequence has been closed.

RXLF_API bool Rx::ApiLF::RxRaySeqGetFileSize | ( | unsigned | uRaySeqID,
 |  | unsigned __int64 & | uFileSize
 | ) |  |

Get the total file size of the ray sequence in bytes.

Parameters
uRaySeqID | The ray sequence id.
uFileSize | Contains the total size of the ray sequence in bytes.
RXLF_API bool Rx::ApiLF::RxRaySeqGetFrameBufferUsedCount | ( | unsigned | uRaySeqID,
 |  | unsigned & | uFrameCount
 | ) |  |

Get number of frame buffers in use.

Parameters
uRaySeqID | The ray sequence id.
uFrameCount | Contains the number of frames in use in the frame buffer on return.
RXLF_API bool Rx::ApiLF::RxRaySeqGetFrameCount | ( | unsigned | uRaySeqID,
 |  | unsigned & | uFrameCount
 | ) |  |

Get number of frames in ray sequence.

Parameters
uRaySeqID | The ray sequence id.
uFrameCount | Contains the number of frames on return.
RXLF_API bool Rx::ApiLF::RxRaySeqGetFrameIndex | ( | unsigned | uRaySeqID,
 |  | unsigned & | uFrameIdx
 | ) |  |

Get current frame index of ray sequence.

Parameters
uRaySeqID | The ray sequence id.
uFrameIdx | Contains the frame index on return.
RXLF_API bool Rx::ApiLF::RxRaySeqMoveFrameIndex | ( | unsigned | uRaySeqID,
 |  | int | iStep
 | ) |  |

Move the frame index relative to the current position in the ray sequence.

Parameters
uRaySeqID | The ray sequence id.
iStep | The number of frames to move. Negative values move frame index backward.
RXLF_API bool Rx::ApiLF::RxRaySeqOpen | ( | unsigned & | uRaySeqID,
 |  | const Rx::CRxString & | sxFilename,
 |  | unsigned | uMode,
 |  | unsigned | uFrameBufferCount
 | ) |  |

Open a ray sequence.

Parameters
uRaySeqID | The ray sequence id. This id is used in other functions to reference the ray sequence.
sxFilename | The ray sequence filename.
uMode | The ray sequence mode. This is a combination of elements of ERxRaySeqMode.
uFrameBufferCount | The number of frame buffers used for buffered writing/reading.

Depending on the mode a ray sequence can be opened for reading or writing.

RXLF_API bool Rx::ApiLF::RxRaySeqRead ( )

Read a frame from the currently bound ray sequence.

A ray sequence in read mode must have been bound beforehand. This function reads the current frame from the ray sequence and advanced the frame pointer by one frame. The ray image is read into the currently bound ray image and the image is automatically copied onto the CUDA device.

RXLF_API bool Rx::ApiLF::RxRaySeqSetFrameIndex | ( | unsigned | uRaySeqID,
 |  | unsigned | uFrameIdx
 | ) |  |

Set the current frame index of ray sequence.

Parameters
uRaySeqID | The ray sequence id.
uFrameIdx | The frame index.
RXLF_API bool Rx::ApiLF::RxRaySeqUnbind ( unsigned uRaySeqID )

Unbind a ray sequence.

Parameters
uRaySeqID The ray sequence ID of the ray sequence to unbind.

If a ray sequence in read mode is unbound, the currently bound ray image stays bound. The ray image is therefore also not removed from memory. You will have to unbind the ray image and then delete it to free all memory.

If a ray sequence in write mode is unbound, the currently bound ray image also stays bound. No more images can be written to the ray sequence once it has been unbound, however, the ray sequence has not been closed. It can be bound again to write further ray images to it.

RXLF_API bool Rx::ApiLF::RxRaySeqWrite ( )

Write currently bound ray image to currently bound ray sequence.

A ray sequence in write mode must have been bound beforehand. This function appends the currently bound ray image to the bound ray sequence.

To automatically write frames captured from a camera device to the bound ray sequence, set the parameter EPar::RaySeq_AutoStoreCamFrames to 1.


Lightfield computation API functions

Functions
Lightfield computation API functions
Raytrix Lightfield API

Functions to perform computations with ray images. More...

Functions

RXLF_API bool | Rx::ApiLF::RxCalibGrid ()
Calibrate the microimage grid. More...
RXLF_API bool | Rx::ApiLF::RxConvertImage (Rx::CRxImage &xDstImage, const Rx::CRxImage &xSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | Rx::ApiLF::RxConvertImage (Rx::IImage *pDstImage, const Rx::IImage *pSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType, bool bCreate)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | Rx::ApiLF::RxDepth (bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxDepth ()
Evaluate the scene depth from a bound ray image. More...
RXLF_API bool | Rx::ApiLF::RxDepthColorCode (double dRelDepthMin=0.0, double dRelDepthMax=1.0, EImgID::ID eTrgImgID=EImgID::DepthCol)
Color code depth images. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxDepthEx (double dViewOffX, double dViewOffY, bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API bool | Rx::ApiLF::RxDepthMap (double dStdDepth, int iWidth, int iHeight, double *pdData, unsigned uElCnt, EImgID::ID eTrgImgID=EImgID::Depth)
Generate a depth map from a set of coordinates. More...
RXLF_API bool | Rx::ApiLF::RxFocusOnPlane ()
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnPlaneEx (double dRelDepth, double dViewOffX=0.0, double dViewOffY=0.0)
Focus image to a plane perpendicular to the optical axis, and select view point. More...
RXLF_API bool | Rx::ApiLF::RxFocusOnSurface ()
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnSurface (double dStdDepth)
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnSurfaceEx (double dStdDepth, double dViewOffX, double dViewOffY)
Focus on surface and select view point. More...
RXLF_API bool | Rx::ApiLF::RxGetImage (EImgID::ID eImgID, Rx::CRxImage &xImage)
Get an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImage (EImgID::ID eImgID, Rx::IImage *pImage, bool bCreate)
Get an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageDevicePointer (EImgID::ID eImgID, void *&pDevicePtr)
Get the device pointer of an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageFormat (EImgID::ID eImgID, Rx::CRxImageFormat &xF)
Get the image format of an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageHistogram (EImgID::ID eImgID, Rx::CRxArrayUInt &xHistogram)
Calculate the histogram of a given image. More...
RXLF_API bool | Rx::ApiLF::RxGrid ()
Show a lens grid overlay on the raw ray image. More...
RXLF_API bool | Rx::ApiLF::RxIsImageValid (EImgID::ID eImgID)
Test whether an internal image is valid. More...
RXLF_API bool | Rx::ApiLF::RxPreProcess ()
Pre-Process a ray image. More...
RXLF_API bool | Rx::ApiLF::RxResizeImage (Rx::CRxImage &xImage, int iDivider)
Resize an image. More...
RXLF_API bool | Rx::ApiLF::RxSaveDepthPointList (const char *pcFilename)
RXLF_API bool | Rx::ApiLF::RxSetImage (EImgID::ID eImgID, const Rx::CRxImage &xImage)
Set an internal image. More...
RXLF_API bool | Rx::ApiLF::RxSetImage (EImgID::ID eImgID, const Rx::IImage *pImage)
Set an internal image. More...
RXLF_API bool | Rx::ApiLF::RxStereoDepth (bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoDepth ()
Calculate the depth for a left and a right view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoDepthEx (double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY, bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API bool | Rx::ApiLF::RxStereoOnPlane ()
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnPlaneEx (double dRelDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API bool | Rx::ApiLF::RxStereoOnSurface ()
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnSurface (double dStdDepth)
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnSurfaceEx (double dStdDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Stereo focus on surface with variable eye separation, view rotation and view offset. More...
RXLF_API bool | Rx::ApiLF::RxTransformDepthValue (double &dTrgValue, double dSrcValue, EDepthImageType::ID eTrgDIT, EDepthImageType::ID eSrcDIT)
Transform between different depth values. More...
RXLF_API bool | Rx::ApiLF::RxUpdateImage (EImgID::ID eImgID)
Update an internal image. More...

Detailed Description

Functions to perform computations with ray images.

The ray image processing functions listed here all work with the bound ray image and write their output to an internal result image. These result images can then either be copied to host memory with the function RxGetImage() or they can be copied directly to an OpenGL texture for fast displaying. For more information on the CUDA/OpenGL interop. see CUDA/OpenGL interop. functions.

The internal result images are referenced by IDs that are listed inRx::ApiLF::EImgID. The available result images and the functions that write into them are:

  • Refocus

    • EImgID::Focus: The result of a refocus operation.
    • EImgID::FocusLeft, EImgID::FocusRight: The results of a stereo refocus operation for the left and right eye.

    The following functions write into these result images:

    • RxFocusOnPlane()
    • RxFocusOnPlaneEx()
    • RxStereoOnPlane()
    • RxStereoOnPlaneEx()
    • RxFocusOnSurface()
    • RxFocusOnSurfaceEx()
    • RxStereoOnSurface()
    • RxStereoOnSurfaceEx()

  • Depth Evaluation

    • EImgID::Depth: The result of a depth evaluation as luminance image.
    • EImgID::DepthLeft, EImgID::DepthRight: The results of a stereo depth evaluation for the left and right eye as luminance images.

    The following functions write into these result images:

    • RxDepth()
    • RxDepthEx()
    • RxStereoDepth()
    • RxStereoDepthEx()
    • RxDepthMap()

    The luminance depth images can also be colored for a better visual presentation of the depth values. This is achieved with the function RxDepthColorCode() which writes into either EImgID::DepthCol, EImgID::DepthColLeft or EImgID::DepthColRight.

  • Calibration Grid

    • EImgID::RayGrid: The resultant grid drawn on top of a raw lightfield image.

    The following functions write into this result image:

    • RxGrid()

Function Documentation

RXLF_API bool Rx::ApiLF::RxCalibGrid ( )

Calibrate the microimage grid.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function attempts an automatic calibration of the micro-image parameters. Note that if the mico-image parameter are too far off, this function may not return a correct calibration. To obtain optimal calibration results with this function, an image of a grey surface or one that has been taken with a white filter should be used.

There are currently two different calibration modes that can be selected via the parameter EPar::Calib_Grid_Mode. The available calibration modes are elements of Rx::ApiLF::ECalibGridMode::ID.

This function reports on its progress using the set progress interface.

RXLF_API bool Rx::ApiLF::RxConvertImage | ( | Rx::CRxImage & | xDstImage,
 |  | const Rx::CRxImage & | xSrcImage,
 |  | Rx::EPixelType::ID | eDstPixelType,
 |  | Rx::EDataType::ID | eDstDataType
 | ) |  |

Convert a Rx::CRxImage to a new pixel and data type.

Perwass, 07.08.2012.

Parameters
xDstImage | [in,out] Destination image.
xSrcImage | Reference to the image.
eDstPixelType | Pixel type of the converted image.
eDstDataType | Data type of the converted image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxConvertImage | ( | Rx::IImage * | pDstImage,
 |  | const Rx::IImage * | pSrcImage,
 |  | Rx::EPixelType::ID | eDstPixelType,
 |  | Rx::EDataType::ID | eDstDataType,
 |  | bool | bCreate
 | ) |  |

Convert a Rx::CRxImage to a new pixel and data type.

Perwass, 07.08.2012.

Parameters
pDstImage | [in,out] Destination image.
pSrcImage | Reference to the image.
eDstPixelType | Pixel type of the converted image.
eDstDataType | Data type of the converted image.
bCreate | if true, memory for the destination image is created by this function.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxDepth ( bool bUpdate = false )

Evaluate the scene depth from a bound ray image with a given view offset.

Parameters
bUpdate Update depth from ray depth or calculate everything again.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::Calculate3D and Rx::ApiLF::EFeature::MultiView are enabled.

The depth calculation is performed in two steps for the standard depth algorithm. In a first step the depth is calculated for each microimage of the ray image. This is the ray depth image. From this image the resultant depth image is then synthesized. As the view offset changes pixels that were previously occluded may appear, for which the depth has to be calculated from the ray depth. However, in this case only the view synthesis has to be repeated with new values for the view offset, instead of a completely new depth calculation, which is much faster. When setting the parameter bUpdate to true only the view synthesis is performed and not the ray depth calculation. However, if no valid ray depth image is available, the ray depth image is calculated nonetheless.

The result is written to the internal image with ID EImgID::Depth. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API DEPRECATED bool Rx::ApiLF::RxDepth ( )

Evaluate the scene depth from a bound ray image.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::Calculate3D is enabled.

This function uses the depth evaluation algorithm type specified by the parameter EPar::Depth_Algo. This parameter is a string value with name of the algorithm. The standard algorithm has the name standard. This is also the default that is selected. The parameters of this depth algorithm are those starting with EPar::Depth_Std_. The size of the resultant depth image is given in relation to the ray image by the parameter EPar::Depth_ResImgDiv. This parameter gives the divisor of the ray image size. That is, if EPar::Depth_ResImgDiv is set to 2, then the result image size of the depth calculation is half the size of the ray image.

The result is written to the internal image with ID EImgID::Depth. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API bool Rx::ApiLF::RxDepthColorCode | ( | double | dRelDepthMin = 0.0,
 |  | double | dRelDepthMax = 1.0,
 |  | EImgID::ID | eTrgImgID = EImgID::DepthCol
 | ) |  |

Color code depth images.

Parameters
dRelDepthMin | The depth to map to the color blue.
dRelDepthMax | The depth to map to the color red.
eTrgImgID | The internal image ID of the resultant image. This has to be one of EImgID::DepthCol, EImgID::DepthColLeft, or EImgID::DepthColRight.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

As source the luminance depth image corresponding to the target image is selected. That is, if eTrgImgID is set to EImgID::DepthColLeft then the source image is EImgID::DepthLeft.

RXLF_API DEPRECATED bool Rx::ApiLF::RxDepthEx | ( | double | dViewOffX,
 |  | double | dViewOffY,
 |  | bool | bUpdate = false
 | ) |  |

Evaluate the scene depth from a bound ray image with a given view offset.

Parameters
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
bUpdate | Update depth from ray depth or calculate everything again.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::Calculate3D and Rx::ApiLF::EFeature::MultiView are enabled.

The depth calculation is performed in two steps for the standard depth algorithm. In a first step the depth is calculated for each microimage of the ray image. This is the ray depth image. From this image the resultant depth image is then synthesized. As the view offset changes pixels that were previously occluded may appear, for which the depth has to be calculated from the ray depth. However, in this case only the view synthesis has to be repeated with new values for the view offset, instead of a completely new depth calculation, which is much faster. When setting the parameter bUpdate to true only the view synthesis is performed and not the ray depth calculation. However, if no valid ray depth image is available, the ray depth image is calculated nonetheless.

The result is written to the internal image with ID EImgID::Depth. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API bool Rx::ApiLF::RxDepthMap | ( | double | dStdDepth,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | double * | pdData,
 |  | unsigned | uElCnt,
 |  | EImgID::ID | eTrgImgID = EImgID::Depth
 | ) |  |

Generate a depth map from a set of coordinates.

Parameters
dStdDepth | The standard depth in range [0,1].
iWidth | Sets the range of the x-coordinates in the array pdData as [0,iWidth].
iHeight | Sets the range of the y-coordinates in the array pdData as [0,iHeight].
pdData | The pointer to an array of 4 * uElCnt double values.
uElCnt | The number of data sets in the array pdData.
eTrgImgID | The image ID of the internal image to write to. Has to be one of [EImgID::Depth, EImgID::DepthLeft, EImgID::DepthRight].
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function expects pdData to point to an array of uElCnt datasets, each of which defines the center of a Gauss distribution with a certain standard deviation and associated relative depth. The final depth map is generated by summing for each pixel over the relative depths scaled by their corresponding Gauss distribution and adding the result to the standard depth given by dStdDepth. The depth map surface generated by this function is scaled such that it covers the whole internal image EImgID::Depth. The given width and height should therefore have the same aspect ratio as the dimensions of EImgID::Depth. The format of EImgID::Depth can be obtaines by RxGetImageFormat(). The size of EImgID::Depth is set relative to the ray image format via the parameter EPar::Depth_ResImgDiv.

A dataset consists of 4 doubles [dX, dY, dD, dR] with

  • dX: x-coordinate of Gauss distribution
  • dY: y-coordinate of Gauss distribution
  • dD: relative depth
  • dR: radius

The relative depth values can be positive or negative. They are added to the depth given in dStdDepth. The radius dR is the standard deviation of the Gauss distribution.

A depth map generated by this function may then be used by the functions RxFocusOnSurface(), RxFocusOnSurfaceEx(), RxStereoOnSurface() and RxStereoOnSurfaceEx().

RXLF_API bool Rx::ApiLF::RxFocusOnPlane ( )

Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This focuses to a plane perpendicular to the optical axis. A depth value of zero refocuses to the plane furthest away from the viewer and a value of 1 would focus to a plane that passes through the object side focal point of the recording lens.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxFocusOnPlane ( double dRelDepth )

Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane.

Parameters
dRelDepth Relative depth to which to refocus. This value has to lie in the range [0,1).
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This focuses to a plane perpendicular to the optical axis. A depth value of zero refocuses to the plane furthest away from the viewer and a value of 1 would focus to a plane that passes through the object side focal point of the recording lens.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxFocusOnPlaneEx | ( | double | dRelDepth,
 |  | double | dViewOffX = 0.0,
 |  | double | dViewOffY = 0.0
 | ) |  |

Focus image to a plane perpendicular to the optical axis, and select view point.

Parameters
dRelDepth | Relative depth to which to refocus. This value has to lie in the range [0,1).
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::MultiView is enabled.

In addition to focusing to a plane, the point of view from which the scene is seen can be changed slightly.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API bool Rx::ApiLF::RxFocusOnSurface ( )

Focus on a depth surface.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::FocusOnSurface is enabled.

In principle, each pixel of the result image can be focused individually. The function RxFocusOnSurface() makes this property available by focusing the ray image to the depth surface given in the internal image EImgID::Depth. This internal depth image can be set by a depth calculation, for example with RxDepth(), or by a depth map generated by RxDepthMap(), or by a user defined image set with RxSetImage().

When setting a depth image with RxSetImage() it need not have the same dimensions as the resultant image. The given depth map is implicitly scaled to the size of the resultant refocused image. For example, if the size of the given depth map image is 1x1 pixel, the depth encoded for that pixel is applied to all focused pixel. The depth image has to be of pixel type Rx::EPixelType::Lum and data type Rx::EDataType::UByte. The pixel value range of [0,255] is mapped to [0,1] for the interpretation as depth.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxFocusOnSurface ( double dStdDepth )

Focus on a depth surface.

Parameters
dStdDepth Standard depth in range [0,1) that is applied at places where the depth map is empty.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::FocusOnSurface is enabled.

In principle, each pixel of the result image can be focused individually. The function RxFocusOnSurface() makes this property available by focusing the ray image to the depth surface given in the internal image EImgID::Depth. This internal depth image can be set by a depth calculation, for example with RxDepth(), or by a depth map generated by RxDepthMap(), or by a user defined image set with RxSetImage().

When setting a depth image with RxSetImage() it need not have the same dimensions as the resultant image. The given depth map is implicitly scaled to the size of the resultant refocused image. For example, if the size of the given depth map image is 1x1 pixel, the depth encoded for that pixel is applied to all focused pixel. The depth image has to be of pixel type Rx::EPixelType::Lum and data type Rx::EDataType::UByte. The pixel value range of [0,255] is mapped to [0,1] for the interpretation as depth.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxFocusOnSurfaceEx | ( | double | dStdDepth,
 |  | double | dViewOffX,
 |  | double | dViewOffY
 | ) |  |

Focus on surface and select view point.

Parameters
dStdDepth | Standard depth in range [0,1) that is applied at places where the depth map is empty.
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::FocusOnSurface and Rx::ApiLF::EFeature::MultiView are enabled.

See function RxFocusOnSurface() for details on focusing on a surface. Note that if a depth surface calculated with RxDepthEx() is used, the depth map should be updated with the same values for dViewOffX and dViewOffY before RxFocusOnSurfaceEx() is called.

The result is written to the internal image with ID EImgID::Focus. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API bool Rx::ApiLF::RxGetImage | ( | EImgID::ID | eImgID,
 |  | Rx::CRxImage & | xImage
 | ) |  |

Get an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
xImage | On return contains a copy of the specified internal image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The available internal image IDs are listed inRx::ApiLF::EImgID.

RXLF_API bool Rx::ApiLF::RxGetImage | ( | EImgID::ID | eImgID,
 |  | Rx::IImage * | pImage,
 |  | bool | bCreate
 | ) |  |

Get an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
pImage | On return contains a copy of the specified internal image.
bCreate | If true, a new image is created in pImage. Otherwise, it is ensured that pImage refers to an image the same size and type as the respective internal image, and then the internal image is copied.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The available internal image IDs are listed inRx::ApiLF::EImgID.

RXLF_API bool Rx::ApiLF::RxGetImageDevicePointer | ( | EImgID::ID | eImgID,
 |  | void *& | pDevicePtr
 | ) |  |

Get the device pointer of an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
pDevicePtr | On return contains the internal image's device pointer.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function returns the image device pointer of an internal image.

The available internal image IDs are listed inRx::ApiLF::EImgID.

RXLF_API bool Rx::ApiLF::RxGetImageFormat | ( | EImgID::ID | eImgID,
 |  | Rx::CRxImageFormat & | xF
 | ) |  |

Get the image format of an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
xF | On return contains the internal image's format.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function returns the image format of an internal image without copying the actual image from the CUDA device to host memory.

The available internal image IDs are listed inRx::ApiLF::EImgID.

RXLF_API bool Rx::ApiLF::RxGetImageHistogram | ( | EImgID::ID | eImgID,
 |  | Rx::CRxArrayUInt & | xHistogram
 | ) |  |

Calculate the histogram of a given image.

Parameters
eImgID | eImgID Internal image ID. This is not a ray image handle.
xHistogram | A reference of Rx::CRxArrayUInt where the histogram will be stored.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function calculates the histogram of a given image.

RXLF_API bool Rx::ApiLF::RxGrid ( )

Show a lens grid overlay on the raw ray image.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The result is written to the internal image with ID EImgID::RayGrid.

RXLF_API bool Rx::ApiLF::RxIsImageValid ( EImgID::ID eImgID )

Test whether an internal image is valid.

Parameters
eImgID Internal image ID. This is not a ray image handle.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The available internal image IDs are listed inRx::ApiLF::EImgID.

RXLF_API bool Rx::ApiLF::RxPreProcess ( )

Pre-Process a ray image.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The ray image that is bound with RxRayBind() is a raw lightfield image. Before this ray image can be used by the actual processing algorithms, it has to be adjusted by applying a rectification of a possible radial distortion and by adjusting its brightness and color with respect to a white image.

The parameters of a radial distortion can be read/set with RxGetPar()/RxSetPar() via the parameters IDs EPar::Ray_MLI_RadDist* (see Rx::ApiLF::ERxPar::ID). When these parameters are changed the ray field image on the device is not automatically adjusted accordingly. Changed distortion parameters are only applied when the function RxPreProcess() is called.

RXLF_API bool Rx::ApiLF::RxResizeImage | ( | Rx::CRxImage & | xImage,
 |  | int | iDivider
 | ) |  |

Resize an image.

Parameters
xImage | The image that is to be resized.
iDivider | The image size divider. For example, if iDivder = 2, then the resultant image size is half the original size.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxSaveDepthPointList ( const char * pcFilename )
RXLF_API bool Rx::ApiLF::RxSetImage | ( | EImgID::ID | eImgID,
 |  | const Rx::CRxImage & | xImage
 | ) |  |

Set an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
xImage | The image to copy into the specified internal image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The available internal image IDs are listed in Rx::ApiLF::EImgID.

A new ray image can be set with eImgID set to EImgID::Ray and a new white image with EImgID::RayWhite. RxSetImage() copies the image data into the currently bound ray image and to the CUDA device. For the new ray image to be used in calculations you must call RxPreProcess() after setting the ray and the white image.

You can also circumvent the internal preprocessing of the ray image by writing directly the processed ray image to the CUDA device with EImgID::RayProc. However, this will not change the EImgID::Ray or EImgID::RayWhite images currently bound.

RXLF_API bool Rx::ApiLF::RxSetImage | ( | EImgID::ID | eImgID,
 |  | const Rx::IImage * | pImage
 | ) |  |

Set an internal image.

Parameters
eImgID | Internal image ID. This is not a ray image handle.
pImage | The image to copy into the specified internal image.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The available internal image IDs are listed inRx::ApiLF::EImgID.

A new ray image can be set with eImgID set to EImgID::Ray and a new white image with EImgID::RayWhite. RxSetImage() copies the image data into the currently bound ray image and to the CUDA device. For the new ray image to be used in calculations you must call RxPreProcess() after setting the ray and the white image.

You can also circumvent the internal preprocessing of the ray image by writing directly the processed ray image to the CUDA device with EImgID::RayProc. However, this will not change the EImgID::Ray or EImgID::RayWhite images currently bound.

RXLF_API bool Rx::ApiLF::RxStereoDepth ( bool bUpdate = false )

Calcualte the depth for a left and a right view with variable eye separation and rotation.

Parameters
bUpdate Update depth from ray depth or calculate everything again.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::Calculate3D and Rx::ApiLF::EFeature::MultiView are enabled.

For details on depth evaluation see RxDepth(). For details on the parameter bUpdate see RxDepthEx(). For details on the other parameters see RxStereoOnSurfaceEx().

The result is written to the internal images with IDs EImgID::DepthLeft and EImgID::DepthRight. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoDepth ( )

Calculate the depth for a left and a right view.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::Calculate3D is enabled.

For details on depth evaluation see RxDepth().

The result is written to the internal images with IDs EImgID::DepthLeft and EImgID::DepthRight. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoDepthEx | ( | double | dEyeSep,
 |  | double | dViewRotDeg,
 |  | double | dViewOffX,
 |  | double | dViewOffY,
 |  | bool | bUpdate = false
 | ) |  |

Calcualte the depth for a left and a right view with variable eye separation and rotation.

Parameters
dEyeSep | The eye separation in the range [0,1].
dViewRotDeg | View rotation CCW in degrees.
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
bUpdate | Update depth from ray depth or calculate everything again.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::Calculate3D and Rx::ApiLF::EFeature::MultiView are enabled.

For details on depth evaluation see RxDepth(). For details on the parameter bUpdate see RxDepthEx(). For details on the other parameters see RxStereoOnSurfaceEx().

The result is written to the internal images with IDs EImgID::DepthLeft and EImgID::DepthRight. Use the function RxDepthColorCode() to color code the depth image.

RXLF_API bool Rx::ApiLF::RxStereoOnPlane ( )

Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This focuses to a plane perpendicular to the optical axis. A depth value of zero refocuses to the plane furthest away from the viewer and a value of 1 would focus to a plane that passes through the object side focal point of the recording lens.

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of these resultant images is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoOnPlane ( double dRelDepth )

Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view.

Parameters
dRelDepth Relative depth to which to refocus. This value has to lie in the range [0,1).
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This focuses to a plane perpendicular to the optical axis. A depth value of zero refocuses to the plane furthest away from the viewer and a value of 1 would focus to a plane that passes through the object side focal point of the recording lens.

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of these resultant images is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoOnPlaneEx | ( | double | dRelDepth,
 |  | double | dEyeSep,
 |  | double | dViewRotDeg,
 |  | double | dViewOffX,
 |  | double | dViewOffY
 | ) |  |

Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view.

Parameters
dRelDepth | Relative depth to which to refocus. This value has to lie in the range [0,1).
dEyeSep | The eye separation in the range [0,1].
dViewRotDeg | View rotation CCW in degrees.
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::MultiView is enabled.

This focuses to a plane perpendicular to the optical axis. A depth value of zero refocuses to the plane furthest away from the viewer and a value of 1 would focus to a plane that passes through the object side focal point of the recording lens.

The parameter dEyeSep gives half the separation between the left and the right view. Since in a lightfield image not only a left and a right view are recorded as in a stereo camera system, it is also possible to rotate the view without loosing the 3D impression. This function calculates the effective view offsets for the left and right view as follows. If $R$ denotes the rotation matrix, then final left view offset dOffX and dOffY is calculates as

Similarly, the right view offset is calculated as

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of these resultant images is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API bool Rx::ApiLF::RxStereoOnSurface ( )

Stereo focus on surface.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::FocusOnSurface is enabled.

See function RxFocusOnSurface() for details on focusing on a surface. This function uses the internal depth maps EImgID::DepthLeft and EImgID::DepthRight to render focused images for the left and right eye in a stereo view.

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoOnSurface ( double dStdDepth )

Stereo focus on surface.

Parameters
dStdDepth Standard depth in range [0,1) that is applied at places where the depth map is empty.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the feature Rx::ApiLF::EFeature::FocusOnSurface is enabled.

See function RxFocusOnSurface() for details on focusing on a surface. This function uses the internal depth maps EImgID::DepthLeft and EImgID::DepthRight to render focused images for the left and right eye in a stereo view.

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API DEPRECATED bool Rx::ApiLF::RxStereoOnSurfaceEx | ( | double | dStdDepth,
 |  | double | dEyeSep,
 |  | double | dViewRotDeg,
 |  | double | dViewOffX,
 |  | double | dViewOffY
 | ) |  |

Stereo focus on surface with variable eye separation, view rotation and view offset.

Parameters
dStdDepth | Standard focus depth for places where the depth map is not set. This value has to lie in the range [0,1).
dEyeSep | The eye separation in the range [0,1].
dViewRotDeg | View rotation CCW in degrees.
dViewOffX | The view offset along horizontal axis in range [-1, 1]
dViewOffY | The view offset along vertical axis in range [-1, 1].
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function is only available if the features Rx::ApiLF::EFeature::FocusOnSurface and Rx::ApiLF::EFeature::MultiView are enabled.

For details on focusing to a surface see RxFocusOnSurface(). For details on the parameters dEyeSep, dViewRotDeg, dViewOffX and dViewOffY see RxStereoOnPlaneEx().

The result is written to the internal images with IDs EImgID::FocusLeft and EImgID::FocusRight. The size of this resultant image is set in relation to the ray image size via the parameter EPar::Focus_ResImgDiv.

RXLF_API bool Rx::ApiLF::RxTransformDepthValue | ( | double & | dTrgValue,
 |  | double | dSrcValue,
 |  | EDepthImageType::ID | eTrgDIT,
 |  | EDepthImageType::ID | eSrcDIT
 | ) |  |

Transform between different depth values.

Parameters
dTrgValue | The resultant depth value of type eTrgDIT.
dSrcValue | The source depth value of type eSrcDIT.
eTrgDIT | The target depth image type.
eSrcDIT | The source depth image type.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function transforms between the different depth image types.

RXLF_API bool Rx::ApiLF::RxUpdateImage ( EImgID::ID eImgID )

Update an internal image.

Parameters
eImgID Internal image ID. This is not a ray image handle.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

Currently this function only has an effect when eImgID is one of EImgID::Depth, EImgID::DepthLeft or EImgID::DepthRight. It should be called if the depth image type has been changed (EPar::Depth_ImageType), the default depth value has been changed (EPar::Depth_DefaultValue) or an affine depth parameter has changed (EPar::Depth_Affine_Offset, EPar::Depth_Affine_FocalLength).


Main API functions

Functions
Main API functions
Raytrix Lightfield API

Functions for fundamental API operations like initialization. More...

Functions

RXLF_API bool | Rx::ApiLF::AddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RxDongleGetID (int &iDngID, int &iRxID)
Get the IDs of an attached dongle. More...
RXLF_API bool | Rx::ApiLF::RxDongleReinitialize ()
RXLF_API bool | Rx::ApiLF::RxFinalize (void)
Close any open cameras and free all memory allocated on CUDA device and in host memory. More...
RXLF_API int | Rx::ApiLF::RxGetLastError (Rx::CRxString &sxError, bool bClear=true)
Obtain the error code and string of the last error that occured and reset the error. More...
RXLF_API int | Rx::ApiLF::RxGetLastErrorReport (Rx::CRxString &sxError, bool bClear=true)
Obtain the full incident report on the last error. More...
RXLF_API double | Rx::ApiLF::RxGetLastExecTime ()
Get last execution time of a CUDA algorithm. More...
RXLF_API bool | Rx::ApiLF::RxGetRegistryString (const Rx::CRxString &sxPath, Rx::CRxString &sxValue)
Read a string from the Windows registry. More...
RXLF_API bool | Rx::ApiLF::RxHasFeature (unsigned uID)
Test whether the API offers a particular feature. More...
RXLF_API bool | Rx::ApiLF::RxInit (bool bInitCuda, const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...
RXLF_API bool | Rx::ApiLF::RxInit (const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...

Detailed Description

Functions for fundamental API operations like initialization.

Function Documentation

RXLF_API bool Rx::ApiLF::AddStatusMessageHandler | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
RXLF_API bool Rx::ApiLF::RemoveStatusMessageHandler | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
RXLF_API bool Rx::ApiLF::RxDongleGetID | ( | int & | iDngID,
 |  | int & | iRxID
 | ) |  |

Get the IDs of an attached dongle.

Parameters
iDngID | On return contains the hardware dongle ID.
iRxID | On return contains the Raytrix dongle ID.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxDongleReinitialize ( )
RXLF_API bool Rx::ApiLF::RxFinalize ( void )

Close any open cameras and free all memory allocated on CUDA device and in host memory.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Make sure to call this function before ending your program. Otherwise the CUDA device memory will fill up with repeated execution of the software.
RXLF_API int Rx::ApiLF::RxGetLastError | ( | Rx::CRxString & | sxError,
 |  | bool | bClear = true
 | ) |  |

Obtain the error code and string of the last error that occured and reset the error.

Parameters
sxError | The error string.
bClear | Flag whether to clear the last error.
Returns
The error code of the last error.
RXLF_API int Rx::ApiLF::RxGetLastErrorReport | ( | Rx::CRxString & | sxError,
 |  | bool | bClear = true
 | ) |  |

Obtain the full incident report on the last error.

Parameters
sxError | On return contains the full error report.
bClear | Flag whether to clear the last error.
Returns
The error code of the last error entry in the error report.
RXLF_API double Rx::ApiLF::RxGetLastExecTime ( )

Get last execution time of a CUDA algorithm.

Returns
The last execution time of a CUDA kernel in milliseconds.

The time returned here is the pure calculation time on the CUDA device without data transfer between host and device or any time used on host before and after the actual CUDA kernel call.

RXLF_API bool Rx::ApiLF::RxGetRegistryString | ( | const Rx::CRxString & | sxPath,
 |  | Rx::CRxString & | sxValue
 | ) |  |

Read a string from the Windows registry.

Parameters
sxPath | The registry path.
sxValue | The returned string value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

The registry path has to start with HKLM\. A registry path must have the following structure HKLM\[path to key]\[value name]:[relative path]. The last colon and the relative path are optional. For example, if the registry value with path HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir contains the value C:\Program Files (x86)\Raytrix\RxLive, then setting sxPath to HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir:bin is translated into the library path C:\Program Files (x86)\Raytrix\RxLive\bin.

RXLF_API bool Rx::ApiLF::RxHasFeature ( unsigned uID )

Test whether the API offers a particular feature.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

Not all functions of this API are necessarily available. This depends on the currently active licence, which is defined by the Raytrix dongle attached to the system. To check whether a set of features is available you can OR the corresponding feature IDs. The feature IDs are availabe through defines all starting with RX_API_FEAT_ . For example, to test for the features multiview and 3D evaluation call RxHasFeature( Rx::ApiLF::EFeature::MultiView | Rx::ApiLF::EFeature::Calculate3D ).

RXLF_API bool Rx::ApiLF::RxInit | ( | bool | bInitCuda,
 |  | const Rx::CRxString & | sxLibPath = Rx::CRxString(),
 |  | const Rx::CRxString & | sxCalibPath = Rx::CRxString(),
 |  | void * | pData = 0
 | ) |  |

Initialize the Raytrix API.

Parameters
bInitCuda | If set to false only functionality that does not rely on CUDA can be used.
sxLibPath | The absolute path to the camera driver DLLs (RaytrixCamera_*.dll).
sxCalibPath | The absolute path to the camera calibration directories.
bInitCuda | Flag indicating whether CUDA is to be used or not.
pData | Reserved. Must be zero.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function has to be called before any other API function, with the exception of

  • RxGetLastError()
  • RxSleep()
  • RxGetTime()
  • RxGetTime64()

If the parameters sxLibPath and sxCalibPath are not specified, the default paths that were given during installation are read from the registry. They are stored under the registry key HKLM\SOFTWARE\Raytrix\RxLive.

To specify different paths, these either have to be absolute paths with a drive letter and a colon (':') as the first two characters, or a registry path. A registry path must have the following structure HKLM\[path to key]\[value name]:[relative path]. The last colon and the relative path are optional. For example, if the registry value with path HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir contains the value C:\Program Files (x86)\Raytrix\RxLive, then setting sxLibPath to HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir:bin is translated into the library path C:\Program Files (x86)\Raytrix\RxLive\bin.

After executing RxInit() neither a CUDA device is selected nor a camera device initialized. Before any lightfield images can be loaded, recorded or processed a CUDA device has to be chosen using the function RxCudaSelectDevice(). To access Raytrix cameras you first have to call RxCamDriverInit() and RxCamRegister().

RXLF_API bool Rx::ApiLF::RxInit | ( | const Rx::CRxString & | sxLibPath = Rx::CRxString(),
 |  | const Rx::CRxString & | sxCalibPath = Rx::CRxString(),
 |  | void * | pData = 0
 | ) |  |

Initialize the Raytrix API.

Parameters
sxLibPath | The absolute path to the camera driver DLLs (RaytrixCamera_*.dll).
sxCalibPath | The absolute path to the camera calibration directories.
pData | Reserved. Must be zero.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function has to be called before any other API function, with the exception of

  • RxGetLastError()
  • RxSleep()
  • RxGetTime()
  • RxGetTime64()

If the parameters sxLibPath and sxCalibPath are not specified, the default paths that were given during installation are read from the registry. They are stored under the registry key HKLM\SOFTWARE\Raytrix\RxLive.

To specify different paths, these either have to be absolute paths with a drive letter and a colon (':') as the first two characters, or a registry path. A registry path must have the following structure HKLM\[path to key]\[value name]:[relative path]. The last colon and the relative path are optional. For example, if the registry value with path HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir contains the value C:\Program Files (x86)\Raytrix\RxLive, then setting sxLibPath to HKLM\SOFTWARE\Raytrix\RxLive\Install_Dir:bin is translated into the library path C:\Program Files (x86)\Raytrix\RxLive\bin.

After executing RxInit() neither a CUDA device is selected nor a camera device initialized. Before any lightfield images can be loaded, recorded or processed a CUDA device has to be chosen using the function RxCudaSelectDevice(). To access Raytrix cameras you first have to call RxCamDriverInit() and RxCamRegister().


Parameter API functions

Functions
Parameter API functions
Raytrix Lightfield API

Functions to get/set API parameters. More...

Functions

RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, unsigned &uValue)
Get a parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, double &dValue)
Get a parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, Rx::CRxString &sValue)
Get a parameter of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxGetParName (EPar::ID ePar, Rx::CRxString &sValue)
Get the string representation of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxGetParRange (EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the range of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxGetParRange (EPar::ID ePar, double &dMin, double &dMax)
Get the range of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxLoadPar (const Rx::CRxString &sxFilename)
Load all API parameters from file. More...
RXLF_API bool | Rx::ApiLF::RxSavePar (const Rx::CRxString &sxFilename)
Save all API parameters from file. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const unsigned &uValue)
Set a parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const double &dValue)
Set a parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const Rx::CRxString &sValue)
Set a parameter of type Rx::CRxString. More...

Detailed Description

Functions to get/set API parameters.

With these functions parameters of the API can be read and set. The parameter IDs are defined in Rx::ApiLF::ERxPar::ID. Note that the parameters starting with EPar::Cam_ and EPar::CamCal_ have to be read and set with RxCamGetPar() and RxCamSetPar(), with the exeception of EPar::Cam_Count. The parameters are grouped in the following categories:

  • EPar::Cuda_*: CUDA device.
  • EPar::Cam_*: Camera.
  • EPar::CamCal_*: Camera calibration.
  • EPar::Ray_*: Ray image.
  • EPar::Ray_MLI_*: Ray microlens image.
  • EPar::Gl_*: CUDA/OpenGL interop.
  • EPar::Depth_*: Depth evaluation algorithms.
  • EPar::Depth_Std_*: Standard depth evaluation algorithm.
  • EPar::Focus_*: Refocus algorithm.
  • EPar::Grid_*: Grid algorithm.

Function Documentation

RXLF_API bool Rx::ApiLF::RxGetPar | ( | EPar::ID | ePar,
 |  | unsigned & | uValue
 | ) |  |

Get a parameter of type unsigned integer.

Parameters
ePar | The parameter ID.
uValue | On return contains the parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an unsigned integer parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.
RXLF_API bool Rx::ApiLF::RxGetPar | ( | EPar::ID | ePar,
 |  | double & | dValue
 | ) |  |

Get a parameter of type double.

Parameters
ePar | The parameter ID.
dValue | On return contains the parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an double parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.
RXLF_API bool Rx::ApiLF::RxGetPar | ( | EPar::ID | ePar,
 |  | Rx::CRxString & | sValue
 | ) |  |

Get a parameter of type Rx::CRxString.

Parameters
ePar | The parameter ID.
sValue | On return contains the parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an Rx::CRxString parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.
RXLF_API bool Rx::ApiLF::RxGetParName | ( | EPar::ID | ePar,
 |  | Rx::CRxString & | sValue
 | ) |  |

Get the string representation of a parameter.

Parameters
ePar | The parameter ID.
sValue | On return contains the parameter string representation.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxGetParRange | ( | EPar::ID | ePar,
 |  | unsigned & | uMin,
 |  | unsigned & | uMax
 | ) |  |

Get the range of a parameter.

Parameters
ePar | The parameter ID.
uMin | The minimal value.
uMax | The maximal value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an unsigned integer parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If no range is defined for this parameter, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOCONSTR.
RXLF_API bool Rx::ApiLF::RxGetParRange | ( | EPar::ID | ePar,
 |  | double & | dMin,
 |  | double & | dMax
 | ) |  |

Get the range of a parameter.

Parameters
ePar | The parameter ID.
dMin | The minimal value.
dMax | The maximal value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an double parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If no range is defined for this parameter, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOCONSTR.
RXLF_API bool Rx::ApiLF::RxLoadPar ( const Rx::CRxString & sxFilename )

Load all API parameters from file.

Parameters
sxFilename The filename of the parameter file.
RXLF_API bool Rx::ApiLF::RxSavePar ( const Rx::CRxString & sxFilename )

Save all API parameters from file.

Parameters
sxFilename The filename of the parameter file.
RXLF_API bool Rx::ApiLF::RxSetPar | ( | EPar::ID | ePar,
 |  | const unsigned & | uValue
 | ) |  |

Set a parameter of type unsigned integer.

Parameters
ePar | The parameter ID.
uValue | The parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an unsigned integer parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.
RXLF_API bool Rx::ApiLF::RxSetPar | ( | EPar::ID | ePar,
 |  | const double & | dValue
 | ) |  |

Set a parameter of type double.

Parameters
ePar | The parameter ID.
dValue | The parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an double parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.
RXLF_API bool Rx::ApiLF::RxSetPar | ( | EPar::ID | ePar,
 |  | const Rx::CRxString & | sValue
 | ) |  |

Set a parameter of type Rx::CRxString.

Parameters
ePar | The parameter ID.
sValue | The parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an Rx::CRxString parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. If a parameter is not supported by the current version of the API, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.


Raytrix Camera API functions

Functions
Raytrix Camera API functions
Raytrix Lightfield API

Functions for working with Raytrix cameras. More...

Functions

RXLF_API bool | Rx::ApiLF::RxCamCalibCreate (unsigned uCamIdx, bool bForce)
Create a new camera calibration database. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibDeleteLens (unsigned uCamIdx)
Delete the currently selected calibration database entry of a lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibDeleteLensSetting (unsigned uCamIdx)
Delete the currently selected calibration database entry for a lens setting. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLens (unsigned uCamIdx, const Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName)
Create a calibration database enty for a new lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLens (unsigned uCamIdx, Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName, bool bCreateID)
Create a calibration database enty for a new lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLensSetting (unsigned uCamIdx, double dFStop, double dFocus)
Create a new calibration database entry for a lens setting. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibStore (unsigned uCamIdx)
Store the calibration database in the camera calibration file. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibStoreWhiteImage (unsigned uCamIdx, unsigned uImgCnt)
Capture a number of images to create a new white image. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibUpdate (unsigned uCamIdx)
Update the lightfield calibration data. More...
RXLF_API bool | Rx::ApiLF::RxCamClose (unsigned uCamIdx)
Close a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamDoCapture (unsigned uCamIdx)
Capture a single image from a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamDriverInit ()
Initialize the camera drivers. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, Rx::CRxString &sxValue)
Get a camera parameter of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, unsigned &uValue)
Get a camera parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, double &dValue)
Get camera parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the parameter range of a camera parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, double &dMin, double &dMax)
Get the parameter range of a camera parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, Rx::CRxArrayUInt &auValues)
Get set of available values for parameter of type unsigned. More...
RXLF_API bool | Rx::ApiLF::RxCamOpen (unsigned uCamIdx)
Open a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamRegister ()
Register available cameras. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const Rx::CRxString &sxValue)
Set a camera property of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const unsigned &uValue)
Set a camera property of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const double &dValue)
Set a camera property of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamStartCapture (unsigned uCamIdx, unsigned &hRay)
Prepare camera for capturing images. More...
RXLF_API bool | Rx::ApiLF::RxCamStopCapture (unsigned uCamIdx)
Stop capturing images. More...
RXLF_API bool | Rx::ApiLF::RxCamSupPar (unsigned uCamIdx, EPar::ID ePar, bool &bSupported)
Test whether a camera parameter is supported by the selected camera. More...
RXLF_API bool | Rx::ApiLF::RxCamSuspendCapture (unsigned uCamIdx, bool bSuspend)
Suspend capturing images. More...

Detailed Description

Functions for working with Raytrix cameras.

Function Documentation

RXLF_API bool Rx::ApiLF::RxCamCalibCreate | ( | unsigned | uCamIdx,
 |  | bool | bForce
 | ) |  |

Create a new camera calibration database.

Parameters
uCamIdx | The zero-based camera index.
bForce | If true, overwrite existing camera database file.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Can only be called while camera capture is NOT active.

This functions creates a new camera calibration database with dummy calibration data. You will have to set all calibration data values to obtain usable images.

RXLF_API bool Rx::ApiLF::RxCamCalibDeleteLens ( unsigned uCamIdx )

Delete the currently selected calibration database entry of a lens.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
The last calibration database entry for a lens cannot be deleted.
RXLF_API bool Rx::ApiLF::RxCamCalibDeleteLensSetting ( unsigned uCamIdx )

Delete the currently selected calibration database entry for a lens setting.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamCalibNewLens | ( | unsigned | uCamIdx,
 |  | const Rx::CRxString & | sxLensID,
 |  | const Rx::CRxString & | sxLensName
 | ) |  |

Create a calibration database enty for a new lens.

Parameters
uCamIdx | The zero-based camera index.
sxLensID | The ID string of the new lens. This ID string has to be unique within the calibration database.
sxLensName | The name of the new lens.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function creates a new calibration database entry for a new lens and copies the data and white image of the current calibration data.

RXLF_API bool Rx::ApiLF::RxCamCalibNewLens | ( | unsigned | uCamIdx,
 |  | Rx::CRxString & | sxLensID,
 |  | const Rx::CRxString & | sxLensName,
 |  | bool | bCreateID
 | ) |  |

Create a calibration database enty for a new lens.

Parameters
uCamIdx | The zero-based camera index.
sxLensID | The ID string of the new lens. If bCreateID is true, a unique ID value is created and returned in this variable.
sxLensName | The name of the new lens.
bCreateID | If true, a unique value for sxLensID is created and returned in sxLensID.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function creates a new calibration database entry for a new lens and copies the data and white image of the current calibration data.

RXLF_API bool Rx::ApiLF::RxCamCalibNewLensSetting | ( | unsigned | uCamIdx,
 |  | double | dFStop,
 |  | double | dFocus
 | ) |  |

Create a new calibration database entry for a lens setting.

Parameters
uCamIdx | The zero-based camera index.
dFStop | The lens f-stop.
dFocus | The lens focus.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamCalibStore ( unsigned uCamIdx )

Store the calibration database in the camera calibration file.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Can only be called while camera capture is active.

This function stores the current lightfield calibration of the currently bound lightfield image in the currently selected camera calibration setting.

RXLF_API bool Rx::ApiLF::RxCamCalibStoreWhiteImage | ( | unsigned | uCamIdx,
 |  | unsigned | uImgCnt
 | ) |  |

Capture a number of images to create a new white image.

Parameters
uCamIdx | The zero-based camera index.
uImgCnt | The number of images to capture.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Ensure that a white filter is placed in front of the camera lens or that the camera looks at a homogeneous white or grey surface before calling this function.

This function captures uImgCnt images, adds them and divides the result by the number of images captured to obtain a mean white image. The resultant image is stored as new white image for the currently selected calibration.

RXLF_API bool Rx::ApiLF::RxCamCalibUpdate ( unsigned uCamIdx )

Update the lightfield calibration data.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

After selecting a different set of calibration data, call this function to update the calibration data that is used for the internal lightfield calculations.

RXLF_API bool Rx::ApiLF::RxCamClose ( unsigned uCamIdx )

Close a camera.

Parameters
uCamIdx The zero-based index of the camera to close.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamDoCapture ( unsigned uCamIdx )

Capture a single image from a camera.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
This function only returns after an image has been captured by the camera and is available on the CUDA device.

The camera image is captured into the image referenced by the ray image handle returned by the function RxCamStartCapture(). It is also automatically copied onto the CUDA device, so that all processing of the lightfield image can be done purely on the CUDA device without repeated copying of the lightfield image from host to device memory.

RXLF_API bool Rx::ApiLF::RxCamDriverInit ( )

Initialize the camera drivers.

This function uses the path given in RxInit() as sxLibPath, or the default lib path as stored in the registry, to search for the camera driver DLLs (RaytrixCamera_*.dll), loads and initializes them. This function has to be called before any other Raytrix API camera function.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamGetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | Rx::CRxString & | sxValue
 | ) |  |

Get a camera parameter of type Rx::CRxString.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
sxValue | The returned string value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to a string parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::Cam_Name, EPar::Cam_Type, EPar::Cam_ID, EPar::CamCal_LensName, EPar::CamCal_LensID.

RXLF_API bool Rx::ApiLF::RxCamGetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | unsigned & | uValue
 | ) |  |

Get a camera parameter of type unsigned integer.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
uValue | The returned unsigned integer value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to an unsigned integer parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::CamCal_LensCnt, EPar::CamCal_LensSetCnt, EPar::CamCal_LensIdx, EPar::CamCal_LensSetIdx, EPar::Cam_Width, EPar::Cam_Height, EPar::Cam_OffsetX, EPar::Cam_OffsetY, EPar::Cam_IsColor, EPar::Cam_AutoUpdateGlTex.

RXLF_API bool Rx::ApiLF::RxCamGetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | double & | dValue
 | ) |  |

Get camera parameter of type double.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
dValue | The returned double value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to a double parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::CamCal_LensSetFStop, EPar::CamCal_LensSetFocus, EPar::Cam_Exposure, EPar::Cam_Gain, EPar::Cam_GainRed, EPar::Cam_GainGreen, EPar::Cam_GainBlue.

RXLF_API bool Rx::ApiLF::RxCamGetParRange | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | unsigned & | uMin,
 |  | unsigned & | uMax
 | ) |  |

Get the parameter range of a camera parameter of type unsigned integer.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
uMin | On return the minimal parameter value.
uMax | On return the maximal parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Not all camera parameters may have a defined range. If a camera parameter has no defined range, this function returns false and the last error is set to Rx::ApiLF::EError::PAR_NOCONSTR.
RXLF_API bool Rx::ApiLF::RxCamGetParRange | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | double & | dMin,
 |  | double & | dMax
 | ) |  |

Get the parameter range of a camera parameter of type double.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
dMin | On return the minimal parameter value.
dMax | On return the maximal parameter value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Not all camera parameters may have a defined range. If a camera parameter has no defined range, this function returns false and the last error is set to Rx::ApiLF::EError::PAR_NOCONSTR.
RXLF_API bool Rx::ApiLF::RxCamGetParRange | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | Rx::CRxArrayUInt & | auValues
 | ) |  |

Get set of available values for parameter of type unsigned.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
auValues | The list of available values.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Not all camera parameters may have a defined range. If a camera parameter has no defined range, this function returns false and the last error is set to Rx::ApiLF::EError::PAR_NOCONSTR.
RXLF_API bool Rx::ApiLF::RxCamOpen ( unsigned uCamIdx )

Open a camera.

Parameters
uCamIdx The zero-based index of the camera to open.

Camera settings can only be accessed after a camera has been opened.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamRegister ( )

Register available cameras.

This functions registers all cameras that are currently available. Only registered cameras can be used by the Raytrix API. This function can be called repeatedly to update the list of available cameras. This function has to be called after RxCamDriverInit() and before any other API camera functions.

Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
RXLF_API bool Rx::ApiLF::RxCamSetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | const Rx::CRxString & | sxValue
 | ) |  |

Set a camera property of type Rx::CRxString.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
sxValue | The string value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to a string parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::None.

RXLF_API bool Rx::ApiLF::RxCamSetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | const unsigned & | uValue
 | ) |  |

Set a camera property of type unsigned integer.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
uValue | The unsigned integer value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to a string parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::CamCal_LensIdx, EPar::CamCal_LensSetIdx, EPar::Cam_Width, EPar::Cam_Height, EPar::Cam_OffsetX, EPar::Cam_OffsetY.

RXLF_API bool Rx::ApiLF::RxCamSetPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | const double & | dValue
 | ) |  |

Set a camera property of type double.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
dValue | The double value.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
If the parameter referenced by ePar does not relate to a string parameter, then the function returns false and the last error is set to Rx::ApiLF::EError::PAR_TYPE. Not all parameters may be supported by all Raytrix cameras. If a parameter is not supported, then false is returned and the last error is set to Rx::ApiLF::EError::PAR_NOTSUPPORTED.

The following parameter IDs defined in Rx::ApiLF::ERxPar::ID can be used with this function: EPar::Cam_Exposure, EPar::Cam_Gain, EPar::Cam_GainRed, EPar::Cam_GainGreen, EPar::Cam_GainBlue.

RXLF_API bool Rx::ApiLF::RxCamStartCapture | ( | unsigned | uCamIdx,
 |  | unsigned & | hRay
 | ) |  |

Prepare camera for capturing images.

Parameters
uCamIdx | The zero-based camera index.
hRay | On return the ray image handle of the image into which camera images are captured.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().
Attention
Only one camera can be used for capturing images. Calling RxCamStartCapture() again with a different camera index results in an error.

Calling this function does not actually capture any images but prepares the camera for capturing images. The function also reads the calibration data of the Raytrix camera with ID uCamIdx from the path set as sxCalibPath in RxInit().

The internal ray image with ID hRay is not deleted from memory when capturing is stopped with RxCamStopCapture(). It has to be deleted explicitly using RxRayDelete() when it is no longer needed.

RXLF_API bool Rx::ApiLF::RxCamStopCapture ( unsigned uCamIdx )

Stop capturing images.

Parameters
uCamIdx The zero-based camera index.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

Note that the ray image that was created by RxCamStartCapture() is not automatically deleted by RxCamStopCapture(). It has to be deleted explicitly using RxRayDelete() when it is no longer needed.

RXLF_API bool Rx::ApiLF::RxCamSupPar | ( | unsigned | uCamIdx,
 |  | EPar::ID | ePar,
 |  | bool & | bSupported
 | ) |  |

Test whether a camera parameter is supported by the selected camera.

Parameters
uCamIdx | The zero-based camera index.
ePar | The camera parameter ID.
bSupported | On return indicates whether the paramtere ePar is supported or not.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

All camera and camera calibration parameters can be tested with this function. Use this function to test whether certain parameters are available or not. For example, the parameters EPar::Cam_Focus, EPar::Cam_Iris and EPar::Cam_Func_CalibMainLens are only available if a camera is attached that allows the direct control of the main lens.

RXLF_API bool Rx::ApiLF::RxCamSuspendCapture | ( | unsigned | uCamIdx,
 |  | bool | bSuspend
 | ) |  |

Suspend capturing images.

Parameters
uCamIdx | The zero-based camera index.
bSuspend | true to suspend camera capture and false to restart camera capture.
Returns
true if successful, false otherwise. If false is returned the error that caused the failure can be obtained by calling RxGetLastError().

This function stops the data transfer between camera and computer but keeps all other capture settings.


Time Functions

Functions
Time Functions
Raytrix Lightfield API

Functions to measure time or to pause API thread. More...

Functions

RXLF_API double | Rx::ApiLF::RxGetTime ()
Get a time measured in milliseconds as double value. More...
RXLF_API __int64 | Rx::ApiLF::RxGetTime64 ()
Get a time in milliseconds as 64 bit integer value. More...
RXLF_API void | Rx::ApiLF::RxSleep (unsigned uTime)
Pause calling thread for the given number of milliseconds. More...

Detailed Description

Functions to measure time or to pause API thread.

These funtions are based on the Windows API function ::QueryPerformanceCounter() to obtain a very accurate time measurement.

Function Documentation

RXLF_API double Rx::ApiLF::RxGetTime ( )

Get a time measured in milliseconds as double value.

RXLF_API __int64 Rx::ApiLF::RxGetTime64 ( )

Get a time in milliseconds as 64 bit integer value.

RXLF_API void Rx::ApiLF::RxSleep ( unsigned uTime )

Pause calling thread for the given number of milliseconds.

Note that this implementation of sleep internally only does an actual Sleep() for one millisecond and then checks the actual elapsed time with the Windows API function ::QueryPerformanceCounter(). This gives more accurate results in the actual time the thread is paused.


Rx::ApiLF::CStatusMessageDelegateList Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • ApiLF
  • CStatusMessageDelegateList
Public Member Functions | Protected Attributes
Rx::ApiLF::CStatusMessageDelegateList Class Reference
Raytrix Lightfield API

#include <Rx.ApiLF.StatusMessageDelegateList.h>

Public Member Functions

CStatusMessageDelegateList (void)
~CStatusMessageDelegateList (void)
bool | Add (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
void | Clear ()
unsigned | Count ()
void | InvokeAll (Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue)
bool | Remove (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)

Protected Attributes

Raytrix::CRxMem
< SStatusMessageDelegate > 		m_mStatusMessageDelegates

Constructor & Destructor Documentation

Rx::ApiLF::CStatusMessageDelegateList::CStatusMessageDelegateList ( void )
Rx::ApiLF::CStatusMessageDelegateList::~CStatusMessageDelegateList ( void )

Member Function Documentation

bool Rx::ApiLF::CStatusMessageDelegateList::Add | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
void Rx::ApiLF::CStatusMessageDelegateList::Clear ( )
unsigned Rx::ApiLF::CStatusMessageDelegateList::Count ( )
void Rx::ApiLF::CStatusMessageDelegateList::InvokeAll | ( | Rx::ApiLF::EStatusSource::ID | eSource,
 |  | Rx::ApiLF::EStatusMessage::ID | eMsg,
 |  | const char * | pcSourceName,
 |  | const char * | pcMessage,
 |  | int | iValue
 | ) |  |
bool Rx::ApiLF::CStatusMessageDelegateList::Remove | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |

Field Documentation

Raytrix::CRxMem<SStatusMessageDelegate> Rx::ApiLF::CStatusMessageDelegateList::m_mStatusMessageDelegates
protected
The documentation for this class was generated from the following file:
  • Rx.ApiLF.StatusMessageDelegateList.h


Rx::ApiLF::SStatusMessageDelegate Struct Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • ApiLF
  • SStatusMessageDelegate
Public Member Functions | Data Fields
Rx::ApiLF::SStatusMessageDelegate Struct Reference
Raytrix Lightfield API

#include <Rx.ApiLF.Types.h>

Public Member Functions

SStatusMessageDelegate ()
SStatusMessageDelegate (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
void | Invoke (Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue)
bool | operator!= (const SStatusMessageDelegate &xSMD)
bool | operator== (const SStatusMessageDelegate &xSMD)
void | Set (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)

Data Fields

Rx::ApiLF::TFuncStatusMessageCallback m_pStatusMessageCallbackFunc
void * m_pvStatusMessageCallbackContext

Constructor & Destructor Documentation

Rx::ApiLF::SStatusMessageDelegate::SStatusMessageDelegate ( )
inline
Rx::ApiLF::SStatusMessageDelegate::SStatusMessageDelegate | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
inline

Member Function Documentation

void Rx::ApiLF::SStatusMessageDelegate::Invoke | ( | Rx::ApiLF::EStatusSource::ID | eSource,
 |  | Rx::ApiLF::EStatusMessage::ID | eMsg,
 |  | const char * | pcSourceName,
 |  | const char * | pcMessage,
 |  | int | iValue
 | ) |  |
inline
bool Rx::ApiLF::SStatusMessageDelegate::operator!= ( const SStatusMessageDelegate & xSMD )
inline
bool Rx::ApiLF::SStatusMessageDelegate::operator== ( const SStatusMessageDelegate & xSMD )
inline
void Rx::ApiLF::SStatusMessageDelegate::Set | ( | Rx::ApiLF::TFuncStatusMessageCallback | pFunc,
 |  | void * | pvContext
 | ) |  |
inline

Field Documentation

Rx::ApiLF::TFuncStatusMessageCallback Rx::ApiLF::SStatusMessageDelegate::m_pStatusMessageCallbackFunc
void* Rx::ApiLF::SStatusMessageDelegate::m_pvStatusMessageCallbackContext
The documentation for this struct was generated from the following file:
  • Rx.ApiLF.Types.h


The Raytrix Core Classes API

Modules | Namespaces | Macros | Typedefs | Functions
The Raytrix Core Classes API
C++

The Raytrix core classes currently offer classes to hold image data of various pixel and data types. More...

Modules

Image classes.
Tool classes.

Namespaces

namespace Rx

Macros

#define | RX_IMG_BAYER_BG 0x2002
#define | RX_IMG_BAYER_GB 0x2004
#define | RX_IMG_BAYER_GR 0x2003
#define | RX_IMG_BAYER_RG 0x2001
Pixel color bayer types More...
#define | RX_IMG_BGR 0x80E0
#define | RX_IMG_BGRA 0x80E1
#define | RX_IMG_BYTE 0x1400
Image data types. More...
#define | RX_IMG_DOUBLE 0x140A
#define | RX_IMG_FLOAT 0x1406
#define | RX_IMG_INT 0x1404
#define | RX_IMG_LUMINANCE 0x1909
#define | RX_IMG_LUMINANCE_ALPHA 0x190A
#define | RX_IMG_RGB 0x1907
Pixel color types. More...
#define | RX_IMG_RGBA 0x1908
#define | RX_IMG_SHORT 0x1402
#define | RX_IMG_UNSIGNED_BYTE 0x1401
#define | RX_IMG_UNSIGNED_INT 0x1405
#define | RX_IMG_UNSIGNED_SHORT 0x1403
#define | RXCORE_API __declspec(dllimport)

Typedefs

typedef unsigned char | uchar
typedef unsigned int | uint

Functions

double | Rx::GetTime ()
__int64 | Rx::GetTime64 ()
void | Rx::InitTime ()
void | Rx::Sleep (unsigned uTime)

Detailed Description

The Raytrix core classes currently offer classes to hold image data of various pixel and data types.

The template class TPixel allows for the representation of various pixel types, by not only using the data type as template parameter, but also the position of the various color and alpha elements within each pixel. Access to the pixel components is then possible with member inline functions r(), g(), b(), a(), which map to the correct position with a pixel.

The functions Float2Pixel() and Pixel2Float() are template functions that cast the pixel data type to float and vice versa.

Macro Definition Documentation

#define RX_IMG_BAYER_BG 0x2002
#define RX_IMG_BAYER_GB 0x2004
#define RX_IMG_BAYER_GR 0x2003
#define RX_IMG_BAYER_RG 0x2001

Pixel color bayer types

#define RX_IMG_BGR 0x80E0
#define RX_IMG_BGRA 0x80E1
#define RX_IMG_BYTE 0x1400

Image data types.

#define RX_IMG_DOUBLE 0x140A
#define RX_IMG_FLOAT 0x1406
#define RX_IMG_INT 0x1404
#define RX_IMG_LUMINANCE 0x1909
#define RX_IMG_LUMINANCE_ALPHA 0x190A
#define RX_IMG_RGB 0x1907

Pixel color types.

#define RX_IMG_RGBA 0x1908
#define RX_IMG_SHORT 0x1402
#define RX_IMG_UNSIGNED_BYTE 0x1401
#define RX_IMG_UNSIGNED_INT 0x1405
#define RX_IMG_UNSIGNED_SHORT 0x1403
#define RXCORE_API __declspec(dllimport)

Typedef Documentation

typedef unsigned char uchar
typedef unsigned int uint

Function Documentation

double Rx::GetTime ( )
__int64 Rx::GetTime64 ( )
void Rx::InitTime ( )
void Rx::Sleep ( unsigned uTime )


Image classes.

Namespaces | Data Structures | Typedefs | Enumerations | Enumerator | Functions
Image classes.
The Raytrix Core Classes API

Namespaces

namespace | Rx::Interop::Runtime28::EDataType
The image data types.
namespace | Rx::Interop::Runtime28::EPixelType
The image pixel types.

Data Structures

class | Rx::CRxImage
Image class. Implements the interface IImage. More...
class | Rx::CRxImageFormat
Image format descriptor. More...
class | Rx::CRxImageMoniker
Image moniker class. Implements the interface IImage but does not allocate memory. More...
class | Rx::Interop::Runtime28::IImage
Interface supported by Raytrix images. More...
struct | Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
General pixel template structure. More...

Typedefs

typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_BYTE > 		Rx::TPixel_Bay_BG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_BG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_BG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_INT > 		Rx::TPixel_Bay_BG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_SHORT > 		Rx::TPixel_Bay_BG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_BG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_BG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_BG_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_BYTE > 		Rx::TPixel_Bay_GB_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_GB_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_GB_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_INT > 		Rx::TPixel_Bay_GB_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_SHORT > 		Rx::TPixel_Bay_GB_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_GB_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_GB_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_GB_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_BYTE > 		Rx::TPixel_Bay_GR_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_GR_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_GR_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_INT > 		Rx::TPixel_Bay_GR_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_SHORT > 		Rx::TPixel_Bay_GR_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_GR_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_GR_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_GR_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_BYTE > 		Rx::TPixel_Bay_RG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_RG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_RG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_INT > 		Rx::TPixel_Bay_RG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_SHORT > 		Rx::TPixel_Bay_RG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_RG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_RG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_RG_us
typedef TPixel< char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_BYTE > 		Rx::TPixel_BGR_c
typedef TPixel< double,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_DOUBLE > 		Rx::TPixel_BGR_d
typedef TPixel< float,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_FLOAT > 		Rx::TPixel_BGR_f
typedef TPixel< __int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_INT > 		Rx::TPixel_BGR_i
typedef TPixel< __int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_SHORT > 		Rx::TPixel_BGR_s
typedef TPixel< unsigned char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_BGR_uc
typedef TPixel< unsigned
__int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_BGR_ui
typedef TPixel< unsigned
__int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_BGR_us
typedef TPixel< char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_BYTE > 		Rx::TPixel_BGRA_c
typedef TPixel< double,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_DOUBLE > 		Rx::TPixel_BGRA_d
typedef TPixel< float,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_FLOAT > 		Rx::TPixel_BGRA_f
typedef TPixel< __int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_INT > 		Rx::TPixel_BGRA_i
typedef TPixel< __int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_SHORT > 		Rx::TPixel_BGRA_s
typedef TPixel< unsigned char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_BGRA_uc
typedef TPixel< unsigned
__int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_BGRA_ui
typedef TPixel< unsigned
__int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_BGRA_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_BYTE > 		Rx::TPixel_L_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_DOUBLE > 		Rx::TPixel_L_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_FLOAT > 		Rx::TPixel_L_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_INT > 		Rx::TPixel_L_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_SHORT > 		Rx::TPixel_L_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_L_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_L_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_L_us
typedef TPixel< char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_BYTE > 		Rx::TPixel_LA_c
typedef TPixel< double,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_DOUBLE > 		Rx::TPixel_LA_d
typedef TPixel< float,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_FLOAT > 		Rx::TPixel_LA_f
typedef TPixel< __int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_INT > 		Rx::TPixel_LA_i
typedef TPixel< __int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_SHORT > 		Rx::TPixel_LA_s
typedef TPixel< unsigned char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_LA_uc
typedef TPixel< unsigned
__int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_LA_ui
typedef TPixel< unsigned
__int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_LA_us
typedef TPixel< char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_BYTE > 		Rx::TPixel_RGB_c
typedef TPixel< double,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_DOUBLE > 		Rx::TPixel_RGB_d
typedef TPixel< float,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_FLOAT > 		Rx::TPixel_RGB_f
typedef TPixel< __int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_INT > 		Rx::TPixel_RGB_i
typedef TPixel< __int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_SHORT > 		Rx::TPixel_RGB_s
typedef TPixel< unsigned char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_RGB_uc
typedef TPixel< unsigned
__int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_RGB_ui
typedef TPixel< unsigned
__int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_RGB_us
typedef TPixel< char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_BYTE > 		Rx::TPixel_RGBA_c
typedef TPixel< double,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_DOUBLE > 		Rx::TPixel_RGBA_d
typedef TPixel< float,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_FLOAT > 		Rx::TPixel_RGBA_f
typedef TPixel< __int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_INT > 		Rx::TPixel_RGBA_i
typedef TPixel< __int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_SHORT > 		Rx::TPixel_RGBA_s
typedef TPixel< unsigned char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_RGBA_uc
typedef TPixel< unsigned
__int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_RGBA_ui
typedef TPixel< unsigned
__int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_RGBA_us

Enumerations

enum Rx::Interop::Runtime28::EDataType::ID {
Rx::Interop::Runtime28::EDataType::Void = 0, Rx::Interop::Runtime28::EDataType::Byte = RX_IMG_BYTE, Rx::Interop::Runtime28::EDataType::UByte = RX_IMG_UNSIGNED_BYTE, Rx::Interop::Runtime28::EDataType::Short = RX_IMG_SHORT, Rx::Interop::Runtime28::EDataType::UShort = RX_IMG_UNSIGNED_SHORT, Rx::Interop::Runtime28::EDataType::Int = RX_IMG_INT, Rx::Interop::Runtime28::EDataType::UInt = RX_IMG_UNSIGNED_INT, Rx::Interop::Runtime28::EDataType::Float = RX_IMG_FLOAT,
Rx::Interop::Runtime28::EDataType::Double = RX_IMG_DOUBLE
}
enum Rx::Interop::Runtime28::EPixelType::ID {
Rx::Interop::Runtime28::EPixelType::None = 0, Rx::Interop::Runtime28::EPixelType::RGB = RX_IMG_RGB, Rx::Interop::Runtime28::EPixelType::RGBA = RX_IMG_RGBA, Rx::Interop::Runtime28::EPixelType::BGR = RX_IMG_BGR, Rx::Interop::Runtime28::EPixelType::BGRA = RX_IMG_BGRA, Rx::Interop::Runtime28::EPixelType::Lum = RX_IMG_LUMINANCE, Rx::Interop::Runtime28::EPixelType::LumA = RX_IMG_LUMINANCE_ALPHA, Rx::Interop::Runtime28::EPixelType::BayerBG = RX_IMG_BAYER_BG,
Rx::Interop::Runtime28::EPixelType::BayerGB = RX_IMG_BAYER_GB, Rx::Interop::Runtime28::EPixelType::BayerGR = RX_IMG_BAYER_GR, Rx::Interop::Runtime28::EPixelType::BayerRG = RX_IMG_BAYER_RG
}

Functions

void | Rx::Float2Pixel (char &rPx, float fVal)
void | Rx::Float2Pixel (unsigned char &rPx, float fVal)
void | Rx::Float2Pixel (short &rPx, float fVal)
void | Rx::Float2Pixel (unsigned short &rPx, float fVal)
void | Rx::Float2Pixel (int &rPx, float fVal)
void | Rx::Float2Pixel (unsigned int &rPx, float fVal)
void | Rx::Float2Pixel (float &rPx, float fVal)
void | Rx::Float2Pixel (double &rPx, float fVal)
void | Rx::Float2Pixel (char &rPx, double fVal)
void | Rx::Float2Pixel (unsigned char &rPx, double fVal)
void | Rx::Float2Pixel (short &rPx, double fVal)
void | Rx::Float2Pixel (unsigned short &rPx, double fVal)
void | Rx::Float2Pixel (int &rPx, double fVal)
void | Rx::Float2Pixel (unsigned int &rPx, double fVal)
void | Rx::Float2Pixel (float &rPx, double fVal)
void | Rx::Float2Pixel (double &rPx, double fVal)
void | Rx::Pixel2Float (float &fVal, char rPx)
void | Rx::Pixel2Float (float &fVal, unsigned char rPx)
void | Rx::Pixel2Float (float &fVal, short rPx)
void | Rx::Pixel2Float (float &fVal, unsigned short rPx)
void | Rx::Pixel2Float (float &fVal, int rPx)
void | Rx::Pixel2Float (float &fVal, unsigned int rPx)
void | Rx::Pixel2Float (float &fVal, float rPx)
void | Rx::Pixel2Float (float &fVal, double rPx)
void | Rx::Pixel2Float (double &fVal, char rPx)
void | Rx::Pixel2Float (double &fVal, unsigned char rPx)
void | Rx::Pixel2Float (double &fVal, short rPx)
void | Rx::Pixel2Float (double &fVal, unsigned short rPx)
void | Rx::Pixel2Float (double &fVal, int rPx)
void | Rx::Pixel2Float (double &fVal, unsigned int rPx)
void | Rx::Pixel2Float (double &fVal, float rPx)
void | Rx::Pixel2Float (double &fVal, double rPx)

Detailed Description

Typedef Documentation

typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_BYTE> Rx::TPixel_Bay_BG_c
typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_DOUBLE> Rx::TPixel_Bay_BG_d
typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_FLOAT> Rx::TPixel_Bay_BG_f
typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_INT> Rx::TPixel_Bay_BG_i
typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_SHORT> Rx::TPixel_Bay_BG_s
typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_Bay_BG_uc
typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_INT> Rx::TPixel_Bay_BG_ui
typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_Bay_BG_us
typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_BYTE> Rx::TPixel_Bay_GB_c
typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_DOUBLE> Rx::TPixel_Bay_GB_d
typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_FLOAT> Rx::TPixel_Bay_GB_f
typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_INT> Rx::TPixel_Bay_GB_i
typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_SHORT> Rx::TPixel_Bay_GB_s
typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_Bay_GB_uc
typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_INT> Rx::TPixel_Bay_GB_ui
typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_Bay_GB_us
typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_BYTE> Rx::TPixel_Bay_GR_c
typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_DOUBLE> Rx::TPixel_Bay_GR_d
typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_FLOAT> Rx::TPixel_Bay_GR_f
typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_INT> Rx::TPixel_Bay_GR_i
typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_SHORT> Rx::TPixel_Bay_GR_s
typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_Bay_GR_uc
typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_INT> Rx::TPixel_Bay_GR_ui
typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_Bay_GR_us
typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_BYTE> Rx::TPixel_Bay_RG_c
typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_DOUBLE> Rx::TPixel_Bay_RG_d
typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_FLOAT> Rx::TPixel_Bay_RG_f
typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_INT> Rx::TPixel_Bay_RG_i
typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_SHORT> Rx::TPixel_Bay_RG_s
typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_Bay_RG_uc
typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_INT> Rx::TPixel_Bay_RG_ui
typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_Bay_RG_us
typedef TPixel<char, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_BYTE> Rx::TPixel_BGR_c
typedef TPixel<double, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_DOUBLE> Rx::TPixel_BGR_d
typedef TPixel<float, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_FLOAT> Rx::TPixel_BGR_f
typedef TPixel<__int32, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_INT> Rx::TPixel_BGR_i
typedef TPixel<__int16, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_SHORT> Rx::TPixel_BGR_s
typedef TPixel<unsigned char, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_BGR_uc
typedef TPixel<unsigned __int32, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_INT> Rx::TPixel_BGR_ui
typedef TPixel<unsigned __int16, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_BGR_us
typedef TPixel<char, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_BYTE> Rx::TPixel_BGRA_c
typedef TPixel<double, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_DOUBLE> Rx::TPixel_BGRA_d
typedef TPixel<float, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_FLOAT> Rx::TPixel_BGRA_f
typedef TPixel<__int32, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_INT> Rx::TPixel_BGRA_i
typedef TPixel<__int16, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_SHORT> Rx::TPixel_BGRA_s
typedef TPixel<unsigned char, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_BGRA_uc
typedef TPixel<unsigned __int32, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_INT> Rx::TPixel_BGRA_ui
typedef TPixel<unsigned __int16, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_BGRA_us
typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_BYTE> Rx::TPixel_L_c
typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_DOUBLE> Rx::TPixel_L_d
typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_FLOAT> Rx::TPixel_L_f
typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_INT> Rx::TPixel_L_i
typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_SHORT> Rx::TPixel_L_s
typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_L_uc
typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_INT> Rx::TPixel_L_ui
typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_L_us
typedef TPixel<char, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_BYTE> Rx::TPixel_LA_c
typedef TPixel<double, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_DOUBLE> Rx::TPixel_LA_d
typedef TPixel<float, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_FLOAT> Rx::TPixel_LA_f
typedef TPixel<__int32, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_INT> Rx::TPixel_LA_i
typedef TPixel<__int16, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_SHORT> Rx::TPixel_LA_s
typedef TPixel<unsigned char, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_LA_uc
typedef TPixel<unsigned __int32, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_INT> Rx::TPixel_LA_ui
typedef TPixel<unsigned __int16, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_LA_us
typedef TPixel<char, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_BYTE> Rx::TPixel_RGB_c
typedef TPixel<double, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_DOUBLE> Rx::TPixel_RGB_d
typedef TPixel<float, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_FLOAT> Rx::TPixel_RGB_f
typedef TPixel<__int32, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_INT> Rx::TPixel_RGB_i
typedef TPixel<__int16, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_SHORT> Rx::TPixel_RGB_s
typedef TPixel<unsigned char, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_RGB_uc
typedef TPixel<unsigned __int32, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_INT> Rx::TPixel_RGB_ui
typedef TPixel<unsigned __int16, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_RGB_us
typedef TPixel<char, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_BYTE> Rx::TPixel_RGBA_c
typedef TPixel<double, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_DOUBLE> Rx::TPixel_RGBA_d
typedef TPixel<float, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_FLOAT> Rx::TPixel_RGBA_f
typedef TPixel<__int32, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_INT> Rx::TPixel_RGBA_i
typedef TPixel<__int16, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_SHORT> Rx::TPixel_RGBA_s
typedef TPixel<unsigned char, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_BYTE> Rx::TPixel_RGBA_uc
typedef TPixel<unsigned __int32, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_INT> Rx::TPixel_RGBA_ui
typedef TPixel<unsigned __int16, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_SHORT> Rx::TPixel_RGBA_us

Enumeration Type Documentation

enum Rx::Interop::Runtime28::EDataType::ID
Enumerator
Void
Byte
UByte
Short
UShort
Int
UInt
Float
Double
enum Rx::Interop::Runtime28::EPixelType::ID
Enumerator
None
RGB
RGBA
BGR
BGRA
Lum
LumA
BayerBG
BayerGB
BayerGR
BayerRG

Function Documentation

void Rx::Float2Pixel | ( | char & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned char & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | short & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned short & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | int & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned int & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | float & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | double & | rPx,
 |  | float | fVal
 | ) |  |
void Rx::Float2Pixel | ( | char & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned char & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | short & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned short & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | int & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | unsigned int & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | float & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Float2Pixel | ( | double & | rPx,
 |  | double | fVal
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | char | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | unsigned char | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | short | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | unsigned short | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | int | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | unsigned int | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | float | rPx
 | ) |  |
void Rx::Pixel2Float | ( | float & | fVal,
 |  | double | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | char | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | unsigned char | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | short | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | unsigned short | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | int | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | unsigned int | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | float | rPx
 | ) |  |
void Rx::Pixel2Float | ( | double & | fVal,
 |  | double | rPx
 | ) |  |


Rx::Interop::Runtime28::EDataType Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • Interop
  • Runtime28
  • EDataType
Enumerations
Rx::Interop::Runtime28::EDataType Namespace Reference
Image classes.

The image data types. More...

Enumerations

enum ID {
Void = 0, Byte = RX_IMG_BYTE, UByte = RX_IMG_UNSIGNED_BYTE, Short = RX_IMG_SHORT, UShort = RX_IMG_UNSIGNED_SHORT, Int = RX_IMG_INT, UInt = RX_IMG_UNSIGNED_INT, Float = RX_IMG_FLOAT,
Double = RX_IMG_DOUBLE
}

Detailed Description

The image data types.


Rx::Interop::Runtime28::EPixelType Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • Interop
  • Runtime28
  • EPixelType
Enumerations
Rx::Interop::Runtime28::EPixelType Namespace Reference
Image classes.

The image pixel types. More...

Enumerations

enum ID {
None = 0, RGB = RX_IMG_RGB, RGBA = RX_IMG_RGBA, BGR = RX_IMG_BGR, BGRA = RX_IMG_BGRA, Lum = RX_IMG_LUMINANCE, LumA = RX_IMG_LUMINANCE_ALPHA, BayerBG = RX_IMG_BAYER_BG,
BayerGB = RX_IMG_BAYER_GB, BayerGR = RX_IMG_BAYER_GR, BayerRG = RX_IMG_BAYER_RG
}

Detailed Description

The image pixel types.


Rx::CRxImage Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxImage
Public Member Functions | Static Public Member Functions | Static Protected Member Functions | Protected Attributes
Rx::CRxImage Class Reference
Image classes.

Image class. Implements the interface IImage. More...

#include <RxImage.h>

Inheritance diagram for Rx::CRxImage:
Rx::Interop::Runtime28::IImage

Public Member Functions

CRxImage (void)
CRxImage (const CRxImage &xImage)
virtual | ~CRxImage (void)
bool | ConvertType (CRxImage &xImage, EPixelType::ID ePixelType, EDataType::ID eDataType) const
Convert this image to a different type and store result in xImage. More...
virtual bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType)
Create an image of given type and size and reserve the appopriate amount of memory. More...
virtual bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData)
Create an image of given type and size and copy the data from the given pointer. More...
virtual bool | Create (const IImage *pImage)
Create an image as copy of the given image. More...
bool | Create (const Rx::CRxImageFormat &xFormat)
Create an image of given type and size and reserve the appopriate amount of memory. More...
bool | Create (const CRxImage &xImage)
Create image from given image. More...
virtual bool | Destroy ()
Destroy image. More...
virtual unsigned | GetByteCount () const
Get the number of bytes of the whole image. More...
virtual int | GetBytesPerPixel () const
Get number of bytes per pixel. More...
virtual void * | GetDataPtr ()
Return the pointer to the data array. More...
virtual const void * | GetDataPtr () const
Return the constant pointer to the data array. More...
virtual const Rx::CRxImageFormat & | GetFormat () const
Get the image format. More...
virtual unsigned | GetPixelCount () const
Get the number of pixels. More...
virtual void | GetSize (int &iWidth, int &iHeight) const
Get width and height of image. More...
virtual void | GetType (Rx::EPixelType::ID &ePixelType, Rx::EDataType::ID &eDataType) const
Get pixel and data type of image. More...
bool | IsOfType (Rx::EPixelType::ID ePixelType, Rx::EDataType::ID eDataType) const
Test whether image is of a particular pixel and data type. More...
virtual bool | IsValid () const
Test whether this image exists. More...
bool | Normalize ()
Find minimal and maximal value of image and normalize image to range [0,1]. More...
CRxImage & | operator= (const CRxImage &xImage)
Copy the contents of an image. More...
bool | Set (const CRxImage &xImage)
Set this image with the contents of the given image. More...
bool | Set (const void *pvData)
Set this image with the contents of the given pointer. More...
void | SetZero ()
- Public Member Functions inherited from Rx::Interop::Runtime28::IImage
virtual void | GetType (EPixelType::ID &ePixelType, EDataType::ID &eDataType) const =0
Gets the type of this image. More...

Static Public Member Functions

static bool ConvertType (IImage *pDstImg, const IImage *pSrcImg, EPixelType::ID ePixelType, EDataType::ID eDataType, bool bCreate)
Convert the pSrcImage to a different type and store result in pDstImage. More...

Static Protected Member Functions

template<class TPix >
static bool | ConvertTypeSub1 (const IImage *pSrcImg, TPix *pTrgPix)
template<class TTrgPix , class TSrcPix >
static bool | ConvertTypeSub2 (const IImage *pSrcImg, TTrgPix *pTrgPix, const TSrcPix *pSrcPix)

Protected Attributes

void * m_pvData
CRxImageFormat m_xFormat

Detailed Description

Image class. Implements the interface IImage.

    This class implements only the basic functionality for an image like create, delete and
    convert. All image processing has to be implemented separately.

    The format of an image is described by the class Rx::CRxImageFormat. It consits of an
    image width, height, a pixel type and a data type. The pixel type defines the number and
    order of color channels, and the data type specifies the data type of each color channel.
    For example, the pixel type can be RGBA or BGRA and the data type may be unsigned byte
    (8bit) or unsigned short (16bit). The various pixel types available are defined in \link
    #Rx::EPixelType::ID EPixelType\endlink and the data types in \link #Rx::EDataType::ID
    EDataType\endlink. Note that the values of the data type and pixel type defines are
    identical to the corresponding OpenGL IDs.

    All possible pixel and data types are represented by the \link #Rx::TPixel TPixel\
    endlink template structure. Specializations of this template structure cover all possible
    combinations of the defined pixel types and data types. The specialization names have the
    form
    TPixel_[Pixel Type]_[Data Type]. For example, the pixel structure
    for an RGBA unsigned char image is TPixel_RGBA_uc.

    The main advantage of using the TPixel_* typedefs to access the pixels of an image is,
    that you can write templated functions that work on many different pixel types. The
    TPixel structure defines functions to access the various color channels that map to the
    correct element within a pixel.

    The pointer to the image data can be obtained with the function GetDataPtr().

Perwass, 08.08.2012.

Constructor & Destructor Documentation

Rx::CRxImage::CRxImage ( void )
Rx::CRxImage::CRxImage ( const CRxImage & xImage )
virtual Rx::CRxImage::~CRxImage ( void )
virtual

Member Function Documentation

bool Rx::CRxImage::ConvertType | ( | CRxImage & | xImage,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType
 | ) |  | const

Convert this image to a different type and store result in xImage.

Parameters
xImage | The image instance into which to write the result. The size of this image is adapted to this size.
ePixelType | The target pixel type.
eDataType | The targer data type.
Returns
false if an error occured, otherwise true.
static bool Rx::CRxImage::ConvertType | ( | IImage * | pDstImg,
 |  | const IImage * | pSrcImg,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType,
 |  | bool | bCreate
 | ) |  |
static

Convert the pSrcImage to a different type and store result in pDstImage.

Perwass, 08.08.2012.

Parameters
pDstImg | [in,out] Pointer to target image interface.
pSrcImg | Pointer to source image interface.
ePixelType | The target pixel type.
eDataType | The targer data type.
bCreate | If true, the memory for the target image is created.
Returns
false if an error occured, otherwise true.
template<class TPix >
static bool Rx::CRxImage::ConvertTypeSub1 | ( | const IImage * | pSrcImg,
 |  | TPix * | pTrgPix
 | ) |  |
staticprotected
template<class TTrgPix , class TSrcPix >
static bool Rx::CRxImage::ConvertTypeSub2 | ( | const IImage * | pSrcImg,
 |  | TTrgPix * | pTrgPix,
 |  | const TSrcPix * | pSrcPix
 | ) |  |
staticprotected
virtual bool Rx::CRxImage::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType
 | ) |  |
virtual

Create an image of given type and size and reserve the appopriate amount of memory.

Implements Rx::Interop::Runtime28::IImage.

virtual bool Rx::CRxImage::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType,
 |  | const void * | pData
 | ) |  |
virtual

Create an image of given type and size and copy the data from the given pointer.

Implements Rx::Interop::Runtime28::IImage.

virtual bool Rx::CRxImage::Create ( const IImage * pImage )
virtual

Create an image as copy of the given image.

Implements Rx::Interop::Runtime28::IImage.

bool Rx::CRxImage::Create ( const Rx::CRxImageFormat & xFormat )

Create an image of given type and size and reserve the appopriate amount of memory.

bool Rx::CRxImage::Create ( const CRxImage & xImage )

Create image from given image.

virtual bool Rx::CRxImage::Destroy ( )
virtual

Destroy image.

Implements Rx::Interop::Runtime28::IImage.

virtual unsigned Rx::CRxImage::GetByteCount ( ) const
inlinevirtual

Get the number of bytes of the whole image.

Implements Rx::Interop::Runtime28::IImage.

virtual int Rx::CRxImage::GetBytesPerPixel ( ) const
inlinevirtual

Get number of bytes per pixel.

Implements Rx::Interop::Runtime28::IImage.

virtual void* Rx::CRxImage::GetDataPtr ( )
inlinevirtual

Return the pointer to the data array.

Implements Rx::Interop::Runtime28::IImage.

virtual const void* Rx::CRxImage::GetDataPtr ( ) const
inlinevirtual

Return the constant pointer to the data array.

Implements Rx::Interop::Runtime28::IImage.

virtual const Rx::CRxImageFormat& Rx::CRxImage::GetFormat ( ) const
inlinevirtual

Get the image format.

virtual unsigned Rx::CRxImage::GetPixelCount ( ) const
inlinevirtual

Get the number of pixels.

Implements Rx::Interop::Runtime28::IImage.

virtual void Rx::CRxImage::GetSize | ( | int & | iWidth,
 |  | int & | iHeight
 | ) |  | const
 inlinevirtual

Get width and height of image.

Implements Rx::Interop::Runtime28::IImage.

virtual void Rx::CRxImage::GetType | ( | Rx::EPixelType::ID & | ePixelType,
 |  | Rx::EDataType::ID & | eDataType
 | ) |  | const
 inlinevirtual

Get pixel and data type of image.

bool Rx::CRxImage::IsOfType | ( | Rx::EPixelType::ID | ePixelType,
 |  | Rx::EDataType::ID | eDataType
 | ) |  | const
 inline

Test whether image is of a particular pixel and data type.

virtual bool Rx::CRxImage::IsValid ( ) const
inlinevirtual

Test whether this image exists.

Implements Rx::Interop::Runtime28::IImage.

bool Rx::CRxImage::Normalize ( )

Find minimal and maximal value of image and normalize image to range [0,1].

Attention
Is currently only implemented for pixel type TPixel_L_f.
CRxImage& Rx::CRxImage::operator= ( const CRxImage & xImage )

Copy the contents of an image.

bool Rx::CRxImage::Set ( const CRxImage & xImage )

Set this image with the contents of the given image.

Expects that image formats are identical.

bool Rx::CRxImage::Set ( const void * pvData )

Set this image with the contents of the given pointer.

Expects that image formats are identical.

void Rx::CRxImage::SetZero ( )

Field Documentation

void* Rx::CRxImage::m_pvData
protected
CRxImageFormat Rx::CRxImage::m_xFormat
protected
The documentation for this class was generated from the following file:
  • RxImage.h


Rx::CRxImageFormat Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxImageFormat
Public Member Functions | Data Fields
Rx::CRxImageFormat Class Reference
Image classes.

Image format descriptor. More...

#include <RxImageFormat.h>

Public Member Functions

CRxImageFormat (void)
unsigned | GetByteCount () const
int | GetBytesPerPixel () const
unsigned | GetPixelCount () const
bool | IsBayerPixelType ()
template<class TPix >
bool | IsOfType ()
Test whether format is of particular pixel type. More...
bool | operator!= (const CRxImageFormat &xFormat) const
bool | operator== (const CRxImageFormat &xFormat) const
void | Reset ()
std::string | ToString () const

Data Fields

Rx::Interop::Runtime28::EDataType::ID m_eDataType
Rx::Interop::Runtime28::EPixelType::ID m_ePixelType
int | m_iHeight
int | m_iWidth

Detailed Description

Image format descriptor.

Constructor & Destructor Documentation

Rx::CRxImageFormat::CRxImageFormat ( void )
inline

Member Function Documentation

unsigned Rx::CRxImageFormat::GetByteCount ( ) const
inline
int Rx::CRxImageFormat::GetBytesPerPixel ( ) const
inline
unsigned Rx::CRxImageFormat::GetPixelCount ( ) const
inline
bool Rx::CRxImageFormat::IsBayerPixelType ( )
inline
template<class TPix >
bool Rx::CRxImageFormat::IsOfType ( )
inline

Test whether format is of particular pixel type.

This function uses the static function IsOfType() of the pixel types to check whether the given template parameter pixel type matches the pixel and data types of this instance.

bool Rx::CRxImageFormat::operator!= ( const CRxImageFormat & xFormat ) const
inline
bool Rx::CRxImageFormat::operator== ( const CRxImageFormat & xFormat ) const
inline
void Rx::CRxImageFormat::Reset ( )
inline
std::string Rx::CRxImageFormat::ToString ( ) const
inline

Field Documentation

Rx::Interop::Runtime28::EDataType::ID Rx::CRxImageFormat::m_eDataType
Rx::Interop::Runtime28::EPixelType::ID Rx::CRxImageFormat::m_ePixelType
int Rx::CRxImageFormat::m_iHeight
int Rx::CRxImageFormat::m_iWidth
The documentation for this class was generated from the following file:
  • RxImageFormat.h


Rx::CRxImageMoniker Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxImageMoniker
Public Member Functions | Protected Attributes
Rx::CRxImageMoniker Class Reference
Image classes.

Image moniker class. Implements the interface IImage but does not allocate memory. More...

#include <RxImageMoniker.h>

Inheritance diagram for Rx::CRxImageMoniker:
Rx::Interop::Runtime28::IImage

Public Member Functions

CRxImageMoniker (void)
CRxImageMoniker (const CRxImageMoniker &xMoniker)
virtual | ~CRxImageMoniker (void)
virtual bool | Create (int iWidth, int iHeight, int iPixelType, int iDataType)
Set image format data to given type and size. No memory is allocated and internal data pointer is set to zero. More...
virtual bool | Create (int iWidth, int iHeight, int iPixelType, int iDataType, const void *pData)
Set image format to given type and size and set internal data pointer to given data pointer. More...
bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType)
Set image format data to given type and size. No memory is allocated and internal data pointer is set to zero. More...
bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData)
Set image format to given type and size and set internal data pointer to given data pointer. More...
virtual bool | Create (const IImage *pImage)
Create an image moniker for given image. More...
bool | Create (const Rx::CRxImageFormat &xFormat)
Set image format to given format. The internal data pointer is set to zero. More...
bool | Create (const Rx::CRxImage &xImage)
Set image format to image format of given image and set internal data pointer to data pointer of given image. More...
virtual bool | Destroy ()
Set internal data pointer to zero and reset image format data. More...
virtual unsigned | GetByteCount () const
Get the number of bytes of the whole image. More...
virtual int | GetBytesPerPixel () const
Get number of bytes per pixel. More...
virtual void * | GetDataPtr ()
Return the pointer to the data array. More...
virtual const void * | GetDataPtr () const
Return the constant pointer to the data array. More...
const Rx::CRxImageFormat & | GetFormat () const
Get the image format. More...
virtual unsigned | GetPixelCount () const
Get the number of pixels. More...
virtual void | GetSize (int &iWidth, int &iHeight) const
Get width and height of image. More...
virtual void | GetType (int &iPixelType, int &iDataType) const
Get pixel and data type of image. More...
void | GetType (Rx::EPixelType::ID &ePixelType, Rx::EDataType::ID &eDataType) const
Get pixel and data type of image. More...
bool | IsOfType (Rx::EPixelType::ID ePixelType, Rx::EDataType::ID eDataType) const
Test whether image is of a particular pixel and data type. More...
virtual bool | IsValid () const
Test whether data pointer is not zero. More...
CRxImageMoniker & | operator= (const CRxImageMoniker &xMoniker)
bool | Set (const void *pvData)
Set internal data pointer to given data pointer. More...
- Public Member Functions inherited from Rx::Interop::Runtime28::IImage
virtual void | GetType (EPixelType::ID &ePixelType, EDataType::ID &eDataType) const =0
Gets the type of this image. More...

Protected Attributes

void * m_pvData
CRxImageFormat m_xFormat

Detailed Description

Image moniker class. Implements the interface IImage but does not allocate memory.

This class implements the basic functionality for an image, but does not create its own memory block. Instead, it can hold the pointer to an image memory block created by some other means. This class therefore does not free the memory the data pointer points to, when it is deleted.

Constructor & Destructor Documentation

Rx::CRxImageMoniker::CRxImageMoniker ( void )
Rx::CRxImageMoniker::CRxImageMoniker ( const CRxImageMoniker & xMoniker )
virtual Rx::CRxImageMoniker::~CRxImageMoniker ( void )
virtual

Member Function Documentation

virtual bool Rx::CRxImageMoniker::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | int | iPixelType,
 |  | int | iDataType
 | ) |  |
virtual

Set image format data to given type and size. No memory is allocated and internal data pointer is set to zero.

virtual bool Rx::CRxImageMoniker::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | int | iPixelType,
 |  | int | iDataType,
 |  | const void * | pData
 | ) |  |
virtual

Set image format to given type and size and set internal data pointer to given data pointer.

bool Rx::CRxImageMoniker::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType
 | ) |  |
virtual

Set image format data to given type and size. No memory is allocated and internal data pointer is set to zero.

Implements Rx::Interop::Runtime28::IImage.

bool Rx::CRxImageMoniker::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType,
 |  | const void * | pData
 | ) |  |
virtual

Set image format to given type and size and set internal data pointer to given data pointer.

Implements Rx::Interop::Runtime28::IImage.

virtual bool Rx::CRxImageMoniker::Create ( const IImage * pImage )
virtual

Create an image moniker for given image.

Implements Rx::Interop::Runtime28::IImage.

bool Rx::CRxImageMoniker::Create ( const Rx::CRxImageFormat & xFormat )

Set image format to given format. The internal data pointer is set to zero.

bool Rx::CRxImageMoniker::Create ( const Rx::CRxImage & xImage )

Set image format to image format of given image and set internal data pointer to data pointer of given image.

virtual bool Rx::CRxImageMoniker::Destroy ( )
virtual

Set internal data pointer to zero and reset image format data.

Implements Rx::Interop::Runtime28::IImage.

virtual unsigned Rx::CRxImageMoniker::GetByteCount ( ) const
inlinevirtual

Get the number of bytes of the whole image.

Implements Rx::Interop::Runtime28::IImage.

virtual int Rx::CRxImageMoniker::GetBytesPerPixel ( ) const
inlinevirtual

Get number of bytes per pixel.

Implements Rx::Interop::Runtime28::IImage.

virtual void* Rx::CRxImageMoniker::GetDataPtr ( )
inlinevirtual

Return the pointer to the data array.

Implements Rx::Interop::Runtime28::IImage.

virtual const void* Rx::CRxImageMoniker::GetDataPtr ( ) const
inlinevirtual

Return the constant pointer to the data array.

Implements Rx::Interop::Runtime28::IImage.

const Rx::CRxImageFormat& Rx::CRxImageMoniker::GetFormat ( ) const
inline

Get the image format.

virtual unsigned Rx::CRxImageMoniker::GetPixelCount ( ) const
inlinevirtual

Get the number of pixels.

Implements Rx::Interop::Runtime28::IImage.

virtual void Rx::CRxImageMoniker::GetSize | ( | int & | iWidth,
 |  | int & | iHeight
 | ) |  | const
 inlinevirtual

Get width and height of image.

Implements Rx::Interop::Runtime28::IImage.

virtual void Rx::CRxImageMoniker::GetType | ( | int & | iPixelType,
 |  | int & | iDataType
 | ) |  | const
 inlinevirtual

Get pixel and data type of image.

void Rx::CRxImageMoniker::GetType | ( | Rx::EPixelType::ID & | ePixelType,
 |  | Rx::EDataType::ID & | eDataType
 | ) |  | const
 inline

Get pixel and data type of image.

bool Rx::CRxImageMoniker::IsOfType | ( | Rx::EPixelType::ID | ePixelType,
 |  | Rx::EDataType::ID | eDataType
 | ) |  | const
 inline

Test whether image is of a particular pixel and data type.

virtual bool Rx::CRxImageMoniker::IsValid ( ) const
inlinevirtual

Test whether data pointer is not zero.

Implements Rx::Interop::Runtime28::IImage.

CRxImageMoniker& Rx::CRxImageMoniker::operator= ( const CRxImageMoniker & xMoniker )
bool Rx::CRxImageMoniker::Set ( const void * pvData )

Set internal data pointer to given data pointer.

Field Documentation

void* Rx::CRxImageMoniker::m_pvData
protected
CRxImageFormat Rx::CRxImageMoniker::m_xFormat
protected
The documentation for this class was generated from the following file:
  • RxImageMoniker.h


Rx::Interop::Runtime28::IImage Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • Interop
  • Runtime28
  • IImage
Public Member Functions
Rx::Interop::Runtime28::IImage Class Referenceabstract
Image classes.

Interface supported by Raytrix images. More...

#include <RxIfcImage.h>

Inheritance diagram for Rx::Interop::Runtime28::IImage:
Rx::CRxImage Rx::CRxImageMoniker

Public Member Functions

virtual bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType)=0
Create an image of given type and size and reserve the appropriate amount of memory. We can use as input types enums as they stay compatible between module versions even if the enum declarations have different numbers of entries. More...
virtual bool | Create (int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData)=0
Create an image of given type and size and copy the data from the given pointer. More...
virtual bool | Create (const IImage *pImage)=0
Create image from given image. More...
virtual bool | Destroy ()=0
Destroy image. More...
virtual unsigned | GetByteCount () const =0
Gets the byte count. More...
virtual int | GetBytesPerPixel () const =0
Gets the bytes per pixel. More...
virtual void * | GetDataPtr ()=0
Gets the data pointer. More...
virtual const void * | GetDataPtr () const =0
Gets the data pointer. More...
virtual unsigned | GetPixelCount () const =0
Gets the pixel count. More...
virtual void | GetSize (int &iWidth, int &iHeight) const =0
Gets the size of this image. More...
virtual void | GetType (EPixelType::ID &ePixelType, EDataType::ID &eDataType) const =0
Gets the type of this image. More...
virtual bool | IsValid () const =0
Test whether this image exists. More...

Detailed Description

Interface supported by Raytrix images.

Member Function Documentation

virtual bool Rx::Interop::Runtime28::IImage::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType
 | ) |  |
pure virtual

Create an image of given type and size and reserve the appropriate amount of memory. We can use as input types enums as they stay compatible between module versions even if the enum declarations have different numbers of entries.

Parameters
iWidth | Zero-based index of the width.
iHeight | Zero-based index of the height.
ePixelType | Type of the pixel.
eDataType | Type of the data.
Returns
True if it succeeds, false if it fails.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual bool Rx::Interop::Runtime28::IImage::Create | ( | int | iWidth,
 |  | int | iHeight,
 |  | EPixelType::ID | ePixelType,
 |  | EDataType::ID | eDataType,
 |  | const void * | pData
 | ) |  |
pure virtual

Create an image of given type and size and copy the data from the given pointer.

Parameters
iWidth | Zero-based index of the width.
iHeight | Zero-based index of the height.
ePixelType | Type of the pixel.
eDataType | Type of the data.
pData | The data.
Returns
True if it succeeds, false if it fails.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual bool Rx::Interop::Runtime28::IImage::Create ( const IImage * pImage )
pure virtual

Create image from given image.

Parameters
pImage The image.
Returns
True if it succeeds, false if it fails.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual bool Rx::Interop::Runtime28::IImage::Destroy ( )
pure virtual

Destroy image.

Returns
True if it succeeds, false if it fails.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual unsigned Rx::Interop::Runtime28::IImage::GetByteCount ( ) const
pure virtual

Gets the byte count.

Returns
The byte count.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual int Rx::Interop::Runtime28::IImage::GetBytesPerPixel ( ) const
pure virtual

Gets the bytes per pixel.

Returns
The bytes per pixel.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual void* Rx::Interop::Runtime28::IImage::GetDataPtr ( )
pure virtual

Gets the data pointer.

Returns
Null if it fails, else the data pointer.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual const void* Rx::Interop::Runtime28::IImage::GetDataPtr ( ) const
pure virtual

Gets the data pointer.

Returns
Null if it fails, else the data pointer.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual unsigned Rx::Interop::Runtime28::IImage::GetPixelCount ( ) const
pure virtual

Gets the pixel count.

Returns
The pixel count.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual void Rx::Interop::Runtime28::IImage::GetSize | ( | int & | iWidth,
 |  | int & | iHeight
 | ) |  | const
 pure virtual

Gets the size of this image.

Parameters
iWidth | [out] The width.
iHeight | [out] The height.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

virtual void Rx::Interop::Runtime28::IImage::GetType | ( | EPixelType::ID & | ePixelType,
 |  | EDataType::ID & | eDataType
 | ) |  | const
 pure virtual

Gets the type of this image.

Parameters
ePixelType | [out] Type of the pixel.
eDataType | [out] Type of the data.
virtual bool Rx::Interop::Runtime28::IImage::IsValid ( ) const
pure virtual

Test whether this image exists.

Returns
True if valid, false if not.

Implemented in Rx::CRxImage, and Rx::CRxImageMoniker.

The documentation for this class was generated from the following file:
  • RxIfcImage.h


Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > Struct Template Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • TPixel
Public Types | Public Member Functions | Static Public Member Functions | Data Fields | Static Public Attributes
Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > Struct Template Reference
Image classes.

General pixel template structure. More...

#include <RxPixel.h>

Public Types

typedef TDataType TType

Public Member Functions

TDataType & | a ()
const TDataType & | a () const
TDataType & | b ()
const TDataType & | b () const
void | Clear ()
TDataType & | g ()
const TDataType & | g () const
TPixel< TDataType, tuColorCnt,
tuAlphaCnt, tiR, tiG, tiB, tiA,
tiPT, tiDT > & 		operator= (const TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > &rPix)
TDataType & | r ()
const TDataType & | r () const

Static Public Member Functions

static bool | IsOfType (int _iPixelType, int _iDataType)
static bool | IsOfType (Rx::EPixelType::ID _ePixelType, Rx::EDataType::ID _eDataType)

Data Fields

TDataType value [tuColorCnt+tuAlphaCnt]

Static Public Attributes

static const int | iAlphaIdx = tiA
static const int | iBlueIdx = tiB
static const int | iDataType = tiDT
static const int | iGreenIdx = tiG
static const int | iPixelType = tiPT
static const int | iRedIdx = tiR
static const unsigned | uAlphaCnt = tuAlphaCnt
static const unsigned | uAlphaSize = tuAlphaCnt*sizeof(TDataType)
static const unsigned | uColorCnt = tuColorCnt
static const unsigned | uColorSize = tuColorCnt*sizeof(TDataType)
static const unsigned | uSize = (tuColorCnt + tuAlphaCnt)*sizeof(TDataType)

Detailed Description

template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
struct Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >

General pixel template structure.

This structure allows the definition of all possible pixel types in such a way, that templated functions working on different image types can be written.

Member Typedef Documentation

template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
typedef TDataType Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::TType

Member Function Documentation

template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::a ( )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::a ( ) const
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::b ( )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::b ( ) const
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
void Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::Clear ( )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::g ( )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::g ( ) const
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
static bool Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::IsOfType | ( | int | _iPixelType,
 |  | int | _iDataType
 | ) |  |
inlinestatic
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
static bool Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::IsOfType | ( | Rx::EPixelType::ID | _ePixelType,
 |  | Rx::EDataType::ID | _eDataType
 | ) |  |
inlinestatic
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TPixel<TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT>& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::operator= ( const TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > & rPix )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::r ( )
inline
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const TDataType& Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::r ( ) const
inline

Field Documentation

template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iAlphaIdx = tiA
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iBlueIdx = tiB
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iDataType = tiDT
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iGreenIdx = tiG
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iPixelType = tiPT
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const int Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::iRedIdx = tiR
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const unsigned Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::uAlphaCnt = tuAlphaCnt
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const unsigned Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::uAlphaSize = tuAlphaCnt*sizeof(TDataType)
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const unsigned Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::uColorCnt = tuColorCnt
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const unsigned Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::uColorSize = tuColorCnt*sizeof(TDataType)
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
const unsigned Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::uSize = (tuColorCnt + tuAlphaCnt)*sizeof(TDataType)
static
template<class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA, int tiPT, int tiDT>
TDataType Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >::value[tuColorCnt+tuAlphaCnt]
The documentation for this struct was generated from the following file:
  • RxPixel.h


Tool classes.

Data Structures | Functions
Tool classes.
The Raytrix Core Classes API

Data Structures

class | Rx::CRxArrayDouble
Basic unsigned int array operations. More...
class | Rx::CRxArrayInt
Basic unsigned int array operations. More...
class | Rx::CRxArrayString
Basic unsigned int array operations. More...
class | Rx::CRxArrayUChar
Basic unsigned char array operations. More...
class | Rx::CRxArrayUInt
Basic unsigned int array operations. More...
class | Rx::CRxMetaData
Handles a collection of meta data of different types. More...
class | Rx::CRxString
Basic character string operations. More...

Functions

CRxString | Rx::operator+ (const CRxString &sxA, const CRxString &sxB)
CRxString | Rx::operator+ (const CRxString &sxA, const char *pcB)
CRxString | Rx::operator+ (const char *pcA, const CRxString &sxB)
CRxString | Rx::operator+ (const CRxString &sxA, int iVal)
CRxString | Rx::operator+ (const CRxString &sxA, unsigned int uVal)
CRxString | Rx::operator+ (const CRxString &sxA, float fVal)
CRxString | Rx::operator+ (const CRxString &sxA, double dVal)

Detailed Description

Function Documentation

CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | const CRxString & | sxB
 | ) |  |
CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | const char * | pcB
 | ) |  |
CRxString Rx::operator+ | ( | const char * | pcA,
 |  | const CRxString & | sxB
 | ) |  |
CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | int | iVal
 | ) |  |
CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | unsigned int | uVal
 | ) |  |
CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | float | fVal
 | ) |  |
CRxString Rx::operator+ | ( | const CRxString & | sxA,
 |  | double | dVal
 | ) |  |


Rx::CRxArrayDouble Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxArrayDouble
Public Types | Public Member Functions | Protected Attributes
Rx::CRxArrayDouble Class Reference
Tool classes.

Basic unsigned int array operations. More...

#include <RxArrayDouble.h>

Public Types

typedef double TValue

Public Member Functions

CRxArrayDouble ()
CRxArrayDouble (unsigned int uiLength)
CRxArrayDouble (const CRxArrayDouble &xArray)
virtual | ~CRxArrayDouble ()
TValue & | CRxArrayDouble::operator[] (unsigned int uiIdx)
const TValue & | CRxArrayDouble::operator[] (unsigned int uiIdx) const
void | Delete ()
TValue * GetDataPtr ()
const TValue * | GetDataPtr () const
bool | IsValid () const
unsigned int | Length () const
bool | New (unsigned int iSize)
CRxArrayDouble & | operator= (const CRxArrayDouble &xArray)
void | Reset ()
bool | Resize (unsigned int uiSize)

Protected Attributes

void * | m_pvData
unsigned int | m_uiLength

Detailed Description

Basic unsigned int array operations.

Member Typedef Documentation

typedef double Rx::CRxArrayDouble::TValue

Constructor & Destructor Documentation

Rx::CRxArrayDouble::CRxArrayDouble ( )
Rx::CRxArrayDouble::CRxArrayDouble ( unsigned int uiLength )
Rx::CRxArrayDouble::CRxArrayDouble ( const CRxArrayDouble & xArray )
virtual Rx::CRxArrayDouble::~CRxArrayDouble ( )
virtual

Member Function Documentation

TValue& Rx::CRxArrayDouble::CRxArrayDouble::operator[] ( unsigned int uiIdx )
const TValue& Rx::CRxArrayDouble::CRxArrayDouble::operator[] ( unsigned int uiIdx ) const
void Rx::CRxArrayDouble::Delete ( )
TValue* Rx::CRxArrayDouble::GetDataPtr ( )
const TValue* Rx::CRxArrayDouble::GetDataPtr ( ) const
bool Rx::CRxArrayDouble::IsValid ( ) const
unsigned int Rx::CRxArrayDouble::Length ( ) const
bool Rx::CRxArrayDouble::New ( unsigned int iSize )
CRxArrayDouble& Rx::CRxArrayDouble::operator= ( const CRxArrayDouble & xArray )
void Rx::CRxArrayDouble::Reset ( )
bool Rx::CRxArrayDouble::Resize ( unsigned int uiSize )

Field Documentation

void* Rx::CRxArrayDouble::m_pvData
protected
unsigned int Rx::CRxArrayDouble::m_uiLength
protected
The documentation for this class was generated from the following file:
  • RxArrayDouble.h


Rx::CRxArrayInt Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxArrayInt
Public Types | Public Member Functions | Protected Attributes
Rx::CRxArrayInt Class Reference
Tool classes.

Basic unsigned int array operations. More...

#include <RxArrayInt.h>

Public Types

typedef int TValue

Public Member Functions

CRxArrayInt ()
CRxArrayInt (unsigned int uiLength)
CRxArrayInt (const CRxArrayInt &xArray)
virtual | ~CRxArrayInt ()
TValue & | CRxArrayInt::operator[] (unsigned int uiIdx)
const TValue & | CRxArrayInt::operator[] (unsigned int uiIdx) const
void | Delete ()
TValue * GetDataPtr ()
const TValue * | GetDataPtr () const
bool | IsValid () const
unsigned int | Length () const
bool | New (unsigned int iSize)
CRxArrayInt & | operator= (const CRxArrayInt &xArray)
void | Reset ()
bool | Resize (unsigned int uiSize)

Protected Attributes

void * | m_pvData
unsigned int | m_uiLength

Detailed Description

Basic unsigned int array operations.

Member Typedef Documentation

typedef int Rx::CRxArrayInt::TValue

Constructor & Destructor Documentation

Rx::CRxArrayInt::CRxArrayInt ( )
Rx::CRxArrayInt::CRxArrayInt ( unsigned int uiLength )
Rx::CRxArrayInt::CRxArrayInt ( const CRxArrayInt & xArray )
virtual Rx::CRxArrayInt::~CRxArrayInt ( )
virtual

Member Function Documentation

TValue& Rx::CRxArrayInt::CRxArrayInt::operator[] ( unsigned int uiIdx )
const TValue& Rx::CRxArrayInt::CRxArrayInt::operator[] ( unsigned int uiIdx ) const
void Rx::CRxArrayInt::Delete ( )
TValue* Rx::CRxArrayInt::GetDataPtr ( )
const TValue* Rx::CRxArrayInt::GetDataPtr ( ) const
bool Rx::CRxArrayInt::IsValid ( ) const
unsigned int Rx::CRxArrayInt::Length ( ) const
bool Rx::CRxArrayInt::New ( unsigned int iSize )
CRxArrayInt& Rx::CRxArrayInt::operator= ( const CRxArrayInt & xArray )
void Rx::CRxArrayInt::Reset ( )
bool Rx::CRxArrayInt::Resize ( unsigned int uiSize )

Field Documentation

void* Rx::CRxArrayInt::m_pvData
protected
unsigned int Rx::CRxArrayInt::m_uiLength
protected
The documentation for this class was generated from the following file:
  • RxArrayInt.h


Rx::CRxArrayString Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxArrayString
Public Types | Public Member Functions | Protected Attributes
Rx::CRxArrayString Class Reference
Tool classes.

Basic unsigned int array operations. More...

#include <RxArrayString.h>

Public Types

typedef Rx::CRxString TValue

Public Member Functions

CRxArrayString ()
CRxArrayString (unsigned int uiLength)
CRxArrayString (const CRxArrayString &xArray)
virtual | ~CRxArrayString ()
TValue & | CRxArrayString::operator[] (unsigned int uiIdx)
const TValue & | CRxArrayString::operator[] (unsigned int uiIdx) const
void | Delete ()
bool | IsValid () const
unsigned int | Length () const
bool | New (unsigned int iSize)
CRxArrayString & | operator= (const CRxArrayString &xArray)
void | Reset ()
bool | Resize (unsigned int uiSize)

Protected Attributes

void * | m_pvData
unsigned int | m_uiLength

Detailed Description

Basic unsigned int array operations.

Member Typedef Documentation

typedef Rx::CRxString Rx::CRxArrayString::TValue

Constructor & Destructor Documentation

Rx::CRxArrayString::CRxArrayString ( )
Rx::CRxArrayString::CRxArrayString ( unsigned int uiLength )
Rx::CRxArrayString::CRxArrayString ( const CRxArrayString & xArray )
virtual Rx::CRxArrayString::~CRxArrayString ( )
virtual

Member Function Documentation

TValue& Rx::CRxArrayString::CRxArrayString::operator[] ( unsigned int uiIdx )
const TValue& Rx::CRxArrayString::CRxArrayString::operator[] ( unsigned int uiIdx ) const
void Rx::CRxArrayString::Delete ( )
bool Rx::CRxArrayString::IsValid ( ) const
unsigned int Rx::CRxArrayString::Length ( ) const
bool Rx::CRxArrayString::New ( unsigned int iSize )
CRxArrayString& Rx::CRxArrayString::operator= ( const CRxArrayString & xArray )
void Rx::CRxArrayString::Reset ( )
bool Rx::CRxArrayString::Resize ( unsigned int uiSize )

Field Documentation

void* Rx::CRxArrayString::m_pvData
protected
unsigned int Rx::CRxArrayString::m_uiLength
protected
The documentation for this class was generated from the following file:
  • RxArrayString.h


Rx::CRxArrayUChar Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxArrayUChar
Public Types | Public Member Functions | Protected Attributes
Rx::CRxArrayUChar Class Reference
Tool classes.

Basic unsigned char array operations. More...

#include <RxArrayUChar.h>

Public Types

typedef unsigned char TValue

Public Member Functions

CRxArrayUChar ()
CRxArrayUChar (unsigned int uiLength)
CRxArrayUChar (const CRxArrayUChar &xArray)
virtual | ~CRxArrayUChar ()
TValue & | CRxArrayUChar::operator[] (unsigned int uiIdx)
const TValue & | CRxArrayUChar::operator[] (unsigned int uiIdx) const
void | Delete ()
TValue * GetDataPtr ()
const TValue * | GetDataPtr () const
bool | IsValid () const
unsigned int | Length () const
bool | New (unsigned int uiSize)
CRxArrayUChar & | operator= (const CRxArrayUChar &xArray)
void | Reset ()
bool | Resize (unsigned int uiSize)

Protected Attributes

void * | m_pvData
unsigned int | m_uiLength

Detailed Description

Basic unsigned char array operations.

Member Typedef Documentation

typedef unsigned char Rx::CRxArrayUChar::TValue

Constructor & Destructor Documentation

Rx::CRxArrayUChar::CRxArrayUChar ( )
Rx::CRxArrayUChar::CRxArrayUChar ( unsigned int uiLength )
Rx::CRxArrayUChar::CRxArrayUChar ( const CRxArrayUChar & xArray )
virtual Rx::CRxArrayUChar::~CRxArrayUChar ( )
virtual

Member Function Documentation

TValue& Rx::CRxArrayUChar::CRxArrayUChar::operator[] ( unsigned int uiIdx )
const TValue& Rx::CRxArrayUChar::CRxArrayUChar::operator[] ( unsigned int uiIdx ) const
void Rx::CRxArrayUChar::Delete ( )
TValue* Rx::CRxArrayUChar::GetDataPtr ( )
const TValue* Rx::CRxArrayUChar::GetDataPtr ( ) const
bool Rx::CRxArrayUChar::IsValid ( ) const
unsigned int Rx::CRxArrayUChar::Length ( ) const
bool Rx::CRxArrayUChar::New ( unsigned int uiSize )
CRxArrayUChar& Rx::CRxArrayUChar::operator= ( const CRxArrayUChar & xArray )
void Rx::CRxArrayUChar::Reset ( )
bool Rx::CRxArrayUChar::Resize ( unsigned int uiSize )

Field Documentation

void* Rx::CRxArrayUChar::m_pvData
protected
unsigned int Rx::CRxArrayUChar::m_uiLength
protected
The documentation for this class was generated from the following file:
  • RxArrayUChar.h


Rx::CRxArrayUInt Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxArrayUInt
Public Types | Public Member Functions | Protected Attributes
Rx::CRxArrayUInt Class Reference
Tool classes.

Basic unsigned int array operations. More...

#include <RxArrayUInt.h>

Public Types

typedef unsigned int TValue

Public Member Functions

CRxArrayUInt ()
CRxArrayUInt (unsigned int uiLength)
CRxArrayUInt (const CRxArrayUInt &xArray)
virtual | ~CRxArrayUInt ()
TValue & | CRxArrayUInt::operator[] (unsigned int uiIdx)
const TValue & | CRxArrayUInt::operator[] (unsigned int uiIdx) const
void | Delete ()
TValue * GetDataPtr ()
const TValue * | GetDataPtr () const
bool | IsValid () const
unsigned int | Length () const
bool | New (unsigned int iSize)
CRxArrayUInt & | operator= (const CRxArrayUInt &xArray)
void | Reset ()
bool | Resize (unsigned int uiSize)

Protected Attributes

void * | m_pvData
unsigned int | m_uiLength

Detailed Description

Basic unsigned int array operations.

Member Typedef Documentation

typedef unsigned int Rx::CRxArrayUInt::TValue

Constructor & Destructor Documentation

Rx::CRxArrayUInt::CRxArrayUInt ( )
Rx::CRxArrayUInt::CRxArrayUInt ( unsigned int uiLength )
Rx::CRxArrayUInt::CRxArrayUInt ( const CRxArrayUInt & xArray )
virtual Rx::CRxArrayUInt::~CRxArrayUInt ( )
virtual

Member Function Documentation

TValue& Rx::CRxArrayUInt::CRxArrayUInt::operator[] ( unsigned int uiIdx )
const TValue& Rx::CRxArrayUInt::CRxArrayUInt::operator[] ( unsigned int uiIdx ) const
void Rx::CRxArrayUInt::Delete ( )
TValue* Rx::CRxArrayUInt::GetDataPtr ( )
const TValue* Rx::CRxArrayUInt::GetDataPtr ( ) const
bool Rx::CRxArrayUInt::IsValid ( ) const
unsigned int Rx::CRxArrayUInt::Length ( ) const
bool Rx::CRxArrayUInt::New ( unsigned int iSize )
CRxArrayUInt& Rx::CRxArrayUInt::operator= ( const CRxArrayUInt & xArray )
void Rx::CRxArrayUInt::Reset ( )
bool Rx::CRxArrayUInt::Resize ( unsigned int uiSize )

Field Documentation

void* Rx::CRxArrayUInt::m_pvData
protected
unsigned int Rx::CRxArrayUInt::m_uiLength
protected
The documentation for this class was generated from the following file:
  • RxArrayUInt.h


Rx::CRxMetaData Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxMetaData
Public Member Functions
Rx::CRxMetaData Class Reference
Tool classes.

Handles a collection of meta data of different types. More...

#include <RxMetaData.h>

Public Member Functions

CRxMetaData (void)
CRxMetaData (const CRxMetaData &xData)
~CRxMetaData (void)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, unsigned uData)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, double dData)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, const Rx::CRxString &sxData)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, const Rx::CRxArrayUInt &xData)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, const Rx::CRxArrayDouble &xData)
bool | AddElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxGroup, const Rx::CRxArrayString &xData)
void | Clear ()
bool | GetElement (const Rx::CRxString &sxLabel, unsigned &uData)
bool | GetElement (const Rx::CRxString &sxLabel, double &dData)
bool | GetElement (const Rx::CRxString &sxLabel, Rx::CRxString &sxData)
bool | GetElement (const Rx::CRxString &sxLabel, Rx::CRxArrayUInt &xData)
bool | GetElement (const Rx::CRxString &sxLabel, Rx::CRxArrayDouble &xData)
bool | GetElement (const Rx::CRxString &sxLabel, Rx::CRxArrayString &xData)
unsigned | GetElementCount ()
bool | GetElementNameType (unsigned iIdx, Rx::CRxString &sxName, Rx::CRxString &sxType)
Rx::CRxString GetLastError ()
bool | HasElement (const Rx::CRxString &sxLabel)
CRxMetaData & | operator= (const CRxMetaData &xData)
bool | SetElement (const Rx::CRxString &sxLabel, unsigned uData)
bool | SetElement (const Rx::CRxString &sxLabel, double dData)
bool | SetElement (const Rx::CRxString &sxLabel, const Rx::CRxString &sxData)
bool | SetElement (const Rx::CRxString &sxLabel, const Rx::CRxArrayUInt &xData)
bool | SetElement (const Rx::CRxString &sxLabel, const Rx::CRxArrayDouble &xData)
bool | SetElement (const Rx::CRxString &sxLabel, const Rx::CRxArrayString &xData)

Detailed Description

Handles a collection of meta data of different types.

Constructor & Destructor Documentation

Rx::CRxMetaData::CRxMetaData ( void )
Rx::CRxMetaData::CRxMetaData ( const CRxMetaData & xData )
Rx::CRxMetaData::~CRxMetaData ( void )

Member Function Documentation

bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | unsigned | uData
 | ) |  |
bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | double | dData
 | ) |  |
bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | const Rx::CRxString & | sxData
 | ) |  |
bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | const Rx::CRxArrayUInt & | xData
 | ) |  |
bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | const Rx::CRxArrayDouble & | xData
 | ) |  |
bool Rx::CRxMetaData::AddElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxGroup,
 |  | const Rx::CRxArrayString & | xData
 | ) |  |
void Rx::CRxMetaData::Clear ( )
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | unsigned & | uData
 | ) |  |
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | double & | dData
 | ) |  |
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | Rx::CRxString & | sxData
 | ) |  |
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | Rx::CRxArrayUInt & | xData
 | ) |  |
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | Rx::CRxArrayDouble & | xData
 | ) |  |
bool Rx::CRxMetaData::GetElement | ( | const Rx::CRxString & | sxLabel,
 |  | Rx::CRxArrayString & | xData
 | ) |  |
unsigned Rx::CRxMetaData::GetElementCount ( )
bool Rx::CRxMetaData::GetElementNameType | ( | unsigned | iIdx,
 |  | Rx::CRxString & | sxName,
 |  | Rx::CRxString & | sxType
 | ) |  |
Rx::CRxString Rx::CRxMetaData::GetLastError ( )
bool Rx::CRxMetaData::HasElement ( const Rx::CRxString & sxLabel )
CRxMetaData& Rx::CRxMetaData::operator= ( const CRxMetaData & xData )
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | unsigned | uData
 | ) |  |
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | double | dData
 | ) |  |
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxString & | sxData
 | ) |  |
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxArrayUInt & | xData
 | ) |  |
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxArrayDouble & | xData
 | ) |  |
bool Rx::CRxMetaData::SetElement | ( | const Rx::CRxString & | sxLabel,
 |  | const Rx::CRxArrayString & | xData
 | ) |  |
The documentation for this class was generated from the following file:
  • RxMetaData.h


Rx::CRxString Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • CRxString
Public Member Functions
Rx::CRxString Class Reference
Tool classes.

Basic character string operations. More...

#include <RxString.h>

Public Member Functions

CRxString (void)
CRxString (const char cChar)
CRxString (const char *pcString)
CRxString (const CRxString &sxString)
CRxString (const std::string &sString)
virtual | ~CRxString (void)
bool | Contains (const char *sString) const
Query if this CRxString contains the given sString. More...
int | Find (const char *pcString, int iStartIdx=0) const
Searches this string for the content specified in either pcString or sString, and returns the position of the first occurrence in this string. More...
int | Find (const std::string &sString, int iStartIdx=0) const
int | Find (const CRxString &sString, int iStartIdx=0) const
int | FindFirstNotOf (const char *pcWhat, int iStartIdx=0, int iCount=-1) const
int | FindFirstOf (const char *pcWhat, int iStartIdx=0, int iCount=-1) const
Searches this string for any of the characters that are part of pcWhat and returns the position of the first occurrence in the string. More...
int | FindLastNotOf (const char *pcWhat, int iStartIdx=0, int iCount=-1) const
int | FindLastOf (const char *pcWhat, int iStartIdx=0, int iCount=-1) const
operator const char * () const
bool | operator!= (const char *pcString) const
CRxString & | operator+= (const char *pcString)
CRxString & | operator+= (const CRxString &sxString)
CRxString & | operator<< (const char *pcString)
CRxString & | operator<< (const CRxString &sxString)
CRxString & | operator= (const char cChar)
CRxString & | operator= (const char *pcString)
CRxString & | operator= (const CRxString &sxString)
CRxString & | operator= (const std::string &sString)
bool | operator== (const char *pcString) const
CRxString | Replace (const char *sOld, const char *sNew) const
Replaces all occurrences of sOld by sNew and returns the resulting CRxString. More...
unsigned | Size () const
void | SplitFilename (CRxString &sxDir, CRxString &sxName, CRxString &sxExt) const
CRxString | SubStr (int iStartIdx, int iCount=-1) const
const char * | ToCString () const
std::string | ToStdString () const

Detailed Description

Basic character string operations.

Perwass, 08.08.2012.

Constructor & Destructor Documentation

Rx::CRxString::CRxString ( void )
Rx::CRxString::CRxString ( const char cChar )
Rx::CRxString::CRxString ( const char * pcString )
Rx::CRxString::CRxString ( const CRxString & sxString )
Rx::CRxString::CRxString ( const std::string & sString )
virtual Rx::CRxString::~CRxString ( void )
virtual

Member Function Documentation

bool Rx::CRxString::Contains ( const char * sString ) const

Query if this CRxString contains the given sString.

Koeper, 19.08.2012.

Parameters
sString The CRxString to test for containment.
Returns
true if this string contains the given sString, false if not.
int Rx::CRxString::Find | ( | const char * | pcString,
 |  | int | iStartIdx = 0
 | ) |  | const

Searches this string for the content specified in either pcString or sString, and returns the position of the first occurrence in this string.

When iStartIdx is specified the search only includes characters on or after position iStartIdx, ignoring any possible occurrences in previous locations.

Parameters
pcString | String to be searched for in this string. The entire content of str must be matched in some part of the string to be considered a match.
iStartIdx | (optional) Position of the first character in the string to be taken into consideration for possible matches. A value of 0 means that the entire string is considered.
Returns
The position of the first occurrence in the string of the searched content. If the content is not found, the member value -1 is returned.
int Rx::CRxString::Find | ( | const std::string & | sString,
 |  | int | iStartIdx = 0
 | ) |  | const
int Rx::CRxString::Find | ( | const CRxString & | sString,
 |  | int | iStartIdx = 0
 | ) |  | const
int Rx::CRxString::FindFirstNotOf | ( | const char * | pcWhat,
 |  | int | iStartIdx = 0,
 |  | int | iCount = -1
 | ) |  | const
int Rx::CRxString::FindFirstOf | ( | const char * | pcWhat,
 |  | int | iStartIdx = 0,
 |  | int | iCount = -1
 | ) |  | const

Searches this string for any of the characters that are part of pcWhat and returns the position of the first occurrence in the string.

When iStartIdx is specified the search only includes characters on or after position iStartIdx, ignoring any possible occurrences at previous character positions.

Notice that for a match to happen it is enough that one of the characters matches in the string (any of them). To search for an entire sequence of characters use Find instead.

Parameters
pcWhat | String containing the characters to search for in this string. The first character in the string that compares equal to any of the characters in pcWhat is considered a match.
iStartIdx | (optional) Position of the first character in the string to be taken into consideration for possible matches. A value of 0 means that the entire string is considered.
iCount | (optional) Length of sequence of characters to search for.
Returns
The position of the first occurrence in the string of any of the characters searched for. If the content is not found, the member value -1 is returned.
int Rx::CRxString::FindLastNotOf | ( | const char * | pcWhat,
 |  | int | iStartIdx = 0,
 |  | int | iCount = -1
 | ) |  | const
int Rx::CRxString::FindLastOf | ( | const char * | pcWhat,
 |  | int | iStartIdx = 0,
 |  | int | iCount = -1
 | ) |  | const
Rx::CRxString::operator const char * ( ) const
bool Rx::CRxString::operator!= ( const char * pcString ) const
CRxString& Rx::CRxString::operator+= ( const char * pcString )
CRxString& Rx::CRxString::operator+= ( const CRxString & sxString )
CRxString& Rx::CRxString::operator<< ( const char * pcString )
CRxString& Rx::CRxString::operator<< ( const CRxString & sxString )
CRxString& Rx::CRxString::operator= ( const char cChar )
CRxString& Rx::CRxString::operator= ( const char * pcString )
CRxString& Rx::CRxString::operator= ( const CRxString & sxString )
CRxString& Rx::CRxString::operator= ( const std::string & sString )
bool Rx::CRxString::operator== ( const char * pcString ) const
CRxString Rx::CRxString::Replace | ( | const char * | sOld,
 |  | const char * | sNew
 | ) |  | const

Replaces all occurrences of sOld by sNew and returns the resulting CRxString.

Koeper, 20.08.2012.

Parameters
sOld | String which should be replaced.
sNew | This string is used as the replacement.
Returns
The replaced CRxString.
unsigned Rx::CRxString::Size ( ) const
void Rx::CRxString::SplitFilename | ( | CRxString & | sxDir,
 |  | CRxString & | sxName,
 |  | CRxString & | sxExt
 | ) |  | const
CRxString Rx::CRxString::SubStr | ( | int | iStartIdx,
 |  | int | iCount = -1
 | ) |  | const
const char* Rx::CRxString::ToCString ( ) const
std::string Rx::CRxString::ToStdString ( ) const
The documentation for this class was generated from the following file:
  • RxString.h


Rx Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Data Structures | Typedefs | Functions
Rx Namespace Reference
The Raytrix Core Classes API

Namespaces

namespace | ApiLF
namespace | Interop

Data Structures

class | CRxArrayDouble
Basic unsigned int array operations. More...
class | CRxArrayInt
Basic unsigned int array operations. More...
class | CRxArrayString
Basic unsigned int array operations. More...
class | CRxArrayUChar
Basic unsigned char array operations. More...
class | CRxArrayUInt
Basic unsigned int array operations. More...
class | CRxImage
Image class. Implements the interface IImage. More...
class | CRxImageFormat
Image format descriptor. More...
class | CRxImageMoniker
Image moniker class. Implements the interface IImage but does not allocate memory. More...
class | CRxMetaData
Handles a collection of meta data of different types. More...
class | CRxString
Basic character string operations. More...
struct | TPixel
General pixel template structure. More...

Typedefs

typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_BYTE > 		TPixel_Bay_BG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_DOUBLE > 		TPixel_Bay_BG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_FLOAT > 		TPixel_Bay_BG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_INT > 		TPixel_Bay_BG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_SHORT > 		TPixel_Bay_BG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_BYTE > 		TPixel_Bay_BG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_INT > 		TPixel_Bay_BG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_SHORT > 		TPixel_Bay_BG_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_BYTE > 		TPixel_Bay_GB_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_DOUBLE > 		TPixel_Bay_GB_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_FLOAT > 		TPixel_Bay_GB_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_INT > 		TPixel_Bay_GB_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_SHORT > 		TPixel_Bay_GB_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_BYTE > 		TPixel_Bay_GB_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_INT > 		TPixel_Bay_GB_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_SHORT > 		TPixel_Bay_GB_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_BYTE > 		TPixel_Bay_GR_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_DOUBLE > 		TPixel_Bay_GR_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_FLOAT > 		TPixel_Bay_GR_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_INT > 		TPixel_Bay_GR_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_SHORT > 		TPixel_Bay_GR_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_BYTE > 		TPixel_Bay_GR_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_INT > 		TPixel_Bay_GR_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_SHORT > 		TPixel_Bay_GR_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_BYTE > 		TPixel_Bay_RG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_DOUBLE > 		TPixel_Bay_RG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_FLOAT > 		TPixel_Bay_RG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_INT > 		TPixel_Bay_RG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_SHORT > 		TPixel_Bay_RG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_BYTE > 		TPixel_Bay_RG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_INT > 		TPixel_Bay_RG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_SHORT > 		TPixel_Bay_RG_us
typedef TPixel< char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_BYTE > 		TPixel_BGR_c
typedef TPixel< double,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_DOUBLE > 		TPixel_BGR_d
typedef TPixel< float,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_FLOAT > 		TPixel_BGR_f
typedef TPixel< __int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_INT > 		TPixel_BGR_i
typedef TPixel< __int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_SHORT > 		TPixel_BGR_s
typedef TPixel< unsigned char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_BYTE > 		TPixel_BGR_uc
typedef TPixel< unsigned
__int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_INT > 		TPixel_BGR_ui
typedef TPixel< unsigned
__int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_SHORT > 		TPixel_BGR_us
typedef TPixel< char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_BYTE > 		TPixel_BGRA_c
typedef TPixel< double,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_DOUBLE > 		TPixel_BGRA_d
typedef TPixel< float,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_FLOAT > 		TPixel_BGRA_f
typedef TPixel< __int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_INT > 		TPixel_BGRA_i
typedef TPixel< __int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_SHORT > 		TPixel_BGRA_s
typedef TPixel< unsigned char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_BYTE > 		TPixel_BGRA_uc
typedef TPixel< unsigned
__int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_INT > 		TPixel_BGRA_ui
typedef TPixel< unsigned
__int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_SHORT > 		TPixel_BGRA_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_BYTE > 		TPixel_L_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_DOUBLE > 		TPixel_L_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_FLOAT > 		TPixel_L_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_INT > 		TPixel_L_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_SHORT > 		TPixel_L_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_BYTE > 		TPixel_L_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_INT > 		TPixel_L_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_SHORT > 		TPixel_L_us
typedef TPixel< char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_BYTE > 		TPixel_LA_c
typedef TPixel< double,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_DOUBLE > 		TPixel_LA_d
typedef TPixel< float,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_FLOAT > 		TPixel_LA_f
typedef TPixel< __int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_INT > 		TPixel_LA_i
typedef TPixel< __int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_SHORT > 		TPixel_LA_s
typedef TPixel< unsigned char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_BYTE > 		TPixel_LA_uc
typedef TPixel< unsigned
__int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_INT > 		TPixel_LA_ui
typedef TPixel< unsigned
__int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_SHORT > 		TPixel_LA_us
typedef TPixel< char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_BYTE > 		TPixel_RGB_c
typedef TPixel< double,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_DOUBLE > 		TPixel_RGB_d
typedef TPixel< float,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_FLOAT > 		TPixel_RGB_f
typedef TPixel< __int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_INT > 		TPixel_RGB_i
typedef TPixel< __int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_SHORT > 		TPixel_RGB_s
typedef TPixel< unsigned char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_BYTE > 		TPixel_RGB_uc
typedef TPixel< unsigned
__int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_INT > 		TPixel_RGB_ui
typedef TPixel< unsigned
__int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_SHORT > 		TPixel_RGB_us
typedef TPixel< char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_BYTE > 		TPixel_RGBA_c
typedef TPixel< double,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_DOUBLE > 		TPixel_RGBA_d
typedef TPixel< float,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_FLOAT > 		TPixel_RGBA_f
typedef TPixel< __int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_INT > 		TPixel_RGBA_i
typedef TPixel< __int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_SHORT > 		TPixel_RGBA_s
typedef TPixel< unsigned char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_BYTE > 		TPixel_RGBA_uc
typedef TPixel< unsigned
__int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_INT > 		TPixel_RGBA_ui
typedef TPixel< unsigned
__int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_SHORT > 		TPixel_RGBA_us

Functions

void | Float2Pixel (char &rPx, float fVal)
void | Float2Pixel (unsigned char &rPx, float fVal)
void | Float2Pixel (short &rPx, float fVal)
void | Float2Pixel (unsigned short &rPx, float fVal)
void | Float2Pixel (int &rPx, float fVal)
void | Float2Pixel (unsigned int &rPx, float fVal)
void | Float2Pixel (float &rPx, float fVal)
void | Float2Pixel (double &rPx, float fVal)
void | Float2Pixel (char &rPx, double fVal)
void | Float2Pixel (unsigned char &rPx, double fVal)
void | Float2Pixel (short &rPx, double fVal)
void | Float2Pixel (unsigned short &rPx, double fVal)
void | Float2Pixel (int &rPx, double fVal)
void | Float2Pixel (unsigned int &rPx, double fVal)
void | Float2Pixel (float &rPx, double fVal)
void | Float2Pixel (double &rPx, double fVal)
double | GetTime ()
__int64 | GetTime64 ()
void | InitTime ()
CRxString | operator+ (const CRxString &sxA, const CRxString &sxB)
CRxString | operator+ (const CRxString &sxA, const char *pcB)
CRxString | operator+ (const char *pcA, const CRxString &sxB)
CRxString | operator+ (const CRxString &sxA, int iVal)
CRxString | operator+ (const CRxString &sxA, unsigned int uVal)
CRxString | operator+ (const CRxString &sxA, float fVal)
CRxString | operator+ (const CRxString &sxA, double dVal)
void | Pixel2Float (float &fVal, char rPx)
void | Pixel2Float (float &fVal, unsigned char rPx)
void | Pixel2Float (float &fVal, short rPx)
void | Pixel2Float (float &fVal, unsigned short rPx)
void | Pixel2Float (float &fVal, int rPx)
void | Pixel2Float (float &fVal, unsigned int rPx)
void | Pixel2Float (float &fVal, float rPx)
void | Pixel2Float (float &fVal, double rPx)
void | Pixel2Float (double &fVal, char rPx)
void | Pixel2Float (double &fVal, unsigned char rPx)
void | Pixel2Float (double &fVal, short rPx)
void | Pixel2Float (double &fVal, unsigned short rPx)
void | Pixel2Float (double &fVal, int rPx)
void | Pixel2Float (double &fVal, unsigned int rPx)
void | Pixel2Float (double &fVal, float rPx)
void | Pixel2Float (double &fVal, double rPx)
void | Sleep (unsigned uTime)

Detailed Description

Interface definition for Images


Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
[detail level 1234]
o N CLUViz |
| o N MT |
| o N ST |
| \ N Tool |
o N CLUVizST |
o N ECalibGridMode | Grid calibration modes for parameter CalibGrid_Mode
o N ECameraTriggerMode |
o N EDepthImageType | Depth image output type. Use these value for the parameter Depth_ImageType
o N EError | Error IDs of Raytrix API
o N EFeature | Values that represent EError.
o N EImgID | Internal image IDs
o N EPar | This enum contains the parameters IDs for various library and camera parameters
o N EParGrp | Parameter group IDs
o N ERadDistType | Radial distortion types of raw images
o N ERaySeqMode | Ray sequence file modes
o N EStatusMessage | Values that represent EStatusCode.
o N EStatusMsgGrp | Values that represent EStatusCode.
o N EStatusSource | Values that represent EStatusCodeGroup.
o N EWarning | Values that represent EWarning.
\ N Rx |
o N ApiLF |
| o N ECalibGridMode | Grid calibration modes for parameter CalibGrid_Mode
| o N ECameraTriggerMode |
| o N EDepthImageType | Depth image output type. Use these value for the parameter Depth_ImageType
| o N EError | Error IDs of Raytrix API
| o N EFeature | Values that represent EError.
| o N EImgID | Internal image IDs
| o N EPar | This enum contains the parameters IDs for various library and camera parameters
| o N EParGrp | Parameter group IDs
| o N ERadDistType | Radial distortion types of raw images
| o N ERaySeqMode | Ray sequence file modes
| o N EStatusMessage | Values that represent EStatusCode.
| o N EStatusMsgGrp | Values that represent EStatusCode.
| o N EStatusSource | Values that represent EStatusCodeGroup.
| o N EWarning | Values that represent EWarning.
| \ N NET |
\ N Interop |
\ N Runtime28 |
o N EDataType | The image data types
\ N EPixelType | The image pixel types


CLUViz Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Functions
CLUViz Namespace Reference

Namespaces

namespace | MT
namespace | ST
namespace | Tool

Functions

CLUVIZDLL_API bool | CheckFeature (__int32 iFeature)
CLUVIZDLL_API bool | CreateEx (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)

Function Documentation

CLUVIZDLL_API bool CLUViz::CheckFeature ( __int32 iFeature )
CLUVIZDLL_API bool CLUViz::CreateEx | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle,
 |  | const char * | pcInitScript,
 |  | const char * | pcCLUPath,
 |  | bool | bVizOnly,
 |  | bool | bShowIntro,
 |  | void * | pvIcon,
 |  | void * | pvParentHandle,
 |  | unsigned int | uWindowStyle
 | ) |  |


CLUViz::MT Namespace Reference

  • Namespace List
  • Namespace Members
  • CLUViz
  • MT
Functions
CLUViz::MT Namespace Reference

Functions

bool | _Start (const char *pcEnvPath, const char *pcLicenceKey, bool bInitAll)
CLUVIZDLL_API bool | Create (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle)
CLUVIZDLL_API bool | CreateEx1 (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | CreateEx2 (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | Destroy (int iHandle)
CLUVIZDLL_API bool | DestroyAll ()
CLUVIZDLL_API bool | EnableUserEnd (bool bVal)
CLUVIZDLL_API bool | End ()
CLUVIZDLL_API bool | ExecUser (int iHandle, const char *pcToolName=0)
CLUVIZDLL_API bool | FullScreen (int iHandle, bool bVal=true)
CLUVIZDLL_API bool | FullScreen (int iHandle, bool bVal, bool bEnableUserToggle)
CLUVIZDLL_API bool | GetFileTypeScript (const char *pcFileType, int iMaxLen, char *pcData)
CLUVIZDLL_API void * | GetIconHandle (const char *pcFilename, bool bModule=false)
CLUVIZDLL_API bool | GetKey (unsigned __int32 *pKey)
CLUVIZDLL_API bool | GetLastError (char *pcError, int iMaxLen)
CLUVIZDLL_API void | GetStdEnvPath (char *pcPath, int iMaxLen)
CLUVIZDLL_API bool | GetVarColor (int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha)
CLUVIZDLL_API bool | GetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | GetVarImageData (int iHandle, const char *pcVarName, void *pvData)
CLUVIZDLL_API bool | GetVarImageProp (int iHandle, const char *pcVarName, int &iWidth, int &iHeight, int &iImgType, int &iDataType, int &iBytesPerPixel)
CLUVIZDLL_API bool | GetVarNumber (int iHandle, const char *pcVarName, int &iVal)
CLUVIZDLL_API bool | GetVarNumber (int iHandle, const char *pcVarName, double &dVal)
CLUVIZDLL_API bool | GetVarString (int iHandle, const char *pcVarName, char *pcString, int iMaxLen)
CLUVIZDLL_API bool | GetVarTensor (int iHandle, const char *pcVarName, vector< int > &vecDim, vector< double > &vecData)
CLUVIZDLL_API bool | GetVarTensorData (int iHandle, const char *pcVarName, unsigned *puDim, double *pdData)
CLUVIZDLL_API bool | GetVarTensorProp (int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt)
CLUVIZDLL_API bool | GetVersion (char *pcVersion, int iBufLen)
CLUVIZDLL_API bool | HideWindow (int iHandle)
CLUVIZDLL_API bool | InfoBox (const char *pcText)
CLUVIZDLL_API bool | IsRunning (int iWait)
CLUVIZDLL_API bool | IsViewValid (int iHandle)
CLUVIZDLL_API bool | LoadScript (int iHandle, const char *pcFilename)
CLUVIZDLL_API bool | LoadScript (int iHandle, const char *pcFilename, const char *pcPass)
CLUVIZDLL_API bool | LoadScript (int iHandle, const char *pcFilename, const char *pcPass, int iArgCnt, const char *pcArg)
CLUVIZDLL_API bool | SetScript (int iHandle, const char *pcScript)
CLUVIZDLL_API bool | SetScriptPath (const char *pcPath)
CLUVIZDLL_API bool | SetTimeout (unsigned int uMilliSeconds)
CLUVIZDLL_API bool | SetVarColor (int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha)
CLUVIZDLL_API bool | SetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | SetVarImage (int iHandle, const char *pcVarName, int iWidth, int iHeight, int iImgType, int iDataType, const void *pvData)
CLUVIZDLL_API bool | SetVarNumber (int iHandle, const char *pcVarName, int iVal)
CLUVIZDLL_API bool | SetVarNumber (int iHandle, const char *pcVarName, double dVal)
CLUVIZDLL_API bool | SetVarString (int iHandle, const char *pcVarName, const char *pcString)
CLUVIZDLL_API bool | SetVarTensor (int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData)
CLUVIZDLL_API bool | SetWindowPosSize (int iHandle, int iX, int iY, int iWidth, int iHeight)
CLUVIZDLL_API bool | ShowWindow (int iHandle)
CLUVIZDLL_API bool | Start (const char *pcEnvPath=0, const char *pcLicenceKey=0)
CLUVIZDLL_API bool | StartAgain (const char *pcEnvPath=0, const char *pcLicenceKey=0)
CLUVIZDLL_API bool | WaitForEnd ()

Function Documentation

bool CLUViz::MT::_Start | ( | const char * | pcEnvPath,
 |  | const char * | pcLicenceKey,
 |  | bool | bInitAll
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::Create | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::CreateEx1 | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle,
 |  | unsigned int | uWindowStyle
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::CreateEx2 | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle,
 |  | const char * | pcInitScript,
 |  | const char * | pcCLUPath,
 |  | bool | bVizOnly,
 |  | bool | bShowIntro,
 |  | void * | pvIcon,
 |  | void * | pvParentHandle,
 |  | unsigned int | uWindowStyle
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::Destroy ( int iHandle )
CLUVIZDLL_API bool CLUViz::MT::DestroyAll ( )
CLUVIZDLL_API bool CLUViz::MT::EnableUserEnd ( bool bVal )
CLUVIZDLL_API bool CLUViz::MT::End ( )
CLUVIZDLL_API bool CLUViz::MT::ExecUser | ( | int | iHandle,
 |  | const char * | pcToolName = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::FullScreen | ( | int | iHandle,
 |  | bool | bVal = true
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::FullScreen | ( | int | iHandle,
 |  | bool | bVal,
 |  | bool | bEnableUserToggle
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetFileTypeScript | ( | const char * | pcFileType,
 |  | int | iMaxLen,
 |  | char * | pcData
 | ) |  |
CLUVIZDLL_API void* CLUViz::MT::GetIconHandle | ( | const char * | pcFilename,
 |  | bool | bModule = false
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetKey ( unsigned __int32 * pKey )
CLUVIZDLL_API bool CLUViz::MT::GetLastError | ( | char * | pcError,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API void CLUViz::MT::GetStdEnvPath | ( | char * | pcPath,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double & | dRed,
 |  | double & | dGreen,
 |  | double & | dBlue,
 |  | double & | dAlpha
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double * | pdColor4
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarImageData | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | void * | pvData
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarImageProp | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int & | iWidth,
 |  | int & | iHeight,
 |  | int & | iImgType,
 |  | int & | iDataType,
 |  | int & | iBytesPerPixel
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int & | iVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double & | dVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarString | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | char * | pcString,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarTensor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | vector< int > & | vecDim,
 |  | vector< double > & | vecData
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarTensorData | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | unsigned * | puDim,
 |  | double * | pdData
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVarTensorProp | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | unsigned & | uDimCnt,
 |  | unsigned & | uElCnt
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::GetVersion | ( | char * | pcVersion,
 |  | int | iBufLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::HideWindow ( int iHandle )
CLUVIZDLL_API bool CLUViz::MT::InfoBox ( const char * pcText )
CLUVIZDLL_API bool CLUViz::MT::IsRunning ( int iWait )
CLUVIZDLL_API bool CLUViz::MT::IsViewValid ( int iHandle )
CLUVIZDLL_API bool CLUViz::MT::LoadScript | ( | int | iHandle,
 |  | const char * | pcFilename
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::LoadScript | ( | int | iHandle,
 |  | const char * | pcFilename,
 |  | const char * | pcPass
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::LoadScript | ( | int | iHandle,
 |  | const char * | pcFilename,
 |  | const char * | pcPass,
 |  | int | iArgCnt,
 |  | const char * | pcArg
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetScript | ( | int | iHandle,
 |  | const char * | pcScript
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetScriptPath ( const char * pcPath )
CLUVIZDLL_API bool CLUViz::MT::SetTimeout ( unsigned int uMilliSeconds )
CLUVIZDLL_API bool CLUViz::MT::SetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double | dRed,
 |  | double | dGreen,
 |  | double | dBlue,
 |  | double | dAlpha
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double * | pdColor4
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarImage | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | int | iImgType,
 |  | int | iDataType,
 |  | const void * | pvData
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double | dVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarString | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | const char * | pcString
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetVarTensor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iDimCnt,
 |  | const int * | piDim,
 |  | const double * | pdData
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::SetWindowPosSize | ( | int | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::ShowWindow ( int iHandle )
CLUVIZDLL_API bool CLUViz::MT::Start | ( | const char * | pcEnvPath = 0,
 |  | const char * | pcLicenceKey = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::StartAgain | ( | const char * | pcEnvPath = 0,
 |  | const char * | pcLicenceKey = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::MT::WaitForEnd ( )


CLUViz::ST Namespace Reference

  • Namespace List
  • Namespace Members
  • CLUViz
  • ST
Functions
CLUViz::ST Namespace Reference

Functions

CLUVIZDLL_API bool | EmbedWindow (int &iHandle, __int64 hWnd, bool bCreateSRC=false, __int64 *phGlRc=0)
CLUVIZDLL_API bool | EnableVisualization (int iHandle, bool bVal)
CLUVIZDLL_API bool | End ()
CLUVIZDLL_API bool | EW_ActiveMouseMove (int iHandle, int iX, int iY)
CLUVIZDLL_API bool | EW_Display (int iHandle, bool bWait=false)
CLUVIZDLL_API bool | EW_ExecUser (int iHandle, const char *pcToolName=0)
CLUVIZDLL_API bool | EW_IdleFunc (int iHandle)
CLUVIZDLL_API bool | EW_Keyboard (int iHandle, int iKey, bool bKeyDown)
CLUVIZDLL_API bool | EW_LoadScript (int iHandle, const char *pcFilename, const char *pcPass=0)
CLUVIZDLL_API bool | EW_LockVis (int iHandle, bool bLock)
CLUVIZDLL_API bool | EW_MakeCurrentSRC (int iHandle)
CLUVIZDLL_API bool | EW_Mouse (int iHandle, int iButton, int iState, int iX, int iY)
CLUVIZDLL_API bool | EW_PassiveMouseMove (int iHandle, int iX, int iY)
CLUVIZDLL_API bool | EW_Reshape (int iHandle, int iWidth, int iHeight)
CLUVIZDLL_API bool | EW_SetKeyModifierStates (int iHandle, bool bShift, bool bCtrl, bool bAlt, bool bNumLock, bool bCapsLock, bool bScrollLock)
CLUVIZDLL_API bool | EW_SetScript (int iHandle, const char *pcScript, bool bResetEnv=false, bool bReparseLatex=false)
CLUVIZDLL_API bool | GetKey (unsigned __int32 *pKey)
CLUVIZDLL_API bool | GetLastError (char *pcError, int iMaxLen)
CLUVIZDLL_API bool | GetScriptOutput (int iHandle, char *pcText, int iMaxLen, bool &bIsError)
CLUVIZDLL_API void | GetStdEnvPath (char *pcPath, int iMaxLen)
CLUVIZDLL_API bool | GetVarColor (int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha)
CLUVIZDLL_API bool | GetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | GetVarImageData (int iHandle, const char *pcVarName, void *pvData)
CLUVIZDLL_API bool | GetVarImageProp (int iHandle, const char *pcVarName, int &iWidth, int &iHeight, int &iImgType, int &iDataType, int &iBytesPerPixel)
CLUVIZDLL_API bool | GetVarNumber (int iHandle, const char *pcVarName, int &iVal)
CLUVIZDLL_API bool | GetVarNumber (int iHandle, const char *pcVarName, double &dVal)
CLUVIZDLL_API bool | GetVarString (int iHandle, const char *pcVarName, char *pcString, int iMaxLen)
CLUVIZDLL_API bool | GetVarTensorData (int iHandle, const char *pcVarName, unsigned *puDim, double *pdData)
CLUVIZDLL_API bool | GetVarTensorProp (int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt)
CLUVIZDLL_API bool | GetVersion (char *pcVersion, int iBufLen)
CLUVIZDLL_API bool | ReleaseAll ()
CLUVIZDLL_API bool | ReleaseWindow (int iHandle)
CLUVIZDLL_API bool | SaveView (int iHandle, const char *pcFilename)
CLUVIZDLL_API bool | SetScriptPath (const char *pcPath)
CLUVIZDLL_API bool | SetVarColor (int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha)
CLUVIZDLL_API bool | SetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | SetVarImage (int iHandle, const char *pcVarName, int iWidth, int iHeight, int iImgType, int iDataType, const void *pvData)
CLUVIZDLL_API bool | SetVarNumber (int iHandle, const char *pcVarName, int iVal)
CLUVIZDLL_API bool | SetVarNumber (int iHandle, const char *pcVarName, double dVal)
CLUVIZDLL_API bool | SetVarObject (int iHandle, const char *pcVarName, const CLUViz::SObject *pData)
CLUVIZDLL_API bool | SetVarString (int iHandle, const char *pcVarName, const char *pcString)
CLUVIZDLL_API bool | SetVarTensor (int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData)
CLUVIZDLL_API bool | Start (const char *pcEnvPath=0, const char *pcLicenceKey=0, bool bAlone=true)

Function Documentation

CLUVIZDLL_API bool CLUViz::ST::EmbedWindow | ( | int & | iHandle,
 |  | __int64 | hWnd,
 |  | bool | bCreateSRC = false,
 |  | __int64 * | phGlRc = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EnableVisualization | ( | int | iHandle,
 |  | bool | bVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::End ( )
CLUVIZDLL_API bool CLUViz::ST::EW_ActiveMouseMove | ( | int | iHandle,
 |  | int | iX,
 |  | int | iY
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_Display | ( | int | iHandle,
 |  | bool | bWait = false
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_ExecUser | ( | int | iHandle,
 |  | const char * | pcToolName = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_IdleFunc ( int iHandle )
CLUVIZDLL_API bool CLUViz::ST::EW_Keyboard | ( | int | iHandle,
 |  | int | iKey,
 |  | bool | bKeyDown
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_LoadScript | ( | int | iHandle,
 |  | const char * | pcFilename,
 |  | const char * | pcPass = 0
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_LockVis | ( | int | iHandle,
 |  | bool | bLock
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_MakeCurrentSRC ( int iHandle )
CLUVIZDLL_API bool CLUViz::ST::EW_Mouse | ( | int | iHandle,
 |  | int | iButton,
 |  | int | iState,
 |  | int | iX,
 |  | int | iY
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_PassiveMouseMove | ( | int | iHandle,
 |  | int | iX,
 |  | int | iY
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_Reshape | ( | int | iHandle,
 |  | int | iWidth,
 |  | int | iHeight
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_SetKeyModifierStates | ( | int | iHandle,
 |  | bool | bShift,
 |  | bool | bCtrl,
 |  | bool | bAlt,
 |  | bool | bNumLock,
 |  | bool | bCapsLock,
 |  | bool | bScrollLock
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::EW_SetScript | ( | int | iHandle,
 |  | const char * | pcScript,
 |  | bool | bResetEnv = false,
 |  | bool | bReparseLatex = false
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetKey ( unsigned __int32 * pKey )
CLUVIZDLL_API bool CLUViz::ST::GetLastError | ( | char * | pcError,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetScriptOutput | ( | int | iHandle,
 |  | char * | pcText,
 |  | int | iMaxLen,
 |  | bool & | bIsError
 | ) |  |
CLUVIZDLL_API void CLUViz::ST::GetStdEnvPath | ( | char * | pcPath,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double & | dRed,
 |  | double & | dGreen,
 |  | double & | dBlue,
 |  | double & | dAlpha
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double * | pdColor4
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarImageData | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | void * | pvData
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarImageProp | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int & | iWidth,
 |  | int & | iHeight,
 |  | int & | iImgType,
 |  | int & | iDataType,
 |  | int & | iBytesPerPixel
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int & | iVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double & | dVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarString | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | char * | pcString,
 |  | int | iMaxLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarTensorData | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | unsigned * | puDim,
 |  | double * | pdData
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVarTensorProp | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | unsigned & | uDimCnt,
 |  | unsigned & | uElCnt
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::GetVersion | ( | char * | pcVersion,
 |  | int | iBufLen
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::ReleaseAll ( )
CLUVIZDLL_API bool CLUViz::ST::ReleaseWindow ( int iHandle )
CLUVIZDLL_API bool CLUViz::ST::SaveView | ( | int | iHandle,
 |  | const char * | pcFilename
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetScriptPath ( const char * pcPath )
CLUVIZDLL_API bool CLUViz::ST::SetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double | dRed,
 |  | double | dGreen,
 |  | double | dBlue,
 |  | double | dAlpha
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarColor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double * | pdColor4
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarImage | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | int | iImgType,
 |  | int | iDataType,
 |  | const void * | pvData
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarNumber | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | double | dVal
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarObject | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | const CLUViz::SObject * | pData
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarString | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | const char * | pcString
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::SetVarTensor | ( | int | iHandle,
 |  | const char * | pcVarName,
 |  | int | iDimCnt,
 |  | const int * | piDim,
 |  | const double * | pdData
 | ) |  |
CLUVIZDLL_API bool CLUViz::ST::Start | ( | const char * | pcEnvPath = 0,
 |  | const char * | pcLicenceKey = 0,
 |  | bool | bAlone = true
 | ) |  |


CLUViz::Tool Namespace Reference

  • Namespace List
  • Namespace Members
  • CLUViz
  • Tool
Functions
CLUViz::Tool Namespace Reference

Functions

CLUVIZTOOL_API bool | CreateViewImage (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle)
CLUVIZTOOL_API bool | DestroyView (int iHandle)
CLUVIZTOOL_API bool | Finalize (void)
CLUVIZTOOL_API const char * | GetLastError (bool bReset=true)
CLUVIZTOOL_API bool | Init (const char *pcEnvPath=0)
CLUVIZTOOL_API bool | ReadImage (const char *pcFilename, Rx::Interop::Runtime28::IImage *pImage)
CLUVIZTOOL_API bool | ViewSetImage (int iHandle, Rx::Interop::Runtime28::IImage *pImage, bool bUpdate=false)
CLUVIZTOOL_API bool | WriteImage (const char *pcFilename, const Rx::Interop::Runtime28::IImage *pImage)

Function Documentation

CLUVIZTOOL_API bool CLUViz::Tool::CreateViewImage | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle
 | ) |  |
CLUVIZTOOL_API bool CLUViz::Tool::DestroyView ( int iHandle )
CLUVIZTOOL_API bool CLUViz::Tool::Finalize ( void )
CLUVIZTOOL_API const char* CLUViz::Tool::GetLastError ( bool bReset = true )
CLUVIZTOOL_API bool CLUViz::Tool::Init ( const char * pcEnvPath = 0 )
CLUVIZTOOL_API bool CLUViz::Tool::ReadImage | ( | const char * | pcFilename,
 |  | Rx::Interop::Runtime28::IImage * | pImage
 | ) |  |
CLUVIZTOOL_API bool CLUViz::Tool::ViewSetImage | ( | int | iHandle,
 |  | Rx::Interop::Runtime28::IImage * | pImage,
 |  | bool | bUpdate = false
 | ) |  |
CLUVIZTOOL_API bool CLUViz::Tool::WriteImage | ( | const char * | pcFilename,
 |  | const Rx::Interop::Runtime28::IImage * | pImage
 | ) |  |


CLUVizST Namespace Reference

  • Namespace List
  • Namespace Members
Functions
CLUVizST Namespace Reference

Functions

CLUVIZDLL_API bool | CreateEx (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | EnableBorder (int iHandle, bool bVal)
CLUVIZDLL_API bool | End ()
CLUVIZDLL_API bool | Run ()
CLUVIZDLL_API bool | RunMsg (__int64 hWnd, unsigned uMsg, unsigned wParam, long lParam)
CLUVIZDLL_API bool | Start ()

Function Documentation

CLUVIZDLL_API bool CLUVizST::CreateEx | ( | int & | iHandle,
 |  | int | iX,
 |  | int | iY,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | const char * | pcTitle,
 |  | const char * | pcInitScript,
 |  | const char * | pcCLUPath,
 |  | bool | bVizOnly,
 |  | bool | bShowIntro,
 |  | void * | pvIcon,
 |  | void * | pvParentHandle,
 |  | unsigned int | uWindowStyle
 | ) |  |
CLUVIZDLL_API bool CLUVizST::EnableBorder | ( | int | iHandle,
 |  | bool | bVal
 | ) |  |
CLUVIZDLL_API bool CLUVizST::End ( )
CLUVIZDLL_API bool CLUVizST::Run ( )
CLUVIZDLL_API bool CLUVizST::RunMsg | ( | __int64 | hWnd,
 |  | unsigned | uMsg,
 |  | unsigned | wParam,
 |  | long | lParam
 | ) |  |
CLUVIZDLL_API bool CLUVizST::Start ( )


ECalibGridMode Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
ECalibGridMode Namespace Reference

Grid calibration modes for parameter CalibGrid_Mode. More...

Enumerations

enum ID { PosScale = 0, PosScaleRot, Count }
Calibration modes More...

Detailed Description

Grid calibration modes for parameter CalibGrid_Mode.

Enumeration Type Documentation

enum ECalibGridMode::ID

Calibration modes

Perwass, 07.08.2012.

Enumerator
PosScale | Calibrate only center position of grid and microimage scale.
PosScaleRot | In addition to center position and microimage scale also calibrate the microimage grid angle.
Count | Number of calibration modes.


ECameraTriggerMode Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
ECameraTriggerMode Namespace Reference

Enumerations

enum ID { None = 0, Camera_FreeRun = 0x0100, Software_SnapShot = 0x0200, Extern_Impulse = 0x0300 }
Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode. More...

Enumeration Type Documentation

enum ECameraTriggerMode::ID

Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode.

Perwass, 07.08.2012.

Enumerator
None |
Camera_FreeRun | The camera triggers new frames itself.
Software_SnapShot | The camera captures a single frame triggered by the software.
Extern_Impulse | The camera waits for an external trigger signal and records a single frame using the current exposure settings.


EDepthImageType Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EDepthImageType Namespace Reference

Depth image output type. Use these value for the parameter Depth_ImageType. More...

Enumerations

enum ID { Standard = 0, Virtual, Relative, Affine, Count }
Depth image types. More...

Detailed Description

Depth image output type. Use these value for the parameter Depth_ImageType.

Enumeration Type Documentation

enum EDepthImageType::ID

Depth image types.

Perwass, 07.08.2012.

Enumerator
Standard | The standard format in which depth data is stored internally. This format maps all depths to the range [0,1] and is comparable between different cameras. Note that for standard Raytrix cameras the effective depth range is [0.5,1].
Virtual | Virtual depths lie in the range [0,infinity] and basically give the number of microlenses each refocused point is seen in. The relation between standard and virtual depth is $d_{std} = 1 - 1 / d_{virt}$ .
Relative | The relative depth depends on the Raytrix camera that is used and maps the effective depth range of the camera to the range [0,1]. These depths are not necessarily comparable between different camera types, but they are well suited for displaying depth.
Affine | Under development! Do not use! The depth values are related to the metric depth values by a scalar factor. The result of this depth image depends on the values of the parameters Depth_Affine_Offset and Depth_Affine_FocalLength.
Count | Number of depth image types.


EError Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EError Namespace Reference

Error IDs of Raytrix API. More...

Enumerations

enum ID {
NONE = 0, COMPUTE = -1, OUTOFMEMORY = -100, OUTOFRANGE = -101, INVALID_POINTER = -102, INSTALL = -103, INTERNAL = -104, API_INIT = -1000,
API_NOINIT = -1001, API_LOADFILE = -1002, API_INVALID_IMGID = -1003, API_NOLFIBOUND = -1004, API_INVALID_IMAGE = -1005, API_SAVEFILE = -1006, API_INITAGAIN = -1007, API_UNKNOWN = -1008,
API_INSTPATH = -1009, API_DONGLE = -1010, API_FEATURE = -1011, API_INVALID_GLTEX = -1012, API_INVALID_IMGTYPE = -1013, API_INVALID_VALUE = -1014, API_LFI_BIND = -1015, API_LFI_BOUND = -1016,
API_VERSION = -1017, PAR_EXIST = -2000, PAR_TYPE = -2001, PAR_ACSREAD = -2002, PAR_ACSWRITE = -2003, PAR_READ = -2004, PAR_WRITE = -2005, PAR_VALUE = -2006,
PAR_NOCONSTR = -2007, PAR_INVCONSTR = -2008, PAR_GRPEXIST = -2009, PAR_NOTSUPPORTED = -2010, PAR_NOTAVAILABLE = -2011, CUDA_MAX = -3000, CUDA_INIT = -3000, CUDA_NODEVICE = -3001,
CUDA_CAPA = -3002, CUDA_ALGO = -3003, CUDA_INITAGAIN = -3004, CUDA_NOINIT = -3005, CUDA_INVDEVID = -3006, CUDA_MIN = -3999, CAMDRV_INIT = -4000, CAMDRV_INITAGAIN = -4001,
CAMDRV_NOINIT = -4002, CAMDRV_INVCAMID = -4003, CAMERA_OPEN = -4100, CAMERA_CLOSE = -4101, CAMERA_STARTCAP = -4102, CAMERA_STOPCAP = -4103, CAMERA_CAPACTIVE = -4104, CAMERA_CAPNOTACTIVE = -4105,
CAMERA_CAPTURE = -4106, CAMERA_ACTIVE = -4107, CAMERA_NOTACTIVE = -4108, CAMERA_NOCALFILE = -4109, CAMERA_INVCALFILE = -4110, CAMERA_STORECALFILE = -4111, CAMERA_LENSSETNEW = -4112, CAMERA_LENSSETEXIST = -4113,
CAMERA_LENSSETDEL = -4114, CAMERA_LENSNEW = -4115, CAMERA_LENSIDEXIST = -4116, CAMERA_LENSDEL = -4117, CAMERA_STOREIMGWHITE = -4118, CAMERA_NOIMGWHITE = -4119, CAMERA_UPDATECALIB = -4120, CAMERA_SUSPENDCAP = -4121,
CAMERA_CALFILEEXIST = -4122, CAMERA_CREATECALFILE = -4123, CAMERA_LENSDEL_LAST_LENS = -4124, CAMERA_TIMEOUT = -4125, CAMERA_TRIGGERMODE_NOT_AVAILABLE = -4126, CAMERA_CAPTURE_STOPPED_UNEXPECTED = -4127, CAMERA_CAPTURE_EXCEPTION = -4128, CAMERA_CAPTURE_INTERNAL_API = -4129,
CAMCAL_NOLENS = -4200, CAMCAL_NOLENSSET = -4201, CAMCAL_INVLENSIDX = -4202, CAMCAL_INVLENSSETIDX = -4203, GL_NOINTEROP = -5000, GL_TEXNOTSUPPORTED = -5001, IMG_NOTSUPPORTED = -6000, IMG_DITNOTSUPPORTED = -6001,
RAYSEQ_OPENREAD = -7000, RAYSEQ_OPENWRITE = -7001, RAYSEQ_READ = -7002, RAYSEQ_WRITE = -7003, RAYSEQ_INVALID = -7004, RAYSEQ_VERSION = -7005, RAYSEQ_CLOSE = -7006, RAYSEQ_NOTOPEN = -7007,
RAYSEQ_EOF = -7008, RAYSEQ_SOF = -7009, RAYSEQ_COMPRESS = -7010, RAYSEQ_UNCOMPRESS = -7011, RAYSEQ_UNKOWNCOMP = -7012, RAYSEQ_UNSUPPIXTYPE = -7013, RAYSEQ_WHITEIMAGE = -7014, RAYSEQ_BIND = -7015,
RAYSEQ_IMAGEFORMAT = -7016, RAYSEQ_WRITEINIT = -7017, RAYSEQ_SETFRAMEIDX = -7018, RAYSEQ_AUTOWRITE = -7094, RAYSEQ_NOREAD = -7095, RAYSEQ_NOWRITE = -7096, RAYSEQ_NOT_BOUND = -7097, RAYSEQ_ALREADY_BOUND = -7098,
RAYSEQ_INVALID_ID = -7099, RAYSEQ_INTERNAL = -7100
}
Error IDs. More...

Detailed Description

Error IDs of Raytrix API.

If an API function returns false, information on the error that occured can be obtained by calling RxGetLastError(). The returned error string contains a standard error text, plus additional information separated by colons (':').

Enumeration Type Documentation

enum EError::ID

Error IDs.

Perwass, 07.08.2012.

Enumerator
NONE | No Error.
COMPUTE | Error in internal computation.
OUTOFMEMORY | Out of memory.
OUTOFRANGE | One of the given parameters is out of range.
INVALID_POINTER | A given pointer is invalid.
INSTALL | Installation is corrupted.
INTERNAL | Internal error. This should not happen. If it does, please report to info@.nosp@m.rayt.nosp@m.rix.d.nosp@m.e.
API_INIT | Error initializing Raytrix API.
API_NOINIT | Raytrix API not initialized.
API_LOADFILE | Error loading file.
API_INVALID_IMGID | Invalid image ID.
API_NOLFIBOUND | No light field image bound.
API_INVALID_IMAGE | Given image is invalid.
API_SAVEFILE | Error saving file.
API_INITAGAIN | Raytrix API already initialized.
API_UNKNOWN | Unexpected error in Raytrix API. This should not happen. If it does, please report to info@.nosp@m.rayt.nosp@m.rix.d.nosp@m.e.
API_INSTPATH | Raytrix API installation path not found in registry.
API_DONGLE | Invalid dongle or no dongle found.
API_FEATURE | Feature not supported by current dongle licence.
API_INVALID_GLTEX | Given GL texture is invalid.
API_INVALID_IMGTYPE | Given image is of invalid type.
API_INVALID_VALUE | Invalid parameter.
API_LFI_BIND | Error binding light field image.
API_LFI_BOUND | Ray image currently bound.
API_VERSION | Current dongle does not support this API version.
PAR_EXIST | Parameter does not exist.
PAR_TYPE | Wrong data type for parameter.
PAR_ACSREAD | Parameter has no read access.
PAR_ACSWRITE | Parameter has no write access.
PAR_READ | Error reading parameter.
PAR_WRITE | Error writing parameter.
PAR_VALUE | Invalid parameter value.
PAR_NOCONSTR | Parameter has no constraint.
PAR_INVCONSTR | Parameter constraint is of different type.
PAR_GRPEXIST | Parameter group does not exist.
PAR_NOTSUPPORTED | Parameter not supported.
PAR_NOTAVAILABLE | Parameter not available.
CUDA_MAX | Minimal CUDA error number.
CUDA_INIT | Error initializing CUDA.
CUDA_NODEVICE | No CUDA device present.
CUDA_CAPA | Insufficient CUDA compute capability.
CUDA_ALGO | Error in CUDA algorithm.
CUDA_INITAGAIN | CUDA device already selected.
CUDA_NOINIT | CUDA not initialized.
CUDA_INVDEVID | Invalid CUDA device ID.
CUDA_MIN | Maximal CUDA error number.
CAMDRV_INIT | Error initializing camera drivers.
CAMDRV_INITAGAIN | Camera drivers already initialized.
CAMDRV_NOINIT | Camera drivers not initialized.
CAMDRV_INVCAMID | Invalid camera ID.
CAMERA_OPEN | Error opening camera.
CAMERA_CLOSE | Error closing camera.
CAMERA_STARTCAP | Error starting camera capture.
CAMERA_STOPCAP | Error stopping camera capture.
CAMERA_CAPACTIVE | Camera capture already active.
CAMERA_CAPNOTACTIVE | Camera capture not active.
CAMERA_CAPTURE | Error capturing image from camera device.
CAMERA_ACTIVE | Camera is already active.
CAMERA_NOTACTIVE | Camera is not active.
CAMERA_NOCALFILE | Camera calibration file not found.
CAMERA_INVCALFILE | Invalid camera calibration file.
CAMERA_STORECALFILE | Error storing camera calibration data in file.
CAMERA_LENSSETNEW | Error creating new calibration lens setting.
CAMERA_LENSSETEXIST | Lens setting already exists.
CAMERA_LENSSETDEL | Error deleting lens setting.
CAMERA_LENSNEW | Error creating new calibration lens data.
CAMERA_LENSIDEXIST | Lens ID already exists.
CAMERA_LENSDEL | Error deleting lens data.
CAMERA_STOREIMGWHITE | Error storing calibration white image.
CAMERA_NOIMGWHITE | No white image available for calibration setting.
CAMERA_UPDATECALIB | Error updating camera calibration.
CAMERA_SUSPENDCAP | Error suspending camera capture.
CAMERA_CALFILEEXIST | Camera calibration file already exists.
CAMERA_CREATECALFILE | Camera calibration file could not be created.
CAMERA_LENSDEL_LAST_LENS | Error deleting lens data (Last available lens)
CAMERA_TIMEOUT | Camera timeout.
CAMERA_TRIGGERMODE_NOT_AVAILABLE | The selected camera trigger mode is not available for the current camera.
CAMERA_CAPTURE_STOPPED_UNEXPECTED | Camera stopped capturing images unexpectedly. Capturing had not been stopped through API.
CAMERA_CAPTURE_EXCEPTION | Exception during camera capture.
CAMERA_CAPTURE_INTERNAL_API | Internal error in API during image capture.
CAMCAL_NOLENS | No lens defined in camera calibration file.
CAMCAL_NOLENSSET | No lens setting defined for currently selected lens in camera calibration file.
CAMCAL_INVLENSIDX | Invalid lens index for camera calibration.
CAMCAL_INVLENSSETIDX | Invalid lens setting index for currently selected lens for camera calibration.
GL_NOINTEROP | Cuda/OpenGL interoperability not available.
GL_TEXNOTSUPPORTED | Texture ID not supported.
IMG_NOTSUPPORTED | Internal image with given ID not supported.
IMG_DITNOTSUPPORTED | Depth image type not supported.
RAYSEQ_OPENREAD | Error opening ray sequence for reading.
RAYSEQ_OPENWRITE | Error opening ray sequence for writing.
RAYSEQ_READ | Error reading from ray sequence.
RAYSEQ_WRITE | Error writing to ray sequence.
RAYSEQ_INVALID | The file is not a ray sequence file.
RAYSEQ_VERSION | Can not read this ray sequence file type version.
RAYSEQ_CLOSE | Error closing ray sequence.
RAYSEQ_NOTOPEN | Ray sequence file not open.
RAYSEQ_EOF | Ray sequence end of file.
RAYSEQ_SOF | Ray sequenece start of file.
RAYSEQ_COMPRESS | Error compressing frame in ray sequence.
RAYSEQ_UNCOMPRESS | Error uncompressing frame in ray sequence.
RAYSEQ_UNKOWNCOMP | Unknown compression type in ray sequence.
RAYSEQ_UNSUPPIXTYPE | Unsupported ray sequence pixel type.
RAYSEQ_WHITEIMAGE | Invalid ray sequence white image.
RAYSEQ_BIND | Error binding ray sequence.
RAYSEQ_IMAGEFORMAT | The image format of the ray sequence is incompatible with that of the given image.
RAYSEQ_WRITEINIT | Error initializing ray sequence for writing.
RAYSEQ_SETFRAMEIDX | Error setting frame index in ray sequence.
RAYSEQ_AUTOWRITE | Auto write mode is active.
RAYSEQ_NOREAD | Ray sequence is not in read mode.
RAYSEQ_NOWRITE | Ray sequence is not in write mode.
RAYSEQ_NOT_BOUND | No ray sequence is bound.
RAYSEQ_ALREADY_BOUND | A ray sequence is already bound.
RAYSEQ_INVALID_ID | Invalid ray sequence id.
RAYSEQ_INTERNAL | Internal ray sequence error.


EFeature Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EFeature Namespace Reference

Values that represent EError. More...

Enumerations

enum ID { None = 0, Standard = 0x0001, MultiView = 0x0002, FocusOnSurface = 0x0004, Calculate3D = 0x0008, Calibrate = 0x0010, RawImage = 0x0020, Save = 0x0040 }
Available features of the lightfield API. More...

Detailed Description

Values that represent EError.

Enumeration Type Documentation

enum EFeature::ID

Available features of the lightfield API.

Perwass, 24.07.2012.

Enumerator
None | No feature.
Standard | Test whether a dongle is present. Check with RxHasFeature().
MultiView | Multiview feature. All functions that allow the generation of images from different viewpoints only run if this feature is enabled. Check availability with RxHasFeature().
FocusOnSurface | Focus on surface. All functions that use a focus surface to generate an output are only available if this feature is enabled. Check availability with RxHasFeature().
Calculate3D | Calculate 3D depth. All functions that evaluate the scene depth are only available if this feature is enabled. Check availability with RxHasFeature().
Calibrate | Calibration. All functions that modify the calibration of a lightfield or a Raytrix camera are only available if this feature is enabled. Check availability with RxHasFeature().
RawImage | Raw image. All functions that output the raw lightfield image are only available if this feature is enabled. Check availability with RxHasFeature().
Save | Save images. All functions that save a lightfield image are only available if this feature is enabled. Check availability with RxHasFeature().


EImgID Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EImgID Namespace Reference

Internal image IDs. More...

Enumerations

enum ID {
None = 0x0000, Ray = 0x0001, RayDepth = 0x0002, Focus = 0x0004, FocusLeft = 0x0004, FocusRight = 0x0008, Depth = 0x0010, DepthLeft = 0x0010,
DepthRight = 0x0020, DepthCol = 0x0040, DepthColLeft = 0x0040, DepthColRight = 0x0080, RayGrid = 0x0100, RayProc = 0x0200, RayWhite = 0x0400
}
Image IDs. More...

Detailed Description

Internal image IDs.

Enumeration Type Documentation

enum EImgID::ID

Image IDs.

Perwass, 07.08.2012.

Enumerator
None |
Ray | Internal ray image.
RayDepth | Internal ray depth image.
Focus | Internal focus result image.
FocusLeft | Internal focus result image for left view.
FocusRight | Internal focus result image for right view.
Depth | Internal depth result image.
DepthLeft | Internal depth result image for left view.
DepthRight | Internal depth result image for right view.
DepthCol | Internal depth color result image.
DepthColLeft | Internal depth color result image for left view.
DepthColRight | Internal depth color result image for right view.
RayGrid | Internal grid result image.
RayProc | Internal pocessed ray image.
RayWhite | Internal ray calibration (white) image.


EPar Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EPar Namespace Reference

This enum contains the parameters IDs for various library and camera parameters. More...

Enumerations

enum ID {
None = 0, Cuda_DeviceName = 0x00010000, Cuda_DeviceID, Cuda_CapaMajor, Cuda_CapaMinor, Cuda_VersionRuntime, Cuda_VersionDriver, Cuda_TotalGlobalMem,
Cuda_RegsPerBlock, Cuda_WarpSize, Cuda_MemPitch, Cuda_MaxThreadsPerBlock, Cuda_TotalConstMem, Cuda_DeviceOverlap, Cuda_MultiProcessorCount, Cuda_ComputeMode,
Cuda_MaxTex2DSizeX, Cuda_MaxTex2DSizeY, Cuda_MaxTex2DArraySizeX, Cuda_MaxTex2DArraySizeY, Cuda_ConcurrentKernels, Cuda_TCCDriver, Cam_Count = 0x00020000, Cam_Name,
Cam_Type, Cam_ID, Cam_Exposure, Cam_TapBalance, Cam_Gain, Cam_GainRed, Cam_GainGreen, Cam_GainBlue,
Cam_IsColor, Cam_IsBayer, Cam_Width, Cam_Height, Cam_OffsetX, Cam_OffsetY, Cam_AutoUpdateGlTex, Cam_FramesPerSecond,
Cam_ActualFramesPerSecond, Cam_Focus, Cam_Iris, Cam_Func_CalibMainLens, Cam_TapBalanceMode, Cam_PIVMode, Cam_IsOpen, Cam_IsCapturing,
Cam_Temperature, Cam_TriggerMode, CamCal_LensCnt = 0x00030000, CamCal_LensSetCnt, CamCal_LensIdx, CamCal_LensSetIdx, CamCal_LensName, CamCal_LensID,
CamCal_LensSetFStop, CamCal_LensSetFocus, CamCal_MainLensIris, CamCal_MainLensFocus, CamCap_Timeout_Video = 0x0003F000, CamCap_Timeout_Single, CamCap_Timeout_Extern, CamCap_Frames_Lost = 0x0003F020,
CamCap_AutoLum_MaxSaturatedPixelPercentage = 0x0003F100, CamCap_AutoGain_Enabled = 0x0003F200, CamCap_AutoGain_Active, CamCap_AutoGain_MinValue, CamCap_AutoGain_MaxValue, CamCap_AutoExposure_Enabled = 0x0003F300, CamCap_AutoExposure_Active, CamCap_AutoExposure_MinValue,
CamCap_AutoExposure_MaxValue, Ray_Width = 0x00040000, Ray_Height, Ray_PixelType, Ray_DataType, Ray_ApplyWhiteImage, Ray_ConvBayer, Ray_MLI_Rotation,
Ray_MLI_Diameter, Ray_MLI_Border, Ray_MLI_OffsetX, Ray_MLI_OffsetY, Ray_MLI_PixelSizeX, Ray_MLI_PixelSizeY, Ray_MLI_BaseRotation, Ray_MLI_BaseReflectX,
Ray_MLI_BaseReflectY, Ray_MLI_BaseVecXX, Ray_MLI_BaseVecXY, Ray_MLI_BaseVecYX, Ray_MLI_BaseVecYY, Ray_MLI_SubGridBaseX, Ray_MLI_SubGridBaseY, Ray_MLI_LensTypeCount,
Ray_MLI_LensTypeIdx, Ray_MLI_LensTypeVirtDepthMin, Ray_MLI_LensTypeVirtDepthMax, Ray_MLI_LensTypeOffsetX, Ray_MLI_LensTypeOffsetY, Ray_MLI_RadDistType, Ray_MLI_RadDistParCnt, Ray_MLI_RadDistOffsetX,
Ray_MLI_RadDistOffsetY, Ray_MLI_RadDistPar1, Ray_MLI_RadDistPar2, Ray_MLI_RadDistPar3, Ray_MLI_RadDistPar4, Ray_MLI_RadDistPar5, Ray_MLI_NeedWhiteImage, Ray_ApplyFileSettings = 0x00047000,
Gl_TexRayID = 0x00050000, Gl_TexFocusLeftID, Gl_TexFocusRightID, Gl_TexDepthLeftID, Gl_TexDepthRightID, Gl_TexDepthColLeftID, Gl_TexDepthColRightID, Gl_TexGridID,
Gl_TexFocusLeftID2, Gl_TexFocusRightID2, Gl_TexRayProcID, Gl_TexRayWhiteID, Gl_TexRayDepthID, RaySeq_AutoStoreCamFrames = 0x00060000, RaySeq_ApplyFileSettings, RaySeq_AutoStoreCamFrameCnt,
PreProc_Std_Enable = 0x00100000, PreProc_Std_Brightness, PreProc_Std_ContrastCenter, PreProc_Std_ContrastScale, PreProc_Sharp1_Enable = 0x00102000, PreProc_Sharp1_BlurStdDev, PreProc_Sharp1_Factor, PreProc_Sharp1_OnlyCalc,
PreProc_Demosaic_Enable = 0x00104000, PreProc_Demosaic_R, PreProc_Demosaic_G, PreProc_Demosaic_B, PreProc_DenoiseNLM_Enable = 0x00105000, PreProc_DenoiseNLM_FilterDia, PreProc_DenoiseNLM_NoiseLevel, PreProc_DenoiseNLM_BlendFactor,
Depth_Algo = 0x00200000, Depth_ResImgDiv, Depth_ImageType, Depth_DefaultValue, Depth_Affine_Offset = 0x00201000, Depth_Affine_FocalLength, Depth_Std_BlockCnt = 0x00202000, Depth_Std_PatchRad,
Depth_Std_MedianRad, Depth_Std_MeanRad, Depth_Std_SizeDiv, Depth_Std_MinTrust, Depth_Std_MaxInvCor, Depth_Std_MinStdDev, Depth_Std_PixelStep, Depth_Std_RawMedianRad,
Depth_Std_RawMeanRad, Depth_Std_RawMeanMaxBlackPart, Depth_Std_Fuse_DepthDeltaMax, Depth_Std_Fuse_DepthOptRangeMax, Depth_Path_BlockCnt = 0x00203000, Depth_Path_NearResLevel, Depth_Path_SparseLensSet, Depth_Path_MaxVirtDepth,
Depth_Path_LensTypeIdx = 0x00203100, Depth_Path_LT_PixelStep, Depth_Path_LT_MinStdDev, Depth_Path_LT_MinCor, Depth_Path_LT_MinPolyParAbs, Depth_Path_LT_MaxPolyCtrDelta, Depth_Path_LT_PatchDia, Depth_Path_LT_PatchStride,
Depth_PathPiv_BlockCnt = 0x00203200, Depth_PathPiv_NearResLevel, Depth_PathPiv_LensTypeIdx = 0x00203300, Depth_PathPiv_LT_PixelStep, Depth_PathPiv_LT_MinCor, Depth_PathPiv_LT_BPSigma, Depth_PathPiv_LT_BPMinCor, Depth_PathPiv_LT_BPMinMean,
Depth_PathPiv_LT_MinPolyParAbs, Depth_PathPiv_LT_MaxPolyCtrDelta, Depth_PathPiv_LT_PatchDia, Depth_PathPiv_LT_PatchStride, Depth_Fuse_MedianRad = 0x00205000, Depth_Fuse_MeanRad, Depth_Fuse_MeanMaxBlackPart, Depth_Fuse_LensTypeIdx = 0x00205100,
Depth_Fill_Enabled = 0x00207000, Depth_Fill_IterCnt, Depth_Fill_IterSize, Depth_Fill_Complete, Depth_Fill_MedianRad, Depth_Fill_MeanRad, Depth_Fill_NLM_Enabled, Depth_Fill_NLM_FilterDia,
Depth_Fill_NLM_NoiseLevel, Depth_Fill_NLM_BlendFactor, Depth_Fill_Bilateral_Enabled, Depth_Fill_Bilateral_FilterRad, Depth_Fill_Bilateral_SigmaR, Depth_Fill_Bilateral_SigmaS, Focus_ResImgDiv = 0x00220000, Focus_MaxLensContribRad,
Focus_ViewOffset_VirtDepthMin, Focus_ViewOffset_VirtDepthMax, Focus_ViewOffset_Gamma, Focus_ViewOffset_Radial, Focus_ViewOffset_VirtDepthCollPlane, Focus_ViewOffset_X, Focus_ViewOffset_Y, Focus_DefaultFocus,
Focus_Focus, Focus_Stereo_Enabled, Focus_Stereo_EyeSep, Focus_Stereo_Rot, Focus_DefocusBlur_Enable = 0x00221000, Focus_DefocusBlur_VirtDOF, Focus_DefocusBlur_Gradient, Focus_DefocusBlur_MaxBlurRad,
Focus_DefocusBlur_DefaultDepth, Grid_ResImgDiv = 0x00230000, Calib_Grid_Mode = 0x00240000
}
LF API parameters More...

Detailed Description

This enum contains the parameters IDs for various library and camera parameters.

There are three possible types the parameters can have: unsigned integer, double or string. Furthoremore, parameters can be read-only (RO), write-only (WO) or read-write (RW). The parameter type and the access type are indicated for each parameter.

Enumeration Type Documentation

enum EPar::ID

LF API parameters

Perwass, 07.08.2012.

Enumerator
None
Cuda_DeviceName

The name of the cuda device (string, RO)

Cuda_DeviceID

The device ID of the selected CUDA device (unsigned, RO)

Cuda_CapaMajor

The compute capability major version (unsigned, RO)

Cuda_CapaMinor

The compute capability minor version (unsigned, RO)

Cuda_VersionRuntime

CUDA device runtime version.

Cuda_VersionDriver

CUDA device driver version.

Cuda_TotalGlobalMem

CUDA device total global memory.

Cuda_RegsPerBlock

CUDA device registers per block.

Cuda_WarpSize

CUDA device warp size.

Cuda_MemPitch

CUDA device memory pitch.

Cuda_MaxThreadsPerBlock

CUDA device maximal number of threads per block.

Cuda_TotalConstMem

CUDA device total constant memory.

Cuda_DeviceOverlap

CUDA device concurrent memory copy and kernel execution.

Cuda_MultiProcessorCount

CUDA device number of processors.

Cuda_ComputeMode

CUDA device compute mode.

Cuda_MaxTex2DSizeX

CUDA device maximum 2D texture size x-dimension.

Cuda_MaxTex2DSizeY

CUDA device maximum 2D texture size y-dimension.

Cuda_MaxTex2DArraySizeX

CUDA device maximum 2D array texture size x-dimension.

Cuda_MaxTex2DArraySizeY

CUDA device maximum 2D array texture size y-dimension.

Cuda_ConcurrentKernels

CUDA device can execute kernels concurrently.

Cuda_TCCDriver

CUDA device is a Tesla device using a TCC driver.

Cam_Count

Number of cameras available (unsigned, RO)

Cam_Name

(deprecated, returns same value as Cam_Type) Name of a camera (string, RO)

Cam_Type

Camera type (string, RO)

Cam_ID

Camera ID (string, RO)

Cam_Exposure

Camera exposure in milliseconds (double, RW)

Cam_TapBalance
Cam_Gain

Camera gain in range [0,100] (double, RW)

Cam_GainRed

Camera gain for red color channel in range [0,100] (double, RW)

Cam_GainGreen

Camera gain for green color channel in range [0,100] (double, RW)

Cam_GainBlue

Camera gain for blue color channel in range [0,100] (double, RW)

Cam_IsColor

If camera is a color camera this is set to 1, otherwise to 0 (unsigned, RO)

Cam_IsBayer

If camera is in bayer mode this is set to 1, otherwise to 0 (unsigned, RO)

Cam_Width

Width of image returned by camera (unsigned, RO)

Cam_Height

Height of image returned by camera (unsigned, RO)

Cam_OffsetX

Offset in X-direction (unsigned, RO)

Cam_OffsetY

Offset in Y-direction (unsigned, RO)

Cam_AutoUpdateGlTex

Automatically update ray image texture (unsigned, RW)

Cam_FramesPerSecond

Target for captured frames per second.

Cam_ActualFramesPerSecond

Actual captured frames per second.

Cam_Focus

Main lens focus setting (double, RW)

Cam_Iris

Main lens iris setting (double, RW)

Cam_Func_CalibMainLens

Execute main lens calibration for controllable lenses (unsigned, RW)

Cam_TapBalanceMode

Tap Balance Mode.

Cam_PIVMode

PIV Mode (unsigned, RW)

Cam_IsOpen

Test whether a camera is open (unsigned, RO)

Cam_IsCapturing

Test whether a camera is in capture mode (unsigned, RO)

Cam_Temperature

Temperature of camera (double, RO)

Cam_TriggerMode

Sets the camera trigger mode. This replaces the old Cam_IsVideoMode. See ECameraTriggerMode for the available trigger modes. (unsigned, RW)

CamCal_LensCnt

Number of lenses stored in camera calibration database (unsigned, RO)

CamCal_LensSetCnt

Number of lens settings stored for currently selected lens in camera calibration database (unsigned, RO)

CamCal_LensIdx

The currently selected lens in the camera calibration database (unsigned, RW)

CamCal_LensSetIdx

The currently selected lens setting in the camera calibration database (unsigned, RW)

CamCal_LensName

The name of the currently selected lens (string, RW)

CamCal_LensID

The ID of the currently selected lens (string, RO)

CamCal_LensSetFStop

The f-stop value of the currently selected lens setting (double, RO)

CamCal_LensSetFocus

The focus value of the currently selected lens setting (double, RO)

CamCal_MainLensIris

The internal iris setting of the main lens for controllable lenses, of the currently selected lens setting (double, RW)

CamCal_MainLensFocus

The internal focus setting of the main lens for controllable lenses, of the currently selected lens setting (double, RW)

CamCap_Timeout_Video

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in video mode. Default is zero. (unsigned, RW)

CamCap_Timeout_Single

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in single capture mode. Default is 10000. (unsigned, RW)

CamCap_Timeout_Extern

Time in milliseconds before RxCamDoCapture() returns with Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE if no image has been received from the camera in external trigger mode. Default is zero. (unsigned, RW)

CamCap_Frames_Lost

Number of lost frames since last image capture start.

CamCap_AutoLum_MaxSaturatedPixelPercentage

The maximal percentage of pixels that are allowed to be overexposed before the luminance (gain and/or shutter) is reduced (double, [0.0, 10.0], RW).

CamCap_AutoGain_Enabled

If set to 1 auto gain is enabled. Captured images are processed by the API and the camera gain is adjusted appropriately. (unsigned, [0,1], RW)

CamCap_AutoGain_Active

This value is set by the API to indicate whether the auto gain algorithm is currently adapting the camera gain. (unsigned, [0,1], RO)

CamCap_AutoGain_MinValue

The minimal gain value set by the auto gain. (unsigned, [0, 100], RW)

CamCap_AutoGain_MaxValue

The maximal gain value set by the auto gain. (unsigned, [0, 100], RW)

CamCap_AutoExposure_Enabled

If set to 1 auto exposure is enabled. Captured images are processed by the API and the camera shutter speed is adjusted appropriately. (unsigned, [0,1], RW)

CamCap_AutoExposure_Active

This value is set by the API to indicate whether the auto gain algorithm is currently adapting the camera exposure time. (unsigned, [0,1], RO).

CamCap_AutoExposure_MinValue

The minimal exposure time in milliseconds. (double, [0, 1000000], RW)

CamCap_AutoExposure_MaxValue

The maximal exposure time in milliseconds. (double, [0, 1000000], RW)

Ray_Width

The width of the currently bound ray image (unsigned, RO)

Ray_Height

The height of the currently bound ray image (unsigned, RO)

Ray_PixelType

The pixel type of the currently bound ray image (unsigned, RO)

Ray_DataType

The data type of the currently bound ray image (unsigned, RO)

Ray_ApplyWhiteImage

Flag whether to apply a white image to the raw ray image or not (unsigned, RW)

Ray_ConvBayer

Flag whether to apply.

Ray_MLI_Rotation

MLA rotation anti-clockwise in radians (double, RW)

Ray_MLI_Diameter

Diameter in pixels of microimage of central microlens (double, RW)

Ray_MLI_Border

Microimage border in pixels (double, RW)

Ray_MLI_OffsetX

X-offset of center of central microimage from image center in pixels (double, RW)

Ray_MLI_OffsetY

Y-offset of center of central microimage from image center in pixels (double, RW)

Ray_MLI_PixelSizeX

Horizontal size of pixel on image sensor in mm (double, RW)

Ray_MLI_PixelSizeY

Vertical size of pixel on image sensor in mm (double, RW)

Ray_MLI_BaseRotation

Base rotation of the MLA as number of 90 degree steps (unsigned, RW)

Ray_MLI_BaseReflectX

Flag whether lens grid is reflected in x-axis (unsigned, RW)

Ray_MLI_BaseReflectY

Flag whether lens grid is reflected in y-axis (unsigned, RW)

Ray_MLI_BaseVecXX

X-component of basis vector of neighboring lenses in x-direction in lens units (double, RW)

Ray_MLI_BaseVecXY

Y-component of basis vector of neighboring lenses in x-direction in lens units (double, RW)

Ray_MLI_BaseVecYX

X-component of basis vector of neighboring lenses in y-direction in lens units (double, RW)

Ray_MLI_BaseVecYY

Y-component of basis vector of neighboring lenses in y-direction in lens units (double, RW)

Ray_MLI_SubGridBaseX

X-component of vector between orthogonal sub grids in lens units (double, RW)

Ray_MLI_SubGridBaseY

Y-component of vector between orthogonal sub grids in lens units (double, RW)

Ray_MLI_LensTypeCount

Number of different lens types. Changing this value also changes the values of Ray_MLI_SubGridBaseX, Ray_MLI_SubGridBaseY, Ray_MLI_BaseVecXX, Ray_MLI_BaseVecXY, Ray_MLI_BaseVecYX, Ray_MLI_BaseVecYY, Ray_MLI_LensTypeOffsetX, Ray_MLI_LensTypeOffsetY appropriately. (unsigned, RW)

Ray_MLI_LensTypeIdx

Currently selected lens type (unsigned, RW)

Ray_MLI_LensTypeVirtDepthMin

Minimal virtual depth of currently selected lens type (double, RW)

Ray_MLI_LensTypeVirtDepthMax

Maximal virtual depth of currently selected lens type (double, RW)

Ray_MLI_LensTypeOffsetX

X-offset to currently selected lens type central lens in lens units (double, RW)

Ray_MLI_LensTypeOffsetY

Y-offset to currently selected lens type central lens in lens units (double, RW)

Ray_MLI_RadDistType

Radial Distortion Type of microimages (unsigned, RW)

Ray_MLI_RadDistParCnt

Number of parameters used in radial distortion (unsigned, RW)

Ray_MLI_RadDistOffsetX

X-offset of radial distortion center from image center (double, RW)

Ray_MLI_RadDistOffsetY

Y-offset of radial distortion center from image center (double, RW)

Ray_MLI_RadDistPar1
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar2
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar3
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar4
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_RadDistPar5
  1. Radial Distortion Parameter (double, RW)
Ray_MLI_NeedWhiteImage

Flag whether raw image needs white image to obtain proper processed raw image (unsigned, [0,1], RW)

Ray_ApplyFileSettings

Flag whether parameter settings stored in ray file are applied when loading image (unsigned, [0,1], RW)

Gl_TexRayID

OpenGL texture name for ray image (unsigned, WO)

Gl_TexFocusLeftID

OpenGL texture name for standard focus and left focus image (unsigned, WO)

Gl_TexFocusRightID

OpenGL texture name for right focus image (unsigned, WO)

Gl_TexDepthLeftID

OpenGL texture name for standard depth and left depth image (unsigned, WO)

Gl_TexDepthRightID

OpenGL texture name for right depth image (unsigned, WO)

Gl_TexDepthColLeftID

OpenGL texture name for standard depth color and left depth color image (unsigned, WO)

Gl_TexDepthColRightID

OpenGL texture name for right depth color image (unsigned, WO)

Gl_TexGridID

OpenGL texture name for grid image (unsigned, WO)

Gl_TexFocusLeftID2
  1. OpenGL texture name for standard focus and left focus image (unsigned, WO)
Gl_TexFocusRightID2
  1. OpenGL texture name for right focus image (unsigned, WO)
Gl_TexRayProcID

OpenGL texture name for processed raw image.

Gl_TexRayWhiteID

OpenGL texture name for raw white image.

Gl_TexRayDepthID

OpenGL texture name for raw depth image.

RaySeq_AutoStoreCamFrames

Automatically store frames captured from a camera into the bound ray sequence in write mode (unsigned, RW)

RaySeq_ApplyFileSettings

Flag whether parameter settings stored in ray sequence file are applied when loading sequence (unsigned, [0,1], RW)

RaySeq_AutoStoreCamFrameCnt

Number of frames that are stored when RaySeq_AutoStoreCamFrames is set to 1. If value is zero, then there is no limit on the number of frames stored. If value is larger than zero, the value is decremented for each frame recorded. When the value reaches zero, RaySeq_AutoStoreCamFrames is set to zero and no more frames are stored. (unsigned, [0,max], RW)

PreProc_Std_Enable

Enable Standard Preprocessing of ray image (unsigned, RW)

PreProc_Std_Brightness

Standard preprocessing: brightness gain [0,1e5] (double, RW)

PreProc_Std_ContrastCenter

Standard preprocessing: contrast center [0,1] (double, RW)

PreProc_Std_ContrastScale

Standard preprocessing: contrast scale [0,2] (double, RW)

PreProc_Sharp1_Enable

Enable sharpness algortithm 1: unsharp masking (unsigned, RW)

PreProc_Sharp1_BlurStdDev

Sharpness Algo1: Standard deviation of Gauss blurred image [0,10] (double, RW)

PreProc_Sharp1_Factor

Sharpness Algo1: Mixing factor of blurred image with original image as pixel * factor + blurred * (1 - factor). [-2,3] (double, RW)

PreProc_Sharp1_OnlyCalc

Use sharpness only for depth calculation (not for output image) (unsigned, RW)

PreProc_Demosaic_Enable

Enable demosaic balance parameters (unsigned, RW)

PreProc_Demosaic_R

Red balance [0,1] (double, RW)

PreProc_Demosaic_G

Green balance [0,1] (double, RW)

PreProc_Demosaic_B

Blue balance [0,1] (double, RW)

PreProc_DenoiseNLM_Enable

Enable Non-Local-Means denoising of raw image (unsigned, [0,1], RW)

PreProc_DenoiseNLM_FilterDia

Denoise filter diameter in pixels (unsigned, [2,8], RW)

PreProc_DenoiseNLM_NoiseLevel

Noise level (double, [0.01, 2.0], RW)

PreProc_DenoiseNLM_BlendFactor

Blending factor (double, [0, 0.3], RW)

Depth_Algo

Depth evaluation algorithm type name. (string, ["standard", "depth_path", "depth_path_piv"], RW)

Depth_ResImgDiv

Result image size divisor for depth evaluation (double, [2.0, 10.0], RW)

Depth_ImageType

Depth image output type. Valid values are listed in Rx::ApiLF::EDepthImageType::ID.

Depth_DefaultValue

Default depth value for output depth images. This value is used for all pixel, where the internal depth map has no result.

Depth_Affine_Offset

Under development! Do not use! Offset value for affine depth values in millimeter.

Depth_Affine_FocalLength

Under development! Do not use! Focal length of main lens in millimeter for calculation of affine depth.

Depth_Std_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_Std_PatchRad

Correlation patch radius (unsigned, [1,10], RW)

Depth_Std_MedianRad

Post process median radius (unsigned, [0,10], RW)

Depth_Std_MeanRad

Post process mean radius (unsigned, [0,10], RW)

Depth_Std_SizeDiv

Size divisor for ray depth image. Should be half the value of Depth_ResImgDiv (unsigned, [1,8], RW)

Depth_Std_MinTrust

Trust threashold (double, [0,1], RW)

Depth_Std_MaxInvCor

Maximal inverse correlation threshold (double, [0,1], RW)

Depth_Std_MinStdDev

Minimal standard deviation of correlation patch (double, [0,1], RW)

Depth_Std_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_Std_RawMedianRad

Post process raw depth image with median filter of given radius. Depth fusion is done after this filter. (unsigned, [0,5], RW)

Depth_Std_RawMeanRad

Post process raw depth image with mean filter of given radius. Depth fusion is done after this filter. (unsigned, [0,5], RW)

Depth_Std_RawMeanMaxBlackPart

Post process raw depth image with mean filter. Mean filter is only applied if the percentage of pixels with unknown depth does not exceed this limit. (double, [0,1], RW)

Depth_Std_Fuse_DepthDeltaMax

Maximum delta of depth values in depth fusion for the depth value to be considered as a result. (double, [0,1], RW)

Depth_Std_Fuse_DepthOptRangeMax

Maximum range of good depth fuse values whose delta lies below Depth_Std_Fuse_DepthDeltaMax. (double, [0,5], RW)

Depth_Path_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_Path_NearResLevel

The resolution level for near objects. The higher the number the finer the depth resolution for near objects. (unsigned, [2,5], RW)

Depth_Path_SparseLensSet

Flag whether to use a sparse set of microlenses to calculate depth. (unsigned, [0,1], RW)

Depth_Path_MaxVirtDepth

Maximum virtual depth for depth estimation (double, [6.0, 100.0], RW)

Depth_Path_LensTypeIdx

Current lens type for which parameter values are read/set (unsigned, [0, 11], RW). All parameters starting with Depth_Path_LT_ are influenced by this setting.

Depth_Path_LT_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_Path_LT_MinStdDev

Minimal standard deviation of correlation patch (double, [0,1], RW)

Depth_Path_LT_MinCor

Minimal correlation threshold (double, [0,1], RW)

Depth_Path_LT_MinPolyParAbs

Absolute polynom parameter threshold. The larger the value the stronger the extremum has to be to be accepted. (double, [0,1], RW)

Depth_Path_LT_MaxPolyCtrDelta

Maximum delta of polynom fit extremum position to central position (double, [0,1], RW)

Depth_Path_LT_PatchDia

Correlation patch radius (unsigned, [2,5], RW)

Depth_Path_LT_PatchStride

Correlation patch stride (unsigned, [1,5], RW)

Depth_PathPiv_BlockCnt

Number of blocks calculated per CUDA kernel call (unsigned, [1,10000000], RW)

Depth_PathPiv_NearResLevel

The resolution level for near objects. The higher the number the finer the depth resolution for near objects. (unsigned, [2,5], RW)

Depth_PathPiv_LensTypeIdx

Current lens type for which parameter values are read/set (unsigned, [0, 11], RW). All parameters starting with Depth_PathPiv_LT_ are influenced by this setting.

Depth_PathPiv_LT_PixelStep

Pixel step for disparity evaluation (double, [0.1,1.0], RW)

Depth_PathPiv_LT_MinCor

Minimal correlation threshold (double, [0,1], RW)

Depth_PathPiv_LT_BPSigma

Standard deviation of Gauss intensity distribution of target base patch (double, [0.5, 10.0], RW)

Depth_PathPiv_LT_BPMinCor

Minimal correlation threshold with target base patch (double, [0,1], RW)

Depth_PathPiv_LT_BPMinMean

Minimal mean intensity threshold for base patch (double, [0,1], RW)

Depth_PathPiv_LT_MinPolyParAbs

Absolute polynom parameter threshold. The larger the value the stronger the extremum has to be to be accepted. (double, [0,1], RW)

Depth_PathPiv_LT_MaxPolyCtrDelta

Maximum delta of polynom fit extremum position to central position (double, [0,1], RW)

Depth_PathPiv_LT_PatchDia

Correlation patch radius (unsigned, [2,5], RW)

Depth_PathPiv_LT_PatchStride

Correlation patch stride (unsigned, [1,5], RW)

Depth_Fuse_MedianRad

Radius of median filter applied after fusion of raw depth image (unsigned, [0,10], RW)

Depth_Fuse_MeanRad

Radius of mean filter applied after fusion of raw depth image (unsigned, [0,10], RW)

Depth_Fuse_MeanMaxBlackPart

Mean filter is only applied for a black central pixel if the percentage of pixels within patch with unknown depth does not exceed this limit. (double, [0,1], RW)

Depth_Fuse_LensTypeIdx

The lens type to which the parameters starting with Depth_Fuse_LT_ relate to. (unsigned, [0,11], RW)

Depth_Fill_Enabled

Flag whether filling of depth map is enabled.

Depth_Fill_IterCnt

Number of iterations used for filling the depth map. (unsigned, [0,10], RW)

Depth_Fill_IterSize

Size of unknown depth border filled per iteration in pixels. (unsigned, [1, 100], RW)

Depth_Fill_Complete

Flag to indicate whether the remaining unknown depth areas are to be filled after the iterations. (unsigned, [0,1], RW)

Depth_Fill_MedianRad

Radius of median filter that is applied after filling the depth map. (unsigned, [0,4], RW)

Depth_Fill_MeanRad

Radius of mean filter that is applied after filling the depth map. (unsigned, [0,10], RW)

Depth_Fill_NLM_Enabled

Enable Denoise "Non Local Means" (NLM) algorithm after filling depth image (unsigned, [0,1], RW)

Depth_Fill_NLM_FilterDia

NLM filter diameter (unsigned, [2,8], RW)

Depth_Fill_NLM_NoiseLevel

NLM noise level (double, [0.01, 2.0], RW)

Depth_Fill_NLM_BlendFactor

NLM blend factor (double, [0,0.3], RW)

Depth_Fill_Bilateral_Enabled

Flag whether bilateral filtering of depth map is enabled. (unsigned, [0,1], RW)

Depth_Fill_Bilateral_FilterRad

Bilateral filter radius (unsigned, [1,20], RW)

Depth_Fill_Bilateral_SigmaR

Bilateral filter sigma R (edge) (double, [0.01,0.2], RW)

Depth_Fill_Bilateral_SigmaS

Bilateral filter sigma S (distance) (double, [1.0,20.0], RW)

Focus_ResImgDiv

Result image size division factor (double, RW)

Focus_MaxLensContribRad

Maximal radius in which lenses contribute to a resultant pixel (double, [1,10], RW)

Focus_ViewOffset_VirtDepthMin

Virtual Depth of furthest depth plane for view offset calculation (double, [1,30], RW)

Focus_ViewOffset_VirtDepthMax

Virtual Depth of closest depth plane for view offset calculation (double, [1,30], RW)

Focus_ViewOffset_Gamma

Gamma value for view offset function along z-direction (double, [0.1,10.0], RW)

Focus_ViewOffset_Radial

Radial view offset scale factor. (double, [-2,2], RW)

Focus_ViewOffset_VirtDepthCollPlane

Virtual depth of collimation plane. (double, [1,30], RW)

Focus_ViewOffset_X

View offset X. (double, [-1.0,1.0], RW)

Focus_ViewOffset_Y

View offset Y. (double, [-1.0,1.0], RW)

Focus_DefaultFocus

Default focus value. (double, [0.0,1.0], RW)

Focus_Focus

Focus value. (double, [0.0,1.0], RW)

Focus_Stereo_Enabled

Flag whether stereo view is enabled.

Focus_Stereo_EyeSep

Stereo eye separation. (double, [0.05,1.0], RW)

Focus_Stereo_Rot

Stereo image rotation. (double, [-180.0,180.0], RW)

Focus_DefocusBlur_Enable

Enable blurring of out-of-focus areas for focusing. (int, [0,1], RW)

Focus_DefocusBlur_VirtDOF

Depth of field for defocus blur as virtual depth delta (double, [0.0,100.0], RW)

Focus_DefocusBlur_Gradient

Gradient of defocus blur. Linear factor for blurring radius depending on virtual depth difference. (double, [0.1,100], RW)

Focus_DefocusBlur_MaxBlurRad

Maximum blur radius for defocusing. (int, [0,100], RW)

Focus_DefocusBlur_DefaultDepth

Default relative depth value used for areas where no depth could be calculated. (double, [0,1], RW)

Grid_ResImgDiv

Result image size division factor (double, RW)

Calib_Grid_Mode

Auto Grid calibration type (unsigned, RW)


EParGrp Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EParGrp Namespace Reference

Parameter group IDs. More...

Enumerations

enum ID {
None = 0, Cuda = 0x00010000, Camera = 0x00020000, CamCal = 0x00030000, CamCap = 0x0003F000, Ray = 0x00040000, Gl = 0x00050000, RaySeq = 0x00060000,
PreProc = 0x00100000, Depth = 0x00200000, Depth_Path = 0x00203000, Depth_PathPiv = 0x00203200, Focus = 0x00220000, Grid = 0x00230000, Calib = 0x00240000
}
Parameter group IDs. More...

Detailed Description

Parameter group IDs.

Enumeration Type Documentation

enum EParGrp::ID

Parameter group IDs.

Perwass, 07.08.2012.

Enumerator
None |
Cuda | CUDA parameter group.
Camera | Camera parameter group.
CamCal | Camera calibration parameter group.
CamCap | Camera capture parameter group.
Ray | Ray image parameter group.
Gl | OpenGL parameter group.
RaySeq | Ray sequence parameters.
PreProc | PreProcessing parameter group.
Depth | Depth evaluation parameter group.
Depth_Path | Depth Path algorithm.
Depth_PathPiv | Depth Path PIV algorithm.
Focus | Focus evaluation parameter group.
Grid | Grid display parameter group.
Calib | Calibration parameters.


ERadDistType Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
ERadDistType Namespace Reference

Radial distortion types of raw images. More...

Enumerations

enum ID { Constant = 0, Polynom4, Inversion2 }
Radial image distortion types. More...

Detailed Description

Radial distortion types of raw images.

Enumeration Type Documentation

enum ERadDistType::ID

Radial image distortion types.

Perwass, 07.08.2012.

Enumerator
Constant | No radial distortion.
Polynom4 | Radial distortion with polynomial of degree 4.
Inversion2 | Radial distortion with inversion of degree 2.


ERaySeqMode Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
ERaySeqMode Namespace Reference

Ray sequence file modes. More...

Enumerations

enum ID { None = 0x0000, Read = 0x0001, Write = 0x0002, Compress_Zip = 0x0100 }

Detailed Description

Ray sequence file modes.

    These enums can be used as a bit mask to combine various modes.

Perwass, 07.08.2012.

Enumeration Type Documentation

enum ERaySeqMode::ID
Enumerator
None | Empty ray sequence mode.
Read | A ray sequence opened for reading.
Write | A ray sequence opened for writing.
Compress_Zip | When writing to a ray sequence, compress frames with zip compression.


EStatusMessage Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EStatusMessage Namespace Reference

Values that represent EStatusCode. More...

Enumerations

enum ID {
None = 0, Debug = int(EStatusMsgGrp::Text), Info, Error, Assertion, Exception, Fatal, Warning,
Progress_Init = int(EStatusMsgGrp::Progress), Progress_Value, Progress_Step, Progress_Finished
}

Detailed Description

Values that represent EStatusCode.

Enumeration Type Documentation

enum EStatusMessage::ID
Enumerator
None |
Debug |
Info |
Error |
Assertion |
Exception |
Fatal |
Warning |
Progress_Init | The number of steps in the process is passed in the iValue parameter.
Progress_Value | The new value of the progress is passed in the iValue parameter.
Progress_Step | Increment the progress by the number passed in iValue.
Progress_Finished | Process is finished.


EStatusMsgGrp Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EStatusMsgGrp Namespace Reference

Values that represent EStatusCode. More...

Enumerations

enum ID { None = 0, Text = 0x00010000, Progress = 0x00020000 }

Detailed Description

Values that represent EStatusCode.

Enumeration Type Documentation

enum EStatusMsgGrp::ID
Enumerator
None
Text
Progress


EStatusSource Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EStatusSource Namespace Reference

Values that represent EStatusCodeGroup. More...

Enumerations

enum ID { Unknown = 0, API, Camera, CameraDriver, Compute, App }

Detailed Description

Values that represent EStatusCodeGroup.

Enumeration Type Documentation

enum EStatusSource::ID
Enumerator
Unknown |
API | Message originates from the API.
Camera | Messages originate from cameras.
CameraDriver |
Compute |
App |


EWarning Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations
EWarning Namespace Reference

Values that represent EWarning. More...

Enumerations

enum ID { NONE = 0, GENERAL = 1, CAMERA_CORRUPTDB = 4100, CAMERA_CAPTURE_NOIMAGE = 4101, CAMERA_INVWHITETYPE = 4102, CAMERA_CAPTURE_STOPPED = 4103, CAMERA_TYPE_MISMATCH = 4104 }

Detailed Description

Values that represent EWarning.

Enumeration Type Documentation

enum EWarning::ID
Enumerator
NONE | No Warning.
GENERAL | A function could finish successfully but issued a warning. The function returns with true but the last error is set to this value.
CAMERA_CORRUPTDB | Corrupted camera database has been corrected.
CAMERA_CAPTURE_NOIMAGE | No image currently available from camera.
CAMERA_INVWHITETYPE | Invalid white image type.
CAMERA_CAPTURE_STOPPED | Camera capturing has stopped while waiting for frame.
CAMERA_TYPE_MISMATCH | Camera's type does not match with current camera driver.


Rx::ApiLF Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
Namespaces | Data Structures | Typedefs | Functions
Rx::ApiLF Namespace Reference

Namespaces

namespace | ECalibGridMode
Grid calibration modes for parameter CalibGrid_Mode.
namespace | ECameraTriggerMode
namespace | EDepthImageType
Depth image output type. Use these value for the parameter Depth_ImageType.
namespace | EError
Error IDs of Raytrix API.
namespace | EFeature
Values that represent EError.
namespace | EImgID
Internal image IDs.
namespace | EPar
This enum contains the parameters IDs for various library and camera parameters.
namespace | EParGrp
Parameter group IDs.
namespace | ERadDistType
Radial distortion types of raw images.
namespace | ERaySeqMode
Ray sequence file modes.
namespace | EStatusMessage
Values that represent EStatusCode.
namespace | EStatusMsgGrp
Values that represent EStatusCode.
namespace | EStatusSource
Values that represent EStatusCodeGroup.
namespace | EWarning
Values that represent EWarning.
namespace | NET

Data Structures

class | CStatusMessageDelegateList
struct | SStatusMessageDelegate

Typedefs

typedef void(__stdcall * TFuncStatusMessageCallback )(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue, void *pvContext)
Function pointer type of the status message callback function. More...

Functions

RXLF_API bool | AddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | RemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | RxAddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | RxCalibGrid ()
Calibrate the microimage grid. More...
RXLF_API bool | RxCamCalibCreate (unsigned uCamIdx, bool bForce)
Create a new camera calibration database. More...
RXLF_API bool | RxCamCalibDeleteLens (unsigned uCamIdx)
Delete the currently selected calibration database entry of a lens. More...
RXLF_API bool | RxCamCalibDeleteLensSetting (unsigned uCamIdx)
Delete the currently selected calibration database entry for a lens setting. More...
RXLF_API bool | RxCamCalibNewLens (unsigned uCamIdx, const Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName)
Create a calibration database enty for a new lens. More...
RXLF_API bool | RxCamCalibNewLens (unsigned uCamIdx, Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName, bool bCreateID)
Create a calibration database enty for a new lens. More...
RXLF_API bool | RxCamCalibNewLensSetting (unsigned uCamIdx, double dFStop, double dFocus)
Create a new calibration database entry for a lens setting. More...
RXLF_API bool | RxCamCalibStore (unsigned uCamIdx)
Store the calibration database in the camera calibration file. More...
RXLF_API bool | RxCamCalibStoreWhiteImage (unsigned uCamIdx, unsigned uImgCnt)
Capture a number of images to create a new white image. More...
RXLF_API bool | RxCamCalibUpdate (unsigned uCamIdx)
Update the lightfield calibration data. More...
RXLF_API bool | RxCamClose (unsigned uCamIdx)
Close a camera. More...
RXLF_API bool | RxCamDoCapture (unsigned uCamIdx)
Capture a single image from a camera. More...
RXLF_API bool | RxCamDriverInit ()
Initialize the camera drivers. More...
RXLF_API bool | RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, Rx::CRxString &sxValue)
Get a camera parameter of type Rx::CRxString. More...
RXLF_API bool | RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, unsigned &uValue)
Get a camera parameter of type unsigned integer. More...
RXLF_API bool | RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, double &dValue)
Get camera parameter of type double. More...
RXLF_API bool | RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the parameter range of a camera parameter of type unsigned integer. More...
RXLF_API bool | RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, double &dMin, double &dMax)
Get the parameter range of a camera parameter of type double. More...
RXLF_API bool | RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, Rx::CRxArrayUInt &auValues)
Get set of available values for parameter of type unsigned. More...
RXLF_API bool | RxCamOpen (unsigned uCamIdx)
Open a camera. More...
RXLF_API bool | RxCamRegister ()
Register available cameras. More...
RXLF_API bool | RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const Rx::CRxString &sxValue)
Set a camera property of type Rx::CRxString. More...
RXLF_API bool | RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const unsigned &uValue)
Set a camera property of type unsigned integer. More...
RXLF_API bool | RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const double &dValue)
Set a camera property of type double. More...
RXLF_API bool | RxCamStartCapture (unsigned uCamIdx, unsigned &hRay)
Prepare camera for capturing images. More...
RXLF_API bool | RxCamStopCapture (unsigned uCamIdx)
Stop capturing images. More...
RXLF_API bool | RxCamSupPar (unsigned uCamIdx, EPar::ID ePar, bool &bSupported)
Test whether a camera parameter is supported by the selected camera. More...
RXLF_API bool | RxCamSuspendCapture (unsigned uCamIdx, bool bSuspend)
Suspend capturing images. More...
RXLF_API bool | RxConvertImage (Rx::CRxImage &xDstImage, const Rx::CRxImage &xSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | RxConvertImage (Rx::IImage *pDstImage, const Rx::IImage *pSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType, bool bCreate)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | RxCudaDeviceCount (int &iDeviceCount)
Returns the number of CUDA devices installed. More...
RXLF_API bool | RxCudaDeviceMemInfo (unsigned &uFreeMem, unsigned &uTotalMem)
Return free and total amount of memory on the selected CUDA device. More...
RXLF_API bool | RxCudaDeviceProp (int iDevice, Rx::CRxString &sxName, unsigned &iCCMajor, unsigned &iCCMinor)
Get the name and the compute capability major and minor version for a CUDA device. More...
RXLF_API bool | RxCudaSelectDevice (int iDevice=-1, bool bUseGL=false)
Select a CUDA device. More...
RXLF_API bool | RxDepth (bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API DEPRECATED bool | RxDepth ()
Evaluate the scene depth from a bound ray image. More...
RXLF_API bool | RxDepthColorCode (double dRelDepthMin=0.0, double dRelDepthMax=1.0, EImgID::ID eTrgImgID=EImgID::DepthCol)
Color code depth images. More...
RXLF_API DEPRECATED bool | RxDepthEx (double dViewOffX, double dViewOffY, bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API bool | RxDepthMap (double dStdDepth, int iWidth, int iHeight, double *pdData, unsigned uElCnt, EImgID::ID eTrgImgID=EImgID::Depth)
Generate a depth map from a set of coordinates. More...
RXLF_API bool | RxDongleGetID (int &iDngID, int &iRxID)
Get the IDs of an attached dongle. More...
RXLF_API bool | RxDongleReinitialize ()
RXLF_API bool | RxFinalize (void)
Close any open cameras and free all memory allocated on CUDA device and in host memory. More...
RXLF_API bool | RxFocusOnPlane ()
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | RxFocusOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | RxFocusOnPlaneEx (double dRelDepth, double dViewOffX=0.0, double dViewOffY=0.0)
Focus image to a plane perpendicular to the optical axis, and select view point. More...
RXLF_API bool | RxFocusOnSurface ()
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | RxFocusOnSurface (double dStdDepth)
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | RxFocusOnSurfaceEx (double dStdDepth, double dViewOffX, double dViewOffY)
Focus on surface and select view point. More...
RXLF_API bool | RxGetImage (EImgID::ID eImgID, Rx::CRxImage &xImage)
Get an internal image. More...
RXLF_API bool | RxGetImage (EImgID::ID eImgID, Rx::IImage *pImage, bool bCreate)
Get an internal image. More...
RXLF_API bool | RxGetImageDevicePointer (EImgID::ID eImgID, void *&pDevicePtr)
Get the device pointer of an internal image. More...
RXLF_API bool | RxGetImageFormat (EImgID::ID eImgID, Rx::CRxImageFormat &xF)
Get the image format of an internal image. More...
RXLF_API bool | RxGetImageHistogram (EImgID::ID eImgID, Rx::CRxArrayUInt &xHistogram)
Calculate the histogram of a given image. More...
RXLF_API int | RxGetLastError (Rx::CRxString &sxError, bool bClear=true)
Obtain the error code and string of the last error that occured and reset the error. More...
RXLF_API int | RxGetLastErrorReport (Rx::CRxString &sxError, bool bClear=true)
Obtain the full incident report on the last error. More...
RXLF_API double | RxGetLastExecTime ()
Get last execution time of a CUDA algorithm. More...
RXLF_API bool | RxGetPar (EPar::ID ePar, unsigned &uValue)
Get a parameter of type unsigned integer. More...
RXLF_API bool | RxGetPar (EPar::ID ePar, double &dValue)
Get a parameter of type double. More...
RXLF_API bool | RxGetPar (EPar::ID ePar, Rx::CRxString &sValue)
Get a parameter of type Rx::CRxString. More...
RXLF_API bool | RxGetParName (EPar::ID ePar, Rx::CRxString &sValue)
Get the string representation of a parameter. More...
RXLF_API bool | RxGetParRange (EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the range of a parameter. More...
RXLF_API bool | RxGetParRange (EPar::ID ePar, double &dMin, double &dMax)
Get the range of a parameter. More...
RXLF_API bool | RxGetRegistryString (const Rx::CRxString &sxPath, Rx::CRxString &sxValue)
Read a string from the Windows registry. More...
RXLF_API double | RxGetTime ()
Get a time measured in milliseconds as double value. More...
RXLF_API __int64 | RxGetTime64 ()
Get a time in milliseconds as 64 bit integer value. More...
RXLF_API bool | RxGlGetVersion (int &iMajor, int &iMinor)
Get OpenGL version of current OpenGL rendering context. More...
RXLF_API bool | RxGlUpdateTex (unsigned uIntImgIDs)
Copy CUDA result images to OpenGL textures. More...
RXLF_API bool | RxGrid ()
Show a lens grid overlay on the raw ray image. More...
RXLF_API bool | RxHasFeature (unsigned uID)
Test whether the API offers a particular feature. More...
RXLF_API bool | RxInit (bool bInitCuda, const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...
RXLF_API bool | RxInit (const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...
RXLF_API bool | RxIsImageValid (EImgID::ID eImgID)
Test whether an internal image is valid. More...
RXLF_API bool | RxLoadPar (const Rx::CRxString &sxFilename)
Load all API parameters from file. More...
RXLF_API bool | RxLogConsoleAddMessage (Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSource, const char *pcMessage, int iValue)
RXLF_API bool | RxLogConsoleClose ()
RXLF_API bool | RxLogConsoleShow ()
RXLF_API bool | RxPreProcess ()
Pre-Process a ray image. More...
RXLF_API bool | RxRayBind (unsigned hRay)
Bind a ray image to perform computations on. More...
RXLF_API bool | RxRayCalibLoad (unsigned hRay, const Rx::CRxString &sxFilename)
Load calibration data of ray image from XML file. More...
RXLF_API bool | RxRayCalibNew (unsigned hRay, int iLensTypeCount, double dLensDia, double dPixSize, double dOffsetX, double dOffsetY, double dRotDeg, double dLensBorder, int iRot90Cnt, bool bReflectX, bool bReflectY)
Create a new calibration data set. More...
RXLF_API bool | RxRayCalibSave (unsigned hRay, const Rx::CRxString &sxFilename)
Save calibration data of ray image in XML format. More...
RXLF_API bool | RxRayCalibXmlGet (unsigned hRay, Rx::CRxString &sxXml)
Get the calibration data of the given ray image as XML string. More...
RXLF_API bool | RxRayCalibXmlSet (unsigned hRay, const Rx::CRxString &sxXml)
Set the calibration data of the given ray image from an XML string. More...
RXLF_API bool | RxRayDelete (unsigned hRay)
Delete the image with the given ID. More...
RXLF_API bool | RxRayGetFormat (unsigned hRay, Rx::CRxImageFormat &xF)
Get the image format of a ray image. More...
RXLF_API bool | RxRayGetFormatEx (unsigned hRay, Rx::CRxImageFormat &xF, void *pData)
Get extended format information on ray image. More...
RXLF_API bool | RxRayGetMetaData (unsigned uImgID, Rx::CRxMetaData &xMetaData)
Get meta data of a ray image. More...
RXLF_API bool | RxRayGetRaw (unsigned hRay, Rx::CRxImage &xRawImage)
Get the ray image as Rx::CRxImage instance. More...
RXLF_API bool | RxRayGetRaw (unsigned hRay, Rx::IImage *pRawImage, bool bCreate)
Get the ray image. More...
RXLF_API bool | RxRayLoad (unsigned &hRay, const Rx::CRxString &sxFilename)
Load a ray image. More...
RXLF_API bool | RxRayNew (unsigned &hRay, const Rx::CRxImageFormat &xF)
Create a new ray image. More...
RXLF_API bool | RxRaySave (unsigned hRay, const Rx::CRxString &sxFilename)
Save a ray image. More...
RXLF_API bool | RxRaySeqBind (unsigned uRaySeqID, unsigned &uImgID)
Bind a ray sequence for use by other API functions. More...
RXLF_API bool | RxRaySeqClose (unsigned uRaySeqID)
Close a ray sequence. More...
RXLF_API bool | RxRaySeqGetFileSize (unsigned uRaySeqID, unsigned __int64 &uFileSize)
Get the total file size of the ray sequence in bytes. More...
RXLF_API bool | RxRaySeqGetFrameBufferUsedCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frame buffers in use. More...
RXLF_API bool | RxRaySeqGetFrameCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frames in ray sequence. More...
RXLF_API bool | RxRaySeqGetFrameIndex (unsigned uRaySeqID, unsigned &uFrameIdx)
Get current frame index of ray sequence. More...
RXLF_API bool | RxRaySeqMoveFrameIndex (unsigned uRaySeqID, int iStep)
Move the frame index relative to the current position in the ray sequence. More...
RXLF_API bool | RxRaySeqOpen (unsigned &uRaySeqID, const Rx::CRxString &sxFilename, unsigned uMode, unsigned uFrameBufferCount)
Open a ray sequence. More...
RXLF_API bool | RxRaySeqRead ()
Read a frame from the currently bound ray sequence. More...
RXLF_API bool | RxRaySeqSetFrameIndex (unsigned uRaySeqID, unsigned uFrameIdx)
Set the current frame index of ray sequence. More...
RXLF_API bool | RxRaySeqUnbind (unsigned uRaySeqID)
Unbind a ray sequence. More...
RXLF_API bool | RxRaySeqWrite ()
Write currently bound ray image to currently bound ray sequence. More...
RXLF_API bool | RxRaySetMetaData (unsigned uImgID, const Rx::CRxMetaData &xMetaData)
Set meta data of a ray image. More...
RXLF_API bool | RxRemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | RxResizeImage (Rx::CRxImage &xImage, int iDivider)
Resize an image. More...
RXLF_API bool | RxSaveDepthPointList (const char *pcFilename)
RXLF_API bool | RxSavePar (const Rx::CRxString &sxFilename)
Save all API parameters from file. More...
RXLF_API bool | RxSetImage (EImgID::ID eImgID, const Rx::CRxImage &xImage)
Set an internal image. More...
RXLF_API bool | RxSetImage (EImgID::ID eImgID, const Rx::IImage *pImage)
Set an internal image. More...
RXLF_API bool | RxSetPar (EPar::ID ePar, const unsigned &uValue)
Set a parameter of type unsigned integer. More...
RXLF_API bool | RxSetPar (EPar::ID ePar, const double &dValue)
Set a parameter of type double. More...
RXLF_API bool | RxSetPar (EPar::ID ePar, const Rx::CRxString &sValue)
Set a parameter of type Rx::CRxString. More...
RXLF_API void | RxSleep (unsigned uTime)
Pause calling thread for the given number of milliseconds. More...
RXLF_API bool | RxStereoDepth (bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API DEPRECATED bool | RxStereoDepth ()
Calculate the depth for a left and a right view. More...
RXLF_API DEPRECATED bool | RxStereoDepthEx (double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY, bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API bool | RxStereoOnPlane ()
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | RxStereoOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | RxStereoOnPlaneEx (double dRelDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API bool | RxStereoOnSurface ()
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | RxStereoOnSurface (double dStdDepth)
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | RxStereoOnSurfaceEx (double dStdDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Stereo focus on surface with variable eye separation, view rotation and view offset. More...
RXLF_API bool | RxTransformDepthValue (double &dTrgValue, double dSrcValue, EDepthImageType::ID eTrgDIT, EDepthImageType::ID eSrcDIT)
Transform between different depth values. More...
RXLF_API bool | RxUpdateImage (EImgID::ID eImgID)
Update an internal image. More...


Rx::ApiLF::NET Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • ApiLF
  • NET
Data Structures
Rx::ApiLF::NET Namespace Reference

Data Structures

class | CtrlLogListView
Summary for CtrlLogList More...
class | FormLogConsole
Summary for RxFormLog More...
class | LogConsoleManager


Rx::Interop Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • Interop
Namespaces
Rx::Interop Namespace Reference

Namespaces

namespace Runtime28


Rx::Interop::Runtime28 Namespace Reference

  • Namespace List
  • Namespace Members
  • Rx
  • Interop
  • Runtime28
Namespaces | Data Structures
Rx::Interop::Runtime28 Namespace Reference

Namespaces

namespace | EDataType
The image data types.
namespace | EPixelType
The image pixel types.

Data Structures

class IImage
Interface supported by Raytrix images. More...


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- _ -

  • _Start() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AddStatusMessageHandler() : Rx::ApiLF
  • Affine : Rx::ApiLF::EDepthImageType , EDepthImageType
  • API : Rx::ApiLF::EStatusSource , EStatusSource
  • API_DONGLE : Rx::ApiLF::EError , EError
  • API_FEATURE : Rx::ApiLF::EError , EError
  • API_INIT : Rx::ApiLF::EError , EError
  • API_INITAGAIN : Rx::ApiLF::EError , EError
  • API_INSTPATH : Rx::ApiLF::EError , EError
  • API_INVALID_GLTEX : Rx::ApiLF::EError , EError
  • API_INVALID_IMAGE : Rx::ApiLF::EError , EError
  • API_INVALID_IMGID : Rx::ApiLF::EError , EError
  • API_INVALID_IMGTYPE : Rx::ApiLF::EError , EError
  • API_INVALID_VALUE : Rx::ApiLF::EError , EError
  • API_LFI_BIND : EError , Rx::ApiLF::EError
  • API_LFI_BOUND : Rx::ApiLF::EError , EError
  • API_LOADFILE : EError , Rx::ApiLF::EError
  • API_NOINIT : Rx::ApiLF::EError , EError
  • API_NOLFIBOUND : Rx::ApiLF::EError , EError
  • API_SAVEFILE : Rx::ApiLF::EError , EError
  • API_UNKNOWN : Rx::ApiLF::EError , EError
  • API_VERSION : Rx::ApiLF::EError , EError
  • App : EStatusSource , Rx::ApiLF::EStatusSource
  • Assertion : EStatusMessage , Rx::ApiLF::EStatusMessage


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BayerBG : Rx::Interop::Runtime28::EPixelType
  • BayerGB : Rx::Interop::Runtime28::EPixelType
  • BayerGR : Rx::Interop::Runtime28::EPixelType
  • BayerRG : Rx::Interop::Runtime28::EPixelType
  • BGR : Rx::Interop::Runtime28::EPixelType
  • BGRA : Rx::Interop::Runtime28::EPixelType
  • Byte : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • Calculate3D : Rx::ApiLF::EFeature , EFeature
  • Calib : EParGrp , Rx::ApiLF::EParGrp
  • Calib_Grid_Mode : Rx::ApiLF::EPar , EPar
  • Calibrate : EFeature , Rx::ApiLF::EFeature
  • Cam_ActualFramesPerSecond : Rx::ApiLF::EPar , EPar
  • Cam_AutoUpdateGlTex : Rx::ApiLF::EPar , EPar
  • Cam_Count : Rx::ApiLF::EPar , EPar
  • Cam_Exposure : EPar , Rx::ApiLF::EPar
  • Cam_Focus : Rx::ApiLF::EPar , EPar
  • Cam_FramesPerSecond : Rx::ApiLF::EPar , EPar
  • Cam_Func_CalibMainLens : Rx::ApiLF::EPar , EPar
  • Cam_Gain : Rx::ApiLF::EPar , EPar
  • Cam_GainBlue : Rx::ApiLF::EPar , EPar
  • Cam_GainGreen : Rx::ApiLF::EPar , EPar
  • Cam_GainRed : Rx::ApiLF::EPar , EPar
  • Cam_Height : EPar , Rx::ApiLF::EPar
  • Cam_ID : Rx::ApiLF::EPar , EPar
  • Cam_Iris : Rx::ApiLF::EPar , EPar
  • Cam_IsBayer : Rx::ApiLF::EPar , EPar
  • Cam_IsCapturing : Rx::ApiLF::EPar , EPar
  • Cam_IsColor : Rx::ApiLF::EPar , EPar
  • Cam_IsOpen : Rx::ApiLF::EPar , EPar
  • Cam_Name : Rx::ApiLF::EPar , EPar
  • Cam_OffsetX : Rx::ApiLF::EPar , EPar
  • Cam_OffsetY : Rx::ApiLF::EPar , EPar
  • Cam_PIVMode : Rx::ApiLF::EPar , EPar
  • Cam_TapBalance : Rx::ApiLF::EPar , EPar
  • Cam_TapBalanceMode : Rx::ApiLF::EPar , EPar
  • Cam_Temperature : Rx::ApiLF::EPar , EPar
  • Cam_TriggerMode : Rx::ApiLF::EPar , EPar
  • Cam_Type : Rx::ApiLF::EPar , EPar
  • Cam_Width : EPar , Rx::ApiLF::EPar
  • CamCal : Rx::ApiLF::EParGrp , EParGrp
  • CAMCAL_INVLENSIDX : Rx::ApiLF::EError , EError
  • CAMCAL_INVLENSSETIDX : Rx::ApiLF::EError , EError
  • CamCal_LensCnt : Rx::ApiLF::EPar , EPar
  • CamCal_LensID : Rx::ApiLF::EPar , EPar
  • CamCal_LensIdx : Rx::ApiLF::EPar , EPar
  • CamCal_LensName : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetCnt : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetFocus : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetFStop : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetIdx : Rx::ApiLF::EPar , EPar
  • CamCal_MainLensFocus : Rx::ApiLF::EPar , EPar
  • CamCal_MainLensIris : Rx::ApiLF::EPar , EPar
  • CAMCAL_NOLENS : Rx::ApiLF::EError , EError
  • CAMCAL_NOLENSSET : Rx::ApiLF::EError , EError
  • CamCap : Rx::ApiLF::EParGrp , EParGrp
  • CamCap_AutoExposure_Active : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_Enabled : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_MaxValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_MinValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_Active : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_Enabled : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_MaxValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_MinValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoLum_MaxSaturatedPixelPercentage : Rx::ApiLF::EPar , EPar
  • CamCap_Frames_Lost : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Extern : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Single : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Video : Rx::ApiLF::EPar , EPar
  • CAMDRV_INIT : Rx::ApiLF::EError , EError
  • CAMDRV_INITAGAIN : Rx::ApiLF::EError , EError
  • CAMDRV_INVCAMID : EError , Rx::ApiLF::EError
  • CAMDRV_NOINIT : Rx::ApiLF::EError , EError
  • Camera : Rx::ApiLF::EParGrp , EParGrp , Rx::ApiLF::EStatusSource , EStatusSource
  • CAMERA_ACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CALFILEEXIST : Rx::ApiLF::EError , EError
  • CAMERA_CAPACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CAPNOTACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_EXCEPTION : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_INTERNAL_API : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_NOIMAGE : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CAPTURE_STOPPED : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CAPTURE_STOPPED_UNEXPECTED : Rx::ApiLF::EError , EError
  • CAMERA_CLOSE : Rx::ApiLF::EError , EError
  • CAMERA_CORRUPTDB : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CREATECALFILE : Rx::ApiLF::EError , EError
  • Camera_FreeRun : Rx::ApiLF::ECameraTriggerMode , ECameraTriggerMode
  • CAMERA_INVCALFILE : Rx::ApiLF::EError , EError
  • CAMERA_INVWHITETYPE : Rx::ApiLF::EWarning , EWarning
  • CAMERA_LENSDEL : EError , Rx::ApiLF::EError
  • CAMERA_LENSDEL_LAST_LENS : Rx::ApiLF::EError , EError
  • CAMERA_LENSIDEXIST : EError , Rx::ApiLF::EError
  • CAMERA_LENSNEW : Rx::ApiLF::EError , EError
  • CAMERA_LENSSETDEL : EError , Rx::ApiLF::EError
  • CAMERA_LENSSETEXIST : Rx::ApiLF::EError , EError
  • CAMERA_LENSSETNEW : Rx::ApiLF::EError , EError
  • CAMERA_NOCALFILE : Rx::ApiLF::EError , EError
  • CAMERA_NOIMGWHITE : EError , Rx::ApiLF::EError
  • CAMERA_NOTACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_OPEN : EError , Rx::ApiLF::EError
  • CAMERA_STARTCAP : Rx::ApiLF::EError , EError
  • CAMERA_STOPCAP : EError , Rx::ApiLF::EError
  • CAMERA_STORECALFILE : Rx::ApiLF::EError , EError
  • CAMERA_STOREIMGWHITE : Rx::ApiLF::EError , EError
  • CAMERA_SUSPENDCAP : Rx::ApiLF::EError , EError
  • CAMERA_TIMEOUT : Rx::ApiLF::EError , EError
  • CAMERA_TRIGGERMODE_NOT_AVAILABLE : Rx::ApiLF::EError , EError
  • CAMERA_TYPE_MISMATCH : Rx::ApiLF::EWarning , EWarning
  • CAMERA_UPDATECALIB : EError , Rx::ApiLF::EError
  • CameraDriver : Rx::ApiLF::EStatusSource , EStatusSource
  • CheckFeature() : CLUViz
  • Compress_Zip : ERaySeqMode , Rx::ApiLF::ERaySeqMode
  • Compute : EStatusSource
  • COMPUTE : Rx::ApiLF::EError , EError
  • Compute : Rx::ApiLF::EStatusSource
  • Constant : ERadDistType , Rx::ApiLF::ERadDistType
  • Count : ECalibGridMode , Rx::ApiLF::ECalibGridMode , Rx::ApiLF::EDepthImageType , EDepthImageType
  • Create() : CLUViz::MT
  • CreateEx() : CLUViz , CLUVizST
  • CreateEx1() : CLUViz::MT
  • CreateEx2() : CLUViz::MT
  • CreateViewImage() : CLUViz::Tool
  • Cuda : EParGrp , Rx::ApiLF::EParGrp
  • CUDA_ALGO : Rx::ApiLF::EError , EError
  • CUDA_CAPA : Rx::ApiLF::EError , EError
  • Cuda_CapaMajor : Rx::ApiLF::EPar , EPar
  • Cuda_CapaMinor : EPar , Rx::ApiLF::EPar
  • Cuda_ComputeMode : EPar , Rx::ApiLF::EPar
  • Cuda_ConcurrentKernels : Rx::ApiLF::EPar , EPar
  • Cuda_DeviceID : EPar , Rx::ApiLF::EPar
  • Cuda_DeviceName : Rx::ApiLF::EPar , EPar
  • Cuda_DeviceOverlap : Rx::ApiLF::EPar , EPar
  • CUDA_INIT : Rx::ApiLF::EError , EError
  • CUDA_INITAGAIN : Rx::ApiLF::EError , EError
  • CUDA_INVDEVID : EError , Rx::ApiLF::EError
  • CUDA_MAX : Rx::ApiLF::EError , EError
  • Cuda_MaxTex2DArraySizeX : Rx::ApiLF::EPar , EPar
  • Cuda_MaxTex2DArraySizeY : Rx::ApiLF::EPar , EPar
  • Cuda_MaxTex2DSizeX : EPar , Rx::ApiLF::EPar
  • Cuda_MaxTex2DSizeY : EPar , Rx::ApiLF::EPar
  • Cuda_MaxThreadsPerBlock : Rx::ApiLF::EPar , EPar
  • Cuda_MemPitch : EPar , Rx::ApiLF::EPar
  • CUDA_MIN : Rx::ApiLF::EError , EError
  • Cuda_MultiProcessorCount : EPar , Rx::ApiLF::EPar
  • CUDA_NODEVICE : EError , Rx::ApiLF::EError
  • CUDA_NOINIT : Rx::ApiLF::EError , EError
  • Cuda_RegsPerBlock : Rx::ApiLF::EPar , EPar
  • Cuda_TCCDriver : Rx::ApiLF::EPar , EPar
  • Cuda_TotalConstMem : EPar , Rx::ApiLF::EPar
  • Cuda_TotalGlobalMem : Rx::ApiLF::EPar , EPar
  • Cuda_VersionDriver : EPar , Rx::ApiLF::EPar
  • Cuda_VersionRuntime : Rx::ApiLF::EPar , EPar
  • Cuda_WarpSize : Rx::ApiLF::EPar , EPar


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • Debug : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Depth : Rx::ApiLF::EImgID , EParGrp , Rx::ApiLF::EParGrp , EImgID
  • Depth_Affine_FocalLength : EPar , Rx::ApiLF::EPar
  • Depth_Affine_Offset : Rx::ApiLF::EPar , EPar
  • Depth_Algo : Rx::ApiLF::EPar , EPar
  • Depth_DefaultValue : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_Enabled : EPar , Rx::ApiLF::EPar
  • Depth_Fill_Bilateral_FilterRad : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_SigmaR : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_SigmaS : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Complete : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Enabled : Rx::ApiLF::EPar , EPar
  • Depth_Fill_IterCnt : Rx::ApiLF::EPar , EPar
  • Depth_Fill_IterSize : Rx::ApiLF::EPar , EPar
  • Depth_Fill_MeanRad : EPar , Rx::ApiLF::EPar
  • Depth_Fill_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_BlendFactor : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_Enabled : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_FilterDia : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_NoiseLevel : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MeanMaxBlackPart : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MeanRad : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_ImageType : Rx::ApiLF::EPar , EPar
  • Depth_Path : Rx::ApiLF::EParGrp , EParGrp
  • Depth_Path_BlockCnt : Rx::ApiLF::EPar , EPar
  • Depth_Path_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MaxPolyCtrDelta : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MinCor : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MinPolyParAbs : EPar , Rx::ApiLF::EPar
  • Depth_Path_LT_MinStdDev : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PatchDia : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PatchStride : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PixelStep : Rx::ApiLF::EPar , EPar
  • Depth_Path_MaxVirtDepth : Rx::ApiLF::EPar , EPar
  • Depth_Path_NearResLevel : Rx::ApiLF::EPar , EPar
  • Depth_Path_SparseLensSet : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv : Rx::ApiLF::EParGrp , EParGrp
  • Depth_PathPiv_BlockCnt : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_BPMinCor : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_BPMinMean : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_BPSigma : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_MaxPolyCtrDelta : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_MinCor : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_MinPolyParAbs : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_PatchDia : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_PatchStride : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_PixelStep : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_NearResLevel : Rx::ApiLF::EPar , EPar
  • Depth_ResImgDiv : Rx::ApiLF::EPar , EPar
  • Depth_Std_BlockCnt : EPar , Rx::ApiLF::EPar
  • Depth_Std_Fuse_DepthDeltaMax : EPar , Rx::ApiLF::EPar
  • Depth_Std_Fuse_DepthOptRangeMax : EPar , Rx::ApiLF::EPar
  • Depth_Std_MaxInvCor : Rx::ApiLF::EPar , EPar
  • Depth_Std_MeanRad : Rx::ApiLF::EPar , EPar
  • Depth_Std_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_Std_MinStdDev : Rx::ApiLF::EPar , EPar
  • Depth_Std_MinTrust : Rx::ApiLF::EPar , EPar
  • Depth_Std_PatchRad : Rx::ApiLF::EPar , EPar
  • Depth_Std_PixelStep : Rx::ApiLF::EPar , EPar
  • Depth_Std_RawMeanMaxBlackPart : EPar , Rx::ApiLF::EPar
  • Depth_Std_RawMeanRad : EPar , Rx::ApiLF::EPar
  • Depth_Std_RawMedianRad : EPar , Rx::ApiLF::EPar
  • Depth_Std_SizeDiv : Rx::ApiLF::EPar , EPar
  • DepthCol : Rx::ApiLF::EImgID , EImgID
  • DepthColLeft : Rx::ApiLF::EImgID , EImgID
  • DepthColRight : Rx::ApiLF::EImgID , EImgID
  • DepthLeft : Rx::ApiLF::EImgID , EImgID
  • DepthRight : Rx::ApiLF::EImgID , EImgID
  • Destroy() : CLUViz::MT
  • DestroyAll() : CLUViz::MT
  • DestroyView() : CLUViz::Tool
  • Double : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EmbedWindow() : CLUViz::ST
  • EnableBorder() : CLUVizST
  • EnableUserEnd() : CLUViz::MT
  • EnableVisualization() : CLUViz::ST
  • End() : CLUViz::MT , CLUVizST , CLUViz::ST
  • Error : Rx::ApiLF::EStatusMessage , EStatusMessage
  • EW_ActiveMouseMove() : CLUViz::ST
  • EW_Display() : CLUViz::ST
  • EW_ExecUser() : CLUViz::ST
  • EW_IdleFunc() : CLUViz::ST
  • EW_Keyboard() : CLUViz::ST
  • EW_LoadScript() : CLUViz::ST
  • EW_LockVis() : CLUViz::ST
  • EW_MakeCurrentSRC() : CLUViz::ST
  • EW_Mouse() : CLUViz::ST
  • EW_PassiveMouseMove() : CLUViz::ST
  • EW_Reshape() : CLUViz::ST
  • EW_SetKeyModifierStates() : CLUViz::ST
  • EW_SetScript() : CLUViz::ST
  • Exception : EStatusMessage , Rx::ApiLF::EStatusMessage
  • ExecUser() : CLUViz::MT
  • Extern_Impulse : ECameraTriggerMode , Rx::ApiLF::ECameraTriggerMode


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • Fatal : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Finalize() : CLUViz::Tool
  • Float : Rx::Interop::Runtime28::EDataType
  • Float2Pixel() : Rx
  • Focus : Rx::ApiLF::EParGrp , Rx::ApiLF::EImgID , EParGrp , EImgID
  • Focus_DefaultFocus : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_DefaultDepth : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_Enable : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_Gradient : EPar , Rx::ApiLF::EPar
  • Focus_DefocusBlur_MaxBlurRad : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_VirtDOF : Rx::ApiLF::EPar , EPar
  • Focus_Focus : Rx::ApiLF::EPar , EPar
  • Focus_MaxLensContribRad : Rx::ApiLF::EPar , EPar
  • Focus_ResImgDiv : Rx::ApiLF::EPar , EPar
  • Focus_Stereo_Enabled : EPar , Rx::ApiLF::EPar
  • Focus_Stereo_EyeSep : Rx::ApiLF::EPar , EPar
  • Focus_Stereo_Rot : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_Gamma : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_Radial : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_VirtDepthCollPlane : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_VirtDepthMax : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_VirtDepthMin : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_X : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_Y : EPar , Rx::ApiLF::EPar
  • FocusLeft : Rx::ApiLF::EImgID , EImgID
  • FocusOnSurface : Rx::ApiLF::EFeature , EFeature
  • FocusRight : Rx::ApiLF::EImgID , EImgID
  • FullScreen() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • GENERAL : Rx::ApiLF::EWarning , EWarning
  • GetFileTypeScript() : CLUViz::MT
  • GetIconHandle() : CLUViz::MT
  • GetKey()
: CLUViz::MT
, CLUViz::ST
  • GetLastError()
: CLUViz::MT
, CLUViz::ST
, CLUViz::Tool
  • GetScriptOutput() : CLUViz::ST
  • GetStdEnvPath()
: CLUViz::MT
, CLUViz::ST
  • GetTime() : Rx
  • GetTime64() : Rx
  • GetVarColor()
: CLUViz::MT
, CLUViz::ST
, CLUViz::MT
  • GetVarImageData()
: CLUViz::MT
, CLUViz::ST
  • GetVarImageProp()
: CLUViz::MT
, CLUViz::ST
  • GetVarNumber()
: CLUViz::MT
, CLUViz::ST
  • GetVarString()
: CLUViz::MT
, CLUViz::ST
  • GetVarTensor() : CLUViz::MT
  • GetVarTensorData()
: CLUViz::MT
, CLUViz::ST
  • GetVarTensorProp()
: CLUViz::MT
, CLUViz::ST
  • GetVersion()
: CLUViz::MT
, CLUViz::ST
  • Gl : Rx::ApiLF::EParGrp , EParGrp
  • GL_NOINTEROP : EError , Rx::ApiLF::EError
  • Gl_TexDepthColLeftID : Rx::ApiLF::EPar , EPar
  • Gl_TexDepthColRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexDepthLeftID : Rx::ApiLF::EPar , EPar
  • Gl_TexDepthRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusLeftID : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusLeftID2 : EPar , Rx::ApiLF::EPar
  • Gl_TexFocusRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusRightID2 : Rx::ApiLF::EPar , EPar
  • Gl_TexGridID : EPar , Rx::ApiLF::EPar
  • GL_TEXNOTSUPPORTED : Rx::ApiLF::EError , EError
  • Gl_TexRayDepthID : EPar , Rx::ApiLF::EPar
  • Gl_TexRayID : Rx::ApiLF::EPar , EPar
  • Gl_TexRayProcID : EPar , Rx::ApiLF::EPar
  • Gl_TexRayWhiteID : EPar , Rx::ApiLF::EPar
  • Grid : EParGrp , Rx::ApiLF::EParGrp
  • Grid_ResImgDiv : Rx::ApiLF::EPar , EPar


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • HideWindow() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • ID : Rx::Interop::Runtime28::EDataType , Rx::Interop::Runtime28::EPixelType , Rx::ApiLF::EWarning , EFeature , Rx::ApiLF::ERaySeqMode , ERadDistType , Rx::ApiLF::ERadDistType , ECameraTriggerMode , EPar , EError , Rx::ApiLF::ECameraTriggerMode , EParGrp , EImgID , Rx::ApiLF::EPar , EDepthImageType , ECalibGridMode , Rx::ApiLF::EError , EWarning , Rx::ApiLF::EParGrp , ERaySeqMode , Rx::ApiLF::EStatusSource , EStatusMessage , EStatusMsgGrp , EStatusSource , Rx::ApiLF::EImgID , Rx::ApiLF::EStatusMsgGrp , Rx::ApiLF::EStatusMessage , Rx::ApiLF::EFeature , Rx::ApiLF::EDepthImageType , Rx::ApiLF::ECalibGridMode
  • IMG_DITNOTSUPPORTED : EError , Rx::ApiLF::EError
  • IMG_NOTSUPPORTED : Rx::ApiLF::EError , EError
  • Info : Rx::ApiLF::EStatusMessage , EStatusMessage
  • InfoBox() : CLUViz::MT
  • Init() : CLUViz::Tool
  • InitTime() : Rx
  • INSTALL : EError , Rx::ApiLF::EError
  • Int : Rx::Interop::Runtime28::EDataType
  • INTERNAL : EError , Rx::ApiLF::EError
  • INVALID_POINTER : EError , Rx::ApiLF::EError
  • Inversion2 : Rx::ApiLF::ERadDistType , ERadDistType
  • IsRunning() : CLUViz::MT
  • IsViewValid() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LoadScript() : CLUViz::MT
  • Lum : Rx::Interop::Runtime28::EPixelType
  • LumA : Rx::Interop::Runtime28::EPixelType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MultiView : Rx::ApiLF::EFeature , EFeature


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • NONE : Rx::ApiLF::EError
  • None : EStatusMessage , EStatusMsgGrp , Rx::ApiLF::EStatusMessage , Rx::ApiLF::EStatusMsgGrp , ERaySeqMode , EImgID , EParGrp , EPar , ECameraTriggerMode , Rx::ApiLF::ERaySeqMode , Rx::ApiLF::EImgID , Rx::ApiLF::EParGrp , Rx::ApiLF::EPar , Rx::ApiLF::ECameraTriggerMode , EFeature , Rx::ApiLF::EFeature , Rx::Interop::Runtime28::EPixelType
  • NONE : EWarning , EError , Rx::ApiLF::EWarning


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • operator+() : Rx
  • OUTOFMEMORY : EError , Rx::ApiLF::EError
  • OUTOFRANGE : EError , Rx::ApiLF::EError


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • PAR_ACSREAD : Rx::ApiLF::EError , EError
  • PAR_ACSWRITE : EError , Rx::ApiLF::EError
  • PAR_EXIST : Rx::ApiLF::EError , EError
  • PAR_GRPEXIST : EError , Rx::ApiLF::EError
  • PAR_INVCONSTR : Rx::ApiLF::EError , EError
  • PAR_NOCONSTR : Rx::ApiLF::EError , EError
  • PAR_NOTAVAILABLE : Rx::ApiLF::EError , EError
  • PAR_NOTSUPPORTED : EError , Rx::ApiLF::EError
  • PAR_READ : Rx::ApiLF::EError , EError
  • PAR_TYPE : Rx::ApiLF::EError , EError
  • PAR_VALUE : Rx::ApiLF::EError , EError
  • PAR_WRITE : Rx::ApiLF::EError , EError
  • Pixel2Float() : Rx
  • Polynom4 : Rx::ApiLF::ERadDistType , ERadDistType
  • PosScale : Rx::ApiLF::ECalibGridMode , ECalibGridMode
  • PosScaleRot : Rx::ApiLF::ECalibGridMode , ECalibGridMode
  • PreProc : Rx::ApiLF::EParGrp , EParGrp
  • PreProc_Demosaic_B : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_G : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_R : EPar , Rx::ApiLF::EPar
  • PreProc_DenoiseNLM_BlendFactor : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_FilterDia : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_NoiseLevel : EPar , Rx::ApiLF::EPar
  • PreProc_Sharp1_BlurStdDev : Rx::ApiLF::EPar , EPar
  • PreProc_Sharp1_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_Sharp1_Factor : EPar , Rx::ApiLF::EPar
  • PreProc_Sharp1_OnlyCalc : EPar , Rx::ApiLF::EPar
  • PreProc_Std_Brightness : Rx::ApiLF::EPar , EPar
  • PreProc_Std_ContrastCenter : EPar , Rx::ApiLF::EPar
  • PreProc_Std_ContrastScale : EPar , Rx::ApiLF::EPar
  • PreProc_Std_Enable : Rx::ApiLF::EPar , EPar
  • Progress : Rx::ApiLF::EStatusMsgGrp , EStatusMsgGrp
  • Progress_Finished : EStatusMessage , Rx::ApiLF::EStatusMessage
  • Progress_Init : EStatusMessage , Rx::ApiLF::EStatusMessage
  • Progress_Step : EStatusMessage , Rx::ApiLF::EStatusMessage
  • Progress_Value : Rx::ApiLF::EStatusMessage , EStatusMessage


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • RawImage : Rx::ApiLF::EFeature , EFeature
  • Ray : Rx::ApiLF::EImgID , EParGrp , Rx::ApiLF::EParGrp , EImgID
  • Ray_ApplyFileSettings : EPar , Rx::ApiLF::EPar
  • Ray_ApplyWhiteImage : Rx::ApiLF::EPar , EPar
  • Ray_ConvBayer : Rx::ApiLF::EPar , EPar
  • Ray_DataType : Rx::ApiLF::EPar , EPar
  • Ray_Height : EPar , Rx::ApiLF::EPar
  • Ray_MLI_BaseReflectX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseReflectY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseRotation : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecXX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecXY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecYX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecYY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_Border : EPar , Rx::ApiLF::EPar
  • Ray_MLI_Diameter : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeCount : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeOffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeOffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeVirtDepthMax : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeVirtDepthMin : Rx::ApiLF::EPar , EPar
  • Ray_MLI_NeedWhiteImage : Rx::ApiLF::EPar , EPar
  • Ray_MLI_OffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_OffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_PixelSizeX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_PixelSizeY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistOffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistOffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar1 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar2 : EPar , Rx::ApiLF::EPar
  • Ray_MLI_RadDistPar3 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar4 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar5 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistParCnt : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistType : Rx::ApiLF::EPar , EPar
  • Ray_MLI_Rotation : Rx::ApiLF::EPar , EPar
  • Ray_MLI_SubGridBaseX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_SubGridBaseY : Rx::ApiLF::EPar , EPar
  • Ray_PixelType : Rx::ApiLF::EPar , EPar
  • Ray_Width : Rx::ApiLF::EPar , EPar
  • RayDepth : Rx::ApiLF::EImgID , EImgID
  • RayGrid : Rx::ApiLF::EImgID , EImgID
  • RayProc : Rx::ApiLF::EImgID , EImgID
  • RaySeq : Rx::ApiLF::EParGrp , EParGrp
  • RAYSEQ_ALREADY_BOUND : Rx::ApiLF::EError , EError
  • RaySeq_ApplyFileSettings : Rx::ApiLF::EPar , EPar
  • RaySeq_AutoStoreCamFrameCnt : Rx::ApiLF::EPar , EPar
  • RaySeq_AutoStoreCamFrames : Rx::ApiLF::EPar , EPar
  • RAYSEQ_AUTOWRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_BIND : Rx::ApiLF::EError , EError
  • RAYSEQ_CLOSE : Rx::ApiLF::EError , EError
  • RAYSEQ_COMPRESS : Rx::ApiLF::EError , EError
  • RAYSEQ_EOF : Rx::ApiLF::EError , EError
  • RAYSEQ_IMAGEFORMAT : Rx::ApiLF::EError , EError
  • RAYSEQ_INTERNAL : Rx::ApiLF::EError , EError
  • RAYSEQ_INVALID : Rx::ApiLF::EError , EError
  • RAYSEQ_INVALID_ID : Rx::ApiLF::EError , EError
  • RAYSEQ_NOREAD : Rx::ApiLF::EError , EError
  • RAYSEQ_NOT_BOUND : Rx::ApiLF::EError , EError
  • RAYSEQ_NOTOPEN : Rx::ApiLF::EError , EError
  • RAYSEQ_NOWRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_OPENREAD : EError , Rx::ApiLF::EError
  • RAYSEQ_OPENWRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_READ : Rx::ApiLF::EError , EError
  • RAYSEQ_SETFRAMEIDX : Rx::ApiLF::EError , EError
  • RAYSEQ_SOF : Rx::ApiLF::EError , EError
  • RAYSEQ_UNCOMPRESS : Rx::ApiLF::EError , EError
  • RAYSEQ_UNKOWNCOMP : Rx::ApiLF::EError , EError
  • RAYSEQ_UNSUPPIXTYPE : Rx::ApiLF::EError , EError
  • RAYSEQ_VERSION : Rx::ApiLF::EError , EError
  • RAYSEQ_WHITEIMAGE : Rx::ApiLF::EError , EError
  • RAYSEQ_WRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_WRITEINIT : Rx::ApiLF::EError , EError
  • RayWhite : Rx::ApiLF::EImgID , EImgID
  • Read : Rx::ApiLF::ERaySeqMode , ERaySeqMode
  • ReadImage() : CLUViz::Tool
  • Relative : Rx::ApiLF::EDepthImageType , EDepthImageType
  • ReleaseAll() : CLUViz::ST
  • ReleaseWindow() : CLUViz::ST
  • RemoveStatusMessageHandler() : Rx::ApiLF
  • RGB : Rx::Interop::Runtime28::EPixelType
  • RGBA : Rx::Interop::Runtime28::EPixelType
  • Run() : CLUVizST
  • RunMsg() : CLUVizST
  • RxAddStatusMessageHandler() : Rx::ApiLF
  • RxCalibGrid() : Rx::ApiLF
  • RxCamCalibCreate() : Rx::ApiLF
  • RxCamCalibDeleteLens() : Rx::ApiLF
  • RxCamCalibDeleteLensSetting() : Rx::ApiLF
  • RxCamCalibNewLens() : Rx::ApiLF
  • RxCamCalibNewLensSetting() : Rx::ApiLF
  • RxCamCalibStore() : Rx::ApiLF
  • RxCamCalibStoreWhiteImage() : Rx::ApiLF
  • RxCamCalibUpdate() : Rx::ApiLF
  • RxCamClose() : Rx::ApiLF
  • RxCamDoCapture() : Rx::ApiLF
  • RxCamDriverInit() : Rx::ApiLF
  • RxCamGetPar() : Rx::ApiLF
  • RxCamGetParRange() : Rx::ApiLF
  • RxCamOpen() : Rx::ApiLF
  • RxCamRegister() : Rx::ApiLF
  • RxCamSetPar() : Rx::ApiLF
  • RxCamStartCapture() : Rx::ApiLF
  • RxCamStopCapture() : Rx::ApiLF
  • RxCamSupPar() : Rx::ApiLF
  • RxCamSuspendCapture() : Rx::ApiLF
  • RxConvertImage() : Rx::ApiLF
  • RxCudaDeviceCount() : Rx::ApiLF
  • RxCudaDeviceMemInfo() : Rx::ApiLF
  • RxCudaDeviceProp() : Rx::ApiLF
  • RxCudaSelectDevice() : Rx::ApiLF
  • RxDepth() : Rx::ApiLF
  • RxDepthColorCode() : Rx::ApiLF
  • RxDepthEx() : Rx::ApiLF
  • RxDepthMap() : Rx::ApiLF
  • RxDongleGetID() : Rx::ApiLF
  • RxDongleReinitialize() : Rx::ApiLF
  • RxFinalize() : Rx::ApiLF
  • RxFocusOnPlane() : Rx::ApiLF
  • RxFocusOnPlaneEx() : Rx::ApiLF
  • RxFocusOnSurface() : Rx::ApiLF
  • RxFocusOnSurfaceEx() : Rx::ApiLF
  • RxGetImage() : Rx::ApiLF
  • RxGetImageDevicePointer() : Rx::ApiLF
  • RxGetImageFormat() : Rx::ApiLF
  • RxGetImageHistogram() : Rx::ApiLF
  • RxGetLastError() : Rx::ApiLF
  • RxGetLastErrorReport() : Rx::ApiLF
  • RxGetLastExecTime() : Rx::ApiLF
  • RxGetPar() : Rx::ApiLF
  • RxGetParName() : Rx::ApiLF
  • RxGetParRange() : Rx::ApiLF
  • RxGetRegistryString() : Rx::ApiLF
  • RxGetTime() : Rx::ApiLF
  • RxGetTime64() : Rx::ApiLF
  • RxGlGetVersion() : Rx::ApiLF
  • RxGlUpdateTex() : Rx::ApiLF
  • RxGrid() : Rx::ApiLF
  • RxHasFeature() : Rx::ApiLF
  • RxInit() : Rx::ApiLF
  • RxIsImageValid() : Rx::ApiLF
  • RxLoadPar() : Rx::ApiLF
  • RxLogConsoleAddMessage() : Rx::ApiLF
  • RxLogConsoleClose() : Rx::ApiLF
  • RxLogConsoleShow() : Rx::ApiLF
  • RxPreProcess() : Rx::ApiLF
  • RxRayBind() : Rx::ApiLF
  • RxRayCalibLoad() : Rx::ApiLF
  • RxRayCalibNew() : Rx::ApiLF
  • RxRayCalibSave() : Rx::ApiLF
  • RxRayCalibXmlGet() : Rx::ApiLF
  • RxRayCalibXmlSet() : Rx::ApiLF
  • RxRayDelete() : Rx::ApiLF
  • RxRayGetFormat() : Rx::ApiLF
  • RxRayGetFormatEx() : Rx::ApiLF
  • RxRayGetMetaData() : Rx::ApiLF
  • RxRayGetRaw() : Rx::ApiLF
  • RxRayLoad() : Rx::ApiLF
  • RxRayNew() : Rx::ApiLF
  • RxRaySave() : Rx::ApiLF
  • RxRaySeqBind() : Rx::ApiLF
  • RxRaySeqClose() : Rx::ApiLF
  • RxRaySeqGetFileSize() : Rx::ApiLF
  • RxRaySeqGetFrameBufferUsedCount() : Rx::ApiLF
  • RxRaySeqGetFrameCount() : Rx::ApiLF
  • RxRaySeqGetFrameIndex() : Rx::ApiLF
  • RxRaySeqMoveFrameIndex() : Rx::ApiLF
  • RxRaySeqOpen() : Rx::ApiLF
  • RxRaySeqRead() : Rx::ApiLF
  • RxRaySeqSetFrameIndex() : Rx::ApiLF
  • RxRaySeqUnbind() : Rx::ApiLF
  • RxRaySeqWrite() : Rx::ApiLF
  • RxRaySetMetaData() : Rx::ApiLF
  • RxRemoveStatusMessageHandler() : Rx::ApiLF
  • RxResizeImage() : Rx::ApiLF
  • RxSaveDepthPointList() : Rx::ApiLF
  • RxSavePar() : Rx::ApiLF
  • RxSetImage() : Rx::ApiLF
  • RxSetPar() : Rx::ApiLF
  • RxSleep() : Rx::ApiLF
  • RxStereoDepth() : Rx::ApiLF
  • RxStereoDepthEx() : Rx::ApiLF
  • RxStereoOnPlane() : Rx::ApiLF
  • RxStereoOnPlaneEx() : Rx::ApiLF
  • RxStereoOnSurface() : Rx::ApiLF
  • RxStereoOnSurfaceEx() : Rx::ApiLF
  • RxTransformDepthValue() : Rx::ApiLF
  • RxUpdateImage() : Rx::ApiLF


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • Save : Rx::ApiLF::EFeature , EFeature
  • SaveView() : CLUViz::ST
  • SetScript() : CLUViz::MT
  • SetScriptPath()
: CLUViz::MT
, CLUViz::ST
  • SetTimeout() : CLUViz::MT
  • SetVarColor()
: CLUViz::MT
, CLUViz::ST
  • SetVarImage()
: CLUViz::MT
, CLUViz::ST
  • SetVarNumber()
: CLUViz::ST
, CLUViz::MT
  • SetVarObject() : CLUViz::ST
  • SetVarString()
: CLUViz::MT
, CLUViz::ST
  • SetVarTensor()
: CLUViz::MT
, CLUViz::ST
  • SetWindowPosSize() : CLUViz::MT
  • Short : Rx::Interop::Runtime28::EDataType
  • ShowWindow() : CLUViz::MT
  • Sleep() : Rx
  • Software_SnapShot : Rx::ApiLF::ECameraTriggerMode , ECameraTriggerMode
  • Standard : Rx::ApiLF::EDepthImageType , EDepthImageType , EFeature , Rx::ApiLF::EFeature
  • Start() : CLUViz::MT , CLUVizST , CLUViz::ST
  • StartAgain() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • Text : Rx::ApiLF::EStatusMsgGrp , EStatusMsgGrp
  • TFuncStatusMessageCallback : Rx::ApiLF
  • TPixel_Bay_BG_c : Rx
  • TPixel_Bay_BG_d : Rx
  • TPixel_Bay_BG_f : Rx
  • TPixel_Bay_BG_i : Rx
  • TPixel_Bay_BG_s : Rx
  • TPixel_Bay_BG_uc : Rx
  • TPixel_Bay_BG_ui : Rx
  • TPixel_Bay_BG_us : Rx
  • TPixel_Bay_GB_c : Rx
  • TPixel_Bay_GB_d : Rx
  • TPixel_Bay_GB_f : Rx
  • TPixel_Bay_GB_i : Rx
  • TPixel_Bay_GB_s : Rx
  • TPixel_Bay_GB_uc : Rx
  • TPixel_Bay_GB_ui : Rx
  • TPixel_Bay_GB_us : Rx
  • TPixel_Bay_GR_c : Rx
  • TPixel_Bay_GR_d : Rx
  • TPixel_Bay_GR_f : Rx
  • TPixel_Bay_GR_i : Rx
  • TPixel_Bay_GR_s : Rx
  • TPixel_Bay_GR_uc : Rx
  • TPixel_Bay_GR_ui : Rx
  • TPixel_Bay_GR_us : Rx
  • TPixel_Bay_RG_c : Rx
  • TPixel_Bay_RG_d : Rx
  • TPixel_Bay_RG_f : Rx
  • TPixel_Bay_RG_i : Rx
  • TPixel_Bay_RG_s : Rx
  • TPixel_Bay_RG_uc : Rx
  • TPixel_Bay_RG_ui : Rx
  • TPixel_Bay_RG_us : Rx
  • TPixel_BGR_c : Rx
  • TPixel_BGR_d : Rx
  • TPixel_BGR_f : Rx
  • TPixel_BGR_i : Rx
  • TPixel_BGR_s : Rx
  • TPixel_BGR_uc : Rx
  • TPixel_BGR_ui : Rx
  • TPixel_BGR_us : Rx
  • TPixel_BGRA_c : Rx
  • TPixel_BGRA_d : Rx
  • TPixel_BGRA_f : Rx
  • TPixel_BGRA_i : Rx
  • TPixel_BGRA_s : Rx
  • TPixel_BGRA_uc : Rx
  • TPixel_BGRA_ui : Rx
  • TPixel_BGRA_us : Rx
  • TPixel_L_c : Rx
  • TPixel_L_d : Rx
  • TPixel_L_f : Rx
  • TPixel_L_i : Rx
  • TPixel_L_s : Rx
  • TPixel_L_uc : Rx
  • TPixel_L_ui : Rx
  • TPixel_L_us : Rx
  • TPixel_LA_c : Rx
  • TPixel_LA_d : Rx
  • TPixel_LA_f : Rx
  • TPixel_LA_i : Rx
  • TPixel_LA_s : Rx
  • TPixel_LA_uc : Rx
  • TPixel_LA_ui : Rx
  • TPixel_LA_us : Rx
  • TPixel_RGB_c : Rx
  • TPixel_RGB_d : Rx
  • TPixel_RGB_f : Rx
  • TPixel_RGB_i : Rx
  • TPixel_RGB_s : Rx
  • TPixel_RGB_uc : Rx
  • TPixel_RGB_ui : Rx
  • TPixel_RGB_us : Rx
  • TPixel_RGBA_c : Rx
  • TPixel_RGBA_d : Rx
  • TPixel_RGBA_f : Rx
  • TPixel_RGBA_i : Rx
  • TPixel_RGBA_s : Rx
  • TPixel_RGBA_uc : Rx
  • TPixel_RGBA_ui : Rx
  • TPixel_RGBA_us : Rx


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • UByte : Rx::Interop::Runtime28::EDataType
  • UInt : Rx::Interop::Runtime28::EDataType
  • Unknown : EStatusSource , Rx::ApiLF::EStatusSource
  • UShort : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • ViewSetImage() : CLUViz::Tool
  • Virtual : Rx::ApiLF::EDepthImageType , EDepthImageType
  • Void : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • WaitForEnd() : CLUViz::MT
  • Warning : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Write : Rx::ApiLF::ERaySeqMode , ERaySeqMode
  • WriteImage() : CLUViz::Tool


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- _ -

  • _Start() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- a -

  • AddStatusMessageHandler() : Rx::ApiLF


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- c -

  • CheckFeature() : CLUViz
  • Create() : CLUViz::MT
  • CreateEx() : CLUVizST , CLUViz
  • CreateEx1() : CLUViz::MT
  • CreateEx2() : CLUViz::MT
  • CreateViewImage() : CLUViz::Tool


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- d -

  • Destroy() : CLUViz::MT
  • DestroyAll() : CLUViz::MT
  • DestroyView() : CLUViz::Tool


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- e -

  • EmbedWindow() : CLUViz::ST
  • EnableBorder() : CLUVizST
  • EnableUserEnd() : CLUViz::MT
  • EnableVisualization() : CLUViz::ST
  • End() : CLUViz::MT , CLUVizST , CLUViz::ST
  • EW_ActiveMouseMove() : CLUViz::ST
  • EW_Display() : CLUViz::ST
  • EW_ExecUser() : CLUViz::ST
  • EW_IdleFunc() : CLUViz::ST
  • EW_Keyboard() : CLUViz::ST
  • EW_LoadScript() : CLUViz::ST
  • EW_LockVis() : CLUViz::ST
  • EW_MakeCurrentSRC() : CLUViz::ST
  • EW_Mouse() : CLUViz::ST
  • EW_PassiveMouseMove() : CLUViz::ST
  • EW_Reshape() : CLUViz::ST
  • EW_SetKeyModifierStates() : CLUViz::ST
  • EW_SetScript() : CLUViz::ST
  • ExecUser() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- f -

  • Finalize() : CLUViz::Tool
  • Float2Pixel() : Rx
  • FullScreen() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- g -

  • GetFileTypeScript() : CLUViz::MT
  • GetIconHandle() : CLUViz::MT
  • GetKey()
: CLUViz::ST
, CLUViz::MT
  • GetLastError()
: CLUViz::Tool
, CLUViz::MT
, CLUViz::ST
  • GetScriptOutput() : CLUViz::ST
  • GetStdEnvPath()
: CLUViz::MT
, CLUViz::ST
  • GetTime() : Rx
  • GetTime64() : Rx
  • GetVarColor()
: CLUViz::ST
, CLUViz::MT
, CLUViz::ST
  • GetVarImageData()
: CLUViz::MT
, CLUViz::ST
  • GetVarImageProp()
: CLUViz::MT
, CLUViz::ST
  • GetVarNumber()
: CLUViz::MT
, CLUViz::ST
  • GetVarString()
: CLUViz::ST
, CLUViz::MT
  • GetVarTensor() : CLUViz::MT
  • GetVarTensorData()
: CLUViz::ST
, CLUViz::MT
  • GetVarTensorProp()
: CLUViz::ST
, CLUViz::MT
  • GetVersion()
: CLUViz::MT
, CLUViz::ST


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- h -

  • HideWindow() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- i -

  • InfoBox() : CLUViz::MT
  • Init() : CLUViz::Tool
  • InitTime() : Rx
  • IsRunning() : CLUViz::MT
  • IsViewValid() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- l -

  • LoadScript() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- o -

  • operator+() : Rx


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- p -

  • Pixel2Float() : Rx


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- r -

  • ReadImage() : CLUViz::Tool
  • ReleaseAll() : CLUViz::ST
  • ReleaseWindow() : CLUViz::ST
  • RemoveStatusMessageHandler() : Rx::ApiLF
  • Run() : CLUVizST
  • RunMsg() : CLUVizST
  • RxAddStatusMessageHandler() : Rx::ApiLF
  • RxCalibGrid() : Rx::ApiLF
  • RxCamCalibCreate() : Rx::ApiLF
  • RxCamCalibDeleteLens() : Rx::ApiLF
  • RxCamCalibDeleteLensSetting() : Rx::ApiLF
  • RxCamCalibNewLens() : Rx::ApiLF
  • RxCamCalibNewLensSetting() : Rx::ApiLF
  • RxCamCalibStore() : Rx::ApiLF
  • RxCamCalibStoreWhiteImage() : Rx::ApiLF
  • RxCamCalibUpdate() : Rx::ApiLF
  • RxCamClose() : Rx::ApiLF
  • RxCamDoCapture() : Rx::ApiLF
  • RxCamDriverInit() : Rx::ApiLF
  • RxCamGetPar() : Rx::ApiLF
  • RxCamGetParRange() : Rx::ApiLF
  • RxCamOpen() : Rx::ApiLF
  • RxCamRegister() : Rx::ApiLF
  • RxCamSetPar() : Rx::ApiLF
  • RxCamStartCapture() : Rx::ApiLF
  • RxCamStopCapture() : Rx::ApiLF
  • RxCamSupPar() : Rx::ApiLF
  • RxCamSuspendCapture() : Rx::ApiLF
  • RxConvertImage() : Rx::ApiLF
  • RxCudaDeviceCount() : Rx::ApiLF
  • RxCudaDeviceMemInfo() : Rx::ApiLF
  • RxCudaDeviceProp() : Rx::ApiLF
  • RxCudaSelectDevice() : Rx::ApiLF
  • RxDepth() : Rx::ApiLF
  • RxDepthColorCode() : Rx::ApiLF
  • RxDepthEx() : Rx::ApiLF
  • RxDepthMap() : Rx::ApiLF
  • RxDongleGetID() : Rx::ApiLF
  • RxDongleReinitialize() : Rx::ApiLF
  • RxFinalize() : Rx::ApiLF
  • RxFocusOnPlane() : Rx::ApiLF
  • RxFocusOnPlaneEx() : Rx::ApiLF
  • RxFocusOnSurface() : Rx::ApiLF
  • RxFocusOnSurfaceEx() : Rx::ApiLF
  • RxGetImage() : Rx::ApiLF
  • RxGetImageDevicePointer() : Rx::ApiLF
  • RxGetImageFormat() : Rx::ApiLF
  • RxGetImageHistogram() : Rx::ApiLF
  • RxGetLastError() : Rx::ApiLF
  • RxGetLastErrorReport() : Rx::ApiLF
  • RxGetLastExecTime() : Rx::ApiLF
  • RxGetPar() : Rx::ApiLF
  • RxGetParName() : Rx::ApiLF
  • RxGetParRange() : Rx::ApiLF
  • RxGetRegistryString() : Rx::ApiLF
  • RxGetTime() : Rx::ApiLF
  • RxGetTime64() : Rx::ApiLF
  • RxGlGetVersion() : Rx::ApiLF
  • RxGlUpdateTex() : Rx::ApiLF
  • RxGrid() : Rx::ApiLF
  • RxHasFeature() : Rx::ApiLF
  • RxInit() : Rx::ApiLF
  • RxIsImageValid() : Rx::ApiLF
  • RxLoadPar() : Rx::ApiLF
  • RxLogConsoleAddMessage() : Rx::ApiLF
  • RxLogConsoleClose() : Rx::ApiLF
  • RxLogConsoleShow() : Rx::ApiLF
  • RxPreProcess() : Rx::ApiLF
  • RxRayBind() : Rx::ApiLF
  • RxRayCalibLoad() : Rx::ApiLF
  • RxRayCalibNew() : Rx::ApiLF
  • RxRayCalibSave() : Rx::ApiLF
  • RxRayCalibXmlGet() : Rx::ApiLF
  • RxRayCalibXmlSet() : Rx::ApiLF
  • RxRayDelete() : Rx::ApiLF
  • RxRayGetFormat() : Rx::ApiLF
  • RxRayGetFormatEx() : Rx::ApiLF
  • RxRayGetMetaData() : Rx::ApiLF
  • RxRayGetRaw() : Rx::ApiLF
  • RxRayLoad() : Rx::ApiLF
  • RxRayNew() : Rx::ApiLF
  • RxRaySave() : Rx::ApiLF
  • RxRaySeqBind() : Rx::ApiLF
  • RxRaySeqClose() : Rx::ApiLF
  • RxRaySeqGetFileSize() : Rx::ApiLF
  • RxRaySeqGetFrameBufferUsedCount() : Rx::ApiLF
  • RxRaySeqGetFrameCount() : Rx::ApiLF
  • RxRaySeqGetFrameIndex() : Rx::ApiLF
  • RxRaySeqMoveFrameIndex() : Rx::ApiLF
  • RxRaySeqOpen() : Rx::ApiLF
  • RxRaySeqRead() : Rx::ApiLF
  • RxRaySeqSetFrameIndex() : Rx::ApiLF
  • RxRaySeqUnbind() : Rx::ApiLF
  • RxRaySeqWrite() : Rx::ApiLF
  • RxRaySetMetaData() : Rx::ApiLF
  • RxRemoveStatusMessageHandler() : Rx::ApiLF
  • RxResizeImage() : Rx::ApiLF
  • RxSaveDepthPointList() : Rx::ApiLF
  • RxSavePar() : Rx::ApiLF
  • RxSetImage() : Rx::ApiLF
  • RxSetPar() : Rx::ApiLF
  • RxSleep() : Rx::ApiLF
  • RxStereoDepth() : Rx::ApiLF
  • RxStereoDepthEx() : Rx::ApiLF
  • RxStereoOnPlane() : Rx::ApiLF
  • RxStereoOnPlaneEx() : Rx::ApiLF
  • RxStereoOnSurface() : Rx::ApiLF
  • RxStereoOnSurfaceEx() : Rx::ApiLF
  • RxTransformDepthValue() : Rx::ApiLF
  • RxUpdateImage() : Rx::ApiLF


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- s -

  • SaveView() : CLUViz::ST
  • SetScript() : CLUViz::MT
  • SetScriptPath()
: CLUViz::ST
, CLUViz::MT
  • SetTimeout() : CLUViz::MT
  • SetVarColor()
: CLUViz::ST
, CLUViz::MT
  • SetVarImage()
: CLUViz::MT
, CLUViz::ST
  • SetVarNumber()
: CLUViz::MT
, CLUViz::ST
  • SetVarObject() : CLUViz::ST
  • SetVarString()
: CLUViz::MT
, CLUViz::ST
  • SetVarTensor()
: CLUViz::MT
, CLUViz::ST
  • SetWindowPosSize() : CLUViz::MT
  • ShowWindow() : CLUViz::MT
  • Sleep() : Rx
  • Start()
: CLUViz::ST
, CLUViz::MT
, CLUVizST
  • StartAgain() : CLUViz::MT


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- v -

  • ViewSetImage() : CLUViz::Tool


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • o
  • p
  • r
  • s
  • v
  • w

- w -

  • WaitForEnd() : CLUViz::MT
  • WriteImage() : CLUViz::Tool


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • t

- t -

  • TFuncStatusMessageCallback : Rx::ApiLF
  • TPixel_Bay_BG_c : Rx
  • TPixel_Bay_BG_d : Rx
  • TPixel_Bay_BG_f : Rx
  • TPixel_Bay_BG_i : Rx
  • TPixel_Bay_BG_s : Rx
  • TPixel_Bay_BG_uc : Rx
  • TPixel_Bay_BG_ui : Rx
  • TPixel_Bay_BG_us : Rx
  • TPixel_Bay_GB_c : Rx
  • TPixel_Bay_GB_d : Rx
  • TPixel_Bay_GB_f : Rx
  • TPixel_Bay_GB_i : Rx
  • TPixel_Bay_GB_s : Rx
  • TPixel_Bay_GB_uc : Rx
  • TPixel_Bay_GB_ui : Rx
  • TPixel_Bay_GB_us : Rx
  • TPixel_Bay_GR_c : Rx
  • TPixel_Bay_GR_d : Rx
  • TPixel_Bay_GR_f : Rx
  • TPixel_Bay_GR_i : Rx
  • TPixel_Bay_GR_s : Rx
  • TPixel_Bay_GR_uc : Rx
  • TPixel_Bay_GR_ui : Rx
  • TPixel_Bay_GR_us : Rx
  • TPixel_Bay_RG_c : Rx
  • TPixel_Bay_RG_d : Rx
  • TPixel_Bay_RG_f : Rx
  • TPixel_Bay_RG_i : Rx
  • TPixel_Bay_RG_s : Rx
  • TPixel_Bay_RG_uc : Rx
  • TPixel_Bay_RG_ui : Rx
  • TPixel_Bay_RG_us : Rx
  • TPixel_BGR_c : Rx
  • TPixel_BGR_d : Rx
  • TPixel_BGR_f : Rx
  • TPixel_BGR_i : Rx
  • TPixel_BGR_s : Rx
  • TPixel_BGR_uc : Rx
  • TPixel_BGR_ui : Rx
  • TPixel_BGR_us : Rx
  • TPixel_BGRA_c : Rx
  • TPixel_BGRA_d : Rx
  • TPixel_BGRA_f : Rx
  • TPixel_BGRA_i : Rx
  • TPixel_BGRA_s : Rx
  • TPixel_BGRA_uc : Rx
  • TPixel_BGRA_ui : Rx
  • TPixel_BGRA_us : Rx
  • TPixel_L_c : Rx
  • TPixel_L_d : Rx
  • TPixel_L_f : Rx
  • TPixel_L_i : Rx
  • TPixel_L_s : Rx
  • TPixel_L_uc : Rx
  • TPixel_L_ui : Rx
  • TPixel_L_us : Rx
  • TPixel_LA_c : Rx
  • TPixel_LA_d : Rx
  • TPixel_LA_f : Rx
  • TPixel_LA_i : Rx
  • TPixel_LA_s : Rx
  • TPixel_LA_uc : Rx
  • TPixel_LA_ui : Rx
  • TPixel_LA_us : Rx
  • TPixel_RGB_c : Rx
  • TPixel_RGB_d : Rx
  • TPixel_RGB_f : Rx
  • TPixel_RGB_i : Rx
  • TPixel_RGB_s : Rx
  • TPixel_RGB_uc : Rx
  • TPixel_RGB_ui : Rx
  • TPixel_RGB_us : Rx
  • TPixel_RGBA_c : Rx
  • TPixel_RGBA_d : Rx
  • TPixel_RGBA_f : Rx
  • TPixel_RGBA_i : Rx
  • TPixel_RGBA_s : Rx
  • TPixel_RGBA_uc : Rx
  • TPixel_RGBA_ui : Rx
  • TPixel_RGBA_us : Rx


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • ID : Rx::Interop::Runtime28::EDataType , EStatusMessage , EStatusMsgGrp , EStatusSource , Rx::ApiLF::EStatusMessage , Rx::ApiLF::EStatusMsgGrp , Rx::ApiLF::EStatusSource , ERaySeqMode , ECalibGridMode , EDepthImageType , EImgID , EParGrp , EPar , ECameraTriggerMode , ERadDistType , Rx::ApiLF::ERaySeqMode , Rx::ApiLF::ECalibGridMode , Rx::ApiLF::EDepthImageType , Rx::ApiLF::EImgID , Rx::ApiLF::EParGrp , Rx::ApiLF::EPar , Rx::ApiLF::ECameraTriggerMode , Rx::ApiLF::ERadDistType , EFeature , Rx::ApiLF::EFeature , EWarning , EError , Rx::ApiLF::EWarning , Rx::ApiLF::EError , Rx::Interop::Runtime28::EPixelType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • Affine : Rx::ApiLF::EDepthImageType , EDepthImageType
  • API : EStatusSource , Rx::ApiLF::EStatusSource
  • API_DONGLE : Rx::ApiLF::EError , EError
  • API_FEATURE : EError , Rx::ApiLF::EError
  • API_INIT : Rx::ApiLF::EError , EError
  • API_INITAGAIN : Rx::ApiLF::EError , EError
  • API_INSTPATH : Rx::ApiLF::EError , EError
  • API_INVALID_GLTEX : EError , Rx::ApiLF::EError
  • API_INVALID_IMAGE : Rx::ApiLF::EError , EError
  • API_INVALID_IMGID : Rx::ApiLF::EError , EError
  • API_INVALID_IMGTYPE : Rx::ApiLF::EError , EError
  • API_INVALID_VALUE : Rx::ApiLF::EError , EError
  • API_LFI_BIND : Rx::ApiLF::EError , EError
  • API_LFI_BOUND : Rx::ApiLF::EError , EError
  • API_LOADFILE : Rx::ApiLF::EError , EError
  • API_NOINIT : EError , Rx::ApiLF::EError
  • API_NOLFIBOUND : Rx::ApiLF::EError , EError
  • API_SAVEFILE : EError , Rx::ApiLF::EError
  • API_UNKNOWN : Rx::ApiLF::EError , EError
  • API_VERSION : Rx::ApiLF::EError , EError
  • App : EStatusSource , Rx::ApiLF::EStatusSource
  • Assertion : EStatusMessage , Rx::ApiLF::EStatusMessage


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BayerBG : Rx::Interop::Runtime28::EPixelType
  • BayerGB : Rx::Interop::Runtime28::EPixelType
  • BayerGR : Rx::Interop::Runtime28::EPixelType
  • BayerRG : Rx::Interop::Runtime28::EPixelType
  • BGR : Rx::Interop::Runtime28::EPixelType
  • BGRA : Rx::Interop::Runtime28::EPixelType
  • Byte : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • Calculate3D : Rx::ApiLF::EFeature , EFeature
  • Calib : EParGrp , Rx::ApiLF::EParGrp
  • Calib_Grid_Mode : Rx::ApiLF::EPar , EPar
  • Calibrate : EFeature , Rx::ApiLF::EFeature
  • Cam_ActualFramesPerSecond : Rx::ApiLF::EPar , EPar
  • Cam_AutoUpdateGlTex : Rx::ApiLF::EPar , EPar
  • Cam_Count : Rx::ApiLF::EPar , EPar
  • Cam_Exposure : EPar , Rx::ApiLF::EPar
  • Cam_Focus : Rx::ApiLF::EPar , EPar
  • Cam_FramesPerSecond : Rx::ApiLF::EPar , EPar
  • Cam_Func_CalibMainLens : Rx::ApiLF::EPar , EPar
  • Cam_Gain : Rx::ApiLF::EPar , EPar
  • Cam_GainBlue : Rx::ApiLF::EPar , EPar
  • Cam_GainGreen : Rx::ApiLF::EPar , EPar
  • Cam_GainRed : Rx::ApiLF::EPar , EPar
  • Cam_Height : EPar , Rx::ApiLF::EPar
  • Cam_ID : Rx::ApiLF::EPar , EPar
  • Cam_Iris : Rx::ApiLF::EPar , EPar
  • Cam_IsBayer : Rx::ApiLF::EPar , EPar
  • Cam_IsCapturing : Rx::ApiLF::EPar , EPar
  • Cam_IsColor : Rx::ApiLF::EPar , EPar
  • Cam_IsOpen : Rx::ApiLF::EPar , EPar
  • Cam_Name : Rx::ApiLF::EPar , EPar
  • Cam_OffsetX : Rx::ApiLF::EPar , EPar
  • Cam_OffsetY : Rx::ApiLF::EPar , EPar
  • Cam_PIVMode : Rx::ApiLF::EPar , EPar
  • Cam_TapBalance : Rx::ApiLF::EPar , EPar
  • Cam_TapBalanceMode : Rx::ApiLF::EPar , EPar
  • Cam_Temperature : Rx::ApiLF::EPar , EPar
  • Cam_TriggerMode : Rx::ApiLF::EPar , EPar
  • Cam_Type : Rx::ApiLF::EPar , EPar
  • Cam_Width : EPar , Rx::ApiLF::EPar
  • CamCal : Rx::ApiLF::EParGrp , EParGrp
  • CAMCAL_INVLENSIDX : Rx::ApiLF::EError , EError
  • CAMCAL_INVLENSSETIDX : Rx::ApiLF::EError , EError
  • CamCal_LensCnt : Rx::ApiLF::EPar , EPar
  • CamCal_LensID : Rx::ApiLF::EPar , EPar
  • CamCal_LensIdx : Rx::ApiLF::EPar , EPar
  • CamCal_LensName : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetCnt : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetFocus : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetFStop : Rx::ApiLF::EPar , EPar
  • CamCal_LensSetIdx : Rx::ApiLF::EPar , EPar
  • CamCal_MainLensFocus : Rx::ApiLF::EPar , EPar
  • CamCal_MainLensIris : Rx::ApiLF::EPar , EPar
  • CAMCAL_NOLENS : Rx::ApiLF::EError , EError
  • CAMCAL_NOLENSSET : Rx::ApiLF::EError , EError
  • CamCap : Rx::ApiLF::EParGrp , EParGrp
  • CamCap_AutoExposure_Active : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_Enabled : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_MaxValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoExposure_MinValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_Active : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_Enabled : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_MaxValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoGain_MinValue : Rx::ApiLF::EPar , EPar
  • CamCap_AutoLum_MaxSaturatedPixelPercentage : Rx::ApiLF::EPar , EPar
  • CamCap_Frames_Lost : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Extern : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Single : Rx::ApiLF::EPar , EPar
  • CamCap_Timeout_Video : Rx::ApiLF::EPar , EPar
  • CAMDRV_INIT : Rx::ApiLF::EError , EError
  • CAMDRV_INITAGAIN : Rx::ApiLF::EError , EError
  • CAMDRV_INVCAMID : EError , Rx::ApiLF::EError
  • CAMDRV_NOINIT : Rx::ApiLF::EError , EError
  • Camera : Rx::ApiLF::EParGrp , EParGrp , Rx::ApiLF::EStatusSource , EStatusSource
  • CAMERA_ACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CALFILEEXIST : Rx::ApiLF::EError , EError
  • CAMERA_CAPACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CAPNOTACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_EXCEPTION : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_INTERNAL_API : Rx::ApiLF::EError , EError
  • CAMERA_CAPTURE_NOIMAGE : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CAPTURE_STOPPED : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CAPTURE_STOPPED_UNEXPECTED : Rx::ApiLF::EError , EError
  • CAMERA_CLOSE : Rx::ApiLF::EError , EError
  • CAMERA_CORRUPTDB : Rx::ApiLF::EWarning , EWarning
  • CAMERA_CREATECALFILE : EError , Rx::ApiLF::EError
  • Camera_FreeRun : Rx::ApiLF::ECameraTriggerMode , ECameraTriggerMode
  • CAMERA_INVCALFILE : Rx::ApiLF::EError , EError
  • CAMERA_INVWHITETYPE : Rx::ApiLF::EWarning , EWarning
  • CAMERA_LENSDEL : EError , Rx::ApiLF::EError
  • CAMERA_LENSDEL_LAST_LENS : Rx::ApiLF::EError , EError
  • CAMERA_LENSIDEXIST : EError , Rx::ApiLF::EError
  • CAMERA_LENSNEW : Rx::ApiLF::EError , EError
  • CAMERA_LENSSETDEL : EError , Rx::ApiLF::EError
  • CAMERA_LENSSETEXIST : Rx::ApiLF::EError , EError
  • CAMERA_LENSSETNEW : Rx::ApiLF::EError , EError
  • CAMERA_NOCALFILE : Rx::ApiLF::EError , EError
  • CAMERA_NOIMGWHITE : EError , Rx::ApiLF::EError
  • CAMERA_NOTACTIVE : Rx::ApiLF::EError , EError
  • CAMERA_OPEN : EError , Rx::ApiLF::EError
  • CAMERA_STARTCAP : Rx::ApiLF::EError , EError
  • CAMERA_STOPCAP : EError , Rx::ApiLF::EError
  • CAMERA_STORECALFILE : Rx::ApiLF::EError , EError
  • CAMERA_STOREIMGWHITE : Rx::ApiLF::EError , EError
  • CAMERA_SUSPENDCAP : Rx::ApiLF::EError , EError
  • CAMERA_TIMEOUT : Rx::ApiLF::EError , EError
  • CAMERA_TRIGGERMODE_NOT_AVAILABLE : EError , Rx::ApiLF::EError
  • CAMERA_TYPE_MISMATCH : Rx::ApiLF::EWarning , EWarning
  • CAMERA_UPDATECALIB : EError , Rx::ApiLF::EError
  • CameraDriver : Rx::ApiLF::EStatusSource , EStatusSource
  • Compress_Zip : ERaySeqMode , Rx::ApiLF::ERaySeqMode
  • COMPUTE : Rx::ApiLF::EError , EError
  • Compute : Rx::ApiLF::EStatusSource , EStatusSource
  • Constant : Rx::ApiLF::ERadDistType , ERadDistType
  • Count : EDepthImageType , Rx::ApiLF::EDepthImageType , Rx::ApiLF::ECalibGridMode , ECalibGridMode
  • Cuda : Rx::ApiLF::EParGrp , EParGrp
  • CUDA_ALGO : EError , Rx::ApiLF::EError
  • CUDA_CAPA : EError , Rx::ApiLF::EError
  • Cuda_CapaMajor : EPar , Rx::ApiLF::EPar
  • Cuda_CapaMinor : EPar , Rx::ApiLF::EPar
  • Cuda_ComputeMode : Rx::ApiLF::EPar , EPar
  • Cuda_ConcurrentKernels : Rx::ApiLF::EPar , EPar
  • Cuda_DeviceID : Rx::ApiLF::EPar , EPar
  • Cuda_DeviceName : Rx::ApiLF::EPar , EPar
  • Cuda_DeviceOverlap : EPar , Rx::ApiLF::EPar
  • CUDA_INIT : EError , Rx::ApiLF::EError
  • CUDA_INITAGAIN : Rx::ApiLF::EError , EError
  • CUDA_INVDEVID : EError , Rx::ApiLF::EError
  • CUDA_MAX : Rx::ApiLF::EError , EError
  • Cuda_MaxTex2DArraySizeX : EPar , Rx::ApiLF::EPar
  • Cuda_MaxTex2DArraySizeY : EPar , Rx::ApiLF::EPar
  • Cuda_MaxTex2DSizeX : Rx::ApiLF::EPar , EPar
  • Cuda_MaxTex2DSizeY : EPar , Rx::ApiLF::EPar
  • Cuda_MaxThreadsPerBlock : EPar , Rx::ApiLF::EPar
  • Cuda_MemPitch : Rx::ApiLF::EPar , EPar
  • CUDA_MIN : EError , Rx::ApiLF::EError
  • Cuda_MultiProcessorCount : EPar , Rx::ApiLF::EPar
  • CUDA_NODEVICE : EError , Rx::ApiLF::EError
  • CUDA_NOINIT : EError , Rx::ApiLF::EError
  • Cuda_RegsPerBlock : EPar , Rx::ApiLF::EPar
  • Cuda_TCCDriver : EPar , Rx::ApiLF::EPar
  • Cuda_TotalConstMem : Rx::ApiLF::EPar , EPar
  • Cuda_TotalGlobalMem : Rx::ApiLF::EPar , EPar
  • Cuda_VersionDriver : EPar , Rx::ApiLF::EPar
  • Cuda_VersionRuntime : Rx::ApiLF::EPar , EPar
  • Cuda_WarpSize : EPar , Rx::ApiLF::EPar


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • Debug : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Depth : Rx::ApiLF::EImgID , EParGrp , Rx::ApiLF::EParGrp , EImgID
  • Depth_Affine_FocalLength : EPar , Rx::ApiLF::EPar
  • Depth_Affine_Offset : Rx::ApiLF::EPar , EPar
  • Depth_Algo : Rx::ApiLF::EPar , EPar
  • Depth_DefaultValue : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_Enabled : EPar , Rx::ApiLF::EPar
  • Depth_Fill_Bilateral_FilterRad : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_SigmaR : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Bilateral_SigmaS : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Complete : Rx::ApiLF::EPar , EPar
  • Depth_Fill_Enabled : Rx::ApiLF::EPar , EPar
  • Depth_Fill_IterCnt : Rx::ApiLF::EPar , EPar
  • Depth_Fill_IterSize : Rx::ApiLF::EPar , EPar
  • Depth_Fill_MeanRad : EPar , Rx::ApiLF::EPar
  • Depth_Fill_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_BlendFactor : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_Enabled : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_FilterDia : Rx::ApiLF::EPar , EPar
  • Depth_Fill_NLM_NoiseLevel : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MeanMaxBlackPart : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MeanRad : Rx::ApiLF::EPar , EPar
  • Depth_Fuse_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_ImageType : Rx::ApiLF::EPar , EPar
  • Depth_Path : Rx::ApiLF::EParGrp , EParGrp
  • Depth_Path_BlockCnt : Rx::ApiLF::EPar , EPar
  • Depth_Path_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MaxPolyCtrDelta : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MinCor : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_MinPolyParAbs : EPar , Rx::ApiLF::EPar
  • Depth_Path_LT_MinStdDev : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PatchDia : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PatchStride : Rx::ApiLF::EPar , EPar
  • Depth_Path_LT_PixelStep : Rx::ApiLF::EPar , EPar
  • Depth_Path_MaxVirtDepth : Rx::ApiLF::EPar , EPar
  • Depth_Path_NearResLevel : Rx::ApiLF::EPar , EPar
  • Depth_Path_SparseLensSet : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv : Rx::ApiLF::EParGrp , EParGrp
  • Depth_PathPiv_BlockCnt : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_BPMinCor : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_BPMinMean : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_BPSigma : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_MaxPolyCtrDelta : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_MinCor : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_MinPolyParAbs : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_LT_PatchDia : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_PatchStride : Rx::ApiLF::EPar , EPar
  • Depth_PathPiv_LT_PixelStep : EPar , Rx::ApiLF::EPar
  • Depth_PathPiv_NearResLevel : Rx::ApiLF::EPar , EPar
  • Depth_ResImgDiv : Rx::ApiLF::EPar , EPar
  • Depth_Std_BlockCnt : EPar , Rx::ApiLF::EPar
  • Depth_Std_Fuse_DepthDeltaMax : Rx::ApiLF::EPar , EPar
  • Depth_Std_Fuse_DepthOptRangeMax : Rx::ApiLF::EPar , EPar
  • Depth_Std_MaxInvCor : EPar , Rx::ApiLF::EPar
  • Depth_Std_MeanRad : EPar , Rx::ApiLF::EPar
  • Depth_Std_MedianRad : Rx::ApiLF::EPar , EPar
  • Depth_Std_MinStdDev : EPar , Rx::ApiLF::EPar
  • Depth_Std_MinTrust : EPar , Rx::ApiLF::EPar
  • Depth_Std_PatchRad : EPar , Rx::ApiLF::EPar
  • Depth_Std_PixelStep : Rx::ApiLF::EPar , EPar
  • Depth_Std_RawMeanMaxBlackPart : EPar , Rx::ApiLF::EPar
  • Depth_Std_RawMeanRad : EPar , Rx::ApiLF::EPar
  • Depth_Std_RawMedianRad : Rx::ApiLF::EPar , EPar
  • Depth_Std_SizeDiv : Rx::ApiLF::EPar , EPar
  • DepthCol : Rx::ApiLF::EImgID , EImgID
  • DepthColLeft : Rx::ApiLF::EImgID , EImgID
  • DepthColRight : Rx::ApiLF::EImgID , EImgID
  • DepthLeft : EImgID , Rx::ApiLF::EImgID
  • DepthRight : Rx::ApiLF::EImgID , EImgID
  • Double : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • Error : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Exception : EStatusMessage , Rx::ApiLF::EStatusMessage
  • Extern_Impulse : ECameraTriggerMode , Rx::ApiLF::ECameraTriggerMode


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • Fatal : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Float : Rx::Interop::Runtime28::EDataType
  • Focus : Rx::ApiLF::EParGrp , Rx::ApiLF::EImgID , EParGrp , EImgID
  • Focus_DefaultFocus : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_DefaultDepth : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_Enable : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_Gradient : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_MaxBlurRad : Rx::ApiLF::EPar , EPar
  • Focus_DefocusBlur_VirtDOF : Rx::ApiLF::EPar , EPar
  • Focus_Focus : Rx::ApiLF::EPar , EPar
  • Focus_MaxLensContribRad : Rx::ApiLF::EPar , EPar
  • Focus_ResImgDiv : Rx::ApiLF::EPar , EPar
  • Focus_Stereo_Enabled : Rx::ApiLF::EPar , EPar
  • Focus_Stereo_EyeSep : Rx::ApiLF::EPar , EPar
  • Focus_Stereo_Rot : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_Gamma : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_Radial : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_VirtDepthCollPlane : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_VirtDepthMax : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_VirtDepthMin : Rx::ApiLF::EPar , EPar
  • Focus_ViewOffset_X : EPar , Rx::ApiLF::EPar
  • Focus_ViewOffset_Y : EPar , Rx::ApiLF::EPar
  • FocusLeft : Rx::ApiLF::EImgID , EImgID
  • FocusOnSurface : Rx::ApiLF::EFeature , EFeature
  • FocusRight : EImgID , Rx::ApiLF::EImgID


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GENERAL : Rx::ApiLF::EWarning , EWarning
  • Gl : EParGrp , Rx::ApiLF::EParGrp
  • GL_NOINTEROP : Rx::ApiLF::EError , EError
  • Gl_TexDepthColLeftID : EPar , Rx::ApiLF::EPar
  • Gl_TexDepthColRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexDepthLeftID : Rx::ApiLF::EPar , EPar
  • Gl_TexDepthRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusLeftID : EPar , Rx::ApiLF::EPar
  • Gl_TexFocusLeftID2 : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusRightID : Rx::ApiLF::EPar , EPar
  • Gl_TexFocusRightID2 : Rx::ApiLF::EPar , EPar
  • Gl_TexGridID : Rx::ApiLF::EPar , EPar
  • GL_TEXNOTSUPPORTED : Rx::ApiLF::EError , EError
  • Gl_TexRayDepthID : Rx::ApiLF::EPar , EPar
  • Gl_TexRayID : Rx::ApiLF::EPar , EPar
  • Gl_TexRayProcID : EPar , Rx::ApiLF::EPar
  • Gl_TexRayWhiteID : Rx::ApiLF::EPar , EPar
  • Grid : Rx::ApiLF::EParGrp , EParGrp
  • Grid_ResImgDiv : Rx::ApiLF::EPar , EPar


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • IMG_DITNOTSUPPORTED : Rx::ApiLF::EError , EError
  • IMG_NOTSUPPORTED : EError , Rx::ApiLF::EError
  • Info : Rx::ApiLF::EStatusMessage , EStatusMessage
  • INSTALL : EError , Rx::ApiLF::EError
  • Int : Rx::Interop::Runtime28::EDataType
  • INTERNAL : Rx::ApiLF::EError , EError
  • INVALID_POINTER : Rx::ApiLF::EError , EError
  • Inversion2 : Rx::ApiLF::ERadDistType , ERadDistType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • Lum : Rx::Interop::Runtime28::EPixelType
  • LumA : Rx::Interop::Runtime28::EPixelType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MultiView : Rx::ApiLF::EFeature , EFeature


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • NONE : Rx::ApiLF::EError
  • None : EStatusMessage , EStatusMsgGrp , Rx::ApiLF::EStatusMessage , Rx::ApiLF::EStatusMsgGrp , ERaySeqMode , EImgID , EParGrp , EPar , ECameraTriggerMode , Rx::ApiLF::ERaySeqMode , Rx::ApiLF::EImgID , Rx::ApiLF::EParGrp , Rx::ApiLF::EPar , Rx::ApiLF::ECameraTriggerMode , EFeature , Rx::ApiLF::EFeature , Rx::Interop::Runtime28::EPixelType
  • NONE : EWarning , EError , Rx::ApiLF::EWarning


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OUTOFMEMORY : Rx::ApiLF::EError , EError
  • OUTOFRANGE : Rx::ApiLF::EError , EError


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PAR_ACSREAD : Rx::ApiLF::EError , EError
  • PAR_ACSWRITE : EError , Rx::ApiLF::EError
  • PAR_EXIST : Rx::ApiLF::EError , EError
  • PAR_GRPEXIST : EError , Rx::ApiLF::EError
  • PAR_INVCONSTR : Rx::ApiLF::EError , EError
  • PAR_NOCONSTR : Rx::ApiLF::EError , EError
  • PAR_NOTAVAILABLE : Rx::ApiLF::EError , EError
  • PAR_NOTSUPPORTED : EError , Rx::ApiLF::EError
  • PAR_READ : Rx::ApiLF::EError , EError
  • PAR_TYPE : Rx::ApiLF::EError , EError
  • PAR_VALUE : Rx::ApiLF::EError , EError
  • PAR_WRITE : Rx::ApiLF::EError , EError
  • Polynom4 : Rx::ApiLF::ERadDistType , ERadDistType
  • PosScale : Rx::ApiLF::ECalibGridMode , ECalibGridMode
  • PosScaleRot : Rx::ApiLF::ECalibGridMode , ECalibGridMode
  • PreProc : EParGrp , Rx::ApiLF::EParGrp
  • PreProc_Demosaic_B : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_G : Rx::ApiLF::EPar , EPar
  • PreProc_Demosaic_R : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_BlendFactor : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_FilterDia : Rx::ApiLF::EPar , EPar
  • PreProc_DenoiseNLM_NoiseLevel : EPar , Rx::ApiLF::EPar
  • PreProc_Sharp1_BlurStdDev : Rx::ApiLF::EPar , EPar
  • PreProc_Sharp1_Enable : Rx::ApiLF::EPar , EPar
  • PreProc_Sharp1_Factor : Rx::ApiLF::EPar , EPar
  • PreProc_Sharp1_OnlyCalc : Rx::ApiLF::EPar , EPar
  • PreProc_Std_Brightness : Rx::ApiLF::EPar , EPar
  • PreProc_Std_ContrastCenter : Rx::ApiLF::EPar , EPar
  • PreProc_Std_ContrastScale : EPar , Rx::ApiLF::EPar
  • PreProc_Std_Enable : EPar , Rx::ApiLF::EPar
  • Progress : EStatusMsgGrp , Rx::ApiLF::EStatusMsgGrp
  • Progress_Finished : EStatusMessage , Rx::ApiLF::EStatusMessage
  • Progress_Init : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Progress_Step : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Progress_Value : Rx::ApiLF::EStatusMessage , EStatusMessage


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RawImage : Rx::ApiLF::EFeature , EFeature
  • Ray : Rx::ApiLF::EImgID , EParGrp , Rx::ApiLF::EParGrp , EImgID
  • Ray_ApplyFileSettings : EPar , Rx::ApiLF::EPar
  • Ray_ApplyWhiteImage : Rx::ApiLF::EPar , EPar
  • Ray_ConvBayer : Rx::ApiLF::EPar , EPar
  • Ray_DataType : Rx::ApiLF::EPar , EPar
  • Ray_Height : EPar , Rx::ApiLF::EPar
  • Ray_MLI_BaseReflectX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseReflectY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseRotation : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecXX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecXY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecYX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_BaseVecYY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_Border : EPar , Rx::ApiLF::EPar
  • Ray_MLI_Diameter : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeCount : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeIdx : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeOffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeOffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeVirtDepthMax : Rx::ApiLF::EPar , EPar
  • Ray_MLI_LensTypeVirtDepthMin : Rx::ApiLF::EPar , EPar
  • Ray_MLI_NeedWhiteImage : Rx::ApiLF::EPar , EPar
  • Ray_MLI_OffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_OffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_PixelSizeX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_PixelSizeY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistOffsetX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistOffsetY : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar1 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar2 : EPar , Rx::ApiLF::EPar
  • Ray_MLI_RadDistPar3 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar4 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistPar5 : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistParCnt : Rx::ApiLF::EPar , EPar
  • Ray_MLI_RadDistType : Rx::ApiLF::EPar , EPar
  • Ray_MLI_Rotation : Rx::ApiLF::EPar , EPar
  • Ray_MLI_SubGridBaseX : Rx::ApiLF::EPar , EPar
  • Ray_MLI_SubGridBaseY : Rx::ApiLF::EPar , EPar
  • Ray_PixelType : Rx::ApiLF::EPar , EPar
  • Ray_Width : Rx::ApiLF::EPar , EPar
  • RayDepth : Rx::ApiLF::EImgID , EImgID
  • RayGrid : Rx::ApiLF::EImgID , EImgID
  • RayProc : Rx::ApiLF::EImgID , EImgID
  • RaySeq : Rx::ApiLF::EParGrp , EParGrp
  • RAYSEQ_ALREADY_BOUND : Rx::ApiLF::EError , EError
  • RaySeq_ApplyFileSettings : Rx::ApiLF::EPar , EPar
  • RaySeq_AutoStoreCamFrameCnt : Rx::ApiLF::EPar , EPar
  • RaySeq_AutoStoreCamFrames : Rx::ApiLF::EPar , EPar
  • RAYSEQ_AUTOWRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_BIND : EError , Rx::ApiLF::EError
  • RAYSEQ_CLOSE : Rx::ApiLF::EError , EError
  • RAYSEQ_COMPRESS : Rx::ApiLF::EError , EError
  • RAYSEQ_EOF : Rx::ApiLF::EError , EError
  • RAYSEQ_IMAGEFORMAT : Rx::ApiLF::EError , EError
  • RAYSEQ_INTERNAL : Rx::ApiLF::EError , EError
  • RAYSEQ_INVALID : Rx::ApiLF::EError , EError
  • RAYSEQ_INVALID_ID : Rx::ApiLF::EError , EError
  • RAYSEQ_NOREAD : Rx::ApiLF::EError , EError
  • RAYSEQ_NOT_BOUND : Rx::ApiLF::EError , EError
  • RAYSEQ_NOTOPEN : Rx::ApiLF::EError , EError
  • RAYSEQ_NOWRITE : EError , Rx::ApiLF::EError
  • RAYSEQ_OPENREAD : Rx::ApiLF::EError , EError
  • RAYSEQ_OPENWRITE : EError , Rx::ApiLF::EError
  • RAYSEQ_READ : EError , Rx::ApiLF::EError
  • RAYSEQ_SETFRAMEIDX : Rx::ApiLF::EError , EError
  • RAYSEQ_SOF : EError , Rx::ApiLF::EError
  • RAYSEQ_UNCOMPRESS : Rx::ApiLF::EError , EError
  • RAYSEQ_UNKOWNCOMP : Rx::ApiLF::EError , EError
  • RAYSEQ_UNSUPPIXTYPE : EError , Rx::ApiLF::EError
  • RAYSEQ_VERSION : EError , Rx::ApiLF::EError
  • RAYSEQ_WHITEIMAGE : Rx::ApiLF::EError , EError
  • RAYSEQ_WRITE : Rx::ApiLF::EError , EError
  • RAYSEQ_WRITEINIT : EError , Rx::ApiLF::EError
  • RayWhite : Rx::ApiLF::EImgID , EImgID
  • Read : ERaySeqMode , Rx::ApiLF::ERaySeqMode
  • Relative : Rx::ApiLF::EDepthImageType , EDepthImageType
  • RGB : Rx::Interop::Runtime28::EPixelType
  • RGBA : Rx::Interop::Runtime28::EPixelType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • Save : Rx::ApiLF::EFeature , EFeature
  • Short : Rx::Interop::Runtime28::EDataType
  • Software_SnapShot : Rx::ApiLF::ECameraTriggerMode , ECameraTriggerMode
  • Standard : EFeature , EDepthImageType , Rx::ApiLF::EDepthImageType , Rx::ApiLF::EFeature


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • Text : Rx::ApiLF::EStatusMsgGrp , EStatusMsgGrp


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UByte : Rx::Interop::Runtime28::EDataType
  • UInt : Rx::Interop::Runtime28::EDataType
  • Unknown : EStatusSource , Rx::ApiLF::EStatusSource
  • UShort : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • Virtual : Rx::ApiLF::EDepthImageType , EDepthImageType
  • Void : Rx::Interop::Runtime28::EDataType


Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • Warning : Rx::ApiLF::EStatusMessage , EStatusMessage
  • Write : Rx::ApiLF::ERaySeqMode , ERaySeqMode


Data Structures

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
Data Structures
Here are the data structures with brief descriptions:
[detail level 1234]
o N CLUViz |
| o N MT |
| o N ST |
| \ N Tool |
o N CLUVizST |
o N ECalibGridMode | Grid calibration modes for parameter CalibGrid_Mode
o N ECameraTriggerMode |
o N EDepthImageType | Depth image output type. Use these value for the parameter Depth_ImageType
o N EError | Error IDs of Raytrix API
o N EFeature | Values that represent EError.
o N EImgID | Internal image IDs
o N EPar | This enum contains the parameters IDs for various library and camera parameters
o N EParGrp | Parameter group IDs
o N ERadDistType | Radial distortion types of raw images
o N ERaySeqMode | Ray sequence file modes
o N EStatusMessage | Values that represent EStatusCode.
o N EStatusMsgGrp | Values that represent EStatusCode.
o N EStatusSource | Values that represent EStatusCodeGroup.
o N EWarning | Values that represent EWarning.
\ N Rx |
o N ApiLF |
| o N ECalibGridMode | Grid calibration modes for parameter CalibGrid_Mode
| o N ECameraTriggerMode |
| o N EDepthImageType | Depth image output type. Use these value for the parameter Depth_ImageType
| o N EError | Error IDs of Raytrix API
| o N EFeature | Values that represent EError.
| o N EImgID | Internal image IDs
| o N EPar | This enum contains the parameters IDs for various library and camera parameters
| o N EParGrp | Parameter group IDs
| o N ERadDistType | Radial distortion types of raw images
| o N ERaySeqMode | Ray sequence file modes
| o N EStatusMessage | Values that represent EStatusCode.
| o N EStatusMsgGrp | Values that represent EStatusCode.
| o N EStatusSource | Values that represent EStatusCodeGroup.
| o N EWarning | Values that represent EWarning.
| o N NET |
| | o C CtrlLogListView | Summary for CtrlLogList
| | o C FormLogConsole | Summary for RxFormLog
| | \ C LogConsoleManager |
| o C CStatusMessageDelegateList |
| \ C SStatusMessageDelegate |
o N Interop |
| \ N Runtime28 |
| o N EDataType | The image data types
| o N EPixelType | The image pixel types
| \ C IImage | Interface supported by Raytrix images.
o C CRxArrayDouble | Basic unsigned int array operations
o C CRxArrayInt | Basic unsigned int array operations
o C CRxArrayString | Basic unsigned int array operations
o C CRxArrayUChar | Basic unsigned char array operations
o C CRxArrayUInt | Basic unsigned int array operations
o C CRxImage | Image class. Implements the interface IImage
o C CRxImageFormat | Image format descriptor
o C CRxImageMoniker | Image moniker class. Implements the interface IImage but does not allocate memory
o C CRxMetaData | Handles a collection of meta data of different types
o C CRxString | Basic character string operations.
\ C TPixel | General pixel template structure


Rx::ApiLF::NET::CtrlLogListView Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • ApiLF
  • NET
  • CtrlLogListView
Public Member Functions | Protected Member Functions | Protected Attributes
Rx::ApiLF::NET::CtrlLogListView Class Reference

Summary for CtrlLogList More...

#include <Rx.ApiLF.Net.CtrlLogListView.h>

Inheritance diagram for Rx::ApiLF::NET::CtrlLogListView:

Public Member Functions

CtrlLogListView (void)
void AddMessage (Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue)

Protected Member Functions

~CtrlLogListView ()
Clean up any resources being used. More...
void | OnProgressBarFinished ()
void | OnProgressBarInit (int iValue, int iMin, int iMax, int iStep)
void | OnProgressBarSetValue (int iValue)
void | OnProgressBarStep (int iValue)
void | OnStatusProgress (Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, System::String^ sSourceName, System::String^ sMessage, int iValue)

Protected Attributes

double m_dLastTime

Detailed Description

Summary for CtrlLogList

Constructor & Destructor Documentation

Rx::ApiLF::NET::CtrlLogListView::CtrlLogListView ( void )
inline
Rx::ApiLF::NET::CtrlLogListView::~CtrlLogListView ( )
inlineprotected

Clean up any resources being used.

Member Function Documentation

void Rx::ApiLF::NET::CtrlLogListView::AddMessage | ( | Rx::ApiLF::NET::EStatusSource | eSource,
 |  | Rx::ApiLF::NET::EStatusMessage | eMsg,
 |  | String^ | sSourceName,
 |  | String^ | sMessage,
 |  | int | iValue
 | ) |  |
void Rx::ApiLF::NET::CtrlLogListView::OnProgressBarFinished ( )
protected
void Rx::ApiLF::NET::CtrlLogListView::OnProgressBarInit | ( | int | iValue,
 |  | int | iMin,
 |  | int | iMax,
 |  | int | iStep
 | ) |  |
protected
void Rx::ApiLF::NET::CtrlLogListView::OnProgressBarSetValue ( int iValue )
protected
void Rx::ApiLF::NET::CtrlLogListView::OnProgressBarStep ( int iValue )
protected
void Rx::ApiLF::NET::CtrlLogListView::OnStatusProgress | ( | Rx::ApiLF::NET::EStatusSource | eSource,
 |  | Rx::ApiLF::NET::EStatusMessage | eMsg,
 |  | System::String^ | sSourceName,
 |  | System::String^ | sMessage,
 |  | int | iValue
 | ) |  |
protected

Field Documentation

double Rx::ApiLF::NET::CtrlLogListView::m_dLastTime
protected
The documentation for this class was generated from the following file:
  • Rx.ApiLF.Net.CtrlLogListView.h


Rx::ApiLF::NET::FormLogConsole Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • ApiLF
  • NET
  • FormLogConsole
Public Member Functions | Protected Member Functions | Protected Attributes
Rx::ApiLF::NET::FormLogConsole Class Reference

Summary for RxFormLog More...

#include <Rx.ApiLF.Net.FormLogConsole.h>

Inheritance diagram for Rx::ApiLF::NET::FormLogConsole:

Public Member Functions

FormLogConsole (Threading::ManualResetEvent^ evInitDone)
void | AddLogMessage (Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue)
delegate void | Delegate_Message (Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue)
delegate void | Delegate_String (String^ sText)
delegate void | Delegate_Void ()
void | End ()
void | SetCudaDeviceInfo (String^ sInfo)

Protected Member Functions

~FormLogConsole ()
Clean up any resources being used. More...

Protected Attributes

bool | m_bDoClose
Threading::ManualResetEvent^ | m_evInitDone
System::Resources::ResourceManager^ | m_xResMgr

Detailed Description

Summary for RxFormLog

Constructor & Destructor Documentation

Rx::ApiLF::NET::FormLogConsole::FormLogConsole ( Threading::ManualResetEvent^ evInitDone )
inline
Rx::ApiLF::NET::FormLogConsole::~FormLogConsole ( )
inlineprotected

Clean up any resources being used.

Member Function Documentation

void Rx::ApiLF::NET::FormLogConsole::AddLogMessage | ( | Rx::ApiLF::NET::EStatusSource | eSource,
 |  | Rx::ApiLF::NET::EStatusMessage | eMsg,
 |  | String^ | sSourceName,
 |  | String^ | sMessage,
 |  | int | iValue
 | ) |  |
delegate void Rx::ApiLF::NET::FormLogConsole::Delegate_Message | ( | Rx::ApiLF::NET::EStatusSource | eSource,
 |  | Rx::ApiLF::NET::EStatusMessage | eMsg,
 |  | String^ | sSourceName,
 |  | String^ | sMessage,
 |  | int | iValue
 | ) |  |
delegate void Rx::ApiLF::NET::FormLogConsole::Delegate_String ( String^ sText )
delegate void Rx::ApiLF::NET::FormLogConsole::Delegate_Void ( )
void Rx::ApiLF::NET::FormLogConsole::End ( )
void Rx::ApiLF::NET::FormLogConsole::SetCudaDeviceInfo ( String^ sInfo )

Field Documentation

bool Rx::ApiLF::NET::FormLogConsole::m_bDoClose
protected
Threading::ManualResetEvent ^ Rx::ApiLF::NET::FormLogConsole::m_evInitDone
protected
System::Resources::ResourceManager ^ Rx::ApiLF::NET::FormLogConsole::m_xResMgr
protected
The documentation for this class was generated from the following file:
  • Rx.ApiLF.Net.FormLogConsole.h


Rx::ApiLF::NET::LogConsoleManager Class Reference

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • Rx
  • ApiLF
  • NET
  • LogConsoleManager
Public Member Functions
Rx::ApiLF::NET::LogConsoleManager Class Reference

#include <Rx.ApiLF.Net.LogConsoleManager.h>

Public Member Functions

LogConsoleManager ()
~LogConsoleManager ()
void | AddMessage (Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue)
void | End ()
void | SetCudaDeviceInfo (String^ sInfo)
void | Start ()

Constructor & Destructor Documentation

Rx::ApiLF::NET::LogConsoleManager::LogConsoleManager ( )
Rx::ApiLF::NET::LogConsoleManager::~LogConsoleManager ( )
inline

Member Function Documentation

void Rx::ApiLF::NET::LogConsoleManager::AddMessage | ( | Rx::ApiLF::NET::EStatusSource | eSource,
 |  | Rx::ApiLF::NET::EStatusMessage | eMsg,
 |  | String^ | sSourceName,
 |  | String^ | sMessage,
 |  | int | iValue
 | ) |  |
void Rx::ApiLF::NET::LogConsoleManager::End ( )
void Rx::ApiLF::NET::LogConsoleManager::SetCudaDeviceInfo ( String^ sInfo )
void Rx::ApiLF::NET::LogConsoleManager::Start ( )
The documentation for this class was generated from the following file:
  • Rx.ApiLF.Net.LogConsoleManager.h


Data Structure Index

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
Data Structure Index
C | F | I | L | S | T
C
CRxArrayUInt (Rx) CStatusMessageDelegateList (Rx::ApiLF)
L
T
CRxImage (Rx) CtrlLogListView (Rx::ApiLF::NET)
CRxArrayDouble (Rx) CRxImageFormat (Rx)
F
LogConsoleManager (Rx::ApiLF::NET) TPixel (Rx)
CRxArrayInt (Rx) CRxImageMoniker (Rx)
S
CRxArrayString (Rx) CRxMetaData (Rx) FormLogConsole (Rx::ApiLF::NET)
CRxArrayUChar (Rx) CRxString (Rx)
I
SStatusMessageDelegate (Rx::ApiLF)
IImage (Rx::Interop::Runtime28)
C | F | I | L | S | T


Class Hierarchy

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
o C Rx::CRxArrayDouble | Basic unsigned int array operations
o C Rx::CRxArrayInt | Basic unsigned int array operations
o C Rx::CRxArrayString | Basic unsigned int array operations
o C Rx::CRxArrayUChar | Basic unsigned char array operations
o C Rx::CRxArrayUInt | Basic unsigned int array operations
o C Rx::CRxImageFormat | Image format descriptor
o C Rx::CRxMetaData | Handles a collection of meta data of different types
o C Rx::CRxString | Basic character string operations.
o C Rx::ApiLF::CStatusMessageDelegateList |
o C Form |
| \ C Rx::ApiLF::NET::FormLogConsole | Summary for RxFormLog
o C Rx::Interop::Runtime28::IImage | Interface supported by Raytrix images.
| o C Rx::CRxImage | Image class. Implements the interface IImage
| \ C Rx::CRxImageMoniker | Image moniker class. Implements the interface IImage but does not allocate memory
o C Rx::ApiLF::NET::LogConsoleManager |
o C Rx::ApiLF::SStatusMessageDelegate |
o C Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > | General pixel template structure
\ C UserControl |
\ C Rx::ApiLF::NET::CtrlLogListView | Summary for CtrlLogList


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • a() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Add() : Rx::ApiLF::CStatusMessageDelegateList
  • AddElement() : Rx::CRxMetaData
  • AddLogMessage() : Rx::ApiLF::NET::FormLogConsole
  • AddMessage()
: Rx::ApiLF::NET::LogConsoleManager
, Rx::ApiLF::NET::CtrlLogListView


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • b() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • Clear()
: Rx::ApiLF::CStatusMessageDelegateList
, Rx::CRxMetaData
, Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Contains() : Rx::CRxString
  • ConvertType() : Rx::CRxImage
  • ConvertTypeSub1() : Rx::CRxImage
  • ConvertTypeSub2() : Rx::CRxImage
  • Count() : Rx::ApiLF::CStatusMessageDelegateList
  • Create()
: Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage
  • CRxArrayDouble() : Rx::CRxArrayDouble
  • CRxArrayDouble::operator[]() : Rx::CRxArrayDouble
  • CRxArrayInt() : Rx::CRxArrayInt
  • CRxArrayInt::operator[]() : Rx::CRxArrayInt
  • CRxArrayString() : Rx::CRxArrayString
  • CRxArrayString::operator[]() : Rx::CRxArrayString
  • CRxArrayUChar() : Rx::CRxArrayUChar
  • CRxArrayUChar::operator[]() : Rx::CRxArrayUChar
  • CRxArrayUInt() : Rx::CRxArrayUInt
  • CRxArrayUInt::operator[]() : Rx::CRxArrayUInt
  • CRxImage() : Rx::CRxImage
  • CRxImageFormat() : Rx::CRxImageFormat
  • CRxImageMoniker() : Rx::CRxImageMoniker
  • CRxMetaData() : Rx::CRxMetaData
  • CRxString() : Rx::CRxString
  • CStatusMessageDelegateList() : Rx::ApiLF::CStatusMessageDelegateList
  • CtrlLogListView() : Rx::ApiLF::NET::CtrlLogListView


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • Delegate_Message() : Rx::ApiLF::NET::FormLogConsole
  • Delegate_String() : Rx::ApiLF::NET::FormLogConsole
  • Delegate_Void() : Rx::ApiLF::NET::FormLogConsole
  • Delete()
: Rx::CRxArrayDouble
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayInt
, Rx::CRxArrayString
  • Destroy()
: Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • End()
: Rx::ApiLF::NET::FormLogConsole
, Rx::ApiLF::NET::LogConsoleManager


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • Find() : Rx::CRxString
  • FindFirstNotOf() : Rx::CRxString
  • FindFirstOf() : Rx::CRxString
  • FindLastNotOf() : Rx::CRxString
  • FindLastOf() : Rx::CRxString
  • FormLogConsole() : Rx::ApiLF::NET::FormLogConsole


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • g() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • GetByteCount()
: Rx::CRxImage
, Rx::CRxImageFormat
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
  • GetBytesPerPixel()
: Rx::CRxImage
, Rx::CRxImageFormat
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
  • GetDataPtr()
: Rx::CRxArrayInt
, Rx::CRxArrayUChar
, Rx::CRxArrayUInt
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage
, Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxArrayDouble
, Rx::CRxArrayInt
  • GetElement() : Rx::CRxMetaData
  • GetElementCount() : Rx::CRxMetaData
  • GetElementNameType() : Rx::CRxMetaData
  • GetFormat()
: Rx::CRxImageMoniker
, Rx::CRxImage
  • GetLastError() : Rx::CRxMetaData
  • GetPixelCount()
: Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::CRxImageFormat
  • GetSize()
: Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage
  • GetType()
: Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • HasElement() : Rx::CRxMetaData


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • iAlphaIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iBlueIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iDataType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iGreenIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Invoke() : Rx::ApiLF::SStatusMessageDelegate
  • InvokeAll() : Rx::ApiLF::CStatusMessageDelegateList
  • iPixelType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iRedIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • IsBayerPixelType() : Rx::CRxImageFormat
  • IsOfType()
: Rx::CRxImage
, Rx::CRxImageFormat
, Rx::CRxImageMoniker
, Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • IsValid()
: Rx::CRxArrayUChar
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImage
, Rx::CRxArrayString
, Rx::CRxArrayDouble
, Rx::CRxArrayUInt
, Rx::CRxArrayInt


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • Length()
: Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString
  • LogConsoleManager() : Rx::ApiLF::NET::LogConsoleManager


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • m_bDoClose : Rx::ApiLF::NET::FormLogConsole
  • m_dLastTime : Rx::ApiLF::NET::CtrlLogListView
  • m_eDataType : Rx::CRxImageFormat
  • m_ePixelType : Rx::CRxImageFormat
  • m_evInitDone : Rx::ApiLF::NET::FormLogConsole
  • m_iHeight : Rx::CRxImageFormat
  • m_iWidth : Rx::CRxImageFormat
  • m_mStatusMessageDelegates : Rx::ApiLF::CStatusMessageDelegateList
  • m_pStatusMessageCallbackFunc : Rx::ApiLF::SStatusMessageDelegate
  • m_pvData
: Rx::CRxImageMoniker
, Rx::CRxArrayDouble
, Rx::CRxImage
, Rx::CRxArrayInt
, Rx::CRxArrayString
, Rx::CRxArrayUChar
, Rx::CRxArrayUInt
  • m_pvStatusMessageCallbackContext : Rx::ApiLF::SStatusMessageDelegate
  • m_uiLength
: Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayDouble
, Rx::CRxArrayString
, Rx::CRxArrayInt
  • m_xFormat : Rx::CRxImage , Rx::CRxImageMoniker
  • m_xResMgr : Rx::ApiLF::NET::FormLogConsole


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • New()
: Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString
  • Normalize() : Rx::CRxImage


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • OnProgressBarFinished() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarInit() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarSetValue() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarStep() : Rx::ApiLF::NET::CtrlLogListView
  • OnStatusProgress() : Rx::ApiLF::NET::CtrlLogListView
  • operator const char *() : Rx::CRxString
  • operator!=()
: Rx::CRxImageFormat
, Rx::CRxString
, Rx::ApiLF::SStatusMessageDelegate
  • operator+=() : Rx::CRxString
  • operator<<() : Rx::CRxString
  • operator=()
: Rx::CRxArrayString
, Rx::CRxArrayUChar
, Rx::CRxArrayInt
, Rx::CRxArrayDouble
, Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
, Rx::CRxString
, Rx::CRxImageMoniker
, Rx::CRxString
, Rx::CRxMetaData
, Rx::CRxString
, Rx::CRxImage
, Rx::CRxArrayUInt
  • operator==()
: Rx::CRxString
, Rx::CRxImageFormat
, Rx::ApiLF::SStatusMessageDelegate


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • r() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Remove() : Rx::ApiLF::CStatusMessageDelegateList
  • Replace() : Rx::CRxString
  • Reset()
: Rx::CRxArrayUChar
, Rx::CRxArrayUInt
, Rx::CRxArrayDouble
, Rx::CRxImageFormat
, Rx::CRxArrayInt
, Rx::CRxArrayString
  • Resize()
: Rx::CRxArrayUChar
, Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayString


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • Set()
: Rx::ApiLF::SStatusMessageDelegate
, Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::CRxImage
  • SetCudaDeviceInfo()
: Rx::ApiLF::NET::FormLogConsole
, Rx::ApiLF::NET::LogConsoleManager
  • SetElement() : Rx::CRxMetaData
  • SetZero() : Rx::CRxImage
  • Size() : Rx::CRxString
  • SplitFilename() : Rx::CRxString
  • SStatusMessageDelegate() : Rx::ApiLF::SStatusMessageDelegate
  • Start() : Rx::ApiLF::NET::LogConsoleManager
  • SubStr() : Rx::CRxString


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • ToCString() : Rx::CRxString
  • ToStdString() : Rx::CRxString
  • ToString() : Rx::CRxImageFormat
  • TType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • TValue
: Rx::CRxArrayInt
, Rx::CRxArrayDouble
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • uAlphaCnt : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uAlphaSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uColorCnt : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uColorSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • value : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >


Data Fields

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- ~ -

  • ~CRxArrayDouble() : Rx::CRxArrayDouble
  • ~CRxArrayInt() : Rx::CRxArrayInt
  • ~CRxArrayString() : Rx::CRxArrayString
  • ~CRxArrayUChar() : Rx::CRxArrayUChar
  • ~CRxArrayUInt() : Rx::CRxArrayUInt
  • ~CRxImage() : Rx::CRxImage
  • ~CRxImageMoniker() : Rx::CRxImageMoniker
  • ~CRxMetaData() : Rx::CRxMetaData
  • ~CRxString() : Rx::CRxString
  • ~CStatusMessageDelegateList() : Rx::ApiLF::CStatusMessageDelegateList
  • ~CtrlLogListView() : Rx::ApiLF::NET::CtrlLogListView
  • ~FormLogConsole() : Rx::ApiLF::NET::FormLogConsole
  • ~LogConsoleManager() : Rx::ApiLF::NET::LogConsoleManager


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- a -

  • a() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Add() : Rx::ApiLF::CStatusMessageDelegateList
  • AddElement() : Rx::CRxMetaData
  • AddLogMessage() : Rx::ApiLF::NET::FormLogConsole
  • AddMessage()
: Rx::ApiLF::NET::LogConsoleManager
, Rx::ApiLF::NET::CtrlLogListView


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- b -

  • b() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- c -

  • Clear()
: Rx::ApiLF::CStatusMessageDelegateList
, Rx::CRxMetaData
, Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Contains() : Rx::CRxString
  • ConvertType() : Rx::CRxImage
  • ConvertTypeSub1() : Rx::CRxImage
  • ConvertTypeSub2() : Rx::CRxImage
  • Count() : Rx::ApiLF::CStatusMessageDelegateList
  • Create()
: Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage
  • CRxArrayDouble() : Rx::CRxArrayDouble
  • CRxArrayDouble::operator[]() : Rx::CRxArrayDouble
  • CRxArrayInt() : Rx::CRxArrayInt
  • CRxArrayInt::operator[]() : Rx::CRxArrayInt
  • CRxArrayString() : Rx::CRxArrayString
  • CRxArrayString::operator[]() : Rx::CRxArrayString
  • CRxArrayUChar() : Rx::CRxArrayUChar
  • CRxArrayUChar::operator[]() : Rx::CRxArrayUChar
  • CRxArrayUInt() : Rx::CRxArrayUInt
  • CRxArrayUInt::operator[]() : Rx::CRxArrayUInt
  • CRxImage() : Rx::CRxImage
  • CRxImageFormat() : Rx::CRxImageFormat
  • CRxImageMoniker() : Rx::CRxImageMoniker
  • CRxMetaData() : Rx::CRxMetaData
  • CRxString() : Rx::CRxString
  • CStatusMessageDelegateList() : Rx::ApiLF::CStatusMessageDelegateList
  • CtrlLogListView() : Rx::ApiLF::NET::CtrlLogListView


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- d -

  • Delegate_Message() : Rx::ApiLF::NET::FormLogConsole
  • Delegate_String() : Rx::ApiLF::NET::FormLogConsole
  • Delegate_Void() : Rx::ApiLF::NET::FormLogConsole
  • Delete()
: Rx::CRxArrayDouble
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayInt
, Rx::CRxArrayString
  • Destroy()
: Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- e -

  • End()
: Rx::ApiLF::NET::FormLogConsole
, Rx::ApiLF::NET::LogConsoleManager


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- f -

  • Find() : Rx::CRxString
  • FindFirstNotOf() : Rx::CRxString
  • FindFirstOf() : Rx::CRxString
  • FindLastNotOf() : Rx::CRxString
  • FindLastOf() : Rx::CRxString
  • FormLogConsole() : Rx::ApiLF::NET::FormLogConsole


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- g -

  • g() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • GetByteCount()
: Rx::CRxImage
, Rx::CRxImageFormat
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
  • GetBytesPerPixel()
: Rx::CRxImage
, Rx::CRxImageFormat
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
  • GetDataPtr()
: Rx::CRxArrayInt
, Rx::CRxArrayUChar
, Rx::CRxArrayUInt
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage
, Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxArrayDouble
, Rx::CRxArrayInt
  • GetElement() : Rx::CRxMetaData
  • GetElementCount() : Rx::CRxMetaData
  • GetElementNameType() : Rx::CRxMetaData
  • GetFormat()
: Rx::CRxImageMoniker
, Rx::CRxImage
  • GetLastError() : Rx::CRxMetaData
  • GetPixelCount()
: Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::CRxImageFormat
  • GetSize()
: Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage
  • GetType()
: Rx::CRxImageMoniker
, Rx::CRxImage
, Rx::Interop::Runtime28::IImage


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- h -

  • HasElement() : Rx::CRxMetaData


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- i -

  • Invoke() : Rx::ApiLF::SStatusMessageDelegate
  • InvokeAll() : Rx::ApiLF::CStatusMessageDelegateList
  • IsBayerPixelType() : Rx::CRxImageFormat
  • IsOfType() : Rx::CRxImage , Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT > , Rx::CRxImageFormat , Rx::CRxImageMoniker , Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • IsValid()
: Rx::Interop::Runtime28::IImage
, Rx::CRxImageMoniker
, Rx::CRxArrayInt
, Rx::CRxImage
, Rx::CRxArrayUChar
, Rx::CRxArrayUInt
, Rx::CRxArrayDouble
, Rx::CRxArrayString


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- l -

  • Length()
: Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString
  • LogConsoleManager() : Rx::ApiLF::NET::LogConsoleManager


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- n -

  • New()
: Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString
  • Normalize() : Rx::CRxImage


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- o -

  • OnProgressBarFinished() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarInit() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarSetValue() : Rx::ApiLF::NET::CtrlLogListView
  • OnProgressBarStep() : Rx::ApiLF::NET::CtrlLogListView
  • OnStatusProgress() : Rx::ApiLF::NET::CtrlLogListView
  • operator const char *() : Rx::CRxString
  • operator!=()
: Rx::CRxImageFormat
, Rx::CRxString
, Rx::ApiLF::SStatusMessageDelegate
  • operator+=() : Rx::CRxString
  • operator<<() : Rx::CRxString
  • operator=()
: Rx::CRxArrayString
, Rx::CRxArrayUChar
, Rx::CRxArrayInt
, Rx::CRxArrayDouble
, Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
, Rx::CRxString
, Rx::CRxImageMoniker
, Rx::CRxString
, Rx::CRxMetaData
, Rx::CRxString
, Rx::CRxImage
, Rx::CRxArrayUInt
  • operator==()
: Rx::CRxString
, Rx::CRxImageFormat
, Rx::ApiLF::SStatusMessageDelegate


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- r -

  • r() : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • Remove() : Rx::ApiLF::CStatusMessageDelegateList
  • Replace() : Rx::CRxString
  • Reset()
: Rx::CRxArrayUChar
, Rx::CRxArrayUInt
, Rx::CRxArrayDouble
, Rx::CRxImageFormat
, Rx::CRxArrayInt
, Rx::CRxArrayString
  • Resize()
: Rx::CRxArrayUChar
, Rx::CRxArrayDouble
, Rx::CRxArrayInt
, Rx::CRxArrayUInt
, Rx::CRxArrayString


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- s -

  • Set()
: Rx::ApiLF::SStatusMessageDelegate
, Rx::CRxImage
, Rx::CRxImageMoniker
, Rx::CRxImage
  • SetCudaDeviceInfo()
: Rx::ApiLF::NET::FormLogConsole
, Rx::ApiLF::NET::LogConsoleManager
  • SetElement() : Rx::CRxMetaData
  • SetZero() : Rx::CRxImage
  • Size() : Rx::CRxString
  • SplitFilename() : Rx::CRxString
  • SStatusMessageDelegate() : Rx::ApiLF::SStatusMessageDelegate
  • Start() : Rx::ApiLF::NET::LogConsoleManager
  • SubStr() : Rx::CRxString


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- t -

  • ToCString() : Rx::CRxString
  • ToStdString() : Rx::CRxString
  • ToString() : Rx::CRxImageFormat


Data Fields - Functions

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • ~

- ~ -

  • ~CRxArrayDouble() : Rx::CRxArrayDouble
  • ~CRxArrayInt() : Rx::CRxArrayInt
  • ~CRxArrayString() : Rx::CRxArrayString
  • ~CRxArrayUChar() : Rx::CRxArrayUChar
  • ~CRxArrayUInt() : Rx::CRxArrayUInt
  • ~CRxImage() : Rx::CRxImage
  • ~CRxImageMoniker() : Rx::CRxImageMoniker
  • ~CRxMetaData() : Rx::CRxMetaData
  • ~CRxString() : Rx::CRxString
  • ~CStatusMessageDelegateList() : Rx::ApiLF::CStatusMessageDelegateList
  • ~CtrlLogListView() : Rx::ApiLF::NET::CtrlLogListView
  • ~FormLogConsole() : Rx::ApiLF::NET::FormLogConsole
  • ~LogConsoleManager() : Rx::ApiLF::NET::LogConsoleManager


Data Fields - Variables

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • i
  • m
  • u
  • v

- i -

  • iAlphaIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iBlueIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iDataType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iGreenIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iPixelType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • iRedIdx : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >

- m -

  • m_bDoClose : Rx::ApiLF::NET::FormLogConsole
  • m_dLastTime : Rx::ApiLF::NET::CtrlLogListView
  • m_eDataType : Rx::CRxImageFormat
  • m_ePixelType : Rx::CRxImageFormat
  • m_evInitDone : Rx::ApiLF::NET::FormLogConsole
  • m_iHeight : Rx::CRxImageFormat
  • m_iWidth : Rx::CRxImageFormat
  • m_mStatusMessageDelegates : Rx::ApiLF::CStatusMessageDelegateList
  • m_pStatusMessageCallbackFunc : Rx::ApiLF::SStatusMessageDelegate
  • m_pvData
: Rx::CRxImageMoniker
, Rx::CRxArrayDouble
, Rx::CRxImage
, Rx::CRxArrayInt
, Rx::CRxArrayString
, Rx::CRxArrayUChar
, Rx::CRxArrayUInt
  • m_pvStatusMessageCallbackContext : Rx::ApiLF::SStatusMessageDelegate
  • m_uiLength
: Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayDouble
, Rx::CRxArrayString
, Rx::CRxArrayInt
  • m_xFormat : Rx::CRxImage , Rx::CRxImageMoniker
  • m_xResMgr : Rx::ApiLF::NET::FormLogConsole

- u -

  • uAlphaCnt : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uAlphaSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uColorCnt : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uColorSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • uSize : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >

- v -

  • value : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >


Data Fields - Typedefs

  • Data Structure Index
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • TType : Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
  • TValue
: Rx::CRxArrayUInt
, Rx::CRxArrayUChar
, Rx::CRxArrayString
, Rx::CRxArrayInt
, Rx::CRxArrayDouble


File List

  • File List
  • Globals
File List
Here is a list of all files with brief descriptions:
o * CvCluViz.h
o * CvCluVizEx.h
o * CvCluVizSt.h
o * CvCluVizTool.h
o * Rx.ApiLF.Errors.h
o * Rx.ApiLF.ErrorValues.h
o * Rx.ApiLF.Features.h
o * Rx.ApiLF.FeatureValues.h
o * Rx.ApiLF.h
o * Rx.ApiLF.Net.CtrlLogListView.h
o * Rx.ApiLF.Net.FormLogConsole.h
o * Rx.ApiLF.Net.LogConsoleManager.h
o * Rx.ApiLF.Properties.h
o * Rx.ApiLF.PropertyValues.h
o * Rx.ApiLF.StatusCodes.h
o * Rx.ApiLF.StatusCodeValues.h
o * Rx.ApiLF.StatusMessageDelegateList.h
o * Rx.ApiLF.Types.h
o * RxArrayDouble.h
o * RxArrayInt.h
o * RxArrayString.h
o * RxArrayUChar.h
o * RxArrayUInt.h
o * RxCore.h
o * RxIfcImage.h
o * RxImage.h
o * RxImageFormat.h
o * RxImageMoniker.h
o * RxImageTypes.h
o * RxMetaData.h
o * RxPixel.h
o * RxString.h
o * RxTime.h
\ * RxTypes.h


CvCluViz.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.MT
Namespaces | Macros | Functions
CvCluViz.h File Reference
#include <string>
#include <vector>
#include "Rx.CluViz.Core.Base\CLUVizDefines.h"
#include "Rx.CluViz.Core.Base\CLUVizTypes.h"

Go to the source code of this file.

Namespaces

namespace | CLUViz
namespace | CLUViz::MT

Macros

#define CLUVIZDLL_API __declspec(dllimport)

Functions

bool | CLUViz::MT::_Start (const char *pcEnvPath, const char *pcLicenceKey, bool bInitAll)
CLUVIZDLL_API bool | CLUViz::MT::Create (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle)
CLUVIZDLL_API bool | CLUViz::MT::CreateEx1 (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | CLUViz::MT::CreateEx2 (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | CLUViz::MT::Destroy (int iHandle)
CLUVIZDLL_API bool | CLUViz::MT::DestroyAll ()
CLUVIZDLL_API bool | CLUViz::MT::EnableUserEnd (bool bVal)
CLUVIZDLL_API bool | CLUViz::MT::End ()
CLUVIZDLL_API bool | CLUViz::MT::ExecUser (int iHandle, const char *pcToolName=0)
CLUVIZDLL_API bool | CLUViz::MT::FullScreen (int iHandle, bool bVal=true)
CLUVIZDLL_API bool | CLUViz::MT::FullScreen (int iHandle, bool bVal, bool bEnableUserToggle)
CLUVIZDLL_API bool | CLUViz::MT::GetFileTypeScript (const char *pcFileType, int iMaxLen, char *pcData)
CLUVIZDLL_API void * | CLUViz::MT::GetIconHandle (const char *pcFilename, bool bModule=false)
CLUVIZDLL_API bool | CLUViz::MT::GetKey (unsigned __int32 *pKey)
CLUVIZDLL_API bool | CLUViz::MT::GetLastError (char *pcError, int iMaxLen)
CLUVIZDLL_API void | CLUViz::MT::GetStdEnvPath (char *pcPath, int iMaxLen)
CLUVIZDLL_API bool | CLUViz::MT::GetVarColor (int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha)
CLUVIZDLL_API bool | CLUViz::MT::GetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | CLUViz::MT::GetVarImageData (int iHandle, const char *pcVarName, void *pvData)
CLUVIZDLL_API bool | CLUViz::MT::GetVarImageProp (int iHandle, const char *pcVarName, int &iWidth, int &iHeight, int &iImgType, int &iDataType, int &iBytesPerPixel)
CLUVIZDLL_API bool | CLUViz::MT::GetVarNumber (int iHandle, const char *pcVarName, int &iVal)
CLUVIZDLL_API bool | CLUViz::MT::GetVarNumber (int iHandle, const char *pcVarName, double &dVal)
CLUVIZDLL_API bool | CLUViz::MT::GetVarString (int iHandle, const char *pcVarName, char *pcString, int iMaxLen)
CLUVIZDLL_API bool | CLUViz::MT::GetVarTensor (int iHandle, const char *pcVarName, vector< int > &vecDim, vector< double > &vecData)
CLUVIZDLL_API bool | CLUViz::MT::GetVarTensorData (int iHandle, const char *pcVarName, unsigned *puDim, double *pdData)
CLUVIZDLL_API bool | CLUViz::MT::GetVarTensorProp (int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt)
CLUVIZDLL_API bool | CLUViz::MT::GetVersion (char *pcVersion, int iBufLen)
CLUVIZDLL_API bool | CLUViz::MT::HideWindow (int iHandle)
CLUVIZDLL_API bool | CLUViz::MT::InfoBox (const char *pcText)
CLUVIZDLL_API bool | CLUViz::MT::IsRunning (int iWait)
CLUVIZDLL_API bool | CLUViz::MT::IsViewValid (int iHandle)
CLUVIZDLL_API bool | CLUViz::MT::LoadScript (int iHandle, const char *pcFilename)
CLUVIZDLL_API bool | CLUViz::MT::LoadScript (int iHandle, const char *pcFilename, const char *pcPass)
CLUVIZDLL_API bool | CLUViz::MT::LoadScript (int iHandle, const char *pcFilename, const char *pcPass, int iArgCnt, const char *pcArg)
CLUVIZDLL_API bool | CLUViz::MT::SetScript (int iHandle, const char *pcScript)
CLUVIZDLL_API bool | CLUViz::MT::SetScriptPath (const char *pcPath)
CLUVIZDLL_API bool | CLUViz::MT::SetTimeout (unsigned int uMilliSeconds)
CLUVIZDLL_API bool | CLUViz::MT::SetVarColor (int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha)
CLUVIZDLL_API bool | CLUViz::MT::SetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | CLUViz::MT::SetVarImage (int iHandle, const char *pcVarName, int iWidth, int iHeight, int iImgType, int iDataType, const void *pvData)
CLUVIZDLL_API bool | CLUViz::MT::SetVarNumber (int iHandle, const char *pcVarName, int iVal)
CLUVIZDLL_API bool | CLUViz::MT::SetVarNumber (int iHandle, const char *pcVarName, double dVal)
CLUVIZDLL_API bool | CLUViz::MT::SetVarString (int iHandle, const char *pcVarName, const char *pcString)
CLUVIZDLL_API bool | CLUViz::MT::SetVarTensor (int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData)
CLUVIZDLL_API bool | CLUViz::MT::SetWindowPosSize (int iHandle, int iX, int iY, int iWidth, int iHeight)
CLUVIZDLL_API bool | CLUViz::MT::ShowWindow (int iHandle)
CLUVIZDLL_API bool | CLUViz::MT::Start (const char *pcEnvPath=0, const char *pcLicenceKey=0)
CLUVIZDLL_API bool | CLUViz::MT::StartAgain (const char *pcEnvPath=0, const char *pcLicenceKey=0)
CLUVIZDLL_API bool | CLUViz::MT::WaitForEnd ()

Macro Definition Documentation

#define CLUVIZDLL_API __declspec(dllimport)


CvCluVizEx.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.MT
Namespaces | Functions
CvCluVizEx.h File Reference

Go to the source code of this file.

Namespaces

namespace | CLUViz
namespace | CLUVizST

Functions

CLUVIZDLL_API bool | CLUViz::CheckFeature (__int32 iFeature)
CLUVIZDLL_API bool | CLUViz::CreateEx (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | CLUVizST::CreateEx (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle, const char *pcInitScript, const char *pcCLUPath, bool bVizOnly, bool bShowIntro, void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle)
CLUVIZDLL_API bool | CLUVizST::EnableBorder (int iHandle, bool bVal)
CLUVIZDLL_API bool | CLUVizST::End ()
CLUVIZDLL_API bool | CLUVizST::Run ()
CLUVIZDLL_API bool | CLUVizST::RunMsg (__int64 hWnd, unsigned uMsg, unsigned wParam, long lParam)
CLUVIZDLL_API bool | CLUVizST::Start ()


CvCluVizSt.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.ST
Namespaces | Macros | Functions
CvCluVizSt.h File Reference
#include <string>
#include <vector>
#include "Rx.CluViz.Core.Base\CLUVizDefines.h"
#include "Rx.CluViz.Core.Base\CLUVizTypes.h"

Go to the source code of this file.

Namespaces

namespace | CLUViz
namespace | CLUViz::ST

Macros

#define CLUVIZDLL_API __declspec(dllimport)

Functions

CLUVIZDLL_API bool | CLUViz::ST::EmbedWindow (int &iHandle, __int64 hWnd, bool bCreateSRC=false, __int64 *phGlRc=0)
CLUVIZDLL_API bool | CLUViz::ST::EnableVisualization (int iHandle, bool bVal)
CLUVIZDLL_API bool | CLUViz::ST::End ()
CLUVIZDLL_API bool | CLUViz::ST::EW_ActiveMouseMove (int iHandle, int iX, int iY)
CLUVIZDLL_API bool | CLUViz::ST::EW_Display (int iHandle, bool bWait=false)
CLUVIZDLL_API bool | CLUViz::ST::EW_ExecUser (int iHandle, const char *pcToolName=0)
CLUVIZDLL_API bool | CLUViz::ST::EW_IdleFunc (int iHandle)
CLUVIZDLL_API bool | CLUViz::ST::EW_Keyboard (int iHandle, int iKey, bool bKeyDown)
CLUVIZDLL_API bool | CLUViz::ST::EW_LoadScript (int iHandle, const char *pcFilename, const char *pcPass=0)
CLUVIZDLL_API bool | CLUViz::ST::EW_LockVis (int iHandle, bool bLock)
CLUVIZDLL_API bool | CLUViz::ST::EW_MakeCurrentSRC (int iHandle)
CLUVIZDLL_API bool | CLUViz::ST::EW_Mouse (int iHandle, int iButton, int iState, int iX, int iY)
CLUVIZDLL_API bool | CLUViz::ST::EW_PassiveMouseMove (int iHandle, int iX, int iY)
CLUVIZDLL_API bool | CLUViz::ST::EW_Reshape (int iHandle, int iWidth, int iHeight)
CLUVIZDLL_API bool | CLUViz::ST::EW_SetKeyModifierStates (int iHandle, bool bShift, bool bCtrl, bool bAlt, bool bNumLock, bool bCapsLock, bool bScrollLock)
CLUVIZDLL_API bool | CLUViz::ST::EW_SetScript (int iHandle, const char *pcScript, bool bResetEnv=false, bool bReparseLatex=false)
CLUVIZDLL_API bool | CLUViz::ST::GetKey (unsigned __int32 *pKey)
CLUVIZDLL_API bool | CLUViz::ST::GetLastError (char *pcError, int iMaxLen)
CLUVIZDLL_API bool | CLUViz::ST::GetScriptOutput (int iHandle, char *pcText, int iMaxLen, bool &bIsError)
CLUVIZDLL_API void | CLUViz::ST::GetStdEnvPath (char *pcPath, int iMaxLen)
CLUVIZDLL_API bool | CLUViz::ST::GetVarColor (int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha)
CLUVIZDLL_API bool | CLUViz::ST::GetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | CLUViz::ST::GetVarImageData (int iHandle, const char *pcVarName, void *pvData)
CLUVIZDLL_API bool | CLUViz::ST::GetVarImageProp (int iHandle, const char *pcVarName, int &iWidth, int &iHeight, int &iImgType, int &iDataType, int &iBytesPerPixel)
CLUVIZDLL_API bool | CLUViz::ST::GetVarNumber (int iHandle, const char *pcVarName, int &iVal)
CLUVIZDLL_API bool | CLUViz::ST::GetVarNumber (int iHandle, const char *pcVarName, double &dVal)
CLUVIZDLL_API bool | CLUViz::ST::GetVarString (int iHandle, const char *pcVarName, char *pcString, int iMaxLen)
CLUVIZDLL_API bool | CLUViz::ST::GetVarTensorData (int iHandle, const char *pcVarName, unsigned *puDim, double *pdData)
CLUVIZDLL_API bool | CLUViz::ST::GetVarTensorProp (int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt)
CLUVIZDLL_API bool | CLUViz::ST::GetVersion (char *pcVersion, int iBufLen)
CLUVIZDLL_API bool | CLUViz::ST::ReleaseAll ()
CLUVIZDLL_API bool | CLUViz::ST::ReleaseWindow (int iHandle)
CLUVIZDLL_API bool | CLUViz::ST::SaveView (int iHandle, const char *pcFilename)
CLUVIZDLL_API bool | CLUViz::ST::SetScriptPath (const char *pcPath)
CLUVIZDLL_API bool | CLUViz::ST::SetVarColor (int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha)
CLUVIZDLL_API bool | CLUViz::ST::SetVarColor (int iHandle, const char *pcVarName, double *pdColor4)
CLUVIZDLL_API bool | CLUViz::ST::SetVarImage (int iHandle, const char *pcVarName, int iWidth, int iHeight, int iImgType, int iDataType, const void *pvData)
CLUVIZDLL_API bool | CLUViz::ST::SetVarNumber (int iHandle, const char *pcVarName, int iVal)
CLUVIZDLL_API bool | CLUViz::ST::SetVarNumber (int iHandle, const char *pcVarName, double dVal)
CLUVIZDLL_API bool | CLUViz::ST::SetVarObject (int iHandle, const char *pcVarName, const CLUViz::SObject *pData)
CLUVIZDLL_API bool | CLUViz::ST::SetVarString (int iHandle, const char *pcVarName, const char *pcString)
CLUVIZDLL_API bool | CLUViz::ST::SetVarTensor (int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData)
CLUVIZDLL_API bool | CLUViz::ST::Start (const char *pcEnvPath=0, const char *pcLicenceKey=0, bool bAlone=true)

Macro Definition Documentation

#define CLUVIZDLL_API __declspec(dllimport)


CvCluVizTool.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.CluVizTool
Namespaces | Macros | Functions
CvCluVizTool.h File Reference
#include "Rx.Interop.Runtime28\RxIfcImage.h"

Go to the source code of this file.

Namespaces

namespace | CLUViz
namespace | CLUViz::Tool

Macros

#define CLUVIZTOOL_API __declspec(dllimport)

Functions

CLUVIZTOOL_API bool | CLUViz::Tool::CreateViewImage (int &iHandle, int iX, int iY, int iWidth, int iHeight, const char *pcTitle)
CLUVIZTOOL_API bool | CLUViz::Tool::DestroyView (int iHandle)
CLUVIZTOOL_API bool | CLUViz::Tool::Finalize (void)
CLUVIZTOOL_API const char * | CLUViz::Tool::GetLastError (bool bReset=true)
CLUVIZTOOL_API bool | CLUViz::Tool::Init (const char *pcEnvPath=0)
CLUVIZTOOL_API bool | CLUViz::Tool::ReadImage (const char *pcFilename, Rx::Interop::Runtime28::IImage *pImage)
CLUVIZTOOL_API bool | CLUViz::Tool::ViewSetImage (int iHandle, Rx::Interop::Runtime28::IImage *pImage, bool bUpdate=false)
CLUVIZTOOL_API bool | CLUViz::Tool::WriteImage (const char *pcFilename, const Rx::Interop::Runtime28::IImage *pImage)

Macro Definition Documentation

#define CLUVIZTOOL_API __declspec(dllimport)


Rx.ApiLF.Errors.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.Errors.h File Reference
#include "Rx.ApiLF.ErrorValues.h"

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::EError
Error IDs of Raytrix API.
namespace | Rx::ApiLF::EWarning
Values that represent EWarning.

Enumerations

enum Rx::ApiLF::EError::ID {
Rx::ApiLF::EError::NONE = 0, Rx::ApiLF::EError::COMPUTE = -1, Rx::ApiLF::EError::OUTOFMEMORY = -100, Rx::ApiLF::EError::OUTOFRANGE = -101, Rx::ApiLF::EError::INVALID_POINTER = -102, Rx::ApiLF::EError::INSTALL = -103, Rx::ApiLF::EError::INTERNAL = -104, Rx::ApiLF::EError::API_INIT = -1000,
Rx::ApiLF::EError::API_NOINIT = -1001, Rx::ApiLF::EError::API_LOADFILE = -1002, Rx::ApiLF::EError::API_INVALID_IMGID = -1003, Rx::ApiLF::EError::API_NOLFIBOUND = -1004, Rx::ApiLF::EError::API_INVALID_IMAGE = -1005, Rx::ApiLF::EError::API_SAVEFILE = -1006, Rx::ApiLF::EError::API_INITAGAIN = -1007, Rx::ApiLF::EError::API_UNKNOWN = -1008,
Rx::ApiLF::EError::API_INSTPATH = -1009, Rx::ApiLF::EError::API_DONGLE = -1010, Rx::ApiLF::EError::API_FEATURE = -1011, Rx::ApiLF::EError::API_INVALID_GLTEX = -1012, Rx::ApiLF::EError::API_INVALID_IMGTYPE = -1013, Rx::ApiLF::EError::API_INVALID_VALUE = -1014, Rx::ApiLF::EError::API_LFI_BIND = -1015, Rx::ApiLF::EError::API_LFI_BOUND = -1016,
Rx::ApiLF::EError::API_VERSION = -1017, Rx::ApiLF::EError::PAR_EXIST = -2000, Rx::ApiLF::EError::PAR_TYPE = -2001, Rx::ApiLF::EError::PAR_ACSREAD = -2002, Rx::ApiLF::EError::PAR_ACSWRITE = -2003, Rx::ApiLF::EError::PAR_READ = -2004, Rx::ApiLF::EError::PAR_WRITE = -2005, Rx::ApiLF::EError::PAR_VALUE = -2006,
Rx::ApiLF::EError::PAR_NOCONSTR = -2007, Rx::ApiLF::EError::PAR_INVCONSTR = -2008, Rx::ApiLF::EError::PAR_GRPEXIST = -2009, Rx::ApiLF::EError::PAR_NOTSUPPORTED = -2010, Rx::ApiLF::EError::PAR_NOTAVAILABLE = -2011, Rx::ApiLF::EError::CUDA_MAX = -3000, Rx::ApiLF::EError::CUDA_INIT = -3000, Rx::ApiLF::EError::CUDA_NODEVICE = -3001,
Rx::ApiLF::EError::CUDA_CAPA = -3002, Rx::ApiLF::EError::CUDA_ALGO = -3003, Rx::ApiLF::EError::CUDA_INITAGAIN = -3004, Rx::ApiLF::EError::CUDA_NOINIT = -3005, Rx::ApiLF::EError::CUDA_INVDEVID = -3006, Rx::ApiLF::EError::CUDA_MIN = -3999, Rx::ApiLF::EError::CAMDRV_INIT = -4000, Rx::ApiLF::EError::CAMDRV_INITAGAIN = -4001,
Rx::ApiLF::EError::CAMDRV_NOINIT = -4002, Rx::ApiLF::EError::CAMDRV_INVCAMID = -4003, Rx::ApiLF::EError::CAMERA_OPEN = -4100, Rx::ApiLF::EError::CAMERA_CLOSE = -4101, Rx::ApiLF::EError::CAMERA_STARTCAP = -4102, Rx::ApiLF::EError::CAMERA_STOPCAP = -4103, Rx::ApiLF::EError::CAMERA_CAPACTIVE = -4104, Rx::ApiLF::EError::CAMERA_CAPNOTACTIVE = -4105,
Rx::ApiLF::EError::CAMERA_CAPTURE = -4106, Rx::ApiLF::EError::CAMERA_ACTIVE = -4107, Rx::ApiLF::EError::CAMERA_NOTACTIVE = -4108, Rx::ApiLF::EError::CAMERA_NOCALFILE = -4109, Rx::ApiLF::EError::CAMERA_INVCALFILE = -4110, Rx::ApiLF::EError::CAMERA_STORECALFILE = -4111, Rx::ApiLF::EError::CAMERA_LENSSETNEW = -4112, Rx::ApiLF::EError::CAMERA_LENSSETEXIST = -4113,
Rx::ApiLF::EError::CAMERA_LENSSETDEL = -4114, Rx::ApiLF::EError::CAMERA_LENSNEW = -4115, Rx::ApiLF::EError::CAMERA_LENSIDEXIST = -4116, Rx::ApiLF::EError::CAMERA_LENSDEL = -4117, Rx::ApiLF::EError::CAMERA_STOREIMGWHITE = -4118, Rx::ApiLF::EError::CAMERA_NOIMGWHITE = -4119, Rx::ApiLF::EError::CAMERA_UPDATECALIB = -4120, Rx::ApiLF::EError::CAMERA_SUSPENDCAP = -4121,
Rx::ApiLF::EError::CAMERA_CALFILEEXIST = -4122, Rx::ApiLF::EError::CAMERA_CREATECALFILE = -4123, Rx::ApiLF::EError::CAMERA_LENSDEL_LAST_LENS = -4124, Rx::ApiLF::EError::CAMERA_TIMEOUT = -4125, Rx::ApiLF::EError::CAMERA_TRIGGERMODE_NOT_AVAILABLE = -4126, Rx::ApiLF::EError::CAMERA_CAPTURE_STOPPED_UNEXPECTED = -4127, Rx::ApiLF::EError::CAMERA_CAPTURE_EXCEPTION = -4128, Rx::ApiLF::EError::CAMERA_CAPTURE_INTERNAL_API = -4129,
Rx::ApiLF::EError::CAMCAL_NOLENS = -4200, Rx::ApiLF::EError::CAMCAL_NOLENSSET = -4201, Rx::ApiLF::EError::CAMCAL_INVLENSIDX = -4202, Rx::ApiLF::EError::CAMCAL_INVLENSSETIDX = -4203, Rx::ApiLF::EError::GL_NOINTEROP = -5000, Rx::ApiLF::EError::GL_TEXNOTSUPPORTED = -5001, Rx::ApiLF::EError::IMG_NOTSUPPORTED = -6000, Rx::ApiLF::EError::IMG_DITNOTSUPPORTED = -6001,
Rx::ApiLF::EError::RAYSEQ_OPENREAD = -7000, Rx::ApiLF::EError::RAYSEQ_OPENWRITE = -7001, Rx::ApiLF::EError::RAYSEQ_READ = -7002, Rx::ApiLF::EError::RAYSEQ_WRITE = -7003, Rx::ApiLF::EError::RAYSEQ_INVALID = -7004, Rx::ApiLF::EError::RAYSEQ_VERSION = -7005, Rx::ApiLF::EError::RAYSEQ_CLOSE = -7006, Rx::ApiLF::EError::RAYSEQ_NOTOPEN = -7007,
Rx::ApiLF::EError::RAYSEQ_EOF = -7008, Rx::ApiLF::EError::RAYSEQ_SOF = -7009, Rx::ApiLF::EError::RAYSEQ_COMPRESS = -7010, Rx::ApiLF::EError::RAYSEQ_UNCOMPRESS = -7011, Rx::ApiLF::EError::RAYSEQ_UNKOWNCOMP = -7012, Rx::ApiLF::EError::RAYSEQ_UNSUPPIXTYPE = -7013, Rx::ApiLF::EError::RAYSEQ_WHITEIMAGE = -7014, Rx::ApiLF::EError::RAYSEQ_BIND = -7015,
Rx::ApiLF::EError::RAYSEQ_IMAGEFORMAT = -7016, Rx::ApiLF::EError::RAYSEQ_WRITEINIT = -7017, Rx::ApiLF::EError::RAYSEQ_SETFRAMEIDX = -7018, Rx::ApiLF::EError::RAYSEQ_AUTOWRITE = -7094, Rx::ApiLF::EError::RAYSEQ_NOREAD = -7095, Rx::ApiLF::EError::RAYSEQ_NOWRITE = -7096, Rx::ApiLF::EError::RAYSEQ_NOT_BOUND = -7097, Rx::ApiLF::EError::RAYSEQ_ALREADY_BOUND = -7098,
Rx::ApiLF::EError::RAYSEQ_INVALID_ID = -7099, Rx::ApiLF::EError::RAYSEQ_INTERNAL = -7100
}
Error IDs. More...
enum Rx::ApiLF::EWarning::ID { Rx::ApiLF::EWarning::NONE = 0, Rx::ApiLF::EWarning::GENERAL = 1, Rx::ApiLF::EWarning::CAMERA_CORRUPTDB = 4100, Rx::ApiLF::EWarning::CAMERA_CAPTURE_NOIMAGE = 4101, Rx::ApiLF::EWarning::CAMERA_INVWHITETYPE = 4102, Rx::ApiLF::EWarning::CAMERA_CAPTURE_STOPPED = 4103, Rx::ApiLF::EWarning::CAMERA_TYPE_MISMATCH = 4104 }


Rx.ApiLF.ErrorValues.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.ErrorValues.h File Reference

Go to the source code of this file.

Namespaces

namespace | EError
Error IDs of Raytrix API.
namespace | EWarning
Values that represent EWarning.

Enumerations

enum EError::ID {
EError::NONE = 0, EError::COMPUTE = -1, EError::OUTOFMEMORY = -100, EError::OUTOFRANGE = -101, EError::INVALID_POINTER = -102, EError::INSTALL = -103, EError::INTERNAL = -104, EError::API_INIT = -1000,
EError::API_NOINIT = -1001, EError::API_LOADFILE = -1002, EError::API_INVALID_IMGID = -1003, EError::API_NOLFIBOUND = -1004, EError::API_INVALID_IMAGE = -1005, EError::API_SAVEFILE = -1006, EError::API_INITAGAIN = -1007, EError::API_UNKNOWN = -1008,
EError::API_INSTPATH = -1009, EError::API_DONGLE = -1010, EError::API_FEATURE = -1011, EError::API_INVALID_GLTEX = -1012, EError::API_INVALID_IMGTYPE = -1013, EError::API_INVALID_VALUE = -1014, EError::API_LFI_BIND = -1015, EError::API_LFI_BOUND = -1016,
EError::API_VERSION = -1017, EError::PAR_EXIST = -2000, EError::PAR_TYPE = -2001, EError::PAR_ACSREAD = -2002, EError::PAR_ACSWRITE = -2003, EError::PAR_READ = -2004, EError::PAR_WRITE = -2005, EError::PAR_VALUE = -2006,
EError::PAR_NOCONSTR = -2007, EError::PAR_INVCONSTR = -2008, EError::PAR_GRPEXIST = -2009, EError::PAR_NOTSUPPORTED = -2010, EError::PAR_NOTAVAILABLE = -2011, EError::CUDA_MAX = -3000, EError::CUDA_INIT = -3000, EError::CUDA_NODEVICE = -3001,
EError::CUDA_CAPA = -3002, EError::CUDA_ALGO = -3003, EError::CUDA_INITAGAIN = -3004, EError::CUDA_NOINIT = -3005, EError::CUDA_INVDEVID = -3006, EError::CUDA_MIN = -3999, EError::CAMDRV_INIT = -4000, EError::CAMDRV_INITAGAIN = -4001,
EError::CAMDRV_NOINIT = -4002, EError::CAMDRV_INVCAMID = -4003, EError::CAMERA_OPEN = -4100, EError::CAMERA_CLOSE = -4101, EError::CAMERA_STARTCAP = -4102, EError::CAMERA_STOPCAP = -4103, EError::CAMERA_CAPACTIVE = -4104, EError::CAMERA_CAPNOTACTIVE = -4105,
EError::CAMERA_CAPTURE = -4106, EError::CAMERA_ACTIVE = -4107, EError::CAMERA_NOTACTIVE = -4108, EError::CAMERA_NOCALFILE = -4109, EError::CAMERA_INVCALFILE = -4110, EError::CAMERA_STORECALFILE = -4111, EError::CAMERA_LENSSETNEW = -4112, EError::CAMERA_LENSSETEXIST = -4113,
EError::CAMERA_LENSSETDEL = -4114, EError::CAMERA_LENSNEW = -4115, EError::CAMERA_LENSIDEXIST = -4116, EError::CAMERA_LENSDEL = -4117, EError::CAMERA_STOREIMGWHITE = -4118, EError::CAMERA_NOIMGWHITE = -4119, EError::CAMERA_UPDATECALIB = -4120, EError::CAMERA_SUSPENDCAP = -4121,
EError::CAMERA_CALFILEEXIST = -4122, EError::CAMERA_CREATECALFILE = -4123, EError::CAMERA_LENSDEL_LAST_LENS = -4124, EError::CAMERA_TIMEOUT = -4125, EError::CAMERA_TRIGGERMODE_NOT_AVAILABLE = -4126, EError::CAMERA_CAPTURE_STOPPED_UNEXPECTED = -4127, EError::CAMERA_CAPTURE_EXCEPTION = -4128, EError::CAMERA_CAPTURE_INTERNAL_API = -4129,
EError::CAMCAL_NOLENS = -4200, EError::CAMCAL_NOLENSSET = -4201, EError::CAMCAL_INVLENSIDX = -4202, EError::CAMCAL_INVLENSSETIDX = -4203, EError::GL_NOINTEROP = -5000, EError::GL_TEXNOTSUPPORTED = -5001, EError::IMG_NOTSUPPORTED = -6000, EError::IMG_DITNOTSUPPORTED = -6001,
EError::RAYSEQ_OPENREAD = -7000, EError::RAYSEQ_OPENWRITE = -7001, EError::RAYSEQ_READ = -7002, EError::RAYSEQ_WRITE = -7003, EError::RAYSEQ_INVALID = -7004, EError::RAYSEQ_VERSION = -7005, EError::RAYSEQ_CLOSE = -7006, EError::RAYSEQ_NOTOPEN = -7007,
EError::RAYSEQ_EOF = -7008, EError::RAYSEQ_SOF = -7009, EError::RAYSEQ_COMPRESS = -7010, EError::RAYSEQ_UNCOMPRESS = -7011, EError::RAYSEQ_UNKOWNCOMP = -7012, EError::RAYSEQ_UNSUPPIXTYPE = -7013, EError::RAYSEQ_WHITEIMAGE = -7014, EError::RAYSEQ_BIND = -7015,
EError::RAYSEQ_IMAGEFORMAT = -7016, EError::RAYSEQ_WRITEINIT = -7017, EError::RAYSEQ_SETFRAMEIDX = -7018, EError::RAYSEQ_AUTOWRITE = -7094, EError::RAYSEQ_NOREAD = -7095, EError::RAYSEQ_NOWRITE = -7096, EError::RAYSEQ_NOT_BOUND = -7097, EError::RAYSEQ_ALREADY_BOUND = -7098,
EError::RAYSEQ_INVALID_ID = -7099, EError::RAYSEQ_INTERNAL = -7100
}
Error IDs. More...
enum EWarning::ID { EWarning::NONE = 0, EWarning::GENERAL = 1, EWarning::CAMERA_CORRUPTDB = 4100, EWarning::CAMERA_CAPTURE_NOIMAGE = 4101, EWarning::CAMERA_INVWHITETYPE = 4102, EWarning::CAMERA_CAPTURE_STOPPED = 4103, EWarning::CAMERA_TYPE_MISMATCH = 4104 }


Rx.ApiLF.Features.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.Features.h File Reference
#include "Rx.ApiLF.FeatureValues.h"

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::EFeature
Values that represent EError.

Enumerations

enum Rx::ApiLF::EFeature::ID { Rx::ApiLF::EFeature::None = 0, Rx::ApiLF::EFeature::Standard = 0x0001, Rx::ApiLF::EFeature::MultiView = 0x0002, Rx::ApiLF::EFeature::FocusOnSurface = 0x0004, Rx::ApiLF::EFeature::Calculate3D = 0x0008, Rx::ApiLF::EFeature::Calibrate = 0x0010, Rx::ApiLF::EFeature::RawImage = 0x0020, Rx::ApiLF::EFeature::Save = 0x0040 }
Available features of the lightfield API. More...


Rx.ApiLF.FeatureValues.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.FeatureValues.h File Reference

Go to the source code of this file.

Namespaces

namespace EFeature
Values that represent EError.

Enumerations

enum EFeature::ID { EFeature::None = 0, EFeature::Standard = 0x0001, EFeature::MultiView = 0x0002, EFeature::FocusOnSurface = 0x0004, EFeature::Calculate3D = 0x0008, EFeature::Calibrate = 0x0010, EFeature::RawImage = 0x0020, EFeature::Save = 0x0040 }
Available features of the lightfield API. More...


Rx.ApiLF.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Namespaces | Macros | Functions
Rx.ApiLF.h File Reference
#include "Rx.Core\RxCore.h"
#include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Errors.h"
#include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Properties.h"
#include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Types.h"
#include "Rx.ApiLF.Lib.Base\Rx.ApiLF.StatusCodes.h"
#include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Features.h"

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::ApiLF

Macros

#define | DEPRECATED __declspec(deprecated)
#define | RX_TRY(theFunc)
Macro to test whether an API function was executed successfully. More...
#define | RXLF_API __declspec(dllimport)

Functions

RXLF_API bool | Rx::ApiLF::AddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RxAddStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RxCalibGrid ()
Calibrate the microimage grid. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibCreate (unsigned uCamIdx, bool bForce)
Create a new camera calibration database. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibDeleteLens (unsigned uCamIdx)
Delete the currently selected calibration database entry of a lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibDeleteLensSetting (unsigned uCamIdx)
Delete the currently selected calibration database entry for a lens setting. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLens (unsigned uCamIdx, const Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName)
Create a calibration database enty for a new lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLens (unsigned uCamIdx, Rx::CRxString &sxLensID, const Rx::CRxString &sxLensName, bool bCreateID)
Create a calibration database enty for a new lens. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibNewLensSetting (unsigned uCamIdx, double dFStop, double dFocus)
Create a new calibration database entry for a lens setting. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibStore (unsigned uCamIdx)
Store the calibration database in the camera calibration file. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibStoreWhiteImage (unsigned uCamIdx, unsigned uImgCnt)
Capture a number of images to create a new white image. More...
RXLF_API bool | Rx::ApiLF::RxCamCalibUpdate (unsigned uCamIdx)
Update the lightfield calibration data. More...
RXLF_API bool | Rx::ApiLF::RxCamClose (unsigned uCamIdx)
Close a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamDoCapture (unsigned uCamIdx)
Capture a single image from a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamDriverInit ()
Initialize the camera drivers. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, Rx::CRxString &sxValue)
Get a camera parameter of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, unsigned &uValue)
Get a camera parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamGetPar (unsigned uCamIdx, EPar::ID ePar, double &dValue)
Get camera parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the parameter range of a camera parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, double &dMin, double &dMax)
Get the parameter range of a camera parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamGetParRange (unsigned uCamIdx, EPar::ID ePar, Rx::CRxArrayUInt &auValues)
Get set of available values for parameter of type unsigned. More...
RXLF_API bool | Rx::ApiLF::RxCamOpen (unsigned uCamIdx)
Open a camera. More...
RXLF_API bool | Rx::ApiLF::RxCamRegister ()
Register available cameras. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const Rx::CRxString &sxValue)
Set a camera property of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const unsigned &uValue)
Set a camera property of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxCamSetPar (unsigned uCamIdx, EPar::ID ePar, const double &dValue)
Set a camera property of type double. More...
RXLF_API bool | Rx::ApiLF::RxCamStartCapture (unsigned uCamIdx, unsigned &hRay)
Prepare camera for capturing images. More...
RXLF_API bool | Rx::ApiLF::RxCamStopCapture (unsigned uCamIdx)
Stop capturing images. More...
RXLF_API bool | Rx::ApiLF::RxCamSupPar (unsigned uCamIdx, EPar::ID ePar, bool &bSupported)
Test whether a camera parameter is supported by the selected camera. More...
RXLF_API bool | Rx::ApiLF::RxCamSuspendCapture (unsigned uCamIdx, bool bSuspend)
Suspend capturing images. More...
RXLF_API bool | Rx::ApiLF::RxConvertImage (Rx::CRxImage &xDstImage, const Rx::CRxImage &xSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | Rx::ApiLF::RxConvertImage (Rx::IImage *pDstImage, const Rx::IImage *pSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType, bool bCreate)
Convert a Rx::CRxImage to a new pixel and data type. More...
RXLF_API bool | Rx::ApiLF::RxCudaDeviceCount (int &iDeviceCount)
Returns the number of CUDA devices installed. More...
RXLF_API bool | Rx::ApiLF::RxCudaDeviceMemInfo (unsigned &uFreeMem, unsigned &uTotalMem)
Return free and total amount of memory on the selected CUDA device. More...
RXLF_API bool | Rx::ApiLF::RxCudaDeviceProp (int iDevice, Rx::CRxString &sxName, unsigned &iCCMajor, unsigned &iCCMinor)
Get the name and the compute capability major and minor version for a CUDA device. More...
RXLF_API bool | Rx::ApiLF::RxCudaSelectDevice (int iDevice=-1, bool bUseGL=false)
Select a CUDA device. More...
RXLF_API bool | Rx::ApiLF::RxDepth (bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxDepth ()
Evaluate the scene depth from a bound ray image. More...
RXLF_API bool | Rx::ApiLF::RxDepthColorCode (double dRelDepthMin=0.0, double dRelDepthMax=1.0, EImgID::ID eTrgImgID=EImgID::DepthCol)
Color code depth images. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxDepthEx (double dViewOffX, double dViewOffY, bool bUpdate=false)
Evaluate the scene depth from a bound ray image with a given view offset. More...
RXLF_API bool | Rx::ApiLF::RxDepthMap (double dStdDepth, int iWidth, int iHeight, double *pdData, unsigned uElCnt, EImgID::ID eTrgImgID=EImgID::Depth)
Generate a depth map from a set of coordinates. More...
RXLF_API bool | Rx::ApiLF::RxDongleGetID (int &iDngID, int &iRxID)
Get the IDs of an attached dongle. More...
RXLF_API bool | Rx::ApiLF::RxDongleReinitialize ()
RXLF_API bool | Rx::ApiLF::RxFinalize (void)
Close any open cameras and free all memory allocated on CUDA device and in host memory. More...
RXLF_API bool | Rx::ApiLF::RxFocusOnPlane ()
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis, i.e. parallel to the image plane. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnPlaneEx (double dRelDepth, double dViewOffX=0.0, double dViewOffY=0.0)
Focus image to a plane perpendicular to the optical axis, and select view point. More...
RXLF_API bool | Rx::ApiLF::RxFocusOnSurface ()
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnSurface (double dStdDepth)
Focus on a depth surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxFocusOnSurfaceEx (double dStdDepth, double dViewOffX, double dViewOffY)
Focus on surface and select view point. More...
RXLF_API bool | Rx::ApiLF::RxGetImage (EImgID::ID eImgID, Rx::CRxImage &xImage)
Get an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImage (EImgID::ID eImgID, Rx::IImage *pImage, bool bCreate)
Get an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageDevicePointer (EImgID::ID eImgID, void *&pDevicePtr)
Get the device pointer of an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageFormat (EImgID::ID eImgID, Rx::CRxImageFormat &xF)
Get the image format of an internal image. More...
RXLF_API bool | Rx::ApiLF::RxGetImageHistogram (EImgID::ID eImgID, Rx::CRxArrayUInt &xHistogram)
Calculate the histogram of a given image. More...
RXLF_API int | Rx::ApiLF::RxGetLastError (Rx::CRxString &sxError, bool bClear=true)
Obtain the error code and string of the last error that occured and reset the error. More...
RXLF_API int | Rx::ApiLF::RxGetLastErrorReport (Rx::CRxString &sxError, bool bClear=true)
Obtain the full incident report on the last error. More...
RXLF_API double | Rx::ApiLF::RxGetLastExecTime ()
Get last execution time of a CUDA algorithm. More...
RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, unsigned &uValue)
Get a parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, double &dValue)
Get a parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxGetPar (EPar::ID ePar, Rx::CRxString &sValue)
Get a parameter of type Rx::CRxString. More...
RXLF_API bool | Rx::ApiLF::RxGetParName (EPar::ID ePar, Rx::CRxString &sValue)
Get the string representation of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxGetParRange (EPar::ID ePar, unsigned &uMin, unsigned &uMax)
Get the range of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxGetParRange (EPar::ID ePar, double &dMin, double &dMax)
Get the range of a parameter. More...
RXLF_API bool | Rx::ApiLF::RxGetRegistryString (const Rx::CRxString &sxPath, Rx::CRxString &sxValue)
Read a string from the Windows registry. More...
RXLF_API double | Rx::ApiLF::RxGetTime ()
Get a time measured in milliseconds as double value. More...
RXLF_API __int64 | Rx::ApiLF::RxGetTime64 ()
Get a time in milliseconds as 64 bit integer value. More...
RXLF_API bool | Rx::ApiLF::RxGlGetVersion (int &iMajor, int &iMinor)
Get OpenGL version of current OpenGL rendering context. More...
RXLF_API bool | Rx::ApiLF::RxGlUpdateTex (unsigned uIntImgIDs)
Copy CUDA result images to OpenGL textures. More...
RXLF_API bool | Rx::ApiLF::RxGrid ()
Show a lens grid overlay on the raw ray image. More...
RXLF_API bool | Rx::ApiLF::RxHasFeature (unsigned uID)
Test whether the API offers a particular feature. More...
RXLF_API bool | Rx::ApiLF::RxInit (bool bInitCuda, const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...
RXLF_API bool | Rx::ApiLF::RxInit (const Rx::CRxString &sxLibPath=Rx::CRxString(), const Rx::CRxString &sxCalibPath=Rx::CRxString(), void *pData=0)
Initialize the Raytrix API. More...
RXLF_API bool | Rx::ApiLF::RxIsImageValid (EImgID::ID eImgID)
Test whether an internal image is valid. More...
RXLF_API bool | Rx::ApiLF::RxLoadPar (const Rx::CRxString &sxFilename)
Load all API parameters from file. More...
RXLF_API bool | Rx::ApiLF::RxLogConsoleAddMessage (Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSource, const char *pcMessage, int iValue)
RXLF_API bool | Rx::ApiLF::RxLogConsoleClose ()
RXLF_API bool | Rx::ApiLF::RxLogConsoleShow ()
RXLF_API bool | Rx::ApiLF::RxPreProcess ()
Pre-Process a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayBind (unsigned hRay)
Bind a ray image to perform computations on. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibLoad (unsigned hRay, const Rx::CRxString &sxFilename)
Load calibration data of ray image from XML file. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibNew (unsigned hRay, int iLensTypeCount, double dLensDia, double dPixSize, double dOffsetX, double dOffsetY, double dRotDeg, double dLensBorder, int iRot90Cnt, bool bReflectX, bool bReflectY)
Create a new calibration data set. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibSave (unsigned hRay, const Rx::CRxString &sxFilename)
Save calibration data of ray image in XML format. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibXmlGet (unsigned hRay, Rx::CRxString &sxXml)
Get the calibration data of the given ray image as XML string. More...
RXLF_API bool | Rx::ApiLF::RxRayCalibXmlSet (unsigned hRay, const Rx::CRxString &sxXml)
Set the calibration data of the given ray image from an XML string. More...
RXLF_API bool | Rx::ApiLF::RxRayDelete (unsigned hRay)
Delete the image with the given ID. More...
RXLF_API bool | Rx::ApiLF::RxRayGetFormat (unsigned hRay, Rx::CRxImageFormat &xF)
Get the image format of a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetFormatEx (unsigned hRay, Rx::CRxImageFormat &xF, void *pData)
Get extended format information on ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetMetaData (unsigned uImgID, Rx::CRxMetaData &xMetaData)
Get meta data of a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayGetRaw (unsigned hRay, Rx::CRxImage &xRawImage)
Get the ray image as Rx::CRxImage instance. More...
RXLF_API bool | Rx::ApiLF::RxRayGetRaw (unsigned hRay, Rx::IImage *pRawImage, bool bCreate)
Get the ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayLoad (unsigned &hRay, const Rx::CRxString &sxFilename)
Load a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRayNew (unsigned &hRay, const Rx::CRxImageFormat &xF)
Create a new ray image. More...
RXLF_API bool | Rx::ApiLF::RxRaySave (unsigned hRay, const Rx::CRxString &sxFilename)
Save a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqBind (unsigned uRaySeqID, unsigned &uImgID)
Bind a ray sequence for use by other API functions. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqClose (unsigned uRaySeqID)
Close a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFileSize (unsigned uRaySeqID, unsigned __int64 &uFileSize)
Get the total file size of the ray sequence in bytes. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameBufferUsedCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frame buffers in use. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameCount (unsigned uRaySeqID, unsigned &uFrameCount)
Get number of frames in ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqGetFrameIndex (unsigned uRaySeqID, unsigned &uFrameIdx)
Get current frame index of ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqMoveFrameIndex (unsigned uRaySeqID, int iStep)
Move the frame index relative to the current position in the ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqOpen (unsigned &uRaySeqID, const Rx::CRxString &sxFilename, unsigned uMode, unsigned uFrameBufferCount)
Open a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqRead ()
Read a frame from the currently bound ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqSetFrameIndex (unsigned uRaySeqID, unsigned uFrameIdx)
Set the current frame index of ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqUnbind (unsigned uRaySeqID)
Unbind a ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySeqWrite ()
Write currently bound ray image to currently bound ray sequence. More...
RXLF_API bool | Rx::ApiLF::RxRaySetMetaData (unsigned uImgID, const Rx::CRxMetaData &xMetaData)
Set meta data of a ray image. More...
RXLF_API bool | Rx::ApiLF::RxRemoveStatusMessageHandler (Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
RXLF_API bool | Rx::ApiLF::RxResizeImage (Rx::CRxImage &xImage, int iDivider)
Resize an image. More...
RXLF_API bool | Rx::ApiLF::RxSaveDepthPointList (const char *pcFilename)
RXLF_API bool | Rx::ApiLF::RxSavePar (const Rx::CRxString &sxFilename)
Save all API parameters from file. More...
RXLF_API bool | Rx::ApiLF::RxSetImage (EImgID::ID eImgID, const Rx::CRxImage &xImage)
Set an internal image. More...
RXLF_API bool | Rx::ApiLF::RxSetImage (EImgID::ID eImgID, const Rx::IImage *pImage)
Set an internal image. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const unsigned &uValue)
Set a parameter of type unsigned integer. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const double &dValue)
Set a parameter of type double. More...
RXLF_API bool | Rx::ApiLF::RxSetPar (EPar::ID ePar, const Rx::CRxString &sValue)
Set a parameter of type Rx::CRxString. More...
RXLF_API void | Rx::ApiLF::RxSleep (unsigned uTime)
Pause calling thread for the given number of milliseconds. More...
RXLF_API bool | Rx::ApiLF::RxStereoDepth (bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoDepth ()
Calculate the depth for a left and a right view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoDepthEx (double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY, bool bUpdate=false)
Calcualte the depth for a left and a right view with variable eye separation and rotation. More...
RXLF_API bool | Rx::ApiLF::RxStereoOnPlane ()
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnPlane (double dRelDepth)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnPlaneEx (double dRelDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Focus image to a plane perpendicular to the optical axis from two different view points, which results in a stereo view. More...
RXLF_API bool | Rx::ApiLF::RxStereoOnSurface ()
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnSurface (double dStdDepth)
Stereo focus on surface. More...
RXLF_API DEPRECATED bool | Rx::ApiLF::RxStereoOnSurfaceEx (double dStdDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY)
Stereo focus on surface with variable eye separation, view rotation and view offset. More...
RXLF_API bool | Rx::ApiLF::RxTransformDepthValue (double &dTrgValue, double dSrcValue, EDepthImageType::ID eTrgDIT, EDepthImageType::ID eSrcDIT)
Transform between different depth values. More...
RXLF_API bool | Rx::ApiLF::RxUpdateImage (EImgID::ID eImgID)
Update an internal image. More...

Macro Definition Documentation

#define DEPRECATED __declspec(deprecated)
#define RXLF_API __declspec(dllimport)


Rx.ApiLF.Net.CtrlLogListView.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Data Structures | Namespaces
Rx.ApiLF.Net.CtrlLogListView.h File Reference
#include "Rx.Core\RxTime.h"

Go to the source code of this file.

Data Structures

class Rx::ApiLF::NET::CtrlLogListView
Summary for CtrlLogList More...

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::NET


Rx.ApiLF.Net.FormLogConsole.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Data Structures | Namespaces
Rx.ApiLF.Net.FormLogConsole.h File Reference
#include "Rx.ApiLF.Lib.Base/Rx.ApiLF.Types.h"
#include "Rx.ApiLF.Net.CtrlLogListView.h"

Go to the source code of this file.

Data Structures

class Rx::ApiLF::NET::FormLogConsole
Summary for RxFormLog More...

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::NET


Rx.ApiLF.Net.LogConsoleManager.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Data Structures | Namespaces
Rx.ApiLF.Net.LogConsoleManager.h File Reference
#include "Rx.ApiLF.Net.FormLogConsole.h"

Go to the source code of this file.

Data Structures

class Rx::ApiLF::NET::LogConsoleManager

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::NET


Rx.ApiLF.Properties.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.Properties.h File Reference
#include "Rx.ApiLF.PropertyValues.h"

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::ECalibGridMode
Grid calibration modes for parameter CalibGrid_Mode.
namespace | Rx::ApiLF::ECameraTriggerMode
namespace | Rx::ApiLF::EDepthImageType
Depth image output type. Use these value for the parameter Depth_ImageType.
namespace | Rx::ApiLF::EImgID
Internal image IDs.
namespace | Rx::ApiLF::EPar
This enum contains the parameters IDs for various library and camera parameters.
namespace | Rx::ApiLF::EParGrp
Parameter group IDs.
namespace | Rx::ApiLF::ERadDistType
Radial distortion types of raw images.
namespace | Rx::ApiLF::ERaySeqMode
Ray sequence file modes.

Enumerations

enum | Rx::ApiLF::ERadDistType::ID { Rx::ApiLF::ERadDistType::Constant = 0, Rx::ApiLF::ERadDistType::Polynom4, Rx::ApiLF::ERadDistType::Inversion2 }
Radial image distortion types. More...
enum | Rx::ApiLF::ECameraTriggerMode::ID { Rx::ApiLF::ECameraTriggerMode::None = 0, Rx::ApiLF::ECameraTriggerMode::Camera_FreeRun = 0x0100, Rx::ApiLF::ECameraTriggerMode::Software_SnapShot = 0x0200, Rx::ApiLF::ECameraTriggerMode::Extern_Impulse = 0x0300 }
Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode. More...
enum Rx::ApiLF::EPar::ID {
Rx::ApiLF::EPar::None = 0, Rx::ApiLF::EPar::Cuda_DeviceName = 0x00010000, Rx::ApiLF::EPar::Cuda_DeviceID, Rx::ApiLF::EPar::Cuda_CapaMajor, Rx::ApiLF::EPar::Cuda_CapaMinor, Rx::ApiLF::EPar::Cuda_VersionRuntime, Rx::ApiLF::EPar::Cuda_VersionDriver, Rx::ApiLF::EPar::Cuda_TotalGlobalMem,
Rx::ApiLF::EPar::Cuda_RegsPerBlock, Rx::ApiLF::EPar::Cuda_WarpSize, Rx::ApiLF::EPar::Cuda_MemPitch, Rx::ApiLF::EPar::Cuda_MaxThreadsPerBlock, Rx::ApiLF::EPar::Cuda_TotalConstMem, Rx::ApiLF::EPar::Cuda_DeviceOverlap, Rx::ApiLF::EPar::Cuda_MultiProcessorCount, Rx::ApiLF::EPar::Cuda_ComputeMode,
Rx::ApiLF::EPar::Cuda_MaxTex2DSizeX, Rx::ApiLF::EPar::Cuda_MaxTex2DSizeY, Rx::ApiLF::EPar::Cuda_MaxTex2DArraySizeX, Rx::ApiLF::EPar::Cuda_MaxTex2DArraySizeY, Rx::ApiLF::EPar::Cuda_ConcurrentKernels, Rx::ApiLF::EPar::Cuda_TCCDriver, Rx::ApiLF::EPar::Cam_Count = 0x00020000, Rx::ApiLF::EPar::Cam_Name,
Rx::ApiLF::EPar::Cam_Type, Rx::ApiLF::EPar::Cam_ID, Rx::ApiLF::EPar::Cam_Exposure, Rx::ApiLF::EPar::Cam_TapBalance, Rx::ApiLF::EPar::Cam_Gain, Rx::ApiLF::EPar::Cam_GainRed, Rx::ApiLF::EPar::Cam_GainGreen, Rx::ApiLF::EPar::Cam_GainBlue,
Rx::ApiLF::EPar::Cam_IsColor, Rx::ApiLF::EPar::Cam_IsBayer, Rx::ApiLF::EPar::Cam_Width, Rx::ApiLF::EPar::Cam_Height, Rx::ApiLF::EPar::Cam_OffsetX, Rx::ApiLF::EPar::Cam_OffsetY, Rx::ApiLF::EPar::Cam_AutoUpdateGlTex, Rx::ApiLF::EPar::Cam_FramesPerSecond,
Rx::ApiLF::EPar::Cam_ActualFramesPerSecond, Rx::ApiLF::EPar::Cam_Focus, Rx::ApiLF::EPar::Cam_Iris, Rx::ApiLF::EPar::Cam_Func_CalibMainLens, Rx::ApiLF::EPar::Cam_TapBalanceMode, Rx::ApiLF::EPar::Cam_PIVMode, Rx::ApiLF::EPar::Cam_IsOpen, Rx::ApiLF::EPar::Cam_IsCapturing,
Rx::ApiLF::EPar::Cam_Temperature, Rx::ApiLF::EPar::Cam_TriggerMode, Rx::ApiLF::EPar::CamCal_LensCnt = 0x00030000, Rx::ApiLF::EPar::CamCal_LensSetCnt, Rx::ApiLF::EPar::CamCal_LensIdx, Rx::ApiLF::EPar::CamCal_LensSetIdx, Rx::ApiLF::EPar::CamCal_LensName, Rx::ApiLF::EPar::CamCal_LensID,
Rx::ApiLF::EPar::CamCal_LensSetFStop, Rx::ApiLF::EPar::CamCal_LensSetFocus, Rx::ApiLF::EPar::CamCal_MainLensIris, Rx::ApiLF::EPar::CamCal_MainLensFocus, Rx::ApiLF::EPar::CamCap_Timeout_Video = 0x0003F000, Rx::ApiLF::EPar::CamCap_Timeout_Single, Rx::ApiLF::EPar::CamCap_Timeout_Extern, Rx::ApiLF::EPar::CamCap_Frames_Lost = 0x0003F020,
Rx::ApiLF::EPar::CamCap_AutoLum_MaxSaturatedPixelPercentage = 0x0003F100, Rx::ApiLF::EPar::CamCap_AutoGain_Enabled = 0x0003F200, Rx::ApiLF::EPar::CamCap_AutoGain_Active, Rx::ApiLF::EPar::CamCap_AutoGain_MinValue, Rx::ApiLF::EPar::CamCap_AutoGain_MaxValue, Rx::ApiLF::EPar::CamCap_AutoExposure_Enabled = 0x0003F300, Rx::ApiLF::EPar::CamCap_AutoExposure_Active, Rx::ApiLF::EPar::CamCap_AutoExposure_MinValue,
Rx::ApiLF::EPar::CamCap_AutoExposure_MaxValue, Rx::ApiLF::EPar::Ray_Width = 0x00040000, Rx::ApiLF::EPar::Ray_Height, Rx::ApiLF::EPar::Ray_PixelType, Rx::ApiLF::EPar::Ray_DataType, Rx::ApiLF::EPar::Ray_ApplyWhiteImage, Rx::ApiLF::EPar::Ray_ConvBayer, Rx::ApiLF::EPar::Ray_MLI_Rotation,
Rx::ApiLF::EPar::Ray_MLI_Diameter, Rx::ApiLF::EPar::Ray_MLI_Border, Rx::ApiLF::EPar::Ray_MLI_OffsetX, Rx::ApiLF::EPar::Ray_MLI_OffsetY, Rx::ApiLF::EPar::Ray_MLI_PixelSizeX, Rx::ApiLF::EPar::Ray_MLI_PixelSizeY, Rx::ApiLF::EPar::Ray_MLI_BaseRotation, Rx::ApiLF::EPar::Ray_MLI_BaseReflectX,
Rx::ApiLF::EPar::Ray_MLI_BaseReflectY, Rx::ApiLF::EPar::Ray_MLI_BaseVecXX, Rx::ApiLF::EPar::Ray_MLI_BaseVecXY, Rx::ApiLF::EPar::Ray_MLI_BaseVecYX, Rx::ApiLF::EPar::Ray_MLI_BaseVecYY, Rx::ApiLF::EPar::Ray_MLI_SubGridBaseX, Rx::ApiLF::EPar::Ray_MLI_SubGridBaseY, Rx::ApiLF::EPar::Ray_MLI_LensTypeCount,
Rx::ApiLF::EPar::Ray_MLI_LensTypeIdx, Rx::ApiLF::EPar::Ray_MLI_LensTypeVirtDepthMin, Rx::ApiLF::EPar::Ray_MLI_LensTypeVirtDepthMax, Rx::ApiLF::EPar::Ray_MLI_LensTypeOffsetX, Rx::ApiLF::EPar::Ray_MLI_LensTypeOffsetY, Rx::ApiLF::EPar::Ray_MLI_RadDistType, Rx::ApiLF::EPar::Ray_MLI_RadDistParCnt, Rx::ApiLF::EPar::Ray_MLI_RadDistOffsetX,
Rx::ApiLF::EPar::Ray_MLI_RadDistOffsetY, Rx::ApiLF::EPar::Ray_MLI_RadDistPar1, Rx::ApiLF::EPar::Ray_MLI_RadDistPar2, Rx::ApiLF::EPar::Ray_MLI_RadDistPar3, Rx::ApiLF::EPar::Ray_MLI_RadDistPar4, Rx::ApiLF::EPar::Ray_MLI_RadDistPar5, Rx::ApiLF::EPar::Ray_MLI_NeedWhiteImage, Rx::ApiLF::EPar::Ray_ApplyFileSettings = 0x00047000,
Rx::ApiLF::EPar::Gl_TexRayID = 0x00050000, Rx::ApiLF::EPar::Gl_TexFocusLeftID, Rx::ApiLF::EPar::Gl_TexFocusRightID, Rx::ApiLF::EPar::Gl_TexDepthLeftID, Rx::ApiLF::EPar::Gl_TexDepthRightID, Rx::ApiLF::EPar::Gl_TexDepthColLeftID, Rx::ApiLF::EPar::Gl_TexDepthColRightID, Rx::ApiLF::EPar::Gl_TexGridID,
Rx::ApiLF::EPar::Gl_TexFocusLeftID2, Rx::ApiLF::EPar::Gl_TexFocusRightID2, Rx::ApiLF::EPar::Gl_TexRayProcID, Rx::ApiLF::EPar::Gl_TexRayWhiteID, Rx::ApiLF::EPar::Gl_TexRayDepthID, Rx::ApiLF::EPar::RaySeq_AutoStoreCamFrames = 0x00060000, Rx::ApiLF::EPar::RaySeq_ApplyFileSettings, Rx::ApiLF::EPar::RaySeq_AutoStoreCamFrameCnt,
Rx::ApiLF::EPar::PreProc_Std_Enable = 0x00100000, Rx::ApiLF::EPar::PreProc_Std_Brightness, Rx::ApiLF::EPar::PreProc_Std_ContrastCenter, Rx::ApiLF::EPar::PreProc_Std_ContrastScale, Rx::ApiLF::EPar::PreProc_Sharp1_Enable = 0x00102000, Rx::ApiLF::EPar::PreProc_Sharp1_BlurStdDev, Rx::ApiLF::EPar::PreProc_Sharp1_Factor, Rx::ApiLF::EPar::PreProc_Sharp1_OnlyCalc,
Rx::ApiLF::EPar::PreProc_Demosaic_Enable = 0x00104000, Rx::ApiLF::EPar::PreProc_Demosaic_R, Rx::ApiLF::EPar::PreProc_Demosaic_G, Rx::ApiLF::EPar::PreProc_Demosaic_B, Rx::ApiLF::EPar::PreProc_DenoiseNLM_Enable = 0x00105000, Rx::ApiLF::EPar::PreProc_DenoiseNLM_FilterDia, Rx::ApiLF::EPar::PreProc_DenoiseNLM_NoiseLevel, Rx::ApiLF::EPar::PreProc_DenoiseNLM_BlendFactor,
Rx::ApiLF::EPar::Depth_Algo = 0x00200000, Rx::ApiLF::EPar::Depth_ResImgDiv, Rx::ApiLF::EPar::Depth_ImageType, Rx::ApiLF::EPar::Depth_DefaultValue, Rx::ApiLF::EPar::Depth_Affine_Offset = 0x00201000, Rx::ApiLF::EPar::Depth_Affine_FocalLength, Rx::ApiLF::EPar::Depth_Std_BlockCnt = 0x00202000, Rx::ApiLF::EPar::Depth_Std_PatchRad,
Rx::ApiLF::EPar::Depth_Std_MedianRad, Rx::ApiLF::EPar::Depth_Std_MeanRad, Rx::ApiLF::EPar::Depth_Std_SizeDiv, Rx::ApiLF::EPar::Depth_Std_MinTrust, Rx::ApiLF::EPar::Depth_Std_MaxInvCor, Rx::ApiLF::EPar::Depth_Std_MinStdDev, Rx::ApiLF::EPar::Depth_Std_PixelStep, Rx::ApiLF::EPar::Depth_Std_RawMedianRad,
Rx::ApiLF::EPar::Depth_Std_RawMeanRad, Rx::ApiLF::EPar::Depth_Std_RawMeanMaxBlackPart, Rx::ApiLF::EPar::Depth_Std_Fuse_DepthDeltaMax, Rx::ApiLF::EPar::Depth_Std_Fuse_DepthOptRangeMax, Rx::ApiLF::EPar::Depth_Path_BlockCnt = 0x00203000, Rx::ApiLF::EPar::Depth_Path_NearResLevel, Rx::ApiLF::EPar::Depth_Path_SparseLensSet, Rx::ApiLF::EPar::Depth_Path_MaxVirtDepth,
Rx::ApiLF::EPar::Depth_Path_LensTypeIdx = 0x00203100, Rx::ApiLF::EPar::Depth_Path_LT_PixelStep, Rx::ApiLF::EPar::Depth_Path_LT_MinStdDev, Rx::ApiLF::EPar::Depth_Path_LT_MinCor, Rx::ApiLF::EPar::Depth_Path_LT_MinPolyParAbs, Rx::ApiLF::EPar::Depth_Path_LT_MaxPolyCtrDelta, Rx::ApiLF::EPar::Depth_Path_LT_PatchDia, Rx::ApiLF::EPar::Depth_Path_LT_PatchStride,
Rx::ApiLF::EPar::Depth_PathPiv_BlockCnt = 0x00203200, Rx::ApiLF::EPar::Depth_PathPiv_NearResLevel, Rx::ApiLF::EPar::Depth_PathPiv_LensTypeIdx = 0x00203300, Rx::ApiLF::EPar::Depth_PathPiv_LT_PixelStep, Rx::ApiLF::EPar::Depth_PathPiv_LT_MinCor, Rx::ApiLF::EPar::Depth_PathPiv_LT_BPSigma, Rx::ApiLF::EPar::Depth_PathPiv_LT_BPMinCor, Rx::ApiLF::EPar::Depth_PathPiv_LT_BPMinMean,
Rx::ApiLF::EPar::Depth_PathPiv_LT_MinPolyParAbs, Rx::ApiLF::EPar::Depth_PathPiv_LT_MaxPolyCtrDelta, Rx::ApiLF::EPar::Depth_PathPiv_LT_PatchDia, Rx::ApiLF::EPar::Depth_PathPiv_LT_PatchStride, Rx::ApiLF::EPar::Depth_Fuse_MedianRad = 0x00205000, Rx::ApiLF::EPar::Depth_Fuse_MeanRad, Rx::ApiLF::EPar::Depth_Fuse_MeanMaxBlackPart, Rx::ApiLF::EPar::Depth_Fuse_LensTypeIdx = 0x00205100,
Rx::ApiLF::EPar::Depth_Fill_Enabled = 0x00207000, Rx::ApiLF::EPar::Depth_Fill_IterCnt, Rx::ApiLF::EPar::Depth_Fill_IterSize, Rx::ApiLF::EPar::Depth_Fill_Complete, Rx::ApiLF::EPar::Depth_Fill_MedianRad, Rx::ApiLF::EPar::Depth_Fill_MeanRad, Rx::ApiLF::EPar::Depth_Fill_NLM_Enabled, Rx::ApiLF::EPar::Depth_Fill_NLM_FilterDia,
Rx::ApiLF::EPar::Depth_Fill_NLM_NoiseLevel, Rx::ApiLF::EPar::Depth_Fill_NLM_BlendFactor, Rx::ApiLF::EPar::Depth_Fill_Bilateral_Enabled, Rx::ApiLF::EPar::Depth_Fill_Bilateral_FilterRad, Rx::ApiLF::EPar::Depth_Fill_Bilateral_SigmaR, Rx::ApiLF::EPar::Depth_Fill_Bilateral_SigmaS, Rx::ApiLF::EPar::Focus_ResImgDiv = 0x00220000, Rx::ApiLF::EPar::Focus_MaxLensContribRad,
Rx::ApiLF::EPar::Focus_ViewOffset_VirtDepthMin, Rx::ApiLF::EPar::Focus_ViewOffset_VirtDepthMax, Rx::ApiLF::EPar::Focus_ViewOffset_Gamma, Rx::ApiLF::EPar::Focus_ViewOffset_Radial, Rx::ApiLF::EPar::Focus_ViewOffset_VirtDepthCollPlane, Rx::ApiLF::EPar::Focus_ViewOffset_X, Rx::ApiLF::EPar::Focus_ViewOffset_Y, Rx::ApiLF::EPar::Focus_DefaultFocus,
Rx::ApiLF::EPar::Focus_Focus, Rx::ApiLF::EPar::Focus_Stereo_Enabled, Rx::ApiLF::EPar::Focus_Stereo_EyeSep, Rx::ApiLF::EPar::Focus_Stereo_Rot, Rx::ApiLF::EPar::Focus_DefocusBlur_Enable = 0x00221000, Rx::ApiLF::EPar::Focus_DefocusBlur_VirtDOF, Rx::ApiLF::EPar::Focus_DefocusBlur_Gradient, Rx::ApiLF::EPar::Focus_DefocusBlur_MaxBlurRad,
Rx::ApiLF::EPar::Focus_DefocusBlur_DefaultDepth, Rx::ApiLF::EPar::Grid_ResImgDiv = 0x00230000, Rx::ApiLF::EPar::Calib_Grid_Mode = 0x00240000
}
LF API parameters More...
enum Rx::ApiLF::EParGrp::ID {
Rx::ApiLF::EParGrp::None = 0, Rx::ApiLF::EParGrp::Cuda = 0x00010000, Rx::ApiLF::EParGrp::Camera = 0x00020000, Rx::ApiLF::EParGrp::CamCal = 0x00030000, Rx::ApiLF::EParGrp::CamCap = 0x0003F000, Rx::ApiLF::EParGrp::Ray = 0x00040000, Rx::ApiLF::EParGrp::Gl = 0x00050000, Rx::ApiLF::EParGrp::RaySeq = 0x00060000,
Rx::ApiLF::EParGrp::PreProc = 0x00100000, Rx::ApiLF::EParGrp::Depth = 0x00200000, Rx::ApiLF::EParGrp::Depth_Path = 0x00203000, Rx::ApiLF::EParGrp::Depth_PathPiv = 0x00203200, Rx::ApiLF::EParGrp::Focus = 0x00220000, Rx::ApiLF::EParGrp::Grid = 0x00230000, Rx::ApiLF::EParGrp::Calib = 0x00240000
}
Parameter group IDs. More...
enum Rx::ApiLF::EImgID::ID {
Rx::ApiLF::EImgID::None = 0x0000, Rx::ApiLF::EImgID::Ray = 0x0001, Rx::ApiLF::EImgID::RayDepth = 0x0002, Rx::ApiLF::EImgID::Focus = 0x0004, Rx::ApiLF::EImgID::FocusLeft = 0x0004, Rx::ApiLF::EImgID::FocusRight = 0x0008, Rx::ApiLF::EImgID::Depth = 0x0010, Rx::ApiLF::EImgID::DepthLeft = 0x0010,
Rx::ApiLF::EImgID::DepthRight = 0x0020, Rx::ApiLF::EImgID::DepthCol = 0x0040, Rx::ApiLF::EImgID::DepthColLeft = 0x0040, Rx::ApiLF::EImgID::DepthColRight = 0x0080, Rx::ApiLF::EImgID::RayGrid = 0x0100, Rx::ApiLF::EImgID::RayProc = 0x0200, Rx::ApiLF::EImgID::RayWhite = 0x0400
}
Image IDs. More...
enum | Rx::ApiLF::EDepthImageType::ID { Rx::ApiLF::EDepthImageType::Standard = 0, Rx::ApiLF::EDepthImageType::Virtual, Rx::ApiLF::EDepthImageType::Relative, Rx::ApiLF::EDepthImageType::Affine, Rx::ApiLF::EDepthImageType::Count }
Depth image types. More...
enum | Rx::ApiLF::ECalibGridMode::ID { Rx::ApiLF::ECalibGridMode::PosScale = 0, Rx::ApiLF::ECalibGridMode::PosScaleRot, Rx::ApiLF::ECalibGridMode::Count }
Calibration modes More...
enum | Rx::ApiLF::ERaySeqMode::ID { Rx::ApiLF::ERaySeqMode::None = 0x0000, Rx::ApiLF::ERaySeqMode::Read = 0x0001, Rx::ApiLF::ERaySeqMode::Write = 0x0002, Rx::ApiLF::ERaySeqMode::Compress_Zip = 0x0100 }


Rx.ApiLF.PropertyValues.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.PropertyValues.h File Reference

Go to the source code of this file.

Namespaces

namespace | ECalibGridMode
Grid calibration modes for parameter CalibGrid_Mode.
namespace | ECameraTriggerMode
namespace | EDepthImageType
Depth image output type. Use these value for the parameter Depth_ImageType.
namespace | EImgID
Internal image IDs.
namespace | EPar
This enum contains the parameters IDs for various library and camera parameters.
namespace | EParGrp
Parameter group IDs.
namespace | ERadDistType
Radial distortion types of raw images.
namespace | ERaySeqMode
Ray sequence file modes.

Enumerations

enum | ERadDistType::ID { ERadDistType::Constant = 0, ERadDistType::Polynom4, ERadDistType::Inversion2 }
Radial image distortion types. More...
enum | ECameraTriggerMode::ID { ECameraTriggerMode::None = 0, ECameraTriggerMode::Camera_FreeRun = 0x0100, ECameraTriggerMode::Software_SnapShot = 0x0200, ECameraTriggerMode::Extern_Impulse = 0x0300 }
Camera trigger modes that can be used with parameter EPar::Cam_TriggerMode. More...
enum EPar::ID {
EPar::None = 0, EPar::Cuda_DeviceName = 0x00010000, EPar::Cuda_DeviceID, EPar::Cuda_CapaMajor, EPar::Cuda_CapaMinor, EPar::Cuda_VersionRuntime, EPar::Cuda_VersionDriver, EPar::Cuda_TotalGlobalMem,
EPar::Cuda_RegsPerBlock, EPar::Cuda_WarpSize, EPar::Cuda_MemPitch, EPar::Cuda_MaxThreadsPerBlock, EPar::Cuda_TotalConstMem, EPar::Cuda_DeviceOverlap, EPar::Cuda_MultiProcessorCount, EPar::Cuda_ComputeMode,
EPar::Cuda_MaxTex2DSizeX, EPar::Cuda_MaxTex2DSizeY, EPar::Cuda_MaxTex2DArraySizeX, EPar::Cuda_MaxTex2DArraySizeY, EPar::Cuda_ConcurrentKernels, EPar::Cuda_TCCDriver, EPar::Cam_Count = 0x00020000, EPar::Cam_Name,
EPar::Cam_Type, EPar::Cam_ID, EPar::Cam_Exposure, EPar::Cam_TapBalance, EPar::Cam_Gain, EPar::Cam_GainRed, EPar::Cam_GainGreen, EPar::Cam_GainBlue,
EPar::Cam_IsColor, EPar::Cam_IsBayer, EPar::Cam_Width, EPar::Cam_Height, EPar::Cam_OffsetX, EPar::Cam_OffsetY, EPar::Cam_AutoUpdateGlTex, EPar::Cam_FramesPerSecond,
EPar::Cam_ActualFramesPerSecond, EPar::Cam_Focus, EPar::Cam_Iris, EPar::Cam_Func_CalibMainLens, EPar::Cam_TapBalanceMode, EPar::Cam_PIVMode, EPar::Cam_IsOpen, EPar::Cam_IsCapturing,
EPar::Cam_Temperature, EPar::Cam_TriggerMode, EPar::CamCal_LensCnt = 0x00030000, EPar::CamCal_LensSetCnt, EPar::CamCal_LensIdx, EPar::CamCal_LensSetIdx, EPar::CamCal_LensName, EPar::CamCal_LensID,
EPar::CamCal_LensSetFStop, EPar::CamCal_LensSetFocus, EPar::CamCal_MainLensIris, EPar::CamCal_MainLensFocus, EPar::CamCap_Timeout_Video = 0x0003F000, EPar::CamCap_Timeout_Single, EPar::CamCap_Timeout_Extern, EPar::CamCap_Frames_Lost = 0x0003F020,
EPar::CamCap_AutoLum_MaxSaturatedPixelPercentage = 0x0003F100, EPar::CamCap_AutoGain_Enabled = 0x0003F200, EPar::CamCap_AutoGain_Active, EPar::CamCap_AutoGain_MinValue, EPar::CamCap_AutoGain_MaxValue, EPar::CamCap_AutoExposure_Enabled = 0x0003F300, EPar::CamCap_AutoExposure_Active, EPar::CamCap_AutoExposure_MinValue,
EPar::CamCap_AutoExposure_MaxValue, EPar::Ray_Width = 0x00040000, EPar::Ray_Height, EPar::Ray_PixelType, EPar::Ray_DataType, EPar::Ray_ApplyWhiteImage, EPar::Ray_ConvBayer, EPar::Ray_MLI_Rotation,
EPar::Ray_MLI_Diameter, EPar::Ray_MLI_Border, EPar::Ray_MLI_OffsetX, EPar::Ray_MLI_OffsetY, EPar::Ray_MLI_PixelSizeX, EPar::Ray_MLI_PixelSizeY, EPar::Ray_MLI_BaseRotation, EPar::Ray_MLI_BaseReflectX,
EPar::Ray_MLI_BaseReflectY, EPar::Ray_MLI_BaseVecXX, EPar::Ray_MLI_BaseVecXY, EPar::Ray_MLI_BaseVecYX, EPar::Ray_MLI_BaseVecYY, EPar::Ray_MLI_SubGridBaseX, EPar::Ray_MLI_SubGridBaseY, EPar::Ray_MLI_LensTypeCount,
EPar::Ray_MLI_LensTypeIdx, EPar::Ray_MLI_LensTypeVirtDepthMin, EPar::Ray_MLI_LensTypeVirtDepthMax, EPar::Ray_MLI_LensTypeOffsetX, EPar::Ray_MLI_LensTypeOffsetY, EPar::Ray_MLI_RadDistType, EPar::Ray_MLI_RadDistParCnt, EPar::Ray_MLI_RadDistOffsetX,
EPar::Ray_MLI_RadDistOffsetY, EPar::Ray_MLI_RadDistPar1, EPar::Ray_MLI_RadDistPar2, EPar::Ray_MLI_RadDistPar3, EPar::Ray_MLI_RadDistPar4, EPar::Ray_MLI_RadDistPar5, EPar::Ray_MLI_NeedWhiteImage, EPar::Ray_ApplyFileSettings = 0x00047000,
EPar::Gl_TexRayID = 0x00050000, EPar::Gl_TexFocusLeftID, EPar::Gl_TexFocusRightID, EPar::Gl_TexDepthLeftID, EPar::Gl_TexDepthRightID, EPar::Gl_TexDepthColLeftID, EPar::Gl_TexDepthColRightID, EPar::Gl_TexGridID,
EPar::Gl_TexFocusLeftID2, EPar::Gl_TexFocusRightID2, EPar::Gl_TexRayProcID, EPar::Gl_TexRayWhiteID, EPar::Gl_TexRayDepthID, EPar::RaySeq_AutoStoreCamFrames = 0x00060000, EPar::RaySeq_ApplyFileSettings, EPar::RaySeq_AutoStoreCamFrameCnt,
EPar::PreProc_Std_Enable = 0x00100000, EPar::PreProc_Std_Brightness, EPar::PreProc_Std_ContrastCenter, EPar::PreProc_Std_ContrastScale, EPar::PreProc_Sharp1_Enable = 0x00102000, EPar::PreProc_Sharp1_BlurStdDev, EPar::PreProc_Sharp1_Factor, EPar::PreProc_Sharp1_OnlyCalc,
EPar::PreProc_Demosaic_Enable = 0x00104000, EPar::PreProc_Demosaic_R, EPar::PreProc_Demosaic_G, EPar::PreProc_Demosaic_B, EPar::PreProc_DenoiseNLM_Enable = 0x00105000, EPar::PreProc_DenoiseNLM_FilterDia, EPar::PreProc_DenoiseNLM_NoiseLevel, EPar::PreProc_DenoiseNLM_BlendFactor,
EPar::Depth_Algo = 0x00200000, EPar::Depth_ResImgDiv, EPar::Depth_ImageType, EPar::Depth_DefaultValue, EPar::Depth_Affine_Offset = 0x00201000, EPar::Depth_Affine_FocalLength, EPar::Depth_Std_BlockCnt = 0x00202000, EPar::Depth_Std_PatchRad,
EPar::Depth_Std_MedianRad, EPar::Depth_Std_MeanRad, EPar::Depth_Std_SizeDiv, EPar::Depth_Std_MinTrust, EPar::Depth_Std_MaxInvCor, EPar::Depth_Std_MinStdDev, EPar::Depth_Std_PixelStep, EPar::Depth_Std_RawMedianRad,
EPar::Depth_Std_RawMeanRad, EPar::Depth_Std_RawMeanMaxBlackPart, EPar::Depth_Std_Fuse_DepthDeltaMax, EPar::Depth_Std_Fuse_DepthOptRangeMax, EPar::Depth_Path_BlockCnt = 0x00203000, EPar::Depth_Path_NearResLevel, EPar::Depth_Path_SparseLensSet, EPar::Depth_Path_MaxVirtDepth,
EPar::Depth_Path_LensTypeIdx = 0x00203100, EPar::Depth_Path_LT_PixelStep, EPar::Depth_Path_LT_MinStdDev, EPar::Depth_Path_LT_MinCor, EPar::Depth_Path_LT_MinPolyParAbs, EPar::Depth_Path_LT_MaxPolyCtrDelta, EPar::Depth_Path_LT_PatchDia, EPar::Depth_Path_LT_PatchStride,
EPar::Depth_PathPiv_BlockCnt = 0x00203200, EPar::Depth_PathPiv_NearResLevel, EPar::Depth_PathPiv_LensTypeIdx = 0x00203300, EPar::Depth_PathPiv_LT_PixelStep, EPar::Depth_PathPiv_LT_MinCor, EPar::Depth_PathPiv_LT_BPSigma, EPar::Depth_PathPiv_LT_BPMinCor, EPar::Depth_PathPiv_LT_BPMinMean,
EPar::Depth_PathPiv_LT_MinPolyParAbs, EPar::Depth_PathPiv_LT_MaxPolyCtrDelta, EPar::Depth_PathPiv_LT_PatchDia, EPar::Depth_PathPiv_LT_PatchStride, EPar::Depth_Fuse_MedianRad = 0x00205000, EPar::Depth_Fuse_MeanRad, EPar::Depth_Fuse_MeanMaxBlackPart, EPar::Depth_Fuse_LensTypeIdx = 0x00205100,
EPar::Depth_Fill_Enabled = 0x00207000, EPar::Depth_Fill_IterCnt, EPar::Depth_Fill_IterSize, EPar::Depth_Fill_Complete, EPar::Depth_Fill_MedianRad, EPar::Depth_Fill_MeanRad, EPar::Depth_Fill_NLM_Enabled, EPar::Depth_Fill_NLM_FilterDia,
EPar::Depth_Fill_NLM_NoiseLevel, EPar::Depth_Fill_NLM_BlendFactor, EPar::Depth_Fill_Bilateral_Enabled, EPar::Depth_Fill_Bilateral_FilterRad, EPar::Depth_Fill_Bilateral_SigmaR, EPar::Depth_Fill_Bilateral_SigmaS, EPar::Focus_ResImgDiv = 0x00220000, EPar::Focus_MaxLensContribRad,
EPar::Focus_ViewOffset_VirtDepthMin, EPar::Focus_ViewOffset_VirtDepthMax, EPar::Focus_ViewOffset_Gamma, EPar::Focus_ViewOffset_Radial, EPar::Focus_ViewOffset_VirtDepthCollPlane, EPar::Focus_ViewOffset_X, EPar::Focus_ViewOffset_Y, EPar::Focus_DefaultFocus,
EPar::Focus_Focus, EPar::Focus_Stereo_Enabled, EPar::Focus_Stereo_EyeSep, EPar::Focus_Stereo_Rot, EPar::Focus_DefocusBlur_Enable = 0x00221000, EPar::Focus_DefocusBlur_VirtDOF, EPar::Focus_DefocusBlur_Gradient, EPar::Focus_DefocusBlur_MaxBlurRad,
EPar::Focus_DefocusBlur_DefaultDepth, EPar::Grid_ResImgDiv = 0x00230000, EPar::Calib_Grid_Mode = 0x00240000
}
LF API parameters More...
enum EParGrp::ID {
EParGrp::None = 0, EParGrp::Cuda = 0x00010000, EParGrp::Camera = 0x00020000, EParGrp::CamCal = 0x00030000, EParGrp::CamCap = 0x0003F000, EParGrp::Ray = 0x00040000, EParGrp::Gl = 0x00050000, EParGrp::RaySeq = 0x00060000,
EParGrp::PreProc = 0x00100000, EParGrp::Depth = 0x00200000, EParGrp::Depth_Path = 0x00203000, EParGrp::Depth_PathPiv = 0x00203200, EParGrp::Focus = 0x00220000, EParGrp::Grid = 0x00230000, EParGrp::Calib = 0x00240000
}
Parameter group IDs. More...
enum EImgID::ID {
EImgID::None = 0x0000, EImgID::Ray = 0x0001, EImgID::RayDepth = 0x0002, EImgID::Focus = 0x0004, EImgID::FocusLeft = 0x0004, EImgID::FocusRight = 0x0008, EImgID::Depth = 0x0010, EImgID::DepthLeft = 0x0010,
EImgID::DepthRight = 0x0020, EImgID::DepthCol = 0x0040, EImgID::DepthColLeft = 0x0040, EImgID::DepthColRight = 0x0080, EImgID::RayGrid = 0x0100, EImgID::RayProc = 0x0200, EImgID::RayWhite = 0x0400
}
Image IDs. More...
enum | EDepthImageType::ID { EDepthImageType::Standard = 0, EDepthImageType::Virtual, EDepthImageType::Relative, EDepthImageType::Affine, EDepthImageType::Count }
Depth image types. More...
enum | ECalibGridMode::ID { ECalibGridMode::PosScale = 0, ECalibGridMode::PosScaleRot, ECalibGridMode::Count }
Calibration modes More...
enum | ERaySeqMode::ID { ERaySeqMode::None = 0x0000, ERaySeqMode::Read = 0x0001, ERaySeqMode::Write = 0x0002, ERaySeqMode::Compress_Zip = 0x0100 }


Rx.ApiLF.StatusCodes.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.StatusCodes.h File Reference
#include "Rx.ApiLF.StatusCodeValues.h"

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::ApiLF
namespace | Rx::ApiLF::EStatusMessage
Values that represent EStatusCode.
namespace | Rx::ApiLF::EStatusMsgGrp
Values that represent EStatusCode.
namespace | Rx::ApiLF::EStatusSource
Values that represent EStatusCodeGroup.

Enumerations

enum | Rx::ApiLF::EStatusSource::ID { Rx::ApiLF::EStatusSource::Unknown = 0, Rx::ApiLF::EStatusSource::API, Rx::ApiLF::EStatusSource::Camera, Rx::ApiLF::EStatusSource::CameraDriver, Rx::ApiLF::EStatusSource::Compute, Rx::ApiLF::EStatusSource::App }
enum | Rx::ApiLF::EStatusMsgGrp::ID { Rx::ApiLF::EStatusMsgGrp::None = 0, Rx::ApiLF::EStatusMsgGrp::Text = 0x00010000, Rx::ApiLF::EStatusMsgGrp::Progress = 0x00020000 }
enum Rx::ApiLF::EStatusMessage::ID {
Rx::ApiLF::EStatusMessage::None = 0, Rx::ApiLF::EStatusMessage::Debug = int(EStatusMsgGrp::Text), Rx::ApiLF::EStatusMessage::Info, Rx::ApiLF::EStatusMessage::Error, Rx::ApiLF::EStatusMessage::Assertion, Rx::ApiLF::EStatusMessage::Exception, Rx::ApiLF::EStatusMessage::Fatal, Rx::ApiLF::EStatusMessage::Warning,
Rx::ApiLF::EStatusMessage::Progress_Init = int(EStatusMsgGrp::Progress), Rx::ApiLF::EStatusMessage::Progress_Value, Rx::ApiLF::EStatusMessage::Progress_Step, Rx::ApiLF::EStatusMessage::Progress_Finished
}


Rx.ApiLF.StatusCodeValues.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Namespaces | Enumerations
Rx.ApiLF.StatusCodeValues.h File Reference

Go to the source code of this file.

Namespaces

namespace | EStatusMessage
Values that represent EStatusCode.
namespace | EStatusMsgGrp
Values that represent EStatusCode.
namespace | EStatusSource
Values that represent EStatusCodeGroup.

Enumerations

enum | EStatusSource::ID { EStatusSource::Unknown = 0, EStatusSource::API, EStatusSource::Camera, EStatusSource::CameraDriver, EStatusSource::Compute, EStatusSource::App }
enum | EStatusMsgGrp::ID { EStatusMsgGrp::None = 0, EStatusMsgGrp::Text = 0x00010000, EStatusMsgGrp::Progress = 0x00020000 }
enum EStatusMessage::ID {
EStatusMessage::None = 0, EStatusMessage::Debug = int(EStatusMsgGrp::Text), EStatusMessage::Info, EStatusMessage::Error, EStatusMessage::Assertion, EStatusMessage::Exception, EStatusMessage::Fatal, EStatusMessage::Warning,
EStatusMessage::Progress_Init = int(EStatusMsgGrp::Progress), EStatusMessage::Progress_Value, EStatusMessage::Progress_Step, EStatusMessage::Progress_Finished
}


Rx.ApiLF.StatusMessageDelegateList.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Data Structures | Namespaces
Rx.ApiLF.StatusMessageDelegateList.h File Reference
#include "Rx.ApiLF.Types.h"
#include "Rx.Core.Development/RxMem.h"

Go to the source code of this file.

Data Structures

class Rx::ApiLF::CStatusMessageDelegateList

Namespaces

namespace | Rx
namespace | Rx::ApiLF


Rx.ApiLF.Types.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Data Structures | Namespaces | Typedefs
Rx.ApiLF.Types.h File Reference
#include "Rx.ApiLF.StatusCodes.h"

Go to the source code of this file.

Data Structures

struct Rx::ApiLF::SStatusMessageDelegate

Namespaces

namespace | Rx
namespace | Rx::ApiLF

Typedefs

typedef void(__stdcall * Rx::ApiLF::TFuncStatusMessageCallback )(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char *pcSourceName, const char *pcMessage, int iValue, void *pvContext)
Function pointer type of the status message callback function. More...


RxArrayDouble.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxArrayDouble.h File Reference

Go to the source code of this file.

Data Structures

class Rx::CRxArrayDouble
Basic unsigned int array operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxArrayInt.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxArrayInt.h File Reference

Go to the source code of this file.

Data Structures

class Rx::CRxArrayInt
Basic unsigned int array operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxArrayString.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxArrayString.h File Reference
#include "RxString.h"

Go to the source code of this file.

Data Structures

class Rx::CRxArrayString
Basic unsigned int array operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxArrayUChar.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxArrayUChar.h File Reference

Go to the source code of this file.

Data Structures

class Rx::CRxArrayUChar
Basic unsigned char array operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxArrayUInt.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxArrayUInt.h File Reference

Go to the source code of this file.

Data Structures

class Rx::CRxArrayUInt
Basic unsigned int array operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxCore.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Macros
RxCore.h File Reference
#include "RxTypes.h"
#include "RxImage.h"
#include "RxImageMoniker.h"
#include "RxImageFormat.h"
#include "RxTime.h"
#include "RxString.h"
#include "RxMetaData.h"
#include "RxArrayInt.h"
#include "RxArrayUInt.h"
#include "RxArrayDouble.h"
#include "RxArrayUChar.h"
#include "RxArrayString.h"

Go to the source code of this file.

Macros

#define RXCORE_API __declspec(dllimport)


RxIfcImage.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime
  • Rx.Interop.Runtime28
Data Structures | Namespaces
RxIfcImage.h File Reference
#include "RxImageTypes.h"

Go to the source code of this file.

Data Structures

class Rx::Interop::Runtime28::IImage
Interface supported by Raytrix images. More...

Namespaces

namespace | Rx
namespace | Rx::Interop
namespace | Rx::Interop::Runtime28


RxImage.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxImage.h File Reference
#include "RxTypes.h"
#include "Rx.Interop.Runtime28/RxIfcImage.h"
#include "RxImageFormat.h"

Go to the source code of this file.

Data Structures

class Rx::CRxImage
Image class. Implements the interface IImage. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxImageFormat.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxImageFormat.h File Reference
#include "Rx.Interop.Runtime28/RxIfcImage.h"
#include "RxTypes.h"
#include <string>

Go to the source code of this file.

Data Structures

class Rx::CRxImageFormat
Image format descriptor. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxImageMoniker.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxImageMoniker.h File Reference
#include "RxImage.h"
#include "RxImageFormat.h"

Go to the source code of this file.

Data Structures

class Rx::CRxImageMoniker
Image moniker class. Implements the interface IImage but does not allocate memory. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxImageTypes.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime
  • Rx.Interop.Runtime28
Namespaces | Macros | Enumerations
RxImageTypes.h File Reference

Go to the source code of this file.

Namespaces

namespace | Rx
namespace | Rx::Interop
namespace | Rx::Interop::Runtime28
namespace | Rx::Interop::Runtime28::EDataType
The image data types.
namespace | Rx::Interop::Runtime28::EPixelType
The image pixel types.

Macros

#define | RX_IMG_BAYER_BG 0x2002
#define | RX_IMG_BAYER_GB 0x2004
#define | RX_IMG_BAYER_GR 0x2003
#define | RX_IMG_BAYER_RG 0x2001
Pixel color bayer types More...
#define | RX_IMG_BGR 0x80E0
#define | RX_IMG_BGRA 0x80E1
#define | RX_IMG_BYTE 0x1400
Image data types. More...
#define | RX_IMG_DOUBLE 0x140A
#define | RX_IMG_FLOAT 0x1406
#define | RX_IMG_INT 0x1404
#define | RX_IMG_LUMINANCE 0x1909
#define | RX_IMG_LUMINANCE_ALPHA 0x190A
#define | RX_IMG_RGB 0x1907
Pixel color types. More...
#define | RX_IMG_RGBA 0x1908
#define | RX_IMG_SHORT 0x1402
#define | RX_IMG_UNSIGNED_BYTE 0x1401
#define | RX_IMG_UNSIGNED_INT 0x1405
#define | RX_IMG_UNSIGNED_SHORT 0x1403

Enumerations

enum Rx::Interop::Runtime28::EDataType::ID {
Rx::Interop::Runtime28::EDataType::Void = 0, Rx::Interop::Runtime28::EDataType::Byte = RX_IMG_BYTE, Rx::Interop::Runtime28::EDataType::UByte = RX_IMG_UNSIGNED_BYTE, Rx::Interop::Runtime28::EDataType::Short = RX_IMG_SHORT, Rx::Interop::Runtime28::EDataType::UShort = RX_IMG_UNSIGNED_SHORT, Rx::Interop::Runtime28::EDataType::Int = RX_IMG_INT, Rx::Interop::Runtime28::EDataType::UInt = RX_IMG_UNSIGNED_INT, Rx::Interop::Runtime28::EDataType::Float = RX_IMG_FLOAT,
Rx::Interop::Runtime28::EDataType::Double = RX_IMG_DOUBLE
}
enum Rx::Interop::Runtime28::EPixelType::ID {
Rx::Interop::Runtime28::EPixelType::None = 0, Rx::Interop::Runtime28::EPixelType::RGB = RX_IMG_RGB, Rx::Interop::Runtime28::EPixelType::RGBA = RX_IMG_RGBA, Rx::Interop::Runtime28::EPixelType::BGR = RX_IMG_BGR, Rx::Interop::Runtime28::EPixelType::BGRA = RX_IMG_BGRA, Rx::Interop::Runtime28::EPixelType::Lum = RX_IMG_LUMINANCE, Rx::Interop::Runtime28::EPixelType::LumA = RX_IMG_LUMINANCE_ALPHA, Rx::Interop::Runtime28::EPixelType::BayerBG = RX_IMG_BAYER_BG,
Rx::Interop::Runtime28::EPixelType::BayerGB = RX_IMG_BAYER_GB, Rx::Interop::Runtime28::EPixelType::BayerGR = RX_IMG_BAYER_GR, Rx::Interop::Runtime28::EPixelType::BayerRG = RX_IMG_BAYER_RG
}


RxMetaData.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros
RxMetaData.h File Reference
#include "RxString.h"
#include "RxArrayUInt.h"
#include "RxArrayDouble.h"
#include "RxArrayString.h"

Go to the source code of this file.

Data Structures

class Rx::CRxMetaData
Handles a collection of meta data of different types. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxPixel.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros | Typedefs | Functions
RxPixel.h File Reference
#include <limits.h>
#include "Rx.Interop.Runtime28/RxIfcImage.h"

Go to the source code of this file.

Data Structures

struct Rx::TPixel< TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT >
General pixel template structure. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Typedefs

typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_BYTE > 		Rx::TPixel_Bay_BG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_BG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_BG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_INT > 		Rx::TPixel_Bay_BG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_SHORT > 		Rx::TPixel_Bay_BG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_BG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_BG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_BG_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_BYTE > 		Rx::TPixel_Bay_GB_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_GB_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_GB_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_INT > 		Rx::TPixel_Bay_GB_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_SHORT > 		Rx::TPixel_Bay_GB_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_GB_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_GB_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_GB_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_BYTE > 		Rx::TPixel_Bay_GR_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_GR_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_GR_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_INT > 		Rx::TPixel_Bay_GR_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_SHORT > 		Rx::TPixel_Bay_GR_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_GR_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_GR_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_GR_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_BYTE > 		Rx::TPixel_Bay_RG_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_DOUBLE > 		Rx::TPixel_Bay_RG_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_FLOAT > 		Rx::TPixel_Bay_RG_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_INT > 		Rx::TPixel_Bay_RG_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_SHORT > 		Rx::TPixel_Bay_RG_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_Bay_RG_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_Bay_RG_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_Bay_RG_us
typedef TPixel< char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_BYTE > 		Rx::TPixel_BGR_c
typedef TPixel< double,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_DOUBLE > 		Rx::TPixel_BGR_d
typedef TPixel< float,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_FLOAT > 		Rx::TPixel_BGR_f
typedef TPixel< __int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_INT > 		Rx::TPixel_BGR_i
typedef TPixel< __int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_SHORT > 		Rx::TPixel_BGR_s
typedef TPixel< unsigned char,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_BGR_uc
typedef TPixel< unsigned
__int32,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_BGR_ui
typedef TPixel< unsigned
__int16,
3, 0, 2, 1, 0, 0, RX_IMG_BGR,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_BGR_us
typedef TPixel< char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_BYTE > 		Rx::TPixel_BGRA_c
typedef TPixel< double,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_DOUBLE > 		Rx::TPixel_BGRA_d
typedef TPixel< float,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_FLOAT > 		Rx::TPixel_BGRA_f
typedef TPixel< __int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_INT > 		Rx::TPixel_BGRA_i
typedef TPixel< __int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_SHORT > 		Rx::TPixel_BGRA_s
typedef TPixel< unsigned char,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_BGRA_uc
typedef TPixel< unsigned
__int32,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_BGRA_ui
typedef TPixel< unsigned
__int16,
3, 1, 2, 1, 0, 3, RX_IMG_BGRA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_BGRA_us
typedef TPixel< char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_BYTE > 		Rx::TPixel_L_c
typedef TPixel< double,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_DOUBLE > 		Rx::TPixel_L_d
typedef TPixel< float,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_FLOAT > 		Rx::TPixel_L_f
typedef TPixel< __int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_INT > 		Rx::TPixel_L_i
typedef TPixel< __int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_SHORT > 		Rx::TPixel_L_s
typedef TPixel< unsigned char,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_L_uc
typedef TPixel< unsigned
__int32,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_L_ui
typedef TPixel< unsigned
__int16,
1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_L_us
typedef TPixel< char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_BYTE > 		Rx::TPixel_LA_c
typedef TPixel< double,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_DOUBLE > 		Rx::TPixel_LA_d
typedef TPixel< float,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_FLOAT > 		Rx::TPixel_LA_f
typedef TPixel< __int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_INT > 		Rx::TPixel_LA_i
typedef TPixel< __int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_SHORT > 		Rx::TPixel_LA_s
typedef TPixel< unsigned char,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_LA_uc
typedef TPixel< unsigned
__int32,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_LA_ui
typedef TPixel< unsigned
__int16,
1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_LA_us
typedef TPixel< char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_BYTE > 		Rx::TPixel_RGB_c
typedef TPixel< double,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_DOUBLE > 		Rx::TPixel_RGB_d
typedef TPixel< float,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_FLOAT > 		Rx::TPixel_RGB_f
typedef TPixel< __int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_INT > 		Rx::TPixel_RGB_i
typedef TPixel< __int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_SHORT > 		Rx::TPixel_RGB_s
typedef TPixel< unsigned char,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_RGB_uc
typedef TPixel< unsigned
__int32,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_RGB_ui
typedef TPixel< unsigned
__int16,
3, 0, 0, 1, 2, 0, RX_IMG_RGB,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_RGB_us
typedef TPixel< char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_BYTE > 		Rx::TPixel_RGBA_c
typedef TPixel< double,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_DOUBLE > 		Rx::TPixel_RGBA_d
typedef TPixel< float,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_FLOAT > 		Rx::TPixel_RGBA_f
typedef TPixel< __int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_INT > 		Rx::TPixel_RGBA_i
typedef TPixel< __int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_SHORT > 		Rx::TPixel_RGBA_s
typedef TPixel< unsigned char,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_BYTE > 		Rx::TPixel_RGBA_uc
typedef TPixel< unsigned
__int32,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_INT > 		Rx::TPixel_RGBA_ui
typedef TPixel< unsigned
__int16,
3, 1, 0, 1, 2, 3, RX_IMG_RGBA,
RX_IMG_UNSIGNED_SHORT > 		Rx::TPixel_RGBA_us

Functions

void | Rx::Float2Pixel (char &rPx, float fVal)
void | Rx::Float2Pixel (unsigned char &rPx, float fVal)
void | Rx::Float2Pixel (short &rPx, float fVal)
void | Rx::Float2Pixel (unsigned short &rPx, float fVal)
void | Rx::Float2Pixel (int &rPx, float fVal)
void | Rx::Float2Pixel (unsigned int &rPx, float fVal)
void | Rx::Float2Pixel (float &rPx, float fVal)
void | Rx::Float2Pixel (double &rPx, float fVal)
void | Rx::Float2Pixel (char &rPx, double fVal)
void | Rx::Float2Pixel (unsigned char &rPx, double fVal)
void | Rx::Float2Pixel (short &rPx, double fVal)
void | Rx::Float2Pixel (unsigned short &rPx, double fVal)
void | Rx::Float2Pixel (int &rPx, double fVal)
void | Rx::Float2Pixel (unsigned int &rPx, double fVal)
void | Rx::Float2Pixel (float &rPx, double fVal)
void | Rx::Float2Pixel (double &rPx, double fVal)
void | Rx::Pixel2Float (float &fVal, char rPx)
void | Rx::Pixel2Float (float &fVal, unsigned char rPx)
void | Rx::Pixel2Float (float &fVal, short rPx)
void | Rx::Pixel2Float (float &fVal, unsigned short rPx)
void | Rx::Pixel2Float (float &fVal, int rPx)
void | Rx::Pixel2Float (float &fVal, unsigned int rPx)
void | Rx::Pixel2Float (float &fVal, float rPx)
void | Rx::Pixel2Float (float &fVal, double rPx)
void | Rx::Pixel2Float (double &fVal, char rPx)
void | Rx::Pixel2Float (double &fVal, unsigned char rPx)
void | Rx::Pixel2Float (double &fVal, short rPx)
void | Rx::Pixel2Float (double &fVal, unsigned short rPx)
void | Rx::Pixel2Float (double &fVal, int rPx)
void | Rx::Pixel2Float (double &fVal, unsigned int rPx)
void | Rx::Pixel2Float (double &fVal, float rPx)
void | Rx::Pixel2Float (double &fVal, double rPx)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxString.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Data Structures | Namespaces | Macros | Functions
RxString.h File Reference
#include <string>

Go to the source code of this file.

Data Structures

class Rx::CRxString
Basic character string operations. More...

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Functions

CRxString | Rx::operator+ (const CRxString &sxA, const CRxString &sxB)
CRxString | Rx::operator+ (const CRxString &sxA, const char *pcB)
CRxString | Rx::operator+ (const char *pcA, const CRxString &sxB)
CRxString | Rx::operator+ (const CRxString &sxA, int iVal)
CRxString | Rx::operator+ (const CRxString &sxA, unsigned int uVal)
CRxString | Rx::operator+ (const CRxString &sxA, float fVal)
CRxString | Rx::operator+ (const CRxString &sxA, double dVal)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxTime.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Namespaces | Macros | Functions
RxTime.h File Reference

Go to the source code of this file.

Namespaces

namespace Rx

Macros

#define RXCORE_API __declspec(dllimport)

Functions

double | Rx::GetTime ()
__int64 | Rx::GetTime64 ()
void | Rx::InitTime ()
void | Rx::Sleep (unsigned uTime)

Macro Definition Documentation

#define RXCORE_API __declspec(dllimport)


RxTypes.h File Reference

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Typedefs
RxTypes.h File Reference

Go to the source code of this file.

Typedefs

typedef unsigned char | uchar
typedef unsigned int | uint


Globals

  • File List
  • Globals
  • All
  • Typedefs
  • Macros
  • c
  • d
  • r
  • u
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CLUVIZDLL_API : CvCluViz.h , CvCluVizSt.h
  • CLUVIZTOOL_API : CvCluVizTool.h

- d -

  • DEPRECATED : Rx.ApiLF.h

- r -

  • RX_IMG_BAYER_BG : RxImageTypes.h
  • RX_IMG_BAYER_GB : RxImageTypes.h
  • RX_IMG_BAYER_GR : RxImageTypes.h
  • RX_IMG_BAYER_RG : RxImageTypes.h
  • RX_IMG_BGR : RxImageTypes.h
  • RX_IMG_BGRA : RxImageTypes.h
  • RX_IMG_BYTE : RxImageTypes.h
  • RX_IMG_DOUBLE : RxImageTypes.h
  • RX_IMG_FLOAT : RxImageTypes.h
  • RX_IMG_INT : RxImageTypes.h
  • RX_IMG_LUMINANCE : RxImageTypes.h
  • RX_IMG_LUMINANCE_ALPHA : RxImageTypes.h
  • RX_IMG_RGB : RxImageTypes.h
  • RX_IMG_RGBA : RxImageTypes.h
  • RX_IMG_SHORT : RxImageTypes.h
  • RX_IMG_UNSIGNED_BYTE : RxImageTypes.h
  • RX_IMG_UNSIGNED_INT : RxImageTypes.h
  • RX_IMG_UNSIGNED_SHORT : RxImageTypes.h
  • RX_TRY : Rx.ApiLF.h
  • RXCORE_API : RxArrayString.h , RxMetaData.h , RxImageMoniker.h , RxArrayUInt.h , RxImage.h , RxString.h , RxPixel.h , RxImageFormat.h , RxArrayInt.h , RxArrayUChar.h , RxCore.h , RxTime.h , RxArrayDouble.h
  • RXLF_API : Rx.ApiLF.h

- u -

  • uchar : RxTypes.h
  • uint : RxTypes.h


Globals

  • File List
  • Globals
  • All
  • Typedefs
  • Macros
  • uchar : RxTypes.h
  • uint : RxTypes.h


Globals

  • File List
  • Globals
  • All
  • Typedefs
  • Macros
  • c
  • d
  • r

- c -

  • CLUVIZDLL_API : CvCluViz.h , CvCluVizSt.h
  • CLUVIZTOOL_API : CvCluVizTool.h

- d -

  • DEPRECATED : Rx.ApiLF.h

- r -

  • RX_IMG_BAYER_BG : RxImageTypes.h
  • RX_IMG_BAYER_GB : RxImageTypes.h
  • RX_IMG_BAYER_GR : RxImageTypes.h
  • RX_IMG_BAYER_RG : RxImageTypes.h
  • RX_IMG_BGR : RxImageTypes.h
  • RX_IMG_BGRA : RxImageTypes.h
  • RX_IMG_BYTE : RxImageTypes.h
  • RX_IMG_DOUBLE : RxImageTypes.h
  • RX_IMG_FLOAT : RxImageTypes.h
  • RX_IMG_INT : RxImageTypes.h
  • RX_IMG_LUMINANCE : RxImageTypes.h
  • RX_IMG_LUMINANCE_ALPHA : RxImageTypes.h
  • RX_IMG_RGB : RxImageTypes.h
  • RX_IMG_RGBA : RxImageTypes.h
  • RX_IMG_SHORT : RxImageTypes.h
  • RX_IMG_UNSIGNED_BYTE : RxImageTypes.h
  • RX_IMG_UNSIGNED_INT : RxImageTypes.h
  • RX_IMG_UNSIGNED_SHORT : RxImageTypes.h
  • RX_TRY : Rx.ApiLF.h
  • RXCORE_API : RxArrayString.h , RxMetaData.h , RxImageMoniker.h , RxArrayUInt.h , RxImage.h , RxString.h , RxPixel.h , RxImageFormat.h , RxArrayInt.h , RxArrayUChar.h , RxCore.h , RxTime.h , RxArrayDouble.h
  • RXLF_API : Rx.ApiLF.h


ApiLFDoc_ChangeLog.dox File Reference

  • File List
  • Globals
ApiLFDoc_ChangeLog.dox File Reference


ApiLFDoc_Main.dox File Reference

  • File List
  • Globals
ApiLFDoc_Main.dox File Reference


ApiLFDoc_ProgMain.dox File Reference

  • File List
  • Globals
ApiLFDoc_ProgMain.dox File Reference


CvCluViz.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.MT
CvCluViz.h
Go to the documentation of this file.
1 // Folgender ifdef-Block ist die Standardmethode zum Erstellen von Makros, die das Exportieren
2 // aus einer DLL vereinfachen. Alle Dateien in dieser DLL werden mit dem NLVIZDLL_EXPORTS-Symbol
3 // kompiliert, das in der Befehlszeile definiert wurde. Das Symbol darf nicht f�r ein Projekt definiert werden,
4 // das diese DLL verwendet. Alle anderen Projekte, deren Quelldateien diese Datei beinhalten, erkennen
5 // CLUVIZDLL_API-Funktionen als aus einer DLL importiert, w�hrend die DLL
6 // mit diesem Makro definierte Symbole als exportiert ansieht.
7
8 #ifdef CLUVIZDLL_EXPORTS
9 #define CLUVIZDLL_API __declspec(dllexport)
10 #else
11 #define CLUVIZDLL_API __declspec(dllimport)
12 #endif
13
14
15 #include <string>
16 #include <vector>
17 using namespace std;
18
19 #include "Rx.CluViz.Core.Base\CLUVizDefines.h"
20 #include "Rx.CluViz.Core.Base\CLUVizTypes.h"
21
22 namespace CLUViz { namespace MT
23 {
24 // Get the version of CluVizCore
25 CLUVIZDLL_API bool GetVersion( char* pcVersion, int iBufLen );
26
27 // Get a key needed to encode pcLicenceKey Data
28 CLUVIZDLL_API bool GetKey( unsigned __int32 *pKey );
29
30 // Load an Icon
31 CLUVIZDLL_API void* GetIconHandle( const char *pcFilename, bool bModule = false );
32
33 // Get path to script for specific file type
34 CLUVIZDLL_API bool GetFileTypeScript( const char* pcFileType, int iMaxLen, char* pcData );
35
36 // Start the CLUViz Engine.
37 // The values passed in pcRegKey und pcLicenceKey are ignored in the
38 // CLUVizHome version.
39 // In the Pro version, pcRegKey gives the key in the registry in which
40 // the two elements "Install_Dir" and "Licence_Dir" are defined.
41 // pcLicenceKey is a string containing the key that has to fit the licence
42 // in the licence file. As licence files all files of the pattern "*.dat"
43 // that are found in the path contained in "Licence_Dir" are tested.
44 CLUVIZDLL_API bool Start( const char *pcEnvPath = 0, const char *pcLicenceKey = 0 );
45 CLUVIZDLL_API bool StartAgain( const char *pcEnvPath = 0, const char *pcLicenceKey = 0 );
46 bool _Start( const char *pcEnvPath, const char *pcLicenceKey, bool bInitAll );
47
48 CLUVIZDLL_API void GetStdEnvPath(char *pcPath, int iMaxLen);
49
50 // End the engine
51 CLUVIZDLL_API bool End();
52
53 CLUVIZDLL_API bool WaitForEnd();
54 CLUVIZDLL_API bool EnableUserEnd(bool bVal);
55 CLUVIZDLL_API bool IsRunning( int iWait );
56 CLUVIZDLL_API bool IsViewValid( int iHandle );
57
58 CLUVIZDLL_API bool InfoBox( const char *pcText );
59
60 CLUVIZDLL_API bool SetScriptPath( const char *pcPath );
61
62 CLUVIZDLL_API bool Create( int &iHandle, int iX, int iY, int iWidth, int iHeight,
63 const char *pcTitle );
64
65 CLUVIZDLL_API bool CreateEx1( int &iHandle, int iX, int iY, int iWidth, int iHeight,
66 const char *pcTitle, unsigned int uWindowStyle );
67
68 CLUVIZDLL_API bool CreateEx2( int &iHandle, int iX, int iY, int iWidth, int iHeight,
69 const char *pcTitle, const char *pcInitScript,
70 const char *pcCLUPath, bool bVizOnly, bool bShowIntro,
71 void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle );
72
73 CLUVIZDLL_API bool Destroy( int iHandle );
74 CLUVIZDLL_API bool DestroyAll();
75
76 CLUVIZDLL_API bool ShowWindow( int iHandle );
77 CLUVIZDLL_API bool HideWindow( int iHandle );
78 CLUVIZDLL_API bool SetWindowPosSize( int iHandle, int iX, int iY, int iWidth, int iHeight );
79
80 CLUVIZDLL_API bool SetScript( int iHandle, const char *pcScript );
81 CLUVIZDLL_API bool LoadScript( int iHandle, const char *pcFilename );
82 CLUVIZDLL_API bool LoadScript( int iHandle, const char *pcFilename, const char *pcPass );
83 // iArgCnt: Number of arguments for script. pcArg contains iArgCnt strings separated by \r (0x13).
84 CLUVIZDLL_API bool LoadScript( int iHandle, const char *pcFilename, const char *pcPass, int iArgCnt, const char *pcArg );
85
86 CLUVIZDLL_API bool GetLastError( char *pcError, int iMaxLen );
87 CLUVIZDLL_API bool SetTimeout( unsigned int uMilliSeconds );
88
89 CLUVIZDLL_API bool ExecUser( int iHandle, const char *pcToolName = 0 );
90 CLUVIZDLL_API bool FullScreen( int iHandle, bool bVal = true );
91 CLUVIZDLL_API bool FullScreen( int iHandle, bool bVal, bool bEnableUserToggle );
92
93 CLUVIZDLL_API bool SetVarNumber( int iHandle, const char *pcVarName, int iVal );
94 CLUVIZDLL_API bool GetVarNumber( int iHandle, const char *pcVarName, int &iVal );
95
96 CLUVIZDLL_API bool SetVarNumber( int iHandle, const char *pcVarName, double dVal );
97 CLUVIZDLL_API bool GetVarNumber( int iHandle, const char *pcVarName, double &dVal );
98
99 CLUVIZDLL_API bool SetVarString( int iHandle, const char *pcVarName,
100 const char *pcString );
101 CLUVIZDLL_API bool GetVarString( int iHandle, const char *pcVarName,
102 char *pcString, int iMaxLen );
103
104 CLUVIZDLL_API bool SetVarTensor( int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData );
105 //CLUVIZDLL_API bool SetVarTensor( int iHandle, const char *pcVarName, const vector<int>& vecDim, const vector<double>& vecData );
106 CLUVIZDLL_API bool GetVarTensor( int iHandle, const char *pcVarName, vector<int>& vecDim, vector<double>& vecData );
107 CLUVIZDLL_API bool GetVarTensorProp( int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt );
108 CLUVIZDLL_API bool GetVarTensorData( int iHandle, const char *pcVarName, unsigned *puDim, double *pdData );
109
110 CLUVIZDLL_API bool SetVarImage( int iHandle, const char *pcVarName, int iWidth, int iHeight,
111 int iImgType, int iDataType, const void *pvData );
112 CLUVIZDLL_API bool GetVarImageProp( int iHandle, const char *pcVarName, int &iWidth, int &iHeight,
113 int &iImgType, int &iDataType, int &iBytesPerPixel );
114 CLUVIZDLL_API bool GetVarImageData( int iHandle, const char *pcVarName, void *pvData );
115
116 CLUVIZDLL_API bool SetVarColor( int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha );
117 CLUVIZDLL_API bool SetVarColor( int iHandle, const char *pcVarName, double *pdColor4 );
118 CLUVIZDLL_API bool GetVarColor( int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha );
119 CLUVIZDLL_API bool GetVarColor( int iHandle, const char *pcVarName, double *pdColor4 );
120
121 } } // namespace CLUViz::MT
122
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


CvCluVizEx.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.MT
CvCluVizEx.h
Go to the documentation of this file.
1
2
3 namespace CLUViz
4 {
5 CLUVIZDLL_API bool CreateEx( int &iHandle, int iX, int iY, int iWidth, int iHeight,
6 const char *pcTitle, const char *pcInitScript,
7 const char *pcCLUPath, bool bVizOnly, bool bShowIntro,
8 void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle );
9
10 CLUVIZDLL_API bool CheckFeature( __int32 iFeature );
11 }
12
13 namespace CLUVizST
14 {
15 CLUVIZDLL_API bool Run();
16 CLUVIZDLL_API bool RunMsg( __int64 hWnd, unsigned uMsg, unsigned wParam, long lParam );
17
18 CLUVIZDLL_API bool Start();
19 CLUVIZDLL_API bool End();
20 CLUVIZDLL_API bool CreateEx( int &iHandle, int iX, int iY, int iWidth, int iHeight,
21 const char *pcTitle, const char *pcInitScript,
22 const char *pcCLUPath, bool bVizOnly, bool bShowIntro,
23 void *pvIcon, void *pvParentHandle, unsigned int uWindowStyle );
24
25 CLUVIZDLL_API bool EnableBorder( int iHandle, bool bVal );
26
27 }
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


CvCluVizSt.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.ST
CvCluVizSt.h
Go to the documentation of this file.
1 // Folgender ifdef-Block ist die Standardmethode zum Erstellen von Makros, die das Exportieren
2 // aus einer DLL vereinfachen. Alle Dateien in dieser DLL werden mit dem NLVIZDLL_EXPORTS-Symbol
3 // kompiliert, das in der Befehlszeile definiert wurde. Das Symbol darf nicht f�r ein Projekt definiert werden,
4 // das diese DLL verwendet. Alle anderen Projekte, deren Quelldateien diese Datei beinhalten, erkennen
5 // CLUVIZDLL_API-Funktionen als aus einer DLL importiert, w�hrend die DLL
6 // mit diesem Makro definierte Symbole als exportiert ansieht.
7
8 #ifdef CVCLUVIZST_EXPORTS
9 #define CLUVIZDLL_API __declspec(dllexport)
10 #else
11 #define CLUVIZDLL_API __declspec(dllimport)
12 #endif
13
14
15 #include <string>
16 #include <vector>
17 using namespace std;
18
19 #include "Rx.CluViz.Core.Base\CLUVizDefines.h"
20 #include "Rx.CluViz.Core.Base\CLUVizTypes.h"
21
22 namespace CLUViz { namespace ST
23 {
24
25 CLUVIZDLL_API void GetStdEnvPath(char *pcPath, int iMaxLen);
26
27 // Get the version of CluVizCore
28 CLUVIZDLL_API bool GetVersion( char* pcVersion, int iBufLen );
29
30 CLUVIZDLL_API bool GetKey( unsigned __int32 *pKey );
31
32 // Start the CLUViz Engine.
33 CLUVIZDLL_API bool Start( const char *pcEnvPath = 0, const char *pcLicenceKey = 0, bool bAlone = true );
34
35 // End the engine
36 CLUVIZDLL_API bool End();
37
38 // Get the error text of the last error that occured
39 CLUVIZDLL_API bool GetLastError( char *pcError, int iMaxLen );
40
41 // Embed a CLUViz window into the window given by hWnd
42 CLUVIZDLL_API bool EmbedWindow( int &iHandle, __int64 hWnd, bool bCreateSRC = false, __int64 *phGlRc = 0 );
43
44 // Release a CLUViz Window
45 CLUVIZDLL_API bool ReleaseWindow( int iHandle );
46 // Release all CLUViz Windows
47 CLUVIZDLL_API bool ReleaseAll();
48
49 // Functions to update OGLWin when window GL Window is embedded in has changed
50 CLUVIZDLL_API bool EW_Display( int iHandle, bool bWait = false );
51 CLUVIZDLL_API bool EW_Reshape(int iHandle, int iWidth, int iHeight);
52 CLUVIZDLL_API bool EW_Mouse(int iHandle, int iButton, int iState, int iX, int iY);
53 //bool EW_Key(int iHandle, unsigned char cKey, int iX, int iY);
54 CLUVIZDLL_API bool EW_ActiveMouseMove(int iHandle, int iX, int iY);
55 CLUVIZDLL_API bool EW_PassiveMouseMove(int iHandle, int iX, int iY);
56 CLUVIZDLL_API bool EW_IdleFunc(int iHandle);
57 CLUVIZDLL_API bool EW_SetKeyModifierStates(int iHandle, bool bShift, bool bCtrl, bool bAlt, bool bNumLock, bool bCapsLock, bool bScrollLock );
58 CLUVIZDLL_API bool EW_Keyboard( int iHandle, int iKey, bool bKeyDown );
59 CLUVIZDLL_API bool EW_LoadScript( int iHandle, const char* pcFilename, const char* pcPass = 0);
60 CLUVIZDLL_API bool EW_SetScript( int iHandle, const char *pcScript, bool bResetEnv = false, bool bReparseLatex = false );
61 CLUVIZDLL_API bool EW_ExecUser( int iHandle, const char *pcToolName = 0 );
62 CLUVIZDLL_API bool EW_LockVis( int iHandle, bool bLock );
63
64 CLUVIZDLL_API bool EW_MakeCurrentSRC(int iHandle);
65
66 // Further View access functions
67 CLUVIZDLL_API bool SaveView( int iHandle, const char* pcFilename );
68
69 // Enable/Disable visualization
70 CLUVIZDLL_API bool EnableVisualization( int iHandle, bool bVal );
71
72 // Get Script Output
73 CLUVIZDLL_API bool GetScriptOutput( int iHandle, char *pcText, int iMaxLen, bool &bIsError );
74
75 CLUVIZDLL_API bool SetScriptPath( const char *pcPath );
76
77
78 // Get/Set CLUScript Number
79 CLUVIZDLL_API bool SetVarNumber( int iHandle, const char *pcVarName, int iVal );
80 CLUVIZDLL_API bool GetVarNumber( int iHandle, const char *pcVarName, int &iVal );
81
82 CLUVIZDLL_API bool SetVarNumber( int iHandle, const char *pcVarName, double dVal );
83 CLUVIZDLL_API bool GetVarNumber( int iHandle, const char *pcVarName, double &dVal );
84
85 CLUVIZDLL_API bool SetVarString( int iHandle, const char *pcVarName,
86 const char *pcString );
87 CLUVIZDLL_API bool GetVarString( int iHandle, const char *pcVarName,
88 char *pcString, int iMaxLen );
89
90 CLUVIZDLL_API bool SetVarTensor( int iHandle, const char *pcVarName, int iDimCnt, const int *piDim, const double *pdData );
91 CLUVIZDLL_API bool GetVarTensorProp( int iHandle, const char *pcVarName, unsigned &uDimCnt, unsigned &uElCnt );
92 CLUVIZDLL_API bool GetVarTensorData( int iHandle, const char *pcVarName, unsigned *puDim, double *pdData );
93
94 CLUVIZDLL_API bool SetVarImage( int iHandle, const char *pcVarName, int iWidth, int iHeight,
95 int iImgType, int iDataType, const void *pvData );
96 CLUVIZDLL_API bool GetVarImageProp( int iHandle, const char *pcVarName, int &iWidth, int &iHeight,
97 int &iImgType, int &iDataType, int &iBytesPerPixel );
98 CLUVIZDLL_API bool GetVarImageData( int iHandle, const char *pcVarName, void *pvData );
99
100 CLUVIZDLL_API bool SetVarColor( int iHandle, const char *pcVarName, double dRed, double dGreen, double dBlue, double dAlpha );
101 CLUVIZDLL_API bool SetVarColor( int iHandle, const char *pcVarName, double *pdColor4 );
102 CLUVIZDLL_API bool GetVarColor( int iHandle, const char *pcVarName, double &dRed, double &dGreen, double &dBlue, double &dAlpha );
103 CLUVIZDLL_API bool GetVarColor( int iHandle, const char *pcVarName, double *pdColor4 );
104
105 CLUVIZDLL_API bool SetVarObject( int iHandle, const char *pcVarName, const CLUViz::SObject *pData);
106 }} // namespace CLUViz::ST
107
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


CvCluVizTool.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.CluVizTool
CvCluVizTool.h
Go to the documentation of this file.
1
2 // Copyright (c) 2013 Raytrix GmbH. All rights reserved.
4
5 #ifdef CVCLUVIZTOOL_EXPORTS
6 #define CLUVIZTOOL_API __declspec(dllexport)
7 #else
8 #define CLUVIZTOOL_API __declspec(dllimport)
9 #endif
10
11 #include "Rx.Interop.Runtime28\RxIfcImage.h"
12
14 // namespace: CLUViz
16 namespace CLUViz { namespace Tool
17 {
18 CLUVIZTOOL_API bool Init( const char *pcEnvPath = 0 );
19 CLUVIZTOOL_API bool Finalize(void);
20
21 CLUVIZTOOL_API bool CreateViewImage(int &iHandle, int iX, int iY, int iWidth, int iHeight, const char* pcTitle);
22 CLUVIZTOOL_API bool DestroyView(int iHandle);
23
24 CLUVIZTOOL_API bool ViewSetImage(int iHandle, Rx::Interop::Runtime28::IImage *pImage, bool bUpdate = false );
25
26 CLUVIZTOOL_API bool ReadImage( const char* pcFilename, Rx::Interop::Runtime28::IImage *pImage );
27 CLUVIZTOOL_API bool WriteImage( const char* pcFilename, const Rx::Interop::Runtime28::IImage *pImage );
28
29 CLUVIZTOOL_API const char* GetLastError( bool bReset = true );
30
31 }} // namespace CLUViz::Tool
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


Rx.ApiLF.ErrorValues.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.ErrorValues.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5
13 #ifdef RX_MANAGED_ENUM
14
20
21 public enum class EError
22 #else
23 namespace EError {
24
30
31 enum ID
32 #endif
33 {
35 NONE = 0,
36
38 COMPUTE = -1,
39
40 // General Errors
42 OUTOFMEMORY = -100,
44 OUTOFRANGE = -101,
46 INVALID_POINTER = -102,
48 INSTALL = -103,
50 INTERNAL = -104,
51
52 // API Errors
54 API_INIT = -1000,
56 API_NOINIT = -1001,
58 API_LOADFILE = -1002,
60 API_INVALID_IMGID = -1003,
62 API_NOLFIBOUND = -1004,
64 API_INVALID_IMAGE = -1005,
66 API_SAVEFILE = -1006,
68 API_INITAGAIN = -1007,
70 API_UNKNOWN = -1008,
72 API_INSTPATH = -1009,
74 API_DONGLE = -1010,
76 API_FEATURE = -1011,
78 API_INVALID_GLTEX = -1012,
80 API_INVALID_IMGTYPE = -1013,
82 API_INVALID_VALUE = -1014,
84 API_LFI_BIND = -1015,
86 API_LFI_BOUND = -1016,
88 API_VERSION = -1017,
89
90 // Parameter Errors
92 PAR_EXIST = -2000,
94 PAR_TYPE = -2001,
96 PAR_ACSREAD = -2002,
98 PAR_ACSWRITE = -2003,
100 PAR_READ = -2004,
102 PAR_WRITE = -2005,
104 PAR_VALUE = -2006,
106 PAR_NOCONSTR = -2007,
108 PAR_INVCONSTR = -2008,
110 PAR_GRPEXIST = -2009,
112 PAR_NOTSUPPORTED = -2010,
114 PAR_NOTAVAILABLE = -2011,
115
116
117 // Cuda Errors
119 CUDA_MAX = -3000,
121 CUDA_INIT = -3000,
123 CUDA_NODEVICE = -3001,
125 CUDA_CAPA = -3002,
127 CUDA_ALGO = -3003,
129 CUDA_INITAGAIN = -3004,
131 CUDA_NOINIT = -3005,
133 CUDA_INVDEVID = -3006,
135 CUDA_MIN = -3999,
136
137 // Camera Driver Errors
139 CAMDRV_INIT = -4000,
141 CAMDRV_INITAGAIN = -4001,
143 CAMDRV_NOINIT = -4002,
145 CAMDRV_INVCAMID = -4003,
146
148 CAMERA_OPEN = -4100,
150 CAMERA_CLOSE = -4101,
152 CAMERA_STARTCAP = -4102,
154 CAMERA_STOPCAP = -4103,
156 CAMERA_CAPACTIVE = -4104,
158 CAMERA_CAPNOTACTIVE = -4105,
160 CAMERA_CAPTURE = -4106,
162 CAMERA_ACTIVE = -4107,
164 CAMERA_NOTACTIVE = -4108,
166 CAMERA_NOCALFILE = -4109,
168 CAMERA_INVCALFILE = -4110,
170 CAMERA_STORECALFILE = -4111,
172 CAMERA_LENSSETNEW = -4112,
174 CAMERA_LENSSETEXIST = -4113,
176 CAMERA_LENSSETDEL = -4114,
178 CAMERA_LENSNEW = -4115,
180 CAMERA_LENSIDEXIST = -4116,
182 CAMERA_LENSDEL = -4117,
184 CAMERA_STOREIMGWHITE = -4118,
186 CAMERA_NOIMGWHITE = -4119,
188 CAMERA_UPDATECALIB = -4120,
190 CAMERA_SUSPENDCAP = -4121,
192 CAMERA_CALFILEEXIST = -4122,
194 CAMERA_CREATECALFILE = -4123,
196 CAMERA_LENSDEL_LAST_LENS = -4124,
198 CAMERA_TIMEOUT = -4125,
200 CAMERA_TRIGGERMODE_NOT_AVAILABLE = -4126,
202 CAMERA_CAPTURE_STOPPED_UNEXPECTED = -4127,
204 CAMERA_CAPTURE_EXCEPTION = -4128,
206 CAMERA_CAPTURE_INTERNAL_API = -4129,
207
209 CAMCAL_NOLENS = -4200,
211 CAMCAL_NOLENSSET = -4201,
213 CAMCAL_INVLENSIDX = -4202,
215 CAMCAL_INVLENSSETIDX = -4203,
216
217 // OpenGL Interop.
219 GL_NOINTEROP = -5000,
221 GL_TEXNOTSUPPORTED = -5001,
222
223 // Internal images
225 IMG_NOTSUPPORTED = -6000,
227 IMG_DITNOTSUPPORTED = -6001,
228
229 // Ray sequence
231 RAYSEQ_OPENREAD = -7000,
233 RAYSEQ_OPENWRITE = -7001,
235 RAYSEQ_READ = -7002,
237 RAYSEQ_WRITE = -7003,
239 RAYSEQ_INVALID = -7004,
241 RAYSEQ_VERSION = -7005,
243 RAYSEQ_CLOSE = -7006,
245 RAYSEQ_NOTOPEN = -7007,
247 RAYSEQ_EOF = -7008,
249 RAYSEQ_SOF = -7009,
251 RAYSEQ_COMPRESS = -7010,
253 RAYSEQ_UNCOMPRESS = -7011,
255 RAYSEQ_UNKOWNCOMP = -7012,
257 RAYSEQ_UNSUPPIXTYPE = -7013,
259 RAYSEQ_WHITEIMAGE = -7014,
261 RAYSEQ_BIND = -7015,
263 RAYSEQ_IMAGEFORMAT = -7016,
265 RAYSEQ_WRITEINIT = -7017,
267 RAYSEQ_SETFRAMEIDX = -7018,
268
270 RAYSEQ_AUTOWRITE = -7094,
272 RAYSEQ_NOREAD = -7095,
274 RAYSEQ_NOWRITE = -7096,
276 RAYSEQ_NOT_BOUND = -7097,
278 RAYSEQ_ALREADY_BOUND = -7098,
280 RAYSEQ_INVALID_ID = -7099,
282 RAYSEQ_INTERNAL = -7100,
283
284
285
286 };
287 #ifndef RX_MANAGED_ENUM
288 } // namespace EError
289 #endif
290
292
293 #ifdef RX_MANAGED_ENUM
294
295
296
297 public enum class EWarning
298 #else
302 namespace EWarning { enum ID
303 #endif
304 {
306 NONE = 0,
307
309 GENERAL = 1,
310
311
313 CAMERA_CORRUPTDB = 4100,
315 CAMERA_CAPTURE_NOIMAGE = 4101,
317 CAMERA_INVWHITETYPE = 4102,
319 CAMERA_CAPTURE_STOPPED = 4103,
321 CAMERA_TYPE_MISMATCH = 4104,
322
323 };
324 #ifndef RX_MANAGED_ENUM
325 } // namespace EWarning
326 #endif
327
328
329
330
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


Rx.ApiLF.Errors.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.Errors.h
Go to the documentation of this file.
1 #pragma once
2
3
4 namespace Rx { namespace ApiLF
5 {
10
11 # undef RX_MANAGED_ENUM
12 # include "Rx.ApiLF.ErrorValues.h"
13 # undef RX_MANAGED_ENUM
14
17 }}
18
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


Rx.ApiLF.FeatureValues.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.FeatureValues.h
Go to the documentation of this file.
1
2 #ifdef RX_MANAGED_ENUM
3
9
10 public enum class EFeature
11 #else
15 namespace EFeature {
16
22
23 enum ID
24 #endif
25 {
27 None = 0,
28
30 Standard = 0x0001,
31
34 MultiView = 0x0002,
35
38 FocusOnSurface = 0x0004,
39
42 Calculate3D = 0x0008,
43
46 Calibrate = 0x0010,
47
50 RawImage = 0x0020,
51
54 Save = 0x0040,
55
56
57 };
58 #ifndef RX_MANAGED_ENUM
59 } // namespace EFeature
60 #endif
61
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


Rx.ApiLF.Features.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.Features.h
Go to the documentation of this file.
1 #pragma once
2
3
4 namespace Rx { namespace ApiLF
5 {
10
11 # undef RX_MANAGED_ENUM
12 # include "Rx.ApiLF.FeatureValues.h"
13 # undef RX_MANAGED_ENUM
14
16 }}
17
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


Rx.ApiLF.Net.CtrlLogListView.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Rx.ApiLF.Net.CtrlLogListView.h
Go to the documentation of this file.
1 #pragma once
2
3 using namespace System;
4 using namespace System::ComponentModel;
5 using namespace System::Collections;
6 using namespace System::Windows::Forms;
7 using namespace System::Data;
8 using namespace System::Drawing;
9
10 #pragma managed(push, off)
11 #include "Rx.Core\RxTime.h"
12 #pragma managed(on)
13
14
15 namespace Rx { namespace ApiLF { namespace NET
16 {
17
18
22 ref class CtrlLogListView : public System::Windows::Forms::UserControl
23 {
24 public:
25 CtrlLogListView(void)
26 {
27 InitializeComponent();
28
29 m_dLastTime = Rx::GetTime();
30 }
31
32 void AddMessage(Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue);
33
34 protected:
38 ~CtrlLogListView()
39 {
40 if (components)
41 {
42 delete components;
43 }
44 }
45
46 double m_dLastTime;
47
48 void OnStatusProgress( Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, System::String^ sSourceName, System::String^ sMessage, int iValue );
49 void OnProgressBarInit( int iValue, int iMin, int iMax, int iStep );
50 void OnProgressBarStep( int iValue );
51 void OnProgressBarSetValue( int iValue );
52 void OnProgressBarFinished();
53
54
55
56 private: RxNET::GUI::RxFlickerFreeListView^ rxListView;
57 private: System::Windows::Forms::ColumnHeader^ chType;
58 private: System::Windows::Forms::ColumnHeader^ chMessage;
59 private: System::Windows::Forms::ColumnHeader^ chSource;
60 private: System::Windows::Forms::ColumnHeader^ chTime;
61 private: System::Windows::Forms::ProgressBar^ progBarLog;
62 private: System::Windows::Forms::SplitContainer^ splitContainer1;
63 protected:
64
65 protected:
66
67 private:
71 System::ComponentModel::Container ^components;
72
73 #pragma region Windows Form Designer generated code
74
75
76
77
78 void InitializeComponent(void)
79 {
80 this->rxListView = (gcnew RxNET::GUI::RxFlickerFreeListView());
81 this->chType = (gcnew System::Windows::Forms::ColumnHeader());
82 this->chMessage = (gcnew System::Windows::Forms::ColumnHeader());
83 this->chSource = (gcnew System::Windows::Forms::ColumnHeader());
84 this->chTime = (gcnew System::Windows::Forms::ColumnHeader());
85 this->progBarLog = (gcnew System::Windows::Forms::ProgressBar());
86 this->splitContainer1 = (gcnew System::Windows::Forms::SplitContainer());
87 (cli::safe_cast<System::ComponentModel::ISupportInitialize^ >(this->splitContainer1))->BeginInit();
88 this->splitContainer1->Panel1->SuspendLayout();
89 this->splitContainer1->Panel2->SuspendLayout();
90 this->splitContainer1->SuspendLayout();
91 this->SuspendLayout();
92 //
93 // rxListView
94 //
95 this->rxListView->BorderStyle = System::Windows::Forms::BorderStyle::None;
96 this->rxListView->Columns->AddRange(gcnew cli::array< System::Windows::Forms::ColumnHeader^ >(4) {this->chType, this->chMessage,
97 this->chSource, this->chTime});
98 this->rxListView->Dock = System::Windows::Forms::DockStyle::Fill;
99 this->rxListView->FullRowSelect = true;
100 this->rxListView->Location = System::Drawing::Point(0, 0);
101 this->rxListView->Name = L"rxListView";
102 this->rxListView->Size = System::Drawing::Size(634, 290);
103 this->rxListView->TabIndex = 0;
104 this->rxListView->UseCompatibleStateImageBehavior = false;
105 this->rxListView->View = System::Windows::Forms::View::Details;
106 //
107 // chType
108 //
109 this->chType->Text = L"Type";
110 this->chType->Width = 75;
111 //
112 // chMessage
113 //
114 this->chMessage->Text = L"Message";
115 this->chMessage->Width = 328;
116 //
117 // chSource
118 //
119 this->chSource->Text = L"Source";
120 this->chSource->Width = 101;
121 //
122 // chTime
123 //
124 this->chTime->Text = L"Time";
125 this->chTime->Width = 96;
126 //
127 // progBarLog
128 //
129 this->progBarLog->Dock = System::Windows::Forms::DockStyle::Fill;
130 this->progBarLog->Location = System::Drawing::Point(0, 0);
131 this->progBarLog->Name = L"progBarLog";
132 this->progBarLog->Size = System::Drawing::Size(634, 25);
133 this->progBarLog->TabIndex = 1;
134 //
135 // splitContainer1
136 //
137 this->splitContainer1->Dock = System::Windows::Forms::DockStyle::Fill;
138 this->splitContainer1->FixedPanel = System::Windows::Forms::FixedPanel::Panel2;
139 this->splitContainer1->IsSplitterFixed = true;
140 this->splitContainer1->Location = System::Drawing::Point(0, 0);
141 this->splitContainer1->Name = L"splitContainer1";
142 this->splitContainer1->Orientation = System::Windows::Forms::Orientation::Horizontal;
143 //
144 // splitContainer1.Panel1
145 //
146 this->splitContainer1->Panel1->Controls->Add(this->rxListView);
147 //
148 // splitContainer1.Panel2
149 //
150 this->splitContainer1->Panel2->Controls->Add(this->progBarLog);
151 this->splitContainer1->Panel2MinSize = 10;
152 this->splitContainer1->Size = System::Drawing::Size(634, 319);
153 this->splitContainer1->SplitterDistance = 290;
154 this->splitContainer1->TabIndex = 2;
155 //
156 // CtrlLogListView
157 //
158 this->AutoScaleDimensions = System::Drawing::SizeF(6, 13);
159 this->AutoScaleMode = System::Windows::Forms::AutoScaleMode::Font;
160 this->BackColor = System::Drawing::SystemColors::Window;
161 this->Controls->Add(this->splitContainer1);
162 this->Name = L"CtrlLogListView";
163 this->Size = System::Drawing::Size(634, 319);
164 this->splitContainer1->Panel1->ResumeLayout(false);
165 this->splitContainer1->Panel2->ResumeLayout(false);
166 (cli::safe_cast<System::ComponentModel::ISupportInitialize^ >(this->splitContainer1))->EndInit();
167 this->splitContainer1->ResumeLayout(false);
168 this->ResumeLayout(false);
169
170 }
171 #pragma endregion
172 };
173
174
175 }}}


Rx.ApiLF.Net.FormLogConsole.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Rx.ApiLF.Net.FormLogConsole.h
Go to the documentation of this file.
1 #pragma once
2
3 #pragma managed(push, off)
4 #include "Rx.ApiLF.Lib.Base/Rx.ApiLF.Types.h"
5 #pragma managed(pop)
6
7 #include "Rx.ApiLF.Net.CtrlLogListView.h"
8
9 namespace Rx { namespace ApiLF { namespace NET
10 {
11
12 using namespace System;
13 using namespace System::ComponentModel;
14 using namespace System::Collections;
15 using namespace System::Windows::Forms;
16 using namespace System::Data;
17 using namespace System::Drawing;
18
22 public ref class FormLogConsole : public System::Windows::Forms::Form
23 {
24 public:
25 FormLogConsole(Threading::ManualResetEvent^ evInitDone)
26 {
27 InitializeComponent();
28 //
29 //TODO: Add the constructor code here
30 //
31 xLogListView = gcnew Rx::ApiLF::NET::CtrlLogListView();
32 tabPgLog->Controls->Add(xLogListView);
33 xLogListView->Dock = DockStyle::Fill;
34
35 tabCtrlLog->TabPages->Remove(tabPgCuda);
36
37 m_xResMgr = gcnew System::Resources::ResourceManager( "Rx.ApiLF.App", GetType()->Assembly );
38 this->Icon = (cli::safe_cast<System::Drawing::Icon^ >(m_xResMgr->GetObject(L"RxLive")));
39
40
41 m_evInitDone = evInitDone;
42 m_bDoClose = false;
43 }
44
45 delegate void Delegate_Message(Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue);
46 delegate void Delegate_String(String^ sText);
47 delegate void Delegate_Void();
48
49 void End();
50 void AddLogMessage(Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue);
51
52 void SetCudaDeviceInfo(String^ sInfo);
53 protected:
57 ~FormLogConsole()
58 {
59 if (components)
60 {
61 delete components;
62 }
63 }
64
65 bool m_bDoClose;
66 Threading::ManualResetEvent^ m_evInitDone;
67 System::Resources::ResourceManager^ m_xResMgr;
68
69 private:
70 Rx::ApiLF::NET::CtrlLogListView^ xLogListView;
71
72 private: System::Windows::Forms::ToolStripContainer^ toolStripContainer1;
73 protected:
74 private: System::Windows::Forms::StatusStrip^ statusStrip1;
75 private: System::Windows::Forms::ToolStripStatusLabel^ toolStripStatusLabel1;
76 private: System::Windows::Forms::ToolStripProgressBar^ toolStripProgressBar1;
77 private: System::Windows::Forms::TabControl^ tabCtrlLog;
78 private: System::Windows::Forms::TabPage^ tabPgLog;
79
80 private: System::Windows::Forms::TabPage^ tabPgCuda;
81 private: System::Windows::Forms::RichTextBox^ rtboxCuda;
82
83 private:
87 System::ComponentModel::Container ^components;
88
89 #pragma region Windows Form Designer generated code
90
91
92
93
94 void InitializeComponent(void)
95 {
96 this->toolStripContainer1 = (gcnew System::Windows::Forms::ToolStripContainer());
97 this->statusStrip1 = (gcnew System::Windows::Forms::StatusStrip());
98 this->toolStripStatusLabel1 = (gcnew System::Windows::Forms::ToolStripStatusLabel());
99 this->toolStripProgressBar1 = (gcnew System::Windows::Forms::ToolStripProgressBar());
100 this->tabCtrlLog = (gcnew System::Windows::Forms::TabControl());
101 this->tabPgLog = (gcnew System::Windows::Forms::TabPage());
102 this->tabPgCuda = (gcnew System::Windows::Forms::TabPage());
103 this->rtboxCuda = (gcnew System::Windows::Forms::RichTextBox());
104 this->toolStripContainer1->BottomToolStripPanel->SuspendLayout();
105 this->toolStripContainer1->ContentPanel->SuspendLayout();
106 this->toolStripContainer1->SuspendLayout();
107 this->statusStrip1->SuspendLayout();
108 this->tabCtrlLog->SuspendLayout();
109 this->tabPgCuda->SuspendLayout();
110 this->SuspendLayout();
111 //
112 // toolStripContainer1
113 //
114 //
115 // toolStripContainer1.BottomToolStripPanel
116 //
117 this->toolStripContainer1->BottomToolStripPanel->Controls->Add(this->statusStrip1);
118 //
119 // toolStripContainer1.ContentPanel
120 //
121 this->toolStripContainer1->ContentPanel->Controls->Add(this->tabCtrlLog);
122 this->toolStripContainer1->ContentPanel->Size = System::Drawing::Size(751, 213);
123 this->toolStripContainer1->Dock = System::Windows::Forms::DockStyle::Fill;
124 this->toolStripContainer1->Location = System::Drawing::Point(0, 0);
125 this->toolStripContainer1->Name = L"toolStripContainer1";
126 this->toolStripContainer1->Size = System::Drawing::Size(751, 262);
127 this->toolStripContainer1->TabIndex = 0;
128 this->toolStripContainer1->Text = L"toolStripContainer1";
129 //
130 // statusStrip1
131 //
132 this->statusStrip1->Dock = System::Windows::Forms::DockStyle::None;
133 this->statusStrip1->Items->AddRange(gcnew cli::array< System::Windows::Forms::ToolStripItem^ >(2) {this->toolStripStatusLabel1,
134 this->toolStripProgressBar1});
135 this->statusStrip1->Location = System::Drawing::Point(0, 0);
136 this->statusStrip1->Name = L"statusStrip1";
137 this->statusStrip1->Size = System::Drawing::Size(751, 24);
138 this->statusStrip1->TabIndex = 0;
139 //
140 // toolStripStatusLabel1
141 //
142 this->toolStripStatusLabel1->BorderSides = System::Windows::Forms::ToolStripStatusLabelBorderSides::Right;
143 this->toolStripStatusLabel1->Name = L"toolStripStatusLabel1";
144 this->toolStripStatusLabel1->Size = System::Drawing::Size(634, 19);
145 this->toolStripStatusLabel1->Spring = true;
146 this->toolStripStatusLabel1->Text = L"OK";
147 this->toolStripStatusLabel1->TextAlign = System::Drawing::ContentAlignment::MiddleLeft;
148 //
149 // toolStripProgressBar1
150 //
151 this->toolStripProgressBar1->Name = L"toolStripProgressBar1";
152 this->toolStripProgressBar1->Size = System::Drawing::Size(100, 18);
153 //
154 // tabCtrlLog
155 //
156 this->tabCtrlLog->Controls->Add(this->tabPgLog);
157 this->tabCtrlLog->Controls->Add(this->tabPgCuda);
158 this->tabCtrlLog->Dock = System::Windows::Forms::DockStyle::Fill;
159 this->tabCtrlLog->Location = System::Drawing::Point(0, 0);
160 this->tabCtrlLog->Multiline = true;
161 this->tabCtrlLog->Name = L"tabCtrlLog";
162 this->tabCtrlLog->SelectedIndex = 0;
163 this->tabCtrlLog->Size = System::Drawing::Size(751, 213);
164 this->tabCtrlLog->TabIndex = 0;
165 //
166 // tabPgLog
167 //
168 this->tabPgLog->Location = System::Drawing::Point(4, 22);
169 this->tabPgLog->Name = L"tabPgLog";
170 this->tabPgLog->Padding = System::Windows::Forms::Padding(3);
171 this->tabPgLog->Size = System::Drawing::Size(743, 187);
172 this->tabPgLog->TabIndex = 0;
173 this->tabPgLog->Text = L"Log";
174 this->tabPgLog->UseVisualStyleBackColor = true;
175 //
176 // tabPgCuda
177 //
178 this->tabPgCuda->Controls->Add(this->rtboxCuda);
179 this->tabPgCuda->Location = System::Drawing::Point(4, 22);
180 this->tabPgCuda->Name = L"tabPgCuda";
181 this->tabPgCuda->Padding = System::Windows::Forms::Padding(3);
182 this->tabPgCuda->Size = System::Drawing::Size(743, 187);
183 this->tabPgCuda->TabIndex = 1;
184 this->tabPgCuda->Text = L"Cuda";
185 this->tabPgCuda->UseVisualStyleBackColor = true;
186 //
187 // rtboxCuda
188 //
189 this->rtboxCuda->BorderStyle = System::Windows::Forms::BorderStyle::None;
190 this->rtboxCuda->Dock = System::Windows::Forms::DockStyle::Fill;
191 this->rtboxCuda->Location = System::Drawing::Point(3, 3);
192 this->rtboxCuda->Name = L"rtboxCuda";
193 this->rtboxCuda->Size = System::Drawing::Size(737, 181);
194 this->rtboxCuda->TabIndex = 0;
195 this->rtboxCuda->Text = L"";
196 //
197 // FormLogConsole
198 //
199 this->AutoScaleDimensions = System::Drawing::SizeF(6, 13);
200 this->AutoScaleMode = System::Windows::Forms::AutoScaleMode::Font;
201 this->ClientSize = System::Drawing::Size(751, 262);
202 this->Controls->Add(this->toolStripContainer1);
203 this->Name = L"FormLogConsole";
204 this->Text = L"Raytrix Lightfield Engine Log";
205 this->FormClosing += gcnew System::Windows::Forms::FormClosingEventHandler(this, &FormLogConsole::FormLogConsole_FormClosing);
206 this->FormClosed += gcnew System::Windows::Forms::FormClosedEventHandler(this, &FormLogConsole::FormLogConsole_FormClosed);
207 this->Shown += gcnew System::EventHandler(this, &FormLogConsole::FormLogConsole_Shown);
208 this->toolStripContainer1->BottomToolStripPanel->ResumeLayout(false);
209 this->toolStripContainer1->BottomToolStripPanel->PerformLayout();
210 this->toolStripContainer1->ContentPanel->ResumeLayout(false);
211 this->toolStripContainer1->ResumeLayout(false);
212 this->toolStripContainer1->PerformLayout();
213 this->statusStrip1->ResumeLayout(false);
214 this->statusStrip1->PerformLayout();
215 this->tabCtrlLog->ResumeLayout(false);
216 this->tabPgCuda->ResumeLayout(false);
217 this->ResumeLayout(false);
218
219 }
220 #pragma endregion
221 private:
222 System::Void FormLogConsole_Shown(System::Object^ sender, System::EventArgs^ e);
223 System::Void FormLogConsole_FormClosing(System::Object^ sender, System::Windows::Forms::FormClosingEventArgs^ e) ;
224 System::Void FormLogConsole_FormClosed(System::Object^ sender, System::Windows::Forms::FormClosedEventArgs^ e) ;
225
226 };
227 }}}


Rx.ApiLF.Net.LogConsoleManager.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Rx.ApiLF.Net.LogConsoleManager.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Rx.ApiLF.Net.FormLogConsole.h"
4
5 using namespace System;
6
7 namespace Rx { namespace ApiLF { namespace NET
8 {
9
10 ref class LogConsoleManager
11 {
12 public:
13 LogConsoleManager();
14 ~LogConsoleManager()
15 {
16 End();
17 }
18
19
20 void Start();
21 void End();
22 void AddMessage(Rx::ApiLF::NET::EStatusSource eSource, Rx::ApiLF::NET::EStatusMessage eMsg, String^ sSourceName, String^ sMessage, int iValue);
23 void SetCudaDeviceInfo(String^ sInfo);
24
25 private:
26 void RunMsgLoop(System::Object^ xObj);
27
28 private:
29 System::Threading::Thread^ m_xThread;
30 Rx::ApiLF::NET::FormLogConsole^ m_xWnd;
31 Threading::ParameterizedThreadStart^ m_xDel;
32 Threading::ManualResetEvent^ m_evInitDone;
33 };
34
35
36 }}} // Namespace Rx.ApiLF.NET
37


Rx.ApiLF.Properties.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.Properties.h
Go to the documentation of this file.
1 #pragma once
2
3
4 namespace Rx { namespace ApiLF
5 {
10
11 # undef RX_MANAGED_ENUM
12 # include "Rx.ApiLF.PropertyValues.h"
13 # undef RX_MANAGED_ENUM
14
17 }}
18


Rx.ApiLF.PropertyValues.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.PropertyValues.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5
6
10 #ifdef RX_MANAGED_ENUM
11
17
18 public enum class ERadDistType
19 #else
20 namespace ERadDistType {
21
27
28 enum ID
29 #endif
30 {
32 Constant = 0,
34 Polynom4,
36 Inversion2,
37 };
38 #ifndef RX_MANAGED_ENUM
39 } // namespace
40 #endif
41
42 #ifdef RX_MANAGED_ENUM
43
49
50 public enum class ECameraTriggerMode
51 #else
52 namespace ECameraTriggerMode {
53
59
60 enum ID
61 #endif
62 {
63 None = 0,
64
66 Camera_FreeRun = 0x0100,
67
69 Software_SnapShot = 0x0200,
70
72 Extern_Impulse = 0x0300,
73 };
74 #ifndef RX_MANAGED_ENUM
75 } // namespace
76 #endif
77
78
88 #ifdef RX_MANAGED_ENUM
89
95
96 public enum class EPar
97 #else
98 namespace EPar {
99
105
106 enum ID
107 #endif
108 {
109 None = 0,
110
111 // CUDA
113 Cuda_DeviceName = 0x00010000,
115 Cuda_DeviceID,
117 Cuda_CapaMajor,
119 Cuda_CapaMinor,
121 Cuda_VersionRuntime,
123 Cuda_VersionDriver,
125 Cuda_TotalGlobalMem,
127 Cuda_RegsPerBlock,
129 Cuda_WarpSize,
131 Cuda_MemPitch,
133 Cuda_MaxThreadsPerBlock,
135 Cuda_TotalConstMem,
137 Cuda_DeviceOverlap,
139 Cuda_MultiProcessorCount,
141 Cuda_ComputeMode,
143 Cuda_MaxTex2DSizeX,
145 Cuda_MaxTex2DSizeY,
147 Cuda_MaxTex2DArraySizeX,
149 Cuda_MaxTex2DArraySizeY,
151 Cuda_ConcurrentKernels,
153 Cuda_TCCDriver,
154
155
156 // Camera parameter
158 Cam_Count = 0x00020000,
160 Cam_Name,
162 Cam_Type,
164 Cam_ID,
166 Cam_Exposure,
167 // Camera tap balance [-1,1] (double, RW)
168 Cam_TapBalance,
170 Cam_Gain,
172 Cam_GainRed,
174 Cam_GainGreen,
176 Cam_GainBlue,
178 Cam_IsColor,
180 Cam_IsBayer,
182 Cam_Width,
184 Cam_Height,
186 Cam_OffsetX,
188 Cam_OffsetY,
190 Cam_AutoUpdateGlTex,
192 Cam_FramesPerSecond,
194 Cam_ActualFramesPerSecond,
196 Cam_Focus,
198 Cam_Iris,
200 Cam_Func_CalibMainLens,
202 Cam_TapBalanceMode,
204 Cam_PIVMode,
206 Cam_IsOpen,
208 Cam_IsCapturing,
210 Cam_Temperature,
212 Cam_TriggerMode,
213
214 // Camera Calibration
216 CamCal_LensCnt = 0x00030000,
218 CamCal_LensSetCnt,
220 CamCal_LensIdx,
222 CamCal_LensSetIdx,
224 CamCal_LensName,
226 CamCal_LensID,
228 CamCal_LensSetFStop,
230 CamCal_LensSetFocus,
232 CamCal_MainLensIris,
234 CamCal_MainLensFocus,
235
236 // Camera Capture
238 CamCap_Timeout_Video = 0x0003F000,
240 CamCap_Timeout_Single,
242 CamCap_Timeout_Extern,
243
245 CamCap_Frames_Lost = 0x0003F020,
246
248 CamCap_AutoLum_MaxSaturatedPixelPercentage = 0x0003F100,
249
251 CamCap_AutoGain_Enabled = 0x0003F200,
253 CamCap_AutoGain_Active,
255 CamCap_AutoGain_MinValue,
257 CamCap_AutoGain_MaxValue,
258
260 CamCap_AutoExposure_Enabled = 0x0003F300,
262 CamCap_AutoExposure_Active,
264 CamCap_AutoExposure_MinValue,
266 CamCap_AutoExposure_MaxValue,
267
268
269 // Bound ray image parameter
271 Ray_Width = 0x00040000,
273 Ray_Height,
275 Ray_PixelType,
277 Ray_DataType,
279 Ray_ApplyWhiteImage,
281 Ray_ConvBayer,
283 Ray_MLI_Rotation,
285 Ray_MLI_Diameter,
287 Ray_MLI_Border,
289 Ray_MLI_OffsetX,
291 Ray_MLI_OffsetY,
293 Ray_MLI_PixelSizeX,
295 Ray_MLI_PixelSizeY,
296
298 Ray_MLI_BaseRotation,
300 Ray_MLI_BaseReflectX,
302 Ray_MLI_BaseReflectY,
303
305 Ray_MLI_BaseVecXX,
307 Ray_MLI_BaseVecXY,
309 Ray_MLI_BaseVecYX,
311 Ray_MLI_BaseVecYY,
312
314 Ray_MLI_SubGridBaseX,
316 Ray_MLI_SubGridBaseY,
317
319 Ray_MLI_LensTypeCount,
321 Ray_MLI_LensTypeIdx,
323 Ray_MLI_LensTypeVirtDepthMin,
325 Ray_MLI_LensTypeVirtDepthMax,
327 Ray_MLI_LensTypeOffsetX,
329 Ray_MLI_LensTypeOffsetY,
330
332 Ray_MLI_RadDistType,
334 Ray_MLI_RadDistParCnt,
336 Ray_MLI_RadDistOffsetX,
338 Ray_MLI_RadDistOffsetY,
340 Ray_MLI_RadDistPar1,
342 Ray_MLI_RadDistPar2,
344 Ray_MLI_RadDistPar3,
346 Ray_MLI_RadDistPar4,
348 Ray_MLI_RadDistPar5,
350 Ray_MLI_NeedWhiteImage,
351
353 Ray_ApplyFileSettings = 0x00047000,
354
355 // OpenGL Interop
357 Gl_TexRayID = 0x00050000,
359 Gl_TexFocusLeftID,
361 Gl_TexFocusRightID,
363 Gl_TexDepthLeftID,
365 Gl_TexDepthRightID,
367 Gl_TexDepthColLeftID,
369 Gl_TexDepthColRightID,
371 Gl_TexGridID,
373 Gl_TexFocusLeftID2,
375 Gl_TexFocusRightID2,
376
378 Gl_TexRayProcID,
380 Gl_TexRayWhiteID,
382 Gl_TexRayDepthID,
383
384
385 // Ray sequence
387 RaySeq_AutoStoreCamFrames = 0x00060000,
389 RaySeq_ApplyFileSettings,
396 RaySeq_AutoStoreCamFrameCnt,
397
398
399 // Ray PreProcess Algorithm
401 PreProc_Std_Enable = 0x00100000,
403 PreProc_Std_Brightness,
405 PreProc_Std_ContrastCenter,
407 PreProc_Std_ContrastScale,
408
410 PreProc_Sharp1_Enable = 0x00102000,
412 PreProc_Sharp1_BlurStdDev,
414 PreProc_Sharp1_Factor,
416 PreProc_Sharp1_OnlyCalc,
417
419 PreProc_Demosaic_Enable = 0x00104000,
421 PreProc_Demosaic_R,
423 PreProc_Demosaic_G,
425 PreProc_Demosaic_B,
426
428 PreProc_DenoiseNLM_Enable = 0x00105000,
430 PreProc_DenoiseNLM_FilterDia,
432 PreProc_DenoiseNLM_NoiseLevel,
434 PreProc_DenoiseNLM_BlendFactor,
435
438 // Depth algorithm
440 Depth_Algo = 0x00200000,
442 Depth_ResImgDiv,
444 Depth_ImageType,
446 Depth_DefaultValue,
447
449 Depth_Affine_Offset = 0x00201000,
451 Depth_Affine_FocalLength,
452
455 Depth_Std_BlockCnt = 0x00202000,
457 Depth_Std_PatchRad,
459 Depth_Std_MedianRad,
461 Depth_Std_MeanRad,
463 Depth_Std_SizeDiv,
465 Depth_Std_MinTrust,
467 Depth_Std_MaxInvCor,
469 Depth_Std_MinStdDev,
471 Depth_Std_PixelStep,
473 Depth_Std_RawMedianRad,
475 Depth_Std_RawMeanRad,
477 Depth_Std_RawMeanMaxBlackPart,
479 Depth_Std_Fuse_DepthDeltaMax,
481 Depth_Std_Fuse_DepthOptRangeMax,
482
483
485 // Depth Path algorithm
487 Depth_Path_BlockCnt = 0x00203000,
489 Depth_Path_NearResLevel,
491 Depth_Path_SparseLensSet,
493 Depth_Path_MaxVirtDepth,
494
497 Depth_Path_LensTypeIdx = 0x00203100,
499 Depth_Path_LT_PixelStep,
501 Depth_Path_LT_MinStdDev,
503 Depth_Path_LT_MinCor,
505 Depth_Path_LT_MinPolyParAbs,
507 Depth_Path_LT_MaxPolyCtrDelta,
509 Depth_Path_LT_PatchDia,
511 Depth_Path_LT_PatchStride,
512
514 // Depth Path PIV algorithm
516 Depth_PathPiv_BlockCnt = 0x00203200,
518 Depth_PathPiv_NearResLevel,
519
522 Depth_PathPiv_LensTypeIdx = 0x00203300,
524 Depth_PathPiv_LT_PixelStep,
526 Depth_PathPiv_LT_MinCor,
528 Depth_PathPiv_LT_BPSigma,
530 Depth_PathPiv_LT_BPMinCor,
532 Depth_PathPiv_LT_BPMinMean,
534 Depth_PathPiv_LT_MinPolyParAbs,
536 Depth_PathPiv_LT_MaxPolyCtrDelta,
538 Depth_PathPiv_LT_PatchDia,
540 Depth_PathPiv_LT_PatchStride,
541
542
544 // Depth Fuse Direct Algo
546 Depth_Fuse_MedianRad = 0x00205000,
548 Depth_Fuse_MeanRad,
550 Depth_Fuse_MeanMaxBlackPart,
551
553 Depth_Fuse_LensTypeIdx = 0x00205100,
554
555
557 // Depth Fill Algo
559 Depth_Fill_Enabled = 0x00207000,
561 Depth_Fill_IterCnt,
563 Depth_Fill_IterSize,
565 Depth_Fill_Complete,
567 Depth_Fill_MedianRad,
569 Depth_Fill_MeanRad,
571 Depth_Fill_NLM_Enabled,
573 Depth_Fill_NLM_FilterDia,
575 Depth_Fill_NLM_NoiseLevel,
577 Depth_Fill_NLM_BlendFactor,
579 Depth_Fill_Bilateral_Enabled,
581 Depth_Fill_Bilateral_FilterRad,
583 Depth_Fill_Bilateral_SigmaR,
585 Depth_Fill_Bilateral_SigmaS,
586
589
591 // Focus algorithms
593 Focus_ResImgDiv = 0x00220000,
595 Focus_MaxLensContribRad,
597 Focus_ViewOffset_VirtDepthMin,
599 Focus_ViewOffset_VirtDepthMax,
601 Focus_ViewOffset_Gamma,
603 Focus_ViewOffset_Radial,
605 Focus_ViewOffset_VirtDepthCollPlane,
607 Focus_ViewOffset_X,
609 Focus_ViewOffset_Y,
611 Focus_DefaultFocus,
613 Focus_Focus,
615 Focus_Stereo_Enabled,
617 Focus_Stereo_EyeSep,
619 Focus_Stereo_Rot,
620
621
622
625 Focus_DefocusBlur_Enable = 0x00221000,
627 Focus_DefocusBlur_VirtDOF,
629 Focus_DefocusBlur_Gradient,
631 Focus_DefocusBlur_MaxBlurRad,
633 Focus_DefocusBlur_DefaultDepth,
634
637 // Grid algorithm
639 Grid_ResImgDiv = 0x00230000,
640
643 // Calibration algoriothms parameter
645 Calib_Grid_Mode = 0x00240000,
646 };
647 #ifndef RX_MANAGED_ENUM
648 } // namespace
649 #endif
650
654 #ifdef RX_MANAGED_ENUM
655
661
662 public enum class EParGrp
663 #else
664 namespace EParGrp {
665
671
672 enum ID
673 #endif
674 {
675 None = 0,
677 Cuda = 0x00010000,
679 Camera = 0x00020000,
681 CamCal = 0x00030000,
683 CamCap = 0x0003F000,
685 Ray = 0x00040000,
687 Gl = 0x00050000,
689 RaySeq = 0x00060000,
691 PreProc = 0x00100000,
693 Depth = 0x00200000,
695 Depth_Path = 0x00203000,
697 Depth_PathPiv = 0x00203200,
699 Focus = 0x00220000,
701 Grid = 0x00230000,
703 Calib = 0x00240000,
704 };
705 #ifndef RX_MANAGED_ENUM
706 } // namespace
707 #endif
708
712 #ifdef RX_MANAGED_ENUM
713
719
720 public enum class EImgID
721 #else
722 namespace EImgID {
723
729
730 enum ID
731 #endif
732 {
733 None = 0x0000,
735 Ray = 0x0001,
737 RayDepth = 0x0002,
739 Focus = 0x0004,
741 FocusLeft = 0x0004,
743 FocusRight = 0x0008,
745 Depth = 0x0010,
747 DepthLeft = 0x0010,
749 DepthRight = 0x0020,
751 DepthCol = 0x0040,
753 DepthColLeft = 0x0040,
755 DepthColRight = 0x0080,
757 RayGrid = 0x0100,
759 RayProc = 0x0200,
761 RayWhite = 0x0400,
762 };
763 #ifndef RX_MANAGED_ENUM
764 } // namespace
765 #endif
766
770 #ifdef RX_MANAGED_ENUM
771
777
778 public enum class EDepthImageType
779 #else
780 namespace EDepthImageType {
781
787
788 enum ID
789 #endif
790 {
797 Standard = 0,
804 Virtual,
811 Relative,
818 Affine,
820 Count,
821
822 };
823 #ifndef RX_MANAGED_ENUM
824 } // namespace
825 #endif
826
827
831 #ifdef RX_MANAGED_ENUM
832
838
839 public enum class ECalibGridMode
840 #else
841 namespace ECalibGridMode {
842
848
849 enum ID
850 #endif
851 {
853 PosScale = 0,
855 PosScaleRot,
857 Count,
858 };
859 #ifndef RX_MANAGED_ENUM
860 } // namespace
861 #endif
862
863 #ifdef RX_MANAGED_ENUM
864
874
875 public enum class ERaySeqMode
876 #else
886 namespace ERaySeqMode { enum ID
887 #endif
888 {
890 None = 0x0000,
892 Read = 0x0001,
894 Write = 0x0002,
895
897 Compress_Zip = 0x0100,
898
899 };
900 #ifndef RX_MANAGED_ENUM
901 } // namespace
902 #endif
903
904


Rx.ApiLF.StatusCodeValues.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.StatusCodeValues.h
Go to the documentation of this file.
1
2 #ifdef RX_MANAGED_ENUM
3
4
5
6 public enum class EStatusSource
7 #else
11 namespace EStatusSource { enum ID
12 #endif
13 {
14 Unknown = 0,
15
17 API,
19 Camera,
20 CameraDriver,
21 Compute,
22 App,
23
24 };
25 #ifndef RX_MANAGED_ENUM
26 } // namespace EStatusSource
27 #endif
28
29 #ifdef RX_MANAGED_ENUM
30
31
32
33 public enum class EStatusMsgGrp
34 #else
35
39 namespace EStatusMsgGrp { enum ID
40 #endif
41 {
42 None = 0,
43 Text = 0x00010000,
44 Progress = 0x00020000,
45 };
46
47 #ifndef RX_MANAGED_ENUM
48 } // namespace EStatusMessage
49 #endif
50
51 #ifdef RX_MANAGED_ENUM
52
53
54
55 public enum class EStatusMessage
56 #else
57
61 namespace EStatusMessage { enum ID
62 #endif
63 {
64 None = 0,
65
66 // Info Message Group
67 Debug = int(EStatusMsgGrp::Text),
68 Info,
69 Error,
70 Assertion,
71 Exception,
72 Fatal,
73 Warning,
74
75 // Progress group
77 Progress_Init = int(EStatusMsgGrp::Progress),
79 Progress_Value,
81 Progress_Step,
83 Progress_Finished,
84
85 };
86 #ifndef RX_MANAGED_ENUM
87 } // namespace EStatusMessage
88 #endif
89


Rx.ApiLF.StatusCodes.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.StatusCodes.h
Go to the documentation of this file.
1 #pragma once
2
3
4 namespace Rx { namespace ApiLF
5 {
10
11 # undef RX_MANAGED_ENUM
12 # include "Rx.ApiLF.StatusCodeValues.h"
13 # undef RX_MANAGED_ENUM
14
18 }}
19
20


Rx.ApiLF.StatusMessageDelegateList.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.StatusMessageDelegateList.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Rx.ApiLF.Types.h"
4 #include "Rx.Core.Development/RxMem.h"
5
6 namespace Rx { namespace ApiLF
7 {
12
13 class CStatusMessageDelegateList
14 {
15 public:
16 CStatusMessageDelegateList(void);
17 ~CStatusMessageDelegateList(void);
18
19 unsigned Count();
20 void Clear();
21 bool Add(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext);
22 bool Remove(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext);
23
24 void InvokeAll(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char* pcSourceName, const char* pcMessage, int iValue);
25
26 protected:
27 Raytrix::CRxMem<SStatusMessageDelegate> m_mStatusMessageDelegates;
28
29 };
33 }} // namespace Rx.ApiLF


Rx.ApiLF.Types.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.Types.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Rx.ApiLF.StatusCodes.h"
4
5
6 namespace Rx { namespace ApiLF
7 {
12
13
15 typedef void (__stdcall* TFuncStatusMessageCallback)(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char* pcSourceName, const char* pcMessage, int iValue, void *pvContext);
16
17
18 struct SStatusMessageDelegate
19 {
20 SStatusMessageDelegate()
21 {
22 m_pStatusMessageCallbackFunc = 0;
23 m_pvStatusMessageCallbackContext = 0;
24 }
25
26 SStatusMessageDelegate(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
27 {
28 Set(pFunc, pvContext);
29 }
30
31 void Set(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext)
32 {
33 m_pStatusMessageCallbackFunc = pFunc;
34 m_pvStatusMessageCallbackContext = pvContext;
35 }
36
37 Rx::ApiLF::TFuncStatusMessageCallback m_pStatusMessageCallbackFunc;
38 void *m_pvStatusMessageCallbackContext;
39
40 bool operator== (const SStatusMessageDelegate& xSMD)
41 {
42 return (m_pStatusMessageCallbackFunc == xSMD.m_pStatusMessageCallbackFunc
43 && m_pvStatusMessageCallbackContext == xSMD.m_pvStatusMessageCallbackContext);
44 }
45
46 bool operator!= (const SStatusMessageDelegate& xSMD)
47 {
48 return (m_pStatusMessageCallbackFunc != xSMD.m_pStatusMessageCallbackFunc
49 || m_pvStatusMessageCallbackContext != xSMD.m_pvStatusMessageCallbackContext);
50 }
51
52 void Invoke(Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char* pcSourceName, const char* pcMessage, int iValue)
53 {
54 if ( m_pStatusMessageCallbackFunc )
55 m_pStatusMessageCallbackFunc(eSource, eMsg, pcSourceName, pcMessage, iValue, m_pvStatusMessageCallbackContext);
56 }
57 };
60 }}
61
62
63


Rx.ApiLF.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Rx.ApiLF.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4 #pragma once
5
6 // Folgender ifdef-Block ist die Standardmethode zum Erstellen von Makros, die das Exportieren
7 // aus einer DLL vereinfachen. Alle Dateien in dieser DLL werden mit dem RAYTRIXAPI_EXPORTS-Symbol
8 // kompiliert, das in der Befehlszeile definiert wurde. Das Symbol darf nicht f�r ein Projekt definiert werden,
9 // das diese DLL verwendet. Alle anderen Projekte, deren Quelldateien diese Datei beinhalten, erkennen
10 // RXLF_API-Funktionen als aus einer DLL importiert, w�hrend die DLL
11 // mit diesem Makro definierte Symbole als exportiert ansieht.
12 #ifdef RXLFAPI_EXPORTS
13 #define RXLF_API __declspec(dllexport)
14 #else
15 #define RXLF_API __declspec(dllimport)
16 #endif
17
18 #define DEPRECATED __declspec(deprecated)
19
20 #pragma managed(push, off)
21
22 #include "Rx.Core\RxCore.h"
23 #include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Errors.h"
24 #include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Properties.h"
25 #include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Types.h"
26 #include "Rx.ApiLF.Lib.Base\Rx.ApiLF.StatusCodes.h"
27 #include "Rx.ApiLF.Lib.Base\Rx.ApiLF.Features.h"
28
33
34
49
51
56
57
67 #define RX_TRY( theFunc ) \
68 if ( !theFunc ) \
69 { \
70 Rx::CRxString sxError; \
71 int iError = RxGetLastError( sxError ); \
72 std::cerr << "Error " << iError << ": " << sxError.ToCString() << std::endl; \
73 throw iError; \
74 }
75
78
79
80
81 namespace Rx { namespace ApiLF
82 {
83
88
95
98
99 // Time functions
101
119 RXLF_API void RxSleep(unsigned uTime);
120
124 RXLF_API double RxGetTime();
125
129 RXLF_API __int64 RxGetTime64();
132
133 // Main API functions
135
136 RXLF_API bool RxLogConsoleShow();
137 RXLF_API bool RxLogConsoleClose();
138 RXLF_API bool RxLogConsoleAddMessage( Rx::ApiLF::EStatusSource::ID eSource, Rx::ApiLF::EStatusMessage::ID eMsg, const char* pcSource, const char *pcMessage, int iValue);
139
140
141 RXLF_API bool RxAddStatusMessageHandler( Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext );
142 RXLF_API bool RxRemoveStatusMessageHandler( Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext );
143
144
145
153
191 RXLF_API bool RxInit( bool bInitCuda, const Rx::CRxString& sxLibPath = Rx::CRxString(), const Rx::CRxString& sxCalibPath = Rx::CRxString(), void *pData = 0 );
192
227 RXLF_API bool RxInit( const Rx::CRxString& sxLibPath = Rx::CRxString(), const Rx::CRxString& sxCalibPath = Rx::CRxString(), void *pData = 0 );
228
239 RXLF_API bool RxFinalize(void);
240
241
256 RXLF_API bool RxHasFeature( unsigned uID );
257
267 RXLF_API bool RxDongleGetID( int& iDngID, int& iRxID );
268
269 RXLF_API bool RxDongleReinitialize( );
270
288 RXLF_API bool RxGetRegistryString( const Rx::CRxString& sxPath, Rx::CRxString& sxValue );
289
290
299 RXLF_API int RxGetLastError( Rx::CRxString& sxError, bool bClear = true );
300
309 RXLF_API int RxGetLastErrorReport( Rx::CRxString& sxError, bool bClear = true );
310
320 RXLF_API double RxGetLastExecTime();
321
322
323
324 RXLF_API bool AddStatusMessageHandler(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext);
325 RXLF_API bool RemoveStatusMessageHandler(Rx::ApiLF::TFuncStatusMessageCallback pFunc, void *pvContext);
326
327
330
331 // CUDA functions
333
341
350 RXLF_API bool RxCudaDeviceCount( int &iDeviceCount );
351
363 RXLF_API bool RxCudaDeviceProp( int iDevice, Rx::CRxString &sxName, unsigned &iCCMajor, unsigned &iCCMinor );
364
388 RXLF_API bool RxCudaSelectDevice( int iDevice = -1, bool bUseGL = false );
389
402 RXLF_API bool RxCudaDeviceMemInfo( unsigned &uFreeMem, unsigned &uTotalMem );
405
406 // Camera functions
408
416
427 RXLF_API bool RxCamDriverInit();
428
439 RXLF_API bool RxCamRegister();
440
451 RXLF_API bool RxCamOpen(unsigned uCamIdx);
452
461 RXLF_API bool RxCamClose(unsigned uCamIdx);
462
463
483 RXLF_API bool RxCamStartCapture(unsigned uCamIdx, unsigned &hRay);
484
496 RXLF_API bool RxCamStopCapture(unsigned uCamIdx);
497
498
511 RXLF_API bool RxCamSuspendCapture(unsigned uCamIdx, bool bSuspend);
512
513
528 RXLF_API bool RxCamDoCapture(unsigned uCamIdx);
529
530
542 RXLF_API bool RxCamCalibUpdate(unsigned uCamIdx);
543
544
558 RXLF_API bool RxCamCalibNewLens(unsigned uCamIdx, const Rx::CRxString& sxLensID, const Rx::CRxString& sxLensName);
559
574 RXLF_API bool RxCamCalibNewLens(unsigned uCamIdx, Rx::CRxString& sxLensID, const Rx::CRxString& sxLensName, bool bCreateID);
575
576
587 RXLF_API bool RxCamCalibDeleteLens(unsigned uCamIdx);
588
589
600 RXLF_API bool RxCamCalibNewLensSetting(unsigned uCamIdx, double dFStop, double dFocus);
601
609 RXLF_API bool RxCamCalibDeleteLensSetting(unsigned uCamIdx);
610
624 RXLF_API bool RxCamCalibCreate(unsigned uCamIdx, bool bForce);
625
638 RXLF_API bool RxCamCalibStore(unsigned uCamIdx);
639
656 RXLF_API bool RxCamCalibStoreWhiteImage(unsigned uCamIdx, unsigned uImgCnt);
657
673 RXLF_API bool RxCamSupPar( unsigned uCamIdx, EPar::ID ePar, bool &bSupported );
674
694 RXLF_API bool RxCamGetPar( unsigned uCamIdx, EPar::ID ePar, Rx::CRxString& sxValue );
695
718 RXLF_API bool RxCamGetPar( unsigned uCamIdx, EPar::ID ePar, unsigned &uValue );
719
739 RXLF_API bool RxCamGetPar( unsigned uCamIdx, EPar::ID ePar, double &dValue );
740
741
760 RXLF_API bool RxCamSetPar( unsigned uCamIdx, EPar::ID ePar, const Rx::CRxString& sxValue );
761
781 RXLF_API bool RxCamSetPar( unsigned uCamIdx, EPar::ID ePar, const unsigned &uValue );
782
801 RXLF_API bool RxCamSetPar( unsigned uCamIdx, EPar::ID ePar, const double &dValue );
802
803
818 RXLF_API bool RxCamGetParRange( unsigned uCamIdx, EPar::ID ePar, unsigned &uMin, unsigned &uMax );
819
834 RXLF_API bool RxCamGetParRange( unsigned uCamIdx, EPar::ID ePar, double &dMin, double &dMax );
835
849 RXLF_API bool RxCamGetParRange( unsigned uCamIdx, EPar::ID ePar, Rx::CRxArrayUInt& auValues );
850
854
855 // Ray image functions
857
884
897 RXLF_API bool RxRayNew( unsigned& hRay, const Rx::CRxImageFormat& xF );
898
910 RXLF_API bool RxRayDelete( unsigned hRay );
911
921 RXLF_API bool RxRayLoad( unsigned &hRay, const Rx::CRxString& sxFilename );
922
932 RXLF_API bool RxRaySave( unsigned hRay, const Rx::CRxString& sxFilename );
933
956
957 RXLF_API bool RxRayCalibNew( unsigned hRay,
958 int iLensTypeCount,
959 double dLensDia, double dPixSize,
960 double dOffsetX, double dOffsetY,
961 double dRotDeg, double dLensBorder,
962 int iRot90Cnt, bool bReflectX, bool bReflectY);
963
973 RXLF_API bool RxRayCalibSave( unsigned hRay, const Rx::CRxString& sxFilename );
974
984 RXLF_API bool RxRayCalibLoad( unsigned hRay, const Rx::CRxString& sxFilename );
985
995 RXLF_API bool RxRayCalibXmlGet( unsigned hRay, Rx::CRxString& sxXml );
996
1006 RXLF_API bool RxRayCalibXmlSet( unsigned hRay, const Rx::CRxString& sxXml );
1007
1018 RXLF_API bool RxRayBind( unsigned hRay );
1019
1020
1030 RXLF_API bool RxRayGetFormat( unsigned hRay, Rx::CRxImageFormat& xF );
1031
1044 RXLF_API bool RxRayGetFormatEx( unsigned hRay, Rx::CRxImageFormat& xF, void *pData );
1045
1046
1058 RXLF_API bool RxRayGetRaw( unsigned hRay, Rx::CRxImage& xRawImage );
1059
1060
1077 RXLF_API bool RxRayGetRaw( unsigned hRay, Rx::IImage* pRawImage, bool bCreate );
1078
1079
1093 RXLF_API bool RxRayGetMetaData( unsigned uImgID, Rx::CRxMetaData &xMetaData );
1094
1108 RXLF_API bool RxRaySetMetaData( unsigned uImgID, const Rx::CRxMetaData &xMetaData );
1109
1113
1114 // Ray sequence functions
1116
1123
1134 RXLF_API bool RxRaySeqOpen( unsigned &uRaySeqID, const Rx::CRxString& sxFilename,
1135 unsigned uMode, unsigned uFrameBufferCount);
1136
1145 RXLF_API bool RxRaySeqClose( unsigned uRaySeqID );
1146
1180 RXLF_API bool RxRaySeqBind( unsigned uRaySeqID, unsigned &uImgID );
1181
1196 RXLF_API bool RxRaySeqUnbind( unsigned uRaySeqID );
1197
1207 RXLF_API bool RxRaySeqRead();
1208
1218 RXLF_API bool RxRaySeqWrite();
1219
1226 RXLF_API bool RxRaySeqGetFrameBufferUsedCount( unsigned uRaySeqID, unsigned &uFrameCount );
1227
1234 RXLF_API bool RxRaySeqGetFrameCount( unsigned uRaySeqID, unsigned &uFrameCount );
1235
1242 RXLF_API bool RxRaySeqGetFileSize( unsigned uRaySeqID, unsigned __int64 &uFileSize );
1243
1250 RXLF_API bool RxRaySeqGetFrameIndex( unsigned uRaySeqID, unsigned &uFrameIdx );
1251
1258 RXLF_API bool RxRaySeqSetFrameIndex( unsigned uRaySeqID, unsigned uFrameIdx );
1259
1266 RXLF_API bool RxRaySeqMoveFrameIndex( unsigned uRaySeqID, int iStep );
1267
1270
1271 // CUDA/OpenGL interop. functions
1273
1352
1353
1366 RXLF_API bool RxGlGetVersion(int &iMajor, int &iMinor);
1367
1380 RXLF_API bool RxGlUpdateTex(unsigned uIntImgIDs);
1384
1385 // Parameter functions
1387
1411
1417 RXLF_API bool RxLoadPar( const Rx::CRxString& sxFilename );
1418
1424 RXLF_API bool RxSavePar( const Rx::CRxString& sxFilename );
1425
1440 RXLF_API bool RxGetPar( EPar::ID ePar, unsigned& uValue );
1441
1456 RXLF_API bool RxGetPar( EPar::ID ePar, double& dValue );
1457
1472 RXLF_API bool RxGetPar( EPar::ID ePar, Rx::CRxString& sValue );
1473
1474
1484 RXLF_API bool RxGetParName( EPar::ID ePar, Rx::CRxString& sValue );
1485
1486
1501 RXLF_API bool RxSetPar( EPar::ID ePar, const unsigned& uValue );
1502
1517 RXLF_API bool RxSetPar( EPar::ID ePar, const double& dValue );
1518
1533 RXLF_API bool RxSetPar( EPar::ID ePar, const Rx::CRxString& sValue );
1534
1535
1552 RXLF_API bool RxGetParRange( EPar::ID ePar, unsigned &uMin, unsigned &uMax );
1553
1569 RXLF_API bool RxGetParRange( EPar::ID ePar, double &dMin, double &dMax );
1572
1573 // Computation functions
1575
1635
1651
1652 RXLF_API bool RxConvertImage( Rx::CRxImage& xDstImage, const Rx::CRxImage& xSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType);
1653
1670
1671 RXLF_API bool RxConvertImage( Rx::IImage* pDstImage, const Rx::IImage* pSrcImage, Rx::EPixelType::ID eDstPixelType, Rx::EDataType::ID eDstDataType, bool bCreate );
1672
1673
1685 RXLF_API bool RxGetImage( EImgID::ID eImgID, Rx::CRxImage &xImage );
1686
1699 RXLF_API bool RxGetImage( EImgID::ID eImgID, Rx::IImage *pImage, bool bCreate );
1700
1721 RXLF_API bool RxSetImage( EImgID::ID eImgID, const Rx::CRxImage &xImage );
1722
1743 RXLF_API bool RxSetImage( EImgID::ID eImgID, const Rx::IImage *pImage );
1744
1745
1756 RXLF_API bool RxIsImageValid( EImgID::ID eImgID );
1757
1772 RXLF_API bool RxGetImageFormat( EImgID::ID eImgID, Rx::CRxImageFormat &xF );
1773
1774
1788 RXLF_API bool RxGetImageDevicePointer( EImgID::ID eImgID, void* &pDevicePtr );
1789
1790
1803 RXLF_API bool RxUpdateImage( EImgID::ID eImgID );
1804
1805
1815 RXLF_API bool RxResizeImage( Rx::CRxImage &xImage, int iDivider );
1816
1817
1832 RXLF_API bool RxTransformDepthValue( double &dTrgValue, double dSrcValue, EDepthImageType::ID eTrgDIT, EDepthImageType::ID eSrcDIT );
1833
1834
1847 RXLF_API bool RxGetImageHistogram( EImgID::ID eImgID, Rx::CRxArrayUInt& xHistogram );
1848
1849
1867 RXLF_API bool RxCalibGrid();
1868
1869
1885 RXLF_API bool RxPreProcess();
1886
1895 RXLF_API bool RxGrid( );
1896
1930 RXLF_API bool RxDepthMap( double dStdDepth, int iWidth, int iHeight, double *pdData, unsigned uElCnt, EImgID::ID eTrgImgID = EImgID::Depth );
1931
1945 RXLF_API bool RxFocusOnPlane();
1946
1962 RXLF_API DEPRECATED bool RxFocusOnPlane( double dRelDepth );
1963
1982 RXLF_API DEPRECATED bool RxFocusOnPlaneEx( double dRelDepth, double dViewOffX = 0.0, double dViewOffY = 0.0 );
1983
1998 RXLF_API bool RxStereoOnPlane();
1999
2016 RXLF_API DEPRECATED bool RxStereoOnPlane( double dRelDepth );
2017
2055 RXLF_API DEPRECATED bool RxStereoOnPlaneEx( double dRelDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY );
2056
2079 RXLF_API bool RxFocusOnSurface();
2080
2105 RXLF_API DEPRECATED bool RxFocusOnSurface( double dStdDepth );
2106
2126 RXLF_API DEPRECATED bool RxFocusOnSurfaceEx( double dStdDepth, double dViewOffX, double dViewOffY );
2127
2143 RXLF_API bool RxStereoOnSurface();
2144
2162 RXLF_API DEPRECATED bool RxStereoOnSurface( double dStdDepth );
2163
2184 RXLF_API DEPRECATED bool RxStereoOnSurfaceEx( double dStdDepth, double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY );
2185
2207 RXLF_API bool RxDepth(bool bUpdate = false);
2208
2228 RXLF_API DEPRECATED bool RxDepth( );
2229
2253 RXLF_API DEPRECATED bool RxDepthEx( double dViewOffX, double dViewOffY, bool bUpdate = false );
2254
2255
2273 RXLF_API bool RxStereoDepth(bool bUpdate = false);
2274
2288 RXLF_API DEPRECATED bool RxStereoDepth( );
2289
2311 RXLF_API DEPRECATED bool RxStereoDepthEx( double dEyeSep, double dViewRotDeg, double dViewOffX, double dViewOffY, bool bUpdate = false );
2312
2327 RXLF_API bool RxDepthColorCode( double dRelDepthMin = 0.0, double dRelDepthMax = 1.0, EImgID::ID eTrgImgID = EImgID::DepthCol);
2328
2329 RXLF_API bool RxSaveDepthPointList(const char* pcFilename);
2330
2335
2337 }} // namespace Rx.ApiLF
2338
2339 #pragma managed(pop)
2340
Copyright (c) 2011 by Raytrix GmbH. All rights reserverd. Generated on Mon Apr 29 2013 18:48:22 by Raytrix GmbH


RxArrayDouble.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxArrayDouble.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 namespace Rx
14 {
19
23 class RXCORE_API CRxArrayDouble
24 {
25 public:
26 typedef double TValue;
27
28 CRxArrayDouble();
29 CRxArrayDouble(unsigned int uiLength);
30 CRxArrayDouble(const CRxArrayDouble& xArray);
31 virtual ~CRxArrayDouble();
32
33 CRxArrayDouble& operator= (const CRxArrayDouble& xArray);
34 TValue& CRxArrayDouble::operator[](unsigned int uiIdx);
35 const TValue& CRxArrayDouble::operator[](unsigned int uiIdx) const;
36
37 bool New(unsigned int iSize);
38 bool Resize(unsigned int uiSize);
39 void Delete();
40
41 void Reset();
42 unsigned int Length() const;
43 TValue* GetDataPtr();
44 const TValue* GetDataPtr() const;
45
46 bool IsValid() const;
47
48 protected:
49 void* m_pvData;
50 unsigned int m_uiLength;
51 };
52
53
56 } // end namespace Raytrix


RxArrayInt.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxArrayInt.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 namespace Rx
14 {
15
20
24 class RXCORE_API CRxArrayInt
25 {
26 public:
27 typedef int TValue;
28
29 CRxArrayInt();
30 CRxArrayInt(unsigned int uiLength);
31 CRxArrayInt(const CRxArrayInt& xArray);
32 virtual ~CRxArrayInt();
33
34 CRxArrayInt& operator= (const CRxArrayInt& xArray);
35 TValue& CRxArrayInt::operator[](unsigned int uiIdx);
36 const TValue& CRxArrayInt::operator[](unsigned int uiIdx) const;
37
38 bool New(unsigned int iSize);
39 bool Resize(unsigned int uiSize);
40 void Delete();
41
42 void Reset();
43 unsigned int Length() const;
44 TValue* GetDataPtr();
45 const TValue* GetDataPtr() const;
46
47 bool IsValid() const;
48
49 protected:
50 void* m_pvData;
51 unsigned int m_uiLength;
52 };
53
54
57 } // end namespace Raytrix


RxArrayString.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxArrayString.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 #include "RxString.h"
14
15 namespace Rx
16 {
21
25 class RXCORE_API CRxArrayString
26 {
27 public:
28 typedef Rx::CRxString TValue;
29
30 CRxArrayString();
31 CRxArrayString(unsigned int uiLength);
32 CRxArrayString(const CRxArrayString& xArray);
33 virtual ~CRxArrayString();
34
35 CRxArrayString& operator= (const CRxArrayString& xArray);
36 TValue& CRxArrayString::operator[](unsigned int uiIdx);
37 const TValue& CRxArrayString::operator[](unsigned int uiIdx) const;
38
39 bool New(unsigned int iSize);
40 bool Resize(unsigned int uiSize);
41 void Delete();
42
43 void Reset();
44 unsigned int Length() const;
45
46 bool IsValid() const;
47
48 protected:
49 void* m_pvData;
50 unsigned int m_uiLength;
51 };
52
53
56 } // end namespace Raytrix


RxArrayUChar.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxArrayUChar.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 namespace Rx
14 {
19
23 class RXCORE_API CRxArrayUChar
24 {
25 public:
26 typedef unsigned char TValue;
27
28 CRxArrayUChar();
29 CRxArrayUChar(unsigned int uiLength);
30 CRxArrayUChar(const CRxArrayUChar& xArray);
31 virtual ~CRxArrayUChar();
32
33 CRxArrayUChar& operator= (const CRxArrayUChar& xArray);
34 TValue& CRxArrayUChar::operator[](unsigned int uiIdx);
35 const TValue& CRxArrayUChar::operator[](unsigned int uiIdx) const;
36
37 bool New(unsigned int uiSize);
38 bool Resize(unsigned int uiSize);
39 void Delete();
40
41 void Reset();
42 unsigned int Length() const;
43 TValue* GetDataPtr();
44 const TValue* GetDataPtr() const;
45
46 bool IsValid() const;
47
48 protected:
49 void* m_pvData;
50 unsigned int m_uiLength;
51 };
52
53
56 } // end namespace Raytrix


RxArrayUInt.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxArrayUInt.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 namespace Rx
14 {
15
20
24 class RXCORE_API CRxArrayUInt
25 {
26 public:
27 typedef unsigned int TValue;
28
29 CRxArrayUInt();
30 CRxArrayUInt(unsigned int uiLength);
31 CRxArrayUInt(const CRxArrayUInt& xArray);
32 virtual ~CRxArrayUInt();
33
34 CRxArrayUInt& operator= (const CRxArrayUInt& xArray);
35 TValue& CRxArrayUInt::operator[](unsigned int uiIdx);
36 const TValue& CRxArrayUInt::operator[](unsigned int uiIdx) const;
37
38 bool New(unsigned int iSize);
39 bool Resize(unsigned int uiSize);
40 void Delete();
41
42 void Reset();
43 unsigned int Length() const;
44 TValue* GetDataPtr();
45 const TValue* GetDataPtr() const;
46
47 bool IsValid() const;
48
49 protected:
50 void* m_pvData;
51 unsigned int m_uiLength;
52 };
53
54
57 } // end namespace Raytrix


RxCore.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxCore.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4 #pragma once
5
6
14
20
35
37
42
47
53
57
58
59
60
61 #ifdef RXCORE_EXPORTS
62 #define RXCORE_API __declspec(dllexport)
63 #else
64 #define RXCORE_API __declspec(dllimport)
65 #endif
66
67
68 #include "RxTypes.h"
69 #include "RxImage.h"
70 #include "RxImageMoniker.h"
71 #include "RxImageFormat.h"
72 #include "RxTime.h"
73 #include "RxString.h"
74 #include "RxMetaData.h"
75 #include "RxArrayInt.h"
76 #include "RxArrayUInt.h"
77 #include "RxArrayDouble.h"
78 #include "RxArrayUChar.h"
79 #include "RxArrayString.h"
80
81


RxIfcImage.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime
  • Rx.Interop.Runtime28
RxIfcImage.h
Go to the documentation of this file.
1
2 // Raytrix Lightfield API Header file
3 // Copyright (c) 2010-2013 Raytrix GmbH. All rights reserved.
5
8 #ifndef __RX_IFC_IMAGE_INCLUDED__
9 #define __RX_IFC_IMAGE_INCLUDED__
10
11 #include "RxImageTypes.h"
12
13
15 // namespace: Rx
17 namespace Rx { namespace Interop { namespace Runtime28
18 {
19
24
30 class IImage
31 {
32 public:
33
47 virtual bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType ) = 0;
48
62 virtual bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData ) = 0;
63
73 virtual bool Create( const IImage* pImage ) = 0;
74
82 virtual bool Destroy() = 0;
83
91 virtual bool IsValid() const = 0;
92
100 virtual int GetBytesPerPixel() const = 0;
101
109 virtual unsigned GetPixelCount() const = 0;
110
118 virtual unsigned GetByteCount() const = 0;
119
128 virtual void GetSize( int &iWidth, int &iHeight ) const = 0;
129
138 virtual void GetType( EPixelType::ID &ePixelType, EDataType::ID &eDataType ) const = 0;
139
147 virtual void* GetDataPtr() = 0;
148
156 virtual const void* GetDataPtr() const = 0;
157
158 };
159
162 }}} // namespace Rx::Interop::Runtime28
163
164 #endif


RxImage.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxImage.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 #include "RxTypes.h"
14 #include "Rx.Interop.Runtime28/RxIfcImage.h"
15 #include "RxImageFormat.h"
16
17
18
19 namespace Rx
20 {
21 using namespace Rx::Interop::Runtime28;
22
27
61
62 class RXCORE_API CRxImage : public IImage
63 {
64 public:
65
66 public:
67 CRxImage(void);
68 CRxImage(const CRxImage& xImage);
69 virtual ~CRxImage(void);
70
74 CRxImage& operator= (const CRxImage& xImage);
75
79 virtual bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType );
80
84 virtual bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData );
85
89 virtual bool Create( const IImage* pImage );
90
94 bool Create( const Rx::CRxImageFormat &xFormat );
95
99 bool Create( const CRxImage& xImage );
100
104 virtual bool Destroy();
105
106
112 bool Set( const CRxImage& xImage );
113
119 bool Set( const void* pvData );
120
130 bool ConvertType( CRxImage& xImage, EPixelType::ID ePixelType, EDataType::ID eDataType ) const;
131
145
146 static bool ConvertType( IImage* pDstImg, const IImage* pSrcImg, EPixelType::ID ePixelType, EDataType::ID eDataType, bool bCreate );
147
151 virtual bool IsValid() const { return (m_pvData ? true : false); }
152
154 virtual int GetBytesPerPixel() const { return m_xFormat.GetBytesPerPixel(); }
155
157 virtual unsigned GetPixelCount() const { return m_xFormat.GetPixelCount(); }
158
160 virtual unsigned GetByteCount() const { return m_xFormat.GetByteCount(); }
161
163 virtual const Rx::CRxImageFormat& GetFormat() const { return m_xFormat; }
164
166 virtual void* GetDataPtr() { return m_pvData; }
167
169 virtual const void* GetDataPtr() const { return m_pvData; }
170
172 virtual void GetSize( int &iWidth, int &iHeight ) const
173 { iWidth = m_xFormat.m_iWidth; iHeight = m_xFormat.m_iHeight; }
174
176 virtual void GetType( Rx::EPixelType::ID &ePixelType, Rx::EDataType::ID &eDataType ) const
177 { ePixelType = m_xFormat.m_ePixelType; eDataType = m_xFormat.m_eDataType; }
178
180 bool IsOfType( Rx::EPixelType::ID ePixelType, Rx::EDataType::ID eDataType ) const
181 { return (ePixelType == m_xFormat.m_ePixelType && eDataType == m_xFormat.m_eDataType); }
182
188 bool Normalize();
189
190 void SetZero();
191 protected:
192 template<class TPix>
193 static bool ConvertTypeSub1( const IImage* pSrcImg, TPix* pTrgPix );
194
195 template<class TTrgPix, class TSrcPix>
196 static bool ConvertTypeSub2( const IImage* pSrcImg, TTrgPix *pTrgPix, const TSrcPix *pSrcPix );
197
198 protected:
199 CRxImageFormat m_xFormat;
200 void *m_pvData;
201 };
202
204 }


RxImageFormat.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxImageFormat.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 #include "Rx.Interop.Runtime28/RxIfcImage.h"
14 #include "RxTypes.h"
15 #include <string>
16
17
18 namespace Rx
19 {
20 using namespace Rx::Interop::Runtime28;
21
26
30 class RXCORE_API CRxImageFormat
31 {
32 public:
33 CRxImageFormat(void)
34 {
35 Reset();
36 }
37
38 void Reset()
39 {
40 m_iWidth = 0;
41 m_iHeight = 0;
42 m_ePixelType = EPixelType::None;
43 m_eDataType = EDataType::Void;
44 }
45
46 std::string ToString() const
47 {
48 char *pcPixType = "", *pcDataType = "";
49 switch( m_ePixelType )
50 {
51 case EPixelType::BayerBG: pcPixType = "BayerBG"; break;
52 case EPixelType::BayerGB: pcPixType = "BayerGB"; break;
53 case EPixelType::BayerGR: pcPixType = "BayerGR"; break;
54 case EPixelType::BayerRG: pcPixType = "BayerRG"; break;
55 case EPixelType::Lum: pcPixType = "Lum"; break;
56 case EPixelType::LumA: pcPixType = "LumA"; break;
57 case EPixelType::RGB: pcPixType = "RGB"; break;
58 case EPixelType::BGR: pcPixType = "BGR"; break;
59 case EPixelType::RGBA: pcPixType = "RGBA"; break;
60 case EPixelType::BGRA: pcPixType = "BGRA"; break;
61 }
62
63 switch ( m_eDataType )
64 {
65 case EDataType::Byte: pcDataType = "Byte"; break;
66 case EDataType::UByte: pcDataType = "UByte"; break;
67 case EDataType::Short: pcDataType = "Short"; break;
68 case EDataType::UShort: pcDataType = "UShort"; break;
69 case EDataType::Int: pcDataType = "Int"; break;
70 case EDataType::UInt: pcDataType = "UInt"; break;
71 case EDataType::Float: pcDataType = "Float"; break;
72 case EDataType::Double: pcDataType = "Double"; break;
73 }
74
75 char pcValue[101];
76 sprintf_s( pcValue, 100, "%dx%d, %s, %s", m_iWidth, m_iHeight, pcPixType, pcDataType );
77 std::string sValue( pcValue );
78
79 return sValue;
80 }
81
82 bool operator== ( const CRxImageFormat& xFormat ) const
83 {
84 return ( m_iWidth == xFormat.m_iWidth
85 && m_iHeight == xFormat.m_iHeight
86 && m_ePixelType == xFormat.m_ePixelType
87 && m_eDataType == xFormat.m_eDataType );
88 }
89
90 bool operator!= ( const CRxImageFormat& xFormat ) const
91 {
92 return ( m_iWidth != xFormat.m_iWidth
93 || m_iHeight != xFormat.m_iHeight
94 || m_ePixelType != xFormat.m_ePixelType
95 || m_eDataType != xFormat.m_eDataType );
96 }
97
105 template<class TPix>
106 bool IsOfType()
107 {
108 return TPix::IsOfType( m_ePixelType, m_eDataType );
109 }
110
111 bool IsBayerPixelType()
112 {
113 return ( m_ePixelType == EPixelType::BayerBG || m_ePixelType == EPixelType::BayerGB
114 || m_ePixelType == EPixelType::BayerGR || m_ePixelType == EPixelType::BayerRG );
115 }
116
117
118 int GetBytesPerPixel() const
119 {
120 int iElCnt = 0, iByteCnt = 0;
121
122 switch ( m_ePixelType )
123 {
124 case EPixelType::BayerBG:
125 case EPixelType::BayerGB:
126 case EPixelType::BayerGR:
127 case EPixelType::BayerRG:
128 case EPixelType::Lum:
129 iElCnt = 1;
130 break;
131
132 case EPixelType::LumA:
133 iElCnt = 2;
134 break;
135
136 case EPixelType::RGB:
137 case EPixelType::BGR:
138 iElCnt = 3;
139 break;
140
141 case EPixelType::RGBA:
142 case EPixelType::BGRA:
143 iElCnt = 4;
144 break;
145 }
146
147 switch ( m_eDataType )
148 {
149 case EDataType::Byte:
150 case EDataType::UByte:
151 iByteCnt = 1;
152 break;
153
154 case EDataType::Short:
155 case EDataType::UShort:
156 iByteCnt = 2;
157 break;
158
159 case EDataType::Int:
160 case EDataType::UInt:
161 case EDataType::Float:
162 iByteCnt = 4;
163 break;
164
165 case EDataType::Double:
166 iByteCnt = 8;
167 break;
168 }
169
170 return iElCnt * iByteCnt;
171 }
172
173
174 unsigned GetPixelCount() const
175 { return unsigned(m_iWidth) * unsigned(m_iHeight); }
176
177 unsigned GetByteCount() const
178 { return unsigned(GetBytesPerPixel()) * GetPixelCount(); }
179
180
181 public:
182 int m_iWidth, m_iHeight;
183 Rx::Interop::Runtime28::EDataType::ID m_eDataType;
184 Rx::Interop::Runtime28::EPixelType::ID m_ePixelType;
185 };
186
189 } // namespace


RxImageMoniker.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxImageMoniker.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 #include "RxImage.h"
14 #include "RxImageFormat.h"
15
16
17
18 namespace Rx
19 {
20
25
35 class RXCORE_API CRxImageMoniker : public IImage
36 {
37 public:
38
39 public:
40 CRxImageMoniker(void);
41 CRxImageMoniker(const CRxImageMoniker& xMoniker);
42 virtual ~CRxImageMoniker(void);
43
44 CRxImageMoniker& operator= (const CRxImageMoniker& xMoniker);
45
49 virtual bool Create( int iWidth, int iHeight, int iPixelType, int iDataType );
50
54 virtual bool Create( int iWidth, int iHeight, int iPixelType, int iDataType, const void *pData );
55
59 bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType );
60
64 bool Create( int iWidth, int iHeight, EPixelType::ID ePixelType, EDataType::ID eDataType, const void *pData );
65
69 virtual bool Create( const IImage* pImage );
70
74 bool Create( const Rx::CRxImageFormat &xFormat );
75
79 bool Create( const Rx::CRxImage& xImage );
80
84 virtual bool Destroy();
85
86
90 bool Set( const void* pvData );
91
95 virtual bool IsValid() const { return (m_pvData ? true : false); }
96
98 virtual int GetBytesPerPixel() const { return m_xFormat.GetBytesPerPixel(); }
99
101 virtual unsigned GetPixelCount() const { return m_xFormat.GetPixelCount(); }
102
104 virtual unsigned GetByteCount() const { return m_xFormat.GetByteCount(); }
105
107 const Rx::CRxImageFormat& GetFormat() const { return m_xFormat; }
108
110 virtual void* GetDataPtr() { return m_pvData; }
111
113 virtual const void* GetDataPtr() const { return m_pvData; }
114
116 virtual void GetSize( int &iWidth, int &iHeight ) const
117 { iWidth = m_xFormat.m_iWidth; iHeight = m_xFormat.m_iHeight; }
118
120 virtual void GetType( int &iPixelType, int &iDataType ) const
121 { iPixelType = int(m_xFormat.m_ePixelType); iDataType = int(m_xFormat.m_eDataType); }
122
124 void GetType( Rx::EPixelType::ID &ePixelType, Rx::EDataType::ID &eDataType ) const
125 { ePixelType = m_xFormat.m_ePixelType; eDataType = m_xFormat.m_eDataType; }
126
128 bool IsOfType( Rx::EPixelType::ID ePixelType, Rx::EDataType::ID eDataType ) const
129 { return (ePixelType == m_xFormat.m_ePixelType && eDataType == m_xFormat.m_eDataType); }
130
131
132 protected:
133 CRxImageFormat m_xFormat;
134 void *m_pvData;
135 };
136
138 }


RxImageTypes.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime
  • Rx.Interop.Runtime28
RxImageTypes.h
Go to the documentation of this file.
1
2 // Copyright (c) 2013 Raytrix GmbH. All rights reserved.
4
5 #ifndef __RX_IMAGE_TYPES_INCLUDED__
6 #define __RX_IMAGE_TYPES_INCLUDED__
7
12
13
14 // ///////////////////////////////////////////////////
15 // Image Type from Core version 2.8
16
20 #define RX_IMG_BYTE 0x1400
21 #define RX_IMG_UNSIGNED_BYTE 0x1401
22 #define RX_IMG_SHORT 0x1402
23 #define RX_IMG_UNSIGNED_SHORT 0x1403
24 #define RX_IMG_INT 0x1404
25 #define RX_IMG_UNSIGNED_INT 0x1405
26 #define RX_IMG_FLOAT 0x1406
27 #define RX_IMG_DOUBLE 0x140A
28
32 #define RX_IMG_RGB 0x1907
33 #define RX_IMG_RGBA 0x1908
34 #define RX_IMG_BGR 0x80E0
35 #define RX_IMG_BGRA 0x80E1
36 #define RX_IMG_LUMINANCE 0x1909
37 #define RX_IMG_LUMINANCE_ALPHA 0x190A
38
42 #define RX_IMG_BAYER_RG 0x2001
43 #define RX_IMG_BAYER_BG 0x2002
44 #define RX_IMG_BAYER_GR 0x2003
45 #define RX_IMG_BAYER_GB 0x2004
46
47 // ///////////////////////////////////////////////////
48
49
50 namespace Rx { namespace Interop { namespace Runtime28
51 {
56
60 namespace EDataType { enum ID
61 {
62 Void = 0,
63 Byte = RX_IMG_BYTE,
64 UByte = RX_IMG_UNSIGNED_BYTE,
65 Short = RX_IMG_SHORT,
66 UShort = RX_IMG_UNSIGNED_SHORT,
67 Int = RX_IMG_INT,
68 UInt = RX_IMG_UNSIGNED_INT,
69 Float = RX_IMG_FLOAT,
70 Double = RX_IMG_DOUBLE
71 };}
72
76 namespace EPixelType { enum ID
77 {
78 None = 0,
79 RGB = RX_IMG_RGB,
80 RGBA = RX_IMG_RGBA,
81 BGR = RX_IMG_BGR,
82 BGRA = RX_IMG_BGRA,
83 Lum = RX_IMG_LUMINANCE,
84 LumA = RX_IMG_LUMINANCE_ALPHA,
85 BayerBG = RX_IMG_BAYER_BG,
86 BayerGB = RX_IMG_BAYER_GB,
87 BayerGR = RX_IMG_BAYER_GR,
88 BayerRG = RX_IMG_BAYER_RG
89 };}
90
91 }}} // namespace Rx::Interop::Runtime28
92
93
94
95 #endif
96


RxMetaData.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxMetaData.h
Go to the documentation of this file.
1 #pragma once
2
3 #ifdef RXCORE_EXPORTS
4 #define RXCORE_API __declspec(dllexport)
5 #else
6 #define RXCORE_API __declspec(dllimport)
7 #endif
8
9 #include "RxString.h"
10 #include "RxArrayUInt.h"
11 #include "RxArrayDouble.h"
12 #include "RxArrayString.h"
13
14 namespace Rx
15 {
16
21
22
27 class RXCORE_API CRxMetaData
28 {
29 public:
30 CRxMetaData(void);
31 CRxMetaData(const CRxMetaData& xData);
32 ~CRxMetaData(void);
33
34 CRxMetaData& operator= (const CRxMetaData& xData);
35
36 void Clear();
37
38 unsigned GetElementCount();
39 bool GetElementNameType(unsigned iIdx, Rx::CRxString &sxName, Rx::CRxString &sxType);
40
41 bool HasElement(const Rx::CRxString& sxLabel);
42
43 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, unsigned uData);
44 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, double dData);
45 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, const Rx::CRxString& sxData);
46 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, const Rx::CRxArrayUInt& xData);
47 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, const Rx::CRxArrayDouble& xData);
48 bool AddElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxGroup, const Rx::CRxArrayString& xData);
49
50 bool SetElement(const Rx::CRxString& sxLabel, unsigned uData);
51 bool SetElement(const Rx::CRxString& sxLabel, double dData);
52 bool SetElement(const Rx::CRxString& sxLabel, const Rx::CRxString& sxData);
53 bool SetElement(const Rx::CRxString& sxLabel, const Rx::CRxArrayUInt& xData);
54 bool SetElement(const Rx::CRxString& sxLabel, const Rx::CRxArrayDouble& xData);
55 bool SetElement(const Rx::CRxString& sxLabel, const Rx::CRxArrayString& xData);
56
57 bool GetElement(const Rx::CRxString& sxLabel, unsigned &uData);
58 bool GetElement(const Rx::CRxString& sxLabel, double &dData);
59 bool GetElement(const Rx::CRxString& sxLabel, Rx::CRxString& sxData);
60 bool GetElement(const Rx::CRxString& sxLabel, Rx::CRxArrayUInt& xData);
61 bool GetElement(const Rx::CRxString& sxLabel, Rx::CRxArrayDouble& xData);
62 bool GetElement(const Rx::CRxString& sxLabel, Rx::CRxArrayString& xData);
63
64 Rx::CRxString GetLastError();
65
66 private:
67 bool Init();
68 bool Finalize();
69
70 private:
71 void *m_pvData;
72 Rx::CRxString m_sxLastError;
73 };
74
77 } // end namespace Raytrix


RxPixel.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxPixel.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 // Pixel definitions
6
7 //#pragma once
8
9 #ifndef __RX_PIXEL_H__DEFINED__
10 #define __RX_PIXEL_H__DEFINED__
11
12
13 #include <limits.h>
14 #include "Rx.Interop.Runtime28/RxIfcImage.h"
15
16 #ifdef RXCORE_EXPORTS
17 #define RXCORE_API __declspec(dllexport)
18 #else
19 #define RXCORE_API __declspec(dllimport)
20 #endif
21
22 namespace Rx
23 {
24 using namespace Rx::Interop::Runtime28;
25
27
32
39 template <class TDataType, unsigned int tuColorCnt, unsigned int tuAlphaCnt, int tiR, int tiG, int tiB, int tiA,
40 int tiPT, int tiDT>
41 struct TPixel
42 {
43 typedef TDataType TType;
44
45 static const int iPixelType = tiPT;
46 static const int iDataType = tiDT;
47
48 static const unsigned uColorCnt = tuColorCnt;
49 static const unsigned uAlphaCnt = tuAlphaCnt;
50 static const int iRedIdx = tiR;
51 static const int iGreenIdx = tiG;
52 static const int iBlueIdx = tiB;
53 static const int iAlphaIdx = tiA;
54
55 static const unsigned uSize = (tuColorCnt + tuAlphaCnt)*sizeof(TDataType);
56 static const unsigned uColorSize = tuColorCnt*sizeof(TDataType);
57 static const unsigned uAlphaSize = tuAlphaCnt*sizeof(TDataType);
58
59 TDataType value[ tuColorCnt + tuAlphaCnt ];
60
61
62 TPixel<TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT>&
63 operator= (const TPixel<TDataType, tuColorCnt, tuAlphaCnt, tiR, tiG, tiB, tiA, tiPT, tiDT>& rPix )
64 {
65 for ( int i = 0; i < tuColorCnt + tuAlphaCnt; ++i )
66 {
67 value[i] = rPix.value[i];
68 }
69
70 return *this;
71 }
72
73 void Clear()
74 {
75 for ( int i = 0; i < tuColorCnt + tuAlphaCnt; ++i )
76 {
77 value[i] = TDataType(0);
78 }
79 }
80
81 static bool IsOfType( int _iPixelType, int _iDataType )
82 { return (iPixelType == _iPixelType && iDataType == _iDataType); }
83
84 static bool IsOfType( Rx::EPixelType::ID _ePixelType, Rx::EDataType::ID _eDataType )
85 { return (iPixelType == int(_ePixelType) && iDataType == int(_eDataType) ); }
86
87 TDataType& r() { return value[tiR]; }
88 TDataType& g() { return value[tiG]; }
89 TDataType& b() { return value[tiB]; }
90 TDataType& a() { return value[tiA]; }
91
92 const TDataType& r() const { return value[tiR]; }
93 const TDataType& g() const { return value[tiG]; }
94 const TDataType& b() const { return value[tiB]; }
95 const TDataType& a() const { return value[tiA]; }
96 };
97
99 // Specific pixel definitions
100 typedef TPixel<char, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_BYTE> TPixel_RGBA_c;
101 typedef TPixel<char, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_BYTE> TPixel_BGRA_c;
102 typedef TPixel<char, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_BYTE> TPixel_RGB_c;
103 typedef TPixel<char, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_BYTE> TPixel_BGR_c;
104 typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_BYTE> TPixel_L_c;
105 typedef TPixel<char, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_BYTE> TPixel_LA_c;
106 typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_BYTE> TPixel_Bay_BG_c;
107 typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_BYTE> TPixel_Bay_GB_c;
108 typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_BYTE> TPixel_Bay_GR_c;
109 typedef TPixel<char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_BYTE> TPixel_Bay_RG_c;
110
111 typedef TPixel<unsigned char, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_BYTE> TPixel_RGBA_uc;
112 typedef TPixel<unsigned char, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_BYTE> TPixel_BGRA_uc;
113 typedef TPixel<unsigned char, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_BYTE> TPixel_RGB_uc;
114 typedef TPixel<unsigned char, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_BYTE> TPixel_BGR_uc;
115 typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_BYTE> TPixel_L_uc;
116 typedef TPixel<unsigned char, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_BYTE> TPixel_LA_uc;
117 typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_BYTE> TPixel_Bay_BG_uc;
118 typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_BYTE> TPixel_Bay_GB_uc;
119 typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_BYTE> TPixel_Bay_GR_uc;
120 typedef TPixel<unsigned char, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_BYTE> TPixel_Bay_RG_uc;
121
122 typedef TPixel<__int16, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_SHORT> TPixel_RGBA_s;
123 typedef TPixel<__int16, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_SHORT> TPixel_BGRA_s;
124 typedef TPixel<__int16, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_SHORT> TPixel_RGB_s;
125 typedef TPixel<__int16, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_SHORT> TPixel_BGR_s;
126 typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_SHORT> TPixel_L_s;
127 typedef TPixel<__int16, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_SHORT> TPixel_LA_s;
128 typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_SHORT> TPixel_Bay_BG_s;
129 typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_SHORT> TPixel_Bay_GB_s;
130 typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_SHORT> TPixel_Bay_GR_s;
131 typedef TPixel<__int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_SHORT> TPixel_Bay_RG_s;
132
133 typedef TPixel<unsigned __int16, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_SHORT> TPixel_RGBA_us;
134 typedef TPixel<unsigned __int16, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_SHORT> TPixel_BGRA_us;
135 typedef TPixel<unsigned __int16, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_SHORT> TPixel_RGB_us;
136 typedef TPixel<unsigned __int16, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_SHORT> TPixel_BGR_us;
137 typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_SHORT> TPixel_L_us;
138 typedef TPixel<unsigned __int16, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_SHORT> TPixel_LA_us;
139 typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_SHORT> TPixel_Bay_BG_us;
140 typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_SHORT> TPixel_Bay_GB_us;
141 typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_SHORT> TPixel_Bay_GR_us;
142 typedef TPixel<unsigned __int16, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_SHORT> TPixel_Bay_RG_us;
143
144 typedef TPixel<__int32, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_INT> TPixel_RGBA_i;
145 typedef TPixel<__int32, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_INT> TPixel_BGRA_i;
146 typedef TPixel<__int32, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_INT> TPixel_RGB_i;
147 typedef TPixel<__int32, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_INT> TPixel_BGR_i;
148 typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_INT> TPixel_L_i;
149 typedef TPixel<__int32, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_INT> TPixel_LA_i;
150 typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_INT> TPixel_Bay_BG_i;
151 typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_INT> TPixel_Bay_GB_i;
152 typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_INT> TPixel_Bay_GR_i;
153 typedef TPixel<__int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_INT> TPixel_Bay_RG_i;
154
155 typedef TPixel<unsigned __int32, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_UNSIGNED_INT> TPixel_RGBA_ui;
156 typedef TPixel<unsigned __int32, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_UNSIGNED_INT> TPixel_BGRA_ui;
157 typedef TPixel<unsigned __int32, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_UNSIGNED_INT> TPixel_RGB_ui;
158 typedef TPixel<unsigned __int32, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_UNSIGNED_INT> TPixel_BGR_ui;
159 typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_UNSIGNED_INT> TPixel_L_ui;
160 typedef TPixel<unsigned __int32, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_UNSIGNED_INT> TPixel_LA_ui;
161 typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_UNSIGNED_INT> TPixel_Bay_BG_ui;
162 typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_UNSIGNED_INT> TPixel_Bay_GB_ui;
163 typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_UNSIGNED_INT> TPixel_Bay_GR_ui;
164 typedef TPixel<unsigned __int32, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_UNSIGNED_INT> TPixel_Bay_RG_ui;
165
166 typedef TPixel<float, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_FLOAT> TPixel_RGBA_f;
167 typedef TPixel<float, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_FLOAT> TPixel_BGRA_f;
168 typedef TPixel<float, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_FLOAT> TPixel_RGB_f;
169 typedef TPixel<float, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_FLOAT> TPixel_BGR_f;
170 typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_FLOAT> TPixel_L_f;
171 typedef TPixel<float, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_FLOAT> TPixel_LA_f;
172 typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_FLOAT> TPixel_Bay_BG_f;
173 typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_FLOAT> TPixel_Bay_GB_f;
174 typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_FLOAT> TPixel_Bay_GR_f;
175 typedef TPixel<float, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_FLOAT> TPixel_Bay_RG_f;
176
177 typedef TPixel<double, 3, 1, 0, 1, 2, 3, RX_IMG_RGBA, RX_IMG_DOUBLE> TPixel_RGBA_d;
178 typedef TPixel<double, 3, 1, 2, 1, 0, 3, RX_IMG_BGRA, RX_IMG_DOUBLE> TPixel_BGRA_d;
179 typedef TPixel<double, 3, 0, 0, 1, 2, 0, RX_IMG_RGB, RX_IMG_DOUBLE> TPixel_RGB_d;
180 typedef TPixel<double, 3, 0, 2, 1, 0, 0, RX_IMG_BGR, RX_IMG_DOUBLE> TPixel_BGR_d;
181 typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_LUMINANCE, RX_IMG_DOUBLE> TPixel_L_d;
182 typedef TPixel<double, 1, 1, 0, 0, 0, 1, RX_IMG_LUMINANCE_ALPHA, RX_IMG_DOUBLE> TPixel_LA_d;
183 typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_BG, RX_IMG_DOUBLE> TPixel_Bay_BG_d;
184 typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GB, RX_IMG_DOUBLE> TPixel_Bay_GB_d;
185 typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_GR, RX_IMG_DOUBLE> TPixel_Bay_GR_d;
186 typedef TPixel<double, 1, 0, 0, 0, 0, 0, RX_IMG_BAYER_RG, RX_IMG_DOUBLE> TPixel_Bay_RG_d;
187
188
189 RXCORE_API void Float2Pixel( char& rPx, float fVal );
190 RXCORE_API void Float2Pixel( unsigned char& rPx, float fVal );
191 RXCORE_API void Float2Pixel( short& rPx, float fVal );
192 RXCORE_API void Float2Pixel( unsigned short& rPx, float fVal );
193 RXCORE_API void Float2Pixel( int& rPx, float fVal );
194 RXCORE_API void Float2Pixel( unsigned int& rPx, float fVal );
195 RXCORE_API void Float2Pixel( float& rPx, float fVal );
196 RXCORE_API void Float2Pixel( double& rPx, float fVal );
197
199 // Pixel data type value to floating piont value
200
201 RXCORE_API void Pixel2Float( float& fVal, char rPx );
202 RXCORE_API void Pixel2Float( float& fVal, unsigned char rPx );
203 RXCORE_API void Pixel2Float( float& fVal, short rPx );
204 RXCORE_API void Pixel2Float( float& fVal, unsigned short rPx );
205 RXCORE_API void Pixel2Float( float& fVal, int rPx );
206 RXCORE_API void Pixel2Float( float& fVal, unsigned int rPx );
207 RXCORE_API void Pixel2Float( float& fVal, float rPx );
208 RXCORE_API void Pixel2Float( float& fVal, double rPx );
209
211 // Pixel2Float and Float2Pixel for double values
212
213 // Convert double to pixel value
214 RXCORE_API void Float2Pixel( char& rPx, double fVal );
215 RXCORE_API void Float2Pixel( unsigned char& rPx, double fVal );
216 RXCORE_API void Float2Pixel( short& rPx, double fVal );
217 RXCORE_API void Float2Pixel( unsigned short& rPx, double fVal );
218 RXCORE_API void Float2Pixel( int& rPx, double fVal );
219 RXCORE_API void Float2Pixel( unsigned int& rPx, double fVal );
220 RXCORE_API void Float2Pixel( float& rPx, double fVal );
221 RXCORE_API void Float2Pixel( double& rPx, double fVal );
222
223
224 // Convert pixel value to double
225 RXCORE_API void Pixel2Float( double& fVal, char rPx );
226 RXCORE_API void Pixel2Float( double& fVal, unsigned char rPx );
227 RXCORE_API void Pixel2Float( double& fVal, short rPx );
228 RXCORE_API void Pixel2Float( double& fVal, unsigned short rPx );
229 RXCORE_API void Pixel2Float( double& fVal, int rPx );
230 RXCORE_API void Pixel2Float( double& fVal, unsigned int rPx );
231 RXCORE_API void Pixel2Float( double& fVal, float rPx );
232 RXCORE_API void Pixel2Float( double& fVal, double rPx );
233
234
235
238 } // namespace Raytrix
239
240 #endif
241


RxString.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxString.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 #pragma once
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 #include <string>
14
15 namespace Rx
16 {
17
22
28
29 class RXCORE_API CRxString
30 {
31 public:
32 CRxString(void);
33 CRxString( const char cChar );
34 CRxString( const char* pcString );
35 CRxString( const CRxString& sxString );
36 CRxString( const std::string& sString );
37 virtual ~CRxString(void);
38
39 CRxString& operator= ( const char cChar );
40 CRxString& operator= ( const char *pcString );
41 CRxString& operator= ( const CRxString& sxString );
42 CRxString& operator= ( const std::string& sString );
43
44 operator const char* () const;
45
46 bool operator==( const char* pcString ) const;
47 bool operator!=( const char* pcString ) const;
48
49 CRxString& operator += ( const char *pcString );
50 CRxString& operator += ( const CRxString& sxString );
51
52 CRxString& operator << ( const char *pcString );
53 CRxString& operator << ( const CRxString& sxString );
54
55 unsigned Size() const;
56 const char *ToCString() const;
57 std::string ToStdString() const;
58
59 void SplitFilename(CRxString& sxDir, CRxString& sxName, CRxString& sxExt) const;
60 CRxString SubStr(int iStartIdx, int iCount = -1) const;
61
89 int FindFirstOf(const char* pcWhat, int iStartIdx = 0, int iCount = -1) const;
90
91 int FindFirstNotOf(const char* pcWhat, int iStartIdx = 0, int iCount = -1) const;
92 int FindLastOf(const char* pcWhat, int iStartIdx = 0, int iCount = -1) const;
93 int FindLastNotOf(const char* pcWhat, int iStartIdx = 0, int iCount = -1) const;
94
118 int Find( const char* pcString, int iStartIdx = 0 ) const;
119 int Find( const std::string& sString, int iStartIdx = 0 ) const;
120 int Find( const CRxString& sString, int iStartIdx = 0 ) const;
121
131 bool Contains( const char* sString ) const;
132
145 //template < class TOld, class TNew >
146 CRxString Replace( const char* sOld, const char* sNew ) const;
147
148 private:
149 bool Init();
150 bool Finalize();
151
152 private:
153 void* m_pvData;
154 const char *m_pcString;
155 };
156
157 RXCORE_API CRxString operator+ ( const CRxString& sxA, const CRxString& sxB );
158 RXCORE_API CRxString operator+ ( const CRxString& sxA, const char* pcB );
159 RXCORE_API CRxString operator+ ( const char* pcA, const CRxString& sxB );
160
161 RXCORE_API CRxString operator+ ( const CRxString& sxA, int iVal );
162 RXCORE_API CRxString operator+ ( const CRxString& sxA, unsigned int uVal );
163 RXCORE_API CRxString operator+ ( const CRxString& sxA, float fVal );
164 RXCORE_API CRxString operator+ ( const CRxString& sxA, double dVal );
165
168 } // end namespace Raytrix


RxTime.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxTime.h
Go to the documentation of this file.
1 // Raytrix Lightfield API Header file
2 // Copyright (c) 2010 by Raytrix GmbH. All rights reserved.
3 //
4
5 // Functions to obtain exact time measurements
6
7 #ifdef RXCORE_EXPORTS
8 #define RXCORE_API __declspec(dllexport)
9 #else
10 #define RXCORE_API __declspec(dllimport)
11 #endif
12
13 namespace Rx
14 {
19
20
21 RXCORE_API void InitTime();
22 RXCORE_API double GetTime();
23 RXCORE_API __int64 GetTime64();
24 RXCORE_API void Sleep(unsigned uTime);
25
26
29 } // namespace


RxTypes.h Source File

  • File List
  • Globals
  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
RxTypes.h
Go to the documentation of this file.
1 #pragma once
2
7
8 typedef unsigned int uint;
9 typedef unsigned char uchar;
10
11


Rx.CluViz.Core.CluVizTool Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.CluVizTool
Rx.CluViz.Core.CluVizTool Directory Reference

Files

file CvCluVizTool.h [code]


Rx.CluViz.Core.ST Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.ST
Rx.CluViz.Core.ST Directory Reference

Files

file CvCluVizSt.h [code]


Rx.Core Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.Core
Rx.Core Directory Reference

Files

file | RxArrayDouble.h [code]
file | RxArrayInt.h [code]
file | RxArrayString.h [code]
file | RxArrayUChar.h [code]
file | RxArrayUInt.h [code]
file | RxCore.h [code]
file | RxImage.h [code]
file | RxImageFormat.h [code]
file | RxImageMoniker.h [code]
file | RxMetaData.h [code]
file | RxPixel.h [code]
file | RxString.h [code]
file | RxTime.h [code]
file | RxTypes.h [code]


_dist Directory Reference

  • _dist
_dist Directory Reference

Directories

directory _include


Rx.CluViz.Core.MT Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.CluViz.Core.MT
Rx.CluViz.Core.MT Directory Reference

Files

file | CvCluViz.h [code]
file | CvCluVizEx.h [code]


Rx.ApiLF Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF
Rx.ApiLF Directory Reference

Files

file | Rx.ApiLF.h [code]
file | Rx.ApiLF.Net.CtrlLogListView.h [code]
file | Rx.ApiLF.Net.FormLogConsole.h [code]
file | Rx.ApiLF.Net.LogConsoleManager.h [code]


Rx.ApiLF.Lib.Base Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
  • Rx.ApiLF.Lib.Base
Rx.ApiLF.Lib.Base Directory Reference

Files

file | Rx.ApiLF.Errors.h [code]
file | Rx.ApiLF.ErrorValues.h [code]
file | Rx.ApiLF.Features.h [code]
file | Rx.ApiLF.FeatureValues.h [code]
file | Rx.ApiLF.Properties.h [code]
file | Rx.ApiLF.PropertyValues.h [code]
file | Rx.ApiLF.StatusCodes.h [code]
file | Rx.ApiLF.StatusCodeValues.h [code]
file | Rx.ApiLF.StatusMessageDelegateList.h [code]
file | Rx.ApiLF.Types.h [code]


RxRuntime Directory Reference

  • _dist
  • _include
  • RxRuntime
RxRuntime Directory Reference

Directories

directory Rx.Interop.Runtime28


RxRuntime-2.8 Directory Reference

  • _dist
  • _include
  • RxRuntime-2.8
RxRuntime-2.8 Directory Reference

Directories

directory | Rx.ApiLF
directory | Rx.ApiLF.Lib.Base
directory | Rx.CluViz.Core.CluVizTool
directory | Rx.CluViz.Core.MT
directory | Rx.CluViz.Core.ST
directory | Rx.Core


_include Directory Reference

  • _dist
  • _include
_include Directory Reference

Directories

directory | RxRuntime
directory | RxRuntime-2.8


Rx.Interop.Runtime28 Directory Reference

  • _dist
  • _include
  • RxRuntime
  • Rx.Interop.Runtime28
Rx.Interop.Runtime28 Directory Reference

Files

file | RxIfcImage.h [code]
file | RxImageTypes.h [code]


Related Pages

Related Pages
Here is a list of all related documentation pages:
o Change Log
\ Programming with the Lightfield API