EposCmd.Net Namespace

EposCmd.Net Namespace EposCmd.Net
This documentation provides the instructions for the provided functions of the .Net DLL EposCmd.Net.dll.
It describes the interface between a .NET application and the EPOS Windows DLL EposCmd(64).dll for 32- and 64-Bit Windows systems.

The document EPOS Command Library PDF contains additional information regarding the usage of the dynamic-link libraries (DLLs).

THIS LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THIS LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THIS LIBRARY IS WITH YOU. SHOULD THIS LIBRARY PROVE DEFECTIVE OR INSUFFICIENT, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

Requirements: .NET Framework 2.0

History

See document EPOS Command Library PDF for version information.
Classes
 | Class | Description
 | Device | Epos device
Public class | DeviceCommandGroup | This class is the base class for the epos device class
Public class | DeviceException | DeviceException class contains the information about epos specific error codes and messages
Public class | DeviceManager | Epos device connector class
Public class | ErrorHandling | This class contains the error code information and is the base class for every EposCmd class
Enumerations
 | Enumeration | Description
Public enumeration | EAnalogInputConfiguration | Kind of analog input configuration
Public enumeration | ECommandSpecifier | NMT services command
Public enumeration | EDataRecorderTriggerType | Data recorder trigger type
Public enumeration | EDialogMode | Kind of dialog mode
Public enumeration | EDigitalInputConfiguration | Kind of digital input configuration
Public enumeration | EDigitalOutputConfiguration | Kind of digital output configuration
Public enumeration | EHomingMethod | Homing method
Public enumeration | EMotorType | Kind of motor type
Public enumeration | EOperationMode | Kind of operation mode
Public enumeration | EPositionCompareDirectionDependency | Position compare direction dependency
Public enumeration | EPositionCompareIntervalMode | Position compare interval mode
Public enumeration | EPositionCompareOperationalMode | Position compare operational mode
Public enumeration | EPositionMarkerEdgeType | Kind of position marker edge type
Public enumeration | EPositionMarkerMode | Position marker-capturing mode
Public enumeration | ESensorType | Kind of position sensor type
Public enumeration | EStates | Controller state
Public enumeration | EVelocityDimension | Velocity dimension index
Public enumeration | EVelocityNotation | Velocity notation index
Examples
Copy
using EposCmd.Net;

public static void Sample()
{
    try
    {
        //DeviceManager object is the starting point of our sample.
        //It will create and store the connection handle for the whole session.
        //
        //DeviceManager without parameters in constructor will start the connection dialog
        //DeviceManager instance should be created in the main application thread.
        using (DeviceManager connector = new DeviceManager("EPOS2","MAXON SERIAL V2", "USB", "USB0"))
        {
            try
            {
                //set connection properties
                //connector.Baudrate = 1000000;
                connector.Timeout = 500;

                //create new epos device,
                Device epos1 = connector.CreateDevice(1 /*node id*/);
                //to make the code more compact we can make the helper variable out of the
                //internal Device properties
                StateMachine sm = epos1.Operation.StateMachine;
                ProfileVelocityMode pvm = epos1.Operation.ProfileVelocityMode;

                //clear errors
                sm.ClearFault();

                //each method have the access to the lastError property
                //this way you can additionally check the error code of the function call
                Console.WriteLine("Last error:" + sm.LastError);

                //disable epos device
                sm.SetDisableState();

                //enable
                sm.SetEnableState();

                //activate profile velocity mode is necessary to use pvm functions
                pvm.ActivateProfileVelocityMode();

                //move
                pvm.MoveWithVelocity(2000);

                //read the new position, this call as you can see is made without using helper variable
                long pos = epos1.Operation.MotionInfo.GetPositionIs();

                Console.WriteLine(pos);

                System.Threading.Thread.Sleep(2000);

                pvm.MoveWithVelocity(1000);

                System.Threading.Thread.Sleep(1000);

                pvm.MoveWithVelocity(0);

                System.Threading.Thread.Sleep(1000);

                sm.SetDisableState();
            }
            catch (DeviceException e)
            {
                Console.WriteLine(e.Message + e.ErrorCode);
            }
        }

        //important notice
        //It's redundant to call Dispose in this example, but in most cases we recommend to call Dispose method
        //before application close to have control when the EposCmd(64).dll will be unloaded.
        //Dispose method should be called in the main application thread.
        connector.Dispose();
    }
    catch (DeviceException e)
    {
        //DeviceException contains the information about the error code from the device
        //message usually contains the information about the internal function rapporting the problem
        Console.WriteLine(e.Message + e.ErrorCode);
    }
    catch (Exception e)
    {
        Console.WriteLine(e.Message);
    }

    System.Threading.Thread.Sleep(1000);
}

maxon motor ag

Send comments on this topic to info@maxonmotor.com


Device Class

Device Class EposCmd.Net
Epos device
Inheritance Hierarchy
SystemObject
EposCmd.NetDevice

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Device
Public MustInherit Class Device
public ref class Device abstract
[<AbstractClassAttribute>]
type Device =  class end

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets the configuration.
Public property | DataRecording | Gets the data recording.
Public property | Initialization | Gets the initialization.
Public property | LowLayer | Gets the low layer.
Public property | Operation | Gets the operation.
Top
Examples
Copy
//DeviceManager instance should be created in the main application thread.
using (DeviceManager connector = new DeviceManager("EPOS2","MAXON SERIAL V2", "USB", "USB0"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //clear errors
        epos1.Operation.StateMachine.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //It's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

EposCmd.Net Namespace


Device Properties

Device Properties EposCmd.Net

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets the configuration.
Public property | DataRecording | Gets the data recording.
Public property | Initialization | Gets the initialization.
Public property | LowLayer | Gets the low layer.
Public property | Operation | Gets the operation.
Top
See Also

Reference

Device Class
EposCmd.Net Namespace


Device.Configuration Property

DeviceConfiguration Property EposCmd.Net
Gets the configuration.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Configuration Configuration { get; }
Public MustOverride ReadOnly Property Configuration As Configuration
    Get
public:
virtual property Configuration^ Configuration {
    Configuration^ get () abstract;
}
abstract Configuration : Configuration with get

Property Value

Type: Configuration
The configuration.
See Also

Reference

Device Class
EposCmd.Net Namespace


Device.DataRecording Property

DeviceDataRecording Property EposCmd.Net
Gets the data recording.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract DataRecorder DataRecording { get; }
Public MustOverride ReadOnly Property DataRecording As DataRecorder
    Get
public:
virtual property DataRecorder^ DataRecording {
    DataRecorder^ get () abstract;
}
abstract DataRecording : DataRecorder with get

Property Value

Type: DataRecorder
The data recording.
See Also

Reference

Device Class
EposCmd.Net Namespace


Device.Initialization Property

DeviceInitialization Property EposCmd.Net
Gets the initialization.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Initialization Initialization { get; }
Public MustOverride ReadOnly Property Initialization As Initialization
    Get
public:
virtual property Initialization^ Initialization {
    Initialization^ get () abstract;
}
abstract Initialization : Initialization with get

Property Value

Type: Initialization
The initialization.
See Also

Reference

Device Class
EposCmd.Net Namespace


Device.LowLayer Property

DeviceLowLayer Property EposCmd.Net
Gets the low layer.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract LowLayer LowLayer { get; }
Public MustOverride ReadOnly Property LowLayer As LowLayer
    Get
public:
virtual property LowLayer^ LowLayer {
    LowLayer^ get () abstract;
}
abstract LowLayer : LowLayer with get

Property Value

Type: LowLayer
The low layer.
See Also

Reference

Device Class
EposCmd.Net Namespace


Device.Operation Property

DeviceOperation Property EposCmd.Net
Gets the operation.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Operation Operation { get; }
Public MustOverride ReadOnly Property Operation As Operation
    Get
public:
virtual property Operation^ Operation {
    Operation^ get () abstract;
}
abstract Operation : Operation with get

Property Value

Type: Operation
The operation.
See Also

Reference

Device Class
EposCmd.Net Namespace


DeviceCommandGroup Class

DeviceCommandGroup Class EposCmd.Net
This class is the base class for the epos device class
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
More...

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DeviceCommandGroup : ErrorHandling
Public Class DeviceCommandGroup
    Inherits ErrorHandling
public ref class DeviceCommandGroup : public ErrorHandling
type DeviceCommandGroup =
    class
        inherit ErrorHandling
    end

The DeviceCommandGroup type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceCommandGroup | Initializes a new instance of the DeviceCommandGroup class
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net Namespace
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationCompatibility
EposCmd.Net.DeviceCmdSet.ConfigurationConfiguration
EposCmd.Net.DeviceCmdSet.ConfigurationInputOutput
EposCmd.Net.DeviceCmdSet.ConfigurationMotor
EposCmd.Net.DeviceCmdSet.ConfigurationRegulator
EposCmd.Net.DeviceCmdSet.ConfigurationSafety
EposCmd.Net.DeviceCmdSet.ConfigurationSensor
EposCmd.Net.DeviceCmdSet.ConfigurationUnits
EposCmd.Net.DeviceCmdSet.DataRecorderData
EposCmd.Net.DeviceCmdSet.DataRecorderDataRecorderAdvanced
EposCmd.Net.DeviceCmdSet.DataRecorderSetup
EposCmd.Net.DeviceCmdSet.DataRecorderStatus
EposCmd.Net.DeviceCmdSet.InitializationInitialization
EposCmd.Net.DeviceCmdSet.InitializationInitializationAdvanced
EposCmd.Net.DeviceCmdSet.LowLayerCanLayer
EposCmd.Net.DeviceCmdSet.OperationCurrentMode
EposCmd.Net.DeviceCmdSet.OperationCurrentModeAdvanced
EposCmd.Net.DeviceCmdSet.OperationDeviceErrorHandling
EposCmd.Net.DeviceCmdSet.OperationHomingMode
EposCmd.Net.DeviceCmdSet.OperationInputOutput
EposCmd.Net.DeviceCmdSet.OperationInterpolatedPositionMode
EposCmd.Net.DeviceCmdSet.OperationMasterEncoderMode
EposCmd.Net.DeviceCmdSet.OperationMotionInfo
EposCmd.Net.DeviceCmdSet.OperationOperationMode
EposCmd.Net.DeviceCmdSet.OperationPositionCompare
EposCmd.Net.DeviceCmdSet.OperationPositionMarker
EposCmd.Net.DeviceCmdSet.OperationPositionMode
EposCmd.Net.DeviceCmdSet.OperationPositionModeAdvanced
EposCmd.Net.DeviceCmdSet.OperationProfilePositionMode
EposCmd.Net.DeviceCmdSet.OperationProfilePositionModeAdvanced
EposCmd.Net.DeviceCmdSet.OperationProfileVelocityMode
EposCmd.Net.DeviceCmdSet.OperationProfileVelocityModeAdvanced
EposCmd.Net.DeviceCmdSet.OperationStateMachine
EposCmd.Net.DeviceCmdSet.OperationStepDirectionMode
EposCmd.Net.DeviceCmdSet.OperationVelocityMode
EposCmd.Net.DeviceCmdSet.OperationVelocityModeAdvanced


DeviceCommandGroup Constructor

DeviceCommandGroup Constructor EposCmd.Net
Initializes a new instance of the DeviceCommandGroup class

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceCommandGroup()
Public Sub New
public:
DeviceCommandGroup()
new : unit -> DeviceCommandGroup
See Also

Reference

DeviceCommandGroup Class
EposCmd.Net Namespace


DeviceCommandGroup Properties

DeviceCommandGroup Properties EposCmd.Net

The DeviceCommandGroup type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

DeviceCommandGroup Class
EposCmd.Net Namespace


DeviceException Class

DeviceException Class EposCmd.Net
DeviceException class contains the information about epos specific error codes and messages
Inheritance Hierarchy
SystemObject
SystemException
EposCmd.NetDeviceException

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DeviceException : Exception
<SerializableAttribute>
Public Class DeviceException
    Inherits Exception
[SerializableAttribute]
public ref class DeviceException : public Exception
[<SerializableAttribute>]
type DeviceException =
    class
        inherit Exception
    end

The DeviceException type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceException(String) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(UInt32) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, Exception) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, UInt32) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, UInt32, Exception) | Initializes a new instance of the DeviceException class.
Top
Properties
Name | Description
ErrorCode | This property stores the value of the error code
ErrorMessage | This property contains the formatted description of the epos error code.
Top
See Also

Reference

EposCmd.Net Namespace


DeviceException Constructor

DeviceException Constructor EposCmd.Net
Overload List
 | Name | Description
Public method | DeviceException(String) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(UInt32) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, Exception) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, UInt32) | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, UInt32, Exception) | Initializes a new instance of the DeviceException class.
Top
See Also

Reference

DeviceException Class
EposCmd.Net Namespace


DeviceException Constructor (String)

DeviceException Constructor (String) EposCmd.Net
Initializes a new instance of the DeviceException class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceException(
    string errorMessage
)
Public Sub New (
    errorMessage As String
)
public:
DeviceException(
    String^ errorMessage
)
new :
        errorMessage : string -> DeviceException

Parameters

errorMessage
Type: SystemString
The error message.
See Also

Reference

DeviceException Class
DeviceException Overload
EposCmd.Net Namespace


DeviceException Constructor (UInt32)

DeviceException Constructor (UInt32) EposCmd.Net
Initializes a new instance of the DeviceException class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceException(
    uint errorCode
)
Public Sub New (
    errorCode As UInteger
)
public:
DeviceException(
    unsigned int errorCode
)
new :
        errorCode : uint32 -> DeviceException

Parameters

errorCode
Type: SystemUInt32
The error code.
See Also

Reference

DeviceException Class
DeviceException Overload
EposCmd.Net Namespace


DeviceException Constructor (String, Exception)

DeviceException Constructor (String, Exception) EposCmd.Net
Initializes a new instance of the DeviceException class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceException(
    string errorMessage,
    Exception innerEx
)
Public Sub New (
    errorMessage As String,
    innerEx As Exception
)
public:
DeviceException(
    String^ errorMessage,
    Exception^ innerEx
)
new :
        errorMessage : string *
        innerEx : Exception -> DeviceException

Parameters

errorMessage
Type: SystemString
The error message.
innerEx
Type: SystemException
The inner ex.
See Also

Reference

DeviceException Class
DeviceException Overload
EposCmd.Net Namespace


DeviceException Constructor (String, UInt32)

DeviceException Constructor (String, UInt32) EposCmd.Net
Initializes a new instance of the DeviceException class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceException(
    string errorMessage,
    uint errorCode
)
Public Sub New (
    errorMessage As String,
    errorCode As UInteger
)
public:
DeviceException(
    String^ errorMessage,
    unsigned int errorCode
)
new :
        errorMessage : string *
        errorCode : uint32 -> DeviceException

Parameters

errorMessage
Type: SystemString
The error message.
errorCode
Type: SystemUInt32
The error code.
See Also

Reference

DeviceException Class
DeviceException Overload
EposCmd.Net Namespace


DeviceException Constructor (String, UInt32, Exception)

DeviceException Constructor (String, UInt32, Exception) EposCmd.Net
Initializes a new instance of the DeviceException class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceException(
    string errorMessage,
    uint errorCode,
    Exception innerEx
)
Public Sub New (
    errorMessage As String,
    errorCode As UInteger,
    innerEx As Exception
)
public:
DeviceException(
    String^ errorMessage,
    unsigned int errorCode,
    Exception^ innerEx
)
new :
        errorMessage : string *
        errorCode : uint32 *
        innerEx : Exception -> DeviceException

Parameters

errorMessage
Type: SystemString
The error message.
errorCode
Type: SystemUInt32
The error code.
innerEx
Type: SystemException
The inner ex.
See Also

Reference

DeviceException Class
DeviceException Overload
EposCmd.Net Namespace


DeviceException Properties

DeviceException Properties EposCmd.Net

The DeviceException type exposes the following members.

Properties
Name | Description
ErrorCode | This property stores the value of the error code
ErrorMessage | This property contains the formatted description of the epos error code.
Top
See Also

Reference

DeviceException Class
EposCmd.Net Namespace


DeviceException.ErrorCode Property

DeviceExceptionErrorCode Property EposCmd.Net
This property stores the value of the error code

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint ErrorCode { get; }
Public ReadOnly Property ErrorCode As UInteger
    Get
public:
property unsigned int ErrorCode {
    unsigned int get ();
}
member ErrorCode : uint32 with get

Property Value

Type: UInt32
The error code.
Examples
Copy
//DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //clear errors
        epos1.Operation.StateMachine.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }

  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceException Class
EposCmd.Net Namespace


DeviceException.ErrorMessage Property

DeviceExceptionErrorMessage Property EposCmd.Net
This property contains the formatted description of the epos error code.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
The error message.
Examples
Copy
//DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //clear errors
        epos1.Operation.StateMachine.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }

  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();

}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceException Class
EposCmd.Net Namespace


DeviceManager Class

DeviceManager Class EposCmd.Net
Epos device connector class
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceManager

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DeviceManager : ErrorHandling
Public Class DeviceManager
    Inherits ErrorHandling
public ref class DeviceManager : public ErrorHandling
type DeviceManager =
    class
        inherit ErrorHandling
    end

The DeviceManager type exposes the following members.

Constructors
Name | Description
DeviceManager | Initializes a new instance of the DeviceManager class. Open device dialog will appear.
DeviceManager(String, String, String, String) | Initializes a new instance of the DeviceManager class.
Top
Methods
Name | Description
CreateDevice | Creates the Epos device.
Top
Properties
Name | Description
Baudrate | Gets or sets the baudrate.
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Timeout | Gets or sets the timeout.
Top
See Also

Reference

EposCmd.Net Namespace


DeviceManager Constructor

DeviceManager Constructor EposCmd.Net
Overload List
Name | Description
DeviceManager | Initializes a new instance of the DeviceManager class. Open device dialog will appear.
DeviceManager(String, String, String, String) | Initializes a new instance of the DeviceManager class.
Top
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


DeviceManager Constructor

DeviceManager Constructor EposCmd.Net
Initializes a new instance of the DeviceManager class. Open device dialog will appear.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceManager()
Public Sub New
public:
DeviceManager()
new : unit -> DeviceManager
Examples
Copy
using EposCmd.Net;
using EposCmd.Net.DeviceCmdSet;
using EposCmd.Net.DeviceCmdSet.Operation;

using (DeviceManager connector = new DeviceManager())
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //to make the code more compact we can make the helper variable out of the
        //internal Device properties
        StateMachine sm = epos1.Operation.StateMachine;
        ProfileVelocityMode pvm = epos1.Operation.ProfileVelocityMode;

        //clear errors
        sm.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceManager Class
DeviceManager Overload
EposCmd.Net Namespace


DeviceManager Constructor (String, String, String, String)

DeviceManager Constructor (String, String, String, String) EposCmd.Net
Initializes a new instance of the DeviceManager class.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceManager(
    string deviceName,
    string protocolStackName,
    string interfaceName,
    string portName
)
Public Sub New (
    deviceName As String,
    protocolStackName As String,
    interfaceName As String,
    portName As String
)
public:
DeviceManager(
    String^ deviceName,
    String^ protocolStackName,
    String^ interfaceName,
    String^ portName
)
new :
        deviceName : string *
        protocolStackName : string *
        interfaceName : string *
        portName : string -> DeviceManager

Parameters

deviceName
Type: SystemString
Device name
protocolStackName
Type: SystemString
Protocol stack name
interfaceName
Type: SystemString
Interface name
portName
Type: SystemString
Port name
Examples
Copy
// DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //to make the code more compact we can make the helper variable out of the
        //internal Device properties
        StateMachine sm = epos1.Operation.StateMachine;
        ProfileVelocityMode pvm = epos1.Operation.ProfileVelocityMode;

        //clear errors
        sm.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceManager Class
DeviceManager Overload
EposCmd.Net Namespace


DeviceManager Methods

DeviceManager Methods EposCmd.Net

The DeviceManager type exposes the following members.

Methods
Name | Description
CreateDevice | Creates the Epos device.
Top
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


DeviceManager.CreateDevice Method

DeviceManagerCreateDevice Method EposCmd.Net
Creates the Epos device.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Device CreateDevice(
    ushort nodeId
)
Public Function CreateDevice (
    nodeId As UShort
) As Device
public:
Device^ CreateDevice(
    unsigned short nodeId
)
member CreateDevice :
        nodeId : uint16 -> Device

Parameters

nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).

Return Value

Type: Device
Device object
Examples
Copy
// DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //to make the code more compact we can make the helper variable out of the
        //internal Device properties
        StateMachine sm = epos1.Operation.StateMachine;
        ProfileVelocityMode pvm = epos1.Operation.ProfileVelocityMode;

        //clear errors
        sm.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


DeviceManager Properties

DeviceManager Properties EposCmd.Net

The DeviceManager type exposes the following members.

Properties
Name | Description
Baudrate | Gets or sets the baudrate.
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Timeout | Gets or sets the timeout.
Top
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


DeviceManager.Baudrate Property

DeviceManagerBaudrate Property EposCmd.Net
Gets or sets the baudrate.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint Baudrate { get; set; }
Public Property Baudrate As UInteger
    Get
    Set
public:
property unsigned int Baudrate {
    unsigned int get ();
    void set (unsigned int value);
}
member Baudrate : uint32 with get, set

Property Value

Type: UInt32
The baudrate.
Examples
Copy
// DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        connector.Baudrate = 38400;
        connector.Timeout = 500;

    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


DeviceManager.Timeout Property

DeviceManagerTimeout Property EposCmd.Net
Gets or sets the timeout.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint Timeout { get; set; }
Public Property Timeout As UInteger
    Get
    Set
public:
property unsigned int Timeout {
    unsigned int get ();
    void set (unsigned int value);
}
member Timeout : uint32 with get, set

Property Value

Type: UInt32
The timeout.
Examples
Copy
// DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        connector.Baudrate = 38400;
        connector.Timeout = 500;

    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

DeviceManager Class
EposCmd.Net Namespace


EAnalogInputConfiguration Enumeration

EAnalogInputConfiguration Enumeration EposCmd.Net
Kind of analog input configuration

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EAnalogInputConfiguration
Public Enumeration EAnalogInputConfiguration
public enum class EAnalogInputConfiguration
type EAnalogInputConfiguration
Members
Member name | Value | Description
AicAnalogCurrentSetpoint | 0 | Analog Current Setpoint
AicAnalogVelocitySetpoint | 1 | Analog Velocity Setpoint
AicAnalogPositionSetpoint | 2 | Analog Position Setpoint
AicAnalogGeneralPurposeB | 14 | Analog General Purpose B
AicAnalogGeneralPurposeA | 15 | Analog General Purpose A
See Also

Reference

EposCmd.Net Namespace


ECommandSpecifier Enumeration

ECommandSpecifier Enumeration EposCmd.Net
NMT services command

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ECommandSpecifier
Public Enumeration ECommandSpecifier
public enum class ECommandSpecifier
type ECommandSpecifier
Members
Member name | Value | Description
NcsStartRemoteNode | 1 | Start remote node
NcsStopRemoteNode | 2 | Stop remote node
NcsEnterPreOperational | 128 | Enter Pre-Operational
NcsResetNode | 129 | Reset Node
NcsResetCommunication | 130 | Reset Communication
See Also

Reference

EposCmd.Net Namespace


EDataRecorderTriggerType Enumeration

EDataRecorderTriggerType Enumeration EposCmd.Net
Data recorder trigger type

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EDataRecorderTriggerType
Public Enumeration EDataRecorderTriggerType
public enum class EDataRecorderTriggerType
type EDataRecorderTriggerType
Members
Member name | Value | Description
DrMovementTrigger | 1 | Movement Trigger
DrErrorTrigger | 2 | Error Trigger
DrDigitalInputTrigger | 4 | Digital Input Trigger
DrMovementEndTrigger | 8 | Movement End Trigger
See Also

Reference

EposCmd.Net Namespace


EDialogMode Enumeration

EDialogMode Enumeration EposCmd.Net
Kind of dialog mode

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EDialogMode
Public Enumeration EDialogMode
public enum class EDialogMode
type EDialogMode
Members
Member name | Value | Description
DmProgressDlg | 0 | Show Progress Dialog
DmProgressAndConfirmDlg | 1 | Show Progress and Confirmation Dialog
DmConfirmDlg | 2 | Show Confirmation Dialog
DmNoDlg | 3 | Dont' show any Dialog
See Also

Reference

EposCmd.Net Namespace


EDigitalInputConfiguration Enumeration

EDigitalInputConfiguration Enumeration EposCmd.Net
Kind of digital input configuration

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EDigitalInputConfiguration
Public Enumeration EDigitalInputConfiguration
public enum class EDigitalInputConfiguration
type EDigitalInputConfiguration
Members
Member name | Value | Description
DicNegativeLimitSwitch | 0 | Negative Limit Switch
DicPositiveLimitSwitch | 1 | Positive Limit Switch
DicHomeSwitch | 2 | Home Switch
DicPositionMarker | 3 | Position Marker
DicDriveEnable | 4 | Drive Enable
DicQuickStop | 5 | Quick Stop
DicGeneralPurposeJ | 6 | General Purpose J
DicGeneralPurposeI | 7 | General Purpose I
DicGeneralPurposeH | 8 | General Purpose H
DicGeneralPurposeG | 9 | General Purpose G
DicGeneralPurposeF | 10 | General Purpose F
DicGeneralPurposeE | 11 | General Purpose E
DicGeneralPurposeD | 12 | General Purpose D
DicGeneralPurposeC | 13 | General Purpose C
DicGeneralPurposeB | 14 | General Purpose B
DicGeneralPurposeA | 15 | General Purpose A
DicTouchProbe1 | 26 | Touch Probe 1
DicNoFunctionality | 255 | No Functionality
See Also

Reference

EposCmd.Net Namespace


EDigitalOutputConfiguration Enumeration

EDigitalOutputConfiguration Enumeration EposCmd.Net
Kind of digital output configuration

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EDigitalOutputConfiguration
Public Enumeration EDigitalOutputConfiguration
public enum class EDigitalOutputConfiguration
type EDigitalOutputConfiguration
Members
Member name | Value | Description
DocReadyFault | 0 | Ready Fault
DocPositionCompare | 1 | Position Compare
DocGeneralPurposeH | 8 | General Purpose H
DocGeneralPurposeG | 9 | General Purpose G
DocGeneralPurposeF | 10 | General Purpose F
DocGeneralPurposeE | 11 | General Purpose E
DocGeneralPurposeD | 12 | General Purpose D
DocGeneralPurposeC | 13 | General Purpose C
DocGeneralPurposeB | 14 | General Purpose B
DocGeneralPurposeA | 15 | General Purpose A
DocNoFunctionality | 255 | No functionality
See Also

Reference

EposCmd.Net Namespace


EHomingMethod Enumeration

EHomingMethod Enumeration EposCmd.Net
Homing method

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EHomingMethod
Public Enumeration EHomingMethod
public enum class EHomingMethod
type EHomingMethod
Members
Member name | Value | Description
HmActualPosition | 35 | Actual Position
HmNegativeLimitSwitch | 17 | Negative Limit Switch
HmNegativeLimitSwitchAndIndex | 1 | Negative Limit Switch and Index
HmPositiveLimitSwitch | 18 | Positive Limit Switch
HmPositiveLimitSwitchAndIndex | 2 | Positive Limit Switch and Index
HmHomeSwitchPositiveSpeed | 23 | Home Switch Positive Speed
HmHomeSwitchPositiveSpeedAndIndex | 7 | Home Switch Positive Speed and Index
HmHomeSwitchNegativeSpeed | 27 | Home Switch Negative Speed
HmHomeSwitchNegativeSpeedAndIndex | 11 | Home Switch Negative Speed and Index
HmCurrentThresholdPositiveSpeed | -3 | Current Threshold Positive Speed
HmCurrentThresholdPositiveSpeedAndIndex | -1 | Current Threshold Positive Speed and Index
HmCurrentThresholdNegativeSpeed | -4 | Current Threshold Negative Speed
HmCurrentThresholdNegativeSpeedAndIndex | -2 | Current Threshold Negative Speed and Index
HmIndexPositiveSpeed | 34 | Index Positive Speed
HmIndexNegativeSpeed | 33 | Index Negative Speed
See Also

Reference

EposCmd.Net Namespace


EMotorType Enumeration

EMotorType Enumeration EposCmd.Net
Kind of motor type

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EMotorType
Public Enumeration EMotorType
public enum class EMotorType
type EMotorType
Members
Member name | Value | Description
MtDcMotor | 1 | Brushed DC motor
MtEcSinusCommutatedMotor | 10 | EC motor sinus commutated
MtEcBlockCommutatedMotor | 11 | EC motor block commutated
See Also

Reference

EposCmd.Net Namespace


EOperationMode Enumeration

EOperationMode Enumeration EposCmd.Net
Kind of operation mode

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EOperationMode
Public Enumeration EOperationMode
public enum class EOperationMode
type EOperationMode
Members
Member name | Value | Description
OmdProfilePositionMode | 1 | Profile Position Mode
OmdProfileVelocityMode | 3 | Profile Velocity Mode
OmdHomingMode | 6 | Homing Mode
OmdInterpolatedPositionMode | 7 | Interpolated Position Mode
OmdCyclicSyncronicTorqueMode | 10 | Cyclic Synronic Torque Mode
OmdPositionMode | -1 | Position Mode
OmdVelocityMode | -2 | Velocity Mode
OmdCurrentMode | -3 | Current Mode
OmdMasterEncoderMode | -5 | Master Encoder Mode
OmdStepDirectionMode | -6 | Step Direction Mode
See Also

Reference

EposCmd.Net Namespace


EPositionCompareDirectionDependency Enumeration

EPositionCompareDirectionDependency Enumeration EposCmd.Net
Position compare direction dependency

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EPositionCompareDirectionDependency
Public Enumeration EPositionCompareDirectionDependency
public enum class EPositionCompareDirectionDependency
type EPositionCompareDirectionDependency
Members
Member name | Value | Description
PcdMotorDirectionNegative | 0 | Positions are compared only if actual motor direction is negative
PcdMotorDirectionPositive | 1 | Positions are compared only if actual motor direction is positive
PcdMotorDirectionBoth | 2 | Positions are compared regardless of the actual motor direction
See Also

Reference

EposCmd.Net Namespace


EPositionCompareIntervalMode Enumeration

EPositionCompareIntervalMode Enumeration EposCmd.Net
Position compare interval mode

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EPositionCompareIntervalMode
Public Enumeration EPositionCompareIntervalMode
public enum class EPositionCompareIntervalMode
type EPositionCompareIntervalMode
Members
Member name | Value | Description
PciNegativeDirToRefpos | 0 | Interval positions are set in negative direction relative to the position compare reference position
PciPositiveDirToRefpos | 1 | Interval positions are set in positive direction relative to the position compare reference position
PciBothDirToRefpos | 2 | Interval positions are set in positive and negative direction relative to the position compare reference position
See Also

Reference

EposCmd.Net Namespace


EPositionCompareOperationalMode Enumeration

EPositionCompareOperationalMode Enumeration EposCmd.Net
Position compare operational mode

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EPositionCompareOperationalMode
Public Enumeration EPositionCompareOperationalMode
public enum class EPositionCompareOperationalMode
type EPositionCompareOperationalMode
Members
Member name | Value | Description
PcoSinglePositionMode | 0 | Single position mode
PcoPositionSequenceMode | 1 | Position sequence mode
See Also

Reference

EposCmd.Net Namespace


EPositionMarkerEdgeType Enumeration

EPositionMarkerEdgeType Enumeration EposCmd.Net
Kind of position marker edge type

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EPositionMarkerEdgeType
Public Enumeration EPositionMarkerEdgeType
public enum class EPositionMarkerEdgeType
type EPositionMarkerEdgeType
Members
Member name | Value | Description
PetBothEdges | 0 | Both edges
PetRisingEdge | 1 | Rising edge
PetFallingEdge | 2 | Falling edge
See Also

Reference

EposCmd.Net Namespace


EPositionMarkerMode Enumeration

EPositionMarkerMode Enumeration EposCmd.Net
Position marker-capturing mode

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EPositionMarkerMode
Public Enumeration EPositionMarkerMode
public enum class EPositionMarkerMode
type EPositionMarkerMode
Members
Member name | Value | Description
PmContinuous | 0 | Continuous
PmSingle | 1 | Single
PmMultiple | 2 | Multiple
See Also

Reference

EposCmd.Net Namespace


ErrorHandling Class

ErrorHandling Class EposCmd.Net
This class contains the error code information and is the base class for every EposCmd class
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.NetDeviceManager

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorHandling : IDisposable
Public Class ErrorHandling
    Implements IDisposable
public ref class ErrorHandling : IDisposable
type ErrorHandling =
    class
        interface IDisposable
    end

The ErrorHandling type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed.
Top
See Also

Reference

EposCmd.Net Namespace


ErrorHandling Properties

ErrorHandling Properties EposCmd.Net

The ErrorHandling type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed.
Top
See Also

Reference

ErrorHandling Class
EposCmd.Net Namespace


ErrorHandling.LastError Property

ErrorHandlingLastError Property EposCmd.Net
Use this propery to get the error status for the last operation that failed.

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint LastError { get; set; }
Public Property LastError As UInteger
    Get
    Set
public:
property unsigned int LastError {
    unsigned int get ();
    void set (unsigned int value);
}
member LastError : uint32 with get, set

Property Value

Type: UInt32
The last error.
Examples
Copy
// DeviceManager instance should be created in the main application thread
using (DeviceManager connector = new DeviceManager("EPOS","MAXON_RS232", "RS232", "COM1"))
{
    try
    {
        //set connection properties
        //connector.Baudrate = 1000000; /*USB*/
        connector.Baudrate = 38400;
        connector.Timeout = 500;

        //create new epos device,
        Device epos1 = connector.CreateDevice(1 /*node id*/);
        //to make the code more compact we can make the helper variable out of the
        //internal Device properties
        StateMachine sm = epos1.Operation.StateMachine;

        //clear errors
        sm.ClearFault();

        //each method have the access to the lastError property
        //this way you can additionally check the error code of the function call
        Console.WriteLine("Last error:" + sm.LastError);
    }
    catch (DeviceException e)
    {
        Console.WriteLine(e.Message + e.ErrorCode);
    }
  }
  //important notice
  //it's redundant to call Dispose in this example, but in most cases we recommend to call "Dispose" method
  //before application close to have control when the EposCmd(64).dll will be unloaded.
  //"Dispose" method should be called in the main application thread.
  connector.Dispose();
}
catch (DeviceException e)
{
    //DeviceException contains the information about the error code from the device
    //message usually contains the information about the internal function rapporting the problem
    Console.WriteLine(e.Message + e.ErrorCode);
}
catch (Exception e)
{
    Console.WriteLine(e.Message);
}
See Also

Reference

ErrorHandling Class
EposCmd.Net Namespace


ESensorType Enumeration

ESensorType Enumeration EposCmd.Net
Kind of position sensor type

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ESensorType
Public Enumeration ESensorType
public enum class ESensorType
type ESensorType
Members
Member name | Value | Description
StUnknown | 0 | Unknown sensor (undefined)
StNone | 0 | No sensor
StIncEncoder3Channel | 1 | Incremental Encoder 1 with index (3-channel)
StIncEncoder2Channel | 2 | Incremental Encoder 1 without index (2-channel)
StHallSensors | 3 | Hall Sensors
StSsiAbsEncoderBinary | 4 | SSI Encoder binary coded
StSsiAbsEncoderGrey | 5 | SSI Encoder Grey coded
See Also

Reference

EposCmd.Net Namespace


EStates Enumeration

EStates Enumeration EposCmd.Net
Controller state

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EStates
Public Enumeration EStates
public enum class EStates
type EStates
Members
Member name | Value | Description
StDisabled | 0 | Disabled State
StEnabled | 1 | Enabled State
StQuickStop | 2 | Quickstop State
StFault | 3 | Fault State
See Also

Reference

EposCmd.Net Namespace


EVelocityDimension Enumeration

EVelocityDimension Enumeration EposCmd.Net
Velocity dimension index

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EVelocityDimension
Public Enumeration EVelocityDimension
public enum class EVelocityDimension
type EVelocityDimension
Members
Member name | Value | Description
VdRpm | 164 | rpm
See Also

Reference

EposCmd.Net Namespace


EVelocityNotation Enumeration

EVelocityNotation Enumeration EposCmd.Net
Velocity notation index

Namespace: EposCmd.Net
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum EVelocityNotation
Public Enumeration EVelocityNotation
public enum class EVelocityNotation
type EVelocityNotation
Members
Member name | Value | Description
VnStandard | 0 | Standard
VnDeci | -1 | Deci
VnCenti | -2 | Centi
VnMilli | -3 | Milli
See Also

Reference

EposCmd.Net Namespace


EposCmd.Net.DeviceCmdSet.Configuration Namespace

EposCmd.Net.DeviceCmdSet.Configuration Namespace EposCmd.Net
Classes
 | Class | Description
Public class | Compatibility | Compatibility / obsolute methods
Public class | Configuration | Configuration methods
Public class | ConfigurationAdvanced | Advanced configuration methods
Public class | InputOutput | Input-Output methods
Public class | Motor | Motor related methods
Public class | Regulator | Regulator profile
Public class | Safety | Safety methods
Public class | Sensor | Sensor related methods
Public class | Units | Velocity Units methods


Compatibility Class

Compatibility Class EposCmd.Net
Compatibility / obsolute methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationCompatibility

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Compatibility : DeviceCommandGroup
Public Class Compatibility
    Inherits DeviceCommandGroup
public ref class Compatibility : public DeviceCommandGroup
type Compatibility =
    class
        inherit DeviceCommandGroup
    end

The Compatibility type exposes the following members.

Constructors
 | Name | Description
Public method | Compatibility | Initializes a new instance of the Compatibility class.
Top
Methods
 | Name | Description
Public method | GetEncoderParameter | With function "GetEncoderParameter" it is possible to read all encoder parameters.
Public method | GetMotorParameter | With function "GetMotorParameter" it is possible to read all motor parameters.
Public method | SetEncoderParameter | With function "SetEncoderParameter" it is possible to write all encoder parameters.
Public method | SetMotorParameter | With function "SetMotorParameter" it is possible to write all motor parameters.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility Constructor

Compatibility Constructor EposCmd.Net
Initializes a new instance of the Compatibility class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Compatibility(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Compatibility(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Compatibility

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility Methods

Compatibility Methods EposCmd.Net

The Compatibility type exposes the following members.

Methods
 | Name | Description
Public method | GetEncoderParameter | With function "GetEncoderParameter" it is possible to read all encoder parameters.
Public method | GetMotorParameter | With function "GetMotorParameter" it is possible to read all motor parameters.
Public method | SetEncoderParameter | With function "SetEncoderParameter" it is possible to write all encoder parameters.
Public method | SetMotorParameter | With function "SetMotorParameter" it is possible to write all motor parameters.
Top
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility.GetEncoderParameter Method

CompatibilityGetEncoderParameter Method EposCmd.Net
With function "GetEncoderParameter" it is possible to read all encoder parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetEncoderParameter(
    ref ushort counts,
    ref ESensorType positionSensorType
)
Public Sub GetEncoderParameter (
    ByRef counts As UShort,
    ByRef positionSensorType As ESensorType
)
public:
void GetEncoderParameter(
    unsigned short% counts,
    ESensorType% positionSensorType
)
member GetEncoderParameter :
        counts : uint16 byref *
        positionSensorType : ESensorType byref -> unit

Parameters

counts
Type: SystemUInt16
Incremental encoder counts [pulse per turn]
positionSensorType
Type: EposCmd.NetESensorType
Position sensor type

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility.GetMotorParameter Method

CompatibilityGetMotorParameter Method EposCmd.Net
With function "GetMotorParameter" it is possible to read all motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetMotorParameter(
    ref EMotorType motorType,
    ref ushort continuousCurrent,
    ref ushort peakCurrent,
    ref byte polePair,
    ref ushort thermalTimeConstant
)
Public Sub GetMotorParameter (
    ByRef motorType As EMotorType,
    ByRef continuousCurrent As UShort,
    ByRef peakCurrent As UShort,
    ByRef polePair As Byte,
    ByRef thermalTimeConstant As UShort
)
public:
void GetMotorParameter(
    EMotorType% motorType,
    unsigned short% continuousCurrent,
    unsigned short% peakCurrent,
    unsigned char% polePair,
    unsigned short% thermalTimeConstant
)
member GetMotorParameter :
        motorType : EMotorType byref *
        continuousCurrent : uint16 byref *
        peakCurrent : uint16 byref *
        polePair : byte byref *
        thermalTimeConstant : uint16 byref -> unit

Parameters

motorType
Type: EposCmd.NetEMotorType
Kind of motor
continuousCurrent
Type: SystemUInt16
Maximal continuous current
peakCurrent
Type: SystemUInt16
Maximal peak current
polePair
Type: SystemByte
Number of pole pairs
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility.SetEncoderParameter Method

CompatibilitySetEncoderParameter Method EposCmd.Net
With function "SetEncoderParameter" it is possible to write all encoder parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEncoderParameter(
    ushort counts,
    ESensorType positionSensorType
)
Public Sub SetEncoderParameter (
    counts As UShort,
    positionSensorType As ESensorType
)
public:
void SetEncoderParameter(
    unsigned short counts,
    ESensorType positionSensorType
)
member SetEncoderParameter :
        counts : uint16 *
        positionSensorType : ESensorType -> unit

Parameters

counts
Type: SystemUInt16
Incremental Encoder counts [pulse per turn]
positionSensorType
Type: EposCmd.NetESensorType
Position Sensor Type

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility.SetMotorParameter Method

CompatibilitySetMotorParameter Method EposCmd.Net
With function "SetMotorParameter" it is possible to write all motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMotorParameter(
    EMotorType motorType,
    ushort continuousCurrent,
    ushort peakCurrent,
    byte polePair,
    ushort thermalTimeConstant
)
Public Sub SetMotorParameter (
    motorType As EMotorType,
    continuousCurrent As UShort,
    peakCurrent As UShort,
    polePair As Byte,
    thermalTimeConstant As UShort
)
public:
void SetMotorParameter(
    EMotorType motorType,
    unsigned short continuousCurrent,
    unsigned short peakCurrent,
    unsigned char polePair,
    unsigned short thermalTimeConstant
)
member SetMotorParameter :
        motorType : EMotorType *
        continuousCurrent : uint16 *
        peakCurrent : uint16 *
        polePair : byte *
        thermalTimeConstant : uint16 -> unit

Parameters

motorType
Type: EposCmd.NetEMotorType
Kind of motor
continuousCurrent
Type: SystemUInt16
Maximal continuous current
peakCurrent
Type: SystemUInt16
Maximal peak current
polePair
Type: SystemByte
Number of pole pairs
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Compatibility Properties

Compatibility Properties EposCmd.Net

The Compatibility type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Compatibility Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration Class

Configuration Class EposCmd.Net
Configuration methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationConfiguration

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Configuration : DeviceCommandGroup
Public Class Configuration
    Inherits DeviceCommandGroup
public ref class Configuration : public DeviceCommandGroup
type Configuration =
    class
        inherit DeviceCommandGroup
    end

The Configuration type exposes the following members.

Constructors
 | Name | Description
Public method | Configuration | Initializes a new instance of the Configuration class.
Top
Methods
 | Name | Description
Public method | ExportParameter | "ExportParameter" reads all parameters of the device and writes this into the file.
Public method | GetObject | The function "GetObject" reads an object value at the given index and sub-index from object dictionary.
Public method | ImportParameter | "ImportParameter" writes parameters from a file to the device.
Public method | Restore | The function "Restore" restores all default parameters.
Public method | SetObject | The function "SetObject" writes an object value at the given index and sub-index from object dictionary.
Public method | Store | The function "Store" stores all parameters.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration Constructor

Configuration Constructor EposCmd.Net
Initializes a new instance of the Configuration class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Configuration(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Configuration(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Configuration

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration Methods

Configuration Methods EposCmd.Net

The Configuration type exposes the following members.

Methods
 | Name | Description
Public method | ExportParameter | "ExportParameter" reads all parameters of the device and writes this into the file.
Public method | GetObject | The function "GetObject" reads an object value at the given index and sub-index from object dictionary.
Public method | ImportParameter | "ImportParameter" writes parameters from a file to the device.
Public method | Restore | The function "Restore" restores all default parameters.
Public method | SetObject | The function "SetObject" writes an object value at the given index and sub-index from object dictionary.
Public method | Store | The function "Store" stores all parameters.
Top
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.ExportParameter Method

ConfigurationExportParameter Method EposCmd.Net
"ExportParameter" reads all parameters of the device and writes this into the file.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ExportParameter(
    string parameterFileName,
    string firmwareFileName,
    string userId,
    string comment,
    int showDlg,
    int showMsg
)
Public Sub ExportParameter (
    parameterFileName As String,
    firmwareFileName As String,
    userId As String,
    comment As String,
    showDlg As Integer,
    showMsg As Integer
)
public:
void ExportParameter(
    String^ parameterFileName,
    String^ firmwareFileName,
    String^ userId,
    String^ comment,
    int showDlg,
    int showMsg
)
member ExportParameter :
        parameterFileName : string *
        firmwareFileName : string *
        userId : string *
        comment : string *
        showDlg : int *
        showMsg : int -> unit

Parameters

parameterFileName
Type: SystemString
Full path of parameter file for export
firmwareFileName
Type: SystemString
Full path of firmware file of the connected device
userId
Type: SystemString
User name
comment
Type: SystemString
Comment.
showDlg
Type: SystemInt32
Dialog is shown
showMsg
Type: SystemInt32
Message box are activated

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.GetObject Method

ConfigurationGetObject Method EposCmd.Net
The function "GetObject" reads an object value at the given index and sub-index from object dictionary.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetObject(
    ushort objectIndex,
    byte objectSubindex,
    byte[] data,
    uint nbOfBytesToRead,
    ref uint nbOfBytesRead
)
Public Sub GetObject (
    objectIndex As UShort,
    objectSubindex As Byte,
    data As Byte(),
    nbOfBytesToRead As UInteger,
    ByRef nbOfBytesRead As UInteger
)
public:
void GetObject(
    unsigned short objectIndex,
    unsigned char objectSubindex,
    array<unsigned char>^ data,
    unsigned int nbOfBytesToRead,
    unsigned int% nbOfBytesRead
)
member GetObject :
        objectIndex : uint16 *
        objectSubindex : byte *
        data : byte[] *
        nbOfBytesToRead : uint32 *
        nbOfBytesRead : uint32 byref -> unit

Parameters

objectIndex
Type: SystemUInt16
Object index
objectSubindex
Type: SystemByte
Object sub-index
data
Type: SystemByte
Object data
nbOfBytesToRead
Type: SystemUInt32
Object length to read (number of bytes)
nbOfBytesRead
Type: SystemUInt32
Object length read (number of bytes)

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.ImportParameter Method

ConfigurationImportParameter Method EposCmd.Net
"ImportParameter" writes parameters from a file to the device.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ImportParameter(
    string parameterFileName,
    bool showDlg,
    bool showMsg
)
Public Sub ImportParameter (
    parameterFileName As String,
    showDlg As Boolean,
    showMsg As Boolean
)
public:
void ImportParameter(
    String^ parameterFileName,
    bool showDlg,
    bool showMsg
)
member ImportParameter :
        parameterFileName : string *
        showDlg : bool *
        showMsg : bool -> unit

Parameters

parameterFileName
Type: SystemString
Full path of parameter file for import
showDlg
Type: SystemBoolean
Dialog is shown
showMsg
Type: SystemBoolean
Message box are activated

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.Restore Method

ConfigurationRestore Method EposCmd.Net
The function "Restore" restores all default parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Restore()
Public Sub Restore
public:
void Restore()
member Restore : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.SetObject Method

ConfigurationSetObject Method EposCmd.Net
The function "SetObject" writes an object value at the given index and sub-index from object dictionary.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetObject(
    ushort objectIndex,
    byte objectSubindex,
    byte[] data,
    uint nbOfBytesToWrite,
    ref uint nbOfBytesWritten
)
Public Sub SetObject (
    objectIndex As UShort,
    objectSubindex As Byte,
    data As Byte(),
    nbOfBytesToWrite As UInteger,
    ByRef nbOfBytesWritten As UInteger
)
public:
void SetObject(
    unsigned short objectIndex,
    unsigned char objectSubindex,
    array<unsigned char>^ data,
    unsigned int nbOfBytesToWrite,
    unsigned int% nbOfBytesWritten
)
member SetObject :
        objectIndex : uint16 *
        objectSubindex : byte *
        data : byte[] *
        nbOfBytesToWrite : uint32 *
        nbOfBytesWritten : uint32 byref -> unit

Parameters

objectIndex
Type: SystemUInt16
Object index
objectSubindex
Type: SystemByte
Object sub-index
data
Type: SystemByte
Object data
nbOfBytesToWrite
Type: SystemUInt32
Object length to write (number of bytes)
nbOfBytesWritten
Type: SystemUInt32
Object length written (number of bytes)

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.Store Method

ConfigurationStore Method EposCmd.Net
The function "Store" stores all parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Store()
Public Sub Store
public:
void Store()
member Store : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration Properties

Configuration Properties EposCmd.Net

The Configuration type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Configuration.Advanced Property

ConfigurationAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationAdvanced Advanced { get; }
Public ReadOnly Property Advanced As ConfigurationAdvanced
    Get
public:
property ConfigurationAdvanced^ Advanced {
    ConfigurationAdvanced^ get ();
}
member Advanced : ConfigurationAdvanced with get

Property Value

Type: ConfigurationAdvanced
The advanced.
See Also

Reference

Configuration Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced Class

ConfigurationAdvanced Class EposCmd.Net
Advanced configuration methods
Inheritance Hierarchy
SystemObject
EposCmd.Net.DeviceCmdSet.ConfigurationConfigurationAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ConfigurationAdvanced
Public Class ConfigurationAdvanced
public ref class ConfigurationAdvanced
type ConfigurationAdvanced =  class end

The ConfigurationAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationAdvanced | Initializes a new instance of the AdvancedConfiguration class.
Top
Properties
 | Name | Description
Public property | Compatibility | Gets the compatibility.
Public property | InputOutput | Gets the io.
Public property | Motor | Gets the motor.
Public property | Regulator | Gets the regulator.
Public property | Safety | Gets the safety.
Public property | Sensor | Gets the sensor.
Public property | Units | Gets the units.
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced Constructor

ConfigurationAdvanced Constructor EposCmd.Net
Initializes a new instance of the AdvancedConfiguration class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
ConfigurationAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> ConfigurationAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced Properties

ConfigurationAdvanced Properties EposCmd.Net

The ConfigurationAdvanced type exposes the following members.

Properties
 | Name | Description
Public property | Compatibility | Gets the compatibility.
Public property | InputOutput | Gets the io.
Public property | Motor | Gets the motor.
Public property | Regulator | Gets the regulator.
Public property | Safety | Gets the safety.
Public property | Sensor | Gets the sensor.
Public property | Units | Gets the units.
Top
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Compatibility Property

ConfigurationAdvancedCompatibility Property EposCmd.Net
Gets the compatibility.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Compatibility Compatibility { get; }
Public ReadOnly Property Compatibility As Compatibility
    Get
public:
property Compatibility^ Compatibility {
    Compatibility^ get ();
}
member Compatibility : Compatibility with get

Property Value

Type: Compatibility
The compatibility.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.InputOutput Property

ConfigurationAdvancedInputOutput Property EposCmd.Net
Gets the io.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InputOutput InputOutput { get; }
Public ReadOnly Property InputOutput As InputOutput
    Get
public:
property InputOutput^ InputOutput {
    InputOutput^ get ();
}
member InputOutput : InputOutput with get

Property Value

Type: InputOutput
The io.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Motor Property

ConfigurationAdvancedMotor Property EposCmd.Net
Gets the motor.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Motor Motor { get; }
Public ReadOnly Property Motor As Motor
    Get
public:
property Motor^ Motor {
    Motor^ get ();
}
member Motor : Motor with get

Property Value

Type: Motor
The motor.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Regulator Property

ConfigurationAdvancedRegulator Property EposCmd.Net
Gets the regulator.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Regulator Regulator { get; }
Public ReadOnly Property Regulator As Regulator
    Get
public:
property Regulator^ Regulator {
    Regulator^ get ();
}
member Regulator : Regulator with get

Property Value

Type: Regulator
The regulator.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Safety Property

ConfigurationAdvancedSafety Property EposCmd.Net
Gets the safety.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Safety Safety { get; }
Public ReadOnly Property Safety As Safety
    Get
public:
property Safety^ Safety {
    Safety^ get ();
}
member Safety : Safety with get

Property Value

Type: Safety
The safety.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Sensor Property

ConfigurationAdvancedSensor Property EposCmd.Net
Gets the sensor.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Sensor Sensor { get; }
Public ReadOnly Property Sensor As Sensor
    Get
public:
property Sensor^ Sensor {
    Sensor^ get ();
}
member Sensor : Sensor with get

Property Value

Type: Sensor
The sensor.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


ConfigurationAdvanced.Units Property

ConfigurationAdvancedUnits Property EposCmd.Net
Gets the units.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Units Units { get; }
Public ReadOnly Property Units As Units
    Get
public:
property Units^ Units {
    Units^ get ();
}
member Units : Units with get

Property Value

Type: Units
Units.
See Also

Reference

ConfigurationAdvanced Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput Class

InputOutput Class EposCmd.Net
Input-Output methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationInputOutput

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class InputOutput : DeviceCommandGroup
Public Class InputOutput
    Inherits DeviceCommandGroup
public ref class InputOutput : public DeviceCommandGroup
type InputOutput =
    class
        inherit DeviceCommandGroup
    end

The InputOutput type exposes the following members.

Constructors
 | Name | Description
Public method | InputOutput | Initializes a new instance of the InputOutput class.
Top
Methods
 | Name | Description
Public method | AnalogInputConfiguration | AnalogInputConfiguration sets parameter for an analog input.
Public method | DigitalInputConfiguration | DigitalInputConfiguration sets the parameter for one digital input.
Public method | DigitalOutputConfiguration | DigitalOutputConfiguration sets parameter for one digital output.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput Constructor

InputOutput Constructor EposCmd.Net
Initializes a new instance of the InputOutput class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InputOutput(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
InputOutput(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> InputOutput

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput Methods

InputOutput Methods EposCmd.Net

The InputOutput type exposes the following members.

Methods
 | Name | Description
Public method | AnalogInputConfiguration | AnalogInputConfiguration sets parameter for an analog input.
Public method | DigitalInputConfiguration | DigitalInputConfiguration sets the parameter for one digital input.
Public method | DigitalOutputConfiguration | DigitalOutputConfiguration sets parameter for one digital output.
Top
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput.AnalogInputConfiguration Method

InputOutputAnalogInputConfiguration Method EposCmd.Net
AnalogInputConfiguration sets parameter for an analog input.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AnalogInputConfiguration(
    ushort analogInputNb,
    EAnalogInputConfiguration configuration,
    int executionMask
)
Public Sub AnalogInputConfiguration (
    analogInputNb As UShort,
    configuration As EAnalogInputConfiguration,
    executionMask As Integer
)
public:
void AnalogInputConfiguration(
    unsigned short analogInputNb,
    EAnalogInputConfiguration configuration,
    int executionMask
)
member AnalogInputConfiguration :
        analogInputNb : uint16 *
        configuration : EAnalogInputConfiguration *
        executionMask : int -> unit

Parameters

analogInputNb
Type: SystemUInt16
Number of analog input (object subindex)
configuration
Type: EposCmd.NetEAnalogInputConfiguration
Configures the functionality assigned to the analog input (bit number) => See Firmware Specification
executionMask
Type: SystemInt32
1: Register will be modified
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput.DigitalInputConfiguration Method

InputOutputDigitalInputConfiguration Method EposCmd.Net
DigitalInputConfiguration sets the parameter for one digital input.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DigitalInputConfiguration(
    ushort digitalInputNb,
    EDigitalInputConfiguration configuration,
    int mask,
    int polarity,
    int executionMask
)
Public Sub DigitalInputConfiguration (
    digitalInputNb As UShort,
    configuration As EDigitalInputConfiguration,
    mask As Integer,
    polarity As Integer,
    executionMask As Integer
)
public:
void DigitalInputConfiguration(
    unsigned short digitalInputNb,
    EDigitalInputConfiguration configuration,
    int mask,
    int polarity,
    int executionMask
)
member DigitalInputConfiguration :
        digitalInputNb : uint16 *
        configuration : EDigitalInputConfiguration *
        mask : int *
        polarity : int *
        executionMask : int -> unit

Parameters

digitalInputNb
Type: SystemUInt16
Number of digital input (object subindex)
configuration
Type: EposCmd.NetEDigitalInputConfiguration
Configures the functionality assigned to the digital input (bit number) => See Firmware Specification
mask
Type: SystemInt32
1: Functionality state will be displayed 0: not displayed
polarity
Type: SystemInt32
1: Low active 0: High active
executionMask
Type: SystemInt32
1: Set the error routine. Only for positive and negative switch.
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput.DigitalOutputConfiguration Method

InputOutputDigitalOutputConfiguration Method EposCmd.Net
DigitalOutputConfiguration sets parameter for one digital output.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DigitalOutputConfiguration(
    ushort digitalOutputNb,
    EDigitalOutputConfiguration configuration,
    int state,
    int mask,
    int polarity
)
Public Sub DigitalOutputConfiguration (
    digitalOutputNb As UShort,
    configuration As EDigitalOutputConfiguration,
    state As Integer,
    mask As Integer,
    polarity As Integer
)
public:
void DigitalOutputConfiguration(
    unsigned short digitalOutputNb,
    EDigitalOutputConfiguration configuration,
    int state,
    int mask,
    int polarity
)
member DigitalOutputConfiguration :
        digitalOutputNb : uint16 *
        configuration : EDigitalOutputConfiguration *
        state : int *
        mask : int *
        polarity : int -> unit

Parameters

digitalOutputNb
Type: SystemUInt16
Number of digital output (object subindex)
configuration
Type: EposCmd.NetEDigitalOutputConfiguration
Configures the functionality assigned to the digital output (bit number) => See Firmware Specification
state
Type: SystemInt32
State of digital output
mask
Type: SystemInt32
1: Register will be modified
polarity
Type: SystemInt32
1: Output will be inverted
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


InputOutput Properties

InputOutput Properties EposCmd.Net

The InputOutput type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor Class

Motor Class EposCmd.Net
Motor related methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationMotor

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Motor : DeviceCommandGroup
Public Class Motor
    Inherits DeviceCommandGroup
public ref class Motor : public DeviceCommandGroup
type Motor =
    class
        inherit DeviceCommandGroup
    end

The Motor type exposes the following members.

Constructors
 | Name | Description
Public method | Motor | Initializes a new instance of the Motor class.
Top
Methods
 | Name | Description
Public method | GetDcMotorParameter | With function "GetDcMotorParameter" it is possible to read all DC motor parameters.
Public method | GetEcMotorParameter | With function "GetEcMotorParameter" it is possible to read all EC motor parameters.
Public method | GetMotorType | With function "GetMotorType" it is possible to read the motor type.
Public method | SetDcMotorParameter | With function "SetDcMotorParameter" it is possible to write all DC motor parameters.
Public method | SetEcMotorParameter | With function "SetEcMotorParameter" it is possible to write all EC motor parameters.
Public method | SetMotorType | With function "SetMotorType" the motor type is written.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor Constructor

Motor Constructor EposCmd.Net
Initializes a new instance of the Motor class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Motor(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Motor(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Motor

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor Methods

Motor Methods EposCmd.Net

The Motor type exposes the following members.

Methods
 | Name | Description
Public method | GetDcMotorParameter | With function "GetDcMotorParameter" it is possible to read all DC motor parameters.
Public method | GetEcMotorParameter | With function "GetEcMotorParameter" it is possible to read all EC motor parameters.
Public method | GetMotorType | With function "GetMotorType" it is possible to read the motor type.
Public method | SetDcMotorParameter | With function "SetDcMotorParameter" it is possible to write all DC motor parameters.
Public method | SetEcMotorParameter | With function "SetEcMotorParameter" it is possible to write all EC motor parameters.
Public method | SetMotorType | With function "SetMotorType" the motor type is written.
Top
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.GetDcMotorParameter Method

MotorGetDcMotorParameter Method EposCmd.Net
With function "GetDcMotorParameter" it is possible to read all DC motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetDcMotorParameter(
    ref ushort nominalCurrent,
    ref ushort maxOutputCurrent,
    ref ushort thermalTimeConstant
)
Public Sub GetDcMotorParameter (
    ByRef nominalCurrent As UShort,
    ByRef maxOutputCurrent As UShort,
    ByRef thermalTimeConstant As UShort
)
public:
void GetDcMotorParameter(
    unsigned short% nominalCurrent,
    unsigned short% maxOutputCurrent,
    unsigned short% thermalTimeConstant
)
member GetDcMotorParameter :
        nominalCurrent : uint16 byref *
        maxOutputCurrent : uint16 byref *
        thermalTimeConstant : uint16 byref -> unit

Parameters

nominalCurrent
Type: SystemUInt16
Maximal continuous current
maxOutputCurrent
Type: SystemUInt16
Maximal peak current
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.GetEcMotorParameter Method

MotorGetEcMotorParameter Method EposCmd.Net
With function "GetEcMotorParameter" it is possible to read all EC motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetEcMotorParameter(
    ref ushort nominalCurrent,
    ref ushort maxOutputCurrent,
    ref ushort thermalTimeConstant,
    ref byte nbOfPolePairs
)
Public Sub GetEcMotorParameter (
    ByRef nominalCurrent As UShort,
    ByRef maxOutputCurrent As UShort,
    ByRef thermalTimeConstant As UShort,
    ByRef nbOfPolePairs As Byte
)
public:
void GetEcMotorParameter(
    unsigned short% nominalCurrent,
    unsigned short% maxOutputCurrent,
    unsigned short% thermalTimeConstant,
    unsigned char% nbOfPolePairs
)
member GetEcMotorParameter :
        nominalCurrent : uint16 byref *
        maxOutputCurrent : uint16 byref *
        thermalTimeConstant : uint16 byref *
        nbOfPolePairs : byte byref -> unit

Parameters

nominalCurrent
Type: SystemUInt16
Maximal continuous current
maxOutputCurrent
Type: SystemUInt16
Maximal peak current
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding
nbOfPolePairs
Type: SystemByte
Number of pole pairs

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.GetMotorType Method

MotorGetMotorType Method EposCmd.Net
With function "GetMotorType" it is possible to read the motor type.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetMotorType(
    ref EMotorType motorType
)
Public Sub GetMotorType (
    ByRef motorType As EMotorType
)
public:
void GetMotorType(
    EMotorType% motorType
)
member GetMotorType :
        motorType : EMotorType byref -> unit

Parameters

motorType
Type: EposCmd.NetEMotorType
Kind of motor

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.SetDcMotorParameter Method

MotorSetDcMotorParameter Method EposCmd.Net
With function "SetDcMotorParameter" it is possible to write all DC motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDcMotorParameter(
    ushort nominalCurrent,
    ushort maxOutputCurrent,
    ushort thermalTimeConstant
)
Public Sub SetDcMotorParameter (
    nominalCurrent As UShort,
    maxOutputCurrent As UShort,
    thermalTimeConstant As UShort
)
public:
void SetDcMotorParameter(
    unsigned short nominalCurrent,
    unsigned short maxOutputCurrent,
    unsigned short thermalTimeConstant
)
member SetDcMotorParameter :
        nominalCurrent : uint16 *
        maxOutputCurrent : uint16 *
        thermalTimeConstant : uint16 -> unit

Parameters

nominalCurrent
Type: SystemUInt16
Maximal continuous current
maxOutputCurrent
Type: SystemUInt16
Maximal peak current
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.SetEcMotorParameter Method

MotorSetEcMotorParameter Method EposCmd.Net
With function "SetEcMotorParameter" it is possible to write all EC motor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEcMotorParameter(
    ushort nominalCurrent,
    ushort maxOutputCurrent,
    ushort thermalTimeConstant,
    byte nbOfPolePairs
)
Public Sub SetEcMotorParameter (
    nominalCurrent As UShort,
    maxOutputCurrent As UShort,
    thermalTimeConstant As UShort,
    nbOfPolePairs As Byte
)
public:
void SetEcMotorParameter(
    unsigned short nominalCurrent,
    unsigned short maxOutputCurrent,
    unsigned short thermalTimeConstant,
    unsigned char nbOfPolePairs
)
member SetEcMotorParameter :
        nominalCurrent : uint16 *
        maxOutputCurrent : uint16 *
        thermalTimeConstant : uint16 *
        nbOfPolePairs : byte -> unit

Parameters

nominalCurrent
Type: SystemUInt16
Maximal continuous current
maxOutputCurrent
Type: SystemUInt16
Maximal peak current
thermalTimeConstant
Type: SystemUInt16
Thermal time constant winding
nbOfPolePairs
Type: SystemByte
Number of pole pairs

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor.SetMotorType Method

MotorSetMotorType Method EposCmd.Net
With function "SetMotorType" the motor type is written.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMotorType(
    EMotorType motorType
)
Public Sub SetMotorType (
    motorType As EMotorType
)
public:
void SetMotorType(
    EMotorType motorType
)
member SetMotorType :
        motorType : EMotorType -> unit

Parameters

motorType
Type: EposCmd.NetEMotorType
Kind of motor

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Motor Properties

Motor Properties EposCmd.Net

The Motor type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Motor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator Class

Regulator Class EposCmd.Net
Regulator profile
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationRegulator

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Regulator : DeviceCommandGroup
Public Class Regulator
    Inherits DeviceCommandGroup
public ref class Regulator : public DeviceCommandGroup
type Regulator =
    class
        inherit DeviceCommandGroup
    end

The Regulator type exposes the following members.

Constructors
 | Name | Description
Public method | Regulator | Initializes a new instance of the Regulator class.
Top
Methods
 | Name | Description
Public method | GetCurrentRegulatorGain | With function "GetCurrentRegulatorGain" it is possible to read all current regulator gains.
Public method | GetPositionRegulatorFeedForward | "GetPositionRegulatorFeedForward" reads parameter for position regulation feed forward.
Public method | GetPositionRegulatorGain | GetPositionRegulatorGain reads all position regulator gains.
Public method | GetVelocityRegulatorFeedForward | "GetVelocityRegulatorFeedForward" reads parameter for velocity regulation feed forward.
Public method | GetVelocityRegulatorGain | With function "GetVelocityRegulatorGain" it is possible to read all velocity regulator gains.
Public method | SetCurrentRegulatorGain | SetCurrentRegulatorGain writes all current regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Public method | SetPositionRegulatorFeedForward | SetPositionRegulatorFeedForward writes parameters for position regulation with feed forward.
Public method | SetPositionRegulatorGain | SetPositionRegulatorGain writes all position regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Public method | SetVelocityRegulatorFeedForward | SetVelocityRegulatorFeedForward writes parameters for velocity regulation with feed forward.
Public method | SetVelocityRegulatorGain | SetVelocityRegulatorGain writes all velocity regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator Constructor

Regulator Constructor EposCmd.Net
Initializes a new instance of the Regulator class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Regulator(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Regulator(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Regulator

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator Methods

Regulator Methods EposCmd.Net

The Regulator type exposes the following members.

Methods
 | Name | Description
Public method | GetCurrentRegulatorGain | With function "GetCurrentRegulatorGain" it is possible to read all current regulator gains.
Public method | GetPositionRegulatorFeedForward | "GetPositionRegulatorFeedForward" reads parameter for position regulation feed forward.
Public method | GetPositionRegulatorGain | GetPositionRegulatorGain reads all position regulator gains.
Public method | GetVelocityRegulatorFeedForward | "GetVelocityRegulatorFeedForward" reads parameter for velocity regulation feed forward.
Public method | GetVelocityRegulatorGain | With function "GetVelocityRegulatorGain" it is possible to read all velocity regulator gains.
Public method | SetCurrentRegulatorGain | SetCurrentRegulatorGain writes all current regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Public method | SetPositionRegulatorFeedForward | SetPositionRegulatorFeedForward writes parameters for position regulation with feed forward.
Public method | SetPositionRegulatorGain | SetPositionRegulatorGain writes all position regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Public method | SetVelocityRegulatorFeedForward | SetVelocityRegulatorFeedForward writes parameters for velocity regulation with feed forward.
Public method | SetVelocityRegulatorGain | SetVelocityRegulatorGain writes all velocity regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».
Top
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.GetCurrentRegulatorGain Method

RegulatorGetCurrentRegulatorGain Method EposCmd.Net
With function "GetCurrentRegulatorGain" it is possible to read all current regulator gains.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetCurrentRegulatorGain(
    ref ushort p,
    ref ushort i
)
Public Sub GetCurrentRegulatorGain (
    ByRef p As UShort,
    ByRef i As UShort
)
public:
void GetCurrentRegulatorGain(
    unsigned short% p,
    unsigned short% i
)
member GetCurrentRegulatorGain :
        p : uint16 byref *
        i : uint16 byref -> unit

Parameters

p
Type: SystemUInt16
Current regulator P-Gain
i
Type: SystemUInt16
Current regulator I-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.GetPositionRegulatorFeedForward Method

RegulatorGetPositionRegulatorFeedForward Method EposCmd.Net
"GetPositionRegulatorFeedForward" reads parameter for position regulation feed forward.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionRegulatorFeedForward(
    ref ushort velocityFeedForward,
    ref ushort accelerationFeedForward
)
Public Sub GetPositionRegulatorFeedForward (
    ByRef velocityFeedForward As UShort,
    ByRef accelerationFeedForward As UShort
)
public:
void GetPositionRegulatorFeedForward(
    unsigned short% velocityFeedForward,
    unsigned short% accelerationFeedForward
)
member GetPositionRegulatorFeedForward :
        velocityFeedForward : uint16 byref *
        accelerationFeedForward : uint16 byref -> unit

Parameters

velocityFeedForward
Type: SystemUInt16
Velocity feed forward factor
accelerationFeedForward
Type: SystemUInt16
Acceleration feed forward factor

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.GetPositionRegulatorGain Method

RegulatorGetPositionRegulatorGain Method EposCmd.Net
GetPositionRegulatorGain reads all position regulator gains.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionRegulatorGain(
    ref ushort p,
    ref ushort i,
    ref ushort d
)
Public Sub GetPositionRegulatorGain (
    ByRef p As UShort,
    ByRef i As UShort,
    ByRef d As UShort
)
public:
void GetPositionRegulatorGain(
    unsigned short% p,
    unsigned short% i,
    unsigned short% d
)
member GetPositionRegulatorGain :
        p : uint16 byref *
        i : uint16 byref *
        d : uint16 byref -> unit

Parameters

p
Type: SystemUInt16
Position regulator P-Gain
i
Type: SystemUInt16
Position regulator I-Gain
d
Type: SystemUInt16
Position regulator D-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.GetVelocityRegulatorFeedForward Method

RegulatorGetVelocityRegulatorFeedForward Method EposCmd.Net
"GetVelocityRegulatorFeedForward" reads parameter for velocity regulation feed forward.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVelocityRegulatorFeedForward(
    ref ushort velocityFeedForward,
    ref ushort accelerationFeedForward
)
Public Sub GetVelocityRegulatorFeedForward (
    ByRef velocityFeedForward As UShort,
    ByRef accelerationFeedForward As UShort
)
public:
void GetVelocityRegulatorFeedForward(
    unsigned short% velocityFeedForward,
    unsigned short% accelerationFeedForward
)
member GetVelocityRegulatorFeedForward :
        velocityFeedForward : uint16 byref *
        accelerationFeedForward : uint16 byref -> unit

Parameters

velocityFeedForward
Type: SystemUInt16
Velocity feed forward factor
accelerationFeedForward
Type: SystemUInt16
Acceleration feed forward factor

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.GetVelocityRegulatorGain Method

RegulatorGetVelocityRegulatorGain Method EposCmd.Net
With function "GetVelocityRegulatorGain" it is possible to read all velocity regulator gains.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVelocityRegulatorGain(
    ref ushort p,
    ref ushort i
)
Public Sub GetVelocityRegulatorGain (
    ByRef p As UShort,
    ByRef i As UShort
)
public:
void GetVelocityRegulatorGain(
    unsigned short% p,
    unsigned short% i
)
member GetVelocityRegulatorGain :
        p : uint16 byref *
        i : uint16 byref -> unit

Parameters

p
Type: SystemUInt16
Velocity regulator P-Gain
i
Type: SystemUInt16
Velocity regulator I-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.SetCurrentRegulatorGain Method

RegulatorSetCurrentRegulatorGain Method EposCmd.Net
SetCurrentRegulatorGain writes all current regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentRegulatorGain(
    ushort p,
    ushort i
)
Public Sub SetCurrentRegulatorGain (
    p As UShort,
    i As UShort
)
public:
void SetCurrentRegulatorGain(
    unsigned short p,
    unsigned short i
)
member SetCurrentRegulatorGain :
        p : uint16 *
        i : uint16 -> unit

Parameters

p
Type: SystemUInt16
Current regulator P-Gain
i
Type: SystemUInt16
Current regulator I-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.SetPositionRegulatorFeedForward Method

RegulatorSetPositionRegulatorFeedForward Method EposCmd.Net
SetPositionRegulatorFeedForward writes parameters for position regulation with feed forward.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionRegulatorFeedForward(
    ushort velocityFeedForward,
    ushort accelerationFeedForward
)
Public Sub SetPositionRegulatorFeedForward (
    velocityFeedForward As UShort,
    accelerationFeedForward As UShort
)
public:
void SetPositionRegulatorFeedForward(
    unsigned short velocityFeedForward,
    unsigned short accelerationFeedForward
)
member SetPositionRegulatorFeedForward :
        velocityFeedForward : uint16 *
        accelerationFeedForward : uint16 -> unit

Parameters

velocityFeedForward
Type: SystemUInt16
Velocity feed forward factor
accelerationFeedForward
Type: SystemUInt16
Acceleration feed forward factor

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.SetPositionRegulatorGain Method

RegulatorSetPositionRegulatorGain Method EposCmd.Net
SetPositionRegulatorGain writes all position regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionRegulatorGain(
    ushort p,
    ushort i,
    ushort d
)
Public Sub SetPositionRegulatorGain (
    p As UShort,
    i As UShort,
    d As UShort
)
public:
void SetPositionRegulatorGain(
    unsigned short p,
    unsigned short i,
    unsigned short d
)
member SetPositionRegulatorGain :
        p : uint16 *
        i : uint16 *
        d : uint16 -> unit

Parameters

p
Type: SystemUInt16
Position regulator P-Gain
i
Type: SystemUInt16
Position regulator I-Gain
d
Type: SystemUInt16
Position regulator D-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.SetVelocityRegulatorFeedForward Method

RegulatorSetVelocityRegulatorFeedForward Method EposCmd.Net
SetVelocityRegulatorFeedForward writes parameters for velocity regulation with feed forward.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVelocityRegulatorFeedForward(
    ushort velocityFeedForward,
    ushort accelerationFeedForward
)
Public Sub SetVelocityRegulatorFeedForward (
    velocityFeedForward As UShort,
    accelerationFeedForward As UShort
)
public:
void SetVelocityRegulatorFeedForward(
    unsigned short velocityFeedForward,
    unsigned short accelerationFeedForward
)
member SetVelocityRegulatorFeedForward :
        velocityFeedForward : uint16 *
        accelerationFeedForward : uint16 -> unit

Parameters

velocityFeedForward
Type: SystemUInt16
Velocity feed forward factor
accelerationFeedForward
Type: SystemUInt16
Acceleration feed forward factor

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator.SetVelocityRegulatorGain Method

RegulatorSetVelocityRegulatorGain Method EposCmd.Net
SetVelocityRegulatorGain writes all velocity regulator gains. Determine the optimal parameters using “Regulation Tuning” in «EPOS Studio».

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVelocityRegulatorGain(
    ushort p,
    ushort i
)
Public Sub SetVelocityRegulatorGain (
    p As UShort,
    i As UShort
)
public:
void SetVelocityRegulatorGain(
    unsigned short p,
    unsigned short i
)
member SetVelocityRegulatorGain :
        p : uint16 *
        i : uint16 -> unit

Parameters

p
Type: SystemUInt16
Velocity regulator P-Gain
i
Type: SystemUInt16
Velocity regulator I-Gain

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Regulator Properties

Regulator Properties EposCmd.Net

The Regulator type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Regulator Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety Class

Safety Class EposCmd.Net
Safety methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationSafety

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Safety : DeviceCommandGroup
Public Class Safety
    Inherits DeviceCommandGroup
public ref class Safety : public DeviceCommandGroup
type Safety =
    class
        inherit DeviceCommandGroup
    end

The Safety type exposes the following members.

Constructors
 | Name | Description
Public method | Safety | Initializes a new instance of the Safety class.
Top
Methods
 | Name | Description
Public method | GetMaxAcceleration | „GetMaxAcceleration” writes the maximal allowed acceleration/deceleration.
Public method | GetMaxFollowingError | "GetMaxFollowingError" writes the maximal allowed following parameter.
Public method | GetMaxProfileVelocity | "GetMaxProfileVelocity" writes the maximal allowed velocity.
Public method | SetMaxAcceleration | „SetMaxAcceleration” writes the maximal allowed acceleration/deceleration.
Public method | SetMaxFollowingError | "SetMaxFollowingError" reads the maximal allowed following parameter.
Public method | SetMaxProfileVelocity | "SetMaxProfileVelocity" reads the maximal allowed velocity.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety Constructor

Safety Constructor EposCmd.Net
Initializes a new instance of the Safety class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Safety(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Safety(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Safety

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety Methods

Safety Methods EposCmd.Net

The Safety type exposes the following members.

Methods
 | Name | Description
Public method | GetMaxAcceleration | „GetMaxAcceleration” writes the maximal allowed acceleration/deceleration.
Public method | GetMaxFollowingError | "GetMaxFollowingError" writes the maximal allowed following parameter.
Public method | GetMaxProfileVelocity | "GetMaxProfileVelocity" writes the maximal allowed velocity.
Public method | SetMaxAcceleration | „SetMaxAcceleration” writes the maximal allowed acceleration/deceleration.
Public method | SetMaxFollowingError | "SetMaxFollowingError" reads the maximal allowed following parameter.
Public method | SetMaxProfileVelocity | "SetMaxProfileVelocity" reads the maximal allowed velocity.
Top
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.GetMaxAcceleration Method

SafetyGetMaxAcceleration Method EposCmd.Net
„GetMaxAcceleration” writes the maximal allowed acceleration/deceleration.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetMaxAcceleration()
Public Function GetMaxAcceleration As UInteger
public:
unsigned int GetMaxAcceleration()
member GetMaxAcceleration : unit -> uint32

Return Value

Type: UInt32
This value is the limit of the other acceleration/deceleration objects. In the case of the failure, throws the exception with the error code.
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.GetMaxFollowingError Method

SafetyGetMaxFollowingError Method EposCmd.Net
"GetMaxFollowingError" writes the maximal allowed following parameter.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetMaxFollowingError()
Public Function GetMaxFollowingError As UInteger
public:
unsigned int GetMaxFollowingError()
member GetMaxFollowingError : unit -> uint32

Return Value

Type: UInt32
Maximal allowed difference of position actual value to position demand value. In the case of the failure, throws the exception with the error code.
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.GetMaxProfileVelocity Method

SafetyGetMaxProfileVelocity Method EposCmd.Net
"GetMaxProfileVelocity" writes the maximal allowed velocity.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetMaxProfileVelocity()
Public Function GetMaxProfileVelocity As UInteger
public:
unsigned int GetMaxProfileVelocity()
member GetMaxProfileVelocity : unit -> uint32

Return Value

Type: UInt32
This value is used as velocity limit in a position (or velocity) move. In the case of the failure, throws the exception with the error code.
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.SetMaxAcceleration Method

SafetySetMaxAcceleration Method EposCmd.Net
„SetMaxAcceleration” writes the maximal allowed acceleration/deceleration.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMaxAcceleration(
    uint maxAcceleration
)
Public Sub SetMaxAcceleration (
    maxAcceleration As UInteger
)
public:
void SetMaxAcceleration(
    unsigned int maxAcceleration
)
member SetMaxAcceleration :
        maxAcceleration : uint32 -> unit

Parameters

maxAcceleration
Type: SystemUInt32
This value is the limit of the other acceleration/deceleration objects.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.SetMaxFollowingError Method

SafetySetMaxFollowingError Method EposCmd.Net
"SetMaxFollowingError" reads the maximal allowed following parameter.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMaxFollowingError(
    uint maxFollowingError
)
Public Sub SetMaxFollowingError (
    maxFollowingError As UInteger
)
public:
void SetMaxFollowingError(
    unsigned int maxFollowingError
)
member SetMaxFollowingError :
        maxFollowingError : uint32 -> unit

Parameters

maxFollowingError
Type: SystemUInt32
Maximal allowed difference of position actual value to position demand value.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety.SetMaxProfileVelocity Method

SafetySetMaxProfileVelocity Method EposCmd.Net
"SetMaxProfileVelocity" reads the maximal allowed velocity.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMaxProfileVelocity(
    uint maxProfileVelocity
)
Public Sub SetMaxProfileVelocity (
    maxProfileVelocity As UInteger
)
public:
void SetMaxProfileVelocity(
    unsigned int maxProfileVelocity
)
member SetMaxProfileVelocity :
        maxProfileVelocity : uint32 -> unit

Parameters

maxProfileVelocity
Type: SystemUInt32
This value is used as velocity limit in a position (or velocity) move.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Safety Properties

Safety Properties EposCmd.Net

The Safety type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Safety Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor Class

Sensor Class EposCmd.Net
Sensor related methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationSensor

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Sensor : DeviceCommandGroup
Public Class Sensor
    Inherits DeviceCommandGroup
public ref class Sensor : public DeviceCommandGroup
type Sensor =
    class
        inherit DeviceCommandGroup
    end

The Sensor type exposes the following members.

Constructors
 | Name | Description
Public method | Sensor | Initializes a new instance of the Sensor class.
Top
Methods
 | Name | Description
Public method | GetHallSensorParameter | With function "GetHallSensorParameter" it is possible to read the Hall sensor parameters.
Public method | GetIncEncoderParameter | With function "GetIncEncoderParameter" it is possible to read the incremental encoder parameters.
Public method | GetSensorType | With function "GetSensorType" it is possible to read the sensor type.
Public method | GetSsiAbsEncoderParameter | With function "GetSsiAbsEncoderParameter" it is possible to read all parameters from SSI absolute encoder.
Public method | SetHallSensorParameter | With function "SetHallSensorParameter" it is possible to write the Hall sensor parameter.
Public method | SetIncEncoderParameter | With function "SetIncEncoderParameter" it is possible to write the incremental encoder parameters.
Public method | SetSensorType | With function "SetSensorType" it is possible to write the sensor type.
Public method | SetSsiAbsEncoderParameter | With function "SetSsiAbsEncoderParameter" it is possible to write all parameters for SSI absolute encoder.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor Constructor

Sensor Constructor EposCmd.Net
Initializes a new instance of the Sensor class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Sensor(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Sensor(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Sensor

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor Methods

Sensor Methods EposCmd.Net

The Sensor type exposes the following members.

Methods
 | Name | Description
Public method | GetHallSensorParameter | With function "GetHallSensorParameter" it is possible to read the Hall sensor parameters.
Public method | GetIncEncoderParameter | With function "GetIncEncoderParameter" it is possible to read the incremental encoder parameters.
Public method | GetSensorType | With function "GetSensorType" it is possible to read the sensor type.
Public method | GetSsiAbsEncoderParameter | With function "GetSsiAbsEncoderParameter" it is possible to read all parameters from SSI absolute encoder.
Public method | SetHallSensorParameter | With function "SetHallSensorParameter" it is possible to write the Hall sensor parameter.
Public method | SetIncEncoderParameter | With function "SetIncEncoderParameter" it is possible to write the incremental encoder parameters.
Public method | SetSensorType | With function "SetSensorType" it is possible to write the sensor type.
Public method | SetSsiAbsEncoderParameter | With function "SetSsiAbsEncoderParameter" it is possible to write all parameters for SSI absolute encoder.
Top
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.GetHallSensorParameter Method

SensorGetHallSensorParameter Method EposCmd.Net
With function "GetHallSensorParameter" it is possible to read the Hall sensor parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetHallSensorParameter(
    ref int invertedPolarity
)
Public Sub GetHallSensorParameter (
    ByRef invertedPolarity As Integer
)
public:
void GetHallSensorParameter(
    int% invertedPolarity
)
member GetHallSensorParameter :
        invertedPolarity : int byref -> unit

Parameters

invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.GetIncEncoderParameter Method

SensorGetIncEncoderParameter Method EposCmd.Net
With function "GetIncEncoderParameter" it is possible to read the incremental encoder parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetIncEncoderParameter(
    ref uint encoderResolution,
    ref int invertedPolarity
)
Public Sub GetIncEncoderParameter (
    ByRef encoderResolution As UInteger,
    ByRef invertedPolarity As Integer
)
public:
void GetIncEncoderParameter(
    unsigned int% encoderResolution,
    int% invertedPolarity
)
member GetIncEncoderParameter :
        encoderResolution : uint32 byref *
        invertedPolarity : int byref -> unit

Parameters

encoderResolution
Type: SystemUInt32
Encoder pulse number [pulse per turn]
invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.GetSensorType Method

SensorGetSensorType Method EposCmd.Net
With function "GetSensorType" it is possible to read the sensor type.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetSensorType(
    ref ESensorType sensorType
)
Public Sub GetSensorType (
    ByRef sensorType As ESensorType
)
public:
void GetSensorType(
    ESensorType% sensorType
)
member GetSensorType :
        sensorType : ESensorType byref -> unit

Parameters

sensorType
Type: EposCmd.NetESensorType
Position sensor type

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.GetSsiAbsEncoderParameter Method

SensorGetSsiAbsEncoderParameter Method EposCmd.Net
With function "GetSsiAbsEncoderParameter" it is possible to read all parameters from SSI absolute encoder.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetSsiAbsEncoderParameter(
    ref ushort dataRate,
    ref ushort nbOfMultiTurnDataBits,
    ref ushort nbOfSingleTurnDataBits,
    ref int invertedPolarity
)
Public Sub GetSsiAbsEncoderParameter (
    ByRef dataRate As UShort,
    ByRef nbOfMultiTurnDataBits As UShort,
    ByRef nbOfSingleTurnDataBits As UShort,
    ByRef invertedPolarity As Integer
)
public:
void GetSsiAbsEncoderParameter(
    unsigned short% dataRate,
    unsigned short% nbOfMultiTurnDataBits,
    unsigned short% nbOfSingleTurnDataBits,
    int% invertedPolarity
)
member GetSsiAbsEncoderParameter :
        dataRate : uint16 byref *
        nbOfMultiTurnDataBits : uint16 byref *
        nbOfSingleTurnDataBits : uint16 byref *
        invertedPolarity : int byref -> unit

Parameters

dataRate
Type: SystemUInt16
SSI Encoder data rate
nbOfMultiTurnDataBits
Type: SystemUInt16
number of bits multi turn
nbOfSingleTurnDataBits
Type: SystemUInt16
number of bits single turn
invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.SetHallSensorParameter Method

SensorSetHallSensorParameter Method EposCmd.Net
With function "SetHallSensorParameter" it is possible to write the Hall sensor parameter.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetHallSensorParameter(
    int invertedPolarity
)
Public Sub SetHallSensorParameter (
    invertedPolarity As Integer
)
public:
void SetHallSensorParameter(
    int invertedPolarity
)
member SetHallSensorParameter :
        invertedPolarity : int -> unit

Parameters

invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.SetIncEncoderParameter Method

SensorSetIncEncoderParameter Method EposCmd.Net
With function "SetIncEncoderParameter" it is possible to write the incremental encoder parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIncEncoderParameter(
    uint encoderResolution,
    int invertedPolarity
)
Public Sub SetIncEncoderParameter (
    encoderResolution As UInteger,
    invertedPolarity As Integer
)
public:
void SetIncEncoderParameter(
    unsigned int encoderResolution,
    int invertedPolarity
)
member SetIncEncoderParameter :
        encoderResolution : uint32 *
        invertedPolarity : int -> unit

Parameters

encoderResolution
Type: SystemUInt32
Encoder pulse number [pulse per turn]
invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.SetSensorType Method

SensorSetSensorType Method EposCmd.Net
With function "SetSensorType" it is possible to write the sensor type.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSensorType(
    ESensorType sensorType
)
Public Sub SetSensorType (
    sensorType As ESensorType
)
public:
void SetSensorType(
    ESensorType sensorType
)
member SetSensorType :
        sensorType : ESensorType -> unit

Parameters

sensorType
Type: EposCmd.NetESensorType
Position Sensor Type

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor.SetSsiAbsEncoderParameter Method

SensorSetSsiAbsEncoderParameter Method EposCmd.Net
With function "SetSsiAbsEncoderParameter" it is possible to write all parameters for SSI absolute encoder.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSsiAbsEncoderParameter(
    ushort dataRate,
    ushort nbOfMultiTurnDataBits,
    ushort nbOfSingleTurnDataBits,
    int invertedPolarity
)
Public Sub SetSsiAbsEncoderParameter (
    dataRate As UShort,
    nbOfMultiTurnDataBits As UShort,
    nbOfSingleTurnDataBits As UShort,
    invertedPolarity As Integer
)
public:
void SetSsiAbsEncoderParameter(
    unsigned short dataRate,
    unsigned short nbOfMultiTurnDataBits,
    unsigned short nbOfSingleTurnDataBits,
    int invertedPolarity
)
member SetSsiAbsEncoderParameter :
        dataRate : uint16 *
        nbOfMultiTurnDataBits : uint16 *
        nbOfSingleTurnDataBits : uint16 *
        invertedPolarity : int -> unit

Parameters

dataRate
Type: SystemUInt16
SSI Encoder data rate
nbOfMultiTurnDataBits
Type: SystemUInt16
number of bits multi turn
nbOfSingleTurnDataBits
Type: SystemUInt16
number of bits single turn
invertedPolarity
Type: SystemInt32
Position sensor polarity

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Sensor Properties

Sensor Properties EposCmd.Net

The Sensor type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Sensor Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units Class

Units Class EposCmd.Net
Velocity Units methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.ConfigurationUnits

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Units : DeviceCommandGroup
Public Class Units
    Inherits DeviceCommandGroup
public ref class Units : public DeviceCommandGroup
type Units =
    class
        inherit DeviceCommandGroup
    end

The Units type exposes the following members.

Constructors
 | Name | Description
Public method | Units | Initializes a new instance of the Units class.
Top
Methods
 | Name | Description
Public method | GetVelocityUnits | "GetVelocityUnits" reads velocity unit parameters.
Public method | SetVelocityUnits | "SetVelocityUnits" writes velocity unit parameters.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units Constructor

Units Constructor EposCmd.Net
Initializes a new instance of the Units class.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Units(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Units(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Units

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Units Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units Methods

Units Methods EposCmd.Net

The Units type exposes the following members.

Methods
 | Name | Description
Public method | GetVelocityUnits | "GetVelocityUnits" reads velocity unit parameters.
Public method | SetVelocityUnits | "SetVelocityUnits" writes velocity unit parameters.
Top
See Also

Reference

Units Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units.GetVelocityUnits Method

UnitsGetVelocityUnits Method EposCmd.Net
"GetVelocityUnits" reads velocity unit parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVelocityUnits(
    ref EVelocityDimension velDimension,
    ref EVelocityNotation velNotation
)
Public Sub GetVelocityUnits (
    ByRef velDimension As EVelocityDimension,
    ByRef velNotation As EVelocityNotation
)
public:
void GetVelocityUnits(
    EVelocityDimension% velDimension,
    EVelocityNotation% velNotation
)
member GetVelocityUnits :
        velDimension : EVelocityDimension byref *
        velNotation : EVelocityNotation byref -> unit

Parameters

velDimension
Type: EposCmd.NetEVelocityDimension
Velocity dimension index => See Firmware Specification
velNotation
Type: EposCmd.NetEVelocityNotation
Velocity notation index => See Firmware Specification

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Units Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units.SetVelocityUnits Method

UnitsSetVelocityUnits Method EposCmd.Net
"SetVelocityUnits" writes velocity unit parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Configuration
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVelocityUnits(
    EVelocityDimension velDimension,
    EVelocityNotation velNotation
)
Public Sub SetVelocityUnits (
    velDimension As EVelocityDimension,
    velNotation As EVelocityNotation
)
public:
void SetVelocityUnits(
    EVelocityDimension velDimension,
    EVelocityNotation velNotation
)
member SetVelocityUnits :
        velDimension : EVelocityDimension *
        velNotation : EVelocityNotation -> unit

Parameters

velDimension
Type: EposCmd.NetEVelocityDimension
Velocity dimension index => See Firmware Specification
velNotation
Type: EposCmd.NetEVelocityNotation
Velocity notation index => See Firmware Specification

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Units Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


Units Properties

Units Properties EposCmd.Net

The Units type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Units Class
EposCmd.Net.DeviceCmdSet.Configuration Namespace


EposCmd.Net.DeviceCmdSet.DataRecorder Namespace

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace EposCmd.Net
Classes
 | Class | Description
Public class | Data | Data access methods
Public class | DataRecorder | Data recorder profile
Public class | DataRecorderAdvanced | Advanced Data Recorder methods
Public class | Setup | Setup of the Daza recorder methods
Public class | Status | Status of the Data recorder


Data Class

Data Class EposCmd.Net
Data access methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.DataRecorderData

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Data : DeviceCommandGroup
Public Class Data
    Inherits DeviceCommandGroup
public ref class Data : public DeviceCommandGroup
type Data =
    class
        inherit DeviceCommandGroup
    end

The Data type exposes the following members.

Constructors
 | Name | Description
Public method | Data | Initializes a new instance of the Data class.
Top
Methods
 | Name | Description
Public method | ExportChannelDataToFile | "ExportChannelDataToFile" saves data point in a file.
Public method | ReadChannelDataVector | "ReadChannelDataVector" returns the data points of a selected channel.
Public method | ReadChannelVectorSize | "ReadChannelVectorSize" returns the maximal number of samples per variable. This parameter is dynamically calculated by the data recorder.
Public method | ShowChannelDataDlg | "ShowChannelDataDlg" opens the dialog to show the data channel(-s).
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data Constructor

Data Constructor EposCmd.Net
Initializes a new instance of the Data class.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Data(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Data(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Data

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data Methods

Data Methods EposCmd.Net

The Data type exposes the following members.

Methods
 | Name | Description
Public method | ExportChannelDataToFile | "ExportChannelDataToFile" saves data point in a file.
Public method | ReadChannelDataVector | "ReadChannelDataVector" returns the data points of a selected channel.
Public method | ReadChannelVectorSize | "ReadChannelVectorSize" returns the maximal number of samples per variable. This parameter is dynamically calculated by the data recorder.
Public method | ShowChannelDataDlg | "ShowChannelDataDlg" opens the dialog to show the data channel(-s).
Top
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data.ExportChannelDataToFile Method

DataExportChannelDataToFile Method EposCmd.Net
"ExportChannelDataToFile" saves data point in a file.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ExportChannelDataToFile(
    string fileName
)
Public Sub ExportChannelDataToFile (
    fileName As String
)
public:
void ExportChannelDataToFile(
    String^ fileName
)
member ExportChannelDataToFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
Path and file name for save data points. File endings: *.csv, *.txt or *.rda.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data.ReadChannelDataVector Method

DataReadChannelDataVector Method EposCmd.Net
"ReadChannelDataVector" returns the data points of a selected channel.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadChannelDataVector(
    byte channelNumber,
    ref byte[] dataVector
)
Public Sub ReadChannelDataVector (
    channelNumber As Byte,
    ByRef dataVector As Byte()
)
public:
void ReadChannelDataVector(
    unsigned char channelNumber,
    array<unsigned char>^% dataVector
)
member ReadChannelDataVector :
        channelNumber : byte *
        dataVector : byte[] byref -> unit

Parameters

channelNumber
Type: SystemByte
Selected channel
dataVector
Type: SystemByte
Data points of selected channel

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data.ReadChannelVectorSize Method

DataReadChannelVectorSize Method EposCmd.Net
"ReadChannelVectorSize" returns the maximal number of samples per variable. This parameter is dynamically calculated by the data recorder.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadChannelVectorSize(
    ref uint vectorSize
)
Public Sub ReadChannelVectorSize (
    ByRef vectorSize As UInteger
)
public:
void ReadChannelVectorSize(
    unsigned int% vectorSize
)
member ReadChannelVectorSize :
        vectorSize : uint32 byref -> unit

Parameters

vectorSize
Type: SystemUInt32
Maximal number of samples per variable.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data.ShowChannelDataDlg Method

DataShowChannelDataDlg Method EposCmd.Net
"ShowChannelDataDlg" opens the dialog to show the data channel(-s).

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowChannelDataDlg()
Public Sub ShowChannelDataDlg
public:
void ShowChannelDataDlg()
member ShowChannelDataDlg : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Data Properties

Data Properties EposCmd.Net

The Data type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Data Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder Class

DataRecorder Class EposCmd.Net
Data recorder profile
Inheritance Hierarchy
SystemObject
EposCmd.Net.DeviceCmdSet.DataRecorderDataRecorder

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DataRecorder
Public Class DataRecorder
public ref class DataRecorder
type DataRecorder =  class end

The DataRecorder type exposes the following members.

Constructors
 | Name | Description
Public method | DataRecorder | Initializes a new instance of the DataRecorder class.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
Public property | Data | Gets the data.
Public property | Setup | Gets the setup.
Public property | Status | Gets the status.
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder Constructor

DataRecorder Constructor EposCmd.Net
Initializes a new instance of the DataRecorder class.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DataRecorder(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
DataRecorder(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> DataRecorder

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder Properties

DataRecorder Properties EposCmd.Net

The DataRecorder type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
Public property | Data | Gets the data.
Public property | Setup | Gets the setup.
Public property | Status | Gets the status.
Top
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder.Advanced Property

DataRecorderAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DataRecorderAdvanced Advanced { get; }
Public ReadOnly Property Advanced As DataRecorderAdvanced
    Get
public:
property DataRecorderAdvanced^ Advanced {
    DataRecorderAdvanced^ get ();
}
member Advanced : DataRecorderAdvanced with get

Property Value

Type: DataRecorderAdvanced
The advanced.
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder.Data Property

DataRecorderData Property EposCmd.Net
Gets the data.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Data Data { get; }
Public ReadOnly Property Data As Data
    Get
public:
property Data^ Data {
    Data^ get ();
}
member Data : Data with get

Property Value

Type: Data
The data.
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder.Setup Property

DataRecorderSetup Property EposCmd.Net
Gets the setup.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Setup Setup { get; }
Public ReadOnly Property Setup As Setup
    Get
public:
property Setup^ Setup {
    Setup^ get ();
}
member Setup : Setup with get

Property Value

Type: Setup
The setup.
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorder.Status Property

DataRecorderStatus Property EposCmd.Net
Gets the status.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Status Status { get; }
Public ReadOnly Property Status As Status
    Get
public:
property Status^ Status {
    Status^ get ();
}
member Status : Status with get

Property Value

Type: Status
The status.
See Also

Reference

DataRecorder Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced Class

DataRecorderAdvanced Class EposCmd.Net
Advanced Data Recorder methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.DataRecorderDataRecorderAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DataRecorderAdvanced : DeviceCommandGroup
Public Class DataRecorderAdvanced
    Inherits DeviceCommandGroup
public ref class DataRecorderAdvanced : public DeviceCommandGroup
type DataRecorderAdvanced =
    class
        inherit DeviceCommandGroup
    end

The DataRecorderAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | DataRecorderAdvanced | Initializes a new instance of the Advanced class.
Top
Methods
 | Name | Description
Public method | ExtractChannelDataVector | ExtractChannelDataVector returns the vector of one data channel.
Public method | ReadDataBuffer | "ReadDataBuffer" returns the buffer data points.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced Constructor

DataRecorderAdvanced Constructor EposCmd.Net
Initializes a new instance of the Advanced class.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DataRecorderAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
DataRecorderAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> DataRecorderAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

DataRecorderAdvanced Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced Methods

DataRecorderAdvanced Methods EposCmd.Net

The DataRecorderAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | ExtractChannelDataVector | ExtractChannelDataVector returns the vector of one data channel.
Public method | ReadDataBuffer | "ReadDataBuffer" returns the buffer data points.
Top
See Also

Reference

DataRecorderAdvanced Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced.ExtractChannelDataVector Method

DataRecorderAdvancedExtractChannelDataVector Method EposCmd.Net
ExtractChannelDataVector returns the vector of one data channel.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ExtractChannelDataVector(
    byte channelNumber,
    ref byte[] dataBuffer,
    uint bufferSize,
    ref byte[] dataVector,
    uint vectorSize,
    ushort vectorStartOffset,
    ushort maxNbOfSamples,
    ushort nbOfRecordedSamples
)
Public Sub ExtractChannelDataVector (
    channelNumber As Byte,
    ByRef dataBuffer As Byte(),
    bufferSize As UInteger,
    ByRef dataVector As Byte(),
    vectorSize As UInteger,
    vectorStartOffset As UShort,
    maxNbOfSamples As UShort,
    nbOfRecordedSamples As UShort
)
public:
void ExtractChannelDataVector(
    unsigned char channelNumber,
    array<unsigned char>^% dataBuffer,
    unsigned int bufferSize,
    array<unsigned char>^% dataVector,
    unsigned int vectorSize,
    unsigned short vectorStartOffset,
    unsigned short maxNbOfSamples,
    unsigned short nbOfRecordedSamples
)
member ExtractChannelDataVector :
        channelNumber : byte *
        dataBuffer : byte[] byref *
        bufferSize : uint32 *
        dataVector : byte[] byref *
        vectorSize : uint32 *
        vectorStartOffset : uint16 *
        maxNbOfSamples : uint16 *
        nbOfRecordedSamples : uint16 -> unit

Parameters

channelNumber
Type: SystemByte
Selected channel
dataBuffer
Type: SystemByte
Data points
bufferSize
Type: SystemUInt32
Buffer size
dataVector
Type: SystemByte
Vector data
vectorSize
Type: SystemUInt32
Vector size
vectorStartOffset
Type: SystemUInt16
Offset to the start of the recorded data vector within the ring buffer.
maxNbOfSamples
Type: SystemUInt16
Maximal number of samples per variable.
nbOfRecordedSamples
Type: SystemUInt16
Number of recorded samples.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

DataRecorderAdvanced Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced.ReadDataBuffer Method

DataRecorderAdvancedReadDataBuffer Method EposCmd.Net
"ReadDataBuffer" returns the buffer data points.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadDataBuffer(
    ref byte[] dataBuffer,
    uint bufferSizeToRead,
    ref uint bufferSizeRead,
    ref ushort vectorStartOffset,
    ref ushort maxNbOfSamples,
    ref ushort nbOfRecordedSamples
)
Public Sub ReadDataBuffer (
    ByRef dataBuffer As Byte(),
    bufferSizeToRead As UInteger,
    ByRef bufferSizeRead As UInteger,
    ByRef vectorStartOffset As UShort,
    ByRef maxNbOfSamples As UShort,
    ByRef nbOfRecordedSamples As UShort
)
public:
void ReadDataBuffer(
    array<unsigned char>^% dataBuffer,
    unsigned int bufferSizeToRead,
    unsigned int% bufferSizeRead,
    unsigned short% vectorStartOffset,
    unsigned short% maxNbOfSamples,
    unsigned short% nbOfRecordedSamples
)
member ReadDataBuffer :
        dataBuffer : byte[] byref *
        bufferSizeToRead : uint32 *
        bufferSizeRead : uint32 byref *
        vectorStartOffset : uint16 byref *
        maxNbOfSamples : uint16 byref *
        nbOfRecordedSamples : uint16 byref -> unit

Parameters

dataBuffer
Type: SystemByte
Data points
bufferSizeToRead
Type: SystemUInt32
Size of read data buffer
bufferSizeRead
Type: SystemUInt32
The buffer size read.
vectorStartOffset
Type: SystemUInt16
Offset to the start of the recorded data vector within the ring buffer.
maxNbOfSamples
Type: SystemUInt16
Maximal number of samples per variable.
nbOfRecordedSamples
Type: SystemUInt16
Number of recorded samples.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

DataRecorderAdvanced Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


DataRecorderAdvanced Properties

DataRecorderAdvanced Properties EposCmd.Net

The DataRecorderAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

DataRecorderAdvanced Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup Class

Setup Class EposCmd.Net
Setup of the Daza recorder methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.DataRecorderSetup

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Setup : DeviceCommandGroup
Public Class Setup
    Inherits DeviceCommandGroup
public ref class Setup : public DeviceCommandGroup
type Setup =
    class
        inherit DeviceCommandGroup
    end

The Setup type exposes the following members.

Constructors
 | Name | Description
Public method | Setup | Initializes a new instance of the Setup class.
Top
Methods
 | Name | Description
Public method | ActivateChannel | "ActivateChannel" connect object for data recording. Start with channel number one!
Public method | DeactivateAllChannels | "DeactivateAllChannel" disconnect all data recording objects.
Public method | DisableAllTriggers | "DisableAllTrigger" set data recorder configuration for triggers to zero.
Public method | EnableTrigger | "EnableTrigger" connect trigger(-s) for data recording.
Public method | GetRecorderParameter | "GetRecorderParameter" read parameters for data recorder.
Public method | SetRecorderParameter | "SetRecorderParameter" write parameters for data recorder.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup Constructor

Setup Constructor EposCmd.Net
Initializes a new instance of the Setup class.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Setup(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Setup(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Setup

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup Methods

Setup Methods EposCmd.Net

The Setup type exposes the following members.

Methods
 | Name | Description
Public method | ActivateChannel | "ActivateChannel" connect object for data recording. Start with channel number one!
Public method | DeactivateAllChannels | "DeactivateAllChannel" disconnect all data recording objects.
Public method | DisableAllTriggers | "DisableAllTrigger" set data recorder configuration for triggers to zero.
Public method | EnableTrigger | "EnableTrigger" connect trigger(-s) for data recording.
Public method | GetRecorderParameter | "GetRecorderParameter" read parameters for data recorder.
Public method | SetRecorderParameter | "SetRecorderParameter" write parameters for data recorder.
Top
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.ActivateChannel Method

SetupActivateChannel Method EposCmd.Net
"ActivateChannel" connect object for data recording. Start with channel number one!

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateChannel(
    byte channelNumber,
    ushort objectIndex,
    byte objectSubIndex,
    byte objectSize
)
Public Sub ActivateChannel (
    channelNumber As Byte,
    objectIndex As UShort,
    objectSubIndex As Byte,
    objectSize As Byte
)
public:
void ActivateChannel(
    unsigned char channelNumber,
    unsigned short objectIndex,
    unsigned char objectSubIndex,
    unsigned char objectSize
)
member ActivateChannel :
        channelNumber : byte *
        objectIndex : uint16 *
        objectSubIndex : byte *
        objectSize : byte -> unit

Parameters

channelNumber
Type: SystemByte
Channel number [1 … 4]
objectIndex
Type: SystemUInt16
Object index for data recording
objectSubIndex
Type: SystemByte
Object sub index for data recording
objectSize
Type: SystemByte
Object size for data recording

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.DeactivateAllChannels Method

SetupDeactivateAllChannels Method EposCmd.Net
"DeactivateAllChannel" disconnect all data recording objects.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateAllChannels()
Public Sub DeactivateAllChannels
public:
void DeactivateAllChannels()
member DeactivateAllChannels : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.DisableAllTriggers Method

SetupDisableAllTriggers Method EposCmd.Net
"DisableAllTrigger" set data recorder configuration for triggers to zero.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableAllTriggers()
Public Sub DisableAllTriggers
public:
void DisableAllTriggers()
member DisableAllTriggers : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.EnableTrigger Method

SetupEnableTrigger Method EposCmd.Net
"EnableTrigger" connect trigger(-s) for data recording.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableTrigger(
    EDataRecorderTriggerType triggerType
)
Public Sub EnableTrigger (
    triggerType As EDataRecorderTriggerType
)
public:
void EnableTrigger(
    EDataRecorderTriggerType triggerType
)
member EnableTrigger :
        triggerType : EDataRecorderTriggerType -> unit

Parameters

triggerType
Type: EposCmd.NetEDataRecorderTriggerType
Configuration of Auto Trigger functions. If a bit is write as one the trigger is activated: 1 (bit 0 = 1): Trigger at movement start 2 (bit 1 = 1): Trigger by error state 4 (bit 2 = 1): Trigger at digital input edge 8 (bit 3 = 1): Trigger at end of profile It is possible to activate more than one trigger at the same time.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.GetRecorderParameter Method

SetupGetRecorderParameter Method EposCmd.Net
"GetRecorderParameter" read parameters for data recorder.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetRecorderParameter(
    ref ushort samplingPeriod,
    ref ushort pNbOfPrecedingSamples
)
Public Sub GetRecorderParameter (
    ByRef samplingPeriod As UShort,
    ByRef pNbOfPrecedingSamples As UShort
)
public:
void GetRecorderParameter(
    unsigned short% samplingPeriod,
    unsigned short% pNbOfPrecedingSamples
)
member GetRecorderParameter :
        samplingPeriod : uint16 byref *
        pNbOfPrecedingSamples : uint16 byref -> unit

Parameters

samplingPeriod
Type: SystemUInt16
Sampling Period as a multiple of the current regulator cycle (n-times 0.1ms)
pNbOfPrecedingSamples
Type: SystemUInt16
Number of preceding samples (data history)

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup.SetRecorderParameter Method

SetupSetRecorderParameter Method EposCmd.Net
"SetRecorderParameter" write parameters for data recorder.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRecorderParameter(
    ushort samplingPeriod,
    ushort nbOfPrecedingSamples
)
Public Sub SetRecorderParameter (
    samplingPeriod As UShort,
    nbOfPrecedingSamples As UShort
)
public:
void SetRecorderParameter(
    unsigned short samplingPeriod,
    unsigned short nbOfPrecedingSamples
)
member SetRecorderParameter :
        samplingPeriod : uint16 *
        nbOfPrecedingSamples : uint16 -> unit

Parameters

samplingPeriod
Type: SystemUInt16
Sampling Period as a multiple of the current regulator cycle (n-times 0.1ms)
nbOfPrecedingSamples
Type: SystemUInt16
Number of preceding samples (data history)

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Setup Properties

Setup Properties EposCmd.Net

The Setup type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Setup Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status Class

Status Class EposCmd.Net
Status of the Data recorder
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.DataRecorderStatus

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Status : DeviceCommandGroup
Public Class Status
    Inherits DeviceCommandGroup
public ref class Status : public DeviceCommandGroup
type Status =
    class
        inherit DeviceCommandGroup
    end

The Status type exposes the following members.

Constructors
 | Name | Description
Public method | Status | Initializes a new instance of the Status class.
Top
Methods
 | Name | Description
Public method | ForceTrigger | "ForceTrigger" forces the data recording triggers.
Public method | IsRecorderRunning | "IsRecorderRunning" returns data recorder status running.
Public method | IsRecorderTriggered | "IsRecorderTriggered" returns data recorder status triggered.
Public method | StartRecorder | "StartRecorder" starts the data recording.
Public method | StopRecorder | "StopRecorder" stops the data recording.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status Constructor

Status Constructor EposCmd.Net
Initializes a new instance of the Status class.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Status(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Status(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Status

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status Methods

Status Methods EposCmd.Net

The Status type exposes the following members.

Methods
 | Name | Description
Public method | ForceTrigger | "ForceTrigger" forces the data recording triggers.
Public method | IsRecorderRunning | "IsRecorderRunning" returns data recorder status running.
Public method | IsRecorderTriggered | "IsRecorderTriggered" returns data recorder status triggered.
Public method | StartRecorder | "StartRecorder" starts the data recording.
Public method | StopRecorder | "StopRecorder" stops the data recording.
Top
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status.ForceTrigger Method

StatusForceTrigger Method EposCmd.Net
"ForceTrigger" forces the data recording triggers.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ForceTrigger()
Public Sub ForceTrigger
public:
void ForceTrigger()
member ForceTrigger : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status.IsRecorderRunning Method

StatusIsRecorderRunning Method EposCmd.Net
"IsRecorderRunning" returns data recorder status running.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void IsRecorderRunning(
    ref bool running
)
Public Sub IsRecorderRunning (
    ByRef running As Boolean
)
public:
void IsRecorderRunning(
    bool% running
)
member IsRecorderRunning :
        running : bool byref -> unit

Parameters

running
Type: SystemBoolean
1: Data recorder running 0: Data recorder stopped

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status.IsRecorderTriggered Method

StatusIsRecorderTriggered Method EposCmd.Net
"IsRecorderTriggered" returns data recorder status triggered.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void IsRecorderTriggered(
    ref bool triggered
)
Public Sub IsRecorderTriggered (
    ByRef triggered As Boolean
)
public:
void IsRecorderTriggered(
    bool% triggered
)
member IsRecorderTriggered :
        triggered : bool byref -> unit

Parameters

triggered
Type: SystemBoolean
1: Data recorder triggered 0: Data recorder not triggered

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status.StartRecorder Method

StatusStartRecorder Method EposCmd.Net
"StartRecorder" starts the data recording.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void StartRecorder()
Public Sub StartRecorder
public:
void StartRecorder()
member StartRecorder : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status.StopRecorder Method

StatusStopRecorder Method EposCmd.Net
"StopRecorder" stops the data recording.

Namespace: EposCmd.Net.DeviceCmdSet.DataRecorder
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void StopRecorder()
Public Sub StopRecorder
public:
void StopRecorder()
member StopRecorder : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


Status Properties

Status Properties EposCmd.Net

The Status type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Status Class
EposCmd.Net.DeviceCmdSet.DataRecorder Namespace


EposCmd.Net.DeviceCmdSet.Initialization Namespace

EposCmd.Net.DeviceCmdSet.Initialization Namespace EposCmd.Net
Classes
 | Class | Description
Public class | Initialization | Initialization profile
Public class | InitializationAdvanced | Advanced initialization methods


Initialization Class

Initialization Class EposCmd.Net
Initialization profile
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.InitializationInitialization

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Initialization : DeviceCommandGroup
Public Class Initialization
    Inherits DeviceCommandGroup
public ref class Initialization : public DeviceCommandGroup
type Initialization =
    class
        inherit DeviceCommandGroup
    end

The Initialization type exposes the following members.

Constructors
 | Name | Description
Public method | Initialization | Initializes a new instance of the Initialization class.
Top
Methods
 | Name | Description
Public method | GetDriverInfo | Function "GetDriverInfo" returns the name and version from the Windows DLL.
Public method | GetErrorInfo | Function "GetErrorInfo" returns the error information about the executed function from a received error code. The function returns communication and library errors but no device errors.
Public method | GetVersion | "GetVersion" returns the firmware version.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization Constructor

Initialization Constructor EposCmd.Net
Initializes a new instance of the Initialization class.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Initialization(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Initialization(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Initialization

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization Methods

Initialization Methods EposCmd.Net

The Initialization type exposes the following members.

Methods
 | Name | Description
Public method | GetDriverInfo | Function "GetDriverInfo" returns the name and version from the Windows DLL.
Public method | GetErrorInfo | Function "GetErrorInfo" returns the error information about the executed function from a received error code. The function returns communication and library errors but no device errors.
Public method | GetVersion | "GetVersion" returns the firmware version.
Top
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization.GetDriverInfo Method

InitializationGetDriverInfo Method EposCmd.Net
Function "GetDriverInfo" returns the name and version from the Windows DLL.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetDriverInfo(
    ref string libraryName,
    ref string libraryVersion
)
Public Sub GetDriverInfo (
    ByRef libraryName As String,
    ByRef libraryVersion As String
)
public:
void GetDriverInfo(
    String^% libraryName,
    String^% libraryVersion
)
member GetDriverInfo :
        libraryName : string byref *
        libraryVersion : string byref -> unit

Parameters

libraryName
Type: SystemString
Name of the library.
libraryVersion
Type: SystemString
The library version.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization.GetErrorInfo Method

InitializationGetErrorInfo Method EposCmd.Net
Function "GetErrorInfo" returns the error information about the executed function from a received error code. The function returns communication and library errors but no device errors.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetErrorInfo(
    uint errorCodeValue,
    ref string errofInfo,
    ushort maxStrSize
)
Public Sub GetErrorInfo (
    errorCodeValue As UInteger,
    ByRef errofInfo As String,
    maxStrSize As UShort
)
public:
void GetErrorInfo(
    unsigned int errorCodeValue,
    String^% errofInfo,
    unsigned short maxStrSize
)
member GetErrorInfo :
        errorCodeValue : uint32 *
        errofInfo : string byref *
        maxStrSize : uint16 -> unit

Parameters

errorCodeValue
Type: SystemUInt32
The error code value.
errofInfo
Type: SystemString
The errof info.
maxStrSize
Type: SystemUInt16
Reserved memory size for the name

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization.GetVersion Method

InitializationGetVersion Method EposCmd.Net
"GetVersion" returns the firmware version.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVersion(
    ref ushort hardwareVersion,
    ref ushort softwareVersion,
    ref ushort applicationNumber,
    ref ushort applicationVersion
)
Public Sub GetVersion (
    ByRef hardwareVersion As UShort,
    ByRef softwareVersion As UShort,
    ByRef applicationNumber As UShort,
    ByRef applicationVersion As UShort
)
public:
void GetVersion(
    unsigned short% hardwareVersion,
    unsigned short% softwareVersion,
    unsigned short% applicationNumber,
    unsigned short% applicationVersion
)
member GetVersion :
        hardwareVersion : uint16 byref *
        softwareVersion : uint16 byref *
        applicationNumber : uint16 byref *
        applicationVersion : uint16 byref -> unit

Parameters

hardwareVersion
Type: SystemUInt16
The hardware version.
softwareVersion
Type: SystemUInt16
The software version.
applicationNumber
Type: SystemUInt16
The application number.
applicationVersion
Type: SystemUInt16
The application version.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization Properties

Initialization Properties EposCmd.Net

The Initialization type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


Initialization.Advanced Property

InitializationAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InitializationAdvanced Advanced { get; }
Public ReadOnly Property Advanced As InitializationAdvanced
    Get
public:
property InitializationAdvanced^ Advanced {
    InitializationAdvanced^ get ();
}
member Advanced : InitializationAdvanced with get

Property Value

Type: InitializationAdvanced
The advanced.
See Also

Reference

Initialization Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced Class

InitializationAdvanced Class EposCmd.Net
Advanced initialization methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.InitializationInitializationAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class InitializationAdvanced : DeviceCommandGroup
Public Class InitializationAdvanced
    Inherits DeviceCommandGroup
public ref class InitializationAdvanced : public DeviceCommandGroup
type InitializationAdvanced =
    class
        inherit DeviceCommandGroup
    end

The InitializationAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | InitializationAdvanced | Initializes a new instance of the InitializationAdvanced class.
Top
Methods
 | Name | Description
Public method | GetBaudrateSelection | Function "GetBaudrateSelection" returns all available baud rates for the connected port.
Public method | GetDeviceName | Function "GetDeviceName" returns the device name to corresponding handle.
Public method | GetDeviceNameSelection | Function "GetDeviceNameSelection" returns all available device names.
Public method | GetInterfaceName | Function "GetInterfaceName" returns the interface name to corresponding handle.
Public method | GetInterfaceNameSelection | Function "GetInterfaceNameSelection" returns all available interface names.
Public method | GetKeyHandle | Function "GetKeyHandle" returns the key handle from the opened interface.
Public method | GetPortName | Function "GetPortName" returns the port name to corresponding handle.
Public method | GetPortNameSelection | Function "GetPortNameSelection" returns all available port names.
Public method | GetProtocolStackName | Function "GetProtocolStackName" returns the protocol stack name to corresponding handle.
Public method | GetProtocolStackNameSelection | Function "GetProtocolStackNameSelection" returns all available protocol stack names.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced Constructor

InitializationAdvanced Constructor EposCmd.Net
Initializes a new instance of the InitializationAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InitializationAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
InitializationAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> InitializationAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced Methods

InitializationAdvanced Methods EposCmd.Net

The InitializationAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | GetBaudrateSelection | Function "GetBaudrateSelection" returns all available baud rates for the connected port.
Public method | GetDeviceName | Function "GetDeviceName" returns the device name to corresponding handle.
Public method | GetDeviceNameSelection | Function "GetDeviceNameSelection" returns all available device names.
Public method | GetInterfaceName | Function "GetInterfaceName" returns the interface name to corresponding handle.
Public method | GetInterfaceNameSelection | Function "GetInterfaceNameSelection" returns all available interface names.
Public method | GetKeyHandle | Function "GetKeyHandle" returns the key handle from the opened interface.
Public method | GetPortName | Function "GetPortName" returns the port name to corresponding handle.
Public method | GetPortNameSelection | Function "GetPortNameSelection" returns all available port names.
Public method | GetProtocolStackName | Function "GetProtocolStackName" returns the protocol stack name to corresponding handle.
Public method | GetProtocolStackNameSelection | Function "GetProtocolStackNameSelection" returns all available protocol stack names.
Top
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetBaudrateSelection Method

InitializationAdvancedGetBaudrateSelection Method EposCmd.Net
Function "GetBaudrateSelection" returns all available baud rates for the connected port.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetBaudrateSelection(
    string deviceName,
    string protocolStackName,
    string interfaceName,
    string portName,
    int startOfSelection,
    ref int endOfSelection
)
Public Function GetBaudrateSelection (
    deviceName As String,
    protocolStackName As String,
    interfaceName As String,
    portName As String,
    startOfSelection As Integer,
    ByRef endOfSelection As Integer
) As UInteger
public:
unsigned int GetBaudrateSelection(
    String^ deviceName,
    String^ protocolStackName,
    String^ interfaceName,
    String^ portName,
    int startOfSelection,
    int% endOfSelection
)
member GetBaudrateSelection :
        deviceName : string *
        protocolStackName : string *
        interfaceName : string *
        portName : string *
        startOfSelection : int *
        endOfSelection : int byref -> uint32

Parameters

deviceName
Type: SystemString
Device name
protocolStackName
Type: SystemString
Protocol stack name
interfaceName
Type: SystemString
Interface name
portName
Type: SystemString
Port name
startOfSelection
Type: SystemInt32
1: Get first selection value
0: Get next selection value
endOfSelection
Type: SystemInt32
1: No more value available
0: More value available

Return Value

Type: UInt32
Baud rate [Bit/s]. In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetDeviceName Method

InitializationAdvancedGetDeviceName Method EposCmd.Net
Function "GetDeviceName" returns the device name to corresponding handle.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetDeviceName(
    StringBuilder deviceName,
    ushort maxStrSize
)
Public Sub GetDeviceName (
    deviceName As StringBuilder,
    maxStrSize As UShort
)
public:
void GetDeviceName(
    StringBuilder^ deviceName,
    unsigned short maxStrSize
)
member GetDeviceName :
        deviceName : StringBuilder *
        maxStrSize : uint16 -> unit

Parameters

deviceName
Type: System.TextStringBuilder
Device name
maxStrSize
Type: SystemUInt16
Reserved memory size for the device name

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetDeviceNameSelection Method

InitializationAdvancedGetDeviceNameSelection Method EposCmd.Net
Function "GetDeviceNameSelection" returns all available device names.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetDeviceNameSelection(
    int startOfSelection,
    ref string deviceNameSel,
    ref int endOfSelection
)
Public Sub GetDeviceNameSelection (
    startOfSelection As Integer,
    ByRef deviceNameSel As String,
    ByRef endOfSelection As Integer
)
public:
void GetDeviceNameSelection(
    int startOfSelection,
    String^% deviceNameSel,
    int% endOfSelection
)
member GetDeviceNameSelection :
        startOfSelection : int *
        deviceNameSel : string byref *
        endOfSelection : int byref -> unit

Parameters

startOfSelection
Type: SystemInt32
1: Get first selection string
0: Get next selection string
deviceNameSel
Type: SystemString
Device name
endOfSelection
Type: SystemInt32
1: No more string available
0: More string available

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetInterfaceName Method

InitializationAdvancedGetInterfaceName Method EposCmd.Net
Function "GetInterfaceName" returns the interface name to corresponding handle.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetInterfaceName(
    StringBuilder interfaceName,
    ushort maxStrSize
)
Public Sub GetInterfaceName (
    interfaceName As StringBuilder,
    maxStrSize As UShort
)
public:
void GetInterfaceName(
    StringBuilder^ interfaceName,
    unsigned short maxStrSize
)
member GetInterfaceName :
        interfaceName : StringBuilder *
        maxStrSize : uint16 -> unit

Parameters

interfaceName
Type: System.TextStringBuilder
Interface name
maxStrSize
Type: SystemUInt16
Reserved memory size for the interface name

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetInterfaceNameSelection Method

InitializationAdvancedGetInterfaceNameSelection Method EposCmd.Net
Function "GetInterfaceNameSelection" returns all available interface names.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetInterfaceNameSelection(
    string deviceName,
    string protocolStackName,
    int startOfSelection,
    ref string interfaceNameSel,
    ref int endOfSelection
)
Public Sub GetInterfaceNameSelection (
    deviceName As String,
    protocolStackName As String,
    startOfSelection As Integer,
    ByRef interfaceNameSel As String,
    ByRef endOfSelection As Integer
)
public:
void GetInterfaceNameSelection(
    String^ deviceName,
    String^ protocolStackName,
    int startOfSelection,
    String^% interfaceNameSel,
    int% endOfSelection
)
member GetInterfaceNameSelection :
        deviceName : string *
        protocolStackName : string *
        startOfSelection : int *
        interfaceNameSel : string byref *
        endOfSelection : int byref -> unit

Parameters

deviceName
Type: SystemString
Device name
protocolStackName
Type: SystemString
1: Get first selection string 0: Get next selection string
startOfSelection
Type: SystemInt32
1: Get first selection string 0: Get next selection string
interfaceNameSel
Type: SystemString
Interface name
endOfSelection
Type: SystemInt32
1: No more string available 0: More string available

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetKeyHandle Method

InitializationAdvancedGetKeyHandle Method EposCmd.Net
Function "GetKeyHandle" returns the key handle from the opened interface.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetKeyHandle(
    string deviceName,
    string protocolStackName,
    string interfaceName,
    string portName,
    ref int keyHandle
)
Public Sub GetKeyHandle (
    deviceName As String,
    protocolStackName As String,
    interfaceName As String,
    portName As String,
    ByRef keyHandle As Integer
)
public:
void GetKeyHandle(
    String^ deviceName,
    String^ protocolStackName,
    String^ interfaceName,
    String^ portName,
    int% keyHandle
)
member GetKeyHandle :
        deviceName : string *
        protocolStackName : string *
        interfaceName : string *
        portName : string *
        keyHandle : int byref -> unit

Parameters

deviceName
Type: SystemString
Device name
protocolStackName
Type: SystemString
Protocol stack name
interfaceName
Type: SystemString
Interface name
portName
Type: SystemString
Port name
keyHandle
Type: SystemInt32
The key handle

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetPortName Method

InitializationAdvancedGetPortName Method EposCmd.Net
Function "GetPortName" returns the port name to corresponding handle.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPortName(
    StringBuilder portName,
    ushort maxStrSize
)
Public Sub GetPortName (
    portName As StringBuilder,
    maxStrSize As UShort
)
public:
void GetPortName(
    StringBuilder^ portName,
    unsigned short maxStrSize
)
member GetPortName :
        portName : StringBuilder *
        maxStrSize : uint16 -> unit

Parameters

portName
Type: System.TextStringBuilder
Port name
maxStrSize
Type: SystemUInt16
Reserved memory size for the port name

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetPortNameSelection Method

InitializationAdvancedGetPortNameSelection Method EposCmd.Net
Function "GetPortNameSelection" returns all available port names.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPortNameSelection(
    string deviceName,
    string protocolStackName,
    string interfaceName,
    int startOfSelection,
    ref string portNameSel,
    ref int endOfSelection
)
Public Sub GetPortNameSelection (
    deviceName As String,
    protocolStackName As String,
    interfaceName As String,
    startOfSelection As Integer,
    ByRef portNameSel As String,
    ByRef endOfSelection As Integer
)
public:
void GetPortNameSelection(
    String^ deviceName,
    String^ protocolStackName,
    String^ interfaceName,
    int startOfSelection,
    String^% portNameSel,
    int% endOfSelection
)
member GetPortNameSelection :
        deviceName : string *
        protocolStackName : string *
        interfaceName : string *
        startOfSelection : int *
        portNameSel : string byref *
        endOfSelection : int byref -> unit

Parameters

deviceName
Type: SystemString
Device name
protocolStackName
Type: SystemString
Protocol stack name
interfaceName
Type: SystemString
Interface name
startOfSelection
Type: SystemInt32
1: Get first selection string
0: Get next selection string
portNameSel
Type: SystemString
Port name
endOfSelection
Type: SystemInt32
1: No more string available
0: More string available

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetProtocolStackName Method

InitializationAdvancedGetProtocolStackName Method EposCmd.Net
Function "GetProtocolStackName" returns the protocol stack name to corresponding handle.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetProtocolStackName(
    ref string protocolStackName,
    ushort maxStrSize
)
Public Sub GetProtocolStackName (
    ByRef protocolStackName As String,
    maxStrSize As UShort
)
public:
void GetProtocolStackName(
    String^% protocolStackName,
    unsigned short maxStrSize
)
member GetProtocolStackName :
        protocolStackName : string byref *
        maxStrSize : uint16 -> unit

Parameters

protocolStackName
Type: SystemString
Pointer to protocol stack name
maxStrSize
Type: SystemUInt16
Reserved memory size for the name

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced.GetProtocolStackNameSelection Method

InitializationAdvancedGetProtocolStackNameSelection Method EposCmd.Net
Function "GetProtocolStackNameSelection" returns all available protocol stack names.

Namespace: EposCmd.Net.DeviceCmdSet.Initialization
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetProtocolStackNameSelection(
    string deviceName,
    int startOfSelection,
    ref string protocolStackNameSel,
    ref int endOfSelection
)
Public Sub GetProtocolStackNameSelection (
    deviceName As String,
    startOfSelection As Integer,
    ByRef protocolStackNameSel As String,
    ByRef endOfSelection As Integer
)
public:
void GetProtocolStackNameSelection(
    String^ deviceName,
    int startOfSelection,
    String^% protocolStackNameSel,
    int% endOfSelection
)
member GetProtocolStackNameSelection :
        deviceName : string *
        startOfSelection : int *
        protocolStackNameSel : string byref *
        endOfSelection : int byref -> unit

Parameters

deviceName
Type: SystemString
Device name
startOfSelection
Type: SystemInt32
1: Get first selection string
0: Get next selection string
protocolStackNameSel
Type: SystemString
Protocol stack name
endOfSelection
Type: SystemInt32
1: No more string available
0: More string available

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


InitializationAdvanced Properties

InitializationAdvanced Properties EposCmd.Net

The InitializationAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

InitializationAdvanced Class
EposCmd.Net.DeviceCmdSet.Initialization Namespace


EposCmd.Net.DeviceCmdSet.LowLayer Namespace

EposCmd.Net.DeviceCmdSet.LowLayer Namespace EposCmd.Net
Classes
 | Class | Description
Public class | CanLayer | Can layer methods
Public class | LowLayer | Low layer methods


CanLayer Class

CanLayer Class EposCmd.Net
Can layer methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.LowLayerCanLayer

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class CanLayer : DeviceCommandGroup
Public Class CanLayer
    Inherits DeviceCommandGroup
public ref class CanLayer : public DeviceCommandGroup
type CanLayer =
    class
        inherit DeviceCommandGroup
    end

The CanLayer type exposes the following members.

Constructors
 | Name | Description
Public method | CanLayer | Initializes a new instance of the CanLayer class.
Top
Methods
 | Name | Description
Public method | ReadCanFrame | Function "ReadCANFrame" reads a general CAN Frame from the CAN bus.
Public method | RequestCanFrame | Function "RequestCANFrame" requests a general CAN Frame from the CAN bus using Remote Transmit Request (RTR).
Public method | SendCanFrame | Function "SendCANFrame" sends a general CAN Frame to the CAN bus.
Public method | SendNmtService | The function "SendNMTService" is used to send a NMT protocol from a master to a slave. It is a command without acknowledge.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer Constructor

CanLayer Constructor EposCmd.Net
Initializes a new instance of the CanLayer class.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CanLayer(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
CanLayer(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> CanLayer

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer Methods

CanLayer Methods EposCmd.Net

The CanLayer type exposes the following members.

Methods
 | Name | Description
Public method | ReadCanFrame | Function "ReadCANFrame" reads a general CAN Frame from the CAN bus.
Public method | RequestCanFrame | Function "RequestCANFrame" requests a general CAN Frame from the CAN bus using Remote Transmit Request (RTR).
Public method | SendCanFrame | Function "SendCANFrame" sends a general CAN Frame to the CAN bus.
Public method | SendNmtService | The function "SendNMTService" is used to send a NMT protocol from a master to a slave. It is a command without acknowledge.
Top
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer.ReadCanFrame Method

CanLayerReadCanFrame Method EposCmd.Net
Function "ReadCANFrame" reads a general CAN Frame from the CAN bus.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadCanFrame(
    ushort cobId,
    ushort length,
    byte[] data,
    uint timeout
)
Public Sub ReadCanFrame (
    cobId As UShort,
    length As UShort,
    data As Byte(),
    timeout As UInteger
)
public:
void ReadCanFrame(
    unsigned short cobId,
    unsigned short length,
    array<unsigned char>^ data,
    unsigned int timeout
)
member ReadCanFrame :
        cobId : uint16 *
        length : uint16 *
        data : byte[] *
        timeout : uint32 -> unit

Parameters

cobId
Type: SystemUInt16
CAN Frame 11-bit Identifier
length
Type: SystemUInt16
CAN Frame Data Length Code (DLC)
data
Type: SystemByte
CAN Frame Data
timeout
Type: SystemUInt32
Max. wait time

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer.RequestCanFrame Method

CanLayerRequestCanFrame Method EposCmd.Net
Function "RequestCANFrame" requests a general CAN Frame from the CAN bus using Remote Transmit Request (RTR).

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RequestCanFrame(
    ushort cobId,
    ushort length,
    byte[] data
)
Public Sub RequestCanFrame (
    cobId As UShort,
    length As UShort,
    data As Byte()
)
public:
void RequestCanFrame(
    unsigned short cobId,
    unsigned short length,
    array<unsigned char>^ data
)
member RequestCanFrame :
        cobId : uint16 *
        length : uint16 *
        data : byte[] -> unit

Parameters

cobId
Type: SystemUInt16
CAN Frame 11-bit Identifier
length
Type: SystemUInt16
CAN Frame Data Length Code (DLC)
data
Type: SystemByte
CAN Frame Data

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer.SendCanFrame Method

CanLayerSendCanFrame Method EposCmd.Net
Function "SendCANFrame" sends a general CAN Frame to the CAN bus.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SendCanFrame(
    ushort cobId,
    ushort length,
    byte[] data
)
Public Sub SendCanFrame (
    cobId As UShort,
    length As UShort,
    data As Byte()
)
public:
void SendCanFrame(
    unsigned short cobId,
    unsigned short length,
    array<unsigned char>^ data
)
member SendCanFrame :
        cobId : uint16 *
        length : uint16 *
        data : byte[] -> unit

Parameters

cobId
Type: SystemUInt16
CAN Frame 11-bit Identifier
length
Type: SystemUInt16
CAN Frame Data Length Code (DLC)
data
Type: SystemByte
CAN Frame Data

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer.SendNmtService Method

CanLayerSendNmtService Method EposCmd.Net
The function "SendNMTService" is used to send a NMT protocol from a master to a slave. It is a command without acknowledge.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SendNmtService(
    ECommandSpecifier commandSpecifier
)
Public Sub SendNmtService (
    commandSpecifier As ECommandSpecifier
)
public:
void SendNmtService(
    ECommandSpecifier commandSpecifier
)
member SendNmtService :
        commandSpecifier : ECommandSpecifier -> unit

Parameters

commandSpecifier
Type: EposCmd.NetECommandSpecifier
Following NMT services are available: 1 Start Remote Node 2 Stop Remote Node 128 Enter Pre-Operational 129 Reset Node 130 Reset Communication

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


CanLayer Properties

CanLayer Properties EposCmd.Net

The CanLayer type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

CanLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


LowLayer Class

LowLayer Class EposCmd.Net
Low layer methods
Inheritance Hierarchy
SystemObject
EposCmd.Net.DeviceCmdSet.LowLayerLowLayer

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class LowLayer
Public Class LowLayer
public ref class LowLayer
type LowLayer =  class end

The LowLayer type exposes the following members.

Constructors
 | Name | Description
Public method | LowLayer | Initializes a new instance of the LowLayer class.
Top
Properties
 | Name | Description
Public property | Can | Gets the can.
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.LowLayer Namespace


LowLayer Constructor

LowLayer Constructor EposCmd.Net
Initializes a new instance of the LowLayer class.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public LowLayer(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
LowLayer(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> LowLayer

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

LowLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


LowLayer Properties

LowLayer Properties EposCmd.Net

The LowLayer type exposes the following members.

Properties
 | Name | Description
Public property | Can | Gets the can.
Top
See Also

Reference

LowLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


LowLayer.Can Property

LowLayerCan Property EposCmd.Net
Gets the can.

Namespace: EposCmd.Net.DeviceCmdSet.LowLayer
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CanLayer Can { get; }
Public ReadOnly Property Can As CanLayer
    Get
public:
property CanLayer^ Can {
    CanLayer^ get ();
}
member Can : CanLayer with get

Property Value

Type: CanLayer
The can.
See Also

Reference

LowLayer Class
EposCmd.Net.DeviceCmdSet.LowLayer Namespace


EposCmd.Net.DeviceCmdSet.Operation Namespace

EposCmd.Net.DeviceCmdSet.Operation Namespace EposCmd.Net
Classes
 | Class | Description
Public class | CurrentMode | Current Mode methods
Public class | CurrentModeAdvanced | Advanced Current Mode methods
Public class | DeviceErrorHandling | Error Handling methods
Public class | HomingMode | Homing mode methods
Public class | InputOutput | Input-Output Mode methods
Public class | InterpolatedPositionMode | Interpolated Position mode methods
Public class | MasterEncoderMode | Master Encoder mode methods
Public class | MotionInfo | Motion Info methods
Public class | Operation | Epos Operation profiles
Public class | OperationMode | Operation mode methods
Public class | PositionCompare | Position Compare methods
Public class | PositionMarker | Position Marker methods
Public class | PositionMode | Position mode methods
Public class | PositionModeAdvanced | Advanced Position Mode methods
Public class | ProfilePositionMode | Profile Position Mode (PPM) methods
Public class | ProfilePositionModeAdvanced | Advanced Profile Position Mode (PPM)
Public class | ProfileVelocityMode | Profile Velocity mode methods
Public class | ProfileVelocityModeAdvanced | Advanced Profile Velocity Mode methods
Public class | StateMachine | State Machine methods
Public class | StepDirectionMode | Step Direction mode methods
Public class | VelocityMode | Velocity mode methods
Public class | VelocityModeAdvanced | Advanced Velocity mode methods


CurrentMode Class

CurrentMode Class EposCmd.Net
Current Mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationCurrentMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class CurrentMode : DeviceCommandGroup
Public Class CurrentMode
    Inherits DeviceCommandGroup
public ref class CurrentMode : public DeviceCommandGroup
type CurrentMode =
    class
        inherit DeviceCommandGroup
    end

The CurrentMode type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentMode | Initializes a new instance of the CurrentMode class.
Top
Methods
 | Name | Description
Public method | ActivateCurrentMode | "ActivateCurrentMode" change operational mode to current mode.
Public method | GetCurrentMust | With function "GetCurrentMust" it is possible to read the current mode setting value.
Public method | SetCurrentMust | With function "SetCurrentMust" it is possible to write current mode setting value.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode Constructor

CurrentMode Constructor EposCmd.Net
Initializes a new instance of the CurrentMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CurrentMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
CurrentMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> CurrentMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode Methods

CurrentMode Methods EposCmd.Net

The CurrentMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateCurrentMode | "ActivateCurrentMode" change operational mode to current mode.
Public method | GetCurrentMust | With function "GetCurrentMust" it is possible to read the current mode setting value.
Public method | SetCurrentMust | With function "SetCurrentMust" it is possible to write current mode setting value.
Top
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode.ActivateCurrentMode Method

CurrentModeActivateCurrentMode Method EposCmd.Net
"ActivateCurrentMode" change operational mode to current mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateCurrentMode()
Public Sub ActivateCurrentMode
public:
void ActivateCurrentMode()
member ActivateCurrentMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode.GetCurrentMust Method

CurrentModeGetCurrentMust Method EposCmd.Net
With function "GetCurrentMust" it is possible to read the current mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetCurrentMust(
    ref short currentMust
)
Public Sub GetCurrentMust (
    ByRef currentMust As Short
)
public:
void GetCurrentMust(
    short% currentMust
)
member GetCurrentMust :
        currentMust : int16 byref -> unit

Parameters

currentMust
Type: SystemInt16
Current mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode.SetCurrentMust Method

CurrentModeSetCurrentMust Method EposCmd.Net
With function "SetCurrentMust" it is possible to write current mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentMust(
    short currentMust
)
Public Sub SetCurrentMust (
    currentMust As Short
)
public:
void SetCurrentMust(
    short currentMust
)
member SetCurrentMust :
        currentMust : int16 -> unit

Parameters

currentMust
Type: SystemInt16
Current mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode Properties

CurrentMode Properties EposCmd.Net

The CurrentMode type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentMode.Advanced Property

CurrentModeAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CurrentModeAdvanced Advanced { get; }
Public ReadOnly Property Advanced As CurrentModeAdvanced
    Get
public:
property CurrentModeAdvanced^ Advanced {
    CurrentModeAdvanced^ get ();
}
member Advanced : CurrentModeAdvanced with get

Property Value

Type: CurrentModeAdvanced
The advanced.
See Also

Reference

CurrentMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced Class

CurrentModeAdvanced Class EposCmd.Net
Advanced Current Mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationCurrentModeAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class CurrentModeAdvanced : DeviceCommandGroup
Public Class CurrentModeAdvanced
    Inherits DeviceCommandGroup
public ref class CurrentModeAdvanced : public DeviceCommandGroup
type CurrentModeAdvanced =
    class
        inherit DeviceCommandGroup
    end

The CurrentModeAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentModeAdvanced | Initializes a new instance of the CurrentModeAdvanced class.
Top
Methods
 | Name | Description
Public method | ActivateAnalogCurrentSetpoint | "ActivateAnalogCurrentSetpoint" configures the selected analog input for analog current setpoint.
Public method | DeactivateAnalogCurrentSetpoint | "DeactivateAnalogCurrentSetpoint" disable the selected analog input for analog current setpoint.
Public method | DisableAnalogCurrentSetpoint | "DisableAnalogCurrentSetpoint" disable the execution mask for analog current setpoint.
Public method | EnableAnalogCurrentSetpoint | "EnableAnalogCurrentSetpoint" enable the execution mask for analog current setpoint.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced Constructor

CurrentModeAdvanced Constructor EposCmd.Net
Initializes a new instance of the CurrentModeAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CurrentModeAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
CurrentModeAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> CurrentModeAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced Methods

CurrentModeAdvanced Methods EposCmd.Net

The CurrentModeAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAnalogCurrentSetpoint | "ActivateAnalogCurrentSetpoint" configures the selected analog input for analog current setpoint.
Public method | DeactivateAnalogCurrentSetpoint | "DeactivateAnalogCurrentSetpoint" disable the selected analog input for analog current setpoint.
Public method | DisableAnalogCurrentSetpoint | "DisableAnalogCurrentSetpoint" disable the execution mask for analog current setpoint.
Public method | EnableAnalogCurrentSetpoint | "EnableAnalogCurrentSetpoint" enable the execution mask for analog current setpoint.
Top
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced.ActivateAnalogCurrentSetpoint Method

CurrentModeAdvancedActivateAnalogCurrentSetpoint Method EposCmd.Net
"ActivateAnalogCurrentSetpoint" configures the selected analog input for analog current setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateAnalogCurrentSetpoint(
    ushort analogInputNumber,
    float scaling,
    short offset
)
Public Sub ActivateAnalogCurrentSetpoint (
    analogInputNumber As UShort,
    scaling As Single,
    offset As Short
)
public:
void ActivateAnalogCurrentSetpoint(
    unsigned short analogInputNumber,
    float scaling,
    short offset
)
member ActivateAnalogCurrentSetpoint :
        analogInputNumber : uint16 *
        scaling : float32 *
        offset : int16 -> unit

Parameters

analogInputNumber
Type: SystemUInt16
Number of the used analog input
scaling
Type: SystemSingle
The scaling factor for analog current setpoint functionality
offset
Type: SystemInt16
Offset for analog current setpoint functionality

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced.DeactivateAnalogCurrentSetpoint Method

CurrentModeAdvancedDeactivateAnalogCurrentSetpoint Method EposCmd.Net
"DeactivateAnalogCurrentSetpoint" disable the selected analog input for analog current setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateAnalogCurrentSetpoint(
    ushort analogInputNumber
)
Public Sub DeactivateAnalogCurrentSetpoint (
    analogInputNumber As UShort
)
public:
void DeactivateAnalogCurrentSetpoint(
    unsigned short analogInputNumber
)
member DeactivateAnalogCurrentSetpoint :
        analogInputNumber : uint16 -> unit

Parameters

analogInputNumber
Type: SystemUInt16
Number of the used analog input

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced.DisableAnalogCurrentSetpoint Method

CurrentModeAdvancedDisableAnalogCurrentSetpoint Method EposCmd.Net
"DisableAnalogCurrentSetpoint" disable the execution mask for analog current setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableAnalogCurrentSetpoint()
Public Sub DisableAnalogCurrentSetpoint
public:
void DisableAnalogCurrentSetpoint()
member DisableAnalogCurrentSetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced.EnableAnalogCurrentSetpoint Method

CurrentModeAdvancedEnableAnalogCurrentSetpoint Method EposCmd.Net
"EnableAnalogCurrentSetpoint" enable the execution mask for analog current setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableAnalogCurrentSetpoint()
Public Sub EnableAnalogCurrentSetpoint
public:
void EnableAnalogCurrentSetpoint()
member EnableAnalogCurrentSetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


CurrentModeAdvanced Properties

CurrentModeAdvanced Properties EposCmd.Net

The CurrentModeAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

CurrentModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling Class

DeviceErrorHandling Class EposCmd.Net
Error Handling methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationDeviceErrorHandling

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DeviceErrorHandling : DeviceCommandGroup
Public Class DeviceErrorHandling
    Inherits DeviceCommandGroup
public ref class DeviceErrorHandling : public DeviceCommandGroup
type DeviceErrorHandling =
    class
        inherit DeviceCommandGroup
    end

The DeviceErrorHandling type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceErrorHandling | Initializes a new instance of the DeviceErrorHandling class.
Top
Methods
 | Name | Description
Public method | GetDeviceErrorCode | "GetNbOfDeviceError" returns the error code of selected sub-index.
Public method | GetNbOfDeviceError | "GetNbOfDeviceError" returns the number of actual errors that are recorded.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling Constructor

DeviceErrorHandling Constructor EposCmd.Net
Initializes a new instance of the DeviceErrorHandling class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceErrorHandling(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
DeviceErrorHandling(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> DeviceErrorHandling

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

DeviceErrorHandling Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling Methods

DeviceErrorHandling Methods EposCmd.Net

The DeviceErrorHandling type exposes the following members.

Methods
 | Name | Description
Public method | GetDeviceErrorCode | "GetNbOfDeviceError" returns the error code of selected sub-index.
Public method | GetNbOfDeviceError | "GetNbOfDeviceError" returns the number of actual errors that are recorded.
Top
See Also

Reference

DeviceErrorHandling Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling.GetDeviceErrorCode Method

DeviceErrorHandlingGetDeviceErrorCode Method EposCmd.Net
"GetNbOfDeviceError" returns the error code of selected sub-index.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetDeviceErrorCode(
    byte deviceErrorNumber,
    ref uint deviceErrorCode
)
Public Sub GetDeviceErrorCode (
    deviceErrorNumber As Byte,
    ByRef deviceErrorCode As UInteger
)
public:
void GetDeviceErrorCode(
    unsigned char deviceErrorNumber,
    unsigned int% deviceErrorCode
)
member GetDeviceErrorCode :
        deviceErrorNumber : byte *
        deviceErrorCode : uint32 byref -> unit

Parameters

deviceErrorNumber
Type: SystemByte
Object sub-index of device error.
deviceErrorCode
Type: SystemUInt32
Actual error code from error history.

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

DeviceErrorHandling Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling.GetNbOfDeviceError Method

DeviceErrorHandlingGetNbOfDeviceError Method EposCmd.Net
"GetNbOfDeviceError" returns the number of actual errors that are recorded.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetNbOfDeviceError(
    ref byte deviceError
)
Public Sub GetNbOfDeviceError (
    ByRef deviceError As Byte
)
public:
void GetNbOfDeviceError(
    unsigned char% deviceError
)
member GetNbOfDeviceError :
        deviceError : byte byref -> unit

Parameters

deviceError
Type: SystemByte
Number of occurred device errors.

Return Value

Type:
In the case of the failure, throws the exception with the error code.
See Also

Reference

DeviceErrorHandling Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


DeviceErrorHandling Properties

DeviceErrorHandling Properties EposCmd.Net

The DeviceErrorHandling type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

DeviceErrorHandling Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode Class

HomingMode Class EposCmd.Net
Homing mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationHomingMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class HomingMode : DeviceCommandGroup
Public Class HomingMode
    Inherits DeviceCommandGroup
public ref class HomingMode : public DeviceCommandGroup
type HomingMode =
    class
        inherit DeviceCommandGroup
    end

The HomingMode type exposes the following members.

Constructors
 | Name | Description
Public method | HomingMode | Initializes a new instance of the HomingMode class.
Top
Methods
 | Name | Description
Public method | ActivateHomingMode | With the function "ActivateHomingMode" the device changes to homing mode (HM).
Public method | DefinePosition | The function "DefinePosition" is using homing method 35 (Actual Position) to set a new home position.
Public method | FindHome | With function "FindHome" and the parameter "HomingMethod" it is possible to find the system home. For example a home switch.
Public method | GetHomingParameter | With function "GetHomingParameter" it is possible to read all homing parameters.
Public method | GetHomingState | With "GetHomingState" it is possible to check, if drive has attained homing position.
Public method | SetHomingParameter | With function "SetHomingParameter" it is possible to write all homing parameters.
Public method | StopHoming | The function "StopHoming" interrupts homing.
Public method | WaitForHomingAttained | "WaitForHomingAttained" is waiting until the state is changed to homing attained or the time is up.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode Constructor

HomingMode Constructor EposCmd.Net
Initializes a new instance of the HomingMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public HomingMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
HomingMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> HomingMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode Methods

HomingMode Methods EposCmd.Net

The HomingMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateHomingMode | With the function "ActivateHomingMode" the device changes to homing mode (HM).
Public method | DefinePosition | The function "DefinePosition" is using homing method 35 (Actual Position) to set a new home position.
Public method | FindHome | With function "FindHome" and the parameter "HomingMethod" it is possible to find the system home. For example a home switch.
Public method | GetHomingParameter | With function "GetHomingParameter" it is possible to read all homing parameters.
Public method | GetHomingState | With "GetHomingState" it is possible to check, if drive has attained homing position.
Public method | SetHomingParameter | With function "SetHomingParameter" it is possible to write all homing parameters.
Public method | StopHoming | The function "StopHoming" interrupts homing.
Public method | WaitForHomingAttained | "WaitForHomingAttained" is waiting until the state is changed to homing attained or the time is up.
Top
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.ActivateHomingMode Method

HomingModeActivateHomingMode Method EposCmd.Net
With the function "ActivateHomingMode" the device changes to homing mode (HM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateHomingMode()
Public Sub ActivateHomingMode
public:
void ActivateHomingMode()
member ActivateHomingMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.DefinePosition Method

HomingModeDefinePosition Method EposCmd.Net
The function "DefinePosition" is using homing method 35 (Actual Position) to set a new home position.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DefinePosition(
    int homePosition
)
Public Sub DefinePosition (
    homePosition As Integer
)
public:
void DefinePosition(
    int homePosition
)
member DefinePosition :
        homePosition : int -> unit

Parameters

homePosition
Type: SystemInt32
Assign the homing position with this value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.FindHome Method

HomingModeFindHome Method EposCmd.Net
With function "FindHome" and the parameter "HomingMethod" it is possible to find the
system home. For example a home switch.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void FindHome(
    EHomingMethod homingMethod
)
Public Sub FindHome (
    homingMethod As EHomingMethod
)
public:
void FindHome(
    EHomingMethod homingMethod
)
member FindHome :
        homingMethod : EHomingMethod -> unit

Parameters

homingMethod
Type: EposCmd.NetEHomingMethod
Homing method

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.GetHomingParameter Method

HomingModeGetHomingParameter Method EposCmd.Net
With function "GetHomingParameter" it is possible to read all homing parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetHomingParameter(
    ref uint homingAcceleration,
    ref uint speedSwitch,
    ref uint speedIndex,
    ref int homeOffset,
    ref ushort currentTreshold,
    ref int homePosition
)
Public Sub GetHomingParameter (
    ByRef homingAcceleration As UInteger,
    ByRef speedSwitch As UInteger,
    ByRef speedIndex As UInteger,
    ByRef homeOffset As Integer,
    ByRef currentTreshold As UShort,
    ByRef homePosition As Integer
)
public:
void GetHomingParameter(
    unsigned int% homingAcceleration,
    unsigned int% speedSwitch,
    unsigned int% speedIndex,
    int% homeOffset,
    unsigned short% currentTreshold,
    int% homePosition
)
member GetHomingParameter :
        homingAcceleration : uint32 byref *
        speedSwitch : uint32 byref *
        speedIndex : uint32 byref *
        homeOffset : int byref *
        currentTreshold : uint16 byref *
        homePosition : int byref -> unit

Parameters

homingAcceleration
Type: SystemUInt32
Acceleration for homing profile
speedSwitch
Type: SystemUInt32
Speed during search for switch
speedIndex
Type: SystemUInt32
Speed during search for index signal
homeOffset
Type: SystemInt32
Home offset after homing
currentTreshold
Type: SystemUInt16
Current threshold for homing method -1, -2, -3 and -4
homePosition
Type: SystemInt32
Home position value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.GetHomingState Method

HomingModeGetHomingState Method EposCmd.Net
With "GetHomingState" it is possible to check, if drive has attained homing position.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetHomingState(
    ref bool homingAttained,
    ref bool homingError
)
Public Sub GetHomingState (
    ByRef homingAttained As Boolean,
    ByRef homingError As Boolean
)
public:
void GetHomingState(
    bool% homingAttained,
    bool% homingError
)
member GetHomingState :
        homingAttained : bool byref *
        homingError : bool byref -> unit

Parameters

homingAttained
Type: SystemBoolean
The drive has attained homing position. The function reads current state of bit 12 from the status word.
homingError
Type: SystemBoolean
An error occured during homing. The function reads current state of bit 13 from the status word.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.SetHomingParameter Method

HomingModeSetHomingParameter Method EposCmd.Net
With function "SetHomingParameter" it is possible to write all homing parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetHomingParameter(
    uint homingAcceleration,
    uint speedSwitch,
    uint speedIndex,
    int homeOffset,
    ushort currentTreshold,
    int homePosition
)
Public Sub SetHomingParameter (
    homingAcceleration As UInteger,
    speedSwitch As UInteger,
    speedIndex As UInteger,
    homeOffset As Integer,
    currentTreshold As UShort,
    homePosition As Integer
)
public:
void SetHomingParameter(
    unsigned int homingAcceleration,
    unsigned int speedSwitch,
    unsigned int speedIndex,
    int homeOffset,
    unsigned short currentTreshold,
    int homePosition
)
member SetHomingParameter :
        homingAcceleration : uint32 *
        speedSwitch : uint32 *
        speedIndex : uint32 *
        homeOffset : int *
        currentTreshold : uint16 *
        homePosition : int -> unit

Parameters

homingAcceleration
Type: SystemUInt32
Acceleration for homing profile
speedSwitch
Type: SystemUInt32
Speed during search for switch
speedIndex
Type: SystemUInt32
Speed during search for index signal
homeOffset
Type: SystemInt32
Home offset after homing
currentTreshold
Type: SystemUInt16
Current threshold for homing method -1, -2, -3 and -4
homePosition
Type: SystemInt32
Assign the current Homing position with this value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.StopHoming Method

HomingModeStopHoming Method EposCmd.Net
The function "StopHoming" interrupts homing.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void StopHoming()
Public Sub StopHoming
public:
void StopHoming()
member StopHoming : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode.WaitForHomingAttained Method

HomingModeWaitForHomingAttained Method EposCmd.Net
"WaitForHomingAttained" is waiting until the state is changed to homing attained or the time is up.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void WaitForHomingAttained(
    uint timeout
)
Public Sub WaitForHomingAttained (
    timeout As UInteger
)
public:
void WaitForHomingAttained(
    unsigned int timeout
)
member WaitForHomingAttained :
        timeout : uint32 -> unit

Parameters

timeout
Type: SystemUInt32
The timeout.
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


HomingMode Properties

HomingMode Properties EposCmd.Net

The HomingMode type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

HomingMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput Class

InputOutput Class EposCmd.Net
Input-Output Mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationInputOutput

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class InputOutput : DeviceCommandGroup
Public Class InputOutput
    Inherits DeviceCommandGroup
public ref class InputOutput : public DeviceCommandGroup
type InputOutput =
    class
        inherit DeviceCommandGroup
    end

The InputOutput type exposes the following members.

Constructors
 | Name | Description
Public method | InputOutput | Initializes a new instance of the InputOutput class.
Top
Methods
 | Name | Description
Public method | GetAllDigitalInputs | "GetAllDigitalInputs" returns state of all digital inputs.
Public method | GetAllDigitalOutputs | "GetAllDigitalOutputs" returns state of all digital outputs.
Public method | GetAnalogInput | "GetAnalogInput" returns the value from an analog input.
Public method | SetAllDigitalOutputs | "SetAllDigitalOutputs" set state of all digital outputs.
Public method | SetAnalogOutput | "SetAnalogOutput" set the voltage level of an analog output.
Top
Properties
 | Name | Description
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Public property | PositionCompare | Gets the position compare methods.
Public property | PositionMarker | Gets the position marker methods.
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput Constructor

InputOutput Constructor EposCmd.Net
Initializes a new instance of the InputOutput class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InputOutput(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
InputOutput(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> InputOutput

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput Methods

InputOutput Methods EposCmd.Net

The InputOutput type exposes the following members.

Methods
 | Name | Description
Public method | GetAllDigitalInputs | "GetAllDigitalInputs" returns state of all digital inputs.
Public method | GetAllDigitalOutputs | "GetAllDigitalOutputs" returns state of all digital outputs.
Public method | GetAnalogInput | "GetAnalogInput" returns the value from an analog input.
Public method | SetAllDigitalOutputs | "SetAllDigitalOutputs" set state of all digital outputs.
Public method | SetAnalogOutput | "SetAnalogOutput" set the voltage level of an analog output.
Top
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.GetAllDigitalInputs Method

InputOutputGetAllDigitalInputs Method EposCmd.Net
"GetAllDigitalInputs" returns state of all digital inputs.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetAllDigitalInputs(
    ref ushort inputs
)
Public Sub GetAllDigitalInputs (
    ByRef inputs As UShort
)
public:
void GetAllDigitalInputs(
    unsigned short% inputs
)
member GetAllDigitalInputs :
        inputs : uint16 byref -> unit

Parameters

inputs
Type: SystemUInt16

Display the state of the digital input functionalities.
If a bit is read as “1", the functionality is activated

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.GetAllDigitalOutputs Method

InputOutputGetAllDigitalOutputs Method EposCmd.Net
"GetAllDigitalOutputs" returns state of all digital outputs.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetAllDigitalOutputs(
    ref ushort outputs
)
Public Sub GetAllDigitalOutputs (
    ByRef outputs As UShort
)
public:
void GetAllDigitalOutputs(
    unsigned short% outputs
)
member GetAllDigitalOutputs :
        outputs : uint16 byref -> unit

Parameters

outputs
Type: SystemUInt16
State of all digital outputs. Activated if a bit is read as “1”.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.GetAnalogInput Method

InputOutputGetAnalogInput Method EposCmd.Net
"GetAnalogInput" returns the value from an analog input.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetAnalogInput(
    ushort inputNumber,
    ref ushort analogValue
)
Public Sub GetAnalogInput (
    inputNumber As UShort,
    ByRef analogValue As UShort
)
public:
void GetAnalogInput(
    unsigned short inputNumber,
    unsigned short% analogValue
)
member GetAnalogInput :
        inputNumber : uint16 *
        analogValue : uint16 byref -> unit

Parameters

inputNumber
Type: SystemUInt16
Analog input number
analogValue
Type: SystemUInt16
Analog value from input

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.SetAllDigitalOutputs Method

InputOutputSetAllDigitalOutputs Method EposCmd.Net
"SetAllDigitalOutputs" set state of all digital outputs.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAllDigitalOutputs(
    ushort outputs
)
Public Sub SetAllDigitalOutputs (
    outputs As UShort
)
public:
void SetAllDigitalOutputs(
    unsigned short outputs
)
member SetAllDigitalOutputs :
        outputs : uint16 -> unit

Parameters

outputs
Type: SystemUInt16
State of all digital outputs. If a bit is written as “1", the state is activated.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.SetAnalogOutput Method

InputOutputSetAnalogOutput Method EposCmd.Net
"SetAnalogOutput" set the voltage level of an analog output.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAnalogOutput(
    ushort outputNumber,
    ushort analogValue
)
Public Sub SetAnalogOutput (
    outputNumber As UShort,
    analogValue As UShort
)
public:
void SetAnalogOutput(
    unsigned short outputNumber,
    unsigned short analogValue
)
member SetAnalogOutput :
        outputNumber : uint16 *
        analogValue : uint16 -> unit

Parameters

outputNumber
Type: SystemUInt16
Analog output number
analogValue
Type: SystemUInt16
Analog value for output

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput Properties

InputOutput Properties EposCmd.Net

The InputOutput type exposes the following members.

Properties
 | Name | Description
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Public property | PositionCompare | Gets the position compare methods.
Public property | PositionMarker | Gets the position marker methods.
Top
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.PositionCompare Property

InputOutputPositionCompare Property EposCmd.Net
Gets the position compare methods.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionCompare PositionCompare { get; }
Public ReadOnly Property PositionCompare As PositionCompare
    Get
public:
property PositionCompare^ PositionCompare {
    PositionCompare^ get ();
}
member PositionCompare : PositionCompare with get

Property Value

Type: PositionCompare
The position compare.
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InputOutput.PositionMarker Property

InputOutputPositionMarker Property EposCmd.Net
Gets the position marker methods.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionMarker PositionMarker { get; }
Public ReadOnly Property PositionMarker As PositionMarker
    Get
public:
property PositionMarker^ PositionMarker {
    PositionMarker^ get ();
}
member PositionMarker : PositionMarker with get

Property Value

Type: PositionMarker
The position compare.
See Also

Reference

InputOutput Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode Class

InterpolatedPositionMode Class EposCmd.Net
Interpolated Position mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationInterpolatedPositionMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class InterpolatedPositionMode : DeviceCommandGroup
Public Class InterpolatedPositionMode
    Inherits DeviceCommandGroup
public ref class InterpolatedPositionMode : public DeviceCommandGroup
type InterpolatedPositionMode =
    class
        inherit DeviceCommandGroup
    end

The InterpolatedPositionMode type exposes the following members.

Constructors
 | Name | Description
Public method | InterpolatedPositionMode | Initializes a new instance of the InterpolatedPositionMode class.
Top
Methods
 | Name | Description
Public method | ActivateInterpolatedPositionMode | With the function "ActivateInterpolatedPositionMode" the device changes to interpolated position mode (IPM).
Public method | AddPvtValueToIpmBuffer | The function "AddPvtValueToIpmBuffer" add a new PVT reference point to the device.
Public method | ClearIpmBuffer | The function "ClearIpmBuffer" clears input buffer and enables the access to the input buffer for the drive functions.
Public method | GetFreeIpmBufferSize | The function "GetFreeIpmBufferSize" read the actual free buffer size.
Public method | GetIpmBufferParameter | The function "GetIpmBufferParameter" read warning borders and the max. buffer size of the data input.
Public method | GetIpmStatus | The function "GetIpmStatus"
Public method | SetIpmBufferParameter | The function "SetIpmBufferParameter" set warning borders of the data input.
Public method | StartIpmTrajectory | The function "StartIpmTrajectory" starts the IPM trajectory.
Public method | StopIpmTrajectory | The function "StopIpmTrajectory" stops the IPM trajectory.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode Constructor

InterpolatedPositionMode Constructor EposCmd.Net
Initializes a new instance of the InterpolatedPositionMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InterpolatedPositionMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
InterpolatedPositionMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> InterpolatedPositionMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode Methods

InterpolatedPositionMode Methods EposCmd.Net

The InterpolatedPositionMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateInterpolatedPositionMode | With the function "ActivateInterpolatedPositionMode" the device changes to interpolated position mode (IPM).
Public method | AddPvtValueToIpmBuffer | The function "AddPvtValueToIpmBuffer" add a new PVT reference point to the device.
Public method | ClearIpmBuffer | The function "ClearIpmBuffer" clears input buffer and enables the access to the input buffer for the drive functions.
Public method | GetFreeIpmBufferSize | The function "GetFreeIpmBufferSize" read the actual free buffer size.
Public method | GetIpmBufferParameter | The function "GetIpmBufferParameter" read warning borders and the max. buffer size of the data input.
Public method | GetIpmStatus | The function "GetIpmStatus"
Public method | SetIpmBufferParameter | The function "SetIpmBufferParameter" set warning borders of the data input.
Public method | StartIpmTrajectory | The function "StartIpmTrajectory" starts the IPM trajectory.
Public method | StopIpmTrajectory | The function "StopIpmTrajectory" stops the IPM trajectory.
Top
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.ActivateInterpolatedPositionMode Method

InterpolatedPositionModeActivateInterpolatedPositionMode Method EposCmd.Net
With the function "ActivateInterpolatedPositionMode" the device changes to interpolated position mode (IPM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateInterpolatedPositionMode()
Public Sub ActivateInterpolatedPositionMode
public:
void ActivateInterpolatedPositionMode()
member ActivateInterpolatedPositionMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.AddPvtValueToIpmBuffer Method

InterpolatedPositionModeAddPvtValueToIpmBuffer Method EposCmd.Net
The function "AddPvtValueToIpmBuffer" add a new PVT reference point to the device.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddPvtValueToIpmBuffer(
    int position,
    int velocity,
    byte time
)
Public Sub AddPvtValueToIpmBuffer (
    position As Integer,
    velocity As Integer,
    time As Byte
)
public:
void AddPvtValueToIpmBuffer(
    int position,
    int velocity,
    unsigned char time
)
member AddPvtValueToIpmBuffer :
        position : int *
        velocity : int *
        time : byte -> unit

Parameters

position
Type: SystemInt32
Position of the reference point
velocity
Type: SystemInt32
Velocity of the reference point
time
Type: SystemByte
Time of the reference point

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.ClearIpmBuffer Method

InterpolatedPositionModeClearIpmBuffer Method EposCmd.Net
The function "ClearIpmBuffer" clears input buffer and enables the access to the input buffer for the drive functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearIpmBuffer()
Public Sub ClearIpmBuffer
public:
void ClearIpmBuffer()
member ClearIpmBuffer : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.GetFreeIpmBufferSize Method

InterpolatedPositionModeGetFreeIpmBufferSize Method EposCmd.Net
The function "GetFreeIpmBufferSize" read the actual free buffer size.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetFreeIpmBufferSize(
    ref uint bufferSize
)
Public Sub GetFreeIpmBufferSize (
    ByRef bufferSize As UInteger
)
public:
void GetFreeIpmBufferSize(
    unsigned int% bufferSize
)
member GetFreeIpmBufferSize :
        bufferSize : uint32 byref -> unit

Parameters

bufferSize
Type: SystemUInt32
Actual free buffer size

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.GetIpmBufferParameter Method

InterpolatedPositionModeGetIpmBufferParameter Method EposCmd.Net
The function "GetIpmBufferParameter" read warning borders and the max. buffer size of the data input.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetIpmBufferParameter(
    ref ushort underflowWarningLimit,
    ref ushort overflowWarningLimit,
    ref uint maxBufferSize
)
Public Sub GetIpmBufferParameter (
    ByRef underflowWarningLimit As UShort,
    ByRef overflowWarningLimit As UShort,
    ByRef maxBufferSize As UInteger
)
public:
void GetIpmBufferParameter(
    unsigned short% underflowWarningLimit,
    unsigned short% overflowWarningLimit,
    unsigned int% maxBufferSize
)
member GetIpmBufferParameter :
        underflowWarningLimit : uint16 byref *
        overflowWarningLimit : uint16 byref *
        maxBufferSize : uint32 byref -> unit

Parameters

underflowWarningLimit
Type: SystemUInt16
This object gives lower signalization level of the data input FIFO
overflowWarningLimit
Type: SystemUInt16
This object gives the higher signalization level of the data input FIFO
maxBufferSize
Type: SystemUInt32
This object provides the maximal buffer size

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.GetIpmStatus Method

InterpolatedPositionModeGetIpmStatus Method EposCmd.Net
The function "GetIpmStatus"

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetIpmStatus(
    ref int trajectoryRunning,
    ref int isUnderflowWarning,
    ref int isOverflowWarning,
    ref int isVelocityWarning,
    ref int isAccelerationWarning,
    ref int isUnderflowError,
    ref int isOverflowError,
    ref int isVelocityError,
    ref int isAccelerationError
)
Public Sub GetIpmStatus (
    ByRef trajectoryRunning As Integer,
    ByRef isUnderflowWarning As Integer,
    ByRef isOverflowWarning As Integer,
    ByRef isVelocityWarning As Integer,
    ByRef isAccelerationWarning As Integer,
    ByRef isUnderflowError As Integer,
    ByRef isOverflowError As Integer,
    ByRef isVelocityError As Integer,
    ByRef isAccelerationError As Integer
)
public:
void GetIpmStatus(
    int% trajectoryRunning,
    int% isUnderflowWarning,
    int% isOverflowWarning,
    int% isVelocityWarning,
    int% isAccelerationWarning,
    int% isUnderflowError,
    int% isOverflowError,
    int% isVelocityError,
    int% isAccelerationError
)
member GetIpmStatus :
        trajectoryRunning : int byref *
        isUnderflowWarning : int byref *
        isOverflowWarning : int byref *
        isVelocityWarning : int byref *
        isAccelerationWarning : int byref *
        isUnderflowError : int byref *
        isOverflowError : int byref *
        isVelocityError : int byref *
        isAccelerationError : int byref -> unit

Parameters

trajectoryRunning
Type: SystemInt32
State if IPM active
isUnderflowWarning
Type: SystemInt32
State if buffer underflow level is reached
isOverflowWarning
Type: SystemInt32
State if buffer overflow level is reached
isVelocityWarning
Type: SystemInt32
State if IPM velocity greater than profile velocity
isAccelerationWarning
Type: SystemInt32
State if IPM acceleration greater than profile acceleration
isUnderflowError
Type: SystemInt32
State of underflow error
isOverflowError
Type: SystemInt32
State of overflow error
isVelocityError
Type: SystemInt32
State if IPM velocity greater than max. profile velocity
isAccelerationError
Type: SystemInt32
State if IPM acceleration greater than max. profile acceleration

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.SetIpmBufferParameter Method

InterpolatedPositionModeSetIpmBufferParameter Method EposCmd.Net
The function "SetIpmBufferParameter" set warning borders of the data input.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIpmBufferParameter(
    ushort underflowWarningLimit,
    ushort overflowWarningLimit
)
Public Sub SetIpmBufferParameter (
    underflowWarningLimit As UShort,
    overflowWarningLimit As UShort
)
public:
void SetIpmBufferParameter(
    unsigned short underflowWarningLimit,
    unsigned short overflowWarningLimit
)
member SetIpmBufferParameter :
        underflowWarningLimit : uint16 *
        overflowWarningLimit : uint16 -> unit

Parameters

underflowWarningLimit
Type: SystemUInt16
This object gives lower signalization level of the data input FIFO
overflowWarningLimit
Type: SystemUInt16
This object gives the higher signalization level of the data input FIFO

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.StartIpmTrajectory Method

InterpolatedPositionModeStartIpmTrajectory Method EposCmd.Net
The function "StartIpmTrajectory" starts the IPM trajectory.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void StartIpmTrajectory()
Public Sub StartIpmTrajectory
public:
void StartIpmTrajectory()
member StartIpmTrajectory : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode.StopIpmTrajectory Method

InterpolatedPositionModeStopIpmTrajectory Method EposCmd.Net
The function "StopIpmTrajectory" stops the IPM trajectory.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void StopIpmTrajectory()
Public Sub StopIpmTrajectory
public:
void StopIpmTrajectory()
member StopIpmTrajectory : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


InterpolatedPositionMode Properties

InterpolatedPositionMode Properties EposCmd.Net

The InterpolatedPositionMode type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

InterpolatedPositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode Class

MasterEncoderMode Class EposCmd.Net
Master Encoder mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationMasterEncoderMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class MasterEncoderMode : DeviceCommandGroup
Public Class MasterEncoderMode
    Inherits DeviceCommandGroup
public ref class MasterEncoderMode : public DeviceCommandGroup
type MasterEncoderMode =
    class
        inherit DeviceCommandGroup
    end

The MasterEncoderMode type exposes the following members.

Constructors
 | Name | Description
Public method | MasterEncoderMode | Initializes a new instance of the MasterEncoderMode class.
Top
Methods
 | Name | Description
Public method | ActivateMasterEncoderMode | With the function "ActivateMasterEncoderMode" the device changes to master encoder mode (MEM).
Public method | GetMasterEncoderParameter | With function "GetMasterEncoderParameter" it is possible to read all parameters for master encoder mode.
Public method | SetMasterEncoderParameter | With function "SetMasterEncoderParameter" it is possible to write all parameters for master encoder mode.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode Constructor

MasterEncoderMode Constructor EposCmd.Net
Initializes a new instance of the MasterEncoderMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public MasterEncoderMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
MasterEncoderMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> MasterEncoderMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode Methods

MasterEncoderMode Methods EposCmd.Net

The MasterEncoderMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateMasterEncoderMode | With the function "ActivateMasterEncoderMode" the device changes to master encoder mode (MEM).
Public method | GetMasterEncoderParameter | With function "GetMasterEncoderParameter" it is possible to read all parameters for master encoder mode.
Public method | SetMasterEncoderParameter | With function "SetMasterEncoderParameter" it is possible to write all parameters for master encoder mode.
Top
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode.ActivateMasterEncoderMode Method

MasterEncoderModeActivateMasterEncoderMode Method EposCmd.Net
With the function "ActivateMasterEncoderMode" the device changes to master encoder mode (MEM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateMasterEncoderMode()
Public Sub ActivateMasterEncoderMode
public:
void ActivateMasterEncoderMode()
member ActivateMasterEncoderMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode.GetMasterEncoderParameter Method

MasterEncoderModeGetMasterEncoderParameter Method EposCmd.Net
With function "GetMasterEncoderParameter" it is possible to read all parameters for master encoder mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetMasterEncoderParameter(
    ref ushort scalingNumerator,
    ref ushort scalingDenominator,
    ref byte polarity,
    ref uint maxVelocity,
    ref uint maxAcceleration
)
Public Sub GetMasterEncoderParameter (
    ByRef scalingNumerator As UShort,
    ByRef scalingDenominator As UShort,
    ByRef polarity As Byte,
    ByRef maxVelocity As UInteger,
    ByRef maxAcceleration As UInteger
)
public:
void GetMasterEncoderParameter(
    unsigned short% scalingNumerator,
    unsigned short% scalingDenominator,
    unsigned char% polarity,
    unsigned int% maxVelocity,
    unsigned int% maxAcceleration
)
member GetMasterEncoderParameter :
        scalingNumerator : uint16 byref *
        scalingDenominator : uint16 byref *
        polarity : byte byref *
        maxVelocity : uint32 byref *
        maxAcceleration : uint32 byref -> unit

Parameters

scalingNumerator
Type: SystemUInt16
Scaling numerator for position calculation
scalingDenominator
Type: SystemUInt16
Scaling denominator for position calculation
polarity
Type: SystemByte
Polarity of the direction input. 0: Positive 1: Negative
maxVelocity
Type: SystemUInt32
This parameter is the maximal allowed speed during a profiled move.
maxAcceleration
Type: SystemUInt32
Defines the maximal allowed acceleration.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode.SetMasterEncoderParameter Method

MasterEncoderModeSetMasterEncoderParameter Method EposCmd.Net
With function "SetMasterEncoderParameter" it is possible to write all parameters for master encoder mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMasterEncoderParameter(
    ushort scalingNumerator,
    ushort scalingDenominator,
    byte polarity,
    uint maxVelocity,
    uint maxAcceleration
)
Public Sub SetMasterEncoderParameter (
    scalingNumerator As UShort,
    scalingDenominator As UShort,
    polarity As Byte,
    maxVelocity As UInteger,
    maxAcceleration As UInteger
)
public:
void SetMasterEncoderParameter(
    unsigned short scalingNumerator,
    unsigned short scalingDenominator,
    unsigned char polarity,
    unsigned int maxVelocity,
    unsigned int maxAcceleration
)
member SetMasterEncoderParameter :
        scalingNumerator : uint16 *
        scalingDenominator : uint16 *
        polarity : byte *
        maxVelocity : uint32 *
        maxAcceleration : uint32 -> unit

Parameters

scalingNumerator
Type: SystemUInt16
Scaling numerator for position calculation
scalingDenominator
Type: SystemUInt16
Scaling denominator for position calculation
polarity
Type: SystemByte
Polarity of the direction input. 0: Positive 1: Negative
maxVelocity
Type: SystemUInt32
This parameter is the maximal allowed speed during a profiled move.
maxAcceleration
Type: SystemUInt32
Defines the maximal allowed acceleration.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MasterEncoderMode Properties

MasterEncoderMode Properties EposCmd.Net

The MasterEncoderMode type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

MasterEncoderMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo Class

MotionInfo Class EposCmd.Net
Motion Info methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationMotionInfo

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class MotionInfo : DeviceCommandGroup
Public Class MotionInfo
    Inherits DeviceCommandGroup
public ref class MotionInfo : public DeviceCommandGroup
type MotionInfo =
    class
        inherit DeviceCommandGroup
    end

The MotionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MotionInfo | Initializes a new instance of the MotionInfo class.
Top
Methods
 | Name | Description
Public method | GetCurrentIs | "GetCurrentIs" returns the current actual value.
Public method | GetCurrentIsAveraged | "GetCurrentIsAveraged" reads the current average current value.
Public method | GetMovementState | With "GetMovementState" it is possible to check, if drive has reached the target.
Public method | GetPositionIs | "GetPositionIs" returns the position actual value.
Public method | GetVelocityIs | "GetVelocityIs" reads the velocity actual value.
Public method | GetVelocityIsAveraged | "GetVelocityIsAveraged" reads the current average velocity value.
Public method | WaitForTargetReached | "WaitForTargetReached" is waiting until the state is changed to target reached or the time is up.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo Constructor

MotionInfo Constructor EposCmd.Net
Initializes a new instance of the MotionInfo class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public MotionInfo(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
MotionInfo(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> MotionInfo

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo Methods

MotionInfo Methods EposCmd.Net

The MotionInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetCurrentIs | "GetCurrentIs" returns the current actual value.
Public method | GetCurrentIsAveraged | "GetCurrentIsAveraged" reads the current average current value.
Public method | GetMovementState | With "GetMovementState" it is possible to check, if drive has reached the target.
Public method | GetPositionIs | "GetPositionIs" returns the position actual value.
Public method | GetVelocityIs | "GetVelocityIs" reads the velocity actual value.
Public method | GetVelocityIsAveraged | "GetVelocityIsAveraged" reads the current average velocity value.
Public method | WaitForTargetReached | "WaitForTargetReached" is waiting until the state is changed to target reached or the time is up.
Top
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetCurrentIs Method

MotionInfoGetCurrentIs Method EposCmd.Net
"GetCurrentIs" returns the current actual value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public short GetCurrentIs()
Public Function GetCurrentIs As Short
public:
short GetCurrentIs()
member GetCurrentIs : unit -> int16

Return Value

Type: Int16
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetCurrentIsAveraged Method

MotionInfoGetCurrentIsAveraged Method EposCmd.Net
"GetCurrentIsAveraged" reads the current average current value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetCurrentIsAveraged()
Public Function GetCurrentIsAveraged As Integer
public:
int GetCurrentIsAveraged()
member GetCurrentIsAveraged : unit -> int

Return Value

Type: Int32
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetMovementState Method

MotionInfoGetMovementState Method EposCmd.Net
With "GetMovementState" it is possible to check, if drive has reached the target.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetMovementState(
    ref bool targetReached
)
Public Sub GetMovementState (
    ByRef targetReached As Boolean
)
public:
void GetMovementState(
    bool% targetReached
)
member GetMovementState :
        targetReached : bool byref -> unit

Parameters

targetReached
Type: SystemBoolean
The drive has reached the target.The function reads actual state of bit 10 from the status word.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetPositionIs Method

MotionInfoGetPositionIs Method EposCmd.Net
"GetPositionIs" returns the position actual value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPositionIs()
Public Function GetPositionIs As Integer
public:
int GetPositionIs()
member GetPositionIs : unit -> int

Return Value

Type: Int32
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetVelocityIs Method

MotionInfoGetVelocityIs Method EposCmd.Net
"GetVelocityIs" reads the velocity actual value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetVelocityIs()
Public Function GetVelocityIs As Integer
public:
int GetVelocityIs()
member GetVelocityIs : unit -> int

Return Value

Type: Int32
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.GetVelocityIsAveraged Method

MotionInfoGetVelocityIsAveraged Method EposCmd.Net
"GetVelocityIsAveraged" reads the current average velocity value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetVelocityIsAveraged()
Public Function GetVelocityIsAveraged As Integer
public:
int GetVelocityIsAveraged()
member GetVelocityIsAveraged : unit -> int

Return Value

Type: Int32
In the case of the failure, throws the exception with the error code
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo.WaitForTargetReached Method

MotionInfoWaitForTargetReached Method EposCmd.Net
"WaitForTargetReached" is waiting until the state is changed to target reached or the time is up.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void WaitForTargetReached(
    uint timeout
)
Public Sub WaitForTargetReached (
    timeout As UInteger
)
public:
void WaitForTargetReached(
    unsigned int timeout
)
member WaitForTargetReached :
        timeout : uint32 -> unit

Parameters

timeout
Type: SystemUInt32
The timeout.
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


MotionInfo Properties

MotionInfo Properties EposCmd.Net

The MotionInfo type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

MotionInfo Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation Class

Operation Class EposCmd.Net
Epos Operation profiles
Inheritance Hierarchy
SystemObject
EposCmd.Net.DeviceCmdSet.OperationOperation

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Operation
Public Class Operation
public ref class Operation
type Operation =  class end

The Operation type exposes the following members.

Constructors
 | Name | Description
Public method | Operation | Initializes a new instance of the Operation class.
Top
Properties
 | Name | Description
Public property | CurrentMode | Gets the current mode.
Public property | DeviceErrorHandling | Gets the error handling.
Public property | HomingMode | Gets the homing mode.
Public property | InterpolatedPositionMode | Gets the interpolated position mode.
Public property | Io | Gets the io.
Public property | MasterEncoderMode | Gets the master encoder mode.
Public property | MotionInfo | Gets the motion info.
Public property | OperationMode | Gets the operation mode.
Public property | PositionMode | Gets the position mode.
Public property | ProfilePositionMode | Gets the profile position mode.
Public property | ProfileVelocityMode | Gets the profile velocity mode.
Public property | StateMachine | Gets the state machine.
Public property | StepDirectionMode | Gets the step direction mode.
Public property | VelocityMode | Gets the velocity mode.
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation Constructor

Operation Constructor EposCmd.Net
Initializes a new instance of the Operation class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public Operation(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
Operation(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> Operation

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation Properties

Operation Properties EposCmd.Net

The Operation type exposes the following members.

Properties
 | Name | Description
Public property | CurrentMode | Gets the current mode.
Public property | DeviceErrorHandling | Gets the error handling.
Public property | HomingMode | Gets the homing mode.
Public property | InterpolatedPositionMode | Gets the interpolated position mode.
Public property | Io | Gets the io.
Public property | MasterEncoderMode | Gets the master encoder mode.
Public property | MotionInfo | Gets the motion info.
Public property | OperationMode | Gets the operation mode.
Public property | PositionMode | Gets the position mode.
Public property | ProfilePositionMode | Gets the profile position mode.
Public property | ProfileVelocityMode | Gets the profile velocity mode.
Public property | StateMachine | Gets the state machine.
Public property | StepDirectionMode | Gets the step direction mode.
Public property | VelocityMode | Gets the velocity mode.
Top
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.CurrentMode Property

OperationCurrentMode Property EposCmd.Net
Gets the current mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public CurrentMode CurrentMode { get; }
Public ReadOnly Property CurrentMode As CurrentMode
    Get
public:
property CurrentMode^ CurrentMode {
    CurrentMode^ get ();
}
member CurrentMode : CurrentMode with get

Property Value

Type: CurrentMode
The current mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.DeviceErrorHandling Property

OperationDeviceErrorHandling Property EposCmd.Net
Gets the error handling.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public DeviceErrorHandling DeviceErrorHandling { get; }
Public ReadOnly Property DeviceErrorHandling As DeviceErrorHandling
    Get
public:
property DeviceErrorHandling^ DeviceErrorHandling {
    DeviceErrorHandling^ get ();
}
member DeviceErrorHandling : DeviceErrorHandling with get

Property Value

Type: DeviceErrorHandling
The error handling.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.HomingMode Property

OperationHomingMode Property EposCmd.Net
Gets the homing mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public HomingMode HomingMode { get; }
Public ReadOnly Property HomingMode As HomingMode
    Get
public:
property HomingMode^ HomingMode {
    HomingMode^ get ();
}
member HomingMode : HomingMode with get

Property Value

Type: HomingMode
The homing mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.InterpolatedPositionMode Property

OperationInterpolatedPositionMode Property EposCmd.Net
Gets the interpolated position mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InterpolatedPositionMode InterpolatedPositionMode { get; }
Public ReadOnly Property InterpolatedPositionMode As InterpolatedPositionMode
    Get
public:
property InterpolatedPositionMode^ InterpolatedPositionMode {
    InterpolatedPositionMode^ get ();
}
member InterpolatedPositionMode : InterpolatedPositionMode with get

Property Value

Type: InterpolatedPositionMode
The interpolated position mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.Io Property

OperationIo Property EposCmd.Net
Gets the io.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public InputOutput Io { get; }
Public ReadOnly Property Io As InputOutput
    Get
public:
property InputOutput^ Io {
    InputOutput^ get ();
}
member Io : InputOutput with get

Property Value

Type: InputOutput
The io.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.MasterEncoderMode Property

OperationMasterEncoderMode Property EposCmd.Net
Gets the master encoder mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public MasterEncoderMode MasterEncoderMode { get; }
Public ReadOnly Property MasterEncoderMode As MasterEncoderMode
    Get
public:
property MasterEncoderMode^ MasterEncoderMode {
    MasterEncoderMode^ get ();
}
member MasterEncoderMode : MasterEncoderMode with get

Property Value

Type: MasterEncoderMode
The master encoder mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.MotionInfo Property

OperationMotionInfo Property EposCmd.Net
Gets the motion info.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public MotionInfo MotionInfo { get; }
Public ReadOnly Property MotionInfo As MotionInfo
    Get
public:
property MotionInfo^ MotionInfo {
    MotionInfo^ get ();
}
member MotionInfo : MotionInfo with get

Property Value

Type: MotionInfo
The motion info.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.OperationMode Property

OperationOperationMode Property EposCmd.Net
Gets the operation mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public OperationMode OperationMode { get; }
Public ReadOnly Property OperationMode As OperationMode
    Get
public:
property OperationMode^ OperationMode {
    OperationMode^ get ();
}
member OperationMode : OperationMode with get

Property Value

Type: OperationMode
The operation mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.PositionMode Property

OperationPositionMode Property EposCmd.Net
Gets the position mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionMode PositionMode { get; }
Public ReadOnly Property PositionMode As PositionMode
    Get
public:
property PositionMode^ PositionMode {
    PositionMode^ get ();
}
member PositionMode : PositionMode with get

Property Value

Type: PositionMode
The position mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.ProfilePositionMode Property

OperationProfilePositionMode Property EposCmd.Net
Gets the profile position mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfilePositionMode ProfilePositionMode { get; }
Public ReadOnly Property ProfilePositionMode As ProfilePositionMode
    Get
public:
property ProfilePositionMode^ ProfilePositionMode {
    ProfilePositionMode^ get ();
}
member ProfilePositionMode : ProfilePositionMode with get

Property Value

Type: ProfilePositionMode
The profile position mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.ProfileVelocityMode Property

OperationProfileVelocityMode Property EposCmd.Net
Gets the profile velocity mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfileVelocityMode ProfileVelocityMode { get; }
Public ReadOnly Property ProfileVelocityMode As ProfileVelocityMode
    Get
public:
property ProfileVelocityMode^ ProfileVelocityMode {
    ProfileVelocityMode^ get ();
}
member ProfileVelocityMode : ProfileVelocityMode with get

Property Value

Type: ProfileVelocityMode
The profile velocity mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.StateMachine Property

OperationStateMachine Property EposCmd.Net
Gets the state machine.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public StateMachine StateMachine { get; }
Public ReadOnly Property StateMachine As StateMachine
    Get
public:
property StateMachine^ StateMachine {
    StateMachine^ get ();
}
member StateMachine : StateMachine with get

Property Value

Type: StateMachine
The state machine.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.StepDirectionMode Property

OperationStepDirectionMode Property EposCmd.Net
Gets the step direction mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public StepDirectionMode StepDirectionMode { get; }
Public ReadOnly Property StepDirectionMode As StepDirectionMode
    Get
public:
property StepDirectionMode^ StepDirectionMode {
    StepDirectionMode^ get ();
}
member StepDirectionMode : StepDirectionMode with get

Property Value

Type: StepDirectionMode
The step direction mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


Operation.VelocityMode Property

OperationVelocityMode Property EposCmd.Net
Gets the velocity mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public VelocityMode VelocityMode { get; }
Public ReadOnly Property VelocityMode As VelocityMode
    Get
public:
property VelocityMode^ VelocityMode {
    VelocityMode^ get ();
}
member VelocityMode : VelocityMode with get

Property Value

Type: VelocityMode
The velocity mode.
See Also

Reference

Operation Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode Class

OperationMode Class EposCmd.Net
Operation mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationOperationMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class OperationMode : DeviceCommandGroup
Public Class OperationMode
    Inherits DeviceCommandGroup
public ref class OperationMode : public DeviceCommandGroup
type OperationMode =
    class
        inherit DeviceCommandGroup
    end

The OperationMode type exposes the following members.

Constructors
 | Name | Description
Public method | OperationMode | Initializes a new instance of the OperationMode class.
Top
Methods
 | Name | Description
Public method | GetOperationMode | Function "GetOperationMode" returns the activated operation mode.
Public method | GetOperationModeAsString | Function "GetOperationModeAsString" returns the activated operation mode as text.
Public method | SetOperationMode | "SetOperationMode" sets the operation mode.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode Constructor

OperationMode Constructor EposCmd.Net
Initializes a new instance of the OperationMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public OperationMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
OperationMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> OperationMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode Methods

OperationMode Methods EposCmd.Net

The OperationMode type exposes the following members.

Methods
 | Name | Description
Public method | GetOperationMode | Function "GetOperationMode" returns the activated operation mode.
Public method | GetOperationModeAsString | Function "GetOperationModeAsString" returns the activated operation mode as text.
Public method | SetOperationMode | "SetOperationMode" sets the operation mode.
Top
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode.GetOperationMode Method

OperationModeGetOperationMode Method EposCmd.Net
Function "GetOperationMode" returns the activated operation mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public EOperationMode GetOperationMode()
Public Function GetOperationMode As EOperationMode
public:
EOperationMode GetOperationMode()
member GetOperationMode : unit -> EOperationMode

Return Value

Type: EOperationMode
In the case of the failure, throws the exception with the error code
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode.GetOperationModeAsString Method

OperationModeGetOperationModeAsString Method EposCmd.Net
Function "GetOperationModeAsString" returns the activated operation mode as text.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public string GetOperationModeAsString()
Public Function GetOperationModeAsString As String
public:
String^ GetOperationModeAsString()
member GetOperationModeAsString : unit -> string

Return Value

Type: String
In the case of the failure, throws the exception with the error code
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode.SetOperationMode Method

OperationModeSetOperationMode Method EposCmd.Net
"SetOperationMode" sets the operation mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOperationMode(
    EOperationMode operationMode
)
Public Sub SetOperationMode (
    operationMode As EOperationMode
)
public:
void SetOperationMode(
    EOperationMode operationMode
)
member SetOperationMode :
        operationMode : EOperationMode -> unit

Parameters

operationMode
Type: EposCmd.NetEOperationMode
Operation mode, Interpolated Position Mode(7), Homing mode(6), Profile Velocity Mode(3), Profile Position Mode(1), Position Mode(-1), Velocity Mode(-2), Current Mode(-3), Diagnostic Mode(-4), Master Encoder Mode(-5), Step/Direction Mode(-6)

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


OperationMode Properties

OperationMode Properties EposCmd.Net

The OperationMode type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

OperationMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare Class

PositionCompare Class EposCmd.Net
Position Compare methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationPositionCompare

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class PositionCompare : DeviceCommandGroup
Public Class PositionCompare
    Inherits DeviceCommandGroup
public ref class PositionCompare : public DeviceCommandGroup
type PositionCompare =
    class
        inherit DeviceCommandGroup
    end

The PositionCompare type exposes the following members.

Constructors
 | Name | Description
Public method | PositionCompare | Initializes a new instance of the PositionCompare class.
Top
Methods
 | Name | Description
Public method | ActivatePositionCompare | "ActivatePositionCompare" enable the output to position compare method.
Public method | DeactivatePositionCompare | "DeactivatePositionCompare" disable the output to position compare method.
Public method | DisablePositionCompare | "DisablePositionCompare" disable the output mask from position compare method.
Public method | EnablePositionCompare | "EnablePositionCompare" enable the output mask for position compare method.
Public method | GetPositionCompareParameter | "GetPositionCompareParameter" read all parameters for position compare.
Public method | SetPositionCompareParameter | "SetPositionCompareParameter" write all parameters for position compare.
Public method | SetPositionCompareReferencePosition | "SetPositionCompareReferencePosition" writes the reference position for position compare method.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare Constructor

PositionCompare Constructor EposCmd.Net
Initializes a new instance of the PositionCompare class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionCompare(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
PositionCompare(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> PositionCompare

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare Methods

PositionCompare Methods EposCmd.Net

The PositionCompare type exposes the following members.

Methods
 | Name | Description
Public method | ActivatePositionCompare | "ActivatePositionCompare" enable the output to position compare method.
Public method | DeactivatePositionCompare | "DeactivatePositionCompare" disable the output to position compare method.
Public method | DisablePositionCompare | "DisablePositionCompare" disable the output mask from position compare method.
Public method | EnablePositionCompare | "EnablePositionCompare" enable the output mask for position compare method.
Public method | GetPositionCompareParameter | "GetPositionCompareParameter" read all parameters for position compare.
Public method | SetPositionCompareParameter | "SetPositionCompareParameter" write all parameters for position compare.
Public method | SetPositionCompareReferencePosition | "SetPositionCompareReferencePosition" writes the reference position for position compare method.
Top
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.ActivatePositionCompare Method

PositionCompareActivatePositionCompare Method EposCmd.Net
"ActivatePositionCompare" enable the output to position compare method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivatePositionCompare(
    ushort digitalOutputNumber,
    int polarity
)
Public Sub ActivatePositionCompare (
    digitalOutputNumber As UShort,
    polarity As Integer
)
public:
void ActivatePositionCompare(
    unsigned short digitalOutputNumber,
    int polarity
)
member ActivatePositionCompare :
        digitalOutputNumber : uint16 *
        polarity : int -> unit

Parameters

digitalOutputNumber
Type: SystemUInt16
Selected digital output for position compare
polarity
Type: SystemInt32
Polarity of the selected output

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.DeactivatePositionCompare Method

PositionCompareDeactivatePositionCompare Method EposCmd.Net
"DeactivatePositionCompare" disable the output to position compare method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivatePositionCompare(
    ushort digitalOutputNumber
)
Public Sub DeactivatePositionCompare (
    digitalOutputNumber As UShort
)
public:
void DeactivatePositionCompare(
    unsigned short digitalOutputNumber
)
member DeactivatePositionCompare :
        digitalOutputNumber : uint16 -> unit

Parameters

digitalOutputNumber
Type: SystemUInt16
Selected digital output for position compare

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.DisablePositionCompare Method

PositionCompareDisablePositionCompare Method EposCmd.Net
"DisablePositionCompare" disable the output mask from position compare method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisablePositionCompare()
Public Sub DisablePositionCompare
public:
void DisablePositionCompare()
member DisablePositionCompare : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.EnablePositionCompare Method

PositionCompareEnablePositionCompare Method EposCmd.Net
"EnablePositionCompare" enable the output mask for position compare method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnablePositionCompare()
Public Sub EnablePositionCompare
public:
void EnablePositionCompare()
member EnablePositionCompare : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.GetPositionCompareParameter Method

PositionCompareGetPositionCompareParameter Method EposCmd.Net
"GetPositionCompareParameter" read all parameters for position compare.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionCompareParameter(
    ref EPositionCompareOperationalMode operationalMode,
    ref EPositionCompareIntervalMode intervalMode,
    ref EPositionCompareDirectionDependency directionDependency,
    ref ushort intervalWidth,
    ref ushort intervalRepetitions,
    ref ushort pulseWidth
)
Public Sub GetPositionCompareParameter (
    ByRef operationalMode As EPositionCompareOperationalMode,
    ByRef intervalMode As EPositionCompareIntervalMode,
    ByRef directionDependency As EPositionCompareDirectionDependency,
    ByRef intervalWidth As UShort,
    ByRef intervalRepetitions As UShort,
    ByRef pulseWidth As UShort
)
public:
void GetPositionCompareParameter(
    EPositionCompareOperationalMode% operationalMode,
    EPositionCompareIntervalMode% intervalMode,
    EPositionCompareDirectionDependency% directionDependency,
    unsigned short% intervalWidth,
    unsigned short% intervalRepetitions,
    unsigned short% pulseWidth
)
member GetPositionCompareParameter :
        operationalMode : EPositionCompareOperationalMode byref *
        intervalMode : EPositionCompareIntervalMode byref *
        directionDependency : EPositionCompareDirectionDependency byref *
        intervalWidth : uint16 byref *
        intervalRepetitions : uint16 byref *
        pulseWidth : uint16 byref -> unit

Parameters

operationalMode
Type: EposCmd.NetEPositionCompareOperationalMode
Used operational mode in position sequence mode:
0: Single position mode
1: Position sequence mode
intervalMode
Type: EposCmd.NetEPositionCompareIntervalMode
Used interval mode in position sequence mode:
0: Interval positions are set in negative direction relative to the position compare reference position
1: Interval positions are set in positive direction relative to the position compare reference position
2: Interval positions are set in positive and negative direction relative to the position compare reference position
directionDependency
Type: EposCmd.NetEPositionCompareDirectionDependency
Used direction dependency in position sequence mode:
0: Positions are compared only if actual motor direction is negative
1: Positions are compared only if actual motor direction is positive
2: Positions are compared regardless of the actual motor direction
intervalWidth
Type: SystemUInt16
This object holds the width of the position intervals
intervalRepetitions
Type: SystemUInt16
This object allows to configure the number of position intervals to be considered by position compare
pulseWidth
Type: SystemUInt16
This object configures the pulse width of the trigger output

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.SetPositionCompareParameter Method

PositionCompareSetPositionCompareParameter Method EposCmd.Net
"SetPositionCompareParameter" write all parameters for position compare.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionCompareParameter(
    EPositionCompareOperationalMode operationalMode,
    EPositionCompareIntervalMode intervalMode,
    EPositionCompareDirectionDependency directionDependency,
    ushort intervalWidth,
    ushort intervalRepetitions,
    ushort pulseWidth
)
Public Sub SetPositionCompareParameter (
    operationalMode As EPositionCompareOperationalMode,
    intervalMode As EPositionCompareIntervalMode,
    directionDependency As EPositionCompareDirectionDependency,
    intervalWidth As UShort,
    intervalRepetitions As UShort,
    pulseWidth As UShort
)
public:
void SetPositionCompareParameter(
    EPositionCompareOperationalMode operationalMode,
    EPositionCompareIntervalMode intervalMode,
    EPositionCompareDirectionDependency directionDependency,
    unsigned short intervalWidth,
    unsigned short intervalRepetitions,
    unsigned short pulseWidth
)
member SetPositionCompareParameter :
        operationalMode : EPositionCompareOperationalMode *
        intervalMode : EPositionCompareIntervalMode *
        directionDependency : EPositionCompareDirectionDependency *
        intervalWidth : uint16 *
        intervalRepetitions : uint16 *
        pulseWidth : uint16 -> unit

Parameters

operationalMode
Type: EposCmd.NetEPositionCompareOperationalMode
Used operational mode in position sequence mode: 0: Single position mode 1: Position sequence mode
intervalMode
Type: EposCmd.NetEPositionCompareIntervalMode
Used interval mode in position sequence mode:
0: Interval positions are set in negative direction relative to the position compare reference position
1: Interval positions are set in positive direction relative to the position compare reference position
2: Interval positions are set in positive and negative direction relative to the position compare reference position
directionDependency
Type: EposCmd.NetEPositionCompareDirectionDependency
Used direction dependency in position sequence mode:
0: Positions are compared only if actual motor direction is negative
1: Positions are compared only if actual motor direction is positive
2: Positions are compared regardless of the actual motor direction
intervalWidth
Type: SystemUInt16
This object holds the width of the position intervals
intervalRepetitions
Type: SystemUInt16
This object allows to configure the number of position intervals to be considered by position compare
pulseWidth
Type: SystemUInt16
This object configures the pulse width of the trigger output

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare.SetPositionCompareReferencePosition Method

PositionCompareSetPositionCompareReferencePosition Method EposCmd.Net
"SetPositionCompareReferencePosition" writes the reference position for position compare method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionCompareReferencePosition(
    int referencePosition
)
Public Sub SetPositionCompareReferencePosition (
    referencePosition As Integer
)
public:
void SetPositionCompareReferencePosition(
    int referencePosition
)
member SetPositionCompareReferencePosition :
        referencePosition : int -> unit

Parameters

referencePosition
Type: SystemInt32
This object holds the position that is compared with the position actual value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionCompare Properties

PositionCompare Properties EposCmd.Net

The PositionCompare type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

PositionCompare Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker Class

PositionMarker Class EposCmd.Net
Position Marker methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationPositionMarker

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class PositionMarker : DeviceCommandGroup
Public Class PositionMarker
    Inherits DeviceCommandGroup
public ref class PositionMarker : public DeviceCommandGroup
type PositionMarker =
    class
        inherit DeviceCommandGroup
    end

The PositionMarker type exposes the following members.

Constructors
 | Name | Description
Public method | PositionMarker | Initializes a new instance of the PositionCompare class.
Top
Methods
 | Name | Description
Public method | ActivatePositionMarker | "ActivatePositionMarker" enable the digital input to position marker method.
Public method | DeactivatePositionMarker | "DeactivatePositionMarker" disable the digital input to position marker method.
Public method | GetPositionMarkerParameter | "GetPositionMarkerParameter" read all parameters for position marker method.
Public method | ReadPositionMarkerCapturedPosition | "ReadPositionMarkerCapturedPosition" returns the last captured position.
Public method | ReadPositionMarkerCounter | "ReadPositionMarkerCounter" returns the number of the detected edges.
Public method | ResetPositionMarkerCounter | "ResetPositionMarkerCounter" clears the counter and the captured positions by writing zero to object position marker counter.
Public method | SetPositionMarkerParameter | "SetPositionMarkerParameter" write all parameters for position marker method.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker Constructor

PositionMarker Constructor EposCmd.Net
Initializes a new instance of the PositionCompare class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionMarker(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
PositionMarker(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> PositionMarker

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker Methods

PositionMarker Methods EposCmd.Net

The PositionMarker type exposes the following members.

Methods
 | Name | Description
Public method | ActivatePositionMarker | "ActivatePositionMarker" enable the digital input to position marker method.
Public method | DeactivatePositionMarker | "DeactivatePositionMarker" disable the digital input to position marker method.
Public method | GetPositionMarkerParameter | "GetPositionMarkerParameter" read all parameters for position marker method.
Public method | ReadPositionMarkerCapturedPosition | "ReadPositionMarkerCapturedPosition" returns the last captured position.
Public method | ReadPositionMarkerCounter | "ReadPositionMarkerCounter" returns the number of the detected edges.
Public method | ResetPositionMarkerCounter | "ResetPositionMarkerCounter" clears the counter and the captured positions by writing zero to object position marker counter.
Public method | SetPositionMarkerParameter | "SetPositionMarkerParameter" write all parameters for position marker method.
Top
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.ActivatePositionMarker Method

PositionMarkerActivatePositionMarker Method EposCmd.Net
"ActivatePositionMarker" enable the digital input to position marker method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivatePositionMarker(
    ushort digitalInputNumber,
    int polarity
)
Public Sub ActivatePositionMarker (
    digitalInputNumber As UShort,
    polarity As Integer
)
public:
void ActivatePositionMarker(
    unsigned short digitalInputNumber,
    int polarity
)
member ActivatePositionMarker :
        digitalInputNumber : uint16 *
        polarity : int -> unit

Parameters

digitalInputNumber
Type: SystemUInt16
Selected digital input for position compare
polarity
Type: SystemInt32
Polarity of the selected input

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.DeactivatePositionMarker Method

PositionMarkerDeactivatePositionMarker Method EposCmd.Net
"DeactivatePositionMarker" disable the digital input to position marker method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivatePositionMarker(
    ushort digitalInputNumber
)
Public Sub DeactivatePositionMarker (
    digitalInputNumber As UShort
)
public:
void DeactivatePositionMarker(
    unsigned short digitalInputNumber
)
member DeactivatePositionMarker :
        digitalInputNumber : uint16 -> unit

Parameters

digitalInputNumber
Type: SystemUInt16
Selected digital input for position marker

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.GetPositionMarkerParameter Method

PositionMarkerGetPositionMarkerParameter Method EposCmd.Net
"GetPositionMarkerParameter" read all parameters for position marker method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionMarkerParameter(
    ref EPositionMarkerEdgeType positionMarkerEdgeType,
    ref EPositionMarkerMode positionMarkerMode
)
Public Sub GetPositionMarkerParameter (
    ByRef positionMarkerEdgeType As EPositionMarkerEdgeType,
    ByRef positionMarkerMode As EPositionMarkerMode
)
public:
void GetPositionMarkerParameter(
    EPositionMarkerEdgeType% positionMarkerEdgeType,
    EPositionMarkerMode% positionMarkerMode
)
member GetPositionMarkerParameter :
        positionMarkerEdgeType : EPositionMarkerEdgeType byref *
        positionMarkerMode : EPositionMarkerMode byref -> unit

Parameters

positionMarkerEdgeType
Type: EposCmd.NetEPositionMarkerEdgeType
The value of this object defines on what kind of edge the position should be captured:
0: Both edges
1: Rising edge
2: Falling edge
positionMarkerMode
Type: EposCmd.NetEPositionMarkerMode
This object defines the position markercapturing mode:
0: Continuous
1: Single
2: Multiple

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.ReadPositionMarkerCapturedPosition Method

PositionMarkerReadPositionMarkerCapturedPosition Method EposCmd.Net
"ReadPositionMarkerCapturedPosition" returns the last captured position.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadPositionMarkerCapturedPosition(
    ushort counterIndex,
    ref int capturedPosition
)
Public Sub ReadPositionMarkerCapturedPosition (
    counterIndex As UShort,
    ByRef capturedPosition As Integer
)
public:
void ReadPositionMarkerCapturedPosition(
    unsigned short counterIndex,
    int% capturedPosition
)
member ReadPositionMarkerCapturedPosition :
        counterIndex : uint16 *
        capturedPosition : int byref -> unit

Parameters

counterIndex
Type: SystemUInt16
0: Read position marker captured position
1: Read position marker history [1]
2: Read position marker history [2]
capturedPosition
Type: SystemInt32
This object contains the captured position or the position marker history

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.ReadPositionMarkerCounter Method

PositionMarkerReadPositionMarkerCounter Method EposCmd.Net
"ReadPositionMarkerCounter" returns the number of the detected edges.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadPositionMarkerCounter(
    ref ushort count
)
Public Sub ReadPositionMarkerCounter (
    ByRef count As UShort
)
public:
void ReadPositionMarkerCounter(
    unsigned short% count
)
member ReadPositionMarkerCounter :
        count : uint16 byref -> unit

Parameters

count
Type: SystemUInt16
This object counts the number of the detected edges.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.ResetPositionMarkerCounter Method

PositionMarkerResetPositionMarkerCounter Method EposCmd.Net
"ResetPositionMarkerCounter" clears the counter and the captured positions by writing zero to object position marker counter.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetPositionMarkerCounter()
Public Sub ResetPositionMarkerCounter
public:
void ResetPositionMarkerCounter()
member ResetPositionMarkerCounter : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker.SetPositionMarkerParameter Method

PositionMarkerSetPositionMarkerParameter Method EposCmd.Net
"SetPositionMarkerParameter" write all parameters for position marker method.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionMarkerParameter(
    EPositionMarkerEdgeType positionMarkerEdgeType,
    EPositionMarkerMode positionMarkerMode
)
Public Sub SetPositionMarkerParameter (
    positionMarkerEdgeType As EPositionMarkerEdgeType,
    positionMarkerMode As EPositionMarkerMode
)
public:
void SetPositionMarkerParameter(
    EPositionMarkerEdgeType positionMarkerEdgeType,
    EPositionMarkerMode positionMarkerMode
)
member SetPositionMarkerParameter :
        positionMarkerEdgeType : EPositionMarkerEdgeType *
        positionMarkerMode : EPositionMarkerMode -> unit

Parameters

positionMarkerEdgeType
Type: EposCmd.NetEPositionMarkerEdgeType
The value of this object defines on what kind of edge the position should be captured:
0: Both edges
1: Rising edge
2: Falling edge
positionMarkerMode
Type: EposCmd.NetEPositionMarkerMode
This object defines the position markercapturing mode:
0: Continuous
1: Single
2: Multiple

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMarker Properties

PositionMarker Properties EposCmd.Net

The PositionMarker type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

PositionMarker Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode Class

PositionMode Class EposCmd.Net
Position mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationPositionMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class PositionMode : DeviceCommandGroup
Public Class PositionMode
    Inherits DeviceCommandGroup
public ref class PositionMode : public DeviceCommandGroup
type PositionMode =
    class
        inherit DeviceCommandGroup
    end

The PositionMode type exposes the following members.

Constructors
 | Name | Description
Public method | PositionMode | Initializes a new instance of the PositionMode class.
Top
Methods
 | Name | Description
Public method | ActivatePositionMode | With the function "ActivatePositionMode" the device changes to position mode (PM).
Public method | GetPositionMust | "GetPositionMust" reads the position mode setting value.
Public method | SetPositionMust | "SetPositionMust" sets the position mode setting value.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode Constructor

PositionMode Constructor EposCmd.Net
Initializes a new instance of the PositionMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
PositionMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> PositionMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode Methods

PositionMode Methods EposCmd.Net

The PositionMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivatePositionMode | With the function "ActivatePositionMode" the device changes to position mode (PM).
Public method | GetPositionMust | "GetPositionMust" reads the position mode setting value.
Public method | SetPositionMust | "SetPositionMust" sets the position mode setting value.
Top
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode.ActivatePositionMode Method

PositionModeActivatePositionMode Method EposCmd.Net
With the function "ActivatePositionMode" the device changes to position mode (PM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivatePositionMode()
Public Sub ActivatePositionMode
public:
void ActivatePositionMode()
member ActivatePositionMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode.GetPositionMust Method

PositionModeGetPositionMust Method EposCmd.Net
"GetPositionMust" reads the position mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionMust(
    ref int positionMust
)
Public Sub GetPositionMust (
    ByRef positionMust As Integer
)
public:
void GetPositionMust(
    int% positionMust
)
member GetPositionMust :
        positionMust : int byref -> unit

Parameters

positionMust
Type: SystemInt32
Position mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode.SetPositionMust Method

PositionModeSetPositionMust Method EposCmd.Net
"SetPositionMust" sets the position mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionMust(
    int positionMust
)
Public Sub SetPositionMust (
    positionMust As Integer
)
public:
void SetPositionMust(
    int positionMust
)
member SetPositionMust :
        positionMust : int -> unit

Parameters

positionMust
Type: SystemInt32
Position mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode Properties

PositionMode Properties EposCmd.Net

The PositionMode type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionMode.Advanced Property

PositionModeAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionModeAdvanced Advanced { get; }
Public ReadOnly Property Advanced As PositionModeAdvanced
    Get
public:
property PositionModeAdvanced^ Advanced {
    PositionModeAdvanced^ get ();
}
member Advanced : PositionModeAdvanced with get

Property Value

Type: PositionModeAdvanced
The advanced.
See Also

Reference

PositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced Class

PositionModeAdvanced Class EposCmd.Net
Advanced Position Mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationPositionModeAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class PositionModeAdvanced : DeviceCommandGroup
Public Class PositionModeAdvanced
    Inherits DeviceCommandGroup
public ref class PositionModeAdvanced : public DeviceCommandGroup
type PositionModeAdvanced =
    class
        inherit DeviceCommandGroup
    end

The PositionModeAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | PositionModeAdvanced | Initializes a new instance of the PositionModeAdvanced class.
Top
Methods
 | Name | Description
Public method | ActivateAnalogPositionSetpoint | "ActivateAnalogPositionSetpoint" configures the selected analog input for analog position setpoint.
Public method | DeactivateAnalogPositionSetpoint | "DeactivateAnalogPositionSetpoint" disable the selected analog input for analog position setpoint.
Public method | DisableAnalogPositionSetpoint | "DisableAnalogPositionSetpoint" disable the execution mask for analog position setpoint.
Public method | EnableAnalogPositionSetpoint | "EnableAnalogPositionSetpoint" enable the execution mask for analog position setpoint.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced Constructor

PositionModeAdvanced Constructor EposCmd.Net
Initializes a new instance of the PositionModeAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public PositionModeAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
PositionModeAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> PositionModeAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced Methods

PositionModeAdvanced Methods EposCmd.Net

The PositionModeAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAnalogPositionSetpoint | "ActivateAnalogPositionSetpoint" configures the selected analog input for analog position setpoint.
Public method | DeactivateAnalogPositionSetpoint | "DeactivateAnalogPositionSetpoint" disable the selected analog input for analog position setpoint.
Public method | DisableAnalogPositionSetpoint | "DisableAnalogPositionSetpoint" disable the execution mask for analog position setpoint.
Public method | EnableAnalogPositionSetpoint | "EnableAnalogPositionSetpoint" enable the execution mask for analog position setpoint.
Top
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced.ActivateAnalogPositionSetpoint Method

PositionModeAdvancedActivateAnalogPositionSetpoint Method EposCmd.Net
"ActivateAnalogPositionSetpoint" configures the selected analog input for analog position setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateAnalogPositionSetpoint(
    ushort analogInputNumber,
    float scaling,
    int offset
)
Public Sub ActivateAnalogPositionSetpoint (
    analogInputNumber As UShort,
    scaling As Single,
    offset As Integer
)
public:
void ActivateAnalogPositionSetpoint(
    unsigned short analogInputNumber,
    float scaling,
    int offset
)
member ActivateAnalogPositionSetpoint :
        analogInputNumber : uint16 *
        scaling : float32 *
        offset : int -> unit

Parameters

analogInputNumber
Type: SystemUInt16
Number of the used analog input
scaling
Type: SystemSingle
The scaling factor for analog position setpoint functionality
offset
Type: SystemInt32
Offset for analog position setpoint functionality

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced.DeactivateAnalogPositionSetpoint Method

PositionModeAdvancedDeactivateAnalogPositionSetpoint Method EposCmd.Net
"DeactivateAnalogPositionSetpoint" disable the selected analog input for analog position setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateAnalogPositionSetpoint(
    ushort analogInputNumber
)
Public Sub DeactivateAnalogPositionSetpoint (
    analogInputNumber As UShort
)
public:
void DeactivateAnalogPositionSetpoint(
    unsigned short analogInputNumber
)
member DeactivateAnalogPositionSetpoint :
        analogInputNumber : uint16 -> unit

Parameters

analogInputNumber
Type: SystemUInt16
The analog input number.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced.DisableAnalogPositionSetpoint Method

PositionModeAdvancedDisableAnalogPositionSetpoint Method EposCmd.Net
"DisableAnalogPositionSetpoint" disable the execution mask for analog position setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableAnalogPositionSetpoint()
Public Sub DisableAnalogPositionSetpoint
public:
void DisableAnalogPositionSetpoint()
member DisableAnalogPositionSetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced.EnableAnalogPositionSetpoint Method

PositionModeAdvancedEnableAnalogPositionSetpoint Method EposCmd.Net
"EnableAnalogPositionSetpoint" enable the execution mask for analog position setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableAnalogPositionSetpoint()
Public Sub EnableAnalogPositionSetpoint
public:
void EnableAnalogPositionSetpoint()
member EnableAnalogPositionSetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


PositionModeAdvanced Properties

PositionModeAdvanced Properties EposCmd.Net

The PositionModeAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

PositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode Class

ProfilePositionMode Class EposCmd.Net
Profile Position Mode (PPM) methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationProfilePositionMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ProfilePositionMode : DeviceCommandGroup
Public Class ProfilePositionMode
    Inherits DeviceCommandGroup
public ref class ProfilePositionMode : public DeviceCommandGroup
type ProfilePositionMode =
    class
        inherit DeviceCommandGroup
    end

The ProfilePositionMode type exposes the following members.

Constructors
 | Name | Description
Public method | ProfilePositionMode | Initializes a new instance of the ProfilePositionMode class.
Top
Methods
 | Name | Description
Public method | ActivateProfilePositionMode | With the function "ActivateProfilePositionMode" the device changes to profile position mode (PPM).
Public method | GetPositionProfile | "GetPositionProfile" returns the position profile parameters.
Public method | GetTargetPosition | The function "GetTargetPosition" returns the profile position mode target value.
Public method | HaltPositionMovement | With function "HaltPositionMovement" movement stops with profile deceleration.
Public method | MoveToPosition | With function "MoveToPosition" device movement starts with position profile to target position.
Public method | SetPositionProfile | "SetPositionProfile" sets the position profile parameters.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode Constructor

ProfilePositionMode Constructor EposCmd.Net
Initializes a new instance of the ProfilePositionMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfilePositionMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
ProfilePositionMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> ProfilePositionMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode Methods

ProfilePositionMode Methods EposCmd.Net

The ProfilePositionMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateProfilePositionMode | With the function "ActivateProfilePositionMode" the device changes to profile position mode (PPM).
Public method | GetPositionProfile | "GetPositionProfile" returns the position profile parameters.
Public method | GetTargetPosition | The function "GetTargetPosition" returns the profile position mode target value.
Public method | HaltPositionMovement | With function "HaltPositionMovement" movement stops with profile deceleration.
Public method | MoveToPosition | With function "MoveToPosition" device movement starts with position profile to target position.
Public method | SetPositionProfile | "SetPositionProfile" sets the position profile parameters.
Top
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.ActivateProfilePositionMode Method

ProfilePositionModeActivateProfilePositionMode Method EposCmd.Net
With the function "ActivateProfilePositionMode" the device changes to profile position mode (PPM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateProfilePositionMode()
Public Sub ActivateProfilePositionMode
public:
void ActivateProfilePositionMode()
member ActivateProfilePositionMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.GetPositionProfile Method

ProfilePositionModeGetPositionProfile Method EposCmd.Net
"GetPositionProfile" returns the position profile parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetPositionProfile(
    ref uint profileVelocity,
    ref uint profileAcceleration,
    ref uint profileDeceleration
)
Public Sub GetPositionProfile (
    ByRef profileVelocity As UInteger,
    ByRef profileAcceleration As UInteger,
    ByRef profileDeceleration As UInteger
)
public:
void GetPositionProfile(
    unsigned int% profileVelocity,
    unsigned int% profileAcceleration,
    unsigned int% profileDeceleration
)
member GetPositionProfile :
        profileVelocity : uint32 byref *
        profileAcceleration : uint32 byref *
        profileDeceleration : uint32 byref -> unit

Parameters

profileVelocity
Type: SystemUInt32
Position profile velocity
profileAcceleration
Type: SystemUInt32
Position profile acceleration
profileDeceleration
Type: SystemUInt32
Position profile deceleration

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.GetTargetPosition Method

ProfilePositionModeGetTargetPosition Method EposCmd.Net
The function "GetTargetPosition" returns the profile position mode target value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetTargetPosition()
Public Function GetTargetPosition As Integer
public:
int GetTargetPosition()
member GetTargetPosition : unit -> int

Return Value

Type: Int32
target position
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.HaltPositionMovement Method

ProfilePositionModeHaltPositionMovement Method EposCmd.Net
With function "HaltPositionMovement" movement stops with profile deceleration.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void HaltPositionMovement()
Public Sub HaltPositionMovement
public:
void HaltPositionMovement()
member HaltPositionMovement : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.MoveToPosition Method

ProfilePositionModeMoveToPosition Method EposCmd.Net
With function "MoveToPosition" device movement starts with position profile to target position.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveToPosition(
    int targetPosition,
    bool absolute,
    bool immediately
)
Public Sub MoveToPosition (
    targetPosition As Integer,
    absolute As Boolean,
    immediately As Boolean
)
public:
void MoveToPosition(
    int targetPosition,
    bool absolute,
    bool immediately
)
member MoveToPosition :
        targetPosition : int *
        absolute : bool *
        immediately : bool -> unit

Parameters

targetPosition
Type: SystemInt32
Target position
absolute
Type: SystemBoolean
TRUE starts an absolute,FALSE a relative movement
immediately
Type: SystemBoolean
TRUE starts immediately, FALSE waits to end of last positioning

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.SetPositionProfile Method

ProfilePositionModeSetPositionProfile Method EposCmd.Net
"SetPositionProfile" sets the position profile parameters.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionProfile(
    uint profileVelocity,
    uint profileAcceleration,
    uint profileDeceleration
)
Public Sub SetPositionProfile (
    profileVelocity As UInteger,
    profileAcceleration As UInteger,
    profileDeceleration As UInteger
)
public:
void SetPositionProfile(
    unsigned int profileVelocity,
    unsigned int profileAcceleration,
    unsigned int profileDeceleration
)
member SetPositionProfile :
        profileVelocity : uint32 *
        profileAcceleration : uint32 *
        profileDeceleration : uint32 -> unit

Parameters

profileVelocity
Type: SystemUInt32
Position profile velocity
profileAcceleration
Type: SystemUInt32
Position profile acceleration
profileDeceleration
Type: SystemUInt32
Position profile deceleration

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode Properties

ProfilePositionMode Properties EposCmd.Net

The ProfilePositionMode type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionMode.Advanced Property

ProfilePositionModeAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfilePositionModeAdvanced Advanced { get; }
Public ReadOnly Property Advanced As ProfilePositionModeAdvanced
    Get
public:
property ProfilePositionModeAdvanced^ Advanced {
    ProfilePositionModeAdvanced^ get ();
}
member Advanced : ProfilePositionModeAdvanced with get

Property Value

Type: ProfilePositionModeAdvanced
The advanced.
See Also

Reference

ProfilePositionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced Class

ProfilePositionModeAdvanced Class EposCmd.Net
Advanced Profile Position Mode (PPM)
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationProfilePositionModeAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ProfilePositionModeAdvanced : DeviceCommandGroup
Public Class ProfilePositionModeAdvanced
    Inherits DeviceCommandGroup
public ref class ProfilePositionModeAdvanced : public DeviceCommandGroup
type ProfilePositionModeAdvanced =
    class
        inherit DeviceCommandGroup
    end

The ProfilePositionModeAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | ProfilePositionModeAdvanced | Initializes a new instance of the ProfilePositionModeAdvanced class.
Top
Methods
 | Name | Description
Public method | DisablePositionWindow | With function "DisablePositionWindow" the position window is deactivated.
Public method | EnablePositionWindow | With function "EnablePositionWindow" the position window is activated.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced Constructor

ProfilePositionModeAdvanced Constructor EposCmd.Net
Initializes a new instance of the ProfilePositionModeAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfilePositionModeAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
ProfilePositionModeAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> ProfilePositionModeAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

ProfilePositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced Methods

ProfilePositionModeAdvanced Methods EposCmd.Net

The ProfilePositionModeAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | DisablePositionWindow | With function "DisablePositionWindow" the position window is deactivated.
Public method | EnablePositionWindow | With function "EnablePositionWindow" the position window is activated.
Top
See Also

Reference

ProfilePositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced.DisablePositionWindow Method

ProfilePositionModeAdvancedDisablePositionWindow Method EposCmd.Net
With function "DisablePositionWindow" the position window is deactivated.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisablePositionWindow()
Public Sub DisablePositionWindow
public:
void DisablePositionWindow()
member DisablePositionWindow : unit -> unit
See Also

Reference

ProfilePositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced.EnablePositionWindow Method

ProfilePositionModeAdvancedEnablePositionWindow Method EposCmd.Net
With function "EnablePositionWindow" the position window is activated.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnablePositionWindow(
    uint positionWindow,
    ushort positionWindowTime
)
Public Sub EnablePositionWindow (
    positionWindow As UInteger,
    positionWindowTime As UShort
)
public:
void EnablePositionWindow(
    unsigned int positionWindow,
    unsigned short positionWindowTime
)
member EnablePositionWindow :
        positionWindow : uint32 *
        positionWindowTime : uint16 -> unit

Parameters

positionWindow
Type: SystemUInt32
Position window value
positionWindowTime
Type: SystemUInt16
Position window time value
See Also

Reference

ProfilePositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfilePositionModeAdvanced Properties

ProfilePositionModeAdvanced Properties EposCmd.Net

The ProfilePositionModeAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

ProfilePositionModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode Class

ProfileVelocityMode Class EposCmd.Net
Profile Velocity mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationProfileVelocityMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ProfileVelocityMode : DeviceCommandGroup
Public Class ProfileVelocityMode
    Inherits DeviceCommandGroup
public ref class ProfileVelocityMode : public DeviceCommandGroup
type ProfileVelocityMode =
    class
        inherit DeviceCommandGroup
    end

The ProfileVelocityMode type exposes the following members.

Constructors
 | Name | Description
Public method | ProfileVelocityMode | Initializes a new instance of the ProfileVelocityMode class.
Top
Methods
 | Name | Description
Public method | ActivateProfileVelocityMode | Activates the profile velocity mode.
Public method | GetTargetVelocity | Gets the target velocity.
Public method | GetVelocityProfile | Gets the velocity profile.
Public method | HaltVelocityMovement | Halts the velocity movement.
Public method | MoveWithVelocity | Moves the with velocity.
Public method | SetVelocityProfile | Sets the velocity profile.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode Constructor

ProfileVelocityMode Constructor EposCmd.Net
Initializes a new instance of the ProfileVelocityMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfileVelocityMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
ProfileVelocityMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> ProfileVelocityMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode Methods

ProfileVelocityMode Methods EposCmd.Net

The ProfileVelocityMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateProfileVelocityMode | Activates the profile velocity mode.
Public method | GetTargetVelocity | Gets the target velocity.
Public method | GetVelocityProfile | Gets the velocity profile.
Public method | HaltVelocityMovement | Halts the velocity movement.
Public method | MoveWithVelocity | Moves the with velocity.
Public method | SetVelocityProfile | Sets the velocity profile.
Top
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.ActivateProfileVelocityMode Method

ProfileVelocityModeActivateProfileVelocityMode Method EposCmd.Net
Activates the profile velocity mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateProfileVelocityMode()
Public Sub ActivateProfileVelocityMode
public:
void ActivateProfileVelocityMode()
member ActivateProfileVelocityMode : unit -> unit
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.GetTargetVelocity Method

ProfileVelocityModeGetTargetVelocity Method EposCmd.Net
Gets the target velocity.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public int GetTargetVelocity()
Public Function GetTargetVelocity As Integer
public:
int GetTargetVelocity()
member GetTargetVelocity : unit -> int

Return Value

Type: Int32
target velocity
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.GetVelocityProfile Method

ProfileVelocityModeGetVelocityProfile Method EposCmd.Net
Gets the velocity profile.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVelocityProfile(
    ref uint profileAcceleration,
    ref uint profileDeceleration
)
Public Sub GetVelocityProfile (
    ByRef profileAcceleration As UInteger,
    ByRef profileDeceleration As UInteger
)
public:
void GetVelocityProfile(
    unsigned int% profileAcceleration,
    unsigned int% profileDeceleration
)
member GetVelocityProfile :
        profileAcceleration : uint32 byref *
        profileDeceleration : uint32 byref -> unit

Parameters

profileAcceleration
Type: SystemUInt32
The profile acceleration.
profileDeceleration
Type: SystemUInt32
The profile deceleration.
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.HaltVelocityMovement Method

ProfileVelocityModeHaltVelocityMovement Method EposCmd.Net
Halts the velocity movement.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void HaltVelocityMovement()
Public Sub HaltVelocityMovement
public:
void HaltVelocityMovement()
member HaltVelocityMovement : unit -> unit
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.MoveWithVelocity Method

ProfileVelocityModeMoveWithVelocity Method EposCmd.Net
Moves the with velocity.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveWithVelocity(
    int targetVelocity
)
Public Sub MoveWithVelocity (
    targetVelocity As Integer
)
public:
void MoveWithVelocity(
    int targetVelocity
)
member MoveWithVelocity :
        targetVelocity : int -> unit

Parameters

targetVelocity
Type: SystemInt32
The target velocity.
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.SetVelocityProfile Method

ProfileVelocityModeSetVelocityProfile Method EposCmd.Net
Sets the velocity profile.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVelocityProfile(
    uint profileAcceleration,
    uint profileDeceleration
)
Public Sub SetVelocityProfile (
    profileAcceleration As UInteger,
    profileDeceleration As UInteger
)
public:
void SetVelocityProfile(
    unsigned int profileAcceleration,
    unsigned int profileDeceleration
)
member SetVelocityProfile :
        profileAcceleration : uint32 *
        profileDeceleration : uint32 -> unit

Parameters

profileAcceleration
Type: SystemUInt32
The profile acceleration.
profileDeceleration
Type: SystemUInt32
The profile deceleration.
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode Properties

ProfileVelocityMode Properties EposCmd.Net

The ProfileVelocityMode type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityMode.Advanced Property

ProfileVelocityModeAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfileVelocityModeAdvanced Advanced { get; }
Public ReadOnly Property Advanced As ProfileVelocityModeAdvanced
    Get
public:
property ProfileVelocityModeAdvanced^ Advanced {
    ProfileVelocityModeAdvanced^ get ();
}
member Advanced : ProfileVelocityModeAdvanced with get

Property Value

Type: ProfileVelocityModeAdvanced
The advanced.
See Also

Reference

ProfileVelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced Class

ProfileVelocityModeAdvanced Class EposCmd.Net
Advanced Profile Velocity Mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationProfileVelocityModeAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ProfileVelocityModeAdvanced : DeviceCommandGroup
Public Class ProfileVelocityModeAdvanced
    Inherits DeviceCommandGroup
public ref class ProfileVelocityModeAdvanced : public DeviceCommandGroup
type ProfileVelocityModeAdvanced =
    class
        inherit DeviceCommandGroup
    end

The ProfileVelocityModeAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | ProfileVelocityModeAdvanced | Initializes a new instance of the ProfileVelocityModeAdvanced class.
Top
Methods
 | Name | Description
Public method | DisableVelocityWindow | With function "DisableVelocityWindow" the velocity window is deactivated.
Public method | EnableVelocityWindow | With function "EnableVelocityWindow" the velocity window is activated.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced Constructor

ProfileVelocityModeAdvanced Constructor EposCmd.Net
Initializes a new instance of the ProfileVelocityModeAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public ProfileVelocityModeAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
ProfileVelocityModeAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> ProfileVelocityModeAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

ProfileVelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced Methods

ProfileVelocityModeAdvanced Methods EposCmd.Net

The ProfileVelocityModeAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | DisableVelocityWindow | With function "DisableVelocityWindow" the velocity window is deactivated.
Public method | EnableVelocityWindow | With function "EnableVelocityWindow" the velocity window is activated.
Top
See Also

Reference

ProfileVelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced.DisableVelocityWindow Method

ProfileVelocityModeAdvancedDisableVelocityWindow Method EposCmd.Net
With function "DisableVelocityWindow" the velocity window is deactivated.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableVelocityWindow()
Public Sub DisableVelocityWindow
public:
void DisableVelocityWindow()
member DisableVelocityWindow : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfileVelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced.EnableVelocityWindow Method

ProfileVelocityModeAdvancedEnableVelocityWindow Method EposCmd.Net
With function "EnableVelocityWindow" the velocity window is activated.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableVelocityWindow(
    uint velocityWindow,
    ushort velocityWindowTime
)
Public Sub EnableVelocityWindow (
    velocityWindow As UInteger,
    velocityWindowTime As UShort
)
public:
void EnableVelocityWindow(
    unsigned int velocityWindow,
    unsigned short velocityWindowTime
)
member EnableVelocityWindow :
        velocityWindow : uint32 *
        velocityWindowTime : uint16 -> unit

Parameters

velocityWindow
Type: SystemUInt32
Velocity window value
velocityWindowTime
Type: SystemUInt16
Velocity window time value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

ProfileVelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


ProfileVelocityModeAdvanced Properties

ProfileVelocityModeAdvanced Properties EposCmd.Net

The ProfileVelocityModeAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

ProfileVelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine Class

StateMachine Class EposCmd.Net
State Machine methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationStateMachine

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class StateMachine : DeviceCommandGroup
Public Class StateMachine
    Inherits DeviceCommandGroup
public ref class StateMachine : public DeviceCommandGroup
type StateMachine =
    class
        inherit DeviceCommandGroup
    end

The StateMachine type exposes the following members.

Constructors
 | Name | Description
Public method | StateMachine | Initializes a new instance of the StateMachine class.
Top
Methods
 | Name | Description
Public method | ClearFault | With function "ClearFault" the device changes from fault state to disable state.
Public method | GetDisableState | The function "GetDisableState" checks if the device is disabled.
Public method | GetEnableState | The function "GetEnableState" checks if the device is enabled.
Public method | GetFaultState | The function "GetFaultState" returns the device state fault.
Public method | GetQuickStopState | The function "GetQuickStopState" returns the device state quick stop.
Public method | GetState | GetState reads the new state for the state machine.
Public method | ResetDevice | The function "ResetDevice" is used to send the NMT service ‘Reset Node’. It is a command without acknowledge.
Public method | SetDisableState | With function "SetDisableState" changes the device to disable state.
Public method | SetEnableState | With the function "SetEnableState" the device changes to enable state.
Public method | SetQuickStopState | With function "SetQuickStopState" the device changes to quick stop state.
Public method | SetState | SetState writes the current state machine state.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine Constructor

StateMachine Constructor EposCmd.Net
Initializes a new instance of the StateMachine class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public StateMachine(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
StateMachine(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> StateMachine

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine Methods

StateMachine Methods EposCmd.Net

The StateMachine type exposes the following members.

Methods
 | Name | Description
Public method | ClearFault | With function "ClearFault" the device changes from fault state to disable state.
Public method | GetDisableState | The function "GetDisableState" checks if the device is disabled.
Public method | GetEnableState | The function "GetEnableState" checks if the device is enabled.
Public method | GetFaultState | The function "GetFaultState" returns the device state fault.
Public method | GetQuickStopState | The function "GetQuickStopState" returns the device state quick stop.
Public method | GetState | GetState reads the new state for the state machine.
Public method | ResetDevice | The function "ResetDevice" is used to send the NMT service ‘Reset Node’. It is a command without acknowledge.
Public method | SetDisableState | With function "SetDisableState" changes the device to disable state.
Public method | SetEnableState | With the function "SetEnableState" the device changes to enable state.
Public method | SetQuickStopState | With function "SetQuickStopState" the device changes to quick stop state.
Public method | SetState | SetState writes the current state machine state.
Top
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.ClearFault Method

StateMachineClearFault Method EposCmd.Net
With function "ClearFault" the device changes from fault state to disable state.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearFault()
Public Sub ClearFault
public:
void ClearFault()
member ClearFault : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.GetDisableState Method

StateMachineGetDisableState Method EposCmd.Net
The function "GetDisableState" checks if the device is disabled.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetDisableState()
Public Function GetDisableState As Boolean
public:
bool GetDisableState()
member GetDisableState : unit -> bool

Return Value

Type: Boolean
disabled=true,enabled=false
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.GetEnableState Method

StateMachineGetEnableState Method EposCmd.Net
The function "GetEnableState" checks if the device is enabled.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetEnableState()
Public Function GetEnableState As Boolean
public:
bool GetEnableState()
member GetEnableState : unit -> bool

Return Value

Type: Boolean
enabled=true,disabled=false
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.GetFaultState Method

StateMachineGetFaultState Method EposCmd.Net
The function "GetFaultState" returns the device state fault.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetFaultState()
Public Function GetFaultState As Boolean
public:
bool GetFaultState()
member GetFaultState : unit -> bool

Return Value

Type: Boolean
in fault state = true
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.GetQuickStopState Method

StateMachineGetQuickStopState Method EposCmd.Net
The function "GetQuickStopState" returns the device state quick stop.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetQuickStopState()
Public Function GetQuickStopState As Boolean
public:
bool GetQuickStopState()
member GetQuickStopState : unit -> bool

Return Value

Type: Boolean
quick stop = true
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.GetState Method

StateMachineGetState Method EposCmd.Net
GetState reads the new state for the state machine.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public EStates GetState()
Public Function GetState As EStates
public:
EStates GetState()
member GetState : unit -> EStates

Return Value

Type: EStates
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.ResetDevice Method

StateMachineResetDevice Method EposCmd.Net
The function "ResetDevice" is used to send the NMT service ‘Reset Node’. It is a command without acknowledge.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDevice()
Public Sub ResetDevice
public:
void ResetDevice()
member ResetDevice : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.SetDisableState Method

StateMachineSetDisableState Method EposCmd.Net
With function "SetDisableState" changes the device to disable state.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDisableState()
Public Sub SetDisableState
public:
void SetDisableState()
member SetDisableState : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.SetEnableState Method

StateMachineSetEnableState Method EposCmd.Net
With the function "SetEnableState" the device changes to enable state.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEnableState()
Public Sub SetEnableState
public:
void SetEnableState()
member SetEnableState : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.SetQuickStopState Method

StateMachineSetQuickStopState Method EposCmd.Net
With function "SetQuickStopState" the device changes to quick stop state.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetQuickStopState()
Public Sub SetQuickStopState
public:
void SetQuickStopState()
member SetQuickStopState : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine.SetState Method

StateMachineSetState Method EposCmd.Net
SetState writes the current state machine state.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetState(
    EStates state
)
Public Sub SetState (
    state As EStates
)
public:
void SetState(
    EStates state
)
member SetState :
        state : EStates -> unit

Parameters

state
Type: EposCmd.NetEStates
The state.
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StateMachine Properties

StateMachine Properties EposCmd.Net

The StateMachine type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

StateMachine Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode Class

StepDirectionMode Class EposCmd.Net
Step Direction mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationStepDirectionMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class StepDirectionMode : DeviceCommandGroup
Public Class StepDirectionMode
    Inherits DeviceCommandGroup
public ref class StepDirectionMode : public DeviceCommandGroup
type StepDirectionMode =
    class
        inherit DeviceCommandGroup
    end

The StepDirectionMode type exposes the following members.

Constructors
 | Name | Description
Public method | StepDirectionMode | Initializes a new instance of the StepDirectionMode class.
Top
Methods
 | Name | Description
Public method | ActivateStepDirectionMode | With the function "ActivateStepDirectionMode" the device changes to step direction mode (SDM).
Public method | GetStepDirectionParameter | With function "GetStepDirectionParameter" it is possible to read all parameters for step direction mode.
Public method | SetStepDirectionParameter | With function "SetStepDirectionParameter" it is possible to write all parameters for step direction mode.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode Constructor

StepDirectionMode Constructor EposCmd.Net
Initializes a new instance of the StepDirectionMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public StepDirectionMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
StepDirectionMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> StepDirectionMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode Methods

StepDirectionMode Methods EposCmd.Net

The StepDirectionMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateStepDirectionMode | With the function "ActivateStepDirectionMode" the device changes to step direction mode (SDM).
Public method | GetStepDirectionParameter | With function "GetStepDirectionParameter" it is possible to read all parameters for step direction mode.
Public method | SetStepDirectionParameter | With function "SetStepDirectionParameter" it is possible to write all parameters for step direction mode.
Top
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode.ActivateStepDirectionMode Method

StepDirectionModeActivateStepDirectionMode Method EposCmd.Net
With the function "ActivateStepDirectionMode" the device changes to step direction mode (SDM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateStepDirectionMode()
Public Sub ActivateStepDirectionMode
public:
void ActivateStepDirectionMode()
member ActivateStepDirectionMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode.GetStepDirectionParameter Method

StepDirectionModeGetStepDirectionParameter Method EposCmd.Net
With function "GetStepDirectionParameter" it is possible to read all parameters for step direction mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetStepDirectionParameter(
    ref ushort scalingNumerator,
    ref ushort scalingDenominator,
    ref byte polarity,
    ref uint maxVelocity,
    ref uint maxAcceleration
)
Public Sub GetStepDirectionParameter (
    ByRef scalingNumerator As UShort,
    ByRef scalingDenominator As UShort,
    ByRef polarity As Byte,
    ByRef maxVelocity As UInteger,
    ByRef maxAcceleration As UInteger
)
public:
void GetStepDirectionParameter(
    unsigned short% scalingNumerator,
    unsigned short% scalingDenominator,
    unsigned char% polarity,
    unsigned int% maxVelocity,
    unsigned int% maxAcceleration
)
member GetStepDirectionParameter :
        scalingNumerator : uint16 byref *
        scalingDenominator : uint16 byref *
        polarity : byte byref *
        maxVelocity : uint32 byref *
        maxAcceleration : uint32 byref -> unit

Parameters

scalingNumerator
Type: SystemUInt16
Scaling numerator for position calculation
scalingDenominator
Type: SystemUInt16
Scaling denominator for position calculation
polarity
Type: SystemByte
Polarity of the direction input. 0: Positive
br>1: Negative
maxVelocity
Type: SystemUInt32
This parameter is the maximal allowed speed during a profiled move.
maxAcceleration
Type: SystemUInt32
Defines the maximal allowed acceleration.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode.SetStepDirectionParameter Method

StepDirectionModeSetStepDirectionParameter Method EposCmd.Net
With function "SetStepDirectionParameter" it is possible to write all parameters for step direction mode.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStepDirectionParameter(
    ushort scalingNumerator,
    ushort scalingDenominator,
    byte polarity,
    uint maxVelocity,
    uint maxAcceleration
)
Public Sub SetStepDirectionParameter (
    scalingNumerator As UShort,
    scalingDenominator As UShort,
    polarity As Byte,
    maxVelocity As UInteger,
    maxAcceleration As UInteger
)
public:
void SetStepDirectionParameter(
    unsigned short scalingNumerator,
    unsigned short scalingDenominator,
    unsigned char polarity,
    unsigned int maxVelocity,
    unsigned int maxAcceleration
)
member SetStepDirectionParameter :
        scalingNumerator : uint16 *
        scalingDenominator : uint16 *
        polarity : byte *
        maxVelocity : uint32 *
        maxAcceleration : uint32 -> unit

Parameters

scalingNumerator
Type: SystemUInt16
Scaling numerator for position calculation
scalingDenominator
Type: SystemUInt16
Scaling denominator for position calculation
polarity
Type: SystemByte
Polarity of the direction input. 0: Positive 1: Negative
maxVelocity
Type: SystemUInt32
This parameter is the maximal allowed speed during a profiled move.
maxAcceleration
Type: SystemUInt32
Defines the maximal allowed acceleration.

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


StepDirectionMode Properties

StepDirectionMode Properties EposCmd.Net

The StepDirectionMode type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

StepDirectionMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode Class

VelocityMode Class EposCmd.Net
Velocity mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationVelocityMode

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class VelocityMode : DeviceCommandGroup
Public Class VelocityMode
    Inherits DeviceCommandGroup
public ref class VelocityMode : public DeviceCommandGroup
type VelocityMode =
    class
        inherit DeviceCommandGroup
    end

The VelocityMode type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityMode | Initializes a new instance of the VelocityMode class.
Top
Methods
 | Name | Description
Public method | ActivateVelocityMode | With the function "ActivateVelocityMode" the device changes to velocity mode (VM).
Public method | GetVelocityMust | The function "GetVelocityMust" returns the position mode setting value.
Public method | SetVelocityMust | The function "SetVelocityMust" sets the velocity mode setting value.
Top
Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode Constructor

VelocityMode Constructor EposCmd.Net
Initializes a new instance of the VelocityMode class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public VelocityMode(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
VelocityMode(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> VelocityMode

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode Methods

VelocityMode Methods EposCmd.Net

The VelocityMode type exposes the following members.

Methods
 | Name | Description
Public method | ActivateVelocityMode | With the function "ActivateVelocityMode" the device changes to velocity mode (VM).
Public method | GetVelocityMust | The function "GetVelocityMust" returns the position mode setting value.
Public method | SetVelocityMust | The function "SetVelocityMust" sets the velocity mode setting value.
Top
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode.ActivateVelocityMode Method

VelocityModeActivateVelocityMode Method EposCmd.Net
With the function "ActivateVelocityMode" the device changes to velocity mode (VM).

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateVelocityMode()
Public Sub ActivateVelocityMode
public:
void ActivateVelocityMode()
member ActivateVelocityMode : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode.GetVelocityMust Method

VelocityModeGetVelocityMust Method EposCmd.Net
The function "GetVelocityMust" returns the position mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void GetVelocityMust(
    ref int velocityMust
)
Public Sub GetVelocityMust (
    ByRef velocityMust As Integer
)
public:
void GetVelocityMust(
    int% velocityMust
)
member GetVelocityMust :
        velocityMust : int byref -> unit

Parameters

velocityMust
Type: SystemInt32
Velocity mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode.SetVelocityMust Method

VelocityModeSetVelocityMust Method EposCmd.Net
The function "SetVelocityMust" sets the velocity mode setting value.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVelocityMust(
    int velocityMust
)
Public Sub SetVelocityMust (
    velocityMust As Integer
)
public:
void SetVelocityMust(
    int velocityMust
)
member SetVelocityMust :
        velocityMust : int -> unit

Parameters

velocityMust
Type: SystemInt32
Velocity mode setting value

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode Properties

VelocityMode Properties EposCmd.Net

The VelocityMode type exposes the following members.

Properties
 | Name | Description
Public property | Advanced | Gets the access to the advanced/specialized functions.
 | LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityMode.Advanced Property

VelocityModeAdvanced Property EposCmd.Net
Gets the access to the advanced/specialized functions.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public VelocityModeAdvanced Advanced { get; }
Public ReadOnly Property Advanced As VelocityModeAdvanced
    Get
public:
property VelocityModeAdvanced^ Advanced {
    VelocityModeAdvanced^ get ();
}
member Advanced : VelocityModeAdvanced with get

Property Value

Type: VelocityModeAdvanced
The advanced.
See Also

Reference

VelocityMode Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced Class

VelocityModeAdvanced Class EposCmd.Net
Advanced Velocity mode methods
Inheritance Hierarchy
SystemObject
EposCmd.NetErrorHandling
EposCmd.NetDeviceCommandGroup
EposCmd.Net.DeviceCmdSet.OperationVelocityModeAdvanced

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class VelocityModeAdvanced : DeviceCommandGroup
Public Class VelocityModeAdvanced
    Inherits DeviceCommandGroup
public ref class VelocityModeAdvanced : public DeviceCommandGroup
type VelocityModeAdvanced =
    class
        inherit DeviceCommandGroup
    end

The VelocityModeAdvanced type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityModeAdvanced | Initializes a new instance of the VelocityModeAdvanced class.
Top
Methods
 | Name | Description
Public method | ActivateAnalogVelocitySetpoint | "ActivateAnalogVelocitySetpoint" configures the selected analog input for analog velocity setpoint.
Public method | DeactivateAnalogVelocitySetpoint | "DeactivateAnalogVelocitySetpoint" disable the selected analog input for analog velocity setpoint.
Public method | DisableAnalogVelocitySetpoint | "DisableAnalogVelocitySetpoint" disable the execution mask for analog velocity setpoint.
Public method | EnableAnalogVelocitySetpoint | "EnableAnalogVelocitySetpoint" enable the execution mask for analog velocity setpoint.
Top
Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced Constructor

VelocityModeAdvanced Constructor EposCmd.Net
Initializes a new instance of the VelocityModeAdvanced class.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public VelocityModeAdvanced(
    int keyHandle,
    ushort nodeId
)
Public Sub New (
    keyHandle As Integer,
    nodeId As UShort
)
public:
VelocityModeAdvanced(
    int keyHandle,
    unsigned short nodeId
)
new :
        keyHandle : int *
        nodeId : uint16 -> VelocityModeAdvanced

Parameters

keyHandle
Type: SystemInt32
The key handle.
nodeId
Type: SystemUInt16
Node ID of the addressed device. ID is given from hardware switches or the layer setting services (LSS).
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced Methods

VelocityModeAdvanced Methods EposCmd.Net

The VelocityModeAdvanced type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAnalogVelocitySetpoint | "ActivateAnalogVelocitySetpoint" configures the selected analog input for analog velocity setpoint.
Public method | DeactivateAnalogVelocitySetpoint | "DeactivateAnalogVelocitySetpoint" disable the selected analog input for analog velocity setpoint.
Public method | DisableAnalogVelocitySetpoint | "DisableAnalogVelocitySetpoint" disable the execution mask for analog velocity setpoint.
Public method | EnableAnalogVelocitySetpoint | "EnableAnalogVelocitySetpoint" enable the execution mask for analog velocity setpoint.
Top
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced.ActivateAnalogVelocitySetpoint Method

VelocityModeAdvancedActivateAnalogVelocitySetpoint Method EposCmd.Net
"ActivateAnalogVelocitySetpoint" configures the selected analog input for analog velocity setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateAnalogVelocitySetpoint(
    ushort analogInputNumber,
    float scaling,
    int offset
)
Public Sub ActivateAnalogVelocitySetpoint (
    analogInputNumber As UShort,
    scaling As Single,
    offset As Integer
)
public:
void ActivateAnalogVelocitySetpoint(
    unsigned short analogInputNumber,
    float scaling,
    int offset
)
member ActivateAnalogVelocitySetpoint :
        analogInputNumber : uint16 *
        scaling : float32 *
        offset : int -> unit

Parameters

analogInputNumber
Type: SystemUInt16
Number of the used analog input
scaling
Type: SystemSingle
The scaling factor for analog velocity setpoint functionality
offset
Type: SystemInt32
Offset for analog velocity setpoint functionality

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced.DeactivateAnalogVelocitySetpoint Method

VelocityModeAdvancedDeactivateAnalogVelocitySetpoint Method EposCmd.Net
"DeactivateAnalogVelocitySetpoint" disable the selected analog input for analog velocity setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateAnalogVelocitySetpoint(
    ushort analogInputNumber
)
Public Sub DeactivateAnalogVelocitySetpoint (
    analogInputNumber As UShort
)
public:
void DeactivateAnalogVelocitySetpoint(
    unsigned short analogInputNumber
)
member DeactivateAnalogVelocitySetpoint :
        analogInputNumber : uint16 -> unit

Parameters

analogInputNumber
Type: SystemUInt16
Number of the used analog input

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced.DisableAnalogVelocitySetpoint Method

VelocityModeAdvancedDisableAnalogVelocitySetpoint Method EposCmd.Net
"DisableAnalogVelocitySetpoint" disable the execution mask for analog velocity setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableAnalogVelocitySetpoint()
Public Sub DisableAnalogVelocitySetpoint
public:
void DisableAnalogVelocitySetpoint()
member DisableAnalogVelocitySetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced.EnableAnalogVelocitySetpoint Method

VelocityModeAdvancedEnableAnalogVelocitySetpoint Method EposCmd.Net
"EnableAnalogVelocitySetpoint" enable the execution mask for analog velocity setpoint.

Namespace: EposCmd.Net.DeviceCmdSet.Operation
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableAnalogVelocitySetpoint()
Public Sub EnableAnalogVelocitySetpoint
public:
void EnableAnalogVelocitySetpoint()
member EnableAnalogVelocitySetpoint : unit -> unit

Return Value

Type:
In the case of the failure, throws the exception with the error code
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


VelocityModeAdvanced Properties

VelocityModeAdvanced Properties EposCmd.Net

The VelocityModeAdvanced type exposes the following members.

Properties
Name | Description
LastError | Use this propery to get the error status for the last operation that failed. (Inherited from ErrorHandling.)
Top
See Also

Reference

VelocityModeAdvanced Class
EposCmd.Net.DeviceCmdSet.Operation Namespace


EposCmd.Net.VcsWrapper Namespace

EposCmd.Net.VcsWrapper Namespace EposCmd.Net
The namespace containing wrapper class for the virtual command set.
Classes
 | Class | Description
Public class | NamespaceDoc |


NamespaceDoc Class

NamespaceDoc Class EposCmd.Net

[Missing <summary> documentation for "T:EposCmd.Net.VcsWrapper.NamespaceDoc"]

Inheritance Hierarchy
SystemObject
EposCmd.Net.VcsWrapperNamespaceDoc

Namespace: EposCmd.Net.VcsWrapper
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public class NamespaceDoc
Public Class NamespaceDoc
public ref class NamespaceDoc
type NamespaceDoc =  class end

The NamespaceDoc type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceDoc | Initializes a new instance of the NamespaceDoc class
Top
See Also

Reference

EposCmd.Net.VcsWrapper Namespace


NamespaceDoc Constructor

NamespaceDoc Constructor EposCmd.Net
Initializes a new instance of the NamespaceDoc class

Namespace: EposCmd.Net.VcsWrapper
Assembly: EposCmd.Net (in EposCmd.Net.dll) Version: 6.1.2.0 (6.1.2.0)
Syntax
C#
VB
C++
F#
Copy
public NamespaceDoc()
Public Sub New
public:
NamespaceDoc()
new : unit -> NamespaceDoc
See Also

Reference

NamespaceDoc Class
EposCmd.Net.VcsWrapper Namespace