X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Modules

X-CUBE-SPN8 for X-NUCLEO-IHM08M1
  • Main Page
  • Modules
  • Classes
  • Files
Modules
Here is a list of all modules:
[detail level 12345]
▼ DRIVERS | Driver Layer
▼ BSP | BSP Layer
▼ COMPONENTS | Components
L6398_Motor_Driver_handler | Handler for L6398 Motor driver
▼ L6398 | L6398 driver section
L6398MotorDriver | API pointer for L6398
EnableInput_CH1_E_CH2_E_CH3_D | Enable Input channel CH1 and CH2 for L6398
EnableInput_CH1_E_CH2_D_CH3_E | Enable Input channel CH1 and CH3 for L6398
EnableInput_CH1_D_CH2_E_CH3_E | Enable Input channel CH2 and CH3 for L6398
DisableInput_CH1_D_CH2_D_CH3_D | Enable Input channel CH2 and CH3 for L6398
Start_PWM_driving | Enable PWM channels for L6398
Stop_PWM_driving | Disable PWM channels for L6398
HF_TIMx_SetDutyCycle_CH1 | Set the Duty Cycle value for CH1
HF_TIMx_SetDutyCycle_CH2 | Set the Duty Cycle value for CH2
HF_TIMx_SetDutyCycle_CH3 | Set the Duty Cycle value for CH3
Current_Reference_Start | Enable the Current Reference generation
Current_Reference_Stop | Disable the Current Reference generation
Current_Reference_Setvalue | Set the value for Current Reference
▼ X-NUCLEO-IHM08M1 | X-Nucleo board
L6398_ECH1CH2_DCH3_IO_Write | Enable Input channel CH1 and CH2 for L6398
L6398_ECH1CH3_DCH2_IO_Write | Enable Input channel CH1 and CH3 for L6398
L6398_ECH2CH3_DCH1_IO_Write | Enable Input channel CH2 and CH3 for L6398
L6398_DCH1CH2CH3_IO_Write | Disable all channels for L6398
L6398_Start_PWM_generation | Enable the PWM generation on Input channels for L6398
L6398_Stop_PWM_generation | Disable the PWM generation on Input channels for L6398
L6398_HFTIM_DC_CH1 | Set the Duty Cycle value for CH1
L6398_HFTIM_DC_CH2 | Set the Duty Cycle value for CH2
L6398_HFTIM_DC_CH3 | Set the Duty Cycle value for CH3
BSP_X_NUCLEO_FAULT_LED_ON | Turns selected LED On
BSP_X_NUCLEO_FAULT_LED_OFF | Turns selected LED Off
▼ MIDDLEWARES | Middlewares Layer
▼ MC_6-STEP_LIB | Motor Control driver
Exported_types |
Exported_function_6StepLib |
MC_SixStep_TABLE | Set the peripherals (TIMx, GPIO etc.) for each step
MC_SixStep_NEXT_step | Generate the next step number according with the direction (CW or CCW)
MC_SixStep_RESET | Reset all variables used for 6Step control algorithm
MC_SixStep_Ramp_Motor_calc | Calculate the acceleration profile step by step for motor during start-up
MC_SixStep_ARR_step | Generate the ARR value for Low Frequency TIM during start-up
MC_SixStep_Alignment | Generate the motor alignment
MC_SixStep_Speed_Val_target_potentiometer | Calculate the Motor Speed validation threshold according with the potentiometer value
MC_SixStep_Speed_Potentiometer | Calculate the potentiometer value to set the Motor Speed
MC_Set_PI_param | Set all parameters for PI regulator
MC_PI_Controller | Compute the PI output for the Current Reference
MC_Task_Speed | Main task: Speed Loop with PI regulator
MC_Set_Speed | Set the new motor speed value
MC_Bemf_Delay | Take the delay time after each new 6-step commutation
MC_StartMotor | Start the Motor
MC_StopMotor | Stop the Motor
MC_GetElSpeedHz | Get the Eletrical Motor Speed from ARR value of LF TIM
MC_GetMechSpeedRPM | Get the Mechanical Motor Speed (RPM)
MC_SixStep_Init_main_data | Init the main variables for motor driving from MC_SixStep_param.h
MC_SixStep_INIT | Initialitation function for SixStep library
MC_TIMx_SixStep_timebase | Low Frequency Timer Callback - Call the next step and request the filtered speed value
MC_Speed_Filter | Calculate the speed filtered
MC_Bemf_delay_Filter | Calculate the Bemf delay time filtered
MC_Potentiometer_filter | Calculate the filtered potentiometer value
MC_SysTick_SixStep_MediumFrequencyTask | Systick Callback - Call the Speed loop
MC_SixStep_ARR_Bemf | Calculate the new Autoreload value (ARR) for Low Frequency timer
MC_ADCx_SixStep_Bemf | Compute the zero crossing detection
MC_EXT_button_SixStep | GPIO EXT Callback - Start or Stop the motor through the Blue push button on STM32Nucleo
Main_Motor_parameters | All motor parameters for 6Step driving
▼ UART_UI | Serial communication through PC serial terminal
Exported_function_Uart |
▼ stm32F302_nucleo_ihm08m1 | Interface file for STM32F302 and Library configuration
Exported_function_F302 |
▼ stm32F401_nucleo_ihm08m1 | Interface file for STM32F401 and Library configuration
Exported_function_F401 |
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: DRIVERS

  • Classes
  • Files
Modules
DRIVERS

Driver Layer. More...

Collaboration diagram for DRIVERS:

Modules

BSP
BSP Layer.

Detailed Description

Driver Layer.

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: BSP

Modules
BSP
DRIVERS

BSP Layer. More...

Collaboration diagram for BSP:

Modules

COMPONENTS
Components.
X-NUCLEO-IHM08M1
X-Nucleo board.

Detailed Description

BSP Layer.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: COMPONENTS

Modules
COMPONENTS
DRIVERS » BSP

Components. More...

Collaboration diagram for COMPONENTS:

Modules

L6398_Motor_Driver_handler
Handler for L6398 Motor driver.
L6398
L6398 driver section.

Detailed Description

Components.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_Motor_Driver_handler

Classes
L6398_Motor_Driver_handler
DRIVERS » BSP » COMPONENTS

Handler for L6398 Motor driver. More...

Collaboration diagram for L6398_Motor_Driver_handler:

Classes

struct L6398_MotorDriver_TypeDef

Detailed Description

Handler for L6398 Motor driver.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_MotorDriver_TypeDef Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
L6398_MotorDriver_TypeDef Struct Reference
DRIVERS » BSP » COMPONENTS » L6398_Motor_Driver_handler

Public Attributes

void(* | EnableInput_CH1_E_CH2_E_CH3_D )(uint8_t, uint8_t, uint16_t)
void(* | EnableInput_CH1_E_CH2_D_CH3_E )(uint8_t, uint8_t, uint16_t)
void(* | EnableInput_CH1_D_CH2_E_CH3_E )(uint8_t, uint8_t, uint16_t)
void(* | DisableInput_CH1_D_CH2_D_CH3_D )(void)
void(* | Start_PWM_driving )(void)
void(* | Stop_PWM_driving )(void)
void(* | HF_TIMx_SetDutyCycle_CH1 )(uint16_t)
void(* | HF_TIMx_SetDutyCycle_CH2 )(uint16_t)
void(* | HF_TIMx_SetDutyCycle_CH3 )(uint16_t)
void(* | Current_Reference_Start )(void)
void(* | Current_Reference_Stop )(void)
void(* | Current_Reference_Setvalue )(uint16_t)

Member Data Documentation

void(* L6398_MotorDriver_TypeDef::Current_Reference_Setvalue) (uint16_t)

Set current reference value for closed loop control

void(* L6398_MotorDriver_TypeDef::Current_Reference_Start) (void)

Start current reference generation for closed loop control

void(* L6398_MotorDriver_TypeDef::Current_Reference_Stop) (void)

Stop current reference generation for closed loop control

void(* L6398_MotorDriver_TypeDef::DisableInput_CH1_D_CH2_D_CH3_D) (void)

Disable all channels

void(* L6398_MotorDriver_TypeDef::EnableInput_CH1_D_CH2_E_CH3_E) (uint8_t, uint8_t, uint16_t)

Enable the channel 2,3 and Disable the channel 1

void(* L6398_MotorDriver_TypeDef::EnableInput_CH1_E_CH2_D_CH3_E) (uint8_t, uint8_t, uint16_t)

Enable the channel 1,3 and Disable the channel 2

void(* L6398_MotorDriver_TypeDef::EnableInput_CH1_E_CH2_E_CH3_D) (uint8_t, uint8_t, uint16_t)

Enable the channel 1,2 and Disable the channel 3

void(* L6398_MotorDriver_TypeDef::HF_TIMx_SetDutyCycle_CH1) (uint16_t)

High Frequency Timer - Change DutyCycle value for CH1

void(* L6398_MotorDriver_TypeDef::HF_TIMx_SetDutyCycle_CH2) (uint16_t)

High Frequency Timer - Change DutyCycle value for CH2

void(* L6398_MotorDriver_TypeDef::HF_TIMx_SetDutyCycle_CH3) (uint16_t)

High Frequency Timer - Change DutyCycle value for CH3

void(* L6398_MotorDriver_TypeDef::Start_PWM_driving) (void)

Start PWM generation

void(* L6398_MotorDriver_TypeDef::Stop_PWM_driving) (void)

Stop PWM generation

The documentation for this struct was generated from the following file:
  • C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/Common/MC_Common.h


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398

Modules
L6398
DRIVERS » BSP » COMPONENTS

L6398 driver section. More...

Collaboration diagram for L6398:

Modules

L6398MotorDriver
API pointer for L6398.
EnableInput_CH1_E_CH2_E_CH3_D
Enable Input channel CH1 and CH2 for L6398.
EnableInput_CH1_E_CH2_D_CH3_E
Enable Input channel CH1 and CH3 for L6398.
EnableInput_CH1_D_CH2_E_CH3_E
Enable Input channel CH2 and CH3 for L6398.
DisableInput_CH1_D_CH2_D_CH3_D
Enable Input channel CH2 and CH3 for L6398.
Start_PWM_driving
Enable PWM channels for L6398.
Stop_PWM_driving
Disable PWM channels for L6398.
HF_TIMx_SetDutyCycle_CH1
Set the Duty Cycle value for CH1.
HF_TIMx_SetDutyCycle_CH2
Set the Duty Cycle value for CH2.
HF_TIMx_SetDutyCycle_CH3
Set the Duty Cycle value for CH3.
Current_Reference_Start
Enable the Current Reference generation.
Current_Reference_Stop
Disable the Current Reference generation.
Current_Reference_Setvalue
Set the value for Current Reference.

Detailed Description

L6398 driver section.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398MotorDriver

Variables
L6398MotorDriver
DRIVERS » BSP » COMPONENTS » L6398

API pointer for L6398. More...

Collaboration diagram for L6398MotorDriver:

Variables

L6398_MotorDriver_TypeDef L6398MotorDriver

Detailed Description

API pointer for L6398.

Variable Documentation

L6398_MotorDriver_TypeDef L6398MotorDriver
Initial value:
=
{
EnableInput_CH1_E_CH2_E_CH3_D,
EnableInput_CH1_E_CH2_D_CH3_E,
EnableInput_CH1_D_CH2_E_CH3_E,
DisableInput_CH1_D_CH2_D_CH3_D,
Start_PWM_driving,
Stop_PWM_driving,
HF_TIMx_SetDutyCycle_CH1,
HF_TIMx_SetDutyCycle_CH2,
HF_TIMx_SetDutyCycle_CH3,
Current_Reference_Start,
Current_Reference_Stop,
Current_Reference_Setvalue,
}


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: EnableInput_CH1_E_CH2_E_CH3_D

Functions
EnableInput_CH1_E_CH2_E_CH3_D
DRIVERS » BSP » COMPONENTS » L6398

Enable Input channel CH1 and CH2 for L6398. More...

Collaboration diagram for EnableInput_CH1_E_CH2_E_CH3_D:

Functions

void EnableInput_CH1_E_CH2_E_CH3_D (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH1 and CH2 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: EnableInput_CH1_E_CH2_D_CH3_E

Functions
EnableInput_CH1_E_CH2_D_CH3_E
DRIVERS » BSP » COMPONENTS » L6398

Enable Input channel CH1 and CH3 for L6398. More...

Collaboration diagram for EnableInput_CH1_E_CH2_D_CH3_E:

Functions

void EnableInput_CH1_E_CH2_D_CH3_E (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH1 and CH3 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: EnableInput_CH1_D_CH2_E_CH3_E

Functions
EnableInput_CH1_D_CH2_E_CH3_E
DRIVERS » BSP » COMPONENTS » L6398

Enable Input channel CH2 and CH3 for L6398. More...

Collaboration diagram for EnableInput_CH1_D_CH2_E_CH3_E:

Functions

void EnableInput_CH1_D_CH2_E_CH3_E (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH2 and CH3 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: DisableInput_CH1_D_CH2_D_CH3_D

Functions
DisableInput_CH1_D_CH2_D_CH3_D
DRIVERS » BSP » COMPONENTS » L6398

Enable Input channel CH2 and CH3 for L6398. More...

Collaboration diagram for DisableInput_CH1_D_CH2_D_CH3_D:

Functions

void DisableInput_CH1_D_CH2_D_CH3_D ()

Detailed Description

Enable Input channel CH2 and CH3 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Start_PWM_driving

Functions
Start_PWM_driving
DRIVERS » BSP » COMPONENTS » L6398

Enable PWM channels for L6398. More...

Collaboration diagram for Start_PWM_driving:

Functions

void Start_PWM_driving ()

Detailed Description

Enable PWM channels for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Stop_PWM_driving

Functions
Stop_PWM_driving
DRIVERS » BSP » COMPONENTS » L6398

Disable PWM channels for L6398. More...

Collaboration diagram for Stop_PWM_driving:

Functions

void Stop_PWM_driving ()

Detailed Description

Disable PWM channels for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: HF_TIMx_SetDutyCycle_CH1

Functions
HF_TIMx_SetDutyCycle_CH1
DRIVERS » BSP » COMPONENTS » L6398

Set the Duty Cycle value for CH1. More...

Collaboration diagram for HF_TIMx_SetDutyCycle_CH1:

Functions

void HF_TIMx_SetDutyCycle_CH1 (uint16_t CCR_value)

Detailed Description

Set the Duty Cycle value for CH1.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: HF_TIMx_SetDutyCycle_CH2

Functions
HF_TIMx_SetDutyCycle_CH2
DRIVERS » BSP » COMPONENTS » L6398

Set the Duty Cycle value for CH2. More...

Collaboration diagram for HF_TIMx_SetDutyCycle_CH2:

Functions

void HF_TIMx_SetDutyCycle_CH2 (uint16_t CCR_value)

Detailed Description

Set the Duty Cycle value for CH2.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: HF_TIMx_SetDutyCycle_CH3

Functions
HF_TIMx_SetDutyCycle_CH3
DRIVERS » BSP » COMPONENTS » L6398

Set the Duty Cycle value for CH3. More...

Collaboration diagram for HF_TIMx_SetDutyCycle_CH3:

Functions

void HF_TIMx_SetDutyCycle_CH3 (uint16_t CCR_value)

Detailed Description

Set the Duty Cycle value for CH3.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Current_Reference_Start

Functions
Current_Reference_Start
DRIVERS » BSP » COMPONENTS » L6398

Enable the Current Reference generation. More...

Collaboration diagram for Current_Reference_Start:

Functions

void Current_Reference_Start ()

Detailed Description

Enable the Current Reference generation.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Current_Reference_Stop

Functions
Current_Reference_Stop
DRIVERS » BSP » COMPONENTS » L6398

Disable the Current Reference generation. More...

Collaboration diagram for Current_Reference_Stop:

Functions

void Current_Reference_Stop ()

Detailed Description

Disable the Current Reference generation.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Current_Reference_Setvalue

Functions
Current_Reference_Setvalue
DRIVERS » BSP » COMPONENTS » L6398

Set the value for Current Reference. More...

Collaboration diagram for Current_Reference_Setvalue:

Functions

void Current_Reference_Setvalue (uint16_t Iref)

Detailed Description

Set the value for Current Reference.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: X-NUCLEO-IHM08M1

Modules
X-NUCLEO-IHM08M1
DRIVERS » BSP

X-Nucleo board. More...

Collaboration diagram for X-NUCLEO-IHM08M1:

Modules

L6398_ECH1CH2_DCH3_IO_Write
Enable Input channel CH1 and CH2 for L6398.
L6398_ECH1CH3_DCH2_IO_Write
Enable Input channel CH1 and CH3 for L6398.
L6398_ECH2CH3_DCH1_IO_Write
Enable Input channel CH2 and CH3 for L6398.
L6398_DCH1CH2CH3_IO_Write
Disable all channels for L6398.
L6398_Start_PWM_generation
Enable the PWM generation on Input channels for L6398.
L6398_Stop_PWM_generation
Disable the PWM generation on Input channels for L6398.
L6398_HFTIM_DC_CH1
Set the Duty Cycle value for CH1.
L6398_HFTIM_DC_CH2
Set the Duty Cycle value for CH2.
L6398_HFTIM_DC_CH3
Set the Duty Cycle value for CH3.
BSP_X_NUCLEO_FAULT_LED_ON
Turns selected LED On.
BSP_X_NUCLEO_FAULT_LED_OFF
Turns selected LED Off.

Detailed Description

X-Nucleo board.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_ECH1CH2_DCH3_IO_Write

Functions
L6398_ECH1CH2_DCH3_IO_Write
DRIVERS » BSP » X-NUCLEO-IHM08M1

Enable Input channel CH1 and CH2 for L6398. More...

Collaboration diagram for L6398_ECH1CH2_DCH3_IO_Write:

Functions

void L6398_ECH1CH2_DCH3_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH1 and CH2 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_ECH1CH3_DCH2_IO_Write

Functions
L6398_ECH1CH3_DCH2_IO_Write
DRIVERS » BSP » X-NUCLEO-IHM08M1

Enable Input channel CH1 and CH3 for L6398. More...

Collaboration diagram for L6398_ECH1CH3_DCH2_IO_Write:

Functions

void L6398_ECH1CH3_DCH2_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH1 and CH3 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_ECH2CH3_DCH1_IO_Write

Functions
L6398_ECH2CH3_DCH1_IO_Write
DRIVERS » BSP » X-NUCLEO-IHM08M1

Enable Input channel CH2 and CH3 for L6398. More...

Collaboration diagram for L6398_ECH2CH3_DCH1_IO_Write:

Functions

void L6398_ECH2CH3_DCH1_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)

Detailed Description

Enable Input channel CH2 and CH3 for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_DCH1CH2CH3_IO_Write

Functions
L6398_DCH1CH2CH3_IO_Write
DRIVERS » BSP » X-NUCLEO-IHM08M1

Disable all channels for L6398. More...

Collaboration diagram for L6398_DCH1CH2CH3_IO_Write:

Functions

void L6398_DCH1CH2CH3_IO_Write ()

Detailed Description

Disable all channels for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_Start_PWM_generation

Functions
L6398_Start_PWM_generation
DRIVERS » BSP » X-NUCLEO-IHM08M1

Enable the PWM generation on Input channels for L6398. More...

Collaboration diagram for L6398_Start_PWM_generation:

Functions

void L6398_Start_PWM_generation ()

Detailed Description

Enable the PWM generation on Input channels for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_Stop_PWM_generation

Functions
L6398_Stop_PWM_generation
DRIVERS » BSP » X-NUCLEO-IHM08M1

Disable the PWM generation on Input channels for L6398. More...

Collaboration diagram for L6398_Stop_PWM_generation:

Functions

void L6398_Stop_PWM_generation ()

Detailed Description

Disable the PWM generation on Input channels for L6398.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_HFTIM_DC_CH1

Functions
L6398_HFTIM_DC_CH1
DRIVERS » BSP » X-NUCLEO-IHM08M1

Set the Duty Cycle value for CH1. More...

Collaboration diagram for L6398_HFTIM_DC_CH1:

Functions

void L6398_HFTIM_DC_CH1 (uint16_t CCRx)

Detailed Description

Set the Duty Cycle value for CH1.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_HFTIM_DC_CH2

Functions
L6398_HFTIM_DC_CH2
DRIVERS » BSP » X-NUCLEO-IHM08M1

Set the Duty Cycle value for CH2. More...

Collaboration diagram for L6398_HFTIM_DC_CH2:

Functions

void L6398_HFTIM_DC_CH2 (uint16_t CCRx)

Detailed Description

Set the Duty Cycle value for CH2.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: L6398_HFTIM_DC_CH3

Functions
L6398_HFTIM_DC_CH3
DRIVERS » BSP » X-NUCLEO-IHM08M1

Set the Duty Cycle value for CH3. More...

Collaboration diagram for L6398_HFTIM_DC_CH3:

Functions

void L6398_HFTIM_DC_CH3 (uint16_t CCRx)

Detailed Description

Set the Duty Cycle value for CH3.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: BSP_X_NUCLEO_FAULT_LED_ON

Functions
BSP_X_NUCLEO_FAULT_LED_ON
DRIVERS » BSP » X-NUCLEO-IHM08M1

Turns selected LED On. More...

Collaboration diagram for BSP_X_NUCLEO_FAULT_LED_ON:

Functions

void BSP_X_NUCLEO_FAULT_LED_ON ()

Detailed Description

Turns selected LED On.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: BSP_X_NUCLEO_FAULT_LED_OFF

Functions
BSP_X_NUCLEO_FAULT_LED_OFF
DRIVERS » BSP » X-NUCLEO-IHM08M1

Turns selected LED Off. More...

Collaboration diagram for BSP_X_NUCLEO_FAULT_LED_OFF:

Functions

void BSP_X_NUCLEO_FAULT_LED_OFF ()

Detailed Description

Turns selected LED Off.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MIDDLEWARES

Modules
MIDDLEWARES

Middlewares Layer. More...

Collaboration diagram for MIDDLEWARES:

Modules

MC_6-STEP_LIB
Motor Control driver.
UART_UI
Serial communication through PC serial terminal.

Detailed Description

Middlewares Layer.

****************************************************************************

###### Main functions for 6-Step algorithm ######

The main function are the following:

1) MC_SixStep_TABLE(...) -> Set the peripherals (TIMx, GPIO etc.) for each step 2) MC_SixStep_ARR_step() -> Generate the ARR value for Low Frequency TIM during start-up 3) MC_SixStep_INIT() -> Init the main variables for motor driving from MC_SixStep_param.h 4) MC_SixStep_RESET() -> Reset all variables used for 6Step control algorithm 5) MC_SixStep_Ramp_Motor_calc() -> Calculate the acceleration profile step by step for motor during start-up 6) MC_SixStep_NEXT_step()-> Generate the next step number according with the direction (CW or CCW) 7) MC_Task_Speed() -> Speed Loop with PI regulator 8) MC_Set_Speed(...) -> Set the new motor speed value 9) MC_StartMotor() -> Start the Motor 10)MC_StopMotor() -> Stop the Motor


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_6-STEP_LIB

Modules | Functions | Variables
MC_6-STEP_LIB
MIDDLEWARES

Motor Control driver. More...

Collaboration diagram for MC_6-STEP_LIB:

Modules

Exported_types
Exported_function_6StepLib
MC_SixStep_TABLE
Set the peripherals (TIMx, GPIO etc.) for each step.
MC_SixStep_NEXT_step
Generate the next step number according with the direction (CW or CCW)
MC_SixStep_RESET
Reset all variables used for 6Step control algorithm.
MC_SixStep_Ramp_Motor_calc
Calculate the acceleration profile step by step for motor during start-up.
MC_SixStep_ARR_step
Generate the ARR value for Low Frequency TIM during start-up.
MC_SixStep_Alignment
Generate the motor alignment.
MC_SixStep_Speed_Val_target_potentiometer
Calculate the Motor Speed validation threshold according with the potentiometer value.
MC_SixStep_Speed_Potentiometer
Calculate the potentiometer value to set the Motor Speed.
MC_Set_PI_param
Set all parameters for PI regulator.
MC_PI_Controller
Compute the PI output for the Current Reference.
MC_Task_Speed
Main task: Speed Loop with PI regulator.
MC_Set_Speed
Set the new motor speed value.
MC_Bemf_Delay
Take the delay time after each new 6-step commutation.
MC_StartMotor
Start the Motor.
MC_StopMotor
Stop the Motor.
MC_GetElSpeedHz
Get the Eletrical Motor Speed from ARR value of LF TIM.
MC_GetMechSpeedRPM
Get the Mechanical Motor Speed (RPM)
MC_SixStep_Init_main_data
Init the main variables for motor driving from MC_SixStep_param.h.
MC_SixStep_INIT
Initialitation function for SixStep library.
MC_TIMx_SixStep_timebase
Low Frequency Timer Callback - Call the next step and request the filtered speed value.
MC_Speed_Filter
Calculate the speed filtered.
MC_Bemf_delay_Filter
Calculate the Bemf delay time filtered.
MC_Potentiometer_filter
Calculate the filtered potentiometer value.
MC_SysTick_SixStep_MediumFrequencyTask
Systick Callback - Call the Speed loop.
MC_SixStep_ARR_Bemf
Calculate the new Autoreload value (ARR) for Low Frequency timer.
MC_ADCx_SixStep_Bemf
Compute the zero crossing detection.
MC_EXT_button_SixStep
GPIO EXT Callback - Start or Stop the motor through the Blue push button on STM32Nucleo.
Main_Motor_parameters
All motor parameters for 6Step driving.

Functions

uint64_t | MCM_Sqrt (uint64_t wInput)
It calculates the square root of a non-negative s64. It returns 0 for negative s64. More...
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)
void | MC_UI_INIT (void)
void | UART_Set_Value (void)
void | UART_Communication_Task (void)
void | CMD_Parser (char *pCommandString)
void | HAL_IncTick (void)
This function is called to increment a global variable "uwTick" used as application time base. More...
uint32_t | HAL_GetTick (void)
Povides a tick value in millisecond. More...

Variables

SIXSTEP_Base_InitTypeDef SIXSTEP_parameters
SIXSTEP_PI_PARAM_InitTypeDef_t PI_parameters
uint16_t | Rotor_poles_pairs
uint32_t | mech_accel_hz = 0
uint32_t | constant_k = 0
uint32_t | Time_vector_tmp = 0
uint32_t | Time_vector_prev_tmp = 0
uint32_t | T_single_step = 0
uint32_t | T_single_step_first_value = 0
int32_t | delta = 0
uint16_t | index_array = 1
int16_t | speed_tmp_array [FILTER_DEEP]
uint16_t | speed_tmp_buffer [FILTER_DEEP]
uint16_t | HFBuffer [HFBUFFERSIZE]
uint16_t | HFBufferIndex = 0
uint8_t | array_completed = FALSE
uint8_t | bemf_array_completed = FALSE
uint8_t | buffer_completed = FALSE
uint8_t | UART_FLAG_RECEIVE = FALSE
uint32_t | ARR_LF = 0
int32_t | Mech_Speed_RPM = 0
int32_t | El_Speed_Hz = 0
uint16_t | index_adc_chn = 0
uint16_t | index_motor_run = 0
uint16_t | test_motor_run = 1
uint8_t | Enable_start_button = TRUE
uint16_t | index_ARR_step = 1
uint32_t | n_zcr_startup = 0
uint16_t | index_startup_motor = 1
uint16_t | target_speed = TARGET_SPEED
uint16_t | shift_n_sqrt = 14
uint16_t | cnt_bemf_event = 0
uint8_t | startup_bemf_failure = 0
uint8_t | speed_fdbk_error = 0
__IO uint32_t | uwTick = 0
uint8_t | dac_status = DAC_ENABLE
uint16_t | index_align = 1
int32_t | speed_sum_sp_filt = 0
int32_t | speed_sum_pot_filt = 0
uint16_t | index_pot_filt = 1
int16_t | potent_filtered = 0
uint32_t | Tick_cnt = 0
uint32_t | counter_ARR_Bemf = 0
uint64_t | constant_multiplier_tmp = 0
uint32_t | demagn_value_tmp = 0
uint32_t | ARR_divider = 80
uint16_t | tmp_val =0
uint32_t | ARR_tmp = 0
uint32_t | ARR_tmp_prev = 0
uint8_t | flag_change_step = FALSE
uint16_t | dmg_tmp = 0
int32_t | bemf_sum_filt = 0
uint16_t | bemf_tmp_array [FILTER_DEEP]
uint16_t | bemf_index_array = 1
uint8_t | synchronous_rect = SYNCHRONOUS_RECTIFICATION
uint8_t | Upcounting_event_flag = FALSE

Detailed Description

Motor Control driver.

Function Documentation

uint32_t HAL_GetTick ( void )

Povides a tick value in millisecond.

Note
The function is declared as __Weak to be overwritten in case of other implementations in user file.
Return values
tick value
void HAL_IncTick ( void )

This function is called to increment a global variable "uwTick" used as application time base.

Note
In the default implementation, this variable is incremented each 1ms in Systick ISR.
This function is declared as __weak to be overwritten in case of other implementations in user file.
Return values
None
uint64_t MCM_Sqrt ( uint64_t wInput )

It calculates the square root of a non-negative s64. It returns 0 for negative s64.

Parameters
Input uint64_t number
Return values
int32_t Square root of Input (0 if Input<0)

Variable Documentation

uint32_t ARR_divider = 80

Bemf delay filter variable

uint32_t ARR_LF = 0

Autoreload LF TIM variable

uint32_t ARR_tmp = 0

Bemf delay filter variable

uint32_t ARR_tmp_prev = 0

Bemf delay filter variable

uint8_t array_completed = FALSE

Speed filter variable

uint8_t bemf_array_completed = FALSE

Bemf-delay filter variable

uint16_t bemf_index_array = 1

Bemf delay filter variable

int32_t bemf_sum_filt = 0

Bemf delay filter variable

uint16_t bemf_tmp_array[FILTER_DEEP]

Bemf delay filter variable

uint8_t buffer_completed = FALSE

Potentiometer filter variable

uint16_t cnt_bemf_event = 0

Counter for Bemf failure detection during startup

uint32_t constant_k = 0

1/3*mech_accel_hz

uint64_t constant_multiplier_tmp = 0

Variable for startup calculation

uint32_t counter_ARR_Bemf = 0

Store the last value of Autoreload for LF timer

uint8_t dac_status = DAC_ENABLE

DAC indicator (TRUE) if enabled

int32_t delta = 0

Startup variable

uint32_t demagn_value_tmp = 0

Demagn delay time dynamically calculated

uint16_t dmg_tmp = 0

Bemf delay filter variable

int32_t El_Speed_Hz = 0

Electrical motor speed

uint8_t Enable_start_button = TRUE

Start/stop button filter to avoid double command

uint8_t flag_change_step = FALSE

Bemf delay filter variable

uint16_t HFBuffer[HFBUFFERSIZE]

Buffer for Potentiometer Value Filtering at the High-Frequency ADC conversion

uint16_t HFBufferIndex = 0

High-Frequency Buffer Index

uint16_t index_adc_chn = 0

Index of ADC channel selector for measuring

uint16_t index_align = 1

Index for alignment time calculation

uint16_t index_ARR_step = 1

Index for number of steps during startup

uint16_t index_array = 1

Speed filter variable

uint16_t index_motor_run = 0

Tmp variable for DEMO mode

uint16_t index_pot_filt = 1

Variable for potentiometer filter

uint16_t index_startup_motor = 1

Index for number of steps calculated during startup

uint32_t mech_accel_hz = 0

Hz – Mechanical acceleration rate

int32_t Mech_Speed_RPM = 0

Mechanical motor speed

uint32_t n_zcr_startup = 0

Counter of zero crossing event before closed loop control

SIXSTEP_PI_PARAM_InitTypeDef_t PI_parameters

SixStep PI regulator structure

int16_t potent_filtered = 0

Variable for potentiometer filter

uint16_t Rotor_poles_pairs

Number of pole pairs of the motor

uint16_t shift_n_sqrt = 14

Shift of bits for root square function

SIXSTEP_Base_InitTypeDef SIXSTEP_parameters

Main SixStep structure

uint8_t speed_fdbk_error = 0

Speedfeedback error indicator during startup (TRUE if failure occurs)

int32_t speed_sum_pot_filt = 0

Variable for potentiometer filter

int32_t speed_sum_sp_filt = 0

Variable for speed filter

int16_t speed_tmp_array[FILTER_DEEP]

Speed filter variable

uint16_t speed_tmp_buffer[FILTER_DEEP]

Potentiometer filter variable

uint8_t startup_bemf_failure = 0

Bemf failure indicator during startup (TRUE if failure occurs)

uint8_t synchronous_rect = SYNCHRONOUS_RECTIFICATION

Synchronous rectification enable flag

uint32_t T_single_step = 0

Startup variable

uint32_t T_single_step_first_value = 0

Startup variable

uint16_t target_speed = TARGET_SPEED

Target speed for closed loop control

uint16_t test_motor_run = 1

Tmp variable for DEMO mode

uint32_t Tick_cnt = 0

Counter for speed loop calling

uint32_t Time_vector_prev_tmp = 0

Startup variable

uint32_t Time_vector_tmp = 0

Startup variable

uint16_t tmp_val =0

Bemf delay filter variable

uint8_t UART_FLAG_RECEIVE = FALSE

UART commmunication flag

uint8_t Upcounting_event_flag = FALSE

HF Timer counting flag indicator

__IO uint32_t uwTick = 0

Tick counter - 1msec updated

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Exported_types

Classes | Typedefs | Enumerations
Exported_types
MIDDLEWARES » MC_6-STEP_LIB
Collaboration diagram for Exported_types:

Classes

struct | SIXSTEP_Base_InitTypeDef
Six Step parameters. More...
struct | SIXSTEP_PI_PARAM_InitTypeDef_t
Six PI regulator parameters. More...

Typedefs

typedef struct SIXSTEP_PI_PARAM_InitTypeDef_t * SIXSTEP_pi_PARAM_InitTypeDef_t

Enumerations

enum SIXSTEP_Base_SystStatus_t {
IDLE, STARTUP, VALIDATION, STOP,
START, RUN, ALIGNMENT, SPEEDFBKERROR,
OVERCURRENT, STARTUP_FAILURE, STARTUP_BEMF_FAILURE
}
Six Step parameters.

Detailed Description

Typedef Documentation

typedef struct SIXSTEP_PI_PARAM_InitTypeDef_t * SIXSTEP_pi_PARAM_InitTypeDef_t

PI Data Structure

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: SIXSTEP_Base_InitTypeDef Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
SIXSTEP_Base_InitTypeDef Struct Reference
MIDDLEWARES » MC_6-STEP_LIB » Exported_types

Six Step parameters. More...

#include <6Step_Lib.h>

Public Attributes

uint32_t | LF_TIMx_PSC
uint32_t | LF_TIMx_ARR
uint32_t | HF_TIMx_PSC
uint32_t | HF_TIMx_ARR
uint32_t | HF_TIMx_CCR
uint8_t | step_position
SIXSTEP_Base_SystStatus_t STATUS
uint8_t | status_prev
uint16_t | pulse_value
uint16_t | ARR_value
uint32_t | Regular_channel [4]
uint32_t | CurrentRegular_BEMF_ch
uint32_t | prescaler_value
uint16_t | numberofitemArr
uint32_t | ADC_BUFFER [4]
uint32_t | ADC_SEQ_CHANNEL [4]
uint32_t | ADC_Regular_Buffer [5]
uint16_t | ADC_BEMF_threshold_UP
uint16_t | ADC_BEMF_threshold_DOWN
uint16_t | demagn_counter
uint16_t | demagn_value
int16_t | speed_fdbk
int16_t | speed_fdbk_filtered
int16_t | filter_depth
uint16_t | Current_Reference
uint16_t | Ireference
int32_t | Integral_Term_sum
uint8_t | CMD
uint8_t | ALIGN_OK
uint8_t | ALIGNMENT
uint8_t | bemf_state_1
uint8_t | bemf_state_2
uint8_t | bemf_state_3
uint8_t | bemf_state_4
uint8_t | bemf_state_5
uint8_t | bemf_state_6
uint16_t | Speed_Loop_Time
uint16_t | Speed_Ref_filtered
uint16_t | RUN_Motor
uint8_t | ARR_OK
uint8_t | VALIDATION_OK
uint8_t | SPEED_VALIDATED
uint16_t | Speed_target_ramp
uint16_t | Speed_target_time
uint16_t | Ramp_Start
uint16_t | Bemf_delay_start
uint16_t | MediumFrequencyTask_flag
uint32_t | SYSCLK_frequency
uint32_t | Uart_cmd_to_set
uint32_t | Uart_value_to_set
uint8_t | Button_ready
uint8_t | BEMF_OK
uint8_t | CL_READY
uint8_t | BEMF_Tdown_count
uint16_t | IREFERENCE
uint16_t | NUMPOLESPAIRS
uint32_t | ACCEL
uint16_t | KP
uint16_t | KI
uint8_t | CW_CCW
uint8_t | Potentiometer

Detailed Description

Six Step parameters.

Member Data Documentation

uint32_t SIXSTEP_Base_InitTypeDef::ACCEL

Acceleration start-up parameter

uint16_t SIXSTEP_Base_InitTypeDef::ADC_BEMF_threshold_DOWN

Voltage threshold for BEMF detection in down direction

uint16_t SIXSTEP_Base_InitTypeDef::ADC_BEMF_threshold_UP

Voltage threshold for BEMF detection in up direction

uint32_t SIXSTEP_Base_InitTypeDef::ADC_BUFFER[4]

Buffer for ADC regular channel

uint32_t SIXSTEP_Base_InitTypeDef::ADC_Regular_Buffer[5]

Buffer for ADC regular channel

uint32_t SIXSTEP_Base_InitTypeDef::ADC_SEQ_CHANNEL[4]

Buffer for ADC regular channel

uint8_t SIXSTEP_Base_InitTypeDef::ALIGN_OK

Flag control for Motor Alignment

uint8_t SIXSTEP_Base_InitTypeDef::ALIGNMENT

Flag control for Motor Alignment ongoing

uint8_t SIXSTEP_Base_InitTypeDef::ARR_OK

ARR flag control for Accell status

uint16_t SIXSTEP_Base_InitTypeDef::ARR_value

ARR vector for Accell compute

uint16_t SIXSTEP_Base_InitTypeDef::Bemf_delay_start

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_1

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_2

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_3

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_4

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_5

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::bemf_state_6

Bemf variable

uint8_t SIXSTEP_Base_InitTypeDef::BEMF_Tdown_count

BEMF Consecutive Threshold Falling Crossings Counter

uint8_t SIXSTEP_Base_InitTypeDef::CMD

Flag control for Motor Start/Stop

uint16_t SIXSTEP_Base_InitTypeDef::Current_Reference

Currrent reference for SixStep algorithm

uint32_t SIXSTEP_Base_InitTypeDef::CurrentRegular_BEMF_ch

ADC regular channel to select

uint8_t SIXSTEP_Base_InitTypeDef::CW_CCW

Set the motor direction

uint16_t SIXSTEP_Base_InitTypeDef::demagn_counter

Demagnetization counter

uint16_t SIXSTEP_Base_InitTypeDef::demagn_value

Demagnetization value

int16_t SIXSTEP_Base_InitTypeDef::filter_depth

Filter depth for speed measuring

uint32_t SIXSTEP_Base_InitTypeDef::HF_TIMx_ARR

ARR variable for high frequency timer

uint32_t SIXSTEP_Base_InitTypeDef::HF_TIMx_CCR

CCR variable for high frequency timer

uint32_t SIXSTEP_Base_InitTypeDef::HF_TIMx_PSC

Prescaler variable for high frequency timer

int32_t SIXSTEP_Base_InitTypeDef::Integral_Term_sum

Global Integral part for PI

uint16_t SIXSTEP_Base_InitTypeDef::Ireference

Currrent reference for SixStep algorithm

uint16_t SIXSTEP_Base_InitTypeDef::IREFERENCE

Currrent reference

uint16_t SIXSTEP_Base_InitTypeDef::KI

KI parameter for PI regulator

uint16_t SIXSTEP_Base_InitTypeDef::KP

KP parameter for PI regulator

uint32_t SIXSTEP_Base_InitTypeDef::LF_TIMx_ARR

ARR variable for low frequency timer

uint32_t SIXSTEP_Base_InitTypeDef::LF_TIMx_PSC

Prescaler variable for low frequency timer

uint16_t SIXSTEP_Base_InitTypeDef::MediumFrequencyTask_flag

Flag for Medium Task Frequency

uint16_t SIXSTEP_Base_InitTypeDef::numberofitemArr

Number of elements

uint16_t SIXSTEP_Base_InitTypeDef::NUMPOLESPAIRS

Number of motor pole pairs

uint8_t SIXSTEP_Base_InitTypeDef::Potentiometer

Enable/Disable potentiometer for speed control

uint32_t SIXSTEP_Base_InitTypeDef::prescaler_value

Prescaler value for low freq timer

uint16_t SIXSTEP_Base_InitTypeDef::pulse_value

CCR value for SixStep algorithm

uint16_t SIXSTEP_Base_InitTypeDef::Ramp_Start

Ramp time start

uint32_t SIXSTEP_Base_InitTypeDef::Regular_channel[4]

Buffer for ADC regular channel

uint16_t SIXSTEP_Base_InitTypeDef::RUN_Motor

Flag for Motor status

int16_t SIXSTEP_Base_InitTypeDef::speed_fdbk

Motor speed variable

int16_t SIXSTEP_Base_InitTypeDef::speed_fdbk_filtered

Filtered Motor speed variable

uint16_t SIXSTEP_Base_InitTypeDef::Speed_Loop_Time

Speed loop variable for timing

uint16_t SIXSTEP_Base_InitTypeDef::Speed_Ref_filtered

Filtered Reference Motor Speed variable

uint16_t SIXSTEP_Base_InitTypeDef::Speed_target_ramp

Target Motor Speed

uint16_t SIXSTEP_Base_InitTypeDef::Speed_target_time

Target Motor Ramp time

uint8_t SIXSTEP_Base_InitTypeDef::SPEED_VALIDATED

Validation flag for Speed before closed loop control

SIXSTEP_Base_SystStatus_t SIXSTEP_Base_InitTypeDef::STATUS

Status variable for SixStep algorithm

uint8_t SIXSTEP_Base_InitTypeDef::status_prev

Previous status variable for SixStep algorithm

uint8_t SIXSTEP_Base_InitTypeDef::step_position

Step number variable for SixStep algorithm

uint32_t SIXSTEP_Base_InitTypeDef::SYSCLK_frequency

System clock main frequency

uint8_t SIXSTEP_Base_InitTypeDef::VALIDATION_OK

Validation flag for Closed loop control begin

The documentation for this struct was generated from the following file:
  • C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: SIXSTEP_PI_PARAM_InitTypeDef_t Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
SIXSTEP_PI_PARAM_InitTypeDef_t Struct Reference
MIDDLEWARES » MC_6-STEP_LIB » Exported_types

Six PI regulator parameters. More...

#include <6Step_Lib.h>

Public Attributes

int16_t | Reference
int16_t | Kp_Gain
int16_t | Ki_Gain
int16_t | Lower_Limit_Output
int16_t | Upper_Limit_Output
int8_t | Max_PID_Output
int8_t | Min_PID_Output

Detailed Description

Six PI regulator parameters.

Member Data Documentation

int16_t SIXSTEP_PI_PARAM_InitTypeDef_t::Ki_Gain

Ki value for PI regulator

int16_t SIXSTEP_PI_PARAM_InitTypeDef_t::Kp_Gain

Kp value for PI regulator

int16_t SIXSTEP_PI_PARAM_InitTypeDef_t::Lower_Limit_Output

Min output value for PI regulator

int8_t SIXSTEP_PI_PARAM_InitTypeDef_t::Max_PID_Output

Max Saturation indicator flag

int8_t SIXSTEP_PI_PARAM_InitTypeDef_t::Min_PID_Output

Min Saturation indicator flag

int16_t SIXSTEP_PI_PARAM_InitTypeDef_t::Reference

Refence value for PI regulator

int16_t SIXSTEP_PI_PARAM_InitTypeDef_t::Upper_Limit_Output

Max output value for PI regulator

The documentation for this struct was generated from the following file:
  • C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Exported_function_6StepLib

Functions
Exported_function_6StepLib
MIDDLEWARES » MC_6-STEP_LIB
Collaboration diagram for Exported_function_6StepLib:

Functions

void | MC_SixStep_INIT (void)
void | MC_SixStep_RESET (void)
void | MC_StartMotor (void)
void | MC_StopMotor (void)
void | MC_Set_Speed (uint16_t)
void | MC_EXT_button_SixStep (void)

Detailed Description

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_TABLE

Functions
MC_SixStep_TABLE
MIDDLEWARES » MC_6-STEP_LIB

Set the peripherals (TIMx, GPIO etc.) for each step. More...

Collaboration diagram for MC_SixStep_TABLE:

Functions

void MC_SixStep_TABLE (uint8_t)

Detailed Description

Set the peripherals (TIMx, GPIO etc.) for each step.

Parameters
step_number step number selected
Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_NEXT_step

Functions
MC_SixStep_NEXT_step
MIDDLEWARES » MC_6-STEP_LIB

Generate the next step number according with the direction (CW or CCW) More...

Collaboration diagram for MC_SixStep_NEXT_step:

Functions

void MC_SixStep_NEXT_step (void)

Detailed Description

Generate the next step number according with the direction (CW or CCW)

Return values
uint8_t SIXSTEP_parameters.status


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_RESET

Functions
MC_SixStep_RESET
MIDDLEWARES » MC_6-STEP_LIB

Reset all variables used for 6Step control algorithm. More...

Collaboration diagram for MC_SixStep_RESET:

Functions

void MC_SixStep_RESET ()

Detailed Description

Reset all variables used for 6Step control algorithm.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_Ramp_Motor_calc

Functions
MC_SixStep_Ramp_Motor_calc
MIDDLEWARES » MC_6-STEP_LIB

Calculate the acceleration profile step by step for motor during start-up. More...

Collaboration diagram for MC_SixStep_Ramp_Motor_calc:

Functions

void MC_SixStep_Ramp_Motor_calc (void)

Detailed Description

Calculate the acceleration profile step by step for motor during start-up.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_ARR_step

Functions
MC_SixStep_ARR_step
MIDDLEWARES » MC_6-STEP_LIB

Generate the ARR value for Low Frequency TIM during start-up. More...

Collaboration diagram for MC_SixStep_ARR_step:

Functions

void MC_SixStep_ARR_step (void)

Detailed Description

Generate the ARR value for Low Frequency TIM during start-up.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_Alignment

Functions
MC_SixStep_Alignment
MIDDLEWARES » MC_6-STEP_LIB

Generate the motor alignment. More...

Collaboration diagram for MC_SixStep_Alignment:

Functions

void MC_SixStep_Alignment (void)

Detailed Description

Generate the motor alignment.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_Speed_Val_target_potentiometer

Functions
MC_SixStep_Speed_Val_target_potentiometer
MIDDLEWARES » MC_6-STEP_LIB

Calculate the Motor Speed validation threshold according with the potentiometer value. More...

Collaboration diagram for MC_SixStep_Speed_Val_target_potentiometer:

Functions

void MC_SixStep_Speed_Val_target_potentiometer (void)

Detailed Description

Calculate the Motor Speed validation threshold according with the potentiometer value.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_Speed_Potentiometer

Functions
MC_SixStep_Speed_Potentiometer
MIDDLEWARES » MC_6-STEP_LIB

Calculate the potentiometer value to set the Motor Speed. More...

Collaboration diagram for MC_SixStep_Speed_Potentiometer:

Functions

void MC_SixStep_Speed_Potentiometer (void)

Detailed Description

Calculate the potentiometer value to set the Motor Speed.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Set_PI_param

Functions
MC_Set_PI_param
MIDDLEWARES » MC_6-STEP_LIB

Set all parameters for PI regulator. More...

Collaboration diagram for MC_Set_PI_param:

Functions

void MC_Set_PI_param (SIXSTEP_PI_PARAM_InitTypeDef_t *)

Detailed Description

Set all parameters for PI regulator.

Parameters
PI_PARAM
Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_PI_Controller

Functions
MC_PI_Controller
MIDDLEWARES » MC_6-STEP_LIB

Compute the PI output for the Current Reference. More...

Collaboration diagram for MC_PI_Controller:

Functions

int16_t MC_PI_Controller (SIXSTEP_PI_PARAM_InitTypeDef_t *, int16_t)

Detailed Description

Compute the PI output for the Current Reference.

Parameters
PI_PARAM | PI parameters structure
speed_fdb | motor_speed_value
Return values
int16_t Currente reference


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Task_Speed

Functions
MC_Task_Speed
MIDDLEWARES » MC_6-STEP_LIB

Main task: Speed Loop with PI regulator. More...

Collaboration diagram for MC_Task_Speed:

Functions

void MC_Task_Speed (void)

Detailed Description

Main task: Speed Loop with PI regulator.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Set_Speed

Functions
MC_Set_Speed
MIDDLEWARES » MC_6-STEP_LIB

Set the new motor speed value. More...

Collaboration diagram for MC_Set_Speed:

Functions

void MC_Set_Speed (uint16_t speed_value)

Detailed Description

Set the new motor speed value.

Parameters
speed_value set new motor speed
Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Bemf_Delay

Functions
MC_Bemf_Delay
MIDDLEWARES » MC_6-STEP_LIB

Take the delay time after each new 6-step commutation. More...

Collaboration diagram for MC_Bemf_Delay:

Functions

void MC_Bemf_Delay (void)

Detailed Description

Take the delay time after each new 6-step commutation.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_StartMotor

Functions
MC_StartMotor
MIDDLEWARES » MC_6-STEP_LIB

Start the Motor. More...

Collaboration diagram for MC_StartMotor:

Functions

void MC_StartMotor ()

Detailed Description

Start the Motor.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_StopMotor

Functions
MC_StopMotor
MIDDLEWARES » MC_6-STEP_LIB

Stop the Motor. More...

Collaboration diagram for MC_StopMotor:

Functions

void MC_StopMotor ()

Detailed Description

Stop the Motor.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_GetElSpeedHz

Functions
MC_GetElSpeedHz
MIDDLEWARES » MC_6-STEP_LIB

Get the Eletrical Motor Speed from ARR value of LF TIM. More...

Collaboration diagram for MC_GetElSpeedHz:

Functions

int32_t MC_GetElSpeedHz (void)

Detailed Description

Get the Eletrical Motor Speed from ARR value of LF TIM.

Return values
int32_t Return the electrical motor speed


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_GetMechSpeedRPM

Functions
MC_GetMechSpeedRPM
MIDDLEWARES » MC_6-STEP_LIB

Get the Mechanical Motor Speed (RPM) More...

Collaboration diagram for MC_GetMechSpeedRPM:

Functions

int32_t MC_GetMechSpeedRPM (void)

Detailed Description

Get the Mechanical Motor Speed (RPM)

Return values
int32_t Return the mechanical motor speed (RPM


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_Init_main_data

Functions
MC_SixStep_Init_main_data
MIDDLEWARES » MC_6-STEP_LIB

Init the main variables for motor driving from MC_SixStep_param.h. More...

Collaboration diagram for MC_SixStep_Init_main_data:

Functions

void MC_SixStep_Init_main_data (void)

Detailed Description

Init the main variables for motor driving from MC_SixStep_param.h.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_INIT

Functions
MC_SixStep_INIT
MIDDLEWARES » MC_6-STEP_LIB

Initialitation function for SixStep library. More...

Collaboration diagram for MC_SixStep_INIT:

Functions

void MC_SixStep_INIT ()

Detailed Description

Initialitation function for SixStep library.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_TIMx_SixStep_timebase

Functions
MC_TIMx_SixStep_timebase
MIDDLEWARES » MC_6-STEP_LIB

Low Frequency Timer Callback - Call the next step and request the filtered speed value. More...

Collaboration diagram for MC_TIMx_SixStep_timebase:

Functions

void MC_TIMx_SixStep_timebase (void)

Detailed Description

Low Frequency Timer Callback - Call the next step and request the filtered speed value.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Speed_Filter

Functions
MC_Speed_Filter
MIDDLEWARES » MC_6-STEP_LIB

Calculate the speed filtered. More...

Collaboration diagram for MC_Speed_Filter:

Functions

void MC_Speed_Filter (void)

Detailed Description

Calculate the speed filtered.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Bemf_delay_Filter

Functions
MC_Bemf_delay_Filter
MIDDLEWARES » MC_6-STEP_LIB

Calculate the Bemf delay time filtered. More...

Collaboration diagram for MC_Bemf_delay_Filter:

Functions

uint32_t MC_Bemf_delay_Filter (uint32_t)

Detailed Description

Calculate the Bemf delay time filtered.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_Potentiometer_filter

Functions
MC_Potentiometer_filter
MIDDLEWARES » MC_6-STEP_LIB

Calculate the filtered potentiometer value. More...

Collaboration diagram for MC_Potentiometer_filter:

Functions

uint16_t MC_Potentiometer_filter (uint16_t)

Detailed Description

Calculate the filtered potentiometer value.

Return values
uint16_t Return the filtered potentiometer value


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SysTick_SixStep_MediumFrequencyTask

Functions
MC_SysTick_SixStep_MediumFrequencyTask
MIDDLEWARES » MC_6-STEP_LIB

Systick Callback - Call the Speed loop. More...

Collaboration diagram for MC_SysTick_SixStep_MediumFrequencyTask:

Functions

void MC_SysTick_SixStep_MediumFrequencyTask (void)

Detailed Description

Systick Callback - Call the Speed loop.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_SixStep_ARR_Bemf

Functions
MC_SixStep_ARR_Bemf
MIDDLEWARES » MC_6-STEP_LIB

Calculate the new Autoreload value (ARR) for Low Frequency timer. More...

Collaboration diagram for MC_SixStep_ARR_Bemf:

Functions

void MC_SixStep_ARR_Bemf (uint8_t)

Detailed Description

Calculate the new Autoreload value (ARR) for Low Frequency timer.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_ADCx_SixStep_Bemf

Functions
MC_ADCx_SixStep_Bemf
MIDDLEWARES » MC_6-STEP_LIB

Compute the zero crossing detection. More...

Collaboration diagram for MC_ADCx_SixStep_Bemf:

Functions

void MC_ADCx_SixStep_Bemf (void)

Detailed Description

Compute the zero crossing detection.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: MC_EXT_button_SixStep

Functions
MC_EXT_button_SixStep
MIDDLEWARES » MC_6-STEP_LIB

GPIO EXT Callback - Start or Stop the motor through the Blue push button on STM32Nucleo. More...

Collaboration diagram for MC_EXT_button_SixStep:

Functions

void MC_EXT_button_SixStep ()

Detailed Description

GPIO EXT Callback - Start or Stop the motor through the Blue push button on STM32Nucleo.

Return values
None
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Main_Motor_parameters

Macros
Main_Motor_parameters
MIDDLEWARES » MC_6-STEP_LIB

All motor parameters for 6Step driving. More...

Collaboration diagram for Main_Motor_parameters:

Macros

#define | NUM_POLE_PAIRS 7
#define | DIRECTION 0
#define | TARGET_SPEED 3000
#define | POTENTIOMETER 1
#define | VOLTAGE_MODE 0
#define | STARTUP_CURRENT_REFERENCE 1000
#define | ACC 10000
#define | MINIMUM_ACC 500
#define | NUMBER_OF_STEPS 20000
#define | TIME_FOR_ALIGN 100
#define | BUTTON_DELAY 1000
#define | NUMBER_ZCR 12
#define | SPEED_LOOP_TIME 1
#define | KP_GAIN 6000
#define | KI_GAIN 150
#define | KP_DIV 8192
#define | KI_DIV 8192
#define | LOWER_OUT_LIMIT 10
#define | UPPER_OUT_LIMIT 16384
#define | MAX_POT_SPEED 6000
#define | MIN_POT_SPEED 1000
#define | VAL_POT_SPEED_DIV 2
#define | INITIAL_DEMAGN_DELAY 2
#define | KP_GAIN_VM 100
#define | KI_GAIN_VM 30
#define | KP_DIV_VM 8192
#define | KI_DIV_VM 8192
#define | LOWER_OUT_LIMIT_VM 400
#define | UPPER_OUT_LIMIT_VM 1799
#define | DUTY_CYCLE_INIT_VALUE 199
#define | SYNCHRONOUS_RECTIFICATION 1
#define | BEMF_THRSLD_DOWN 80
#define | BEMF_THRSLD_UP 80
#define | FILTER_DEEP 20
#define | HFBUFFERSIZE 10
#define | ADC_SPEED_TH 82
#define | BEMF_CONSEC_DOWN_MAX 10
#define | BEMF_CNT_EVENT_MAX 100
#define | GPIO_ZERO_CROSS 1
#define | GPIO_COMM 1
#define | DEMO_START_TIME 5000
#define | DEMO_STOP_TIME 2000
#define | TRUE 1
#define | FALSE 0

Detailed Description

All motor parameters for 6Step driving.

Macro Definition Documentation

#define ACC 10000

Mechanical acceleration rate (setting available in manual mode, LOAD_TYPE = 0)

#define ADC_SPEED_TH 82

Fixed treshold to change the target speed (t.b.f) Motor stall detection parameters

#define BEMF_CNT_EVENT_MAX 100

Maximum number of BEMF Counter in open loop Debug pin

#define BEMF_CONSEC_DOWN_MAX 10

Maximum value of BEMF Consecutive Threshold Falling Crossings Counter in closed loop

#define BEMF_THRSLD_DOWN 80

Zero Crossing threshold

#define BEMF_THRSLD_UP 80

Zero Crossing threshold Speed filtering parameters

#define BUTTON_DELAY 1000

Delay time to enable push button for new command (1 = 1msec)

#define DEMO_START_TIME 5000

Time (msec) to keep the motor in run mode

#define DEMO_STOP_TIME 2000

Time (msec) to keep the motor in stop mode

#define DIRECTION 0

Set motor direction CW = 0 and CCW = 1

#define DUTY_CYCLE_INIT_VALUE 199

Initial duty cycle value during startup *********** Syncronous rectification for high frequency leg

#define FALSE 0

Define FALSE

#define FILTER_DEEP 20

Number of bits for digital filter

#define GPIO_COMM 1

Enable (1) the GPIO toggling for commutation Demo mode parameters

#define GPIO_ZERO_CROSS 1

Enable (1) the GPIO toggling for zero crossing detection

#define INITIAL_DEMAGN_DELAY 2

Initial value for delay time during startup for Bemf detection ********************* Closed Loop control - VOLTAGE MODE

#define KI_DIV 8192

Ki parameter divider for PI regulator

#define KI_DIV_VM 8192

Ki parameter divider for PI regulator

#define KI_GAIN 150

Ki parameter for PI regulator

#define KI_GAIN_VM 30

Ki parameter for PI regulator

#define KP_DIV 8192

Kp parameter divider for PI regulator

#define KP_DIV_VM 8192

Kp parameter divider for PI regulator

#define KP_GAIN 6000

Kp parameter for PI regulator

#define KP_GAIN_VM 100

Kp parameter for PI regulator

#define LOWER_OUT_LIMIT 10

Low Out value of PI regulator

#define LOWER_OUT_LIMIT_VM 400

Low Out value of PI regulator

#define MAX_POT_SPEED 6000

Maximum Speed regulated by potentiometer

#define MIN_POT_SPEED 1000

Minimum Speed regulated by potentiometer

#define MINIMUM_ACC 500

Mechanical acceleration rate for BIG load application

#define NUM_POLE_PAIRS 7

Number of Motor Pole pairs

#define NUMBER_OF_STEPS 20000

Number of elements for motor start-UP (max value 65535)

#define NUMBER_ZCR 12

Number of zero crossing event during the startup for closed loop control begin ********************* Closed Loop control - CURRENT MODE

#define POTENTIOMETER 1

Enable (1)/Disable (0) the potentiometer

#define SPEED_LOOP_TIME 1

Speed Loop time (1 = 1msec)

#define STARTUP_CURRENT_REFERENCE 1000

< ********************* Open loop control StartUP Currente Reference (3000 = 10A)

#define SYNCHRONOUS_RECTIFICATION 1

Enable (1) or Disable (0) the complementary output of high frequency leg for synchronous rectification Zero Crossissing parameters

#define TARGET_SPEED 3000

Target speed in closed loop control when the potentiometer is disabled

#define TIME_FOR_ALIGN 100

Time for alignment (msec)

#define TRUE 1

Define TRUE

#define UPPER_OUT_LIMIT 16384

High Out value of PI regulator

#define UPPER_OUT_LIMIT_VM 1799

High Out value of PI regulator

#define VAL_POT_SPEED_DIV 2

Validation potentiometer speed divider

#define VOLTAGE_MODE 0

(1) for VOLTAGE mode / (0) for CURRENT mode control


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: UART_UI

Modules
UART_UI
MIDDLEWARES

Serial communication through PC serial terminal. More...

Collaboration diagram for UART_UI:

Modules

Exported_function_Uart

Detailed Description

Serial communication through PC serial terminal.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Exported_function_Uart

Functions
Exported_function_Uart
MIDDLEWARES » UART_UI
Collaboration diagram for Exported_function_Uart:

Functions

void | CMD_STARTM (void)
UART function.
void | CMD_STOPMT (void)
void | CMD_DIRECTION (void)
void | CMD_SETSPD (void)
void | CMD_GETSPD (void)
void | CMD_STATUS (void)
void | CMD_POTENZ (void)
void | CMD_HELP (void)
void | CMD_INIREF (void)
void | CMD_POLESP (void)
void | CMD_ACCELE (void)
void | CMD_KP_PRM (void)
void | CMD_KI_PRM (void)

Detailed Description

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: stm32F302_nucleo_ihm08m1

Modules
stm32F302_nucleo_ihm08m1

Interface file for STM32F302 and Library configuration. More...

Collaboration diagram for stm32F302_nucleo_ihm08m1:

Modules

Exported_function_F302

Detailed Description

Interface file for STM32F302 and Library configuration.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Exported_function_F302

Functions
Exported_function_F302
stm32F302_nucleo_ihm08m1
Collaboration diagram for Exported_function_F302:

Functions

uint32_t | Get_UART_Data (void)
API function for STM32 instruction.
void | MC_SixStep_ADC_Channel (uint32_t)
void | MC_SixStep_Nucleo_Init (void)
void | START_Ref_Generation (void)
void | STOP_Ref_Generation (void)
void | Set_Ref_Generation (uint16_t)
void | START_DAC (void)
void | STOP_DAC (void)
void | SET_DAC_value (uint16_t)
void | Bemf_delay_calc (void)
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)

Detailed Description

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: stm32F401_nucleo_ihm08m1

Modules
stm32F401_nucleo_ihm08m1

Interface file for STM32F401 and Library configuration. More...

Collaboration diagram for stm32F401_nucleo_ihm08m1:

Modules

Exported_function_F401

Detailed Description

Interface file for STM32F401 and Library configuration.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Exported_function_F401

Functions
Exported_function_F401
stm32F401_nucleo_ihm08m1
Collaboration diagram for Exported_function_F401:

Functions

void | MC_SixStep_ADC_Channel (uint32_t)
API function for STM32 instruction.
void | MC_SixStep_Nucleo_Init (void)
void | START_Ref_Generation (void)
void | STOP_Ref_Generation (void)
void | Set_Ref_Generation (uint16_t)
void | START_DAC (void)
void | STOP_DAC (void)
void | SET_DAC_value (uint16_t)
void | Bemf_delay_calc (void)
uint32_t | Get_UART_Data (void)
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)

Detailed Description

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C CMD_T |
C L6398_MotorDriver_TypeDef |
C SIXSTEP_Base_InitTypeDef | Six Step parameters
C SIXSTEP_PI_PARAM_InitTypeDef_t | Six PI regulator parameters
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: CMD_T Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
CMD_T Struct Reference

Public Attributes

char | name [10]
void(* | pCmdFunc )(void)
The documentation for this struct was generated from the following file:
  • C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc/UART_UI.h


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
C | L | S
C
L
S
SIXSTEP_PI_PARAM_InitTypeDef_t
CMD_T L6398_MotorDriver_TypeDef SIXSTEP_Base_InitTypeDef
C | L | S
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • u
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • ACCEL : SIXSTEP_Base_InitTypeDef
  • ADC_BEMF_threshold_DOWN : SIXSTEP_Base_InitTypeDef
  • ADC_BEMF_threshold_UP : SIXSTEP_Base_InitTypeDef
  • ADC_BUFFER : SIXSTEP_Base_InitTypeDef
  • ADC_Regular_Buffer : SIXSTEP_Base_InitTypeDef
  • ADC_SEQ_CHANNEL : SIXSTEP_Base_InitTypeDef
  • ALIGN_OK : SIXSTEP_Base_InitTypeDef
  • ALIGNMENT : SIXSTEP_Base_InitTypeDef
  • ARR_OK : SIXSTEP_Base_InitTypeDef
  • ARR_value : SIXSTEP_Base_InitTypeDef

- b -

  • Bemf_delay_start : SIXSTEP_Base_InitTypeDef
  • bemf_state_1 : SIXSTEP_Base_InitTypeDef
  • bemf_state_2 : SIXSTEP_Base_InitTypeDef
  • bemf_state_3 : SIXSTEP_Base_InitTypeDef
  • bemf_state_4 : SIXSTEP_Base_InitTypeDef
  • bemf_state_5 : SIXSTEP_Base_InitTypeDef
  • bemf_state_6 : SIXSTEP_Base_InitTypeDef
  • BEMF_Tdown_count : SIXSTEP_Base_InitTypeDef

- c -

  • CMD : SIXSTEP_Base_InitTypeDef
  • Current_Reference : SIXSTEP_Base_InitTypeDef
  • Current_Reference_Setvalue : L6398_MotorDriver_TypeDef
  • Current_Reference_Start : L6398_MotorDriver_TypeDef
  • Current_Reference_Stop : L6398_MotorDriver_TypeDef
  • CurrentRegular_BEMF_ch : SIXSTEP_Base_InitTypeDef
  • CW_CCW : SIXSTEP_Base_InitTypeDef

- d -

  • demagn_counter : SIXSTEP_Base_InitTypeDef
  • demagn_value : SIXSTEP_Base_InitTypeDef
  • DisableInput_CH1_D_CH2_D_CH3_D : L6398_MotorDriver_TypeDef

- e -

  • EnableInput_CH1_D_CH2_E_CH3_E : L6398_MotorDriver_TypeDef
  • EnableInput_CH1_E_CH2_D_CH3_E : L6398_MotorDriver_TypeDef
  • EnableInput_CH1_E_CH2_E_CH3_D : L6398_MotorDriver_TypeDef

- f -

  • filter_depth : SIXSTEP_Base_InitTypeDef

- h -

  • HF_TIMx_ARR : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_CCR : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_PSC : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_SetDutyCycle_CH1 : L6398_MotorDriver_TypeDef
  • HF_TIMx_SetDutyCycle_CH2 : L6398_MotorDriver_TypeDef
  • HF_TIMx_SetDutyCycle_CH3 : L6398_MotorDriver_TypeDef

- i -

  • Integral_Term_sum : SIXSTEP_Base_InitTypeDef
  • IREFERENCE : SIXSTEP_Base_InitTypeDef
  • Ireference : SIXSTEP_Base_InitTypeDef

- k -

  • KI : SIXSTEP_Base_InitTypeDef
  • Ki_Gain : SIXSTEP_PI_PARAM_InitTypeDef_t
  • KP : SIXSTEP_Base_InitTypeDef
  • Kp_Gain : SIXSTEP_PI_PARAM_InitTypeDef_t

- l -

  • LF_TIMx_ARR : SIXSTEP_Base_InitTypeDef
  • LF_TIMx_PSC : SIXSTEP_Base_InitTypeDef
  • Lower_Limit_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- m -

  • Max_PID_Output : SIXSTEP_PI_PARAM_InitTypeDef_t
  • MediumFrequencyTask_flag : SIXSTEP_Base_InitTypeDef
  • Min_PID_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- n -

  • numberofitemArr : SIXSTEP_Base_InitTypeDef
  • NUMPOLESPAIRS : SIXSTEP_Base_InitTypeDef

- p -

  • Potentiometer : SIXSTEP_Base_InitTypeDef
  • prescaler_value : SIXSTEP_Base_InitTypeDef
  • pulse_value : SIXSTEP_Base_InitTypeDef

- r -

  • Ramp_Start : SIXSTEP_Base_InitTypeDef
  • Reference : SIXSTEP_PI_PARAM_InitTypeDef_t
  • Regular_channel : SIXSTEP_Base_InitTypeDef
  • RUN_Motor : SIXSTEP_Base_InitTypeDef

- s -

  • speed_fdbk : SIXSTEP_Base_InitTypeDef
  • speed_fdbk_filtered : SIXSTEP_Base_InitTypeDef
  • Speed_Loop_Time : SIXSTEP_Base_InitTypeDef
  • Speed_Ref_filtered : SIXSTEP_Base_InitTypeDef
  • Speed_target_ramp : SIXSTEP_Base_InitTypeDef
  • Speed_target_time : SIXSTEP_Base_InitTypeDef
  • SPEED_VALIDATED : SIXSTEP_Base_InitTypeDef
  • Start_PWM_driving : L6398_MotorDriver_TypeDef
  • STATUS : SIXSTEP_Base_InitTypeDef
  • status_prev : SIXSTEP_Base_InitTypeDef
  • step_position : SIXSTEP_Base_InitTypeDef
  • Stop_PWM_driving : L6398_MotorDriver_TypeDef
  • SYSCLK_frequency : SIXSTEP_Base_InitTypeDef

- u -

  • Upper_Limit_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- v -

  • VALIDATION_OK : SIXSTEP_Base_InitTypeDef
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • u
  • v

- a -

  • ACCEL : SIXSTEP_Base_InitTypeDef
  • ADC_BEMF_threshold_DOWN : SIXSTEP_Base_InitTypeDef
  • ADC_BEMF_threshold_UP : SIXSTEP_Base_InitTypeDef
  • ADC_BUFFER : SIXSTEP_Base_InitTypeDef
  • ADC_Regular_Buffer : SIXSTEP_Base_InitTypeDef
  • ADC_SEQ_CHANNEL : SIXSTEP_Base_InitTypeDef
  • ALIGN_OK : SIXSTEP_Base_InitTypeDef
  • ALIGNMENT : SIXSTEP_Base_InitTypeDef
  • ARR_OK : SIXSTEP_Base_InitTypeDef
  • ARR_value : SIXSTEP_Base_InitTypeDef

- b -

  • Bemf_delay_start : SIXSTEP_Base_InitTypeDef
  • bemf_state_1 : SIXSTEP_Base_InitTypeDef
  • bemf_state_2 : SIXSTEP_Base_InitTypeDef
  • bemf_state_3 : SIXSTEP_Base_InitTypeDef
  • bemf_state_4 : SIXSTEP_Base_InitTypeDef
  • bemf_state_5 : SIXSTEP_Base_InitTypeDef
  • bemf_state_6 : SIXSTEP_Base_InitTypeDef
  • BEMF_Tdown_count : SIXSTEP_Base_InitTypeDef

- c -

  • CMD : SIXSTEP_Base_InitTypeDef
  • Current_Reference : SIXSTEP_Base_InitTypeDef
  • Current_Reference_Setvalue : L6398_MotorDriver_TypeDef
  • Current_Reference_Start : L6398_MotorDriver_TypeDef
  • Current_Reference_Stop : L6398_MotorDriver_TypeDef
  • CurrentRegular_BEMF_ch : SIXSTEP_Base_InitTypeDef
  • CW_CCW : SIXSTEP_Base_InitTypeDef

- d -

  • demagn_counter : SIXSTEP_Base_InitTypeDef
  • demagn_value : SIXSTEP_Base_InitTypeDef
  • DisableInput_CH1_D_CH2_D_CH3_D : L6398_MotorDriver_TypeDef

- e -

  • EnableInput_CH1_D_CH2_E_CH3_E : L6398_MotorDriver_TypeDef
  • EnableInput_CH1_E_CH2_D_CH3_E : L6398_MotorDriver_TypeDef
  • EnableInput_CH1_E_CH2_E_CH3_D : L6398_MotorDriver_TypeDef

- f -

  • filter_depth : SIXSTEP_Base_InitTypeDef

- h -

  • HF_TIMx_ARR : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_CCR : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_PSC : SIXSTEP_Base_InitTypeDef
  • HF_TIMx_SetDutyCycle_CH1 : L6398_MotorDriver_TypeDef
  • HF_TIMx_SetDutyCycle_CH2 : L6398_MotorDriver_TypeDef
  • HF_TIMx_SetDutyCycle_CH3 : L6398_MotorDriver_TypeDef

- i -

  • Integral_Term_sum : SIXSTEP_Base_InitTypeDef
  • IREFERENCE : SIXSTEP_Base_InitTypeDef
  • Ireference : SIXSTEP_Base_InitTypeDef

- k -

  • KI : SIXSTEP_Base_InitTypeDef
  • Ki_Gain : SIXSTEP_PI_PARAM_InitTypeDef_t
  • KP : SIXSTEP_Base_InitTypeDef
  • Kp_Gain : SIXSTEP_PI_PARAM_InitTypeDef_t

- l -

  • LF_TIMx_ARR : SIXSTEP_Base_InitTypeDef
  • LF_TIMx_PSC : SIXSTEP_Base_InitTypeDef
  • Lower_Limit_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- m -

  • Max_PID_Output : SIXSTEP_PI_PARAM_InitTypeDef_t
  • MediumFrequencyTask_flag : SIXSTEP_Base_InitTypeDef
  • Min_PID_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- n -

  • numberofitemArr : SIXSTEP_Base_InitTypeDef
  • NUMPOLESPAIRS : SIXSTEP_Base_InitTypeDef

- p -

  • Potentiometer : SIXSTEP_Base_InitTypeDef
  • prescaler_value : SIXSTEP_Base_InitTypeDef
  • pulse_value : SIXSTEP_Base_InitTypeDef

- r -

  • Ramp_Start : SIXSTEP_Base_InitTypeDef
  • Reference : SIXSTEP_PI_PARAM_InitTypeDef_t
  • Regular_channel : SIXSTEP_Base_InitTypeDef
  • RUN_Motor : SIXSTEP_Base_InitTypeDef

- s -

  • speed_fdbk : SIXSTEP_Base_InitTypeDef
  • speed_fdbk_filtered : SIXSTEP_Base_InitTypeDef
  • Speed_Loop_Time : SIXSTEP_Base_InitTypeDef
  • Speed_Ref_filtered : SIXSTEP_Base_InitTypeDef
  • Speed_target_ramp : SIXSTEP_Base_InitTypeDef
  • Speed_target_time : SIXSTEP_Base_InitTypeDef
  • SPEED_VALIDATED : SIXSTEP_Base_InitTypeDef
  • Start_PWM_driving : L6398_MotorDriver_TypeDef
  • STATUS : SIXSTEP_Base_InitTypeDef
  • status_prev : SIXSTEP_Base_InitTypeDef
  • step_position : SIXSTEP_Base_InitTypeDef
  • Stop_PWM_driving : L6398_MotorDriver_TypeDef
  • SYSCLK_frequency : SIXSTEP_Base_InitTypeDef

- u -

  • Upper_Limit_Output : SIXSTEP_PI_PARAM_InitTypeDef_t

- v -

  • VALIDATION_OK : SIXSTEP_Base_InitTypeDef
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File List

  • File List
  • File Members
File List
Here is a list of all documented files with brief descriptions:
[detail level 123456]
▼ Drivers |
▼ BSP |
▼ Components |
▼ Common |
MC_Common.h | This header file is a common file
▼ l6398 |
l6398.c | This file provides a set of functions to manage L6398 driver
l6398.h | This file provides a set of functions to manage L6398 driver
▼ X-NUCLEO-IHM08M1 |
X-NUCLEO-IHM08M1.c | This file provides the set of functions to manage the X-Nucleo board
X-NUCLEO-IHM08M1.h | This file provides the set of functions to manage the X-Nucleo board
▼ Middlewares |
▼ ST |
▼ MC_6Step_Lib |
▼ Inc |
6Step_Lib.h | This header file provides the set of functions for Motor Control library
stm32_nucleo_ihm08m1.h | This file provides the interface between the MC-lib and STM Nucleo
▼ Src |
6Step_Lib.c | This file provides the set of functions for Motor Control library
▼ UART_serial_com |
▼ Inc |
UART_UI.h | This file provides a set of functions needed to manage the UART com
▼ Src |
UART_UI.c | This file provides a set of functions needed to manage the UART com
▼ Projects |
▼ Multi |
▼ Examples |
▼ MotorControl |
▼ Inc |
main_F302.h | This file provides a set of functions needed to configure STM32 MCU
main_F401.h |
MC_SixStep_param.h | This header file provides all parameters to driver a motor with 6Step library
stm32F302_nucleo_ihm08m1.h | This file provides the interface between the MC-lib and STM Nucleo
stm32f3xx_hal_conf.h | HAL configuration file
stm32f3xx_it.h | This file contains the headers of the interrupt handlers
stm32F401_nucleo_ihm08m1.h | This file provides the interface between the MC-lib and STM Nucleo
stm32f4xx_hal_conf.h | HAL configuration file
stm32f4xx_it.h | This file contains the headers of the interrupt handlers
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers Directory Reference

  • Drivers
Drivers Directory Reference
Directory dependency graph for Drivers:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers

Directories

directory BSP
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP Directory Reference

  • Drivers
  • BSP
BSP Directory Reference
Directory dependency graph for BSP:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP

Directories

directory | Components
directory | X-NUCLEO-IHM08M1
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components Directory Reference

  • Drivers
  • BSP
  • Components
Components Directory Reference
Directory dependency graph for Components:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components

Directories

directory | Common
directory | l6398
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/Common Directory Reference

  • Drivers
  • BSP
  • Components
  • Common
Common Directory Reference
Directory dependency graph for Common:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/Common

Files

file MC_Common.h [code]
This header file is a common file.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/Common/MC_Common.h File Reference

  • File List
  • File Members
  • Drivers
  • BSP
  • Components
  • Common
Classes
MC_Common.h File Reference

This header file is a common file. More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct L6398_MotorDriver_TypeDef

Detailed Description

This header file is a common file.

Author
System lab - Automation and Motion control team
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398 Directory Reference

  • Drivers
  • BSP
  • Components
  • l6398
l6398 Directory Reference
Directory dependency graph for l6398:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398

Files

file | l6398.c
This file provides a set of functions to manage L6398 driver.
file | l6398.h [code]
This file provides a set of functions to manage L6398 driver.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398/l6398.c File Reference

  • File List
  • File Members
  • Drivers
  • BSP
  • Components
  • l6398
Functions | Variables
l6398.c File Reference

This file provides a set of functions to manage L6398 driver. More...

#include "l6398.h"
Include dependency graph for l6398.c:

Functions

void | EnableInput_CH1_E_CH2_E_CH3_D (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | EnableInput_CH1_E_CH2_D_CH3_E (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | EnableInput_CH1_D_CH2_E_CH3_E (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | DisableInput_CH1_D_CH2_D_CH3_D ()
void | Start_PWM_driving ()
void | Stop_PWM_driving ()
void | HF_TIMx_SetDutyCycle_CH1 (uint16_t CCR_value)
void | HF_TIMx_SetDutyCycle_CH2 (uint16_t CCR_value)
void | HF_TIMx_SetDutyCycle_CH3 (uint16_t CCR_value)
void | Current_Reference_Start ()
void | Current_Reference_Stop ()
void | Current_Reference_Setvalue (uint16_t Iref)

Variables

L6398_MotorDriver_TypeDef L6398MotorDriver

Detailed Description

This file provides a set of functions to manage L6398 driver.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398/l6398.h File Reference

  • File List
  • File Members
  • Drivers
  • BSP
  • Components
  • l6398
Functions
l6398.h File Reference

This file provides a set of functions to manage L6398 driver. More...

#include "stdint.h"
#include "MC_Common.h"
Include dependency graph for l6398.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Functions

void | L6398_ECH1CH2_DCH3_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_ECH1CH3_DCH2_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_ECH2CH3_DCH1_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_DCH1CH2CH3_IO_Write (void)
void | L6398_Start_PWM_generation (void)
void | L6398_Stop_PWM_generation (void)
void | L6398_HFTIM_DC_CH1 (uint16_t CCR_value)
void | L6398_HFTIM_DC_CH2 (uint16_t CCR_value)
void | L6398_HFTIM_DC_CH3 (uint16_t CCR_value)
void | START_Ref_Generation (void)
void | STOP_Ref_Generation (void)
void | Set_Ref_Generation (uint16_t)
void | EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | DisableInput_CH1_D_CH2_D_CH3_D (void)
void | Start_PWM_driving (void)
void | Stop_PWM_driving (void)
void | HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | Current_Reference_Start (void)
void | Current_Reference_Stop (void)
void | Current_Reference_Setvalue (uint16_t)

Detailed Description

This file provides a set of functions to manage L6398 driver.

Author
System lab - Automation and Motion control team
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1 Directory Reference

  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1
X-NUCLEO-IHM08M1 Directory Reference
Directory dependency graph for X-NUCLEO-IHM08M1:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1

Files

file | X-NUCLEO-IHM08M1.c
This file provides the set of functions to manage the X-Nucleo board.
file | X-NUCLEO-IHM08M1.h [code]
This file provides the set of functions to manage the X-Nucleo board.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1/X-NUCLEO-IHM08M1.c File Reference

  • File List
  • File Members
  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1
Functions
X-NUCLEO-IHM08M1.c File Reference

This file provides the set of functions to manage the X-Nucleo board. More...

#include "X-NUCLEO-IHM08M1.h"
#include "6Step_Lib.h"
Include dependency graph for X-NUCLEO-IHM08M1.c:

Functions

void | L6398_ECH1CH2_DCH3_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | L6398_ECH1CH3_DCH2_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | L6398_ECH2CH3_DCH1_IO_Write (uint8_t step_position, uint8_t sync_rect, uint16_t CCR_value)
void | L6398_DCH1CH2CH3_IO_Write ()
void | L6398_Start_PWM_generation ()
void | L6398_Stop_PWM_generation ()
void | L6398_HFTIM_DC_CH1 (uint16_t CCRx)
void | L6398_HFTIM_DC_CH2 (uint16_t CCRx)
void | L6398_HFTIM_DC_CH3 (uint16_t CCRx)
void | BSP_X_NUCLEO_FAULT_LED_ON ()
void | BSP_X_NUCLEO_FAULT_LED_OFF ()

Detailed Description

This file provides the set of functions to manage the X-Nucleo board.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1/X-NUCLEO-IHM08M1.h File Reference

  • File List
  • File Members
  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1
Functions
X-NUCLEO-IHM08M1.h File Reference

This file provides the set of functions to manage the X-Nucleo board. More...

#include "l6398.h"
Include dependency graph for X-NUCLEO-IHM08M1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Functions

void | L6398_ECH1CH2_DCH3_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_ECH1CH3_DCH2_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_ECH2CH3_DCH1_IO_Write (uint8_t, uint8_t, uint16_t)
void | L6398_DCH1CH2CH3_IO_Write (void)
void | L6398_Start_PWM_generation (void)
void | L6398_Stop_PWM_generation (void)
void | L6398_HFTIM_DC_CH1 (uint16_t CCR_value)
void | L6398_HFTIM_DC_CH2 (uint16_t CCR_value)
void | L6398_HFTIM_DC_CH3 (uint16_t CCR_value)
void | BSP_X_NUCLEO_FAULT_LED_ON (void)
void | BSP_X_NUCLEO_FAULT_LED_OFF (void)

Detailed Description

This file provides the set of functions to manage the X-Nucleo board.

Author
System lab - Automation and Motion control team
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares Directory Reference

  • Middlewares
Middlewares Directory Reference
Directory dependency graph for Middlewares:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares

Directories

directory ST
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST Directory Reference

  • Middlewares
  • ST
ST Directory Reference
Directory dependency graph for ST:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST

Directories

directory | MC_6Step_Lib
directory | UART_serial_com
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib Directory Reference

  • Middlewares
  • ST
  • MC_6Step_Lib
MC_6Step_Lib Directory Reference
Directory dependency graph for MC_6Step_Lib:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib

Directories

directory | Inc
directory | Src
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc Directory Reference

  • Middlewares
  • ST
  • MC_6Step_Lib
  • Inc
Inc Directory Reference
Directory dependency graph for Inc:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc

Files

file | 6Step_Lib.h [code]
This header file provides the set of functions for Motor Control library.
file | stm32_nucleo_ihm08m1.h [code]
This file provides the interface between the MC-lib and STM Nucleo.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/6Step_Lib.h File Reference

  • File List
  • File Members
  • Middlewares
  • ST
  • MC_6Step_Lib
  • Inc
Classes | Typedefs | Enumerations | Functions
6Step_Lib.h File Reference

This header file provides the set of functions for Motor Control library. More...

#include "stm32_nucleo_ihm08m1.h"
#include "math.h"
#include "stdlib.h"
#include "stdio.h"
Include dependency graph for 6Step_Lib.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | SIXSTEP_Base_InitTypeDef
Six Step parameters. More...
struct | SIXSTEP_PI_PARAM_InitTypeDef_t
Six PI regulator parameters. More...

Typedefs

typedef struct SIXSTEP_PI_PARAM_InitTypeDef_t * SIXSTEP_pi_PARAM_InitTypeDef_t

Enumerations

enum SIXSTEP_Base_SystStatus_t {
IDLE, STARTUP, VALIDATION, STOP,
START, RUN, ALIGNMENT, SPEEDFBKERROR,
OVERCURRENT, STARTUP_FAILURE, STARTUP_BEMF_FAILURE
}
Six Step parameters.

Functions

void | MC_SixStep_INIT (void)
void | MC_SixStep_RESET (void)
void | MC_StartMotor (void)
void | MC_StopMotor (void)
void | MC_Set_Speed (uint16_t)
void | MC_EXT_button_SixStep (void)

Detailed Description

This header file provides the set of functions for Motor Control library.

Author
System lab
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/stm32_nucleo_ihm08m1.h File Reference

  • File List
  • File Members
  • Middlewares
  • ST
  • MC_6Step_Lib
  • Inc
stm32_nucleo_ihm08m1.h File Reference

This file provides the interface between the MC-lib and STM Nucleo. More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Detailed Description

This file provides the interface between the MC-lib and STM Nucleo.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Src Directory Reference

  • Middlewares
  • ST
  • MC_6Step_Lib
  • Src
Src Directory Reference
Directory dependency graph for Src:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Src

Files

file 6Step_Lib.c
This file provides the set of functions for Motor Control library.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Src/6Step_Lib.c File Reference

  • File List
  • File Members
  • Middlewares
  • ST
  • MC_6Step_Lib
  • Src
Functions | Variables
6Step_Lib.c File Reference

This file provides the set of functions for Motor Control library. More...

#include "6Step_Lib.h"
#include <string.h>
Include dependency graph for 6Step_Lib.c:

Functions

int16_t | MC_PI_Controller (SIXSTEP_PI_PARAM_InitTypeDef_t *, int16_t)
uint16_t | MC_Potentiometer_filter (uint16_t)
uint64_t | MCM_Sqrt (uint64_t wInput)
It calculates the square root of a non-negative s64. It returns 0 for negative s64. More...
int32_t | MC_GetElSpeedHz (void)
int32_t | MC_GetMechSpeedRPM (void)
uint32_t | MC_Bemf_delay_Filter (uint32_t)
void | MC_SixStep_NEXT_step (void)
void | MC_Speed_Filter (void)
void | MC_SixStep_ARR_step (void)
void | MC_SixStep_TABLE (uint8_t)
void | MC_SixStep_Speed_Potentiometer (void)
void | MC_Set_PI_param (SIXSTEP_PI_PARAM_InitTypeDef_t *)
void | MC_Task_Speed (void)
void | MC_SixStep_Alignment (void)
void | MC_Bemf_Delay (void)
void | MC_TIMx_SixStep_timebase (void)
void | MC_ADCx_SixStep_Bemf (void)
void | MC_SysTick_SixStep_MediumFrequencyTask (void)
void | MC_SixStep_Ramp_Motor_calc (void)
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)
void | MC_SixStep_ARR_Bemf (uint8_t)
void | MC_UI_INIT (void)
void | UART_Set_Value (void)
void | UART_Communication_Task (void)
void | MC_SixStep_Init_main_data (void)
void | CMD_Parser (char *pCommandString)
void | MC_SixStep_Speed_Val_target_potentiometer (void)
void | MC_SixStep_RESET ()
void | MC_Set_Speed (uint16_t speed_value)
void | MC_StartMotor ()
void | MC_StopMotor ()
void | MC_SixStep_INIT ()
void | MC_EXT_button_SixStep ()
void | HAL_IncTick (void)
This function is called to increment a global variable "uwTick" used as application time base. More...
uint32_t | HAL_GetTick (void)
Povides a tick value in millisecond. More...

Variables

SIXSTEP_Base_InitTypeDef SIXSTEP_parameters
SIXSTEP_PI_PARAM_InitTypeDef_t PI_parameters
uint16_t | Rotor_poles_pairs
uint32_t | mech_accel_hz = 0
uint32_t | constant_k = 0
uint32_t | Time_vector_tmp = 0
uint32_t | Time_vector_prev_tmp = 0
uint32_t | T_single_step = 0
uint32_t | T_single_step_first_value = 0
int32_t | delta = 0
uint16_t | index_array = 1
int16_t | speed_tmp_array [FILTER_DEEP]
uint16_t | speed_tmp_buffer [FILTER_DEEP]
uint16_t | HFBuffer [HFBUFFERSIZE]
uint16_t | HFBufferIndex = 0
uint8_t | array_completed = FALSE
uint8_t | bemf_array_completed = FALSE
uint8_t | buffer_completed = FALSE
uint8_t | UART_FLAG_RECEIVE = FALSE
uint32_t | ARR_LF = 0
int32_t | Mech_Speed_RPM = 0
int32_t | El_Speed_Hz = 0
uint16_t | index_adc_chn = 0
uint16_t | index_motor_run = 0
uint16_t | test_motor_run = 1
uint8_t | Enable_start_button = TRUE
uint16_t | index_ARR_step = 1
uint32_t | n_zcr_startup = 0
uint16_t | index_startup_motor = 1
uint16_t | target_speed = TARGET_SPEED
uint16_t | shift_n_sqrt = 14
uint16_t | cnt_bemf_event = 0
uint8_t | startup_bemf_failure = 0
uint8_t | speed_fdbk_error = 0
__IO uint32_t | uwTick = 0
uint8_t | dac_status = DAC_ENABLE
uint16_t | index_align = 1
int32_t | speed_sum_sp_filt = 0
int32_t | speed_sum_pot_filt = 0
uint16_t | index_pot_filt = 1
int16_t | potent_filtered = 0
uint32_t | Tick_cnt = 0
uint32_t | counter_ARR_Bemf = 0
uint64_t | constant_multiplier_tmp = 0
uint32_t | demagn_value_tmp = 0
uint32_t | ARR_divider = 80
uint16_t | tmp_val =0
uint32_t | ARR_tmp = 0
uint32_t | ARR_tmp_prev = 0
uint8_t | flag_change_step = FALSE
uint16_t | dmg_tmp = 0
int32_t | bemf_sum_filt = 0
uint16_t | bemf_tmp_array [FILTER_DEEP]
uint16_t | bemf_index_array = 1
uint8_t | synchronous_rect = SYNCHRONOUS_RECTIFICATION
uint8_t | Upcounting_event_flag = FALSE

Detailed Description

This file provides the set of functions for Motor Control library.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com Directory Reference

  • Middlewares
  • ST
  • UART_serial_com
UART_serial_com Directory Reference
Directory dependency graph for UART_serial_com:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com

Directories

directory | Inc
directory | Src
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc Directory Reference

  • Middlewares
  • ST
  • UART_serial_com
  • Inc
Inc Directory Reference
Directory dependency graph for Inc:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc

Files

file UART_UI.h [code]
This file provides a set of functions needed to manage the UART com.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc/UART_UI.h File Reference

  • File List
  • File Members
  • Middlewares
  • ST
  • UART_serial_com
  • Inc
Classes | Macros | Functions
UART_UI.h File Reference

This file provides a set of functions needed to manage the UART com. More...

#include "6Step_Lib.h"
#include "stdlib.h"
#include "stdio.h"
#include <string.h>
Include dependency graph for UART_UI.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct CMD_T

Macros

#define | TOKEN "\r"
#define | CMD_NUM 16
#define | COUNTOF(__BUFFER__) (sizeof(__BUFFER__) / sizeof(*(__BUFFER__)))
#define | TXBUFFERSIZE (COUNTOF(aTxBuffer) - 1)
#define | RXBUFFERSIZE 8

Functions

void | CMD_STARTM (void)
UART function.
void | CMD_STOPMT (void)
void | CMD_DIRECTION (void)
void | CMD_SETSPD (void)
void | CMD_GETSPD (void)
void | CMD_STATUS (void)
void | CMD_POTENZ (void)
void | CMD_HELP (void)
void | CMD_INIREF (void)
void | CMD_POLESP (void)
void | CMD_ACCELE (void)
void | CMD_KP_PRM (void)
void | CMD_KI_PRM (void)

Detailed Description

This file provides a set of functions needed to manage the UART com.

Author
System lab
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Src Directory Reference

  • Middlewares
  • ST
  • UART_serial_com
  • Src
Src Directory Reference
Directory dependency graph for Src:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Src

Files

file UART_UI.c
This file provides a set of functions needed to manage the UART com.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Src/UART_UI.c File Reference

  • File List
  • File Members
  • Middlewares
  • ST
  • UART_serial_com
  • Src
UART_UI.c File Reference

This file provides a set of functions needed to manage the UART com. More...

#include "UART_UI.h"
Include dependency graph for UART_UI.c:

Detailed Description

This file provides a set of functions needed to manage the UART com.

Author
System lab - Automation and Motion control team
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects Directory Reference

  • Projects
Projects Directory Reference
Directory dependency graph for Projects:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects

Directories

directory Multi
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi Directory Reference

  • Projects
  • Multi
Multi Directory Reference
Directory dependency graph for Multi:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi

Directories

directory Examples
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples Directory Reference

  • Projects
  • Multi
  • Examples
Examples Directory Reference
Directory dependency graph for Examples:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples

Directories

directory MotorControl
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl Directory Reference

  • Projects
  • Multi
  • Examples
  • MotorControl
MotorControl Directory Reference
Directory dependency graph for MotorControl:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl

Directories

directory Inc
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc Directory Reference

  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Inc Directory Reference
Directory dependency graph for Inc:
C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc

Files

file | main_F302.h [code]
This file provides a set of functions needed to configure STM32 MCU.
file | main_F401.h [code]
file | MC_SixStep_param.h [code]
This header file provides all parameters to driver a motor with 6Step library.
file | stm32F302_nucleo_ihm08m1.h [code]
This file provides the interface between the MC-lib and STM Nucleo.
file | stm32f3xx_hal_conf.h [code]
HAL configuration file.
file | stm32f3xx_it.h [code]
This file contains the headers of the interrupt handlers.
file | stm32F401_nucleo_ihm08m1.h [code]
This file provides the interface between the MC-lib and STM Nucleo.
file | stm32f4xx_hal_conf.h [code]
HAL configuration file.
file | stm32f4xx_it.h [code]
This file contains the headers of the interrupt handlers.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/main_F302.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Variables
main_F302.h File Reference

This file provides a set of functions needed to configure STM32 MCU. More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Variables

ADC_HandleTypeDef | hadc1
TIM_HandleTypeDef | htim16
TIM_HandleTypeDef | htim1
TIM_HandleTypeDef | htim2
TIM_HandleTypeDef | htim6
UART_HandleTypeDef | huart2

Detailed Description

This file provides a set of functions needed to configure STM32 MCU.

Author
System lab
Version
V1.0.0
Date
29-Sept-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/main_F401.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
main_F401.h
1
35 extern ADC_HandleTypeDef hadc1;
36 extern TIM_HandleTypeDef htim1;
37 extern TIM_HandleTypeDef htim2;
38 extern TIM_HandleTypeDef htim3;
39 extern TIM_HandleTypeDef htim4;
40 extern UART_HandleTypeDef huart2;


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/MC_SixStep_param.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Macros
MC_SixStep_param.h File Reference

This header file provides all parameters to driver a motor with 6Step library. More...

Go to the source code of this file.

Macros

#define | NUM_POLE_PAIRS 7
#define | DIRECTION 0
#define | TARGET_SPEED 3000
#define | POTENTIOMETER 1
#define | VOLTAGE_MODE 0
#define | STARTUP_CURRENT_REFERENCE 1000
#define | ACC 10000
#define | MINIMUM_ACC 500
#define | NUMBER_OF_STEPS 20000
#define | TIME_FOR_ALIGN 100
#define | BUTTON_DELAY 1000
#define | NUMBER_ZCR 12
#define | SPEED_LOOP_TIME 1
#define | KP_GAIN 6000
#define | KI_GAIN 150
#define | KP_DIV 8192
#define | KI_DIV 8192
#define | LOWER_OUT_LIMIT 10
#define | UPPER_OUT_LIMIT 16384
#define | MAX_POT_SPEED 6000
#define | MIN_POT_SPEED 1000
#define | VAL_POT_SPEED_DIV 2
#define | INITIAL_DEMAGN_DELAY 2
#define | KP_GAIN_VM 100
#define | KI_GAIN_VM 30
#define | KP_DIV_VM 8192
#define | KI_DIV_VM 8192
#define | LOWER_OUT_LIMIT_VM 400
#define | UPPER_OUT_LIMIT_VM 1799
#define | DUTY_CYCLE_INIT_VALUE 199
#define | SYNCHRONOUS_RECTIFICATION 1
#define | BEMF_THRSLD_DOWN 80
#define | BEMF_THRSLD_UP 80
#define | FILTER_DEEP 20
#define | HFBUFFERSIZE 10
#define | ADC_SPEED_TH 82
#define | BEMF_CONSEC_DOWN_MAX 10
#define | BEMF_CNT_EVENT_MAX 100
#define | GPIO_ZERO_CROSS 1
#define | GPIO_COMM 1
#define | DEMO_START_TIME 5000
#define | DEMO_STOP_TIME 2000
#define | TRUE 1
#define | FALSE 0

Detailed Description

This header file provides all parameters to driver a motor with 6Step library.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32F302_nucleo_ihm08m1.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Macros | Functions
stm32F302_nucleo_ihm08m1.h File Reference

This file provides the interface between the MC-lib and STM Nucleo. More...

#include "stm32f3xx_hal.h"
#include "main_F302.h"
#include "X-NUCLEO-IHM08M1.h"
Include dependency graph for stm32F302_nucleo_ihm08m1.h:

Go to the source code of this file.

Macros

#define | HF_TIMx htim1
#define | LF_TIMx htim6
#define | ADCx hadc1
#define | REFx htim16
#define | UART huart2
#define | GPIO_PORT_2 GPIOC
#define | GPIO_CH2 GPIO_PIN_11
#define | GPIO_PORT_3 GPIOC
#define | GPIO_CH3 GPIO_PIN_12
#define | GPIO_PORT_BEMF GPIOC
#define | GPIO_CH_BEMF GPIO_PIN_9
#define | ADC_CH_1 ADC_CHANNEL_7 /*CURRENT*/
#define | ADC_CH_2 ADC_CHANNEL_5 /*SPEED*/
#define | ADC_CH_3 ADC_CHANNEL_2 /*VBUS*/
#define | ADC_CH_4 ADC_CHANNEL_8 /*TEMP*/
#define | ADC_Bemf_CH1 ADC_CHANNEL_9 /*BEMF1*/
#define | ADC_Bemf_CH2 ADC_CHANNEL_14 /*BEMF2*/
#define | ADC_Bemf_CH3 ADC_CHANNEL_13 /*BEMF3*/
#define | ADC_CH_1_ST ADC_SAMPLETIME_1CYCLE_5 /*CURRENT sampling time */
#define | ADC_CH_2_ST ADC_SAMPLETIME_181CYCLES_5 /*SPEED sampling time*/
#define | ADC_CH_3_ST ADC_SAMPLETIME_181CYCLES_5 /*VBUS sampling time*/
#define | ADC_CH_4_ST ADC_SAMPLETIME_181CYCLES_5 /*TEMP sampling time*/
#define | ADC_Bemf_CH1_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF1 sampling time*/
#define | ADC_Bemf_CH2_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF2 sampling time*/
#define | ADC_Bemf_CH3_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF3 sampling time*/
#define | HF_TIMx_CH1 TIM_CHANNEL_1
#define | HF_TIMx_CH2 TIM_CHANNEL_2
#define | HF_TIMx_CH3 TIM_CHANNEL_3
#define | HF_TIMx_CCR1 CCR1 /*Channel 1*/
#define | HF_TIMx_CCR2 CCR2 /*Channel 2*/
#define | HF_TIMx_CCR3 CCR3 /*Channel 3*/
#define | DAC_ENABLE 1
#define | DACx htim2
#define | DACx_CH DAC1_CHANNEL_1
#define | DACx_ALIGN DAC_ALIGN_12B_L
#define | GPIO_PORT_ZCR GPIOC
#define | GPIO_CH_ZCR GPIO_PIN_7
#define | GPIO_PORT_COMM GPIOC
#define | GPIO_CH_COMM GPIO_PIN_10
#define | STARTM_CMD 0
#define | STOPMT_CMD 1
#define | SETSPD_CMD 2
#define | GETSPD_CMD 3
#define | INIREF_CMD 4
#define | POLESP_CMD 5
#define | ACCELE_CMD 6
#define | KP_PRM_CMD 7
#define | KI_PRM_CMD 8
#define | POTENZ_CMD 9
#define | HELP_CMD 10
#define | STATUS_CMD 11
#define | DIRECT_CMD 12

Functions

uint32_t | Get_UART_Data (void)
API function for STM32 instruction.
void | MC_SixStep_ADC_Channel (uint32_t)
void | MC_SixStep_Nucleo_Init (void)
void | START_Ref_Generation (void)
void | STOP_Ref_Generation (void)
void | Set_Ref_Generation (uint16_t)
void | START_DAC (void)
void | STOP_DAC (void)
void | SET_DAC_value (uint16_t)
void | Bemf_delay_calc (void)
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)

Detailed Description

This file provides the interface between the MC-lib and STM Nucleo.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Macro Definition Documentation

#define ACCELE_CMD 6

Set the Accelleration for Start-up of the motor command received

#define DAC_ENABLE 1

Enable (1) the DAC peripheral

#define DACx_ALIGN DAC_ALIGN_12B_L

DAC Aligment value

#define DACx_CH DAC1_CHANNEL_1

DAC Channel

#define DIRECT_CMD 12

Get the motor direction

#define GETSPD_CMD 3

Get Mechanical Motor Speed command received

#define GPIO_CH_COMM GPIO_PIN_10

GPIO pin name for 6Step commutation

#define GPIO_CH_ZCR GPIO_PIN_7

GPIO pin name for zero crossing detection

#define GPIO_PORT_COMM GPIOC

GPIO port name for 6Step commutation

#define GPIO_PORT_ZCR GPIOC

GPIO port name for zero crossing detection

#define HELP_CMD 10

Help command received

#define INIREF_CMD 4

Set the new STARUP_CURRENT_REFERENCE value command received

#define KI_PRM_CMD 8

Set the KI PI param command received

#define KP_PRM_CMD 7

Set the KP PI param command received

#define POLESP_CMD 5

Set the Pole Pairs value command received

#define POTENZ_CMD 9

Enable Potentiometer command received

#define SETSPD_CMD 2

Set the new speed value command received

#define STARTM_CMD 0

Start Motor command received

#define STATUS_CMD 11

Get the Status of the system command received

#define STOPMT_CMD 1

Stop Motor command received

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f3xx_hal_conf.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Macros
stm32f3xx_hal_conf.h File Reference

HAL configuration file. More...

#include "stm32f3xx_hal_rcc.h"
#include "stm32f3xx_hal_gpio.h"
#include "stm32f3xx_hal_dma.h"
#include "stm32f3xx_hal_cortex.h"
#include "stm32f3xx_hal_adc.h"
#include "stm32f3xx_hal_flash.h"
#include "stm32f3xx_hal_pwr.h"
#include "stm32f3xx_hal_tim.h"
#include "stm32f3xx_hal_uart.h"
Include dependency graph for stm32f3xx_hal_conf.h:

Go to the source code of this file.

Macros

#define | HAL_MODULE_ENABLED
This is the list of modules to be used in the HAL driver.
#define | HAL_ADC_MODULE_ENABLED
#define | HAL_TIM_MODULE_ENABLED
#define | HAL_UART_MODULE_ENABLED
#define | HAL_GPIO_MODULE_ENABLED
#define | HAL_DMA_MODULE_ENABLED
#define | HAL_RCC_MODULE_ENABLED
#define | HAL_FLASH_MODULE_ENABLED
#define | HAL_PWR_MODULE_ENABLED
#define | HAL_CORTEX_MODULE_ENABLED
#define | HSE_VALUE ((uint32_t)8000000)
Adjust the value of External High Speed oscillator (HSE) used in your application. This value is used by the RCC HAL module to compute the system frequency (when HSE is used as system clock source, directly or through the PLL). More...
#define | HSE_STARTUP_TIMEOUT ((uint32_t)5000)
In the following line adjust the External High Speed oscillator (HSE) Startup Timeout value. More...
#define | HSI_VALUE ((uint32_t)8000000)
Internal High Speed oscillator (HSI) value. This value is used by the RCC HAL module to compute the system frequency (when HSI is used as system clock source, directly or through the PLL). More...
#define | HSI_STARTUP_TIMEOUT ((uint32_t)5000)
In the following line adjust the Internal High Speed oscillator (HSI) Startup Timeout value. More...
#define | LSI_VALUE ((uint32_t)40000)
Internal Low Speed oscillator (LSI) value.
#define | LSE_VALUE ((uint32_t)32768)
External Low Speed oscillator (LSI) value. More...
#define | EXTERNAL_CLOCK_VALUE ((uint32_t)8000000)
External clock source for I2S peripheral This value is used by the I2S HAL module to compute the I2S clock source frequency, this source is inserted directly through I2S_CKIN pad. More...
#define | VDD_VALUE ((uint32_t)3300)
This is the HAL system configuration section. More...
#define | TICK_INT_PRIORITY ((uint32_t)2)
#define | USE_RTOS 0
#define | PREFETCH_ENABLE 1
#define | INSTRUCTION_CACHE_ENABLE 0
#define | DATA_CACHE_ENABLE 0
#define | assert_param(expr) ((void)0)
Uncomment the line below to expanse the "assert_param" macro in the HAL drivers code. More...

Detailed Description

HAL configuration file.

Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Macro Definition Documentation

#define assert_param ( expr ) ((void)0)

Uncomment the line below to expanse the "assert_param" macro in the HAL drivers code.

Include module's header file

#define EXTERNAL_CLOCK_VALUE ((uint32_t)8000000)

External clock source for I2S peripheral This value is used by the I2S HAL module to compute the I2S clock source frequency, this source is inserted directly through I2S_CKIN pad.

  • External clock generated through external PLL component on EVAL 303 (based on MCO or crystal)
  • External clock not generated on EVAL 373Value of the External oscillator in Hz
#define HSE_STARTUP_TIMEOUT ((uint32_t)5000)

In the following line adjust the External High Speed oscillator (HSE) Startup Timeout value.

Time out for HSE start up, in ms

#define HSE_VALUE ((uint32_t)8000000)

Adjust the value of External High Speed oscillator (HSE) used in your application. This value is used by the RCC HAL module to compute the system frequency (when HSE is used as system clock source, directly or through the PLL).

Value of the External oscillator in Hz

#define HSI_STARTUP_TIMEOUT ((uint32_t)5000)

In the following line adjust the Internal High Speed oscillator (HSI) Startup Timeout value.

Time out for HSI start up

#define HSI_VALUE ((uint32_t)8000000)

Internal High Speed oscillator (HSI) value. This value is used by the RCC HAL module to compute the system frequency (when HSI is used as system clock source, directly or through the PLL).

Value of the Internal oscillator in Hz

#define LSE_VALUE ((uint32_t)32768)

External Low Speed oscillator (LSI) value.

< Value of the Internal Low Speed oscillator in Hz The real value may vary depending on the variations in voltage and temperature. Value of the External Low Speed oscillator in Hz

#define TICK_INT_PRIORITY ((uint32_t)2)

tick interrupt priority (lowest by default)

#define VDD_VALUE ((uint32_t)3300)

This is the HAL system configuration section.

Value of VDD in mv

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f3xx_it.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Functions
stm32f3xx_it.h File Reference

This file contains the headers of the interrupt handlers. More...

Go to the source code of this file.

Functions

void | SysTick_Handler (void)
void | ADC1_IRQHandler (void)
void | TIM1_BRK_TIM15_IRQHandler (void)
void | USART2_IRQHandler (void)
void | EXTI15_10_IRQHandler (void)
void | TIM6_DAC_IRQHandler (void)

Detailed Description

This file contains the headers of the interrupt handlers.

COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32F401_nucleo_ihm08m1.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Macros | Functions
stm32F401_nucleo_ihm08m1.h File Reference

This file provides the interface between the MC-lib and STM Nucleo. More...

#include "stm32f4xx_hal.h"
#include "main_F401.h"
#include "X-NUCLEO-IHM08M1.h"
Include dependency graph for stm32F401_nucleo_ihm08m1.h:

Go to the source code of this file.

Macros

#define | HF_TIMx htim1
#define | LF_TIMx htim4
#define | ADCx hadc1
#define | REFx htim3
#define | UART huart2
#define | GPIO_PORT_1 GPIOC
#define | GPIO_CH1 GPIO_PIN_10
#define | GPIO_PORT_2 GPIOC
#define | GPIO_CH2 GPIO_PIN_11
#define | GPIO_PORT_3 GPIOC
#define | GPIO_CH3 GPIO_PIN_12
#define | GPIO_PORT_BEMF GPIOC
#define | GPIO_CH_BEMF GPIO_PIN_9
#define | GPIO_SET GPIO_PIN_SET
#define | GPIO_RESET GPIO_PIN_RESET
#define | ADC_CH_1 ADC_CHANNEL_11 /*CURRENT*/
#define | ADC_CH_2 ADC_CHANNEL_4 /*SPEED*/
#define | ADC_CH_3 ADC_CHANNEL_1 /*VBUS*/
#define | ADC_CH_4 ADC_CHANNEL_12 /*TEMP*/
#define | ADC_Bemf_CH1 ADC_CHANNEL_13 /*BEMF1*/
#define | ADC_Bemf_CH2 ADC_CHANNEL_14 /*BEMF2*/
#define | ADC_Bemf_CH3 ADC_CHANNEL_15 /*BEMF3*/
#define | ADC_CH_1_ST ADC_SAMPLETIME_3CYCLES /*CURRENT sampling time */
#define | ADC_CH_2_ST ADC_SAMPLETIME_84CYCLES /*SPEED sampling time*/
#define | ADC_CH_3_ST ADC_SAMPLETIME_84CYCLES /*VBUS sampling time*/
#define | ADC_CH_4_ST ADC_SAMPLETIME_84CYCLES /*TEMP sampling time*/
#define | ADC_Bemf_CH1_ST ADC_SAMPLETIME_28CYCLES /*BEMF1 sampling time*/
#define | ADC_Bemf_CH2_ST ADC_SAMPLETIME_28CYCLES /*BEMF2 sampling time*/
#define | ADC_Bemf_CH3_ST ADC_SAMPLETIME_28CYCLES /*BEMF3 sampling time*/
#define | HF_TIMx_CH1 TIM_CHANNEL_1
#define | HF_TIMx_CH2 TIM_CHANNEL_2
#define | HF_TIMx_CH3 TIM_CHANNEL_3
#define | HF_TIMx_CCR1 CCR1 /*Channel 1*/
#define | HF_TIMx_CCR2 CCR2 /*Channel 2*/
#define | HF_TIMx_CCR3 CCR3 /*Channel 3*/
#define | DAC_ENABLE 0
#define | GPIO_PORT_ZCR GPIOC
#define | GPIO_CH_ZCR GPIO_PIN_7
#define | GPIO_PORT_COMM GPIOC
#define | GPIO_CH_COMM GPIO_PIN_10
#define | STARTM_CMD 0
#define | STOPMT_CMD 1
#define | SETSPD_CMD 2
#define | GETSPD_CMD 3
#define | INIREF_CMD 4
#define | POLESP_CMD 5
#define | ACCELE_CMD 6
#define | KP_PRM_CMD 7
#define | KI_PRM_CMD 8
#define | POTENZ_CMD 9
#define | HELP_CMD 10
#define | STATUS_CMD 11
#define | DIRECT_CMD 12

Functions

void | MC_SixStep_ADC_Channel (uint32_t)
API function for STM32 instruction.
void | MC_SixStep_Nucleo_Init (void)
void | START_Ref_Generation (void)
void | STOP_Ref_Generation (void)
void | Set_Ref_Generation (uint16_t)
void | START_DAC (void)
void | STOP_DAC (void)
void | SET_DAC_value (uint16_t)
void | Bemf_delay_calc (void)
uint32_t | Get_UART_Data (void)
void | MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E (uint8_t, uint8_t, uint16_t)
void | MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D (void)
void | MC_SixStep_Start_PWM_driving (void)
void | MC_SixStep_Stop_PWM_driving (void)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH1 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH2 (uint16_t)
void | MC_SixStep_HF_TIMx_SetDutyCycle_CH3 (uint16_t)
void | MC_SixStep_Current_Reference_Start (void)
void | MC_SixStep_Current_Reference_Stop (void)
void | MC_SixStep_Current_Reference_Setvalue (uint16_t)

Detailed Description

This file provides the interface between the MC-lib and STM Nucleo.

Author
System lab - Automation and Motion control team
Version
V1.1.0
Date
23-Oct-2015
Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Macro Definition Documentation

#define ACCELE_CMD 6

Set the Accelleration for Start-up of the motor command received

#define DAC_ENABLE 0

Enable (1) the DAC peripheral

#define DIRECT_CMD 12

Get the motor direction

#define GETSPD_CMD 3

Get Mechanical Motor Speed command received

#define GPIO_CH_COMM GPIO_PIN_10

GPIO pin name for 6Step commutation

#define GPIO_CH_ZCR GPIO_PIN_7

GPIO pin name for zero crossing detection

#define GPIO_PORT_COMM GPIOC

GPIO port name for 6Step commutation

#define GPIO_PORT_ZCR GPIOC

GPIO port name for zero crossing detection

#define HELP_CMD 10

Help command received

#define INIREF_CMD 4

Set the new STARUP_CURRENT_REFERENCE value command received

#define KI_PRM_CMD 8

Set the KI PI param command received

#define KP_PRM_CMD 7

Set the KP PI param command received

#define POLESP_CMD 5

Set the Pole Pairs value command received

#define POTENZ_CMD 9

Enable Potentiometer command received

#define SETSPD_CMD 2

Set the new speed value command received

#define STARTM_CMD 0

Start Motor command received

#define STATUS_CMD 11

Get the Status of the system command received

#define STOPMT_CMD 1

Stop Motor command received

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f4xx_hal_conf.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Macros
stm32f4xx_hal_conf.h File Reference

HAL configuration file. More...

#include "stm32f4xx_hal_rcc.h"
#include "stm32f4xx_hal_gpio.h"
#include "stm32f4xx_hal_dma.h"
#include "stm32f4xx_hal_cortex.h"
#include "stm32f4xx_hal_adc.h"
#include "stm32f4xx_hal_flash.h"
#include "stm32f4xx_hal_pwr.h"
#include "stm32f4xx_hal_spi.h"
#include "stm32f4xx_hal_tim.h"
#include "stm32f4xx_hal_uart.h"
Include dependency graph for stm32f4xx_hal_conf.h:

Go to the source code of this file.

Macros

#define | HAL_MODULE_ENABLED
This is the list of modules to be used in the HAL driver.
#define | HAL_ADC_MODULE_ENABLED
#define | HAL_SPI_MODULE_ENABLED
#define | HAL_TIM_MODULE_ENABLED
#define | HAL_UART_MODULE_ENABLED
#define | HAL_GPIO_MODULE_ENABLED
#define | HAL_DMA_MODULE_ENABLED
#define | HAL_RCC_MODULE_ENABLED
#define | HAL_FLASH_MODULE_ENABLED
#define | HAL_PWR_MODULE_ENABLED
#define | HAL_CORTEX_MODULE_ENABLED
#define | HSE_VALUE ((uint32_t)8000000)
Adjust the value of External High Speed oscillator (HSE) used in your application. This value is used by the RCC HAL module to compute the system frequency (when HSE is used as system clock source, directly or through the PLL). More...
#define | HSE_STARTUP_TIMEOUT ((uint32_t)5000)
#define | HSI_VALUE ((uint32_t)16000000)
Internal High Speed oscillator (HSI) value. This value is used by the RCC HAL module to compute the system frequency (when HSI is used as system clock source, directly or through the PLL). More...
#define | LSI_VALUE ((uint32_t)32000)
Internal Low Speed oscillator (LSI) value.
#define | LSE_VALUE ((uint32_t)32768)
External Low Speed oscillator (LSE) value. More...
#define | EXTERNAL_CLOCK_VALUE ((uint32_t)12288000)
External clock source for I2S peripheral This value is used by the I2S HAL module to compute the I2S clock source frequency, this source is inserted directly through I2S_CKIN pad. More...
#define | VDD_VALUE ((uint32_t)3300)
This is the HAL system configuration section. More...
#define | TICK_INT_PRIORITY ((uint32_t)2)
#define | USE_RTOS 0
#define | PREFETCH_ENABLE 1
#define | INSTRUCTION_CACHE_ENABLE 1
#define | DATA_CACHE_ENABLE 1
#define | MAC_ADDR0 2
Uncomment the line below to expanse the "assert_param" macro in the HAL drivers code.
#define | MAC_ADDR1 0
#define | MAC_ADDR2 0
#define | MAC_ADDR3 0
#define | MAC_ADDR4 0
#define | MAC_ADDR5 0
#define | ETH_RX_BUF_SIZE ETH_MAX_PACKET_SIZE /* buffer size for receive */
#define | ETH_TX_BUF_SIZE ETH_MAX_PACKET_SIZE /* buffer size for transmit */
#define | ETH_RXBUFNB ((uint32_t)4) /* 4 Rx buffers of size ETH_RX_BUF_SIZE */
#define | ETH_TXBUFNB ((uint32_t)4) /* 4 Tx buffers of size ETH_TX_BUF_SIZE */
#define | DP83848_PHY_ADDRESS 0x01
#define | PHY_RESET_DELAY ((uint32_t)0x000000FF)
#define | PHY_CONFIG_DELAY ((uint32_t)0x00000FFF)
#define | PHY_READ_TO ((uint32_t)0x0000FFFF)
#define | PHY_WRITE_TO ((uint32_t)0x0000FFFF)
#define | PHY_BCR ((uint16_t)0x00)
#define | PHY_BSR ((uint16_t)0x01)
#define | PHY_RESET ((uint16_t)0x8000)
#define | PHY_LOOPBACK ((uint16_t)0x4000)
#define | PHY_FULLDUPLEX_100M ((uint16_t)0x2100)
#define | PHY_HALFDUPLEX_100M ((uint16_t)0x2000)
#define | PHY_FULLDUPLEX_10M ((uint16_t)0x0100)
#define | PHY_HALFDUPLEX_10M ((uint16_t)0x0000)
#define | PHY_AUTONEGOTIATION ((uint16_t)0x1000)
#define | PHY_RESTART_AUTONEGOTIATION ((uint16_t)0x0200)
#define | PHY_POWERDOWN ((uint16_t)0x0800)
#define | PHY_ISOLATE ((uint16_t)0x0400)
#define | PHY_AUTONEGO_COMPLETE ((uint16_t)0x0020)
#define | PHY_LINKED_STATUS ((uint16_t)0x0004)
#define | PHY_JABBER_DETECTION ((uint16_t)0x0002)
#define | PHY_SR ((uint16_t)0x10)
#define | PHY_MICR ((uint16_t)0x11)
#define | PHY_MISR ((uint16_t)0x12)
#define | PHY_LINK_STATUS ((uint16_t)0x0001)
#define | PHY_SPEED_STATUS ((uint16_t)0x0002)
#define | PHY_DUPLEX_STATUS ((uint16_t)0x0004)
#define | PHY_MICR_INT_EN ((uint16_t)0x0002)
#define | PHY_MICR_INT_OE ((uint16_t)0x0001)
#define | PHY_MISR_LINK_INT_EN ((uint16_t)0x0020)
#define | PHY_LINK_INTERRUPT ((uint16_t)0x2000)
#define | assert_param(expr) ((void)0)
Include module's header file.

Detailed Description

HAL configuration file.

Attention

© COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Macro Definition Documentation

#define EXTERNAL_CLOCK_VALUE ((uint32_t)12288000)

External clock source for I2S peripheral This value is used by the I2S HAL module to compute the I2S clock source frequency, this source is inserted directly through I2S_CKIN pad.

Value of the External audio frequency in Hz

#define HSE_STARTUP_TIMEOUT ((uint32_t)5000)

Time out for HSE start up, in ms

#define HSE_VALUE ((uint32_t)8000000)

Adjust the value of External High Speed oscillator (HSE) used in your application. This value is used by the RCC HAL module to compute the system frequency (when HSE is used as system clock source, directly or through the PLL).

Value of the External oscillator in Hz

#define HSI_VALUE ((uint32_t)16000000)

Internal High Speed oscillator (HSI) value. This value is used by the RCC HAL module to compute the system frequency (when HSI is used as system clock source, directly or through the PLL).

Value of the Internal oscillator in Hz

#define LSE_VALUE ((uint32_t)32768)

External Low Speed oscillator (LSE) value.

< Value of the Internal Low Speed oscillator in Hz The real value may vary depending on the variations in voltage and temperature. Value of the External Low Speed oscillator in Hz

#define PHY_AUTONEGO_COMPLETE ((uint16_t)0x0020)

Auto-Negotiation process completed

#define PHY_AUTONEGOTIATION ((uint16_t)0x1000)

Enable auto-negotiation function

#define PHY_BCR ((uint16_t)0x00)

Transceiver Basic Control Register

#define PHY_BSR ((uint16_t)0x01)

Transceiver Basic Status Register

#define PHY_DUPLEX_STATUS ((uint16_t)0x0004)

PHY Duplex mask

#define PHY_FULLDUPLEX_100M ((uint16_t)0x2100)

Set the full-duplex mode at 100 Mb/s

#define PHY_FULLDUPLEX_10M ((uint16_t)0x0100)

Set the full-duplex mode at 10 Mb/s

#define PHY_HALFDUPLEX_100M ((uint16_t)0x2000)

Set the half-duplex mode at 100 Mb/s

#define PHY_HALFDUPLEX_10M ((uint16_t)0x0000)

Set the half-duplex mode at 10 Mb/s

#define PHY_ISOLATE ((uint16_t)0x0400)

Isolate PHY from MII

#define PHY_JABBER_DETECTION ((uint16_t)0x0002)

Jabber condition detected

#define PHY_LINK_INTERRUPT ((uint16_t)0x2000)

PHY link status interrupt mask

#define PHY_LINK_STATUS ((uint16_t)0x0001)

PHY Link mask

#define PHY_LINKED_STATUS ((uint16_t)0x0004)

Valid link established

#define PHY_LOOPBACK ((uint16_t)0x4000)

Select loop-back mode

#define PHY_MICR ((uint16_t)0x11)

MII Interrupt Control Register

#define PHY_MICR_INT_EN ((uint16_t)0x0002)

PHY Enable interrupts

#define PHY_MICR_INT_OE ((uint16_t)0x0001)

PHY Enable output interrupt events

#define PHY_MISR ((uint16_t)0x12)

MII Interrupt Status and Misc. Control Register

#define PHY_MISR_LINK_INT_EN ((uint16_t)0x0020)

Enable Interrupt on change of link status

#define PHY_POWERDOWN ((uint16_t)0x0800)

Select the power down mode

#define PHY_RESET ((uint16_t)0x8000)

PHY Reset

#define PHY_RESTART_AUTONEGOTIATION ((uint16_t)0x0200)

Restart auto-negotiation function

#define PHY_SPEED_STATUS ((uint16_t)0x0002)

PHY Speed mask

#define PHY_SR ((uint16_t)0x10)

PHY status register Offset

#define TICK_INT_PRIORITY ((uint32_t)2)

tick interrupt priority

#define VDD_VALUE ((uint32_t)3300)

This is the HAL system configuration section.

Value of VDD in mv

Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f4xx_it.h File Reference

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
Functions
stm32f4xx_it.h File Reference

This file contains the headers of the interrupt handlers. More...

Go to the source code of this file.

Functions

void | SysTick_Handler (void)
void | ADC_IRQHandler (void)
void | TIM1_BRK_TIM9_IRQHandler (void)
void | TIM4_IRQHandler (void)
void | USART2_IRQHandler (void)
void | EXTI15_10_IRQHandler (void)

Detailed Description

This file contains the headers of the interrupt handlers.

Date
02/10/2015 17:21:01 COPYRIGHT(c) 2015 STMicroelectronics

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of STMicroelectronics nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented file members with links to the documentation:

- a -

  • ACC : MC_SixStep_param.h
  • ACCELE_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • ADC_SPEED_TH : MC_SixStep_param.h
  • ARR_divider : 6Step_Lib.c
  • ARR_LF : 6Step_Lib.c
  • ARR_tmp : 6Step_Lib.c
  • ARR_tmp_prev : 6Step_Lib.c
  • array_completed : 6Step_Lib.c
  • assert_param : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h

- b -

  • bemf_array_completed : 6Step_Lib.c
  • BEMF_CNT_EVENT_MAX : MC_SixStep_param.h
  • BEMF_CONSEC_DOWN_MAX : MC_SixStep_param.h
  • bemf_index_array : 6Step_Lib.c
  • bemf_sum_filt : 6Step_Lib.c
  • BEMF_THRSLD_DOWN : MC_SixStep_param.h
  • BEMF_THRSLD_UP : MC_SixStep_param.h
  • bemf_tmp_array : 6Step_Lib.c
  • buffer_completed : 6Step_Lib.c
  • BUTTON_DELAY : MC_SixStep_param.h

- c -

  • CMD_STARTM() : UART_UI.h
  • cnt_bemf_event : 6Step_Lib.c
  • constant_k : 6Step_Lib.c
  • constant_multiplier_tmp : 6Step_Lib.c
  • counter_ARR_Bemf : 6Step_Lib.c

- d -

  • DAC_ENABLE : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • dac_status : 6Step_Lib.c
  • DACx_ALIGN : stm32F302_nucleo_ihm08m1.h
  • DACx_CH : stm32F302_nucleo_ihm08m1.h
  • delta : 6Step_Lib.c
  • demagn_value_tmp : 6Step_Lib.c
  • DEMO_START_TIME : MC_SixStep_param.h
  • DEMO_STOP_TIME : MC_SixStep_param.h
  • DIRECT_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • DIRECTION : MC_SixStep_param.h
  • dmg_tmp : 6Step_Lib.c
  • DUTY_CYCLE_INIT_VALUE : MC_SixStep_param.h

- e -

  • El_Speed_Hz : 6Step_Lib.c
  • Enable_start_button : 6Step_Lib.c
  • EXTERNAL_CLOCK_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h

- f -

  • FALSE : MC_SixStep_param.h
  • FILTER_DEEP : MC_SixStep_param.h
  • flag_change_step : 6Step_Lib.c

- g -

  • Get_UART_Data() : stm32F302_nucleo_ihm08m1.h
  • GETSPD_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_CH_COMM : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_CH_ZCR : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_COMM : MC_SixStep_param.h
  • GPIO_PORT_COMM : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_PORT_ZCR : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_ZERO_CROSS : MC_SixStep_param.h

- h -

  • HAL_GetTick() : 6Step_Lib.c
  • HAL_IncTick() : 6Step_Lib.c
  • HAL_MODULE_ENABLED : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h
  • HELP_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • HFBuffer : 6Step_Lib.c
  • HFBufferIndex : 6Step_Lib.c
  • HSE_STARTUP_TIMEOUT : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • HSE_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • HSI_STARTUP_TIMEOUT : stm32f3xx_hal_conf.h
  • HSI_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h

- i -

  • index_adc_chn : 6Step_Lib.c
  • index_align : 6Step_Lib.c
  • index_ARR_step : 6Step_Lib.c
  • index_array : 6Step_Lib.c
  • index_motor_run : 6Step_Lib.c
  • index_pot_filt : 6Step_Lib.c
  • index_startup_motor : 6Step_Lib.c
  • INIREF_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • INITIAL_DEMAGN_DELAY : MC_SixStep_param.h

- k -

  • KI_DIV : MC_SixStep_param.h
  • KI_DIV_VM : MC_SixStep_param.h
  • KI_GAIN : MC_SixStep_param.h
  • KI_GAIN_VM : MC_SixStep_param.h
  • KI_PRM_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • KP_DIV : MC_SixStep_param.h
  • KP_DIV_VM : MC_SixStep_param.h
  • KP_GAIN : MC_SixStep_param.h
  • KP_GAIN_VM : MC_SixStep_param.h
  • KP_PRM_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h

- l -

  • LOWER_OUT_LIMIT : MC_SixStep_param.h
  • LOWER_OUT_LIMIT_VM : MC_SixStep_param.h
  • LSE_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h
  • LSI_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h

- m -

  • MAC_ADDR0 : stm32f4xx_hal_conf.h
  • MAX_POT_SPEED : MC_SixStep_param.h
  • MC_SixStep_ADC_Channel() : stm32F401_nucleo_ihm08m1.h
  • MCM_Sqrt() : 6Step_Lib.c
  • mech_accel_hz : 6Step_Lib.c
  • Mech_Speed_RPM : 6Step_Lib.c
  • MIN_POT_SPEED : MC_SixStep_param.h
  • MINIMUM_ACC : MC_SixStep_param.h

- n -

  • n_zcr_startup : 6Step_Lib.c
  • NUM_POLE_PAIRS : MC_SixStep_param.h
  • NUMBER_OF_STEPS : MC_SixStep_param.h
  • NUMBER_ZCR : MC_SixStep_param.h

- p -

  • PHY_AUTONEGO_COMPLETE : stm32f4xx_hal_conf.h
  • PHY_AUTONEGOTIATION : stm32f4xx_hal_conf.h
  • PHY_BCR : stm32f4xx_hal_conf.h
  • PHY_BSR : stm32f4xx_hal_conf.h
  • PHY_DUPLEX_STATUS : stm32f4xx_hal_conf.h
  • PHY_FULLDUPLEX_100M : stm32f4xx_hal_conf.h
  • PHY_FULLDUPLEX_10M : stm32f4xx_hal_conf.h
  • PHY_HALFDUPLEX_100M : stm32f4xx_hal_conf.h
  • PHY_HALFDUPLEX_10M : stm32f4xx_hal_conf.h
  • PHY_ISOLATE : stm32f4xx_hal_conf.h
  • PHY_JABBER_DETECTION : stm32f4xx_hal_conf.h
  • PHY_LINK_INTERRUPT : stm32f4xx_hal_conf.h
  • PHY_LINK_STATUS : stm32f4xx_hal_conf.h
  • PHY_LINKED_STATUS : stm32f4xx_hal_conf.h
  • PHY_LOOPBACK : stm32f4xx_hal_conf.h
  • PHY_MICR : stm32f4xx_hal_conf.h
  • PHY_MICR_INT_EN : stm32f4xx_hal_conf.h
  • PHY_MICR_INT_OE : stm32f4xx_hal_conf.h
  • PHY_MISR : stm32f4xx_hal_conf.h
  • PHY_MISR_LINK_INT_EN : stm32f4xx_hal_conf.h
  • PHY_POWERDOWN : stm32f4xx_hal_conf.h
  • PHY_RESET : stm32f4xx_hal_conf.h
  • PHY_RESTART_AUTONEGOTIATION : stm32f4xx_hal_conf.h
  • PHY_SPEED_STATUS : stm32f4xx_hal_conf.h
  • PHY_SR : stm32f4xx_hal_conf.h
  • PI_parameters : 6Step_Lib.c
  • POLESP_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • potent_filtered : 6Step_Lib.c
  • POTENTIOMETER : MC_SixStep_param.h
  • POTENZ_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h

- r -

  • Rotor_poles_pairs : 6Step_Lib.c

- s -

  • SETSPD_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • shift_n_sqrt : 6Step_Lib.c
  • SIXSTEP_Base_SystStatus_t : 6Step_Lib.h
  • SIXSTEP_parameters : 6Step_Lib.c
  • SIXSTEP_pi_PARAM_InitTypeDef_t : 6Step_Lib.h
  • speed_fdbk_error : 6Step_Lib.c
  • SPEED_LOOP_TIME : MC_SixStep_param.h
  • speed_sum_pot_filt : 6Step_Lib.c
  • speed_sum_sp_filt : 6Step_Lib.c
  • speed_tmp_array : 6Step_Lib.c
  • speed_tmp_buffer : 6Step_Lib.c
  • STARTM_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • startup_bemf_failure : 6Step_Lib.c
  • STARTUP_CURRENT_REFERENCE : MC_SixStep_param.h
  • STATUS_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • STOPMT_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • synchronous_rect : 6Step_Lib.c
  • SYNCHRONOUS_RECTIFICATION : MC_SixStep_param.h

- t -

  • T_single_step : 6Step_Lib.c
  • T_single_step_first_value : 6Step_Lib.c
  • TARGET_SPEED : MC_SixStep_param.h
  • target_speed : 6Step_Lib.c
  • test_motor_run : 6Step_Lib.c
  • Tick_cnt : 6Step_Lib.c
  • TICK_INT_PRIORITY : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h
  • TIME_FOR_ALIGN : MC_SixStep_param.h
  • Time_vector_prev_tmp : 6Step_Lib.c
  • Time_vector_tmp : 6Step_Lib.c
  • tmp_val : 6Step_Lib.c
  • TRUE : MC_SixStep_param.h

- u -

  • UART_FLAG_RECEIVE : 6Step_Lib.c
  • Upcounting_event_flag : 6Step_Lib.c
  • UPPER_OUT_LIMIT : MC_SixStep_param.h
  • UPPER_OUT_LIMIT_VM : MC_SixStep_param.h
  • uwTick : 6Step_Lib.c

- v -

  • VAL_POT_SPEED_DIV : MC_SixStep_param.h
  • VDD_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • VOLTAGE_MODE : MC_SixStep_param.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • CMD_STARTM() : UART_UI.h
  • Get_UART_Data() : stm32F302_nucleo_ihm08m1.h
  • HAL_GetTick() : 6Step_Lib.c
  • HAL_IncTick() : 6Step_Lib.c
  • MC_SixStep_ADC_Channel() : stm32F401_nucleo_ihm08m1.h
  • MCM_Sqrt() : 6Step_Lib.c
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • m
  • n
  • p
  • r
  • s
  • t
  • u

- a -

  • ARR_divider : 6Step_Lib.c
  • ARR_LF : 6Step_Lib.c
  • ARR_tmp : 6Step_Lib.c
  • ARR_tmp_prev : 6Step_Lib.c
  • array_completed : 6Step_Lib.c

- b -

  • bemf_array_completed : 6Step_Lib.c
  • bemf_index_array : 6Step_Lib.c
  • bemf_sum_filt : 6Step_Lib.c
  • bemf_tmp_array : 6Step_Lib.c
  • buffer_completed : 6Step_Lib.c

- c -

  • cnt_bemf_event : 6Step_Lib.c
  • constant_k : 6Step_Lib.c
  • constant_multiplier_tmp : 6Step_Lib.c
  • counter_ARR_Bemf : 6Step_Lib.c

- d -

  • dac_status : 6Step_Lib.c
  • delta : 6Step_Lib.c
  • demagn_value_tmp : 6Step_Lib.c
  • dmg_tmp : 6Step_Lib.c

- e -

  • El_Speed_Hz : 6Step_Lib.c
  • Enable_start_button : 6Step_Lib.c

- f -

  • flag_change_step : 6Step_Lib.c

- h -

  • HFBuffer : 6Step_Lib.c
  • HFBufferIndex : 6Step_Lib.c

- i -

  • index_adc_chn : 6Step_Lib.c
  • index_align : 6Step_Lib.c
  • index_ARR_step : 6Step_Lib.c
  • index_array : 6Step_Lib.c
  • index_motor_run : 6Step_Lib.c
  • index_pot_filt : 6Step_Lib.c
  • index_startup_motor : 6Step_Lib.c

- m -

  • mech_accel_hz : 6Step_Lib.c
  • Mech_Speed_RPM : 6Step_Lib.c

- n -

  • n_zcr_startup : 6Step_Lib.c

- p -

  • PI_parameters : 6Step_Lib.c
  • potent_filtered : 6Step_Lib.c

- r -

  • Rotor_poles_pairs : 6Step_Lib.c

- s -

  • shift_n_sqrt : 6Step_Lib.c
  • SIXSTEP_parameters : 6Step_Lib.c
  • speed_fdbk_error : 6Step_Lib.c
  • speed_sum_pot_filt : 6Step_Lib.c
  • speed_sum_sp_filt : 6Step_Lib.c
  • speed_tmp_array : 6Step_Lib.c
  • speed_tmp_buffer : 6Step_Lib.c
  • startup_bemf_failure : 6Step_Lib.c
  • synchronous_rect : 6Step_Lib.c

- t -

  • T_single_step : 6Step_Lib.c
  • T_single_step_first_value : 6Step_Lib.c
  • target_speed : 6Step_Lib.c
  • test_motor_run : 6Step_Lib.c
  • Tick_cnt : 6Step_Lib.c
  • Time_vector_prev_tmp : 6Step_Lib.c
  • Time_vector_tmp : 6Step_Lib.c
  • tmp_val : 6Step_Lib.c

- u -

  • UART_FLAG_RECEIVE : 6Step_Lib.c
  • Upcounting_event_flag : 6Step_Lib.c
  • uwTick : 6Step_Lib.c
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • SIXSTEP_pi_PARAM_InitTypeDef_t : 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • SIXSTEP_Base_SystStatus_t : 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Macros
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • s
  • t
  • u
  • v

- a -

  • ACC : MC_SixStep_param.h
  • ACCELE_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • ADC_SPEED_TH : MC_SixStep_param.h
  • assert_param : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h

- b -

  • BEMF_CNT_EVENT_MAX : MC_SixStep_param.h
  • BEMF_CONSEC_DOWN_MAX : MC_SixStep_param.h
  • BEMF_THRSLD_DOWN : MC_SixStep_param.h
  • BEMF_THRSLD_UP : MC_SixStep_param.h
  • BUTTON_DELAY : MC_SixStep_param.h

- d -

  • DAC_ENABLE : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • DACx_ALIGN : stm32F302_nucleo_ihm08m1.h
  • DACx_CH : stm32F302_nucleo_ihm08m1.h
  • DEMO_START_TIME : MC_SixStep_param.h
  • DEMO_STOP_TIME : MC_SixStep_param.h
  • DIRECT_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • DIRECTION : MC_SixStep_param.h
  • DUTY_CYCLE_INIT_VALUE : MC_SixStep_param.h

- e -

  • EXTERNAL_CLOCK_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h

- f -

  • FALSE : MC_SixStep_param.h
  • FILTER_DEEP : MC_SixStep_param.h

- g -

  • GETSPD_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_CH_COMM : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • GPIO_CH_ZCR : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • GPIO_COMM : MC_SixStep_param.h
  • GPIO_PORT_COMM : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • GPIO_PORT_ZCR : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • GPIO_ZERO_CROSS : MC_SixStep_param.h

- h -

  • HAL_MODULE_ENABLED : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • HELP_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • HSE_STARTUP_TIMEOUT : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • HSE_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h
  • HSI_STARTUP_TIMEOUT : stm32f3xx_hal_conf.h
  • HSI_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h

- i -

  • INIREF_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • INITIAL_DEMAGN_DELAY : MC_SixStep_param.h

- k -

  • KI_DIV : MC_SixStep_param.h
  • KI_DIV_VM : MC_SixStep_param.h
  • KI_GAIN : MC_SixStep_param.h
  • KI_GAIN_VM : MC_SixStep_param.h
  • KI_PRM_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • KP_DIV : MC_SixStep_param.h
  • KP_DIV_VM : MC_SixStep_param.h
  • KP_GAIN : MC_SixStep_param.h
  • KP_GAIN_VM : MC_SixStep_param.h
  • KP_PRM_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h

- l -

  • LOWER_OUT_LIMIT : MC_SixStep_param.h
  • LOWER_OUT_LIMIT_VM : MC_SixStep_param.h
  • LSE_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h
  • LSI_VALUE : stm32f4xx_hal_conf.h , stm32f3xx_hal_conf.h

- m -

  • MAC_ADDR0 : stm32f4xx_hal_conf.h
  • MAX_POT_SPEED : MC_SixStep_param.h
  • MIN_POT_SPEED : MC_SixStep_param.h
  • MINIMUM_ACC : MC_SixStep_param.h

- n -

  • NUM_POLE_PAIRS : MC_SixStep_param.h
  • NUMBER_OF_STEPS : MC_SixStep_param.h
  • NUMBER_ZCR : MC_SixStep_param.h

- p -

  • PHY_AUTONEGO_COMPLETE : stm32f4xx_hal_conf.h
  • PHY_AUTONEGOTIATION : stm32f4xx_hal_conf.h
  • PHY_BCR : stm32f4xx_hal_conf.h
  • PHY_BSR : stm32f4xx_hal_conf.h
  • PHY_DUPLEX_STATUS : stm32f4xx_hal_conf.h
  • PHY_FULLDUPLEX_100M : stm32f4xx_hal_conf.h
  • PHY_FULLDUPLEX_10M : stm32f4xx_hal_conf.h
  • PHY_HALFDUPLEX_100M : stm32f4xx_hal_conf.h
  • PHY_HALFDUPLEX_10M : stm32f4xx_hal_conf.h
  • PHY_ISOLATE : stm32f4xx_hal_conf.h
  • PHY_JABBER_DETECTION : stm32f4xx_hal_conf.h
  • PHY_LINK_INTERRUPT : stm32f4xx_hal_conf.h
  • PHY_LINK_STATUS : stm32f4xx_hal_conf.h
  • PHY_LINKED_STATUS : stm32f4xx_hal_conf.h
  • PHY_LOOPBACK : stm32f4xx_hal_conf.h
  • PHY_MICR : stm32f4xx_hal_conf.h
  • PHY_MICR_INT_EN : stm32f4xx_hal_conf.h
  • PHY_MICR_INT_OE : stm32f4xx_hal_conf.h
  • PHY_MISR : stm32f4xx_hal_conf.h
  • PHY_MISR_LINK_INT_EN : stm32f4xx_hal_conf.h
  • PHY_POWERDOWN : stm32f4xx_hal_conf.h
  • PHY_RESET : stm32f4xx_hal_conf.h
  • PHY_RESTART_AUTONEGOTIATION : stm32f4xx_hal_conf.h
  • PHY_SPEED_STATUS : stm32f4xx_hal_conf.h
  • PHY_SR : stm32f4xx_hal_conf.h
  • POLESP_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • POTENTIOMETER : MC_SixStep_param.h
  • POTENZ_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h

- s -

  • SETSPD_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • SPEED_LOOP_TIME : MC_SixStep_param.h
  • STARTM_CMD : stm32F302_nucleo_ihm08m1.h , stm32F401_nucleo_ihm08m1.h
  • STARTUP_CURRENT_REFERENCE : MC_SixStep_param.h
  • STATUS_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • STOPMT_CMD : stm32F401_nucleo_ihm08m1.h , stm32F302_nucleo_ihm08m1.h
  • SYNCHRONOUS_RECTIFICATION : MC_SixStep_param.h

- t -

  • TARGET_SPEED : MC_SixStep_param.h
  • TICK_INT_PRIORITY : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • TIME_FOR_ALIGN : MC_SixStep_param.h
  • TRUE : MC_SixStep_param.h

- u -

  • UPPER_OUT_LIMIT : MC_SixStep_param.h
  • UPPER_OUT_LIMIT_VM : MC_SixStep_param.h

- v -

  • VAL_POT_SPEED_DIV : MC_SixStep_param.h
  • VDD_VALUE : stm32f3xx_hal_conf.h , stm32f4xx_hal_conf.h
  • VOLTAGE_MODE : MC_SixStep_param.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/6Step_Lib.h Source File

  • File List
  • File Members
  • Middlewares
  • ST
  • MC_6Step_Lib
  • Inc
6Step_Lib.h
Go to the documentation of this file.
1
40 /* Define to prevent recursive inclusion -------------------------------------*/
41 #ifndef __6STEP_LIB_H
42 #define __6STEP_LIB_H
43
44 #include "stm32_nucleo_ihm08m1.h"
45
46 #include "math.h"
47 #include "stdlib.h"
48 #include "stdio.h"
49
67 typedef enum
68 {
69 IDLE, /* 0 */
70 STARTUP, /* 1 */
71 VALIDATION, /* 2 */
72 STOP, /* 3 */
73 START, /* 4 */
74 RUN, /* 5 */
75 ALIGNMENT, /* 6 */
76 SPEEDFBKERROR, /* 7 */
77 OVERCURRENT, /* 8 */
78 STARTUP_FAILURE, /* 9 */
79 STARTUP_BEMF_FAILURE /* 10 */
80 } SIXSTEP_Base_SystStatus_t;
81
93 typedef struct
94 {
95 uint32_t LF_TIMx_PSC;
96 uint32_t LF_TIMx_ARR;
97 uint32_t HF_TIMx_PSC;
98 uint32_t HF_TIMx_ARR;
99 uint32_t HF_TIMx_CCR;
100 uint8_t step_position;
101 SIXSTEP_Base_SystStatus_t STATUS;
102 uint8_t status_prev;
103 uint16_t pulse_value;
104 uint16_t ARR_value;
105 uint32_t Regular_channel[4];
106 uint32_t CurrentRegular_BEMF_ch;
107 uint32_t prescaler_value;
108 uint16_t numberofitemArr;
109 uint32_t ADC_BUFFER[4];
110 uint32_t ADC_SEQ_CHANNEL[4];
111 uint32_t ADC_Regular_Buffer[5];
112 uint16_t ADC_BEMF_threshold_UP;
113 uint16_t ADC_BEMF_threshold_DOWN;
114 uint16_t demagn_counter;
115 uint16_t demagn_value;
116 int16_t speed_fdbk;
117 int16_t speed_fdbk_filtered;
118 int16_t filter_depth;
119 uint16_t Current_Reference;
120 uint16_t Ireference;
121 int32_t Integral_Term_sum;
122 uint8_t CMD;
123 uint8_t ALIGN_OK;
124 uint8_t ALIGNMENT;
125 uint8_t bemf_state_1;
126 uint8_t bemf_state_2;
127 uint8_t bemf_state_3;
128 uint8_t bemf_state_4;
129 uint8_t bemf_state_5;
130 uint8_t bemf_state_6;
131 uint16_t Speed_Loop_Time;
132 uint16_t Speed_Ref_filtered;
133 uint16_t RUN_Motor;
134 uint8_t ARR_OK;
135 uint8_t VALIDATION_OK;
136 uint8_t SPEED_VALIDATED;
137 uint16_t Speed_target_ramp;
138 uint16_t Speed_target_time;
139 uint16_t Ramp_Start;
140 uint16_t Bemf_delay_start;
141 uint16_t MediumFrequencyTask_flag;
142 uint32_t SYSCLK_frequency;
143 uint32_t Uart_cmd_to_set;
144 uint32_t Uart_value_to_set;
145 uint8_t Button_ready;
146 uint8_t BEMF_OK;
147 uint8_t CL_READY;
148 uint8_t BEMF_Tdown_count;
149 uint16_t IREFERENCE;
150 uint16_t NUMPOLESPAIRS;
151 uint32_t ACCEL;
152 uint16_t KP;
153 uint16_t KI;
154 uint8_t CW_CCW;
155 uint8_t Potentiometer;
156 } SIXSTEP_Base_InitTypeDef;
169 typedef struct
170 {
171 int16_t Reference;
172 int16_t Kp_Gain;
173 int16_t Ki_Gain;
174 int16_t Lower_Limit_Output;
175 int16_t Upper_Limit_Output;
176 int8_t Max_PID_Output;
177 int8_t Min_PID_Output;
178 } SIXSTEP_PI_PARAM_InitTypeDef_t, *SIXSTEP_pi_PARAM_InitTypeDef_t;
188 void MC_SixStep_INIT(void);
189 void MC_SixStep_RESET(void);
190 void MC_StartMotor(void);
191 void MC_StopMotor(void);
192 void MC_Set_Speed(uint16_t);
193 void MC_EXT_button_SixStep(void);
194
208 #endif
SIXSTEP_Base_InitTypeDef::IREFERENCE
uint16_t IREFERENCE
Definition: 6Step_Lib.h:149
SIXSTEP_Base_InitTypeDef
Six Step parameters.
Definition: 6Step_Lib.h:93
SIXSTEP_Base_InitTypeDef::status_prev
uint8_t status_prev
Definition: 6Step_Lib.h:102
SIXSTEP_Base_InitTypeDef::bemf_state_4
uint8_t bemf_state_4
Definition: 6Step_Lib.h:128
stm32_nucleo_ihm08m1.h
This file provides the interface between the MC-lib and STM Nucleo.
SIXSTEP_Base_InitTypeDef::KP
uint16_t KP
Definition: 6Step_Lib.h:152
SIXSTEP_Base_InitTypeDef::ADC_BEMF_threshold_UP
uint16_t ADC_BEMF_threshold_UP
Definition: 6Step_Lib.h:112
SIXSTEP_PI_PARAM_InitTypeDef_t::Min_PID_Output
int8_t Min_PID_Output
Definition: 6Step_Lib.h:177
SIXSTEP_Base_InitTypeDef::ADC_BEMF_threshold_DOWN
uint16_t ADC_BEMF_threshold_DOWN
Definition: 6Step_Lib.h:113
SIXSTEP_Base_InitTypeDef::Ramp_Start
uint16_t Ramp_Start
Definition: 6Step_Lib.h:139
SIXSTEP_Base_InitTypeDef::ARR_value
uint16_t ARR_value
Definition: 6Step_Lib.h:104
SIXSTEP_Base_InitTypeDef::Bemf_delay_start
uint16_t Bemf_delay_start
Definition: 6Step_Lib.h:140
SIXSTEP_Base_InitTypeDef::numberofitemArr
uint16_t numberofitemArr
Definition: 6Step_Lib.h:108
SIXSTEP_Base_InitTypeDef::VALIDATION_OK
uint8_t VALIDATION_OK
Definition: 6Step_Lib.h:135
SIXSTEP_Base_InitTypeDef::prescaler_value
uint32_t prescaler_value
Definition: 6Step_Lib.h:107
SIXSTEP_Base_InitTypeDef::filter_depth
int16_t filter_depth
Definition: 6Step_Lib.h:118
SIXSTEP_Base_InitTypeDef::LF_TIMx_PSC
uint32_t LF_TIMx_PSC
Definition: 6Step_Lib.h:95
SIXSTEP_Base_SystStatus_t
SIXSTEP_Base_SystStatus_t
Six Step parameters.
Definition: 6Step_Lib.h:67
SIXSTEP_Base_InitTypeDef::Speed_target_time
uint16_t Speed_target_time
Definition: 6Step_Lib.h:138
SIXSTEP_Base_InitTypeDef::Ireference
uint16_t Ireference
Definition: 6Step_Lib.h:120
SIXSTEP_Base_InitTypeDef::HF_TIMx_CCR
uint32_t HF_TIMx_CCR
Definition: 6Step_Lib.h:99
SIXSTEP_Base_InitTypeDef::demagn_value
uint16_t demagn_value
Definition: 6Step_Lib.h:115
SIXSTEP_PI_PARAM_InitTypeDef_t::Ki_Gain
int16_t Ki_Gain
Definition: 6Step_Lib.h:173
SIXSTEP_Base_InitTypeDef::SYSCLK_frequency
uint32_t SYSCLK_frequency
Definition: 6Step_Lib.h:142
SIXSTEP_pi_PARAM_InitTypeDef_t
struct SIXSTEP_PI_PARAM_InitTypeDef_t * SIXSTEP_pi_PARAM_InitTypeDef_t
SIXSTEP_Base_InitTypeDef::Integral_Term_sum
int32_t Integral_Term_sum
Definition: 6Step_Lib.h:121
SIXSTEP_Base_InitTypeDef::CW_CCW
uint8_t CW_CCW
Definition: 6Step_Lib.h:154
SIXSTEP_Base_InitTypeDef::CurrentRegular_BEMF_ch
uint32_t CurrentRegular_BEMF_ch
Definition: 6Step_Lib.h:106
SIXSTEP_Base_InitTypeDef::speed_fdbk
int16_t speed_fdbk
Definition: 6Step_Lib.h:116
SIXSTEP_Base_InitTypeDef::KI
uint16_t KI
Definition: 6Step_Lib.h:153
SIXSTEP_Base_InitTypeDef::HF_TIMx_PSC
uint32_t HF_TIMx_PSC
Definition: 6Step_Lib.h:97
SIXSTEP_Base_InitTypeDef::Potentiometer
uint8_t Potentiometer
Definition: 6Step_Lib.h:155
SIXSTEP_Base_InitTypeDef::Current_Reference
uint16_t Current_Reference
Definition: 6Step_Lib.h:119
SIXSTEP_Base_InitTypeDef::SPEED_VALIDATED
uint8_t SPEED_VALIDATED
Definition: 6Step_Lib.h:136
SIXSTEP_Base_InitTypeDef::CMD
uint8_t CMD
Definition: 6Step_Lib.h:122
SIXSTEP_Base_InitTypeDef::Speed_Loop_Time
uint16_t Speed_Loop_Time
Definition: 6Step_Lib.h:131
SIXSTEP_PI_PARAM_InitTypeDef_t::Max_PID_Output
int8_t Max_PID_Output
Definition: 6Step_Lib.h:176
SIXSTEP_Base_InitTypeDef::pulse_value
uint16_t pulse_value
Definition: 6Step_Lib.h:103
SIXSTEP_Base_InitTypeDef::bemf_state_5
uint8_t bemf_state_5
Definition: 6Step_Lib.h:129
SIXSTEP_Base_InitTypeDef::ALIGN_OK
uint8_t ALIGN_OK
Definition: 6Step_Lib.h:123
SIXSTEP_Base_InitTypeDef::RUN_Motor
uint16_t RUN_Motor
Definition: 6Step_Lib.h:133
SIXSTEP_Base_InitTypeDef::demagn_counter
uint16_t demagn_counter
Definition: 6Step_Lib.h:114
SIXSTEP_Base_InitTypeDef::bemf_state_6
uint8_t bemf_state_6
Definition: 6Step_Lib.h:130
SIXSTEP_Base_InitTypeDef::Speed_Ref_filtered
uint16_t Speed_Ref_filtered
Definition: 6Step_Lib.h:132
SIXSTEP_Base_InitTypeDef::Speed_target_ramp
uint16_t Speed_target_ramp
Definition: 6Step_Lib.h:137
SIXSTEP_Base_InitTypeDef::MediumFrequencyTask_flag
uint16_t MediumFrequencyTask_flag
Definition: 6Step_Lib.h:141
SIXSTEP_PI_PARAM_InitTypeDef_t::Kp_Gain
int16_t Kp_Gain
Definition: 6Step_Lib.h:172
SIXSTEP_PI_PARAM_InitTypeDef_t::Upper_Limit_Output
int16_t Upper_Limit_Output
Definition: 6Step_Lib.h:175
SIXSTEP_Base_InitTypeDef::step_position
uint8_t step_position
Definition: 6Step_Lib.h:100
SIXSTEP_Base_InitTypeDef::BEMF_Tdown_count
uint8_t BEMF_Tdown_count
Definition: 6Step_Lib.h:148
SIXSTEP_PI_PARAM_InitTypeDef_t
Six PI regulator parameters.
Definition: 6Step_Lib.h:169
SIXSTEP_Base_InitTypeDef::bemf_state_3
uint8_t bemf_state_3
Definition: 6Step_Lib.h:127
SIXSTEP_PI_PARAM_InitTypeDef_t::Reference
int16_t Reference
Definition: 6Step_Lib.h:171
SIXSTEP_Base_InitTypeDef::bemf_state_2
uint8_t bemf_state_2
Definition: 6Step_Lib.h:126
SIXSTEP_Base_InitTypeDef::NUMPOLESPAIRS
uint16_t NUMPOLESPAIRS
Definition: 6Step_Lib.h:150
SIXSTEP_Base_InitTypeDef::STATUS
SIXSTEP_Base_SystStatus_t STATUS
Definition: 6Step_Lib.h:101
SIXSTEP_Base_InitTypeDef::bemf_state_1
uint8_t bemf_state_1
Definition: 6Step_Lib.h:125
SIXSTEP_Base_InitTypeDef::ACCEL
uint32_t ACCEL
Definition: 6Step_Lib.h:151
SIXSTEP_Base_InitTypeDef::speed_fdbk_filtered
int16_t speed_fdbk_filtered
Definition: 6Step_Lib.h:117
SIXSTEP_Base_InitTypeDef::ALIGNMENT
uint8_t ALIGNMENT
Definition: 6Step_Lib.h:124
SIXSTEP_Base_InitTypeDef::ARR_OK
uint8_t ARR_OK
Definition: 6Step_Lib.h:134
SIXSTEP_Base_InitTypeDef::HF_TIMx_ARR
uint32_t HF_TIMx_ARR
Definition: 6Step_Lib.h:98
SIXSTEP_Base_InitTypeDef::LF_TIMx_ARR
uint32_t LF_TIMx_ARR
Definition: 6Step_Lib.h:96
SIXSTEP_PI_PARAM_InitTypeDef_t::Lower_Limit_Output
int16_t Lower_Limit_Output
Definition: 6Step_Lib.h:174
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/Common/MC_Common.h Source File

  • File List
  • File Members
  • Drivers
  • BSP
  • Components
  • Common
MC_Common.h
Go to the documentation of this file.
1
39 /* Define to prevent recursive inclusion -------------------------------------*/
40 #ifndef __MC_COMMON_H
41 #define __MC_COMMON_H
42
63 typedef struct
64 {
65 void (*EnableInput_CH1_E_CH2_E_CH3_D)(uint8_t,uint8_t,uint16_t);
66 void (*EnableInput_CH1_E_CH2_D_CH3_E)(uint8_t,uint8_t,uint16_t);
67 void (*EnableInput_CH1_D_CH2_E_CH3_E)(uint8_t,uint8_t,uint16_t);
68 void (*DisableInput_CH1_D_CH2_D_CH3_D)(void);
69 void (*Start_PWM_driving)(void);
70 void (*Stop_PWM_driving)(void);
71 void (*HF_TIMx_SetDutyCycle_CH1)(uint16_t);
72 void (*HF_TIMx_SetDutyCycle_CH2)(uint16_t);
73 void (*HF_TIMx_SetDutyCycle_CH3)(uint16_t);
74 void (*Current_Reference_Start)(void);
75 void (*Current_Reference_Stop)(void);
76 void (*Current_Reference_Setvalue)(uint16_t);
77 } L6398_MotorDriver_TypeDef;
95 #endif
96
L6398_MotorDriver_TypeDef
Definition: MC_Common.h:63
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/MC_SixStep_param.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
MC_SixStep_param.h
Go to the documentation of this file.
1
54 /* ****************************************************************************
55 ==============================================================================
56 ###### BASIC PARAMETERS ######
57 ==============================================================================
58 **************************************************************************** */
59 #define NUM_POLE_PAIRS 7
60 #define DIRECTION 0
61 #define TARGET_SPEED 3000
62 #define POTENTIOMETER 1
63 #define VOLTAGE_MODE 0
64 /* ****************************************************************************
65 ==============================================================================
66 ###### ADVANCED PARAMETERS ######
67 ==============================================================================
68 **************************************************************************** */
69
70 #define STARTUP_CURRENT_REFERENCE 1000
71 #define ACC 10000
72 #define MINIMUM_ACC 500
73 #define NUMBER_OF_STEPS 20000
74 #define TIME_FOR_ALIGN 100
75 #define BUTTON_DELAY 1000
76 #define NUMBER_ZCR 12
79 #define SPEED_LOOP_TIME 1
80 #define KP_GAIN 6000
81 #define KI_GAIN 150
82 #define KP_DIV 8192
83 #define KI_DIV 8192
84 #define LOWER_OUT_LIMIT 10
85 #define UPPER_OUT_LIMIT 16384
86 #define MAX_POT_SPEED 6000
87 #define MIN_POT_SPEED 1000
88 #define VAL_POT_SPEED_DIV 2
89 #define INITIAL_DEMAGN_DELAY 2
92 #define KP_GAIN_VM 100
93 #define KI_GAIN_VM 30
94 #define KP_DIV_VM 8192
95 #define KI_DIV_VM 8192
96 #define LOWER_OUT_LIMIT_VM 400
97 #define UPPER_OUT_LIMIT_VM 1799
98 #define DUTY_CYCLE_INIT_VALUE 199
101 #define SYNCHRONOUS_RECTIFICATION 1
104 #define BEMF_THRSLD_DOWN 80
105 #define BEMF_THRSLD_UP 80
108 #define FILTER_DEEP 20
109 #define HFBUFFERSIZE 10
110 #define ADC_SPEED_TH 82
113 #define BEMF_CONSEC_DOWN_MAX 10
114 #define BEMF_CNT_EVENT_MAX 100
117 #define GPIO_ZERO_CROSS 1
118 #define GPIO_COMM 1
122 #define DEMO_START_TIME 5000
123 #define DEMO_STOP_TIME 2000
125 #define TRUE 1
126 #define FALSE 0
Generated on Wed Oct 28 2015 17:58:55 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc/UART_UI.h Source File

  • File List
  • File Members
  • Middlewares
  • ST
  • UART_serial_com
  • Inc
UART_UI.h
Go to the documentation of this file.
1
38 #include "6Step_Lib.h"
39 #include "stdlib.h"
40 #include "stdio.h"
41 #include <string.h>
42
43 #define TOKEN "\r"
44 #define CMD_NUM 16
45
46 #define COUNTOF(__BUFFER__) (sizeof(__BUFFER__) / sizeof(*(__BUFFER__)))
47 #define TXBUFFERSIZE (COUNTOF(aTxBuffer) - 1)
48 #define RXBUFFERSIZE 8
49
50 typedef struct {
51 char name[10];
52 void (*pCmdFunc)(void);
53 } CMD_T;
54
73 void CMD_STARTM( void );
74 void CMD_STOPMT( void );
75 void CMD_DIRECTION( void );
76 void CMD_SETSPD( void );
77 void CMD_GETSPD( void );
78 void CMD_STATUS( void );
79 void CMD_POTENZ( void );
80 void CMD_HELP(void);
81 void CMD_INIREF(void);
82 void CMD_POLESP(void);
83 void CMD_ACCELE(void);
84 void CMD_KP_PRM(void);
85 void CMD_KI_PRM(void);
86
CMD_T
Definition: UART_UI.h:50
6Step_Lib.h
This header file provides the set of functions for Motor Control library.
CMD_STARTM
void CMD_STARTM(void)
UART function.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1/X-NUCLEO-IHM08M1.h Source File

  • File List
  • File Members
  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1
X-NUCLEO-IHM08M1.h
Go to the documentation of this file.
1
38 /* Includes ------------------------------------------------------------------*/
39
40 #include "l6398.h"
41
42 void L6398_ECH1CH2_DCH3_IO_Write(uint8_t,uint8_t,uint16_t);
43 void L6398_ECH1CH3_DCH2_IO_Write(uint8_t,uint8_t,uint16_t);
44 void L6398_ECH2CH3_DCH1_IO_Write(uint8_t,uint8_t,uint16_t);
45 void L6398_DCH1CH2CH3_IO_Write(void);
46 void L6398_Start_PWM_generation(void);
47 void L6398_Stop_PWM_generation(void);
48 void L6398_HFTIM_DC_CH1(uint16_t CCR_value);
49 void L6398_HFTIM_DC_CH2(uint16_t CCR_value);
50 void L6398_HFTIM_DC_CH3(uint16_t CCR_value);
51
52 void BSP_X_NUCLEO_FAULT_LED_ON(void);
53 void BSP_X_NUCLEO_FAULT_LED_OFF(void);
54
l6398.h
This file provides a set of functions to manage L6398 driver.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP -> Middlewares Relation

  • Drivers
  • BSP

BSP → Middlewares Relation

File in Drivers/BSP | Includes file in Middlewares
X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.c | ST / MC_6Step_Lib / Inc / 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398 -> Common Relation

  • Drivers
  • BSP
  • Components
  • l6398

l6398 → Common Relation

File in Drivers/BSP/Components/l6398 | Includes file in Drivers/BSP/Components/Common
l6398.h | MC_Common.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1 -> Components Relation

  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1

X-NUCLEO-IHM08M1 → Components Relation

File in Drivers/BSP/X-NUCLEO-IHM08M1 | Includes file in Drivers/BSP/Components
X-NUCLEO-IHM08M1.h | l6398 / l6398.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/X-NUCLEO-IHM08M1 -> Middlewares Relation

  • Drivers
  • BSP
  • X-NUCLEO-IHM08M1

X-NUCLEO-IHM08M1 → Middlewares Relation

File in Drivers/BSP/X-NUCLEO-IHM08M1 | Includes file in Middlewares
X-NUCLEO-IHM08M1.c | ST / MC_6Step_Lib / Inc / 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Src -> Inc Relation

  • Middlewares
  • ST
  • MC_6Step_Lib
  • Src

Src → Inc Relation

File in Middlewares/ST/MC_6Step_Lib/Src | Includes file in Middlewares/ST/MC_6Step_Lib/Inc
6Step_Lib.c | 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com -> MC_6Step_Lib Relation

  • Middlewares
  • ST
  • UART_serial_com

UART_serial_com → MC_6Step_Lib Relation

File in Middlewares/ST/UART_serial_com | Includes file in Middlewares/ST/MC_6Step_Lib
Inc / UART_UI.h | Inc / 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Inc -> MC_6Step_Lib Relation

  • Middlewares
  • ST
  • UART_serial_com
  • Inc

Inc → MC_6Step_Lib Relation

File in Middlewares/ST/UART_serial_com/Inc | Includes file in Middlewares/ST/MC_6Step_Lib
UART_UI.h | Inc / 6Step_Lib.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/UART_serial_com/Src -> Inc Relation

  • Middlewares
  • ST
  • UART_serial_com
  • Src

Src → Inc Relation

File in Middlewares/ST/UART_serial_com/Src | Includes file in Middlewares/ST/UART_serial_com/Inc
UART_UI.c | UART_UI.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi -> Drivers Relation

  • Projects
  • Multi

Multi → Drivers Relation

File in Projects/Multi | Includes file in Drivers
Examples / MotorControl / Inc / stm32F302_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Examples / MotorControl / Inc / stm32F401_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples -> Drivers Relation

  • Projects
  • Multi
  • Examples

Examples → Drivers Relation

File in Projects/Multi/Examples | Includes file in Drivers
MotorControl / Inc / stm32F302_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
MotorControl / Inc / stm32F401_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl -> Drivers Relation

  • Projects
  • Multi
  • Examples
  • MotorControl

MotorControl → Drivers Relation

File in Projects/Multi/Examples/MotorControl | Includes file in Drivers
Inc / stm32F302_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Inc / stm32F401_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc -> Drivers Relation

  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc

Inc → Drivers Relation

File in Projects/Multi/Examples/MotorControl/Inc | Includes file in Drivers
stm32F302_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
stm32F401_nucleo_ihm08m1.h | BSP / X-NUCLEO-IHM08M1 / X-NUCLEO-IHM08M1.h
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

1 /*! Invisible class because of truncation */
2 class Invisible { };
3
4 /*! Truncated class, inheritance relation is hidden */
5 class Truncated : public Invisible { };
6
7 /* Class not documented with doxygen comments */
8 class Undocumented { };
9
10 /*! Class that is inherited using public inheritance */
11 class PublicBase : public Truncated { };
12
13 /*! A template class */
14 template<class T> class Templ { };
15
16 /*! Class that is inherited using protected inheritance */
17 class ProtectedBase { };
18
19 /*! Class that is inherited using private inheritance */
20 class PrivateBase { };
21
22 /*! Class that is used by the Inherited class */
23 class Used { };
24
25 /*! Super class that inherits a number of other classes */
26 class Inherited : public PublicBase,
27 protected ProtectedBase,
28 private PrivateBase,
29 public Undocumented,
30 public Templ<int>
31 {
32 private:
33 Used *m_usedClass;
34 };

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-NUCLEO-IHM07M1 - X-CUBE-SPN8: X-NUCLEO-IHM08M1 - X-CUBE-SPN8 Main Page

X-CUBE-SPN8 Documentation
Version
1.0
Author
STMicroelectronics - SystemLab, 2015

Introduction

X-CUBE-SPN8 is an expansion software package for STM32Cube. The software runs on the STM32 and includes drivers that initialize and send application commands to 3ph motor driver (L6398) mounted on dedicated expansion board (X-NUCLEO-IHM08M1) stacked on a STM32 Nucleo Board. The expansion is built on STM32Cube software technology to ease portability across different STM32 microcontrollers..

It was developed by means of STM32CUBE so it based on the HAL (Hardware Abstraction Layer) Library.

The firmware is split into modules:

  • L6398: to manage the motor driver;
  • X-NUCLEO-IHM08M1: to manage the expansion board;
  • MOTORCONTROL: to contain the FW library for motor control and the interface file between MCU and LIB
  • the "main" to manage the whole system.

A user can use this firmware as base to develop the own application that can:

  • run a 3ph BLDC/PMSM motor with X-NUCLEO-IHM08M1;
X-NUCLEO-IHM08M1 FW Layers
Generated on Wed Apr 22 2015 10:07:01 for X-Nucleo-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Drivers/BSP/Components/l6398/l6398.h Source File

  • File List
  • File Members
  • Drivers
  • BSP
  • Components
  • l6398
l6398.h
Go to the documentation of this file.
1
38 /* Define to prevent recursive inclusion -------------------------------------*/
39 #ifndef __L6398_H
40 #define __L6398_H
41
42 #include "stdint.h"
43 #include "MC_Common.h"
44
45 extern void L6398_ECH1CH2_DCH3_IO_Write(uint8_t,uint8_t,uint16_t);
46 extern void L6398_ECH1CH3_DCH2_IO_Write(uint8_t,uint8_t,uint16_t);
47 extern void L6398_ECH2CH3_DCH1_IO_Write(uint8_t,uint8_t,uint16_t);
48 extern void L6398_DCH1CH2CH3_IO_Write(void);
49 extern void L6398_Start_PWM_generation(void);
50 extern void L6398_Stop_PWM_generation(void);
51 extern void L6398_HFTIM_DC_CH1(uint16_t CCR_value);
52 extern void L6398_HFTIM_DC_CH2(uint16_t CCR_value);
53 extern void L6398_HFTIM_DC_CH3(uint16_t CCR_value);
54 extern void START_Ref_Generation(void);
55 extern void STOP_Ref_Generation(void);
56 extern void Set_Ref_Generation(uint16_t);
57
58 void EnableInput_CH1_E_CH2_E_CH3_D(uint8_t,uint8_t,uint16_t);
59 void EnableInput_CH1_E_CH2_D_CH3_E(uint8_t,uint8_t,uint16_t);
60 void EnableInput_CH1_D_CH2_E_CH3_E(uint8_t,uint8_t,uint16_t);
61 void DisableInput_CH1_D_CH2_D_CH3_D(void);
62 void Start_PWM_driving(void);
63 void Stop_PWM_driving(void);
64 void HF_TIMx_SetDutyCycle_CH1(uint16_t);
65 void HF_TIMx_SetDutyCycle_CH2(uint16_t);
66 void HF_TIMx_SetDutyCycle_CH3(uint16_t);
67 void Current_Reference_Start(void);
68 void Current_Reference_Stop(void);
69 void Current_Reference_Setvalue(uint16_t);
70
71
98 #endif
MC_Common.h
This header file is a common file.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/main_F302.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
main_F302.h
Go to the documentation of this file.
1
38 extern ADC_HandleTypeDef hadc1;
39 extern TIM_HandleTypeDef htim16;
40 extern TIM_HandleTypeDef htim1;
41 extern TIM_HandleTypeDef htim2;
42 extern TIM_HandleTypeDef htim6;
43 extern UART_HandleTypeDef huart2;


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Middlewares/ST/MC_6Step_Lib/Inc/stm32_nucleo_ihm08m1.h Source File

  • File List
  • File Members
  • Middlewares
  • ST
  • MC_6Step_Lib
  • Inc
stm32_nucleo_ihm08m1.h
Go to the documentation of this file.
1
38 #ifdef STM32F030x8
39 #include "stm32F030_nucleo_ihm08m1.h"
40 #include "MC_SixStep_param_F030.h"
41 #endif
42 #ifdef STM32F103xB
43 #include "stm32F103_nucleo_ihm08m1.h"
44 #include "MC_SixStep_param.h"
45 #endif
46 #ifdef STM32F302x8
47 #include "stm32F302_nucleo_ihm08m1.h"
48 #include "MC_SixStep_param.h"
49 #endif
50 #ifdef STM32F401xE
51 #include "stm32F401_nucleo_ihm08m1.h"
52 #include "MC_SixStep_param.h"
53 #endif
54
55
56
MC_SixStep_param.h
This header file provides all parameters to driver a motor with 6Step library.
stm32F302_nucleo_ihm08m1.h
This file provides the interface between the MC-lib and STM Nucleo.
stm32F401_nucleo_ihm08m1.h
This file provides the interface between the MC-lib and STM Nucleo.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32F302_nucleo_ihm08m1.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32F302_nucleo_ihm08m1.h
Go to the documentation of this file.
1
39 /* Define to prevent recursive inclusion -------------------------------------*/
40 #ifndef __STM32F302_NUCLEO_IHM08M1_H
41 #define __STM32F302_NUCLEO_IHM08M1_H
42
43 #include "stm32f3xx_hal.h"
44 #include "main_F302.h"
45 #include "X-NUCLEO-IHM08M1.h"
46
47 #define HF_TIMx htim1
48 #define LF_TIMx htim6
49 // #define HALL_ENCODER_TIMx htim2
50 #define ADCx hadc1
51 #define REFx htim16
52 #define UART huart2
53
54 #define GPIO_PORT_2 GPIOC
55 #define GPIO_CH2 GPIO_PIN_11
56 #define GPIO_PORT_3 GPIOC
57 #define GPIO_CH3 GPIO_PIN_12
58 #define GPIO_PORT_BEMF GPIOC
59 #define GPIO_CH_BEMF GPIO_PIN_9
60
61 #define ADC_CH_1 ADC_CHANNEL_7 /*CURRENT*/
62 #define ADC_CH_2 ADC_CHANNEL_5 /*SPEED*/
63 #define ADC_CH_3 ADC_CHANNEL_2 /*VBUS*/
64 #define ADC_CH_4 ADC_CHANNEL_8 /*TEMP*/
65 #define ADC_Bemf_CH1 ADC_CHANNEL_9 /*BEMF1*/
66 #define ADC_Bemf_CH2 ADC_CHANNEL_14 /*BEMF2*/
67 #define ADC_Bemf_CH3 ADC_CHANNEL_13 /*BEMF3*/
68
69 #define ADC_CH_1_ST ADC_SAMPLETIME_1CYCLE_5 /*CURRENT sampling time */
70 #define ADC_CH_2_ST ADC_SAMPLETIME_181CYCLES_5 /*SPEED sampling time*/
71 #define ADC_CH_3_ST ADC_SAMPLETIME_181CYCLES_5 /*VBUS sampling time*/
72 #define ADC_CH_4_ST ADC_SAMPLETIME_181CYCLES_5 /*TEMP sampling time*/
73 #define ADC_Bemf_CH1_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF1 sampling time*/
74 #define ADC_Bemf_CH2_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF2 sampling time*/
75 #define ADC_Bemf_CH3_ST ADC_SAMPLETIME_61CYCLES_5 /*BEMF3 sampling time*/
76
77 #define HF_TIMx_CH1 TIM_CHANNEL_1
78 #define HF_TIMx_CH2 TIM_CHANNEL_2
79 #define HF_TIMx_CH3 TIM_CHANNEL_3
80 #define HF_TIMx_CCR1 CCR1 /*Channel 1*/
81 #define HF_TIMx_CCR2 CCR2 /*Channel 2*/
82 #define HF_TIMx_CCR3 CCR3 /*Channel 3*/
83
84 #define DAC_ENABLE 1
85 #define DACx htim2
86 #define DACx_CH DAC1_CHANNEL_1
87 #define DACx_ALIGN DAC_ALIGN_12B_L
89 #define GPIO_PORT_ZCR GPIOC
90 #define GPIO_CH_ZCR GPIO_PIN_7
91 #define GPIO_PORT_COMM GPIOC
92 #define GPIO_CH_COMM GPIO_PIN_10
94 #define STARTM_CMD 0
95 #define STOPMT_CMD 1
96 #define SETSPD_CMD 2
97 #define GETSPD_CMD 3
98 #define INIREF_CMD 4
99 #define POLESP_CMD 5
100 #define ACCELE_CMD 6
101 #define KP_PRM_CMD 7
102 #define KI_PRM_CMD 8
103 #define POTENZ_CMD 9
104 #define HELP_CMD 10
105 #define STATUS_CMD 11
106 #define DIRECT_CMD 12
119 uint32_t Get_UART_Data(void);
120 void MC_SixStep_ADC_Channel(uint32_t);
121 void MC_SixStep_Nucleo_Init(void);
122 void START_Ref_Generation(void);
123 void STOP_Ref_Generation(void);
124 void Set_Ref_Generation(uint16_t);
125 void START_DAC(void);
126 void STOP_DAC(void);
127 void SET_DAC_value(uint16_t);
128 void Bemf_delay_calc(void);
129 void MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D(uint8_t,uint8_t,uint16_t);
130 void MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E(uint8_t,uint8_t,uint16_t);
131 void MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E(uint8_t,uint8_t,uint16_t);
132 void MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D(void);
133 void MC_SixStep_Start_PWM_driving(void);
134 void MC_SixStep_Stop_PWM_driving(void);
135 void MC_SixStep_HF_TIMx_SetDutyCycle_CH1(uint16_t);
136 void MC_SixStep_HF_TIMx_SetDutyCycle_CH2(uint16_t);
137 void MC_SixStep_HF_TIMx_SetDutyCycle_CH3(uint16_t);
138 void MC_SixStep_Current_Reference_Start(void);
139 void MC_SixStep_Current_Reference_Stop(void);
140 void MC_SixStep_Current_Reference_Setvalue(uint16_t);
141
150 #endif
X-NUCLEO-IHM08M1.h
This file provides the set of functions to manage the X-Nucleo board.
MC_SixStep_ADC_Channel
void MC_SixStep_ADC_Channel(uint32_t)
API function for STM32 instruction.
main_F302.h
This file provides a set of functions needed to configure STM32 MCU.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32F401_nucleo_ihm08m1.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32F401_nucleo_ihm08m1.h
Go to the documentation of this file.
1
38 /* Define to prevent recursive inclusion -------------------------------------*/
39 #ifndef __STM32F401_NUCLEO_IHM08M1_H
40 #define __STM32F401_NUCLEO_IHM08M1_H
41
42 #include "stm32f4xx_hal.h"
43 #include "main_F401.h"
44 #include "X-NUCLEO-IHM08M1.h"
45
46 #define HF_TIMx htim1
47 #define LF_TIMx htim4
48 // #define HALL_ENCODER_TIMx htim2
49 #define ADCx hadc1
50 #define REFx htim3
51 #define UART huart2
52
53 #define GPIO_PORT_1 GPIOC
54 #define GPIO_CH1 GPIO_PIN_10
55 #define GPIO_PORT_2 GPIOC
56 #define GPIO_CH2 GPIO_PIN_11
57 #define GPIO_PORT_3 GPIOC
58 #define GPIO_CH3 GPIO_PIN_12
59 #define GPIO_PORT_BEMF GPIOC
60 #define GPIO_CH_BEMF GPIO_PIN_9
61 #define GPIO_SET GPIO_PIN_SET
62 #define GPIO_RESET GPIO_PIN_RESET
63
64 #define ADC_CH_1 ADC_CHANNEL_11 /*CURRENT*/
65 #define ADC_CH_2 ADC_CHANNEL_4 /*SPEED*/
66 #define ADC_CH_3 ADC_CHANNEL_1 /*VBUS*/
67 #define ADC_CH_4 ADC_CHANNEL_12 /*TEMP*/
68 #define ADC_Bemf_CH1 ADC_CHANNEL_13 /*BEMF1*/
69 #define ADC_Bemf_CH2 ADC_CHANNEL_14 /*BEMF2*/
70 #define ADC_Bemf_CH3 ADC_CHANNEL_15 /*BEMF3*/
71
72 #define ADC_CH_1_ST ADC_SAMPLETIME_3CYCLES /*CURRENT sampling time */
73 #define ADC_CH_2_ST ADC_SAMPLETIME_84CYCLES /*SPEED sampling time*/
74 #define ADC_CH_3_ST ADC_SAMPLETIME_84CYCLES /*VBUS sampling time*/
75 #define ADC_CH_4_ST ADC_SAMPLETIME_84CYCLES /*TEMP sampling time*/
76 #define ADC_Bemf_CH1_ST ADC_SAMPLETIME_28CYCLES /*BEMF1 sampling time*/
77 #define ADC_Bemf_CH2_ST ADC_SAMPLETIME_28CYCLES /*BEMF2 sampling time*/
78 #define ADC_Bemf_CH3_ST ADC_SAMPLETIME_28CYCLES /*BEMF3 sampling time*/
79
80 #define HF_TIMx_CH1 TIM_CHANNEL_1
81 #define HF_TIMx_CH2 TIM_CHANNEL_2
82 #define HF_TIMx_CH3 TIM_CHANNEL_3
83 #define HF_TIMx_CCR1 CCR1 /*Channel 1*/
84 #define HF_TIMx_CCR2 CCR2 /*Channel 2*/
85 #define HF_TIMx_CCR3 CCR3 /*Channel 3*/
86
87 #define DAC_ENABLE 0
89 #define GPIO_PORT_ZCR GPIOC
90 #define GPIO_CH_ZCR GPIO_PIN_7
91 #define GPIO_PORT_COMM GPIOC
92 #define GPIO_CH_COMM GPIO_PIN_10
94 #define STARTM_CMD 0
95 #define STOPMT_CMD 1
96 #define SETSPD_CMD 2
97 #define GETSPD_CMD 3
98 #define INIREF_CMD 4
99 #define POLESP_CMD 5
100 #define ACCELE_CMD 6
101 #define KP_PRM_CMD 7
102 #define KI_PRM_CMD 8
103 #define POTENZ_CMD 9
104 #define HELP_CMD 10
105 #define STATUS_CMD 11
106 #define DIRECT_CMD 12
119 void MC_SixStep_ADC_Channel(uint32_t);
120 void MC_SixStep_Nucleo_Init(void);
121 void START_Ref_Generation(void);
122 void STOP_Ref_Generation(void);
123 void Set_Ref_Generation(uint16_t);
124 void START_DAC(void);
125 void STOP_DAC(void);
126 void SET_DAC_value(uint16_t);
127 void Bemf_delay_calc(void);
128 uint32_t Get_UART_Data(void);
129 void MC_SixStep_EnableInput_CH1_E_CH2_E_CH3_D(uint8_t,uint8_t,uint16_t);
130 void MC_SixStep_EnableInput_CH1_E_CH2_D_CH3_E(uint8_t,uint8_t,uint16_t);
131 void MC_SixStep_EnableInput_CH1_D_CH2_E_CH3_E(uint8_t,uint8_t,uint16_t);
132 void MC_SixStep_DisableInput_CH1_D_CH2_D_CH3_D(void);
133 void MC_SixStep_Start_PWM_driving(void);
134 void MC_SixStep_Stop_PWM_driving(void);
135 void MC_SixStep_HF_TIMx_SetDutyCycle_CH1(uint16_t);
136 void MC_SixStep_HF_TIMx_SetDutyCycle_CH2(uint16_t);
137 void MC_SixStep_HF_TIMx_SetDutyCycle_CH3(uint16_t);
138 void MC_SixStep_Current_Reference_Start(void);
139 void MC_SixStep_Current_Reference_Stop(void);
140 void MC_SixStep_Current_Reference_Setvalue(uint16_t);
148 #endif
X-NUCLEO-IHM08M1.h
This file provides the set of functions to manage the X-Nucleo board.
Get_UART_Data
uint32_t Get_UART_Data(void)
API function for STM32 instruction.


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f3xx_hal_conf.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32f3xx_hal_conf.h
Go to the documentation of this file.
1
35 /* Define to prevent recursive inclusion -------------------------------------*/
36 #ifndef __STM32F3xx_HAL_CONF_H
37 #define __STM32F3xx_HAL_CONF_H
38
39 #ifdef __cplusplus
40 extern "C" {
41 #endif
42
43 /* Exported types ------------------------------------------------------------*/
44 /* Exported constants --------------------------------------------------------*/
45
46 /* ########################## Module Selection ############################## */
51 #define HAL_MODULE_ENABLED
52 #define HAL_ADC_MODULE_ENABLED
53 //#define HAL_CAN_MODULE_ENABLED
54 //#define HAL_CEC_MODULE_ENABLED
55 //#define HAL_NAND_MODULE_ENABLED
56 //#define HAL_NOR_MODULE_ENABLED
57 //#define HAL_PCCARD_MODULE_ENABLED
58 //#define HAL_SRAM_MODULE_ENABLED
59 //#define HAL_HRTIM_MODULE_ENABLED
60 //#define HAL_OPAMP_MODULE_ENABLED
61 //#define HAL_SDADC_MODULE_ENABLED
62 //#define HAL_TSC_MODULE_ENABLED
63 //#define HAL_COMP_MODULE_ENABLED
64 //#define HAL_CRC_MODULE_ENABLED
65 //#define HAL_CRYP_MODULE_ENABLED
66 //#define HAL_DAC_MODULE_ENABLED
67 //#define HAL_I2C_MODULE_ENABLED
68 //#define HAL_I2S_MODULE_ENABLED
69 //#define HAL_IWDG_MODULE_ENABLED
70 //#define HAL_LCD_MODULE_ENABLED
71 //#define HAL_LPTIM_MODULE_ENABLED
72 //#define HAL_RNG_MODULE_ENABLED
73 //#define HAL_RTC_MODULE_ENABLED
74 //#define HAL_SPI_MODULE_ENABLED
75 #define HAL_TIM_MODULE_ENABLED
76 #define HAL_UART_MODULE_ENABLED
77 //#define HAL_USART_MODULE_ENABLED
78 //#define HAL_IRDA_MODULE_ENABLED
79 //#define HAL_SMARTCARD_MODULE_ENABLED
80 //#define HAL_SMBUS_MODULE_ENABLED
81 //#define HAL_WWDG_MODULE_ENABLED
82 //#define HAL_PCD_MODULE_ENABLED
83 #define HAL_GPIO_MODULE_ENABLED
84 #define HAL_DMA_MODULE_ENABLED
85 #define HAL_RCC_MODULE_ENABLED
86 #define HAL_FLASH_MODULE_ENABLED
87 #define HAL_PWR_MODULE_ENABLED
88 #define HAL_CORTEX_MODULE_ENABLED
89 /* ########################## HSE/HSI Values adaptation ##################### */
95 #if !defined (HSE_VALUE)
96 #define HSE_VALUE ((uint32_t)8000000)
97 #endif /* HSE_VALUE */
98
103 #if !defined (HSE_STARTUP_TIMEOUT)
104 #define HSE_STARTUP_TIMEOUT ((uint32_t)5000)
105 #endif /* HSE_STARTUP_TIMEOUT */
106
112 #if !defined (HSI_VALUE)
113 #define HSI_VALUE ((uint32_t)8000000)
114 #endif /* HSI_VALUE */
115
120 #if !defined (HSI_STARTUP_TIMEOUT)
121 #define HSI_STARTUP_TIMEOUT ((uint32_t)5000)
122 #endif /* HSI_STARTUP_TIMEOUT */
123
127 #if !defined (LSI_VALUE)
128 #define LSI_VALUE ((uint32_t)40000)
129 #endif /* LSI_VALUE */
135 #if !defined (LSE_VALUE)
136 #define LSE_VALUE ((uint32_t)32768)
137 #endif /* LSE_VALUE */
138
146 #if !defined (EXTERNAL_CLOCK_VALUE)
147 #define EXTERNAL_CLOCK_VALUE ((uint32_t)8000000)
148 #endif /* EXTERNAL_CLOCK_VALUE */
149
150 /* Tip: To avoid modifying this file each time you need to use different HSE,
151 === you can define the HSE value in your toolchain compiler preprocessor. */
152
153 /* ########################### System Configuration ######################### */
158 #define VDD_VALUE ((uint32_t)3300)
159 #define TICK_INT_PRIORITY ((uint32_t)2)
160 #define USE_RTOS 0
161 #define PREFETCH_ENABLE 1
162 #define INSTRUCTION_CACHE_ENABLE 0
163 #define DATA_CACHE_ENABLE 0
164
165 /* ########################## Assert Selection ############################## */
170 /* #define USE_FULL_ASSERT 1 */
171
172 /* Includes ------------------------------------------------------------------*/
177 #ifdef HAL_RCC_MODULE_ENABLED
178 #include "stm32f3xx_hal_rcc.h"
179 #endif /* HAL_RCC_MODULE_ENABLED */
180
181 #ifdef HAL_GPIO_MODULE_ENABLED
182 #include "stm32f3xx_hal_gpio.h"
183 #endif /* HAL_GPIO_MODULE_ENABLED */
184
185 #ifdef HAL_DMA_MODULE_ENABLED
186 #include "stm32f3xx_hal_dma.h"
187 #endif /* HAL_DMA_MODULE_ENABLED */
188
189 #ifdef HAL_CORTEX_MODULE_ENABLED
190 #include "stm32f3xx_hal_cortex.h"
191 #endif /* HAL_CORTEX_MODULE_ENABLED */
192
193 #ifdef HAL_ADC_MODULE_ENABLED
194 #include "stm32f3xx_hal_adc.h"
195 #endif /* HAL_ADC_MODULE_ENABLED */
196
197 #ifdef HAL_CAN_MODULE_ENABLED
198 #include "stm32f3xx_hal_can.h"
199 #endif /* HAL_CAN_MODULE_ENABLED */
200
201 #ifdef HAL_CEC_MODULE_ENABLED
202 #include "stm32f3xx_hal_cec.h"
203 #endif /* HAL_CEC_MODULE_ENABLED */
204
205 #ifdef HAL_COMP_MODULE_ENABLED
206 #include "stm32f3xx_hal_comp.h"
207 #endif /* HAL_COMP_MODULE_ENABLED */
208
209 #ifdef HAL_CRC_MODULE_ENABLED
210 #include "stm32f3xx_hal_crc.h"
211 #endif /* HAL_CRC_MODULE_ENABLED */
212
213 #ifdef HAL_DAC_MODULE_ENABLED
214 #include "stm32f3xx_hal_dac.h"
215 #endif /* HAL_DAC_MODULE_ENABLED */
216
217 #ifdef HAL_FLASH_MODULE_ENABLED
218 #include "stm32f3xx_hal_flash.h"
219 #endif /* HAL_FLASH_MODULE_ENABLED */
220
221 #ifdef HAL_SRAM_MODULE_ENABLED
222 #include "stm32f3xx_hal_sram.h"
223 #endif /* HAL_SRAM_MODULE_ENABLED */
224
225 #ifdef HAL_NOR_MODULE_ENABLED
226 #include "stm32f3xx_hal_nor.h"
227 #endif /* HAL_NOR_MODULE_ENABLED */
228
229 #ifdef HAL_NAND_MODULE_ENABLED
230 #include "stm32f3xx_hal_nand.h"
231 #endif /* HAL_NAND_MODULE_ENABLED */
232
233 #ifdef HAL_PCCARD_MODULE_ENABLED
234 #include "stm32f3xx_hal_pccard.h"
235 #endif /* HAL_PCCARD_MODULE_ENABLED */
236
237 #ifdef HAL_HRTIM_MODULE_ENABLED
238 #include "stm32f3xx_hal_hrtim.h"
239 #endif /* HAL_HRTIM_MODULE_ENABLED */
240
241 #ifdef HAL_I2C_MODULE_ENABLED
242 #include "stm32f3xx_hal_i2c.h"
243 #endif /* HAL_I2C_MODULE_ENABLED */
244
245 #ifdef HAL_I2S_MODULE_ENABLED
246 #include "stm32f3xx_hal_i2s.h"
247 #endif /* HAL_I2S_MODULE_ENABLED */
248
249 #ifdef HAL_IRDA_MODULE_ENABLED
250 #include "stm32f3xx_hal_irda.h"
251 #endif /* HAL_IRDA_MODULE_ENABLED */
252
253 #ifdef HAL_IWDG_MODULE_ENABLED
254 #include "stm32f3xx_hal_iwdg.h"
255 #endif /* HAL_IWDG_MODULE_ENABLED */
256
257 #ifdef HAL_OPAMP_MODULE_ENABLED
258 #include "stm32f3xx_hal_opamp.h"
259 #endif /* HAL_OPAMP_MODULE_ENABLED */
260
261 #ifdef HAL_PCD_MODULE_ENABLED
262 #include "stm32f3xx_hal_pcd.h"
263 #endif /* HAL_PCD_MODULE_ENABLED */
264
265 #ifdef HAL_PWR_MODULE_ENABLED
266 #include "stm32f3xx_hal_pwr.h"
267 #endif /* HAL_PWR_MODULE_ENABLED */
268
269 #ifdef HAL_RTC_MODULE_ENABLED
270 #include "stm32f3xx_hal_rtc.h"
271 #endif /* HAL_RTC_MODULE_ENABLED */
272
273 #ifdef HAL_SDADC_MODULE_ENABLED
274 #include "stm32f3xx_hal_sdadc.h"
275 #endif /* HAL_SDADC_MODULE_ENABLED */
276
277 #ifdef HAL_SMARTCARD_MODULE_ENABLED
278 #include "stm32f3xx_hal_smartcard.h"
279 #endif /* HAL_SMARTCARD_MODULE_ENABLED */
280
281 #ifdef HAL_SMBUS_MODULE_ENABLED
282 #include "stm32f3xx_hal_smbus.h"
283 #endif /* HAL_SMBUS_MODULE_ENABLED */
284
285 #ifdef HAL_SPI_MODULE_ENABLED
286 #include "stm32f3xx_hal_spi.h"
287 #endif /* HAL_SPI_MODULE_ENABLED */
288
289 #ifdef HAL_TIM_MODULE_ENABLED
290 #include "stm32f3xx_hal_tim.h"
291 #endif /* HAL_TIM_MODULE_ENABLED */
292
293 #ifdef HAL_TSC_MODULE_ENABLED
294 #include "stm32f3xx_hal_tsc.h"
295 #endif /* HAL_TSC_MODULE_ENABLED */
296
297 #ifdef HAL_UART_MODULE_ENABLED
298 #include "stm32f3xx_hal_uart.h"
299 #endif /* HAL_UART_MODULE_ENABLED */
300
301 #ifdef HAL_USART_MODULE_ENABLED
302 #include "stm32f3xx_hal_usart.h"
303 #endif /* HAL_USART_MODULE_ENABLED */
304
305 #ifdef HAL_WWDG_MODULE_ENABLED
306 #include "stm32f3xx_hal_wwdg.h"
307 #endif /* HAL_WWDG_MODULE_ENABLED */
308
309 /* Exported macro ------------------------------------------------------------*/
310 #ifdef USE_FULL_ASSERT
311
319 #define assert_param(expr) ((expr) ? (void)0 : assert_failed((uint8_t *)__FILE__, __LINE__))
320 /* Exported functions ------------------------------------------------------- */
321 void assert_failed(uint8_t* file, uint32_t line);
322 #else
323 #define assert_param(expr) ((void)0)
324 #endif /* USE_FULL_ASSERT */
325
326 #ifdef __cplusplus
327 }
328 #endif
329
330 #endif /* __STM32F3xx_HAL_CONF_H */
331
332 /************************ (C) COPYRIGHT STMicroelectronics *****END OF FILE****/


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f3xx_it.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32f3xx_it.h
Go to the documentation of this file.
1
34 /* Define to prevent recursive inclusion -------------------------------------*/
35 #ifndef __STM32F3xx_IT_H
36 #define __STM32F3xx_IT_H
37
38 #ifdef __cplusplus
39 extern "C" {
40 #endif
41
42 /* Includes ------------------------------------------------------------------*/
43 /* Exported types ------------------------------------------------------------*/
44 /* Exported constants --------------------------------------------------------*/
45 /* Exported macro ------------------------------------------------------------*/
46 /* Exported functions ------------------------------------------------------- */
47
48 void SysTick_Handler(void);
49 void ADC1_IRQHandler(void);
50 void TIM1_BRK_TIM15_IRQHandler(void);
51 void USART2_IRQHandler(void);
52 void EXTI15_10_IRQHandler(void);
53 void TIM6_DAC_IRQHandler(void);
54
55 #ifdef __cplusplus
56 }
57 #endif
58
59 #endif /* __STM32F3xx_IT_H */
60
61 /************************ (C) COPYRIGHT STMicroelectronics *****END OF FILE****/


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f4xx_hal_conf.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32f4xx_hal_conf.h
Go to the documentation of this file.
1
35 /* Define to prevent recursive inclusion -------------------------------------*/
36 #ifndef __STM32F4xx_HAL_CONF_H
37 #define __STM32F4xx_HAL_CONF_H
38
39 #ifdef __cplusplus
40 extern "C" {
41 #endif
42
43 /* Exported types ------------------------------------------------------------*/
44 /* Exported constants --------------------------------------------------------*/
45
46 /* ########################## Module Selection ############################## */
50 #define HAL_MODULE_ENABLED
51 #define HAL_ADC_MODULE_ENABLED
52 //#define HAL_CAN_MODULE_ENABLED
53 //#define HAL_CRC_MODULE_ENABLED
54 //#define HAL_CRYP_MODULE_ENABLED
55 //#define HAL_DAC_MODULE_ENABLED
56 //#define HAL_DCMI_MODULE_ENABLED
57 //#define HAL_DMA2D_MODULE_ENABLED
58 //#define HAL_ETH_MODULE_ENABLED
59 //#define HAL_NAND_MODULE_ENABLED
60 //#define HAL_NOR_MODULE_ENABLED
61 //#define HAL_PCCARD_MODULE_ENABLED
62 //#define HAL_SRAM_MODULE_ENABLED
63 //#define HAL_SDRAM_MODULE_ENABLED
64 //#define HAL_HASH_MODULE_ENABLED
65 //#define HAL_I2C_MODULE_ENABLED
66 //#define HAL_I2S_MODULE_ENABLED
67 //#define HAL_IWDG_MODULE_ENABLED
68 //#define HAL_LTDC_MODULE_ENABLED
69 //#define HAL_RNG_MODULE_ENABLED
70 //#define HAL_RTC_MODULE_ENABLED
71 //#define HAL_SAI_MODULE_ENABLED
72 //#define HAL_SD_MODULE_ENABLED
73 #define HAL_SPI_MODULE_ENABLED
74 #define HAL_TIM_MODULE_ENABLED
75 #define HAL_UART_MODULE_ENABLED
76 //#define HAL_USART_MODULE_ENABLED
77 //#define HAL_IRDA_MODULE_ENABLED
78 //#define HAL_SMARTCARD_MODULE_ENABLED
79 //#define HAL_WWDG_MODULE_ENABLED
80 //#define HAL_PCD_MODULE_ENABLED
81 //#define HAL_HCD_MODULE_ENABLED
82 #define HAL_GPIO_MODULE_ENABLED
83 #define HAL_DMA_MODULE_ENABLED
84 #define HAL_RCC_MODULE_ENABLED
85 #define HAL_FLASH_MODULE_ENABLED
86 #define HAL_PWR_MODULE_ENABLED
87 #define HAL_CORTEX_MODULE_ENABLED
88
89 /* ########################## HSE/HSI Values adaptation ##################### */
95 #if !defined (HSE_VALUE)
96 #define HSE_VALUE ((uint32_t)8000000)
97 #endif /* HSE_VALUE */
98
99 #if !defined (HSE_STARTUP_TIMEOUT)
100 #define HSE_STARTUP_TIMEOUT ((uint32_t)5000)
101 #endif /* HSE_STARTUP_TIMEOUT */
102
108 #if !defined (HSI_VALUE)
109 #define HSI_VALUE ((uint32_t)16000000)
110 #endif /* HSI_VALUE */
111
115 #if !defined (LSI_VALUE)
116 #define LSI_VALUE ((uint32_t)32000)
117 #endif /* LSI_VALUE */
123 #if !defined (LSE_VALUE)
124 #define LSE_VALUE ((uint32_t)32768)
125 #endif /* LSE_VALUE */
126
132 #if !defined (EXTERNAL_CLOCK_VALUE)
133 #define EXTERNAL_CLOCK_VALUE ((uint32_t)12288000)
134 #endif /* EXTERNAL_CLOCK_VALUE */
135
136 /* Tip: To avoid modifying this file each time you need to use different HSE,
137 === you can define the HSE value in your toolchain compiler preprocessor. */
138
139 /* ########################### System Configuration ######################### */
144 #define VDD_VALUE ((uint32_t)3300)
145 #define TICK_INT_PRIORITY ((uint32_t)2)
146 #define USE_RTOS 0
147 #define PREFETCH_ENABLE 1
148 #define INSTRUCTION_CACHE_ENABLE 1
149 #define DATA_CACHE_ENABLE 1
150
151 /* ########################## Assert Selection ############################## */
156 /* #define USE_FULL_ASSERT 1 */
157
158 /* ################## Ethernet peripheral configuration ##################### */
159
160 /* Section 1 : Ethernet peripheral configuration */
161
162 /* MAC ADDRESS: MAC_ADDR0:MAC_ADDR1:MAC_ADDR2:MAC_ADDR3:MAC_ADDR4:MAC_ADDR5 */
163 #define MAC_ADDR0 2
164 #define MAC_ADDR1 0
165 #define MAC_ADDR2 0
166 #define MAC_ADDR3 0
167 #define MAC_ADDR4 0
168 #define MAC_ADDR5 0
169
170 /* Definition of the Ethernet driver buffers size and count */
171 #define ETH_RX_BUF_SIZE ETH_MAX_PACKET_SIZE /* buffer size for receive */
172 #define ETH_TX_BUF_SIZE ETH_MAX_PACKET_SIZE /* buffer size for transmit */
173 #define ETH_RXBUFNB ((uint32_t)4) /* 4 Rx buffers of size ETH_RX_BUF_SIZE */
174 #define ETH_TXBUFNB ((uint32_t)4) /* 4 Tx buffers of size ETH_TX_BUF_SIZE */
175
176 /* Section 2: PHY configuration section */
177
178 /* DP83848 PHY Address*/
179 #define DP83848_PHY_ADDRESS 0x01
180 /* PHY Reset delay these values are based on a 1 ms Systick interrupt*/
181 #define PHY_RESET_DELAY ((uint32_t)0x000000FF)
182 /* PHY Configuration delay */
183 #define PHY_CONFIG_DELAY ((uint32_t)0x00000FFF)
184
185 #define PHY_READ_TO ((uint32_t)0x0000FFFF)
186 #define PHY_WRITE_TO ((uint32_t)0x0000FFFF)
187
188 /* Section 3: Common PHY Registers */
189
190 #define PHY_BCR ((uint16_t)0x00)
191 #define PHY_BSR ((uint16_t)0x01)
193 #define PHY_RESET ((uint16_t)0x8000)
194 #define PHY_LOOPBACK ((uint16_t)0x4000)
195 #define PHY_FULLDUPLEX_100M ((uint16_t)0x2100)
196 #define PHY_HALFDUPLEX_100M ((uint16_t)0x2000)
197 #define PHY_FULLDUPLEX_10M ((uint16_t)0x0100)
198 #define PHY_HALFDUPLEX_10M ((uint16_t)0x0000)
199 #define PHY_AUTONEGOTIATION ((uint16_t)0x1000)
200 #define PHY_RESTART_AUTONEGOTIATION ((uint16_t)0x0200)
201 #define PHY_POWERDOWN ((uint16_t)0x0800)
202 #define PHY_ISOLATE ((uint16_t)0x0400)
204 #define PHY_AUTONEGO_COMPLETE ((uint16_t)0x0020)
205 #define PHY_LINKED_STATUS ((uint16_t)0x0004)
206 #define PHY_JABBER_DETECTION ((uint16_t)0x0002)
208 /* Section 4: Extended PHY Registers */
209
210 #define PHY_SR ((uint16_t)0x10)
211 #define PHY_MICR ((uint16_t)0x11)
212 #define PHY_MISR ((uint16_t)0x12)
214 #define PHY_LINK_STATUS ((uint16_t)0x0001)
215 #define PHY_SPEED_STATUS ((uint16_t)0x0002)
216 #define PHY_DUPLEX_STATUS ((uint16_t)0x0004)
218 #define PHY_MICR_INT_EN ((uint16_t)0x0002)
219 #define PHY_MICR_INT_OE ((uint16_t)0x0001)
221 #define PHY_MISR_LINK_INT_EN ((uint16_t)0x0020)
222 #define PHY_LINK_INTERRUPT ((uint16_t)0x2000)
224 /* Includes ------------------------------------------------------------------*/
225
229 #ifdef HAL_RCC_MODULE_ENABLED
230 #include "stm32f4xx_hal_rcc.h"
231 #endif /* HAL_RCC_MODULE_ENABLED */
232
233 #ifdef HAL_GPIO_MODULE_ENABLED
234 #include "stm32f4xx_hal_gpio.h"
235 #endif /* HAL_GPIO_MODULE_ENABLED */
236
237 #ifdef HAL_DMA_MODULE_ENABLED
238 #include "stm32f4xx_hal_dma.h"
239 #endif /* HAL_DMA_MODULE_ENABLED */
240
241 #ifdef HAL_CORTEX_MODULE_ENABLED
242 #include "stm32f4xx_hal_cortex.h"
243 #endif /* HAL_CORTEX_MODULE_ENABLED */
244
245 #ifdef HAL_ADC_MODULE_ENABLED
246 #include "stm32f4xx_hal_adc.h"
247 #endif /* HAL_ADC_MODULE_ENABLED */
248
249 #ifdef HAL_CAN_MODULE_ENABLED
250 #include "stm32f4xx_hal_can.h"
251 #endif /* HAL_CAN_MODULE_ENABLED */
252
253 #ifdef HAL_CRC_MODULE_ENABLED
254 #include "stm32f4xx_hal_crc.h"
255 #endif /* HAL_CRC_MODULE_ENABLED */
256
257 #ifdef HAL_CRYP_MODULE_ENABLED
258 #include "stm32f4xx_hal_cryp.h"
259 #endif /* HAL_CRYP_MODULE_ENABLED */
260
261 #ifdef HAL_DMA2D_MODULE_ENABLED
262 #include "stm32f4xx_hal_dma2d.h"
263 #endif /* HAL_DMA2D_MODULE_ENABLED */
264
265 #ifdef HAL_DAC_MODULE_ENABLED
266 #include "stm32f4xx_hal_dac.h"
267 #endif /* HAL_DAC_MODULE_ENABLED */
268
269 #ifdef HAL_DCMI_MODULE_ENABLED
270 #include "stm32f4xx_hal_dcmi.h"
271 #endif /* HAL_DCMI_MODULE_ENABLED */
272
273 #ifdef HAL_ETH_MODULE_ENABLED
274 #include "stm32f4xx_hal_eth.h"
275 #endif /* HAL_ETH_MODULE_ENABLED */
276
277 #ifdef HAL_FLASH_MODULE_ENABLED
278 #include "stm32f4xx_hal_flash.h"
279 #endif /* HAL_FLASH_MODULE_ENABLED */
280
281 #ifdef HAL_SRAM_MODULE_ENABLED
282 #include "stm32f4xx_hal_sram.h"
283 #endif /* HAL_SRAM_MODULE_ENABLED */
284
285 #ifdef HAL_NOR_MODULE_ENABLED
286 #include "stm32f4xx_hal_nor.h"
287 #endif /* HAL_NOR_MODULE_ENABLED */
288
289 #ifdef HAL_NAND_MODULE_ENABLED
290 #include "stm32f4xx_hal_nand.h"
291 #endif /* HAL_NAND_MODULE_ENABLED */
292
293 #ifdef HAL_PCCARD_MODULE_ENABLED
294 #include "stm32f4xx_hal_pccard.h"
295 #endif /* HAL_PCCARD_MODULE_ENABLED */
296
297 #ifdef HAL_SDRAM_MODULE_ENABLED
298 #include "stm32f4xx_hal_sdram.h"
299 #endif /* HAL_SDRAM_MODULE_ENABLED */
300
301 #ifdef HAL_HASH_MODULE_ENABLED
302 #include "stm32f4xx_hal_hash.h"
303 #endif /* HAL_HASH_MODULE_ENABLED */
304
305 #ifdef HAL_I2C_MODULE_ENABLED
306 #include "stm32f4xx_hal_i2c.h"
307 #endif /* HAL_I2C_MODULE_ENABLED */
308
309 #ifdef HAL_I2S_MODULE_ENABLED
310 #include "stm32f4xx_hal_i2s.h"
311 #endif /* HAL_I2S_MODULE_ENABLED */
312
313 #ifdef HAL_IWDG_MODULE_ENABLED
314 #include "stm32f4xx_hal_iwdg.h"
315 #endif /* HAL_IWDG_MODULE_ENABLED */
316
317 #ifdef HAL_LTDC_MODULE_ENABLED
318 #include "stm32f4xx_hal_ltdc.h"
319 #endif /* HAL_LTDC_MODULE_ENABLED */
320
321 #ifdef HAL_PWR_MODULE_ENABLED
322 #include "stm32f4xx_hal_pwr.h"
323 #endif /* HAL_PWR_MODULE_ENABLED */
324
325 #ifdef HAL_RNG_MODULE_ENABLED
326 #include "stm32f4xx_hal_rng.h"
327 #endif /* HAL_RNG_MODULE_ENABLED */
328
329 #ifdef HAL_RTC_MODULE_ENABLED
330 #include "stm32f4xx_hal_rtc.h"
331 #endif /* HAL_RTC_MODULE_ENABLED */
332
333 #ifdef HAL_SAI_MODULE_ENABLED
334 #include "stm32f4xx_hal_sai.h"
335 #endif /* HAL_SAI_MODULE_ENABLED */
336
337 #ifdef HAL_SD_MODULE_ENABLED
338 #include "stm32f4xx_hal_sd.h"
339 #endif /* HAL_SD_MODULE_ENABLED */
340
341 #ifdef HAL_SPI_MODULE_ENABLED
342 #include "stm32f4xx_hal_spi.h"
343 #endif /* HAL_SPI_MODULE_ENABLED */
344
345 #ifdef HAL_TIM_MODULE_ENABLED
346 #include "stm32f4xx_hal_tim.h"
347 #endif /* HAL_TIM_MODULE_ENABLED */
348
349 #ifdef HAL_UART_MODULE_ENABLED
350 #include "stm32f4xx_hal_uart.h"
351 #endif /* HAL_UART_MODULE_ENABLED */
352
353 #ifdef HAL_USART_MODULE_ENABLED
354 #include "stm32f4xx_hal_usart.h"
355 #endif /* HAL_USART_MODULE_ENABLED */
356
357 #ifdef HAL_IRDA_MODULE_ENABLED
358 #include "stm32f4xx_hal_irda.h"
359 #endif /* HAL_IRDA_MODULE_ENABLED */
360
361 #ifdef HAL_SMARTCARD_MODULE_ENABLED
362 #include "stm32f4xx_hal_smartcard.h"
363 #endif /* HAL_SMARTCARD_MODULE_ENABLED */
364
365 #ifdef HAL_WWDG_MODULE_ENABLED
366 #include "stm32f4xx_hal_wwdg.h"
367 #endif /* HAL_WWDG_MODULE_ENABLED */
368
369 #ifdef HAL_PCD_MODULE_ENABLED
370 #include "stm32f4xx_hal_pcd.h"
371 #endif /* HAL_PCD_MODULE_ENABLED */
372
373 #ifdef HAL_HCD_MODULE_ENABLED
374 #include "stm32f4xx_hal_hcd.h"
375 #endif /* HAL_HCD_MODULE_ENABLED */
376
377 /* Exported macro ------------------------------------------------------------*/
378 #ifdef USE_FULL_ASSERT
379
387 #define assert_param(expr) ((expr) ? (void)0 : assert_failed((uint8_t *)__FILE__, __LINE__))
388 /* Exported functions ------------------------------------------------------- */
389 void assert_failed(uint8_t* file, uint32_t line);
390 #else
391 #define assert_param(expr) ((void)0)
392 #endif /* USE_FULL_ASSERT */
393
394 #ifdef __cplusplus
395 }
396 #endif
397
398 #endif /* __STM32F4xx_HAL_CONF_H */
399
400
401 /************************ (C) COPYRIGHT STMicroelectronics *****END OF FILE****/


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: C:/Users/giuseppe scuderi-sl/Desktop/MOTOR CONTROL/X-NUCLEO-IHM08M1/trunk/Firmware/STM32CubeExpansion_SPN8/Projects/Multi/Examples/MotorControl/Inc/stm32f4xx_it.h Source File

  • File List
  • File Members
  • Projects
  • Multi
  • Examples
  • MotorControl
  • Inc
stm32f4xx_it.h
Go to the documentation of this file.
1
35 /* Define to prevent recursive inclusion -------------------------------------*/
36 #ifndef __STM32F4xx_IT_H
37 #define __STM32F4xx_IT_H
38
39 #ifdef __cplusplus
40 extern "C" {
41 #endif
42
43 /* Includes ------------------------------------------------------------------*/
44 /* Exported types ------------------------------------------------------------*/
45 /* Exported constants --------------------------------------------------------*/
46 /* Exported macro ------------------------------------------------------------*/
47 /* Exported functions ------------------------------------------------------- */
48
49 void SysTick_Handler(void);
50 void ADC_IRQHandler(void);
51 void TIM1_BRK_TIM9_IRQHandler(void);
52 void TIM4_IRQHandler(void);
53 void USART2_IRQHandler(void);
54 void EXTI15_10_IRQHandler(void);
55
56 #ifdef __cplusplus
57 }
58 #endif
59
60 #endif /* __STM32F4xx_IT_H */
61
62 /************************ (C) COPYRIGHT STMicroelectronics *****END OF FILE****/


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Member List

  • Class List
  • Class Index
  • Class Members
CMD_T Member List

This is the complete list of members for CMD_T, including all inherited members.

name (defined in CMD_T) | CMD_T
pCmdFunc (defined in CMD_T) | CMD_T


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Member List

  • Class List
  • Class Index
  • Class Members
L6398_MotorDriver_TypeDef Member List

This is the complete list of members for L6398_MotorDriver_TypeDef, including all inherited members.

Current_Reference_Setvalue | L6398_MotorDriver_TypeDef
Current_Reference_Start | L6398_MotorDriver_TypeDef
Current_Reference_Stop | L6398_MotorDriver_TypeDef
DisableInput_CH1_D_CH2_D_CH3_D | L6398_MotorDriver_TypeDef
EnableInput_CH1_D_CH2_E_CH3_E | L6398_MotorDriver_TypeDef
EnableInput_CH1_E_CH2_D_CH3_E | L6398_MotorDriver_TypeDef
EnableInput_CH1_E_CH2_E_CH3_D | L6398_MotorDriver_TypeDef
HF_TIMx_SetDutyCycle_CH1 | L6398_MotorDriver_TypeDef
HF_TIMx_SetDutyCycle_CH2 | L6398_MotorDriver_TypeDef
HF_TIMx_SetDutyCycle_CH3 | L6398_MotorDriver_TypeDef
Start_PWM_driving | L6398_MotorDriver_TypeDef
Stop_PWM_driving | L6398_MotorDriver_TypeDef


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Member List

  • Class List
  • Class Index
  • Class Members
SIXSTEP_Base_InitTypeDef Member List

This is the complete list of members for SIXSTEP_Base_InitTypeDef, including all inherited members.

ACCEL | SIXSTEP_Base_InitTypeDef
ADC_BEMF_threshold_DOWN | SIXSTEP_Base_InitTypeDef
ADC_BEMF_threshold_UP | SIXSTEP_Base_InitTypeDef
ADC_BUFFER | SIXSTEP_Base_InitTypeDef
ADC_Regular_Buffer | SIXSTEP_Base_InitTypeDef
ADC_SEQ_CHANNEL | SIXSTEP_Base_InitTypeDef
ALIGN_OK | SIXSTEP_Base_InitTypeDef
ALIGNMENT | SIXSTEP_Base_InitTypeDef
ARR_OK | SIXSTEP_Base_InitTypeDef
ARR_value | SIXSTEP_Base_InitTypeDef
Bemf_delay_start | SIXSTEP_Base_InitTypeDef
BEMF_OK (defined in SIXSTEP_Base_InitTypeDef) | SIXSTEP_Base_InitTypeDef
bemf_state_1 | SIXSTEP_Base_InitTypeDef
bemf_state_2 | SIXSTEP_Base_InitTypeDef
bemf_state_3 | SIXSTEP_Base_InitTypeDef
bemf_state_4 | SIXSTEP_Base_InitTypeDef
bemf_state_5 | SIXSTEP_Base_InitTypeDef
bemf_state_6 | SIXSTEP_Base_InitTypeDef
BEMF_Tdown_count | SIXSTEP_Base_InitTypeDef
Button_ready (defined in SIXSTEP_Base_InitTypeDef) | SIXSTEP_Base_InitTypeDef
CL_READY (defined in SIXSTEP_Base_InitTypeDef) | SIXSTEP_Base_InitTypeDef
CMD | SIXSTEP_Base_InitTypeDef
Current_Reference | SIXSTEP_Base_InitTypeDef
CurrentRegular_BEMF_ch | SIXSTEP_Base_InitTypeDef
CW_CCW | SIXSTEP_Base_InitTypeDef
demagn_counter | SIXSTEP_Base_InitTypeDef
demagn_value | SIXSTEP_Base_InitTypeDef
filter_depth | SIXSTEP_Base_InitTypeDef
HF_TIMx_ARR | SIXSTEP_Base_InitTypeDef
HF_TIMx_CCR | SIXSTEP_Base_InitTypeDef
HF_TIMx_PSC | SIXSTEP_Base_InitTypeDef
Integral_Term_sum | SIXSTEP_Base_InitTypeDef
Ireference | SIXSTEP_Base_InitTypeDef
IREFERENCE | SIXSTEP_Base_InitTypeDef
KI | SIXSTEP_Base_InitTypeDef
KP | SIXSTEP_Base_InitTypeDef
LF_TIMx_ARR | SIXSTEP_Base_InitTypeDef
LF_TIMx_PSC | SIXSTEP_Base_InitTypeDef
MediumFrequencyTask_flag | SIXSTEP_Base_InitTypeDef
numberofitemArr | SIXSTEP_Base_InitTypeDef
NUMPOLESPAIRS | SIXSTEP_Base_InitTypeDef
Potentiometer | SIXSTEP_Base_InitTypeDef
prescaler_value | SIXSTEP_Base_InitTypeDef
pulse_value | SIXSTEP_Base_InitTypeDef
Ramp_Start | SIXSTEP_Base_InitTypeDef
Regular_channel | SIXSTEP_Base_InitTypeDef
RUN_Motor | SIXSTEP_Base_InitTypeDef
speed_fdbk | SIXSTEP_Base_InitTypeDef
speed_fdbk_filtered | SIXSTEP_Base_InitTypeDef
Speed_Loop_Time | SIXSTEP_Base_InitTypeDef
Speed_Ref_filtered | SIXSTEP_Base_InitTypeDef
Speed_target_ramp | SIXSTEP_Base_InitTypeDef
Speed_target_time | SIXSTEP_Base_InitTypeDef
SPEED_VALIDATED | SIXSTEP_Base_InitTypeDef
STATUS | SIXSTEP_Base_InitTypeDef
status_prev | SIXSTEP_Base_InitTypeDef
step_position | SIXSTEP_Base_InitTypeDef
SYSCLK_frequency | SIXSTEP_Base_InitTypeDef
Uart_cmd_to_set (defined in SIXSTEP_Base_InitTypeDef) | SIXSTEP_Base_InitTypeDef
Uart_value_to_set (defined in SIXSTEP_Base_InitTypeDef) | SIXSTEP_Base_InitTypeDef
VALIDATION_OK | SIXSTEP_Base_InitTypeDef
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1


X-CUBE-SPN8 for X-NUCLEO-IHM08M1: Member List

  • Class List
  • Class Index
  • Class Members
SIXSTEP_PI_PARAM_InitTypeDef_t Member List

This is the complete list of members for SIXSTEP_PI_PARAM_InitTypeDef_t, including all inherited members.

Ki_Gain | SIXSTEP_PI_PARAM_InitTypeDef_t
Kp_Gain | SIXSTEP_PI_PARAM_InitTypeDef_t
Lower_Limit_Output | SIXSTEP_PI_PARAM_InitTypeDef_t
Max_PID_Output | SIXSTEP_PI_PARAM_InitTypeDef_t
Min_PID_Output | SIXSTEP_PI_PARAM_InitTypeDef_t
Reference | SIXSTEP_PI_PARAM_InitTypeDef_t
Upper_Limit_Output | SIXSTEP_PI_PARAM_InitTypeDef_t
Generated on Wed Oct 28 2015 17:58:56 for X-CUBE-SPN8 for X-NUCLEO-IHM08M1 by doxygen 1.8.9.1