MFDeploy

.NET Micro Framework Platform SDK
MFDeploy
CollapseAll image

The MFDeploy tool helps you copy Microsoft® .NET Micro Framework applications to your hardware devices. MFDeploy makes it easy for you to deploy or upgrade the firmware you are developing to your hardware. To learn more about the MFDeploy tool, use the following links:

In This Section

Legal Notice
This section provides a list of trademarks or registered trademarks of Microsoft® Corporation that appear in this documentation.
MFDeploy Overviews
This documentation presents an overview of the MFDeploy tool.
MFDeploy References
The MFDeploy class library contains the functionality you need to deploy code to .NET Micro Framework devices namespaces from within your own applications.

© 2007 Microsoft Corporation. All rights reserved.
Send feedback to mfdocfb@microsoft.com.
Version: 2007.09.12.14h58m


Legal Notice

Legal Notice

The following trademarks or registered trademarks of Microsoft Corporation are referenced in this documentation:

  • Microsoft ®
  • .NET
  • Visual Studio®
  • Windows®
  • Windows Server®
  • Windows Vista™


MFDeploy Overviews

MFDeploy Overviews

This documentation presents an overview of the MFDeploy tool. The MFDeploy tool copies applications to .NET Micro Framework devices. Its primary use is for production environments.

In addition to deploying applications to devices, MFDeploy enables you to test a device to see if it is responsive, create a standard application deployment that can be replicated on multiple devices, manage device keys for application signing, and perform some debugging tasks.

In This Section

Selecting and Managing Devices
This overview explains how to select a device and perform common device management tasks.
Managing Image Files
This overview explains how to select an image file and deploy it to your hardware device.
Deploying Applications
This section explains how to create and sign an application deployment.
Managing Device Keys
This section explains tells how to create and update public and private keys that are used for signing code on your devices.
Configuring Your Device Connection
This section describes how to use MFDeploy to configure your device's USB or network connection.
Selecting the Default Port
This section describes how to set the default serial port that MFDeploy uses for connecting with a device.
Invoking MFDeploy from the Command Line
This overview describes the options available for invoking MFDeploy from the command line.
Accomplishing Common Tasks
This overview explains and demonstrates the most common tasks that MFDeploy can accomplish.
Customizing MFDeploy
This overview explains how to use the application programming interface (API) to develop your own customized versions of MFDeploy.


Selecting and Managing Devices

Selecting and Managing Devices

Selecting a Device

You can select the device to which your Microsoft® .NET Micro Framework application will be deployed by selecting the port to which the device is connected using the controls in the Device panel in the MFDeploy main window.

Begin by choosing the type of port to which your device is connected using the leftmost pull-down list in the Device panel. MFDeploy currently supports serial, USB, and TCP/IP connections.

After you have selected the port type, choose the specific port your device is connected to. If your device is on a serial port, the second pull-down list displays a list of the available serial ports. If you selected a USB or TCP/IP port, MFDeploy displays all the devices connected to those types of ports. If there are no USB devices connected, the list is empty.

Testing the State of the Device

To check to see if the selected device is responding, click the Ping button in the Device panel in the MFDeploy main window. MFDeploy displays the response in the output panel. If the selected device is not responding, MFDeploy displays the following message:

Pinging... Error: No response from device

If the .NET Micro Framework common language runtime (CLR) is functional and running, MFDeploy prints the following output:

Pinging... TinyCLR

In rare cases in which the device is functional but the CLR is not, MFDeploy gives the following response:

Pinging... TinyBooter

This situation usually occurs only if some problem in the device has completely erased or garbled both your application and the CLR.

Erasing the Deployment Sector

It is best to erase the deployment area of the flash memory before you deploy new firmware to your device, ensuring that no artifacts from previous versions remain. To do this, click the Erase button in the MFDeploy Device panel. The procedure erases only the programmer-installed managed application and any associated data.


Managing Image Files

Managing Image Files

To deploy an image file to your device, you must first create the image in Motorola SREC (.hex) format containing the .NET Micro Framework or libraries that your application needs. You can obtain image files from Microsoft or from your hardware platform vendor. You can install multiple image files on a device.

Choosing an Image File

The names of image files you have recently deployed to a device appear in the drop-down list in the Image File panel in MFDeploy for quick access. If you are deploying the image file for the first time, use the Browse button to navigate to it.

Copying an Image File to Your Device

After selecting an image file, deploy it to the device by clicking the Deploy button.

It is possible to copy multiple image files to a device by selecting multiple file names. If you do, the file names appear in the Image File box separated by semicolons. Click the Deploy button when you are ready for the image files to be copied to the device.


Deploying Applications

Deploying Applications

MFDeploy enables you to create a standard deployment that you can then replicate to multiple devices. A standard deployment contains a copy of all of a device's deployment sectors. You have the option of signing the code you deploy to your device, which is highly advisable in a production environment. The easiest way to sign code is to create a key file containing a public and a private key. For information on creating key files, see Managing Device Keys.

Use the following procedure to create a standard deployment.

  1. Use Visual Studio to create and deploy the application into the deployment sectors of a device.
  2. When the deployment sectors are exactly as you want them to be, run MFDeploy, select Target from the main menu, and then choose Application Deployment.
  3. Click Create Application Deployment.
  4. In the dialog box that appears, specify the name of your deployment file.
  5. If you want to digitally sign the deployment file and you have previously stored the key in a file, click the button with the ellipsis to navigate to the key file. Otherwise, click the Create Key button to create a key pair.
  6. Click Ok.

If you want to sign an existing deployment file, use the steps in the following procedure.

  1. Select Target from the main MFDeploy menu, and then choose Application Deployment.
  2. Click Create Application Deployment.
  3. In the dialog box that appears, specify the name of your deployment file.
  4. If you have previously stored the key in a file, click the button with the ellipsis to navigate to the key file. Otherwise, click the Create Key button to create a key pair.
  5. Click Ok.

The deployment file is now ready for use. You can use MFDeploy to copy it to devices that are identical to the device for which it was created.


Managing Device Keys

Managing Device Keys

It is often desirable for manufacturers to sign code that they deploy to devices. This helps prevent others from placing unauthorized code on the device after it has been released for sale on the open market. MFDeploy enables you to create a pair of keys containing a public and a private key. You can also use it to update the keys on a device.

You can store up to two keys on the device. The first key is for the device's firmware. The second is for signing your application. If a hardware manufacturer signs its firmware, the hardware's firmware can only be updated by those who provide the public key that matches the firmware's private key. If there is no key on the device, anyone can update its firmware.

The second key enables device manufacturers, or their authorized partners and customers, to add signed code to the device without updating all of the device's firmware. If the second key is not used, anyone can add code to the device.

Use the following procedure to create a key pair.

  1. Select Target from the main MFDeploy menu, and then choose Manage Device Keys.
  2. Click Create Key Pair.
  3. MFDeploy generates the keys and displays a dialog box that enables you to save the keys in a text file. Navigate to the folder in which you would like to store your key file and specify a file name. The default extension for the key file is .key.
  4. Click Save.

To replace a key with a new key, use the steps in the following procedure.

  1. Select Target from the main MFDeploy menu, and then choose Manage Device Keys.
  2. Click Update Device Keys.
  3. In the dialog box that appears, enter the new key into the New Key field. If you already saved a key pair into a file, use the ellipsis button immediately to the right of the New Key field to navigate to and select the key file.

  4. Enter the old key into the Old Key field. If you have stored the old key in a file, click the ellipsis immediately to the right of the Old Key field to navigate to the key file.

    Note
    You must provide the old key to be able to update the key on the device only if the device already has a key for the selected key index.
  5. Click OK.


Configuring Your Device Connection

Configuring Your Device Connection

USB Configuration

You can set the USB name for your device using the following procedure.

  1. From the main menu of MFDeploy, choose Target and then Configuration.
  2. Click USB Name.
  3. In the dialog box that appears, enter the name for the device. This name is displayed when the device is connected to a USB port.

Network Configuration

To configure your device's network connection, do the following.

  1. From the main menu of MFDeploy, choose Target and then Configuration.
  2. Click Network.

  3. The dialog box shown below appears.

    Change the network configuration settings by entering the new information into the dialog box and then clicking the Update button.

Note
Updating a device's network configuration requires the device to be rebooted.


Selecting the Default Port

Selecting the Default Port

To select a default serial port to be used to communicate with the bootstrap loader installed on the device, click Options on the MFDeploy main menu, then click Bootloader Serial Port. MFDeploy displays a list of available serial ports. Click the one that you want to use as the default port.


Invoking MFDeploy from the Command Line

Invoking MFDeploy from the Command Line

This overview describes the options available for invoking MFDeploy from the command line.

Usage

To invoke MFDeploy from the command prompt, use the following form:

MFDeploy [COMMAND[:CMD_ARGS]] [/I:INTERFACE[:INTEFACE_ARGS]]

Commands

MFDeploy supports the commands listed in the following table.

Command | Description
Erase | Erases the user application and user data sectors.
Deploy:<image file>[;<image file>]

Deploys one or more image files.
Ping

Determines whether a particular device is in a state that allows communication. MFDeploy displays one of the following :

Pinging... Error: No response from device
Pinging... TinyCLR
Pinging... TinyBooter
Reboot[:Warm] | Reboots the device if the Warm option is not specified. Reboots only the CLR if the Warm option is specified.
List | Displays a list of all available serial and USB ports.
Help | Displays help information.

Interface

MFDeploy supports the following ports for interfacing with your hardware device.

Interface | Description
Serial:<port_num> | Selects the serial port (COM port). The communication rate is automatically set to 115200 bps.
USB:<usb_name> | Selects a USB port. Use the List command to see the names of the available USB ports.
TCPIP:<ip_addr> | Selects the TCP/IP interface.

Examples

>MFDeploy.exe Ping /i:TCPIP:10.52.32.196
Pinging…TinyCLR

>MFDeploy.exe Erase /i:TCPIP:10.52.32.196

>MFdeploy.exe Deploy:c:\tinyclr_compressed.hex;c:\ER_CONFIG.hex /i:TCPIP:10.52.32.196 /i:Serial:1:115200


Accomplishing Common Tasks

Accomplishing Common Tasks

This overview explains and demonstrates the most common tasks that MFDeploy can accomplish.

Upgrading Firmware

Follow these steps to upgrade or update a device's firmware.

  1. Connect your device to your computer.
  2. Run MFDeploy.
  3. Choose the device's port type.

  4. Choose the device's port.

    Note
    The default address for a TCP/IP port is 10.52.32.196.

  5. Browse for the SREC (.hex) object file you want to deploy, or select a file in the pull-down list. Typically, the file name will be one of the names listed in the following table.

    File Name | Comments
    Tinyclr_compressed.hex | Contains the Microsoft® .NET Micro Framework common language runtime (CLR). The file ER_CONFIG.hex must always be included with tinyclr_compressed.hex.
    ER_CONFIG.hex | Contains the .NET Micro Framework configuration sector. ER_CONFIG.hex cannot be delpoyed by itself. You must also include the file Tinyclr_compressed.hex with ER_CONFIG.hex.
    TinyBooter_image.hex | Contains the bootstrap loader, which is needed to boot the device.
  6. Click the Deploy button.

Deploying a File When the CLR Is Unresponsive

If the code on the device becomes corrupted, the CLR becomes unresponsive. Follow these steps to upload and re-deploy your image file.

Note
You can check to see if the CLR is responding by clicking the Ping button.
  1. Set the TinyBooter port.
  2. Select the image file or files.

  3. Activate the bootstrap loader (TinyBooter). The method for doing this is platform-specific. For details, see your hardware platform's documentation.

    Examples:

    Freescale
    Press and hold the UP ARROW and DOWN ARROW keys at the same time while rebooting the device.
    ConnectME
    Connect using the serial interface, reboot the board, and click the Ping button in MFDeploy repeatedly until the bootstrap loader (TinyBooter) responds.
Note
You can also erase deployment sectors and configure network settings while the bootstrap loader is active.

Configuring Your Firewall for MFDeploy

MFDeploy requires the use of some specific multicast IP addresses and ports. By default, the installation process automatically makes these addresses and ports available. However, it is possible that your firewall prevents this. In such cases, MFDeploy will not function properly on your computer.

If your firewall blocks MFDeploy's access to the addresses and ports it needs, you must manually configure your firewall to allow access. For details on how to do this, see your firewall's documentation. The addresses and ports that MFDeploy requires are as follows.

  • IP Receive: 234.102.98.44
  • IP Send: 234.102.98.45
  • IP Port: 26001
  • UDP Protocol


Customizing MFDeploy

Customizing MFDeploy

MFDeploy provides an API that enables you to develop your own program that takes advantage of its functionality. The MFDeploy tool offers this ability so that you can create deployment programs that are specific to the needs of your production environment. In particular, you can write your own deployment programs to automate many deployment tasks. The reference section of this document presents a complete description of the MFDeploy API.

When writing a deployment application with the MFDeploy API, you begin with the MFDeploy and MFDevice classes. The MFDeploy class enables your program to discover and connect to Micro Framework devices. The MFDevice class lets your program connect directly to TinyBooter, which resides on the Micro Framework device. It also gives access to much of the MFDeploy tool's primary functionality. Specifically, it provides methods for deploying and erasing applications, forcing a reboot, executing code on the device, and pinging a device to ensure that it's still operational. Use the MFApplicationDeployment and MFApplicationDeploymentData classes to hold the NET Micro Framework application data to be deployed.

MFDeploy supports connections to devices over serial, TCP/IP, and USB ports. Therefore, its API provides classes to access that functionality. In particular, applications use the MFSerialPort, MFTcpIpPort, MFUsbPort, and MFUsbConfiguration classes to create objects that access and control communications ports.

The MFDeploy tool provides you with the capability to manually adjust a device's network connection settings. You can accomplish the same thing programmatically with the methods of the MFNetworkConfiguration class.

Your program can sign the code it deploys to devices. Use the KeyPair class and the PublicKeyUpdateInfo structure to store signature key information. Use the methods of the MFKeyConfig class to create key pairs and update the key information on the device.


MFDeploy References

MFDeploy References

The MFDeploy class library contains the functionality you need to deploy code to .NET Micro Framework devices namespaces from within your own applications.

In This Section

Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace
This namespace provides the ability to deploy .NET Micro Framework applications to a device.


Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace

Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace
CollapseAll image

This namespace provides the ability to deploy .NET Micro Framework applications to a device.

Expand image Classes

 | Name | Description
Public Class | KeyPair | Contains a key pair consisting of a public and a private key.
Public Class | MFApplicationDeployment | Enables a device's deployment sectors to persist for transfer to other devices.
Public Class | MFApplicationDeploymentData | Contains data stored in a device's deployment sectors.
Public Class | MFConfigHelper | Enables desktop applications to programmatically load and save firmware configurations.
Public Class | MFDeploy | Contains methods for enumerating, addressing, and connecting to .NET Micro Framework devices.
Public Class | MFDevice | Contains methods for deploying, erasing, and executing code on .NET Micro Framework devices.
Public Class | MFDeviceInUseException | An exception thrown when the device targeted for a deployment is busy.
Public Class | MFDeviceNoResponseException | An exception thrown when the device targeted for a deployment is not responding.
Public Class | MFDeviceUnknownDeviceException | An exception thrown when a deployment is attempted to a device that does not exist or cannot be found.
Public Class | MFInvalidFileFormatException | An exception thrown when the file being deployed to a device has an invalid format.
Public Class | MFKeyConfig | Enables applications to perform signature operations and update the public keys on the device.
Public Class | MFNetworkConfiguration | Contains methods for updating the network configuration of the device.
Public Class | MFPortDefinition | Represents port addressing information for a .NET Micro Framework device.
Public Class | MFSerialPort | A class representing a serial port that can be used to deploy Micro Framework applications to a device.
Public Class | MFSignatureFailureException | An exception thrown when the file being deployed to a device does not have a valid signature.
Public Class | MFTcpIpPort | A class representing a TCP/IP network address that can be used to deploy Micro Framework applications to a device.
Public Class | MFUsbConfiguration | Contains methods for updating the USB name of a specific USB device.
Public Class | MFUsbPort | A class representing a USB port that can be used to deploy Micro Framework applications to a device.
Public Class | MFUserExitException | An exception thrown when the user exits a deployment.

Expand image Structures

 | Name | Description
Public Structure | PublicKeyUpdateInfo | Contains information used to update a public key.

Expand image Enumerations

 | Name | Description
Public Enumeration | EraseOptions | Defines values to indicate which regions of the flash memory should be erased.
Public Enumeration | PingConnectionType | Defines values that indicate what .NET Micro Framework components on a device are responding to connection attempts.
Public Enumeration | PublicKeyUpdateInfo.KeyIndex | Defines the transport types for device connections.
Public Enumeration | TransportType | Defines the transport types for device connections.


EraseOptions Enumeration

EraseOptions Enumeration
See Also
CollapseAll image

Defines values to indicate which regions of the flash memory should be erased.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
[System.Flags]
public enum EraseOptions

Expand image Members

Member name | Description
Deployment | Indicates that the deployment area of the flash memory should be erased.
UserStorage | Indicates that the user storage areas of the flash memory should be erased.
Logging | Indicates that the log storage area of the flash memory should be erased.

Expand image Remarks

There are two user storage areas in the flash memory device. UserStorage refers to both of these areas.

The values of this enumeration may be combined using a bitwise OR operation, as in EraseOptions.Deployment | EraseOptions.UserStorage, to specify more than one option.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


KeyPair Class

KeyPair Class
See Also Members
CollapseAll image

Contains a key pair consisting of a public and a private key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class KeyPair

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

KeyPair Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


KeyPair Members

KeyPair Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the KeyPair type.

Expand image Public Constructors

 | Name | Description
Public Method | KeyPair | Initializes a new instance of the KeyPair class.

Expand image Public Fields

 | Name | Description
Public Field | PrivateKey | Holds a private key.
Public Field | PublicKey | Holds a public key.

Expand image See Also

KeyPair Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


KeyPair Constructor

KeyPair Constructor

Initializes a new instance of the KeyPair class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public KeyPair ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

KeyPair Class


KeyPair Fields

KeyPair Fields

Expand image Public Fields

 | Name | Description
Public Field | PrivateKey | Holds a private key.
Public Field | PublicKey | Holds a public key.

Expand image See Also

Reference

KeyPair Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


KeyPair.PrivateKey Field

KeyPair.PrivateKey Field

Holds a private key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] PrivateKey

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

KeyPair Class
KeyPair Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


KeyPair.PublicKey Field

KeyPair.PublicKey Field

Holds a public key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] PublicKey

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

KeyPair Class
KeyPair Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeployment Class

MFApplicationDeployment Class
See Also Members
CollapseAll image

Enables a device's deployment sectors to persist for transfer to other devices.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFApplicationDeployment

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

MFApplicationDeployment Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeployment Members

MFApplicationDeployment Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the MFApplicationDeployment type.

Expand image Public Constructors

 | Name | Description
Public Method | MFApplicationDeployment | Initializes a new instance of the MFApplicationDeployment class.

Expand image Public Methods

 | Name | Description
Public Method | CreateDeploymentData | Creates an MFApplicationDeploymentData object that stores the deployment data.

Expand image See Also

MFApplicationDeployment Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeployment Constructor

MFApplicationDeployment Constructor

Initializes a new instance of the MFApplicationDeployment class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFApplicationDeployment (
         MFDevice device
)

Parameters

device
Holds the device to which the application is deployed.

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

MFApplicationDeployment Class


MFApplicationDeployment Methods

MFApplicationDeployment Methods

Expand image Public Methods

 | Name | Description
Public Method | CreateDeploymentData | Creates an MFApplicationDeploymentData object that stores the deployment data.

Expand image See Also

Reference

MFApplicationDeployment Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeployment.CreateDeploymentData Method

MFApplicationDeployment.CreateDeploymentData Method

Creates an MFApplicationDeploymentData object that stores the deployment data.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFApplicationDeploymentData CreateDeploymentData ()

Return Value

The deployment sector data.

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFApplicationDeployment Class
MFApplicationDeployment Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeploymentData Class

MFApplicationDeploymentData Class
See Also Members
CollapseAll image

Contains data stored in a device's deployment sectors.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFApplicationDeploymentData

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

MFApplicationDeploymentData Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeploymentData Members

MFApplicationDeploymentData Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the MFApplicationDeploymentData type.

Expand image Public Constructors

 | Name | Description
Public Method | MFApplicationDeploymentData | Initializes a new instance of the MFApplicationDeploymentData class.

Expand image Public Fields

 | Name | Description
Public Field | BinaryData | Contains binary data stored in the device's deployment sector.
Public Field | HexData | Contains hexadecimal data stored in the device's deployment sector.

Expand image See Also

MFApplicationDeploymentData Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeploymentData Constructor

MFApplicationDeploymentData Constructor

Initializes a new instance of the MFApplicationDeploymentData class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFApplicationDeploymentData ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

MFApplicationDeploymentData Class


MFApplicationDeploymentData Fields

MFApplicationDeploymentData Fields

Expand image Public Fields

 | Name | Description
Public Field | BinaryData | Contains binary data stored in the device's deployment sector.
Public Field | HexData | Contains hexadecimal data stored in the device's deployment sector.

Expand image See Also

Reference

MFApplicationDeploymentData Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeploymentData.BinaryData Field

MFApplicationDeploymentData.BinaryData Field

Contains binary data stored in the device's deployment sector.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] BinaryData

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MFApplicationDeploymentData Class
MFApplicationDeploymentData Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFApplicationDeploymentData.HexData Field

MFApplicationDeploymentData.HexData Field

Contains hexadecimal data stored in the device's deployment sector.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] HexData

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MFApplicationDeploymentData Class
MFApplicationDeploymentData Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper Class

MFConfigHelper Class
See Also Members
CollapseAll image

Enables desktop applications to programmatically load and save firmware configurations.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFConfigHelper : System.IDisposable

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper Members

MFConfigHelper Members
See Also Constructors Destructors Methods Properties
CollapseAll image

The following tables list the members exposed by the MFConfigHelper type.

Expand image Public Constructors

 | Name | Description
Public Method | MFConfigHelper | Initializes a new instance of the MFConfigHelper class.

Expand image Public Destructors

 | Name | Description
Public Method | ~MFConfigHelper | Releases all resources held by this object.

Expand image Public Properties

 | Name | Description
Public Property | IsDeploymentKeyLocked | A Boolean value indicating whether the deployment sector security key has been programmed.
Public Property | IsFirmwareKeyLocked | A Boolean value indicating whether the firmware security key has been programmed.
Public Property | IsValidConfig | A Boolean value indicating whether the device configuration version matches this version of MFDeploy.
Public Property | MaintainConnection | A Boolean value indicating whether MFDeploy should maintain a connection to TinyBooter.

Expand image Public Methods

 | Name | Description
Public Method | Dispose | Cleans up this object by releasing.
Public Method | FindConfig | Searches the dynamic portion of the configuration sector for the given configuration.
 | UnmarshalData | Unmarshalls data into an object of a specified type.
Public Method | UpdatePublicKey | Updates the given public signature key.
Public Method | WriteConfig | Updates or creates a device configuration.

Expand image See Also

MFConfigHelper Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper Constructor

MFConfigHelper Constructor

Initializes a new instance of the MFConfigHelper class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFConfigHelper ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

MFConfigHelper


~MFConfigHelper Destructor

~MFConfigHelper Destructor

Releases all resources held by this object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public ~MFConfigHelper ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members


MFConfigHelper Methods

MFConfigHelper Methods

Expand image Public Methods

 | Name | Description
Public Method | Dispose | Cleans up this object by releasing.
Public Method | FindConfig | Searches the dynamic portion of the configuration sector for the given configuration.
 | UnmarshalData | Unmarshalls data into an object of a specified type.
Public Method | UpdatePublicKey | Updates the given public signature key.
Public Method | WriteConfig | Updates or creates a device configuration.

Expand image See Also

Reference

MFConfigHelper Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper.Dispose Method

MFConfigHelper.Dispose Method

Cleans up this object by releasing.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Dispose ()

Expand image Remarks

This method calls GC.SuppressFinalize on this object to remove it from the finalization queue.

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper.FindConfig Method

MFConfigHelper.FindConfig Method

Searches the dynamic portion of the configuration sector for the given configuration.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte [] FindConfig (
         string configName
)

Parameters

configName
Holds the name of the configuration.

Return Value

The byte array of the configuration if successful, or null if not.

Expand image Remarks

The byte array returned by this method includes the HAL_CONFIG_BLOCK header.

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper.UnmarshalData Method

MFConfigHelper.UnmarshalData Method

Unmarshalls data into an object of a specified type.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public static object UnmarshalData (
         byte[] data,
         System.Type type
)

Parameters

data
Holds the data to be unmarshalled into an object.
type
Specifies the type of the object where the unmarshalled data is stored.

Return Value

An object containing the unmarshalled data

Expand image Remarks

This method enables plug-in libraries to unmarshal configuration data from a byte array to an object. It does not work unless the type specified in the type parameter contains only value types or fixed-size buffers of value types.

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper.UpdatePublicKey Method

MFConfigHelper.UpdatePublicKey Method

Updates the given public signature key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool UpdatePublicKey (
         PublicKeyUpdateInfo newKeyInfo
)

Parameters

newKeyInfo
Contains the information used to update the key, including the new key, the new key signature (if the key has already been set), and the key index.

Return Value

true if successful, otherwise false.

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper.WriteConfig Method

MFConfigHelper.WriteConfig Method

Updates or creates a device configuration.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void WriteConfig (
         string configName,
         IHAL_CONFIG_BASE config
)

Parameters

configName
Contains the unique, case-sensitive name of the configuration.
config
Holds the configuration object to be written.

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

Reference

MFConfigHelper Class
MFConfigHelper Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFConfigHelper Properties

MFConfigHelper Properties

Expand image Public Properties

 | Name | Description
Public Property | IsDeploymentKeyLocked | A Boolean value indicating whether the deployment sector security key has been programmed.
Public Property | IsFirmwareKeyLocked | A Boolean value indicating whether the firmware security key has been programmed.
Public Property | IsValidConfig | A Boolean value indicating whether the device configuration version matches this version of MFDeploy.
Public Property | MaintainConnection | A Boolean value indicating whether MFDeploy should maintain a connection to TinyBooter.

Expand image See Also

MFConfigHelper Members


MFConfigHelper.IsDeploymentKeyLocked Property

MFConfigHelper.IsDeploymentKeyLocked Property

A Boolean value indicating whether the deployment sector security key has been programmed.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool IsDeploymentKeyLocked { get; }

Property Value

true if the key has been programmed, or false if not.

Expand image Remarks

If the deployment sector security key has been programmed, the key is locked. You must reprogram it to change it.

Expand image Version Information

Available in MFDeploy 2.0 SP1


MFConfigHelper.IsFirmwareKeyLocked Property

MFConfigHelper.IsFirmwareKeyLocked Property

A Boolean value indicating whether the firmware security key has been programmed.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool IsFirmwareKeyLocked { get; }

Property Value

true if the key has been programmed, or false if not.

Expand image Remarks

If the firmware security key has been programmed, the key is locked. You must reprogram it to change it.

Expand image Version Information

Available in MFDeploy 2.0 SP1


MFConfigHelper.IsValidConfig Property

MFConfigHelper.IsValidConfig Property

A Boolean value indicating whether the device configuration version matches this version of MFDeploy.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool IsValidConfig { get; }

Property Value

true if the versions match, or false if not.

Expand image Version Information

Available in MFDeploy 2.0 SP1


MFConfigHelper.MaintainConnection Property

MFConfigHelper.MaintainConnection Property

A Boolean value indicating whether MFDeploy should maintain a connection to TinyBooter.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool MaintainConnection { get; set; }

Property Value

true if MFDeploy should keep the connection active, or false if not.

Expand image Remarks

TinyBooter, which executes on devices compatible with the .NET Micro Framework, times out and enters the device's main application if it doesn't receive a message in a specified time span. When set to true, this property starts a thread that continually pings the device, thus maintaining connection to TinyBooter and preventing it from entering its main application.

Note
To avoid threading problems, set this value to false before attempting to communicate with the device.

Expand image Version Information

Available in MFDeploy 2.0 SP1


MFDeploy Class

MFDeploy Class
See Also Members
CollapseAll image

Contains methods for enumerating, addressing, and connecting to .NET Micro Framework devices.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFDeploy : System.IDisposable

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeploy Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFDeploy Members

MFDeploy Members
See Also Constructors Delegates Destructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the MFDeploy type.

Expand image Public Constructors

 | Name | Description
Public Method | MFDeploy | Initializes a new instance of the MFDeploy class.

Expand image Public Destructors

 | Name | Description
Public Method | ~MFDeploy | Restores the system interrupt to the state it was in when the SmartPTR_IRQ object was created.

Expand image Public Properties

 | Name | Description
Public Property | DeviceList | A list of all available .NET Micro Framework device ports.
Public Property | DiscoveryMultiCastAddress | The address to which network multicasts for device discovery are sent by MFDeploy.
Public Property | DiscoveryMultiCastAddressRecv | The address at which network multicasts for device discovery are received by MFDeploy.
Public Property | DiscoveryMultiCastPort | The port on which network multicasts for device discovery are sent and received.
Public Property | DiscoveryMultiCastToken | A string used to recognize .NET Micro Framework devices on the network.

Expand image Public Methods

 | Name | Description
Public Method | Connect | Overloaded. Attempts to connect to a .NET Micro Framework device on a given port, optionally specifiyng a boot loader port for devices that use a second port for this function.
Public Method | Dispose | Disposes of an MFDeploy object and its associated connection, if any.
Public Method | EnumPorts | Enumerates (lists) the ports available for .NET Micro Framework deployment.

Expand image Public Events

 | Name | Description
Public Event | OnDeviceListUpdate | Occurs when the MFDeploy device list changes.

Expand image Public Delegates

 | Name | Description
Public Delegate | OnMFDeviceUpdate | Handles an OnDeviceListUpdate event, which is a notification that the MFDeploy device list has changed.

Expand image See Also

MFDeploy Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFDeploy Constructor

MFDeploy Constructor

Initializes a new instance of the MFDeploy class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDeploy ()

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also


~MFDeploy Destructor

~MFDeploy Destructor

Restores the system interrupt to the state it was in when the SmartPTR_IRQ object was created.

Expand image Syntax

C#
public ~MFDeploy ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MFDeploy Class
MFDeploy Members


MFDeploy Methods

MFDeploy Methods

Expand image Public Methods

 | Name | Description
Public Method | Connect | Overloaded. Attempts to connect to a .NET Micro Framework device on a given port, optionally specifiyng a boot loader port for devices that use a second port for this function.
Public Method | Dispose | Disposes of an MFDeploy object and its associated connection, if any.
Public Method | EnumPorts | Enumerates (lists) the ports available for .NET Micro Framework deployment.

Expand image See Also

Reference

MFDeploy Members
MFDeploy Class


MFDeploy.Connect Method

MFDeploy.Connect Method

Attempts to connect to a .NET Micro Framework device on a given port, optionally specifiyng a boot loader port for devices that use a second port for this function.

Expand image Overload List

Name | Description
MFDeploy.Connect (MFPortDefinition) | Attempts to connect to .NET Micro Framework device via a specified port.
MFDeploy.Connect (MFPortDefinition, MFPortDefinition) | Attempts to connect to .NET Micro Framework device via a specified port and boot loader port.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDeploy.Connect Method (MFPortDefinition)

MFDeploy.Connect Method (MFPortDefinition)
See Also
CollapseAll image

Attempts to connect to .NET Micro Framework device via a specified port.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDevice Connect (
         MFPortDefinition portdef
)

Parameters

portdef
The port definition of the device to connect to.

Return Value

A handle to the requested device.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDeploy.Connect Method (MFPortDefinition, MFPortDefinition)

MFDeploy.Connect Method (MFPortDefinition, MFPortDefinition)
See Also
CollapseAll image

Attempts to connect to .NET Micro Framework device via a specified port and boot loader port.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDevice Connect (
         MFPortDefinition portdef,
         MFPortDefinition tinybooterPortDef
)

Parameters

portdef
The port definition of the device to connect to.
tinybooterPortDef
For devices that use a second port for the boot loader (TinyBooter), the port definition of the device's TinyBooter port.

Return Value

A handle to the requested device.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDeploy.Dispose Method

MFDeploy.Dispose Method

Disposes of an MFDeploy object and its associated connection, if any.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Dispose ()

Return Value

This function does not return a value.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDeploy.EnumPorts Method

MFDeploy.EnumPorts Method

Enumerates (lists) the ports available for .NET Micro Framework deployment.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Collections.Generic.List<MFPortDefinition> EnumPorts (
         params TransportType[] types
)

Parameters

types
The types of ports to be listed, using the TransportType enumeration.

Return Value

A list of the available ports, representing transports for possible .NET Micro Framework devices.

Expand image Remarks

If called with a null parameter list, EnumPorts returns a list of all types of ports. To receive a list only of specific types of ports, pass one or more TransportTypes, for example, EnumPorts(TransportType.Serial, TransportType.USB).

Since serial ports do not support device discovery, all such ports are always included in the return list if the serial port transport type was requested.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFPortDefinition Class
TransportType Enumeration


MFDeploy Properties

MFDeploy Properties

Expand image Public Properties

 | Name | Description
Public Property | DeviceList | A list of all available .NET Micro Framework device ports.
Public Property | DiscoveryMultiCastAddress | The address to which network multicasts for device discovery are sent by MFDeploy.
Public Property | DiscoveryMultiCastAddressRecv | The address at which network multicasts for device discovery are received by MFDeploy.
Public Property | DiscoveryMultiCastPort | The port on which network multicasts for device discovery are sent and received.
Public Property | DiscoveryMultiCastToken | A string used to recognize .NET Micro Framework devices on the network.

Expand image See Also

MFDeploy Members


MFDeploy.DeviceList Property

MFDeploy.DeviceList Property

A list of all available .NET Micro Framework device ports.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Collections.IList DeviceList { get; }

Property Value

A list of all available ports.

Expand image Remarks

Because there is no way to query a serial device without potential side effects, this list may contain ports without a connected device.

Expand image Version Information

Available in MFDeploy 1.0


MFDeploy.DiscoveryMultiCastAddress Property

MFDeploy.DiscoveryMultiCastAddress Property

The address to which network multicasts for device discovery are sent by MFDeploy.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress DiscoveryMultiCastAddress { get; set; }

Property Value

The transmit IP address (default 234.102.98.44).

Expand image Remarks

This value must match the corresponding setting on the device for the device to be found.

Expand image Version Information

Available in MFDeploy 1.0


MFDeploy.DiscoveryMultiCastAddressRecv Property

MFDeploy.DiscoveryMultiCastAddressRecv Property

The address at which network multicasts for device discovery are received by MFDeploy.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress DiscoveryMultiCastAddressRecv { get; set; }

Property Value

The receive IP address (default 234.102.98.45).

Expand image Remarks

This value must match the corresponding setting on the device for the device to be found.

Expand image Version Information

Available in MFDeploy 1.0


MFDeploy.DiscoveryMultiCastPort Property

MFDeploy.DiscoveryMultiCastPort Property

The port on which network multicasts for device discovery are sent and received.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public int DiscoveryMultiCastPort { get; set; }

Property Value

The multicast port (default 26001).

Expand image Remarks

This value must match the corresponding setting on the device for the device to be found.

Expand image Version Information

Available in MFDeploy 1.0


MFDeploy.DiscoveryMultiCastToken Property

MFDeploy.DiscoveryMultiCastToken Property

A string used to recognize .NET Micro Framework devices on the network.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string DiscoveryMultiCastToken { get; set; }

Property Value

The token (default "DOTNETMF").

Expand image Remarks

This value must match the corresponding setting on the device for the device to be found.

Expand image Version Information

Available in MFDeploy 1.0


MFDeploy Events

MFDeploy Events

Expand image Public Events

 | Name | Description
Public Event | OnDeviceListUpdate | Occurs when the MFDeploy device list changes.


MFDeploy.OnDeviceListUpdate Event

MFDeploy.OnDeviceListUpdate Event

Occurs when the MFDeploy device list changes.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public event OnMFDeviceUpdate OnDeviceListUpdate

Expand image Version Information

Available in MFDeploy version 1.0


MFDeploy Delegates

MFDeploy Delegates

Expand image Public Delegates

 | Name | Description
Public Delegate | OnMFDeviceUpdate | Handles an OnDeviceListUpdate event, which is a notification that the MFDeploy device list has changed.


MFDeploy.OnMFDeviceUpdate Delegate

MFDeploy.OnMFDeviceUpdate Delegate

Handles an OnDeviceListUpdate event, which is a notification that the MFDeploy device list has changed.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public delegate void OnMFDeviceUpdate ()

Return Value

Expand image Version Information

Available in MFDeploy version 1.0


MFDevice Class

MFDevice Class
See Also Members
CollapseAll image

Contains methods for deploying, erasing, and executing code on .NET Micro Framework devices.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFDevice : System.IDisposable

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDevice Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFDevice Members

MFDevice Members
See Also Delegates Destructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the MFDevice type.

Expand image Public Destructors

 | Name | Description
Public Method | ~MFDevice | Restores the system interrupt to the state it was in when the SmartPTR_IRQ object was created.

Expand image Public Properties

 | Name | Description
Public Property | IsConnected | Indicates whether or not the device is connected.

Expand image Public Methods

 | Name | Description
Public Method | ConnectToTinybooter | Establishes communications to the device with TinyBooter.
Public Method | Deploy | Deploys an object file to a device in Motorola SREC format (.hex).
Public Method | Dispose | Disposes of an MFDevice object.
Public Method | Erase | Erases part or all of flash memory.
Public Method | Execute | Begins execution of code on a device.
Public Method | Ping | Attempts to connect to a device to see if it is responding.
Public Method | Reboot | Reboots a connected device.

Expand image Public Events

 | Name | Description
Public Event | OnDbgText | Occurs when a device sends a debug message.

Expand image Public Delegates

 | Name | Description
Public Delegate | OnDebugTextDelegate | Handles a OnDbgText event representing a debug message sent from a device.

Expand image See Also

MFDevice Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


~MFDevice Destructor

~MFDevice Destructor

Restores the system interrupt to the state it was in when the SmartPTR_IRQ object was created.

Expand image Syntax

C#
public ~MFDevice ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MFDevice Class
MFDevice Members


MFDevice Methods

MFDevice Methods

Expand image Public Methods

 | Name | Description
Public Method | ConnectToTinybooter | Establishes communications to the device with TinyBooter.
Public Method | Deploy | Deploys an object file to a device in Motorola SREC format (.hex).
Public Method | Dispose | Disposes of an MFDevice object.
Public Method | Erase | Erases part or all of flash memory.
Public Method | Execute | Begins execution of code on a device.
Public Method | Ping | Attempts to connect to a device to see if it is responding.
Public Method | Reboot | Reboots a connected device.

Expand image See Also

Reference

MFDevice Members
MFDevice Class


MFDevice.ConnectToTinybooter Method

MFDevice.ConnectToTinybooter Method

Establishes communications to the device with TinyBooter.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool ConnectToTinybooter ()

Return Value

If the method connected to TinyBooter, true. If not connected, the return value is false.

Expand image Remarks

This method causes the device to reboot if that is needed to establish communications with TinyBooter.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Deploy Method

MFDevice.Deploy Method

Deploys an object file to a device in Motorola SREC format (.hex).

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool Deploy (
         string filepath,
         string signatureFile,
         out uint entrypoint
)

Parameters

filepath
Path to the SREC file to be deployed.
signatureFile
Path to the digital signature for the SREC file.
entrypoint
Receives the entry point address for the SREC file after it has been deployed.

Return Value

true if the deployment was successful, or false if not.

Expand image Remarks

The signature file is used to validate the image after it has been deployed. If the signature does not match, the deployed SREC file is erased from the device.

Can throw MFFileNotFoundException, MFDeviceNoResponseException, or MFUserExitException.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Dispose Method

MFDevice.Dispose Method

Disposes of an MFDevice object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Dispose ()

Return Value

This function does not return a value.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Erase Method

MFDevice.Erase Method

Erases part or all of flash memory.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool Erase (
         params EraseOptions[] options
)

Parameters

options
Indicates which portions of flash memory should be erased.

Return Value

true if the erase operation completed successfully, otherwise false.

Expand image Remarks

Any number of EraseOptions may be specified, for example Erase(EraseOptions.Deployment, EraseOptions.UserStorage). If no options are given, all flash memory will be erased.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Execute Method

MFDevice.Execute Method

Begins execution of code on a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool Execute (
         uint entrypoint
)

Parameters

entrypoint
The entry point at which execution should begin.

Return Value

true if execution was successfully initiated, or false if not.

Expand image Remarks

This function only works if MFDeploy can connect to the .NET Micro Framework boot loader. If the CLR is already running on the device, the CLR will be rebooted instead.

Can throw MFDeviceNoResponseException.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Ping Method

MFDevice.Ping Method

Attempts to connect to a device to see if it is responding.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public TransportType Ping ()

Return Value

Indicates which .NET Micro Framework component on the device is responding, or TransportType.NoConnection if the device is not responding.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice.Reboot Method

MFDevice.Reboot Method

Reboots a connected device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Reboot (
         bool fColdBoot
)

Parameters

fColdBoot
If true, performs a cold reboot. If false, restarts only the CLR.

Return Value

This method does not return a value.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


MFDevice Properties

MFDevice Properties

Expand image Public Properties

 | Name | Description
Public Property | IsConnected | Indicates whether or not the device is connected.

Expand image See Also

MFDevice Members


MFDevice.IsConnected Property

MFDevice.IsConnected Property

Indicates whether or not the device is connected.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool IsConnected { get; }

Property Value

true if MFDeploy is connected to the device, otherwise false.

Expand image Version Information

Available in MFDeploy 1.0


MFDevice Events

MFDevice Events

Expand image Public Events

 | Name | Description
Public Event | OnDbgText | Occurs when a device sends a debug message.


MFDevice.OnDbgText Event

MFDevice.OnDbgText Event

Occurs when a device sends a debug message.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public event Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine.OnDebugTextDelegate OnDbgText

Expand image Version Information

Available in MFDeploy version 1.0


MFDevice Delegates

MFDevice Delegates

Expand image Public Delegates

 | Name | Description
Public Delegate | OnDebugTextDelegate | Handles a OnDbgText event representing a debug message sent from a device.


MFDevice.OnDebugTextDelegate Delegate

MFDevice.OnDebugTextDelegate Delegate

Handles a OnDbgText event representing a debug message sent from a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public delegate void OnDebugTextDelegate (
         string text
)

Parameters

text
The debug message sent by the device.

Return Value

Expand image Version Information

Available in MFDeploy version 1.0


MFDeviceInUseException Class

MFDeviceInUseException Class
See Also Members
CollapseAll image

An exception thrown when the device targeted for a deployment is busy.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFDeviceInUseException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFDeviceInUseException Members


MFDeviceInUseException Members

MFDeviceInUseException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFDeviceInUseException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFDeviceInUseException | Initializes a new instance of the MFDeviceInUseException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceInUseException Class


MFDeviceInUseException Constructor

MFDeviceInUseException Constructor

Initializes a new instance of the MFDeviceInUseException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDeviceInUseException ()

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeviceInUseException Class
MFDeviceInUseException Members


MFDeviceInUseException Properties

MFDeviceInUseException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceInUseException Members


MFDeviceInUseException.Message Property

MFDeviceInUseException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0


MFDeviceNoResponseException Class

MFDeviceNoResponseException Class
See Also Members
CollapseAll image

An exception thrown when the device targeted for a deployment is not responding.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFDeviceNoResponseException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFDeviceNoResponseException Members


MFDeviceNoResponseException Members

MFDeviceNoResponseException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFDeviceNoResponseException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFDeviceNoResponseException | Initializes a new instance of the MFDeviceNoResponseException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceNoResponseException Class


MFDeviceNoResponseException Constructor

MFDeviceNoResponseException Constructor

Initializes a new instance of the MFDeviceNoResponseException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDeviceNoResponseException ()

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeviceNoResponseException Class
MFDeviceNoResponseException Members


MFDeviceNoResponseException Properties

MFDeviceNoResponseException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceNoResponseException Members


MFDeviceNoResponseException.Message Property

MFDeviceNoResponseException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeviceNoResponseException Members


MFDeviceUnknownDeviceException Class

MFDeviceUnknownDeviceException Class
See Also Members
CollapseAll image

An exception thrown when a deployment is attempted to a device that does not exist or cannot be found.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFDeviceUnknownDeviceException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFDeviceUnknownDeviceException Members


MFDeviceUnknownDeviceException Members

MFDeviceUnknownDeviceException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFDeviceUnknownDeviceException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFDeviceUnknownDeviceException | Initializes a new instance of the MFDeviceUnknownDeviceException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceUnknownDeviceException Class


MFDeviceUnknownDeviceException Constructor

MFDeviceUnknownDeviceException Constructor

Initializes a new instance of the MFDeviceUnknownDeviceException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFDeviceUnknownDeviceException ()

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeviceUnknownDeviceException Class
MFDeviceUnknownDeviceException Members


MFDeviceUnknownDeviceException Properties

MFDeviceUnknownDeviceException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFDeviceUnknownDeviceException Members


MFDeviceUnknownDeviceException.Message Property

MFDeviceUnknownDeviceException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFDeviceUnknownDeviceException Members


MFInvalidFileFormatException Class

MFInvalidFileFormatException Class
See Also Members
CollapseAll image

An exception thrown when the file being deployed to a device has an invalid format.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFInvalidFileFormatException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFInvalidFileFormatException Members


MFInvalidFileFormatException Members

MFInvalidFileFormatException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFInvalidFileFormatException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFInvalidFileFormatException | Initializes a new instance of the MFInvalidFileFormatException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFInvalidFileFormatException Class


MFInvalidFileFormatException Constructor

MFInvalidFileFormatException Constructor

Initializes a new instance of the MFInvalidFileFormatException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFInvalidFileFormatException (
         string file
)

Parameters

file
The path to the invalid file.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFInvalidFileFormatException Class
MFInvalidFileFormatException Members


MFInvalidFileFormatException Properties

MFInvalidFileFormatException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFInvalidFileFormatException Members


MFInvalidFileFormatException.Message Property

MFInvalidFileFormatException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFInvalidFileFormatException Members


MFKeyConfig Class

MFKeyConfig Class
See Also Members
CollapseAll image

Enables applications to perform signature operations and update the public keys on the device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFKeyConfig

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

MFKeyConfig Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFKeyConfig Members

MFKeyConfig Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the MFKeyConfig type.

Expand image Public Constructors

 | Name | Description
Public Method | MFKeyConfig | Initializes a new instance of the MFKeyConfig class.

Expand image Public Methods

 | Name | Description
Public Method | CreateEmptyKeyPair | Creates an object that contains a public and a private key.
Public Method | CreateKeyPair | Creates a public and a private key, each containing random key values.
Public Method | LoadKeyPair | Loads a public and a private key from the disk.
Public Method | SaveKeyPair | Loads a public and a private key from the disk.
Public Method | UpdateDeviceKey | Overloaded. Updates the public key of a device.

Expand image See Also

MFKeyConfig Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFKeyConfig Constructor

MFKeyConfig Constructor

Initializes a new instance of the MFKeyConfig class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFKeyConfig ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also


MFKeyConfig Methods

MFKeyConfig Methods

Expand image Public Methods

 | Name | Description
Public Method | CreateEmptyKeyPair | Creates an object that contains a public and a private key.
Public Method | CreateKeyPair | Creates a public and a private key, each containing random key values.
Public Method | LoadKeyPair | Loads a public and a private key from the disk.
Public Method | SaveKeyPair | Loads a public and a private key from the disk.
Public Method | UpdateDeviceKey | Overloaded. Updates the public key of a device.

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.CreateEmptyKeyPair Method

MFKeyConfig.CreateEmptyKeyPair Method

Creates an object that contains a public and a private key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public KeyPair CreateEmptyKeyPair ()

Return Value

An object containing a pair of keys.

Expand image Remarks

This method sets the bits in the keys it returns to 0xFF. It always creates keys that are 260 bytes in length.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.CreateKeyPair Method

MFKeyConfig.CreateKeyPair Method

Creates a public and a private key, each containing random key values.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public KeyPair CreateKeyPair ()

Return Value

An object containing a pair of random keys.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.LoadKeyPair Method

MFKeyConfig.LoadKeyPair Method

Loads a public and a private key from the disk.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public KeyPair LoadKeyPair (
         string fileName
)

Parameters

fileName
The name of the file to read the key pair from.

Return Value

An object containing a pair of keys.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.SaveKeyPair Method

MFKeyConfig.SaveKeyPair Method

Loads a public and a private key from the disk.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void SaveKeyPair (
         KeyPair keyPair,
         string fileName
)

Parameters

keyPair
Holds the public and private keys to be saved.
fileName
Contains the name of the file to read the key pair from.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.UpdateDeviceKey Method

MFKeyConfig.UpdateDeviceKey Method

Updates the public key of a device.

Expand image Overload List

Name | Description
MFKeyConfig.UpdateDeviceKey (MFDevice, KeyIndex, byte[]) | Updates the public key of a device.
MFKeyConfig.UpdateDeviceKey (MFDevice, KeyIndex, byte[], byte[]) | Updates the public key of a device.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.UpdateDeviceKey Method (MFDevice, KeyIndex, byte[])

MFKeyConfig.UpdateDeviceKey Method (MFDevice, KeyIndex, byte[])
See Also
CollapseAll image

Updates the public key of a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void UpdateDeviceKey (
         MFDevice device,
         PublicKeyUpdateInfo.KeyIndex index,
         byte[] publicKey
)

Parameters

device
Specifies the device whose public key is updated.
index
Selects the public key to update.
publicKey
Holds the new public key.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFKeyConfig.UpdateDeviceKey Method (MFDevice, KeyIndex, byte[], byte[])

MFKeyConfig.UpdateDeviceKey Method (MFDevice, KeyIndex, byte[], byte[])
See Also
CollapseAll image

Updates the public key of a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void UpdateDeviceKey (
         MFDevice device,
         PublicKeyUpdateInfo.KeyIndex index,
         byte[] publicKey,
         byte[] publicKeySignature
)

Parameters

device
Specifies the device whose public key is updated.
index
Selects the public key to update.
publicKey
Holds the new public key.
publicKeySignature
Contains the signature associated with the public key.

Expand image Version Information

Available in MFDeploy version 2.0

Expand image See Also

Reference

MFKeyConfig Members
MFKeyConfig Class


MFNetworkConfiguration Class

MFNetworkConfiguration Class
See Also Members
CollapseAll image

Contains methods for updating the network configuration of the device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFNetworkConfiguration

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

MFNetworkConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFNetworkConfiguration Members

MFNetworkConfiguration Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the MFNetworkConfiguration type.

Expand image Public Constructors

 | Name | Description
Public Method | MFUsbConfiguration | Initializes a new instance of the MFNetworkConfiguration class.

Expand image Public Properties

 | Name | Description
Public Property | EnableDhcp | Indicates whether DHCP is enabled in the device configuration.
Public Property | Gateway | Gets or sets the device's gateway address.
Public Property | IpAddress | Gets or sets the device's network address.
Public Property | MacAddress | Gets or sets the device's MAC address.
Public Property | MaxMacAddressLength | Gets MAC address's length.
Public Property | PrimaryDns | Gets or sets the primary DNS address.
Public Property | SecondaryDns | Gets or sets the secondary DNS address.
Public Property | SubNetMask | Gets or sets the subnet address mask.

Expand image Public Methods

 | Name | Description
Public Method | Load | Loads the network configuration for device.
Public Method | Save | Saves the network configuration for device.

Expand image See Also

MFNetworkConfiguration Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration Constructor

MFUsbConfiguration Constructor

Initializes a new instance of the MFUsbConfiguration class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFUsbConfiguration (
         Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine.MFDevice dev
)

Parameters

dev
Specifies the device to associcate with this configuration class.

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

MFUsbConfiguration Class


MFNetworkConfiguration Methods

MFNetworkConfiguration Methods

Expand image Public Methods

 | Name | Description
Public Method | Load | Loads the network configuration for device.
Public Method | Save | Saves the network configuration for device.

Expand image See Also

Reference

MFNetworkConfiguration Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFNetworkConfiguration.Load Method

MFNetworkConfiguration.Load Method

Loads the network configuration for device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Load ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFNetworkConfiguration Class
MFNetworkConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFNetworkConfiguration.Save Method

MFNetworkConfiguration.Save Method

Saves the network configuration for device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Save ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFNetworkConfiguration Class
MFNetworkConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFPortDefinition Class

MFPortDefinition Class
See Also Members
CollapseAll image

Represents port addressing information for a .NET Micro Framework device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public abstract class MFPortDefinition

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFPortDefinition Members


MFPortDefinition Members

MFPortDefinition Members
See Also Properties
CollapseAll image

The following tables list the members exposed by the MFPortDefinition type.

Expand image Public Properties

 | Name | Description
Public Property | Name | The name of the port represented by a MFPortDefinition object.
Public Property | Port | The identifier of the port represented by a MFPortDefinition object.
Public Property | Transport | The transport type of the port represented by a MFPortDefinition object.

Expand image See Also

MFPortDefinition Class


MFPortDefinition Properties

MFPortDefinition Properties

Expand image Public Properties

 | Name | Description
Public Property | Name | The name of the port represented by a MFPortDefinition object.
Public Property | Port | The identifier of the port represented by a MFPortDefinition object.
Public Property | Transport | The transport type of the port represented by a MFPortDefinition object.

Expand image See Also

MFPortDefinition Class


MFPortDefinition.Name Property

MFPortDefinition.Name Property

The name of the port represented by a MFPortDefinition object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Name { get; }

Property Value

The name of the port.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFPortDefinition Class


MFPortDefinition.Port Property

MFPortDefinition.Port Property

The identifier of the port represented by a MFPortDefinition object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Port { get; }

Property Value

The identifier of the port, such as COM port path or network address.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFPortDefinition Class


MFPortDefinition.Transport Property

MFPortDefinition.Transport Property

The transport type of the port represented by a MFPortDefinition object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine.TransportType Transport { get; }

Property Value

The transport type of the port.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFPortDefinition Class


MFSerialPort Class

MFSerialPort Class
See Also Members
CollapseAll image

A class representing a serial port that can be used to deploy Micro Framework applications to a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFSerialPort : MFPortDefinition

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFSerialPort Members


MFSerialPort Members

MFSerialPort Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the MFSerialPort type.

Expand image Public Constructors

 | Name | Description
Public Method | MFSerialPort | Initializes a new instance of the MFSerialPort class.

Expand image See Also

MFSerialPort Class


MFSerialPort Constructor

MFSerialPort Constructor

Initializes a new instance of the MFSerialPort class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFSerialPort (
         string name,
         string port
)

Parameters

name
The name of the serial port.
port
The serial port address.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFSerialPort Class
MFSerialPort Members


MFSignatureFailureException Class

MFSignatureFailureException Class
See Also Members
CollapseAll image

An exception thrown when the file being deployed to a device does not have a valid signature.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFSignatureFailureException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFSignatureFailureException Members


MFSignatureFailureException Members

MFSignatureFailureException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFSignatureFailureException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFSignatureFailureException | Initializes a new instance of the MFSignatureFailureException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFSignatureFailureException Class


MFSignatureFailureException Constructor

MFSignatureFailureException Constructor

Initializes a new instance of the MFSignatureFailureException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFSignatureFailureException (
         string file
)

Parameters

file
The path to the invalid file.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFSignatureFailureException Class
MFSignatureFailureException Members


MFSignatureFailureException Properties

MFSignatureFailureException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFSignatureFailureException Members


MFSignatureFailureException.Message Property

MFSignatureFailureException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFSignatureFailureException Members


MFTcpIpPort Class

MFTcpIpPort Class
See Also Members
CollapseAll image

A class representing a TCP/IP network address that can be used to deploy Micro Framework applications to a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFTcpIpPort : MFPortDefinition

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFTcpIpPort Members


MFTcpIpPort Members

MFTcpIpPort Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFTcpIpPort type.

Expand image Public Constructors

 | Name | Description
Public Method | MFTcpIpPort | Initializes a new instance of the MFTcpIpPort class.

Expand image Public Properties

 | Name | Description
Public Property | Address | The network address represented by a MFTcpIpPort object.

Expand image See Also

MFTcpIpPort Class


MFTcpIpPort Constructor

MFTcpIpPort Constructor

Initializes a new instance of the MFTcpIpPort class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFTcpIpPort (
         string ipAddress
)

Parameters

ipAddress
The network address of the TCP/IP device.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFTcpIpPort Class
MFTcpIpPort Members


MFTcpIpPort Properties

MFTcpIpPort Properties

Expand image Public Properties

 | Name | Description
Public Property | Address | The network address represented by a MFTcpIpPort object.

Expand image See Also

MFTcpIpPort Class


MFTcpIpPort.Address Property

MFTcpIpPort.Address Property

The network address represented by a MFTcpIpPort object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress Address { get; }

Property Value

The TCP/IP network address.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFTcpIpPort Class


MFUsbConfiguration Class

MFUsbConfiguration Class
See Also Members
CollapseAll image

Contains methods for updating the USB name of a specific USB device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFUsbConfiguration

Expand image Version Information

Available in MFDeploy 2.0 SP1.

Expand image See Also

MFUsbConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration Members

MFUsbConfiguration Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the MFUsbConfiguration type.

Expand image Public Constructors

 | Name | Description
Public Method | MFUsbConfiguration | Initializes a new instance of the MFUsbConfiguration class.

Expand image Public Properties

 | Name | Description
Public Property | Name | A string containing the USB name of the device.

Expand image Public Methods

 | Name | Description
Public Method | Load | Loads the configuration for the USB device associated with this configuration object.
Public Method | Save | Saves the configuration for the USB device associated with this configuration object.

Expand image See Also

MFUsbConfiguration Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration Methods

MFUsbConfiguration Methods

Expand image Public Methods

 | Name | Description
Public Method | Load | Loads the configuration for the USB device associated with this configuration object.
Public Method | Save | Saves the configuration for the USB device associated with this configuration object.

Expand image See Also

Reference

MFUsbConfiguration Class
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration.Load Method

MFUsbConfiguration.Load Method

Loads the configuration for the USB device associated with this configuration object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Load ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFUsbConfiguration Class
MFUsbConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration.Save Method

MFUsbConfiguration.Save Method

Saves the configuration for the USB device associated with this configuration object.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public void Save ()

Expand image Version Information

Available in MFDeploy 2.0 SP1

Expand image See Also

Reference

MFUsbConfiguration Class
MFUsbConfiguration Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


MFUsbConfiguration Properties

MFUsbConfiguration Properties

Expand image Public Properties

 | Name | Description
Public Property | Name | A string containing the USB name of the device.

Expand image See Also

MFUsbConfiguration Members


MFUsbConfiguration.Name Property

MFUsbConfiguration.Name Property

A string containing the USB name of the device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Name { get; set; }

Property Value

The USB name of the device.

Expand image Version Information

Available in MFDeploy 2.0 SP1


MFUsbPort Class

MFUsbPort Class
See Also Members
CollapseAll image

A class representing a USB port that can be used to deploy Micro Framework applications to a device.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFUsbPort : MFPortDefinition

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFUsbPort Members


MFUsbPort Members

MFUsbPort Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the MFUsbPort type.

Expand image Public Constructors

 | Name | Description
Public Method | MFUsbPort | Initializes a new instance of the MFUsbPort class.

Expand image See Also

MFUsbPort Class


MFUsbPort Constructor

MFUsbPort Constructor

Initializes a new instance of the MFUsbPort class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFUsbPort (
         string usbName
)

Parameters

usbName
The name of the USB port.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFUsbPort Class
MFUsbPort Members


MFUserExitException Class

MFUserExitException Class
See Also Members
CollapseAll image

An exception thrown when the user exits a deployment.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public class MFUserExitException : System.Exception

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also

MFUserExitException Members


MFUserExitException Members

MFUserExitException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MFUserExitException type.

Expand image Public Constructors

 | Name | Description
Public Method | MFUserExitException | Initializes a new instance of the MFUserExitException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFUserExitException Class


MFUserExitException Constructor

MFUserExitException Constructor

Initializes a new instance of the MFUserExitException class.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public MFUserExitException (
         string file
)

Parameters

file
The path to the invalid file.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFUserExitException Class
MFUserExitException Members


MFUserExitException Properties

MFUserExitException Properties

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets a message describing the exception.

Expand image See Also

MFUserExitException Members


MFUserExitException.Message Property

MFUserExitException.Message Property

Gets a message describing the exception.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public string Message { get; }

Property Value

A message that describes the exception.

Expand image Version Information

Available in MFDeploy 1.0

Expand image See Also

MFUserExitException Members


PingConnectionType Enumeration

PingConnectionType Enumeration

Defines values that indicate what .NET Micro Framework components on a device are responding to connection attempts.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public enum PingConnectionType

Expand image Members

Member name | Description
TinyCLR | Indicates a response from the Common Language Runtime (CLR).
TinyBooter | Indicates a response from the bootstrap loader.
NoConnection | Indicates that no response was received.

Expand image Version Information

Available in MFDeploy version 1.0

Expand image See Also


PublicKeyUpdateInfo Structure

PublicKeyUpdateInfo Structure

Contains information used to update a public key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public struct PublicKeyUpdateInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PublicKeyUpdateInfo Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo Members

PublicKeyUpdateInfo Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the PublicKeyUpdateInfo type.

Expand image Public Fields

 | Name | Description
Public Field | NewPublicKey | Contains the new public key.
Public Field | NewPublicKeySignature | Contains the new public key signature.
Public Field | PublicKeyIndex | Contains the index of the new public key.

Expand image See Also

Reference

PublicKeyUpdateInfo Structure
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo Fields

PublicKeyUpdateInfo Fields

Expand image Public Fields

 | Name | Description
Public Field | NewPublicKey | Contains the new public key.
Public Field | NewPublicKeySignature | Contains the new public key signature.
Public Field | PublicKeyIndex | Contains the index of the new public key.

Expand image See Also

Reference

PublicKeyUpdateInfo Structure
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo.NewPublicKey Field

PublicKeyUpdateInfo.NewPublicKey Field

Contains the new public key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] NewPublicKey

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PublicKeyUpdateInfo Structure
PublicKeyUpdateInfo Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo.NewPublicKeySignature Field

PublicKeyUpdateInfo.NewPublicKeySignature Field

Contains the new public key signature.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte[] NewPublicKeySignature

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PublicKeyUpdateInfo Structure
PublicKeyUpdateInfo Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo.PublicKeyIndex Field

PublicKeyUpdateInfo.PublicKeyIndex Field

Contains the index of the new public key.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public KeyIndex PublicKeyIndex

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PublicKeyUpdateInfo Structure
PublicKeyUpdateInfo Members
Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine Namespace


PublicKeyUpdateInfo.KeyIndex Enumeration

PublicKeyUpdateInfo.KeyIndex Enumeration

Defines the transport types for device connections.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public enum PublicKeyUpdateInfo.KeyIndex

Expand image Members

Member name | Description
DeploymentKey | Specifies that the public key is an application deployment key.
FirmwareKey | Specifies that the public key is the firmware key for the .NET Micro Framework.

Expand image Version Information

Available in MFDeploy version 2.0 SP1.


TransportType Enumeration

TransportType Enumeration

Defines the transport types for device connections.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public enum TransportType

Expand image Members

Member name | Description
Serial | Represents the serial transport type.
USB | Represents the USB transport type.
TCPIP | Represents the TCP/IP network transport type.

Expand image Version Information

Available in MFDeploy version 1.0


DateTimeFormatInfo.AbbreviatedDayNames Property

DateTimeFormatInfo.AbbreviatedDayNames Property

Gets a one-dimensional array of String objects that contain the culture-specific abbreviated names of the days of the week.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string [] AbbreviatedDayNames { get; }

Property Value

A one-dimensional array of String objects that contain the culture-specific abbreviated names of the days of the week.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTimeFormatInfo.AbbreviatedMonthNames Property

DateTimeFormatInfo.AbbreviatedMonthNames Property

Gets a one-dimensional array of String objects that contain the culture-specific abbreviated names of the months.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string [] AbbreviatedMonthNames { get; }

Property Value

A one-dimensional array of String objects that contain the culture-specific abbreviated names of the months. In a 12-month calendar, the 13th object in the array is an empty string.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DispatcherOperation.Abort Method

DispatcherOperation.Abort Method

Aborts the delegate on the dispatcher queue associated with the current DispatcherOperation object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Abort ()

Return Value

true if the operation was aborted; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


Thread.Abort Method

Thread.Abort Method

Raises a ThreadAbortException exception in the thread on which it is invoked. This begins the process of terminating the thread.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Abort ()

Expand image Remarks

Calling this method usually terminates the thread on which it is called.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


DispatcherOperation.Aborted Event

DispatcherOperation.Aborted Event

Occurs when the delegate on the dispatcher queue associated with the current DispatcherOperation object is aborted.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler Aborted

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


Math.Abs Method

Math.Abs Method

Returns the absolute value of a specified integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Abs (
         int val
)

Parameters

val
A number between the minimum and maximum allowable values for an integer.

Return Value

The absolute value of a specified integer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
System Namespace


RawButtonInputReport.Actions Field

RawButtonInputReport.Actions Field

Specifies the action of a particular button.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RawButtonActions Actions

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RawButtonInputReport Class
RawButtonInputReport Members
Microsoft.SPOT.Input Namespace


UIElement.ActualHeight Property

UIElement.ActualHeight Property

Gets the rendered height of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ActualHeight { get; }

Property Value

The element's rendered height, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Expand image Remarks

This property is a calculated value based on other height inputs, and the layout system. The value is set by the layout system itself, based on an actual rendering pass, and may therefore lag slightly behind the set value of the Height property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.ActualWidth Property

UIElement.ActualWidth Property

Gets the rendered width of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ActualWidth { get; }

Property Value

The element's rendered width, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Expand image Remarks

This property is a calculated value based on other width inputs, and the layout system. The value is set by the layout system itself, based on an actual rendering pass, and may therefore lag slightly behind the set value of the Width property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


ListBoxItemCollection.Add Method (UIElement)

ListBoxItemCollection.Add Method (UIElement)
See Also
CollapseAll image

Adds a user interface item (element) to the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Add (
         UIElement element
)

Parameters

element
The item to be added to the current collection.

Return Value

The index number of the item that was added to the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Add Method (TextRun)

TextRunCollection.Add Method (TextRun)
See Also
CollapseAll image

Adds a specified TextRun object (string) to the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Add (
         TextRun textRun
)

Parameters

textRun
The string to be added to the text run collection.

Return Value

The index number of the specified string added to the text run collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Add Method (String, Font, Color)

TextRunCollection.Add Method (String, Font, Color)
See Also
CollapseAll image

Adds a specified TextRun object (string) to the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Add (
         string text,
         Font font,
         Color foreColor
)

Parameters

text
The string to be added to the text run collection.
font
The font to be used for the string.
foreColor
The foreground color to be used for the string.

Return Value

The index number of the specified string in the text run collection.

Expand image Remarks

This method creates a TextRun object, stores the specified string in it, and then saves the object in the current text run collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


ArrayList.Add Method

ArrayList.Add Method

Adds a specified object to the end of the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int Add (
         Object value
)

Parameters

value
The object you want to add to the end of the ArrayList collection. This value can be a null reference.

Return Value

The index number at which the specified object is added to the ArrayList collection.

Expand image Remarks

The ArrayList collection accepts a null reference as a valid value and allows duplicate objects.

If the value of the Count property already equals the value of the Capacity property, Add automatically doubles the capacity of the list.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ListBoxItemCollection.Add Method (ListBoxItem)

ListBoxItemCollection.Add Method (ListBoxItem)
See Also
CollapseAll image

Adds a list box item (element) to the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Add (
         ListBoxItem item
)

Parameters

item
The item to be added to the current collection.

Return Value

The index number of the item that was added to the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


DateTime.Add Method

DateTime.Add Method

Adds a specified time period to the current DateTime object, yielding a new DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime Add (
         TimeSpan val
)

Parameters

val
A TimeSpan object that specifies a period of time.

Return Value

A DateTime object that results from the addition of the time period specified in the TimeSpan object's val parameter to the current DateTime object.

Expand image Remarks

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


EventRoute.Add Method

EventRoute.Add Method

Adds a specified handler for a specified target to the event route.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Add (
         Object target,
         Delegate handler,
         bool handledEventsToo
)

Parameters

target
The target object for which a handler is to be added to the event route.
handler
The handler to be added to the event route.
handledEventsToo
A value that indicates whether or not the listener detects events that have already been handled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventRoute Class
EventRoute Members
Microsoft.SPOT Namespace


System.Collections.IList.Add Method

System.Collections.IList.Add Method

Adds an object to an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
int System.Collections.IList.Add (
         Object value
)

Parameters

value
The object you want to add to the array.

Return Value

An exception (in every case).

Expand image Remarks

This method always throws a NotSupportedException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.Add Method

IList.Add Method

When implemented by a class, this method adds a specified object to the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Add (
         Object value
)

Parameters

value
The object you want to add to the collection.

Return Value

The index number at which the specified objectwas inserted into the IList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Add Method

ListBoxItemCollection.Add Method

Adds an item (element) to the current collection.

Expand image Overload List

Name | Description
ListBoxItemCollection.Add (ListBoxItem) | Adds a list box item (element) to the current collection.
ListBoxItemCollection.Add (UIElement) | Adds a user interface item (element) to the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Add Method

TextRunCollection.Add Method

Adds a TextRun object (string) to the current text run collection.

Expand image Overload List

Name | Description
TextRunCollection.Add (String, Font, Color) | Adds a specified TextRun object (string) to the current text run collection.
TextRunCollection.Add (TextRun) | Adds a specified TextRun object (string) to the current text run collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TimeSpan.Add Method

TimeSpan.Add Method

Adds a specified TimeSpan object (time period) to the current TimeSpan object, yielding a new TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Add (
         TimeSpan ts
)

Parameters

ts
A TimeSpan object to be added to the current TimeSpan object.

Return Value

A new TimeSpan object that results from the addition of the ts parameter to the current TimeSpan object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


UIElementCollection.Add Method

UIElementCollection.Add Method

Adds a specified element to the current collection at a specified index number (position).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Add (
         UIElement element
)

Parameters

element
A UIElement object that specifies the element to be added to the current collection.

Return Value

The index number where the specified element was added to the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


DateTime.AddDays Method

DateTime.AddDays Method

Adds a specified number of days to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddDays (
         double val
)

Parameters

val
A specific number of days. Note that the number in the val parameter can be either positive or negative, and it can express partial days as well as whole days.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of days.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

The fractional part of a day is represented by the fractional part of the val parameter (that is, anything to the right of the decimal point). For example, 4.5 is equivalent to 4 days, 12 hours, 0 minutes, 0 seconds, 0 milliseconds, and 0 ticks. The number in the val parameter is rounded to the nearest tick.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


AddFontToProcess

AddFontToProcess
See Also Example
CollapseAll image

Specifies the path to a TrueType font to use for building a .tinyfnt font.

Expand image Syntax

AddFontToProcess path

Parameters

path
The fully qualified path to a TrueType font file. The path should be enclosed in quotes if it contains spaces. If path is quoted, backslashes in path must be escaped.

Expand image Remarks

TFConvert attempts to match the font characteristics specified in the SelectFont option to the font named in path, as well as to any fonts installed on the system. The .tinyfnt file will be generated from the first match found, but it is not guaranteed that the path argument will be searched first.

Expand image Example

AddFontToProcess C:\Windows\Fonts\Miramo.ttf
AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Miramo.ttf"

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SelectFont


UIElement.AddHandler Method

UIElement.AddHandler Method

Adds a routed-event handler for a specified routed event, adding the handler to the current element's event handler collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void AddHandler (
         RoutedEvent routedEvent,
         Delegate handler,
         bool handledEventsToo
)

Parameters

routedEvent
An identifier for the routed event to be handled.
handler
A delegate that represents the handler to be added.
handledEventsToo
true if you want to register the handler such that it is invoked even when the routed event is marked handled in its event data; false if you want to register the handler with the default condition that it will not be invoked if the routed event is already marked handled. Note that the default value for this parameter is false. Do not routinely ask to rehandle a routed event. For more information, see the "Remarks" section on this page.

Expand image Remarks

Processing low-level input events in a practical way is a complex task. Many controls implement a behavior wherein a certain event is marked as handled and is replaced by another, more intuitive event. Generally, a control will mark a platform input event as handled only if there is some design intention for doing so. In certain scenarios, those design intentions might not be what your particular handling of the input event requires. It is for these scenarios that registering handlers with the handledEventsToo parameter set to true is appropriate. But you should not do this routinely. Invoking handlers in response to all events — even if they are handled events — will complicate your own application event processing logic. You may see a decrease in performance if the handler logic is substantial. You should reserve the use of attaching handlers for already handled events for situations in which you have already discovered during the development process that certain controls are handling events that you still want to handle with application logic.

You can add the same handler for the same event multiple times without raising an exception. However, the handler is actually invoked multiple times when the event is handled. Therefore, consider how this behavior might have side effects that you should account for in your handler implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


DateTime.AddHours Method

DateTime.AddHours Method

Adds a specified number of hours to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddHours (
         double val
)

Parameters

val
A specific number of hours. Note that the number in the val parameter can be either positive or negative, and it can express partial hours as well as whole hours.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of hours.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

The fractional part of an hour is represented by the fractional part of the val parameter (that is, anything to the right of the decimal point). For example, 4.5 is equivalent to 4 hours, 30 minutes, 0 seconds, 0 milliseconds, and 0 ticks. The number in the val parameter is rounded to the nearest tick.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator + Method

TimeSpan.operator + Method

Adds two specified TimeSpan objects (time periods), yielding a new TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeSpan operator + (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that specifies a period of time.
t2
A TimeSpan object that specifies a period of time.

Return Value

A new TimeSpan object that represents the sum of the two TimeSpan objects represented by the t1 and t2 parameters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.operator + Method

DateTime.operator + Method

Adds a specified period of time to a specified DateTime object, yielding a new DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTime operator + (
         DateTime d,
         TimeSpan t
)

Parameters

d
A DateTime object that specifies a date and time.
t
A TimeSpan object that specifies a period of time.

Return Value

A DateTime object that represents the sum of the d and t parameters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator + Method

TimeSpan.operator + Method

Unary plus operator.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeSpan operator + (
         TimeSpan t
)

Parameters

t
A TimeSpan object that specifies a period of time.

Return Value

The TimeSpan object represented by the t parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.AddMilliseconds Method

DateTime.AddMilliseconds Method

Adds a specified number of milliseconds to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddMilliseconds (
         double val
)

Parameters

val
A specific number of milliseconds. Note that the number in the val parameter can be either positive or negative, and it can express partial milliseconds as well as whole milliseconds.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of milliseconds.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

The fractional part of a millisecond is represented by the fractional part of the val parameter (that is, anything to the right of the decimal point). For example, 4.5 is equivalent to 4 milliseconds and 5,000 ticks, where one millisecond equals 10,000 ticks. The number in the val parameter is rounded to the nearest tick.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.AddMinutes Method

DateTime.AddMinutes Method

Adds a specified number of minutes to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddMinutes (
         double val
)

Parameters

val
A specific number of minutes. Note that the number in the val parameter can be either positive or negative, and it can express partial minutes as well as whole minutes.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of minutes.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

The fractional part of a minute is represented by the fractional part of the val parameter (that is, anything to the right of the decimal point). For example, 4.5 is equivalent to 4 minutes, 30 seconds, 0 milliseconds, and 0 ticks. The number in the val parameter is rounded to the nearest tick.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


EventHandlersStore.AddRoutedEventHandler Method

EventHandlersStore.AddRoutedEventHandler Method

Adds a specified routed event handler for a specified RoutedEvent object to the collection of events in the current EventHandlersStore object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void AddRoutedEventHandler (
         RoutedEvent routedEvent,
         Delegate handler,
         bool handledEventsToo
)

Parameters

routedEvent
The routed event.
handler
The handler for the routed event.
handledEventsToo
A Boolean value that indicates whether the routed event handler should also process events that have already been handled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventHandlersStore Class
EventHandlersStore Members
Microsoft.SPOT Namespace


DateTime.AddSeconds Method

DateTime.AddSeconds Method

Adds a specified number of seconds to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddSeconds (
         double val
)

Parameters

val
A specific number of seconds. Note that the number in the val parameter can be either positive or negative, and it can express partial seconds as well as whole seconds.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of seconds.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

The fractional part of a second is represented by the fractional part of the val parameter. For example, 4.5 is equivalent to 4 seconds, 500 milliseconds, and 0 ticks. The number in the val parameter is rounded to the nearest tick.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.AddTicks Method

DateTime.AddTicks Method

Adds a specified number of ticks to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime AddTicks (
         long val
)

Parameters

val
A specific number of ticks (one tick equals 100 nanoseconds). Note that the number in the val parameter can be either positive or negative.

Return Value

A new DateTime object having a value that represents the sum of the current DateTime object and the specified number of ticks.

Expand image Remarks

This method does not change the value of the current DateTime object; rather, it returns a new DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


UIElement.AddToEventRoute Method

UIElement.AddToEventRoute Method

Adds handlers to the specified event route for the current element's event handler collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void AddToEventRoute (
         EventRoute route,
         RoutedEventArgs args
)

Parameters

route
The event route to which handlers are to be added.
args
The event data to be used to add the handlers. The AddToEventRoute method uses the RoutedEventArgs.RoutedEvent property to create the handlers.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


AdjustAscent

AdjustAscent
See Also Example
CollapseAll image

Adjusts the ascent of the font being created.

Expand image Syntax

AdjustAscent adjustment

Parameters

adjustment
An integer indicating the number of EM units to adjust the ascent. A positive number increases the ascent, and a negative number decreases it.

Expand image Remarks

The ascent cannot be decreased to less than 0. For example, if the original font has an ascent of 10, and adjustment is -11, TFConvert will fail.

Note
The AdjustAscent option can be applied only once per .fntdef file. If this option is included more than once, the last occurrence will be used.

Expand image Example

      #The following increases the ascent by 3.
      AdjustAscent 3

Expand image See Also

Reference

AdjustDescent


AdjustDescent

AdjustDescent
See Also Example
CollapseAll image

Adjusts the descent of the font being created.

Expand image Syntax

AdjustDescent adjustment

Parameters

adjustment
An integer indicating the number of EM units to adjust the descent. A positive number increases the descent, and a negative number decreases it.

Expand image Remarks

The descent cannot be decreased to less than 0. For example, if the original font has an Descent of 3, and adjustment is -4, TFConvert will fail.

Note
The AdjustDescent option can be applied only once per .fntdef file. If this option is included more than once, the last occurrence will be used.

Expand image Example

      #The following increases the Descent by 3.
      AdjustDescentLeading 3

Expand image See Also

Reference

AdjustAscent


AdjustExternalLeading

AdjustExternalLeading
See Also Example
CollapseAll image

Adjusts the external leading measurement of the font being created.

Expand image Syntax

AdjustExternalLeading adjustment

Parameters

adjustment
An integer indicating the number of EM units to adjust the external leading measurement. A positive number increases the external leading measurement, and a negative number decreases it.

Expand image Remarks

The external leading measurement cannot be decreased to less than 0. For example, if the original font has an external leading measurement of 3, and adjustment is -4, TFConvert will fail.

Note
The AdjustExternalLeading option can be applied only once per .fntdef file. If this option is included more than once, the last occurrence will be used.

Expand image Example

      #The following increases the external leading measurement by 3.
      AdjustExternalLeading 3

Expand image See Also

Reference

AdjustInternalLeading


AdjustInternalLeading

AdjustInternalLeading
See Also Example
CollapseAll image

Adjusts the internal leading measurement of the font being created.

Expand image Syntax

AdjustInternalLeading adjustment

Parameters

adjustment
An integer indicating the number of EM units to adjust the internal leading measurement. A positive number increases the internal leading measurement, and a negative number decreases it.

Expand image Remarks

The internal leading measurement cannot be decreased to less than 0. For example, if the original font has an internal leading measurement of 3, and adjustment is -4, TFConvert will fail.

Note
The AdjustInternalLeading option can be applied only once per .fntdef file. If this option is included more than once, the last occurrence will be used.

Expand image Example

      #The following increases the internal leading measurement by 3.
      AdjustInternalLeading 3

Expand image See Also

Reference

AdjustExternalLeading


AdjustLeftMargin

AdjustLeftMargin
See Also Example
CollapseAll image

Adjusts the left margin of a range of characters.

Expand image Syntax

AdjustLeftMargin adjustment

Parameters

adjustment
An integer indicating the number of device units to add to the left margin. A positive number increases the left margin on each glyph in the next ImportRange, and a negative number decreases it.

Expand image Remarks

By default, the margins applied to each character are set to 0. If the left margin is decreased to less than 0, the character may shift to the left far enough to overlap with the previous character.

The AdjustLeftMargin option applies to the characters specified by the ImportRange option most immediately following it in the .fntdef file.

Expand image Example

The following .fntdef file increases the left margin for letters A through C but resets it for D through F.
      SelectFont "WE:400,FN:Pescadero"
      #Increase the left margin and then import the letters A through C
      AdjustLeftMargin 3
      ImportRange 65 67
      #reset the left margin for D through F
      AdjustLeftMargin 0
      ImportRange 68 70

Expand image See Also

Reference

AdjustRightMargin


AdjustRightMargin

AdjustRightMargin
See Also Example
CollapseAll image

Adjusts the right margin of a character or range of characters.

Expand image Syntax

AdjustRightMargin adjustment

Parameters

adjustment
An integer indicating the number of EM units to add to the right margin. A positive number increases the right margin on each glyph in the next ImportRange, and a negative number decreases it.

Expand image Remarks

The AdjustRightMargin option applies to the character or range of characters specified by the ImportRange option most immediately following it in the .fntdef file.

By default, the margins applied to each character are set to 0. If the right margin is decreased to less than 0, the character may shift to the right far enough to overlap with the next character.

Expand image Example

The following .fntdef file increases the right margin for letters A through C but resets it for D through F.
      SelectFont "WE:400,FN:Pescadero"
      #Increase the right margin and then import the letters A through C
      AdjustRightMargin 3
      ImportRange 65 67
      #reset the right margin for D through F
      AdjustRightMargin 0
      ImportRange 68 70

Expand image See Also

Reference

AdjustLeftMargin


Bitmap.DT_AlignmentCenter Field

Bitmap.DT_AlignmentCenter Field

Specifies that text is center-aligned as it flows around a bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_AlignmentCenter

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DT_AlignmentLeft Field

Bitmap.DT_AlignmentLeft Field

Specifies that text is left-aligned as it flows around a bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_AlignmentLeft

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DT_AlignmentMask Field

Bitmap.DT_AlignmentMask Field

Specifies that you can use a mask to get or set text alignment around a bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_AlignmentMask

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DT_AlignmentRight Field

Bitmap.DT_AlignmentRight Field

Specifies that text is right-aligned as it flows around a bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_AlignmentRight

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


AttributeUsageAttribute.AllowMultiple Property

AttributeUsageAttribute.AllowMultiple Property

Gets or sets a Boolean value that indicates whether you can specify more than one instance of the specified attribute for a single program element.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool AllowMultiple { get; set; }

Property Value

true if you can specify more than one instance of the attribute; otherwise, false. The default return value is false.

Expand image Remarks

An attribute that you can specify more than once for a program element is called a multiuse attribute. An attribute that you can specify only once is called a single-use attribute.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AttributeUsageAttribute Class
AttributeUsageAttribute Members
System Namespace


DateTimeFormatInfo.AMDesignator Property

DateTimeFormatInfo.AMDesignator Property

Gets the string designator for hours that are "ante meridiem" (before noon).

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string AMDesignator { get; }

Property Value

The string designator for hours that are "ante meridiem" (before noon). The default return value is "AM".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


AppDomain Class

AppDomain Class
See Also Members
CollapseAll image

Represents an application domain, which is an isolated environment in which applications run.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public sealed class AppDomain : MarshalByRefObject

Expand image Remarks

Application domains, which are represented by AppDomain objects, help provide isolation, unloading, and security boundaries for executing managed code.

Multiple application domains can run in a single process, but there is not a one-to-one correlation between application domains and threads. Several threads can belong to a single application domain. Note, however, that although a given thread is not confined to a single application domain, it can run in only one application domain at a time.

The AppDomain class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Members
System Namespace


AppDomain Members

AppDomain Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the AppDomain type.

Expand image Public Properties

 | Name | Description
 | CurrentDomain | Gets the name of the application domain for the current thread.
Public Property | FriendlyName | Gets the "friendly" name of the current application domain.

Expand image Public Methods

 | Name | Description
 | CreateDomain | Creates a new application domain with the specified name.
Public Method | CreateInstanceAndUnwrap | Creates a new instance of the specified type. Parameters specify the name of the type and the display name of the assembly where the type is defined.
Public Method | GetAssemblies | Gets the assemblies that have been loaded into the current application domain.
Public Method | Load | Loads an assembly into the specified application domain, using the assembly's display name.
 | Unload | Unloads the specified application domain.

Expand image See Also

Reference

AppDomain Class
System Namespace


AppDomainUnloadedException Class

AppDomainUnloadedException Class
See Also Members
CollapseAll image

The exception that is thrown when an attempt is made to access an unloaded application domain.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class AppDomainUnloadedException : SystemException

Expand image Remarks

The AppDomainUnloadedException class uses the HRESULT COR_E_APPDOMAINUNLOADED constant, which has the value 0x80131014.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomainUnloadedException Members
System Namespace


AppDomainUnloadedException Members

AppDomainUnloadedException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the AppDomainUnloadedException type.

Expand image Public Constructors

 | Name | Description
Public Method | AppDomainUnloadedException | Overloaded. Initializes a new instance of the AppDomainUnloadedException class.

Expand image See Also

Reference

AppDomainUnloadedException Class
System Namespace


Logging.AppendRecord Method

Logging.AppendRecord Method

Adds a Logging object (log record) at the end of the list of log records.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void AppendRecord (
         Object o
)

Parameters

o
The log record you want to add at the end of the list.

Expand image Remarks

When the flash sectors in which the log is stored are full, this method deletes and replaces the oldest data.

The use of this class is currently not supported and is not recommended.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Logging Class
Logging Members
Microsoft.SPOT Namespace


Application Class

Application Class
See Also Members
CollapseAll image

Encapsulates a Windows Presentation Foundation (WPF) application.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Application : DispatcherObject

Expand image Remarks

Each instance of the Application class is a singleton object whose application-scope services are shared across a single application domain. Consequently, only one Application object can be created per AppDomain object. To enable shared access, the Application class provides the static Current property, which returns a reference to the Application object for the current AppDomain object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Members
Microsoft.SPOT Namespace


Application Members

Application Members
See Also Constructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the Application type.

Expand image Public Constructors

 | Name | Description
Public Method | Application | Initializes a new instance of the Application class.

Expand image Public Properties

 | Name | Description
 | Current | Gets the Application object for the current application domain.
Public Property | MainWindow | Gets or sets the main window of the current application.
Public Property | ShutdownMode | Gets or sets the condition that causes the Shutdown method to be called.
Public Property | Windows | Gets the instantiated windows in the current application.

Expand image Public Methods

 | Name | Description
Public Method | Run | Overloaded. Starts a Windows Presentation Foundation (WPF) application.
Public Method | Shutdown | Causes an application to exit.

Expand image Protected Methods

 | Name | Description
Protected Method | OnExit | Raises the Exit event.
Protected Method | OnStartup | Raises the Startup event.

Expand image Public Events

 | Name | Description
Public Event | Exit | Occurs just before an application exits.
Public Event | Startup | Occurs when the Run method of an Application object is called.

Expand image See Also

Reference

Application Class
Microsoft.SPOT Namespace


ApplicationException Class

ApplicationException Class
See Also Members
CollapseAll image

The exception that is thrown when a nonfatal application error occurs.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class ApplicationException : Exception

Expand image Remarks

An instance of the ApplicationException class is thrown by a user program, not by the common language runtime (CLR). If you are designing an application that needs to create its own exceptions, derive the exceptions from the ApplicationException class.

The ApplicationException class extends the Exception class, but it does not add new functionality. This class of exceptions is provided as means of differentiating between exceptions defined by applications versus exceptions defined by the system.

The ApplicationException class does not provide information as to the cause of exceptions. In most scenarios, instances of this class should not be thrown. In cases where this class is instantiated, a human-readable message describing the error should be passed to the constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ApplicationException Members
System Namespace


ApplicationException Members

ApplicationException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the ApplicationException type.

Expand image Public Constructors

 | Name | Description
Public Method | ApplicationException | Overloaded. Initializes a new instance of the ApplicationException class.

Expand image See Also

Reference

ApplicationException Class
System Namespace


ArgumentException Class

ArgumentException Class
See Also Members
CollapseAll image

The exception that is thrown when one of the arguments provided to a method is not valid.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class ArgumentException : SystemException

Expand image Remarks

An ArgumentException exception is thrown when a method is called and at least one of the passed arguments does not meet the parameter specification for that method. Every instance of the ArgumentException class should carry a meaningful error message describing the invalid argument, as well as the expected range of values for that argument.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Members
System Namespace


ArgumentException Members

ArgumentException Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the ArgumentException type.

Expand image Public Constructors

 | Name | Description
Public Method | ArgumentException | Overloaded. Initializes a new instance of the ArgumentException class.

Expand image Public Properties

 | Name | Description
Public Property | Message | Gets the error message associated with this exception.
Public Property | ParamName | Gets the name of the parameter that caused this exception.

Expand image See Also

Reference

ArgumentException Class
System Namespace


ArgumentNullException Class

ArgumentNullException Class
See Also Members
CollapseAll image

The exception that is thrown when a null reference is passed to a method that does not accept it as a valid argument.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class ArgumentNullException : ArgumentException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentNullException Members
System Namespace


ArgumentNullException Members

ArgumentNullException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the ArgumentNullException type.

Expand image Public Constructors

 | Name | Description
Public Method | ArgumentNullException | Overloaded. Initializes a new instance of the ArgumentNullException class.

Expand image See Also

Reference

ArgumentNullException Class
System Namespace


ArgumentOutOfRangeException Class

ArgumentOutOfRangeException Class
See Also Members
CollapseAll image

The exception that is thrown when the value of an argument is outside the allowable range of values, as defined by the method that was invoked.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class ArgumentOutOfRangeException : ArgumentException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentOutOfRangeException Members
System Namespace


ArgumentOutOfRangeException Members

ArgumentOutOfRangeException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the ArgumentOutOfRangeException type.

Expand image Public Constructors

 | Name | Description
Public Method | ArgumentOutOfRangeException | Overloaded. Initializes a new instance of the ArgumentOutOfRangeException class.

Expand image See Also

Reference

ArgumentOutOfRangeException Class
System Namespace


UIElement.Arrange Method

UIElement.Arrange Method

Positions child elements in a particular region on the screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Arrange (
         int finalRectX,
         int finalRectY,
         int finalRectWidth,
         int finalRectHeight
)

Parameters

finalRectX
The upper-left x-coordinate of the final rectangle that the parent uses to position the child element.
finalRectY
The upper-left y-coordinate of the final rectangle that the parent uses to position the child element.
finalRectWidth
The width of the final rectangle that the parent uses to position the child element.
finalRectHeight
The height of the final rectangle that the parent uses to position the child element.

Expand image Remarks

Calling this method constitutes the second pass of a layout update.

Computation of layout positioning in Windows Presentation Foundation (WPF) consists of a Measure method call and an Arrange method call. During the Measure call, an element determines its size requirements, using the specified available sizes. During the Arrange call, the element size is finalized and returned.

For derived elements, behavior of the Arrange method should not be changed (and cannot be changed, unless you shadow). Instead, you should override the ArrangeOverride method implementation in your class. Your ArrangeOverride implementation is called internally by the Arrange method as part of default layout operations.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Border.ArrangeOverride Method

Border.ArrangeOverride Method

Positions and determines the size of a user interface child element on the screen.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void ArrangeOverride (
         int width,
         int height
)

Parameters

width
The width of the smallest rectangle that can enclose the user interface child element.
height
The height of the smallest rectangle that can enclose the user interface child element.

Expand image Remarks

Your application does not call this method. It is called automatically when it is time to arrange the child element on the screen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Canvas.ArrangeOverride Method

Canvas.ArrangeOverride Method

Arranges the contents of a specific canvas element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void ArrangeOverride (
         int arrangeWidth,
         int arrangeHeight
)

Parameters

arrangeWidth
Contains the width of the area that the canvas element should use to arrange its child elements.
arrangeHeight
Contains the height of the area that the canvas element should use to arrange its child elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.ArrangeOverride Method

ScrollViewer.ArrangeOverride Method

Arranges and sizes the contents (controls) of a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void ArrangeOverride (
         int arrangeWidth,
         int arrangeHeight
)

Parameters

arrangeWidth
The width of the area in which the contents of the ScrollViewer control are arranged.
arrangeHeight
The height of the area in which the contents of the ScrollViewer control are arranged.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


StackPanel.ArrangeOverride Method

StackPanel.ArrangeOverride Method

Arranges the layout of the child objects contained by the StackPanel control.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void ArrangeOverride (
         int arrangeWidth,
         int arrangeHeight
)

Parameters

arrangeWidth
Holds the maximum available width, in pixels, of the rectangular area where the child controls are displayed.
arrangeHeight
Holds the maximum available height, in pixels, of the rectangular area where the child controls are displayed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.ArrangeOverride Method

UIElement.ArrangeOverride Method

Positions child elements and determines a size for a UIElement-derived class when implemented in a derived class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void ArrangeOverride (
         int arrangeWidth,
         int arrangeHeight
)

Parameters

arrangeWidth
The width of the final area within the parent in which the current element will arrange itself and its children.
arrangeHeight
The height of the final area within the parent in which the current element will arrange itself and its children.

Expand image Remarks

Your implementation of the ArrangeOverride method is called internally by the Arrange method as part of default layout operations.

Computation of layout positioning in Windows Presentation Foundation (WPF) consists of a Measure method call and an Arrange method call. During the Measure call, an element determines its size requirements, using the specified available sizes. During the Arrange call, the element size is finalized and returned.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Window.ArrangeOverride Method

Window.ArrangeOverride Method

Determines the current window's size and positions its child elements when you override this method.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void ArrangeOverride (
         int arrangeWidth,
         int arrangeHeight
)

Parameters

arrangeWidth
The width that the current window should use to arrange itself and its children.
arrangeHeight
The height that the current window should use to arrange itself and its children.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


Array Class

Array Class
See Also Members
CollapseAll image

Contains methods for creating, manipulating, searching, and sorting arrays. The Array class is therefore the base class for all arrays in the common language runtime (CLR).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class Array : ICloneable, IList, ICollection, IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Members
System Namespace


Array Members

Array Members
See Also Constructors Methods Properties Explicit Interface Implementations
CollapseAll image

The following tables list the members exposed by the Array type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Array | Initializes an instance of the Array class.

Expand image Public Properties

 | Name | Description
Public Property | IsFixedSize | Gets a value indicating whether a specific array has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether a specific array is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to a specific array is synchronized.
Public Property | Length | Gets a 32-bit integer that represents the total number of objects in all the dimensions of a specific array.
Public Property | SyncRoot | Gets an object that you can use to synchronize access to a specific array.

Expand image Public Methods

 | Name | Description
 | BinarySearch | Overloaded. Searches a one-dimensional sorted array for a specified value, using a binary search algorithm.
 | Clear | Sets a range of objects in a specified array to 0 (zero), to false, or to a null reference, depending on the object type.
Public Method | Clone | Creates a shallow copy of an array.
 | Copy | Overloaded. Copies a specified range of objects from an array to another array and performs type casting and boxing, as required.
Public Method | CopyTo | Copies all of the objects from a one-dimensional array (source array) to another one-dimensional array (destination array), starting at the specified index number in the destination array. You specify this index number as a 32-bit integer.
 | CreateInstance | Creates a one-dimensional array of the specified type and length, with zero-based indexing.
Public Method | GetEnumerator | Gets an IEnumerator object for a specified array.
Public Method | GetValue | Gets the value of the object at a specified position in a one-dimensional array.
 | IndexOf | Overloaded. Returns the index number of the first occurrence of a specified object (if any) in a one-dimensional array or in a specified range within that array.

Expand image Explicit Interface Implementations

 | Name | Description
Explicit Interface Implementation | System.Collections.IList.Add | Adds an object to an array.
Explicit Interface Implementation | System.Collections.IList.Clear | Sets all of the objects in a specific array to 0 (zero), to false, or to a null reference, depending on the object type.
Explicit Interface Implementation | System.Collections.IList.Contains | Determines whether a specified object is contained in a specific array.
Explicit Interface Implementation | System.Collections.IList.IndexOf | Searches for a specified object in a one-dimensional array and returns the index number of the first occurrence of that object (if any) in the array.
Explicit Interface Implementation | System.Collections.IList.Insert | Inserts an object at a specified location (index number) in an array.
Explicit Interface Implementation | System.Collections.IList.RemoveAt | Removes the object at a specified location (index number) in an array.
Explicit Interface Implementation | System.Collections.IList.Remove | Removes a specified object from an array.

Expand image See Also

Reference

Array Class
System Namespace


ArrayList Class

ArrayList Class
See Also Members
CollapseAll image

Implements the IList interface by using an array whose size is dynamically increased, as necessary.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
[DebuggerDisplayAttribute]
[SerializableAttribute]
public class ArrayList : IList, ICollection, IEnumerable, ICloneable

Expand image Remarks

The capacity of an ArrayList collection is the maximum number of objects that the collection can contain. As objects are added to an ArrayList collection, its capacity is automatically increased through reallocation accordingly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Members
System.Collections Namespace


ArrayList Members

ArrayList Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the ArrayList type.

Expand image Public Constructors

 | Name | Description
Public Method | ArrayList | Initializes a new instance of the ArrayList class.

Expand image Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of objects that the ArrayList collection can contain.
Public Property | Count | Gets the number of objects that the ArrayList collection actually contains.
Public Property | IsFixedSize | Gets a value indicating whether the ArrayList collection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the ArrayList collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ArrayList collection is synchronized.
Public Property | Item | Gets or sets the object at the specified index number in the ArrayList collection.
Public Property | SyncRoot | Gets an object that you can use to synchronize access to the ArrayList collection.

Expand image Public Methods

 | Name | Description
Public Method | Add | Adds a specified object to the end of the ArrayList collection.
Public Method | BinarySearch | Searches the entire sorted ArrayList collection for a specified object by using the specified comparer; returns the zero-based index number of the object.
Public Method | Clear | Removes all objects from the ArrayList collection.
Public Method | Clone | Creates a shallow copy of the ArrayList collection.
Public Method | Contains | Determines whether a specified object is contained in the ArrayList collection.
Public Method | CopyTo | Overloaded. Copies objects from the ArrayList collection to a specified one-dimensional array.
Public Method | GetEnumerator | Returns an enumerator for the entire ArrayList collection.
Public Method | IndexOf | Overloaded. Returns the zero-based index number of the first occurrence of a specified object (if any) in either the entire ArrayList collection or a specified portion of it.
Public Method | Insert | Inserts a specified object into the ArrayList collection at a specified index number.
Public Method | Remove | Removes the first occurrence of a specified object from the ArrayList collection.
Public Method | RemoveAt | Removes the object at the specified index number in the ArrayList collection.
Public Method | ToArray | Overloaded. Copies objects from the ArrayList collection to a new array.

Expand image See Also

Reference

ArrayList Class
System.Collections Namespace


SerializationHintsAttribute.ArraySize Field

SerializationHintsAttribute.ArraySize Field

Specifies the size of a particular serialized array.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int ArraySize

Expand image Remarks

A value of -1 for the array size indicates that the array extends to the end of the stream.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Class
SerializationHintsAttribute Members
Microsoft.SPOT Namespace


Font.Ascent Property

Font.Ascent Property

Gets the ascent measurement for the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int Ascent { get; }

Property Value

The ascent measurement for the current font, in pixels.

Expand image Remarks

A font's ascent is the vertical distance between the font baseline and the top of the font area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Assembly Class

Assembly Class
See Also Members
CollapseAll image

Defines an Assembly object, which is a reusable, self-describing building block of a common language runtime (CLR) application. Note that you can create different versions of a single Assembly object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class Assembly

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Members
System.Reflection Namespace


Assembly Members

Assembly Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Assembly type.

Expand image Public Constructors

 | Name | Description
Public Method | Assembly | Initializes a new instance of the Assembly class.

Expand image Public Properties

 | Name | Description
Public Property | FullName | Gets the full name, or display name, of the current assembly.

Expand image Public Methods

 | Name | Description
 | GetAssembly | Gets the assembly in which a specified class (type) is defined.
Public Method | GetSatelliteAssembly | Gets a satellite assembly associated with a specified culture.
Public Method | GetType | Overloaded. Gets the Type object that represents a specified class (type).
Public Method | GetTypes | Gets the Type objects that represent all of the classes (types) defined in the current assembly.
 | Load | Overloaded. Loads a specified assembly.

Expand image See Also

Reference

Assembly Class
System.Reflection Namespace


Type.Assembly Property

Type.Assembly Property

Gets the Assembly object in which the current type is declared.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Assembly Assembly { get; }

Property Value

The Assembly object describing the assembly that contains the current type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


AssemblyCompanyAttribute Class

AssemblyCompanyAttribute Class
See Also Members
CollapseAll image

Defines a company name custom attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyCompanyAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCompanyAttribute Members
System.Reflection Namespace


AssemblyCompanyAttribute Members

AssemblyCompanyAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyCompanyAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyCompanyAttribute | Initializes a new instance of the AssemblyCompanyAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Company | Gets company name information.

Expand image See Also

Reference

AssemblyCompanyAttribute Class
System.Reflection Namespace


AssemblyConfigurationAttribute Class

AssemblyConfigurationAttribute Class
See Also Members
CollapseAll image

Defines an assembly configuration custom attribute (such as retail or debug) for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyConfigurationAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyConfigurationAttribute Members
System.Reflection Namespace


AssemblyConfigurationAttribute Members

AssemblyConfigurationAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyConfigurationAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyConfigurationAttribute | Initializes a new instance of the AssemblyConfigurationAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Configuration | Gets assembly configuration information.

Expand image See Also

Reference

AssemblyConfigurationAttribute Class
System.Reflection Namespace


AssemblyCopyrightAttribute Class

AssemblyCopyrightAttribute Class
See Also Members
CollapseAll image

Defines a copyright custom attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyCopyrightAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCopyrightAttribute Members
System.Reflection Namespace


AssemblyCopyrightAttribute Members

AssemblyCopyrightAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyCopyrightAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyCopyrightAttribute | Initializes a new instance of the AssemblyCopyrightAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Copyright | Gets copyright information.

Expand image See Also

Reference

AssemblyCopyrightAttribute Class
System.Reflection Namespace


AssemblyCultureAttribute Class

AssemblyCultureAttribute Class
See Also Members
CollapseAll image

Specifies the culture that a particular assembly supports.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyCultureAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCultureAttribute Members
System.Reflection Namespace


AssemblyCultureAttribute Members

AssemblyCultureAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyCultureAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyCultureAttribute | Initializes a new instance of the AssemblyCultureAttribute class with the culture supported by the assembly being attributed.

Expand image Public Properties

 | Name | Description
Public Property | Culture | Gets the culture supported by the assembly being attributed.

Expand image See Also

Reference

AssemblyCultureAttribute Class
System.Reflection Namespace


AssemblyDefaultAliasAttribute Class

AssemblyDefaultAliasAttribute Class
See Also Members
CollapseAll image

Defines a "friendly" default alias for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyDefaultAliasAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDefaultAliasAttribute Members
System.Reflection Namespace


AssemblyDefaultAliasAttribute Members

AssemblyDefaultAliasAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyDefaultAliasAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyDefaultAliasAttribute | Initializes a new instance of the AssemblyDefaultAliasAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | DefaultAlias | Gets the default alias information for an assembly.

Expand image See Also

Reference

AssemblyDefaultAliasAttribute Class
System.Reflection Namespace


AssemblyDelaySignAttribute Class

AssemblyDelaySignAttribute Class
See Also Members
CollapseAll image

Specifies that an assembly is not fully signed when it is created.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyDelaySignAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDelaySignAttribute Members
System.Reflection Namespace


AssemblyDelaySignAttribute Members

AssemblyDelaySignAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyDelaySignAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyDelaySignAttribute | Initializes a new instance of the AssemblyDelaySignAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | DelaySign | Gets a value that indicates the state of the AssemblyDelaySignAttribute attribute for the current assembly.

Expand image See Also

Reference

AssemblyDelaySignAttribute Class
System.Reflection Namespace


AssemblyDescriptionAttribute Class

AssemblyDescriptionAttribute Class
See Also Members
CollapseAll image

Defines an assembly description custom attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyDescriptionAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDescriptionAttribute Members
System.Reflection Namespace


AssemblyDescriptionAttribute Members

AssemblyDescriptionAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyDescriptionAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyDescriptionAttribute | Initializes a new instance of the AssemblyDescriptionAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Description | Gets the description text for the assembly being attributed.

Expand image See Also

Reference

AssemblyDescriptionAttribute Class
System.Reflection Namespace


AssemblyFlagsAttribute Class

AssemblyFlagsAttribute Class
See Also Members
CollapseAll image

Specifies whether the assembly being attributed supports side-by-side execution on the same computer, in the same process, or in the same application domain.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyFlagsAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyFlagsAttribute Members
System.Reflection Namespace


AssemblyFlagsAttribute Members

AssemblyFlagsAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyFlagsAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyFlagsAttribute | Overloaded. Initializes a new instance of the AssemblyFlagsAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Flags | Gets a value that represents the type of side-by-side execution that is supported for the assembly being attributed.

Expand image See Also

Reference

AssemblyFlagsAttribute Class
System.Reflection Namespace


Reflection.AssemblyInfo Class

Reflection.AssemblyInfo Class
See Also Members
CollapseAll image

Defines an AssemblyInfo object (an assembly), which is a self-describing building block of a common language runtime (CLR) application.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class Reflection.AssemblyInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo Members

Reflection.AssemblyInfo Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the Reflection.AssemblyInfo type.

Expand image Public Constructors

 | Name | Description
Public Method | Reflection.AssemblyInfo | Creates and initializes a new instance of the AssemblyInfo class.

Expand image Public Fields

 | Name | Description
 | c_Flags_NeedReboot | Contains a flag stating that after the current assembly is installed, the device must be rebooted.
 | c_Flags_Patch | Contains a flag stating that the current assembly is a patch for another assembly.
Public Field | m_flags | Contains flags that describe the current assembly.
Public Field | m_hash | Contains the assembly hash attribute, which is a unique identifier for the current assembly.
Public Field | m_name | Contains the name of the current assembly.
Public Field | m_refs | Contains an array of references to assemblies that the current assembly is dependent on.
Public Field | m_size | Specifies the size of the current assembly.

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Microsoft.SPOT Namespace


AssemblyInformationalVersionAttribute Class

AssemblyInformationalVersionAttribute Class
See Also Members
CollapseAll image

Defines additional version information for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyInformationalVersionAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyInformationalVersionAttribute Members
System.Reflection Namespace


AssemblyInformationalVersionAttribute Members

AssemblyInformationalVersionAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyInformationalVersionAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyInformationalVersionAttribute | Initializes a new instance of the AssemblyInformationalVersionAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | InformationalVersion | Gets the version information for the assembly being attributed.

Expand image See Also

Reference

AssemblyInformationalVersionAttribute Class
System.Reflection Namespace


AssemblyKeyFileAttribute Class

AssemblyKeyFileAttribute Class
See Also Members
CollapseAll image

Specifies the name of a file containing the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyKeyFileAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyFileAttribute Members
System.Reflection Namespace


AssemblyKeyFileAttribute Members

AssemblyKeyFileAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyKeyFileAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyKeyFileAttribute | Initializes a new instance of the AssemblyKeyFileAttribute class with the name of the file containing the key pair that is used to generate a strong name for the assembly being attributed.

Expand image Public Properties

 | Name | Description
Public Property | KeyFile | Gets the name of the file containing the key pair that is used to generate a strong name for the assembly being attributed.

Expand image See Also

Reference

AssemblyKeyFileAttribute Class
System.Reflection Namespace


AssemblyKeyNameAttribute Class

AssemblyKeyNameAttribute Class
See Also Members
CollapseAll image

Specifies the name of a key container within the Cryptographic Service Provider (CSP) that contains the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyKeyNameAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyNameAttribute Members
System.Reflection Namespace


AssemblyKeyNameAttribute Members

AssemblyKeyNameAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyKeyNameAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyKeyNameAttribute | Initializes a new instance of the AssemblyKeyNameAttribute class with the name of the container holding the key pair that is used to generate a strong name for the assembly being attributed.

Expand image Public Properties

 | Name | Description
Public Property | KeyName | Gets the name of the container holding the key pair that is used to generate a strong name for the assembly being attributed.

Expand image See Also

Reference

AssemblyKeyNameAttribute Class
System.Reflection Namespace


AssemblyNameFlags Enumeration

AssemblyNameFlags Enumeration

Provides information about an Assembly reference.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[FlagsAttribute]
[SerializableAttribute]
public enum AssemblyNameFlags

Expand image Members

Member name | Description
AppDomainPlatform |
EnableJITcompileOptimizer | Not currently implemented.
EnableJITcompileTracking | Not currently implemented.
Library |
LongevityMask |
LongevityUnspecified |
None | A value specifying that no flags are in effect.
ProcessPlatform |
PublicKey | A value specifying that a public key is formed from the full public key rather than from the public key token.
Retargetable | A value specifying that the assembly can be retargeted at run time to an assembly from a different publisher.
SystemPlatform |

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Reflection Namespace


AssemblyProductAttribute Class

AssemblyProductAttribute Class
See Also Members
CollapseAll image

Defines a product name custom attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyProductAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyProductAttribute Members
System.Reflection Namespace


AssemblyProductAttribute Members

AssemblyProductAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyProductAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyProductAttribute | Initializes a new instance of the AssemblyProductAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Product | Gets product name information.

Expand image See Also

Reference

AssemblyProductAttribute Class
System.Reflection Namespace


AssemblyTitleAttribute Class

AssemblyTitleAttribute Class
See Also Members
CollapseAll image

Defines an assembly title attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyTitleAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTitleAttribute Members
System.Reflection Namespace


AssemblyTitleAttribute Members

AssemblyTitleAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyTitleAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyTitleAttribute | Initializes a new instance of the AssemblyTitleAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Title | Gets assembly title information.

Expand image See Also

Reference

AssemblyTitleAttribute Class
System.Reflection Namespace


AssemblyTrademarkAttribute Class

AssemblyTrademarkAttribute Class
See Also Members
CollapseAll image

Defines a trademark attribute for an assembly manifest.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyTrademarkAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTrademarkAttribute Members
System.Reflection Namespace


AssemblyTrademarkAttribute Members

AssemblyTrademarkAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AssemblyTrademarkAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyTrademarkAttribute | Initializes a new instance of the AssemblyTrademarkAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Trademark | Gets trademark information for the assembly being attributed.

Expand image See Also

Reference

AssemblyTrademarkAttribute Class
System.Reflection Namespace


AssemblyVersionAttribute Class

AssemblyVersionAttribute Class
See Also Members
CollapseAll image

Specifies the version number of the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class AssemblyVersionAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyVersionAttribute Members
System.Reflection Namespace


AssemblyVersionAttribute Members

AssemblyVersionAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the AssemblyVersionAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AssemblyVersionAttribute | Initializes a new instance of the AssemblyVersionAttribute class with the version number of the assembly being attributed.

Expand image See Also

Reference

AssemblyVersionAttribute Class
System.Reflection Namespace


Debug.Assert Method (Boolean, String, String)

Debug.Assert Method (Boolean, String, String)
See Also
CollapseAll image

Causes a break in execution if the specified assertion (condition) evaluates to true.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[ConditionalAttribute]
public static void Assert (
         bool condition,
         string message,
         string detailedMessage
)

Parameters

condition
The condition to be evaluated. If the return value is true, program execution stops.
message
The text to be displayed if the assertion is true.
detailedMessage
The detailed message to be displayed if the assertion is true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.Assert Method (Boolean)

Debug.Assert Method (Boolean)
See Also
CollapseAll image

Causes a break in execution if the specified assertion (condition) evaluates to true.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[ConditionalAttribute]
public static void Assert (
         bool condition
)

Parameters

condition
The condition to be evaluated. If the return value is true, program execution stops.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.Assert Method (Boolean, String)

Debug.Assert Method (Boolean, String)
See Also
CollapseAll image

Causes a break in execution if the specified assertion (condition) evaluates to true.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[ConditionalAttribute]
public static void Assert (
         bool condition,
         string message
)

Parameters

condition
The condition to be evaluated. If the return value is true, program execution stops.
message
The text to be displayed if the assertion is true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.Assert Method

Debug.Assert Method

Causes a break in execution if the specified assertion (condition) evaluates to true.

Expand image Overload List

Name | Description
Debug.Assert (Boolean) | Causes a break in execution if the specified assertion (condition) evaluates to true.
Debug.Assert (Boolean, String) | Causes a break in execution if the specified assertion (condition) evaluates to true.
Debug.Assert (Boolean, String, String) | Causes a break in execution if the specified assertion (condition) evaluates to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


AsyncCallback Delegate

AsyncCallback Delegate

References the callback method to be invoked when an asynchronous operation is completed.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public delegate void AsyncCallback (
         IAsyncResult ar
)

Parameters

ar
The result of the asynchronous operation.

Expand image Remarks

The declaration of your callback method must have the same parameters as the AsyncCallback delegate declaration.

The AsyncCallback delegate provides a way for client applications to complete an asynchronous operation. This callback delegate is supplied to the client when the asynchronous operation is initiated. The event handler referenced by AsyncCallback contains program logic to finish processing the asynchronous task for the client.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


Attribute Class

Attribute Class
See Also Members
CollapseAll image

Constitutes the base class for custom attributes.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public abstract class Attribute

Expand image Remarks

Although you can use any user-defined type as an attribute, it is expected that most attributes will be instances of types derived from the Attribute class.

All attributes derive directly or indirectly from the Attribute class. You can apply attributes to any target object. In addition, you can apply multiple instances of an attribute to the same target object. Note that attributes can also be inherited by an object derived from a target object. Compilers and other development tools use this information to identify which attributes are custom attributes.

You can store custom attributes with any element of the metadata. This mechanism makes it easy to store application-specific information at compile time and then access it either at run time or when another tool reads the metadata.

The .NET Micro Framework predefines some attribute types and uses them to control run-time behavior. Developers are encouraged to define and use additional attribute types, as needed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Attribute Members
System Namespace


Attribute Members

Attribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the Attribute type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Attribute | Initializes a new instance of the Attribute class.

Expand image See Also

Reference

Attribute Class
System Namespace


AttributeTargets Enumeration

AttributeTargets Enumeration

Contains the application elements on which it is valid to apply an attribute.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[FlagsAttribute]
[SerializableAttribute]
public enum AttributeTargets

Expand image Members

Member name | Description
All = 16383 | A value that enables you to apply an attribute to any application element.
Assembly = 1 | A value that enables you to apply an attribute to an assembly.
Class = 4 | A value that enables you to apply an attribute to a class.
Constructor = 32 | A value that enables you to apply an attribute to a constructor.
Delegate = 4096 | A value that enables you to apply an attribute to a delegate.
Enum = 16 | A value that enables you to apply an attribute to an enumeration.
Event = 512 | A value that enables you to apply an attribute to an event.
Field = 256 | A value that enables you to apply an attribute to a field.
Interface = 1024 | A value that enables you to apply an attribute to an interface.
Method = 64 | A value that enables you to apply an attribute to a method.
Module = 2 | A value that enables you to apply an attribute to a module. A module is a portable executable file (.dll or .exe).
Parameter = 2048 | A value that enables you to apply an attribute to a parameter.
Property = 128 | A value that enables you to apply an attribute to a property.
ReturnValue = 8192 | A value that enables you to apply an attribute to a return value.
Struct = 8 | A value that enables you to apply an attribute a structure (a value type).

Expand image Remarks

You can combine the members of this enumeration by using a bitwise OR.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


AttributeUsageAttribute Class

AttributeUsageAttribute Class
See Also Members
CollapseAll image

Specifies the usage of another attribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class AttributeUsageAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

When you are defining your own attribute class, you can control the manner in which it is used by assigning an AttributeUsageAttribute object to your attribute class. Note that your attribute class must derive from the Attribute class, either directly or indirectly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AttributeUsageAttribute Members
System Namespace


AttributeUsageAttribute Members

AttributeUsageAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the AttributeUsageAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | AttributeUsageAttribute | Initializes a new instance of the AttributeUsageAttribute class with a specified list of AttributeTargets values.

Expand image Public Properties

 | Name | Description
Public Property | AllowMultiple | Gets or sets a Boolean value that indicates whether you can specify more than one instance of the specified attribute for a single program element.
Public Property | Inherited | Gets or sets a Boolean value that indicates whether the specified attribute can be inherited by derived classes and overriding members.
Public Property | ValidOn | Gets a set of values that indicate which program elements you can apply the specified attribute to.

Expand image See Also

Reference

AttributeUsageAttribute Class
System Namespace


AutoResetEvent Class

AutoResetEvent Class
See Also Members
CollapseAll image

Notifies a waiting thread that an event has occurred.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public sealed class AutoResetEvent : WaitHandle

Expand image Remarks

This class cannot be inherited.

The AutoResetEvent class represents a local wait handle event that resets automatically when signaled, after releasing a single waiting thread. An AutoResetEvent object is automatically reset to non-signaled by the system after a single waiting thread has been released.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AutoResetEvent Members
System.Threading Namespace


AutoResetEvent Members

AutoResetEvent Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the AutoResetEvent type.

Expand image Public Constructors

 | Name | Description
Public Method | AutoResetEvent | Initializes a new instance of the AutoResetEvent class with a Boolean value that indicates whether the initial state of the specified event is set to signaled.

Expand image Public Methods

 | Name | Description
Public Method | Reset | Sets the state of the specified event to nonsignaled.
Public Method | Set | Sets the state of the specified event to signaled.

Expand image See Also

Reference

AutoResetEvent Class
System.Threading Namespace


Font.AverageWidth Property

Font.AverageWidth Property

Gets the average width of the characters in the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int AverageWidth { get; }

Property Value

The average width of the characters in the current font, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Control._background Field

Control._background Field

Contains the brush used to paint a control's background.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected internal Brush _background

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Control.Background Property

Control.Background Property

Gets or sets the brush used to paint a control's background.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Brush Background { get; set; }

Property Value

The brush used to paint the control's background.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Type.BaseType Property

Type.BaseType Property

Gets the type from which the current type directly inherits.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type BaseType { get; }

Property Value

The type from which the current type directly inherits, or a null reference if the current type represents the Object type.

Expand image Remarks

The base type is the type from which the current type directly inherits. The Object type is the only type that does not have a base type; therefore, a null reference is returned as the base type for the Object type.

Interfaces inherit from the Object type and from 0 (zero) or more base interfaces; therefore, the Object type is considered to be the base type for interfaces.

This property is read-only.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Dispatcher.BeginInvoke Method

Dispatcher.BeginInvoke Method

Executes a specified delegate on the thread on which a particular Dispatcher object (dispatcher) was created.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherOperation BeginInvoke (
         Delegate method,
         Object[] args
)

Parameters

method
A delegate to a method that takes one argument, which is pushed into the dispatcher's event queue.
args
[ParamArrayAttribute] The object to be passed as an argument to the delegate.

Return Value

An object, which is returned immediately after the BeginInvoke method is called, that can be used to interact with the delegate as it is pending execution in the event queue.

Expand image Remarks

The arg parameter can be a null reference if no arguments are needed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


TimeZoneInformation.Bias Field

TimeZoneInformation.Bias Field

Specifies the current bias for local time translation on this operating system, in minutes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int Bias

Expand image Remarks

The bias is the difference, in minutes, between Coordinated Universal Time (UTC) and local time. All translations between UTC and local time are based on the following formula:

UTC = local time + bias

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


Array.BinarySearch Method (Array, Object, IComparer)

Array.BinarySearch Method (Array, Object, IComparer)
See Also
CollapseAll image

Searches an entire one-dimensional sorted array for a specified value, using the specified IComparer interface.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int BinarySearch (
         Array array,
         Object value,
         IComparer comparer
)

Parameters

array
The one-dimensional array you want to search.
value
The object you want to search for.
comparer
The IComparer implementation you want to use when comparing elements. If this parameter is null, the Array.BinarySearch method uses the IComparable implementation of each object in the array.

Return Value

The index number of the specified value in the specified array, if the value is found in the array.

-or-

A negative number, which is the bitwise complement of the index number of the first object that is larger than the specified value, if that value is not found and it is less than at least one of the objects in the array.

-or-

A negative number, which is the bitwise complement of the index number of the last object in the array plus 1, if the specified value is not found and it is greater than at least one of the objects in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


Array.BinarySearch Method

Array.BinarySearch Method

Searches a one-dimensional sorted array for a specified value, using a binary search algorithm.

Expand image Overload List

Name | Description
Array.BinarySearch (Array, Int32, Int32, Object, IComparer) | Searches a specified range within a one-dimensional sorted array for a specified value, using the specified IComparer interface.
Array.BinarySearch (Array, Object, IComparer) | Searches an entire one-dimensional sorted array for a specified value, using the specified IComparer interface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.BinarySearch Method

ArrayList.BinarySearch Method

Searches the entire sorted ArrayList collection for a specified object by using the specified comparer; returns the zero-based index number of the object.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int BinarySearch (
         Object value,
         IComparer comparer
)

Parameters

value
The object you want to locate. This value can be a null reference.
comparer

The IComparer implementation you want to use when comparing objects.

-or-

A null reference that causes this method to use the default comparer associated with the type of each object.

Return Value

The zero-based index number of the specified object in the sorted ArrayList collection, if the object is found in the collection. If the object is not found, this is a negative number that is the bitwise complement of the index number of the next object whose value parameter is larger than that of the specified object; or, if there is no object with a larger value parameter, this is the bitwise complement of the value of the Count property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.BinarySearch Method (Array, Int32, Int32, Object, IComparer)

Array.BinarySearch Method (Array, Int32, Int32, Object, IComparer)
See Also
CollapseAll image

Searches a specified range within a one-dimensional sorted array for a specified value, using the specified IComparer interface.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int BinarySearch (
         Array array,
         int index,
         int length,
         Object value,
         IComparer comparer
)

Parameters

array
The one-dimensional array containing the range you want to search.
index
The starting index number of the range you want to search.
length
The length of the range you want to search.
value
The object you want to search for in the range.
comparer
The IComparer implementation you want to use when comparing objects. If this parameter is null, the Array.BinarySearch method uses the IComparable implementation of each object in the search range.

Return Value

The index number of the specified value in the specified array, if that value is found in the array.

-or-

A negative number, which is the bitwise complement of the index number of the first object that is larger than the specified value, if that value is not found and it is less than at least one of the objects in the array.

-or-

A negative number, which is the bitwise complement of the index number of the last object in the array plus 1, if the specified value is not found and it is greater than at least one of the objects in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


Binder Class

Binder Class
See Also Members
CollapseAll image

Selects a member from a list of candidates, and performs a type conversion from actual argument type to formal argument type.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class Binder

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Binder Members
System.Reflection Namespace


Binder Members

Binder Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the Binder type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Binder | Initializes a new instance of the Binder class.

Expand image See Also

Reference

Binder Class
System.Reflection Namespace


BindingFlags Enumeration

BindingFlags Enumeration

Contains flags that control binding and the way in which the search for members and types is conducted by reflection.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[FlagsAttribute]
[SerializableAttribute]
public enum BindingFlags

Expand image Members

Member name | Description
CreateInstance | A binding flag specifying that reflection should create an instance of the specified type. Reflection calls the constructor that matches the given arguments. The provided member name is ignored. If the type of lookup is not specified, (Instance | Public) will apply. It is not possible to call a type initializer.
DeclaredOnly | A binding flag specifying that only members declared at the level of the supplied type's hierarchy should be considered. Inherited members are not considered.
Default | A value indicating that there is no binding flag.
ExactBinding

A binding flag specifying that types of the provided arguments must exactly match the types of the corresponding formal parameters. Reflection throws an exception if the caller supplies a non-null Binder object, because that implies that the caller is providing BindToX implementations (where X represents the name of a method that begins with BindTo) that will select the appropriate method.

Reflection models the accessibility rules of the common type system. For example, if the caller is in the same assembly, the caller does not need special permissions for internal members. Otherwise, the caller needs ReflectionPermission. This is consistent with the rules for looking up members that are protected, private, and so on.

The general principle is that the ChangeType method should perform only widening coercions, which never lose data. An example of a widening coercion is the coercion of a value that is a 32-bit signed integer to a value that is a 64-bit signed integer. This is distinguished from a narrowing coercion, which may lose data. An example of a narrowing coercion is the coercion of a 64-bit signed integer to a 32-bit signed integer.

The default binder ignores this flag, whereas custom binders can implement the semantics of this flag.

FlattenHierarchy | A binding flag specifying that static members that are farther up the hierarchy should be returned. Static members include fields, methods, events, and properties. Nested types are not returned.
GetField | A binding flag specifying that the value of the specified field should be returned.
GetProperty | A binding flag specifying that the value of the specified property should be returned.
IgnoreCase | A binding flag specifying that the case of the member name should not be considered when binding.
IgnoreReturn | A binding flag used in COM interop to specify that the return value of the member can be ignored.
Instance | A binding flag specifying that instance members are to be included in the search.
InvokeMethod | A binding flag specifying that a method is to be invoked. This cannot be a constructor or a type initializer.
NonPublic | A binding flag specifying that nonpublic members are to be included in the search.
OptionalParamBinding

A binding flag that returns the set of members whose parameter count matches the number of provided arguments. This flag is used for methods with parameters that have default values and for methods with variable arguments (varargs). Note that this flag should be passed only to the Type.InvokeMember method.

Parameters with default values are used only in calls in which trailing arguments are omitted. Those parameters must be the last arguments.

Public | A binding flag specifying that the PROPPUT member on a COM object should be invoked. PROPPUT specifies a property-setting function that uses a value. Use PutDispProperty if a property has both PROPPUT and PROPPUTREF and you need to specify which one is to be called.
PutDispProperty | A binding flag specifying that the PROPPUTREF member on a COM object should be invoked. PROPPUTREF specifies a property-setting function that uses a reference instead of a value. Use PutRefDispProperty if a property has both PROPPUT and PROPPUTREF and you need to specify which one is to be called.
PutRefDispProperty | A binding flag specifying that the PROPPUTREF member on a COM object should be invoked. PROPPUTREF specifies a property-setting function that uses a reference instead of a value. Use PutRefDispProperty if a property has both PROPPUT and PROPPUTREF and you need to specify which one is to be called.
SetField | A binding flag specifying that the value of the specified field should be set.
SetProperty | A binding flag specifying that the value of the specified property should be set. For COM properties, specifying this binding flag is equivalent to specifying PutDispProperty and PutRefDispProperty.
Static | A binding flag specifying that static members are to be included in the search.
SuppressChangeType | Not currently implemented.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Reflection Namespace


Bitmap.BitBlt Method

Bitmap.BitBlt Method

Performs a bit block transfer of the bitmap data corresponding to a rectangle of pixels, transferring the data from a specified source bitmap into the current destination bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void BitBlt (
         int xDst,
         int yDst,
         int nWidth,
         int nHeight,
         Bitmap pSrc,
         int xSrc,
         int ySrc,
         int dwRop
)

Parameters

xDst
The x-coordinate of the upper-left corner of the destination rectangle.
yDst
The y-coordinate of the upper-left corner of the destination rectangle.
nWidth
The width of the source and destination rectangles.
nHeight
The height of the source and destination rectangles.
pSrc
The source bitmap.
xSrc
The x-coordinate of the upper-left corner of the source rectangle.
ySrc
The y-coordinate of the upper-left corner of the source rectangle.
dwRop
A raster operation code. This code defines how the bitmap data for the source rectangle is to be combined with the bitmap data for the destination rectangle.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.Bitmap Property

DrawingContext.Bitmap Property

Gets the bitmapped image that the current DrawingContext object uses as its drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Bitmap Bitmap { get; }

Property Value

A Bitmap object that specifies the bitmapped image used as the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Image.Bitmap Property

Image.Bitmap Property

Gets or sets an Image control's bitmap.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Bitmap Bitmap { get; set; }

Property Value

The Image control's bitmap image.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


Bitmap Class

Bitmap Class
See Also Members
CollapseAll image

Encapsulates a bitmap, which consists of the pixel data for a graphics image and its methods and attributes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public sealed class Bitmap : MarshalByRefObject

Expand image Remarks

This class cannot be inherited.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

The .NET Micro Framework currently provides support for the following bitmap types.

  • 1bpp Indexed
  • 24bpp RGB
  • 32bpp RGB
  • 48bpp RGB
  • 16bpp RGB 555 (five bits for each color, one bit unused)
  • 16bpp RGB 556 (five bits each for red and blue, six bits for green)

If you add a bitmap to a resource file, your project must reference the assemblies Microsoft.SPOT.Graphics.dll and Microsoft.SPOT.TinyCore.dll.

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Members
Microsoft.SPOT Namespace


Bitmap Members

Bitmap Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Bitmap type.

Expand image Public Constructors

 | Name | Description
Public Method | Bitmap | Overloaded. Initializes a new instance of the Bitmap class to the specified height and width.

Expand image Public Fields

Name | Description
BLACKNESS | Fills the destination rectangle with the color associated with index number 0 in the physical palette.
CenterX | Represents the x-coordinate location of the center of the display device, in pixels.
CenterY | Represents the y-coordinate location of the center of the display device, in pixels.
DSTDKGRAY | Fills the destination rectangle with a dark gray color.
DSTGRAY | Fills the destination rectangle with a gray color.
DSTINVERT | Inverts the destination rectangle.
DSTLTGRAY | Fills the destination rectangle with a light gray color.
DT_AlignmentCenter | Specifies that text is center-aligned as it flows around a bitmap.
DT_AlignmentLeft | Specifies that text is left-aligned as it flows around a bitmap.
DT_AlignmentMask | Specifies that you can use a mask to get or set text alignment around a bitmap.
DT_AlignmentRight | Specifies that text is right-aligned as it flows around a bitmap.
DT_Ellipsis | Specifies that the bitmap text is trimmed to the nearest character, and an ellipsis is inserted at the end of each trimmed line.
DT_IgnoreHeight | Specifies that if the bitmap text is larger than the space provided, the text is drawn in its full size, rather than being scaled down to fit the value in the Height property.
DT_None | Specifies that there are no format rules.
DT_TruncateAtBottom | Specifies that if the bitmap text is larger than the space provided, the text is truncated at the bottom.
DT_WordWrap | Specifies whether a line of bitmap text automatically wraps words to the beginning of the next line when the line reaches its maximum width.
MaxHeight | Specifies the maximum height of the display device, in pixels.
MaxWidth | Specifies the maximum width of the display device, in pixels.
OpacityOpaque | Specifies that the current bitmap is opaque.
OpacityTransparent | Specifies that the current bitmap is transparent.
PATINVERT | Inverts the source rectangle.
RANDOM | Fills the destination rectangle or circle with a randomly generated pattern.
SINGLEPIXEL | Specifies that a circle should have only a single-pixel border and no fill pattern or color.
SRCCOPY | Copies the source rectangle directly to the destination rectangle.
WHITENESS | Fills the destination rectangle with the color associated with index number 1 in the physical palette.

Expand image Public Properties

 | Name | Description
Public Property | Height | Gets the height of the current bitmap.
Public Property | Width | Gets the width of the current bitmap.

Expand image Public Methods

 | Name | Description
Public Method | BitBlt | Performs a bit block transfer of the bitmap data corresponding to a rectangle of pixels, transferring the data from a specified source bitmap into the current destination bitmap.
Public Method | Circle | Draws a circle specified by a coordinate pair (x and y) and a radius, using a specified raster operation.
Public Method | Clear | Clears the entire drawing surface.
Public Method | DrawEllipse | Overloaded. Draws a filled ellipse on the display device.
Public Method | DrawImage | Overloaded. Draws a rectangular block of pixels on the display device.
Public Method | DrawLine | Draws a line on the display device.
Public Method | DrawRectangle | Overloaded. Draws a rectangle on the display device.
Public Method | DrawText | Overloaded. Draws text on the display device.
Public Method | DrawTextInRect | Overloaded. Draws text in a specified rectangle.
Public Method | Flush | Overloaded. Flushes the current bitmap to the display device.
Public Method | GetPixel | Retrieves the pixel color at a specified location on the display device.
Public Method | Line | Draws a line connecting the two points specified by two coordinate (x,y) pairs.
Public Method | MakeTransparent | Sets a bitmap's transparent color.
Public Method | MaskBlt | Combines the data for the source bitmap and the current (destination) bitmap, using the specified mask.
Public Method | PatBlt | Creates a bit pattern on a bitmap.
Public Method | ResetClippingRectangle | Resets a bitmap's clipping region (clipping rectangle) to the entire bitmap.
Public Method | RotateBlt | Rotates a bitmap to a specified degree around a specified point.
Public Method | SetClippingRectangle | Sets the clipping region (clipping rectangle) of a bitmap with a specified coordinate pair (x,y), width, and height.
Public Method | SetPixel | Overloaded. Turns a specified pixel on or off.
Public Method | StretchImage | Draws a rectangular block of pixels on the display device, stretching or shrinking the rectangular area as necessary.
Public Method | TransparentBlt | Combines the data for the specified source bitmap and the current bitmap (destination bitmap) in a defined rectangular area.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image See Also

Reference

Bitmap Class
Microsoft.SPOT Namespace


Bitmap.BitmapImageType Enumeration

Bitmap.BitmapImageType Enumeration

Lists the available formats for bitmap images.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Bitmap.BitmapImageType

Expand image Members

Member name | Description
Bmp | A bitmap in Windows BMP format.
Gif | A bitmap in GIF format.
Jpeg | A bitmap in JPEG format.
TinyCLRBitmap | A bitmap in a format specific to the .NET Micro Framework common language runtine (CLR).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


ImageBrush.BitmapSource Field

ImageBrush.BitmapSource Field

Specifies the bitmapped image that is used as the brush's paint, or fill.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Bitmap BitmapSource

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ImageBrush Class
ImageBrush Members
Microsoft.SPOT.Presentation.Media Namespace


SerializationHintsAttribute.BitPacked Field

SerializationHintsAttribute.BitPacked Field

Specifies the number of bits in which the current object is bit-packed.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int BitPacked

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Class
SerializationHintsAttribute Members
Microsoft.SPOT Namespace


Colors.Black Field

Colors.Black Field

The system-defined color that has an RGB value of #000000.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color Black

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.BLACKNESS Field

Bitmap.BLACKNESS Field

Fills the destination rectangle with the color associated with index number 0 in the physical palette.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int BLACKNESS

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.BlendImage Method

DrawingContext.BlendImage Method

Overlays a specified bitmapped image on an image that already exists on the drawing surface, and displays the resulting overlayed image at a specified location (position) on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void BlendImage (
         Bitmap source,
         int destinationX,
         int destinationY,
         int sourceX,
         int sourceY,
         int sourceWidth,
         int sourceHeight,
         UInt16 opacity
)

Parameters

source
A Bitmap object that specifies the bitmapped image.
destinationX
The upper-left horizontal position at which the overlayed image is to be displayed.
destinationY
The upper-left vertical position at which the overlayed image is to be displayed.
sourceX
The upper-left horizontal position of the existing image.
sourceY
The upper-left vertical position of the existing image.
sourceWidth
The width of the existing image.
sourceHeight
The height of the existing image.
opacity
The opacity of the bitmapped image when overlayed on the existing image. A value of 0 (zero) makes the bitmap completely opaque (not transparent at all); a value of 255 makes the bitmap completely transparent.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Colors.Blue Field

Colors.Blue Field

The system-defined color that has an RGB value of #0000FF.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color Blue

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


Boolean Structure

Boolean Structure

Represents a Boolean value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Boolean

Expand image Remarks

Instances of this type have values of either true or false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Boolean Members
System Namespace


Boolean Members

Boolean Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Boolean type.

Expand image Public Fields

Name | Description
FalseString | Represents the Boolean value false as a string. This field is read-only.
TrueString | Represents the Boolean value true as a string. This field is read-only.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current Boolean object to its equivalent string representation.

Expand image See Also

Reference

Boolean Structure
System Namespace


Border Class

Border Class
See Also Members
CollapseAll image

Draws a border around another user interface element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Border : ContentControl

Expand image Remarks

If you want to display a border around specific content, you must place that content within a parent border element, this making the enclosed content a child element. Note that the parent border element, as represented by the Border object, can contain only one discrete child element. To display multiple child elements, you need to place a panel element, which is represented by the Panel object, within the parent border element. You can then place multiple child elements within that panel element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Border Members

Border Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Border type.

Expand image Public Constructors

 | Name | Description
Public Method | Border | Initializes a new instance of the Border class.

Expand image Public Properties

 | Name | Description
Public Property | BorderBrush | Gets or sets the brush used to paint a border.

Expand image Public Methods

 | Name | Description
Public Method | GetBorderThickness | Retrieves the thickness of a specific border, in pixels.
Public Method | OnRender | Draws a border and its background to the display device (screen).
Public Method | SetBorderThickness | Overloaded. Sets the thickness of a particular border, in pixels.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Positions and determines the size of a user interface child element on the screen.
Protected Method | MeasureOverride | Measures the size of the space required for a particular child element, during layout.

Expand image See Also

Reference

Border Class
Microsoft.SPOT.Presentation.Controls Namespace


Border.BorderBrush Property

Border.BorderBrush Property

Gets or sets the brush used to paint a border.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Brush BorderBrush { get; set; }

Property Value

The brush used to paint the border.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Debugger.Break Method

Debugger.Break Method

Signals a breakpoint to an attached debugger.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Break ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debugger Class
Debugger Members
System.Diagnostics Namespace


Brush Class

Brush Class
See Also Members
CollapseAll image

Paints, or fills, an area or shape on the screen.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class Brush

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Brush Members
Microsoft.SPOT.Presentation.Media Namespace


Brush Members

Brush Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the Brush type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Brush | Initializes a new instance of the Brush class.

Expand image Public Fields

 | Name | Description
Public Field | Opacity | Specifies the degree of opacity of the brush's paint or fill.

Expand image See Also

Reference

Brush Class
Microsoft.SPOT.Presentation.Media Namespace


ButtonEventArgs.Button Field

ButtonEventArgs.Button Field

Specifies the button that was used to enter the input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Button Button

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


Button Enumeration

Button Enumeration

Identifies a button on a button device.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Button

Expand image Members

Member name | Description
Down | The Down Arrow button.
FastForward | The Fast-Forward button.
Last | The End button.
Left | The Left Arrow button.
Menu | The Menu button.
None | No button is specified.
Pause | The Pause button.
Play | The Play button.
Rewind | The Rewind button.
Right | The Right Arrow button.
Select | The Select button.
Stop | The Stop button.
Up | The Up Arrow button.

Expand image Remarks

The values of the Button enumeration are not mapped to physical buttons. The mapping is handled by the ButtonDevice, Buttons, and ButtonEventArgs classes. The Button enumerated values are used by the other classes to specify a particular button in order to monitor the button's state.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


RawButtonInputReport.Button Field

RawButtonInputReport.Button Field

Specifies the button that is currently generating input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Button Button

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RawButtonInputReport Class
RawButtonInputReport Members
Microsoft.SPOT.Input Namespace


ButtonDevice Class

ButtonDevice Class
See Also Members
CollapseAll image

Represents a hardware device that has buttons on it for inputing data.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class ButtonDevice : InputDevice

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Members
Microsoft.SPOT.Input Namespace


ButtonDevice Members

ButtonDevice Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the ButtonDevice type.

Expand image Public Properties

 | Name | Description
Public Property | Target | Gets the display element that receives input from a particular button device.

Expand image Public Methods

 | Name | Description
Public Method | Focus | Moves the focus for a button device to the specified display element.
Public Method | GetButtonState | Gets the state of a specified button.
Public Method | IsButtonDown | Determines whether a specified button has been pressed.
Public Method | IsButtonHeld | Determines whether the specified button has been pressed and whether it remained in the down position for a period of time when it was pressed.
Public Method | IsButtonUp | Determines whether a specified button is currently in the up position (that is, not pressed down).

Expand image See Also

Reference

ButtonDevice Class
Microsoft.SPOT.Input Namespace


Buttons.ButtonDownEvent Field

Buttons.ButtonDownEvent Field

Specifies the bubbling-routed event that occurs when a button on a button device is pressed.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent ButtonDownEvent

Expand image Remarks

The ButtonDownEvent field specifies a routed event that uses the bubbling routing strategy. The event handler for this event is represented by the ButtonEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


ButtonEventArgs Class

ButtonEventArgs Class
See Also Members
CollapseAll image

Provides data for a button input event.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ButtonEventArgs : InputEventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


ButtonEventArgs Members

ButtonEventArgs Members
See Also Constructors Fields Properties
CollapseAll image

The following tables list the members exposed by the ButtonEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | ButtonEventArgs | Initializes a new instance of the ButtonEventArgs class, using specified values.

Expand image Public Fields

 | Name | Description
Public Field | Button | Specifies the button that was used to enter the input.
Public Field | InputSource | Specifies the source of the button input.

Expand image Public Properties

 | Name | Description
Public Property | ButtonState | Gets the current state of the button input.
Public Property | IsRepeat | Gets a value that indicates whether the button input is currently repeating.

Expand image See Also

Reference

ButtonEventArgs Class
Microsoft.SPOT.Input Namespace


ButtonEventHandler Delegate

ButtonEventHandler Delegate

Represents the method that handles button-related input events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void ButtonEventHandler (
         Object sender,
         ButtonEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


Buttons Class

Buttons Class
See Also Members
CollapseAll image

Represents the buttons on an input device that is represented by a ButtonDevice object.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class Buttons

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Members
Microsoft.SPOT.Input Namespace


Buttons Members

Buttons Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Buttons type.

Expand image Public Constructors

 | Name | Description
Public Method | Buttons | Initializes a new instance of the Buttons class.

Expand image Public Fields

Name | Description
ButtonDownEvent | Specifies the bubbling-routed event that occurs when a button on a button device is pressed.
ButtonUpEvent | Specifies the bubbling-routed event that occurs when a button on a button device is released.
GotFocusEvent | Specifies the bubbling-routed event that occurs when a display element on a button device receives the button focus.
LostFocusEvent | Specifies the bubbling-routed event that occurs when a display element on a button device loses the button focus.
PreviewButtonDownEvent | Specifies the tunneling-routed event that occurs when a button on a button device is pressed.
PreviewButtonUpEvent | Specifies the tunneling-routed event that occurs when a button on a button device is released.

Expand image Public Properties

Name | Description
FocusedElement | Gets the display element that currently has the button focus.
PrimaryDevice | Gets the primary button input device with which the current Buttons object is associated.

Expand image Public Methods

Name | Description
Focus | Moves the button focus to a specified display element.
GetButtonState | Gets the state of a specified button.
IsButtonDown | Determines whether a specifed button is currently pressed down.
IsButtonHeld | Determines whether the specified button is currently being held down.
IsButtonUp | Determines whether a specified button is currently in the up position (that is, not pressed down).

Expand image See Also

Reference

Buttons Class
Microsoft.SPOT.Input Namespace


ButtonEventArgs.ButtonState Property

ButtonEventArgs.ButtonState Property

Gets the current state of the button input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ButtonState ButtonState { get; }

Property Value

A value of the ButtonState enumeration that indicates the current state of the button input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


ButtonState Enumeration

ButtonState Enumeration

Specifies the state of a button's input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[FlagsAttribute]
public enum ButtonState

Expand image Members

Member name | Description
Down | A value specifying that the input is currently in the down state. That is, the input corresponds to the button being pressed.
Held | A value specifying that the input is currently in the held state. That is, the input corresponds to the button being held down.
None | No input. That is, the button is not currently being pressed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


Buttons.ButtonUpEvent Field

Buttons.ButtonUpEvent Field

Specifies the bubbling-routed event that occurs when a button on a button device is released.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent ButtonUpEvent

Expand image Remarks

The ButtonUpEvent field specifies a routed event that uses the bubbling routing strategy. The event handler for this event is represented by the ButtonEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


Byte Structure

Byte Structure

Represents a 8-bit unsigned integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Byte

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Members
System Namespace


Byte Members

Byte Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Byte type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of Byte Structure. This field is constant.
MinValue | Represents the smallest possible value of Byte Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current Byte object to its equivalent string representation.

Expand image See Also

Reference

Byte Structure
System Namespace


CancelEventArgs.Cancel Field

CancelEventArgs.Cancel Field

Contains a value that indicates whether a specific event should be canceled.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Cancel

Expand image Remarks

Setting this field to true specifies that the event should be canceled; setting it to false specifies that the event should not be canceled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CancelEventArgs Class
CancelEventArgs Members
Microsoft.SPOT Namespace


PreProcessInputEventArgs.Cancel Method

PreProcessInputEventArgs.Cancel Method

Cancels the processing of raw input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Cancel ()

Expand image Remarks

Canceling the processing of raw input will remove it from the input staging area. The input will not be converted to a series of Windows Presentation Foundation (WPF) events.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PreProcessInputEventArgs Class
PreProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


PreProcessInputEventArgs.Canceled Property

PreProcessInputEventArgs.Canceled Property

Gets a value that indicates whether input processing has been canceled.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Canceled { get; }

Property Value

true if input processing has been canceled; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PreProcessInputEventArgs Class
PreProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


CancelEventArgs Class

CancelEventArgs Class
See Also Members
CollapseAll image

Provides data for an event that can be canceled.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class CancelEventArgs : EventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CancelEventArgs Members
Microsoft.SPOT Namespace


CancelEventArgs Members

CancelEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the CancelEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | CancelEventArgs | Initializes a new instance of the CancelEventArgs class.

Expand image Public Fields

 | Name | Description
Public Field | Cancel | Contains a value that indicates whether a specific event should be canceled.

Expand image See Also

Reference

CancelEventArgs Class
Microsoft.SPOT Namespace


CancelEventHandler Delegate

CancelEventHandler Delegate

Provides the method that handles a cancelable event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void CancelEventHandler (
         Object sender,
         CancelEventArgs e
)

Parameters

sender
The sender (source) of the event.
e
Data describing the event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


Canvas Class

Canvas Class
See Also Members
CollapseAll image

Defines an area, or canvas, within which you can explicitly position child elements by using coordinates that are relative to the upper-left corner of the canvas.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Canvas : Panel

Expand image Remarks

A Canvas object represents the canvas element in the layout of a group of user interface elements. Likewise, all of the user interface elements on the canvas are seen as child elements of the canvas and are represented by instances of classes derived from the UIElement class. The Canvas object manages this collection of child elements. The children of a Canvas object are also referred to as child controls.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


Canvas Members

Canvas Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the Canvas type.

Expand image Public Constructors

 | Name | Description
Public Method | Canvas | Initializes a new instance of the Canvas class.

Expand image Public Methods

Name | Description
GetBottom | Retrieves the row number of the bottom of the rectangular area that contains a specified child element.
GetLeft | Retrieves the number of the leftmost column in the rectangular area that contains a specified child element.
GetRight | Retrieves the number of the rightmost column in the rectangular area that contains a specified child element.
GetTop | Retrieves the row number of the top of the rectangular area that contains a specified child element.
SetBottom | Sets the row number of the bottom of the rectangular area that contains a specified child element.
SetLeft | Sets the number of the leftmost column in the rectangular area that contains a specified child element.
SetRight | Sets the rightmost column number in the area that contains the specified child element.
SetTop | Sets the row number of the top of the area that contains the specified child element.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Arranges the contents of a specific canvas element.
Protected Method | MeasureOverride | Measures the child elements in a canvas in anticipation of arranging them during the ArrangeOverride pass.

Expand image See Also

Reference

Canvas Class
Microsoft.SPOT.Presentation.Controls Namespace


ArrayList.Capacity Property

ArrayList.Capacity Property

Gets or sets the number of objects that the ArrayList collection can contain.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int Capacity { get; set; }

Property Value

The maximum number of objects that the ArrayList collection can contain.

Expand image Remarks

The Capacity property denotes the maximum number of objects that the ArrayList collection is capable of storing. The Count property denotes the number of objects that the ArrayList collection actually contains. By definition, the value of Capacity is always greater than or equal to the value of Count. If the Count value surpasses the Capacity value while objects are being added to the collection, the capacity of the collection is automatically doubled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


UIElementCollection.Capacity Property

UIElementCollection.Capacity Property

Gets or sets the maximum number of elements that the current collection can contain.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual int Capacity { get; set; }

Property Value

The maximum number of elements that the current collection can contain.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


Bitmap.CenterX Field

Bitmap.CenterX Field

Represents the x-coordinate location of the center of the display device, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int CenterX

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.CenterY Field

Bitmap.CenterY Field

Represents the y-coordinate location of the center of the display device, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int CenterY

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ExtendedTimer.Change Method (DateTime, TimeSpan)

ExtendedTimer.Change Method (DateTime, TimeSpan)
See Also
CollapseAll image

Changes the start time and the interval between method invocations for a timer, using System.DateTime and System.TimeSpan values to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Change (
         DateTime dueTime,
         TimeSpan period
)

Parameters

dueTime
The System.DateTime value that represents the amount of time the timer will wait before the callback parameter invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The System.TimeSpan value that represents the time interval between invocations of the methods referenced by the delegate specified at System.Threading.Timer construction time, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


ExtendedTimer.Change Method (TimeSpan, TimeSpan)

ExtendedTimer.Change Method (TimeSpan, TimeSpan)
See Also
CollapseAll image

Changes the start time and the interval between method invocations for a timer, using >System.TimeSpan values to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Change (
         TimeSpan dueTime,
         TimeSpan period
)

Parameters

dueTime
The System.TimeSpan value that represents the amount of time the timer will wait before the callback parameter invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The System.TimeSpan value that represents the time interval between invocations of the methods referenced by the delegate specified at System.Threading.Timer construction time, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


Timer.Change Method (TimeSpan, TimeSpan)

Timer.Change Method (TimeSpan, TimeSpan)
See Also
CollapseAll image

Changes the start time and the interval between method invocations for a Timer object (timer), using TimeSpan values to specify time intervals.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Change (
         TimeSpan dueTime,
         TimeSpan period
)

Parameters

dueTime
A TimeSpan object that represents the amount of time, in milliseconds, you want the system to delay before invoking the callback method specified when the current timer was constructed. Specify -1 milliseconds to prevent the timer from restarting. Specify 0 (zero) to restart the timer immediately.
period
The time interval, in milliseconds, between invocations of the callback method specified when the current timer was constructed. Specify -1 milliseconds to disable periodic signaling.

Return Value

true if the current timer has not been disposed; otherwise, false.

Expand image Remarks

To keep CPU and memory usage to a minimum, timers in the .NET Micro Framework operate slightly differently than do timers in the .NET Framework. Specifically, setting both the dueTime and period parameters does not cause a timer to be queued, as it does in the .NET Framework. Instead, calling the Change method throws an exception indicating that the timer has been retriggered.

It is possible for the common language runtime (CLR) to reuse a timer after the timer has been released by the Dispose method. As a result, the Change method may return true even though your application has already called Dispose on it.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


ExtendedTimer.Change Method (Int32, Int32)

ExtendedTimer.Change Method (Int32, Int32)
See Also
CollapseAll image

Changes the start time and the interval between method invocations for a timer, using 32-bit signed integers to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Change (
         int dueTime,
         int period
)

Parameters

dueTime
The amount of time the timer will wait before the delegate specified at System.Threading.Timer construction time invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from restarting. Specify 0 (zero) to restart the timer immediately.
period
The time interval between invocations of the methods referenced by the delegate specified at System.Threading.Timer construction time, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


Timer.Change Method (Int32, Int32)

Timer.Change Method (Int32, Int32)
See Also
CollapseAll image

Changes the start time and the interval between method invocations for a Timer object (timer), using 32-bit signed integers to specify time intervals.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Change (
         int dueTime,
         int period
)

Parameters

dueTime
A TimeSpan object that represents the amount of time, in milliseconds, you want the system to delay before invoking the callback method specified when the current timer was constructed. Specify Timeout.Infinite to prevent the timer from restarting. Specify 0 (zero) to restart the timer immediately.
period
The time interval, in milliseconds, between invocations of the callback method specified when the current timer was constructed. Specify Timeout.Infinite to disable periodic signaling.

Return Value

true if the current timer has not been disposed; otherwise, false.

Expand image Remarks

To keep CPU and memory usage to a minimum, timers in the .NET Micro Framework operate slightly differently than do timers in the .NET Framework. Specifically, setting both the dueTime and period parameters does not cause a timer to be queued, as it does in the .NET Framework. Instead, calling the Change method throws an exception indicating that the timer has been retriggered.

It is possible for the common language runtime (CLR) to reuse a timer after the timer has been released by the Dispose method. As a result, the Change method may return true even though your application has already called Dispose on it.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


ExtendedTimer.Change Method

ExtendedTimer.Change Method

Changes the start time and the interval between method invocations for a timer.

Expand image Overload List

Name | Description
ExtendedTimer.Change (DateTime, TimeSpan) | Changes the start time and the interval between method invocations for a timer, using System.DateTime and System.TimeSpan values to measure time intervals.
ExtendedTimer.Change (Int32, Int32) | Changes the start time and the interval between method invocations for a timer, using 32-bit signed integers to measure time intervals.
ExtendedTimer.Change (TimeSpan, TimeSpan) | Changes the start time and the interval between method invocations for a timer, using >System.TimeSpan values to measure time intervals.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


Timer.Change Method

Timer.Change Method

Changes the start time and the interval between method invocations for a Timer object (timer).

Expand image Overload List

Name | Description
Timer.Change (Int32, Int32) | Changes the start time and the interval between method invocations for a Timer object (timer), using 32-bit signed integers to specify time intervals.
Timer.Change (TimeSpan, TimeSpan) | Changes the start time and the interval between method invocations for a Timer object (timer), using TimeSpan values to specify time intervals.

Expand image Remarks

To keep CPU and memory usage to a minimum, timers in the .NET Micro Framework operate slightly differently than do timers in the .NET Framework. Specifically, setting both the dueTime and period parameters does not cause a timer to be queued, as it does in the .NET Framework. Instead, calling the Change method throws an exception indicating that the timer has been retriggered.

It is possible for the common language runtime (CLR) to reuse a timer after the timer has been released by the Dispose method. As a result, the Change method may return true even though your application has already called Dispose on it.

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


Char Structure

Char Structure

Represents a Unicode character.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Char

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Char Members
System Namespace


Char Members

Char Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Char type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of Char Structure. This field is constant.
MinValue | Represents the smallest possible value of Char Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current Char object to its equivalent string representation.

Expand image See Also

Reference

Char Structure
System Namespace


String.Chars Property

String.Chars Property

Gets the character at a specified index number (character position) in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public char this [
         int index
] { get; }

Parameters

index
The specified character position in the current String object.

Property Value

A Unicode character.

Expand image Remarks

The value of the index parameter is zero-based.

This property returns the character at the position specified by the index parameter. Note, however, that a particular Unicode character might be represented by more than one standard character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


CharSet Enumeration

CharSet Enumeration

Dictates which character set marshaled strings should use.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum CharSet

Expand image Members

Member name | Description
Ansi | A value that causes strings to be marshaled as multiple-byte character strings.
Auto | A value that causes strings to be automatically marshaled appropriately for the target operating system.
None | An obsolete value that has the same behavior as the CharSet.Ansi value.
Unicode | A value that causes strings to be marshaled as 2-byte Unicode characters.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Runtime.InteropServices Namespace


StructLayoutAttribute.CharSet Field

StructLayoutAttribute.CharSet Field

Indicates how string data fields within a particular class should be marshaled by default — that is, as LPWSTR or as LPSTR.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public CharSet CharSet

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


Font.CharWidth Method

Font.CharWidth Method

Gets the width of the specified character, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int CharWidth (
         char c
)

Parameters

c
The character whose width you want to find.

Return Value

The width of the specified character, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Dispatcher.CheckAccess Method

Dispatcher.CheckAccess Method

Determines whether the calling thread has access to the current Dispatcher object (dispatcher).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool CheckAccess ()

Return Value

true if the calling thread has access to the current dispatcher; otherwise, false.

Expand image Remarks

Only the thread on which the dispatcher was created can access the dispatcher.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


DispatcherObject.CheckAccess Method

DispatcherObject.CheckAccess Method

Determines whether the calling thread has access to the current DispatcherObject object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool CheckAccess ()

Return Value

true if the calling thread has access to the current object; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherObject Class
DispatcherObject Members
Microsoft.SPOT Namespace


ContentControl.Child Property

ContentControl.Child Property

Gets or sets a child element (child control) contained in the current ContentControl object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement Child { get; set; }

Property Value

The child control contained in the current ContentControl object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ContentControl Class
ContentControl Members
Microsoft.SPOT.Presentation.Controls Namespace


Panel.Children Property

Panel.Children Property

Gets the collection of child elements in the current panel.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElementCollection Children { get; }

Property Value

The collection of child elements in the current panel.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Panel Class
Panel Members
Microsoft.SPOT.Presentation.Controls Namespace


Bitmap.Circle Method

Bitmap.Circle Method

Draws a circle specified by a coordinate pair (x and y) and a radius, using a specified raster operation.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
[MethodImplAttribute]
public void Circle (
         int xCenter,
         int yCenter,
         int radius,
         int dwRop
)

Parameters

xCenter
The x-coordinate of the center of the circle.
yCenter
The y-coordinate of the center of the circle.
radius
The radius of the circle.
dwRop
A raster operation code.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Array.Clear Method

Array.Clear Method

Sets a range of objects in a specified array to 0 (zero), to false, or to a null reference, depending on the object type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Clear (
         Array array,
         int index,
         int length
)

Parameters

array
The array containing the range of objects you want to clear.
index
The starting index number of the range of objects you want to clear.
length
The length of the range (the number of objects) you want to clear.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.Clear Method

ArrayList.Clear Method

Removes all objects from the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void Clear ()

Expand image Remarks

The Count property is set to 0 (zero); the value of the Capacity property remains unchanged.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Bitmap.Clear Method

Bitmap.Clear Method

Clears the entire drawing surface.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Clear ()

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.Clear Method

DrawingContext.Clear Method

Clears the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Clear ()

Expand image Remarks

When you use this method, all images that are currently on the drawing surface are erased.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


System.Collections.IList.Clear Method

System.Collections.IList.Clear Method

Sets all of the objects in a specific array to 0 (zero), to false, or to a null reference, depending on the object type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
void System.Collections.IList.Clear ()

Expand image Remarks

Reference-type objects are set to a null reference; Boolean-type objects are set to false; other value-type objects are set to 0 (zero).

This method clears only the objects' values; it does not remove the objects themselves. Because the array has a fixed size, you cannot add objects to it or remove objects from it.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.Clear Method

IList.Clear Method

When implemented by a class, this method removes all objects from the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void Clear ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Clear Method

ListBoxItemCollection.Clear Method

Empties the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Clear ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Clear Method

TextRunCollection.Clear Method

Empties the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Clear ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Clear Method

UIElementCollection.Clear Method

Removes all elements from the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Clear ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


Array.Clone Method

Array.Clone Method

Creates a shallow copy of an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object Clone ()

Return Value

A shallow copy of an array.

Expand image Remarks

A shallow copy of an array contains only the reference elements contained in the original array, whether they are reference types or value types; it does not copy the objects that the references refer to. The references in the new array (the shallow copy) point to the same objects that the references in the original array point to.

By contrast, a deep copy of an array copies the original array's objects and everything directly or indirectly referenced by those objects.

A clone array is of the same type as the original array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.Clone Method

ArrayList.Clone Method

Creates a shallow copy of the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object Clone ()

Return Value

A shallow copy of the ArrayList collection.

Expand image Remarks

A shallow copy of a collection copies only the objects contained in the collection, whether they are reference types or value types; it does not copy the objects that the references refer to. The references in the new collection point to the same objects that the references in the original collection point to.

By contrast, a deep copy of a collection copies the collection's objects and everything directly or indirectly referenced by those objects.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


UIElementCollection.Enumerator.Clone Method

UIElementCollection.Enumerator.Clone Method

Creates a shallow copy of the current UIElementCollection.Enumerator object (enumerator).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object Clone ()

Return Value

An object that represents a shallow copy of the current enumerator.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection.Enumerator Structure
UIElementCollection.Enumerator Members
Microsoft.SPOT.Presentation Namespace


ICloneable.Clone Method

ICloneable.Clone Method

Creates a new instance (object) that is a copy of the current object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Object Clone ()

Return Value

A new object that is a copy of the current object.

Expand image Remarks

You can use the Clone to create either a deep copy or a shallow copy of a specific object. In a deep copy, all elements are duplicated. In a shallow copy, only the top-level elements are duplicated, whereas the lower-level elements contain references.

An object created by cloning must be of the same type as or a type compatible with the original object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICloneable Interface
ICloneable Members
System Namespace


Window.Close Method

Window.Close Method

Closes the current window manually.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Close ()

Expand image Remarks

Closing a window will cause any child windows that it owns to be closed. Furthermore, doing this may cause your application to stop running, depending on the value of the ShutdownMode property of the Application object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


CLSCompliantAttribute Class

CLSCompliantAttribute Class
See Also Members
CollapseAll image

Indicates whether a particular program element is compliant with the Common Language Specification (CLS).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class CLSCompliantAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

You can apply the CLSCompliantAttribute attribute to the following types of program elements: assemblies, classes, constructors, delegates, enums, events, fields, interfaces, methods, modules, parameters, properties, return values, and structs. Note, however, that the concept of CLS compliance is meaningful only for assemblies, modules, types, and members of types, and not for parts of a member signature. Consequently, CLSCompliantAttribute is ignored when it is applied to parameters or return values.

If no CLSCompliantAttribute attribute is applied to a particular assembly, type, or member of a type, the following are true (respectively) by default:

  • The assembly is not CLS-compliant.
  • The type is CLS-compliant only if its enclosing type or assembly is CLS-compliant.
  • The member of a type is CLS-compliant only if the type is CLS-compliant.

If an assembly is marked as CLS-compliant, you must mark any publicly exposed type in the assembly that is not CLS-compliant with CLSCompliantAttribute, using a false argument. Similarly, if a class is marked as CLS-compliant, you must individually mark all members of that class that are not CLS-compliant. For all noncompliant members, you must provide corresponding CLS-compliant alternatives.

Attributes that are applied to assemblies or modules must occur after the C# "using" statements and before the actual code.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CLSCompliantAttribute Members
System Namespace


CLSCompliantAttribute Members

CLSCompliantAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the CLSCompliantAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | CLSCompliantAttribute | Initializes an instance of the CLSCompliantAttribute class with a Boolean value indicating whether the specified program element is CLS-compliant.

Expand image Public Properties

 | Name | Description
Public Property | IsCompliant | Gets the Boolean value indicating whether the specified program element is CLS-compliant.

Expand image See Also

Reference

CLSCompliantAttribute Class
System Namespace


System.Collections Namespace

System.Collections Namespace

The System.Collections namespace in the Microsoft® .NET Micro Framework contains a number of interfaces and a class that define collections of objects.

Expand image Classes

 | Name | Description
Public Class | ArrayList | Implements the IList interface by using an array whose size is dynamically increased, as necessary.

Expand image Interfaces

 | Name | Description
Public Interface | ICollection | Defines size, enumerators, and synchronization methods for all collections.
Public Interface | IComparer | Exposes a method that compares two objects.
Public Interface | IEnumerable | Exposes the enumerator, which supports a simple iteration through a collection.
Public Interface | IEnumerator | Supports a simple iteration through a collection.
Public Interface | IList | Represents a collection of objects that you can access individually by index number.


Color Enumeration

Color Enumeration

Specifies colors for drawing or painting on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Color

Expand image Members

Member name | Description
Black = 0x00000000 | Black.
White = 0x00ffffff | White.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Media Namespace


Pen.Color Field

Pen.Color Field

Specifies the color of the current pen.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color Color

Expand image Remarks

This field is a value of the Color enumeration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Class
Pen Members
Microsoft.SPOT.Presentation.Media Namespace


SolidColorBrush.Color Field

SolidColorBrush.Color Field

Specifies the color for the brush's paint, or fill.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color Color

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SolidColorBrush Class
SolidColorBrush Members
Microsoft.SPOT.Presentation.Media Namespace


ColorUtility.ColorFromRGB Method

ColorUtility.ColorFromRGB Method

Builds a Color object from red, green, and blue values.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static Color ColorFromRGB (
         byte r,
         byte g,
         byte b
)

Parameters

r
The red value.
g
The green value.
b
The blue value.

Return Value

A color with the specified red, green, and blue values.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ColorUtility Class
ColorUtility Members
Microsoft.SPOT.Presentation.Media Namespace


Colors Class

Colors Class
See Also Members
CollapseAll image

Provides a set of predefined colors for a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class Colors

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Members
Microsoft.SPOT.Presentation.Media Namespace


Colors Members

Colors Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the Colors type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Colors | Initializes a new instance of the Colors class.

Expand image Public Fields

 | Name | Description
Public Field | Black | The system-defined color that has an RGB value of #000000.
Public Field | Blue | The system-defined color that has an RGB value of #0000FF.
Public Field | Gray | The system-defined color that has an RGB value of #808080.
Public Field | Green | The system-defined color that has an RGB value of #008000.
Public Field | Red | The system-defined color that has an RGB value of #FF0000.
Public Field | White | The system-defined color that has an RGB value of #FFFFFF.

Expand image See Also

Reference

Colors Class
Microsoft.SPOT.Presentation.Media Namespace


ColorUtility Class

ColorUtility Class
See Also Members
CollapseAll image

Provides a collection of methods for working with colors.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ColorUtility

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ColorUtility Members
Microsoft.SPOT.Presentation.Media Namespace


ColorUtility Members

ColorUtility Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the ColorUtility type.

Expand image Public Methods

Name | Description
ColorFromRGB | Builds a Color object from red, green, and blue values.
GetBValue | Extracts a blue value from a specified color.
GetGValue | Extracts a green value from a specified color.
GetRValue | Extracts a red value from a specified color.

Expand image See Also

Reference

ColorUtility Class
Microsoft.SPOT.Presentation.Media Namespace


Delegate.Combine Method

Delegate.Combine Method

Concatenates the invocation lists of two multicast (combinable) delegates.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Delegate Combine (
         Delegate a,
         Delegate b
)

Parameters

a
The multicast (combinable) delegate whose invocation list comes first.
b
The multicast (combinable) delegate whose invocation list comes last.

Return Value

A new multicast (combinable) delegate with an invocation list that concatenates the invocation lists of a and b, in that order.

-or-

a, if b is a null reference.

-or-

b, if a is a null reference.

-or-

A null reference, if both a and b are null references.

Expand image Remarks

The invocation list can contain duplicate entries — that is, entries that refer to the same method for the same object.

The Combine method is useful for creating event handlers that call multiple methods each time an event occurs.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


WeakDelegate.Combine Method

WeakDelegate.Combine Method

Concatenates the invocation lists of two multicast (combinable) delegates.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Delegate Combine (
         Delegate a,
         Delegate b
)

Parameters

a
The combinable delegate whose invocation list comes first.
b
The combinable delegate whose invocation list comes second.

Return Value

A new combinable delegate with an invocation list that concatenates the invocation lists of the a and b parameters, in that order. If b is a null reference, this method returns a. If a is a null reference, this method returns b. If both a and b are null references, this method returns null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakDelegate Class
WeakDelegate Members
Microsoft.SPOT Namespace


# Comments

# Comments
See Also Example
CollapseAll image

Add comments to a .fntdef file.
#comment

Parameters

comment
A comment should follow the # symbol.

Expand image Remarks

A comment must be on its own line.

Expand image Example

#This is a comment

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TFConvert References


AssemblyCompanyAttribute.Company Property

AssemblyCompanyAttribute.Company Property

Gets company name information.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Company { get; }

Property Value

A string containing the company name.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCompanyAttribute Class
AssemblyCompanyAttribute Members
System.Reflection Namespace


DateTime.Compare Method

DateTime.Compare Method

Compares two date/time values in order to determine their relative value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Compare (
         DateTime t1,
         DateTime t2
)

Parameters

t1
A DateTime object that specifies a date and time.
t2
A DateTime object that specifies a date and time.

Return Value

An integer that specifies the relative value of the t1 and t2 objects.
Return Value | Meaning
Less than zero | The t1 object is less than the t2 object.
Zero | The t1 object is equal to the t2 object.
Greater than zero | The t1 object is greater than the t2 object.

Expand image Remarks

The two date/time values must be in the same time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


IComparer.Compare Method

IComparer.Compare Method

Compares two objects and returns a value indicating whether the first object is less than, equal to, or greater than the second object.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Compare (
         Object x,
         Object y
)

Parameters

x
The first object you want to compare.
y
The second object you want to compare.

Return Value

One of the values listed in the following table.

Value | Condition
Less than 0 (zero) | x is less than y
Zero | x equals y
Greater than zero | x is greater than y

Expand image Remarks

Using IComparable, you can compare a null reference with any type of object without generating an exception. Note that during a sorting operation, a null reference is considered to be less than any other object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IComparer Interface
IComparer Members
System.Collections Namespace


String.Compare Method

String.Compare Method

Compares two specified String objects with one another.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Compare (
         string strA,
         string strB
)

Parameters

strA
The first String object you want to compare.
strB
The second String object you want to compare.

Return Value

A 32-bit signed integer that indicates the lexical relationship between the two comparands.

Value | Meaning
Less than 0 (zero) | strA is less than strB.
0 (zero) | strA equals strB.
Greater than 0 (zero) | strA is greater than strB.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


TimeSpan.Compare Method

TimeSpan.Compare Method

Compares two specified TimeSpan objects (time periods) with one another to determine their relative value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Compare (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that specifies a period of time.
t2
A TimeSpan object that specifies a period of time.

Return Value

An integer that represents the relative value of the two TimeSpan objects specified by the t1 and t2 parameters.
Return value | Meaning
Less than 0 (zero) | The value of t1 is less than the value of t2.
0 (zero) | The value of t1 is equal to the value of t2.
Greater than 0 (zero) | The value of t1 is greater than the value of t2.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Interlocked.CompareExchange Method

Interlocked.CompareExchange Method

Compares two 32-bit signed integers for equality and, if they are equal, replaces one of the values.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int CompareExchange (
         ref int location1,
         int value,
         int comparand
)

Parameters

location1
The destination value that will be compared with the value of the comparand parameter and will possibly be replaced.
value
The value that will replace the destination value if the compared integers are equal.
comparand
The value that will be compared with the location1 parameter.

Return Value

The original value of the location1 parameter.

Expand image Remarks

This is an atomic operation; it cannot be interrupted before it is complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Interlocked Class
Interlocked Members
System.Threading Namespace


String.CompareTo Method (String)

String.CompareTo Method (String)
See Also
CollapseAll image

Compares the current String object with a specified String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int CompareTo (
         string strB
)

Parameters

strB
The specified String object.

Return Value

A 32-bit signed integer that indicates the lexical relationship between the two comparands.

Value | Meaning
Less than 0 (zero) | this is less than strB.
0 (zero) | this equals strB.
Greater than 0 (zero) | this is greater than strB.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.CompareTo Method (Object)

String.CompareTo Method (Object)
See Also
CollapseAll image

Compares the current String object with a specified Object object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int CompareTo (
         Object value
)

Parameters

value
An Object object that evaluates to a String object.

Return Value

A 32-bit signed integer that indicates the lexical relationship between the two comparands.

Value | Meaning
Less than 0 (zero) | this is less than value.
0 (zero) | this equals value.
Greater than 0 (zero) | this is greater than value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DateTime.CompareTo Method

DateTime.CompareTo Method

Compares a specified date/time to this date/time instance in order to determine their relative value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int CompareTo (
         Object val
)

Parameters

val
An Object instance that specifies a date and time.

Return Value

An integer that specifies the relative value of the val object to this instance of date/time.
Return Value | Meaning
Less than zero | This date/time instance is less than the val object.
Zero | This date/time instance is equal to the val object.
Greater than zero | This date/time instance is greater than the val object.

Expand image Remarks

The date/time value that is specified by the val parameter must be in the same time zone as this instance of the date/time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


IComparable.CompareTo Method

IComparable.CompareTo Method

Compares the current instance (object) with another object of the same type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int CompareTo (
         Object obj
)

Parameters

obj
The object you want to compare with the current object.

Return Value

A 32-bit signed integer that indicates the relative order of the comparands. The return value has one of the three meanings described in the following table.

Value | Meaning
Less than 0 (zero) | This object is less than the obj parameter.
0 (zero) | This object is equal to the obj parameter.
Greater than 0 (zero) | This object is greater than the obj parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IComparable Interface
IComparable Members
System Namespace


String.CompareTo Method

String.CompareTo Method

Compares the current String object with a specified String object or Object object.

Expand image Overload List

Name | Description
String.CompareTo (Object) | Compares the current String object with a specified Object object.
String.CompareTo (String) | Compares the current String object with a specified String object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


TimeSpan.CompareTo Method

TimeSpan.CompareTo Method

Compares a specified TimeSpan object (time period) or other time-period object with the current TimeSpan object to determine their relative value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int CompareTo (
         Object value
)

Parameters

value
A TimeSpan object or a null reference.

Return Value

An integer that represents the value of the specified TimeSpan object or other time-period object relative to the current TimeSpan object.
Return value | Meaning
Less than 0 (zero) | The current TimeSpan object is less than the object specified by the value parameter.
0 (zero) | The current TimeSpan object is equal to the object specified by the value parameter.
Greater than 0 (zero) | The current TimeSpan object is greater than the object specified by the value parameter.

Expand image Remarks

Any TimeSpan object, regardless of its value, is considered greater than a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


System.Runtime.CompilerServices Namespace

System.Runtime.CompilerServices Namespace

The System.Runtime.CompilerServices namespace in the Microsoft® .NET Micro Framework provides functionality for compiler writers using managed code to specify metadata attributes that affect the run-time behavior of the common language runtime (CLR).

Expand image Remarks

Items in this namespace are for use by Microsoft Visual Studio®. You should not try to use them in your applications.

Expand image Classes

 | Name | Description
Public Class | IndexerNameAttribute | Indicates the name by which a particular indexer is known in programming languages that do not directly support indexers.
Public Class | MethodImplAttribute | Specifies the details of how a particular method is implemented.
Public Class | RuntimeHelpers | Provides a set of static methods and properties that provide support for compilers.

Expand image Enumerations

 | Name | Description
Public Enumeration | MethodCodeType | Defines how a particular method is implemented.
Public Enumeration | MethodImplOptions | Defines the details of how a particular method is implemented.


DispatcherOperation.Completed Event

DispatcherOperation.Completed Event

Occurs when the delegate on the dispatcher queue associated with the current DispatcherOperation object completes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler Completed

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


Font.ComputeExtent Method (String, Int32, Int32, Int32)

Font.ComputeExtent Method (String, Int32, Int32, Int32)
See Also
CollapseAll image

Computes the width, height, and kerning of a specified line of text.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void ComputeExtent (
         string text,
         ref int width,
         ref int height,
         int kerning
)

Parameters

text
The text you want to measure.
width
[OutAttribute] The width of the specified text.
height
[OutAttribute] The height of the specified text.
kerning
The spacing between consecutive characters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeExtent Method (String, Int32, Int32)

Font.ComputeExtent Method (String, Int32, Int32)
See Also
CollapseAll image

Computes the width and height of a specified line of text.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void ComputeExtent (
         string text,
         ref int width,
         ref int height
)

Parameters

text
The text you want to measure.
width
[OutAttribute] The width of the specified text.
height
[OutAttribute] The height of the specified text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeExtent Method

Font.ComputeExtent Method

Computes the width and height of a specified line of text.

Expand image Overload List

Name | Description
Font.ComputeExtent (String, Int32, Int32) | Computes the width and height of a specified line of text.
Font.ComputeExtent (String, Int32, Int32, Int32) | Computes the width, height, and kerning of a specified line of text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeTextInRect Method (String, Int32, Int32, Int32)

Font.ComputeTextInRect Method (String, Int32, Int32, Int32)
See Also
CollapseAll image

Computes the size of the rectangular area on the display device needed to render the specified text string.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void ComputeTextInRect (
         string text,
         ref int renderWidth,
         ref int renderHeight,
         int availableWidth
)

Parameters

text
The text you want to render on the display device.
renderWidth
[OutAttribute] The width, in pixels, of the rectangular area needed to render the text.
renderHeight
[OutAttribute] The height, in pixels, of the rectangular area needed to render the text.
availableWidth
The maximum width of text that will fit in the defined rectangular area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32)

Font.ComputeTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32)
See Also
CollapseAll image

Computes the size of the rectangular area on the display device needed to render the specified text string.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void ComputeTextInRect (
         string text,
         ref int renderWidth,
         ref int renderHeight,
         int xRelStart,
         int yRelStart,
         int availableWidth,
         int availableHeight,
         UInt32 dtFlags
)

Parameters

text
The text you want to render on the display device.
renderWidth
[OutAttribute] The width, in pixels, of the rectangular area needed to render the text.
renderHeight
[OutAttribute] The height, in pixels, of the rectangular area needed to render the text.
xRelStart
The x-coordinate of the relative starting point for the text.
yRelStart
The y-coordinate of the relative starting point for the text.
availableWidth
The maximum width of text that will fit in the defined rectangular area.
availableHeight
The maximum height of text that will fit in the defined rectangular area.
dtFlags
Flags that specify various text characteristics, such as alignment.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeTextInRect Method (String, Int32, Int32)

Font.ComputeTextInRect Method (String, Int32, Int32)
See Also
CollapseAll image

Computes the size of the rectangular area on the display device needed to render the specified text string.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void ComputeTextInRect (
         string text,
         ref int renderWidth,
         ref int renderHeight
)

Parameters

text
The text you want to render on the display device.
renderWidth
[OutAttribute] The width, in pixels, of the rectangular area needed to render the text.
renderHeight
[OutAttribute] The height, in pixels, of the rectangular area needed to render the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Font.ComputeTextInRect Method

Font.ComputeTextInRect Method

Computes the size of the rectangular area on the display device needed to render the specified text string.

Expand image Overload List

Name | Description
Font.ComputeTextInRect (String, Int32, Int32) | Computes the size of the rectangular area on the display device needed to render the specified text string.
Font.ComputeTextInRect (String, Int32, Int32, Int32) | Computes the size of the rectangular area on the display device needed to render the specified text string.
Font.ComputeTextInRect (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32) | Computes the size of the rectangular area on the display device needed to render the specified text string.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


String.Concat Method (String, String, String, String)

String.Concat Method (String, String, String, String)
See Also
CollapseAll image

Concatenates four specified String objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static string Concat (
         string str0,
         string str1,
         string str2,
         string str3
)

Parameters

str0
The first String object you want to concatenate.
str1
The second String object you want to concatenate.
str2
The third String object you want to concatenate.
str3
The fourth String object you want to concatenate.

Return Value

The concatenation of the str0, str1, str2, and str3 parameters.

Expand image Remarks

An empty String object is used in place of any parameters that contain a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (String, String)

String.Concat Method (String, String)
See Also
CollapseAll image

Concatenates two specified String objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static string Concat (
         string str0,
         string str1
)

Parameters

str0
The first String object you want to concatenate.
str1
The second String object you want to concatenate.

Return Value

The concatenation of the str0 and str1 parameters.

Expand image Remarks

An empty String object is used in place of any parameters that contain a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (Object, Object)

String.Concat Method (Object, Object)
See Also
CollapseAll image

Concatenates the String representations of two specified Object objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Concat (
         Object arg0,
         Object arg1
)

Parameters

arg0
The first Object object for which you want a concatenated String representation.
arg1
The second Object object for which you want a concatenated String representation.

Return Value

The concatenated String representations of the arg0 and arg1 values for the two specified Object objects.

Expand image Remarks

An empty string is used in place of any parameters that contain a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (String[])

String.Concat Method (String[])
See Also
CollapseAll image

Concatenates the objects contained in a specified String array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static string Concat (
         string[] values
)

Parameters

values
An array of String objects.

Return Value

The concatenated objects listed in the values parameter for the specified String array.

Expand image Remarks

An empty string is used in place of any null reference in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (Object, Object, Object)

String.Concat Method (Object, Object, Object)
See Also
CollapseAll image

Concatenates the String representations of three specified Object objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Concat (
         Object arg0,
         Object arg1,
         Object arg2
)

Parameters

arg0
The first Object object for which you want a concatenated String representation.
arg1
The second Object object for which you want a concatenated String representation.
arg2
The third Object object for which you want a concatenated String representation.

Return Value

The concatenated String representations of the arg0, arg1, and arg2 values for the three specified Object objects.

Expand image Remarks

An empty string is used in place of any parameters that contain a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (Object)

String.Concat Method (Object)
See Also
CollapseAll image

Creates the String representation of a specified Object object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Concat (
         Object arg0
)

Parameters

arg0
An Object object or a null reference.

Return Value

The String representation of the arg0 value for the specified Object object.

Expand image Remarks

An empty string is used if the parameter contains a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (String, String, String)

String.Concat Method (String, String, String)
See Also
CollapseAll image

Concatenates three specified String objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static string Concat (
         string str0,
         string str1,
         string str2
)

Parameters

str0
The first String object you want to concatenate.
str1
The second String object you want to concatenate.
str2
The third String object you want to concatenate.

Return Value

The concatenation of the str0, str1, and str2 parameters for the specified String objects.

Expand image Remarks

An empty string is used in place of any parameters that contain a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method (Object[])

String.Concat Method (Object[])
See Also
CollapseAll image

Concatenates the String representations of the objects contained in a specified Object array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Concat (
         Object[] args
)

Parameters

args
The specified Object array.

Return Value

The concatenated String representations of the args values for the objects in the specified Object array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Concat Method

String.Concat Method

Concatenates one or more String objects or the String representations of the args values for one or more Object objects.

Expand image Overload List

Name | Description
String.Concat (Object) | Creates the String representation of a specified Object object.
String.Concat (Object, Object) | Concatenates the String representations of two specified Object objects.
String.Concat (Object, Object, Object) | Concatenates the String representations of three specified Object objects.
String.Concat (Object[]) | Concatenates the String representations of the objects contained in a specified Object array.
String.Concat (String, String) | Concatenates two specified String objects.
String.Concat (String, String, String) | Concatenates three specified String objects.
String.Concat (String, String, String, String) | Concatenates four specified String objects.
String.Concat (String[]) | Concatenates the objects contained in a specified String array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


ConditionalAttribute Class

ConditionalAttribute Class
See Also Members
CollapseAll image

Indicates to compilers that a particular method is callable if a specified preprocessing identifier is applied to that method.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class ConditionalAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConditionalAttribute Members
System.Diagnostics Namespace


ConditionalAttribute Members

ConditionalAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the ConditionalAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | ConditionalAttribute | Initializes a new instance of the ConditionalAttribute class, specifying the name of the attribute that makes a specific conditional method callable.

Expand image Public Properties

 | Name | Description
Public Property | ConditionString | Gets the string containing the preprocessing identifier that makes the target method of the current object callable.

Expand image See Also

Reference

ConditionalAttribute Class
System.Diagnostics Namespace


ConditionalAttribute.ConditionString Property

ConditionalAttribute.ConditionString Property

Gets the string containing the preprocessing identifier that makes the target method of the current object callable.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ConditionString { get; }

Property Value

A string containing the preprocessing identifier that makes the target method of the current object callable.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConditionalAttribute Class
ConditionalAttribute Members
System.Diagnostics Namespace


AssemblyConfigurationAttribute.Configuration Property

AssemblyConfigurationAttribute.Configuration Property

Gets assembly configuration information.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Configuration { get; }

Property Value

A string that contains assembly configuration information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyConfigurationAttribute Class
AssemblyConfigurationAttribute Members
System.Reflection Namespace


Constants Class

Constants Class
See Also Members
CollapseAll image

Provides constants that are common to all types in the Media namespace.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static class Constants

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Constants Members
Microsoft.SPOT.Presentation.Media Namespace


Constants Members

Constants Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the Constants type.

Expand image Public Fields

 | Name | Description
Public Field | MaxExtent | Specifies the maximum extent of an image or child element.

Expand image See Also

Reference

Constants Class
Microsoft.SPOT.Presentation.Media Namespace


ConstraintException Class

ConstraintException Class
See Also Members
CollapseAll image

The exception that is thrown when an action is attempted that violates a constraint.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class ConstraintException : Exception

Expand image Remarks

When a ConstraintException exception is caught, if the ExecutionConstraint object that caused this exception has not been uninstalled, the catch block implementation has a small additional amount of time during which to handle the exception. If this takes too long, the exception is rethrown automatically.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConstraintException
Microsoft.SPOT Namespace


ConstructorInfo Class

ConstructorInfo Class
See Also Members
CollapseAll image

Discovers the attributes of a class constructor and provides access to constructor metadata.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class ConstructorInfo : MethodBase

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConstructorInfo Members
System.Reflection Namespace


ConstructorInfo Members

ConstructorInfo Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the ConstructorInfo type.

Expand image Protected Constructors

 | Name | Description
Protected Method | ConstructorInfo | Initializes a new instance of the ConstructorInfo class.

Expand image Public Properties

 | Name | Description
Public Property | MemberType | Gets the member type of the current object.

Expand image Public Methods

 | Name | Description
Public Method | Invoke | Invokes the constructor reflected by the object that has the specified parameters, and provides default values for the parameters that are not commonly used.

Expand image See Also

Reference

ConstructorInfo Class
System.Reflection Namespace


ArrayList.Contains Method

ArrayList.Contains Method

Determines whether a specified object is contained in the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool Contains (
         Object item
)

Parameters

item
The object you want to locate in the ArrayList collection. This value can be a null reference.

Return Value

true if the specified object is found in the ArrayList collection; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


System.Collections.IList.Contains Method

System.Collections.IList.Contains Method

Determines whether a specified object is contained in a specific array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
bool System.Collections.IList.Contains (
         Object value
)

Parameters

value
The object you want to find in the array. This object can be a null reference.

Return Value

true if the specified object was found in the array; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.Contains Method

IList.Contains Method

When implemented by a class, this method determines whether the IList collection contains a specified object.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool Contains (
         Object value
)

Parameters

value
The object you want to search for in the collection.

Return Value

true if the specified object was found in the IList collection; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Contains Method

ListBoxItemCollection.Contains Method

Determines whether a specified item (element) is contained in the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Contains (
         ListBoxItem item
)

Parameters

item
The item you want to search for in the current collection.

Return Value

true if the specified item is a member of the current collection; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Contains Method

TextRunCollection.Contains Method

Determines whether the current text run collection contains a specified text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Contains (
         TextRun run
)

Parameters

run
The text run to be searched for in the collection.

Return Value

true if the collection contains the specified text run; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Contains Method

UIElementCollection.Contains Method

Determines whether the current collection contains a specified element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Contains (
         UIElement element
)

Parameters

element
A UIElement object that specifies the element you want to search for in the current collection.

Return Value

true if the specified element was found in the current collection; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


ContentControl Class

ContentControl Class
See Also Members
CollapseAll image

Constitutes the base class for all controls that contain a single piece of content. This is not an abstract class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class ContentControl : Control

Expand image Remarks

Note that ContentControl objects have a limited default style. Your program can instantiate a ContentControl object (that is, a control), but its appearance will be very simple. If you want to enhance the appearance of the control, derive a new class from ContentControl. The ContentControl class is useful for creating custom controls because it provides a model for controls that have a single piece of content.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ContentControl Members
Microsoft.SPOT.Presentation.Controls Namespace


ContentControl Members

ContentControl Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the ContentControl type.

Expand image Protected Constructors

 | Name | Description
Protected Method | ContentControl | Initializes a new instance of the ContentControl class.

Expand image Public Properties

 | Name | Description
Public Property | Child | Gets or sets a child element (child control) contained in the current ContentControl object.

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Remeasures a control for layout on a display device.

Expand image See Also

Reference

ContentControl Class
Microsoft.SPOT.Presentation.Controls Namespace


DispatcherFrame.Continue Property

DispatcherFrame.Continue Property

Gets or sets a value that indicates whether the current dispatcher frame should continue.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Continue { get; set; }

Property Value

true if the dispatcher frame should continue; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherFrame Class
DispatcherFrame Members
Microsoft.SPOT Namespace


Control Class

Control Class
See Also Members
CollapseAll image

Constitutes the base class for all user interface elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Control : UIElement

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Control Members

Control Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Control type.

Expand image Public Constructors

 | Name | Description
Public Method | Control | Provides initialization for Control class values when it is called by the constructor of a derived class.

Expand image Protected Fields

 | Name | Description
Protected Field | _background | Contains the brush used to paint a control's background.
Protected Field | _font | Specifies the current font used for text in a control.
Protected Field | _foreground | Contains the brush used to paint a control's foreground.

Expand image Public Properties

 | Name | Description
Public Property | Background | Gets or sets the brush used to paint a control's background.
Public Property | Font | Gets or sets a control's font.
Public Property | Foreground | Gets or sets the brush used to paint a control's foreground.

Expand image Public Methods

 | Name | Description
Public Method | OnRender | Draws a control to a display device.

Expand image See Also

Reference

Control Class
Microsoft.SPOT.Presentation.Controls Namespace


Microsoft.SPOT.Presentation.Controls Namespace

Microsoft.SPOT.Presentation.Controls Namespace

The Microsoft.SPOT.Presentation.Controls namespace in the Microsoft® .NET Micro Framework provides classes, delegates, and enumerations you can use to create elements (known as controls) that enable a user to interact with an application.

Expand image Classes

 | Name | Description
Public Class | Border | Draws a border around another user interface element.
Public Class | Canvas | Defines an area, or canvas, within which you can explicitly position child elements by using coordinates that are relative to the upper-left corner of the canvas.
Public Class | ContentControl | Constitutes the base class for all controls that contain a single piece of content. This is not an abstract class.
Public Class | Control | Constitutes the base class for all user interface elements.
Public Class | Image | Displays a bitmap image.
Public Class | ListBox | Implements a list of selectable items.
Public Class | ListBoxItem | Implements a selectable item inside a ListBox object.
Public Class | ListBoxItemCollection | Contains a group of ListBoxItem objects.
Public Class | Panel | Constitutes a base class for all panel elements.
Public Class | ScrollChangedEventArgs | Describes a change in the scrolling state and contains the required arguments for a ScrollChanged event.
Public Class | ScrollViewer | Defines the characteristics and functionality of a scrollable area (on a display device) that can contain other visible elements.
Public Class | SelectionChangedEventArgs | Provides data for an occurrence of the SelectionChanged event.
Public Class | StackPanel | Arranges child elements (child objects) in a single line that can be oriented either horizontally or vertically.
Public Class | Text | Displays a block of text.
Public Class | TextFlow | Provides members that control how text flows on the display device (screen).
Public Class | TextRun | Provides members you can use to create and work with a text run, which is a string of characters that share a single property set.
Public Class | TextRunCollection | Provides methods and properties that enable you to work with groups, or collections, of TextRun objects.

Expand image Delegates

 | Name | Description
Public Delegate | ScrollChangedEventHandler | Handles a ScrollChanged event.
Public Delegate | SelectionChangedEventHandler | Handles a SelectionChanged event.

Expand image Enumerations

 | Name | Description
Public Enumeration | Orientation | Specifies the layout orientation for controls that manage the layout of other user interface elements.
Public Enumeration | ScrollingStyle | Specifies how a control, such as a ScrollViewer object, scrolls.


Array.Copy Method (Array, Int32, Array, Int32, Int32)

Array.Copy Method (Array, Int32, Array, Int32, Int32)
See Also
CollapseAll image

Copies a specified range of objects from an array (source array) and pastes them into another array (destination array). Copying starts at the specified index number in the source array; pasting starts at the specified index number in the destination array. You specify the length of the range to be copied and the starting index numbers for the range in both the source and destination arrays as 32-bit integers.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Copy (
         Array sourceArray,
         int sourceIndex,
         Array destinationArray,
         int destinationIndex,
         int length
)

Parameters

sourceArray
The array that contains the range of objects you want to copy.
sourceIndex
A 32-bit integer that represents the index number in the source array at which you want the copying to begin.
destinationArray
The array into which you want to paste the copied objects.
destinationIndex
A 32-bit integer that represents the index number in the destination array at which you want the pasting of copied objects to begin.
length
A 32-bit integer that represents the number of objects you want to copy.

Expand image Remarks

The sourceArray and destinationArray parameters must have the same number of dimensions.

When you copy objects between multidimensional arrays, the arrays behave like long one-dimensional arrays, where the rows or columns are conceptually laid end to end. For example, if an array has three rows (or columns) containing four objects each, copying six objects from the beginning of the source array would copy all four objects in the first row (or column) and the first two objects in the second row (or column).

If the values of the sourceArray and destinationArray parameters overlap, this method behaves as if the original sourceArray values were preserved in a temporary location before the destinationArray parameter was overwritten.

The arrays can be either reference-type arrays or value-type arrays. Type downcasting is performed, as required.

  • When you copy objects from a reference-type array to a value-type array, each object is unboxed and then copied. When you copy objects from a value-type array to a reference-type array, each object is boxed and then copied.
  • When you copy objects from a reference-type or value-type array to an Object array, an instance of the Object class is created for each reference or value to be copied, and then the objects are copied. When you copy objects from an Object array to a reference-type or value-type array and the assignment is not possible, an InvalidCastException exception is thrown.
  • If the source array and the destination array are both reference-type arrays or are both Object arrays, a shallow copy is created. A shallow copy of an array is a new array that contains references to all of the objects in the source array, but not the objects themselves or anything referenced by those objects. By contrast, a deep copy of an array contains all of the objects from the source array and everything directly or indirectly referenced by those objects.

An ArrayTypeMismatchException exception is thrown if the source and destination arrays are of incompatible types. Type compatibility is defined as follows:

  • Any array type is compatible with itself.
  • A value-type array is compatible with an Object array and with an interface type implemented by that particular value type. Furthermore, a value-type array is considered connected to an interface only if it implements that interface directly. Disconnected array types are not compatible.
  • Two intrinsic (predefined) value-type arrays are compatible if the copying process from the source array type to the destination array type is a widening conversion. A widening conversion never loses data, whereas a narrowing conversion can lose data. For example, converting a 32-bit signed integer to a 64-bit signed integer is a widening conversion; converting a 64-bit signed integer to a 32-bit signed integer is a narrowing conversion.
  • A nonintrinsic (user-defined) value-type array is compatible only with itself.

If every object in the source array requires a downcast (for example, from a base class to a derived class or from an interface to an object) and one or more objects cannot be cast to the corresponding type in the destination array, an InvalidCastException exception is thrown.

If this method throws an exception while copying objects, the state of the destinationArray parameter is undefined.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


Array.Copy Method

Array.Copy Method

Copies a specified range of objects from an array to another array and performs type casting and boxing, as required.

Expand image Overload List

Name | Description
Array.Copy (Array, Array, Int32) | Copies a specified range of objects from an array (source array), starting at the first object in the array, and pastes them into another array (destination array), starting at the first object in that array. You specify the length of the range to be copied as a 32-bit integer.
Array.Copy (Array, Int32, Array, Int32, Int32) | Copies a specified range of objects from an array (source array) and pastes them into another array (destination array). Copying starts at the specified index number in the source array; pasting starts at the specified index number in the destination array. You specify the length of the range to be copied and the starting index numbers for the range in both the source and destination arrays as 32-bit integers.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


Array.Copy Method (Array, Array, Int32)

Array.Copy Method (Array, Array, Int32)
See Also
CollapseAll image

Copies a specified range of objects from an array (source array), starting at the first object in the array, and pastes them into another array (destination array), starting at the first object in that array. You specify the length of the range to be copied as a 32-bit integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static void Copy (
         Array sourceArray,
         Array destinationArray,
         int length
)

Parameters

sourceArray
The array that contains the range of objects you want to copy.
destinationArray
The array in which you want to paste the copied objects.
length
A 32-bit integer that represents the number of objects you want to copy.

Expand image Remarks

The sourceArray and destinationArray parameters must have the same number of dimensions.

When you copy objects between multidimensional arrays, the arrays behave like long one-dimensional arrays, where the rows or columns are conceptually laid end to end. For example, if an array has three rows (or columns) containing four objects each, copying six objects from the beginning of the source array would copy all four objects in the first row (or column) and the first two objects in the second row (or column).

If the values of the sourceArray and destinationArray parameters overlap, this method behaves as if the original sourceArray values were preserved in a temporary location before the destinationArray parameter was overwritten.

The arrays can be either reference-type arrays or value-type arrays. Type downcasting is performed, as required.

  • When you copy objects from a reference-type array to a value-type array, each object is unboxed and then copied. When you copy objects from a value-type array to a reference-type array, each object is boxed and then copied.
  • When you copy objects from a reference-type or value-type array to an Object array, an instance of the Object class is created for each reference or value to be copied, and then the objects are copied. When you copy objects from an Object array to a reference-type or value-type array and the assignment is not possible, an InvalidCastException exception is thrown.
  • If the source array and the destination array are both reference-type arrays or are both Object arrays, a shallow copy is created. A shallow copy of an array is a new array that contains references to all of the objects in the source array, but not the objects themselves or anything referenced by those objects. By contrast, a deep copy of an array contains all of the objects from the source array and everything directly or indirectly referenced by those objects.

An ArrayTypeMismatchException exception is thrown if the source and destination arrays are of incompatible types. Type compatibility is defined as follows:

  • Any array type is compatible with itself.
  • A value-type array is compatible with an Object array and with an interface type implemented by that particular value type. Furthermore, a value-type array is considered connected to an interface only if it implements that interface directly. Disconnected array types are not compatible.
  • Two intrinsic (predefined) value-type arrays are compatible if the copying process from the source array type to the destination array type is a widening conversion. A widening conversion never loses data, whereas a narrowing conversion can lose data. For example, converting a 32-bit signed integer to a 64-bit signed integer is a widening conversion; converting a 64-bit signed integer to a 32-bit signed integer is a narrowing conversion.
  • A nonintrinsic (user-defined) value-type array is compatible only with itself.

If every object in the source array requires a downcast (for example, from a base class to a derived class or from an interface to an object) and one or more objects cannot be cast to the corresponding type in the destination array, an InvalidCastException exception is thrown.

If this method throws an exception while copying objects, the state of the destinationArray parameter is undefined.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


AssemblyCopyrightAttribute.Copyright Property

AssemblyCopyrightAttribute.Copyright Property

Gets copyright information.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Copyright { get; }

Property Value

A string that contains copyright information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCopyrightAttribute Class
AssemblyCopyrightAttribute Members
System.Reflection Namespace


ArrayList.CopyTo Method (Array)

ArrayList.CopyTo Method (Array)
See Also
CollapseAll image

Copies the entire ArrayList collection to a compatible one-dimensional array, starting at the beginning of the destination array.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array
)

Parameters

array
The one-dimensional array that is the destination for the objects copied from the ArrayList collection. The destination array must have zero-based indexing.

Expand image Remarks

The specified array must be of a type compatible with the objects in the ArrayList collection.

This method calls the Array.Copy method to copy the objects from the ArrayList collection.

The objects are copied to the destination array in the same order in which the enumerator iterates through the ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.CopyTo Method

Array.CopyTo Method

Copies all of the objects from a one-dimensional array (source array) to another one-dimensional array (destination array), starting at the specified index number in the destination array. You specify this index number as a 32-bit integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array,
         int index
)

Parameters

array
The one-dimensional destination array to which you want to copy the objects.
index
A 32-bit integer that represents the index number in the destination array at which you want the copying to begin.

Expand image Remarks

This method supports the System.Collections.ICollection interface. If implementing this interface is not explicitly required, use the Copy method instead of this method to avoid an extra indirection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.CopyTo Method

ArrayList.CopyTo Method

Copies objects from the ArrayList collection to a specified one-dimensional array.

Expand image Overload List

Name | Description
ArrayList.CopyTo (Array) | Copies the entire ArrayList collection to a compatible one-dimensional array, starting at the beginning of the destination array.
ArrayList.CopyTo (Array, Int32) | Copies the entire ArrayList collection to a compatible one-dimensional array, starting at the specified index number in the destination array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ArrayList.CopyTo Method (Array, Int32)

ArrayList.CopyTo Method (Array, Int32)
See Also
CollapseAll image

Copies the entire ArrayList collection to a compatible one-dimensional array, starting at the specified index number in the destination array.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array,
         int arrayIndex
)

Parameters

array
The one-dimensional array that is the destination of the objects copied from the ArrayList collection. The destination array must have zero-based indexing.
arrayIndex
The zero-based index number in the array parameter where you want the copying to begin.

Expand image Remarks

The specified array must be of a type compatible with the objects in the ArrayList collection.

This method calls the Array.Copy method to copy the objects from the ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


UIElementCollection.CopyTo Method (Array, Int32)

UIElementCollection.CopyTo Method (Array, Int32)
See Also
CollapseAll image

Copies the UIElement objects from the current collection to a generic array, starting at a specified index number (position) in the collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array,
         int index
)

Parameters

array
A generic array into which you want to copy the UIElement objects.
index
The index number in the current collection where you want copying to begin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


UIElementCollection.CopyTo Method (UIElement[], Int32)

UIElementCollection.CopyTo Method (UIElement[], Int32)
See Also
CollapseAll image

Copies the UIElement objects from the current collection to a UIElement array, starting at a specified index number (position) in the collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         UIElement[] array,
         int index
)

Parameters

array
A UIElement array into which you want to copy the UIElement objects.
index
The index number in the current collection where you want copying to begin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


ICollection.CopyTo Method

ICollection.CopyTo Method

When implemented by a class, this method copies objects from an ICollection collection to a specified array (destination array), starting at a specified index number in the destination array.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void CopyTo (
         Array array,
         int index
)

Parameters

array
The one-dimensional array to which you want to copy objects from the collection. The destination array must have zero-based indexing.
index
The zero-based index number at which you want copying to begin in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICollection Interface
ICollection Members
System.Collections Namespace


ListBoxItemCollection.CopyTo Method

ListBoxItemCollection.CopyTo Method

Copies all or part of the current collection into a specified array.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array,
         int index
)

Parameters

array
The array that is the destination of the copy operation.
index
The index number in the current collection where you want copying to start.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.CopyTo Method

TextRunCollection.CopyTo Method

Copies a specified portion of the current text run collection into a specified array.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual void CopyTo (
         Array array,
         int index
)

Parameters

array
The array into which the specified TextRun objects are to be copied.
index
The index number of the first TextRun object to be copied into the array specified by the array parameter. This index number indicates the position in the text run collection where copying is to begin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.CopyTo Method

UIElementCollection.CopyTo Method

Copies the UIElement objects from the current collection to an array, starting at a specified index number (position) in the collection.

Expand image Overload List

Name | Description
UIElementCollection.CopyTo (Array, Int32) | Copies the UIElement objects from the current collection to a generic array, starting at a specified index number (position) in the collection.
UIElementCollection.CopyTo (UIElement[], Int32) | Copies the UIElement objects from the current collection to a UIElement array, starting at a specified index number (position) in the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WindowCollection.CopyTo Method

WindowCollection.CopyTo Method

Copies Window objects from a window collection to a specified array, starting at a specified index number in the window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void CopyTo (
         Window[] array,
         int index
)

Parameters

array
An array of Window objects that is the destination of the copy operation.
index
The starting index number in the window collection where copying is to begin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


Math.Cos Method

Math.Cos Method

Gets the cosine of the specified angle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Cos (
         int angle
)

Parameters

angle
An angle, measured in degrees.

Return Value

The cosine of the specified angle, multiplied by 1000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
Microsoft.SPOT Namespace


ArrayList.Count Property

ArrayList.Count Property

Gets the number of objects that the ArrayList collection actually contains.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int Count { get; }

Property Value

The number of objects that the ArrayList actually contains.

Expand image Remarks

The Count property denotes the number of objects that the ArrayList collection actually contains. The Capacity property denotes the maximum number of objects that the ArrayList collection is capable of storing. By definition, the value of Capacity is always greater than or equal to the value of Count. If the Count value surpasses the Capacity value while objects are being added to the collection, the capacity of the list is automatically doubled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.System.Collections.ICollection.Count Property

Array.System.Collections.ICollection.Count Property

Gets the number of objects contained in a specific array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
private virtual int System.Collections.ICollection.Count { get; }

Property Value

The number of objects contained in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ICollection.Count Property

ICollection.Count Property

When implemented by a class, this property gets the number of objects contained in a specific ICollection collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract int Count { get; }

Property Value

The number of objects contained in the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICollection Interface
ICollection Members
System.Collections Namespace


ListBoxItemCollection.Count Property

ListBoxItemCollection.Count Property

Gets the number of items (elements) in the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual int Count { get; }

Property Value

The number of items in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Count Property

TextRunCollection.Count Property

Gets the number of objects in the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual int Count { get; }

Property Value

The number of TextRun objects in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Count Property

UIElementCollection.Count Property

Gets the actual number of elements in the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual int Count { get; }

Property Value

The actual number of elements in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WindowCollection.Count Property

WindowCollection.Count Property

Gets the number of Window objects in a particular window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual int Count { get; }

Property Value

An integer that specifies the number of Window objects in the window collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


AppDomain.CreateDomain Method

AppDomain.CreateDomain Method

Creates a new application domain with the specified name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static AppDomain CreateDomain (
         string friendlyName
)

Parameters

friendlyName
The "friendly" name of the application domain.

Return Value

The newly created application domain.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


Array.CreateInstance Method

Array.CreateInstance Method

Creates a one-dimensional array of the specified type and length, with zero-based indexing.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Array CreateInstance (
         Type elementType,
         int length
)

Parameters

elementType
The type of array you want to create.
length
The size of the array you want to create.

Return Value

A new one-dimensional array of the specified type and with the specified length, with zero-based indexing.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


AppDomain.CreateInstanceAndUnwrap Method

AppDomain.CreateInstanceAndUnwrap Method

Creates a new instance of the specified type. Parameters specify the name of the type and the display name of the assembly where the type is defined.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Object CreateInstanceAndUnwrap (
         string assemblyName,
         string typeName
)

Parameters

assemblyName
The display name of the assembly.
typeName
The fully qualified name of the requested type.

Return Value

An instance of the object specified by the typeName parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


RoutedEventArgs Constructor (RoutedEvent)

RoutedEventArgs Constructor (RoutedEvent)
See Also
CollapseAll image

Initializes a new instance of the RoutedEventArgs class, using the routed event identifier that is provided.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutedEventArgs (
         RoutedEvent routedEvent
)

Parameters

routedEvent
The routed event identifier for the current RoutedEventArgs object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


DispatcherFrame Constructor (Boolean)

DispatcherFrame Constructor (Boolean)
See Also
CollapseAll image

Initializes a new instance of the DispatcherFrame class, using the specified exit request flag.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherFrame (
         bool exitWhenRequested
)

Parameters

exitWhenRequested
Indicates whether the current dispatcher frame will exit when all frames are requested to exit.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherFrame Class
DispatcherFrame Members
Microsoft.SPOT Namespace


AppDomainUnloadedException Constructor (String)

AppDomainUnloadedException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the AppDomainUnloadedException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AppDomainUnloadedException (
         string message
)

Parameters

message
The error message that explains the reason for the exception.

Expand image Remarks

The text in the message parameter is intended to be understood by humans. Whoever calls this constructor should ensure that the message text has been localized for the current system culture.

The following table lists the initial property values for an instance of the AppDomainUnloadedException class.

Property | Value
InnerException | A null reference
Message | The error message string

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomainUnloadedException Class
AppDomainUnloadedException Members
System Namespace


ApplicationException Constructor (String)

ApplicationException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the ApplicationException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ApplicationException (
         string message
)

Parameters

message
The error message that explains the reason for the exception.

Expand image Remarks

The content of the message parameter is intended to be understood by humans. The caller of this constructor should ensure that this string has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ApplicationException Class
ApplicationException Members
System Namespace


ArgumentException Constructor (String)

ArgumentException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentException (
         string message
)

Parameters

message
The error message that explains the reason for the exception.

Expand image Remarks

This constructor initializes the Message property of the new instance, using the value of the message parameter. The content of the message parameter is intended to be understood by humans. The caller of this constructor should ensure that this string has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


ArgumentNullException Constructor (String)

ArgumentNullException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentNullException class with the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentNullException (
         string argument
)

Parameters

argument
The name of the parameter that caused the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentNullException Class
ArgumentNullException Members
System Namespace


ArgumentOutOfRangeException Constructor (String)

ArgumentOutOfRangeException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentOutOfRangeException class with the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentOutOfRangeException (
         string paramName
)

Parameters

paramName
The name of the parameter that caused the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentOutOfRangeException Class
ArgumentOutOfRangeException Members
System Namespace


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the DateTime structure and sets it to the specified year, month, day, hour, minute, second, and millisecond.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime (
         int year,
         int month,
         int day,
         int hour,
         int minute,
         int second,
         int millisecond
)

Parameters

year
The year, expressed as a number ranging from 1 through 9999.
month
The month, expressed as a number ranging from 1 through 12.
day
The day, expressed as a number ranging from 1 through 31.
hour
The hour, expressed as a number ranging from 0 through 23.
minute
The minute, expressed as a number ranging from 0 through 59.
second
The second, expressed as a number ranging from 0 through 59.
millisecond
The millisecond, expressed as a number ranging from 0 through 999.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DebuggerTypeProxyAttribute Constructor (String)

DebuggerTypeProxyAttribute Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the DebuggerTypeProxyAttribute class, using a string that represents the type of the proxy.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerTypeProxyAttribute (
         string typeName
)

Parameters

typeName
A string that represents the name of the proxy type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


Exception Constructor (String)

Exception Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the Exception class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Exception (
         string message
)

Parameters

message
An error message that explains the reason for the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


IndexOutOfRangeException Constructor (String)

IndexOutOfRangeException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the IndexOutOfRangeException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public IndexOutOfRangeException (
         string message
)

Parameters

message
An error message that explains the reason for the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
System Namespace


InvalidCastException Constructor (String)

InvalidCastException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the InvalidCastException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidCastException (
         string message
)

Parameters

message
The error message that explains the reason for the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidCastException Class
InvalidCastException Members
System Namespace


InvalidOperationException Constructor (String)

InvalidOperationException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the InvalidOperationException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidOperationException (
         string message
)

Parameters

message
The error message that explains the reason for the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidOperationException Class
InvalidOperationException Members
System Namespace


NotImplementedException Constructor (String)

NotImplementedException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the NotImplementedException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotImplementedException (
         string message
)

Parameters

message
The error message that explains the reason for the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotImplementedException Class
NotImplementedException Members
System Namespace


NotSupportedException Constructor (String)

NotSupportedException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the NotSupportedException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotSupportedException (
         string message
)

Parameters

message
The error message that explains the reason for the exception. This error message should be understandable to humans. Whoever calls this constructor must ensure that the error message has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotSupportedException Class
NotSupportedException Members
System Namespace


NullReferenceException Constructor (String)

NullReferenceException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the NullReferenceException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NullReferenceException (
         string message
)

Parameters

message
The error message that explains the reason for the exception. This error message should be understandable to humans. Whoever calls this constructor must ensure that the error message has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NullReferenceException Class
NullReferenceException Members
System Namespace


ObsoleteAttribute Constructor (String)

ObsoleteAttribute Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the ObsoleteAttribute class with a specified work-around message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ObsoleteAttribute (
         string message
)

Parameters

message
The text string that describes the available work-arounds (alternative approaches) for this situation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


OutOfMemoryException Constructor (String)

OutOfMemoryException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the OutOfMemoryException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public OutOfMemoryException (
         string message
)

Parameters

message
The error message that explains the reason for the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
System Namespace


SystemException Constructor (String)

SystemException Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the SystemException class with a specified error message.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public SystemException (
         string message
)

Parameters

message
The error message that explains the reason for the current exception.

Expand image Remarks

The content of the error message should be understandable to humans. Whoever calls this constructor should ensure that the message has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemException Class
SystemException Members
System Namespace


Text Constructor (String)

Text Constructor (String)
See Also
CollapseAll image

Initializes a new instance of the Text class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Text (
         string content
)

Parameters

content
The text string that constitutes the contents of the new Text object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TimeSpan Constructor (Int32, Int32, Int32, Int32, Int32)

TimeSpan Constructor (Int32, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the TimeSpan structure and sets it to the specified number of days, hours, minutes, seconds, and milliseconds.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan (
         int days,
         int hours,
         int minutes,
         int seconds,
         int milliseconds
)

Parameters

days
The number of days in the specified time period.
hours
The number of hours in the specified time period.
minutes
The number of minutes in the specified time period.
seconds
The number of seconds in the specified time period.
milliseconds
The number of milliseconds in the specified time period.

Expand image Remarks

The components of the specified time period — that is, the days, hours, minutes, seconds, and milliseconds — are converted to ticks. The new TimeSpan object is then initialized to that number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


AssemblyFlagsAttribute Constructor (AssemblyNameFlags)

AssemblyFlagsAttribute Constructor (AssemblyNameFlags)
See Also
CollapseAll image

Initializes a new instance of the AssemblyFlagsAttribute class and sets the assembly name flags.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyFlagsAttribute (
         AssemblyNameFlags assemblyFlags
)

Parameters

assemblyFlags
One or more values from the AssemblyNameFlags enumeration that are combined in a bitwise OR operation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyFlagsAttribute Class
AssemblyFlagsAttribute Members
System.Reflection Namespace


ArgumentException Constructor (String, String)

ArgumentException Constructor (String, String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentException class with a specified error message and the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentException (
         string message,
         string paramName
)

Parameters

message
The error message that explains the reason for the current exception.
paramName
The name of the parameter that caused the current exception.

Expand image Remarks

This constructor initializes the Message property of the new instance, using the value of the message parameter. The content of the message parameter is intended to be understood by humans. The caller of this constructor should ensure that this string has been localized for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


ArgumentNullException Constructor (String, String)

ArgumentNullException Constructor (String, String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentNullException class with a specified error message and the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentNullException (
         string paramName,
         string message
)

Parameters

paramName
The name of the parameter that caused the exception.
message
The error message that explains the reason for the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentNullException Class
ArgumentNullException Members
System Namespace


ArgumentOutOfRangeException Constructor (String, String)

ArgumentOutOfRangeException Constructor (String, String)
See Also
CollapseAll image

Initializes a new instance of the ArgumentOutOfRangeException class with a specified error message and the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentOutOfRangeException (
         string paramName,
         string message
)

Parameters

paramName
The name of the parameter that caused the exception.
message
The error message that explains the reason for the exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentOutOfRangeException Class
ArgumentOutOfRangeException Members
System Namespace


Text Constructor (Font, String)

Text Constructor (Font, String)
See Also
CollapseAll image

Initializes a new instance of the Text class and sets its content and font.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Text (
         Font font,
         string content
)

Parameters

font
Specifies the font to use when displaying the text.
content
Holds the text string to display.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


ArgumentException Constructor (String, String, Exception)

ArgumentException Constructor (String, String, Exception)
See Also
CollapseAll image

Initializes a new instance of the ArgumentException class with a specified error message, the parameter name, and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentException (
         string message,
         string paramName,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
paramName
The name of the parameter that caused the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Remarks

This constructor initializes the Message property of the new instance, using the value of the message parameter. The content of the message parameter is intended to be understood by humans. The caller of this constructor should ensure that this string has been localized for the current system culture.

An exception that is thrown as a direct result of a previous exception should include a reference to the previous exception in the InnerException property. The InnerException property returns the same value that is passed into the constructor, or it returns a null reference if this property does not supply the inner exception value to the constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


DebuggerTypeProxyAttribute Constructor (Type)

DebuggerTypeProxyAttribute Constructor (Type)
See Also
CollapseAll image

Initializes a new instance of the DebuggerTypeProxyAttribute class, using a Type object that represents the type of the proxy.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerTypeProxyAttribute (
         Type type
)

Parameters

type
A Type object that represents the name of the proxy type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


ExtendedTimer Constructor (TimerCallback, Object, DateTime, TimeSpan)

ExtendedTimer Constructor (TimerCallback, Object, DateTime, TimeSpan)
See Also
CollapseAll image

Initializes a new instance of the ExtendedTimer class, using System.DateTime and System.TimeSpan values to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ExtendedTimer (
         TimerCallback callback,
         Object state,
         DateTime dueTime,
         TimeSpan period
)

Parameters

callback
The callback method that is executed when the timer expires.
state
An object that contains application-specific information relevant to the methods invoked by the callback method, or a null reference.
dueTime
The System.DateTime value that represents the amount of time the timer will wait before the callback method invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The System.TimeSpan value that represents the time interval between invocations of the methods referenced by the callback method, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


ExtendedTimer Constructor (TimerCallback, Object, TimeSpan, TimeSpan)

ExtendedTimer Constructor (TimerCallback, Object, TimeSpan, TimeSpan)
See Also
CollapseAll image

Initializes a new instance of the ExtendedTimer class, using System.TimeSpan values to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ExtendedTimer (
         TimerCallback callback,
         Object state,
         TimeSpan dueTime,
         TimeSpan period
)

Parameters

callback
The callback method that is executed when the timer expires.
state
An object that contains application-specific information relevant to the methods invoked by the callback method, or a null reference.
dueTime
The amount of time the timer will wait before the callback method invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The time interval between invocations of the methods referenced by the callback method, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


Timer Constructor (TimerCallback, Object, TimeSpan, TimeSpan)

Timer Constructor (TimerCallback, Object, TimeSpan, TimeSpan)
See Also
CollapseAll image

Initializes a new instance of the Timer class, using TimeSpan values to specify time intervals.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Timer (
         TimerCallback callback,
         Object state,
         TimeSpan dueTime,
         TimeSpan period
)

Parameters

callback
A TimerCallback delegate that represents the method to be executed.
state
An object that contains information to be used by the callback method, or a null reference.
dueTime
A TimeSpan object that represents the amount of time you want the system to delay before the callback parameter invokes its methods. Specify -1 milliseconds to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The time interval between invocations of the methods referenced by the callback method. Specify -1 milliseconds to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


Bitmap Constructor (Byte[], BitmapImageType)

Bitmap Constructor (Byte[], BitmapImageType)
See Also
CollapseAll image

Initializes a new instance of the Bitmap class to the specified height and width.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Bitmap (
         byte[] imageData,
         BitmapImageType type
)

Parameters

imageData
An array of pixel data for the specified image.
type
The bitmap type for the specified image.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ObsoleteAttribute Constructor (String, Boolean)

ObsoleteAttribute Constructor (String, Boolean)
See Also
CollapseAll image

Initializes a new instance of the ObsoleteAttribute class with a specified work-around message and a Boolean value that indicates whether the use of this obsolete program element is considered an error.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ObsoleteAttribute (
         string message,
         bool error
)

Parameters

message
The text string that describes the available work-arounds (alternative approaches) for this situation.
error
A Boolean value that indicates whether the use of this obsolete element is considered an error.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


MethodImplAttribute Constructor (MethodImplOptions)

MethodImplAttribute Constructor (MethodImplOptions)
See Also
CollapseAll image

Initializes a new instance of the MethodImplAttribute class with a specified MethodImplOptions value.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodImplAttribute (
         MethodImplOptions methodImplOptions
)

Parameters

methodImplOptions
A MethodImplOptions value that specifies properties of the method being attributed.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


DrawingContext Constructor (Bitmap)

DrawingContext Constructor (Bitmap)
See Also
CollapseAll image

Initializes a new instance of the DrawingContext class that uses a specified bitmapped image as the background on its drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DrawingContext (
         Bitmap bmp
)

Parameters

bmp
A Bitmap object that specifies the bitmapped image to be used as the background on the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Image Constructor (Bitmap)

Image Constructor (Bitmap)
See Also
CollapseAll image

Initializes a new instance of the Image class and sets its bitmap.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Image (
         Bitmap bmp
)

Parameters

bmp
The bitmap to be stored in the image control.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


StructLayoutAttribute Constructor (LayoutKind)

StructLayoutAttribute Constructor (LayoutKind)
See Also
CollapseAll image

Initalizes a new instance of the StructLayoutAttribute class with a specified LayoutKind enumeration member.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public StructLayoutAttribute (
         LayoutKind layoutKind
)

Parameters

layoutKind
One of the LayoutKind values that specifes how a particular class or structure should be arranged.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


ExtendedTimer Constructor (TimerCallback, Object, TimeEvents)

ExtendedTimer Constructor (TimerCallback, Object, TimeEvents)
See Also
CollapseAll image

Initializes a new instance of the ExtendedTimer class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ExtendedTimer (
         TimerCallback callback,
         Object state,
         TimeEvents ev
)

Parameters

callback
The callback method that is executed when the timer expires.
state
An object that contains application-specific information relevant to the methods invoked by the callback method, or a null reference.
ev
The event on which the callback method is to be executed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


String Constructor (Char[], Int32, Int32)

String Constructor (Char[], Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the String class with a value indicated by a specified array of Unicode characters, a specified starting index number (character position) in that array, and a specified length (number of characters).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public String (
         char[] value,
         int startIndex,
         int length
)

Parameters

value
The specified array of Unicode characters.
startIndex
The index number in the Unicode array where you want the copying of characters to begin.
length
The number of characters you want to copy from the Unicode array.

Expand image Remarks

If the length of the string passed in the array parameter is 0 (zero), an empty instance of the String class is initialized.

This constructor copies Unicode characters from the value parameter, starting at startIndex and ending at (startIndex + length - 1).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DateTime Constructor (Int64)

DateTime Constructor (Int64)
See Also
CollapseAll image

Initializes a new instance of the DateTime structure and sets it to the specified number of ticks.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime (
         long ticks
)

Parameters

ticks
A date and time expressed in ticks (100-nanosecond units).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan Constructor (Int64)

TimeSpan Constructor (Int64)
See Also
CollapseAll image

Initializes a new instance of the TimeSpan structure and sets it to the specified number of ticks.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan (
         long ticks
)

Parameters

ticks
A specific time period expressed in 100-nanosecond units, or ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


AppDomainUnloadedException Constructor (String, Exception)

AppDomainUnloadedException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the AppDomainUnloadedException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AppDomainUnloadedException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Remarks

The text in the message parameter is intended to be understood by humans. Whoever calls this constructor should ensure that the message text has been localized for the current system culture.

An exception that is thrown as a direct result of a previous exception should include a reference to the previous exception in the innerException parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomainUnloadedException Class
AppDomainUnloadedException Members
System Namespace


ApplicationException Constructor (String, Exception)

ApplicationException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the ApplicationException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ApplicationException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ApplicationException Class
ApplicationException Members
System Namespace


ArgumentException Constructor (String, Exception)

ArgumentException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the ArgumentException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Remarks

This constructor initializes the Message property of the new instance of the ArgumentException class, using the value of the message parameter. The content of the message parameter is intended to be understood by humans. The caller of this constructor should ensure that this string has been localized for the current system culture.

An exception that is thrown as a direct result of a previous exception should include a reference to the previous exception in the InnerException property. The InnerException property returns the same value that is passed into the constructor, or it returns a null reference if the this property does not supply the inner exception value to the constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the DateTime structure and sets it to the specified year, month, day, hour, minute, and second.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime (
         int year,
         int month,
         int day,
         int hour,
         int minute,
         int second
)

Parameters

year
The year, expressed as a number ranging from 1 through 9999.
month
The month, expressed as a number ranging from 1 through 12.
day
The day, expressed as a number ranging from 1 through 31.
hour
The hour, expressed as a number ranging from 0 through 23.
minute
The minute, expressed as a number ranging from 0 through 59.
second
The second, expressed as a number ranging from 0 through 59.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Exception Constructor (String, Exception)

Exception Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Exception (
         string message,
         Exception innerException
)

Parameters

message
An error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


IndexOutOfRangeException Constructor (String, Exception)

IndexOutOfRangeException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the IndexOutOfRangeException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public IndexOutOfRangeException (
         string message,
         Exception innerException
)

Parameters

message
An error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
System Namespace


InvalidCastException Constructor (String, Exception)

InvalidCastException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the InvalidCastException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidCastException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Supported in .NET Micro Framework 2.0

Expand image See Also

Reference

InvalidCastException Class
InvalidCastException Members
System Namespace


InvalidOperationException Constructor (String, Exception)

InvalidOperationException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the InvalidOperationException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidOperationException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidOperationException Class
InvalidOperationException Members
System Namespace


NotImplementedException Constructor (String, Exception)

NotImplementedException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the NotImplementedException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotImplementedException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotImplementedException Class
NotImplementedException Members
System Namespace


NotSupportedException Constructor (String, Exception)

NotSupportedException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the NotSupportedException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotSupportedException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the exception. This error message should be understandable to humans. Whoever calls this constructor must ensure that the error message has been localized for the current system culture.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotSupportedException Class
NotSupportedException Members
System Namespace


NullReferenceException Constructor (String, Exception)

NullReferenceException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the NullReferenceException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NullReferenceException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the exception. This error message should be understandable to humans. Whoever calls this constructor must ensure that the error message has been localized for the current system culture.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NullReferenceException Class
NullReferenceException Members
System Namespace


OutOfMemoryException Constructor (String, Exception)

OutOfMemoryException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the OutOfMemoryException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public OutOfMemoryException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
System Namespace


SystemException Constructor (String, Exception)

SystemException Constructor (String, Exception)
See Also
CollapseAll image

Initializes a new instance of the SystemException class with a specified error message and a reference to the inner exception that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public SystemException (
         string message,
         Exception innerException
)

Parameters

message
The error message that explains the reason for the current exception.
innerException
The exception that caused the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemException Class
SystemException Members
System Namespace


TimeSpan Constructor (Int32, Int32, Int32, Int32)

TimeSpan Constructor (Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the TimeSpan structure and sets it to the specified number of days, hours, minutes, and seconds.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan (
         int days,
         int hours,
         int minutes,
         int seconds
)

Parameters

days
The number of days in the specified time period.
hours
The number of hours in the specified time period.
minutes
The number of minutes in the specified time period.
seconds
The number of seconds in the specified time period.

Expand image Remarks

The components of the specified time period — that is, the days, hours, minutes, and seconds — are converted to ticks. The new TimeSpan instance is then initialized to that number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


StackPanel Constructor (Orientation)

StackPanel Constructor (Orientation)
See Also
CollapseAll image

Initializes a new instance of the StackPanel class and sets the orientation for child element (child object) presentation.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StackPanel (
         Orientation orientation
)

Parameters

orientation
A value that specifies the presentation of user interface child elements, each of which is represented by an object. Child objects can be presented collectively as either a horizontal or vertical line of elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


Pen Constructor (Color)

Pen Constructor (Color)
See Also
CollapseAll image

Initializes a new instance of the Pen class with a specified color.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Pen (
         Color color
)

Parameters

color
A value of the Color enumeration that specifies the color of the current pen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Class
Pen Members
Microsoft.SPOT.Presentation.Media Namespace


String Constructor (Char[])

String Constructor (Char[])
See Also
CollapseAll image

Initializes a new instance of the String class with a value indicated by a specified array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public String (
         char[] value
)

Parameters

value
The specified array of Unicode characters.

Expand image Remarks

If the value parameter is a null reference or devoid of elements, an empty instance of the String class is initialized.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


ExtendedTimer Constructor (TimerCallback, Object, Int32, Int32)

ExtendedTimer Constructor (TimerCallback, Object, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the ExtendedTimer class, using 32-bit signed integers to measure time intervals.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ExtendedTimer (
         TimerCallback callback,
         Object state,
         int dueTime,
         int period
)

Parameters

callback
The callback method that is executed when the timer expires.
state
An object that contains application-specific information relevant to the methods invoked by the callback method, or a null reference.
dueTime
The amount of time the timer will wait before the callback method invokes its methods, in milliseconds. Specify System.Threading.Timeout.Infinite to prevent the timer from starting. Specify 0 (zero) to start the timer immediately.
period
The time interval between invocations of the methods referenced by the callback method, in milliseconds. Specify System.Threading.Timeout.Infinite to disable periodic signaling.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


Timer Constructor (TimerCallback, Object, Int32, Int32)

Timer Constructor (TimerCallback, Object, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the Timer class, using a 32-bit signed integer to specify the time interval.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Timer (
         TimerCallback callback,
         Object state,
         int dueTime,
         int period
)

Parameters

callback
A TimerCallback delegate that represents the method to be executed.
state
An object that contains information to be used by the callback method, or a null reference.
dueTime
The amount of time you want the system to delay before callback is invoked, in milliseconds. Specify zero (0) to start the timer immediately.
period
The time interval between invocations of the callback method, in milliseconds.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


String Constructor (Char, Int32)

String Constructor (Char, Int32)
See Also
CollapseAll image

Initializes a new instance of the String class with a value indicated by a specified Unicode character repeated a specified number of times.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public String (
         char c,
         int count
)

Parameters

c
The specified Unicode character.
count
The number of times you want the specified character to be repeated.

Expand image Remarks

If the value of the count parameter is 0 (zero), an empty instance of the String class is initialized.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


AppDomainUnloadedException Constructor ()

AppDomainUnloadedException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the AppDomainUnloadedException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AppDomainUnloadedException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomainUnloadedException Class
AppDomainUnloadedException Members
System Namespace


AppDomainUnloadedException Constructor

AppDomainUnloadedException Constructor

Initializes a new instance of the AppDomainUnloadedException class.

Expand image Overload List

Name | Description
AppDomainUnloadedException () | Initializes a new instance of the AppDomainUnloadedException class.
AppDomainUnloadedException (String) | Initializes a new instance of the AppDomainUnloadedException class with a specified error message.
AppDomainUnloadedException (String, Exception) | Initializes a new instance of the AppDomainUnloadedException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomainUnloadedException Class
AppDomainUnloadedException Members
System Namespace


Application Constructor

Application Constructor

Initializes a new instance of the Application class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Application ()

Expand image Remarks

Only one instance of the Application class can be created per AppDomain object. This constructor detects whether the Application object being initialized is the first such object in a specific application domain and, if not, raises the InvalidOperationException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


ApplicationException Constructor ()

ApplicationException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the ApplicationException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ApplicationException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ApplicationException Class
ApplicationException Members
System Namespace


ApplicationException Constructor

ApplicationException Constructor

Initializes a new instance of the ApplicationException class.

Expand image Overload List

Name | Description
ApplicationException () | Initializes a new instance of the ApplicationException class.
ApplicationException (String) | Initializes a new instance of the ApplicationException class with a specified error message.
ApplicationException (String, Exception) | Initializes a new instance of the ApplicationException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ApplicationException Class
ApplicationException Members
System Namespace


ArgumentException Constructor ()

ArgumentException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the ArgumentException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentException ()

Expand image Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "An invalid argument was specified." This message takes into account the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


ArgumentException Constructor

ArgumentException Constructor

Initializes a new instance of the ArgumentException class.

Expand image Overload List

Name | Description
ArgumentException () | Initializes a new instance of the ArgumentException class.
ArgumentException (String) | Initializes a new instance of the ArgumentException class with a specified error message.
ArgumentException (String, Exception) | Initializes a new instance of the ArgumentException class with a specified error message and a reference to the inner exception that caused the current exception.
ArgumentException (String, String) | Initializes a new instance of the ArgumentException class with a specified error message and the name of the parameter that caused this exception.
ArgumentException (String, String, Exception) | Initializes a new instance of the ArgumentException class with a specified error message, the parameter name, and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


ArgumentNullException Constructor ()

ArgumentNullException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the ArgumentNullException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentNullException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentNullException Class
ArgumentNullException Members
System Namespace


ArgumentNullException Constructor

ArgumentNullException Constructor

Initializes a new instance of the ArgumentNullException class.

Expand image Overload List

Name | Description
ArgumentNullException () | Initializes a new instance of the ArgumentNullException class.
ArgumentNullException (String) | Initializes a new instance of the ArgumentNullException class with the name of the parameter that caused this exception.
ArgumentNullException (String, String) | Initializes a new instance of the ArgumentNullException class with a specified error message and the name of the parameter that caused this exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentNullException Class
ArgumentNullException Members
System Namespace


ArgumentOutOfRangeException Constructor ()

ArgumentOutOfRangeException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the ArgumentOutOfRangeException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArgumentOutOfRangeException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentOutOfRangeException Class
ArgumentOutOfRangeException Members
System Namespace


ArgumentOutOfRangeException Constructor

ArgumentOutOfRangeException Constructor

Initializes a new instance of the ArgumentOutOfRangeException class.

Expand image Overload List

Name | Description
ArgumentOutOfRangeException () | Initializes a new instance of the ArgumentOutOfRangeException class.
ArgumentOutOfRangeException (String) | Initializes a new instance of the ArgumentOutOfRangeException class with the name of the parameter that caused this exception.
ArgumentOutOfRangeException (String, String) | Initializes a new instance of the ArgumentOutOfRangeException class with a specified error message and the name of the parameter that caused this exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentOutOfRangeException Class
ArgumentOutOfRangeException Members
System Namespace


Array Constructor

Array Constructor

Initializes an instance of the Array class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected Array ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList Constructor

ArrayList Constructor

Initializes a new instance of the ArrayList class.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ArrayList ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Assembly Constructor

Assembly Constructor

Initializes a new instance of the Assembly class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Assembly ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


AssemblyCompanyAttribute Constructor

AssemblyCompanyAttribute Constructor

Initializes a new instance of the AssemblyCompanyAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyCompanyAttribute (
         string company
)

Parameters

company
Company name information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCompanyAttribute Class
AssemblyCompanyAttribute Members
System.Reflection Namespace


AssemblyConfigurationAttribute Constructor

AssemblyConfigurationAttribute Constructor

Initializes a new instance of the AssemblyConfigurationAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyConfigurationAttribute (
         string configuration
)

Parameters

configuration
The assembly configuration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyConfigurationAttribute Class
AssemblyConfigurationAttribute Members
System.Reflection Namespace


AssemblyCopyrightAttribute Constructor

AssemblyCopyrightAttribute Constructor

Initializes a new instance of the AssemblyCopyrightAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyCopyrightAttribute (
         string copyright
)

Parameters

copyright
Copyright information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCopyrightAttribute Class
AssemblyCopyrightAttribute Members
System.Reflection Namespace


AssemblyCultureAttribute Constructor

AssemblyCultureAttribute Constructor

Initializes a new instance of the AssemblyCultureAttribute class with the culture supported by the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyCultureAttribute (
         string culture
)

Parameters

culture
The culture supported by the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCultureAttribute Class
AssemblyCultureAttribute Members
System.Reflection Namespace


AssemblyDefaultAliasAttribute Constructor

AssemblyDefaultAliasAttribute Constructor

Initializes a new instance of the AssemblyDefaultAliasAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyDefaultAliasAttribute (
         string defaultAlias
)

Parameters

defaultAlias
The default alias information for an assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDefaultAliasAttribute Class
AssemblyDefaultAliasAttribute Members
System.Reflection Namespace


AssemblyDelaySignAttribute Constructor

AssemblyDelaySignAttribute Constructor

Initializes a new instance of the AssemblyDelaySignAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyDelaySignAttribute (
         bool delaySign
)

Parameters

delaySign
true if the current assembly has been built as delay-signed; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDelaySignAttribute Class
AssemblyDelaySignAttribute Members
System.Reflection Namespace


AssemblyDescriptionAttribute Constructor

AssemblyDescriptionAttribute Constructor

Initializes a new instance of the AssemblyDescriptionAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyDescriptionAttribute (
         string description
)

Parameters

description
The assembly description.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDescriptionAttribute Class
AssemblyDescriptionAttribute Members
System.Reflection Namespace


AssemblyFlagsAttribute Constructor

AssemblyFlagsAttribute Constructor

Initializes a new instance of the AssemblyFlagsAttribute class.

Expand image Overload List

Name | Description
AssemblyFlagsAttribute (AssemblyNameFlags) | Initializes a new instance of the AssemblyFlagsAttribute class and sets the assembly name flags.
AssemblyFlagsAttribute (UInt32) | Initializes a new instance of the AssemblyFlagsAttribute class with the specified side-by-side execution flag.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyFlagsAttribute Class
AssemblyFlagsAttribute Members
System.Reflection Namespace


Reflection.AssemblyInfo Constructor

Reflection.AssemblyInfo Constructor

Creates and initializes a new instance of the AssemblyInfo class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public Reflection.AssemblyInfo ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


AssemblyInformationalVersionAttribute Constructor

AssemblyInformationalVersionAttribute Constructor

Initializes a new instance of the AssemblyInformationalVersionAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyInformationalVersionAttribute (
         string informationalVersion
)

Parameters

informationalVersion
The version information for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyInformationalVersionAttribute Class
AssemblyInformationalVersionAttribute Members
System.Reflection Namespace


AssemblyKeyFileAttribute Constructor

AssemblyKeyFileAttribute Constructor

Initializes a new instance of the AssemblyKeyFileAttribute class with the name of the file containing the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyKeyFileAttribute (
         string keyFile
)

Parameters

keyFile
The name of the file containing the key pair.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyFileAttribute Class
AssemblyKeyFileAttribute Members
System.Reflection Namespace


AssemblyKeyNameAttribute Constructor

AssemblyKeyNameAttribute Constructor

Initializes a new instance of the AssemblyKeyNameAttribute class with the name of the container holding the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyKeyNameAttribute (
         string keyName
)

Parameters

keyName
The name of the container that holds the key pair.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyNameAttribute Class
AssemblyKeyNameAttribute Members
System.Reflection Namespace


AssemblyProductAttribute Constructor

AssemblyProductAttribute Constructor

Initializes a new instance of the AssemblyProductAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyProductAttribute (
         string product
)

Parameters

product
Product name information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyProductAttribute Class
AssemblyProductAttribute Members
System.Reflection Namespace


AssemblyTitleAttribute Constructor

AssemblyTitleAttribute Constructor

Initializes a new instance of the AssemblyTitleAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyTitleAttribute (
         string title
)

Parameters

title
The title of the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTitleAttribute Class
AssemblyTitleAttribute Members
System.Reflection Namespace


AssemblyTrademarkAttribute Constructor

AssemblyTrademarkAttribute Constructor

Initializes a new instance of the AssemblyTrademarkAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyTrademarkAttribute (
         string trademark
)

Parameters

trademark
The trademark information for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTrademarkAttribute Class
AssemblyTrademarkAttribute Members
System.Reflection Namespace


AssemblyVersionAttribute Constructor

AssemblyVersionAttribute Constructor

Initializes a new instance of the AssemblyVersionAttribute class with the version number of the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AssemblyVersionAttribute (
         string version
)

Parameters

version
The version number of the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyVersionAttribute Class
AssemblyVersionAttribute Members
System.Reflection Namespace


Attribute Constructor

Attribute Constructor

Initializes a new instance of the Attribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected Attribute ()

Expand image Remarks

This constructor is only called by classes that derive from the Attribute class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Attribute Class
Attribute Members
System Namespace


AttributeUsageAttribute Constructor

AttributeUsageAttribute Constructor

Initializes a new instance of the AttributeUsageAttribute class with a specified list of AttributeTargets values.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AttributeUsageAttribute (
         AttributeTargets validOn
)

Parameters

validOn
The set of values combined using a bitwise OR operation to indicate which program elements are valid.

Expand image Remarks

You can combine several AttributeTargets values by using a bitwise OR operation to get the desired combination of valid program elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AttributeUsageAttribute Class
AttributeUsageAttribute Members
System Namespace


AutoResetEvent Constructor

AutoResetEvent Constructor

Initializes a new instance of the AutoResetEvent class with a Boolean value that indicates whether the initial state of the specified event is set to signaled.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public AutoResetEvent (
         bool initialState
)

Parameters

initialState
A value that you set to true to set the initial state of the specified event to signaled. Set this value to false to set the initial state of the event to nonsignaled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AutoResetEvent Class
AutoResetEvent Members
System.Threading Namespace


Binder Constructor

Binder Constructor

Initializes a new instance of the Binder class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected Binder ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Binder Class
Binder Members
System.Reflection Namespace


Bitmap Constructor

Bitmap Constructor

Initializes a new instance of the Bitmap class to the specified height and width.

Expand image Overload List

Name | Description
Bitmap (Byte[], BitmapImageType) | Initializes a new instance of the Bitmap class to the specified height and width.
Bitmap (Int32, Int32) | Initializes a new instance of the Bitmap class to the specified height and width.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Border Constructor

Border Constructor

Initializes a new instance of the Border class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Border ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Brush Constructor

Brush Constructor

Initializes a new instance of the Brush class.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected Brush ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Brush Class
Brush Members
Microsoft.SPOT.Presentation.Media Namespace


ButtonEventArgs Constructor

ButtonEventArgs Constructor

Initializes a new instance of the ButtonEventArgs class, using specified values.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ButtonEventArgs (
         ButtonDevice buttonDevice,
         PresentationSource inputSource,
         TimeSpan timestamp,
         Button button
)

Parameters

buttonDevice
The button device that generated the input.
inputSource
The source of the input.
timestamp
The time period during which the input was received.
button
A value of the Button enumeration that specifies the button used to enter the input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


Buttons Constructor

Buttons Constructor

Initializes a new instance of the Buttons class.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Buttons ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


MethodImplAttribute Constructor (Int16)

MethodImplAttribute Constructor (Int16)
See Also
CollapseAll image

Initializes a new instance of the MethodImplAttribute class with a specified MethodImplOptions value.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodImplAttribute (
         short value
)

Parameters

value
A bitmask representing the specified MethodImplOptions value, which specifies properties of the method being attributed.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


StructLayoutAttribute Constructor (Int16)

StructLayoutAttribute Constructor (Int16)
See Also
CollapseAll image

Initalizes a new instance of the StructLayoutAttribute class with a specified LayoutKind enumeration member.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public StructLayoutAttribute (
         short layoutKind
)

Parameters

layoutKind
One of the LayoutKind values that specifes how a particular class or structure should be arranged.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


RoutedEventArgs Constructor (RoutedEvent, Object)

RoutedEventArgs Constructor (RoutedEvent, Object)
See Also
CollapseAll image

Initializes a new instance of the RoutedEventArgs class, using the routed event identifier that is provided. Note that using this constructor also gives you the opportunity to declare a different source for the event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutedEventArgs (
         RoutedEvent routedEvent,
         Object source
)

Parameters

routedEvent
The routed event identifier for the current RoutedEventArgs object.
source
An alternate source that will be reported when the routed event is handled.

Expand image Remarks

When you use this constructor, the unspecified properties of the new RoutedEventArgs object assume the following default values:

  • Handled defaults to false.
  • OriginalSource defaults to a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


Bitmap Constructor (Int32, Int32)

Bitmap Constructor (Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the Bitmap class to the specified height and width.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Bitmap (
         int width,
         int height
)

Parameters

width
The width of the current bitmap, in pixels.
height
The height of the current bitmap, in pixels.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext Constructor (Int32, Int32)

DrawingContext Constructor (Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the DrawingContext class with a drawing surface of a specified size.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DrawingContext (
         int width,
         int height
)

Parameters

width
The width of the drawing surface.
height
The height of the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Pen Constructor (Color, UInt16)

Pen Constructor (Color, UInt16)
See Also
CollapseAll image

Initializes a new instance of the Pen class with a specified color and thickness.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Pen (
         Color color,
         UInt16 thickness
)

Parameters

color
A value of the Color enumeration that specifies the color of the current pen.
thickness
The thickness of the current pen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Class
Pen Members
Microsoft.SPOT.Presentation.Media Namespace


CancelEventArgs Constructor

CancelEventArgs Constructor

Initializes a new instance of the CancelEventArgs class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public CancelEventArgs ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CancelEventArgs Class
CancelEventArgs Members
Microsoft.SPOT Namespace


Canvas Constructor

Canvas Constructor

Initializes a new instance of the Canvas class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Canvas ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


DebuggableAttribute Constructor (DebuggingModes)

DebuggableAttribute Constructor (DebuggingModes)
See Also
CollapseAll image

Sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggableAttribute (
         DebuggingModes modes
)

Parameters

modes
The debugging mode.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


CLSCompliantAttribute Constructor

CLSCompliantAttribute Constructor

Initializes an instance of the CLSCompliantAttribute class with a Boolean value indicating whether the specified program element is CLS-compliant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public CLSCompliantAttribute (
         bool isCompliant
)

Parameters

isCompliant
true if the specified program element is CLS-compliant; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CLSCompliantAttribute Class
CLSCompliantAttribute Members
System Namespace


Colors Constructor

Colors Constructor

Initializes a new instance of the Colors class.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected Colors ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


ConditionalAttribute Constructor

ConditionalAttribute Constructor

Initializes a new instance of the ConditionalAttribute class, specifying the name of the attribute that makes a specific conditional method callable.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ConditionalAttribute (
         string conditionString
)

Parameters

conditionString
A string containing the preprocessing identifier that makes the target method of the current object callable.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConditionalAttribute Class
ConditionalAttribute Members
System.Diagnostics Namespace


ConstructorInfo Constructor

ConstructorInfo Constructor

Initializes a new instance of the ConstructorInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected ConstructorInfo ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConstructorInfo Class
ConstructorInfo Members
System.Reflection Namespace


ContentControl Constructor

ContentControl Constructor

Initializes a new instance of the ContentControl class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected ContentControl ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ContentControl Class
ContentControl Members
Microsoft.SPOT.Presentation.Controls Namespace


Control Constructor

Control Constructor

Provides initialization for Control class values when it is called by the constructor of a derived class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Control ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


CultureInfo Constructor

CultureInfo Constructor

Initializes a new instance of the CultureInfo class based on the specified culture name.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public CultureInfo (
         string name
)

Parameters

name
A predefined CultureInfo name or the Name property of an existing CultureInfo name.

Expand image Remarks

The CultureInfo names follow the RFC 1766 standard, in the format "<languagecode2>-<country/regioncode2>", where <languagecode2> is a lowercase two-letter code derived from ISO 639-1 and <country/regioncode2> is an uppercase two-letter code derived from ISO 3166. For example, U.S. English is denoted as "en-US". In cases where a two-letter language code is not available, the appropriate three-letter code derived from ISO 639-2 is used; for example, the three-letter code "div" is used for cultures that use the Dhivehi language. The predefined CultureInfo names are listed in the CultureInfo class topic.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


DateTime Constructor (Int32, Int32, Int32)

DateTime Constructor (Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the DateTime structure and sets it to the specified year, month, and day.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime (
         int year,
         int month,
         int day
)

Parameters

year
The year, expressed as a number ranging from 1 through 9999.
month
The month, expressed as a number ranging from 1 through 12.
day
The day, expressed as a number ranging from 1 through 31.

Expand image Remarks

The time-of-day component for the new DateTime object is ininitalized to midnight (00:00:00).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime Constructor

DateTime Constructor

Initializes a new instance of the DateTime structure.

Expand image Overload List

Name | Description
DateTime (Int32, Int32, Int32) | Initializes a new instance of the DateTime structure and sets it to the specified year, month, and day.
DateTime (Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the DateTime structure and sets it to the specified year, month, day, hour, minute, and second.
DateTime (Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the DateTime structure and sets it to the specified year, month, day, hour, minute, second, and millisecond.
DateTime (Int64) | Initializes a new instance of the DateTime structure and sets it to the specified number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DaylightTime Constructor

DaylightTime Constructor

Initializes a new instance of the DaylightTime class.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DaylightTime (
         DateTime start,
         DateTime end,
         TimeSpan delta
)

Parameters

start
A DateTime object that represents the date and time when daylight saving time begins for the local time zone. You must specify this value in local time.
end
A DateTime object that represents the date and time when daylight saving time ends for the local time zone. You must specify this value in local time.
delta
A TimeSpan object that represents, in clock ticks, the difference between standard time and daylight saving time for the local time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DaylightTime Class
DaylightTime Members
System.Globalization Namespace


DebuggableAttribute Constructor

DebuggableAttribute Constructor

Initializes a new instance of the DebuggableAttribute class, which sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.

Expand image Overload List

Name | Description
DebuggableAttribute (Boolean, Boolean) | Sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.
DebuggableAttribute (DebuggingModes) | Sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


DebuggerBrowsableAttribute Constructor

DebuggerBrowsableAttribute Constructor

Initializes a new instance of the DebuggerBrowsableAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerBrowsableAttribute (
         DebuggerBrowsableState state
)

Parameters

state
A value that specifies the current browsing state of a particular section of code.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerBrowsableAttribute Class
DebuggerBrowsableAttribute Members
System.Diagnostics Namespace


DebuggerDisplayAttribute Constructor

DebuggerDisplayAttribute Constructor

Creates and initializes a new instance of the DebuggerDisplayAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerDisplayAttribute (
         string value
)

Parameters

value
A string that appears in the value column for instances of the display type.

Expand image Remarks

The string in the value parameter can include text enclosed in curly braces ({}). This text can be the name of a field, a property, or a method. Note that you can also include in this string a general expression that has implicit access only to the this pointer for the current instance of the target type. This general expression is limited, however; there is no access to aliases, locals, or pointers. In addition, attributes on properties referenced in the expression are not processed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


DebuggerHiddenAttribute Constructor

DebuggerHiddenAttribute Constructor

Initializes a new instance of the DebuggerHiddenAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerHiddenAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerHiddenAttribute Class
DebuggerHiddenAttribute Members
System.Diagnostics Namespace


DebuggerNonUserCodeAttribute Constructor

DebuggerNonUserCodeAttribute Constructor

Creates and initializes an instance of the DebuggerNonUserCodeAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerNonUserCodeAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerNonUserCodeAttribute Class
DebuggerNonUserCodeAttribute Members
System.Diagnostics Namespace


DebuggerStepperBoundaryAttribute Constructor

DebuggerStepperBoundaryAttribute Constructor

Creates and initializes an instance of the DebuggerStepperBoundaryAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerStepperBoundaryAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerStepperBoundaryAttribute Class
DebuggerStepperBoundaryAttribute Members
System.Diagnostics Namespace


DebuggerStepThroughAttribute Constructor

DebuggerStepThroughAttribute Constructor

Initializes a new instance of the DebuggerStepThroughAttribute class.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerStepThroughAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerStepThroughAttribute Class
DebuggerStepThroughAttribute Members
System.Diagnostics Namespace


DebuggerTypeProxyAttribute Constructor

DebuggerTypeProxyAttribute Constructor

Initializes a new instance of the DebuggerTypeProxyAttribute class.

Expand image Overload List

Name | Description
DebuggerTypeProxyAttribute (String) | Initializes a new instance of the DebuggerTypeProxyAttribute class, using a string that represents the type of the proxy.
DebuggerTypeProxyAttribute (Type) | Initializes a new instance of the DebuggerTypeProxyAttribute class, using a Type object that represents the type of the proxy.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


DefaultMemberAttribute Constructor

DefaultMemberAttribute Constructor

Initializes a new instance of the DefaultMemberAttribute class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DefaultMemberAttribute (
         string memberName
)

Parameters

memberName

A String object that contains the name of the member to you want to invoke. This member can be a constructor, method, property, or field. Note that you must specify a suitable invocation attribute. You can invoke the default member of a class by passing an empty String object as the name of the member.

You mark the default member of a type with the DefaultMemberAttribute custom attribute, or you can mark it in COM in the usual way.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DefaultMemberAttribute Class
DefaultMemberAttribute Members
System.Reflection Namespace


Delegate Constructor

Delegate Constructor

Initializes a new delegate.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected Delegate ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


DispatcherFrame Constructor ()

DispatcherFrame Constructor ()
See Also
CollapseAll image

Initializes a new instance of the DispatcherFrame class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherFrame ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherFrame Class
DispatcherFrame Members
Microsoft.SPOT Namespace


DispatcherFrame Constructor

DispatcherFrame Constructor

Initializes a new instance of the DispatcherFrame class.

Expand image Overload List

Name | Description
DispatcherFrame () | Initializes a new instance of the DispatcherFrame class.
DispatcherFrame (Boolean) | Initializes a new instance of the DispatcherFrame class, using the specified exit request flag.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherFrame Class
DispatcherFrame Members
Microsoft.SPOT Namespace


DispatcherObject Constructor

DispatcherObject Constructor

Initializes a new instance of the DispatcherObject class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherObject ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherObject Class
DispatcherObject Members
Microsoft.SPOT Namespace


DispatcherTimer Constructor ()

DispatcherTimer Constructor ()
See Also
CollapseAll image

Initializes a new instance of the DispatcherTimer class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherTimer ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


DispatcherTimer Constructor

DispatcherTimer Constructor

Initializes a new instance of the DispatcherTimer class.

Expand image Overload List

Name | Description
DispatcherTimer () | Initializes a new instance of the DispatcherTimer class.
DispatcherTimer (Dispatcher) | Initializes a new instance of the DispatcherTimer class and associates it with a specified Dispatcher object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


DrawingContext Constructor

DrawingContext Constructor

Initializes a new instance of the DrawingContext class.

Expand image Overload List

Name | Description
DrawingContext (Bitmap) | Initializes a new instance of the DrawingContext class that uses a specified bitmapped image as the background on its drawing surface.
DrawingContext (Int32, Int32) | Initializes a new instance of the DrawingContext class with a drawing surface of a specified size.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


DebuggableAttribute Constructor (Boolean, Boolean)

DebuggableAttribute Constructor (Boolean, Boolean)
See Also
CollapseAll image

Sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggableAttribute (
         bool isJITTrackingEnabled,
         bool isJITOptimizerDisabled
)

Parameters

isJITTrackingEnabled
true to enable JIT tracking for debugging; otherwise, false.
isJITOptimizerDisabled
true to disable the optimizer for execution; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


AssemblyFlagsAttribute Constructor (UInt32)

AssemblyFlagsAttribute Constructor (UInt32)
See Also
CollapseAll image

Initializes a new instance of the AssemblyFlagsAttribute class with the specified side-by-side execution flag.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[CLSCompliantAttribute]
public AssemblyFlagsAttribute (
         UInt32 flags
)

Parameters

flags
A value that represents the type of side-by-side execution (same process, same computer, or same application domain) that is supported for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyFlagsAttribute Class
AssemblyFlagsAttribute Members
System.Reflection Namespace


EventArgs Constructor

EventArgs Constructor

Initializes a new instance of the EventArgs class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public EventArgs ()

Expand image Remarks

This constructor is called only by the .NET Micro Framework common language runtime (CLR).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventArgs Class
EventArgs Members
Microsoft.SPOT Namespace


EventHandlersStore Constructor

EventHandlersStore Constructor

Initializes a new instance of the EventHandlersStore class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public EventHandlersStore ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventHandlersStore Class
EventHandlersStore Members
Microsoft.SPOT Namespace


EventRoute Constructor

EventRoute Constructor

Initializes a new instance of the EventRoute class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public EventRoute (
         RoutedEvent routedEvent
)

Parameters

routedEvent
The event identifier (ID) to be associated with the current event route. Note that this parameter cannot be set to null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventRoute Class
EventRoute Members
Microsoft.SPOT Namespace


Exception Constructor ()

Exception Constructor ()
See Also
CollapseAll image

Initializes a new instance of the Exception class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Exception ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


Exception Constructor

Exception Constructor

Initializes a new instance of the Exception class.

Expand image Overload List

Name | Description
Exception () | Initializes a new instance of the Exception class.
Exception (String) | Initializes a new instance of the Exception class with a specified error message.
Exception (String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


ExtendedTimer Constructor

ExtendedTimer Constructor

Initializes a new instance of the ExtendedTimer class.

Expand image Overload List

Name | Description
ExtendedTimer (TimerCallback, Object, DateTime, TimeSpan) | Initializes a new instance of the ExtendedTimer class, using System.DateTime and System.TimeSpan values to measure time intervals.
ExtendedTimer (TimerCallback, Object, Int32, Int32) | Initializes a new instance of the ExtendedTimer class, using 32-bit signed integers to measure time intervals.
ExtendedTimer (TimerCallback, Object, TimeEvents) | Initializes a new instance of the ExtendedTimer class.
ExtendedTimer (TimerCallback, Object, TimeSpan, TimeSpan) | Initializes a new instance of the ExtendedTimer class, using System.TimeSpan values to measure time intervals.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


ExtendedWeakReference Constructor

ExtendedWeakReference Constructor

Initializes a new instance of the ExtendedWeakReference class, referencing a specified object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ExtendedWeakReference (
         Object target,
         Type selector,
         UInt32 id,
         UInt32 flags
)

Parameters

target
The object targeted for the current weak reference.
selector
The type that you want to associate with the current weak reference.
id
The indentifier that you want to associate with the current weak reference.
flags
Flags that specify the states from which the current weak reference should be recoverable.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


DispatcherTimer Constructor (Dispatcher)

DispatcherTimer Constructor (Dispatcher)
See Also
CollapseAll image

Initializes a new instance of the DispatcherTimer class and associates it with a specified Dispatcher object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherTimer (
         Dispatcher dispatcher
)

Parameters

dispatcher
The dispatcher associated with the current timer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


FieldInfo Constructor

FieldInfo Constructor

Initializes a new instance of the FieldInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected FieldInfo ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Class
FieldInfo Members
System.Reflection Namespace


FieldNoReflectionAttribute Constructor

FieldNoReflectionAttribute Constructor

Constructs a FieldNoReflectionAttribute object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public FieldNoReflectionAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldNoReflectionAttribute Class
FieldNoReflectionAttribute Members
Microsoft.SPOT Namespace


FlagsAttribute Constructor

FlagsAttribute Constructor

Initializes a new instance of the FlagsAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public FlagsAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FlagsAttribute Class
FlagsAttribute Members
System Namespace


FocusChangedEventArgs Constructor

FocusChangedEventArgs Constructor

Initializes a new instance of the FocusChangedEventArgs class, using specified values.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public FocusChangedEventArgs (
         ButtonDevice buttonDevice,
         TimeSpan timestamp,
         UIElement oldFocus,
         UIElement newFocus
)

Parameters

buttonDevice
The button device that generated the input.
timestamp
The time period during which the input was received.
oldFocus
The display element that last had the button focus.
newFocus
The display element that currently has the button focus.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FocusChangedEventArgs Class
FocusChangedEventArgs Members
Microsoft.SPOT.Input Namespace


Image Constructor ()

Image Constructor ()
See Also
CollapseAll image

Initializes a new instance of the Image class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Image ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


Image Constructor

Image Constructor

Initializes a new instance of the Image class.

Expand image Overload List

Name | Description
Image () | Initializes a new instance of the Image class.
Image (Bitmap) | Initializes a new instance of the Image class and sets its bitmap.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


ImageBrush Constructor

ImageBrush Constructor

Initializes a new instance of the ImageBrush class with a specified image.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ImageBrush (
         Bitmap bmp
)

Parameters

bmp
A Bitmap object that specifies the bitmapped image to be used as the brush's paint, or fill.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ImageBrush Class
ImageBrush Members
Microsoft.SPOT.Presentation.Media Namespace


IndexerNameAttribute Constructor

IndexerNameAttribute Constructor

Initializes a new instance of the IndexerNameAttribute class.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public IndexerNameAttribute (
         string indexerName
)

Parameters

indexerName
The name of the current indexer, as shown to other programming languages.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexerNameAttribute Class
IndexerNameAttribute Members
System.Runtime.CompilerServices Namespace


IndexOutOfRangeException Constructor ()

IndexOutOfRangeException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the IndexOutOfRangeException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public IndexOutOfRangeException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
System Namespace


IndexOutOfRangeException Constructor

IndexOutOfRangeException Constructor

Initializes a new instance of the IndexOutOfRangeException class.

Expand image Overload List

Name | Description
IndexOutOfRangeException () | Initializes a new instance of the IndexOutOfRangeException class.
IndexOutOfRangeException (String) | Initializes a new instance of the IndexOutOfRangeException class with a specified error message.
IndexOutOfRangeException (String, Exception) | Initializes a new instance of the IndexOutOfRangeException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
System Namespace


InputDevice Constructor

InputDevice Constructor

Initializes a new instance of the InputDevice class.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputDevice ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputDevice Class
InputDevice Members
Microsoft.SPOT.Input Namespace


InputEventArgs Constructor

InputEventArgs Constructor

Initializes a new instance of the InputEventArgs class, using specified values.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputEventArgs (
         InputDevice inputDevice,
         TimeSpan timestamp
)

Parameters

inputDevice
An InputDevice object specifying the device that generated the input.
timestamp
A TimeSpan object specifying the time period during which the input was received.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputEventArgs Class
InputEventArgs Members
Microsoft.SPOT.Input Namespace


InputReport Constructor

InputReport Constructor

Creates a new InputReport object, using a specified input source.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected InputReport (
         PresentationSource inputSource,
         TimeSpan timestamp
)

Parameters

inputSource
A PresentationSource object that specifies the source of the input for the current input report.
timestamp
A TimeSpan object that specifies the time period during which the input was received.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReport Class
InputReport Members
Microsoft.SPOT.Input Namespace


InputReportEventArgs Constructor

InputReportEventArgs Constructor

Initializes a new instance of the InputReportEventArgs class, using specified values.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputReportEventArgs (
         InputDevice inputDevice,
         InputReport report
)

Parameters

inputDevice
The device that generated the input.
report
The input report that specifies the input to the InputProviderSite and InputManager objects.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReportEventArgs Class
InputReportEventArgs Members
Microsoft.SPOT.Input Namespace


InvalidCastException Constructor ()

InvalidCastException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the InvalidCastException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidCastException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidCastException Class
InvalidCastException Members
System Namespace


InvalidCastException Constructor

InvalidCastException Constructor

Initializes a new instance of the InvalidCastException class.

Expand image Overload List

Name | Description
InvalidCastException () | Initializes a new instance of the InvalidCastException class.
InvalidCastException (String) | Initializes a new instance of the InvalidCastException class with a specified error message.
InvalidCastException (String, Exception) | Initializes a new instance of the InvalidCastException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidCastException Class
InvalidCastException Members
System Namespace


InvalidOperationException Constructor ()

InvalidOperationException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the InvalidOperationException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public InvalidOperationException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidOperationException Class
InvalidOperationException Members
System Namespace


InvalidOperationException Constructor

InvalidOperationException Constructor

Initializes a new instance of the InvalidOperationException class.

Expand image Overload List

Name | Description
InvalidOperationException () | Initializes a new instance of the InvalidOperationException class.
InvalidOperationException (String) | Initializes a new instance of the InvalidOperationException class with a specified error message.
InvalidOperationException (String, Exception) | Initializes a new instance of the InvalidOperationException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidOperationException Class
InvalidOperationException Members
System Namespace


LinearGradientBrush Constructor

LinearGradientBrush Constructor

Initializes a new instance of the LinearGradientBrush class with specified starting and ending colors and a specified gradient path.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public LinearGradientBrush (
         Color startColor,
         Color endColor,
         int startX,
         int startY,
         int endX,
         int endY
)

Parameters

startColor
A value of the Color enumeration that specifies the color at the beginning of the gradient path. This is the color at the point specified by the startX and startY parameters.
endColor
A value of the Color enumeration that specifies the color at the end of the gradient path. This is the color at the point specified by the endX and endY parameters.
startX
The horizontal coordinate (relative to the left edge of the area being painted) of the starting point of the gradient's path. The default value is 0 (zero), which is the left edge of the area.
startY
The vertical coordinate (relative to the top edge of the area being painted) of the starting point of the gradient's path. The default value is 0 (zero), which is the top edge of the area.
endX
The horizontal coordinate (relative to the left edge of the area being painted) of the ending point of the gradient's path. The default value is 1, which is the right edge of the area.
endY
The vertical coordinate (relative to the top edge of the area being painted) of the ending point of the gradient's path. The default value is 1, which is the bottom edge of the area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


ListBox Constructor

ListBox Constructor

Initializes a new instance of the ListBox class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBox ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItem Constructor

ListBoxItem Constructor

Initializes a new instance of the ListBoxItem class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBoxItem ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItem Class
ListBoxItem Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItemCollection Constructor

ListBoxItemCollection Constructor

Initializes an instance of the ListBoxItemCollection class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBoxItemCollection (
         ListBox listBox,
         UIElementCollection items
)

Parameters

listBox
The list box associated with the current collection.
items
A group of items to be stored in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


MarshalByRefObject Constructor

MarshalByRefObject Constructor

Initializes a new instance of the MarshalByRefObject class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected MarshalByRefObject ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MarshalByRefObject Class
MarshalByRefObject Members
System Namespace


MemberInfo Constructor

MemberInfo Constructor

Initializes a new instance of the MemberInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected MemberInfo ()

Expand image Remarks

Only a derived class can create a MemberInfo object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MemberInfo Class
MemberInfo Members
System.Reflection Namespace


MethodBase Constructor

MethodBase Constructor

Initializes a new instance of the MethodBase class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected MethodBase ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


MethodImplAttribute Constructor ()

MethodImplAttribute Constructor ()
See Also
CollapseAll image

Initializes a new instance of the MethodImplAttribute class.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodImplAttribute ()

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


MethodImplAttribute Constructor

MethodImplAttribute Constructor

Initializes a new instance of the MethodImplAttribute class.

Expand image Overload List

Name | Description
MethodImplAttribute () | Initializes a new instance of the MethodImplAttribute class.
MethodImplAttribute (Int16) | Initializes a new instance of the MethodImplAttribute class with a specified MethodImplOptions value.
MethodImplAttribute (MethodImplOptions) | Initializes a new instance of the MethodImplAttribute class with a specified MethodImplOptions value.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


MethodInfo Constructor

MethodInfo Constructor

Initializes a new instance of the MethodInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected MethodInfo ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodInfo Class
MethodInfo Members
System.Reflection Namespace


MTAThreadAttribute Constructor

MTAThreadAttribute Constructor

Initializes a new instance of the MTAThreadAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MTAThreadAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MTAThreadAttribute Class
MTAThreadAttribute Members
System Namespace


MulticastDelegate Constructor

MulticastDelegate Constructor

Initializes a new instance of the MulticastDelegate class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected MulticastDelegate ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MulticastDelegate Class
MulticastDelegate Members
System Namespace


NonSerializedAttribute Constructor

NonSerializedAttribute Constructor

Initializes a new instance of the NonSerializedAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NonSerializedAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NonSerializedAttribute Class
NonSerializedAttribute Members
System Namespace


NotImplementedException Constructor ()

NotImplementedException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the NotImplementedException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotImplementedException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotImplementedException Class
NotImplementedException Members
System Namespace


NotImplementedException Constructor

NotImplementedException Constructor

Initializes a new instance of the NotImplementedException class.

Expand image Overload List

Name | Description
NotImplementedException () | Initializes a new instance of the NotImplementedException class.
NotImplementedException (String) | Initializes a new instance of the NotImplementedException class with a specified error message.
NotImplementedException (String, Exception) | Initializes a new instance of the NotImplementedException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotImplementedException Class
NotImplementedException Members
System Namespace


NotSupportedException Constructor ()

NotSupportedException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the NotSupportedException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NotSupportedException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotSupportedException Class
NotSupportedException Members
System Namespace


NotSupportedException Constructor

NotSupportedException Constructor

Initializes a new instance of the NotSupportedException class.

Expand image Overload List

Name | Description
NotSupportedException () | Initializes a new instance of the NotSupportedException class.
NotSupportedException (String) | Initializes a new instance of the NotSupportedException class with a specified error message.
NotSupportedException (String, Exception) | Initializes a new instance of the NotSupportedException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotSupportedException Class
NotSupportedException Members
System Namespace


NullReferenceException Constructor ()

NullReferenceException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the NullReferenceException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public NullReferenceException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NullReferenceException Class
NullReferenceException Members
System Namespace


NullReferenceException Constructor

NullReferenceException Constructor

Initializes a new instance of the NullReferenceException class.

Expand image Overload List

Name | Description
NullReferenceException () | Initializes a new instance of the NullReferenceException class.
NullReferenceException (String) | Initializes a new instance of the NullReferenceException class with a specified error message.
NullReferenceException (String, Exception) | Initializes a new instance of the NullReferenceException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NullReferenceException Class
NullReferenceException Members
System Namespace


Object Constructor

Object Constructor

Initializes a new instance of the Object class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
public Object ()

Expand image Remarks

This constructor is called by constructors in derived classes, but you can also use it to create an instance of the Object class directly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


ObsoleteAttribute Constructor ()

ObsoleteAttribute Constructor ()
See Also
CollapseAll image

Initializes a new instance of the ObsoleteAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ObsoleteAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


ObsoleteAttribute Constructor

ObsoleteAttribute Constructor

Initializes a new instance of the ObsoleteAttribute class.

Expand image Overload List

Name | Description
ObsoleteAttribute () | Initializes a new instance of the ObsoleteAttribute class.
ObsoleteAttribute (String) | Initializes a new instance of the ObsoleteAttribute class with a specified work-around message.
ObsoleteAttribute (String, Boolean) | Initializes a new instance of the ObsoleteAttribute class with a specified work-around message and a Boolean value that indicates whether the use of this obsolete program element is considered an error.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


OutAttribute Constructor

OutAttribute Constructor

Initializes a new instance of the OutAttribute class.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public OutAttribute ()

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutAttribute Class
OutAttribute Members
System.Runtime.InteropServices Namespace


OutOfMemoryException Constructor ()

OutOfMemoryException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the OutOfMemoryException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public OutOfMemoryException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
System Namespace


OutOfMemoryException Constructor

OutOfMemoryException Constructor

Initializes a new instance of the OutOfMemoryException class.

Expand image Overload List

Name | Description
OutOfMemoryException () | Initializes a new instance of the OutOfMemoryException class.
OutOfMemoryException (String) | Initializes a new instance of the OutOfMemoryException class with a specified error message.
OutOfMemoryException (String, Exception) | Initializes a new instance of the OutOfMemoryException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
System Namespace


Panel Constructor

Panel Constructor

Initializes an instance of the Panel class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Panel ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Panel Class
Panel Members
Microsoft.SPOT.Presentation.Controls Namespace


ParamArrayAttribute Constructor

ParamArrayAttribute Constructor

Initializes a new instance of the ParamArrayAttribute class with default properties.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ParamArrayAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ParamArrayAttribute Class
ParamArrayAttribute Members
System Namespace


Pen Constructor

Pen Constructor

Initializes a new instance of the Pen class.

Expand image Overload List

Name | Description
Pen (Color) | Initializes a new instance of the Pen class with a specified color.
Pen (Color, UInt16) | Initializes a new instance of the Pen class with a specified color and thickness.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Class
Pen Members
Microsoft.SPOT.Presentation.Media Namespace


PresentationSource Constructor

PresentationSource Constructor

Initializes a new instance of the PresentationSource class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public PresentationSource ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PresentationSource Class
PresentationSource Members
Microsoft.SPOT.Presentation Namespace


PropertyChangedEventArgs Constructor

PropertyChangedEventArgs Constructor

Initializes a new instance of the PropertyChangedEventArgs class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public PropertyChangedEventArgs (
         string property,
         Object oldValue,
         Object newValue
)

Parameters

property
The name of the property that changes.
oldValue
The value of the specified property before the change.
newValue
The value of the specified property after the change.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Class
PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


PropertyInfo Constructor

PropertyInfo Constructor

Initializes a new instance of the PropertyInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected PropertyInfo ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyInfo Class
PropertyInfo Members
System.Reflection Namespace


PublishInApplicationDirectoryAttribute Constructor

PublishInApplicationDirectoryAttribute Constructor

Creates and initializes a new instance of the PublishInApplicationDirectoryAttribute class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public PublishInApplicationDirectoryAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PublishInApplicationDirectoryAttribute Class
Microsoft.SPOT Namespace


RawButtonInputReport Constructor

RawButtonInputReport Constructor

Initializes a new instance of the RawButtonInputReport class, using specified values.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RawButtonInputReport (
         PresentationSource inputSource,
         TimeSpan timestamp,
         Button button,
         RawButtonActions actions
)

Parameters

inputSource
A PresentationSource object that specifies the source of the input for the current input report.
timestamp
A TimeSpan object that specifies the time period during which the input was received.
button
A Button enumeration value specifying the button that generated the input.
actions
A RawButtonActions enumeration value specifying the raw action of the button that generated the input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RawButtonInputReport Class
RawButtonInputReport Members
Microsoft.SPOT.Input Namespace


Reflection Constructor

Reflection Constructor

Creates and initializes a new instance of the Reflection class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public Reflection ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


ResourceManager Constructor

ResourceManager Constructor

Initializes a new instance of the ResourceManager class that looks up resources contained in files derived from the specified root name, using a specified Assembly object.

Namespace: System.Resources
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ResourceManager (
         string baseName,
         Assembly assembly
)

Parameters

baseName
The root name of the resources you want to look up. For example, the root name of the resource file named "MyResource.en-US.resources" is "MyResource".
assembly
The main Assembly object for the resources you want to look up.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceManager Class
ResourceManager Members
System.Resources Namespace


ResourceUtility Constructor

ResourceUtility Constructor

Constructs a ResourceUtility object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public ResourceUtility ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Class
ResourceUtility Members
Microsoft.SPOT Namespace


RoutedEvent Constructor

RoutedEvent Constructor

Initializes a new instance of the RoutedEvent class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutedEvent (
         string name,
         RoutingStrategy routingStrategy,
         Type handlerType
)

Parameters

name
The identifying name of the routed event.
routingStrategy
The routing strategy of the routed event.
handlerType
The handler type of the routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Class
RoutedEvent Members
Microsoft.SPOT Namespace


RoutedEventArgs Constructor ()

RoutedEventArgs Constructor ()
See Also
CollapseAll image

Initializes a new instance of the RoutedEventArgs class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutedEventArgs ()

Expand image Remarks

When you use this parameterless constructor, all public properties of the new RoutedEventArgs object assume the following default values:

  • RoutedEvent defaults to a null reference.
  • Handled defaults to false.
  • Source defaults to a null reference.
  • OriginalSource defaults to a null reference.

Setting the Source and OriginalSource properties to a null reference means that the current RoutedEventArgs object makes no attempt to specify the source. When this object is used in a call to the UIElement.RaiseEvent method, those values are populated based on the element that raised the event. The values are then passed on through the routing.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


RoutedEventArgs Constructor

RoutedEventArgs Constructor

Initializes a new instance of the RoutedEventArgs class.

Expand image Overload List

Name | Description
RoutedEventArgs () | Initializes a new instance of the RoutedEventArgs class.
RoutedEventArgs (RoutedEvent) | Initializes a new instance of the RoutedEventArgs class, using the routed event identifier that is provided.
RoutedEventArgs (RoutedEvent, Object) | Initializes a new instance of the RoutedEventArgs class, using the routed event identifier that is provided. Note that using this constructor also gives you the opportunity to declare a different source for the event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


ScrollChangedEventArgs Constructor

ScrollChangedEventArgs Constructor

Initializes a new instance of the ScrollChangedEventArgs class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ScrollChangedEventArgs (
         int offsetX,
         int offsetY,
         int offsetChangeX,
         int offsetChangeY
)

Parameters

offsetX
Specifies the current horizontal offset value for a ScrollViewer object.
offsetY
Specifies the current vertical offset value for a ScrollViewer object.
offsetChangeX
Specifies the new horizontal offset value for a ScrollViewer object.
offsetChangeY
Specifies the new vertical offset value for a ScrollViewer object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Class
ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer Constructor

ScrollViewer Constructor

Initializes a new instance of the ScrollViewer class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ScrollViewer ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


SelectionChangedEventArgs Constructor

SelectionChangedEventArgs Constructor

Initializes a new instance of the SelectionChangedEventArgs class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public SelectionChangedEventArgs (
         int previousIndex,
         int newIndex
)

Parameters

previousIndex
The index number of the item that was last selected.
newIndex
The index number of the item that is currently selected.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


SerializableAttribute Constructor

SerializableAttribute Constructor

Initializes a new instance of the SerializableAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public SerializableAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializableAttribute Class
SerializableAttribute Members
System Namespace


SolidColorBrush Constructor

SolidColorBrush Constructor

Initializes a new instance of the SolidColorBrush class with a specified color for the brush's paint, or fill.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public SolidColorBrush (
         Color color
)

Parameters

color
A value of the Color enumeration that specifies the color of the brush's paint.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SolidColorBrush Class
SolidColorBrush Members
Microsoft.SPOT.Presentation.Media Namespace


StackPanel Constructor ()

StackPanel Constructor ()
See Also
CollapseAll image

Initializes a new instance of the StackPanel class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StackPanel ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


StackPanel Constructor

StackPanel Constructor

Initializes a new instance of the StackPanel class.

Expand image Overload List

Name | Description
StackPanel () | Initializes a new instance of the StackPanel class.
StackPanel (Orientation) | Initializes a new instance of the StackPanel class and sets the orientation for child element (child object) presentation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


STAThreadAttribute Constructor

STAThreadAttribute Constructor

Initializes a new instance of the STAThreadAttribute class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public STAThreadAttribute ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

STAThreadAttribute Class
STAThreadAttribute Members
System Namespace


String Constructor

String Constructor

Initializes a new instance of the String class.

Expand image Overload List

Name | Description
String (Char, Int32) | Initializes a new instance of the String class with a value indicated by a specified Unicode character repeated a specified number of times.
String (Char[]) | Initializes a new instance of the String class with a value indicated by a specified array of Unicode characters.
String (Char[], Int32, Int32) | Initializes a new instance of the String class with a value indicated by a specified array of Unicode characters, a specified starting index number (character position) in that array, and a specified length (number of characters).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


StructLayoutAttribute Constructor

StructLayoutAttribute Constructor

Initalizes a new instance of the StructLayoutAttribute class.

Expand image Overload List

Name | Description
StructLayoutAttribute (Int16) | Initalizes a new instance of the StructLayoutAttribute class with a specified LayoutKind enumeration member.
StructLayoutAttribute (LayoutKind) | Initalizes a new instance of the StructLayoutAttribute class with a specified LayoutKind enumeration member.

Expand image Remarks

Items in this namespace are for use by in Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


SystemException Constructor ()

SystemException Constructor ()
See Also
CollapseAll image

Initializes a new instance of the SystemException class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public SystemException ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemException Class
SystemException Members
System Namespace


SystemException Constructor

SystemException Constructor

Initializes a new instance of the SystemException class.

Expand image Overload List

Name | Description
SystemException () | Initializes a new instance of the SystemException class.
SystemException (String) | Initializes a new instance of the SystemException class with a specified error message.
SystemException (String, Exception) | Initializes a new instance of the SystemException class with a specified error message and a reference to the inner exception that caused the current exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemException Class
SystemException Members
System Namespace


SystemMetrics Constructor

SystemMetrics Constructor

Initializes a new instance of the SystemMetrics class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public SystemMetrics ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemMetrics Class
SystemMetrics Members
Microsoft.SPOT.Presentation Namespace


SystemTime Constructor

SystemTime Constructor

Constructs a SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public SystemTime ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


Text Constructor ()

Text Constructor ()
See Also
CollapseAll image

Initializes a new instance of the Text class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Text ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


Text Constructor

Text Constructor

Initializes a new instance of the Text class.

Expand image Overload List

Name | Description
Text () | Initializes a new instance of the Text class.
Text (Font, String) | Initializes a new instance of the Text class and sets its content and font.
Text (String) | Initializes a new instance of the Text class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow Constructor

TextFlow Constructor

Initializes a new instance of the TextFlow class.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextFlow ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRun Constructor

TextRun Constructor

Initializes a new instance of the TextRun class (a text run).

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextRun (
         string text,
         Font font,
         Color foreColor
)

Parameters

text
The text in the text run.
font
The font for the text in the text run.
foreColor
The foreground color for the text in the text run.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


Thread Constructor

Thread Constructor

Initializes a new instance of the Thread class.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Thread (
         ThreadStart start
)

Parameters

start
A ThreadStart delegate that references the methods to be invoked when this thread begins executing.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Timer Constructor

Timer Constructor

Initializes a new instance of the Timer class.

Expand image Overload List

Name | Description
Timer (TimerCallback, Object, Int32, Int32) | Initializes a new instance of the Timer class, using a 32-bit signed integer to specify the time interval.
Timer (TimerCallback, Object, TimeSpan, TimeSpan) | Initializes a new instance of the Timer class, using TimeSpan values to specify time intervals.

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


TimeSpan Constructor (Int32, Int32, Int32)

TimeSpan Constructor (Int32, Int32, Int32)
See Also
CollapseAll image

Initializes a new instance of the TimeSpan structure and sets it to the specified number of hours, minutes, and seconds.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan (
         int hours,
         int minutes,
         int seconds
)

Parameters

hours
The number of hours in the specified time period.
minutes
The number of minutes in the specified time period.
seconds
The number of seconds in the specified time period.

Expand image Remarks

The components of the specified time period — that is, the hours, minutes, and seconds — are converted to ticks. The new TimeSpan instance is then initialized to that number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan Constructor

TimeSpan Constructor

Initializes a new instance of the TimeSpan structure.

Expand image Overload List

Name | Description
TimeSpan (Int32, Int32, Int32) | Initializes a new instance of the TimeSpan structure and sets it to the specified number of hours, minutes, and seconds.
TimeSpan (Int32, Int32, Int32, Int32) | Initializes a new instance of the TimeSpan structure and sets it to the specified number of days, hours, minutes, and seconds.
TimeSpan (Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TimeSpan structure and sets it to the specified number of days, hours, minutes, seconds, and milliseconds.
TimeSpan (Int64) | Initializes a new instance of the TimeSpan structure and sets it to the specified number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeZone Constructor

TimeZone Constructor

Initializes a new instance of the TimeZone class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected TimeZone ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


TimeZoneInformation Constructor

TimeZoneInformation Constructor

Constructs a TimeZoneInformation object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public TimeZoneInformation ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


Type Constructor

Type Constructor

Initializes a new instance of the Type class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected Type ()

Expand image Remarks

This constructor is invoked by derived classes during the construction of Type objects.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


UIElement Constructor

UIElement Constructor

Initializes a new instance of the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElementCollection Constructor

UIElementCollection Constructor

Initializes a new instance of the UIElementCollection class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElementCollection (
         UIElement owner
)

Parameters

owner
A UIElement object specifying the element that owns the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


ValueType Constructor

ValueType Constructor

Initializes a new instance of the ValueType class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected ValueType ()

Expand image Remarks

This constructor is called by derived class constructors to initialize state in the ValueType type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ValueType Class
ValueType Members
System Namespace


WaitHandle Constructor

WaitHandle Constructor

Initializes a new instance of the WaitHandle class.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected WaitHandle ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WaitHandle Class
WaitHandle Members
System.Threading Namespace


WeakDelegate Constructor

WeakDelegate Constructor

Creates and initializes an instance of the WeakDelegate class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public WeakDelegate ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakDelegate Class
WeakDelegate Members
Microsoft.SPOT Namespace


WeakReference Constructor

WeakReference Constructor

Initializes a new instance of the WeakReference class, referencing a specified object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public WeakReference (
         Object target
)

Parameters

target
The object you want to reference, or a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakReference Class
WeakReference Members
System Namespace


Window Constructor

Window Constructor

Initializes a new instance of the Window class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Window ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


WindowCollection Constructor

WindowCollection Constructor

Initializes a new instance of the WindowCollection class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public WindowCollection ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


AssemblyCultureAttribute.Culture Property

AssemblyCultureAttribute.Culture Property

Gets the culture supported by the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Culture { get; }

Property Value

A string that contains the name of the culture supported by the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyCultureAttribute Class
AssemblyCultureAttribute Members
System.Reflection Namespace


CultureInfo Class

CultureInfo Class
See Also Members
CollapseAll image

Provides information about a specific culture (such as its name, its writing system, and so forth), as well as access to culture-specific objects that provide information for common operations, such as formatting dates and sorting strings.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public class CultureInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Members
System.Globalization Namespace


CultureInfo Members

CultureInfo Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the CultureInfo type.

Expand image Public Constructors

 | Name | Description
Public Method | CultureInfo | Initializes a new instance of the CultureInfo class based on the specified culture name.

Expand image Public Properties

 | Name | Description
 | CurrentUICulture | Gets the CultureInfo object that represents the culture currently used by the Resource Manager to look up culture-specific resources at run time.
Public Property | DateTimeFormat | Gets or sets a DateTimeFormatInfo object that defines the culturally appropriate format for displaying dates and times.
Public Property | IsNeutralCulture | Gets a value that indicates whether the current CultureInfo object represents a neutral culture.
Public Property | Name | Gets the name of the current culture, in the format "<languagecode2>-<country/regioncode2>".
Public Property | NumberFormat | Gets or sets a NumberFormatInfo object that defines the culturally appropriate format for displaying numbers, currency, and percentages.
Public Property | Parent | Gets the CultureInfo object that represents the parent culture of the current CultureInfo object.

Expand image Public Methods

 | Name | Description
 | GetCultures | Gets the list of supported cultures filtered by the specified CultureTypes values.
Public Method | ToString | Returns a string that contains the name of the current CultureInfo object, in the format "<languagecode2>-<country/regioncode2>".

Expand image See Also

Reference

CultureInfo Class
System.Globalization Namespace


CultureTypes Enumeration

CultureTypes Enumeration

Defines the types of culture lists that you can retrieve by using the CultureInfo.GetCultures method.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public enum CultureTypes

Expand image Members

Member name | Description
AllCultures | All cultures.
FrameworkCultures | Cultures supported by the .NET Micro Framework.
InstalledWin32Cultures | All cultures that are installed in the Windows system.
NeutralCultures | Cultures that are associated with a particular language but are not specific to a particular country or region. The name of each such culture consists of a lowercase two-letter code derived from ISO 639-1. For example, "en" (English) is a neutral culture.
ReplacementCultures | Cultures that are used when a specified culture is not supported by the .NET Micro Framework.
SpecificCultures | Cultures that are specific to a particular country or region. The names of these cultures follow the RFC 1766 standard, in the format "<languagecode2>-<country/regioncode2>", where <languagecode2> is a lowercase two-letter code derived from ISO 639-1 and <country/regioncode2> is an uppercase two-letter code derived from ISO 3166. For example, "en-US" (English - United States) is a specific culture.
UserCustomCulture | Programmer-defined cultures.
WindowsOnlyCultures | Cultures defined only in Windows and not in the .NET Micro Framework.

Expand image Remarks

Currently, the only supported culture type is AllCultures.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Globalization Namespace


Application.Current Property

Application.Current Property

Gets the Application object for the current application domain.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static Application Current { get; }

Property Value

The Application object for the current AppDomain object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


UIElementCollection.Enumerator.Current Property

UIElementCollection.Enumerator.Current Property

Gets the current UI element in the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement Current { get; }

Property Value

A UIElement object that specifies the current UI element.

Expand image Remarks

The current UI element is the one to which this UIElementCollection.Enumerator object currently points.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection.Enumerator Structure
UIElementCollection.Enumerator Members
Microsoft.SPOT.Presentation Namespace


IEnumerator.Current Property

IEnumerator.Current Property

Gets the current object in a specified collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Object Current { get; }

Property Value

The current object in the specified collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerator Interface
IEnumerator Members
System.Collections Namespace


Dispatcher.CurrentDispatcher Property

Dispatcher.CurrentDispatcher Property

Gets the Dispatcher object (dispatcher) for the thread that is currently executing and creates a new dispatcher if one is not already associated with the current thread.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static Dispatcher CurrentDispatcher { get; }

Property Value

The dispatcher that is associated with the current thread.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


AppDomain.CurrentDomain Property

AppDomain.CurrentDomain Property

Gets the name of the application domain for the current thread.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static AppDomain CurrentDomain { get; }

Property Value

The name of the current application domain.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


DateTimeFormatInfo.CurrentInfo Property

DateTimeFormatInfo.CurrentInfo Property

Gets a read-only DateTimeFormatInfo object that formats values based on the current culture.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTimeFormatInfo CurrentInfo { get; }

Property Value

A read-only DateTimeFormatInfo object that formats values based on the current culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


NumberFormatInfo.CurrentInfo Property

NumberFormatInfo.CurrentInfo Property

Gets the read-only NumberFormatInfo object that formats values based on the current system culture, as indicated in the CultureInfo object.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static NumberFormatInfo CurrentInfo { get; }

Property Value

The read-only NumberFormatInfo object that formats values based on the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


InputManager.CurrentInputManager Property

InputManager.CurrentInputManager Property

Gets the current InputManager object associated with a particular thread.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static InputManager CurrentInputManager { get; }

Property Value

An InputManager object that represents the current input manager.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


Thread.CurrentThread Property

Thread.CurrentThread Property

Gets the thread that is currently running.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static Thread CurrentThread { get; }

Property Value

A Thread object representing the thread that is currently running.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


TimeZone.CurrentTimeZone Property

TimeZone.CurrentTimeZone Property

Gets the time zone of the computer you are using.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeZone CurrentTimeZone { get; }

Property Value

A TimeZone object that represents the local time zone of the computer you are using.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


CultureInfo.CurrentUICulture Property

CultureInfo.CurrentUICulture Property

Gets the CultureInfo object that represents the culture currently used by the Resource Manager to look up culture-specific resources at run time.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static CultureInfo CurrentUICulture { get; }

Property Value

The CultureInfo object that represents the culture currently used by the Resource Manager to look up culture-specific resources at run time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


DateTime.Date Property

DateTime.Date Property

Gets the date component of current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime Date { get; }

Property Value

A new DateTime object with the same date as the current DateTime object, and with the time value set to 12:00:00 midnight (00:00:00).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTimeFormatInfo.DateSeparator Property

DateTimeFormatInfo.DateSeparator Property

Gets the string that separates the components of a date (year, month, and day).

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string DateSeparator { get; }

Property Value

The string that separates the components of a date (year, month, and day).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTime Structure

DateTime Structure

Represents a specific instant in time, expressed as a date and a time of day.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct DateTime

Expand image Remarks

The DateTime value type represents dates and times with values ranging from 12:00:00 midnight, January 1, 0001 Anno Domini, or A.D. (also known as Common Era, or C.E.) through 11:59:59 P.M., December 31, 9999 A.D. (C.E.) These limits are stored as read-only values in the MinValue and MaxValue fields.

Time values are measured in 100-nanosecond units called ticks, and a particular date is expressed as the number of ticks that have elapsed since 12:00 midnight, January 1, 0001 A.D. (C.E.) in the Gregorian calendar. For example, a tick value of 31241376000000000L represents Friday, January 01, 0100 12:00:00 midnight.

DateTime Values

Descriptions of DateTime time values are often expressed using the Coordinated Universal Time (UTC) standard, which is the internationally recognized name for Greenwich Mean Time (GMT). Coordinated Universal Time is the time as measured at 0 (zero) degrees longitude, the UTC origin point. Note that daylight saving time is not applicable to UTC.

Local time is relative to a particular time zone. Each time zone is associated with a specific time zone offset, which is the displacement of that time zone measured in hours of temporal distance from the UTC origin point. In addition, local time is optionally affected by daylight saving time, which is a widely used system of adjusting the official local time forward, usually by one hour from its official standard time, for the summer months. Consequently, local time is calculated by adding the time zone offset to UTC and adjusting for daylight saving time, if necessary. The time zone offset at the UTC origin point is 0 (zero).

UTC time is suitable for making calculations and comparisons and for storing dates and time in files. Local time is appropriate for displaying the current date and time in user interfaces.

DateTime Operations

A calculation using a DateTime structure, such as the Add or Subtract method, does not modify the value of the structure. Instead, the calculation returns a new DateTime structure whose value is the result of the calculation.

Operations by members of the DateTime type take into account such details as leap years and the number of days in a particular month. Conversion operations between local time and UTC time take daylight saving time into account, but arithmetic and comparison operations do not make this daylight saving time adjustment.

Calculations and comparisons of DateTime objects are meaningful only if the objects represent times in the same time zone. It is assumed that the developer has some external mechanism, such as an explicit variable or policy, that can be used to determine the time zone in which a particular DateTime object was created.

DateTime vs. TimeSpan

The DateTime and TimeSpan value types differ in that a DateTime value represents a specific instant in time, whereas a TimeSpan value represents a specific period of time. This means, for example, that you can subtract one DateTime value from another to obtain the time interval between the two. Similarly, you can either add a positive TimeSpan value to the current DateTime value to calculate a future date or subtract a positive TimeSpan value from the current DateTime value to calculate a past date.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Members
System Namespace


DateTime Members

DateTime Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the DateTime type.

Expand image Public Constructors

 | Name | Description
Public Method | DateTime | Overloaded. Initializes a new instance of the DateTime structure.

Expand image Public Fields

 | Name | Description
Public Field | MaxValue | Represents the largest possible value for a DateTime object. Note that this field is read-only.
Public Field | MinValue | Represents the smallest possible value for a DateTime object. Note that this field is read-only.

Expand image Public Properties

 | Name | Description
Public Property | Date | Gets the date component of current DateTime object.
Public Property | Day | Gets the day-of-the-month component of the current DateTime object.
Public Property | DayOfWeek | Gets the day-of-the-week component of the current DateTime object.
Public Property | DayOfYear | Gets the day-of-the-year component of the current DateTime object.
Public Property | Hour | Gets the hours component of the current DateTime object.
Public Property | Millisecond | Gets the milliseconds component of the current DateTime object.
Public Property | Minute | Gets the minutes component of the current DateTime object.
Public Property | Month | Gets the month component of the current DateTime object.
 | Now | Gets the system's current date and time, expressed in local time.
Public Property | Second | Gets the seconds component of the current DateTime object.
Public Property | Ticks | Gets the current number of ticks in the current DateTime object.
Public Property | TimeOfDay | Gets the time-of-day component of the current DateTime object.
 | Today | Gets the current date.
 | UtcNow | Gets the system's current date and time, expressed in Coordinated Universal Time (UTC).
Public Property | Year | Gets the year component of the current DateTime object.

Expand image Public Methods

 | Name | Description
Public Method | Add | Adds a specified time period to the current DateTime object, yielding a new DateTime object.
Public Method | AddDays | Adds a specified number of days to the current DateTime object.
Public Method | AddHours | Adds a specified number of hours to the current DateTime object.
Public Method | AddMilliseconds | Adds a specified number of milliseconds to the current DateTime object.
Public Method | AddMinutes | Adds a specified number of minutes to the current DateTime object.
Public Method | AddSeconds | Adds a specified number of seconds to the current DateTime object.
Public Method | AddTicks | Adds a specified number of ticks to the current DateTime object.
 | Compare | Compares two date/time values in order to determine their relative value.
Public Method | CompareTo | Compares a specified date/time to this date/time instance in order to determine their relative value.
 | DaysInMonth | Returns the number of days in a specified month of a specified year.
Public Method | Equals | Overloaded. Determines whether two DateTime objects have identical values.
 | operator - | Overloaded. Subtracts one DateTime object from another one, or subtracts a specified time period from a specified DateTime object.
 | operator != | Determines whether two specified DateTime objects are not equal.
 | operator + | Adds a specified period of time to a specified DateTime object, yielding a new DateTime object.
 | operator < | Determines whether one DateTime object is less than another one.
 | operator <= | Determines whether one DateTime is less than or equal to another one.
 | operator == | Determines whether two specified DateTime objects have the same date/time value.
 | operator > | Determines whether one DateTime object is greater than another one.
 | operator >= | Determines whether one DateTime object is greater than or equal to another one.
Public Method | Subtract | Overloaded. Subtracts either a time period or another DateTime object from the current DateTime object.
Public Method | ToLocalTime | Converts the current value of the current DateTime object to local time.
Public Method | ToString | Overloaded. Converts the value of the current DateTime object to its equivalent string representation.
Public Method | ToUniversalTime | Converts the value of the current DateTime object to Coordinated Universal Time (UTC).

Expand image See Also

Reference

DateTime Structure
System Namespace


CultureInfo.DateTimeFormat Property

CultureInfo.DateTimeFormat Property

Gets or sets a DateTimeFormatInfo object that defines the culturally appropriate format for displaying dates and times.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual DateTimeFormatInfo DateTimeFormat { get; }

Property Value

A DateTimeFormatInfo object that defines the culturally appropriate format for displaying dates and times.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


DateTimeFormatInfo Class

DateTimeFormatInfo Class
See Also Members
CollapseAll image

Defines how DateTime values are formatted and displayed, depending on the culture.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public sealed class DateTimeFormatInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Members
System.Globalization Namespace


DateTimeFormatInfo Members

DateTimeFormatInfo Members
See Also Properties
CollapseAll image

The following tables list the members exposed by the DateTimeFormatInfo type.

Expand image Public Properties

 | Name | Description
Public Property | AbbreviatedDayNames | Gets a one-dimensional array of String objects that contain the culture-specific abbreviated names of the days of the week.
Public Property | AbbreviatedMonthNames | Gets a one-dimensional array of String objects that contain the culture-specific abbreviated names of the months.
Public Property | AMDesignator | Gets the string designator for hours that are "ante meridiem" (before noon).
 | CurrentInfo | Gets a read-only DateTimeFormatInfo object that formats values based on the current culture.
Public Property | DateSeparator | Gets the string that separates the components of a date (year, month, and day).
Public Property | DayNames | Gets a one-dimensional array of String objects that contain the culture-specific full names of the days of the week.
Public Property | FullDateTimePattern | Gets the format pattern for a long date and long time value, which is associated with the "F" format character.
Public Property | LongDatePattern | Gets the format pattern for a long date value, which is associated with the "D" format character.
Public Property | LongTimePattern | Gets the format pattern for a long time value, which is associated with the "T" format character.
Public Property | MonthDayPattern | Gets the format pattern for a month and day value, which is associated with the "m" and "M" format characters.
Public Property | MonthNames | Gets a one-dimensional array of String objects that contain the culture-specific full names of the months.
Public Property | PMDesignator | Gets the string designator for hours that are "post meridiem" (after noon).
Public Property | ShortDatePattern | Gets the format pattern for a short date value, which is associated with the "d" format character.
Public Property | ShortTimePattern | Gets the format pattern for a short time value, which is associated with the "t" format character.
Public Property | TimeSeparator | Gets the string that separates the components of time, as expressed on the system clock (hour, minutes, and seconds).
Public Property | YearMonthPattern | Gets the format pattern for a year and month value, which is associated with the "y" and "Y" format characters.

Expand image See Also

Reference

DateTimeFormatInfo Class
System.Globalization Namespace


DateTime.Day Property

DateTime.Day Property

Gets the day-of-the-month component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Day { get; }

Property Value

The day of the month, expressed as a number ranging from 1 through 31.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Day Field

SystemTime.Day Field

Specifies the day associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Day

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


TimeZoneInformation.DaylightBias Field

TimeZoneInformation.DaylightBias Field

Specifies the bias value to be used for local time translations that occur during daylight saving time in a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int DaylightBias

Expand image Remarks

This field is ignored if a DaylightDate value has not been set.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


TimeZoneInformation.DaylightDate Field

TimeZoneInformation.DaylightDate Field

Specifies a date and a local time when the transition from standard time to daylight saving time will occur on this operating system.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public SystemTime DaylightDate

Expand image Remarks

If a particular time zone does not support daylight saving time, or if the caller needs to disable daylight saving time, the Month field in the SystemTime object must be 0 (zero). If this date is specified, the StandardDate field in the current TimeZoneInformation object must also be specified. Otherwise, the system assumes that the time zone data is invalid and no changes are applied.

To select the correct day in a particular month, set the SystemTime object's Year member to 0 (zero), set the Hour and Minute members to the transition time, set the DayOfWeek member to the appropriate day of the week, and set the Day member to indicate the sequential occurrence of the specified day of the week within the specified month (that is, the first, second, third, fourth, or fifth occurrence of that day of the week in that month).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


ExtendedTimeZone.DaylightName Property

ExtendedTimeZone.DaylightName Property

Gets the daylight saving time name for a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public override string DaylightName { get; }

Property Value

The daylight saving time name for a particular time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


TimeZone.DaylightName Property

TimeZone.DaylightName Property

Gets the daylight saving time zone name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract string DaylightName { get; }

Property Value

The daylight saving time zone name.

Expand image Remarks

If daylight saving time is not used in the time zone you are in, an empty string ("") is returned.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


TimeZoneInformation.DaylightName Field

TimeZoneInformation.DaylightName Field

Contains a description of daylight saving time.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public string DaylightName

Expand image Remarks

This string can be a full text description, an abbreviated description, or an acronym. For example, you could denote Pacific Daylight Time as "PDT". Note that this string can be empty.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


DaylightTime Class

DaylightTime Class
See Also Members
CollapseAll image

Defines the period of daylight saving time for the local time zone.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class DaylightTime

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DaylightTime Members
System.Globalization Namespace


DaylightTime Members

DaylightTime Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DaylightTime type.

Expand image Public Constructors

 | Name | Description
Public Method | DaylightTime | Initializes a new instance of the DaylightTime class.

Expand image Public Properties

 | Name | Description
Public Property | Delta | Gets the TimeSpan object that represents the difference between standard time and daylight saving time for the local time zone.
Public Property | End | Gets the DateTime object that represents the date and time when daylight saving time ends for the local time zone.
Public Property | Start | Gets the DateTime object that represents the date and time when daylight saving time begins for the local time zone.

Expand image See Also

Reference

DaylightTime Class
System.Globalization Namespace


DateTimeFormatInfo.DayNames Property

DateTimeFormatInfo.DayNames Property

Gets a one-dimensional array of String objects that contain the culture-specific full names of the days of the week.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string [] DayNames { get; }

Property Value

A one-dimensional array of String objects that contain the culture-specific full names of the days of the week.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTime.DayOfWeek Property

DateTime.DayOfWeek Property

Gets the day-of-the-week component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DayOfWeek DayOfWeek { get; }

Property Value

The day of the week, expressed as a number ranging from 0 through 6. This value is a member of the DayOfWeek enumeration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DayOfWeek Enumeration

DayOfWeek Enumeration

Contains values you can use to specify the day of the week.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum DayOfWeek

Expand image Members

Member name | Description
Friday | A value that indicates Friday.
Monday | A value that indicates Monday.
Saturday | A value that indicates Saturday.
Sunday | A value that indicates Sunday.
Thursday | A value that indicates Thursday
Tuesday | A value that indicates Tuesday.
Wednesday | A value that indicates Wednesday.

Expand image Remarks

The DayOfWeek enumeration represents the day of the week in calendars that have seven days per week. This enumeration contains values ranging from 0 (indicating Sunday) to 6 (indicating Saturday).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


SystemTime.DayOfWeek Field

SystemTime.DayOfWeek Field

Specifies the day of the week associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short DayOfWeek

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


DateTime.DayOfYear Property

DateTime.DayOfYear Property

Gets the day-of-the-year component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int DayOfYear { get; }

Property Value

The day of the year, expressed as a number ranging from 1 through 366.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.Days Property

TimeSpan.Days Property

Gets the number of whole days in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Days { get; }

Property Value

The number of whole days in the current TimeSpan object.

Expand image Remarks

The value of a TimeSpan object can be expressed as [-]d.hh:mm:ss.ff, where the optional minus sign indicates a negative time period, d is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. The value of the Days property is the day component, d.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.DaysInMonth Method

DateTime.DaysInMonth Method

Returns the number of days in a specified month of a specified year.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int DaysInMonth (
         int year,
         int month
)

Parameters

year
A specific year, expressed as a number from 1 through 9999.
month
A specific month, expressed as a number from 1 through 12.

Return Value

The number of days in the specified month (from 28 through 31).

Expand image Remarks

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Debug Class

Debug Class
See Also Members
CollapseAll image

Provides a set of methods and properties that help you debug your code.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static class Debug

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Members
Microsoft.SPOT Namespace


Debug Members

Debug Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the Debug type.

Expand image Public Methods

Name | Description
Assert | Overloaded. Causes a break in execution if the specified assertion (condition) evaluates to true.
DumpBuffer | Prints the data for a specified buffer to the standard output stream.
DumpHeap | Prints all available heap information to the standard output stream.
DumpPerfCounters | Prints performance counter information to the standard output stream.
DumpStack | Prints all available stack information to the standard output stream.
GC | Runs garbage collection, a service that automatically reclaims unused computer memory.
Print | Prints a message (followed by the current line terminator) to the standard output stream.

Expand image See Also

Reference

Debug Class
Microsoft.SPOT Namespace


DebuggableAttribute Class

DebuggableAttribute Class
See Also Members
CollapseAll image

Modifies code generation for just-in-time (JIT) runtime debugging.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class DebuggableAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Members
System.Diagnostics Namespace


DebuggableAttribute Members

DebuggableAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DebuggableAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggableAttribute | Overloaded. Initializes a new instance of the DebuggableAttribute class, which sets the conditions for controlling code generation for just-in-time (JIT) runtime debugging.

Expand image Public Properties

 | Name | Description
Public Property | DebuggingFlags | Gets the debugging mode flags.
Public Property | IsJITOptimizerDisabled | Gets a value that indicates whether the runtime optimizer is disabled.
Public Property | IsJITTrackingEnabled | Gets a value that indicates whether the runtime will track information for the debugger during code generation.

Expand image See Also

Reference

DebuggableAttribute Class
System.Diagnostics Namespace


Debugger Class

Debugger Class
See Also Members
CollapseAll image

Enables communication with a debugger.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class Debugger

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debugger Members
System.Diagnostics Namespace


Debugger Members

Debugger Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the Debugger type.

Expand image Public Properties

Name | Description
IsAttached | Gets a value that indicates whether a debugger is attached to the current process.

Expand image Public Methods

Name | Description
Break | Signals a breakpoint to an attached debugger.

Expand image See Also

Reference

Debugger Class
System.Diagnostics Namespace


DebuggerBrowsableAttribute Class

DebuggerBrowsableAttribute Class
See Also Members
CollapseAll image

Specifies whether a particular section of code is browsable.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class DebuggerBrowsableAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerBrowsableAttribute Members
System.Diagnostics Namespace


DebuggerBrowsableAttribute Members

DebuggerBrowsableAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DebuggerBrowsableAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerBrowsableAttribute | Initializes a new instance of the DebuggerBrowsableAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | State | Gets the current browsing state of a particular section of code.

Expand image See Also

Reference

DebuggerBrowsableAttribute Class
System.Diagnostics Namespace


DebuggerBrowsableState Enumeration

DebuggerBrowsableState Enumeration

Specifies the state of a node in the debugger.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public enum DebuggerBrowsableState

Expand image Members

Member name | Description
Collapsed | A value indicating that the current class is not expanded and that the class's internal visible members are hidden.
Never | A value indicating that the specified element should never be shown.
RootHidden | A value indicating that the target element itself should not be shown, but that it should instead be expanded automatically so that its members are displayed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Diagnostics Namespace


DebuggerDisplayAttribute Class

DebuggerDisplayAttribute Class
See Also Members
CollapseAll image

Controls what is displayed for a specific class or field in the debugger's data windows.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class DebuggerDisplayAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Members
System.Diagnostics Namespace


DebuggerDisplayAttribute Members

DebuggerDisplayAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DebuggerDisplayAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerDisplayAttribute | Creates and initializes a new instance of the DebuggerDisplayAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | Name | Gets or sets the display name.
Public Property | Target | Gets or sets the target assembly.
Public Property | TargetTypeName | Gets or sets the name of the target type.
Public Property | Type | Gets or sets the display type.
Public Property | Value | Gets the display value.

Expand image See Also

Reference

DebuggerDisplayAttribute Class
System.Diagnostics Namespace


DebuggerHiddenAttribute Class

DebuggerHiddenAttribute Class
See Also Members
CollapseAll image

Specifies hidden attributes of the debugger.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class DebuggerHiddenAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerHiddenAttribute Members
System.Diagnostics Namespace


DebuggerHiddenAttribute Members

DebuggerHiddenAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the DebuggerHiddenAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerHiddenAttribute | Initializes a new instance of the DebuggerHiddenAttribute class.

Expand image See Also

Reference

DebuggerHiddenAttribute Class
System.Diagnostics Namespace


DebuggerNonUserCodeAttribute Class

DebuggerNonUserCodeAttribute Class
See Also Members
CollapseAll image

Implements an attribute that marks code as not being written by the developer who wrote the current application.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class DebuggerNonUserCodeAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerNonUserCodeAttribute Members
System.Diagnostics Namespace


DebuggerNonUserCodeAttribute Members

DebuggerNonUserCodeAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the DebuggerNonUserCodeAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerNonUserCodeAttribute | Creates and initializes an instance of the DebuggerNonUserCodeAttribute class.

Expand image See Also

Reference

DebuggerNonUserCodeAttribute Class
System.Diagnostics Namespace


DebuggerStepperBoundaryAttribute Class

DebuggerStepperBoundaryAttribute Class
See Also Members
CollapseAll image

Immediately precedes code that is to be executed in run mode, as opposed to step mode.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class DebuggerStepperBoundaryAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerStepperBoundaryAttribute Members
System.Diagnostics Namespace


DebuggerStepperBoundaryAttribute Members

DebuggerStepperBoundaryAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the DebuggerStepperBoundaryAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerStepperBoundaryAttribute | Creates and initializes an instance of the DebuggerStepperBoundaryAttribute class.

Expand image See Also

Reference

DebuggerStepperBoundaryAttribute Class
System.Diagnostics Namespace


DebuggerStepThroughAttribute Class

DebuggerStepThroughAttribute Class
See Also Members
CollapseAll image

Enables the debugger to step through code line by line during the debugging process.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class DebuggerStepThroughAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerStepThroughAttribute Members
System.Diagnostics Namespace


DebuggerStepThroughAttribute Members

DebuggerStepThroughAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the DebuggerStepThroughAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerStepThroughAttribute | Initializes a new instance of the DebuggerStepThroughAttribute class.

Expand image See Also

Reference

DebuggerStepThroughAttribute Class
System.Diagnostics Namespace


DebuggerTypeProxyAttribute Class

DebuggerTypeProxyAttribute Class
See Also Members
CollapseAll image

Specifies the display proxy for a particular type.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class DebuggerTypeProxyAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


DebuggerTypeProxyAttribute Members

DebuggerTypeProxyAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DebuggerTypeProxyAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DebuggerTypeProxyAttribute | Overloaded. Initializes a new instance of the DebuggerTypeProxyAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | ProxyTypeName | Gets the name of the proxy type.
Public Property | Target | Gets or sets the target type for the current attribute.
Public Property | TargetTypeName | Gets or sets the name of the target type.

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
System.Diagnostics Namespace


DebuggableAttribute.DebuggingFlags Property

DebuggableAttribute.DebuggingFlags Property

Gets the debugging mode flags.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggingModes DebuggingFlags { get; }

Property Value

The debugging mode flags.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


DebuggableAttribute.DebuggingModes Enumeration

DebuggableAttribute.DebuggingModes Enumeration

Specifies the debugging modes supported in the .NET Micro Framework.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[FlagsAttribute]
public enum DebuggableAttribute.DebuggingModes

Expand image Members

Member name | Description
Default | A value specifying the default debugging mode.
DisableOptimizations | A value specifying that compiler optimizations should be turned off when debugging is in progress.
EnableEditAndContinue | A value specifying that the Edit and Continue feature should be enabled.
IgnoreSymbolStoreSequencePoints | A value specifying that symbol store sequence points should be ignored.
None | A value specifying that the debugging mode is not specified.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Diagnostics Namespace


MemberInfo.DeclaringType Property

MemberInfo.DeclaringType Property

Gets the class that declares the current member.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type DeclaringType { get; }

Property Value

The Type object for the class that declares the current member.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MemberInfo Class
MemberInfo Members
System.Reflection Namespace


MethodBase.DeclaringType Property

MethodBase.DeclaringType Property

Gets the class that declares the current method.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override Type DeclaringType { get; }

Property Value

The Type object for the class that declares the current method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Type.DeclaringType Property

Type.DeclaringType Property

Gets the type name of the class that declares the current member.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override Type DeclaringType { get; }

Property Value

The Type object (type name) for the class that declares the current member. If the type is a nested type, this property returns the enclosing type.

Expand image Remarks

This property implements the abstract property inherited from the MemberInfo class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Interlocked.Decrement Method

Interlocked.Decrement Method

Decrements the value of a specified variable and stores the result, as an atomic operation.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Decrement (
         ref int location
)

Parameters

location
The variable whose value is to be decremented.

Return Value

The decremented value.

Expand image Remarks

This is an atomic operation; it cannot be interrupted before it is complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Interlocked Class
Interlocked Members
System.Threading Namespace


AssemblyDefaultAliasAttribute.DefaultAlias Property

AssemblyDefaultAliasAttribute.DefaultAlias Property

Gets the default alias information for an assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string DefaultAlias { get; }

Property Value

A string that contains the default alias information for an assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDefaultAliasAttribute Class
AssemblyDefaultAliasAttribute Members
System.Reflection Namespace


Font.DefaultKerning Field

Font.DefaultKerning Field

Contains the default kerning for a particular font.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int DefaultKerning

Expand image Remarks

The kerning controls the amount of space between consecutive characters in a particular font.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


DefaultMemberAttribute Class

DefaultMemberAttribute Class
See Also Members
CollapseAll image

Defines the member of a type that is the default member used by the System.Type.InvokeMember method.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class DefaultMemberAttribute : Attribute

Expand image Remarks

The default member is a name given to a particular type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DefaultMemberAttribute Members
System.Reflection Namespace


DefaultMemberAttribute Members

DefaultMemberAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DefaultMemberAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | DefaultMemberAttribute | Initializes a new instance of the DefaultMemberAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | MemberName | Gets the member name from the current attribute.

Expand image See Also

Reference

DefaultMemberAttribute Class
System.Reflection Namespace


AssemblyDelaySignAttribute.DelaySign Property

AssemblyDelaySignAttribute.DelaySign Property

Gets a value that indicates the state of the AssemblyDelaySignAttribute attribute for the current assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool DelaySign { get; }

Property Value

true if the current assembly has been built as delay-signed; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDelaySignAttribute Class
AssemblyDelaySignAttribute Members
System.Reflection Namespace


Delegate Class

Delegate Class
See Also Members
CollapseAll image

Represents a delegate, which is a data structure that refers to a static method or to a class instance and an instance method of that class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class Delegate

Expand image Remarks

The Delegate class is the base class for delegate types. Note, however, that only the system and compilers can derive types explicitly from the Delegate class or from the MulticastDelegate class. Also, you cannot derive a new type from a delegate type. The Delegate class is not considered a delegate type; rather, it is a class that you use to derive delegate types.

Most programming languages provide a delegate keyword, and compilers for those languages are able to derive types from the Delegate and MulticastDelegate classes. Therefore, you should use the delegate keyword provided by each language.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Members
System Namespace


Delegate Members

Delegate Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Delegate type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Delegate | Initializes a new delegate.

Expand image Public Properties

 | Name | Description
Public Property | Method | Gets the method represented by the current delegate.
Public Property | Target | Gets the object for which the current delegate invokes the instance method.

Expand image Public Methods

 | Name | Description
 | Combine | Concatenates the invocation lists of two multicast (combinable) delegates.
Public Method | Equals | Determines whether the specified object and the current singlecast (uncombinable) delegate share the same target, method, and invocation list.
 | op_Equality | Determines whether the specified delegates are equal to one another.
 | op_Inequality | Determines whether the specified delegates are not equal to one another.
 | Remove | Removes the last occurrence of a delegate's invocation list from another delegate's invocation list.

Expand image See Also

Reference

Delegate Class
System Namespace


DaylightTime.Delta Property

DaylightTime.Delta Property

Gets the TimeSpan object that represents the difference between standard time and daylight saving time for the local time zone.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Delta { get; }

Property Value

The TimeSpan object that represents the difference between standard time and daylight saving time for the local time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DaylightTime Class
DaylightTime Members
System.Globalization Namespace


Font.Descent Property

Font.Descent Property

Gets the descent measurement for the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int Descent { get; }

Property Value

The descent measurement for the current font, in pixels.

Expand image Remarks

A font's descent is the vertical distance between the font baseline and the bottom of the font area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


AssemblyDescriptionAttribute.Description Property

AssemblyDescriptionAttribute.Description Property

Gets the description text for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Description { get; }

Property Value

A string that contains the description text for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyDescriptionAttribute Class
AssemblyDescriptionAttribute Members
System.Reflection Namespace


Reflection.Deserialize Method

Reflection.Deserialize Method

Deserializes a byte array of data into an object of the specified type.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Object Deserialize (
         byte[] v,
         Type t
)

Parameters

v
A byte array containing data that represents the serialized object.
t
The type of the object to be deserialized. This should be a null reference if the array in the v parameter contains that type.

Return Value

The deserialized object represented by the byte array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


InputEventArgs.Device Property

InputEventArgs.Device Property

Gets the device that generated the input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputDevice Device { get; }

Property Value

The device that generated the input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputEventArgs Class
InputEventArgs Members
Microsoft.SPOT.Input Namespace


System.Diagnostics Namespace

System.Diagnostics Namespace

The System.Diagnostics namespace in the Microsoft® .NET Micro Framework provides classes and enumerations you can use to interact with system processes, event logs, and performance counters.

Expand image Classes

 | Name | Description
Public Class | ConditionalAttribute | Indicates to compilers that a particular method is callable if a specified preprocessing identifier is applied to that method.
Public Class | DebuggableAttribute | Modifies code generation for just-in-time (JIT) runtime debugging.
Public Class | Debugger | Enables communication with a debugger.
Public Class | DebuggerBrowsableAttribute | Specifies whether a particular section of code is browsable.
Public Class | DebuggerDisplayAttribute | Controls what is displayed for a specific class or field in the debugger's data windows.
Public Class | DebuggerHiddenAttribute | Specifies hidden attributes of the debugger.
Public Class | DebuggerNonUserCodeAttribute | Implements an attribute that marks code as not being written by the developer who wrote the current application.
Public Class | DebuggerStepperBoundaryAttribute | Immediately precedes code that is to be executed in run mode, as opposed to step mode.
Public Class | DebuggerStepThroughAttribute | Enables the debugger to step through code line by line during the debugging process.
Public Class | DebuggerTypeProxyAttribute | Specifies the display proxy for a particular type.

Expand image Enumerations

 | Name | Description
Public Enumeration | DebuggableAttribute.DebuggingModes | Specifies the debugging modes supported in the .NET Micro Framework.
Public Enumeration | DebuggerBrowsableState | Specifies the state of a node in the debugger.

Expand image Remarks

Although the .NET Micro Framework supports many of the classes contained in the System.Diagnostics namespace, it also provides the Microsoft.SPOT.Debug class for your debugging needs. The Microsoft.SPOT.Debug class was created especially for the .NET Micro Framework, so you are strongly encouraged to use it instead of the classes in System.Diagnostics whenever you need to debug your .NET Micro Framework applications.


DispatcherObject.Dispatcher Field

DispatcherObject.Dispatcher Field

Contains the Dispatcher object that the current DispatcherObject object is associated with.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Dispatcher Dispatcher

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherObject Class
DispatcherObject Members
Microsoft.SPOT Namespace


DispatcherOperation.Dispatcher Property

DispatcherOperation.Dispatcher Property

Gets the dispatcher that the delegate associated with the current DispatcherOperation object was posted to.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Dispatcher Dispatcher { get; }

Property Value

The dispatcher that the delegate was posted to.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


DispatcherTimer.Dispatcher Property

DispatcherTimer.Dispatcher Property

Gets the Dispatcher object (dispatcher) associated with the current DispatcherTimer object (timer).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Dispatcher Dispatcher { get; }

Property Value

The dispatcher associated with the current timer.

Expand image Remarks

The Dispatcher object contained in the Dispatcher property is set when your program calls the DispatcherTimer constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


Dispatcher Class

Dispatcher Class
See Also Members
CollapseAll image

Provides services for maintaining the event queue for a thread.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class Dispatcher

Expand image Remarks

This class cannot be inherited.

When a Dispatcher object (a dispatcher) is created on a thread, it becomes the only dispatcher that can be associated with that thread, even if the program shuts down the Dispatcher object. If your program shuts down a Dispatcher object, that dispatcher cannot be restarted. If your program calls the BeginInvoke and BeginInvoke methods on a Dispatcher object that has been shut down, an exception is thrown.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Members
Microsoft.SPOT Namespace


Dispatcher Members

Dispatcher Members
See Also Events Methods Properties
CollapseAll image

The following tables list the members exposed by the Dispatcher type.

Expand image Public Properties

 | Name | Description
 | CurrentDispatcher | Gets the Dispatcher object (dispatcher) for the thread that is currently executing and creates a new dispatcher if one is not already associated with the current thread.
Public Property | HasShutdownFinished | Determines whether the current Dispatcher object (dispatcher) has finished shutting down.
Public Property | HasShutdownStarted | Determines whether the current Dispatcher object (dispatcher) is shutting down.
Public Property | Thread | Gets the thread with which the current Dispatcher object (dispatcher) is associated.

Expand image Public Methods

 | Name | Description
Public Method | BeginInvoke | Executes a specified delegate on the thread on which a particular Dispatcher object (dispatcher) was created.
Public Method | CheckAccess | Determines whether the calling thread has access to the current Dispatcher object (dispatcher).
 | FromThread | Gets the Dispatcher object (dispatcher) for a specified thread.
Public Method | Invoke | Executes a specified delegate with a specified argument.
Public Method | InvokeShutdown | Initiates the shutdown process for a Dispatcher object (dispatcher) synchronously.
 | PushFrame | Pushes an execution frame onto the event queue of a Dispatcher object (dispatcher).
 | Run | Initiates the event queue of a Dispatcher object (dispatcher).
Public Method | VerifyAccess | Determines whether the calling thread has access to the current Dispatcher object (dispatcher).

Expand image Public Events

 | Name | Description
Public Event | ShutdownFinished | Occurs when a Dispatcher object (a dispatcher) finishes shutting down.
Public Event | ShutdownStarted | Occurs when a Dispatcher object (a dispatcher) begins the shutdown process.

Expand image See Also

Reference

Dispatcher Class
Microsoft.SPOT Namespace


DispatcherFrame Class

DispatcherFrame Class
See Also Members
CollapseAll image

Represents an execution loop iteration in the dispatcher event queue.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class DispatcherFrame

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherFrame Members
Microsoft.SPOT Namespace


DispatcherFrame Members

DispatcherFrame Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the DispatcherFrame type.

Expand image Public Constructors

 | Name | Description
Public Method | DispatcherFrame | Overloaded. Initializes a new instance of the DispatcherFrame class.

Expand image Public Properties

 | Name | Description
Public Property | Continue | Gets or sets a value that indicates whether the current dispatcher frame should continue.

Expand image See Also

Reference

DispatcherFrame Class
Microsoft.SPOT Namespace


DispatcherObject Class

DispatcherObject Class
See Also Members
CollapseAll image

Represents an object that is associated with a dispatcher.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class DispatcherObject

Expand image Remarks

Subclasses of the DispatcherObject class should enforce thread safety by calling the Dispatcher.VerifyAccess method in all of their public methods. This guarantees that the calling thread is the thread on which the current DispatcherObject object was created.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherObject Members
Microsoft.SPOT Namespace


DispatcherObject Members

DispatcherObject Members
See Also Constructors Fields Methods
CollapseAll image

The following tables list the members exposed by the DispatcherObject type.

Expand image Public Constructors

 | Name | Description
Public Method | DispatcherObject | Initializes a new instance of the DispatcherObject class.

Expand image Public Fields

 | Name | Description
Public Field | Dispatcher | Contains the Dispatcher object that the current DispatcherObject object is associated with.

Expand image Public Methods

 | Name | Description
Public Method | CheckAccess | Determines whether the calling thread has access to the current DispatcherObject object.
Public Method | VerifyAccess | Determines whether the calling thread has access to the current DispatcherObject object.

Expand image See Also

Reference

DispatcherObject Class
Microsoft.SPOT Namespace


DispatcherOperation Class

DispatcherOperation Class
See Also Members
CollapseAll image

Enables programs to interact with a delegate that has been posted to a dispatcher queue.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class DispatcherOperation

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Members
Microsoft.SPOT Namespace


DispatcherOperation Members

DispatcherOperation Members
See Also Events Methods Properties
CollapseAll image

The following tables list the members exposed by the DispatcherOperation type.

Expand image Public Properties

 | Name | Description
Public Property | Dispatcher | Gets the dispatcher that the delegate associated with the current DispatcherOperation object was posted to.
Public Property | Result | Gets the result of the delegate associated with the current DispatcherOperation object, if the operation has completed.
Public Property | Status | Gets the current operation status of the delegate on the dispatcher queue associated with the current DispatcherOperation object.

Expand image Public Methods

 | Name | Description
Public Method | Abort | Aborts the delegate on the dispatcher queue associated with the current DispatcherOperation object.
Public Method | Wait | Overloaded. Waits for the delegate on the dispatcher queue associated with the current DispatcherOperation object to complete.

Expand image Public Events

 | Name | Description
Public Event | Aborted | Occurs when the delegate on the dispatcher queue associated with the current DispatcherOperation object is aborted.
Public Event | Completed | Occurs when the delegate on the dispatcher queue associated with the current DispatcherOperation object completes.

Expand image See Also

Reference

DispatcherOperation Class
Microsoft.SPOT Namespace


DispatcherOperationCallback Delegate

DispatcherOperationCallback Delegate

Provides callback functionality for dispatcher operations.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate Object DispatcherOperationCallback (
         Object arg
)

Parameters

arg
An argument that is passed to the callback method. The value of this parameter can be null.

Return Value

The object returned by the callback method. This value can be null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


DispatcherOperationStatus Enumeration

DispatcherOperationStatus Enumeration

Describes the possible values for the status of a DispatcherOperation object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum DispatcherOperationStatus

Expand image Members

Member name | Description
Aborted | A value indicating that the operation has aborted.
Completed | A value indicating that the operation has completed.
Executing | A value indicating that the operation has started executing but has not completed.
Pending | A value indicating that the operation is pending.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


DispatcherTimer Class

DispatcherTimer Class
See Also Members
CollapseAll image

A timer that is integrated into a dispatcher queue.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class DispatcherTimer

Expand image Remarks

When your program inserts a DispatcherTimer object (timer) into the queue of a Dispatcher object (dispatcher), the dispatcher processes the timer at a specified time interval. If the dispatcher is processing a large number of messages, the timer might not be evaluated at the expected time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Members
Microsoft.SPOT Namespace


DispatcherTimer Members

DispatcherTimer Members
See Also Constructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the DispatcherTimer type.

Expand image Public Constructors

 | Name | Description
Public Method | DispatcherTimer | Overloaded. Initializes a new instance of the DispatcherTimer class.

Expand image Public Properties

 | Name | Description
Public Property | Dispatcher | Gets the Dispatcher object (dispatcher) associated with the current DispatcherTimer object (timer).
Public Property | Interval | Gets or sets the current DispatcherTimer object's defined time interval.
Public Property | IsEnabled | Gets or sets a Boolean value that indicates whether a particular DispatcherTimer object (timer) is enabled — that is, currently running.
Public Property | Tag | Gets or sets a user-defined data object that is passed to the Tick event handler.

Expand image Public Methods

 | Name | Description
Public Method | Start | Starts a DispatcherTimer object's timer.
Public Method | Stop | Stops a DispatcherTimer object's timer.

Expand image Public Events

 | Name | Description
Public Event | Tick | Occurs when the specified time interval for the current DispatcherTimer object (timer) has elapsed and the timer is enabled.

Expand image See Also

Reference

DispatcherTimer Class
Microsoft.SPOT Namespace


ExtendedTimer.Dispose Method

ExtendedTimer.Dispose Method

Releases all resources used by the current instance of the ExtendedTimer class.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual void Dispose ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


IDisposable.Dispose Method

IDisposable.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void Dispose ()

Expand image Remarks

Use this method to close or release unmanaged resources such as files, streams, and handles held by an instance of the class that implements the IDisposable interface. This method is typically used for all tasks associated with freeing resources held by an object or preparing an object for reuse.

When you implement this method, objects must free all held resources by propagating the call through the containment hierarchy. For example, if object A allocates object B, and object B allocates object C, then object A's Dispose implementation must call the Dispose method on object B, which must in turn call the Dispose method on object C. Objects must also call the Dispose method of their base class if the base class implements the IDisposable interface.

If an object's Dispose method is called more than once, the object must ignore all such calls after the first one. The object must not throw an exception if its Dispose method is called multiple times. Note that Dispose can throw an exception if an error occurs because a resource has already been freed and Dispose has not yet been called.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IDisposable Interface
IDisposable Members
System Namespace


InputProviderSite.Dispose Method

InputProviderSite.Dispose Method

Frees, releases, or resets unmanaged resources for the current InputProviderSite object.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Dispose ()

Expand image Remarks

Use this method to close or release unmanaged resources, such as streams and handles, that are held by an InputProviderSite object. Typically, this method is used for all tasks associated with freeing resources held by an object, or preparing an object for reuse.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputProviderSite Class
InputProviderSite Members
Microsoft.SPOT.Input Namespace
IDisposable Interface


Timer.Dispose Method

Timer.Dispose Method

Releases all resources used by the current Timer object (timer).

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual void Dispose ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Class
Timer Members
System.Threading Namespace


Double Structure

Double Structure

Represents a double-precision floating point number.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Double

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Members
System Namespace


Double Members

Double Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Double type.

Expand image Public Fields

Name | Description
Epsilon | Represents the smallest possible Double greater than zero. This field is constant.
MaxValue | Represents the largest possible value of Double. This field is constant.
MinValue | Represents the smallest possible value of Double. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current Double object to its equivalent string representation.

Expand image See Also

Reference

Double Structure
System Namespace


Bitmap.DrawEllipse Method

Bitmap.DrawEllipse Method

Draws a filled ellipse on the display device.

Expand image Overload List

Name | Description
Bitmap.DrawEllipse (Color, Int32, Int32, Int32, Int32) | Draws a filled ellipse on the display device.
Bitmap.DrawEllipse (Color, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, Double) | Draws an ellipse filled with a specified color gradient.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawEllipse Method (Color, Int32, Int32, Int32, Int32)

Bitmap.DrawEllipse Method (Color, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Draws a filled ellipse on the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void DrawEllipse (
         Color colorOutline,
         int x,
         int y,
         int xRadius,
         int yRadius
)

Parameters

colorOutline
The outline color.
x
The x-coordinate location of the center of the ellipse.
y
The y-coordinate location of the center of the ellipse.
xRadius
The radius of the ellipse in the x-coordinate direction.
yRadius
The radius of the ellipse in the y-coordinate direction.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawEllipse Method

DrawingContext.DrawEllipse Method

Draws an ellipse on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawEllipse (
         Brush brush,
         Pen pen,
         int x,
         int y,
         int xRadius,
         int yRadius
)

Parameters

brush
The brush with which the ellipse is to be filled. This parameter is optional, and it can be a null value. If the value of brush is null, the ellipse is not filled.
pen
The pen with which the outline of the ellipse is to be drawn. This parameter is optional, and it can be a null value. If the value of pen is null, no outline is drawn.
x
The horizontal coordinate of the ellipse's center.
y
The vertical coordinate of the ellipse's center
xRadius
The horizontal radius of the ellipse.
yRadius
The vertical radius of the ellipse.

Expand image Remarks

The drawing is not visible if the values of both the pen and brush parameters are null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawEllipse Method (Color, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, Double)

Bitmap.DrawEllipse Method (Color, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, Double)
See Also
CollapseAll image

Draws an ellipse filled with a specified color gradient.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void DrawEllipse (
         Color colorOutline,
         int thicknessOutline,
         int x,
         int y,
         int xRadius,
         int yRadius,
         Color colorGradientStart,
         int xGradientStart,
         int yGradientStart,
         Color colorGradientEnd,
         int xGradientEnd,
         int yGradientEnd,
         double opacity
)

Parameters

colorOutline
The outline color.
thicknessOutline
The thickness of the ellipse's outline, in pixels.
x
The x-coordinate location of the center of the ellipse.
y
The y-coordinate location of the center of the ellipse.
xRadius
The radius of the ellipse in the x-coordinate direction.
yRadius
The radius of the ellipse in the y-coordinate direction.
colorGradientStart
The starting color of the color gradient.
xGradientStart
The x-coordinate location of the starting point of the color gradient.
yGradientStart
The y-coordinate location of the starting point of the color gradient.
colorGradientEnd
The ending color of the color gradient.
xGradientEnd
The x-coordinate location of the ending point of the color gradient.
yGradientEnd
The y-coordinate location of the ending point of the color gradient.
opacity
The opacity of the ellipse.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawImage Method (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32, UInt16)

Bitmap.DrawImage Method (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32, UInt16)
See Also
CollapseAll image

Draws a rectangular block of pixels with a specified degree of transparency.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void DrawImage (
         int xDst,
         int yDst,
         Bitmap bitmap,
         int xSrc,
         int ySrc,
         int width,
         int height,
         UInt16 opacity
)

Parameters

xDst
The x-coordinate location of the upper-left corner of the rectangular area on the display to which the specified pixels are to be copied.
yDst
The y-coordinate location of the upper-left corner of the rectangular area on the display to which the specified pixels are to be copied.
bitmap
The source bitmap.
xSrc
The x-coordinate location of the upper-left corner of the rectangular area in the source bitmap from which the specified pixels are to be copied.
ySrc
The x-coordinate location of the upper-left corner of the rectangular area in the source bitmap from which the specified pixels are to be copied.
width
The width of the rectangular block of pixels to be copied.
height
The height of the rectangular block of pixels to be copied.
opacity
The degree of opacity of the bitmap. A value of 0 (zero) makes the bitmap completely opaque (not transparent at all); a value of 255 makes the bitmap completely transparent.

Expand image Remarks

Passing negative values in the xSrc and ySrc parameters produces undefined results.

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

          Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
          Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
          // copy the bitmap
          bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
          // now you may modify the copy using any Bitmap method
          bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawImage Method (Bitmap, Int32, Int32, Int32, Int32, Int32, Int32)

DrawingContext.DrawImage Method (Bitmap, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Displays a cropped, bitmapped image on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawImage (
         Bitmap source,
         int destinationX,
         int destinationY,
         int sourceX,
         int sourceY,
         int sourceWidth,
         int sourceHeight
)

Parameters

source
A Bitmap object that represents the bitmapped image to be displayed.
destinationX
The horizontal coordinate at which the leftmost edge of the cropped image is to be placed.
destinationY
The vertical coordinate at which the topmost edge of the the cropped image is to be placed.
sourceX
The horizontal coordinate that is to become the leftmost edge of the cropped image.
sourceY
The vertical coordinate that is to become the topmost edge of the cropped image.
sourceWidth
The width of the cropped image.
sourceHeight
The height of the cropped image.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawImage Method (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32)

Bitmap.DrawImage Method (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Draws a rectangular block of pixels on the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void DrawImage (
         int xDst,
         int yDst,
         Bitmap bitmap,
         int xSrc,
         int ySrc,
         int width,
         int height
)

Parameters

xDst
The x-coordinate location of the upper-left corner of the rectangular area on the display to which the specified pixels are to be copied.
yDst
The y-coordinate location of the upper-left corner of the rectangular area on the display to which the specified pixels are to be copied.
bitmap
The source bitmap.
xSrc
The x-coordinate location of the upper-left corner of the rectangular area in the source bitmap from which the specified pixels are to be copied.
ySrc
The y-coordinate location of the upper-left corner of the rectangular area in the source bitmap from which the specified pixels are to be copied.
width
The width of the rectangular block of pixels to be copied.
height
The height of the rectangular block of pixels to be copied.

Expand image Remarks

Passing negative values in the xSrc and ySrc parameters produces undefined results.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

          Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
          Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
          // copy the bitmap
          bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
          // now you may modify the copy using any Bitmap method
          bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawImage Method (Bitmap, Int32, Int32)

DrawingContext.DrawImage Method (Bitmap, Int32, Int32)
See Also
CollapseAll image

Displays an uncropped, bitmapped image on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawImage (
         Bitmap source,
         int x,
         int y
)

Parameters

source
A Bitmap object that represents the bitmapped image to be displayed.
x
The horizontal coordinate at which the leftmost edge of the image is to be placed.
y
The vertical coordinate at which the topmost edge of the image is to be placed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawImage Method

Bitmap.DrawImage Method

Draws a rectangular block of pixels on the display device.

Expand image Overload List

Name | Description
Bitmap.DrawImage (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32) | Draws a rectangular block of pixels on the display device.
Bitmap.DrawImage (Int32, Int32, Bitmap, Int32, Int32, Int32, Int32, UInt16) | Draws a rectangular block of pixels with a specified degree of transparency.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawImage Method

DrawingContext.DrawImage Method

Displays a bitmapped image on the drawing surface.

Expand image Overload List

Name | Description
DrawingContext.DrawImage (Bitmap, Int32, Int32) | Displays an uncropped, bitmapped image on the drawing surface.
DrawingContext.DrawImage (Bitmap, Int32, Int32, Int32, Int32, Int32, Int32) | Displays a cropped, bitmapped image on the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


DrawingContext Class

DrawingContext Class
See Also Members
CollapseAll image

Provides constructors, methods, and properties you can use to generate a drawing surface and create images on that surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class DrawingContext : DispatcherObject

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


DrawingContext Members

DrawingContext Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the DrawingContext type.

Expand image Public Constructors

 | Name | Description
Public Method | DrawingContext | Overloaded. Initializes a new instance of the DrawingContext class.

Expand image Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmapped image that the current DrawingContext object uses as its drawing surface.
Public Property | Height | Gets the height of the current DrawingContext object's drawing surface.
Public Property | Width | Gets the width of the current DrawingContext object's drawing surface.

Expand image Public Methods

 | Name | Description
Public Method | BlendImage | Overlays a specified bitmapped image on an image that already exists on the drawing surface, and displays the resulting overlayed image at a specified location (position) on the drawing surface.
Public Method | Clear | Clears the drawing surface.
Public Method | DrawEllipse | Draws an ellipse on the drawing surface.
Public Method | DrawImage | Overloaded. Displays a bitmapped image on the drawing surface.
Public Method | DrawLine | Draws a line on the drawing surface.
Public Method | DrawPolygon | Draws a polygon on the drawing surface.
Public Method | DrawRectangle | Draws a rectangle on the drawing surface.
Public Method | DrawText | Overloaded. Draws text on the drawing surface.
Public Method | GetClippingRectangle | Retrieves the clipping rectangle of the current DrawingContext object.
Public Method | PopClippingRectangle | Pops the clipping rectangle that was most recently pushed onto the current DrawingContext object.
Public Method | PushClippingRectangle | Pushes the specified clipping rectangle onto the current DrawingContext object.
Public Method | SetPixel | Sets a single pixel to a color.
Public Method | Translate | Translates (moves) the most recently drawn image by the specified amount on the drawing surface.

Expand image See Also

Reference

DrawingContext Class
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawLine Method

Bitmap.DrawLine Method

Draws a line on the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void DrawLine (
         Color color,
         int thickness,
         int x0,
         int y0,
         int x1,
         int y1
)

Parameters

color
The color of the line.
thickness
The thickness of the line, in pixels.
x0
The x-coordinate location of the line's starting point.
y0
The y-coordinate location of the line's starting point.
x1
The x-coordinate location of the line's ending point.
y1
The y-coordinate location of the line's ending point.

Expand image Remarks

The thickness parameter is not currently available. For now, all lines are one pixel thick.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawLine Method

DrawingContext.DrawLine Method

Draws a line on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawLine (
         Pen pen,
         int x0,
         int y0,
         int x1,
         int y1
)

Parameters

pen
The pen with which the line is to be drawn.
x0
The horizontal coordinate of the line's starting point.
y0
The vertical coordinate of the line's starting point.
x1
The horizontal coordinate of the line's ending point.
y1
The vertical coordinate of the line's ending point.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


DrawingContext.DrawPolygon Method

DrawingContext.DrawPolygon Method

Draws a polygon on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawPolygon (
         Brush brush,
         Pen pen,
         int[] pts
)

Parameters

brush
The brush with which the polygon is to be filled. This parameter is optional, and it can be a null value. If the value of brush is null, the polygon is not filled.
pen
The pen with which the outline of the polygon is to be drawn. This parameter is optional, and it can be a null value. If the value of pen is null, no outline is drawn.
pts
An array of points that specify the vertices of the polygon.

Expand image Remarks

If the first and last points in the array are not identical, a line is drawn between them to close the polygon.

The pts array contains pairs of x,y values, where pts[0] is the first x value and pts[1] is the first y value. If there is an odd number of values in the pts array, this method ignores the last value.

The drawing is not visible if the values of both the pen and brush parameters are null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawRectangle Method

Bitmap.DrawRectangle Method

Draws a rectangle on the display device.

Expand image Overload List

Name | Description
Bitmap.DrawRectangle (Color, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, UInt16) | Draws a rectangle on the display device.
Bitmap.DrawRectangle (Int32, Int32, Int32, Int32) | Draws a rectangle defined by two coordinate (x,y) pairs.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawRectangle Method (Int32, Int32, Int32, Int32)

Bitmap.DrawRectangle Method (Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Draws a rectangle defined by two coordinate (x,y) pairs.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void DrawRectangle (
         int x1,
         int y1,
         int x2,
         int y2
)

Parameters

x1
The x-coordinate of the upper-left corner of the rectangle.
y1
The y-coordinate of the upper-left corner of the rectangle.
x2
The x-coordinate of the lower-right corner of the rectangle.
y2
The y-coordinate of the lower-right corner of the rectangle.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawRectangle Method

DrawingContext.DrawRectangle Method

Draws a rectangle on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawRectangle (
         Brush brush,
         Pen pen,
         int x,
         int y,
         int width,
         int height
)

Parameters

brush
The brush with which the rectangle is to be filled. This parameter is optional, and it can be a null value. If the value of brush is null, the rectangle is not filled.
pen
The pen with which the outline of the rectangle is to be drawn. This parameter is optional, and it can be a null value. If the value of pen is null, no outline is drawn.
x
The horizontal coordinate of the left edge of the rectangle.
y
The vertical coordinate of the top edge of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Expand image Remarks

The drawing is not visible if the values of both the pen and brush parameters are null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawRectangle Method (Color, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, UInt16)

Bitmap.DrawRectangle Method (Color, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Color, Int32, Int32, Color, Int32, Int32, UInt16)
See Also
CollapseAll image

Draws a rectangle on the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void DrawRectangle (
         Color colorOutline,
         int thicknessOutline,
         int x,
         int y,
         int width,
         int height,
         int xCornerRadius,
         int yCornerRadius,
         Color colorGradientStart,
         int xGradientStart,
         int yGradientStart,
         Color colorGradientEnd,
         int xGradientEnd,
         int yGradientEnd,
         UInt16 opacity
)

Parameters

colorOutline
The color of the rectangle's outline.
thicknessOutline
The thickness of the rectangle's outline, in pixels.
x
The x-coordinate of the rectangle's upper-left corner.
y
The y-coordinate of the rectangle's upper-left corner.
width
The width of the rectangle, in pixels.
height
The height of the rectangle, in pixels.
xCornerRadius
The x-coordinate value of the corner radius used to produce rounded corners on the rectangle.
yCornerRadius
The y-coordinate value of the corner radius used to produce rounded corners on the rectangle.
colorGradientStart
The starting color for a color gradient.
xGradientStart
Holds the x coordinate of the starting location of the color gradient.
yGradientStart
Holds the y coordinate of the starting location of the color gradient.
colorGradientEnd
Specifies the ending color of the color gradient.
xGradientEnd
Holds the x coordinate of the ending location of the color gradient.
yGradientEnd
Holds the y coordinate of the ending location of the color gradient.
opacity
Specifies the opacity of the fill color. Set to 0x00 for completely transparent. Set to 0xFF for completely opague.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

      Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
      Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
      // copy the bitmap
      bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
      // now you may modify the copy using any Bitmap method
      bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawText Method (String, Font, Color, Int32, Int32, Int32, Int32, TextAlignment, TextTrimming)

DrawingContext.DrawText Method (String, Font, Color, Int32, Int32, Int32, Int32, TextAlignment, TextTrimming)
See Also
CollapseAll image

Draws specified text within a bounding rectangular region on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool DrawText (
         ref string text,
         Font font,
         Color color,
         int x,
         int y,
         int width,
         int height,
         TextAlignment alignment,
         TextTrimming trimming
)

Parameters

text
The string that contains the text to be drawn.
font
The font to be applied to the specified text.
color
The color to be applied to the specified text.
x
The horizontal coordinate of the left edge of the rectangular region in which the specified text is to be drawn.
y
The vertical coordinate of the top edge of the rectangular region in which the specified text is to be drawn.
width
The width of the rectangular region in which the specified text is to be drawn.
height
The height of the rectangular region in which the specified text is to be drawn.
alignment
A value of the TextAlignment enumeration that specifies the edge with which the specified text is to be aligned.
trimming
A value of the TextTrimming enumeration that specifies how characters from a string that does not completely fit into the specified rectangular region are to be trimmed.

Return Value

true if the text fits within the specified bounds; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawText Method (String, Font, Color, Int32, Int32)

Bitmap.DrawText Method (String, Font, Color, Int32, Int32)
See Also
CollapseAll image

Draws text on the display device, using a specified font and color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void DrawText (
         string text,
         Font font,
         Color color,
         int x,
         int y
)

Parameters

text
The text to be drawn.
font
The font to be used for the text.
color
The color to be used for the text.
x
The x-coordinate of the location where text drawing is to begin.
y
The y-coordinate of the location where text drawing is to begin.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawText Method (String, Font, Color, Int32, Int32)

DrawingContext.DrawText Method (String, Font, Color, Int32, Int32)
See Also
CollapseAll image

Draws specified text on the drawing surface, beginning at a specified location (position).

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void DrawText (
         string text,
         Font font,
         Color color,
         int x,
         int y
)

Parameters

text
The string that contains the text to be drawn.
font
The font to be applied to the specified text.
color
The color to be applied to the specified text.
x
The horizontal coordinate at which the drawing of the specified text is to begin.
y
The vertical coordinate at which the drawing of the specified text is to begin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawText Method (String, Int32, Int32, Font)

Bitmap.DrawText Method (String, Int32, Int32, Font)
See Also
CollapseAll image

Draws text on the display device, using a specified font.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public int DrawText (
         string text,
         int xPos,
         int yPos,
         Font font
)

Parameters

text
The text to be drawn.
xPos
The x-coordinate of the location where text drawing is to begin.
yPos
The y-coordinate of the location where text drawing is to begin.
font
The font to be used for the text.

Return Value

The width of the text, in pixels.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawText Method

Bitmap.DrawText Method

Draws text on the display device.

Expand image Overload List

Name | Description
Bitmap.DrawText (String, Font, Color, Int32, Int32) | Draws text on the display device, using a specified font and color.
Bitmap.DrawText (String, Int32, Int32, Font) | Draws text on the display device, using a specified font.
Bitmap.DrawText (String, Int32, Int32, Font, Single) | Draws text on the display device, using a specified font and kerning.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawText Method (String, Int32, Int32, Font, Single)

Bitmap.DrawText Method (String, Int32, Int32, Font, Single)
See Also
CollapseAll image

Draws text on the display device, using a specified font and kerning.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public int DrawText (
         string text,
         int xPos,
         int yPos,
         Font font,
         float kerning
)

Parameters

text
The text to be drawn.
xPos
The x-coordinate of the location where text drawing is to begin.
yPos
The y-coordinate of location where text drawing is to begin.
font
The font to be used for the text.
kerning
The kerning to be used for the text, in pixels.

Return Value

The width of the text, in pixels.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.DrawText Method

DrawingContext.DrawText Method

Draws text on the drawing surface.

Expand image Overload List

Name | Description
DrawingContext.DrawText (String, Font, Color, Int32, Int32) | Draws specified text on the drawing surface, beginning at a specified location (position).
DrawingContext.DrawText (String, Font, Color, Int32, Int32, Int32, Int32, TextAlignment, TextTrimming) | Draws specified text within a bounding rectangular region on the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Font)

Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Font)
See Also
CollapseAll image

Draws text in a specified rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public bool DrawTextInRect (
         ref string text,
         ref int xRelStart,
         ref int yRelStart,
         int x,
         int y,
         int width,
         int height,
         UInt32 dtFlags,
         Font font
)

Parameters

text
The text to be drawn. This parameter contains the remaining text, or an empty string, if the complete text string did not fit in the specified rectangle.
xRelStart
The x-coordinate, relative to the rectangle, at which text drawing is to begin.
yRelStart
The y-coordinate, relative to the rectangle, at which text drawing is to begin.
x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
dtFlags
Flags that specify the format of the text.
font
The font to be used for the text.

Return Value

true if all of the specified text was drawn; false if this is not the case and the text parameter contains the remaining text that was not drawn.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, UInt32, Color, Font)

Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, UInt32, Color, Font)
See Also
CollapseAll image

Draws text in a specified rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public void DrawTextInRect (
         string text,
         int x,
         int y,
         int width,
         int height,
         UInt32 dtFlags,
         Color color,
         Font font
)

Parameters

text
The text to be drawn. This parameter contains the remaining text, or an empty string, if the complete text string did not fit in the specified rectangle.
x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
dtFlags
Flags that specify the format of the text.
color
The color to be used for the text.
font
The font to be used for the text.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Color, Font)

Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Color, Font)
See Also
CollapseAll image

Draws text in a specified rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool DrawTextInRect (
         ref string text,
         ref int xRelStart,
         ref int yRelStart,
         int x,
         int y,
         int width,
         int height,
         UInt32 dtFlags,
         Color color,
         Font font
)

Parameters

text
The text to be drawn. This parameter contains the remaining text, or an empty string, if the complete text string did not fit in the specified rectangle.
xRelStart
The x-coordinate, relative to the rectangle, at which text drawing is to begin.
yRelStart
The y-coordinate, relative to the rectangle, at which text drawing is to begin.
x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
dtFlags
Flags that specify the format of the text.
color
The color to be used for the text.
font
The font to be used for the text.

Return Value

true if all of the specified text was drawn; false if this is not the case and the text parameter contains the remaining text that was not drawn.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawTextInRect Method

Bitmap.DrawTextInRect Method

Draws text in a specified rectangle.

Expand image Overload List

Name | Description
Bitmap.DrawTextInRect (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Color, Font) | Draws text in a specified rectangle.
Bitmap.DrawTextInRect (String, Int32, Int32, Int32, Int32, Int32, Int32, UInt32, Font) | Draws text in a specified rectangle.
Bitmap.DrawTextInRect (String, Int32, Int32, Int32, Int32, UInt32, Color, Font) | Draws text in a specified rectangle.
Bitmap.DrawTextInRect (String, Int32, Int32, Int32, Int32, UInt32, Font) | Draws text in a specified rectangle.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, UInt32, Font)

Bitmap.DrawTextInRect Method (String, Int32, Int32, Int32, Int32, UInt32, Font)
See Also
CollapseAll image

Draws text in a specified rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void DrawTextInRect (
         string text,
         int x,
         int y,
         int width,
         int height,
         UInt32 dtFlags,
         Font font
)

Parameters

text
The text to be drawn. This parameter contains the remaining text, or an empty string, if the complete text string did not fit in the specified rectangle.
x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
dtFlags
Flags that specify the format of the text.
font
The font to be used for the text.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DSTDKGRAY Field

Bitmap.DSTDKGRAY Field

Fills the destination rectangle with a dark gray color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int DSTDKGRAY

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DSTGRAY Field

Bitmap.DSTGRAY Field

Fills the destination rectangle with a gray color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int DSTGRAY

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DSTINVERT Field

Bitmap.DSTINVERT Field

Inverts the destination rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int DSTINVERT

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.DSTLTGRAY Field

Bitmap.DSTLTGRAY Field

Fills the destination rectangle with a light gray color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int DSTLTGRAY

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Debug.DumpBuffer Method

Debug.DumpBuffer Method

Prints the data for a specified buffer to the standard output stream.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void DumpBuffer (
         byte[] buf,
         bool fCRC,
         bool fOffset
)

Parameters

buf
An array containing the bytes of buffer data.
fCRC
A Boolean value that specifies whether to compute and print the cyclic redundancy check (CRC) for each row of data.
fOffset
A Boolean value that specifies whether to print the memory offset address for each row of data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.DumpHeap Method

Debug.DumpHeap Method

Prints all available heap information to the standard output stream.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void DumpHeap ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.DumpPerfCounters Method

Debug.DumpPerfCounters Method

Prints performance counter information to the standard output stream.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void DumpPerfCounters ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


Debug.DumpStack Method

Debug.DumpStack Method

Prints all available stack information to the standard output stream.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void DumpStack ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


TimeSpan.Duration Method

TimeSpan.Duration Method

Returns a new TimeSpan object (time period) that has the absolute value of the current TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Duration ()

Return Value

A TimeSpan object that has the absolute value of the current TimeSpan object.

Expand image Remarks

The absolute value of a number is its numeric value without regard to its plus sign or minus sign. Therefore, a number's absolute value is always either positive or 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Math.E Field

Math.E Field

Represents the natural logarithmic base, specified by the constant e.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static double E

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
System Namespace


Bitmap.DT_Ellipsis Field

Bitmap.DT_Ellipsis Field

Specifies that the bitmap text is trimmed to the nearest character, and an ellipsis is inserted at the end of each trimmed line.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_Ellipsis

Expand image Remarks

You cannot use this field with the DT_TruncateAtBottom flag. Use it only with the Microsoft.SPOT.Bitmap.DrawTextInRect methods.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


EventArgs.Empty Property

EventArgs.Empty Property

Gets an empty, read-only EventArgs object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static EventArgs Empty { get; }

Property Value

An empty, read-only EventArgs object. This is equivalent to the result of calling the EventArgs constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventArgs Class
EventArgs Members
Microsoft.SPOT Namespace


String.Empty Field

String.Empty Field

Represents an empty instance of the String class. This field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Empty

Expand image Remarks

The value of this field is the zero-length string denoted by "".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


MFNetworkConfiguration.EnableDhcp Property

MFNetworkConfiguration.EnableDhcp Property

Indicates whether DHCP is enabled in the device configuration.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public bool EnableDhcp { get; set; }

Property Value

true if DHCP is enabled, or false if not.

Expand image Version Information

Available in MFDeploy 2.0 SP1


DaylightTime.End Property

DaylightTime.End Property

Gets the DateTime object that represents the date and time when daylight saving time ends for the local time zone.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime End { get; }

Property Value

The DateTime object that represents the date and time when daylight saving time ends for the local time zone. This return value is expressed in local time.

Expand image Remarks

When daylight saving time ends, the system clock is automatically reset to standard time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DaylightTime Class
DaylightTime Members
System.Globalization Namespace


LinearGradientBrush.EndColor Field

LinearGradientBrush.EndColor Field

Specifies the color at the end of the gradient path. This is the color at the point specified by the EndX and EndY fields.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color EndColor

Expand image Remarks

This field is a value of the Color enumeration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


TextRun.EndOfLine Property

TextRun.EndOfLine Property

Gets a text run that is marked as an end-of-line.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static TextRun EndOfLine { get; }

Property Value

A text run that is marked as an end-of-line.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


LinearGradientBrush.EndX Field

LinearGradientBrush.EndX Field

The horizontal coordinate (relative to the left edge of the area being painted) of the ending point of the gradient path. The default value is 1, which is the right edge of the area.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int EndX

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


LinearGradientBrush.EndY Field

LinearGradientBrush.EndY Field

The vertical coordinate (relative to the top edge of the area being painted) of the ending point of the gradient path. The default value is 1, which is the bottom edge of the area.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int EndY

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


Monitor.Enter Method

Monitor.Enter Method

Acquires an exclusive lock on a specified object.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Enter (
         Object obj
)

Parameters

obj
The object on which to acquire the monitor lock.

Expand image Remarks

Use the Enter method to acquire the specified Monitor object or the object passed as the parameter. If another thread has executed the Enter method on the same object but has not yet executed the corresponding Exit method, the current thread will be blocked until the other thread releases the object. It is legal for the same thread to invoke Enter more than once without it blocking. Note, however, that an equal number of Exit calls must be invoked before other threads waiting on the object will be unblocked.

Use the Monitor class to lock objects (reference types), not value types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Monitor Class
Monitor Members
System.Threading Namespace


UIElementCollection.Enumerator Structure

UIElementCollection.Enumerator Structure

Enumerates the UIElement objects that are contained in a particular UIElementCollection object.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public struct UIElementCollection.Enumerator : IEnumerator, IDisposable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection.Enumerator Members
Microsoft.SPOT.Presentation Namespace


UIElementCollection.Enumerator Members

UIElementCollection.Enumerator Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the UIElementCollection.Enumerator type.

Expand image Public Properties

 | Name | Description
Public Property | Current | Gets the current UI element in the current collection.

Expand image Public Methods

 | Name | Description
Public Method | Clone | Creates a shallow copy of the current UIElementCollection.Enumerator object (enumerator).
Public Method | MoveNext | Advances the enumerator to the next element in the current collection.
Public Method | Reset | Resets the enumerator to its initial position, immediately preceding the first element in the collection.

Expand image See Also

Reference

UIElementCollection.Enumerator Structure
Microsoft.SPOT.Presentation Namespace


Double.Epsilon Field

Double.Epsilon Field

Represents the smallest possible Double greater than zero. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const double Epsilon

Expand image Remarks

The value of this constant is 4.94066e-324.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


MulticastDelegate.op_Equality Method

MulticastDelegate.op_Equality Method

Determines whether the current multicast delegate and another specified delegate are equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Equality (
         MulticastDelegate d1,
         MulticastDelegate d2
)

Parameters

d1
The first delegate you want to compare.
d2
The second delegate you want to compare.

Return Value

true if the d1 and d2 parameters contain the same invocation lists; otherwise, false.

Expand image Remarks

Two delegates with the same methods, the same targets, and the same invocation lists are considered equal, even if they are not both multicast (combinable) or both singlecast (uncombinable).

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method used on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method used on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered equal and the targets are also not considered equal.

Two invocation lists are considered identical if they have the same order and the corresponding elements from the two lists represent the same method and target.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MulticastDelegate Class
MulticastDelegate Members
System Namespace


DateTime.operator == Method

DateTime.operator == Method

Determines whether two specified DateTime objects have the same date/time value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator == (
         DateTime d1,
         DateTime d2
)

Parameters

d1
The first DateTime object whose date/time value you want to compare.
d2
The first DateTime object whose date/time value you want to compare.

Return Value

true if the d1 and d2 parameters specify the same date and time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Delegate.op_Equality Method

Delegate.op_Equality Method

Determines whether the specified delegates are equal to one another.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Equality (
         Delegate d1,
         Delegate d2
)

Parameters

d1
The first delegate you want to compare.
d2
The second delegate you want to compare.

Return Value

true if d1 is equal to d2; otherwise, false.

Expand image Remarks

Two delegates with the same methods, the same targets, and the same invocation lists are considered equal, even if they are not both multicast (combinable) or both singlecast (uncombinable).

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method used on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method used on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered equal and the targets are also not considered equal.

Two invocation lists are considered identical if they have the same order and the corresponding elements from the two lists represent the same method and target.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


String.op_Equality Method

String.op_Equality Method

Determines whether two specified String objects have the same value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Equality (
         string a,
         string b
)

Parameters

a
A String object or a null reference.
b
A String object or a null reference.

Return Value

true if the value of a is the same as the value of b; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


TimeSpan.operator == Method

TimeSpan.operator == Method

Determines whether two specified TimeSpan objects (time periods) are equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator == (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that specifies a period of time.
t2
A TimeSpan object that specifies a period of time.

Return Value

true if the t1 and t2 parameters specify the same period of time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.Equals Method (DateTime, DateTime)

DateTime.Equals Method (DateTime, DateTime)
See Also
CollapseAll image

Determines whether two specified DateTime objects have the same date/time value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool Equals (
         DateTime t1,
         DateTime t2
)

Parameters

t1
The first DateTime object whose date/time value you want to compare.
t2
The second DateTime object whose date/time value you want to compare.

Return Value

true if the t1 and t2 parameters specify the same date and time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.Equals Method (TimeSpan, TimeSpan)

TimeSpan.Equals Method (TimeSpan, TimeSpan)
See Also
CollapseAll image

Determines whether two specified TimeSpan objects (time periods) are equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool Equals (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that specifies a period of time.
t2
A TimeSpan object that specifies a period of time.

Return Value

true if the t1 and t2 parameters specify the same period of time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


String.Equals Method

String.Equals Method

Determines whether two specified String objects have the same value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool Equals (
         string a,
         string b
)

Parameters

a
A String object or a null reference.
b
A String object or a null reference.

Return Value

true if the value of a is the same as the value of b; otherwise, false.

Expand image Remarks

This method performs an ordinal (case-sensitive and culture-insensitive) comparison.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Object.Equals Method (Object, Object)

Object.Equals Method (Object, Object)
See Also
CollapseAll image

Determines whether two specified instances (objects) of the Object class are equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool Equals (
         Object objA,
         Object objB
)

Parameters

objA
The first object you want to compare.
objB
The second object you want to compare.

Return Value

true if the objA and objB parameters are identical or are both null references; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


Delegate.Equals Method

Delegate.Equals Method

Determines whether the specified object and the current singlecast (uncombinable) delegate share the same target, method, and invocation list.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public override bool Equals (
         Object obj
)

Parameters

obj
The object you want to compare with the current singlecast (uncombinable) delegate.

Return Value

true if the specified object and the current delegate have the same target, method, and invocation list; otherwise, false.

Expand image Remarks

This method applies only if the current delegate is singlecast (uncombinable).

Two delegates with the same methods, the same targets, and the same invocation lists are considered equal, even if they are not both multicast (combinable) or both singlecast (uncombinable).

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method used on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method used on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered equal and the targets are also not considered equal.

Two invocation lists are considered identical only if they have the same order as one another and the corresponding elements from the two lists represent the same method and target.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


Object.Equals Method (Object)

Object.Equals Method (Object)
See Also
CollapseAll image

Determines whether a specified instance (object) of the Object class is equal to the current object of that class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual bool Equals (
         Object obj
)

Parameters

obj
The object you want to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


ValueType.Equals Method

ValueType.Equals Method

Indicates whether the current ValueType object and a specified Object object are equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public override bool Equals (
         Object obj
)

Parameters

obj
The object you want to compare with the current object.

Return Value

true if the current object and the specified object are the same type and represent the same value (indicated by the obj parameter); otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ValueType Class
ValueType Members
System Namespace


DateTime.Equals Method (Object)

DateTime.Equals Method (Object)
See Also
CollapseAll image

Determines whether the specified DateTime object is equal to the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override bool Equals (
         Object val
)

Parameters

val
A specific date and time.

Return Value

true if the val parameter is the same for the specified DateTime object and the current DateTime object; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.Equals Method

DateTime.Equals Method

Determines whether two DateTime objects have identical values.

Expand image Overload List

Name | Description
DateTime.Equals (DateTime, DateTime) | Determines whether two specified DateTime objects have the same date/time value.
DateTime.Equals (Object) | Determines whether the specified DateTime object is equal to the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Object.Equals Method

Object.Equals Method

Determines whether two instances (objects) of the Object class are equal.

Expand image Overload List

Name | Description
Object.Equals (Object) | Determines whether a specified instance (object) of the Object class is equal to the current object of that class.
Object.Equals (Object, Object) | Determines whether two specified instances (objects) of the Object class are equal.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


TimeSpan.Equals Method (Object)

TimeSpan.Equals Method (Object)
See Also
CollapseAll image

Determines whether the specified time-period object is equal to the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override bool Equals (
         Object value
)

Parameters

value
An object that specifies a period of time.

Return Value

true if the time-period object represented by the value parameter and the current TimeSpan object specify the same period of time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.Equals Method

TimeSpan.Equals Method

Determines whether two objects that specify time periods are equal.

Expand image Overload List

Name | Description
TimeSpan.Equals (Object) | Determines whether the specified time-period object is equal to the current TimeSpan object (time period).
TimeSpan.Equals (TimeSpan, TimeSpan) | Determines whether two specified TimeSpan objects (time periods) are equal.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Logging.Erase Method

Logging.Erase Method

Erases all Logging objects (log records).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Erase ()

Expand image Remarks

The use of this class is currently not supported and is not recommended.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Logging Class
Logging Members
Microsoft.SPOT Namespace


EventArgs Class

EventArgs Class
See Also Members
CollapseAll image

Constitutes the base class for classes that contain event data.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class EventArgs

Expand image Remarks

This class contains no event data; it is used by events that do not pass state information to an event handler when an event is raised. If the event handler requires state information, the application must derive a class from this class to hold the data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventArgs Members
Microsoft.SPOT Namespace


EventArgs Members

EventArgs Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the EventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | EventArgs | Initializes a new instance of the EventArgs class.

Expand image Public Properties

Name | Description
Empty | Gets an empty, read-only EventArgs object.

Expand image See Also

Reference

EventArgs Class
Microsoft.SPOT Namespace


EventHandler Delegate

EventHandler Delegate

Provides a method that handles events that have no event data.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void EventHandler (
         Object sender,
         EventArgs e
)

Parameters

sender
The sender (source) of the event.
e
A parameter that contains no event data.

Expand image Remarks

The standard signature of an event handler delegate defines a method that does not return a value, whose first parameter is an Object object referring to the instance that raises the event, and whose second parameter is an EventArgs object that holds the event data. If the event does not generate event data, the second parameter is an empty EventArgs object. Note that the EventHandler delegate is a predefined delegate that specifically represents an event handler method for an event that does not generate data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


EventHandlersStore Class

EventHandlersStore Class
See Also Members
CollapseAll image

Provides a container for event handlers.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public class EventHandlersStore

Expand image Remarks

Each EventHandlersStore object contains a hash table of event handlers for routed events.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventHandlersStore Members
Microsoft.SPOT Namespace


EventHandlersStore Members

EventHandlersStore Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the EventHandlersStore type.

Expand image Public Constructors

 | Name | Description
Public Method | EventHandlersStore | Initializes a new instance of the EventHandlersStore class.

Expand image Public Methods

 | Name | Description
Public Method | AddRoutedEventHandler | Adds a specified routed event handler for a specified RoutedEvent object to the collection of events in the current EventHandlersStore object.

Expand image See Also

Reference

EventHandlersStore Class
Microsoft.SPOT Namespace


EventRoute Class

EventRoute Class
See Also Members
CollapseAll image

Provides a container for a route to be followed by a routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class EventRoute

Expand image Remarks

This class corresponds to a valid routed event, and it contains an ordered list of information pairs that provide the event route. Each pair in the list consists of the target object and a list of handlers for the event. The EventRoute class supports the addition of new entries to the list; it also enables the handlers in the list to be invoked.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

EventRoute Members
Microsoft.SPOT Namespace


EventRoute Members

EventRoute Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the EventRoute type.

Expand image Public Constructors

 | Name | Description
Public Method | EventRoute | Initializes a new instance of the EventRoute class.

Expand image Public Methods

 | Name | Description
Public Method | Add | Adds a specified handler for a specified target to the event route.

Expand image See Also

Reference

EventRoute Class
Microsoft.SPOT Namespace


Exception Class

Exception Class
See Also Members
CollapseAll image

The exception that is thrown when errors occur during application execution.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class Exception

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Members
System Namespace


Exception Members

Exception Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Exception type.

Expand image Public Constructors

 | Name | Description
Public Method | Exception | Overloaded. Initializes a new instance of the Exception class.

Expand image Protected Fields

 | Name | Description
Protected Field | m_HResult | Contains a coded numeric value that is assigned to a specific exception.

Expand image Public Properties

 | Name | Description
Public Property | InnerException | Gets the Exception instance that caused the current exception.
Public Property | Message | Gets a message that describes the current exception.
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time when the current exception was thrown.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Creates and returns a string representation of the current exception.

Expand image See Also

Reference

Exception Class
System Namespace


Interlocked.Exchange Method

Interlocked.Exchange Method

Sets a 32-bit signed integer to a specified value as an atomic operation, and then returns the original value.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Exchange (
         ref int location1,
         int value
)

Parameters

location1
The variable to be set to the specified value.
value
The value to which the location1 parameter is set.

Return Value

The original value of the location1 parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Interlocked Class
Interlocked Members
System.Threading Namespace


ExecutionConstraint Class

ExecutionConstraint Class
See Also Members
CollapseAll image

Provides a method you can use to require a thread to complete an operation within specific constraints.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public sealed class ExecutionConstraint

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExecutionConstraint Members
Microsoft.SPOT Namespace


ExecutionConstraint Members

ExecutionConstraint Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the ExecutionConstraint type.

Expand image Public Methods

Name | Description
Install | Creates a subthread within the calling thread, containing a constraint that requires the calling thread to complete an operation within a specified time period and at a specified priority level.

Expand image See Also

Reference

ExecutionConstraint Class
Microsoft.SPOT Namespace


Application.Exit Event

Application.Exit Event

Occurs just before an application exits.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler Exit

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Monitor.Exit Method

Monitor.Exit Method

Releases an exclusive lock on a specified object.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Exit (
         Object obj
)

Parameters

obj
The object whose lock you want to release.

Expand image Remarks

Use the Enter method to acquire the specified Monitor object or the object passed as the parameter. If another thread has executed the Enter method on the same object but has not yet executed the corresponding Exit method, the current thread will be blocked until the other thread releases the object. It is legal for the same thread to invoke Enter more than once without it blocking. Note, however, that an equal number of Exit calls must be invoked before other threads waiting on the object will be unblocked.

Use the Monitor class to lock objects (reference types), not value types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Monitor Class
Monitor Members
System.Threading Namespace


ExtendedTimer Class

ExtendedTimer Class
See Also Members
CollapseAll image

Provides a mechanism for executing methods at specified intervals or on specific events.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public sealed class ExtendedTimer : IDisposable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Members
Microsoft.SPOT Namespace


ExtendedTimer Members

ExtendedTimer Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the ExtendedTimer type.

Expand image Public Constructors

 | Name | Description
Public Method | ExtendedTimer | Overloaded. Initializes a new instance of the ExtendedTimer class.

Expand image Public Properties

 | Name | Description
Public Property | LastExpiration | Gets the System.TimeSpan value of the last expiration of the current timer.

Expand image Public Methods

 | Name | Description
Public Method | Change | Overloaded. Changes the start time and the interval between method invocations for a timer.
Public Method | Dispose | Releases all resources used by the current instance of the ExtendedTimer class.

Expand image See Also

Reference

ExtendedTimer Class
Microsoft.SPOT Namespace


ExtendedTimeZone Class

ExtendedTimeZone Class
See Also Members
CollapseAll image

Represents a time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class ExtendedTimeZone : TimeZone

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Members
Microsoft.SPOT Namespace


ExtendedTimeZone Members

ExtendedTimeZone Members
See Also Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the ExtendedTimeZone type.

Expand image Public Fields

Name | Description
c_TicksTo20030101 | Specifies the number of clock ticks equal to the DateTime value of 2003/01/01 00:00:00.

Expand image Public Properties

 | Name | Description
Public Property | DaylightName | Gets the daylight saving time name for a particular time zone.
Public Property | StandardName | Gets the standard name for a particular time zone.
Public Property | TimeZoneId | Gets the ID of a particular time zone.

Expand image Public Methods

 | Name | Description
Public Method | GetDaylightChanges | Finds the daylight saving time period for a specified year.
 | GetTimeZone | Returns a time zone for a specified time zone ID.
Public Method | GetUtcOffset | Finds the coordinated universal time (UTC) offset for the specified local time.
 | SetTimeOffset | Sets the time offset.
 | SetTimeZone | Sets the time zone.
 | SetTimeZoneInfo | Sets the extended information for a particular time zone.
 | SynchronizeWithNetworkTime | Synchronizes the device system time with the network time, if the device system currently has a network connection.

Expand image See Also

Reference

ExtendedTimeZone Class
Microsoft.SPOT Namespace


ExtendedWeakReference Class

ExtendedWeakReference Class
See Also Members
CollapseAll image

Represents an extended weak reference, which references an object but still leaves it prone to garbage collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class ExtendedWeakReference : WeakReference

Expand image Remarks

When the object referred to by the extended weak references has no live references to it, it will be stored in a serialized format. Thus, the target of an ExtendedWeakRefernence object must be serializable. You use a selector and an identifier to identify a group of one or more weak references. The selector should be a type known only to the user of the ExtendedWeakReference object. Note that you can use the same selector with multiple IDs to create groups of ExtendedWeakReference objects.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Members
Microsoft.SPOT Namespace


ExtendedWeakReference Members

ExtendedWeakReference Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the ExtendedWeakReference type.

Expand image Public Constructors

 | Name | Description
Public Method | ExtendedWeakReference | Initializes a new instance of the ExtendedWeakReference class, referencing a specified object.

Expand image Public Fields

Name | Description
c_SurviveBoot | Contains a flag specifying that the current weak reference will be recoverable after the device reboots.
c_SurvivePowerdown | Contains a flag specifying that the current weak reference will be recoverable after the device powers down and restarts.

Expand image Public Properties

 | Name | Description
Public Property | Flags | Gets the flags specifying the states from which the current weak reference should be recoverable.
Public Property | Id | Gets the ID associated with the current ExtendedWeakReference object.
Public Property | Priority | Gets or sets the priority level for the current ExtendedWeakReference object.
Public Property | Selector | Gets the selector for the current ExtendedWeakReference object.

Expand image Public Methods

 | Name | Description
Public Method | PushBackIntoRecoverList | Flags an ExtendedWeakReference object as a candidate for recovery after the device reboots or powers down and restarts.
 | Recover | Recovers a specific ExtendedWeakReference object.
 | RecoverOrCreate | Attempts to recover a specific ExtendedWeakReference object, and creates a new instance of this class if the recovery attempt fails.

Expand image See Also

Reference

ExtendedWeakReference Class
Microsoft.SPOT Namespace


ListBox.ExtentHeight Property

ListBox.ExtentHeight Property

Gets the height of a control's display area, in pixels.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ExtentHeight { get; }

Property Value

The height of the control's display area, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.ExtentHeight Property

ScrollViewer.ExtentHeight Property

Gets the height of the extent for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ExtentHeight { get; }

Property Value

The height of the extent. The default value for this property is 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox.ExtentWidth Property

ListBox.ExtentWidth Property

Gets the width of a control's display area, in pixels.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ExtentWidth { get; }

Property Value

The width of the control's display area, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.ExtentWidth Property

ScrollViewer.ExtentWidth Property

Gets the width of the extent for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int ExtentWidth { get; }

Property Value

The width of the extent. The default value for this property is 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


Font.ExternalLeading Property

Font.ExternalLeading Property

Gets the external leading measurement for the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int ExternalLeading { get; }

Property Value

The external leading measurement for the current font, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


Boolean.FalseString Field

Boolean.FalseString Field

Represents the Boolean value false as a string. This field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static readonly bool FalseString

Expand image Remarks

This field is equal to the string "False".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Boolean Structure
Boolean Members
System Namespace


FieldInfo Class

FieldInfo Class
See Also Members
CollapseAll image

Discovers the attributes of a specific field and provides access to field metadata.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class FieldInfo : MemberInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Members
System.Reflection Namespace


FieldInfo Members

FieldInfo Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the FieldInfo type.

Expand image Protected Constructors

 | Name | Description
Protected Method | FieldInfo | Initializes a new instance of the FieldInfo class.

Expand image Public Properties

 | Name | Description
Public Property | FieldType | Gets the type of the current FieldInfo object.
Public Property | MemberType | Gets the type of property reflected by the current FieldInfo object.

Expand image Public Methods

 | Name | Description
Public Method | GetValue | When overridden in a derived class, this method returns the value of a field supported by a specified object.
Public Method | SetValue | Sets the value of a field supported by a specified object.

Expand image See Also

Reference

FieldInfo Class
System.Reflection Namespace


FieldNoReflectionAttribute Class

FieldNoReflectionAttribute Class
See Also Members
CollapseAll image

Sets a field such that there can be no reflection it.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class FieldNoReflectionAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldNoReflectionAttribute Members
Microsoft.SPOT Namespace


FieldNoReflectionAttribute Members

FieldNoReflectionAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the FieldNoReflectionAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | FieldNoReflectionAttribute | Constructs a FieldNoReflectionAttribute object.

Expand image See Also

Reference

FieldNoReflectionAttribute Class
Microsoft.SPOT Namespace


FieldInfo.FieldType Property

FieldInfo.FieldType Property

Gets the type of the current FieldInfo object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type FieldType { get; }

Property Value

The type of the current FieldInfo object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Class
FieldInfo Members
System.Reflection Namespace


Object.Finalize Method

Object.Finalize Method

Enables an instance (object) of the Object class to attempt to free resources and perform other cleanup operations before it is reclaimed by garbage collection.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
protected virtual void Finalize ()

Expand image Remarks

The Finalize method is protected and is therefore accessible only through the Object class or a class derived from Object.

The Finalize method is automatically called after an object becomes inaccessible, unless the object has been exempted from finalization by a call to the SuppressFinalize method. During the shutdown of an application domain, Finalize is automatically called on objects that are not exempt from finalization, even those that are still accessible. Note that Finalize is automatically called only once on a given object, unless the object is reregistered (such as by using the ReRegisterForFinalize method) and the SuppressFinalize method has not been subsequently called.

Every implementation of the Finalize method in a derived type must call its base type's implementation of Finalize. This is the only scenario in which application code is able to call Finalize.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


AssemblyFlagsAttribute.Flags Property

AssemblyFlagsAttribute.Flags Property

Gets a value that represents the type of side-by-side execution that is supported for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[CLSCompliantAttribute]
public UInt32 Flags { get; }

Property Value

A value that represents the type of side-by-side execution that is supported for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyFlagsAttribute Class
AssemblyFlagsAttribute Members
System.Reflection Namespace


ExtendedWeakReference.Flags Property

ExtendedWeakReference.Flags Property

Gets the flags specifying the states from which the current weak reference should be recoverable.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt32 Flags { get; }

Property Value

The recovery flags for the current weak reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo.m_flags Field

Reflection.AssemblyInfo.m_flags Field

Contains flags that describe the current assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt32 m_flags

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


SerializationHintsAttribute.Flags Field

SerializationHintsAttribute.Flags Field

Contains flags that describe the serialization of the current object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public SerializationFlags Flags

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Class
SerializationHintsAttribute Members
Microsoft.SPOT Namespace


FlagsAttribute Class

FlagsAttribute Class
See Also Members
CollapseAll image

Indicates that an enumeration can be treated as a bit field (a set of flags).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public class FlagsAttribute : Attribute

Expand image Remarks

In general, you use bit fields for lists of elements that might occur in combination, whereas generally you use enumeration constants for lists of mutually exclusive elements. For this reason, bit fields are designed such that you can combine elements with a bitwise OR operation to generate unnamed values; you cannot do this with enumerated constants.

Note that different programming languages vary in their use of bit fields and enumeration constants.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FlagsAttribute Members
System Namespace


FlagsAttribute Members

FlagsAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the FlagsAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | FlagsAttribute | Initializes a new instance of the FlagsAttribute class.

Expand image See Also

Reference

FlagsAttribute Class
System Namespace


Bitmap.Flush Method ()

Bitmap.Flush Method ()
See Also
CollapseAll image

Flushes the current bitmap to the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Flush ()

Expand image Remarks

The bitmap must have the same dimensions as the display device.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.Flush Method

Bitmap.Flush Method

Flushes the current bitmap to the display device.

Expand image Overload List

Name | Description
Bitmap.Flush () | Flushes the current bitmap to the display device.
Bitmap.Flush (Int32, Int32, Int32, Int32) | Flushes the current bitmap to the display device.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.Flush Method (Int32, Int32, Int32, Int32)

Bitmap.Flush Method (Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Flushes the current bitmap to the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Flush (
         int x,
         int y,
         int width,
         int height
)

Parameters

x
The x-coordinate of the bitmap's upper-left corner.
y
The y-coordinate of the bitmap's upper-left corner.
width
The width of the bitmap.
height
The height of the bitmap.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ButtonDevice.Focus Method

ButtonDevice.Focus Method

Moves the focus for a button device to the specified display element.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement Focus (
         UIElement focus
)

Parameters

focus
A UIElement object specifying the display element to which you want to move the button focus.

Return Value

A UIElement object specifying the display element that currently has the button focus.

Expand image Remarks

Button focus refers to the state of the element that is currently receiving input from a button device. At any specific point in time, there can be only one element on a button device's display that has the button focus. In Windows Presentation Foundation (WPF), the button device element with the current button focus has its UIElement.IsFocused Property property set to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


Buttons.Focus Method

Buttons.Focus Method

Moves the button focus to a specified display element.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static UIElement Focus (
         UIElement element
)

Parameters

element
A UIElement object specifying the display element to which you want to move the button focus.

Return Value

A UIElement object specifying the display element that currently has the button focus.

Expand image Remarks

Button focus refers to state of the display element that is currently receiving input from a button device. At any specific point in time, there can be only one element on a button device's display that has the button focus. In Windows Presentation Foundation (WPF), the display element with the current button focus has its UIElement.IsFocused Property property set to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


FocusChangedEventArgs Class

FocusChangedEventArgs Class
See Also Members
CollapseAll image

Provides data for an event that occurs when an input device's button focus moves to a different display element.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class FocusChangedEventArgs : InputEventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FocusChangedEventArgs Members
Microsoft.SPOT.Input Namespace


FocusChangedEventArgs Members

FocusChangedEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the FocusChangedEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | FocusChangedEventArgs | Initializes a new instance of the FocusChangedEventArgs class, using specified values.

Expand image Public Fields

 | Name | Description
Public Field | NewFocus | Specifies the display element that currently has the button focus.
Public Field | OldFocus | Specifies the display element that last had the button focus.

Expand image See Also

Reference

FocusChangedEventArgs Class
Microsoft.SPOT.Input Namespace


FocusChangedEventHandler Delegate

FocusChangedEventHandler Delegate

Represents the method that handles an event that occurs when the focus changes.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void FocusChangedEventHandler (
         Object sender,
         FocusChangedEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


Buttons.FocusedElement Property

Buttons.FocusedElement Property

Gets the display element that currently has the button focus.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static UIElement FocusedElement { get; }

Property Value

A UIElement object specifying the display element that currently has the button focus.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


Control._font Field

Control._font Field

Specifies the current font used for text in a control.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected internal Font _font

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Text._font Field

Text._font Field

Specifies the font to be used for the text in the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected Font _font

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


Control.Font Property

Control.Font Property

Gets or sets a control's font.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Font Font { get; set; }

Property Value

The font used by the control to write text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Font Class

Font Class
See Also Members
CollapseAll image

Defines a particular format for text, including font choice, font size, and style attributes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public sealed class Font : MarshalByRefObject

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Members
Microsoft.SPOT Namespace
TFConvert


Font Members

Font Members
See Also Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Font type.

Expand image Public Fields

Name | Description
DefaultKerning | Contains the default kerning for a particular font.

Expand image Public Properties

 | Name | Description
Public Property | Ascent | Gets the ascent measurement for the current font, in pixels.
Public Property | AverageWidth | Gets the average width of the characters in the current font, in pixels.
Public Property | Descent | Gets the descent measurement for the current font, in pixels.
Public Property | ExternalLeading | Gets the external leading measurement for the current font, in pixels.
Public Property | Height | Gets the height of the current font, in pixels.
Public Property | InternalLeading | Gets the internal leading measurement for the current font, in pixels.
Public Property | MaxWidth | Gets the width of the widest character in the current font, in pixels.

Expand image Public Methods

 | Name | Description
Public Method | CharWidth | Gets the width of the specified character, in pixels.
Public Method | ComputeExtent | Overloaded. Computes the width and height of a specified line of text.
Public Method | ComputeTextInRect | Overloaded. Computes the size of the rectangular area on the display device needed to render the specified text string.

Expand image See Also

Reference

Font Class
Microsoft.SPOT Namespace


Text.Font Property

Text.Font Property

Gets or sets the font for the text in the current Text object .

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Font Font { get; set; }

Property Value

The font to be used for the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRun.Font Field

TextRun.Font Field

Specifies the font for the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Font Font

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


Text.ForeColor Property

Text.ForeColor Property

Gets or sets the foreground color for the text in the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color ForeColor { get; set; }

Property Value

The foreground color for the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRun.ForeColor Field

TextRun.ForeColor Field

Specifies the foreground color for the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color ForeColor

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


Control._foreground Field

Control._foreground Field

Contains the brush used to paint a control's foreground.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected internal Brush _foreground

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Control.Foreground Property

Control.Foreground Property

Gets or sets the brush used to paint a control's foreground.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Brush Foreground { get; set; }

Property Value

The brush used to paint the control's foreground.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


ICustomFormatter.Format Method

ICustomFormatter.Format Method

Converts the value of a specified object to an equivalent string representation, using a specified format and culture-specific formatting information.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Format (
         string format,
         Object arg,
         IFormatProvider formatProvider
)

Parameters

format
A format string containing formatting specifications.
arg
An object you want to format.
formatProvider
An IFormatProvider object that supplies format information about the current object.

Return Value

Returns the string representation of the value of the arg parameter, formatted as specified by the format and formatProvider parameters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICustomFormatter Interface
ICustomFormatter Members
System Namespace


AppDomain.FriendlyName Property

AppDomain.FriendlyName Property

Gets the "friendly" name of the current application domain.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string FriendlyName { get; }

Property Value

The friendly name of the current application domain.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


Dispatcher.FromThread Method

Dispatcher.FromThread Method

Gets the Dispatcher object (dispatcher) for a specified thread.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static Dispatcher FromThread (
         Thread thread
)

Parameters

thread
The thread from which the dispatcher is to be obtained.

Return Value

The dispatcher for the specified thread.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


TimeSpan.FromTicks Method

TimeSpan.FromTicks Method

Returns a TimeSpan object (time period) that is equivalent to a specified number of ticks.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeSpan FromTicks (
         long val
)

Parameters

val
A number of ticks that specifies a time.

Return Value

A TimeSpan object that is equivalent to the specified number of ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTimeFormatInfo.FullDateTimePattern Property

DateTimeFormatInfo.FullDateTimePattern Property

Gets the format pattern for a long date and long time value, which is associated with the "F" format character.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string FullDateTimePattern { get; }

Property Value

The format pattern for a long date and long time value, which is associated with the "F" format character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


Assembly.FullName Property

Assembly.FullName Property

Gets the full name, or display name, of the current assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string FullName { get; }

Property Value

The full name of the current assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Type.FullName Property

Type.FullName Property

Gets the fully qualified type name of the class that declares the current member.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract string FullName { get; }

Property Value

The Type object for the class that declares the current member as a fully qualified name. If the type is a nested type, this property returns the enclosing type.

Expand image Remarks

This property implements the abstract property inherited from the MemberInfo class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


MFNetworkConfiguration.Gateway Property

MFNetworkConfiguration.Gateway Property

Gets or sets the device's gateway address.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress Gateway { get; set; }

Property Value

The IP address of the network gateway.

Expand image Version Information

Available in MFDeploy 2.0 SP1


Debug.GC Method

Debug.GC Method

Runs garbage collection, a service that automatically reclaims unused computer memory.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static UInt32 GC (
         bool force
)

Parameters

force
A Boolean value that specifies whether garbage collection should be forced.

Return Value

The amount of free (unused) memory, in bytes.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


GC Class

GC Class
See Also Members
CollapseAll image

Controls the system garbage collector, a service that automatically reclaims unused computer memory.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class GC

Expand image Remarks

The methods in this class influence when an object is reclaimed by the system garbage collector and when resources allocated by an object are released.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

GC Members
System Namespace


GC Members

GC Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the GC type.

Expand image Public Methods

Name | Description
ReRegisterForFinalize | Requests that the system call the finalizer method for a specified object, after the SuppressFinalize method has been called for this object.
SuppressFinalize | Requests that the system not call the finalizer method for a specified object.
WaitForPendingFinalizers | Suspends the current thread until the thread processing the queue of finalizers has emptied that queue.

Expand image See Also

Reference

GC Class
System Namespace


AppDomain.GetAssemblies Method

AppDomain.GetAssemblies Method

Gets the assemblies that have been loaded into the current application domain.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Assembly [] GetAssemblies ()

Return Value

An array of assemblies in the current application domain.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


Reflection.GetAssemblies Method

Reflection.GetAssemblies Method

Gets all known assemblies.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Assembly [] GetAssemblies ()

Return Value

An array containing all known assemblies.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Assembly.GetAssembly Method

Assembly.GetAssembly Method

Gets the assembly in which a specified class (type) is defined.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static Assembly GetAssembly (
         Type type
)

Parameters

type
A Type object that represents a specific class defined in the assembly you want to get.

Return Value

The assembly in which the specified class is defined.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Reflection.GetAssemblyFromHash Method

Reflection.GetAssemblyFromHash Method

Gets the assembly with the specified hash attribute.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Assembly GetAssemblyFromHash (
         UInt32 hash
)

Parameters

hash
The hash attribute for the assembly you want to get.

Return Value

The assembly with the specified hash attribute.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Reflection.GetAssemblyHash Method

Reflection.GetAssemblyHash Method

Retrieves the hash attribute from a specified assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static UInt32 GetAssemblyHash (
         Assembly assm
)

Parameters

assm
The assembly you want to retrieve the hash attribute from.

Return Value

The hash attribute that represents the specified assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Reflection.GetAssemblyInfo Method

Reflection.GetAssemblyInfo Method

Get an AssemblyInfo object from a byte array that represents a specified assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool GetAssemblyInfo (
         byte[] assm,
         AssemblyInfo ai
)

Parameters

assm
The byte array that represents the specified assembly.
ai
The assembly to be populated with data extracted from the byte array.

Return Value

true if the AssemblyInfo object contains valid data extracted from the byte array; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Reflection.GetAssemblyLastUse Method

Reflection.GetAssemblyLastUse Method

Gets a System.TimeSpan value that represents the time at which the specified assembly was last used.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static TimeSpan GetAssemblyLastUse (
         Assembly assm
)

Parameters

assm
The specified assembly.

Return Value

The time at which the specified assembly was last used.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Reflection.GetAssemblyPatch Method

Reflection.GetAssemblyPatch Method

Gets the assembly that is designated as a patch for the specified assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Assembly GetAssemblyPatch (
         Assembly assm
)

Parameters

assm
The specified assembly.

Return Value

The patch assembly for the specified assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Border.GetBorderThickness Method

Border.GetBorderThickness Method

Retrieves the thickness of a specific border, in pixels.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetBorderThickness (
         ref int left,
         ref int top,
         ref int right,
         ref int bottom
)

Parameters

left
[OutAttribute] The screen coordinate of the left edge of the border's background.
top
[OutAttribute] The screen coordinate of the top edge of the border's background.
right
[OutAttribute] The screen coordinate of the right edge of the border's background.
bottom
[OutAttribute] The screen coordinate of the bottom edge of the border's background.

Expand image Remarks

The parameters of this method contain their values when the method returns a value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Canvas.GetBottom Method

Canvas.GetBottom Method

Retrieves the row number of the bottom of the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int GetBottom (
         UIElement e
)

Parameters

e
The child element for which the bottom row number in the containing area is to be retrieved.

Return Value

The row number of the bottom of the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


ButtonDevice.GetButtonState Method

ButtonDevice.GetButtonState Method

Gets the state of a specified button.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ButtonState GetButtonState (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button whose state is to be retrieved.

Return Value

A value of the ButtonState enumeration that indicates the current state of the specified button.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


Buttons.GetButtonState Method

Buttons.GetButtonState Method

Gets the state of a specified button.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static ButtonState GetButtonState (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button whose current state you want to get.

Return Value

A value of the ButtonState enumeration that indicates the state of the specified button.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


ColorUtility.GetBValue Method

ColorUtility.GetBValue Method

Extracts a blue value from a specified color.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static byte GetBValue (
         Color color
)

Parameters

color
The color from which the blue value is to be extracted.

Return Value

The blue value extracted from the specified color.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ColorUtility Class
ColorUtility Members
Microsoft.SPOT.Presentation.Media Namespace


DrawingContext.GetClippingRectangle Method

DrawingContext.GetClippingRectangle Method

Retrieves the clipping rectangle of the current DrawingContext object.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetClippingRectangle (
         ref int x,
         ref int y,
         ref int width,
         ref int height
)

Parameters

x
[OutAttribute] The horizontal coordinate of the left edge of the clipping rectangle.
y
[OutAttribute] The vertical coordinate of the top edge of the clipping rectangle.
width
[OutAttribute] The width of the clipping rectangle.
height
[OutAttribute] The height of the clipping rectangle.

Expand image Remarks

The clipping rectangle is a rectangular region that restricts the drawing surface. All drawing must be done within the clipping rectangle. Any images or parts of images that are outside the clipping rectangle do not appear on the drawing surface.

The GetClippingRectangle method does not remove the clipping rectangle. Use the PopClippingRectangle method to remove it.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Type.GetConstructor Method

Type.GetConstructor Method

Searches for a public instance constructor whose parameters match the types in the specified array of Type objects.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public ConstructorInfo GetConstructor (
         Type[] types
)

Parameters

types

An array of Type objects representing the number, order, and type of the parameters you want the constructor to get.

-or-

An empty Type array you can use to get a constructor that takes no parameters.

Return Value

A ConstructorInfo object that represents the public instance constructor whose parameters match the types in the specified array, if such a match is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


CultureInfo.GetCultures Method

CultureInfo.GetCultures Method

Gets the list of supported cultures filtered by the specified CultureTypes values.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static CultureInfo [] GetCultures (
         CultureTypes types
)

Parameters

types
A combination of CultureTypes values that filter the cultures you want to retrieve.

Return Value

An array of CultureInfo objects that represent the supported cultures filtered by the specified CultureTypes values.

Expand image Remarks

Currently, the only supported culture type is AllCultures.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


StagingAreaInputItem.GetData Method

StagingAreaInputItem.GetData Method

Gets the entry associated with a specified key.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object GetData (
         Object key
)

Parameters

key
An object that specifies the key for which you want to get the associated entry.

Return Value

An object that represents the input and its event-related data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StagingAreaInputItem Class
StagingAreaInputItem Members
Microsoft.SPOT.Input Namespace


ExtendedTimeZone.GetDaylightChanges Method

ExtendedTimeZone.GetDaylightChanges Method

Finds the daylight saving time period for a specified year.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public override DaylightTime GetDaylightChanges (
         int year
)

Parameters

year
The year to which the daylight saving time period applies.

Return Value

A System.Globalization.DaylightTime value that contains the start and end dates for daylight saving time in the specified year.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


TimeZone.GetDaylightChanges Method

TimeZone.GetDaylightChanges Method

Returns the daylight saving time period for a specified year.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract DaylightTime GetDaylightChanges (
         int year
)

Parameters

year
The year to which the daylight saving time period applies.

Return Value

A System.Globalization.DaylightTime object that contains the start and end dates for daylight saving time in the specified year.

Expand image Remarks

Only one daylight saving time period per year is supported.

If daylight saving time is not used in the time zone you are in, the return value is a DaylightTime object, where the value of both Start and End is DateTime.MinValue, and the value of DaylightTime.Delta is a TimeSpan object initialized to 0 (zero) ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


ResourceUtility.GetDelimitedStringResource Method

ResourceUtility.GetDelimitedStringResource Method

Retrieves the string representation of a specified resource.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static string GetDelimitedStringResource (
         ResourceManager rm,
         Enum resource,
         int i
)

Parameters

rm
The resource manager that contains the specified resource.
resource
An enumerated value that indicates the type of the specified resource.
i
The index number of the resource (in the resource manager's resource collection) for which you want to get the string representation.

Return Value

The string representation of the specified resource.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Class
ResourceUtility Members
Microsoft.SPOT Namespace


ResourceUtility.GetDelimitedStringResources Method

ResourceUtility.GetDelimitedStringResources Method

Retrieves the string representations of the specified resources.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static string [] GetDelimitedStringResources (
         ResourceManager rm,
         Enum resource
)

Parameters

rm
The resource manager that contains the specified resources.
resource
An enumerated value that specifies the type of the resources for which you want to get the string representations.

Return Value

The string representations of the specified resources.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Class
ResourceUtility Members
Microsoft.SPOT Namespace


UIElement.GetDesiredSize Method

UIElement.GetDesiredSize Method

Gets the current element's size, as computed during the measure pass of the layout process.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetDesiredSize (
         ref int width,
         ref int height
)

Parameters

width
[OutAttribute] The current element's width.
height
[OutAttribute] The current element's height.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Thread.GetDomain Method

Thread.GetDomain Method

Returns the name of the domain in which the current thread is running.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static AppDomain GetDomain ()

Return Value

An AppDomain object that represents the application domain in which the current thread is running.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Type.GetElementType Method

Type.GetElementType Method

When overridden in a derived class, this method returns the type of the object encompassed or referred to by the current array, pointer, or reference type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type GetElementType ()

Return Value

The type of the object encompassed or referred to by the current array, pointer, or reference type.

-or-

A null reference if the current Type object is not an array, pointer, or reference type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Array.GetEnumerator Method

Array.GetEnumerator Method

Gets an IEnumerator object for a specified array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual IEnumerator GetEnumerator ()

Return Value

An IEnumerator object for the specified Array.

Expand image Remarks

Enumerators facilitate the reading of data in a collection; you cannot use enumerators to modify the underlying collection.

Initially, an enumerator is positioned before the first object in the specified collection. Calling the IEnumerator.Reset method also brings the enumerator back to this position. From this position, calling the IEnumerator.Current property throws an exception. Therefore, you must call the IEnumerator.MoveNext method to advance the enumerator to the first object in the collection before you can read the value of the IEnumerator.Current property.

The Current property returns the same object until either the MoveNext method or the Reset method is called. The MoveNext method sets the Current property to the next element.

After the end of the collection is passed, the enumerator is positioned after the last object in the collection, and calling MoveNext returns false. If the last call to MoveNext returned false, calling Current throws an exception. To set Current to the first object in the collection again, you can call Reset followed by MoveNext.

An enumerator remains valid as long as the collection you are using it in remains unchanged. If changes are made to the collection, such as adding, modifying, or deleting elements, the enumerator is irrecoverably invalidated and the next call to MoveNext or Reset throws an InvalidOperationException exception. If the collection is modified between the invoking of MoveNext and the invoking of Current, Current returns the element that it is set to, even if the enumerator is already invalidated.

Note also that an enumerator does not have exclusive access to a collection; therefore, enumerating through a collection is intrinsically not a thread-safe procedure. Even when a collection is synchronized, other threads could still modify it, thus causing the enumerator to throw an exception. To guarantee thread safety during enumeration, you can either lock the collection for the duration of the enumeration or catch the exceptions that result from changes made by other threads.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.GetEnumerator Method

ArrayList.GetEnumerator Method

Returns an enumerator for the entire ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual IEnumerator GetEnumerator ()

Return Value

An IEnumerator object for the entire ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


IEnumerable.GetEnumerator Method

IEnumerable.GetEnumerator Method

Returns an IEnumerator object (enumerator) that can iterate through a collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public IEnumerator GetEnumerator ()

Return Value

An enumerator that can iterate through a collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerable Interface
IEnumerable Members
System.Collections Namespace


System.Collections.IEnumerable.GetEnumerator Method

System.Collections.IEnumerable.GetEnumerator Method

Retrieves an enumerator that can be used to iterate through the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
IEnumerator System.Collections.IEnumerable.GetEnumerator ()

Return Value

An IEnumerator object that can access the UIElement objects in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


ListBoxItemCollection.GetEnumerator Method

ListBoxItemCollection.GetEnumerator Method

Retrieves an enumerator that can be used to iterate through the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual IEnumerator GetEnumerator ()

Return Value

The enumerator that can iterate through the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.GetEnumerator Method

TextRunCollection.GetEnumerator Method

Retrieves an enumerator that programs can use to iterate through the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual IEnumerator GetEnumerator ()

Return Value

An enumerator associated with the current text run collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


WindowCollection.GetEnumerator Method

WindowCollection.GetEnumerator Method

Returns an IEnumerator interface that your program can use to enumerate the Window objects in a window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual IEnumerator GetEnumerator ()

Return Value

An IEnumerator interface that your program can use to enumerate the Window objects in a window collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


Type.GetField Method (String)

Type.GetField Method (String)
See Also
CollapseAll image

Searches for the data field with the specified name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public FieldInfo GetField (
         string name
)

Parameters

name
The String object that contains the name of the field you want to get.

Return Value

A FieldInfo object that represents the field with the specified name, if it is found; otherwise, a null reference.

Expand image Remarks

The search name you use in a GetField search is case-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetField Method (String, BindingFlags)

Type.GetField Method (String, BindingFlags)
See Also
CollapseAll image

Searches for the specified data field, using the specified binding constraints (flags).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract FieldInfo GetField (
         string name,
         BindingFlags bindingAttr
)

Parameters

name
The String object containing the name of the field you want to get.
bindingAttr

A bitmask containing one or more BindingFlags objects that specify how the search is conducted.

-or-

0 (zero), to return a null reference.

Return Value

A FieldInfo object representing the field that matches the specified requirements, if such a match is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


IReflect.GetField Method

IReflect.GetField Method

Retrieves the FieldInfo object that corresponds to a specified field and BindingFlags member (binding attributes).

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public FieldInfo GetField (
         string name,
         BindingFlags bindingAttr
)

Parameters

name
The name of the field you want to find.
bindingAttr
The binding attributes you want to use to control the search.

Return Value

A FieldInfo object that contains the field information for the named object that meets the search constraints specified in the bindingAttr parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IReflect Interface
IReflect Members
System.Reflection Namespace


Type.GetField Method

Type.GetField Method

Searches for the specified data field.

Expand image Overload List

Name | Description
Type.GetField (String) | Searches for the data field with the specified name.
Type.GetField (String, BindingFlags) | Searches for the specified data field, using the specified binding constraints (flags).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetFields Method (BindingFlags)

Type.GetFields Method (BindingFlags)
See Also
CollapseAll image

When overridden in a derived class, this method searches for the fields defined for the current type, using the specified binding constraints (flags).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract FieldInfo [] GetFields (
         BindingFlags bindingAttr
)

Parameters

bindingAttr

A bitmask containing one or more BindingFlags objects that specify how the search is conducted.

-or-

0 (zero), to return a null reference.

Return Value

An array of FieldInfo objects representing all of the fields defined for the current type.

-or-

An empty FieldInfo array, if no fields are defined for the current type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetFields Method ()

Type.GetFields Method ()
See Also
CollapseAll image

Gets the fields of the current type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public FieldInfo [] GetFields ()

Return Value

An array of FieldInfo objects representing all of the fields defined for the current type.

-or-

An empty FieldInfo array, if no fields are defined for the current type.

Expand image Remarks

The GetFields method does not return fields in a particular order, such as alphabetic or declaration order. Your code must not depend on the order in which fields are returned, because that order can vary.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetFields Method

Type.GetFields Method

Gets the fields of the current type.

Expand image Overload List

Name | Description
Type.GetFields () | Gets the fields of the current type.
Type.GetFields (BindingFlags) | When overridden in a derived class, this method searches for the fields defined for the current type, using the specified binding constraints (flags).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


IFormatProvider.GetFormat Method

IFormatProvider.GetFormat Method

Gets an object that provides formatting services for the specified type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Object GetFormat (
         Type formatType
)

Parameters

formatType
An object that specifies the type of format object you want to get.

Return Value

The current object, if the object you want to get has the same formatType parameter as the current object; otherwise, a null reference.

Expand image Remarks

Use this method in classes that use format objects in methods that either generate or parse string representations of objects.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IFormatProvider Interface
IFormatProvider Members
System Namespace


ColorUtility.GetGValue Method

ColorUtility.GetGValue Method

Extracts a green value from a specified color.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static byte GetGValue (
         Color color
)

Parameters

color
The color from which the green value is to be extracted.

Return Value

The green value extracted from the specified color.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ColorUtility Class
ColorUtility Members
Microsoft.SPOT.Presentation.Media Namespace


Object.GetHashCode Method

Object.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual int GetHashCode ()

Return Value

A hash code for the current object.

Expand image Remarks

You can use the GetHashCode method to hash algorithms and data structures (such as hash tables).

The GetHashCode method can be overridden by a derived class. Value classes must override this method to provide a hash function that is appropriate for the class and that ensures optimum distribution in the hash table. Classes that might be used as keys in a hash table must also override this method, because objects that are used as keys in a hash table are required to generate their own hash code by using this method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


Type.GetInterfaces Method

Type.GetInterfaces Method

When overridden in a derived class, this method gets all of the interfaces implemented or inherited by the current type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type [] GetInterfaces ()

Return Value

An array of Type objects representing all of the interfaces implemented or inherited by the current type.

-or-

An empty Type array, if no interfaces are implemented or inherited by the current type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


UIElement.GetLayoutOffset Method

UIElement.GetLayoutOffset Method

Gets the current element's offset, relative to the upper-left corner of the screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetLayoutOffset (
         ref int x,
         ref int y
)

Parameters

x
[OutAttribute] The current element's horizontal offset.
y
[OutAttribute] The current element's vertical offset.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Canvas.GetLeft Method

Canvas.GetLeft Method

Retrieves the number of the leftmost column in the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int GetLeft (
         UIElement e
)

Parameters

e
The child element for which the leftmost column number in the containing area is to be retrieved.

Return Value

The leftmost column number in the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.GetMargin Method

UIElement.GetMargin Method

Gets the width of the current element's margins.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetMargin (
         ref int left,
         ref int top,
         ref int right,
         ref int bottom
)

Parameters

left
[OutAttribute] The width of the current element's left margin.
top
[OutAttribute] The width of the current element's top margin.
right
[OutAttribute] The width of the current element's right margin.
bottom
[OutAttribute] The width of the current element's bottom margin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Type.GetMethod Method (String)

Type.GetMethod Method (String)
See Also
CollapseAll image

Searches for the public method with the specified name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public MethodInfo GetMethod (
         string name
)

Parameters

name
The String object containing the name of the method you want to get.

Return Value

A MethodInfo object representing the method with the specified name, if it is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetMethod Method (String, Type[])

Type.GetMethod Method (String, Type[])
See Also
CollapseAll image

Searches for the specified public method whose parameters match the specified argument types.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public MethodInfo GetMethod (
         string name,
         Type[] types
)

Parameters

name
The String object containing the name of the method you want to get.
types

An array of Type objects representing the number, order, and type of the parameters for the method you want to get.

-or-

An empty Type array (that is, Type[] types = new Type[0]) you can use to get a method that takes no parameters.

Return Value

A MethodInfo object representing the method whose parameters match the specified argument types, if such a match is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetMethod Method (String, BindingFlags)

Type.GetMethod Method (String, BindingFlags)
See Also
CollapseAll image

Searches for the specified method, using the specified binding constraints (flags).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual MethodInfo GetMethod (
         string name,
         BindingFlags bindingAttr
)

Parameters

name
The String object containing the name of the method you want to get.
bindingAttr

A bitmask containing one or more BindingFlags objects that specify how the search is conducted.

-or-

0 (zero), to return a null reference.

Return Value

A MethodInfo object representing the method that matches the specified requirements, if such a match is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


IReflect.GetMethod Method

IReflect.GetMethod Method

Retrieves the MethodInfo object that corresponds to a specified method, using specified search constraints.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodInfo GetMethod (
         string name,
         BindingFlags bindingAttr
)

Parameters

name
The name of the method you want to find.
bindingAttr
The binding attributes you want to use to control the search.

Return Value

A MethodInfo object that contains method information, with the match being based on the method name and search constraints specified in the bindingAttr parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IReflect Interface
IReflect Members
System.Reflection Namespace


Type.GetMethod Method

Type.GetMethod Method

Gets a specific method of the current type.

Expand image Overload List

Name | Description
Type.GetMethod (String) | Searches for the public method with the specified name.
Type.GetMethod (String, BindingFlags) | Searches for the specified method, using the specified binding constraints (flags).
Type.GetMethod (String, Type[]) | Searches for the specified public method whose parameters match the specified argument types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetMethods Method (BindingFlags)

Type.GetMethods Method (BindingFlags)
See Also
CollapseAll image

When overridden in a derived class, this method searches for the methods defined for the current type, using the specified binding constraints (flags).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract MethodInfo [] GetMethods (
         BindingFlags bindingAttr
)

Parameters

bindingAttr

A bitmask containing one or more BindingFlags objects that specify how the search is conducted.

-or-

0 (zero), to return a null reference.

Return Value

An array of MethodInfo objects representing all of the methods defined for the current type that match the specified binding constraints.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetMethods Method ()

Type.GetMethods Method ()
See Also
CollapseAll image

Gets all of the public methods of the current type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodInfo [] GetMethods ()

Return Value

An array of MethodInfo objects representing all of the methods defined for the current type.

-or-

An empty MethodInfo array, if no methods are defined for the current type.

Expand image Remarks

Constructors are not included in the array of methods returned by this call. Make a separate call to the GetConstructors method to get the constructor methods.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.GetMethods Method

Type.GetMethods Method

Gets the methods of the current type.

Expand image Overload List

Name | Description
Type.GetMethods () | Gets all of the public methods of the current type.
Type.GetMethods (BindingFlags) | When overridden in a derived class, this method searches for the methods defined for the current type, using the specified binding constraints (flags).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


ResourceUtility.GetObject Method

ResourceUtility.GetObject Method

Gets the value of a specified Object resource for the current system culture.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Object GetObject (
         ResourceManager rm,
         Enum id
)

Parameters

rm
The resource manager that contains the specified resource.
id
The integer identifier for the specified resource.

Return Value

The value of the specified resource for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Class
ResourceUtility Members
Microsoft.SPOT Namespace


RuntimeHelpers.GetObjectValue Method

RuntimeHelpers.GetObjectValue Method

Boxes a value type.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Object GetObjectValue (
         Object obj
)

Parameters

obj
The value type to be boxed.

Return Value

A boxed copy of the obj parameter if the value type is a value class; otherwise obj itself is returned.

Expand image Remarks

Boxing a value type creates an object and then performs a shallow copy of the fields of the specified value type into the new object.

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RuntimeHelpers Class
RuntimeHelpers Members
System.Runtime.CompilerServices Namespace


Bitmap.GetPixel Method

Bitmap.GetPixel Method

Retrieves the pixel color at a specified location on the display device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Color GetPixel (
         int xPos,
         int yPos
)

Parameters

xPos
The x-coordinate of the location where pixel color is to be retrieved.
yPos
The y-coordinate of the location where pixel color is to be retrieved.

Return Value

The pixel color at the specified location.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Logging.GetRecord Method

Logging.GetRecord Method

Gets a Logging object (log record) from the zero-based list of log records.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Object GetRecord (
         int i
)

Parameters

i
The index number of the log record you want to retrieve.

Return Value

A log record.

Expand image Remarks

The use of this class is currently not supported and is not recommended.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Logging Class
Logging Members
Microsoft.SPOT Namespace


UIElement.GetRenderSize Method

UIElement.GetRenderSize Method

Gets the final render size of the current element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetRenderSize (
         ref int width,
         ref int height
)

Parameters

width
[OutAttribute] The width of the current element when rendered.
height
[OutAttribute] The height of the current element when rendered.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Canvas.GetRight Method

Canvas.GetRight Method

Retrieves the number of the rightmost column in the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int GetRight (
         UIElement e
)

Parameters

e
The child element for which the rightmost column number in the containing area is to be retrieved.

Return Value

The rightmost column number in the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


ColorUtility.GetRValue Method

ColorUtility.GetRValue Method

Extracts a red value from a specified color.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static byte GetRValue (
         Color color
)

Parameters

color
The color from which the red value is to be extracted.

Return Value

The red value extracted from the specified color.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ColorUtility Class
ColorUtility Members
Microsoft.SPOT.Presentation.Media Namespace


Assembly.GetSatelliteAssembly Method

Assembly.GetSatelliteAssembly Method

Gets a satellite assembly associated with a specified culture.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Assembly GetSatelliteAssembly (
         CultureInfo culture
)

Parameters

culture
A culture associated with the satellite assembly you want to get.

Return Value

The satellite assembly associated with the specified culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


TextRun.GetSize Method

TextRun.GetSize Method

Retrieves the dimensions (height and width) of the display area for the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void GetSize (
         ref int width,
         ref int height
)

Parameters

width
[OutAttribute] The width of the display area for the text.
height
[OutAttribute] The height of the display area for the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


ExtendedTimeZone.GetTimeZone Method

ExtendedTimeZone.GetTimeZone Method

Returns a time zone for a specified time zone ID.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static TimeZone GetTimeZone (
         TimeZoneId id
)

Parameters

id
The ID of the time zone you want to get.

Return Value

A System.TimeZone value set to the time zone ID provided .

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


Canvas.GetTop Method

Canvas.GetTop Method

Retrieves the row number of the top of the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int GetTop (
         UIElement e
)

Parameters

e
The child element for which the top row number in the containing area is to be retrieved.

Return Value

The row number of the top of the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


Assembly.GetType Method (String)

Assembly.GetType Method (String)
See Also
CollapseAll image

Gets the Type object that represents a specified class (type) in the current assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual Type GetType (
         string name
)

Parameters

name
The full name of the class you want to look for in the current assembly.

Return Value

The Type object that represents the specified class, or a null reference if that class is not found in the current assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Type.GetType Method

Type.GetType Method

Gets the type with the specified name by performing a case-sensitive search.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Type GetType (
         string typeName
)

Parameters

typeName
The name of the type you want to get.

Return Value

The type with the specified name, if it is found; otherwise, a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Assembly.GetType Method (String, Boolean)

Assembly.GetType Method (String, Boolean)
See Also
CollapseAll image

Gets the Type object that represents a specified class (type) in the current assembly, and optionally throws an exception.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Type GetType (
         string name,
         bool throwOnError
)

Parameters

name
The full name of the class you want to look for in the current assembly.
throwOnError
true if an exception will be thrown if the specified class is not found; otherwise, false.

Return Value

The Type object that represents the specified class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Assembly.GetType Method

Assembly.GetType Method

Gets the Type object that represents a specified class (type).

Expand image Overload List

Name | Description
Assembly.GetType (String) | Gets the Type object that represents a specified class (type) in the current assembly.
Assembly.GetType (String, Boolean) | Gets the Type object that represents a specified class (type) in the current assembly, and optionally throws an exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Object.GetType Method

Object.GetType Method

Gets the type of the current instance (object) of the Object class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Type GetType ()

Return Value

The type object that represents the exact run-time type of the current object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


Type.GetTypeFromHandle Method

Type.GetTypeFromHandle Method

Gets the type referenced by the specified RuntimeTypeHandle object (type handle).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Type GetTypeFromHandle (
         RuntimeTypeHandle handle
)

Parameters

handle
The specified type handle.

Return Value

The type referenced by the specified type handle.

Expand image Remarks

Note that the type handles are valid only in the application domain in which they reside.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Reflection.GetTypeFromHash Method

Reflection.GetTypeFromHash Method

Gets the type that uses the specified hash attribute.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Type GetTypeFromHash (
         UInt32 hash
)

Parameters

hash
The hash attribute for the specified type.

Return Value

The type that corresponds to the specified hash attribute.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Reflection.GetTypeHash Method

Reflection.GetTypeHash Method

Gets the hash attribute for a specified type.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static UInt32 GetTypeHash (
         Type t
)

Parameters

t
The type you want to retrieve the hash attribute from.

Return Value

The hash attribute that represents the specified type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Assembly.GetTypes Method

Assembly.GetTypes Method

Gets the Type objects that represent all of the classes (types) defined in the current assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual Type [] GetTypes ()

Return Value

An array of Type objects that represent all of the classes defined in the current assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Reflection.GetTypesImplementingInterface Method

Reflection.GetTypesImplementingInterface Method

Gets the System.Type objects (types) that implement the specified interface.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Type [] GetTypesImplementingInterface (
         Type itf
)

Parameters

itf
The type of the interface you want to search for.

Return Value

An array of types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


ExtendedTimeZone.GetUtcOffset Method

ExtendedTimeZone.GetUtcOffset Method

Finds the coordinated universal time (UTC) offset for the specified local time.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public override TimeSpan GetUtcOffset (
         DateTime time
)

Parameters

time
The local date and time.

Return Value

The local time for which you want the UTC offset, measured in clock ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


TimeZone.GetUtcOffset Method

TimeZone.GetUtcOffset Method

Returns the Coordinated Universal Time (UTC) offset for the specified local time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract TimeSpan GetUtcOffset (
         DateTime time
)

Parameters

time
The local date and time.

Return Value

The UTC offset from the time parameter, measured in ticks.

Expand image Remarks

Coordinated Universal Time (UTC) was previously known as Greenwich Mean Time (GMT). Local time is the date and time on the computer you are using. Offset is the difference between local time and UTC (local time = UTC + offset).

The time parameter must reflect the Gregorian calendar and the time zone represented by this TimeZone object. If time is in daylight saving time, the GetUtcOffset method returns the UTC offset to the daylight saving time zone. This method obtains the daylight saving time rule from the system.

For example, for Pacific Standard Time (in the United States), which has -8 hours of offset, the following method call returns -288000000000:

GetUtcOffset(new DateTime(1999, 1, 1))

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


Array.GetValue Method

Array.GetValue Method

Gets the value of the object at a specified position in a one-dimensional array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Object GetValue (
         int index
)

Parameters

index
A 32-bit integer that represents the value (index number) of the object you want to get.

Return Value

The index number of the specified object in the one-dimensional array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


FieldInfo.GetValue Method

FieldInfo.GetValue Method

When overridden in a derived class, this method returns the value of a field supported by a specified object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
public virtual abstract Object GetValue (
         Object obj
)

Parameters

obj
The object whose field value will be returned.

Return Value

An object that contains the value of the field reflected by the current FieldInfo object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Class
FieldInfo Members
System.Reflection Namespace


PropertyInfo.GetValue Method

PropertyInfo.GetValue Method

Retrieves the value of a property for a specified object. For indexed properties, the GetValue property also retrieves optional index values.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
[MethodImplAttribute]
public virtual Object GetValue (
         Object obj,
         Object[] index
)

Parameters

obj
The object whose property value will be returned.
index
Optional index values for indexed properties. For nonindexed properties, this value should be a null reference.

Return Value

The property value for the object specified by the obj parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyInfo Class
PropertyInfo Members
System.Reflection Namespace


System.Globalization Namespace

System.Globalization Namespace

The System.Globalization namespace in the Microsoft® .NET Micro Framework contains classes and an enumeration that define culture-related information. These types are useful for writing globalized (internationalized) applications.

Expand image Classes

 | Name | Description
Public Class | CultureInfo | Provides information about a specific culture (such as its name, its writing system, and so forth), as well as access to culture-specific objects that provide information for common operations, such as formatting dates and sorting strings.
Public Class | DateTimeFormatInfo | Defines how DateTime values are formatted and displayed, depending on the culture.
Public Class | DaylightTime | Defines the period of daylight saving time for the local time zone.
Public Class | NumberFormatInfo | Defines how numeric values are formatted and displayed, depending on the system culture.

Expand image Enumerations

 | Name | Description
Public Enumeration | CultureTypes | Defines the types of culture lists that you can retrieve by using the CultureInfo.GetCultures method.


GloballySynchronizedAttribute Class

GloballySynchronizedAttribute Class
See Also Members
CollapseAll image

Indicates that a particular method is globally synchronized.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class GloballySynchronizedAttribute : Attribute

Expand image Remarks

Applying this attribute to a method provides concurrency protection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

GloballySynchronizedAttribute
Microsoft.SPOT Namespace


Buttons.GotFocusEvent Field

Buttons.GotFocusEvent Field

Specifies the bubbling-routed event that occurs when a display element on a button device receives the button focus.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent GotFocusEvent

Expand image Remarks

The GotFocusEvent field specifies a routed event that uses the bubbling routing strategy. The event handler for this event is represented by the FocusChangedEventHandler Delegate delegate.

Button focus refers to state of the display element that is currently receiving input from a button device. At any specific point in time, there can be only one element on a button device's display that has the button focus.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


Colors.Gray Field

Colors.Gray Field

The system-defined color that has an RGB value of #808080.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color Gray

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


DateTime.operator > Method

DateTime.operator > Method

Determines whether one DateTime object is greater than another one.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator > (
         DateTime t1,
         DateTime t2
)

Parameters

t1
A DateTime value that represents the first operand.
t2
A DateTime value that represents the second operand.

Return Value

true if the value of t1 is greater than the value of t2; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator > Method

TimeSpan.operator > Method

Determines whether a specified TimeSpan object (time period) is greater than another specified TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator > (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes the first operand.
t2
A TimeSpan object that constitutes the second operand.

Return Value

true if the object specified by the t1 parameter is greater than the object specified by the t2 parameter; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.operator >= Method

DateTime.operator >= Method

Determines whether one DateTime object is greater than or equal to another one.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator >= (
         DateTime t1,
         DateTime t2
)

Parameters

t1
A DateTime value that represents the first operand.
t2
A DateTime value that represents the second operand.

Return Value

true if the value of t1 is greater than or equal to the value of t2; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator >= Method

TimeSpan.operator >= Method

Determines whether a specified TimeSpan object (time period) is greater than or equal to another specified TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator >= (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes the first operand.
t2
A TimeSpan object that constitutes the second operand.

Return Value

true if the object specified by the t1 parameter is greater than or equal to the object specified by the t2 parameter; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Colors.Green Field

Colors.Green Field

The system-defined color that has an RGB value of #008000.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color Green

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


RoutedEventArgs.Handled Property

RoutedEventArgs.Handled Property

Gets or sets a value that indicates the present state of the event handling for a particular routed event as it travels the route.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Handled { get; set; }

Property Value

When setting this property: true if the routed event is to be marked handled; otherwise false. When reading this property: true if a class handler or some instance handler along the route has already marked this event handled; otherwise, false. Note that the default value is false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


RoutedEvent.HandlerType Property

RoutedEvent.HandlerType Property

Gets the handler type of the current RoutedEvent object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Type HandlerType { get; }

Property Value

The handler type of the current routed event.

Expand image Remarks

The handler type is the event handler delegate that you should use when implementing handlers that will listen for the event represented by the current routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Class
RoutedEvent Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo.m_hash Field

Reflection.AssemblyInfo.m_hash Field

Contains the assembly hash attribute, which is a unique identifier for the current assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt32 m_hash

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


Dispatcher.HasShutdownFinished Property

Dispatcher.HasShutdownFinished Property

Determines whether the current Dispatcher object (dispatcher) has finished shutting down.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool HasShutdownFinished { get; }

Property Value

true if the current dispatcher has finished shutting down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


Dispatcher.HasShutdownStarted Property

Dispatcher.HasShutdownStarted Property

Determines whether the current Dispatcher object (dispatcher) is shutting down.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool HasShutdownStarted { get; }

Property Value

true if the current dispatcher has started shutting down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


TextRun._height Field

TextRun._height Field

Specifies the height, in pixels, of the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected int _height

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


Bitmap.Height Property

Bitmap.Height Property

Gets the height of the current bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int Height { get; }

Property Value

The height of the current bitmap, in pixels.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.Height Property

DrawingContext.Height Property

Gets the height of the current DrawingContext object's drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Height { get; }

Property Value

The height of the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Font.Height Property

Font.Height Property

Gets the height of the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int Height { get; }

Property Value

The height of the current font, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


UIElement.Height Property

UIElement.Height Property

Gets or sets the suggested height of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Height { get; set; }

Property Value

The suggested height of the element, in device-independent units (1/96th inch per unit).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement._horizontalAlignment Field

UIElement._horizontalAlignment Field

Specifies the horizontal alignment characteristics that are applied to the current element when it is composed within a parent element, such as a Panel object.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected HorizontalAlignment _horizontalAlignment

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


HorizontalAlignment Enumeration

HorizontalAlignment Enumeration

Specifies a child element's horizontal alignment within its parent element's layout space.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum HorizontalAlignment

Expand image Members

Member name | Description
Center | A value specifying that the child element is aligned with the horizontal center of the parent element's layout space.
Left | A value specifying that the child element is aligned with the left margin of the parent element's layout space.
Right | A value specifying that the child element is aligned with the right margin of the parent element's layout space.
Stretch | A value specifying that the child element is horizontally stretched to the left and right margins of the parent element's layout space. Note that explicitly set values of the UIElement.Height and UIElement.Width properties of an element take precedence over the Stretch value of the UIElement.HorizontalAlignment property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation Namespace


UIElement.HorizontalAlignment Property

UIElement.HorizontalAlignment Property

Gets or sets the horizontal alignment characteristics that are applied to this element when it is composed within a parent element, such as a Panel.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public HorizontalAlignment HorizontalAlignment { get; set; }

Property Value

A value of the HorizontalAlignment enumeration. The default value is Stretch.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


ScrollChangedEventArgs.HorizontalChange Field

ScrollChangedEventArgs.HorizontalChange Field

Contains the new (changed) horizontal offset value for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int HorizontalChange

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Class
ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox.HorizontalOffset Property

ListBox.HorizontalOffset Property

Gets or sets the horizontal offset, or displacement, of a control's content from the left edge of the display device area that contains the control.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int HorizontalOffset { get; set; }

Property Value

The horizontal offset of the control's content from the left edge of the area in which the control is contained.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollChangedEventArgs.HorizontalOffset Field

ScrollChangedEventArgs.HorizontalOffset Field

Contains the current horizontal offset value for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int HorizontalOffset

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Class
ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.HorizontalOffset Property

ScrollViewer.HorizontalOffset Property

Gets or sets the horizontal offset of the scrolled content in a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int HorizontalOffset { get; set; }

Property Value

The horizontal offset of the scrolled content. The default value for this property is 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


DateTime.Hour Property

DateTime.Hour Property

Gets the hours component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Hour { get; }

Property Value

The hour of the day, expressed as a number ranging from 0 through 23.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Hour Field

SystemTime.Hour Field

Specifies the hour associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Hour

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


TimeSpan.Hours Property

TimeSpan.Hours Property

Gets the number of whole hours in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Hours { get; }

Property Value

The number of whole hours in the current TimeSpan object.

Expand image Remarks

The value of a TimeSpan object can be expressed as [-]d.hh:mm:ss.ff, where the optional minus sign indicates a negative time period, d is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. The value of the Hours property is the hour component, hh.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Exception.m_HResult Field

Exception.m_HResult Field

Contains a coded numeric value that is assigned to a specific exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
protected int m_HResult

Expand image Remarks

This field holds a 32-bit value, which is divided into three sections: a severity code, a facility code, and an error code. The severity code indicates whether the return value represents information, a warning, or an error. The facility code identifies the area of the system that is responsible for the error. The error code is a unique number that is assigned to the exception. Each exception is mapped to a distinct HRESULT value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


IAsyncResult Interface

IAsyncResult Interface

Represents the status of an asynchronous operation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IAsyncResult

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


ICloneable Interface

ICloneable Interface

Supports cloning, which creates a new instance (object) of a specific class such that the new object is a copy of an existing object of that class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface ICloneable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICloneable Members
System Namespace


ICloneable Members

ICloneable Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the ICloneable type.

Expand image Public Methods

 | Name | Description
Public Method | Clone | Creates a new instance (object) that is a copy of the current object.

Expand image See Also

Reference

ICloneable Interface
System Namespace


ICollection Interface

ICollection Interface

Defines size, enumerators, and synchronization methods for all collections.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface ICollection : IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICollection Members
System.Collections Namespace


ICollection Members

ICollection Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the ICollection type.

Expand image Public Properties

 | Name | Description
Public Property | Count | When implemented by a class, this property gets the number of objects contained in a specific ICollection collection.
Public Property | IsSynchronized | When implemented by a class, this property gets a value indicating whether access to a specific ICollection collection is currently synchronized.
Public Property | SyncRoot | When implemented by a class, this property gets an object you can use to synchronize access to a specific ICollection collection.

Expand image Public Methods

 | Name | Description
Public Method | CopyTo | When implemented by a class, this method copies objects from an ICollection collection to a specified array (destination array), starting at a specified index number in the destination array.

Expand image See Also

Reference

ICollection Interface
System.Collections Namespace


IComparable Interface

IComparable Interface

Defines a generalized comparison method that a value type or class implements to create a type-specific comparison method.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IComparable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IComparable Members
System Namespace


IComparable Members

IComparable Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IComparable type.

Expand image Public Methods

 | Name | Description
Public Method | CompareTo | Compares the current instance (object) with another object of the same type.

Expand image See Also

Reference

IComparable Interface
System Namespace


IComparer Interface

IComparer Interface

Exposes a method that compares two objects.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IComparer

Expand image Remarks

This interface provides a way to customize the sort order for a collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IComparer Members
System.Collections Namespace


IComparer Members

IComparer Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IComparer type.

Expand image Public Methods

 | Name | Description
Public Method | Compare | Compares two objects and returns a value indicating whether the first object is less than, equal to, or greater than the second object.

Expand image See Also

Reference

IComparer Interface
System.Collections Namespace


ICustomFormatter Interface

ICustomFormatter Interface

Defines a method that supports custom, user-defined formatting of a specified object's value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface ICustomFormatter

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICustomFormatter Members
System Namespace


ICustomFormatter Members

ICustomFormatter Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the ICustomFormatter type.

Expand image Public Methods

 | Name | Description
Public Method | Format | Converts the value of a specified object to an equivalent string representation, using a specified format and culture-specific formatting information.

Expand image See Also

Reference

ICustomFormatter Interface
System Namespace


ExtendedWeakReference.Id Property

ExtendedWeakReference.Id Property

Gets the ID associated with the current ExtendedWeakReference object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt32 Id { get; }

Property Value

The ID for the current weak reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


IDisposable Interface

IDisposable Interface

Defines a method that frees, releases, or resets allocated unmanaged resources.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IDisposable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IDisposable Members
System Namespace


IDisposable Members

IDisposable Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IDisposable type.

Expand image Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Expand image See Also

Reference

IDisposable Interface
System Namespace


IEnumerable Interface

IEnumerable Interface

Exposes the enumerator, which supports a simple iteration through a collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerable Members
System.Collections Namespace


IEnumerable Members

IEnumerable Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IEnumerable type.

Expand image Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an IEnumerator object (enumerator) that can iterate through a collection.

Expand image See Also

Reference

IEnumerable Interface
System.Collections Namespace


IEnumerator Interface

IEnumerator Interface

Supports a simple iteration through a collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IEnumerator

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerator Members
System.Collections Namespace


IEnumerator Members

IEnumerator Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the IEnumerator type.

Expand image Public Properties

 | Name | Description
Public Property | Current | Gets the current object in a specified collection.

Expand image Public Methods

 | Name | Description
Public Method | MoveNext | Advances the enumerator to the next object in a specified collection.
Public Method | Reset | Sets the enumerator to its initial position, immediately preceding the first object in a specified collection.

Expand image See Also

Reference

IEnumerator Interface
System.Collections Namespace


IFormatProvider Interface

IFormatProvider Interface

Provides a mechanism for retrieving an object to control formatting.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IFormatProvider

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IFormatProvider Members
System Namespace


IFormatProvider Members

IFormatProvider Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IFormatProvider type.

Expand image Public Methods

 | Name | Description
Public Method | GetFormat | Gets an object that provides formatting services for the specified type.

Expand image See Also

Reference

IFormatProvider Interface
System Namespace


IFormattable Interface

IFormattable Interface

Provides functionality for formatting the value of an object as a string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IFormattable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IFormattable Members
System Namespace


IFormattable Members

IFormattable Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IFormattable type.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Formats the value of the current object with the specified format.

Expand image See Also

Reference

IFormattable Interface
System Namespace


Bitmap.DT_IgnoreHeight Field

Bitmap.DT_IgnoreHeight Field

Specifies that if the bitmap text is larger than the space provided, the text is drawn in its full size, rather than being scaled down to fit the value in the Height property.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_IgnoreHeight

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image Remarks

Use this field only with the Microsoft.SPOT.Bitmap.DrawTextInRect methods.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


IList Interface

IList Interface

Represents a collection of objects that you can access individually by index number.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public interface IList : ICollection, IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Members
System.Collections Namespace


IList Members

IList Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the IList type.

Expand image Public Properties

 | Name | Description
Public Property | IsFixedSize | When implemented by a class, this property gets a value indicating whether the IList collection has a fixed size.
Public Property | IsReadOnly | When implemented by a class, this property gets a value indicating whether the IList collection is read-only.
Public Property | Item | When implemented by a class, this property gets or sets the object at the specified index number in the IList collection.

Expand image Public Methods

 | Name | Description
Public Method | Add | When implemented by a class, this method adds a specified object to the IList collection.
Public Method | Clear | When implemented by a class, this method removes all objects from the IList collection.
Public Method | Contains | When implemented by a class, this method determines whether the IList collection contains a specified object.
Public Method | IndexOf | When implemented by a class, this method determines the index number of a specified object in the IList collection.
Public Method | Insert | When implemented by a class, this method inserts an object at a specified index number in the IList collection.
Public Method | Remove | When implemented by a class, this method removes the first occurrence of a specified object from the IList collection.
Public Method | RemoveAt | When implemented by a class, this method removes the object at the specified index number in the IList collection.

Expand image See Also

Reference

IList Interface
System.Collections Namespace


Image Class

Image Class
See Also Members
CollapseAll image

Displays a bitmap image.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Image : UIElement

Expand image Remarks

When a multiframe image is displayed, only the first frame of the image appears on the display device. The animation of multiframe images is not inherently supported in the .NET Micro Framework.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Members
Microsoft.SPOT.Presentation.Controls Namespace


Image Members

Image Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Image type.

Expand image Public Constructors

 | Name | Description
Public Method | Image | Overloaded. Initializes a new instance of the Image class.

Expand image Public Properties

 | Name | Description
Public Property | Bitmap | Gets or sets an Image control's bitmap.

Expand image Public Methods

 | Name | Description
Public Method | OnRender | Draws a bitmap to a display device.

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Remeasures a control for layout on a display device.

Expand image See Also

Reference

Image Class
Microsoft.SPOT.Presentation.Controls Namespace


ImageBrush Class

ImageBrush Class
See Also Members
CollapseAll image

Paints, or fills, an area with an image on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class ImageBrush : Brush

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ImageBrush Members
Microsoft.SPOT.Presentation.Media Namespace


ImageBrush Members

ImageBrush Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the ImageBrush type.

Expand image Public Constructors

 | Name | Description
Public Method | ImageBrush | Initializes a new instance of the ImageBrush class with a specified image.

Expand image Public Fields

 | Name | Description
Public Field | BitmapSource | Specifies the bitmapped image that is used as the brush's paint, or fill.
Public Field | Stretch | Specifies how an image extends (stretches) over the display area.

Expand image See Also

Reference

ImageBrush Class
Microsoft.SPOT.Presentation.Media Namespace


ImportRange

ImportRange
See Also Example
CollapseAll image

Specifies a range of Unicode characters to import.

Expand image Syntax

ImportRange start end

Parameters

start
An integer that indicates the beginning of the range of Unicode characters to import.
end
An integer that indicates the end of the range of Unicode characters to import.

Expand image Remarks

A SelectFont statement that specifies the font from which to import glyphs must precede the ImportRange statement in the .fntdef file. Otherwise TFConvert will fail. If there are multiple SelectFont statements, the one that more closely precedes the ImportRange statement will be used.

The ImportRange option may be applied multiple times per .fntdef file, to select non-contiguous ranges of characters.

Both the start and end arguments are required. To import only one character, use the same number for both start and end.

Expand image Example

The following .fntdef file will import the uppercase characters from A to C, the uppercase F, and the lowercase characters from a to c.
SelectFont "WE:400,FN:Kootenay"
#import A, B, C
ImportRange 65 67
#import F
ImportRange 70 70
#import a, b, c
ImportRange 97 99

Expand image See Also

Reference

ImportRangeAndMap


ImportRangeAndMap

ImportRangeAndMap
See Also Example
CollapseAll image

Specifies a range of Unicode characters to import.

Expand image Syntax

ImportRangeAndMap start end offset

Parameters

start
An integer, that when added to offset, indicates the beginning of the range of Unicode characters to import.
end
An integer, when added to offset, indicates the end of the range of Unicode characters to import.
offset
An integer that indicates the offset from which start and end are calculated.

Expand image Remarks

A SelectFont statement that specifies the font from which to import glyphs must precede the ImportRangeAndMap statement in the .fntdef file. Otherwise TFConvert will fail. If there are multiple SelectFont statements, the one that more closely precedes the ImportRangeAndMap statement will be used.

The ImportRangeAndMap option may be applied multiple times per .fntdef file, to select non-contiguous ranges of characters.

Expand image Example

The following .fntdef file will import the uppercase characters from A to C.
      SelectFont "WE:400,FN:Kootenay"
      #import A, B, C
      ImportRangeAndMap 0 2 65

Expand image See Also

Reference

ImportRange


Interlocked.Increment Method

Interlocked.Increment Method

Increments the value of a specified variable and stores the result, as an atomic operation.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Increment (
         ref int location
)

Parameters

location
The variable whose value is to be incremented.

Return Value

The incremented value.

Expand image Remarks

This is an atomic operation; it cannot be interrupted before it is complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Interlocked Class
Interlocked Members
System.Threading Namespace


IndexerNameAttribute Class

IndexerNameAttribute Class
See Also Members
CollapseAll image

Indicates the name by which a particular indexer is known in programming languages that do not directly support indexers.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class IndexerNameAttribute : Attribute

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexerNameAttribute Members
System.Runtime.CompilerServices Namespace


IndexerNameAttribute Members

IndexerNameAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the IndexerNameAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | IndexerNameAttribute | Initializes a new instance of the IndexerNameAttribute class.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image See Also

Reference

IndexerNameAttribute Class
System.Runtime.CompilerServices Namespace


String.IndexOf Method (Char, Int32, Int32)

String.IndexOf Method (Char, Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of the specified Unicode character in the current String object. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         char value,
         int startIndex,
         int count
)

Parameters

value
The Unicode character you want to find.
startIndex
The starting index number for the search.
count
The number of character positions to be examined.

Return Value

The character position of the value parameter for the specified character if it is found, or -1 if it is not found.

Expand image Remarks

The search begins at startIndex and continues to startIndex + count - 1. Note that the character at startIndex + count is not included in the search.

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Supported in .NET Micro Framework 1.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOf Method (String)

String.IndexOf Method (String)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of the specified String object in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         string value
)

Parameters

value
The String object you want to find.

Return Value

The character position of the value parameter if the specified string is found, or -1 if it is not found. If value is empty, the return value is 0 (zero).

Expand image Remarks

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOf Method (Char)

String.IndexOf Method (Char)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of a specified Unicode character in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         char value
)

Parameters

value
The Unicode character you want to find.

Return Value

The character position of the value parameter if the specified character is found, or -1 if it is not found.

Expand image Remarks

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOf Method (String, Int32)

String.IndexOf Method (String, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of the specified String object in the current String object. The search starts at a specified character position.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         string value,
         int startIndex
)

Parameters

value
The String object you want to find.
startIndex
The starting index number for the search.

Return Value

The character position of the value parameter if the specified string is found, or -1 if it is not found. If value is empty, the return value is startIndex.

Expand image Remarks

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


ArrayList.IndexOf Method (Object, Int32)

ArrayList.IndexOf Method (Object, Int32)
See Also
CollapseAll image

Searches for a specified object within that portion of the ArrayList collection starting at a specified index number and ending at the last object in the collection. Returns the zero-based index number of the first occurrence of that object (if any) within the specified portion of the collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int IndexOf (
         Object value,
         int startIndex
)

Parameters

value
A specified object contained in the ArrayList collection. This value can be a null reference.
startIndex
The zero-based index number where you want the search to start.

Return Value

The zero-based index number of the first occurrence of the specified object (if any) within that portion of the ArrayList collection starting at a specified index number and ending at the last object in the collection. If there are no such occurrences, this method returns -1.

Expand image Remarks

The ArrayList collection is searched forward, starting at the specified index number and ending at the last object in the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


String.IndexOf Method (String, Int32, Int32)

String.IndexOf Method (String, Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of the specified String object in the current String object. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         string value,
         int startIndex,
         int count
)

Parameters

value
The String object you want to find.
startIndex
The starting index number for the search.
count
The number of character positions to be examined.

Return Value

The character position of the value parameter if the specified String object is found, or -1 if it is not found.

Expand image Remarks

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Array.IndexOf Method (Array, Object, Int32, Int32)

Array.IndexOf Method (Array, Object, Int32, Int32)
See Also
CollapseAll image

Searches for a specified object in a defined range (search range) within a one-dimensional array, starting at the specified index number and searching through a specified number of objects. Returns the index number of the first occurrence of that object (if any) in the search range.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int IndexOf (
         Array array,
         Object value,
         int startIndex,
         int count
)

Parameters

array
The one-dimensional array that contains the search range.
value
The index number of the object you want to look for in the search range.
startIndex
The starting index number in the search range.
count
The number of objects in the search range.

Return Value

The index number of the first occurrence of the specified object (if any) in the search range. If the object is not found in the range, the return value is -1.

Expand image Remarks

The search range in the one-dimensional array is searched forward, starting at the first object in the range and ending at the last object in the range.

Use the Object.Equals method to compare the specified object with the objects in the search range. If the specified object is of a nonintrinsic (programmer-defined) type, use the Equals implementation for that type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


String.IndexOf Method (Char, Int32)

String.IndexOf Method (Char, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence of a specified Unicode character in the current String object. The search starts at a specified character position.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOf (
         char value,
         int startIndex
)

Parameters

value
The Unicode character you want to find.
startIndex
The starting index number for the search.

Return Value

The character position of the value parameter if the specified character is found, or -1 if it is not found.

Expand image Remarks

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


ArrayList.IndexOf Method (Object)

ArrayList.IndexOf Method (Object)
See Also
CollapseAll image

Searches for a specified object and returns the zero-based index number of the first occurrence of that object (if any) within the entire ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int IndexOf (
         Object value
)

Parameters

value
The object you want to locate in the ArrayList collection. This value can be a null reference.

Return Value

The zero-based index number of the first occurrence of the specified object (if any) within the entire ArrayList collection. If there are no such occurrences, this method returns -1.

Expand image Remarks

The ArrayList collection is searched forward, starting at the first object in the collection and ending at the last object.

This method performs a linear search; therefore, the average execution time is proportional to the value of the Count property. In other words, this method is an O(n) operation, where n is the value of Count.

This method determines equality by calling the Object.Equals method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.IndexOf Method

Array.IndexOf Method

Returns the index number of the first occurrence of a specified object (if any) in a one-dimensional array or in a specified range within that array.

Expand image Overload List

Name | Description
Array.IndexOf (Array, Object) | Searches an entire one-dimensional array for a specified object and returns the index number of the first occurrence of that object (if any) in the array.
Array.IndexOf (Array, Object, Int32) | Searches for a specified object in a defined range (search range) within a one-dimensional array, starting at a specified index number and ending at the last object in the entire array. Returns the index number of the first occurrence of that object (if any) in the search range.
Array.IndexOf (Array, Object, Int32, Int32) | Searches for a specified object in a defined range (search range) within a one-dimensional array, starting at the specified index number and searching through a specified number of objects. Returns the index number of the first occurrence of that object (if any) in the search range.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.IndexOf Method

ArrayList.IndexOf Method

Returns the zero-based index number of the first occurrence of a specified object (if any) in either the entire ArrayList collection or a specified portion of it.

Expand image Overload List

Name | Description
ArrayList.IndexOf (Object) | Searches for a specified object and returns the zero-based index number of the first occurrence of that object (if any) within the entire ArrayList collection.
ArrayList.IndexOf (Object, Int32) | Searches for a specified object within that portion of the ArrayList collection starting at a specified index number and ending at the last object in the collection. Returns the zero-based index number of the first occurrence of that object (if any) within the specified portion of the collection.
ArrayList.IndexOf (Object, Int32, Int32) | Searches for a specified object within that portion of the ArrayList collection that starts at a specified index number and contains a specified number of objects. Returns the zero-based index number of the first occurrence of that object (if any) within the specified portion of the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.IndexOf Method (Array, Object)

Array.IndexOf Method (Array, Object)
See Also
CollapseAll image

Searches an entire one-dimensional array for a specified object and returns the index number of the first occurrence of that object (if any) in the array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int IndexOf (
         Array array,
         Object value
)

Parameters

array
The one-dimensional array you want to search.
value
The object you want to search for in the one-dimensional array.

Return Value

The index number of the first occurrence of the specified object (if any) in the array. If the object is not found in the array, this method returns -1.

Expand image Remarks

The one-dimensional array is searched forward, starting at the first object in the array and ending at the last object.

Use the Object.Equals method to compare the specified object with the objects in the search range. If the specified object is of a nonintrinsic (programmer-defined) type, use the Equals implementation for that type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.IndexOf Method (Object, Int32, Int32)

ArrayList.IndexOf Method (Object, Int32, Int32)
See Also
CollapseAll image

Searches for a specified object within that portion of the ArrayList collection that starts at a specified index number and contains a specified number of objects. Returns the zero-based index number of the first occurrence of that object (if any) within the specified portion of the collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual int IndexOf (
         Object value,
         int startIndex,
         int count
)

Parameters

value
The object you want to locate in the ArrayList collection. This value can be a null reference.
startIndex
The zero-based index number where you want the search to start .
count
The number of objects in the portion of the collection you want to search.

Return Value

The zero-based index number of the first occurrence of a specified value parameter (if any) within that portion of the ArrayList collection that starts at the startIndex number and contains the number of objects specified in the count parameter. If there are no such occurrences, this method returns -1.

Expand image Remarks

The ArrayList collection is searched forward, starting at the startIndex number and ending at startIndex + count - 1.

This method performs a linear search; therefore, the average execution time is proportional to the value of the Count property. In other words, this method is an O(n) operation, where n is the value of Count.

This method determines equality by calling the Object.Equals method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Array.IndexOf Method (Array, Object, Int32)

Array.IndexOf Method (Array, Object, Int32)
See Also
CollapseAll image

Searches for a specified object in a defined range (search range) within a one-dimensional array, starting at a specified index number and ending at the last object in the entire array. Returns the index number of the first occurrence of that object (if any) in the search range.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int IndexOf (
         Array array,
         Object value,
         int startIndex
)

Parameters

array
The one-dimensional array that contains the search range.
value
The object you want to look for in the search range.
startIndex
The starting index number in the search range.

Return Value

The index number of the first occurrence of the specified object (if any) in the search range. If the object is not found in the search range, this method returns -1.

Expand image Remarks

The search range in the one-dimensional array is searched forward, starting at the first object in the range and ending at the last object in the range.

Use the Object.Equals method to compare the specified object with the objects in the search range. If the specified object is of a nonintrinsic (programmer-defined) type, use the Equals implementation for that type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


System.Collections.IList.IndexOf Method

System.Collections.IList.IndexOf Method

Searches for a specified object in a one-dimensional array and returns the index number of the first occurrence of that object (if any) in the array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
int System.Collections.IList.IndexOf (
         Object value
)

Parameters

value
The object you want to search for in the current array.

Return Value

The index number of the first occurrence of the specified object (if any) in the current array. If the object is not found in the array, this method returns -1.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.IndexOf Method

IList.IndexOf Method

When implemented by a class, this method determines the index number of a specified object in the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int IndexOf (
         Object value
)

Parameters

value
The object you want to search for in the collection.

Return Value

The index number of the specified object if it was found in the IList collection; otherwise, -1.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.IndexOf Method

ListBoxItemCollection.IndexOf Method

Retrieves the index number of a specified item (element) if that item is found in the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int IndexOf (
         ListBoxItem item
)

Parameters

item
The item you want to search for in the current collection.

Return Value

The index number of the specified item if it is found in the current collection, or -1 if it is not found there.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


String.IndexOf Method

String.IndexOf Method

Reports the index number, or character position, of the first occurrence of a specified String object or one or more specified Unicode characters in the current String object.

Expand image Overload List

Name | Description
String.IndexOf (Char) | Reports the index number, or character position, of the first occurrence of a specified Unicode character in the current String object.
String.IndexOf (Char, Int32) | Reports the index number, or character position, of the first occurrence of a specified Unicode character in the current String object. The search starts at a specified character position.
String.IndexOf (Char, Int32, Int32) | Reports the index number, or character position, of the first occurrence of the specified Unicode character in the current String object. The search starts at a specified character position and examines a specified number of character positions.
String.IndexOf (String) | Reports the index number, or character position, of the first occurrence of the specified String object in the current String object.
String.IndexOf (String, Int32) | Reports the index number, or character position, of the first occurrence of the specified String object in the current String object. The search starts at a specified character position.
String.IndexOf (String, Int32, Int32) | Reports the index number, or character position, of the first occurrence of the specified String object in the current String object. The search starts at a specified character position and examines a specified number of character positions.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


TextRunCollection.IndexOf Method

TextRunCollection.IndexOf Method

Returns the index number of the specified TextRun object, if that object is found in the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int IndexOf (
         TextRun run
)

Parameters

run
The TextRun object to be searched for in the current collection.

Return Value

The index number of the specified TextRun object, or -1 if the object is not found in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.IndexOf Method

UIElementCollection.IndexOf Method

Returns the index number (position) of a specified element in the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int IndexOf (
         UIElement element
)

Parameters

element
A UIElement object that specifies the element whose index number you want to retrieve.

Return Value

The index number of the specified element in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


String.IndexOfAny Method (Char[], Int32, Int32)

String.IndexOfAny Method (Char[], Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOfAny (
         char[] anyOf,
         int startIndex,
         int count
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.
startIndex
The starting index number for the search.
count
The number of character positions to be examined.

Return Value

The character position of the first occurrence in the current String object of any character within the specified array, or -1 if no such character is found.

Expand image Remarks

The search begins at startIndex and continues to startIndex + count -1. The character at startIndex + count is not included in the search.

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOfAny Method (Char[])

String.IndexOfAny Method (Char[])
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOfAny (
         char[] anyOf
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.

Return Value

The character position of the first occurrence in the current String object of any character within the specified array, or -1 if no such character is found.

Expand image Remarks

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOfAny Method (Char[], Int32)

String.IndexOfAny Method (Char[], Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int IndexOfAny (
         char[] anyOf,
         int startIndex
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.
startIndex
The starting index number for the search.

Return Value

The character position of the first occurrence in the current String object of any character within the specified array, or -1 if no such character is found.

Expand image Remarks

Index numbering starts at 0 (zero). The search ranges from startIndex to the end of the string.

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.IndexOfAny Method

String.IndexOfAny Method

Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.

Expand image Overload List

Name | Description
String.IndexOfAny (Char[]) | Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.
String.IndexOfAny (Char[], Int32) | Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.
String.IndexOfAny (Char[], Int32, Int32) | Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters. The search starts at a specified character position and examines a specified number of character positions.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


IndexOutOfRangeException Class

IndexOutOfRangeException Class
See Also Members
CollapseAll image

The exception that is thrown when an attempt is made to access an object in an array and the index number of that object is outside the bounds of the array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class IndexOutOfRangeException : SystemException

Expand image Remarks

The IndexOutOfRangeException class cannot be inherited.

This class uses HRESULT COR_E_INDEXOUTOFRANGE, which has the value 0x80131508.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IndexOutOfRangeException Members
System Namespace


IndexOutOfRangeException Members

IndexOutOfRangeException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the IndexOutOfRangeException type.

Expand image Public Constructors

 | Name | Description
Public Method | IndexOutOfRangeException | Overloaded. Initializes a new instance of the IndexOutOfRangeException class.

Expand image See Also

Reference

IndexOutOfRangeException Class
System Namespace


MulticastDelegate.op_Inequality Method

MulticastDelegate.op_Inequality Method

Determines whether the current multicast delegate and another specified delegate are not equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Inequality (
         MulticastDelegate d1,
         MulticastDelegate d2
)

Parameters

d1
The first delegate you want to compare.
d2
The second delegate you want to compare.

Return Value

true if the d1 and d2 parameters contain different invocation lists; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MulticastDelegate Class
MulticastDelegate Members
System Namespace


DateTime.operator != Method

DateTime.operator != Method

Determines whether two specified DateTime objects are not equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator != (
         DateTime d1,
         DateTime d2
)

Parameters

d1
A DateTime object that specifies a date and time.
d2
A DateTime object that specifies a date and time.

Return Value

true if the d1 and d2 objects do not specify the same date and time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Delegate.op_Inequality Method

Delegate.op_Inequality Method

Determines whether the specified delegates are not equal to one another.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Inequality (
         Delegate d1,
         Delegate d2
)

Parameters

d1
The first delegate you want to compare.
d2
The second delegate you want to compare.

Return Value

true if d1 is not equal to d2; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


String.op_Inequality Method

String.op_Inequality Method

Determines whether two specified String objects have different values.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool op_Inequality (
         string a,
         string b
)

Parameters

a
A String object or a null reference.
b
A String object or a null reference.

Return Value

true if the value of a is different from the value of b; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


TimeSpan.operator != Method

TimeSpan.operator != Method

Determines whether two specified TimeSpan objects (time periods) are not equal.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator != (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes a period of time.
t2
A TimeSpan object that constitutes a period of time.

Return Value

true if the two TimeSpan objects specified by the t1 and t2 parameters do not specify the same period of time; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Timeout.Infinite Field

Timeout.Infinite Field

Represents a constant you can use to specify an infinite waiting period.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Infinite

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timeout Class
Timeout Members
System.Threading Namespace


AssemblyInformationalVersionAttribute.InformationalVersion Property

AssemblyInformationalVersionAttribute.InformationalVersion Property
See Also
CollapseAll image

Gets the version information for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string InformationalVersion { get; }

Property Value

A string that contains the version information for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyInformationalVersionAttribute Class
AssemblyInformationalVersionAttribute Members
System.Reflection Namespace


AttributeUsageAttribute.Inherited Property

AttributeUsageAttribute.Inherited Property

Gets or sets a Boolean value that indicates whether the specified attribute can be inherited by derived classes and overriding members.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool Inherited { get; set; }

Property Value

true if the attribute can be inherited by derived classes and overriding members; otherwise, false. The default return value is true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AttributeUsageAttribute Class
AttributeUsageAttribute Members
System Namespace


RuntimeHelpers.InitializeArray Method

RuntimeHelpers.InitializeArray Method

Provides a fast way to initialize an array from data stored in a module.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void InitializeArray (
         Array array,
         RuntimeFieldHandle fldHandle
)

Parameters

array
The array to be initialized.
fldHandle
A RuntimeFieldHandle object that specifies the location of the data used to initialize the array.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RuntimeHelpers Class
RuntimeHelpers Members
System.Runtime.CompilerServices Namespace


Exception.InnerException Property

Exception.InnerException Property

Gets the Exception instance that caused the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Exception InnerException { get; }

Property Value

An instance of the Exception class that describes the error that caused the current exception. The InnerException property returns the same value that was passed to the constructor, or it returns a null reference if the inner exception value was not supplied to the constructor.

Expand image Remarks

This property is read-only.

When an exception (X) is thrown as a direct result of a previous exception (Y), the InnerException property of X should contain a reference to Y.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


Microsoft.SPOT.Input Namespace

Microsoft.SPOT.Input Namespace

The Microsoft.SPOT.Input namespace in the Microsoft® .NET Micro Framework provides classes, delegates, and enumerations that support the Windows® Presentation Foundation (WPF) input system.

Expand image Classes

 | Name | Description
Public Class | ButtonDevice | Represents a hardware device that has buttons on it for inputing data.
Public Class | ButtonEventArgs | Provides data for a button input event.
Public Class | Buttons | Represents the buttons on an input device that is represented by a ButtonDevice object.
Public Class | FocusChangedEventArgs | Provides data for an event that occurs when an input device's button focus moves to a different display element.
Public Class | InputDevice | Provides a constructor and a property for describing input devices.
Public Class | InputEventArgs | Provides data for input-related routed events.
Public Class | InputManager | Manages all of the input systems in Windows Presentation Foundation (WPF).
Public Class | InputProviderSite | Represents the intermediary between an input provider and the input manager.
Public Class | InputReport | Represents an input to InputProviderSite and InputManager objects.
Public Class | InputReportEventArgs | Provides data for an event that occurs when the input manager receives an input report from an input provider site.
Public Class | NotifyInputEventArgs | Provides data for raw input being processed by the input manager.
Public Class | PreProcessInputEventArgs | Provides data for preprocess input events.
Public Class | ProcessInputEventArgs | Provides data for postprocess input events.
Public Class | RawButtonInputReport | Represents a button device's input to InputProviderSite and InputManager objects.
Public Class | StagingAreaInputItem | Encapsulates an input for entry in the staging area.

Expand image Delegates

 | Name | Description
Public Delegate | ButtonEventHandler | Represents the method that handles button-related input events.
Public Delegate | FocusChangedEventHandler | Represents the method that handles an event that occurs when the focus changes.
Public Delegate | InputEventHandler | Represents the method that handles input-related events.
Public Delegate | InputReportEventHandler | Supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code.
Public Delegate | NotifyInputEventHandler | Represents the method that handles notify input events for the input manager.
Public Delegate | PreProcessInputEventHandler | Represents the method that handles preprocess input events.
Public Delegate | ProcessInputEventHandler | Represents the method that handles process input events.

Expand image Enumerations

 | Name | Description
Public Enumeration | Button | Identifies a button on a button device.
Public Enumeration | ButtonState | Specifies the state of a button's input.
Public Enumeration | RawButtonActions | Specifies the current "raw" action of a button.


StagingAreaInputItem.Input Field

StagingAreaInputItem.Input Field

Specifies the data for the events related to the input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputEventArgs Input

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StagingAreaInputItem Class
StagingAreaInputItem Members
Microsoft.SPOT.Input Namespace


InputDevice Class

InputDevice Class
See Also Members
CollapseAll image

Provides a constructor and a property for describing input devices.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class InputDevice : DispatcherObject

Expand image Remarks

Each InputDevice object represents a specific input device. For example, if there are two mice (pointing devices), there will be two InputDevice objects — one object for each mouse.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputDevice Members
Microsoft.SPOT.Input Namespace


InputDevice Members

InputDevice Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the InputDevice type.

Expand image Public Constructors

 | Name | Description
Public Method | InputDevice | Initializes a new instance of the InputDevice class.

Expand image Public Properties

 | Name | Description
Public Property | Target | When overridden in a derived class, this property gets the display element that receives input from the current input device.

Expand image See Also

Reference

InputDevice Class
Microsoft.SPOT.Input Namespace


InputEventArgs Class

InputEventArgs Class
See Also Members
CollapseAll image

Provides data for input-related routed events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class InputEventArgs : RoutedEventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputEventArgs Members
Microsoft.SPOT.Input Namespace


InputEventArgs Members

InputEventArgs Members
See Also Constructors Fields Properties
CollapseAll image

The following tables list the members exposed by the InputEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | InputEventArgs | Initializes a new instance of the InputEventArgs class, using specified values.

Expand image Public Fields

 | Name | Description
Public Field | Timestamp | Specifies the time period during which the input was received.

Expand image Public Properties

 | Name | Description
Public Property | Device | Gets the device that generated the input.

Expand image See Also

Reference

InputEventArgs Class
Microsoft.SPOT.Input Namespace


InputEventHandler Delegate

InputEventHandler Delegate

Represents the method that handles input-related events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void InputEventHandler (
         Object sender,
         InputEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


InputManager Class

InputManager Class
See Also Members
CollapseAll image

Manages all of the input systems in Windows Presentation Foundation (WPF).

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class InputManager : DispatcherObject

Expand image Remarks

You use the InputManager class to coordinate all of the input systems in WPF, and also to control the input staging area.

The input staging area processes raw input into WPF events. Canceling the InputManager.PreProcessInput Event event will remove the input event from the staging area. The InputManager.PostProcessInput Event event exposes the staging area as a stack and enables items to be popped off or pushed on to the top of the staging area. A filter is any code routine that listens for the PreProcessInput event or the PostProcessInput event. A monitor is any code routine that listens for the PreNotifyInput event or the PostNotifyInput event. Note that filters can modify the input staging area, whereas monitors cannot.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Members
Microsoft.SPOT.Input Namespace


InputManager Members

InputManager Members
See Also Events Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the InputManager type.

Expand image Public Fields

Name | Description
InputReportEvent | Specifies the bubbling-routed event that occurs when the input manager receives an input report from an InputProviderSite object.
PreviewInputReportEvent | Specifies the tunneling-routed event that occurs when the input manager receives an input report from an InputProviderSite object.

Expand image Public Properties

 | Name | Description
 | CurrentInputManager | Gets the current InputManager object associated with a particular thread.
Public Property | InputProviders | Gets the collection of input providers that are registered with the current input manager.
Public Property | MostRecentInputDevice | Gets or sets the input device that is associated with the most recent input event.

Expand image Public Methods

 | Name | Description
Public Method | ProcessInput | Processes the specified input synchronously.
Public Method | RegisterInputProvider | Registers an input source with the input manager.

Expand image Public Events

 | Name | Description
Public Event | PostNotifyInput | Occurs after the PreNotifyInput event handlers have finished processing the raw input and the corresponding WPF events have been raised.
Public Event | PostProcessInput | Occurs after the NotifyInputEventHandler Delegate delegate has finished processing the raw input.
Public Event | PreNotifyInput | Occurs when the PreProcessInputEventHandler Delegate delegate has finished processing the raw input, if the raw input was not canceled.
Public Event | PreProcessInput | Occurs when the input manager starts to process a raw input item.

Expand image See Also

Reference

InputManager Class
Microsoft.SPOT.Input Namespace


InputProviderSite.InputManager Property

InputProviderSite.InputManager Property

Gets the input manager with which the current InputProviderSite object communicates.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputManager InputManager { get; }

Property Value

An InputManager object that represents the input manager with which the current InputProviderSite object communicates.

Expand image Remarks

You use the InputManager object to coordinate all of the input systems in Windows Presentation Foundation (WPF), and to control the input staging area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputProviderSite Class
InputProviderSite Members
Microsoft.SPOT.Input Namespace


InputManager.InputProviders Property

InputManager.InputProviders Property

Gets the collection of input providers that are registered with the current input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ICollection InputProviders { get; }

Property Value

An ICollection object that contains the collection of input providers registered with the current input manager.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


InputProviderSite Class

InputProviderSite Class
See Also Members
CollapseAll image

Represents the intermediary between an input provider and the input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class InputProviderSite : IDisposable

Expand image Remarks

An InputProviderSite object receives an input report from an input provider. The InputProviderSite object forwards the input report to the input manager, which then places the input report in the staging area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputProviderSite Members
Microsoft.SPOT.Input Namespace


InputProviderSite Members

InputProviderSite Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the InputProviderSite type.

Expand image Public Properties

 | Name | Description
Public Property | InputManager | Gets the input manager with which the current InputProviderSite object communicates.
Public Property | IsDisposed | Gets a value that indicates whether the current InputProviderSite object has been disposed.

Expand image Public Methods

 | Name | Description
Public Method | Dispose | Frees, releases, or resets unmanaged resources for the current InputProviderSite object.
Public Method | ReportInput | Determines whether a specified input report has been forwarded to the input manager.

Expand image See Also

Reference

InputProviderSite Class
Microsoft.SPOT.Input Namespace


InputReport Class

InputReport Class
See Also Members
CollapseAll image

Represents an input to InputProviderSite and InputManager objects.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class InputReport

Expand image Remarks

An InputProviderSite object receives an input report from an input provider. The InputProviderSite object forwards the input report to the InputManager object, which then places the input report in the staging area. Once the input report is in the staging area, it is changed into a series of Windows Presentation Foundation (WPF) events, which are then routed through the element tree.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReport Members
Microsoft.SPOT.Input Namespace


InputReport Members

InputReport Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the InputReport type.

Expand image Protected Constructors

 | Name | Description
Protected Method | InputReport | Creates a new InputReport object, using a specified input source.

Expand image Public Fields

 | Name | Description
Public Field | InputSource | Specifies the source of the input represented by the current InputReport object.
Public Field | Timestamp | Specifies the time period during which the input represented by the current InputReport object was received.

Expand image See Also

Reference

InputReport Class
Microsoft.SPOT.Input Namespace


InputManager.InputReportEvent Field

InputManager.InputReportEvent Field

Specifies the bubbling-routed event that occurs when the input manager receives an input report from an InputProviderSite object.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent InputReportEvent

Expand image Remarks

The InputReportEvent field specifies a routed event that uses the bubbling routing strategy. The event handler for this event is represented by the InputEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


InputReportEventArgs Class

InputReportEventArgs Class
See Also Members
CollapseAll image

Provides data for an event that occurs when the input manager receives an input report from an input provider site.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class InputReportEventArgs : InputEventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReportEventArgs Members
Microsoft.SPOT.Input Namespace
InputManager Class
InputReport Class
InputProviderSite Class


InputReportEventArgs Members

InputReportEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the InputReportEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | InputReportEventArgs | Initializes a new instance of the InputReportEventArgs class, using specified values.

Expand image Public Fields

 | Name | Description
Public Field | Report | Contains the input report that specifies the input to the InputProviderSite and InputManager objects.

Expand image See Also

Reference

InputReportEventArgs Class
Microsoft.SPOT.Input Namespace


InputReportEventHandler Delegate

InputReportEventHandler Delegate

Supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void InputReportEventHandler (
         Object sender,
         InputReportEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Remarks

Do not use this delegate directly from the code in your .NET Micro Framework applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


ButtonEventArgs.InputSource Field

ButtonEventArgs.InputSource Field

Specifies the source of the button input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public PresentationSource InputSource

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


InputReport.InputSource Field

InputReport.InputSource Field

Specifies the source of the input represented by the current InputReport object.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public PresentationSource InputSource

Expand image Remarks

A source of input is also called an input provider.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReport Class
InputReport Members
Microsoft.SPOT.Input Namespace


ArrayList.Insert Method

ArrayList.Insert Method

Inserts a specified object into the ArrayList collection at a specified index number.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void Insert (
         int index,
         Object value
)

Parameters

index
The zero-based index number where you want the object to be inserted.
value
The object you want to insert. This value can be a null reference.

Expand image Remarks

The ArrayList collection accepts a null reference as a valid value and allows duplicate objects.

If the value of the Count property already equals the value of the Capacity property, Insert automatically doubles the capacity of the list before the object is inserted.

If the index parameter is equal to the value of the Count property, the contents of the value parameter are added to the end of the ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


System.Collections.IList.Insert Method

System.Collections.IList.Insert Method

Inserts an object at a specified location (index number) in an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
void System.Collections.IList.Insert (
         int index,
         Object value
)

Parameters

index
The index number at which you want to insert the specified object into the array.
value
The object you want to insert into the array.

Expand image Remarks

The Array object has a fixed size. Therefore, inserting objects into an array of this type does not increase the length of the arrary, and removing objects from it does not decrease its length.

This method always throws a NotSupportedException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.Insert Method

IList.Insert Method

When implemented by a class, this method inserts an object at a specified index number in the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void Insert (
         int index,
         Object value
)

Parameters

index
The zero-based index number at which you want the specified object to be inserted into the IList collection.
value
The object you want to insert into the collection.

Expand image Remarks

If the specified index number equals the total number of objects in the IList collection, the specified object is inserted at the end of the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Insert Method

ListBoxItemCollection.Insert Method

Inserts an item (element) into the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Insert (
         int index,
         ListBoxItem item
)

Parameters

index
The index number in the current collection where you want to insert the item.
item
The item you want to insert into the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Insert Method

TextRunCollection.Insert Method

Inserts a specified TextRun object at a specified position (index number) in the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Insert (
         int index,
         TextRun run
)

Parameters

index
The index number in the collection where the specified TextRun object is to be inserted.
run
The TextRun object to be inserted into the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Insert Method

UIElementCollection.Insert Method

Inserts a specified element into the current collection at a specified index number (position).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Insert (
         int index,
         UIElement element
)

Parameters

index
The index number in the current collection where you want to insert the specified element.
element
A UIElement object that specifies the element you want to insert into the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


ExecutionConstraint.Install Method

ExecutionConstraint.Install Method

Creates a subthread within the calling thread, containing a constraint that requires the calling thread to complete an operation within a specified time period and at a specified priority level.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Install (
         int timeout,
         int priority
)

Parameters

timeout
The number of clock ticks before a ConstraintException exception is thrown. Note that the value -1 in this parameter indicates that the current constraint exception is to be uninstalled.
priority
The priority level of the calling thread.

Expand image Remarks

If the specified time period expires before the thread has completed the operation, a ConstraintException exception is thrown. Note that the time you set in the timeout parameter is standard clock time, not thread execution time.

You can raise the priority level only for threads that already have a priority level higher than 0 (zero).

Exceptions This method throws exceptions for any of the reasons (conditions) listed in the following table.
Exception | Condition
System.Exception | The timeout parameter is less than -1.
System.Exception | The system is unable to identify the thread that is installing this constraint.
System.Exception | The thread installing this contraint does not own the subthread that the constraint applies to.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExecutionConstraint Class
ExecutionConstraint Members
Microsoft.SPOT Namespace


WindowManager.Instance Property

WindowManager.Instance Property

Gets the current instance (object) of the WindowManager class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static WindowManager Instance { get; }

Property Value

The current instance of the WindowManager class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowManager Class
WindowManager Members
Microsoft.SPOT.Presentation Namespace


UIElement.InstanceEventHandlersStore Property

UIElement.InstanceEventHandlersStore Property

Gets the event-handler store for this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected EventHandlersStore InstanceEventHandlersStore { get; }

Property Value

An EventHandlersStore object that contains a hash table of the event-handlers for the this element's routed events.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Int16 Structure

Int16 Structure

Represents a 16-bit integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Int16

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Members
System Namespace


Int16 Members

Int16 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Int16 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of Int16 Structure. This field is constant.
MinValue | Represents the smallest possible value of Int16 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current Int16 object to its equivalent string representation.

Expand image See Also

Reference

Int16 Structure
System Namespace


Int32 Structure

Int32 Structure

Represents a 32-bit integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Int32

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Members
System Namespace


Int32 Members

Int32 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Int32 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of Int32 Structure. This field is constant.
MinValue | Represents the smallest possible value of Int32 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current Int32 object to its equivalent string representation.

Expand image See Also

Reference

Int32 Structure
System Namespace


Int64 Structure

Int64 Structure

Represents a 64-bit integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Int64

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Members
System Namespace


Int64 Members

Int64 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Int64 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of Int64 Structure. This field is constant.
MinValue | Represents the smallest possible value of Int64 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current Int64 object to its equivalent string representation.

Expand image See Also

Reference

Int64 Structure
System Namespace


Interlocked Class

Interlocked Class
See Also Members
CollapseAll image

Provides atomic operations for variables that are shared by multiple threads.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class Interlocked

Expand image Remarks

The methods of this class help protect against errors that can occur when the scheduler switches contexts while a thread is updating a variable that can be accessed by other threads. All method in this class are atomic; they cannot be interrupted until they complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Interlocked Members
System.Threading Namespace


Interlocked Members

Interlocked Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the Interlocked type.

Expand image Public Methods

Name | Description
CompareExchange | Compares two 32-bit signed integers for equality and, if they are equal, replaces one of the values.
Decrement | Decrements the value of a specified variable and stores the result, as an atomic operation.
Exchange | Sets a 32-bit signed integer to a specified value as an atomic operation, and then returns the original value.
Increment | Increments the value of a specified variable and stores the result, as an atomic operation.

Expand image See Also

Reference

Interlocked Class
System.Threading Namespace


String.Intern Method

String.Intern Method

Retrieves the system's reference to a specified String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string Intern (
         string str
)

Parameters

str
A value that represents a specific String object.

Return Value

The system's reference, if the value of the str parameter is already interned; otherwise, a new reference to a string with the value of str.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Font.InternalLeading Property

Font.InternalLeading Property

Gets the internal leading measurement for the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int InternalLeading { get; }

Property Value

The internal leading measurement for the current font, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


System.Runtime.InteropServices Namespace

System.Runtime.InteropServices Namespace

The System.Runtime.InteropServices namespace in the Microsoft® .NET Micro Framework provides classes and enumerations that support interoperation and platform invoke services.

Expand image Classes

 | Name | Description
Public Class | OutAttribute | Indicates that data should be marshaled from the callee back to the caller.
Public Class | StructLayoutAttribute | The StructLayoutAttribute class provides fields and properties you can use to control the physical layout of the data fields of a class or structure.

Expand image Enumerations

 | Name | Description
Public Enumeration | CharSet | Dictates which character set marshaled strings should use.
Public Enumeration | LayoutKind | Controls the layout of an object exported to unmanaged code.

Expand image Remarks

Items in this namespace are for use by Microsoft Visual Studio®. You should not try to use them in your applications.


DispatcherTimer.Interval Property

DispatcherTimer.Interval Property

Gets or sets the current DispatcherTimer object's defined time interval.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TimeSpan Interval { get; set; }

Property Value

The time interval between the timer's ticks, in hours:minutes:seconds. The default value is 00:00:00.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


UIElement.Invalidate Method

UIElement.Invalidate Method

Invalidates the rendering of the current element and forces a complete new layout pass.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Invalidate ()

Expand image Remarks

This method calls the InvalidateArrange method internally. The OnRender method is called after the layout cycle is completed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.InvalidateArrange Method

UIElement.InvalidateArrange Method

Invalidates the arrange state of the current element's layout.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void InvalidateArrange ()

Expand image Remarks

After the invalidation, the current element will have its layout updated, which will occur asynchronously unless the UpdateLayout method is called to force a synchronous layout change.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.InvalidateMeasure Method

UIElement.InvalidateMeasure Method

Invalidates the measurement state of the current element's layout.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void InvalidateMeasure ()

Expand image Remarks

Calling this method also calls the InvalidateArrange method internally, so there is no need to call InvalidateMeasure and InvalidateArrange in succession. After the invalidation, the element will have its layout updated, which will occur asynchronously unless the UpdateLayout method is called to force a synchronous layout change.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


InvalidCastException Class

InvalidCastException Class
See Also Members
CollapseAll image

The exception that is thrown whenever invalid casting or explicit conversion occurs.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class InvalidCastException : SystemException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidCastException Members
System Namespace


InvalidCastException Members

InvalidCastException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the InvalidCastException type.

Expand image Public Constructors

 | Name | Description
Public Method | InvalidCastException | Overloaded. Initializes a new instance of the InvalidCastException class.

Expand image See Also

Reference

InvalidCastException Class
System Namespace


InvalidOperationException Class

InvalidOperationException Class
See Also Members
CollapseAll image

The exception that is thrown when a method call is invalid for a specified object's current state.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class InvalidOperationException : SystemException

Expand image Remarks

An instance of the InvalidOperationException class is used in cases where the failure to invoke a method is caused by reasons other than invalid arguments.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InvalidOperationException Members
System Namespace


InvalidOperationException Members

InvalidOperationException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the InvalidOperationException type.

Expand image Public Constructors

 | Name | Description
Public Method | InvalidOperationException | Overloaded. Initializes a new instance of the InvalidOperationException class.

Expand image See Also

Reference

InvalidOperationException Class
System Namespace


Dispatcher.Invoke Method

Dispatcher.Invoke Method

Executes a specified delegate with a specified argument.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object Invoke (
         TimeSpan timeout,
         Delegate method,
         Object[] args
)

Parameters

timeout
The maximum amount of time the program will wait for the operation to finish.
method
A delegate to a method that takes multiple arguments, which is pushed onto the Dispatcher object's event queue.
args
[ParamArrayAttribute] An object to be passed as an argument to the specified method. This can be a null reference if no arguments are needed.

Return Value

The return value from the invoked delegate, or a null reference if the delegate has no return value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


ConstructorInfo.Invoke Method

ConstructorInfo.Invoke Method

Invokes the constructor reflected by the object that has the specified parameters, and provides default values for the parameters that are not commonly used.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
[MethodImplAttribute]
public Object Invoke (
         Object[] parameters
)

Parameters

parameters
An array of values that matches the number, order and type (under the constraints of the default binder) of the parameters for the invoked constructor. If this constructor takes no parameters, use either an array with 0 (zero) elements or a null reference, as in Object[] parameters = new Object[0]. Any object in this array that is not explicitly initialized with a value will contain the default value for that object type. For reference-type elements, this value is a null reference. For value-type elements, this value is 0, 0.0, or false, depending on the specific element type.

Return Value

An object of the type (class) associated with the invoked constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConstructorInfo Class
ConstructorInfo Members
System.Reflection Namespace


MethodBase.Invoke Method

MethodBase.Invoke Method

Invokes the method or constructor reflected by the current MethodInfo object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
[MethodImplAttribute]
public Object Invoke (
         Object obj,
         Object[] parameters
)

Parameters

obj
The object on which the method or constructor is to be invoked. If a method is static, this argument is ignored. If a constructor is static, this argument must be a null reference or an instance of the class that defines the constructor.
parameters

An argument list for the invoked method or constructor. This is an array of objects with the same number, order, and type as the parameters of the method or constructor to be invoked. If there are no parameters, parameters should be a null reference

If the method or constructor represented by this instance takes a reference parameter, no special attribute is required for that parameter to invoke the method or constructor by using this function. Any object in this array that is not explicitly initialized with a value will contain the default value for that object type. For reference-type elements, this value is a null reference. For value-type elements, this value is 0, 0.0, or false, depending on the specific element type.

Return Value

An object that contains the return value of the invoked method, or a null reference in the case of a constructor.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Type.InvokeMember Method

Type.InvokeMember Method

Invokes the specified member by using the specified binding constraints (flags) and matching the specified argument list.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
[MethodImplAttribute]
public Object InvokeMember (
         string name,
         BindingFlags invokeAttr,
         Binder binder,
         Object target,
         Object[] args
)

Parameters

name

The String object containing the name of the constructor, method, property, or field member you want to invoke.

-or-

An empty string ("") to invoke the default member.

invokeAttr
A bitmask containing one or more BindingFlags objects (binding flags) that specify how the search is conducted. You can use such binding flags as Public, NonPublic, Private, InvokeMethod, GetField, among others. You do not need to specify the type of lookup. If you omit the type of lookup, BindingFlags.Public and BindingFlags.Instance will apply by default.
binder

A Binder object that defines a set of properties and enables binding, which can involve selection of an overloaded method, coercion of argument types, or invocation of a member through reflection.

-or-

A null reference.

target
The Object object on which you want to invoke the specified member.
args
An array containing the arguments to pass to the member you want to invoke.

Return Value

An Object object representing the return value of the invoked member.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Dispatcher.InvokeShutdown Method

Dispatcher.InvokeShutdown Method

Initiates the shutdown process for a Dispatcher object (dispatcher) synchronously.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void InvokeShutdown ()

Expand image Remarks

When a program starts shutting down a Dispatcher object (a dispatcher), the ShutdownStarted event is raised and the HasShutdownStarted property is set to true. The dispatcher does not shut down completely until its event queue unwinds. When the dispatcher finishes shutting down, it raises the ShutdownFinished event and sets the HasShutdownFinished property to true.

A synchronous operation is one that must complete before the function ends. In an asynchronous operation, the function can end before the operation is complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


MFNetworkConfiguration.IpAddress Property

MFNetworkConfiguration.IpAddress Property

Gets or sets the device's network address.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress IpAddress { get; set; }

Property Value

The IP address of the device.

Expand image Version Information

Available in MFDeploy 2.0 SP1


IReflect Interface

IReflect Interface

Enables objects to return MemberInfo objects that represent other objects.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public interface IReflect

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IReflect Members
System.Reflection Namespace


IReflect Members

IReflect Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the IReflect type.

Expand image Public Methods

 | Name | Description
Public Method | GetField | Retrieves the FieldInfo object that corresponds to a specified field and BindingFlags member (binding attributes).
Public Method | GetMethod | Retrieves the MethodInfo object that corresponds to a specified method, using specified search constraints.

Expand image See Also

Reference

IReflect Interface
System.Reflection Namespace


MethodBase.IsAbstract Property

MethodBase.IsAbstract Property

Gets a value that indicates whether the current method is abstract.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsAbstract { get; }

Property Value

true if the current method is abstract; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Type.IsAbstract Property

Type.IsAbstract Property

Gets a value indicating whether the current type is abstract and must be overridden.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsAbstract { get; }

Property Value

true if the current type is abstract; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Thread.IsAlive Property

Thread.IsAlive Property

Gets a value that indicates the execution status of the current thread.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsAlive { get; }

Property Value

true if the current thread has started executing and has not terminated normally; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


WeakReference.IsAlive Property

WeakReference.IsAlive Property

Determines whether the object referenced by the current WeakReference object has been collected by the garbage collection mechanism.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsAlive { get; }

Property Value

true if the object referenced by the current object has not collected as garbage and is still accessible; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakReference Class
WeakReference Members
System Namespace


UIElement.IsArrangeValid Property

UIElement.IsArrangeValid Property

Gets a value indicating whether the computed size and position of child elements in this element's layout are valid.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsArrangeValid { get; }

Property Value

true if the size and position of layout are valid; otherwise, false.

Expand image Remarks

You can force arrangement to be invalidated by calling InvalidateArrange on this element (or its parents). This flags the layout for recomposition at such time as the layout system determines. Alternatively, an immediate call to UpdateLayout could be made, but this should only be done if it is certain that no further invalidations are pending (a large number of unnecessarily forced updates has performance consequences).

The IsArrangeValid property cannot be true unless IsMeasureValid is also true (in the layout process, arrangement cannot be valid without measurement first being valid).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Type.IsArray Property

Type.IsArray Property

Gets a value indicating whether the current type is an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsArray { get; }

Property Value

true if the current type is an array; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Debugger.IsAttached Property

Debugger.IsAttached Property

Gets a value that indicates whether a debugger is attached to the current process.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool IsAttached { get; }

Property Value

true if a debugger is attached to the current process; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debugger Class
Debugger Members
System.Diagnostics Namespace


ButtonDevice.IsButtonDown Method

ButtonDevice.IsButtonDown Method

Determines whether a specified button has been pressed.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsButtonDown (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button to be inspected.

Return Value

true if the specified button has been pressed; otherwise, false.

Expand image Remarks

The IsButtonDown method determines only whether the specified button has been pressed, whereas the IsButtonHeld method determines whether the specified button has been pressed and whether it remained in the down position for a period of time when it was pressed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


Buttons.IsButtonDown Method

Buttons.IsButtonDown Method

Determines whether a specifed button is currently pressed down.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static bool IsButtonDown (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button whose current state you want to determine.

Return Value

true if the specified button is currently pressed down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


ButtonDevice.IsButtonHeld Method

ButtonDevice.IsButtonHeld Method

Determines whether the specified button has been pressed and whether it remained in the down position for a period of time when it was pressed.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsButtonHeld (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button to be inspected.

Return Value

true if the specified button has been pressed and if it remained in the down position for a period of time when it was pressed; otherwise, false.

Expand image Remarks

The IsButtonHeld method determines whether the specified button has been pressed and whether it remained in the down position for a period of time, whereas the IsButtonDown method determines only whether the specified button has been pressed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


Buttons.IsButtonHeld Method

Buttons.IsButtonHeld Method

Determines whether the specified button is currently being held down.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static bool IsButtonHeld (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button whose current state you want to determine.

Return Value

true if the specified button is currently being held down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


ButtonDevice.IsButtonUp Method

ButtonDevice.IsButtonUp Method

Determines whether a specified button is currently in the up position (that is, not pressed down).

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsButtonUp (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button to be inspected.

Return Value

true if the specified button is not currently pressed down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


Buttons.IsButtonUp Method

Buttons.IsButtonUp Method

Determines whether a specified button is currently in the up position (that is, not pressed down).

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static bool IsButtonUp (
         Button button
)

Parameters

button
A value of the Button enumeration that identifies the button whose current state you want to determine.

Return Value

true if the specified button is not currently pressed down; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


Type.IsClass Property

Type.IsClass Property

Gets a value indicating whether the current type is a class, and not a value type or an interface.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsClass { get; }

Property Value

true if the current type is a class; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


CLSCompliantAttribute.IsCompliant Property

CLSCompliantAttribute.IsCompliant Property

Gets the Boolean value indicating whether the specified program element is CLS-compliant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsCompliant { get; }

Property Value

true if the specified program element is CLS-compliant; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CLSCompliantAttribute Class
CLSCompliantAttribute Members
System Namespace


TimeZone.IsDaylightSavingTime Method

TimeZone.IsDaylightSavingTime Method

Returns a value that indicates whether a specified date and time is in a daylight saving time period.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual bool IsDaylightSavingTime (
         DateTime time
)

Parameters

time
The specified date and time.

Return Value

true if the time parameter is in a daylight saving time period; otherwise, false. Note that if time is a null reference, the return value is false.

Expand image Remarks

The year to which the daylight saving time period applies is derived from the time parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


InputProviderSite.IsDisposed Property

InputProviderSite.IsDisposed Property

Gets a value that indicates whether the current InputProviderSite object has been disposed.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsDisposed { get; }

Property Value

true if the current InputProviderSite object has been disposed; otherwise, false.

Expand image Remarks

Disposing an object frees the resources held by the object or prepares the object for reuse. Use the Dispose method to dispose an InputProviderSite object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputProviderSite Class
InputProviderSite Members
Microsoft.SPOT.Input Namespace


DispatcherTimer.IsEnabled Property

DispatcherTimer.IsEnabled Property

Gets or sets a Boolean value that indicates whether a particular DispatcherTimer object (timer) is enabled — that is, currently running.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsEnabled { get; set; }

Property Value

true if the timer is currently running; otherwise, false. The default value is false.

Expand image Remarks

The IsEnabled property must be set to true for the Tick event to be raised.

Calling the Start method sets the IsEnabled property to true. Invoking the Stop method sets the IsEnabled property to false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


UIElement.IsEnabled Property

UIElement.IsEnabled Property

Gets or sets a value indicating whether this element is enabled in the user interface (UI).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsEnabled { get; set; }

Property Value

true if the element is enabled; otherwise, false. The default value is true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.IsEnabledChanged Event

UIElement.IsEnabledChanged Event

Occurs when the value of the IsEnabled property changes for the current element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event PropertyChangedEventHandler IsEnabledChanged

Expand image Remarks

The IsEnabledChanged event is a common language runtime (CLR) event, not a routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Type.IsEnum Property

Type.IsEnum Property

Gets a value indicating whether the current type represents an enumeration.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsEnum { get; }

Property Value

true if the current type represents an enumeration; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


ObsoleteAttribute.IsError Property

ObsoleteAttribute.IsError Property

Gets a Boolean value that indicates whether the compiler will treat the use of the obsolete program element as an error.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsError { get; }

Property Value

true if the use of the obsolete element is considered an error; otherwise, false. Note that the default return value is false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


MethodBase.IsFinal Property

MethodBase.IsFinal Property

Gets a value that indicates whether the current method is final.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsFinal { get; }

Property Value

true if the current method is final; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Array.IsFixedSize Property

Array.IsFixedSize Property

Gets a value indicating whether a specific array has a fixed size.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsFixedSize { get; }

Property Value

true for all arrays.

Expand image Remarks

An array implements the IsFixedSize property because this is required by the System.Collections.IList interface.

If an array has a fixed size, you cannot add objects to it or remove objects from it, but you can modify any of the existing objects in the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.IsFixedSize Property

ArrayList.IsFixedSize Property

Gets a value indicating whether the ArrayList collection has a fixed size.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsFixedSize { get; }

Property Value

true if the ArrayList collection has a fixed size; otherwise, false. The default return value is false.

Expand image Remarks

After a collection with a fixed size is created, you cannot add objects to it or remove objects from it. You can, however, modify existing objects in the collection.

A collection with a fixed size is simply a collection with a wrapper that prevents the adding or removing of objects. Therefore, if changes are made to the underlying collection, including the addition or removal of elements, the fixed-size collection reflects those changes.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


IList.IsFixedSize Property

IList.IsFixedSize Property

When implemented by a class, this property gets a value indicating whether the IList collection has a fixed size.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract bool IsFixedSize { get; }

Property Value

true if the IList collection has a fixed size; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


UIElement.IsFocused Property

UIElement.IsFocused Property

Gets a value that determines whether this element has logical focus.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsFocused { get; }

Property Value

true if this element has logical focus; otherwise, false.

Expand image Remarks

Logical focus might differ from keyboard focus if an application has multiple focus divisions, such as between menu contents and the remainder of the application. In this scenario, keyboard focus can only be on one element of the application UI, however, certain elements in other focus divisions might still retain logical focus.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Type.IsInstanceOfType Method

Type.IsInstanceOfType Method

Determines whether the specified object is an instance of the current type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual bool IsInstanceOfType (
         Object o
)

Parameters

o
The object you want to compare with the current type.

Return Value

true if the current type is in the inheritance hierarchy of the object represented by the o parameter, or if the current type is an interface that o supports; false if neither of the preceding conditions is the case, or if o is a null reference.

Expand image Remarks

This method can be overridden by a derived class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Type.IsInterface Property

Type.IsInterface Property

Gets a value indicating whether the current type is an interface, and not a class or a value type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsInterface { get; }

Property Value

true if the current type is an interface; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


String.IsInterned Method

String.IsInterned Method

Retrieves a reference to a specified String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static string IsInterned (
         string str
)

Parameters

str
A value that represents a specific String object.

Return Value

A reference to the specified String object if it is found in the common language runtime (CLR) intern pool; otherwise, a null reference.

Expand image Remarks

The CLR automatically maintains a table, called the "intern pool", that contains a single instance of each unique literal string constant declared in a program, as well as any unique String objects that you add programmatically.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DebuggableAttribute.IsJITOptimizerDisabled Property

DebuggableAttribute.IsJITOptimizerDisabled Property

Gets a value that indicates whether the runtime optimizer is disabled.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsJITOptimizerDisabled { get; }

Property Value

true if the runtime optimizer is disabled; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


DebuggableAttribute.IsJITTrackingEnabled Property

DebuggableAttribute.IsJITTrackingEnabled Property

Gets a value that indicates whether the runtime will track information for the debugger during code generation.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsJITTrackingEnabled { get; }

Property Value

true if the runtime will track information for the debugger during code generation; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggableAttribute Class
DebuggableAttribute Members
System.Diagnostics Namespace


StagingAreaInputItem.IsMarker Field

StagingAreaInputItem.IsMarker Field

Indicates whether the input is used as a marker.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsMarker

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StagingAreaInputItem Class
StagingAreaInputItem Members
Microsoft.SPOT.Input Namespace


UIElement.IsMeasureValid Property

UIElement.IsMeasureValid Property

Gets a value indicating whether the current size returned by layout measure is valid.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsMeasureValid { get; }

Property Value

true if the measure pass of layout returned a valid and current value; otherwise, false.

Expand image Remarks

You can force measurement and arrangement to be invalidated by calling InvalidateMeasure on this element (or its parents). This flags the layout for recomposition at such time as the layout system determines. Alternatively, an immediate call to UpdateLayout could be made, but this should only be done if it is certain that no further invalidations are pending (a large number of unnecessarily forced updates has performance consequences).

If IsMeasureValid is false, IsArrangeValid must also be false (by the enforced logic of the layout process, arrangement cannot be valid without measurement first being valid).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


CultureInfo.IsNeutralCulture Property

CultureInfo.IsNeutralCulture Property

Gets a value that indicates whether the current CultureInfo object represents a neutral culture.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsNeutralCulture { get; }

Property Value

true if the current CultureInfo object represents a neutral culture; otherwise, false.

Expand image Remarks

A neutral culture is a culture that is associated with a particular language but not with a particular country or region. A specific culture is a culture that is associated with both a particular language and a particular country or region. For example, "fr" is a neutral culture and "fr-FR" is a specific culture. Note that both "zh-CHS" (Simplified Chinese) and "zh-CHT" (Traditional Chinese) are neutral cultures.

Note
This method currently returns false for neutral cultures that do not have a dash (the '-' character) in their names. This is a known issue that is scheduled to be fixed in subsequent releases of the .NET Micro Framework.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


Type.IsNotPublic Property

Type.IsNotPublic Property

Gets a value indicating whether the top-level type is not declared as a public type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsNotPublic { get; }

Property Value

true if the top-level type is not declared as a public type; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


MethodBase.IsPublic Property

MethodBase.IsPublic Property

Gets a value that indicates whether the current method is public.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsPublic { get; }

Property Value

true if the current method is public; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Type.IsPublic Property

Type.IsPublic Property

Gets a value indicating whether the top-level type is declared as a public type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsPublic { get; }

Property Value

true if the top-level type is declared as a public type; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Array.IsReadOnly Property

Array.IsReadOnly Property

Gets a value indicating whether a specific array is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsReadOnly { get; }

Property Value

false for all arrays.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.IsReadOnly Property

ArrayList.IsReadOnly Property

Gets a value indicating whether the ArrayList collection is read-only.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsReadOnly { get; }

Property Value

true if the ArrayList collection is read-only; otherwise, false. The default return value is false.

Expand image Remarks

You cannot add, remove, or modify any of the objects in a read-only collection after it has been created.

A read-only collection is simply a collection with a wrapper that prevents objects in the collection from being added, removed, or modified. Therefore, if changes are made to the underlying collection, the read-only collection reflects those changes.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


IList.IsReadOnly Property

IList.IsReadOnly Property

When implemented by a class, this property gets a value indicating whether the IList collection is read-only.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract bool IsReadOnly { get; }

Property Value

true if the IList collection is read-only; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ButtonEventArgs.IsRepeat Property

ButtonEventArgs.IsRepeat Property

Gets a value that indicates whether the button input is currently repeating.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsRepeat { get; }

Property Value

true if the button input is currently repeating; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members
Microsoft.SPOT.Input Namespace


ListBoxItem.IsSelectable Property

ListBoxItem.IsSelectable Property

Gets or sets a value that indicates whether a particular ListBoxItem object can be selected.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsSelectable { get; set; }

Property Value

true if the ListBoxItem object can be selected; otherwise, false. The default is true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItem Class
ListBoxItem Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItem.IsSelected Property

ListBoxItem.IsSelected Property

Gets a value that indicates whether a particular ListBoxItem object is currently selected.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsSelected { get; }

Property Value

true if the ListBoxItem object is currently selected; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItem Class
ListBoxItem Members
Microsoft.SPOT.Presentation.Controls Namespace


Type.IsSerializable Property

Type.IsSerializable Property

Gets a value indicating whether the current type is serializable.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsSerializable { get; }

Property Value

true if the current type is serializable; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


MethodBase.IsStatic Property

MethodBase.IsStatic Property

Gets a value that indicates whether the current method is static.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsStatic { get; }

Property Value

true if the current method is static; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


Type.IsSubclassOf Method

Type.IsSubclassOf Method

Determines whether the current type derives from the specified type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsSubclassOf (
         Type c
)

Parameters

c
The type you want to compare with the current type.

Return Value

true if the type represented by the c parameter and the current type both represent classes, and the class represented by the current type derives from the class represented by c; otherwise, false. This method also returns false if c and the current type both represent the same class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


Array.IsSynchronized Property

Array.IsSynchronized Property

Gets a value indicating whether access to a specific array is synchronized.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

false for all arrays.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.IsSynchronized Property

ArrayList.IsSynchronized Property

Gets a value indicating whether access to the ArrayList collection is synchronized.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

true if the ArrayList collection is synchronized; otherwise, false. The default return value is false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ICollection.IsSynchronized Property

ICollection.IsSynchronized Property

When implemented by a class, this property gets a value indicating whether access to a specific ICollection collection is currently synchronized.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract bool IsSynchronized { get; }

Property Value

true if access to the collection is currently synchronized; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICollection Interface
ICollection Members
System.Collections Namespace


ListBoxItemCollection.IsSynchronized Property

ListBoxItemCollection.IsSynchronized Property

Gets a value that indicates whether access to the current collection is presently synchronized.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

true if access to the current collecton is presently synchronized; otherwise, false.

Expand image Remarks

Access to the collection is synchronized if the collection is thread-safe.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.IsSynchronized Property

TextRunCollection.IsSynchronized Property

Gets a value that indicates whether access to the current text run collection is presently synchronized.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

true if the current collection is synchronized; otherwise, false.

Expand image Remarks

The text run collection is considered synchronized if it is thread-safe.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.IsSynchronized Property

UIElementCollection.IsSynchronized Property

Gets a value that indicates whether access to the ICollection interface is synchronized (that is, thread-safe).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

true if access to the ICollection interface is synchronized; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WindowCollection.IsSynchronized Property

WindowCollection.IsSynchronized Property

Gets a value that indicates whether a particular window collection is thread-safe.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual bool IsSynchronized { get; }

Property Value

true if the window collection is thread-safe; otherwise, false.

Expand image Remarks

A progamming element or routine is considered thread-safe if it can be executed from multiple threads simultaneously.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


Reflection.IsTypeLoaded Method

Reflection.IsTypeLoaded Method

Indicates whether a specified type is loaded.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool IsTypeLoaded (
         Type t
)

Parameters

t
The type you want to check for.

Return Value

true if the specified type is loaded; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


Type.IsValueType Property

Type.IsValueType Property

Gets a value indicating whether the current type is a value type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsValueType { get; }

Property Value

true if the current type is a value type; otherwise, false.

Expand image Remarks

Value types are those types that are represented as sequences of bits; they are not classes or interfaces. Note that value types are referred to as "structs" in some programming languages. Enums are a special category of value types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


MethodBase.IsVirtual Property

MethodBase.IsVirtual Property

Gets a value that indicates whether the current method is virtual.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool IsVirtual { get; }

Property Value

true if the current method is virtual; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


UIElement.IsVisible Property

UIElement.IsVisible Property

Gets a value indicating whether this element is visible in the user interface (UI).

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool IsVisible { get; }

Property Value

true if the element is visible; otherwise, false.

Expand image Remarks

Determination of the IsVisible value takes all factors of layout into account. In contrast, the Visibility property, which is settable, only indicates the intention to programmatically make an element visible or invisible.

Elements where IsVisible is false do not participate in input events (or commands), do not influence either the "measure" or "arrange" passes of layout, are not focusable, and are not in a tab sequence.

IsVisible is not intended to be used as a style trigger. Using IsVisible as a style trigger might have unpredicable results. IsVisible is intended for state checking by lower level input implementations.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.IsVisibleChanged Event

UIElement.IsVisibleChanged Event

Occurs when the value of the IsVisible property changes for the current element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event PropertyChangedEventHandler IsVisibleChanged

Expand image Remarks

The IsVisibleChanged event is not raised if the current element is not being rendered by the layout system, for reasons other than the value of the IsVisible property. For example, the element might not have an associated visual component.

The IsVisibleChanged event is a common language runtime (CLR) event, not a routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


ArrayList.Item Property

ArrayList.Item Property

Gets or sets the object at the specified index number in the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object this [
         int index
] { get; set; }

Parameters

index
The zero-based index number of the object you want to get or set.

Property Value

The object at the specified index number in the ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


IList.Item Property

IList.Item Property

When implemented by a class, this property gets or sets the object at the specified index number in the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Object this [
         int index
] { get; set; }

Parameters

index
The zero-based index number of the object you want to get or set.

Property Value

The object at the specified index number in the IList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Item Property

ListBoxItemCollection.Item Property

Gets or sets a specified item (element) in the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBoxItem Item { get; set; }

Property Value

The specified item in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Item Property

TextRunCollection.Item Property

Gets or sets a specified object in the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextRun Item { get; set; }

Property Value

The TextRun object to be retrieved or set.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Item Property

UIElementCollection.Item Property

Gets or sets the element that is stored at a specified index number (position) in the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement this [
         int index
] { get; set; }

Parameters

index
The index number in the current collection whose corresponding element you want to retrieve.

Property Value

The UIElement object that represents the element stored at the specified index number in the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WindowCollection.Item Property

WindowCollection.Item Property

Gets the Window object at a specified index number in a particular window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Window Item { get; }

Property Value

The Window object at the specified index number in the window collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


ListBox.Items Property

ListBox.Items Property

Gets the collection used to generate the contents of the current list box.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBoxItemCollection Items { get; }

Property Value

The collection used to generate the contents of the current list box.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


Thread.Join Method (TimeSpan)

Thread.Join Method (TimeSpan)
See Also
CollapseAll image

Blocks the calling thread until the current thread terminates or until a specified amount of time elapses.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Join (
         TimeSpan timeout
)

Parameters

timeout
A TimeSpan object set to the amount of time you want the system to wait for the thread to terminate.

Return Value

true if the current thread has terminated; false if the thread has not terminated after the amount of time specified in the millisecondsTimeout parameter has elapsed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Thread.Join Method (Int32)

Thread.Join Method (Int32)
See Also
CollapseAll image

Blocks the calling thread until the current thread terminates or until a specified amount of time elapses.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Join (
         int millisecondsTimeout
)

Parameters

millisecondsTimeout
The number of milliseconds you want the system to wait for the thread to terminate.

Return Value

true if the current thread has terminated; false if the thread has not terminated after the amount of time specified in the millisecondsTimeout parameter has elapsed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Thread.Join Method ()

Thread.Join Method ()
See Also
CollapseAll image

Blocks the calling thread until the current thread terminates.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Join ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Thread.Join Method

Thread.Join Method

Blocks the calling thread until the current thread terminates.

Expand image Overload List

Name | Description
Thread.Join () | Blocks the calling thread until the current thread terminates.
Thread.Join (Int32) | Blocks the calling thread until the current thread terminates or until a specified amount of time elapses.
Thread.Join (TimeSpan) | Blocks the calling thread until the current thread terminates or until a specified amount of time elapses.

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


AssemblyKeyFileAttribute.KeyFile Property

AssemblyKeyFileAttribute.KeyFile Property

Gets the name of the file containing the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string KeyFile { get; }

Property Value

A string containing the name of the file that contains the key pair.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyFileAttribute Class
AssemblyKeyFileAttribute Members
System.Reflection Namespace


AssemblyKeyNameAttribute.KeyName Property

AssemblyKeyNameAttribute.KeyName Property

Gets the name of the container holding the key pair that is used to generate a strong name for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string KeyName { get; }

Property Value

A string containing the name of the container that holds the relevant key pair.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyKeyNameAttribute Class
AssemblyKeyNameAttribute Members
System.Reflection Namespace


ExtendedTimer.LastExpiration Property

ExtendedTimer.LastExpiration Property

Gets the System.TimeSpan value of the last expiration of the current timer.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public TimeSpan LastExpiration { get; }

Property Value

The System.TimeSpan value of the last expiration of the current timer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimer Class
ExtendedTimer Members
Microsoft.SPOT Namespace


String.LastIndexOf Method (Char, Int32, Int32)

String.LastIndexOf Method (Char, Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence in the current String object of a specified Unicode character within a specified substring. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         char value,
         int startIndex,
         int count
)

Parameters

value
The Unicode character you want to find.
startIndex
The starting index number of the substring you want to search.
count
The number of character positions to be examined.

Return Value

The character position of the value parameter if the specified character is found, or -1 if it is not found.

Expand image Remarks

The search begins at the startIndex character position in the current String object and proceeds backward toward the beginning of the string until either value is found or the number of character positions specified in the count parameter have been examined (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method (String)

String.LastIndexOf Method (String)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence of a specified String object in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         string value
)

Parameters

value
The String object you want to find.

Return Value

The character position of the value parameter if the specified String object is found, or -1 if it is not found.

Expand image Remarks

The search begins at the last character position in the current String object and proceeds backward toward the beginning of the string until either the value parameter is found or the beginning of the string is reached (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method (Char)

String.LastIndexOf Method (Char)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence of a specified Unicode character in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         char value
)

Parameters

value
The Unicode character you want to find.

Return Value

The character position of the value parameter if the specified character is found, or -1 if it is not found.

Expand image Remarks

Index numbering starts at 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method (String, Int32)

String.LastIndexOf Method (String, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence of a specified String object in the current String object. The search starts at a specified character position.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         string value,
         int startIndex
)

Parameters

value
The String object you want to find.
startIndex
The starting index number for the search.

Return Value

The character position of the value parameter if the specified String object is found, or -1 if it is not found. If value is set to Empty, the return value is startIndex.

Expand image Remarks

The search begins at the startIndex character position in the current String object and proceeds backward toward the beginning of the string until either the value parameter is found or the beginning of the string is reached (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method (String, Int32, Int32)

String.LastIndexOf Method (String, Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence of a specified String object in the current String object. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         string value,
         int startIndex,
         int count
)

Parameters

value
The String object you want to find.
startIndex
The starting index number for the search.
count
The number of character positions to be examined.

Return Value

The character position of the value parameter if the specified String object is found, or -1 if it is not found. If value is set to Empty, the return value is startIndex.

Expand image Remarks

The search begins at the startIndex character position in the current String object and proceeds backward toward the beginning of the string until either value is found or the number of character positions specified in the count parameter have been examined (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method (Char, Int32)

String.LastIndexOf Method (Char, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence of a specified Unicode character in the current String object. The search starts at a specified character position.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOf (
         char value,
         int startIndex
)

Parameters

value
The Unicode character you want to find.
startIndex
The starting index number for the search.

Return Value

The character position of the value parameter if the specified character is found, or -1 if it is not found.

Expand image Remarks

The search begins at startIndex and proceeds backward toward the beginning of the string until either value is found or the first character position has been examined (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the value parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOf Method

String.LastIndexOf Method

Reports the index number, or character position, of the last occurrence of a specified Unicode character or String object in the current String object.

Expand image Overload List

Name | Description
String.LastIndexOf (Char) | Reports the index number, or character position, of the last occurrence of a specified Unicode character in the current String object.
String.LastIndexOf (Char, Int32) | Reports the index number, or character position, of the last occurrence of a specified Unicode character in the current String object. The search starts at a specified character position.
String.LastIndexOf (Char, Int32, Int32) | Reports the index number, or character position, of the last occurrence in the current String object of a specified Unicode character within a specified substring. The search starts at a specified character position and examines a specified number of character positions.
String.LastIndexOf (String) | Reports the index number, or character position, of the last occurrence of a specified String object in the current String object.
String.LastIndexOf (String, Int32) | Reports the index number, or character position, of the last occurrence of a specified String object in the current String object. The search starts at a specified character position.
String.LastIndexOf (String, Int32, Int32) | Reports the index number, or character position, of the last occurrence of a specified String object in the current String object. The search starts at a specified character position and examines a specified number of character positions.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOfAny Method (Char[], Int32, Int32)

String.LastIndexOfAny Method (Char[], Int32, Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters. The search starts at a specified character position and examines a specified number of character positions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOfAny (
         char[] anyOf,
         int startIndex,
         int count
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.
startIndex
The starting index number for the search.
count
The number of character positions to be examined.

Return Value

The character position of the last occurrence in the current String object of any character within the specified array, or -1 if no such character is found.

Expand image Remarks

The search begins at the startIndex character position in the current String object and proceeds backward toward the beginning of the string until either a character in the anyOf parameter is found or the number of character positions specified in the count parameter have been examined (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOfAny Method (Char[])

String.LastIndexOfAny Method (Char[])
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOfAny (
         char[] anyOf
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.

Return Value

The character position of the last occurrence in the current String object of any character specified in the anyOf parameter, or -1 if no such character is found.

Expand image Remarks

The search begins at the last character position in the current String object and proceeds backward toward the beginning of the string until either a character specified in the anyOf parameter is found or the first character position has been examined (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOfAny Method (Char[], Int32)

String.LastIndexOfAny Method (Char[], Int32)
See Also
CollapseAll image

Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public int LastIndexOfAny (
         char[] anyOf,
         int startIndex
)

Parameters

anyOf
An array of Unicode characters, any one or more of whose characters you want to find in the current String object.
startIndex
The starting index number for the search.

Return Value

The character position of the last occurrence in the current String object of any character within the specified array, or -1 if no such character is found.

Expand image Remarks

The search begins at the first character position in the current String object and proceeds backward toward the beginning of the string until either the anyOf parameter is found or the beginning of the string is reached (whichever occurs first).

Index numbering starts at 0 (zero).

The search for the anyOf parameter is both case-sensitive and culture-sensitive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.LastIndexOfAny Method

String.LastIndexOfAny Method

Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.

Expand image Overload List

Name | Description
String.LastIndexOfAny (Char[]) | Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.
String.LastIndexOfAny (Char[], Int32) | Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.
String.LastIndexOfAny (Char[], Int32, Int32) | Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters. The search starts at a specified character position and examines a specified number of character positions.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


LayoutKind Enumeration

LayoutKind Enumeration

Controls the layout of an object exported to unmanaged code.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum LayoutKind

Expand image Members

Member name | Description
Auto | A value that causes the common language runtime (CLR) to choose an appropriate layout for the members of an object in unmanaged memory automatically. You should not attempt to expose objects defined with this enumeration member outside of managed code. Any such attempt will generate an exception.
Explicit | A value that causes the precise position of each member of an object in unmanaged memory to be controlled explicitly .
Sequential | A value that causes the members of an object to be laid out sequentially, in the order in which they appear when exported to unmanaged memory.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Runtime.InteropServices Namespace


Window.Left Property

Window.Left Property

Gets or sets the position of the current window's left edge in relation to the desktop.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Left { get; set; }

Property Value

The position of the current window's left edge, in logical units (1/96th of an inch).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


Array.Length Property

Array.Length Property

Gets a 32-bit integer that represents the total number of objects in all the dimensions of a specific array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Length { get; }

Property Value

A 32-bit integer that represents the total number of elements in all the dimensions of the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


String.Length Property

String.Length Property

Gets the number of characters in the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Length { get; }

Property Value

The number of characters in the current String object.

Expand image Remarks

The Length property returns the number of Char objects in the current String object, not the number of Unicode characters. This is because a particular Unicode character might be represented by more than one Char object (standard character).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DateTime.operator < Method

DateTime.operator < Method

Determines whether one DateTime object is less than another one.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator < (
         DateTime t1,
         DateTime t2
)

Parameters

t1
A DateTime value that represents the first operand.
t2
A DateTime value that represents the second operand.

Return Value

true if the t1 object is less than the t2 object; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator < Method

TimeSpan.operator < Method

Determines whether a specified TimeSpan object (time period) is less than another specified TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator < (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes the first operand.
t2
A TimeSpan object that constitutes the second operand.

Return Value

true if the object specified by the t1 parameter is less than the object specified by the t2 parameter; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.operator <= Method

DateTime.operator <= Method

Determines whether one DateTime is less than or equal to another one.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator <= (
         DateTime t1,
         DateTime t2
)

Parameters

t1
A DateTime value that represents the first operand.
t2
A DateTime value that represents the second operand.

Return Value

true if the t1 object is less than or equal to the t2 object; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator <= Method

TimeSpan.operator <= Method

Determines whether a specified TimeSpan object (time period) is less than or equal to another specified TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static bool operator <= (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes the first operand.
t2
A TimeSpan object that constitutes the second operand.

Return Value

true if the object specified by the t1 parameter is less than or equal to the object specified by the t2 parameter; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Bitmap.Line Method

Bitmap.Line Method

Draws a line connecting the two points specified by two coordinate (x,y) pairs.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void Line (
         int x1,
         int y1,
         int x2,
         int y2
)

Parameters

x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


LinearGradientBrush Class

LinearGradientBrush Class
See Also Members
CollapseAll image

Paints, or fills, an area with a linear gradient of color on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class LinearGradientBrush : Brush

Expand image Remarks

A "linear gradient of color" is a blend of colors that transistion smoothly through the range of hues. A LinearGradientBrush object paints an area with color that changes gradually along a gradient path (a linear representation of the spectrum), from a specified starting color to a specified ending color.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


LinearGradientBrush Members

LinearGradientBrush Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the LinearGradientBrush type.

Expand image Public Constructors

 | Name | Description
Public Method | LinearGradientBrush | Initializes a new instance of the LinearGradientBrush class with specified starting and ending colors and a specified gradient path.

Expand image Public Fields

 | Name | Description
Public Field | EndColor | Specifies the color at the end of the gradient path. This is the color at the point specified by the EndX and EndY fields.
Public Field | EndX | The horizontal coordinate (relative to the left edge of the area being painted) of the ending point of the gradient path. The default value is 1, which is the right edge of the area.
Public Field | EndY | The vertical coordinate (relative to the top edge of the area being painted) of the ending point of the gradient path. The default value is 1, which is the bottom edge of the area.
Public Field | StartColor | Specifies the color at the beginning of the gradient path. This is the color at the point specified by the StartX and StartY fields.
Public Field | StartX | The horizontal coordinate (relative to the left edge of the area being painted) of the starting point of the gradient path. The default value is 0 (zero), which is the left edge of the area.
Public Field | StartY | The vertical coordinate (relative to the top edge of the area being painted) of the starting point of the gradient path. The default value is 0 (zero), which is the top edge of the area.

Expand image See Also

Reference

LinearGradientBrush Class
Microsoft.SPOT.Presentation.Media Namespace


TextFlow.LineCount Property

TextFlow.LineCount Property

Gets the number of lines into which text is to flow.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int LineCount { get; }

Property Value

The number of lines into which text is to flow.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineDown Method

ScrollViewer.LineDown Method

Scrolls the contents (controls) of a ScrollViewer object downward by one line.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void LineDown ()

Expand image Remarks

The amount to scroll is determined by the value of the LineHeight property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineHeight Property

ScrollViewer.LineHeight Property

Gets or sets the height, in pixels, of one line in a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int LineHeight { get; set; }

Property Value

The height, in pixels, of a single line in a ScrollViewer object.

Expand image Remarks

The LineHeight property specifies the number of pixels that the ScrollViewer object scrolls its contents up or down whenever the program calls the LineUp method or the LineDown method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


Text.LineHeight Property

Text.LineHeight Property

Gets the height of a line of text in the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int LineHeight { get; }

Property Value

The height of a line of text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineLeft Method

ScrollViewer.LineLeft Method

Scrolls the contents (controls) of a ScrollViewer object to the left by a predetermined amount.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void LineLeft ()

Expand image Remarks

The amount to scroll is determined by the value of the LineWidth property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineRight Method

ScrollViewer.LineRight Method

Scrolls the contents (controls) of a ScrollViewer object to the right by a predetermined amount.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void LineRight ()

Expand image Remarks

The amount to scroll is determined by the value of the LineWidth property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineUp Method

ScrollViewer.LineUp Method

Scrolls the contents (controls) of a ScrollViewer object upward by one line.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void LineUp ()

Expand image Remarks

The amount to scroll is determined by the value of the LineHeight property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.LineWidth Property

ScrollViewer.LineWidth Property

Gets or sets the width, in pixels, of one line in a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int LineWidth { get; set; }

Property Value

The width, in pixels, of a single line in a ScrollViewer object.

Expand image Remarks

The LineWidth property specifies the number of pixels that the ScrollViewer object scrolls its contents to the left or right whenever the program calls the LineLeft method or the LineRight method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox Class

ListBox Class
See Also Members
CollapseAll image

Implements a list of selectable items.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ListBox : ContentControl

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox Members

ListBox Members
See Also Constructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the ListBox type.

Expand image Public Constructors

 | Name | Description
Public Method | ListBox | Initializes a new instance of the ListBox class.

Expand image Public Properties

 | Name | Description
Public Property | ExtentHeight | Gets the height of a control's display area, in pixels.
Public Property | ExtentWidth | Gets the width of a control's display area, in pixels.
Public Property | HorizontalOffset | Gets or sets the horizontal offset, or displacement, of a control's content from the left edge of the display device area that contains the control.
Public Property | Items | Gets the collection used to generate the contents of the current list box.
Public Property | ScrollingStyle | Gets or sets a value that controls how the current list box is scrolled.
Public Property | SelectedIndex | Gets or sets the index number of a specified item in the current list box.
Public Property | SelectedItem | Gets or sets a specified item in the current list box.
Public Property | VerticalOffset | Gets or sets the vertical offset, or displacement, of a control's content from the top edge of the display device area that contains the control.

Expand image Public Methods

 | Name | Description
Public Method | ScrollIntoView | Scrolls a specified item into view on a display device.

Expand image Protected Methods

 | Name | Description
Protected Method | OnButtonDown | Displays an event description whenever the user presses the Up button or the Down button.

Expand image Public Events

 | Name | Description
Public Event | ScrollChanged | Occurs when a list is scrolled.
Public Event | SelectionChanged | Occurs each time a user selects a different item in a list box.

Expand image See Also

Reference

ListBox Class
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItem Class

ListBoxItem Class
See Also Members
CollapseAll image

Implements a selectable item inside a ListBox object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ListBoxItem : ContentControl

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItem Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItem Members

ListBoxItem Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the ListBoxItem type.

Expand image Public Constructors

 | Name | Description
Public Method | ListBoxItem | Initializes a new instance of the ListBoxItem class.

Expand image Public Properties

 | Name | Description
Public Property | IsSelectable | Gets or sets a value that indicates whether a particular ListBoxItem object can be selected.
Public Property | IsSelected | Gets a value that indicates whether a particular ListBoxItem object is currently selected.

Expand image See Also

Reference

ListBoxItem Class
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItemCollection Class

ListBoxItemCollection Class
See Also Members
CollapseAll image

Contains a group of ListBoxItem objects.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public class ListBoxItemCollection : ICollection, IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBoxItemCollection Members

ListBoxItemCollection Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the ListBoxItemCollection type.

Expand image Public Constructors

 | Name | Description
Public Method | ListBoxItemCollection | Initializes an instance of the ListBoxItemCollection class.

Expand image Public Properties

 | Name | Description
Public Property | Count | Gets the number of items (elements) in the current collection.
Public Property | IsSynchronized | Gets a value that indicates whether access to the current collection is presently synchronized.
Public Property | Item | Gets or sets a specified item (element) in the current collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the current collection.

Expand image Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item (element) to the current collection.
Public Method | Clear | Empties the current collection.
Public Method | Contains | Determines whether a specified item (element) is contained in the current collection.
Public Method | CopyTo | Copies all or part of the current collection into a specified array.
Public Method | GetEnumerator | Retrieves an enumerator that can be used to iterate through the current collection.
Public Method | IndexOf | Retrieves the index number of a specified item (element) if that item is found in the current collection.
Public Method | Insert | Inserts an item (element) into the current collection.
Public Method | Remove | Removes a specified item from the current collection.
Public Method | RemoveAt | Removes the item (element) at a specified index number in the current collection.

Expand image See Also

Reference

ListBoxItemCollection Class
Microsoft.SPOT.Presentation.Controls Namespace


Assembly.Load Method (String)

Assembly.Load Method (String)
See Also
CollapseAll image

Loads a specified assembly, given the long form of the assembly name.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static Assembly Load (
         string assemblyString
)

Parameters

assemblyString
The long form of the assembly name.

Return Value

The assembly that was loaded.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


AppDomain.Load Method

AppDomain.Load Method

Loads an assembly into the specified application domain, using the assembly's display name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public Assembly Load (
         string assemblyString
)

Parameters

assemblyString
The display name of the assembly.

Return Value

The loaded assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


Assembly.Load Method

Assembly.Load Method

Loads a specified assembly.

Expand image Overload List

Name | Description
Assembly.Load (Byte[]) | Loads a specified "raw" assembly with a Common Object File Format (COFF)-based image containing an emitted assembly.
Assembly.Load (String) | Loads a specified assembly, given the long form of the assembly name.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Assembly.Load Method (Byte[])

Assembly.Load Method (Byte[])
See Also
CollapseAll image

Loads a specified "raw" assembly with a Common Object File Format (COFF)-based image containing an emitted assembly.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Assembly Load (
         byte[] rawAssembly
)

Parameters

rawAssembly
A byte array that is a COFF-based image containing an emitted assembly.

Return Value

The assembly that was loaded.

Expand image Remarks

When you use this method, the specified assembly is loaded into the domain of the caller.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Assembly Class
Assembly Members
System.Reflection Namespace


Logging Class

Logging Class
See Also Members
CollapseAll image

Provides methods and properties for managing logged data.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static class Logging

Expand image Remarks

This class cannot be inherited.

The use of this class is currently not supported and is not recommended.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Logging Members
Microsoft.SPOT Namespace


Logging Members

Logging Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the Logging type.

Expand image Public Properties

Name | Description
NumberOfRecords | Gets the number of Logging objects (log records) in the current list of records.

Expand image Public Methods

Name | Description
AppendRecord | Adds a Logging object (log record) at the end of the list of log records.
Erase | Erases all Logging objects (log records).
GetRecord | Gets a Logging object (log record) from the zero-based list of log records.

Expand image Remarks

The use of this class is currently not supported and is not recommended.

Expand image See Also

Reference

Logging Class
Microsoft.SPOT Namespace


UIElement.LogicalChildren Property

UIElement.LogicalChildren Property

Gets an enumerator for this element's logical child elements.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected UIElementCollection LogicalChildren { get; }

Property Value

A UIElementCollectionenumerator for this element's logical child elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


DateTimeFormatInfo.LongDatePattern Property

DateTimeFormatInfo.LongDatePattern Property

Gets the format pattern for a long date value, which is associated with the "D" format character.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string LongDatePattern { get; }

Property Value

The format pattern for a long date value, which is associated with the "D" format character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTimeFormatInfo.LongTimePattern Property

DateTimeFormatInfo.LongTimePattern Property

Gets the format pattern for a long time value, which is associated with the "T" format character.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string LongTimePattern { get; }

Property Value

The format pattern for a long time value, which is associated with the "T" format character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


Buttons.LostFocusEvent Field

Buttons.LostFocusEvent Field

Specifies the bubbling-routed event that occurs when a display element on a button device loses the button focus.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent LostFocusEvent

Expand image Remarks

The LostFocusEvent field specifies a routed event that uses the bubbling routing strategy. The event handler for this event is represented by the FocusChangedEventHandler Delegate delegate.

Button focus refers to state of the display element that is currently receiving input from a button device. At any specific point in time, there can be only one element on a button device's display that has the button focus.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


MFNetworkConfiguration.MacAddress Property

MFNetworkConfiguration.MacAddress Property

Gets or sets the device's MAC address.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public byte [] MacAddress { get; set; }

Property Value

The MAC address of the device.

Expand image Version Information

Available in MFDeploy 2.0 SP1


Application.MainWindow Property

Application.MainWindow Property

Gets or sets the main window of the current application.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Window MainWindow { get; set; }

Property Value

A Window object that represents the current application's main window.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Bitmap.MakeTransparent Method

Bitmap.MakeTransparent Method

Sets a bitmap's transparent color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void MakeTransparent (
         Color color
)

Parameters

color
The color to be used as the bitmap's transparent color.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


MarshalByRefObject Class

MarshalByRefObject Class
See Also Members
CollapseAll image

Provides access to objects across application domain boundaries in applications that support remoting.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class MarshalByRefObject

Expand image Remarks

An application domain is a partition in an operating system process; one or more applications reside in each such partition. Objects in the same application domain communicate with one another directly. Objects in different application domains communicate with one another either by transporting copies of objects across application domain boundaries or by using a proxy to exchange messages.

The MarshalByRefObject class is the base class for objects that communicate across application domain boundaries by exchanging messages through a proxy. Objects that do not inherit from the MarshalByRefObject class are implicitly marshaled by value instead. When a remote application references an object that is marshaled by value, a copy of that object is passed across application domain boundaries.

Applications access MarshalByRefObject objects directly within the boundaries of the local application domain. The first time an application in a remote application domain accesses a MarshalByRefObject object, a proxy is passed to the remote application. Subsequent calls on the proxy are marshaled back to the object that resides in the local application domain.

A type must inherit from the MarshalByRefObject class if that type is to be used across application domain boundaries. Also, you must not copy the state of a MarshalByRefObject object, because the members of the object are not usable outside the application domain in which they were created.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MarshalByRefObject Members
System Namespace


MarshalByRefObject Members

MarshalByRefObject Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the MarshalByRefObject type.

Expand image Protected Constructors

 | Name | Description
Protected Method | MarshalByRefObject | Initializes a new instance of the MarshalByRefObject class.

Expand image See Also

Reference

MarshalByRefObject Class
System Namespace


Bitmap.MaskBlt Method

Bitmap.MaskBlt Method

Combines the data for the source bitmap and the current (destination) bitmap, using the specified mask.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
[MethodImplAttribute]
public void MaskBlt (
         int xDst,
         int yDst,
         int nWidth,
         int nHeight,
         Bitmap pSrc,
         int xSrc,
         int ySrc,
         Bitmap pMask
)

Parameters

xDst
The x-coordinate of the upper-left corner of the destination rectangle.
yDst
The y-coordinate of the upper-left corner of the destination rectangle.
nWidth
The width of the source and destination rectangles.
nHeight
The height of the source and destination rectangles.
pSrc
The source bitmap.
xSrc
The x-coordinate of the upper-left corner of the source rectangle.
ySrc
The y-coordinate of the upper-left corner of the source rectangle.
pMask
A mask that specifies how the bitmaps are to be combined.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Math Class

Math Class
See Also Members
CollapseAll image

Provides static methods for common mathematical functions.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static class Math

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Members
Microsoft.SPOT Namespace


Math Members

Math Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the Math type.

Expand image Public Methods

Name | Description
Cos | Gets the cosine of the specified angle.
Random | Generates a pseudorandom number.
Randomize | Sets a random starting point for random number generation.
Sin | Gets the sine of the specified angle.

Expand image See Also

Reference

Math Class
Microsoft.SPOT Namespace


Math Class

Math Class
See Also Members
CollapseAll image

A small collection of common mathematical functions.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class Math

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Members
System Namespace


Math Members

Math Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the Math type.

Expand image Public Fields

Name | Description
E | Represents the natural logarithmic base, specified by the constant e.
PI | Represents the ratio of the circumference of a circle to its diameter, specified by the constant π.

Expand image Public Methods

Name | Description
Abs | Returns the absolute value of a specified integer.
Max | Returns the larger of two integers that have been compared with one another.
Min | Returns the smaller of two integers that have been compared with one another.

Expand image See Also

Reference

Math Class
System Namespace


Math.Max Method

Math.Max Method

Returns the larger of two integers that have been compared with one another.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Max (
         int val1,
         int val2
)

Parameters

val1
The first of two integers you want to compare.
val2
The second of two integers you want to compare.

Return Value

The larger of the two compared integers.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
System Namespace


Constants.MaxExtent Field

Constants.MaxExtent Field

Specifies the maximum extent of an image or child element.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public const int MaxExtent

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Constants Class
Constants Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.MaxHeight Field

Bitmap.MaxHeight Field

Specifies the maximum height of the display device, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int MaxHeight

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


MFNetworkConfiguration.MaxMacAddressLength Property

MFNetworkConfiguration.MaxMacAddressLength Property

Gets MAC address's length.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public int MaxMacAddressLength { get; }

Property Value

The total number of bytes used to store the MAC address.

Expand image Version Information

Available in MFDeploy 2.0 SP1


Byte.MaxValue Field

Byte.MaxValue Field

Represents the largest possible value of Byte Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const byte MaxValue

Expand image Remarks

This value of this constant is 255; that is, hexadecimal 0xFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Structure
Byte Members
System Namespace


Char.MaxValue Field

Char.MaxValue Field

Represents the largest possible value of Char Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const char MaxValue

Expand image Remarks

This value of this constant is 65535; that is, hexadecimal 0xFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Char Structure
Char Members
System Namespace


DateTime.MaxValue Field

DateTime.MaxValue Field

Represents the largest possible value for a DateTime object. Note that this field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public readonly DateTime MaxValue

Expand image Remarks

The value of this constant is equivalent to 23:59:59.9999999, December 31, 9999, exactly one tick (100 nanoseconds) before 00:00:00, January 1, 10000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Double.MaxValue Field

Double.MaxValue Field

Represents the largest possible value of Double. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const double MaxValue

Expand image Remarks

This value of this constant is 1.79769e+308.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


Int16.MaxValue Field

Int16.MaxValue Field

Represents the largest possible value of Int16 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const short MaxValue

Expand image Remarks

This value of this constant is 32,767; that is, hexadecimal 0x7FFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Structure
Int16 Members
System Namespace


Int32.MaxValue Field

Int32.MaxValue Field

Represents the largest possible value of Int32 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const int MaxValue

Expand image Remarks

This value of this constant is 2,147,483,647; that is, hexadecimal 0x7FFFFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Structure
Int32 Members
System Namespace


Int64.MaxValue Field

Int64.MaxValue Field

Represents the largest possible value of Int64 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const long MaxValue

Expand image Remarks

This value of this constant is 9,223,372,036,854,775,807; that is, hexadecimal 0x7FFFFFFFFFFFFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Structure
Int64 Members
System Namespace


TimeSpan.MaxValue Field

TimeSpan.MaxValue Field

Represents the largest possible value for a TimeSpan object. Note that this field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public readonly TimeSpan MaxValue

Expand image Remarks

The value of this field is equivalent to Int64.MaxValue ticks. The string representation of this value is 10675199.02:48:05.4775807.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


UInt16.MaxValue Field

UInt16.MaxValue Field

Represents the largest possible value of UInt16 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt16 MaxValue

Expand image Remarks

This value of this constant is 65535; that is, hexadecimal 0xFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Structure
UInt16 Members
System Namespace


UInt32.MaxValue Field

UInt32.MaxValue Field

Represents the largest possible value of UInt32 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt32 MaxValue

Expand image Remarks

This value of this constant is 4,294,967,295; that is, hexadecimal 0xFFFFFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Structure
UInt32 Members
System Namespace


UInt64.MaxValue Field

UInt64.MaxValue Field

Represents the largest possible value of UInt64 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt64 MaxValue

Expand image Remarks

This value of this constant is 18,446,744,073,709,551,615; that is, hexadecimal 0xFFFFFFFFFFFFFFFF.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Structure
UInt64 Members
System Namespace


Bitmap.MaxWidth Field

Bitmap.MaxWidth Field

Specifies the maximum width of the display device, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int MaxWidth

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Font.MaxWidth Property

Font.MaxWidth Property

Gets the width of the widest character in the current font, in pixels.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int MaxWidth { get; }

Property Value

The width of the widest character in the current font, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Font Class
Font Members
Microsoft.SPOT Namespace


UIElement.Measure Method

UIElement.Measure Method

Determines the size requirements for the layout of a child element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Measure (
         int availableWidth,
         int availableHeight
)

Parameters

availableWidth
The width of the available space that a parent element can allocate to a child element.
availableHeight
The height of the available space that a parent element can allocate to a child element.

Expand image Remarks

Calling this method constitutes the first pass of a layout update in the layout engine.

Computation of layout positioning in Windows Presentation Foundation (WPF) consists of a Measure method call and an Arrange method call. During the Measure call, an element determines its size requirements, using the specified available sizes. During the Arrange call, the element size is finalized and returned.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Border.MeasureOverride Method

Border.MeasureOverride Method

Measures the size of the space required for a particular child element, during layout.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The available width of the rectangular space that the border element can allocate to its child element.
availableHeight
The available height of the rectangular space that the border element can allocate to its child element.
desiredWidth
[OutAttribute] The optimum width of the rectangular space that the border element will allocate to its child element.
desiredHeight
[OutAttribute] The optimum height of the rectangular space that the border element will allocate its child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Canvas.MeasureOverride Method

Canvas.MeasureOverride Method

Measures the child elements in a canvas in anticipation of arranging them during the ArrangeOverride pass.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width of the layout area, in pixels.
availableHeight
The maximum available height of the layout area, in pixels.
desiredWidth
[OutAttribute] The optimum width of the layout area, in pixels.
desiredHeight
[OutAttribute] The optimum height of the layout area, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


ContentControl.MeasureOverride Method

ContentControl.MeasureOverride Method

Remeasures a control for layout on a display device.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width of the layout area, in pixels.
availableHeight
The maximum available height of the layout area, in pixels.
desiredWidth
[OutAttribute] The optimum width of the layout area, in pixels.
desiredHeight
[OutAttribute] The optimum height of the layout area, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ContentControl Class
ContentControl Members
Microsoft.SPOT.Presentation.Controls Namespace


Image.MeasureOverride Method

Image.MeasureOverride Method

Remeasures a control for layout on a display device.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width, in pixels, of the rectangular area where the bitmap can be drawn.
availableHeight
The maximum available height, in pixels, of the rectangular area where the bitmap can be drawn.
desiredWidth
[OutAttribute] The optimum width of the layout area, in pixels.
desiredHeight
[OutAttribute] The optimum height of the layout area, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


Panel.MeasureOverride Method

Panel.MeasureOverride Method

Measures the size of the layout area required for child elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The available width of the rectangular area that the panel can allocate to the child element.
availableHeight
The available height of the rectangular area that the panel can allocate to the child element.
desiredWidth
[OutAttribute] The optimum width of the rectangular area that the panel is to allocate to the child element.
desiredHeight
[OutAttribute] The optimum height of the rectangular area that the panel is to allocate to the child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Panel Class
Panel Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.MeasureOverride Method

ScrollViewer.MeasureOverride Method

Measures the contents (controls) of a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width of the rectangular area in which the controls can be contained.
availableHeight
The maximum available height of the rectangular area in which the controls can be contained.
desiredWidth
[OutAttribute] The optimum width of the rectangular area in which the controls are to be contained.
desiredHeight
[OutAttribute] The optimum height of the rectangular area in which the controls are to be contained.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


StackPanel.MeasureOverride Method

StackPanel.MeasureOverride Method

Measures the children of a StackPanel in anticipation of arranging them during the ArrangeOverride pass.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int constraintWidth,
         int constraintHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

constraintWidth
Holds a maximum width for the layout area that should not be exceeded.
constraintHeight
Holds a maximum height for the layout area that should not be exceeded.
desiredWidth
[OutAttribute] Holds the desired width of the layout area.
desiredHeight
[OutAttribute] Holds the desired height of the layout area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


Text.MeasureOverride Method

Text.MeasureOverride Method

Measures the text layout area for the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width of the rectangular text layout area.
availableHeight
The maximum available height of the rectangular text layout area.
desiredWidth
[OutAttribute] The optimum width of the text layout area.
desiredHeight
[OutAttribute] The optimum height of the text layout area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.MeasureOverride Method

TextFlow.MeasureOverride Method

Measures the rectangular area in which text is to flow.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The maximum available width of the text flow area.
availableHeight
The maximum available height of the text flow area.
desiredWidth
[OutAttribute] The optimum width of the text flow area.
desiredHeight
[OutAttribute] The optimum height of the text flow area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.MeasureOverride Method

UIElement.MeasureOverride Method

Determines the custom size requirements for the layout of a child element when implemented in a derived class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The width of the available space that a parent element can allocate to a child element.
availableHeight
The height of the available space that a parent element can allocate to a child element.
desiredWidth
[OutAttribute] The width of the space that a parent element will allocate to a child element.
desiredHeight
[OutAttribute] The height of the space that a parent element will allocate to a child element.

Expand image Remarks

You should override this virtual method to implement custom sizing behavior for your element, because it is part of the Windows Presentation Foundation (WPF) layout system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Window.MeasureOverride Method

Window.MeasureOverride Method

Measures the size of the current window for the layout of a child element when you override this method.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The width of the available space that the current window can allocate to a child element.
availableHeight
The height of the available space that the current window can allocate to a child element.
desiredWidth
[OutAttribute] The width of space that the current window requires for the layout of a child element.
desiredHeight
[OutAttribute] The height of space that the current window requires for the layout of a child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


WindowManager.MeasureOverride Method

WindowManager.MeasureOverride Method

Determines the custom size requirements for the layout of a child element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void MeasureOverride (
         int availableWidth,
         int availableHeight,
         ref int desiredWidth,
         ref int desiredHeight
)

Parameters

availableWidth
The width of the available space that a parent element can allocate to a child element.
availableHeight
The height of the available space that a parent element can allocate to a child element.
desiredWidth
[OutAttribute] The width of the space that a parent element will allocate to a child element.
desiredHeight
[OutAttribute] The height of space that a parent element will allocate to a child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowManager Class
WindowManager Members
Microsoft.SPOT.Presentation Namespace


Microsoft.SPOT.Presentation.Media Namespace

Microsoft.SPOT.Presentation.Media Namespace

The Microsoft.SPOT.Presentation.Media namespace in the Microsoft® .NET Micro Framework contains classes and enumerations that help you draw and manipulate images.

Expand image Classes

 | Name | Description
Public Class | Brush | Paints, or fills, an area or shape on the screen.
Public Class | Colors | Provides a set of predefined colors for a hardware display device.
Public Class | ColorUtility | Provides a collection of methods for working with colors.
Public Class | Constants | Provides constants that are common to all types in the Media namespace.
Public Class | DrawingContext | Provides constructors, methods, and properties you can use to generate a drawing surface and create images on that surface.
Public Class | ImageBrush | Paints, or fills, an area with an image on a hardware display device.
Public Class | LinearGradientBrush | Paints, or fills, an area with a linear gradient of color on a hardware display device.
Public Class | Pen | Creates lines, curves, and outlines of shapes on a hardware display device.
Public Class | SolidColorBrush | Paints (fills) an area with a single, uniform color on a hardware display device.

Expand image Enumerations

 | Name | Description
Public Enumeration | Color | Specifies colors for drawing or painting on a hardware display device.
Public Enumeration | Stretch | Specifies how an image is sized within its layout area on a hardware display device.
Public Enumeration | TextAlignment | Specifies the horizontal alignment of text with its layout area on a hardware display device.
Public Enumeration | TextTrimming | Specifies how characters from a string that does not completely fit into the specified layout area are to be trimmed.


MemberInfo Class

MemberInfo Class
See Also Members
CollapseAll image

Discovers the attributes of a particular member and provides access to member metadata.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class MemberInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MemberInfo Members
System.Reflection Namespace


MemberInfo Members

MemberInfo Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MemberInfo type.

Expand image Protected Constructors

 | Name | Description
Protected Method | MemberInfo | Initializes a new instance of the MemberInfo class.

Expand image Public Properties

 | Name | Description
Public Property | DeclaringType | Gets the class that declares the current member.
Public Property | MemberType | Gets the type of the current member, such as field, method, or property, for example.
Public Property | Name | Gets the name of the current member.

Expand image See Also

Reference

MemberInfo Class
System.Reflection Namespace


DefaultMemberAttribute.MemberName Property

DefaultMemberAttribute.MemberName Property

Gets the member name from the current attribute.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string MemberName { get; }

Property Value

A string that represents the member name.

Expand image Remarks

There is no set accessor because the member name must be provided to the constructor. The inclusion of the name is not optional.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DefaultMemberAttribute Class
DefaultMemberAttribute Members
System.Reflection Namespace


ConstructorInfo.MemberType Property

ConstructorInfo.MemberType Property

Gets the member type of the current object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override MemberTypes MemberType { get; }

Property Value

The MemberTypes object that represents the type of the current object.

Expand image Remarks

This property is read-only.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ConstructorInfo Class
ConstructorInfo Members
System.Reflection Namespace


FieldInfo.MemberType Property

FieldInfo.MemberType Property

Gets the type of property reflected by the current FieldInfo object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual MemberTypes MemberType { get; }

Property Value

A MemberTypes object.

Expand image Remarks

The value retrieved by this property indicates that the specified member is a field.

Use this property when testing a particular field as a generic member.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Class
FieldInfo Members
System.Reflection Namespace


MemberInfo.MemberType Property

MemberInfo.MemberType Property

Gets the type of the current member, such as field, method, or property, for example.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract MemberTypes MemberType { get; }

Property Value

An enumerated value from the MemberTypes enumeration, specifying a constructor, event, field, method, property, type, all member types, or a custom member type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MemberInfo Class
MemberInfo Members
System.Reflection Namespace


MethodInfo.MemberType Property

MethodInfo.MemberType Property

Gets a value indicating that the current member is a method.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual MemberTypes MemberType { get; }

Property Value

A MemberTypes object indicating that the current member is a method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodInfo Class
MethodInfo Members
System.Reflection Namespace


MemberTypes Enumeration

MemberTypes Enumeration

Marks each member type that is defined as a class derived from the MemberInfo class.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum MemberTypes

Expand image Members

Member name | Description
All | All member types.
Constructor | A constructor that represents a ConstructorInfo member.
Custom | A custom member type with a hexadecimal value of 0x40.
Event | An event with a hexadecimal value of 0x02.
Field | A field that represents a FieldInfo member. This field has a hexadecimal value of 0x04.
Method | A method that represents a MethodInfo member. This method has a hexadecimal value of 0x08.
NestedType | A nested type that extends the MemberInfo class.
Property | A property that represents a PropertyInfo member. This property has a hexadecimal value of 0x10.
TypeInfo | A type with a hexadecimal value of 0x20.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Reflection Namespace


Object.MemberwiseClone Method

Object.MemberwiseClone Method

Creates a shallow copy of the current instance (object) of the Object class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
protected Object MemberwiseClone ()

Return Value

A shallow copy of the current object.

Expand image Remarks

The MemberwiseClone method cannot be overridden, and it is accessible only through this class or a derived class. Use a class that implements the ICloneable interface if a deep or shallow copy of an object needs to be publicly exposed to users.

A shallow copy creates a new instance of the same type as the original object, and then it copies the nonstatic fields of the original object. If the field is a value type, a bit-by-bit copy of the field is performed. If the field is a reference type, the reference is copied but the referenced object is not, with the result that the reference in the original object and the reference in the clone point to the same object. By contrast, a deep copy of an object duplicates everything that is directly or indirectly referenced by the fields in the object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


ArgumentException.Message Property

ArgumentException.Message Property

Gets the error message associated with this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string Message { get; }

Property Value

A text string that describes the details of the exception. This string should be human-readable and localized for the current system culture.

Expand image Remarks

This property overrides the Exception.Message property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


Exception.Message Property

Exception.Message Property

Gets a message that describes the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string Message { get; }

Property Value

An error message that explains the reason for the current exception, or an empty string("").

Expand image Remarks

The text of the Message property should completely describe the error (the exception) and should, if at all possible, explain how to correct it. The value of the Message property is included in the information returned by the ToString method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


ObsoleteAttribute.Message Property

ObsoleteAttribute.Message Property

Gets the work-around message, which describes the alternative program elements that you can use.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Message { get; }

Property Value

The text string that describes the available work-arounds.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Class
ObsoleteAttribute Members
System Namespace


Delegate.Method Property

Delegate.Method Property

Gets the method represented by the current delegate.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodInfo Method { get; }

Property Value

A MethodInfo object describing the method represented by the current delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


MethodBase Class

MethodBase Class
See Also Members
CollapseAll image

Provides information about methods and constructors.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class MethodBase : MemberInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Members
System.Reflection Namespace


MethodBase Members

MethodBase Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the MethodBase type.

Expand image Protected Constructors

 | Name | Description
Protected Method | MethodBase | Initializes a new instance of the MethodBase class.

Expand image Public Properties

 | Name | Description
Public Property | DeclaringType | Gets the class that declares the current method.
Public Property | IsAbstract | Gets a value that indicates whether the current method is abstract.
Public Property | IsFinal | Gets a value that indicates whether the current method is final.
Public Property | IsPublic | Gets a value that indicates whether the current method is public.
Public Property | IsStatic | Gets a value that indicates whether the current method is static.
Public Property | IsVirtual | Gets a value that indicates whether the current method is virtual.
Public Property | Name | Gets the name of the current method.

Expand image Public Methods

 | Name | Description
Public Method | Invoke | Invokes the method or constructor reflected by the current MethodInfo object.

Expand image See Also

Reference

MethodBase Class
System.Reflection Namespace


MethodCodeType Enumeration

MethodCodeType Enumeration

Defines how a particular method is implemented.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum MethodCodeType

Expand image Members

Member name | Description
IL = 0 | A value specifying that the method implementation is in Microsoft intermediate language (MSIL).
Native = 1 | A value specifying that the method is implemented in native code.
OPTIL = 2 | A value that supports the .NET Micro Framework infrastructure and is not intended to be used directly from your code.
Runtime = 3 | A value specifying that the method implementation is provided by the common language runtime (CLR).

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Runtime.CompilerServices Namespace


MethodImplAttribute.MethodCodeType Field

MethodImplAttribute.MethodCodeType Field

Contains a MethodCodeType value that indicates what type of implementation is provided for the method being attributed.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodCodeType MethodCodeType

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


MethodImplAttribute Class

MethodImplAttribute Class
See Also Members
CollapseAll image

Specifies the details of how a particular method is implemented.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class MethodImplAttribute : Attribute

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


MethodImplAttribute Members

MethodImplAttribute Members
See Also Constructors Fields Properties
CollapseAll image

The following tables list the members exposed by the MethodImplAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | MethodImplAttribute | Overloaded. Initializes a new instance of the MethodImplAttribute class.

Expand image Public Fields

 | Name | Description
Public Field | MethodCodeType | Contains a MethodCodeType value that indicates what type of implementation is provided for the method being attributed.

Expand image Public Properties

 | Name | Description
Public Property | Value | Gets the MethodImplOptions value that describes the method being attributed.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image See Also

Reference

MethodImplAttribute Class
System.Runtime.CompilerServices Namespace


MethodImplAttributes Enumeration

MethodImplAttributes Enumeration

Contains flags for the attributes of a method implementation.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum MethodImplAttributes

Expand image Members

Member name | Description
CodeTypeMask | A flag specifying code type.
ForwardRef | A flag specifying that the method is not defined.
IL | A flag specifying that the method implementation is in Microsoft intermediate language (MSIL).
InternalCall | A flag specifying an internal call.
Managed | A flag specifying that the method implementation is managed.
ManagedMask | A flag specifying whether the code is managed or unmanaged.
MaxMethodImplVal | A flag specifying a range check value.
Native | A flag specifying that the method implementation is native.
NoInlining | A flag specifying that the method cannot be inlined.
OPTIL | A flag specifying that this member supports the .NET Micro Framework infrastructure and is not intended to be used directly from your code.
PreserveSig | A flag specifying that the method signature is exported exactly as declared.
Runtime | A flag specifying that the method implementation is provided by the runtime.
Synchronized | A flag specifying that the method is single-threaded through the body.
Unmanaged | A flag specifying that the method implementation is unmanaged.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Reflection Namespace


MethodImplOptions Enumeration

MethodImplOptions Enumeration

Defines the details of how a particular method is implemented.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum MethodImplOptions

Expand image Members

Member name | Description
ForwardRef = 16 | A value specifying that the method is declared, but its implementation is provided elsewhere.
InternalCall = 4069 | A value specifying an internal call. An internal call is a call to a method implemented within the common language runtime (CLR) itself.
NoInlining = 8 | A value specifying that the method cannot be inlined.
PreserveSig = 128 | A value specifying that the method signature is exported exactly as declared.
Synchronized = 32 | A value specifying the method can be executed by only one thread at a time.
Unmanaged = 4 | A value specifying that the method is implemented in unmanaged code.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Runtime.CompilerServices Namespace


MethodInfo Class

MethodInfo Class
See Also Members
CollapseAll image

Discovers the attributes of a particular method and provides access to method metadata.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class MethodInfo : MethodBase

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodInfo Members
System.Reflection Namespace


MethodInfo Members

MethodInfo Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the MethodInfo type.

Expand image Protected Constructors

 | Name | Description
Protected Method | MethodInfo | Initializes a new instance of the MethodInfo class.

Expand image Public Properties

 | Name | Description
Public Property | MemberType | Gets a value indicating that the current member is a method.
Public Property | ReturnType | Gets the return type of the current method.

Expand image See Also

Reference

MethodInfo Class
System.Reflection Namespace


DateTime.Millisecond Property

DateTime.Millisecond Property

Gets the milliseconds component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Millisecond { get; }

Property Value

The milliseconds, expressed as a number ranging from 0 through 999.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Milliseconds Field

SystemTime.Milliseconds Field

Specifies the milliseconds associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Milliseconds

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


TimeSpan.Milliseconds Property

TimeSpan.Milliseconds Property

Gets the number of whole milliseconds in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Milliseconds { get; }

Property Value

The number of whole milliseconds in the current TimeSpan object.

Expand image Remarks

The value of a TimeSpan object can be expressed as [-]d.hh:mm:ss.ff, where the optional minus sign indicates a negative time period, d is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. The value of the Milliseconds property is the fractional second component, ff.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Math.Min Method

Math.Min Method

Returns the smaller of two integers that have been compared with one another.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int Min (
         int val1,
         int val2
)

Parameters

val1
The first of two integers you want to compare.
val2
The second of two integers you want to compare.

Return Value

The smaller of the two compared integers.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
System Namespace


DateTime.Minute Property

DateTime.Minute Property

Gets the minutes component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Minute { get; }

Property Value

The minute, expressed as a number ranging from 0 through 59.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Minute Field

SystemTime.Minute Field

Specifies the minute associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Minute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


TimeSpan.Minutes Property

TimeSpan.Minutes Property

Gets the number of whole minutes in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Minutes { get; }

Property Value

The number of whole minutes in the current TimeSpan object.

Expand image Remarks

The value of a TimeSpan object can be expressed as [-]d.hh:mm:ss.ff, where the optional minus sign indicates a negative time period, d is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. The value of the Minutes property is the minutes component, mm.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Byte.MinValue Field

Byte.MinValue Field

Represents the smallest possible value of Byte Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const byte MinValue

Expand image Remarks

The value of this constant is 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Structure
Byte Members
System Namespace


Char.MinValue Field

Char.MinValue Field

Represents the smallest possible value of Char Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const char MinValue

Expand image Remarks

The value of this constant is 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Char Structure
Char Members
System Namespace


DateTime.MinValue Field

DateTime.MinValue Field

Represents the smallest possible value for a DateTime object. Note that this field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public readonly DateTime MinValue

Expand image Remarks

The value of this constant is equivalent to 00:00:00.0000000, January 1, 0001.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Double.MinValue Field

Double.MinValue Field

Represents the smallest possible value of Double. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const double MinValue

Expand image Remarks

The value of this constant is -1.79769e+308.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


Int16.MinValue Field

Int16.MinValue Field

Represents the smallest possible value of Int16 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const short MinValue

Expand image Remarks

The value of this constant is -32,768; that is, hexadecimal 0x8000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Structure
Int16 Members
System Namespace


Int32.MinValue Field

Int32.MinValue Field

Represents the smallest possible value of Int32 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const int MinValue

Expand image Remarks

The value of this constant is -2,147,483,648; that is, hexadecimal 0x80000000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Structure
Int32 Members
System Namespace


Int64.MinValue Field

Int64.MinValue Field

Represents the smallest possible value of Int64 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const long MinValue

Expand image Remarks

The value of this constant is negative 9,223,372,036,854,775,807; that is, hexadecimal 0x8000000000000000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Structure
Int64 Members
System Namespace


TimeSpan.MinValue Field

TimeSpan.MinValue Field

Represents the smallest possible value for a TimeSpan object. Note that this field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public readonly TimeSpan MinValue

Expand image Remarks

The value of this field is equivalent to Int64.MinValue ticks. The string representation of this value is negative 10675199.02:48:05.4775808.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


UInt16.MinValue Field

UInt16.MinValue Field

Represents the smallest possible value of UInt16 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt16 MinValue

Expand image Remarks

The value of this constant is 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Structure
UInt16 Members
System Namespace


UInt32.MinValue Field

UInt32.MinValue Field

Represents the smallest possible value of UInt32 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt32 MinValue

Expand image Remarks

The value of this constant is 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Structure
UInt32 Members
System Namespace


UInt64.MinValue Field

UInt64.MinValue Field

Represents the smallest possible value of UInt64 Structure. This field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static const UInt64 MinValue

Expand image Remarks

The value of this constant is 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Structure
UInt64 Members
System Namespace


Monitor Class

Monitor Class
See Also Members
CollapseAll image

Provides a mechanism that synchronizes access to objects.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class Monitor

Expand image Remarks

The Monitor class controls access to objects by granting a lock for an object to a single thread. Object locks provide you with the ability to restrict access to a specific block of code, commonly called a critical section. While any one thread owns the lock for a particular object, no other thread can acquire that lock. You can also use the Monitor class to ensure that no other thread is permitted to access a section of application code being executed by the lock owner, unless the other thread is executing the code by using a different locked object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Monitor Members
System.Threading Namespace


Monitor Members

Monitor Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the Monitor type.

Expand image Public Methods

Name | Description
Enter | Acquires an exclusive lock on a specified object.
Exit | Releases an exclusive lock on a specified object.

Expand image See Also

Reference

Monitor Class
System.Threading Namespace


DateTime.Month Property

DateTime.Month Property

Gets the month component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Month { get; }

Property Value

The month, expressed as a number ranging from 1 through 12.

Expand image Remarks

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Month Field

SystemTime.Month Field

Specifies the month associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Month

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


DateTimeFormatInfo.MonthDayPattern Property

DateTimeFormatInfo.MonthDayPattern Property

Gets the format pattern for a month and day value, which is associated with the "m" and "M" format characters.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string MonthDayPattern { get; }

Property Value

The format pattern for a month and day value, which is associated with the "m" and "M" format characters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTimeFormatInfo.MonthNames Property

DateTimeFormatInfo.MonthNames Property

Gets a one-dimensional array of String objects that contain the culture-specific full names of the months.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string [] MonthNames { get; }

Property Value

A one-dimensional array of String objects that contain the culture-specific full names of the months. In a 12-month calendar, the 13th element of this array is an empty string.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


InputManager.MostRecentInputDevice Property

InputManager.MostRecentInputDevice Property

Gets or sets the input device that is associated with the most recent input event.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputDevice MostRecentInputDevice { get; set; }

Property Value

An InputDevice object that represents the input device associated with the most recent input event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


UIElementCollection.Enumerator.MoveNext Method

UIElementCollection.Enumerator.MoveNext Method

Advances the enumerator to the next element in the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool MoveNext ()

Return Value

true if the enumerator successfully advanced to the next element in the collection; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection.Enumerator Structure
UIElementCollection.Enumerator Members
Microsoft.SPOT.Presentation Namespace


IEnumerator.MoveNext Method

IEnumerator.MoveNext Method

Advances the enumerator to the next object in a specified collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public bool MoveNext ()

Return Value

true if the enumerator successfully advanced to the next object in the specified collection; false if the enumerator passed the end of the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerator Interface
IEnumerator Members
System.Collections Namespace


MTAThreadAttribute Class

MTAThreadAttribute Class
See Also Members
CollapseAll image

This class is intended for internal use. Indicates that the COM threading model for a specific application is set to multithreaded apartment (MTA).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class MTAThreadAttribute : Attribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MTAThreadAttribute Members
System Namespace


MTAThreadAttribute Members

MTAThreadAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the MTAThreadAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | MTAThreadAttribute | Initializes a new instance of the MTAThreadAttribute class.

Expand image See Also

Reference

MTAThreadAttribute Class
System Namespace


MulticastDelegate Class

MulticastDelegate Class
See Also Members
CollapseAll image

Represents a multicast delegate, which is a delegate that can contain multiple elements in its invocation list.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class MulticastDelegate : Delegate

Expand image Remarks

MulticastDelegate is a special class. Compilers and other tools can derive from this class, but you cannot derive from it explicitly. The same is true for the Delegate class.

Most programming languages implement a delegate keyword, and compilers for those languages are able to derive from the Delegate and MulticastDelegate classes. You should therefore use the delegate keyword provided by the language in each such case.

A MulticastDelegate object has a linked list of delegates, called an invocation list, that consists of one or more elements. When a multicast delegate is invoked, the delegates in the invocation list are called synchronously in the order in which they appear in the list. If an error occurs during execution of the invocation list, an exception is thrown.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MulticastDelegate Members
System Namespace


MulticastDelegate Members

MulticastDelegate Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the MulticastDelegate type.

Expand image Protected Constructors

 | Name | Description
Protected Method | MulticastDelegate | Initializes a new instance of the MulticastDelegate class.

Expand image Public Methods

Name | Description
op_Equality | Determines whether the current multicast delegate and another specified delegate are equal.
op_Inequality | Determines whether the current multicast delegate and another specified delegate are not equal.

Expand image See Also

Reference

MulticastDelegate Class
System Namespace


CultureInfo.Name Property

CultureInfo.Name Property

Gets the name of the current culture, in the format "<languagecode2>-<country/regioncode2>".

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string Name { get; }

Property Value

The name of the current culture, in the format "<languagecode2>-<country/regioncode2>", where <languagecode2> is a lowercase two-letter code derived from ISO 639-1 and <country/regioncode2> is an uppercase two-letter code derived from ISO 3166.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


DebuggerDisplayAttribute.Name Property

DebuggerDisplayAttribute.Name Property

Gets or sets the display name.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Name { get; set; }

Property Value

The display name.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


Reflection.AssemblyInfo.m_name Field

Reflection.AssemblyInfo.m_name Field

Contains the name of the current assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public string m_name

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


MemberInfo.Name Property

MemberInfo.Name Property

Gets the name of the current member.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract string Name { get; }

Property Value

A String object that contains the name of the current member.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MemberInfo Class
MemberInfo Members
System.Reflection Namespace


MethodBase.Name Property

MethodBase.Name Property

Gets the name of the current method.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string Name { get; }

Property Value

A String object that contains the name of the current method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodBase Class
MethodBase Members
System.Reflection Namespace


RoutedEvent.Name Property

RoutedEvent.Name Property

Gets the identifying name of the current RoutedEvent object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public string Name { get; }

Property Value

The identifying name of the current routed event.

Expand image Remarks

The name of a routed event must be unique within each owner type, but it does not need to be globally unique.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Class
RoutedEvent Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo.c_Flags_NeedReboot Field

Reflection.AssemblyInfo.c_Flags_NeedReboot Field

Contains a flag stating that after the current assembly is installed, the device must be rebooted.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static UInt32 c_Flags_NeedReboot

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


TimeSpan.Negate Method

TimeSpan.Negate Method

Returns a new TimeSpan object that has the negated (opposite) value of the current TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Negate ()

Return Value

A TimeSpan object that has the opposite (positive or negative) value of the current TimeSpan object.

Expand image Remarks

The value of the TimeSpan object returned by this method is numerically equal to the value of the current TimeSpan object, but the returned value has the opposite symbol (plus sign or minus sign).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


NumberFormatInfo.NegativeSign Property

NumberFormatInfo.NegativeSign Property

Gets the string that indicates that the associated number is negative.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string NegativeSign { get; }

Property Value

The string that indicates that the associated number is negative.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


FocusChangedEventArgs.NewFocus Field

FocusChangedEventArgs.NewFocus Field

Specifies the display element that currently has the button focus.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement NewFocus

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FocusChangedEventArgs Class
FocusChangedEventArgs Members
Microsoft.SPOT.Input Namespace


PropertyChangedEventArgs.NewValue Field

PropertyChangedEventArgs.NewValue Field

Contains the value of the specified property after the change.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object NewValue

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Class
PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


NoDefaultCharacter

NoDefaultCharacter
See Also Example
CollapseAll image

Specifies that no default character will substitute for characters not imported into the .tinyfnt font.

Expand image Syntax

NoDefaultCharacter

Expand image Remarks

A SelectFont statement that specifies the font from which to import glyphs must precede the NoDefaultCharacter statement in the .fntdef file. Otherwise TFConvert will fail. If there are multiple SelectFont statements, the one that more closely precedes the NoDefaultCharacter statement will be used.

Expand image Example

The following .fntdef file imports the uppercase characters from A to C, and specifies that no default character is to be used.
      AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Kooten.ttf"
      #import A, B, C
      SelectFont "WE:400,FN:Kootenay"
      ImportRange 65 67
      NoDefaultCharacter

Expand image See Also

Reference

SetAsDefaultCharacter
SetDefaultCharacter


Bitmap.DT_None Field

Bitmap.DT_None Field

Specifies that there are no format rules.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_None

Expand image Remarks

Use this field only with the Microsoft.SPOT.Bitmap.DrawTextInRect methods.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


NonSerializedAttribute Class

NonSerializedAttribute Class
See Also Members
CollapseAll image

Indicates that a field of a serializable class should not be serialized.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class NonSerializedAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NonSerializedAttribute Members
System Namespace


NonSerializedAttribute Members

NonSerializedAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the NonSerializedAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | NonSerializedAttribute | Initializes a new instance of the NonSerializedAttribute class.

Expand image See Also

Reference

NonSerializedAttribute Class
System Namespace


NotifyInputEventArgs Class

NotifyInputEventArgs Class
See Also Members
CollapseAll image

Provides data for raw input being processed by the input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class NotifyInputEventArgs : EventArgs

Expand image Remarks

The input staging area processes raw input into Windows Presentation Foundation (WPF) events.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotifyInputEventArgs Members
Microsoft.SPOT.Input Namespace
InputManager Class


NotifyInputEventArgs Members

NotifyInputEventArgs Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the NotifyInputEventArgs type.

Expand image Public Fields

 | Name | Description
Public Field | StagingItem | Specifies the StagingAreaInputItem object that represents a particular input in the staging area.

Expand image See Also

Reference

NotifyInputEventArgs Class
Microsoft.SPOT.Input Namespace


NotifyInputEventHandler Delegate

NotifyInputEventHandler Delegate

Represents the method that handles notify input events for the input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void NotifyInputEventHandler (
         Object sender,
         NotifyInputEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


NotImplementedException Class

NotImplementedException Class
See Also Members
CollapseAll image

The exception that is thrown when a requested method or operation is not implemented.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class NotImplementedException : SystemException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotImplementedException Members
System Namespace


NotImplementedException Members

NotImplementedException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the NotImplementedException type.

Expand image Public Constructors

 | Name | Description
Public Method | NotImplementedException | Overloaded. Initializes a new instance of the NotImplementedException class.

Expand image See Also

Reference

NotImplementedException Class
System Namespace


NotSupportedException Class

NotSupportedException Class
See Also Members
CollapseAll image

The exception that is thrown when a called method is not supported by .NET Micro Framework.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class NotSupportedException : SystemException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotSupportedException Members
System Namespace


NotSupportedException Members

NotSupportedException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the NotSupportedException type.

Expand image Public Constructors

 | Name | Description
Public Method | NotSupportedException | Overloaded. Initializes a new instance of the NotSupportedException class.

Expand image See Also

Reference

NotSupportedException Class
System Namespace


DateTime.Now Property

DateTime.Now Property

Gets the system's current date and time, expressed in local time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTime Now { get; }

Property Value

A DateTime object that represents the system's current date and time, expressed in local time.

Expand image Remarks

The resolution of this property depends on the system timer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


NullReferenceException Class

NullReferenceException Class
See Also Members
CollapseAll image

The exception that is thrown when there is an attempt to dereference a null object reference.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class NullReferenceException : SystemException

Expand image Remarks

Note that applications throw an ArgumentNullException exception rather than a NullReferenceException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NullReferenceException Members
System Namespace


NullReferenceException Members

NullReferenceException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the NullReferenceException type.

Expand image Public Constructors

 | Name | Description
Public Method | NullReferenceException | Overloaded. Initializes a new instance of the NullReferenceException class.

Expand image See Also

Reference

NullReferenceException Class
System Namespace


NumberFormatInfo.NumberDecimalSeparator Property

NumberFormatInfo.NumberDecimalSeparator Property

Gets the string that is used as the decimal separator in numeric values.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string NumberDecimalSeparator { get; }

Property Value

The string that is used as the decimal separator in numeric values.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


CultureInfo.NumberFormat Property

CultureInfo.NumberFormat Property

Gets or sets a NumberFormatInfo object that defines the culturally appropriate format for displaying numbers, currency, and percentages.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual NumberFormatInfo NumberFormat { get; }

Property Value

A NumberFormatInfo object that defines the culturally appropriate format for displaying numbers, currency, and percentages.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


NumberFormatInfo Class

NumberFormatInfo Class
See Also Members
CollapseAll image

Defines how numeric values are formatted and displayed, depending on the system culture.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public sealed class NumberFormatInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Members
System.Globalization Namespace


NumberFormatInfo Members

NumberFormatInfo Members
See Also Properties
CollapseAll image

The following tables list the members exposed by the NumberFormatInfo type.

Expand image Public Properties

 | Name | Description
 | CurrentInfo | Gets the read-only NumberFormatInfo object that formats values based on the current system culture, as indicated in the CultureInfo object.
Public Property | NegativeSign | Gets the string that indicates that the associated number is negative.
Public Property | NumberDecimalSeparator | Gets the string that is used as the decimal separator in numeric values.
Public Property | NumberGroupSeparator | Gets the string that separates groups of digits to the left of the decimal point in numeric values.
Public Property | NumberGroupSizes | Gets the number of digits in each group to the left of the decimal point in numeric values.
Public Property | PositiveSign | Gets the string that indicates that the associated number is positive.

Expand image See Also

Reference

NumberFormatInfo Class
System.Globalization Namespace


NumberFormatInfo.NumberGroupSeparator Property

NumberFormatInfo.NumberGroupSeparator Property

Gets the string that separates groups of digits to the left of the decimal point in numeric values.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string NumberGroupSeparator { get; }

Property Value

The string that separates groups of digits to the left of the decimal point in numeric values.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


NumberFormatInfo.NumberGroupSizes Property

NumberFormatInfo.NumberGroupSizes Property

Gets the number of digits in each group to the left of the decimal point in numeric values.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int [] NumberGroupSizes { get; }

Property Value

The number of digits in each group to the left of the decimal point in numeric values.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


Logging.NumberOfRecords Property

Logging.NumberOfRecords Property

Gets the number of Logging objects (log records) in the current list of records.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int NumberOfRecords { get; }

Property Value

The number of log records in the current list of records.

Expand image Remarks

The use of this class is currently not supported and is not recommended.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Logging Class
Logging Members
Microsoft.SPOT Namespace


Object Class

Object Class
See Also Members
CollapseAll image

Supports all classes in the .NET Micro Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Micro Framework; it is the root of the type hierarchy.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class Object

Expand image Remarks

Programming languages typically do not require a class to declare inheritance from the Object class because the inheritance is implicit.

Because all classes in the .NET Micro Framework are derived from the Object class, every method defined in this class is available for all objects in the system. Note, however, that derived classes can and do override some of these methods.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Members
System Namespace


Object Members

Object Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the Object type.

Expand image Public Constructors

 | Name | Description
Public Method | Object | Initializes a new instance of the Object class.

Expand image Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether two instances (objects) of the Object class are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | GetType | Gets the type of the current instance (object) of the Object class.
 | ReferenceEquals | Determines whether two specified instances (objects) of the Object class are the same object.
Public Method | ToString | Returns a string that represents the current instance (object) of the Object class.

Expand image Protected Methods

 | Name | Description
Protected Method | Finalize | Enables an instance (object) of the Object class to attempt to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
Protected Method | MemberwiseClone | Creates a shallow copy of the current instance (object) of the Object class.

Expand image See Also

Reference

Object Class
System Namespace


ObsoleteAttribute Class

ObsoleteAttribute Class
See Also Members
CollapseAll image

Marks the program elements that are no longer in use.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
[SerializableAttribute]
public sealed class ObsoleteAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ObsoleteAttribute Members
System Namespace


ObsoleteAttribute Members

ObsoleteAttribute Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the ObsoleteAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | ObsoleteAttribute | Overloaded. Initializes a new instance of the ObsoleteAttribute class.

Expand image Public Properties

 | Name | Description
Public Property | IsError | Gets a Boolean value that indicates whether the compiler will treat the use of the obsolete program element as an error.
Public Property | Message | Gets the work-around message, which describes the alternative program elements that you can use.

Expand image See Also

Reference

ObsoleteAttribute Class
System Namespace


RuntimeHelpers.OffsetToStringData Property

RuntimeHelpers.OffsetToStringData Property

Gets the offset, in bytes, to the data in a specified string within a particular String object.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static int OffsetToStringData { get; }

Property Value

The offset, in bytes, from the start of the String object to the first character in the specified string.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RuntimeHelpers Class
RuntimeHelpers Members
System.Runtime.CompilerServices Namespace


OffsetX

OffsetX
See Also Example
CollapseAll image

Shifts a character or range of characters right or left.

Expand image Syntax

OffsetX adjustment

Parameters

adjustment
An integer indicating the number of EM units to shift a character left or right. A positive number shifts the characters left, and a negative number shifts characters to the right.

Expand image Remarks

The OffsetX option applies to the characters specified by any ImportRange, ImportRangeAndMap, or SetAsDefaultCharacter options that follow it in the .fntdef file and precede any subsequent OffsetX options in the same .fntdef file.

Expand image Example

The following .fntdef file shifts letters A through C to the right but centers letters D through F.
      SelectFont "WE:400,FN:Pescadero"
      #Shift to the right then import the letters A through C
      OffsetX -3
      ImportRange 65 67
      #Undo the shift for D through F
      OffsetX 0
      ImportRange 68 70

Expand image See Also

Reference

OffsetY


OffsetY

OffsetY
See Also Example
CollapseAll image

Shifts a character or range of characters up or down.

Expand image Syntax

OffsetY adjustment

Parameters

adjustment
An integer indicating the number of EM units to shift a character up or down. A positive number shifts the characters down, and a negative number shifts characters up.

Expand image Remarks

The OffsetY option applies to the characters specified by any ImportRange, ImportRangeAndMap, or SetAsDefaultCharacter options that follow it in the .fntdef file and precede any subsequent OffsetY options in the same .fntdef file.

Expand image Example

The following .fntdef file shifts letters A through C upward but centers letters D through F.
      SelectFont "WE:400,FN:Pescadero"
      #Shift up then import the letters A through C
      OffsetY -3
      ImportRange 65 67
      #Undo the shift for D through F
      OffsetY 0
      ImportRange 68 70

Expand image See Also

Reference

OffsetX


FocusChangedEventArgs.OldFocus Field

FocusChangedEventArgs.OldFocus Field

Specifies the display element that last had the button focus.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement OldFocus

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FocusChangedEventArgs Class
FocusChangedEventArgs Members
Microsoft.SPOT.Input Namespace


PropertyChangedEventArgs.OldValue Field

PropertyChangedEventArgs.OldValue Field

Contains the value of the specified property before the change.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object OldValue

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Class
PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


ListBox.OnButtonDown Method

ListBox.OnButtonDown Method

Displays an event description whenever the user presses the Up button or the Down button.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void OnButtonDown (
         ButtonEventArgs e
)

Parameters

e
A description of the button-related event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.OnButtonDown Method

ScrollViewer.OnButtonDown Method

Displays an event description whenever the user presses a scroll button.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void OnButtonDown (
         ButtonEventArgs e
)

Parameters

e
A description of the button-generated event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.OnButtonDown Method

TextFlow.OnButtonDown Method

Displays an event description whenever the user presses a button.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected override void OnButtonDown (
         ButtonEventArgs e
)

Parameters

e
A description of the button-generated event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.OnButtonDown Method

UIElement.OnButtonDown Method

Adds class handling for an unhandled ButtonDown attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnButtonDown (
         ButtonEventArgs e
)

Parameters

e
A ButtonEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.OnButtonUp Method

UIElement.OnButtonUp Method

Adds class handling for an unhandled ButtonUp attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnButtonUp (
         ButtonEventArgs e
)

Parameters

e
A ButtonEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.OnChildDesiredSizeChanged Method

UIElement.OnChildDesiredSizeChanged Method

Supports the layout system when a child element is resized.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnChildDesiredSizeChanged (
         UIElement child
)

Parameters

child
The child element that is being resized.

Expand image Remarks

This method typically is not called by your application code. It is exposed so that derived element classes can make further checks on their own potentially invalid layout state. Classes could also attempt optimizations to minimize the processing time for a layout pass based on size changes to child elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Application.OnExit Method

Application.OnExit Method

Raises the Exit event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnExit (
         EventArgs e
)

Parameters

e
An EventArgs object that contains the event data for the Exit event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


UIElement.OnGotFocus Method

UIElement.OnGotFocus Method

Adds class handling for an unhandled ButtonsGotFocus attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnGotFocus (
         FocusChangedEventArgs e
)

Parameters

e
A FocusChangedEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.OnLostFocus Method

UIElement.OnLostFocus Method

Adds class handling for an unhandled ButtonsLostFocus attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnLostFocus (
         FocusChangedEventArgs e
)

Parameters

e
A FocusChangedEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.OnPreviewButtonDown Method

UIElement.OnPreviewButtonDown Method

Adds class handling for an unhandled PreviewButtonDown attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnPreviewButtonDown (
         ButtonEventArgs e
)

Parameters

e
A ButtonEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.OnPreviewButtonUp Method

UIElement.OnPreviewButtonUp Method

Adds class handling for an unhandled PreviewButtonUp attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnPreviewButtonUp (
         ButtonEventArgs e
)

Parameters

e
A ButtonEventArgs object that provides data for the attached event.

Expand image Remarks

This method has no default implementation. Because an intermediate class in the inheritance might implement this method, you should call the base implementation in your own implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Border.OnRender Method

Border.OnRender Method

Draws a border and its background to the display device (screen).

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a Border object. This context is provided to the layout system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Control.OnRender Method

Control.OnRender Method

Draws a control to a display device.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a Control object. This context is provided to the layout system.

Expand image Remarks

This method must be implemented by all classes that derive from the Control class. Note that the Control class does not provide a default implementation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Control Class
Control Members
Microsoft.SPOT.Presentation.Controls Namespace


Image.OnRender Method

Image.OnRender Method

Draws a bitmap to a display device.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a Image object. This context is provided to the layout system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Image Class
Image Members
Microsoft.SPOT.Presentation.Controls Namespace


Text.OnRender Method

Text.OnRender Method

Writes the contents of the current Text object to the display device (screen).

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a Text object. This context is provided to the layout system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.OnRender Method

TextFlow.OnRender Method

Writes text to the display device (screen).

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a TextFlow object. This context is provided to the layout system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.OnRender Method

UIElement.OnRender Method

Participates in rendering operations that are directed by the layout system when implemented in a derived class.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual void OnRender (
         DrawingContext dc
)

Parameters

dc
A DrawingContext object that supplies the drawing instructions for a UIElement object. This context is provided to the layout system.

Expand image Remarks

The rendering instructions for a specific element are not used directly when this method is invoked; instead, those instructions are preserved for later asynchronous use by layout and drawing.

This method has no default implementation in the UIElement class.

Note
Note to implementers: You can override the OnRender method to add further graphical elements (not previously defined in a logical tree) to a rendered element. Also note that a DrawingContext object is passed as an argument, which provides methods for drawing shapes, text, images, or videos.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


RoutedEventArgs.OnSetSource Method

RoutedEventArgs.OnSetSource Method

Provides a notification callback entry point whenever the value of the Source property of an object changes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnSetSource (
         Object source
)

Parameters

source
Contains the object whose Source property triggers the invocation of this method.

Expand image Remarks

The OnSetSource method is protected virtual and is intended to be overridden by subclasses of the RoutedEventArgs class. Note that OnSetSource has no default implementation.

Note
Changing the reported source of an event programmatically can potentially require updating the type-specific data within the event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


Application.OnStartup Method

Application.OnStartup Method

Raises the Startup event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected virtual void OnStartup (
         EventArgs e
)

Parameters

e
An EventArgs object that contains the event data for the Startup event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Brush.Opacity Field

Brush.Opacity Field

Specifies the degree of opacity of the brush's paint or fill.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UInt16 Opacity

Expand image Remarks

A value of 0 (zero) indicates that the paint or fill is transparent (that is, 0-percent opaque). A value of 100 indicates that the paint or fill is completely opaque.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Brush Class
Brush Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.OpacityOpaque Field

Bitmap.OpacityOpaque Field

Specifies that the current bitmap is opaque.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt16 OpacityOpaque

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.OpacityTransparent Field

Bitmap.OpacityTransparent Field

Specifies that the current bitmap is transparent.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt16 OpacityTransparent

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Orientation Enumeration

Orientation Enumeration

Specifies the layout orientation for controls that manage the layout of other user interface elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Orientation

Expand image Members

Member name | Description
Horizontal | A value specifying that the layout of child elements should be horizontal.
Vertical | A value specifying that the layout of child elements should be vertical.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Controls Namespace


StackPanel.Orientation Property

StackPanel.Orientation Property

Gets or sets the presentation (orientation) of the child user interface elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Orientation Orientation { get; set; }

Property Value

The orientation of the line of controls.

Expand image Remarks

Child user interface elements are each represented by an object. The StackPanel control can present child objects as a horizontal or vertical line of elements.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Class
StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


RoutedEventArgs.OriginalSource Property

RoutedEventArgs.OriginalSource Property

Gets the orginal object that raised the current routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object OriginalSource { get; }

Property Value

The original reporting source, before any possible adjustments could be made to the Source property by class handling.

Expand image Remarks

This property acquires its value once, before the class event handlers or any instance handlers are invoked, and it is never adjusted past this point. Thereafter it is strictly read-only.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


OutAttribute Class

OutAttribute Class
See Also Members
CollapseAll image

Indicates that data should be marshaled from the callee back to the caller.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class OutAttribute : Attribute

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutAttribute Members
System.Runtime.InteropServices Namespace


OutAttribute Members

OutAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the OutAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | OutAttribute | Initializes a new instance of the OutAttribute class.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image See Also

Reference

OutAttribute Class
System.Runtime.InteropServices Namespace


OutOfMemoryException Class

OutOfMemoryException Class
See Also Members
CollapseAll image

The exception that is thrown when there is not enough memory available to continue the execution of a program.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class OutOfMemoryException : SystemException

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

OutOfMemoryException Members
System Namespace


OutOfMemoryException Members

OutOfMemoryException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the OutOfMemoryException type.

Expand image Public Constructors

 | Name | Description
Public Method | OutOfMemoryException | Overloaded. Initializes a new instance of the OutOfMemoryException class.

Expand image See Also

Reference

OutOfMemoryException Class
System Namespace


StructLayoutAttribute.Pack Field

StructLayoutAttribute.Pack Field

Controls the alignment of the data fields of a particular class or structure in memory.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Pack

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


ScrollViewer.PageDown Method

ScrollViewer.PageDown Method

Scrolls the contents (controls) of a ScrollViewer object downward by one page.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PageDown ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.PageLeft Method

ScrollViewer.PageLeft Method

Scrolls the contents (controls) of a ScrollViewer object to the left by one page.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PageLeft ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.PageRight Method

ScrollViewer.PageRight Method

Scrolls the contents (controls) of a ScrollViewer object to the right by one page.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PageRight ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.PageUp Method

ScrollViewer.PageUp Method

Scrolls the contents (controls) of a ScrollViewer object upward by one page.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PageUp ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


Panel Class

Panel Class
See Also Members
CollapseAll image

Constitutes a base class for all panel elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Panel : UIElement

Expand image Remarks

Use panel elements to position and arrange child elements (child controls) in applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Panel Members
Microsoft.SPOT.Presentation.Controls Namespace


Panel Members

Panel Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Panel type.

Expand image Public Constructors

 | Name | Description
Public Method | Panel | Initializes an instance of the Panel class.

Expand image Public Properties

 | Name | Description
Public Property | Children | Gets the collection of child elements in the current panel.

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Measures the size of the layout area required for child elements.

Expand image See Also

Reference

Panel Class
Microsoft.SPOT.Presentation.Controls Namespace


ParamArrayAttribute Class

ParamArrayAttribute Class
See Also Members
CollapseAll image

Indicates that the specified method will accept a variable number of arguments in its invocation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class ParamArrayAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ParamArrayAttribute Members
System Namespace


ParamArrayAttribute Members

ParamArrayAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the ParamArrayAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | ParamArrayAttribute | Initializes a new instance of the ParamArrayAttribute class with default properties.

Expand image See Also

Reference

ParamArrayAttribute Class
System Namespace


ArgumentException.ParamName Property

ArgumentException.ParamName Property

Gets the name of the parameter that caused this exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string ParamName { get; }

Property Value

The parameter name.

Expand image Remarks

Every instance of the ArgumentException class should carry the name of the parameter that caused this exception. The parameter name should not be localized.

This property is read-only and returns the same value that was passed into the constructor. Overriding methods should be used only to customize the content or formatting of the parameter name.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArgumentException Class
ArgumentException Members
System Namespace


CultureInfo.Parent Property

CultureInfo.Parent Property

Gets the CultureInfo object that represents the parent culture of the current CultureInfo object.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual CultureInfo Parent { get; }

Property Value

The CultureInfo object that represents the parent culture of the current CultureInfo object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


UIElement.Parent Property

UIElement.Parent Property

Gets the logical parent element of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement Parent { get; }

Property Value

A UIElement object that specifies the logical parent element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Bitmap.PatBlt Method

Bitmap.PatBlt Method

Creates a bit pattern on a bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
[MethodImplAttribute]
public void PatBlt (
         int xDst,
         int yDst,
         int nWidth,
         int nHeight,
         int dwRop
)

Parameters

xDst
The x-coordinate of the upper-left corner of the destination rectangle.
yDst
The y-coordinate of the upper-left corner of the destination rectangle.
nWidth
The width of the source and destination rectangles.
nHeight
The height of the source and destination rectangles.
dwRop
A raster operation code, which defines the pattern to be created on the bitmap.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo.c_Flags_Patch Field

Reflection.AssemblyInfo.c_Flags_Patch Field

Contains a flag stating that the current assembly is a patch for another assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static UInt32 c_Flags_Patch

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


Bitmap.PATINVERT Field

Bitmap.PATINVERT Field

Inverts the source rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int PATINVERT

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ProcessInputEventArgs.PeekInput Method

ProcessInputEventArgs.PeekInput Method

Gets, but does not remove, the input event on the top of the staging area stack.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StagingAreaInputItem PeekInput ()

Return Value

The input event that is on the top of the staging area stack. The return value will be a null reference if the staging area is empty.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Class
ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


Pen Class

Pen Class
See Also Members
CollapseAll image

Creates lines, curves, and outlines of shapes on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Pen

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Members
Microsoft.SPOT.Presentation.Media Namespace


Pen Members

Pen Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the Pen type.

Expand image Public Constructors

 | Name | Description
Public Method | Pen | Overloaded. Initializes a new instance of the Pen class.

Expand image Public Fields

 | Name | Description
Public Field | Color | Specifies the color of the current pen.
Public Field | Thickness | Specifies the thickness of the current pen.

Expand image See Also

Reference

Pen Class
Microsoft.SPOT.Presentation.Media Namespace


Math.PI Field

Math.PI Field

Represents the ratio of the circumference of a circle to its diameter, specified by the constant π.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static double PI

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
System Namespace


DateTimeFormatInfo.PMDesignator Property

DateTimeFormatInfo.PMDesignator Property

Gets the string designator for hours that are "post meridiem" (after noon).

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string PMDesignator { get; }

Property Value

The string designator for hours that are "post meridiem" (after noon). The default return value is "PM".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DrawingContext.PopClippingRectangle Method

DrawingContext.PopClippingRectangle Method

Pops the clipping rectangle that was most recently pushed onto the current DrawingContext object.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PopClippingRectangle ()

Expand image Remarks

Use the PushClippingRectangle method to push a clipping rectangle onto the DrawingContext object.

If your program invokes this method after the stack of clipping rectangles is empty, this method creates a clipping rectangle whose dimensions are the same as the display's dimensions, and then it uses that rectangle in clipping operations.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


ProcessInputEventArgs.PopInput Method

ProcessInputEventArgs.PopInput Method

Removes the input event on the top of the staging area stack.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StagingAreaInputItem PopInput ()

Return Value

The input event that was on the top of the staging area stack. The return value will be a null reference if the staging area is empty.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Class
ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


NumberFormatInfo.PositiveSign Property

NumberFormatInfo.PositiveSign Property

Gets the string that indicates that the associated number is positive.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string PositiveSign { get; }

Property Value

The string that indicates that the associated number is positive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NumberFormatInfo Class
NumberFormatInfo Members
System.Globalization Namespace


InputManager.PostNotifyInput Event

InputManager.PostNotifyInput Event

Occurs after the PreNotifyInput event handlers have finished processing the raw input and the corresponding WPF events have been raised.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event NotifyInputEventHandler PostNotifyInput

Expand image Remarks

A monitor is any code routine that listens for the PreNotifyInput event or the PostNotifyInput event. Note that monitors cannot modify the input staging area.

The handlers attached to the PostNotifyInput event are invoked in reverse order so that handlers added by users are invoked before handlers in the system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


InputManager.PostProcessInput Event

InputManager.PostProcessInput Event

Occurs after the NotifyInputEventHandler Delegate delegate has finished processing the raw input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event ProcessInputEventHandler PostProcessInput

Expand image Remarks

A filter is any code routine that listens for the PreProcessInput event or the PostProcessInput event. Note that filters can modify the input staging area.

The handlers attached to the PostProcessInput event are invoked in reverse order so that handlers added by users are invoked before handlers in the system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


InputManager.PreNotifyInput Event

InputManager.PreNotifyInput Event

Occurs when the PreProcessInputEventHandler Delegate delegate has finished processing the raw input, if the raw input was not canceled.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event NotifyInputEventHandler PreNotifyInput

Expand image Remarks

A monitor is any code routine that listens for the PreNotifyInput event or the PostNotifyInput event. Note that monitors cannot modify the input staging area.

The handlers attached to the PreNotifyInput event are invoked in reverse order so that handlers added by users are invoked before handlers in the system.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


InputManager.PreProcessInput Event

InputManager.PreProcessInput Event

Occurs when the input manager starts to process a raw input item.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event PreProcessInputEventHandler PreProcessInput

Expand image Remarks

A filter is any code routine that listens for the PreProcessInput event or the PostProcessInput event. Note that filters can modify the input staging area.

The handlers attached to the PreProcessInput event are invoked in reverse order so that handlers added by users are invoked before handlers in the system.

Calling the PreProcessInputEventArgs.Cancel Method method on a PreProcessInputEventArgs Class object that is passed to the PreProcessInputEventHandler Delegate delegate will cancel the processing of the raw input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


PreProcessInputEventArgs Class

PreProcessInputEventArgs Class
See Also Members
CollapseAll image

Provides data for preprocess input events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class PreProcessInputEventArgs : ProcessInputEventArgs

Expand image Remarks

Canceling a preprocess input will remove the input event from the staging area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PreProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


PreProcessInputEventArgs Members

PreProcessInputEventArgs Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the PreProcessInputEventArgs type.

Expand image Public Properties

 | Name | Description
Public Property | Canceled | Gets a value that indicates whether input processing has been canceled.

Expand image Public Methods

 | Name | Description
Public Method | Cancel | Cancels the processing of raw input.

Expand image See Also

Reference

PreProcessInputEventArgs Class
Microsoft.SPOT.Input Namespace


PreProcessInputEventHandler Delegate

PreProcessInputEventHandler Delegate

Represents the method that handles preprocess input events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void PreProcessInputEventHandler (
         Object sender,
         PreProcessInputEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


Microsoft.SPOT.Presentation Namespace

Microsoft.SPOT.Presentation Namespace

The Microsoft.SPOT.Presentation namespace in the Microsoft® .NET Micro Framework provides classes, a structure, and enumerations you can use to lay out and display graphical user interface (GUI) items — such as a window and its child elements — on a display device screen.

Expand image Classes

 | Name | Description
Public Class | PresentationSource | Enables you to work with content from other technologies (sources) as part of interoperational scenarios.
Public Class | SystemMetrics | Contains a display device screen's dimensions and the number of available colors.
Public Class | UIElement | Provides programming components you can use to lay out and render graphical user interface (GUI) items such as shapes, images, and controls on a particular region of a display device's screen.
Public Class | UIElementCollection | Represents an ordered collection of UIElement objects.
Public Class | Window | Provides members you can use to create, configure, show, and manage windows and dialog boxes in your .NET Micro Framework applications.
Public Class | WindowManager | Manages windows that are currently open.

Expand image Structures

 | Name | Description
Public Structure | UIElementCollection.Enumerator | Enumerates the UIElement objects that are contained in a particular UIElementCollection object.

Expand image Enumerations

 | Name | Description
Public Enumeration | HorizontalAlignment | Specifies a child element's horizontal alignment within its parent element's layout space.
Public Enumeration | SizeToContent | Specifies how a window should be sized, relative to its contents.
Public Enumeration | VerticalAlignment | Specifies a child element's vertical alignment within its parent element's layout space.
Public Enumeration | Visibility | Specifies the current display state of a particular .NET Micro Framework element.


PresentationSource Class

PresentationSource Class
See Also Members
CollapseAll image

Enables you to work with content from other technologies (sources) as part of interoperational scenarios.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class PresentationSource : DispatcherObject

Expand image Remarks

The PresentationSource class provides static methods for working with the sources of content and the basic visual-layer presentation architecture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PresentationSource Members
Microsoft.SPOT.Presentation Namespace


PresentationSource Members

PresentationSource Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the PresentationSource type.

Expand image Public Constructors

 | Name | Description
Public Method | PresentationSource | Initializes a new instance of the PresentationSource class.

Expand image Public Properties

 | Name | Description
Public Property | RootUIElement | Gets or sets the logical root UI element of a source of content.

Expand image See Also

Reference

PresentationSource Class
Microsoft.SPOT.Presentation Namespace


Buttons.PreviewButtonDownEvent Field

Buttons.PreviewButtonDownEvent Field

Specifies the tunneling-routed event that occurs when a button on a button device is pressed.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent PreviewButtonDownEvent

Expand image Remarks

The PreviewButtonDownEvent field specifies a routed event that uses the tunneling routing strategy. The event handler for this event is represented by the ButtonEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


Buttons.PreviewButtonUpEvent Field

Buttons.PreviewButtonUpEvent Field

Specifies the tunneling-routed event that occurs when a button on a button device is released.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent PreviewButtonUpEvent

Expand image Remarks

The PreviewButtonUpEvent field specifies a routed event that uses the tunneling routing strategy. The event handler for this event is represented by the ButtonEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


InputManager.PreviewInputReportEvent Field

InputManager.PreviewInputReportEvent Field

Specifies the tunneling-routed event that occurs when the input manager receives an input report from an InputProviderSite object.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static RoutedEvent PreviewInputReportEvent

Expand image Remarks

The PreviewInputReportEvent field specifies a routed event that uses the tunneling routing strategy. The event handler for this event is represented by the InputEventHandler Delegate delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


SelectionChangedEventArgs.PreviousSelectedIndex Field

SelectionChangedEventArgs.PreviousSelectedIndex Field

Specifies the index number of the item that was last selected.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int PreviousSelectedIndex

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


Buttons.PrimaryDevice Property

Buttons.PrimaryDevice Property

Gets the primary button input device with which the current Buttons object is associated.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static ButtonDevice PrimaryDevice { get; }

Property Value

A ButtonDevice object that represents the button input device with which the current Buttons object is associated.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Buttons Class
Buttons Members
Microsoft.SPOT.Input Namespace


MFNetworkConfiguration.PrimaryDns Property

MFNetworkConfiguration.PrimaryDns Property

Gets or sets the primary DNS address.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress PrimaryDns { get; set; }

Property Value

The primary DNS address.

Expand image Version Information

Available in MFDeploy 2.0 SP1


Debug.Print Method

Debug.Print Method

Prints a message (followed by the current line terminator) to the standard output stream.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Print (
         string text
)

Parameters

text
The message to be printed to the standard output stream.

Expand image Remarks

This method does not follow the convention of the .NET Framework class System.Diagnostics.Debug.Print in that it appoears in some builds that System.Diagnostics.Debug.Print does not. If you want that behavior, you can implement the following class in your application to obtain it.

public static class MyDebug
{
    [ConditionalAttribute("DEBUG")]
    public static void Print(string text)
    {
        Microsoft.SPOT.Debug.Print(text);
    }

    [ConditionalAttribute("TRACE")]
    public static void Trace(string text)
    {
        Microsoft.SPOT.Debug.Print(text);
    }
}

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Debug Class
Debug Members
Microsoft.SPOT Namespace


ExtendedWeakReference.Priority Property

ExtendedWeakReference.Priority Property

Gets or sets the priority level for the current ExtendedWeakReference object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int Priority { get; set; }

Property Value

The priority level for the current weak reference.

Expand image Remarks

The higher the value, the higher the priority level.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


Thread.Priority Property

Thread.Priority Property

Gets or sets a value that indicates the scheduling priority of the current thread.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ThreadPriority Priority { get; set; }

Property Value

One of the ThreadPriority values. Note that the default priority value for threads is Normal.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


ExtendedWeakReference.PriorityLevel Enumeration

ExtendedWeakReference.PriorityLevel Enumeration

Defines a set of constants available for prioritizing extended weak references.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public enum ExtendedWeakReference.PriorityLevel

Expand image Members

Member name | Description
Critical | Critical data.
Important | Data that is important, but not critical.
NiceToHave | Data that is nice to have, but not critical.
OkayToThrowAway | Data that can be safely thrown away.
System | System data that is mandatory for basic operation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


InputManager.ProcessInput Method

InputManager.ProcessInput Method

Processes the specified input synchronously.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool ProcessInput (
         InputEventArgs input
)

Parameters

input
An InputEventArgs object that represents the input to be processed.

Return Value

true if the input was processed successfully; otherwise, false.

Expand image Remarks

A synchronous operation is one that must complete before the function ends. An asynchronous operation enables the function to end before the operation is complete.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


ProcessInputEventArgs Class

ProcessInputEventArgs Class
See Also Members
CollapseAll image

Provides data for postprocess input events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ProcessInputEventArgs : NotifyInputEventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


ProcessInputEventArgs Members

ProcessInputEventArgs Members
See Also Methods
CollapseAll image

The following tables list the members exposed by the ProcessInputEventArgs type.

Expand image Public Methods

 | Name | Description
Public Method | PeekInput | Gets, but does not remove, the input event on the top of the staging area stack.
Public Method | PopInput | Removes the input event on the top of the staging area stack.
Public Method | PushInput | Overloaded. Places an input event on the top of the staging area stack.

Expand image See Also

Reference

ProcessInputEventArgs Class
Microsoft.SPOT.Input Namespace


ProcessInputEventHandler Delegate

ProcessInputEventHandler Delegate

Represents the method that handles process input events.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void ProcessInputEventHandler (
         Object sender,
         ProcessInputEventArgs e
)

Parameters

sender
The source of the event.
e
The event data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


ProcessorArchitecture Enumeration

ProcessorArchitecture Enumeration

Specifies the type of microprocessor used by the hardware device.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum ProcessorArchitecture

Expand image Members

Member name | Description
Amd64 | A value that specifies 62-bit AMD microprocessors.
IA64 | A value that specifies 64-bit Intel and compatible microprocessors.
MSIL | A value that specifies the Microsoft common language runtime (CLR) intermediate language (IL).
None | A value that indicates that the microprocessor is unspecified.
X86 | A value that specifies Intel x86 and compatible microprocessors.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Reflection Namespace


AssemblyProductAttribute.Product Property

AssemblyProductAttribute.Product Property

Gets product name information.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Product { get; }

Property Value

A string that contains product name information.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyProductAttribute Class
AssemblyProductAttribute Members
System.Reflection Namespace


PropertyChangedEventArgs.Property Field

PropertyChangedEventArgs.Property Field

Contains the name of the property that changes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public string Property

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Class
PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


PropertyChangedEventArgs Class

PropertyChangedEventArgs Class
See Also Members
CollapseAll image

Provides data for a property changed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class PropertyChangedEventArgs

Expand image Remarks

The .NET Micro Framework raises a property changed event when a property is changed on a component. Specifically, it passes a PropertyChangedEventArgs object to the delegate that handles the event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


PropertyChangedEventArgs Members

PropertyChangedEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the PropertyChangedEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | PropertyChangedEventArgs | Initializes a new instance of the PropertyChangedEventArgs class.

Expand image Public Fields

 | Name | Description
Public Field | NewValue | Contains the value of the specified property after the change.
Public Field | OldValue | Contains the value of the specified property before the change.
Public Field | Property | Contains the name of the property that changes.

Expand image See Also

Reference

PropertyChangedEventArgs Class
Microsoft.SPOT Namespace


PropertyChangedEventHandler Delegate

PropertyChangedEventHandler Delegate

Handles a property change event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void PropertyChangedEventHandler (
         Object sender,
         PropertyChangedEventArgs e
)

Parameters

sender
The object whose property is changing.
e
Information about the property change.

Expand image Remarks

By associating this delegate with a property, your program can receive a notification each time the property changes. The PropertyChangedEventArgs object that this delegate receives through the e parameter contains the name of the property, its value before the change, and its new value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


PropertyInfo Class

PropertyInfo Class
See Also Members
CollapseAll image

Discovers the attributes of a particular property and provides access to property metadata.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class PropertyInfo : MemberInfo

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyInfo Members
System.Reflection Namespace


PropertyInfo Members

PropertyInfo Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the PropertyInfo type.

Expand image Protected Constructors

 | Name | Description
Protected Method | PropertyInfo | Initializes a new instance of the PropertyInfo class.

Expand image Public Properties

 | Name | Description
Public Property | PropertyType | Gets the type of the current property.

Expand image Public Methods

 | Name | Description
Public Method | GetValue | Retrieves the value of a property for a specified object. For indexed properties, the GetValue property also retrieves optional index values.
Public Method | SetValue | Sets the value of an indexed property for a specified object with optional index values.

Expand image See Also

Reference

PropertyInfo Class
System.Reflection Namespace


PropertyInfo.PropertyType Property

PropertyInfo.PropertyType Property

Gets the type of the current property.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type PropertyType { get; }

Property Value

The type of the current property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyInfo Class
PropertyInfo Members
System.Reflection Namespace


DebuggerTypeProxyAttribute.ProxyTypeName Property

DebuggerTypeProxyAttribute.ProxyTypeName Property

Gets the name of the proxy type.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ProxyTypeName { get; }

Property Value

The name of the proxy type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


Adding Fonts To Your Application

Adding Fonts To Your Application

This section provides an overview of the steps required to reference and use fonts in a .NET Micro Framework application.

Adding the Font Resource to Your Application

Once a .tinyfnt file has been generated, add the font resource to your application using the following procedure.
  1. Open the Resource Designer by double-clicking on Resources.resx in Solution Explorer.
  2. On the Resource Designer toolbar, point to Add Resource, click the arrow, then click Add Existing File.
  3. In the Add existing file to resources dialog box, browse to the .tinyfnt file, and then click Open. The file will be added to the Resources directory, and the Resource Designer will open the Files pane.

Using Fonts In Your Application

Once the .tinyfnt font file has been added to your application's Resources, you can use the font in your application's code. Visual Studio automatically generates the Resources.FontResources enumerated type to contain members that identifies each font. Each member has the same name as its corresponding .tinyfnt file. For instance, the member Resources.FontResources.miramonte would identify the font in the miramonte.tinyfnt file. To retrieve a Font object, call the Resources.GetFont method, passing the Resources.FontResources enumerated type member that identifies the font. For example, the following code creates a text control and sets its font to the font contained in the miramonte.tinyfnt file.
        // Create a single text control.
        Text text = new Text();
        // Set Font
        text.Font = Resources.GetFont(Resources.FontResources.miramonte);


TFConvert References

TFConvert References

This section describes the .FNTDEF file format used by the TFConvert tool.

The .fntdef Format

The TFConvert tool creates a .tinyfnt font using a font definition file that you create. The font definition file, a text file with the .fntdef extension, specifies the TrueType font to import from, the range of characters to import, and other options. The .fntdef file contains one option on each line.

The following topics describe the .fntdef options in detail.

.fntdef File Options

AddFontToProcess
Specifies the path to a TrueType font to use for building a .tinyfnt font.
AdjustAscent
Adjusts the ascent of the font being created.
AdjustDescent
Adjusts the descent of the font being created.
AdjustExternalLeading
Adjusts the external leading measurement of the font being created.
AdjustInternalLeading
Adjusts the internal leading measurement of the font being created.
AdjustLeftMargin
Adjusts the left margin of a range of characters.
AdjustRightMargin
Adjusts the right margin of a character or range of characters.
ImportRange
Specifies a range of Unicode characters to import.
ImportRangeAndMap
Specifies a range of Unicode characters to import.
NoDefaultCharacter
Specifies that no default character will substitute for characters not imported into the .tinyfnt font.
OffsetX
Shifts a character or range of characters right or left.
OffsetY
Shifts a character or range of characters up or down.
SelectFont
Specifies a list of attributes that define the .tinyfnt font to create.
SetAsDefaultCharacter
Specifies the value of the character to substitute for characters not imported into the .tinyfnt font.
SetDefaultCharacter
Indicates that the default character defined by a TrueType font will be substituted for characters not imported to the TINYFNT font.
Verbosity
Specifies the verbosity level of TFConvert output.
# Comments
Add comments to a .fntdef file.


Creating a .tinyfnt Font File

Creating a .tinyfnt Font File

This section provides an overview of the TinyFNT file format and the steps required to create a .tinyfnt font file.

The TinyFNT Format

The .NET Micro Framework uses the .tinyfnt file format to work with fonts. The .tinyfnt format uses a fixed-point bitmap-based font system for a simpler way to render fonts. Two sample .tinyfnt fonts are included in the Fonts subdirectory of your .NET Micro Framework installation. To create other fonts, in the size, style, and language tailored to your application, you use the TFConvert tool to create a .tinyfnt font from TrueType or OpenType font files.

Steps To Create a TinyFNT Font

To create a custom font for your application, select a TrueType font to begin with, create a font definition in a .fntdef file, and run TFConvert to generate the .tinyfnt file from the font definition.

Selecting a TrueType Font

The .NET Micro Framework SDK provides a set of sample OpenType fonts that you can use in creating and distributing applications for the .NET Micro Framework. The fonts are located in the \Tools\Fonts\TrueType subdirectory of your .NET Micro Framework installation.

The sample fonts are supplied under license from Ascender Corporation. These fonts support a small character set that is a subset of the full font available from Ascender. The following list contains the names of the sample OpenType fonts, with the name using the corresponding font.

Figure 1. The names of sample fonts

Ascender is a provider of advanced font products specializing in font design, development and licensing. To license extended or custom versions of the sample fonts please contact Ascender Corporation directly via their Web site http://www.ascendercorp.com

Creating a Font Definition

Once you have identified a TrueType font file to import from, you create a font definition file. The font definition file, a text file with the .fntdef extension, specifies the TrueType font to import from, the range of characters to import, and other options. The .fntdef file contains one option on each line. The TFConvert References contain details on the options that make up a .fntdef file.

At a basic level, a .fntdef file must contain a SelectFont option and an option to import a range of characters. The following example shows a font definition for importing code points 65 to 90 from the sample Miramonte font. The path in the AddFontToProcess statement should be modified to match the location of the Miramonte font on your installation of the .NET Micro Framework.

        AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Miramo.ttf"
        SelectFont “WE:400,FN:Miramonte”
        ImportRange 65 90

Running TFConvert

Pass the path to the font definition file you created and the name of the .tinyfnt file to generate as command line arguments to TFConvert.

Location

The TFConvert tool can be found in the Tools subdirectory of your .NET Micro Framework installation. For example,

C:\Program Files\Microsoft .NET Micro Framework\v2.0.3036\Tools

Usage

To invoke TFConvert from the command prompt, use the following form:

TFConvert <input file> <output file>

The input file argument is the path of the font definition file. It must have the .fntdef extension.

The output file argument is the path of the TINYFNT font that you wish to create. It must have the .tinyfnt extension.

Example

TFConvert miramonte.fntdef miramonte.tinyfnt


TFConvert Overviews

TFConvert Overviews

This documentation provides an overview of the TFConvert tool. To learn more about the TFConvert tool, use the following links:

In This Section

Creating a .tinyfnt Font File
This section provides an overview of the TinyFNT file format and the steps required to create a .tinyfnt font file.
Adding Fonts To Your Application
This section provides an overview of the steps required to reference and use fonts in a .NET Micro Framework application.
Considering Unsupported Features
This section lists font features that are not supported by TFConvert.


Considering Unsupported Features

Considering Unsupported Features

This section lists font features that are not supported by TFConvert. Keep in mind the following limitations when working with fonts with the .NET Micro Framework.

Multi-Directional and Bi-Directional Characters

Right-to-left or vertical scripts are not supported.

Positional Characters

Characters that have different forms depending on their position in a string are not supported.

Four-Byte Unicode Characters

The .NET Micro Framework supports only two-byte Unicode characters. Characters greater than 0xFFFD are not supported.

Anti-aliasing

The creation of anti-aliased fonts is not supported in the Microsoft® .NET Micro Framework 2.0 Service Pack 1 (SP1).


TFConvert

TFConvert

The TFConvert tool helps you convert TrueType fonts to the TINYFNT format that Microsoft® .NET Micro Framework applications use. To learn more about the TFConvert tool, use the following links:

In This Section

TFConvert Overviews
This documentation provides an overview of the TFConvert tool.
TFConvert References
This section describes the .FNTDEF file format used by the TFConvert tool.


PublishInApplicationDirectoryAttribute Class

PublishInApplicationDirectoryAttribute Class
See Also Members
CollapseAll image

Indicates that an application should be published in its application directory.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class PublishInApplicationDirectoryAttribute

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyChangedEventArgs Members
Microsoft.SPOT Namespace


PublishInApplicationDirectoryAttribute Members

PublishInApplicationDirectoryAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the PublishInApplicationDirectoryAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | PublishInApplicationDirectoryAttribute | Creates and initializes a new instance of the PublishInApplicationDirectoryAttribute class.

Expand image See Also

Reference

PublishInApplicationDirectoryAttribute Class
Microsoft.SPOT Namespace


ExtendedWeakReference.PushBackIntoRecoverList Method

ExtendedWeakReference.PushBackIntoRecoverList Method

Flags an ExtendedWeakReference object as a candidate for recovery after the device reboots or powers down and restarts.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void PushBackIntoRecoverList ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


DrawingContext.PushClippingRectangle Method

DrawingContext.PushClippingRectangle Method

Pushes the specified clipping rectangle onto the current DrawingContext object.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void PushClippingRectangle (
         int x,
         int y,
         int width,
         int height
)

Parameters

x
The horizontal coordinate of the left edge of the clipping rectangle.
y
The vertical coordinate of the top edge of the clipping rectangle.
width
The width of the clipping rectangle.
height
The height of the clipping rectangle.

Expand image Remarks

The clipping rectangle is a rectangular region that restricts the drawing surface. All drawing must be done within the clipping rectangle. Any images or parts of images that are outside the clipping rectangle do not appear on the drawing surface.

The specified clipping rectangle applies to all subsequent drawing commands, until it is removed by the PopClippingRectangle method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Dispatcher.PushFrame Method

Dispatcher.PushFrame Method

Pushes an execution frame onto the event queue of a Dispatcher object (dispatcher).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void PushFrame (
         DispatcherFrame frame
)

Parameters

frame
The frame to be processed by the dispatcher.

Expand image Remarks

A dispatcher processes the event queue in a loop that is typically initiated by having the application invoke the Run method. Each iteration of the loop is referred to as a frame. The PushFrame method pushes a nested loop, which is contained in the frame parameter, onto the event queue.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


ProcessInputEventArgs.PushInput Method (StagingAreaInputItem)

ProcessInputEventArgs.PushInput Method (StagingAreaInputItem)
See Also
CollapseAll image

Places the specified input on the top of the staging area stack.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StagingAreaInputItem PushInput (
         StagingAreaInputItem input
)

Parameters

input
The input to be placed on the top of the staging area stack.

Return Value

The staging area input item that wraps the specified input.

Expand image Remarks

The value of the input parameter cannot be a null reference, and it cannot already exist in the staging area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Class
ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


ProcessInputEventArgs.PushInput Method (InputEventArgs, StagingAreaInputItem)

ProcessInputEventArgs.PushInput Method (InputEventArgs, StagingAreaInputItem)
See Also
CollapseAll image

Replaces an input that is already on the staging area stack, with a specified input.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StagingAreaInputItem PushInput (
         InputEventArgs input,
         StagingAreaInputItem promote
)

Parameters

input
The input to be placed on the staging area stack.
promote
The input to be replaced on (removed from) the staging area stack.

Return Value

The staging area input item that wraps the specified input.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Class
ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


ProcessInputEventArgs.PushInput Method

ProcessInputEventArgs.PushInput Method

Places an input event on the top of the staging area stack.

Expand image Overload List

Name | Description
ProcessInputEventArgs.PushInput (InputEventArgs, StagingAreaInputItem) | Replaces an input that is already on the staging area stack, with a specified input.
ProcessInputEventArgs.PushInput (StagingAreaInputItem) | Places the specified input on the top of the staging area stack.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ProcessInputEventArgs Class
ProcessInputEventArgs Members
Microsoft.SPOT.Input Namespace


UIElement.RaiseEvent Method

UIElement.RaiseEvent Method

Raises a specific routed event.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void RaiseEvent (
         RoutedEventArgs args
)

Parameters

args
A RoutedEventArgs object that contains the event data and also identifies the routed event to be raised.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Bitmap.RANDOM Field

Bitmap.RANDOM Field

Fills the destination rectangle or circle with a randomly generated pattern.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int RANDOM

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Math.Random Method

Math.Random Method

Generates a pseudorandom number.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Random (
         int modulo
)

Parameters

modulo
A modulo to apply to the pseudorandom number that is generated. Note that the generated number is greater than or equal to 0 (zero) and less than the modulo.

Return Value

A pseudorandom number.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
Microsoft.SPOT Namespace


Math.Randomize Method

Math.Randomize Method

Sets a random starting point for random number generation.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Randomize ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
Microsoft.SPOT Namespace


SerializationHintsAttribute.RangeBias Field

SerializationHintsAttribute.RangeBias Field

Specifies the range bias adjustment for a particular serialized value.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public long RangeBias

Expand image Remarks

This is the calculated middle range in which the serialized value should reside.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Class
SerializationHintsAttribute Members
Microsoft.SPOT Namespace


RawButtonActions Enumeration

RawButtonActions Enumeration

Specifies the current "raw" action of a button.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum RawButtonActions

Expand image Members

Member name | Description
Activate | A value specifying that the button is currently activated.
ButtonDown | A value specifying that the button is currently in the down position.
ButtonUp | A value specifying that the button is currently in the up position.
Deactivate | A value specifying that the button is currently deactivated.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Input Namespace


RawButtonInputReport Class

RawButtonInputReport Class
See Also Members
CollapseAll image

Represents a button device's input to InputProviderSite and InputManager objects.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class RawButtonInputReport : InputReport

Expand image Remarks

An InputProviderSite object receives an input report from an input provider. The InputProviderSite object forwards the input report to the InputManager object, which then places the input report in the staging area. Once the input report is in the staging area, it is changed into a series of Windows Presentation Foundation (WPF) events, which are then routed through the element tree.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RawButtonInputReport Members
Microsoft.SPOT.Input Namespace


RawButtonInputReport Members

RawButtonInputReport Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the RawButtonInputReport type.

Expand image Public Constructors

 | Name | Description
Public Method | RawButtonInputReport | Initializes a new instance of the RawButtonInputReport class, using specified values.

Expand image Public Fields

 | Name | Description
Public Field | Actions | Specifies the action of a particular button.
Public Field | Button | Specifies the button that is currently generating input.

Expand image See Also

Reference

RawButtonInputReport Class
Microsoft.SPOT.Input Namespace


ReasonSessionEnding Enumeration

ReasonSessionEnding Enumeration

Specifies the reason for the end of the session.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum ReasonSessionEnding

Expand image Members

Member name | Description
Logoff | A value specifying that the user has logged off.
Shutdown | A value specifying that the user has shut the system down.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


ExtendedWeakReference.Recover Method

ExtendedWeakReference.Recover Method

Recovers a specific ExtendedWeakReference object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static ExtendedWeakReference Recover (
         Type selector,
         UInt32 id
)

Parameters

selector
The type associated with the weak reference you want to recover.
id
The ID associated with the weak reference you want to recover.

Return Value

A weak reference, or a null reference if there are no more weak references to be recovered.

Expand image Remarks

You can call this method multiple times to recover all of the weak references associated with a specific type or ID.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


ExtendedWeakReference.RecoverOrCreate Method

ExtendedWeakReference.RecoverOrCreate Method

Attempts to recover a specific ExtendedWeakReference object, and creates a new instance of this class if the recovery attempt fails.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static ExtendedWeakReference RecoverOrCreate (
         Type selector,
         UInt32 id,
         UInt32 flags
)

Parameters

selector
The type associated with the weak reference you want to recover.
id
The ID associated with the weak reference you want to recover.
flags
The flags for the new ExtendedWeakReference object that will be created if the one you specified is not recovered.

Return Value

The weak reference you specified, or a null reference if the recovery attempt failed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


Colors.Red Field

Colors.Red Field

The system-defined color that has an RGB value of #FF0000.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color Red

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


Object.ReferenceEquals Method

Object.ReferenceEquals Method

Determines whether two specified instances (objects) of the Object class are the same object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static bool ReferenceEquals (
         Object objA,
         Object objB
)

Parameters

objA
The first object you want to compare.
objB
The second object you want to compare.

Return Value

true if the objA and objB parameters are exactly the same or if both are null references; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


Reflection Class

Reflection Class
See Also Members
CollapseAll image

Provides information about assemblies and the types defined within them, as well as information about creating, invoking, and accessing type instances at run time.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class Reflection

Expand image Version Information

Supported in .NET Framework version 2.0

Expand image See Also

Reference

Reflection Members
Microsoft.SPOT Namespace


Reflection Members

Reflection Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the Reflection type.

Expand image Public Constructors

 | Name | Description
Public Method | Reflection | Creates and initializes a new instance of the Reflection class.

Expand image Public Methods

Name | Description
Deserialize | Deserializes a byte array of data into an object of the specified type.
GetAssemblies | Gets all known assemblies.
GetAssemblyFromHash | Gets the assembly with the specified hash attribute.
GetAssemblyHash | Retrieves the hash attribute from a specified assembly.
GetAssemblyInfo | Get an AssemblyInfo object from a byte array that represents a specified assembly.
GetAssemblyLastUse | Gets a System.TimeSpan value that represents the time at which the specified assembly was last used.
GetAssemblyPatch | Gets the assembly that is designated as a patch for the specified assembly.
GetTypeFromHash | Gets the type that uses the specified hash attribute.
GetTypeHash | Gets the hash attribute for a specified type.
GetTypesImplementingInterface | Gets the System.Type objects (types) that implement the specified interface.
IsTypeLoaded | Indicates whether a specified type is loaded.
Serialize | Serializes an object of the specified type to a byte array of data.

Expand image See Also

Reference

Reflection Class
Microsoft.SPOT Namespace


System.Reflection Namespace

System.Reflection Namespace

The System.Reflection namespace in the Microsoft® .NET Micro Framework contains classes, an interface, and enumerations that provide you with a managed view of loaded types, methods, and fields and enable you to create and invoke types dynamically.

Expand image Classes

 | Name | Description
Public Class | Assembly | Defines an Assembly object, which is a reusable, self-describing building block of a common language runtime (CLR) application. Note that you can create different versions of a single Assembly object.
Public Class | AssemblyCompanyAttribute | Defines a company name custom attribute for an assembly manifest.
Public Class | AssemblyConfigurationAttribute | Defines an assembly configuration custom attribute (such as retail or debug) for an assembly manifest.
Public Class | AssemblyCopyrightAttribute | Defines a copyright custom attribute for an assembly manifest.
Public Class | AssemblyCultureAttribute | Specifies the culture that a particular assembly supports.
Public Class | AssemblyDefaultAliasAttribute | Defines a "friendly" default alias for an assembly manifest.
Public Class | AssemblyDelaySignAttribute | Specifies that an assembly is not fully signed when it is created.
Public Class | AssemblyDescriptionAttribute | Defines an assembly description custom attribute for an assembly manifest.
Public Class | AssemblyFlagsAttribute | Specifies whether the assembly being attributed supports side-by-side execution on the same computer, in the same process, or in the same application domain.
Public Class | AssemblyInformationalVersionAttribute | Defines additional version information for an assembly manifest.
Public Class | AssemblyKeyFileAttribute | Specifies the name of a file containing the key pair that is used to generate a strong name for the assembly being attributed.
Public Class | AssemblyKeyNameAttribute | Specifies the name of a key container within the Cryptographic Service Provider (CSP) that contains the key pair that is used to generate a strong name for the assembly being attributed.
Public Class | AssemblyProductAttribute | Defines a product name custom attribute for an assembly manifest.
Public Class | AssemblyTitleAttribute | Defines an assembly title attribute for an assembly manifest.
Public Class | AssemblyTrademarkAttribute | Defines a trademark attribute for an assembly manifest.
Public Class | AssemblyVersionAttribute | Specifies the version number of the assembly being attributed.
Public Class | Binder | Selects a member from a list of candidates, and performs a type conversion from actual argument type to formal argument type.
Public Class | ConstructorInfo | Discovers the attributes of a class constructor and provides access to constructor metadata.
Public Class | DefaultMemberAttribute | Defines the member of a type that is the default member used by the System.Type.InvokeMember method.
Public Class | FieldInfo | Discovers the attributes of a specific field and provides access to field metadata.
Public Class | MemberInfo | Discovers the attributes of a particular member and provides access to member metadata.
Public Class | MethodBase | Provides information about methods and constructors.
Public Class | MethodInfo | Discovers the attributes of a particular method and provides access to method metadata.
Public Class | PropertyInfo | Discovers the attributes of a particular property and provides access to property metadata.

Expand image Interfaces

 | Name | Description
Public Interface | IReflect | Enables objects to return MemberInfo objects that represent other objects.

Expand image Enumerations

 | Name | Description
Public Enumeration | AssemblyNameFlags | Provides information about an Assembly reference.
Public Enumeration | BindingFlags | Contains flags that control binding and the way in which the search for members and types is conducted by reflection.
Public Enumeration | MemberTypes | Marks each member type that is defined as a class derived from the MemberInfo class.
Public Enumeration | MethodImplAttributes | Contains flags for the attributes of a method implementation.
Public Enumeration | ProcessorArchitecture | Specifies the type of microprocessor used by the hardware device.


Reflection.AssemblyInfo.m_refs Field

Reflection.AssemblyInfo.m_refs Field

Contains an array of references to assemblies that the current assembly is dependent on.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt32[] m_refs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


InputManager.RegisterInputProvider Method

InputManager.RegisterInputProvider Method

Registers an input source with the input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputProviderSite RegisterInputProvider (
         Object inputProvider
)

Parameters

inputProvider
An object that specifies the input source.

Return Value

An InputProviderSite object that is responsible for informing the input manager when input is received from the specified source.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputManager Class
InputManager Members
Microsoft.SPOT.Input Namespace


ArrayList.Remove Method

ArrayList.Remove Method

Removes the first occurrence of a specified object from the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void Remove (
         Object obj
)

Parameters

obj
The object you want to remove from the ArrayList collection. This value can be a null reference.

Expand image Remarks

This method performs a linear search; therefore, the average execution time is proportional to the value of the Count property. In other words, this method is an O(n) operation, where n is the value of Count.

This method determines equality by calling the Object.Equals method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


Delegate.Remove Method

Delegate.Remove Method

Removes the last occurrence of a delegate's invocation list from another delegate's invocation list.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Delegate Remove (
         Delegate source,
         Delegate value
)

Parameters

source
The delegate from which you want to remove the invocation list of value.
value
The delegate that supplies the invocation list you want to remove from the invocation list of source.

Return Value

A new delegate with an invocation list formed by taking the invocation list of source and removing the last occurrence of the invocation list of value, if the invocation list of value is found within the invocation list of source.

-or-

source, if value is a null reference or if the invocation list of value is not found within the invocation list of source.

-or-

A null reference, if the invocation list of value is equal to the invocation list of source, or if source is a null reference.

Expand image Remarks

If the invocation list of value matches a contiguous set of elements in the invocation list of source, the invocation list of value is said to occur within the invocation list of source. If the invocation list of value occurs more than once in the invocation list of source, the last occurrence of the repeated list is removed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


System.Collections.IList.Remove Method

System.Collections.IList.Remove Method

Removes a specified object from an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
void System.Collections.IList.Remove (
         Object value
)

Parameters

value
The object you want to remove from the array.

Expand image Remarks

The Array object has a fixed size. Therefore, inserting objects into an array of this type does not increase the length of the array, and removing objects from it does not decrease its length.

This method always throws a NotSupportedException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.Remove Method

IList.Remove Method

When implemented by a class, this method removes the first occurrence of a specified object from the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void Remove (
         Object value
)

Parameters

value
The object you want to remove from the IList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.Remove Method

ListBoxItemCollection.Remove Method

Removes a specified item from the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Remove (
         ListBoxItem item
)

Parameters

item
The item you want to remove from the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.Remove Method

TextRunCollection.Remove Method

Removes the first occurrence of a specified TextRun object from the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Remove (
         TextRun run
)

Parameters

run
The TextRun object whose first occurrence is to be removed from the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.Remove Method

UIElementCollection.Remove Method

Removes a specified element from the current collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Remove (
         UIElement element
)

Parameters

element
A UIElement object that specifies the element you want to remove from the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WeakDelegate.Remove Method

WeakDelegate.Remove Method

Removes the invocation list of a specified delegate from the invocation list of another specified delegate.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static Delegate Remove (
         Delegate a,
         Delegate b
)

Parameters

a
The delegate from which you want to remove the invocation list.
b
The delegate that supplies the invocation list you want to remove from the delegate specified in a.

Return Value

A new delegate with an invocation list formed by taking the invocation list of the a parameter and removing the invocation list of the b parameter, if b's invocation list is found in a's invocation list. If b is a null reference, or if b's invocation list is not found in a's invocation list, this method returns a. If b's invocation list is equal to a's invocation list, or if b is a null reference, this method returns null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakDelegate Class
WeakDelegate Members
Microsoft.SPOT Namespace


ArrayList.RemoveAt Method

ArrayList.RemoveAt Method

Removes the object at the specified index number in the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual void RemoveAt (
         int index
)

Parameters

index
The zero-based index number of the object you want to remove.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


System.Collections.IList.RemoveAt Method

System.Collections.IList.RemoveAt Method

Removes the object at a specified location (index number) in an array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
void System.Collections.IList.RemoveAt (
         int index
)

Parameters

index
The index number at which you want to remove an object from the array.

Expand image Remarks

The Array object has a fixed size. Therefore, inserting objects into an array of this type does not increase the length of the array, and removing objects from it does not decrease its length.

This method always throws a NotSupportedException exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


IList.RemoveAt Method

IList.RemoveAt Method

When implemented by a class, this method removes the object at the specified index number in the IList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void RemoveAt (
         int index
)

Parameters

index
The zero-based index number of the object you want to remove from the IList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IList Interface
IList Members
System.Collections Namespace


ListBoxItemCollection.RemoveAt Method

ListBoxItemCollection.RemoveAt Method

Removes the item (element) at a specified index number in the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void RemoveAt (
         int index
)

Parameters

index
The index number of the item you want to remove from the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.RemoveAt Method

TextRunCollection.RemoveAt Method

Removes the TextRun object at a specified position (index number) in the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void RemoveAt (
         int index
)

Parameters

index
The index number of the TextRun object to be removed from the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.RemoveAt Method

UIElementCollection.RemoveAt Method

Removes from the current collection the element at the specified index number (position) in the collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void RemoveAt (
         int index
)

Parameters

index
The index number of the UIElement object you want to remove from the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


UIElementCollection.RemoveRange Method

UIElementCollection.RemoveRange Method

Removes from the current collection a range of elements starting at a specified index number (position) in the collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void RemoveRange (
         int index,
         int count
)

Parameters

index
The index number in the current collection where you want the removal of elements to begin.
count
The number of elements you want to remove from the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


InputReportEventArgs.Report Field

InputReportEventArgs.Report Field

Contains the input report that specifies the input to the InputProviderSite and InputManager objects.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public InputReport Report

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReportEventArgs Class
InputReportEventArgs Members
Microsoft.SPOT.Input Namespace


InputProviderSite.ReportInput Method

InputProviderSite.ReportInput Method

Determines whether a specified input report has been forwarded to the input manager.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool ReportInput (
         InputReport inputReport
)

Parameters

inputReport
An InputReport object that represents input from an input provider.

Return Value

true if the specified input report has been forwarded to the input manager; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputProviderSite Class
InputProviderSite Members
Microsoft.SPOT.Input Namespace


GC.ReRegisterForFinalize Method

GC.ReRegisterForFinalize Method

Requests that the system call the finalizer method for a specified object, after the SuppressFinalize method has been called for this object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void ReRegisterForFinalize (
         Object obj
)

Parameters

obj
The object for which a finalizer must be called.

Expand image Remarks

The ReRegisterForFinalize method adds the obj parameter to the list of objects that request finalization before the garbage collector frees the specified object. The obj parameter must be the caller of this method.

Calling the ReRegisterForFinalize method does not guarantee that the garbage collector will call an object's finalizer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

GC Class
GC Members
System Namespace


AutoResetEvent.Reset Method

AutoResetEvent.Reset Method

Sets the state of the specified event to nonsignaled.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Reset ()

Return Value

true if the function succeeded; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AutoResetEvent Class
AutoResetEvent Members
System.Threading Namespace


UIElementCollection.Enumerator.Reset Method

UIElementCollection.Enumerator.Reset Method

Resets the enumerator to its initial position, immediately preceding the first element in the collection.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Reset ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection.Enumerator Structure
UIElementCollection.Enumerator Members
Microsoft.SPOT.Presentation Namespace


IEnumerator.Reset Method

IEnumerator.Reset Method

Sets the enumerator to its initial position, immediately preceding the first object in a specified collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public void Reset ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IEnumerator Interface
IEnumerator Members
System.Collections Namespace


Bitmap.ResetClippingRectangle Method

Bitmap.ResetClippingRectangle Method

Resets a bitmap's clipping region (clipping rectangle) to the entire bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void ResetClippingRectangle ()

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ResourceManager Class

ResourceManager Class
See Also Members
CollapseAll image

Provides convenient access to culture-specific resources at run time.

Namespace: System.Resources
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public class ResourceManager

Expand image Remarks

The ResourceManager class enables you to look up culture-specific resources, provides a fallback resource when a particular localized resource does not exist, and supports resource serialization.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceManager Members
System.Resources Namespace


ResourceManager Members

ResourceManager Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the ResourceManager type.

Expand image Public Constructors

 | Name | Description
Public Method | ResourceManager | Initializes a new instance of the ResourceManager class that looks up resources contained in files derived from the specified root name, using a specified Assembly object.

Expand image See Also

Reference

ResourceManager Class
System.Resources Namespace


System.Resources Namespace

System.Resources Namespace

The System.Resources namespace in the Microsoft® .NET Micro Framework provides a class that gives software developers easy run-time access to culture-specific resources used in .NET Micro Framework applications.

Expand image Classes

 | Name | Description
Public Class | ResourceManager | Provides convenient access to culture-specific resources at run time.


ResourceUtility Class

ResourceUtility Class
See Also Members
CollapseAll image

Helps .NET Micro Framework applications manage resources.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public sealed class ResourceUtility

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Members
Microsoft.SPOT Namespace


ResourceUtility Members

ResourceUtility Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the ResourceUtility type.

Expand image Public Constructors

 | Name | Description
Public Method | ResourceUtility | Constructs a ResourceUtility object.

Expand image Public Methods

Name | Description
GetDelimitedStringResource | Retrieves the string representation of a specified resource.
GetDelimitedStringResources | Retrieves the string representations of the specified resources.
GetObject | Gets the value of a specified Object resource for the current system culture.
SetCurrentUICulture | Sets the information for the current system culture.

Expand image See Also

Reference

ResourceUtility Class
Microsoft.SPOT Namespace


DispatcherOperation.Result Property

DispatcherOperation.Result Property

Gets the result of the delegate associated with the current DispatcherOperation object, if the operation has completed.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object Result { get; }

Property Value

The result of the operation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


Thread.Resume Method

Thread.Resume Method

Resumes a thread that has been suspended.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Resume ()

Expand image Remarks

Note
CAUTION Do not use the Suspend and Resume methods to synchronize the activities of threads. You have no way of knowing what code a thread is executing when you suspend it. If you suspend a thread while it is holding locks during a security permission evaluation, other threads in the AppDomain object might be blocked. If you suspend a thread while it is executing a class constructor, other threads in the AppDomain object that attempt to use that class will be blocked. In other words, using the Suspend and Resume methods to synchronize thread activities can very easily cause deadlocks, so you should avoid using them for this purpose.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


MethodInfo.ReturnType Property

MethodInfo.ReturnType Property

Gets the return type of the current method.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Type ReturnType { get; }

Property Value

The return type of the current method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodInfo Class
MethodInfo Members
System.Reflection Namespace


PresentationSource.RootUIElement Property

PresentationSource.RootUIElement Property

Gets or sets the logical root UI element of a source of content.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement RootUIElement { get; set; }

Property Value

A UIElement object that represents the root UI element of the source.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PresentationSource Class
PresentationSource Members
Microsoft.SPOT.Presentation Namespace


UIElement.RootUIElement Property

UIElement.RootUIElement Property

Gets the logical root element of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UIElement RootUIElement { get; }

Property Value

A UIElement object that specifies the logical root element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Bitmap.RotateBlt Method

Bitmap.RotateBlt Method

Rotates a bitmap to a specified degree around a specified point.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
[MethodImplAttribute]
public void RotateBlt (
         Bitmap pSrc,
         int degree,
         int xSrc,
         int ySrc,
         int xDst,
         int yDst
)

Parameters

pSrc
The source bitmap.
degree
The degree of rotation.
xSrc
The x-coordinate of the center of the source bitmap.
ySrc
The y-coordinate of the center of the source bitmap.
xDst
The x-coordinate of the center of the destination bitmap.
yDst
The y-coordinate of the center of the destination bitmap.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


RoutedEventArgs.RoutedEvent Property

RoutedEventArgs.RoutedEvent Property

Gets or sets a routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutedEvent RoutedEvent { get; set; }

Property Value

A routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


RoutedEvent Class

RoutedEvent Class
See Also Members
CollapseAll image

Represents and identifies a routed event and declares its characteristics.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class RoutedEvent

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Members
Microsoft.SPOT Namespace


RoutedEvent Members

RoutedEvent Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the RoutedEvent type.

Expand image Public Constructors

 | Name | Description
Public Method | RoutedEvent | Initializes a new instance of the RoutedEvent class.

Expand image Public Properties

 | Name | Description
Public Property | HandlerType | Gets the handler type of the current RoutedEvent object.
Public Property | Name | Gets the identifying name of the current RoutedEvent object.
Public Property | RoutingStrategy | Gets the routing strategy of the current Routed Event object.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Retrieves a string representation of the current RoutedEvent object.

Expand image See Also

Reference

RoutedEvent Class
Microsoft.SPOT Namespace


RoutedEventArgs Class

RoutedEventArgs Class
See Also Members
CollapseAll image

Provides state information and event data associated with a particular routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class RoutedEventArgs : EventArgs

Expand image Remarks

You can use multiple RoutedEventArgs objects with a single routed event. This class provides extra event state information about the rounted event. The event system uses this class to invoke the handler associated with the routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Members
Microsoft.SPOT Namespace


RoutedEventArgs Members

RoutedEventArgs Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the RoutedEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | RoutedEventArgs | Overloaded. Initializes a new instance of the RoutedEventArgs class.

Expand image Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a particular routed event as it travels the route.
Public Property | OriginalSource | Gets the orginal object that raised the current routed event.
Public Property | RoutedEvent | Gets or sets a routed event.
Public Property | Source | Gets or sets a reference to the object that raised the current routed event.

Expand image Protected Methods

 | Name | Description
Protected Method | OnSetSource | Provides a notification callback entry point whenever the value of the Source property of an object changes.

Expand image See Also

Reference

RoutedEventArgs Class
Microsoft.SPOT Namespace


RoutedEventHandler Delegate

RoutedEventHandler Delegate

Represents an event handler that receive a routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void RoutedEventHandler (
         Object sender,
         RoutedEventArgs e
)

Parameters

sender
The sender of the routed event.
e
Event arguments that contain information about the routed event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


RoutedEventHandlerInfo Class

RoutedEventHandlerInfo Class
See Also Members
CollapseAll image

Constructs event routes.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class RoutedEventHandlerInfo

Expand image Remarks

You should use this class only in Microsoft® Visual Studio®. You should not try to use it in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


RoutedEvent.RoutingStrategy Property

RoutedEvent.RoutingStrategy Property

Gets the routing strategy of the current Routed Event object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public RoutingStrategy RoutingStrategy { get; }

Property Value

A value from the RoutingStrategy enumeration.

Expand image Remarks

When creating and naming routed events, you should try to follow the convention of using the prefix "Preview" in the names of all tunneling routed events. Also, as a general rule, you should try to avoid having a tunneling version of a routed event without having a matching bubbling version as well.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Class
RoutedEvent Members
Microsoft.SPOT Namespace


RoutingStrategy Enumeration

RoutingStrategy Enumeration

Indicates the routing strategy of a routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum RoutingStrategy

Expand image Members

Member name | Description
Bubble | A value indicating that the event uses a "bubbling" strategy, in which the event instance moves up the tree.
Direct | A value indicating that the event does not support routing.
Tunnel | A value indicating that the event uses a "tunneling" strategy, in which the event instance moves down the tree.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


RpcClient Class

RpcClient Class
See Also Members
CollapseAll image

Provides a client for remote procedure calls.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class RpcClient

Expand image Remarks

This class is provided for legacy applications and is not supported for use in new programs.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


RpcServer Class

RpcServer Class
See Also Members
CollapseAll image

Provides a server for remote procedure calls.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class RpcServer

Expand image Remarks

This class is provided for legacy applications and is not supported for use in new programs.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


Application.Run Method (Window)

Application.Run Method (Window)
See Also
CollapseAll image

Starts a Windows Presentation Foundation (WPF) application and opens a specified window.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Run (
         Window window
)

Parameters

window
A Window object representing a window that opens automatically when the WPF application starts running.

Expand image Remarks

This overload extends the Run method to open the specified window when the WPF application starts running.

If you define your Application object only in code, it calls the Run method explicitly .

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Application.Run Method ()

Application.Run Method ()
See Also
CollapseAll image

Starts a Windows Presentation Foundation (WPF) application.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Run ()

Expand image Remarks

The Run method is called to start a WPF application. If you define your Application object by using only XAML, or by using XAML and code in a code-behind page, Run is called implicitly (automatically). However, if you define your Application object by using only code, you must call Run explicitly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Application.Run Method

Application.Run Method

Starts a Windows Presentation Foundation (WPF) application.

Expand image Overload List

Name | Description
Application.Run () | Starts a Windows Presentation Foundation (WPF) application.
Application.Run (Window) | Starts a Windows Presentation Foundation (WPF) application and opens a specified window.

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Dispatcher.Run Method

Dispatcher.Run Method

Initiates the event queue of a Dispatcher object (dispatcher).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void Run ()

Expand image Remarks

A dispatcher processes its event queue in a loop, which is referred to as a frame. The Run method pushes the main execution frame onto the queue. The main execution frame continues until the program shuts down the dispatcher.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


RuntimeHelpers.RunClassConstructor Method

RuntimeHelpers.RunClassConstructor Method

Runs a specified class constructor method.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void RunClassConstructor (
         RuntimeTypeHandle type
)

Parameters

type
A RuntimeTypeHandle object that specifies the class constructor method you want to run.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RuntimeHelpers Class
RuntimeHelpers Members
System.Runtime.CompilerServices Namespace


RuntimeFieldHandle Structure

RuntimeFieldHandle Structure

Provides a field descriptor for internal use by the common language runtime (CLR).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct RuntimeFieldHandle

Expand image Remarks

This structure has no members. You should not use it in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Members
System Namespace


RuntimeHelpers Class

RuntimeHelpers Class
See Also Members
CollapseAll image

Provides a set of static methods and properties that provide support for compilers.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public static class RuntimeHelpers

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RuntimeHelpers Members
System.Runtime.CompilerServices Namespace


RuntimeHelpers Members

RuntimeHelpers Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the RuntimeHelpers type.

Expand image Public Properties

Name | Description
OffsetToStringData | Gets the offset, in bytes, to the data in a specified string within a particular String object.

Expand image Public Methods

Name | Description
GetObjectValue | Boxes a value type.
InitializeArray | Provides a fast way to initialize an array from data stored in a module.
RunClassConstructor | Runs a specified class constructor method.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image See Also

Reference

RuntimeHelpers Class
System.Runtime.CompilerServices Namespace


RuntimeTypeHandle Structure

RuntimeTypeHandle Structure

Represents a type using an internal metadata token.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct RuntimeTypeHandle

Expand image Remarks

This structure has no members. You should not use it in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Members
System Namespace


SerializationHintsAttribute.Scale Field

SerializationHintsAttribute.Scale Field

Specifies the scale adjustment for a particular serialized value.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public UInt64 Scale

Expand image Remarks

For time values, this property is measured in clock ticks.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Class
SerializationHintsAttribute Members
Microsoft.SPOT Namespace


SystemMetrics.ScreenColorDepth Property

SystemMetrics.ScreenColorDepth Property

Gets the number of colors that are available on the screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int ScreenColorDepth { get; }

Property Value

The number of colors that are available on the screen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemMetrics Class
SystemMetrics Members
Microsoft.SPOT.Presentation Namespace


SystemMetrics.ScreenHeight Property

SystemMetrics.ScreenHeight Property

Gets the height of the screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int ScreenHeight { get; }

Property Value

The height of the screen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemMetrics Class
SystemMetrics Members
Microsoft.SPOT.Presentation Namespace


SystemMetrics.ScreenWidth Property

SystemMetrics.ScreenWidth Property

Gets the width of the screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static int ScreenWidth { get; }

Property Value

The width of the screen.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemMetrics Class
SystemMetrics Members
Microsoft.SPOT.Presentation Namespace


ListBox.ScrollChanged Event

ListBox.ScrollChanged Event

Occurs when a list is scrolled.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event ScrollChangedEventHandler ScrollChanged

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.ScrollChanged Event

ScrollViewer.ScrollChanged Event

Occurs when changes to a ScrollViewer object's scroll position, extent, or viewport size are detected.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event ScrollChangedEventHandler ScrollChanged

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollChangedEventArgs Class

ScrollChangedEventArgs Class
See Also Members
CollapseAll image

Describes a change in the scrolling state and contains the required arguments for a ScrollChanged event.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ScrollChangedEventArgs : EventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollChangedEventArgs Members

ScrollChangedEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the ScrollChangedEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | ScrollChangedEventArgs | Initializes a new instance of the ScrollChangedEventArgs class.

Expand image Public Fields

 | Name | Description
Public Field | HorizontalChange | Contains the new (changed) horizontal offset value for a ScrollViewer object.
Public Field | HorizontalOffset | Contains the current horizontal offset value for a ScrollViewer object.
Public Field | VerticalChange | Contains the new (changed) vertical offset value for a ScrollViewer object.
Public Field | VerticalOffset | Contains the current vertical offset value for a ScrollViewer object.

Expand image See Also

Reference

ScrollChangedEventArgs Class
Microsoft.SPOT.Presentation.Controls Namespace


ScrollChangedEventHandler Delegate

ScrollChangedEventHandler Delegate

Handles a ScrollChanged event.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void ScrollChangedEventHandler (
         Object sender,
         ScrollChangedEventArgs args
)

Parameters

sender
The object on which the ScrollChanged event occurred.
args
A description of the ScrollChanged event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Controls Namespace


ScrollingStyle Enumeration

ScrollingStyle Enumeration

Specifies how a control, such as a ScrollViewer object, scrolls.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum ScrollingStyle

Expand image Members

Member name | Description
First | A value specifying that the object scrolls to the first line.
Last | A value specifying that the object scrolls to the last line.
LineByLine | A value specifying that the object scrolls one line at a time.
PageByPage | A value specifying that the object scrolls one page at a time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Controls Namespace


ListBox.ScrollingStyle Property

ListBox.ScrollingStyle Property

Gets or sets a value that controls how the current list box is scrolled.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ScrollingStyle ScrollingStyle { get; set; }

Property Value

A value that controls how the current list box is scrolled.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.ScrollingStyle Property

ScrollViewer.ScrollingStyle Property

Gets or sets a value that specifies how a ScrollViewer object scrolls its contents.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ScrollingStyle ScrollingStyle { get; set; }

Property Value

The scrolling style for the ScrollViewer object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.ScrollingStyle Property

TextFlow.ScrollingStyle Property

Gets or sets a value that specifies how text is scrolled.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ScrollingStyle ScrollingStyle { get; set; }

Property Value

The scrolling style for the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox.ScrollIntoView Method

ListBox.ScrollIntoView Method

Scrolls a specified item into view on a display device.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void ScrollIntoView (
         ListBoxItem item
)

Parameters

item
The item to be scrolled into view on the display device.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer Class

ScrollViewer Class
See Also Members
CollapseAll image

Defines the characteristics and functionality of a scrollable area (on a display device) that can contain other visible elements.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class ScrollViewer : ContentControl

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer Members

ScrollViewer Members
See Also Constructors Events Methods Properties
CollapseAll image

The following tables list the members exposed by the ScrollViewer type.

Expand image Public Constructors

 | Name | Description
Public Method | ScrollViewer | Initializes a new instance of the ScrollViewer class.

Expand image Public Properties

 | Name | Description
Public Property | ExtentHeight | Gets the height of the extent for a ScrollViewer object.
Public Property | ExtentWidth | Gets the width of the extent for a ScrollViewer object.
Public Property | HorizontalOffset | Gets or sets the horizontal offset of the scrolled content in a ScrollViewer object.
Public Property | LineHeight | Gets or sets the height, in pixels, of one line in a ScrollViewer object.
Public Property | LineWidth | Gets or sets the width, in pixels, of one line in a ScrollViewer object.
Public Property | ScrollingStyle | Gets or sets a value that specifies how a ScrollViewer object scrolls its contents.
Public Property | VerticalOffset | Gets or sets the vertical offset of the scrolled content in a ScrollViewer object.

Expand image Public Methods

 | Name | Description
Public Method | LineDown | Scrolls the contents (controls) of a ScrollViewer object downward by one line.
Public Method | LineLeft | Scrolls the contents (controls) of a ScrollViewer object to the left by a predetermined amount.
Public Method | LineRight | Scrolls the contents (controls) of a ScrollViewer object to the right by a predetermined amount.
Public Method | LineUp | Scrolls the contents (controls) of a ScrollViewer object upward by one line.
Public Method | PageDown | Scrolls the contents (controls) of a ScrollViewer object downward by one page.
Public Method | PageLeft | Scrolls the contents (controls) of a ScrollViewer object to the left by one page.
Public Method | PageRight | Scrolls the contents (controls) of a ScrollViewer object to the right by one page.
Public Method | PageUp | Scrolls the contents (controls) of a ScrollViewer object upward by one page.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Arranges and sizes the contents (controls) of a ScrollViewer object.
Protected Method | MeasureOverride | Measures the contents (controls) of a ScrollViewer object.
Protected Method | OnButtonDown | Displays an event description whenever the user presses a scroll button.

Expand image Public Events

 | Name | Description
Public Event | ScrollChanged | Occurs when changes to a ScrollViewer object's scroll position, extent, or viewport size are detected.

Expand image See Also

Reference

ScrollViewer Class
Microsoft.SPOT.Presentation.Controls Namespace


DateTime.Second Property

DateTime.Second Property

Gets the seconds component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Second { get; }

Property Value

The seconds, expressed as a number from 0 through 59.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Second Field

SystemTime.Second Field

Specifies the second associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Second

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


MFNetworkConfiguration.SecondaryDns Property

MFNetworkConfiguration.SecondaryDns Property

Gets or sets the secondary DNS address.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress SecondaryDns { get; set; }

Property Value

The secondary DNS address.

Expand image Version Information

Available in MFDeploy 2.0 SP1


TimeSpan.Seconds Property

TimeSpan.Seconds Property

Gets the number of whole seconds in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Seconds { get; }

Property Value

The number of whole seconds in the current TimeSpan object.

Expand image Remarks

The value of a TimeSpan object can be expressed as [-]d.hh:mm:ss.ff, where the optional minus sign indicates a negative time period, d is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. The value of the Seconds property is the seconds component, ss.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


ListBox.SelectedIndex Property

ListBox.SelectedIndex Property

Gets or sets the index number of a specified item in the current list box.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int SelectedIndex { get; set; }

Property Value

The index number of the specified item in the current list box.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


SelectionChangedEventArgs.SelectedIndex Field

SelectionChangedEventArgs.SelectedIndex Field

Specifies the index number of the item that is currently selected.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int SelectedIndex

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox.SelectedItem Property

ListBox.SelectedItem Property

Gets or sets a specified item in the current list box.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ListBoxItem SelectedItem { get; set; }

Property Value

The specified item in the current list box.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


SelectFont

SelectFont
See Also Example
CollapseAll image

Specifies a list of attributes that define the .tinyfnt font to create.

Expand image Syntax

SelectFont "selectionstring"

Parameters

selectionstring
A quoted string containing comma-delimited fields that indicate the characteristics of the .tinyfnt to create. The fields correspond to fields in the LOGFONT structure and the ENUMLOGFONTEX structure. Each field in selectionstring consists of one of the prefixes below, followed by a string described below:
Prefix Name Description
FN: Face Name The typeface name of the font, for instance, Miramonte. If the name includes spaces, this field must be enclosed in quotes, for example, FN:"Miramonte Bold". This field should always be specified to ensure consistent results.
WE: Weight Specifies the weight of the font in the range 0 through 1000. For example, 400 is normal and 700 is bold. This value corresponds to the lfWeight field of the LOGFONT structure. This value is optional, but should be specified to ensure consistent results. If this field is not provided, a normal weight is assumed.
HE: Height Specifies the height, in logical units, of the font's character cell or character. The character height value (also known as the em height) is the character cell height value minus the internal-leading value. For all height comparisons, the font mapper looks for the largest font that does not exceed the requested size.

If this value is greater than 0, the font mapper transforms this value into device units and matches it against the cell height of the available fonts.

If this value is less than 0, the font mapper transforms this value into device units and matches its absolute value against the character height of the available fonts.

This value is optional, but should be specified to ensure consistent results. If not specified, a default height is used.

WI: Width Specifies the average width, in logical units, of characters in the font. This value is optional.
ES: Escapement Specifies the angle, in tenths of degrees, between the escapement vector and the x-axis of the device. The escapement vector is parallel to the base line of a row of text. A positive escapement value will rotate characters counter-clockwise. For example, ES:300 will rotate characters 30 degrees counter-clockwise. This value is optional.
OR: Orientation Specifies the angle, in tenths of degrees, between each character's base line and the x-axis of the device. This value is optional. If you provide the OR: value, you should set it to be the same as the ES: value.
IT: Italic Specifies an italic font if set to 1. This value is optional.
UN: Underline Specifies an underlined font if set to 1. This value is optional.
CS: Character Set An integer that specifies the character set. This value corresponds to the lfCharset field of the LOGFONT structure. The character set defaults to ANSI if this field is not provided. Make sure that the value of the CS: field matches the character set of the typeface specified in the FN: field. The following table shows possible values:
Character Set | Value
ANSI | 0
Arabic | 178
Baltic | 186
Chinese Big5 | 136
Default | 1
Eastern Europe | 238
GB2312 | 134
Greek | 161
Hebrew | 177
Hangul | 129
Johab | 130
Mac | 77
OEM | 255
Russian | 204
Shift JIS | 128
Symbol | 2
Thai | 222
Turkish | 162
Vietnamese | 163
OP: Output Precision Specifies the output precision. This value is optional. This value corresponds to the lfOutPrecision field of the LOGFONT structure.
CP: Clip Precision Specifies the clip precision. This value is optional. This value corresponds to the lfClipPrecision field of the LOGFONT structure.
QA: Quality Specifies the quality. This value is optional. This value corresponds to the lfCharset field of the LOGFONT structure.
PF: Pitch and Family Specifies the pitch and family. This field is optional. This value corresponds to the lfPitchAndFamily member of the LOGFONT structure.
FullName: Full Name A string that specifies the full font name, which may include publisher and version information. For example, ABC Font Company TrueType Bold Italic Sans Serif. This value is optional.
Script: Script A string that specifies the character set of the font, for example, Cyrillic. This value is optional.
Style: Style A string that specifies the font style, for example, Bold Italic. This value is optional.

Expand image Remarks

TFConvert searches all TrueType fonts installed on the system, as well as any fonts specified in an AddFontToProcess argument, to find a font that matches the characteristics specified in the selectionstring argument. The .tinyfnt file is generated based on the first match.

A SelectFont statement "selects" the current font that subsequent statements in the .fntdef file refer to. A SelectFont statement must be followed by an ImportRange or ImportRangeAndMap statement that specifies the characters to import from the currently selected font. If any ImportRange or ImportRangeAndMap options appear in a .fntdef file before a font has been selected using a SelectFont statement, TFConvert fails.

Note
The comma-delimited fields in selectionstring may not be preceded by a space. For instance, SelectFont "WE:400,FN:Pericles" is a valid SelectFont option, but SelectFont "WE:400, FN:Pericles" is not.

Expand image Example

In the following .fntdef file, the SelectFont statement instructs TFConvert to look for a regular-weight font with the face name "Miramonte". Fonts installed on the system, as well as the font at the path specified in the AddFontToProcess argument, will be considered by TFConvert.
AddFontToProcess C:\SampleFonts\miramo.ttf
SelectFont "WE:400,FN:Miramonte"
#import upper case letters
ImportRange 65 90
In the following .fntdef file, the SelectFont statement instructs TFConvert to look for a bold-weight font of height 12, with the face name "Miramonte Bold". Note that the font name in the FN: field must be enclosed in quotes because it contains a space.
AddFontToProcess C:\SampleFonts\miramob.ttf
SelectFont "HE:12,WE:700,FN:"Miramonte Bold""
#import upper case letters
ImportRange 65 90

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AddFontToProcess


ListBox.SelectionChanged Event

ListBox.SelectionChanged Event

Occurs each time a user selects a different item in a list box.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event SelectionChangedEventHandler SelectionChanged

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


SelectionChangedEventArgs Class

SelectionChangedEventArgs Class
See Also Members
CollapseAll image

Provides data for an occurrence of the SelectionChanged event.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class SelectionChangedEventArgs : EventArgs

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SelectionChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


SelectionChangedEventArgs Members

SelectionChangedEventArgs Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the SelectionChangedEventArgs type.

Expand image Public Constructors

 | Name | Description
Public Method | SelectionChangedEventArgs | Initializes a new instance of the SelectionChangedEventArgs class.

Expand image Public Fields

 | Name | Description
Public Field | PreviousSelectedIndex | Specifies the index number of the item that was last selected.
Public Field | SelectedIndex | Specifies the index number of the item that is currently selected.

Expand image See Also

Reference

SelectionChangedEventArgs Class
Microsoft.SPOT.Presentation.Controls Namespace


SelectionChangedEventHandler Delegate

SelectionChangedEventHandler Delegate

Handles a SelectionChanged event.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public delegate void SelectionChangedEventHandler (
         Object sender,
         SelectionChangedEventArgs args
)

Parameters

sender
The ScrollViewer object on which the SelectionChanged event occurred.
args
A description of the SelectionChanged event.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Controls Namespace


ExtendedWeakReference.Selector Property

ExtendedWeakReference.Selector Property

Gets the selector for the current ExtendedWeakReference object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public Type Selector { get; }

Property Value

The selector for the current weak reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


SerializableAttribute Class

SerializableAttribute Class
See Also Members
CollapseAll image

Indicates that a specified class can be serialized.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class SerializableAttribute : Attribute

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializableAttribute Members
System Namespace


SerializableAttribute Members

SerializableAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the SerializableAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | SerializableAttribute | Initializes a new instance of the SerializableAttribute class.

Expand image See Also

Reference

SerializableAttribute Class
System Namespace


SerializationFlags Enumeration

SerializationFlags Enumeration

Defines a set of flags that indicate various attributes of a serialization (serialized object).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[FlagsAttribute]
public enum SerializationFlags

Expand image Members

Member name | Description
Compressed | A value indicating that the serialized object is compressed. This flag is not currently implemented.
DemandTrusted | This flag is not currently implemented.
ElementsNeverNull | A value indicating that the elements in the serialized object are never null.
Encrypted | A value indicating that the serialized object is encrypted. This flag is not currently implemented.
FixedType | A value indicating that the serialized object can only be an instance of the specified class, and not an instance of a derived class.
Optional | A value indicating that the serialized object can be skipped if it cannot be deserialized. This flag is not currently implemented.
PointerNeverNull | A value indicating that the pointer to the serialized object is never null.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


SerializationHintsAttribute Class

SerializationHintsAttribute Class
See Also Members
CollapseAll image

Indicates that a particular serializable object has known attributes and methods of serialization.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public class SerializationHintsAttribute : Attribute

Expand image Remarks

Because these attributes are known, the attribute and method information will not be serialized, thus saving storage space and data transfer memory.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SerializationHintsAttribute Members
Microsoft.SPOT Namespace


SerializationHintsAttribute Members

SerializationHintsAttribute Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the SerializationHintsAttribute type.

Expand image Public Fields

 | Name | Description
Public Field | ArraySize | Specifies the size of a particular serialized array.
Public Field | BitPacked | Specifies the number of bits in which the current object is bit-packed.
Public Field | Flags | Contains flags that describe the serialization of the current object.
Public Field | RangeBias | Specifies the range bias adjustment for a particular serialized value.
Public Field | Scale | Specifies the scale adjustment for a particular serialized value.

Expand image See Also

Reference

SerializationHintsAttribute Class
Microsoft.SPOT Namespace


Reflection.Serialize Method

Reflection.Serialize Method

Serializes an object of the specified type to a byte array of data.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static byte [] Serialize (
         Object o,
         Type t
)

Parameters

o
The object you want to serialize.
t
The type of the object you want to serialize. This parameter can be a null reference.

Return Value

A byte array containing data that represents the serialized object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection Class
Reflection Members
Microsoft.SPOT Namespace


AutoResetEvent.Set Method

AutoResetEvent.Set Method

Sets the state of the specified event to signaled.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public bool Set ()

Return Value

true if the function succeeded; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AutoResetEvent Class
AutoResetEvent Members
System.Threading Namespace


SetAsDefaultCharacter

SetAsDefaultCharacter
See Also Example
CollapseAll image

Specifies the value of the character to substitute for characters not imported into the .tinyfnt font.

Expand image Syntax

SetAsDefaultCharacter charcode

Parameters

charcode
The Unicode code point for the default character.

Expand image Remarks

A SelectFont statement that specifies the font from which to import glyphs must precede the SetAsDefaultCharacter statement in the .fntdef file. Otherwise TFConvert will fail. If there are multiple SelectFont statements, the one that more closely precedes the SetAsDefaultCharacter statement will be used.

Expand image Example

The following .fntdef file will import the uppercase characters from A to C, and set X as the default character.
      AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Kooten.ttf"
      SelectFont "WE:400,FN:Kootenay"
      #import A, B, C
      ImportRange 65 67
      SetAsDefaultCharacter 88 #use X as default

Expand image See Also

Reference

SetDefaultCharacter
NoDefaultCharacter


Border.SetBorderThickness Method

Border.SetBorderThickness Method

Sets the thickness of a particular border, in pixels.

Expand image Overload List

Name | Description
Border.SetBorderThickness (Int32) | Sets the thickness of a particular border, in pixels.
Border.SetBorderThickness (Int32, Int32, Int32, Int32) | Sets the thickness of a particular border, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Border.SetBorderThickness Method (Int32, Int32, Int32, Int32)

Border.SetBorderThickness Method (Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Sets the thickness of a particular border, in pixels.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetBorderThickness (
         int left,
         int top,
         int right,
         int bottom
)

Parameters

left
The screen coordinate of the left edge of the border's background.
top
The screen coordinate of the top edge of the border's background.
right
The screen coordinate of the right edge of the border's background.
bottom
The screen coordinate of the bottom edge of the border's background.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Border.SetBorderThickness Method (Int32)

Border.SetBorderThickness Method (Int32)
See Also
CollapseAll image

Sets the thickness of a particular border, in pixels.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetBorderThickness (
         int length
)

Parameters

length
The thickness of the border, in pixels.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Border Class
Border Members
Microsoft.SPOT.Presentation.Controls Namespace


Canvas.SetBottom Method

Canvas.SetBottom Method

Sets the row number of the bottom of the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void SetBottom (
         UIElement e,
         int bottom
)

Parameters

e
The child element for which the bottom row number in the containing area is to be set.
bottom
The row number of the bottom of the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


Bitmap.SetClippingRectangle Method

Bitmap.SetClippingRectangle Method

Sets the clipping region (clipping rectangle) of a bitmap with a specified coordinate pair (x,y), width, and height.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void SetClippingRectangle (
         int x,
         int y,
         int width,
         int height
)

Parameters

x
The x-coordinate of the upper-left corner of the clipping rectangle.
y
The y-coordinate of the upper-left corner of the clipping rectangle.
width
The width of the clipping rectangle.
height
The height of the clipping rectangle.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

          Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
          Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
          // copy the bitmap
          bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
          // now you may modify the copy using any Bitmap method
          bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

Setting the parameters of this method to negative values produces undefined results.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


ResourceUtility.SetCurrentUICulture Method

ResourceUtility.SetCurrentUICulture Method

Sets the information for the current system culture.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static void SetCurrentUICulture (
         CultureInfo culture
)

Parameters

culture
The object that contains the information for the current system culture.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ResourceUtility Class
ResourceUtility Members
Microsoft.SPOT Namespace


StagingAreaInputItem.SetData Method

StagingAreaInputItem.SetData Method

Creates an entry, associating it with a specified key.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetData (
         Object key,
         Object value
)

Parameters

key
An object that specifies the key you want to associate with the new entry.
value
An object that represents the input and its event-related data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StagingAreaInputItem Class
StagingAreaInputItem Members
Microsoft.SPOT.Input Namespace


SetDefaultCharacter

SetDefaultCharacter
See Also Example
CollapseAll image

Indicates that the default character defined by a TrueType font will be substituted for characters not imported to the TINYFNT font.

Expand image Syntax

SetDefaultCharacter

Expand image Remarks

A SelectFont statement that specifies the font from which to import glyphs must precede the SetDefaultCharacter statement in the .fntdef file. Otherwise TFConvert will fail. If there are multiple SelectFont statements, the one that more closely precedes the SetDefaultCharacter statement will be used.

Expand image Example

      AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Linds.ttf"
      AddFontToProcess "C:\\Program Files\\Microsoft .NET Micro Framework\\v2.0.3036\\Tools\\Fonts\\TrueType\\Kooten.ttf"
      SelectFont "WE:400,FN:Lindsey"
      #import X
      ImportRange 88 88
      SelectFont "WE:400,FN:Kootenay"
      #import A, B, C
      ImportRange 65 67
      #use the default character from Kootenay as the default character.
      SetDefaultCharacter

Expand image See Also

Reference

SetAsDefaultCharacter
NoDefaultCharacter


Canvas.SetLeft Method

Canvas.SetLeft Method

Sets the number of the leftmost column in the rectangular area that contains a specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void SetLeft (
         UIElement e,
         int left
)

Parameters

e
The child element for which the leftmost column number in the containing area is to be set.
left
The leftmost column number in the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElement.SetMargin Method (Int32, Int32, Int32, Int32)

UIElement.SetMargin Method (Int32, Int32, Int32, Int32)
See Also
CollapseAll image

Sets the size of the current element's margin, using a specified width for each of the four sides of the element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetMargin (
         int left,
         int top,
         int right,
         int bottom
)

Parameters

left
The width of the left margin.
top
The width of the top margin.
right
The width of the right margin.
bottom
The width of the bottom margin.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.SetMargin Method (Int32)

UIElement.SetMargin Method (Int32)
See Also
CollapseAll image

Sets the size of the current element's margin, using the same (specified) width for each of the four sides of the element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetMargin (
         int length
)

Parameters

length
The width of the margin on all four sides of the element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement.SetMargin Method

UIElement.SetMargin Method

Sets the size of the current element's margin.

Expand image Overload List

Name | Description
UIElement.SetMargin (Int32) | Sets the size of the current element's margin, using the same (specified) width for each of the four sides of the element.
UIElement.SetMargin (Int32, Int32, Int32, Int32) | Sets the size of the current element's margin, using a specified width for each of the four sides of the element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Bitmap.SetPixel Method (Int32, Int32, Color)

Bitmap.SetPixel Method (Int32, Int32, Color)
See Also
CollapseAll image

Sets the color for a specified pixel.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void SetPixel (
         int xPos,
         int yPos,
         Color color
)

Parameters

xPos
The x-coordinate of the pixel whose color you want to set.
yPos
The y-coordinate of the pixel whose color you want to set.
color
The color you want to set for the specified pixel.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Bitmap.SetPixel Method

Bitmap.SetPixel Method

Turns a specified pixel on or off.

Expand image Overload List

Name | Description
Bitmap.SetPixel (Int32, Int32, Boolean) | Turns a specified pixel on or off.
Bitmap.SetPixel (Int32, Int32, Color) | Sets the color for a specified pixel.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.SetPixel Method

DrawingContext.SetPixel Method

Sets a single pixel to a color.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void SetPixel (
         Color color,
         int x,
         int y
)

Parameters

color
The color value to set the pixel to.
x
The horizontal coordinate of the pixel.
y
The vertical coordinate of the pixel.

Expand image Remarks

In addition to the values Black and White, your program can set the color parameter to any color using RGB values in hexadecimal format. For example, setting color to 0x00FF0000 specifies red.

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.SetPixel Method (Int32, Int32, Boolean)

Bitmap.SetPixel Method (Int32, Int32, Boolean)
See Also
CollapseAll image

Turns a specified pixel on or off.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
public void SetPixel (
         int xPos,
         int yPos,
         bool fSet
)

Parameters

xPos
The x-coordinate of the pixel you want to set.
yPos
The y-coordinate of the pixel you want to set.
fSet
The parameter that you can set to true to turn the pixel on, or set to false to turn the pixel off.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Canvas.SetRight Method

Canvas.SetRight Method

Sets the rightmost column number in the area that contains the specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void SetRight (
         UIElement e,
         int right
)

Parameters

e
The child element for which the rightmost column number in the containing area is to be set.
right
The rightmost column number in the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


ExtendedTimeZone.SetTimeOffset Method

ExtendedTimeZone.SetTimeOffset Method

Sets the time offset.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void SetTimeOffset (
         int minutes
)

Parameters

minutes
The amount of time you want to set the device system time ahead of the true time, in minutes.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


ExtendedTimeZone.SetTimeZone Method

ExtendedTimeZone.SetTimeZone Method

Sets the time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void SetTimeZone (
         TimeZoneId id
)

Parameters

id
The time zone you want to set the device system to.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


ExtendedTimeZone.SetTimeZoneInfo Method

ExtendedTimeZone.SetTimeZoneInfo Method

Sets the extended information for a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void SetTimeZoneInfo (
         TimeZoneInformation timeZoneInformation
)

Parameters

timeZoneInformation
The extended information for a particular time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


Canvas.SetTop Method

Canvas.SetTop Method

Sets the row number of the top of the area that contains the specified child element.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static void SetTop (
         UIElement e,
         int top
)

Parameters

e
The child element for which the top row number in the containing area is to be set.
top
The row number of the top of the area that contains the specified child element.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Canvas Class
Canvas Members
Microsoft.SPOT.Presentation.Controls Namespace


FieldInfo.SetValue Method

FieldInfo.SetValue Method

Sets the value of a field supported by a specified object.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
[MethodImplAttribute]
public virtual void SetValue (
         Object obj,
         Object value
)

Parameters

obj
The object whose field value will be set.
value
The value to be assigned to the field.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

FieldInfo Class
FieldInfo Members
System.Reflection Namespace


PropertyInfo.SetValue Method

PropertyInfo.SetValue Method

Sets the value of an indexed property for a specified object with optional index values.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
[MethodImplAttribute]
public virtual void SetValue (
         Object obj,
         Object value,
         Object[] index
)

Parameters

obj
The object whose property value will be set.
value
The new value for the current property.
index
Optional index values for indexed properties. For nonindexed properties, this value should be a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

PropertyInfo Class
PropertyInfo Members
System.Reflection Namespace


DateTimeFormatInfo.ShortDatePattern Property

DateTimeFormatInfo.ShortDatePattern Property

Gets the format pattern for a short date value, which is associated with the "d" format character.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ShortDatePattern { get; }

Property Value

The format pattern for a short date value, which is associated with the "d" format character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


DateTimeFormatInfo.ShortTimePattern Property

DateTimeFormatInfo.ShortTimePattern Property

Gets the format pattern for a short time value, which is associated with the "t" format character.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ShortTimePattern { get; }

Property Value

The format pattern for a short time value, which is associated with the "t" format character.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


Application.Shutdown Method

Application.Shutdown Method

Causes an application to exit.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Shutdown ()

Expand image Remarks

When the Shutdown method is called, it triggers an Exit event. Your event handler can process the Exit event to detect when an application is about to stop running. At that time, the event handler performs any necessary processing.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Dispatcher.ShutdownFinished Event

Dispatcher.ShutdownFinished Event

Occurs when a Dispatcher object (a dispatcher) finishes shutting down.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler ShutdownFinished

Expand image Remarks

When a program starts shutting down a Dispatcher object, the ShutdownStarted event is raised and the HasShutdownStarted property is set to true. The dispatcher does not shut down completely until its event queue unwinds. When the dispatcher finishes shutting down, it raises the ShutdownFinished event and sets the HasShutdownFinished property to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


Application.ShutdownMode Property

Application.ShutdownMode Property

Gets or sets the condition that causes the Shutdown method to be called.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public ShutdownMode ShutdownMode { get; set; }

Property Value

A value from the ShutdownMode enumeration. The default return value is OnLastWindowClose.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


ShutdownMode Enumeration

ShutdownMode Enumeration

Defines how an application shuts down.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum ShutdownMode

Expand image Members

Member name | Description
OnExplicitShutdown | A value that causes the application to shut down when your program explicitly calls the Application.Shutdown method.
OnLastWindowClose | A value that causes the application to shut down when the last window closes or when your program explicitly calls the Application.Shutdown method. Note that this is the default setting.
OnMainWindowClose | A value that causes the application to shut down when the main window closes or when your program explicitly calls the Application.Shutdown method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


Dispatcher.ShutdownStarted Event

Dispatcher.ShutdownStarted Event

Occurs when a Dispatcher object (a dispatcher) begins the shutdown process.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler ShutdownStarted

Expand image Remarks

When a program starts shutting down a Dispatcher object, the ShutdownStarted event is raised and the HasShutdownStarted property is set to true. The dispatcher does not shut down completely until its event queue unwinds. When the dispatcher finishes shutting down, it raises the ShutdownFinished event and sets the HasShutdownFinished property to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


Math.Sin Method

Math.Sin Method

Gets the sine of the specified angle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static int Sin (
         int angle
)

Parameters

angle
An angle, measured in degrees.

Return Value

The sine of the specified angle, multiplied by 1000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Math Class
Math Members
Microsoft.SPOT Namespace


Bitmap.SINGLEPIXEL Field

Bitmap.SINGLEPIXEL Field

Specifies that a circle should have only a single-pixel border and no fill pattern or color.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int SINGLEPIXEL

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


Reflection.AssemblyInfo.m_size Field

Reflection.AssemblyInfo.m_size Field

Specifies the size of the current assembly.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int m_size

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Reflection.AssemblyInfo Class
Reflection.AssemblyInfo Members
Microsoft.SPOT Namespace


StructLayoutAttribute.Size Field

StructLayoutAttribute.Size Field

Indicates the absolute size of a particular class or structure.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Size

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


SizeToContent Enumeration

SizeToContent Enumeration

Specifies how a window should be sized, relative to its contents.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum SizeToContent

Expand image Members

Member name | Description
Height | A value specifying that the window automatically sizes itself to the height of its contents, but not the width.
Manual | A value specifying that the window does not automatically size itself to fit its contents. Instead, the size of the window is determined by other properties, including the UIElement.Height and UIElement.Width properties.
Width | A value specifying that the window automatically sizes itself to the width of its contents, but not the height.
WidthAndHeight | A value specifying that the window automatically sizes itself to both the height and width of its contents.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation Namespace


Window.SizeToContent Property

Window.SizeToContent Property

Gets or sets a value that specifies how the current window should be sized relative to its content.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public SizeToContent SizeToContent { get; set; }

Property Value

A value of the SizeToContent enumeration that specifies how the current window should be sized relative to its content. Note that the default return value is Manual.

Expand image Remarks

This property has the following limitations:

  • If you set the window's SizeToContent property to WidthAndHeight, you cannot programmatically alter the window's Height property or Width property.
  • If you set the window's SizeToContent property to Height, you can still programmatically alter the window's Height property.
  • If you set the window's SizeToContent property to Width, you can still programmatically alter the window's Width property.
  • If a user manually changes the window's size, autosizing is disabled and the window's SizeToContent property is set to Manual by default.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


Thread.Sleep Method

Thread.Sleep Method

Suspends the current thread for a specified amount of time.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Sleep (
         int millisecondsTimeout
)

Parameters

millisecondsTimeout
The number of milliseconds for which the current thread is to be blocked, or suspended. Specify 0 (zero) to indicate that this thread should be suspended so that other waiting threads can execute. Specify infinite to suspend the thread indefinitely.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


Socket Class

Socket Class
See Also Members
CollapseAll image

For internal use only. Please use System.Net.Sockets instead.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public static class Socket

Expand image See Also

Reference

Socket
Microsoft.SPOT Namespace


SolidColorBrush Class

SolidColorBrush Class
See Also Members
CollapseAll image

Paints (fills) an area with a single, uniform color on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class SolidColorBrush : Brush

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SolidColorBrush Members
Microsoft.SPOT.Presentation.Media Namespace


SolidColorBrush Members

SolidColorBrush Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the SolidColorBrush type.

Expand image Public Constructors

 | Name | Description
Public Method | SolidColorBrush | Initializes a new instance of the SolidColorBrush class with a specified color for the brush's paint, or fill.

Expand image Public Fields

 | Name | Description
Public Field | Color | Specifies the color for the brush's paint, or fill.

Expand image See Also

Reference

SolidColorBrush Class
Microsoft.SPOT.Presentation.Media Namespace


RoutedEventArgs.Source Property

RoutedEventArgs.Source Property

Gets or sets a reference to the object that raised the current routed event.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object Source { get; set; }

Property Value

The object that raised the current routed event.

Expand image Remarks

Typically, you would set this property only when overriding or implementing other API methods that adjust event sources.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEventArgs Class
RoutedEventArgs Members
Microsoft.SPOT Namespace


String.Split Method (Char[])

String.Split Method (Char[])
See Also
CollapseAll image

Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string [] Split (
         char[] separator
)

Parameters

separator
[ParamArrayAttribute] An array of Unicode characters that delimit the substrings in the current String object, an empty array that contains no delimiters, or a null reference.

Return Value

An array consisting of a single element that contains the current String object, if this object contains none of the characters specified in the separator parameter.

-or-

An array of substrings if the current object is delimited by one or more of the characters in separator.

-or-

An array of the substrings in the current object, delimited by white-space characters, if those characters occur in the object and separator is a null reference or contains no delimiter characters.

Note that the Empty field is returned for any substring in which two delimiters are adjacent, or if a delimiter is found at the beginning or end of the current object.

Delimiter characters are not included in the substrings.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Split Method (Char[], Int32)

String.Split Method (Char[], Int32)
See Also
CollapseAll image

Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string [] Split (
         char[] separator,
         int count
)

Parameters

separator
An array of Unicode characters that delimit the substrings in the current String object, an empty array that contains no delimiters, or a null reference.
count
The maximum number of array elements to be returned.

Return Value

An array consisting of a single element that contains the current String object, if the object contains none of the characters specified in the separator parameter.

-or-

An array of substrings if the current object is delimited by one or more of the characters in separator.

-or-

An array of the substrings in the current object, delimited by white-space characters, if those characters occur and separator is a null reference or contains no delimiter characters.

Note that the Empty field is returned for any substring in which two delimiters are adjacent, or if a delimiter is found at the beginning or end of the current object.

Delimiter characters are not included in the substrings.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Split Method

String.Split Method

Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.

Expand image Overload List

Name | Description
String.Split (Char[]) | Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.
String.Split (Char[], Int32) | Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Microsoft.SPOT Namespace

Microsoft.SPOT Namespace

The Microsoft.SPOT namespace contains classes, delegates, and enumerations that are specific to the Microsoft® .NET Micro Framework.
Note
The .NET Micro Framework was formerly known as Smart Personal Objects Technology (SPOT).

Expand image Classes

 | Name | Description
Public Class | Application | Encapsulates a Windows Presentation Foundation (WPF) application.
Public Class | Bitmap | Encapsulates a bitmap, which consists of the pixel data for a graphics image and its methods and attributes.
Public Class | CancelEventArgs | Provides data for an event that can be canceled.
Public Class | ConstraintException | The exception that is thrown when an action is attempted that violates a constraint.
Public Class | Debug | Provides a set of methods and properties that help you debug your code.
Public Class | Dispatcher | Provides services for maintaining the event queue for a thread.
Public Class | DispatcherFrame | Represents an execution loop iteration in the dispatcher event queue.
Public Class | DispatcherObject | Represents an object that is associated with a dispatcher.
Public Class | DispatcherOperation | Enables programs to interact with a delegate that has been posted to a dispatcher queue.
Public Class | DispatcherTimer | A timer that is integrated into a dispatcher queue.
Public Class | EventArgs | Constitutes the base class for classes that contain event data.
Public Class | EventHandlersStore | Provides a container for event handlers.
Public Class | EventRoute | Provides a container for a route to be followed by a routed event.
Public Class | ExecutionConstraint | Provides a method you can use to require a thread to complete an operation within specific constraints.
Public Class | ExtendedTimer | Provides a mechanism for executing methods at specified intervals or on specific events.
Public Class | ExtendedTimeZone | Represents a time zone.
Public Class | ExtendedWeakReference | Represents an extended weak reference, which references an object but still leaves it prone to garbage collection.
Public Class | FieldNoReflectionAttribute | Sets a field such that there can be no reflection it.
Public Class | Font | Defines a particular format for text, including font choice, font size, and style attributes.
Public Class | GloballySynchronizedAttribute | Indicates that a particular method is globally synchronized.
Public Class | Logging | Provides methods and properties for managing logged data.
Public Class | Math | Provides static methods for common mathematical functions.
Public Class | PropertyChangedEventArgs | Provides data for a property changed event.
Public Class | PublishInApplicationDirectoryAttribute | Indicates that an application should be published in its application directory.
Public Class | Reflection | Provides information about assemblies and the types defined within them, as well as information about creating, invoking, and accessing type instances at run time.
Public Class | Reflection.AssemblyInfo | Defines an AssemblyInfo object (an assembly), which is a self-describing building block of a common language runtime (CLR) application.
Public Class | ResourceUtility | Helps .NET Micro Framework applications manage resources.
Public Class | RoutedEvent | Represents and identifies a routed event and declares its characteristics.
Public Class | RoutedEventArgs | Provides state information and event data associated with a particular routed event.
Public Class | RoutedEventHandlerInfo | Constructs event routes.
Public Class | RpcClient | Provides a client for remote procedure calls.
Public Class | RpcServer | Provides a server for remote procedure calls.
Public Class | SerializationHintsAttribute | Indicates that a particular serializable object has known attributes and methods of serialization.
Public Class | Socket | For internal use only. Please use System.Net.Sockets instead.
Public Class | SystemTime | Sets or gets the current system time for the device.
Public Class | TimeZoneInformation | Contains information describing a specific time zone.
Public Class | UnknownTypeException | The exception that is thown when an error occurs because of an unknown type.
Public Class | WeakDelegate | Provides methods for combining and removing "weak" delegates.
Public Class | WindowCollection | Collects the window objects for an application into a single set, or window collection.

Expand image Delegates

 | Name | Description
Public Delegate | CancelEventHandler | Provides the method that handles a cancelable event.
Public Delegate | DispatcherOperationCallback | Provides callback functionality for dispatcher operations.
Public Delegate | EventHandler | Provides a method that handles events that have no event data.
Public Delegate | PropertyChangedEventHandler | Handles a property change event.
Public Delegate | RoutedEventHandler | Represents an event handler that receive a routed event.

Expand image Enumerations

 | Name | Description
Public Enumeration | Bitmap.BitmapImageType | Lists the available formats for bitmap images.
Public Enumeration | DispatcherOperationStatus | Describes the possible values for the status of a DispatcherOperation object.
Public Enumeration | ExtendedTimer.TimeEvents | Defines the various timer events that are available in the .NET Micro Framework.
Public Enumeration | ExtendedWeakReference.PriorityLevel | Defines a set of constants available for prioritizing extended weak references.
Public Enumeration | ReasonSessionEnding | Specifies the reason for the end of the session.
Public Enumeration | RoutingStrategy | Indicates the routing strategy of a routed event.
Public Enumeration | SerializationFlags | Defines a set of flags that indicate various attributes of a serialization (serialized object).
Public Enumeration | ShutdownMode | Defines how an application shuts down.
Public Enumeration | TimeZoneId | Provides the set of time zones that are available for .NET Micro Framework applications.


Bitmap.SRCCOPY Field

Bitmap.SRCCOPY Field

Copies the source rectangle directly to the destination rectangle.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int SRCCOPY

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


StackPanel Class

StackPanel Class
See Also Members
CollapseAll image

Arranges child elements (child objects) in a single line that can be oriented either horizontally or vertically.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class StackPanel : Panel

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StackPanel Members
Microsoft.SPOT.Presentation.Controls Namespace


StackPanel Members

StackPanel Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the StackPanel type.

Expand image Public Constructors

 | Name | Description
Public Method | StackPanel | Overloaded. Initializes a new instance of the StackPanel class.

Expand image Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the presentation (orientation) of the child user interface elements.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Arranges the layout of the child objects contained by the StackPanel control.
Protected Method | MeasureOverride | Measures the children of a StackPanel in anticipation of arranging them during the ArrangeOverride pass.

Expand image See Also

Reference

StackPanel Class
Microsoft.SPOT.Presentation.Controls Namespace


Exception.StackTrace Property

Exception.StackTrace Property

Gets a string representation of the frames on the call stack at the time when the current exception was thrown.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string StackTrace { get; }

Property Value

A string that describes the contents of the call stack at the time when the current exception was thrown, starting with the most recent method call.

Expand image Remarks

The execution stack keeps track of all the methods that are executing at a particular point in time. A trace of these method calls is called a stack trace. You can use the stack trace listing to follow the call sequence to the line number in the method where a specific exception occurred.

Note that the StackTrace property may not report as many method calls as you might expect, because of code transformations (such as inlining) that occur during optimization.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


StagingAreaInputItem Class

StagingAreaInputItem Class
See Also Members
CollapseAll image

Encapsulates an input for entry in the staging area.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class StagingAreaInputItem

Expand image Remarks

An InputProviderSite object receives an input (represented by an InputReport object) from an input provider. The InputProviderSite object forwards the input to the InputManager object, which then places the input in the staging area, where it is stored as a StagingAreaInputItem object. Once the input is in the staging area, it is changed into a series of Windows Presentation Foundation (WPF) events, which are then routed through the element tree.

The StagingAreaInputItem class provides dictionary-based storage of the input and its event-related data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StagingAreaInputItem Members
Microsoft.SPOT.Input Namespace


StagingAreaInputItem Members

StagingAreaInputItem Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the StagingAreaInputItem type.

Expand image Public Fields

 | Name | Description
Public Field | Input | Specifies the data for the events related to the input.
Public Field | IsMarker | Indicates whether the input is used as a marker.

Expand image Public Methods

 | Name | Description
Public Method | GetData | Gets the entry associated with a specified key.
Public Method | SetData | Creates an entry, associating it with a specified key.

Expand image See Also

Reference

StagingAreaInputItem Class
Microsoft.SPOT.Input Namespace


NotifyInputEventArgs.StagingItem Field

NotifyInputEventArgs.StagingItem Field

Specifies the StagingAreaInputItem object that represents a particular input in the staging area.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public StagingAreaInputItem StagingItem

Expand image Remarks

An InputProviderSite object receives an input (represented by an InputReport object) from an input provider. The InputProviderSite object forwards the input to the InputManager object, which then places the input in the staging area, where it is stored as a StagingAreaInputItem object. Once the input is in the staging area, it is changed into a series of Windows Presentation Foundation (WPF) events, which are then routed through the element tree.

The StagingAreaInputItem class provides dictionary-based storage of the input, along with its event-related data.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

NotifyInputEventArgs Class
StagingAreaInputItem Class
NotifyInputEventArgs Members
Microsoft.SPOT.Input Namespace


TimeZoneInformation.StandardBias Field

TimeZoneInformation.StandardBias Field

Specifies the bias value to be used for local time translations that occur during standard time in a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public int StandardBias

Expand image Remarks

This field is ignored if a DaylightDate value has not been set.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


TimeZoneInformation.StandardDate Field

TimeZoneInformation.StandardDate Field

Contains a date and a local time when the transition from daylight saving time to standard time will occur on this operating system.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public SystemTime StandardDate

Expand image Remarks

If a particular time zone does not support daylight saving time, or if the caller needs to disable daylight saving time, the Month value in the SystemTime object must be 0 (zero). If this date is specified, the StandardDate field in this TimeZoneInformation object must also be specified. Otherwise, the system assumes that the time zone data is invalid and no changes are applied.

To select the correct day in the month, set the SystemTime object's Year member to 0 (zero), set the Hour and Minute members to the transition time, set the DayOfWeek member to the appropriate day of the week, and set the Day member to indicate the sequential occurrence of that day of the week within that month (that is, the first, second, third, fourth, or fifth occurrence of that day of the week in that month).

Using the following syntax, you can specify 2:00 a.m. on the first Sunday in each April: Hour = 2, Month = 4, DayOfWeek = 0, Day 1. Similarly, you can specify 2:00 a.m. on the last Thursday in each October as follows: Hour = 2, Month = 10, DayOfWeek = 4, Day = 5.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


ExtendedTimeZone.StandardName Property

ExtendedTimeZone.StandardName Property

Gets the standard name for a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public override string StandardName { get; }

Property Value

The standard name for a particular time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


TimeZone.StandardName Property

TimeZone.StandardName Property

Gets the standard time zone name.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract string StandardName { get; }

Property Value

The standard time zone name.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


TimeZoneInformation.StandardName Field

TimeZoneInformation.StandardName Field

Contains a description of standard time.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public string StandardName

Expand image Remarks

This string can be a full text description, an abbreviated description, or an acronym. For example, you could denote Eastern Standard Time as "EST". Note that this string can be empty.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Class
TimeZoneInformation Members
Microsoft.SPOT Namespace


DaylightTime.Start Property

DaylightTime.Start Property

Gets the DateTime object that represents the date and time when daylight saving time begins for the local time zone.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime Start { get; }

Property Value

The DateTime object that represents the date and time when daylight saving time begins for the local time zone. This return value is expressed in local time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DaylightTime Class
DaylightTime Members
System.Globalization Namespace


DispatcherTimer.Start Method

DispatcherTimer.Start Method

Starts a DispatcherTimer object's timer.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Start ()

Expand image Remarks

Setting the IsEnabled property to false when the timer is running stops the timer. Setting the IsEnabled property to true when the timer is stopped starts the timer. Calling the Start method sets the IsEnabled property to true.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


Thread.Start Method

Thread.Start Method

Starts execution of a thread.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Start ()

Expand image Remarks

This method causes the operating system to change the state of the current ThreadState.Running member to indicate that the thread is started. Once started, the thread can be paused by calling the Suspend method and resumed by invoking the Resume method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


LinearGradientBrush.StartColor Field

LinearGradientBrush.StartColor Field

Specifies the color at the beginning of the gradient path. This is the color at the point specified by the StartX and StartY fields.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Color StartColor

Expand image Remarks

This field is a value of the Color enumeration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


Application.Startup Event

Application.Startup Event

Occurs when the Run method of an Application object is called.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler Startup

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


LinearGradientBrush.StartX Field

LinearGradientBrush.StartX Field

The horizontal coordinate (relative to the left edge of the area being painted) of the starting point of the gradient path. The default value is 0 (zero), which is the left edge of the area.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int StartX

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


LinearGradientBrush.StartY Field

LinearGradientBrush.StartY Field

The vertical coordinate (relative to the top edge of the area being painted) of the starting point of the gradient path. The default value is 0 (zero), which is the top edge of the area.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int StartY

Expand image Remarks

This field is a value of the Color enumeration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

LinearGradientBrush Class
LinearGradientBrush Members
Microsoft.SPOT.Presentation.Media Namespace


DebuggerBrowsableAttribute.State Property

DebuggerBrowsableAttribute.State Property

Gets the current browsing state of a particular section of code.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DebuggerBrowsableState State { get; }

Property Value

The current browsing state of a particular section of code.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerBrowsableAttribute Class
DebuggerBrowsableAttribute Members
System.Diagnostics Namespace


STAThreadAttribute Class

STAThreadAttribute Class
See Also Members
CollapseAll image

Indicates that the COM threading model for a specific application is set to single-threaded apartment (STA).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class STAThreadAttribute : Attribute

Expand image Remarks

The STAThreadAttribute class is provided for devices that connect to personal computers. Note that you use this class for applications that run on the computers, not on the devices themselves.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

STAThreadAttribute Members
System Namespace


STAThreadAttribute Members

STAThreadAttribute Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the STAThreadAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | STAThreadAttribute | Initializes a new instance of the STAThreadAttribute class.

Expand image See Also

Reference

STAThreadAttribute Class
System Namespace


DispatcherOperation.Status Property

DispatcherOperation.Status Property

Gets the current operation status of the delegate on the dispatcher queue associated with the current DispatcherOperation object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherOperationStatus Status { get; }

Property Value

The status of the operation.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


DispatcherTimer.Stop Method

DispatcherTimer.Stop Method

Stops a DispatcherTimer object's timer.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Stop ()

Expand image Remarks

Setting the IsEnabled property to true when the timer is stopped starts the timer. Setting the IsEnabled property to false when the timer is running stops the timer. Calling the Stop method sets the IsEnabled property to false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


ImageBrush.Stretch Field

ImageBrush.Stretch Field

Specifies how an image extends (stretches) over the display area.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Stretch Stretch

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ImageBrush Class
ImageBrush Members
Microsoft.SPOT.Presentation.Media Namespace


Stretch Enumeration

Stretch Enumeration

Specifies how an image is sized within its layout area on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Stretch

Expand image Members

Member name | Description
Fill | A value specifying that the image is resized such that it completely fills the layout area. When you use this member, the aspect ratio of the image is not preserved.
None | A value specifying that the image is not resized (that is, its original size is preserved).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Media Namespace


Bitmap.StretchImage Method

Bitmap.StretchImage Method

Draws a rectangular block of pixels on the display device, stretching or shrinking the rectangular area as necessary.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void StretchImage (
         int xDst,
         int yDst,
         Bitmap bitmap,
         int width,
         int height,
         UInt16 opacity
)

Parameters

xDst
The x-coordinate of the upper-left corner of the rectangular area to which the pixels are to be copied.
yDst
The y-coordinate of the upper-left corner of the rectangular area to which the pixels are to be copied.
bitmap
The source bitmap.
width
The width of the rectangluar area to which the pixels are to be copied.
height
The height of the rectangluar area to which the pixels are to be copied.
opacity
The bitmap's degree of opacity. A value of 0 (zero) makes the bitmap completely opaque (not transparent at all); a value of 255 makes the bitmap completely transparent.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


String Class

String Class
See Also Members
CollapseAll image

Represents a text string composed of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
[SerializableAttribute]
public sealed class String

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Members
System Namespace


String Members

String Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the String type.

Expand image Public Constructors

 | Name | Description
Public Method | String | Overloaded. Initializes a new instance of the String class.

Expand image Public Fields

Name | Description
Empty | Represents an empty instance of the String class. This field is read-only.

Expand image Public Properties

 | Name | Description
Public Property | Chars | Gets the character at a specified index number (character position) in the current String object.
Public Property | Length | Gets the number of characters in the current String object.

Expand image Public Methods

 | Name | Description
 | Compare | Compares two specified String objects with one another.
Public Method | CompareTo | Overloaded. Compares the current String object with a specified String object or Object object.
 | Concat | Overloaded. Concatenates one or more String objects or the String representations of the args values for one or more Object objects.
 | Equals | Determines whether two specified String objects have the same value.
Public Method | IndexOf | Overloaded. Reports the index number, or character position, of the first occurrence of a specified String object or one or more specified Unicode characters in the current String object.
Public Method | IndexOfAny | Overloaded. Reports the index number, or character position, of the first occurrence in the current String object of any character within a specified array of Unicode characters.
 | Intern | Retrieves the system's reference to a specified String object.
 | IsInterned | Retrieves a reference to a specified String object.
Public Method | LastIndexOf | Overloaded. Reports the index number, or character position, of the last occurrence of a specified Unicode character or String object in the current String object.
Public Method | LastIndexOfAny | Overloaded. Reports the index number, or character position, of the last occurrence in the current String object of any character within a specified array of Unicode characters.
 | op_Equality | Determines whether two specified String objects have the same value.
 | op_Inequality | Determines whether two specified String objects have different values.
Public Method | Split | Overloaded. Identifies the substrings in the current String object that are delimited by one or more characters specified in an array, and then places the substrings in a String array.
Public Method | Substring | Overloaded. Retrieves a substring from the current String object.
Public Method | ToCharArray | Overloaded. Copies the characters in the current String object to an array of Unicode characters.
Public Method | ToLower | Returns the current String object in lowercase.
Public Method | ToString | Returns the current String object; no actual conversion is performed.
Public Method | ToUpper | Returns the current String object in uppercase.
Public Method | Trim | Overloaded. Removes all occurrences of a specified array of Unicode characters from the beginning and end of the current String object.
Public Method | TrimEnd | Removes all occurrences of a specified array of Unicode characters from the end of the current String object.
Public Method | TrimStart | Removes all occurrences of a specified array of Unicode characters from the beginning of the current String object.

Expand image See Also

Reference

String Class
System Namespace


StructLayoutAttribute Class

StructLayoutAttribute Class
See Also Members
CollapseAll image

The StructLayoutAttribute class provides fields and properties you can use to control the physical layout of the data fields of a class or structure.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[AttributeUsageAttribute]
public sealed class StructLayoutAttribute : Attribute

Expand image Remarks

Note that you can apply this attribute to either classes or structures.

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


StructLayoutAttribute Members

StructLayoutAttribute Members
See Also Constructors Fields Properties
CollapseAll image

The following tables list the members exposed by the StructLayoutAttribute type.

Expand image Public Constructors

 | Name | Description
Public Method | StructLayoutAttribute | Overloaded. Initalizes a new instance of the StructLayoutAttribute class.

Expand image Public Fields

 | Name | Description
Public Field | CharSet | Indicates how string data fields within a particular class should be marshaled by default — that is, as LPWSTR or as LPSTR.
Public Field | Pack | Controls the alignment of the data fields of a particular class or structure in memory.
Public Field | Size | Indicates the absolute size of a particular class or structure.

Expand image Public Properties

 | Name | Description
Public Property | Value | Gets the LayoutKind value that specifies how a particular class or structure is arranged.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image See Also

Reference

StructLayoutAttribute Class
System.Runtime.InteropServices Namespace


MFNetworkConfiguration.SubNetMask Property

MFNetworkConfiguration.SubNetMask Property

Gets or sets the subnet address mask.

Namespace: Microsoft.NetMicroFramework.Tools.MFDeployTool.Engine
Assembly: (in )

Expand image Syntax

C#
public System.Net.IPAddress SubNetMask { get; set; }

Property Value

The subnet mask.

Expand image Version Information

Available in MFDeploy 2.0 SP1


String.Substring Method (Int32, Int32)

String.Substring Method (Int32, Int32)
See Also
CollapseAll image

Retrieves a substring from the current String object. The substring starts at a specified index number, or character position, in the String object and has a specified length.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string Substring (
         int startIndex,
         int length
)

Parameters

startIndex
The starting index number in the substring.
length
The number of characters in the substring

Return Value

A String object equivalent to the substring of the length specified in the length parameter, beginning at the starting index number in the current String object.

-or-

The Empty field if the startIndex parameter is equal to the length of the current object and length is 0 (zero).

Expand image Remarks

The startIndex parameter is zero-based.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Substring Method (Int32)

String.Substring Method (Int32)
See Also
CollapseAll image

Retrieves a substring from the current String object. The substring starts at a specified index number, or character position, in the String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string Substring (
         int startIndex
)

Parameters

startIndex
The starting index number of a substring in the current String object.

Return Value

A String object equivalent to the substring that begins at the starting index number in the current String object.

-or-

The Empty field if the startIndex parameter is equal to the length of the current object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Substring Method

String.Substring Method

Retrieves a substring from the current String object.

Expand image Overload List

Name | Description
String.Substring (Int32) | Retrieves a substring from the current String object. The substring starts at a specified index number, or character position, in the String object.
String.Substring (Int32, Int32) | Retrieves a substring from the current String object. The substring starts at a specified index number, or character position, in the String object and has a specified length.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DateTime.Subtract Method (TimeSpan)

DateTime.Subtract Method (TimeSpan)
See Also
CollapseAll image

Subtracts a specified time period from the current DateTime object, yielding a new DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime Subtract (
         TimeSpan val
)

Parameters

val
A TimeSpan object specifying the time period that is the subtrahend.

Return Value

A DateTime object that results from the subtraction of the val parameter from the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.Subtract Method (DateTime)

DateTime.Subtract Method (DateTime)
See Also
CollapseAll image

Subtracts a specified DateTime object from the current DateTime object, yielding a specific period of time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Subtract (
         DateTime val
)

Parameters

val
A DateTime object specifying the date/time value that is the subtrahend.

Return Value

A TimeSpan object specifying the time period that results from the subtraction of the val parameter from the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.Subtract Method

DateTime.Subtract Method

Subtracts either a time period or another DateTime object from the current DateTime object.

Expand image Overload List

Name | Description
DateTime.Subtract (DateTime) | Subtracts a specified DateTime object from the current DateTime object, yielding a specific period of time.
DateTime.Subtract (TimeSpan) | Subtracts a specified time period from the current DateTime object, yielding a new DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.Subtract Method

TimeSpan.Subtract Method

Subtracts a specified TimeSpan object (time period) from the current TimeSpan object, yielding a new TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan Subtract (
         TimeSpan ts
)

Parameters

ts
A TimeSpan object that represents the subtrahend.

Return Value

A TimeSpan object that results from the subtraction of the ts parameter from the current TimeSpan object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


DateTime.operator - Method (DateTime, TimeSpan)

DateTime.operator - Method (DateTime, TimeSpan)
See Also
CollapseAll image

Subtracts a specified period of time from a specified DateTime object, yielding a new DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTime operator - (
         DateTime d,
         TimeSpan t
)

Parameters

d
A DateTime object that specifies the date and time.
t
A TimeSpan object that specifies the time period.

Return Value

A DateTime object that results from the subtraction of the t object from the d object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.operator - Method (DateTime, DateTime)

DateTime.operator - Method (DateTime, DateTime)
See Also
CollapseAll image

Subtracts one DateTime object from another one, yielding a specific period of time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeSpan operator - (
         DateTime d1,
         DateTime d2
)

Parameters

d1
A DateTime object specifying the date/time value that is the minuend.
d2
A DateTime object specifying the date/time value that is the subtrahend.

Return Value

A TimeSpan object specifying the time period that results from the subtraction of the d2 object from the d1 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.operator - Method

DateTime.operator - Method

Subtracts one DateTime object from another one, or subtracts a specified time period from a specified DateTime object.

Expand image Overload List

Name | Description
DateTime.operator - (DateTime, DateTime) | Subtracts one DateTime object from another one, yielding a specific period of time.
DateTime.operator - (DateTime, TimeSpan) | Subtracts a specified period of time from a specified DateTime object, yielding a new DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.operator - Method

TimeSpan.operator - Method

Subtracts a specified TimeSpan object (time period) from another specified TimeSpan object, yielding a new TimeSpan object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static TimeSpan operator - (
         TimeSpan t1,
         TimeSpan t2
)

Parameters

t1
A TimeSpan object that constitutes the minuend.
t2
A TimeSpan object that constitutes the subtrahend.

Return Value

A TimeSpan object that results from the subtraction of the object specified by the t2 parameter from the object specified by the t1 parameter.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


GC.SuppressFinalize Method

GC.SuppressFinalize Method

Requests that the system not call the finalizer method for a specified object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void SuppressFinalize (
         Object obj
)

Parameters

obj
The object for which a finalizer must not be called.

Expand image Remarks

The SuppressFinalize method removes the obj parameter from the set of objects that require finalization. The obj parameter must be the caller of this method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

GC Class
GC Members
System Namespace


ExtendedWeakReference.c_SurviveBoot Field

ExtendedWeakReference.c_SurviveBoot Field

Contains a flag specifying that the current weak reference will be recoverable after the device reboots.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static UInt32 c_SurviveBoot

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


ExtendedWeakReference.c_SurvivePowerdown Field

ExtendedWeakReference.c_SurvivePowerdown Field

Contains a flag specifying that the current weak reference will be recoverable after the device powers down and restarts.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static UInt32 c_SurvivePowerdown

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedWeakReference Class
ExtendedWeakReference Members
Microsoft.SPOT Namespace


Thread.Suspend Method

Thread.Suspend Method

Suspends the current thread or, if it is already suspended, has no effect.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public void Suspend ()

Expand image Remarks

Note that if the current thread is already suspended, this method has no effect whatsoever.

Note
CAUTION Do not use the Suspend and Resume methods to synchronize the activities of threads. You have no way of knowing what code a thread is executing when you suspend it. If you suspend a thread while it is holding locks during a security permission evaluation, other threads in the AppDomain object might be blocked. If you suspend a thread while it is executing a class constructor, other threads in the AppDomain object that attempt to use that class will be blocked. In other words, using the Suspend and Resume methods to synchronize thread activities can very easily cause deadlocks, so you should avoid using them for this purpose.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


ExtendedTimeZone.SynchronizeWithNetworkTime Method

ExtendedTimeZone.SynchronizeWithNetworkTime Method

Synchronizes the device system time with the network time, if the device system currently has a network connection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static TimeSpan SynchronizeWithNetworkTime (
         DateTime startOfFrameUniversalTime,
         TimeSpan startofFrameMachineTime,
         TimeZoneId tzi
)

Parameters

startOfFrameUniversalTime
The UTC time obtained from the network.
startofFrameMachineTime
The device system time.
tzi
The ID of the time zone you want to synchronize to.

Return Value

A System.TimeSpan value that is set to the difference between the network time and the device system time.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


Array.SyncRoot Property

Array.SyncRoot Property

Gets an object that you can use to synchronize access to a specific array.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

An object that you can use to synchronize access to the array.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Array Class
Array Members
System Namespace


ArrayList.SyncRoot Property

ArrayList.SyncRoot Property

Gets an object that you can use to synchronize access to the ArrayList collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

An object that you can use to synchronize access to the ArrayList collection.

Expand image Remarks

Using the SyncRoot property, you can have derived classes create their own synchronized version of the ArrayList collection. The synchronizing code must perform operations on the SyncRoot property of the ArrayList collection, not directly on the collection itself. This ensures that objects in collections derived from other objects will function properly. Specifically, SyncRoot maintains proper synchronization with other threads that might be simultaneously modifying one or more objects in the ArrayList collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ICollection.SyncRoot Property

ICollection.SyncRoot Property

When implemented by a class, this property gets an object you can use to synchronize access to a specific ICollection collection.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual abstract Object SyncRoot { get; }

Property Value

An object you can use to synchronize access to the collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ICollection Interface
ICollection Members
System.Collections Namespace


ListBoxItemCollection.SyncRoot Property

ListBoxItemCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the current collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

The synchronization object for the current collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBoxItemCollection Class
ListBoxItemCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection.SyncRoot Property

TextRunCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the current text run collection.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

The synchronization object for the text run collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Class
TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


UIElementCollection.SyncRoot Property

UIElementCollection.SyncRoot Property

Gets an object that you can use to synchronize access to the ICollection interface.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

An object that you can use to synchronize access to the ICollection interface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Class
UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


WindowCollection.SyncRoot Property

WindowCollection.SyncRoot Property

Gets an object that you can use to synchronize access to a particular window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual Object SyncRoot { get; }

Property Value

An object that you can use to synchronize access to the window collection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Class
WindowCollection Members
Microsoft.SPOT Namespace


System Namespace

System Namespace

The System namespace in the Microsoft® .NET Micro Framework contains fundamental classes and base types that define commonly used value and reference data types, events and event handlers, interfaces, attributes, and processing exceptions.

Expand image Classes

 | Name | Description
Public Class | AppDomain | Represents an application domain, which is an isolated environment in which applications run.
Public Class | AppDomainUnloadedException | The exception that is thrown when an attempt is made to access an unloaded application domain.
Public Class | ApplicationException | The exception that is thrown when a nonfatal application error occurs.
Public Class | ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.
Public Class | ArgumentNullException | The exception that is thrown when a null reference is passed to a method that does not accept it as a valid argument.
Public Class | ArgumentOutOfRangeException | The exception that is thrown when the value of an argument is outside the allowable range of values, as defined by the method that was invoked.
Public Class | Array | Contains methods for creating, manipulating, searching, and sorting arrays. The Array class is therefore the base class for all arrays in the common language runtime (CLR).
Public Class | Attribute | Constitutes the base class for custom attributes.
Public Class | AttributeUsageAttribute | Specifies the usage of another attribute class.
Public Class | CLSCompliantAttribute | Indicates whether a particular program element is compliant with the Common Language Specification (CLS).
Public Class | Delegate | Represents a delegate, which is a data structure that refers to a static method or to a class instance and an instance method of that class.
Public Class | Exception | The exception that is thrown when errors occur during application execution.
Public Class | FlagsAttribute | Indicates that an enumeration can be treated as a bit field (a set of flags).
Public Class | GC | Controls the system garbage collector, a service that automatically reclaims unused computer memory.
Public Class | IndexOutOfRangeException | The exception that is thrown when an attempt is made to access an object in an array and the index number of that object is outside the bounds of the array.
Public Class | InvalidCastException | The exception that is thrown whenever invalid casting or explicit conversion occurs.
Public Class | InvalidOperationException | The exception that is thrown when a method call is invalid for a specified object's current state.
Public Class | MarshalByRefObject | Provides access to objects across application domain boundaries in applications that support remoting.
Public Class | Math | A small collection of common mathematical functions.
Public Class | MTAThreadAttribute | This class is intended for internal use. Indicates that the COM threading model for a specific application is set to multithreaded apartment (MTA).
Public Class | MulticastDelegate | Represents a multicast delegate, which is a delegate that can contain multiple elements in its invocation list.
Public Class | NonSerializedAttribute | Indicates that a field of a serializable class should not be serialized.
Public Class | NotImplementedException | The exception that is thrown when a requested method or operation is not implemented.
Public Class | NotSupportedException | The exception that is thrown when a called method is not supported by .NET Micro Framework.
Public Class | NullReferenceException | The exception that is thrown when there is an attempt to dereference a null object reference.
Public Class | Object | Supports all classes in the .NET Micro Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Micro Framework; it is the root of the type hierarchy.
Public Class | ObsoleteAttribute | Marks the program elements that are no longer in use.
Public Class | OutOfMemoryException | The exception that is thrown when there is not enough memory available to continue the execution of a program.
Public Class | ParamArrayAttribute | Indicates that the specified method will accept a variable number of arguments in its invocation.
Public Class | SerializableAttribute | Indicates that a specified class can be serialized.
Public Class | STAThreadAttribute | Indicates that the COM threading model for a specific application is set to single-threaded apartment (STA).
Public Class | String | Represents a text string composed of Unicode characters.
Public Class | SystemException | Constitutes the base class for predefined exceptions in the System namespace.
Public Class | TimeZone | Represents a specific time zone.
Public Class | Type | Represents type declarations for the following categories of types: class types, interface types, array types, value types, and enumeration types.
Public Class | ValueType | Constitutes the base class for value types.
Public Class | WeakReference | Represents a weak reference, which references an object but still leaves it prone to garbage collection.

Expand image Interfaces

 | Name | Description
Public Interface | IAsyncResult | Represents the status of an asynchronous operation.
Public Interface | ICloneable | Supports cloning, which creates a new instance (object) of a specific class such that the new object is a copy of an existing object of that class.
Public Interface | IComparable | Defines a generalized comparison method that a value type or class implements to create a type-specific comparison method.
Public Interface | ICustomFormatter | Defines a method that supports custom, user-defined formatting of a specified object's value.
Public Interface | IDisposable | Defines a method that frees, releases, or resets allocated unmanaged resources.
Public Interface | IFormatProvider | Provides a mechanism for retrieving an object to control formatting.
Public Interface | IFormattable | Provides functionality for formatting the value of an object as a string representation.

Expand image Structures

 | Name | Description
Public Structure | Boolean | Represents a Boolean value.
Public Structure | Byte | Represents a 8-bit unsigned integer.
Public Structure | Char | Represents a Unicode character.
Public Structure | DateTime | Represents a specific instant in time, expressed as a date and a time of day.
Public Structure | Double | Represents a double-precision floating point number.
Public Structure | Int16 | Represents a 16-bit integer.
Public Structure | Int32 | Represents a 32-bit integer.
Public Structure | Int64 | Represents a 64-bit integer.
Public Structure | RuntimeFieldHandle | Provides a field descriptor for internal use by the common language runtime (CLR).
Public Structure | RuntimeTypeHandle | Represents a type using an internal metadata token.
Public Structure | TimeSpan | Specifies a discrete period of time, or a time span.
Public Structure | UInt16 | Represents a 16-bit unsigned integer.
Public Structure | UInt32 | Represents a 32-bit unsigned integer.
Public Structure | UInt64 | Represents a 64-bit unsigned integer.
Public Structure | Void | Specifies a return value for a method that does not return a value.

Expand image Delegates

 | Name | Description
Public Delegate | AsyncCallback | References the callback method to be invoked when an asynchronous operation is completed.

Expand image Enumerations

 | Name | Description
Public Enumeration | AttributeTargets | Contains the application elements on which it is valid to apply an attribute.
Public Enumeration | DayOfWeek | Contains values you can use to specify the day of the week.
Public Enumeration | TypeCode | Contains values that specify the type of an object.

Expand image Remarks

Note that unlike the .NET Framework for desktop computers, the Visual Studio application wizard for the .NET Micro Framework does not automatically add a reference to the file System.dll, which contains the System namespace. This is by design. You must manually add a reference to System.dll to your Visual Studio project to be able to access items in the System namespace.


SystemException Class

SystemException Class
See Also Members
CollapseAll image

Constitutes the base class for predefined exceptions in the System namespace.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class SystemException : Exception

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemException Members
System Namespace


SystemException Members

SystemException Members
See Also Constructors
CollapseAll image

The following tables list the members exposed by the SystemException type.

Expand image Public Constructors

 | Name | Description
Public Method | SystemException | Overloaded. Initializes a new instance of the SystemException class.

Expand image See Also

Reference

SystemException Class
System Namespace


SystemMetrics Class

SystemMetrics Class
See Also Members
CollapseAll image

Contains a display device screen's dimensions and the number of available colors.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public sealed class SystemMetrics

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemMetrics Members
Microsoft.SPOT.Presentation Namespace


SystemMetrics Members

SystemMetrics Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the SystemMetrics type.

Expand image Public Constructors

 | Name | Description
Public Method | SystemMetrics | Initializes a new instance of the SystemMetrics class.

Expand image Public Properties

Name | Description
ScreenColorDepth | Gets the number of colors that are available on the screen.
ScreenHeight | Gets the height of the screen.
ScreenWidth | Gets the width of the screen.

Expand image See Also

Reference

SystemMetrics Class
Microsoft.SPOT.Presentation Namespace


SystemTime Class

SystemTime Class
See Also Members
CollapseAll image

Sets or gets the current system time for the device.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class SystemTime

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Members
Microsoft.SPOT Namespace


SystemTime Members

SystemTime Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the SystemTime type.

Expand image Public Constructors

 | Name | Description
Public Method | SystemTime | Constructs a SystemTime object.

Expand image Public Fields

 | Name | Description
Public Field | Day | Specifies the day associated with a particular SystemTime object.
Public Field | DayOfWeek | Specifies the day of the week associated with a particular SystemTime object.
Public Field | Hour | Specifies the hour associated with a particular SystemTime object.
Public Field | Milliseconds | Specifies the milliseconds associated with a particular SystemTime object.
Public Field | Minute | Specifies the minute associated with a particular SystemTime object.
Public Field | Month | Specifies the month associated with a particular SystemTime object.
Public Field | Second | Specifies the second associated with a particular SystemTime object.
Public Field | Year | Specifies the year associated with a particular SystemTime object.

Expand image See Also

Reference

SystemTime Class
Microsoft.SPOT Namespace


DispatcherTimer.Tag Property

DispatcherTimer.Tag Property

Gets or sets a user-defined data object that is passed to the Tick event handler.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Object Tag { get; set; }

Property Value

The user-defined data object that is passed to the Tick event handler. The default value is a null reference.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


ButtonDevice.Target Property

ButtonDevice.Target Property

Gets the display element that receives input from a particular button device.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override UIElement Target { get; }

Property Value

A UIElement object that specifies the input value's basic presentation characteristics, such as focusing and rendering behaviors.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ButtonDevice Class
ButtonDevice Members
Microsoft.SPOT.Input Namespace


DebuggerDisplayAttribute.Target Property

DebuggerDisplayAttribute.Target Property

Gets or sets the target assembly.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Type Target { get; set; }

Property Value

The name of the target assembly.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


DebuggerTypeProxyAttribute.Target Property

DebuggerTypeProxyAttribute.Target Property

Gets or sets the target type for the current attribute.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Type Target { get; set; }

Property Value

A Type object that represents the target type for the current attribute.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


Delegate.Target Property

Delegate.Target Property

Gets the object for which the current delegate invokes the instance method.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public Object Target { get; }

Property Value

The object for which the current delegate invokes the instance method, if the delegate represents an instance method.

-or-

A null reference if the delegate represents a static method.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Delegate Class
Delegate Members
System Namespace


InputDevice.Target Property

InputDevice.Target Property

When overridden in a derived class, this property gets the display element that receives input from the current input device.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public virtual abstract UIElement Target { get; }

Property Value

A UIElement object representing the display element that receives input from the current input device.

Expand image Remarks

A UIElement object controls basic display characteristics, such as layout, focusing, and rendering behavior.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputDevice Class
InputDevice Members
Microsoft.SPOT.Input Namespace


WeakReference.Target Property

WeakReference.Target Property

Gets or sets the object (the target) referenced by the current WeakReference object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object Target { get; set; }

Property Value

A null reference if the object referenced by the current object has been collected as garbage; otherwise, a reference to the object referenced by the current object.

Expand image Remarks

An exception is thrown if the reference to the object referenced by the current object is invalid. This can occur if there is an attempt to resurrect the referenced object after it has been finalized.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakReference Class
WeakReference Members
System Namespace


DebuggerDisplayAttribute.TargetTypeName Property

DebuggerDisplayAttribute.TargetTypeName Property

Gets or sets the name of the target type.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string TargetTypeName { get; set; }

Property Value

A string that contains the name of the target type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


DebuggerTypeProxyAttribute.TargetTypeName Property

DebuggerTypeProxyAttribute.TargetTypeName Property

Gets or sets the name of the target type.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string TargetTypeName { get; set; }

Property Value

A string that represents the name of the target type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerTypeProxyAttribute Class
DebuggerTypeProxyAttribute Members
System.Diagnostics Namespace


Text._text Field

Text._text Field

Contains the text string for the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected string _text

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


Text Class

Text Class
See Also Members
CollapseAll image

Displays a block of text.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Text : UIElement

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Members
Microsoft.SPOT.Presentation.Controls Namespace


Text Members

Text Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the Text type.

Expand image Public Constructors

 | Name | Description
Public Method | Text | Overloaded. Initializes a new instance of the Text class.

Expand image Protected Fields

 | Name | Description
Protected Field | _font | Specifies the font to be used for the text in the current Text object.
Protected Field | _text | Contains the text string for the current Text object.

Expand image Public Properties

 | Name | Description
Public Property | Font | Gets or sets the font for the text in the current Text object .
Public Property | ForeColor | Gets or sets the foreground color for the text in the current Text object.
Public Property | LineHeight | Gets the height of a line of text in the current Text object.
Public Property | TextAlignment | Gets or sets the text alignment for the current Text object.
Public Property | TextContent | Gets or sets the contents of the current Text object.
Public Property | TextWrap | Gets or sets the text-wrapping setting for the current Text object.
Public Property | Trimming | Gets or sets the type of white-space trimming for the text in the current Text object.

Expand image Public Methods

 | Name | Description
Public Method | OnRender | Writes the contents of the current Text object to the display device (screen).
Public Method | ToString | Creates a string representation of the current Text object.

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Measures the text layout area for the current Text object.

Expand image See Also

Reference

Text Class
Microsoft.SPOT.Presentation.Controls Namespace


TextRun.Text Field

TextRun.Text Field

Specifies the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public string Text

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


TextAlignment Enumeration

TextAlignment Enumeration

Specifies the horizontal alignment of text with its layout area on a hardware display device.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum TextAlignment

Expand image Members

Member name | Description
Center | A value specifying that the center of the text is aligned with the center of the layout area.
Justify | A value specifying that the text is aligned evenly along both the left and right margins of the layout area so that there is a smooth edge on both sides.
Left | A value specifying that the left edge of the text is flush with the left margin of the layout area.
Right | A value specifying that the right edge of the text is flush with the right margin of the layout area.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Media Namespace


Text.TextAlignment Property

Text.TextAlignment Property

Gets or sets the text alignment for the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextAlignment TextAlignment { get; set; }

Property Value

The current text alignment.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.TextAlignment Property

TextFlow.TextAlignment Property

Gets or sets the text alignment.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextAlignment TextAlignment { get; set; }

Property Value

The text alignment.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


Text.TextContent Property

Text.TextContent Property

Gets or sets the contents of the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public string TextContent { get; set; }

Property Value

The text string contained in the current Text object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow Class

TextFlow Class
See Also Members
CollapseAll image

Provides members that control how text flows on the display device (screen).

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class TextFlow : UIElement

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow Members

TextFlow Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the TextFlow type.

Expand image Public Constructors

 | Name | Description
Public Method | TextFlow | Initializes a new instance of the TextFlow class.

Expand image Public Fields

 | Name | Description
Public Field | TextRuns | Specifies a group of TextRun objects that contain the text whose flow is controlled by the current TextFlow object.

Expand image Public Properties

 | Name | Description
Public Property | LineCount | Gets the number of lines into which text is to flow.
Public Property | ScrollingStyle | Gets or sets a value that specifies how text is scrolled.
Public Property | TextAlignment | Gets or sets the text alignment.
Public Property | TopLine | Gets or sets the line number of the first line of the text whose flow is controlled by the current TextFlow object.

Expand image Public Methods

 | Name | Description
Public Method | OnRender | Writes text to the display device (screen).

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Measures the rectangular area in which text is to flow.
Protected Method | OnButtonDown | Displays an event description whenever the user presses a button.

Expand image See Also

Reference

TextFlow Class
Microsoft.SPOT.Presentation.Controls Namespace


TextRun Class

TextRun Class
See Also Members
CollapseAll image

Provides members you can use to create and work with a text run, which is a string of characters that share a single property set.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class TextRun

Expand image Remarks

The text in a text run contains a property set. The property set includes the font style, foreground color, and any other formatting effects that have been specified.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRun Members

TextRun Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the TextRun type.

Expand image Public Constructors

 | Name | Description
Public Method | TextRun | Initializes a new instance of the TextRun class (a text run).

Expand image Public Fields

 | Name | Description
Public Field | Font | Specifies the font for the text in the current text run.
Public Field | ForeColor | Specifies the foreground color for the text in the current text run.
Public Field | Text | Specifies the text in the current text run.

Expand image Protected Fields

 | Name | Description
Protected Field | _height | Specifies the height, in pixels, of the text in the current text run.
Protected Field | _width | Specifies the width, in pixels, of the text in the current text run.

Expand image Public Properties

Name | Description
EndOfLine | Gets a text run that is marked as an end-of-line.

Expand image Public Methods

 | Name | Description
Public Method | GetSize | Retrieves the dimensions (height and width) of the display area for the text in the current text run.

Expand image See Also

Reference

TextRun Class
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection Class

TextRunCollection Class
See Also Members
CollapseAll image

Provides methods and properties that enable you to work with groups, or collections, of TextRun objects.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public class TextRunCollection : ICollection, IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRunCollection Members
Microsoft.SPOT.Presentation.Controls Namespace


TextRunCollection Members

TextRunCollection Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the TextRunCollection type.

Expand image Public Properties

 | Name | Description
Public Property | Count | Gets the number of objects in the current text run collection.
Public Property | IsSynchronized | Gets a value that indicates whether access to the current text run collection is presently synchronized.
Public Property | Item | Gets or sets a specified object in the current text run collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the current text run collection.

Expand image Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a TextRun object (string) to the current text run collection.
Public Method | Clear | Empties the current text run collection.
Public Method | Contains | Determines whether the current text run collection contains a specified text run.
Public Method | CopyTo | Copies a specified portion of the current text run collection into a specified array.
Public Method | GetEnumerator | Retrieves an enumerator that programs can use to iterate through the current text run collection.
Public Method | IndexOf | Returns the index number of the specified TextRun object, if that object is found in the current text run collection.
Public Method | Insert | Inserts a specified TextRun object at a specified position (index number) in the current text run collection.
Public Method | Remove | Removes the first occurrence of a specified TextRun object from the current text run collection.
Public Method | RemoveAt | Removes the TextRun object at a specified position (index number) in the current text run collection.

Expand image See Also

Reference

TextRunCollection Class
Microsoft.SPOT.Presentation.Controls Namespace


TextFlow.TextRuns Field

TextFlow.TextRuns Field

Specifies a group of TextRun objects that contain the text whose flow is controlled by the current TextFlow object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextRunCollection TextRuns

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


TextTrimming Enumeration

TextTrimming Enumeration

Specifies how characters from a string that does not completely fit into the specified layout area are to be trimmed.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum TextTrimming

Expand image Members

Member name | Description
CharacterEllipsis | A value specifying that the text is to be trimmed to the nearest character, and an ellipsis is to be inserted at the end of the trimmed text.
None | A value specifying that the text is not to be trimmed.
WordEllipsis | A value specifying that the text is to be trimmed to the nearest word, and an ellipsis is to be inserted at the end of the trimmed text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation.Media Namespace


Text.TextWrap Property

Text.TextWrap Property

Gets or sets the text-wrapping setting for the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool TextWrap { get; set; }

Property Value

true if the text automatically wraps from one line to the next; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


Pen.Thickness Field

Pen.Thickness Field

Specifies the thickness of the current pen.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public UInt16 Thickness

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Pen Class
Pen Members
Microsoft.SPOT.Presentation.Media Namespace


Dispatcher.Thread Property

Dispatcher.Thread Property

Gets the thread with which the current Dispatcher object (dispatcher) is associated.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Thread Thread { get; }

Property Value

The thread that is associated with the current dispatcher.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


Thread Class

Thread Class
See Also Members
CollapseAll image

Creates and controls a thread, sets its priority, and gets its status.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public sealed class Thread

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Members
System.Threading Namespace


Thread Members

Thread Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Thread type.

Expand image Public Constructors

 | Name | Description
Public Method | Thread | Initializes a new instance of the Thread class.

Expand image Public Properties

 | Name | Description
 | CurrentThread | Gets the thread that is currently running.
Public Property | IsAlive | Gets a value that indicates the execution status of the current thread.
Public Property | Priority | Gets or sets a value that indicates the scheduling priority of the current thread.
Public Property | ThreadState | Gets a value that contains the present state of the current thread.

Expand image Public Methods

 | Name | Description
Public Method | Abort | Raises a ThreadAbortException exception in the thread on which it is invoked. This begins the process of terminating the thread.
 | GetDomain | Returns the name of the domain in which the current thread is running.
Public Method | Join | Overloaded. Blocks the calling thread until the current thread terminates.
Public Method | Resume | Resumes a thread that has been suspended.
 | Sleep | Suspends the current thread for a specified amount of time.
Public Method | Start | Starts execution of a thread.
Public Method | Suspend | Suspends the current thread or, if it is already suspended, has no effect.

Expand image See Also

Reference

Thread Class
System.Threading Namespace


ThreadAbortException Class

ThreadAbortException Class
See Also Members
CollapseAll image

The exception that is thrown when a call is made to the Thread.Abort method.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public sealed class ThreadAbortException : SystemException

Expand image Remarks

This class cannot be inherited.

When a call is made to the Abort method to destroy a thread, the common language runtime (CLR) throws a ThreadAbortException exception. This is a special type of exception that can be caught but will be raised again automatically at the end of the catch block. When this exception is raised, the CLR executes all of the finally blocks before killing the thread. Because the thread can do an unbounded computation in the finally blocks, you must call the Join method to guarantee that the thread has died. Note that the Join method is a blocking call that does not return until the thread actually stops executing.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Threading Namespace


System.Threading Namespace

System.Threading Namespace

The System.Threading namespace in the Microsoft® .NET Micro Framework provides classes, delegates, and enumerations you can use to handle threading in your .NET Micro Framework applications.

Expand image Classes

 | Name | Description
Public Class | AutoResetEvent | Notifies a waiting thread that an event has occurred.
Public Class | Interlocked | Provides atomic operations for variables that are shared by multiple threads.
Public Class | Monitor | Provides a mechanism that synchronizes access to objects.
Public Class | Thread | Creates and controls a thread, sets its priority, and gets its status.
Public Class | ThreadAbortException | The exception that is thrown when a call is made to the Thread.Abort method.
Public Class | Timeout | Provides a constant you can use to specify an infinite amount of time.
Public Class | Timer | Provides a mechanism for executing a method at specified intervals.
Public Class | WaitHandle | Encapsulates operating system-specific objects that wait for exclusive access to shared resources.

Expand image Delegates

 | Name | Description
Public Delegate | ThreadStart | Represents the method that executes on Thread objects.
Public Delegate | TimerCallback | Represents the method that handles calls from Timer objects.

Expand image Enumerations

 | Name | Description
Public Enumeration | ThreadPriority | Specifies the scheduling priority of the current Thread object (thread).
Public Enumeration | ThreadState | Specifies the execution states of the current Thread object (thread).


ThreadPriority Enumeration

ThreadPriority Enumeration

Specifies the scheduling priority of the current Thread object (thread).

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum ThreadPriority

Expand image Members

Member name | Description
Highest | A value specifying that the current thread can be scheduled before threads with any other priority.
AboveNormal | A value specifying that the current thread can be scheduled after threads with Highest priority and before those with Normal priority.
Normal | A value specifying that the current thread can be scheduled after threads with AboveNormal priority and before those with BelowNormal priority. Note that threads have Normal priority by default.
BelowNormal | A value specifying that the current thread can be scheduled after threads with Normal priority and before those with Lowest priority.
Lowest | A value specifying that the current thread can be scheduled after threads with any other priority.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Threading Namespace


ThreadStart Delegate

ThreadStart Delegate

Represents the method that executes on Thread objects.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public delegate void ThreadStart ()

Expand image Remarks

When you create a thread, the new Thread object is generated by a constructor that takes the ThreadStart delegate as its only parameter. However, the thread does not begin executing until the Start method is invoked. When Start is called, execution begins at the first line of the method referenced by the ThreadStart delegate.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Threading Namespace


Thread.ThreadState Property

Thread.ThreadState Property

Gets a value that contains the present state of the current thread.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public ThreadState ThreadState { get; }

Property Value

One of the ThreadState values that indicate the present state of the current thread. Note that the default value for thread state is Unstarted.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Thread Class
Thread Members
System.Threading Namespace


ThreadState Enumeration

ThreadState Enumeration

Specifies the execution states of the current Thread object (thread).

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[FlagsAttribute]
[SerializableAttribute]
public enum ThreadState

Expand image Members

Member name | Description
Aborted | A value specifying that the current thread is in the Stopped state.
AbortRequested | A value specifying that the Thread.Abort method has been invoked on the current thread, but the thread has not yet received the pending System.Threading.ThreadAbortException exception that will attempt to terminate it.
Background | A value specifying that the current thread is being executed as a background thread, as opposed to a foreground thread.
Running | A value specifying that the current thread has been started, it is not blocked, and there is no pending ThreadAbortException exception.
Stopped | A value specifying that the current thread has stopped.
StopRequested | A value specifying that the current thread is being requested to stop. Note that this member is for internal use only.
Suspended | A value specifying that the current thread has been suspended.
SuspendRequested | A value specifying that the current thread is being requested to suspend itself.
Unstarted | A value specifying that the Thread.Start method has not been invoked on the current thread.
WaitSleepJoin | A value specifying that the current thread is blocked as a result of a call to the Wait method, the Sleep method, or the Join method.

Expand image Remarks

This enumeration has a FlagsAttribute attribute that enables you to combine its member values in a bitwise combination.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Threading Namespace


DispatcherTimer.Tick Event

DispatcherTimer.Tick Event

Occurs when the specified time interval for the current DispatcherTimer object (timer) has elapsed and the timer is enabled.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public event EventHandler Tick

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherTimer Class
DispatcherTimer Members
Microsoft.SPOT Namespace


DateTime.Ticks Property

DateTime.Ticks Property

Gets the current number of ticks in the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public long Ticks { get; }

Property Value

The current number of ticks, expressed as a number ranging from the value in the MinValue field through the value in the MaxValue field.

Expand image Remarks

One tick equals 100 nanoseconds. The value of this property represents the number of ticks that have elapsed since 12:00:00 midnight, January 1, 0001.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeSpan.Ticks Property

TimeSpan.Ticks Property

Gets the number of ticks in the current TimeSpan object (time period).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public long Ticks { get; }

Property Value

The number of ticks in the current TimeSpan object, expressed as a number between the value in the MinValue field and the value in the MaxValue field.

Expand image Remarks

One tick equals 100 nanoseconds. The value of the Ticks property is the total number of ticks in the current TimeSpan object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.TicksPerDay Field

TimeSpan.TicksPerDay Field

Specifies the number of ticks in one entire day. Note that the value of this field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public const long TicksPerDay

Expand image Remarks

The value of this field is 864,000,000,000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.TicksPerHour Field

TimeSpan.TicksPerHour Field

Specifies the number of ticks in one hour. Note that the value of this field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public const long TicksPerHour

Expand image Remarks

The value of this field is 36,000,000,000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.TicksPerMillisecond Field

TimeSpan.TicksPerMillisecond Field

Specifies the number of ticks in one millisecond. Note that the value of this field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public const long TicksPerMillisecond

Expand image Remarks

The value of this field is 10,000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.TicksPerMinute Field

TimeSpan.TicksPerMinute Field

Specifies the number of ticks in one minute. Note that the value of this field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public const long TicksPerMinute

Expand image Remarks

The value of this field is 600,000,000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


TimeSpan.TicksPerSecond Field

TimeSpan.TicksPerSecond Field

Specifies the number of ticks in one second. Note that the value of this field is constant.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public const long TicksPerSecond

Expand image Remarks

The value of this field is 10,000,000.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


ExtendedTimeZone.c_TicksTo20030101 Field

ExtendedTimeZone.c_TicksTo20030101 Field

Specifies the number of clock ticks equal to the DateTime value of 2003/01/01 00:00:00.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public static long c_TicksTo20030101

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


ExtendedTimer.TimeEvents Enumeration

ExtendedTimer.TimeEvents Enumeration

Defines the various timer events that are available in the .NET Micro Framework.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public enum ExtendedTimer.TimeEvents

Expand image Members

Member name | Description
Day | An event that occurs on a change in days.
Hour | An event that occurs on a change in hours.
Minute | An event that occurs on a change in minutes.
Second | An event that occurs on a change in seconds.
SetTime | An event that occurs at a specified time.
TimeZone | An event that occurs on a change in time zones.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


DateTime.TimeOfDay Property

DateTime.TimeOfDay Property

Gets the time-of-day component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public TimeSpan TimeOfDay { get; }

Property Value

A TimeSpan object that represents the portion of the current day that has elapsed since midnight.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Timeout Class

Timeout Class
See Also Members
CollapseAll image

Provides a constant you can use to specify an infinite amount of time.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static class Timeout

Expand image Remarks

This class cannot be inherited.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timeout Members
System.Threading Namespace


Timeout Members

Timeout Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the Timeout type.

Expand image Public Fields

Name | Description
Infinite | Represents a constant you can use to specify an infinite waiting period.

Expand image See Also

Reference

Timeout Class
System.Threading Namespace


Timer Class

Timer Class
See Also Members
CollapseAll image

Provides a mechanism for executing a method at specified intervals.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public sealed class Timer : MarshalByRefObject, IDisposable

Expand image Remarks

This class cannot be inherited.

Use a TimerCallback delegate to specify the method you want a particular Timer object to execute. The timer delegate is specified when the timer is constructed, and it cannot be changed. Note that the specified method does not execute in the thread that created the timer; it executes in a thread pool thread provided by the system.

Note
As long as you are using a Timer, you must keep a reference to it. As with any managed object, a Timer is subject to garbage collection when there are no references to it. The fact that a Timer is still active does not prevent it from being collected.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Timer Members
System.Threading Namespace


Timer Members

Timer Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the Timer type.

Expand image Public Constructors

 | Name | Description
Public Method | Timer | Overloaded. Initializes a new instance of the Timer class.

Expand image Public Methods

 | Name | Description
Public Method | Change | Overloaded. Changes the start time and the interval between method invocations for a Timer object (timer).
Public Method | Dispose | Releases all resources used by the current Timer object (timer).

Expand image See Also

Reference

Timer Class
System.Threading Namespace


TimerCallback Delegate

TimerCallback Delegate

Represents the method that handles calls from Timer objects.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public delegate void TimerCallback (
         Object state
)

Parameters

state
An object that contains application-specific information relevant to the method invoked by this delegate, or a null reference.

Expand image Remarks

The declaration of your callback method must have the same parameters as the TimerCallback delegate declaration.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System.Threading Namespace


DateTimeFormatInfo.TimeSeparator Property

DateTimeFormatInfo.TimeSeparator Property

Gets the string that separates the components of time, as expressed on the system clock (hour, minutes, and seconds).

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string TimeSeparator { get; }

Property Value

The string that separates the components of time, as expressed on the system clock (hour, minutes, and seconds).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


TimeSpan Structure

TimeSpan Structure

Specifies a discrete period of time, or a time span.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct TimeSpan

Expand image Remarks

A TimeSpan object represents a specific period of time, expressed as a positive or negative number of days, hours, minutes, seconds, and fractions of a second. The largest unit of measure that .NET Micro Framework uses to represent time periods is a day. For the sake of consistency, time spans are measured in days because the number of days in larger units of time, such as months and years, varies.

The value of a TimeSpan object is the number of ticks that equal the specified time period. A tick is equal to 100 nanoseconds, and the value of a TimeSpan object can range from the value in the MinValue field to the value in the MaxValue field.

A TimeSpan value can be represented as [-]d.hh:mm:ss.ff, where the optional minus sign (–) indicates a negative time period, the d component is days, hh is hours as measured on a 24-hour clock, mm is minutes, ss is seconds, and ff is fractions of a second. That is, a time period consists of a positive or negative number of whole days, a positive or negative number of whole and partial days, or a positive or negative partial day. For example, the text representation of a TimeSpan object initialized to 1.0e+13 ticks is "11.13:46:40", which equates to 11 days, 13 hours, 46 minutes, and 40 seconds.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Members
System Namespace


TimeSpan Members

TimeSpan Members
See Also Constructors Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the TimeSpan type.

Expand image Public Constructors

 | Name | Description
Public Method | TimeSpan | Overloaded. Initializes a new instance of the TimeSpan structure.

Expand image Public Fields

 | Name | Description
Public Field | MaxValue | Represents the largest possible value for a TimeSpan object. Note that this field is read-only.
Public Field | MinValue | Represents the smallest possible value for a TimeSpan object. Note that this field is read-only.
Public Field | TicksPerDay | Specifies the number of ticks in one entire day. Note that the value of this field is constant.
Public Field | TicksPerHour | Specifies the number of ticks in one hour. Note that the value of this field is constant.
Public Field | TicksPerMillisecond | Specifies the number of ticks in one millisecond. Note that the value of this field is constant.
Public Field | TicksPerMinute | Specifies the number of ticks in one minute. Note that the value of this field is constant.
Public Field | TicksPerSecond | Specifies the number of ticks in one second. Note that the value of this field is constant.
Public Field | Zero | A TimeSpan having a value of 0 (zero). Note that this field is read-only.

Expand image Public Properties

 | Name | Description
Public Property | Days | Gets the number of whole days in the current TimeSpan object (time period).
Public Property | Hours | Gets the number of whole hours in the current TimeSpan object (time period).
Public Property | Milliseconds | Gets the number of whole milliseconds in the current TimeSpan object (time period).
Public Property | Minutes | Gets the number of whole minutes in the current TimeSpan object (time period).
Public Property | Seconds | Gets the number of whole seconds in the current TimeSpan object (time period).
Public Property | Ticks | Gets the number of ticks in the current TimeSpan object (time period).

Expand image Public Methods

 | Name | Description
Public Method | Add | Adds a specified TimeSpan object (time period) to the current TimeSpan object, yielding a new TimeSpan object.
 | Compare | Compares two specified TimeSpan objects (time periods) with one another to determine their relative value.
Public Method | CompareTo | Compares a specified TimeSpan object (time period) or other time-period object with the current TimeSpan object to determine their relative value.
Public Method | Duration | Returns a new TimeSpan object (time period) that has the absolute value of the current TimeSpan object.
Public Method | Equals | Overloaded. Determines whether two objects that specify time periods are equal.
 | FromTicks | Returns a TimeSpan object (time period) that is equivalent to a specified number of ticks.
Public Method | Negate | Returns a new TimeSpan object that has the negated (opposite) value of the current TimeSpan object.
 | operator - | Subtracts a specified TimeSpan object (time period) from another specified TimeSpan object, yielding a new TimeSpan object.
 | operator != | Determines whether two specified TimeSpan objects (time periods) are not equal.
 | operator + | Adds two specified TimeSpan objects (time periods), yielding a new TimeSpan object.
 | operator + | Unary plus operator.
 | operator < | Determines whether a specified TimeSpan object (time period) is less than another specified TimeSpan object.
 | operator <= | Determines whether a specified TimeSpan object (time period) is less than or equal to another specified TimeSpan object.
 | operator == | Determines whether two specified TimeSpan objects (time periods) are equal.
 | operator > | Determines whether a specified TimeSpan object (time period) is greater than another specified TimeSpan object.
 | operator >= | Determines whether a specified TimeSpan object (time period) is greater than or equal to another specified TimeSpan object.
Public Method | Subtract | Subtracts a specified TimeSpan object (time period) from the current TimeSpan object, yielding a new TimeSpan object.
Public Method | ToString | Converts the value of the current TimeSpan object (time period) to its equivalent string representation.

Expand image See Also

Reference

TimeSpan Structure
System Namespace


InputEventArgs.Timestamp Field

InputEventArgs.Timestamp Field

Specifies the time period during which the input was received.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TimeSpan Timestamp

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputEventArgs Class
InputEventArgs Members
Microsoft.SPOT.Input Namespace


InputReport.Timestamp Field

InputReport.Timestamp Field

Specifies the time period during which the input represented by the current InputReport object was received.

Namespace: Microsoft.SPOT.Input
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TimeSpan Timestamp

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

InputReport Class
InputReport Members
Microsoft.SPOT.Input Namespace


TimeZone Class

TimeZone Class
See Also Members
CollapseAll image

Represents a specific time zone.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class TimeZone

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Members
System Namespace


TimeZone Members

TimeZone Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the TimeZone type.

Expand image Protected Constructors

 | Name | Description
Protected Method | TimeZone | Initializes a new instance of the TimeZone class.

Expand image Public Properties

 | Name | Description
 | CurrentTimeZone | Gets the time zone of the computer you are using.
Public Property | DaylightName | Gets the daylight saving time zone name.
Public Property | StandardName | Gets the standard time zone name.

Expand image Public Methods

 | Name | Description
Public Method | GetDaylightChanges | Returns the daylight saving time period for a specified year.
Public Method | GetUtcOffset | Returns the Coordinated Universal Time (UTC) offset for the specified local time.
Public Method | IsDaylightSavingTime | Returns a value that indicates whether a specified date and time is in a daylight saving time period.
Public Method | ToLocalTime | Returns the local time that corresponds to a specified Coordinated Universal Time (UTC) time.
Public Method | ToUniversalTime | Returns the Coordinated Universal Time (UTC) time that corresponds to a specified local time.

Expand image See Also

Reference

TimeZone Class
System Namespace


ExtendedTimeZone.TimeZoneId Property

ExtendedTimeZone.TimeZoneId Property

Gets the ID of a particular time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public TimeZoneId TimeZoneId { get; }

Property Value

The ID of a particular time zone.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ExtendedTimeZone Class
ExtendedTimeZone Members
Microsoft.SPOT Namespace


TimeZoneId Enumeration

TimeZoneId Enumeration

Provides the set of time zones that are available for .NET Micro Framework applications.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum TimeZoneId

Expand image Members

Member name | Description
AbuDhabi | Abu Dhabi
Adelaide | Adelaide
Alaska | Alaska
Almaty | Almaty
Arizona | Arizona
Astana | Astana
Athens | Athens
Atlantic | Atlantic
Azores | Azores
Baghdad | Baghdad
Baku | Baku
Bangkok | Bangkok
Beijing | Beijing
Berlin | Berlin
Bogota | Bogota
Brasilia | Brasilia
Brisbane | Brisbane
Bucharest | Bucharest
BuenosAires | Buenos Aires
Cairo | Cairo
CapeVerde | Cape Verde
Caracas | Caracas
Casablanca | Casablanca
CentAmerica | Central America
Central | Central
COUNT | The total number of time zone IDs
Current | The current time zone ID
Darwin | Darwin
Dateline | A string resource
Eastern | Eastern
FijiIslands | Fiji Islands
FIRST | The first time zone ID
FIRST_RESOURCE | The first resource string
GMT | GMT, or Greenwich Mean Time (also known as UTC, or Coordinated Universal Time)
Greenland | Greenland
Guam | Guam
Hawaii | Hawaii
Helsinki | Helsinki
Hobart | Hobart
Indiana | Indiana
Islamabad | Islamabad
Jerusalem | Jerusalem
Kabul | Kabul
Kathmandu | Kathmandu
Krasnoyarsk | Krasnoyarsk
LAST | The last time zone ID
London | London
Magadan | Magadan
Malaysia | Malaysia
MexicoCity | Mexico City
MidAtlantic | Mid-Atlantic
Moscow | Moscow
Mountain | Mountain
Nairobi | Nairobi
Network | The network-provided time zone
NewDelhi | New Delhi
Newfoundland | Newfoundland
NewZealand | New Zealand
Pacific | Pacific
Paris | Paris
Perth | Perth
Prague | Prague
Pretoria | Pretoria
Riyadh | Riyadh
Samoa | Samoa
Santiago | Santiago
Saskatchewan | Saskatchewan
Seoul | Seoul
SriLanka | Sri Lanka
Sydney | Sydney
Taipei | Taipei
Tehran | Tehran
Tokyo | Tokyo
Tonga | Tonga
Ulaanbataar | Ulaanbataar
Vladivostok | Vladivostok
Warsaw | Warsaw
WCentAfrica | West Central Africa
Yakutsk | Yakutsk
Yangon | Yangon
Yekaterinburg | Yekaterinburg

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT Namespace


TimeZoneInformation Class

TimeZoneInformation Class
See Also Members
CollapseAll image

Contains information describing a specific time zone.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class TimeZoneInformation

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZoneInformation Members
Microsoft.SPOT Namespace


TimeZoneInformation Members

TimeZoneInformation Members
See Also Constructors Fields
CollapseAll image

The following tables list the members exposed by the TimeZoneInformation type.

Expand image Public Constructors

 | Name | Description
Public Method | TimeZoneInformation | Constructs a TimeZoneInformation object.

Expand image Public Fields

 | Name | Description
Public Field | Bias | Specifies the current bias for local time translation on this operating system, in minutes.
Public Field | DaylightBias | Specifies the bias value to be used for local time translations that occur during daylight saving time in a particular time zone.
Public Field | DaylightDate | Specifies a date and a local time when the transition from standard time to daylight saving time will occur on this operating system.
Public Field | DaylightName | Contains a description of daylight saving time.
Public Field | StandardBias | Specifies the bias value to be used for local time translations that occur during standard time in a particular time zone.
Public Field | StandardDate | Contains a date and a local time when the transition from daylight saving time to standard time will occur on this operating system.
Public Field | StandardName | Contains a description of standard time.

Expand image See Also

Reference

TimeZoneInformation Class
Microsoft.SPOT Namespace


AssemblyTitleAttribute.Title Property

AssemblyTitleAttribute.Title Property

Gets assembly title information.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Title { get; }

Property Value

A string that contains the title of the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTitleAttribute Class
AssemblyTitleAttribute Members
System.Reflection Namespace


ArrayList.ToArray Method (Type)

ArrayList.ToArray Method (Type)
See Also
CollapseAll image

Copies objects from the ArrayList collection to a new array of the specified type.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Array ToArray (
         Type type
)

Parameters

type
The type of array you want to create and copy objects to.

Return Value

An array of the specified type containing objects copied from the ArrayListcollection.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ArrayList.ToArray Method ()

ArrayList.ToArray Method ()
See Also
CollapseAll image

Copies objects from the ArrayList collection to a new Object array.

Namespace: System.Collections
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual Object [] ToArray ()

Return Value

An Object array containing objects copied from the ArrayList collection.

Expand image Remarks

You copy the objects by using the Array.Copy method, which is an O(n) operation, where n is the value of the Count property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


ArrayList.ToArray Method

ArrayList.ToArray Method

Copies objects from the ArrayList collection to a new array.

Expand image Overload List

Name | Description
ArrayList.ToArray () | Copies objects from the ArrayList collection to a new Object array.
ArrayList.ToArray (Type) | Copies objects from the ArrayList collection to a new array of the specified type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ArrayList Class
ArrayList Members
System.Collections Namespace


String.ToCharArray Method (Int32, Int32)

String.ToCharArray Method (Int32, Int32)
See Also
CollapseAll image

Copies the characters in a specified substring of the current String object to an array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public char [] ToCharArray (
         int startIndex,
         int length
)

Parameters

startIndex
The starting index number in the current String object.
length
The length of the substring in the current String object.

Return Value

A Unicode character array that is defined by the length and startIndex parameters.

Expand image Remarks

If the length parameter is 0 (zero), the entire string is copied, starting from the beginning of the current String object and ignoring the value of the startIndex parameter. If the current object is an empty string, the returned array is empty and has a length of 0.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.ToCharArray Method ()

String.ToCharArray Method ()
See Also
CollapseAll image

Copies the characters in the current String object to an array of Unicode characters.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public char [] ToCharArray ()

Return Value

A Unicode character array whose contents are the individual characters in the current String object. If the current object is an empty string, the returned array is empty and has a length of 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.ToCharArray Method

String.ToCharArray Method

Copies the characters in the current String object to an array of Unicode characters.

Expand image Overload List

Name | Description
String.ToCharArray () | Copies the characters in the current String object to an array of Unicode characters.
String.ToCharArray (Int32, Int32) | Copies the characters in a specified substring of the current String object to an array of Unicode characters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


DateTime.Today Property

DateTime.Today Property

Gets the current date.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTime Today { get; }

Property Value

A DateTime object with the date component set to today's date and the time component set to 00:00:00.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.ToLocalTime Method

DateTime.ToLocalTime Method

Converts the current value of the current DateTime object to local time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime ToLocalTime ()

Return Value

A new DateTime object with the local-time equivalent of the current value of the current DateTime object.

Expand image Remarks

The value of the new DateTime object is MaxValue field if the converted value is too large to be represented by a DateTime object, or it is a MinValue field if the converted value is too small to be represented by a DateTime object.

The local time is equal to the Coordinated Universal Time (UTC) time plus the UTC offset. For more information about the UTC offset, see the GetUtcOffset method. The conversion also takes into account the daylight saving time rule that applies to the current value of the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeZone.ToLocalTime Method

TimeZone.ToLocalTime Method

Returns the local time that corresponds to a specified Coordinated Universal Time (UTC) time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual DateTime ToLocalTime (
         DateTime time
)

Parameters

time
The specified UTC time.

Return Value

A DateTime object whose value is the local time that corresponds to the time parameter.

Expand image Remarks

Coordinated Universal Time (UTC) was previously known as Greenwich Mean Time (GMT). Local time is the date and time on the computer you are using. Offset is the difference between local time and UTC (local time = UTC + offset).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


String.ToLower Method

String.ToLower Method

Returns the current String object in lowercase.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string ToLower ()

Return Value

The current String object in lowercase.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Window.Top Property

Window.Top Property

Gets or sets the position of the current window's top edge in relation to the desktop.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Top { get; set; }

Property Value

The position of the current window's top edge, in logical units (1/96 of an inch).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


TextFlow.TopLine Property

TextFlow.TopLine Property

Gets or sets the line number of the first line of the text whose flow is controlled by the current TextFlow object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int TopLine { get; set; }

Property Value

The line number of the first line of text to flow.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextFlow Class
TextFlow Members
Microsoft.SPOT.Presentation.Controls Namespace


Window.Topmost Property

Window.Topmost Property

Gets or sets a value that indicates whether the current window is always the topmost window.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public bool Topmost { get; set; }

Property Value

true if the current window is always the topmost window; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Class
Window Members
Microsoft.SPOT.Presentation Namespace


Byte.ToString Method (String)

Byte.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current Byte object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard Byte format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9), prefixed by a minus sign if the number is negative.

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9). The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "d,ddd,ddd.ddd…", where 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current Byte object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Structure
Byte Members
System Namespace


DateTime.ToString Method (String)

DateTime.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current DateTime object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that specifies the format to be used for the returned string.

Return Value

A string representation of the value of the current DateTime object, in the specified format.

Expand image Remarks

The format parameter should contain either a format specifier character or a custom format pattern.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard DateTime format specifiers.

Format specifier | Name | Description
d | Short date pattern | Represents a custom DateTime format string defined by the current ShortDatePattern property. For example, the custom format string for the invariant culture is "MM/dd/yyyy".
D | Long date pattern | Represents a custom DateTime format string defined by the current LongDatePattern property. For example, the custom format string for the invariant culture is "dddd, dd MMMM yyyy".
f | Full date/time pattern (short time) | Represents a combination of the long date (D) and short time (t) patterns, separated by a space.
F | Full date/time pattern (long time) | Represents a custom DateTime format string defined by the current FullDateTimePattern property.
g | General date/time pattern (short time) | Represents a combination of the short date (d) and short time (t) patterns, separated by a space.
G | General date/time pattern (long time) | Represents a combination of the short date (d) and long time (T) patterns, separated by a space.
M or m | Month day pattern | Represents a custom DateTime format string defined by the current MonthDayPattern property. For example, the custom format string for the invariant culture is "MMMM dd".
o | Round-trip date/time pattern | Represents a custom DateTime format string using a pattern that preserves time zone information.
R or r | RFC1123 pattern | The custom format string is "ddd, dd MMM yyyy HH':'mm':'ss 'GMT'".
s | Sortable date/time pattern; conforms to ISO 8601 | The custom format string is "yyyy'-'MM'-'dd'T'HH':'mm':'ss".
t | Short time pattern | Represents a custom DateTime format string defined by the current ShortTimePattern property. For example, the custom format string for the invariant culture is "HH:mm".
T | Long time pattern | Represents a custom DateTime format string defined by the current LongTimePattern property.
u | Universal sortable date/time pattern | The custom format string is "yyyy'-'MM'-'dd HH':'mm':'ss'Z'".
U | Universal sortable date/time pattern | Represents a custom DateTime format string defined by the current FullDateTimePattern property. This pattern is the same as the full date/long time (F) pattern. However, formatting operates on the Coordinated Universal Time (UTC) that is equivalent to the DateTime object being formatted.
Y or y | Year month pattern | Represents a custom DateTime format string defined by the current YearMonthPattern property. For example, the custom format string for the invariant culture is "yyyy MMMM".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Double.ToString Method (String)

Double.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current Double object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard Double format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9), prefixed by a minus sign if the number is negative.

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9), prefixed by a minus sign if the number is negative. The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "-d,ddd,ddd.ddd…", where '-' indicates a negative symbol if required, 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current Double object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


Int16.ToString Method (String)

Int16.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current Int16 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard Int16 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9), prefixed by a minus sign if the number is negative.

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9), prefixed by a minus sign if the number is negative. The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "-d,ddd,ddd.ddd…", where '-' indicates a negative sign if required, 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current Int16 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Structure
Int16 Members
System Namespace


Int32.ToString Method (String)

Int32.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current Int32 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard Int32 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9), prefixed by a minus sign if the number is negative.

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9), prefixed by a minus sign if the number is negative. The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "-d,ddd,ddd.ddd…", where '-' indicates a negative symbol if required, 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current Int32 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Structure
Int32 Members
System Namespace


Int64.ToString Method (String)

Int64.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current Int64 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard Int64 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9), prefixed by a minus sign if the number is negative.

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9), prefixed by a minus sign if the number is negative. The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "-d,ddd,ddd.ddd…", where '-' indicates a negative symbol if required, 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current Int64 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Structure
Int64 Members
System Namespace


UInt16.ToString Method (String)

UInt16.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current UInt16 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard UInt16 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9).

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9). The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "d,ddd,ddd.ddd…", where 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current UInt16 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Structure
UInt16 Members
System Namespace


UInt32.ToString Method (String)

UInt32.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current UInt32 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard UInt32 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9).

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9). The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "d,ddd,ddd.ddd…", where 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current UInt32 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Structure
UInt32 Members
System Namespace


UInt64.ToString Method (String)

UInt64.ToString Method (String)
See Also
CollapseAll image

Converts the value of the current UInt64 object to its equivalent string representation, using a specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format
)

Parameters

format
A string that takes the form Axx, where A is an alphabetic character called the format specifier, and xx is an optional integer called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

If format is a null reference or an empty string, the general format specifier, 'G', is used.

The following table describes the standard UInt64 format specifiers.

Format specifier | Name | Description
F or f Fixed Point

The number is converted to a string of the form "ddd.ddd…" where each 'd' indicates a digit (0-9).

The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

G or g General

The number is converted to a string of decimal digits (0-9). The precision specifier is ignored.

N or n | Number | The number is converted to a string of the form "d,ddd,ddd.ddd…", where 'd' indicates a digit (0-9), ',' indicates a thousand separator between number groups, and '.' indicates a decimal point symbol. The actual number group size and thousand separator are specified by the current NumberFormatInfo object. The precision specifier indicates the desired number of decimal places. If the precision specifier is omitted, the default numeric precision is 2.

Return Value

A string representation of the value of the current UInt64 object, in the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Structure
UInt64 Members
System Namespace


Boolean.ToString Method

Boolean.ToString Method

Converts the value of the current Boolean object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString ()

Return Value

TrueString if the value of this instance is true, or FalseString if the value of this instance is false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Boolean Structure
Boolean Members
System Namespace


Byte.ToString Method ()

Byte.ToString Method ()
See Also
CollapseAll image

Converts the value of the current Byte object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Byte object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Structure
Byte Members
System Namespace


Byte.ToString Method

Byte.ToString Method

Converts the numeric value of the current Byte object to its equivalent string representation.

Expand image Overload List

Name | Description
Byte.ToString () | Converts the value of the current Byte object to its equivalent string representation.
Byte.ToString (String) | Converts the value of the current Byte object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Byte Structure
Byte Members
System Namespace


Char.ToString Method

Char.ToString Method

Converts the value of the current Char object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Char object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Char Structure
Char Members
System Namespace


CultureInfo.ToString Method

CultureInfo.ToString Method

Returns a string that contains the name of the current CultureInfo object, in the format "<languagecode2>-<country/regioncode2>".

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string that contains the name of the current CultureInfo object, in the format "<languagecode2>-<country/regioncode2>", where <languagecode2> is a lowercase two-letter code derived from ISO 639-1 and <country/regioncode2> is an uppercase two-letter code derived from ISO 3166.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

CultureInfo Class
CultureInfo Members
System.Globalization Namespace


DateTime.ToString Method ()

DateTime.ToString Method ()
See Also
CollapseAll image

Converts the value of the current DateTime object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


DateTime.ToString Method

DateTime.ToString Method

Converts the value of the current DateTime object to its equivalent string representation.

Expand image Overload List

Name | Description
DateTime.ToString () | Converts the value of the current DateTime object to its equivalent string representation.
DateTime.ToString (String) | Converts the value of the current DateTime object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


Double.ToString Method ()

Double.ToString Method ()
See Also
CollapseAll image

Converts the value of the current Double object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Double object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


Double.ToString Method

Double.ToString Method

Converts the numeric value of the current Double object to its equivalent string representation.

Expand image Overload List

Name | Description
Double.ToString () | Converts the value of the current Double object to its equivalent string representation.
Double.ToString (String) | Converts the value of the current Double object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Double Structure
Double Members
System Namespace


Exception.ToString Method

Exception.ToString Method

Creates and returns a string representation of the current exception.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the current exception.

Expand image Remarks

The ToString method returns a representation of the current exception that should be understandable to humans. If the exception contains culture-sensitive data, you must take into account the current system culture when you write the string representation returned by ToString. Although there are no exact requirements for the format of the string that is returned, it should reflect the value of the object, as perceived by the user.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Exception Class
Exception Members
System Namespace


IFormattable.ToString Method

IFormattable.ToString Method

Formats the value of the current object with the specified format.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string ToString (
         string format,
         IFormatProvider formatProvider
)

Parameters

format

The String object that specifies the format you want to use.

-or-

A null reference, which will obtain the default format defined for the type of the IFormattable implementation.

formatProvider

The IFormatProvider object you want to use to format the value.

-or-

A null reference, which will obtain the numeric format information from the current locale setting for the operating system.

Return Value

The String object that contains the value of the current object with the specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

IFormattable Interface
IFormattable Members
System Namespace


Int16.ToString Method ()

Int16.ToString Method ()
See Also
CollapseAll image

Converts the value of the current Int16 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Int16 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Structure
Int16 Members
System Namespace


Int16.ToString Method

Int16.ToString Method

Converts the numeric value of the current Int16 object to its equivalent string representation.

Expand image Overload List

Name | Description
Int16.ToString () | Converts the value of the current Int16 object to its equivalent string representation.
Int16.ToString (String) | Converts the value of the current Int16 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int16 Structure
Int16 Members
System Namespace


Int32.ToString Method ()

Int32.ToString Method ()
See Also
CollapseAll image

Converts the value of the current Int32 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Int32 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Structure
Int32 Members
System Namespace


Int32.ToString Method

Int32.ToString Method

Converts the numeric value of the current Int32 object to its equivalent string representation.

Expand image Overload List

Name | Description
Int32.ToString () | Converts the value of the current Int32 object to its equivalent string representation.
Int32.ToString (String) | Converts the value of the current Int32 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int32 Structure
Int32 Members
System Namespace


Int64.ToString Method ()

Int64.ToString Method ()
See Also
CollapseAll image

Converts the value of the current Int64 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current Int64 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Structure
Int64 Members
System Namespace


Int64.ToString Method

Int64.ToString Method

Converts the numeric value of the current Int64 object to its equivalent string representation.

Expand image Overload List

Name | Description
Int64.ToString () | Converts the value of the current Int64 object to its equivalent string representation.
Int64.ToString (String) | Converts the value of the current Int64 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Int64 Structure
Int64 Members
System Namespace


Object.ToString Method

Object.ToString Method

Returns a string that represents the current instance (object) of the Object class.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public virtual string ToString ()

Return Value

A string that represents the current object.

Expand image Remarks

This method returns a human-readable text string that is culture-sensitive. For example, for a Double object whose value is 0 (zero), the implementation of the Double.ToString method might return "0.00" or "0,00", depending on the current system culture.

The default implementation returns the fully qualified name of the type of the Object object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Object Class
Object Members
System Namespace


RoutedEvent.ToString Method

RoutedEvent.ToString Method

Retrieves a string representation of the current RoutedEvent object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the current routed event. Note that this string is identical to the value returned by the Name property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

RoutedEvent Class
RoutedEvent Members
Microsoft.SPOT Namespace


String.ToString Method

String.ToString Method

Returns the current String object; no actual conversion is performed.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

The current String object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Text.ToString Method

Text.ToString Method

Creates a string representation of the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

The contents of the current Text object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


TimeSpan.ToString Method

TimeSpan.ToString Method

Converts the value of the current TimeSpan object (time period) to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current TimeSpan object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace


Type.ToString Method

Type.ToString Method

Returns a String object that represents the name of the current type.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A String object representing the name of the current type.

Expand image Remarks

This method returns the fully qualified Common Language Runtime (CLR) namespace and the names for all primitive types.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Class
Type Members
System Namespace


UInt16.ToString Method ()

UInt16.ToString Method ()
See Also
CollapseAll image

Converts the value of the current UInt16 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current UInt16 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Structure
UInt16 Members
System Namespace


UInt16.ToString Method

UInt16.ToString Method

Converts the numeric value of the current UInt16 object to its equivalent string representation.

Expand image Overload List

Name | Description
UInt16.ToString () | Converts the value of the current UInt16 object to its equivalent string representation.
UInt16.ToString (String) | Converts the value of the current UInt16 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Structure
UInt16 Members
System Namespace


UInt32.ToString Method ()

UInt32.ToString Method ()
See Also
CollapseAll image

Converts the value of the current UInt32 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current UInt32 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Structure
UInt32 Members
System Namespace


UInt32.ToString Method

UInt32.ToString Method

Converts the numeric value of the current UInt32 object to its equivalent string representation.

Expand image Overload List

Name | Description
UInt32.ToString () | Converts the value of the current UInt32 object to its equivalent string representation.
UInt32.ToString (String) | Converts the value of the current UInt32 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Structure
UInt32 Members
System Namespace


UInt64.ToString Method ()

UInt64.ToString Method ()
See Also
CollapseAll image

Converts the value of the current UInt64 object to its equivalent string representation.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public override string ToString ()

Return Value

A string representation of the value of the current UInt64 object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Structure
UInt64 Members
System Namespace


UInt64.ToString Method

UInt64.ToString Method

Converts the numeric value of the current UInt64 object to its equivalent string representation.

Expand image Overload List

Name | Description
UInt64.ToString () | Converts the value of the current UInt64 object to its equivalent string representation.
UInt64.ToString (String) | Converts the value of the current UInt64 object to its equivalent string representation, using a specified format.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Structure
UInt64 Members
System Namespace


DateTime.ToUniversalTime Method

DateTime.ToUniversalTime Method

Converts the value of the current DateTime object to Coordinated Universal Time (UTC).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public DateTime ToUniversalTime ()

Return Value

A new DateTime object that contains the UTC equivalent of the value of the current DateTime object.

Expand image Remarks

The value of the new DateTime object is a MaxValue field if the converted value is too large to be represented by a DateTime object, or it is a MinValue field if the converted value is too small to be represented by a DateTime object.

The UTC time is equal to the local time minus the UTC offset. For more information about the UTC offset, see the GetUtcOffset method. Note that the conversion also takes into account the daylight saving time rule that applies to the value of the current DateTime object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


TimeZone.ToUniversalTime Method

TimeZone.ToUniversalTime Method

Returns the Coordinated Universal Time (UTC) time that corresponds to a specified local time.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual DateTime ToUniversalTime (
         DateTime time
)

Parameters

time
The specified local date and time.

Return Value

A DateTime object whose value is the UTC time that corresponds to the time parameter.

Expand image Remarks

Coordinated universal time (UTC) was previously known as Greenwich Mean Time (GMT). Local time is the date and time on the computer you are using. Offset is the difference between local time and UTC (local time = UTC + offset).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeZone Class
TimeZone Members
System Namespace


String.ToUpper Method

String.ToUpper Method

Returns the current String object in uppercase.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string ToUpper ()

Return Value

The current String object in uppercase.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


AssemblyTrademarkAttribute.Trademark Property

AssemblyTrademarkAttribute.Trademark Property

Gets trademark information for the assembly being attributed.

Namespace: System.Reflection
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Trademark { get; }

Property Value

A string that contains trademark information for the assembly being attributed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AssemblyTrademarkAttribute Class
AssemblyTrademarkAttribute Members
System.Reflection Namespace


DrawingContext.Translate Method

DrawingContext.Translate Method

Translates (moves) the most recently drawn image by the specified amount on the drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void Translate (
         int dx,
         int dy
)

Parameters

dx
The horizontal distance to translate the image.
dy
The vertical distance to translate the image.

Expand image Remarks

The horizontal and vertical translations are relative to the upper left point of the image.

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.TransparentBlt Method

Bitmap.TransparentBlt Method

Combines the data for the specified source bitmap and the current bitmap (destination bitmap) in a defined rectangular area.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
[ObsoleteAttribute]
[MethodImplAttribute]
public void TransparentBlt (
         int xDst,
         int yDst,
         int nWidth,
         int nHeight,
         Bitmap pSrc,
         int xSrc,
         int ySrc
)

Parameters

xDst
The x-coordinate of the upper-left corner of the destination rectangle.
yDst
The y-coordinate of the upper-left corner of the destination rectangle.
nWidth
The width of the source and destination rectangles.
nHeight
The height of the source and destination rectangles.
pSrc
The source bitmap.
xSrc
The x-coordinate of the upper-left corner of the source rectangle.
ySrc
The y-coordinate of the upper-left corner of the source rectangle.

Expand image Remarks

If a bitmap is embedded as a resource, and its BitmapImageType is Bmp, then the Bitmap object is read-only, and attempts to modify it will throw an exception. You must make a copy of it using Bitmap.DrawImage, and modify the copy, as shown in the following code:

        Bitmap bmpMyBitmap = Resources.GetBitmap(Resources.BitmapResources.MyBitmap);
        Bitmap bmpCopy = new Bitmap(bmpMyBitmap.Width, bmpMyBitmap.Height);
        // copy the bitmap
        bmpCopy.DrawImage(0, 0, bmpMyBitmap, 0, 0, bmpMyBitmap.Width, bmpMyBitmap.Height);
        // now you may modify the copy using any Bitmap method
        bmpCopy.MakeTransparent(Microsoft.SPOT.Presentation.Media.Color.White);

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


String.Trim Method (Char[])

String.Trim Method (Char[])
See Also
CollapseAll image

Removes all occurrences of a specified array of Unicode characters from the beginning and end of the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string Trim (
         char[] trimChars
)

Parameters

trimChars
The array of Unicode characters to be removed from the beginning and end of the current String object, or a null reference.

Return Value

The String object that remains after all occurrences of the characters specified in the trimChars parameter have been removed from the beginning and end of the string. If trimChars is a null reference, white-space characters are removed instead.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Trim Method ()

String.Trim Method ()
See Also
CollapseAll image

Removes all white-space characters from the beginning and end of the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string Trim ()

Return Value

The String object that remains after all white-space characters have been removed from the beginning and end of the string.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.Trim Method

String.Trim Method

Removes all occurrences of a specified array of Unicode characters from the beginning and end of the current String object.

Expand image Overload List

Name | Description
String.Trim () | Removes all white-space characters from the beginning and end of the current String object.
String.Trim (Char[]) | Removes all occurrences of a specified array of Unicode characters from the beginning and end of the current String object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


String.TrimEnd Method

String.TrimEnd Method

Removes all occurrences of a specified array of Unicode characters from the end of the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string TrimEnd (
         char[] trimChars
)

Parameters

trimChars
[ParamArrayAttribute] The array of Unicode characters to be removed from the end of the current String object, or a null reference.

Return Value

The String object that remains after all occurrences of the characters specified in the trimChars parameter have been removed from the end of the string. If trimChars is a null reference, white-space characters are removed instead.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Text.Trimming Property

Text.Trimming Property

Gets or sets the type of white-space trimming for the text in the current Text object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public TextTrimming Trimming { get; set; }

Property Value

The type of white-space trimming for the text.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Text Class
Text Members
Microsoft.SPOT.Presentation.Controls Namespace


String.TrimStart Method

String.TrimStart Method

Removes all occurrences of a specified array of Unicode characters from the beginning of the current String object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public string TrimStart (
         char[] trimChars
)

Parameters

trimChars
[ParamArrayAttribute] The array of Unicode characters to be removed from the beginning of the current String object, or a null reference.

Return Value

The String object that remains after all occurrences of the characters specified in the trimChars parameter have been removed from the beginning of the string. If trimChars is a null reference, white-space characters are removed instead.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

String Class
String Members
System Namespace


Boolean.TrueString Field

Boolean.TrueString Field

Represents the Boolean value true as a string. This field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static readonly bool TrueString

Expand image Remarks

This field is equal to the string "True".

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Boolean Structure
Boolean Members
System Namespace


Bitmap.DT_TruncateAtBottom Field

Bitmap.DT_TruncateAtBottom Field

Specifies that if the bitmap text is larger than the space provided, the text is truncated at the bottom.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_TruncateAtBottom

Expand image Remarks

You cannot use this field with the DT_Ellipsis flag. Use it only with the Microsoft.SPOT.Bitmap.DrawTextInRect methods.

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DebuggerDisplayAttribute.Type Property

DebuggerDisplayAttribute.Type Property

Gets or sets the display type.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Type { get; set; }

Property Value

The display type.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


UnknownTypeException.m_type Field

UnknownTypeException.m_type Field

Contains a reference to the unknown type that caused the current exception.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public Type m_type

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UnknownTypeException Class
UnknownTypeException Members
Microsoft.SPOT Namespace


Type Class

Type Class
See Also Members
CollapseAll image

Represents type declarations for the following categories of types: class types, interface types, array types, value types, and enumeration types.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class Type : MemberInfo, IReflect

Expand image Remarks

The Type class is the root of the System.Reflection functionality and is the primary way that you access metadata. Use the members of the Type class to get information about a type declaration — such as a class's constructors, methods, fields, properties, and events — as well as information about the module and the assembly in which the class is deployed.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Type Members
System Namespace


Type Members

Type Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Type type.

Expand image Protected Constructors

 | Name | Description
Protected Method | Type | Initializes a new instance of the Type class.

Expand image Public Properties

 | Name | Description
Public Property | Assembly | Gets the Assembly object in which the current type is declared.
Public Property | BaseType | Gets the type from which the current type directly inherits.
Public Property | DeclaringType | Gets the type name of the class that declares the current member.
Public Property | FullName | Gets the fully qualified type name of the class that declares the current member.
Public Property | IsAbstract | Gets a value indicating whether the current type is abstract and must be overridden.
Public Property | IsArray | Gets a value indicating whether the current type is an array.
Public Property | IsClass | Gets a value indicating whether the current type is a class, and not a value type or an interface.
Public Property | IsEnum | Gets a value indicating whether the current type represents an enumeration.
Public Property | IsInterface | Gets a value indicating whether the current type is an interface, and not a class or a value type.
Public Property | IsNotPublic | Gets a value indicating whether the top-level type is not declared as a public type.
Public Property | IsPublic | Gets a value indicating whether the top-level type is declared as a public type.
Public Property | IsSerializable | Gets a value indicating whether the current type is serializable.
Public Property | IsValueType | Gets a value indicating whether the current type is a value type.

Expand image Public Methods

 | Name | Description
Public Method | GetConstructor | Searches for a public instance constructor whose parameters match the types in the specified array of Type objects.
Public Method | GetElementType | When overridden in a derived class, this method returns the type of the object encompassed or referred to by the current array, pointer, or reference type.
Public Method | GetField | Overloaded. Searches for the specified data field.
Public Method | GetFields | Overloaded. Gets the fields of the current type.
Public Method | GetInterfaces | When overridden in a derived class, this method gets all of the interfaces implemented or inherited by the current type.
Public Method | GetMethod | Overloaded. Gets a specific method of the current type.
Public Method | GetMethods | Overloaded. Gets the methods of the current type.
 | GetType | Gets the type with the specified name by performing a case-sensitive search.
 | GetTypeFromHandle | Gets the type referenced by the specified RuntimeTypeHandle object (type handle).
Public Method | InvokeMember | Invokes the specified member by using the specified binding constraints (flags) and matching the specified argument list.
Public Method | IsInstanceOfType | Determines whether the specified object is an instance of the current type.
Public Method | IsSubclassOf | Determines whether the current type derives from the specified type.
Public Method | ToString | Returns a String object that represents the name of the current type.

Expand image See Also

Reference

Type Class
System Namespace


TypeCode Enumeration

TypeCode Enumeration

Contains values that specify the type of an object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public enum TypeCode

Expand image Members

Member name | Description
Boolean | A simple type that represents Boolean values.
Byte | An integral type that represents unsigned 8-bit integers with values ranging from 0 through 255.
Char | An integral type that represents unsigned 16-bit integers with values ranging from 0 through 65535. The set of possible values for the Char type corresponds to the Unicode character set.
DateTime | A type that represents a date and time value.
DBNull | A database null (column) value.
Decimal | A simple type that represents values ranging from 1.0 x 10-28 through approximately 7.9 x 1028, with 28-29 significant digits.
Double | A floating-point type that represents values ranging from approximately 5.0 x 10-324 through 1.7 x 10308, with a precision of 15-16 digits.
Empty | A null reference.
Int16 | An integral type that represents signed 16-bit integers with values ranging from -32768 through 32767.
Int32 | An integral type that represents signed 32-bit integers with values rangine from -2147483648 through 2147483647.
Int64 | An integral type that represents signed 64-bit integers with values ranging from -9223372036854775808 through 9223372036854775807.
Object | A general type that represents any reference or value type not explicitly represented by another TypeCode object.
SByte | An integral type that represents signed 8-bit integers with values ranging from -128 through 127.
Single | A floating-point type that represents values ranging from approximately 1.5 x 10-45 through 3.4 x 1038, with a precision of 7 digits.
String | A sealed class type that represents Unicode character strings.
UInt16 | An integral type that represents unsigned 16-bit integers with values ranging from 0 through 65535.
UInt32 | An integral type that represents unsigned 32-bit integers with values ranging from 0 through 4294967295.
UInt64 | An integral type that represents unsigned 64-bit integers with values ranging from 0 through 18446744073709551615.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


UIElement Class

UIElement Class
See Also Members
CollapseAll image

Provides programming components you can use to lay out and render graphical user interface (GUI) items such as shapes, images, and controls on a particular region of a display device's screen.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public abstract class UIElement : DispatcherObject

Expand image Remarks

The UIElement class is the the base class — or the basic Windows Presentation Foundation (WPF) element — from which all display elements derive.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Members
Microsoft.SPOT.Presentation Namespace


UIElement Members

UIElement Members
See Also Constructors Events Fields Methods Properties
CollapseAll image

The following tables list the members exposed by the UIElement type.

Expand image Public Constructors

 | Name | Description
Public Method | UIElement | Initializes a new instance of the UIElement class.

Expand image Protected Fields

 | Name | Description
Protected Field | _horizontalAlignment | Specifies the horizontal alignment characteristics that are applied to the current element when it is composed within a parent element, such as a Panel object.
Protected Field | _verticalAlignment | Specifies the vertical alignment characteristics that are applied to the current element when it is composed within a parent element, such as a Panel object.

Expand image Public Properties

 | Name | Description
Public Property | ActualHeight | Gets the rendered height of this element.
Public Property | ActualWidth | Gets the rendered width of this element.
Public Property | Height | Gets or sets the suggested height of this element.
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to this element when it is composed within a parent element, such as a Panel.
Public Property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI).
Public Property | IsFocused | Gets a value that determines whether this element has logical focus.
Public Property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid.
Public Property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI).
Public Property | Parent | Gets the logical parent element of this element.
Public Property | RootUIElement | Gets the logical root element of this element.
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to this element when it is composed within a parent element, such as a Panel.
Public Property | Visibility | Gets or sets the user interface (UI) visibility of this element.
Public Property | Width | Gets or sets the suggested width of this element.

Expand image Protected Properties

 | Name | Description
Protected Property | InstanceEventHandlersStore | Gets the event-handler store for this element.
Protected Property | LogicalChildren | Gets an enumerator for this element's logical child elements.

Expand image Public Methods

 | Name | Description
Public Method | AddHandler | Adds a routed-event handler for a specified routed event, adding the handler to the current element's event handler collection.
Public Method | AddToEventRoute | Adds handlers to the specified event route for the current element's event handler collection.
Public Method | Arrange | Positions child elements in a particular region on the screen.
Public Method | GetDesiredSize | Gets the current element's size, as computed during the measure pass of the layout process.
Public Method | GetLayoutOffset | Gets the current element's offset, relative to the upper-left corner of the screen.
Public Method | GetMargin | Gets the width of the current element's margins.
Public Method | GetRenderSize | Gets the final render size of the current element.
Public Method | Invalidate | Invalidates the rendering of the current element and forces a complete new layout pass.
Public Method | InvalidateArrange | Invalidates the arrange state of the current element's layout.
Public Method | InvalidateMeasure | Invalidates the measurement state of the current element's layout.
Public Method | Measure | Determines the size requirements for the layout of a child element.
Public Method | OnRender | Participates in rendering operations that are directed by the layout system when implemented in a derived class.
Public Method | RaiseEvent | Raises a specific routed event.
Public Method | SetMargin | Overloaded. Sets the size of the current element's margin.
Public Method | UpdateLayout | Ensures that all visual child elements of the current element are properly updated for layout.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Positions child elements and determines a size for a UIElement-derived class when implemented in a derived class.
Protected Method | MeasureOverride | Determines the custom size requirements for the layout of a child element when implemented in a derived class.
Protected Method | OnButtonDown | Adds class handling for an unhandled ButtonDown attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.
Protected Method | OnButtonUp | Adds class handling for an unhandled ButtonUp attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.
Protected Method | OnChildDesiredSizeChanged | Supports the layout system when a child element is resized.
Protected Method | OnGotFocus | Adds class handling for an unhandled ButtonsGotFocus attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.
Protected Method | OnLostFocus | Adds class handling for an unhandled ButtonsLostFocus attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.
Protected Method | OnPreviewButtonDown | Adds class handling for an unhandled PreviewButtonDown attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.
Protected Method | OnPreviewButtonUp | Adds class handling for an unhandled PreviewButtonUp attached event when that event reaches, by way of its route, an element that is derived from the UIElement class.

Expand image Public Events

 | Name | Description
Public Event | IsEnabledChanged | Occurs when the value of the IsEnabled property changes for the current element.
Public Event | IsVisibleChanged | Occurs when the value of the IsVisible property changes for the current element.

Expand image See Also

Reference

UIElement Class
Microsoft.SPOT.Presentation Namespace


UIElementCollection Class

UIElementCollection Class
See Also Members
CollapseAll image

Represents an ordered collection of UIElement objects.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public class UIElementCollection : ICollection, IEnumerable

Expand image Remarks

The Panel class uses a UIElementCollection object to represent its collection of child elements. Methods and properties defined by the UIElementCollection class affect all objects derived from the Panel class and define a common feature set you can use to manipulate Panel child elements.

A UIElementCollection object has affinity to its own context (class). You must access the collection from the context of the owning Panel object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElementCollection Members
Microsoft.SPOT.Presentation Namespace


UIElementCollection Members

UIElementCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
CollapseAll image

The following tables list the members exposed by the UIElementCollection type.

Expand image Public Constructors

 | Name | Description
Public Method | UIElementCollection | Initializes a new instance of the UIElementCollection class.

Expand image Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the maximum number of elements that the current collection can contain.
Public Property | Count | Gets the actual number of elements in the current collection.
Public Property | IsSynchronized | Gets a value that indicates whether access to the ICollection interface is synchronized (that is, thread-safe).
Public Property | Item | Gets or sets the element that is stored at a specified index number (position) in the current collection.
Public Property | SyncRoot | Gets an object that you can use to synchronize access to the ICollection interface.

Expand image Public Methods

 | Name | Description
Public Method | Add | Adds a specified element to the current collection at a specified index number (position).
Public Method | Clear | Removes all elements from the current collection.
Public Method | Contains | Determines whether the current collection contains a specified element.
Public Method | CopyTo | Overloaded. Copies the UIElement objects from the current collection to an array, starting at a specified index number (position) in the collection.
Public Method | IndexOf | Returns the index number (position) of a specified element in the current collection.
Public Method | Insert | Inserts a specified element into the current collection at a specified index number (position).
Public Method | Remove | Removes a specified element from the current collection.
Public Method | RemoveAt | Removes from the current collection the element at the specified index number (position) in the collection.
Public Method | RemoveRange | Removes from the current collection a range of elements starting at a specified index number (position) in the collection.

Expand image Explicit Interface Implementations

 | Name | Description
Explicit Interface Implementation | System.Collections.IEnumerable.GetEnumerator | Retrieves an enumerator that can be used to iterate through the current collection.

Expand image See Also

Reference

UIElementCollection Class
Microsoft.SPOT.Presentation Namespace


UInt16 Structure

UInt16 Structure

Represents a 16-bit unsigned integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct UInt16

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt16 Members
System Namespace


UInt16 Members

UInt16 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the UInt16 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of UInt16 Structure. This field is constant.
MinValue | Represents the smallest possible value of UInt16 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current UInt16 object to its equivalent string representation.

Expand image See Also

Reference

UInt16 Structure
System Namespace


UInt32 Structure

UInt32 Structure

Represents a 32-bit unsigned integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct UInt32

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt32 Members
System Namespace


UInt32 Members

UInt32 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the UInt32 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of UInt32 Structure. This field is constant.
MinValue | Represents the smallest possible value of UInt32 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current UInt32 object to its equivalent string representation.

Expand image See Also

Reference

UInt32 Structure
System Namespace


UInt64 Structure

UInt64 Structure

Represents a 64-bit unsigned integer.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct UInt64

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UInt64 Members
System Namespace


UInt64 Members

UInt64 Members
See Also Fields Methods
CollapseAll image

The following tables list the members exposed by the UInt64 type.

Expand image Public Fields

Name | Description
MaxValue | Represents the largest possible value of UInt64 Structure. This field is constant.
MinValue | Represents the smallest possible value of UInt64 Structure. This field is constant.

Expand image Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Converts the numeric value of the current UInt64 object to its equivalent string representation.

Expand image See Also

Reference

UInt64 Structure
System Namespace


UnknownTypeException Class

UnknownTypeException Class
See Also Members
CollapseAll image

The exception that is thown when an error occurs because of an unknown type.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public class UnknownTypeException : Exception

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UnknownTypeException Members
Microsoft.SPOT Namespace


UnknownTypeException Members

UnknownTypeException Members
See Also Fields
CollapseAll image

The following tables list the members exposed by the UnknownTypeException type.

Expand image Public Fields

 | Name | Description
Public Field | m_type | Contains a reference to the unknown type that caused the current exception.

Expand image See Also

Reference

UnknownTypeException Class
Microsoft.SPOT Namespace


AppDomain.Unload Method

AppDomain.Unload Method

Unloads the specified application domain.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public static void Unload (
         AppDomain domain
)

Parameters

domain
The application domain you want to unload.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AppDomain Class
AppDomain Members
System Namespace


UIElement.UpdateLayout Method

UIElement.UpdateLayout Method

Ensures that all visual child elements of the current element are properly updated for layout.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public void UpdateLayout ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


DateTime.UtcNow Property

DateTime.UtcNow Property

Gets the system's current date and time, expressed in Coordinated Universal Time (UTC).

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static DateTime UtcNow { get; }

Property Value

A DateTime object that represents the system's current date and time, expressed in Coordinated Universal Time.

Expand image Remarks

The resolution of this property depends on the system timer.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


AttributeUsageAttribute.ValidOn Property

AttributeUsageAttribute.ValidOn Property

Gets a set of values that indicate which program elements you can apply the specified attribute to.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public AttributeTargets ValidOn { get; }

Property Value

One or more AttributeTargets values. The default return value is All.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

AttributeUsageAttribute Class
AttributeUsageAttribute Members
System Namespace


DebuggerDisplayAttribute.Value Property

DebuggerDisplayAttribute.Value Property

Gets the display value.

Namespace: System.Diagnostics
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string Value { get; }

Property Value

The display value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DebuggerDisplayAttribute Class
DebuggerDisplayAttribute Members
System.Diagnostics Namespace


MethodImplAttribute.Value Property

MethodImplAttribute.Value Property

Gets the MethodImplOptions value that describes the method being attributed.

Namespace: System.Runtime.CompilerServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public MethodImplOptions Value { get; }

Property Value

The MethodImplOptions value that describes the method being attributed.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

MethodImplAttribute Class
MethodImplAttribute Members
System.Runtime.CompilerServices Namespace


StructLayoutAttribute.Value Property

StructLayoutAttribute.Value Property

Gets the LayoutKind value that specifies how a particular class or structure is arranged.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public LayoutKind Value { get; }

Property Value

The LayoutKind value that specifies how the class or structure is arranged.

Expand image Remarks

Items in this namespace are for use by Microsoft® Visual Studio®. You should not try to use them in your applications.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

StructLayoutAttribute Class
StructLayoutAttribute Members
System.Runtime.InteropServices Namespace


ValueType Class

ValueType Class
See Also Members
CollapseAll image

Constitutes the base class for value types.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public abstract class ValueType

Expand image Remarks

The ValueType class overrides the virtual methods from the Object class, providing more appropriate implementations for value types.

Data types are separated into value types and reference types. Value types are either stack-allocated or allocated inline in a structure. Reference types are heap-allocated. Both reference types and value types are derived from the ultimate base class, the Object class. In cases where it is necessary for a value type to behave like an object, a wrapper that makes the value type look like a reference object is allocated on the heap, and the value type's value is copied into it. The wrapper is marked so that the system knows that it contains a value type. This process is known as boxing, and the reverse process is known as unboxing. Boxing and unboxing allow any data type to be treated as an object.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ValueType Members
System Namespace


ValueType Members

ValueType Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the ValueType type.

Expand image Protected Constructors

 | Name | Description
Protected Method | ValueType | Initializes a new instance of the ValueType class.

Expand image Public Methods

 | Name | Description
Public Method | Equals | Indicates whether the current ValueType object and a specified Object object are equal.

Expand image See Also

Reference

ValueType Class
System Namespace


Verbosity

Verbosity
See Also Example
CollapseAll image

Specifies the verbosity level of TFConvert output.

Expand image Syntax

Verbosity level

Parameters

level
May be 0, 1, or 2.
level | Description
0 | Details are not displayed.
1 | Font properties are displayed.
2 | Font properties and character properties, and a diagram of each character, are displayed.

Expand image Remarks

This option is optional. If Verbosity is not specified, the default value is 0.

Expand image Example

Verbosity 0

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TFConvert References


Dispatcher.VerifyAccess Method

Dispatcher.VerifyAccess Method

Determines whether the calling thread has access to the current Dispatcher object (dispatcher).

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[ConditionalAttribute]
public void VerifyAccess ()
Exceptions This method throws the exceptions listed in the following table.
Exception | Condition
InvalidOperationException | The calling thread does not have access to the current dispatcher.

Expand image Remarks

Only the thread that created the current dispatcher can access it. Note, however, that because this method is public, any thread can check to see whether it has access to the current dispatcher.

The difference between the CheckAccess and VerifyAccess methods is that CheckAccess returns false if the calling thread does not have access to the current dispatcher, whereas VerifyAccess throws an exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Dispatcher Class
Dispatcher Members
Microsoft.SPOT Namespace


DispatcherObject.VerifyAccess Method

DispatcherObject.VerifyAccess Method

Determines whether the calling thread has access to the current DispatcherObject object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[ConditionalAttribute]
public void VerifyAccess ()

Expand image Remarks

The difference between the CheckAccess and VerifyAccess methods is that CheckAccess returns false if the calling thread does not have access to the current DispatcherObject object, whereras VerifyAccess throws an exception.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherObject Class
DispatcherObject Members
Microsoft.SPOT Namespace


UIElement._verticalAlignment Field

UIElement._verticalAlignment Field

Specifies the vertical alignment characteristics that are applied to the current element when it is composed within a parent element, such as a Panel object.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected VerticalAlignment _verticalAlignment

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


VerticalAlignment Enumeration

VerticalAlignment Enumeration

Specifies a child element's vertical alignment within its parent element's layout space.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum VerticalAlignment

Expand image Members

Member name | Description
Bottom | A value specifying that the child element is aligned with the bottom of the parent element's layout space.
Center | A value specifying that the child element is aligned with the vertical center of the parent element's layout space.
Stretch | A value specifying that the child element is vertically stretched to the top and bottom of the parent element's layout space. Note that explicitly set values of the UIElement.Height and UIElement.Width properties of an element take precedence over the Stretch value of the UIElement.VerticalAlignment property.
Top | A value specifying that the child element is aligned with the top of the parent element's layout space.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation Namespace


UIElement.VerticalAlignment Property

UIElement.VerticalAlignment Property

Gets or sets the vertical alignment characteristics that are applied to this element when it is composed within a parent element, such as a Panel.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public VerticalAlignment VerticalAlignment { get; set; }

Property Value

A value of the VerticalAlignment enumeration. The default value is Stretch.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


ScrollChangedEventArgs.VerticalChange Field

ScrollChangedEventArgs.VerticalChange Field

Contains the new (changed) vertical offset value for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int VerticalChange

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Class
ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ListBox.VerticalOffset Property

ListBox.VerticalOffset Property

Gets or sets the vertical offset, or displacement, of a control's content from the top edge of the display device area that contains the control.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int VerticalOffset { get; set; }

Property Value

The vertical offset of the control's content from the top edge of the area in which the control is contained.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ListBox Class
ListBox Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollChangedEventArgs.VerticalOffset Field

ScrollChangedEventArgs.VerticalOffset Field

Contains the current vertical offset value for a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int VerticalOffset

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollChangedEventArgs Class
ScrollChangedEventArgs Members
Microsoft.SPOT.Presentation.Controls Namespace


ScrollViewer.VerticalOffset Property

ScrollViewer.VerticalOffset Property

Gets or sets the vertical offset of the scrolled content in a ScrollViewer object.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int VerticalOffset { get; set; }

Property Value

The vertical offset of the scrolled content. The default value for this property is 0 (zero).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

ScrollViewer Class
ScrollViewer Members
Microsoft.SPOT.Presentation.Controls Namespace


Visibility Enumeration

Visibility Enumeration

Specifies the current display state of a particular .NET Micro Framework element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public enum Visibility

Expand image Members

Member name | Description
Collapsed | A value specifying that the element is not displayed and no space is reserved for it in the layout.
Hidden | A value specifying that the element is not displayed but space is reserved for it in the layout.
Visible | A value specifying that the element is displayed.

Expand image Remarks

Elements that have a UIElement.Visibility property value of Collapsed do not occupy any layout space. Note that by default, elements are visible (specified by the Visible value).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Microsoft.SPOT.Presentation Namespace


UIElement.Visibility Property

UIElement.Visibility Property

Gets or sets the user interface (UI) visibility of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public Visibility Visibility { get; set; }

Property Value

A value of the Visibility enumeration. The default value is Visible.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Void Structure

Void Structure

Specifies a return value for a method that does not return a value.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public struct Void

Expand image Remarks

The Void structure is used in the System.Reflection namespace, but is rarely useful in a typical application. The Void structure has no members other than the ones all types inherit from the Object class.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

System Namespace


DispatcherOperation.Wait Method (TimeSpan)

DispatcherOperation.Wait Method (TimeSpan)
See Also
CollapseAll image

Waits for a specified amount of time for the delegate on the dispatcher queue to complete.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherOperationStatus Wait (
         TimeSpan timeout
)

Parameters

timeout
The maximum amount of time this method will wait.

Return Value

The status of the operation.

Expand image Remarks

To obtain the return value of the invoked delegate, use the Result property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


DispatcherOperation.Wait Method ()

DispatcherOperation.Wait Method ()
See Also
CollapseAll image

Waits for the delegate on the dispatcher queue associated with the current DispatcherOperation object to complete.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public DispatcherOperationStatus Wait ()

Return Value

The status of the operation.

Expand image Remarks

To obtain the return value of the invoked delegate, use the Result property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


DispatcherOperation.Wait Method

DispatcherOperation.Wait Method

Waits for the delegate on the dispatcher queue associated with the current DispatcherOperation object to complete.

Expand image Overload List

Name | Description
DispatcherOperation.Wait () | Waits for the delegate on the dispatcher queue associated with the current DispatcherOperation object to complete.
DispatcherOperation.Wait (TimeSpan) | Waits for a specified amount of time for the delegate on the dispatcher queue to complete.

Expand image Remarks

To obtain the return value of the invoked delegate, use the Result property.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DispatcherOperation Class
DispatcherOperation Members
Microsoft.SPOT Namespace


GC.WaitForPendingFinalizers Method

GC.WaitForPendingFinalizers Method

Suspends the current thread until the thread processing the queue of finalizers has emptied that queue.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public static void WaitForPendingFinalizers ()

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

GC Class
GC Members
System Namespace


WaitHandle Class

WaitHandle Class
See Also Members
CollapseAll image

Encapsulates operating system-specific objects that wait for exclusive access to shared resources.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public abstract class WaitHandle : MarshalByRefObject

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WaitHandle Members
System.Threading Namespace


WaitHandle Members

WaitHandle Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the WaitHandle type.

Expand image Protected Constructors

 | Name | Description
Protected Method | WaitHandle | Initializes a new instance of the WaitHandle class.

Expand image Public Methods

 | Name | Description
Public Method | WaitOne | Overloaded. When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal.

Expand image See Also

Reference

WaitHandle Class
System.Threading Namespace


WaitHandle.WaitOne Method (Int32, Boolean)

WaitHandle.WaitOne Method (Int32, Boolean)
See Also
CollapseAll image

When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal, using a 32-bit signed integer to specify the time interval and indicating whether to exit the synchronization domain before the wait.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual bool WaitOne (
         int millisecondsTimeout,
         bool exitContext
)

Parameters

millisecondsTimeout
The number of milliseconds you want the system to wait, or Timeout.Infinite (-1) if you want it to wait indefinitely.
exitContext
A parameter you should set to true to exit the synchronization domain for the context before the wait (in a synchronized context) and then reacquire it; otherwise, set this parameter to false.

Return Value

true if the current wait handle receives a signal; otherwise, false.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WaitHandle Class
WaitHandle Members
System.Threading Namespace


WaitHandle.WaitOne Method ()

WaitHandle.WaitOne Method ()
See Also
CollapseAll image

When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal.

Namespace: System.Threading
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[MethodImplAttribute]
public virtual bool WaitOne ()

Return Value

true if the current wait handle receives a signal; otherwise, the WaitOne method does not return a value.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WaitHandle Class
WaitHandle Members
System.Threading Namespace


WaitHandle.WaitOne Method

WaitHandle.WaitOne Method

When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal.

Expand image Overload List

Name | Description
WaitHandle.WaitOne () | When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal.
WaitHandle.WaitOne (Int32, Boolean) | When overridden in a derived class, this method blocks the current thread until the current WaitHandle object (wait handle) receives a signal, using a 32-bit signed integer to specify the time interval and indicating whether to exit the synchronization domain before the wait.

Expand image See Also

Reference

WaitHandle Class
WaitHandle Members
System.Threading Namespace


WeakDelegate Class

WeakDelegate Class
See Also Members
CollapseAll image

Provides methods for combining and removing "weak" delegates.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public sealed class WeakDelegate

Expand image Remarks

This class cannot be inherited.

When instances of the WeakDelegate class are created, the object references in the delegate list are treated like WeakReference objects. This means that these object references are prone to garbage collection even if they are still targets in the list of delegates. When such object references are collected as garbage, they are automatically removed from the list of delegates.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakDelegate Members
Microsoft.SPOT Namespace


WeakDelegate Members

WeakDelegate Members
See Also Constructors Methods
CollapseAll image

The following tables list the members exposed by the WeakDelegate type.

Expand image Public Constructors

 | Name | Description
Public Method | WeakDelegate | Creates and initializes an instance of the WeakDelegate class.

Expand image Public Methods

Name | Description
Combine | Concatenates the invocation lists of two multicast (combinable) delegates.
Remove | Removes the invocation list of a specified delegate from the invocation list of another specified delegate.

Expand image See Also

Reference

WeakDelegate Class
Microsoft.SPOT Namespace


WeakReference Class

WeakReference Class
See Also Members
CollapseAll image

Represents a weak reference, which references an object but still leaves it prone to garbage collection.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
[SerializableAttribute]
public class WeakReference

Expand image Remarks

The common language runtime (CLR) garbage collection mechanism reclaims inaccessible (unreachable) memory that is allocated to a particular object. An object becomes inaccessible if all references to it become invalid (for example, if you set those references to a null reference).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WeakReference Members
System Namespace


WeakReference Members

WeakReference Members
See Also Constructors Properties
CollapseAll image

The following tables list the members exposed by the WeakReference type.

Expand image Public Constructors

 | Name | Description
Public Method | WeakReference | Initializes a new instance of the WeakReference class, referencing a specified object.

Expand image Public Properties

 | Name | Description
Public Property | IsAlive | Determines whether the object referenced by the current WeakReference object has been collected by the garbage collection mechanism.
Public Property | Target | Gets or sets the object (the target) referenced by the current WeakReference object.

Expand image See Also

Reference

WeakReference Class
System Namespace


Colors.White Field

Colors.White Field

The system-defined color that has an RGB value of #FFFFFF.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public readonly Color White

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Colors Class
Colors Members
Microsoft.SPOT.Presentation.Media Namespace


Bitmap.WHITENESS Field

Bitmap.WHITENESS Field

Fills the destination rectangle with the color associated with index number 1 in the physical palette.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static int WHITENESS

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


TextRun._width Field

TextRun._width Field

Specifies the width, in pixels, of the text in the current text run.

Namespace: Microsoft.SPOT.Presentation.Controls
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
protected int _width

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TextRun Class
TextRun Members
Microsoft.SPOT.Presentation.Controls Namespace


Bitmap.Width Property

Bitmap.Width Property

Gets the width of the current bitmap.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public int Width { get; }

Property Value

The width of the current bitmap, in pixels.

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DrawingContext.Width Property

DrawingContext.Width Property

Gets the width of the current DrawingContext object's drawing surface.

Namespace: Microsoft.SPOT.Presentation.Media
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Width { get; }

Property Value

The width of the drawing surface.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DrawingContext Class
DrawingContext Members
Microsoft.SPOT.Presentation.Media Namespace


UIElement.Width Property

UIElement.Width Property

Gets or sets the suggested width of this element.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public int Width { get; set; }

Property Value

The suggested width of the element, in device-independent units (1/96th inch per unit).

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

UIElement Class
UIElement Members
Microsoft.SPOT.Presentation Namespace


Window Class

Window Class
See Also Members
CollapseAll image

Provides members you can use to create, configure, show, and manage windows and dialog boxes in your .NET Micro Framework applications.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class Window : ContentControl

Expand image Remarks

The point of interaction between a user and a stand-alone application is a window. A Windows Presentation Foundation (WPF) window consists of two distinct areas:

  • A system-provided area that hosts the window's adornments, including an icon, a Title Bar, System Menu, Minimize button, Maximize button, Restore button, and Close button, as well as a border.
  • A client area, which hosts application-specific content.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Window Members
Microsoft.SPOT.Presentation Namespace


Window Members

Window Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the Window type.

Expand image Public Constructors

 | Name | Description
Public Method | Window | Initializes a new instance of the Window class.

Expand image Public Properties

 | Name | Description
Public Property | Left | Gets or sets the position of the current window's left edge in relation to the desktop.
Public Property | SizeToContent | Gets or sets a value that specifies how the current window should be sized relative to its content.
Public Property | Top | Gets or sets the position of the current window's top edge in relation to the desktop.
Public Property | Topmost | Gets or sets a value that indicates whether the current window is always the topmost window.

Expand image Public Methods

 | Name | Description
Public Method | Close | Closes the current window manually.

Expand image Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Determines the current window's size and positions its child elements when you override this method.
Protected Method | MeasureOverride | Measures the size of the current window for the layout of a child element when you override this method.

Expand image See Also

Reference

Window Class
Microsoft.SPOT.Presentation Namespace


WindowCollection Class

WindowCollection Class
See Also Members
CollapseAll image

Collects the window objects for an application into a single set, or window collection.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
[DefaultMemberAttribute]
public sealed class WindowCollection : ICollection, IEnumerable

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowCollection Members
Microsoft.SPOT Namespace


WindowCollection Members

WindowCollection Members
See Also Constructors Methods Properties
CollapseAll image

The following tables list the members exposed by the WindowCollection type.

Expand image Public Constructors

 | Name | Description
Public Method | WindowCollection | Initializes a new instance of the WindowCollection class.

Expand image Public Properties

 | Name | Description
Public Property | Count | Gets the number of Window objects in a particular window collection.
Public Property | IsSynchronized | Gets a value that indicates whether a particular window collection is thread-safe.
Public Property | Item | Gets the Window object at a specified index number in a particular window collection.
Public Property | SyncRoot | Gets an object that you can use to synchronize access to a particular window collection.

Expand image Public Methods

 | Name | Description
Public Method | CopyTo | Copies Window objects from a window collection to a specified array, starting at a specified index number in the window collection.
Public Method | GetEnumerator | Returns an IEnumerator interface that your program can use to enumerate the Window objects in a window collection.

Expand image See Also

Reference

WindowCollection Class
Microsoft.SPOT Namespace


WindowManager Class

WindowManager Class
See Also Members
CollapseAll image

Manages windows that are currently open.

Namespace: Microsoft.SPOT.Presentation
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public class WindowManager : Canvas

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

WindowManager Members
Microsoft.SPOT.Presentation Namespace


WindowManager Members

WindowManager Members
See Also Methods Properties
CollapseAll image

The following tables list the members exposed by the WindowManager type.

Expand image Public Properties

Name | Description
Instance | Gets the current instance (object) of the WindowManager class.

Expand image Protected Methods

 | Name | Description
Protected Method | MeasureOverride | Determines the custom size requirements for the layout of a child element.

Expand image See Also

Reference

WindowManager Class
Microsoft.SPOT.Presentation Namespace


Application.Windows Property

Application.Windows Property

Gets the instantiated windows in the current application.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.TinyCore (in microsoft.spot.tinycore.dll)

Expand image Syntax

C#
public WindowCollection Windows { get; }

Property Value

A WindowCollection object that contains references to all of the window objects in the current application.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Application Class
Application Members
Microsoft.SPOT Namespace


Bitmap.DT_WordWrap Field

Bitmap.DT_WordWrap Field

Specifies whether a line of bitmap text automatically wraps words to the beginning of the next line when the line reaches its maximum width.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Graphics (in microsoft.spot.graphics.dll)

Expand image Syntax

C#
public static UInt32 DT_WordWrap

Expand image Remarks

The .NET Micro Framework provides the Microsoft.SPOT.Bitmap class for backward compatibility with existing applications. However, this class is not supported for new applications, and you should not use it in your .NET Micro Framework programs. Instead, the framework now provides the Windows Presentation Foundation (WPF) in the following namespaces:

  • Microsoft.SPOT.Input
  • Microsoft.SPOT.Presentation
  • Microsoft.SPOT.Presentation.Controls
  • Microsoft.SPOT.Presentation.Media
  • Microsoft.SPOT.Presentation.Shapes

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

Bitmap Class
Bitmap Members
Microsoft.SPOT Namespace


DateTime.Year Property

DateTime.Year Property

Gets the year component of the current DateTime object.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public int Year { get; }

Property Value

The year, expressed as a number from 1 through 9999.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTime Structure
DateTime Members
System Namespace


SystemTime.Year Field

SystemTime.Year Field

Specifies the year associated with a particular SystemTime object.

Namespace: Microsoft.SPOT
Assembly: Microsoft.SPOT.Native (in microsoft.spot.native.dll)

Expand image Syntax

C#
public short Year

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

SystemTime Class
SystemTime Members
Microsoft.SPOT Namespace


DateTimeFormatInfo.YearMonthPattern Property

DateTimeFormatInfo.YearMonthPattern Property

Gets the format pattern for a year and month value, which is associated with the "y" and "Y" format characters.

Namespace: System.Globalization
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public string YearMonthPattern { get; }

Property Value

The format pattern for a year and month value, which is associated with the "y" and "Y" format characters.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

DateTimeFormatInfo Class
DateTimeFormatInfo Members
System.Globalization Namespace


TimeSpan.Zero Field

TimeSpan.Zero Field

A TimeSpan having a value of 0 (zero). Note that this field is read-only.

Namespace: System
Assembly: mscorlib (in mscorlib.dll)

Expand image Syntax

C#
public readonly TimeSpan Zero

Expand image Remarks

This field provides a convenient source for 0 (zero) in time calculations.

Expand image Version Information

Available in .NET Micro Framework version 2.0

Expand image See Also

Reference

TimeSpan Structure
TimeSpan Members
System Namespace