Einführung

Einführung

PCAN-View ist ein leicht zu verwendendes Programm zur Überwachung des Datenverkehrs auf einem Controller Area Network (CAN). Es basiert auf dem PCAN-System der Firma PEAK-System Technik GmbH. Der Kern dieses Systems ist verantwortlich für die Echtzeitanbindung von Windows-Anwendungen an die an den PC angeschlossenen CAN-Busse.

PCAN-View hat die folgenden Merkmale:

  • Empfangene CAN-Botschaften werden mit ID, Datenlängencode und Datenbytes in einer Liste angezeigt. Zusätzlich wird für Botschaften mit der selben ID die Zeitdifferenz zwischen den beiden letzten Empfangszeitpunkten in der Liste angezeigt.

  • Empfangene Remote Request Frames werden angezeigt.

  • Eine beliebige Anzahl selbst erstellter Datenbotschaften oder Remote Request Frames können in eine Sendeliste eingetragen werden. Diese Botschaften können entweder manuell, automatisch in vorgegebenen Zeitintervallen, oder als Antwort auf empfangene Remote Request Frames gesendet werden.

  • Error Frames auf dem CAN-Bus werden angezeigt.

  • Sendelisten können in Dateien gespeichert und aus ihnen geladen werden.

  • Bis zu 1.000.000 CAN-Botschaften können von einem Tracer aufzeichnet werden, entweder in einem Ringpuffer oder einem linearem Puffer.

  • Die Geräte-ID einer PCAN-Hardware kann gesetzt werden, falls die verwendete PCAN-Hardware diese Funktion unterstützt.

Zusätzliche Merkmale, die nur in Verbindung mit einem PCAN-USB Pro, PCAN-USB FD oder PCAN-USB Pro FD gelten:

  • Die Buslast des verbundenen CAN-Kanals wird in einer Balkenanzeige und einer Verlaufsanzeige angezeigt.

  • Error Frames können erzeugt werden.

Verwendung dieser Online-Hilfe

Ein Hilfe-Fenster wird anzeigt, wenn Sie die Schaltfläche Hilfe in einem Dialogfenster anklicken, und die kontextbezogene Hilfe erscheint für das jeweilige Dialogfenster. In jedem Fenster von PCAN-View können Sie auch F1 auf der Tastatur drücken, um ein Hilfethema für das Fenster oder die aktuelle Registerseite anzuzeigen.

Sie können auch die Registerseiten Inhalt und Suchen auf der linken Seite des Hilfe-Fensters verwenden, um ein spezielles Hilfethema zu finden. Wenn Sie eine Suche durchführen, werden die Ergebnisse nach dem Titel der Themen sortiert angezeigt.

Wie kann man...

  • Verbinden mit einer CAN-Hardware

  • Empfangen von CAN-Botschaften

  • Senden von CAN-Botschaften

  • Bearbeiten der Sendeliste

  • Aufzeichnen von CAN-Botschaften

Siehe auch

PCAN-System Grundlagen

Kontakt-Information / Copyrights

Feedback senden | Copyright © 2021 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


PCAN-System Grundlagen

PCAN steht für PEAK CAN APPLICATIONS und ist ein flexibles System zur Planung, Entwicklung und Benutzung von CAN-Netzen. Es ist sowohl für den Entwickler als auch für den Endbenutzer ein hilfreiches und mächtiges Produkt.

Basis für die Kommunikation zwischen PCs und externer Hardware über CAN sind eine Reihe von Windows Kernel Mode Gerätetreiber, z.B. PCAN_USB.SYS, PCAN_PCI.SYS, PCAN_xxx.SYS. Diese Treiber bilden den Kern einer kompletten CAN-Umgebung auf einem PC mit Windows als Betriebssystem, und arbeiten als Schnittstellen zwischen CAN-Software und PC-basierter CAN-Hardware. Die Treiber verwalten den ganzen Datenverkehr jedes an den PC angeschlossenen CAN-Geräts.

Benutzern oder Administratoren einer CAN-Installation wird der Zugriff auf das Netzwerk mittels PCAN-Client-Programmen ermöglicht (kurz: Client). Mit ihrer Hilfe können Prozessgrößen visualisiert und beeinflusst werden. Die Treiber ermöglichen die Verbindung von mehreren Clients zur selben Zeit.

Weiterhin werden von einem PCAN-Treiber mehrere Hardware-Komponenten unterstützt, die auf dem CAN-Controller SJA1000 basieren. So genannte Netze stellen die logische Struktur für CAN-Busse zur Verfügung, die virtuell in den PC hinein verlängert sind. Auf der Hardware-Seite können ebenfalls mehrere Clients verbunden sein. Die folgende Grafik zeigt die verschiedenen Möglichkeiten von Netzkonfigurationen (die auch alle zur selben Zeit realisiert werde können):

Merkmale des PCAN-Systems

  • Ein Client kann an mehrere Netze angeschlossen sein

  • Ein Netz versorgt mehrere Clients

  • Eine Hardware gehört zu maximal einem Netz

  • Einem Netz ist keine oder genau eine Hardware zugeordnet

  • Sendet ein Client, wird die Botschaft an alle anderen verbundenen Clients weitergegeben, und über eine verbundene CAN-Hardware auf den externen CAN-Bus

  • Wird eine Botschaft über die CAN-Hardware empfangen, wird sie an alle verbundenen Clients weitergegeben. Jeder Client empfängt aber nur die Botschaften, die seinen Akzeptanzfilter passieren.

Benutzer von PCAN-View müssen keine Netze definieren und verwalten. Wenn PCAN-View angewiesen wird, eine direkte Verbindung mit einer PCAN-Hardware herzustellen, erzeugt die Anwendung automatisch ein Netz für die ausgewählte Hardware, und stellt automatisch eine Verbindung mit diesem Netz her.


Kontakt-Information / Copyright

PCAN-View ist ein Produkt von:

PEAK-System Technik GmbH

Otto-Röhm-Strasse 69
64293 Darmstadt
Deutschland

Info: | info@peak-system.com
Support: | support@peak-system.com
Web: | www.peak-system.com

Copyright © 2021 PEAK-System Technik GmbH. Alle Rechte vorbehalten.

Windows® ist ein eingetragenes Warenzeichen von Microsoft in den Vereinigten Staten von Amerika und anderen Ländern. Alle in dieser Dokumentation erwähnten anderen Produktnamen können Warenzeichen oder registrierte Warenzeichen ihrer entsprechenden Hersteller sein. Weiterhin werden "™" und "®" nicht in jedem Fall in dieser Dokumentation angegeben.

Letzte Aktualisierung: 24.03.2021


Verbinden mit einer CAN-Hardware

Um mit PCAN-View arbeiten zu können, müssen Sie zuerst eine Verbindung mit einer PCAN-Hardware herstellen, oder, falls verfügbar, mit einem PCAN-Netz.

Um PCAN-View mit einer PCAN-Hardware zu verbinden:

  1. Wählen Sie den Befehl Verbinden im Menü CAN. Das Verbinden-Dialogfenster wird angezeigt.

  2. Wählen Sie im Verbinden-Dialogfenster die PCAN-Hardware aus, mit der Sie eine Verbindung herstellen möchten, oder wählen Sie ein PCAN-Netz, falls verfügbar.

  3. Wenn Sie eine PCAN-Hardware ausgewählt haben, wählen Sie in der Dropdownliste Bitrate die Übertragungsrate, die sie verwenden möchten.

  4. Optional können Sie den Empfangsfilter in dem Gruppenfeld Filtereinstellungen konfigurieren. Wählen Sie in den Feldern Von und Bis einen Bereich von CAN-IDs aus, den Sie empfangen möchten. Die Standardeinstellung öffnet den Filter so, dass alle Standard und Extended CAN-IDs empfangen werden.

  5. Drücken Sie OK. Wenn ein Fehler auftritt und die Verbindung nicht hergestellt werden kann, wird eine entsprechende Fehlermeldung angezeigt.

Siehe auch

Verbinden-Dialogfenster

Senden von CAN-Botschaften

Empfangen von CAN-Botschaften


Empfangen von CAN-Botschaften

Nachdem PCAN-View erfolgreich mit einer CAN-Hardware oder einem PCAN-Netz (falls verfügbar) verbunden wurde, werden alle CAN-Botschaften auf dem Bus, die den Empfangsfilter des CAN-Controllers passieren, in hexadezimaler Form in der Empfangsliste angezeigt.

Der Botschaftsfilter kann im Verbinden-Dialogfenster konfiguriert werden.

Siehe auch

Senden von CAN-Botschaften


Senden von CAN-Botschaften

CAN-Botschaften können zu anderen CAN-Knoten gesendet werden, indem eine neue Sendebotschaft in der Sendeliste erzeugt wird. Siehe Bearbeiten der Sendeliste.

Nachdem eine neue Sendebotschaft erzeugt wurde, wird die Botschaft entweder zyklisch gesendet, oder manuell durch den Benutzer, je nachdem, ob eine Zykluszeit vorgegeben wurde.

Manuelles Senden von Botschaften

Die Botschaften, die aktuell in der Sendeliste ausgewählt sind, werden einmal gesendet, wenn Sie den Befehl Senden aus dem Menü Senden ausführen, oder wenn Sie die Leertaste auf der Tastatur drücken. Sie können eine einzelne Botschaft auch Senden, indem Sie mit der Maus einen Doppelklick in der Spalte Botschaft oder DLC ausführen.

Zyklisches Senden von Botschaften

Eine Botschaft kann periodisch gesendet werden, wenn die Zykluszeit auf einen Wert größer als 0 ms eingestellt wird. Um eine manuelle Botschaft in eine zyklische Botschaft abzuändern, drücken Sie die Taste [Eingabe] während die Botschaft ausgewählt ist, um das Botschaft bearbeiten-Dialogfenster anzuzeigen. Geben Sie dann die gewünschte Sende-Zykluszeit im Feld Zykluszeit ein, und stellen Sie sicher, dass die Option Angehalten nicht ausgewählt ist. Drücken Sie schließlich OK.

Um das zyklische Senden einer Botschaft zu unterbrechen, öffnen Sie das Botschaft bearbeiten-Dialogfenster und aktivieren Sie die Option Angehalten. Sie können auch eine oder mehrere Botschaften in der Sendeliste auswählen und die Taste [Pause] auf der Tastatur drücken. Dies bewirkt, dass die Option Angehalten für alle ausgewählten Sendebotschaften umgeschaltet wird.

Botschaften in der Sendeliste werden auch automatisch als Antwort auf empfangene Remote Transmit Request Frames gesendet. Siehe Beantworten von Remote-Request-Botschaften.

Siehe auch

Bearbeiten der Sendeliste

Aufzeichnen von CAN-Botschaften


Bearbeiten der Sendeliste

CAN-Botschaften können gesendet werden, indem neue Einträge in der Sendeliste erzeugt werden.

Um eine neue CAN-Botschaft zu senden:

  1. Wählen Sie den Befehl Neue Botschaft im Menü Senden.

  2. Geben Sie die CAN-ID der neuen Botschaft im Feld ID in hexadezimaler Schreibweise ein.

  3. Wählen Sie den Datenlängencode der Botschaft im Feld DLC. Dies bestimmt die Anzahl der Datenbytes (0-8) der neuen Botschaft.

  4. Geben Sie die Werte der für die Datenbytes der Botschaft in hexadezimaler Form in den Feldern Daten ein.

  5. Optional kann die Botschaft zyklisch gesendet werden. Dazu geben Sie ein Sendeintervall im Feld Zykluszeit ein, in Millisekunden.

  6. Drücken Sie OK. Die neue CAN-Botschaft wird der Sendeliste auf der Registerseite Senden/Empfangen hinzugefügt, und wird automatisch ausgewählt.

  7. Falls die Botschaft keine zyklische Sendebotschaft ist, können Sie diese schließlich manuell senden, indem Sie entweder den Befehl Senden aus dem Menü Senden wählen, oder die Leertaste auf der Tastatur drücken.

Sendebotschaften, die Sie zur Sendeliste auf der Registerseite Senden/Empfangen hinzufügen, werden beim Beenden des Programms in die Windows Registry gespeichert. Wenn Sie PCAN-View später neu starten, werden alle zuvor konfigurierten Sendebotschaften automatisch wiederhergestellt.

Die folgenden Befehle können zum Bearbeiten der Einträge der Sendeliste verwendet werden:

Befehl | Tastenkombination / Menübefehl | Symbol | Beschreibung
Neue Botschaft | [Einfg] Senden | Neue Botschaft |  | Öffnet das Botschaft bearbeiten-Dialogfenster, um eine neue Botschaft in die Sendeliste zu einzutragen.
Botschaft bearbeiten | [Eingabe] Senden | Botschaft bearbeiten |  | Öffnet das Botschaft bearbeiten-Dialogfenster, um die Parameter der Botschaft zu bearbeiten, die in der Sendeliste ausgewählt ist.
Löschen | [Entf] Bearbeiten | Löschen |  | Löscht die ausgewählten CAN-Botschaften aus der Sendeliste.
Alles löschen | [Umsch+Esc] Bearbeiten | Alles löschen |  | Entfernt alle CAN-Botschaften aus der Empfangs- oder Sendeliste.
Kopieren | [Strg+C] Bearbeiten | Kopieren |  | Kopiert die ausgewählten CAN-Botschaften in die Zwischenablage.
Ausschneiden | [Strg+X] Bearbeiten | Ausschneiden |  | Schneidet die ausgewählten CAN-Botschaften aus und legt sie in die Zwischenablage.
Einfügen | [Strg+V] Bearbeiten | Einfügen |  | Fügt den Inhalt der Zwischenablage in die Sendeliste ein.

Siehe auch

Menübefehle


Aufzeichnen von CAN-Botschaften

PCAN-View enthält einen Tracer (Datenlogger), der zum Aufzeichnen des Datenverkehrs auf einem CAN-Bus verwendet werden kann. Während der Aufzeichnung werden die CAN-Botschaften im Arbeitsspeicher des PCs gespeichert. Nach der Aufzeichnung kann der Datenpuffer dann in eine Datei gespeichert werden. Um die Aufzeichnung zu überwachen, zeigen Sie die Trace-Registerseite an.

Der Tracer kann so konfiguriert werden, dass er als linearer Puffer oder als Ringpuffer arbeitet. Arbeitet er als linearer Puffer, wird die Aufzeichnung gestoppt wenn der Puffer komplett gefüllt ist. Arbeitet er als Ringpuffer, wird die älteste Botschaft im Puffer überschrieben, wenn der Puffer voll ist und eine neue Botschaft aufgezeichnet wird.

Die maximal einstellbare Puffergröße des Tracers beträgt 1.000.000 Botschaften.

Die folgenden Befehle können zum Steuern des Tracers verwendet werden:

Befehl | Tastenkombination / Menübefehl | Symbol | Beschreibung
Trace Start | [Strg+T] Trace | Start |  | Startet die Aufzeichnung von CAN-Botschaften.
Trace Pause | Trace | Pause |  | Unterbricht die Aufzeichnung von CAN-Botschaften.
Trace Stopp | [Strg+Alt+T] Trace | Stopp |  | Stoppt die Aufzeichnung von CAN-Botschaften.
Trace Speichern | [Umsch+Strg+S] Trace | Speichern |  | Speichert die aufgezeichneten CAN-Botschaften in eine *.TRC-Datei.
Linearer Puffer | Trace | Linearer Puffer |  | Konfiguriert den Tracer so, dass er mit einem linearen Puffer arbeitet. Wenn der Puffer komplett gefüllt ist, wird die Aufzeichnung gestoppt.
Ringpuffer | Trace | Ringpuffer |  | Konfiguriert den Tracer so, dass er als Ringpuffer arbeitet. Wenn der Puffer voll ist, wird die älteste Botschaft überschrieben, wenn eine neue Botschaft aufgezeichnet wird.

Trace-Dateien

Verwenden Sie den Befehl Trace Speichern, um eine Aufzeichnung in eine *.TRC-Datei zu speichern.

Über das Hilfe-Menü können Sie ein PDF-Dokument öffnen, welches das PEAK CAN TRC Dateiformat beschreibt. Falls der entsprechende Menübefehl nicht vorhanden sein sollte, können Sie das Dokument auch über unsere Webseite herunterladen.

Siehe auch

Menübefehle


Beantworten von Remote-Request-Botschaften

Wenn ein Remote Transmit Request (RTR) Frame empfangen wird und die Option Remote Request Frames verarbeiten im Menü Senden aktiviert ist, überprüft PCAN-View, ob passende Datenbotschaften in der Sendeliste vorhanden sind (identische CAN-ID). Wenn dies der Fall ist werden die gefundenen Botschaften als Antwort auf den RTR gesendet. In der Spalte "Trigger" wird für diese Botschaften dann "RTR" angezeigt.

Hinweis

RTR-Botschaften in der Sendeliste werden niemals als Anwort auf einen empfangenen Remote Transmit Request gesendet.

Der Datenlängencode eines empfangenen Remote Transmit Request Frame wird nicht für die Beurteilung verwendet, welche Datenbotschaft zur Beantwortung des RTR gesendet werden soll. Nur die CAN-ID muss übereinstimmen.


Hauptfenster

Das PCAN-View-Hauptfenster enthält die folgenden Bereiche, von oben nach unten:

  • Menüs

  • Symbolleiste - Die Symbolleiste erlaubt einen schnellen Zugriff auf die am häufigsten verwendeten Befehle.

  • Registerseiten - Die verschiedenen Funktionen von PCAN-View sind auf Registerseiten angeordnet. Welche Registerseiten verfügbar sind hängt von der verbundenen PCAN-Hardware ab.
    PCAN-View unterstützt die folgenden Registerseiten:

Registerseite | Beschreibung
Senden/Empfangen | Zeigt empfangene und gesendete CAN-Botschaften an.
Trace | Ermöglicht die Aufzeichnung von CAN-Botschaften.
Buslast | Nur PCAN-USB Pro, PCAN-USB FD, PCAN-USB Pro FD: Ermöglicht die Messung der Buslast.
Fehler-Generator | Nur PCAN-USB Pro, PCAN-USB FD, PCAN-USB Pro FD: Ermöglicht die Erzeugung von Error Frames.
PCAN-... | Zeigt spezielle Werte und Parameter der jeweils verwendeten PCAN-Hardware an.

  • Statuszeile - Zeigt Informationen über die aktuelle Verbindung sowie den Status der verbundenen PCAN-Hardware an, und enthält Fehlerzähler.

Sie können die aktive Registerseite durch Drücken von [Strg+Tab] oder [Umsch+Strg+Tab] wechseln.

Manche Registerseiten können vom Hauptfenster abgedockt werden. Abdockbare Registerseiten sind: Trace, Buslast und Fehler-Generator. Um eine Registerseite abzudocken, führen Sie entweder einen Doppelklick auf der Registerkarte aus oder wählen Sie den Befehl Fenster schwebend aus dem Kontextmenü der Registerkarte aus (rechte Maustaste). Um ein schwebendes Fenster wieder an das Hauptfenster anzudocken, führen Sie entweder einen Doppelklick auf der Titelzeile des schwebenden Fensters aus oder wählen Sie den Befehl An Hauptfenster andocken im Kontextmenü des Fensters.

Siehe auch

Menübefehle

Symbolleiste

Statuszeile


Menübefehle

  • Datei-Menü

  • CAN-Menü

  • Bearbeiten-Menü

  • Senden-Menü

  • Ansicht-Menü

  • Trace-Menü

  • Fenster-Menü

  • Hilfe-Menü

Datei

Befehl | Symbol | Tasten-Kombination | Beschreibung
Öffnen |  | [Strg+O] | Öffnet eine zuvor gespeicherte Sendelisten-Datei.
Zuletzt verwendet |  |  | Enthält eine Liste mit zuletzt geöffneten Sendelisten-Dateien.
Speichern |  | [Strg+S] | Speichert die aktuelle Sendeliste in eine Datei.
Einstellungen |  |  | Enthält Untermenüs zur Konfiguration verschiedener Anwendungseinstellungen.
Beenden |  | [Alt+F4] | Beendet die Anwendung.

CAN

Befehl | Symbol | Tasten-Kombination | Beschreibung
Verbinden |  | [Strg+B] | Öffnet das Verbinden-Dialogfenster, um die Anwendung mit einer CAN-Hardware oder einem PCAN-Netz zu verbinden.
Trennen |  | [Strg+D] | Trennt eine aktive CAN-Verbindung.
Zurücksetzen |  | [Esc] | Setzt den CAN-Controller zurück, löscht die Empfangsliste und setzt die Zählerwerte in der Sendeliste auf 0.

Bearbeiten

Befehl | Symbol | Tasten-Kombination | Beschreibung
Ausschneiden |  | [Strg+X] | Schneidet die Auswahl aus und legt sie in die Zwischenablage.
Kopieren |  | [Strg+C] | Kopiert die ausgewählten CAN-Botschaften in die Zwischenablage.
Einfügen |  | [Strg+V] | Fügt den Inhalt der Zwischenablage in die Sendeliste ein.
Löschen |  | [Entf] | Löscht die ausgewählten CAN-Botschaften aus der Sendeliste.
Alles auswählen |  | [Strg+A] | Wählt alle CAN-Botschaften in der Empfangs- oder Sendeliste aus.
Alles löschen |  | [Umsch+Esc] | Entfernt alle CAN-Botschaften aus der Empfangs- oder Sendeliste.

Senden

Befehl | Symbol | Tasten-Kombination | Beschreibung
Neue Botschaft |  | [Einfg] | Öffnet das Botschaft bearbeiten-Dialogfenster, um eine neue Botschaft in die Sendeliste zu einzutragen.
Botschaft bearbeiten |  | [Eingabe] | Öffnet das Botschaft bearbeiten-Dialogfenster, um die Parameter der Botschaft zu bearbeiten, die in der Sendeliste ausgewählt ist.
Senden |  | [Leertaste] | Sendet alle Botschaften, die in der Sendeliste ausgewählt sind.
Anhalten / Fortsetzen |  | [Pause] | Unterbricht zyklische Sendebotschaften oder setzt das zyklische Senden fort.
Remote Request Frames verarbeiten |  |  | Ist diese Option aktiviert, verarbeitet PCAN-View eintreffende Remote Request Frames, und sendet gegebenenfalls eine oder mehrere Botschaften als Antwort, falls die Sendeliste auf der Senden/Empfangen-Registerseite passende Botschaften enthält.

Ansicht

Befehl | Symbol | Tasten-Kombination | Beschreibung
Senden / Empfangen |  | [Alt+1] | Aktiviert/zeigt die Senden/Empfangen-Registerseite.
Trace |  | [Alt+2] | Aktiviert/zeigt die Trace-Registerseite.
PCAN-... |  | [Alt+3] | Aktiviert die Registerseite der momentan verbundenen PCAN-Hardware (nur verfügbar, wenn PCAN-View mit einer PCAN-Hardware verbunden ist).
Buslast |  | [Alt+4] | Aktiviert die Buslast-Registerseite (nur verfügbar, wenn PCAN-View mit einem PCAN-USB Pro, PCAN-USB FD oder PCAN-USB Pro FD Adapter verbunden ist).
Fehler-Generator |  | [Alt+5] | Aktiviert die Fehler-Generator-Registerseite (nur verfügbar, wenn PCAN-View mit einem PCAN-USB Pro, PCAN-USB FD oder PCAN-USB Pro FD Adapter verbunden ist).

Trace

Befehl | Symbol | Tasten-Kombination | Beschreibung
Start |  | [Strg+T] | Startet die Aufzeichnung von CAN-Botschaften.
Pause |  |  | Unterbricht die Aufzeichnung von CAN-Botschaften.
Stopp |  | [Strg+Alt+T] | Stoppt die Aufzeichnung von CAN-Botschaften.
Speichern |  | [Umsch+Strg+S] | Speichert die aufgezeichneten CAN-Botschaften in eine *.TRC-Datei.
Puffergröße |  |  | Konfiguriert die Puffergröße. Die maximal einstellbare Puffergröße des Tracers beträgt 1.000.000 Botschaften.
Linearer Puffer |  |  | Konfiguriert den Tracer so, dass er mit einem linearen Puffer arbeitet. Wenn der Puffer komplett gefüllt ist, wird die Aufzeichnung gestoppt.
Ringpuffer |  |  | Konfiguriert den Tracer so, dass er als Ringpuffer arbeitet. Wenn der Puffer voll ist, wird die älteste Botschaft überschrieben, wenn eine neue Botschaft aufgezeichnet wird.
Daten-Frames loggen |  |  | Diese Option legt fest, ob Daten-Frames aufgezeichnet werden sollen.
RTR-Frames loggen |  |  | Diese Option legt fest, ob Remote Transmission Requests aufgezeichnet werden sollen.
Statusänderungen loggen |  |  | Diese Option legt fest, ob Änderungen des Hardware-Status aufgezeichnet werden sollen.
Error Frames loggen |  |  | Diese Option legt fest, ob Error Frames aufgezeichnet werden sollen.
Änderungen von Fehlerzählern loggen |  |  | Diese Option legt fest, ob Änderungen an Fehlerzählern aufgezeichnet werden sollen.
Ereignisse loggen |  |  | Diese Option legt fest, ob Ereignisse aufgezeichnet werden sollen. Ereignisse treten auf wenn z.B. Plug-and-Play CAN-Hardware eingesteckt oder abgezogen wird.

Fenster

Befehl | Symbol | Tasten-Kombination | Beschreibung
Immer im Vordergrund |  | [Strg+I] | Zeigt das PCAN-View-Anwendungsfenster im Vordergrund vor allen anderen Fenstern an.
Fenster schwebend |  |  | Dockt die aktive Registerseite vom Hauptfenster ab und zeigt sie als schwebendes Fenster. Dieser Befehl ist für die Registerseiten Trace, Fehler-Generator und Buslast verfügbar.

Hilfe

Befehl | Symbol | Tasten-Kombination | Beschreibung
PCAN-View Hilfe |  | [F1] | Zeigt das Inhaltsverzeichnis der Online-Hilfe an.
Dateiformat-Spezifikation für CAN-Trace-Dateien |  |  | Öffnet ein PDF-Dokument, welches das PEAK CAN TRC Dateiformat beschreibt. Ist dieser Menübefehl nicht sichtbar, wurde PCAN-View wahrscheinlich nicht über das PEAK-Drivers Setup installiert.
Gerätetreiber-Version |  |  | Zeigt Informationen über den aktuell verwendeten PCAN-Gerätetreiber an. Dieser Menübefehl ist nur dann auswählbar, wenn PCAN-View aktuell mit einer CAN-Hardware oder einem PCAN-Netz verbunden ist.
Über |  |  | Zeigt Informationen über das Programm, dessen Version und zum Copyright an.


Symbolleiste

Die Symbolleiste kann verwendet werden, um schnell auf die wichtigsten Funktionen von PCAN-View zuzugreifen.

Die folgenden Schaltflächen sind in der Symbolleiste verfügbar:

Schaltfläche | Befehl | Beschreibung | Alternativ
 | Öffnen | Öffnet eine zuvor gespeicherte Sendelisten-Datei. | [Strg+O] Datei | Öffnen...
 | Speichern | Speichert die aktuelle Sendeliste in eine Datei. | [Strg+S] Datei | Speichern
 | Verbinden | Öffnet das Verbinden-Dialogfenster, um die Anwendung mit einer CAN-Hardware oder einem PCAN-Netz zu verbinden. | [Strg+B] CAN | Verbinden...
 | Zurücksetzen | Setzt den CAN-Controller zurück, löscht die Empfangsliste und setzt die Zählerwerte in der Sendeliste auf 0. | [Esc] CAN | Zurücksetzen
 | Neue Botschaft | Öffnet das Botschaft bearbeiten-Dialogfenster, um eine neue Botschaft in die Sendeliste zu einzutragen. | [Einfg] Senden | Neue Botschaft...
 | Botschaft bearbeiten | Öffnet das Botschaft bearbeiten-Dialogfenster, um die Parameter der Botschaft zu bearbeiten, die in der Sendeliste ausgewählt ist. | [Eingabe] Senden | Botschaft bearbeiten...
 | Ausschneiden | Schneidet die Auswahl aus und legt sie in die Zwischenablage. | [Strg+X] Bearbeiten | Ausschneiden
 | Kopieren | Kopiert die ausgewählten CAN-Botschaften in die Zwischenablage. | [Strg+C] Bearbeiten | Kopieren
 | Einfügen | Fügt den Inhalt der Zwischenablage in die Sendeliste ein. | [Strg+V] Bearbeiten | Einfügen
 | Trace Start | Startet die Aufzeichnung von CAN-Botschaften. | [Strg+T] Trace | Start
 | Trace Pause | Unterbricht die Aufzeichnung von CAN-Botschaften. | Trace | Pause
 | Trace Stopp | Stoppt die Aufzeichnung von CAN-Botschaften. | [Umsch+Strg+T] Trace | Stopp
 | PCAN-View Hilfe | Zeigt das Inhaltsverzeichnis der Online-Hilfe an. | Hilfe | PCAN-View Hilfe
 | Über | Zeigt Informationen über das Programm, dessen Version und zum Copyright an. | Help | Über...

Siehe auch

Menübefehle


Statuszeile

Die Statuszeile zeigt Informationen über die aktuelle Verbindung sowie den Status der verbundenen PCAN-Hardware an, und enthält Fehlerzähler.

Status

Zeigt den Status der verbundenen PCAN-Hardware an.

Die Fehlerzähler zeigen die folgenden Werte:

Overruns

Wenn der CAN-Controller so viele Botschaften empfängt, dass nicht mehr alle ausgelösten Hardware-Interrupts verarbeitet werden können, zeigt dieser Zähler die Anzahl der verloren gegangenen Botschaften. Eine mögliche Ursache: der Computer ist zu langsam.

QXmtFulls

Wenn der Gerätetreiber nicht in der Lage war, alle Botschaften an den CAN-Controller zu übergeben, die in seine Sende-Queue geschrieben wurden, zeigt dieser Zähler die Anzahl der verloren gegangenen Botschaften. Mögliche Fehler: eine zu niedrige Bitrate, hohe Buslast, oder ein Fehler auf dem Bus. Dieser Fehler tritt mit einer Verzögerung auf, da erst die Sende-Queue komplett gefüllt sein muss, die eine Größe von 32767 Botschaften hat.


Verbinden-Dialogfenster

Nach dem Start von PCAN-View wird zunächst das Verbinden-Dialogfenster angezeigt. Um mit PCAN-View arbeiten zu können, müssen Sie zuerst eine Verbindung mit einer PCAN-Hardware herstellen, oder, falls verfügbar, mit einem PCAN-Netz.

Um das Verbinden-Dialogfenster anzuzeigen, führen Sie den Befehl Verbinden aus dem Menü CAN aus, oder klicken Sie auf die Schaltfläche [image] in der Symbolleiste.

Verfügbare PCAN-Hardware (und PCAN-Netze)

Diese Liste zeigt alle verfügbare PCAN-Hardware und PCAN-Netze, mit denen Sie eine Verbindung herstellen können. Falls mindestens ein PCAN-Netz für eine Hardware definiert wurde, können Sie den Knoten des jeweiligen Hardware-Eintrags aufklappen, um in einer Baumdarstellung die darunter liegenden PCAN-Netze auswählen zu können. Wenn interne Netze für ein PCAN-Gerät definiert wurden, wird am Anfang der Liste ein Knoten Intern angezeigt, der die internen Netze von allen Geräten gruppiert.

Hinzufügen

Die Schaltfläche Hinzufügen ist nur sichtbar, wenn mindestens ein PCAN-Gerätetreiber installiert ist, der Non-Plug-and-Play PCAN-Hardware unterstützt.

Wird die Schaltfläche angeklickt, öffnet sich das CAN-Hardware hinzufügen-Dialogfenster, das verwendet werden kann, um Non-Plug-and-Play PCAN-Hardware zur Liste Verfügbare CAN-Hardware hinzuzufügen, z.B. ein PCAN-Dongle oder eine PCAN-ISA-Karte. Non-Plug-and-Play Hardware wird vom Betriebssystem nicht automatisch erkannt, Sie müssen die Hardware manuell hinzufügen und konfigurieren.

Löschen

Diese Schaltfläche ist nur sichtbar, wenn mindestens ein PCAN-Gerätetreiber installiert ist, der Non-Plug-and-Play PCAN-Hardware unterstützt.

Sie können die Schaltfläche Löschen verwenden, um eine zuvor hinzugefügte Non-Plug-and-Play Hardware zu entfernen. Um eine solche Hardware zu löschen, wählen Sie die Hardware aus der Liste aus und klicken Sie auf Löschen. Die Schaltfläche Löschen ist nur aktiviert, wenn Sie eine Non-Plug-and-Play Hardware in der Liste auswählen.

CAN FD

Aktivieren Sie diese Option, wenn Sie CAN-FD-Botschaften senden und empfangen möchten.

Die Option können Sie nur dann ändern, wenn Sie in der Liste Verfügbare CAN-Hardware eine PCAN-Hardware auswählen, die CAN-FD-fähig ist.

Clock-Frequenz

Wählt die Clock-Frequenz aus, die als Basis der Bitrate dienen soll, mit welcher der CAN-Controller initialisiert werden soll. Die hier auswählbaren Clock-Frequenzen werden von den vordefinierten Bitraten bestimmt.

Wenn Sie in der Liste Verfügbare CAN-Hardware eine PCAN-Hardware auswählen, die mit einem SJA1000 CAN-Controller bestückt ist, ist die Clock-Frequenz fest auf 8 MHz eingestellt und kann nicht verändert werden.

Für SJA1000-basierte PCAN-Hardware

Die folgenden Steuerelemente sind nur sichtbar, wenn Sie in der Liste Verfügbare CAN-Hardware eine PCAN-Hardware auswählen, die mit einem SJA1000 CAN-Controller bestückt ist, oder wenn Sie ein PCAN-Netz auswählen, das für eine solche Hardware definiert ist:

Bitrate

Diese Dropdownliste bietet verschiedene Übertragungsraten zur Auswahl.

Haben Sie in der Liste Verfügbare CAN-Hardware ein PCAN-Netz ausgewählt, ist die Dropdownliste nicht änderbar, da die Bitrate hier vom ausgewählten Netz bestimmt wird.

Bus Timing Register

Dieses Feld zeigt den Wert des SJA1000 Bus Timing Registers (BTR0 / BTR1) der in der Dropdownliste Bitrate ausgewählten Bitrate, in hexadezimaler Schreibweise.

Für CAN-FD-fähige PCAN-Hardware

Die folgenden Steuerelemente sind nur sichtbar, wenn Sie in der Liste Verfügbare CAN-Hardware eine PCAN-Hardware auswählen, die CAN-FD-fähig ist, oder wenn Sie ein PCAN-Netz auswählen, das für eine solche Hardware definiert ist:

Nominal-Bitrate

Wählt die Nominal-Bitrate des CAN-FD-Busses aus.

Haben Sie in der Liste Verfügbare CAN-Hardware ein PCAN-Netz ausgewählt, ist die Dropdownliste nicht änderbar, da die Bitrate hier vom ausgewählten Netz bestimmt wird.

Daten-Bitrate

Wenn die Option CAN FD aktiviert ist, können Sie über diese Option eine zusätzliche Daten-Bitrate für den CAN-FD-Bus auswählen. Diese separate Bitrate bestimmt die höhere Übertragungsgeschwindigkeit für die Datenfelder eines CAN-FD-Frames. Die höhere Bitrate wird auf solche CAN-FD-Botschaften angewendet, bei denen das Flag "Bit Rate Switch" gesetzt ist.

Haben Sie in der Liste Verfügbare CAN-Hardware ein PCAN-Netz ausgewählt, ist die Dropdownliste nicht änderbar, da die Bitrate hier vom ausgewählten Netz bestimmt wird.

Filtereinstellungen

Standard/Extended

Diese Optionen wählen eine Filterkonfiguration für Standard Frames (11-Bit CAN-Identifier) oder Extended Frames (29-Bit CAN-Identifier).

Von/Bis

Diese Felder ermöglichen es, den kleinsten und den größten CAN-Identifier vorzugeben, die den Akzeptanzfilter von PCAN-View passieren dürfen. Wenn Sie die Option Standard wählen, können Sie einen maximalen ID-Bereich von 0 bis 7FFh eingeben. Wenn Sie die Option Extended wählen, sind IDs von 0 bis 1FFFFFFFh erlaubt. Die Standardeinstellung des Filters ermöglicht es, alle CAN-Botschaften auf dem Bus zu empfangen.

Andere Einstellungen und Befehle

Listen-Only Modus

Aktiviert den Listen-Only Modus der CAN-Hardware. In diesem Modus quittiert der CAN-Controller keine empfangenen CAN-Frames auf dem Bus, so dass dieser Modus ideal geeignet ist, ein CAN-Netzwerk passiv zu überwachen.

Bitraten verwalten (über Schaltfläche [image] auswählbar)

Zeigt ein Dialogfenster an, mit dessen Hilfe Sie eigene Bitraten definieren oder die vorhandenen Bitraten anpassen können.

In Zwischenablage kopieren (über Schaltfläche [image] auswählbar)

Kopiert die vollständige Definition der Bitrate als Text in die Windows-Zwischenablage. Beispiel:

"f_clock=20000000, nom_brp=5, nom_tseg1=2, nom_tseg2=1, nom_sjw=1, data_brp=2, data_tseg1=3, data_tseg2=1, data_sjw=1"

Siehe auch

CAN-Hardware hinzufügen-Dialogfenster


CAN-Hardware hinzufügen-Dialogfenster

Dieses Dialogfenster kann verwendet werden, um Non-Plug-and-Play CAN-Hardware zum Verbinden-Dialogfenster hinzuzufügen.

Um das CAN-Hardware hinzufügen-Dialogfenster anzuzeigen, klicken Sie auf die Schaltfläche Hinzufügen im Verbinden-Dialogfenster. Die Schaltfläche Hinzufügen ist nur verfügbar, wenn ein PCAN-Gerätetreiber installiert ist, der Non-Plug-And-Play PCAN-Hardware unterstützt.

Gerät

Diese Dropdownliste zeigt alle installierten Geräte an, die Non-Plug-and-Play PCAN-Hardware unterstützen. Mögliche Geräte sind: Peakcan, ISA oder Dongle.

Typ der CAN-Hardware

Wurde ein Gerät aus der Dropdownliste Gerät ausgewählt, zeigt diese Liste die Typen der PCAN-Hardware an, die von dem Gerät unterstützt wird.

Beschreibung

Dieses Feld zeigt eine kurze Beschreibung des ausgewählten Hardware-Typs an.

E/A-Adresse

Wählt die E/A-Adresse aus, welche die neue Hardware verwendet.

Interrupt

Wählt den Interrupt aus, den die neue Hardware verwendet.

Um CAN-Hardware manuell hinzuzufügen, wählen Sie den Typ der Hardware in der Liste, wählen Sie E/A-Adresse und Interrupt-Ressourcen, die von der Hardware verwendet werden, und drücken Sie OK. Wurde die gewählte Hardware unter Verwendung der angegebenen Ressourcen gefunden, wird sie zur Liste der installierten CAN-Hardware hinzugefügt. Andernfalls wird eine Fehlermeldung angezeigt.

Siehe auch

Verbinden-Dialogfenster


Botschaft bearbeiten-Dialogfenster

Das Botschaft bearbeiten-Dialogfenster kann verwendet werden, um die Parameter einer CAN-Botschaft in der Sendeliste zu bearbeiten.

Um das Botschaft bearbeiten-Dialogfenster anzuzeigen und eine neue Sendebotschaft anzulegen, wählen Sie den Befehl Neue Botschaft im Menü Senden, oder klicken Sie auf die Schaltfläche [image] in der Symbolleiste. Um die Parameter einer ausgewählten Sendebotschaft zu verändern, öffnen Sie das Botschaft bearbeiten-Dialogfenster, indem Sie im Menü Senden den Befehl Botschaft bearbeiten auswählen, oder indem Sie die Schaltfläche [image] in der Symbolleiste anklicken.

ID

Dies ist der CAN-Identifier (hexadezimales Format) der Botschaft.

DLC

Dieses Feld bestimmt den Datenlängencode der CAN-Botschaft. Dies ist die Anzahl der Datenbytes der Botschaft (0 bis 8). Falls die Botschaft ein Remote Transmission Request (RTR) ist, legt dieser Wert die Anzahl der angeforderten Datenbytes fest.

Daten

Die Datenbytes der Botschaft in hexadezimaler Form.

Wird die Schaltfläche ... hinter den Datenbyte-Feldern gedrückt, wird das Dialogfenster Daten bearbeiten angezeigt, in dem man die Datenbytes der Botschaft mit Hilfe eines Hex-Editors bearbeiten kann. Dies ist speziell dann nützlich, wenn man mit CAN-FD-Botschaften arbeitet, die bis zu 64 Datenbytes besitzen können.

Zykluszeit

Die Länge des Zeitintervalls (in Millisekunden) für zyklisches Senden. Falls die Botschaft manuell gesendet werden soll, oder nur als Antwort auf empfangene Remote Request Frames, geben Sie den Wert '0' ein.

Angehalten

Wenn Sie diese Option auswählen, und im Feld Zykluszeit einen Wert größer als 0 eingeben, wird das periodische Senden der Botschaft unterbrochen. Wenn Sie die Option löschen, wird das periodische Senden der Botschaft fortgesetzt, sobald Sie das Dialogfenster durch Drücken von OK schließen..

Kommentar

Ein beliebiger Text, der die Botschaft kommentiert.

Botschafts-Typ

Extended Frame

Diese Option muss aktiviert werden, wenn ein Extended Frame erzeugt werden soll. Extended Frames sind CAN-Botschaften, die einen 29-Bit CAN-Identifier gemäß CAN-Spezifikation 2.0B besitzen.

Remote Request

Diese Option muss aktiviert werden, wenn ein Remote Transmission Request erzeugt werden soll. In diesem Fall werden die Felder zur Eingabe der Datenbytes verborgen.

CAN FD

Definiert die CAN-Botschaft als CAN-FD-Botschaft. Eine CAN-FD-Botschaft kann bis zu 64 Datenbytes haben.

Dieser Botschafts-Typ ist nur verfügbar, wenn eine Verbindung mit einer CAN-FD-fähigen PCAN-Hardware besteht.

Bit Rate Switch

Setzt für eine CAN-FD-Botschaft das "Bit Rate Switch" Flag. Wurde beim Herstellen der CAN-Verbindung eine separate Daten-Bitrate aktiviert, werden für CAN-FD-Botschaften mit gesetztem Bit Rate Switch die Datenfelder des CAN-Frames mit dieser höheren Bitrate übertragen.

Dieser Botschafts-Typ ist nur verfügbar, wenn eine Verbindung mit einer CAN-FD-fähigen PCAN-Hardware besteht.

Siehe auch

Bearbeiten der Sendeliste

Senden von CAN-Botschaften

Daten bearbeiten-Dialogfenster

Verbinden-Dialogfenster


Daten bearbeiten-Dialogfenster

Verwenden Sie das Daten bearbeiten-Dialogfenster, um die Rohdaten einer Botschaft zu verändern.

Um das Daten bearbeiten-Dialogfenster anzuzeigen, klicken Sie auf die Schaltfläche ... hinter den Datenbyte-Eingabefeldern im Botschaft bearbeiten-Dialogfenster.

Lädt Daten aus einer Datei.

Speichert die Daten in eine Datei.

Setzt alle Datenbytes zu Null.

(Hex-Editor)

Im Hex-Editor können Sie die Datenbytes einer Botschaft verändern indem Sie Hex-Werte oder Zeichen eingeben. Durch Drücken von [Tab] auf der Tastatur können Sie die Einfügemarke zwischen dem Bereich für die Hex-Daten links und der ASCII-Interpretation der Daten auf der rechten Seite bewegen. Dort können Sie Zeichen anstatt von Hex-Codes eingeben. Wenn der Hex-Editor den Eingabefokus besitzt, können Sie [Strg+Tab] oder [Umsch+Strg+Tab] drücken, um den Eingabefokus zu einem anderen Steuerelement des Dialogfensters zu bewegen.

Der Hex-Editor kann mit Hilfe seines Kontextmenüs angepasst werden. Sie können sowohl die Anzahl der angezeigten Datenbytes pro Zeile auswählen (8, 10 oder 16) als auch die Anzahl der Datenbytes pro Spalte (1, 2 oder 4).

Siehe auch

Botschaft bearbeiten-Dialogfenster


Senden/Empfangen-Registerseite

Die Senden/Empfangen-Registerseite ist das zentrale Element von PCAN-View. Sie enthält die Empfangsliste und die Sendeliste.

Beide Listen sind an der linken Seite des Fensters vertikal beschriftet (Empfangen und Senden). Die Empfangsliste zeigt alle CAN-Botschaften an, die von PCAN-View empfangen werden, und die Sendeliste enthält CAN-Botschaften, die von PCAN-View gesendet werden.

Die Höhen der Listen auf der Senden/Empfangen-Registerseite kann verändert werden, indem der horizontale Trennbalken zwischen den Listen mit der Maus gezogen wird.

Eine der beiden Listen kann auch maximiert werden, so dass sie den ganzen Raum der Senden/Empfangen-Registerseite einnimmt.

Schaltflächen-Symbol | Beschreibung
 | Maximiert die entsprechende Liste. Alternativ kann die Taste [+] auf der Tastatur gedrückt werden, während eine Liste den Eingabefokus besitzt.
 | Stellt die ursprüngliche Aufteilung der Empfangs- und Sendeliste wieder her. Alternativ kann die Taste [-] auf der Tastatur gedrückt werden.

Der Eingabefokus kann zwischen den beiden Listen gewechselt werden, indem die Taste [Tab] gedrückt wird.

Innerhalb der Botschafts-Listen können Sie mit den Pfeiltasten [Nach oben] und [Nach unten] navigieren. Um mehr als eine Botschaft zu selektieren, halten Sie die Taste [Umsch] gedrückt und bewegen Sie die Selektionsmarke entweder mit den Pfeiltasten oder durch Klicken mit der Maus.

Siehe auch

Empfangen von CAN-Botschaften

Senden von CAN-Botschaften

Bearbeiten der Sendeliste


Empfangsliste

Die Empfangsliste zeigt die empfangenen CAN-Botschaften an.

Spalten

Die Empfangsliste hat die folgenden Spalten:

CAN-ID

CAN-Identifier der Botschaft in hexadezimaler Form. 0 bis 7FFh für 11-Bit Identifier, 0 bis 1FFFFFFFh für 29-Bit Identifier (nach CAN-Spezifikation 2.0B).

Typ

Typ der CAN-Botschaft. Die verschiedenen Typen werden durch farbige Indikatoren und Kürzel kenntlich gemacht.

Die folgende Indikatoren können angezeigt werden:

Typ | Beschreibung
Keine Anzeige | 11- oder 29-Bit Datenbotschaft
 | Remote Request Frame
 | CAN FD Botschaft
 | CAN FD Botschaft mit gesetztem Bit Rate Switch
oder | CAN FD Botschaft mit gesetztem Error State Indicator, d.h. der Sender der Botschaft befand sich im Zustand "Error Passive"

DLC

Datenlängencode der Botschaft (CAN: 0 bis 8, CAN FD: 0 bis 15).

Länge

Die Anzahl der Datenbytes der Botschaft. Herkömmliche CAN-Botschaften können eine Länge zwischen 0 und 8 Datenbytes haben.

Bei CAN FD beträgt die maximale Länge 64 Datenbytes, wobei der folgende Zusammenhang zwischen DLC und Länge gilt:

DLC | Länge
<= 8 | = DLC
9 | 12
10 | 16
11 | 20
12 | 24
13 | 32
14 | 48
15 | 64

Daten

Werte der Datenbytes der Botschaft in hexadezimaler Form, oder der Text "Remote Request", falls ein Remote Request Frame empfangen wurde.

Zykluszeit

Zeitintervall zwischen den letzen beiden empfangenen Botschaften dieser ID, in Millisekunden.

Anzahl

Anzahl der empfangenen Botschaften seit dem letzten Zurücksetzen (drücken von [Esc] auf der Tastatur führt ein Hardware-Reset durch und setzt die Zähler der Botschaften zurück).

Sortierung

Sie können die Empfangsliste sortieren, indem Sie mit der Maus eine der Spaltenüberschriften anklicken (Ausnahme: Typ-Spalte). Ein nochmaliger Klick auf die Spaltenüberschrift wechselt die Sortierrichtung zwischen aufsteigender und absteigender Sortierung. Ein Pfeil in der Spaltenüberschrift zeigt an, nach welcher Spalte aktuell sortiert wird, und gibt Auskunft über die Sortierrichtung.

Die Sortierung nach Spalten wie Daten, Zykluszeit oder auch Anzahl bedeutet nicht, dass die Reihenfolge der Nachrichten in der Liste ständig an die aktuellen Werte angepasst wird. Bei Spalten, deren Inhalt sich schnell ändern kann, führt nur der Klick in die Spaltenüberschrift zu einem Neusortieren der Liste.

Siehe auch

Sendeliste

Senden/Empfangen-Registerseite


Sendeliste

Die Sendeliste enthält Botschaften, die von PCAN-View gesendet werden können. Die Sendeliste kann mehrere identische CAN-Botschaften enthalten.

Spalten

Die Sendeliste hat die folgenden Spalten:

CAN-ID

CAN-Identifier der Botschaft in hexadezimaler Form. 0 bis 7FFh für 11-Bit Identifier, 0 bis 1FFFFFFFh für 29-Bit Identifier (nach CAN-Spezifikation 2.0B).

Typ

Typ der CAN-Botschaft. Die verschiedenen Typen werden durch farbige Indikatoren und Kürzel kenntlich gemacht.

Die folgende Indikatoren können angezeigt werden:

Typ | Beschreibung
Keine Anzeige | 11- oder 29-Bit Datenbotschaft
 | Remote Request Frame
 | CAN FD Botschaft
 | CAN FD Botschaft mit gesetztem Bit Rate Switch

DLC

Datenlängencode der Botschaft (CAN: 0 bis 8, CAN FD: 0 bis 15).

Länge

Die Anzahl der Datenbytes der Botschaft. Herkömmliche CAN-Botschaften können eine Länge zwischen 0 und 8 Datenbytes haben.

Bei CAN FD beträgt die maximale Länge 64 Datenbytes, wobei der folgende Zusammenhang zwischen DLC und Länge gilt:

DLC | Länge
<= 8 | = DLC
9 | 12
10 | 16
11 | 20
12 | 24
13 | 32
14 | 48
15 | 64

Daten

Werte der Datenbytes der Botschaft in hexadezimaler Form, oder der Text "Remote Request", falls die Botschaft einen Remote Transmission Request (RTR) darstellt.

Zykluszeit

Das Zeitintervall, in dem die Botschaft zyklisch gesendet wird, in Millisekunden. Wurde die Zykluszeit der Botschaft auf 0 gesetzt, wird der Text "Warte" angezeigt. In diesem Fall muss die Botschaft manuell gesendet werden, oder wird automatisch als Antwort auf einen empfangenen Remote Request Frame gesendet, der eine passende CAN-ID hat.

Anzahl

Die Anzahl der gesendeten Botschaften seit dem letzen Zurücksetzen (drücken von [Esc] auf der Tastatur führt ein Hardware-Reset durch und setzt die Zähler der Botschaften zurück.

Trigger

Grund der letzten Sendung der Botschaft. Mögliche Auslöser sind:

  • Manuell: Die Botschaft wurde vom Benutzer manuell gesendet.

  • Zeit: Die Botschaft wird zyklisch gesendet.

  • RTR: Die Botschaft wurde als Antwort auf einen empfangenen Remote Transmission Request gesendet.

Kommentar

Der Kommentar, der für die Botschaft vorgegeben wurde.

Um eine neue Sendebotschaft zu erzeugen, siehe Bearbeiten der Sendeliste

Sortierung

Sie können die Sendeliste sortieren, indem Sie mit der Maus eine der Spaltenüberschriften anklicken (Ausnahme: Typ-Spalte). Ein nochmaliger Klick auf die Spaltenüberschrift wechselt die Sortierrichtung zwischen aufsteigender und absteigender Sortierung. Ein Pfeil in der Spaltenüberschrift zeigt an, nach welcher Spalte aktuell sortiert wird, und gibt Auskunft über die Sortierrichtung.

Die Sortierung nach Spalten wie Anzahl bedeutet nicht, dass die Reihenfolge der Nachrichten in der Liste ständig an die aktuellen Werte angepasst wird. Bei Spalten, deren Inhalt sich schnell ändern kann, führt nur der Klick in die Spaltenüberschrift zu einem Neusortieren der Liste.

Mit Hilfe der Tastenkombinationen [Strg+Pfeil-rauf] sowie [Strg+Pfeil-runter] können Sie eine oder mehrere ausgewählte Botschaften in der Liste an eine andere Position bewegen, wodurch eine manuelle Sortierung der Liste begonnen wird. Wenn Sie anschließend wieder auf eine der Spaltenüberschriften klicken, fragt PCAN-View zunächst nach, bevor diese manuelle Sortierung wieder aufgehoben wird.

Siehe auch

Empfangsliste

Senden/Empfangen-Registerseite


Trace-Registerseite

Auf der Trace-Registerseite kann der Inhalt und der Status des Trace-Puffers untersucht werden.

Statuszeile

Am oberen Rand der Registerseite befindet sich eine Statuszeile mit mehreren Feldern, die detaillierte Informationen über den Betriebsmodus des Tracers und den Inhalt des Puffers anzeigen. Die Felder der Statuszeile sind, von links nach rechts:

  • Betriebsmodus
    Zeigt an, ob die Aufzeichnung angehalten, gestartet oder unterbrochen wurde.

  • Aufnahmedauer
    Zeigt die Zeitdauer zwischen dem Start der Aufzeichnung und dem Zeitpunkt letzten aufgezeichneten Botschaft an.

  • Füllstand
    Der aktuelle Füllstand des Puffers in Prozent.

  • Puffertyp
    Zeigt an, ob der Datenpuffer als linearer Puffer oder als Ringpuffer konfiguriert wurde. Sie können den Puffertyp einfach umschalten, indem Sie mit der Maus einen Doppelklick auf dem Feld ausführen.

  • Empfangene Botschaften
    Die Anzahl der im Puffer enthaltenen empfangenen Botschaften.

  • Gesendete Botschaften
    Die Anzahl der im Puffer enthaltenen gesendeten Botschaften.

  • Statusänderungen
    Die Anzahl der aufgezeichneten Hardware-Statusänderungen.

  • Fehler
    Die Anzahl der aufgezeichneten Error Frames.

  • Andere
    Die Anzahl von aufgezeichneten Ereignisse und Änderungen von Fehlerzählern.

Spalten in der Trace-Liste

Zeit

Die Zeit in Sekunden, die seit dem Start der Aufzeichnung vergangen ist, mit einer Auflösung von 1/10 Millisekunde.

Typ

Der Typ der Botschaft. Die folgenden Typen sind möglich:

  • Daten
    Ein Daten-Frame.

  • RTR
    Ein Remote Transmission Request.

  • Status
    Ein Hardware-Status.

  • Fehler
    Ein Error Frame. Error Frames können sein: Bit-Fehler, Form-Fehler, Stuff-Fehler, oder "Anderer" Fehler.
    Für eine Beschreibung der verschiedenen Busfehler, siehe NXP (vormals Philips) Application Note AN97076, "SJA1000 Stand-alone CAN controller", Abschnitt 5.2.3.

  • Fehlerzähler
    Der Wert einer der Fehlerzähler im CAN-Controller hat sich geändert.

  • Ereignis
    Zeigt Plug-In/Out-Ereignisse der Hardware an.

ID

Die CAN-ID der Botschaft. 11-Bit CAN-IDs werden mit 3 Stellen angezeigt, 29-Bit CAN-IDs werden mit 8 Stellen angezeigt.

DLC

Der Datenlängencode der Botschaft (CAN: 0-8, CAN FD: 0-15).

Daten

Die Datenbytes der aufgezeichneten Botschaft.

Falls die Botschaft einen Remote Request Frame repräsentiert, wird der Text Remote Request angezeigt.

Falls die Botschaft einen Error Frame darstellt, werden hier zusätzliche Informationen über den Error Frame angezeigt. RxErr und TxErr-Werte zeigen die Inhalte von Empfangs- und Sende-Fehlerzählern des CAN-Controllers.

Siehe auch

Aufzeichnen von CAN-Botschaften


Buslast-Registerseite

Die Buslast-Registerseite zeigt die aktuelle Buslast auf dem verbundenen CAN-Bus an, und sie enthält einige statistische Informationen bezüglich der Buslast.

Die Buslast-Registerseite ist nur verfügbar, wenn PCAN-View mit einem PCAN-USB Pro, PCAN-USB FD oder PCAN-USB Pro FD Adapter verbunden ist.

Buslastmessung aktivieren

Ermöglicht das Ein- oder Ausschalten der Buslastmessung. Standardmäßig ist die Buslastmessung aktiviert.

Buslast

Zeigt die aktuelle Buslast in Prozent.

Buslast-Historie

Eine grafische Anzeige, die den Verlauf der Buslast über der Zeit anzeigt.

Statistik

Diese statistischen Daten zeigen die minimale und maximale Buslast, sowie den arithmetischen Mittelwert der Buslast.

Zurücksetzen

Setzt die statistischen Werte zurück.


Fehler-Generator-Registerseite

Die Fehler-Generator-Registerseite kann verwendet werden, um Error Frames auf dem verbundenen CAN-Bus zu erzeugen.

Die Fehler-Generator-Registerseite ist nur verfügbar, wenn PCAN-View mit einer PCAN-Hardware verbunden ist, welche die Erzeugung von Error Frames unterstützt, wie PCAN-USB Pro und alle CAN-FD-fähigen USB/PCI PC-Interfaces.

Einzelnen Frame zerstören

Sie können diese Funktion verwenden, um einzelne Frames auf dem Bus zu zerstören.

Bit-Position

Legt die Bit-Position innerhalb des CAN-Frames fest, an welcher der Fehler erzeugt werden soll.

Jetzt

Wenn Sie diese Schaltfläche anklicken, wird der nächste empfangene oder gesendete CAN-Frame an der ausgewählten Bit-Position zerstört.

Mehrere Frames zerstören

Sie können diese Funktion verwenden, um wiederholt CAN-Frames mit einer bestimmten CAN-ID zu zerstören.

CAN-ID

Legt die ID des CAN-Frames fest, den Sie zerstören möchten.

Bit-Position

Bestimmt die Bit-Position innerhalb des CAN-Frames, wo der Fehler erzeugt werden soll.

Anzahl zu ignorierender Frames

Bestimmt die Anzahl der aufeinanderfolgenden CAN-Frames, die ignoriert werden sollen, bevor ein Frame zerstört wird.

Anzahl zu zerstörender Frames

Bestimmt die Anzahl von aufeinanderfolgenden CAN-Frames, die zerstört werden sollen.

Anwenden

Aktiviert den Fehler-Generator mit den angegebenen Parametern.

Deaktivieren

Deaktiviert den Fehler-Generator.

Hinweis

Wird der Befehl Zurücksetzen aus dem Menü CAN ausgeführt, wird der Fehler-Generator auch automatisch deaktivert.


Hardware-Status

Der Status einer PCAN-Hardware wird einerseits in der Statuszeile des Hauptfensters angezeigt, oder in der Trace-Liste auf der Trace-Registerseite.

Die folgenden Tabellen beschreiben die Statusanzeigen, die in Abhängigkeit der verwendeten CAN-Hardware und der jeweils installierten PCAN-Treiber auftreten können.

Die folgenden Statusanzeigen können auftreten, wenn für die verwendete CAN-Hardware ein PCAN-Treiber mit einer Versionsnummer von 4 oder neuer installiert ist, und eine Verbindung zu einer anderen CAN-Hardware als zu einem PCAN-USB, PCAN-USB Pro oder PCAN-USB Hub besteht:

Status Beschreibung

OK

Der CAN-Controller befindet sich im Zustand "Error Active", d.h. alle Fehlerzähler befinden sich unterhalb des Schwellwerts 128.

Error Passive

Der CAN-Controller befindet sich im Zustand "Error Passive", d.h. mindestens ein Fehlerzähler erreichte den Schwellwert 128.

Mögliche Ursachen: eine Hardware ist nicht korrekt mit dem CAN-Bus verbunden, oder es wurde eine falsche Bitrate gewählt.

Warnung

Einer der Fehlerzähler erreichte den Schwellwert für "Error Warning Limit", der per Voreinstellung bei 96 liegt.

Bus-Off

Der CAN-Controller ist im Zustand "Bus-Off", weil ein fortwährender Fehler auf dem Bus existiert (255 Fehlerpunkte wurden überschritten).

Ein möglicher Fehler kann ein Kurzschluss der Busleitungen sein.

OVERRUN

Der CAN-Controller empfängt so viele Botschaften, dass nicht mehr alle ausgelösten Hardware-Interrupts verarbeitet werden können.

QOVERRUN

Die Empfangs-Queue ist voll.

Die interne Verarbeitungsgeschwindigkeit der Anwendung ist nicht hoch genug, um alle Botschaften zu verarbeiten, die vom Gerätetreiber in die Empfangs-Queue der Anwendung geschrieben wurden.

QXMTFULL

Die Sende-Queue ist voll.

Der Gerätetreiber ist nicht in der Lage, alle Botschaften an den CAN-Controller zu übergeben, die in seine Sende-Queue geschrieben wurden. Mögliche Fehler: eine zu niedrige Bitrate, hohe Buslast, oder ein Fehler auf dem Bus. Dieser Fehler tritt mit einer Verzögerung auf, da erst die Sende-Queue komplett gefüllt sein muss, die eine Größe von 32767 Botschaften hat.

Die folgenden Statusanzeigen können auftreten, wenn für die verwendete CAN-Hardware ein PCAN-Treiber mit einer Versionsnummer kleiner als 4 installiert ist, oder wenn eine Verbindung zu einem PCAN-USB, PCAN-USB Pro oder PCAN-USB Hub besteht:

Status Beschreibung

BUSLIGHT

Busfehler: einer der Fehlerzähler des CAN-Controllers erreichte den Schwellwert "Light" (mehr als 0 Fehlerpunkte).

BUSHEAVY

Busfehler: eienr der Fehlerzähler des CAN-Controllers erreichte den Schwellwert "Heavy" (mindestens 96 Fehlerpunkte).

Mögliche Ursachen: eine Hardware ist nicht korrekt mit dem CAN-Bus verbunden, oder es wurde eine falsche Bitrate gewählt.

BUSOFF

Der CAN-Controller ist im Zustand "Bus-Off", weil ein fortwährender Fehler auf dem Bus existiert (255 Fehlerpunkte wurden überschritten).

Ein möglicher Fehler kann ein Kurzschluss der Busleitungen sein.

OVERRUN

Der CAN-Controller empfängt so viele Botschaften, dass nicht mehr alle ausgelösten Hardware-Interrupts verarbeitet werden können.

QOVERRUN

Die Empfangs-Queue ist voll.

Die interne Verarbeitungsgeschwindigkeit der Anwendung ist nicht hoch genug, um alle Botschaften zu verarbeiten, die vom Gerätetreiber in die Empfangs-Queue der Anwendung geschrieben wurden.

QXMTFULL

Die Sende-Queue ist voll.

Der Gerätetreiber ist nicht in der Lage, alle Botschaften an den CAN-Controller zu übergeben, die in seine Sende-Queue geschrieben wurden. Mögliche Fehler: eine zu niedrige Bitrate, hohe Buslast, oder ein Fehler auf dem Bus. Dieser Fehler tritt mit einer Verzögerung auf, da erst die Sende-Queue komplett gefüllt sein muss, die eine Größe von 32767 Botschaften hat.


PCAN-Chip-USB-Registerseite

Sie können die PCAN-Chip-USB-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID einer PCAN-Chip-USB-Hardware zu setzen.

Firmware-Version

Zeigt die Firmware-Version der PCAN-Chip-USB-Hardware an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-Chip-USB-Hardware geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die auf der PCAN-Chip-USB-Hardware vorhanden sind.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher einer PCAN-Chip-USB-Hardware gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als eine PCAN-Chip-USB-Hardware zur selben Zeit im Computer vorhanden ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einer PCAN-Chip-USB-Hardware zu speichern.


PCAN-Dongle-Registerseite

Sie können die PCAN-Dongle-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-Dongle geladen ist.

E/A-Adresse

Zeigt die E/A-Adresse an, über welche der Gerätetreiber mit dem PCAN-Dongle kommuniziert.

Interrupt

Zeigt die Interrupt-Nummer an, die dem PCAN-Dongle zugewiesen wurde.


PCAN-ExpressCard 34-Registerseite

Sie können die PCAN-ExpressCard 34-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-ExpressCard 34 geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-ExpressCard 34 unterstützt.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.


PCAN-ExpressCard-Registerseite

Sie können die PCAN-ExpressCard-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um den 5V-Ausgang an Pin 1 des CAN-Anschlusses einer PCAN-ExpressCard zu aktivieren oder zu deaktivieren.

Firmware-Version

Zeigt die Firmware-Version der PCAN-ExpressCard an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-ExpressCard geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-ExpressCard unterstützt.

Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

5V-Ausgang am CAN-Anschluss

Zeigt an, ob der 5V-Ausgang an Pin 1 des CAN-Anschlusses zur Zeit aktiviert ist.

Aktivieren / Deaktivieren

Drücken Sie diese Schaltfläche, um den 5V-Ausgang an Pin 1 des CAN-Anschlusses zu aktivieren oder zu deaktivieren.

Hinweis

Für mehr Information über den 5V-Ausgang, siehe PCAN-ExpressCard Benutzerhandbuch Kapitel 3.2.


PCAN-ISA-Registerseite

Sie können die PCAN-ISA-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-ISA-Karte geladen ist.

E/A-Adresse

Zeigt die E/A-Adresse an, über welche der Gerätetreiber mit der PCAN-ISA-Karte kommuniziert.

Interrupt

Zeigt die Interrupt-Nummer an, die der PCAN-ISA-Karte zugewiesen wurde.


PCAN-M.2-Registerseite

Sie können die PCAN-M.2-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID einer PCAN-M.2-Karte zu setzen.

Firmware-Version

Zeigt die Version des FPGA-Designs der PCAN-M.2-Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-M.2-Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-M.2-Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Hardware-Revision

Zeigt die Hardware-Revisionsnummer der PCAN-M.2-Karte an.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher einer PCAN-M.2-Karte gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation einer bestimmten Karte leichter zu machen, falls mehr als eine PCAN-M.2-Karte zur selben Zeit im Computer eingesteckt ist.

Anzeige und Setzen einer Geräte-ID ist nur verfügbar, wenn der installierte Gerätetreiber und die verwendete Firmware dieses Feature unterstützen.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einer PCAN-M.2-Karte zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller der PCAN-M.2-Karte gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus der PCAN-M.2-Karte zu deaktiveren oder wieder zu aktivieren.


PCAN-miniPCIe FD-Registerseite

Sie können die PCAN-miniPCIe FD-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID einer PCAN-miniPCIe FD Karte zu setzen.

Firmware-Version

Zeigt die Version des FPGA-Designs der PCAN-miniPCIe FD Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-miniPCIe FD Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-miniPCIe FD Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Hardware-Revision

Zeigt die Hardware-Revisionsnummer der PCAN-miniPCIe FD Karte an.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher einer PCAN-miniPCIe FD Karte gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation einer bestimmten Karte leichter zu machen, falls mehr als eine PCAN-miniPCIe FD Karte zur selben Zeit im Computer eingesteckt ist.

Anzeige und Setzen einer Geräte-ID ist nur verfügbar, wenn der installierte Gerätetreiber und die verwendete Firmware dieses Feature unterstützen.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einer PCAN-miniPCIe FD Karte zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller der PCAN-miniPCIe FD Karte gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus der PCAN-miniPCIe FD Karte zu deaktiveren oder wieder zu aktivieren.


PCAN-PC Card-Registerseite

Sie können die PCAN-PC Card-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, um den 5V-Ausgang an Pin 1 des CAN-Anschlusses einer PCAN-PC Card zu aktivieren oder zu deaktivieren.

Firmware-Version

Zeigt die Firmware-Version der PCAN-PC Card an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-PC Card geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-PC Card unterstützt.

Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

5V-Ausgang am CAN-Anschluss

Zeigt an, ob der 5V-Ausgang an Pin 1 des CAN-Anschlusses zur Zeit aktiviert ist.

Aktivieren / Deaktivieren

Drücken Sie diese Schaltfläche, um den 5V-Ausgang an Pin 1 des CAN-Anschlusses zu aktivieren oder zu deaktivieren.

Hinweis

Für mehr Information über den 5V-Ausgang, siehe PCAN-PC Card Benutzerhandbuch Kapitel 2.3.


PCAN-PCI Express FD-Registerseite

Sie können die PCAN-PCI Express FD-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID einer PCAN-PCI Express FD Karte zu setzen.

Firmware-Version

Zeigt die Version des FPGA-Designs der PCAN-PCI Express FD Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-PCI Express FD Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-PCI Express FD Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Hardware-Revision

Zeigt die Hardware-Revisionsnummer der PCAN-PCI Express FD Karte an.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher einer PCAN-PCI Express FD Karte gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation einer bestimmten Karte leichter zu machen, falls mehr als eine PCAN-PCI Express FD Karte zur selben Zeit im Computer eingesteckt ist.

Anzeige und Setzen einer Geräte-ID ist nur verfügbar, wenn der installierte Gerätetreiber und die verwendete Firmware dieses Feature unterstützen.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einer PCAN-PCI Express FD Karte zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller der PCAN-PCI Express FD Karte gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus der PCAN-PCI Express FD Karte zu deaktiveren oder wieder zu aktivieren.


PCAN-PCI Express-Registerseite

Sie können die PCAN-PCI Express-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten.

Firmware-Version

Zeigt die Version des FPGA-Designs der PCAN-PCI Express Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-PCI Express Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-PCI Express Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Hardware-Revision

Zeigt die Hardware-Revisionsnummer der PCAN-PCI Express Karte an.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.


PCAN-PCI-Registerseite

Sie können die PCAN-PCI-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten.

Version

Zeigt die Version der PCAN-PCI-Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-PCI-Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-PCI-Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.


PCAN-PCI/104-Express FD-Registerseite

Sie können die PCAN-PCI/104-Express FD-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID einer PCAN-PCI/104-Express FD Karte zu setzen.

Firmware-Version

Zeigt die Version des FPGA-Designs der PCAN-PCI/104-Express FD Karte an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für die PCAN-PCI/104-Express FD Karte geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die die PCAN-PCI/104-Express FD Karte unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Hardware-Revision

Zeigt die Hardware-Revisionsnummer der PCAN-PCI/104-Express FD Karte an.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher einer PCAN-PCI/104-Express FD Karte gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation einer bestimmten Karte leichter zu machen, falls mehr als eine PCAN-PCI/104-Express FD Karte zur selben Zeit im Computer eingesteckt ist.

Anzeige und Setzen einer Geräte-ID ist nur verfügbar, wenn der installierte Gerätetreiber und die verwendete Firmware dieses Feature unterstützen.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einer PCAN-PCI/104-Express FD Karte zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller der PCAN-PCI/104-Express FD Karte gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus der PCAN-PCI/104-Express FD Karte zu deaktiveren oder wieder zu aktivieren.


PCAN-USB FD-Registerseite

Sie können die PCAN-USB FD-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID eines PCAN-USB FD Adapters zu setzen.

Firmware-Version

Zeigt die Firmware-Version des PCAN-USB FD Adapters an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB FD Adapter geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB FD Adapter unterstützt.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher eines PCAN-USB FD Adapters gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB FD Adapter zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB FD Adapter zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller des PCAN-USB FD Adapters gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus des PCAN-USB FD Adapters zu deaktiveren oder wieder zu aktivieren.


PCAN-USB Hub-Registerseite

Sie können die PCAN-USB Hub-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, um den PWR-OUT-Ausgang an Pin 9 des CAN-Anschlusses einer PCAN-PC Card zu aktivieren oder zu deaktivieren.

Firmware-Version

Zeigt die Firmware-Version des PCAN-USB Hubs an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB Hub geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB Hub unterstützt.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 1 Byte langer Wert, der im Flash-Speicher eines PCAN-USB Hubs gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB Hub zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB Hub zu speichern.

PWR-OUT am CAN-Anschluss

Zeigt an, ob der PWR-OUT-Ausgang an Pin 9 des CAN-Anschlusses zur Zeit aktiviert ist.

Aktivieren / Deaktivieren

Drücken Sie diese Schaltfläche, um den PWR-OUT-Ausgang an Pin 9 des CAN-Anschlusses zu aktivieren oder zu deaktivieren.

Hinweis

PWR-OUT kann nur aktiviert werden, wenn eine externe Spannungsquelle an der Power-Buchse angeschlossen ist, und die Lötbrücke JP103 auf der Platine des PCAN-USB Hubs geschlossen ist. Für weitere Informationen siehe PCAN-USB Hub Benutzerhandbuch Kapitel 3.3.1.


PCAN-USB Pro FD-Registerseite

Sie können die PCAN-USB Pro FD-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID eines PCAN-USB Pro FD Adapters zu setzen.

Firmware-Version

Zeigt die Firmware-Version des PCAN-USB Pro FD Adapters an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB Pro FD Adapter geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB Pro FD Adapter unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher eines PCAN-USB Pro FD Adapters gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB Pro FD Adapter zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB Pro FD Adapter zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller des PCAN-USB Pro FD Adapters gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus des PCAN-USB Pro FD Adapters zu deaktiveren oder wieder zu aktivieren.


PCAN-USB Pro-Registerseite

Sie können die PCAN-USB Pro-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID eines PCAN-USB Pro Adapters zu setzen.

Firmware-Version

Zeigt die Firmware-Version des PCAN-USB Pro Adapters an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB Pro Adapter geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB Pro Adapter unterstützt.

Verwendeter Kanal

Zeigt die Nummer des Kanals an, der momentan verwendet wird.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher eines PCAN-USB Pro Adapters gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB Pro Adapter zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB Pro Adapter zu speichern.


PCAN-USB-Registerseite

Sie können die PCAN-USB-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID eines PCAN-USB-Adpaters zu setzen.

Firmware-Version

Zeigt die Firmware-Version des PCAN-USB-Adapters an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB-Adapter geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB-Adapter unterstützt.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Geräte-ID

Die Geräte-ID ist ein 1 Byte langer Wert, der im Flash-Speicher eines PCAN-USB Adapters gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB-Adapter zu speichern.


PCAN-USB X6-Registerseite

Sie können die PCAN-USB X6-Registerseite verwenden, um allgemeine Informationen über die verwendete Hardware zu erhalten, und um die Geräte-ID eines PCAN-USB X6 Adapters zu setzen.

Firmware-Version

Zeigt die Firmware-Version der PCAN-USB X6 Adapters an.

Treiberversion

Zeigt die Version des Gerätetreibers an, der momentan für den PCAN-USB X6 Adapter geladen ist.

Anzahl Kanäle

Zeigt die Anzahl der CAN-Kanäle an, die der PCAN-USB X6 Adapter unterstützt.

Art.Nr.

Falls verfügbar, gibt die PEAK-Artikelnummer der PCAN-Hardware an.

Seriennummer

Zeigt die Seriennummer des PCAN-USB X6 Adapters an.

Geräte-ID

Die Geräte-ID ist ein 4 Byte langer Wert, der im Flash-Speicher eines PCAN-USB X6 Adapters gespeichert ist. Die Geräte-ID wird im Verbinden-Dialogfenster angezeigt, um die Identifikation eines bestimmten Adapters leichter zu machen, falls mehr als ein PCAN-USB X6 Adapter zur selben Zeit in den Computer eingesteckt ist.

Setzen

Drücken Sie diese Schaltfläche, um die eingegebene Geräte-ID in einem PCAN-USB X6 Adapter zu speichern.

CAN FD ISO-Modus

Gibt an, ob der CAN-Controller des PCAN-USB X6 Adapters gemäß des ISO-Standards ISO 11898-1:2015 betrieben wird (ISO CAN FD), oder ob das originale Bosch CAN FD Protokoll verwendet werden soll (non-ISO CAN FD), das nicht konform zum ISO-Standard ist.

Deaktivieren / Aktivieren

Drücken Sie diese Schaltfläche, um den CAN FD ISO-Modus des PCAN-USB X6 Adapters zu deaktiveren oder wieder zu aktivieren.


Firmware aktualisieren

Nach dem Start der Firmware-Aktualisierung trennt sich der Adapter vom System und meldet sich als Wechseldatenträger erneut an. Wird die Firmware-Aktualisierung das erste Mal ausgeführt, installiert Windows zunächst einen geeigneten Treiber für den Wechseldatenträger.

Um die Firmware-Aktualisierung durchzuführen, gehen Sie folgendermaßen vor:

  1. Ist die Treiberinstallation für den Wechseldatenträger abgeschlossen, lokalisieren und öffnen Sie das neue Laufwerk z.B. mit dem Windows Datei-Explorer. Das Laufwerk muss eine Datei namens "pcan-xyz.bin" enthalten, wobei der Anhang "xyz" je nach verwendeter PCAN-Hardware unterschiedlich ist. Für einen PCAN-USB-Adapter lautet der Dateiname "pcan-usb.bin".

  2. Löschen Sie die Datei "pcan-xyz.bin".

  3. Kopieren Sie die neue Firmwaredatei auf den Wechseldatenträger.

  4. Ist der Kopiervorgang beendet, ist die Firmware-Aktualisierung vollständig.

  5. Werfen Sie den Wechseldatenträger aus, indem Sie z.B. den Windows Datei-Explorer verwenden. Drücken Sie die rechte Maustaste auf dem Laufwerkssymbol um das Kontextmenü für den Wechseldatenträger anzeigen, und wählen Sie dort den Befehl Auswerfen aus.

  6. Nach dem Auswerfen des Wechseldatenträgers verbindet sich die PCAN-Hardware automatisch erneut mit dem System. Sie können die neue Firmware-Version jetzt in PCAN-View auf dem Hardware-Tab der verwendeten PCAN-Hardware ablesen.