Measurement Fundamentals

July 2016, 371408M-01

Measurement Fundamentals covers API-independent information that might help you as you develop applications. Topics include an explanation of different signal types, sensors commonly used with measurement devices, signal conditioning, and control fundamentals.

© 2005–2016 National Instruments. All rights reserved.


Measurement System Overview—Hardware and NI-DAQmx

The following figure depicts the measurement system overview, showing the path of real-world physical phenomena to your measurement application.

Sensors and transducers detect physical phenomena. Signal conditioning components condition physical phenomena so that the measurement device can receive the data. The computer receives the data through the measurement device. Software controls the measurement system, telling the measurement device when and from which channels to acquire or generate data. Software also takes the raw data, analyzes it, and presents it in a form you can understand, such as a graph, chart, or file for a report.

NI measurement devices and application software are packaged with NI-DAQmx driver software to program all the features of your NI measurement device such as configuring, acquiring, and generating data from and sending data to NI measurement devices. Using NI-DAQmx saves you from having to write these programs yourself. Application software, such as LabVIEW, LabWindows™/CVI™, and Measurement Studio, sends the commands to the driver, such as acquire and return a thermocouple reading, and then displays and analyzes the data acquired.

You can use the NI-DAQmx driver from NI application software or from any programming environment that supports calling dynamic link libraries (DLLs) through ANSI C interfaces. Regardless of the programming environment, your DAQ application uses NI-DAQmx, as shown in the figure.

Parent topic: Measurement Fundamentals


Signal Types

A signal is classified as analog or digital by the way it conveys information. A digital (or binary) signal has only two possible discrete levels—high level (on) or low level (off). An analog signal, on the other hand, contains information in the continuous variation of the signal with respect to time. A breakdown of the main signal types is shown in the following figure.

Parent topic: Measurement Fundamentals


Analog Connection Considerations

To measure analog signals, you need to know the signal source—grounded or floating. You also must consider the measurement system—differential, referenced single-ended, or nonreferenced single-ended.

Parent topic: Signal Types
Related concepts
Grounded Signal Sources
Floating Signal Sources
Differential Measurement System
Referenced and Nonreferenced Single-Ended Measurement Systems


Connecting Analog Input Signals

Signal connections vary depending on your device, connector block, and signal conditioning module. The DAQ Assistant contains connection diagrams that show terminal connections for all common analog input measurements, such as measuring strain, temperature, current, voltage, and so on. Refer to Viewing Connection Diagrams in the DAQ Assistant Help for additional information.

For terminals specific to your device, refer to your device documentation.

Parent topic: Analog Connection Considerations


Floating Signal Sources

In a floating source, the voltage signal is not connected to any absolute reference or any common ground, such as earth or building ground as shown in the following figure.

Floating signal sources are also called nonreferenced signal sources. Some common examples of floating signal sources are batteries, thermocouples, transformers, and isolation amplifiers. Notice in the figure that neither terminal of the source is connected to the electrical outlet ground, so each terminal is independent of the system ground.

Parent topic: Connecting Analog Input Signals

Measuring Floating Signal Sources

You can measure floating signal sources with both differential and single-ended measurement systems. In the case of the differential measurement system, however, make sure the common-mode voltage level of the signal with respect to the measurement system ground remains in the common-mode input range of the measurement device. A variety of phenomena—for example, the instrumentation amplifier input bias currents—can move the voltage level of the floating source out of the valid range of the input stage of a DAQ device.

Related concepts
Differential Measurement System
Referenced and Nonreferenced Single-Ended Measurement Systems


Grounded Signal Sources

A grounded source is one in which the voltage signals are referenced to a system ground, such as earth or building ground, as shown in the following figure.

Because such sources use the system ground, they share a common ground with the measurement device. The most common examples of grounded sources are devices that plug into the building ground through wall outlets, such as signal generators and power supplies.

Note Note The grounds of two independently grounded signal sources generally are not at the same potential. The difference in ground potential between two instruments connected to the same building ground system is typically 10 mV to 200 mV. The difference can be higher if power distribution circuits are not properly connected.
Parent topic: Connecting Analog Input Signals

Measuring Grounded Signal Sources

A grounded signal source is best measured with a differential or an NRSE measurement system. If you use an RSE measurement system with a grounded source, the result is typically a noisy measurement system often showing power-line frequency (60 Hz) components in the readings. Ground-loop introduced noise can have both AC and DC components, introducing offset errors and noise in the measurements. The potential difference between the two grounds causes a current to flow in the interconnection. This current is called ground-loop current.

However, you can still use an RSE measurement system if the signal voltage levels are high and the interconnection wiring between the source and the measurement device has a low impedance. In this case, the signal voltage measurement is degraded by ground loop, but the degradation may be tolerable. You must observe the polarity of a grounded signal source before connecting the signal to a ground-referenced measurement system because the signal source can be short-circuited to ground, which can damage the signal source.

Related concepts
Differential Measurement System
Referenced and Nonreferenced Single-Ended Measurement Systems


Measurement System Types and Signal Sources

The type of input signal source (grounded or floating) and the configuration of the measurement system (differential, single-ended, pseudodifferential) determine how you connect signals to measurement devices.

The following table provides an application-independent summary of analog input connections.

Input | Signal Source Type
 | Floating Signal Source (Not Connected to Building Ground) | Grounded Signal Source
 | Examples: Ungrounded thermocouples, signal conditioning with isolated outputs, battery devices | Example: Instruments with nonisolated outputs
Differential (DIFF) |  |
Ground Referenced Single-Ended (RSE) Note: AI GND is shared as a reference for all RSE channels |  |
Nonreferenced Single-Ended (NRSE) Note: AI SENSE is shared as a reference for all NRSE channels |  |
Pseudodifferential |  |
R ext is the external bias resistor that you add.
Parent topic: Connecting Analog Input Signals
Related concepts
Grounded Signal Sources
Floating Signal Sources
Differential Measurement System
Referenced and Nonreferenced Single-Ended Measurement Systems
Pseudodifferential Measurement System


Differential Measurement System

A differential measurement system has neither of its inputs tied to a fixed reference, such as earth or building ground. A differential measurement system is similar to a floating signal source in that the measurement is made with respect to a floating ground that is different from the measurement system ground. Hand-held, battery-powered instruments and DAQ devices with instrumentation amplifiers are examples of differential measurement systems.

The following figure shows an implementation of an 8-channel differential measurement system used in a typical NI device. Analog multiplexers are used in the signal path to increase the number of measurement channels when there is only a single instrumentation amplifier. For this device, the pin labeled AIGND, the analog input ground, is the measurement system ground.

Your signal source—floating or grounded—helps determine if you should use a differential measurement system.

Parent topic: Measurement System Types and Signal Sources
Related concepts
Floating Signal Sources
Grounded Signal Sources


Rejecting Common-Mode Voltages

An ideal differential measurement system responds only to the potential difference between its two terminals—the positive (+) and negative (–) inputs. Any voltage measured with respect to the instrumentation amplifier ground that is present at both amplifier inputs is referred to as a common-mode voltage. Common-mode voltage is completely rejected (not measured) by an ideal differential measurement system. This capability is useful in rejection of noise, because unwanted noise is often introduced as common-mode voltage in the circuit making up the cabling system.

Real-world devices have several factors, described by parameters such as common-mode voltage range and common-mode rejection ratio (CMRR), that limit the ability to reject the common-mode voltage.

Parent topic: Differential Measurement System

Common-Mode Voltage

The common-mode voltage range limits the allowable voltage swing on each input with respect to the measurement system ground. Violating this constraint results not only in measurement error but also in possible damage to components on the device. Common-mode voltage (Vcm) is defined using the following formula:

  • Vcm = (V+ + V–) / 2

where V+ is the voltage at the noninverting terminal of the measurement system with respect to the measurement system ground, and V– is the voltage at the inverting terminal of the measurement system with respect to the measurement system ground.

CMRR

CMRR measures the ability of a differential measurement system to reject the common-mode voltage signal. For instance, if you are measuring a thermocouple in a noisy environment, the noise from the environment appears on both input leads. Therefore, this noise is a common mode voltage signal that is rejected by an amount equal to the CMRR of the instrument. Most DAQ devices specify the CMRR up to 60 Hz, the power line frequency. CMRR in decibels (dB) is defined using the following formula:

  • CMRR(dB) = 20 log (Differential Gain/Common-Mode Gain)

A simple circuit is shown in the following figure. In this circuit, CMRR in decibels is measured as 20 log Vcm/Vout, where Vcm = V+ + V–.


Referenced and Nonreferenced Single-Ended Measurement Systems

Referenced and nonreferenced single-ended measurement systems are similar to grounded sources in that the measurement is made with respect to ground. A referenced single-ended (RSE) measurement system measures voltage with respect to the ground, AIGND in the figure, which is directly connected to the measurement system ground. The following figure shows an 8-channel referenced single-ended measurement system.

DAQ devices often use a variant of the referenced single-ended measurement technique, known as nonreferenced single-ended (NRSE). The following figure shows an NRSE system.

In an NRSE measurement system, all measurements are still made with respect to a single-node analog input sense (AISENSE), but the potential at this node can vary with respect to the measurement system ground. The previous figure illustrates that a single-channel NRSE measurement system is the same as a single-channel differential measurement system.

Parent topic: Measurement System Types and Signal Sources


Pseudodifferential Measurement System

A pseudodifferential measurement system combines some characteristics of a differential input channel and a referenced single-ended (RSE) input channel. Like a differential input channel, a pseudodifferential measurement system exposes both the positive and negative sides of the channel. You connect the positive and negative inputs to the respective outputs of the unit under test. The negative input is tied to system ground through a relatively small impedance (designated as Z1 in the diagram below). The impedance between the negative input and ground may include both resistive and capacitive components. The positive and negative sides of the input channel are separated by a larger impedance (designated by Zin).

Pseudodifferential input configurations are common in simultaneous sampling and dynamic signal acquisition (DSA) devices that do not employ a multiplexed signal architecture. A pseudodifferential system is well-suited for measuring the output of floating or isolated devices under test such as battery-powered instruments or most accelerometers. The pseudodifferential setup can also be used to measure referenced signals if the signal reference potential does not differ greatly from the ground potential of the measurement device. However, ground loops may pose an issue if the potential of the negative leg of the signal differs significantly from chassis ground. In general, a differential input offers a better common-mode rejection ratio (CMRR) than a pseudodifferential input.

Parent topic: Measurement System Types and Signal Sources


Connecting Analog Output Signals

Signal connections vary depending on your device, connector block, and signal conditioning module. The following figure shows how to make analog output connections for a typical NI device.

For terminals specific to your device, refer to your device documentation.

Parent topic: Analog Connection Considerations


Sampling Considerations

Parent topic: Analog Connection Considerations
Related concepts
Device Range
Input Limits (Maximum and Minimum Values)
Sampling Rate
Resolution
Calculating the Smallest Detectable Change—Code Width


Device Range

Device range refers to the minimum and maximum analog signal levels that the ADC can digitize. Many measurement devices can select from several ranges by changing from unipolar mode to bipolar mode or by selecting from multiple gains, allowing the ADC to take full advantage of its resolution to digitize the signal.

Parent topic: Sampling Considerations
Related concepts
Input Limits (Maximum and Minimum Values)
DSA Devices

Unipolar and Bipolar Modes

Unipolar mode means that a device only supports a range of 0 V to +X V. Bipolar mode means that a device supports a range of -X V to +X V. Some devices support only one mode or the other, while other devices can change from unipolar mode to bipolar mode.

Devices that can change from unipolar to bipolar mode are able to select the mode that best fits the signal to measure. The first chart of the following figure illustrates unipolar mode for a 3-bit ADC. The ADC has eight digital divisions in the range from 0 to 10 V. In bipolar mode, the range is -10.00 to 10.00 V, as shown in the second chart. The same ADC now separates a 20 V range into eight divisions. The smallest detectable difference in voltage increases from 1.25 to 2.50 V, and you now have a much less accurate representation of the signal. The device selects the best mode available based on the input limits you specify when you create a virtual channel.

Gain Adjustment

If a device has multiple gains, it multiplies an input signal by one of the gains to make the signal take up more of the full device range. This essentially gives the device multiple ranges it can select from. For example, a device with an overall range of -10 V to 10 V and possible gains of 1, 2, and 4 can select between ranges of -10 V to 10 V, -5 V to 5 V, and -2.5 V to 2.5 V. The device selects the best gain available according to the input limits you specify when you create a virtual channel.

Note Note Gain works differently for DSA devices


Input Limits (Maximum and Minimum Values)

Input limits are the maximum and minimum values you expect to measure, after any scaling, including custom scaling. Input limits are sometimes confused with device range. Device range refers only to the input range of a particular device. For instance, the device range for a DAQ device might be 0 to 10 V, but that device might be used with a temperature sensor that outputs 100 mV for every 1 °C. The input limits in that case could be 0 to 100, with 10 V corresponding to 100 °C.

Input limits in a smaller range can improve the precision of your measurement. If, in the previous example, you knew that the temperature would never be higher than 50 °C, you could choose a minimum value of 0 and a maximum value of 50. The device can then detect smaller differences in temperature because it is digitizing a voltage between 0 and 5 V, rather than 0 and 10 V.

Parent topic: Sampling Considerations
Related concepts
Device Range


Sampling Rate

One of the most important parameters of an analog input or output system is the rate at which the measurement device samples an incoming signal or generates the output signal. The sampling rate, which is called the scan rate in Traditional NI-DAQ (Legacy), is the speed at which a device acquires or generates a sample on each channel. A fast input sampling rate acquires more points in a given time and can form a better representation of the original signal than a slow sampling rate. Generating a 1 Hz signal using 1000 points per cycle at 1000 S/s produces a much finer representation than using 10 points per cycle at a sample rate of 10 S/s.

Sampling too slowly results in a poor representation of the analog signal. Undersampling causes the signal to appear as if it has a different frequency than it actually does. This misrepresentation of a signal is called aliasing.

Parent topic: Sampling Considerations


Resolution

Resolution is the smallest amount of input signal change that a device or sensor can detect. The number of bits used to represent an analog signal determines the resolution of the ADC. You can compare the resolution on a measurement device to the marks on a ruler. The more marks you have, the more precise your measurements. Similarly, the higher the resolution, the higher the number of divisions into which your system can break down the ADC range, and therefore, the smaller the detectable change.

A 3-bit ADC divides the range into 23 or 8 divisions. A binary or digital code between 000 and 111 represents each division. The ADC translates each measurement of the analog signal to one of the digital divisions. The following figure shows a sine wave digital image as obtained by a 3-bit ADC. Clearly, the digital signal does not represent the original signal adequately, because the converter has too few digital divisions to represent the varying voltages of the analog signal. By increasing the resolution to 16 bits, however, the number of divisions of the ADC increases from 8 to 65,536 (216). The ADC now can obtain an extremely accurate representation of the analog signal.

Parent topic: Sampling Considerations


Calculating the Smallest Detectable Change—Code Width

The resolution and device range of a measurement device determine the smallest detectable change, called the code width, in the input signal. The smaller your code width, the more accurate your measurements are.

You can calculate the code width using the following formula:

  • code width = device range/ 2resolution

For example, a 12-bit measurement device with a 0 to 10 V range detects a 2.4 mV change, while the same device with a -10 to 10 V input range detects only a change of 4.8 mV:

  • device range/ 2resolution = 10/212 = 2.4 mV
  • device range/ 2resolution = 20/212 = 4.8 mV

A high-resolution A/D converter (ADC) provides a smaller code width given the preceding device voltage ranges.

  • device range/ 2resolution = 10/216 = 0.15 mV
  • device range/ 2resolution = 20/216 = 0.3 mV

The following table shows how the code width of a 12-bit measurement device varies by device range. The device selects the best possible range based on the input limits you specify when you create a virtual channel. Select input limits that accurately reflect the signal you want to measure in order to achieve the smallest possible code width. NI-DAQmx coerces those input limits to fit the selected device range.

Overall Device Range Possible Device Ranges with Gain Adjustment Precision1
0 to 10 V
  • 0 to 10 V
  • 0 to 5 V
  • 0 to 2.5 V
  • 0 to 1.25 V
  • 0 to 1 V
  • 0 to 0.1 V
  • 0 to 20 mV
  • 2.44 mV
  • 1.22 mV
  • 610 µV
  • 305 µV
  • 244 µV
  • 24.4 µV
  • 4.88 µV
–5 to 5 V
  • -5 to 5 V
  • -2.5 to 2.5 V
  • -1.25 to 1.25 V
  • -0.625 to 0.625 V
  • -0.5 to 0.5 V
  • -50 to 50 mV
  • -10 to 10 mV
  • 2.44 mV
  • 1.22 mV
  • 610 µV
  • 305 µV
  • 244 µV
  • 24.4 µV
  • 4.88 µV
-10 to 10 V
  • -10 to 10 V
  • -5 to 5 V
  • -2.5 to 2.5 V
  • -1.25 to 1.25 V
  • -1 to 1 V
  • -0.1 to 0.1 V
  • -20 to 20 mV
  • 4.88 mV
  • 2.44 mV
  • 1.22 mV
  • 610 µV
  • 488 µV
  • 48.8 µV
  • 9.76 µV
Note Note The NI 4472 is a 24-bit device with a range of -10 V to 10 V. However, one bit is reserved, leaving an effective resolution of 23 bits. Thus, the code width is 20/223 = 2.38 µV.
Parent topic: Sampling Considerations
Related concepts
Resolution
Device Range
Input Limits (Maximum and Minimum Values)
Input Limits Coercion
1 The value of 1 Least Significant Bit (LSB) of the 12-bit ADC. In other words, the voltage increment corresponding to a change of 1 count in the ADC 12-bit count.


Digital Signals

A digital signal has two discrete levels—a high and a low level. One example of a digital signal is a transistor-transistor logic (TTL) compatible signal. A TTL-compatible signal has the following characteristics:
  • 0 V to 0.8 V = logic low
  • 2 V to 5 V = logic high
  • Maximum rise/fall time = 50 ns

Digital devices can monitor the state of the pulse and can transition the pulse from one state to another. A counter can also monitor the state as well as detect rising edges, a transition from logic low to logic high, and falling edges, a transition from logic high to logic low. Counters are used commonly to count edges and for time measurements, such as measuring digital frequency or the period of a signal.

Parent topic: Signal Types


Connecting Digital I/O Signals

The number of digital lines varies from device to device. The following figure shows signal connections for three typical DIO applications.

The figure shows PO <0..3> configured for digital input and PO <4..7> configured for digital output. Digital input applications include receiving TTL signals and sensing external device states such as the state of a switch. Digital output applications include sending TTL signals and driving external devices such as the LED shown in the figure.

Parent topic: Digital Signals


Counters

Counters measure and generate digital signals. Counters are used commonly to count edges and for time measurements, such as measuring digital frequency or the period of a signal. The signal connections required for counters vary depending on the device and your application.

Parent topic: Digital Signals
Related concepts
Connecting Counter Signals


Digital Logic States

Test engineers can choose from a number of different digital I/O instruments with a range of features for communication and test applications. Beyond the basic capabilities of driving a digital pattern of 1s and 0s, digital instruments often support waveforms that can include some or all of the logic states shown in the following table.

 | Logic State | Drive Data | Expected Response
Drive States | 0 | Logic Low | Don't Care
 | 1 | Logic High | Don't Care
 | Z | Disable | Don't Care
Compare States | L | Disable | Logic Low
 | H | Disable | Logic High
 | X | Disable | Don't Care

The six logic states control the voltage driver and, if supported, the compare engine of the digital tester (such as a DAQ device) on a per clock cycle basis. Drive states specify what stimulus data the digital tester drives on a particular channel or when to disable the voltage driver (referred to as the tristate or high-impedence state). Compare states indicate the expected response from the device under test. These six logic states make it possible to perform bidirectional communication and real-time hardware comparison of acquired response data.

Parent topic: Digital Signals


Duty Cycle

The duty cycle is a characteristic of a pulse. Use the following equation to calculate the duty cycle of a pulse whose high time and low time are unequal:

  • Duty Cycle = High Time/Pulse Period

where Pulse Period is high time plus low time.

The duty cycle of a pulse is between 0 and 1 and is often expressed as a percentage. Refer to the following figure for examples of duty cycles. A pulse with a high time equal to the low time has a duty cycle of 0.5, or 50%. A duty cycle less than 50% indicates that the low time is greater than the high time, and a duty cycle greater than 50% indicates that the high time is greater than the low time.

Parent topic: Digital Signals


Signal Analysis

Signal analysis is the process of transforming an acquired signal to extract information about the signal, filter noise from the signal, and present the signal in a more understandable form than the raw signal.

Filtering and windowing are two signal analysis techniques.

Parent topic: Signal Types
Related concepts
Filtering
Windowing


Filtering

Filtering is one of the most commonly used signal processing techniques. Signal conditioning systems can filter unwanted signals or noise from the signal you are measuring. Use a noise filter on low-rate, or slowly changing, signals, such as temperature, to eliminate higher frequency signals that can reduce signal accuracy. A common use of a filter is to eliminate the noise from a 50 or 60 Hz AC power line. A lowpass filter of 4 Hz removes the 50 or 60 Hz AC noise from signals sampled at low rates. A lowpass filter eliminates all signal frequency components above the cutoff frequency. Many signal conditioning modules have lowpass filters that have software-selectable cutoff frequencies from 10 Hz to 25 kHz.

Parent topic: Signal Analysis


Windowing

Use windowing, or smoothing windows, to minimize spectral leakage associated with truncated waveforms.

Parent topic: Signal Analysis

Spectral Leakage

Spectral leakage is a phenomenon whereby the measured spectral energy appears to leak from one frequency into other frequencies. It occurs when a sampled waveform does not contain an integral number of cycles over the time period during which it was sampled. The technique used to reduce spectral leakage is to multiply the time-domain waveform by a window function.

Discrete Fourier Transform (DFT) and Fast Fourier Transform (FFT) are mathematical techniques that resolve a given signal into the sum of sines and cosines. It is the basis for spectrum analysis. Using the DFT/FFT when you sample a noninteger number of cycles, such as 7.5 cycles, returns a spectrum in which it appears as if the energy at one frequency leaks into all the other frequencies because the FFT assumes that the data is a single period of a periodically repeating waveform. The artificial discontinuities appear as very high frequencies that were not present in the original signal. Because these frequencies are higher than the Nyquist frequency, they appear aliased between 0 and fs/2.

The type of window to use depends on the type of signal you acquire and on the application. Choosing the correct window requires some knowledge of the signal that you are analyzing. The following table lists common types of windows, the appropriate signal types, and example applications.

Window | Signal Type and Description | Applications
Rectangular (no window) | Transient signals that are shorter than the length of the window; truncates a window to within a finite time interval | Order tracking, system analysis (frequency response measurements) with pseudorandom excitation, separation of two tones with frequencies very close to each other but with almost equal amplitudes
Triangle | Window that is the shape of a triangle | General-purpose applications
Hanning | Transient signals that are longer than the length of the window | Often used in speech signal processing
Hamming | Transient signals that are longer than the length of the window; a modified version of the Hanning window that is discontinuous at the edges | Often used in speech signal processing
Blackman | Transient signals; similar to Hanning and Hamming windows but adds one additional cosine term to reduce ripple | General-purpose applications
Flat Top | Has the best amplitude accuracy of all the windows but limits frequency selectivity | Accurate, single-tone amplitude measurements with no nearby frequency components
Note Note In many cases, you might not have sufficient knowledge of the signal, so you need to experiment with different windows to find the best one.


Signal Conditioning

Sensors can generate electrical signals to measure physical phenomena, such as temperature, force, sound, or light. To measure signals from transducers, you must convert them into a form that a DAQ device can accept. For example, the output voltage of most thermocouples is very small and susceptible to noise. Therefore, you may need to amplify or filter the thermocouple output before digitizing it.

The manipulation of signals to prepare them for digitizing is called signal conditioning. Common types of signal conditioning include the following:
  • Amplification
  • Linearization
  • Transducer excitation
  • Isolation
Parent topic: Measurement Fundamentals
Related concepts
Amplification
Linearization
Transducer Excitation
Isolation


Amplification

Amplification is a type of signal conditioning that improves accuracy in the resulting digitized signal by increasing signal amplitude relative to noise.

For the highest possible accuracy, amplify the signal so the maximum voltage swing equals the maximum input range of the ADC, or digitizer. Your system should amplify low-level signals at the measurement device located nearest the signal source, as shown in the following figure.

Tip Tip Use shielded cables or a twisted pair of cables. By minimizing wire length, you can minimize noise that the lead wires pick up. Keep signal wires away from AC power cables and monitors to reduce 50 or 60 Hz noise.

If you amplify the signal at the measurement device, the signal is measured and digitized with noise that may have entered the lead wires. However, if you amplify the signal close to the signal source with an SCXI module, noise has less impact on the measured signal.

Parent topic: Signal Conditioning


Linearization

Linearization is a type of signal conditioning in which software linearizes the voltage levels from transducers, so the voltages can be scaled to measure physical phenomena. For example, a change in voltage of 10 mV for a thermocouple usually does not reflect a change of 10 degrees. However, with linearization in software or hardware, the thermocouple can be scaled to the appropriate temperature in your application. Most transducers have linearization tables that describe scaling the transducer.

Parent topic: Signal Conditioning


Transducer Excitation

Signal conditioning systems can generate excitation for some transducers. Strain gages and RTDs require external voltage and current, respectively, to excite their circuitry into measuring physical phenomena. This type of excitation is similar to the power a radio needs to receive and decode audio signals. Several measurement devices provide the necessary excitation for transducers. Consult your device documentation to see if your device can generate excitation.

Parent topic: Signal Conditioning


Isolation

Signals often can exceed the limits that a measurement device can handle. Trying to measure a signal that is too large for the measurement device can damage the device or you. To keep you and your device safe from large voltages, you can apply a signal conditioning technique called isolation. The signal conditioning hardware attenuates high common mode voltages and extracts a signal that measurement devices can handle. Isolation also ensures that differences in ground potentials do not affect your device.

Parent topic: Signal Conditioning


Common Sensors

Depending on your application, you may use several different kinds of sensors. Some commonly used ones are strain gages, thermocouples, thermistors, angular encoders, linear encoders, bridge-based sensors, and resistance temperature detectors (RTDs).

Parent topic: Measurement Fundamentals
Related concepts
Strain Gages
Thermocouples
Thermistors
Quadrature Encoders
Two-Pulse Encoders
Bridge-Based Sensors
Resistance Temperature Detectors (RTDs)


2-Wire Resistance

Resistance measurements in the range above 100 Ω are generally made using the 2-wire method shown in the following figure. The excitation current flows through the leads and the unknown resistance, Rmeas. Your device measures the voltage across the resistance through the same set of leads and computes the resistance accordingly.

Errors in the 2-wire measurements are introduced by the lead resistance, RLead, when measuring lower resistances. Because there is a voltage drop across the lead resistance equal to I × RLead, the voltage measured by your device is not exactly the same as the voltage across the resistance, Rmeas. Because typical lead resistances lie in the range of 0.01–1 Ω, accurate 2-wire resistance measurements are very difficult to obtain if Rmeas is below 100 Ω.

Parent topic: Common Sensors


3-Wire Resistance

Use the 3-wire resistance method, as shown in the following figure, to measure resistance on resistors that have three lead wires.

The 3-wire method uses three test leads, one pair for the excitation current (Ex+, Ex-), and a third wire (Sense-) to compensate for the lead wire resistances. The third wire measures the voltage developed over the lead resistance in the Ex- leg of the excitation current path. By subtracting its value from the overall differential signal, the device can compensate for parasitic lead resistances in the Ex+ leg. However, this would only compensate for lead resistance in the Ex+ leg and not in the Ex- leg. To compensate for lead resistance both in the Ex- leg and in the Ex+ leg, the device approximates the Ex+ leg by assuming the voltage is the same as in the Ex- leg. Thus the voltage between Sense- and Ex- is multiplied by two before being subtracted from the overall differential signal. This method works well when lead resistances in the Ex+ leg match resistances in the Ex- leg.

Some legacy devices do not provide compensation. In that case, you need to specify the lead-wire resistance so that it can be subtracted in software.

Parent topic: Common Sensors


4-Wire Resistance

Use the 4-wire resistance method, as shown in the following figure, to measure resistances of less than 100 Ω. The 4-wire method is more accurate than the 2-wire method.

The 4-wire method uses four test leads, one pair for the injected current (the test lead) and the other pair for sensing the voltage across the resistor Rmeas (the sense lead). Because no current flows in the sense lead, the device measures only the voltage developed across the resistance. Thus, a 4-wire resistance eliminates errors that test lead and contact resistance cause.

Parent topic: Common Sensors


Bridge-Based Sensors

Bridge-based sensors operate by correlating a physical phenomena, such as strain, temperature, or force, to a change in resistance in one or more legs of a Wheatstone bridge. The general Wheatstone bridge, shown in the following figure, is a network of four resistive legs with an excitation voltage, VEX, that is applied across the bridge. One or more of these legs can be active sensing elements.

The Wheatstone bridge is the electrical equivalent of two parallel voltage divider circuits. R1 and R2 compose one voltage divider circuit, and R4 and R3 compose the second voltage divider circuit. You measure the output of a Wheatstone bridge between the middle nodes of the two voltage dividers.

A physical phenomena, such as a temperature shift or a change in strain applied to a specimen, changes the resistance of the sensing elements in the Wheatstone bridge. You can use the Wheatstone bridge configuration to help measure the small variations in resistance that the sensing elements produce corresponding to a physical change in the specimen.

Parent topic: Common Sensors


Bridge Measurement Types

NI-DAQmx provides several measurement types for taking measurements from a bridge-based sensor.

  • Strain gage—Use the strain gage measurement type for performing strain measurements.
  • Force, pressure, and torque—Use these measurement types for performing bridge-based force, pressure, or torque measurements on supported devices.

NI-DAQmx provides additional measurement types from which you read data in electrical units. Use a custom scale or write scaling code to convert the electrical units to physical units.

  • Bridge (V/V)—Channels using the bridge V/V measurement type return a voltage ratio instead of physical units. Use this measurement type on supported devices for other bridge-based sensors, for sensors that scale data to physical units NI-DAQmx does not support, or to measure torsional strain.
  • Custom voltage with excitation—Use this measurement type for bridge-based measurements on devices that do not support the strain gage, force, pressure, torque, or bridge (V/V) measurement types. Specify to use excitation for scaling to acquire a voltage ratio instead of a voltage. On ratiometric devices, you must specify to use excitation for scaling because those devices can only acquire a voltage ratio.
  • Voltage—Use this measurement type with bridge-based sensors that include an internal amplifier and output voltage.
  • Current—Use this measurement type with bridge-based sensors that include an internal amplifier and output current.
Parent topic: Bridge-Based Sensors
Related concepts
Bridge Measurement Type Support


Bridge Sensor Scaling

Measurements from a bridge-based sensor are based on a ratio of measured voltage to excitation voltage. NI-DAQmx uses the following equation to calculate that ratio:

where VR is the voltage ratio; V is the voltage output from the bridge; VIB is the initial bridge voltage, as determined by offset nulling; VEX is the excitation voltage supplied to the bridge; and G is the gain adjustment from shunt calibration.

Ratiometric devices divide the voltage output from the bridge by the excitation voltage in hardware. Therefore, V/VEX must be within the device range of the device. On voltage devices, the voltage output from the bridge must be within the device range. The initial bridge voltage and gain adjustment affect the association between device range and input limits. For example, on a device that can measure ±5 V, an initial bridge voltage of 1 V means that the minimum and maximum input limits must correspond to -6 V to 4 V.

NI-DAQmx uses various methods to scale that voltage ratio to physical units, depending on the bridge configuration for strain measurements or on the scaling type that best matches the specifications provided by the sensor manufacturer for other bridge-based sensors NI-DAQmx supports.

Parent topic: Bridge-Based Sensors
Related concepts
Offset Nulling (Bridge Balancing)
Shunt Calibration (Gain Adjustment)
Device Range
Input Limits (Maximum and Minimum Values)
Strain Gage Bridge Configurations
Bridge Scaling Types


Bridge Configurations

There are three types of bridge configurations: quarter-bridge, half-bridge, and full-bridge. The number of active element legs in the Wheatstone bridge determines the kind of bridge configuration.

Configuration | Number of Active Elements
Quarter-bridge | 1
Half-bridge | 2
Full-bridge | 4

Strain gages use variations of these bridge configurations.

Parent topic: Bridge-Based Sensors
Related concepts
Strain Gage Bridge Configurations


Signal Conditioning Requirements for Bridge-Based Sensors

Common signal conditioning requirements for bridge-based sensors include:
  • Bridge completion
  • Bridge excitation and remote sensing
  • Signal amplification

In addition, you should calibrate your sensor periodically to account for changes in the physical characteristics of the sensor and in the material the sensor is measuring, to account for variations in the lead wire resistance, and to compensate for imperfections in the measurement system. Calibrating bridge-based sensors usually involves two steps: offset nulling, or bridge balancing, and shunt calibration, or gain adjustment.

Parent topic: Bridge-Based Sensors
Related concepts
Bridge Completion
Bridge Excitation
Signal Amplification
Offset Nulling (Bridge Balancing)
Shunt Calibration (Gain Adjustment)


Bridge Completion

Unless you are using a full-bridge sensor, you must complete the bridge with reference resistors. Therefore, signal conditioners for bridge-based sensors typically provide half-bridge completion networks consisting of two high-precision reference resistors. The nominal resistance of the completion resistors is less important than how well the two resistors match. Ideally, the resistors match well and provide a stable reference voltage of VEX/2 to the negative input lead of the measurement channel. The high resistance of the completion resistors helps minimize the current draw from the excitation voltage. However, using completion resistors that are too large can result in increased noise and errors due to bias currents.

Parent topic: Signal Conditioning Requirements for Bridge-Based Sensors


Signal Amplification

The output of bridge-based sensors is relatively small. For example, most strain gage bridges and strain-based transducers output less than 10 mV/V, or 10 millivolts of output per volt of excitation voltage. Therefore, signal conditioners for bridge-based sensors usually include amplifiers to boost the signal level, to increase measurement resolution, and to improve signal-to-noise ratios. For example, SCXI signal conditioning modules include configurable gain amplifiers with gains up to 2,000. Other devices support multiple device ranges.

Parent topic: Signal Conditioning Requirements for Bridge-Based Sensors
Related concepts
Device Range


Bridge Excitation

Bridge-based sensors require a constant voltage to power the bridge. Bridge signal conditioners typically include a voltage source. While there is no standard voltage level that is recognized industry wide, excitation voltage levels of around 3 V and 10 V are common.

Excitation sources can suffer from stability and accuracy issues. To compensate, ratiometric devices constantly measure the actual excitation voltage and use it, rather than an intended excitation value, when scaling data.

Parent topic: Signal Conditioning Requirements for Bridge-Based Sensors
Related concepts
Bridge Sensor Scaling

Remote Sensing

If the bridge circuit is located away from the signal conditioner and excitation source, a possible source of error is voltage drops caused by resistance in the wires that connect the excitation voltage to the bridge. Therefore, some signal conditioners include a feature called remote sensing to compensate for this error. There are two common methods of remote sensing.

With feedback remote sensing, you connect extra sense wires to the point where the excitation voltage wires connect to the bridge circuit. The extra sense wires serve to regulate the excitation supply, to compensate for lead losses, and to deliver the needed voltage at the bridge.

An alternative remote sensing scheme uses a separate measurement channel to measure directly the excitation voltage delivered across the bridge. Because the measurement channel leads carry very little current, the lead resistance has negligible effect on the measurement. You then can use the measured excitation voltage in the voltage-to-strain conversion to compensate for lead losses.


Bridge-Based Sensor Calibration

Calibrate bridge-based sensors periodically to account for changes in the physical characteristics of the sensor and in the material the sensor is measuring, to account for variations in the lead wire resistance, and to compensate for imperfections in the measurement system. Calibrating bridge-based sensors usually involves two steps: offset nulling, or bridge balancing, and shunt calibration, or gain adjustment.

Parent topic: Bridge-Based Sensors
Related concepts
Offset Nulling (Bridge Balancing)
Shunt Calibration (Gain Adjustment)


Offset Nulling (Bridge Balancing)

When you install a bridge-based sensor, the bridge probably will not output exactly 0 V when not under load. Slight variations in resistance among the bridge legs generate some nonzero initial offset voltage. Use the DAQmx Perform Bridge Offset Nulling Calibration VI/function or the DAQ Assistant to perform an offset nulling calibration, which performs bridge balancing in a few different ways. Refer to the device documentation to determine the offset nulling methods your device provides.

Parent topic: Bridge-Based Sensor Calibration
Related concepts
Bridge Sensor Scaling

Software Compensation (Initial Bridge Voltage)

This method of bridge balancing compensates for the initial voltage in software. With this method, NI-DAQmx measures the bridge while not under load. NI-DAQmx then uses this measurement as the initial bridge voltage when scaling readings from the bridge. This method is simple, fast, and requires no manual adjustments. The disadvantage of the software compensation method is that the method does not remove the offset of the bridge. If the offset is large enough, it limits the amplifier gain you can apply to the output voltage, thus limiting the dynamic range of the measurement.

Offset Nulling Circuit

The second bridge balancing method uses an adjustable resistor, or potentiometer, to electrically adjust the output of the bridge to 0 V.

Hardware Nulling Compensation

The third method, like the software compensation method, does not affect the bridge directly. A nulling circuit adds an adjustable DC voltage, positive or negative, to the output of the instrumentation amplifier to compensate for initial bridge offset.


Shunt Calibration (Gain Adjustment)

You can verify the output of a bridge-based measurement system by comparing the measured bridge output with a calculated value if the physical load on the sensor is known. NI-DAQmx can then use the difference (if any) between the calculated and the measured values as a gain adjustment factor for each measurement. You can simulate applying a load to the bridge by connecting a large known resistor in parallel with the bridge. This resistor, called a shunt resistor, offsets the zero voltage of the bridge. Because the value of the shunt resistor is known, you can calculate the physical load corresponding to the voltage drop of the resistor.

Use the DAQmx Perform Shunt Calibration VI/function or the DAQ Assistant to perform a shunt calibration, which sets the gain adjustment for a virtual channel. NI-DAQmx then uses this gain adjustment when scaling readings from the bridge. Some National Instruments products include internal shunt resistors.

Parent topic: Bridge-Based Sensor Calibration
Related concepts
Bridge Sensor Scaling


Bridge-Based Force, Pressure, and Torque Sensors

Sensors for measuring force, pressure, and torque, such as a load cell, are often based on a Wheatstone bridge. These sensors typically use a full-bridge configuration with a 350 Ω nominal bridge resistance.

Sensor manufacturers often provide a table or polynomial equation to describe how electrical values scale to the physical phenomena the sensor measures. NI-DAQmx provides several scaling types for scaling data according to the specifications provided by the sensor manufacturer.

Parent topic: Bridge-Based Sensors
Related concepts
Bridge-Based Sensors
Bridge Configurations
Bridge Scaling Types


Bridge Scaling Types

NI-DAQmx provides three methods to scale electrical values (voltage ratios) from a bridge-based sensor to physical units:

  • Two-Point Linear—You provide two pairs of electrical values and their corresponding physical values. NI-DAQmx uses those values to calculate the slope and y-intercept of a linear equation and uses that equation to scale electrical values to physical values. Measured electrical and physical values can fall outside the range of the values specified for calculating the slope and y-intercept.
  • Table—You provide a set of electrical values and the corresponding physical values. NI-DAQmx performs linear scaling between each pair of electrical and physical values. The input limits must fall within the smallest and largest physical values.
  • Polynomial—You provide the forward and reverse coefficients of a polynomial equation. NI-DAQmx uses that equation to scale electrical values to physical values. Use the DAQmx Compute Reverse Polynomial Coefficients VI/function to determine one set of coefficients if you know only the other set.

Datasheets or calibration certificates from sensor manufacturers often include a table of electrical and physical values or a polynomial equation for scaling. If you do not have a table or polynomial equation for your sensor, use two-point linear scaling. Use the rated output of the sensor and the sensor capacity as one pair of electrical and physical values. Use zero for the other pair of electrical and physical values.

Note Note Strain gages use specific equations for scaling, depending on the bridge configuration.

Parent topic: Bridge-Based Force, Pressure, and Torque Sensors
Related concepts
Bridge Sensor Scaling
Input Limits (Maximum and Minimum Values)
Strain Gage Bridge Configurations


Strain Gages

You can measure strain with a strain gage, which is a device with electrical resistance that varies in proportion to the amount of strain in the device, and with signal conditioning. When using a strain gage, you bond the strain gage to the device under test, apply force, and measure the strain by detecting changes in resistance (Ω). Strain gages return varying voltages in response to stress or vibrations in materials. Resistance changes in parts of the strain gage to indicate deformation of the material. Strain gages require excitation, generally voltage excitation, and linearization of the voltage measurements.

Strain measurements rarely involve quantities larger than a few microstrain (µε). Therefore, measuring strain requires accurate measurements of very small changes in resistance. For example, if a test specimen undergoes a substantial strain of 500 µε, a strain gage with a gage factor of 2 exhibits a change in electrical resistance of only 2 × (500 × 10 -6 ) = 0.1%. For 120 Ω, this is a change of only 0.12 Ω.

To measure such small changes in resistance and to compensate for temperature sensitivity, strain gages often use a Wheatstone bridge with a voltage or current excitation source, arranged in one of several bridge configurations. The gage is the collection of all of the active elements of the Wheatstone bridge.

NI-DAQmx supports measuring axial strain, bending strain, or both. While you can use some similar configuration types to measure torsional strain, NI software scaling does not support these configuration types. It is possible to use NI products to measure torsional strain, but to properly scale these configuration types you must use a custom scale with a bridge (V/V) or a custom voltage with excitation channel.

Gage Factor

A fundamental parameter of the strain gage is its sensitivity to strain, expressed quantitatively as the gage factor (GF). Gage factor is the ratio of the fractional change in electrical resistance to the fractional change in length, or strain. The gage factor must be the same for each gage in the bridge.

The gage factor for metallic strain gages is usually around 2. You can obtain the actual gage factor of a particular strain gage from the sensor vendor or sensor documentation.

Nominal Gage Resistance

Nominal gage resistance is the resistance of a strain gage in an unstrained position. You can obtain the nominal gage resistance of a particular gage from the sensor vendor or sensor documentation.

Parent topic: Bridge-Based Sensors
Related concepts
Strain Rosette
Signal Conditioning Requirements for Bridge-Based Sensors
Bridge-Based Sensors
Strain Gage Bridge Configurations
Custom Scales


Strain Gage Bridge Configurations

Connect strain gages in a variation on a generic Wheatstone bridge configuration. These configurations vary based on the placement of strain gages within the bridge; their location and orientation on the material you want to measure; and whether the gages are active sensing gages or dummy gages, used for temperature compensation.

Parent topic: Strain Gages
Related concepts
Bridge Configurations
Quarter-Bridge Type I
Quarter-Bridge Type II
Half-Bridge Type I
Half-Bridge Type II
Full-Bridge Type I
Full-Bridge Type II
Full-Bridge Type III


Quarter-Bridge Type I

The following figure shows how to position a strain gage resistor in an axial configuration for the quarter-bridge type I.

The following figure shows how to position a strain gage resistor in a bending configuration for the quarter-bridge type I.

Quarter-bridge type I strain gage configurations have the following characteristics:
  • A single active strain gage element mounted in the principle direction of axial or bending strain.
  • A passive quarter-bridge completion resistor, known as a dummy resistor, in addition to half-bridge completion.
  • Temperature variation decreasing the accuracy of the measurements.
  • Sensitivity at 1000 µε is ~ 0.5 mVout / VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Quarter-Bridge Type I Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the half-bridge completion resistor.
  • R2 is the half-bridge completion resistor.
  • R3 is the quarter-bridge completion resistor, known as a dummy resistor.
  • R4 is the active strain gage element measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for quarter-bridge configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, RL is the lead resistance, and Rg is the nominal gage resistance.


Quarter-Bridge Type II

The following figure shows how to position a strain gage resistor in an axial configuration for the quarter-bridge type II.

The following figure shows how to position a strain gage resistor in a bending configuration for the quarter-bridge type II.

Quarter-bridge type II strain gage configurations have the following characteristics:
  • One active strain gage element and one passive, temperature-sensing quarter-bridge element, known as a dummy resistor. The active element is mounted in the direction of axial or bending strain. The dummy gage is mounted in close thermal contact with the strain specimen but is not bonded to the specimen, and is usually mounted transverse, or perpendicular, to the principle axis of strain. This configuration is often confused with the half-bridge type I configuration, but in the half-bridge type I configuration, the R3 element is active and bonded to the strain specimen to measure the effect of Poisson's ratio.
  • Completion resistors which provide half-bridge completion.
  • Compensation for temperature.
  • Sensitivity at 1000 µε is ~ 0.5 mVout/ VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Quarter-Bridge Type II Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the half-bridge completion resistor.
  • R2 is the half-bridge completion resistor.
  • R3 is the quarter-bridge temperature sensing element, known as a dummy resistor.
  • R4 is the active strain gage element measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for quarter-bridge configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, RL is the lead resistance, and Rg is the nominal gage resistance.


Half-Bridge Type I

The following figure shows how to position strain gage resistors in an axial configuration for the half-bridge type I.

The following figure shows how to position strain gage resistors in a bending configuration for the half-bridge type I.

Half-bridge type I strain gage configurations have the following characteristics:
  • Two active strain gage elements, one mounted in the direction of axial strain and the other acting as a Poisson gage and mounted transverse, or perpendicular, to the principal axis of strain.
  • Completion resistors which provide half-bridge completion.
  • Sensitivity to both axial and bending strain.
  • Compensation for temperature.
  • Compensation for the aggregate effect on the principle strain measurement due to the Poisson's ratio of the material.
  • Sensitivity at 1000 µε is ~ 0.65 mVout/ VEX input
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Half-Bridge Type I Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the half-bridge completion resistor.
  • R2 is the half-bridge completion resistor.
  • R3 is the active strain gage element measuring compression due to the Poisson effect (–ε).
  • R4 is the active strain gage element measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for half-bridge type I configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, v is the Poisson's ratio, RL is the lead resistance, and Rg is the nominal gage resistance.


Half-Bridge Type II

The half-bridge type II configuration only measures bending strain.

The following figure shows how to position strain gage resistors in a bending configuration for the half-bridge type II.

Half-bridge type II strain gage configurations have the following characteristics:

  • Two active strain gage elements, one mounted in the direction of axial strain on the top side of the strain specimen and the other mounted in the direction of axial strain on the bottom side.
  • Completion resistors which provide half-bridge completion.
  • Sensitivity to bending strain.
  • Rejection of axial strain.
  • Compensation for temperature.
  • Sensitivity at 1000 µε is ~ 1 mVout / VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Half-Bridge Type II Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the half-bridge completion resistor.
  • R2 is the half-bridge completion resistor.
  • R3 is the active strain gage element measuring compressive strain (–ε).
  • R4 is the active strain gage resistor measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for half-bridge type II configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, RL is the lead resistance, and Rg is the nominal gage resistance.


Full-Bridge Type I

The full-bridge type I configuration only measures the bending strain.

The following figure shows how to position strain gage resistors in a bending configuration for the full-bridge type I.

Full-bridge type I strain gage configurations have the following characteristics:
  • Four active strain gage elements, two mounted in the direction of bending strain on the top side of the strain specimen and the other two mounted in the direction of bending strain on the bottom side.
  • High sensitivity to bending strain.
  • Rejection of axial strain.
  • Compensation for temperature.
  • Compensation for lead resistance.
  • Sensitivity at 1000 µε is ~ 2.0 mVout / VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Full-Bridge Type I Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the active strain gage element measuring compressive strain (–ε).
  • R2 is the active strain gage element measuring tensile strain (+ε).
  • R3 is the active strain gage element measuring compressive strain (–ε).
  • R4 is the active strain gage element measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for full-bridge type I configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, and GF is the gage factor.


Full-Bridge Type II

The full-bridge type II configuration only measures bending strain.

The following figure shows how to position strain gage elements in a bending configuration for the full-bridge type II.

Full-bridge type II strain gage configurations have the following characteristics:
  • Four active strain gage elements. Two are mounted in the direction of bending strain with one on the top side of the strain specimen and the other on the bottom side. The other two act together as a Poisson gage and are mounted transverse, or perpendicular, to the principal axis of strain with one on the top side of the strain specimen and the other on the bottom side.
  • Rejection of axial strain.
  • Compensation for temperature.
  • Compensation for the aggregate effect on the principle strain measurement due to the Poisson's ratio of the material.
  • Compensation for lead resistance.
  • Sensitivity at 1000 µε is ~ 1.3 mVout / VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Full-Bridge Type II Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the active strain gage element measuring compressive Poisson effect (–ε).
  • R2 is the active strain gage element measuring tensile Poisson effect (+ε).
  • R3 is the active strain gage element measuring compressive strain (–ε).
  • R4 is the active strain gage element measuring tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for full-bridge type II configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, and v is the Poisson's ratio.


Full-Bridge Type III

The following figure shows how to position strain gage resistors in an axial configuration for the full-bridge type III.

The full-bridge type III configuration only measures the axial configuration.

Full-bridge type III strain gage configurations have the following characteristics:
  • Four active strain gage elements. Two are mounted in the direction of axial strain with one on the top side of the strain specimen and the other on the bottom side. The other two act together as a Poisson gage and are mounted transverse, or perpendicular, to the principal axis of strain with one on the top side of the strain specimen and the other on the bottom side.
  • Compensation for temperature.
  • Rejection of bending strain.
  • Compensation for the aggregate effect on the principle strain measurement due to the Poisson's ratio of the material.
  • Compensation for lead resistance.
  • Sensitivity at 1000 µε is ~ 1.3 mVout / VEX input.
Parent topic: Strain Gage Bridge Configurations
Related concepts
Bridge Sensor Scaling

Full-Bridge Type III Circuit Diagram

The following symbols apply to the circuit diagram:
  • R1 is the active strain gage element measuring compressive Poisson effect (–ε).
  • R2 is the active strain gage element measuring tensile strain (+ε).
  • R3 is the active strain gage element measuring compressive Poisson effect (–ε).
  • R4 is the active strain gage element measuring the tensile strain (+ε).
  • VEX is the excitation voltage.
  • RL is the lead resistance.
  • VCH is the measured voltage.

The following equation converts voltage ratios to strain units for full-bridge type III configurations.

where Vr is the voltage ratio that virtual channels use in the voltage-to-strain conversion equation, GF is the gage factor, and v is the Poisson's ratio.


Strain Rosette

A strain gage can measure strain in only one direction—the axis along which the strain gage is mounted. To effectively measure the three independent components of plane strain (extensional strain along X and Y axis, as well as shear strain), three independent strain measurements are needed. Strain gage rosettes are used to perform such measurements.

A strain gage rosette is an arrangement of two or three closely positioned strain gages, separately oriented to measure the strains along different directions of the underlying surface of the object being measured.

Strain-gage manufacturers offer three basic types of strain gage rosettes.

  • Tee Rosette—A tee rosette consists of two gages oriented at 90 degrees with respect to each other.
  • Rectangular Rosette—A rectangular rosette consists of three strain gages, each separated by a 45 degree angle.
  • Delta Rosette—A delta rosette consists of three strain gages, each separated by a 60 degree angle.
Parent topic: Bridge-Based Sensors
Related concepts
Strain Gages


Eddy Current Proximity Probes

Proximity probes are sensors that measure relative proximity. They use changes in voltage to measure shaft surfaces that rotate or reciprocate. Because they are non-contacting transducers, proximity probes are mounted on a reasonably stationary mechanical structure, such as a bearing housing. From the mounting point, they measure the static and dynamic displacement behavior of the moving machinery. Use the proximity probe measurement type when you want to measure a dynamic position, such as an air gap between parts of moving machinery.

Eddy current proximity probes contain a driver and a monitor or regulated DC supply. The monitor or DC supply applies a power input of -24 VDC to the driver. The driver's internal oscillator converts some of the energy into a high-frequency radio signal. The signal is directed to the probe coil through a coaxial cable. The coil at the tip of the probe broadcasts the signal as a magnetic field into the surrounding area. If a conductive material intercepts the magnetic field, eddy currents are generated and the high-frequency radio signal loses power. The closer the conductive material is to the probe tip, the more power the signal loses. This power loss triggers a change in the voltage of the driver.

Proximity probe sensitivity is usually defined as the slope of a calibration curve as follows:

You can calculate the sensitivity by measuring two points in the sensor's dynamic range, using the following formula:

Note Note Proximity probes can differ in sensitivity. Refer to the documentation provided by the proximity probe manufacturer for information specific to your probe.

Offset voltage can occur when the tip of the probe touches the conductive material. Use the following formula to determine the offset voltage where offset is the output voltage of the sensor when the tip contacts the conductive material. In most cases, offset should be 0 V.

After you calibrate your proximity probe, you need to update the sensitivity and offset attributes. You can determine the physical distance between the sensor's tip and the target material by using the following formula:

Parent topic: Common Sensors


Encoders

There are two common types of encoders used for measuring position: two-pulse encoders and quadrature encoders.

Parent topic: Common Sensors
Related concepts
Two-Pulse Encoders
Quadrature Encoders


Quadrature Encoders

Quadrature encoders measure position by causing two signals to pulse while the encoder moves. These signals are signal A (also called channel A) and signal B (also called channel B). Signal A and B are offset by 90°, which determines the direction the encoder moves. For instance, in an angular quadrature encoder, if signal A leads, the encoder rotates clockwise. If signal B leads, the encoder rotates counter clockwise.

Counters on M Series, C Series, NI-TIO devices support three types of decoding for quadrature encoders: X1, X2, and X4. With X1 decoding, when signal A leads signal B, the counter increments on the rising edge of signal A. When signal B leads signal A, the counter decrements on the falling edge of signal A.

With X2 decoding, the same behavior holds as with X1, except the counter increments and decrements on both rising and falling edges of signal A.

Similarly, with X4 decoding, the counter increments and decrements on both rising and falling edges of both signal A and signal B. X4 decoding is more sensitive to position, but is also more likely to provide an incorrect measurement if there is vibration in the encoder.

Many encoders also use z indexing for precise determination of a reference position.

Parent topic: Encoders
Related concepts
Z Indexing


Two-Pulse Encoders

A two pulse encoder is a position measurement sensor that has two channels, A and B. When the encoder is moved, either signal A or signal B on the encoder pulses. A pulse on signal A represents a movement in one direction, and a pulse on signal B represents movement in the opposite direction. When signal A pulses, the counter increments. When signal B pulses, the counter decrements.

Many encoders also use z indexing for precise determination of a reference position.

Parent topic: Encoders
Related concepts
Z Indexing


Z Indexing

Encoders typically use a third signal for Z indexing, which produces a pulse at fixed positions that you can use for precise determination of a reference position. For instance, if the Z index is 45° for an angular encoder, the encoder sends a pulse on the Z input terminal every time the encoder is turned to the 45° mark.

The behavior of signal Z differs with designs. You must refer to the documentation for an encoder to obtain the timing of signal Z in relation to the A and B signals. In NI-DAQmx, you can configure Z indexing with the Z Index Phase attribute/property.

Parent topic: Encoders


Integrated Electronics Piezoelectric (IEPE) and Charge

Integrated Electronics Piezoelectric (IEPE) is a type of transducer that is packaged with a built-in amplifier. Because the charge produced by some sensors is very small, the electrical signal produced by the transducer is susceptible to noise, and sensitive electronics must be used to amplify and condition the signal. An IEPE sensor integrates the sensitive electronics as close as possible to the transducer to ensure better noise immunity and convenient packaging. These sensors require a 4-20 mA current excitation to operate.

Charge Mode Operation

A charge mode sensor is a piezoelectric transducer which requires an amplifier, but unlike IEPE transducers, this amplifier is not built in. This separation of transducer and amplifier allows for the implementation of more complex amplifiers and filters because there is less constraints on physical space and power. The separation of piezoelectric element and signal conditioning also allows the transducer to operate over a higher temperature range. These sensors require no external excitation, but do require a device which has charge mode amplification.

Parent topic: Common Sensors


Accelerometers

An accelerometer, a sensor that represents acceleration as a voltage, comes in two axial types. The most common accelerometer measures acceleration along only a single axis. This type is often used to measure mechanical vibration levels. The second type is a tri-axial accelerometer. This accelerometer can create a 3D vector of acceleration in the form of orthogonal components. Use this type when you need to determine the type of vibration—lateral, transverse, rotational, and so on—that a component is undergoing or the direction of acceleration of the component.

Both types of accelerometers come with either both leads insulated, or isolated, from the case or with one lead grounded to the case. Some accelerometers rely on the piezoelectric effect to generate voltage. To measure acceleration with this type of sensor, the sensor must be connected to a charge-sensitive amplifier.

Other accelerometers have a charge-sensitive amplifier built inside them. This amplifier accepts a constant current source and varies its impedance with respect to a varying charge on the piezoelectric crystal. You can see this change in impedance as a change in voltage across the inputs of the accelerometer. Thus, the accelerometer uses only two wires per axis for both sensor excitation, or current, and signal output, or voltage. The instrumentation for this type of accelerometer consists of a constant current source and an instrumentation, or differential, amplifier. The current source provides the excitation for the built-in amplifier of the sensor, while the instrumentation amplifier measures the voltage potential across the leads of the sensor.

When choosing an accelerometer, pay attention to the most critical parameters. If the sensor must operate in extreme temperatures, you are limited to a sensor that relies on the piezoelectric effect to generate voltage. If the environment is very noisy, a sensor with a charge-sensitive amplifier built in might be the only usable choice.

To reduce errors when using an accelerometer, consider these factors:

  • If the sensor is DC coupled, the DC offset of the accelerometer can drift with both temperature and age. This applies to both types of sensors because charge-sensitive amplifiers are prone to drift. AC coupling the output of the amplifier can minimize the drift in the system.
  • Motors, transformers, and other industrial equipment can induce noise currents in the sensor cables. These currents can be an especially large source of noise with sensor systems that rely on the piezoelectric effect to generate voltage. Carefully routing sensor cables can minimize the noise in the cables.
  • Accelerometers might have ground loops. Some accelerometers have their cases tied to a sense wire, while others are completely isolated from their cases. If you use a case-grounded sensor in a system with a grounded input amplifier, you set up a large ground loop, creating a source of noise.

Parent topic: Integrated Electronics Piezoelectric (IEPE) and Charge
Related concepts
Velocity Transducers


Force Sensors (Piezoelectric)

Piezoelectric force sensors are typically used to measure dynamic force events. Such sensors are divided into two main categories: load cells and impact hammers.

Piezoelectric load cells measure the amount of force transmitted through the sensor in response to an external stimulus, such as shaking or an impact.

Impact hammers allow you to apply an impact to a material and measure the actual amount of force applied. You can then correlate that force to the force measured by a load cell or to readings from accelerometers. Impact hammers can use tips of different size, shape, or material for measuring different frequencies.

Note Note NI-DAQmx supports only bridge-based and IEPE force sensors.

Sensor manufacturers make load cells and impact hammers with varying sensitivity and other characteristics. Refer to the documentation from your sensor manufacturer for specifications and theory of operation for your load cell or impact hammer.

Parent topic: Integrated Electronics Piezoelectric (IEPE) and Charge

Sensor Calibration

Force sensors can drift from their documented sensitivity over time. Calibrating a force sensor involves determining its actual sensitivity. Use ratio calibration with a calibrated accelerometer to determine the actual sensitivity of a force sensor.

Related concepts
Accelerometers
Velocity Transducers


Microphones

A microphone is a transducer that converts acoustical waves into electrical signals. The most common instrumentation microphone, a condenser microphone, uses a capacitive sensing element.

A condenser microphone incorporates a stretched metal diaphragm that forms one plate of a capacitor. A metal disk placed close to the diaphragm acts as a backplate. When a sound field excites the diaphragm, the capacitance between the two plates varies according to the variation in the sound pressure. A stable DC voltage is applied to the plates through a high resistance to keep electrical charges on the plate. The change in the capacitance generates an AC output proportional to the sound pressure. The following figure shows a condenser microphone.

AP = acoustic pressure, 1 = metal diaphragm, 2 = metal disk, 3 = insulator, 4 = case.

An instrumentation microphone usually consists of a microphone cartridge and a pre-amplifier. Sometimes these two components are independent; sometimes the components are combined and cannot be separated.

The major characteristics of a microphone are its sensitivity, usually expressed in mV/Pa, and its frequency response. Microphones are available in different diameters. Common diameters include: 1/8 in., 1/4 in., 1/2 in., and 1 in. Each diameter offers a specific compromise in terms of sensitivity and frequency response.

To reduce errors when using a microphone, keep several factors in mind:
  • For measurements in a free field (a sound field with no major nearby reflections), use a free-field microphone pointed at the source of sound.
  • For measurements in a diffuse field, such as inside in a highly reverberant room, where sound is coming from all directions, use a random incidence microphone.
  • For measurements when the microphone is part of the surface of a room or of the object being measured, use a pressure microphone.
  • For outdoor measurements, fit the microphone with suitable protection against the environment. This may include windscreens, rain caps, and built-in heaters to prevent condensation.
  • To prevent vibrations from influencing the measurement, you might need to shock mount the microphone. Check the microphone specifications for vibration sensitivity.
  • For reproducible measurements, make sure the microphone is mounted firmly and at a precisely reproducible location, both compared to the unit being tested and to the environment.
  • Always calibrate the entire measurement chain, including the microphone, before starting the measurement. For highly critical measurements, as an extra precaution, you may want to perform a new calibration immediately after the measurements are completed to make sure the system is still within tolerances.
Parent topic: Integrated Electronics Piezoelectric (IEPE) and Charge


Velocity Transducers

Velocity transducers are used to measure dynamic velocity such as that produced by a running machine or a vibrating structure.

Older velocity probes use a moving coil in a permanent magnetic field to generate a signal that is proportional to the velocity of the vibration.

More modern implementations operate using the same principles as IEPE accelerometers. Additionally, an integrating circuit is used to convert acceleration to velocity. Use the same best practices for storage and handling, calibration, mounting, and signal conditioning of IEPE velocity sensors as you would for IEPE accelerometers.

Note Note NI-DAQmx supports only IEPE velocity sensors.

Sensor manufacturers make IEPE velocity transducers with varying sensitivity and other characteristics. Use a sensor appropriate for your application.

Parent topic: Integrated Electronics Piezoelectric (IEPE) and Charge
Related concepts
Accelerometers


Overview of Temperature Sensor Types

The three most commonly used transducers for temperature are thermocouples, resistance temperature detectors (RTDs), and thermistors. The following table illustrates some of the capabilities and limitations of these sensors. Use this table as a reference for choosing the right sensor for your temperature measurement application.

Sensor | Advantages | Disadvantages
Thermocouples | wide range, fast response, inexpensive | require CJC, nonlinear
RTDs | rugged, accurate | slow response, require excitation, lead resistance, nonlinear
Thermistors | repeatable, fine resolution, low current, fast response | require excitation, narrow range, nonlinear
Parent topic: Common Sensors
Related concepts
Thermocouples
Resistance Temperature Detectors (RTDs)
Thermistors


Resistance Temperature Detectors (RTDs)

An RTD is a temperature sensing device with resistance that increases with temperature. An RTD is usually constructed with wire coil or deposited film of pure metal. RTDs can be made of different metals and have different nominal resistances, but the most popular RTD is platinum and has a nominal resistance of 100 Ω at 0 °C.

Signal conditioning is generally required to measure temperature using an RTD. Because an RTD is a resistive device, you must pass a current through the device to produce a measurable voltage. Providing current to take a resistive measurement is a form of signal conditioning called current excitation. In addition to producing current excitation for the RTD, signal conditioning amplifies the output voltage signal, and filters the signal to remove unwanted noise. You also can use signal conditioning to electrically isolate the RTD and the monitored system from the DAQ system and the host computer. Refer to Signal Conditioning Requirements for Thermistors and RTDs for more information.

Numerous types of RTDs exist, and they are typically defined by their material, their nominal resistance, and their temperature coefficient of resistance (TCR). The TCR of an RTD is the average temperature coefficient of resistance of the RTD from 0 to 100 °C and is the most common method of specifying the behavior of an RTD. The TCR for platinum RTDs is determined by the Callendar-Van Dusen equation.

Parent topic: Overview of Temperature Sensor Types
Related concepts
Signal Conditioning Requirements for Thermistors and RTDs
Callendar-Van Dusen Equation
Platinum RTD Types
2-Wire Resistance
3-Wire Resistance
4-Wire Resistance


Platinum RTD Types

The following table lists common platinum RTD types and standards. All of these RTD types are supported in NI-DAQmx. Notice that there are some shared standards. The TCR and the Callendar-Van Dusen coefficients are more important than the standards.

Standards Material TCR Typical R0 (Ω) Callendar-Van Dusen Coefficient Notes
  • IEC-751
  • DIN 43760
  • BS 1904
  • ASTM-E1137
  • EN-60751
  • IEC-60751
Platinum 3851
  • 100 Ω
  • 1000 Ω
  • A = 3.9083 × 10-3
  • B = -5.775 × 10-7
  • C = -4.183 × 10-12
Most common RTDs
Low-cost vendor compliant RTD1 Platinum 3750 1000 Ω
  • A = 3.81 × 10-3
  • B = -6.02 × 10-7
  • C = -6.0 × 10-12
Low-cost RTD
JISC 1604 1997 Platinum 3916 100 Ω
  • A = 3.9739 × 10-3
  • B = -5.870 × 10-7
  • C = -4.4 × 10-12
Used primarily in Japan
US Industrial Standard D-100 American Platinum 3920 100 Ω
  • A = 3.9787 × 10-3
  • B = -5.8686 × 10-7
  • C = -4.167 × 10-12
Low-cost RTD
US Industrial Standard American Platinum 3911 100 Ω
  • A = 3.9692 × 10-3
  • B = -5.8495 × 10-7
  • C = -4.233 × 10-12
Low-cost RTD
ITS-90 Platinum 3928 100 Ω
  • A = 3.9888 × 10-3
  • B = -5.915 × 10-7
  • C = -3.85 × 10-12
The definition of temperature
Parent topic: Resistance Temperature Detectors (RTDs)
Related concepts
Callendar-Van Dusen Equation
1 No standard. Check the TCR.


Callendar-Van Dusen Equation

Platinum RTDs use a linearization curve known as the Callendar-Van Dusen equation to measure the temperature of RTDs. The equation is as follows:

Temperatures below 0 °C:

RT = R0[1 + A × T + B × T2 + C × T3 × (T - 100 °C)]

Temperatures above 0 °C:

RT = R0[1 + A × T + B × T2]

Where:

T = temperature in degrees Celsius

RT = RTD resistance at temperature T

R0 = RTD nominal resistance at 0 °C

A, B, and C = coefficients given in the table in Platinum RTD Types.

Parent topic: Resistance Temperature Detectors (RTDs)
Related concepts
Platinum RTD Types


Thermistors

A thermistor is a piece of semiconductor made from metal oxides, pressed into a small bead, disk, wafer, or other shape, heated at high temperatures, and coated with epoxy or glass.

Like RTDs, by passing a current through a thermistor, you can read the voltage across the thermistor and thus determine its temperature. Unlike RTDs, thermistors have a higher resistance (anywhere from 2,000 to 10,000 Ω) and a much higher sensitivity (~200 Ω/°C). However, thermistors are generally used only up to the 300 °C temperature range.

NI-DAQmx scales the resistance of a thermistor to a temperature using the Steinhart-Hart thermistor equation:

where T is the temperature in Kelvins, R is the measured resistance, and A, B, and C are constants provided by the thermistor manufacturer.

Because thermistors have high resistance, lead-wire resistance does not affect the accuracy of the measurements. Unlike RTDs, 2-wire measurements are adequate.

For more information about the signal conditioning requirements of a thermistor, refer to Signal Conditioning Requirements for Thermistors and RTDs.

Parent topic: Overview of Temperature Sensor Types
Related concepts
Signal Conditioning Requirements for Thermistors and RTDs


Signal Conditioning Requirements for Thermistors and RTDs

Thermistors and RTDs require the following signal conditioning:

  • Current Excitation—Because RTDs and thermistors are resistive devices, your DAQ system must provide a current excitation source to measure a voltage across the device. This current source must be constant and precise.
  • 2-, 3-, and 4-Wire Configurations (RTDs only)—RTDs come in 2-, 3-, and 4-wire configurations. Therefore, your system must support the type of RTD you choose. Thermistors are typically 2-wire devices because they have higher resistance characteristics, thus eliminating lead resistance considerations.
  • Linearization —Neither RTD nor thermistor output voltage is linear with temperature. Therefore, your system must perform linearization either in hardware or software.
Parent topic: Thermistors
Related concepts
2-Wire Resistance
3-Wire Resistance
4-Wire Resistance


Thermocouples

Thermocouples are the most commonly used temperature sensors.

A thermocouple is created when two dissimilar metals touch and the contact point produces a small open-circuit voltage that corresponds to temperature. This thermoelectric voltage is known as Seebeck voltage and is nonlinear with respect to temperature. Thermocouples require signal conditioning.

Thermocouple types differ in composition and accurate range:

Thermocouple Type | Positive Conductor | Negative Conductor | Temperature Range (°C) for Polynomial Coefficients or for Table Conversion | Temperature Range (°C) for Inverse Polynomial Coefficients
J | Iron | Constantan | -210 to 1200 | -210 to 1200
K | Chromel | Alumel | -270 to 1372 | -200 to 1372
N | Nicrosil | Nisil | -270 to 1300 | -200 to 1300
R | Platinum-13% Rhodium | Platinum | -50 to 1768 | -50 to 1768
S | Platinum-10% Rhodium | Platinum | -50 to 1768 | -50 to 1768
T | Copper | Constantan | -270 to 400 | -200 to 400
B | Platinum | Rhodium | 0 to 1820 | 250 to 1820
E | Chromel | Constantan | -270 to 1000 | -200 to 1000

Use the temperature ranges for polynomial coefficients when converting temperature to voltage. For most thermocouples, the equation used for converting temperature to voltage is the following:

where E is the voltage in millivolts, t90 is the temperature in degrees Celsius, and ci is the coefficient.

Use the temperature ranges for inverse polynomial coefficients when converting voltage to temperature. For most thermocouples, the equation for converting voltage to temperature is the following:

where t90 is the temperature in degrees Celsius, E is the voltage in millivolts, and Di is the coefficient.

Note Note For coefficients to use with each thermocouple type, visit the NIST ITS-90 thermocouple database available at nist.gov.

Parent topic: Overview of Temperature Sensor Types
Related concepts
Signal Conditioning Requirements for Thermocouples
Related information
nist.gov


Signal Conditioning Requirements for Thermocouples

Thermocouples require the following signal conditioning:

  • Amplification for High-Resolution ADC—Thermocouples generate very low-voltage signals, usually measured in microvolts. To acquire these signals with a measurement device, you must amplify the thermocouple signal to measure it accurately with a standard 12-bit measurement device. Alternatively, you can use a measurement device with a high-resolution ADC. NI recommends a device with 16 bits of resolution and amplification capabilities or a device with 24 bits of resolution.
  • Cold-Junction Compensation—Thermocouples require some form of temperature reference to compensate for unwanted parasitic thermocouples. A parasitic thermocouple is created when you connect a thermocouple to an instrument. Because the terminals on the instrument are made of a different material than the thermocouple wire, voltage is created at the junctions, called cold junctions, which changes the voltage output by the actual thermocouple.

    Traditionally, the temperature reference was 0 °C. The National Institute of Standards and Technology (NIST) thermocouple reference tables are created using this setup. Although an ice bath reference is quite accurate, it is not always practical. A more practical approach is to measure the temperature of the reference junction with a direct-reading temperature sensor, such as a thermistor or an IC sensor, and then subtract the parasitic thermocouple thermoelectric contributions. This process is called cold-junction compensation.

  • Filtering—A thermocouple can act much like an antenna, making it very susceptible to noise from nearby 50/60 Hz power sources. Therefore, apply a 2 Hz or 4 Hz lowpass filter to your thermocouple signal to remove power line noise.
  • Linearization—The output voltage of a thermocouple is not linear with temperature. Therefore, your system must perform linearization either through hardware or software.
Parent topic: Thermocouples


LVDTs

LVDTs operate on the principle of a transformer and consist of a stationary coil assembly and a moveable core. An LVDT measures displacement by associating a specific signal value for any given position of the core. LVDT signal conditioners generate a sine wave for the primary output signal and synchronously demodulate the secondary output signal. The demodulated output is passed through a lowpass filter to remove high-frequency ripple. The resulting output is a DC voltage proportional to core displacement. The sign of the DC voltage indicates whether the displacement is to the left or right.

LVDTs require special electronics designed for the sensor. LVDTs typically have a delay of approximately 10 ms caused by filtering in the signal conditioner.

LVDTs typically come in 4-wire, or open wire, and 5-wire, or ratiometric wire, configurations. Wires from the sensor connect to a signal conditioning circuit that translates the output of the LVDT to a measurable voltage. The method of signal conditioning used on the signals from the first and second secondaries differentiate the 4-wire and 5-wire configurations. In the 4-wire configuration, the sensor only measures the voltage difference between the two secondaries.

The benefit of using a 4-wire configuration is that you require a simpler signal conditioning system. However, temperature changes can alter the efficiency of the magnetic induction of the LVDT. Because the 4-wire scheme is also sensitive to phase changes between the primary and the resulting secondary voltage, long wires or a poor excitation source also can cause problems.

The 5-wire configuration is less sensitive to both temperature changes and phase differences between the primary and the secondaries. The device determines phase information at the signal conditioning circuitry without needing to reference the phase of the primary excitation source. Therefore, you can use longer wires between the LVDT and the signal conditioning circuitry.

LVDTs are extremely rugged, operate over wide temperature ranges, and are insensitive to moisture and dirt. LVDTs are a preferred sensor in harsh environments, where very long life is needed because there are no moving parts in contact or where very low friction is required. Also, LVDT technology lends itself well to applications requiring accurate measurements less than 0.1 in., such as measuring the thickness of sheet material. The main advantage of the LVDT transducer over other types of displacement transducer is the high degree of robustness. Because there is no physical contact across the sensing element, there is no wear in the sensing element.

Because the device relies on the coupling of magnetic flux, an LVDT can have infinite resolution. Therefore, suitable signal conditioning hardware can detect the smallest fraction of movement, and only the resolution of the data acquisition system determines the resolution of the transducer.

Parent topic: Common Sensors


RVDTs

RVDTs are the rotational version of LVDTs and generally operate over an angular range of ±30°–70°. They are available in servo-mount and can rotate through 360° without stopping.

RVDTs require special electronics designed for the sensor. RVDTs typically have a delay of 10 ms caused by required filtering in the signal conditioner. They are extremely rugged and operate over wide temperature ranges. In environments characterized by extremes in temperature and shock, an RVDT is the clear choice for rotational applications when you need more than 70° of measurement range.

Parent topic: Common Sensors
Related concepts
LVDTs


Transducer Electronic Data Sheets (TEDS)

IEEE P1451.4 is an emerging standard for adding plug and play capabilities to analog transducers. The underlying mechanism for plug and play identification is the standardization of a Transducer Electronic Data Sheet (TEDS). A TEDS contains the critical information needed by a device or measurement system to identify, characterize, interface, and properly use signals from an analog sensor. That information includes the sensor's model number, model ID, calibration constants, scaling constants, and more.

A TEDS is deployed for a sensor in one of two ways:
  • A TEDS can reside in embedded memory, typically an EEPROM, within the sensor. To download a TEDS from the sensor, you need TEDS-supported hardware such as the BNC-2096 or the SCXI-1314T. You can then download the TEDS in MAX to use in your application. Refer to the Measurement & Automation Explorer Help for NI-DAQmx for additional information on downloading and using TEDS.
  • A Virtual TEDS can exist as a separate file, downloadable from the internet. A Virtual TEDS extends the benefits of the standardized TEDS to legacy sensors and applications in which the embedded memory or EEPROM is not available. You can download Virtual TEDS from ni.com by typing in the sensor serial number. A Virtual TEDS does not require TEDS-supported hardware.
Parent topic: Common Sensors


Writing Data to TEDS Sensors

Use the Write TEDS Data function/VI to write data to a TEDS sensor. The TEDS data must be in a virtual TEDS file or in a bitstream constructed according to the IEEE 1451.4 specification.

National Instruments provides a LabVIEW library for viewing and editing TEDS bitstreams and virtual TEDS files. You can download the TEDS Library for LabVIEW at ni.com/teds.

Parent topic: Transducer Electronic Data Sheets (TEDS)
Related information
ni.com/teds/

Basic TEDS Data

Some TEDS sensors include a PROM, to which you can write data one time. When you write TEDS data, you can choose to write basic TEDS data to the PROM or to the EEPROM. Basic TEDS data includes the manufacturer ID, model number, serial number, version number, and version letter. If you write basic TEDS data to the PROM, the Write TEDS Data function/VI returns an error if you later attempt to write basic TEDS data to the EEPROM.


Control Overview

In a typical control application, there are one or more process variables that you want to control, such as temperature. Sensors measure the process variable in the dynamic system and provide the data to the control application. The set point is the value you want for the process variable. A comparator determines if a difference exists between the process variable and the set point. If a difference exists and if the control system deems the difference large enough, the compensator processes the data and determines the desired actuator output to drive the system closer to the set point.

For example, in a temperature measurement system, if the actual temperature is 100 °C and the temperature set point is 120 °C, the compensator needs to take some action to raise the temperature. One actuator output might be to drive a heater at 62 percent of its maximum output capacity. The increased heater actuator output causes the system to become warmer, which results in an increased temperature. This kind of system is called a closed-loop control system because the process of reading sensors and calculating the actuator output you want repeats continuously at a fixed loop rate.

Parent topic: Measurement Fundamentals
Related concepts
Proportional-Integral-Derivative (PID)
Real Time
Loop Cycle Time
Jitter Overview for Control Applications
Event Response


Proportional-Integral-Derivative (PID)

The Proportional-Integral-Derivative (PID) algorithm is the most common control algorithm used in industry. Often, people use PID to control processes that include heating and cooling systems, fluid level monitoring, flow control, and pressure control. In PID control, you must specify a process variable and a setpoint. The process variable is the system parameter you want to control, such as temperature, pressure, or flow rate, and the setpoint is the desired value for the parameter you are controlling. A PID controller determines a controller output value, such as the heater power or valve position. The controller applies the controller output value to the system, which in turn drives the process variable toward the setpoint value.

Parent topic: Control Overview


Real Time

Real time means that responses occur in time, or on time. With non-real-time systems, there is no way to ensure that a response occurs within any time period, and operations may finish much later or earlier than expected. In other words, real-time systems are deterministic, which guarantees that operations occur within a given time. Real-time systems are predictable.

For a system to be a real-time system, all parts of it need to be real time. For instance, even though a program runs in a real-time operating system, it does not mean that the program behaves with real-time characteristics. The program may rely on something that does not behave in real-time such as file I/O, which then causes the program to not behave in real-time.

Parent topic: Control Overview


Loop Cycle Time

Many applications that require a real-time operating system are cyclic, such as a control application. The time between the start and finish of each cycle, T, is called the loop cycle time (or sample period). 1/T is the loop rate or sample rate. Even with real-time operating systems, the loop cycle time can vary between cycles, but will not be greater than the maximum jitter.

Parent topic: Control Overview
Related concepts
Jitter Overview for Control Applications


Jitter Overview for Control Applications

For control applications, the amount of time that the loop cycle time varies from the desired time is called jitter. The maximum amount that a loop cycle time varies from the desired loop cycle time is called maximum jitter.

In real-time systems, jitter is bounded. For instance, air bags must deploy within fractions of a second after a critical impact and are thus bound to a maximum jitter. In non-real-time systems, jitter is unbounded—or very large. Waiting for a bus is an example. Suppose that according to the schedule, the bus is supposed to arrive at 11:00 a.m. but actually arrives at 11:05 a.m. one day, 11:30 a.m. the next day, and has a flat tire the day after that. There is no bound on how late the bus could arrive.

Parent topic: Control Overview
Related concepts
Loop Cycle Time


Event Response

Event response applications require a response to a stimulus in a determined amount of time. An example is monitoring the temperature of an engine. When the temperature rises too high, the engine is slowed down. The event, in this case, is the temperature rising above a predetermined level, and the response is the engine slowing down. Another example comes from manufacturing. In a manufacturing line, a system senses when a part is in front of a station (the event) and takes a reading or manipulates the part (the response). If the system does not sense and respond to the presence of that part in a set amount of time, the manufacturing line creates defective parts.

Parent topic: Control Overview


Please enable Javascript to view this file correctly.