List of Buffer Properties

Input

Buffer Size

Onboard Buffer Size

Output

Buffer Size

Onboard Buffer Size


List of Calibration Info Properties

Self Calibration

Is Supported

Last Self Calibration Temperature

External Calibration

Recommended Interval

Last External Calibration Temperature

User-Defined Information

Information

Max Size

More

Device Temperature

Accessory Connection Count

Recommended Accessory Connection Count Limit


List of Channel Properties

Analog Input

Maximum Value

Minimum Value

Custom Scale Name

Measurement Type

Voltage

Units

dB Reference

AC RMS Voltage

Units

Temperature

Units

Thermocouple

Type

Scale Type

CJC Source

CJC Value

CJC Channel

RTD

Type

R0

Custom

A

B

C

Thermistor

A

B

C

R1

Advanced

Force Read From Channel

Current

Units

AC RMS Current

Units

Strain

Units

Force Read From Channel

Strain Gage

Gage Factor

Poisson Ratio

Configuration

Rosette Strain Gage

Rosette Type

Gage Orientation

Strain Channels

Rosette Measurement Type

Resistance

Units

Frequency

Units

Voltage

Threshold Level

Hysteresis

Position

LVDT

Units

Sensitivity

Sensitivity Units

RVDT

Units

Sensitivity

Sensitivity Units

Eddy Current Proximity Probe

Units

Sensitivity

Sensitivity Units

Sound Pressure

Maximum Sound Pressure Level

Units

dB Reference

Microphone

Sensitivity

Acceleration

Units

dB Reference

4 Wire DC Voltage

Sensitivity

Sensitivity Units

Accelerometer

Sensitivity

Sensitivity Units

Charge

Sensitivity

Sensitivity Units

Velocity

Units

IEPE Sensor

dB Reference

Sensitivity

Sensitivity Units

Force

Units

IEPE Sensor

Sensitivity

Sensitivity Units

Pressure

Units

Torque

Units

Bridge

Units

Scaling Parameters

Electrical Units

Physical Units

Scale Type

Two-Point Linear

First

Electrical Value

Physical Value

Second

Electrical Value

Physical Value

Table

Electrical Values

Physical Values

Polynomial

Forward Coefficients

Reverse Coefficients

Charge

Units

TEDS

Is TEDS

Units

General Properties

Input Configuration

Coupling

Impedance

Terminal Configuration

Input Source

Signal Conditioning

Resistance Configuration

Lead Wire Resistance

Bridge

Configuration

Nominal Resistance

Initial Bridge Voltage

Initial Bridge Ratio

Shunt Cal

Shunt Cal Enable

Shunt Cal Select

Shunt Cal A Source

Gain Adjustment

Shunt Cal A Resistor Value

Shunt Cal A Actual Resistor Value

Shunt Cal B Resistor Value

Shunt Cal B Actual Resistor Value

Balance

Coarse Potentiometer

Fine Potentiometer

Current Shunt Resistor

Location

Value

Excitation

Sense

Source

Value

Advanced

Use Excitation For Scaling

Use Multiplexed Excitation

Actual Excitation Value

DC or AC

Voltage or Current

Idle Output Behavior

AC Excitation

Frequency

Synchronization Enable

Wire Mode

Thermocouple

Open Thermocouple Detection Enable

Lead Offset Voltage

Attenuation

Probe Attenuation

Filter

Analog Filter

Lowpass

Enable

Cutoff Frequency

Advanced

Switched Capacitor

Clock Source

External Clock Frequency

External Clock Divisor

Output Clock Divisor

Digital Filter

Enable

Type

Response

Order

Lowpass

Cutoff Frequency

Highpass

Cutoff Frequency

Bandpass

Center Frequency

Width

Notch

Center Frequency

Width

Advanced

Coefficients

Filter Delay

Filter Delay Units

Remove Filter Delay

Filter Delay Adjustment

Averaging Window Size

Digitizer/ADC

Resolution Units

Resolution Value

Raw Sample Size

Raw Sample Justification

Timing Mode

Custom Timing Mode

Dither

Enable

Channel Calibration

Has Valid Calibration Information

Enable Calibration

Apply Calibration If Expired

Scaling Parameters

Scale Type

Table

Pre-Scaled Values

Scaled Values

Polynomial

Forward Coefficients

Reverse Coefficients

Operator Name

Description

Verification

Reference Values

Acquired Values

Advanced

Range

High

Low

DC Offset

Gain

Sample and Hold Enable

High Accuracy Settings

Auto Zero Mode

Data Transfer and Memory

Data Transfer Mechanism

Data Transfer Request Condition

Data Transfer Custom Threshold

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Compression

Raw Data Compression Type

Lossy LSB Removal

Compressed Sample Size

Device Scaling Coefficients

Device Scaling Coefficients

Enhanced Alias Rejection Enable

Open Channel Detection Enable

Analog Output

Maximum Value

Minimum Value

Custom Scale Name

Output Type

Voltage

Units

Current Limit

Current

Units

Function Generation

Type

Frequency

Amplitude

Offset

Square

DutyCycle

Modulation

Type

FM Deviation

General Properties

Output Configuration

Output Impedance

Load Impedance

Idle Output Behavior

Terminal Configuration

DAC

Resolution Units

Resolution Value

Range

High

Low

Reference Voltage

Connect DAC Reference to Ground

Allow Connecting DAC Reference to Ground at Runtime

Source

External Source

Value

Offset Voltage

Source

External Source

Value

Reglitching Enable

Filter

Filter Delay

Filter Delay Units

Filter Delay Adjustment

Advanced

Gain

Gain Value

Data Transfer and Memory

Use Only Onboard Memory

Data Transfer Mechanism

Data Transfer Request Condition

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Device Scaling Coefficients

Device Scaling Coefficients

Enhanced Image Rejection Enable

Digital Input

Invert Lines

Number of Lines

Digital Filter

Enable

Minimum Pulse Width

Enable Bus Mode

Timebase

Source

Rate

Digital Synchronization

Enable

Tristate

Logic Family

General Properties

Advanced

Data Transfer and Memory

Data Transfer Mechanism

Data Transfer Request Condition

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Acquire On

Digital Output

Output Drive Type

Invert Lines

Number of Lines

Tristate

Line States

Start State

Paused State

Done State

Logic Family

Overcurrent

Current Limit

Automatic Re-enable

Re-enable Period

General Properties

Advanced

Data Transfer and Memory

Use Only Onboard Memory

Data Transfer Mechanism

Data Transfer Request Condition

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Generate On

Counter Input

Maximum Value

Minimum Value

Custom Scale Name

Measurement Type

Frequency

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Measurement Specifications

Method

Enable Averaging

High Frequency

Measurement Time

Large Range

Divisor

Period

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Measurement Specifications

Method

Enable Averaging

High Frequency

Measurement Time

Large Range

Divisor

Count Edges

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Count Direction

Direction

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Initial Count

Active Edge

Count Reset

Enable

Reset Count

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Active Edge

Gate

Enable

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Pause When

Duty Cycle

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

StartingEdge

Position

Angular Encoder

Units

Pulses Per Revolution

Initial Angle

Linear Encoder

Units

Distance Per Pulse

Initial Position

Decoding Type

A Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

B Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Z Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Z Index Enable

Z Index Value

Z Index Phase

Pulse Width

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Timestamp

Units

Initial Seconds

GPS

Synchronization Method

Synchronization Source

Velocity

Angular Encoder

Units

Pulses Per Revolution

Linear Encoder

Units

Distance per Pulse

Decoding Type

A Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase Source

Timebase Rate

B Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase Source

Timebase Rate

Advanced

Measurement Time

Divisor

Two Edge Separation

Units

First

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Edge

Second

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Edge

Semi-Period

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Pulse

Frequency

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Time

Units

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

Ticks

Input

Terminal

Terminal Configuration

Logic Level Behavior

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Starting Edge

General Properties

Counter Timebase

Source

Rate

Active Edge

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Input Configuration

Voltage Threshold Level

More

Count

Output State

Terminal Count Reached

Counter Timebase Master Timebase Divisor

Sample Clock Overrun Behavior

Sample Clock Overrun Sentinel Value

Advanced

Data Transfer and Memory

Data Transfer Mechanism

Data Transfer Request Condition

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Number Of Possibly Invalid Samples

Duplicate Count Prevention

Prescaler

Maximum Measurable Period

Counter Output

Output Type

Pulse

Idle State

Output Terminal

Time

Units

High Time

Low Time

Initial Delay

Frequency

Duty Cycle

Units

Frequency

Initial Delay

Ticks

High Ticks

Low Ticks

Initial Delay

General Properties

Counter Timebase

Source

Rate

Active Edge

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

More

Count

Output State

Auto Increment Count

Counter Timebase Master Timebase Divisor

Pulse Done

Enable Initial Delay on Retrigger

Advanced

Constrained Generation Mode

Data Transfer and Memory

Use Only Onboard Memory

Data Transfer Mechanism

Data Transfer Request Condition

USB Transfer Request Size

USB Transfer Request Count

Memory Mapping for Programmed IO Enable

Prescaler

Ready For New Value

General Properties

Channel Type

Physical Channel Name

Description

Is Global


List of Device Properties

Device Is Simulated

Identification

Product Category

Product Type

Product Number

Device Serial Number

Accessory

Product Types

Product Numbers

Serial Numbers

Carrier Serial Number

Chassis

Module Device Names

Triggering

Analog Triggering Supported

Digital Triggering Supported

I/O Type

Analog Input

Physical Channels

Measurement Types

Timing

Maximum Single Channel Rate

Maximum Multiple Channel Rate

Minimum Rate

Simultaneous Sampling Supported

Sample Modes

Trigger

Trigger Usage

Voltage

Ranges

Internal Excitation

Discrete Values

Range Values

Charge

Ranges

Current

Ranges

Internal Excitation

Discrete Values

Bridge

Ranges

Resistance

Ranges

Frequency

Ranges

Gains

Couplings

Filter

Analog Low Pass

Cutoff Frequency

Discrete Values

Range Values

Digital Filter

Types

Low Pass

Cutoff Frequency

Discrete Values

Range Values

Analog Output

Physical Channels

Output Types

Timing

Sample Clock Supported

Sample Modes

Maximum Rate

Minimum Rate

Trigger

Trigger Usage

Voltage

Ranges

Current

Ranges

Gains

Digital Input

Lines

Ports

Timing

Maximum Rate

Trigger

Trigger Usage

Digital Output

Lines

Ports

Timing

Maximum Rate

Trigger

Trigger Usage

Counter Input

Physical Channels

Measurement Types

Trigger

Trigger Usage

Timing

Sample Clock Supported

Sample Modes

Maximum Size

Maximum Timebase

Counter Output

Physical Channels

Output Types

Timing

Sample Clock Supported

SampleModes

Trigger

Trigger Usage

Maximum Size

Maximum Timebase

TEDS

Hardware TEDS Supported

Bus

Number of DMA Channels

Location

Bus Type

PCI

Bus Number

Device Number

PXI

Chassis Number

Slot Number

CompactDAQ

Chassis Device Name

Slot Number

TCP/IP

Hostname

Ethernet IP Address

Wireless IP Address

Terminals


List of Export Signal Properties

Clocks

AI Convert Clock

Output Terminal

Pulse

Polarity

10MHz Reference Clock

Output Terminal

20MHz Timebase

Output Terminal

Sample Clock

Output Behavior

Output Terminal

Delay Offset

Pulse

Polarity

Sample Clock Timebase

Output Terminal

Divided Sample Clock Timebase

Output Terminal

Triggers

Advance Trigger

Output Terminal

Pulse

Polarity

Width Units

Width Value

Pause Trigger

Output Terminal

Level

Active Level

Reference Trigger

Output Terminal

Pulse

Polarity

Start Trigger

Output Terminal

Pulse

Polarity

Events

Advance Complete Event

Output Terminal

Delay Value

Pulse

Polarity

Width Value

AI Hold Complete Event

Output Terminal

Pulse

Polarity

Change Detection Event

Output Terminal

Pulse

Polarity

Counter Output Event

Output Terminal

Output Behavior

Pulse

Polarity

Toggle

Idle State

Handshake Event

Output Terminal

Output Behavior

Delay Value

Interlocked

Asserted Level

Assert on Start

Deassert Delay Value

Pulse

Polarity

Width Value

Ready For Transfer Event

Output Terminal

Level

Active Level

Deassert Condition

Deassert Condition Custom Threshold

Data Active Event

Output Terminal

Level

Active Level

Ready For Start Event

Output Terminal

Level

Active Level

Synchronization Pulse Event

Output Terminal

Watchdog Timer Expired Event

Output Terminal


List of Persisted Channel Properties

Author

Allow Interactive Editing?

Allow Interactive Deletion?


List of Persisted Scale Properties

Author

Allow Interactive Editing?

Allow Interactive Deletion?


List of Persisted Task Properties

Author

Allow Interactive Editing?

Allow Interactive Deletion?


List of Physical Channel Properties

Analog Input

Measurement Types

Input Configuration

Terminal Configurations

Input Sources

Analog Output

Output Types

Power Up Output Types

Output Configuration

Terminal Configurations

Advanced

Manual Control

Enable

Short Detected

Amplitude

Frequency

Power Amplifier

Channel Enable

Scaling Coefficients

Overcurrent

Calibration

Gain

Offset

Digital Input

Port Width

Timing

Sample Clock Supported

Sample Modes

Change Detection Supported

Digital Output

Port Width

Timing

Sample Clock Supported

Sample Modes

Counter Input

Measurement Types

Counter Output

Output Types

TEDS

ManufacturerID

Model Number

Serial Number

Version Number

Version Letter

BitStream

TemplateIDs


List of Read Properties

RelativeTo

Offset

Channels to Read

Read All Available Samples

Auto Start

OverWrite Mode

Logging

File Path

Mode

TDMS

Group Name

Operation

Pause

Samples Per File

File Write Size

File Pre-allocation Size

Status

Current Read Position

Available Samples Per Channel

Total Samples Per Channel Acquired

Common Mode Range Error

Common Mode Range Error Channels Exist

Common Mode Range Error Channels

Excitation Fault

Excitation Fault Channels Exist

Excitation Fault Channels

Overcurrent

Overcurrent Channels Exist

Overcurrent Channels

Overtemperature

Overtemperature Channels Exist

Overtemperature Channels

Open Channels

Open Channels Exist

Open Channels

Open Channels Details

Open Current Loop

Open Current Loop Channels Exist

Open Current Loop Channels

Open Thermocouple

Open Thermocouple Channels Exist

Open Thermocouple Channels

Overload

Overloaded Channels Exist

Overloaded Channels

Accessory

Accessory Insertion or Removal Detected

Devices with Inserted or Removed Accessories

Advanced

ChangeDetection

Overflowed

Advanced

Raw Data Width

Number of Channels

Digital Input

Number of Bytes Per Channel

Wait Mode

Sleep Time


List of Real-Time Properties

Convert Late Errors To Warnings

Number Of Warmup Iterations

Wait For Next Sample Clock Wait Mode

Report Missed Samples

Write Recovery Mode


List of Scale Properties

Description

Scaled Units

Pre-Scaled Units

Scale Type

Linear

Slope

Y-Intercept

Map

Scaled Maximum Value

Pre-Scaled Maximum Value

Scaled Minimum Value

Pre-Scaled Minimum Value

Polynomial

Forward Coefficients

Reverse Coefficients

Table

Scaled Values

Pre-Scaled Values


List of Switch Channel Properties

Deprecated

Usage

Analog Bus Sharing Enable

Capability

Max AC Carry Current

Max AC Switching Current

Max AC Carry Power

Max AC Switching Power

Max DC Carry Current

Max DC Switching Current

Max DC Carry Power

Max DC Switching Power

Max AC Voltage

Max DC Voltage

Wire Mode

Bandwidth

Impedance


List of Switch Device Properties

Deprecated

Settling Time

Auto Connect Analog Bus

Power Down Latching Relays After Settling

Is Settled

Capability

Relay List

Number of Relays

Switch Channel List

Number of Switch Channels

Number of Rows

Number of Columns

Topology

Temperature


List of Switch Scan Properties

Deprecated

Break Mode

Repeat Mode

Is Waiting For Advance


List of System Properties

Global Channels

Scales

Tasks

Device Names

System

NI-DAQ Version

Major

Minor

Update


List of Task Properties

Name

Channels

Number of Channels

Devices

Number of Devices

Task Done


List of Timing Properties

Sample Quantity

Sample Mode

Samples Per Channel

Sample Timing Type

Sample Clock

Rate

Maximum Rate

Source

Active Edge

Overrun Behavior

Underflow Behavior

Timebase Divisor

Terminal

Timebase

Rate

Source

Active Edge

Master Timebase Divisor

Terminal

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Write Waveform

Use Initial Waveform dt

Handshake

Delay After Transfer

Start Condition

Sample Input Data When

Change Detection

Digital Input

Rising Edge Physical Channels

Falling Edge Physical Channels

Tristate

On Demand

Simultaneous Analog Output Enable

Implicit

Underflow Behavior

More

AI Convert

Rate

Maximum Rate

Source

Active Edge

Timebase Divisor

Timebase

Source

Delay From Sample Clock

Delay Units

Delay

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Master Timebase

Rate

Source

Reference Clock

Rate

Source

Synchronization Pulse

Source

Synchronization Time

Minimum Delay To Start

Reset Time

Reset Delay

Terminal

Synchronization Clock

Interval

Advanced

Sample Timing Engine


List of Trigger Properties

Start

Trigger Type

Terminal

Digital Edge

Source

Edge

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Digital Pattern

Source

Pattern

Trigger When

Analog Edge

Source

Slope

Level

Hysteresis

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Analog Window

Source

Trigger When

Top

Bottom

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

More

Delay

Delay Units

Retriggerable

Reference

Trigger Type

Pretrigger Samples per Channel

Terminal

Digital Edge

Source

Edge

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Digital Pattern

Source

Pattern

Trigger When

Analog Edge

Source

Slope

Level

Hysteresis

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Analog Window

Source

Trigger When

Top

Bottom

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Auto Trigger

Enable

Auto Triggered

More

Delay

More

Advance

Trigger Type

Digital Edge

Source

Edge

Digital Filter

Enable

Handshake

Trigger Type

Interlocked

Source

Asserted Level

Pause

Trigger Type

Terminal

Analog Level

Source

Pause When

Level

Hysteresis

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Analog Window

Source

Pause When

Top

Bottom

Coupling

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Digital Level

Source

Pause When

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Digital Pattern

Source

Pattern

Pause When

Arm Start

Trigger Type

Terminal

Digital Edge

Source

Edge

Digital Filter

Enable

Minimum Pulse Width

Timebase

Source

Rate

Digital Synchronization

Enable

Advanced

Synchronization Type


List of Watchdog Properties

Timeout

Expiration Trigger

Trigger Type

Trigger On Network Connection Loss

Digital Edge

Source

Edge

Expiration States

Digital Output

Expiration State

Analog Output

Output Type

Expiration State

Counter Output

Expiration State

Status

Expired


List of Write Properties

Relative To

Offset

Regeneration Mode

Status

Current Write Position

Overcurrent

Overcurrent Channels Exist

Overcurrent Channels

Overtemperature

Overtemperature Channels Exist

Overtemperature Channels

External Overvoltage

External Overvoltage Channels Exist

External Overvoltage Channels

Overload

Overloaded Channels Exist

Overloaded Channels

Open Current Loop

Open Current Loop Channels Exist

Open Current Loop Channels

Power Supply Fault

Power Supply Fault Channels Exist

Power Supply Fault Channels

Space Available in Buffer

Total Samples Per Channel Generated

Accessory

Accessory Insertion or Removal Detected

Devices with Inserted or Removed Accessories

Advanced

Raw Data Width

Number of Channels

Wait Mode

Sleep Time

Digital Output

Number of Booleans Per Channel


Status >> Open Current Loop >> Open Current Loop Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected an open current loop. You must read Open Current Loop Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenCurrentLoopChans


Analog Output >> Function Generation >> Amplitude

Data Type: | float64
Description: | Specifies the zero-to-peak amplitude of the waveform to generate in volts. Zero and negative values are valid.

You can get/set/reset this property using:

DAQmxGetAOFuncGenAmplitude

DAQmxSetAOFuncGenAmplitude

DAQmxResetAOFuncGenAmplitude


Analog Output >> Function Generation >> Offset

Data Type: | float64
Description: | Specifies the voltage offset of the waveform to generate.

You can get/set/reset this property using:

DAQmxGetAOFuncGenOffset

DAQmxSetAOFuncGenOffset

DAQmxResetAOFuncGenOffset


Analog Output >> Function Generation >> Square >> DutyCycle

Data Type: | float64
Description: | Specifies the square wave duty cycle of the waveform to generate.

You can get/set/reset this property using:

DAQmxGetAOFuncGenSquareDutyCycle

DAQmxSetAOFuncGenSquareDutyCycle

DAQmxResetAOFuncGenSquareDutyCycle


Analog Output >> Voltage >> Current Limit

Data Type: | float64
Description: | Specifies the current limit, in amperes, for the voltage channel.

You can get/set/reset this property using:

DAQmxGetAOVoltageCurrentLimit

DAQmxSetAOVoltageCurrentLimit

DAQmxResetAOVoltageCurrentLimit


Analog Output >> Advanced >> Manual Control >> Enable

Data Type: | bool32
Description: | Specifies if you can control the physical channel externally via a manual control located on the device. You cannot simultaneously control a channel manually and with NI-DAQmx.

You can get/set/reset this property using:

DAQmxGetPhysicalChanAOManualControlEnable

DAQmxSetPhysicalChanAOManualControlEnable

DAQmxResetPhysicalChanAOManualControlEnable


Analog Output >> Advanced >> Manual Control >> Amplitude

Data Type: | float64
Description: | Indicates the current value of the front panel amplitude control for the physical channel in volts.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanAOManualControlAmplitude


Identification >> Carrier Serial Number

Data Type: | uInt32
Description: | Indicates the serial number of the device carrier. This value is zero if the carrier does not have a serial number.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCarrierSerialNum


Location >> TCP/IP >> Hostname

Data Type: | char*
Description: | Indicates the IPv4 hostname of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevTCPIPHostname


Location >> TCP/IP >> Ethernet IP Address

Data Type: | char*
Description: | Indicates the IPv4 address of the Ethernet interface in dotted decimal format. This property returns 0.0.0.0 if the Ethernet interface cannot acquire an address.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevTCPIPEthernetIP


Location >> TCP/IP >> Wireless IP Address

Data Type: | char*
Description: | Indicates the IPv4 address of the 802.11 wireless interface in dotted decimal format. This property returns 0.0.0.0 if the wireless interface cannot acquire an address.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevTCPIPWirelessIP


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetAIUsbXferReqSize

DAQmxSetAIUsbXferReqSize

DAQmxResetAIUsbXferReqSize


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetAOUsbXferReqSize

DAQmxSetAOUsbXferReqSize

DAQmxResetAOUsbXferReqSize


Status >> Open Current Loop >> Open Current Loop Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an open current loop for any virtual channel in the task. Reading this property clears the open current loop status for all channels in the task. You must read this property before you read Open Current Loop Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenCurrentLoopChansExist


I/O Type >> Analog Input >> Resistance >> Ranges

Data Type: | float64*
Description: | Indicates pairs of input resistance ranges, in ohms, supported by devices that have the necessary signal conditioning to measure resistances. Each pair consists of the low value followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIResistanceRngs


Analog Output >> Function Generation >> Type

Data Type: | int32
Description: | Specifies the kind of the waveform to generate.

Valid values
DAQmx_Val_Sine | 14751 | Sine wave.
DAQmx_Val_Triangle | 14752 | Triangle wave.
DAQmx_Val_Square | 14753 | Square wave.
DAQmx_Val_Sawtooth | 14754 | Sawtooth wave.

You can get/set/reset this property using:

DAQmxGetAOFuncGenType

DAQmxSetAOFuncGenType

DAQmxResetAOFuncGenType


Analog Output >> Function Generation >> Frequency

Data Type: | float64
Description: | Specifies the frequency of the waveform to generate in hertz.

You can get/set/reset this property using:

DAQmxGetAOFuncGenFreq

DAQmxSetAOFuncGenFreq

DAQmxResetAOFuncGenFreq


Analog Output >> Advanced >> Manual Control >> Frequency

Data Type: | float64
Description: | Indicates the current value of the front panel frequency control for the physical channel in hertz.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanAOManualControlFreq


Analog Output >> Function Generation >> Modulation >> Type

Data Type: | int32
Description: | Specifies if the device generates a modulated version of the waveform using the original waveform as a carrier and input from an external terminal as the signal.

Valid values
DAQmx_Val_AM | 14756 | Amplitude modulation.
DAQmx_Val_FM | 14757 | Frequency modulation.
DAQmx_Val_None | 10230 | No modulation.

You can get/set/reset this property using:

DAQmxGetAOFuncGenModulationType

DAQmxSetAOFuncGenModulationType

DAQmxResetAOFuncGenModulationType


Analog Output >> Function Generation >> Modulation >> FM Deviation

Data Type: | float64
Description: | Specifies the FM deviation in hertz per volt when Type is DAQmx_Val_FM.

You can get/set/reset this property using:

DAQmxGetAOFuncGenFMDeviation

DAQmxSetAOFuncGenFMDeviation

DAQmxResetAOFuncGenFMDeviation


Advanced >> Sample Timing Engine

Data Type: | uInt32
Description: | Specifies which timing engine to use for the task.

You can get/set/reset this property using:

DAQmxGetSampTimingEngine

DAQmxSetSampTimingEngine

DAQmxResetSampTimingEngine


Terminals

Data Type: | char*
Description: | Indicates a list of all terminals on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevTerminals


Status >> Overtemperature >> Overtemperature Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overtemperature condition in any virtual channel in the task. Reading this property clears the overtemperature status for all channels in the task. You must read this property before you read Overtemperature Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOvertemperatureChansExist


Digital Output >> Overcurrent >> Current Limit

Data Type: | float64
Description: | Specifies the current threshold in Amperes for the channel. A value of 0 means the channel observes no limit. Devices can monitor only a finite number of current thresholds simultaneously. If you attempt to monitor additional thresholds, NI-DAQmx returns an error.

You can get/set/reset this property using:

DAQmxGetDOOvercurrentLimit

DAQmxSetDOOvercurrentLimit

DAQmxResetDOOvercurrentLimit


Digital Output >> Overcurrent >> Automatic Re-enable

Data Type: | bool32
Description: | Specifies whether to automatically reenable channels after they no longer exceed the current limit specified by Current Limit.

You can get/set/reset this property using:

DAQmxGetDOOvercurrentAutoReenable

DAQmxSetDOOvercurrentAutoReenable

DAQmxResetDOOvercurrentAutoReenable


Digital Output >> Overcurrent >> Re-enable Period

Data Type: | float64
Description: | Specifies the delay in seconds between the time a channel no longer exceeds the current limit and the reactivation of that channel, if Automatic Re-enable is TRUE.

You can get/set/reset this property using:

DAQmxGetDOOvercurrentReenablePeriod

DAQmxSetDOOvercurrentReenablePeriod

DAQmxResetDOOvercurrentReenablePeriod


Analog Input >> General Properties >> Signal Conditioning >> Probe Attenuation

Data Type: | float64
Description: | Specifies the amount of attenuation provided by the probe connected to the channel. Specify this attenuation as a ratio.

You can get/set/reset this property using:

DAQmxGetAIProbeAtten

DAQmxSetAIProbeAtten

DAQmxResetAIProbeAtten


Analog Input >> General Properties >> Advanced >> DC Offset

Data Type: | float64
Description: | Specifies the DC value to add to the input range of the device. Use High and Low to specify the input range. This offset is in the native units of the device .

You can get/set/reset this property using:

DAQmxGetAIDCOffset

DAQmxSetAIDCOffset

DAQmxResetAIDCOffset


Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetDIUsbXferReqSize

DAQmxSetDIUsbXferReqSize

DAQmxResetDIUsbXferReqSize


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetDOUsbXferReqSize

DAQmxSetDOUsbXferReqSize

DAQmxResetDOUsbXferReqSize


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetCIUsbXferReqSize

DAQmxSetCIUsbXferReqSize

DAQmxResetCIUsbXferReqSize


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size

Data Type: | uInt32
Description: | Specifies the maximum size of a USB transfer request in bytes. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetCOUsbXferReqSize

DAQmxSetCOUsbXferReqSize

DAQmxResetCOUsbXferReqSize


Status >> Open Thermocouple >> Open Thermocouple Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an open thermocouple connected to any virtual channel in the task. Reading this property clears the open thermocouple status for all channels in the task. You must read this property before you read Open Thermocouple Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenThrmcplChansExist


Status >> Open Thermocouple >> Open Thermocouple Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected an open thermcouple. You must read Open Thermocouple Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenThrmcplChans


Status >> Common Mode Range Error >> Common Mode Range Error Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected a common mode range violation for any virtual channel in the task. Common mode range violation occurs when the voltage of either the positive terminal or negative terminal to ground are out of range. Reading this property clears the common mode range violation status for all channels in the task. You must read this property before you read Common Mode Range Error Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadCommonModeRangeErrorChansExist


Status >> Common Mode Range Error >> Common Mode Range Error Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected a common mode range violation. You must read Common Mode Range Error Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadCommonModeRangeErrorChans


Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the eddy current proximity probe . This value is in the units you specify with Sensitivity Units. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIEddyCurrentProxProbeSensitivity

DAQmxSetAIEddyCurrentProxProbeSensitivity

DAQmxResetAIEddyCurrentProxProbeSensitivity


Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of Sensitivity.

Valid values
DAQmx_Val_mVoltsPerMil | 14836 | mVolts/mil.
DAQmx_Val_VoltsPerMil | 14837 | Volts/mil.
DAQmx_Val_mVoltsPerMillimeter | 14838 | mVolts/mMeter.
DAQmx_Val_VoltsPerMillimeter | 14839 | Volts/mMeter.
DAQmx_Val_mVoltsPerMicron | 14840 | mVolts/micron.

You can get/set/reset this property using:

DAQmxGetAIEddyCurrentProxProbeSensitivityUnits

DAQmxSetAIEddyCurrentProxProbeSensitivityUnits

DAQmxResetAIEddyCurrentProxProbeSensitivityUnits


Analog Input >> Position >> Eddy Current Proximity Probe >> Units

Data Type: | int32
Description: | Specifies the units to use to return proximity measurements from the channel.

Valid values
DAQmx_Val_Meters | 10219 | Meters.
DAQmx_Val_Inches | 10379 | Inches.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIEddyCurrentProxProbeUnits

DAQmxSetAIEddyCurrentProxProbeUnits

DAQmxResetAIEddyCurrentProxProbeUnits


Reference >> Auto Trigger >> Enable

Data Type: | bool32
Description: | Specifies whether to send a software trigger to the device when a hardware trigger is no longer active in order to prevent a timeout.

You can get/set/reset this property using:

DAQmxGetRefTrigAutoTrigEnable

DAQmxSetRefTrigAutoTrigEnable

DAQmxResetRefTrigAutoTrigEnable


Reference >> Auto Triggered

Data Type: | bool32
Description: | Indicates whether a completed acquisition was triggered by the auto trigger. If an acquisition has not completed after the task starts, this property returns FALSE. This property is only applicable when Enable is TRUE.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetRefTrigAutoTriggered


Analog Output >> Advanced >> Manual Control >> Short Detected

Data Type: | bool32
Description: | Indicates whether the physical channel is currently disabled due to a short detected on the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanAOManualControlShortDetected


Logging >> File Path

Data Type: | char*
Description: | Specifies the path to the TDMS file to which you want to log data. If the file path is changed while the task is running, this takes effect on the next sample interval (if Logging.SampsPerFile has been set) or when DAQmx Start New File is called. New file paths can be specified by ending with "\" or "/". Files created after specifying a new file path retain the same name and numbering sequence.

You can get/set/reset this property using:

DAQmxGetLoggingFilePath

DAQmxSetLoggingFilePath

DAQmxResetLoggingFilePath


Logging >> Mode

Data Type: | int32
Description: | Specifies whether to enable logging and whether to allow reading data while logging. Log mode allows for the best performance. However, you cannot read data while logging if you specify this mode. If you want to read data while logging, specify Log and Read mode.

Valid values
DAQmx_Val_Off | 10231 | Disable logging for the task.
DAQmx_Val_Log | 15844 | Enable logging for the task. You cannot read data using an NI-DAQmx Read function when using this mode. If you require access to the data, read from the TDMS file.
DAQmx_Val_LogAndRead | 15842 | Enable both logging and reading data for the task. You must use an NI-DAQmx Read function to read samples for NI-DAQmx to stream them to disk.

You can get/set/reset this property using:

DAQmxGetLoggingMode

DAQmxSetLoggingMode

DAQmxResetLoggingMode


Logging >> TDMS >> Group Name

Data Type: char*
Description: Specifies the name of the group to create within the TDMS file for data from this task. If you append data to an existing file and the specified group already exists, NI-DAQmx appends a number symbol and a number to the group name, incrementing that number until finding a group name that does not exist. For example, if you specify a group name of Voltage Task, and that group already exists, NI-DAQmx assigns the group name Voltage Task #1, then Voltage Task #2.

For digital input tasks, NI-DAQmx creates a group for each virtual channel in the task. For each created group, NI-DAQmx appends a hyphen and the virtual channel name to the group name.

If you query this property, NI-DAQmx returns the original value specified without any suffixes appended by NI-DAQmx for digital input tasks or for existing groups.

You can get/set/reset this property using:

DAQmxGetLoggingTDMSGroupName

DAQmxSetLoggingTDMSGroupName

DAQmxResetLoggingTDMSGroupName


Logging >> TDMS >> Operation

Data Type: | int32
Description: | Specifies how to open the TDMS file.

Valid values
DAQmx_Val_Open | 10437 | Open an existing TDMS file, and append data to that file. If the file does not exist, NI-DAQmx returns an error.
DAQmx_Val_OpenOrCreate | 15846 | Open an existing TDMS file, and append data to that file. If the file does not exist, NI-DAQmx creates a new TDMS file.
DAQmx_Val_CreateOrReplace | 15847 | Create a new TDMS file, or replace an existing TDMS file.
DAQmx_Val_Create | 15848 | Create a new TDMS file. If the file already exists, NI-DAQmx returns an error.

You can get/set/reset this property using:

DAQmxGetLoggingTDMSOperation

DAQmxSetLoggingTDMSOperation

DAQmxResetLoggingTDMSOperation


Counter Output >> General Properties >> More >> Enable Initial Delay on Retrigger

Data Type: | bool32
Description: | Specifies whether to apply the initial delay to retriggered pulse trains.

You can get/set/reset this property using:

DAQmxGetCOEnableInitialDelayOnRetrigger

DAQmxSetCOEnableInitialDelayOnRetrigger

DAQmxResetCOEnableInitialDelayOnRetrigger


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory

Data Type: | bool32
Description: | Specifies whether to write samples directly to the onboard memory of the device, bypassing the memory buffer. Generally, you cannot update onboard memory directly after you start the task. Onboard memory includes data FIFOs.

You can get/set/reset this property using:

DAQmxGetCOUseOnlyOnBrdMem

DAQmxSetCOUseOnlyOnBrdMem

DAQmxResetCOUseOnlyOnBrdMem


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the device. For buffered operations, use DMA or USB Bulk. For non-buffered operations, use Polled.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetCODataXferMech

DAQmxSetCODataXferMech

DAQmxResetCODataXferMech


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the buffer to the onboard memory of the device.

Valid values
DAQmx_Val_OnBrdMemEmpty | 10235 | Transfer data to the device only when there is no data in the onboard memory of the device.
DAQmx_Val_OnBrdMemHalfFullOrLess | 10239 | Transfer data to the device any time the onboard memory is less than half full.
DAQmx_Val_OnBrdMemNotFull | 10242 | Transfer data to the device any time the onboard memory of the device is not full.

You can get/set/reset this property using:

DAQmxGetCODataXferReqCond

DAQmxSetCODataXferReqCond

DAQmxResetCODataXferReqCond


Counter Input >> Frequency >> Measurement Specifications >> Enable Averaging

Data Type: | bool32
Description: | Specifies whether to enable averaging mode for Sample Clock-timed frequency measurements.

You can get/set/reset this property using:

DAQmxGetCIFreqEnableAveraging

DAQmxSetCIFreqEnableAveraging

DAQmxResetCIFreqEnableAveraging


Counter Input >> Period >> Measurement Specifications >> Enable Averaging

Data Type: | bool32
Description: | Specifies whether to enable averaging mode for Sample Clock-timed period measurements.

You can get/set/reset this property using:

DAQmxGetCIPeriodEnableAveraging

DAQmxSetCIPeriodEnableAveraging

DAQmxResetCIPeriodEnableAveraging


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetCIMemMapEnable

DAQmxSetCIMemMapEnable

DAQmxResetCIMemMapEnable


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetCOMemMapEnable

DAQmxSetCOMemMapEnable

DAQmxResetCOMemMapEnable


Digital Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetDIDigFltrTimebaseSrc

DAQmxSetDIDigFltrTimebaseSrc

DAQmxResetDIDigFltrTimebaseSrc


Digital Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetDIDigFltrTimebaseRate

DAQmxSetDIDigFltrTimebaseRate

DAQmxResetDIDigFltrTimebaseRate


Digital Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetDIDigSyncEnable

DAQmxSetDIDigSyncEnable

DAQmxResetDIDigSyncEnable


Reference >> Digital Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the trigger signal.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigDigFltrEnable

DAQmxSetDigEdgeRefTrigDigFltrEnable

DAQmxResetDigEdgeRefTrigDigFltrEnable


Reference >> Digital Edge >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigDigFltrMinPulseWidth

DAQmxSetDigEdgeRefTrigDigFltrMinPulseWidth

DAQmxResetDigEdgeRefTrigDigFltrMinPulseWidth


Reference >> Digital Edge >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigDigFltrTimebaseSrc

DAQmxSetDigEdgeRefTrigDigFltrTimebaseSrc

DAQmxResetDigEdgeRefTrigDigFltrTimebaseSrc


Reference >> Digital Edge >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigDigFltrTimebaseRate

DAQmxSetDigEdgeRefTrigDigFltrTimebaseRate

DAQmxResetDigEdgeRefTrigDigFltrTimebaseRate


Reference >> Digital Edge >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigDigSyncEnable

DAQmxSetDigEdgeRefTrigDigSyncEnable

DAQmxResetDigEdgeRefTrigDigSyncEnable


More >> AI Convert >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the AI Convert Clock.

You can get/set/reset this property using:

DAQmxGetAIConvDigFltrEnable

DAQmxSetAIConvDigFltrEnable

DAQmxResetAIConvDigFltrEnable

DAQmxGetAIConvDigFltrEnableEx

DAQmxSetAIConvDigFltrEnableEx

DAQmxResetAIConvDigFltrEnableEx


More >> AI Convert >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAIConvDigFltrMinPulseWidth

DAQmxSetAIConvDigFltrMinPulseWidth

DAQmxResetAIConvDigFltrMinPulseWidth

DAQmxGetAIConvDigFltrMinPulseWidthEx

DAQmxSetAIConvDigFltrMinPulseWidthEx

DAQmxResetAIConvDigFltrMinPulseWidthEx


More >> AI Convert >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAIConvDigFltrTimebaseSrc

DAQmxSetAIConvDigFltrTimebaseSrc

DAQmxResetAIConvDigFltrTimebaseSrc

DAQmxGetAIConvDigFltrTimebaseSrcEx

DAQmxSetAIConvDigFltrTimebaseSrcEx

DAQmxResetAIConvDigFltrTimebaseSrcEx


More >> AI Convert >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAIConvDigFltrTimebaseRate

DAQmxSetAIConvDigFltrTimebaseRate

DAQmxResetAIConvDigFltrTimebaseRate

DAQmxGetAIConvDigFltrTimebaseRateEx

DAQmxSetAIConvDigFltrTimebaseRateEx

DAQmxResetAIConvDigFltrTimebaseRateEx


More >> AI Convert >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAIConvDigSyncEnable

DAQmxSetAIConvDigSyncEnable

DAQmxResetAIConvDigSyncEnable

DAQmxGetAIConvDigSyncEnableEx

DAQmxSetAIConvDigSyncEnableEx

DAQmxResetAIConvDigSyncEnableEx


Start >> Analog Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay above or below the trigger level for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the hysteresis window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigDigFltrEnable

DAQmxSetAnlgEdgeStartTrigDigFltrEnable

DAQmxResetAnlgEdgeStartTrigDigFltrEnable


Start >> Analog Edge >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigDigFltrMinPulseWidth

DAQmxSetAnlgEdgeStartTrigDigFltrMinPulseWidth

DAQmxResetAnlgEdgeStartTrigDigFltrMinPulseWidth


Start >> Analog Edge >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseSrc

DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseSrc

DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseSrc


Start >> Analog Edge >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseRate

DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseRate

DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseRate


Start >> Analog Edge >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigDigSyncEnable

DAQmxSetAnlgEdgeStartTrigDigSyncEnable

DAQmxResetAnlgEdgeStartTrigDigSyncEnable


Reference >> Analog Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay above or below the trigger level for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the hysteresis window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigDigFltrEnable

DAQmxSetAnlgEdgeRefTrigDigFltrEnable

DAQmxResetAnlgEdgeRefTrigDigFltrEnable


Reference >> Analog Edge >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width thefilter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigDigFltrMinPulseWidth

DAQmxSetAnlgEdgeRefTrigDigFltrMinPulseWidth

DAQmxResetAnlgEdgeRefTrigDigFltrMinPulseWidth


Reference >> Analog Edge >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseSrc

DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseSrc

DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseSrc


Reference >> Analog Edge >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseRate

DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseRate

DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseRate


Reference >> Analog Edge >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigDigSyncEnable

DAQmxSetAnlgEdgeRefTrigDigSyncEnable

DAQmxResetAnlgEdgeRefTrigDigSyncEnable


Reference >> Analog Window >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay within the trigger window for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigDigFltrEnable

DAQmxSetAnlgWinRefTrigDigFltrEnable

DAQmxResetAnlgWinRefTrigDigFltrEnable


Reference >> Analog Window >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigDigFltrMinPulseWidth

DAQmxSetAnlgWinRefTrigDigFltrMinPulseWidth

DAQmxResetAnlgWinRefTrigDigFltrMinPulseWidth


Reference >> Analog Window >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigDigFltrTimebaseSrc

DAQmxSetAnlgWinRefTrigDigFltrTimebaseSrc

DAQmxResetAnlgWinRefTrigDigFltrTimebaseSrc


Reference >> Analog Window >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigDigFltrTimebaseRate

DAQmxSetAnlgWinRefTrigDigFltrTimebaseRate

DAQmxResetAnlgWinRefTrigDigFltrTimebaseRate


Reference >> Analog Window >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigDigSyncEnable

DAQmxSetAnlgWinRefTrigDigSyncEnable

DAQmxResetAnlgWinRefTrigDigSyncEnable


More >> Pause >> Analog Level >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay above or below the trigger level for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the hysteresis window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigDigFltrEnable

DAQmxSetAnlgLvlPauseTrigDigFltrEnable

DAQmxResetAnlgLvlPauseTrigDigFltrEnable


More >> Pause >> Analog Level >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigDigFltrMinPulseWidth

DAQmxSetAnlgLvlPauseTrigDigFltrMinPulseWidth

DAQmxResetAnlgLvlPauseTrigDigFltrMinPulseWidth


More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseSrc

DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseSrc

DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseSrc


More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseRate

DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseRate

DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseRate


More >> Pause >> Analog Level >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigDigSyncEnable

DAQmxSetAnlgLvlPauseTrigDigSyncEnable

DAQmxResetAnlgLvlPauseTrigDigSyncEnable


More >> Pause >> Analog Window >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay within the trigger window for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigDigFltrEnable

DAQmxSetAnlgWinPauseTrigDigFltrEnable

DAQmxResetAnlgWinPauseTrigDigFltrEnable


More >> Pause >> Analog Window >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigDigFltrMinPulseWidth

DAQmxSetAnlgWinPauseTrigDigFltrMinPulseWidth

DAQmxResetAnlgWinPauseTrigDigFltrMinPulseWidth


More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigDigFltrTimebaseSrc

DAQmxSetAnlgWinPauseTrigDigFltrTimebaseSrc

DAQmxResetAnlgWinPauseTrigDigFltrTimebaseSrc


More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigDigFltrTimebaseRate

DAQmxSetAnlgWinPauseTrigDigFltrTimebaseRate

DAQmxResetAnlgWinPauseTrigDigFltrTimebaseRate


More >> Pause >> Analog Window >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigDigSyncEnable

DAQmxSetAnlgWinPauseTrigDigSyncEnable

DAQmxResetAnlgWinPauseTrigDigSyncEnable


Change Detection >> Digital Input >> Tristate

Data Type: | bool32
Description: | Specifies whether to tristate lines specified with Rising Edge Physical Channels and Falling Edge Physical Channels that are not in a virtual channel in the task. If you set this property to TRUE, NI-DAQmx tristates rising/falling edge lines that are not in a virtual channel in the task. If you set this property to FALSE, NI-DAQmx does not modify the configuration of rising/falling edge lines that are not in a virtual channel in the task, even if the lines were previously tristated. Set this property to FALSE to detect changes on lines in other tasks or to detect changes on output-only lines.

You can get/set/reset this property using:

DAQmxGetChangeDetectDITristate

DAQmxSetChangeDetectDITristate

DAQmxResetChangeDetectDITristate


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the onboard memory of the device to the buffer.

Valid values
DAQmx_Val_OnBrdMemMoreThanHalfFull | 10237 | Transfer data from the device when more than half of the onboard memory of the device fills.
DAQmx_Val_OnBrdMemNotEmpty | 10241 | Transfer data from the device when there is data in the onboard memory.
DAQmx_Val_OnbrdMemCustomThreshold | 12577 | Transfer data from the device when the number of samples specified with Data Transfer Custom Threshold are in the device FIFO.
DAQmx_Val_WhenAcqComplete | 12546 | Transfer data when the acquisition is complete.

You can get/set/reset this property using:

DAQmxGetCIDataXferReqCond

DAQmxSetCIDataXferReqCond

DAQmxResetCIDataXferReqCond


Sample Clock >> Overrun Behavior

Data Type: | int32
Description: | Specifies the action to take if Sample Clock edges occur faster than the device can handle them.

Valid values
DAQmx_Val_StopTaskAndError | 15862 | Stop task and return an error.
DAQmx_Val_IgnoreOverruns | 15863 | NI-DAQmx ignores Sample Clock overruns, and the task continues to run.

You can get/set/reset this property using:

DAQmxGetSampClkOverrunBehavior

DAQmxSetSampClkOverrunBehavior

DAQmxResetSampClkOverrunBehavior


Implicit >> Underflow Behavior

Data Type: | int32
Description: | Specifies the action to take when the onboard memory of the device becomes empty.

Valid values
DAQmx_Val_HaltOutputAndError | 14615 | Stop generating samples and return an error.
DAQmx_Val_PauseUntilDataAvailable | 14616 | Pause the task until samples are available in the FIFO.

You can get/set/reset this property using:

DAQmxGetImplicitUnderflowBehavior

DAQmxSetImplicitUnderflowBehavior

DAQmxResetImplicitUnderflowBehavior


Digital Input >> Digital Filter >> Enable Bus Mode

Data Type: | bool32
Description: | Specifies whether to enable bus mode for digital filtering. If you set this property to TRUE, NI-DAQmx treats all lines that use common filtering settings as a bus. If any line in the bus has jitter, all lines in the bus hold state until the entire bus stabilizes, or until 2 times the minimum pulse width elapses. If you set this property to FALSE, NI-DAQmx filters all lines individually. Jitter in one line does not affect other lines.

You can get/set/reset this property using:

DAQmxGetDIDigFltrEnableBusMode

DAQmxSetDIDigFltrEnableBusMode

DAQmxResetDIDigFltrEnableBusMode


Start >> Analog Window >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the digital output of the analog triggering circuitry (the Analog Comparison Event). When enabled, the analog signal must stay within the trigger window for the minimum pulse width before being recognized. Use filtering for noisy trigger signals that transition in and out of the window rapidly.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigDigFltrEnable

DAQmxSetAnlgWinStartTrigDigFltrEnable

DAQmxResetAnlgWinStartTrigDigFltrEnable


Start >> Analog Window >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigDigFltrMinPulseWidth

DAQmxSetAnlgWinStartTrigDigFltrMinPulseWidth

DAQmxResetAnlgWinStartTrigDigFltrMinPulseWidth


Counter Input >> Pulse >> Frequency >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqDigSyncEnable

DAQmxSetCIPulseFreqDigSyncEnable

DAQmxResetCIPulseFreqDigSyncEnable


Counter Input >> Pulse >> Frequency >> Units

Data Type: | int32
Description: | Specifies the units to use to return pulse specifications in terms of frequency.

Valid values
DAQmx_Val_Hz 10373 Hertz.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqUnits

DAQmxSetCIPulseFreqUnits

DAQmxResetCIPulseFreqUnits


Counter Input >> Pulse >> Time >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeTerm

DAQmxSetCIPulseTimeTerm

DAQmxResetCIPulseTimeTerm


Counter Input >> Pulse >> Time >> Starting Edge

Data Type: | int32
Description: | Specifies on which edge of the input signal to begin pulse measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIPulseTimeStartEdge

DAQmxSetCIPulseTimeStartEdge

DAQmxResetCIPulseTimeStartEdge


Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeDigFltrEnable

DAQmxSetCIPulseTimeDigFltrEnable

DAQmxResetCIPulseTimeDigFltrEnable


Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeDigFltrMinPulseWidth

DAQmxSetCIPulseTimeDigFltrMinPulseWidth

DAQmxResetCIPulseTimeDigFltrMinPulseWidth


Start >> Analog Window >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigDigFltrTimebaseSrc

DAQmxSetAnlgWinStartTrigDigFltrTimebaseSrc

DAQmxResetAnlgWinStartTrigDigFltrTimebaseSrc


Counter Input >> Pulse >> Ticks >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksDigSyncEnable

DAQmxSetCIPulseTicksDigSyncEnable

DAQmxResetCIPulseTicksDigSyncEnable


Sample Clock >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Sample Clock terminal for the task. This property does not return the name of the Sample Clock source terminal specified with Source.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSampClkTerm


Sample Clock >> Timebase >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Sample Clock Timebase terminal for the task. This property does not return the name of the Sample Clock Timebase source terminal specified with Source.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSampClkTimebaseTerm


Start >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Start Trigger terminal for the task. This property does not return the name of the trigger source terminal.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetStartTrigTerm


Reference >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Reference Trigger terminal for the task. This property does not return the name of the trigger source terminal.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetRefTrigTerm


Start >> Analog Window >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigDigFltrTimebaseRate

DAQmxSetAnlgWinStartTrigDigFltrTimebaseRate

DAQmxResetAnlgWinStartTrigDigFltrTimebaseRate


Start >> Analog Window >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigDigSyncEnable

DAQmxSetAnlgWinStartTrigDigSyncEnable

DAQmxResetAnlgWinStartTrigDigSyncEnable


Counter Input >> Pulse >> Frequency >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqTerm

DAQmxSetCIPulseFreqTerm

DAQmxResetCIPulseFreqTerm


Counter Input >> Pulse >> Frequency >> Starting Edge

Data Type: | int32
Description: | Specifies on which edge of the input signal to begin pulse measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIPulseFreqStartEdge

DAQmxSetCIPulseFreqStartEdge

DAQmxResetCIPulseFreqStartEdge


I/O Type >> Counter Output >> Timing >> Sample Clock Supported

Data Type: | bool32
Description: | Indicates if the device supports Sample Clock timing for counter output tasks.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCOSampClkSupported


Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqDigFltrEnable

DAQmxSetCIPulseFreqDigFltrEnable

DAQmxResetCIPulseFreqDigFltrEnable


Analog Input >> General Properties >> Digitizer/ADC >> Custom Timing Mode

Data Type: | uInt32
Description: | Specifies the timing mode of the ADC when Timing Mode is DAQmx_Val_Custom.

You can get/set/reset this property using:

DAQmxGetAIADCCustomTimingMode

DAQmxSetAIADCCustomTimingMode

DAQmxResetAIADCCustomTimingMode


Identification >> Accessory >> Product Types

Data Type: | char*
Description: | Indicates the model names of accessories connected to the device. Each array element corresponds to a connector. For example, index 0 corresponds to connector 0. The array contains an empty string for each connector with no accessory connected.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAccessoryProductTypes


Identification >> Accessory >> Product Numbers

Data Type: | uInt32*
Description: | Indicates the unique hardware identification number for accessories connected to the device. Each array element corresponds to a connector. For example, index 0 corresponds to connector 0. The array contains 0 for each connector with no accessory connected.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAccessoryProductNums


Identification >> Accessory >> Serial Numbers

Data Type: | uInt32*
Description: | Indicates the serial number for accessories connected to the device. Each array element corresponds to a connector. For example, index 0 corresponds to connector 0. The array contains 0 for each connector with no accessory connected.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAccessorySerialNums


Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqDigFltrMinPulseWidth

DAQmxSetCIPulseFreqDigFltrMinPulseWidth

DAQmxResetCIPulseFreqDigFltrMinPulseWidth


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Resistor Value

Data Type: | float64
Description: | Specifies in ohms the desired value of the internal shunt calibration B resistor.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalShuntCalBResistance

DAQmxSetAIBridgeShuntCalShuntCalBResistance

DAQmxResetAIBridgeShuntCalShuntCalBResistance


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Actual Resistor Value

Data Type: | float64
Description: | Specifies in ohms the actual value of the internal shunt calibration B resistor.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalShuntCalBActualResistance

DAQmxSetAIBridgeShuntCalShuntCalBActualResistance

DAQmxResetAIBridgeShuntCalShuntCalBActualResistance


More >> Synchronization Pulse >> Reset Time

Data Type: | float64
Description: | Indicates in seconds the amount of time required for the ADCs or DACs on the device to reset. When synchronizing devices, query this property on all devices and note the largest reset time. Then, for each device, subtract the value of this property from the largest reset time and set Reset Delay to the resulting value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSyncPulseResetTime


More >> Synchronization Pulse >> Reset Delay

Data Type: | float64
Description: | Specifies in seconds the amount of time to wait after the Synchronization Pulse before resetting the ADCs or DACs on the device. When synchronizing devices, query Reset Time on all devices and note the largest reset time. Then, for each device, subtract the reset time from the largest reset time and set this property to the resulting value.

You can get/set/reset this property using:

DAQmxGetSyncPulseResetDelay

DAQmxSetSyncPulseResetDelay

DAQmxResetSyncPulseResetDelay


More >> Synchronization Clock >> Interval

Data Type: | uInt32
Description: | Specifies the interval, in Sample Clock periods, between each internal Synchronization Clock pulse. NI-DAQmx uses this pulse for synchronization of triggers between multiple devices at different rates. Refer to device documentation for information about how to calculate this value.

You can get/set/reset this property using:

DAQmxGetSyncClkInterval

DAQmxSetSyncClkInterval

DAQmxResetSyncClkInterval


More >> Arm Start >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Arm Start Trigger terminal for the task. This property does not return the name of the trigger source terminal.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetArmStartTerm


Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqDigFltrTimebaseSrc

DAQmxSetCIPulseFreqDigFltrTimebaseSrc

DAQmxResetCIPulseFreqDigFltrTimebaseSrc


Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Electrical Value

Data Type: | float64
Description: | Specifies the first electrical value, corresponding to Physical Value. Specify this value in the unit indicated by Electrical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTwoPointLinFirstElectricalVal

DAQmxSetAIBridgeTwoPointLinFirstElectricalVal

DAQmxResetAIBridgeTwoPointLinFirstElectricalVal


Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Physical Value

Data Type: | float64
Description: | Specifies the first physical value, corresponding to Electrical Value. Specify this value in the unit indicated by Physical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTwoPointLinFirstPhysicalVal

DAQmxSetAIBridgeTwoPointLinFirstPhysicalVal

DAQmxResetAIBridgeTwoPointLinFirstPhysicalVal


Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Electrical Value

Data Type: | float64
Description: | Specifies the second electrical value, corresponding to Physical Value. Specify this value in the unit indicated by Electrical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTwoPointLinSecondElectricalVal

DAQmxSetAIBridgeTwoPointLinSecondElectricalVal

DAQmxResetAIBridgeTwoPointLinSecondElectricalVal


Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Physical Value

Data Type: | float64
Description: | Specifies the second physical value, corresponding to Electrical Value. Specify this value in the unit indicated by Physical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTwoPointLinSecondPhysicalVal

DAQmxSetAIBridgeTwoPointLinSecondPhysicalVal

DAQmxResetAIBridgeTwoPointLinSecondPhysicalVal


Analog Input >> Bridge >> Scaling Parameters >> Table >> Electrical Values

Data Type: | float64*
Description: | Specifies the array of electrical values that map to the values in Physical Values. Specify this value in the unit indicated by Electrical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTableElectricalVals

DAQmxSetAIBridgeTableElectricalVals

DAQmxResetAIBridgeTableElectricalVals


Analog Input >> Bridge >> Scaling Parameters >> Table >> Physical Values

Data Type: | float64*
Description: | Specifies the array of physical values that map to the values in Electrical Values. Specify this value in the unit indicated by Physical Units.

You can get/set/reset this property using:

DAQmxGetAIBridgeTablePhysicalVals

DAQmxSetAIBridgeTablePhysicalVals

DAQmxResetAIBridgeTablePhysicalVals


Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqDigFltrTimebaseRate

DAQmxSetCIPulseFreqDigFltrTimebaseRate

DAQmxResetCIPulseFreqDigFltrTimebaseRate


Deprecated >> Analog Bus Sharing Enable

Data Type: | bool32
Description: | (Deprecated) Specifies whether to enable sharing of an analog bus line so that multiple switch devices can connect to it simultaneously. For each device that will share the analog bus line, set this property to TRUE to enable sharing on the channel that connects to the analog bus line. Analog bus sharing is disabled by default.

You can get/set this property using:

DAQmxGetSwitchChanAnlgBusSharingEnable

DAQmxSetSwitchChanAnlgBusSharingEnable


Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeDigFltrTimebaseSrc

DAQmxSetCIPulseTimeDigFltrTimebaseSrc

DAQmxResetCIPulseTimeDigFltrTimebaseSrc


Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeDigFltrTimebaseRate

DAQmxSetCIPulseTimeDigFltrTimebaseRate

DAQmxResetCIPulseTimeDigFltrTimebaseRate


Counter Input >> Pulse >> Time >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeDigSyncEnable

DAQmxSetCIPulseTimeDigSyncEnable

DAQmxResetCIPulseTimeDigSyncEnable


Counter Input >> Pulse >> Time >> Units

Data Type: | int32
Description: | Specifies the units to use to return pulse specifications in terms of high time and low time.

Valid values
DAQmx_Val_Seconds 10364 Seconds.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeUnits

DAQmxSetCIPulseTimeUnits

DAQmxResetCIPulseTimeUnits


Counter Input >> Pulse >> Ticks >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksTerm

DAQmxSetCIPulseTicksTerm

DAQmxResetCIPulseTicksTerm


Counter Input >> Pulse >> Ticks >> Starting Edge

Data Type: | int32
Description: | Specifies on which edge of the input signal to begin pulse measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIPulseTicksStartEdge

DAQmxSetCIPulseTicksStartEdge

DAQmxResetCIPulseTicksStartEdge


Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksDigFltrEnable

DAQmxSetCIPulseTicksDigFltrEnable

DAQmxResetCIPulseTicksDigFltrEnable


Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksDigFltrMinPulseWidth

DAQmxSetCIPulseTicksDigFltrMinPulseWidth

DAQmxResetCIPulseTicksDigFltrMinPulseWidth


Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the timebase of the digital filter.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksDigFltrTimebaseSrc

DAQmxSetCIPulseTicksDigFltrTimebaseSrc

DAQmxResetCIPulseTicksDigFltrTimebaseSrc


Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the digital filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksDigFltrTimebaseRate

DAQmxSetCIPulseTicksDigFltrTimebaseRate

DAQmxResetCIPulseTicksDigFltrTimebaseRate


More >> Pause >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Pause Trigger terminal for the task. This property does not return the name of the trigger source terminal.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPauseTrigTerm


System >> NI-DAQ Version >> Update

Data Type: | uInt32
Description: | Indicates the update portion of the installed version of NI-DAQmx, such as 1 for version 9.0.1.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysNIDAQUpdateVersion


Status >> Accessory >> Accessory Insertion or Removal Detected

Data Type: | bool32
Description: | Indicates if any device(s) in the task detected the insertion or removal of an accessory since the task started. Reading this property clears the accessory change status for all channels in the task. You must read this property before you read Devices with Inserted or Removed Accessories. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadAccessoryInsertionOrRemovalDetected


Status >> Accessory >> Devices with Inserted or Removed Accessories

Data Type: | char*
Description: | Indicates the names of any devices that detected the insertion or removal of an accessory since the task started. You must read Accessory Insertion or Removal Detected before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadDevsWithInsertedOrRemovedAccessories


Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Open Thermocouple Detection Enable

Data Type: | bool32
Description: | Specifies whether to apply the open thermocouple detection bias voltage to the channel. Changing the value of this property on a channel may require settling time before the data returned is valid. To compensate for this settling time, discard unsettled data or add a delay between committing and starting the task. Refer to your device specifications for the required settling time. When open thermocouple detection is enabled, use Open Thermocouple Channels Exist to determine if any channels were open.

You can get/set/reset this property using:

DAQmxGetAIOpenThrmcplDetectEnable

DAQmxSetAIOpenThrmcplDetectEnable

DAQmxResetAIOpenThrmcplDetectEnable


Analog Input >> Force >> Units

Data Type: | int32
Description: | Specifies in which unit to return force or load measurements from the channel.

Valid values
DAQmx_Val_Newtons | 15875 | Newtons.
DAQmx_Val_Pounds | 15876 | Pounds.
DAQmx_Val_KilogramForce | 15877 | Kilograms-force.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIForceUnits

DAQmxSetAIForceUnits

DAQmxResetAIForceUnits


Analog Input >> Pressure >> Units

Data Type: | int32
Description: | Specifies in which unit to return pressure measurements from the channel.

Valid values
DAQmx_Val_Pascals | 10081 | Pascals.
DAQmx_Val_PoundsPerSquareInch | 15879 | Pounds per square inch.
DAQmx_Val_Bar | 15880 | Bar.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIPressureUnits

DAQmxSetAIPressureUnits

DAQmxResetAIPressureUnits


Analog Input >> Torque >> Units

Data Type: | int32
Description: | Specifies in which unit to return torque measurements from the channel.

Valid values
DAQmx_Val_NewtonMeters | 15881 | Newton meters.
DAQmx_Val_InchOunces | 15882 | Ounce-inches.
DAQmx_Val_InchPounds | 15883 | Pound-inches.
DAQmx_Val_FootPounds | 15884 | Pound-feet.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAITorqueUnits

DAQmxSetAITorqueUnits

DAQmxResetAITorqueUnits


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Resistor Value

Data Type: | float64
Description: | Specifies in ohms the desired value of the internal shunt calibration A resistor.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalShuntCalAResistance

DAQmxSetAIBridgeShuntCalShuntCalAResistance

DAQmxResetAIBridgeShuntCalShuntCalAResistance


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Actual Resistor Value

Data Type: | float64
Description: | Specifies in ohms the actual value of the internal shunt calibration A resistor.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalShuntCalAActualResistance

DAQmxSetAIBridgeShuntCalShuntCalAActualResistance

DAQmxResetAIBridgeShuntCalShuntCalAActualResistance


Advanced >> Synchronization Type

Data Type: | int32
Description: | Specifies the role of the device in a synchronized system. Setting this value to DAQmx_Val_Master or DAQmx_Val_Slave enables trigger skew correction. If you enable trigger skew correction, set this property to DAQmx_Val_Master on only one device, and set this property to DAQmx_Val_Slave on the other devices.

Valid values
DAQmx_Val_None | 10230 | Disables trigger skew correction.
DAQmx_Val_Master | 15888 | Device is the source for shared clocks and triggers.
DAQmx_Val_Slave | 15889 | Device uses clocks and triggers from the master device.

You can get/set/reset this property using:

DAQmxGetTriggerSyncType

DAQmxSetTriggerSyncType

DAQmxResetTriggerSyncType


Analog Input >> Force >> IEPE Sensor >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the IEPE force sensor connected to the channel. Specify this value in the unit indicated by Sensitivity Units.

You can get/set/reset this property using:

DAQmxGetAIForceIEPESensorSensitivity

DAQmxSetAIForceIEPESensorSensitivity

DAQmxResetAIForceIEPESensorSensitivity


Analog Input >> Force >> IEPE Sensor >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units for Sensitivity.

Valid values
DAQmx_Val_mVoltsPerNewton | 15891 | Millivolts per newton.
DAQmx_Val_mVoltsPerPound | 15892 | Millivolts per pound.

You can get/set/reset this property using:

DAQmxGetAIForceIEPESensorSensitivityUnits

DAQmxSetAIForceIEPESensorSensitivityUnits

DAQmxResetAIForceIEPESensorSensitivityUnits


More >> Synchronization Pulse >> Terminal

Data Type: | char*
Description: | Indicates the name of the internal Synchronization Pulse terminal for the task. This property does not return the name of the source terminal.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSyncPulseTerm


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Ratio

Data Type: | float64
Description: | Specifies in volts per volt the ratio of output voltage from the bridge to excitation voltage supplied to the bridge while not under load. NI-DAQmx subtracts this value from any measurements before applying scaling equations. If you set Initial Bridge Voltage, NI-DAQmx coerces this property to Initial Bridge Voltage divided by Actual Excitation Value. If you set this property, NI-DAQmx coerces Initial Bridge Voltage to the value of this property times Actual Excitation Value. If you set both this property and Initial Bridge Voltage, and their values conflict, NI-DAQmx returns an error. To avoid this error, reset one property to its default value before setting the other.

You can get/set/reset this property using:

DAQmxGetAIBridgeInitialRatio

DAQmxSetAIBridgeInitialRatio

DAQmxResetAIBridgeInitialRatio


Analog Input >> Bridge >> Scaling Parameters >> Electrical Units

Data Type: | int32
Description: | Specifies from which electrical unit to scale data. Select the same unit that the sensor data sheet or calibration certificate uses for electrical values.

Valid values
DAQmx_Val_VoltsPerVolt | 15896 | Volts per volt.
DAQmx_Val_mVoltsPerVolt | 15897 | Millivolts per volt.

You can get/set/reset this property using:

DAQmxGetAIBridgeElectricalUnits

DAQmxSetAIBridgeElectricalUnits

DAQmxResetAIBridgeElectricalUnits


Analog Input >> Bridge >> Scaling Parameters >> Physical Units

Data Type: | int32
Description: | Specifies to which physical unit to scale electrical data. Select the same unit that the sensor data sheet or calibration certificate uses for physical values.

Valid values
DAQmx_Val_Newtons | 15875 | Newtons.
DAQmx_Val_Pounds | 15876 | Pounds.
DAQmx_Val_KilogramForce | 15877 | kilograms-force.
DAQmx_Val_Pascals | 10081 | Pascals.
DAQmx_Val_PoundsPerSquareInch | 15879 | Pounds per square inch.
DAQmx_Val_Bar | 15880 | Bar.
DAQmx_Val_NewtonMeters | 15881 | Newton metres.
DAQmx_Val_InchOunces | 15882 | Ounce-inches.
DAQmx_Val_InchPounds | 15883 | Pound-inches.
DAQmx_Val_FootPounds | 15884 | Pound-feet.

You can get/set/reset this property using:

DAQmxGetAIBridgePhysicalUnits

DAQmxSetAIBridgePhysicalUnits

DAQmxResetAIBridgePhysicalUnits


Analog Input >> Bridge >> Scaling Parameters >> Scale Type

Data Type: | int32
Description: | Specifies the scaling type to use when scaling electrical values from the sensor to physical units.

Valid values
DAQmx_Val_None | 10230 | Do not scale electrical values to physical units.
DAQmx_Val_TwoPointLinear | 15898 | You provide two pairs of electrical values and their corresponding physical values. NI-DAQmx uses those values to calculate the slope and y-intercept of a linear equation and uses that equation to scale electrical values to physical values.
DAQmx_Val_Table | 10450 | Map an array of electrical values to an array of corresponding physical values, with all other values scaled proportionally. If you specify this scaling type, Maximum Value and Minimum Value must be within the smallest and largest physical values. For any data outside those endpoints, NI-DAQmx coerces that data to the endpoints.
DAQmx_Val_Polynomial | 10449 | Scale values by using an Nth order polynomial equation.

You can get/set/reset this property using:

DAQmxGetAIBridgeScaleType

DAQmxSetAIBridgeScaleType

DAQmxResetAIBridgeScaleType


Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Forward Coefficients

Data Type: | float64*
Description: | Specifies an array of coefficients for the polynomial that converts electrical values to physical values. Each element of the array corresponds to a term of the equation. For example, if index three of the array is 9, the fourth term of the equation is 9x^3.

You can get/set/reset this property using:

DAQmxGetAIBridgePolyForwardCoeff

DAQmxSetAIBridgePolyForwardCoeff

DAQmxResetAIBridgePolyForwardCoeff


Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Reverse Coefficients

Data Type: | float64*
Description: | Specifies an array of coefficients for the polynomial that converts physical values to electrical values. Each element of the array corresponds to a term of the equation. For example, if index three of the array is 9, the fourth term of the equation is 9x^3.

You can get/set/reset this property using:

DAQmxGetAIBridgePolyReverseCoeff

DAQmxSetAIBridgePolyReverseCoeff

DAQmxResetAIBridgePolyReverseCoeff


Analog Input >> Bridge >> Units

Data Type: | int32
Description: | Specifies in which unit to return voltage ratios from the channel.

Valid values
DAQmx_Val_VoltsPerVolt | 15896 | Volts per volt.
DAQmx_Val_mVoltsPerVolt | 15897 | Millivolts per volt.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAIBridgeUnits

DAQmxSetAIBridgeUnits

DAQmxResetAIBridgeUnits


Counter Input >> Count Edges >> Count Reset >> Enable

Data Type: | bool32
Description: | Specifies whether to reset the count on the active edge specified with Terminal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetEnable

DAQmxSetCICountEdgesCountResetEnable

DAQmxResetCICountEdgesCountResetEnable


Counter Input >> Count Edges >> Count Reset >> Reset Count

Data Type: | uInt32
Description: | Specifies the value to reset the count to.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetResetCount

DAQmxSetCICountEdgesCountResetResetCount

DAQmxResetCICountEdgesCountResetResetCount


Counter Input >> Count Edges >> Count Reset >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to reset the count.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetTerm

DAQmxSetCICountEdgesCountResetTerm

DAQmxResetCICountEdgesCountResetTerm


Counter Input >> Count Edges >> Count Reset >> Active Edge

Data Type: | int32
Description: | Specifies on which edge of the signal to reset the count.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetActiveEdge

DAQmxSetCICountEdgesCountResetActiveEdge

DAQmxResetCICountEdgesCountResetActiveEdge


Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetDigFltrEnable

DAQmxSetCICountEdgesCountResetDigFltrEnable

DAQmxResetCICountEdgesCountResetDigFltrEnable


Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetDigFltrMinPulseWidth

DAQmxSetCICountEdgesCountResetDigFltrMinPulseWidth

DAQmxResetCICountEdgesCountResetDigFltrMinPulseWidth


Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetDigFltrTimebaseSrc

DAQmxSetCICountEdgesCountResetDigFltrTimebaseSrc

DAQmxResetCICountEdgesCountResetDigFltrTimebaseSrc


Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetDigFltrTimebaseRate

DAQmxSetCICountEdgesCountResetDigFltrTimebaseRate

DAQmxResetCICountEdgesCountResetDigFltrTimebaseRate


Counter Input >> Count Edges >> Count Reset >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetDigSyncEnable

DAQmxSetCICountEdgesCountResetDigSyncEnable

DAQmxResetCICountEdgesCountResetDigSyncEnable


Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Lead Offset Voltage

Data Type: | float64
Description: | Specifies the lead offset nulling voltage to subtract from measurements on a device. This property is ignored if open thermocouple detection is disabled.

You can get/set/reset this property using:

DAQmxGetAIThrmcplLeadOffsetVoltage

DAQmxSetAIThrmcplLeadOffsetVoltage

DAQmxResetAIThrmcplLeadOffsetVoltage


Analog Input >> General Properties >> Filter >> Remove Filter Delay

Data Type: | bool32
Description: | Specifies if filter delay removal is enabled on the device.

You can get/set/reset this property using:

DAQmxGetAIRemoveFilterDelay

DAQmxSetAIRemoveFilterDelay

DAQmxResetAIRemoveFilterDelay


Logging >> File Write Size

Data Type: | uInt32
Description: | Specifies the size, in samples, in which data will be written to disk. The size must be evenly divisible by the volume sector size, in bytes.

You can get/set/reset this property using:

DAQmxGetLoggingFileWriteSize

DAQmxSetLoggingFileWriteSize

DAQmxResetLoggingFileWriteSize


Logging >> File Pre-allocation Size

Data Type: | uInt64
Description: | Specifies a size in samples to be used to pre-allocate space on disk. Pre-allocation can improve file I/O performance, especially in situations where multiple files are being written to disk. For finite tasks, the default behavior is to pre-allocate the file based on the number of samples you configure the task to acquire.

You can get/set/reset this property using:

DAQmxGetLoggingFilePreallocationSize

DAQmxSetLoggingFilePreallocationSize

DAQmxResetLoggingFilePreallocationSize


I/O Type >> Analog Input >> Bridge >> Ranges

Data Type: | float64*
Description: | Indicates pairs of input voltage ratio ranges, in volts per volt, supported by devices that acquire using ratiometric measurements. Each pair consists of the low value followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIBridgeRngs


I/O Type >> Analog Input >> Measurement Types

Data Type: | int32*
Description: | Indicates the measurement types supported by the physical channels of the device. Refer to Measurement Types for information on specific channels.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage measurement.
DAQmx_Val_VoltageRMS | 10350 | Voltage RMS measurement.
DAQmx_Val_Current | 10134 | Current measurement.
DAQmx_Val_CurrentRMS | 10351 | Current RMS measurement.
DAQmx_Val_Voltage_CustomWithExcitation | 10323 | Voltage measurement with an excitation source. You can use this measurement type for custom sensors that require excitation, but you must use a custom scale to scale the measured voltage.
DAQmx_Val_Bridge | 15908 | Measure voltage ratios from a Wheatstone bridge.
DAQmx_Val_Freq_Voltage | 10181 | Frequency measurement using a frequency to voltage converter.
DAQmx_Val_Resistance | 10278 | Resistance measurement.
DAQmx_Val_Temp_TC | 10303 | Temperature measurement using a thermocouple.
DAQmx_Val_Temp_Thrmstr | 10302 | Temperature measurement using a thermistor.
DAQmx_Val_Temp_RTD | 10301 | Temperature measurement using an RTD.
DAQmx_Val_Temp_BuiltInSensor | 10311 | Temperature measurement using a built-in sensor on a terminal block or device. On SCXI modules, for example, this could be the CJC sensor.
DAQmx_Val_Strain_Gage | 10300 | Strain measurement.
DAQmx_Val_Rosette_Strain_Gage | 15980 | Strain measurement using a rosette strain gage.
DAQmx_Val_Position_LVDT | 10352 | Position measurement using an LVDT.
DAQmx_Val_Position_RVDT | 10353 | Position measurement using an RVDT.
DAQmx_Val_Position_EddyCurrentProximityProbe | 14835 | Position measurement using an eddy current proximity probe.
DAQmx_Val_Accelerometer | 10356 | Acceleration measurement using an accelerometer.
DAQmx_Val_Acceleration_Charge | 16104 | Acceleration measurement using a charge-based sensor.
DAQmx_Val_Acceleration_4WireDCVoltage | 16106 | Acceleration measurement using a 4 wire DC voltage based sensor.
DAQmx_Val_Velocity_IEPESensor | 15966 | Velocity measurement using an IEPE Sensor.
DAQmx_Val_Force_Bridge | 15899 | Force measurement using a bridge-based sensor.
DAQmx_Val_Force_IEPESensor | 15895 | Force measurement using an IEPE Sensor.
DAQmx_Val_Pressure_Bridge | 15902 | Pressure measurement using a bridge-based sensor.
DAQmx_Val_SoundPressure_Microphone | 10354 | Sound pressure measurement using a microphone.
DAQmx_Val_Torque_Bridge | 15905 | Torque measurement using a bridge-based sensor.
DAQmx_Val_TEDS_Sensor | 12531 | Measurement type defined by TEDS.
DAQmx_Val_Charge | 16105 | Charge measurement.

You can get this property using:

DAQmxGetDevAISupportedMeasTypes


I/O Type >> Analog Output >> Output Types

Data Type: | int32*
Description: | Indicates the generation types supported by the physical channels of the device. Refer to Output Types for information on specific channels.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage generation.
DAQmx_Val_Current | 10134 | Current generation.
DAQmx_Val_FuncGen | 14750 | Function generation.

You can get this property using:

DAQmxGetDevAOSupportedOutputTypes


I/O Type >> Counter Input >> Measurement Types

Data Type: | int32*
Description: | Indicates the measurement types supported by the physical channels of the device. Refer to Measurement Types for information on specific channels.
Restrictions: | Not Settable

Valid values
DAQmx_Val_CountEdges | 10125 | Count edges of a digital signal.
DAQmx_Val_Freq | 10179 | Measure the frequency of a digital signal.
DAQmx_Val_Period | 10256 | Measure the period of a digital signal.
DAQmx_Val_PulseWidth | 10359 | Measure the width of a pulse of a digital signal.
DAQmx_Val_SemiPeriod | 10289 | Measure the time between state transitions of a digital signal.
DAQmx_Val_PulseFrequency | 15864 | Pulse measurement, returning the result as frequency and duty cycle.
DAQmx_Val_PulseTime | 15865 | Pulse measurement, returning the result as high time and low time.
DAQmx_Val_PulseTicks | 15866 | Pulse measurement, returning the result as high ticks and low ticks.
DAQmx_Val_DutyCycle | 16070 | Measure the duty cycle of a digital signal.
DAQmx_Val_Position_AngEncoder | 10360 | Angular position measurement using an angular encoder.
DAQmx_Val_Position_LinEncoder | 10361 | Linear position measurement using a linear encoder.
DAQmx_Val_Velocity_AngEncoder | 16078 | Angular velocity measurement using an angular encoder.
DAQmx_Val_Velocity_LinEncoder | 16079 | Linear velocity measurement using a linear encoder.
DAQmx_Val_TwoEdgeSep | 10267 | Measure time between edges of two digital signals.
DAQmx_Val_GPS_Timestamp | 10362 | Timestamp measurement, synchronizing the counter to a GPS receiver.

You can get this property using:

DAQmxGetDevCISupportedMeasTypes


I/O Type >> Counter Output >> Output Types

Data Type: | int32*
Description: | Indicates the generation types supported by the physical channels of the device. Refer to Output Types for information on specific channels.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Pulse_Time | 10269 | Generate pulses defined by the time the pulse is at a low state and the time the pulse is at a high state.
DAQmx_Val_Pulse_Freq | 10119 | Generate digital pulses defined by frequency and duty cycle.
DAQmx_Val_Pulse_Ticks | 10268 | Generate digital pulses defined by the number of timebase ticks that the pulse is at a low state and the number of timebase ticks that the pulse is at a high state.

You can get this property using:

DAQmxGetDevCOSupportedOutputTypes


TEDS >> Hardware TEDS Supported

Data Type: | bool32
Description: | Indicates whether the device supports hardware TEDS.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevTEDSHWTEDSSupported


Analog Input >> Measurement Types

Data Type: | int32*
Description: | Indicates the measurement types supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage measurement.
DAQmx_Val_VoltageRMS | 10350 | Voltage RMS measurement.
DAQmx_Val_Current | 10134 | Current measurement.
DAQmx_Val_CurrentRMS | 10351 | Current RMS measurement.
DAQmx_Val_Voltage_CustomWithExcitation | 10323 | Voltage measurement with an excitation source. You can use this measurement type for custom sensors that require excitation, but you must use a custom scale to scale the measured voltage.
DAQmx_Val_Bridge | 15908 | Measure voltage ratios from a Wheatstone bridge.
DAQmx_Val_Freq_Voltage | 10181 | Frequency measurement using a frequency to voltage converter.
DAQmx_Val_Resistance | 10278 | Resistance measurement.
DAQmx_Val_Temp_TC | 10303 | Temperature measurement using a thermocouple.
DAQmx_Val_Temp_Thrmstr | 10302 | Temperature measurement using a thermistor.
DAQmx_Val_Temp_RTD | 10301 | Temperature measurement using an RTD.
DAQmx_Val_Temp_BuiltInSensor | 10311 | Temperature measurement using a built-in sensor on a terminal block or device. On SCXI modules, for example, this could be the CJC sensor.
DAQmx_Val_Strain_Gage | 10300 | Strain measurement.
DAQmx_Val_Rosette_Strain_Gage | 15980 | Strain measurement using a rosette strain gage.
DAQmx_Val_Position_LVDT | 10352 | Position measurement using an LVDT.
DAQmx_Val_Position_RVDT | 10353 | Position measurement using an RVDT.
DAQmx_Val_Position_EddyCurrentProximityProbe | 14835 | Position measurement using an eddy current proximity probe.
DAQmx_Val_Accelerometer | 10356 | Acceleration measurement using an accelerometer.
DAQmx_Val_Acceleration_Charge | 16104 | Acceleration measurement using a charge-based sensor.
DAQmx_Val_Acceleration_4WireDCVoltage | 16106 | Acceleration measurement using a 4 wire DC voltage based sensor.
DAQmx_Val_Velocity_IEPESensor | 15966 | Velocity measurement using an IEPE Sensor.
DAQmx_Val_Force_Bridge | 15899 | Force measurement using a bridge-based sensor.
DAQmx_Val_Force_IEPESensor | 15895 | Force measurement using an IEPE Sensor.
DAQmx_Val_Pressure_Bridge | 15902 | Pressure measurement using a bridge-based sensor.
DAQmx_Val_SoundPressure_Microphone | 10354 | Sound pressure measurement using a microphone.
DAQmx_Val_Torque_Bridge | 15905 | Torque measurement using a bridge-based sensor.
DAQmx_Val_TEDS_Sensor | 12531 | Measurement type defined by TEDS.
DAQmx_Val_Charge | 16105 | Charge measurement.

You can get this property using:

DAQmxGetPhysicalChanAISupportedMeasTypes


Analog Input >> Input Configuration >> Input Sources

Data Type: | char*
Description: | Indicates the list of input sources supported by the channel. Channels may support using the signal from the I/O connector or one of several calibration signals.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanAIInputSrcs


Analog Output >> Output Types

Data Type: | int32*
Description: | Indicates the output types supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage generation.
DAQmx_Val_Current | 10134 | Current generation.
DAQmx_Val_FuncGen | 14750 | Function generation.

You can get this property using:

DAQmxGetPhysicalChanAOSupportedOutputTypes


Counter Input >> Measurement Types

Data Type: | int32*
Description: | Indicates the measurement types supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_CountEdges | 10125 | Count edges of a digital signal.
DAQmx_Val_Freq | 10179 | Measure the frequency of a digital signal.
DAQmx_Val_Period | 10256 | Measure the period of a digital signal.
DAQmx_Val_PulseWidth | 10359 | Measure the width of a pulse of a digital signal.
DAQmx_Val_SemiPeriod | 10289 | Measure the time between state transitions of a digital signal.
DAQmx_Val_PulseFrequency | 15864 | Pulse measurement, returning the result as frequency and duty cycle.
DAQmx_Val_PulseTime | 15865 | Pulse measurement, returning the result as high time and low time.
DAQmx_Val_PulseTicks | 15866 | Pulse measurement, returning the result as high ticks and low ticks.
DAQmx_Val_DutyCycle | 16070 | Measure the duty cycle of a digital signal.
DAQmx_Val_Position_AngEncoder | 10360 | Angular position measurement using an angular encoder.
DAQmx_Val_Position_LinEncoder | 10361 | Linear position measurement using a linear encoder.
DAQmx_Val_Velocity_AngEncoder | 16078 | Angular velocity measurement using an angular encoder.
DAQmx_Val_Velocity_LinEncoder | 16079 | Linear velocity measurement using a linear encoder.
DAQmx_Val_TwoEdgeSep | 10267 | Measure time between edges of two digital signals.
DAQmx_Val_GPS_Timestamp | 10362 | Timestamp measurement, synchronizing the counter to a GPS receiver.

You can get this property using:

DAQmxGetPhysicalChanCISupportedMeasTypes


Counter Output >> Output Types

Data Type: | int32*
Description: | Indicates the output types supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Pulse_Time | 10269 | Generate pulses defined by the time the pulse is at a low state and the time the pulse is at a high state.
DAQmx_Val_Pulse_Freq | 10119 | Generate digital pulses defined by frequency and duty cycle.
DAQmx_Val_Pulse_Ticks | 10268 | Generate digital pulses defined by the number of timebase ticks that the pulse is at a low state and the number of timebase ticks that the pulse is at a high state.

You can get this property using:

DAQmxGetPhysicalChanCOSupportedOutputTypes


I/O Type >> Analog Input >> Timing >> Sample Modes

Data Type: | int32*
Description: | Indicates sample modes supported by devices that support sample clocked analog input.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetDevAISampModes


I/O Type >> Analog Output >> Timing >> Sample Modes

Data Type: | int32*
Description: | Indicates sample modes supported by devices that support sample clocked analog output.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetDevAOSampModes


I/O Type >> Counter Input >> Timing >> Sample Modes

Data Type: | int32*
Description: | Indicates sample modes supported by devices that support sample clocked counter input.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetDevCISampModes


I/O Type >> Counter Output >> Timing >> SampleModes

Data Type: | int32*
Description: | Indicates sample modes supported by devices that support sample clocked counter output.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetDevCOSampModes


Digital Input >> Timing >> Sample Modes

Data Type: | int32*
Description: | Indicates the sample modes supported by devices that support sample clocked digital input.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetPhysicalChanDISampModes


Digital Output >> Timing >> Sample Modes

Data Type: | int32*
Description: | Indicates the sample modes supported by devices that support sample clocked digital output.
Restrictions: | Not Settable

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get this property using:

DAQmxGetPhysicalChanDOSampModes


Logging >> Pause

Data Type: | bool32
Description: | Specifies whether logging is paused while a task is executing. If Mode is set to Log and Read mode, this value is taken into consideration on the next call to DAQmx Read, where data is written to disk. If Mode is set to Log Only mode, this value is taken into consideration the next time that data is written to disk. A new TDMS group is written when logging is resumed from a paused state.

You can get/set/reset this property using:

DAQmxGetLoggingPause

DAQmxSetLoggingPause

DAQmxResetLoggingPause


Logging >> Samples Per File

Data Type: | uInt64
Description: | Specifies how many samples to write to each file. When the file reaches the number of samples specified, a new file is created with the naming convention of <filename>_####.tdms, where #### starts at 0001 and increments automatically with each new file. For example, if the file specified is C:\data.tdms, the next file name used is C:\data_0001.tdms. To disable file spanning behavior, set this attribute to 0. If File Path is changed while this attribute is set, the new file path takes effect on the next file created.

You can get/set/reset this property using:

DAQmxGetLoggingSampsPerFile

DAQmxSetLoggingSampsPerFile

DAQmxResetLoggingSampsPerFile


More >> Accessory Connection Count

Data Type: | uInt32
Description: | Specifies the number of times a particular connection that results in tangible wear and tear of onboard components has been made on the accessory. This connection count is useful for tracking accessory life and usage.

You can get/set this property using:

DAQmxGetCalAccConnectionCount

DAQmxSetCalAccConnectionCount


More >> Recommended Accessory Connection Count Limit

Data Type: | uInt32
Description: | Indicates the recommended connection count limit for an accessory. If the accessory connection count exceeds this limit, the accessory could require maintenance.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCalRecommendedAccConnectionCountLimit


Analog Input >> General Properties >> Filter >> Filter Delay

Data Type: | float64
Description: | Indicates the amount of time between when the ADC samples data and when the sample is read by the host device. This value is in the units you specify with Filter Delay Units. You can adjust this amount of time using Filter Delay Adjustment.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIFilterDelay


Analog Input >> General Properties >> Filter >> Averaging Window Size

Data Type: | uInt32
Description: | Specifies the number of samples to average while acquiring data. Increasing the number of samples to average reduces noise in your measurement.

You can get/set/reset this property using:

DAQmxGetAIAveragingWinSize

DAQmxSetAIAveragingWinSize

DAQmxResetAIAveragingWinSize


Analog Input >> Velocity >> Units

Data Type: | int32
Description: | Specifies in which unit to return velocity measurements from the channel.

Valid values
DAQmx_Val_MetersPerSecond | 15959 | Meters per second.
DAQmx_Val_InchesPerSecond | 15960 | Inches per second.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIVelocityUnits

DAQmxSetAIVelocityUnits

DAQmxResetAIVelocityUnits


Analog Input >> Velocity >> IEPE Sensor >> dB Reference

Data Type: | float64
Description: | Specifies the decibel reference level in the units of the channel. When you read samples as a waveform, the decibel reference level is included in the waveform attributes.

You can get/set/reset this property using:

DAQmxGetAIVelocityIEPESensordBRef

DAQmxSetAIVelocityIEPESensordBRef

DAQmxResetAIVelocityIEPESensordBRef


Analog Input >> Velocity >> IEPE Sensor >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the IEPE velocity sensor connected to the channel. Specify this value in the unit indicated by Sensitivity Units.

You can get/set/reset this property using:

DAQmxGetAIVelocityIEPESensorSensitivity

DAQmxSetAIVelocityIEPESensorSensitivity

DAQmxResetAIVelocityIEPESensorSensitivity


Analog Input >> Velocity >> IEPE Sensor >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units for Sensitivity.

Valid values
DAQmx_Val_MillivoltsPerMillimeterPerSecond | 15963 | Millivolts per millimeter per second.
DAQmx_Val_MilliVoltsPerInchPerSecond | 15964 | Millivolts per inch per second.

You can get/set/reset this property using:

DAQmxGetAIVelocityIEPESensorSensitivityUnits

DAQmxSetAIVelocityIEPESensorSensitivityUnits

DAQmxResetAIVelocityIEPESensorSensitivityUnits


Analog Input >> Strain >> Force Read From Channel

Data Type: | bool32
Description: | Specifies whether the data is returned by an NI-DAQmx Read function when set on a raw strain channel that is part of a rosette configuration.

You can get/set/reset this property using:

DAQmxGetAIStrainGageForceReadFromChan

DAQmxSetAIStrainGageForceReadFromChan

DAQmxResetAIStrainGageForceReadFromChan


Analog Input >> Rosette Strain Gage >> Strain Channels

Data Type: | char*
Description: | Indicates the raw strain channels that comprise the strain rosette.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIRosetteStrainGageStrainChans


Analog Input >> Rosette Strain Gage >> Gage Orientation

Data Type: | float64
Description: | Specifies gage orientation in degrees with respect to the X axis.

You can get/set/reset this property using:

DAQmxGetAIRosetteStrainGageOrientation

DAQmxSetAIRosetteStrainGageOrientation

DAQmxResetAIRosetteStrainGageOrientation


Analog Input >> Rosette Strain Gage >> Rosette Measurement Type

Data Type: | int32
Description: | Specifies the type of rosette measurement.

Valid values
DAQmx_Val_PrincipalStrain1 | 15971 | The maximum tensile strain coplanar to the surface of the material under stress.
DAQmx_Val_PrincipalStrain2 | 15972 | The minimum tensile strain coplanar to the surface of the material under stress.
DAQmx_Val_PrincipalStrainAngle | 15973 | The angle at which the principal strains of the rosette occur.
DAQmx_Val_CartesianStrainX | 15974 | The tensile strain coplanar to the surface of the material under stress in the X coordinate direction.
DAQmx_Val_CartesianStrainY | 15975 | The tensile strain coplanar to the surface of the material under stress in the Y coordinate direction.
DAQmx_Val_CartesianShearStrainXY | 15976 | The tensile strain coplanar to the surface of the material under stress in the XY coordinate direction.
DAQmx_Val_MaxShearStrain | 15977 | The maximum strain coplanar to the cross section of the material under stress.
DAQmx_Val_MaxShearStrainAngle | 15978 | The angle at which the maximum shear strain of the rosette occurs.

You can get/set/reset this property using:

DAQmxGetAIRosetteStrainGageRosetteMeasType

DAQmxSetAIRosetteStrainGageRosetteMeasType

DAQmxResetAIRosetteStrainGageRosetteMeasType


Analog Input >> Rosette Strain Gage >> Rosette Type

Data Type: | int32
Description: | Indicates the type of rosette gage.
Restrictions: | Not Settable

Valid values
DAQmx_Val_RectangularRosette | 15968 | A rectangular rosette consists of three strain gages, each separated by a 45 degree angle.
DAQmx_Val_DeltaRosette | 15969 | A delta rosette consists of three strain gages, each separated by a 60 degree angle.
DAQmx_Val_TeeRosette | 15970 | A tee rosette consists of two gages oriented at 90 degrees with respect to each other.

You can get this property using:

DAQmxGetAIRosetteStrainGageRosetteType


Deprecated >> Is Waiting For Advance

Data Type: | bool32
Description: | (Deprecated) Indicates if the switch hardware is waiting for an Advance Trigger. If the hardware is waiting, it completed the previous entry in the scan list.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchScanWaitingForAdv


Deprecated >> Auto Connect Analog Bus

Data Type: | bool32
Description: | (Deprecated) Specifies if NI-DAQmx routes multiplexed channels to the analog bus backplane. Only the SCXI-1127 and SCXI-1128 support this property.

You can get/set this property using:

DAQmxGetSwitchDevAutoConnAnlgBus

DAQmxSetSwitchDevAutoConnAnlgBus


Deprecated >> Capability >> Relay List

Data Type: | char*
Description: | (Deprecated) Indicates a comma-delimited list of relay names.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevRelayList


Analog Input >> Maximum Value

Data Type: | float64
Description: | Specifies the maximum value you expect to measure. This value is in the units you specify with a units property. When you query this property, it returns the coerced maximum value that the device can measure with the current settings.

You can get/set/reset this property using:

DAQmxGetAIMax

DAQmxSetAIMax

DAQmxResetAIMax


Analog Input >> Minimum Value

Data Type: | float64
Description: | Specifies the minimum value you expect to measure. This value is in the units you specify with a units property. When you query this property, it returns the coerced minimum value that the device can measure with the current settings.

You can get/set/reset this property using:

DAQmxGetAIMin

DAQmxSetAIMin

DAQmxResetAIMin


Analog Input >> Custom Scale Name

Data Type: | char*
Description: | Specifies the name of a custom scale for the channel.

You can get/set/reset this property using:

DAQmxGetAICustomScaleName

DAQmxSetAICustomScaleName

DAQmxResetAICustomScaleName


Analog Input >> Voltage >> AC RMS Voltage >> Units

Data Type: | int32
Description: | Specifies the units to use to return voltage RMS measurements from the channel.

Valid values
DAQmx_Val_Volts | 10348 | Volts.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAIVoltageACRMSUnits

DAQmxSetAIVoltageACRMSUnits

DAQmxResetAIVoltageACRMSUnits


Analog Input >> Current >> AC RMS Current >> Units

Data Type: | int32
Description: | Specifies the units to use to return current RMS measurements from the channel.

Valid values
DAQmx_Val_Amps | 10342 | Amperes.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAICurrentACRMSUnits

DAQmxSetAICurrentACRMSUnits

DAQmxResetAICurrentACRMSUnits


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Nominal Resistance

Data Type: | float64
Description: | Specifies in ohms the resistance of the bridge while not under load.

You can get/set/reset this property using:

DAQmxGetAIBridgeNomResistance

DAQmxSetAIBridgeNomResistance

DAQmxResetAIBridgeNomResistance


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Voltage

Data Type: | float64
Description: | Specifies in volts the output voltage of the bridge while not under load. NI-DAQmx subtracts this value from any measurements before applying scaling equations. If you set Initial Bridge Ratio, NI-DAQmx coerces this property to Initial Bridge Ratio times Actual Excitation Value. This property is set by DAQmx Perform Bridge Offset Nulling Calibration. If you set this property, NI-DAQmx coerces Initial Bridge Ratio to the value of this property divided by Actual Excitation Value. If you set both this property and Initial Bridge Ratio, and their values conflict, NI-DAQmx returns an error. To avoid this error, reset one property to its default value before setting the other.

You can get/set/reset this property using:

DAQmxGetAIBridgeInitialVoltage

DAQmxSetAIBridgeInitialVoltage

DAQmxResetAIBridgeInitialVoltage


Analog Input >> General Properties >> Signal Conditioning >> Lead Wire Resistance

Data Type: | float64
Description: | Specifies in ohms the resistance of the wires that lead to the sensor.

You can get/set/reset this property using:

DAQmxGetAILeadWireResistance

DAQmxSetAILeadWireResistance

DAQmxResetAILeadWireResistance


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Coarse Potentiometer

Data Type: | int32
Description: | Specifies by how much to compensate for offset in the signal. This value can be between 0 and 127.

You can get/set/reset this property using:

DAQmxGetAIBridgeBalanceCoarsePot

DAQmxSetAIBridgeBalanceCoarsePot

DAQmxResetAIBridgeBalanceCoarsePot


Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Location

Data Type: | int32
Description: | Specifies the shunt resistor location for current measurements.

Valid values
DAQmx_Val_Internal | 10200 | Use the built-in shunt resistor of the device.
DAQmx_Val_External | 10167 | Use a shunt resistor external to the device. You must specify the value of the shunt resistor by using Value.

You can get/set/reset this property using:

DAQmxGetAICurrentShuntLoc

DAQmxSetAICurrentShuntLoc

DAQmxResetAICurrentShuntLoc


Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Value

Data Type: | float64
Description: | Specifies in ohms the external shunt resistance for current measurements.

You can get/set/reset this property using:

DAQmxGetAICurrentShuntResistance

DAQmxSetAICurrentShuntResistance

DAQmxResetAICurrentShuntResistance


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Source

Data Type: | int32
Description: | Specifies the source of excitation.

Valid values
DAQmx_Val_Internal | 10200 | Use the built-in excitation source of the device. If you select this value, you must specify the amount of excitation.
DAQmx_Val_External | 10167 | Use an excitation source other than the built-in excitation source of the device. If you select this value, you must specify the amount of excitation.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetAIExcitSrc

DAQmxSetAIExcitSrc

DAQmxResetAIExcitSrc


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Value

Data Type: | float64
Description: | Specifies the amount of excitation that the sensor requires. If Voltage or Current is DAQmx_Val_Voltage, this value is in volts. If Voltage or Current is DAQmx_Val_Current, this value is in amperes.

You can get/set/reset this property using:

DAQmxGetAIExcitVal

DAQmxSetAIExcitVal

DAQmxResetAIExcitVal


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Voltage or Current

Data Type: | int32
Description: | Specifies if the channel uses current or voltage excitation.

Valid values
DAQmx_Val_Voltage | 10322 | Voltage excitation.
DAQmx_Val_Current | 10134 | Current excitation.

You can get/set/reset this property using:

DAQmxGetAIExcitVoltageOrCurrent

DAQmxSetAIExcitVoltageOrCurrent

DAQmxResetAIExcitVoltageOrCurrent


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> DC or AC

Data Type: | int32
Description: | Specifies if the excitation supply is DC or AC.

Valid values
DAQmx_Val_DC | 10050 | DC excitation.
DAQmx_Val_AC | 10045 | AC excitation.

You can get/set/reset this property using:

DAQmxGetAIExcitDCorAC

DAQmxSetAIExcitDCorAC

DAQmxResetAIExcitDCorAC


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Excitation For Scaling

Data Type: | bool32
Description: | Specifies if NI-DAQmx divides the measurement by the excitation. You should typically set this property to TRUE for ratiometric transducers. If you set this property to TRUE, set Maximum Value and Minimum Value to reflect the scaling. For example, if you expect to acquire a voltage between -5 and 5, and you use an excitation of .10 volts to scale the measurement, set Minimum Value to -50 and set Maximum Value to 50. If you set Configuration to DAQmx_Val_NoBridge, this property has no effect on the measurement.

You can get/set/reset this property using:

DAQmxGetAIExcitUseForScaling

DAQmxSetAIExcitUseForScaling

DAQmxResetAIExcitUseForScaling


Counter Input >> Measurement Type

Data Type: | int32
Description: | Indicates the measurement to take with the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_CountEdges | 10125 | Count edges of a digital signal.
DAQmx_Val_Freq | 10179 | Measure the frequency of a digital signal.
DAQmx_Val_Period | 10256 | Measure the period of a digital signal.
DAQmx_Val_PulseWidth | 10359 | Measure the width of a pulse of a digital signal.
DAQmx_Val_SemiPeriod | 10289 | Measure the time between state transitions of a digital signal.
DAQmx_Val_PulseFrequency | 15864 | Pulse measurement, returning the result as frequency and duty cycle.
DAQmx_Val_PulseTime | 15865 | Pulse measurement, returning the result as high time and low time.
DAQmx_Val_PulseTicks | 15866 | Pulse measurement, returning the result as high ticks and low ticks.
DAQmx_Val_DutyCycle | 16070 | Measure the duty cycle of a digital signal.
DAQmx_Val_Position_AngEncoder | 10360 | Angular position measurement using an angular encoder.
DAQmx_Val_Position_LinEncoder | 10361 | Linear position measurement using a linear encoder.
DAQmx_Val_Velocity_AngEncoder | 16078 | Angular velocity measurement using an angular encoder.
DAQmx_Val_Velocity_LinEncoder | 16079 | Linear velocity measurement using a linear encoder.
DAQmx_Val_TwoEdgeSep | 10267 | Measure time between edges of two digital signals.
DAQmx_Val_GPS_Timestamp | 10362 | Timestamp measurement, synchronizing the counter to a GPS receiver.

You can get this property using:

DAQmxGetCIMeasType


Counter Input >> Frequency >> Units

Data Type: | int32
Description: | Specifies the units to use to return frequency measurements.

Valid values
DAQmx_Val_Hz | 10373 | Hertz.
DAQmx_Val_Ticks | 10304 | Timebase ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIFreqUnits

DAQmxSetCIFreqUnits

DAQmxResetCIFreqUnits


Counter Input >> Frequency >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIFreqTerm

DAQmxSetCIFreqTerm

DAQmxResetCIFreqTerm


Counter Input >> Period >> Units

Data Type: | int32
Description: | Specifies the unit to use to return period measurements.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIPeriodUnits

DAQmxSetCIPeriodUnits

DAQmxResetCIPeriodUnits


Counter Input >> Period >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPeriodTerm

DAQmxSetCIPeriodTerm

DAQmxResetCIPeriodTerm


Counter Input >> Position >> Angular Encoder >> Units

Data Type: | int32
Description: | Specifies the units to use to return angular position measurements from the channel.

Valid values
DAQmx_Val_Degrees | 10146 | Degrees.
DAQmx_Val_Radians | 10273 | Radians.
DAQmx_Val_Ticks | 10304 | Ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIAngEncoderUnits

DAQmxSetCIAngEncoderUnits

DAQmxResetCIAngEncoderUnits


Counter Input >> Position >> Linear Encoder >> Units

Data Type: | int32
Description: | Specifies the units to use to return linear encoder measurements from the channel.

Valid values
DAQmx_Val_Meters | 10219 | Meters.
DAQmx_Val_Inches | 10379 | Inches.
DAQmx_Val_Ticks | 10304 | Ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCILinEncoderUnits

DAQmxSetCILinEncoderUnits

DAQmxResetCILinEncoderUnits


Counter Input >> Pulse Width >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthTerm

DAQmxSetCIPulseWidthTerm

DAQmxResetCIPulseWidthTerm


Counter Input >> Two Edge Separation >> Units

Data Type: | int32
Description: | Specifies the units to use to return two-edge separation measurements from the channel.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepUnits

DAQmxSetCITwoEdgeSepUnits

DAQmxResetCITwoEdgeSepUnits


Counter Input >> Two Edge Separation >> First >> Input >> Terminal

Data Type: | char*
Description: | Specifies the source terminal of the digital signal that starts each measurement.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstTerm

DAQmxSetCITwoEdgeSepFirstTerm

DAQmxResetCITwoEdgeSepFirstTerm


Counter Input >> Two Edge Separation >> Second >> Input >> Terminal

Data Type: | char*
Description: | Specifies the source terminal of the digital signal that stops each measurement.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondTerm

DAQmxSetCITwoEdgeSepSecondTerm

DAQmxResetCITwoEdgeSepSecondTerm


Counter Input >> Semi-Period >> Units

Data Type: | int32
Description: | Specifies the units to use to return semi-period measurements.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodUnits

DAQmxSetCISemiPeriodUnits

DAQmxResetCISemiPeriodUnits


Counter Input >> Semi-Period >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodTerm

DAQmxSetCISemiPeriodTerm

DAQmxResetCISemiPeriodTerm


Counter Input >> General Properties >> Counter Timebase >> Rate

Data Type: | float64
Description: | Specifies in Hertz the frequency of the counter timebase. Specifying the rate of a counter timebase allows you to take measurements in terms of time or frequency rather than in ticks of the timebase. If you use an external timebase and do not specify the rate, you can take measurements only in terms of ticks of the timebase.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseRate

DAQmxSetCICtrTimebaseRate

DAQmxResetCICtrTimebaseRate


Counter Input >> General Properties >> More >> Counter Timebase Master Timebase Divisor

Data Type: | uInt32
Description: | Specifies the divisor for an external counter timebase. You can divide the counter timebase in order to measure slower signals without causing the count register to roll over.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseMasterTimebaseDiv

DAQmxSetCICtrTimebaseMasterTimebaseDiv

DAQmxResetCICtrTimebaseMasterTimebaseDiv


Counter Output >> Output Type

Data Type: | int32
Description: | Indicates how to define pulses generated on the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Pulse_Time | 10269 | Generate pulses defined by the time the pulse is at a low state and the time the pulse is at a high state.
DAQmx_Val_Pulse_Freq | 10119 | Generate digital pulses defined by frequency and duty cycle.
DAQmx_Val_Pulse_Ticks | 10268 | Generate digital pulses defined by the number of timebase ticks that the pulse is at a low state and the number of timebase ticks that the pulse is at a high state.

You can get this property using:

DAQmxGetCOOutputType


Counter Output >> Pulse >> Time >> High Time

Data Type: | float64
Description: | Specifies the amount of time that the pulse is at a high voltage. This value is in the units you specify with Units or when you create the channel.

You can get/set/reset this property using:

DAQmxGetCOPulseHighTime

DAQmxSetCOPulseHighTime

DAQmxResetCOPulseHighTime


Counter Output >> Pulse >> Time >> Low Time

Data Type: | float64
Description: | Specifies the amount of time that the pulse is at a low voltage. This value is in the units you specify with Units or when you create the channel.

You can get/set/reset this property using:

DAQmxGetCOPulseLowTime

DAQmxSetCOPulseLowTime

DAQmxResetCOPulseLowTime


Counter Output >> Pulse >> Time >> Initial Delay

Data Type: | float64
Description: | Specifies in seconds the amount of time to wait before generating the first pulse.

You can get/set/reset this property using:

DAQmxGetCOPulseTimeInitialDelay

DAQmxSetCOPulseTimeInitialDelay

DAQmxResetCOPulseTimeInitialDelay


Counter Output >> General Properties >> Counter Timebase >> Rate

Data Type: | float64
Description: | Specifies in Hertz the frequency of the counter timebase. Specifying the rate of a counter timebase allows you to define output pulses in seconds rather than in ticks of the timebase. If you use an external timebase and do not specify the rate, you can define output pulses only in ticks of the timebase.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseRate

DAQmxSetCOCtrTimebaseRate

DAQmxResetCOCtrTimebaseRate


Counter Output >> General Properties >> More >> Counter Timebase Master Timebase Divisor

Data Type: | uInt32
Description: | Specifies the divisor for an external counter timebase. You can divide the counter timebase in order to generate slower signals without causing the count register to roll over.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseMasterTimebaseDiv

DAQmxSetCOCtrTimebaseMasterTimebaseDiv

DAQmxResetCOCtrTimebaseMasterTimebaseDiv


Counter Input >> Count Edges >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCICountEdgesTerm

DAQmxSetCICountEdgesTerm

DAQmxResetCICountEdgesTerm


Start >> More >> Delay Units

Data Type: | int32
Description: | Specifies the units of Delay.

Valid values
DAQmx_Val_SampClkPeriods | 10286 | Complete periods of the Sample Clock.
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.

You can get/set/reset this property using:

DAQmxGetStartTrigDelayUnits

DAQmxSetStartTrigDelayUnits

DAQmxResetStartTrigDelayUnits


Analog Input >> Temperature >> Thermistor >> A

Data Type: | float64
Description: | Specifies the 'A' constant of the Steinhart-Hart thermistor equation.

You can get/set/reset this property using:

DAQmxGetAIThrmstrA

DAQmxSetAIThrmstrA

DAQmxResetAIThrmstrA


Analog Input >> Temperature >> Thermistor >> C

Data Type: | float64
Description: | Specifies the 'C' constant of the Steinhart-Hart thermistor equation.

You can get/set/reset this property using:

DAQmxGetAIThrmstrC

DAQmxSetAIThrmstrC

DAQmxResetAIThrmstrC


Analog Input >> Temperature >> Thermistor >> B

Data Type: | float64
Description: | Specifies the 'B' constant of the Steinhart-Hart thermistor equation.

You can get/set/reset this property using:

DAQmxGetAIThrmstrB

DAQmxSetAIThrmstrB

DAQmxResetAIThrmstrB


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Wire Mode

Data Type: | int32
Description: | Specifies the number of leads on the LVDT or RVDT. Some sensors require you to tie leads together to create a four- or five- wire sensor. Refer to the sensor documentation for more information.

Valid values
DAQmx_Val_4Wire | 4 | 4-wire.
DAQmx_Val_5Wire | 5 | 5-wire.
DAQmx_Val_6Wire | 6 | 6-wire.

You can get/set/reset this property using:

DAQmxGetAIACExcitWireMode

DAQmxSetAIACExcitWireMode

DAQmxResetAIACExcitWireMode


Counter Output >> Pulse >> Frequency >> Units

Data Type: | int32
Description: | Specifies the units in which to define pulse frequency.

Valid values
DAQmx_Val_Hz 10373 Hertz.

You can get/set/reset this property using:

DAQmxGetCOPulseFreqUnits

DAQmxSetCOPulseFreqUnits

DAQmxResetCOPulseFreqUnits


Counter Output >> Pulse >> Time >> Units

Data Type: | int32
Description: | Specifies the units in which to define high and low pulse time.

Valid values
DAQmx_Val_Seconds 10364 Seconds.

You can get/set/reset this property using:

DAQmxGetCOPulseTimeUnits

DAQmxSetCOPulseTimeUnits

DAQmxResetCOPulseTimeUnits


Counter Output >> Pulse >> Output Terminal

Data Type: | char*
Description: | Specifies on which terminal to generate pulses.

You can get/set/reset this property using:

DAQmxGetCOPulseTerm

DAQmxSetCOPulseTerm

DAQmxResetCOPulseTerm


Deprecated >> Usage

Data Type: | int32
Description: | (Deprecated) Specifies how you can use the channel. Using this property acts as a safety mechanism to prevent you from connecting two source channels, for example.

Valid values
DAQmx_Val_Source | 10439 | You can use the channel only as an input for a signal.
DAQmx_Val_Load | 10440 | You can use the channel only as the output for a signal passing through the switch.
DAQmx_Val_ReservedForRouting | 10441 | You can use the channel only to complete routes within a switch.

You can get/set this property using:

DAQmxGetSwitchChanUsage

DAQmxSetSwitchChanUsage


Deprecated >> Capability >> Wire Mode

Data Type: | uInt32
Description: | (Deprecated) Indicates the number of wires that the channel switches.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanWireMode


Deprecated >> Capability >> Number of Relays

Data Type: | uInt32
Description: | (Deprecated) Indicates the number of relays on the device. This value matches the number of relay names in Relay List.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevNumRelays


Deprecated >> Capability >> Switch Channel List

Data Type: | char*
Description: | (Deprecated) Indicates a comma-delimited list of channel names for the current topology of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevSwitchChanList


Deprecated >> Capability >> Number of Switch Channels

Data Type: | uInt32
Description: | (Deprecated) Indicates the number of switch channels for the current topology of the device. This value matches the number of channel names in Switch Channel List.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevNumSwitchChans


Deprecated >> Capability >> Number of Rows

Data Type: | uInt32
Description: | (Deprecated) Indicates the number of rows on a device in a matrix switch topology. Indicates the number of multiplexed channels on a device in a mux topology.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevNumRows


Deprecated >> Capability >> Number of Columns

Data Type: | uInt32
Description: | (Deprecated) Indicates the number of columns on a device in a matrix switch topology. This value is always 1 if the device is in a mux topology.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevNumColumns


Sample Clock >> Timebase Divisor

Data Type: uInt32
Description: Specifies the number of Sample Clock Timebase pulses needed to produce a single Sample Clock pulse.

The rate of the Sample Clock is equal to (frequency of Sample Clock Timebase) / (value of this property).

If the Sample Clock Timebase is not a periodic clock, the value of this property determines the number of Sample Clock Timebase edges that the device must receive before producing each Sample Clock pulse. Use Active Edge to specify the polarity of these edges.

Setting this property has a similar effect to setting Rate. Use Rate when you know the rate of the Sample Clock Timebase and you want to acquire or generate samples at the specified rate. Use this property when you have an external timebase that you want to divide down and use as the Sample Clock, but you do not know rate of the external timebase.

You can get/set/reset this property using:

DAQmxGetSampClkTimebaseDiv

DAQmxSetSampClkTimebaseDiv

DAQmxResetSampClkTimebaseDiv


Sample Clock >> Timebase >> Active Edge

Data Type: | int32
Description: | Specifies on which edge to recognize a Sample Clock Timebase pulse. This property is useful primarily when the signal you use as the Sample Clock Timebase is not a periodic clock.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetSampClkTimebaseActiveEdge

DAQmxSetSampClkTimebaseActiveEdge

DAQmxResetSampClkTimebaseActiveEdge


Events >> AI Hold Complete Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the AI Hold Complete Event.

You can get/set/reset this property using:

DAQmxGetExportedAIHoldCmpltEventOutputTerm

DAQmxSetExportedAIHoldCmpltEventOutputTerm

DAQmxResetExportedAIHoldCmpltEventOutputTerm


Events >> AI Hold Complete Event >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of an exported AI Hold Complete Event pulse.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedAIHoldCmpltEventPulsePolarity

DAQmxSetExportedAIHoldCmpltEventPulsePolarity

DAQmxResetExportedAIHoldCmpltEventPulsePolarity


Digital Output >> Tristate

Data Type: bool32
Description: Specifies whether to stop driving the channel and set it to a high-impedance state. You must commit the task for this setting to take effect.

Setting this property before you commit the task determines whether NI-DAQmx drives data on the channel or tristates the channel after the task transitions to the committed state.

Use this property when you want to read and write to channels in a task. Set this property to TRUE before you read from the channel and set this property to FALSE before you write to the channel.

When you read from an output channel that is not tristated, the value corresponds to the current value you are driving on the channel.

When you write to a channel that is tristated, no change occurs until you set this property to FALSE. After you set this property to FALSE, the value NI-DAQmx drives on the channel corresponds to the last value written to the channel.

Ensure the channel is tristated before any external devices that you connect to the channel drive data onto the channel. Failure to do so could result in double-driving the channel and damaging the device.

This property is supported only for line-configurable, bidirectional ports.

You can get/set/reset this property using:

DAQmxGetDOTristate

DAQmxSetDOTristate

DAQmxResetDOTristate


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Fine Potentiometer

Data Type: | int32
Description: | Specifies by how much to compensate for offset in the signal. This value can be between 0 and 4095.

You can get/set/reset this property using:

DAQmxGetAIBridgeBalanceFinePot

DAQmxSetAIBridgeBalanceFinePot

DAQmxResetAIBridgeBalanceFinePot


General Properties >> Physical Channel Name

Data Type: | char*
Description: | Specifies the name of the physical channel upon which this virtual channel is based.

You can get/set this property using:

DAQmxGetPhysicalChanName

DAQmxSetPhysicalChanName


Pre-Scaled Units

Data Type: | int32
Description: | Specifies the units of the values that you want to scale.

Valid values
DAQmx_Val_Volts | 10348 | Volts.
DAQmx_Val_Amps | 10342 | Amperes.
DAQmx_Val_DegF | 10144 | Degrees Fahrenheit.
DAQmx_Val_DegC | 10143 | Degrees Celsius.
DAQmx_Val_DegR | 10145 | Degrees Rankine.
DAQmx_Val_Kelvins | 10325 | Kelvins.
DAQmx_Val_Strain | 10299 | Strain.
DAQmx_Val_Ohms | 10384 | Ohms.
DAQmx_Val_Hz | 10373 | Hertz.
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Meters | 10219 | Meters.
DAQmx_Val_Inches | 10379 | Inches.
DAQmx_Val_Degrees | 10146 | Degrees.
DAQmx_Val_Radians | 10273 | Radians.
DAQmx_Val_Ticks | 10304 | Ticks.
DAQmx_Val_RPM | 16080 | Revolutions per minute.
DAQmx_Val_RadiansPerSecond | 16081 | Radians per second.
DAQmx_Val_DegreesPerSecond | 16082 | Degrees per second.
DAQmx_Val_g | 10186 | 1 g is approximately equal to 9.81 m/s/s.
DAQmx_Val_MetersPerSecondSquared | 12470 | Meters per second per second.
DAQmx_Val_InchesPerSecondSquared | 12471 | Inches per second per second.
DAQmx_Val_MetersPerSecond | 15959 | Meters per second.
DAQmx_Val_InchesPerSecond | 15960 | Inches per second.
DAQmx_Val_Pascals | 10081 | Pascals.
DAQmx_Val_Newtons | 15875 | Newtons.
DAQmx_Val_Pounds | 15876 | Pounds.
DAQmx_Val_KilogramForce | 15877 | Kilograms-force.
DAQmx_Val_PoundsPerSquareInch | 15879 | Pounds per square inch.
DAQmx_Val_Bar | 15880 | Bar.
DAQmx_Val_NewtonMeters | 15881 | Newton meters.
DAQmx_Val_InchOunces | 15882 | Ounce-inches.
DAQmx_Val_InchPounds | 15883 | Pound-inches.
DAQmx_Val_FootPounds | 15884 | Pound-feet.
DAQmx_Val_VoltsPerVolt | 15896 | Volts per volt.
DAQmx_Val_mVoltsPerVolt | 15897 | Millivolts per volt.
DAQmx_Val_Coulombs | 16102 | Coulombs.
DAQmx_Val_PicoCoulombs | 16103 | PicoCoulombs.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set this property using:

DAQmxGetScalePreScaledUnits

DAQmxSetScalePreScaledUnits


Analog Input >> Temperature >> Advanced >> Force Read From Channel

Data Type: | bool32
Description: | Specifies whether to read from the channel if it is a cold-junction compensation channel. By default, an NI-DAQmx Read function does not return data from cold-junction compensation channels. Setting this property to TRUE forces read operations to return the cold-junction compensation channel data with the other channels in the task.

You can get/set/reset this property using:

DAQmxGetAIForceReadFromChan

DAQmxSetAIForceReadFromChan

DAQmxResetAIForceReadFromChan


Clocks >> Sample Clock Timebase >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Sample Clock Timebase.

You can get/set/reset this property using:

DAQmxGetExportedSampClkTimebaseOutputTerm

DAQmxSetExportedSampClkTimebaseOutputTerm

DAQmxResetExportedSampClkTimebaseOutputTerm


On Demand >> Simultaneous Analog Output Enable

Data Type: | bool32
Description: | Specifies whether to update all channels in the task simultaneously, rather than updating channels independently when you write a sample to that channel.

You can get/set/reset this property using:

DAQmxGetOnDemandSimultaneousAOEnable

DAQmxSetOnDemandSimultaneousAOEnable

DAQmxResetOnDemandSimultaneousAOEnable


Clocks >> Divided Sample Clock Timebase >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Divided Sample Clock Timebase.

You can get/set/reset this property using:

DAQmxGetExportedDividedSampClkTimebaseOutputTerm

DAQmxSetExportedDividedSampClkTimebaseOutputTerm

DAQmxResetExportedDividedSampClkTimebaseOutputTerm


Expiration Trigger >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to expire a watchdog task.

Valid values
DAQmx_Val_DigEdge | 10150 | Trigger on a rising or falling edge of a digital signal.
DAQmx_Val_None | 10230 | Disable the trigger.

You can get/set/reset this property using:

DAQmxGetWatchdogExpirTrigType

DAQmxSetWatchdogExpirTrigType

DAQmxResetWatchdogExpirTrigType


Expiration Trigger >> Digital Edge >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where a digital signal exists to use as the source of the Expiration Trigger.

You can get/set/reset this property using:

DAQmxGetDigEdgeWatchdogExpirTrigSrc

DAQmxSetDigEdgeWatchdogExpirTrigSrc

DAQmxResetDigEdgeWatchdogExpirTrigSrc


Expiration Trigger >> Digital Edge >> Edge

Data Type: | int32
Description: | Specifies on which edge of a digital signal to expire the watchdog task.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetDigEdgeWatchdogExpirTrigEdge

DAQmxSetDigEdgeWatchdogExpirTrigEdge

DAQmxResetDigEdgeWatchdogExpirTrigEdge


Expiration States >> Digital Output >> Expiration State

Data Type: | int32
Description: | Specifies the state to which to set the digital physical channels when the watchdog task expires. You cannot modify the expiration state of dedicated digital input physical channels.

Valid values
DAQmx_Val_High | 10192 | Logic high.
DAQmx_Val_Low | 10214 | Logic low.
DAQmx_Val_Tristate | 10310 | High-impedance state. You can select this state only on devices with bidirectional lines. You cannot select this state for dedicated digital output lines. On some devices, you can select this value only for entire ports.
DAQmx_Val_NoChange | 10160 | Do not change the state of the lines. On some devices, you can select this value only for entire ports.

You can get/set/reset this property using:

DAQmxGetWatchdogDOExpirState

DAQmxSetWatchdogDOExpirState

DAQmxResetWatchdogDOExpirState


Status >> Expired

Data Type: | bool32
Description: | Indicates if the watchdog timer expired. You can read this property only while the task is running.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWatchdogHasExpired


Timeout

Data Type: | float64
Description: | Specifies in seconds the amount of time until the watchdog timer expires. A value of -1 means the internal timer never expires. Set this input to -1 if you use an Expiration Trigger to expire the watchdog task.

You can get/set/reset this property using:

DAQmxGetWatchdogTimeout

DAQmxSetWatchdogTimeout

DAQmxResetWatchdogTimeout


Events >> Watchdog Timer Expired Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Watchdog Timer Expired Event.

You can get/set/reset this property using:

DAQmxGetExportedWatchdogExpiredEventOutputTerm

DAQmxSetExportedWatchdogExpiredEventOutputTerm

DAQmxResetExportedWatchdogExpiredEventOutputTerm


Counter Input >> General Properties >> More >> Advanced >> Duplicate Count Prevention

Data Type: | bool32
Description: | Specifies whether to enable duplicate count prevention for the channel. Duplicate count prevention is enabled by default. Setting Prescaler disables duplicate count prevention unless you explicitly enable it.

You can get/set/reset this property using:

DAQmxGetCIDupCountPrevent

DAQmxSetCIDupCountPrevent

DAQmxResetCIDupCountPrevent


Clocks >> Sample Clock >> Delay Offset

Data Type: | float64
Description: | Specifies in seconds the amount of time to offset the exported Sample clock. Refer to timing diagrams for generation applications in the device documentation for more information about this value.

You can get/set/reset this property using:

DAQmxGetExportedSampClkDelayOffset

DAQmxSetExportedSampClkDelayOffset

DAQmxResetExportedSampClkDelayOffset


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Select

Data Type: | int32
Description: | Specifies which shunt calibration switch(es) to enable. Use Shunt Cal Enable to enable the switch(es) you specify with this property.

Valid values
DAQmx_Val_A | 12513 | Switch A.
DAQmx_Val_B | 12514 | Switch B.
DAQmx_Val_AandB | 12515 | Switches A and B.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalSelect

DAQmxSetAIBridgeShuntCalSelect

DAQmxResetAIBridgeShuntCalSelect


Digital Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to enable the digital filter for the line(s) or port(s). You can enable the filter on a line-by-line basis. You do not have to enable the filter for all lines in a channel.

You can get/set/reset this property using:

DAQmxGetDIDigFltrEnable

DAQmxSetDIDigFltrEnable

DAQmxResetDIDigFltrEnable


Digital Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes as a valid high or low state transition.

You can get/set/reset this property using:

DAQmxGetDIDigFltrMinPulseWidth

DAQmxSetDIDigFltrMinPulseWidth

DAQmxResetDIDigFltrMinPulseWidth


TEDS >> ManufacturerID

Data Type: | uInt32
Description: | Indicates the manufacturer ID of the sensor.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSMfgID


TEDS >> Model Number

Data Type: | uInt32
Description: | Indicates the model number of the sensor.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSModelNum


TEDS >> Serial Number

Data Type: | uInt32
Description: | Indicates the serial number of the sensor.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSSerialNum


TEDS >> Version Number

Data Type: | uInt32
Description: | Indicates the version number of the sensor.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSVersionNum


TEDS >> Version Letter

Data Type: | char*
Description: | Indicates the version letter of the sensor.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSVersionLetter


TEDS >> BitStream

Data Type: | uInt8*
Description: | Indicates the TEDS binary bitstream without checksums.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSBitStream


Analog Input >> TEDS >> Units

Data Type: | char*
Description: | Indicates the units defined by TEDS information associated with the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAITEDSUnits


Counter Input >> Count Edges >> Count Direction >> Input >> Terminal

Data Type: | char*
Description: | Specifies the source terminal of the digital signal that controls the count direction if Direction is DAQmx_Val_ExtControlled.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDirTerm

DAQmxSetCICountEdgesDirTerm

DAQmxResetCICountEdgesDirTerm


Counter Input >> Position >> Decoding Type

Data Type: | int32
Description: | Specifies how to count and interpret the pulses the encoder generates on signal A and signal B. DAQmx_Val_X1, DAQmx_Val_X2, and DAQmx_Val_X4 are valid for quadrature encoders only. DAQmx_Val_TwoPulseCounting is valid for two-pulse encoders only. X2 and X4 decoding are more sensitive to smaller changes in position than X1 encoding, with X4 being the most sensitive. However, more sensitive decoding is more likely to produce erroneous measurements if vibration exists in the encoder or other noise exists in the signals.

Valid values
DAQmx_Val_X1 | 10090 | If signal A leads signal B, count the rising edges of signal A. If signal B leads signal A, count the falling edges of signal A.
DAQmx_Val_X2 | 10091 | Count the rising and falling edges of signal A.
DAQmx_Val_X4 | 10092 | Count the rising and falling edges of signal A and signal B.
DAQmx_Val_TwoPulseCounting | 10313 | Increment the count on rising edges of signal A. Decrement the count on rising edges of signal B.

You can get/set/reset this property using:

DAQmxGetCIEncoderDecodingType

DAQmxSetCIEncoderDecodingType

DAQmxResetCIEncoderDecodingType


Counter Input >> Frequency >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIFreqDigFltrEnable

DAQmxSetCIFreqDigFltrEnable

DAQmxResetCIFreqDigFltrEnable


Counter Input >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIFreqDigFltrMinPulseWidth

DAQmxSetCIFreqDigFltrMinPulseWidth

DAQmxResetCIFreqDigFltrMinPulseWidth


Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIFreqDigFltrTimebaseSrc

DAQmxSetCIFreqDigFltrTimebaseSrc

DAQmxResetCIFreqDigFltrTimebaseSrc


Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIFreqDigFltrTimebaseRate

DAQmxSetCIFreqDigFltrTimebaseRate

DAQmxResetCIFreqDigFltrTimebaseRate


Counter Input >> Frequency >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIFreqDigSyncEnable

DAQmxSetCIFreqDigSyncEnable

DAQmxResetCIFreqDigSyncEnable


Counter Input >> Period >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIPeriodDigFltrEnable

DAQmxSetCIPeriodDigFltrEnable

DAQmxResetCIPeriodDigFltrEnable


Counter Input >> Period >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIPeriodDigFltrMinPulseWidth

DAQmxSetCIPeriodDigFltrMinPulseWidth

DAQmxResetCIPeriodDigFltrMinPulseWidth


Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIPeriodDigFltrTimebaseSrc

DAQmxSetCIPeriodDigFltrTimebaseSrc

DAQmxResetCIPeriodDigFltrTimebaseSrc


Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIPeriodDigFltrTimebaseRate

DAQmxSetCIPeriodDigFltrTimebaseRate

DAQmxResetCIPeriodDigFltrTimebaseRate


Counter Input >> Period >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIPeriodDigSyncEnable

DAQmxSetCIPeriodDigSyncEnable

DAQmxResetCIPeriodDigSyncEnable


Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirDigFltrEnable

DAQmxSetCICountEdgesCountDirDigFltrEnable

DAQmxResetCICountEdgesCountDirDigFltrEnable


Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirDigFltrMinPulseWidth

DAQmxSetCICountEdgesCountDirDigFltrMinPulseWidth

DAQmxResetCICountEdgesCountDirDigFltrMinPulseWidth


Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirDigFltrTimebaseSrc

DAQmxSetCICountEdgesCountDirDigFltrTimebaseSrc

DAQmxResetCICountEdgesCountDirDigFltrTimebaseSrc


Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirDigFltrTimebaseRate

DAQmxSetCICountEdgesCountDirDigFltrTimebaseRate

DAQmxResetCICountEdgesCountDirDigFltrTimebaseRate


Counter Input >> Count Edges >> Count Direction >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirDigSyncEnable

DAQmxSetCICountEdgesCountDirDigSyncEnable

DAQmxResetCICountEdgesCountDirDigSyncEnable


Counter Input >> Count Edges >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDigFltrEnable

DAQmxSetCICountEdgesDigFltrEnable

DAQmxResetCICountEdgesDigFltrEnable


Counter Input >> Count Edges >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDigFltrMinPulseWidth

DAQmxSetCICountEdgesDigFltrMinPulseWidth

DAQmxResetCICountEdgesDigFltrMinPulseWidth


Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDigFltrTimebaseSrc

DAQmxSetCICountEdgesDigFltrTimebaseSrc

DAQmxResetCICountEdgesDigFltrTimebaseSrc


Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDigFltrTimebaseRate

DAQmxSetCICountEdgesDigFltrTimebaseRate

DAQmxResetCICountEdgesDigFltrTimebaseRate


Counter Input >> Count Edges >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDigSyncEnable

DAQmxSetCICountEdgesDigSyncEnable

DAQmxResetCICountEdgesDigSyncEnable


Counter Input >> Position >> A Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputDigFltrEnable

DAQmxSetCIEncoderAInputDigFltrEnable

DAQmxResetCIEncoderAInputDigFltrEnable


Counter Input >> Position >> A Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputDigFltrMinPulseWidth

DAQmxSetCIEncoderAInputDigFltrMinPulseWidth

DAQmxResetCIEncoderAInputDigFltrMinPulseWidth


Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputDigFltrTimebaseSrc

DAQmxSetCIEncoderAInputDigFltrTimebaseSrc

DAQmxResetCIEncoderAInputDigFltrTimebaseSrc


Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputDigFltrTimebaseRate

DAQmxSetCIEncoderAInputDigFltrTimebaseRate

DAQmxResetCIEncoderAInputDigFltrTimebaseRate


Counter Input >> Position >> A Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputDigSyncEnable

DAQmxSetCIEncoderAInputDigSyncEnable

DAQmxResetCIEncoderAInputDigSyncEnable


Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Reverse Coefficients

Data Type: | float64*
Description: | Specifies the reverse polynomial values used for calibrating the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalPolyReverseCoeff

DAQmxSetAIChanCalPolyReverseCoeff

DAQmxResetAIChanCalPolyReverseCoeff


Analog Input >> General Properties >> Channel Calibration >> Verification >> Reference Values

Data Type: | float64*
Description: | Specifies the reference values collected when verifying the calibration. NI-DAQmx stores these values as a record of calibration accuracy and does not use them in the scaling process. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalVerifRefVals

DAQmxSetAIChanCalVerifRefVals

DAQmxResetAIChanCalVerifRefVals


Analog Input >> General Properties >> Channel Calibration >> Verification >> Acquired Values

Data Type: | float64*
Description: | Specifies the acquired values collected when verifying the calibration. NI-DAQmx stores these values as a record of calibration accuracy and does not use them in the scaling process. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalVerifAcqVals

DAQmxSetAIChanCalVerifAcqVals

DAQmxResetAIChanCalVerifAcqVals


Analog Input >> General Properties >> Channel Calibration >> Operator Name

Data Type: | char*
Description: | Specifies the name of the operator who performed the channel calibration. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalOperatorName

DAQmxSetAIChanCalOperatorName

DAQmxResetAIChanCalOperatorName


Analog Input >> General Properties >> Channel Calibration >> Description

Data Type: | char*
Description: | Specifies the description entered for the calibration of the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalDesc

DAQmxSetAIChanCalDesc

DAQmxResetAIChanCalDesc


Advanced >> Sleep Time

Data Type: | float64
Description: | Specifies in seconds the amount of time to sleep after checking for available samples if Wait Mode is DAQmx_Val_Sleep.

You can get/set/reset this property using:

DAQmxGetReadSleepTime

DAQmxSetReadSleepTime

DAQmxResetReadSleepTime


Advanced >> Wait Mode

Data Type: | int32
Description: | Specifies how an NI-DAQmx Write function waits for space to become available in the buffer.

Valid values
DAQmx_Val_Poll | 12524 | Repeatedly check for available buffer space as fast as possible. This mode allows for the highest sampling rates at the expense of CPU efficiency.
DAQmx_Val_Yield | 12525 | Repeatedly check for available buffer space, but yield control to other threads after each check. This mode offers a balance between sampling rate and CPU efficiency.
DAQmx_Val_Sleep | 12547 | Check for available buffer space once per the amount of time specified in Sleep Time.

You can get/set/reset this property using:

DAQmxGetWriteWaitMode

DAQmxSetWriteWaitMode

DAQmxResetWriteWaitMode


Advanced >> Sleep Time

Data Type: | float64
Description: | Specifies in seconds the amount of time to sleep after checking for available buffer space if Wait Mode is DAQmx_Val_Sleep.

You can get/set/reset this property using:

DAQmxGetWriteSleepTime

DAQmxSetWriteSleepTime

DAQmxResetWriteSleepTime


Counter Input >> Timestamp >> Units

Data Type: | int32
Description: | Specifies the units to use to return timestamp measurements.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCITimestampUnits

DAQmxSetCITimestampUnits

DAQmxResetCITimestampUnits


Counter Input >> Timestamp >> Initial Seconds

Data Type: | uInt32
Description: | Specifies the number of seconds that elapsed since the beginning of the current year. This value is ignored if Synchronization Method is DAQmx_Val_IRIGB.

You can get/set/reset this property using:

DAQmxGetCITimestampInitialSeconds

DAQmxSetCITimestampInitialSeconds

DAQmxResetCITimestampInitialSeconds


Events >> Ready For Transfer Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Ready for Transfer Event.

You can get/set/reset this property using:

DAQmxGetExportedRdyForXferEventOutputTerm

DAQmxSetExportedRdyForXferEventOutputTerm

DAQmxResetExportedRdyForXferEventOutputTerm


Events >> Ready For Transfer Event >> Level >> Active Level

Data Type: | int32
Description: | Specifies the active level of the exported Ready for Transfer Event.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedRdyForXferEventLvlActiveLvl

DAQmxSetExportedRdyForXferEventLvlActiveLvl

DAQmxResetExportedRdyForXferEventLvlActiveLvl


More >> Handshake >> Trigger Type

Data Type: | int32
Description: | Specifies the type of Handshake Trigger to use.

Valid values
DAQmx_Val_Interlocked | 12549 | Use the Handshake Trigger as a control signal for asynchronous handshaking, such as 8255 handshaking.
DAQmx_Val_None | 10230 | Start the measurement or generation immediately when you start the task.

You can get/set/reset this property using:

DAQmxGetHshkTrigType

DAQmxSetHshkTrigType

DAQmxResetHshkTrigType


More >> Handshake >> Interlocked >> Source

Data Type: | char*
Description: | Specifies the source terminal of the Handshake Trigger.

You can get/set/reset this property using:

DAQmxGetInterlockedHshkTrigSrc

DAQmxSetInterlockedHshkTrigSrc

DAQmxResetInterlockedHshkTrigSrc


More >> Handshake >> Interlocked >> Asserted Level

Data Type: | int32
Description: | Specifies the asserted level of the Handshake Trigger.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetInterlockedHshkTrigAssertedLvl

DAQmxSetInterlockedHshkTrigAssertedLvl

DAQmxResetInterlockedHshkTrigAssertedLvl


Events >> Handshake Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Handshake Event.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventOutputTerm

DAQmxSetExportedHshkEventOutputTerm

DAQmxResetExportedHshkEventOutputTerm


Events >> Handshake Event >> Output Behavior

Data Type: | int32
Description: | Specifies the output behavior of the Handshake Event.

Valid values
DAQmx_Val_Interlocked | 12549 | Handshake Event deasserts after the Handshake Trigger asserts, plus the amount of time specified with Deassert Delay Value.
DAQmx_Val_Pulse | 10265 | Handshake Event pulses with the pulse width specified in Width Value.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventOutputBehavior

DAQmxSetExportedHshkEventOutputBehavior

DAQmxResetExportedHshkEventOutputBehavior


Events >> Handshake Event >> Delay Value

Data Type: | float64
Description: | Specifies the number of seconds to delay after the Handshake Trigger deasserts before asserting the Handshake Event.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventDelay

DAQmxSetExportedHshkEventDelay

DAQmxResetExportedHshkEventDelay


Events >> Handshake Event >> Interlocked >> Asserted Level

Data Type: | int32
Description: | Specifies the asserted level of the exported Handshake Event if Output Behavior is DAQmx_Val_Interlocked.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventInterlockedAssertedLvl

DAQmxSetExportedHshkEventInterlockedAssertedLvl

DAQmxResetExportedHshkEventInterlockedAssertedLvl


Events >> Handshake Event >> Interlocked >> Assert on Start

Data Type: | bool32
Description: | Specifies to assert the Handshake Event when the task starts if Output Behavior is DAQmx_Val_Interlocked.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventInterlockedAssertOnStart

DAQmxSetExportedHshkEventInterlockedAssertOnStart

DAQmxResetExportedHshkEventInterlockedAssertOnStart


Events >> Handshake Event >> Interlocked >> Deassert Delay Value

Data Type: | float64
Description: | Specifies in seconds the amount of time to wait after the Handshake Trigger asserts before deasserting the Handshake Event if Output Behavior is DAQmx_Val_Interlocked.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventInterlockedDeassertDelay

DAQmxSetExportedHshkEventInterlockedDeassertDelay

DAQmxResetExportedHshkEventInterlockedDeassertDelay


Events >> Handshake Event >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the exported Handshake Event if Output Behavior is DAQmx_Val_Pulse.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventPulsePolarity

DAQmxSetExportedHshkEventPulsePolarity

DAQmxResetExportedHshkEventPulsePolarity


Events >> Handshake Event >> Pulse >> Width Value

Data Type: | float64
Description: | Specifies in seconds the pulse width of the exported Handshake Event if Output Behavior is DAQmx_Val_Pulse.

You can get/set/reset this property using:

DAQmxGetExportedHshkEventPulseWidth

DAQmxSetExportedHshkEventPulseWidth

DAQmxResetExportedHshkEventPulseWidth


Handshake >> Delay After Transfer

Data Type: | float64
Description: | Specifies the number of seconds to wait after a handshake cycle before starting a new handshake cycle.

You can get/set/reset this property using:

DAQmxGetHshkDelayAfterXfer

DAQmxSetHshkDelayAfterXfer

DAQmxResetHshkDelayAfterXfer


Handshake >> Start Condition

Data Type: | int32
Description: | Specifies the point in the handshake cycle that the device is in when the task starts.

Valid values
DAQmx_Val_Immediate | 10198 | Device is waiting for space in the FIFO (for acquisition) or waiting for samples (for generation).
DAQmx_Val_WaitForHandshakeTriggerAssert | 12550 | Device is waiting for the Handshake Trigger to assert.
DAQmx_Val_WaitForHandshakeTriggerDeassert | 12551 | Device is waiting for the Handshake Trigger to deassert.

You can get/set/reset this property using:

DAQmxGetHshkStartCond

DAQmxSetHshkStartCond

DAQmxResetHshkStartCond


Handshake >> Sample Input Data When

Data Type: | int32
Description: | Specifies on which edge of the Handshake Trigger an input task latches the data from the peripheral device.

Valid values
DAQmx_Val_HandshakeTriggerAsserts | 12552 | Latch data when the Handshake Trigger asserts.
DAQmx_Val_HandshakeTriggerDeasserts | 12553 | Latch data when the Handshake Trigger deasserts.

You can get/set/reset this property using:

DAQmxGetHshkSampleInputDataWhen

DAQmxSetHshkSampleInputDataWhen

DAQmxResetHshkSampleInputDataWhen


Sample Clock >> Maximum Rate

Data Type: | float64
Description: | Indicates the maximum Sample Clock rate supported by the task, based on other timing settings. For output tasks, the maximum Sample Clock rate is the maximum rate of the DAC. For input tasks, NI-DAQmx calculates the maximum sampling rate differently for multiplexed devices than simultaneous sampling devices. For multiplexed devices, NI-DAQmx calculates the maximum sample clock rate based on the maximum AI Convert Clock rate unless you set Rate. If you set that property, NI-DAQmx calculates the maximum sample clock rate based on that setting. Use Maximum Rate to query the maximum AI Convert Clock rate. NI-DAQmx also uses the minimum sample clock delay to calculate the maximum sample clock rate unless you set Delay. For simultaneous sampling devices, the maximum Sample Clock rate is the maximum rate of the ADC.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSampClkMaxRate


More >> AI Convert >> Maximum Rate

Data Type: float64
Description: Indicates the maximum convert rate supported by the task, given the current devices and channel count.

This rate is generally faster than the default AI Convert Clock rate selected by NI-DAQmx, because NI-DAQmx adds in an additional 10 microseconds per channel settling time to compensate for most potential system settling constraints.

For single channel tasks, the maximum AI Convert Clock rate is the maximum rate of the ADC. For multiple channel tasks, the maximum AI Convert Clock rate is the maximum convert rate of the analog hardware, including the ADC, filters, multiplexers, and amplifiers. Signal conditioning accessories can further constrain the maximum AI Convert Clock based on timing and settling requirements.

Restrictions: Not Settable

You can get this property using:

DAQmxGetAIConvMaxRate

DAQmxGetAIConvMaxRateEx


Device Is Simulated

Data Type: | bool32
Description: | Indicates if the device is a simulated device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevIsSimulated


Author

Data Type: | char*
Description: | Indicates the author of the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedTaskAuthor


Allow Interactive Editing?

Data Type: | bool32
Description: | Indicates whether the task can be edited in the DAQ Assistant.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedTaskAllowInteractiveEditing


Allow Interactive Deletion?

Data Type: | bool32
Description: | Indicates whether the task can be deleted through MAX.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedTaskAllowInteractiveDeletion


Author

Data Type: | char*
Description: | Indicates the author of the global channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedChanAuthor


Allow Interactive Editing?

Data Type: | bool32
Description: | Indicates whether the global channel can be edited in the DAQ Assistant.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedChanAllowInteractiveEditing


Allow Interactive Deletion?

Data Type: | bool32
Description: | Indicates whether the global channel can be deleted through MAX.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedChanAllowInteractiveDeletion


Author

Data Type: | char*
Description: | Indicates the author of the custom scale.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedScaleAuthor


Allow Interactive Editing?

Data Type: | bool32
Description: | Indicates whether the custom scale can be edited in the DAQ Assistant.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedScaleAllowInteractiveEditing


Allow Interactive Deletion?

Data Type: | bool32
Description: | Indicates whether the custom scale can be deleted through MAX.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPersistedScaleAllowInteractiveDeletion


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Raw Data Compression Type

Data Type: | int32
Description: | Specifies the type of compression to apply to raw samples returned from the device. Refer to the DAQmx Professional Tools Web site for more information and examples of raw data compression and streaming to disk.

Valid values
DAQmx_Val_None | 10230 | Do not compress samples.
DAQmx_Val_LosslessPacking | 12555 | Remove unused bits from samples. No resolution is lost.
DAQmx_Val_LossyLSBRemoval | 12556 | Remove unused bits from samples. Then, if necessary, remove bits from samples until the samples are the size specified with Compressed Sample Size. This compression type limits resolution to the specified sample size.

You can get/set/reset this property using:

DAQmxGetAIRawDataCompressionType

DAQmxSetAIRawDataCompressionType

DAQmxResetAIRawDataCompressionType


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Lossy LSB Removal >> Compressed Sample Size

Data Type: | uInt32
Description: | Specifies the number of bits to return in a raw sample when Raw Data Compression Type is set to DAQmx_Val_LossyLSBRemoval. Refer to the DAQmx Professional Tools Web site for more information and examples of raw data compression and streaming to disk.

You can get/set/reset this property using:

DAQmxGetAILossyLSBRemovalCompressedSampSize

DAQmxSetAILossyLSBRemovalCompressedSampSize

DAQmxResetAILossyLSBRemovalCompressedSampSize


Analog Input >> General Properties >> Digitizer/ADC >> Raw Sample Size

Data Type: | uInt32
Description: | Indicates in bits the size of a raw sample from the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIRawSampSize


Deprecated >> Power Down Latching Relays After Settling

Data Type: | bool32
Description: | (Deprecated) Specifies if DAQmxSwitchWaitForSettling() powers down latching relays after waiting for the device to settle.

You can get/set this property using:

DAQmxGetSwitchDevPwrDownLatchRelaysAfterSettling

DAQmxSetSwitchDevPwrDownLatchRelaysAfterSettling


Number Of Warmup Iterations

Data Type: | uInt32
Description: | Specifies the number of loop iterations that must occur before DAQmxWaitForNextSampleClock() and an NI-DAQmx Read function return any late warnings or errors. The system needs a number of iterations to stabilize. During this period, a large amount of jitter occurs, potentially causing reads and writes to be late. The default number of warmup iterations is 100. Specify a larger number if needed to stabilize the system.

You can get/set/reset this property using:

DAQmxGetRealTimeNumOfWarmupIters

DAQmxSetRealTimeNumOfWarmupIters

DAQmxResetRealTimeNumOfWarmupIters


Convert Late Errors To Warnings

Data Type: | bool32
Description: | Specifies if DAQmxWaitForNextSampleClock(), an NI-DAQmx Read function, and an NI-DAQmx Write function convert late errors to warnings. NI-DAQmx returns no late warnings or errors until the number of warmup iterations you specify with Number Of Warmup Iterations execute.

You can get/set/reset this property using:

DAQmxGetRealTimeConvLateErrorsToWarnings

DAQmxSetRealTimeConvLateErrorsToWarnings

DAQmxResetRealTimeConvLateErrorsToWarnings


Wait For Next Sample Clock Wait Mode

Data Type: | int32
Description: | Specifies how DAQmxWaitForNextSampleClock() waits for the next Sample Clock pulse.

Valid values
DAQmx_Val_WaitForInterrupt | 12523 | Check for Sample Clock pulses when the system receives an interrupt service request. This mode is the most CPU efficient, but results in lower possible sampling rates.
DAQmx_Val_Poll | 12524 | Repeatedly check for Sample Clock pulses as fast as possible. This mode allows for the highest sampling rates at the expense of CPU efficiency.

You can get/set/reset this property using:

DAQmxGetRealTimeWaitForNextSampClkWaitMode

DAQmxSetRealTimeWaitForNextSampClkWaitMode

DAQmxResetRealTimeWaitForNextSampClkWaitMode


Counter Input >> Semi-Period >> Starting Edge

Data Type: | int32
Description: | Specifies on which edge of the input signal to begin semi-period measurement. Semi-period measurements alternate between high time and low time, starting on this edge.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCISemiPeriodStartingEdge

DAQmxSetCISemiPeriodStartingEdge

DAQmxResetCISemiPeriodStartingEdge


Counter Output >> General Properties >> More >> Advanced >> Ready For New Value

Data Type: | bool32
Description: | Indicates whether the counter is ready for new continuous pulse train values.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCORdyForNewVal


I/O Type >> Counter Input >> Maximum Timebase

Data Type: | float64
Description: | Indicates in hertz the maximum counter timebase frequency.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCIMaxTimebase


I/O Type >> Counter Output >> Maximum Size

Data Type: | uInt32
Description: | Indicates in bits the size of the counters on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCOMaxSize


I/O Type >> Counter Output >> Maximum Timebase

Data Type: | float64
Description: | Indicates in hertz the maximum counter timebase frequency.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCOMaxTimebase


Analog Output >> Output Configuration >> Terminal Configurations

Data Type: | int32
Description: | Indicates the list of terminal configurations supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TermCfg_RSE | 1 | RSE terminal configuration
DAQmx_Val_Bit_TermCfg_NRSE | 2 | NRSE terminal configuration
DAQmx_Val_Bit_TermCfg_Diff | 4 | Differential terminal configuration
DAQmx_Val_Bit_TermCfg_PseudoDIFF | 8 | Pseudodifferential terminal configuration

You can get this property using:

DAQmxGetPhysicalChanAOTermCfgs


Digital Input >> Port Width

Data Type: | uInt32
Description: | Indicates in bits the width of digital input port.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanDIPortWidth


Digital Input >> Timing >> Sample Clock Supported

Data Type: | bool32
Description: | Indicates if the sample clock timing type is supported for the digital input physical channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanDISampClkSupported


Digital Input >> Timing >> Change Detection Supported

Data Type: | bool32
Description: | Indicates if the change detection timing type is supported for the digital input physical channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanDIChangeDetectSupported


Digital Output >> Port Width

Data Type: | uInt32
Description: | Indicates in bits the width of digital output port.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanDOPortWidth


Digital Output >> Timing >> Sample Clock Supported

Data Type: | bool32
Description: | Indicates if the sample clock timing type is supported for the digital output physical channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanDOSampClkSupported


Identification >> Product Category

Data Type: | int32
Description: | Indicates the product category of the device. This category corresponds to the category displayed in MAX when creating NI-DAQmx simulated devices.
Restrictions: | Not Settable

Valid values
DAQmx_Val_MSeriesDAQ | 14643 | M Series DAQ.
DAQmx_Val_XSeriesDAQ | 15858 | X Series DAQ.
DAQmx_Val_ESeriesDAQ | 14642 | E Series DAQ.
DAQmx_Val_SSeriesDAQ | 14644 | S Series DAQ.
DAQmx_Val_BSeriesDAQ | 14662 | B Series DAQ.
DAQmx_Val_SCSeriesDAQ | 14645 | SC Series DAQ.
DAQmx_Val_USBDAQ | 14646 | USB DAQ.
DAQmx_Val_AOSeries | 14647 | AO Series.
DAQmx_Val_DigitalIO | 14648 | Digital I/O.
DAQmx_Val_TIOSeries | 14661 | TIO Series.
DAQmx_Val_DynamicSignalAcquisition | 14649 | Dynamic Signal Acquisition.
DAQmx_Val_Switches | 14650 | Switches.
DAQmx_Val_CompactDAQChassis | 14658 | CompactDAQ chassis.
DAQmx_Val_CSeriesModule | 14659 | C Series I/O module.
DAQmx_Val_SCXIModule | 14660 | SCXI module.
DAQmx_Val_SCCConnectorBlock | 14704 | SCC Connector Block.
DAQmx_Val_SCCModule | 14705 | SCC Module.
DAQmx_Val_NIELVIS | 14755 | NI ELVIS.
DAQmx_Val_NetworkDAQ | 14829 | Network DAQ.
DAQmx_Val_SCExpress | 15886 | SC Express.
DAQmx_Val_Unknown | 12588 | Unknown category.

You can get this property using:

DAQmxGetDevProductCategory


Analog Input >> Voltage >> dB Reference

Data Type: | float64
Description: | Specifies the decibel reference level in the units of the channel. When you read samples as a waveform, the decibel reference level is included in the waveform attributes.

You can get/set/reset this property using:

DAQmxGetAIVoltagedBRef

DAQmxSetAIVoltagedBRef

DAQmxResetAIVoltagedBRef


Analog Input >> Sound Pressure >> dB Reference

Data Type: | float64
Description: | Specifies the decibel reference level in the units of the channel. When you read samples as a waveform, the decibel reference level is included in the waveform attributes. NI-DAQmx also uses the decibel reference level when converting Maximum Sound Pressure Level to a voltage level.

You can get/set/reset this property using:

DAQmxGetAISoundPressuredBRef

DAQmxSetAISoundPressuredBRef

DAQmxResetAISoundPressuredBRef


Analog Input >> Acceleration >> dB Reference

Data Type: | float64
Description: | Specifies the decibel reference level in the units of the channel. When you read samples as a waveform, the decibel reference level is included in the waveform attributes.

You can get/set/reset this property using:

DAQmxGetAIAcceldBRef

DAQmxSetAIAcceldBRef

DAQmxResetAIAcceldBRef


Chassis >> Module Device Names

Data Type: | char*
Description: | Indicates an array containing the names of the modules in the chassis.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevChassisModuleDevNames


Location >> CompactDAQ >> Chassis Device Name

Data Type: | char*
Description: | Indicates the name of the CompactDAQ chassis that contains this module.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCompactDAQChassisDevName


Location >> CompactDAQ >> Slot Number

Data Type: | uInt32
Description: | Indicates the slot number in which this module is located in the CompactDAQ chassis.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCompactDAQSlotNum


Number of Devices

Data Type: | uInt32
Description: | Indicates the number of devices in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskNumDevices


I/O Type >> Analog Input >> Voltage >> Internal Excitation >> Discrete Values

Data Type: | float64*
Description: | Indicates the set of discrete internal voltage excitation values supported by this device. If the device supports ranges of internal excitation values, use Range Values to determine supported excitation values.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIVoltageIntExcitDiscreteVals


I/O Type >> Analog Input >> Voltage >> Internal Excitation >> Range Values

Data Type: | float64*
Description: | Indicates pairs of internal voltage excitation ranges supported by this device. Each pair consists of the low value, followed by the high value. If the device supports a set of discrete internal excitation values, use Discrete Values to determine the supported excitation values.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIVoltageIntExcitRangeVals


I/O Type >> Analog Input >> Current >> Internal Excitation >> Discrete Values

Data Type: | float64*
Description: | Indicates the set of discrete internal current excitation values supported by this device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAICurrentIntExcitDiscreteVals


I/O Type >> Analog Input >> Filter >> Analog Low Pass >> Cutoff Frequency >> Range Values

Data Type: | float64*
Description: | Indicates pairs of lowpass cutoff frequency ranges supported by this device. Each pair consists of the low value, followed by the high value. If the device supports a set of discrete lowpass cutoff frequencies, use Discrete Values to determine the supported frequencies.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAILowpassCutoffFreqRangeVals


Analog Input >> Temperature >> Thermocouple >> Scale Type

Data Type: | int32
Description: | Specifies the method or equation form that the thermocouple scale uses.

Valid values
DAQmx_Val_Polynomial | 10449 | Scale values by using an Nth order polynomial equation.
DAQmx_Val_Table | 10450 | Map an array of prescaled values to an array of corresponding scaled values, with all other values scaled proportionally.

You can get/set/reset this property using:

DAQmxGetAIThrmcplScaleType

DAQmxSetAIThrmcplScaleType

DAQmxResetAIThrmcplScaleType


Status >> Overcurrent >> Overcurrent Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overcurrent condition for any virtual channel in the task. Reading this property clears the overcurrent status for all channels in the task. You must read this property before you read Overcurrent Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOvercurrentChansExist


Status >> Overcurrent >> Overcurrent Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected an overcurrent condition. You must read Overcurrent Channels Exist before you read this property. Otherwise, you will receive an error. On some devices, you must restart the task for all overcurrent channels to recover.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOvercurrentChans


Status >> Overcurrent >> Overcurrent Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overcurrent condition for any channel in the task. Reading this property clears the overcurrent status for all channels in the task. You must read this property before you read Overcurrent Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOvercurrentChansExist


Status >> Overcurrent >> Overcurrent Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which an overcurrent condition has been detected. You must read Overcurrent Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOvercurrentChans


Status >> Open Current Loop >> Open Current Loop Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an open current loop for any channel in the task. Reading this property clears the open current loop status for all channels in the task. You must read this property before you read Open Current Loop Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOpenCurrentLoopChansExist


Status >> Open Current Loop >> Open Current Loop Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected an open current loop. You must read Open Current Loop Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOpenCurrentLoopChans


Status >> Power Supply Fault >> Power Supply Fault Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected a power supply fault for any channel in the task. Reading this property clears the power supply fault status for all channels in the task. You must read this property before you read Power Supply Fault Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWritePowerSupplyFaultChansExist


Status >> Power Supply Fault >> Power Supply Fault Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task that have a power supply fault. You must read Power Supply Fault Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWritePowerSupplyFaultChans


Counter Output >> General Properties >> More >> Advanced >> Constrained Generation Mode

Data Type: | int32
Description: | Specifies constraints to apply when the counter generates pulses. Constraining the counter reduces the device resources required for counter operation. Constraining the counter can also allow additional analog or counter tasks on the device to run concurrently. For continuous counter tasks, NI-DAQmx consumes no device resources when the counter is constrained. For finite counter tasks, resource use increases with the frequency regardless of the constraint mode. However, fixed frequency constraints significantly reduce resource usage, and fixed duty cycle constraint marginally reduces it.

Valid values
DAQmx_Val_Unconstrained | 14708 | Counter has no restrictions on pulse generation.
DAQmx_Val_FixedHighFreq | 14709 | Pulse frequency must be above 7.63 Hz and cannot change while the task runs. In this mode, the duty cycle has 8 bits of resolution.
DAQmx_Val_FixedLowFreq | 14710 | Pulse frequency must be below 366.21 Hz and cannot change while the task runs. In this mode, the duty cycle has 16 bits of resolution.
DAQmx_Val_Fixed50PercentDutyCycle | 14711 | Pulse duty cycle must be 50 percent. The frequency can change while the task runs.

You can get/set/reset this property using:

DAQmxGetCOConstrainedGenMode

DAQmxSetCOConstrainedGenMode

DAQmxResetCOConstrainedGenMode


Analog Input >> General Properties >> Digitizer/ADC >> Timing Mode

Data Type: | int32
Description: | Specifies the ADC timing mode, controlling the tradeoff between speed and effective resolution. Some ADC timing modes provide increased powerline noise rejection. On devices that have an AI Convert clock, this setting affects both the maximum and default values for Rate. You must use the same ADC timing mode for all channels on a device, but you can use different ADC timing modes for different devices in the same task.

Valid values
DAQmx_Val_Automatic | 16097 | Uses the most appropriate supported timing mode based on the Sample Clock Rate.
DAQmx_Val_HighResolution | 10195 | Increases resolution and noise rejection while decreasing conversion rate.
DAQmx_Val_HighSpeed | 14712 | Increases conversion rate while decreasing resolution.
DAQmx_Val_Best50HzRejection | 14713 | Improves 50 Hz noise rejection while decreasing noise rejection at other frequencies.
DAQmx_Val_Best60HzRejection | 14714 | Improves 60 Hz noise rejection while decreasing noise rejection at other frequencies.
DAQmx_Val_Custom | 10137 | Use Custom Timing Mode to specify a custom value controlling the tradeoff between speed and resolution.

You can get/set/reset this property using:

DAQmxGetAIADCTimingMode

DAQmxSetAIADCTimingMode

DAQmxResetAIADCTimingMode


Counter Input >> Count Edges >> Count Reset >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetLogicLvlBehavior

DAQmxSetCICountEdgesCountResetLogicLvlBehavior

DAQmxResetCICountEdgesCountResetLogicLvlBehavior


Counter Input >> Duty Cycle >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleTermCfg

DAQmxSetCIDutyCycleTermCfg

DAQmxResetCIDutyCycleTermCfg


Counter Input >> Duty Cycle >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleLogicLvlBehavior

DAQmxSetCIDutyCycleLogicLvlBehavior

DAQmxResetCIDutyCycleLogicLvlBehavior


Counter Input >> Position >> A Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputTermCfg

DAQmxSetCIEncoderAInputTermCfg

DAQmxResetCIEncoderAInputTermCfg


Counter Input >> Position >> A Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputLogicLvlBehavior

DAQmxSetCIEncoderAInputLogicLvlBehavior

DAQmxResetCIEncoderAInputLogicLvlBehavior


Counter Input >> Position >> B Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputTermCfg

DAQmxSetCIEncoderBInputTermCfg

DAQmxResetCIEncoderBInputTermCfg


Counter Input >> Position >> B Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputLogicLvlBehavior

DAQmxSetCIEncoderBInputLogicLvlBehavior

DAQmxResetCIEncoderBInputLogicLvlBehavior


Counter Input >> Position >> Z Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputTermCfg

DAQmxSetCIEncoderZInputTermCfg

DAQmxResetCIEncoderZInputTermCfg


Counter Input >> Position >> Z Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputLogicLvlBehavior

DAQmxSetCIEncoderZInputLogicLvlBehavior

DAQmxResetCIEncoderZInputLogicLvlBehavior


Counter Input >> Pulse Width >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthTermCfg

DAQmxSetCIPulseWidthTermCfg

DAQmxResetCIPulseWidthTermCfg


Counter Input >> Pulse Width >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthLogicLvlBehavior

DAQmxSetCIPulseWidthLogicLvlBehavior

DAQmxResetCIPulseWidthLogicLvlBehavior


Counter Input >> Two Edge Separation >> First >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstTermCfg

DAQmxSetCITwoEdgeSepFirstTermCfg

DAQmxResetCITwoEdgeSepFirstTermCfg


Counter Input >> Two Edge Separation >> First >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstLogicLvlBehavior

DAQmxSetCITwoEdgeSepFirstLogicLvlBehavior

DAQmxResetCITwoEdgeSepFirstLogicLvlBehavior


Counter Input >> Two Edge Separation >> Second >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondTermCfg

DAQmxSetCITwoEdgeSepSecondTermCfg

DAQmxResetCITwoEdgeSepSecondTermCfg


Counter Input >> Two Edge Separation >> Second >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondLogicLvlBehavior

DAQmxSetCITwoEdgeSepSecondLogicLvlBehavior

DAQmxResetCITwoEdgeSepSecondLogicLvlBehavior


Counter Input >> Semi-Period >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodTermCfg

DAQmxSetCISemiPeriodTermCfg

DAQmxResetCISemiPeriodTermCfg


Counter Input >> Semi-Period >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodLogicLvlBehavior

DAQmxSetCISemiPeriodLogicLvlBehavior

DAQmxResetCISemiPeriodLogicLvlBehavior


Counter Input >> Pulse >> Frequency >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqTermCfg

DAQmxSetCIPulseFreqTermCfg

DAQmxResetCIPulseFreqTermCfg


Counter Input >> Pulse >> Frequency >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIPulseFreqLogicLvlBehavior

DAQmxSetCIPulseFreqLogicLvlBehavior

DAQmxResetCIPulseFreqLogicLvlBehavior


Counter Input >> Pulse >> Time >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeTermCfg

DAQmxSetCIPulseTimeTermCfg

DAQmxResetCIPulseTimeTermCfg


Counter Input >> Pulse >> Time >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIPulseTimeLogicLvlBehavior

DAQmxSetCIPulseTimeLogicLvlBehavior

DAQmxResetCIPulseTimeLogicLvlBehavior


Counter Input >> Pulse >> Ticks >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksTermCfg

DAQmxSetCIPulseTicksTermCfg

DAQmxResetCIPulseTicksTermCfg


Counter Input >> Pulse >> Ticks >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIPulseTicksLogicLvlBehavior

DAQmxSetCIPulseTicksLogicLvlBehavior

DAQmxResetCIPulseTicksLogicLvlBehavior


Counter Input >> General Properties >> Input Configuration >> Voltage Threshold Level

Data Type: | float64
Description: | Specifies the digital threshold value in Volts for high and low input transitions. Some devices do not support this for differential channels.

You can get/set/reset this property using:

DAQmxGetCIThreshVoltage

DAQmxSetCIThreshVoltage

DAQmxResetCIThreshVoltage


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Idle Output Behavior

Data Type: | int32
Description: | Specifies whether this channel will disable excitation after the task is uncommitted. Setting this to Zero Volts or Amps disables excitation after task uncommit. Setting this attribute to Maintain Existing Value leaves the excitation on after task uncommit.

Valid values
DAQmx_Val_ZeroVoltsOrAmps | 12526 | Drive excitation output to zero.
DAQmx_Val_MaintainExistingValue | 12528 | Continue generating the current value.

You can get/set/reset this property using:

DAQmxGetAIExcitIdleOutputBehavior

DAQmxSetAIExcitIdleOutputBehavior

DAQmxResetAIExcitIdleOutputBehavior


Status >> External Overvoltage >> External Overvoltage Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an External Overvoltage condition for any channel in the task. Reading this property clears the External Overvoltage status for all channels in the task. You must read this property before you read External OvervoltageChans. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteExternalOvervoltageChansExist


Status >> External Overvoltage >> External Overvoltage Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which an External Overvoltage condition has been detected. You must read External OvervoltageChansExist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteExternalOvervoltageChans


Analog Input >> General Properties >> Filter >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether the digital filter is enabled or disabled.

You can get/set/reset this property using:

DAQmxGetAIDigFltrEnable

DAQmxSetAIDigFltrEnable

DAQmxResetAIDigFltrEnable


Analog Input >> General Properties >> Filter >> Digital Filter >> Type

Data Type: | int32
Description: | Specifies the digital filter type.

Valid values
DAQmx_Val_Lowpass | 16071 | Lowpass filter.
DAQmx_Val_Highpass | 16072 | Highpass filter.
DAQmx_Val_Bandpass | 16073 | Bandpass filter.
DAQmx_Val_Notch | 16074 | Notch filter.
DAQmx_Val_Custom | 10137 | Custom filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrType

DAQmxSetAIDigFltrType

DAQmxResetAIDigFltrType


Analog Input >> General Properties >> Filter >> Digital Filter >> Response

Data Type: | int32
Description: | Specifies the digital filter response.

Valid values
DAQmx_Val_ConstantGroupDelay | 16075 | Constant group delay filter response.
DAQmx_Val_Butterworth | 16076 | Butterworth filter response.
DAQmx_Val_Elliptical | 16077 | Elliptical filter response.
DAQmx_Val_HardwareDefined | 10191 | Use the hardware-defined filter response.

You can get/set/reset this property using:

DAQmxGetAIDigFltrResponse

DAQmxSetAIDigFltrResponse

DAQmxResetAIDigFltrResponse


Analog Input >> General Properties >> Filter >> Digital Filter >> Order

Data Type: | uInt32
Description: | Specifies the order of the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrOrder

DAQmxSetAIDigFltrOrder

DAQmxResetAIDigFltrOrder


Analog Input >> General Properties >> Filter >> Digital Filter >> Lowpass >> Cutoff Frequency

Data Type: | float64
Description: | Specifies the lowpass cutoff frequency of the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrLowpassCutoffFreq

DAQmxSetAIDigFltrLowpassCutoffFreq

DAQmxResetAIDigFltrLowpassCutoffFreq


Analog Input >> General Properties >> Filter >> Digital Filter >> Highpass >> Cutoff Frequency

Data Type: | float64
Description: | Specifies the highpass cutoff frequency of the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrHighpassCutoffFreq

DAQmxSetAIDigFltrHighpassCutoffFreq

DAQmxResetAIDigFltrHighpassCutoffFreq


Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Center Frequency

Data Type: | float64
Description: | Specifies the center frequency of the passband for the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrBandpassCenterFreq

DAQmxSetAIDigFltrBandpassCenterFreq

DAQmxResetAIDigFltrBandpassCenterFreq


Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Width

Data Type: | float64
Description: | Specifies the width of the passband centered around the center frequency for the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrBandpassWidth

DAQmxSetAIDigFltrBandpassWidth

DAQmxResetAIDigFltrBandpassWidth


Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Center Frequency

Data Type: | float64
Description: | Specifies the center frequency of the stopband for the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrNotchCenterFreq

DAQmxSetAIDigFltrNotchCenterFreq

DAQmxResetAIDigFltrNotchCenterFreq


Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Width

Data Type: | float64
Description: | Specifies the width of the stopband centered around the center frequency for the digital filter.

You can get/set/reset this property using:

DAQmxGetAIDigFltrNotchWidth

DAQmxSetAIDigFltrNotchWidth

DAQmxResetAIDigFltrNotchWidth


Analog Input >> General Properties >> Filter >> Digital Filter >> Advanced >> Coefficients

Data Type: | float64*
Description: | Specifies the digital filter coefficients.

You can get/set/reset this property using:

DAQmxGetAIDigFltrCoeff

DAQmxSetAIDigFltrCoeff

DAQmxResetAIDigFltrCoeff


I/O Type >> Analog Input >> Filter >> Digital Filter >> Low Pass >> Cutoff Frequency >> Discrete Values

Data Type: | float64*
Description: | Indicates the set of discrete lowpass cutoff frequencies supported by this device. If the device supports ranges of lowpass cutoff frequencies, use AI.DigFltr.Lowpass.CutoffFreq.RangeVals to determine supported frequencies.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIDigFltrLowpassCutoffFreqDiscreteVals


I/O Type >> Analog Input >> Filter >> Digital Filter >> Low Pass >> Cutoff Frequency >> Range Values

Data Type: | float64*
Description: | Indicates pairs of lowpass cutoff frequency ranges supported by this device. Each pair consists of the low value, followed by the high value. If the device supports a set of discrete lowpass cutoff frequencies, use AI.DigFltr.Lowpass.CutoffFreq.DiscreteVals to determine the supported frequencies.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIDigFltrLowpassCutoffFreqRangeVals


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Source

Data Type: | int32
Description: | Specifies whether to use internal or external shunt when Shunt Cal A is selected.

Valid values
DAQmx_Val_BuiltIn | 10200 | Use the internal shunt.
DAQmx_Val_UserProvided | 10167 | Use an external shunt.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalShuntCalASrc

DAQmxSetAIBridgeShuntCalShuntCalASrc

DAQmxResetAIBridgeShuntCalShuntCalASrc


Counter Input >> Velocity >> Angular Encoder >> Units

Data Type: | int32
Description: | Specifies the units to use to return angular velocity counter measurements.

Valid values
DAQmx_Val_RPM | 16080 | Revolutions per minute.
DAQmx_Val_RadiansPerSecond | 16081 | Radians per second.
DAQmx_Val_DegreesPerSecond | 16082 | Degrees per second.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIVelocityAngEncoderUnits

DAQmxSetCIVelocityAngEncoderUnits

DAQmxResetCIVelocityAngEncoderUnits


Counter Input >> Velocity >> Angular Encoder >> Pulses Per Revolution

Data Type: | uInt32
Description: | Specifies the number of pulses the encoder generates per revolution. This value is the number of pulses on either signal A or signal B, not the total number of pulses on both signal A and signal B.

You can get/set/reset this property using:

DAQmxGetCIVelocityAngEncoderPulsesPerRev

DAQmxSetCIVelocityAngEncoderPulsesPerRev

DAQmxResetCIVelocityAngEncoderPulsesPerRev


Counter Input >> Velocity >> Linear Encoder >> Units

Data Type: | int32
Description: | Specifies the units to use to return linear encoder velocity measurements from the channel.

Valid values
DAQmx_Val_MetersPerSecond | 15959 | Meters per second.
DAQmx_Val_InchesPerSecond | 15960 | Inches per second.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIVelocityLinEncoderUnits

DAQmxSetCIVelocityLinEncoderUnits

DAQmxResetCIVelocityLinEncoderUnits


Counter Input >> Velocity >> Linear Encoder >> Distance per Pulse

Data Type: | float64
Description: | Specifies the distance to measure for each pulse the encoder generates on signal A or signal B. This value is in the units you specify in CI.Velocity.LinEncoder.DistUnits.

You can get/set/reset this property using:

DAQmxGetCIVelocityLinEncoderDistPerPulse

DAQmxSetCIVelocityLinEncoderDistPerPulse

DAQmxResetCIVelocityLinEncoderDistPerPulse


Counter Input >> Velocity >> Decoding Type

Data Type: | int32
Description: | Specifies how to count and interpret the pulses the encoder generates on signal A and signal B. X1, X2, and X4 are valid for quadrature encoders only. Two Pulse Counting is valid for two-pulse encoders only.

Valid values
DAQmx_Val_X1 | 10090 | If signal A leads signal B, count the rising edges of signal A. If signal B leads signal A, count the falling edges of signal A.
DAQmx_Val_X2 | 10091 | Count the rising and falling edges of signal A.
DAQmx_Val_X4 | 10092 | Count the rising and falling edges of signal A and signal B.
DAQmx_Val_TwoPulseCounting | 10313 | Increment the count on rising edges of signal A. Decrement the count on rising edges of signal B.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderDecodingType

DAQmxSetCIVelocityEncoderDecodingType

DAQmxResetCIVelocityEncoderDecodingType


Counter Input >> Velocity >> A Input >> Terminal

Data Type: | char*
Description: | Specifies the terminal to which signal A is connected.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputTerm

DAQmxSetCIVelocityEncoderAInputTerm

DAQmxResetCIVelocityEncoderAInputTerm


Counter Input >> Velocity >> A Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputTermCfg

DAQmxSetCIVelocityEncoderAInputTermCfg

DAQmxResetCIVelocityEncoderAInputTermCfg


Counter Input >> Velocity >> A Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior of the input terminal.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputLogicLvlBehavior

DAQmxSetCIVelocityEncoderAInputLogicLvlBehavior

DAQmxResetCIVelocityEncoderAInputLogicLvlBehavior


Counter Input >> Velocity >> A Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputDigFltrEnable

DAQmxSetCIVelocityEncoderAInputDigFltrEnable

DAQmxResetCIVelocityEncoderAInputDigFltrEnable


Counter Input >> Velocity >> A Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the digital filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputDigFltrMinPulseWidth

DAQmxSetCIVelocityEncoderAInputDigFltrMinPulseWidth

DAQmxResetCIVelocityEncoderAInputDigFltrMinPulseWidth


Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseSrc

DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseSrc

DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseSrc


Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseRate

DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseRate

DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseRate


Counter Input >> Velocity >> B Input >> Terminal

Data Type: | char*
Description: | Specifies the terminal to which signal B is connected.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputTerm

DAQmxSetCIVelocityEncoderBInputTerm

DAQmxResetCIVelocityEncoderBInputTerm


Counter Input >> Velocity >> B Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputTermCfg

DAQmxSetCIVelocityEncoderBInputTermCfg

DAQmxResetCIVelocityEncoderBInputTermCfg


Counter Input >> Velocity >> B Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior of the input terminal.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputLogicLvlBehavior

DAQmxSetCIVelocityEncoderBInputLogicLvlBehavior

DAQmxResetCIVelocityEncoderBInputLogicLvlBehavior


Counter Input >> Velocity >> B Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputDigFltrEnable

DAQmxSetCIVelocityEncoderBInputDigFltrEnable

DAQmxResetCIVelocityEncoderBInputDigFltrEnable


Counter Input >> Velocity >> B Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the digital filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputDigFltrMinPulseWidth

DAQmxSetCIVelocityEncoderBInputDigFltrMinPulseWidth

DAQmxResetCIVelocityEncoderBInputDigFltrMinPulseWidth


Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseSrc

DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseSrc

DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseSrc


Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseRate

DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseRate

DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseRate


Counter Input >> Velocity >> Advanced >> Measurement Time

Data Type: | float64
Description: | Specifies in seconds the length of time to measure the velocity of the signal.

You can get/set/reset this property using:

DAQmxGetCIVelocityMeasTime

DAQmxSetCIVelocityMeasTime

DAQmxResetCIVelocityMeasTime


Counter Input >> Velocity >> Advanced >> Divisor

Data Type: | uInt32
Description: | Specifies the value by which to divide the input signal.

You can get/set/reset this property using:

DAQmxGetCIVelocityDiv

DAQmxSetCIVelocityDiv

DAQmxResetCIVelocityDiv


Counter Input >> Count Edges >> Gate >> Enable

Data Type: | bool32
Description: | Specifies whether to enable the functionality to gate the counter input signal for a count edges measurement.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateEnable

DAQmxSetCICountEdgesGateEnable

DAQmxResetCICountEdgesGateEnable


Counter Input >> Count Edges >> Gate >> Input >> Terminal

Data Type: | char*
Description: | Specifies the gate terminal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateTerm

DAQmxSetCICountEdgesGateTerm

DAQmxResetCICountEdgesGateTerm


Counter Input >> Count Edges >> Gate >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the gate terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateTermCfg

DAQmxSetCICountEdgesGateTermCfg

DAQmxResetCICountEdgesGateTermCfg


Counter Input >> Count Edges >> Gate >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the gate input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateLogicLvlBehavior

DAQmxSetCICountEdgesGateLogicLvlBehavior

DAQmxResetCICountEdgesGateLogicLvlBehavior


Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the gate input signal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateDigFltrEnable

DAQmxSetCICountEdgesGateDigFltrEnable

DAQmxResetCICountEdgesGateDigFltrEnable


Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the digital filter recognizes.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateDigFltrMinPulseWidth

DAQmxSetCICountEdgesGateDigFltrMinPulseWidth

DAQmxResetCICountEdgesGateDigFltrMinPulseWidth


Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateDigFltrTimebaseSrc

DAQmxSetCICountEdgesGateDigFltrTimebaseSrc

DAQmxResetCICountEdgesGateDigFltrTimebaseSrc


Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateDigFltrTimebaseRate

DAQmxSetCICountEdgesGateDigFltrTimebaseRate

DAQmxResetCICountEdgesGateDigFltrTimebaseRate


Counter Input >> Count Edges >> Gate >> Pause When

Data Type: | int32
Description: | Specifies whether the counter gates input pulses while the signal is high or low.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetCICountEdgesGateWhen

DAQmxSetCICountEdgesGateWhen

DAQmxResetCICountEdgesGateWhen


Sample Clock >> Write Waveform >> Use Initial Waveform dt

Data Type: | bool32
Description: | Specifies that the value of Rate will be determined by the dt component of the initial DAQmx Write waveform input for Output tasks.

You can get/set/reset this property using:

DAQmxGetSampClkWriteWfmUseInitialWfmDT

DAQmxSetSampClkWriteWfmUseInitialWfmDT

DAQmxResetSampClkWriteWfmUseInitialWfmDT


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Sense

Data Type: | int32
Description: | Specifies whether to use local or remote sense to sense excitation.

Valid values
DAQmx_Val_Local | 16095 | Local.
DAQmx_Val_Remote | 16096 | Remote.

You can get/set/reset this property using:

DAQmxGetAIExcitSense

DAQmxSetAIExcitSense

DAQmxResetAIExcitSense


Analog Input >> General Properties >> Advanced >> Open Channel Detection Enable

Data Type: | bool32
Description: | Specifies whether to enable open channel detection.

You can get/set/reset this property using:

DAQmxGetAIOpenChanDetectEnable

DAQmxSetAIOpenChanDetectEnable

DAQmxResetAIOpenChanDetectEnable


Analog Input >> General Properties >> Digitizer/ADC >> Raw Sample Justification

Data Type: | int32
Description: | Indicates the justification of a raw sample from the device.
Restrictions: | Not Settable

Valid values
DAQmx_Val_RightJustified | 10279 | Samples occupy the lower bits of the integer.
DAQmx_Val_LeftJustified | 10209 | Samples occupy the higher bits of the integer.

You can get this property using:

DAQmxGetAIRawSampJustification


Analog Input >> General Properties >> Input Configuration >> Impedance

Data Type: | float64
Description: | Specifies the input impedance of the channel.

Valid values
50 | 50 Ohms.
75 | 75 Ohms.
1000000 | 1 M Ohm.
10000000000 | 10 G Ohm.

You can get/set/reset this property using:

DAQmxGetAIImpedance

DAQmxSetAIImpedance

DAQmxResetAIImpedance


Analog Input >> General Properties >> Input Configuration >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the channel.

Valid values
DAQmx_Val_AC | 10045 | Remove the DC offset from the signal.
DAQmx_Val_DC | 10050 | Allow NI-DAQmx to measure all of the signal.
DAQmx_Val_GND | 10066 | Remove the signal from the measurement and measure only ground.

You can get/set/reset this property using:

DAQmxGetAICoupling

DAQmxSetAICoupling

DAQmxResetAICoupling


Analog Input >> General Properties >> Digitizer/ADC >> Dither >> Enable

Data Type: | bool32
Description: | Specifies whether to enable dithering. Dithering adds Gaussian noise to the input signal. You can use dithering to achieve higher resolution measurements by over sampling the input signal and averaging the results.

You can get/set/reset this property using:

DAQmxGetAIDitherEnable

DAQmxSetAIDitherEnable

DAQmxResetAIDitherEnable


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Configuration

Data Type: | int32
Description: | Specifies the type of Wheatstone bridge connected to the channel.

Valid values
DAQmx_Val_FullBridge | 10182 | Sensor is a full bridge. If you set Use Excitation For Scaling to TRUE, NI-DAQmx divides the measurement by the excitation value. Many sensors scale data to native units using scaling of volts per excitation.
DAQmx_Val_HalfBridge | 10187 | Sensor is a half bridge. If you set Use Excitation For Scaling to TRUE, NI-DAQmx divides the measurement by the excitation value. Many sensors scale data to native units using scaling of volts per excitation.
DAQmx_Val_QuarterBridge | 10270 | Sensor is a quarter bridge. If you set Use Excitation For Scaling to TRUE, NI-DAQmx divides the measurement by the excitation value. Many sensors scale data to native units using scaling of volts per excitation.
DAQmx_Val_NoBridge | 10228 | Sensor is not a Wheatstone bridge.

You can get/set/reset this property using:

DAQmxGetAIBridgeCfg

DAQmxSetAIBridgeCfg

DAQmxResetAIBridgeCfg


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Enable

Data Type: | bool32
Description: | Specifies whether to enable a shunt calibration switch. Use Shunt Cal Select to select the switch(es) to enable.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalEnable

DAQmxSetAIBridgeShuntCalEnable

DAQmxResetAIBridgeShuntCalEnable


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Frequency

Data Type: | float64
Description: | Specifies the AC excitation frequency in Hertz.

You can get/set/reset this property using:

DAQmxGetAIACExcitFreq

DAQmxSetAIACExcitFreq

DAQmxResetAIACExcitFreq


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Synchronization Enable

Data Type: | bool32
Description: | Specifies whether to synchronize the AC excitation source of the channel to that of another channel. Synchronize the excitation sources of multiple channels to use multichannel sensors. Set this property to FALSE for the master channel and to TRUE for the slave channels.

You can get/set/reset this property using:

DAQmxGetAIACExcitSyncEnable

DAQmxSetAIACExcitSyncEnable

DAQmxResetAIACExcitSyncEnable


Analog Output >> General Properties >> Advanced >> Gain >> Gain Value

Data Type: | float64
Description: | Specifies in decibels the gain factor to apply to the channel.

You can get/set/reset this property using:

DAQmxGetAOGain

DAQmxSetAOGain

DAQmxResetAOGain


Analog Output >> General Properties >> Output Configuration >> Load Impedance

Data Type: | float64
Description: | Specifies in ohms the load impedance connected to the analog output channel.

You can get/set/reset this property using:

DAQmxGetAOLoadImpedance

DAQmxSetAOLoadImpedance

DAQmxResetAOLoadImpedance


Analog Output >> General Properties >> DAC >> Reference Voltage >> Connect DAC Reference to Ground

Data Type: | bool32
Description: | Specifies whether to ground the internal DAC reference. Grounding the internal DAC reference has the effect of grounding all analog output channels and stopping waveform generation across all analog output channels regardless of whether the channels belong to the current task. You can ground the internal DAC reference only when Source is DAQmx_Val_Internal and Allow Connecting DAC Reference to Ground at Runtime is TRUE.

You can get/set/reset this property using:

DAQmxGetAODACRefConnToGnd

DAQmxSetAODACRefConnToGnd

DAQmxResetAODACRefConnToGnd


Analog Output >> General Properties >> DAC >> Reference Voltage >> Source

Data Type: | int32
Description: | Specifies the source of the DAC reference voltage. The value of this voltage source determines the full-scale value of the DAC.

Valid values
DAQmx_Val_Internal | 10200 | Internal to the device.
DAQmx_Val_External | 10167 | External to the device.

You can get/set/reset this property using:

DAQmxGetAODACRefSrc

DAQmxSetAODACRefSrc

DAQmxResetAODACRefSrc


Analog Output >> General Properties >> DAC >> Reglitching Enable

Data Type: | bool32
Description: | Specifies whether to enable reglitching. The output of a DAC normally glitches whenever the DAC is updated with a new value. The amount of glitching differs from code to code and is generally largest at major code transitions. Reglitching generates uniform glitch energy at each code transition and provides for more uniform glitches. Uniform glitch energy makes it easier to filter out the noise introduced from glitching during spectrum analysis.

You can get/set/reset this property using:

DAQmxGetAOReglitchEnable

DAQmxSetAOReglitchEnable

DAQmxResetAOReglitchEnable


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the device.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetAODataXferMech

DAQmxSetAODataXferMech

DAQmxResetAODataXferMech


Counter Input >> General Properties >> Counter Timebase >> Active Edge

Data Type: | int32
Description: | Specifies whether a timebase cycle is from rising edge to rising edge or from falling edge to falling edge.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseActiveEdge

DAQmxSetCICtrTimebaseActiveEdge

DAQmxResetCICtrTimebaseActiveEdge


Counter Input >> General Properties >> Counter Timebase >> Source

Data Type: char*
Description: Specifies the terminal of the timebase to use for the counter.

Typically, NI-DAQmx uses one of the internal counter timebases when performing counter measurements. Use this property to specify an external timebase and produce custom measurement ranges that are not possible with the internal timebases.

You also can use this property to chain counters together. By using the output of a counter as the timebase of another counter, you can effectively widen a counter. For example, you can chain two 24 bit counters together to produce one 48 bit counter.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseSrc

DAQmxSetCICtrTimebaseSrc

DAQmxResetCICtrTimebaseSrc


Counter Input >> Frequency >> Measurement Specifications >> Method

Data Type: | int32
Description: | Specifies the method to use to measure the frequency of the signal.

Valid values
DAQmx_Val_LowFreq1Ctr | 10105 | Use one counter that uses a constant timebase to measure the input signal.
DAQmx_Val_HighFreq2Ctr | 10157 | Use two counters, one of which counts pulses of the signal to measure during the specified measurement time.
DAQmx_Val_LargeRng2Ctr | 10205 | Use one counter to divide the frequency of the input signal to create a lower-frequency signal that the second counter can more easily measure.
DAQmx_Val_DynAvg | 16065 | Uses one counter and automatically configures the counter settings based on the range of frequencies to be measured. During the acquisition, the counter dynamically adjusts the number of periods that are averaged to balance measurement accuracy and latency.

You can get/set/reset this property using:

DAQmxGetCIFreqMeasMeth

DAQmxSetCIFreqMeasMeth

DAQmxResetCIFreqMeasMeth


Counter Input >> Frequency >> Measurement Specifications >> High Frequency >> Measurement Time

Data Type: | float64
Description: | Specifies in seconds the length of time to measure the frequency of the signal if Method is DAQmx_Val_HighFreq2Ctr. Measurement accuracy increases with increased measurement time and with increased signal frequency. If you measure a high-frequency signal for too long, however, the count register could roll over, which results in an incorrect measurement.

You can get/set/reset this property using:

DAQmxGetCIFreqMeasTime

DAQmxSetCIFreqMeasTime

DAQmxResetCIFreqMeasTime


Counter Input >> Frequency >> Measurement Specifications >> Large Range >> Divisor

Data Type: | uInt32
Description: | Specifies the value by which to divide the input signal if Method is DAQmx_Val_LargeRng2Ctr. The larger the divisor, the more accurate the measurement. However, too large a value could cause the count register to roll over, which results in an incorrect measurement.

You can get/set/reset this property using:

DAQmxGetCIFreqDiv

DAQmxSetCIFreqDiv

DAQmxResetCIFreqDiv


Counter Input >> General Properties >> More >> Count

Data Type: | uInt32
Description: | Indicates the current value of the count register.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCICount


Counter Input >> General Properties >> More >> Output State

Data Type: | int32
Description: | Indicates the current state of the out terminal of the counter.
Restrictions: | Not Settable

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get this property using:

DAQmxGetCIOutputState


Counter Input >> General Properties >> More >> Terminal Count Reached

Data Type: | bool32
Description: | Indicates whether the counter rolled over. When you query this property, NI-DAQmx resets it to FALSE.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCITCReached


Events >> Counter Output Event >> Output Behavior

Data Type: int32
Description: Specifies whether the exported Counter Output Event pulses or changes from one state to the other when the counter reaches terminal count.

Upon reaching terminal count, the counter can issue a pulse. Use Polarity to select a high or low pulse.

Upon reaching terminal count, the output terminal of the counter can change state, or toggle. For example, if the terminal is initially at a low state, it changes to high state and stays at the high state until the next terminal count. The terminal then changes to low state. Use Idle State to select the initial state of the terminal.

When counting up, a counter reaches terminal count when it reaches the maximum value (2^24 - 1 for a 24-bit counter). When counting down, a counter reaches terminal count when it reaches 0.

Valid values
DAQmx_Val_Pulse | 10265 | Send a pulse to the terminal.
DAQmx_Val_Toggle | 10307 | Toggle the state of the terminal from low to high or from high to low.

You can get/set/reset this property using:

DAQmxGetExportedCtrOutEventOutputBehavior

DAQmxSetExportedCtrOutEventOutputBehavior

DAQmxResetExportedCtrOutEventOutputBehavior


Analog Input >> General Properties >> Advanced >> Sample and Hold Enable

Data Type: | bool32
Description: | Specifies whether to enable the sample and hold circuitry of the device. When you disable sample and hold circuitry, a small voltage offset might be introduced into the signal. You can eliminate this offset by using Auto Zero Mode to perform an auto zero on the channel.

You can get/set/reset this property using:

DAQmxGetAISampAndHoldEnable

DAQmxSetAISampAndHoldEnable

DAQmxResetAISampAndHoldEnable


Analog Output >> General Properties >> DAC >> Resolution Units

Data Type: | int32
Description: | Specifies the units of Resolution Value.

Valid values
DAQmx_Val_Bits 10109 Bits.

You can get/set/reset this property using:

DAQmxGetAOResolutionUnits

DAQmxSetAOResolutionUnits

DAQmxResetAOResolutionUnits


Analog Output >> General Properties >> DAC >> Resolution Value

Data Type: | float64
Description: | Indicates the resolution of the digital-to-analog converter of the channel. This value is in the units you specify with Resolution Units.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAOResolution


Analog Output >> General Properties >> DAC >> Range >> Low

Data Type: | float64
Description: | Specifies the lower limit of the output range of the device. This value is in the native units of the device. On E Series devices, for example, the native units is volts.

You can get/set/reset this property using:

DAQmxGetAODACRngLow

DAQmxSetAODACRngLow

DAQmxResetAODACRngLow


Analog Output >> General Properties >> DAC >> Range >> High

Data Type: | float64
Description: | Specifies the upper limit of the output range of the device. This value is in the native units of the device. On E Series devices, for example, the native units is volts.

You can get/set/reset this property using:

DAQmxGetAODACRngHigh

DAQmxSetAODACRngHigh

DAQmxResetAODACRngHigh


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory

Data Type: | bool32
Description: | Specifies whether to write samples directly to the onboard memory of the device, bypassing the memory buffer. Generally, you cannot update onboard memory directly after you start the task. Onboard memory includes data FIFOs.

You can get/set/reset this property using:

DAQmxGetAOUseOnlyOnBrdMem

DAQmxSetAOUseOnlyOnBrdMem

DAQmxResetAOUseOnlyOnBrdMem


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the buffer to the onboard memory of the device.

Valid values
DAQmx_Val_OnBrdMemEmpty | 10235 | Transfer data to the device only when there is no data in the onboard memory of the device.
DAQmx_Val_OnBrdMemHalfFullOrLess | 10239 | Transfer data to the device any time the onboard memory is less than half full.
DAQmx_Val_OnBrdMemNotFull | 10242 | Transfer data to the device any time the onboard memory of the device is not full.

You can get/set/reset this property using:

DAQmxGetAODataXferReqCond

DAQmxSetAODataXferReqCond

DAQmxResetAODataXferReqCond


Events >> Counter Output Event >> Toggle >> Idle State

Data Type: | int32
Description: | Specifies the initial state of the output terminal of the counter when Output Behavior is DAQmx_Val_Toggle. The terminal enters this state when NI-DAQmx commits the task. The initial state of the terminal affects whether the first toggle is from low state to high state or from high state to low state. NI-DAQmx ignores this property if Output Behavior is DAQmx_Val_Pulse.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetExportedCtrOutEventToggleIdleState

DAQmxSetExportedCtrOutEventToggleIdleState

DAQmxResetExportedCtrOutEventToggleIdleState


Clocks >> Sample Clock >> Output Behavior

Data Type: | int32
Description: | Specifies whether the exported Sample Clock issues a pulse at the beginning of a sample or changes to a high state for the duration of the sample. E Series devices might require many AI Convert Clock pulses to acquire one sample. Each pulse of the Sample Clock initiates the acquisition of one sample per channel in the task. Each sample per channel requires a pulse from the AI Convert Clock. This property is valid for the AI Sample Clock only.

Valid values
DAQmx_Val_Pulse | 10265 | The exported Sample Clock pulses at the beginning of each sample.
DAQmx_Val_Lvl | 10210 | The exported Sample Clock goes high at the beginning of the sample and goes low when the last AI Convert begins.

You can get/set/reset this property using:

DAQmxGetExportedSampClkOutputBehavior

DAQmxSetExportedSampClkOutputBehavior

DAQmxResetExportedSampClkOutputBehavior


Input >> Buffer Size

Data Type: | uInt32
Description: | Specifies the number of samples the input buffer can hold for each channel in the task. Zero indicates to allocate no buffer. Use a buffer size of 0 to perform a hardware-timed operation without using a buffer. Setting this property overrides the automatic input buffer allocation that NI-DAQmx performs.

You can get/set/reset this property using:

DAQmxGetBufInputBufSize

DAQmxSetBufInputBufSize

DAQmxResetBufInputBufSize


Output >> Buffer Size

Data Type: | uInt32
Description: | Specifies the number of samples the output buffer can hold for each channel in the task. Zero indicates to allocate no buffer. Use a buffer size of 0 to perform a hardware-timed operation without using a buffer. Setting this property overrides the automatic output buffer allocation that NI-DAQmx performs.

You can get/set/reset this property using:

DAQmxGetBufOutputBufSize

DAQmxSetBufOutputBufSize

DAQmxResetBufOutputBufSize


General Properties >> Channel Type

Data Type: | int32
Description: | Indicates the type of the virtual channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_AI | 10100 | Analog input channel.
DAQmx_Val_AO | 10102 | Analog output channel.
DAQmx_Val_DI | 10151 | Digital input channel.
DAQmx_Val_DO | 10153 | Digital output channel.
DAQmx_Val_CI | 10131 | Counter input channel.
DAQmx_Val_CO | 10132 | Counter output channel.

You can get this property using:

DAQmxGetChanType


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the onboard memory of the device to the buffer.

Valid values
DAQmx_Val_OnBrdMemMoreThanHalfFull | 10237 | Transfer data from the device when more than half of the onboard memory of the device fills.
DAQmx_Val_OnBrdMemNotEmpty | 10241 | Transfer data from the device when there is data in the onboard memory.
DAQmx_Val_OnbrdMemCustomThreshold | 12577 | Transfer data from the device when the number of samples specified with Data Transfer Custom Threshold are in the device FIFO.
DAQmx_Val_WhenAcqComplete | 12546 | Transfer data when the acquisition is complete.

You can get/set/reset this property using:

DAQmxGetAIDataXferReqCond

DAQmxSetAIDataXferReqCond

DAQmxResetAIDataXferReqCond


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetAIMemMapEnable

DAQmxSetAIMemMapEnable

DAQmxResetAIMemMapEnable


Analog Output >> General Properties >> Output Configuration >> Terminal Configuration

Data Type: | int32
Description: | Specifies the terminal configuration of the channel.

Valid values
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_PseudoDiff | 12529 | Pseudodifferential.

You can get/set/reset this property using:

DAQmxGetAOTermCfg

DAQmxSetAOTermCfg

DAQmxResetAOTermCfg


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetAOMemMapEnable

DAQmxSetAOMemMapEnable

DAQmxResetAOMemMapEnable


Counter Input >> Maximum Value

Data Type: | float64
Description: | Specifies the maximum value you expect to measure. This value is in the units you specify with a units property. When you query this property, it returns the coerced maximum value that the hardware can measure with the current settings.

You can get/set/reset this property using:

DAQmxGetCIMax

DAQmxSetCIMax

DAQmxResetCIMax


Counter Input >> Minimum Value

Data Type: | float64
Description: | Specifies the minimum value you expect to measure. This value is in the units you specify with a units property. When you query this property, it returns the coerced minimum value that the hardware can measure with the current settings.

You can get/set/reset this property using:

DAQmxGetCIMin

DAQmxSetCIMin

DAQmxResetCIMin


Counter Input >> Custom Scale Name

Data Type: | char*
Description: | Specifies the name of a custom scale for the channel.

You can get/set/reset this property using:

DAQmxGetCICustomScaleName

DAQmxSetCICustomScaleName

DAQmxResetCICustomScaleName


RelativeTo

Data Type: | int32
Description: | Specifies the point in the buffer at which to begin a read operation. If you also specify an offset with Offset, the read operation begins at that offset relative to the point you select with this property. The default value is DAQmx_Val_CurrReadPos unless you configure a Reference Trigger for the task. If you configure a Reference Trigger, the default value is DAQmx_Val_FirstPretrigSamp.

Valid values
DAQmx_Val_FirstSample | 10424 | Start reading samples relative to the first sample acquired.
DAQmx_Val_CurrReadPos | 10425 | Start reading samples relative to the last sample returned by the previous read. For the first read operation, this position is the first sample acquired or the first pretrigger sample if you configured a reference trigger for the task.
DAQmx_Val_RefTrig | 10426 | Start reading samples relative to the first sample after the reference trigger occurred.
DAQmx_Val_FirstPretrigSamp | 10427 | Start reading samples relative to the first pretrigger sample. You specify the number of pretrigger samples to acquire when you configure a reference trigger.
DAQmx_Val_MostRecentSamp | 10428 | Start reading samples relative to the next sample acquired. For example, use this value and set Offset to -1 to read the last sample acquired.

You can get/set/reset this property using:

DAQmxGetReadRelativeTo

DAQmxSetReadRelativeTo

DAQmxResetReadRelativeTo


Offset

Data Type: | int32
Description: | Specifies an offset in samples per channel at which to begin a read operation. This offset is relative to the location you specify with RelativeTo.

You can get/set/reset this property using:

DAQmxGetReadOffset

DAQmxSetReadOffset

DAQmxResetReadOffset


Relative To

Data Type: | int32
Description: | Specifies the point in the buffer at which to write data. If you also specify an offset with Offset, the write operation begins at that offset relative to this point you select with this property.

Valid values
DAQmx_Val_FirstSample | 10424 | Write samples relative to the first sample.
DAQmx_Val_CurrWritePos | 10430 | Write samples relative to the current position in the buffer.

You can get/set/reset this property using:

DAQmxGetWriteRelativeTo

DAQmxSetWriteRelativeTo

DAQmxResetWriteRelativeTo


Offset

Data Type: | int32
Description: | Specifies in samples per channel an offset at which a write operation begins. This offset is relative to the location you specify with Relative To.

You can get/set/reset this property using:

DAQmxGetWriteOffset

DAQmxSetWriteOffset

DAQmxResetWriteOffset


Counter Output >> General Properties >> More >> Pulse Done

Data Type: | bool32
Description: | Indicates if the task completed pulse generation. Use this value for retriggerable pulse generation when you need to determine if the device generated the current pulse. For retriggerable tasks, when you query this property, NI-DAQmx resets it to FALSE.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCOPulseDone


Start >> More >> Retriggerable

Data Type: | bool32
Description: | Specifies whether a finite task resets and waits for another Start Trigger after the task completes. When you set this property to TRUE, the device performs a finite acquisition or generation each time the Start Trigger occurs until the task stops. The device ignores a trigger if it is in the process of acquiring or generating signals.

You can get/set/reset this property using:

DAQmxGetStartTrigRetriggerable

DAQmxSetStartTrigRetriggerable

DAQmxResetStartTrigRetriggerable


Scaled Units

Data Type: | char*
Description: | Specifies the units to use for scaled values. You can use an arbitrary string.

You can get/set this property using:

DAQmxGetScaleScaledUnits

DAQmxSetScaleScaledUnits


User-Defined Information >> Max Size

Data Type: | uInt32
Description: | Indicates the maximum length in characters of Information.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCalUserDefinedInfoMaxSize


Status >> Total Samples Per Channel Acquired

Data Type: | uInt64
Description: | Indicates the total number of samples acquired by each channel. NI-DAQmx returns a single value because this value is the same for all channels. For retriggered acquisitions, this value is the cumulative number of samples across all retriggered acquisitions.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadTotalSampPerChanAcquired


Status >> Total Samples Per Channel Generated

Data Type: | uInt64
Description: | Indicates the total number of samples generated by each channel in the task. This value is identical for all channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteTotalSampPerChanGenerated


Counter Input >> Period >> Measurement Specifications >> Method

Data Type: | int32
Description: | Specifies the method to use to measure the period of the signal.

Valid values
DAQmx_Val_LowFreq1Ctr | 10105 | Use one counter that uses a constant timebase to measure the input signal.
DAQmx_Val_HighFreq2Ctr | 10157 | Use two counters, one of which counts pulses of the signal to measure during the specified measurement time.
DAQmx_Val_LargeRng2Ctr | 10205 | Use one counter to divide the frequency of the input signal to create a lower-frequency signal that the second counter can more easily measure.
DAQmx_Val_DynAvg | 16065 | Uses one counter and automatically configures the counter settings based on the range of frequencies to be measured. During the acquisition, the counter dynamically adjusts the number of periods that are averaged to balance measurement accuracy and latency.

You can get/set/reset this property using:

DAQmxGetCIPeriodMeasMeth

DAQmxSetCIPeriodMeasMeth

DAQmxResetCIPeriodMeasMeth


Counter Input >> Period >> Measurement Specifications >> High Frequency >> Measurement Time

Data Type: | float64
Description: | Specifies in seconds the length of time to measure the period of the signal if Method is DAQmx_Val_HighFreq2Ctr. Measurement accuracy increases with increased measurement time and with increased signal frequency. If you measure a high-frequency signal for too long, however, the count register could roll over, which results in an incorrect measurement.

You can get/set/reset this property using:

DAQmxGetCIPeriodMeasTime

DAQmxSetCIPeriodMeasTime

DAQmxResetCIPeriodMeasTime


Counter Input >> Period >> Measurement Specifications >> Large Range >> Divisor

Data Type: | uInt32
Description: | Specifies the value by which to divide the input signal if Method is DAQmx_Val_LargeRng2Ctr. The larger the divisor, the more accurate the measurement. However, too large a value could cause the count register to roll over, which results in an incorrect measurement.

You can get/set/reset this property using:

DAQmxGetCIPeriodDiv

DAQmxSetCIPeriodDiv

DAQmxResetCIPeriodDiv


Device Names

Data Type: | char*
Description: | Indicates the names of all devices installed in the system.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysDevNames


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Number Of Possibly Invalid Samples

Data Type: uInt32
Description: Indicates the number of samples that the device might have overwritten before it could transfer them to the buffer.

On certain devices during finite buffered time measurements, it is not possible to detect if the counter overwrites a value it read before the device could transfer the sample to the buffer. This uncertainty is present only when Data Transfer Mechanism is DAQmx_Val_DMA and occurs as the acquisition nears completion.

Once the acquisition completes, it is impossible to tell if the status value on the counter indicates an overwrite as a result of a true overwrite, or because the counter detected another edge of the input signal after the acquisition completed but before the counter could disarm. As a result of this behavior, higher frequency input signals are more likely to increase the number of possibly invalid samples.

To decrease the number of possibly invalid samples, read more often from the buffer. Reading from the buffer forces a check on the hardware status and ensures all data is valid up to the present point in the buffer. By default, NI-DAQmx checks the validity of data every fourth of the buffer. If you do not perform a read until after the device acquires all data, the value of this property is one-fourth of the buffer size or zero.

The value this property indicates is valid only while the task is in the running state. The value of this property while the task is in any other state is zero.

Restrictions: Not Settable

You can get this property using:

DAQmxGetCINumPossiblyInvalidSamps


Deprecated >> Topology

Data Type: | char*
Description: | (Deprecated) Indicates the current topology of the device. This value is one of the topology options in DAQmxSwitchSetTopologyAndReset().
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevTopology


Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Gain Adjustment

Data Type: | float64
Description: | Specifies the result of a shunt calibration. This property is set by DAQmx Perform Shunt Calibration. NI-DAQmx multiplies data read from the channel by the value of this property. This value should be close to 1.0.

You can get/set/reset this property using:

DAQmxGetAIBridgeShuntCalGainAdjust

DAQmxSetAIBridgeShuntCalGainAdjust

DAQmxResetAIBridgeShuntCalGainAdjust


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the channel.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetCIDataXferMech

DAQmxSetCIDataXferMech

DAQmxResetCIDataXferMech


More >> Pause >> Digital Pattern >> Source

Data Type: | char*
Description: | Specifies the physical channels to use for pattern matching. The order of the physical channels determines the order of the pattern. If a port is included, the lines within the port are in ascending order.

You can get/set/reset this property using:

DAQmxGetDigPatternPauseTrigSrc

DAQmxSetDigPatternPauseTrigSrc

DAQmxResetDigPatternPauseTrigSrc


Advanced >> Raw Data Width

Data Type: | uInt32
Description: | Indicates in bytes the size of a raw sample from the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadRawDataWidth


Advanced >> Number of Channels

Data Type: | uInt32
Description: | Indicates the number of channels that an NI-DAQmx Read function reads from the task. This value is the number of channels in the task or the number of channels you specify with Channels to Read.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadNumChans


Advanced >> Digital Input >> Number of Bytes Per Channel

Data Type: | uInt32
Description: | Indicates the number of bytes per channel that NI-DAQmx returns in a sample for line-based reads. If a channel has fewer lines than this number, the extra bytes are FALSE.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadDigitalLinesBytesPerChan


Advanced >> Raw Data Width

Data Type: | uInt32
Description: | Indicates in bytes the required size of a raw sample to write to the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteRawDataWidth


Advanced >> Number of Channels

Data Type: | uInt32
Description: | Indicates the number of channels that an NI-DAQmx Write function writes to the task. This value is the number of channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteNumChans


Advanced >> Digital Output >> Number of Booleans Per Channel

Data Type: | uInt32
Description: | Indicates the number of Boolean values expected per channel in a sample for line-based writes. This property is determined by the channel in the task with the most digital lines. If a channel has fewer lines than this number, NI-DAQmx ignores the extra Boolean values.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteDigitalLinesBytesPerChan


Analog Input >> Position >> LVDT >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of Sensitivity.

Valid values
DAQmx_Val_mVoltsPerVoltPerMillimeter | 12506 | mVolts/Volt/mMeter.
DAQmx_Val_mVoltsPerVoltPerMilliInch | 12505 | mVolts/Volt/0.001 Inch.

You can get/set/reset this property using:

DAQmxGetAILVDTSensitivityUnits

DAQmxSetAILVDTSensitivityUnits

DAQmxResetAILVDTSensitivityUnits


Analog Input >> Position >> RVDT >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of Sensitivity.

Valid values
DAQmx_Val_mVoltsPerVoltPerDegree | 12507 | mVolts/Volt/Degree.
DAQmx_Val_mVoltsPerVoltPerRadian | 12508 | mVolts/Volt/Radian.

You can get/set/reset this property using:

DAQmxGetAIRVDTSensitivityUnits

DAQmxSetAIRVDTSensitivityUnits

DAQmxResetAIRVDTSensitivityUnits


Analog Input >> Acceleration >> Accelerometer >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of Sensitivity.

Valid values
DAQmx_Val_mVoltsPerG | 12509 | mVolts/g.
DAQmx_Val_VoltsPerG | 12510 | Volts/g.

You can get/set/reset this property using:

DAQmxGetAIAccelSensitivityUnits

DAQmxSetAIAccelSensitivityUnits

DAQmxResetAIAccelSensitivityUnits


Counter Input >> Position >> A Input >> Terminal

Data Type: | char*
Description: | Specifies the terminal to which signal A is connected.

You can get/set/reset this property using:

DAQmxGetCIEncoderAInputTerm

DAQmxSetCIEncoderAInputTerm

DAQmxResetCIEncoderAInputTerm


Counter Input >> Position >> B Input >> Terminal

Data Type: | char*
Description: | Specifies the terminal to which signal B is connected.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputTerm

DAQmxSetCIEncoderBInputTerm

DAQmxResetCIEncoderBInputTerm


Counter Input >> Position >> Z Input >> Terminal

Data Type: | char*
Description: | Specifies the terminal to which signal Z is connected.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputTerm

DAQmxSetCIEncoderZInputTerm

DAQmxResetCIEncoderZInputTerm


Counter Input >> Pulse Width >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthDigFltrEnable

DAQmxSetCIPulseWidthDigFltrEnable

DAQmxResetCIPulseWidthDigFltrEnable


Counter Input >> Pulse Width >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthDigFltrMinPulseWidth

DAQmxSetCIPulseWidthDigFltrMinPulseWidth

DAQmxResetCIPulseWidthDigFltrMinPulseWidth


Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthDigFltrTimebaseSrc

DAQmxSetCIPulseWidthDigFltrTimebaseSrc

DAQmxResetCIPulseWidthDigFltrTimebaseSrc


Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthDigFltrTimebaseRate

DAQmxSetCIPulseWidthDigFltrTimebaseRate

DAQmxResetCIPulseWidthDigFltrTimebaseRate


Counter Input >> Pulse Width >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthDigSyncEnable

DAQmxSetCIPulseWidthDigSyncEnable

DAQmxResetCIPulseWidthDigSyncEnable


Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstDigFltrEnable

DAQmxSetCITwoEdgeSepFirstDigFltrEnable

DAQmxResetCITwoEdgeSepFirstDigFltrEnable


Counter Input >> Semi-Period >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodDigFltrMinPulseWidth

DAQmxSetCISemiPeriodDigFltrMinPulseWidth

DAQmxResetCISemiPeriodDigFltrMinPulseWidth


Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodDigFltrTimebaseSrc

DAQmxSetCISemiPeriodDigFltrTimebaseSrc

DAQmxResetCISemiPeriodDigFltrTimebaseSrc


Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodDigFltrTimebaseRate

DAQmxSetCISemiPeriodDigFltrTimebaseRate

DAQmxResetCISemiPeriodDigFltrTimebaseRate


Counter Input >> Semi-Period >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodDigSyncEnable

DAQmxSetCISemiPeriodDigSyncEnable

DAQmxResetCISemiPeriodDigSyncEnable


Sample Clock >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetSampClkDigFltrEnable

DAQmxSetSampClkDigFltrEnable

DAQmxResetSampClkDigFltrEnable


Sample Clock >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetSampClkDigFltrMinPulseWidth

DAQmxSetSampClkDigFltrMinPulseWidth

DAQmxResetSampClkDigFltrMinPulseWidth


More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigDigFltrTimebaseSrc

DAQmxSetDigLvlPauseTrigDigFltrTimebaseSrc

DAQmxResetDigLvlPauseTrigDigFltrTimebaseSrc


More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigDigFltrTimebaseRate

DAQmxSetDigLvlPauseTrigDigFltrTimebaseRate

DAQmxResetDigLvlPauseTrigDigFltrTimebaseRate


More >> Pause >> Digital Level >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigDigSyncEnable

DAQmxSetDigLvlPauseTrigDigSyncEnable

DAQmxResetDigLvlPauseTrigDigSyncEnable


More >> Arm Start >> Digital Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigDigFltrEnable

DAQmxSetDigEdgeArmStartTrigDigFltrEnable

DAQmxResetDigEdgeArmStartTrigDigFltrEnable


More >> Arm Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigDigFltrMinPulseWidth

DAQmxSetDigEdgeArmStartTrigDigFltrMinPulseWidth

DAQmxResetDigEdgeArmStartTrigDigFltrMinPulseWidth


More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseSrc

DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseSrc

DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseSrc


Analog Input >> Sound Pressure >> Maximum Sound Pressure Level

Data Type: | float64
Description: | Specifies the maximum instantaneous sound pressure level you expect to measure. This value is in decibels, referenced to 20 micropascals. NI-DAQmx uses the maximum sound pressure level to calculate values in pascals for Maximum Value and Minimum Value for the channel.

You can get/set/reset this property using:

DAQmxGetAISoundPressureMaxSoundPressureLvl

DAQmxSetAISoundPressureMaxSoundPressureLvl

DAQmxResetAISoundPressureMaxSoundPressureLvl


More >> Device Temperature

Data Type: | float64
Description: | Indicates in degrees Celsius the current temperature of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCalDevTemp


Events >> Synchronization Pulse Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Synchronization Pulse Event.

You can get/set/reset this property using:

DAQmxGetExportedSyncPulseEventOutputTerm

DAQmxSetExportedSyncPulseEventOutputTerm

DAQmxResetExportedSyncPulseEventOutputTerm


More >> Synchronization Pulse >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the synchronization pulse. The synchronization pulse resets the clock dividers and the ADCs/DACs on the device.

You can get/set/reset this property using:

DAQmxGetSyncPulseSrc

DAQmxSetSyncPulseSrc

DAQmxResetSyncPulseSrc


More >> Synchronization Pulse >> Synchronization Time

Data Type: | float64
Description: | Indicates in seconds the delay required to reset the ADCs/DACs after the device receives the synchronization pulse. This time is the minimum delay required by the device between the receipt of the synchronization pulse and the start of the acquisition. Read this property for all slave devices and set Minimum Delay To Start for the master device to the maximum of these delays.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSyncPulseSyncTime


More >> Synchronization Pulse >> Minimum Delay To Start

Data Type: | float64
Description: | Specifies in seconds the amount of time that elapses after the master device issues the synchronization pulse before the task starts. Read Synchronization Time for all slave devices, and set this property for the master device to the maximum of those values.

You can get/set/reset this property using:

DAQmxGetSyncPulseMinDelayToStart

DAQmxSetSyncPulseMinDelayToStart

DAQmxResetSyncPulseMinDelayToStart


Counter Output >> General Properties >> More >> Advanced >> Prescaler

Data Type: | uInt32
Description: | Specifies the divisor to apply to the signal you connect to the counter source terminal. Pulse generations defined by frequency or time take this setting into account, but pulse generations defined by ticks do not. You should use a prescaler only when you connect an external signal to the counter source terminal and when that signal has a higher frequency than the fastest onboard timebase.

You can get/set/reset this property using:

DAQmxGetCOPrescaler

DAQmxSetCOPrescaler

DAQmxResetCOPrescaler


Clocks >> 10MHz Reference Clock >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the 10MHz Clock.

You can get/set/reset this property using:

DAQmxGetExported10MHzRefClkOutputTerm

DAQmxSetExported10MHzRefClkOutputTerm

DAQmxResetExported10MHzRefClkOutputTerm


Counter Output >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseDigSyncEnable

DAQmxSetCOCtrTimebaseDigSyncEnable

DAQmxResetCOCtrTimebaseDigSyncEnable


TEDS >> TemplateIDs

Data Type: | uInt32*
Description: | Indicates the IDs of the templates in the bitstream in BitStream.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetPhysicalChanTEDSTemplateIDs


Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Scale Type

Data Type: | int32
Description: | Specifies the method or equation form that the calibration scale uses. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

Valid values
DAQmx_Val_Polynomial | 10449 | Scale values by using an Nth order polynomial equation.
DAQmx_Val_Table | 10450 | Map an array of prescaled values to an array of corresponding scaled values, with all other values scaled proportionally.
DAQmx_Val_None | 10230 |

You can get/set/reset this property using:

DAQmxGetAIChanCalScaleType

DAQmxSetAIChanCalScaleType

DAQmxResetAIChanCalScaleType


Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Pre-Scaled Values

Data Type: | float64*
Description: | Specifies the reference values collected when calibrating the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalTablePreScaledVals

DAQmxSetAIChanCalTablePreScaledVals

DAQmxResetAIChanCalTablePreScaledVals


Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Scaled Values

Data Type: | float64*
Description: | Specifies the acquired values collected when calibrating the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalTableScaledVals

DAQmxSetAIChanCalTableScaledVals

DAQmxResetAIChanCalTableScaledVals


Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Forward Coefficients

Data Type: | float64*
Description: | Specifies the forward polynomial values used for calibrating the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalPolyForwardCoeff

DAQmxSetAIChanCalPolyForwardCoeff

DAQmxResetAIChanCalPolyForwardCoeff


Input >> Onboard Buffer Size

Data Type: | uInt32
Description: | Indicates in samples per channel the size of the onboard input buffer of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetBufInputOnbrdBufSize


Output >> Onboard Buffer Size

Data Type: | uInt32
Description: | Specifies in samples per channel the size of the onboard output buffer of the device.

You can get/set/reset this property using:

DAQmxGetBufOutputOnbrdBufSize

DAQmxSetBufOutputOnbrdBufSize

DAQmxResetBufOutputOnbrdBufSize


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Custom Threshold

Data Type: | uInt32
Description: | Specifies the number of samples that must be in the FIFO to transfer data from the device if Data Transfer Request Condition is DAQmx_Val_OnbrdMemCustomThreshold.

You can get/set/reset this property using:

DAQmxGetAIDataXferCustomThreshold

DAQmxSetAIDataXferCustomThreshold

DAQmxResetAIDataXferCustomThreshold


Devices

Data Type: | char*
Description: | Indicates an array containing the names of all devices in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskDevices


Write Recovery Mode

Data Type: | int32
Description: | Specifies how NI-DAQmx attempts to recover after missing a Sample Clock pulse when performing counter writes.

Valid values
DAQmx_Val_WaitForInterrupt | 12523 | Attempt to recover when the system receives an interrupt service request. This mode is the most CPU efficient and best suited for recovery at lower pulse train frequencies.
DAQmx_Val_Poll | 12524 | Repeatedly attempt to recover as fast as possible. This mode has the highest probability of recovery success at the expense of CPU efficiency.

You can get/set/reset this property using:

DAQmxGetRealTimeWriteRecoveryMode

DAQmxSetRealTimeWriteRecoveryMode

DAQmxResetRealTimeWriteRecoveryMode


Identification >> Product Number

Data Type: | uInt32
Description: | Indicates the unique hardware identification number for the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevProductNum


I/O Type >> Analog Input >> Physical Channels

Data Type: | char*
Description: | Indicates an array containing the names of the analog input physical channels available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIPhysicalChans


I/O Type >> Analog Output >> Physical Channels

Data Type: | char*
Description: | Indicates an array containing the names of the analog output physical channels available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOPhysicalChans


Location >> PXI >> Slot Number

Data Type: | uInt32
Description: | Indicates the PXI slot number of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevPXISlotNum


Bus >> Number of DMA Channels

Data Type: | uInt32
Description: | Indicates the number of DMA channels on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevNumDMAChans


Counter Output >> General Properties >> More >> Count

Data Type: | uInt32
Description: | Indicates the current value of the count register.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetCOCount


Counter Output >> General Properties >> More >> Output State

Data Type: | int32
Description: | Indicates the current state of the output terminal of the counter.
Restrictions: | Not Settable

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get this property using:

DAQmxGetCOOutputState


Counter Output >> General Properties >> More >> Auto Increment Count

Data Type: uInt32
Description: Specifies a number of timebase ticks by which to increase the time spent in the idle state for each successive pulse.

When this value is greater than 0, NI-DAQmx generates progressively longer pulses until the count register rolls over. At that point, the generated pulses return to the original pulse width and grow progressively longer until the count register rolls over again.

Use this property to provide a clock to an analog input channel for equivalent time sampling (ETS). ETS is a data acquisition technique in which data on a periodic waveform with a frequency higher than the Nyquist frequency of the system is obtained by sampling the waveform at instants in time skewed in relation to the beginning of each period of the waveform.

You can get/set/reset this property using:

DAQmxGetCOAutoIncrCnt

DAQmxSetCOAutoIncrCnt

DAQmxResetCOAutoIncrCnt


Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetDIMemMapEnable

DAQmxSetDIMemMapEnable

DAQmxResetDIMemMapEnable


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable

Data Type: | bool32
Description: | Specifies for NI-DAQmx to map hardware registers to the memory space of the application, if possible. Normally, NI-DAQmx maps hardware registers to memory accessible only to the kernel. Mapping the registers to the memory space of the application increases performance. However, if the application accesses the memory space mapped to the registers, it can adversely affect the operation of the device and possibly result in a system crash.

You can get/set/reset this property using:

DAQmxGetDOMemMapEnable

DAQmxSetDOMemMapEnable

DAQmxResetDOMemMapEnable


Digital Input >> Logic Family

Data Type: | int32
Description: | Specifies the logic family to use for acquisition. A logic family corresponds to voltage thresholds that are compatible with a group of voltage standards. Refer to the device documentation for information on the logic high and logic low voltages for these logic families.

Valid values
DAQmx_Val_2point5V | 14620 | Compatible with 2.5 V CMOS signals.
DAQmx_Val_3point3V | 14621 | Compatible with LVTTL signals.
DAQmx_Val_5V | 14619 | Compatible with TTL and 5 V CMOS signals.

You can get/set/reset this property using:

DAQmxGetDILogicFamily

DAQmxSetDILogicFamily

DAQmxResetDILogicFamily


Digital Output >> Logic Family

Data Type: | int32
Description: | Specifies the logic family to use for generation. A logic family corresponds to voltage thresholds that are compatible with a group of voltage standards. Refer to the device documentation for information on the logic high and logic low voltages for these logic families.

Valid values
DAQmx_Val_2point5V | 14620 | Compatible with 2.5 V CMOS signals.
DAQmx_Val_3point3V | 14621 | Compatible with LVTTL signals.
DAQmx_Val_5V | 14619 | Compatible with TTL and 5 V CMOS signals.

You can get/set/reset this property using:

DAQmxGetDOLogicFamily

DAQmxSetDOLogicFamily

DAQmxResetDOLogicFamily


Counter Output >> Pulse >> Ticks >> Initial Delay

Data Type: | uInt32
Description: | Specifies the number of ticks to wait before generating the first pulse.

You can get/set/reset this property using:

DAQmxGetCOPulseTicksInitialDelay

DAQmxSetCOPulseTicksInitialDelay

DAQmxResetCOPulseTicksInitialDelay


I/O Type >> Counter Input >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for counter input tasks.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevCITrigUsage


I/O Type >> Counter Output >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for counter output tasks.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevCOTrigUsage


I/O Type >> Analog Input >> Timing >> Maximum Single Channel Rate

Data Type: | float64
Description: | Indicates the maximum rate for an analog input task if the task contains only a single channel from this device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIMaxSingleChanRate


I/O Type >> Analog Input >> Timing >> Maximum Multiple Channel Rate

Data Type: | float64
Description: | Indicates the maximum sampling rate for an analog input task from this device. To find the maximum rate for the task, take the minimum of Maximum Single Channel Rate or the indicated sampling rate of this device divided by the number of channels to acquire data from (including cold-junction compensation and autozero channels).
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIMaxMultiChanRate


I/O Type >> Analog Input >> Timing >> Minimum Rate

Data Type: | float64
Description: | Indicates the minimum rate for an analog input task on this device. NI-DAQmx returns a warning or error if you attempt to sample at a slower rate.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIMinRate


I/O Type >> Analog Input >> Timing >> Simultaneous Sampling Supported

Data Type: | bool32
Description: | Indicates if the device supports simultaneous sampling.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAISimultaneousSamplingSupported


Counter Output >> Pulse >> Frequency >> Initial Delay

Data Type: | float64
Description: | Specifies in seconds the amount of time to wait before generating the first pulse.

You can get/set/reset this property using:

DAQmxGetCOPulseFreqInitialDelay

DAQmxSetCOPulseFreqInitialDelay

DAQmxResetCOPulseFreqInitialDelay


I/O Type >> Digital Output >> Timing >> Maximum Rate

Data Type: | float64
Description: | Indicates the maximum digital output rate of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDOMaxRate


I/O Type >> Analog Output >> Voltage >> Ranges

Data Type: | float64*
Description: | Indicates pairs of output voltage ranges supported by this device. Each pair consists of the low value, followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOVoltageRngs


I/O Type >> Analog Output >> Current >> Ranges

Data Type: | float64*
Description: | Indicates pairs of output current ranges supported by this device. Each pair consists of the low value, followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOCurrentRngs


I/O Type >> Analog Output >> Gains

Data Type: | float64*
Description: | Indicates the output gain settings supported by this device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOGains


I/O Type >> Counter Input >> Timing >> Sample Clock Supported

Data Type: | bool32
Description: | Indicates if the device supports the sample clock timing type for counter input tasks.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCISampClkSupported


I/O Type >> Counter Input >> Maximum Size

Data Type: | uInt32
Description: | Indicates in bits the size of the counters on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCIMaxSize


Deprecated >> Temperature

Data Type: | float64
Description: | (Deprecated) Indicates the current temperature as read by the Switch module in degrees Celsius. Refer to your device documentation for more information.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevTemperature


Analog Output >> Power Up Output Types

Data Type: | int32*
Description: | Indicates the power up output types supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_ | 10322 | Voltage output.
DAQmx_Val_ | 10134 | Current output.
DAQmx_Val_ | 12527 | High-impedance state.

You can get this property using:

DAQmxGetPhysicalChanAOSupportedPowerUpOutputTypes


Expiration Trigger >> Trigger On Network Connection Loss

Data Type: | bool32
Description: | Specifies the watchdog timer behavior when the network connection is lost between the host and the chassis. If set to true, the watchdog timer expires when the chassis detects the loss of network connection.

You can get/set/reset this property using:

DAQmxGetWatchdogExpirTrigTrigOnNetworkConnLoss

DAQmxSetWatchdogExpirTrigTrigOnNetworkConnLoss

DAQmxResetWatchdogExpirTrigTrigOnNetworkConnLoss


Expiration States >> Analog Output >> Output Type

Data Type: | int32
Description: | Specifies the output type of the analog output physical channels when the watchdog task expires.

Valid values
DAQmx_Val_Voltage | 10322 | Voltage output.
DAQmx_Val_Current | 10134 | Current output.
DAQmx_Val_NoChange | 10160 | Expiration does not affect the port. Do not change the state of any lines in the port, and do not lock the port.

You can get/set/reset this property using:

DAQmxGetWatchdogAOOutputType

DAQmxSetWatchdogAOOutputType

DAQmxResetWatchdogAOOutputType


Expiration States >> Analog Output >> Expiration State

Data Type: | float64
Description: | Specifies the state to set the analog output physical channels when the watchdog task expires.

You can get/set/reset this property using:

DAQmxGetWatchdogAOExpirState

DAQmxSetWatchdogAOExpirState

DAQmxResetWatchdogAOExpirState


Counter Input >> Duty Cycle >> Input >> Terminal

Data Type: | char*
Description: | Specifies the input terminal of the signal to measure.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleTerm

DAQmxSetCIDutyCycleTerm

DAQmxResetCIDutyCycleTerm


Counter Input >> Duty Cycle >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleDigFltrEnable

DAQmxSetCIDutyCycleDigFltrEnable

DAQmxResetCIDutyCycleDigFltrEnable


Counter Input >> Duty Cycle >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the digital filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleDigFltrMinPulseWidth

DAQmxSetCIDutyCycleDigFltrMinPulseWidth

DAQmxResetCIDutyCycleDigFltrMinPulseWidth


Counter Input >> Period >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIPeriodLogicLvlBehavior

DAQmxSetCIPeriodLogicLvlBehavior

DAQmxResetCIPeriodLogicLvlBehavior


Counter Input >> Count Edges >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCICountEdgesTermCfg

DAQmxSetCICountEdgesTermCfg

DAQmxResetCICountEdgesTermCfg


Counter Input >> Count Edges >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCICountEdgesLogicLvlBehavior

DAQmxSetCICountEdgesLogicLvlBehavior

DAQmxResetCICountEdgesLogicLvlBehavior


Counter Input >> Count Edges >> Count Direction >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirTermCfg

DAQmxSetCICountEdgesCountDirTermCfg

DAQmxResetCICountEdgesCountDirTermCfg


Counter Input >> Count Edges >> Count Direction >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the count reset line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountDirLogicLvlBehavior

DAQmxSetCICountEdgesCountDirLogicLvlBehavior

DAQmxResetCICountEdgesCountDirLogicLvlBehavior


Counter Input >> Count Edges >> Count Reset >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCICountEdgesCountResetTermCfg

DAQmxSetCICountEdgesCountResetTermCfg

DAQmxResetCICountEdgesCountResetTermCfg


Counter Output >> General Properties >> Counter Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the timebase to use for the counter. Typically, NI-DAQmx uses one of the internal counter timebases when generating pulses. Use this property to specify an external timebase and produce custom pulse widths that are not possible using the internal timebases.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseSrc

DAQmxSetCOCtrTimebaseSrc

DAQmxResetCOCtrTimebaseSrc


Counter Output >> General Properties >> Counter Timebase >> Active Edge

Data Type: | int32
Description: | Specifies whether a timebase cycle is from rising edge to rising edge or from falling edge to falling edge.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseActiveEdge

DAQmxSetCOCtrTimebaseActiveEdge

DAQmxResetCOCtrTimebaseActiveEdge


Triggers >> Start Trigger >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Start Trigger.

You can get/set/reset this property using:

DAQmxGetExportedStartTrigOutputTerm

DAQmxSetExportedStartTrigOutputTerm

DAQmxResetExportedStartTrigOutputTerm


Triggers >> Start Trigger >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the exported Start Trigger.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedStartTrigPulsePolarity

DAQmxSetExportedStartTrigPulsePolarity

DAQmxResetExportedStartTrigPulsePolarity


Triggers >> Reference Trigger >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Reference Trigger.

You can get/set/reset this property using:

DAQmxGetExportedRefTrigOutputTerm

DAQmxSetExportedRefTrigOutputTerm

DAQmxResetExportedRefTrigOutputTerm


Triggers >> Reference Trigger >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the exported Reference Trigger.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedRefTrigPulsePolarity

DAQmxSetExportedRefTrigPulsePolarity

DAQmxResetExportedRefTrigPulsePolarity


Identification >> Product Type

Data Type: | char*
Description: | Indicates the product name of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevProductType


Identification >> Device Serial Number

Data Type: | uInt32
Description: | Indicates the serial number of the device. This value is zero if the device does not have a serial number.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevSerialNum


Deprecated >> Capability >> Bandwidth

Data Type: | float64
Description: | (Deprecated) Indicates in Hertz the maximum frequency of a signal that can pass through the switch without significant deterioration.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanBandwidth


Deprecated >> Capability >> Impedance

Data Type: | float64
Description: | (Deprecated) Indicates in ohms the switch impedance. This value is important in the RF domain and should match the impedance of the sources and loads.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanImpedance


Deprecated >> Capability >> Max AC Carry Power

Data Type: | float64
Description: | (Deprecated) Indicates in watts the maximum AC power that the device can carry.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxACCarryPwr


Deprecated >> Capability >> Max DC Carry Power

Data Type: | float64
Description: | (Deprecated) Indicates in watts the maximum DC power that the device can carry.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxDCCarryPwr


Deprecated >> Capability >> Max AC Switching Power

Data Type: | float64
Description: | (Deprecated) Indicates in watts the maximum AC power that the device can switch.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxACSwitchPwr


Deprecated >> Capability >> Max DC Switching Current

Data Type: | float64
Description: | (Deprecated) Indicates in amperes the maximum DC current that the device can switch. This current is always against a DC voltage level.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxDCSwitchCurrent


Deprecated >> Capability >> Max AC Switching Current

Data Type: | float64
Description: | (Deprecated) Indicates in amperes the maximum AC current that the device can switch. This current is always against an RMS voltage level.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxACSwitchCurrent


Deprecated >> Capability >> Max DC Carry Current

Data Type: | float64
Description: | (Deprecated) Indicates in amperes the maximum DC current that the device can carry.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxDCCarryCurrent


Deprecated >> Capability >> Max AC Carry Current

Data Type: | float64
Description: | (Deprecated) Indicates in amperes the maximum AC current that the device can carry.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxACCarryCurrent


Deprecated >> Capability >> Max DC Switching Power

Data Type: | float64
Description: | (Deprecated) Indicates in watts the maximum DC power that the device can switch.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxDCSwitchPwr


Deprecated >> Capability >> Max DC Voltage

Data Type: | float64
Description: | (Deprecated) Indicates in volts the maximum DC voltage that the device can switch.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxDCVoltage


Deprecated >> Capability >> Max AC Voltage

Data Type: | float64
Description: | (Deprecated) Indicates in volts the maximum AC RMS voltage that the device can switch.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchChanMaxACVoltage


Analog Input >> Acceleration >> Units

Data Type: | int32
Description: | Specifies the units to use to return acceleration measurements from the channel.

Valid values
DAQmx_Val_AccelUnit_g | 10186 | 1 g is approximately equal to 9.81 m/s/s.
DAQmx_Val_MetersPerSecondSquared | 12470 | Meters per second per second.
DAQmx_Val_InchesPerSecondSquared | 12471 | Inches per second per second.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIAccelUnits

DAQmxSetAIAccelUnits

DAQmxResetAIAccelUnits


Analog Input >> Acceleration >> Accelerometer >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the accelerometer. This value is in the units you specify with Sensitivity Units. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIAccelSensitivity

DAQmxSetAIAccelSensitivity

DAQmxResetAIAccelSensitivity


Analog Input >> Measurement Type

Data Type: | int32
Description: | Indicates the measurement to take with the analog input channel and in some cases, such as for temperature measurements, the sensor to use.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage measurement.
DAQmx_Val_VoltageRMS | 10350 | Voltage RMS measurement.
DAQmx_Val_Current | 10134 | Current measurement.
DAQmx_Val_CurrentRMS | 10351 | Current RMS measurement.
DAQmx_Val_Voltage_CustomWithExcitation | 10323 | Voltage measurement with an excitation source. You can use this measurement type for custom sensors that require excitation, but you must use a custom scale to scale the measured voltage.
DAQmx_Val_Bridge | 15908 | Measure voltage ratios from a Wheatstone bridge.
DAQmx_Val_Freq_Voltage | 10181 | Frequency measurement using a frequency to voltage converter.
DAQmx_Val_Resistance | 10278 | Resistance measurement.
DAQmx_Val_Temp_TC | 10303 | Temperature measurement using a thermocouple.
DAQmx_Val_Temp_Thrmstr | 10302 | Temperature measurement using a thermistor.
DAQmx_Val_Temp_RTD | 10301 | Temperature measurement using an RTD.
DAQmx_Val_Temp_BuiltInSensor | 10311 | Temperature measurement using a built-in sensor on a terminal block or device. On SCXI modules, for example, this could be the CJC sensor.
DAQmx_Val_Strain_Gage | 10300 | Strain measurement.
DAQmx_Val_Rosette_Strain_Gage | 15980 | Strain measurement using a rosette strain gage.
DAQmx_Val_Position_LVDT | 10352 | Position measurement using an LVDT.
DAQmx_Val_Position_RVDT | 10353 | Position measurement using an RVDT.
DAQmx_Val_Position_EddyCurrentProximityProbe | 14835 | Position measurement using an eddy current proximity probe.
DAQmx_Val_Accelerometer | 10356 | Acceleration measurement using an accelerometer.
DAQmx_Val_Acceleration_Charge | 16104 | Acceleration measurement using a charge-based sensor.
DAQmx_Val_Acceleration_4WireDCVoltage | 16106 | Acceleration measurement using a 4 wire DC voltage based sensor.
DAQmx_Val_Velocity_IEPESensor | 15966 | Velocity measurement using an IEPE Sensor.
DAQmx_Val_Force_Bridge | 15899 | Force measurement using a bridge-based sensor.
DAQmx_Val_Force_IEPESensor | 15895 | Force measurement using an IEPE Sensor.
DAQmx_Val_Pressure_Bridge | 15902 | Pressure measurement using a bridge-based sensor.
DAQmx_Val_SoundPressure_Microphone | 10354 | Sound pressure measurement using a microphone.
DAQmx_Val_Torque_Bridge | 15905 | Torque measurement using a bridge-based sensor.
DAQmx_Val_TEDS_Sensor | 12531 | Measurement type defined by TEDS.
DAQmx_Val_Charge | 16105 | Charge measurement.

You can get this property using:

DAQmxGetAIMeasType


Counter Input >> Count Edges >> Count Direction >> Direction

Data Type: | int32
Description: | Specifies whether to increment or decrement the counter on each edge.

Valid values
DAQmx_Val_CountUp | 10128 | Increment counter.
DAQmx_Val_CountDown | 10124 | Decrement counter.
DAQmx_Val_ExtControlled | 10326 | The state of a digital line controls the count direction. Each counter has a default count direction terminal.

You can get/set/reset this property using:

DAQmxGetCICountEdgesDir

DAQmxSetCICountEdgesDir

DAQmxResetCICountEdgesDir


Counter Input >> Count Edges >> Active Edge

Data Type: | int32
Description: | Specifies on which edges to increment or decrement the counter.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCICountEdgesActiveEdge

DAQmxSetCICountEdgesActiveEdge

DAQmxResetCICountEdgesActiveEdge


Counter Input >> Count Edges >> Initial Count

Data Type: | uInt32
Description: | Specifies the starting value from which to count.

You can get/set/reset this property using:

DAQmxGetCICountEdgesInitialCnt

DAQmxSetCICountEdgesInitialCnt

DAQmxResetCICountEdgesInitialCnt


Analog Input >> Current >> Units

Data Type: | int32
Description: | Specifies the units to use to return current measurements from the channel.

Valid values
DAQmx_Val_Amps | 10342 | Amperes.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAICurrentUnits

DAQmxSetAICurrentUnits

DAQmxResetAICurrentUnits


Digital Input >> Invert Lines

Data Type: | bool32
Description: | Specifies whether to invert the lines in the channel. If you set this property to TRUE, the lines are at high logic when off and at low logic when on.

You can get/set/reset this property using:

DAQmxGetDIInvertLines

DAQmxSetDIInvertLines

DAQmxResetDIInvertLines


Counter Input >> Frequency >> Starting Edge

Data Type: | int32
Description: | Specifies between which edges to measure the frequency of the signal.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIFreqStartingEdge

DAQmxSetCIFreqStartingEdge

DAQmxResetCIFreqStartingEdge


Analog Input >> Frequency >> Units

Data Type: | int32
Description: | Specifies the units to use to return frequency measurements from the channel.

Valid values
DAQmx_Val_Hz | 10373 | Hertz.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIFreqUnits

DAQmxSetAIFreqUnits

DAQmxResetAIFreqUnits


Analog Input >> Frequency >> Voltage >> Hysteresis

Data Type: | float64
Description: | Specifies in volts a window below Threshold Level. The input voltage must pass below Threshold Level minus this value before NI-DAQmx recognizes a waveform repetition at Threshold Level. Hysteresis can improve the measurement accuracy when the signal contains noise or jitter.

You can get/set/reset this property using:

DAQmxGetAIFreqHyst

DAQmxSetAIFreqHyst

DAQmxResetAIFreqHyst


Analog Input >> Frequency >> Voltage >> Threshold Level

Data Type: | float64
Description: | Specifies the voltage level at which to recognize waveform repetitions. You should select a voltage level that occurs only once within the entire period of a waveform. You also can select a voltage that occurs only once while the voltage rises or falls.

You can get/set/reset this property using:

DAQmxGetAIFreqThreshVoltage

DAQmxSetAIFreqThreshVoltage

DAQmxResetAIFreqThreshVoltage


Counter Input >> Pulse Width >> Units

Data Type: | int32
Description: | Specifies the units to use to return pulse width measurements.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetCIPulseWidthUnits

DAQmxSetCIPulseWidthUnits

DAQmxResetCIPulseWidthUnits


Counter Input >> Pulse Width >> Starting Edge

Data Type: | int32
Description: | Specifies on which edge of the input signal to begin each pulse width measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIPulseWidthStartingEdge

DAQmxSetCIPulseWidthStartingEdge

DAQmxResetCIPulseWidthStartingEdge


Counter Input >> Two Edge Separation >> First >> Edge

Data Type: | int32
Description: | Specifies on which edge of the first signal to start each measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstEdge

DAQmxSetCITwoEdgeSepFirstEdge

DAQmxResetCITwoEdgeSepFirstEdge


Counter Input >> Two Edge Separation >> Second >> Edge

Data Type: | int32
Description: | Specifies on which edge of the second signal to stop each measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondEdge

DAQmxSetCITwoEdgeSepSecondEdge

DAQmxResetCITwoEdgeSepSecondEdge


Counter Input >> Period >> Starting Edge

Data Type: | int32
Description: | Specifies between which edges to measure the period of the signal.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIPeriodStartingEdge

DAQmxSetCIPeriodStartingEdge

DAQmxResetCIPeriodStartingEdge


Counter Input >> Position >> Angular Encoder >> Pulses Per Revolution

Data Type: | uInt32
Description: | Specifies the number of pulses the encoder generates per revolution. This value is the number of pulses on either signal A or signal B, not the total number of pulses on both signal A and signal B.

You can get/set/reset this property using:

DAQmxGetCIAngEncoderPulsesPerRev

DAQmxSetCIAngEncoderPulsesPerRev

DAQmxResetCIAngEncoderPulsesPerRev


Analog Input >> Position >> RVDT >> Units

Data Type: | int32
Description: | Specifies the units to use to return angular position measurements from the channel.

Valid values
DAQmx_Val_Degrees | 10146 | Degrees.
DAQmx_Val_Radians | 10273 | Radians.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIRVDTUnits

DAQmxSetAIRVDTUnits

DAQmxResetAIRVDTUnits


Counter Input >> Position >> Angular Encoder >> Initial Angle

Data Type: | float64
Description: | Specifies the starting angle of the encoder. This value is in the units you specify with Units.

You can get/set/reset this property using:

DAQmxGetCIAngEncoderInitialAngle

DAQmxSetCIAngEncoderInitialAngle

DAQmxResetCIAngEncoderInitialAngle


Counter Input >> Position >> Z Index Value

Data Type: | float64
Description: | Specifies the value to which to reset the measurement when signal Z is high and signal A and signal B are at the states you specify with Z Index Phase. Specify this value in the units of the measurement.

You can get/set/reset this property using:

DAQmxGetCIEncoderZIndexVal

DAQmxSetCIEncoderZIndexVal

DAQmxResetCIEncoderZIndexVal


Counter Input >> Position >> Z Index Phase

Data Type: | int32
Description: | Specifies the states at which signal A and signal B must be while signal Z is high for NI-DAQmx to reset the measurement. If signal Z is never high while signal A and signal B are high, for example, you must choose a phase other than DAQmx_Val_AHighBHigh. When signal Z transitions to high and how long it stays high varies from encoder to encoder. Refer to the documentation for the encoder to determine the timing of signal Z with respect to signal A and signal B.

Valid values
DAQmx_Val_AHighBHigh | 10040 | Reset the measurement when signal A and signal B are high.
DAQmx_Val_AHighBLow | 10041 | Reset the measurement when signal A is high and signal B is low.
DAQmx_Val_ALowBHigh | 10042 | Reset the measurement when signal A is low and signal B high.
DAQmx_Val_ALowBLow | 10043 | Reset the measurement when signal A and signal B are low.

You can get/set/reset this property using:

DAQmxGetCIEncoderZIndexPhase

DAQmxSetCIEncoderZIndexPhase

DAQmxResetCIEncoderZIndexPhase


Counter Input >> Position >> Z Index Enable

Data Type: | bool32
Description: | Specifies whether to use Z indexing for the channel.

You can get/set/reset this property using:

DAQmxGetCIEncoderZIndexEnable

DAQmxSetCIEncoderZIndexEnable

DAQmxResetCIEncoderZIndexEnable


Analog Input >> Position >> RVDT >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the RVDT. This value is in the units you specify with Sensitivity Units. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIRVDTSensitivity

DAQmxSetAIRVDTSensitivity

DAQmxResetAIRVDTSensitivity


Analog Input >> Position >> LVDT >> Units

Data Type: | int32
Description: | Specifies the units to use to return linear position measurements from the channel.

Valid values
DAQmx_Val_Meters | 10219 | Meters.
DAQmx_Val_Inches | 10379 | Inches.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAILVDTUnits

DAQmxSetAILVDTUnits

DAQmxResetAILVDTUnits


Counter Input >> Position >> Linear Encoder >> Distance Per Pulse

Data Type: | float64
Description: | Specifies the distance to measure for each pulse the encoder generates on signal A or signal B. This value is in the units you specify with Units.

You can get/set/reset this property using:

DAQmxGetCILinEncoderDistPerPulse

DAQmxSetCILinEncoderDistPerPulse

DAQmxResetCILinEncoderDistPerPulse


Counter Input >> Position >> Linear Encoder >> Initial Position

Data Type: | float64
Description: | Specifies the position of the encoder when the measurement begins. This value is in the units you specify with Units.

You can get/set/reset this property using:

DAQmxGetCILinEncoderInitialPos

DAQmxSetCILinEncoderInitialPos

DAQmxResetCILinEncoderInitialPos


Analog Input >> Position >> LVDT >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the LVDT. This value is in the units you specify with Sensitivity Units. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAILVDTSensitivity

DAQmxSetAILVDTSensitivity

DAQmxResetAILVDTSensitivity


Analog Input >> Resistance >> Units

Data Type: | int32
Description: | Specifies the units to use to return resistance measurements.

Valid values
DAQmx_Val_Ohms | 10384 | Ohms.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAIResistanceUnits

DAQmxSetAIResistanceUnits

DAQmxResetAIResistanceUnits


Analog Input >> Strain >> Units

Data Type: | int32
Description: | Specifies the units to use to return strain measurements from the channel.

Valid values
DAQmx_Val_Strain | 10299 | Strain.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIStrainUnits

DAQmxSetAIStrainUnits

DAQmxResetAIStrainUnits


Analog Input >> Strain >> Strain Gage >> Configuration

Data Type: | int32
Description: | Specifies the bridge configuration of the strain gages.

Valid values
DAQmx_Val_FullBridgeI | 10183 | Four active gages with two pairs subjected to equal and opposite strains.
DAQmx_Val_FullBridgeII | 10184 | Four active gages with two aligned with maximum principal strain and two Poisson gages in adjacent arms.
DAQmx_Val_FullBridgeIII | 10185 | Four active gages with two aligned with maximum principal strain and two Poisson gages in opposite arms.
DAQmx_Val_HalfBridgeI | 10188 | Two active gages with one aligned with maximum principal strain and one Poisson gage.
DAQmx_Val_HalfBridgeII | 10189 | Two active gages with equal and opposite strains.
DAQmx_Val_QuarterBridgeI | 10271 | Single active gage.
DAQmx_Val_QuarterBridgeII | 10272 | Single active gage and one dummy gage.

You can get/set/reset this property using:

DAQmxGetAIStrainGageCfg

DAQmxSetAIStrainGageCfg

DAQmxResetAIStrainGageCfg


Analog Input >> Strain >> Strain Gage >> Gage Factor

Data Type: | float64
Description: | Specifies the sensitivity of the strain gage. Gage factor relates the change in electrical resistance to the change in strain. Refer to the sensor documentation for this value.

You can get/set/reset this property using:

DAQmxGetAIStrainGageGageFactor

DAQmxSetAIStrainGageGageFactor

DAQmxResetAIStrainGageGageFactor


Analog Input >> Strain >> Strain Gage >> Poisson Ratio

Data Type: | float64
Description: | Specifies the ratio of lateral strain to axial strain in the material you are measuring.

You can get/set/reset this property using:

DAQmxGetAIStrainGagePoissonRatio

DAQmxSetAIStrainGagePoissonRatio

DAQmxResetAIStrainGagePoissonRatio


Analog Input >> Temperature >> RTD >> Custom >> A

Data Type: | float64
Description: | Specifies the 'A' constant of the Callendar-Van Dusen equation. NI-DAQmx requires this value when you use a custom RTD.

You can get/set/reset this property using:

DAQmxGetAIRTDA

DAQmxSetAIRTDA

DAQmxResetAIRTDA


Analog Input >> Temperature >> RTD >> Custom >> B

Data Type: | float64
Description: | Specifies the 'B' constant of the Callendar-Van Dusen equation. NI-DAQmx requires this value when you use a custom RTD.

You can get/set/reset this property using:

DAQmxGetAIRTDB

DAQmxSetAIRTDB

DAQmxResetAIRTDB


Analog Input >> Temperature >> RTD >> Custom >> C

Data Type: | float64
Description: | Specifies the 'C' constant of the Callendar-Van Dusen equation. NI-DAQmx requires this value when you use a custom RTD.

You can get/set/reset this property using:

DAQmxGetAIRTDC

DAQmxSetAIRTDC

DAQmxResetAIRTDC


Analog Input >> Temperature >> RTD >> R0

Data Type: | float64
Description: | Specifies in ohms the sensor resistance at 0 deg C. The Callendar-Van Dusen equation requires this value. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIRTDR0

DAQmxSetAIRTDR0

DAQmxResetAIRTDR0


Analog Input >> Temperature >> RTD >> Type

Data Type: | int32
Description: | Specifies the type of RTD connected to the channel.

Valid values
DAQmx_Val_Pt3750 | 12481 | Pt3750.
DAQmx_Val_Pt3851 | 10071 | Pt3851.
DAQmx_Val_Pt3911 | 12482 | Pt3911.
DAQmx_Val_Pt3916 | 10069 | Pt3916.
DAQmx_Val_Pt3920 | 10053 | Pt3920.
DAQmx_Val_Pt3928 | 12483 | Pt3928.
DAQmx_Val_Custom | 10137 | You must use A, B, and C to supply the coefficients for the Callendar-Van Dusen equation.

You can get/set/reset this property using:

DAQmxGetAIRTDType

DAQmxSetAIRTDType

DAQmxResetAIRTDType


Analog Input >> Temperature >> Units

Data Type: | int32
Description: | Specifies the units to use to return temperature measurements from the channel.

Valid values
DAQmx_Val_DegC | 10143 | Degrees Celsius.
DAQmx_Val_DegF | 10144 | Degrees Fahrenheit.
DAQmx_Val_Kelvins | 10325 | Kelvins.
DAQmx_Val_DegR | 10145 | Degrees Rankine.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAITempUnits

DAQmxSetAITempUnits

DAQmxResetAITempUnits


Analog Input >> Temperature >> Thermocouple >> CJC Channel

Data Type: | char*
Description: | Indicates the channel that acquires the temperature of the cold junction if CJC Source is DAQmx_Val_Chan. If the channel is a temperature channel, NI-DAQmx acquires the temperature in the correct units. Other channel types, such as a resistance channel with a custom sensor, must use a custom scale to scale values to degrees Celsius.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIThrmcplCJCChan


Analog Input >> Temperature >> Thermocouple >> CJC Source

Data Type: | int32
Description: | Indicates the source of cold-junction compensation.
Restrictions: | Not Settable

Valid values
DAQmx_Val_BuiltIn | 10200 | Use a cold-junction compensation channel built into the terminal block.
DAQmx_Val_ConstVal | 10116 | You must specify the cold-junction temperature.
DAQmx_Val_Chan | 10113 | Use a channel for cold-junction compensation.

You can get this property using:

DAQmxGetAIThrmcplCJCSrc


Analog Input >> Temperature >> Thermocouple >> CJC Value

Data Type: | float64
Description: | Specifies the temperature of the cold junction if CJC Source is DAQmx_Val_ConstVal. Specify this value in the units of the measurement.

You can get/set/reset this property using:

DAQmxGetAIThrmcplCJCVal

DAQmxSetAIThrmcplCJCVal

DAQmxResetAIThrmcplCJCVal


Analog Input >> Temperature >> Thermocouple >> Type

Data Type: | int32
Description: | Specifies the type of thermocouple connected to the channel. Thermocouple types differ in composition and measurement range.

Valid values
DAQmx_Val_J_Type_TC | 10072 | J-type thermocouple.
DAQmx_Val_K_Type_TC | 10073 | K-type thermocouple.
DAQmx_Val_N_Type_TC | 10077 | N-type thermocouple.
DAQmx_Val_R_Type_TC | 10082 | R-type thermocouple.
DAQmx_Val_S_Type_TC | 10085 | S-type thermocouple.
DAQmx_Val_T_Type_TC | 10086 | T-type thermocouple.
DAQmx_Val_B_Type_TC | 10047 | B-type thermocouple.
DAQmx_Val_E_Type_TC | 10055 | E-type thermocouple.

You can get/set/reset this property using:

DAQmxGetAIThrmcplType

DAQmxSetAIThrmcplType

DAQmxResetAIThrmcplType


Analog Input >> Temperature >> Thermistor >> R1

Data Type: | float64
Description: | Specifies in ohms the value of the reference resistor for the thermistor if you use voltage excitation. NI-DAQmx ignores this value for current excitation.

You can get/set/reset this property using:

DAQmxGetAIThrmstrR1

DAQmxSetAIThrmstrR1

DAQmxResetAIThrmstrR1


Counter Input >> Timestamp >> GPS >> Synchronization Method

Data Type: | int32
Description: | Specifies the method to use to synchronize the counter to a GPS receiver.

Valid values
DAQmx_Val_IRIGB | 10070 | Use the IRIG-B synchronization method. The GPS receiver sends one synchronization pulse per second, as well as information about the number of days, hours, minutes, and seconds that elapsed since the beginning of the current year.
DAQmx_Val_PPS | 10080 | Use the PPS synchronization method. The GPS receiver sends one synchronization pulse per second, but does not send any timing information. The timestamp measurement returns the number of seconds that elapsed since the device powered up unless you set Initial Seconds.
DAQmx_Val_None | 10230 | Do not synchronize the counter to a GPS receiver. The timestamp measurement returns the number of seconds that elapsed since the device powered up unless you set Initial Seconds.

You can get/set/reset this property using:

DAQmxGetCIGPSSyncMethod

DAQmxSetCIGPSSyncMethod

DAQmxResetCIGPSSyncMethod


Counter Input >> Timestamp >> GPS >> Synchronization Source

Data Type: | char*
Description: | Specifies the terminal to which the GPS synchronization signal is connected.

You can get/set/reset this property using:

DAQmxGetCIGPSSyncSrc

DAQmxSetCIGPSSyncSrc

DAQmxResetCIGPSSyncSrc


Analog Input >> Voltage >> Units

Data Type: | int32
Description: | Specifies the units to use to return voltage measurements from the channel.

Valid values
DAQmx_Val_Volts | 10348 | Volts.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAIVoltageUnits

DAQmxSetAIVoltageUnits

DAQmxResetAIVoltageUnits


Analog Input >> General Properties >> Input Configuration >> Terminal Configuration

Data Type: | int32
Description: | Specifies the terminal configuration for the channel.

Valid values
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.
DAQmx_Val_NRSE | 10078 | Non-Referenced Single-Ended.
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_PseudoDiff | 12529 | Pseudodifferential.

You can get/set/reset this property using:

DAQmxGetAITermCfg

DAQmxSetAITermCfg

DAQmxResetAITermCfg


Analog Output >> Output Type

Data Type: | int32
Description: | Indicates whether the channel generates voltage, current, or a waveform.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Voltage | 10322 | Voltage generation.
DAQmx_Val_Current | 10134 | Current generation.
DAQmx_Val_FuncGen | 14750 | Function generation.

You can get this property using:

DAQmxGetAOOutputType


Analog Output >> Current >> Units

Data Type: | int32
Description: | Specifies in what units to generate current on the channel. Write data to the channel in the units you select.

Valid values
DAQmx_Val_Amps | 10342 | Amperes.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.
DAQmx_Val_FromTEDS | 12516 | Units defined by TEDS information associated with the channel.

You can get/set/reset this property using:

DAQmxGetAOCurrentUnits

DAQmxSetAOCurrentUnits

DAQmxResetAOCurrentUnits


Digital Output >> Invert Lines

Data Type: | bool32
Description: | Specifies whether to invert the lines in the channel. If you set this property to TRUE, the lines are at high logic when off and at low logic when on.

You can get/set/reset this property using:

DAQmxGetDOInvertLines

DAQmxSetDOInvertLines

DAQmxResetDOInvertLines


Digital Output >> Output Drive Type

Data Type: | int32
Description: | Specifies the drive type for digital output channels.

Valid values
DAQmx_Val_ActiveDrive | 12573 | Drive the output pin to approximately 0 V for logic low and +3.3 V or +5 V, depending on the device, for logic high.
DAQmx_Val_OpenCollector | 12574 | Drive the output pin to 0 V for logic low. For logic high, the output driver assumes a high-impedance state and does not drive a voltage.

You can get/set/reset this property using:

DAQmxGetDOOutputDriveType

DAQmxSetDOOutputDriveType

DAQmxResetDOOutputDriveType


Counter Output >> Pulse >> Ticks >> High Ticks

Data Type: | uInt32
Description: | Specifies the number of ticks the pulse is high.

You can get/set/reset this property using:

DAQmxGetCOPulseHighTicks

DAQmxSetCOPulseHighTicks

DAQmxResetCOPulseHighTicks


Counter Output >> Pulse >> Idle State

Data Type: | int32
Description: | Specifies the resting state of the output terminal.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetCOPulseIdleState

DAQmxSetCOPulseIdleState

DAQmxResetCOPulseIdleState


Counter Output >> Pulse >> Ticks >> Low Ticks

Data Type: | uInt32
Description: | Specifies the number of ticks the pulse is low.

You can get/set/reset this property using:

DAQmxGetCOPulseLowTicks

DAQmxSetCOPulseLowTicks

DAQmxResetCOPulseLowTicks


Counter Output >> Pulse >> Frequency >> Duty Cycle

Data Type: | float64
Description: | Specifies the duty cycle of the pulses. The duty cycle of a signal is the width of the pulse divided by period. NI-DAQmx uses this ratio and the pulse frequency to determine the width of the pulses and the delay between pulses.

You can get/set/reset this property using:

DAQmxGetCOPulseDutyCyc

DAQmxSetCOPulseDutyCyc

DAQmxResetCOPulseDutyCyc


Counter Output >> Pulse >> Frequency >> Frequency

Data Type: | float64
Description: | Specifies the frequency of the pulses to generate. This value is in the units you specify with Units or when you create the channel.

You can get/set/reset this property using:

DAQmxGetCOPulseFreq

DAQmxSetCOPulseFreq

DAQmxResetCOPulseFreq


Analog Output >> Voltage >> Units

Data Type: | int32
Description: | Specifies in what units to generate voltage on the channel. Write data to the channel in the units you select.

Valid values
DAQmx_Val_Volts | 10348 | Volts.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAOVoltageUnits

DAQmxSetAOVoltageUnits

DAQmxResetAOVoltageUnits


Analog Output >> Maximum Value

Data Type: | float64
Description: | Specifies the maximum value you expect to generate. The value is in the units you specify with a units property. If you try to write a value larger than the maximum value, NI-DAQmx generates an error. NI-DAQmx might coerce this value to a smaller value if other task settings restrict the device from generating the desired maximum.

You can get/set/reset this property using:

DAQmxGetAOMax

DAQmxSetAOMax

DAQmxResetAOMax


Analog Output >> Minimum Value

Data Type: | float64
Description: | Specifies the minimum value you expect to generate. The value is in the units you specify with a units property. If you try to write a value smaller than the minimum value, NI-DAQmx generates an error. NI-DAQmx might coerce this value to a larger value if other task settings restrict the device from generating the desired minimum.

You can get/set/reset this property using:

DAQmxGetAOMin

DAQmxSetAOMin

DAQmxResetAOMin


Analog Output >> Custom Scale Name

Data Type: | char*
Description: | Specifies the name of a custom scale for the channel.

You can get/set/reset this property using:

DAQmxGetAOCustomScaleName

DAQmxSetAOCustomScaleName

DAQmxResetAOCustomScaleName


OverWrite Mode

Data Type: | int32
Description: | Specifies whether to overwrite samples in the buffer that you have not yet read.

Valid values
DAQmx_Val_OverwriteUnreadSamps | 10252 | When an acquisition encounters unread data in the buffer, the acquisition continues and overwrites the unread samples with new ones. You can read the new samples by setting RelativeTo to DAQmx_Val_MostRecentSamp and setting Offset to the appropriate number of samples.
DAQmx_Val_DoNotOverwriteUnreadSamps | 10159 | The acquisition stops when it encounters a sample in the buffer that you have not read.

You can get/set/reset this property using:

DAQmxGetReadOverWrite

DAQmxSetReadOverWrite

DAQmxResetReadOverWrite


Read All Available Samples

Data Type: | bool32
Description: | Specifies whether subsequent read operations read all samples currently available in the buffer or wait for the buffer to become full before reading. NI-DAQmx uses this setting for finite acquisitions and only when the number of samples to read is -1. For continuous acquisitions when the number of samples to read is -1, a read operation always reads all samples currently available in the buffer.

You can get/set/reset this property using:

DAQmxGetReadReadAllAvailSamp

DAQmxSetReadReadAllAvailSamp

DAQmxResetReadReadAllAvailSamp


Status >> Current Read Position

Data Type: | uInt64
Description: | Indicates in samples per channel the current position in the buffer.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadCurrReadPos


Status >> Available Samples Per Channel

Data Type: | uInt32
Description: | Indicates the number of samples available to read per channel. This value is the same for all channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadAvailSampPerChan


Description

Data Type: | char*
Description: | Specifies a description for the scale.

You can get/set this property using:

DAQmxGetScaleDescr

DAQmxSetScaleDescr


Linear >> Slope

Data Type: | float64
Description: | Specifies the slope, m, in the equation y=mx+b.

You can get/set this property using:

DAQmxGetScaleLinSlope

DAQmxSetScaleLinSlope


Linear >> Y-Intercept

Data Type: | float64
Description: | Specifies the y-intercept, b, in the equation y=mx+b.

You can get/set this property using:

DAQmxGetScaleLinYIntercept

DAQmxSetScaleLinYIntercept


Map >> Scaled Maximum Value

Data Type: | float64
Description: | Specifies the largest value in the range of scaled values. NI-DAQmx maps this value to Pre-Scaled Maximum Value. Reads coerce samples that are larger than this value to match this value. Writes generate errors for samples that are larger than this value.

You can get/set this property using:

DAQmxGetScaleMapScaledMax

DAQmxSetScaleMapScaledMax


Map >> Scaled Minimum Value

Data Type: | float64
Description: | Specifies the smallest value in the range of scaled values. NI-DAQmx maps this value to Pre-Scaled Minimum Value. Reads coerce samples that are smaller than this value to match this value. Writes generate errors for samples that are smaller than this value.

You can get/set this property using:

DAQmxGetScaleMapScaledMin

DAQmxSetScaleMapScaledMin


Map >> Pre-Scaled Maximum Value

Data Type: | float64
Description: | Specifies the largest value in the range of pre-scaled values. NI-DAQmx maps this value to Scaled Maximum Value.

You can get/set this property using:

DAQmxGetScaleMapPreScaledMax

DAQmxSetScaleMapPreScaledMax


Map >> Pre-Scaled Minimum Value

Data Type: | float64
Description: | Specifies the smallest value in the range of pre-scaled values. NI-DAQmx maps this value to Scaled Minimum Value.

You can get/set this property using:

DAQmxGetScaleMapPreScaledMin

DAQmxSetScaleMapPreScaledMin


Polynomial >> Forward Coefficients

Data Type: | float64*
Description: | Specifies an array of coefficients for the polynomial that converts pre-scaled values to scaled values. Each element of the array corresponds to a term of the equation. For example, if index three of the array is 9, the fourth term of the equation is 9x^3.

You can get/set this property using:

DAQmxGetScalePolyForwardCoeff

DAQmxSetScalePolyForwardCoeff


Polynomial >> Reverse Coefficients

Data Type: | float64*
Description: | Specifies an array of coefficients for the polynomial that converts scaled values to pre-scaled values. Each element of the array corresponds to a term of the equation. For example, if index three of the array is 9, the fourth term of the equation is 9y^3.

You can get/set this property using:

DAQmxGetScalePolyReverseCoeff

DAQmxSetScalePolyReverseCoeff


Table >> Scaled Values

Data Type: | float64*
Description: | Specifies an array of scaled values. These values map directly to the values in Pre-Scaled Values.

You can get/set this property using:

DAQmxGetScaleTableScaledVals

DAQmxSetScaleTableScaledVals


Table >> Pre-Scaled Values

Data Type: | float64*
Description: | Specifies an array of pre-scaled values. These values map directly to the values in Scaled Values.

You can get/set this property using:

DAQmxGetScaleTablePreScaledVals

DAQmxSetScaleTablePreScaledVals


Deprecated >> Is Settled

Data Type: | bool32
Description: | (Deprecated) Indicates when Settling Time expires.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSwitchDevSettled


Deprecated >> Settling Time

Data Type: | float64
Description: | (Deprecated) Specifies in seconds the amount of time to wait for the switch to settle (or debounce). NI-DAQmx adds this time to the settling time of the motherboard. Modify this property only if the switch does not settle within the settling time of the motherboard. Refer to device documentation for supported settling times.

You can get/set this property using:

DAQmxGetSwitchDevSettlingTime

DAQmxSetSwitchDevSettlingTime


Deprecated >> Break Mode

Data Type: | int32
Description: | (Deprecated) Specifies the action to take between each entry in a scan list.

Valid values
DAQmx_Val_NoAction | 10227 | When advancing to the next entry in the scan list, leave all previous connections intact.
DAQmx_Val_BreakBeforeMake | 10110 | When advancing to the next entry in the scan list, disconnect all previous connections before making any new connections.

You can get/set/reset this property using:

DAQmxGetSwitchScanBreakMode

DAQmxSetSwitchScanBreakMode

DAQmxResetSwitchScanBreakMode


Deprecated >> Repeat Mode

Data Type: | int32
Description: | (Deprecated) Specifies if the task advances through the scan list multiple times.

Valid values
DAQmx_Val_Finite | 10172 | The task advances through the scan list one time only. NI-DAQmx ignores any Advance Triggers after completing the scan list.
DAQmx_Val_Cont | 10117 | The task returns to the beginning of the scan list when it reaches the end of the scan list.

You can get/set/reset this property using:

DAQmxGetSwitchScanRepeatMode

DAQmxSetSwitchScanRepeatMode

DAQmxResetSwitchScanRepeatMode


Global Channels

Data Type: | char*
Description: | Indicates an array that contains the names of all global channels saved on the system.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysGlobalChans


Scales

Data Type: | char*
Description: | Indicates an array that contains the names of all custom scales saved on the system.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysScales


Tasks

Data Type: | char*
Description: | Indicates an array that contains the names of all tasks saved on the system.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysTasks


System >> NI-DAQ Version >> Major

Data Type: | uInt32
Description: | Indicates the major portion of the installed version of NI-DAQmx, such as 7 for version 7.0.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysNIDAQMajorVersion


Channels

Data Type: | char*
Description: | Indicates the names of all virtual channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskChannels


Task Done

Data Type: | bool32
Description: | Indicates whether the task completed execution.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskComplete


Name

Data Type: | char*
Description: | Indicates the name of the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskName


Sample Quantity >> Sample Mode

Data Type: | int32
Description: | Specifies if a task acquires or generates a finite number of samples or if it continuously acquires or generates samples. For an analog input task with a Reference Trigger, you must set this property to DAQmx_Val_FiniteSamps even though the task runs continuously until the Reference Trigger occurs.

Valid values
DAQmx_Val_FiniteSamps | 10178 | Acquire or generate a finite number of samples.
DAQmx_Val_ContSamps | 10123 | Acquire or generate samples until you stop the task.
DAQmx_Val_HWTimedSinglePoint | 12522 | Acquire or generate samples continuously using hardware timing without a buffer. Hardware timed single point sample mode is supported only for the sample clock and change detection timing types.

You can get/set/reset this property using:

DAQmxGetSampQuantSampMode

DAQmxSetSampQuantSampMode

DAQmxResetSampQuantSampMode


Sample Clock >> Active Edge

Data Type: | int32
Description: | Specifies on which edge of a clock pulse sampling takes place. This property is useful primarily when the signal you use as the Sample Clock is not a periodic clock.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetSampClkActiveEdge

DAQmxSetSampClkActiveEdge

DAQmxResetSampClkActiveEdge


Sample Clock >> Timebase >> Rate

Data Type: | float64
Description: | Specifies the rate of the Sample Clock Timebase. Some applications require that you specify a rate when you use any signal other than the onboard Sample Clock Timebase. NI-DAQmx requires this rate to calculate other timing parameters.

You can get/set/reset this property using:

DAQmxGetSampClkTimebaseRate

DAQmxSetSampClkTimebaseRate

DAQmxResetSampClkTimebaseRate


More >> AI Convert >> Delay From Sample Clock >> Delay Units

Data Type: int32
Description: Specifies the units of Delay.

NI-DAQmx uses the AI Convert Clock timebase to produce the delay.

If you set this property to DAQmx_Val_Ticks and N is the value of Delay, N pulses of the AI Convert Clock Timebase occur after receiving a Sample Clock pulse before the acquisition of the sample begins.

If you set this property to DAQmx_Val_Seconds, that number of seconds elapses after receiving a Sample Clock pulse before the acquisition of the sample begins.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_Ticks | 10304 | Timebase ticks.

You can get/set/reset this property using:

DAQmxGetDelayFromSampClkDelayUnits

DAQmxSetDelayFromSampClkDelayUnits

DAQmxResetDelayFromSampClkDelayUnits

DAQmxGetDelayFromSampClkDelayUnitsEx

DAQmxSetDelayFromSampClkDelayUnitsEx

DAQmxResetDelayFromSampClkDelayUnitsEx


Sample Clock >> Timebase >> Master Timebase Divisor

Data Type: uInt32
Description: Specifies the number of pulses of the Master Timebase needed to produce a single pulse of the Sample Clock Timebase.

The rate of the Sample Clock Timebase is equal to (frequency of Master Timebase) / (value of this property). The only valid values for this property are 1 and 200.

Setting this property has a similar effect to setting Rate. Use Rate when you know the rate of the Master Timebase and you want to produce a Sample Clock Timebase at the specified rate. Use this property when you have an external Master Timebase that you want to divide down and use as the Sample Clock Timebase, but you do not know rate of that external Master Timebase.

You can get/set/reset this property using:

DAQmxGetSampClkTimebaseMasterTimebaseDiv

DAQmxSetSampClkTimebaseMasterTimebaseDiv

DAQmxResetSampClkTimebaseMasterTimebaseDiv


Sample Clock >> Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the Sample Clock Timebase.

You can get/set/reset this property using:

DAQmxGetSampClkTimebaseSrc

DAQmxSetSampClkTimebaseSrc

DAQmxResetSampClkTimebaseSrc


Sample Quantity >> Samples Per Channel

Data Type: | uInt64
Description: | Specifies the number of samples to acquire or generate for each channel if Sample Mode is DAQmx_Val_FiniteSamps. If Sample Mode is DAQmx_Val_ContSamps, NI-DAQmx uses this value to determine the buffer size. To configure an analog output task to generate a finite number of cycles of a waveform, set this property to (desired number of cycles) * (number of samples per cycle). This property affects the buffer allocation for the task.

You can get/set/reset this property using:

DAQmxGetSampQuantSampPerChan

DAQmxSetSampQuantSampPerChan

DAQmxResetSampQuantSampPerChan


More >> Reference Clock >> Rate

Data Type: | float64
Description: | Specifies the frequency of the Reference Clock.

You can get/set/reset this property using:

DAQmxGetRefClkRate

DAQmxSetRefClkRate

DAQmxResetRefClkRate


More >> Reference Clock >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the Reference Clock.

You can get/set/reset this property using:

DAQmxGetRefClkSrc

DAQmxSetRefClkSrc

DAQmxResetRefClkSrc


More >> AI Convert >> Delay From Sample Clock >> Delay

Data Type: | float64
Description: | Specifies the amount of time to wait after receiving a Sample Clock edge before beginning to acquire the sample. This value is in the units you specify with Delay Units.

You can get/set/reset this property using:

DAQmxGetDelayFromSampClkDelay

DAQmxSetDelayFromSampClkDelay

DAQmxResetDelayFromSampClkDelay

DAQmxGetDelayFromSampClkDelayEx

DAQmxSetDelayFromSampClkDelayEx

DAQmxResetDelayFromSampClkDelayEx


More >> AI Convert >> Timebase Divisor

Data Type: | uInt32
Description: | Specifies the number of AI Convert Clock Timebase pulses needed to produce a single AI Convert Clock pulse.

You can get/set/reset this property using:

DAQmxGetAIConvTimebaseDiv

DAQmxSetAIConvTimebaseDiv

DAQmxResetAIConvTimebaseDiv

DAQmxGetAIConvTimebaseDivEx

DAQmxSetAIConvTimebaseDivEx

DAQmxResetAIConvTimebaseDivEx


More >> AI Convert >> Timebase >> Source

Data Type: | int32
Description: | Specifies the terminal of the signal to use as the AI Convert Clock Timebase.

Valid values
DAQmx_Val_SameAsSampTimebase | 10284 | Use the same source as Sample Clock timebase.
DAQmx_Val_SameAsMasterTimebase | 10282 | Use the same source as the Master Timebase.
DAQmx_Val_100MHzTimebase | 15857 | Use the onboard 100 MHz timebase.
DAQmx_Val_80MHzTimebase | 14636 | Use the onboard 80 MHz timebase.
DAQmx_Val_20MHzTimebase | 12537 | Use the onboard 20 MHz timebase.
DAQmx_Val_8MHzTimebase | 16023 | Use the onboard 8 MHz timebase.

You can get/set/reset this property using:

DAQmxGetAIConvTimebaseSrc

DAQmxSetAIConvTimebaseSrc

DAQmxResetAIConvTimebaseSrc

DAQmxGetAIConvTimebaseSrcEx

DAQmxSetAIConvTimebaseSrcEx

DAQmxResetAIConvTimebaseSrcEx


More >> Master Timebase >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the Master Timebase. On an E Series device, you can choose only between the onboard 20MHz Timebase or the RTSI7 terminal.

You can get/set/reset this property using:

DAQmxGetMasterTimebaseSrc

DAQmxSetMasterTimebaseSrc

DAQmxResetMasterTimebaseSrc


Sample Clock >> Rate

Data Type: | float64
Description: | Specifies the sampling rate in samples per channel per second. If you use an external source for the Sample Clock, set this input to the maximum expected rate of that clock.

You can get/set/reset this property using:

DAQmxGetSampClkRate

DAQmxSetSampClkRate

DAQmxResetSampClkRate


Sample Timing Type

Data Type: int32
Description: Specifies the type of sample timing to use for the task.

Select DAQmx_Val_SampClk when a hardware signal (usually a clock) must acquire or produce samples. To perform buffered edge counting, for example, select DAQmx_Val_SampClk and use Source to specify the source of the Sample clock.

Select DAQmx_Val_Handshake to use bidirectional hardware signals to time the exchange of digital data between two devices.

Select DAQmx_Val_BurstHandshake to run at a slower rate but with the capability for per sample evaluation of triggers and events to pause the operation.

Select DAQmx_Val_PipelinedSampClk on supported devices to run at the maximum sample rate with a few Sample clock cycles delay before the device can respond to triggers and events.

Select DAQmx_Val_OnDemand to acquire data only when an NI-DAQmx Read function executes or to generate data only when an NI-DAQmx Write function executes.

Select DAQmx_Val_Implicit to perform a buffered period or frequency counter measurement or to generate a finite pulse train.

Select DAQmx_Val_ChangeDetection to capture data only when certain digital lines change states and without continuously transferring unnecessary data during periods of inactivity.

Valid values
DAQmx_Val_SampClk | 10388 | Acquire or generate samples on the specified edge of the sample clock.
DAQmx_Val_BurstHandshake | 12548 | Determine sample timing using burst handshaking between the device and a peripheral device.
DAQmx_Val_Handshake | 10389 | Determine sample timing by using digital handshaking between the device and a peripheral device.
DAQmx_Val_Implicit | 10451 | Configure only the duration of the task.
DAQmx_Val_OnDemand | 10390 | Acquire or generate a sample on each read or write operation. This timing type is also referred to as static or software-timed.
DAQmx_Val_ChangeDetection | 12504 | Acquire samples when a change occurs in the state of one or more digital input lines. The lines must be contained within a digital input channel.
DAQmx_Val_PipelinedSampClk | 14668 | Device acquires or generates samples on each sample clock edge, but does not respond to certain triggers until a few sample clock edges later. Pipelining allows higher data transfer rates at the cost of increased trigger response latency. Refer to the device documentation for information about which triggers pipelining affects. This timing type allows handshaking with some devices using the Pause trigger, the Ready for Transfer event, or the Data Active event. Refer to the device documentation for more information.

You can get/set/reset this property using:

DAQmxGetSampTimingType

DAQmxSetSampTimingType

DAQmxResetSampTimingType


More >> Advance >> Digital Edge >> Edge

Data Type: | int32
Description: | Specifies on which edge of a digital signal to advance to the next entry in a scan list.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetDigEdgeAdvTrigEdge

DAQmxSetDigEdgeAdvTrigEdge

DAQmxResetDigEdgeAdvTrigEdge


More >> Advance >> Digital Edge >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where there is a digital signal to use as the source of the Advance Trigger.

You can get/set/reset this property using:

DAQmxGetDigEdgeAdvTrigSrc

DAQmxSetDigEdgeAdvTrigSrc

DAQmxResetDigEdgeAdvTrigSrc


More >> Advance >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to advance to the next entry in a switch scan list.

Valid values
DAQmx_Val_DigEdge | 10150 | Advance to the next entry in a scan list on the rising or falling edge of a digital signal.
DAQmx_Val_Software | 10292 | Advance to the next entry in a scan list when you call DAQmxSendSoftwareTrigger().
DAQmx_Val_None | 10230 | Advance through all entries in the scan list as fast as possible.

You can get/set/reset this property using:

DAQmxGetAdvTrigType

DAQmxSetAdvTrigType

DAQmxResetAdvTrigType


More >> Pause >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to pause a task.

Valid values
DAQmx_Val_AnlgLvl | 10101 | Pause the measurement or generation while an analog signal is above or below a level.
DAQmx_Val_AnlgWin | 10103 | Pause the measurement or generation while an analog signal is either inside or outside of a range of values.
DAQmx_Val_DigLvl | 10152 | Pause the measurement or generation while a digital signal is at either a high or low state.
DAQmx_Val_DigPattern | 10398 | Pause the measurement or generation while digital physical channels either match or do not match a digital pattern.
DAQmx_Val_None | 10230 | Do not pause the measurement or generation.

You can get/set/reset this property using:

DAQmxGetPauseTrigType

DAQmxSetPauseTrigType

DAQmxResetPauseTrigType


More >> Pause >> Analog Level >> Hysteresis

Data Type: | float64
Description: | Specifies a hysteresis level in the units of the measurement or generation. If Pause When is DAQmx_Val_AboveLvl, the trigger does not deassert until the source signal passes below Level minus the hysteresis. If Pause When is DAQmx_Val_BelowLvl, the trigger does not deassert until the source signal passes above Level plus the hysteresis. Hysteresis is always enabled. Set this property to a non-zero value to use hysteresis.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigHyst

DAQmxSetAnlgLvlPauseTrigHyst

DAQmxResetAnlgLvlPauseTrigHyst


More >> Pause >> Analog Level >> Level

Data Type: | float64
Description: | Specifies the threshold at which to pause the task. Specify this value in the units of the measurement or generation. Use Pause When to specify whether the task pauses above or below this threshold.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigLvl

DAQmxSetAnlgLvlPauseTrigLvl

DAQmxResetAnlgLvlPauseTrigLvl


More >> Pause >> Analog Level >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the trigger. For E Series devices, if you use a channel name, the channel must be the only channel in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigSrc

DAQmxSetAnlgLvlPauseTrigSrc

DAQmxResetAnlgLvlPauseTrigSrc


More >> Pause >> Analog Level >> Pause When

Data Type: | int32
Description: | Specifies whether the task pauses above or below the threshold you specify with Level.

Valid values
DAQmx_Val_AboveLvl | 10093 | Pause the measurement or generation while the signal is above the threshold.
DAQmx_Val_BelowLvl | 10107 | Pause the measurement or generation while the signal is below the threshold.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigWhen

DAQmxSetAnlgLvlPauseTrigWhen

DAQmxResetAnlgLvlPauseTrigWhen


More >> Pause >> Analog Window >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the trigger. For E Series devices, if you use a channel name, the channel must be the only channel in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigSrc

DAQmxSetAnlgWinPauseTrigSrc

DAQmxResetAnlgWinPauseTrigSrc


More >> Pause >> Analog Window >> Pause When

Data Type: | int32
Description: | Specifies whether the task pauses while the trigger signal is inside or outside the window you specify with Bottom and Top.

Valid values
DAQmx_Val_InsideWin | 10199 | Pause the measurement or generation while the trigger is inside the window.
DAQmx_Val_OutsideWin | 10251 | Pause the measurement or generation while the signal is outside the window.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigWhen

DAQmxSetAnlgWinPauseTrigWhen

DAQmxResetAnlgWinPauseTrigWhen


More >> Pause >> Analog Window >> Bottom

Data Type: | float64
Description: | Specifies the lower limit of the window. Specify this value in the units of the measurement or generation.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigBtm

DAQmxSetAnlgWinPauseTrigBtm

DAQmxResetAnlgWinPauseTrigBtm


More >> Pause >> Analog Window >> Top

Data Type: | float64
Description: | Specifies the upper limit of the window. Specify this value in the units of the measurement or generation.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigTop

DAQmxSetAnlgWinPauseTrigTop

DAQmxResetAnlgWinPauseTrigTop


More >> Pause >> Digital Level >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where there is a digital signal to use as the source of the Pause Trigger.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigSrc

DAQmxSetDigLvlPauseTrigSrc

DAQmxResetDigLvlPauseTrigSrc


More >> Pause >> Digital Level >> Pause When

Data Type: | int32
Description: | Specifies whether the task pauses while the signal is high or low.

Valid values
DAQmx_Val_High | 10192 | High state.
DAQmx_Val_Low | 10214 | Low state.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigWhen

DAQmxSetDigLvlPauseTrigWhen

DAQmxResetDigLvlPauseTrigWhen


Start >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to start a task.

Valid values
DAQmx_Val_AnlgEdge | 10099 | Trigger when an analog signal signal crosses a threshold.
DAQmx_Val_DigEdge | 10150 | Trigger on the rising or falling edge of a digital signal.
DAQmx_Val_DigPattern | 10398 | Trigger when digital physical channels match a digital pattern.
DAQmx_Val_AnlgWin | 10103 | Trigger when an analog signal enters or leaves a range of values. The range is in the units of the measurement.
DAQmx_Val_None | 10230 | Disable triggering for the task.

You can get/set/reset this property using:

DAQmxGetStartTrigType

DAQmxSetStartTrigType

DAQmxResetStartTrigType


Start >> Analog Edge >> Hysteresis

Data Type: | float64
Description: | Specifies a hysteresis level in the units of the measurement or generation. If Slope is DAQmx_Val_RisingSlope, the trigger does not deassert until the source signal passes below Level minus the hysteresis. If Slope is DAQmx_Val_FallingSlope, the trigger does not deassert until the source signal passes above Level plus the hysteresis. Hysteresis is always enabled. Set this property to a non-zero value to use hysteresis.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigHyst

DAQmxSetAnlgEdgeStartTrigHyst

DAQmxResetAnlgEdgeStartTrigHyst


Start >> Analog Edge >> Level

Data Type: | float64
Description: | Specifies at what threshold in the units of the measurement or generation to start acquiring or generating samples. Use Slope to specify on which slope to trigger on this threshold.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigLvl

DAQmxSetAnlgEdgeStartTrigLvl

DAQmxResetAnlgEdgeStartTrigLvl


Start >> Analog Edge >> Slope

Data Type: | int32
Description: | Specifies on which slope of the trigger signal to start acquiring or generating samples.

Valid values
DAQmx_Val_RisingSlope | 10280 | Trigger on the rising slope of the signal.
DAQmx_Val_FallingSlope | 10171 | Trigger on the falling slope of the signal.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigSlope

DAQmxSetAnlgEdgeStartTrigSlope

DAQmxResetAnlgEdgeStartTrigSlope


Start >> Analog Edge >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the Start Trigger. For E Series devices, if you use a channel name, the channel must be the first one in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigSrc

DAQmxSetAnlgEdgeStartTrigSrc

DAQmxResetAnlgEdgeStartTrigSrc


Start >> Analog Window >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the Start Trigger. For E Series devices, if you use a channel name, the channel must be the first one in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigSrc

DAQmxSetAnlgWinStartTrigSrc

DAQmxResetAnlgWinStartTrigSrc


Start >> Analog Window >> Trigger When

Data Type: | int32
Description: | Specifies whether the task starts acquiring or generating samples when the signal enters or leaves the window you specify with Bottom and Top.

Valid values
DAQmx_Val_EnteringWin | 10163 | Trigger when the signal enters the window.
DAQmx_Val_LeavingWin | 10208 | Trigger when the signal leaves the window.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigWhen

DAQmxSetAnlgWinStartTrigWhen

DAQmxResetAnlgWinStartTrigWhen


Start >> Analog Window >> Bottom

Data Type: | float64
Description: | Specifies the lower limit of the window. Specify this value in the units of the measurement or generation.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigBtm

DAQmxSetAnlgWinStartTrigBtm

DAQmxResetAnlgWinStartTrigBtm


Start >> Analog Window >> Top

Data Type: | float64
Description: | Specifies the upper limit of the window. Specify this value in the units of the measurement or generation.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigTop

DAQmxSetAnlgWinStartTrigTop

DAQmxResetAnlgWinStartTrigTop


Start >> Digital Edge >> Edge

Data Type: | int32
Description: | Specifies on which edge of a digital pulse to start acquiring or generating samples.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigEdge

DAQmxSetDigEdgeStartTrigEdge

DAQmxResetDigEdgeStartTrigEdge


Start >> Digital Edge >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where there is a digital signal to use as the source of the Start Trigger.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigSrc

DAQmxSetDigEdgeStartTrigSrc

DAQmxResetDigEdgeStartTrigSrc


Start >> Digital Pattern >> Source

Data Type: | char*
Description: | Specifies the physical channels to use for pattern matching. The order of the physical channels determines the order of the pattern. If a port is included, the order of the physical channels within the port is in ascending order.

You can get/set/reset this property using:

DAQmxGetDigPatternStartTrigSrc

DAQmxSetDigPatternStartTrigSrc

DAQmxResetDigPatternStartTrigSrc


Start >> Digital Pattern >> Trigger When

Data Type: | int32
Description: | Specifies whether the Start Trigger occurs when the physical channels specified with Source match or differ from the digital pattern specified with Pattern.

Valid values
DAQmx_Val_PatternMatches | 10254 | Trigger when the physical channels match the specified pattern.
DAQmx_Val_PatternDoesNotMatch | 10253 | Trigger when the physical channels do not match the specified pattern.

You can get/set/reset this property using:

DAQmxGetDigPatternStartTrigWhen

DAQmxSetDigPatternStartTrigWhen

DAQmxResetDigPatternStartTrigWhen


More >> Arm Start >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to arm the task for a Start Trigger. If you configure an Arm Start Trigger, the task does not respond to a Start Trigger until the device receives the Arm Start Trigger.

Valid values
DAQmx_Val_DigEdge | 10150 | Trigger on a rising or falling edge of a digital signal.
DAQmx_Val_None | 10230 | Disable the trigger.

You can get/set/reset this property using:

DAQmxGetArmStartTrigType

DAQmxSetArmStartTrigType

DAQmxResetArmStartTrigType


More >> Arm Start >> Digital Edge >> Edge

Data Type: | int32
Description: | Specifies on which edge of a digital signal to arm the task for a Start Trigger.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigEdge

DAQmxSetDigEdgeArmStartTrigEdge

DAQmxResetDigEdgeArmStartTrigEdge


More >> Arm Start >> Digital Edge >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where there is a digital signal to use as the source of the Arm Start Trigger.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigSrc

DAQmxSetDigEdgeArmStartTrigSrc

DAQmxResetDigEdgeArmStartTrigSrc


Reference >> Trigger Type

Data Type: | int32
Description: | Specifies the type of trigger to use to mark a reference point for the measurement.

Valid values
DAQmx_Val_AnlgEdge | 10099 | Trigger when an analog signal signal crosses a threshold.
DAQmx_Val_DigEdge | 10150 | Trigger on the rising or falling edge of a digital signal.
DAQmx_Val_DigPattern | 10398 | Trigger when digital physical channels match a digital pattern.
DAQmx_Val_AnlgWin | 10103 | Trigger when an analog signal enters or leaves a range of values. The range is in the units of the measurement.
DAQmx_Val_None | 10230 | Disable triggering for the task.

You can get/set/reset this property using:

DAQmxGetRefTrigType

DAQmxSetRefTrigType

DAQmxResetRefTrigType


Reference >> Analog Edge >> Hysteresis

Data Type: | float64
Description: | Specifies a hysteresis level in the units of the measurement. If Slope is DAQmx_Val_RisingSlope, the trigger does not deassert until the source signal passes below Level minus the hysteresis. If Slope is DAQmx_Val_FallingSlope, the trigger does not deassert until the source signal passes above Level plus the hysteresis. Hysteresis is always enabled. Set this property to a non-zero value to use hysteresis.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigHyst

DAQmxSetAnlgEdgeRefTrigHyst

DAQmxResetAnlgEdgeRefTrigHyst


Reference >> Analog Edge >> Level

Data Type: | float64
Description: | Specifies in the units of the measurement the threshold at which the Reference Trigger occurs. Use Slope to specify on which slope to trigger at this threshold.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigLvl

DAQmxSetAnlgEdgeRefTrigLvl

DAQmxResetAnlgEdgeRefTrigLvl


Reference >> Analog Edge >> Slope

Data Type: | int32
Description: | Specifies on which slope of the source signal the Reference Trigger occurs.

Valid values
DAQmx_Val_RisingSlope | 10280 | Trigger on the rising slope of the signal.
DAQmx_Val_FallingSlope | 10171 | Trigger on the falling slope of the signal.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigSlope

DAQmxSetAnlgEdgeRefTrigSlope

DAQmxResetAnlgEdgeRefTrigSlope


Reference >> Analog Edge >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the Reference Trigger. For E Series devices, if you use a channel name, the channel must be the only channel in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigSrc

DAQmxSetAnlgEdgeRefTrigSrc

DAQmxResetAnlgEdgeRefTrigSrc


Reference >> Analog Window >> Source

Data Type: | char*
Description: | Specifies the name of a virtual channel or terminal where there is an analog signal to use as the source of the Reference Trigger. For E Series devices, if you use a channel name, the channel must be the only channel in the task. The only terminal you can use for E Series devices is PFI0.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigSrc

DAQmxSetAnlgWinRefTrigSrc

DAQmxResetAnlgWinRefTrigSrc


Reference >> Analog Window >> Trigger When

Data Type: | int32
Description: | Specifies whether the Reference Trigger occurs when the source signal enters the window or when it leaves the window. Use Bottom and Top to specify the window.

Valid values
DAQmx_Val_EnteringWin | 10163 | Trigger when the signal enters the window.
DAQmx_Val_LeavingWin | 10208 | Trigger when the signal leaves the window.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigWhen

DAQmxSetAnlgWinRefTrigWhen

DAQmxResetAnlgWinRefTrigWhen


Reference >> Analog Window >> Bottom

Data Type: | float64
Description: | Specifies the lower limit of the window. Specify this value in the units of the measurement.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigBtm

DAQmxSetAnlgWinRefTrigBtm

DAQmxResetAnlgWinRefTrigBtm


Reference >> Analog Window >> Top

Data Type: | float64
Description: | Specifies the upper limit of the window. Specify this value in the units of the measurement.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigTop

DAQmxSetAnlgWinRefTrigTop

DAQmxResetAnlgWinRefTrigTop


Reference >> Digital Edge >> Edge

Data Type: | int32
Description: | Specifies on what edge of a digital pulse the Reference Trigger occurs.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigEdge

DAQmxSetDigEdgeRefTrigEdge

DAQmxResetDigEdgeRefTrigEdge


Reference >> Digital Edge >> Source

Data Type: | char*
Description: | Specifies the name of a terminal where there is a digital signal to use as the source of the Reference Trigger.

You can get/set/reset this property using:

DAQmxGetDigEdgeRefTrigSrc

DAQmxSetDigEdgeRefTrigSrc

DAQmxResetDigEdgeRefTrigSrc


Reference >> Digital Pattern >> Source

Data Type: | char*
Description: | Specifies the physical channels to use for pattern matching. The order of the physical channels determines the order of the pattern. If a port is included, the order of the physical channels within the port is in ascending order.

You can get/set/reset this property using:

DAQmxGetDigPatternRefTrigSrc

DAQmxSetDigPatternRefTrigSrc

DAQmxResetDigPatternRefTrigSrc


Reference >> Digital Pattern >> Trigger When

Data Type: | int32
Description: | Specifies whether the Reference Trigger occurs when the physical channels specified with Source match or differ from the digital pattern specified with Pattern.

Valid values
DAQmx_Val_PatternMatches | 10254 | Trigger when the physical channels match the specified pattern.
DAQmx_Val_PatternDoesNotMatch | 10253 | Trigger when the physical channels do not match the specified pattern.

You can get/set/reset this property using:

DAQmxGetDigPatternRefTrigWhen

DAQmxSetDigPatternRefTrigWhen

DAQmxResetDigPatternRefTrigWhen


Reference >> Pretrigger Samples per Channel

Data Type: | uInt32
Description: | Specifies the minimum number of pretrigger samples to acquire from each channel before recognizing the reference trigger. Post-trigger samples per channel are equal to Samples Per Channel minus the number of pretrigger samples per channel.

You can get/set/reset this property using:

DAQmxGetRefTrigPretrigSamples

DAQmxSetRefTrigPretrigSamples

DAQmxResetRefTrigPretrigSamples


Regeneration Mode

Data Type: | int32
Description: | Specifies whether to allow NI-DAQmx to generate the same data multiple times. If you enable regeneration and write new data to the buffer, NI-DAQmx can generate a combination of old and new data, a phenomenon called glitching.

Valid values
DAQmx_Val_AllowRegen | 10097 | Allow NI-DAQmx to regenerate samples that the device previously generated. When you choose this value, the write marker returns to the beginning of the buffer after the device generates all samples currently in the buffer.
DAQmx_Val_DoNotAllowRegen | 10158 | Do not allow NI-DAQmx to regenerate samples the device previously generated. When you choose this value, NI-DAQmx waits for you to write more samples to the buffer or until the timeout expires.

You can get/set/reset this property using:

DAQmxGetWriteRegenMode

DAQmxSetWriteRegenMode

DAQmxResetWriteRegenMode


Status >> Current Write Position

Data Type: | uInt64
Description: | Indicates the position in the buffer of the next sample to generate. This value is identical for all channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteCurrWritePos


Status >> Space Available in Buffer

Data Type: | uInt32
Description: | Indicates in samples per channel the amount of available space in the buffer.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteSpaceAvail


Reference >> More >> Delay

Data Type: | float64
Description: | Specifies in seconds the time to wait after the device receives the Reference Trigger before switching from pretrigger to posttrigger samples.

You can get/set/reset this property using:

DAQmxGetRefTrigDelay

DAQmxSetRefTrigDelay

DAQmxResetRefTrigDelay


Analog Output >> General Properties >> Output Configuration >> Output Impedance

Data Type: | float64
Description: | Specifies in ohms the impedance of the analog output stage of the device.

You can get/set/reset this property using:

DAQmxGetAOOutputImpedance

DAQmxSetAOOutputImpedance

DAQmxResetAOOutputImpedance


More >> Master Timebase >> Rate

Data Type: | float64
Description: | Specifies the rate of the Master Timebase. This property is useful only when the source of the Master Timebase is not the onboard 20 MHz timebase. NI-DAQmx requires the Master Timebase rate to calculate other timing parameters.

You can get/set/reset this property using:

DAQmxGetMasterTimebaseRate

DAQmxSetMasterTimebaseRate

DAQmxResetMasterTimebaseRate


More >> AI Convert >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the AI Convert Clock.

You can get/set/reset this property using:

DAQmxGetAIConvSrc

DAQmxSetAIConvSrc

DAQmxResetAIConvSrc

DAQmxGetAIConvSrcEx

DAQmxSetAIConvSrcEx

DAQmxResetAIConvSrcEx


Analog Input >> Sound Pressure >> Units

Data Type: | int32
Description: | Specifies the units to use to return sound pressure measurements from the channel.

Valid values
DAQmx_Val_Pascals | 10081 | Pascals.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAISoundPressureUnits

DAQmxSetAISoundPressureUnits

DAQmxResetAISoundPressureUnits


Analog Input >> Sound Pressure >> Microphone >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the microphone. This value is in mV/Pa. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIMicrophoneSensitivity

DAQmxSetAIMicrophoneSensitivity

DAQmxResetAIMicrophoneSensitivity


Events >> Ready For Start Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Ready for Start Event.

You can get/set/reset this property using:

DAQmxGetExportedRdyForStartEventOutputTerm

DAQmxSetExportedRdyForStartEventOutputTerm

DAQmxResetExportedRdyForStartEventOutputTerm


Triggers >> Pause Trigger >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Pause Trigger.

You can get/set/reset this property using:

DAQmxGetExportedPauseTrigOutputTerm

DAQmxSetExportedPauseTrigOutputTerm

DAQmxResetExportedPauseTrigOutputTerm


Triggers >> Pause Trigger >> Level >> Active Level

Data Type: | int32
Description: | Specifies the active level of the exported Pause Trigger.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedPauseTrigLvlActiveLvl

DAQmxSetExportedPauseTrigLvlActiveLvl

DAQmxResetExportedPauseTrigLvlActiveLvl


Events >> Data Active Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to export the Data Active Event.

You can get/set/reset this property using:

DAQmxGetExportedDataActiveEventOutputTerm

DAQmxSetExportedDataActiveEventOutputTerm

DAQmxResetExportedDataActiveEventOutputTerm


Events >> Data Active Event >> Level >> Active Level

Data Type: | int32
Description: | Specifies the polarity of the exported Data Active Event.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedDataActiveEventLvlActiveLvl

DAQmxSetExportedDataActiveEventLvlActiveLvl

DAQmxResetExportedDataActiveEventLvlActiveLvl


Triggers >> Advance Trigger >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Advance Trigger.

You can get/set/reset this property using:

DAQmxGetExportedAdvTrigOutputTerm

DAQmxSetExportedAdvTrigOutputTerm

DAQmxResetExportedAdvTrigOutputTerm


Triggers >> Advance Trigger >> Pulse >> Polarity

Data Type: | int32
Description: | Indicates the polarity of the exported Advance Trigger.
Restrictions: | Not Settable

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get this property using:

DAQmxGetExportedAdvTrigPulsePolarity


Triggers >> Advance Trigger >> Pulse >> Width Units

Data Type: | int32
Description: | Specifies the units of Width Value.

Valid values
DAQmx_Val_Seconds 10364 Seconds.

You can get/set/reset this property using:

DAQmxGetExportedAdvTrigPulseWidthUnits

DAQmxSetExportedAdvTrigPulseWidthUnits

DAQmxResetExportedAdvTrigPulseWidthUnits


Triggers >> Advance Trigger >> Pulse >> Width Value

Data Type: | float64
Description: | Specifies the width of an exported Advance Trigger pulse. Specify this value in the units you specify with Width Units.

You can get/set/reset this property using:

DAQmxGetExportedAdvTrigPulseWidth

DAQmxSetExportedAdvTrigPulseWidth

DAQmxResetExportedAdvTrigPulseWidth


Events >> Advance Complete Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Advance Complete Event.

You can get/set/reset this property using:

DAQmxGetExportedAdvCmpltEventOutputTerm

DAQmxSetExportedAdvCmpltEventOutputTerm

DAQmxResetExportedAdvCmpltEventOutputTerm


Events >> Advance Complete Event >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the exported Advance Complete Event.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedAdvCmpltEventPulsePolarity

DAQmxSetExportedAdvCmpltEventPulsePolarity

DAQmxResetExportedAdvCmpltEventPulsePolarity


Events >> Advance Complete Event >> Pulse >> Width Value

Data Type: | float64
Description: | Specifies the width of the exported Advance Complete Event pulse.

You can get/set/reset this property using:

DAQmxGetExportedAdvCmpltEventPulseWidth

DAQmxSetExportedAdvCmpltEventPulseWidth

DAQmxResetExportedAdvCmpltEventPulseWidth


Clocks >> 20MHz Timebase >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the 20MHz Timebase.

You can get/set/reset this property using:

DAQmxGetExported20MHzTimebaseOutputTerm

DAQmxSetExported20MHzTimebaseOutputTerm

DAQmxResetExported20MHzTimebaseOutputTerm


Clocks >> Sample Clock >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Sample Clock.

You can get/set/reset this property using:

DAQmxGetExportedSampClkOutputTerm

DAQmxSetExportedSampClkOutputTerm

DAQmxResetExportedSampClkOutputTerm


Clocks >> Sample Clock >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the exported Sample Clock if Output Behavior is DAQmx_Val_Pulse.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedSampClkPulsePolarity

DAQmxSetExportedSampClkPulsePolarity

DAQmxResetExportedSampClkPulsePolarity


Clocks >> AI Convert Clock >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the AI Convert Clock.

You can get/set/reset this property using:

DAQmxGetExportedAIConvClkOutputTerm

DAQmxSetExportedAIConvClkOutputTerm

DAQmxResetExportedAIConvClkOutputTerm


Clocks >> AI Convert Clock >> Pulse >> Polarity

Data Type: | int32
Description: | Indicates the polarity of the exported AI Convert Clock. The polarity is fixed and independent of the active edge of the source of the AI Convert Clock.
Restrictions: | Not Settable

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get this property using:

DAQmxGetExportedAIConvClkPulsePolarity


Events >> Counter Output Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Counter Output Event.

You can get/set/reset this property using:

DAQmxGetExportedCtrOutEventOutputTerm

DAQmxSetExportedCtrOutEventOutputTerm

DAQmxResetExportedCtrOutEventOutputTerm


Events >> Counter Output Event >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of the pulses at the output terminal of the counter when Output Behavior is DAQmx_Val_Pulse. NI-DAQmx ignores this property if Output Behavior is DAQmx_Val_Toggle.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedCtrOutEventPulsePolarity

DAQmxSetExportedCtrOutEventPulsePolarity

DAQmxResetExportedCtrOutEventPulsePolarity


Events >> Ready For Start Event >> Level >> Active Level

Data Type: | int32
Description: | Specifies the polarity of the exported Ready for Start Event.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedRdyForStartEventLvlActiveLvl

DAQmxSetExportedRdyForStartEventLvlActiveLvl

DAQmxResetExportedRdyForStartEventLvlActiveLvl


Events >> Advance Complete Event >> Delay Value

Data Type: | float64
Description: | Specifies the output signal delay in periods of the sample clock.

You can get/set/reset this property using:

DAQmxGetExportedAdvCmpltEventDelay

DAQmxSetExportedAdvCmpltEventDelay

DAQmxResetExportedAdvCmpltEventDelay


Analog Input >> General Properties >> Advanced >> High Accuracy Settings >> Auto Zero Mode

Data Type: | int32
Description: | Specifies how often to measure ground. NI-DAQmx subtracts the measured ground voltage from every sample.

Valid values
DAQmx_Val_None | 10230 | Do not perform an autozero.
DAQmx_Val_Once | 10244 | Perform an auto zero at the beginning of the acquisition. This auto zero task might not run if you have used DAQmxTaskControl() previously in your task.
DAQmx_Val_EverySample | 10164 | Perform an auto zero at every sample of the acquisition.

You can get/set/reset this property using:

DAQmxGetAIAutoZeroMode

DAQmxSetAIAutoZeroMode

DAQmxResetAIAutoZeroMode


Analog Input >> General Properties >> Digitizer/ADC >> Resolution Units

Data Type: | int32
Description: | Indicates the units of Resolution Value.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bits 10109 Bits.

You can get this property using:

DAQmxGetAIResolutionUnits


Analog Input >> General Properties >> Digitizer/ADC >> Resolution Value

Data Type: | float64
Description: | Indicates the resolution of the analog-to-digital converter of the channel. This value is in the units you specify with Resolution Units.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIResolution


Analog Input >> General Properties >> Signal Conditioning >> Attenuation

Data Type: | float64
Description: | Specifies the amount of attenuation to use.

You can get/set/reset this property using:

DAQmxGetAIAtten

DAQmxSetAIAtten

DAQmxResetAIAtten


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Enable

Data Type: | bool32
Description: | Specifies whether to enable the lowpass filter of the channel.

You can get/set/reset this property using:

DAQmxGetAILowpassEnable

DAQmxSetAILowpassEnable

DAQmxResetAILowpassEnable


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Cutoff Frequency

Data Type: | float64
Description: | Specifies the frequency in Hertz that corresponds to the -3dB cutoff of the filter.

You can get/set/reset this property using:

DAQmxGetAILowpassCutoffFreq

DAQmxSetAILowpassCutoffFreq

DAQmxResetAILowpassCutoffFreq


Analog Input >> General Properties >> Advanced >> Range >> High

Data Type: | float64
Description: | Specifies the upper limit of the input range of the device. This value is in the native units of the device. On E Series devices, for example, the native units is volts.

You can get/set/reset this property using:

DAQmxGetAIRngHigh

DAQmxSetAIRngHigh

DAQmxResetAIRngHigh


Analog Input >> General Properties >> Advanced >> Range >> Low

Data Type: | float64
Description: | Specifies the lower limit of the input range of the device. This value is in the native units of the device. On E Series devices, for example, the native units is volts.

You can get/set/reset this property using:

DAQmxGetAIRngLow

DAQmxSetAIRngLow

DAQmxResetAIRngLow


Analog Input >> General Properties >> Advanced >> Gain

Data Type: | float64
Description: | Specifies a gain factor to apply to the channel.

You can get/set/reset this property using:

DAQmxGetAIGain

DAQmxSetAIGain

DAQmxResetAIGain


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the device.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetAIDataXferMech

DAQmxSetAIDataXferMech

DAQmxResetAIDataXferMech


Channels to Read

Data Type: | char*
Description: | Specifies a subset of channels in the task from which to read.

You can get/set/reset this property using:

DAQmxGetReadChannelsToRead

DAQmxSetReadChannelsToRead

DAQmxResetReadChannelsToRead


Auto Start

Data Type: | bool32
Description: | Specifies if an NI-DAQmx Read function automatically starts the task if you did not start the task explicitly by using DAQmxStartTask(). The default value is TRUE. When an NI-DAQmx Read function starts a finite acquisition task, it also stops the task after reading the last sample.

You can get/set/reset this property using:

DAQmxGetReadAutoStart

DAQmxSetReadAutoStart

DAQmxResetReadAutoStart


Analog Output >> General Properties >> DAC >> Reference Voltage >> Allow Connecting DAC Reference to Ground at Runtime

Data Type: | bool32
Description: | Specifies whether to allow grounding the internal DAC reference at run time. You must set this property to TRUE and set Source to DAQmx_Val_Internal before you can set Connect DAC Reference to Ground to TRUE.

You can get/set/reset this property using:

DAQmxGetAODACRefAllowConnToGnd

DAQmxSetAODACRefAllowConnToGnd

DAQmxResetAODACRefAllowConnToGnd


Analog Output >> General Properties >> DAC >> Reference Voltage >> Value

Data Type: | float64
Description: | Specifies in volts the value of the DAC reference voltage. This voltage determines the full-scale range of the DAC. Smaller reference voltages result in smaller ranges, but increased resolution.

You can get/set/reset this property using:

DAQmxGetAODACRefVal

DAQmxSetAODACRefVal

DAQmxResetAODACRefVal


More >> AI Convert >> Rate

Data Type: float64
Description: Specifies in Hertz the rate at which to clock the analog-to-digital converter. This clock is specific to the analog input section of multiplexed devices.

By default, NI-DAQmx selects the maximum convert rate supported by the device, plus up to 10 microseconds per channel settling time. Other task settings, such as high channel counts or setting Delay, can result in a faster default convert rate.

CompactDAQ applies up to 10 microseconds of settling time for all C Series devices even if the maximum convert rates of the devices differ.

If you connect signal conditioning accessories with track and hold capabilities, such as an SCXI module, to the device, NI-DAQmx uses the fastest convert rate possible that meets the settling requirements for the slowest module sampled. Refer to the device documentation for the signal conditioning accessory for more information.

You can get/set/reset this property using:

DAQmxGetAIConvRate

DAQmxSetAIConvRate

DAQmxResetAIConvRate

DAQmxGetAIConvRateEx

DAQmxSetAIConvRateEx

DAQmxResetAIConvRateEx


Sample Clock >> Source

Data Type: | char*
Description: | Specifies the terminal of the signal to use as the Sample Clock.

You can get/set/reset this property using:

DAQmxGetSampClkSrc

DAQmxSetSampClkSrc

DAQmxResetSampClkSrc


More >> AI Convert >> Active Edge

Data Type: | int32
Description: | Specifies on which edge of the clock pulse an analog-to-digital conversion takes place. This property is useful primarily when the signal you use as the AI Convert Clock is not a periodic clock. For example, set this property to DAQmx_Val_Rising to perform an analog to digital conversion on each rising edge of an aperiodic signal.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetAIConvActiveEdge

DAQmxSetAIConvActiveEdge

DAQmxResetAIConvActiveEdge

DAQmxGetAIConvActiveEdgeEx

DAQmxSetAIConvActiveEdgeEx

DAQmxResetAIConvActiveEdgeEx


Start >> More >> Delay

Data Type: | float64
Description: | Specifies an amount of time to wait after the Start Trigger is received before acquiring or generating the first sample. This value is in the units you specify with Delay Units.

You can get/set/reset this property using:

DAQmxGetStartTrigDelay

DAQmxSetStartTrigDelay

DAQmxResetStartTrigDelay


Reference >> Analog Window >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the trigger if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgWinRefTrigCoupling

DAQmxSetAnlgWinRefTrigCoupling

DAQmxResetAnlgWinRefTrigCoupling


Self Calibration >> Is Supported

Data Type: | bool32
Description: | Indicates whether the device supports self-calibration.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSelfCalSupported


User-Defined Information >> Information

Data Type: | char*
Description: | Specifies a string that contains arbitrary, user-defined information. This number of characters in this string can be no more than Max Size.

You can get/set this property using:

DAQmxGetCalUserDefinedInfo

DAQmxSetCalUserDefinedInfo


Self Calibration >> Last Self Calibration Temperature

Data Type: float64
Description: Indicates in degrees Celsius the temperature of the device at the time of the last self-calibration. Compare this temperature to the current onboard temperature to determine if you should perform another calibration.

The temperature returned by this property is the calibration temperature as measured by an onboard temperature sensor and may differ from the temperature displayed on a printed calibration certificate. Calibration certificates usually display the ambient temperature rather than the onboard temperature.

Using Traditional NI-DAQ (Legacy) to perform calibration does not update this property. This property is updated only when you use NI-DAQmx to perform calibration.

Restrictions: Not Settable

You can get this property using:

DAQmxGetSelfCalLastTemp


External Calibration >> Last External Calibration Temperature

Data Type: float64
Description: Indicates in degrees Celsius the temperature of the device at the time of the last external calibration. Compare this temperature to the current onboard temperature to determine if you should perform another calibration.

The temperature returned by this property is the calibration temperature as measured by an onboard temperature sensor and may differ from the temperature displayed on a printed calibration certificate. Calibration certificates usually display the ambient temperature rather than the onboard temperature.

Using Traditional NI-DAQ (Legacy) to perform calibration does not update this property. This property is updated only when you use NI-DAQmx to perform calibration.

Restrictions: Not Settable

You can get this property using:

DAQmxGetExtCalLastTemp


External Calibration >> Recommended Interval

Data Type: | uInt32
Description: | Indicates in months the National Instruments recommended interval between each external calibration of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetExtCalRecommendedInterval


Analog Input >> General Properties >> Signal Conditioning >> Resistance Configuration

Data Type: | int32
Description: | Specifies the resistance configuration for the channel. NI-DAQmx uses this value for any resistance-based measurements, including temperature measurement using a thermistor or RTD.

Valid values
DAQmx_Val_2Wire | 2 | 2-wire mode.
DAQmx_Val_3Wire | 3 | 3-wire mode.
DAQmx_Val_4Wire | 4 | 4-wire mode.

You can get/set/reset this property using:

DAQmxGetAIResistanceCfg

DAQmxSetAIResistanceCfg

DAQmxResetAIResistanceCfg


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Actual Excitation Value

Data Type: | float64
Description: | Specifies the actual amount of excitation supplied by an internal excitation source. If you read an internal excitation source more precisely with an external device, set this property to the value you read. NI-DAQmx ignores this value for external excitation. When performing shunt calibration, some devices set this property automatically.

You can get/set/reset this property using:

DAQmxGetAIExcitActualVal

DAQmxSetAIExcitActualVal

DAQmxResetAIExcitActualVal


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Clock Source

Data Type: | int32
Description: | Specifies the source of the filter clock. If you need a higher resolution for the filter, you can supply an external clock to increase the resolution. Refer to the SCXI-1141/1142/1143 User Manual for more information.

Valid values
DAQmx_Val_Internal | 10200 | Internal to the device.
DAQmx_Val_External | 10167 | External to the device.

You can get/set/reset this property using:

DAQmxGetAILowpassSwitchCapClkSrc

DAQmxSetAILowpassSwitchCapClkSrc

DAQmxResetAILowpassSwitchCapClkSrc


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Frequency

Data Type: | float64
Description: | Specifies the frequency of the external clock when you set Clock Source to DAQmx_Val_External. NI-DAQmx uses this frequency to set the pre- and post- filters on the SCXI-1141, SCXI-1142, and SCXI-1143. On those devices, NI-DAQmx determines the filter cutoff by using the equation f/(100*n), where f is the external frequency, and n is the external clock divisor. Refer to the SCXI-1141/1142/1143 User Manual for more information.

You can get/set/reset this property using:

DAQmxGetAILowpassSwitchCapExtClkFreq

DAQmxSetAILowpassSwitchCapExtClkFreq

DAQmxResetAILowpassSwitchCapExtClkFreq


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Divisor

Data Type: | uInt32
Description: | Specifies the divisor for the external clock when you set Clock Source to DAQmx_Val_External. On the SCXI-1141, SCXI-1142, and SCXI-1143, NI-DAQmx determines the filter cutoff by using the equation f/(100*n), where f is the external frequency, and n is the external clock divisor. Refer to the SCXI-1141/1142/1143 User Manual for more information.

You can get/set/reset this property using:

DAQmxGetAILowpassSwitchCapExtClkDiv

DAQmxSetAILowpassSwitchCapExtClkDiv

DAQmxResetAILowpassSwitchCapExtClkDiv


Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Output Clock Divisor

Data Type: | uInt32
Description: | Specifies the divisor for the output clock. NI-DAQmx uses the cutoff frequency to determine the output clock frequency. Refer to the SCXI-1141/1142/1143 User Manual for more information.

You can get/set/reset this property using:

DAQmxGetAILowpassSwitchCapOutClkDiv

DAQmxSetAILowpassSwitchCapOutClkDiv

DAQmxResetAILowpassSwitchCapOutClkDiv


Digital Input >> Tristate

Data Type: | bool32
Description: | Specifies whether to tristate the lines in the channel. If you set this property to TRUE, NI-DAQmx tristates the lines in the channel. If you set this property to FALSE, NI-DAQmx does not modify the configuration of the lines even if the lines were previously tristated. Set this property to FALSE to read lines in other tasks or to read output-only lines.

You can get/set/reset this property using:

DAQmxGetDITristate

DAQmxSetDITristate

DAQmxResetDITristate


System >> NI-DAQ Version >> Minor

Data Type: | uInt32
Description: | Indicates the minor portion of the installed version of NI-DAQmx, such as 0 for version 7.0.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetSysNIDAQMinorVersion


General Properties >> Description

Data Type: | char*
Description: | Specifies a user-defined description for the channel.

You can get/set/reset this property using:

DAQmxGetChanDescr

DAQmxSetChanDescr

DAQmxResetChanDescr


Scale Type

Data Type: | int32
Description: | Indicates the method or equation form that the custom scale uses.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Linear | 10447 | Scale values by using the equation y=mx+b, where x is a prescaled value and y is a scaled value.
DAQmx_Val_MapRanges | 10448 | Scale values proportionally from a range of pre-scaled values to a range of scaled values.
DAQmx_Val_Polynomial | 10449 | Scale values by using an Nth order polynomial equation.
DAQmx_Val_Table | 10450 | Map an array of pre-scaled values to an array of corresponding scaled values, with all other values scaled proportionally.

You can get this property using:

DAQmxGetScaleType


Analog Input >> General Properties >> Advanced >> Device Scaling Coefficients >> Device Scaling Coefficients

Data Type: | float64*
Description: | Indicates the coefficients of a polynomial equation that NI-DAQmx uses to scale values from the native format of the device to volts. Each element of the array corresponds to a term of the equation. For example, if index two of the array is 4, the third term of the equation is 4x^2. Scaling coefficients do not account for any custom scales or sensors contained by the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIDevScalingCoeff


Analog Output >> General Properties >> Advanced >> Device Scaling Coefficients >> Device Scaling Coefficients

Data Type: | float64*
Description: | Indicates the coefficients of a linear equation that NI-DAQmx uses to scale values from a voltage to the native format of the device. Each element of the array corresponds to a term of the equation. The first element of the array corresponds to the y-intercept, and the second element corresponds to the slope. Scaling coefficients do not account for any custom scales that may be applied to the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAODevScalingCoeff


More >> Pause >> Digital Pattern >> Pause When

Data Type: | int32
Description: | Specifies if the Pause Trigger occurs when the physical channels specified with Source match or differ from the digital pattern specified with Pattern.

Valid values
DAQmx_Val_PatternMatches | 10254 | Trigger when the physical channels match the specified pattern.
DAQmx_Val_PatternDoesNotMatch | 10253 | Trigger when the physical channels do not match the specified pattern.

You can get/set/reset this property using:

DAQmxGetDigPatternPauseTrigWhen

DAQmxSetDigPatternPauseTrigWhen

DAQmxResetDigPatternPauseTrigWhen


Status >> Overload >> Overloaded Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overload in any virtual channel in the task. Reading this property clears the overload status for all channels in the task. You must read this property before you read Overloaded Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOverloadedChansExist


Status >> Overload >> Overloaded Channels

Data Type: | char*
Description: | Indicates a list of names of any overloaded virtual channels in the task. You must read Overloaded Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOverloadedChans


Digital Input >> Number of Lines

Data Type: | uInt32
Description: | Indicates the number of digital lines in the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDINumLines


Digital Output >> Number of Lines

Data Type: | uInt32
Description: | Indicates the number of digital lines in the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDONumLines


Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Multiplexed Excitation

Data Type: | bool32
Description: | Specifies if the SCXI-1122 multiplexes the excitation to the upper half of the channels as it advances through the scan list.

You can get/set/reset this property using:

DAQmxGetAIExcitUseMultiplexed

DAQmxSetAIExcitUseMultiplexed

DAQmxResetAIExcitUseMultiplexed


Number of Channels

Data Type: | uInt32
Description: | Indicates the number of virtual channels in the task.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetTaskNumChans


Start >> Digital Pattern >> Pattern

Data Type: | char*
Description: | Specifies the digital pattern that must be met for the Start Trigger to occur.

You can get/set/reset this property using:

DAQmxGetDigPatternStartTrigPattern

DAQmxSetDigPatternStartTrigPattern

DAQmxResetDigPatternStartTrigPattern


Reference >> Digital Pattern >> Pattern

Data Type: | char*
Description: | Specifies the digital pattern that must be met for the Reference Trigger to occur.

You can get/set/reset this property using:

DAQmxGetDigPatternRefTrigPattern

DAQmxSetDigPatternRefTrigPattern

DAQmxResetDigPatternRefTrigPattern


More >> Pause >> Digital Pattern >> Pattern

Data Type: | char*
Description: | Specifies the digital pattern that must be met for the Pause Trigger to occur.

You can get/set/reset this property using:

DAQmxGetDigPatternPauseTrigPattern

DAQmxSetDigPatternPauseTrigPattern

DAQmxResetDigPatternPauseTrigPattern


Status >> Advanced >> ChangeDetection >> Overflowed

Data Type: | bool32
Description: | Indicates if samples were missed because change detection events occurred faster than the device could handle them. Some devices detect overflows differently than others.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadChangeDetectHasOverflowed


Change Detection >> Digital Input >> Rising Edge Physical Channels

Data Type: | char*
Description: | Specifies the names of the digital lines or ports on which to detect rising edges. The lines or ports must be used by virtual channels in the task. You also can specify a string that contains a list or range of digital lines or ports.

You can get/set/reset this property using:

DAQmxGetChangeDetectDIRisingEdgePhysicalChans

DAQmxSetChangeDetectDIRisingEdgePhysicalChans

DAQmxResetChangeDetectDIRisingEdgePhysicalChans


Change Detection >> Digital Input >> Falling Edge Physical Channels

Data Type: | char*
Description: | Specifies the names of the digital lines or ports on which to detect falling edges. The lines or ports must be used by virtual channels in the task. You also can specify a string that contains a list or range of digital lines or ports.

You can get/set/reset this property using:

DAQmxGetChangeDetectDIFallingEdgePhysicalChans

DAQmxSetChangeDetectDIFallingEdgePhysicalChans

DAQmxResetChangeDetectDIFallingEdgePhysicalChans


Events >> Change Detection Event >> Output Terminal

Data Type: | char*
Description: | Specifies the terminal to which to route the Change Detection Event.

You can get/set/reset this property using:

DAQmxGetExportedChangeDetectEventOutputTerm

DAQmxSetExportedChangeDetectEventOutputTerm

DAQmxResetExportedChangeDetectEventOutputTerm


Analog Input >> General Properties >> Input Configuration >> Input Source

Data Type: | char*
Description: | Specifies the source of the channel. You can use the signal from the I/O connector or one of several calibration signals. Certain devices have a single calibration signal bus. For these devices, you must specify the same calibration signal for all channels you connect to a calibration signal.

You can get/set/reset this property using:

DAQmxGetAIInputSrc

DAQmxSetAIInputSrc

DAQmxResetAIInputSrc


Counter Input >> Position >> B Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputDigFltrEnable

DAQmxSetCIEncoderBInputDigFltrEnable

DAQmxResetCIEncoderBInputDigFltrEnable


Counter Input >> Position >> B Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputDigFltrMinPulseWidth

DAQmxSetCIEncoderBInputDigFltrMinPulseWidth

DAQmxResetCIEncoderBInputDigFltrMinPulseWidth


Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputDigFltrTimebaseSrc

DAQmxSetCIEncoderBInputDigFltrTimebaseSrc

DAQmxResetCIEncoderBInputDigFltrTimebaseSrc


Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputDigFltrTimebaseRate

DAQmxSetCIEncoderBInputDigFltrTimebaseRate

DAQmxResetCIEncoderBInputDigFltrTimebaseRate


Counter Input >> Position >> B Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIEncoderBInputDigSyncEnable

DAQmxSetCIEncoderBInputDigSyncEnable

DAQmxResetCIEncoderBInputDigSyncEnable


Counter Input >> Position >> Z Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputDigFltrEnable

DAQmxSetCIEncoderZInputDigFltrEnable

DAQmxResetCIEncoderZInputDigFltrEnable


Counter Input >> Position >> Z Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputDigFltrMinPulseWidth

DAQmxSetCIEncoderZInputDigFltrMinPulseWidth

DAQmxResetCIEncoderZInputDigFltrMinPulseWidth


Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputDigFltrTimebaseSrc

DAQmxSetCIEncoderZInputDigFltrTimebaseSrc

DAQmxResetCIEncoderZInputDigFltrTimebaseSrc


Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputDigFltrTimebaseRate

DAQmxSetCIEncoderZInputDigFltrTimebaseRate

DAQmxResetCIEncoderZInputDigFltrTimebaseRate


Counter Input >> Position >> Z Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCIEncoderZInputDigSyncEnable

DAQmxSetCIEncoderZInputDigSyncEnable

DAQmxResetCIEncoderZInputDigSyncEnable


Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstDigFltrMinPulseWidth

DAQmxSetCITwoEdgeSepFirstDigFltrMinPulseWidth

DAQmxResetCITwoEdgeSepFirstDigFltrMinPulseWidth


Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseSrc

DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseSrc

DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseSrc


Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseRate

DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseRate

DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseRate


Counter Input >> Two Edge Separation >> First >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepFirstDigSyncEnable

DAQmxSetCITwoEdgeSepFirstDigSyncEnable

DAQmxResetCITwoEdgeSepFirstDigSyncEnable


Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondDigFltrEnable

DAQmxSetCITwoEdgeSepSecondDigFltrEnable

DAQmxResetCITwoEdgeSepSecondDigFltrEnable


Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondDigFltrMinPulseWidth

DAQmxSetCITwoEdgeSepSecondDigFltrMinPulseWidth

DAQmxResetCITwoEdgeSepSecondDigFltrMinPulseWidth


Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseSrc

DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseSrc

DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseSrc


Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseRate

DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseRate

DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseRate


Counter Input >> Two Edge Separation >> Second >> Input >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCITwoEdgeSepSecondDigSyncEnable

DAQmxSetCITwoEdgeSepSecondDigSyncEnable

DAQmxResetCITwoEdgeSepSecondDigSyncEnable


Counter Input >> Semi-Period >> Input >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCISemiPeriodDigFltrEnable

DAQmxSetCISemiPeriodDigFltrEnable

DAQmxResetCISemiPeriodDigFltrEnable


Sample Clock >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetSampClkDigFltrTimebaseSrc

DAQmxSetSampClkDigFltrTimebaseSrc

DAQmxResetSampClkDigFltrTimebaseSrc


Sample Clock >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetSampClkDigFltrTimebaseRate

DAQmxSetSampClkDigFltrTimebaseRate

DAQmxResetSampClkDigFltrTimebaseRate


Sample Clock >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetSampClkDigSyncEnable

DAQmxSetSampClkDigSyncEnable

DAQmxResetSampClkDigSyncEnable


Start >> Digital Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the trigger signal.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigDigFltrEnable

DAQmxSetDigEdgeStartTrigDigFltrEnable

DAQmxResetDigEdgeStartTrigDigFltrEnable


Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigDigFltrMinPulseWidth

DAQmxSetDigEdgeStartTrigDigFltrMinPulseWidth

DAQmxResetDigEdgeStartTrigDigFltrMinPulseWidth


Start >> Digital Edge >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigDigFltrTimebaseSrc

DAQmxSetDigEdgeStartTrigDigFltrTimebaseSrc

DAQmxResetDigEdgeStartTrigDigFltrTimebaseSrc


Start >> Digital Edge >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigDigFltrTimebaseRate

DAQmxSetDigEdgeStartTrigDigFltrTimebaseRate

DAQmxResetDigEdgeStartTrigDigFltrTimebaseRate


Start >> Digital Edge >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. If you set this property to TRUE, the device does not recognize and act upon the trigger until the next pulse of the internal timebase. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetDigEdgeStartTrigDigSyncEnable

DAQmxSetDigEdgeStartTrigDigSyncEnable

DAQmxResetDigEdgeStartTrigDigSyncEnable


More >> Pause >> Digital Level >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply a digital filter to the trigger signal.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigDigFltrEnable

DAQmxSetDigLvlPauseTrigDigFltrEnable

DAQmxResetDigLvlPauseTrigDigFltrEnable


More >> Pause >> Digital Level >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetDigLvlPauseTrigDigFltrMinPulseWidth

DAQmxSetDigLvlPauseTrigDigFltrMinPulseWidth

DAQmxResetDigLvlPauseTrigDigFltrMinPulseWidth


More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseRate

DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseRate

DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseRate


More >> Arm Start >> Digital Edge >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetDigEdgeArmStartTrigDigSyncEnable

DAQmxSetDigEdgeArmStartTrigDigSyncEnable

DAQmxResetDigEdgeArmStartTrigDigSyncEnable


Advanced >> Wait Mode

Data Type: | int32
Description: | Specifies how an NI-DAQmx Read function waits for samples to become available.

Valid values
DAQmx_Val_WaitForInterrupt | 12523 | Check for available samples when the system receives an interrupt service request. This mode is the most CPU efficient, but results in lower possible sampling rates.
DAQmx_Val_Poll | 12524 | Repeatedly check for available samples as fast as possible. This mode allows for the highest sampling rates at the expense of CPU efficiency.
DAQmx_Val_Yield | 12525 | Repeatedly check for available samples, but yield control to other threads after each check. This mode offers a balance between sampling rate and CPU efficiency.
DAQmx_Val_Sleep | 12547 | Check for available samples once per the amount of time specified in Sleep Time.

You can get/set/reset this property using:

DAQmxGetReadWaitMode

DAQmxSetReadWaitMode

DAQmxResetReadWaitMode


Start >> Analog Edge >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the trigger if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeStartTrigCoupling

DAQmxSetAnlgEdgeStartTrigCoupling

DAQmxResetAnlgEdgeStartTrigCoupling


Start >> Analog Window >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the trigger if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgWinStartTrigCoupling

DAQmxSetAnlgWinStartTrigCoupling

DAQmxResetAnlgWinStartTrigCoupling


Reference >> Analog Edge >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the trigger if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgEdgeRefTrigCoupling

DAQmxSetAnlgEdgeRefTrigCoupling

DAQmxResetAnlgEdgeRefTrigCoupling


More >> Pause >> Analog Level >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the trigger if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgLvlPauseTrigCoupling

DAQmxSetAnlgLvlPauseTrigCoupling

DAQmxResetAnlgLvlPauseTrigCoupling


More >> Pause >> Analog Window >> Coupling

Data Type: | int32
Description: | Specifies the coupling for the source signal of the terminal if the source is a terminal rather than a virtual channel.

Valid values
DAQmx_Val_AC | 10045 | Alternating Current.
DAQmx_Val_DC | 10050 | Direct Current.

You can get/set/reset this property using:

DAQmxGetAnlgWinPauseTrigCoupling

DAQmxSetAnlgWinPauseTrigCoupling

DAQmxResetAnlgWinPauseTrigCoupling


More >> Advance >> Digital Edge >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetDigEdgeAdvTrigDigFltrEnable

DAQmxSetDigEdgeAdvTrigDigFltrEnable

DAQmxResetDigEdgeAdvTrigDigFltrEnable


Counter Input >> General Properties >> More >> Advanced >> Prescaler

Data Type: | uInt32
Description: | Specifies the divisor to apply to the signal you connect to the counter source terminal. Scaled data that you read takes this setting into account. You should use a prescaler only when you connect an external signal to the counter source terminal and when that signal has a higher frequency than the fastest onboard timebase. Setting this value disables duplicate count prevention unless you explicitly set Duplicate Count Prevention to TRUE.

You can get/set/reset this property using:

DAQmxGetCIPrescaler

DAQmxSetCIPrescaler

DAQmxResetCIPrescaler


Analog Output >> General Properties >> Output Configuration >> Idle Output Behavior

Data Type: | int32
Description: | Specifies the state of the channel when no generation is in progress.

Valid values
DAQmx_Val_ZeroVolts | 12526 | Generate 0 V.
DAQmx_Val_HighImpedance | 12527 | Set the channel to high-impedance, effectively disconnecting the analog output circuitry from the I/O connector.
DAQmx_Val_MaintainExistingValue | 12528 | Continue generating the current value.

You can get/set/reset this property using:

DAQmxGetAOIdleOutputBehavior

DAQmxSetAOIdleOutputBehavior

DAQmxResetAOIdleOutputBehavior


Analog Output >> General Properties >> Advanced >> Enhanced Image Rejection Enable

Data Type: | bool32
Description: | Specifies whether to enable the DAC interpolation filter. Disable the interpolation filter to improve DAC signal-to-noise ratio at the expense of degraded image rejection.

You can get/set/reset this property using:

DAQmxGetAOEnhancedImageRejectionEnable

DAQmxSetAOEnhancedImageRejectionEnable

DAQmxResetAOEnhancedImageRejectionEnable


Analog Output >> General Properties >> DAC >> Reference Voltage >> External Source

Data Type: | char*
Description: | Specifies the source of the DAC reference voltage if Source is DAQmx_Val_External. The valid sources for this signal vary by device.

You can get/set/reset this property using:

DAQmxGetAODACRefExtSrc

DAQmxSetAODACRefExtSrc

DAQmxResetAODACRefExtSrc


Analog Output >> General Properties >> DAC >> Offset Voltage >> Source

Data Type: | int32
Description: | Specifies the source of the DAC offset voltage. The value of this voltage source determines the full-scale value of the DAC.

Valid values
DAQmx_Val_Internal | 10200 | Internal to the device.
DAQmx_Val_External | 10167 | External to the device.

You can get/set/reset this property using:

DAQmxGetAODACOffsetSrc

DAQmxSetAODACOffsetSrc

DAQmxResetAODACOffsetSrc


Analog Output >> General Properties >> DAC >> Offset Voltage >> External Source

Data Type: | char*
Description: | Specifies the source of the DAC offset voltage if Source is DAQmx_Val_External. The valid sources for this signal vary by device.

You can get/set/reset this property using:

DAQmxGetAODACOffsetExtSrc

DAQmxSetAODACOffsetExtSrc

DAQmxResetAODACOffsetExtSrc


Analog Output >> General Properties >> DAC >> Offset Voltage >> Value

Data Type: | float64
Description: | Specifies in volts the value of the DAC offset voltage. To achieve best accuracy, the DAC offset value should be hand calibrated.

You can get/set/reset this property using:

DAQmxGetAODACOffsetVal

DAQmxSetAODACOffsetVal

DAQmxResetAODACOffsetVal


Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the device.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetDIDataXferMech

DAQmxSetDIDataXferMech

DAQmxResetDIDataXferMech


Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the onboard memory of the device to the buffer.

Valid values
DAQmx_Val_OnBrdMemMoreThanHalfFull | 10237 | Transfer data from the device when more than half of the onboard memory of the device fills.
DAQmx_Val_OnBrdMemNotEmpty | 10241 | Transfer data from the device when there is data in the onboard memory.
DAQmx_Val_OnbrdMemCustomThreshold | 12577 | Transfer data from the device when the number of samples specified with Data Transfer Custom Threshold are in the device FIFO.
DAQmx_Val_WhenAcqComplete | 12546 | Transfer data when the acquisition is complete.

You can get/set/reset this property using:

DAQmxGetDIDataXferReqCond

DAQmxSetDIDataXferReqCond

DAQmxResetDIDataXferReqCond


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory

Data Type: | bool32
Description: | Specifies whether to write samples directly to the onboard memory of the device, bypassing the memory buffer. Generally, you cannot update onboard memory after you start the task. Onboard memory includes data FIFOs.

You can get/set/reset this property using:

DAQmxGetDOUseOnlyOnBrdMem

DAQmxSetDOUseOnlyOnBrdMem

DAQmxResetDOUseOnlyOnBrdMem


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism

Data Type: | int32
Description: | Specifies the data transfer mode for the device.

Valid values
DAQmx_Val_DMA | 10054 | Direct Memory Access. Data transfers take place independently from the application.
DAQmx_Val_Interrupts | 10204 | Data transfers take place independently from the application. Using interrupts increases CPU usage because the CPU must service interrupt requests. Typically, you should use interrupts if the device is out of DMA channels.
DAQmx_Val_ProgrammedIO | 10264 | Data transfers take place when you call an NI-DAQmx Read function or an NI-DAQmx Write function.
DAQmx_Val_USBbulk | 12590 | Data transfers take place independently from the application using a USB bulk pipe.

You can get/set/reset this property using:

DAQmxGetDODataXferMech

DAQmxSetDODataXferMech

DAQmxResetDODataXferMech


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition

Data Type: | int32
Description: | Specifies under what condition to transfer data from the buffer to the onboard memory of the device.

Valid values
DAQmx_Val_OnBrdMemEmpty | 10235 | Transfer data to the device only when there is no data in the onboard memory of the device.
DAQmx_Val_OnBrdMemHalfFullOrLess | 10239 | Transfer data to the device any time the onboard memory is less than half full.
DAQmx_Val_OnBrdMemNotFull | 10242 | Transfer data to the device any time the onboard memory of the device is not full.

You can get/set/reset this property using:

DAQmxGetDODataXferReqCond

DAQmxSetDODataXferReqCond

DAQmxResetDODataXferReqCond


Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseDigFltrEnable

DAQmxSetCICtrTimebaseDigFltrEnable

DAQmxResetCICtrTimebaseDigFltrEnable


Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseDigFltrMinPulseWidth

DAQmxSetCICtrTimebaseDigFltrMinPulseWidth

DAQmxResetCICtrTimebaseDigFltrMinPulseWidth


Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseDigFltrTimebaseSrc

DAQmxSetCICtrTimebaseDigFltrTimebaseSrc

DAQmxResetCICtrTimebaseDigFltrTimebaseSrc


Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseDigFltrTimebaseRate

DAQmxSetCICtrTimebaseDigFltrTimebaseRate

DAQmxResetCICtrTimebaseDigFltrTimebaseRate


Counter Input >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable

Data Type: | bool32
Description: | Specifies whether to synchronize recognition of transitions in the signal to the internal timebase of the device. This property does not affect the minimum pulse width recognized by the device, but setting this property to TRUE does limit the speed at which the device recognizes transitions to less than the frequency of the internal timebase.

You can get/set/reset this property using:

DAQmxGetCICtrTimebaseDigSyncEnable

DAQmxSetCICtrTimebaseDigSyncEnable

DAQmxResetCICtrTimebaseDigSyncEnable


Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Enable

Data Type: | bool32
Description: | Specifies whether to apply the pulse width filter to the signal.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseDigFltrEnable

DAQmxSetCOCtrTimebaseDigFltrEnable

DAQmxResetCOCtrTimebaseDigFltrEnable


Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width

Data Type: | float64
Description: | Specifies in seconds the minimum pulse width the filter recognizes.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseDigFltrMinPulseWidth

DAQmxSetCOCtrTimebaseDigFltrMinPulseWidth

DAQmxResetCOCtrTimebaseDigFltrMinPulseWidth


Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseDigFltrTimebaseSrc

DAQmxSetCOCtrTimebaseDigFltrTimebaseSrc

DAQmxResetCOCtrTimebaseDigFltrTimebaseSrc


Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCOCtrTimebaseDigFltrTimebaseRate

DAQmxSetCOCtrTimebaseDigFltrTimebaseRate

DAQmxResetCOCtrTimebaseDigFltrTimebaseRate


Analog Input >> General Properties >> Advanced >> Enhanced Alias Rejection Enable

Data Type: | bool32
Description: | Specifies whether to enable enhanced alias rejection. Leave this property set to the default value for most applications.

You can get/set/reset this property using:

DAQmxGetAIEnhancedAliasRejectionEnable

DAQmxSetAIEnhancedAliasRejectionEnable

DAQmxResetAIEnhancedAliasRejectionEnable


Analog Input >> General Properties >> Channel Calibration >> Has Valid Calibration Information

Data Type: | bool32
Description: | Indicates if the channel has calibration information. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIChanCalHasValidCalInfo


Analog Input >> General Properties >> Channel Calibration >> Enable Calibration

Data Type: | bool32
Description: | Specifies whether to enable the channel calibration associated with the channel. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalEnableCal

DAQmxSetAIChanCalEnableCal

DAQmxResetAIChanCalEnableCal


Analog Input >> General Properties >> Channel Calibration >> Apply Calibration If Expired

Data Type: | bool32
Description: | Specifies whether to apply the channel calibration to the channel after the expiration date has passed. Refer to the DAQmx Professional Tools Web site for more information and examples of channel calibration.

You can get/set/reset this property using:

DAQmxGetAIChanCalApplyCalIfExp

DAQmxSetAIChanCalApplyCalIfExp

DAQmxResetAIChanCalApplyCalIfExp


Events >> Change Detection Event >> Pulse >> Polarity

Data Type: | int32
Description: | Specifies the polarity of an exported Change Detection Event pulse.

Valid values
DAQmx_Val_ActiveHigh | 10095 | High state is the active state.
DAQmx_Val_ActiveLow | 10096 | Low state is the active state.

You can get/set/reset this property using:

DAQmxGetExportedChangeDetectEventPulsePolarity

DAQmxSetExportedChangeDetectEventPulsePolarity

DAQmxResetExportedChangeDetectEventPulsePolarity


General Properties >> Is Global

Data Type: | bool32
Description: | Indicates whether the channel is a global channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetChanIsGlobal


Report Missed Samples

Data Type: | bool32
Description: | Specifies whether an NI-DAQmx Read function returns lateness errors or warnings when it detects missed Sample Clock pulses. This setting does not affect DAQmxWaitForNextSampleClock(). Set this property to TRUE for applications that need to detect lateness without using DAQmxWaitForNextSampleClock().

You can get/set/reset this property using:

DAQmxGetRealTimeReportMissedSamp

DAQmxSetRealTimeReportMissedSamp

DAQmxResetRealTimeReportMissedSamp


I/O Type >> Digital Input >> Lines

Data Type: | char*
Description: | Indicates an array containing the names of the digital input lines available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDILines


I/O Type >> Digital Input >> Ports

Data Type: | char*
Description: | Indicates an array containing the names of the digital input ports available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDIPorts


I/O Type >> Digital Output >> Lines

Data Type: | char*
Description: | Indicates an array containing the names of the digital output lines available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDOLines


I/O Type >> Digital Output >> Ports

Data Type: | char*
Description: | Indicates an array containing the names of the digital output ports available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDOPorts


I/O Type >> Counter Input >> Physical Channels

Data Type: | char*
Description: | Indicates an array containing the names of the counter input physical channels available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCIPhysicalChans


I/O Type >> Counter Output >> Physical Channels

Data Type: | char*
Description: | Indicates an array containing the names of the counter output physical channels available on the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevCOPhysicalChans


Location >> Bus Type

Data Type: | int32
Description: | Indicates the bus type of the device.
Restrictions: | Not Settable

Valid values
DAQmx_Val_PCI | 12582 | PCI.
DAQmx_Val_PCIe | 13612 | PCI Express.
DAQmx_Val_PXI | 12583 | PXI.
DAQmx_Val_PXIe | 14706 | PXI Express.
DAQmx_Val_SCXI | 12584 | SCXI.
DAQmx_Val_SCC | 14707 | SCC.
DAQmx_Val_PCCard | 12585 | PC Card/PCMCIA.
DAQmx_Val_USB | 12586 | USB.
DAQmx_Val_CompactDAQ | 14637 | CompactDAQ.
DAQmx_Val_TCPIP | 14828 | TCP/IP.
DAQmx_Val_Unknown | 12588 | Unknown bus type.
DAQmx_Val_SwitchBlock | 15870 | SwitchBlock.

You can get this property using:

DAQmxGetDevBusType


Location >> PCI >> Bus Number

Data Type: | uInt32
Description: | Indicates the PCI bus number of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevPCIBusNum


Location >> PCI >> Device Number

Data Type: | uInt32
Description: | Indicates the PCI slot number of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevPCIDevNum


Location >> PXI >> Chassis Number

Data Type: | uInt32
Description: | Indicates the PXI chassis number of the device, as identified in MAX.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevPXIChassisNum


Analog Input >> Input Configuration >> Terminal Configurations

Data Type: | int32
Description: | Indicates the list of terminal configurations supported by the channel.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TermCfg_RSE | 1 | RSE terminal configuration
DAQmx_Val_Bit_TermCfg_NRSE | 2 | NRSE terminal configuration
DAQmx_Val_Bit_TermCfg_Diff | 4 | Differential terminal configuration
DAQmx_Val_Bit_TermCfg_PseudoDIFF | 8 | Pseudodifferential terminal configuration

You can get this property using:

DAQmxGetPhysicalChanAITermCfgs


Sample Clock >> Underflow Behavior

Data Type: | int32
Description: | Specifies the action to take when the onboard memory of the device becomes empty. In either case, the sample clock does not stop.

Valid values
DAQmx_Val_HaltOutputAndError | 14615 | Stop generating samples and return an error.
DAQmx_Val_PauseUntilDataAvailable | 14616 | Pause the task until samples are available in the FIFO.

You can get/set/reset this property using:

DAQmxGetSampClkUnderflowBehavior

DAQmxSetSampClkUnderflowBehavior

DAQmxResetSampClkUnderflowBehavior


Events >> Ready For Transfer Event >> Deassert Condition

Data Type: | int32
Description: | Specifies when the ready for transfer event deasserts.

Valid values
DAQmx_Val_OnbrdMemMoreThanHalfFull | 10237 | Deassert the signal when more than half of the onboard memory of the device fills.
DAQmx_Val_OnbrdMemFull | 10236 | Deassert the signal when the onboard memory fills.
DAQmx_Val_OnbrdMemCustomThreshold | 12577 | Deassert the signal when the amount of space available in the onboard memory is below the value specified with Deassert Condition Custom Threshold.

You can get/set/reset this property using:

DAQmxGetExportedRdyForXferEventDeassertCond

DAQmxSetExportedRdyForXferEventDeassertCond

DAQmxResetExportedRdyForXferEventDeassertCond


Events >> Ready For Transfer Event >> Deassert Condition Custom Threshold

Data Type: | uInt32
Description: | Specifies in samples the threshold below which the Ready for Transfer Event deasserts. This threshold is an amount of space available in the onboard memory of the device. Deassert Condition must be DAQmx_Val_OnbrdMemCustomThreshold to use a custom threshold.

You can get/set/reset this property using:

DAQmxGetExportedRdyForXferEventDeassertCondCustomThreshold

DAQmxSetExportedRdyForXferEventDeassertCondCustomThreshold

DAQmxResetExportedRdyForXferEventDeassertCondCustomThreshold


Digital Input >> General Properties >> Advanced >> Acquire On

Data Type: | int32
Description: | Specifies on which edge of the sample clock to acquire samples.

Valid values
DAQmx_Val_SampClkActiveEdge | 14617 | Active edges.
DAQmx_Val_SampClkInactiveEdge | 14618 | Inactive edges.

You can get/set/reset this property using:

DAQmxGetDIAcquireOn

DAQmxSetDIAcquireOn

DAQmxResetDIAcquireOn


Digital Output >> Line States >> Paused State

Data Type: | int32
Description: | Specifies the state of the lines in a digital output task when the task pauses.

Valid values
DAQmx_Val_High | 10192 | Logic high.
DAQmx_Val_Low | 10214 | Logic low.
DAQmx_Val_Tristate | 10310 | High-impedance state. You can select this state only on devices with bidirectional lines. You cannot select this state for dedicated digital output lines. On some devices, you can select this value only for entire ports.
DAQmx_Val_NoChange | 10160 | Do not change the state of the lines. On some devices, you can select this value only for entire ports.

You can get/set/reset this property using:

DAQmxGetDOLineStatesPausedState

DAQmxSetDOLineStatesPausedState

DAQmxResetDOLineStatesPausedState


Digital Output >> Line States >> Done State

Data Type: | int32
Description: | Specifies the state of the lines in a digital output task when the task completes execution.

Valid values
DAQmx_Val_High | 10192 | Logic high.
DAQmx_Val_Low | 10214 | Logic low.
DAQmx_Val_Tristate | 10310 | High-impedance state. You can select this state only on devices with bidirectional lines. You cannot select this state for dedicated digital output lines. On some devices, you can select this value only for entire ports.
DAQmx_Val_NoChange | 10160 | Do not change the state of the lines. On some devices, you can select this value only for entire ports.

You can get/set/reset this property using:

DAQmxGetDOLineStatesDoneState

DAQmxSetDOLineStatesDoneState

DAQmxResetDOLineStatesDoneState


Digital Output >> General Properties >> Advanced >> Generate On

Data Type: | int32
Description: | Specifies on which edge of the sample clock to generate samples.

Valid values
DAQmx_Val_SampClkActiveEdge | 14617 | Active edges.
DAQmx_Val_SampClkInactiveEdge | 14618 | Inactive edges.

You can get/set/reset this property using:

DAQmxGetDOGenerateOn

DAQmxSetDOGenerateOn

DAQmxResetDOGenerateOn


Digital Output >> Line States >> Start State

Data Type: | int32
Description: | Specifies the state of the lines in a digital output task when the task starts.

Valid values
DAQmx_Val_High | 10192 | Logic high.
DAQmx_Val_Low | 10214 | Logic low.
DAQmx_Val_Tristate | 10310 | High-impedance state. You can select this state only on devices with bidirectional lines. You cannot select this state for dedicated digital output lines. On some devices, you can select this value only for entire ports.
DAQmx_Val_NoChange | 10160 | Do not change the state of the lines. On some devices, you can select this value only for entire ports.

You can get/set/reset this property using:

DAQmxGetDOLineStatesStartState

DAQmxSetDOLineStatesStartState

DAQmxResetDOLineStatesStartState


Analog Input >> TEDS >> Is TEDS

Data Type: | bool32
Description: | Indicates if the virtual channel was initialized using a TEDS bitstream from the corresponding physical channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAIIsTEDS


Triggering >> Analog Triggering Supported

Data Type: | bool32
Description: | Indicates if the device supports analog triggering.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAnlgTrigSupported


Triggering >> Digital Triggering Supported

Data Type: | bool32
Description: | Indicates if the device supports digital triggering.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDigTrigSupported


I/O Type >> Analog Input >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for an analog input task.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevAITrigUsage


I/O Type >> Analog Output >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for analog output tasks.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevAOTrigUsage


I/O Type >> Digital Input >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for digital input tasks.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevDITrigUsage


I/O Type >> Digital Output >> Trigger >> Trigger Usage

Data Type: | int32
Description: | Indicates the triggers supported by this device for digital output tasks.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_TriggerUsageTypes_Advance | 1 | Device supports advance triggers
DAQmx_Val_Bit_TriggerUsageTypes_Pause | 2 | Device supports pause triggers
DAQmx_Val_Bit_TriggerUsageTypes_Reference | 4 | Device supports reference triggers
DAQmx_Val_Bit_TriggerUsageTypes_Start | 8 | Device supports start triggers
DAQmx_Val_Bit_TriggerUsageTypes_Handshake | 16 | Device supports handshake triggers
DAQmx_Val_Bit_TriggerUsageTypes_ArmStart | 32 | Device supports arm start triggers

You can get this property using:

DAQmxGetDevDOTrigUsage


I/O Type >> Analog Input >> Voltage >> Ranges

Data Type: | float64*
Description: | Indicates pairs of input voltage ranges supported by this device. Each pair consists of the low value, followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIVoltageRngs


I/O Type >> Analog Input >> Current >> Ranges

Data Type: | float64*
Description: | Indicates the pairs of current input ranges supported by this device. Each pair consists of the low value, followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAICurrentRngs


I/O Type >> Analog Input >> Frequency >> Ranges

Data Type: | float64*
Description: | Indicates the pairs of frequency input ranges supported by this device. Each pair consists of the low value, followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIFreqRngs


I/O Type >> Analog Input >> Gains

Data Type: | float64*
Description: | Indicates the input gain settings supported by this device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIGains


I/O Type >> Analog Input >> Couplings

Data Type: | int32
Description: | Indicates the coupling types supported by this device.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Bit_CouplingTypes_AC | 1 | Device supports AC coupling
DAQmx_Val_Bit_CouplingTypes_DC | 2 | Device supports DC coupling
DAQmx_Val_Bit_CouplingTypes_Ground | 4 | Device supports ground coupling
DAQmx_Val_Bit_CouplingTypes_HFReject | 8 | Device supports High Frequency Reject coupling
DAQmx_Val_Bit_CouplingTypes_LFReject | 16 | Device supports Low Frequency Reject coupling
DAQmx_Val_Bit_CouplingTypes_NoiseReject | 32 | Device supports Noise Reject coupling

You can get this property using:

DAQmxGetDevAICouplings


I/O Type >> Analog Input >> Filter >> Analog Low Pass >> Cutoff Frequency >> Discrete Values

Data Type: | float64*
Description: | Indicates the set of discrete lowpass cutoff frequencies supported by this device. If the device supports ranges of lowpass cutoff frequencies, use Range Values to determine supported frequencies.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAILowpassCutoffFreqDiscreteVals


I/O Type >> Analog Output >> Timing >> Sample Clock Supported

Data Type: | bool32
Description: | Indicates if the device supports the sample clock timing type for analog output tasks.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOSampClkSupported


I/O Type >> Analog Output >> Timing >> Maximum Rate

Data Type: | float64
Description: | Indicates the maximum analog output rate of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOMaxRate


I/O Type >> Analog Output >> Timing >> Minimum Rate

Data Type: | float64
Description: | Indicates the minimum analog output rate of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAOMinRate


I/O Type >> Digital Input >> Timing >> Maximum Rate

Data Type: | float64
Description: | Indicates the maximum digital input rate of the device.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevDIMaxRate


Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetAIUsbXferReqCount

DAQmxSetAIUsbXferReqCount

DAQmxResetAIUsbXferReqCount


Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetAOUsbXferReqCount

DAQmxSetAOUsbXferReqCount

DAQmxResetAOUsbXferReqCount


Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetDIUsbXferReqCount

DAQmxSetDIUsbXferReqCount

DAQmxResetDIUsbXferReqCount


Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetDOUsbXferReqCount

DAQmxSetDOUsbXferReqCount

DAQmxResetDOUsbXferReqCount


Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetCIUsbXferReqCount

DAQmxSetCIUsbXferReqCount

DAQmxResetCIUsbXferReqCount


Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count

Data Type: | uInt32
Description: | Specifies the maximum number of simultaneous USB transfers used to stream data. Modify this value to affect performance under different combinations of operating system and device.

You can get/set/reset this property using:

DAQmxGetCOUsbXferReqCount

DAQmxSetCOUsbXferReqCount

DAQmxResetCOUsbXferReqCount


Status >> Accessory >> Accessory Insertion or Removal Detected

Data Type: | bool32
Description: | Indicates if any devices in the task detected the insertion or removal of an accessory since the task started. Reading this property clears the accessory change status for all channels in the task. You must read this property before you read Devices with Inserted or Removed Accessories. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteAccessoryInsertionOrRemovalDetected


Status >> Accessory >> Devices with Inserted or Removed Accessories

Data Type: | char*
Description: | Indicates the names of any devices that detected the insertion or removal of an accessory since the task started. You must read Accessory Insertion or Removal Detected before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteDevsWithInsertedOrRemovedAccessories


Expiration States >> Counter Output >> Expiration State

Data Type: | int32
Description: | Specifies the state to set the counter output channel terminal when the watchdog task expires.

Valid values
DAQmx_Val_Low | 10214 | Low logic.
DAQmx_Val_High | 10192 | High logic.
DAQmx_Val_NoChange | 10160 | Expiration does not affect the state of the counter output. The channels retain their states at the time of the watchdog timer expiration, and no further counter generation runs.

You can get/set/reset this property using:

DAQmxGetWatchdogCOExpirState

DAQmxSetWatchdogCOExpirState

DAQmxResetWatchdogCOExpirState


Analog Output >> Advanced >> Power Amplifier >> Channel Enable

Data Type: | bool32
Description: | Specifies whether to enable or disable a channel for amplification. This property can also be used to check if a channel is enabled.

You can get/set/reset this property using:

DAQmxGetAOPowerAmpChannelEnable

DAQmxSetAOPowerAmpChannelEnable

DAQmxResetAOPowerAmpChannelEnable


Analog Output >> Advanced >> Power Amplifier >> Scaling Coefficients

Data Type: | float64*
Description: | Indicates the coefficients of a polynomial equation used to scale from pre-amplified values.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAOPowerAmpScalingCoeff


Analog Output >> Advanced >> Power Amplifier >> Overcurrent

Data Type: | bool32
Description: | Indicates if the channel detected an overcurrent condition.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAOPowerAmpOvercurrent


Analog Output >> Advanced >> Power Amplifier >> Calibration >> Gain

Data Type: | float64
Description: | Indicates the calibrated gain of the channel.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAOPowerAmpGain


Analog Output >> Advanced >> Power Amplifier >> Calibration >> Offset

Data Type: | float64
Description: | Indicates the calibrated offset of the channel in volts.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetAOPowerAmpOffset


Analog Input >> General Properties >> Filter >> Filter Delay Units

Data Type: | int32
Description: | Specifies the units of Filter Delay and Filter Delay Adjustment.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_SampleClkPeriods | 10286 | Sample Clock Periods.

You can get/set/reset this property using:

DAQmxGetAIFilterDelayUnits

DAQmxSetAIFilterDelayUnits

DAQmxResetAIFilterDelayUnits


Analog Output >> General Properties >> Filter >> Filter Delay Adjustment

Data Type: | float64
Description: | Specifies an additional amount of time to wait between when the sample is written by the host device and when the sample is output by the DAC. This delay adjustment is in addition to the value indicated by Filter Delay. This delay adjustment is in the units you specify with Filter Delay Units.

You can get/set/reset this property using:

DAQmxGetAOFilterDelayAdjustment

DAQmxSetAOFilterDelayAdjustment

DAQmxResetAOFilterDelayAdjustment


Analog Input >> General Properties >> Filter >> Filter Delay Adjustment

Data Type: | float64
Description: | Specifies the amount of filter delay that gets removed if Remove Filter Delay is enabled. This delay adjustment is in addition to the value indicated by Filter Delay. This delay adjustment is in the units you specify with Filter Delay Units.

You can get/set/reset this property using:

DAQmxGetAIFilterDelayAdjustment

DAQmxSetAIFilterDelayAdjustment

DAQmxResetAIFilterDelayAdjustment


Analog Output >> General Properties >> Filter >> Filter Delay

Data Type: | float64
Description: | Specifies the amount of time between when the sample is written by the host device and when the sample is output by the DAC. This value is in the units you specify with Filter Delay Units.

You can get/set/reset this property using:

DAQmxGetAOFilterDelay

DAQmxSetAOFilterDelay

DAQmxResetAOFilterDelay


Analog Output >> General Properties >> Filter >> Filter Delay Units

Data Type: | int32
Description: | Specifies the units of Filter Delay and Filter Delay Adjustment.

Valid values
DAQmx_Val_Seconds | 10364 | Seconds.
DAQmx_Val_SampleClkPeriods | 10286 | Sample Clock Periods.

You can get/set/reset this property using:

DAQmxGetAOFilterDelayUnits

DAQmxSetAOFilterDelayUnits

DAQmxResetAOFilterDelayUnits


Status >> Overtemperature >> Overtemperature Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overtemperature condition in any virtual channel in the task. Reading this property clears the overtemperature status for all channels in the task. You must read this property before you read Overtemperature Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOvertemperatureChansExist


Status >> Overtemperature >> Overtemperature Channels

Data Type: | char*
Description: | Indicates a list of names of any overtemperature virtual channels. You must read Overtemperature Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOvertemperatureChans


Status >> Overtemperature >> Overtemperature Channels

Data Type: | char*
Description: | Indicates a list of names of any overtemperature virtual channels. You must read Overtemperature Channels Exist before you read this property. Otherwise, you will receive an error. The list of names may be empty if the device cannot determine the source of the overtemperature.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOvertemperatureChans


Status >> Overload >> Overloaded Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an overload in any virtual channel in the task. Reading this property clears the overload status for all channels in the task. You must read this property before you read Overloaded Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOverloadedChansExist


Status >> Overload >> Overloaded Channels

Data Type: | char*
Description: | Indicates a list of names of any overloaded virtual channels in the task. You must read Overloaded Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetWriteOverloadedChans


Status >> Excitation Fault >> Excitation Fault Channels Exist

Data Type: | bool32
Description: | Indicates if the device(s) detected an excitation fault condition for any virtual channel in the task. Reading this property clears the excitation fault status for all channels in the task. You must read this property before you read Excitation Fault Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadExcitFaultChansExist


Status >> Excitation Fault >> Excitation Fault Channels

Data Type: | char*
Description: | Indicates a list of names of any virtual channels in the task for which the device(s) detected an excitation fault condition. You must read Excitation Fault Channels Exist before you read this property. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadExcitFaultChans


Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Source

Data Type: | char*
Description: | Specifies the input terminal of the signal to use as the timebase of the pulse width filter.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleDigFltrTimebaseSrc

DAQmxSetCIDutyCycleDigFltrTimebaseSrc

DAQmxResetCIDutyCycleDigFltrTimebaseSrc


Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Rate

Data Type: | float64
Description: | Specifies in hertz the rate of the pulse width filter timebase. NI-DAQmx uses this value to compute settings for the filter.

You can get/set/reset this property using:

DAQmxGetCIDutyCycleDigFltrTimebaseRate

DAQmxSetCIDutyCycleDigFltrTimebaseRate

DAQmxResetCIDutyCycleDigFltrTimebaseRate


Counter Input >> Duty Cycle >> StartingEdge

Data Type: | int32
Description: | Specifies which edge of the input signal to begin the duty cycle measurement.

Valid values
DAQmx_Val_Rising | 10280 | Rising edge(s).
DAQmx_Val_Falling | 10171 | Falling edge(s).

You can get/set/reset this property using:

DAQmxGetCIDutyCycleStartingEdge

DAQmxSetCIDutyCycleStartingEdge

DAQmxResetCIDutyCycleStartingEdge


Counter Input >> General Properties >> More >> Sample Clock Overrun Behavior

Data Type: | int32
Description: | Specifies the counter behavior when data is read but a new value was not detected during a sample clock.

Valid values
DAQmx_Val_RepeatedData | 16062 | Repeat the last sample.
DAQmx_Val_SentinelValue | 16063 | Return the sentinel value.

You can get/set/reset this property using:

DAQmxGetCISampClkOverrunBehavior

DAQmxSetCISampClkOverrunBehavior

DAQmxResetCISampClkOverrunBehavior


Counter Input >> General Properties >> More >> Sample Clock Overrun Sentinel Value

Data Type: | int32
Description: | Specifies the sentinel value returned when the No New Sample Behavior is set to Sentinel Value.

You can get/set/reset this property using:

DAQmxGetCISampClkOverrunSentinelVal

DAQmxSetCISampClkOverrunSentinelVal

DAQmxResetCISampClkOverrunSentinelVal


Counter Input >> General Properties >> More >> Advanced >> Maximum Measurable Period

Data Type: | float64
Description: | Specifies the maximum period (in seconds) in which the device will recognize signals. For frequency measurements, a signal with a higher period than the one set in this property will return 0 Hz. For duty cycle, the device will return 0 or 1 depending on the state of the line during the max defined period of time. Period measurements will return NaN. Pulse width measurement will return zero.

You can get/set/reset this property using:

DAQmxGetCIMaxMeasPeriod

DAQmxSetCIMaxMeasPeriod

DAQmxResetCIMaxMeasPeriod


Counter Input >> Frequency >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIFreqTermCfg

DAQmxSetCIFreqTermCfg

DAQmxResetCIFreqTermCfg


Counter Input >> Frequency >> Input >> Logic Level Behavior

Data Type: | int32
Description: | Specifies the logic level behavior on the input line.

Valid values
DAQmx_Val_LogicLevelPullUp | 16064 | High logic.
DAQmx_Val_None | 10230 | Supply no excitation to the channel.

You can get/set/reset this property using:

DAQmxGetCIFreqLogicLvlBehavior

DAQmxSetCIFreqLogicLvlBehavior

DAQmxResetCIFreqLogicLvlBehavior


Counter Input >> Period >> Input >> Terminal Configuration

Data Type: | int32
Description: | Specifies the input terminal configuration.

Valid values
DAQmx_Val_Diff | 10106 | Differential.
DAQmx_Val_RSE | 10083 | Referenced Single-Ended.

You can get/set/reset this property using:

DAQmxGetCIPeriodTermCfg

DAQmxSetCIPeriodTermCfg

DAQmxResetCIPeriodTermCfg


Status >> Open Channels >> Open Channels Exist

Data Type: | bool32
Description: | Indicates if the device or devices detected an open channel condition in any virtual channel in the task. Reading this property clears the open channel status for all channels in this task. You must read this property before you read Open Channels. Otherwise, you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenChansExist


Status >> Open Channels >> Open Channels

Data Type: | char*
Description: | Indicates a list of names of any open virtual channels. You must read Open Channels Exist before you read this property. Otherwise you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenChans


Status >> Open Channels >> Open Channels Details

Data Type: | char*
Description: | Indicates a list of details of any open virtual channels. You must read Open Channels Exist before you read this property. Otherwise you will receive an error.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetReadOpenChansDetails


I/O Type >> Analog Input >> Filter >> Digital Filter >> Types

Data Type: | int32*
Description: | Indicates the AI digital filter types supported by the device.
Restrictions: | Not Settable

Valid values
DAQmx_Val_Lowpass | 16071 | Lowpass filter.
DAQmx_Val_Highpass | 16072 | Highpass filter.
DAQmx_Val_Bandpass | 16073 | Bandpass filter.
DAQmx_Val_Notch | 16074 | Notch filter.
DAQmx_Val_Custom | 10137 | Custom filter.

You can get this property using:

DAQmxGetAIDigFltrTypes


I/O Type >> Analog Input >> Charge >> Ranges

Data Type: | float64*
Description: | Indicates in coulombs pairs of input charge ranges for the device. Each pair consists of the low value followed by the high value.
Restrictions: | Not Settable

You can get this property using:

DAQmxGetDevAIChargeRngs


Analog Input >> Charge >> Units

Data Type: | int32
Description: | Specifies the units to use to return charge measurements from the channel.

Valid values
DAQmx_Val_Coulombs | 16102 | Coulombs.
DAQmx_Val_PicoCoulombs | 16103 | PicoCoulombs.
DAQmx_Val_FromCustomScale | 10065 | Units a custom scale specifies. If you select this value, you must specify a custom scale name.

You can get/set/reset this property using:

DAQmxGetAIChargeUnits

DAQmxSetAIChargeUnits

DAQmxResetAIChargeUnits


Analog Input >> Acceleration >> Charge >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the charge acceleration sensor connected to the channel. This value is the units you specify with AI.Accel.Charge.SensitivityUnits. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIAccelChargeSensitivity

DAQmxSetAIAccelChargeSensitivity

DAQmxResetAIAccelChargeSensitivity


Analog Input >> Acceleration >> Charge >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of AI.Accel.Charge.Sensitivity.

Valid values
DAQmx_Val_PicoCoulombsPerG | 16099 | PicoCoulombs per g.
DAQmx_Val_PicoCoulombsPerMetersPerSecondSquared | 16100 | PicoCoulombs per m/s^2.
DAQmx_Val_PicoCoulombsPerInchesPerSecondSquared | 16101 | PicoCoulombs per in/s^2.

You can get/set/reset this property using:

DAQmxGetAIAccelChargeSensitivityUnits

DAQmxSetAIAccelChargeSensitivityUnits

DAQmxResetAIAccelChargeSensitivityUnits


Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity

Data Type: | float64
Description: | Specifies the sensitivity of the 4 wire DC voltage acceleration sensor connected to the channel. This value is the units you specify with AI.Accel.4WireDCVoltage.SensitivityUnits. Refer to the sensor documentation to determine this value.

You can get/set/reset this property using:

DAQmxGetAIAccel4WireDCVoltageSensitivity

DAQmxSetAIAccel4WireDCVoltageSensitivity

DAQmxResetAIAccel4WireDCVoltageSensitivity


Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity Units

Data Type: | int32
Description: | Specifies the units of AI.Accel.4WireDCVoltage.Sensitivity.

Valid values
DAQmx_Val_mVoltsPerG | 12509 | mVolts/g.
DAQmx_Val_VoltsPerG | 12510 | Volts/g.

You can get/set/reset this property using:

DAQmxGetAIAccel4WireDCVoltageSensitivityUnits

DAQmxSetAIAccel4WireDCVoltageSensitivityUnits

DAQmxResetAIAccel4WireDCVoltageSensitivityUnits


Get/Set/Reset Read_OpenCurrentLoopChans

int32 __CFUNC DAQmxGetReadOpenCurrentLoopChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOpenCurrentLoopChans gets the Status >> Open Current Loop >> Open Current Loop Channels property.


Get/Set/Reset AO_FuncGen_Amplitude

int32 __CFUNC DAQmxGetAOFuncGenAmplitude(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFuncGenAmplitude(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFuncGenAmplitude(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenAmplitude gets the Analog Output >> Function Generation >> Amplitude property.

DAQmxSetAOFuncGenAmplitude sets the Analog Output >> Function Generation >> Amplitude property.

DAQmxResetAOFuncGenAmplitude resets the Analog Output >> Function Generation >> Amplitude property.


Get/Set/Reset AO_FuncGen_Offset

int32 __CFUNC DAQmxGetAOFuncGenOffset(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFuncGenOffset(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFuncGenOffset(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenOffset gets the Analog Output >> Function Generation >> Offset property.

DAQmxSetAOFuncGenOffset sets the Analog Output >> Function Generation >> Offset property.

DAQmxResetAOFuncGenOffset resets the Analog Output >> Function Generation >> Offset property.


Get/Set/Reset AO_FuncGen_Square_DutyCycle

int32 __CFUNC DAQmxGetAOFuncGenSquareDutyCycle(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFuncGenSquareDutyCycle(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFuncGenSquareDutyCycle(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenSquareDutyCycle gets the Analog Output >> Function Generation >> Square >> DutyCycle property.

DAQmxSetAOFuncGenSquareDutyCycle sets the Analog Output >> Function Generation >> Square >> DutyCycle property.

DAQmxResetAOFuncGenSquareDutyCycle resets the Analog Output >> Function Generation >> Square >> DutyCycle property.


Get/Set/Reset AO_Voltage_CurrentLimit

int32 __CFUNC DAQmxGetAOVoltageCurrentLimit(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOVoltageCurrentLimit(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOVoltageCurrentLimit(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOVoltageCurrentLimit gets the Analog Output >> Voltage >> Current Limit property.

DAQmxSetAOVoltageCurrentLimit sets the Analog Output >> Voltage >> Current Limit property.

DAQmxResetAOVoltageCurrentLimit resets the Analog Output >> Voltage >> Current Limit property.


Get/Set/Reset PhysicalChan_AO_ManualControlEnable

int32 __CFUNC DAQmxGetPhysicalChanAOManualControlEnable(const char physicalChannel[], bool32 *data);

int32 __CFUNC DAQmxSetPhysicalChanAOManualControlEnable(const char physicalChannel[], bool32 data);

int32 __CFUNC DAQmxResetPhysicalChanAOManualControlEnable(const char physicalChannel[]);

Purpose

DAQmxGetPhysicalChanAOManualControlEnable gets the Analog Output >> Advanced >> Manual Control >> Enable property.

DAQmxSetPhysicalChanAOManualControlEnable sets the Analog Output >> Advanced >> Manual Control >> Enable property.

DAQmxResetPhysicalChanAOManualControlEnable resets the Analog Output >> Advanced >> Manual Control >> Enable property.


Get/Set/Reset PhysicalChan_AO_ManualControlAmplitude

int32 __CFUNC DAQmxGetPhysicalChanAOManualControlAmplitude(const char physicalChannel[], float64 *data);

Purpose

DAQmxGetPhysicalChanAOManualControlAmplitude gets the Analog Output >> Advanced >> Manual Control >> Amplitude property.


Get/Set/Reset Carrier_SerialNum

int32 __CFUNC DAQmxGetCarrierSerialNum(const char device[], uInt32 *data);

Purpose

DAQmxGetCarrierSerialNum gets the Identification >> Carrier Serial Number property.


Get/Set/Reset Dev_TCPIP_Hostname

int32 __CFUNC DAQmxGetDevTCPIPHostname(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevTCPIPHostname gets the Location >> TCP/IP >> Hostname property.


Get/Set/Reset Dev_TCPIP_EthernetIP

int32 __CFUNC DAQmxGetDevTCPIPEthernetIP(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevTCPIPEthernetIP gets the Location >> TCP/IP >> Ethernet IP Address property.


Get/Set/Reset Dev_TCPIP_WirelessIP

int32 __CFUNC DAQmxGetDevTCPIPWirelessIP(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevTCPIPWirelessIP gets the Location >> TCP/IP >> Wireless IP Address property.


Get/Set/Reset AI_UsbXferReqSize

int32 __CFUNC DAQmxGetAIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIUsbXferReqSize gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetAIUsbXferReqSize sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetAIUsbXferReqSize resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset AO_UsbXferReqSize

int32 __CFUNC DAQmxGetAOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAOUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOUsbXferReqSize gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetAOUsbXferReqSize sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetAOUsbXferReqSize resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset Read_OpenCurrentLoopChansExist

int32 __CFUNC DAQmxGetReadOpenCurrentLoopChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOpenCurrentLoopChansExist gets the Status >> Open Current Loop >> Open Current Loop Channels Exist property.


Get/Set/Reset Dev_AI_ResistanceRngs

int32 __CFUNC DAQmxGetDevAIResistanceRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIResistanceRngs gets the I/O Type >> Analog Input >> Resistance >> Ranges property.


Get/Set/Reset AO_FuncGen_Type

int32 __CFUNC DAQmxGetAOFuncGenType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOFuncGenType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOFuncGenType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenType gets the Analog Output >> Function Generation >> Type property.

DAQmxSetAOFuncGenType sets the Analog Output >> Function Generation >> Type property.

DAQmxResetAOFuncGenType resets the Analog Output >> Function Generation >> Type property.


Get/Set/Reset AO_FuncGen_Freq

int32 __CFUNC DAQmxGetAOFuncGenFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFuncGenFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFuncGenFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenFreq gets the Analog Output >> Function Generation >> Frequency property.

DAQmxSetAOFuncGenFreq sets the Analog Output >> Function Generation >> Frequency property.

DAQmxResetAOFuncGenFreq resets the Analog Output >> Function Generation >> Frequency property.


Get/Set/Reset PhysicalChan_AO_ManualControlFreq

int32 __CFUNC DAQmxGetPhysicalChanAOManualControlFreq(const char physicalChannel[], float64 *data);

Purpose

DAQmxGetPhysicalChanAOManualControlFreq gets the Analog Output >> Advanced >> Manual Control >> Frequency property.


Get/Set/Reset AO_FuncGen_ModulationType

int32 __CFUNC DAQmxGetAOFuncGenModulationType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOFuncGenModulationType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOFuncGenModulationType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenModulationType gets the Analog Output >> Function Generation >> Modulation >> Type property.

DAQmxSetAOFuncGenModulationType sets the Analog Output >> Function Generation >> Modulation >> Type property.

DAQmxResetAOFuncGenModulationType resets the Analog Output >> Function Generation >> Modulation >> Type property.


Get/Set/Reset AO_FuncGen_FMDeviation

int32 __CFUNC DAQmxGetAOFuncGenFMDeviation(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFuncGenFMDeviation(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFuncGenFMDeviation(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFuncGenFMDeviation gets the Analog Output >> Function Generation >> Modulation >> FM Deviation property.

DAQmxSetAOFuncGenFMDeviation sets the Analog Output >> Function Generation >> Modulation >> FM Deviation property.

DAQmxResetAOFuncGenFMDeviation resets the Analog Output >> Function Generation >> Modulation >> FM Deviation property.


Get/Set/Reset SampTimingEngine

int32 __CFUNC DAQmxGetSampTimingEngine(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetSampTimingEngine(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetSampTimingEngine(TaskHandle taskHandle);

Purpose

DAQmxGetSampTimingEngine gets the Advanced >> Sample Timing Engine property.

DAQmxSetSampTimingEngine sets the Advanced >> Sample Timing Engine property.

DAQmxResetSampTimingEngine resets the Advanced >> Sample Timing Engine property.


Get/Set/Reset Dev_Terminals

int32 __CFUNC DAQmxGetDevTerminals(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevTerminals gets the Terminals property.


Get/Set/Reset Write_OvertemperatureChansExist

int32 __CFUNC DAQmxGetWriteOvertemperatureChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteOvertemperatureChansExist gets the Status >> Overtemperature >> Overtemperature Channels Exist property.


Get/Set/Reset DO_Overcurrent_Limit

int32 __CFUNC DAQmxGetDOOvercurrentLimit(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetDOOvercurrentLimit(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetDOOvercurrentLimit(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOOvercurrentLimit gets the Digital Output >> Overcurrent >> Current Limit property.

DAQmxSetDOOvercurrentLimit sets the Digital Output >> Overcurrent >> Current Limit property.

DAQmxResetDOOvercurrentLimit resets the Digital Output >> Overcurrent >> Current Limit property.


Get/Set/Reset DO_Overcurrent_AutoReenable

int32 __CFUNC DAQmxGetDOOvercurrentAutoReenable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDOOvercurrentAutoReenable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDOOvercurrentAutoReenable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOOvercurrentAutoReenable gets the Digital Output >> Overcurrent >> Automatic Re-enable property.

DAQmxSetDOOvercurrentAutoReenable sets the Digital Output >> Overcurrent >> Automatic Re-enable property.

DAQmxResetDOOvercurrentAutoReenable resets the Digital Output >> Overcurrent >> Automatic Re-enable property.


Get/Set/Reset DO_Overcurrent_ReenablePeriod

int32 __CFUNC DAQmxGetDOOvercurrentReenablePeriod(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetDOOvercurrentReenablePeriod(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetDOOvercurrentReenablePeriod(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOOvercurrentReenablePeriod gets the Digital Output >> Overcurrent >> Re-enable Period property.

DAQmxSetDOOvercurrentReenablePeriod sets the Digital Output >> Overcurrent >> Re-enable Period property.

DAQmxResetDOOvercurrentReenablePeriod resets the Digital Output >> Overcurrent >> Re-enable Period property.


Get/Set/Reset AI_ProbeAtten

int32 __CFUNC DAQmxGetAIProbeAtten(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIProbeAtten(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIProbeAtten(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIProbeAtten gets the Analog Input >> General Properties >> Signal Conditioning >> Probe Attenuation property.

DAQmxSetAIProbeAtten sets the Analog Input >> General Properties >> Signal Conditioning >> Probe Attenuation property.

DAQmxResetAIProbeAtten resets the Analog Input >> General Properties >> Signal Conditioning >> Probe Attenuation property.


Get/Set/Reset AI_DCOffset

int32 __CFUNC DAQmxGetAIDCOffset(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDCOffset(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDCOffset(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDCOffset gets the Analog Input >> General Properties >> Advanced >> DC Offset property.

DAQmxSetAIDCOffset sets the Analog Input >> General Properties >> Advanced >> DC Offset property.

DAQmxResetAIDCOffset resets the Analog Input >> General Properties >> Advanced >> DC Offset property.


Get/Set/Reset DI_UsbXferReqSize

int32 __CFUNC DAQmxGetDIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetDIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetDIUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIUsbXferReqSize gets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetDIUsbXferReqSize sets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetDIUsbXferReqSize resets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset DO_UsbXferReqSize

int32 __CFUNC DAQmxGetDOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetDOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetDOUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOUsbXferReqSize gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetDOUsbXferReqSize sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetDOUsbXferReqSize resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset CI_UsbXferReqSize

int32 __CFUNC DAQmxGetCIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIUsbXferReqSize gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetCIUsbXferReqSize sets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetCIUsbXferReqSize resets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset CO_UsbXferReqSize

int32 __CFUNC DAQmxGetCOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOUsbXferReqSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOUsbXferReqSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOUsbXferReqSize gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxSetCOUsbXferReqSize sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.

DAQmxResetCOUsbXferReqSize resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Size property.


Get/Set/Reset Read_OpenThrmcplChansExist

int32 __CFUNC DAQmxGetReadOpenThrmcplChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOpenThrmcplChansExist gets the Status >> Open Thermocouple >> Open Thermocouple Channels Exist property.


Get/Set/Reset Read_OpenThrmcplChans

int32 __CFUNC DAQmxGetReadOpenThrmcplChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOpenThrmcplChans gets the Status >> Open Thermocouple >> Open Thermocouple Channels property.


Get/Set/Reset Read_CommonModeRangeErrorChansExist

int32 __CFUNC DAQmxGetReadCommonModeRangeErrorChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadCommonModeRangeErrorChansExist gets the Status >> Common Mode Range Error >> Common Mode Range Error Channels Exist property.


Get/Set/Reset Read_CommonModeRangeErrorChans

int32 __CFUNC DAQmxGetReadCommonModeRangeErrorChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadCommonModeRangeErrorChans gets the Status >> Common Mode Range Error >> Common Mode Range Error Channels property.


Get/Set/Reset AI_EddyCurrentProxProbe_Sensitivity

int32 __CFUNC DAQmxGetAIEddyCurrentProxProbeSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIEddyCurrentProxProbeSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIEddyCurrentProxProbeSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIEddyCurrentProxProbeSensitivity gets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity property.

DAQmxSetAIEddyCurrentProxProbeSensitivity sets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity property.

DAQmxResetAIEddyCurrentProxProbeSensitivity resets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity property.


Get/Set/Reset AI_EddyCurrentProxProbe_SensitivityUnits

int32 __CFUNC DAQmxGetAIEddyCurrentProxProbeSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIEddyCurrentProxProbeSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIEddyCurrentProxProbeSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIEddyCurrentProxProbeSensitivityUnits gets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity Units property.

DAQmxSetAIEddyCurrentProxProbeSensitivityUnits sets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity Units property.

DAQmxResetAIEddyCurrentProxProbeSensitivityUnits resets the Analog Input >> Position >> Eddy Current Proximity Probe >> Sensitivity Units property.


Get/Set/Reset AI_EddyCurrentProxProbe_Units

int32 __CFUNC DAQmxGetAIEddyCurrentProxProbeUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIEddyCurrentProxProbeUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIEddyCurrentProxProbeUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIEddyCurrentProxProbeUnits gets the Analog Input >> Position >> Eddy Current Proximity Probe >> Units property.

DAQmxSetAIEddyCurrentProxProbeUnits sets the Analog Input >> Position >> Eddy Current Proximity Probe >> Units property.

DAQmxResetAIEddyCurrentProxProbeUnits resets the Analog Input >> Position >> Eddy Current Proximity Probe >> Units property.


Get/Set/Reset RefTrig_AutoTrigEnable

int32 __CFUNC DAQmxGetRefTrigAutoTrigEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetRefTrigAutoTrigEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetRefTrigAutoTrigEnable(TaskHandle taskHandle);

Purpose

DAQmxGetRefTrigAutoTrigEnable gets the Reference >> Auto Trigger >> Enable property.

DAQmxSetRefTrigAutoTrigEnable sets the Reference >> Auto Trigger >> Enable property.

DAQmxResetRefTrigAutoTrigEnable resets the Reference >> Auto Trigger >> Enable property.


Get/Set/Reset RefTrig_AutoTriggered

int32 __CFUNC DAQmxGetRefTrigAutoTriggered(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetRefTrigAutoTriggered gets the Reference >> Auto Triggered property.


Get/Set/Reset PhysicalChan_AO_ManualControl_ShortDetected

int32 __CFUNC DAQmxGetPhysicalChanAOManualControlShortDetected(const char physicalChannel[], bool32 *data);

Purpose

DAQmxGetPhysicalChanAOManualControlShortDetected gets the Analog Output >> Advanced >> Manual Control >> Short Detected property.


Get/Set/Reset Logging_FilePath

int32 __CFUNC DAQmxGetLoggingFilePath(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetLoggingFilePath(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetLoggingFilePath(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingFilePath gets the Logging >> File Path property.

DAQmxSetLoggingFilePath sets the Logging >> File Path property.

DAQmxResetLoggingFilePath resets the Logging >> File Path property.


Get/Set/Reset Logging_Mode

int32 __CFUNC DAQmxGetLoggingMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetLoggingMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetLoggingMode(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingMode gets the Logging >> Mode property.

DAQmxSetLoggingMode sets the Logging >> Mode property.

DAQmxResetLoggingMode resets the Logging >> Mode property.


Get/Set/Reset Logging_TDMS_GroupName

int32 __CFUNC DAQmxGetLoggingTDMSGroupName(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetLoggingTDMSGroupName(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetLoggingTDMSGroupName(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingTDMSGroupName gets the Logging >> TDMS >> Group Name property.

DAQmxSetLoggingTDMSGroupName sets the Logging >> TDMS >> Group Name property.

DAQmxResetLoggingTDMSGroupName resets the Logging >> TDMS >> Group Name property.


Get/Set/Reset Logging_TDMS_Operation

int32 __CFUNC DAQmxGetLoggingTDMSOperation(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetLoggingTDMSOperation(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetLoggingTDMSOperation(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingTDMSOperation gets the Logging >> TDMS >> Operation property.

DAQmxSetLoggingTDMSOperation sets the Logging >> TDMS >> Operation property.

DAQmxResetLoggingTDMSOperation resets the Logging >> TDMS >> Operation property.


Get/Set/Reset CO_EnableInitialDelayOnRetrigger

int32 __CFUNC DAQmxGetCOEnableInitialDelayOnRetrigger(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCOEnableInitialDelayOnRetrigger(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCOEnableInitialDelayOnRetrigger(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOEnableInitialDelayOnRetrigger gets the Counter Output >> General Properties >> More >> Enable Initial Delay on Retrigger property.

DAQmxSetCOEnableInitialDelayOnRetrigger sets the Counter Output >> General Properties >> More >> Enable Initial Delay on Retrigger property.

DAQmxResetCOEnableInitialDelayOnRetrigger resets the Counter Output >> General Properties >> More >> Enable Initial Delay on Retrigger property.


Get/Set/Reset CO_UseOnlyOnBrdMem

int32 __CFUNC DAQmxGetCOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOUseOnlyOnBrdMem gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxSetCOUseOnlyOnBrdMem sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxResetCOUseOnlyOnBrdMem resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.


Get/Set/Reset CO_DataXferMech

int32 __CFUNC DAQmxGetCODataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCODataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCODataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCODataXferMech gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetCODataXferMech sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetCODataXferMech resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset CO_DataXferReqCond

int32 __CFUNC DAQmxGetCODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCODataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCODataXferReqCond gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetCODataXferReqCond sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetCODataXferReqCond resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset CI_Freq_EnableAveraging

int32 __CFUNC DAQmxGetCIFreqEnableAveraging(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIFreqEnableAveraging(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIFreqEnableAveraging(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqEnableAveraging gets the Counter Input >> Frequency >> Measurement Specifications >> Enable Averaging property.

DAQmxSetCIFreqEnableAveraging sets the Counter Input >> Frequency >> Measurement Specifications >> Enable Averaging property.

DAQmxResetCIFreqEnableAveraging resets the Counter Input >> Frequency >> Measurement Specifications >> Enable Averaging property.


Get/Set/Reset CI_Period_EnableAveraging

int32 __CFUNC DAQmxGetCIPeriodEnableAveraging(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPeriodEnableAveraging(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPeriodEnableAveraging(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodEnableAveraging gets the Counter Input >> Period >> Measurement Specifications >> Enable Averaging property.

DAQmxSetCIPeriodEnableAveraging sets the Counter Input >> Period >> Measurement Specifications >> Enable Averaging property.

DAQmxResetCIPeriodEnableAveraging resets the Counter Input >> Period >> Measurement Specifications >> Enable Averaging property.


Get/Set/Reset CI_MemMapEnable

int32 __CFUNC DAQmxGetCIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIMemMapEnable gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetCIMemMapEnable sets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetCIMemMapEnable resets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset CO_MemMapEnable

int32 __CFUNC DAQmxGetCOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCOMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOMemMapEnable gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetCOMemMapEnable sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetCOMemMapEnable resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset DI_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetDIDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDIDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetDIDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigFltrTimebaseSrc gets the Digital Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetDIDigFltrTimebaseSrc sets the Digital Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetDIDigFltrTimebaseSrc resets the Digital Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset DI_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetDIDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetDIDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetDIDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigFltrTimebaseRate gets the Digital Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetDIDigFltrTimebaseRate sets the Digital Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetDIDigFltrTimebaseRate resets the Digital Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset DI_DigSync_Enable

int32 __CFUNC DAQmxGetDIDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDIDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDIDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigSyncEnable gets the Digital Input >> Digital Synchronization >> Enable property.

DAQmxSetDIDigSyncEnable sets the Digital Input >> Digital Synchronization >> Enable property.

DAQmxResetDIDigSyncEnable resets the Digital Input >> Digital Synchronization >> Enable property.


Get/Set/Reset DigEdge_RefTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetDigEdgeRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigDigFltrEnable gets the Reference >> Digital Edge >> Digital Filter >> Enable property.

DAQmxSetDigEdgeRefTrigDigFltrEnable sets the Reference >> Digital Edge >> Digital Filter >> Enable property.

DAQmxResetDigEdgeRefTrigDigFltrEnable resets the Reference >> Digital Edge >> Digital Filter >> Enable property.


Get/Set/Reset DigEdge_RefTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetDigEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigDigFltrMinPulseWidth gets the Reference >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetDigEdgeRefTrigDigFltrMinPulseWidth sets the Reference >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetDigEdgeRefTrigDigFltrMinPulseWidth resets the Reference >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset DigEdge_RefTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetDigEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigDigFltrTimebaseSrc gets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxSetDigEdgeRefTrigDigFltrTimebaseSrc sets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxResetDigEdgeRefTrigDigFltrTimebaseSrc resets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset DigEdge_RefTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetDigEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigDigFltrTimebaseRate gets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxSetDigEdgeRefTrigDigFltrTimebaseRate sets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxResetDigEdgeRefTrigDigFltrTimebaseRate resets the Reference >> Digital Edge >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset DigEdge_RefTrig_DigSync_Enable

int32 __CFUNC DAQmxGetDigEdgeRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigDigSyncEnable gets the Reference >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxSetDigEdgeRefTrigDigSyncEnable sets the Reference >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxResetDigEdgeRefTrigDigSyncEnable resets the Reference >> Digital Edge >> Digital Synchronization >> Enable property.


Get/Set/Reset AIConv_DigFltr_Enable

int32 __CFUNC DAQmxGetAIConvDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAIConvDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvDigFltrEnable gets the More >> AI Convert >> Digital Filter >> Enable property.

DAQmxSetAIConvDigFltrEnable sets the More >> AI Convert >> Digital Filter >> Enable property.

DAQmxResetAIConvDigFltrEnable resets the More >> AI Convert >> Digital Filter >> Enable property.


Get/Set/Reset AIConv_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAIConvDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAIConvDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvDigFltrMinPulseWidth gets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAIConvDigFltrMinPulseWidth sets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAIConvDigFltrMinPulseWidth resets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AIConv_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAIConvDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIConvDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAIConvDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvDigFltrTimebaseSrc gets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.

DAQmxSetAIConvDigFltrTimebaseSrc sets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.

DAQmxResetAIConvDigFltrTimebaseSrc resets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AIConv_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAIConvDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAIConvDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvDigFltrTimebaseRate gets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAIConvDigFltrTimebaseRate sets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAIConvDigFltrTimebaseRate resets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AIConv_DigSync_Enable

int32 __CFUNC DAQmxGetAIConvDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAIConvDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAIConvDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvDigSyncEnable gets the More >> AI Convert >> Digital Synchronization >> Enable property.

DAQmxSetAIConvDigSyncEnable sets the More >> AI Convert >> Digital Synchronization >> Enable property.

DAQmxResetAIConvDigSyncEnable resets the More >> AI Convert >> Digital Synchronization >> Enable property.


Get/Set/Reset AnlgEdge_StartTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigDigFltrEnable gets the Start >> Analog Edge >> Digital Filter >> Enable property.

DAQmxSetAnlgEdgeStartTrigDigFltrEnable sets the Start >> Analog Edge >> Digital Filter >> Enable property.

DAQmxResetAnlgEdgeStartTrigDigFltrEnable resets the Start >> Analog Edge >> Digital Filter >> Enable property.


Get/Set/Reset AnlgEdge_StartTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigDigFltrMinPulseWidth gets the Start >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgEdgeStartTrigDigFltrMinPulseWidth sets the Start >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgEdgeStartTrigDigFltrMinPulseWidth resets the Start >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgEdge_StartTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseSrc gets the Start >> Analog Edge >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseSrc sets the Start >> Analog Edge >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseSrc resets the Start >> Analog Edge >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AnlgEdge_StartTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigDigFltrTimebaseRate gets the Start >> Analog Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgEdgeStartTrigDigFltrTimebaseRate sets the Start >> Analog Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgEdgeStartTrigDigFltrTimebaseRate resets the Start >> Analog Edge >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgEdge_StartTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigDigSyncEnable gets the Start >> Analog Edge >> Digital Synchronization >> Enable property.

DAQmxSetAnlgEdgeStartTrigDigSyncEnable sets the Start >> Analog Edge >> Digital Synchronization >> Enable property.

DAQmxResetAnlgEdgeStartTrigDigSyncEnable resets the Start >> Analog Edge >> Digital Synchronization >> Enable property.


Get/Set/Reset AnlgEdge_RefTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigDigFltrEnable gets the Reference >> Analog Edge >> Digital Filter >> Enable property.

DAQmxSetAnlgEdgeRefTrigDigFltrEnable sets the Reference >> Analog Edge >> Digital Filter >> Enable property.

DAQmxResetAnlgEdgeRefTrigDigFltrEnable resets the Reference >> Analog Edge >> Digital Filter >> Enable property.


Get/Set/Reset AnlgEdge_RefTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigDigFltrMinPulseWidth gets the Reference >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgEdgeRefTrigDigFltrMinPulseWidth sets the Reference >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgEdgeRefTrigDigFltrMinPulseWidth resets the Reference >> Analog Edge >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgEdge_RefTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseSrc gets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseSrc sets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseSrc resets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AnlgEdge_RefTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigDigFltrTimebaseRate gets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgEdgeRefTrigDigFltrTimebaseRate sets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgEdgeRefTrigDigFltrTimebaseRate resets the Reference >> Analog Edge >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgEdge_RefTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigDigSyncEnable gets the Reference >> Analog Edge >> Digital Synchronization >> Enable property.

DAQmxSetAnlgEdgeRefTrigDigSyncEnable sets the Reference >> Analog Edge >> Digital Synchronization >> Enable property.

DAQmxResetAnlgEdgeRefTrigDigSyncEnable resets the Reference >> Analog Edge >> Digital Synchronization >> Enable property.


Get/Set/Reset AnlgWin_RefTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgWinRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigDigFltrEnable gets the Reference >> Analog Window >> Digital Filter >> Enable property.

DAQmxSetAnlgWinRefTrigDigFltrEnable sets the Reference >> Analog Window >> Digital Filter >> Enable property.

DAQmxResetAnlgWinRefTrigDigFltrEnable resets the Reference >> Analog Window >> Digital Filter >> Enable property.


Get/Set/Reset AnlgWin_RefTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgWinRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigDigFltrMinPulseWidth gets the Reference >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgWinRefTrigDigFltrMinPulseWidth sets the Reference >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgWinRefTrigDigFltrMinPulseWidth resets the Reference >> Analog Window >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgWin_RefTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgWinRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigDigFltrTimebaseSrc gets the Reference >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgWinRefTrigDigFltrTimebaseSrc sets the Reference >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgWinRefTrigDigFltrTimebaseSrc resets the Reference >> Analog Window >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AnlgWin_RefTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgWinRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigDigFltrTimebaseRate gets the Reference >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgWinRefTrigDigFltrTimebaseRate sets the Reference >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgWinRefTrigDigFltrTimebaseRate resets the Reference >> Analog Window >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgWin_RefTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgWinRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigDigSyncEnable gets the Reference >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxSetAnlgWinRefTrigDigSyncEnable sets the Reference >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxResetAnlgWinRefTrigDigSyncEnable resets the Reference >> Analog Window >> Digital Synchronization >> Enable property.


Get/Set/Reset AnlgLvl_PauseTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigDigFltrEnable gets the More >> Pause >> Analog Level >> Digital Filter >> Enable property.

DAQmxSetAnlgLvlPauseTrigDigFltrEnable sets the More >> Pause >> Analog Level >> Digital Filter >> Enable property.

DAQmxResetAnlgLvlPauseTrigDigFltrEnable resets the More >> Pause >> Analog Level >> Digital Filter >> Enable property.


Get/Set/Reset AnlgLvl_PauseTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigDigFltrMinPulseWidth gets the More >> Pause >> Analog Level >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgLvlPauseTrigDigFltrMinPulseWidth sets the More >> Pause >> Analog Level >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgLvlPauseTrigDigFltrMinPulseWidth resets the More >> Pause >> Analog Level >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgLvl_PauseTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseSrc gets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseSrc sets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseSrc resets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AnlgLvl_PauseTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigDigFltrTimebaseRate gets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgLvlPauseTrigDigFltrTimebaseRate sets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgLvlPauseTrigDigFltrTimebaseRate resets the More >> Pause >> Analog Level >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgLvl_PauseTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigDigSyncEnable gets the More >> Pause >> Analog Level >> Digital Synchronization >> Enable property.

DAQmxSetAnlgLvlPauseTrigDigSyncEnable sets the More >> Pause >> Analog Level >> Digital Synchronization >> Enable property.

DAQmxResetAnlgLvlPauseTrigDigSyncEnable resets the More >> Pause >> Analog Level >> Digital Synchronization >> Enable property.


Get/Set/Reset AnlgWin_PauseTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgWinPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigDigFltrEnable gets the More >> Pause >> Analog Window >> Digital Filter >> Enable property.

DAQmxSetAnlgWinPauseTrigDigFltrEnable sets the More >> Pause >> Analog Window >> Digital Filter >> Enable property.

DAQmxResetAnlgWinPauseTrigDigFltrEnable resets the More >> Pause >> Analog Window >> Digital Filter >> Enable property.


Get/Set/Reset AnlgWin_PauseTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgWinPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigDigFltrMinPulseWidth gets the More >> Pause >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgWinPauseTrigDigFltrMinPulseWidth sets the More >> Pause >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgWinPauseTrigDigFltrMinPulseWidth resets the More >> Pause >> Analog Window >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgWin_PauseTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgWinPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigDigFltrTimebaseSrc gets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgWinPauseTrigDigFltrTimebaseSrc sets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgWinPauseTrigDigFltrTimebaseSrc resets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AnlgWin_PauseTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgWinPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigDigFltrTimebaseRate gets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgWinPauseTrigDigFltrTimebaseRate sets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgWinPauseTrigDigFltrTimebaseRate resets the More >> Pause >> Analog Window >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgWin_PauseTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgWinPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigDigSyncEnable gets the More >> Pause >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxSetAnlgWinPauseTrigDigSyncEnable sets the More >> Pause >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxResetAnlgWinPauseTrigDigSyncEnable resets the More >> Pause >> Analog Window >> Digital Synchronization >> Enable property.


Get/Set/Reset ChangeDetect_DI_Tristate

int32 __CFUNC DAQmxGetChangeDetectDITristate(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetChangeDetectDITristate(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetChangeDetectDITristate(TaskHandle taskHandle);

Purpose

DAQmxGetChangeDetectDITristate gets the Change Detection >> Digital Input >> Tristate property.

DAQmxSetChangeDetectDITristate sets the Change Detection >> Digital Input >> Tristate property.

DAQmxResetChangeDetectDITristate resets the Change Detection >> Digital Input >> Tristate property.


Get/Set/Reset CI_DataXferReqCond

int32 __CFUNC DAQmxGetCIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIDataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDataXferReqCond gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetCIDataXferReqCond sets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetCIDataXferReqCond resets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset SampClk_OverrunBehavior

int32 __CFUNC DAQmxGetSampClkOverrunBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampClkOverrunBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampClkOverrunBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkOverrunBehavior gets the Sample Clock >> Overrun Behavior property.

DAQmxSetSampClkOverrunBehavior sets the Sample Clock >> Overrun Behavior property.

DAQmxResetSampClkOverrunBehavior resets the Sample Clock >> Overrun Behavior property.


Get/Set/Reset Implicit_UnderflowBehavior

int32 __CFUNC DAQmxGetImplicitUnderflowBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetImplicitUnderflowBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetImplicitUnderflowBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetImplicitUnderflowBehavior gets the Implicit >> Underflow Behavior property.

DAQmxSetImplicitUnderflowBehavior sets the Implicit >> Underflow Behavior property.

DAQmxResetImplicitUnderflowBehavior resets the Implicit >> Underflow Behavior property.


Get/Set/Reset DI_DigFltr_EnableBusMode

int32 __CFUNC DAQmxGetDIDigFltrEnableBusMode(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDIDigFltrEnableBusMode(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDIDigFltrEnableBusMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigFltrEnableBusMode gets the Digital Input >> Digital Filter >> Enable Bus Mode property.

DAQmxSetDIDigFltrEnableBusMode sets the Digital Input >> Digital Filter >> Enable Bus Mode property.

DAQmxResetDIDigFltrEnableBusMode resets the Digital Input >> Digital Filter >> Enable Bus Mode property.


Get/Set/Reset AnlgWin_StartTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetAnlgWinStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigDigFltrEnable gets the Start >> Analog Window >> Digital Filter >> Enable property.

DAQmxSetAnlgWinStartTrigDigFltrEnable sets the Start >> Analog Window >> Digital Filter >> Enable property.

DAQmxResetAnlgWinStartTrigDigFltrEnable resets the Start >> Analog Window >> Digital Filter >> Enable property.


Get/Set/Reset AnlgWin_StartTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAnlgWinStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigDigFltrMinPulseWidth gets the Start >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAnlgWinStartTrigDigFltrMinPulseWidth sets the Start >> Analog Window >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAnlgWinStartTrigDigFltrMinPulseWidth resets the Start >> Analog Window >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Pulse_Freq_DigSync_Enable

int32 __CFUNC DAQmxGetCIPulseFreqDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseFreqDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqDigSyncEnable gets the Counter Input >> Pulse >> Frequency >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIPulseFreqDigSyncEnable sets the Counter Input >> Pulse >> Frequency >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIPulseFreqDigSyncEnable resets the Counter Input >> Pulse >> Frequency >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Pulse_Freq_Units

int32 __CFUNC DAQmxGetCIPulseFreqUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseFreqUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqUnits gets the Counter Input >> Pulse >> Frequency >> Units property.

DAQmxSetCIPulseFreqUnits sets the Counter Input >> Pulse >> Frequency >> Units property.

DAQmxResetCIPulseFreqUnits resets the Counter Input >> Pulse >> Frequency >> Units property.


Get/Set/Reset CI_Pulse_Time_Term

int32 __CFUNC DAQmxGetCIPulseTimeTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseTimeTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseTimeTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeTerm gets the Counter Input >> Pulse >> Time >> Input >> Terminal property.

DAQmxSetCIPulseTimeTerm sets the Counter Input >> Pulse >> Time >> Input >> Terminal property.

DAQmxResetCIPulseTimeTerm resets the Counter Input >> Pulse >> Time >> Input >> Terminal property.


Get/Set/Reset CI_Pulse_Time_StartEdge

int32 __CFUNC DAQmxGetCIPulseTimeStartEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeStartEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTimeStartEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeStartEdge gets the Counter Input >> Pulse >> Time >> Starting Edge property.

DAQmxSetCIPulseTimeStartEdge sets the Counter Input >> Pulse >> Time >> Starting Edge property.

DAQmxResetCIPulseTimeStartEdge resets the Counter Input >> Pulse >> Time >> Starting Edge property.


Get/Set/Reset CI_Pulse_Time_DigFltr_Enable

int32 __CFUNC DAQmxGetCIPulseTimeDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseTimeDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeDigFltrEnable gets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Enable property.

DAQmxSetCIPulseTimeDigFltrEnable sets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Enable property.

DAQmxResetCIPulseTimeDigFltrEnable resets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Pulse_Time_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIPulseTimeDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseTimeDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseTimeDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeDigFltrMinPulseWidth gets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIPulseTimeDigFltrMinPulseWidth sets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIPulseTimeDigFltrMinPulseWidth resets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AnlgWin_StartTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAnlgWinStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigDigFltrTimebaseSrc gets the Start >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxSetAnlgWinStartTrigDigFltrTimebaseSrc sets the Start >> Analog Window >> Digital Filter >> Timebase >> Source property.

DAQmxResetAnlgWinStartTrigDigFltrTimebaseSrc resets the Start >> Analog Window >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Pulse_Ticks_DigSync_Enable

int32 __CFUNC DAQmxGetCIPulseTicksDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseTicksDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseTicksDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksDigSyncEnable gets the Counter Input >> Pulse >> Ticks >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIPulseTicksDigSyncEnable sets the Counter Input >> Pulse >> Ticks >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIPulseTicksDigSyncEnable resets the Counter Input >> Pulse >> Ticks >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset SampClk_Term

int32 __CFUNC DAQmxGetSampClkTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetSampClkTerm gets the Sample Clock >> Terminal property.


Get/Set/Reset SampClkTimebase_Term

int32 __CFUNC DAQmxGetSampClkTimebaseTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetSampClkTimebaseTerm gets the Sample Clock >> Timebase >> Terminal property.


Get/Set/Reset StartTrig_Term

int32 __CFUNC DAQmxGetStartTrigTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetStartTrigTerm gets the Start >> Terminal property.


Get/Set/Reset RefTrig_Term

int32 __CFUNC DAQmxGetRefTrigTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetRefTrigTerm gets the Reference >> Terminal property.


Get/Set/Reset AnlgWin_StartTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAnlgWinStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigDigFltrTimebaseRate gets the Start >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAnlgWinStartTrigDigFltrTimebaseRate sets the Start >> Analog Window >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAnlgWinStartTrigDigFltrTimebaseRate resets the Start >> Analog Window >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AnlgWin_StartTrig_DigSync_Enable

int32 __CFUNC DAQmxGetAnlgWinStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigDigSyncEnable gets the Start >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxSetAnlgWinStartTrigDigSyncEnable sets the Start >> Analog Window >> Digital Synchronization >> Enable property.

DAQmxResetAnlgWinStartTrigDigSyncEnable resets the Start >> Analog Window >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Pulse_Freq_Term

int32 __CFUNC DAQmxGetCIPulseFreqTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseFreqTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseFreqTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqTerm gets the Counter Input >> Pulse >> Frequency >> Input >> Terminal property.

DAQmxSetCIPulseFreqTerm sets the Counter Input >> Pulse >> Frequency >> Input >> Terminal property.

DAQmxResetCIPulseFreqTerm resets the Counter Input >> Pulse >> Frequency >> Input >> Terminal property.


Get/Set/Reset CI_Pulse_Freq_Start_Edge

int32 __CFUNC DAQmxGetCIPulseFreqStartEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqStartEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseFreqStartEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqStartEdge gets the Counter Input >> Pulse >> Frequency >> Starting Edge property.

DAQmxSetCIPulseFreqStartEdge sets the Counter Input >> Pulse >> Frequency >> Starting Edge property.

DAQmxResetCIPulseFreqStartEdge resets the Counter Input >> Pulse >> Frequency >> Starting Edge property.


Get/Set/Reset Dev_CO_SampClkSupported

int32 __CFUNC DAQmxGetDevCOSampClkSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevCOSampClkSupported gets the I/O Type >> Counter Output >> Timing >> Sample Clock Supported property.


Get/Set/Reset CI_Pulse_Freq_DigFltr_Enable

int32 __CFUNC DAQmxGetCIPulseFreqDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseFreqDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqDigFltrEnable gets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Enable property.

DAQmxSetCIPulseFreqDigFltrEnable sets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Enable property.

DAQmxResetCIPulseFreqDigFltrEnable resets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Enable property.


Get/Set/Reset AI_ADCCustomTimingMode

int32 __CFUNC DAQmxGetAIADCCustomTimingMode(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIADCCustomTimingMode(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIADCCustomTimingMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIADCCustomTimingMode gets the Analog Input >> General Properties >> Digitizer/ADC >> Custom Timing Mode property.

DAQmxSetAIADCCustomTimingMode sets the Analog Input >> General Properties >> Digitizer/ADC >> Custom Timing Mode property.

DAQmxResetAIADCCustomTimingMode resets the Analog Input >> General Properties >> Digitizer/ADC >> Custom Timing Mode property.


Get/Set/Reset Dev_Accessory_ProductTypes

int32 __CFUNC DAQmxGetDevAccessoryProductTypes(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevAccessoryProductTypes gets the Identification >> Accessory >> Product Types property.


Get/Set/Reset Dev_Accessory_ProductNums

int32 __CFUNC DAQmxGetDevAccessoryProductNums(const char device[], uInt32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAccessoryProductNums gets the Identification >> Accessory >> Product Numbers property.


Get/Set/Reset Dev_Accessory_SerialNums

int32 __CFUNC DAQmxGetDevAccessorySerialNums(const char device[], uInt32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAccessorySerialNums gets the Identification >> Accessory >> Serial Numbers property.


Get/Set/Reset CI_Pulse_Freq_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIPulseFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqDigFltrMinPulseWidth gets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIPulseFreqDigFltrMinPulseWidth sets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIPulseFreqDigFltrMinPulseWidth resets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AI_Bridge_ShuntCal_ShuntCalBResistance

int32 __CFUNC DAQmxGetAIBridgeShuntCalShuntCalBResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalShuntCalBResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalShuntCalBResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalShuntCalBResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Resistor Value property.

DAQmxSetAIBridgeShuntCalShuntCalBResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Resistor Value property.

DAQmxResetAIBridgeShuntCalShuntCalBResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Resistor Value property.


Get/Set/Reset AI_Bridge_ShuntCal_ShuntCalBActualResistance

int32 __CFUNC DAQmxGetAIBridgeShuntCalShuntCalBActualResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalShuntCalBActualResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalShuntCalBActualResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalShuntCalBActualResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Actual Resistor Value property.

DAQmxSetAIBridgeShuntCalShuntCalBActualResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Actual Resistor Value property.

DAQmxResetAIBridgeShuntCalShuntCalBActualResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal B Actual Resistor Value property.


Get/Set/Reset SyncPulse_ResetTime

int32 __CFUNC DAQmxGetSyncPulseResetTime(TaskHandle taskHandle, float64 *data);

Purpose

DAQmxGetSyncPulseResetTime gets the More >> Synchronization Pulse >> Reset Time property.


Get/Set/Reset SyncPulse_ResetDelay

int32 __CFUNC DAQmxGetSyncPulseResetDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSyncPulseResetDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSyncPulseResetDelay(TaskHandle taskHandle);

Purpose

DAQmxGetSyncPulseResetDelay gets the More >> Synchronization Pulse >> Reset Delay property.

DAQmxSetSyncPulseResetDelay sets the More >> Synchronization Pulse >> Reset Delay property.

DAQmxResetSyncPulseResetDelay resets the More >> Synchronization Pulse >> Reset Delay property.


Get/Set/Reset SyncClk_Interval

int32 __CFUNC DAQmxGetSyncClkInterval(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetSyncClkInterval(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetSyncClkInterval(TaskHandle taskHandle);

Purpose

DAQmxGetSyncClkInterval gets the More >> Synchronization Clock >> Interval property.

DAQmxSetSyncClkInterval sets the More >> Synchronization Clock >> Interval property.

DAQmxResetSyncClkInterval resets the More >> Synchronization Clock >> Interval property.


Get/Set/Reset ArmStart_Term

int32 __CFUNC DAQmxGetArmStartTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetArmStartTerm gets the More >> Arm Start >> Terminal property.


Get/Set/Reset CI_Pulse_Freq_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIPulseFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqDigFltrTimebaseSrc gets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIPulseFreqDigFltrTimebaseSrc sets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIPulseFreqDigFltrTimebaseSrc resets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AI_Bridge_TwoPointLin_First_ElectricalVal

int32 __CFUNC DAQmxGetAIBridgeTwoPointLinFirstElectricalVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeTwoPointLinFirstElectricalVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeTwoPointLinFirstElectricalVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTwoPointLinFirstElectricalVal gets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Electrical Value property.

DAQmxSetAIBridgeTwoPointLinFirstElectricalVal sets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Electrical Value property.

DAQmxResetAIBridgeTwoPointLinFirstElectricalVal resets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Electrical Value property.


Get/Set/Reset AI_Bridge_TwoPointLin_First_PhysicalVal

int32 __CFUNC DAQmxGetAIBridgeTwoPointLinFirstPhysicalVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeTwoPointLinFirstPhysicalVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeTwoPointLinFirstPhysicalVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTwoPointLinFirstPhysicalVal gets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Physical Value property.

DAQmxSetAIBridgeTwoPointLinFirstPhysicalVal sets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Physical Value property.

DAQmxResetAIBridgeTwoPointLinFirstPhysicalVal resets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> First >> Physical Value property.


Get/Set/Reset AI_Bridge_TwoPointLin_Second_ElectricalVal

int32 __CFUNC DAQmxGetAIBridgeTwoPointLinSecondElectricalVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeTwoPointLinSecondElectricalVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeTwoPointLinSecondElectricalVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTwoPointLinSecondElectricalVal gets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Electrical Value property.

DAQmxSetAIBridgeTwoPointLinSecondElectricalVal sets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Electrical Value property.

DAQmxResetAIBridgeTwoPointLinSecondElectricalVal resets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Electrical Value property.


Get/Set/Reset AI_Bridge_TwoPointLin_Second_PhysicalVal

int32 __CFUNC DAQmxGetAIBridgeTwoPointLinSecondPhysicalVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeTwoPointLinSecondPhysicalVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeTwoPointLinSecondPhysicalVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTwoPointLinSecondPhysicalVal gets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Physical Value property.

DAQmxSetAIBridgeTwoPointLinSecondPhysicalVal sets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Physical Value property.

DAQmxResetAIBridgeTwoPointLinSecondPhysicalVal resets the Analog Input >> Bridge >> Scaling Parameters >> Two-Point Linear >> Second >> Physical Value property.


Get/Set/Reset AI_Bridge_Table_ElectricalVals

int32 __CFUNC DAQmxGetAIBridgeTableElectricalVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIBridgeTableElectricalVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIBridgeTableElectricalVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTableElectricalVals gets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Electrical Values property.

DAQmxSetAIBridgeTableElectricalVals sets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Electrical Values property.

DAQmxResetAIBridgeTableElectricalVals resets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Electrical Values property.


Get/Set/Reset AI_Bridge_Table_PhysicalVals

int32 __CFUNC DAQmxGetAIBridgeTablePhysicalVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIBridgeTablePhysicalVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIBridgeTablePhysicalVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeTablePhysicalVals gets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Physical Values property.

DAQmxSetAIBridgeTablePhysicalVals sets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Physical Values property.

DAQmxResetAIBridgeTablePhysicalVals resets the Analog Input >> Bridge >> Scaling Parameters >> Table >> Physical Values property.


Get/Set/Reset CI_Pulse_Freq_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIPulseFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqDigFltrTimebaseRate gets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIPulseFreqDigFltrTimebaseRate sets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIPulseFreqDigFltrTimebaseRate resets the Counter Input >> Pulse >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset SwitchChan_AnlgBusSharingEnable

int32 __CFUNC DAQmxGetSwitchChanAnlgBusSharingEnable(const char switchChannelName[], bool32 *data);

int32 __CFUNC DAQmxSetSwitchChanAnlgBusSharingEnable(const char switchChannelName[], bool32 data);

Purpose

DAQmxGetSwitchChanAnlgBusSharingEnable gets the Deprecated >> Analog Bus Sharing Enable property.

DAQmxSetSwitchChanAnlgBusSharingEnable sets the Deprecated >> Analog Bus Sharing Enable property.


Get/Set/Reset CI_Pulse_Time_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIPulseTimeDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseTimeDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseTimeDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeDigFltrTimebaseSrc gets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIPulseTimeDigFltrTimebaseSrc sets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIPulseTimeDigFltrTimebaseSrc resets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Pulse_Time_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIPulseTimeDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseTimeDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseTimeDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeDigFltrTimebaseRate gets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIPulseTimeDigFltrTimebaseRate sets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIPulseTimeDigFltrTimebaseRate resets the Counter Input >> Pulse >> Time >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Pulse_Time_DigSync_Enable

int32 __CFUNC DAQmxGetCIPulseTimeDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseTimeDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeDigSyncEnable gets the Counter Input >> Pulse >> Time >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIPulseTimeDigSyncEnable sets the Counter Input >> Pulse >> Time >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIPulseTimeDigSyncEnable resets the Counter Input >> Pulse >> Time >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Pulse_Time_Units

int32 __CFUNC DAQmxGetCIPulseTimeUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTimeUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeUnits gets the Counter Input >> Pulse >> Time >> Units property.

DAQmxSetCIPulseTimeUnits sets the Counter Input >> Pulse >> Time >> Units property.

DAQmxResetCIPulseTimeUnits resets the Counter Input >> Pulse >> Time >> Units property.


Get/Set/Reset CI_Pulse_Ticks_Term

int32 __CFUNC DAQmxGetCIPulseTicksTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseTicksTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseTicksTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksTerm gets the Counter Input >> Pulse >> Ticks >> Input >> Terminal property.

DAQmxSetCIPulseTicksTerm sets the Counter Input >> Pulse >> Ticks >> Input >> Terminal property.

DAQmxResetCIPulseTicksTerm resets the Counter Input >> Pulse >> Ticks >> Input >> Terminal property.


Get/Set/Reset CI_Pulse_Ticks_StartEdge

int32 __CFUNC DAQmxGetCIPulseTicksStartEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTicksStartEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTicksStartEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksStartEdge gets the Counter Input >> Pulse >> Ticks >> Starting Edge property.

DAQmxSetCIPulseTicksStartEdge sets the Counter Input >> Pulse >> Ticks >> Starting Edge property.

DAQmxResetCIPulseTicksStartEdge resets the Counter Input >> Pulse >> Ticks >> Starting Edge property.


Get/Set/Reset CI_Pulse_Ticks_DigFltr_Enable

int32 __CFUNC DAQmxGetCIPulseTicksDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseTicksDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseTicksDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksDigFltrEnable gets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Enable property.

DAQmxSetCIPulseTicksDigFltrEnable sets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Enable property.

DAQmxResetCIPulseTicksDigFltrEnable resets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Pulse_Ticks_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIPulseTicksDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseTicksDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseTicksDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksDigFltrMinPulseWidth gets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIPulseTicksDigFltrMinPulseWidth sets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIPulseTicksDigFltrMinPulseWidth resets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Pulse_Ticks_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIPulseTicksDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseTicksDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseTicksDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksDigFltrTimebaseSrc gets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIPulseTicksDigFltrTimebaseSrc sets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIPulseTicksDigFltrTimebaseSrc resets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Pulse_Ticks_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIPulseTicksDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseTicksDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseTicksDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksDigFltrTimebaseRate gets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIPulseTicksDigFltrTimebaseRate sets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIPulseTicksDigFltrTimebaseRate resets the Counter Input >> Pulse >> Ticks >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset PauseTrig_Term

int32 __CFUNC DAQmxGetPauseTrigTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetPauseTrigTerm gets the More >> Pause >> Terminal property.


Get/Set/Reset Sys_NIDAQUpdateVersion

int32 __CFUNC DAQmxGetSysNIDAQUpdateVersion(uInt32 *data);

Purpose

DAQmxGetSysNIDAQUpdateVersion gets the System >> NI-DAQ Version >> Update property.


Get/Set/Reset Read_AccessoryInsertionOrRemovalDetected

int32 __CFUNC DAQmxGetReadAccessoryInsertionOrRemovalDetected(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadAccessoryInsertionOrRemovalDetected gets the Status >> Accessory >> Accessory Insertion or Removal Detected property.


Get/Set/Reset Read_DevsWithInsertedOrRemovedAccessories

int32 __CFUNC DAQmxGetReadDevsWithInsertedOrRemovedAccessories(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadDevsWithInsertedOrRemovedAccessories gets the Status >> Accessory >> Devices with Inserted or Removed Accessories property.


Get/Set/Reset AI_OpenThrmcplDetectEnable

int32 __CFUNC DAQmxGetAIOpenThrmcplDetectEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIOpenThrmcplDetectEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIOpenThrmcplDetectEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIOpenThrmcplDetectEnable gets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Open Thermocouple Detection Enable property.

DAQmxSetAIOpenThrmcplDetectEnable sets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Open Thermocouple Detection Enable property.

DAQmxResetAIOpenThrmcplDetectEnable resets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Open Thermocouple Detection Enable property.


Get/Set/Reset AI_Force_Units

int32 __CFUNC DAQmxGetAIForceUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIForceUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIForceUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIForceUnits gets the Analog Input >> Force >> Units property.

DAQmxSetAIForceUnits sets the Analog Input >> Force >> Units property.

DAQmxResetAIForceUnits resets the Analog Input >> Force >> Units property.


Get/Set/Reset AI_Pressure_Units

int32 __CFUNC DAQmxGetAIPressureUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIPressureUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIPressureUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIPressureUnits gets the Analog Input >> Pressure >> Units property.

DAQmxSetAIPressureUnits sets the Analog Input >> Pressure >> Units property.

DAQmxResetAIPressureUnits resets the Analog Input >> Pressure >> Units property.


Get/Set/Reset AI_Torque_Units

int32 __CFUNC DAQmxGetAITorqueUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAITorqueUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAITorqueUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAITorqueUnits gets the Analog Input >> Torque >> Units property.

DAQmxSetAITorqueUnits sets the Analog Input >> Torque >> Units property.

DAQmxResetAITorqueUnits resets the Analog Input >> Torque >> Units property.


Get/Set/Reset AI_Bridge_ShuntCal_ShuntCalAResistance

int32 __CFUNC DAQmxGetAIBridgeShuntCalShuntCalAResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalShuntCalAResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalShuntCalAResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalShuntCalAResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Resistor Value property.

DAQmxSetAIBridgeShuntCalShuntCalAResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Resistor Value property.

DAQmxResetAIBridgeShuntCalShuntCalAResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Resistor Value property.


Get/Set/Reset AI_Bridge_ShuntCal_ShuntCalAActualResistance

int32 __CFUNC DAQmxGetAIBridgeShuntCalShuntCalAActualResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalShuntCalAActualResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalShuntCalAActualResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalShuntCalAActualResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Actual Resistor Value property.

DAQmxSetAIBridgeShuntCalShuntCalAActualResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Actual Resistor Value property.

DAQmxResetAIBridgeShuntCalShuntCalAActualResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Actual Resistor Value property.


Get/Set/Reset Trigger_SyncType

int32 __CFUNC DAQmxGetTriggerSyncType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetTriggerSyncType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetTriggerSyncType(TaskHandle taskHandle);

Purpose

DAQmxGetTriggerSyncType gets the Advanced >> Synchronization Type property.

DAQmxSetTriggerSyncType sets the Advanced >> Synchronization Type property.

DAQmxResetTriggerSyncType resets the Advanced >> Synchronization Type property.


Get/Set/Reset AI_Force_IEPESensor_Sensitivity

int32 __CFUNC DAQmxGetAIForceIEPESensorSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIForceIEPESensorSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIForceIEPESensorSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIForceIEPESensorSensitivity gets the Analog Input >> Force >> IEPE Sensor >> Sensitivity property.

DAQmxSetAIForceIEPESensorSensitivity sets the Analog Input >> Force >> IEPE Sensor >> Sensitivity property.

DAQmxResetAIForceIEPESensorSensitivity resets the Analog Input >> Force >> IEPE Sensor >> Sensitivity property.


Get/Set/Reset AI_Force_IEPESensor_SensitivityUnits

int32 __CFUNC DAQmxGetAIForceIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIForceIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIForceIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIForceIEPESensorSensitivityUnits gets the Analog Input >> Force >> IEPE Sensor >> Sensitivity Units property.

DAQmxSetAIForceIEPESensorSensitivityUnits sets the Analog Input >> Force >> IEPE Sensor >> Sensitivity Units property.

DAQmxResetAIForceIEPESensorSensitivityUnits resets the Analog Input >> Force >> IEPE Sensor >> Sensitivity Units property.


Get/Set/Reset SyncPulse_Term

int32 __CFUNC DAQmxGetSyncPulseTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetSyncPulseTerm gets the More >> Synchronization Pulse >> Terminal property.


Get/Set/Reset AI_Bridge_InitialRatio

int32 __CFUNC DAQmxGetAIBridgeInitialRatio(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeInitialRatio(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeInitialRatio(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeInitialRatio gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Ratio property.

DAQmxSetAIBridgeInitialRatio sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Ratio property.

DAQmxResetAIBridgeInitialRatio resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Ratio property.


Get/Set/Reset AI_Bridge_ElectricalUnits

int32 __CFUNC DAQmxGetAIBridgeElectricalUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeElectricalUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeElectricalUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeElectricalUnits gets the Analog Input >> Bridge >> Scaling Parameters >> Electrical Units property.

DAQmxSetAIBridgeElectricalUnits sets the Analog Input >> Bridge >> Scaling Parameters >> Electrical Units property.

DAQmxResetAIBridgeElectricalUnits resets the Analog Input >> Bridge >> Scaling Parameters >> Electrical Units property.


Get/Set/Reset AI_Bridge_PhysicalUnits

int32 __CFUNC DAQmxGetAIBridgePhysicalUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgePhysicalUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgePhysicalUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgePhysicalUnits gets the Analog Input >> Bridge >> Scaling Parameters >> Physical Units property.

DAQmxSetAIBridgePhysicalUnits sets the Analog Input >> Bridge >> Scaling Parameters >> Physical Units property.

DAQmxResetAIBridgePhysicalUnits resets the Analog Input >> Bridge >> Scaling Parameters >> Physical Units property.


Get/Set/Reset AI_Bridge_ScaleType

int32 __CFUNC DAQmxGetAIBridgeScaleType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeScaleType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeScaleType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeScaleType gets the Analog Input >> Bridge >> Scaling Parameters >> Scale Type property.

DAQmxSetAIBridgeScaleType sets the Analog Input >> Bridge >> Scaling Parameters >> Scale Type property.

DAQmxResetAIBridgeScaleType resets the Analog Input >> Bridge >> Scaling Parameters >> Scale Type property.


Get/Set/Reset AI_Bridge_Poly_ForwardCoeff

int32 __CFUNC DAQmxGetAIBridgePolyForwardCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIBridgePolyForwardCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIBridgePolyForwardCoeff(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgePolyForwardCoeff gets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Forward Coefficients property.

DAQmxSetAIBridgePolyForwardCoeff sets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Forward Coefficients property.

DAQmxResetAIBridgePolyForwardCoeff resets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Forward Coefficients property.


Get/Set/Reset AI_Bridge_Poly_ReverseCoeff

int32 __CFUNC DAQmxGetAIBridgePolyReverseCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIBridgePolyReverseCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIBridgePolyReverseCoeff(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgePolyReverseCoeff gets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.

DAQmxSetAIBridgePolyReverseCoeff sets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.

DAQmxResetAIBridgePolyReverseCoeff resets the Analog Input >> Bridge >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.


Get/Set/Reset AI_Bridge_Units

int32 __CFUNC DAQmxGetAIBridgeUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeUnits gets the Analog Input >> Bridge >> Units property.

DAQmxSetAIBridgeUnits sets the Analog Input >> Bridge >> Units property.

DAQmxResetAIBridgeUnits resets the Analog Input >> Bridge >> Units property.


Get/Set/Reset CI_CountEdges_CountReset_Enable

int32 __CFUNC DAQmxGetCICountEdgesCountResetEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetEnable gets the Counter Input >> Count Edges >> Count Reset >> Enable property.

DAQmxSetCICountEdgesCountResetEnable sets the Counter Input >> Count Edges >> Count Reset >> Enable property.

DAQmxResetCICountEdgesCountResetEnable resets the Counter Input >> Count Edges >> Count Reset >> Enable property.


Get/Set/Reset CI_CountEdges_CountReset_ResetCount

int32 __CFUNC DAQmxGetCICountEdgesCountResetResetCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetResetCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetResetCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetResetCount gets the Counter Input >> Count Edges >> Count Reset >> Reset Count property.

DAQmxSetCICountEdgesCountResetResetCount sets the Counter Input >> Count Edges >> Count Reset >> Reset Count property.

DAQmxResetCICountEdgesCountResetResetCount resets the Counter Input >> Count Edges >> Count Reset >> Reset Count property.


Get/Set/Reset CI_CountEdges_CountReset_Term

int32 __CFUNC DAQmxGetCICountEdgesCountResetTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesCountResetTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetTerm gets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal property.

DAQmxSetCICountEdgesCountResetTerm sets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal property.

DAQmxResetCICountEdgesCountResetTerm resets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal property.


Get/Set/Reset CI_CountEdges_CountReset_ActiveEdge

int32 __CFUNC DAQmxGetCICountEdgesCountResetActiveEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetActiveEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetActiveEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetActiveEdge gets the Counter Input >> Count Edges >> Count Reset >> Active Edge property.

DAQmxSetCICountEdgesCountResetActiveEdge sets the Counter Input >> Count Edges >> Count Reset >> Active Edge property.

DAQmxResetCICountEdgesCountResetActiveEdge resets the Counter Input >> Count Edges >> Count Reset >> Active Edge property.


Get/Set/Reset CI_CountEdges_CountReset_DigFltr_Enable

int32 __CFUNC DAQmxGetCICountEdgesCountResetDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetDigFltrEnable gets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Enable property.

DAQmxSetCICountEdgesCountResetDigFltrEnable sets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Enable property.

DAQmxResetCICountEdgesCountResetDigFltrEnable resets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_CountEdges_CountReset_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCICountEdgesCountResetDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetDigFltrMinPulseWidth gets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCICountEdgesCountResetDigFltrMinPulseWidth sets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCICountEdgesCountResetDigFltrMinPulseWidth resets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_CountEdges_CountReset_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCICountEdgesCountResetDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesCountResetDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetDigFltrTimebaseSrc gets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCICountEdgesCountResetDigFltrTimebaseSrc sets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCICountEdgesCountResetDigFltrTimebaseSrc resets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_CountEdges_CountReset_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCICountEdgesCountResetDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetDigFltrTimebaseRate gets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCICountEdgesCountResetDigFltrTimebaseRate sets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCICountEdgesCountResetDigFltrTimebaseRate resets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_CountEdges_CountReset_DigSync_Enable

int32 __CFUNC DAQmxGetCICountEdgesCountResetDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetDigSyncEnable gets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCICountEdgesCountResetDigSyncEnable sets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCICountEdgesCountResetDigSyncEnable resets the Counter Input >> Count Edges >> Count Reset >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset AI_Thrmcpl_LeadOffsetVoltage

int32 __CFUNC DAQmxGetAIThrmcplLeadOffsetVoltage(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmcplLeadOffsetVoltage(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmcplLeadOffsetVoltage(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmcplLeadOffsetVoltage gets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Lead Offset Voltage property.

DAQmxSetAIThrmcplLeadOffsetVoltage sets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Lead Offset Voltage property.

DAQmxResetAIThrmcplLeadOffsetVoltage resets the Analog Input >> General Properties >> Signal Conditioning >> Thermocouple >> Lead Offset Voltage property.


Get/Set/Reset AI_RemoveFilterDelay

int32 __CFUNC DAQmxGetAIRemoveFilterDelay(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIRemoveFilterDelay(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIRemoveFilterDelay(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRemoveFilterDelay gets the Analog Input >> General Properties >> Filter >> Remove Filter Delay property.

DAQmxSetAIRemoveFilterDelay sets the Analog Input >> General Properties >> Filter >> Remove Filter Delay property.

DAQmxResetAIRemoveFilterDelay resets the Analog Input >> General Properties >> Filter >> Remove Filter Delay property.


Get/Set/Reset Logging_FileWriteSize

int32 __CFUNC DAQmxGetLoggingFileWriteSize(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetLoggingFileWriteSize(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetLoggingFileWriteSize(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingFileWriteSize gets the Logging >> File Write Size property.

DAQmxSetLoggingFileWriteSize sets the Logging >> File Write Size property.

DAQmxResetLoggingFileWriteSize resets the Logging >> File Write Size property.


Get/Set/Reset Logging_FilePreallocationSize

int32 __CFUNC DAQmxGetLoggingFilePreallocationSize(TaskHandle taskHandle, uInt64 *data);

int32 __CFUNC DAQmxSetLoggingFilePreallocationSize(TaskHandle taskHandle, uInt64 data);

int32 __CFUNC DAQmxResetLoggingFilePreallocationSize(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingFilePreallocationSize gets the Logging >> File Pre-allocation Size property.

DAQmxSetLoggingFilePreallocationSize sets the Logging >> File Pre-allocation Size property.

DAQmxResetLoggingFilePreallocationSize resets the Logging >> File Pre-allocation Size property.


Get/Set/Reset Dev_AI_BridgeRngs

int32 __CFUNC DAQmxGetDevAIBridgeRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIBridgeRngs gets the I/O Type >> Analog Input >> Bridge >> Ranges property.


Get/Set/Reset Dev_AI_SupportedMeasTypes

int32 __CFUNC DAQmxGetDevAISupportedMeasTypes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAISupportedMeasTypes gets the I/O Type >> Analog Input >> Measurement Types property.


Get/Set/Reset Dev_AO_SupportedOutputTypes

int32 __CFUNC DAQmxGetDevAOSupportedOutputTypes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAOSupportedOutputTypes gets the I/O Type >> Analog Output >> Output Types property.


Get/Set/Reset Dev_CI_SupportedMeasTypes

int32 __CFUNC DAQmxGetDevCISupportedMeasTypes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevCISupportedMeasTypes gets the I/O Type >> Counter Input >> Measurement Types property.


Get/Set/Reset Dev_CO_SupportedOutputTypes

int32 __CFUNC DAQmxGetDevCOSupportedOutputTypes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevCOSupportedOutputTypes gets the I/O Type >> Counter Output >> Output Types property.


Get/Set/Reset Dev_TEDS_HWTEDSSupported

int32 __CFUNC DAQmxGetDevTEDSHWTEDSSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevTEDSHWTEDSSupported gets the TEDS >> Hardware TEDS Supported property.


Get/Set/Reset PhysicalChan_AI_SupportedMeasTypes

int32 __CFUNC DAQmxGetPhysicalChanAISupportedMeasTypes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanAISupportedMeasTypes gets the Analog Input >> Measurement Types property.


Get/Set/Reset PhysicalChan_AI_InputSrcs

int32 __CFUNC DAQmxGetPhysicalChanAIInputSrcs(const char physicalChannel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetPhysicalChanAIInputSrcs gets the Analog Input >> Input Configuration >> Input Sources property.


Get/Set/Reset PhysicalChan_AO_SupportedOutputTypes

int32 __CFUNC DAQmxGetPhysicalChanAOSupportedOutputTypes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanAOSupportedOutputTypes gets the Analog Output >> Output Types property.


Get/Set/Reset PhysicalChan_CI_SupportedMeasTypes

int32 __CFUNC DAQmxGetPhysicalChanCISupportedMeasTypes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanCISupportedMeasTypes gets the Counter Input >> Measurement Types property.


Get/Set/Reset PhysicalChan_CO_SupportedOutputTypes

int32 __CFUNC DAQmxGetPhysicalChanCOSupportedOutputTypes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanCOSupportedOutputTypes gets the Counter Output >> Output Types property.


Get/Set/Reset Dev_AI_SampModes

int32 __CFUNC DAQmxGetDevAISampModes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAISampModes gets the I/O Type >> Analog Input >> Timing >> Sample Modes property.


Get/Set/Reset Dev_AO_SampModes

int32 __CFUNC DAQmxGetDevAOSampModes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAOSampModes gets the I/O Type >> Analog Output >> Timing >> Sample Modes property.


Get/Set/Reset Dev_CI_SampModes

int32 __CFUNC DAQmxGetDevCISampModes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevCISampModes gets the I/O Type >> Counter Input >> Timing >> Sample Modes property.


Get/Set/Reset Dev_CO_SampModes

int32 __CFUNC DAQmxGetDevCOSampModes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevCOSampModes gets the I/O Type >> Counter Output >> Timing >> SampleModes property.


Get/Set/Reset PhysicalChan_DI_SampModes

int32 __CFUNC DAQmxGetPhysicalChanDISampModes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanDISampModes gets the Digital Input >> Timing >> Sample Modes property.


Get/Set/Reset PhysicalChan_DO_SampModes

int32 __CFUNC DAQmxGetPhysicalChanDOSampModes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanDOSampModes gets the Digital Output >> Timing >> Sample Modes property.


Get/Set/Reset Logging_Pause

int32 __CFUNC DAQmxGetLoggingPause(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetLoggingPause(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetLoggingPause(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingPause gets the Logging >> Pause property.

DAQmxSetLoggingPause sets the Logging >> Pause property.

DAQmxResetLoggingPause resets the Logging >> Pause property.


Get/Set/Reset Logging_SampsPerFile

int32 __CFUNC DAQmxGetLoggingSampsPerFile(TaskHandle taskHandle, uInt64 *data);

int32 __CFUNC DAQmxSetLoggingSampsPerFile(TaskHandle taskHandle, uInt64 data);

int32 __CFUNC DAQmxResetLoggingSampsPerFile(TaskHandle taskHandle);

Purpose

DAQmxGetLoggingSampsPerFile gets the Logging >> Samples Per File property.

DAQmxSetLoggingSampsPerFile sets the Logging >> Samples Per File property.

DAQmxResetLoggingSampsPerFile resets the Logging >> Samples Per File property.


Get/Set/Reset Cal_AccConnectionCount

int32 __CFUNC DAQmxGetCalAccConnectionCount(const char deviceName[], uInt32 *data);

int32 __CFUNC DAQmxSetCalAccConnectionCount(const char deviceName[], uInt32 data);

Purpose

DAQmxGetCalAccConnectionCount gets the More >> Accessory Connection Count property.

DAQmxSetCalAccConnectionCount sets the More >> Accessory Connection Count property.


Get/Set/Reset Cal_RecommendedAccConnectionCountLimit

int32 __CFUNC DAQmxGetCalRecommendedAccConnectionCountLimit(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetCalRecommendedAccConnectionCountLimit gets the More >> Recommended Accessory Connection Count Limit property.


Get/Set/Reset AI_FilterDelay

int32 __CFUNC DAQmxGetAIFilterDelay(TaskHandle taskHandle, const char channel[], float64 *data);

Purpose

DAQmxGetAIFilterDelay gets the Analog Input >> General Properties >> Filter >> Filter Delay property.


Get/Set/Reset AI_AveragingWinSize

int32 __CFUNC DAQmxGetAIAveragingWinSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIAveragingWinSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIAveragingWinSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAveragingWinSize gets the Analog Input >> General Properties >> Filter >> Averaging Window Size property.

DAQmxSetAIAveragingWinSize sets the Analog Input >> General Properties >> Filter >> Averaging Window Size property.

DAQmxResetAIAveragingWinSize resets the Analog Input >> General Properties >> Filter >> Averaging Window Size property.


Get/Set/Reset AI_Velocity_Units

int32 __CFUNC DAQmxGetAIVelocityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIVelocityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIVelocityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVelocityUnits gets the Analog Input >> Velocity >> Units property.

DAQmxSetAIVelocityUnits sets the Analog Input >> Velocity >> Units property.

DAQmxResetAIVelocityUnits resets the Analog Input >> Velocity >> Units property.


Get/Set/Reset AI_Velocity_IEPESensor_dBRef

int32 __CFUNC DAQmxGetAIVelocityIEPESensordBRef(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIVelocityIEPESensordBRef(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIVelocityIEPESensordBRef(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVelocityIEPESensordBRef gets the Analog Input >> Velocity >> IEPE Sensor >> dB Reference property.

DAQmxSetAIVelocityIEPESensordBRef sets the Analog Input >> Velocity >> IEPE Sensor >> dB Reference property.

DAQmxResetAIVelocityIEPESensordBRef resets the Analog Input >> Velocity >> IEPE Sensor >> dB Reference property.


Get/Set/Reset AI_Velocity_IEPESensor_Sensitivity

int32 __CFUNC DAQmxGetAIVelocityIEPESensorSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIVelocityIEPESensorSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIVelocityIEPESensorSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVelocityIEPESensorSensitivity gets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity property.

DAQmxSetAIVelocityIEPESensorSensitivity sets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity property.

DAQmxResetAIVelocityIEPESensorSensitivity resets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity property.


Get/Set/Reset AI_Velocity_IEPESensor_SensitivityUnits

int32 __CFUNC DAQmxGetAIVelocityIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIVelocityIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIVelocityIEPESensorSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVelocityIEPESensorSensitivityUnits gets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity Units property.

DAQmxSetAIVelocityIEPESensorSensitivityUnits sets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity Units property.

DAQmxResetAIVelocityIEPESensorSensitivityUnits resets the Analog Input >> Velocity >> IEPE Sensor >> Sensitivity Units property.


Get/Set/Reset AI_StrainGage_ForceReadFromChan

int32 __CFUNC DAQmxGetAIStrainGageForceReadFromChan(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIStrainGageForceReadFromChan(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIStrainGageForceReadFromChan(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIStrainGageForceReadFromChan gets the Analog Input >> Strain >> Force Read From Channel property.

DAQmxSetAIStrainGageForceReadFromChan sets the Analog Input >> Strain >> Force Read From Channel property.

DAQmxResetAIStrainGageForceReadFromChan resets the Analog Input >> Strain >> Force Read From Channel property.


Get/Set/Reset AI_RosetteStrainGage_StrainChans

int32 __CFUNC DAQmxGetAIRosetteStrainGageStrainChans(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetAIRosetteStrainGageStrainChans gets the Analog Input >> Rosette Strain Gage >> Strain Channels property.


Get/Set/Reset AI_RosetteStrainGage_Orientation

int32 __CFUNC DAQmxGetAIRosetteStrainGageOrientation(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRosetteStrainGageOrientation(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRosetteStrainGageOrientation(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRosetteStrainGageOrientation gets the Analog Input >> Rosette Strain Gage >> Gage Orientation property.

DAQmxSetAIRosetteStrainGageOrientation sets the Analog Input >> Rosette Strain Gage >> Gage Orientation property.

DAQmxResetAIRosetteStrainGageOrientation resets the Analog Input >> Rosette Strain Gage >> Gage Orientation property.


Get/Set/Reset AI_RosetteStrainGage_RosetteMeasType

int32 __CFUNC DAQmxGetAIRosetteStrainGageRosetteMeasType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIRosetteStrainGageRosetteMeasType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIRosetteStrainGageRosetteMeasType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRosetteStrainGageRosetteMeasType gets the Analog Input >> Rosette Strain Gage >> Rosette Measurement Type property.

DAQmxSetAIRosetteStrainGageRosetteMeasType sets the Analog Input >> Rosette Strain Gage >> Rosette Measurement Type property.

DAQmxResetAIRosetteStrainGageRosetteMeasType resets the Analog Input >> Rosette Strain Gage >> Rosette Measurement Type property.


Get/Set/Reset AI_RosetteStrainGage_RosetteType

int32 __CFUNC DAQmxGetAIRosetteStrainGageRosetteType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAIRosetteStrainGageRosetteType gets the Analog Input >> Rosette Strain Gage >> Rosette Type property.


Get/Set/Reset SwitchScan_WaitingForAdv

int32 __CFUNC DAQmxGetSwitchScanWaitingForAdv(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetSwitchScanWaitingForAdv gets the Deprecated >> Is Waiting For Advance property.


Get/Set/Reset SwitchDev_AutoConnAnlgBus

int32 __CFUNC DAQmxGetSwitchDevAutoConnAnlgBus(const char deviceName[], bool32 *data);

int32 __CFUNC DAQmxSetSwitchDevAutoConnAnlgBus(const char deviceName[], bool32 data);

Purpose

DAQmxGetSwitchDevAutoConnAnlgBus gets the Deprecated >> Auto Connect Analog Bus property.

DAQmxSetSwitchDevAutoConnAnlgBus sets the Deprecated >> Auto Connect Analog Bus property.


Get/Set/Reset SwitchDev_RelayList

int32 __CFUNC DAQmxGetSwitchDevRelayList(const char deviceName[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetSwitchDevRelayList gets the Deprecated >> Capability >> Relay List property.


Get/Set/Reset AI_Max

int32 __CFUNC DAQmxGetAIMax(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIMax(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIMax(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIMax gets the Analog Input >> Maximum Value property.

DAQmxSetAIMax sets the Analog Input >> Maximum Value property.

DAQmxResetAIMax resets the Analog Input >> Maximum Value property.


Get/Set/Reset AI_Min

int32 __CFUNC DAQmxGetAIMin(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIMin(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIMin(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIMin gets the Analog Input >> Minimum Value property.

DAQmxSetAIMin sets the Analog Input >> Minimum Value property.

DAQmxResetAIMin resets the Analog Input >> Minimum Value property.


Get/Set/Reset AI_CustomScaleName

int32 __CFUNC DAQmxGetAICustomScaleName(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAICustomScaleName(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAICustomScaleName(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICustomScaleName gets the Analog Input >> Custom Scale Name property.

DAQmxSetAICustomScaleName sets the Analog Input >> Custom Scale Name property.

DAQmxResetAICustomScaleName resets the Analog Input >> Custom Scale Name property.


Get/Set/Reset AI_Voltage_ACRMS_Units

int32 __CFUNC DAQmxGetAIVoltageACRMSUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIVoltageACRMSUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIVoltageACRMSUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVoltageACRMSUnits gets the Analog Input >> Voltage >> AC RMS Voltage >> Units property.

DAQmxSetAIVoltageACRMSUnits sets the Analog Input >> Voltage >> AC RMS Voltage >> Units property.

DAQmxResetAIVoltageACRMSUnits resets the Analog Input >> Voltage >> AC RMS Voltage >> Units property.


Get/Set/Reset AI_Current_ACRMS_Units

int32 __CFUNC DAQmxGetAICurrentACRMSUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAICurrentACRMSUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAICurrentACRMSUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICurrentACRMSUnits gets the Analog Input >> Current >> AC RMS Current >> Units property.

DAQmxSetAICurrentACRMSUnits sets the Analog Input >> Current >> AC RMS Current >> Units property.

DAQmxResetAICurrentACRMSUnits resets the Analog Input >> Current >> AC RMS Current >> Units property.


Get/Set/Reset AI_Bridge_NomResistance

int32 __CFUNC DAQmxGetAIBridgeNomResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeNomResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeNomResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeNomResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Nominal Resistance property.

DAQmxSetAIBridgeNomResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Nominal Resistance property.

DAQmxResetAIBridgeNomResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Nominal Resistance property.


Get/Set/Reset AI_Bridge_InitialVoltage

int32 __CFUNC DAQmxGetAIBridgeInitialVoltage(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeInitialVoltage(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeInitialVoltage(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeInitialVoltage gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Voltage property.

DAQmxSetAIBridgeInitialVoltage sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Voltage property.

DAQmxResetAIBridgeInitialVoltage resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Initial Bridge Voltage property.


Get/Set/Reset AI_LeadWireResistance

int32 __CFUNC DAQmxGetAILeadWireResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAILeadWireResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAILeadWireResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILeadWireResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Lead Wire Resistance property.

DAQmxSetAILeadWireResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Lead Wire Resistance property.

DAQmxResetAILeadWireResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Lead Wire Resistance property.


Get/Set/Reset AI_Bridge_Balance_CoarsePot

int32 __CFUNC DAQmxGetAIBridgeBalanceCoarsePot(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeBalanceCoarsePot(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeBalanceCoarsePot(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeBalanceCoarsePot gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Coarse Potentiometer property.

DAQmxSetAIBridgeBalanceCoarsePot sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Coarse Potentiometer property.

DAQmxResetAIBridgeBalanceCoarsePot resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Coarse Potentiometer property.


Get/Set/Reset AI_CurrentShunt_Loc

int32 __CFUNC DAQmxGetAICurrentShuntLoc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAICurrentShuntLoc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAICurrentShuntLoc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICurrentShuntLoc gets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Location property.

DAQmxSetAICurrentShuntLoc sets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Location property.

DAQmxResetAICurrentShuntLoc resets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Location property.


Get/Set/Reset AI_CurrentShunt_Resistance

int32 __CFUNC DAQmxGetAICurrentShuntResistance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAICurrentShuntResistance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAICurrentShuntResistance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICurrentShuntResistance gets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Value property.

DAQmxSetAICurrentShuntResistance sets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Value property.

DAQmxResetAICurrentShuntResistance resets the Analog Input >> General Properties >> Signal Conditioning >> Current Shunt Resistor >> Value property.


Get/Set/Reset AI_Excit_Src

int32 __CFUNC DAQmxGetAIExcitSrc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIExcitSrc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIExcitSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitSrc gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Source property.

DAQmxSetAIExcitSrc sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Source property.

DAQmxResetAIExcitSrc resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Source property.


Get/Set/Reset AI_Excit_Val

int32 __CFUNC DAQmxGetAIExcitVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIExcitVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIExcitVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitVal gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Value property.

DAQmxSetAIExcitVal sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Value property.

DAQmxResetAIExcitVal resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Value property.


Get/Set/Reset AI_Excit_VoltageOrCurrent

int32 __CFUNC DAQmxGetAIExcitVoltageOrCurrent(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIExcitVoltageOrCurrent(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIExcitVoltageOrCurrent(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitVoltageOrCurrent gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Voltage or Current property.

DAQmxSetAIExcitVoltageOrCurrent sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Voltage or Current property.

DAQmxResetAIExcitVoltageOrCurrent resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Voltage or Current property.


Get/Set/Reset AI_Excit_DCorAC

int32 __CFUNC DAQmxGetAIExcitDCorAC(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIExcitDCorAC(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIExcitDCorAC(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitDCorAC gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> DC or AC property.

DAQmxSetAIExcitDCorAC sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> DC or AC property.

DAQmxResetAIExcitDCorAC resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> DC or AC property.


Get/Set/Reset AI_Excit_UseForScaling

int32 __CFUNC DAQmxGetAIExcitUseForScaling(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIExcitUseForScaling(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIExcitUseForScaling(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitUseForScaling gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Excitation For Scaling property.

DAQmxSetAIExcitUseForScaling sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Excitation For Scaling property.

DAQmxResetAIExcitUseForScaling resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Excitation For Scaling property.


Get/Set/Reset CI_MeasType

int32 __CFUNC DAQmxGetCIMeasType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetCIMeasType gets the Counter Input >> Measurement Type property.


Get/Set/Reset CI_Freq_Units

int32 __CFUNC DAQmxGetCIFreqUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIFreqUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIFreqUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqUnits gets the Counter Input >> Frequency >> Units property.

DAQmxSetCIFreqUnits sets the Counter Input >> Frequency >> Units property.

DAQmxResetCIFreqUnits resets the Counter Input >> Frequency >> Units property.


Get/Set/Reset CI_Freq_Term

int32 __CFUNC DAQmxGetCIFreqTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIFreqTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIFreqTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqTerm gets the Counter Input >> Frequency >> Input >> Terminal property.

DAQmxSetCIFreqTerm sets the Counter Input >> Frequency >> Input >> Terminal property.

DAQmxResetCIFreqTerm resets the Counter Input >> Frequency >> Input >> Terminal property.


Get/Set/Reset CI_Period_Units

int32 __CFUNC DAQmxGetCIPeriodUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPeriodUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPeriodUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodUnits gets the Counter Input >> Period >> Units property.

DAQmxSetCIPeriodUnits sets the Counter Input >> Period >> Units property.

DAQmxResetCIPeriodUnits resets the Counter Input >> Period >> Units property.


Get/Set/Reset CI_Period_Term

int32 __CFUNC DAQmxGetCIPeriodTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPeriodTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPeriodTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodTerm gets the Counter Input >> Period >> Input >> Terminal property.

DAQmxSetCIPeriodTerm sets the Counter Input >> Period >> Input >> Terminal property.

DAQmxResetCIPeriodTerm resets the Counter Input >> Period >> Input >> Terminal property.


Get/Set/Reset CI_AngEncoder_Units

int32 __CFUNC DAQmxGetCIAngEncoderUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIAngEncoderUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIAngEncoderUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIAngEncoderUnits gets the Counter Input >> Position >> Angular Encoder >> Units property.

DAQmxSetCIAngEncoderUnits sets the Counter Input >> Position >> Angular Encoder >> Units property.

DAQmxResetCIAngEncoderUnits resets the Counter Input >> Position >> Angular Encoder >> Units property.


Get/Set/Reset CI_LinEncoder_Units

int32 __CFUNC DAQmxGetCILinEncoderUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCILinEncoderUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCILinEncoderUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCILinEncoderUnits gets the Counter Input >> Position >> Linear Encoder >> Units property.

DAQmxSetCILinEncoderUnits sets the Counter Input >> Position >> Linear Encoder >> Units property.

DAQmxResetCILinEncoderUnits resets the Counter Input >> Position >> Linear Encoder >> Units property.


Get/Set/Reset CI_PulseWidth_Term

int32 __CFUNC DAQmxGetCIPulseWidthTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseWidthTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseWidthTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthTerm gets the Counter Input >> Pulse Width >> Input >> Terminal property.

DAQmxSetCIPulseWidthTerm sets the Counter Input >> Pulse Width >> Input >> Terminal property.

DAQmxResetCIPulseWidthTerm resets the Counter Input >> Pulse Width >> Input >> Terminal property.


Get/Set/Reset CI_TwoEdgeSep_Units

int32 __CFUNC DAQmxGetCITwoEdgeSepUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepUnits gets the Counter Input >> Two Edge Separation >> Units property.

DAQmxSetCITwoEdgeSepUnits sets the Counter Input >> Two Edge Separation >> Units property.

DAQmxResetCITwoEdgeSepUnits resets the Counter Input >> Two Edge Separation >> Units property.


Get/Set/Reset CI_TwoEdgeSep_FirstTerm

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstTerm gets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal property.

DAQmxSetCITwoEdgeSepFirstTerm sets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal property.

DAQmxResetCITwoEdgeSepFirstTerm resets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal property.


Get/Set/Reset CI_TwoEdgeSep_SecondTerm

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondTerm gets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal property.

DAQmxSetCITwoEdgeSepSecondTerm sets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal property.

DAQmxResetCITwoEdgeSepSecondTerm resets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal property.


Get/Set/Reset CI_SemiPeriod_Units

int32 __CFUNC DAQmxGetCISemiPeriodUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISemiPeriodUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodUnits gets the Counter Input >> Semi-Period >> Units property.

DAQmxSetCISemiPeriodUnits sets the Counter Input >> Semi-Period >> Units property.

DAQmxResetCISemiPeriodUnits resets the Counter Input >> Semi-Period >> Units property.


Get/Set/Reset CI_SemiPeriod_Term

int32 __CFUNC DAQmxGetCISemiPeriodTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCISemiPeriodTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCISemiPeriodTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodTerm gets the Counter Input >> Semi-Period >> Input >> Terminal property.

DAQmxSetCISemiPeriodTerm sets the Counter Input >> Semi-Period >> Input >> Terminal property.

DAQmxResetCISemiPeriodTerm resets the Counter Input >> Semi-Period >> Input >> Terminal property.


Get/Set/Reset CI_CtrTimebaseRate

int32 __CFUNC DAQmxGetCICtrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICtrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseRate gets the Counter Input >> General Properties >> Counter Timebase >> Rate property.

DAQmxSetCICtrTimebaseRate sets the Counter Input >> General Properties >> Counter Timebase >> Rate property.

DAQmxResetCICtrTimebaseRate resets the Counter Input >> General Properties >> Counter Timebase >> Rate property.


Get/Set/Reset CI_CtrTimebaseMasterTimebaseDiv

int32 __CFUNC DAQmxGetCICtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCICtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseMasterTimebaseDiv gets the Counter Input >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.

DAQmxSetCICtrTimebaseMasterTimebaseDiv sets the Counter Input >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.

DAQmxResetCICtrTimebaseMasterTimebaseDiv resets the Counter Input >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.


Get/Set/Reset CO_OutputType

int32 __CFUNC DAQmxGetCOOutputType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetCOOutputType gets the Counter Output >> Output Type property.


Get/Set/Reset CO_Pulse_HighTime

int32 __CFUNC DAQmxGetCOPulseHighTime(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseHighTime(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseHighTime(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseHighTime gets the Counter Output >> Pulse >> Time >> High Time property.

DAQmxSetCOPulseHighTime sets the Counter Output >> Pulse >> Time >> High Time property.

DAQmxResetCOPulseHighTime resets the Counter Output >> Pulse >> Time >> High Time property.


Get/Set/Reset CO_Pulse_LowTime

int32 __CFUNC DAQmxGetCOPulseLowTime(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseLowTime(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseLowTime(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseLowTime gets the Counter Output >> Pulse >> Time >> Low Time property.

DAQmxSetCOPulseLowTime sets the Counter Output >> Pulse >> Time >> Low Time property.

DAQmxResetCOPulseLowTime resets the Counter Output >> Pulse >> Time >> Low Time property.


Get/Set/Reset CO_Pulse_Time_InitialDelay

int32 __CFUNC DAQmxGetCOPulseTimeInitialDelay(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseTimeInitialDelay(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseTimeInitialDelay(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseTimeInitialDelay gets the Counter Output >> Pulse >> Time >> Initial Delay property.

DAQmxSetCOPulseTimeInitialDelay sets the Counter Output >> Pulse >> Time >> Initial Delay property.

DAQmxResetCOPulseTimeInitialDelay resets the Counter Output >> Pulse >> Time >> Initial Delay property.


Get/Set/Reset CO_CtrTimebaseRate

int32 __CFUNC DAQmxGetCOCtrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseRate gets the Counter Output >> General Properties >> Counter Timebase >> Rate property.

DAQmxSetCOCtrTimebaseRate sets the Counter Output >> General Properties >> Counter Timebase >> Rate property.

DAQmxResetCOCtrTimebaseRate resets the Counter Output >> General Properties >> Counter Timebase >> Rate property.


Get/Set/Reset CO_CtrTimebaseMasterTimebaseDiv

int32 __CFUNC DAQmxGetCOCtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseMasterTimebaseDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseMasterTimebaseDiv gets the Counter Output >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.

DAQmxSetCOCtrTimebaseMasterTimebaseDiv sets the Counter Output >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.

DAQmxResetCOCtrTimebaseMasterTimebaseDiv resets the Counter Output >> General Properties >> More >> Counter Timebase Master Timebase Divisor property.


Get/Set/Reset CI_CountEdges_Term

int32 __CFUNC DAQmxGetCICountEdgesTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesTerm gets the Counter Input >> Count Edges >> Input >> Terminal property.

DAQmxSetCICountEdgesTerm sets the Counter Input >> Count Edges >> Input >> Terminal property.

DAQmxResetCICountEdgesTerm resets the Counter Input >> Count Edges >> Input >> Terminal property.


Get/Set/Reset StartTrig_DelayUnits

int32 __CFUNC DAQmxGetStartTrigDelayUnits(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetStartTrigDelayUnits(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetStartTrigDelayUnits(TaskHandle taskHandle);

Purpose

DAQmxGetStartTrigDelayUnits gets the Start >> More >> Delay Units property.

DAQmxSetStartTrigDelayUnits sets the Start >> More >> Delay Units property.

DAQmxResetStartTrigDelayUnits resets the Start >> More >> Delay Units property.


Get/Set/Reset AI_Thrmstr_A

int32 __CFUNC DAQmxGetAIThrmstrA(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmstrA(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmstrA(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmstrA gets the Analog Input >> Temperature >> Thermistor >> A property.

DAQmxSetAIThrmstrA sets the Analog Input >> Temperature >> Thermistor >> A property.

DAQmxResetAIThrmstrA resets the Analog Input >> Temperature >> Thermistor >> A property.


Get/Set/Reset AI_Thrmstr_C

int32 __CFUNC DAQmxGetAIThrmstrC(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmstrC(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmstrC(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmstrC gets the Analog Input >> Temperature >> Thermistor >> C property.

DAQmxSetAIThrmstrC sets the Analog Input >> Temperature >> Thermistor >> C property.

DAQmxResetAIThrmstrC resets the Analog Input >> Temperature >> Thermistor >> C property.


Get/Set/Reset AI_Thrmstr_B

int32 __CFUNC DAQmxGetAIThrmstrB(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmstrB(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmstrB(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmstrB gets the Analog Input >> Temperature >> Thermistor >> B property.

DAQmxSetAIThrmstrB sets the Analog Input >> Temperature >> Thermistor >> B property.

DAQmxResetAIThrmstrB resets the Analog Input >> Temperature >> Thermistor >> B property.


Get/Set/Reset AI_ACExcit_WireMode

int32 __CFUNC DAQmxGetAIACExcitWireMode(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIACExcitWireMode(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIACExcitWireMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIACExcitWireMode gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Wire Mode property.

DAQmxSetAIACExcitWireMode sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Wire Mode property.

DAQmxResetAIACExcitWireMode resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Wire Mode property.


Get/Set/Reset CO_Pulse_Freq_Units

int32 __CFUNC DAQmxGetCOPulseFreqUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCOPulseFreqUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCOPulseFreqUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseFreqUnits gets the Counter Output >> Pulse >> Frequency >> Units property.

DAQmxSetCOPulseFreqUnits sets the Counter Output >> Pulse >> Frequency >> Units property.

DAQmxResetCOPulseFreqUnits resets the Counter Output >> Pulse >> Frequency >> Units property.


Get/Set/Reset CO_Pulse_Time_Units

int32 __CFUNC DAQmxGetCOPulseTimeUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCOPulseTimeUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCOPulseTimeUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseTimeUnits gets the Counter Output >> Pulse >> Time >> Units property.

DAQmxSetCOPulseTimeUnits sets the Counter Output >> Pulse >> Time >> Units property.

DAQmxResetCOPulseTimeUnits resets the Counter Output >> Pulse >> Time >> Units property.


Get/Set/Reset CO_Pulse_Term

int32 __CFUNC DAQmxGetCOPulseTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCOPulseTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCOPulseTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseTerm gets the Counter Output >> Pulse >> Output Terminal property.

DAQmxSetCOPulseTerm sets the Counter Output >> Pulse >> Output Terminal property.

DAQmxResetCOPulseTerm resets the Counter Output >> Pulse >> Output Terminal property.


Get/Set/Reset SwitchChan_Usage

int32 __CFUNC DAQmxGetSwitchChanUsage(const char switchChannelName[], int32 *data);

int32 __CFUNC DAQmxSetSwitchChanUsage(const char switchChannelName[], int32 data);

Purpose

DAQmxGetSwitchChanUsage gets the Deprecated >> Usage property.

DAQmxSetSwitchChanUsage sets the Deprecated >> Usage property.


Get/Set/Reset SwitchChan_WireMode

int32 __CFUNC DAQmxGetSwitchChanWireMode(const char switchChannelName[], uInt32 *data);

Purpose

DAQmxGetSwitchChanWireMode gets the Deprecated >> Capability >> Wire Mode property.


Get/Set/Reset SwitchDev_NumRelays

int32 __CFUNC DAQmxGetSwitchDevNumRelays(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetSwitchDevNumRelays gets the Deprecated >> Capability >> Number of Relays property.


Get/Set/Reset SwitchDev_SwitchChanList

int32 __CFUNC DAQmxGetSwitchDevSwitchChanList(const char deviceName[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetSwitchDevSwitchChanList gets the Deprecated >> Capability >> Switch Channel List property.


Get/Set/Reset SwitchDev_NumSwitchChans

int32 __CFUNC DAQmxGetSwitchDevNumSwitchChans(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetSwitchDevNumSwitchChans gets the Deprecated >> Capability >> Number of Switch Channels property.


Get/Set/Reset SwitchDev_NumRows

int32 __CFUNC DAQmxGetSwitchDevNumRows(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetSwitchDevNumRows gets the Deprecated >> Capability >> Number of Rows property.


Get/Set/Reset SwitchDev_NumColumns

int32 __CFUNC DAQmxGetSwitchDevNumColumns(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetSwitchDevNumColumns gets the Deprecated >> Capability >> Number of Columns property.


Get/Set/Reset SampClk_TimebaseDiv

int32 __CFUNC DAQmxGetSampClkTimebaseDiv(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetSampClkTimebaseDiv(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetSampClkTimebaseDiv(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkTimebaseDiv gets the Sample Clock >> Timebase Divisor property.

DAQmxSetSampClkTimebaseDiv sets the Sample Clock >> Timebase Divisor property.

DAQmxResetSampClkTimebaseDiv resets the Sample Clock >> Timebase Divisor property.


Get/Set/Reset SampClk_Timebase_ActiveEdge

int32 __CFUNC DAQmxGetSampClkTimebaseActiveEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampClkTimebaseActiveEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampClkTimebaseActiveEdge(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkTimebaseActiveEdge gets the Sample Clock >> Timebase >> Active Edge property.

DAQmxSetSampClkTimebaseActiveEdge sets the Sample Clock >> Timebase >> Active Edge property.

DAQmxResetSampClkTimebaseActiveEdge resets the Sample Clock >> Timebase >> Active Edge property.


Get/Set/Reset Exported_AIHoldCmpltEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedAIHoldCmpltEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedAIHoldCmpltEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedAIHoldCmpltEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAIHoldCmpltEventOutputTerm gets the Events >> AI Hold Complete Event >> Output Terminal property.

DAQmxSetExportedAIHoldCmpltEventOutputTerm sets the Events >> AI Hold Complete Event >> Output Terminal property.

DAQmxResetExportedAIHoldCmpltEventOutputTerm resets the Events >> AI Hold Complete Event >> Output Terminal property.


Get/Set/Reset Exported_AIHoldCmpltEvent_PulsePolarity

int32 __CFUNC DAQmxGetExportedAIHoldCmpltEventPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedAIHoldCmpltEventPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedAIHoldCmpltEventPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAIHoldCmpltEventPulsePolarity gets the Events >> AI Hold Complete Event >> Pulse >> Polarity property.

DAQmxSetExportedAIHoldCmpltEventPulsePolarity sets the Events >> AI Hold Complete Event >> Pulse >> Polarity property.

DAQmxResetExportedAIHoldCmpltEventPulsePolarity resets the Events >> AI Hold Complete Event >> Pulse >> Polarity property.


Get/Set/Reset DO_Tristate

int32 __CFUNC DAQmxGetDOTristate(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDOTristate(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDOTristate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOTristate gets the Digital Output >> Tristate property.

DAQmxSetDOTristate sets the Digital Output >> Tristate property.

DAQmxResetDOTristate resets the Digital Output >> Tristate property.


Get/Set/Reset AI_Bridge_Balance_FinePot

int32 __CFUNC DAQmxGetAIBridgeBalanceFinePot(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeBalanceFinePot(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeBalanceFinePot(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeBalanceFinePot gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Fine Potentiometer property.

DAQmxSetAIBridgeBalanceFinePot sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Fine Potentiometer property.

DAQmxResetAIBridgeBalanceFinePot resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Balance >> Fine Potentiometer property.


Get/Set/Reset PhysicalChanName

int32 __CFUNC DAQmxGetPhysicalChanName(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetPhysicalChanName(TaskHandle taskHandle, const char channel[], const char *data);

Purpose

DAQmxGetPhysicalChanName gets the General Properties >> Physical Channel Name property.

DAQmxSetPhysicalChanName sets the General Properties >> Physical Channel Name property.


Get/Set/Reset Scale_PreScaledUnits

int32 __CFUNC DAQmxGetScalePreScaledUnits(const char scaleName[], int32 *data);

int32 __CFUNC DAQmxSetScalePreScaledUnits(const char scaleName[], int32 data);

Purpose

DAQmxGetScalePreScaledUnits gets the Pre-Scaled Units property.

DAQmxSetScalePreScaledUnits sets the Pre-Scaled Units property.


Get/Set/Reset AI_ForceReadFromChan

int32 __CFUNC DAQmxGetAIForceReadFromChan(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIForceReadFromChan(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIForceReadFromChan(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIForceReadFromChan gets the Analog Input >> Temperature >> Advanced >> Force Read From Channel property.

DAQmxSetAIForceReadFromChan sets the Analog Input >> Temperature >> Advanced >> Force Read From Channel property.

DAQmxResetAIForceReadFromChan resets the Analog Input >> Temperature >> Advanced >> Force Read From Channel property.


Get/Set/Reset Exported_SampClkTimebase_OutputTerm

int32 __CFUNC DAQmxGetExportedSampClkTimebaseOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedSampClkTimebaseOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedSampClkTimebaseOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSampClkTimebaseOutputTerm gets the Clocks >> Sample Clock Timebase >> Output Terminal property.

DAQmxSetExportedSampClkTimebaseOutputTerm sets the Clocks >> Sample Clock Timebase >> Output Terminal property.

DAQmxResetExportedSampClkTimebaseOutputTerm resets the Clocks >> Sample Clock Timebase >> Output Terminal property.


Get/Set/Reset OnDemand_SimultaneousAOEnable

int32 __CFUNC DAQmxGetOnDemandSimultaneousAOEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetOnDemandSimultaneousAOEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetOnDemandSimultaneousAOEnable(TaskHandle taskHandle);

Purpose

DAQmxGetOnDemandSimultaneousAOEnable gets the On Demand >> Simultaneous Analog Output Enable property.

DAQmxSetOnDemandSimultaneousAOEnable sets the On Demand >> Simultaneous Analog Output Enable property.

DAQmxResetOnDemandSimultaneousAOEnable resets the On Demand >> Simultaneous Analog Output Enable property.


Get/Set/Reset Exported_DividedSampClkTimebase_OutputTerm

int32 __CFUNC DAQmxGetExportedDividedSampClkTimebaseOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedDividedSampClkTimebaseOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedDividedSampClkTimebaseOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedDividedSampClkTimebaseOutputTerm gets the Clocks >> Divided Sample Clock Timebase >> Output Terminal property.

DAQmxSetExportedDividedSampClkTimebaseOutputTerm sets the Clocks >> Divided Sample Clock Timebase >> Output Terminal property.

DAQmxResetExportedDividedSampClkTimebaseOutputTerm resets the Clocks >> Divided Sample Clock Timebase >> Output Terminal property.


Get/Set/Reset WatchdogExpirTrig_Type

int32 __CFUNC DAQmxGetWatchdogExpirTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetWatchdogExpirTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetWatchdogExpirTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetWatchdogExpirTrigType gets the Expiration Trigger >> Trigger Type property.

DAQmxSetWatchdogExpirTrigType sets the Expiration Trigger >> Trigger Type property.

DAQmxResetWatchdogExpirTrigType resets the Expiration Trigger >> Trigger Type property.


Get/Set/Reset DigEdge_WatchdogExpirTrig_Src

int32 __CFUNC DAQmxGetDigEdgeWatchdogExpirTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeWatchdogExpirTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeWatchdogExpirTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeWatchdogExpirTrigSrc gets the Expiration Trigger >> Digital Edge >> Source property.

DAQmxSetDigEdgeWatchdogExpirTrigSrc sets the Expiration Trigger >> Digital Edge >> Source property.

DAQmxResetDigEdgeWatchdogExpirTrigSrc resets the Expiration Trigger >> Digital Edge >> Source property.


Get/Set/Reset DigEdge_WatchdogExpirTrig_Edge

int32 __CFUNC DAQmxGetDigEdgeWatchdogExpirTrigEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigEdgeWatchdogExpirTrigEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigEdgeWatchdogExpirTrigEdge(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeWatchdogExpirTrigEdge gets the Expiration Trigger >> Digital Edge >> Edge property.

DAQmxSetDigEdgeWatchdogExpirTrigEdge sets the Expiration Trigger >> Digital Edge >> Edge property.

DAQmxResetDigEdgeWatchdogExpirTrigEdge resets the Expiration Trigger >> Digital Edge >> Edge property.


Get/Set/Reset Watchdog_DO_ExpirState

int32 __CFUNC DAQmxGetWatchdogDOExpirState(TaskHandle taskHandle, const char lines[], int32 *data);

int32 __CFUNC DAQmxSetWatchdogDOExpirState(TaskHandle taskHandle, const char lines[], int32 data);

int32 __CFUNC DAQmxResetWatchdogDOExpirState(TaskHandle taskHandle, const char lines[]);

Purpose

DAQmxGetWatchdogDOExpirState gets the Expiration States >> Digital Output >> Expiration State property.

DAQmxSetWatchdogDOExpirState sets the Expiration States >> Digital Output >> Expiration State property.

DAQmxResetWatchdogDOExpirState resets the Expiration States >> Digital Output >> Expiration State property.


Get/Set/Reset Watchdog_HasExpired

int32 __CFUNC DAQmxGetWatchdogHasExpired(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWatchdogHasExpired gets the Status >> Expired property.


Get/Set/Reset Watchdog_Timeout

int32 __CFUNC DAQmxGetWatchdogTimeout(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetWatchdogTimeout(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetWatchdogTimeout(TaskHandle taskHandle);

Purpose

DAQmxGetWatchdogTimeout gets the Timeout property.

DAQmxSetWatchdogTimeout sets the Timeout property.

DAQmxResetWatchdogTimeout resets the Timeout property.


Get/Set/Reset Exported_WatchdogExpiredEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedWatchdogExpiredEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedWatchdogExpiredEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedWatchdogExpiredEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedWatchdogExpiredEventOutputTerm gets the Events >> Watchdog Timer Expired Event >> Output Terminal property.

DAQmxSetExportedWatchdogExpiredEventOutputTerm sets the Events >> Watchdog Timer Expired Event >> Output Terminal property.

DAQmxResetExportedWatchdogExpiredEventOutputTerm resets the Events >> Watchdog Timer Expired Event >> Output Terminal property.


Get/Set/Reset CI_DupCountPrevent

int32 __CFUNC DAQmxGetCIDupCountPrevent(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIDupCountPrevent(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIDupCountPrevent(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDupCountPrevent gets the Counter Input >> General Properties >> More >> Advanced >> Duplicate Count Prevention property.

DAQmxSetCIDupCountPrevent sets the Counter Input >> General Properties >> More >> Advanced >> Duplicate Count Prevention property.

DAQmxResetCIDupCountPrevent resets the Counter Input >> General Properties >> More >> Advanced >> Duplicate Count Prevention property.


Get/Set/Reset Exported_SampClk_DelayOffset

int32 __CFUNC DAQmxGetExportedSampClkDelayOffset(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedSampClkDelayOffset(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedSampClkDelayOffset(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSampClkDelayOffset gets the Clocks >> Sample Clock >> Delay Offset property.

DAQmxSetExportedSampClkDelayOffset sets the Clocks >> Sample Clock >> Delay Offset property.

DAQmxResetExportedSampClkDelayOffset resets the Clocks >> Sample Clock >> Delay Offset property.


Get/Set/Reset AI_Bridge_ShuntCal_Select

int32 __CFUNC DAQmxGetAIBridgeShuntCalSelect(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalSelect(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalSelect(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalSelect gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Select property.

DAQmxSetAIBridgeShuntCalSelect sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Select property.

DAQmxResetAIBridgeShuntCalSelect resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Select property.


Get/Set/Reset DI_DigFltr_Enable

int32 __CFUNC DAQmxGetDIDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDIDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDIDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigFltrEnable gets the Digital Input >> Digital Filter >> Enable property.

DAQmxSetDIDigFltrEnable sets the Digital Input >> Digital Filter >> Enable property.

DAQmxResetDIDigFltrEnable resets the Digital Input >> Digital Filter >> Enable property.


Get/Set/Reset DI_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetDIDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetDIDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetDIDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDigFltrMinPulseWidth gets the Digital Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetDIDigFltrMinPulseWidth sets the Digital Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetDIDigFltrMinPulseWidth resets the Digital Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset PhysicalChan_TEDS_MfgID

int32 __CFUNC DAQmxGetPhysicalChanTEDSMfgID(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanTEDSMfgID gets the TEDS >> ManufacturerID property.


Get/Set/Reset PhysicalChan_TEDS_ModelNum

int32 __CFUNC DAQmxGetPhysicalChanTEDSModelNum(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanTEDSModelNum gets the TEDS >> Model Number property.


Get/Set/Reset PhysicalChan_TEDS_SerialNum

int32 __CFUNC DAQmxGetPhysicalChanTEDSSerialNum(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanTEDSSerialNum gets the TEDS >> Serial Number property.


Get/Set/Reset PhysicalChan_TEDS_VersionNum

int32 __CFUNC DAQmxGetPhysicalChanTEDSVersionNum(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanTEDSVersionNum gets the TEDS >> Version Number property.


Get/Set/Reset PhysicalChan_TEDS_VersionLetter

int32 __CFUNC DAQmxGetPhysicalChanTEDSVersionLetter(const char physicalChannel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetPhysicalChanTEDSVersionLetter gets the TEDS >> Version Letter property.


Get/Set/Reset PhysicalChan_TEDS_BitStream

int32 __CFUNC DAQmxGetPhysicalChanTEDSBitStream(const char physicalChannel[], uInt8 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanTEDSBitStream gets the TEDS >> BitStream property.


Get/Set/Reset AI_TEDS_Units

int32 __CFUNC DAQmxGetAITEDSUnits(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetAITEDSUnits gets the Analog Input >> TEDS >> Units property.


Get/Set/Reset CI_CountEdges_DirTerm

int32 __CFUNC DAQmxGetCICountEdgesDirTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesDirTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesDirTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDirTerm gets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal property.

DAQmxSetCICountEdgesDirTerm sets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal property.

DAQmxResetCICountEdgesDirTerm resets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal property.


Get/Set/Reset CI_Encoder_DecodingType

int32 __CFUNC DAQmxGetCIEncoderDecodingType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderDecodingType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderDecodingType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderDecodingType gets the Counter Input >> Position >> Decoding Type property.

DAQmxSetCIEncoderDecodingType sets the Counter Input >> Position >> Decoding Type property.

DAQmxResetCIEncoderDecodingType resets the Counter Input >> Position >> Decoding Type property.


Get/Set/Reset CI_Freq_DigFltr_Enable

int32 __CFUNC DAQmxGetCIFreqDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIFreqDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIFreqDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDigFltrEnable gets the Counter Input >> Frequency >> Input >> Digital Filter >> Enable property.

DAQmxSetCIFreqDigFltrEnable sets the Counter Input >> Frequency >> Input >> Digital Filter >> Enable property.

DAQmxResetCIFreqDigFltrEnable resets the Counter Input >> Frequency >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Freq_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIFreqDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDigFltrMinPulseWidth gets the Counter Input >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIFreqDigFltrMinPulseWidth sets the Counter Input >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIFreqDigFltrMinPulseWidth resets the Counter Input >> Frequency >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Freq_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIFreqDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDigFltrTimebaseSrc gets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIFreqDigFltrTimebaseSrc sets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIFreqDigFltrTimebaseSrc resets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Freq_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIFreqDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDigFltrTimebaseRate gets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIFreqDigFltrTimebaseRate sets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIFreqDigFltrTimebaseRate resets the Counter Input >> Frequency >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Freq_DigSync_Enable

int32 __CFUNC DAQmxGetCIFreqDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIFreqDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIFreqDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDigSyncEnable gets the Counter Input >> Frequency >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIFreqDigSyncEnable sets the Counter Input >> Frequency >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIFreqDigSyncEnable resets the Counter Input >> Frequency >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Period_DigFltr_Enable

int32 __CFUNC DAQmxGetCIPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDigFltrEnable gets the Counter Input >> Period >> Input >> Digital Filter >> Enable property.

DAQmxSetCIPeriodDigFltrEnable sets the Counter Input >> Period >> Input >> Digital Filter >> Enable property.

DAQmxResetCIPeriodDigFltrEnable resets the Counter Input >> Period >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Period_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDigFltrMinPulseWidth gets the Counter Input >> Period >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIPeriodDigFltrMinPulseWidth sets the Counter Input >> Period >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIPeriodDigFltrMinPulseWidth resets the Counter Input >> Period >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Period_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDigFltrTimebaseSrc gets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIPeriodDigFltrTimebaseSrc sets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIPeriodDigFltrTimebaseSrc resets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Period_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDigFltrTimebaseRate gets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIPeriodDigFltrTimebaseRate sets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIPeriodDigFltrTimebaseRate resets the Counter Input >> Period >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Period_DigSync_Enable

int32 __CFUNC DAQmxGetCIPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDigSyncEnable gets the Counter Input >> Period >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIPeriodDigSyncEnable sets the Counter Input >> Period >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIPeriodDigSyncEnable resets the Counter Input >> Period >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_CountEdges_CountDir_DigFltr_Enable

int32 __CFUNC DAQmxGetCICountEdgesCountDirDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirDigFltrEnable gets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Enable property.

DAQmxSetCICountEdgesCountDirDigFltrEnable sets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Enable property.

DAQmxResetCICountEdgesCountDirDigFltrEnable resets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_CountEdges_CountDir_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCICountEdgesCountDirDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirDigFltrMinPulseWidth gets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCICountEdgesCountDirDigFltrMinPulseWidth sets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCICountEdgesCountDirDigFltrMinPulseWidth resets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_CountEdges_CountDir_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCICountEdgesCountDirDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesCountDirDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirDigFltrTimebaseSrc gets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCICountEdgesCountDirDigFltrTimebaseSrc sets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCICountEdgesCountDirDigFltrTimebaseSrc resets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_CountEdges_CountDir_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCICountEdgesCountDirDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirDigFltrTimebaseRate gets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCICountEdgesCountDirDigFltrTimebaseRate sets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCICountEdgesCountDirDigFltrTimebaseRate resets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_CountEdges_CountDir_DigSync_Enable

int32 __CFUNC DAQmxGetCICountEdgesCountDirDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirDigSyncEnable gets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCICountEdgesCountDirDigSyncEnable sets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCICountEdgesCountDirDigSyncEnable resets the Counter Input >> Count Edges >> Count Direction >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_CountEdges_DigFltr_Enable

int32 __CFUNC DAQmxGetCICountEdgesDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDigFltrEnable gets the Counter Input >> Count Edges >> Input >> Digital Filter >> Enable property.

DAQmxSetCICountEdgesDigFltrEnable sets the Counter Input >> Count Edges >> Input >> Digital Filter >> Enable property.

DAQmxResetCICountEdgesDigFltrEnable resets the Counter Input >> Count Edges >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_CountEdges_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCICountEdgesDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDigFltrMinPulseWidth gets the Counter Input >> Count Edges >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCICountEdgesDigFltrMinPulseWidth sets the Counter Input >> Count Edges >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCICountEdgesDigFltrMinPulseWidth resets the Counter Input >> Count Edges >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_CountEdges_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCICountEdgesDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDigFltrTimebaseSrc gets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCICountEdgesDigFltrTimebaseSrc sets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCICountEdgesDigFltrTimebaseSrc resets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_CountEdges_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCICountEdgesDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDigFltrTimebaseRate gets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCICountEdgesDigFltrTimebaseRate sets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCICountEdgesDigFltrTimebaseRate resets the Counter Input >> Count Edges >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_CountEdges_DigSync_Enable

int32 __CFUNC DAQmxGetCICountEdgesDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDigSyncEnable gets the Counter Input >> Count Edges >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCICountEdgesDigSyncEnable sets the Counter Input >> Count Edges >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCICountEdgesDigSyncEnable resets the Counter Input >> Count Edges >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Encoder_AInput_DigFltr_Enable

int32 __CFUNC DAQmxGetCIEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputDigFltrEnable gets the Counter Input >> Position >> A Input >> Digital Filter >> Enable property.

DAQmxSetCIEncoderAInputDigFltrEnable sets the Counter Input >> Position >> A Input >> Digital Filter >> Enable property.

DAQmxResetCIEncoderAInputDigFltrEnable resets the Counter Input >> Position >> A Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Encoder_AInput_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputDigFltrMinPulseWidth gets the Counter Input >> Position >> A Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIEncoderAInputDigFltrMinPulseWidth sets the Counter Input >> Position >> A Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIEncoderAInputDigFltrMinPulseWidth resets the Counter Input >> Position >> A Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Encoder_AInput_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputDigFltrTimebaseSrc gets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIEncoderAInputDigFltrTimebaseSrc sets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIEncoderAInputDigFltrTimebaseSrc resets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Encoder_AInput_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputDigFltrTimebaseRate gets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIEncoderAInputDigFltrTimebaseRate sets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIEncoderAInputDigFltrTimebaseRate resets the Counter Input >> Position >> A Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Encoder_AInput_DigSync_Enable

int32 __CFUNC DAQmxGetCIEncoderAInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderAInputDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputDigSyncEnable gets the Counter Input >> Position >> A Input >> Digital Synchronization >> Enable property.

DAQmxSetCIEncoderAInputDigSyncEnable sets the Counter Input >> Position >> A Input >> Digital Synchronization >> Enable property.

DAQmxResetCIEncoderAInputDigSyncEnable resets the Counter Input >> Position >> A Input >> Digital Synchronization >> Enable property.


Get/Set/Reset AI_ChanCal_Poly_ReverseCoeff

int32 __CFUNC DAQmxGetAIChanCalPolyReverseCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalPolyReverseCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalPolyReverseCoeff(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalPolyReverseCoeff gets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.

DAQmxSetAIChanCalPolyReverseCoeff sets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.

DAQmxResetAIChanCalPolyReverseCoeff resets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Reverse Coefficients property.


Get/Set/Reset AI_ChanCal_Verif_RefVals

int32 __CFUNC DAQmxGetAIChanCalVerifRefVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalVerifRefVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalVerifRefVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalVerifRefVals gets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Reference Values property.

DAQmxSetAIChanCalVerifRefVals sets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Reference Values property.

DAQmxResetAIChanCalVerifRefVals resets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Reference Values property.


Get/Set/Reset AI_ChanCal_Verif_AcqVals

int32 __CFUNC DAQmxGetAIChanCalVerifAcqVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalVerifAcqVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalVerifAcqVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalVerifAcqVals gets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Acquired Values property.

DAQmxSetAIChanCalVerifAcqVals sets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Acquired Values property.

DAQmxResetAIChanCalVerifAcqVals resets the Analog Input >> General Properties >> Channel Calibration >> Verification >> Acquired Values property.


Get/Set/Reset AI_ChanCal_OperatorName

int32 __CFUNC DAQmxGetAIChanCalOperatorName(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIChanCalOperatorName(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAIChanCalOperatorName(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalOperatorName gets the Analog Input >> General Properties >> Channel Calibration >> Operator Name property.

DAQmxSetAIChanCalOperatorName sets the Analog Input >> General Properties >> Channel Calibration >> Operator Name property.

DAQmxResetAIChanCalOperatorName resets the Analog Input >> General Properties >> Channel Calibration >> Operator Name property.


Get/Set/Reset AI_ChanCal_Desc

int32 __CFUNC DAQmxGetAIChanCalDesc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIChanCalDesc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAIChanCalDesc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalDesc gets the Analog Input >> General Properties >> Channel Calibration >> Description property.

DAQmxSetAIChanCalDesc sets the Analog Input >> General Properties >> Channel Calibration >> Description property.

DAQmxResetAIChanCalDesc resets the Analog Input >> General Properties >> Channel Calibration >> Description property.


Get/Set/Reset Read_SleepTime

int32 __CFUNC DAQmxGetReadSleepTime(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetReadSleepTime(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetReadSleepTime(TaskHandle taskHandle);

Purpose

DAQmxGetReadSleepTime gets the Advanced >> Sleep Time property.

DAQmxSetReadSleepTime sets the Advanced >> Sleep Time property.

DAQmxResetReadSleepTime resets the Advanced >> Sleep Time property.


Get/Set/Reset Write_WaitMode

int32 __CFUNC DAQmxGetWriteWaitMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetWriteWaitMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetWriteWaitMode(TaskHandle taskHandle);

Purpose

DAQmxGetWriteWaitMode gets the Advanced >> Wait Mode property.

DAQmxSetWriteWaitMode sets the Advanced >> Wait Mode property.

DAQmxResetWriteWaitMode resets the Advanced >> Wait Mode property.


Get/Set/Reset Write_SleepTime

int32 __CFUNC DAQmxGetWriteSleepTime(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetWriteSleepTime(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetWriteSleepTime(TaskHandle taskHandle);

Purpose

DAQmxGetWriteSleepTime gets the Advanced >> Sleep Time property.

DAQmxSetWriteSleepTime sets the Advanced >> Sleep Time property.

DAQmxResetWriteSleepTime resets the Advanced >> Sleep Time property.


Get/Set/Reset CI_Timestamp_Units

int32 __CFUNC DAQmxGetCITimestampUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITimestampUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITimestampUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITimestampUnits gets the Counter Input >> Timestamp >> Units property.

DAQmxSetCITimestampUnits sets the Counter Input >> Timestamp >> Units property.

DAQmxResetCITimestampUnits resets the Counter Input >> Timestamp >> Units property.


Get/Set/Reset CI_Timestamp_InitialSeconds

int32 __CFUNC DAQmxGetCITimestampInitialSeconds(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCITimestampInitialSeconds(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCITimestampInitialSeconds(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITimestampInitialSeconds gets the Counter Input >> Timestamp >> Initial Seconds property.

DAQmxSetCITimestampInitialSeconds sets the Counter Input >> Timestamp >> Initial Seconds property.

DAQmxResetCITimestampInitialSeconds resets the Counter Input >> Timestamp >> Initial Seconds property.


Get/Set/Reset Exported_RdyForXferEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedRdyForXferEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedRdyForXferEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedRdyForXferEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForXferEventOutputTerm gets the Events >> Ready For Transfer Event >> Output Terminal property.

DAQmxSetExportedRdyForXferEventOutputTerm sets the Events >> Ready For Transfer Event >> Output Terminal property.

DAQmxResetExportedRdyForXferEventOutputTerm resets the Events >> Ready For Transfer Event >> Output Terminal property.


Get/Set/Reset Exported_RdyForXferEvent_Lvl_ActiveLvl

int32 __CFUNC DAQmxGetExportedRdyForXferEventLvlActiveLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedRdyForXferEventLvlActiveLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedRdyForXferEventLvlActiveLvl(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForXferEventLvlActiveLvl gets the Events >> Ready For Transfer Event >> Level >> Active Level property.

DAQmxSetExportedRdyForXferEventLvlActiveLvl sets the Events >> Ready For Transfer Event >> Level >> Active Level property.

DAQmxResetExportedRdyForXferEventLvlActiveLvl resets the Events >> Ready For Transfer Event >> Level >> Active Level property.


Get/Set/Reset HshkTrig_Type

int32 __CFUNC DAQmxGetHshkTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetHshkTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetHshkTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetHshkTrigType gets the More >> Handshake >> Trigger Type property.

DAQmxSetHshkTrigType sets the More >> Handshake >> Trigger Type property.

DAQmxResetHshkTrigType resets the More >> Handshake >> Trigger Type property.


Get/Set/Reset Interlocked_HshkTrig_Src

int32 __CFUNC DAQmxGetInterlockedHshkTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetInterlockedHshkTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetInterlockedHshkTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetInterlockedHshkTrigSrc gets the More >> Handshake >> Interlocked >> Source property.

DAQmxSetInterlockedHshkTrigSrc sets the More >> Handshake >> Interlocked >> Source property.

DAQmxResetInterlockedHshkTrigSrc resets the More >> Handshake >> Interlocked >> Source property.


Get/Set/Reset Interlocked_HshkTrig_AssertedLvl

int32 __CFUNC DAQmxGetInterlockedHshkTrigAssertedLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetInterlockedHshkTrigAssertedLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetInterlockedHshkTrigAssertedLvl(TaskHandle taskHandle);

Purpose

DAQmxGetInterlockedHshkTrigAssertedLvl gets the More >> Handshake >> Interlocked >> Asserted Level property.

DAQmxSetInterlockedHshkTrigAssertedLvl sets the More >> Handshake >> Interlocked >> Asserted Level property.

DAQmxResetInterlockedHshkTrigAssertedLvl resets the More >> Handshake >> Interlocked >> Asserted Level property.


Get/Set/Reset Exported_HshkEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedHshkEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedHshkEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedHshkEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventOutputTerm gets the Events >> Handshake Event >> Output Terminal property.

DAQmxSetExportedHshkEventOutputTerm sets the Events >> Handshake Event >> Output Terminal property.

DAQmxResetExportedHshkEventOutputTerm resets the Events >> Handshake Event >> Output Terminal property.


Get/Set/Reset Exported_HshkEvent_OutputBehavior

int32 __CFUNC DAQmxGetExportedHshkEventOutputBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedHshkEventOutputBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedHshkEventOutputBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventOutputBehavior gets the Events >> Handshake Event >> Output Behavior property.

DAQmxSetExportedHshkEventOutputBehavior sets the Events >> Handshake Event >> Output Behavior property.

DAQmxResetExportedHshkEventOutputBehavior resets the Events >> Handshake Event >> Output Behavior property.


Get/Set/Reset Exported_HshkEvent_Delay

int32 __CFUNC DAQmxGetExportedHshkEventDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedHshkEventDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedHshkEventDelay(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventDelay gets the Events >> Handshake Event >> Delay Value property.

DAQmxSetExportedHshkEventDelay sets the Events >> Handshake Event >> Delay Value property.

DAQmxResetExportedHshkEventDelay resets the Events >> Handshake Event >> Delay Value property.


Get/Set/Reset Exported_HshkEvent_Interlocked_AssertedLvl

int32 __CFUNC DAQmxGetExportedHshkEventInterlockedAssertedLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedHshkEventInterlockedAssertedLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedHshkEventInterlockedAssertedLvl(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventInterlockedAssertedLvl gets the Events >> Handshake Event >> Interlocked >> Asserted Level property.

DAQmxSetExportedHshkEventInterlockedAssertedLvl sets the Events >> Handshake Event >> Interlocked >> Asserted Level property.

DAQmxResetExportedHshkEventInterlockedAssertedLvl resets the Events >> Handshake Event >> Interlocked >> Asserted Level property.


Get/Set/Reset Exported_HshkEvent_Interlocked_AssertOnStart

int32 __CFUNC DAQmxGetExportedHshkEventInterlockedAssertOnStart(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetExportedHshkEventInterlockedAssertOnStart(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetExportedHshkEventInterlockedAssertOnStart(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventInterlockedAssertOnStart gets the Events >> Handshake Event >> Interlocked >> Assert on Start property.

DAQmxSetExportedHshkEventInterlockedAssertOnStart sets the Events >> Handshake Event >> Interlocked >> Assert on Start property.

DAQmxResetExportedHshkEventInterlockedAssertOnStart resets the Events >> Handshake Event >> Interlocked >> Assert on Start property.


Get/Set/Reset Exported_HshkEvent_Interlocked_DeassertDelay

int32 __CFUNC DAQmxGetExportedHshkEventInterlockedDeassertDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedHshkEventInterlockedDeassertDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedHshkEventInterlockedDeassertDelay(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventInterlockedDeassertDelay gets the Events >> Handshake Event >> Interlocked >> Deassert Delay Value property.

DAQmxSetExportedHshkEventInterlockedDeassertDelay sets the Events >> Handshake Event >> Interlocked >> Deassert Delay Value property.

DAQmxResetExportedHshkEventInterlockedDeassertDelay resets the Events >> Handshake Event >> Interlocked >> Deassert Delay Value property.


Get/Set/Reset Exported_HshkEvent_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedHshkEventPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedHshkEventPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedHshkEventPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventPulsePolarity gets the Events >> Handshake Event >> Pulse >> Polarity property.

DAQmxSetExportedHshkEventPulsePolarity sets the Events >> Handshake Event >> Pulse >> Polarity property.

DAQmxResetExportedHshkEventPulsePolarity resets the Events >> Handshake Event >> Pulse >> Polarity property.


Get/Set/Reset Exported_HshkEvent_Pulse_Width

int32 __CFUNC DAQmxGetExportedHshkEventPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedHshkEventPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedHshkEventPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetExportedHshkEventPulseWidth gets the Events >> Handshake Event >> Pulse >> Width Value property.

DAQmxSetExportedHshkEventPulseWidth sets the Events >> Handshake Event >> Pulse >> Width Value property.

DAQmxResetExportedHshkEventPulseWidth resets the Events >> Handshake Event >> Pulse >> Width Value property.


Get/Set/Reset Hshk_DelayAfterXfer

int32 __CFUNC DAQmxGetHshkDelayAfterXfer(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetHshkDelayAfterXfer(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetHshkDelayAfterXfer(TaskHandle taskHandle);

Purpose

DAQmxGetHshkDelayAfterXfer gets the Handshake >> Delay After Transfer property.

DAQmxSetHshkDelayAfterXfer sets the Handshake >> Delay After Transfer property.

DAQmxResetHshkDelayAfterXfer resets the Handshake >> Delay After Transfer property.


Get/Set/Reset Hshk_StartCond

int32 __CFUNC DAQmxGetHshkStartCond(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetHshkStartCond(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetHshkStartCond(TaskHandle taskHandle);

Purpose

DAQmxGetHshkStartCond gets the Handshake >> Start Condition property.

DAQmxSetHshkStartCond sets the Handshake >> Start Condition property.

DAQmxResetHshkStartCond resets the Handshake >> Start Condition property.


Get/Set/Reset Hshk_SampleInputDataWhen

int32 __CFUNC DAQmxGetHshkSampleInputDataWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetHshkSampleInputDataWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetHshkSampleInputDataWhen(TaskHandle taskHandle);

Purpose

DAQmxGetHshkSampleInputDataWhen gets the Handshake >> Sample Input Data When property.

DAQmxSetHshkSampleInputDataWhen sets the Handshake >> Sample Input Data When property.

DAQmxResetHshkSampleInputDataWhen resets the Handshake >> Sample Input Data When property.


Get/Set/Reset SampClk_MaxRate

int32 __CFUNC DAQmxGetSampClkMaxRate(TaskHandle taskHandle, float64 *data);

Purpose

DAQmxGetSampClkMaxRate gets the Sample Clock >> Maximum Rate property.


Get/Set/Reset AIConv_MaxRate

int32 __CFUNC DAQmxGetAIConvMaxRate(TaskHandle taskHandle, float64 *data);

Purpose

DAQmxGetAIConvMaxRate gets the More >> AI Convert >> Maximum Rate property.


Get/Set/Reset Dev_IsSimulated

int32 __CFUNC DAQmxGetDevIsSimulated(const char device[], bool32 *data);

Purpose

DAQmxGetDevIsSimulated gets the Device Is Simulated property.


Get/Set/Reset PersistedTask_Author

int32 __CFUNC DAQmxGetPersistedTaskAuthor(const char taskName[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetPersistedTaskAuthor gets the Author property.


Get/Set/Reset PersistedTask_AllowInteractiveEditing

int32 __CFUNC DAQmxGetPersistedTaskAllowInteractiveEditing(const char taskName[], bool32 *data);

Purpose

DAQmxGetPersistedTaskAllowInteractiveEditing gets the Allow Interactive Editing? property.


Get/Set/Reset PersistedTask_AllowInteractiveDeletion

int32 __CFUNC DAQmxGetPersistedTaskAllowInteractiveDeletion(const char taskName[], bool32 *data);

Purpose

DAQmxGetPersistedTaskAllowInteractiveDeletion gets the Allow Interactive Deletion? property.


Get/Set/Reset PersistedChan_Author

int32 __CFUNC DAQmxGetPersistedChanAuthor(const char channel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetPersistedChanAuthor gets the Author property.


Get/Set/Reset PersistedChan_AllowInteractiveEditing

int32 __CFUNC DAQmxGetPersistedChanAllowInteractiveEditing(const char channel[], bool32 *data);

Purpose

DAQmxGetPersistedChanAllowInteractiveEditing gets the Allow Interactive Editing? property.


Get/Set/Reset PersistedChan_AllowInteractiveDeletion

int32 __CFUNC DAQmxGetPersistedChanAllowInteractiveDeletion(const char channel[], bool32 *data);

Purpose

DAQmxGetPersistedChanAllowInteractiveDeletion gets the Allow Interactive Deletion? property.


Get/Set/Reset PersistedScale_Author

int32 __CFUNC DAQmxGetPersistedScaleAuthor(const char scaleName[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetPersistedScaleAuthor gets the Author property.


Get/Set/Reset PersistedScale_AllowInteractiveEditing

int32 __CFUNC DAQmxGetPersistedScaleAllowInteractiveEditing(const char scaleName[], bool32 *data);

Purpose

DAQmxGetPersistedScaleAllowInteractiveEditing gets the Allow Interactive Editing? property.


Get/Set/Reset PersistedScale_AllowInteractiveDeletion

int32 __CFUNC DAQmxGetPersistedScaleAllowInteractiveDeletion(const char scaleName[], bool32 *data);

Purpose

DAQmxGetPersistedScaleAllowInteractiveDeletion gets the Allow Interactive Deletion? property.


Get/Set/Reset AI_RawDataCompressionType

int32 __CFUNC DAQmxGetAIRawDataCompressionType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIRawDataCompressionType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIRawDataCompressionType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRawDataCompressionType gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Raw Data Compression Type property.

DAQmxSetAIRawDataCompressionType sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Raw Data Compression Type property.

DAQmxResetAIRawDataCompressionType resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Raw Data Compression Type property.


Get/Set/Reset AI_LossyLSBRemoval_CompressedSampSize

int32 __CFUNC DAQmxGetAILossyLSBRemovalCompressedSampSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAILossyLSBRemovalCompressedSampSize(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAILossyLSBRemovalCompressedSampSize(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILossyLSBRemovalCompressedSampSize gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Lossy LSB Removal >> Compressed Sample Size property.

DAQmxSetAILossyLSBRemovalCompressedSampSize sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Lossy LSB Removal >> Compressed Sample Size property.

DAQmxResetAILossyLSBRemovalCompressedSampSize resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Compression >> Lossy LSB Removal >> Compressed Sample Size property.


Get/Set/Reset AI_RawSampSize

int32 __CFUNC DAQmxGetAIRawSampSize(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetAIRawSampSize gets the Analog Input >> General Properties >> Digitizer/ADC >> Raw Sample Size property.


Get/Set/Reset SwitchDev_PwrDownLatchRelaysAfterSettling

int32 __CFUNC DAQmxGetSwitchDevPwrDownLatchRelaysAfterSettling(const char deviceName[], bool32 *data);

int32 __CFUNC DAQmxSetSwitchDevPwrDownLatchRelaysAfterSettling(const char deviceName[], bool32 data);

Purpose

DAQmxGetSwitchDevPwrDownLatchRelaysAfterSettling gets the Deprecated >> Power Down Latching Relays After Settling property.

DAQmxSetSwitchDevPwrDownLatchRelaysAfterSettling sets the Deprecated >> Power Down Latching Relays After Settling property.


Get/Set/Reset RealTime_NumOfWarmupIters

int32 __CFUNC DAQmxGetRealTimeNumOfWarmupIters(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetRealTimeNumOfWarmupIters(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetRealTimeNumOfWarmupIters(TaskHandle taskHandle);

Purpose

DAQmxGetRealTimeNumOfWarmupIters gets the Number Of Warmup Iterations property.

DAQmxSetRealTimeNumOfWarmupIters sets the Number Of Warmup Iterations property.

DAQmxResetRealTimeNumOfWarmupIters resets the Number Of Warmup Iterations property.


Get/Set/Reset RealTime_ConvLateErrorsToWarnings

int32 __CFUNC DAQmxGetRealTimeConvLateErrorsToWarnings(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetRealTimeConvLateErrorsToWarnings(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetRealTimeConvLateErrorsToWarnings(TaskHandle taskHandle);

Purpose

DAQmxGetRealTimeConvLateErrorsToWarnings gets the Convert Late Errors To Warnings property.

DAQmxSetRealTimeConvLateErrorsToWarnings sets the Convert Late Errors To Warnings property.

DAQmxResetRealTimeConvLateErrorsToWarnings resets the Convert Late Errors To Warnings property.


Get/Set/Reset RealTime_WaitForNextSampClkWaitMode

int32 __CFUNC DAQmxGetRealTimeWaitForNextSampClkWaitMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetRealTimeWaitForNextSampClkWaitMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetRealTimeWaitForNextSampClkWaitMode(TaskHandle taskHandle);

Purpose

DAQmxGetRealTimeWaitForNextSampClkWaitMode gets the Wait For Next Sample Clock Wait Mode property.

DAQmxSetRealTimeWaitForNextSampClkWaitMode sets the Wait For Next Sample Clock Wait Mode property.

DAQmxResetRealTimeWaitForNextSampClkWaitMode resets the Wait For Next Sample Clock Wait Mode property.


Get/Set/Reset CI_SemiPeriod_StartingEdge

int32 __CFUNC DAQmxGetCISemiPeriodStartingEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodStartingEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISemiPeriodStartingEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodStartingEdge gets the Counter Input >> Semi-Period >> Starting Edge property.

DAQmxSetCISemiPeriodStartingEdge sets the Counter Input >> Semi-Period >> Starting Edge property.

DAQmxResetCISemiPeriodStartingEdge resets the Counter Input >> Semi-Period >> Starting Edge property.


Get/Set/Reset CO_RdyForNewVal

int32 __CFUNC DAQmxGetCORdyForNewVal(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetCORdyForNewVal gets the Counter Output >> General Properties >> More >> Advanced >> Ready For New Value property.


Get/Set/Reset Dev_CI_MaxTimebase

int32 __CFUNC DAQmxGetDevCIMaxTimebase(const char device[], float64 *data);

Purpose

DAQmxGetDevCIMaxTimebase gets the I/O Type >> Counter Input >> Maximum Timebase property.


Get/Set/Reset Dev_CO_MaxSize

int32 __CFUNC DAQmxGetDevCOMaxSize(const char device[], uInt32 *data);

Purpose

DAQmxGetDevCOMaxSize gets the I/O Type >> Counter Output >> Maximum Size property.


Get/Set/Reset Dev_CO_MaxTimebase

int32 __CFUNC DAQmxGetDevCOMaxTimebase(const char device[], float64 *data);

Purpose

DAQmxGetDevCOMaxTimebase gets the I/O Type >> Counter Output >> Maximum Timebase property.


Get/Set/Reset PhysicalChan_AO_TermCfgs

int32 __CFUNC DAQmxGetPhysicalChanAOTermCfgs(const char physicalChannel[], int32 *data);

Purpose

DAQmxGetPhysicalChanAOTermCfgs gets the Analog Output >> Output Configuration >> Terminal Configurations property.


Get/Set/Reset PhysicalChan_DI_PortWidth

int32 __CFUNC DAQmxGetPhysicalChanDIPortWidth(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanDIPortWidth gets the Digital Input >> Port Width property.


Get/Set/Reset PhysicalChan_DI_SampClkSupported

int32 __CFUNC DAQmxGetPhysicalChanDISampClkSupported(const char physicalChannel[], bool32 *data);

Purpose

DAQmxGetPhysicalChanDISampClkSupported gets the Digital Input >> Timing >> Sample Clock Supported property.


Get/Set/Reset PhysicalChan_DI_ChangeDetectSupported

int32 __CFUNC DAQmxGetPhysicalChanDIChangeDetectSupported(const char physicalChannel[], bool32 *data);

Purpose

DAQmxGetPhysicalChanDIChangeDetectSupported gets the Digital Input >> Timing >> Change Detection Supported property.


Get/Set/Reset PhysicalChan_DO_PortWidth

int32 __CFUNC DAQmxGetPhysicalChanDOPortWidth(const char physicalChannel[], uInt32 *data);

Purpose

DAQmxGetPhysicalChanDOPortWidth gets the Digital Output >> Port Width property.


Get/Set/Reset PhysicalChan_DO_SampClkSupported

int32 __CFUNC DAQmxGetPhysicalChanDOSampClkSupported(const char physicalChannel[], bool32 *data);

Purpose

DAQmxGetPhysicalChanDOSampClkSupported gets the Digital Output >> Timing >> Sample Clock Supported property.


Get/Set/Reset Dev_ProductCategory

int32 __CFUNC DAQmxGetDevProductCategory(const char device[], int32 *data);

Purpose

DAQmxGetDevProductCategory gets the Identification >> Product Category property.


Get/Set/Reset AI_Voltage_dBRef

int32 __CFUNC DAQmxGetAIVoltagedBRef(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIVoltagedBRef(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIVoltagedBRef(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVoltagedBRef gets the Analog Input >> Voltage >> dB Reference property.

DAQmxSetAIVoltagedBRef sets the Analog Input >> Voltage >> dB Reference property.

DAQmxResetAIVoltagedBRef resets the Analog Input >> Voltage >> dB Reference property.


Get/Set/Reset AI_SoundPressure_dBRef

int32 __CFUNC DAQmxGetAISoundPressuredBRef(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAISoundPressuredBRef(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAISoundPressuredBRef(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAISoundPressuredBRef gets the Analog Input >> Sound Pressure >> dB Reference property.

DAQmxSetAISoundPressuredBRef sets the Analog Input >> Sound Pressure >> dB Reference property.

DAQmxResetAISoundPressuredBRef resets the Analog Input >> Sound Pressure >> dB Reference property.


Get/Set/Reset AI_Accel_dBRef

int32 __CFUNC DAQmxGetAIAcceldBRef(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIAcceldBRef(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIAcceldBRef(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAcceldBRef gets the Analog Input >> Acceleration >> dB Reference property.

DAQmxSetAIAcceldBRef sets the Analog Input >> Acceleration >> dB Reference property.

DAQmxResetAIAcceldBRef resets the Analog Input >> Acceleration >> dB Reference property.


Get/Set/Reset Dev_Chassis_ModuleDevNames

int32 __CFUNC DAQmxGetDevChassisModuleDevNames(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevChassisModuleDevNames gets the Chassis >> Module Device Names property.


Get/Set/Reset Dev_CompactDAQ_ChassisDevName

int32 __CFUNC DAQmxGetDevCompactDAQChassisDevName(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevCompactDAQChassisDevName gets the Location >> CompactDAQ >> Chassis Device Name property.


Get/Set/Reset Dev_CompactDAQ_SlotNum

int32 __CFUNC DAQmxGetDevCompactDAQSlotNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevCompactDAQSlotNum gets the Location >> CompactDAQ >> Slot Number property.


Get/Set/Reset Task_NumDevices

int32 __CFUNC DAQmxGetTaskNumDevices(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetTaskNumDevices gets the Number of Devices property.


Get/Set/Reset Dev_AI_VoltageIntExcitDiscreteVals

int32 __CFUNC DAQmxGetDevAIVoltageIntExcitDiscreteVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIVoltageIntExcitDiscreteVals gets the I/O Type >> Analog Input >> Voltage >> Internal Excitation >> Discrete Values property.


Get/Set/Reset Dev_AI_VoltageIntExcitRangeVals

int32 __CFUNC DAQmxGetDevAIVoltageIntExcitRangeVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIVoltageIntExcitRangeVals gets the I/O Type >> Analog Input >> Voltage >> Internal Excitation >> Range Values property.


Get/Set/Reset Dev_AI_CurrentIntExcitDiscreteVals

int32 __CFUNC DAQmxGetDevAICurrentIntExcitDiscreteVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAICurrentIntExcitDiscreteVals gets the I/O Type >> Analog Input >> Current >> Internal Excitation >> Discrete Values property.


Get/Set/Reset Dev_AI_LowpassCutoffFreqRangeVals

int32 __CFUNC DAQmxGetDevAILowpassCutoffFreqRangeVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAILowpassCutoffFreqRangeVals gets the I/O Type >> Analog Input >> Filter >> Analog Low Pass >> Cutoff Frequency >> Range Values property.


Get/Set/Reset AI_Thrmcpl_ScaleType

int32 __CFUNC DAQmxGetAIThrmcplScaleType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIThrmcplScaleType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIThrmcplScaleType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmcplScaleType gets the Analog Input >> Temperature >> Thermocouple >> Scale Type property.

DAQmxSetAIThrmcplScaleType sets the Analog Input >> Temperature >> Thermocouple >> Scale Type property.

DAQmxResetAIThrmcplScaleType resets the Analog Input >> Temperature >> Thermocouple >> Scale Type property.


Get/Set/Reset Read_OvercurrentChansExist

int32 __CFUNC DAQmxGetReadOvercurrentChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOvercurrentChansExist gets the Status >> Overcurrent >> Overcurrent Channels Exist property.


Get/Set/Reset Read_OvercurrentChans

int32 __CFUNC DAQmxGetReadOvercurrentChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOvercurrentChans gets the Status >> Overcurrent >> Overcurrent Channels property.


Get/Set/Reset Write_OvercurrentChansExist

int32 __CFUNC DAQmxGetWriteOvercurrentChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteOvercurrentChansExist gets the Status >> Overcurrent >> Overcurrent Channels Exist property.


Get/Set/Reset Write_OvercurrentChans

int32 __CFUNC DAQmxGetWriteOvercurrentChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteOvercurrentChans gets the Status >> Overcurrent >> Overcurrent Channels property.


Get/Set/Reset Write_OpenCurrentLoopChansExist

int32 __CFUNC DAQmxGetWriteOpenCurrentLoopChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteOpenCurrentLoopChansExist gets the Status >> Open Current Loop >> Open Current Loop Channels Exist property.


Get/Set/Reset Write_OpenCurrentLoopChans

int32 __CFUNC DAQmxGetWriteOpenCurrentLoopChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteOpenCurrentLoopChans gets the Status >> Open Current Loop >> Open Current Loop Channels property.


Get/Set/Reset Write_PowerSupplyFaultChansExist

int32 __CFUNC DAQmxGetWritePowerSupplyFaultChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWritePowerSupplyFaultChansExist gets the Status >> Power Supply Fault >> Power Supply Fault Channels Exist property.


Get/Set/Reset Write_PowerSupplyFaultChans

int32 __CFUNC DAQmxGetWritePowerSupplyFaultChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWritePowerSupplyFaultChans gets the Status >> Power Supply Fault >> Power Supply Fault Channels property.


Get/Set/Reset CO_ConstrainedGenMode

int32 __CFUNC DAQmxGetCOConstrainedGenMode(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCOConstrainedGenMode(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCOConstrainedGenMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOConstrainedGenMode gets the Counter Output >> General Properties >> More >> Advanced >> Constrained Generation Mode property.

DAQmxSetCOConstrainedGenMode sets the Counter Output >> General Properties >> More >> Advanced >> Constrained Generation Mode property.

DAQmxResetCOConstrainedGenMode resets the Counter Output >> General Properties >> More >> Advanced >> Constrained Generation Mode property.


Get/Set/Reset AI_ADCTimingMode

int32 __CFUNC DAQmxGetAIADCTimingMode(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIADCTimingMode(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIADCTimingMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIADCTimingMode gets the Analog Input >> General Properties >> Digitizer/ADC >> Timing Mode property.

DAQmxSetAIADCTimingMode sets the Analog Input >> General Properties >> Digitizer/ADC >> Timing Mode property.

DAQmxResetAIADCTimingMode resets the Analog Input >> General Properties >> Digitizer/ADC >> Timing Mode property.


Get/Set/Reset CI_CountEdges_CountReset_LogicLvlBehavior

int32 __CFUNC DAQmxGetCICountEdgesCountResetLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetLogicLvlBehavior gets the Counter Input >> Count Edges >> Count Reset >> Input >> Logic Level Behavior property.

DAQmxSetCICountEdgesCountResetLogicLvlBehavior sets the Counter Input >> Count Edges >> Count Reset >> Input >> Logic Level Behavior property.

DAQmxResetCICountEdgesCountResetLogicLvlBehavior resets the Counter Input >> Count Edges >> Count Reset >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_DutyCycle_TermCfg

int32 __CFUNC DAQmxGetCIDutyCycleTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIDutyCycleTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIDutyCycleTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleTermCfg gets the Counter Input >> Duty Cycle >> Input >> Terminal Configuration property.

DAQmxSetCIDutyCycleTermCfg sets the Counter Input >> Duty Cycle >> Input >> Terminal Configuration property.

DAQmxResetCIDutyCycleTermCfg resets the Counter Input >> Duty Cycle >> Input >> Terminal Configuration property.


Get/Set/Reset CI_DutyCycle_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIDutyCycleLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIDutyCycleLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIDutyCycleLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleLogicLvlBehavior gets the Counter Input >> Duty Cycle >> Input >> Logic Level Behavior property.

DAQmxSetCIDutyCycleLogicLvlBehavior sets the Counter Input >> Duty Cycle >> Input >> Logic Level Behavior property.

DAQmxResetCIDutyCycleLogicLvlBehavior resets the Counter Input >> Duty Cycle >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_Encoder_AInputTermCfg

int32 __CFUNC DAQmxGetCIEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputTermCfg gets the Counter Input >> Position >> A Input >> Terminal Configuration property.

DAQmxSetCIEncoderAInputTermCfg sets the Counter Input >> Position >> A Input >> Terminal Configuration property.

DAQmxResetCIEncoderAInputTermCfg resets the Counter Input >> Position >> A Input >> Terminal Configuration property.


Get/Set/Reset CI_Encoder_AInputLogicLvlBehavior

int32 __CFUNC DAQmxGetCIEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputLogicLvlBehavior gets the Counter Input >> Position >> A Input >> Logic Level Behavior property.

DAQmxSetCIEncoderAInputLogicLvlBehavior sets the Counter Input >> Position >> A Input >> Logic Level Behavior property.

DAQmxResetCIEncoderAInputLogicLvlBehavior resets the Counter Input >> Position >> A Input >> Logic Level Behavior property.


Get/Set/Reset CI_Encoder_BInputTermCfg

int32 __CFUNC DAQmxGetCIEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputTermCfg gets the Counter Input >> Position >> B Input >> Terminal Configuration property.

DAQmxSetCIEncoderBInputTermCfg sets the Counter Input >> Position >> B Input >> Terminal Configuration property.

DAQmxResetCIEncoderBInputTermCfg resets the Counter Input >> Position >> B Input >> Terminal Configuration property.


Get/Set/Reset CI_Encoder_BInputLogicLvlBehavior

int32 __CFUNC DAQmxGetCIEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputLogicLvlBehavior gets the Counter Input >> Position >> B Input >> Logic Level Behavior property.

DAQmxSetCIEncoderBInputLogicLvlBehavior sets the Counter Input >> Position >> B Input >> Logic Level Behavior property.

DAQmxResetCIEncoderBInputLogicLvlBehavior resets the Counter Input >> Position >> B Input >> Logic Level Behavior property.


Get/Set/Reset CI_Encoder_ZInputTermCfg

int32 __CFUNC DAQmxGetCIEncoderZInputTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderZInputTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputTermCfg gets the Counter Input >> Position >> Z Input >> Terminal Configuration property.

DAQmxSetCIEncoderZInputTermCfg sets the Counter Input >> Position >> Z Input >> Terminal Configuration property.

DAQmxResetCIEncoderZInputTermCfg resets the Counter Input >> Position >> Z Input >> Terminal Configuration property.


Get/Set/Reset CI_Encoder_ZInputLogicLvlBehavior

int32 __CFUNC DAQmxGetCIEncoderZInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderZInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputLogicLvlBehavior gets the Counter Input >> Position >> Z Input >> Logic Level Behavior property.

DAQmxSetCIEncoderZInputLogicLvlBehavior sets the Counter Input >> Position >> Z Input >> Logic Level Behavior property.

DAQmxResetCIEncoderZInputLogicLvlBehavior resets the Counter Input >> Position >> Z Input >> Logic Level Behavior property.


Get/Set/Reset CI_PulseWidth_TermCfg

int32 __CFUNC DAQmxGetCIPulseWidthTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseWidthTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthTermCfg gets the Counter Input >> Pulse Width >> Input >> Terminal Configuration property.

DAQmxSetCIPulseWidthTermCfg sets the Counter Input >> Pulse Width >> Input >> Terminal Configuration property.

DAQmxResetCIPulseWidthTermCfg resets the Counter Input >> Pulse Width >> Input >> Terminal Configuration property.


Get/Set/Reset CI_PulseWidth_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIPulseWidthLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseWidthLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthLogicLvlBehavior gets the Counter Input >> Pulse Width >> Input >> Logic Level Behavior property.

DAQmxSetCIPulseWidthLogicLvlBehavior sets the Counter Input >> Pulse Width >> Input >> Logic Level Behavior property.

DAQmxResetCIPulseWidthLogicLvlBehavior resets the Counter Input >> Pulse Width >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_TwoEdgeSep_FirstTermCfg

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstTermCfg gets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal Configuration property.

DAQmxSetCITwoEdgeSepFirstTermCfg sets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal Configuration property.

DAQmxResetCITwoEdgeSepFirstTermCfg resets the Counter Input >> Two Edge Separation >> First >> Input >> Terminal Configuration property.


Get/Set/Reset CI_TwoEdgeSep_FirstLogicLvlBehavior

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstLogicLvlBehavior gets the Counter Input >> Two Edge Separation >> First >> Input >> Logic Level Behavior property.

DAQmxSetCITwoEdgeSepFirstLogicLvlBehavior sets the Counter Input >> Two Edge Separation >> First >> Input >> Logic Level Behavior property.

DAQmxResetCITwoEdgeSepFirstLogicLvlBehavior resets the Counter Input >> Two Edge Separation >> First >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_TwoEdgeSep_SecondTermCfg

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondTermCfg gets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal Configuration property.

DAQmxSetCITwoEdgeSepSecondTermCfg sets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal Configuration property.

DAQmxResetCITwoEdgeSepSecondTermCfg resets the Counter Input >> Two Edge Separation >> Second >> Input >> Terminal Configuration property.


Get/Set/Reset CI_TwoEdgeSep_SecondLogicLvlBehavior

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondLogicLvlBehavior gets the Counter Input >> Two Edge Separation >> Second >> Input >> Logic Level Behavior property.

DAQmxSetCITwoEdgeSepSecondLogicLvlBehavior sets the Counter Input >> Two Edge Separation >> Second >> Input >> Logic Level Behavior property.

DAQmxResetCITwoEdgeSepSecondLogicLvlBehavior resets the Counter Input >> Two Edge Separation >> Second >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_SemiPeriod_TermCfg

int32 __CFUNC DAQmxGetCISemiPeriodTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISemiPeriodTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodTermCfg gets the Counter Input >> Semi-Period >> Input >> Terminal Configuration property.

DAQmxSetCISemiPeriodTermCfg sets the Counter Input >> Semi-Period >> Input >> Terminal Configuration property.

DAQmxResetCISemiPeriodTermCfg resets the Counter Input >> Semi-Period >> Input >> Terminal Configuration property.


Get/Set/Reset CI_SemiPeriod_LogicLvlBehavior

int32 __CFUNC DAQmxGetCISemiPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISemiPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodLogicLvlBehavior gets the Counter Input >> Semi-Period >> Input >> Logic Level Behavior property.

DAQmxSetCISemiPeriodLogicLvlBehavior sets the Counter Input >> Semi-Period >> Input >> Logic Level Behavior property.

DAQmxResetCISemiPeriodLogicLvlBehavior resets the Counter Input >> Semi-Period >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_Pulse_Freq_TermCfg

int32 __CFUNC DAQmxGetCIPulseFreqTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseFreqTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqTermCfg gets the Counter Input >> Pulse >> Frequency >> Input >> Terminal Configuration property.

DAQmxSetCIPulseFreqTermCfg sets the Counter Input >> Pulse >> Frequency >> Input >> Terminal Configuration property.

DAQmxResetCIPulseFreqTermCfg resets the Counter Input >> Pulse >> Frequency >> Input >> Terminal Configuration property.


Get/Set/Reset CI_Pulse_Freq_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIPulseFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseFreqLogicLvlBehavior gets the Counter Input >> Pulse >> Frequency >> Input >> Logic Level Behavior property.

DAQmxSetCIPulseFreqLogicLvlBehavior sets the Counter Input >> Pulse >> Frequency >> Input >> Logic Level Behavior property.

DAQmxResetCIPulseFreqLogicLvlBehavior resets the Counter Input >> Pulse >> Frequency >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_Pulse_Time_TermCfg

int32 __CFUNC DAQmxGetCIPulseTimeTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTimeTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeTermCfg gets the Counter Input >> Pulse >> Time >> Input >> Terminal Configuration property.

DAQmxSetCIPulseTimeTermCfg sets the Counter Input >> Pulse >> Time >> Input >> Terminal Configuration property.

DAQmxResetCIPulseTimeTermCfg resets the Counter Input >> Pulse >> Time >> Input >> Terminal Configuration property.


Get/Set/Reset CI_Pulse_Time_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIPulseTimeLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTimeLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTimeLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTimeLogicLvlBehavior gets the Counter Input >> Pulse >> Time >> Input >> Logic Level Behavior property.

DAQmxSetCIPulseTimeLogicLvlBehavior sets the Counter Input >> Pulse >> Time >> Input >> Logic Level Behavior property.

DAQmxResetCIPulseTimeLogicLvlBehavior resets the Counter Input >> Pulse >> Time >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_Pulse_Ticks_TermCfg

int32 __CFUNC DAQmxGetCIPulseTicksTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTicksTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTicksTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksTermCfg gets the Counter Input >> Pulse >> Ticks >> Input >> Terminal Configuration property.

DAQmxSetCIPulseTicksTermCfg sets the Counter Input >> Pulse >> Ticks >> Input >> Terminal Configuration property.

DAQmxResetCIPulseTicksTermCfg resets the Counter Input >> Pulse >> Ticks >> Input >> Terminal Configuration property.


Get/Set/Reset CI_Pulse_Ticks_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIPulseTicksLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseTicksLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseTicksLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseTicksLogicLvlBehavior gets the Counter Input >> Pulse >> Ticks >> Input >> Logic Level Behavior property.

DAQmxSetCIPulseTicksLogicLvlBehavior sets the Counter Input >> Pulse >> Ticks >> Input >> Logic Level Behavior property.

DAQmxResetCIPulseTicksLogicLvlBehavior resets the Counter Input >> Pulse >> Ticks >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_ThreshVoltage

int32 __CFUNC DAQmxGetCIThreshVoltage(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIThreshVoltage(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIThreshVoltage(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIThreshVoltage gets the Counter Input >> General Properties >> Input Configuration >> Voltage Threshold Level property.

DAQmxSetCIThreshVoltage sets the Counter Input >> General Properties >> Input Configuration >> Voltage Threshold Level property.

DAQmxResetCIThreshVoltage resets the Counter Input >> General Properties >> Input Configuration >> Voltage Threshold Level property.


Get/Set/Reset AI_Excit_IdleOutputBehavior

int32 __CFUNC DAQmxGetAIExcitIdleOutputBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIExcitIdleOutputBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIExcitIdleOutputBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitIdleOutputBehavior gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Idle Output Behavior property.

DAQmxSetAIExcitIdleOutputBehavior sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Idle Output Behavior property.

DAQmxResetAIExcitIdleOutputBehavior resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Idle Output Behavior property.


Get/Set/Reset Write_ExternalOvervoltageChansExist

int32 __CFUNC DAQmxGetWriteExternalOvervoltageChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteExternalOvervoltageChansExist gets the Status >> External Overvoltage >> External Overvoltage Channels Exist property.


Get/Set/Reset Write_ExternalOvervoltageChans

int32 __CFUNC DAQmxGetWriteExternalOvervoltageChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteExternalOvervoltageChans gets the Status >> External Overvoltage >> External Overvoltage Channels property.


Get/Set/Reset AI_DigFltr_Enable

int32 __CFUNC DAQmxGetAIDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrEnable gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Enable property.

DAQmxSetAIDigFltrEnable sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Enable property.

DAQmxResetAIDigFltrEnable resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Enable property.


Get/Set/Reset AI_DigFltr_Type

int32 __CFUNC DAQmxGetAIDigFltrType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIDigFltrType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIDigFltrType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrType gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Type property.

DAQmxSetAIDigFltrType sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Type property.

DAQmxResetAIDigFltrType resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Type property.


Get/Set/Reset AI_DigFltr_Response

int32 __CFUNC DAQmxGetAIDigFltrResponse(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIDigFltrResponse(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIDigFltrResponse(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrResponse gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Response property.

DAQmxSetAIDigFltrResponse sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Response property.

DAQmxResetAIDigFltrResponse resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Response property.


Get/Set/Reset AI_DigFltr_Order

int32 __CFUNC DAQmxGetAIDigFltrOrder(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIDigFltrOrder(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIDigFltrOrder(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrOrder gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Order property.

DAQmxSetAIDigFltrOrder sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Order property.

DAQmxResetAIDigFltrOrder resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Order property.


Get/Set/Reset AI_DigFltr_Lowpass_CutoffFreq

int32 __CFUNC DAQmxGetAIDigFltrLowpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrLowpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrLowpassCutoffFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrLowpassCutoffFreq gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Lowpass >> Cutoff Frequency property.

DAQmxSetAIDigFltrLowpassCutoffFreq sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Lowpass >> Cutoff Frequency property.

DAQmxResetAIDigFltrLowpassCutoffFreq resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Lowpass >> Cutoff Frequency property.


Get/Set/Reset AI_DigFltr_Highpass_CutoffFreq

int32 __CFUNC DAQmxGetAIDigFltrHighpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrHighpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrHighpassCutoffFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrHighpassCutoffFreq gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Highpass >> Cutoff Frequency property.

DAQmxSetAIDigFltrHighpassCutoffFreq sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Highpass >> Cutoff Frequency property.

DAQmxResetAIDigFltrHighpassCutoffFreq resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Highpass >> Cutoff Frequency property.


Get/Set/Reset AI_DigFltr_Bandpass_CenterFreq

int32 __CFUNC DAQmxGetAIDigFltrBandpassCenterFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrBandpassCenterFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrBandpassCenterFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrBandpassCenterFreq gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Center Frequency property.

DAQmxSetAIDigFltrBandpassCenterFreq sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Center Frequency property.

DAQmxResetAIDigFltrBandpassCenterFreq resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Center Frequency property.


Get/Set/Reset AI_DigFltr_Bandpass_Width

int32 __CFUNC DAQmxGetAIDigFltrBandpassWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrBandpassWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrBandpassWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrBandpassWidth gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Width property.

DAQmxSetAIDigFltrBandpassWidth sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Width property.

DAQmxResetAIDigFltrBandpassWidth resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Bandpass >> Width property.


Get/Set/Reset AI_DigFltr_Notch_CenterFreq

int32 __CFUNC DAQmxGetAIDigFltrNotchCenterFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrNotchCenterFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrNotchCenterFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrNotchCenterFreq gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Center Frequency property.

DAQmxSetAIDigFltrNotchCenterFreq sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Center Frequency property.

DAQmxResetAIDigFltrNotchCenterFreq resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Center Frequency property.


Get/Set/Reset AI_DigFltr_Notch_Width

int32 __CFUNC DAQmxGetAIDigFltrNotchWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIDigFltrNotchWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIDigFltrNotchWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrNotchWidth gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Width property.

DAQmxSetAIDigFltrNotchWidth sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Width property.

DAQmxResetAIDigFltrNotchWidth resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Notch >> Width property.


Get/Set/Reset AI_DigFltr_Coeff

int32 __CFUNC DAQmxGetAIDigFltrCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIDigFltrCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIDigFltrCoeff(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDigFltrCoeff gets the Analog Input >> General Properties >> Filter >> Digital Filter >> Advanced >> Coefficients property.

DAQmxSetAIDigFltrCoeff sets the Analog Input >> General Properties >> Filter >> Digital Filter >> Advanced >> Coefficients property.

DAQmxResetAIDigFltrCoeff resets the Analog Input >> General Properties >> Filter >> Digital Filter >> Advanced >> Coefficients property.


Get/Set/Reset Dev_AI_DigFltr_LowpassCutoffFreqDiscreteVals

int32 __CFUNC DAQmxGetDevAIDigFltrLowpassCutoffFreqDiscreteVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIDigFltrLowpassCutoffFreqDiscreteVals gets the I/O Type >> Analog Input >> Filter >> Digital Filter >> Low Pass >> Cutoff Frequency >> Discrete Values property.


Get/Set/Reset Dev_AI_DigFltr_LowpassCutoffFreqRangeVals

int32 __CFUNC DAQmxGetDevAIDigFltrLowpassCutoffFreqRangeVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIDigFltrLowpassCutoffFreqRangeVals gets the I/O Type >> Analog Input >> Filter >> Digital Filter >> Low Pass >> Cutoff Frequency >> Range Values property.


Get/Set/Reset AI_Bridge_ShuntCal_ShuntCalASrc

int32 __CFUNC DAQmxGetAIBridgeShuntCalShuntCalASrc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalShuntCalASrc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalShuntCalASrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalShuntCalASrc gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Source property.

DAQmxSetAIBridgeShuntCalShuntCalASrc sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Source property.

DAQmxResetAIBridgeShuntCalShuntCalASrc resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal A Source property.


Get/Set/Reset CI_Velocity_AngEncoder_Units

int32 __CFUNC DAQmxGetCIVelocityAngEncoderUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityAngEncoderUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityAngEncoderUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityAngEncoderUnits gets the Counter Input >> Velocity >> Angular Encoder >> Units property.

DAQmxSetCIVelocityAngEncoderUnits sets the Counter Input >> Velocity >> Angular Encoder >> Units property.

DAQmxResetCIVelocityAngEncoderUnits resets the Counter Input >> Velocity >> Angular Encoder >> Units property.


Get/Set/Reset CI_Velocity_AngEncoder_PulsesPerRev

int32 __CFUNC DAQmxGetCIVelocityAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIVelocityAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIVelocityAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityAngEncoderPulsesPerRev gets the Counter Input >> Velocity >> Angular Encoder >> Pulses Per Revolution property.

DAQmxSetCIVelocityAngEncoderPulsesPerRev sets the Counter Input >> Velocity >> Angular Encoder >> Pulses Per Revolution property.

DAQmxResetCIVelocityAngEncoderPulsesPerRev resets the Counter Input >> Velocity >> Angular Encoder >> Pulses Per Revolution property.


Get/Set/Reset CI_Velocity_LinEncoder_Units

int32 __CFUNC DAQmxGetCIVelocityLinEncoderUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityLinEncoderUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityLinEncoderUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityLinEncoderUnits gets the Counter Input >> Velocity >> Linear Encoder >> Units property.

DAQmxSetCIVelocityLinEncoderUnits sets the Counter Input >> Velocity >> Linear Encoder >> Units property.

DAQmxResetCIVelocityLinEncoderUnits resets the Counter Input >> Velocity >> Linear Encoder >> Units property.


Get/Set/Reset CI_Velocity_LinEncoder_DistPerPulse

int32 __CFUNC DAQmxGetCIVelocityLinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityLinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityLinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityLinEncoderDistPerPulse gets the Counter Input >> Velocity >> Linear Encoder >> Distance per Pulse property.

DAQmxSetCIVelocityLinEncoderDistPerPulse sets the Counter Input >> Velocity >> Linear Encoder >> Distance per Pulse property.

DAQmxResetCIVelocityLinEncoderDistPerPulse resets the Counter Input >> Velocity >> Linear Encoder >> Distance per Pulse property.


Get/Set/Reset CI_Velocity_Encoder_DecodingType

int32 __CFUNC DAQmxGetCIVelocityEncoderDecodingType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderDecodingType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderDecodingType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderDecodingType gets the Counter Input >> Velocity >> Decoding Type property.

DAQmxSetCIVelocityEncoderDecodingType sets the Counter Input >> Velocity >> Decoding Type property.

DAQmxResetCIVelocityEncoderDecodingType resets the Counter Input >> Velocity >> Decoding Type property.


Get/Set/Reset CI_Velocity_Encoder_AInputTerm

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputTerm gets the Counter Input >> Velocity >> A Input >> Terminal property.

DAQmxSetCIVelocityEncoderAInputTerm sets the Counter Input >> Velocity >> A Input >> Terminal property.

DAQmxResetCIVelocityEncoderAInputTerm resets the Counter Input >> Velocity >> A Input >> Terminal property.


Get/Set/Reset CI_Velocity_Encoder_AInputTermCfg

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputTermCfg gets the Counter Input >> Velocity >> A Input >> Terminal Configuration property.

DAQmxSetCIVelocityEncoderAInputTermCfg sets the Counter Input >> Velocity >> A Input >> Terminal Configuration property.

DAQmxResetCIVelocityEncoderAInputTermCfg resets the Counter Input >> Velocity >> A Input >> Terminal Configuration property.


Get/Set/Reset CI_Velocity_Encoder_AInputLogicLvlBehavior

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputLogicLvlBehavior gets the Counter Input >> Velocity >> A Input >> Logic Level Behavior property.

DAQmxSetCIVelocityEncoderAInputLogicLvlBehavior sets the Counter Input >> Velocity >> A Input >> Logic Level Behavior property.

DAQmxResetCIVelocityEncoderAInputLogicLvlBehavior resets the Counter Input >> Velocity >> A Input >> Logic Level Behavior property.


Get/Set/Reset CI_Velocity_Encoder_AInputDigFltr_Enable

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputDigFltrEnable gets the Counter Input >> Velocity >> A Input >> Digital Filter >> Enable property.

DAQmxSetCIVelocityEncoderAInputDigFltrEnable sets the Counter Input >> Velocity >> A Input >> Digital Filter >> Enable property.

DAQmxResetCIVelocityEncoderAInputDigFltrEnable resets the Counter Input >> Velocity >> A Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Velocity_Encoder_AInputDigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputDigFltrMinPulseWidth gets the Counter Input >> Velocity >> A Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIVelocityEncoderAInputDigFltrMinPulseWidth sets the Counter Input >> Velocity >> A Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIVelocityEncoderAInputDigFltrMinPulseWidth resets the Counter Input >> Velocity >> A Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Velocity_Encoder_AInputDigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseSrc gets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Source property.

DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseSrc sets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Source property.

DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseSrc resets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Source property.


Get/Set/Reset CI_Velocity_Encoder_AInputDigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderAInputDigFltrTimebaseRate gets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Rate property.

DAQmxSetCIVelocityEncoderAInputDigFltrTimebaseRate sets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Rate property.

DAQmxResetCIVelocityEncoderAInputDigFltrTimebaseRate resets the Counter Input >> Velocity >> A Input >> Digital Filter >> Timebase Rate property.


Get/Set/Reset CI_Velocity_Encoder_BInputTerm

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputTerm gets the Counter Input >> Velocity >> B Input >> Terminal property.

DAQmxSetCIVelocityEncoderBInputTerm sets the Counter Input >> Velocity >> B Input >> Terminal property.

DAQmxResetCIVelocityEncoderBInputTerm resets the Counter Input >> Velocity >> B Input >> Terminal property.


Get/Set/Reset CI_Velocity_Encoder_BInputTermCfg

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputTermCfg gets the Counter Input >> Velocity >> B Input >> Terminal Configuration property.

DAQmxSetCIVelocityEncoderBInputTermCfg sets the Counter Input >> Velocity >> B Input >> Terminal Configuration property.

DAQmxResetCIVelocityEncoderBInputTermCfg resets the Counter Input >> Velocity >> B Input >> Terminal Configuration property.


Get/Set/Reset CI_Velocity_Encoder_BInputLogicLvlBehavior

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputLogicLvlBehavior gets the Counter Input >> Velocity >> B Input >> Logic Level Behavior property.

DAQmxSetCIVelocityEncoderBInputLogicLvlBehavior sets the Counter Input >> Velocity >> B Input >> Logic Level Behavior property.

DAQmxResetCIVelocityEncoderBInputLogicLvlBehavior resets the Counter Input >> Velocity >> B Input >> Logic Level Behavior property.


Get/Set/Reset CI_Velocity_Encoder_BInputDigFltr_Enable

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputDigFltrEnable gets the Counter Input >> Velocity >> B Input >> Digital Filter >> Enable property.

DAQmxSetCIVelocityEncoderBInputDigFltrEnable sets the Counter Input >> Velocity >> B Input >> Digital Filter >> Enable property.

DAQmxResetCIVelocityEncoderBInputDigFltrEnable resets the Counter Input >> Velocity >> B Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Velocity_Encoder_BInputDigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputDigFltrMinPulseWidth gets the Counter Input >> Velocity >> B Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIVelocityEncoderBInputDigFltrMinPulseWidth sets the Counter Input >> Velocity >> B Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIVelocityEncoderBInputDigFltrMinPulseWidth resets the Counter Input >> Velocity >> B Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Velocity_Encoder_BInputDigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseSrc gets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Source property.

DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseSrc sets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Source property.

DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseSrc resets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Source property.


Get/Set/Reset CI_Velocity_Encoder_BInputDigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityEncoderBInputDigFltrTimebaseRate gets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Rate property.

DAQmxSetCIVelocityEncoderBInputDigFltrTimebaseRate sets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Rate property.

DAQmxResetCIVelocityEncoderBInputDigFltrTimebaseRate resets the Counter Input >> Velocity >> B Input >> Digital Filter >> Timebase Rate property.


Get/Set/Reset CI_Velocity_MeasTime

int32 __CFUNC DAQmxGetCIVelocityMeasTime(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIVelocityMeasTime(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIVelocityMeasTime(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityMeasTime gets the Counter Input >> Velocity >> Advanced >> Measurement Time property.

DAQmxSetCIVelocityMeasTime sets the Counter Input >> Velocity >> Advanced >> Measurement Time property.

DAQmxResetCIVelocityMeasTime resets the Counter Input >> Velocity >> Advanced >> Measurement Time property.


Get/Set/Reset CI_Velocity_Div

int32 __CFUNC DAQmxGetCIVelocityDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIVelocityDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIVelocityDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIVelocityDiv gets the Counter Input >> Velocity >> Advanced >> Divisor property.

DAQmxSetCIVelocityDiv sets the Counter Input >> Velocity >> Advanced >> Divisor property.

DAQmxResetCIVelocityDiv resets the Counter Input >> Velocity >> Advanced >> Divisor property.


Get/Set/Reset CI_CountEdges_Gate_Enable

int32 __CFUNC DAQmxGetCICountEdgesGateEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesGateEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateEnable gets the Counter Input >> Count Edges >> Gate >> Enable property.

DAQmxSetCICountEdgesGateEnable sets the Counter Input >> Count Edges >> Gate >> Enable property.

DAQmxResetCICountEdgesGateEnable resets the Counter Input >> Count Edges >> Gate >> Enable property.


Get/Set/Reset CI_CountEdges_Gate_Term

int32 __CFUNC DAQmxGetCICountEdgesGateTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesGateTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesGateTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateTerm gets the Counter Input >> Count Edges >> Gate >> Input >> Terminal property.

DAQmxSetCICountEdgesGateTerm sets the Counter Input >> Count Edges >> Gate >> Input >> Terminal property.

DAQmxResetCICountEdgesGateTerm resets the Counter Input >> Count Edges >> Gate >> Input >> Terminal property.


Get/Set/Reset CI_CountEdges_Gate_TermCfg

int32 __CFUNC DAQmxGetCICountEdgesGateTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesGateTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateTermCfg gets the Counter Input >> Count Edges >> Gate >> Input >> Terminal Configuration property.

DAQmxSetCICountEdgesGateTermCfg sets the Counter Input >> Count Edges >> Gate >> Input >> Terminal Configuration property.

DAQmxResetCICountEdgesGateTermCfg resets the Counter Input >> Count Edges >> Gate >> Input >> Terminal Configuration property.


Get/Set/Reset CI_CountEdges_Gate_LogicLvlBehavior

int32 __CFUNC DAQmxGetCICountEdgesGateLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesGateLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateLogicLvlBehavior gets the Counter Input >> Count Edges >> Gate >> Input >> Logic Level Behavior property.

DAQmxSetCICountEdgesGateLogicLvlBehavior sets the Counter Input >> Count Edges >> Gate >> Input >> Logic Level Behavior property.

DAQmxResetCICountEdgesGateLogicLvlBehavior resets the Counter Input >> Count Edges >> Gate >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_CountEdges_Gate_DigFltrEnable

int32 __CFUNC DAQmxGetCICountEdgesGateDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICountEdgesGateDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateDigFltrEnable gets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Enable property.

DAQmxSetCICountEdgesGateDigFltrEnable sets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Enable property.

DAQmxResetCICountEdgesGateDigFltrEnable resets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_CountEdges_Gate_DigFltrMinPulseWidth

int32 __CFUNC DAQmxGetCICountEdgesGateDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesGateDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateDigFltrMinPulseWidth gets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCICountEdgesGateDigFltrMinPulseWidth sets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCICountEdgesGateDigFltrMinPulseWidth resets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_CountEdges_Gate_DigFltrTimebaseSrc

int32 __CFUNC DAQmxGetCICountEdgesGateDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICountEdgesGateDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICountEdgesGateDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateDigFltrTimebaseSrc gets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCICountEdgesGateDigFltrTimebaseSrc sets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCICountEdgesGateDigFltrTimebaseSrc resets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_CountEdges_Gate_DigFltrTimebaseRate

int32 __CFUNC DAQmxGetCICountEdgesGateDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICountEdgesGateDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateDigFltrTimebaseRate gets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCICountEdgesGateDigFltrTimebaseRate sets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCICountEdgesGateDigFltrTimebaseRate resets the Counter Input >> Count Edges >> Gate >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_CountEdges_GateWhen

int32 __CFUNC DAQmxGetCICountEdgesGateWhen(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesGateWhen(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesGateWhen(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesGateWhen gets the Counter Input >> Count Edges >> Gate >> Pause When property.

DAQmxSetCICountEdgesGateWhen sets the Counter Input >> Count Edges >> Gate >> Pause When property.

DAQmxResetCICountEdgesGateWhen resets the Counter Input >> Count Edges >> Gate >> Pause When property.


Get/Set/Reset SampClk_WriteWfm_UseInitialWfmDT

int32 __CFUNC DAQmxGetSampClkWriteWfmUseInitialWfmDT(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetSampClkWriteWfmUseInitialWfmDT(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetSampClkWriteWfmUseInitialWfmDT(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkWriteWfmUseInitialWfmDT gets the Sample Clock >> Write Waveform >> Use Initial Waveform dt property.

DAQmxSetSampClkWriteWfmUseInitialWfmDT sets the Sample Clock >> Write Waveform >> Use Initial Waveform dt property.

DAQmxResetSampClkWriteWfmUseInitialWfmDT resets the Sample Clock >> Write Waveform >> Use Initial Waveform dt property.


Get/Set/Reset AI_Excit_Sense

int32 __CFUNC DAQmxGetAIExcitSense(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIExcitSense(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIExcitSense(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitSense gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Sense property.

DAQmxSetAIExcitSense sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Sense property.

DAQmxResetAIExcitSense resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Sense property.


Get/Set/Reset AI_OpenChanDetectEnable

int32 __CFUNC DAQmxGetAIOpenChanDetectEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIOpenChanDetectEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIOpenChanDetectEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIOpenChanDetectEnable gets the Analog Input >> General Properties >> Advanced >> Open Channel Detection Enable property.

DAQmxSetAIOpenChanDetectEnable sets the Analog Input >> General Properties >> Advanced >> Open Channel Detection Enable property.

DAQmxResetAIOpenChanDetectEnable resets the Analog Input >> General Properties >> Advanced >> Open Channel Detection Enable property.


Get/Set/Reset AI_RawSampJustification

int32 __CFUNC DAQmxGetAIRawSampJustification(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAIRawSampJustification gets the Analog Input >> General Properties >> Digitizer/ADC >> Raw Sample Justification property.


Get/Set/Reset AI_Impedance

int32 __CFUNC DAQmxGetAIImpedance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIImpedance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIImpedance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIImpedance gets the Analog Input >> General Properties >> Input Configuration >> Impedance property.

DAQmxSetAIImpedance sets the Analog Input >> General Properties >> Input Configuration >> Impedance property.

DAQmxResetAIImpedance resets the Analog Input >> General Properties >> Input Configuration >> Impedance property.


Get/Set/Reset AI_Coupling

int32 __CFUNC DAQmxGetAICoupling(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAICoupling(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAICoupling(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICoupling gets the Analog Input >> General Properties >> Input Configuration >> Coupling property.

DAQmxSetAICoupling sets the Analog Input >> General Properties >> Input Configuration >> Coupling property.

DAQmxResetAICoupling resets the Analog Input >> General Properties >> Input Configuration >> Coupling property.


Get/Set/Reset AI_Dither_Enable

int32 __CFUNC DAQmxGetAIDitherEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIDitherEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIDitherEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDitherEnable gets the Analog Input >> General Properties >> Digitizer/ADC >> Dither >> Enable property.

DAQmxSetAIDitherEnable sets the Analog Input >> General Properties >> Digitizer/ADC >> Dither >> Enable property.

DAQmxResetAIDitherEnable resets the Analog Input >> General Properties >> Digitizer/ADC >> Dither >> Enable property.


Get/Set/Reset AI_Bridge_Cfg

int32 __CFUNC DAQmxGetAIBridgeCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIBridgeCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIBridgeCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeCfg gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Configuration property.

DAQmxSetAIBridgeCfg sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Configuration property.

DAQmxResetAIBridgeCfg resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Configuration property.


Get/Set/Reset AI_Bridge_ShuntCal_Enable

int32 __CFUNC DAQmxGetAIBridgeShuntCalEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalEnable gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Enable property.

DAQmxSetAIBridgeShuntCalEnable sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Enable property.

DAQmxResetAIBridgeShuntCalEnable resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Shunt Cal Enable property.


Get/Set/Reset AI_ACExcit_Freq

int32 __CFUNC DAQmxGetAIACExcitFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIACExcitFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIACExcitFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIACExcitFreq gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Frequency property.

DAQmxSetAIACExcitFreq sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Frequency property.

DAQmxResetAIACExcitFreq resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Frequency property.


Get/Set/Reset AI_ACExcit_SyncEnable

int32 __CFUNC DAQmxGetAIACExcitSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIACExcitSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIACExcitSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIACExcitSyncEnable gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Synchronization Enable property.

DAQmxSetAIACExcitSyncEnable sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Synchronization Enable property.

DAQmxResetAIACExcitSyncEnable resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> AC Excitation >> Synchronization Enable property.


Get/Set/Reset AO_Gain

int32 __CFUNC DAQmxGetAOGain(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOGain(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOGain(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOGain gets the Analog Output >> General Properties >> Advanced >> Gain >> Gain Value property.

DAQmxSetAOGain sets the Analog Output >> General Properties >> Advanced >> Gain >> Gain Value property.

DAQmxResetAOGain resets the Analog Output >> General Properties >> Advanced >> Gain >> Gain Value property.


Get/Set/Reset AO_LoadImpedance

int32 __CFUNC DAQmxGetAOLoadImpedance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOLoadImpedance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOLoadImpedance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOLoadImpedance gets the Analog Output >> General Properties >> Output Configuration >> Load Impedance property.

DAQmxSetAOLoadImpedance sets the Analog Output >> General Properties >> Output Configuration >> Load Impedance property.

DAQmxResetAOLoadImpedance resets the Analog Output >> General Properties >> Output Configuration >> Load Impedance property.


Get/Set/Reset AO_DAC_Ref_ConnToGnd

int32 __CFUNC DAQmxGetAODACRefConnToGnd(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAODACRefConnToGnd(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAODACRefConnToGnd(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRefConnToGnd gets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Connect DAC Reference to Ground property.

DAQmxSetAODACRefConnToGnd sets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Connect DAC Reference to Ground property.

DAQmxResetAODACRefConnToGnd resets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Connect DAC Reference to Ground property.


Get/Set/Reset AO_DAC_Ref_Src

int32 __CFUNC DAQmxGetAODACRefSrc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAODACRefSrc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAODACRefSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRefSrc gets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Source property.

DAQmxSetAODACRefSrc sets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Source property.

DAQmxResetAODACRefSrc resets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Source property.


Get/Set/Reset AO_ReglitchEnable

int32 __CFUNC DAQmxGetAOReglitchEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAOReglitchEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAOReglitchEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOReglitchEnable gets the Analog Output >> General Properties >> DAC >> Reglitching Enable property.

DAQmxSetAOReglitchEnable sets the Analog Output >> General Properties >> DAC >> Reglitching Enable property.

DAQmxResetAOReglitchEnable resets the Analog Output >> General Properties >> DAC >> Reglitching Enable property.


Get/Set/Reset AO_DataXferMech

int32 __CFUNC DAQmxGetAODataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAODataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAODataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODataXferMech gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetAODataXferMech sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetAODataXferMech resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset CI_CtrTimebaseActiveEdge

int32 __CFUNC DAQmxGetCICtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseActiveEdge gets the Counter Input >> General Properties >> Counter Timebase >> Active Edge property.

DAQmxSetCICtrTimebaseActiveEdge sets the Counter Input >> General Properties >> Counter Timebase >> Active Edge property.

DAQmxResetCICtrTimebaseActiveEdge resets the Counter Input >> General Properties >> Counter Timebase >> Active Edge property.


Get/Set/Reset CI_CtrTimebaseSrc

int32 __CFUNC DAQmxGetCICtrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICtrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICtrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseSrc gets the Counter Input >> General Properties >> Counter Timebase >> Source property.

DAQmxSetCICtrTimebaseSrc sets the Counter Input >> General Properties >> Counter Timebase >> Source property.

DAQmxResetCICtrTimebaseSrc resets the Counter Input >> General Properties >> Counter Timebase >> Source property.


Get/Set/Reset CI_Freq_MeasMeth

int32 __CFUNC DAQmxGetCIFreqMeasMeth(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIFreqMeasMeth(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIFreqMeasMeth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqMeasMeth gets the Counter Input >> Frequency >> Measurement Specifications >> Method property.

DAQmxSetCIFreqMeasMeth sets the Counter Input >> Frequency >> Measurement Specifications >> Method property.

DAQmxResetCIFreqMeasMeth resets the Counter Input >> Frequency >> Measurement Specifications >> Method property.


Get/Set/Reset CI_Freq_MeasTime

int32 __CFUNC DAQmxGetCIFreqMeasTime(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIFreqMeasTime(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIFreqMeasTime(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqMeasTime gets the Counter Input >> Frequency >> Measurement Specifications >> High Frequency >> Measurement Time property.

DAQmxSetCIFreqMeasTime sets the Counter Input >> Frequency >> Measurement Specifications >> High Frequency >> Measurement Time property.

DAQmxResetCIFreqMeasTime resets the Counter Input >> Frequency >> Measurement Specifications >> High Frequency >> Measurement Time property.


Get/Set/Reset CI_Freq_Div

int32 __CFUNC DAQmxGetCIFreqDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIFreqDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIFreqDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqDiv gets the Counter Input >> Frequency >> Measurement Specifications >> Large Range >> Divisor property.

DAQmxSetCIFreqDiv sets the Counter Input >> Frequency >> Measurement Specifications >> Large Range >> Divisor property.

DAQmxResetCIFreqDiv resets the Counter Input >> Frequency >> Measurement Specifications >> Large Range >> Divisor property.


Get/Set/Reset CI_Count

int32 __CFUNC DAQmxGetCICount(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetCICount gets the Counter Input >> General Properties >> More >> Count property.


Get/Set/Reset CI_OutputState

int32 __CFUNC DAQmxGetCIOutputState(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetCIOutputState gets the Counter Input >> General Properties >> More >> Output State property.


Get/Set/Reset CI_TCReached

int32 __CFUNC DAQmxGetCITCReached(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetCITCReached gets the Counter Input >> General Properties >> More >> Terminal Count Reached property.


Get/Set/Reset Exported_CtrOutEvent_OutputBehavior

int32 __CFUNC DAQmxGetExportedCtrOutEventOutputBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedCtrOutEventOutputBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedCtrOutEventOutputBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetExportedCtrOutEventOutputBehavior gets the Events >> Counter Output Event >> Output Behavior property.

DAQmxSetExportedCtrOutEventOutputBehavior sets the Events >> Counter Output Event >> Output Behavior property.

DAQmxResetExportedCtrOutEventOutputBehavior resets the Events >> Counter Output Event >> Output Behavior property.


Get/Set/Reset AI_SampAndHold_Enable

int32 __CFUNC DAQmxGetAISampAndHoldEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAISampAndHoldEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAISampAndHoldEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAISampAndHoldEnable gets the Analog Input >> General Properties >> Advanced >> Sample and Hold Enable property.

DAQmxSetAISampAndHoldEnable sets the Analog Input >> General Properties >> Advanced >> Sample and Hold Enable property.

DAQmxResetAISampAndHoldEnable resets the Analog Input >> General Properties >> Advanced >> Sample and Hold Enable property.


Get/Set/Reset AO_ResolutionUnits

int32 __CFUNC DAQmxGetAOResolutionUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOResolutionUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOResolutionUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOResolutionUnits gets the Analog Output >> General Properties >> DAC >> Resolution Units property.

DAQmxSetAOResolutionUnits sets the Analog Output >> General Properties >> DAC >> Resolution Units property.

DAQmxResetAOResolutionUnits resets the Analog Output >> General Properties >> DAC >> Resolution Units property.


Get/Set/Reset AO_Resolution

int32 __CFUNC DAQmxGetAOResolution(TaskHandle taskHandle, const char channel[], float64 *data);

Purpose

DAQmxGetAOResolution gets the Analog Output >> General Properties >> DAC >> Resolution Value property.


Get/Set/Reset AO_DAC_Rng_Low

int32 __CFUNC DAQmxGetAODACRngLow(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAODACRngLow(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAODACRngLow(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRngLow gets the Analog Output >> General Properties >> DAC >> Range >> Low property.

DAQmxSetAODACRngLow sets the Analog Output >> General Properties >> DAC >> Range >> Low property.

DAQmxResetAODACRngLow resets the Analog Output >> General Properties >> DAC >> Range >> Low property.


Get/Set/Reset AO_DAC_Rng_High

int32 __CFUNC DAQmxGetAODACRngHigh(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAODACRngHigh(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAODACRngHigh(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRngHigh gets the Analog Output >> General Properties >> DAC >> Range >> High property.

DAQmxSetAODACRngHigh sets the Analog Output >> General Properties >> DAC >> Range >> High property.

DAQmxResetAODACRngHigh resets the Analog Output >> General Properties >> DAC >> Range >> High property.


Get/Set/Reset AO_UseOnlyOnBrdMem

int32 __CFUNC DAQmxGetAOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOUseOnlyOnBrdMem gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxSetAOUseOnlyOnBrdMem sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxResetAOUseOnlyOnBrdMem resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.


Get/Set/Reset AO_DataXferReqCond

int32 __CFUNC DAQmxGetAODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAODataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODataXferReqCond gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetAODataXferReqCond sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetAODataXferReqCond resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset Exported_CtrOutEvent_Toggle_IdleState

int32 __CFUNC DAQmxGetExportedCtrOutEventToggleIdleState(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedCtrOutEventToggleIdleState(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedCtrOutEventToggleIdleState(TaskHandle taskHandle);

Purpose

DAQmxGetExportedCtrOutEventToggleIdleState gets the Events >> Counter Output Event >> Toggle >> Idle State property.

DAQmxSetExportedCtrOutEventToggleIdleState sets the Events >> Counter Output Event >> Toggle >> Idle State property.

DAQmxResetExportedCtrOutEventToggleIdleState resets the Events >> Counter Output Event >> Toggle >> Idle State property.


Get/Set/Reset Exported_SampClk_OutputBehavior

int32 __CFUNC DAQmxGetExportedSampClkOutputBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedSampClkOutputBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedSampClkOutputBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSampClkOutputBehavior gets the Clocks >> Sample Clock >> Output Behavior property.

DAQmxSetExportedSampClkOutputBehavior sets the Clocks >> Sample Clock >> Output Behavior property.

DAQmxResetExportedSampClkOutputBehavior resets the Clocks >> Sample Clock >> Output Behavior property.


Get/Set/Reset Buf_Input_BufSize

int32 __CFUNC DAQmxGetBufInputBufSize(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetBufInputBufSize(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetBufInputBufSize(TaskHandle taskHandle);

Purpose

DAQmxGetBufInputBufSize gets the Input >> Buffer Size property.

DAQmxSetBufInputBufSize sets the Input >> Buffer Size property.

DAQmxResetBufInputBufSize resets the Input >> Buffer Size property.


Get/Set/Reset Buf_Output_BufSize

int32 __CFUNC DAQmxGetBufOutputBufSize(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetBufOutputBufSize(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetBufOutputBufSize(TaskHandle taskHandle);

Purpose

DAQmxGetBufOutputBufSize gets the Output >> Buffer Size property.

DAQmxSetBufOutputBufSize sets the Output >> Buffer Size property.

DAQmxResetBufOutputBufSize resets the Output >> Buffer Size property.


Get/Set/Reset ChanType

int32 __CFUNC DAQmxGetChanType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetChanType gets the General Properties >> Channel Type property.


Get/Set/Reset AI_DataXferReqCond

int32 __CFUNC DAQmxGetAIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIDataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDataXferReqCond gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetAIDataXferReqCond sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetAIDataXferReqCond resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset AI_MemMapEnable

int32 __CFUNC DAQmxGetAIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIMemMapEnable gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetAIMemMapEnable sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetAIMemMapEnable resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset AO_TermCfg

int32 __CFUNC DAQmxGetAOTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOTermCfg gets the Analog Output >> General Properties >> Output Configuration >> Terminal Configuration property.

DAQmxSetAOTermCfg sets the Analog Output >> General Properties >> Output Configuration >> Terminal Configuration property.

DAQmxResetAOTermCfg resets the Analog Output >> General Properties >> Output Configuration >> Terminal Configuration property.


Get/Set/Reset AO_MemMapEnable

int32 __CFUNC DAQmxGetAOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAOMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOMemMapEnable gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetAOMemMapEnable sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetAOMemMapEnable resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset CI_Max

int32 __CFUNC DAQmxGetCIMax(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIMax(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIMax(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIMax gets the Counter Input >> Maximum Value property.

DAQmxSetCIMax sets the Counter Input >> Maximum Value property.

DAQmxResetCIMax resets the Counter Input >> Maximum Value property.


Get/Set/Reset CI_Min

int32 __CFUNC DAQmxGetCIMin(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIMin(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIMin(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIMin gets the Counter Input >> Minimum Value property.

DAQmxSetCIMin sets the Counter Input >> Minimum Value property.

DAQmxResetCIMin resets the Counter Input >> Minimum Value property.


Get/Set/Reset CI_CustomScaleName

int32 __CFUNC DAQmxGetCICustomScaleName(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICustomScaleName(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICustomScaleName(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICustomScaleName gets the Counter Input >> Custom Scale Name property.

DAQmxSetCICustomScaleName sets the Counter Input >> Custom Scale Name property.

DAQmxResetCICustomScaleName resets the Counter Input >> Custom Scale Name property.


Get/Set/Reset Read_RelativeTo

int32 __CFUNC DAQmxGetReadRelativeTo(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetReadRelativeTo(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetReadRelativeTo(TaskHandle taskHandle);

Purpose

DAQmxGetReadRelativeTo gets the RelativeTo property.

DAQmxSetReadRelativeTo sets the RelativeTo property.

DAQmxResetReadRelativeTo resets the RelativeTo property.


Get/Set/Reset Read_Offset

int32 __CFUNC DAQmxGetReadOffset(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetReadOffset(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetReadOffset(TaskHandle taskHandle);

Purpose

DAQmxGetReadOffset gets the Offset property.

DAQmxSetReadOffset sets the Offset property.

DAQmxResetReadOffset resets the Offset property.


Get/Set/Reset Write_RelativeTo

int32 __CFUNC DAQmxGetWriteRelativeTo(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetWriteRelativeTo(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetWriteRelativeTo(TaskHandle taskHandle);

Purpose

DAQmxGetWriteRelativeTo gets the Relative To property.

DAQmxSetWriteRelativeTo sets the Relative To property.

DAQmxResetWriteRelativeTo resets the Relative To property.


Get/Set/Reset Write_Offset

int32 __CFUNC DAQmxGetWriteOffset(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetWriteOffset(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetWriteOffset(TaskHandle taskHandle);

Purpose

DAQmxGetWriteOffset gets the Offset property.

DAQmxSetWriteOffset sets the Offset property.

DAQmxResetWriteOffset resets the Offset property.


Get/Set/Reset CO_PulseDone

int32 __CFUNC DAQmxGetCOPulseDone(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetCOPulseDone gets the Counter Output >> General Properties >> More >> Pulse Done property.


Get/Set/Reset StartTrig_Retriggerable

int32 __CFUNC DAQmxGetStartTrigRetriggerable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetStartTrigRetriggerable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetStartTrigRetriggerable(TaskHandle taskHandle);

Purpose

DAQmxGetStartTrigRetriggerable gets the Start >> More >> Retriggerable property.

DAQmxSetStartTrigRetriggerable sets the Start >> More >> Retriggerable property.

DAQmxResetStartTrigRetriggerable resets the Start >> More >> Retriggerable property.


Get/Set/Reset Scale_ScaledUnits

int32 __CFUNC DAQmxGetScaleScaledUnits(const char scaleName[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetScaleScaledUnits(const char scaleName[], const char *data);

Purpose

DAQmxGetScaleScaledUnits gets the Scaled Units property.

DAQmxSetScaleScaledUnits sets the Scaled Units property.


Get/Set/Reset Cal_UserDefinedInfo_MaxSize

int32 __CFUNC DAQmxGetCalUserDefinedInfoMaxSize(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetCalUserDefinedInfoMaxSize gets the User-Defined Information >> Max Size property.


Get/Set/Reset Read_TotalSampPerChanAcquired

int32 __CFUNC DAQmxGetReadTotalSampPerChanAcquired(TaskHandle taskHandle, uInt64 *data);

Purpose

DAQmxGetReadTotalSampPerChanAcquired gets the Status >> Total Samples Per Channel Acquired property.


Get/Set/Reset Write_TotalSampPerChanGenerated

int32 __CFUNC DAQmxGetWriteTotalSampPerChanGenerated(TaskHandle taskHandle, uInt64 *data);

Purpose

DAQmxGetWriteTotalSampPerChanGenerated gets the Status >> Total Samples Per Channel Generated property.


Get/Set/Reset CI_Period_MeasMeth

int32 __CFUNC DAQmxGetCIPeriodMeasMeth(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPeriodMeasMeth(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPeriodMeasMeth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodMeasMeth gets the Counter Input >> Period >> Measurement Specifications >> Method property.

DAQmxSetCIPeriodMeasMeth sets the Counter Input >> Period >> Measurement Specifications >> Method property.

DAQmxResetCIPeriodMeasMeth resets the Counter Input >> Period >> Measurement Specifications >> Method property.


Get/Set/Reset CI_Period_MeasTime

int32 __CFUNC DAQmxGetCIPeriodMeasTime(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPeriodMeasTime(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPeriodMeasTime(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodMeasTime gets the Counter Input >> Period >> Measurement Specifications >> High Frequency >> Measurement Time property.

DAQmxSetCIPeriodMeasTime sets the Counter Input >> Period >> Measurement Specifications >> High Frequency >> Measurement Time property.

DAQmxResetCIPeriodMeasTime resets the Counter Input >> Period >> Measurement Specifications >> High Frequency >> Measurement Time property.


Get/Set/Reset CI_Period_Div

int32 __CFUNC DAQmxGetCIPeriodDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIPeriodDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIPeriodDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodDiv gets the Counter Input >> Period >> Measurement Specifications >> Large Range >> Divisor property.

DAQmxSetCIPeriodDiv sets the Counter Input >> Period >> Measurement Specifications >> Large Range >> Divisor property.

DAQmxResetCIPeriodDiv resets the Counter Input >> Period >> Measurement Specifications >> Large Range >> Divisor property.


Get/Set/Reset Sys_DevNames

int32 __CFUNC DAQmxGetSysDevNames(char *data, uInt32 bufferSize);

Purpose

DAQmxGetSysDevNames gets the Device Names property.


Get/Set/Reset CI_NumPossiblyInvalidSamps

int32 __CFUNC DAQmxGetCINumPossiblyInvalidSamps(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetCINumPossiblyInvalidSamps gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Number Of Possibly Invalid Samples property.


Get/Set/Reset SwitchDev_Topology

int32 __CFUNC DAQmxGetSwitchDevTopology(const char deviceName[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetSwitchDevTopology gets the Deprecated >> Topology property.


Get/Set/Reset AI_Bridge_ShuntCal_GainAdjust

int32 __CFUNC DAQmxGetAIBridgeShuntCalGainAdjust(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIBridgeShuntCalGainAdjust(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIBridgeShuntCalGainAdjust(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIBridgeShuntCalGainAdjust gets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Gain Adjustment property.

DAQmxSetAIBridgeShuntCalGainAdjust sets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Gain Adjustment property.

DAQmxResetAIBridgeShuntCalGainAdjust resets the Analog Input >> General Properties >> Signal Conditioning >> Bridge >> Shunt Cal >> Gain Adjustment property.


Get/Set/Reset CI_DataXferMech

int32 __CFUNC DAQmxGetCIDataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIDataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIDataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDataXferMech gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetCIDataXferMech sets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetCIDataXferMech resets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset DigPattern_PauseTrig_Src

int32 __CFUNC DAQmxGetDigPatternPauseTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternPauseTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternPauseTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternPauseTrigSrc gets the More >> Pause >> Digital Pattern >> Source property.

DAQmxSetDigPatternPauseTrigSrc sets the More >> Pause >> Digital Pattern >> Source property.

DAQmxResetDigPatternPauseTrigSrc resets the More >> Pause >> Digital Pattern >> Source property.


Get/Set/Reset Read_RawDataWidth

int32 __CFUNC DAQmxGetReadRawDataWidth(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetReadRawDataWidth gets the Advanced >> Raw Data Width property.


Get/Set/Reset Read_NumChans

int32 __CFUNC DAQmxGetReadNumChans(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetReadNumChans gets the Advanced >> Number of Channels property.


Get/Set/Reset Read_DigitalLines_BytesPerChan

int32 __CFUNC DAQmxGetReadDigitalLinesBytesPerChan(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetReadDigitalLinesBytesPerChan gets the Advanced >> Digital Input >> Number of Bytes Per Channel property.


Get/Set/Reset Write_RawDataWidth

int32 __CFUNC DAQmxGetWriteRawDataWidth(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetWriteRawDataWidth gets the Advanced >> Raw Data Width property.


Get/Set/Reset Write_NumChans

int32 __CFUNC DAQmxGetWriteNumChans(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetWriteNumChans gets the Advanced >> Number of Channels property.


Get/Set/Reset Write_DigitalLines_BytesPerChan

int32 __CFUNC DAQmxGetWriteDigitalLinesBytesPerChan(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetWriteDigitalLinesBytesPerChan gets the Advanced >> Digital Output >> Number of Booleans Per Channel property.


Get/Set/Reset AI_LVDT_SensitivityUnits

int32 __CFUNC DAQmxGetAILVDTSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAILVDTSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAILVDTSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILVDTSensitivityUnits gets the Analog Input >> Position >> LVDT >> Sensitivity Units property.

DAQmxSetAILVDTSensitivityUnits sets the Analog Input >> Position >> LVDT >> Sensitivity Units property.

DAQmxResetAILVDTSensitivityUnits resets the Analog Input >> Position >> LVDT >> Sensitivity Units property.


Get/Set/Reset AI_RVDT_SensitivityUnits

int32 __CFUNC DAQmxGetAIRVDTSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIRVDTSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIRVDTSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRVDTSensitivityUnits gets the Analog Input >> Position >> RVDT >> Sensitivity Units property.

DAQmxSetAIRVDTSensitivityUnits sets the Analog Input >> Position >> RVDT >> Sensitivity Units property.

DAQmxResetAIRVDTSensitivityUnits resets the Analog Input >> Position >> RVDT >> Sensitivity Units property.


Get/Set/Reset AI_Accel_SensitivityUnits

int32 __CFUNC DAQmxGetAIAccelSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIAccelSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIAccelSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccelSensitivityUnits gets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity Units property.

DAQmxSetAIAccelSensitivityUnits sets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity Units property.

DAQmxResetAIAccelSensitivityUnits resets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity Units property.


Get/Set/Reset CI_Encoder_AInputTerm

int32 __CFUNC DAQmxGetCIEncoderAInputTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderAInputTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderAInputTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderAInputTerm gets the Counter Input >> Position >> A Input >> Terminal property.

DAQmxSetCIEncoderAInputTerm sets the Counter Input >> Position >> A Input >> Terminal property.

DAQmxResetCIEncoderAInputTerm resets the Counter Input >> Position >> A Input >> Terminal property.


Get/Set/Reset CI_Encoder_BInputTerm

int32 __CFUNC DAQmxGetCIEncoderBInputTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderBInputTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderBInputTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputTerm gets the Counter Input >> Position >> B Input >> Terminal property.

DAQmxSetCIEncoderBInputTerm sets the Counter Input >> Position >> B Input >> Terminal property.

DAQmxResetCIEncoderBInputTerm resets the Counter Input >> Position >> B Input >> Terminal property.


Get/Set/Reset CI_Encoder_ZInputTerm

int32 __CFUNC DAQmxGetCIEncoderZInputTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderZInputTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderZInputTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputTerm gets the Counter Input >> Position >> Z Input >> Terminal property.

DAQmxSetCIEncoderZInputTerm sets the Counter Input >> Position >> Z Input >> Terminal property.

DAQmxResetCIEncoderZInputTerm resets the Counter Input >> Position >> Z Input >> Terminal property.


Get/Set/Reset CI_PulseWidth_DigFltr_Enable

int32 __CFUNC DAQmxGetCIPulseWidthDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseWidthDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthDigFltrEnable gets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Enable property.

DAQmxSetCIPulseWidthDigFltrEnable sets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Enable property.

DAQmxResetCIPulseWidthDigFltrEnable resets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_PulseWidth_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIPulseWidthDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseWidthDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseWidthDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthDigFltrMinPulseWidth gets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIPulseWidthDigFltrMinPulseWidth sets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIPulseWidthDigFltrMinPulseWidth resets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_PulseWidth_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIPulseWidthDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIPulseWidthDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIPulseWidthDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthDigFltrTimebaseSrc gets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIPulseWidthDigFltrTimebaseSrc sets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIPulseWidthDigFltrTimebaseSrc resets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_PulseWidth_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIPulseWidthDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIPulseWidthDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIPulseWidthDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthDigFltrTimebaseRate gets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIPulseWidthDigFltrTimebaseRate sets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIPulseWidthDigFltrTimebaseRate resets the Counter Input >> Pulse Width >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_PulseWidth_DigSync_Enable

int32 __CFUNC DAQmxGetCIPulseWidthDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIPulseWidthDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthDigSyncEnable gets the Counter Input >> Pulse Width >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCIPulseWidthDigSyncEnable sets the Counter Input >> Pulse Width >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCIPulseWidthDigSyncEnable resets the Counter Input >> Pulse Width >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_TwoEdgeSep_First_DigFltr_Enable

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstDigFltrEnable gets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Enable property.

DAQmxSetCITwoEdgeSepFirstDigFltrEnable sets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Enable property.

DAQmxResetCITwoEdgeSepFirstDigFltrEnable resets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_SemiPeriod_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCISemiPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCISemiPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCISemiPeriodDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodDigFltrMinPulseWidth gets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCISemiPeriodDigFltrMinPulseWidth sets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCISemiPeriodDigFltrMinPulseWidth resets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_SemiPeriod_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCISemiPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCISemiPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCISemiPeriodDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodDigFltrTimebaseSrc gets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCISemiPeriodDigFltrTimebaseSrc sets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCISemiPeriodDigFltrTimebaseSrc resets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_SemiPeriod_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCISemiPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCISemiPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCISemiPeriodDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodDigFltrTimebaseRate gets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCISemiPeriodDigFltrTimebaseRate sets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCISemiPeriodDigFltrTimebaseRate resets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_SemiPeriod_DigSync_Enable

int32 __CFUNC DAQmxGetCISemiPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCISemiPeriodDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodDigSyncEnable gets the Counter Input >> Semi-Period >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCISemiPeriodDigSyncEnable sets the Counter Input >> Semi-Period >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCISemiPeriodDigSyncEnable resets the Counter Input >> Semi-Period >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset SampClk_DigFltr_Enable

int32 __CFUNC DAQmxGetSampClkDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetSampClkDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetSampClkDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkDigFltrEnable gets the Sample Clock >> Digital Filter >> Enable property.

DAQmxSetSampClkDigFltrEnable sets the Sample Clock >> Digital Filter >> Enable property.

DAQmxResetSampClkDigFltrEnable resets the Sample Clock >> Digital Filter >> Enable property.


Get/Set/Reset SampClk_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetSampClkDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSampClkDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSampClkDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkDigFltrMinPulseWidth gets the Sample Clock >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetSampClkDigFltrMinPulseWidth sets the Sample Clock >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetSampClkDigFltrMinPulseWidth resets the Sample Clock >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset DigLvl_PauseTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetDigLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigDigFltrTimebaseSrc gets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Source property.

DAQmxSetDigLvlPauseTrigDigFltrTimebaseSrc sets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Source property.

DAQmxResetDigLvlPauseTrigDigFltrTimebaseSrc resets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset DigLvl_PauseTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetDigLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigDigFltrTimebaseRate gets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Rate property.

DAQmxSetDigLvlPauseTrigDigFltrTimebaseRate sets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Rate property.

DAQmxResetDigLvlPauseTrigDigFltrTimebaseRate resets the More >> Pause >> Digital Level >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset DigLvl_PauseTrig_DigSync_Enable

int32 __CFUNC DAQmxGetDigLvlPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigLvlPauseTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigDigSyncEnable gets the More >> Pause >> Digital Level >> Digital Synchronization >> Enable property.

DAQmxSetDigLvlPauseTrigDigSyncEnable sets the More >> Pause >> Digital Level >> Digital Synchronization >> Enable property.

DAQmxResetDigLvlPauseTrigDigSyncEnable resets the More >> Pause >> Digital Level >> Digital Synchronization >> Enable property.


Get/Set/Reset DigEdge_ArmStartTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigDigFltrEnable gets the More >> Arm Start >> Digital Edge >> Digital Filter >> Enable property.

DAQmxSetDigEdgeArmStartTrigDigFltrEnable sets the More >> Arm Start >> Digital Edge >> Digital Filter >> Enable property.

DAQmxResetDigEdgeArmStartTrigDigFltrEnable resets the More >> Arm Start >> Digital Edge >> Digital Filter >> Enable property.


Get/Set/Reset DigEdge_ArmStartTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigDigFltrMinPulseWidth gets the More >> Arm Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetDigEdgeArmStartTrigDigFltrMinPulseWidth sets the More >> Arm Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetDigEdgeArmStartTrigDigFltrMinPulseWidth resets the More >> Arm Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset DigEdge_ArmStartTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseSrc gets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseSrc sets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseSrc resets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AI_SoundPressure_MaxSoundPressureLvl

int32 __CFUNC DAQmxGetAISoundPressureMaxSoundPressureLvl(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAISoundPressureMaxSoundPressureLvl(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAISoundPressureMaxSoundPressureLvl(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAISoundPressureMaxSoundPressureLvl gets the Analog Input >> Sound Pressure >> Maximum Sound Pressure Level property.

DAQmxSetAISoundPressureMaxSoundPressureLvl sets the Analog Input >> Sound Pressure >> Maximum Sound Pressure Level property.

DAQmxResetAISoundPressureMaxSoundPressureLvl resets the Analog Input >> Sound Pressure >> Maximum Sound Pressure Level property.


Get/Set/Reset Cal_DevTemp

int32 __CFUNC DAQmxGetCalDevTemp(const char deviceName[], float64 *data);

Purpose

DAQmxGetCalDevTemp gets the More >> Device Temperature property.


Get/Set/Reset Exported_SyncPulseEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedSyncPulseEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedSyncPulseEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedSyncPulseEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSyncPulseEventOutputTerm gets the Events >> Synchronization Pulse Event >> Output Terminal property.

DAQmxSetExportedSyncPulseEventOutputTerm sets the Events >> Synchronization Pulse Event >> Output Terminal property.

DAQmxResetExportedSyncPulseEventOutputTerm resets the Events >> Synchronization Pulse Event >> Output Terminal property.


Get/Set/Reset SyncPulse_Src

int32 __CFUNC DAQmxGetSyncPulseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetSyncPulseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetSyncPulseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetSyncPulseSrc gets the More >> Synchronization Pulse >> Source property.

DAQmxSetSyncPulseSrc sets the More >> Synchronization Pulse >> Source property.

DAQmxResetSyncPulseSrc resets the More >> Synchronization Pulse >> Source property.


Get/Set/Reset SyncPulse_SyncTime

int32 __CFUNC DAQmxGetSyncPulseSyncTime(TaskHandle taskHandle, float64 *data);

Purpose

DAQmxGetSyncPulseSyncTime gets the More >> Synchronization Pulse >> Synchronization Time property.


Get/Set/Reset SyncPulse_MinDelayToStart

int32 __CFUNC DAQmxGetSyncPulseMinDelayToStart(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSyncPulseMinDelayToStart(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSyncPulseMinDelayToStart(TaskHandle taskHandle);

Purpose

DAQmxGetSyncPulseMinDelayToStart gets the More >> Synchronization Pulse >> Minimum Delay To Start property.

DAQmxSetSyncPulseMinDelayToStart sets the More >> Synchronization Pulse >> Minimum Delay To Start property.

DAQmxResetSyncPulseMinDelayToStart resets the More >> Synchronization Pulse >> Minimum Delay To Start property.


Get/Set/Reset CO_Prescaler

int32 __CFUNC DAQmxGetCOPrescaler(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOPrescaler(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOPrescaler(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPrescaler gets the Counter Output >> General Properties >> More >> Advanced >> Prescaler property.

DAQmxSetCOPrescaler sets the Counter Output >> General Properties >> More >> Advanced >> Prescaler property.

DAQmxResetCOPrescaler resets the Counter Output >> General Properties >> More >> Advanced >> Prescaler property.


Get/Set/Reset Exported_10MHzRefClk_OutputTerm

int32 __CFUNC DAQmxGetExported10MHzRefClkOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExported10MHzRefClkOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExported10MHzRefClkOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExported10MHzRefClkOutputTerm gets the Clocks >> 10MHz Reference Clock >> Output Terminal property.

DAQmxSetExported10MHzRefClkOutputTerm sets the Clocks >> 10MHz Reference Clock >> Output Terminal property.

DAQmxResetExported10MHzRefClkOutputTerm resets the Clocks >> 10MHz Reference Clock >> Output Terminal property.


Get/Set/Reset CO_CtrTimebase_DigSync_Enable

int32 __CFUNC DAQmxGetCOCtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseDigSyncEnable gets the Counter Output >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.

DAQmxSetCOCtrTimebaseDigSyncEnable sets the Counter Output >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.

DAQmxResetCOCtrTimebaseDigSyncEnable resets the Counter Output >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.


Get/Set/Reset PhysicalChan_TEDS_TemplateIDs

int32 __CFUNC DAQmxGetPhysicalChanTEDSTemplateIDs(const char physicalChannel[], uInt32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanTEDSTemplateIDs gets the TEDS >> TemplateIDs property.


Get/Set/Reset AI_ChanCal_ScaleType

int32 __CFUNC DAQmxGetAIChanCalScaleType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIChanCalScaleType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIChanCalScaleType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalScaleType gets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Scale Type property.

DAQmxSetAIChanCalScaleType sets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Scale Type property.

DAQmxResetAIChanCalScaleType resets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Scale Type property.


Get/Set/Reset AI_ChanCal_Table_PreScaledVals

int32 __CFUNC DAQmxGetAIChanCalTablePreScaledVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalTablePreScaledVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalTablePreScaledVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalTablePreScaledVals gets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Pre-Scaled Values property.

DAQmxSetAIChanCalTablePreScaledVals sets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Pre-Scaled Values property.

DAQmxResetAIChanCalTablePreScaledVals resets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Pre-Scaled Values property.


Get/Set/Reset AI_ChanCal_Table_ScaledVals

int32 __CFUNC DAQmxGetAIChanCalTableScaledVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalTableScaledVals(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalTableScaledVals(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalTableScaledVals gets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Scaled Values property.

DAQmxSetAIChanCalTableScaledVals sets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Scaled Values property.

DAQmxResetAIChanCalTableScaledVals resets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Table >> Scaled Values property.


Get/Set/Reset AI_ChanCal_Poly_ForwardCoeff

int32 __CFUNC DAQmxGetAIChanCalPolyForwardCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetAIChanCalPolyForwardCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxResetAIChanCalPolyForwardCoeff(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalPolyForwardCoeff gets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Forward Coefficients property.

DAQmxSetAIChanCalPolyForwardCoeff sets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Forward Coefficients property.

DAQmxResetAIChanCalPolyForwardCoeff resets the Analog Input >> General Properties >> Channel Calibration >> Scaling Parameters >> Polynomial >> Forward Coefficients property.


Get/Set/Reset Buf_Input_OnbrdBufSize

int32 __CFUNC DAQmxGetBufInputOnbrdBufSize(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetBufInputOnbrdBufSize gets the Input >> Onboard Buffer Size property.


Get/Set/Reset Buf_Output_OnbrdBufSize

int32 __CFUNC DAQmxGetBufOutputOnbrdBufSize(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetBufOutputOnbrdBufSize(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetBufOutputOnbrdBufSize(TaskHandle taskHandle);

Purpose

DAQmxGetBufOutputOnbrdBufSize gets the Output >> Onboard Buffer Size property.

DAQmxSetBufOutputOnbrdBufSize sets the Output >> Onboard Buffer Size property.

DAQmxResetBufOutputOnbrdBufSize resets the Output >> Onboard Buffer Size property.


Get/Set/Reset AI_DataXferCustomThreshold

int32 __CFUNC DAQmxGetAIDataXferCustomThreshold(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIDataXferCustomThreshold(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIDataXferCustomThreshold(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDataXferCustomThreshold gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Custom Threshold property.

DAQmxSetAIDataXferCustomThreshold sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Custom Threshold property.

DAQmxResetAIDataXferCustomThreshold resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Custom Threshold property.


Get/Set/Reset Task_Devices

int32 __CFUNC DAQmxGetTaskDevices(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetTaskDevices gets the Devices property.


Get/Set/Reset RealTime_WriteRecoveryMode

int32 __CFUNC DAQmxGetRealTimeWriteRecoveryMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetRealTimeWriteRecoveryMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetRealTimeWriteRecoveryMode(TaskHandle taskHandle);

Purpose

DAQmxGetRealTimeWriteRecoveryMode gets the Write Recovery Mode property.

DAQmxSetRealTimeWriteRecoveryMode sets the Write Recovery Mode property.

DAQmxResetRealTimeWriteRecoveryMode resets the Write Recovery Mode property.


Get/Set/Reset Dev_ProductNum

int32 __CFUNC DAQmxGetDevProductNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevProductNum gets the Identification >> Product Number property.


Get/Set/Reset Dev_AI_PhysicalChans

int32 __CFUNC DAQmxGetDevAIPhysicalChans(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevAIPhysicalChans gets the I/O Type >> Analog Input >> Physical Channels property.


Get/Set/Reset Dev_AO_PhysicalChans

int32 __CFUNC DAQmxGetDevAOPhysicalChans(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevAOPhysicalChans gets the I/O Type >> Analog Output >> Physical Channels property.


Get/Set/Reset Dev_PXI_SlotNum

int32 __CFUNC DAQmxGetDevPXISlotNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevPXISlotNum gets the Location >> PXI >> Slot Number property.


Get/Set/Reset Dev_NumDMAChans

int32 __CFUNC DAQmxGetDevNumDMAChans(const char device[], uInt32 *data);

Purpose

DAQmxGetDevNumDMAChans gets the Bus >> Number of DMA Channels property.


Get/Set/Reset CO_Count

int32 __CFUNC DAQmxGetCOCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetCOCount gets the Counter Output >> General Properties >> More >> Count property.


Get/Set/Reset CO_OutputState

int32 __CFUNC DAQmxGetCOOutputState(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetCOOutputState gets the Counter Output >> General Properties >> More >> Output State property.


Get/Set/Reset CO_AutoIncrCnt

int32 __CFUNC DAQmxGetCOAutoIncrCnt(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOAutoIncrCnt(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOAutoIncrCnt(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOAutoIncrCnt gets the Counter Output >> General Properties >> More >> Auto Increment Count property.

DAQmxSetCOAutoIncrCnt sets the Counter Output >> General Properties >> More >> Auto Increment Count property.

DAQmxResetCOAutoIncrCnt resets the Counter Output >> General Properties >> More >> Auto Increment Count property.


Get/Set/Reset DI_MemMapEnable

int32 __CFUNC DAQmxGetDIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDIMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDIMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIMemMapEnable gets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetDIMemMapEnable sets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetDIMemMapEnable resets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset DO_MemMapEnable

int32 __CFUNC DAQmxGetDOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDOMemMapEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDOMemMapEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOMemMapEnable gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxSetDOMemMapEnable sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.

DAQmxResetDOMemMapEnable resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Memory Mapping for Programmed IO Enable property.


Get/Set/Reset DI_LogicFamily

int32 __CFUNC DAQmxGetDILogicFamily(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDILogicFamily(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDILogicFamily(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDILogicFamily gets the Digital Input >> Logic Family property.

DAQmxSetDILogicFamily sets the Digital Input >> Logic Family property.

DAQmxResetDILogicFamily resets the Digital Input >> Logic Family property.


Get/Set/Reset DO_LogicFamily

int32 __CFUNC DAQmxGetDOLogicFamily(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOLogicFamily(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOLogicFamily(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOLogicFamily gets the Digital Output >> Logic Family property.

DAQmxSetDOLogicFamily sets the Digital Output >> Logic Family property.

DAQmxResetDOLogicFamily resets the Digital Output >> Logic Family property.


Get/Set/Reset CO_Pulse_Ticks_InitialDelay

int32 __CFUNC DAQmxGetCOPulseTicksInitialDelay(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOPulseTicksInitialDelay(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOPulseTicksInitialDelay(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseTicksInitialDelay gets the Counter Output >> Pulse >> Ticks >> Initial Delay property.

DAQmxSetCOPulseTicksInitialDelay sets the Counter Output >> Pulse >> Ticks >> Initial Delay property.

DAQmxResetCOPulseTicksInitialDelay resets the Counter Output >> Pulse >> Ticks >> Initial Delay property.


Get/Set/Reset Dev_CI_TrigUsage

int32 __CFUNC DAQmxGetDevCITrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevCITrigUsage gets the I/O Type >> Counter Input >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_CO_TrigUsage

int32 __CFUNC DAQmxGetDevCOTrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevCOTrigUsage gets the I/O Type >> Counter Output >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_AI_MaxSingleChanRate

int32 __CFUNC DAQmxGetDevAIMaxSingleChanRate(const char device[], float64 *data);

Purpose

DAQmxGetDevAIMaxSingleChanRate gets the I/O Type >> Analog Input >> Timing >> Maximum Single Channel Rate property.


Get/Set/Reset Dev_AI_MaxMultiChanRate

int32 __CFUNC DAQmxGetDevAIMaxMultiChanRate(const char device[], float64 *data);

Purpose

DAQmxGetDevAIMaxMultiChanRate gets the I/O Type >> Analog Input >> Timing >> Maximum Multiple Channel Rate property.


Get/Set/Reset Dev_AI_MinRate

int32 __CFUNC DAQmxGetDevAIMinRate(const char device[], float64 *data);

Purpose

DAQmxGetDevAIMinRate gets the I/O Type >> Analog Input >> Timing >> Minimum Rate property.


Get/Set/Reset Dev_AI_SimultaneousSamplingSupported

int32 __CFUNC DAQmxGetDevAISimultaneousSamplingSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevAISimultaneousSamplingSupported gets the I/O Type >> Analog Input >> Timing >> Simultaneous Sampling Supported property.


Get/Set/Reset CO_Pulse_Freq_InitialDelay

int32 __CFUNC DAQmxGetCOPulseFreqInitialDelay(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseFreqInitialDelay(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseFreqInitialDelay(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseFreqInitialDelay gets the Counter Output >> Pulse >> Frequency >> Initial Delay property.

DAQmxSetCOPulseFreqInitialDelay sets the Counter Output >> Pulse >> Frequency >> Initial Delay property.

DAQmxResetCOPulseFreqInitialDelay resets the Counter Output >> Pulse >> Frequency >> Initial Delay property.


Get/Set/Reset Dev_DO_MaxRate

int32 __CFUNC DAQmxGetDevDOMaxRate(const char device[], float64 *data);

Purpose

DAQmxGetDevDOMaxRate gets the I/O Type >> Digital Output >> Timing >> Maximum Rate property.


Get/Set/Reset Dev_AO_VoltageRngs

int32 __CFUNC DAQmxGetDevAOVoltageRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAOVoltageRngs gets the I/O Type >> Analog Output >> Voltage >> Ranges property.


Get/Set/Reset Dev_AO_CurrentRngs

int32 __CFUNC DAQmxGetDevAOCurrentRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAOCurrentRngs gets the I/O Type >> Analog Output >> Current >> Ranges property.


Get/Set/Reset Dev_AO_Gains

int32 __CFUNC DAQmxGetDevAOGains(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAOGains gets the I/O Type >> Analog Output >> Gains property.


Get/Set/Reset Dev_CI_SampClkSupported

int32 __CFUNC DAQmxGetDevCISampClkSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevCISampClkSupported gets the I/O Type >> Counter Input >> Timing >> Sample Clock Supported property.


Get/Set/Reset Dev_CI_MaxSize

int32 __CFUNC DAQmxGetDevCIMaxSize(const char device[], uInt32 *data);

Purpose

DAQmxGetDevCIMaxSize gets the I/O Type >> Counter Input >> Maximum Size property.


Get/Set/Reset SwitchDev_Temperature

int32 __CFUNC DAQmxGetSwitchDevTemperature(const char deviceName[], float64 *data);

Purpose

DAQmxGetSwitchDevTemperature gets the Deprecated >> Temperature property.


Get/Set/Reset PhysicalChan_AO_SupportedPowerUpOutputTypes

int32 __CFUNC DAQmxGetPhysicalChanAOSupportedPowerUpOutputTypes(const char physicalChannel[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetPhysicalChanAOSupportedPowerUpOutputTypes gets the Analog Output >> Power Up Output Types property.


Get/Set/Reset WatchdogExpirTrig_TrigOnNetworkConnLoss

int32 __CFUNC DAQmxGetWatchdogExpirTrigTrigOnNetworkConnLoss(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetWatchdogExpirTrigTrigOnNetworkConnLoss(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetWatchdogExpirTrigTrigOnNetworkConnLoss(TaskHandle taskHandle);

Purpose

DAQmxGetWatchdogExpirTrigTrigOnNetworkConnLoss gets the Expiration Trigger >> Trigger On Network Connection Loss property.

DAQmxSetWatchdogExpirTrigTrigOnNetworkConnLoss sets the Expiration Trigger >> Trigger On Network Connection Loss property.

DAQmxResetWatchdogExpirTrigTrigOnNetworkConnLoss resets the Expiration Trigger >> Trigger On Network Connection Loss property.


Get/Set/Reset Watchdog_AO_OutputType

int32 __CFUNC DAQmxGetWatchdogAOOutputType(TaskHandle taskHandle, const char lines[], int32 *data);

int32 __CFUNC DAQmxSetWatchdogAOOutputType(TaskHandle taskHandle, const char lines[], int32 data);

int32 __CFUNC DAQmxResetWatchdogAOOutputType(TaskHandle taskHandle, const char lines[]);

Purpose

DAQmxGetWatchdogAOOutputType gets the Expiration States >> Analog Output >> Output Type property.

DAQmxSetWatchdogAOOutputType sets the Expiration States >> Analog Output >> Output Type property.

DAQmxResetWatchdogAOOutputType resets the Expiration States >> Analog Output >> Output Type property.


Get/Set/Reset Watchdog_AO_ExpirState

int32 __CFUNC DAQmxGetWatchdogAOExpirState(TaskHandle taskHandle, const char lines[], float64 *data);

int32 __CFUNC DAQmxSetWatchdogAOExpirState(TaskHandle taskHandle, const char lines[], float64 data);

int32 __CFUNC DAQmxResetWatchdogAOExpirState(TaskHandle taskHandle, const char lines[]);

Purpose

DAQmxGetWatchdogAOExpirState gets the Expiration States >> Analog Output >> Expiration State property.

DAQmxSetWatchdogAOExpirState sets the Expiration States >> Analog Output >> Expiration State property.

DAQmxResetWatchdogAOExpirState resets the Expiration States >> Analog Output >> Expiration State property.


Get/Set/Reset CI_DutyCycle_Term

int32 __CFUNC DAQmxGetCIDutyCycleTerm(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIDutyCycleTerm(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIDutyCycleTerm(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleTerm gets the Counter Input >> Duty Cycle >> Input >> Terminal property.

DAQmxSetCIDutyCycleTerm sets the Counter Input >> Duty Cycle >> Input >> Terminal property.

DAQmxResetCIDutyCycleTerm resets the Counter Input >> Duty Cycle >> Input >> Terminal property.


Get/Set/Reset CI_DutyCycle_DigFltr_Enable

int32 __CFUNC DAQmxGetCIDutyCycleDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIDutyCycleDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIDutyCycleDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleDigFltrEnable gets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Enable property.

DAQmxSetCIDutyCycleDigFltrEnable sets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Enable property.

DAQmxResetCIDutyCycleDigFltrEnable resets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_DutyCycle_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIDutyCycleDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIDutyCycleDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIDutyCycleDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleDigFltrMinPulseWidth gets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIDutyCycleDigFltrMinPulseWidth sets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIDutyCycleDigFltrMinPulseWidth resets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Period_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPeriodLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodLogicLvlBehavior gets the Counter Input >> Period >> Input >> Logic Level Behavior property.

DAQmxSetCIPeriodLogicLvlBehavior sets the Counter Input >> Period >> Input >> Logic Level Behavior property.

DAQmxResetCIPeriodLogicLvlBehavior resets the Counter Input >> Period >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_CountEdges_TermCfg

int32 __CFUNC DAQmxGetCICountEdgesTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesTermCfg gets the Counter Input >> Count Edges >> Input >> Terminal Configuration property.

DAQmxSetCICountEdgesTermCfg sets the Counter Input >> Count Edges >> Input >> Terminal Configuration property.

DAQmxResetCICountEdgesTermCfg resets the Counter Input >> Count Edges >> Input >> Terminal Configuration property.


Get/Set/Reset CI_CountEdges_LogicLvlBehavior

int32 __CFUNC DAQmxGetCICountEdgesLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesLogicLvlBehavior gets the Counter Input >> Count Edges >> Input >> Logic Level Behavior property.

DAQmxSetCICountEdgesLogicLvlBehavior sets the Counter Input >> Count Edges >> Input >> Logic Level Behavior property.

DAQmxResetCICountEdgesLogicLvlBehavior resets the Counter Input >> Count Edges >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_CountEdges_CountDir_TermCfg

int32 __CFUNC DAQmxGetCICountEdgesCountDirTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirTermCfg gets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal Configuration property.

DAQmxSetCICountEdgesCountDirTermCfg sets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal Configuration property.

DAQmxResetCICountEdgesCountDirTermCfg resets the Counter Input >> Count Edges >> Count Direction >> Input >> Terminal Configuration property.


Get/Set/Reset CI_CountEdges_CountDir_LogicLvlBehavior

int32 __CFUNC DAQmxGetCICountEdgesCountDirLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountDirLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountDirLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountDirLogicLvlBehavior gets the Counter Input >> Count Edges >> Count Direction >> Input >> Logic Level Behavior property.

DAQmxSetCICountEdgesCountDirLogicLvlBehavior sets the Counter Input >> Count Edges >> Count Direction >> Input >> Logic Level Behavior property.

DAQmxResetCICountEdgesCountDirLogicLvlBehavior resets the Counter Input >> Count Edges >> Count Direction >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_CountEdges_CountReset_TermCfg

int32 __CFUNC DAQmxGetCICountEdgesCountResetTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesCountResetTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesCountResetTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesCountResetTermCfg gets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal Configuration property.

DAQmxSetCICountEdgesCountResetTermCfg sets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal Configuration property.

DAQmxResetCICountEdgesCountResetTermCfg resets the Counter Input >> Count Edges >> Count Reset >> Input >> Terminal Configuration property.


Get/Set/Reset CO_CtrTimebaseSrc

int32 __CFUNC DAQmxGetCOCtrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCOCtrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCOCtrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseSrc gets the Counter Output >> General Properties >> Counter Timebase >> Source property.

DAQmxSetCOCtrTimebaseSrc sets the Counter Output >> General Properties >> Counter Timebase >> Source property.

DAQmxResetCOCtrTimebaseSrc resets the Counter Output >> General Properties >> Counter Timebase >> Source property.


Get/Set/Reset CO_CtrTimebaseActiveEdge

int32 __CFUNC DAQmxGetCOCtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseActiveEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseActiveEdge gets the Counter Output >> General Properties >> Counter Timebase >> Active Edge property.

DAQmxSetCOCtrTimebaseActiveEdge sets the Counter Output >> General Properties >> Counter Timebase >> Active Edge property.

DAQmxResetCOCtrTimebaseActiveEdge resets the Counter Output >> General Properties >> Counter Timebase >> Active Edge property.


Get/Set/Reset Exported_StartTrig_OutputTerm

int32 __CFUNC DAQmxGetExportedStartTrigOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedStartTrigOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedStartTrigOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedStartTrigOutputTerm gets the Triggers >> Start Trigger >> Output Terminal property.

DAQmxSetExportedStartTrigOutputTerm sets the Triggers >> Start Trigger >> Output Terminal property.

DAQmxResetExportedStartTrigOutputTerm resets the Triggers >> Start Trigger >> Output Terminal property.


Get/Set/Reset Exported_StartTrig_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedStartTrigPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedStartTrigPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedStartTrigPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedStartTrigPulsePolarity gets the Triggers >> Start Trigger >> Pulse >> Polarity property.

DAQmxSetExportedStartTrigPulsePolarity sets the Triggers >> Start Trigger >> Pulse >> Polarity property.

DAQmxResetExportedStartTrigPulsePolarity resets the Triggers >> Start Trigger >> Pulse >> Polarity property.


Get/Set/Reset Exported_RefTrig_OutputTerm

int32 __CFUNC DAQmxGetExportedRefTrigOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedRefTrigOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedRefTrigOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRefTrigOutputTerm gets the Triggers >> Reference Trigger >> Output Terminal property.

DAQmxSetExportedRefTrigOutputTerm sets the Triggers >> Reference Trigger >> Output Terminal property.

DAQmxResetExportedRefTrigOutputTerm resets the Triggers >> Reference Trigger >> Output Terminal property.


Get/Set/Reset Exported_RefTrig_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedRefTrigPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedRefTrigPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedRefTrigPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRefTrigPulsePolarity gets the Triggers >> Reference Trigger >> Pulse >> Polarity property.

DAQmxSetExportedRefTrigPulsePolarity sets the Triggers >> Reference Trigger >> Pulse >> Polarity property.

DAQmxResetExportedRefTrigPulsePolarity resets the Triggers >> Reference Trigger >> Pulse >> Polarity property.


Get/Set/Reset Dev_ProductType

int32 __CFUNC DAQmxGetDevProductType(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevProductType gets the Identification >> Product Type property.


Get/Set/Reset Dev_SerialNum

int32 __CFUNC DAQmxGetDevSerialNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevSerialNum gets the Identification >> Device Serial Number property.


Get/Set/Reset SwitchChan_Bandwidth

int32 __CFUNC DAQmxGetSwitchChanBandwidth(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanBandwidth gets the Deprecated >> Capability >> Bandwidth property.


Get/Set/Reset SwitchChan_Impedance

int32 __CFUNC DAQmxGetSwitchChanImpedance(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanImpedance gets the Deprecated >> Capability >> Impedance property.


Get/Set/Reset SwitchChan_MaxACCarryPwr

int32 __CFUNC DAQmxGetSwitchChanMaxACCarryPwr(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxACCarryPwr gets the Deprecated >> Capability >> Max AC Carry Power property.


Get/Set/Reset SwitchChan_MaxDCCarryPwr

int32 __CFUNC DAQmxGetSwitchChanMaxDCCarryPwr(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxDCCarryPwr gets the Deprecated >> Capability >> Max DC Carry Power property.


Get/Set/Reset SwitchChan_MaxACSwitchPwr

int32 __CFUNC DAQmxGetSwitchChanMaxACSwitchPwr(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxACSwitchPwr gets the Deprecated >> Capability >> Max AC Switching Power property.


Get/Set/Reset SwitchChan_MaxDCSwitchCurrent

int32 __CFUNC DAQmxGetSwitchChanMaxDCSwitchCurrent(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxDCSwitchCurrent gets the Deprecated >> Capability >> Max DC Switching Current property.


Get/Set/Reset SwitchChan_MaxACSwitchCurrent

int32 __CFUNC DAQmxGetSwitchChanMaxACSwitchCurrent(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxACSwitchCurrent gets the Deprecated >> Capability >> Max AC Switching Current property.


Get/Set/Reset SwitchChan_MaxDCCarryCurrent

int32 __CFUNC DAQmxGetSwitchChanMaxDCCarryCurrent(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxDCCarryCurrent gets the Deprecated >> Capability >> Max DC Carry Current property.


Get/Set/Reset SwitchChan_MaxACCarryCurrent

int32 __CFUNC DAQmxGetSwitchChanMaxACCarryCurrent(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxACCarryCurrent gets the Deprecated >> Capability >> Max AC Carry Current property.


Get/Set/Reset SwitchChan_MaxDCSwitchPwr

int32 __CFUNC DAQmxGetSwitchChanMaxDCSwitchPwr(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxDCSwitchPwr gets the Deprecated >> Capability >> Max DC Switching Power property.


Get/Set/Reset SwitchChan_MaxDCVoltage

int32 __CFUNC DAQmxGetSwitchChanMaxDCVoltage(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxDCVoltage gets the Deprecated >> Capability >> Max DC Voltage property.


Get/Set/Reset SwitchChan_MaxACVoltage

int32 __CFUNC DAQmxGetSwitchChanMaxACVoltage(const char switchChannelName[], float64 *data);

Purpose

DAQmxGetSwitchChanMaxACVoltage gets the Deprecated >> Capability >> Max AC Voltage property.


Get/Set/Reset AI_Accel_Units

int32 __CFUNC DAQmxGetAIAccelUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIAccelUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIAccelUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccelUnits gets the Analog Input >> Acceleration >> Units property.

DAQmxSetAIAccelUnits sets the Analog Input >> Acceleration >> Units property.

DAQmxResetAIAccelUnits resets the Analog Input >> Acceleration >> Units property.


Get/Set/Reset AI_Accel_Sensitivity

int32 __CFUNC DAQmxGetAIAccelSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIAccelSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIAccelSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccelSensitivity gets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity property.

DAQmxSetAIAccelSensitivity sets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity property.

DAQmxResetAIAccelSensitivity resets the Analog Input >> Acceleration >> Accelerometer >> Sensitivity property.


Get/Set/Reset AI_MeasType

int32 __CFUNC DAQmxGetAIMeasType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAIMeasType gets the Analog Input >> Measurement Type property.


Get/Set/Reset CI_CountEdges_Dir

int32 __CFUNC DAQmxGetCICountEdgesDir(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesDir(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesDir(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesDir gets the Counter Input >> Count Edges >> Count Direction >> Direction property.

DAQmxSetCICountEdgesDir sets the Counter Input >> Count Edges >> Count Direction >> Direction property.

DAQmxResetCICountEdgesDir resets the Counter Input >> Count Edges >> Count Direction >> Direction property.


Get/Set/Reset CI_CountEdges_ActiveEdge

int32 __CFUNC DAQmxGetCICountEdgesActiveEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCICountEdgesActiveEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCICountEdgesActiveEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesActiveEdge gets the Counter Input >> Count Edges >> Active Edge property.

DAQmxSetCICountEdgesActiveEdge sets the Counter Input >> Count Edges >> Active Edge property.

DAQmxResetCICountEdgesActiveEdge resets the Counter Input >> Count Edges >> Active Edge property.


Get/Set/Reset CI_CountEdges_InitialCnt

int32 __CFUNC DAQmxGetCICountEdgesInitialCnt(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCICountEdgesInitialCnt(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCICountEdgesInitialCnt(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICountEdgesInitialCnt gets the Counter Input >> Count Edges >> Initial Count property.

DAQmxSetCICountEdgesInitialCnt sets the Counter Input >> Count Edges >> Initial Count property.

DAQmxResetCICountEdgesInitialCnt resets the Counter Input >> Count Edges >> Initial Count property.


Get/Set/Reset AI_Current_Units

int32 __CFUNC DAQmxGetAICurrentUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAICurrentUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAICurrentUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAICurrentUnits gets the Analog Input >> Current >> Units property.

DAQmxSetAICurrentUnits sets the Analog Input >> Current >> Units property.

DAQmxResetAICurrentUnits resets the Analog Input >> Current >> Units property.


Get/Set/Reset DI_InvertLines

int32 __CFUNC DAQmxGetDIInvertLines(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDIInvertLines(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDIInvertLines(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIInvertLines gets the Digital Input >> Invert Lines property.

DAQmxSetDIInvertLines sets the Digital Input >> Invert Lines property.

DAQmxResetDIInvertLines resets the Digital Input >> Invert Lines property.


Get/Set/Reset CI_Freq_StartingEdge

int32 __CFUNC DAQmxGetCIFreqStartingEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIFreqStartingEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIFreqStartingEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqStartingEdge gets the Counter Input >> Frequency >> Starting Edge property.

DAQmxSetCIFreqStartingEdge sets the Counter Input >> Frequency >> Starting Edge property.

DAQmxResetCIFreqStartingEdge resets the Counter Input >> Frequency >> Starting Edge property.


Get/Set/Reset AI_Freq_Units

int32 __CFUNC DAQmxGetAIFreqUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIFreqUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIFreqUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIFreqUnits gets the Analog Input >> Frequency >> Units property.

DAQmxSetAIFreqUnits sets the Analog Input >> Frequency >> Units property.

DAQmxResetAIFreqUnits resets the Analog Input >> Frequency >> Units property.


Get/Set/Reset AI_Freq_Hyst

int32 __CFUNC DAQmxGetAIFreqHyst(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIFreqHyst(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIFreqHyst(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIFreqHyst gets the Analog Input >> Frequency >> Voltage >> Hysteresis property.

DAQmxSetAIFreqHyst sets the Analog Input >> Frequency >> Voltage >> Hysteresis property.

DAQmxResetAIFreqHyst resets the Analog Input >> Frequency >> Voltage >> Hysteresis property.


Get/Set/Reset AI_Freq_ThreshVoltage

int32 __CFUNC DAQmxGetAIFreqThreshVoltage(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIFreqThreshVoltage(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIFreqThreshVoltage(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIFreqThreshVoltage gets the Analog Input >> Frequency >> Voltage >> Threshold Level property.

DAQmxSetAIFreqThreshVoltage sets the Analog Input >> Frequency >> Voltage >> Threshold Level property.

DAQmxResetAIFreqThreshVoltage resets the Analog Input >> Frequency >> Voltage >> Threshold Level property.


Get/Set/Reset CI_PulseWidth_Units

int32 __CFUNC DAQmxGetCIPulseWidthUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseWidthUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthUnits gets the Counter Input >> Pulse Width >> Units property.

DAQmxSetCIPulseWidthUnits sets the Counter Input >> Pulse Width >> Units property.

DAQmxResetCIPulseWidthUnits resets the Counter Input >> Pulse Width >> Units property.


Get/Set/Reset CI_PulseWidth_StartingEdge

int32 __CFUNC DAQmxGetCIPulseWidthStartingEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPulseWidthStartingEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPulseWidthStartingEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPulseWidthStartingEdge gets the Counter Input >> Pulse Width >> Starting Edge property.

DAQmxSetCIPulseWidthStartingEdge sets the Counter Input >> Pulse Width >> Starting Edge property.

DAQmxResetCIPulseWidthStartingEdge resets the Counter Input >> Pulse Width >> Starting Edge property.


Get/Set/Reset CI_TwoEdgeSep_FirstEdge

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstEdge gets the Counter Input >> Two Edge Separation >> First >> Edge property.

DAQmxSetCITwoEdgeSepFirstEdge sets the Counter Input >> Two Edge Separation >> First >> Edge property.

DAQmxResetCITwoEdgeSepFirstEdge resets the Counter Input >> Two Edge Separation >> First >> Edge property.


Get/Set/Reset CI_TwoEdgeSep_SecondEdge

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondEdge gets the Counter Input >> Two Edge Separation >> Second >> Edge property.

DAQmxSetCITwoEdgeSepSecondEdge sets the Counter Input >> Two Edge Separation >> Second >> Edge property.

DAQmxResetCITwoEdgeSepSecondEdge resets the Counter Input >> Two Edge Separation >> Second >> Edge property.


Get/Set/Reset CI_Period_StartingEdge

int32 __CFUNC DAQmxGetCIPeriodStartingEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPeriodStartingEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPeriodStartingEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodStartingEdge gets the Counter Input >> Period >> Starting Edge property.

DAQmxSetCIPeriodStartingEdge sets the Counter Input >> Period >> Starting Edge property.

DAQmxResetCIPeriodStartingEdge resets the Counter Input >> Period >> Starting Edge property.


Get/Set/Reset CI_AngEncoder_PulsesPerRev

int32 __CFUNC DAQmxGetCIAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIAngEncoderPulsesPerRev(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIAngEncoderPulsesPerRev gets the Counter Input >> Position >> Angular Encoder >> Pulses Per Revolution property.

DAQmxSetCIAngEncoderPulsesPerRev sets the Counter Input >> Position >> Angular Encoder >> Pulses Per Revolution property.

DAQmxResetCIAngEncoderPulsesPerRev resets the Counter Input >> Position >> Angular Encoder >> Pulses Per Revolution property.


Get/Set/Reset AI_RVDT_Units

int32 __CFUNC DAQmxGetAIRVDTUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIRVDTUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIRVDTUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRVDTUnits gets the Analog Input >> Position >> RVDT >> Units property.

DAQmxSetAIRVDTUnits sets the Analog Input >> Position >> RVDT >> Units property.

DAQmxResetAIRVDTUnits resets the Analog Input >> Position >> RVDT >> Units property.


Get/Set/Reset CI_AngEncoder_InitialAngle

int32 __CFUNC DAQmxGetCIAngEncoderInitialAngle(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIAngEncoderInitialAngle(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIAngEncoderInitialAngle(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIAngEncoderInitialAngle gets the Counter Input >> Position >> Angular Encoder >> Initial Angle property.

DAQmxSetCIAngEncoderInitialAngle sets the Counter Input >> Position >> Angular Encoder >> Initial Angle property.

DAQmxResetCIAngEncoderInitialAngle resets the Counter Input >> Position >> Angular Encoder >> Initial Angle property.


Get/Set/Reset CI_Encoder_ZIndexVal

int32 __CFUNC DAQmxGetCIEncoderZIndexVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderZIndexVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderZIndexVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZIndexVal gets the Counter Input >> Position >> Z Index Value property.

DAQmxSetCIEncoderZIndexVal sets the Counter Input >> Position >> Z Index Value property.

DAQmxResetCIEncoderZIndexVal resets the Counter Input >> Position >> Z Index Value property.


Get/Set/Reset CI_Encoder_ZIndexPhase

int32 __CFUNC DAQmxGetCIEncoderZIndexPhase(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIEncoderZIndexPhase(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIEncoderZIndexPhase(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZIndexPhase gets the Counter Input >> Position >> Z Index Phase property.

DAQmxSetCIEncoderZIndexPhase sets the Counter Input >> Position >> Z Index Phase property.

DAQmxResetCIEncoderZIndexPhase resets the Counter Input >> Position >> Z Index Phase property.


Get/Set/Reset CI_Encoder_ZIndexEnable

int32 __CFUNC DAQmxGetCIEncoderZIndexEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderZIndexEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderZIndexEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZIndexEnable gets the Counter Input >> Position >> Z Index Enable property.

DAQmxSetCIEncoderZIndexEnable sets the Counter Input >> Position >> Z Index Enable property.

DAQmxResetCIEncoderZIndexEnable resets the Counter Input >> Position >> Z Index Enable property.


Get/Set/Reset AI_RVDT_Sensitivity

int32 __CFUNC DAQmxGetAIRVDTSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRVDTSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRVDTSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRVDTSensitivity gets the Analog Input >> Position >> RVDT >> Sensitivity property.

DAQmxSetAIRVDTSensitivity sets the Analog Input >> Position >> RVDT >> Sensitivity property.

DAQmxResetAIRVDTSensitivity resets the Analog Input >> Position >> RVDT >> Sensitivity property.


Get/Set/Reset AI_LVDT_Units

int32 __CFUNC DAQmxGetAILVDTUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAILVDTUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAILVDTUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILVDTUnits gets the Analog Input >> Position >> LVDT >> Units property.

DAQmxSetAILVDTUnits sets the Analog Input >> Position >> LVDT >> Units property.

DAQmxResetAILVDTUnits resets the Analog Input >> Position >> LVDT >> Units property.


Get/Set/Reset CI_LinEncoder_DistPerPulse

int32 __CFUNC DAQmxGetCILinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCILinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCILinEncoderDistPerPulse(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCILinEncoderDistPerPulse gets the Counter Input >> Position >> Linear Encoder >> Distance Per Pulse property.

DAQmxSetCILinEncoderDistPerPulse sets the Counter Input >> Position >> Linear Encoder >> Distance Per Pulse property.

DAQmxResetCILinEncoderDistPerPulse resets the Counter Input >> Position >> Linear Encoder >> Distance Per Pulse property.


Get/Set/Reset CI_LinEncoder_InitialPos

int32 __CFUNC DAQmxGetCILinEncoderInitialPos(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCILinEncoderInitialPos(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCILinEncoderInitialPos(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCILinEncoderInitialPos gets the Counter Input >> Position >> Linear Encoder >> Initial Position property.

DAQmxSetCILinEncoderInitialPos sets the Counter Input >> Position >> Linear Encoder >> Initial Position property.

DAQmxResetCILinEncoderInitialPos resets the Counter Input >> Position >> Linear Encoder >> Initial Position property.


Get/Set/Reset AI_LVDT_Sensitivity

int32 __CFUNC DAQmxGetAILVDTSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAILVDTSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAILVDTSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILVDTSensitivity gets the Analog Input >> Position >> LVDT >> Sensitivity property.

DAQmxSetAILVDTSensitivity sets the Analog Input >> Position >> LVDT >> Sensitivity property.

DAQmxResetAILVDTSensitivity resets the Analog Input >> Position >> LVDT >> Sensitivity property.


Get/Set/Reset AI_Resistance_Units

int32 __CFUNC DAQmxGetAIResistanceUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIResistanceUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIResistanceUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIResistanceUnits gets the Analog Input >> Resistance >> Units property.

DAQmxSetAIResistanceUnits sets the Analog Input >> Resistance >> Units property.

DAQmxResetAIResistanceUnits resets the Analog Input >> Resistance >> Units property.


Get/Set/Reset AI_Strain_Units

int32 __CFUNC DAQmxGetAIStrainUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIStrainUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIStrainUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIStrainUnits gets the Analog Input >> Strain >> Units property.

DAQmxSetAIStrainUnits sets the Analog Input >> Strain >> Units property.

DAQmxResetAIStrainUnits resets the Analog Input >> Strain >> Units property.


Get/Set/Reset AI_StrainGage_Cfg

int32 __CFUNC DAQmxGetAIStrainGageCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIStrainGageCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIStrainGageCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIStrainGageCfg gets the Analog Input >> Strain >> Strain Gage >> Configuration property.

DAQmxSetAIStrainGageCfg sets the Analog Input >> Strain >> Strain Gage >> Configuration property.

DAQmxResetAIStrainGageCfg resets the Analog Input >> Strain >> Strain Gage >> Configuration property.


Get/Set/Reset AI_StrainGage_GageFactor

int32 __CFUNC DAQmxGetAIStrainGageGageFactor(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIStrainGageGageFactor(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIStrainGageGageFactor(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIStrainGageGageFactor gets the Analog Input >> Strain >> Strain Gage >> Gage Factor property.

DAQmxSetAIStrainGageGageFactor sets the Analog Input >> Strain >> Strain Gage >> Gage Factor property.

DAQmxResetAIStrainGageGageFactor resets the Analog Input >> Strain >> Strain Gage >> Gage Factor property.


Get/Set/Reset AI_StrainGage_PoissonRatio

int32 __CFUNC DAQmxGetAIStrainGagePoissonRatio(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIStrainGagePoissonRatio(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIStrainGagePoissonRatio(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIStrainGagePoissonRatio gets the Analog Input >> Strain >> Strain Gage >> Poisson Ratio property.

DAQmxSetAIStrainGagePoissonRatio sets the Analog Input >> Strain >> Strain Gage >> Poisson Ratio property.

DAQmxResetAIStrainGagePoissonRatio resets the Analog Input >> Strain >> Strain Gage >> Poisson Ratio property.


Get/Set/Reset AI_RTD_A

int32 __CFUNC DAQmxGetAIRTDA(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRTDA(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRTDA(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRTDA gets the Analog Input >> Temperature >> RTD >> Custom >> A property.

DAQmxSetAIRTDA sets the Analog Input >> Temperature >> RTD >> Custom >> A property.

DAQmxResetAIRTDA resets the Analog Input >> Temperature >> RTD >> Custom >> A property.


Get/Set/Reset AI_RTD_B

int32 __CFUNC DAQmxGetAIRTDB(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRTDB(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRTDB(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRTDB gets the Analog Input >> Temperature >> RTD >> Custom >> B property.

DAQmxSetAIRTDB sets the Analog Input >> Temperature >> RTD >> Custom >> B property.

DAQmxResetAIRTDB resets the Analog Input >> Temperature >> RTD >> Custom >> B property.


Get/Set/Reset AI_RTD_C

int32 __CFUNC DAQmxGetAIRTDC(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRTDC(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRTDC(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRTDC gets the Analog Input >> Temperature >> RTD >> Custom >> C property.

DAQmxSetAIRTDC sets the Analog Input >> Temperature >> RTD >> Custom >> C property.

DAQmxResetAIRTDC resets the Analog Input >> Temperature >> RTD >> Custom >> C property.


Get/Set/Reset AI_RTD_R0

int32 __CFUNC DAQmxGetAIRTDR0(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRTDR0(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRTDR0(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRTDR0 gets the Analog Input >> Temperature >> RTD >> R0 property.

DAQmxSetAIRTDR0 sets the Analog Input >> Temperature >> RTD >> R0 property.

DAQmxResetAIRTDR0 resets the Analog Input >> Temperature >> RTD >> R0 property.


Get/Set/Reset AI_RTD_Type

int32 __CFUNC DAQmxGetAIRTDType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIRTDType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIRTDType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRTDType gets the Analog Input >> Temperature >> RTD >> Type property.

DAQmxSetAIRTDType sets the Analog Input >> Temperature >> RTD >> Type property.

DAQmxResetAIRTDType resets the Analog Input >> Temperature >> RTD >> Type property.


Get/Set/Reset AI_Temp_Units

int32 __CFUNC DAQmxGetAITempUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAITempUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAITempUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAITempUnits gets the Analog Input >> Temperature >> Units property.

DAQmxSetAITempUnits sets the Analog Input >> Temperature >> Units property.

DAQmxResetAITempUnits resets the Analog Input >> Temperature >> Units property.


Get/Set/Reset AI_Thrmcpl_CJCChan

int32 __CFUNC DAQmxGetAIThrmcplCJCChan(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetAIThrmcplCJCChan gets the Analog Input >> Temperature >> Thermocouple >> CJC Channel property.


Get/Set/Reset AI_Thrmcpl_CJCSrc

int32 __CFUNC DAQmxGetAIThrmcplCJCSrc(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAIThrmcplCJCSrc gets the Analog Input >> Temperature >> Thermocouple >> CJC Source property.


Get/Set/Reset AI_Thrmcpl_CJCVal

int32 __CFUNC DAQmxGetAIThrmcplCJCVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmcplCJCVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmcplCJCVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmcplCJCVal gets the Analog Input >> Temperature >> Thermocouple >> CJC Value property.

DAQmxSetAIThrmcplCJCVal sets the Analog Input >> Temperature >> Thermocouple >> CJC Value property.

DAQmxResetAIThrmcplCJCVal resets the Analog Input >> Temperature >> Thermocouple >> CJC Value property.


Get/Set/Reset AI_Thrmcpl_Type

int32 __CFUNC DAQmxGetAIThrmcplType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIThrmcplType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIThrmcplType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmcplType gets the Analog Input >> Temperature >> Thermocouple >> Type property.

DAQmxSetAIThrmcplType sets the Analog Input >> Temperature >> Thermocouple >> Type property.

DAQmxResetAIThrmcplType resets the Analog Input >> Temperature >> Thermocouple >> Type property.


Get/Set/Reset AI_Thrmstr_R1

int32 __CFUNC DAQmxGetAIThrmstrR1(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIThrmstrR1(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIThrmstrR1(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIThrmstrR1 gets the Analog Input >> Temperature >> Thermistor >> R1 property.

DAQmxSetAIThrmstrR1 sets the Analog Input >> Temperature >> Thermistor >> R1 property.

DAQmxResetAIThrmstrR1 resets the Analog Input >> Temperature >> Thermistor >> R1 property.


Get/Set/Reset CI_GPS_SyncMethod

int32 __CFUNC DAQmxGetCIGPSSyncMethod(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIGPSSyncMethod(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIGPSSyncMethod(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIGPSSyncMethod gets the Counter Input >> Timestamp >> GPS >> Synchronization Method property.

DAQmxSetCIGPSSyncMethod sets the Counter Input >> Timestamp >> GPS >> Synchronization Method property.

DAQmxResetCIGPSSyncMethod resets the Counter Input >> Timestamp >> GPS >> Synchronization Method property.


Get/Set/Reset CI_GPS_SyncSrc

int32 __CFUNC DAQmxGetCIGPSSyncSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIGPSSyncSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIGPSSyncSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIGPSSyncSrc gets the Counter Input >> Timestamp >> GPS >> Synchronization Source property.

DAQmxSetCIGPSSyncSrc sets the Counter Input >> Timestamp >> GPS >> Synchronization Source property.

DAQmxResetCIGPSSyncSrc resets the Counter Input >> Timestamp >> GPS >> Synchronization Source property.


Get/Set/Reset AI_Voltage_Units

int32 __CFUNC DAQmxGetAIVoltageUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIVoltageUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIVoltageUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIVoltageUnits gets the Analog Input >> Voltage >> Units property.

DAQmxSetAIVoltageUnits sets the Analog Input >> Voltage >> Units property.

DAQmxResetAIVoltageUnits resets the Analog Input >> Voltage >> Units property.


Get/Set/Reset AI_TermCfg

int32 __CFUNC DAQmxGetAITermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAITermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAITermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAITermCfg gets the Analog Input >> General Properties >> Input Configuration >> Terminal Configuration property.

DAQmxSetAITermCfg sets the Analog Input >> General Properties >> Input Configuration >> Terminal Configuration property.

DAQmxResetAITermCfg resets the Analog Input >> General Properties >> Input Configuration >> Terminal Configuration property.


Get/Set/Reset AO_OutputType

int32 __CFUNC DAQmxGetAOOutputType(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAOOutputType gets the Analog Output >> Output Type property.


Get/Set/Reset AO_Current_Units

int32 __CFUNC DAQmxGetAOCurrentUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOCurrentUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOCurrentUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOCurrentUnits gets the Analog Output >> Current >> Units property.

DAQmxSetAOCurrentUnits sets the Analog Output >> Current >> Units property.

DAQmxResetAOCurrentUnits resets the Analog Output >> Current >> Units property.


Get/Set/Reset DO_InvertLines

int32 __CFUNC DAQmxGetDOInvertLines(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDOInvertLines(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDOInvertLines(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOInvertLines gets the Digital Output >> Invert Lines property.

DAQmxSetDOInvertLines sets the Digital Output >> Invert Lines property.

DAQmxResetDOInvertLines resets the Digital Output >> Invert Lines property.


Get/Set/Reset DO_OutputDriveType

int32 __CFUNC DAQmxGetDOOutputDriveType(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOOutputDriveType(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOOutputDriveType(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOOutputDriveType gets the Digital Output >> Output Drive Type property.

DAQmxSetDOOutputDriveType sets the Digital Output >> Output Drive Type property.

DAQmxResetDOOutputDriveType resets the Digital Output >> Output Drive Type property.


Get/Set/Reset CO_Pulse_HighTicks

int32 __CFUNC DAQmxGetCOPulseHighTicks(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOPulseHighTicks(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOPulseHighTicks(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseHighTicks gets the Counter Output >> Pulse >> Ticks >> High Ticks property.

DAQmxSetCOPulseHighTicks sets the Counter Output >> Pulse >> Ticks >> High Ticks property.

DAQmxResetCOPulseHighTicks resets the Counter Output >> Pulse >> Ticks >> High Ticks property.


Get/Set/Reset CO_Pulse_IdleState

int32 __CFUNC DAQmxGetCOPulseIdleState(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCOPulseIdleState(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCOPulseIdleState(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseIdleState gets the Counter Output >> Pulse >> Idle State property.

DAQmxSetCOPulseIdleState sets the Counter Output >> Pulse >> Idle State property.

DAQmxResetCOPulseIdleState resets the Counter Output >> Pulse >> Idle State property.


Get/Set/Reset CO_Pulse_LowTicks

int32 __CFUNC DAQmxGetCOPulseLowTicks(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOPulseLowTicks(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOPulseLowTicks(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseLowTicks gets the Counter Output >> Pulse >> Ticks >> Low Ticks property.

DAQmxSetCOPulseLowTicks sets the Counter Output >> Pulse >> Ticks >> Low Ticks property.

DAQmxResetCOPulseLowTicks resets the Counter Output >> Pulse >> Ticks >> Low Ticks property.


Get/Set/Reset CO_Pulse_DutyCyc

int32 __CFUNC DAQmxGetCOPulseDutyCyc(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseDutyCyc(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseDutyCyc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseDutyCyc gets the Counter Output >> Pulse >> Frequency >> Duty Cycle property.

DAQmxSetCOPulseDutyCyc sets the Counter Output >> Pulse >> Frequency >> Duty Cycle property.

DAQmxResetCOPulseDutyCyc resets the Counter Output >> Pulse >> Frequency >> Duty Cycle property.


Get/Set/Reset CO_Pulse_Freq

int32 __CFUNC DAQmxGetCOPulseFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOPulseFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOPulseFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOPulseFreq gets the Counter Output >> Pulse >> Frequency >> Frequency property.

DAQmxSetCOPulseFreq sets the Counter Output >> Pulse >> Frequency >> Frequency property.

DAQmxResetCOPulseFreq resets the Counter Output >> Pulse >> Frequency >> Frequency property.


Get/Set/Reset AO_Voltage_Units

int32 __CFUNC DAQmxGetAOVoltageUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOVoltageUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOVoltageUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOVoltageUnits gets the Analog Output >> Voltage >> Units property.

DAQmxSetAOVoltageUnits sets the Analog Output >> Voltage >> Units property.

DAQmxResetAOVoltageUnits resets the Analog Output >> Voltage >> Units property.


Get/Set/Reset AO_Max

int32 __CFUNC DAQmxGetAOMax(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOMax(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOMax(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOMax gets the Analog Output >> Maximum Value property.

DAQmxSetAOMax sets the Analog Output >> Maximum Value property.

DAQmxResetAOMax resets the Analog Output >> Maximum Value property.


Get/Set/Reset AO_Min

int32 __CFUNC DAQmxGetAOMin(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOMin(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOMin(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOMin gets the Analog Output >> Minimum Value property.

DAQmxSetAOMin sets the Analog Output >> Minimum Value property.

DAQmxResetAOMin resets the Analog Output >> Minimum Value property.


Get/Set/Reset AO_CustomScaleName

int32 __CFUNC DAQmxGetAOCustomScaleName(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAOCustomScaleName(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAOCustomScaleName(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOCustomScaleName gets the Analog Output >> Custom Scale Name property.

DAQmxSetAOCustomScaleName sets the Analog Output >> Custom Scale Name property.

DAQmxResetAOCustomScaleName resets the Analog Output >> Custom Scale Name property.


Get/Set/Reset Read_OverWrite

int32 __CFUNC DAQmxGetReadOverWrite(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetReadOverWrite(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetReadOverWrite(TaskHandle taskHandle);

Purpose

DAQmxGetReadOverWrite gets the OverWrite Mode property.

DAQmxSetReadOverWrite sets the OverWrite Mode property.

DAQmxResetReadOverWrite resets the OverWrite Mode property.


Get/Set/Reset Read_ReadAllAvailSamp

int32 __CFUNC DAQmxGetReadReadAllAvailSamp(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetReadReadAllAvailSamp(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetReadReadAllAvailSamp(TaskHandle taskHandle);

Purpose

DAQmxGetReadReadAllAvailSamp gets the Read All Available Samples property.

DAQmxSetReadReadAllAvailSamp sets the Read All Available Samples property.

DAQmxResetReadReadAllAvailSamp resets the Read All Available Samples property.


Get/Set/Reset Read_CurrReadPos

int32 __CFUNC DAQmxGetReadCurrReadPos(TaskHandle taskHandle, uInt64 *data);

Purpose

DAQmxGetReadCurrReadPos gets the Status >> Current Read Position property.


Get/Set/Reset Read_AvailSampPerChan

int32 __CFUNC DAQmxGetReadAvailSampPerChan(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetReadAvailSampPerChan gets the Status >> Available Samples Per Channel property.


Get/Set/Reset Scale_Descr

int32 __CFUNC DAQmxGetScaleDescr(const char scaleName[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetScaleDescr(const char scaleName[], const char *data);

Purpose

DAQmxGetScaleDescr gets the Description property.

DAQmxSetScaleDescr sets the Description property.


Get/Set/Reset Scale_Lin_Slope

int32 __CFUNC DAQmxGetScaleLinSlope(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleLinSlope(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleLinSlope gets the Linear >> Slope property.

DAQmxSetScaleLinSlope sets the Linear >> Slope property.


Get/Set/Reset Scale_Lin_YIntercept

int32 __CFUNC DAQmxGetScaleLinYIntercept(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleLinYIntercept(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleLinYIntercept gets the Linear >> Y-Intercept property.

DAQmxSetScaleLinYIntercept sets the Linear >> Y-Intercept property.


Get/Set/Reset Scale_Map_ScaledMax

int32 __CFUNC DAQmxGetScaleMapScaledMax(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleMapScaledMax(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleMapScaledMax gets the Map >> Scaled Maximum Value property.

DAQmxSetScaleMapScaledMax sets the Map >> Scaled Maximum Value property.


Get/Set/Reset Scale_Map_ScaledMin

int32 __CFUNC DAQmxGetScaleMapScaledMin(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleMapScaledMin(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleMapScaledMin gets the Map >> Scaled Minimum Value property.

DAQmxSetScaleMapScaledMin sets the Map >> Scaled Minimum Value property.


Get/Set/Reset Scale_Map_PreScaledMax

int32 __CFUNC DAQmxGetScaleMapPreScaledMax(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleMapPreScaledMax(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleMapPreScaledMax gets the Map >> Pre-Scaled Maximum Value property.

DAQmxSetScaleMapPreScaledMax sets the Map >> Pre-Scaled Maximum Value property.


Get/Set/Reset Scale_Map_PreScaledMin

int32 __CFUNC DAQmxGetScaleMapPreScaledMin(const char scaleName[], float64 *data);

int32 __CFUNC DAQmxSetScaleMapPreScaledMin(const char scaleName[], float64 data);

Purpose

DAQmxGetScaleMapPreScaledMin gets the Map >> Pre-Scaled Minimum Value property.

DAQmxSetScaleMapPreScaledMin sets the Map >> Pre-Scaled Minimum Value property.


Get/Set/Reset Scale_Poly_ForwardCoeff

int32 __CFUNC DAQmxGetScalePolyForwardCoeff(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetScalePolyForwardCoeff(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetScalePolyForwardCoeff gets the Polynomial >> Forward Coefficients property.

DAQmxSetScalePolyForwardCoeff sets the Polynomial >> Forward Coefficients property.


Get/Set/Reset Scale_Poly_ReverseCoeff

int32 __CFUNC DAQmxGetScalePolyReverseCoeff(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetScalePolyReverseCoeff(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetScalePolyReverseCoeff gets the Polynomial >> Reverse Coefficients property.

DAQmxSetScalePolyReverseCoeff sets the Polynomial >> Reverse Coefficients property.


Get/Set/Reset Scale_Table_ScaledVals

int32 __CFUNC DAQmxGetScaleTableScaledVals(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetScaleTableScaledVals(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetScaleTableScaledVals gets the Table >> Scaled Values property.

DAQmxSetScaleTableScaledVals sets the Table >> Scaled Values property.


Get/Set/Reset Scale_Table_PreScaledVals

int32 __CFUNC DAQmxGetScaleTablePreScaledVals(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

int32 __CFUNC DAQmxSetScaleTablePreScaledVals(const char scaleName[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetScaleTablePreScaledVals gets the Table >> Pre-Scaled Values property.

DAQmxSetScaleTablePreScaledVals sets the Table >> Pre-Scaled Values property.


Get/Set/Reset SwitchDev_Settled

int32 __CFUNC DAQmxGetSwitchDevSettled(const char deviceName[], bool32 *data);

Purpose

DAQmxGetSwitchDevSettled gets the Deprecated >> Is Settled property.


Get/Set/Reset SwitchDev_SettlingTime

int32 __CFUNC DAQmxGetSwitchDevSettlingTime(const char deviceName[], float64 *data);

int32 __CFUNC DAQmxSetSwitchDevSettlingTime(const char deviceName[], float64 data);

Purpose

DAQmxGetSwitchDevSettlingTime gets the Deprecated >> Settling Time property.

DAQmxSetSwitchDevSettlingTime sets the Deprecated >> Settling Time property.


Get/Set/Reset SwitchScan_BreakMode

int32 __CFUNC DAQmxGetSwitchScanBreakMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSwitchScanBreakMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSwitchScanBreakMode(TaskHandle taskHandle);

Purpose

DAQmxGetSwitchScanBreakMode gets the Deprecated >> Break Mode property.

DAQmxSetSwitchScanBreakMode sets the Deprecated >> Break Mode property.

DAQmxResetSwitchScanBreakMode resets the Deprecated >> Break Mode property.


Get/Set/Reset SwitchScan_RepeatMode

int32 __CFUNC DAQmxGetSwitchScanRepeatMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSwitchScanRepeatMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSwitchScanRepeatMode(TaskHandle taskHandle);

Purpose

DAQmxGetSwitchScanRepeatMode gets the Deprecated >> Repeat Mode property.

DAQmxSetSwitchScanRepeatMode sets the Deprecated >> Repeat Mode property.

DAQmxResetSwitchScanRepeatMode resets the Deprecated >> Repeat Mode property.


Get/Set/Reset Sys_GlobalChans

int32 __CFUNC DAQmxGetSysGlobalChans(char *data, uInt32 bufferSize);

Purpose

DAQmxGetSysGlobalChans gets the Global Channels property.


Get/Set/Reset Sys_Scales

int32 __CFUNC DAQmxGetSysScales(char *data, uInt32 bufferSize);

Purpose

DAQmxGetSysScales gets the Scales property.


Get/Set/Reset Sys_Tasks

int32 __CFUNC DAQmxGetSysTasks(char *data, uInt32 bufferSize);

Purpose

DAQmxGetSysTasks gets the Tasks property.


Get/Set/Reset Sys_NIDAQMajorVersion

int32 __CFUNC DAQmxGetSysNIDAQMajorVersion(uInt32 *data);

Purpose

DAQmxGetSysNIDAQMajorVersion gets the System >> NI-DAQ Version >> Major property.


Get/Set/Reset Task_Channels

int32 __CFUNC DAQmxGetTaskChannels(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetTaskChannels gets the Channels property.


Get/Set/Reset Task_Complete

int32 __CFUNC DAQmxGetTaskComplete(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetTaskComplete gets the Task Done property.


Get/Set/Reset Task_Name

int32 __CFUNC DAQmxGetTaskName(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetTaskName gets the Name property.


Get/Set/Reset SampQuant_SampMode

int32 __CFUNC DAQmxGetSampQuantSampMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampQuantSampMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampQuantSampMode(TaskHandle taskHandle);

Purpose

DAQmxGetSampQuantSampMode gets the Sample Quantity >> Sample Mode property.

DAQmxSetSampQuantSampMode sets the Sample Quantity >> Sample Mode property.

DAQmxResetSampQuantSampMode resets the Sample Quantity >> Sample Mode property.


Get/Set/Reset SampClk_ActiveEdge

int32 __CFUNC DAQmxGetSampClkActiveEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampClkActiveEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampClkActiveEdge(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkActiveEdge gets the Sample Clock >> Active Edge property.

DAQmxSetSampClkActiveEdge sets the Sample Clock >> Active Edge property.

DAQmxResetSampClkActiveEdge resets the Sample Clock >> Active Edge property.


Get/Set/Reset SampClk_Timebase_Rate

int32 __CFUNC DAQmxGetSampClkTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSampClkTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSampClkTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkTimebaseRate gets the Sample Clock >> Timebase >> Rate property.

DAQmxSetSampClkTimebaseRate sets the Sample Clock >> Timebase >> Rate property.

DAQmxResetSampClkTimebaseRate resets the Sample Clock >> Timebase >> Rate property.


Get/Set/Reset DelayFromSampClk_DelayUnits

int32 __CFUNC DAQmxGetDelayFromSampClkDelayUnits(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDelayFromSampClkDelayUnits(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDelayFromSampClkDelayUnits(TaskHandle taskHandle);

Purpose

DAQmxGetDelayFromSampClkDelayUnits gets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.

DAQmxSetDelayFromSampClkDelayUnits sets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.

DAQmxResetDelayFromSampClkDelayUnits resets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.


Get/Set/Reset SampClk_Timebase_MasterTimebaseDiv

int32 __CFUNC DAQmxGetSampClkTimebaseMasterTimebaseDiv(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetSampClkTimebaseMasterTimebaseDiv(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetSampClkTimebaseMasterTimebaseDiv(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkTimebaseMasterTimebaseDiv gets the Sample Clock >> Timebase >> Master Timebase Divisor property.

DAQmxSetSampClkTimebaseMasterTimebaseDiv sets the Sample Clock >> Timebase >> Master Timebase Divisor property.

DAQmxResetSampClkTimebaseMasterTimebaseDiv resets the Sample Clock >> Timebase >> Master Timebase Divisor property.


Get/Set/Reset SampClk_Timebase_Src

int32 __CFUNC DAQmxGetSampClkTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetSampClkTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetSampClkTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkTimebaseSrc gets the Sample Clock >> Timebase >> Source property.

DAQmxSetSampClkTimebaseSrc sets the Sample Clock >> Timebase >> Source property.

DAQmxResetSampClkTimebaseSrc resets the Sample Clock >> Timebase >> Source property.


Get/Set/Reset SampQuant_SampPerChan

int32 __CFUNC DAQmxGetSampQuantSampPerChan(TaskHandle taskHandle, uInt64 *data);

int32 __CFUNC DAQmxSetSampQuantSampPerChan(TaskHandle taskHandle, uInt64 data);

int32 __CFUNC DAQmxResetSampQuantSampPerChan(TaskHandle taskHandle);

Purpose

DAQmxGetSampQuantSampPerChan gets the Sample Quantity >> Samples Per Channel property.

DAQmxSetSampQuantSampPerChan sets the Sample Quantity >> Samples Per Channel property.

DAQmxResetSampQuantSampPerChan resets the Sample Quantity >> Samples Per Channel property.


Get/Set/Reset RefClk_Rate

int32 __CFUNC DAQmxGetRefClkRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetRefClkRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetRefClkRate(TaskHandle taskHandle);

Purpose

DAQmxGetRefClkRate gets the More >> Reference Clock >> Rate property.

DAQmxSetRefClkRate sets the More >> Reference Clock >> Rate property.

DAQmxResetRefClkRate resets the More >> Reference Clock >> Rate property.


Get/Set/Reset RefClk_Src

int32 __CFUNC DAQmxGetRefClkSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetRefClkSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetRefClkSrc(TaskHandle taskHandle);

Purpose

DAQmxGetRefClkSrc gets the More >> Reference Clock >> Source property.

DAQmxSetRefClkSrc sets the More >> Reference Clock >> Source property.

DAQmxResetRefClkSrc resets the More >> Reference Clock >> Source property.


Get/Set/Reset DelayFromSampClk_Delay

int32 __CFUNC DAQmxGetDelayFromSampClkDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDelayFromSampClkDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDelayFromSampClkDelay(TaskHandle taskHandle);

Purpose

DAQmxGetDelayFromSampClkDelay gets the More >> AI Convert >> Delay From Sample Clock >> Delay property.

DAQmxSetDelayFromSampClkDelay sets the More >> AI Convert >> Delay From Sample Clock >> Delay property.

DAQmxResetDelayFromSampClkDelay resets the More >> AI Convert >> Delay From Sample Clock >> Delay property.


Get/Set/Reset AIConv_TimebaseDiv

int32 __CFUNC DAQmxGetAIConvTimebaseDiv(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetAIConvTimebaseDiv(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetAIConvTimebaseDiv(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvTimebaseDiv gets the More >> AI Convert >> Timebase Divisor property.

DAQmxSetAIConvTimebaseDiv sets the More >> AI Convert >> Timebase Divisor property.

DAQmxResetAIConvTimebaseDiv resets the More >> AI Convert >> Timebase Divisor property.


Get/Set/Reset AIConv_Timebase_Src

int32 __CFUNC DAQmxGetAIConvTimebaseSrc(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAIConvTimebaseSrc(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAIConvTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvTimebaseSrc gets the More >> AI Convert >> Timebase >> Source property.

DAQmxSetAIConvTimebaseSrc sets the More >> AI Convert >> Timebase >> Source property.

DAQmxResetAIConvTimebaseSrc resets the More >> AI Convert >> Timebase >> Source property.


Get/Set/Reset MasterTimebase_Src

int32 __CFUNC DAQmxGetMasterTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetMasterTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetMasterTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetMasterTimebaseSrc gets the More >> Master Timebase >> Source property.

DAQmxSetMasterTimebaseSrc sets the More >> Master Timebase >> Source property.

DAQmxResetMasterTimebaseSrc resets the More >> Master Timebase >> Source property.


Get/Set/Reset SampClk_Rate

int32 __CFUNC DAQmxGetSampClkRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSampClkRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSampClkRate(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkRate gets the Sample Clock >> Rate property.

DAQmxSetSampClkRate sets the Sample Clock >> Rate property.

DAQmxResetSampClkRate resets the Sample Clock >> Rate property.


Get/Set/Reset SampTimingType

int32 __CFUNC DAQmxGetSampTimingType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampTimingType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampTimingType(TaskHandle taskHandle);

Purpose

DAQmxGetSampTimingType gets the Sample Timing Type property.

DAQmxSetSampTimingType sets the Sample Timing Type property.

DAQmxResetSampTimingType resets the Sample Timing Type property.


Get/Set/Reset DigEdge_AdvTrig_Edge

int32 __CFUNC DAQmxGetDigEdgeAdvTrigEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigEdgeAdvTrigEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigEdgeAdvTrigEdge(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeAdvTrigEdge gets the More >> Advance >> Digital Edge >> Edge property.

DAQmxSetDigEdgeAdvTrigEdge sets the More >> Advance >> Digital Edge >> Edge property.

DAQmxResetDigEdgeAdvTrigEdge resets the More >> Advance >> Digital Edge >> Edge property.


Get/Set/Reset DigEdge_AdvTrig_Src

int32 __CFUNC DAQmxGetDigEdgeAdvTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeAdvTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeAdvTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeAdvTrigSrc gets the More >> Advance >> Digital Edge >> Source property.

DAQmxSetDigEdgeAdvTrigSrc sets the More >> Advance >> Digital Edge >> Source property.

DAQmxResetDigEdgeAdvTrigSrc resets the More >> Advance >> Digital Edge >> Source property.


Get/Set/Reset AdvTrig_Type

int32 __CFUNC DAQmxGetAdvTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAdvTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAdvTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetAdvTrigType gets the More >> Advance >> Trigger Type property.

DAQmxSetAdvTrigType sets the More >> Advance >> Trigger Type property.

DAQmxResetAdvTrigType resets the More >> Advance >> Trigger Type property.


Get/Set/Reset PauseTrig_Type

int32 __CFUNC DAQmxGetPauseTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetPauseTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetPauseTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetPauseTrigType gets the More >> Pause >> Trigger Type property.

DAQmxSetPauseTrigType sets the More >> Pause >> Trigger Type property.

DAQmxResetPauseTrigType resets the More >> Pause >> Trigger Type property.


Get/Set/Reset AnlgLvl_PauseTrig_Hyst

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigHyst(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigHyst(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigHyst(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigHyst gets the More >> Pause >> Analog Level >> Hysteresis property.

DAQmxSetAnlgLvlPauseTrigHyst sets the More >> Pause >> Analog Level >> Hysteresis property.

DAQmxResetAnlgLvlPauseTrigHyst resets the More >> Pause >> Analog Level >> Hysteresis property.


Get/Set/Reset AnlgLvl_PauseTrig_Lvl

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigLvl(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigLvl(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigLvl(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigLvl gets the More >> Pause >> Analog Level >> Level property.

DAQmxSetAnlgLvlPauseTrigLvl sets the More >> Pause >> Analog Level >> Level property.

DAQmxResetAnlgLvlPauseTrigLvl resets the More >> Pause >> Analog Level >> Level property.


Get/Set/Reset AnlgLvl_PauseTrig_Src

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigSrc gets the More >> Pause >> Analog Level >> Source property.

DAQmxSetAnlgLvlPauseTrigSrc sets the More >> Pause >> Analog Level >> Source property.

DAQmxResetAnlgLvlPauseTrigSrc resets the More >> Pause >> Analog Level >> Source property.


Get/Set/Reset AnlgLvl_PauseTrig_When

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigWhen gets the More >> Pause >> Analog Level >> Pause When property.

DAQmxSetAnlgLvlPauseTrigWhen sets the More >> Pause >> Analog Level >> Pause When property.

DAQmxResetAnlgLvlPauseTrigWhen resets the More >> Pause >> Analog Level >> Pause When property.


Get/Set/Reset AnlgWin_PauseTrig_Src

int32 __CFUNC DAQmxGetAnlgWinPauseTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigSrc gets the More >> Pause >> Analog Window >> Source property.

DAQmxSetAnlgWinPauseTrigSrc sets the More >> Pause >> Analog Window >> Source property.

DAQmxResetAnlgWinPauseTrigSrc resets the More >> Pause >> Analog Window >> Source property.


Get/Set/Reset AnlgWin_PauseTrig_When

int32 __CFUNC DAQmxGetAnlgWinPauseTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigWhen gets the More >> Pause >> Analog Window >> Pause When property.

DAQmxSetAnlgWinPauseTrigWhen sets the More >> Pause >> Analog Window >> Pause When property.

DAQmxResetAnlgWinPauseTrigWhen resets the More >> Pause >> Analog Window >> Pause When property.


Get/Set/Reset AnlgWin_PauseTrig_Btm

int32 __CFUNC DAQmxGetAnlgWinPauseTrigBtm(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigBtm(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigBtm(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigBtm gets the More >> Pause >> Analog Window >> Bottom property.

DAQmxSetAnlgWinPauseTrigBtm sets the More >> Pause >> Analog Window >> Bottom property.

DAQmxResetAnlgWinPauseTrigBtm resets the More >> Pause >> Analog Window >> Bottom property.


Get/Set/Reset AnlgWin_PauseTrig_Top

int32 __CFUNC DAQmxGetAnlgWinPauseTrigTop(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigTop(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigTop(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigTop gets the More >> Pause >> Analog Window >> Top property.

DAQmxSetAnlgWinPauseTrigTop sets the More >> Pause >> Analog Window >> Top property.

DAQmxResetAnlgWinPauseTrigTop resets the More >> Pause >> Analog Window >> Top property.


Get/Set/Reset DigLvl_PauseTrig_Src

int32 __CFUNC DAQmxGetDigLvlPauseTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigLvlPauseTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigSrc gets the More >> Pause >> Digital Level >> Source property.

DAQmxSetDigLvlPauseTrigSrc sets the More >> Pause >> Digital Level >> Source property.

DAQmxResetDigLvlPauseTrigSrc resets the More >> Pause >> Digital Level >> Source property.


Get/Set/Reset DigLvl_PauseTrig_When

int32 __CFUNC DAQmxGetDigLvlPauseTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigLvlPauseTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigWhen gets the More >> Pause >> Digital Level >> Pause When property.

DAQmxSetDigLvlPauseTrigWhen sets the More >> Pause >> Digital Level >> Pause When property.

DAQmxResetDigLvlPauseTrigWhen resets the More >> Pause >> Digital Level >> Pause When property.


Get/Set/Reset StartTrig_Type

int32 __CFUNC DAQmxGetStartTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetStartTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetStartTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetStartTrigType gets the Start >> Trigger Type property.

DAQmxSetStartTrigType sets the Start >> Trigger Type property.

DAQmxResetStartTrigType resets the Start >> Trigger Type property.


Get/Set/Reset AnlgEdge_StartTrig_Hyst

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigHyst(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigHyst(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigHyst(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigHyst gets the Start >> Analog Edge >> Hysteresis property.

DAQmxSetAnlgEdgeStartTrigHyst sets the Start >> Analog Edge >> Hysteresis property.

DAQmxResetAnlgEdgeStartTrigHyst resets the Start >> Analog Edge >> Hysteresis property.


Get/Set/Reset AnlgEdge_StartTrig_Lvl

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigLvl(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigLvl(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigLvl(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigLvl gets the Start >> Analog Edge >> Level property.

DAQmxSetAnlgEdgeStartTrigLvl sets the Start >> Analog Edge >> Level property.

DAQmxResetAnlgEdgeStartTrigLvl resets the Start >> Analog Edge >> Level property.


Get/Set/Reset AnlgEdge_StartTrig_Slope

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigSlope(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigSlope(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigSlope(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigSlope gets the Start >> Analog Edge >> Slope property.

DAQmxSetAnlgEdgeStartTrigSlope sets the Start >> Analog Edge >> Slope property.

DAQmxResetAnlgEdgeStartTrigSlope resets the Start >> Analog Edge >> Slope property.


Get/Set/Reset AnlgEdge_StartTrig_Src

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigSrc gets the Start >> Analog Edge >> Source property.

DAQmxSetAnlgEdgeStartTrigSrc sets the Start >> Analog Edge >> Source property.

DAQmxResetAnlgEdgeStartTrigSrc resets the Start >> Analog Edge >> Source property.


Get/Set/Reset AnlgWin_StartTrig_Src

int32 __CFUNC DAQmxGetAnlgWinStartTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinStartTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigSrc gets the Start >> Analog Window >> Source property.

DAQmxSetAnlgWinStartTrigSrc sets the Start >> Analog Window >> Source property.

DAQmxResetAnlgWinStartTrigSrc resets the Start >> Analog Window >> Source property.


Get/Set/Reset AnlgWin_StartTrig_When

int32 __CFUNC DAQmxGetAnlgWinStartTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigWhen gets the Start >> Analog Window >> Trigger When property.

DAQmxSetAnlgWinStartTrigWhen sets the Start >> Analog Window >> Trigger When property.

DAQmxResetAnlgWinStartTrigWhen resets the Start >> Analog Window >> Trigger When property.


Get/Set/Reset AnlgWin_StartTrig_Btm

int32 __CFUNC DAQmxGetAnlgWinStartTrigBtm(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigBtm(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigBtm(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigBtm gets the Start >> Analog Window >> Bottom property.

DAQmxSetAnlgWinStartTrigBtm sets the Start >> Analog Window >> Bottom property.

DAQmxResetAnlgWinStartTrigBtm resets the Start >> Analog Window >> Bottom property.


Get/Set/Reset AnlgWin_StartTrig_Top

int32 __CFUNC DAQmxGetAnlgWinStartTrigTop(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigTop(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigTop(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigTop gets the Start >> Analog Window >> Top property.

DAQmxSetAnlgWinStartTrigTop sets the Start >> Analog Window >> Top property.

DAQmxResetAnlgWinStartTrigTop resets the Start >> Analog Window >> Top property.


Get/Set/Reset DigEdge_StartTrig_Edge

int32 __CFUNC DAQmxGetDigEdgeStartTrigEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigEdgeStartTrigEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigEdge(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigEdge gets the Start >> Digital Edge >> Edge property.

DAQmxSetDigEdgeStartTrigEdge sets the Start >> Digital Edge >> Edge property.

DAQmxResetDigEdgeStartTrigEdge resets the Start >> Digital Edge >> Edge property.


Get/Set/Reset DigEdge_StartTrig_Src

int32 __CFUNC DAQmxGetDigEdgeStartTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeStartTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigSrc gets the Start >> Digital Edge >> Source property.

DAQmxSetDigEdgeStartTrigSrc sets the Start >> Digital Edge >> Source property.

DAQmxResetDigEdgeStartTrigSrc resets the Start >> Digital Edge >> Source property.


Get/Set/Reset DigPattern_StartTrig_Src

int32 __CFUNC DAQmxGetDigPatternStartTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternStartTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternStartTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternStartTrigSrc gets the Start >> Digital Pattern >> Source property.

DAQmxSetDigPatternStartTrigSrc sets the Start >> Digital Pattern >> Source property.

DAQmxResetDigPatternStartTrigSrc resets the Start >> Digital Pattern >> Source property.


Get/Set/Reset DigPattern_StartTrig_When

int32 __CFUNC DAQmxGetDigPatternStartTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigPatternStartTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigPatternStartTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternStartTrigWhen gets the Start >> Digital Pattern >> Trigger When property.

DAQmxSetDigPatternStartTrigWhen sets the Start >> Digital Pattern >> Trigger When property.

DAQmxResetDigPatternStartTrigWhen resets the Start >> Digital Pattern >> Trigger When property.


Get/Set/Reset ArmStartTrig_Type

int32 __CFUNC DAQmxGetArmStartTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetArmStartTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetArmStartTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetArmStartTrigType gets the More >> Arm Start >> Trigger Type property.

DAQmxSetArmStartTrigType sets the More >> Arm Start >> Trigger Type property.

DAQmxResetArmStartTrigType resets the More >> Arm Start >> Trigger Type property.


Get/Set/Reset DigEdge_ArmStartTrig_Edge

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigEdge(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigEdge gets the More >> Arm Start >> Digital Edge >> Edge property.

DAQmxSetDigEdgeArmStartTrigEdge sets the More >> Arm Start >> Digital Edge >> Edge property.

DAQmxResetDigEdgeArmStartTrigEdge resets the More >> Arm Start >> Digital Edge >> Edge property.


Get/Set/Reset DigEdge_ArmStartTrig_Src

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigSrc gets the More >> Arm Start >> Digital Edge >> Source property.

DAQmxSetDigEdgeArmStartTrigSrc sets the More >> Arm Start >> Digital Edge >> Source property.

DAQmxResetDigEdgeArmStartTrigSrc resets the More >> Arm Start >> Digital Edge >> Source property.


Get/Set/Reset RefTrig_Type

int32 __CFUNC DAQmxGetRefTrigType(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetRefTrigType(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetRefTrigType(TaskHandle taskHandle);

Purpose

DAQmxGetRefTrigType gets the Reference >> Trigger Type property.

DAQmxSetRefTrigType sets the Reference >> Trigger Type property.

DAQmxResetRefTrigType resets the Reference >> Trigger Type property.


Get/Set/Reset AnlgEdge_RefTrig_Hyst

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigHyst(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigHyst(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigHyst(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigHyst gets the Reference >> Analog Edge >> Hysteresis property.

DAQmxSetAnlgEdgeRefTrigHyst sets the Reference >> Analog Edge >> Hysteresis property.

DAQmxResetAnlgEdgeRefTrigHyst resets the Reference >> Analog Edge >> Hysteresis property.


Get/Set/Reset AnlgEdge_RefTrig_Lvl

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigLvl(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigLvl(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigLvl(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigLvl gets the Reference >> Analog Edge >> Level property.

DAQmxSetAnlgEdgeRefTrigLvl sets the Reference >> Analog Edge >> Level property.

DAQmxResetAnlgEdgeRefTrigLvl resets the Reference >> Analog Edge >> Level property.


Get/Set/Reset AnlgEdge_RefTrig_Slope

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigSlope(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigSlope(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigSlope(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigSlope gets the Reference >> Analog Edge >> Slope property.

DAQmxSetAnlgEdgeRefTrigSlope sets the Reference >> Analog Edge >> Slope property.

DAQmxResetAnlgEdgeRefTrigSlope resets the Reference >> Analog Edge >> Slope property.


Get/Set/Reset AnlgEdge_RefTrig_Src

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigSrc gets the Reference >> Analog Edge >> Source property.

DAQmxSetAnlgEdgeRefTrigSrc sets the Reference >> Analog Edge >> Source property.

DAQmxResetAnlgEdgeRefTrigSrc resets the Reference >> Analog Edge >> Source property.


Get/Set/Reset AnlgWin_RefTrig_Src

int32 __CFUNC DAQmxGetAnlgWinRefTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAnlgWinRefTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigSrc gets the Reference >> Analog Window >> Source property.

DAQmxSetAnlgWinRefTrigSrc sets the Reference >> Analog Window >> Source property.

DAQmxResetAnlgWinRefTrigSrc resets the Reference >> Analog Window >> Source property.


Get/Set/Reset AnlgWin_RefTrig_When

int32 __CFUNC DAQmxGetAnlgWinRefTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigWhen gets the Reference >> Analog Window >> Trigger When property.

DAQmxSetAnlgWinRefTrigWhen sets the Reference >> Analog Window >> Trigger When property.

DAQmxResetAnlgWinRefTrigWhen resets the Reference >> Analog Window >> Trigger When property.


Get/Set/Reset AnlgWin_RefTrig_Btm

int32 __CFUNC DAQmxGetAnlgWinRefTrigBtm(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigBtm(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigBtm(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigBtm gets the Reference >> Analog Window >> Bottom property.

DAQmxSetAnlgWinRefTrigBtm sets the Reference >> Analog Window >> Bottom property.

DAQmxResetAnlgWinRefTrigBtm resets the Reference >> Analog Window >> Bottom property.


Get/Set/Reset AnlgWin_RefTrig_Top

int32 __CFUNC DAQmxGetAnlgWinRefTrigTop(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigTop(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigTop(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigTop gets the Reference >> Analog Window >> Top property.

DAQmxSetAnlgWinRefTrigTop sets the Reference >> Analog Window >> Top property.

DAQmxResetAnlgWinRefTrigTop resets the Reference >> Analog Window >> Top property.


Get/Set/Reset DigEdge_RefTrig_Edge

int32 __CFUNC DAQmxGetDigEdgeRefTrigEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigEdgeRefTrigEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigEdge(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigEdge gets the Reference >> Digital Edge >> Edge property.

DAQmxSetDigEdgeRefTrigEdge sets the Reference >> Digital Edge >> Edge property.

DAQmxResetDigEdgeRefTrigEdge resets the Reference >> Digital Edge >> Edge property.


Get/Set/Reset DigEdge_RefTrig_Src

int32 __CFUNC DAQmxGetDigEdgeRefTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeRefTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeRefTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeRefTrigSrc gets the Reference >> Digital Edge >> Source property.

DAQmxSetDigEdgeRefTrigSrc sets the Reference >> Digital Edge >> Source property.

DAQmxResetDigEdgeRefTrigSrc resets the Reference >> Digital Edge >> Source property.


Get/Set/Reset DigPattern_RefTrig_Src

int32 __CFUNC DAQmxGetDigPatternRefTrigSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternRefTrigSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternRefTrigSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternRefTrigSrc gets the Reference >> Digital Pattern >> Source property.

DAQmxSetDigPatternRefTrigSrc sets the Reference >> Digital Pattern >> Source property.

DAQmxResetDigPatternRefTrigSrc resets the Reference >> Digital Pattern >> Source property.


Get/Set/Reset DigPattern_RefTrig_When

int32 __CFUNC DAQmxGetDigPatternRefTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigPatternRefTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigPatternRefTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternRefTrigWhen gets the Reference >> Digital Pattern >> Trigger When property.

DAQmxSetDigPatternRefTrigWhen sets the Reference >> Digital Pattern >> Trigger When property.

DAQmxResetDigPatternRefTrigWhen resets the Reference >> Digital Pattern >> Trigger When property.


Get/Set/Reset RefTrig_PretrigSamples

int32 __CFUNC DAQmxGetRefTrigPretrigSamples(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetRefTrigPretrigSamples(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetRefTrigPretrigSamples(TaskHandle taskHandle);

Purpose

DAQmxGetRefTrigPretrigSamples gets the Reference >> Pretrigger Samples per Channel property.

DAQmxSetRefTrigPretrigSamples sets the Reference >> Pretrigger Samples per Channel property.

DAQmxResetRefTrigPretrigSamples resets the Reference >> Pretrigger Samples per Channel property.


Get/Set/Reset Write_RegenMode

int32 __CFUNC DAQmxGetWriteRegenMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetWriteRegenMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetWriteRegenMode(TaskHandle taskHandle);

Purpose

DAQmxGetWriteRegenMode gets the Regeneration Mode property.

DAQmxSetWriteRegenMode sets the Regeneration Mode property.

DAQmxResetWriteRegenMode resets the Regeneration Mode property.


Get/Set/Reset Write_CurrWritePos

int32 __CFUNC DAQmxGetWriteCurrWritePos(TaskHandle taskHandle, uInt64 *data);

Purpose

DAQmxGetWriteCurrWritePos gets the Status >> Current Write Position property.


Get/Set/Reset Write_SpaceAvail

int32 __CFUNC DAQmxGetWriteSpaceAvail(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetWriteSpaceAvail gets the Status >> Space Available in Buffer property.


Get/Set/Reset RefTrig_Delay

int32 __CFUNC DAQmxGetRefTrigDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetRefTrigDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetRefTrigDelay(TaskHandle taskHandle);

Purpose

DAQmxGetRefTrigDelay gets the Reference >> More >> Delay property.

DAQmxSetRefTrigDelay sets the Reference >> More >> Delay property.

DAQmxResetRefTrigDelay resets the Reference >> More >> Delay property.


Get/Set/Reset AO_OutputImpedance

int32 __CFUNC DAQmxGetAOOutputImpedance(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOOutputImpedance(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOOutputImpedance(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOOutputImpedance gets the Analog Output >> General Properties >> Output Configuration >> Output Impedance property.

DAQmxSetAOOutputImpedance sets the Analog Output >> General Properties >> Output Configuration >> Output Impedance property.

DAQmxResetAOOutputImpedance resets the Analog Output >> General Properties >> Output Configuration >> Output Impedance property.


Get/Set/Reset MasterTimebase_Rate

int32 __CFUNC DAQmxGetMasterTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetMasterTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetMasterTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetMasterTimebaseRate gets the More >> Master Timebase >> Rate property.

DAQmxSetMasterTimebaseRate sets the More >> Master Timebase >> Rate property.

DAQmxResetMasterTimebaseRate resets the More >> Master Timebase >> Rate property.


Get/Set/Reset AIConv_Src

int32 __CFUNC DAQmxGetAIConvSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIConvSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetAIConvSrc(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvSrc gets the More >> AI Convert >> Source property.

DAQmxSetAIConvSrc sets the More >> AI Convert >> Source property.

DAQmxResetAIConvSrc resets the More >> AI Convert >> Source property.


Get/Set/Reset AI_SoundPressure_Units

int32 __CFUNC DAQmxGetAISoundPressureUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAISoundPressureUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAISoundPressureUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAISoundPressureUnits gets the Analog Input >> Sound Pressure >> Units property.

DAQmxSetAISoundPressureUnits sets the Analog Input >> Sound Pressure >> Units property.

DAQmxResetAISoundPressureUnits resets the Analog Input >> Sound Pressure >> Units property.


Get/Set/Reset AI_Microphone_Sensitivity

int32 __CFUNC DAQmxGetAIMicrophoneSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIMicrophoneSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIMicrophoneSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIMicrophoneSensitivity gets the Analog Input >> Sound Pressure >> Microphone >> Sensitivity property.

DAQmxSetAIMicrophoneSensitivity sets the Analog Input >> Sound Pressure >> Microphone >> Sensitivity property.

DAQmxResetAIMicrophoneSensitivity resets the Analog Input >> Sound Pressure >> Microphone >> Sensitivity property.


Get/Set/Reset Exported_RdyForStartEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedRdyForStartEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedRdyForStartEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedRdyForStartEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForStartEventOutputTerm gets the Events >> Ready For Start Event >> Output Terminal property.

DAQmxSetExportedRdyForStartEventOutputTerm sets the Events >> Ready For Start Event >> Output Terminal property.

DAQmxResetExportedRdyForStartEventOutputTerm resets the Events >> Ready For Start Event >> Output Terminal property.


Get/Set/Reset Exported_PauseTrig_OutputTerm

int32 __CFUNC DAQmxGetExportedPauseTrigOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedPauseTrigOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedPauseTrigOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedPauseTrigOutputTerm gets the Triggers >> Pause Trigger >> Output Terminal property.

DAQmxSetExportedPauseTrigOutputTerm sets the Triggers >> Pause Trigger >> Output Terminal property.

DAQmxResetExportedPauseTrigOutputTerm resets the Triggers >> Pause Trigger >> Output Terminal property.


Get/Set/Reset Exported_PauseTrig_Lvl_ActiveLvl

int32 __CFUNC DAQmxGetExportedPauseTrigLvlActiveLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedPauseTrigLvlActiveLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedPauseTrigLvlActiveLvl(TaskHandle taskHandle);

Purpose

DAQmxGetExportedPauseTrigLvlActiveLvl gets the Triggers >> Pause Trigger >> Level >> Active Level property.

DAQmxSetExportedPauseTrigLvlActiveLvl sets the Triggers >> Pause Trigger >> Level >> Active Level property.

DAQmxResetExportedPauseTrigLvlActiveLvl resets the Triggers >> Pause Trigger >> Level >> Active Level property.


Get/Set/Reset Exported_DataActiveEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedDataActiveEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedDataActiveEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedDataActiveEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedDataActiveEventOutputTerm gets the Events >> Data Active Event >> Output Terminal property.

DAQmxSetExportedDataActiveEventOutputTerm sets the Events >> Data Active Event >> Output Terminal property.

DAQmxResetExportedDataActiveEventOutputTerm resets the Events >> Data Active Event >> Output Terminal property.


Get/Set/Reset Exported_DataActiveEvent_Lvl_ActiveLvl

int32 __CFUNC DAQmxGetExportedDataActiveEventLvlActiveLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedDataActiveEventLvlActiveLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedDataActiveEventLvlActiveLvl(TaskHandle taskHandle);

Purpose

DAQmxGetExportedDataActiveEventLvlActiveLvl gets the Events >> Data Active Event >> Level >> Active Level property.

DAQmxSetExportedDataActiveEventLvlActiveLvl sets the Events >> Data Active Event >> Level >> Active Level property.

DAQmxResetExportedDataActiveEventLvlActiveLvl resets the Events >> Data Active Event >> Level >> Active Level property.


Get/Set/Reset Exported_AdvTrig_OutputTerm

int32 __CFUNC DAQmxGetExportedAdvTrigOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedAdvTrigOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedAdvTrigOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvTrigOutputTerm gets the Triggers >> Advance Trigger >> Output Terminal property.

DAQmxSetExportedAdvTrigOutputTerm sets the Triggers >> Advance Trigger >> Output Terminal property.

DAQmxResetExportedAdvTrigOutputTerm resets the Triggers >> Advance Trigger >> Output Terminal property.


Get/Set/Reset Exported_AdvTrig_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedAdvTrigPulsePolarity(TaskHandle taskHandle, int32 *data);

Purpose

DAQmxGetExportedAdvTrigPulsePolarity gets the Triggers >> Advance Trigger >> Pulse >> Polarity property.


Get/Set/Reset Exported_AdvTrig_Pulse_WidthUnits

int32 __CFUNC DAQmxGetExportedAdvTrigPulseWidthUnits(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedAdvTrigPulseWidthUnits(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedAdvTrigPulseWidthUnits(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvTrigPulseWidthUnits gets the Triggers >> Advance Trigger >> Pulse >> Width Units property.

DAQmxSetExportedAdvTrigPulseWidthUnits sets the Triggers >> Advance Trigger >> Pulse >> Width Units property.

DAQmxResetExportedAdvTrigPulseWidthUnits resets the Triggers >> Advance Trigger >> Pulse >> Width Units property.


Get/Set/Reset Exported_AdvTrig_Pulse_Width

int32 __CFUNC DAQmxGetExportedAdvTrigPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedAdvTrigPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedAdvTrigPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvTrigPulseWidth gets the Triggers >> Advance Trigger >> Pulse >> Width Value property.

DAQmxSetExportedAdvTrigPulseWidth sets the Triggers >> Advance Trigger >> Pulse >> Width Value property.

DAQmxResetExportedAdvTrigPulseWidth resets the Triggers >> Advance Trigger >> Pulse >> Width Value property.


Get/Set/Reset Exported_AdvCmpltEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedAdvCmpltEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedAdvCmpltEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedAdvCmpltEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvCmpltEventOutputTerm gets the Events >> Advance Complete Event >> Output Terminal property.

DAQmxSetExportedAdvCmpltEventOutputTerm sets the Events >> Advance Complete Event >> Output Terminal property.

DAQmxResetExportedAdvCmpltEventOutputTerm resets the Events >> Advance Complete Event >> Output Terminal property.


Get/Set/Reset Exported_AdvCmpltEvent_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedAdvCmpltEventPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedAdvCmpltEventPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedAdvCmpltEventPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvCmpltEventPulsePolarity gets the Events >> Advance Complete Event >> Pulse >> Polarity property.

DAQmxSetExportedAdvCmpltEventPulsePolarity sets the Events >> Advance Complete Event >> Pulse >> Polarity property.

DAQmxResetExportedAdvCmpltEventPulsePolarity resets the Events >> Advance Complete Event >> Pulse >> Polarity property.


Get/Set/Reset Exported_AdvCmpltEvent_Pulse_Width

int32 __CFUNC DAQmxGetExportedAdvCmpltEventPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedAdvCmpltEventPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedAdvCmpltEventPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvCmpltEventPulseWidth gets the Events >> Advance Complete Event >> Pulse >> Width Value property.

DAQmxSetExportedAdvCmpltEventPulseWidth sets the Events >> Advance Complete Event >> Pulse >> Width Value property.

DAQmxResetExportedAdvCmpltEventPulseWidth resets the Events >> Advance Complete Event >> Pulse >> Width Value property.


Get/Set/Reset Exported_20MHzTimebase_OutputTerm

int32 __CFUNC DAQmxGetExported20MHzTimebaseOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExported20MHzTimebaseOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExported20MHzTimebaseOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExported20MHzTimebaseOutputTerm gets the Clocks >> 20MHz Timebase >> Output Terminal property.

DAQmxSetExported20MHzTimebaseOutputTerm sets the Clocks >> 20MHz Timebase >> Output Terminal property.

DAQmxResetExported20MHzTimebaseOutputTerm resets the Clocks >> 20MHz Timebase >> Output Terminal property.


Get/Set/Reset Exported_SampClk_OutputTerm

int32 __CFUNC DAQmxGetExportedSampClkOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedSampClkOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedSampClkOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSampClkOutputTerm gets the Clocks >> Sample Clock >> Output Terminal property.

DAQmxSetExportedSampClkOutputTerm sets the Clocks >> Sample Clock >> Output Terminal property.

DAQmxResetExportedSampClkOutputTerm resets the Clocks >> Sample Clock >> Output Terminal property.


Get/Set/Reset Exported_SampClk_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedSampClkPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedSampClkPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedSampClkPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedSampClkPulsePolarity gets the Clocks >> Sample Clock >> Pulse >> Polarity property.

DAQmxSetExportedSampClkPulsePolarity sets the Clocks >> Sample Clock >> Pulse >> Polarity property.

DAQmxResetExportedSampClkPulsePolarity resets the Clocks >> Sample Clock >> Pulse >> Polarity property.


Get/Set/Reset Exported_AIConvClk_OutputTerm

int32 __CFUNC DAQmxGetExportedAIConvClkOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedAIConvClkOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedAIConvClkOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAIConvClkOutputTerm gets the Clocks >> AI Convert Clock >> Output Terminal property.

DAQmxSetExportedAIConvClkOutputTerm sets the Clocks >> AI Convert Clock >> Output Terminal property.

DAQmxResetExportedAIConvClkOutputTerm resets the Clocks >> AI Convert Clock >> Output Terminal property.


Get/Set/Reset Exported_AIConvClk_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedAIConvClkPulsePolarity(TaskHandle taskHandle, int32 *data);

Purpose

DAQmxGetExportedAIConvClkPulsePolarity gets the Clocks >> AI Convert Clock >> Pulse >> Polarity property.


Get/Set/Reset Exported_CtrOutEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedCtrOutEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedCtrOutEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedCtrOutEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedCtrOutEventOutputTerm gets the Events >> Counter Output Event >> Output Terminal property.

DAQmxSetExportedCtrOutEventOutputTerm sets the Events >> Counter Output Event >> Output Terminal property.

DAQmxResetExportedCtrOutEventOutputTerm resets the Events >> Counter Output Event >> Output Terminal property.


Get/Set/Reset Exported_CtrOutEvent_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedCtrOutEventPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedCtrOutEventPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedCtrOutEventPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedCtrOutEventPulsePolarity gets the Events >> Counter Output Event >> Pulse >> Polarity property.

DAQmxSetExportedCtrOutEventPulsePolarity sets the Events >> Counter Output Event >> Pulse >> Polarity property.

DAQmxResetExportedCtrOutEventPulsePolarity resets the Events >> Counter Output Event >> Pulse >> Polarity property.


Get/Set/Reset Exported_RdyForStartEvent_Lvl_ActiveLvl

int32 __CFUNC DAQmxGetExportedRdyForStartEventLvlActiveLvl(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedRdyForStartEventLvlActiveLvl(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedRdyForStartEventLvlActiveLvl(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForStartEventLvlActiveLvl gets the Events >> Ready For Start Event >> Level >> Active Level property.

DAQmxSetExportedRdyForStartEventLvlActiveLvl sets the Events >> Ready For Start Event >> Level >> Active Level property.

DAQmxResetExportedRdyForStartEventLvlActiveLvl resets the Events >> Ready For Start Event >> Level >> Active Level property.


Get/Set/Reset Exported_AdvCmpltEvent_Delay

int32 __CFUNC DAQmxGetExportedAdvCmpltEventDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetExportedAdvCmpltEventDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetExportedAdvCmpltEventDelay(TaskHandle taskHandle);

Purpose

DAQmxGetExportedAdvCmpltEventDelay gets the Events >> Advance Complete Event >> Delay Value property.

DAQmxSetExportedAdvCmpltEventDelay sets the Events >> Advance Complete Event >> Delay Value property.

DAQmxResetExportedAdvCmpltEventDelay resets the Events >> Advance Complete Event >> Delay Value property.


Get/Set/Reset AI_AutoZeroMode

int32 __CFUNC DAQmxGetAIAutoZeroMode(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIAutoZeroMode(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIAutoZeroMode(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAutoZeroMode gets the Analog Input >> General Properties >> Advanced >> High Accuracy Settings >> Auto Zero Mode property.

DAQmxSetAIAutoZeroMode sets the Analog Input >> General Properties >> Advanced >> High Accuracy Settings >> Auto Zero Mode property.

DAQmxResetAIAutoZeroMode resets the Analog Input >> General Properties >> Advanced >> High Accuracy Settings >> Auto Zero Mode property.


Get/Set/Reset AI_ResolutionUnits

int32 __CFUNC DAQmxGetAIResolutionUnits(TaskHandle taskHandle, const char channel[], int32 *data);

Purpose

DAQmxGetAIResolutionUnits gets the Analog Input >> General Properties >> Digitizer/ADC >> Resolution Units property.


Get/Set/Reset AI_Resolution

int32 __CFUNC DAQmxGetAIResolution(TaskHandle taskHandle, const char channel[], float64 *data);

Purpose

DAQmxGetAIResolution gets the Analog Input >> General Properties >> Digitizer/ADC >> Resolution Value property.


Get/Set/Reset AI_Atten

int32 __CFUNC DAQmxGetAIAtten(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIAtten(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIAtten(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAtten gets the Analog Input >> General Properties >> Signal Conditioning >> Attenuation property.

DAQmxSetAIAtten sets the Analog Input >> General Properties >> Signal Conditioning >> Attenuation property.

DAQmxResetAIAtten resets the Analog Input >> General Properties >> Signal Conditioning >> Attenuation property.


Get/Set/Reset AI_Lowpass_Enable

int32 __CFUNC DAQmxGetAILowpassEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAILowpassEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAILowpassEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassEnable gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Enable property.

DAQmxSetAILowpassEnable sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Enable property.

DAQmxResetAILowpassEnable resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Enable property.


Get/Set/Reset AI_Lowpass_CutoffFreq

int32 __CFUNC DAQmxGetAILowpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAILowpassCutoffFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAILowpassCutoffFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassCutoffFreq gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Cutoff Frequency property.

DAQmxSetAILowpassCutoffFreq sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Cutoff Frequency property.

DAQmxResetAILowpassCutoffFreq resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Cutoff Frequency property.


Get/Set/Reset AI_Rng_High

int32 __CFUNC DAQmxGetAIRngHigh(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRngHigh(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRngHigh(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRngHigh gets the Analog Input >> General Properties >> Advanced >> Range >> High property.

DAQmxSetAIRngHigh sets the Analog Input >> General Properties >> Advanced >> Range >> High property.

DAQmxResetAIRngHigh resets the Analog Input >> General Properties >> Advanced >> Range >> High property.


Get/Set/Reset AI_Rng_Low

int32 __CFUNC DAQmxGetAIRngLow(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIRngLow(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIRngLow(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIRngLow gets the Analog Input >> General Properties >> Advanced >> Range >> Low property.

DAQmxSetAIRngLow sets the Analog Input >> General Properties >> Advanced >> Range >> Low property.

DAQmxResetAIRngLow resets the Analog Input >> General Properties >> Advanced >> Range >> Low property.


Get/Set/Reset AI_Gain

int32 __CFUNC DAQmxGetAIGain(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIGain(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIGain(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIGain gets the Analog Input >> General Properties >> Advanced >> Gain property.

DAQmxSetAIGain sets the Analog Input >> General Properties >> Advanced >> Gain property.

DAQmxResetAIGain resets the Analog Input >> General Properties >> Advanced >> Gain property.


Get/Set/Reset AI_DataXferMech

int32 __CFUNC DAQmxGetAIDataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIDataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIDataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIDataXferMech gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetAIDataXferMech sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetAIDataXferMech resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset Read_ChannelsToRead

int32 __CFUNC DAQmxGetReadChannelsToRead(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetReadChannelsToRead(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetReadChannelsToRead(TaskHandle taskHandle);

Purpose

DAQmxGetReadChannelsToRead gets the Channels to Read property.

DAQmxSetReadChannelsToRead sets the Channels to Read property.

DAQmxResetReadChannelsToRead resets the Channels to Read property.


Get/Set/Reset Read_AutoStart

int32 __CFUNC DAQmxGetReadAutoStart(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetReadAutoStart(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetReadAutoStart(TaskHandle taskHandle);

Purpose

DAQmxGetReadAutoStart gets the Auto Start property.

DAQmxSetReadAutoStart sets the Auto Start property.

DAQmxResetReadAutoStart resets the Auto Start property.


Get/Set/Reset AO_DAC_Ref_AllowConnToGnd

int32 __CFUNC DAQmxGetAODACRefAllowConnToGnd(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAODACRefAllowConnToGnd(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAODACRefAllowConnToGnd(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRefAllowConnToGnd gets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Allow Connecting DAC Reference to Ground at Runtime property.

DAQmxSetAODACRefAllowConnToGnd sets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Allow Connecting DAC Reference to Ground at Runtime property.

DAQmxResetAODACRefAllowConnToGnd resets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Allow Connecting DAC Reference to Ground at Runtime property.


Get/Set/Reset AO_DAC_Ref_Val

int32 __CFUNC DAQmxGetAODACRefVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAODACRefVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAODACRefVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRefVal gets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Value property.

DAQmxSetAODACRefVal sets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Value property.

DAQmxResetAODACRefVal resets the Analog Output >> General Properties >> DAC >> Reference Voltage >> Value property.


Get/Set/Reset AIConv_Rate

int32 __CFUNC DAQmxGetAIConvRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetAIConvRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetAIConvRate(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvRate gets the More >> AI Convert >> Rate property.

DAQmxSetAIConvRate sets the More >> AI Convert >> Rate property.

DAQmxResetAIConvRate resets the More >> AI Convert >> Rate property.


Get/Set/Reset SampClk_Src

int32 __CFUNC DAQmxGetSampClkSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetSampClkSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetSampClkSrc(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkSrc gets the Sample Clock >> Source property.

DAQmxSetSampClkSrc sets the Sample Clock >> Source property.

DAQmxResetSampClkSrc resets the Sample Clock >> Source property.


Get/Set/Reset AIConv_ActiveEdge

int32 __CFUNC DAQmxGetAIConvActiveEdge(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAIConvActiveEdge(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAIConvActiveEdge(TaskHandle taskHandle);

Purpose

DAQmxGetAIConvActiveEdge gets the More >> AI Convert >> Active Edge property.

DAQmxSetAIConvActiveEdge sets the More >> AI Convert >> Active Edge property.

DAQmxResetAIConvActiveEdge resets the More >> AI Convert >> Active Edge property.


Get/Set/Reset StartTrig_Delay

int32 __CFUNC DAQmxGetStartTrigDelay(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetStartTrigDelay(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetStartTrigDelay(TaskHandle taskHandle);

Purpose

DAQmxGetStartTrigDelay gets the Start >> More >> Delay property.

DAQmxSetStartTrigDelay sets the Start >> More >> Delay property.

DAQmxResetStartTrigDelay resets the Start >> More >> Delay property.


Get/Set/Reset AnlgWin_RefTrig_Coupling

int32 __CFUNC DAQmxGetAnlgWinRefTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinRefTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinRefTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinRefTrigCoupling gets the Reference >> Analog Window >> Coupling property.

DAQmxSetAnlgWinRefTrigCoupling sets the Reference >> Analog Window >> Coupling property.

DAQmxResetAnlgWinRefTrigCoupling resets the Reference >> Analog Window >> Coupling property.


Get/Set/Reset SelfCal_Supported

int32 __CFUNC DAQmxGetSelfCalSupported(const char deviceName[], bool32 *data);

Purpose

DAQmxGetSelfCalSupported gets the Self Calibration >> Is Supported property.


Get/Set/Reset Cal_UserDefinedInfo

int32 __CFUNC DAQmxGetCalUserDefinedInfo(const char deviceName[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCalUserDefinedInfo(const char deviceName[], const char *data);

Purpose

DAQmxGetCalUserDefinedInfo gets the User-Defined Information >> Information property.

DAQmxSetCalUserDefinedInfo sets the User-Defined Information >> Information property.


Get/Set/Reset SelfCal_LastTemp

int32 __CFUNC DAQmxGetSelfCalLastTemp(const char deviceName[], float64 *data);

Purpose

DAQmxGetSelfCalLastTemp gets the Self Calibration >> Last Self Calibration Temperature property.


Get/Set/Reset ExtCal_LastTemp

int32 __CFUNC DAQmxGetExtCalLastTemp(const char deviceName[], float64 *data);

Purpose

DAQmxGetExtCalLastTemp gets the External Calibration >> Last External Calibration Temperature property.


Get/Set/Reset ExtCal_RecommendedInterval

int32 __CFUNC DAQmxGetExtCalRecommendedInterval(const char deviceName[], uInt32 *data);

Purpose

DAQmxGetExtCalRecommendedInterval gets the External Calibration >> Recommended Interval property.


Get/Set/Reset AI_ResistanceCfg

int32 __CFUNC DAQmxGetAIResistanceCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIResistanceCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIResistanceCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIResistanceCfg gets the Analog Input >> General Properties >> Signal Conditioning >> Resistance Configuration property.

DAQmxSetAIResistanceCfg sets the Analog Input >> General Properties >> Signal Conditioning >> Resistance Configuration property.

DAQmxResetAIResistanceCfg resets the Analog Input >> General Properties >> Signal Conditioning >> Resistance Configuration property.


Get/Set/Reset AI_Excit_ActualVal

int32 __CFUNC DAQmxGetAIExcitActualVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIExcitActualVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIExcitActualVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitActualVal gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Actual Excitation Value property.

DAQmxSetAIExcitActualVal sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Actual Excitation Value property.

DAQmxResetAIExcitActualVal resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Actual Excitation Value property.


Get/Set/Reset AI_Lowpass_SwitchCap_ClkSrc

int32 __CFUNC DAQmxGetAILowpassSwitchCapClkSrc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAILowpassSwitchCapClkSrc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAILowpassSwitchCapClkSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassSwitchCapClkSrc gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Clock Source property.

DAQmxSetAILowpassSwitchCapClkSrc sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Clock Source property.

DAQmxResetAILowpassSwitchCapClkSrc resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Clock Source property.


Get/Set/Reset AI_Lowpass_SwitchCap_ExtClkFreq

int32 __CFUNC DAQmxGetAILowpassSwitchCapExtClkFreq(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAILowpassSwitchCapExtClkFreq(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAILowpassSwitchCapExtClkFreq(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassSwitchCapExtClkFreq gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Frequency property.

DAQmxSetAILowpassSwitchCapExtClkFreq sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Frequency property.

DAQmxResetAILowpassSwitchCapExtClkFreq resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Frequency property.


Get/Set/Reset AI_Lowpass_SwitchCap_ExtClkDiv

int32 __CFUNC DAQmxGetAILowpassSwitchCapExtClkDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAILowpassSwitchCapExtClkDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAILowpassSwitchCapExtClkDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassSwitchCapExtClkDiv gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Divisor property.

DAQmxSetAILowpassSwitchCapExtClkDiv sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Divisor property.

DAQmxResetAILowpassSwitchCapExtClkDiv resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> External Clock Divisor property.


Get/Set/Reset AI_Lowpass_SwitchCap_OutClkDiv

int32 __CFUNC DAQmxGetAILowpassSwitchCapOutClkDiv(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAILowpassSwitchCapOutClkDiv(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAILowpassSwitchCapOutClkDiv(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAILowpassSwitchCapOutClkDiv gets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Output Clock Divisor property.

DAQmxSetAILowpassSwitchCapOutClkDiv sets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Output Clock Divisor property.

DAQmxResetAILowpassSwitchCapOutClkDiv resets the Analog Input >> General Properties >> Filter >> Analog Filter >> Lowpass >> Advanced >> Switched Capacitor >> Output Clock Divisor property.


Get/Set/Reset DI_Tristate

int32 __CFUNC DAQmxGetDITristate(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDITristate(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDITristate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDITristate gets the Digital Input >> Tristate property.

DAQmxSetDITristate sets the Digital Input >> Tristate property.

DAQmxResetDITristate resets the Digital Input >> Tristate property.


Get/Set/Reset Sys_NIDAQMinorVersion

int32 __CFUNC DAQmxGetSysNIDAQMinorVersion(uInt32 *data);

Purpose

DAQmxGetSysNIDAQMinorVersion gets the System >> NI-DAQ Version >> Minor property.


Get/Set/Reset ChanDescr

int32 __CFUNC DAQmxGetChanDescr(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetChanDescr(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetChanDescr(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetChanDescr gets the General Properties >> Description property.

DAQmxSetChanDescr sets the General Properties >> Description property.

DAQmxResetChanDescr resets the General Properties >> Description property.


Get/Set/Reset Scale_Type

int32 __CFUNC DAQmxGetScaleType(const char scaleName[], int32 *data);

Purpose

DAQmxGetScaleType gets the Scale Type property.


Get/Set/Reset AI_DevScalingCoeff

int32 __CFUNC DAQmxGetAIDevScalingCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetAIDevScalingCoeff gets the Analog Input >> General Properties >> Advanced >> Device Scaling Coefficients >> Device Scaling Coefficients property.


Get/Set/Reset AO_DevScalingCoeff

int32 __CFUNC DAQmxGetAODevScalingCoeff(TaskHandle taskHandle, const char channel[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetAODevScalingCoeff gets the Analog Output >> General Properties >> Advanced >> Device Scaling Coefficients >> Device Scaling Coefficients property.


Get/Set/Reset DigPattern_PauseTrig_When

int32 __CFUNC DAQmxGetDigPatternPauseTrigWhen(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetDigPatternPauseTrigWhen(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetDigPatternPauseTrigWhen(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternPauseTrigWhen gets the More >> Pause >> Digital Pattern >> Pause When property.

DAQmxSetDigPatternPauseTrigWhen sets the More >> Pause >> Digital Pattern >> Pause When property.

DAQmxResetDigPatternPauseTrigWhen resets the More >> Pause >> Digital Pattern >> Pause When property.


Get/Set/Reset Read_OverloadedChansExist

int32 __CFUNC DAQmxGetReadOverloadedChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOverloadedChansExist gets the Status >> Overload >> Overloaded Channels Exist property.


Get/Set/Reset Read_OverloadedChans

int32 __CFUNC DAQmxGetReadOverloadedChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOverloadedChans gets the Status >> Overload >> Overloaded Channels property.


Get/Set/Reset DI_NumLines

int32 __CFUNC DAQmxGetDINumLines(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetDINumLines gets the Digital Input >> Number of Lines property.


Get/Set/Reset DO_NumLines

int32 __CFUNC DAQmxGetDONumLines(TaskHandle taskHandle, const char channel[], uInt32 *data);

Purpose

DAQmxGetDONumLines gets the Digital Output >> Number of Lines property.


Get/Set/Reset AI_Excit_UseMultiplexed

int32 __CFUNC DAQmxGetAIExcitUseMultiplexed(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIExcitUseMultiplexed(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIExcitUseMultiplexed(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIExcitUseMultiplexed gets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Multiplexed Excitation property.

DAQmxSetAIExcitUseMultiplexed sets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Multiplexed Excitation property.

DAQmxResetAIExcitUseMultiplexed resets the Analog Input >> General Properties >> Signal Conditioning >> Excitation >> Advanced >> Use Multiplexed Excitation property.


Get/Set/Reset Task_NumChans

int32 __CFUNC DAQmxGetTaskNumChans(TaskHandle taskHandle, uInt32 *data);

Purpose

DAQmxGetTaskNumChans gets the Number of Channels property.


Get/Set/Reset DigPattern_StartTrig_Pattern

int32 __CFUNC DAQmxGetDigPatternStartTrigPattern(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternStartTrigPattern(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternStartTrigPattern(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternStartTrigPattern gets the Start >> Digital Pattern >> Pattern property.

DAQmxSetDigPatternStartTrigPattern sets the Start >> Digital Pattern >> Pattern property.

DAQmxResetDigPatternStartTrigPattern resets the Start >> Digital Pattern >> Pattern property.


Get/Set/Reset DigPattern_RefTrig_Pattern

int32 __CFUNC DAQmxGetDigPatternRefTrigPattern(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternRefTrigPattern(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternRefTrigPattern(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternRefTrigPattern gets the Reference >> Digital Pattern >> Pattern property.

DAQmxSetDigPatternRefTrigPattern sets the Reference >> Digital Pattern >> Pattern property.

DAQmxResetDigPatternRefTrigPattern resets the Reference >> Digital Pattern >> Pattern property.


Get/Set/Reset DigPattern_PauseTrig_Pattern

int32 __CFUNC DAQmxGetDigPatternPauseTrigPattern(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigPatternPauseTrigPattern(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigPatternPauseTrigPattern(TaskHandle taskHandle);

Purpose

DAQmxGetDigPatternPauseTrigPattern gets the More >> Pause >> Digital Pattern >> Pattern property.

DAQmxSetDigPatternPauseTrigPattern sets the More >> Pause >> Digital Pattern >> Pattern property.

DAQmxResetDigPatternPauseTrigPattern resets the More >> Pause >> Digital Pattern >> Pattern property.


Get/Set/Reset Read_ChangeDetect_HasOverflowed

int32 __CFUNC DAQmxGetReadChangeDetectHasOverflowed(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadChangeDetectHasOverflowed gets the Status >> Advanced >> ChangeDetection >> Overflowed property.


Get/Set/Reset ChangeDetect_DI_RisingEdgePhysicalChans

int32 __CFUNC DAQmxGetChangeDetectDIRisingEdgePhysicalChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetChangeDetectDIRisingEdgePhysicalChans(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetChangeDetectDIRisingEdgePhysicalChans(TaskHandle taskHandle);

Purpose

DAQmxGetChangeDetectDIRisingEdgePhysicalChans gets the Change Detection >> Digital Input >> Rising Edge Physical Channels property.

DAQmxSetChangeDetectDIRisingEdgePhysicalChans sets the Change Detection >> Digital Input >> Rising Edge Physical Channels property.

DAQmxResetChangeDetectDIRisingEdgePhysicalChans resets the Change Detection >> Digital Input >> Rising Edge Physical Channels property.


Get/Set/Reset ChangeDetect_DI_FallingEdgePhysicalChans

int32 __CFUNC DAQmxGetChangeDetectDIFallingEdgePhysicalChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetChangeDetectDIFallingEdgePhysicalChans(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetChangeDetectDIFallingEdgePhysicalChans(TaskHandle taskHandle);

Purpose

DAQmxGetChangeDetectDIFallingEdgePhysicalChans gets the Change Detection >> Digital Input >> Falling Edge Physical Channels property.

DAQmxSetChangeDetectDIFallingEdgePhysicalChans sets the Change Detection >> Digital Input >> Falling Edge Physical Channels property.

DAQmxResetChangeDetectDIFallingEdgePhysicalChans resets the Change Detection >> Digital Input >> Falling Edge Physical Channels property.


Get/Set/Reset Exported_ChangeDetectEvent_OutputTerm

int32 __CFUNC DAQmxGetExportedChangeDetectEventOutputTerm(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetExportedChangeDetectEventOutputTerm(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetExportedChangeDetectEventOutputTerm(TaskHandle taskHandle);

Purpose

DAQmxGetExportedChangeDetectEventOutputTerm gets the Events >> Change Detection Event >> Output Terminal property.

DAQmxSetExportedChangeDetectEventOutputTerm sets the Events >> Change Detection Event >> Output Terminal property.

DAQmxResetExportedChangeDetectEventOutputTerm resets the Events >> Change Detection Event >> Output Terminal property.


Get/Set/Reset AI_InputSrc

int32 __CFUNC DAQmxGetAIInputSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIInputSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAIInputSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIInputSrc gets the Analog Input >> General Properties >> Input Configuration >> Input Source property.

DAQmxSetAIInputSrc sets the Analog Input >> General Properties >> Input Configuration >> Input Source property.

DAQmxResetAIInputSrc resets the Analog Input >> General Properties >> Input Configuration >> Input Source property.


Get/Set/Reset CI_Encoder_BInput_DigFltr_Enable

int32 __CFUNC DAQmxGetCIEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderBInputDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputDigFltrEnable gets the Counter Input >> Position >> B Input >> Digital Filter >> Enable property.

DAQmxSetCIEncoderBInputDigFltrEnable sets the Counter Input >> Position >> B Input >> Digital Filter >> Enable property.

DAQmxResetCIEncoderBInputDigFltrEnable resets the Counter Input >> Position >> B Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Encoder_BInput_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderBInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputDigFltrMinPulseWidth gets the Counter Input >> Position >> B Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIEncoderBInputDigFltrMinPulseWidth sets the Counter Input >> Position >> B Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIEncoderBInputDigFltrMinPulseWidth resets the Counter Input >> Position >> B Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Encoder_BInput_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderBInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputDigFltrTimebaseSrc gets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIEncoderBInputDigFltrTimebaseSrc sets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIEncoderBInputDigFltrTimebaseSrc resets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Encoder_BInput_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderBInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputDigFltrTimebaseRate gets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIEncoderBInputDigFltrTimebaseRate sets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIEncoderBInputDigFltrTimebaseRate resets the Counter Input >> Position >> B Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Encoder_BInput_DigSync_Enable

int32 __CFUNC DAQmxGetCIEncoderBInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderBInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderBInputDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderBInputDigSyncEnable gets the Counter Input >> Position >> B Input >> Digital Synchronization >> Enable property.

DAQmxSetCIEncoderBInputDigSyncEnable sets the Counter Input >> Position >> B Input >> Digital Synchronization >> Enable property.

DAQmxResetCIEncoderBInputDigSyncEnable resets the Counter Input >> Position >> B Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_Encoder_ZInput_DigFltr_Enable

int32 __CFUNC DAQmxGetCIEncoderZInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderZInputDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputDigFltrEnable gets the Counter Input >> Position >> Z Input >> Digital Filter >> Enable property.

DAQmxSetCIEncoderZInputDigFltrEnable sets the Counter Input >> Position >> Z Input >> Digital Filter >> Enable property.

DAQmxResetCIEncoderZInputDigFltrEnable resets the Counter Input >> Position >> Z Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_Encoder_ZInput_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCIEncoderZInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderZInputDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputDigFltrMinPulseWidth gets the Counter Input >> Position >> Z Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCIEncoderZInputDigFltrMinPulseWidth sets the Counter Input >> Position >> Z Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCIEncoderZInputDigFltrMinPulseWidth resets the Counter Input >> Position >> Z Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_Encoder_ZInput_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIEncoderZInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIEncoderZInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIEncoderZInputDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputDigFltrTimebaseSrc gets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIEncoderZInputDigFltrTimebaseSrc sets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIEncoderZInputDigFltrTimebaseSrc resets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_Encoder_ZInput_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIEncoderZInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIEncoderZInputDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputDigFltrTimebaseRate gets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIEncoderZInputDigFltrTimebaseRate sets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIEncoderZInputDigFltrTimebaseRate resets the Counter Input >> Position >> Z Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_Encoder_ZInput_DigSync_Enable

int32 __CFUNC DAQmxGetCIEncoderZInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCIEncoderZInputDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCIEncoderZInputDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIEncoderZInputDigSyncEnable gets the Counter Input >> Position >> Z Input >> Digital Synchronization >> Enable property.

DAQmxSetCIEncoderZInputDigSyncEnable sets the Counter Input >> Position >> Z Input >> Digital Synchronization >> Enable property.

DAQmxResetCIEncoderZInputDigSyncEnable resets the Counter Input >> Position >> Z Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_TwoEdgeSep_First_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstDigFltrMinPulseWidth gets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCITwoEdgeSepFirstDigFltrMinPulseWidth sets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCITwoEdgeSepFirstDigFltrMinPulseWidth resets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_TwoEdgeSep_First_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseSrc gets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseSrc sets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseSrc resets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_TwoEdgeSep_First_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstDigFltrTimebaseRate gets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCITwoEdgeSepFirstDigFltrTimebaseRate sets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCITwoEdgeSepFirstDigFltrTimebaseRate resets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_TwoEdgeSep_First_DigSync_Enable

int32 __CFUNC DAQmxGetCITwoEdgeSepFirstDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepFirstDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepFirstDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepFirstDigSyncEnable gets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCITwoEdgeSepFirstDigSyncEnable sets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCITwoEdgeSepFirstDigSyncEnable resets the Counter Input >> Two Edge Separation >> First >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_TwoEdgeSep_Second_DigFltr_Enable

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondDigFltrEnable gets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Enable property.

DAQmxSetCITwoEdgeSepSecondDigFltrEnable sets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Enable property.

DAQmxResetCITwoEdgeSepSecondDigFltrEnable resets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Enable property.


Get/Set/Reset CI_TwoEdgeSep_Second_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondDigFltrMinPulseWidth gets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCITwoEdgeSepSecondDigFltrMinPulseWidth sets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCITwoEdgeSepSecondDigFltrMinPulseWidth resets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_TwoEdgeSep_Second_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseSrc gets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseSrc sets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseSrc resets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_TwoEdgeSep_Second_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondDigFltrTimebaseRate gets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCITwoEdgeSepSecondDigFltrTimebaseRate sets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCITwoEdgeSepSecondDigFltrTimebaseRate resets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_TwoEdgeSep_Second_DigSync_Enable

int32 __CFUNC DAQmxGetCITwoEdgeSepSecondDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCITwoEdgeSepSecondDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCITwoEdgeSepSecondDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCITwoEdgeSepSecondDigSyncEnable gets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Synchronization >> Enable property.

DAQmxSetCITwoEdgeSepSecondDigSyncEnable sets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Synchronization >> Enable property.

DAQmxResetCITwoEdgeSepSecondDigSyncEnable resets the Counter Input >> Two Edge Separation >> Second >> Input >> Digital Synchronization >> Enable property.


Get/Set/Reset CI_SemiPeriod_DigFltr_Enable

int32 __CFUNC DAQmxGetCISemiPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCISemiPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCISemiPeriodDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISemiPeriodDigFltrEnable gets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Enable property.

DAQmxSetCISemiPeriodDigFltrEnable sets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Enable property.

DAQmxResetCISemiPeriodDigFltrEnable resets the Counter Input >> Semi-Period >> Input >> Digital Filter >> Enable property.


Get/Set/Reset SampClk_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetSampClkDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetSampClkDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetSampClkDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkDigFltrTimebaseSrc gets the Sample Clock >> Digital Filter >> Timebase >> Source property.

DAQmxSetSampClkDigFltrTimebaseSrc sets the Sample Clock >> Digital Filter >> Timebase >> Source property.

DAQmxResetSampClkDigFltrTimebaseSrc resets the Sample Clock >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset SampClk_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetSampClkDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetSampClkDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetSampClkDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkDigFltrTimebaseRate gets the Sample Clock >> Digital Filter >> Timebase >> Rate property.

DAQmxSetSampClkDigFltrTimebaseRate sets the Sample Clock >> Digital Filter >> Timebase >> Rate property.

DAQmxResetSampClkDigFltrTimebaseRate resets the Sample Clock >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset SampClk_DigSync_Enable

int32 __CFUNC DAQmxGetSampClkDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetSampClkDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetSampClkDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkDigSyncEnable gets the Sample Clock >> Digital Synchronization >> Enable property.

DAQmxSetSampClkDigSyncEnable sets the Sample Clock >> Digital Synchronization >> Enable property.

DAQmxResetSampClkDigSyncEnable resets the Sample Clock >> Digital Synchronization >> Enable property.


Get/Set/Reset DigEdge_StartTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetDigEdgeStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeStartTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigDigFltrEnable gets the Start >> Digital Edge >> Digital Filter >> Enable property.

DAQmxSetDigEdgeStartTrigDigFltrEnable sets the Start >> Digital Edge >> Digital Filter >> Enable property.

DAQmxResetDigEdgeStartTrigDigFltrEnable resets the Start >> Digital Edge >> Digital Filter >> Enable property.


Get/Set/Reset DigEdge_StartTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetDigEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigDigFltrMinPulseWidth gets the Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetDigEdgeStartTrigDigFltrMinPulseWidth sets the Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetDigEdgeStartTrigDigFltrMinPulseWidth resets the Start >> Digital Edge >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset DigEdge_StartTrig_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetDigEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetDigEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle, const char *data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigDigFltrTimebaseSrc(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigDigFltrTimebaseSrc gets the Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxSetDigEdgeStartTrigDigFltrTimebaseSrc sets the Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.

DAQmxResetDigEdgeStartTrigDigFltrTimebaseSrc resets the Start >> Digital Edge >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset DigEdge_StartTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetDigEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigDigFltrTimebaseRate gets the Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxSetDigEdgeStartTrigDigFltrTimebaseRate sets the Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxResetDigEdgeStartTrigDigFltrTimebaseRate resets the Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset DigEdge_StartTrig_DigSync_Enable

int32 __CFUNC DAQmxGetDigEdgeStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeStartTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeStartTrigDigSyncEnable gets the Start >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxSetDigEdgeStartTrigDigSyncEnable sets the Start >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxResetDigEdgeStartTrigDigSyncEnable resets the Start >> Digital Edge >> Digital Synchronization >> Enable property.


Get/Set/Reset DigLvl_PauseTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetDigLvlPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigLvlPauseTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigDigFltrEnable gets the More >> Pause >> Digital Level >> Digital Filter >> Enable property.

DAQmxSetDigLvlPauseTrigDigFltrEnable sets the More >> Pause >> Digital Level >> Digital Filter >> Enable property.

DAQmxResetDigLvlPauseTrigDigFltrEnable resets the More >> Pause >> Digital Level >> Digital Filter >> Enable property.


Get/Set/Reset DigLvl_PauseTrig_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetDigLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigLvlPauseTrigDigFltrMinPulseWidth(TaskHandle taskHandle);

Purpose

DAQmxGetDigLvlPauseTrigDigFltrMinPulseWidth gets the More >> Pause >> Digital Level >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetDigLvlPauseTrigDigFltrMinPulseWidth sets the More >> Pause >> Digital Level >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetDigLvlPauseTrigDigFltrMinPulseWidth resets the More >> Pause >> Digital Level >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset DigEdge_ArmStartTrig_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 *data);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseRate(TaskHandle taskHandle, float64 data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseRate(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigDigFltrTimebaseRate gets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxSetDigEdgeArmStartTrigDigFltrTimebaseRate sets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.

DAQmxResetDigEdgeArmStartTrigDigFltrTimebaseRate resets the More >> Arm Start >> Digital Edge >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset DigEdge_ArmStartTrig_DigSync_Enable

int32 __CFUNC DAQmxGetDigEdgeArmStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeArmStartTrigDigSyncEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeArmStartTrigDigSyncEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeArmStartTrigDigSyncEnable gets the More >> Arm Start >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxSetDigEdgeArmStartTrigDigSyncEnable sets the More >> Arm Start >> Digital Edge >> Digital Synchronization >> Enable property.

DAQmxResetDigEdgeArmStartTrigDigSyncEnable resets the More >> Arm Start >> Digital Edge >> Digital Synchronization >> Enable property.


Get/Set/Reset Read_WaitMode

int32 __CFUNC DAQmxGetReadWaitMode(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetReadWaitMode(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetReadWaitMode(TaskHandle taskHandle);

Purpose

DAQmxGetReadWaitMode gets the Advanced >> Wait Mode property.

DAQmxSetReadWaitMode sets the Advanced >> Wait Mode property.

DAQmxResetReadWaitMode resets the Advanced >> Wait Mode property.


Get/Set/Reset AnlgEdge_StartTrig_Coupling

int32 __CFUNC DAQmxGetAnlgEdgeStartTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeStartTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgEdgeStartTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeStartTrigCoupling gets the Start >> Analog Edge >> Coupling property.

DAQmxSetAnlgEdgeStartTrigCoupling sets the Start >> Analog Edge >> Coupling property.

DAQmxResetAnlgEdgeStartTrigCoupling resets the Start >> Analog Edge >> Coupling property.


Get/Set/Reset AnlgWin_StartTrig_Coupling

int32 __CFUNC DAQmxGetAnlgWinStartTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinStartTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinStartTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinStartTrigCoupling gets the Start >> Analog Window >> Coupling property.

DAQmxSetAnlgWinStartTrigCoupling sets the Start >> Analog Window >> Coupling property.

DAQmxResetAnlgWinStartTrigCoupling resets the Start >> Analog Window >> Coupling property.


Get/Set/Reset AnlgEdge_RefTrig_Coupling

int32 __CFUNC DAQmxGetAnlgEdgeRefTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgEdgeRefTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgEdgeRefTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgEdgeRefTrigCoupling gets the Reference >> Analog Edge >> Coupling property.

DAQmxSetAnlgEdgeRefTrigCoupling sets the Reference >> Analog Edge >> Coupling property.

DAQmxResetAnlgEdgeRefTrigCoupling resets the Reference >> Analog Edge >> Coupling property.


Get/Set/Reset AnlgLvl_PauseTrig_Coupling

int32 __CFUNC DAQmxGetAnlgLvlPauseTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgLvlPauseTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgLvlPauseTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgLvlPauseTrigCoupling gets the More >> Pause >> Analog Level >> Coupling property.

DAQmxSetAnlgLvlPauseTrigCoupling sets the More >> Pause >> Analog Level >> Coupling property.

DAQmxResetAnlgLvlPauseTrigCoupling resets the More >> Pause >> Analog Level >> Coupling property.


Get/Set/Reset AnlgWin_PauseTrig_Coupling

int32 __CFUNC DAQmxGetAnlgWinPauseTrigCoupling(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetAnlgWinPauseTrigCoupling(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetAnlgWinPauseTrigCoupling(TaskHandle taskHandle);

Purpose

DAQmxGetAnlgWinPauseTrigCoupling gets the More >> Pause >> Analog Window >> Coupling property.

DAQmxSetAnlgWinPauseTrigCoupling sets the More >> Pause >> Analog Window >> Coupling property.

DAQmxResetAnlgWinPauseTrigCoupling resets the More >> Pause >> Analog Window >> Coupling property.


Get/Set/Reset DigEdge_AdvTrig_DigFltr_Enable

int32 __CFUNC DAQmxGetDigEdgeAdvTrigDigFltrEnable(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetDigEdgeAdvTrigDigFltrEnable(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetDigEdgeAdvTrigDigFltrEnable(TaskHandle taskHandle);

Purpose

DAQmxGetDigEdgeAdvTrigDigFltrEnable gets the More >> Advance >> Digital Edge >> Digital Filter >> Enable property.

DAQmxSetDigEdgeAdvTrigDigFltrEnable sets the More >> Advance >> Digital Edge >> Digital Filter >> Enable property.

DAQmxResetDigEdgeAdvTrigDigFltrEnable resets the More >> Advance >> Digital Edge >> Digital Filter >> Enable property.


Get/Set/Reset CI_Prescaler

int32 __CFUNC DAQmxGetCIPrescaler(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIPrescaler(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIPrescaler(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPrescaler gets the Counter Input >> General Properties >> More >> Advanced >> Prescaler property.

DAQmxSetCIPrescaler sets the Counter Input >> General Properties >> More >> Advanced >> Prescaler property.

DAQmxResetCIPrescaler resets the Counter Input >> General Properties >> More >> Advanced >> Prescaler property.


Get/Set/Reset AO_IdleOutputBehavior

int32 __CFUNC DAQmxGetAOIdleOutputBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOIdleOutputBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOIdleOutputBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOIdleOutputBehavior gets the Analog Output >> General Properties >> Output Configuration >> Idle Output Behavior property.

DAQmxSetAOIdleOutputBehavior sets the Analog Output >> General Properties >> Output Configuration >> Idle Output Behavior property.

DAQmxResetAOIdleOutputBehavior resets the Analog Output >> General Properties >> Output Configuration >> Idle Output Behavior property.


Get/Set/Reset AO_EnhancedImageRejectionEnable

int32 __CFUNC DAQmxGetAOEnhancedImageRejectionEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAOEnhancedImageRejectionEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAOEnhancedImageRejectionEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOEnhancedImageRejectionEnable gets the Analog Output >> General Properties >> Advanced >> Enhanced Image Rejection Enable property.

DAQmxSetAOEnhancedImageRejectionEnable sets the Analog Output >> General Properties >> Advanced >> Enhanced Image Rejection Enable property.

DAQmxResetAOEnhancedImageRejectionEnable resets the Analog Output >> General Properties >> Advanced >> Enhanced Image Rejection Enable property.


Get/Set/Reset AO_DAC_Ref_ExtSrc

int32 __CFUNC DAQmxGetAODACRefExtSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAODACRefExtSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAODACRefExtSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACRefExtSrc gets the Analog Output >> General Properties >> DAC >> Reference Voltage >> External Source property.

DAQmxSetAODACRefExtSrc sets the Analog Output >> General Properties >> DAC >> Reference Voltage >> External Source property.

DAQmxResetAODACRefExtSrc resets the Analog Output >> General Properties >> DAC >> Reference Voltage >> External Source property.


Get/Set/Reset AO_DAC_Offset_Src

int32 __CFUNC DAQmxGetAODACOffsetSrc(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAODACOffsetSrc(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAODACOffsetSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACOffsetSrc gets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Source property.

DAQmxSetAODACOffsetSrc sets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Source property.

DAQmxResetAODACOffsetSrc resets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Source property.


Get/Set/Reset AO_DAC_Offset_ExtSrc

int32 __CFUNC DAQmxGetAODACOffsetExtSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAODACOffsetExtSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetAODACOffsetExtSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACOffsetExtSrc gets the Analog Output >> General Properties >> DAC >> Offset Voltage >> External Source property.

DAQmxSetAODACOffsetExtSrc sets the Analog Output >> General Properties >> DAC >> Offset Voltage >> External Source property.

DAQmxResetAODACOffsetExtSrc resets the Analog Output >> General Properties >> DAC >> Offset Voltage >> External Source property.


Get/Set/Reset AO_DAC_Offset_Val

int32 __CFUNC DAQmxGetAODACOffsetVal(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAODACOffsetVal(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAODACOffsetVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAODACOffsetVal gets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Value property.

DAQmxSetAODACOffsetVal sets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Value property.

DAQmxResetAODACOffsetVal resets the Analog Output >> General Properties >> DAC >> Offset Voltage >> Value property.


Get/Set/Reset DI_DataXferMech

int32 __CFUNC DAQmxGetDIDataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDIDataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDIDataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDataXferMech gets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetDIDataXferMech sets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetDIDataXferMech resets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset DI_DataXferReqCond

int32 __CFUNC DAQmxGetDIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDIDataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDIDataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIDataXferReqCond gets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetDIDataXferReqCond sets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetDIDataXferReqCond resets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset DO_UseOnlyOnBrdMem

int32 __CFUNC DAQmxGetDOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetDOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetDOUseOnlyOnBrdMem(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOUseOnlyOnBrdMem gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxSetDOUseOnlyOnBrdMem sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.

DAQmxResetDOUseOnlyOnBrdMem resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Use Only Onboard Memory property.


Get/Set/Reset DO_DataXferMech

int32 __CFUNC DAQmxGetDODataXferMech(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDODataXferMech(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDODataXferMech(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDODataXferMech gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxSetDODataXferMech sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.

DAQmxResetDODataXferMech resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Mechanism property.


Get/Set/Reset DO_DataXferReqCond

int32 __CFUNC DAQmxGetDODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDODataXferReqCond(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDODataXferReqCond(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDODataXferReqCond gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxSetDODataXferReqCond sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.

DAQmxResetDODataXferReqCond resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> Data Transfer Request Condition property.


Get/Set/Reset CI_CtrTimebase_DigFltr_Enable

int32 __CFUNC DAQmxGetCICtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseDigFltrEnable gets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.

DAQmxSetCICtrTimebaseDigFltrEnable sets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.

DAQmxResetCICtrTimebaseDigFltrEnable resets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.


Get/Set/Reset CI_CtrTimebase_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCICtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseDigFltrMinPulseWidth gets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCICtrTimebaseDigFltrMinPulseWidth sets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCICtrTimebaseDigFltrMinPulseWidth resets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CI_CtrTimebase_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCICtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCICtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCICtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseDigFltrTimebaseSrc gets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.

DAQmxSetCICtrTimebaseDigFltrTimebaseSrc sets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.

DAQmxResetCICtrTimebaseDigFltrTimebaseSrc resets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_CtrTimebase_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCICtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCICtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseDigFltrTimebaseRate gets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCICtrTimebaseDigFltrTimebaseRate sets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCICtrTimebaseDigFltrTimebaseRate resets the Counter Input >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_CtrTimebase_DigSync_Enable

int32 __CFUNC DAQmxGetCICtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCICtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCICtrTimebaseDigSyncEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCICtrTimebaseDigSyncEnable gets the Counter Input >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.

DAQmxSetCICtrTimebaseDigSyncEnable sets the Counter Input >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.

DAQmxResetCICtrTimebaseDigSyncEnable resets the Counter Input >> General Properties >> Counter Timebase >> Digital Synchronization >> Enable property.


Get/Set/Reset CO_CtrTimebase_DigFltr_Enable

int32 __CFUNC DAQmxGetCOCtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseDigFltrEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseDigFltrEnable gets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.

DAQmxSetCOCtrTimebaseDigFltrEnable sets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.

DAQmxResetCOCtrTimebaseDigFltrEnable resets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Enable property.


Get/Set/Reset CO_CtrTimebase_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetCOCtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseDigFltrMinPulseWidth(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseDigFltrMinPulseWidth gets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetCOCtrTimebaseDigFltrMinPulseWidth sets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetCOCtrTimebaseDigFltrMinPulseWidth resets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset CO_CtrTimebase_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCOCtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCOCtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCOCtrTimebaseDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseDigFltrTimebaseSrc gets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.

DAQmxSetCOCtrTimebaseDigFltrTimebaseSrc sets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.

DAQmxResetCOCtrTimebaseDigFltrTimebaseSrc resets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CO_CtrTimebase_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCOCtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCOCtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCOCtrTimebaseDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOCtrTimebaseDigFltrTimebaseRate gets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCOCtrTimebaseDigFltrTimebaseRate sets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCOCtrTimebaseDigFltrTimebaseRate resets the Counter Output >> General Properties >> Counter Timebase >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AI_EnhancedAliasRejectionEnable

int32 __CFUNC DAQmxGetAIEnhancedAliasRejectionEnable(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIEnhancedAliasRejectionEnable(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIEnhancedAliasRejectionEnable(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIEnhancedAliasRejectionEnable gets the Analog Input >> General Properties >> Advanced >> Enhanced Alias Rejection Enable property.

DAQmxSetAIEnhancedAliasRejectionEnable sets the Analog Input >> General Properties >> Advanced >> Enhanced Alias Rejection Enable property.

DAQmxResetAIEnhancedAliasRejectionEnable resets the Analog Input >> General Properties >> Advanced >> Enhanced Alias Rejection Enable property.


Get/Set/Reset AI_ChanCal_HasValidCalInfo

int32 __CFUNC DAQmxGetAIChanCalHasValidCalInfo(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetAIChanCalHasValidCalInfo gets the Analog Input >> General Properties >> Channel Calibration >> Has Valid Calibration Information property.


Get/Set/Reset AI_ChanCal_EnableCal

int32 __CFUNC DAQmxGetAIChanCalEnableCal(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIChanCalEnableCal(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIChanCalEnableCal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalEnableCal gets the Analog Input >> General Properties >> Channel Calibration >> Enable Calibration property.

DAQmxSetAIChanCalEnableCal sets the Analog Input >> General Properties >> Channel Calibration >> Enable Calibration property.

DAQmxResetAIChanCalEnableCal resets the Analog Input >> General Properties >> Channel Calibration >> Enable Calibration property.


Get/Set/Reset AI_ChanCal_ApplyCalIfExp

int32 __CFUNC DAQmxGetAIChanCalApplyCalIfExp(TaskHandle taskHandle, const char channel[], bool32 *data);

int32 __CFUNC DAQmxSetAIChanCalApplyCalIfExp(TaskHandle taskHandle, const char channel[], bool32 data);

int32 __CFUNC DAQmxResetAIChanCalApplyCalIfExp(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChanCalApplyCalIfExp gets the Analog Input >> General Properties >> Channel Calibration >> Apply Calibration If Expired property.

DAQmxSetAIChanCalApplyCalIfExp sets the Analog Input >> General Properties >> Channel Calibration >> Apply Calibration If Expired property.

DAQmxResetAIChanCalApplyCalIfExp resets the Analog Input >> General Properties >> Channel Calibration >> Apply Calibration If Expired property.


Get/Set/Reset Exported_ChangeDetectEvent_Pulse_Polarity

int32 __CFUNC DAQmxGetExportedChangeDetectEventPulsePolarity(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedChangeDetectEventPulsePolarity(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedChangeDetectEventPulsePolarity(TaskHandle taskHandle);

Purpose

DAQmxGetExportedChangeDetectEventPulsePolarity gets the Events >> Change Detection Event >> Pulse >> Polarity property.

DAQmxSetExportedChangeDetectEventPulsePolarity sets the Events >> Change Detection Event >> Pulse >> Polarity property.

DAQmxResetExportedChangeDetectEventPulsePolarity resets the Events >> Change Detection Event >> Pulse >> Polarity property.


Get/Set/Reset ChanIsGlobal

int32 __CFUNC DAQmxGetChanIsGlobal(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetChanIsGlobal gets the General Properties >> Is Global property.


Get/Set/Reset RealTime_ReportMissedSamp

int32 __CFUNC DAQmxGetRealTimeReportMissedSamp(TaskHandle taskHandle, bool32 *data);

int32 __CFUNC DAQmxSetRealTimeReportMissedSamp(TaskHandle taskHandle, bool32 data);

int32 __CFUNC DAQmxResetRealTimeReportMissedSamp(TaskHandle taskHandle);

Purpose

DAQmxGetRealTimeReportMissedSamp gets the Report Missed Samples property.

DAQmxSetRealTimeReportMissedSamp sets the Report Missed Samples property.

DAQmxResetRealTimeReportMissedSamp resets the Report Missed Samples property.


Get/Set/Reset Dev_DI_Lines

int32 __CFUNC DAQmxGetDevDILines(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevDILines gets the I/O Type >> Digital Input >> Lines property.


Get/Set/Reset Dev_DI_Ports

int32 __CFUNC DAQmxGetDevDIPorts(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevDIPorts gets the I/O Type >> Digital Input >> Ports property.


Get/Set/Reset Dev_DO_Lines

int32 __CFUNC DAQmxGetDevDOLines(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevDOLines gets the I/O Type >> Digital Output >> Lines property.


Get/Set/Reset Dev_DO_Ports

int32 __CFUNC DAQmxGetDevDOPorts(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevDOPorts gets the I/O Type >> Digital Output >> Ports property.


Get/Set/Reset Dev_CI_PhysicalChans

int32 __CFUNC DAQmxGetDevCIPhysicalChans(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevCIPhysicalChans gets the I/O Type >> Counter Input >> Physical Channels property.


Get/Set/Reset Dev_CO_PhysicalChans

int32 __CFUNC DAQmxGetDevCOPhysicalChans(const char device[], char *data, uInt32 bufferSize);

Purpose

DAQmxGetDevCOPhysicalChans gets the I/O Type >> Counter Output >> Physical Channels property.


Get/Set/Reset Dev_BusType

int32 __CFUNC DAQmxGetDevBusType(const char device[], int32 *data);

Purpose

DAQmxGetDevBusType gets the Location >> Bus Type property.


Get/Set/Reset Dev_PCI_BusNum

int32 __CFUNC DAQmxGetDevPCIBusNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevPCIBusNum gets the Location >> PCI >> Bus Number property.


Get/Set/Reset Dev_PCI_DevNum

int32 __CFUNC DAQmxGetDevPCIDevNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevPCIDevNum gets the Location >> PCI >> Device Number property.


Get/Set/Reset Dev_PXI_ChassisNum

int32 __CFUNC DAQmxGetDevPXIChassisNum(const char device[], uInt32 *data);

Purpose

DAQmxGetDevPXIChassisNum gets the Location >> PXI >> Chassis Number property.


Get/Set/Reset PhysicalChan_AI_TermCfgs

int32 __CFUNC DAQmxGetPhysicalChanAITermCfgs(const char physicalChannel[], int32 *data);

Purpose

DAQmxGetPhysicalChanAITermCfgs gets the Analog Input >> Input Configuration >> Terminal Configurations property.


Get/Set/Reset SampClk_UnderflowBehavior

int32 __CFUNC DAQmxGetSampClkUnderflowBehavior(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetSampClkUnderflowBehavior(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetSampClkUnderflowBehavior(TaskHandle taskHandle);

Purpose

DAQmxGetSampClkUnderflowBehavior gets the Sample Clock >> Underflow Behavior property.

DAQmxSetSampClkUnderflowBehavior sets the Sample Clock >> Underflow Behavior property.

DAQmxResetSampClkUnderflowBehavior resets the Sample Clock >> Underflow Behavior property.


Get/Set/Reset Exported_RdyForXferEvent_DeassertCond

int32 __CFUNC DAQmxGetExportedRdyForXferEventDeassertCond(TaskHandle taskHandle, int32 *data);

int32 __CFUNC DAQmxSetExportedRdyForXferEventDeassertCond(TaskHandle taskHandle, int32 data);

int32 __CFUNC DAQmxResetExportedRdyForXferEventDeassertCond(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForXferEventDeassertCond gets the Events >> Ready For Transfer Event >> Deassert Condition property.

DAQmxSetExportedRdyForXferEventDeassertCond sets the Events >> Ready For Transfer Event >> Deassert Condition property.

DAQmxResetExportedRdyForXferEventDeassertCond resets the Events >> Ready For Transfer Event >> Deassert Condition property.


Get/Set/Reset Exported_RdyForXferEvent_DeassertCondCustomThreshold

int32 __CFUNC DAQmxGetExportedRdyForXferEventDeassertCondCustomThreshold(TaskHandle taskHandle, uInt32 *data);

int32 __CFUNC DAQmxSetExportedRdyForXferEventDeassertCondCustomThreshold(TaskHandle taskHandle, uInt32 data);

int32 __CFUNC DAQmxResetExportedRdyForXferEventDeassertCondCustomThreshold(TaskHandle taskHandle);

Purpose

DAQmxGetExportedRdyForXferEventDeassertCondCustomThreshold gets the Events >> Ready For Transfer Event >> Deassert Condition Custom Threshold property.

DAQmxSetExportedRdyForXferEventDeassertCondCustomThreshold sets the Events >> Ready For Transfer Event >> Deassert Condition Custom Threshold property.

DAQmxResetExportedRdyForXferEventDeassertCondCustomThreshold resets the Events >> Ready For Transfer Event >> Deassert Condition Custom Threshold property.


Get/Set/Reset DI_AcquireOn

int32 __CFUNC DAQmxGetDIAcquireOn(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDIAcquireOn(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDIAcquireOn(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIAcquireOn gets the Digital Input >> General Properties >> Advanced >> Acquire On property.

DAQmxSetDIAcquireOn sets the Digital Input >> General Properties >> Advanced >> Acquire On property.

DAQmxResetDIAcquireOn resets the Digital Input >> General Properties >> Advanced >> Acquire On property.


Get/Set/Reset DO_LineStates_PausedState

int32 __CFUNC DAQmxGetDOLineStatesPausedState(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOLineStatesPausedState(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOLineStatesPausedState(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOLineStatesPausedState gets the Digital Output >> Line States >> Paused State property.

DAQmxSetDOLineStatesPausedState sets the Digital Output >> Line States >> Paused State property.

DAQmxResetDOLineStatesPausedState resets the Digital Output >> Line States >> Paused State property.


Get/Set/Reset DO_LineStates_DoneState

int32 __CFUNC DAQmxGetDOLineStatesDoneState(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOLineStatesDoneState(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOLineStatesDoneState(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOLineStatesDoneState gets the Digital Output >> Line States >> Done State property.

DAQmxSetDOLineStatesDoneState sets the Digital Output >> Line States >> Done State property.

DAQmxResetDOLineStatesDoneState resets the Digital Output >> Line States >> Done State property.


Get/Set/Reset DO_GenerateOn

int32 __CFUNC DAQmxGetDOGenerateOn(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOGenerateOn(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOGenerateOn(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOGenerateOn gets the Digital Output >> General Properties >> Advanced >> Generate On property.

DAQmxSetDOGenerateOn sets the Digital Output >> General Properties >> Advanced >> Generate On property.

DAQmxResetDOGenerateOn resets the Digital Output >> General Properties >> Advanced >> Generate On property.


Get/Set/Reset DO_LineStates_StartState

int32 __CFUNC DAQmxGetDOLineStatesStartState(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetDOLineStatesStartState(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetDOLineStatesStartState(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOLineStatesStartState gets the Digital Output >> Line States >> Start State property.

DAQmxSetDOLineStatesStartState sets the Digital Output >> Line States >> Start State property.

DAQmxResetDOLineStatesStartState resets the Digital Output >> Line States >> Start State property.


Get/Set/Reset AI_Is_TEDS

int32 __CFUNC DAQmxGetAIIsTEDS(TaskHandle taskHandle, const char channel[], bool32 *data);

Purpose

DAQmxGetAIIsTEDS gets the Analog Input >> TEDS >> Is TEDS property.


Get/Set/Reset Dev_AnlgTrigSupported

int32 __CFUNC DAQmxGetDevAnlgTrigSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevAnlgTrigSupported gets the Triggering >> Analog Triggering Supported property.


Get/Set/Reset Dev_DigTrigSupported

int32 __CFUNC DAQmxGetDevDigTrigSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevDigTrigSupported gets the Triggering >> Digital Triggering Supported property.


Get/Set/Reset Dev_AI_TrigUsage

int32 __CFUNC DAQmxGetDevAITrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevAITrigUsage gets the I/O Type >> Analog Input >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_AO_TrigUsage

int32 __CFUNC DAQmxGetDevAOTrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevAOTrigUsage gets the I/O Type >> Analog Output >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_DI_TrigUsage

int32 __CFUNC DAQmxGetDevDITrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevDITrigUsage gets the I/O Type >> Digital Input >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_DO_TrigUsage

int32 __CFUNC DAQmxGetDevDOTrigUsage(const char device[], int32 *data);

Purpose

DAQmxGetDevDOTrigUsage gets the I/O Type >> Digital Output >> Trigger >> Trigger Usage property.


Get/Set/Reset Dev_AI_VoltageRngs

int32 __CFUNC DAQmxGetDevAIVoltageRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIVoltageRngs gets the I/O Type >> Analog Input >> Voltage >> Ranges property.


Get/Set/Reset Dev_AI_CurrentRngs

int32 __CFUNC DAQmxGetDevAICurrentRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAICurrentRngs gets the I/O Type >> Analog Input >> Current >> Ranges property.


Get/Set/Reset Dev_AI_FreqRngs

int32 __CFUNC DAQmxGetDevAIFreqRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIFreqRngs gets the I/O Type >> Analog Input >> Frequency >> Ranges property.


Get/Set/Reset Dev_AI_Gains

int32 __CFUNC DAQmxGetDevAIGains(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIGains gets the I/O Type >> Analog Input >> Gains property.


Get/Set/Reset Dev_AI_Couplings

int32 __CFUNC DAQmxGetDevAICouplings(const char device[], int32 *data);

Purpose

DAQmxGetDevAICouplings gets the I/O Type >> Analog Input >> Couplings property.


Get/Set/Reset Dev_AI_LowpassCutoffFreqDiscreteVals

int32 __CFUNC DAQmxGetDevAILowpassCutoffFreqDiscreteVals(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAILowpassCutoffFreqDiscreteVals gets the I/O Type >> Analog Input >> Filter >> Analog Low Pass >> Cutoff Frequency >> Discrete Values property.


Get/Set/Reset Dev_AO_SampClkSupported

int32 __CFUNC DAQmxGetDevAOSampClkSupported(const char device[], bool32 *data);

Purpose

DAQmxGetDevAOSampClkSupported gets the I/O Type >> Analog Output >> Timing >> Sample Clock Supported property.


Get/Set/Reset Dev_AO_MaxRate

int32 __CFUNC DAQmxGetDevAOMaxRate(const char device[], float64 *data);

Purpose

DAQmxGetDevAOMaxRate gets the I/O Type >> Analog Output >> Timing >> Maximum Rate property.


Get/Set/Reset Dev_AO_MinRate

int32 __CFUNC DAQmxGetDevAOMinRate(const char device[], float64 *data);

Purpose

DAQmxGetDevAOMinRate gets the I/O Type >> Analog Output >> Timing >> Minimum Rate property.


Get/Set/Reset Dev_DI_MaxRate

int32 __CFUNC DAQmxGetDevDIMaxRate(const char device[], float64 *data);

Purpose

DAQmxGetDevDIMaxRate gets the I/O Type >> Digital Input >> Timing >> Maximum Rate property.


Get/Set/Reset AI_UsbXferReqCount

int32 __CFUNC DAQmxGetAIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAIUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIUsbXferReqCount gets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetAIUsbXferReqCount sets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetAIUsbXferReqCount resets the Analog Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset AO_UsbXferReqCount

int32 __CFUNC DAQmxGetAOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetAOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetAOUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOUsbXferReqCount gets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetAOUsbXferReqCount sets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetAOUsbXferReqCount resets the Analog Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset DI_UsbXferReqCount

int32 __CFUNC DAQmxGetDIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetDIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetDIUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDIUsbXferReqCount gets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetDIUsbXferReqCount sets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetDIUsbXferReqCount resets the Digital Input >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset DO_UsbXferReqCount

int32 __CFUNC DAQmxGetDOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetDOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetDOUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetDOUsbXferReqCount gets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetDOUsbXferReqCount sets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetDOUsbXferReqCount resets the Digital Output >> General Properties >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset CI_UsbXferReqCount

int32 __CFUNC DAQmxGetCIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCIUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCIUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIUsbXferReqCount gets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetCIUsbXferReqCount sets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetCIUsbXferReqCount resets the Counter Input >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset CO_UsbXferReqCount

int32 __CFUNC DAQmxGetCOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 *data);

int32 __CFUNC DAQmxSetCOUsbXferReqCount(TaskHandle taskHandle, const char channel[], uInt32 data);

int32 __CFUNC DAQmxResetCOUsbXferReqCount(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCOUsbXferReqCount gets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxSetCOUsbXferReqCount sets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.

DAQmxResetCOUsbXferReqCount resets the Counter Output >> General Properties >> More >> Advanced >> Data Transfer and Memory >> USB Transfer Request Count property.


Get/Set/Reset Write_AccessoryInsertionOrRemovalDetected

int32 __CFUNC DAQmxGetWriteAccessoryInsertionOrRemovalDetected(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteAccessoryInsertionOrRemovalDetected gets the Status >> Accessory >> Accessory Insertion or Removal Detected property.


Get/Set/Reset Write_DevsWithInsertedOrRemovedAccessories

int32 __CFUNC DAQmxGetWriteDevsWithInsertedOrRemovedAccessories(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteDevsWithInsertedOrRemovedAccessories gets the Status >> Accessory >> Devices with Inserted or Removed Accessories property.


Get/Set/Reset Watchdog_CO_ExpirState

int32 __CFUNC DAQmxGetWatchdogCOExpirState(TaskHandle taskHandle, const char lines[], int32 *data);

int32 __CFUNC DAQmxSetWatchdogCOExpirState(TaskHandle taskHandle, const char lines[], int32 data);

int32 __CFUNC DAQmxResetWatchdogCOExpirState(TaskHandle taskHandle, const char lines[]);

Purpose

DAQmxGetWatchdogCOExpirState gets the Expiration States >> Counter Output >> Expiration State property.

DAQmxSetWatchdogCOExpirState sets the Expiration States >> Counter Output >> Expiration State property.

DAQmxResetWatchdogCOExpirState resets the Expiration States >> Counter Output >> Expiration State property.


Get/Set/Reset AO_PowerAmp_ChannelEnable

int32 __CFUNC DAQmxGetAOPowerAmpChannelEnable(const char physicalChannel[], bool32 *data);

int32 __CFUNC DAQmxSetAOPowerAmpChannelEnable(const char physicalChannel[], bool32 data);

int32 __CFUNC DAQmxResetAOPowerAmpChannelEnable(const char physicalChannel[]);

Purpose

DAQmxGetAOPowerAmpChannelEnable gets the Analog Output >> Advanced >> Power Amplifier >> Channel Enable property.

DAQmxSetAOPowerAmpChannelEnable sets the Analog Output >> Advanced >> Power Amplifier >> Channel Enable property.

DAQmxResetAOPowerAmpChannelEnable resets the Analog Output >> Advanced >> Power Amplifier >> Channel Enable property.


Get/Set/Reset AO_PowerAmp_ScalingCoeff

int32 __CFUNC DAQmxGetAOPowerAmpScalingCoeff(const char physicalChannel[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetAOPowerAmpScalingCoeff gets the Analog Output >> Advanced >> Power Amplifier >> Scaling Coefficients property.


Get/Set/Reset AO_PowerAmp_Overcurrent

int32 __CFUNC DAQmxGetAOPowerAmpOvercurrent(const char physicalChannel[], bool32 *data);

Purpose

DAQmxGetAOPowerAmpOvercurrent gets the Analog Output >> Advanced >> Power Amplifier >> Overcurrent property.


Get/Set/Reset AO_PowerAmp_Gain

int32 __CFUNC DAQmxGetAOPowerAmpGain(const char physicalChannel[], float64 *data);

Purpose

DAQmxGetAOPowerAmpGain gets the Analog Output >> Advanced >> Power Amplifier >> Calibration >> Gain property.


Get/Set/Reset AO_PowerAmp_Offset

int32 __CFUNC DAQmxGetAOPowerAmpOffset(const char physicalChannel[], float64 *data);

Purpose

DAQmxGetAOPowerAmpOffset gets the Analog Output >> Advanced >> Power Amplifier >> Calibration >> Offset property.


Get/Set/Reset AI_FilterDelayUnits

int32 __CFUNC DAQmxGetAIFilterDelayUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIFilterDelayUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIFilterDelayUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIFilterDelayUnits gets the Analog Input >> General Properties >> Filter >> Filter Delay Units property.

DAQmxSetAIFilterDelayUnits sets the Analog Input >> General Properties >> Filter >> Filter Delay Units property.

DAQmxResetAIFilterDelayUnits resets the Analog Input >> General Properties >> Filter >> Filter Delay Units property.


Get/Set/Reset AO_FilterDelayAdjustment

int32 __CFUNC DAQmxGetAOFilterDelayAdjustment(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFilterDelayAdjustment(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFilterDelayAdjustment(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFilterDelayAdjustment gets the Analog Output >> General Properties >> Filter >> Filter Delay Adjustment property.

DAQmxSetAOFilterDelayAdjustment sets the Analog Output >> General Properties >> Filter >> Filter Delay Adjustment property.

DAQmxResetAOFilterDelayAdjustment resets the Analog Output >> General Properties >> Filter >> Filter Delay Adjustment property.


Get/Set/Reset AI_FilterDelayAdjustment

int32 __CFUNC DAQmxGetAIFilterDelayAdjustment(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIFilterDelayAdjustment(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIFilterDelayAdjustment(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIFilterDelayAdjustment gets the Analog Input >> General Properties >> Filter >> Filter Delay Adjustment property.

DAQmxSetAIFilterDelayAdjustment sets the Analog Input >> General Properties >> Filter >> Filter Delay Adjustment property.

DAQmxResetAIFilterDelayAdjustment resets the Analog Input >> General Properties >> Filter >> Filter Delay Adjustment property.


Get/Set/Reset AO_FilterDelay

int32 __CFUNC DAQmxGetAOFilterDelay(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAOFilterDelay(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAOFilterDelay(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFilterDelay gets the Analog Output >> General Properties >> Filter >> Filter Delay property.

DAQmxSetAOFilterDelay sets the Analog Output >> General Properties >> Filter >> Filter Delay property.

DAQmxResetAOFilterDelay resets the Analog Output >> General Properties >> Filter >> Filter Delay property.


Get/Set/Reset AO_FilterDelayUnits

int32 __CFUNC DAQmxGetAOFilterDelayUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAOFilterDelayUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAOFilterDelayUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAOFilterDelayUnits gets the Analog Output >> General Properties >> Filter >> Filter Delay Units property.

DAQmxSetAOFilterDelayUnits sets the Analog Output >> General Properties >> Filter >> Filter Delay Units property.

DAQmxResetAOFilterDelayUnits resets the Analog Output >> General Properties >> Filter >> Filter Delay Units property.


Get/Set/Reset Read_OvertemperatureChansExist

int32 __CFUNC DAQmxGetReadOvertemperatureChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOvertemperatureChansExist gets the Status >> Overtemperature >> Overtemperature Channels Exist property.


Get/Set/Reset Read_OvertemperatureChans

int32 __CFUNC DAQmxGetReadOvertemperatureChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOvertemperatureChans gets the Status >> Overtemperature >> Overtemperature Channels property.


Get/Set/Reset Write_OvertemperatureChans

int32 __CFUNC DAQmxGetWriteOvertemperatureChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteOvertemperatureChans gets the Status >> Overtemperature >> Overtemperature Channels property.


Get/Set/Reset Write_OverloadedChansExist

int32 __CFUNC DAQmxGetWriteOverloadedChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetWriteOverloadedChansExist gets the Status >> Overload >> Overloaded Channels Exist property.


Get/Set/Reset Write_OverloadedChans

int32 __CFUNC DAQmxGetWriteOverloadedChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetWriteOverloadedChans gets the Status >> Overload >> Overloaded Channels property.


Get/Set/Reset Read_ExcitFaultChansExist

int32 __CFUNC DAQmxGetReadExcitFaultChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadExcitFaultChansExist gets the Status >> Excitation Fault >> Excitation Fault Channels Exist property.


Get/Set/Reset Read_ExcitFaultChans

int32 __CFUNC DAQmxGetReadExcitFaultChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadExcitFaultChans gets the Status >> Excitation Fault >> Excitation Fault Channels property.


Get/Set/Reset CI_DutyCycle_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetCIDutyCycleDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetCIDutyCycleDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[], const char *data);

int32 __CFUNC DAQmxResetCIDutyCycleDigFltrTimebaseSrc(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleDigFltrTimebaseSrc gets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxSetCIDutyCycleDigFltrTimebaseSrc sets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Source property.

DAQmxResetCIDutyCycleDigFltrTimebaseSrc resets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset CI_DutyCycle_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetCIDutyCycleDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIDutyCycleDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIDutyCycleDigFltrTimebaseRate(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleDigFltrTimebaseRate gets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxSetCIDutyCycleDigFltrTimebaseRate sets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Rate property.

DAQmxResetCIDutyCycleDigFltrTimebaseRate resets the Counter Input >> Duty Cycle >> Input >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset CI_DutyCycle_StartingEdge

int32 __CFUNC DAQmxGetCIDutyCycleStartingEdge(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIDutyCycleStartingEdge(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIDutyCycleStartingEdge(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIDutyCycleStartingEdge gets the Counter Input >> Duty Cycle >> StartingEdge property.

DAQmxSetCIDutyCycleStartingEdge sets the Counter Input >> Duty Cycle >> StartingEdge property.

DAQmxResetCIDutyCycleStartingEdge resets the Counter Input >> Duty Cycle >> StartingEdge property.


Get/Set/Reset CI_SampClkOverrunBehavior

int32 __CFUNC DAQmxGetCISampClkOverrunBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISampClkOverrunBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISampClkOverrunBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISampClkOverrunBehavior gets the Counter Input >> General Properties >> More >> Sample Clock Overrun Behavior property.

DAQmxSetCISampClkOverrunBehavior sets the Counter Input >> General Properties >> More >> Sample Clock Overrun Behavior property.

DAQmxResetCISampClkOverrunBehavior resets the Counter Input >> General Properties >> More >> Sample Clock Overrun Behavior property.


Get/Set/Reset CI_SampClkOverrunSentinelVal

int32 __CFUNC DAQmxGetCISampClkOverrunSentinelVal(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCISampClkOverrunSentinelVal(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCISampClkOverrunSentinelVal(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCISampClkOverrunSentinelVal gets the Counter Input >> General Properties >> More >> Sample Clock Overrun Sentinel Value property.

DAQmxSetCISampClkOverrunSentinelVal sets the Counter Input >> General Properties >> More >> Sample Clock Overrun Sentinel Value property.

DAQmxResetCISampClkOverrunSentinelVal resets the Counter Input >> General Properties >> More >> Sample Clock Overrun Sentinel Value property.


Get/Set/Reset CI_MaxMeasPeriod

int32 __CFUNC DAQmxGetCIMaxMeasPeriod(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetCIMaxMeasPeriod(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetCIMaxMeasPeriod(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIMaxMeasPeriod gets the Counter Input >> General Properties >> More >> Advanced >> Maximum Measurable Period property.

DAQmxSetCIMaxMeasPeriod sets the Counter Input >> General Properties >> More >> Advanced >> Maximum Measurable Period property.

DAQmxResetCIMaxMeasPeriod resets the Counter Input >> General Properties >> More >> Advanced >> Maximum Measurable Period property.


Get/Set/Reset CI_Freq_TermCfg

int32 __CFUNC DAQmxGetCIFreqTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIFreqTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIFreqTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqTermCfg gets the Counter Input >> Frequency >> Input >> Terminal Configuration property.

DAQmxSetCIFreqTermCfg sets the Counter Input >> Frequency >> Input >> Terminal Configuration property.

DAQmxResetCIFreqTermCfg resets the Counter Input >> Frequency >> Input >> Terminal Configuration property.


Get/Set/Reset CI_Freq_LogicLvlBehavior

int32 __CFUNC DAQmxGetCIFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIFreqLogicLvlBehavior(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIFreqLogicLvlBehavior gets the Counter Input >> Frequency >> Input >> Logic Level Behavior property.

DAQmxSetCIFreqLogicLvlBehavior sets the Counter Input >> Frequency >> Input >> Logic Level Behavior property.

DAQmxResetCIFreqLogicLvlBehavior resets the Counter Input >> Frequency >> Input >> Logic Level Behavior property.


Get/Set/Reset CI_Period_TermCfg

int32 __CFUNC DAQmxGetCIPeriodTermCfg(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetCIPeriodTermCfg(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetCIPeriodTermCfg(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetCIPeriodTermCfg gets the Counter Input >> Period >> Input >> Terminal Configuration property.

DAQmxSetCIPeriodTermCfg sets the Counter Input >> Period >> Input >> Terminal Configuration property.

DAQmxResetCIPeriodTermCfg resets the Counter Input >> Period >> Input >> Terminal Configuration property.


Get/Set/Reset Read_OpenChansExist

int32 __CFUNC DAQmxGetReadOpenChansExist(TaskHandle taskHandle, bool32 *data);

Purpose

DAQmxGetReadOpenChansExist gets the Status >> Open Channels >> Open Channels Exist property.


Get/Set/Reset Read_OpenChans

int32 __CFUNC DAQmxGetReadOpenChans(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOpenChans gets the Status >> Open Channels >> Open Channels property.


Get/Set/Reset Read_OpenChansDetails

int32 __CFUNC DAQmxGetReadOpenChansDetails(TaskHandle taskHandle, char *data, uInt32 bufferSize);

Purpose

DAQmxGetReadOpenChansDetails gets the Status >> Open Channels >> Open Channels Details property.


Get/Set/Reset AI_DigFltr_Types

int32 __CFUNC DAQmxGetAIDigFltrTypes(const char device[], int32 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetAIDigFltrTypes gets the I/O Type >> Analog Input >> Filter >> Digital Filter >> Types property.


Get/Set/Reset Dev_AI_ChargeRngs

int32 __CFUNC DAQmxGetDevAIChargeRngs(const char device[], float64 *data, uInt32 arraySizeInElements);

Purpose

DAQmxGetDevAIChargeRngs gets the I/O Type >> Analog Input >> Charge >> Ranges property.


Get/Set/Reset AI_Charge_Units

int32 __CFUNC DAQmxGetAIChargeUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIChargeUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIChargeUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIChargeUnits gets the Analog Input >> Charge >> Units property.

DAQmxSetAIChargeUnits sets the Analog Input >> Charge >> Units property.

DAQmxResetAIChargeUnits resets the Analog Input >> Charge >> Units property.


Get/Set/Reset AI_Accel_Charge_Sensitivity

int32 __CFUNC DAQmxGetAIAccelChargeSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIAccelChargeSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIAccelChargeSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccelChargeSensitivity gets the Analog Input >> Acceleration >> Charge >> Sensitivity property.

DAQmxSetAIAccelChargeSensitivity sets the Analog Input >> Acceleration >> Charge >> Sensitivity property.

DAQmxResetAIAccelChargeSensitivity resets the Analog Input >> Acceleration >> Charge >> Sensitivity property.


Get/Set/Reset AI_Accel_Charge_SensitivityUnits

int32 __CFUNC DAQmxGetAIAccelChargeSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIAccelChargeSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIAccelChargeSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccelChargeSensitivityUnits gets the Analog Input >> Acceleration >> Charge >> Sensitivity Units property.

DAQmxSetAIAccelChargeSensitivityUnits sets the Analog Input >> Acceleration >> Charge >> Sensitivity Units property.

DAQmxResetAIAccelChargeSensitivityUnits resets the Analog Input >> Acceleration >> Charge >> Sensitivity Units property.


Get/Set/Reset AI_Accel_4WireDCVoltage_Sensitivity

int32 __CFUNC DAQmxGetAIAccel4WireDCVoltageSensitivity(TaskHandle taskHandle, const char channel[], float64 *data);

int32 __CFUNC DAQmxSetAIAccel4WireDCVoltageSensitivity(TaskHandle taskHandle, const char channel[], float64 data);

int32 __CFUNC DAQmxResetAIAccel4WireDCVoltageSensitivity(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccel4WireDCVoltageSensitivity gets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity property.

DAQmxSetAIAccel4WireDCVoltageSensitivity sets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity property.

DAQmxResetAIAccel4WireDCVoltageSensitivity resets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity property.


Get/Set/Reset AI_Accel_4WireDCVoltage_SensitivityUnits

int32 __CFUNC DAQmxGetAIAccel4WireDCVoltageSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 *data);

int32 __CFUNC DAQmxSetAIAccel4WireDCVoltageSensitivityUnits(TaskHandle taskHandle, const char channel[], int32 data);

int32 __CFUNC DAQmxResetAIAccel4WireDCVoltageSensitivityUnits(TaskHandle taskHandle, const char channel[]);

Purpose

DAQmxGetAIAccel4WireDCVoltageSensitivityUnits gets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity Units property.

DAQmxSetAIAccel4WireDCVoltageSensitivityUnits sets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity Units property.

DAQmxResetAIAccel4WireDCVoltageSensitivityUnits resets the Analog Input >> Acceleration >> 4 Wire DC Voltage >> Sensitivity Units property.


Get/Set/Reset AIConv_DigFltr_Enable

int32 __CFUNC DAQmxGetAIConvDigFltrEnableEx(TaskHandle taskHandle, const char deviceNames[], bool32 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrEnableEx(TaskHandle taskHandle, const char deviceNames[], bool32 data);

int32 __CFUNC DAQmxResetAIConvDigFltrEnableEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvDigFltrEnableEx gets the More >> AI Convert >> Digital Filter >> Enable property.

DAQmxSetAIConvDigFltrEnableEx sets the More >> AI Convert >> Digital Filter >> Enable property.

DAQmxResetAIConvDigFltrEnableEx resets the More >> AI Convert >> Digital Filter >> Enable property.


Get/Set/Reset AIConv_DigFltr_MinPulseWidth

int32 __CFUNC DAQmxGetAIConvDigFltrMinPulseWidthEx(TaskHandle taskHandle, const char deviceNames[], float64 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrMinPulseWidthEx(TaskHandle taskHandle, const char deviceNames[], float64 data);

int32 __CFUNC DAQmxResetAIConvDigFltrMinPulseWidthEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvDigFltrMinPulseWidthEx gets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.

DAQmxSetAIConvDigFltrMinPulseWidthEx sets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.

DAQmxResetAIConvDigFltrMinPulseWidthEx resets the More >> AI Convert >> Digital Filter >> Minimum Pulse Width property.


Get/Set/Reset AIConv_DigFltr_TimebaseSrc

int32 __CFUNC DAQmxGetAIConvDigFltrTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIConvDigFltrTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[], const char *data);

int32 __CFUNC DAQmxResetAIConvDigFltrTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvDigFltrTimebaseSrcEx gets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.

DAQmxSetAIConvDigFltrTimebaseSrcEx sets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.

DAQmxResetAIConvDigFltrTimebaseSrcEx resets the More >> AI Convert >> Digital Filter >> Timebase >> Source property.


Get/Set/Reset AIConv_DigFltr_TimebaseRate

int32 __CFUNC DAQmxGetAIConvDigFltrTimebaseRateEx(TaskHandle taskHandle, const char deviceNames[], float64 *data);

int32 __CFUNC DAQmxSetAIConvDigFltrTimebaseRateEx(TaskHandle taskHandle, const char deviceNames[], float64 data);

int32 __CFUNC DAQmxResetAIConvDigFltrTimebaseRateEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvDigFltrTimebaseRateEx gets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.

DAQmxSetAIConvDigFltrTimebaseRateEx sets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.

DAQmxResetAIConvDigFltrTimebaseRateEx resets the More >> AI Convert >> Digital Filter >> Timebase >> Rate property.


Get/Set/Reset AIConv_DigSync_Enable

int32 __CFUNC DAQmxGetAIConvDigSyncEnableEx(TaskHandle taskHandle, const char deviceNames[], bool32 *data);

int32 __CFUNC DAQmxSetAIConvDigSyncEnableEx(TaskHandle taskHandle, const char deviceNames[], bool32 data);

int32 __CFUNC DAQmxResetAIConvDigSyncEnableEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvDigSyncEnableEx gets the More >> AI Convert >> Digital Synchronization >> Enable property.

DAQmxSetAIConvDigSyncEnableEx sets the More >> AI Convert >> Digital Synchronization >> Enable property.

DAQmxResetAIConvDigSyncEnableEx resets the More >> AI Convert >> Digital Synchronization >> Enable property.


Get/Set/Reset AIConv_MaxRate

int32 __CFUNC DAQmxGetAIConvMaxRateEx(TaskHandle taskHandle, const char deviceNames[], float64 *data);

Purpose

DAQmxGetAIConvMaxRateEx gets the More >> AI Convert >> Maximum Rate property.


Get/Set/Reset DelayFromSampClk_DelayUnits

int32 __CFUNC DAQmxGetDelayFromSampClkDelayUnitsEx(TaskHandle taskHandle, const char deviceNames[], int32 *data);

int32 __CFUNC DAQmxSetDelayFromSampClkDelayUnitsEx(TaskHandle taskHandle, const char deviceNames[], int32 data);

int32 __CFUNC DAQmxResetDelayFromSampClkDelayUnitsEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetDelayFromSampClkDelayUnitsEx gets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.

DAQmxSetDelayFromSampClkDelayUnitsEx sets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.

DAQmxResetDelayFromSampClkDelayUnitsEx resets the More >> AI Convert >> Delay From Sample Clock >> Delay Units property.


Get/Set/Reset DelayFromSampClk_Delay

int32 __CFUNC DAQmxGetDelayFromSampClkDelayEx(TaskHandle taskHandle, const char deviceNames[], float64 *data);

int32 __CFUNC DAQmxSetDelayFromSampClkDelayEx(TaskHandle taskHandle, const char deviceNames[], float64 data);

int32 __CFUNC DAQmxResetDelayFromSampClkDelayEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetDelayFromSampClkDelayEx gets the More >> AI Convert >> Delay From Sample Clock >> Delay property.

DAQmxSetDelayFromSampClkDelayEx sets the More >> AI Convert >> Delay From Sample Clock >> Delay property.

DAQmxResetDelayFromSampClkDelayEx resets the More >> AI Convert >> Delay From Sample Clock >> Delay property.


Get/Set/Reset AIConv_TimebaseDiv

int32 __CFUNC DAQmxGetAIConvTimebaseDivEx(TaskHandle taskHandle, const char deviceNames[], uInt32 *data);

int32 __CFUNC DAQmxSetAIConvTimebaseDivEx(TaskHandle taskHandle, const char deviceNames[], uInt32 data);

int32 __CFUNC DAQmxResetAIConvTimebaseDivEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvTimebaseDivEx gets the More >> AI Convert >> Timebase Divisor property.

DAQmxSetAIConvTimebaseDivEx sets the More >> AI Convert >> Timebase Divisor property.

DAQmxResetAIConvTimebaseDivEx resets the More >> AI Convert >> Timebase Divisor property.


Get/Set/Reset AIConv_Timebase_Src

int32 __CFUNC DAQmxGetAIConvTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[], int32 *data);

int32 __CFUNC DAQmxSetAIConvTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[], int32 data);

int32 __CFUNC DAQmxResetAIConvTimebaseSrcEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvTimebaseSrcEx gets the More >> AI Convert >> Timebase >> Source property.

DAQmxSetAIConvTimebaseSrcEx sets the More >> AI Convert >> Timebase >> Source property.

DAQmxResetAIConvTimebaseSrcEx resets the More >> AI Convert >> Timebase >> Source property.


Get/Set/Reset AIConv_Src

int32 __CFUNC DAQmxGetAIConvSrcEx(TaskHandle taskHandle, const char deviceNames[], char *data, uInt32 bufferSize);

int32 __CFUNC DAQmxSetAIConvSrcEx(TaskHandle taskHandle, const char deviceNames[], const char *data);

int32 __CFUNC DAQmxResetAIConvSrcEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvSrcEx gets the More >> AI Convert >> Source property.

DAQmxSetAIConvSrcEx sets the More >> AI Convert >> Source property.

DAQmxResetAIConvSrcEx resets the More >> AI Convert >> Source property.


Get/Set/Reset AIConv_Rate

int32 __CFUNC DAQmxGetAIConvRateEx(TaskHandle taskHandle, const char deviceNames[], float64 *data);

int32 __CFUNC DAQmxSetAIConvRateEx(TaskHandle taskHandle, const char deviceNames[], float64 data);

int32 __CFUNC DAQmxResetAIConvRateEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvRateEx gets the More >> AI Convert >> Rate property.

DAQmxSetAIConvRateEx sets the More >> AI Convert >> Rate property.

DAQmxResetAIConvRateEx resets the More >> AI Convert >> Rate property.


Get/Set/Reset AIConv_ActiveEdge

int32 __CFUNC DAQmxGetAIConvActiveEdgeEx(TaskHandle taskHandle, const char deviceNames[], int32 *data);

int32 __CFUNC DAQmxSetAIConvActiveEdgeEx(TaskHandle taskHandle, const char deviceNames[], int32 data);

int32 __CFUNC DAQmxResetAIConvActiveEdgeEx(TaskHandle taskHandle, const char deviceNames[]);

Purpose

DAQmxGetAIConvActiveEdgeEx gets the More >> AI Convert >> Active Edge property.

DAQmxSetAIConvActiveEdgeEx sets the More >> AI Convert >> Active Edge property.

DAQmxResetAIConvActiveEdgeEx resets the More >> AI Convert >> Active Edge property.