SOLIDWORKS Installation Manager Download Folder

SOLIDWORKS Installation Manager can download the installation files it needs to a folder that you specify. This topic provides answers to frequently asked questions about the download folder.

If you are running Windows 8 and later, refer to Tips for Using SOLIDWORKS with Microsoft Windows 8 for tasks such as accessing Start or the Control Panel. These steps may vary depending on how Windows 8 is configured on your system. Consult Microsoft Windows documentation for additional instructions and options, especially for systems later than Windows 8.
Question Answer
How do I install the files in this folder?

Run setup.exe. You may still be required to download some files if you select to install items that were not downloaded previously.

Do not install using msiexec (see below).
Can I install MSI files manually from this folder using msiexec or some other application?

No. The Installation Manager does not download some files that would be required when running msiexec.
Can I select the same download folder for each version I install?

Download folders are version-specific. Starting in SOLIDWORKS 2010, SOLIDWORKS Installation Manager automatically creates a version-specific sub-folder within the specified folder.

I downloaded some products manually from the Dassault Systèmes SOLIDWORKS Corporation Web site. Can the Installation Manager install these?
Starting in SW2009, files downloaded manually can be used by SOLIDWORKS Installation Manager. However, it is better to run SOLIDWORKS Installation Manager, selecting the option to download files. SOLIDWORKS Installation Manager shows which files you need based on what you are installing, providing links to download each file. This option can be used when the built-in download page does not work (most likely because of downloading restrictions enforced by a proxy server).
If Microsoft Internet Explorer asks whether you want to save or run files during a download or installation, always specify save.
Can the files I download be shared by other users?

Yes. To do so, download to a network share. Each client can then run SOLIDWORKS Installation Manager from the share to install.

No further downloads will be required unless a user selects some items to install that were not selected during the initial download or if a computer that uses this download to install has a different set of prerequisites than the computer to which you downloaded the files.

If you are downloading on behalf of others but are not installing, select the Download Only option when installing. This option will allow you to select products regardless of what may be installed on your system. However, this option cannot be used to download patches or to create administrative images.
How do I know when a new version of SOLIDWORKS products becomes available?
You will be informed when a new version is available in the following cases:
  • If you run Check for Updates ( Start > All Programs > SOLIDWORKS Installation Manager > Check For Updates)
  • If you have enabled SOLIDWORKS Background Downloader.
  • If you select an installed version of SOLIDWORKS in Windows Add/Remove Programs and click Change
  • If you run an older version of the Installation Manager (sldIM.exe) from a download folder
In these cases, you may select to download the newer version. SOLIDWORKS Installation Manager will download and run the newer version of itself, and not any installation files. After the newer version of SOLIDWORKS Installation Manager runs, you may select a set of installation actions. SOLIDWORKS Installation Manager will then determine which installation files are needed (and not downloaded previously) and will offer to download those files.
Why does SOLIDWORKS Installation Manager not let me select a different service pack of a product to install?

Each version of SOLIDWORKS Installation Manager is designed to install only a specific version of SOLIDWORKS products. If you want to install a different service pack, you need to run that version of SOLIDWORKS Installation Manager. To find the latest version available, see the preceding item.
Why is SOLIDWORKS Installation Manager prevented from downloading files?

If proxy server restrictions prevent applications from downloading files, SOLIDWORKS Installation Manager cannot download files automatically.

You can download files manually and then install them using SOLIDWORKS Installation Manager. Select the option in SOLIDWORKS Installation Manager to download individual files (for example, Conduct manual download on the Download Options page). Based on your product selections and system requirements, a web page appears in a separate window containing links to download all required files manually. These links are identical to those provided by the SOLIDWORKS Customer Portal, but you do not need to search for the files.
Not all of my SOLIDWORKS products are updated to the latest service pack. Why does Check For Updates tell me I have the latest version?

Check For Updates only tells you whether you have installed (or are running) the latest version of SOLIDWORKS Installation Manager.

If you want to update all products to the latest version that is installed, in Add/Remove Programs, select the latest installed version of SOLIDWORKS and click Change.

Can I copy a DVD to a download folder?

Yes, but installations may fail unless you copy the entire contents of each DVD released for that platform. SOLIDWORKS Installation Manager looks for the files swdata*.id to determine the version. If these files are not present, it will fail to recognize any of the installation files that you copied and will require that they be downloaded.

Contents

  • Tips for Using SOLIDWORKS with Microsoft Windows 8

    The user interface of Windows 8 (and later) departs significantly from earlier versions of Windows. Not only are navigation techniques different, but several methods have been added to access key commands.


Legal Notices

© 1995-2018, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028; 8,910,078; 9,129,083; 9,153,072; 9,262,863; 9,465,894; 9,646,412; 9,870,436; 10,055,083; 10,073,600 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of HCL Technologies Ltd.

SOLIDWORKS 2019, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium, SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage, eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium, and SOLIDWORKS Visualize are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995)

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2018 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

D-Cubed® 2D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® 3D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® PGM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® CDM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® AEM © 2018. Siemens Industry Software Limited. All Rights Reserved.

Portions of this software © 1998-2018 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2018 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2018 DriveWorks Ltd.

© 2011, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology.

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS PDM Professional Product

Outside In® Viewer Technology, © 1992-2012 Oracle

© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2017 Open Design Alliance. All rights reserved.

The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.

Portions of eDrawings® for iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.

Portions of eDrawings® for iPad® copyright © 2003 – 2005 Apple Computer Inc.

Copyright Notices for SOLIDWORKS PCB Products

Portions of this software © 2017-2018 Altium Limited.

Copyright Notices for SOLIDWORKS Visualize Products

NVIDIA GameWorks™ Technology provided under license from NVIDIA Corporation. Copyright © 2002-2015 NVIDIA Corporation. All rights reserved.


Tips for Using SOLIDWORKS with Microsoft Windows 8

The user interface of Windows 8 (and later) departs significantly from earlier versions of Windows. Not only are navigation techniques different, but several methods have been added to access key commands.

The following topics provide instructions on how to access three of the most basic functions with Windows 8. Refer to these topics when using Windows 8 to install SOLIDWORKS.
These steps may vary depending on how your Windows system is configured. Consult Microsoft Windows documentation for additional instructions and options, especially for systems later than Windows 8.
Parent topic SOLIDWORKS Installation Manager Download Folder