SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）

このガイドは SOLIDWORKS 製品の個人インストレーションと複数インストレーションの両方におけるインストレーション、ライセンス管理、アップグレード、管理について説明します。

個人インストレーション | 複数インストレーションの展開
インストール 1台または数台のコンピュータへのインストレーション。 | インストール 複数のクライアント コンピュータに展開するアドミニストレーティブ イメージの作成。
ライセンス契約（Licensing） マシン アクティベーション、オンライン ライセンス、またはネットワーク ライセンス。 | ライセンス契約（Licensing） マシン アクティベーション、オンライン ライセンス、またはネットワーク ライセンス。
アップグレード 各コンピュータを新しいリリース版に移行。 | アップグレード コンピュータへのインストールに使用したアドミニストレーティブ イメージのアップデートにより複数のコンピュータを新しいリリース版に移行。
管理 インストレーションの変更、修復、削除、および新しいリリースへのアップグレード。 | 管理 アドミニストレーティブ イメージとクライアント、およびネットワーク ライセンス管理のアップグレード

SOLIDWORKS Installation Manager は、SOLIDWORKS、SOLIDWORKS Toolbox、PhotoView 360、SOLIDWORKS Electrical、SOLIDWORKS Manage、SOLIDWORKS PDM、SOLIDWORKS PCB、SOLIDWORKS Visualize、および SOLIDWORKS SolidNetWork License Manager を含む SOLIDWORKS 製品コンポーネントの設定を構成できるようにします。

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

SOLIDWORKS Admin Portal は、クラウドベースのアセットおよびサービス管理システムで、オンライン ライセンスを割り当ておよび管理できます。 ライセンスの割り当ては、オンライン ライセンスにのみ必要です。 その他のライセンス タイプの場合、ライセンスの割り当てはオプションです。

目次

  • 個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

    SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

  • システムおよびソフトウェア要件の確認

    インストール前に、システムがハードウェア、オペレーティング システムおよび Microsoft 製品の要件を満たしていることを確認します。 SOLIDWORKS Electrical および SOLIDWORKS Visualize などのアドイン、および eDrawings には、別の要件があるので注意してください。

  • SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）

    SOLIDWORKS インストレーションを開始するには、ローカル コンピュータで DVD を読み込むか、共有インストレーション ディレクトリにアクセスするか、または SOLIDWORKS からダウンロードします。


個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

一台のコンピュータのみにインストールする場合や数百台のコンピュータにインストールする場合、この選択は明らかです。それ以外の場合は、次の比較を参考にしてください。

個人インストレーション | アドミニストレーティブ イメージ
各ユーザーが個人的に SOLIDWORKS を管理できます。 | システム管理者はオプション エディタを使って、複数のインストレーションをカスタマイズすることができます。新規インストレーションを作成したり、あるいは既存のものを更新するインストレーション オプションを指定したり、アドミニストレーティブ ユーザーとして起動したり、インストレーションの前後に外部コマンドを実行したり、異なる製品のグループ分けを行います。
インストレーションを実行する個人が、コンピュータに物理的にアクセスできなければなりません。 | クライアント コンピュータが同じネットワーク上でアクセス可能な限り、物理的な距離は問題ありません。
異なるバージョン、ServicePack、製品を、別々のコンピュータ上に独自の設定でインストールできます。 | オプション エディタを使って、アドミニストレーティブ イメージはバージョン、Service Pack、製品、設定の一貫性を維持することができます。
コンピューターには、ネットワークまたは電子メールへのアクセスが必要です。 SOLIDWORKS をアクティブ化してファイルをダウンロードするには、ネットワークまたは電子メールの接続が必要です。 また、ネットワーク ライセンス サーバーからライセンスを収集するには、ネットワークへのアクセスが必要です。 | アプリケーションを展開するには、ローカル ネットワークが接続されている必要があります。クライアント コンピュータ上にメディア ドライブは必要ありません。 クライアントは自動的にアップデートされます。 同じアドミニストレーティブ イメージから展開されたすべてのクライアントが同じServicePackになります。 複数のバージョンを維持するには、複数のアドミニストレーティブ イメージを作成します。 ライセンスのアクティベーションを自動的に行うことができます。 アドミニストレーティブ イメージは、サーバー上の追加のディスク容量を必要とします。クライアントは、個別インストレーションと同じ容量を必要とします。
親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
システムおよびソフトウェア要件の確認
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


システムおよびソフトウェア要件の確認

インストール前に、システムがハードウェア、オペレーティング システムおよび Microsoft 製品の要件を満たしていることを確認します。 SOLIDWORKS Electrical および SOLIDWORKS Visualize などのアドイン、および eDrawings には、別の要件があるので注意してください。

現在のシステム要件にアクセスするには、http://solidworks.com/System_Requirements を参照してください。

親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）

SOLIDWORKS インストレーションを開始するには、ローカル コンピュータで DVD を読み込むか、共有インストレーション ディレクトリにアクセスするか、または SOLIDWORKS からダウンロードします。

SOLIDWORKS インストールを開始するは、次のいずれかを行います。

  • ローカル コンピュータにディスクからインストールするには、適切なディスクをディスク ドライブに挿入します。
  • ダウンロード ディレクトリからインストールするには、ディレクトリまで移動し、setup.exe をダブルクリックします。
  • SOLIDWORKS からダウンロードしてインストールするには、以下を行います。
    1. SOLIDWORKS Web サイトまで参照します。
    2. Subscription サービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SOLIDWORKS シリアル番号を入力します。
    3. セルフ サービス（Self Service）で、ソフトウェアとアップデートのダウンロード（Download Software and Updates）をクリックします。
    4. ソフトウェアのダウンロード （Windows、Mac、Linux）で、ダウンロードする SOLIDWORKS のバージョンとサービス パックを選択します。
親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
システムおよびソフトウェア要件の確認


個人インストレーション（Individual Installations）

目次

  • 個人コンピュータでのインストール（Installation on Individual Computers）

    SOLIDWORKS は、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。

  • 個人インストレーションの管理（Administration of Individual Installations）

    通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。


個人コンピュータでのインストール（Installation on Individual Computers）

SOLIDWORKS は、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。

SOLIDWORKS Installation Manager はインストレーションを購入した製品に合うように調整し、インストレーションを実行します。 インストレーションを開始する前に、以下を行います。

  • SOLIDWORKS シリアル番号をお手元に準備してください。
  • インターネット接続された環境であることを確認してください。 権利をチェックするには、接続が必要です。

SOLIDWORKS Installation Manager は、Microsoft Windows インストーラ、Microsoft Visual Studio Tools for Applications、Visual Basic、および .NET Framework を含むさまざまな Microsoft コンポーネントを必要とします。 すべての Windows 前提条件コンポーネントの正しいバージョンがコンピュータにインストールされていない場合、SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストールする前に、これらのコンポーネントを自動的にインストールします。 Bonjour service for Windows も必要なコンポーネントです。

インストレーション方法 | プロセスの概要
SOLIDWORKS インストレーション メディアを使用 | DVD ディスクをコンピュータのディスク ドライブに挿入します。
サーバー上のダウンロード ディレクトリを使用 ダウンロード先のディレクトリで、setup.exe をダブルクリックします。

ダウンロード ディレクトリは、SOLIDWORKS 製品をインストールするコンピュータからアクセス可能であり、インストレーションの開始前にすべての SOLIDWORKS インストレーション ファイルが含められている必要があります。 SOLIDWORKS Installation Manager は、ダウンロード ディレクトリに対するインターネット アクセスと書き込みアクセスがある場合、見つからないファイルを探すのに役立ちます。

アップデート チェック を使用して既存の SOLIDWORKS インストレーションを更新 次のいずれかを行います。
  • SOLIDWORKS で ヘルプ > アップデート チェックをクリックします。
  • Windows で スタート > すべてのプログラム > SOLIDWORKS Installation Manager > アップデート チェックをクリックします。
動作しているインターネット接続とマシンの管理者権限が必要です。
SOLIDWORKS カスタマー Web サイトからのダウンロード
  1. SOLIDWORKS Web サイトを参照します。
  2. Subscription サービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SOLIDWORKS シリアル番号を入力します。
  3. セルフ サービス (Self Service) で、ソフトウェアとアップデートのダウンロード (Download Software and Updates) をクリックします。
  4. ソフトウェアのダウンロード (Download Software) で、インストールする SOLIDWORKS バージョンをクリックします。
動作しているインターネット接続が必要で、ユーザーはカスタマー ポータル サイトへのログイン アクセス権を持つ、Subscription サービス契約中のユーザーでなければなりません。

インストレーションが完了したら、SOLIDWORKS アプリケーションおよびライセンス アクティベーションを開始します。

マシンにインストールされている製品のリストを表示するには、SOLIDWORKS メイン メニューから、ヘルプ（Help） > マイ製品（My Products）をクリックします。ダイアログ ボックスのチェック マークは、ユーザーまたはユーザーの組織が所有している製品を、アクティベーションおよびネットワーク ライセンスに基づいて示しています。 また、各製品カテゴリの先頭にあるリンクをクリックすることで、SOLIDWORKS 製品の詳細を確認できます。

どのライセンスが使用中であるかを確認するには、Windows で、スタート（Start） > SOLIDWORKS <バージョン> > SOLIDWORKS ツール（SOLIDWORKS Tools） > SolidNetWork License Manager Client > ライセンスの使用状況（License Usage）タブをクリックします。

親トピック 個人インストレーション（Individual Installations）
関連概念
個人インストレーションの管理（Administration of Individual Installations）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


個人インストレーションの管理（Administration of Individual Installations）

通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。

目次

  • インストレーションの変更（Modifying an Installation）

    インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  • 新しいリリースへのアップグレード（Upgrading to a New Release）

    個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

  • 製品の共存ルール（Product Coexistence Rules）

    製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

親トピック 個人インストレーション（Individual Installations）
関連概念
個人コンピュータでのインストール（Installation on Individual Computers）


インストレーションの変更（Modifying an Installation）

インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

SOLIDWORKS をインストールした後でアドインを購入した場合は、新規のアドインが含まれるようにインストレーションを変更できます。 アドインは個別のコンピュータにインストールする必要があります。

  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. Windows 7 以降では、スタート > コントロール パネル >プログラムと機能 をクリックします。
  3. 変更したい SOLIDWORKS インストレーションを選択してから、変更 をクリックします。
  4. SOLIDWORKS Installation Manager へようこそ (Welcome to the SOLIDWORKS Installation) 画面で、（Modify the individual installation （on this computer））をクリックします。 をクリックします。
  5. シリアル番号 画面で適切なシリアル番号が指定されていることを確認します。
  6. 製品選択 画面でインストールまたは削除する製品を選択します。
    インストレーションの変更は以下のようになります。
    • 新しいシリアル番号を指定した場合も、デフォルトでインストールまたは削除される製品はありません。 それぞれの製品や機能コンポーネントのインストール動作を変更する必要があります。
    • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。 製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
    • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。 （たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
    • 初期の指定からコンポーネントのインストール動作を変更すると、アスタリスク（*）がリスト内のそのコンポーネントの横に表示されます。
    • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
    • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
  7. サマリー 画面で、今すぐ変更 をクリックします。
  8. インストレーション完了 画面で、完了 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）


インストールの修復（Repairing an Installation）

もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

ただし、インストールを修復するには、以前のインストールのすべてのソース ファイルと、適用されたすべてのサービス パックが、最初のインストール ロケーションになければなりません。

個人インストレーションは修復できます。 アドミニストレーティブ イメージは修復できません； アドミニストレーティブ イメージをアンインストールして、次に再インストールしなければなりません。
  1. Windows 7 以降で スタート > コントロール パネル > プログラム > プログラムと機能 をクリックします。
  2. 修復する SOLIDWORKS バージョンを選択し、変更 をクリックします。
  3. SOLIDWORKS Installation Manager へようこそ (Welcome to SOLIDWORKS Installation Manager) 画面で （Repair the individual installation (on this computer)）をクリックします。 をクリックします
  4. 修復する製品 画面で、修復する製品を選択します。
  5. スクリーン上で残りの製品を選択解除します。
  6. 修復 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

個人インストレーションを現在のメジャー リリース ファミリー内の以前のServicePackリリースにロールバックするには、コンピュータに現在インストールされているServicePackバージョンをアンインストールしてから、以前のバージョンを再インストールします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
インストレーションの削除（Removing an Installation）


インストレーションの削除（Removing an Installation）

個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. SOLIDWORKS ライセンスを別のコンピュータに移動する場合は、コンピュータから SOLIDWORKS インストレーションを削除する前に、そのコンピュータのライセンスを非アクティブにしてください。
    詳細は、ライセンスの移動を参照してください。
  3. Windows 7 以降の場合は、コントロール パネル > プログラムと機能 を起動します。
  4. 削除する製品を選択します。
    場合によっては、特定のメジャー リリース バージョンに対して複数の SOLIDWORKS ServicePack コンポーネントが存在するかもしれません。 SOLIDWORKS メジャー リリースを削除するには、そのメジャー リリースに対するすべての SevicePack 要素を削除します。
  5. アンインストール 画面で:
    1. 削除する製品を選択します。 すべての製品コンポーネントがデフォルトで選択されています。
    2. 削除したくない製品を選択解除します。
    3. カスタム アンインストールか完全なアンインストールを選択します。 SOLIDWORKS Installation Manager では、デフォルトで一般的なアンインストールが実行され、プログラム ファイルとフォルダが削除されます。
      1. 変更 を 詳細設定オプション でクリックします。

        詳細設定オプション 画面が表示されます。プログラム ファイルとフォルダのオプションが選択されています。

      2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
      3. サマリーに戻る（Back to Summary）をクリックします。
      4. サマリー の画面で、詳細設定オプション を展開し、アンインストールの方法を表示します。
    4. アイテムを削除 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
親トピック 複数インストレーションの管理（Administration of Multiple Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
ライセンスの移動


新しいリリースへのアップグレード（Upgrading to a New Release）

個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

次の場合に新しいリリースにアップグレードすることができます。
  • 新しいインストレーション メディアを受け取った
  • SOLIDWORKS の開始時にアップグレードが通知された
  • マニュアルでのアップデート チェックを行った
  • 新しいインスタンスの SOLIDWORKS Installation Manager を開始した

新しいメジャー リリースのインストール時には、前にインストールしたメジャー リリースをアップグレードするか、または新しいリリースを並行してインストールできます。インストール済みのメジャー リリースに対するServicePackリリースをインストールする場合、このリリースは自動的にアップデートされます。

親トピック 個人インストレーションの管理（Administration of Individual Installations）
関連概念
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）

マニュアルでのアップデート チェック（Checking for Updates Manually）

マシンの管理者権限を持つユーザーは、現在インストールされている SOLIDWORKS リリースのアップデート チェックを、以下のいずれかの方法を使用して実行できます。

  • SOLIDWORKS で ヘルプ（Help） > アップデート チェック（Check for Updates）をクリックします。
  • Microsoft Windows で スタート（Start） > すべてのプログラム（All Programs） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします。

アップグレードの注意点（Upgrade Caveats）

メジャー バージョンが異なる複数のインストレーションが許可される製品の場合は、メジャー アップグレードがサポートされない、あるいは次のメジャー バージョンへのアップグレードが一度の作業で可能でない場合があります。

このような場合、SOLIDWORKS Installation Manager は先ず新規バージョンをインストールし、続いて古いバージョンを削除することにより、アップグレードを実行しようします。 現時点では、SOLIDWORKS のコア製品はメジャー バージョンのアップグレードをサポートしますが、その他の製品はサポートしません。

この結果、以下のようになります。
  • SOLIDWORKS のコア製品のメジャー バージョン アップグレードを行う場合:
    • 既存のインストレーション場所は変更しません。
    • アップグレード中にエラーが発生したり、キャンセルをした場合、アップグレードをロールバックできます。
  • その他の製品のメジャー バージョン アップグレードを行う場合:
    • 各製品は、先ず新規製品として新しい場所にインストールされ、続いて元のインストレーションが削除されます。
    • 一度アップグレードを開始すると、エラーが発生したり、キャンセルをした場合でも、アップグレードをロールバックすることはできません。


製品の共存ルール（Product Coexistence Rules）

製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

ルール | 例
以下に示す製品を除いて、複数のメジャー リリース バージョンのコア SOLIDWOKRS 製品が許可されます。 | SOLIDWORKS 2018 SP3.0 と SOLIDWORKS 2019 SP0.0 は 1 台のコンピュータに共存できます。
同じメジャー リリース バージョンの複数のサービス パックは許可されません。 | SOLIDWORKS 2019 SP0.0 と 2019 SP1.0 は 1 台のコンピュータに共存できません。 SOLIDWORKS 2019 SP0.0 が既にインストールされているコンピュータに SOLIDWORKS 2019 SP1.0 をインストールすると、SOLIDWORKS Installation Manager によって SP0.0 が SP1.0 に置き換えられます。
次の製品は、1台のコンピュータで 1 つのバージョンのみが許可されます。
  • SolidNetWork License Manager
 SOLIDWORKS 2019 SP0.0 がインストールされている場合（それ以前の SOLIDWORKS メジャー リリースがコンピュータ上に残っている場合でも）、SolidNetWork License Manager は 2019 SP0.0 にアップグレードされます。
次の製品は、1 台のコンピュータで 1 つのバージョンのみが許可されます。
  • SOLIDWORKS Electrical
 SOLIDWORKS Electrical 2019 SP1.0 の新規インストレーションを作成する場合は、SOLIDWORKS Installation Manager によって、それより前のバージョンの SOLIDWORKS Electrical がマシンから自動的に削除されます。 アップグレードする前に SOLIDWORKS Electrical 環境をバックアップしてください。
次の製品は、1台のコンピュータで 1 つのバージョンのみが許可されます。
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

SOLIDWORKS 2019 SP0.0 または SP1.0 をインストールした場合、SOLIDWORKS 2019 PDM Server や PDM Client もアップグレードする必要があります。

SOLIDWORKS 2019 PDM Server をインストールした場合、PDM Server のインストール プロセスを使用して SOLIDWORKS PDM Client をインストールする必要があります。 SOLIDWORKS PDM Client をクライアントのインストール プロセスと別にインストールしないでください。

同じマシン上の SOLIDWORKS PDM Server と SOLIDWORKS PDM Client は同じリリース バージョンとサービス パックである必要があります。

詳細については、SLDIM による PDM サーバーのインストールに関するトピックを参照してください。

SOLIDWORKS に含まれる製品は、各メジャー リリース バージョンについて 1 つのバージョンのみインストールできます。 ただし、異なるメジャー リリース バージョンの SOLIDWORKS に含まれる製品は共存できます。 | SOLIDWORKS 2019 SP0.0 が 2019 SP1.0 にアップグレードされると、SOLIDWORKS Explorer 2019 SP0.0 は自動的に 2019 SP1.0 にアップグレードされます。ただし、SOLIDWORKS Explorer 2018 SP4.0 は SOLIDWORKS Explorer 2019 SP0.0 や SOLIDWORKS Explorer 2019 SP1.0 と共存できます。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）


複数インストレーション（Multiple Installations）

目次

  • 複数クライアントへの展開（Deploying to Multiple Clients）

    アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

  • アドミニストレーティブ イメージの使用（Using Administrative Images）

    アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

  • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

    共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

  • コマンドラインによる展開（Command-Line Deployment）

    コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

  • 複数インストレーションの管理（Administration of Multiple Installations）

    複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。


複数クライアントへの展開（Deploying to Multiple Clients）

アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

複数クライアントに展開する手順は、以下のようになります。
  1. アドミニストレーティブ イメージを作成します。
    • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）
  2. アドミニストレーティブ イメージをクライアントに展開します。
    • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
    • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
  3. ライセンス管理 を行います。
    • 個人ライセンスの管理（Administering Individual Licenses）
    • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
親トピック 複数インストレーション（Multiple Installations）
関連概念
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


アドミニストレーティブ イメージの使用（Using Administrative Images）

アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

ネットワーク上のクライアント コンピュータを含む任意のコンピュータから、アドミニストレーティブ イメージをインストールできます。
  • アドミニストレーティブ イメージは必ず共有フォルダに保存してください。
  • すべての製品を含むと、アドミニストレーティブ イメージには7GB かそれ以上のディスク容量が必要です。
  • アドミニストレーティブをアップグレードするときに、共有名を更新した場合、クライアントは、次の機会にアプリケーションを開始すると、アップグレードされます。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。
  • アドミニストレーティブ イメージを展開するときは、イメージのパスを 58 文字以内にする必要があります。
  • クライアントには、各自のコンピュータにおける管理権限が必要です。 クライアントは、十分な権限がない場合、別のユーザーとしてインストールを実行できます。 本オプションが役立つのは、個別のユーザーが使用中のマシンで SOLIDWORKS 製品のインストールに必要なローカル管理権限を持っていないときです。

    オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）を参照してください。 クライアントに十分な権限がないときにイメージをインストールする、別の方法についても説明されています。

  • Windows ログが有効な場合、またはアドミニストレーティブ イメージ オプション エディタでステータス機能を使用している場合、次のフォルダに対して読み取り/書き込み権限を持っている必要があります: {Administrative image directory}\x64\Logs.

アドミニストレーティブ イメージを作成すれば、アドミニストレーティブ イメージ オプション エディタを用い、そのイメージからインストールするユーザーとグループに対するインストレーション オプション設定を管理することが可能です。 詳細については、SOLIDWORKS アドミニストレーティブ イメージ オプション エディタ (Administrative Image Option Editor)を参照してください。

目次

  • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

    SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

親トピック 複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
アドミニストレーティブ イメージ オプション エディタ


SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

  1. SOLIDWORKS Installation Manager を起動します。 SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）を参照してください。
  2. ようこそ 画面で アドミニストレーティブ イメージ を選択します。
    アドミニストレーティブ イメージの作成オプションが表示されます。
    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. 画面上の指示に従います。

目次

  • アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

    アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

親トピック アドミニストレーティブ イメージの使用（Using Administrative Images）
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

アドミニストレーティブ イメージを作成した後で、SOLIDWORKS Installation Manager はオプション エディタを開始するように要求します。 オプション エディタは、アドミニストレーティブ イメージ フォルダにある sldAdminOptionEditor.exe をダブルクリックにより、後から起動することも可能です。

マシンのグループまたは個々のマシンに対して異なるインストール構成を指定するには、オプション エディターで、次のいずれかを指定してマシンを選択します。
  • マシン名
  • IP アドレス
  • IP アドレスの範囲
次に、これらのマシンに対してインストール オプションを指定します。
ファイルまたはフォルダのパスを要求するすべてのダイアログ ボックスに、選択したフォルダを環境変数に割り当てることができるオプションがあります。 たとえば、C:\Program Files\SOLIDWORKS Corp を選択した場合、ファイル パスは %ProgramFiles%\SOLIDWORKS Corp にマッピングされます。最も一般的な変数は、%ProgramFiles% と %SystemDrive% です。 また、すべてのパスを環境変数に変換できるわけではありません。 たとえば、Z:\SOLIDWORKS Data は、環境変数にマッピングできません。

目次

  • グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

    アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

  • オプション設定の表示と編集（Viewing and Editing Option Settings）

    SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • 設定アドミニストレータ ツール

  • オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

    手動またはプッシュによる方法を用いて、オプション エディタから直接インストレーションを展開することが可能です。

  • オプション エディタの終了（Exiting the Option Editor）

    オプション エディタを閉じるには、OKまたは閉じるをクリックします。

  • オプション エディタに対するデスクトップ ショートカットの作製

    特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

親トピック SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）


グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

例えば、いくつかのマシンではイメージに含まれる使用可能な製品コンポーネントの特定のサブセットを使用するように設定したいが、その一方で別のグループは異なる製品コンポーネントのサブセットを使用する場合もあります。オプション エディタのグループ設定は1つのアドミニストレーティブ イメージを使用しているにもかかわらず、異なるマシンのグループに異なる製品のサブセットをインストールできるようにします。

グループを追加するには:
  1. グローバル設定を右クリックし、グループ追加をクリックします。
  2. グループ名を入力します。

マシンを追加するには:
  1. 既存のグループまたはグローバル設定を右クリックし、マシン追加をクリックします。
    既存のグループを右クリックした場合、マシンはそのグループに追加されます。 他の場合、マシンはトップレベルに追加されます。
  2. 次のいずれかを行います:
    • マシン名（By Machine Name）を選択し、1 つ以上のマシン名を入力します。 複数のマシンが改行、スペース、タブ、カンマ、ピリオド、コロン、あるいはセミコロンによって分けられます。 外部ファイルからマシン名のリストをコピー/ペーストすることができます。 マシンはドメイン名を含むことができません。 例えば、pluto.solidworks.comは無効です。
    • IP アドレス（By IP Address）を選択し、マシンの IP アドレスを入力します。
    • IP アドレスの範囲（By IP Address Range）を選択し、指定する範囲の開始 IP アドレスと終了 IP アドレスを入力します。
    • 複数のマシン追加をクリックして、ネットワークからマシンを選択します。

既存のマシンをグループに移動するには:

グループにマシンをドラッグします。

既存のマシンをグループ外に移動するには:

グローバル設定にマシンをドラッグするか、他のグループにドラッグします。

グループ、マシンを削除するには:

グループまたはマシンを右クリックし、グループ削除またはマシン削除をクリックします。

グループを削除した場合、グループ内のすべてのマシンは削除されます。

すべてのグループとマシンを削除するには:

グローバル設定を右クリックし、すべて削除をクリックします。

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
設定アドミニストレータ ツール
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


オプション設定の表示と編集（Viewing and Editing Option Settings）

SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタを最初に起動すると、オプション設定が読み取り専用モードで表示されます。 編集アイコンは押された状態になっていません。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定のサマリが表示されます：

    スコープ（Scope） | 表示されるオプション設定
    グローバル設定 | アドミニストレーティブ イメージに対して指定されたすべてのオプション設定
    グループ | グローバル設定と比較してグループ設定で変更された内容
    工作機械 | グループ設定と比較してマシン設定で変更された内容
  • オプション設定を変更するには、編集アイコンをクリックします。 アイコン表示が押された状態になり、より詳細なオプション設定の一覧が表示されます。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定が変更可能です。 変更により、グローバル設定やグループ設定から継承された設定とは異なったオプション設定は、ハイライト表示が行われます。

    編集アイコンを再度クリックすると、表示は読み取り専用モードに戻ります。

    変更を行った場合は、オプション エディタの終了時に、それらの保存または破棄が要求されます。

目次

  • グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

    すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  • アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

    オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

  • グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

    グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

  • 各マシンの設定のカスタマイズ

    マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
設定アドミニストレータ ツール
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製


グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  1. オプション エディタで、修正するオブジェクト（グローバル設定、グループ、またはマシン）をクリックします。
  2. 右側の編集アイコンをクリックします。
    編集アイコンが押された状態になり、より詳細なオプション設定の一覧が表示されます。
  3. 左側で選択されたアイテムに対する右側のオプション設定をクリックすることにより、それらを変更します。
    グローバル設定やグループ設定をオーバーライドするオプション設定の変更は、ハイライト表示されます。
  4. OKまたは閉じるをクリックして、変更内容を保存します。
    オプション | 説明
    OK | 変更内容が保存され、オプション エディタが終了します。
    閉じる（Close） | 変更内容を保存するか否かについてユーザーに質問を行い、その対応を受けた後、オプション エディタを終了します。
親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

シリアル番号（Serial Numbers）

クライアント マシンにインストールされる製品のシリアル番号を入力します。
SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。
ライセンス管理を SolidNetWork ライセンスを用いて行っている場合：
  • 最初のシリアル番号フィールドにSolidNetWorkのシリアル番号を入力します。
  • SNLサーバー ポート@サーバー フィールドに SolidNetWork License Manager のサーバー名とポートを nnnnn@サーバー名 の形式で入力します。 複数のエントリはセミコロンにより区切ってください。

SolidNetWork ライセンスの詳細は、SolidNetWork ライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）を参照してください。

クライアント インストレーション オプション（Client Installation Options）

メジャー バージョンのクライアント インストールどの方法で行いますか? クライアントのインストールでは、インストール済みの古いメジャー バージョンの取り扱い方法を指定できます：
  • 既存のメジャー バージョン（存在する場合）をアップグレードします。

    インストール済みの古いメジャー バージョンを新しいバージョンのインストールで置き換えるには、このオプションを指定します。

  • 新規メジャー バージョンを作成します。

    インストール済みの古いメジャー バージョンを保持したまま、新しいメジャー バージョンをインストールするには、このオプションを指定します。 新しいバージョンのインストール先を指定するには、参照（Browse）をクリックします。
新しいメジャー バージョンをインストールする前に、最も最新の前のバージョンをアンイストールしますか? インストール済みの古いメジャー バージョンをアンインストールするかどうかを指定できます:
  • いいえ、最初にアンインストールしません:

    古いメジャー バージョンを保持する場合に選択します。

  • はい、カスタム アンインストールを実行します:

    次のアイテムを削除する場合に選択します:初期のインストールにより作成された データ ファイルとフォルダ 。

SOLIDWORKS 設定をどのように適用しますか? SOLIDWORKS のクライアント インストールが起動時に参照する設定ファイルを指定することができます。 設定（*.sldsettings）ファイルは、すべてのインストールで表示可能な共有 UNC パスに配置されている必要があります。 SOLIDWORKS をインストールする前に、*.sldsettings パスを指定する必要があります。 クライアント インストールは、インストール中に *.sldsettings ファイル パスを通知します。
指定したユーザーのみ書き込みアクセス権を許可するように Windows のファイル権限を設定することによって、*.sldsettings ファイルを保護します。

*.sldsettings を作成または編集するには、設定アドミニストレータ実行（Launch Settings Administrator）をクリックします。 SOLIDWORKS 設定アドミニストレータ（Settings Administrator）では、どの SOLIDWORKS システム オプションを組織内のエンド ユーザーに適用し、オプションでロックするかを定義できます。 設定がいつどのように個々のインストールに適用されるかを定義することもでき、設定アドミニストレータ（Settings Administrator）を実行して、既存ファイルを上書きすることにより、*.sldsettings ファイルをいつでも変更できます。

さまざまなマシンまたはグループに対して、異なる *.sldsettings ファイルを使用できます。

*.sldsettings へのパスはインストール時に設定されます。 展開後は、*.sldsettings ファイルの名前を変更したり、移動したりしないでください。

設定アドミニストレータ（Settings Administrator）を実行するには、既存の SOLIDWORKS 2019 [現行メジャー バージョン] のインストールが必要です。
クライアント インストレーションはどの方法でアクティブ化しますか? ライセンスのアクティブ化は、インストール後に自動で完了するか、あるいはユーザーが手動で行うかを選択することが可能です。
自動的な製品のアクティブ化を指定した場合、インストレーション後にクライアントが初めて SOLIDWORKS を実行する際、共有ネットワーク上にアドミニストレーティブ イメージが準備されている必要があります。 アドミニストレーティブ イメージからインストールしたクライアントがアドミニストレーティブ イメージにアクセスできない場合、クライアントは自動的に製品をアクティブ化することができません。 SOLIDWORKS 製品を手動でアクティブ化しない限り、SOLIDWORKS を実行することができません。
  • 各クライアント インストレーションが完了した時点で自動的にアクティベーションを行います。

    オプションを選択すると、アクティベーションは SOLIDWORKS 製品アクティベーション ファイルを使用して自動的に実行されます。 （一般的に、ファイル名は AutoActivation.xml です）。参照（Browse）をクリックして既存のアクティベーション ファイルを指定するか、新規作成（New）をクリックして SOLIDWORKS 製品アクティベーションを開始し、新しいアクティベーション ファイルを作成します。

  • 自動的にアクティブ化しません。

    オプションを選択すると、製品は自動的にアクティブ化されません。 クライアントは、インストレーション後に製品をアクティブ化します。

アドミニストレーティブ オプション（Administrative Options）

各インストレーションに対して診断ログ ファイルを作成します。 | クライアントのインストールでは、インストール時に発生した問題のトラブルシューティングに利用可能な診断ログを作成できます。 このログを作成すると、クライアントのインストール速度が遅くなります。 ログ ファイルは、アドミニストレーティブ イメージ ディレクトリ}\x64\Logs\<マシン名>\Status.xml に格納されます。
別ユーザーとしてインストレーションを実行。

クライアントのインストールは異なるユーザーで実行できます。 このオプションは、個別のユーザーが、使用中のマシンで SOLIDWORKS 製品のインストールに必要なローカル管理権限を持っていない場合に便利です。

クライアントが管理権限を持っていない場合、展開とインストールは別の方法で実行できます。 オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）を参照してください。
インストレーションの前後に実行するプログラム。 | クライアントのインストール前後におけるユーザー定義プログラムの実行を指定できます。
クライアントは SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムに参加しますか? | クライアント マシンの SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムへの参加を指定できます。 パフォーマンス インフォメーションが、製品改善の手助けの為に SOLIDWORKS Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 詳細は Customer Experience Improvement Program Web サイトを参照してください。

インスレーションの前にプログラムを作動 (Run a Program Before Installation) オプションおよび インスレーションの後にプログラムを作動 (Run a Program After Installation) オプション

これらのオプションを使用すると、SOLIDWORKS を展開する前または後に他のインストール プログラムまたはスクリプト（例: Microsoft Office をインストールするスクリプト）をクライアント マシンで実行できます。

Windows 8 以降のクライアント マシンに自動的に展開する場合は、これらのオプションの使用に関する制限があります。 いずれかのオプションを使用して、ユーザー インタフェースを表示するインストール プログラムまたはスクリプト（例: ダイアログ ボックスを表示するスクリプト）を展開した場合、失敗が生じます。 SOLIDWORKS の自動展開が実行されても、SOLIDWORKS がターゲット マシンにインストールされません。 この制限は、Windows 7 クライアント マシンでは発生しません。

インストレーションの前にプログラムを作動（Run a program before installation） オプションと インストレーションの後にプログラムを作動（Run a program after installation） オプションを使用するには、サイレント モードでインストール可能なプログラムのみを選択する必要があります。

インストールするソフトウェア

インストールする SOLIDWORKS 製品は指定することが可能です。
  • クライアントのインストール中にインストールされる製品コンポーネントを指定するには、コンポーネントの隣にあるチェックボックスを選択します。
  • チェックボックスの選択を解除すると、そのコンポーネントはインストールされません。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
言語 仕様はインストールされる言語を SOLIDWORKS 製品についてのみ限定します。 その他の製品のインストレーションはこの仕様では影響されません。 たとえば、eDrawings®、SOLIDWORKS Explorer ではすべての言語版がインストールされます。

Toolbox オプション

クライアントのインストールに対しては、サポートする規格とデフォルトの Toolbox の場所を指定することが可能です。

Toolboxへのアクセスはネットワーク上のフォルダを、UNCパス、共有フォルダ、共通のネットワーク ドライブ指定等を用い、複数のユーザーで共有することが一般的です。

該当する場所に古いメジャー バージョンのToolboxが存在する場合は、クライアントのインストール時に新しいメジャー バージョンのToolboxにアップグレードされます。 このファイルは、古いメジャー バージョンの SOLIDWORKS との互換性を持ちません。
一部のユーザーが古いバージョンの SOLIDWORKS を継続使用する場合等、そのバージョン用の Toolbox を保持したい場合には、新しいバージョンにアップグレードするための Toolbox 用に異なるネットワーク ロケーションを指定する必要があります。

SOLIDWORKS Toolbox の管理に関する詳細は、SOLIDWORKS ヘルプの Toolbox 情報を参照してください。

SOLIDWORKS PDM Client オプション

SOLIDWORKS PDM のクライアントとアドインを配布する際に、次のオプションを選択できます:

  • PDM 製品のタイプ
  • PDM クライアントの種類
  • フィーチャー

これらのクライアントやアドインの詳細については、SOLIDWORKS PDM のセクションを参照してください。

Electrical オプション

SOLIDWORKS Electrical の管理コンポーネントに次のパラメータを指定できます。
  • データ パス
  • Collaborative Server マシン名とポート番号
  • SQL Server マシン名とパスワード

これらのコンポーネントの詳細については、SOLIDWORKS Electrical を参照してください。

親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
SOLIDWORKS Electrical
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）


グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

例：
  • グローバル設定（Global Settings）に定義された設定は、すべてのグループとマシンに継承されます。
  • グループのために定義された設定は、そのグループの中ですべてのマシンに継承されます。

マシン、またはグループのオプション設定で、デフォルトを上書きするか、設定を継承するかを変更することができます。オプション設定をデフォルト、またはその継承された値から変えるとき、そのオプションはハイライトされます。

オプション設定を元の継承された値に戻すには、グループまたはマシンを右クリックしてからグローバル設定に戻す（Revert to Global Settings）（グループ メンバーではないグループまたはマシンの場合）、あるいはグループ設定に戻す（Revert to Group Settings）（グループ メンバーであるマシンの場合）をクリックします。
親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
各マシンの設定のカスタマイズ
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


各マシンの設定のカスタマイズ

マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

ショートカット メニューから、各マシンに対して以下の操作を実行できます。
  • エディターからのマシン削除
  • グローバル設定に戻す
  • 注記の追加または編集
  • 編集オプション

[編集オプション]（Edit options）では、クライアント インストール オプションやアドミニストレーティブ オプションなど、そのマシンのすべてのオプションを変更できます。

親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


設定アドミニストレータ ツール

設定アドミニストレータ ツールを使用して、SOLIDWORKS ソフトウェアを展開またはアップグレードするときに適用されるシステム オプションを設定し、ユーザーがそれらのオプションを変更できないようにすることができます。 このツールは、設定を展開するための設定のコピー ウィザードの代替ですが、設定のコピー ウィザードも設定のコピーに利用できます。

設定アドミニストレータ ツールを使用するためのステップが 3 つあります。
  1. ツールにアクセスするためのアドミニストレーティブ イメージを作成します。
  2. 設定アドミニストレータを使用して、選択した SOLIDWORKS オプションを含む *.sldSettings ファイルを生成します。
  3. *.sldSettings ファイルを SOLIDWORKS インストレーションに含めます。

目次

  • 設定アドミニストレータ ツールにアクセスする

    設定アドミニストレータ ツール（Settings Administrator Tool）にアクセスするには、まずアドミニストレーティブ イメージを作成する必要があります。

  • 設定アドミニストレータ ツールの使用

  • オプションの適用およびロック

  • オプション設定を終了

  • SOLIDWORKS インストレーションに .sldSettings ファイルを含める

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


設定アドミニストレータ ツールにアクセスする

設定アドミニストレータ ツール（Settings Administrator Tool）にアクセスするには、まずアドミニストレーティブ イメージを作成する必要があります。

設定アドミニストレータ ツール（Settings Administrator Tool）は、アドミニストレーティブ イメージまたは次のデフォルトの場所から起動できます: C:\SolidWorks Admin\SOLIDWORKS <バージョン>\64bit\SOLIDWORKS\Program Files 64\SOLIDWORKS\sldSettingsAdmin.exe。

設定アドミニストレータ ツールにアクセスするには:

  1. アドミニストレーティブ イメージ フォルダの sldAdminOptionEditor.exe を実行します。
  2. アドミニストレーティブ イメージ オプション エディタで設定編集をクリックします。
  3. クライアント インストール オプションセクションで、以下を実行します:
    1. SOLIDWORKS 設定アドミニストレータで出力した設定ファイルを使用します。をクリックします。
    2. 設定アドミニストレータ起動をクリックします。
親トピック 設定アドミニストレータ ツール


設定アドミニストレータ ツールの使用

設定アドミニストレータ ツール（Settings Administrator Tool）を使用するには:

  1. ようこそ（Welcome）タブで、次のオプションを選択します。
    • デフォルトのオプション設定（Default set of options）。このリリースの SOLIDWORKS で開始します。
    • SOLIDWORKS 2019 オプション設定をコンピュータからインポート（Import SOLIDWORKS 2016 options from this computer）。
    • 既存の sldreg ファイルを参照。
    • 既存の sldSetting ファイルを参照。
    *.sldreg ファイルは、設定のコピー ウィザード（Copy Settings Wizard）で生成され、*.sldSettings ファイルは設定アドミニストレータ ツール（Settings Administrator Tool）で生成されます。
  2. 次へ（Next）をクリックします。
親トピック 設定アドミニストレータ ツール


オプションの適用およびロック

システム オプション（System Options）タブで、チェック ボックスの 2 つの列を使って、これらのオプションのどちらを適用するか、また適用したオプションのどちらをロックしてユーザーが変更できないようにするかを選択できます。

ユーザーが SOLIDWORKS ソフトウェアの システム オプション（System Options）ダイアログ ボックスにアクセスすると、ロックされたオプションはロックアイコン [image] 付きで使用不可と表示されます。 ただし、オプションをユーザーがロック解除できるようにするパスワードを作成できます。 ユーザーがロックされたオプションの上にポインタを移動すると、ツールチップに管理者の名前とメールアドレスが表示されるため、ユーザーは管理者に連絡し、パスワードをリクエストできます。

オプションを適用およびロックするには:

  1. システム オプション（System Options）タブで、次を行います。
    1. システム オプションを適用するには、オプションを選択し、適用（Apply）列の対応するボックスをチェックします。
    2. システム オプションをロックするには、オプションを選択し、適用（Apply）列とロック（Lock）列の両方の対応するボックスをチェックします。
      システム オプション（System Options）タブにアクセスすると、これらのオプションはロック付き [image] で表示されます。
  2. オプションによっては、追加のパラメータをオプションに指定する必要があります。
  3. メッセージ/エラー/警告のコントロールを適用することにより、メッセージをユーザーが閉じられないようにすることもできます。
    1. メッセージ/エラー/警告（Messages/Errors/Warnings）をクリックします。
    2. 適用（Apply）を選択して、管理するメッセージのロック（Lock）を任意で選択します。
    3. メッセージを表示（Show）または表示しない（Don't Show）に設定します。

      表示（Show）を選択した場合、メッセージはユーザーの閉じられたメッセージ リストから削除され、ユーザーに適時表示されます。 表示しない（Don't Show）を選択した場合、メッセージは自動的にユーザーの閉じられたメッセージ リストに追加されて、ユーザーがモデルで作業を行っているときに表示されません。

      次の表に、ソフトウェアでの動作を示します。
      適用 | ロック | 表示 | 表示しない | 動作状態
      X | X | メッセージを強制的に表示します。
      X | X | メッセージを閉じて、メッセージを閉じられたメッセージ リストに追加します。
      X | X | X | メッセージを強制的に表示して、メッセージ ボックスの以後、このメッセージを表示しない（Don't show again）オプションを無効にします。
      X | X | X | メッセージを閉じて、ユーザーがツール（Tools） > オプション（Options） > メッセージ/エラー/警告（Messages/Errors/Warnings）でそれを有効にできないようにします。
  4. システム オプション（System Options）タブの次へ（Next）をクリックします。
親トピック 設定アドミニストレータ ツール


オプション設定を終了

オプション設定を終了するには:

  1. 完了（Finish）タブで、システム オプションがいつ適用されるかを選択します:
    • ユーザーが最初にソフトウェアを開始したとき（the first time a user starts the software）。
    • ソフトウェアが開始されるたび毎回（every time the software starts）。
    • ユーザー定義（customizations）が同時に適用されるかどうかも選択します。
  2. ユーザーがネットワークからはずれたとき、ロックされたオプションを適用（apply locked options when users are off the network）、およびAPI によるロックされたオプションの上書きを許可（allow the API to override locked options）を選択できます。
  3. ロックされたシステム オプションには、ユーザーの名前（Name）およびメール（Email）アドレスを指定する必要があります。 SOLIDWORKS ソフトウェアは、ユーザーがロックされたオプションの上にポインタを移動したとき、ヒントにこの情報を表示します。
  4. ユーザーがロックされたオプションを上書きすることを許可（allow users to override locked options）することもできます。 その後、ユーザーに提供できるパスワード（Password）を指定する必要があります。
  5. 保存（Save）をクリックすると、配布用の .sldSettings ファイルが生成されます。
親トピック 設定アドミニストレータ ツール


SOLIDWORKS インストレーションに .sldSettings ファイルを含める

*.sldSettings ファイルをインストレーションに含めるには:

  1. アドミニストレーティブ イメージ フォルダの sldAdminOptionEditor.exe をダブルクリックします。
  2. アドミニストレーティブ イメージ オプション エディタで設定を編集（Edit Settings）をクリックします。
  3. クライアント インストール オプション（Client Installation Options）セクションで、以下を実行します:
    1. SOLIDWORKS 設定アドミニストレータからエクスポートした設定ファイルを使用（Use a settings file exported from the SOLIDWORKS Settings Administrator）をクリックします。
    2. パスの編集（Edit Path）をクリックし、*.sldSettings ファイルを参照します。
    さまざまなグループやマシンに、さまざまな *.sldSettings ファイルを作成し適用できます。
  4. SOLIDWORKS ソフトウェアを配布してインストールします。

展開後、ステップ 2 を繰り返せば、既存の *.sldSettings を何度でも変更できます。 SOLIDWORKS ソフトウェアは、次回開始されたときに、変更された *.sldSettings を読み込みます。

親トピック 設定アドミニストレータ ツール


オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

手動またはプッシュによる方法を用いて、オプション エディタから直接インストレーションを展開することが可能です。

  • インストールの開始方法に関する電子メールの指示をユーザーに送信するには、オプション エディタの [手動配布（Deploy Manually）] ページを使用します。 この方法は、ユーザーがクライアント マシンの管理権限を持っている場合に使用します。
  • ターゲット マシンにインストレーションを自動的にプッシュするには、オプション エディタの [自動配布（Deploy Automatically）] ページを使用します。 カスタム アンインストールを実行することもできます。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

いずれの方法を使用する場合も、アドミニストレーティブ イメージのインストール ディレクトリを Windows の共有ディレクトリに変更し、ネットワークを通して利用可能にする必要があります（たとえば、\\machine\shared_directory または C:\SOLIDWORKS Admin\SOLIDWORKS 2019 SP0 のように各マシンのローカル ディレクトリにイメージ全体をコピーします）。

目次

  • アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）

    アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名 ）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。

  • StartSWInstall.exe によるアドミニストレーティブ イメージの展開

  • 手動で展開する

    ユーザーに、システムへのインストールに必要な権限がある場合は、この方法を使用します。

  • 自動展開の前提条件

    自動展開では、インストール タスクはターゲット マシンにプッシュされ、各システムで Microsoft タスク スケジューラによって実行されます。ユーザーによる操作は必要ありません。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

  • 自動的に展開する

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
設定アドミニストレータ ツール
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）

アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名 ）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。

たとえば、アドミニストレーティブ イメージの共有ディレクトリにU:ドライブを割り当てた場合は、電子メールによりfile://U:\StartSWIOnstall.htaのクリックがユーザーに対して指示されます。電子メールを受け取ったユーザーは、U:ドライブがアドミニストレーティブ イメージに対するUNCロケーション（\\マシン名\共有名 ）に割り当てられていれば、問題なくインストールすることが可能です。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


StartSWInstall.exe によるアドミニストレーティブ イメージの展開

クライアント上でアドミニストレーティブ イメージをインストールまたはアンインストールするには、admin_image_install_dir\ StartSWInstall.exe コマンドを実行します。 この方法により、アドミニストレーティブ イメージ オプション エディタで定義されたオプション、マシン、およびグループを使用して SOLIDWORKS がインストールされます。

StartSWInstall.exe コマンドには以下のオプションを追加できます。
/install | クライアント マシンにアドミニストレーティブ イメージをインストールします。
/uninstall クライアント マシンからソフトウェアをアンインストールします。次の 2 つのオプションを使用できます。

/removedata

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のデータ ファイルおよびフォルダを削除します。

/removeregistry

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のレジストリ エントリを削除します。
/showui | SOLIDWORKS Installation Manager のプログレス ウィンドウを表示します。 指定しなかった場合、SOLIDWORKS Installation Manager はユーザーに対して非表示になります。
/now | インストールまたはアンインストールを直ちに開始します。 5 分間の警告ダイアログ ボックスは表示されません。

ユーザー操作なしでインストールを実行したいが、アドミニストレーティブ イメージ オプション エディターの自動展開を使用したくない場合は、StartSWInstall.hta ではなく StartSWInstall.exe を使用することを推奨します。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


手動で展開する

ユーザーに、システムへのインストールに必要な権限がある場合は、この方法を使用します。

電子メールを使用して手動でインストレーションを展開するには:

  1. オプション エディタで展開をクリックします。
    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。
  2. メール送信 をクリックします。
  3. アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク パスを指定します。
    一般的にアドミニストレーティブ イメージのインストール ディレクトリに対するディレクトリ パスは、初期状態において、C:\SOLIDWORKS Admin\SOLIDWORKS 2019 SP0 のような Windows のファイル パスで表示されます。 ダイアログ ボックスにはこのパスはネットワーク パスではありませんと表示されます。
    1. 参照 をクリックして、このアドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーションを指定します。
    2. アドミニストレーティブ イメージがインストールされたコンピュータを探し、アドミニストレーティブ イメージに対するWindowsの共有ディレクトリを選択します。
      アドミニストレーティブ イメージの共有ディレクトリの内部（64bit のサブディレクトリなど）は選択しないでください。
    3. OK をクリックします。
      ダイアログ ボックスにはこのパスはネットワーク パスですと表示されます。
    電子メールが作成されます。このメールは、アドミニストレーティブ イメージ内の StartSWInstall.hta ファイルに対するネットワーク ロケーションを使用してアドミニストレーティブ イメージからインストールする方法をマシンの所有者に伝えるものです。
  4. SOLIDWORKS のインストール権限を持つユーザーに電子メールを送信してください。

ユーザーは電子メールに記述された StartSWInstall.hta に対するネットワーク ロケーションのリンクをダブルクリックすることで、アドミニストレーティブ イメージから SOLIDWORKS をインストールできます。

オプション エディターでは、インストレーション ステータス で次のように表示されます：
保留中 | ユーザーによる該当マシンへのインストールは未だ実施されていません。
成功 | ユーザーによる該当マシンへのインストールは無事完了しています。
失敗 | ユーザーによる該当マシンへのインストールが実施されましたが、失敗しました。

表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストールできませんでした」、「アンインストールできませんでした」。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動展開の前提条件

自動展開では、インストール タスクはターゲット マシンにプッシュされ、各システムで Microsoft タスク スケジューラによって実行されます。ユーザーによる操作は必要ありません。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

プッシュ インストールでは、タスク スケジューラは SOLIDWORKS Installation Manager を、管理者により指定された資格情報に従って動作するよう起動します。 タスク スケジューラはコンピュータの LocalSystem アカウントに従って動作します。 このアカウントはネットワーク上で、コンピュータ セキュリティ原則として表示されます。 コンピュータ セキュリティ原則には、アドミニストレーティブ イメージを置いてある共有フォルダへの読み取り権が必要です。

Active Directory では、共有フォルダのグループにコンピュータを追加する場合、オブジェクト タイプ（Object Types）を選択し、コンピュータ（Computers）が選択されていることを確認します。

また、アドミニストレーティブ イメージをホストするコンピュータとターゲット クライアント マシンが、同じ Active Directory ドメインのメンバーである必要があります。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動的に展開する

ユーザー システムにインストールをプッシュして自動的に展開するには:

  1. オプション エディタで自動配布タブをクリックします。
    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。
  2. 展開（Deploy）列では、展開（Deploy）列のターゲットのクライアント マシンとグループを選択します。
    展開プロセスを開始する前に、展開（Deploy）列で 1 つ以上のマシンまたはグループを選択します。
  3. インストール時間 で、今すぐ を選択してすぐに展開するか、後で実行 を選択して展開する特定の日時をスケジュールします。
  4. クライアント オプション（Client Options）で、以下を選択します:
    • SOLIDWORKS 2019 インストールまたはアップグレード
    • SOLIDWORKS 2019 アンインストール
      アンインストールを選択する場合、プログラム ファイルおよびプログラム フォルダーと共にレジストリ エントリ、データ ファイル、データ フォルダーをアンインストールするかどうかを指定できます。
  5. 展開中または展開後に必要に応じて 1 台以上のターゲット マシンを再起動する場合は、コンピュータの自動再起動（Reboot computer automatically）を選択します。
  6. 1 台以上のターゲット マシンのクライアント資格情報（Client Credentials）を入力します。
  7. 展開 をクリックして展開プロセスを開始します。
オプション エディタには次のようなインストレーション ステータスが表示されます:
保留中 | このマシンではまだインストールが実行されていません。
成功 | このマシンでのインストールは正常に完了しました。
失敗 | このマシンでのインストールは失敗しました。

表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「スケジューリング」、「接続中」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストール スケジュール済」、「アンインストール スケジュール済」、「インストールできませんでした」、「アンインストールできませんでした」、「接続できませんでした」、「スケジュールできませんでした」。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


オプション エディタの終了（Exiting the Option Editor）

オプション エディタを閉じるには、OKまたは閉じるをクリックします。

変更内容を適用し、オプション エディタを閉じるにはOK、閉じる（Close）、あるいはWindowsアプリケーションの閉じるボタンをクリックします。
  • OKをクリックすると、オプション設定の変更内容が適用され、オプション エディタが終了します。
  • 閉じる（Close）をクリックすると、オプション エディタが終了します。

    適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。

  • Windowsアプリケーションの閉じるボタン（X）をクリックします。適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。
親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
設定アドミニストレータ ツール
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


オプション エディタに対するデスクトップ ショートカットの作製

特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

  1. オプション エディタを起動します。
    たとえばWindowsエクスプローラにおいて、アドミニストレーティブ イメージのインストール ディレクトリに移動し、sldAdminOptionEditor.exeをダブルクリックします。
  2. デスクトップにこのオプション エディタへのショートカットを作成（Create Desktop Shortcut to this Option Editor）をクリックします。
    該当するアドミニストレーティブ イメージに対するオプション エディタへのショートカットが、Windowsデスクトップに作成されます。
親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
設定アドミニストレータ ツール
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

アドミニストレーティブ イメージ ディレクトリは、他のコンピュータからアクセス可能なマシン（例えば、UNCパス経由）で共有されるように設定します。

すべてのクライアントに admin_image_install_dir\StartSWInstall.hta へのリンクを含む電子メールを送信できます。 その後、クライアントはこのリンクをクリックし、続いて SOLIDWORKS 製品のインストール開始（Install SOLIDWORKS products now） をクリックし、アドミニストレーティブ イメージからのインストレーションを開始します。

新しい SOLIDWORKS バージョンのアドミニストレーティブ イメージをアップグレードしている場合は、そのイメージを使用して前にインストールしたクライアントが自動的にアップグレードされるように、アドミニストレーティブ イメージの場所と共有プロパティを設定できます。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。
親トピック 複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


コマンドラインによる展開（Command-Line Deployment）

コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

コマンドラインを使用して SOLIDWORKS PDM クライアントにアドミニストレーティブ イメージを配布するには、SOLIDWORKS PDM インストール ガイドを参照してください。

目次

  • アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

    アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

  • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

    コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

  • コマンドライン プロパティ（Command-Line Properties）

    ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

  • Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

    Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

  • Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）

    次の手順に従い、Microsoft Windows Active Directory を使用してクライアント コンピュータに SOLIDWORKS をインストールする既存のアドミニストレーティブ イメージを用意します。

親トピック 複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

これらの Windows コンポーネントのマニュアル インストールは、コマンドラインの使用または Microsoft Active Directory によってアドミニストレーティブ イメージからインストールする場合のみに必要となります。 SOLIDWORKS Installation Manager でアドミニストレーティブ イメージを作成してインストールする場合、これらの Windows コンポーネントは自動的にインストールされます。
以下に、SOLIDWORKS で必要になる Windows 構成部品のファイルをまとめます。
Windows Performance Toolkit: |
Visual C++ 2008、2010、2012、2013、および 2015 再頒布可能パッケージ | Microsoft Visual C++の実行に必要なランタイム構成部品を含みます。 2008、2010、2012、2013、および 2015 のバージョンがインストールされている必要があります。
Visual Basic for Applications 7.1 | Visual Basic のマクロをサポートします。
Visual Studio Tools for Application 2005 | Visual Studio 2005 アプリケーションをサポートするツール セットを含みます。 SOLIDWORKS 2013 では、Microsoft Visual Studio Tools for Applications（VSTA）のインストールはオプションです。 VSTA 2005 は、コンピュータにインストールされている Microsoft .NET Framework 3.5 に依存します。 Windows 7 以降では、.NET Framework はオペレーティング システムの機能に含まれています。 .NET Framework 3.5 のインストールが必要な場合、これは Windows メディアに収録されています。あるいはインターネットから入手できます。 Windows メディアがない場合、インターネットに接続できない場合、あるいは Microsoft .NET Framework 3.5 をコンピュータにインストールする権限がない場合は、使用しているコンピュータの管理者に問い合わせてください。
Visual Studio Tools for Application 2015 | この操作はオプションです。 Visual Studio 2015 アプリケーションをサポートするツール セットを含みます。
Visual Studioリモート デバッガ | 64-ビット オペレーティング システムのデバッグ環境を提供します。
.NET Framework 4.6.2 | .NET Framework 4.6.2 アプリケーションの実行に必要な共通語のランタイムと .NET Framework 構成部品が含まれています。
Bonjour service for Windows | ローカル エリア ネットワークでサービスを検出する機能です。
Visual C++ 再頒布可能パッケージと .NET Framework 4.6.2 は、コア SOLIDWORKS 製品だけでなく、すべての SOLIDWORKS 製品に必要です。

これらのコンポーネントはアドミニストレーティブ イメージのサブディレクトリに含める必要があります。

サポートされるオペレーティング システムで必要なファイルは次の通りです:
オペレーティング システム: Windows Server 2016 64 ビット
オペレーティング システム: Windows Server 2012 および 2012 R2 64-bit
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server、SOLIDWORKS PDM Server、および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications 2005: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015（オプション）: | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour service for Windows: | bonjour64.msi
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server、SOLIDWORKS PDM Server、および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications 2005: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015（オプション）: | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows Server 2012 および Windows Server 2012 R2 64-bit
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications 2005: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 8 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015: （オプション） | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows 7 64-bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015: （オプション） | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows 8.1 64 ビット
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications 2005: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015: （オプション） | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows 10 64 ビット
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2013 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2015 再頒布可能パッケージ: | vc_redist_x86.exe vc_redist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications 2005: （オプション） | vsta_aide.msi
VSTA 2005 がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio Tools for Applications 2015: （オプション） | vsta_setup.exe
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.6.2: | .NET 4.6.2 は、この要件を満たすオペレーティング システムの一部です。
Bonjour service for Windows: | bonjour64.msi

目次

  • 64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

    次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールします。

親トピック コマンドラインによる展開（Command-Line Deployment）
関連概念
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールします。

1回のインストール作業で複数のコンポーネントをインストールするには、次の手順にあるコマンドでバッチ ファイルを作成し、コンポーネントをクライアント コンピュータにインストールします。

  1. ターゲットのコンピュータに最低620 MBの空き容量と、有効なTEMPディレクトリがあることを確認します。
  2. Visual C++ RELEASE 再頒布可能パッケージをインストールします。
    RELEASE = 2008、2010、2012、2013、および 2015 用のパッケージをインストールします。
    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    このパッケージの 32-bit バージョンと 64-bit バージョンの両方をインストールする必要があります。

    たとえば、Visual C++ 2008 再頒布可能パッケージをインストールするには、以下を使用します。

    • administrative_image_directory\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q
    • administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q
  3. Microsoft .NET Framework 4.5.2:
    administrative_image_directory\.Net_Framework_4.6.2\NDP462-KB3151800-x86-x64-AllOS-ENU.exe をインストールします。
  4. Visual Studio Tools for Applications 2015:
    administrative_image_directory\Microsoft_VSTA\vsta_setup.exe をインストールします。
  5. Visual Studioリモート デバッガをインストールします。
    administrative_image_directory\VSRemoteDebugger\install.exe /Q
  6. Visual Basic 7.1 をインストールします。
    administrative_image_directory\Microsoft_VBA\vba71.msiおよびadministrative_image_directory\Microsoft_VBA\vba71_1033.msiはすべての言語で必要です。
    このパッケージでは 64-bit バージョンのみ、インストールが必須です。

    さらに、目的の言語用に次のパッケージをインストールします。

    vba71_1028.msi | 中国語
    vba71_1031.msi | ﾄﾞｲﾂ語
    vba71_1036.msi | ﾌﾗﾝｽ語
    vba71_1040.msi | イタリア語
    vba71_1041.msi | 日本語
    vba71_1042.msi | Korean
    vba71_1046.msi | ポルトガル語(ブラジル)
    vba71_2052.msi | 中国語（簡体字）
    vba71_3082.msi | スペイン語
    英語、チェコ語、ポーランド語、ロシア語、およびトルコ語では、言語パッケージを追加する必要がありません。
    SOLIDWORKS 2013 Service Pack 2.0 では、追加の前提条件をインストールする必要があります: Msiexec.exe /p vba71-kb27832-x64.msp
  7. Windows に Bonjour サービスをインストールします。
    administrative_image_directory\Bonjour\Bonjour64.msi
親トピック アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

サイレント インストールを行うには:

  1. コマンド プロンプト ウィンドウを開きます（Windowsでスタート > ファイル名を指定して実行をクリックします）。
  2. msiexec.exeコマンドを/iと/qbオプションを使用して入力し、デフォルト値とは異なる値を指定する任意のオプションのプロパティを設定します。

    msiexec /i "64-bit_admin_image_path\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Program Files\your_folder /qb

個々のインストール コンポーネントのコマンドライン プロパティには次が含まれます：
  • コマンドラインの機能プロパティ（Command-Line Feature Properties）
  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）
  • eDrawings コマンドライン プロパティ
  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

次の例をサイレント インストレーションのテンプレートとして使用してください。

SOLIDWORKS Client

  • SOLIDWORKS コア (英語)
  • Toolboxアドイン
  • フィードバック プログラムに参加
  • フランス語

SOLIDWORKS:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

SOLIDWORKS フランス語インストール コンポーネントは個別にインストールする必要があります:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

SOLIDWORKS 言語コンポーネントのインストール コマンドを指定する際には、コマンド ライン引数を指定しないでください。

eDrawings クライアント

  • ログ パフォーマンス
  • すべての機能

msiexec /i "admin_image_path\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Electrical

Microsoft SQL Server とともに SOLIDWORKS Electrical をインストールする場合の技術的な複雑さが原因で、SOLIDWORKS Electrical のコマンド ラインの例はドキュメントから除外されています。

SOLIDWORKS PCB

msiexec /i “admin_image_path\SOLIDWORKS PCB.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PCB” /qb

SOLIDWORKS Visualize および Visualize Boost

SOLIDWORKS Visualize の場合:

msiexec. /i “admin_image_path\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

SOLIDWORKS Visualize Boost の場合:

msiexec /i “admin_image_path\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

親トピック コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


コマンドライン プロパティ（Command-Line Properties）

ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

目次

  • コマンドラインの機能プロパティ（Command-Line Feature Properties）

    SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）

    各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

  • eDrawings コマンドライン プロパティ

    これらのコマンドライン プロパティは eDrawings ® 特有のものです。

  • SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

    これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

    これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

  • SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

    これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

  • SOLIDWORKS Visualize コマンド ライン プロパティ

    これらのコマンド ライン プロパティは、SOLIDWORKS Visualize 特有のものです。

  • アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

    コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

親トピック コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


コマンドラインの機能プロパティ（Command-Line Feature Properties）

SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • VSTA
コマンドライン インストールのプロパティを指定する際の注意：
  • SOLIDWORKS は ADDSOURCE オプションを使用したインストレーションはサポートしません。
  • プロパティでは、大文字と小文字が識別されます。 またコマンドラインには、スペースやダッシュを含むことはできず、コンマで区切る必要があります。

    アプリケーションを正確にインストールするには、大文字と小文字が組み合わされた SOLIDWORKS を指定する必要があります。

親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


コマンドラインのグローバル プロパティ（Command-Line Global Properties）

各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

プロパティ | 説明
ENABLEPERFORMANCE SOLIDWORKS 社に自動的にパフォーマンス データを送信するかどうかを指定します。

1

パフォーマンス データを送信します。

0

パフォーマンス データを送信しません。
INSTALLDIR SOLIDWORKS インストレーション フォルダです。

個人インストレーションのみ。
MBDSERIALNUMBER | SOLIDWORKS モデル ベース定義のプロダクトのシリアル番号です。
MOTIONSERIALNUMBER | SOLIDWORKS Motion プロダクトのシリアル番号です。
OFFICEOPTION インストールする製品パッケージを指定します。
0 | SOLIDWORKS Client
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL 現在インストールされている機能すべてを更新するには、ALL を指定します。
このプロパティは、既存のメジャー リリース内のサービス パック リリースへの更新（たとえば、既存の SOLIDWORKS 2019 SP01 インストールから SOLIDWORKS 2019 SP02 への更新）にのみ指定してください。
REINSTALLMODE Microsoft Installer の再インストール オプションです。

たとえば、あるサービスパック リリースから別のサービス パックへ、同じメジャーリリース内でアップグレードする場合は REINSTALLMODE=vomus を指定します。

REINSTALLMODE の設定の詳細については、www.microsoft.com にある Windows Installer の関連ドキュメントを参照してください。

このプロパティは、既存のメジャー リリース内のサービス パック リリースへの更新（たとえば、既存の SOLIDWORKS 2019 SP01 インストールから SOLIDWORKS 2019 SP02 への更新）にのみ指定してください。 このプロパティは、SOLIDWORKS の新しいメジャー リリースを最初にインストールする際には指定しないでください。
SERVERLIST SolidNetWork サーバー リストです。
SolidNetWork サーバー リストは、文字列の区切りリストで、それぞれの文字列は次のフォーマットでサーバー上のポート番号を表します:
  • トライアド（カンマ区切り）=xxxxx@サーバー名1,yyyyy@サーバー名2,zzzzz@サーバー名3
  • 非トライアド（セミコロン区切り）=xxxxx@サーバー名1;yyyyy@サーバー名2;zzzzz@サーバー名3
x および y は 1 桁の数字です。 リスト内の最後のサーバーの後には区切り文字を追加しないでください。

個人インストレーションのみ。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation プロダクトのシリアル番号です。
SOLIDWORKSSERIALNUMBER | SOLIDWORKS プロダクトのシリアル番号です（すべてのアドインが含まれます）。
SWMIGRATE アップグレードする SOLIDWORKS のバージョンを指定します。このリストは SOLIDWORKS インストレーションの選択 ダイアログ ボックスに表示されます。 例:

SWMIGRATE="SOLIDWORKS 2019 x64 Edition SP01"

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。 このプロパティは、同じメジャー リリース内で1つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
TOOLBOXFOLDER SOLIDWORKS Toolbox ファイルのインストレーション フォルダです。

個人インストレーションのみ。

例: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"
TRANSFORMS 次の形式で言語固有のアイテムを含めます。
TRANSFORMS number.mst
  • 中国語（台湾）（1028）
  • 中国語（中国）（2052）
  • チェコ語（1029）
  • 英語（1033）
  • フランス語（1036）
  • ドイツ語（1031）
  • イタリア語（1040）
  • 日本語（1041）
  • 韓国語（1042）
  • ポーランド語（1045）
  • ポルトガル語（ブラジル）（1046）
  • ロシア語（1049）
  • スペイン語（1034）
  • トルコ語（1055）
UPGRADESWINSTALL
既存の SOLIDWORKS のバージョンを現在のバージョンにアップグレードするかどうかを指定します。
0 | 新規インストレーション、アップデートなし。
1 | 更新

個人インストレーションのみ。

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。 このプロパティは、同じメジャー リリース内で 1 つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


eDrawings コマンドライン プロパティ

これらのコマンドライン プロパティは eDrawings ® 特有のものです。

プロパティ（Properties） | 説明
ADDLOCAL インストールする eDrawings アプリケーション機能を指定します。
All が推奨オプションです。
コマンドライン構文 | フィーチャー
すべて | 全機能をインストールします。 eDrawings はインストール済みの SOLIDWORKS と AutoCAD の Publisher を検索し、インストールを有効にします。
CALS | eDrawings Viewer で CAL ファイルを表示
Inventor | Autodesk Inventor アプリケーションから eDrawings ファイルを作成します。
eDrawingsViewer | eDrawings やその他のファイルを表示します。
ProE | eDrawings Viewer を使用して ProE ファイルを表示
DXFDWGTranslator | eDrawings Viewer で DXF/DWG ファイルを表示します。
Shortcuts | デスクトップ ショートカットをインストールします。
XML3D | eDrawings Viewer で 3DXML ファイルを表示します。
INSTALLDIR | eDrawings のためのインストレーション フォルダーを指定します。
LOGPERFORMANCE SOLIDWORKS Corporation に自動的にパフォーマンス データを送信するかどうかを指定します。
1 | パフォーマンス データを送信する
0 | 送信しない
SNLSERVER SolidNetWork License Server の ポート@サーバー名 を入力します。 複数の ポート@サーバー名 の組み合わせはセミコロンで区切ります。

SNLSERVER のポート サーバー名は SOLIDWORKS SNL サーバーを設定する場合にのみ必要です。 ポート_の_リスト@サーバー_ストリング はセミコロンで区切られているストリングのリストであり、それぞれのストリングは、次のフォーマットをもつサーバー上のポート番号を表します:

xxxxx@サーバー_名1; yyyyy@サーバー_名2;

ここで、x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

SOLIDWORKS Composer の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Composer のシリアル番号。
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
ADDLOCAL 完全なアプリケーションをインストールする場合は、以下のアイテムを指定する必要はありません。
必須:
  • ライセンス契約（Licensing）
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
これはオプションです。
  • Sync3Dvia
INSTALLDIR | SOLIDWORKS Composer ソフトウェアをインストールするフォルダを指定します。

SOLIDWORKS Composer Player の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
INSTALLDIR | SOLIDWORKS Composer Player ソフトウェアをインストールするフォルダを指定します。
SOLIDWORKS がインストールされていないマシンでは、SOLIDWORKS Translator を使用して SOLIDWORKS ファイルを SOLIDWORKS Composer にインポートする必要があります。 SOLIDWORKS Translator を展開するには、SOLIDWORKS Installation Manager を使用する必要があります。コマンド ラインは使用できません。
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） SOLIDWORKS Flow Simulation スタンドアロン シリアル番号です。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

CWUPGRADEINSTALL 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアの既存バージョンをアップグレードします。
1 | アップデート
2 | 新規インストレーション、新規ディレクトリにインストール

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

INSTALLDIR 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアのインストレーションを指定します。

（個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
SOLIDWORKSPATH SOLIDWORKS ソフトウェアのインストール フォルダを指定します。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Inspection のシリアル番号。 （アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。
INSTALLDIR | SOLIDWORKS Inspection アプリケーション ソフトウェアのインストールを指定します。 （個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Visualize コマンド ライン プロパティ

これらのコマンド ライン プロパティは、SOLIDWORKS Visualize 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Visualize のシリアル番号。 （アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。
INSTALLDIR | SOLIDWORKS Visualize アプリケーション ソフトウェアのインストールを指定します。 （個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

SOLIDWORKS （コア製品、英語版）

swwi\data\SOLIDWORKS.msi

SOLIDWORKS （英語以外の言語コンポーネント）

中国語（台湾） | swwi\lang\chinese\chinese.msi
中国語（中国） | swwi\lang\chinese-simplified\chinese-simplified.msi
チェコ語 | swwi\lang\czech\czech.msi
フランス語 | swwi\lang\french\french.msi
ドイツ語 | swwi\lang\german\german.msi
イタリア語 | swwi\lang\italian\italian.msi
日本語 | swwi\lang\japanese\japanese.msi
Korean | swwi\lang\korean\korean.msi
ポーランド語 | swwi\lang\polish\polish.msi
ポルトガル語（ブラジル） | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russian | swwi\lang\russian\russian.msi
スペイン語 | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS アクティベーション ウィザード

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Explorer

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PCB

PCB\SOLIDWORKS PCB.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional には API が用意されていますが、Client でのみ使用可能で、.msi では使用できません。 詳細については、SOLIDWORKS PDM Client の install\API ディレクトリにある API ガイドを参照してください。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi
親トピック コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ


Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

Microsoft Active Directoryはネットワーク環境にあるクライアントとサーバーを管理するためのディレクトリ サービスです。 これにより、管理、移行、展開がシンプルになります。

Microsoft Active Directory での SOLIDWORKS のインストールについては、代理店にお問い合わせください。

親トピック コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）

次の手順に従い、Microsoft Windows Active Directory を使用してクライアント コンピュータに SOLIDWORKS をインストールする既存のアドミニストレーティブ イメージを用意します。

  1. Visual C++ 再頒布可能パッケージ インストーラ ファイルをすべて抽出してインストールします。
    1. Visual C++ 2008
      1. administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Microsoft C++ 2008 再頒布可能モジュールをインストールするためのポリシーを作成します。
    2. Visual C++ 2010
      1. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{Target Directory}
      2. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{Target Directory}
      3. Microsoft C++ 2010 再頒布可能モジュールをインストールするためのポリシーを作成します。
    3. Visual C++ 2012
      1. テストマシンに admistrative_image_directory\Microsoft_C++_2012_Redistributable\vcredist_x86.exe をインストールします。
      2. ネットワーク ロケーションにこれらのフォルダをコピーします（Target Directory）:
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
    4. Visual C++ 2013
      1. administrative_image_directory\Microsoft_C++_2013_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2013_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Microsoft C++ 2013 再頒布可能モジュールをインストールするためのポリシーを作成します。
    5. Visual C++ 2015
      1. administrative_image_directory\Microsoft_C++_2015_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2015_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Microsoft C++ 2015 再頒布可能モジュールをインストールするためのポリシーを作成します。

      1. 次のファイルをインストールするためのポリシーを作成します:
        ファイル パスにはスペースを含められません。

        Target Directory\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Target Directory\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      2. テスト マシンに administrative_image_directory\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe をインストールします。
      3. ネットワーク ロケーションにこれらのフォルダをコピーします（Target Directory）:
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      4. 次のファイルをインストールするためのポリシーを作成します:
        ファイル パスにはスペースを含められません。

        Target Directory\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Target Directory\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Target Directory\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Microsoft .NET Framework 4.6.2 をインストールします。
    SOLIDWORKS では、.NET Framework 4.6.2 のインストールには Windows Updates Services （WSUS）または同様のサービスを使用することを推奨します。
  3. 次のポリシーを作成して、Visual Studio リモート デバッガをインストールします（.Net Framework 3.5 がコンピューターにインストールされている場合は 64 ビット バージョンのみ）。
    {Microsoft_remote_debugger_directory}\rdbgexp.MSI
    このインストレーションでは、トランスフォーム ファイルは必要ありません。
  4. 次のタスクを行います。
    1. vba71-kb2783832-x64 サービス パックを使用してアプリケーション用に Visual Basic 7.1 を更新します。
    2. 管理イメージの作成後に、次のコマンドを実行します。
      Msiexec /a {SOLIDWORKS アドミニストレーティブ イメージ}/Microsoft_vba/vba71.msi /p {SOLIDWORKS アドミニストレーティブ イメージ}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp
    3. 次のポリシーを作成して、Visual Basic 7.1 をインストールします。
      {VBA directory}\vba71.MSI
      このインストレーションでは、トランスフォーム ファイルは必要ありません。
  5. 次のポリシーを作成し、Visual basic 7.1言語パックをインストールします。
    {VBA directory}\vba71_nnnn.MSI
    このnnnnの部分で必要な言語を定義します。
    • 1028 = 中国語
    • 1031 = ドイツ語
    • 1033 = 英語
    • 1036 = フランス語
    • 1040 = イタリア語
    • 1041 = 日本語
    • 1042 = 韓国語
    • 1046 = ポルトガル語
    • 2052 = 中国語 - 中国
    • 3082 = スペイン語
  6. 次のポリシーを作成して、Bonjour Serviceをインストールします。
    {Bonjour directory}\Bonjour.MSI
    このインストレーションでは、トランスフォーム ファイルは必要ありません。
親トピック コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


複数インストレーションの管理（Administration of Multiple Installations）

複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。

目次

  • 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

    アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

  • ServicePack製品アップデートの管理（Service Pack Product Update Administration）

    ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

親トピック 複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）


新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

SOLIDWORKS Installation Manager をインターネットから実行し、正しいファイルが参照されるようにします。 SOLIDWORKS Installation Manager は自動的にリダイレクトされますが、SOLIDWORKS Downloads Web サイト（http://www.solidworks.com/sw/support/downloads.htm）からアップデートを直接実行することもできます。

アドミニストレーティブ イメージをアップデートすると（新しいイメージのコピーが作成されます）、新しいアドミニストレーティブ イメージのコピーを参照することによってクライアントを更新できます。

クライアントが、前のバージョンのネットワークドライブに割り当てられている、または共有ディレクトリにあるアドミニストレーティブ イメージを参照していた場合、ネットワークドライブに割り当てられている、または共有ディレクトリのアドミニストレーティブ イメージの位置を更新することによって再定義することができます。

目次

  • アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  • アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

    アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

  • アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

親トピック 複数インストレーションの管理（Administration of Multiple Installations）
関連概念
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  1. DVD をメディアに挿入し、SOLIDWORKS Installation Manager を開始します。
  2. ようこそ(Welcome) スクリーンで、アドミニストレーティブ イメージ(Administrative image)をクリックします。
  3. シリアル番号 画面で、SOLIDWORKS のシリアル番号を入力します。
    SOLIDWORKS Installation Manager は、ライセンスのある製品と使用可能なサービス パックが SOLIDWORKS Web サイトにあるかどうかをチェックします。
  4. 利用可能なより新しいバージョン（Newer Version Available）画面が表示されたら、 はい、新しいバージョンをダウンロードﾞしてインストールします： バージョン（Yes, download and install a newer version: version）を選択します。
    SOLIDWORKS Installation Manager が新しいバージョンをインストールするためのセッションを新たに開始します。
  5. ダウンロード フォルダーに問題がある場合は、ダウンロード オプション（Download Options）が表示されるかもしれません。この場合は、新しいインストレーション ファイルのデフォルトのディレクトリを確定するか、または新しいディレクトリ名を入力します。
    ディレクトリが存在しない旨を伝えるメッセージが表示された場合は、はい（Yes）をクリックしてディレクトリを作成します。
  6. ダウンロード完了（Download Complete）画面で閉じる（Close）をクリックして現在のインストーラを閉じ、新規バージョンのインストーラを開始します。
親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連概念
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
関連タスク
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）


アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

このプロセスは、アドミニストレーティブ イメージのすべてのアップデートされたインストレーション ファイルのダウンロードが行われていることを前提とします。 詳細は、アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロードを参照してください。

  1. SOLIDWORKS Installation Manager を起動します。 詳細は、SOLIDWORKS インストレーションの開始を参照してください。
  2. ようこそ 画面で アドミニストレーティブ イメージ を選択します。
    アドミニストレーティブ イメージの作成オプションが表示されます。
    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. シリアル番号 画面でシリアル番号を確認します。
  4. サマリー（イメージ作成の準備完了）画面で、アドミニストレーティブ イメージのオプションが正しいかどうか確認します。
    個々のアドミニストレーティブ イメージとインストレーション オプションの詳細については、変更（CHANGE）をクリックしてオプション ページに移動してから、ヘルプ（Help）をクリックします。
  5. アドミニストレーティブ イメージの新しいバージョンを作成するには、今すぐ作成（Create Now）をクリックします。

これで、この新しいバージョンのアドミニストレーティブ イメージへのクライアントのアップグレードを行えるようになります。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。

親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連概念
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
関連タスク
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

通常、アドミニストレーティブ イメージはサーバー上のフォルダーにまとめられています。クライアントの自動アップグレードをサポートするためには、アドミニストレーティブ イメージが共有フォルダーにある必要があります。

アドミニストレーティブ イメージのアップグレードを行うと、元のインストレーションが1つのフォルダーに保存され、更新されたインストレーションが別のフォルダーに保存されます。アップグレードされたインストレーションを使用するには、元のアドミニストレーティブ イメージ フォルダーの共有オプションを解除します。続いてアップグレードされたアドミニストレーティブ イメージ フォルダーに共有オプションを追加します。

元のアドミニストレーティブ イメージからインストールした SOLIDWORKS をクライアント マシンで起動すると、新しいバージョンが識別されてクライアントがアップグレードされます。
SOLIDWORKS によって更新が引き起こされると、アドミニストレーティブ イメージからインストールした他の製品も自動的に更新されます。
親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連タスク
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

元のアドミニストレーティブ イメージ フォルダからの共有オプションの解除（Removing the Sharing Option from the Original Administrative Image Folder）

共有フォルダからアクセスされるアドミニストレーティブ イメージをアップグレードする際は、元のフォルダから共有オプションを解除する必要があります。

  1. 元のアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブでこのフォルダを共有しない（Do not share this folder）を選択し、OKをクリックします。

次に、アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）の手順に従い、アップグレードされたアドミニストレーティブ フォルダに共有オプションを追加します。

アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）

アドミニストレーティブ イメージ フォルダーを作成してアップデートし、元のアドミニストレーティブ イメージ フォルダーの共有を無効にしたら、新しいフォルダーに共有オプションを追加してアドミニストレーティブ イメージを再び有効にする必要があります。

  1. アップグレードされたアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブで、適切な共有プロパティを業務グループ用に指定し、共有名を元のアドミニストレーティブ イメージ フォルダ名に変更します。
元のアドミニストレーティブ イメージの共有場所からインストールしたコンピュータは、SOLIDWORKS の起動時に新しいバージョンに自動的にアップグレードされます。


ServicePack製品アップデートの管理（Service Pack Product Update Administration）

ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

次の2つの方法で製品アップデートを入手できます。
  • SOLIDWORKS Installation Manager を使用して、ダウンロードとインストールの更新をチェックできます。

    SOLIDWORKS Installation Manager を手動で開始するか、アップデート チェックが定期的に行われるようにスケジュールします。

  • サービス パックを SOLIDWORKS サポート Web サイトから手動でダウンロードします。

    サービス パックはソフトウェアの既存バージョンにパッチとして適用されます。 たとえば、SOLIDWORKS 2019 SP1.0 は SOLIDWORKS 2019 SP0.0 のサービス パックです。これらのサービス パックは SOLIDWORKS 2019 Installation Manager を使用してインストールします。SOLIDWORKS 2018 の SOLIDWORKS Installation Manager を使用してインストールすることはできません。

    サービス パックのダウンロードとインストールの詳細手順については、アップデートしている SOLIDWORKS バージョンのインストレーション ドキュメントを参照してください。

目次

  • アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

    アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

  • Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）

    Microsoft Active Directory を使用して SOLIDWORKS ソフトウェアをインストールした場合、サービス パックも同様にクライアントに適用することができます。

親トピック 複数インストレーションの管理（Administration of Multiple Installations）
関連概念
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連タスク
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

一度アップグレードしたアドミニストレーティブ イメージを前回バージョンのService Packへとロールバックすることはできません。 SOLIDWORKS Installation Manager 以外の方法で作成したアドミニストレーティブ イメージを以前のバージョンにロールバックすることはできません。 これらのアドミニストレーティブ イメージからインストールしたクライアントは、アンインストールしてから前のバージョンで作成したアドミニストレーティブ イメージを使用して再インストールする必要があります。
  1. 現在のアドミニストレーティブ イメージを含むフォルダーを削除します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。
    rmdir /s/q 現在の_アドミニストレーティブ_イメージ_への_パス
  2. アドミニストレーティブ イメージのバックアップ コピーを現在のアドミニストレーティブ イメージを削除した場所へ移動します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。
    move バックアップした_アドミニストレーティブ_イメージ_への_パス 現在の_アドミニストレーティブ_イメージ_への_パス
    アドミニストレーティブ イメージをロールバックすると、次回 SOLIDWORKS を実行した時にクライアント コンピュータは自動的にロールバックされます。
親トピック ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）


Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）

Microsoft Active Directory を使用して SOLIDWORKS ソフトウェアをインストールした場合、サービス パックも同様にクライアントに適用することができます。

  1. 次のコマンドラインでアドミニストレーティブ イメージを新規フォルダーにコピーします。
    xcopy 現在の_アドミニストレーティブ_イメージ_への_パス バックアップした_アドミニストレーティブ_イメージ_への_パス /s/i/v
  2. SOLIDWORKS Installation Manager を使用してアドミニストレーティブ イメージをアップグレードします。
  3. SOLIDWORKS ソフトウェアのアップグレード インストレーションを指定するために、新規トランスフォーム ファイルを作成するには以下を行います。
    1. コマンド プロンプト ウィンドウを開きます。
    2. アドミニストレーティブ イメージを含むフォルダでSWCreateMST.exeをコマンド プロンプト ウィンドウ内にドラッグします。
      コマンド フォーマットは次のようになります。

      アドミニストレーティブ_イメージ_への_パスSWCreateMST.exe アドミニストレーティブ_イメージ_の_MSI_ファイル_へ_の_パス プロパティ_の_リスト

      コマンドラインには、元の MST ファイルを作成した際に使用したすべてのパラメータが含まれていなくてはなりません。また、グローバル プロパティの UPGRADESWINSTALL と SWMIGRATE も必要です。

      たとえば、元のコマンドが次の場合:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\選択_フォルダ" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー

      アップデート コマンドは次のようにする必要があります。

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\選択_フォルダ" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS version service_pack"

      トランスフォーム ファイル SOLIDWORKS.mst は、アドミニストレーティブ イメージを含むフォルダに作成されます。

  4. Active Directory でグループ、または複数グループの Published Apps ポリシーを編集して SOLIDWORKS ソフトウェアを展開します。
  5. グループ ポリシー ダイアログ ボックスで コンピュータの構成とソフトウェアの設定 を展開します。
  6. ソフトウェア インストール を右クリックし、新規作成（New） > パッケージ（Package） を選択します。
  7. アドミニストレーティブ イメージまで参照し、開く（Open）をクリックします。
  8. ソフトウェアの展開 ダイアログ ボックスで 公開または割り当て時の詳細設定 を選択してから、OK をクリックします。
  9. SOLIDWORKS プロパティ (SOLIDWORKS Properties) ダイアログ ボックスの 変更 タブで次を行います。
    1. 追加 をクリックします。
    2. .mstファイルを参照します。
    3. 開く をクリックします。
  10. OK をクリックします。
親トピック ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）


SOLIDWORKS PDM および SOLIDWORKS Manage

SOLIDWORKS PDM は、以前 SOLIDWORKS Enterprise PDM と呼ばれていたクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。 SOLIDWORKS PDM には次の 2 種類があります。
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

この表には、各製品タイプで使用できるデータベース システム、サーバー コンポーネント、およびクライアント オプションがリストされています。
 | PDM Standard | PDM Professional
設計対象 | 小規模～中規模のオフィス ネットワーク（一般的に 20 以下の同時ユーザー）。 | 大規模オフィス ネットワーク（多数の同時ユーザー）
制限 | 1 ソケットまたは 4 コア（どちらか少ない方）、1 GB RAM、10 GB データベース サイズ | SQL Standard の制限: 4 ソケットまたは 16 コア（どちらか少ない方）、128 GB RAM、524 PB データベース サイズ
データベース管理システム | Microsoft SQL Server Express 2014（SOLIDWORKS に含まれており、一緒にインストールされます） | Microsoft SQL Server 2014（SOLIDWORKS とは別途）、または前もってインストールされた Microsoft SQL Server 2014、2012、または 2008 R2
SolidNetWork License Manager が必要ですか? | はい | はい
アーカイブ サーバーとデータベース サーバーが含まれていますか? | はい | はい
SOLIDWORKS PDM Web サーバーと Web2 サーバーが含まれていますか? | いいえ | はい
クライアント タイプ | ネイティブ | ネイティブ、ブラウザ ベース
CAD Editors 向けクライアント アドイン | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office Integration、Autodesk Inventor、AutoCAD
Contributors 向けクライアント アドイン | DraftSight | DraftSight、Microsoft Office Integration
Viewers 向けクライアント アドイン |  | Microsoft Office との統合

SOLIDWORKS Manage Professional では、高度なデータ管理ツールが SOLIDWORKS PDM Professional に提供されます。 高度なバージョン制御機能、およびプロジェクト、プロセス、アイテムの管理機能が提供されます。 インタラクティブなダッシュボードとレポートでは、アイテム、アクティビティ、プロジェクト完了までの進行状況を追跡できます。

SOLIDWORKS Manage Professional のアーキテクチャは、SOLIDWORKS PDM Professional に似ています。 アイテムおよびプロジェクト データを管理するために Microsoft SQL Server データベースを用いる、クライアント/サーバー アーキテクチャを使用します。 データベース、ファイル サーバー、Web サーバー機能の 3 つのサービスがあり、シック クライアントと Web ブラウザ クライアントの両方がサポートされます。 これら 3 つのサービスは、同一のサーバー上でホストすることも、別々のサーバー上でホストすることもできます。 SOLIDWORKS Manage Professional Editor のライセンスを所有するユーザーは、SOLIDWORKS Manage アドインを使用すると、SOLIDWORKS の内部から Manage のデータに直接アクセスできます。

SOLIDWORKS Installation Manager を使用すると、SOLIDWORKS Manage Professional のサーバーとクライアントをインストールすることができます。

SOLIDWORKS Manage Professional のインストール手順については、SOLIDWORKS PDM/SOLIDWORKS Manage インストレーション ガイドを参照してください。

目次

  • PDM Server コンポーネントのリスト

  • PDM クライアントの違いについて

    クライアント ソフトウェアをインストールする前に、PDM 環境によって異なるクライアントのうちどのクライアントが必要なのかを判断する必要があります。

  • PDM Server をインストールする前に

    PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。

  • SLDIM を使用した PDM Server のインストール

    PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

  • SLDIM を使用した PDM Client のインストール


PDM Server コンポーネントのリスト

このテーブルにはSOLIDWORKS PDM Server のサーバー コンポーネントがまとめられています。

Server | 関数 | インストレーション（Installation）
PDM Standard 向け Microsoft SQL Server Express | SOLIDWORKS PDM データ ボルトのデータを管理します。 | PDM Standard と一緒にインストール可能です。または、前にライセンスが付与されインストールされているバージョンを使用できます。
PDM Professional 向け Microsoft SQL Server | SOLIDWORKS PDM データ ボルトのデータを管理します。 | 個別に PDM Professional で提供 以前に使用許諾され、インストールされたバージョンも使用できます。
SolidNetWork License Manager | SOLIDWORKS PDM ライセンスを管理します。 | 新しいボルトを作成する前にインストールされている必要があります。 SLDIM を使用するときに、SOLIDWORKS PDM サーバー構成部品でインストールできます。
アーカイブ サーバー | クライアントとファイル ボルト アーカイブ間のファイル転送を管理し、ユーザーとその資格情報を管理します。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
データベース サーバー | 更新に関して PDM データベースをポーリングし、データのインポートおよびエクスポート ルールを管理し、メッセージ システムを管理し、また複製およびコールド ストレージをスケジュールします。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
Web Server と Web2 Server | ブラウザ ベースのクライアントからインターネット経由でファイル ボルトへのアクセスを提供します。 | この操作はオプションです。 PDM Professional のみと一緒にインストールします。
Web API サーバー | EXALEAD OnePart ユーザーは、Web API サーバーを使用して、SOLIDWORKS PDM データをインデックス化し、取得することができます。 | この操作はオプションです。 PDM Professional のみと一緒にインストールします。

アーカイブ サーバーはインストール先のコンピュータのシステム アカウントでのサービスとして実行されます。 1 つのアーカイブ サーバーは同じコンピュータにある複数のファイル ボルトをホスティングできます。

スタンドアロン インストレーションでは、アーカイブ サーバー、データベース サーバー、ライセンス サーバー、Web API サーバーだけでなく、SQL Express または SQL Server データベースもすべて同じマシンにインストールできます。

分散環境では、サーバー コンポーネントは別のマシンに配置できます。 また、同じファイル ボルト アーカイブの複製コピーをホスティングするために、複数のアーカイブ サーバーを別のコンピュータにセットアップすることも可能です。 詳細はSOLIDWORKS PDM Professional 複製ガイドを参照してください。

親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


PDM クライアントの違いについて

クライアント ソフトウェアをインストールする前に、PDM 環境によって異なるクライアントのうちどのクライアントが必要なのかを判断する必要があります。

このテーブルには SOLIDWORKS PDM Standard 向けクライアントの要約が記載されています。
Standard クライアントの種類 | 説明
CAD Editor | SOLIDWORKS、DWG/DXF 形式、Microsoft Word、Microsoft Excel ファイルの作業に対応します。 Office プラグインで処理されるすべてのファイル フォーマットは、プレビューを除き SOLIDWORKS PDM Standard で同じように動作します。
Contributor | SOLIDWORKS、DWG/DXF 形式、Microsoft Word、Microsoft Excel ファイルの作業に対応します。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。 ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）することはできません。
このテーブルには SOLIDWORKS PDM Professional 向けクライアントの要約が記載されています。
Professional クライアントの種類 | 説明
CAD Editor & Web | 全てのファイル タイプをサポートし、SOLIDWORKS を含む CAD フォーマットの管理とプレビュー機能が強化されています。 CAD アドインの使用により、CAD アプリケーションから SOLIDWORKS PDM Professional にアクセスすることも可能です。 リモート ユーザーは、ボルトを検索し、インターネットを介して Web クライアントおよび Web2 クライアントを使用して基本的な機能を実行できます。
Contributor & Web | CAD ファイルを含む全てのファイルタイプをサポートしています。 しかし、このクライアントタイプに対しては CAD アドインはサポートされていません。 リモート ユーザーは、ボルトを検索し、インターネットを介して Web クライアントおよび Web2 クライアントを使用して基本的な機能を実行できます。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。 ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）すること、または CAD アドインを使用することはできません。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


PDM Server をインストールする前に

PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。

  • サーバーとクライアントをインストールする予定のマシンに完全な管理権限を取得してください。
  • データベース サーバーがTCP</Z1>ポート3030</Z2>を使ってアーカイブ サーバーへ、そしてTCP</Z3>ポート1433</Z4>を使ってSQL</Z5>サーバーにアクセス可能であることを確認してください。
  • 既存の SQL Server Express または SQL Server データベースを使用する予定の場合、SQL Server データベースの名前と、データベースへの読み取り/書き込みアクセス権を持つ SQL Server 管理者またはデータベース所有者のアカウント ID とパスワードを取得してください。 tew ユーザーは使用できません。
  • PDM クライアントが既にシステムにインストールされている場合、それをアンインストールします。 PDM Server と PDM クライアントを同じシステムに置きたい場合、SOLIDWORKS Installation Manager のServer 製品ページから両方をインストールできます。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SLDIM を使用した PDM Server のインストール

PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

PDM Professional 用に PDM Server をインストールするとき、これらのコンポーネントの他、Web サーバー、Web2 サーバー、および Web API サーバーも含めることができます。

PDM Server とそのコンポーネントをインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページでサーバー製品（Server Products）を選択して以下を選択します。
    • SOLIDWORKS PDM Server コンポーネントをこのコンピュータにインストールする（Install SOLIDWORKS PDM Server components on this computer）。
    • SolidNetWork License Manager をこのコンピュータにインストールする（Install SolidNetWork License Manager on this computer）。

      SolidNetWork License Manager がインストールされている場合、このオプションは表示されません。

  3. SolidNetwork License Manager オプション（SolidNetwork License Manager Options）ページが表示される場合、シリアル番号を入力し、ディレクトリの場所を指定して次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. SOLIDWORKS PDM Server のサマリー（Summary）ページで変更（Change）をクリックします。
  6. SOLIDWORKS PDM Server オプション（SOLIDWORKS PDM Server Options）ページで:
    1. Server 製品の選択（Select Server Product）で、SOLIDWORKS PDM Standard または Professional をクリックします。
    2. インストレーション先（Installation Location）で、参照（Browse）をクリックしてファイル パスを指定します。
    3. 機能の選択（Select Features）で:
      1. アーカイブ サーバー（Archive Server）、データベース サーバー（Database Server）、およびクライアント（client）をクリックして、これらのコンポーネントを同じマシン上にインストールします。 分散環境にいる場合、別のマシン上で Installation Manager を実行して、アーカイブ サーバーとデータベース サーバーをインストールできます。
        マシン上に PDM クライアントが既にインストールされている場合、インストレーションをキャンセルして、クライアントをアンインストールする必要があります。 次に、SLDIM を実行して、クライアントと共に PDM サーバーをインストールします。
      2. PDM Professional をインストールしている場合は、Web サーバー（Web server）、Web2 サーバー（Web2 server）、および Web API サーバー（Web API Server）もクリックできます。
        Web API サーバーをインストールしている場合は、HTTP ポート番号（HTTP port number）に 0 ～ 65535 の値を指定します。デフォルト値は 65453 です。
    4. SQL Server で、PDM Server と共に提供されるデータベース ツールの新規インスタンスをインストールできます（SQL Server Express for PDM Standard）。または、既存インスタンスのデータベース名、ユーザー名、およびパスワードを指定できます。
      完全版の SQL Server は、別途 PDM Professional と共に提供されます。
    5. サマリーに戻る（Back to Summary）をクリックします。
  7. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。

    SOLIDWORKS Installation Manager がインストールを完了すると、アーカイブ サーバー コンフィギュレーション ツール（Archive Server Configuration Tool）が開始します。 ウィザード内のプロンプトに従って、アーカイブ サーバーを構成します。

アーカイブ サーバー、データベース サーバー、Web サーバーと Web2 サーバー、および SQL Server データベースのセットアップ、構成、およびトラブルシューティングを行うには、SOLIDWORKS PDM 2019 インストール ガイドで関連するトピックを参照してください。

目次

  • SOLIDWORKS PDM Server のインストールを変更する

親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SOLIDWORKS PDM Server のインストールを変更する

SOLIDWORKS PDM Server とそのコンポーネントのインストールを変更するには、Windows コントロール パネル（Windows Control Panel）からプログラムと機能（Programs and Features）を使用します。 SOLIDWORKS PDM Server のインストールに使用した場合でも、SOLIDWORKS Installation Manager（SLDIM）でインストールを変更することはできません。

親トピック SLDIM を使用した PDM Server のインストール


SLDIM を使用した PDM Client のインストール

SOLIDWORKS PDM Client のメジャー バージョンは SOLIDWORKS PDM Server のメジャー バージョンと一致させる必要があります。 SOLIDWORKS PDM Client をインストールまたはアップグレードする場合は、バージョンが一致していることを確認してください。

PDM Client をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで個人（Individual）を選択します。
  3. シリアル番号（Serial Number）ページで次へ（Next）をクリックします。
    SOLIDWORKS PDM クライアントは、別個のシリアル番号を必要としません。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページの製品（Products）の下で変更（Change）をクリックします。
  6. 製品選択（Product Selection）ページで別のパッケージ/製品の選択（Select different packages or products）をクリックします。
  7. 表示するパッケージを選択してください（Select the package you want to show）ダイアログ ボックスで SOLIDWORKS のエディションを選択します。 OKをクリックします。
  8. 製品選択（Product Selection）ページで SOLIDWORKS PDM Client を選択します。 次に、eDrawings を選択して、PDM プレビュー機能を有効にします。 SOLIDWORKS PDM Professional を使用している場合は Item Explorer も選択できます。
  9. サマリー（Summary）ページで SOLIDWORKS PDM オプション（SOLIDWORKS PDM Options）を展開して変更（Change）をクリックします。
  10. SOLIDWORKS PDM Client オプション（SOLIDWORKS PDM Client Options）ページで次を選択してサマリーに戻る（Back to Summary）をクリックします。
    • PDM 製品の種類
    • PDM クライアントの種類
    • アドイン
  11. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
管理者は、PDM クライアントのイメージの作成と展開に、アドミニストレーティブ イメージ オプション エディタも使用できます。 詳細については、SOLIDWORKS インストレーションおよびアドミニストレーション ガイド（SOLIDWORKS Installation and Administration Guide）のアドミニストレーティブ イメージの使用（Using Administrative Images）を参照してください。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Electrical は、インテリジェントな設計ツール、包括的な部品データベース、および 2D スキマティックと 3D モデル間のリアルタイム統合によって、電子システム設計を簡略化します。

SOLIDWORKS Electrical の主なコンポーネントは以下のとおりです。
  • SOLIDWORKS Electrical Schematic - 動的な 2D 電気配線を作成するツールです。
  • SOLIDWORKS Electrical 3D - 電気システムを 3D でモデリングできるように、ケーブルやワイヤを含む 2D スキマティックを 3D モデルに統合するツールです。
  • Data - ユーザー間で共有できる部品、記号、ライブラリ、カタログのデータベースです。
  • Collaborative Server - 電気図面のオープンと更新を管理するユーティリティです。
  • Microsoft SQL Server データベースのインスタンス。

SOLIDWORKS Electrical には、Microsoft SQL Server データベースが必要です。 既存のデータベースを使用することも、インストール時に作成した新しいインスタンスを使用することもできます。

SOLIDWORKS Electrical のすべてのコンポーネントを同じマシンにインストールできます。 このインストールは、通常、スタンドアロン インストールとみなされます。 1 つのシステムにすべてのプログラム データ（プロジェクトの図面やレポートなど）が保存されます。 SOLIDWORKS Electrical をインストールする前に、システムに対する完全な管理者権限が必要です。

SOLIDWORKS Electrical のコンポーネントをクライアント/サーバー アプリケーションとしてインストールすることもできます。 このインストールは、データをネットワーク サーバー上に保存する必要がある場合や、すべての SOLIDWORKS Electrical データベースが格納される既存の SQL Server データベースがネットワーク サーバー上にある場合に必要です。 このような場合は、サーバー システムとクライアント システムの両方に完全な管理者権限が必要です。 また、クライアント システムに、サーバーへのネットワーク アクセス権と、プロジェクト、ライブラリ、および記号を作成するための読み取り/書き込み権限が必要です。

SOLIDWORKS Electrical は、1 台のマシンに 1 つのバージョンのみをインストールできます。 SOLIDWORKS の新規インストレーションを作成している場合、インストールする製品の 1 つとして SOLIDWORKS Electrical を選択したときは、古いバージョンの SOLIDWORKS Electrical は削除されます。

新しいバージョンをインストールする前に、常に既存の SOLIDWORKS Electrical 環境をバックアップしてください。 SOLIDWORKS Electrical Schematic 内からファイル（File） アーカイブ環境（Archive Environment）を選択するか、SOLIDWORKS Electrical 3D 内からSOLIDWORKS Electrical > ツール（Tools） > アーカイブ環境（Archive Environment）を選択します。

目次

  • SOLIDWORKS Electrical でのデータの管理

  • SOLIDWORKS Electrical をインストールするための要件


SOLIDWORKS Electrical でのデータの管理

多くのプログラムは、1 つのデータベースを使用してすべてのプログラム データを格納します。 SOLIDWORKS Electrical はこれに該当しません。SOLIDWORKS Electrical の各プロジェクトには一意の ID 番号が割り当てられ、その一意の ID 番号に基づいて識別できるデータベースが各プロジェクトに関連付けられています。 たとえば、SOLIDWORKS Electrical Project Manager で、ID 番号 112 のプロジェクトが存在する場合、関連付けられたデータベースの名前は「tew_project_data_112」になります。

各プロジェクトに一意のデータベースが存在する理由は、それによって処理時間が大幅に短縮されるためです。 また、重大なデータベース障害が発生した場合も、影響を受けるプロジェクトは 1 つだけであり、プログラム情報の大部分の整合性が保持されます。

ただし、新しいデータベースの作成を制限するポリシーを持つ企業もあります。 SOLIDWORKS Electrical を実行するには、ユーザーによる新しいデータベースの作成を制限しないようにする必要があります。 システムまたはデータベースの管理者に問い合わせて、ユーザーによる新しいデータベースの作成を禁止するコンフィギュレーション設定が存在しないことを確認してください。
親トピック SOLIDWORKS Electrical
関連概念
SOLIDWORKS Electrical をインストールするための要件


SOLIDWORKS Electrical をインストールするための要件

最新のシステム要件にアクセスするには、http://solidworks.com/System_Requirements を参照してください。

目次

  • 個別オプションとサーバー オプション

    SOLIDWORKS Electrical は、個別モードかサーバー モードのどちらかでインストールできます。

  • データの場所の指定

  • Collaborative Server の設定

  • Microsoft SQL Server の設定

親トピック SOLIDWORKS Electrical
関連概念
SOLIDWORKS Electrical でのデータの管理


個別オプションとサーバー オプション

SOLIDWORKS Electrical は、個別モードかサーバー モードのどちらかでインストールできます。

SOLIDWORKS Electrical は SQL Server のインスタンス（既存か新規かに関係なく）に接続する必要があることに注意してください。

個別モードでは、以下のコンポーネントをインストールできます。
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • ﾃﾞｰﾀ
  • SQL Server データベースの新規インスタンス
サーバー モードでは、以下のコンポーネントをインストールできます。
  • SQL Server データベースの新規インスタンス
  • Collaborative Server
  • ﾃﾞｰﾀ

個別モードとサーバー モードのコンポーネントを組み合わせて、クライアント/サーバー環境を作成できます。 たとえば、クライアント システムに SOLIDWORKS Electrical Schematic と SOLIDWORKS Electrical 3D をインストールし、サーバー システムにすべてのサーバー コンポーネントをインストールすることができます。

親トピック SOLIDWORKS Electrical をインストールするための要件
関連概念
データの場所の指定
Collaborative Server の設定
Microsoft SQL Server の設定


データの場所の指定

データの場所として、部品、テンプレート、2D と 3D の記号などのプログラム データを保存するディレクトリを選択します。 この場所については、専用のディレクトリを指定してください。 ルート ディレクトリや SOLIDWORKS データの保存に使用するディレクトリは指定できません。

デフォルト ディレクトリは C:\ProgramData\SOLIDWORKS Electrical です。同じディレクトリに Update と言う名前のフォルダが追加され、このフォルダに使用可能なすべてのプログラム データが保存されます。

SOLIDWORKS Electrical を初めて起動すると、データ更新 ウィザードが表示されます。 このウィザードで、アプリケーションや SQL Server データベースに追加するデータを選択できます。
親トピック SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
Collaborative Server の設定
Microsoft SQL Server の設定


Collaborative Server の設定

SOLIDWORKS Electrical を実行するには、Microsoft SQL Server データベースをホストしている同じシステムに Collaborative Server をインストールする必要があります。

Collaborative Server は、常に実行されている必要があり、ファイアウォールとウイルス スキャナーを介してクライアントと常に中断なしで双方向通信を行う必要があります。

Collaborative Server を個別モードまたはサーバー モードでインストールするには、以下のパラメータを指定する必要があります。
  • マシン名（LOCALHOST など）
  • マシンの IP アドレス（127.0.0.1 など）
  • ポート番号（26666 など）

中断なしで双方向通信を行うには、Collaborative Server がインストールされるシステム上でポート番号 26666 が使用可能であることを確認してください。 ポート 26666 にアクセスできない場合は、システム管理者と協力して、SOLIDWORKS Electrical がアクセスできる別のポートを見つけてください。

親トピック SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
データの場所の指定
Microsoft SQL Server の設定


Microsoft SQL Server の設定

SOLIDWORKS Electrical のどのタイプのインストールでも、必ず SQL Server データベースのインスタンスを使用可能にする必要があります。 既存の SQL Server データベースがシステムにインストールされている場合は、それを使用できます。SOLIDWORKS Electrical のインストール時に新しいインスタンスをインストールすることもできます。

SOLIDWORKS のインストールで SQL Server の新しいインスタンスをインストールすると、Microsoft SQL Server Express の無償ライセンス版がインストールされます。 このバージョンは、1 つの CPU、1 GB のメモリ、および 10 GB のデータに制限されています。 このメモリと CPU の制限内で、5 人の同時ユーザーを十分にサポートできます。

SQL Server Express Edition をインストールする場合は、サーバーのソフトウェアとハードウェアが http://solidworks.com/System_Requirements に記載されている要件を満たすことを確認してください。

ただし、同じサーバー上に 6 人以上の同時ユーザーが存在する場合は、SQL Server のフル バージョンを購入してインストールし、既存の SQL Server インスタンスを使用して SOLIDWORKS Electrical をインストールする場合のワークフローを使用してください。

SQL Server Express Edition については、Microsoft SQL Server のドキュメントを参照してください。

親トピック SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
データの場所の指定
Collaborative Server の設定

SQL Server の新しいインスタンス

SQL Server の新しいインスタンスをインストールする場合は、サーバーおよびクライアント システムに対する完全な管理者権限が必要です。 また、クライアントにデータベースの読み取り/書き込み権限があり、クライアントでプロジェクト、ライブラリ、記号、およびその他のプロジェクト データを作成できることを確認する必要があります。

SQL Server の新しいインスタンスをインストールする場合は、デフォルト以外の名前を選択してください。

SQL Server の既存のインスタンス

新しい SOLIDWORKS Electrical データベースをインストールする場合、または SQL Server の既存のインスタンスにインストールされた SOLIDWORKS Electrical に接続する場合は、SQL Server データベースに対する完全な管理者権限を持つユーザー アカウントが必要です。

SOLIDWORKS Electrical が正しく機能するには、SQL Server の混合モード認証を有効にする必要があります。 混合モード認証では、Windows と SQL Server のどちらかの認証情報を使用できます。

既存の SQL Server データベースに接続するには、Windows 認証または SQL Server 認証を使用します。 SQL Server に対する完全な管理者権限を持つユーザーが Windows または SQL Server にログインするためのユーザー名とパスワードを入力します。

インストール時に「tew」ユーザーを使用して SQL Server に接続することはできません。 SQL Server に対する適切な認証情報を含むログインの取得方法については、SQL Server 管理者またはシステム管理者に問い合わせてください。

SQL Server のインストール後処理

SOLIDWORKS Electrical をインストールした後は、SQL Server インスタンスによって SOLIDWORKS Electrical の以下のデータベースが作成されます。
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


SOLIDWORKS PCB

SOLIDWORKS® PCB（以前の PCBWorks）は PCB（プリント基板）設計ツールで、SOLIDWORKS 3D 設計ソフトウェアに統合されています。 SOLIDWORKS Installation Manager によって、個人（individual）インストールの一部としてインストールされます。

電気系エンジニアは、SOLIDWORKS PCB を使用すると、プリント基板を変更して、その変更を共有リポジトリにプッシュできます。 機械系エンジニアは、SOLIDWORKS ソフトウェアを使用して、変更済み基板をリポジトリから引き出して変更を解析し、さらに変更して、その設計をリポジトリに戻すことができます。リポジトリでは、電気系エンジニアがその設計に再びアクセスできます。

このコラボレーションを可能にするには、SOLIDWORKS PCB サービスをインストールして、共有サーバーでリポジトリを管理する必要があります。 これは SOLIDWORKS Installation Manager によってサーバー（Server）インストールの一部としてインストールされ、別のライセンスは必要ありません。 これには Microsoft Internet Information Services とデータベースが含まれ、電気系設計者と機械系設計者は作業の同期に使用するデータを保存します。

ネットワーク環境では、一般的に SOLIDWORKS ソフトウェアを実行しない共有サーバーに SOLIDWORKS PCB Services をインストールします。 その他の SOLIDWORKS PCB コンポーネントとともに、単一マシンにインストールすることもできます。 SOLIDWORKS PCB Services は常時動作している必要があり、ファイアウォールとウィルス スキャナによって、SOLIDWORKS PCB と SOLIDWORKS ソフトウェアを実行しているクライアントおよび SOLIDWORKS ソフトウェアに統合される Altium Designer を実行しているクライアントと、中断のない双方向通信を行います。
SOLIDWORKS PCB をインストールする前に、SOLIDWORKS PCB Services をインストールすることが推奨されます。

さらに、SOLIDWORKS ソフトウェアを実行しているマシンでは、SOLIDWORKS PCB アドインというもう 1 つの構成部品も有効にする必要があります。 アドインは、ツール（Tools） > アドイン（Add-ins）で有効にできます。

Altium Designer のライセンスを持つ電気系エンジニアも、SOLIDWORKS 3D 設計ソフトウェア ユーザーと、リポジトリによって設計をやり取りできます。 このようなやり取りを行うには、SOLIDWORKS PCB Connector をインストールする必要があります。 このソフトウェアは Altium Designer クライアントでインストールされます。

目次

  • 前提条件

  • SLDIM を使用した PCB サービスのインストール

  • SLDIM を使用した PCB のインストール

  • デフォルトの管理者ログインの変更

  • Altium Designer 用 PCB Connector のインストール

  • インストール後

  • PCB Services のアップグレード

  • PCB サービスをアンインストールする


前提条件

インストールする前に、次の前提条件を満たしている必要があります。
  • SOLIDWORKS PCB のシリアル番号。
  • SOLIDWORKS ソフトウェアに統合される Altium Designer クライアントの SOLIDWORKS PCB Connector シリアル番号。

現在のシステム要件にアクセスするには、http://solidworks.com/System_Requirements を参照してください。

親トピック SOLIDWORKS PCB


SLDIM を使用した PCB サービスのインストール

SOLIDWORKS PCB サービスをインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページでサーバー製品（Server Products）を選択します。
  3. SOLIDWORKS PCB サービスをこのコンピュータにインストール（Install SOLIDWORKS PCB Services on this computer）を選択し、次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS PCB サービスのデフォルト設定を受け入れるか、変更（Change）をクリックして次の設定を指定します。
    • インストレーション先
    • データベース フォルダ
    • リビジョン ファイル フォルダ
    • ポート番号

    PCB Services には Microsoft Internet Information Services とデータベースが含まれ、電気系デザイナーと機械系デザイナーが作業の同期に使用するデータを保存します。

    デフォルトのポート番号は 9780 です。

  6. SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
親トピック SOLIDWORKS PCB


SLDIM を使用した PCB のインストール

SOLIDWORKS PCB をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで個人（Individual）を選択します。
  3. 以下を行います：
    1. 電気設計（Electrical Design）を展開します。
    2. SOLIDWORKS PCB を選択し、シリアル番号を入力します。
    3. 次へ（Next） をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
親トピック SOLIDWORKS PCB


デフォルトの管理者ログインの変更

SOLIDWORKS PCB Services では、次の認証情報を持つデフォルト管理者アカウントが提供されます:
  • admin（ユーザー名）
  • admin（パスワード）
セキュリティを高めるためには、このアカウントのログイン認証情報を変更することが推奨されます。

デフォルトの管理者ログインを変更するには:

  1. Web ブラウザを開き、アドレス バーに、マシン名およびポート番号を次の形式で入力します: http://server name:port number.

    デフォルトのポート番号は 9780 です。

  2. SOLIDWORKS PCB Services にサインイン（Sign in to SOLIDWORKS PCB Services）ページで、Username として admin、Password として admin を入力し、サインイン（Sign In）をクリックします。
  3. SOLIDWORKS PCB ServicesメニューでUSERSをクリックし、ユーザー（Users）タブをクリックします。
  4. 管理者アカウントに関連付けられたリンクをクリックするか、またはユーザーの編集（Edit User）アイコン [image] をクリックします。
  5. ユーザー情報、ユーザー名、およびパスワードを変更します。
  6. 保存（Save）をクリックします。
親トピック SOLIDWORKS PCB


Altium Designer 用 PCB Connector のインストール

Altium Designer は、PCB（プリント基板）設計ツールです。 Altium Designer をライセンス許諾されインストールしたユーザーは、SOLIDWORKS PCB Connector をインストールすることによって、これを SOLIDWORKS ソフトウェアと統合することができます。

Altium Designer を実行しているマシンに、SOLIDWORKS PCB Connector をインストールするには:

  1. 自動的にサインインされていない場合は、Altium アカウントにサインインします。
  2. Altium Designer を起動し、DXP タブを開き、Extensions and Updates をクリックします。
  3. Extensions and Updates ページで 購入済み（Purchased） タブをクリックします。
  4. Software Extensions セクションまで、下にスクロールします。 SOLIDWORKS PCB Connector で、タイルの右上隅にある下矢印をクリックし、インストールをダウンロードして開始します。

  5. 確認（Confirm） ダイアログ ボックスで、Yes をクリックし、インストールを続行します。
    アクティベーションおよびインストールの問題を回避するため、ステップ 6 および 7 は、指定された順に実行してください。
  6. PCB Connector Registration ページで、SOLIDWORKS PCB Connector のシリアル番号を入力し、登録（Register） をクリックします。
  7. Altium Designer アプリケーションによって表示される 確認（Confirm） ダイアログ ボックスで、はい（Yes） をクリックするとシステムが再起動されてインストールを完了し、いいえ（No） をクリックすると後でインストールが完了します。

SOLIDWORKS PCB Connector ライセンスを非アクティブ化するには、ヘルプ（Help） メニューで、SOLIDWORKS PCB Connector のライセンス（SOLIDWORKS PCB Connector Licensing） > ライセンスの非アクティブ化（Deactivate Licenses）をクリックします。

親トピック SOLIDWORKS PCB


インストール後

SOLIDWORKS PCB とそのコンポーネントをインストールすると、ユーザー アカウントを SOLIDWORKS PCB サービスに追加し、ユーザーがリポジトリからボードにアクセスできるようにします。

その他のタスクには、SOLIDWORKS PCB アドイン リポジトリへのログインおよびソフトウェアのアンインストールが含まれています。

目次

  • PCB サービスへのユーザーの追加

  • PCB リポジトリへのログイン

親トピック SOLIDWORKS PCB


PCB サービスへのユーザーの追加

SOLIDWORKS PCB サービス Web サイトにユーザーを追加するには:

  1. Web ブラウザを開き、アドレス バーに、SOLIDWORKS PCB サービスに割り当てられているサーバー名とポート番号を入力します。 たとえば、次の形式で入力します。 http://server name:port number.
  2. SOLIDWORKS PCB サービスにサインイン（Sign in to SOLIDWORKS PCB Services）ページで、管理者ユーザー名とパスワードを入力し、サインイン（Sign In）をクリックします。
  3. SOLIDWORKS PCB サービスメニューでユーザー（Users）をクリックし、ユーザー（Users）タブをクリックします。
  4. ユーザーの追加（Add User）ボタンをクリックして、以下を入力します。
    • ﾌｧｰｽﾄﾈｰﾑ(名)
    • ﾗｽﾄﾈｰﾑ(姓)
    • ユーザー名（User Name）
    • ﾊﾟｽﾜｰﾄﾞ
    • 電子メール アドレス
    • 電話番号

    ユーザー ロール（User Role）を選択し、メンバー（Member）ボックスをオンにしてユーザーをグループに関連付ける必要もあります。

  5. 保存（Save）をクリックします。
ユーザー（User）タブでユーザー情報を編集できます。
親トピック インストール後


PCB リポジトリへのログイン

SOLIDWORKS では、PCB アドイン（PCB Add-in）タスク パネルで新しい基板を選択したり既存の基板を取得したりする場合は、SOLIDWORKS PCB サービスにログインしてリポジトリにアクセスする必要があります。

SOLIDWORKS PCB リポジトリにログインするには:

  1. SOLIDWORKS タスク パネルで SOLIDWORKS PCB アドイン（SOLIDWORKS PCB Add-in）ボタン [image] をクリックします。
  2. 新規基板アセンブリ（New Board Assembly）またはボルトから基板を取得（Pull Board From Vault）をクリックします。
  3. SOLIDWORKS PCB サービスにログインします。
    1. SOLIDWORKS PCB サービスに割り当てられているサーバー名とポート番号を指定します。 たとえば、次の形式で入力します。 http://server name:port number.
    2. ユーザー名（Username）とパスワード（Password）を入力し、OK をクリックします。
親トピック インストール後


PCB Services のアップグレード

SOLIDWORKS PCB Services を 2019 にアップグレードするとき、SOLIDWORKS Installation Manager によって Firebird データベースがリリース 2.0 から 3.0 にアップグレードされ、データは自動的に移行されます。 アップグレードする前に、データベースの手動バックアップを行なってください。

SOLIDWORKS PCB Services をアップグレードするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページでサーバー製品（Server Products）を選択します。
  3. SOLIDWORKS PCB サービスをこのコンピュータでアップグレード（Upgrade SOLIDWORKS PCB Services on this computer）を選択し、次へ（Next）をクリックします。

    次のメッセージが表示されます。 SOLIDWORKS PCB Services では、Firebird データベースをアップグレードする必要があります。 続行すると、Firebird ソフトウェアとデータベースはアップグレードされます。

  4. 次へ（Next）をクリックします。
  5. サマリー（Summary）ページでデフォルト設定を受け入れるか、変更（Change）をクリックしてその他の設定を指定します。
  6. SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
親トピック SOLIDWORKS PCB


PCB サービスをアンインストールする

SOLIDWORKS PCB サービスをアンインストールするには:

  1. スタート（Start） > すべてのプログラム（All Programs） > SOLIDWORKS バージョン > SOLIDWORKS PCB サービス（SOLIDWORKS PCB Services） > SOLIDWORKS PCB サービスをアンインストール（Uninstall SOLIDWORKS PCB Services）をクリックします。
  2. SOLIDWORKS PCB サービスとそのコンポーネントを除去するかどうか、プロンプトが表示されたら、はい（Yes）をクリックします。
  3. すべての SOLIDWORKS PCB サービス データを削除するかどうか、プロンプトが表示されたら、いいえ（No）をクリックします。
    すべてのデータおよびリビジョン ファイルが完全に削除されないようにする場合は、いいえ（No）をクリックする必要があります。
親トピック SOLIDWORKS PCB


SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize（以前の Bunkspeed）は、高度なレンダリング機能と設計指向の機能およびワークフローを組み合わせたスタンドアロン ソフトウェア ツール一式を備えます。これにより、3D CAD モデルの非常にリアルなイメージを作成できます。

SOLIDWORKS Visualize 製品は、次の 2 つのパッケージで利用できます:
  • 標準
  • Professional

SOLIDWORKS Visualize ソフトウェアの各バージョンの現行機能のリストについて は、 solidworks.com に移動して、 SOLIDWORKS Visualize データシート（SOLIDWORKS Visualize Datasheet）を検索してください。

SOLIDWORKS Visualize Standard の無償シートは、アクティブなサブスクリプションの SOLIDWORKS 2019 Professional および Premium ライセンスそれぞれに含まれています。 無償シートをアクティブ化するには、追加のシリアル番号が必要です。これは、SOLIDWORKS カスタマー ポータルにログインし、マイ プロダクト（My Products）をクリックすると、見つけることができます。 SOLIDWORKS Professional または Premium のシリアル番号を使用して、SOLIDWORKS Visualize Standard の無償シートをアクティブ化することはできなくなりました。

SOLIDWORKS Visualize は、オフライン アクティベーションの他、フローティングなどの SolidNetWork Licensing（SNL）ライセンス タイプもサポートします。

SOLIDWORKS Installation Manager（SLDIM）を使用して、SOLIDWORKS Visualize を個人インストールの一部としてインストールします。 スタンドアロン アプリケーションとしてインストールできるため、モデリングとレンダリングに別々のコンピュータを使用する場合に有効です。 SOLIDWORKS ライセンスは使用しません。

SOLIDWORKS Visualize Boost は、SOLIDWORKS Visualize Professional を実行しているコンピュータから、ネットワーク上の 1 つ以上のコンピュータにレンダリングを配布できるサービスです。 レンダリングが行われている間に、コンピュータ上で他のタスクを実行でき、最終レンダリング イメージがより早く利用可能になります。 Visualize Boost を実行している 1 台のコンピュータ、または複数コンピュータのクラスタ上で、イメージをレンダリングできます。

SOLIDWORKS Visualize Boost の無償シートは、アクティブなサブスクリプションの SOLIDWORKS Visualize Professional 2019 の各シートに含まれています。
Visualize Boost は、Visualize Professional のみに対するプロダクト アドオンです。 Visualize Boost は、Visualize Standard では機能しません。

Visualize Boost は、SOLIDWORKS Visualize Professional を実行しているコンピュータとは異なるコンピュータにインストールする必要があります。 Visualize Boost は、SLDIM の個人（Individual）インストールの一部としてインストールすることもできます。

目次

  • 前提条件とシステム要件

  • SLDIM を使用した SOLIDWORKS Visualize のインストール

  • SLDIM による Visualize Boost のインストール


前提条件とシステム要件

SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost をインストールするには、各マシンで次の前提条件が必要になります。
  • SOLIDWORKS Visualize シリアル番号
  • SOLIDWORKS Visualize Boost シリアル番号
SOLIDWORKS Visualize または SOLIDWORKS Visualize Boost を実行する各コンピュータは以下の要件を満たす必要があります。
  • Windows® 7 以降（64 ビット）
  • デュアルコア CPU、クアッドコアを推奨
  • 8GB の RAM、16GB を推奨
  • 2GB の空きディスク容量、5GB を推奨
  • 2GB 以上の GPU RAM、4GB を推奨
  • NVIDIA® グラフィックス カード: NVIDIA Quadro®/NVIDIA GeForce®/Tesla™（NVIDIA Kepler™ チップ以上）、NVIDIA Maxwell™ 以上のカードによるデュアル GPU 設定（最適な結果を得るには）
  • NVIDIA ドライバ バージョン 385.41（以降）推奨
  • CUDA® 9.0 以降をサポートする NVIDIA ドライバが必要
  • HDR Light Studio 接続: HDR Light Studio v5.3.3 以降（v5.4 を除く）
  • 4GB のビデオ メモリ。ノイズ除去機能にはそれ以上のビデオ メモリが必要
非 NVIDIA グラフィック カードがインストールされている場合、SOLIDWORKS Visualize のデフォルト設定は CPU（中央プロセッシング ユニット）となり、これらのカードを GPU-アクセラレーションに使用します。 また、Fermi™ アーキテクチャを基盤とする NVIDIA カードが GPU アクセラレーションをサポートしなくなりました。
親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


SLDIM を使用した SOLIDWORKS Visualize のインストール

SOLIDWORKS Visualize をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで個人（Individual）を選択します。
  3. 以下を行います：
    1. シリアル番号（Serial Number）ページで Visualization を展開します。
    2. SOLIDWORKS Visualize を選択し、シリアル番号を入力します。
    3. 次へ（Next） をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。

デスクトップで SOLIDWORKS Visualize ショートカット アイコンをダブルクリックしてアプリケーションを開始するか、または Windows のスタート（Start）メニューから、すべてのプログラム（All Programs） > SOLIDWORKS バージョン > SOLIDWORKS Visualize バージョン をクリックします。

目次

  • インストール後のタスク

親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


インストール後のタスク

インストール後、SOLIDWORKS Visualize をセットアップするために実行する必要があるタスクがいくつかあります。

目次

  • 内容フォルダの作成

  • レンダリング モードの選択

  • ヘルプ、チュートリアル、システム情報、およびライセンスへのアクセス

親トピック SLDIM を使用した SOLIDWORKS Visualize のインストール


内容フォルダの作成

ソフトウェアを初めて起動すると、SOLIDWORKS Visualize から内容（Content）フォルダを作成する場所が求められます。

内容（Content）フォルダには次のサブフォルダが含まれ、プロジェクトのアセットを格納できます:
サブフォルダ | ストア（Stores）
カメラ（Cameras） | デフォルトのカメラおよび保存したカメラ
環境（Environments） | ハイ ダイナミック レンジ（HDR）イメージ
パレット（Palettes） | エクスポートしたパレット ファイル
イメージ（Images） | レンダリングおよびスナップショット
外観（Appearances） | 外観ライブラリの材料 外観をライブラリに追加すると、内容が更新されます。
モデル（Models） | モデル ファイル（Model files） デフォルトでは、モデルでファイル（File） > インポート（Import）を使用すると、SOLIDWORKS Visualize は最初にこのフォルダを検索します。
プレート（Plates） | バックプレートで使用するための標準 2D イメージ
プロジェクト（Projects） | .SVP 形式のネイティブ プロジェクト ファイル
テクスチャ（Textures） | 外観で使用するための 2D テクスチャ
親トピック インストール後のタスク


レンダリング モードの選択

各システムは、それぞれのレンダリング モードにより異なる結果を生み出すことができます。 最適なモードを設定する前に、各レンダリング モードを試してみてください。

レンダリング モードを選択するには:

  1. ツール（Tools） > オプション（Options） > 3D ビューポート（3D Viewport）をクリックします。
  2. デバイスのレンダリング（Render Device）で、自動（Automatic）をクリアします。
  3. レンダリング モードを選択します:
    • CPU、CPU がグラフィックス カードより著しく強力な場合。
    • GPU、1 GB を超える VRAM を搭載した nVidia CUDA 対応 GPU のような強力なビデオ カードを持っている場合。
    • ハイブリッド（Hybrid）、適切な nVidia カードと同等の CPU とのバランスのとれたシステムの場合。

詳細は、はじめに（Getting Started） を参照してください。

親トピック インストール後のタスク


ヘルプ、チュートリアル、システム情報、およびライセンスへのアクセス

ヘルプ メニューには、ソフトウェアを更新したり、システムをトラブルシューティングするためのドキュメントおよびオプションが含まれています。

Visualize ヘルプ（Visualize Help） | SOLIDWORKS Visualize オンライン ヘルプを開きます。
Visualize チュートリアル（Visualize Tutorials） | MySolidWorks を開き、SOLIDWORKS Visualize のチュートリアルにアクセスできるようにします。
リリース ノート(Release Notes): | 現在のバージョンのオンライン リリース ノートを表示します。
新規機能（What's New） | SOLIDWORKS 製品の新機能を表示します。
ホット キー | ショートカット キーがリストされます。
システム情報 | 使用中の PC ハードウェアで SOLIDWORKS Visualize ソフトウェアのシステム チェックを実行し、必要な場合はアップグレードを提案します。
ライセンスのアクティブ化（Activate License） | （ノードロック ライセンス）SOLIDWORKS 製品アクティベーション ウィザードを使用して製品をアクティブ化します。
ライセンスを無効化（Deactivate License） | （ノードロック ライセンス）SOLIDWORKS 製品アクティベーション ウィザードを使用して製品を無効化します。
SolidNetWork ライセンス マネージャー(SolidNetWork License Manager) | SOLIDWORKS 製品アクティベーション ウィザードを使用して製品を無効化します。
Visualize のバージョン情報（About Visualize） | SOLIDWORKS Visualizeのバージョン番号およびライセンス情報が表示されます。
親トピック インストール後のタスク


SLDIM による Visualize Boost のインストール

Visualize Boost は、SOLIDWORKS Installation Manager を使用してインストールします。 別のシリアル番号が必要です。

Visualize Boost の目的はレンダリングをオフロードすることにあるため、Visualize Boost は SOLIDWORKS Visualize Professional を実行するコンピュータとは別のコンピュータにインストールする必要があります。 CPU コアとグラフィックス プロセッシング ユニット（GPU）を複数備えたコンピュータに Visualize Boost をインストールすると、レンダリングのパフォーマンスが最大になる可能性があります。

SOLIDWORKS Visualize Boost をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで個人（Individual）を選択します。
  3. 以下を行います：
    1. シリアル番号（Serial Number）ページで Visualization を展開します。
    2. SOLIDWORKS Visualize Boost を選択し、シリアル番号を入力します。
    3. 次へ（Next） をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。

デスクトップ上で、SOLIDWORKS Visualize Boost ショートカット アイコンをダブルクリックして、インタフェースを開きます。

目次

  • Visualize Boost ライセンスのアクティブ化

    本品をレンダリングで使用する前に、SOLIDWORKS Visualize Boost を Web インターフェースからアクティブ化して構成する必要があります。 Chrome、Firefox、または Internet Explorer ブラウザが対応しています。

  • Visualize Boost の設定

親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


Visualize Boost ライセンスのアクティブ化

本品をレンダリングで使用する前に、SOLIDWORKS Visualize Boost を Web インターフェースからアクティブ化して構成する必要があります。 Chrome、Firefox、または Internet Explorer ブラウザが対応しています。

Visualize Boost をアクティブ化して構成した後は、システム起動時に自動的に起動してバックグラウンドで稼働します。 他に必要な操作はありません。

SOLIDWORKS Visualize Boost ライセンスをアクティブ化するには:

  1. 次のいずれかを実行します:
    1. デスクトップで、Visualize Boost ショートカット アイコンをダブルクリックします。
    2. ブラウザを開き、次の URL を入力します。 http://localhost:8993/config.html。
  2. メール アドレスを入力し、ライセンスを有効化（Enable License）をクリックします。
親トピック SLDIM による Visualize Boost のインストール


Visualize Boost の設定

ほとんどのネットワークでは、コンピュータを Visualize Boost 用に設定するにはデフォルトの設定で十分ですが、ネットワーク環境で他の設定が必要な場合は、以下の手順に従って、手動でコンピュータを設定してください。

コンピュータを Visualize Boost でレンダリング クラスタになるように設定するには:

  1. 次のいずれかを実行します:
    1. システムで SOLIDWORKS Visualize Boost が実行されている場合は、デスクトップ上で Visualize Boost ショートカット アイコンをダブルクリックするか、ブラウザを開き、次の URL を入力します: http://localhost:8993/config.html。
    2. 別のシステムを使用している場合は、ブラウザを開いて次の URL を入力します。 http://<IP アドレス>:8993/config.html または http://<DNS 名>:8993/config.html。
  2. 画面の右上隅にあるドロップダウン リストから、言語（Language）を選択します。
  3. 設定タブをクリックし、Visualize Boost ノードを設定します。
  4. クラスタ名（Cluster Name）フィールドで超高速レンダー（Superfast Render）、プレゼンテーション クラスタ（Presentation Cluster）、または4 階のコンピュータ（4th Floor Computers）などのコンピュータ名を指定します。

    クラスタ名は SOLIDWORKS Visualize Professional にクラスタ プロファイルとして表示されます。 イメージをレンダリングするために、SOLIDWORKS Visualize Professional を実行するユーザーは利用可能な Boost クラスタからクラスタ プロファイルを選択します。

    クラスタ名を Visualize Professional コンピュータ上でローカルで指定するのでなく、Visualize Boost コンピュータ上で指定して、すべての Visualize ユーザーが Visualize Boost プロファイル リストで同じクラスタ名にアクセスするようにすることをお勧めします。
  5. クラスタ クライアント アクセス ポート（Cluster Client Access Port）を入力します。
    これは、SOLIDWORKS Visualize を実行するコンピュータが Boost クラスタに接続するために使用するポートです。 デフォルトのクラスタ クライアント アクセス ポートは 8998 です。
  6. ネットワーキング モード（Networking Mode）エリアで、ご利用のネットワーク環境に基づいてオプションを選択します。
    • このコンピュータを他のクラスタに属さないようにするには、ネットワーキングなし（No Networking）を選択します。 このモードは、Visualize Boost に関わる問題のトラブルシューティングに便利です。
    • ネットワークが UDP マルチキャストに対応している場合は、UDP マルチキャスト モード（UDP Multicast Mode）を選択します。 Visualize Boost はネットワークを検索して、同じポート上で UDP マルチキャスト モードを使用するすべてのコンピュータから 1 つのクラスタを形成します。 このモードは、ネットワークが対応している場合にお勧めします。
    • UDP マルチキャスト モードを使用できない場合は、ディスカバリーによる TCP モード（デフォルト）（TCP Mode with Discovery （Default））を選択します。 Visualize Boost はネットワークを検索して、同じポート上で ディスカバリーによる TCP モードを使用するすべてのコンピュータから 1 つのクラスタを形成します。
    • TCP モード（TCP Mode）は、クラスタ内のコンピュータの明示的なリストを作成する場合（他のモードでは含めたいコンピュータを見つけることができない）に選択します。 このモードには追加の設定作業が必要なため、UDP マルチキャストまたはディスカバリーによる TCP モードを利用できる場合にはお勧めしません。
  7. UDP マルチキャスト モード（UDP Multicast Mode）またはディスカバリーによる TCP モード（TCP Mode with Discovery）を選択する場合は、クラスタ検出アドレス（Cluster Discovery Address）を入力します。
    この設定は、IP アドレスおよび1024 より上のポートでなければなりません。デフォルトのポートはネットワーキング モードにより異なります。
    • 8994 （UDP マルチキャスト）
    • 8995 （ディスカバリーによる TCP モード）
    • 8996 （TCP）

    これらのポートは Visualize Boost コンピュータで相互接続に使用されます。 同じローカル ネットワーク上にある同じクラスタ検出アドレス（Cluster Discovery Address）で設定されたすべてのコンピュータで 1 つのクラスタを形成します。

  8. TCP モード（TCP Mode）を選択する場合:
    • クラスタ アクセス ポート（Cluster Access Port）を入力します。 これは、クラスタ内の Visualize Boost ノードが相互に通信するポートです。 TCP モードのデフォルト ポートは、8996 です。
    • このマシンがクラスタの「ヘッド ノード」（クラスタの作業を調整するマシン）になる場合、クラスタ アドレス リスト（Cluster Address List）フィールドを使用してクラスタ内の他のノードのIP アドレスをリストします。 各 IP アドレス（192.168.0.100:8996 など）はクラスタ内のすべてのノードに設定されたクラスタ アクセス ポート（Cluster Access Port）を含む必要があります。 このマシンがクラスタのヘッド ノードにならない場合は、このフィールドは空白のままにしてください。
  9. コンフィギュレーションの保存（Save Configuration）をクリックします。 Visualize Boost は新しいコンフィギュレーションを保存し、サービスを停止して、再開します。
  10. ステータス（Status）タブをクリックします。 ステータスが準備完了（Ready）の場合、画面にはクラスタ内で接続されたコンピュータおよびクラスタに割り当てられたセッション（Sessions）（ジョブ）が表示されます。
親トピック SLDIM による Visualize Boost のインストール


SOLIDWORKS Admin Portal とオンライン ライセンス

SOLIDWORKS Admin Portal は、クラウドベースのアセットおよびサービス管理システムで、オンライン ライセンスを割り当ておよび管理できます。

Admin Portal を使用すると、SOLIDWORKS オンライン ライセンスの監視、アカウントへのメンバーの招待、メンバーへの製品およびサービスの割り当て、新しい管理者の作成を簡単に行えます。 また、ユーザーがリモート位置にいる場合でも、ユーザーをライセンスから除去できます。

SOLIDWORKS ユーザーは、オンライン ライセンスによって、どこにいても 1 つの SOLIDWORKS ライセンスをすべてのデバイスで柔軟に使用できるようになり、各マシンでライセンスを手動でアクティブ化および非アクティブ化する必要がありません。 サインインしてオンライン ライセンスを使用するには、インターネットにアクセスする必要がありますが、サインインした後は、オフライン モードを選択して、デバイスがネットワークに接続されていない状態で作業できます。

目次

  • Admin Portal へのアクセス

    Admin Portal にアクセスするには、SOLIDWORKS ID と、MySolidWorks Guest、Standard、または Professional アカウントが必要です。

  • 管理者のタスク

    管理者は、一般に、ユーザー アカウントおよびオンライン ライセンスの管理を担当します。

  • オンライン ライセンスを使用した SOLIDWORKS 製品の使用

  • CAD Admin Dashboard へのアクセス

    SOLIDWORKS のサブスクリプション契約をお持ちの場合は、Admin Portal から SOLIDWORKS CAD Admin Dashboard に、再度ログインすることなくアクセスできます。


Admin Portal へのアクセス

Admin Portal にアクセスするには、SOLIDWORKS ID と、MySolidWorks Guest、Standard、または Professional アカウントが必要です。

ただし、有効な SOLIDWORKS ID をお持ちの商用のお客様は、サブスクリプション ステータスに関係なく、適格な場合に MySolidWorks.com にログインして Admin Portal にアクセスできます。

Admin Portal にアクセスするには:

  1. MySolidWorks.com にサインインします。
  2. プロファイル名の下で、リストを展開して Admin Portal をクリックします。
親トピック SOLIDWORKS Admin Portal とオンライン ライセンス
関連概念
管理者のタスク
オンライン ライセンスを使用した SOLIDWORKS 製品の使用
CAD Admin Dashboard へのアクセス


管理者のタスク

管理者は、一般に、ユーザー アカウントおよびオンライン ライセンスの管理を担当します。

デフォルトでは、SOLIDWORKS ソフトウェアはマシン アクティベーションを使用するようにセットアップされます。 Admin Portal でオンライン ライセンスを有効にするための基本的な手順は、次のとおりです。
  1. SOLIDWORKS ソフトウェアをマシンにインストール済みである場合は、ライセンスを手動で非アクティブ化します。
  2. 製品のアクティベーション タイプを、マシン アクティベーションからオンライン ライセンスに設定します。
  3. 次に、メンバー（ユーザー）に製品およびサービスを割り当てます。

目次

  • 最初の管理者アカウントの作成

    Admin Portal 上のアカウントに最初にアクセスする人は、次の条件を満たす場合に、自分を最初の管理者に昇格できます。

  • 製品およびサービスの管理

  • メンバーおよびライセンスの管理

  • オンライン ライセンスを使用するように製品を設定する

    デフォルトでは、SOLIDWORKS ソフトウェアはマシン アクティベーションを使用するようにセットアップされます。 SOLIDWORKS ソフトウェアをマシンにインストール済みである場合は、手動でライセンスを非アクティブ化してから、アクティベーション タイプを変更してオンライン ライセンスを使用する必要があります。

  • 管理者へのユーザーの昇格

    アカウントに管理者がいる場合は、管理者の連絡先情報が Admin Portal に表示されます。 ユーザーは管理者に連絡して、アカウントの管理者になることを要求できます。

  • SOLIDWORKS Customer Portal でのマイプロダクトの登録

    いったん管理者が会社で宣言されると、SOLIDWORKS Customer Portal でその会社からユーザーが製品を登録することができなくなります。

親トピック SOLIDWORKS Admin Portal とオンライン ライセンス
関連概念
オンライン ライセンスを使用した SOLIDWORKS 製品の使用
CAD Admin Dashboard へのアクセス
関連タスク
Admin Portal へのアクセス


最初の管理者アカウントの作成

Admin Portal 上のアカウントに最初にアクセスする人は、次の条件を満たす場合に、自分を最初の管理者に昇格できます。

  • アカウントが自分のプライマリ アカウントである。
  • アカウントにアセットがある。
  • アカウントに製品を登録済みである。

アカウントに関連付けられていない場合、またはアカウントにアセットがない場合は、SOLIDWORKS カスタマー センターまでご連絡ください。

アカウントの最初の管理者として自分を割り当てるには:

  1. MySolidWorks.com にサインインし、自分のプロファイル名の下にあるリストを展開し、Admin Portal を選択します。

    ようこそページで、現在の管理者がいないことが通知されます。

  2. SOLIDWORKS 製品のライセンス割り当てを管理するための使用条件および責任を確認し、同意します。
  3. 自分を管理者に昇格（Promote me to Administrator）をクリックします。
親トピック 管理者のタスク
関連概念
製品およびサービスの管理
メンバーおよびライセンスの管理
オンライン ライセンスを使用するように製品を設定する
SOLIDWORKS Customer Portal でのマイプロダクトの登録
関連タスク
管理者へのユーザーの昇格


製品およびサービスの管理

Admin Portal には、製品（Products）タブとサービス（Services）タブが含まれています。 製品（Products）タブを使用して、製品を割り当ておよびアクティブ化します。 サービス（Services）タブを使用して、e ラーニング コースおよび MySolidWorks Pro などのサービスをメンバーに割り当てます。

サービスは製品と異なり、トランスファーできません。 サービスをメンバーに割り当てたら、そのメンバーからサービスを除去できません。

製品（Products）の管理は、 、ネットワーク ライセンス製品を含むマシン アクティベーション（machine activation）製品のオプションです。

メンバーに名前を付けて製品を割り当てることで、次のメリットがあります。
  • メンバーは、インストール マネージャのログイン機能を使用して、割り当てられているシリアル番号をインストールできます。
  • メンバーへのサブスクリプション製品の割り当てると、サブスクリプション コンテンツへのオンラインでのアクセスが許可されます。

ただしこの場合、メンバーに名前を付けて、製品をマシン アクティベーション製品に割り当てる必要はありません。 マシン アクティベーション製品へのアクセスは、管理ポータルの割り当てに関係なく、ライセンス サーバーまたはアクティベーション イベントによってゲートされます。 大規模な組織では、すべてのメンバーとその製品を管理することはできません。

製品（Products）の管理は、オンライン ライセンスに必要です。 同様に、サービス（Services）を名前付きメンバーに割り当てる必要があります。

親トピック 管理者のタスク
関連概念
メンバーおよびライセンスの管理
オンライン ライセンスを使用するように製品を設定する
SOLIDWORKS Customer Portal でのマイプロダクトの登録
関連タスク
最初の管理者アカウントの作成
管理者へのユーザーの昇格


メンバーおよびライセンスの管理

目次

  • アカウントへの新規メンバーの招待

    管理者は、アカウントに参加するように新規メンバーを招待できます。

  • アカウントからのメンバーの除去

    管理者は、メンバーを除去する前に、まずメンバーのアカウントに割り当てられているすべての製品を除去する必要があります。

  • メンバーへの製品の割り当て

    管理者は、製品タイプごとに 1 つの製品のみをメンバーに割り当てることができます。 たとえば、メンバーには 1 つの CAD 製品のみを割り当て、1 つの Simulation 製品のみを割り当てることができます。

  • 製品へのメンバーの割り当て

  • メンバーへのサービスの割り当て

  • メンバーからのライセンスの除去

    メンバーから製品を除去できます。

  • メンバーの検索と、ユーザー権限および割り当てられた製品の確認

    Admin Portal では、複数の方法を使用して、ユーザーを検索し、ユーザー権限および割り当てられた製品を監視できます。

  • 製品の検索と、製品に割り当てられているユーザーの確認

    Admin Portal では、複数の方法を使用して、製品を検索し、それらの製品に割り当てられているユーザーを監視できます。

  • 外部メンバーからの製品の除去

    外部メンバーとは、組織外の人で、製品のいずれかを登録した人です。 Admin Portal では、これらを識別して製品から除去できます。

  • ギア メニューを使用したクエリ

    ギア メニューには、クエリを作成してリファインするコマンドが含まれています。

親トピック 管理者のタスク
関連概念
製品およびサービスの管理
オンライン ライセンスを使用するように製品を設定する
SOLIDWORKS Customer Portal でのマイプロダクトの登録
関連タスク
最初の管理者アカウントの作成
管理者へのユーザーの昇格


アカウントへの新規メンバーの招待

管理者は、アカウントに参加するように新規メンバーを招待できます。

新規メンバーを招待するには:

  1. メンバー（Members）タブをクリックします。
  2. メンバーを招待（Invite Member）をクリックします。
  3. 招待するメンバーの電子メール アドレス（Email addresses）を入力します。
    1 つの電子メールで複数のユーザーを招待できます。それには、アドレス フィールドにユーザーの電子メール アドレスをセミコロン（;）で区切って入力します。
  4. ユーザー権限（User Rights）のレベルとしてメンバー（Member）または管理（Admin）を選択します。
  5. 必要に応じて招待状のテキストを編集し、招待状を送信（Send Invitations）をクリックします。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


アカウントからのメンバーの除去

管理者は、メンバーを除去する前に、まずメンバーのアカウントに割り当てられているすべての製品を除去する必要があります。

アカウントからメンバーを除去するには:

  1. メンバー（Members）タブをクリックします。
  2. メンバー（Members）リストの行をクリックして、名前を選択します。

    下部にあるナビゲーション コントロールを使用して、レコード セット内を前後に移動します。 メンバーの検索（Find Members）パネルを使用してメンバーを検索することもできます。

  3. メンバーの詳細（Member Details）ページで、製品の除去（Remove Product）をクリックして、割り当てられた製品（Assigned Products）リストのすべての製品を除去します。
  4. メンバーの詳細（Member Details）で、メンバーを除去（Remove Member）をクリックし、OK をクリックして確認します。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


メンバーへの製品の割り当て

管理者は、製品タイプごとに 1 つの製品のみをメンバーに割り当てることができます。 たとえば、メンバーには 1 つの CAD 製品のみを割り当て、1 つの Simulation 製品のみを割り当てることができます。

保留中のメンバーに製品を割り当てることはできません。

メンバーに製品を割り当てるには:

  1. メンバー（Members）タブをクリックします。
  2. メンバー（Members）リストの行をクリックして、名前を選択します。

    リストの下部にあるナビゲーション コントロールを使用して、レコード セット内を前後に移動します。 メンバーの検索（Find Members）パネルを使用してメンバーを検索することもできます。

    メンバーの詳細（Member Details）ページには、割り当てられた製品（Assigned Products）と、割り当てられていない利用可能な製品（Available Products）が一覧表示されます。

  3. 利用可能な製品（Available Products）で製品を強調表示します。

    メンバーには、一度に 1 つの製品のみを割り当てることができます。 リストの最初の項目がデフォルトで選択されます。 割り当てる製品がリストの最初にない場合は、その項目をクリアして、正しい項目を選択します。

    いくつかの要因に基づいてフィルターすることで、以下に該当する製品のみを表示できます。
    • サブスクリプションが現行または有効期限切れ
    • 割り当て済みまたは未割り当て
    • オンライン ライセンスのアクティブ化または非アクティブ化、またはアクティブ化済み
    • 1 つまたは複数の製品タイプに属する
    製品名またはシリアル番号に基づいてフィルターすることもできます。

    製品名を選択すると、製品の詳細（Product Details）ページが表示されます。 ブラウザで、戻る（Back）を押して、メンバーの詳細（Member Details）ページに戻ります。

  4. 製品の割り当て（Assign Product）をクリックします。

    メンバーの割り当てられた製品（Assigned Products）リストに製品が追加されます。

    製品詳細（Product Details）ページからメンバーを製品に割り当てることもできます。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


製品へのメンバーの割り当て

製品にメンバーを割り当てるには:

  1. 製品（Products）タブをクリックします。

    製品の詳細（Product Details）ページには、製品に割り当てられていない使用可能なメンバーがリストされます。

  2. 利用可能な製品（Available Products）で製品を強調表示します。
  3. メンバーを検索するために、姓、名、電子メール、および製品タイプに基づいて、利用可能なメンバーをフィルターできます。
  4. メンバーを割り当て（Assign Member）をクリックします。

メンバー（Members）タブの割り当てられた製品（Assigned Products）から製品をメンバーに割り当てることもできます。

親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


メンバーへのサービスの割り当て

管理者は、メンバーにサービスを割り当てることができます。 サービスの例としては、MySolidWorks Professional および e ラーニング コースがあります。 サービスは製品と異なり、トランスファーできません。 サービスをメンバーに割り当てた後は、そのメンバーからサービスを除去できません。

メンバーにサービスを割り当てるには:

  1. メンバー（Members）タブをクリックします。
  2. メンバーの検索（Find Members）パネルでメンバーを検索するか、リストからユーザー名をクリックします。
  3. メンバーの（Member's）ページのメンバーの詳細（Member's Details）で、サービス（Services）をクリックします。

    サービス（Services）タブには、メンバーに関連付けられているサービスと、割り当てられていない利用可能なサービス（Available Services）が一覧表示されます。

  4. 利用可能なサービス（Available Services）でサービスをハイライト表示します。

    メンバーには、一度に 1 つのサービスのみを割り当てることができます。 リストの最初の項目がデフォルトで選択されます。 割り当てるサービスがリストの最初にない場合は、その項目をクリアして、正しい項目を選択します。

    いくつかの要因に基づいてフィルターすることで、以下に該当するサービスのみを表示できます。
    • 現行または期限切れのサブスクリプション。
    • 割り当て済みまたは未割り当て。
    サービス名またはシリアル番号に基づいてフィルターすることもできます。

    サービス名を選択すると、サービスの詳細（Service Details）ページが表示されます。 ブラウザで、戻る（Back）をクリックして、メンバーの詳細（Member Details）ページに戻ります。

  5. サービスを割り当て（Assign Service）をクリックします。

メンバーのサービス（Services）リストに製品が追加されます。

親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


メンバーからのライセンスの除去

メンバーから製品を除去できます。

メンバーから製品を除去するには:

  1. メンバー（Members）タブをクリックします。
  2. メンバーの検索（Find Members）パネルでメンバーを検索するか、リストから名前をクリックします。

    メンバーのページで、メンバーに関連付けられているすべての製品が割り当てられた製品（Assigned Products）に一覧表示され、割り当てられていない製品が利用可能な製品（Available Products）に一覧表示されます。

  3. 割り当てられた製品（Assigned Products）で製品を選択して、製品の除去（Remove Product）をクリックします。
  4. OK をクリックして確定します。

    メンバーの利用可能な製品（Available Products）リストに製品が追加されます。

メンバーがオフライン モードの製品を使用している場合、メンバーがオフライン モード（Offline Mode）をオフにするか、30 日のオフライン期間が期限切れになるまで、ライセンスの復元および再割り当てはできません。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


メンバーの検索と、ユーザー権限および割り当てられた製品の確認

Admin Portal では、複数の方法を使用して、ユーザーを検索し、ユーザー権限および割り当てられた製品を監視できます。

メンバーを検索し、ユーザー権限および割り当てられた製品を確認するには:

  1. メンバー（Members）タブをクリックします。
  2. メンバーの検索（Find Members）パネルで、ユーザー権限および割り当てられた製品に基づいてフィルタできます。
    • 管理（Admin）、メンバー（Member）、または保留中（Pending）を選択して、そのステータスを持つユーザーに検索を制限します。
    • 1 つまたは複数の製品タイプを選択して、選択した製品に割り当てられているユーザーに検索を制限します。
  3. 特定のユーザーの権限と割り当て済み製品を確認するには、メンバー（Members）で名前を選択します。

    メンバーの詳細（Member Details）で、特定のユーザーの権限レベルを表示できます。 同じページに、ユーザーに関連付けられている割り当てられた製品と、割り当てることができる利用可能な製品が一覧表示されます。

親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


製品の検索と、製品に割り当てられているユーザーの確認

Admin Portal では、複数の方法を使用して、製品を検索し、それらの製品に割り当てられているユーザーを監視できます。

製品を検索するには:

  1. 製品（Products）タブをクリックします。
  2. 製品の検索（Find Products）パネルで、製品名を入力します。
  3. いくつかの要因に基づいてフィルタすることで、以下に該当する製品のみを表示できます。
    • サブスクリプションが現行または有効期限切れ
    • 割り当て済みまたは未割り当て
    • オンライン ライセンスのアクティブ化を実行済みまたは未実行
    • 1 つまたは複数の製品タイプに属する
    シリアル番号に基づいてフィルタすることもできます。
  4. 検索（Search）をクリックします。
  5. プロダクトに割り当てられたユーザーを確認するには、プロダクト（Products）の下にあるプロダクト名を選択します。
    製品の詳細（Product Details）ページに、その製品に割り当てられているすべてのメンバーが一覧表示されます。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
外部メンバーからの製品の除去
関連資料
ギア メニューを使用したクエリ


外部メンバーからの製品の除去

外部メンバーとは、組織外の人で、製品のいずれかを登録した人です。 Admin Portal では、これらを識別して製品から除去できます。

外部メンバーから製品を除去するには:

  1. 製品（Products）タブをクリックします。
  2. 製品の検索（Find Products）ペインで、製品名または検索条件を入力します。
  3. 検索（Search）をクリックします。
  4. 製品名を選択します。
    製品の詳細（Product Details）ページに、その製品に割り当てられているすべてのメンバーが一覧表示されます。
  5. 割り当てられた外部メンバー（Assigned External Members）のリストで外部メンバーを選択して、メンバーを除去（Remove Member）をクリックします。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
関連資料
ギア メニューを使用したクエリ


ギア メニューを使用したクエリ

ギア メニューには、クエリを作成してリファインするコマンドが含まれています。

コマンド | キーボード ショートカット | 説明
新しいクエリ（New Query） | Alt + Q | メンバー（Members）ページでテキストを名前（名）（First Name）、名前（姓）（Last Name）、ユーザー権限（User Rights）、電子メール（Email）、割り当てられた製品（Assigned Products）などの 1 つまたは複数のフィールドに入力するか、または製品（Products）ページで製品名（Product Name）、製品タイプ（Product Type）、シリアル番号（Serial Number）、アクティブ化（Activated）、割り当て済み（Assigned）、期限切れ（Expire）などに入力して、クエリを作成します。
クエリの実行（Run Query） | Alt + Enter | クエリを実行します。
クエリのリファイン（Refine Query） | Alt + G | クエリ フィールドでテキストを変更および追加します。
表示する列（Columns Displayed） | Ctrl + Shift + K | メンバー（Members）および製品（Products）ページに表示する列を選択します。
エクスポート（Export） |  | クエリの結果をエクスポートします。 列内のすべての行または現在の行のみをエクスポートすることや、すべての列または表示されている列のみをエクスポートすることができます。 結果は、タブ区切りのテキスト ファイル、カンマ区切りのテキスト ファイル、HTML ファイル、または指定した区切り文字を使用したテキスト ファイルとしてエクスポートできます。
詳細な並べ替え（Advanced Sort） |  | 3 つまでの列に基づいてクエリの結果を並べ替えます。
親トピック メンバーおよびライセンスの管理
関連タスク
アカウントへの新規メンバーの招待
アカウントからのメンバーの除去
メンバーへの製品の割り当て
製品へのメンバーの割り当て
メンバーへのサービスの割り当て
メンバーからのライセンスの除去
メンバーの検索と、ユーザー権限および割り当てられた製品の確認
製品の検索と、製品に割り当てられているユーザーの確認
外部メンバーからの製品の除去


オンライン ライセンスを使用するように製品を設定する

デフォルトでは、SOLIDWORKS ソフトウェアはマシン アクティベーションを使用するようにセットアップされます。 SOLIDWORKS ソフトウェアをマシンにインストール済みである場合は、手動でライセンスを非アクティブ化してから、アクティベーション タイプを変更してオンライン ライセンスを使用する必要があります。

親トピック 管理者のタスク
関連概念
製品およびサービスの管理
メンバーおよびライセンスの管理
SOLIDWORKS Customer Portal でのマイプロダクトの登録
関連タスク
最初の管理者アカウントの作成
管理者へのユーザーの昇格

SOLIDWORKS でのインストール済みライセンスの非アクティブ化

オンライン ライセンスを使用する前に、同じ製品がマシンにインストールされていないことを確認する必要があります。 インストールされている場合は、Admin Portal でオンライン ライセンスを設定する前に、インストールされている製品のライセンスを非アクティブ化する必要があります。

ライセンスを非アクティブ化するには:

  • SOLIDWORKS ソフトウェアで、ヘルプ（Help） > ライセンスの非アクティブ化（Deactivate Licenses）をクリックし、指示に従います。
同じマシン上で、オンライン ライセンスと SolidNetWork ライセンスを混在させることができます。 たとえば、同じマシンで、SOLIDWORKS Premium 2018 をオンライン ライセンスで実行し、SOLIDWORKS Simulation Premium 2018 を SolidNetWork ライセンスで実行することができます。

オンライン ライセンスへのアクティベーション タイプの変更

製品でオンライン ライセンスを使用するには、そのアクティベーション タイプをマシン アクティベーションからオンライン ライセンスに変更する必要があります。

ライセンスのアクティベーション タイプの変更は、ライセンスをメンバーに割り当てる前に行うことも、割り当てた後に行うこともできます。 ライセンスがアクティブ化している場合、または製品が複数のメンバーに割り当てられている場合は、ライセンスのアクティベーション タイプを変更できません。 マシン アクティベーションによってライセンスがアクティブ化している場合は、リモートからライセンスを非アクティブ化することはできません。マシン上のユーザーがそのライセンスを非アクティブ化する必要があります。

アクティベーション タイプをオンライン ライセンスに変更するには:

  1. 製品がメンバーに割り当てられている場合:
    1. メンバー（Members）タブをクリックし、リストからメンバーを選択します。
    2. 割り当てられた製品（Assigned Products）で、変更する製品をクリックします。
    3. 製品の詳細（Product Details）のアクティベーション タイプ（Activation Type）で、オンライン ライセンスに変更（Change to Online Licensing）をクリックします。
    4. 変更（Change）をクリックして確認するか、またはキャンセル（Cancel）をクリックします。
  2. 製品がメンバーに割り当てられていない場合:
    1. 製品（Products）タブをクリックし、リストから製品を選択します。

      製品の検索（Find Products）パネルを使用して、製品をクエリできます。

  3. 製品の詳細（Product Details）のアクティベーション タイプ（Activation Type）で、オンライン ライセンスに変更（Change to Online Licensing）をクリックします。
  4. 変更（Change）をクリックして確認するか、またはキャンセル（Cancel）をクリックします。
  5. メンバーに製品を割り当てます。
オンライン ライセンスを割り当てると、その製品はそのメンバーのみが使用できるようになります。 それに対して、メンバーへのマシン アクティベーション製品の割り当ては、追跡目的のみとなります。 指定したマシンの前に座った任意の人が、製品を使用できます。 この状況では、マシンを使用している人が、そのライセンスを所有しているメンバー本人であることを確認することが必要な場合があります。


管理者へのユーザーの昇格

アカウントに管理者がいる場合は、管理者の連絡先情報が Admin Portal に表示されます。 ユーザーは管理者に連絡して、アカウントの管理者になることを要求できます。

管理者は、アカウントの他のユーザーを管理者に昇格させることができます。

ユーザーを管理者に昇格させるには:

  1. メンバー（Members）タブをクリックします。
  2. 名前のリストから、ユーザーを選択します。

    ユーザーを見つけにくい場合は、メンバーの検索（Find Members）パネルに検索条件を入力することで、Admin Portal をクエリできます。

  3. メンバーの詳細（Member Details）パネルのユーザー権限（User Rights）で、管理に変更（Change to Admin）をクリックします。
  4. 次に、変更（Change）をクリックして確認するか、またはキャンセル（Cancel）をクリックします。
  5. 管理者になるようにユーザーを招待する電子メールが表示されます。 送信（Send）をクリックします。

招待が送信されると、ユーザー権限（User Rights）は保留中（Pending）として表示されます。 受け入れ後、ユーザー権限は Admin に変更されます。

メンバーに変更（Change to Member）を選択して、管理者をユーザーに降格させることができます。
親トピック 管理者のタスク
関連概念
製品およびサービスの管理
メンバーおよびライセンスの管理
オンライン ライセンスを使用するように製品を設定する
SOLIDWORKS Customer Portal でのマイプロダクトの登録
関連タスク
最初の管理者アカウントの作成


SOLIDWORKS Customer Portal でのマイプロダクトの登録

いったん管理者が会社で宣言されると、SOLIDWORKS Customer Portal でその会社からユーザーが製品を登録することができなくなります。

ユーザーは登録を拒否され、会社の指定管理者に、要求者の連絡先情報とシリアル番号がメールで通知されます。 管理者は、要求者に代わって製品を要求者に割り当てるかどうかを決定することができます。
製品の割り当ては、製品の登録と同じステータスで行われます。

要求者がすでにアカウントのメンバーである場合は、リクエストされた製品または同等の製品を代理で割り当てることができます。

要求者がアカウントのメンバーでない場合、管理者は、要求者をメンバーとして招待し、その後で割り当てを完了します。

親トピック 管理者のタスク
関連概念
製品およびサービスの管理
メンバーおよびライセンスの管理
オンライン ライセンスを使用するように製品を設定する
関連タスク
最初の管理者アカウントの作成
管理者へのユーザーの昇格


オンライン ライセンスを使用した SOLIDWORKS 製品の使用

SOLIDWORKS のオンライン ライセンスによって、ユーザーはどこにいても 1 つのライセンスをすべてのデバイスで柔軟に使用できるようになり、各マシンでライセンスを手動でアクティブ化および非アクティブ化する必要がありません。

たとえば、日中にオフィスのマシンで作業し、帰宅して自宅のコンピュータから同じ製品にログインできます。 製品の 2 番目のライセンスは必要ありません。 オフィスのマシンでライセンスを手動で非アクティブ化して自宅のコンピュータでライセンスをアクティブ化する必要はありません。

サインインしてオンライン ライセンスを使用するには、インターネットにアクセスする必要があります。 サインインした後は、オフライン モードを選択して、マシンがネットワークに接続されていない状態で作業できます。

また、SOLIDWORKS のオプションをマシン間で同期することや、MySolidWorks.com および SOLIDWORKS Customer Portal などの SOLIDWORKS Web サイトに、再度ログインすることなくアクセスすることができます。

目次

  • オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン

    オンライン ライセンスを使用して SOLIDWORKS 製品をインストールした後は、任意のマシンでログインできます。 別のマシンで製品を使用する場合、製品を再度インストールする必要はありません。

  • オフライン モードでの SOLIDWORKS 製品の使用

    オンライン ライセンスを持つ SOLIDWORKS 製品を使用するときに、インターネットに接続できない場合は、オフライン モードを指定できます。

  • オンライン ライセンス使用時のマシンの切り替え

    オンライン ライセンスによって、ユーザーは 1 つのライセンスをすべてのマシンで柔軟に使用できるようになります。 ただし、ライセンスは一度に 1 台のマシンでのみ使用できます。

  • 複数のマシンでの設定とオプションの同期

    複数のマシンで SOLIDWORKS ソフトウェアを使用している場合、いずれかのマシンで設定を更新し、その設定を SOLIDWORKS 2018 が動作するすべてのマシンで同期することができます。

  • オンライン ライセンスを使用することの SOLIDWORKS 製品への通知

親トピック SOLIDWORKS Admin Portal とオンライン ライセンス
関連概念
管理者のタスク
CAD Admin Dashboard へのアクセス
関連タスク
Admin Portal へのアクセス


オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン

オンライン ライセンスを使用して SOLIDWORKS 製品をインストールした後は、任意のマシンでログインできます。 別のマシンで製品を使用する場合、製品を再度インストールする必要はありません。

オンライン ライセンスを使用した SOLIDWORKS 製品にログインするには:

  1. デスクトップで SOLIDWORKS [image] をクリックします。
  2. SOLIDWORKS ID とパスワードを入力し、ログイン（Login）をクリックします。
    SOLIDWORKS ID は、電子メール アドレスにすることができます。

有効な SOLIDWORKS ID とパスワードが入力され、その製品のライセンスが SOLIDWORKS 管理者によって割り当てられている場合は、SOLIDWORKS 製品が起動します。

ログアウトするまでは、認証情報を再入力しなくても、同じマシン上で SOLIDWORKS 製品を閉じて再起動できます。

親トピック オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
オフライン モードでの SOLIDWORKS 製品の使用
オンライン ライセンス使用時のマシンの切り替え
複数のマシンでの設定とオプションの同期
オンライン ライセンスを使用することの SOLIDWORKS 製品への通知


オフライン モードでの SOLIDWORKS 製品の使用

オンライン ライセンスを持つ SOLIDWORKS 製品を使用するときに、インターネットに接続できない場合は、オフライン モードを指定できます。

オフライン モードで作業するには:

  • SOLIDWORKS のタイトル バーで、ログイン（Login） [image] を右クリックして、オフラインでライセンスを取得（Take License Offline）をクリックします。

SOLIDWORKS の Web サイトに再接続することなく、SOLIDWORKS 製品を 30 日間使用できます。 30 日経過した後、オフライン モードで作業を続けるには、オフラインでライセンスを取得（Take License Offline）を再度クリックする必要があります。

1 台のマシンでオフライン モードでオンライン ライセンスを使用している場合、他のマシンでそのライセンスを使用することはできません。
親トピック オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン
オンライン ライセンス使用時のマシンの切り替え
複数のマシンでの設定とオプションの同期
オンライン ライセンスを使用することの SOLIDWORKS 製品への通知


オンライン ライセンス使用時のマシンの切り替え

オンライン ライセンスによって、ユーザーは 1 つのライセンスをすべてのマシンで柔軟に使用できるようになります。 ただし、ライセンスは一度に 1 台のマシンでのみ使用できます。

プライマリ マシンで SOLIDWORKS ソフトウェアを実行し、ログアウトしていない状況であるとします。 2 台目のマシン（自宅のコンピュータなど）にログインしようとすると、プライマリ マシンからライセンスを移動するようにソフトウェアから提案されます。

2 台目のマシンで SOLIDWORKS ソフトウェアを起動するには:

  1. 2 台目のマシンにログインすると、オンライン ライセンス製品が別のマシンで使用中であることが SOLIDWORKS ソフトウェアによって通知されます。 はいをクリックして続行します。

    SOLIDWORKS 製品が 2 台目のマシン上で実行されます。

  2. プライマリ マシンに戻ると、SOLIDWORKS ソフトウェアを閉じる前に作業を保存するように求められます。 OK をクリックして、モデルへの変更を保存します。
親トピック オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン
オフライン モードでの SOLIDWORKS 製品の使用
複数のマシンでの設定とオプションの同期
オンライン ライセンスを使用することの SOLIDWORKS 製品への通知


複数のマシンでの設定とオプションの同期

複数のマシンで SOLIDWORKS ソフトウェアを使用している場合、いずれかのマシンで設定を更新し、その設定を SOLIDWORKS 2018 が動作するすべてのマシンで同期することができます。

設定の同期はサービスであり、ネットワーク構成によってはブロックされることがあります。 クラウド ストレージ サービスにアクセスするには、ファイアウォールまたはプロキシ サーバーで *.solidworks.com への通信が許可されることを確認します。

複数のマシンで設定とオプションを同期するには:

  1. SOLIDWORKS ソフトウェアにログインします。
  2. ツール（Tools） > オプション（Options）で、設定を同期（Synchronize Settings）をクリックします。
  3. 手動方式か自動方式かを選びます:
    • 今すぐ同期（Synchronize Now）をクリックします。

      アップロード設定（Upload Settings）。 現在のマシンからクラウド ストレージ サービスに設定を送信します。 設定は、再びアップロードすることにより、いつでもクラウドで更新できます。

      ダウンロード設定（Download Settings）。 クラウド ストレージ サービスから現在のマシンに設定をダウンロードし、適用します。

    • 自動同期（Automatic Synchronization）をクリックします。

      現在のマシンを自動的にクラウト ストレージ サービスと同期します。 選択した設定とカスタマイズは、更新されるとクラウド ストレージ サービスに自動的にアップロードされ、起動時またはログイン時にダウンロードされて適用されます。

    同期設定は、マシンごとに異なる設定が可能です。 たとえば、システム オプションとファイル保存場所は自動的に同期するけれど、カスタマイズの同期は行わないマシンを指定できます。 別のマシンでは、すべてのタイプの設定を手動でダウンロードしてアップロードするように指定できます。

    同期プロセスによって、適用またはロック済みの管理者設定を上書きすることはできません。
  4. OK をクリックします。
親トピック オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン
オフライン モードでの SOLIDWORKS 製品の使用
オンライン ライセンス使用時のマシンの切り替え
オンライン ライセンスを使用することの SOLIDWORKS 製品への通知


オンライン ライセンスを使用することの SOLIDWORKS 製品への通知

オンライン ライセンスに切り替えたことを SOLIDWORKS 製品に通知するには、次の 2 つの方法があります。
  • SOLIDWORKS 製品にログインすると、入力したシリアル番号がオンライン ライセンス用にリセットされたことを知らせるメッセージが表示されます。 製品を再起動して、ログインします。
  • 管理者は、アドミニストレーティブ イメージ オプション エディタを使用して、シリアル番号の代わりにオンライン ライセンスを使用するように製品に指定できます。 このようにインストールされた各製品では、ソフトウェアの実行時にユーザーにログインが求められます。
親トピック オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
オンライン ライセンスを使用した SOLIDWORKS 製品へのログイン
オフライン モードでの SOLIDWORKS 製品の使用
オンライン ライセンス使用時のマシンの切り替え
複数のマシンでの設定とオプションの同期


CAD Admin Dashboard へのアクセス

SOLIDWORKS のサブスクリプション契約をお持ちの場合は、Admin Portal から SOLIDWORKS CAD Admin Dashboard に、再度ログインすることなくアクセスできます。

CAD Admin Dashboard では、パフォーマンスの監視、セッション統計の監視、ネットワーク内で SOLIDWORKS ソフトウェアを実行しているマシンの詳細の表示などのタスクを実行できます。

詳細については、CAD Admin Dashboard 内のヘルプを参照してください。

親トピック SOLIDWORKS Admin Portal とオンライン ライセンス
関連概念
管理者のタスク
オンライン ライセンスを使用した SOLIDWORKS 製品の使用
関連タスク
Admin Portal へのアクセス


ライセンス管理（License Administration）

インストール後に SOLIDWORKS ライセンスをアクティブ化するには、個別のコンピュータでのアクティブ化（マシン アクティベーション）、サーバーでのフローティング ネットワーク ライセンスのインストールとアクティブ化（SolidNetWork ライセンス）、または SOLIDWORKS アプリケーションへのログイン（オンライン ライセンス）のいずれかを行います。

一般的に、個人コンピュータで行うインストレーションではライセンス アクティベーションを使用します。しかし、ソフトウェアを個別にインストールしてからライセンスをSolidNetWork License Managerでコントロールすることもできます。逆に、大規模な環境では一般的にフローティング ネットワーク ライセンスが使用されますが、アドミニストレーティブ イメージからインストレーションを展開し、シリアル番号を各コンピュータからアクティブ化することもできます。

目次

  • 個人ライセンスの管理（Administering Individual Licenses）

    個別のライセンスは、マシン アクティベーションまたはオンライン ライセンスを使用するように設定できます。 このセクションでは、マシン アクティベーションについて説明します。 オンライン ライセンスの詳細については、Admin Portal を参照してください。

  • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

    SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。


個人ライセンスの管理（Administering Individual Licenses）

個別のライセンスは、マシン アクティベーションまたはオンライン ライセンスを使用するように設定できます。 このセクションでは、マシン アクティベーションについて説明します。 オンライン ライセンスの詳細については、Admin Portal を参照してください。

通常、個人ライセンスの管理は、SOLIDWORKS から直接、ライセンスをアクティブ化/非アクティブ化して行います。

SOLIDWORKS スタンドアロン ライセンス (SolidNetWork ライセンスではありません) において、製品のライセンスを取得して登録するプロセスを「アクティベーション」と呼びます。 一般に製品のライセンスがアクティブ化されていない場合、SOLIDWORKS は製品の開始時にライセンスをアクティブ化しようとします。

また、個人ライセンスを非アクティブにするには、SOLIDWORKS でヘルプ（Help） > ライセンスの非アクティブ化（Deactivate Licenses）をクリックします。

親トピック ライセンス管理（License Administration）
関連概念
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

ライセンス アクティベーション（Activating a License）

SOLIDWORKS 製品を個人コンピュータで実行する前に、そのコンピュータに対するライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体のソフトウェア ライセンスをアクティブ化します。
  • ライセンス権を別のコンピュータへ移動します。
  • その場で実行する（推奨）ことも、インストレーション後 30日以内に実行することもできます。
  • ドングル（ハードウェア ロック）が不必要になります。 しかし、アクティベーションを利用しない、以前のバージョンの SOLIDWORKS 製品をご使用の場合は、ドングルが必要です。

複数のシリアル番号を管理するシステム管理者の場合、アドミニストレーティブ イメージ オプション エディタを参照してください。 詳細については、SOLIDWORKS アドミニストレーティブ イメージ オプション エディタ (Administrative Image Option Editor)を参照してください。

ライセンスをアクティブ化するには:

  1. SOLIDWORKS アプリケーションを開始します。
  2. 以下のいずれかの方法を使用し、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) を開始します。
    • このコンピュータのライセンスがアクティブ化されていない場合、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) ウィンドウは SOLIDWORKS の開始時に自動的に表示されます。
    • SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) ウィンドウが自動的に表示されない場合、ヘルプ > ライセンス アクティブ化 をクリックしてアクティベーションを開始します。
  3. 製品 リストをクリックし、ライセンスをアクティブ化する製品を指定します。
  4. インターネット経由の自動アクティベーションまたは電子メール使用のマニュアル アクティベーションを指定します。
  5. 電子メールの連絡先を入力します。
  6. 続行するには 次へ をクリックしてください。
    • インターネットの場合:アクティベーションは自動的に行われます。
    • Email : 保存 をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com まで電子メールで送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く をクリックしてファイルを読み込みます。
      必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。
  7. 完了 をクリックします。
関連資料
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

ライセンスの移動

ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まず Dassault Systèmes SolidWorks Corporation のライセンス キー サーバー上でライセンスを非アクティブ化して、続いて別のコンピュータ上で再度アクティブ化します。

ライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻せない場合（たとえば、ハード ドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。 そうでない場合は、お客様の代理店にお問い合わせください。

ライセンスをサーバーに戻すには、以下を行います。

  1. SOLIDWORKS でヘルプ（Help） > ライセンスの非アクティブ化（Deactivate Licenses）をクリックし、指示に従います。
  2. 再アクティブ化するには、新しいまたはアップグレードしたコンピュータで初期のアクティベーションと同じようにライセンス アクティベーションを行います。 詳細については、ライセンス アクティベーションを参照してください。


SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

次のイメージは、SolidNetWorkライセンスのインストレーションを表しています。

このイメージは、以下を明らかにします。
  • SolidNetWork License Manager ソフトウェアは、ライセンス マネージャー コンピュータにのみにインストールされ、アクティブ化されます。
  • ライセンス クラインアント コンピュータには、SolidNetWork特有のソフトウェアはインストールされていません。

    インストール時に SolidNetWork ライセンスのシリアル番号を指定すると、SOLIDWORKS Installation Manager はそのコンピュータを SolidNetWork ライセンス クライアントとして認識します。 SOLIDWORKS Installation Manager はクライアントをライセンス マネージャーと接続させるために、SolidNetWork License Manager コンピュータ名とポート番号を求めるプロンプトを表示します。

  • ライセンス マネージャーとすべてのライセンス クライアントは、TCP/IP（Transmission Control Protocol/Internet Protocol）接続を必要とします。

目次

  • SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）

    ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

  • SolidNetWork ライセンスの移動

    SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まずライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻し、続いて移動先のコンピュータ上で再度アクティブ化します。

  • SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）

    SolidNetWork ライセンスの設定は、ライセンス マネージャー コンピュータに SolidNetWork License Manager をインストールしてから SolidNetWork ライセンスのシリアル番号を使用してクライアント コンピュータに SOLIDWORKS をインストールすることで構成されます。

  • SolidNetWorkライセンス管理（SolidNetWork License Administration）

    タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの借入と返却が含まれます。

親トピック ライセンス管理（License Administration）
関連概念
個人ライセンスの管理（Administering Individual Licenses）


SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）

ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。 アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。 製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体の SolidNetWork ライセンスと共に SOLIDWORKS SolidNetWork License Manager をアクティブ化します。
  • 1 台の SolidNetWork License Manager コンピュータから別のコンピュータへ SolidNetWork ライセンス権限を移動できます。
  • 1台のSolidNetWork License ManagerコンピュータにSolidNetWorkライセンス権限をインストールしてアクティブ化できるようにします。
  • SolidNetWorkライセンスを使用する前に、実行する必要があります。
  • ドングル（ハードウェア ロック）が不必要になります。 このバージョンの SOLIDWORKS の SolidNetWork ライセンスをアクティブ化すると、前のバージョンの SOLIDWORKS の SolidNetWork ライセンスもアクティブ化されます （ドングルを保持する必要はなくなります）。

SolidNetWorkライセンスをアクティブ化するには、以下を行います。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. まだ SolidNetWork ライセンスをアクティブ化していない場合は、今すぐライセンスをアクティブ化するかどうかを確認するプロンプトが表示されます。 はい をクリックしてアクティブ化します。
  3. どのようにアクティブ化しますか? （How would you like to activate?）で インターネットを自動的に使用（推奨） （Automatically over the internet (recommended)）を選択します。
  4. 連絡情報 （Contact Information）で連絡先の電子メール アドレスを指定します。
アクティベーション/再アクティベーションの成功（Activation/Reactivation Succeeded）ダイアログ ボックスにアクティブ化された製品の名前が表示されます。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWork ライセンスの移動


SolidNetWork ライセンスの移動

SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まずライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻し、続いて移動先のコンピュータ上で再度アクティブ化します。

ライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻せない場合（たとえば、ハード ドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。 そうでない場合は、お客様の代理店にお問い合わせください。

SolidNetWork ライセンスを移動してサーバーに戻すには、以下を行います。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。 SOLIDWORKS 製品のアクティベーション （SOLIDWORKS Product Activation）ウィザードが開始されます。
  3. 何を行いますか?（What would you like to do?）でソフトウェア ライセンスの非アクティブ化（Deactivate a software license）を選択し、次へ（Next）をクリックします。
  4. どのように非アクティブ化しますか?（How would you like to deactivate?）でインターネットを自動的に使用（推奨）（Automatically over the internet (recommended)）を選択します。
  5. 連絡情報 （Contact Information）で連絡先の電子メール アドレスを指定します。
  6. 次へ（Next）をクリックします。 製品ライセンスが非アクティブになります。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）


SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）

SolidNetWork ライセンスの設定は、ライセンス マネージャー コンピュータに SolidNetWork License Manager をインストールしてから SolidNetWork ライセンスのシリアル番号を使用してクライアント コンピュータに SOLIDWORKS をインストールすることで構成されます。

目次

  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）

    SolidNetWork License Manager は、複数のラインセンス クライアント コンピュータをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

  • ライセンス クライアントのインストール（Installing a License Client）

    SOLIDWORKS を SolidNetWork ライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によって SolidNetWork ライセンス クライアントとして識別されます。

  • ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）

    SolidNetWork ライセンス クライアント コンピュータをインストールする前に、少なくとも 1 台のコンピュータに SolidNetWork License Manager をインストールして設定する必要があります。

  • SOLIDWORKS の各種バージョンへのアクセスの管理

    SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

  • トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

  • SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

    コンピュータでファイアウォールを使用している場合は、SolidNetWork ライセンスをサポートするようにポートを構成する必要があります。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）
SolidNetWork ライセンスの移動


License Managerのインストールとアクティベーション（Installing and Activating a License Manager）

SolidNetWork License Manager は、複数のラインセンス クライアント コンピュータをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

ライセンスのアクティベーション にハードウェア ドングルを使用した以前のバージョンの SolidNetWork License Manager をアップグレードする場合は、新しいバージョンの SolidNetWork License Manager をインストールする前にハードウェア ドングルを取り外してください。

  1. SOLIDWORKS Installation Manager を起動します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    1. インストレーションのタイプには、以下を選択します。
      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。
    2. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    3. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWorkライセンスをアクティブ化するには、以下を行います。
    1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
    2. アクティブ化を求めるプロンプトが表示されたら、はい をクリックします。
    3. SolidNetWork ライセンス サーバー情報（SolidNetWork License Server Information）画面 で以下を行います。
      • 会社でファイアウォールを使用している場合は、このサーバーのファイアウォールは使用中です （A firewall is in use on this server）を選択します。

        詳細は、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。

      • ポート番号 （Port Number）（およびファイアウォールを使用している場合は ベンダー デーモン ポート番号 （Vendor Daemon Port Number））にはデフォルト値を使用するか、または会社で使用しているポート番号を指定します。
        ポート番号は、1024 - 60000の範囲内のTCP/IPポート番号で、これは他のプロセスでは使用できません。 通常、デフォルト（25734）が好ましく、現在ライセンス マネージャー コンピュータ上にある他の FLEXnet サーバーのプロセスと一致する可能性が少ないといえます。
    4. SOLIDWORKS 製品のアクティブ化（Activate Your SOLIDWORKS Product）画面で以下を行います。
      • インターネットか電子メールのプロセスを選択します。
      • 電子メールの連絡先を入力します。
      • 次へ をクリックし、続行します。
        • インターネットの場合: アクティベーションは自動的に行われます。
        • 電子メール: 保存 をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com に送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く をクリックしてファイルを読み込みます。
          必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。
  3. 完了（Finish）をクリックします。
親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS の各種バージョンへのアクセスの管理
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


ライセンス クライアントのインストール（Installing a License Client）

SOLIDWORKS を SolidNetWork ライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によって SolidNetWork ライセンス クライアントとして識別されます。

  1. SOLIDWORKS Installation Manager を起動します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
  2. ようこそ画面で、今回がこのメジャー リリースの初めての SOLIDWORKS インストレーションである場合は個人（このコンピュータ上）（Individual (on this computer)）をクリックします。
    既存のリリースからアップグレードして個人ライセンスから SolidNetWork ライセンスに変更する場合は、個人インストレーションの変更（このコンピュータ上で実行します）をクリックします。 詳細は、個人ライセンスから SolidNetWork ライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）を参照してください。
  3. シリアル番号を求めるプロンプトが表示されたら、SolidNetWorkライセンスのシリアル番号を入力します。
  4. サーバーの追加（Add Server）ダイアログ ボックスで、SolidNetWork License Manager のアドレスを次の形式で入力します。

    port@ComputerName

    ポート番号は、ライセンス マネージャー コンピュータで使用している番号と同じでなければなりません。 デフォルトは 25734 です（License Manager のインストールとアクティベーション（Installing and Activating a License Manager）を参照）。

    SOLIDWORKS Installation Manager は、この SolidNetWork License Manager がアクセス可能であることを検証しようとします。 まだライセンス マネージャーをインストールしていない場合、この検証には失敗します。しかし、それでもライセンス クライアントのインストレーションは続行できます。
  5. SOLIDWORKS Installation Manager の指示に従い、SOLIDWORKS のインストレーションを完了します。
親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
SOLIDWORKS の各種バージョンへのアクセスの管理
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）

SolidNetWork ライセンス クライアント コンピュータをインストールする前に、少なくとも 1 台のコンピュータに SolidNetWork License Manager をインストールして設定する必要があります。

SolidNetWork ライセンスのシリアル番号でインストールするときに、SOLIDWORKS Installation Manager は SolidNetWork License Manager コンピュータ名とポート番号の入力を求めるプロンプトを表示した後で、この情報を検証しようとします。

SolidNetWork License Managerが指定したコンピュータにインストールされていない場合は、検証に失敗します。 ただし、この場合、検証の失敗は正しいライセンス マネージャー情報が提供されているかどうかを示すものではありません。 ライセンス マネージャーがインストールされている場合、検証の失敗は指定したライセンス マネージャー情報が間違っていることを示します。

親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS の各種バージョンへのアクセスの管理


SOLIDWORKS の各種バージョンへのアクセスの管理

SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

FLEXnet オプション ファイルを使用して SOLIDWORKS のバージョンに対するアクセスを管理するには:

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. ライセンス ファイルで特定の SOLIDWORKS バージョンに対するアクセスを管理するには、次の構文を SOLIDWORKS に追加します:
    :SWVERSION=xx xx は、管理する SOLIDWORKS 製品のバージョンを示します
  3. 複数のバージョンの SOLIDWORKS を管理するには、管理するバージョンごとに行を追加します。

    すべての FLEXnet オプションがサポートされているわけではありません。 サポートされるバージョン フィルタのオプションは次のとおりです:

    INCLUDE | ユーザーまたはグループのみが、特定のバージョンを開始できます。 その他のすべてのユーザーは、このバージョンを開始できません。
    INCLUDE_BORROW | ユーザーまたはグループのみが、特定のバージョンを借用できます。 その他のすべてのユーザーは、このバージョンを借用できません。
    EXCLUDE | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を開始することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    EXCLUDE_BORROW | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を借用することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    例:
    1 | SWVERSION=26.0 は SOLIDWORKS 2019 を表します
    SWVERSION=25.0 は SOLIDWORKS 2018 を表します
    2 | INCLUDE solidworks:SWVERSION=26.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=26.0 USER jane
    オプション ファイル内のこれらの行で、jane のみが SOLIDWORKS 2019 の実行または借用が可能です。その他のすべてのユーザーは SOLIDWORKS 2019 の実行も借用もできませんが、他のバージョンの SOLIDWORKS の実行と借用ができます。jane も他のバージョンの SOLIDWORKS の実行と借用ができます。
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=26.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=25.0 GROUP chicago
    EXCLUDE solidworks USER don
    これらの行は、chicago というユーザーの GROUP を定義します。このグループは SOLIDWORKS 2019 と SOLIDWORKS 2018 の両方へのアクセスは拒否されますが、他のすべてのバージョンの SOLIDWORKS は実行できます。 ユーザー don はどのバージョンの SOLIDWORKS も実行できません。
    4 | EXCLUDE swinspection_std:SWVERSION=26.0 HOST machine1
    この行により、machine1 のすべてのユーザーが SOLIDWORKS Inspection 2019 を起動することを禁止します。

    FLEXnet の詳細については、SolidNetwork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）


トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

トライアド ライセンス マネージャーの使用条件は、以下のとおりです。
  • トライアド ライセンス マネージャーは、頻繁に再起動、またはシャットダウンがスケジュールされたコンピュータではなく、安定したコンピュータのみにインストールしてください。
  • トライアド ライセンス マネージャー コンピュータは同一のサブネット上になければなりません。トライアド ライセンス マネージャーは、通信状態の悪い状態、またはダイアルアップ リンクで構成しないでください。
  • ライセンス マネージャー コンピュータがダウンした場合、システム管理者が早急に検知でき、再起動できる状態になければなりません。
    2台のライセンス マネージャー コンピュータのみが実行されている場合、2台のコンピュータ共に問題があることになるため、ライセンス マネージャー コンピュータが1台のみの場合よりも好ましくない状況にあるといえます。

目次

  • 最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

    この手順では、トライアドの最初のコンピュータに SolidNetWork License Manager をインストールする方法について説明します。

  • 残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

    次の手順に従って、トライアドの 2 台目と 3 台目のコンピュータに SolidNetWork License Manager をインストールします。 この手順は、ステップ 2（f）と 2（i）以外は、このソフトウェアを最初のコンピュータにインストールした手順とほぼ同じです。

親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS の各種バージョンへのアクセスの管理


最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

この手順では、トライアドの最初のコンピュータに SolidNetWork License Manager をインストールする方法について説明します。

  1. 最初のトライアド ライセンス マネージャー コンピュータで、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. SOLIDWORKS Installation Manager を起動します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    2. インストレーションのタイプには、以下を選択します。
      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。
    3. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    4. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、最初のトライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
    2. いいえ（No）をクリックします。
      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。
    3. 詳細設定オプション で オプション をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが表示されます。
    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが閉じます。
    5. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードが表示されます。
    6. サーバー タイプ （Server Type）で 3サーバー （Triad）を選択し、次へ （Next）をクリックします。
    7. サーバー情報パネルで最初のトライアド ライセンス マネージャー コンピュータのコンピュータ名、ポート番号が正しいことを確認し、次へ（Next）をクリックします。

      ネットワーク インタフェース カード（NIC）アドレスが SOLIDWORKS から受け取ったライセンス ファイルの情報と一致することと、トライアド ライセンス マネージャー コンピュータのポート番号が正しいことを確認します。 NIC アドレスは、MAC（Media Access Control Address）アドレスとも呼ばれます。 続いて、次へ （Next）をクリックしします。

      NIC アドレスを調べるには、コマンド プロンプト ウィンドウを開いて次のように入力します:

      ipconfig /all

      また、コンピュータでファイアウォールを使用している場合は、この画面で仕様を追加することが必要な場合があります。 詳細は、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。

    8. Triad Partner Server Information 画面で、他の 2 台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とホスト ID の値を入力します。
      この方法では、1 台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの 2 台のサーバーからライセンスを取得できます。
    9. ライセンス （Licenses）画面で 読み取り （Read）をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。
      SolidNetWork ライセンス ファイル ウィザードにライセンスが表示されます。 このコンピュータに対しては、代理店もしくはカスタマー センターから受け取ったライセンス ファイルを使用します。
    10. 完了（Finish）をクリックします。
    11. OK をクリックし SolidNetWorkライセンス ファイル ウィザード （SolidNetWork License File wizard）を終了してから、終了 （Finish）をクリックして SolidNetWork License Manager を終了します。
親トピック トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連概念
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

次の手順に従って、トライアドの 2 台目と 3 台目のコンピュータに SolidNetWork License Manager をインストールします。 この手順は、ステップ 2（f）と 2（i）以外は、このソフトウェアを最初のコンピュータにインストールした手順とほぼ同じです。

既に別のコンピュータに少なくとも1つのトライアド ライセンス マネージャーがインストールされていることを前提とします。

  1. トライアド ライセンス マネージャー コンピュータで、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. SOLIDWORKS Installation Manager を開始します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    2. インストレーションのタイプには、以下を選択します。
      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。
    3. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    4. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、トライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
      このコンピュータでSolidNetWork License Managerを実行するのは今回が初めてであるため、今すぐアクティブ化するかどうかを確認するプロンプトが表示されます。
    2. いいえ（No）をクリックします。
      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。
    3. 詳細設定オプション で オプション をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが表示されます。
    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが閉じます。
    5. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードが表示されます。
    6. サーバー タイプ （Server Type）で 3サーバー （Triad）と 同期サーバー/ライセンス情報 （Synchronize server/license information）を選択してから、次へ （Next）をクリックします。
    7. サーバー情報パネルで、このトライアド ライセンス マネージャー コンピュータのコンピュータ名とポート番号が正しいことを確認し、次へ（Next）をクリックします。

      ネットワーク インタフェース カード（NIC）アドレスが SOLIDWORKS から受け取ったライセンス ファイルの情報と一致することと、トライアド ライセンス マネージャー コンピュータのポート番号が正しいことを確認します。 NIC アドレスは、MAC（Media Access Control Address）アドレスとも呼ばれます。 続いて、次へ （Next）をクリックしします。

      NIC アドレスを調べるには、コマンド プロンプト ウィンドウを開いて次のように入力します:

      ipconfig /all

      また、コンピュータでファイアウォールを使用している場合は、この画面で仕様を追加することが必要な場合があります。 詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

    8. Triad Partner Server Information 画面で、コンピュータ名とホスト ID の値を入力します。
      この方法では、1 台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの 2 台のサーバーからライセンスを取得できます。
    9. ライセンス （Licenses）画面で 読み取り （Read）をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。
      SolidNetWork ライセンス ファイル ウィザードにライセンスが表示されます。
    このライセンス ファイルは、設定した最初のトライアド ライセンス マネージャー コンピュータで生成されています。 通常、ライセンス ファイルは \licenses\sw_d.lic にあります。たとえば: C:\Program Files\SOLIDWORKS Corp\SolidNetWork License Manager\licenses\sw_d.lic。
    1. 完了（Finish）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードの警告が表示されます。
    2. OK をクリックし SolidNetWorkライセンス ファイル ウィザード （SolidNetWork License File wizard）を終了してから、終了 （Finish）をクリックして SolidNetWork License Manager を終了します。

3 台目のトライアド ライセンス マネージャー コンピュータに対しても、このプロセスを繰り返します。

親トピック トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連タスク
最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）


SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

コンピュータでファイアウォールを使用している場合は、SolidNetWork ライセンスをサポートするようにポートを構成する必要があります。

ファイアウォールのソフトウェアで、2 つの SolidNetWork ライセンス ポート（例: SNL-in-port と SNL-out-port）をファイアウォールの例外リストに追加する必要があります。 これらのポートを構成する方法の詳細については、システム管理者に相談してください。

サポートされる Windows オペレーティング システムで Windows ファイアウォールを使用している場合は、SolidNetWork ライセンス マネージャー コンピュータでポートを変更し、SolidNetWork ライセンス ファイルを変更してライセンスをライセンス クライアント コンピュータに配布する必要があります。

目次

  • Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

    Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。

  • WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

    Windows ファイアウォールを使用している場合は、ファイアウォール ポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWork ライセンス ファイルを変更する必要があります。

親トピック SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS の各種バージョンへのアクセスの管理


Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。

  1. Windowsでコントロール パネルを開き、セキュリティ センター（Security Center）をダブル クリックします。
  2. Windows ファイアウォール（Windows Firewall）をクリックします。
  3. 例外（Exceptions）タブでポートの追加（Add Port）をクリックします。
  4. 名前（Name）（例えば、SNL-in-port）とポート番号（Port Number）（例えば、25734）を入力してから、OKをクリックします。
  5. 2つ目のポートのために、例外（Exceptions）タブのポートの追加（Add Port）を再びクリックし、残りのポートの名前と番号（例えば、SNL-out-portと25735）を指定してから、OKをクリックします。後からSolidNetWorkライセンス ファイルを変更する際等に参照ができるように、ポート番号をメモしてください。
  6. Windowsセキュリティ センターとコントロール パネルを閉じます。
親トピック SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）


WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

Windows ファイアウォールを使用している場合は、ファイアウォール ポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWork ライセンス ファイルを変更する必要があります。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンス サーバー（License Server）のサーバー アドミニストレーション（Server Administration）タブで停止（Stop）をクリックします。 （確認を求めるプロンプトが表示されたら、はい と OK をクリックし、ライセンス サーバーの停止を完了します。）
  3. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
  4. サーバー タイプ （Server Type）でネットワークのサーバー配置（単一 （Single）または 3サーバー （Triad））を選択してから、次へ （Next）をクリックします。
  5. サーバー情報 （Server Information）で以下を行います。
    1. このサーバーのファイアウォールは使用中です （A firewall is in use on this server）を選択します。
    2. ポート番号とベンダー デーモン ポート番号には、Windows ファイアウォールに指定したポート番号が含まれていなければなりません（詳細については、Windows ファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）を参照）。
    3. オプション ファイル を選択し、参照 をクリックしてファイルを見つけます。 編集 をクリックして、いずれかのパラメータを変更します。
      オプション ファイルを使用することで、ライセンス管理者は FLEXnet ライセンスのさまざまな操作パラメータを制御できます。

      オプション ファイルの推奨される場所は、SolidNetwork License Manager のインストレーション ディレクトリ（SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt）です。 このファイルは、sw_d.lic ファイルと同じディレクトリにある必要があります。

      オプション ファイルの詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

    4. 次へ （Next）をクリックし、終了 （Finish）をクリックします。
  6. サーバー アドミニストレーション （Server Administration）タブの ライセンス サーバー （License Server）で 開始 （Start）をクリックします。
  7. OK をクリックして SolidNetWork License Manager を閉じます。
親トピック SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）


SolidNetWorkライセンス管理（SolidNetWork License Administration）

タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの借入と返却が含まれます。

ライセンス マネージャーを開始またはアップグレードする前に、借りたライセンスを返却する必要があります。

目次

  • SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

    SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

  • SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

    SOLIDWORKS メジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化で構成されます。

  • SolidNetWork ライセンス ファイルの削除

    新しい SolidNetWork ライセンス ファイルにアップグレードする前に、有効期限の切れた古いファイルを削除してください。

  • SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  • ライセンスのアイドル状態の監視（Monitoring License Idle Time）

    SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  • 一時的なライセンスのインストール（Installing Temporary Licenses）

    一時的な "ANY" ライセンスは、オリジナルの SolidNetWork ライセンスが使用できない場合に一時的に使用できます。

  • 個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

    SOLIDWORKS 個人ライセンスから SolidNetWork ライセンスにコンピュータをアップグレードするには、SOLIDWORKS Installation Manager で SolidNetWork ライセンスのシリアル番号を指定します。

  • SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

    SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品のライセンスを配布できます。

  • ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

    ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

  • FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）

    SolidNetWork ライセンスは、FLEXnet Publisher® ライセンス管理に基づいています。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）
SolidNetWork ライセンスの移動


SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

Windows で次のコマンドを実行します： スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager。
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

SOLIDWORKS メジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化で構成されます。

新しいリリース用のライセンス マネージャーは、以前のリリースを保持しているクライアント コンピュータのライセンスも配布できます。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスの使用状況（License Usage）タブで、SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。
  3. 古いライセンス マネージャーをアンインストールします。 詳細は、SolidNetWork License Manager のアンインストール（Uninstalling the SolidNetWork License Manager）を参照してください。
  4. 新しいライセンス マネージャーをインストールし、ライセンス マネージャー コンピュータでSolidNetWork ライセンスを再アクティブ化します。 詳細は、License Managerのインストールとアクティベーション（Installing and Activating a License Manager）を参照してください。

SOLIDWORKS アプリケーションを同時に実行しているコンピュータで SolidNetWork License Manager をアップグレードする場合は、そのコンピュータに SOLIDWORKS アプリケーションの新しいサービス パックをインストールする前に SolidNetWork ライセンス マネージャーとクライアントをアップグレードします。

アドミニストレーティブ イメージをホストするコンピュータでライセンス マネージャーをアップグレードする場合は、アドミニストレーティブ イメージをアップグレードする前にライセンス マネージャーをアップグレードします。 詳細については、Using the Same Computer for the License Manager and Administrative Image Installations を参照してください。

目次

  • SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）

    SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）

SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

  1. SolidNetwork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。
    ライセンスの使用状況（License Usage）タブは SOLIDWORKS を実行しているクライアントを示します。
  3. SolidNetWork ライセンスを別のコンピュータに移動する場合は、SolidNetWork License Managerを削除する前にライセンスを非アクティブにして別のコンピュータに移動してください。
    SolidNetWork ライセンスの移動については、SolidNetWork ライセンスの移動を参照してください。
  4. ライセンス サーバー（License Server）のサーバー アドミニストレーション（Server Administration）タブで停止（Stop）をクリックします。
  5. OK をクリックし、ライセンス マネージャーを閉じます。
  6. Windows で コントロール パネル > プログラムの追加と削除 を開きます。
  7. SOLIDWORKS SolidNetWork License Manager を選択し、削除（Remove）をクリックして削除を確定します。
  8. Windows エクスプローラで SOLIDWORKS SolidNetWork License Manager のフォルダを削除します
    （通常、このフォルダは SOLIDWORKS インストレーション ディレクトリの Program Files にあります）。

これで、新しいバージョンのライセンス マネージャーのインストールを行う準備が整いました。 詳細については、License Manager のインストールとアクティベーション（Installing and Activating a License Manager）を参照してください。

SolidNetWork License Manager コンピュータにハードウェア ドングルが取り付けられている場合は、新しいバージョンの SolidNetWork License Manager をインストールする前に、ハードウェア ドングルを取り外します。
親トピック SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
関連タスク
SolidNetWork ライセンスの移動
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）


SolidNetWork ライセンス ファイルの削除

新しい SolidNetWork ライセンス ファイルにアップグレードする前に、有効期限の切れた古いファイルを削除してください。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. サーバー アドミニストレーション （Server Administration）タブの ライセンス ファイル （License File）で 変更 （Modify）をクリックします。続いて ライセンス （Licenses）スクリーンが表示されるまで 次へ （Next）をクリックします。
  3. ライセンス （Licenses）画面で古いまたは期限の切れた SolidNetWork ライセンス ファイルを選択してから、削除 （Remove）をクリックします。
  4. 終了 （Finish）をクリックし、次に OK をクリックします。
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

借入ライセンスは、現在のユーザーおよび借りたコンピュータでのみ有効で、移動することはできません。

ライセンスは指定期間中（30日間まで）、（またはシステム管理者によって定義された日数）貸し出すことができ、ライセンスは使用可能なライセンスのプールから取り除かれます。

ライセンスの借用と返却は、その SOLIDWORKS ライセンスを使用中の場合は機能しません。

システム管理者はライセンスの借入を次のようにカスタマイズできます。
  • ライセンスを借りることのできるユーザーやグループを定義する
  • 借りることのできないライセンスの数を設定する

詳細については、 SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdfを参照してください。

目次

  • SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

  • 借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

    借りた SolidNetWork ライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

SolidNetWork License Manager は、常にスタート（Start）メニューから起動します。 ライセンスを借用するには、SolidNetWork License Manager に接続している必要があります。

Windows 8 以降を実行している場合、以下の手順はシステムのコンフィギュレーションによって異なります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。
  1. クライアント マシンで SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスを借りる（License Borrowing）タブでは:
    1. 借りる期限 （Borrow until）で日付を指定します。
    2. 借りる製品ライセンスを選び、借りる （Borrow）をクリックし、続いて はい もクリックして確認します。
    3. 更新 （Refresh）をクリックします。 期限切れ期日 （Expire Date）列は、ライセンスの期限を示します。
  3. OK をクリックします。
親トピック SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
関連タスク
借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）


借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

借りた SolidNetWork ライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  1. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスを借りる（License Borrowing）タブでは:
    1. 返す製品ライセンスを選び、返却 （Return）をクリックし、確認のために はい をクリックします。
    2. 更新 （Refresh）をクリックします。 期限切れ期日 （Expire Date）は空欄になり、ライセンスが返却されたことを示します。
  3. OK をクリックします。
有効期限が過ぎたライセンスを戻す必要はありません。 有効期限最終日の真夜中になると、ライセンスは自動的に SolidNetWork ライセンス マネージャーのライセンス プールに戻され、リモート システム上にあるアプリケーションは実行できなくなります。
親トピック SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
関連タスク
SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）


ライセンスのアイドル状態の監視（Monitoring License Idle Time）

SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. ファイルに次のラインを追加します。
    TIMEOUTALL seconds

    ここで、secondsは900（15分）（許容最少時間）、またはそれ以上の数値となります。

親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


一時的なライセンスのインストール（Installing Temporary Licenses）

一時的な "ANY" ライセンスは、オリジナルの SolidNetWork ライセンスが使用できない場合に一時的に使用できます。

"ANY" ライセンス ファイルのインストールにより、お客様は Dassault Systèmes SOLIDWORKS Corporation から SolidNetWork ライセンスを受け取った際、従来のライセンスの履行に同意することになります。 この場合も、ライセンス制限への応諾が必要となります。

"ANY"ライセンスをインストールするには、以下を行います。

  1. 既存のSolidNetWork ユーザーである場合、SolidNetWork License Manager のアンインストールを行い、インストレーション フォルダを削除します。 詳細は、SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）を参照してください。
  2. SOLIDWORKS Installation Manager を開始します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    1. インストレーションのタイプには、以下を選択します。
      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。
    2. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    3. サマリー（Summary）ページで、今すぐインストール（Install Now）をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  3. SolidNetWork License Manager を開始します（スタート（Start） > プログラム（Programs） > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  4. アクティブ化を求めるプロンプトが表示される場合は、いいえ をクリックします。
    SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。
  5. 詳細設定オプション で オプション をクリックします。
    詳細設定オプション（Advanced Options） ダイアログ ボックスが表示されます。
  6. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。
    詳細設定オプション（Advanced Options） ダイアログ ボックスが閉じます。
  7. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
    SolidNetWorkライセンス ファイル ウィザードが表示されます。
  8. サーバー タイプ （Server Type）で 単一 （Single）を選択し、次へ （Next）をクリックします。
  9. 次のメッセージが表示される場合は、以下を行います。
    ドングルのID番号が読み取れませんでした。キャンセルをクリックしてください。
    IDとして"ANY"が自動的に表示されます。
    コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。 詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。
  10. インストレーションを続行します。
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

SOLIDWORKS 個人ライセンスから SolidNetWork ライセンスにコンピュータをアップグレードするには、SOLIDWORKS Installation Manager で SolidNetWork ライセンスのシリアル番号を指定します。

コンピュータに SOLIDWORKS がインストールされていない場合は、SOLIDWORKS Installation Manager でインストールするときに SolidNetWork シリアル番号を入力することで SolidNetWork ライセンスを指定できます。

SOLIDWORKS が既にインストールされたコンピュータで個人ライセンスから SolidNetWork ライセンスに切り替える場合は、クライアント コンピュータのインストレーションの変更を行い、SOLIDWORKS Installation Manager の実行時に個人ライセンスのシリアル番号の代わりに SolidNetWork ライセンスのシリアル番号を指定します。 詳細は、インストレーションの変更（Modifying an Installation）を参照してください。
管理イメージから SOLIDWORKS をインストールした場合、変更オプションは使用できません。 管理オプション エディタを使用して管理イメージを変更して、クライアントをアンインストールして、インストールを再実行する必要があります。
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
インストレーションの変更（Modifying an Installation）


SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品のライセンスを配布できます。

  • SOLIDWORKS ソフトウェアのライセンス数と SOLIDWORKS アドインのライセンス数が同じである必要はありません。
  • アドイン製品のライセンスをチェックアウトするには、最初に SOLIDWORKS のライセンスをチェックアウトする必要があります。
  • アドイン製品ライセンスを借りるには、SOLIDWORKS ソフトウェア ライセンスと、アドイン製品を含む SOLIDWORKS 製品ライセンスの両方を借りる必要があります。 デフォルトでは、SOLIDWORKS Standard ライセンスを借りますが、アドインを有効にするには、SOLIDWORKS Professional または SOLIDWORKS Premium 製品のライセンスを借りる必要があります。
  • アドイン製品ライセンスをリリースするには、以下を行います。
    • SOLIDWORKS で ツール (Tools) > アドイン (Add-ins) をクリックし、アドインを選択解除します。
    • SOLIDWORKS を終了します。
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

クライアント コンピュータはライセンス マネージャーからライセンスを入手し、次に同じコンピュータから SOLIDWORKS をインストールできます。

このコンフィギュレーションでは、同じコンピュータにライセンス マネージャーとアドミニストレーティブ イメージ の両方をインストールする必要があります。 最初にライセンス マネージャーのインストールを行い、次にアドミニストレーティブ イメージの作成と展開を行います。
詳細は次を参照してください：
  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
  • 複数クライアントへの展開（Deploying to Multiple Clients）
親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）

SolidNetWork ライセンスは、FLEXnet Publisher® ライセンス管理に基づいています。

FLEXnet Publisher ライセンス管理の詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（SolidNetWork License Manager インストレーション ディレクトリ\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

FLEXnet Publisher ライセンス管理の最新情報については、Acresso® Software までお問い合わせください。

親トピック SolidNetWorkライセンス管理（SolidNetWork License Administration）


トラブルシューティング（Troubleshooting）

インストレーションの問題のトラブルシューティングに役立てるため、これらのトピックを参考にしてください。

目次

  • ネットワーク ライセンスの使用状況（Network License Usage）

  • SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

    SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

  • SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

    SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

  • SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

    SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

  • アップグレードのトラブル シューティング（Troubleshooting Upgrades）

    新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

  • インストール時またはアップグレード時にグラフィック カードを検証

    マシン上への SOLIDWORKS のインストールまたはアップグレードを完了すると、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認する必要があります。


ネットワーク ライセンスの使用状況（Network License Usage）

このダイアログ ボックスは、サーバーで製品のライセンスが不足している場合に開きます。

製品 ボックスの矢印をクリックし、選択可能なすべての製品を表示します。 製品の選択アイテムには、SOLIDWORKS、および購入可能なすべてのアドインが含まれています。

ライセンスの合計数は購入したライセンスの合計数です。

利用可能なライセンスは現在使用されていないライセンスです。

ライセンス使用者ボックスには、現在ライセンスを使用している各ユーザーに関する情報が表示されます。

親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証


SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

これらのログ ファイルは、その他の SOLIDWORKS アプリケーションのログ ファイルと同じ場所にあります。
  • Windows 7 以降の場合:

    C:\Users\ユーザー名\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

ログ ファイルのディレクトリを表示するには、Windowsのフォルダ オプションをすべてのファイルとフォルダを表示する（Show hidden files and folders）に設定する必要があるかもしれません。

アプリケーション データがC:以外のドライブにある場合は、これに応じて適切にディレクトリ パスを調整してください。

このディレクトリには、SOLIDWORKS Installation Manager プログレスの全般的なログである SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt ファイルがあります。

Other Logsサブディレクトリには、より詳細なインストレーション ログ情報が含まれています。

親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

Windows 8 以降を実行している場合、スタートまたはコントロール パネルへのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 詳細な説明およびオプション、特に Windows 8 以降のシステムに関する説明については、Microsoft Windows のドキュメントを参照してください。
質問 答え
このフォルダにあるファイルをインストールするには？

setup.exeを実行します。 以前ダウンロードされたことの無いアイテムをインストールするように選択した場合は、追加ファイルのダウンロードが必要な場合があります。

msiexecを使用してインストールしないでください（下記参照）。
msiexec や他のアプリケーションを使用して MSI ファイルをこのフォルダからマニュアルでインストールできますか?

いいえ。 Installation Manager では msiexec の実行に必要なファイルの一部がダウンロードされません。
各々のバージョンのインストールに同じダウンロード フォルダを選択して良いですか？

ダウンロード フォルダはバージョン固有のものです。 SOLIDWORKS 2010 を開始すると、SOLIDWORKS Installation Manager は指定されたフォルダ内にバージョン固有のサブフォルダを自動的に作成します。

一部の製品は Dassault Systèmes SOLIDWORKS Corporation Web サイトからダウンロードしてあります。 これらもInstallation Managerでインストールできますか?
SW2009 から、マニュアルでダウンロードしたファイルを SOLIDWORKS Installation Manager で使うことができます。 しかし、ファイルをダウンロードするオプションを選択して、SOLIDWORKS Installation Manager を実行するほうが適切です。 SOLIDWORKS Installation Manager は各ファイルをダウンロードするためにリンクを提供し、インストールしているものに基づいてどのファイルを必要とするかを表示します。 組み込みのダウンロードページが機能しないとき、このオプションを使用してください（プロキシ サーバーによって実施されたダウンロード制限などがあるときです）。
Microsoft Internet Explorer によってダウンロードまたはインストレーション中にファイルを保存するか、または実行するかを確認された場合は、必ず保存を指定してください。
ダウンロードしたファイルは他のユーザーと共有できますか?

Yes そのためには、共有ネットワーク上にダウンロードします。 続いて、各クライアントが共有ネットワークから SOLIDWORKS Installation Manager を実行し、インストールすることができます。

初期のダウンロードに含まれていないアイテムがユーザーによって選択されていない、またはダウンロードをインストールに使用するコンピュータがファイルをダウンロードするコンピュータとは異なる前提条件のセットを持っていない限り、追加のダウンロードは必要ありません。

インストールは行わず、他のユーザーのためにダウンロードを行う場合は、インストール時にダウンロードのみ（Download Only）オプションを選択します。 このオプションを選択すると、システム上にインストールされていない製品も選択することができます。 ただし、パッチをダウンロードする場合、アドミニストレーティブ イメージを作成する場合は、このオプションを使用することはできません。
いつ新しいバージョンの SOLIDWORKS を使用できるか知りたいのですが?
次の場合において、新しいバージョンが使用できるようになった際に通知を受けることができます。
  • [アップデート チェック (Check for Updates)] ( スタート > すべてのプログラム > SOLIDWORKS Installation Manager > アップデート チェック) を実行する場合
  • SOLIDWORKS バックグラウンド ダウンローダーを有効にした場合
  • Windows プログラムの追加と削除 でインストール済みバージョンの SOLIDWORKS を選択して、変更 をクリックした場合
  • ダウンロード フォルダで古いバージョンの Installation Manager（sldIM.exe）を実行した場合
これらの場合、新しいバージョンのダウンロードを選択することができます。 SOLIDWORKS Installation Manager は新しいバージョンの Installation Manager （インストレーション ファイルでは無く）をダウンロードし、実行します。 新しいバージョンの SOLIDWORKS Installation Manager が実行された後、インストレーションの詳細を指定することができます。 続いて、SOLIDWORKS Installation Manager によって必要なインストレーション ファイル（これまでにダウンロードされていないファイル）が確定され、これらのファイルをダウンロードするかどうかを尋ねられます。
SOLIDWORKS Installation Manager で別の製品の ServicePack のインストールを選択できないのはなぜですか。

それぞれのバージョンの SOLIDWORKS Installation Manager は、特定バージョンの SOLIDWORKS 製品のみをインストールするように設計されています。 別のバージョンの ServicePack をインストールするには、そのバージョンの SOLIDWORKS Installation Manager を実行する必要があります。 使用可能な最新バージョンを確認するには、前の項目を参照してください。
SOLIDWORKS Installation Manager によるファイルのダウンロードが妨げられるのはなぜですか。

プロキシ サーバーによってアプリケーションによるファイルのダウンロードが制限さていれる場合、SOLIDWORKS Installation Manager は自動的にファイルをダウンロードすることができません。

マニュアルでファイルをダウンロードして、次に SOLIDWORKS Installation Manager を使ってそれらをインストールすることができます。 個々のファイルをダウンロードするには SOLIDWORKS Installation Manager のオプションを選択します (たとえば、マニュアル ダウンロード実行 ページの ダウンロード オプション)。 製品選択とシステム必要条件に基づいて、マニュアルでダウンロードするすべての必要なファイルのリンクを含むWebページが、別のウィンドウに表示されます。 これらのリンクは SOLIDWORKS Customer Portal によって提供されたものとまったく同じです。しかしファイルを探す必要はありません。
一部の SOLIDWORKS 製品が最新の ServicePack バージョンまでアップデートされません。 アップデート チェックに最新バージョンであると示されるのはなぜですか。

アップデート チェックは最新バージョンの SOLIDWORKS Installation Manager がインストールされているか（あるいは実行されているか）のみを伝えてきます。

すべての製品を最新バージョンまでアップデートしたい場合は、プログラムの追加と削除 で、インストールされている SOLIDWORKS の最新バージョンを選択し、変更 をクリックしてください。

DVD をダウンロード フォルダにコピーして良いですか?

はい、しかし該当するプラットフォームにリリースされた各 DVD の全内容をコピーしない限り、インストレーションが失敗する場合があります。 SOLIDWORKS Installation Manager はバージョンを決定するためにファイル swdata*.id を探します。 これらのファイルが無い場合は、コピーした、ダウンロードが必要なインストレーション ファイルが認識されません。
親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）

SolidNetWorkライセンス ログ ファイルへのアクセス（Accessing the SolidNetWork License log files）

ライセンス エラーの原因は、ほとんどの場合、 SNL_Manager_インストール_ディレクトリ\lmgrd.logファイルに表示されています。

SOLIDWORKS のライセンスを取得できない場合。 ライセンス サーバーに接続できない場合。

一般に、この問題はポートの設定によって生じます。

  • SolidNetWorkライセンス マネージャーとライセンス クライアントとで一致していないポート設定を使用している場合が考えられます。
  • 複数バージョンの SolidNetWork License Manager で必要な追加のポート設定が指定されていない場合が考えられます。
  • サーバー名が指定されている場合に、クライアント マシンがサーバーを正確に解決してサーバーにルートできることを確認します。 また、クライアント マシン名が指定されている場合に、サーバーがクライアントを正確に解決してクライアントにルートできることを確認します。
SolidNetWork ライセンス マネージャーとクライアントのポート設定に関する詳細については、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。
関連概念
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


アップグレードのトラブル シューティング（Troubleshooting Upgrades）

新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）

移動されたソースからアップグレードする場合（Upgrading from a Source That Has Moved）

SOLIDWORKS がインストールされると、SOLIDWORKS Installation Manager はインストレーション ソース（ディスク メディア、ネットワーク上のディスク イメージなど）を記憶します。 更新する際、このソースがアクセス可能であることを前提とします。

ソースが移動/削除されている、あるいはソース メディアが変更されている場合、SOLIDWORKS Installation Manager はエラー メッセージを表示します。 しかし、必要なすべてのソース ファイルが同じフォルダ階層で移動されている場合は、そこまで参照し、アップグレードを続行できます。


インストール時またはアップグレード時にグラフィック カードを検証

マシン上への SOLIDWORKS のインストールまたはアップグレードを完了すると、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認する必要があります。

グラフィック カードとドライバを検証するには:

  1. Installation Manager がインストールを完了し、完了（Finish）ページが表示されたら、システムを確認（Check Your System）の下で、システム診断ツールの実行（Run System Diagnostics）をクリックします。

    SOLIDWORKS Rx が起動し、診断を実行します。

  2. SOLIDWORKS Rx は、グラフィック カードとグラフィック カード ドライバがサポートされているか確認します。 グラフィック カードがサポートされているが、ドライバがサポートされていない場合は、ステータス メッセージによってサポートされているドライバへのリンクが提供されます。

SOLIDWORKS を 10 回起動するごとに、システムを確認（Check Your System）メッセージが表示され、もう一度システム診断を実行するように推奨されます。 これらの通知を抑制するには、Windows 通知領域で SOLIDWORKS Resource Monitor を右クリックして、通知をオフに設定（Turn Off Notifications）をクリックします。

Windows 通知領域で SOLIDWORKS Resource Monitor を右クリックすることにより、任意の時点でグラフィック カードとドライバを検証できます。 ショートカット メニューを使用すると、次の作業を行うこともできます。
  • SOLIDWORKS Resource Monitor のヘルプを表示（Display Help）
  • システム診断ツールの実行
  • ｸﾞﾗﾌｨｯｸ ﾄﾞﾗｲﾊﾞｰの更新
親トピック トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストール/更新する、スタンドアロン アプリケーションです。

SOLIDWORKS Installation Manager は、次のように実行することができます:
  • SOLIDWORKS DVD、共有ソース、またはダウンロード フォルダ（新規バージョンのインストール時）
  • コントロール パネルのプログラムの追加と削除ページ（既存のバージョンの変更または削除時）から
  • スケジュールまたはマニュアルによるアップデート チェック（新規リリース バージョンの検出、ダウンロード、インストール時）を介して

各バージョンの SOLIDWORKS には、そのバージョン特有の SOLIDWORKS Installation Manager があります。

SOLIDWORKS 2008 より前のバージョンでは、SOLIDWORKS 2007 の Installation Manager を使用してください。または、SOLIDWORKS サポート ウェブ サイトからマニュアルで製品バージョンをダウンロードしてください。
Windows 8 を実行している場合、スタート または コントロール パネル へのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 詳細な説明およびオプション、特に Windows 8 以降のシステムに関する説明については、Microsoft Windows のドキュメントを参照してください。

目次

  • SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

    SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。

  • アップデート チェックの結果（Check for Updates Results）

    アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

  • アドミニストレーティブ イメージ位置（Administrative Image Location）

    アドミニストレーティブ イメージのインストール場所を指定します。

  • ダウンロード オプション（Download Options）

    ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

  • SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

    より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

  • 製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

    指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

  • ダウンロードの進捗状況（Download Progress）

    このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

  • ダウンロード結果（Download Results）

    ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

  • インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

    インストレーションでエラーが発生し、キャンセルされました。

  • インストレーション完了（Installation Is Complete）

    SOLIDWORKS Installation Manager は、その処理を完了しました。

  • インストール先（Installation Location）

    SOLIDWORKS のインストール先を指定します。

  • 更新オプション（Upgrade Options）

    このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 新規インストレーションを作成して、古いバージョンと共存させることも、アップグレードして古いバージョンを削除することもできます。

  • インストールの進行状況（Installation Progress）

    この画面にはインストレーションの進捗状況が表示されます。

  • インストレーション タイプ（Installation Type）

    新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。

  • 複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

    SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

  • マニュアル ダウンロード（Manual Download）

    ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

  • 利用可能なより新しいバージョン（Newer Version Available）

    Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

  • 利用可能な新しいバージョンはありません（No New Versions Available）

    ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

  • 検出されたプロセス（Processes Detected）

    SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • 製品選択（Product Selection）

    インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。

  • ダウンロードする製品（Products to Download）

    指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

  • 修復する製品（Products to Repair）

    このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

  • シリアル番号（Serial Numbers）

    シリアル番号 (パッケージ上にあります) は、購入した SOLIDWORKS 製品をご使用のコンピュータに関連付けます。

  • サーバー インストール（Server Installation）

    インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

  • SolidNetWork License Manager

    SolidNetWork License Managerサーバー製品のインストール オプションを指定します。

  • サマリー（Summary）

    SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

  • システム チェックの警告（System Check Warnings）

    システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

  • 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

    SOLIDWORKS Toolbox がインストールされている場合、SOLIDWORKS は穴タイプと汎用部品の標準ライブラリを含みます。

  • 製品のアンインストール（Uninstall Products）

    削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

関連概念
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。

バックグラウンド ダウンローダーは、SOLIDWORKS のインストール時にデフォルトで有効になります。

インストールやダウンロードのために Installation Manager を実行している間は、バックグラウンド ダウンローダーは一時停止します。 たとえば、実行中のダウンロードを一時停止し、新たなダウンロードの開始やダウンロード フォルダ指定の変更等を禁止します。

サマリー ページで [ダウンロード オプション (Download Options)] を変更することにより、インストール中にバックグラウンド ダウンローダーを無効にできます。 (バックグラウンド ダウンローダーを使用しますか? (Do you want to use the Background Downloader?) オプションを選択解除します。)

有効な場合には、Windowsのシステム トレイに次のアイコンが表示されます：

このアイコンをクリックすると、次のオプションが有効になります：
  • バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）
  • ダウンロード一時停止（Pause Download）
  • ダウンロード再開（Resume Download）
  • ダウンロード キャンセル（Cancel Download）
  • インストレーション オプション（Installation Options）
  • ダウンロード先の変更（Change Download Location）
  • アップデート チェック（Check for Updates）
  • アップデートを自動的にチェック（Automatically Check for Updates）
  • アップデート自動ダウンロード（Automatically Download Updates）
  • バックグラウンド ダウンローダー無効化（Disable Background Downloader）

バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）

SOLIDWORKS インストレーション ガイド（SOLIDWORKS Installation Guide）内のバックグラウンド ダウンローダーに対する本ヘルプ トピックを開きます。

ダウンロード一時停止/再開（Pause/Resume Download）

バックグラウンドでダウンロードを実行している場合は、ダウンロード一時停止（Pause Download）のクリックによりダウンロードの一時停止が行えます。このダウンロードはダウンロード再開（Resume Download）のクリックにより再開できます。

ダウンロード キャンセル（Cancel Download）

実行中のダウンロードを停止し、バックグラウンド ダウンローダーがダウンロードしたすべてのファイルを削除します。
キャンセルしたダウンロードは再開できません。

インストレーション オプション（Installation Options）

ダウンロードが完了したら、次のオプションが選択できます：
  • 今すぐインストール（Install now）：ダウンロードしたファイルをインストールします。
  • 後で通知（Remind me later）：ダウンロードしたファイルをインストールせず、後から実行を促すための通知メッセージを設定します。
  • このダウンロードﾞを削除（Delete this download）：ダウンロードしたファイルをインストールせずに削除します。（本機能は、ダウンロードしたファイルのインストールが無用となった場合に有効です。）

ダウンロード先の変更（Change Download Location）

バックグラウンド ダウンローダーによるファイルのダウンロード先を変更します。

ダウンロードの実行中や一時停止中には、本オプションは利用できません。

アップデート チェック（Check for Updates）

SOLIDWORKS Installation Manager の アップデート チェック (Check for Updates) 機能を実行します。

アップデートを自動的にチェック（Automatically Check for Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には通知します。

アップデート自動ダウンロード（Automatically Download Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には、それらをダウンロードします。

SOLIDWORKS バックグラウンド ダウンローダーの無効化と再有効化（Disabling and Re-Enabling SOLIDWORKS Background Downloader）

アイコンをクリックし、バックグラウンド ダウンローダー無効化（Disable Background Downloading）を選択することにより、バックグラウンド ダウンローダーを無効にすることが可能です。

バックグラウンド ダウンローダーを再度有効にするには、スタート (Start) > すべてのプログラム (All Programs) > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー (SOLIDWORKS Background Downloader) をクリックします。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アップデート チェックの結果（Check for Updates Results）

アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

マシンの管理者権限を持つユーザーは、アップデート チェック（Check for Updates）を手動で実行できます。
  • Windows で スタート（Start） > プログラム（Programs） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします
  • SOLIDWORKS で ヘルプ（Help） > アップデート チェック（Check for Updates）をクリックします。
アップデート チェックは、アドミニストレーティブ イメージからインストールしたクライアントでは利用できません。

利用可能なより新しいバージョン（Newer Version Available）

SOLIDWORKS Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 より新しいバージョンの SOLIDWORKS Installation Manager を選択することで、新しいバージョンに更新できます。

より新しいバージョンでは、インストレーションで指定した製品に基づいてインストレーション ファイルをダウンロードできます。 ダウンロードしたファイルは SOLIDWORKS Installation Manager を使用してインストールを行う他のユーザーと共有することができます。

これらのダウンロードは、SOLIDWORKS Installation Manager のみで利用できます。
次のオプションを利用できます。
  • 複数のバージョンが利用可能な場合、リストから選択できます。
  • このバージョンの詳細については、アップグレードに含まれるアイテムのチェック（Check to see what this upgrade includes）をクリックします。
次へ (Next) をクリックすると、選択したバージョンの SOLIDWORKS Installation Manager を入手して実行します。

利用可能な新しいダウンロードはありません/新しいバージョンをチェックすることができません（No New Downloads Available/Unable to Check for New Versions）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品の新しいバージョンを見つけられません。これは、利用可能な最新のバージョンがインストール済みであるか、または SOLIDWORKS のサイトに接続してチェックできなかったかのどちらかです。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アドミニストレーティブ イメージ位置（Administrative Image Location）

アドミニストレーティブ イメージのインストール場所を指定します。

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。 アドミニストレーティブ イメージは、クライアント向けに共有可能なフォルダにある必要があります。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプション（Download Options）を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード オプション（Download Options）

ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

SOLIDWORKS Installation Manager は 電子ソフトウェア配布 (ESD) をサポートします。 SOLIDWORKS DVD からインストールしない場合は、インストールする SOLIDWORKS 製品のソースを指定する必要があります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

何を行いますか?（What do you want to do?）

次のいずれかを選択します。

ダウンロードとインストール/ダウンロードとイメージ作成

ダウンロードの完了後、SOLIDWORKS Installation Manager はダウンロード ファイルを使用してインストレーションを実行します。

ダウンロードのみ。 ダウンロードを 1 度行い、ダウンロード ファイルを複数コンピュータで共有できます。

SOLIDWORKS Installation Manager はダウンロードの完了後にインストレーションを実行しません。

通常、このオプションは複数のコンピュータ間で共有するインストレーション ファイル セットを構成するためにファイルをダウンロードする場合のみに指定します。

このオプションを指定すると、ダウンロードする 2 つのファイル セットからの選択を求められます。
  • 当コンピュータ用のファイル: ダウンロードには、現在コンピュータ上にあるインストレーション ファイル セットにないファイルのみが含められます。
    このダウンロードには以下が含まれるため、そのサイズは小さくなるはずです。
    • 製品選択ページで選択した製品のファイルのみ
    • コンピュータに必要な未インストールの前提条件ファイルのみ

    しかし、このダウンロード ファイル セットを別のコンピュータで使用してインストレーションを実行しようとすると、いくつかのファイルが見つからないかもしれません（なぜなら、別のコンピュータ上のインストレーション ファイル セットがこのコンピュータのものと異なる可能性があるからです）。 このダウンロード ファイルを使用して別のコンピュータへインストールすることは可能ですが、インストレーションの実行時に追加のファイルをダウンロードし、そのコンピュータのインストレーション ファイル セットを完全にする必要があるかもしれません。

  • 任意のコンピュータで共有できるファイル: ダウンロードには、このバージョンを任意のコンピュータにインストールするために使用できる完全なインストレーション ファイル セットが含まれます。

    このダウンロードには、このバージョンの任意の製品を任意のコンピュータにインストールするために使用できる完全なファイル セットが含まれているため、そのサイズは大きくなります。

    限られた製品セットをダウンロードするように指定している場合、このオプションはその指定を無視して製品リリースに含まれるすべての製品をダウンロードします。

    ダウンロードには、個人インストレーションを実行するために必要となるファイルだけでなく、アドミニストレーティブ イメージを作成するために必要となるすべてのファイルが含まれます。

インストールのみ/イメージ作成のみ。 必要なインストレーション ファイルは既にすべて持っています。

SOLIDWORKS Installation Manager はファイルをいっさいダウンロードしないで、選択したディレクトリにあるファイルを使用します。

参照をクリックし、別の場所に移動します。 例えば、その場所に必要なファイルがすべて含まれている場合は、インストレーション DVD またはダウンロード フォルダまで参照します。

すべてのインストレーション ファイルがその場所にあると思われたのに、フォルダーが不完全であるとするメッセージが表示される場合は、以下が考えられます。
  • 前にダウンロードされなかったインストーレーションのコンポーネントを選択したか、またはそのコンポーネントがデフォルトで選択された。
  • ファイルはシステム必要条件の異なる設定で別のコンピュータにダウンロードされた。
  • 以前はクライアント インストレーションを実行しており、今回は多くのファイル セットが必要となるアドミニストレーティブ イメージを作成している。

すべてのファイルを含むフォルダ（例えば、DVD）まで参照するか、またはダウンロード オプションのいずれかを選択できます。

必要なファイルをどこにダウンロードしますか?（Where do you want to download the required files?）

これは、ダウンロード フォルダーの場所です。

場合によっては、このオプションが無効になった状態で表示されることもあります。 たとえば、インストールのみ (Install only) を指定した場合、SOLIDWORKS Installation Manager は個別のダウンロード フォルダを使用するのではなく、そのオプションに対して指定されたディレクトリのダウンロード ファイルをインストールします。

これらのファイルをダウンロードする場合、あるいは独自の位置からアクセスしている場合でも、すべてのファイルを同じダウンロード フォルダーにダウンロードする必要があります。

推定ダウンロード サイズ（Estimated download size）

推定ダウンロードの必要なディスク スペースは、これが新規のダウンロードであるか、または前のセッションからのダウンロードを再開しているかどうかにかかわらず、選択された完全なコンポーネント リストに基づいています。

たとえば、もし前回のダウンロードを再開している場合、SOLIDWORKS Installation Manager はダウンロードされなかったファイルだけを処理します。 ダウンロード時間は推定より短くなる可能性があります。

前回のダウンロードでファイルのダウンロードが完了している場合も、そのサイズは推定に含められません。したがって、推定は実際のダウンロード サイズよりも大きい可能性があります。

どのようにダウンロードしますか?（How do you want to download?）

2つのオプションがあります。
マニュアル ダウンロード実行 | 場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。 | このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。 この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。
ネットワークの高帯域幅を使用してダウンロード速度を向上 | ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。 場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。 このオプションは自動ダウンロードのみに適用されます。マニュアル ダウンロードには影響しません。

SOLIDWORKS バックグラウンド ダウンローダーの使用

ダウンロード処理の完全実行や、SOLIDWORKS のサービスパックがリリースされた際のダウンロードには、SOLIDWORKS バックグラウンド ダウンローダーを使用できます。

SOLIDWORKS バックグラウンド ダウンローダーでは、新しいサービスパックの検出とダウンロードをバンクグラウンドで実行することが可能です。ダウンロードが完了し、ファイルのインストール準備が整うと、その内容が通知されます。 詳細は、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

この画面はデフォルトのダウンロード フォルダーに問題がある場合のみに表示されます（例えば、書き込みアクセスまたはネットワーク アクセスを利用できない場合など）。通常、続行するには代替のダウンロード ディレクトリをただ指定するだけです。

ダウンロード ディレクトリ（Download Directory）

SOLIDWORKS Installation Manager ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード アクセラレータを使用（Use Download Acceleration）

このオプションを選択した場合、ダウンロード速度を速くするためのアルゴリズムが使用されます。

ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

このスクリーンをキャンセルすると、残りのインストレーション シーケンスもキャンセルされます。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラー（Installation Errors）を参照してください。

ダウンロード ディレクトリ（Download Directory）

ダウンロード ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダを参照してください。

ダウンロード オプション（Download Options）

SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

ネットワークの高帯域幅を使用してダウンロード速度を向上

ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。

場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。
ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になる場合もあります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
関連資料
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）


ダウンロードの進捗状況（Download Progress）

このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

ダウンロードを実行中にキャンセルするにはキャンセルをクリックします。

ダウンロードをキャンセルするかまたはダウンロードに失敗すると、ダウンロード中止（Download Canceled）またはダウンロードの問題（Download Problem）画面にどのダウンロードが完了されていないかが表示され、ダウンロードを再開するかまたはアプリケーションを終了できるようになります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード結果（Download Results）

ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

ダウンロードの問題/ダウンロード中止（Download Problem/Download Cancelled）

ダウンロードの問題 は、SOLIDWORKS Installation Manager がダウンロードの完了を妨げる問題と遭遇した場合に表示されます。

ダウンロード中止（Download Cancelled）は、ユーザーがダウンロードが完了する前に中止した場合に表示されます。

続行するには、以下を行います。

自動ダウンロードの再試行/再開 | 中止した時点から自動ダウンロードを再開するには、このオプションを選択してダウンロードを再試行（Retry Download）またはダウンロードを再開（Resume Download）をクリックします。
Webブラウザで個々のファイルをダウンロード | 場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。 | このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。 この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。

ダウンロード完了（Download Complete）

ダウンロード完了画面は、ダウンロードのみ（Download Only）オプションを指定した場合にダウンロードが完了すると表示されます。

終了 (Finish) をクリックし、SOLIDWORKS Installation Manager を終了します。

これらの製品のマニュアル インストールは試みないでください。 必ず SOLIDWORKS Installation Manager を使用してダウンロードしたファイルをインストールしてください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

インストレーションでエラーが発生し、キャンセルされました。

エラーまたはキャンセルが発生した場合は:
  • エラーまたはキャンセルが発生する前にインストールされた製品はコンピュータに残ります。
  • エラーまたはキャンセルが発生した際にインストールされていた製品は、可能な場合はロールバックされ、部分的なインストレーションが残らないようにします。
  • 残りの製品はインストールされないか、またはアンインストールされます。まだ実行されていません（Not Yet Attempted）の下にリストが表示されます。

    これらの製品をインストールを再開するか、またはアンインストールするには、表示されたリンクをクリックします。

SOLIDWORKS Installation Manager はまずコンピュータにインストールされていない前提条件 (たとえば .NET Framework など) をインストールします。

目次

  • 失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）

    インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

    インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager のログ ファイルを Zip 圧縮して提供する必要がある場合もあります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）

インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。

  1. インストレーションが失敗した場合は、インストレーション エラー（Installation Errors）およびインストレーションのキャンセル（Installation Cancelled）画面に表示されるエラー メッセージと製品コード番号を記録してください。
    既存の SOLIDWORKS インストレーションを変更していないときにソース ファイルに対するプロンプトが表示される場合は、インストレーションまたはコンピュータが破損している可能性があります。 お客様の代理店までご連絡ください。
  2. コンピューターを再起動します。
  3. SOLIDWORKS 製品が実行されていないことを確認するために、Windows で Ctr+Alt+Del キーを押してタスク マネージャーを開きます。
  4. プロセス タブで、次のいずれかのプロセスが イメージ名 に表示される場合、選択して プロセスの終了 をクリックします。
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. アプリケーションが既にインストールされており、変更/削除する場合は、インストレーションの修復を試みます。 詳細は インストールの修復(Repairing an Installation)を参照してください。
  6. Windows 7 以降では、スタート > コントロール パネル >プログラムと機能 をクリックします。 前のバージョンの Windows では、スタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。
  7. 失敗したバージョンの SOLIDWORKS を選択します。
    インストールする SOLIDWORKS のバージョンが表示されない場合は、インストレーション プロセスを繰り返してください。
  8. 次のいずれかを行います：
    • 再試行するには、変更 （Change）をクリックし、インストールに失敗した、あるいはインストレーション中にスキップされたすべての製品を選択します。

    • 失敗したインストレーションをスキップするには、変更 （Change）をクリックし、インストレーション中にスキップされたすべての製品を選択します。 インストールに失敗した製品を選択解除します。

    • インストレーションを中止するには、削除 （Remove）をクリックし、インストールされたすべての製品を選択します。
    このプロセスでは、アップグレードしていた製品の前バージョンまでは回復されません。
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連タスク
インストールの修復（Repairing an Installation）
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager のログ ファイルを Zip 圧縮して提供する必要がある場合もあります。

  1. ログ ファイルを探します：
    • Windows 7 以降の場合:

      C:\Users\ユーザー名\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version\

    フォルダーが見つからない場合は、隠しフォルダーになっている場合があります。Windowsエクスプローラでツール > フォルダ オプションをクリックします。表示（View）タブの詳細設定（Advanced Settings）で、ファイルとフォルダの表示（Hidden files and folders）ですべてのファイルとフォルダを表示する（Show hidden files and folders）を選択します。
  2. サブフォルダーを含め、このフォルダーのすべてのコンテンツをZip圧縮します。
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連タスク
失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）
インストールの修復（Repairing an Installation）


インストレーション完了（Installation Is Complete）

SOLIDWORKS Installation Manager は、その処理を完了しました。

以下の1つまたは複数のオプションが表示されるかもしれません。

新規機能（What's New）

個人インストレーションの場合は、インストレーション手順を完了した際に、SOLIDWORKS とアドイン製品の新規機能を説明するドキュメントが表示されます。

アドミニストレーティブ イメージ インストレーションの場合は、クライアントがインストレーションを完了した際に、クライアントのコンピュータ上にドキュメントが表示されます。

アンケート（Survey）

インストレーション プロセスに関する短いアンケートにご協力ください。

SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム (Join the SOLIDWORKS Customer Experience Improvement Program)

製品改善を支援するため、パフォーマンス インフォメーションが SOLIDWORKS Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 次のいずれかを選択します:
  • はい、参加します
  • いいえ、参加しません
  • 後で通知
詳細は、Customer Experience Improvement Program Web サイト を参照してください。

アドミニストレーティブ イメージの作成が完了しました（Administrative Image Creation Is Complete）

アドミニストレーティブ イメージの作成が完了したら、イメージのカスタマイズ（Customize Image）をクリックすることによりアドミニストレーティブ イメージ オプション エディタを起動し、イメージをカスタマイズすることが可能です。

オプション エディタの使用方法を表示するには、クライアントにイメージをインストールする方法を表示します。（Show me how to install this image on a client.）をクリックしてください。

オプション エディタを使用してアドミニストレーティブ イメージを設定する方法の詳細については、アドミニストレーティブ イメージ オプション エディタを参照してください。

アドミニストレーティブ イメージ オプション エディタを起動し、アドミニストレーティブ イメージに対するオプション設定をカスタマイズするには、イメージのカスタマイズ（Customize Image）をクリックします。
オプション エディタは、アドミニストレーティブ イメージのインストール ディレクトリにあるsldAdminOptionEditor.exeをダブルクリックにより、後から起動することも可能です。

目次

  • SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

    マシンの管理者権限を持つユーザーは、SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  • SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

    SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連資料
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

マシンの管理者権限を持つユーザーは、SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  1. 次のいずれかを実行して SOLIDWORKS Installation Manager を開始します:

    • SOLIDWORKS アプリケーションで、ヘルプ (Help) > アップデート チェック (Check for Updates) をクリックします。

    • Windows でスタート (Start) > プログラム (Programs) > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) をクリックします。

    SOLIDWORKS Installation Manager は利用できるアップデートがあるかどうかを通知します。
  2. 利用できるアップデートがある場合は、ダウンロードしてインストールするかどうかを選びます。
  3. 定期的な自動アップデート チェックを有効にするには、SOLIDWORKS Installation Manager がそのプロセスを完了したときに ___日毎に更新をチェックします (Check for Updates every __ days) を選択し、チェックの頻度を指定します。
親トピック インストレーション完了（Installation Is Complete）
関連概念
SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）


SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

SOLIDWORKS はこの情報を製品の使用と品質の評価の傾向を確定するために使用します。 パフォーマンス ログは、最も高品質な製品を提供するために役立ちます。

このプロセスでは透明性が確保されています。ログ ファイルに含まれるすべての情報は機密情報として扱われます。その他の目的で使用されることは無く、お客様に連絡が入ることもありません。

詳細については、Customer Experience Improvement Program Web サイトを参照してください。

親トピック インストレーション完了（Installation Is Complete）
関連タスク
SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）


インストール先（Installation Location）

SOLIDWORKS のインストール先を指定します。

アドミニストレーティブ イメージの作成を除いて、インストレーションには以下のオプションが適用されます。
選択製品を次へインストールします | これは、SOLIDWORKS をインストールするディレクトリの場所です。 インストレーションのアップグレードまたは変更時には、すべてのファイルをそのインストレーションの既存の場所にインストールする必要があります。 この場合、既存の SOLIDWORKS インストレーションの場所は変更できません。
インストレーションに必要なスペースの推定サイズ | これは、インストレーションまたは変更のために選択された製品に対して必要となる追加スペースです。 | インストール先のディスクにインストレーションの要件をサポートするのに十分な空きスペースがあることを確認してください。
インストール元 | これは、SOLIDWORKS のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプションを参照してください。
どちらの SOLIDWORKS インストール位置についても変更する前に、システム管理者に相談してください。

アドミニストレーティブ イメージの位置（Administrative Image Locations）

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプションを参照してください。
既存イメージ位置 | 既存のアドミニストレーティブ イメージをアップグレードするとき、SOLIDWORKS Installation Manager は既存のイメージの設定に基づいて新規イメージを作成します。 この既存のイメージは変更されません。 これは、ようこそ 画面で指定した元のイメージの場所を示します。

特定のバージョンのディレクトリ パスの使用回避（Avoid Using Version-Specific Directory Paths)

インストレーション ディレクトリの位置にバージョン番号を指定してから（たとえば、C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2018\）このインストレーションを SOLIDWORKS 2019 にアップグレードすると、SOLIDWORKS 2019 のインストレーション ディレクトリに SOLIDWORKS 2018 というラベルが付きます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連資料
ダウンロード オプション（Download Options）


更新オプション（Upgrade Options）

このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 新規インストレーションを作成して、古いバージョンと共存させることも、アップグレードして古いバージョンを削除することもできます。

SOLIDWORKS version の新しいインストレーションを作成します。

新規インストレーションを作成する場合は、インストールする SOLIDWORKS 製品を選択できます。

選択した製品ごとに、このメジャー バージョンの新規インストレーションが作成されます。 古いメジャー バージョンは、SOLIDWORKS Electrical と SOLIDWORKS PDM Client を除き、マシン上に残ります。

製品を選択解除すると、その新しいバージョンはインストールされません。

新規インストレーションの作成は、新しいバージョンのインストール後も古いバージョンの SOLIDWORKS にアクセスしたい場合に役立ちます。 たとえば、古いバージョンを実行し続けている他のユーザーとファイルを共有する場合、新しいバージョンを使用して保存したファイルのバージョンの互換性の問題を回避できます。

SOLIDWORKS previous_major_version から SOLIDWORKS 2019 current_major_version へアップグレードします。

アップグレードする場合は、アップグレードする SOLIDWORKS 製品を選択できます。 選択した製品ごとに、新規インストレーションが作成され、古いバージョンが削除されます。

製品を選択解除すると、その新しいバージョンはインストールされず、マシンには古いバージョンが残ります。

SOLIDWORKS Electrical と SOLIDWORKS PDM Client の考慮事項

SOLIDWORKS Electrical は、1 台のマシンに 1 つのバージョンのみをインストールできます。 SOLIDWORKS の新規インストレーションを作成している場合、インストールする製品の 1 つとして SOLIDWORKS Electrical を選択したときは、古いバージョンの SOLIDWORKS Electrical は削除されます。

新しいバージョンをインストールする前に、既存の SOLIDWORKS Electrical 環境をバックアップすることをお勧めします。 SOLIDWORKS Electrical Schematic 内からファイル（File） アーカイブ環境（Archive Environment）を選択するか、SOLIDWORKS Electrical 3D 内からSOLIDWORKS Electrical > ツール（Tools） > アーカイブ環境（Archive Environment）を選択します。

SOLIDWORKS PDM Client のメジャー バージョンは SOLIDWORKS PDM Server のメジャー バージョンと一致させる必要があります。 SOLIDWORKS PDM Server をアップグレードするつもりがない場合は、アップグレードで SOLIDWORKS PDM Client を選択しないでください。

製品を削除するには、Windows で、プログラムの追加と削除（Add/Remove Programs）を使用します。 詳細は、インストレーションの削除を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連タスク
インストレーションの削除（Removing an Installation）


インストールの進行状況（Installation Progress）

この画面にはインストレーションの進捗状況が表示されます。

インストレーションの開始後にキャンセルするには、キャンセル（Cancel）をクリックします。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラーを参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション タイプ（Installation Type）

新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。

個人（Individual）

SOLIDWORKS 製品をこのコンピュータへインストールします。

このオプションは、このバージョンがコンピュータにインストールされていない場合のみに表示されます。

個人インストレーションの変更（Modify the individual installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で変更します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
変更には以下が含まれます。
  • SOLIDWORKS 製品コンポーネントの追加または削除
  • 異なる SOLIDWORKS パッケージへの変更 (たとえば、SOLIDWORKS Professional、SOLIDWORKS Premium など)
  • SOLIDWORKS シリアル番号設定の変更
    前回のインストレーションで SOLIDWORKS シリアル番号を既に指定している場合、SOLIDWORKS Installation Manager ではシリアル番号の指定を求められないことがあります。 SOLIDWORKS Installation Manager によって仮定されたシリアル番号を変更するには、このオプションを選択する必要があります。

個人インストレーションの修復（Repair the individual installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で修復します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。
個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを使用して再インストールする必要があります。

アドミニストレーティブ イメージ（Administrative image）

このコンピュータでアドミニストレーティブ イメージの作成または更新を行います。

アドミニストレーティブ イメージを使用し、複数のコンピュータにインストールできます。 アドミニストレーティブ イメージを使用して複数のクライアントに SOLIDWORKS をインストールする方法については、アドミニストレーティブ イメージの使用を参照してください。

アドミニストレーティブ イメージを作成またはアップデートするときは、以下を行えます。
  • 既存イメージのインストレーション設定を使用し、新規またはアップデートされたイメージを設定するか、デフォルトの SOLIDWORKS インストレーション設定を使用できます。
  • 既存のイメージをアップデートする場合:
    • アップデートする場合も、SOLIDWORKS Installation Manager はイメージの新規コピーを作成します。 元のイメージは変更されません。
    • アップデートする既存のイメージのファイルを使用し、アップデートされたイメージを作成できます。この結果、ダウンロード サイズが小さくなります。
    以前のイメージをアップデートするためにServicePackリリースを利用できるイメージを指定しなかった場合、サイズの小さいダウンロードを利用することはできません。

サーバー製品（Server products）

SOLIDWORKS アドミニストレーティブ サーバー製品には、SOLIDWORKS Electrical、SOLIDWORKS PDM と SolidNetWork License Manager が含まれます。

SOLIDWORKS Electrical と SOLIDWORKS PDM については、クライアント ツールとサーバー ツールを同じコンピュータにインストールするか、別々のコンピュータにインストールするかを選べます。

これらのサーバーのインストールについての詳細は、ヘルプで対応するトピックを参照してください。

ダウンロードのみ（Download only）

製品をインストールしないで、選択した SOLIDWORKS 製品のインストレーション ファイルをダウンロードします。

このオプションは DVD からインストレーションを行っているときは表示されません。

ダウンロード ファイルの内容は、SOLIDWORKS インストレーション DVD で利用できるファイルと同じものです。 このオプションを選択すると、どのファイルが既にコンピュータにインストールされているかにかかわらず、インストール ファイルの完全なセットがダウンロードされます。

この方法を使用してサーバーをセット アップし、このサーバーからユーザーはインストレーションを実行できます。これはアドミニストレーティブ イメージを作成することとは異なります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
アドミニストレーティブ イメージの使用（Using Administrative Images）
SOLIDWORKS PDM
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SOLIDWORKS Electrical


複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

SOLIDWORKS アドミニストレーティブ イメージ（SOLIDWORKS Administrative Images）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

SOLIDWORKS PDM

SOLIDWORKS PDM は、SOLIDWORKS Enterprise PDM と同じクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。 次の 2 つのバージョンで使用できます。 Standard および Professional。 SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

SolidNetWork License Manager

SolidNetWork License Managerでは、ライセンスの使用をフロートすることにより、実際のライセンス数よりも多数のユーザーを許可します。 使用されていないクライアント ライセンスは、他の SOLIDWORKS ユーザーが使用できます。

また、SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品（たとえば、FeatureWorks）のライセンスを配布できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


マニュアル ダウンロード（Manual Download）

ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

リンクをクリックし、ダウンロードを完了するために必要なファイルの完全なリストを含む自動生成されたWebページを開きます。

サマリー ページで指定したフォルダーにダウンロードする必要があります。インストレーションは、すべてのファイルがフォルダーにダウンロードされるまで開始できません。

マニュアル ダウンロードを終えたら、次へ（Next）をクリックして続行します。

自動的にダウンロードしたい場合は、サマリー ページに戻ってダウンロード オプションを変更することでオプションを変更できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能なより新しいバージョン（Newer Version Available）

Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

DVDからインストールする場合（If You Are Installing from a DVD）

より新しいバージョンを使用しますか? (Would you like to use the newer version?) で以下のいずれかを選択します。
  • いいえ、この DVD からの version のインストールを継続します。 その後で更新することができます。（No, continue installing version from this DVD. You can update afterwards.）

    このオプションは、現在のInstallation Managerを使用してインストレーションを続行する場合に選択します。

    インストレーションが完了した後は、Installation Managerを使用してアップデートをチェックしてインストールすることができます。 アップデートをチェックするには、スタート（Start） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）を実行します。
    マシンの管理者権限を持つユーザーのみ、アップデート チェック（Check for Updates）を使用できます。

    この場合の利点は、ダウンロードが最小限になることです。 不利な点は、これが 2 ステップの過程になり、ダウンロードしたファイルが特定のバージョン用になる点です（他のバージョンを使用しているユーザーと共有はできません）。

  • はい、このDVDを使用してインストールを行います。続いて、ダウンロードして次までのアップデートを行います version（Yes, perform installation using this DVD, then download and update to version）

    SOLIDWORKS　製品の最新のバージョンをインストールするために、このオプションを選択し、最新のバージョンの Installation Manager をダウンロードして起動します。

    小さな ServicePack リリースを利用して DVD バージョンをアップデートできる場合、Installation Manager は DVD から元のバージョンをインストールし、次に ServicePack アップデートを適用します。 この結果、ダウンロード サイズが小さくなります。

    DVDからインストールを続行するオプションを選択してから、後日アップデートを適用しても同じ結果を得られます。

    このオプションの利点は、これが1ステップの過程であることです。

通常、完全なバージョンをDVDからインストールし、Installation Managerを使用して更新をチェックし、インストールすることが最小限のファイルをダウンロードする点で推奨されます。

ダウンロードからインストールする場合（If You Are Installing from a Download）

次のいずれかを選択します。
  • version のインストールを続行します。

    このオプションを選択し、初期のダウンロードに含まれるバージョンのインストールを続行します。

  • 新しいバージョンのダウンロードとインストール versionをクリックします。

    このオプションを選択すると、新しいバージョンをダウンロードしてインストールします。 もし複数の新しいバージョンがあるなら、ダウンロードしてインストールするバージョンを選択できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能な新しいバージョンはありません（No New Versions Available）

ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

インストレーションを続けるには次へ（Next）をクリックします。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


検出されたプロセス（Processes Detected）

SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • インストレーションを続行するには、以下のいずれかを行います。
    • 例えば、Microsoft Windowsタスク マネージャを使用してプロセスを終了してから、再試行（Retry）をクリックします。
    • 無視（Ignore）をクリックし、プロセスを終了しないまま続行します。
  • インストレーションを中止するには、キャンセル（Cancel）をクリックします。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品選択（Product Selection）

インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。

製品リストは以下のようになります。
  • 製品リストは、製品リスト上で指定されたパッケージで利用できる製品の完全なリストです。
  • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。 製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
  • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。 （たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
  • インストレーションの変更を行っている場合、製品選択で変更を行うとアスタリスク（*）がコンポーネントの左に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

ServicePack を適用している場合、SOLIDWORKS の下に表示される FeatureWorks などの SOLIDWORKS 機能は選択できません。 これは、このタイプの更新を行う時に、機能の追加/削除ができないためです。

SOLIDWORKS Installation Manage は製品の共存ルール（product coexistence rules）に従って機能します。 詳細は、製品の共存ルール（Product Coexistence Rules）を参照してください。

SOLIDWORKS Installation Manager は以下の製品をデフォルトで選択します。
  • アップグレードまたは SevicePack アップデートを実行している場合、SOLIDWORKS Installation Manager は現在インストールされている製品を選択します。
  • そうでない場合、SOLIDWORKS Installation Manager は権限のあるすべての製品を選択します。
インストレーションまたはダウンロードの時間と必要なディスク スペースを減らすために、製品コンポーネントを展開して不要なコンポーネントのチェック ボックスを選択解除します。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、別のパッケージ/製品の選択 をクリックしてインストールまたは変更する製品のパッケージ（たとえば、SOLIDWORKS Professional または SOLIDWORKS Premium など）のリストを変更できます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

SOLIDWORKS 検索

SOLIDWORKS 検索機能は、SOLIDWORKS ドキュメントと 3D ContentCentral の強力で完全なテキスト検索を提供します。 検索機能は、プレビューとファイルの場所と名前を示します。

インストレーションの後で、SOLIDWORKS 検索は、より速い検索のために SOLIDWORKS ドキュメントにインデックスを付けます。 デフォルトでは、SOLIDWORKS ファイルのインデックス ファイルのみが作成されます。

SOLIDWORKS 検索は Windows Desktop Search が既にコンピュータの上にインストールされていない場合、自動的にそれをインストールします。

言語サポート（Language Support）

SOLIDWORKS 製品と 言語 コンポーネントを展開し、インストール可能な言語版を表示します。

言語 仕様はインストールされる言語を SOLIDWORKS 製品についてのみ限定します。 その他の製品のインストレーションはこの仕様では影響されません。 たとえば、eDrawings®、SOLIDWORKS Explorer、および SOLIDWORKS PDM はすべての言語をインストールします。

必要なスペース（Space Needed）

SOLIDWORKS Installation Manager はページの一番下に合計のインストレーション サイズ、あるいは、合計のダウンロード サイズを表示します。

  • ダウンロードのみ オプションを選択した場合は、ダウンロード サイズ が表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。
    インストレーションに必要なすべてのファイルは合計のダウンロード サイズに含まれます。 もしいくつかのファイルが既に現在のダウンロードフォルダにダウンロードされている場合、それらは再びダウンロードされません。 結果として、実際のダウンロードサイズは表示された合計サイズより小さくなることがあります。または、まったくファイルのダウンロードが必要ないときもあります。
  • そうでない場合、インストレーション サイズ(installation size)が表示されます。 インストレーション サイズは、このインストレーションを完了したときに生じるディスク スペース使用量で変わります。 ファイル圧縮のため、これらの数字は推定です。

    既存のインストレーションをアップグレード、または削除する場合、インストレーション サイズは0（ゼロ）になります。

    表示される数字は、インストレーションに必要である場合もファイルをダウンロードする、または解凍するために必要なスペースを含みません。

    ダウンロードが必要で、同じドライブにダウンロードしている場合、実際に必要とされるディスク スペースは表示されるインストレーション サイズよりも著しく大きくなります。

    将来の更新作業でのダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
製品の共存ルール（Product Coexistence Rules）


ダウンロードする製品（Products to Download）

指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

ダウンロードで利用可能な製品は与えられたシリアルナンバーによって決まります：

  • 各コンポーネントに対して行われるアクションは、各項目の右側に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
  • 各コンポーネントの左にあるチェックボックスをクリックし、SOLIDWORKS Installation Manager が行う処理を指定します。
指定しない場合、SOLIDWORKS Installation Manager は使用権があるすべての製品のコンポーネントをダウンロードします。 ダウンロード時間と必要なディスク スペースを減らすために、製品コンポーネントを展開し、ダウンロードする必要のないコンポーネントを指定します。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、SOLIDWORKS パッケージをダウンロードするように選ぶことができます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての SOLIDWORKS 製品をリストします。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、別のパッケージ/製品の選択 をクリックしてインストールまたは変更する製品のパッケージ（たとえば、SOLIDWORKS Professional または SOLIDWORKS Premium など）のリストを変更できます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

言語サポート（Language Support）

言語 (Languages)仕様はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションはこの仕様では影響されません。 たとえば、eDrawings®、SOLIDWORKS Explorer ではすべての言語版がインストールされます。

必要なスペース（Space Needed）

選択する製品に基づいて、ダウンロードを行なうために必要なスペースが表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。

将来の更新やパッチを当てる作業でダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


修復する製品（Products to Repair）

このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。

修復（Repair）をクリックし、選択した製品の修復を開始します。

個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを再インストールする必要があります。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


シリアル番号（Serial Numbers）

シリアル番号 (パッケージ上にあります) は、購入した SOLIDWORKS 製品をご使用のコンピュータに関連付けます。

既にインストールされている SOLIDWORKS 製品のシリアル番号は、デフォルトで表示されます。
  • シリアル番号が表示されていない場合は、SOLIDWORKS シリアル番号を入力します。
  • SOLIDWORKS ライセンスに含まれていない製品のシリアル番号がある場合は、適切なフィールドに入力します。
  • SOLIDWORKS 管理者が SOLIDWORKS 管理ポータルで製品を割り当てた場合は、ページ上部のログイン機能を使用して、割り当てられたシリアル番号を自動的に入力することができます。

インターネットに接続している場合、入力したシリアル番号はインストレーション プロセスを続ける際に権限のある製品を決定します。

SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


サーバー インストール（Server Installation）

インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

サーバー インストレーション ステータス（Server Installation Status）

サーバー製品のインストレーションは、外部インストレーション アプリケーションによって実行されます。このアプリケーションを開いていない場合はインストレーションを完了するため、このアプリケーションに切り替える必要があります。

サーバー製品のインストレーションを中止するには、キャンセル（Cancel）をクリックします。

サーバー インストレーション完了（Server Installation Complete）

外部インストレーション アプリケーションは正常に終了しました。

終了 あるいは 次へをクリックします。
  • その他のアドミニストレーティブ製品をインストールする場合（たとえば、SOLIDWORKS アドミニストレーティブ イメージ）、そのインストレーションが続きます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。

サーバー インストレーションのキャンセルまたは失敗（Server Installation Cancelled or Failed）

サーバー製品のインストレーションに失敗したか、または開始後にキャンセルされた場合、インストールが完了しなかったサーバーがリストに表示されます。

閉じる あるいは 次へをクリックします。
  • 別のアドミニストレーティブ製品のインストレーションが指定されている場合、SOLIDWORKS Installation Manager は再開されます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SolidNetWork License Manager

SolidNetWork License Managerサーバー製品のインストール オプションを指定します。

シリアル番号（Serial numbers）

SolidNetWork Licenseのシリアル番号を指定します。 複数のシリアル番号をカンマで区切って入力できます。
SolidNetWork シリアル番号は SOLIDWORKS シリアル番号とは異なります。

インストレーション先

SolidNetWork License Managerをインストールする場所を指定します。

既存のSolidNetWork License Managerを更新する場合、既存のインストレーション場所にインストールする必要があります。

詳細情報

SolidNetWork License Manager のインストール、設定、使用の詳細については、SolidNetWork License Manager を使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）を参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


サマリー（Summary）

SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

続行するには: | アクション 今すぐ ボタンをクリックしてインストレーション作業を開始します（たとえば、今すぐインストール、今すぐ作成、今すぐダウンロード、今すぐ変更）。
インストレーション設定を変更するには: | 変更したいセクションに対して変更 [image] をクリックします（たとえば、製品、インストール先、Toolbox オプション）。
キャンセルするには: | インストレーション コンポーネントを変更せずに SOLIDWORKS Installation Manager を終了するには、キャンセルをクリックします。
前のページに戻るには: | SOLIDWORKS Installation Manager の前のページに戻るには、戻るをクリックします。
特定のインストレーション オプション セット（たとえば、製品、インストール先、Toolbox オプション など）の情報については、以下を行います。
  1. 情報を希望するセクションの横にある変更 [image] をクリックします。
  2. 表示される詳細ページでヘルプをクリックし、これらのインストレーション オプションの設定に関する情報を入手します。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


システム チェックの警告（System Check Warnings）

システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

下記にこの段階で遭遇する可能性のある警告を解決方法と共に一覧します。

シリアル番号検証に関する問題

シリアル番号の検証ができなかったので、InstallationManagerは新しいバージョンをチェックすることができませんでした。 接続しており、正しいシリアル番号を入力している場合は、ご使用のサーバーの一時的な問題である可能性があります。 後でまた試してみてください。

シリアル番号認証: InstallationManager は使用権をお持ちの製品を自動的に確定するために必要なシリアル番号の認証ができませんでした。インストールする製品を選ぶことはできますが、インストレーション ファイルをダウンロードすることはできません。インストールするためにはダウンロード ソース ファイルの全セットか DVD が必要です。

解決策:
  • インターネットの接続を確認してください。シリアル番号のチェックには、有効なインターネット接続が必要です。
  • 入力したシリアル番号が、インストールを試みている製品に対して正しいことを確認してください。
  • 一部のインストールでは、バージョンのリリース時に適切な契約を交わす必要があります。 詳細は、SOLIDWORKS 代理店までお問い合わせください。
  • 大部分のケースでは、DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

より新しいバージョンの存在

利用可能なより新しいバージョン

利用可能な新しいバージョン

製品のより新しいバージョンをダウンロードして利用できます。

解決策: アップデート チェックの実行時には、SOLIDWORKS からのダウンロードにより利用可能な新しいバージョンのインストールを促される場合があります。 この処理は最初に指定したバージョンを用い継続することも、あるいは利用可能なより新しいバージョンをダウンロードし、そのバージョンを用いて継続することも可能です。

最新バージョンの存在

これはご利用可能な最新のバージョンです。「次へ」をｸﾘｯｸして続行してください。

利用可能な新しいﾀﾞｳﾝﾛｰﾄﾞはありません

解決策:このメッセージには、インストールや変更の間、アップデートをチェックしている際に遭遇する可能性があります。このメッセージは、利用可能な最新バージョンをインストール中であること、あるいは最新バージョンが既にインストール済みであることを示すものです。

インターネット接続に関する問題

インターネット接続: InstallationManager は使用権をお持ちの製品を確定するために必要な SOLIDWORKS サーバーへ接続できませんでした。 インストールを行う製品を選択することは可能ですが、しかしインストレーションファイルをダウンロードすることはできません。 ソース ファイルの DVD あるいは以前にダウンロードしたファイル セットが必要です。

新しいバージョンをチェックすることができません

サーバーに接続することができなかったので、InstallationManager は新しいバージョンをチェックすることができませんでした。

解決策:
  • インターネットの接続を確認してください。
  • DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

SOLIDWORKS Toolbox がインストールされている場合、SOLIDWORKS は穴タイプと汎用部品の標準ライブラリを含みます。

SOLIDWORKS Toolbox の設定、拡張、使用の詳細は、SOLIDWORKS で ヘルプ (Help) > Toolbox ヘルプ (Toolbox Help) をクリックします。
このヘルプを表示するには、ツール > アドインを使用してToolboxアドインを開始する必要があります。

SOLIDWORKS Toolbox を使用する前に、企業やグループのポリシーに従って適切に設定されていることを確認します。 ほとんどの場合は、グループが中央 Toolbox を設定および管理します。 SOLIDWORKS のインストレーション中に Toolbox を指定する方法のガイダンスについては、SOLIDWORKS 管理者に確認してください。

選択した SOLIDWORKS Toolbox は、インストレーション後に変更できます。 SOLIDWORKS で ツール (Tools) > オプション (Options) をクリックします。 システム オプション タブの 穴ウィザード/Toolbox (Hole Wizard/Toolbox) をクリックします。

次のセクションでは、あらゆる設定に対して画面に表示されるすべてのオプションについて説明します。 実際に表示される Toolbox オプションは、コンピュータにある既存の SOLIDWORKS と Toolbox の設定、および、これまでに指定した SOLIDWORKS Installation Manager の選択内容によって異なります。

新しいnew-version Toolboxの作成（Create a new new-version Toolbox）

このコンピュータで SOLIDWORKS Toolbox の新しいバージョンを作成します。

[製品選択 (Product Selection)] 画面で新しいバージョンを作成する場合、SOLIDWORKS > SOLIDWORKS Toolbox の順に展開し、Toolbox に対してどの規格をサポートするか選択します。 デフォルトでは、すべての規格が選択されます。

このコンピュータにある既存のToolboxは、いっさい変更されません。

既存のToolboxの参照またはアップグレード（Reference or upgrade an existing Toolbox）

既存のToolboxを使用します。 参照（Browse）をクリックし、このインストレーションで使用する Toolbox の位置を指定します。

  • Toolbox が以前の SOLIDWORKS メジャー リリース バージョン用に設定されている場合は、現在のバージョンにアップグレードされます。 前のToolboxに対して行われたユーザー定義はすべて、アップグレードされたToolboxでも保持されます。
    Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。
  • Toolbox が現在の SOLIDWORKS バージョン用に設定されている場合（既にアップグレードされた共有ネットワーク Toolbox を指定した場合）、その Toolbox に対するアップグレードは行われません。
  • SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

このオプションは、アドミニストレーティブ イメージの作成を除く、すべてのインストレーション シナリオで表示されます。

previous-version Toolboxのアップグレード（Upgrade a previous-version Toolbox）

以前のメジャー リリース バージョン用に設定されたToolboxを新しい位置にコピーし、このコピーを現在のバージョンにアップグレードします。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、そのインストレーションを現在のリリースにアップグレードしないことを選択した場合に表示されます。
このオプションの目的は、古いバージョンの Toolbox を使用しているユーザーに影響を与えずに、以前の SOLIDWORKS メジャー リリース バージョン用の Toolbox をアップグレードすることです。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている previous-version Toolbox のアップグレード（Upgrade this installed previous-version Toolbox）

より新しいバージョンにToolboxをアップグレードします。
Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンを現在のバージョンにアップグレードする際に、以前のリリース用に設定された Toolbox がコンピュータ上で見つかった場合に表示されます。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている current-version Toolbox の使用（Use the installed current-version Toolbox）

SOLIDWORKS Installation Manager は、このコンピュータ上に現在の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox があることを検出しました。

このオプションを選択すると、SOLIDWORKS はこの Toolbox を使用します。 アップグレードは行われません。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、Toolbox は現在のバージョン用に設定されている場合に表示されます。 このような状況は、古い SOLIDWORKS バージョンを実行し続けているコンピュータに共有 Toolbox が作成された場合に生じる可能性があります。

クライアント コンピュータのToolbox位置を指定（Specify the Toolbox location for the client computer）

アドミニストレーティブ イメージからのクライアント インストール時に、デフォルトの Toolbox 位置としてネットワークまたはディレクトリ位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

このオプションは、新しいアドミニストレーティブ イメージを作成するときに表示されます。

クライアント コンピュータ用に、アップグレードするか、既存のイメージで参照されているToolboxを使用します（Upgrade or use the Toolbox referenced in the existing image for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたToolbox位置を使用します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

クライアント コンピュータ用に別のToolbox位置を選択します（Select a different Toolbox location for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたものとは異なる Toolbox 位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

目次

  • SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

    SOLIDWORKS Toolbox は、強力かつ複雑な機能です。 ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。

  • UNCフォーマット（UNC Format）

    UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox は、強力かつ複雑な機能です。 ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。

SOLIDWORKS Toolbox の詳細情報（Finding More Information About SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox の設定、拡張、使用の詳細は、SOLIDWORKS の ヘルプ > Toolbox ヘルプ をクリックしてください。
このヘルプを表示するには、ツール > アドインを使用して Toolbox アドインを開始する必要があります。

共有Toolboxの使用（Using a Shared Toolbox）

Toolbox をインストールするとき、ローカルコンピュータ上、あるいは共有されたネットワーク上でToolbox データを持つことができます。 Toolbox データをネットワーク上に保管することが推奨されます。 共通の場所を使うことによって、すべての SOLIDWORKS ユーザーは一貫したファスナー情報を共有します。

今回が最初のインストールである場合、Toolbox をインストールする新しい共有された場所を参照してください。

既存のToolboxのアップグレード（Upgrading an Existing Toolbox）

Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

他のコンピュータが以前のメジャー リリースのままであり、以前のリリース用に設定されたToolboxを必要とする場合は、このToolboxのコピーを作成し、そのコピーをアップグレードするべきです。 新規の SOLIDWORKS インストレーションは Toolbox のコピーをアップグレードし、以前の SOLIDWORKS インストレーションは古い Toolbox を使用し続けます。

Toolboxアクセスの設定（Configuring Toolbox Access）

インストレーション後に、Toolbox コンポーネントにアクセスするとき、SOLIDWORKS はどのように Toolbox を配置したかをチェックし、アクセスとパフォーマンスを改善するために提案をします。

共有ネットワークToolbox（推奨）にアクセスする場合、共有Toolboxのインストールされたサーバーに対するUNCパスを使用します。 詳細は、UNC フォーマット（UNC Format）を参照してください。

アドミニストレータ（管理者）はToolboxのパスワードを作成し、ワークグループの権限と優先権を設定できます。コンフィギュレーションへのアクセスを限定することと、共通の優先権を設定することは安定した Toolbox データを保証します。

SOLIDWORKS PDM 環境での Toolbox のアップグレード

SOLIDWORKS ソフトウェアをアップグレードする際、Toolbox に部品が追加されていれば Toolbox もアップグレードされます。 Toolbox ルート フォルダが SOLIDWORKS PDM ボルト内にある場合、SOLIDWORKS のアップグレードを開始する前に、Toolbox フォルダの準備をする必要があります。

アップグレードを行う最初のシステムで、最新バージョンの取得 を使用して Toolbox ファイルをローカル キャッシュにダウンロードし、Toolbox データベースをチェックアウトする必要があります。 アップグレードする他のシステムでは、Toolboxファイルをダウンロードするだけです。

アップグレードをはじめる前に:
  • ボルト データベースの最新のフルバックアップおよびアーカイブが存在することを確認します。
  • Toolbox 部品がチェックアウトされておらず、現在チェックアウトされているいずれのアセンブリでも使用されていないことを確認します。

Toolbox をアップグレードするには:

  1. Windows エクスプローラで、全権限（チェックアウト、チェックイン、追加、削除）を持つユーザーとしてボルトにログインします。
  2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして、すべての Toolbox ファイルおよび Toolbox データベースをローカル キャッシュにコピーします。
    アーカイブ サーバーがリモートの場合、この操作には数分かかることがあります。
  3. Toolbox データベース ファイル（SWBrowser.mdb）を \Toolbox_folder_name\lang\your_lang からチェックアウトします。
  4. SOLIDWORKS Installation Manager を実行してアップグレードを行います。
  5. サマリー画面で、Toolbox オプションのインストレーションの位置がボルトにあることを確認します。

    無い場合は、変更をクリックし、既存の Toolbox の参照またはアップグレードを選択し、ボルトの Toolbox 位置を参照します。

  6. アップグレードが完了した後、Windows エクスプローラで、新しい、または更新されたファイルをボルトへ追加するために Toolbox フォルダをチェックインし、他のユーザーが Toolbox を操作できるようにします。
  7. SOLIDWORKS 2012 またはそれ以降へのアップグレードでは、ボルトの Toolbox フォルダに移動して、次のフォルダおよびファイルがあることを確認します。
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      無い場合は、お客様の代理店までご連絡ください。

  8. Toolbox と SOLIDWORKS PDM 統合を使用する残りのコンピュータをアップグレードします。
    1. Windows エクスプローラで、少なくとも Toolbox フォルダに対する読み取り権限を持つユーザーとしてボルトにログインします。
    2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして Toolbox ファイルをローカル キャッシュにコピーします。
    3. SOLIDWORKS Installation Manager を実行してアップグレードを行います。

      Toolbox が既にアップグレードされていることが、インストーラによって検出されます。

SOLIDWORKS PDM における Toolbox コンフィギュレーションに関する詳細は、 SOLIDWORKS PDM アドミニストレーション ツール ヘルプの Toolbox の設定 を参照してください。

親トピック 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
関連資料
UNCフォーマット（UNC Format）


UNCフォーマット（UNC Format）

UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

\\サーバー\ボリューム\パス

例えば:

\\Disk_Server\SOLIDWORKS\AdminImage

親トピック 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
関連概念
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


製品のアンインストール（Uninstall Products）

削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

一般的なアンインストールでは、SOLIDWORKS 製品のプログラム ファイルとフォルダが削除されます。 デフォルトで、選択したリリースのすべての SOLIDWORKS 製品のアンインストールが指定されます。

カスタム インストールでは、次のアイテムのいくつかを削除できます: プログラム ファイルとフォルダ、レジストリ キー、SOLIDWORKS Toolbox などのデータ フォルダ、元のダウンロード位置からのファイルとフォルダ。

完全なアンインストールではインストール ディレクトリ、レジストリ キー、データ フォルダが削除されます。

製品をアンインストールするには:
  1. アンインストール（Uninstall）の画面で、製品が選択されていることを確認してください。

    すべての製品をアンインストールすると、Solidworks Installation Manager もアンインストールされます。

  2. 削除したくない製品を選択解除します。

    1 つでも製品を保持すると、SOLIDWORKS Installation Manager も削除されません。

  3. カスタム アンインストールか完全なアンインストールを選択します。
    1. 変更（Change）を詳細設定オプション（Advanced Options）でクリックします。

      詳細設定オプション(Advanced Options)画面が表示されます。 プログラム ファイルとフォルダのオプションが選択されています。

    2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
    3. サマリーに戻る（Back to Summary）をクリックします。
    4. サマリー（Summary）の画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法を表示します。
  4. アイテムを削除 をクリックします。
アイテムを削除 (Remove Items) をクリックすると、SOLIDWORKS Installation Manager は直ちに製品の削除を開始します。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


著作権に関する注意書き

© 1995-2018, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

本ドキュメントに記載されている情報とソフトウェアは予告なく変更されることがあり、Dassault Systemes SolidWorks Corporation (DS SolidWorks) の保証事項ではありません。

この製品を DS SolidWorks の書面上の許可なしにその目的、方法に関わりなく複製、頒布はできません。

本ドキュメントに記載されているソフトウェアは使用許諾に基づくものであり、当該使用許諾の条件の下でのみ使用あるいは複製が許可されています。 DS SolidWorks がソフトウェアとドキュメントに関して付与するすべての保証は、ライセンス契約書に規定されており、本ドキュメントまたはその内容に記載、あるいは黙示されているいかなる事項もそれらの保証、その変更あるいは補完を意味するものではありません。

特許

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028; 8,910,078; 9,129,083; 9,153,072; 9,262,863; 9,465,894; 9,646,412; 9,870,436; 10,055,083; 10,073,600 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

SOLIDWORKS 製品とサービスの商標と製品名

SOLIDWORKS、3D ContentCentral、3D PartStream.NET、eDrawings、eDrawings のロゴは DS SOLIDWORKS の登録商標です。FeatureManager DS SOLIDWORKS が共同所有する登録商標です。

CircuitWorks、FloXpress、PhotoView 360、TolAnalyst は DS SolidWorks の商標です。

FeatureWorks は、HCL Technologies Ltd. の登録商標です。

SOLIDWORKS 2019、SOLIDWORKS Standard、SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS PDM Professional、SOLIDWORKS PDM Standard、SOLIDWORKS Simulation Standard、SOLIDWORKS Simulation Professional、SOLIDWORKS Simulation Premium、SOLIDWORKS Flow Simulation、SOLIDWORKS CAM、SOLIDWORKS Manage、eDrawings Viewer、eDrawings Professional、SOLIDWORKS Sustainability、SOLIDWORKS Plastics、SOLIDWORKS Electrical Schematic Standard、SOLIDWORKS Electrical Schematic Professional、SOLIDWORKS Electrical 3D、SOLIDWORKS Electrical Professional、CircuitWorks、SOLIDWORKS Composer、SOLIDWORKS Inspection、SOLIDWORKS MBD、SOLIDWORKS PCB powered by Altium、SOLIDWORKS PCB Connector powered by Altium、SOLIDWORKS Visualize は、DS SolidWorks の製品名です。

その他、記載されているブランド名、製品名は各社の商標及び登録商標です。

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

本ソフトウェアは、48 C.F.R. 2.101 （OCT 1995） に定義されている「商用品」であり、48 C.F.R. 12.212 （SEPT 1995） で使用されている「商用コンピュータ ソフトウェア」および「商用コンピュータ ソフトウェア ドキュメンテーション」で構成されます。本ソフトウェアは、（a） 48 C.F.R. 12.212 に規定された政策に従って、民間機関による、またはそれに代わる取得のため、あるいは （b） 48 C.F.R. 227.7202-1 （JUN 1995） および 227.7202-4 （JUN 1995） に既定された政策に従って、国防総省の一部門による、またはそれに代わる取得のために、米国政府に対して提供されます。

米国政府機関から、上記の規定を超える権利と共にソフトウェアを提供するように要求された場合は、DS SolidWorks にその要求の範囲を通知するものとします。DS SolidWorks は、5 営業日以内に、独自の判断により、そのような要求を受け入れるか拒絶するかを決定します。 Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

SOLIDWORKS Standard、Premium、Professional、Education 製品における著作権

Portions of this software © 1986-2018 Siemens Product Lifecycle Management Software Inc. All rights reserved.

この製品には、Siemens Industry Software Limited が所有する、次のソフトウェアが含まれています。

D-Cubed® 2D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® 3D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® PGM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® CDM © 2018. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® AEM © 2018. Siemens Industry Software Limited. All Rights Reserved.

Portions of this software © 1998-2018 HCL Technologies Ltd.

本ソフトウェアの一部は NVIDIA 2006-2010 による PhysX™ が含まれています。

Portions of this software © 2001-2018 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2018 DriveWorks Ltd.

(c) 2011, Microsoft Corporation. All rights reserved.

Adobe® PDF Library テクノロジーを含みます。

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe、Adobeのロゴ、Acrobat、Adobe PDFのロゴ、Distiller、Reader は米国およびその他の国において Adobe Systems Inc. の登録商標または商標です。

DS SolidWorks の詳細な著作権情報については、ヘルプ（Help） > SOLIDWORKS について（About SOLIDWORKS）を参照してください。

SOLIDWORKS Simulation 製品における著作権

Portions of this software (c) 2008, Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights reserved.

SOLIDWORKS PDM Professional 製品における著作権

Outside In® Viewer Technology, © 1992-2012 Oracle

（c） 2011, Microsoft Corporation. All rights reserved.

eDrawings 製品における著作権

Portions of this software © 2000-2014 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2017 Open Design Alliance. All rights reserved.

eDrawings® for Windows® ソフトウェアは部分的に Independent JPEG Group の研究に依存しています。

Portions of eDrawings® for iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.

Portions of eDrawings® for iPad® copyright © 2003 – 2005 Apple Computer Inc.

SOLIDWORKS PCB 製品における著作権

Portions of this software © 2017-2018 Altium Limited.

SOLIDWORKS Visualize 製品における著作権表示

NVIDIA Corporation のライセンスに基づいて提供される NVIDIA GameWorks ™ テクノロジー。 Copyright (C) 2002-2015 NVIDIA Corporation. All rights reserved.


アドミニストレーティブ イメージ オプション エディタ

SOLIDWORKS アドミニストレーティブ イメージ オプション エディタが改善されました。

  • 管理者は完全アンインストールまたはカスタム アンインストールをクライアント コンピュータ上で実行する新しいアンインストール オプションを使用できます。アンインストール オプションは、オプション エディタのクライアント インストール オプション (Client Installation Options) セクションにあります。オプションを表示するには、はい、カスタム インストールを実行します (Yes, perform a custom uninstall) をクリックし、削除対象の項目を選択します。
  • 管理者はまた、SOLIDWORKS Toolbox の標準をリストから事前に選択できます。


SOLIDWORKS PDM

SOLIDWORKS PDM は、以前 SOLIDWORKS Enterprise PDM と呼ばれていたクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。

SOLIDWORKS PDM には次の 2 種類があります。
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

この表には、各製品で使用できるデータベース システム、サーバー コンポーネント、およびクライアント オプションがリストされています。
 | PDM Standard | PDM Professional
設計対象 | 小規模～中規模のオフィス ネットワーク（一般的に 20 以下の同時ユーザー）。 | 大規模オフィス ネットワーク（多数の同時ユーザー）
制限 | 1 ソケットまたは 4 コア（どちらか少ない方）、1 GB RAM、10 GB データベース サイズ | SQL Standard の制限: 4 ソケットまたは 16 コア（どちらか少ない方）、128 GB RAM、524 PB データベース サイズ
データベース管理システム | Microsoft SQL Server Express 2014（SOLIDWORKS に含まれており、一緒にインストールされます） | Microsoft SQL Server 2014（SOLIDWORKS とは別途）、または前もってインストールされた Microsoft SQL Server 2014、または 2012。
SolidNetWork License Manager が必要ですか? | はい | はい
アーカイブ サーバーとデータベース サーバーが含まれていますか? | はい | はい
SOLIDWORKS PDM Web サーバー、Web2 サーバー、および Web API サーバーが含まれていますか。 | いいえ | はい
クライアント タイプ | ネイティブ | ネイティブ、ブラウザ ベース
CAD Editors 向けクライアント アドイン | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office Integration、Autodesk Inventor、AutoCAD
Contributors 向けクライアント アドイン | DraftSight | DraftSight、Microsoft Office Integration
Viewers 向けクライアント アドイン |  | Microsoft Office との統合


Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント

Windows 8 （以降）のユーザー インタフェースは以前のバージョンの Windows とは大幅に異なっています。 ナビゲーションの方法が異なるだけでなく、主なコマンドにアクセスするための手段が複数追加されています。

以下のトピックでは、Windows 8 の最も基本的な 3 つの機能にアクセスする方法について説明します。Windows 8 を使用して SOLIDWORKS をインストールするときは、以下のトピックを参照してください。
これらの手順は、Windows システムの構成方法によって異なる場合があります。 特に、Windows 8 よりも後のシステムの場合、追加の指示とオプションについて Microsoft Windows のドキュメントを確認してください。
関連概念
個人コンピュータでのインストール（Installation on Individual Computers）