FTDI.D2xx.WinRT Namespace

Classes

 | Class | Description
Public class | FTManager | Management class for connected FTDI devices. Allows you to enumerate and communicate with connected FTDI devices.
Copyright © 2014 - Future Technology Devices International Ltd.


FTManager Class

Management class for connected FTDI devices. Allows you to enumerate and communicate with connected FTDI devices.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FTManager
Public NotInheritable Class FTManager
public ref class FTManager sealed

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT..::..FTManager

See Also

FTManager Members
FTDI.D2xx.WinRT Namespace


FTManager Members

The FTManager type exposes the following members.

Constructors

 | Name | Description
Public method | FTManager | Default constructor for FTManager class.

Methods

 | Name | Description
 | AddVIDPID | Add a custom vendor ID/product ID combination to the list of allowed devices.
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetDeviceList | Returns a list of FTDI devices connected to the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
 | GetLibraryVersion | Returns the version string of this library.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | OpenByDescription | Open a handle to the specified FTDI device.
Public method | OpenByDeviceID | Open a handle to the specified FTDI device.
Public method | OpenBySerialNumber | Open a handle to the specified FTDI device.
 | RemoveVIDPID | Remove a custom vendor ID/product ID combination from the list of allowed devices.
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


FTManager Constructor

Default constructor for FTManager class.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public FTManager()
Public Sub New
public:
FTManager()

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


FTManager Methods

The FTManager type exposes the following members.

Methods

 | Name | Description
 | AddVIDPID | Add a custom vendor ID/product ID combination to the list of allowed devices.
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetDeviceList | Returns a list of FTDI devices connected to the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
 | GetLibraryVersion | Returns the version string of this library.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | OpenByDescription | Open a handle to the specified FTDI device.
Public method | OpenByDeviceID | Open a handle to the specified FTDI device.
Public method | OpenBySerialNumber | Open a handle to the specified FTDI device.
 | RemoveVIDPID | Remove a custom vendor ID/product ID combination from the list of allowed devices.
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


AddVIDPID Method

FTDI D2xx WinRT Driver

FTManager..::..AddVIDPID Method

Add a custom vendor ID/product ID combination to the list of allowed devices.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public static bool AddVIDPID(
    uint vendorId,
    uint productId
)
Public Shared Function AddVIDPID ( _
    vendorId As UInteger, _
    productId As UInteger _
) As System.Boolean
public:
static bool^ AddVIDPID(
    unsigned int^ vendorId,
    unsigned int^ productId
)

Parameters

vendorId
Type: System.UInt32
Device Vendor ID.
productId
Type: System.UInt32
Device Product ID.

Return Value

True on success, false if the vendor ID/product ID combination is already in the list.

Examples

This example shows how to add a custom VID and PID to the driver list.
C#
uint myVid = 0x1234;
uint myPid = 0x4321;

FTManager.AddVIDPID(myVid, myPid);
FTManager ftManager = new FTManager();

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


GetDeviceList Method

FTManager..::..GetDeviceList Method

Returns a list of FTDI devices connected to the system.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public System.Collections.Generic.IList`1<IFTDeviceInfoNode> GetDeviceList()
Public Function GetDeviceList As System.Collections.Generic.IList`1(Of IFTDeviceInfoNode)
public:
System.Collections.Generic.IList`1<IFTDeviceInfoNode^>^ GetDeviceList()

Return Value

IList containing FTDeviceInfoNodes.

Examples

This example shows how to access an FTDI device using the FTManager class.
C#
FTManager ftManager = new FTManager();
var deviceList = ftManager.GetDeviceList();

if (deviceList.Count > 0)
{
    byte[] data = new byte[10];
    // Open a handle to the device.
    IFTDevice ftDevice = ftManager.OpenByDeviceID(deviceList[0].DeviceId);

    await ftDevice.SetBaudRate(9600);
    await ftDevice.SetFlowControl(FLOW_CONTROL.RTS_CTS, 0, 0);
    // Write/Read some data.
    await ftDevice.Write(data, 10);
    ftDevice.Read(data, 10);
    // Close the device handle.
    ftDevice.Close();
}

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


GetLibraryVersion Method

FTManager..::..GetLibraryVersion Method

Returns the version string of this library.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public static string GetLibraryVersion()
Public Shared Function GetLibraryVersion As System.String
public:
static System.String^ GetLibraryVersion()

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


OpenByDescription Method

FTManager..::..OpenByDescription Method

Open a handle to the specified FTDI device.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public IFTDevice OpenByDescription(
    string description
)
Public Function OpenByDescription ( _
    description As System.String _
) As IFTDevice
public:
IFTDevice^ OpenByDescription(
    System.String^ description
)

Parameters

description
Type: System.String
Device Descriptor for the device to be opened.

Return Value

The open FTDI device on success, null otherwise.

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


OpenByDeviceID Method

FTManager..::..OpenByDeviceID Method

Open a handle to the specified FTDI device.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public IFTDevice OpenByDeviceID(
    string id
)
Public Function OpenByDeviceID ( _
    id As System.String _
) As IFTDevice
public:
IFTDevice^ OpenByDeviceID(
    System.String^ id
)

Parameters

id
Type: System.String
Unique ID of the deivce to be opened.

Return Value

An open FTDI device on success, null otherwise.

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


OpenBySerialNumber Method

FTManager..::..OpenBySerialNumber Method

Open a handle to the specified FTDI device.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public IFTDevice OpenBySerialNumber(
    string serialNumber
)
Public Function OpenBySerialNumber ( _
    serialNumber As System.String _
) As IFTDevice
public:
IFTDevice^ OpenBySerialNumber(
    System.String^ serialNumber
)

Parameters

serialNumber
Type: System.String
Serial Number for the device to be opened.

Return Value

The open FTDI device on success, null otherwise.

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


RemoveVIDPID Method

FTManager..::..RemoveVIDPID Method

Remove a custom vendor ID/product ID combination from the list of allowed devices.

Namespace: FTDI.D2xx.WinRT
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public static bool RemoveVIDPID(
    uint vendorId,
    uint productId
)
Public Shared Function RemoveVIDPID ( _
    vendorId As UInteger, _
    productId As UInteger _
) As System.Boolean
public:
static bool^ RemoveVIDPID(
    unsigned int^ vendorId,
    unsigned int^ productId
)

Parameters

vendorId
Type: System.UInt32
Device Vendor ID.
productId
Type: System.UInt32
Device Product ID.

Return Value

True on success, false if the vendor ID/product ID combination was not found in the list.

Examples

This example shows how to remove a standard FTDI VID and PID from the driver list.
C#
uint rDeviceVid = 0x0403;
uint rDevicePid = 0x6001;

FTManager.RemoveVIDPID(rDeviceVid, rDevicePid);
FTManager ftManager = new FTManager();

See Also

FTManager Class
FTDI.D2xx.WinRT Namespace


FTDI.D2xx.WinRT.Device Namespace

Interfaces

 | Interface | Description
Public interface | IChipId | Interface providing details of the FTDI Chip-ID number. Applies only to FT232R, FT245R and FT X-Series devices.
Public interface | IFTDevice | Interface representing an FTDI device connected to the system, containing methods for communicating with the device.
Public interface | IFTDeviceInfoNode | Interface providing details of an FTDI device connected to the system.

Enumerations

 | Enumeration | Description
Public enumeration | BIT_MODE | FTDI bit modes.
Public enumeration | DEVICE_TYPE | FTDI device types.
Public enumeration | FLOW_CONTROL | UART flow control.
Public enumeration | PARITY | UART parity bits.
Public enumeration | STOP_BITS | UART stop bits.
Public enumeration | WORD_LENGTH | UART word length.


BIT_MODE Enumeration

FTDI bit modes.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum BIT_MODE
Public Enumeration BIT_MODE
public enum class BIT_MODE

Members

Member name | Description
RESET | Reset bit mode (off).
ASYNC_BITBANG | Asynchronous bit bang.
MPSSE | MPSSE (FT2232D, FT2232H, FT4232H and FT232H only).
SYNC_BITBANG | Synchronous bit bang (FT2232D, FT232R, FT4232H, FT232H and FT X-Series only).
MCU_HOST | MPSSE CPU emulation (FT2232D, FT2232H, FT4232H and FT232H only).
FAST_SERIAL | Fast serial mode (FT2232D, FT2232H and FT232H only).
CBUS_BITBANG | CBus bit bang (FT232R, FT232H and FT X-Series only).
SYNC_FIFO | Single channel synchronous FIFO (FT2232H port A and FT232H only).

See Also

FTDI.D2xx.WinRT.Device Namespace


DEVICE_TYPE Enumeration

FTDI device types.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DEVICE_TYPE
Public Enumeration DEVICE_TYPE
public enum class DEVICE_TYPE

Members

Member name | Description
FT232AM | FT232AM device (single channel full speed).
FT232BM | FT232BM device (single channel full speed).
FT2232D | FT2232D device (dual channel full speed).
FT232R | FT232R device (single channel full speed).
FT245R | FT245R device (single channel full speed).
FT2232H | FT2232H device (dual channel high speed).
FT4232H | FT4232H device (quad channel high speed).
FT232H | FT232H device (single channel high speed).
FTXSeries | FT X-Series device (single channel full speed).

See Also

FTDI.D2xx.WinRT.Device Namespace


FLOW_CONTROL Enumeration

UART flow control.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum FLOW_CONTROL
Public Enumeration FLOW_CONTROL
public enum class FLOW_CONTROL

Members

Member name | Description
NONE | No flow control.
RTS_CTS | RTS/CTS hardware flow control.
DTR_DSR | DTR/DSR hardware flow control.
XON_XOFF | XON/XOFF software flow control.

See Also

FTDI.D2xx.WinRT.Device Namespace


IChipId Interface

Interface providing details of the FTDI Chip-ID number. Applies only to FT232R, FT245R and FT X-Series devices.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public interface IChipId
Public Interface IChipId
public interface class IChipId

See Also

IChipId Members
FTDI.D2xx.WinRT.Device Namespace


IChipId Members

The IChipId type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetId | Return the unique FTDI Chip-ID number for this device.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

IChipId Interface
FTDI.D2xx.WinRT.Device Namespace


IChipId Methods

The IChipId type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetId | Return the unique FTDI Chip-ID number for this device.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

IChipId Interface
FTDI.D2xx.WinRT.Device Namespace


GetId Method

IChipId..::..GetId Method

Return the unique FTDI Chip-ID number for this device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<uint> GetId()
Function GetId As IAsyncOperation(Of UInteger)
IAsyncOperation<unsigned int^>^ GetId()

See Also

IChipId Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDevice Interface

Interface representing an FTDI device connected to the system, containing methods for communicating with the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public interface IFTDevice
Public Interface IFTDevice
public interface class IFTDevice

See Also

IFTDevice Members
FTDI.D2xx.WinRT.Device Namespace


IFTDevice Members

The IFTDevice type exposes the following members.

Methods

 | Name | Description
Public method | ClearDtrAsync | Clears the Data Terminal Ready (DTR) control signal.
Public method | ClearRtsAsync | Clears the Request To Send (RTS) control signal.
Public method | Close | Closes the handle to the current IFTDevice.
Public method | EepromEraseAsync | Erases the device's EEPROM contents. Not applicable to FT232R, FT245R and X-Series devices.
Public method | EepromGetUserAreaSizeAsync | Gets the available size of the EEPROM user area.
Public method | EepromProgramAsync | Program the contents of the device EEPROM.
Public method | EepromReadAsync | Read the contents of the device EEPROM.
Public method | EepromReadUserAreaAsync | Reads the contents of the EEPROM user area.
Public method | EepromReadWordAsync | Read a value from an EEPROM location.
Public method | EepromWriteUserAreaAsync | Writes the contents of data to the EEPROM user area.
Public method | EepromWriteWordAsync | Write a word to an EEPROM location.
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetBaudRate | Gets the baud rate for the device.
Public method | GetBitModeAsync | Gets the instantaneous value of the data bus.
Public method | GetFlowControl | Returns the flow control for the device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetLatencyTimerAsync | Get the latency timer value.
Public method | GetModemStatus | Gets the modem status and line status from the device.
Public method | GetParity | Gets the parity bit.
Public method | GetQueueStatus | Gets the number of bytes in the receive queue.
Public method | GetStopBits | Gets the number of stop bits.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Public method | GetWordLength | Gets the number of bits per word.
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | Purge | This function purges receive and transmit buffers in the device.
Public method | ReadAsync | Read data from the device. The function will attempt to read 'bytesToRead' bytes from the device. The number of bytes in the receive queue can be determined with a call to GetQueueStatus(). The read will finish either when 'bytesToRead' bytes have been read or a timeout has occurred. The read timeout can be specified with a call to SetTimeouts(). If a timeout does occur the function will return 0 bytes.
Public method | ResetAsync | Reset the current device.
Public method | RestartInTask | Restarts the driver's IN task.
Public method | SetBaudRateAsync | Sets the baud rate for the device.
Public method | SetBitModeAsync | Enables different chip modes.
Public method | SetBreakOffAsync | Resets the break condition for the device.
Public method | SetBreakOnAsync | Sets the BREAK condition for the device.
Public method | SetDataCharacteristicsAsync | Sets the data characteristics for the device.
Public method | SetDtrAsync | Sets the Data Terminal Ready (DTR) control signal.
Public method | SetFlowControlAsync | Sets the flow control for the device.
Public method | SetLatencyTimerAsync | Set the latency timer value in msecs.
Public method | SetRtsAsync | Sets the Request To Send (RTS) control signal.
Public method | SetTimeouts | Sets the read and write timeouts for the device.
Public method | StopInTask | Stops the driver's IN task. It can be used in situations where data is being received continuously, so that the device can be purged without more data being received.
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)
Public method | WriteAsync | Write data to the device. The function will attempt to write 'bytesToWrite' bytes from the device. The write will complete either when the request has completed or a timeout has occured. The write timeout can be specified with a call to SetTimouts().

Properties

 | Name | Description
Public property | ChipId | IChipId interface. This interface can be used to return the unique FTDI Chip-ID from FT232R, FT245R and FT X-Series devices. If the current chip does not support the FTDI Chip-ID feature then this function will return null.
Public property | DeviceInfoNode | Device Information. Interface containing identification details of this device.
Public property | IsOpen | Returns true if the device has been opened, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDevice Methods

The IFTDevice type exposes the following members.

Methods

 | Name | Description
Public method | ClearDtrAsync | Clears the Data Terminal Ready (DTR) control signal.
Public method | ClearRtsAsync | Clears the Request To Send (RTS) control signal.
Public method | Close | Closes the handle to the current IFTDevice.
Public method | EepromEraseAsync | Erases the device's EEPROM contents. Not applicable to FT232R, FT245R and X-Series devices.
Public method | EepromGetUserAreaSizeAsync | Gets the available size of the EEPROM user area.
Public method | EepromProgramAsync | Program the contents of the device EEPROM.
Public method | EepromReadAsync | Read the contents of the device EEPROM.
Public method | EepromReadUserAreaAsync | Reads the contents of the EEPROM user area.
Public method | EepromReadWordAsync | Read a value from an EEPROM location.
Public method | EepromWriteUserAreaAsync | Writes the contents of data to the EEPROM user area.
Public method | EepromWriteWordAsync | Write a word to an EEPROM location.
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetBaudRate | Gets the baud rate for the device.
Public method | GetBitModeAsync | Gets the instantaneous value of the data bus.
Public method | GetFlowControl | Returns the flow control for the device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetLatencyTimerAsync | Get the latency timer value.
Public method | GetModemStatus | Gets the modem status and line status from the device.
Public method | GetParity | Gets the parity bit.
Public method | GetQueueStatus | Gets the number of bytes in the receive queue.
Public method | GetStopBits | Gets the number of stop bits.
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Public method | GetWordLength | Gets the number of bits per word.
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | Purge | This function purges receive and transmit buffers in the device.
Public method | ReadAsync | Read data from the device. The function will attempt to read 'bytesToRead' bytes from the device. The number of bytes in the receive queue can be determined with a call to GetQueueStatus(). The read will finish either when 'bytesToRead' bytes have been read or a timeout has occurred. The read timeout can be specified with a call to SetTimeouts(). If a timeout does occur the function will return 0 bytes.
Public method | ResetAsync | Reset the current device.
Public method | RestartInTask | Restarts the driver's IN task.
Public method | SetBaudRateAsync | Sets the baud rate for the device.
Public method | SetBitModeAsync | Enables different chip modes.
Public method | SetBreakOffAsync | Resets the break condition for the device.
Public method | SetBreakOnAsync | Sets the BREAK condition for the device.
Public method | SetDataCharacteristicsAsync | Sets the data characteristics for the device.
Public method | SetDtrAsync | Sets the Data Terminal Ready (DTR) control signal.
Public method | SetFlowControlAsync | Sets the flow control for the device.
Public method | SetLatencyTimerAsync | Set the latency timer value in msecs.
Public method | SetRtsAsync | Sets the Request To Send (RTS) control signal.
Public method | SetTimeouts | Sets the read and write timeouts for the device.
Public method | StopInTask | Stops the driver's IN task. It can be used in situations where data is being received continuously, so that the device can be purged without more data being received.
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)
Public method | WriteAsync | Write data to the device. The function will attempt to write 'bytesToWrite' bytes from the device. The write will complete either when the request has completed or a timeout has occured. The write timeout can be specified with a call to SetTimouts().

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


ClearDtrAsync Method

IFTDevice..::..ClearDtrAsync Method

Clears the Data Terminal Ready (DTR) control signal.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> ClearDtrAsync()
Function ClearDtrAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ ClearDtrAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


ClearRtsAsync Method

IFTDevice..::..ClearRtsAsync Method

Clears the Request To Send (RTS) control signal.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> ClearRtsAsync()
Function ClearRtsAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ ClearRtsAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


Close Method

IFTDevice..::..Close Method

Closes the handle to the current IFTDevice.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
void Close()
Sub Close
void Close()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromEraseAsync Method

IFTDevice..::..EepromEraseAsync Method

Erases the device's EEPROM contents. Not applicable to FT232R, FT245R and X-Series devices.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> EepromEraseAsync()
Function EepromEraseAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ EepromEraseAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromGetUserAreaSizeAsync Method

IFTDevice..::..EepromGetUserAreaSizeAsync Method

Gets the available size of the EEPROM user area.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<ushort> EepromGetUserAreaSizeAsync()
Function EepromGetUserAreaSizeAsync As IAsyncOperation(Of UShort)
IAsyncOperation<unsigned short^>^ EepromGetUserAreaSizeAsync()

Return Value

The available size.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromProgramAsync Method

IFTDevice..::..EepromProgramAsync Method

Program the contents of the device EEPROM.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> EepromProgramAsync(
    IFT_EEPROM eeData
)
Function EepromProgramAsync ( _
    eeData As IFT_EEPROM _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ EepromProgramAsync(
    IFT_EEPROM^ eeData
)

Parameters

eeData
Type: FTDI.D2xx.WinRT.Device.EEPROM..::..IFT_EEPROM
Class containing data to be programmed into the device EEPROM.

Return Value

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromReadAsync Method

IFTDevice..::..EepromReadAsync Method

Read the contents of the device EEPROM.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<IFT_EEPROM> EepromReadAsync()
Function EepromReadAsync As IAsyncOperation(Of IFT_EEPROM)
IAsyncOperation<IFT_EEPROM^>^ EepromReadAsync()

Return Value

Device EEPROM structure on success, null otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromReadUserAreaAsync Method

IFTDevice..::..EepromReadUserAreaAsync Method

Reads the contents of the EEPROM user area.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<ushort> EepromReadUserAreaAsync(
    System.Array[] data,
    ushort length
)
Function EepromReadUserAreaAsync ( _
    data As System.Array(), _
    length As UShort _
) As IAsyncOperation(Of UShort)
IAsyncOperation<unsigned short^>^ EepromReadUserAreaAsync(
    array<System.Array^>^ data,
    unsigned short^ length
)

Parameters

data
Type: array< System.Array >[]()[][]
Buffer to hold data read from the EEPROM user area.
length
Type: System.UInt16
The number of bytes from the EEPROM to read.

Return Value

Byte[] containing user area contents.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromReadWordAsync Method

IFTDevice..::..EepromReadWordAsync Method

Read a value from an EEPROM location.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<ushort> EepromReadWordAsync(
    ushort offset
)
Function EepromReadWordAsync ( _
    offset As UShort _
) As IAsyncOperation(Of UShort)
IAsyncOperation<unsigned short^>^ EepromReadWordAsync(
    unsigned short^ offset
)

Parameters

offset
Type: System.UInt16
EEPROM location to read from.

Return Value

Value read from the EEPROM.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromWriteUserAreaAsync Method

IFTDevice..::..EepromWriteUserAreaAsync Method

Writes the contents of data to the EEPROM user area.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<ushort> EepromWriteUserAreaAsync(
    System.Array[] data,
    ushort length
)
Function EepromWriteUserAreaAsync ( _
    data As System.Array(), _
    length As UShort _
) As IAsyncOperation(Of UShort)
IAsyncOperation<unsigned short^>^ EepromWriteUserAreaAsync(
    array<System.Array^>^ data,
    unsigned short^ length
)

Parameters

data
Type: array< System.Array >[]()[][]
Buffer that contains the data to be written to the EEPROM user area.
length
Type: System.UInt16
The number of bytes to write.

Return Value

Returns the number of bytes successfully written.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


EepromWriteWordAsync Method

IFTDevice..::..EepromWriteWordAsync Method

Write a word to an EEPROM location.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> EepromWriteWordAsync(
    ushort offset,
    ushort val
)
Function EepromWriteWordAsync ( _
    offset As UShort, _
    val As UShort _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ EepromWriteWordAsync(
    unsigned short^ offset,
    unsigned short^ val
)

Parameters

offset
Type: System.UInt16
EEPROM location to write to.
val
Type: System.UInt16
Unsigned 16-bit value to write.

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetBaudRate Method

IFTDevice..::..GetBaudRate Method

Gets the baud rate for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
uint GetBaudRate()
Function GetBaudRate As UInteger
unsigned int^ GetBaudRate()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetBitModeAsync Method

IFTDevice..::..GetBitModeAsync Method

Gets the instantaneous value of the data bus.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<byte> GetBitModeAsync()
Function GetBitModeAsync As IAsyncOperation(Of System.Byte)
IAsyncOperation<unsigned char^>^ GetBitModeAsync()

Return Value

Instantaneous data bus value.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetFlowControl Method

IFTDevice..::..GetFlowControl Method

Returns the flow control for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
FLOW_CONTROL GetFlowControl()
Function GetFlowControl As FLOW_CONTROL
FLOW_CONTROL^ GetFlowControl()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetLatencyTimerAsync Method

IFTDevice..::..GetLatencyTimerAsync Method

Get the latency timer value.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<byte> GetLatencyTimerAsync()
Function GetLatencyTimerAsync As IAsyncOperation(Of System.Byte)
IAsyncOperation<unsigned char^>^ GetLatencyTimerAsync()

Return Value

Latency timer value.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetModemStatus Method

IFTDevice..::..GetModemStatus Method

Gets the modem status and line status from the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
uint GetModemStatus()
Function GetModemStatus As UInteger
unsigned int^ GetModemStatus()

Return Value

The least significant byte of the return value holds the modem status. The line status is held in the second least significant byte of the return value. The modem status is bit-mapped as follows: Clear To Send (CTS) = 0x10, Data Set Ready (DSR) = 0x20, Ring Indicator (RI) = 0x40, Data Carrier Detect (DCD) = 0x80. The line status is bit-mapped as follows: Overrun Error (OE) = 0x02, Parity Error (PE) = 0x04, Framing Error (FE) = 0x08, Break Interrupt (BI) = 0x10.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetParity Method

IFTDevice..::..GetParity Method

Gets the parity bit.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
PARITY GetParity()
Function GetParity As PARITY
PARITY^ GetParity()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetQueueStatus Method

IFTDevice..::..GetQueueStatus Method

Gets the number of bytes in the receive queue.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
uint GetQueueStatus()
Function GetQueueStatus As UInteger
unsigned int^ GetQueueStatus()

Return Value

The number of bytes in the receive queue.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetStopBits Method

IFTDevice..::..GetStopBits Method

Gets the number of stop bits.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
STOP_BITS GetStopBits()
Function GetStopBits As STOP_BITS
STOP_BITS^ GetStopBits()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


GetWordLength Method

IFTDevice..::..GetWordLength Method

Gets the number of bits per word.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
WORD_LENGTH GetWordLength()
Function GetWordLength As WORD_LENGTH
WORD_LENGTH^ GetWordLength()

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


Purge Method

IFTDevice..::..Purge Method

This function purges receive and transmit buffers in the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool Purge(
    bool purgeRx,
    bool purgeTx
)
Function Purge ( _
    purgeRx As System.Boolean, _
    purgeTx As System.Boolean _
) As System.Boolean
bool^ Purge(
    bool^ purgeRx,
    bool^ purgeTx
)

Parameters

purgeRx
Type: System.Boolean
Will purge receive buffer if true.
purgeTx
Type: System.Boolean
Will purge transmit buffer if true.

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


ReadAsync Method

IFTDevice..::..ReadAsync Method

Read data from the device. The function will attempt to read 'bytesToRead' bytes from the device. The number of bytes in the receive queue can be determined with a call to GetQueueStatus(). The read will finish either when 'bytesToRead' bytes have been read or a timeout has occurred. The read timeout can be specified with a call to SetTimeouts(). If a timeout does occur the function will return 0 bytes.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<uint> ReadAsync(
    System.Array[] buf,
    uint bytesToRead
)
Function ReadAsync ( _
    buf As System.Array(), _
    bytesToRead As UInteger _
) As IAsyncOperation(Of UInteger)
IAsyncOperation<unsigned int^>^ ReadAsync(
    array<System.Array^>^ buf,
    unsigned int^ bytesToRead
)

Parameters

buf
Type: array< System.Array >[]()[][]
Buffer that receives data from the device.
bytesToRead
Type: System.UInt32
Number of bytes to read from the device.

Return Value

The number of bytes read from the device.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


ResetAsync Method

IFTDevice..::..ResetAsync Method

Reset the current device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> ResetAsync()
Function ResetAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ ResetAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


RestartInTask Method

IFTDevice..::..RestartInTask Method

Restarts the driver's IN task.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool RestartInTask()
Function RestartInTask As System.Boolean
bool^ RestartInTask()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetBaudRateAsync Method

IFTDevice..::..SetBaudRateAsync Method

Sets the baud rate for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetBaudRateAsync(
    uint baudRate
)
Function SetBaudRateAsync ( _
    baudRate As UInteger _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetBaudRateAsync(
    unsigned int^ baudRate
)

Parameters

baudRate
Type: System.UInt32
Baud rate

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetBitModeAsync Method

IFTDevice..::..SetBitModeAsync Method

Enables different chip modes.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetBitModeAsync(
    BIT_MODE mode,
    byte mask
)
Function SetBitModeAsync ( _
    mode As BIT_MODE, _
    mask As System.Byte _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetBitModeAsync(
    BIT_MODE^ mode,
    unsigned char^ mask
)

Parameters

mode
Type: FTDI.D2xx.WinRT.Device..::..BIT_MODE
Mode value. Can be one of the following:

Reset

Asynchronous Bit Bang

MPSSE (FT2232, FT2232H, FT4232H and FT232H devices only)

Synchronous Bit Bang (FT232R, FT245R, FT2232, FT2232H, FT4232H and FT232H devices only)

MCU Host Bus Emulation Mode (FT2232, FT2232H, FT4232H and FT232H devices only)

Fast Opto-Isolated Serial Mode (FT2232, FT2232H, FT4232H and FT232H devices only)

CBUS Bit Bang Mode (FT232R and FT232H devices only)

Single Channel Synchronous 245 FIFO Mode (FT2232H and FT232H devices only)

mask
Type: System.Byte
Required value for bit mode mask. This sets up which bits are inputs and outputs. A bit value of 0 sets the corresponding pin to an input, a bit value of 1 sets the corresponding pin to an output. In the case of CBUS Bit Bang, the upper nibble of this value controls which pins are inputs and outputs, while the lower nibble controls which of the outputs are high and low.

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetBreakOffAsync Method

IFTDevice..::..SetBreakOffAsync Method

Resets the break condition for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetBreakOffAsync()
Function SetBreakOffAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetBreakOffAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetBreakOnAsync Method

IFTDevice..::..SetBreakOnAsync Method

Sets the BREAK condition for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetBreakOnAsync()
Function SetBreakOnAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetBreakOnAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetDataCharacteristicsAsync Method

IFTDevice..::..SetDataCharacteristicsAsync Method

Sets the data characteristics for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetDataCharacteristicsAsync(
    WORD_LENGTH wordLength,
    STOP_BITS stopBits,
    PARITY parity
)
Function SetDataCharacteristicsAsync ( _
    wordLength As WORD_LENGTH, _
    stopBits As STOP_BITS, _
    parity As PARITY _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetDataCharacteristicsAsync(
    WORD_LENGTH^ wordLength,
    STOP_BITS^ stopBits,
    PARITY^ parity
)

Parameters

wordLength
Type: FTDI.D2xx.WinRT.Device..::..WORD_LENGTH
Number of bits per word - must be FT_BITS_8 or FT_BITS_7.
stopBits
Type: FTDI.D2xx.WinRT.Device..::..STOP_BITS
Number of stop bits - must be FT_STOP_BITS_1 or FT_STOP_BITS_2.
parity
Type: FTDI.D2xx.WinRT.Device..::..PARITY
Parity - must be FT_PARITY_NONE, FT_PARITY_ODD, FT_PARITY_EVEN, FT_PARITY_MARK or FT_PARITY SPACE

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetDtrAsync Method

IFTDevice..::..SetDtrAsync Method

Sets the Data Terminal Ready (DTR) control signal.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetDtrAsync()
Function SetDtrAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetDtrAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetFlowControlAsync Method

IFTDevice..::..SetFlowControlAsync Method

Sets the flow control for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetFlowControlAsync(
    FLOW_CONTROL flowCtrl,
    byte xOn,
    byte xOff
)
Function SetFlowControlAsync ( _
    flowCtrl As FLOW_CONTROL, _
    xOn As System.Byte, _
    xOff As System.Byte _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetFlowControlAsync(
    FLOW_CONTROL^ flowCtrl,
    unsigned char^ xOn,
    unsigned char^ xOff
)

Parameters

flowCtrl
Type: FTDI.D2xx.WinRT.Device..::..FLOW_CONTROL
Must be one of the values within FLOW_CONTROL.
xOn
Type: System.Byte
Character used to signal XOn. Only used if flow control is FT_FLOW_XON_XOFF
xOff
Type: System.Byte
Character used to signal XOff. Only used if flow control is FT_FLOW_XON_XOFF

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetLatencyTimerAsync Method

IFTDevice..::..SetLatencyTimerAsync Method

Set the latency timer value in msecs.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetLatencyTimerAsync(
    byte timer
)
Function SetLatencyTimerAsync ( _
    timer As System.Byte _
) As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetLatencyTimerAsync(
    unsigned char^ timer
)

Parameters

timer
Type: System.Byte
Required value in milliseconds of latency timer. Valid range is 2 - 255.

Return Value

True on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetRtsAsync Method

IFTDevice..::..SetRtsAsync Method

Sets the Request To Send (RTS) control signal.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<bool> SetRtsAsync()
Function SetRtsAsync As IAsyncOperation(Of System.Boolean)
IAsyncOperation<bool^>^ SetRtsAsync()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


SetTimeouts Method

IFTDevice..::..SetTimeouts Method

Sets the read and write timeouts for the device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool SetTimeouts(
    ushort readTimeout,
    ushort writeTimeout
)
Function SetTimeouts ( _
    readTimeout As UShort, _
    writeTimeout As UShort _
) As System.Boolean
bool^ SetTimeouts(
    unsigned short^ readTimeout,
    unsigned short^ writeTimeout
)

Parameters

readTimeout
Type: System.UInt16
Read timeout in milliseconds.
writeTimeout
Type: System.UInt16
Write timeout in milliseconds.

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


StopInTask Method

IFTDevice..::..StopInTask Method

Stops the driver's IN task. It can be used in situations where data is being received continuously, so that the device can be purged without more data being received.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool StopInTask()
Function StopInTask As System.Boolean
bool^ StopInTask()

Return Value

true on success, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


WriteAsync Method

IFTDevice..::..WriteAsync Method

Write data to the device. The function will attempt to write 'bytesToWrite' bytes from the device. The write will complete either when the request has completed or a timeout has occured. The write timeout can be specified with a call to SetTimouts().

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IAsyncOperation<uint> WriteAsync(
    System.Array[] buf,
    uint bytesToWrite
)
Function WriteAsync ( _
    buf As System.Array(), _
    bytesToWrite As UInteger _
) As IAsyncOperation(Of UInteger)
IAsyncOperation<unsigned int^>^ WriteAsync(
    array<System.Array^>^ buf,
    unsigned int^ bytesToWrite
)

Parameters

buf
Type: array< System.Array >[]()[][]
Buffer that contains data to be written to the device.
bytesToWrite
Type: System.UInt32
Number of bytes to write to the device.

Return Value

Returns the number of bytes that have successfully been written to the device.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDevice Properties

The IFTDevice type exposes the following members.

Properties

 | Name | Description
Public property | ChipId | IChipId interface. This interface can be used to return the unique FTDI Chip-ID from FT232R, FT245R and FT X-Series devices. If the current chip does not support the FTDI Chip-ID feature then this function will return null.
Public property | DeviceInfoNode | Device Information. Interface containing identification details of this device.
Public property | IsOpen | Returns true if the device has been opened, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


ChipId Property

IFTDevice..::..ChipId Property

IChipId interface. This interface can be used to return the unique FTDI Chip-ID from FT232R, FT245R and FT X-Series devices. If the current chip does not support the FTDI Chip-ID feature then this function will return null.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IChipId ChipId { get; }
ReadOnly Property ChipId As IChipId
    Get
property IChipId^ ChipId {
    IChipId^ get ();
}

Return Value

IChipID object or null.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


DeviceInfoNode Property

IFTDevice..::..DeviceInfoNode Property

Device Information. Interface containing identification details of this device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
IFTDeviceInfoNode DeviceInfoNode { get; }
ReadOnly Property DeviceInfoNode As IFTDeviceInfoNode
    Get
property IFTDeviceInfoNode^ DeviceInfoNode {
    IFTDeviceInfoNode^ get ();
}

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


IsOpen Property

IFTDevice..::..IsOpen Property

Returns true if the device has been opened, false otherwise.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool IsOpen { get; }
ReadOnly Property IsOpen As System.Boolean
    Get
property bool^ IsOpen {
    bool^ get ();
}

Return Value

True if open, false otherwise.

See Also

IFTDevice Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDeviceInfoNode Interface

Interface providing details of an FTDI device connected to the system.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public interface IFTDeviceInfoNode
Public Interface IFTDeviceInfoNode
public interface class IFTDeviceInfoNode

See Also

IFTDeviceInfoNode Members
FTDI.D2xx.WinRT.Device Namespace


IFTDeviceInfoNode Members

The IFTDeviceInfoNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | Description | USB Device Descriptor string.
Public property | DeviceId | Unique string that identifies an FTDI device.
Public property | DeviceType | Enum value representing the device type.
Public property | IsOpen | Returns the open state of the current device.
Public property | Manufacturer | USB Manufacturer Device Descriptor string.
Public property | SerialNumber | Device serial number string.

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDeviceInfoNode Methods

The IFTDeviceInfoNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


IFTDeviceInfoNode Properties

The IFTDeviceInfoNode type exposes the following members.

Properties

 | Name | Description
Public property | Description | USB Device Descriptor string.
Public property | DeviceId | Unique string that identifies an FTDI device.
Public property | DeviceType | Enum value representing the device type.
Public property | IsOpen | Returns the open state of the current device.
Public property | Manufacturer | USB Manufacturer Device Descriptor string.
Public property | SerialNumber | Device serial number string.

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


Description Property

IFTDeviceInfoNode..::..Description Property

USB Device Descriptor string.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string Description { get; }
ReadOnly Property Description As System.String
    Get
property System.String^ Description {
    System.String^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


DeviceId Property

IFTDeviceInfoNode..::..DeviceId Property

Unique string that identifies an FTDI device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string DeviceId { get; }
ReadOnly Property DeviceId As System.String
    Get
property System.String^ DeviceId {
    System.String^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


DeviceType Property

IFTDeviceInfoNode..::..DeviceType Property

Enum value representing the device type.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
DEVICE_TYPE DeviceType { get; }
ReadOnly Property DeviceType As DEVICE_TYPE
    Get
property DEVICE_TYPE^ DeviceType {
    DEVICE_TYPE^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


IsOpen Property

IFTDeviceInfoNode..::..IsOpen Property

Returns the open state of the current device.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool IsOpen { get; }
ReadOnly Property IsOpen As System.Boolean
    Get
property bool^ IsOpen {
    bool^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


Manufacturer Property

IFTDeviceInfoNode..::..Manufacturer Property

USB Manufacturer Device Descriptor string.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string Manufacturer { get; }
ReadOnly Property Manufacturer As System.String
    Get
property System.String^ Manufacturer {
    System.String^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


SerialNumber Property

IFTDeviceInfoNode..::..SerialNumber Property

Device serial number string.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string SerialNumber { get; }
ReadOnly Property SerialNumber As System.String
    Get
property System.String^ SerialNumber {
    System.String^ get ();
}

See Also

IFTDeviceInfoNode Interface
FTDI.D2xx.WinRT.Device Namespace


PARITY Enumeration

UART parity bits.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum PARITY
Public Enumeration PARITY
public enum class PARITY

Members

Member name | Description
NONE | No parity.
ODD | Odd parity.
EVEN | Even parity.
MARK | Mark parity (bit is always 1).
SPACE | Space parity (bit is always 0).

See Also

FTDI.D2xx.WinRT.Device Namespace


STOP_BITS Enumeration

UART stop bits.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum STOP_BITS
Public Enumeration STOP_BITS
public enum class STOP_BITS

Members

Member name | Description
BITS_1 | 1 stop bit.
BITS_2 | 2 stop bits.

See Also

FTDI.D2xx.WinRT.Device Namespace


WORD_LENGTH Enumeration

UART word length.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum WORD_LENGTH
Public Enumeration WORD_LENGTH
public enum class WORD_LENGTH

Members

Member name | Description
BITS_7 | 7 bit data length.
BITS_8 | 8 bit data length.

See Also

FTDI.D2xx.WinRT.Device Namespace


FTDI.D2xx.WinRT.Device.EEPROM Namespace

Classes

 | Class | Description
Public class | FT2232D_EEPROM | Class that represents the EEPROM of an FT2232D device.
Public class | FT2232H_EEPROM | Class that represents the contents of an FT2232H EEPROM.
Public class | FT232AM_EEPROM | Class that represents the contents of an FT232AM EEPROM.
Public class | FT232BM_EEPROM | Class that represents the contents of an FT232BM EEPROM.
Public class | FT232H_EEPROM | Class that represents the contents of an FT232H EEPROM.
Public class | FT232R_EEPROM | Class that represents the contents of an FT232R device EEPROM.
Public class | FT4232H_EEPROM | Class that represents the contents of an FT4232H EEPROM.
Public class | FTXSeries_EEPROM | Class that represents the EEPROM of an FT X-Series devices.

Interfaces

 | Interface | Description
Public interface | IFT_EEPROM | Interface that represents the contents of a generic FTDI device EEPROM.

Enumerations

 | Enumeration | Description
Public enumeration | USB_VERSION | USB Version


FT2232D_EEPROM Class

Class that represents the EEPROM of an FT2232D device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT2232D_EEPROM : IFT_EEPROM
Public NotInheritable Class FT2232D_EEPROM _
    Implements IFT_EEPROM
public ref class FT2232D_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT2232D_EEPROM

See Also

FT2232D_EEPROM Members
FTDI.D2xx.WinRT.Device.EEPROM Namespace


FT2232D_EEPROM Members

The FT2232D_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | A_DeviceInterface | Channel A - Device interface type
Public property | A_HighIO | Channel A - High drive level on UART and FIFO IO signals
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | B_DeviceInterface | Channel B - Device interface type
Public property | B_HighIO | Channel B - High drive level on UART and FIFO IO signals
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT2232D_EEPROM Class


FT2232D_EEPROM Methods

The FT2232D_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT2232D_EEPROM Class


FT2232D_EEPROM Properties

The FT2232D_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | A_DeviceInterface | Channel A - Device interface type
Public property | A_HighIO | Channel A - High drive level on UART and FIFO IO signals
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | B_DeviceInterface | Channel B - Device interface type
Public property | B_HighIO | Channel B - High drive level on UART and FIFO IO signals
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT2232D_EEPROM Class


A_DeviceInterface Property

FT2232D_EEPROM..::..A_DeviceInterface Property

Channel A - Device interface type

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DEVICE_INTERFACE A_DeviceInterface { get; set; }
Public Property A_DeviceInterface As DEVICE_INTERFACE
    Get
    Set
public:
property DEVICE_INTERFACE^ A_DeviceInterface {
    DEVICE_INTERFACE^ get ();
    void set (DEVICE_INTERFACE^ value);
}

See Also

FT2232D_EEPROM Class


A_HighIO Property

FT2232D_EEPROM..::..A_HighIO Property

Channel A - High drive level on UART and FIFO IO signals

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_HighIO { get; set; }
Public Property A_HighIO As System.Boolean
    Get
    Set
public:
property bool^ A_HighIO {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


A_LoadVCP Property

FT2232D_EEPROM..::..A_LoadVCP Property

Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_LoadVCP { get; set; }
Public Property A_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ A_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


B_DeviceInterface Property

FT2232D_EEPROM..::..B_DeviceInterface Property

Channel B - Device interface type

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DEVICE_INTERFACE B_DeviceInterface { get; set; }
Public Property B_DeviceInterface As DEVICE_INTERFACE
    Get
    Set
public:
property DEVICE_INTERFACE^ B_DeviceInterface {
    DEVICE_INTERFACE^ get ();
    void set (DEVICE_INTERFACE^ value);
}

See Also

FT2232D_EEPROM Class


B_HighIO Property

FT2232D_EEPROM..::..B_HighIO Property

Channel B - High drive level on UART and FIFO IO signals

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_HighIO { get; set; }
Public Property B_HighIO As System.Boolean
    Get
    Set
public:
property bool^ B_HighIO {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


B_LoadVCP Property

FT2232D_EEPROM..::..B_LoadVCP Property

Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_LoadVCP { get; set; }
Public Property B_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ B_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


Manufacturer Property

FT2232D_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232D_EEPROM Class


MaxPower Property

FT2232D_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232D_EEPROM Class


Product Property

FT2232D_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232D_EEPROM Class


ProductID Property

FT2232D_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232D_EEPROM Class


PullDownEnable Property

FT2232D_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


RemoteWakeupEnable Property

FT2232D_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


SelfPowered Property

FT2232D_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


SerialNumber Property

FT2232D_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232D_EEPROM Class


SerialNumberEnable Property

FT2232D_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232D_EEPROM Class


UsbVersion Property

FT2232D_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT2232D_EEPROM Class


VendorID Property

FT2232D_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232D_EEPROM Class


FT2232H_EEPROM Class

Class that represents the contents of an FT2232H EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT2232H_EEPROM : IFT_EEPROM
Public NotInheritable Class FT2232H_EEPROM _
    Implements IFT_EEPROM
public ref class FT2232H_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT2232H_EEPROM

See Also

FT2232H_EEPROM Members


FT2232H_EEPROM Members

The FT2232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | A_DeviceInterface | Channel A - Device interface type
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | AC_DriveCurrent | AC Bus - Drive current of IO lines.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO lines.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | B_DeviceInterface | Channel B - Device interface type
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | BC_DriveCurrent | BC Bus - Drive current of IO lines.
Public property | BC_SchmittInput | BC Bus - Schmitt trigger input.
Public property | BC_SlowSlew | BC Bus - Slow slew rate.
Public property | BD_DriveCurrent | BD Bus - Drive current of IO lines.
Public property | BD_SchmittInput | BD Bus - Schmitt trigger input.
Public property | BD_SlowSlew | BD Bus - Slow slew rate.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | SuspendDBus7 |
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT2232H_EEPROM Class


FT2232H_EEPROM Methods

The FT2232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT2232H_EEPROM Class


FT2232H_EEPROM Properties

The FT2232H_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | A_DeviceInterface | Channel A - Device interface type
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | AC_DriveCurrent | AC Bus - Drive current of IO lines.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO lines.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | B_DeviceInterface | Channel B - Device interface type
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | BC_DriveCurrent | BC Bus - Drive current of IO lines.
Public property | BC_SchmittInput | BC Bus - Schmitt trigger input.
Public property | BC_SlowSlew | BC Bus - Slow slew rate.
Public property | BD_DriveCurrent | BD Bus - Drive current of IO lines.
Public property | BD_SchmittInput | BD Bus - Schmitt trigger input.
Public property | BD_SlowSlew | BD Bus - Slow slew rate.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | SuspendDBus7 |
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT2232H_EEPROM Class


A_DeviceInterface Property

FT2232H_EEPROM..::..A_DeviceInterface Property

Channel A - Device interface type

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DEVICE_INTERFACE A_DeviceInterface { get; set; }
Public Property A_DeviceInterface As DEVICE_INTERFACE
    Get
    Set
public:
property DEVICE_INTERFACE^ A_DeviceInterface {
    DEVICE_INTERFACE^ get ();
    void set (DEVICE_INTERFACE^ value);
}

See Also

FT2232H_EEPROM Class


A_LoadVCP Property

FT2232H_EEPROM..::..A_LoadVCP Property

Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_LoadVCP { get; set; }
Public Property A_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ A_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


AC_DriveCurrent Property

FT2232H_EEPROM..::..AC_DriveCurrent Property

AC Bus - Drive current of IO lines.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AC_DriveCurrent { get; set; }
Public Property AC_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AC_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT2232H_EEPROM Class


AC_SchmittInput Property

FT2232H_EEPROM..::..AC_SchmittInput Property

AC Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SchmittInput { get; set; }
Public Property AC_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AC_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


AC_SlowSlew Property

FT2232H_EEPROM..::..AC_SlowSlew Property

AC Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SlowSlew { get; set; }
Public Property AC_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AC_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


AD_DriveCurrent Property

FT2232H_EEPROM..::..AD_DriveCurrent Property

AD Bus - Drive current of IO lines.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AD_DriveCurrent { get; set; }
Public Property AD_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AD_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT2232H_EEPROM Class


AD_SchmittInput Property

FT2232H_EEPROM..::..AD_SchmittInput Property

AD Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SchmittInput { get; set; }
Public Property AD_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AD_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


AD_SlowSlew Property

FT2232H_EEPROM..::..AD_SlowSlew Property

AD Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SlowSlew { get; set; }
Public Property AD_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AD_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


B_DeviceInterface Property

FT2232H_EEPROM..::..B_DeviceInterface Property

Channel B - Device interface type

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DEVICE_INTERFACE B_DeviceInterface { get; set; }
Public Property B_DeviceInterface As DEVICE_INTERFACE
    Get
    Set
public:
property DEVICE_INTERFACE^ B_DeviceInterface {
    DEVICE_INTERFACE^ get ();
    void set (DEVICE_INTERFACE^ value);
}

See Also

FT2232H_EEPROM Class


B_LoadVCP Property

FT2232H_EEPROM..::..B_LoadVCP Property

Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_LoadVCP { get; set; }
Public Property B_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ B_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


BC_DriveCurrent Property

FT2232H_EEPROM..::..BC_DriveCurrent Property

BC Bus - Drive current of IO lines.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT BC_DriveCurrent { get; set; }
Public Property BC_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ BC_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT2232H_EEPROM Class


BC_SchmittInput Property

FT2232H_EEPROM..::..BC_SchmittInput Property

BC Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BC_SchmittInput { get; set; }
Public Property BC_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ BC_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


BC_SlowSlew Property

FT2232H_EEPROM..::..BC_SlowSlew Property

BC Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BC_SlowSlew { get; set; }
Public Property BC_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ BC_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


BD_DriveCurrent Property

FT2232H_EEPROM..::..BD_DriveCurrent Property

BD Bus - Drive current of IO lines.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT BD_DriveCurrent { get; set; }
Public Property BD_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ BD_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT2232H_EEPROM Class


BD_SchmittInput Property

FT2232H_EEPROM..::..BD_SchmittInput Property

BD Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BD_SchmittInput { get; set; }
Public Property BD_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ BD_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


BD_SlowSlew Property

FT2232H_EEPROM..::..BD_SlowSlew Property

BD Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BD_SlowSlew { get; set; }
Public Property BD_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ BD_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


Manufacturer Property

FT2232H_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232H_EEPROM Class


MaxPower Property

FT2232H_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232H_EEPROM Class


PowerSaveEnable Property

FT2232H_EEPROM..::..PowerSaveEnable Property

Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PowerSaveEnable { get; set; }
Public Property PowerSaveEnable As System.Boolean
    Get
    Set
public:
property bool^ PowerSaveEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


Product Property

FT2232H_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232H_EEPROM Class


ProductID Property

FT2232H_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232H_EEPROM Class


PullDownEnable Property

FT2232H_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


RemoteWakeupEnable Property

FT2232H_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


SelfPowered Property

FT2232H_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


SerialNumber Property

FT2232H_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT2232H_EEPROM Class


SerialNumberEnable Property

FT2232H_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


SuspendDBus7 Property

FT2232H_EEPROM..::..SuspendDBus7 Property

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SuspendDBus7 { get; set; }
Public Property SuspendDBus7 As System.Boolean
    Get
    Set
public:
property bool^ SuspendDBus7 {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT2232H_EEPROM Class


UsbVersion Property

FT2232H_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT2232H_EEPROM Class


VendorID Property

FT2232H_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT2232H_EEPROM Class


FT232AM_EEPROM Class

Class that represents the contents of an FT232AM EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT232AM_EEPROM : IFT_EEPROM
Public NotInheritable Class FT232AM_EEPROM _
    Implements IFT_EEPROM
public ref class FT232AM_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT232AM_EEPROM

See Also

FT232AM_EEPROM Members


FT232AM_EEPROM Members

The FT232AM_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232AM_EEPROM Class


FT232AM_EEPROM Methods

The FT232AM_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT232AM_EEPROM Class


FT232AM_EEPROM Properties

The FT232AM_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232AM_EEPROM Class


Manufacturer Property

FT232AM_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232AM_EEPROM Class


MaxPower Property

FT232AM_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232AM_EEPROM Class


Product Property

FT232AM_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232AM_EEPROM Class


ProductID Property

FT232AM_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232AM_EEPROM Class


PullDownEnable Property

FT232AM_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232AM_EEPROM Class


RemoteWakeupEnable Property

FT232AM_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232AM_EEPROM Class


SelfPowered Property

FT232AM_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232AM_EEPROM Class


SerialNumber Property

FT232AM_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232AM_EEPROM Class


SerialNumberEnable Property

FT232AM_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232AM_EEPROM Class


UsbVersion Property

FT232AM_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT232AM_EEPROM Class


VendorID Property

FT232AM_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232AM_EEPROM Class


FT232BM_EEPROM Class

Class that represents the contents of an FT232BM EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT232BM_EEPROM : IFT_EEPROM
Public NotInheritable Class FT232BM_EEPROM _
    Implements IFT_EEPROM
public ref class FT232BM_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT232BM_EEPROM

See Also

FT232BM_EEPROM Members


FT232BM_EEPROM Members

The FT232BM_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232BM_EEPROM Class


FT232BM_EEPROM Methods

The FT232BM_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT232BM_EEPROM Class


FT232BM_EEPROM Properties

The FT232BM_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232BM_EEPROM Class


Manufacturer Property

FT232BM_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232BM_EEPROM Class


MaxPower Property

FT232BM_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232BM_EEPROM Class


Product Property

FT232BM_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232BM_EEPROM Class


ProductID Property

FT232BM_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232BM_EEPROM Class


PullDownEnable Property

FT232BM_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232BM_EEPROM Class


RemoteWakeupEnable Property

FT232BM_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232BM_EEPROM Class


SelfPowered Property

FT232BM_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232BM_EEPROM Class


SerialNumber Property

FT232BM_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232BM_EEPROM Class


SerialNumberEnable Property

FT232BM_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232BM_EEPROM Class


UsbVersion Property

FT232BM_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT232BM_EEPROM Class


VendorID Property

FT232BM_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232BM_EEPROM Class


FT232H_EEPROM Class

Class that represents the contents of an FT232H EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT232H_EEPROM : IFT_EEPROM
Public NotInheritable Class FT232H_EEPROM _
    Implements IFT_EEPROM
public ref class FT232H_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT232H_EEPROM

See Also

FT232H_EEPROM Members


FT232H_EEPROM Members

The FT232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | AC_DriveCurrent | AC Bus - Drive current of IO pins.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO pins.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | CBus0 | CBus 0 signal
Public property | CBus1 | CBus 1 signal.
Public property | CBus2 | CBus 2 signal.
Public property | CBus3 | CBus 3 signal.
Public property | CBus4 | CBus 4 signal.
Public property | CBus5 | CBus 5 signal.
Public property | CBus6 | CBus 6 signal.
Public property | CBus7 | CBus 7 signal.
Public property | CBus8 | CBus 8 signal.
Public property | CBus9 | CBus 9 signal.
Public property | DeviceInterface | Device interface type.
Public property | FT1248_ClockPolarityHigh | FT1248 interface clock polarity.
Public property | FT1248_FlowControlEnable | FT1248 flow control enable.
Public property | FT1248_LSB | FT1248 Least Significant Byte first.
Public property | LoadVCP | Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | Suspend_BCBus7 |
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232H_EEPROM Class


FT232H_EEPROM Methods

The FT232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT232H_EEPROM Class


FT232H_EEPROM Properties

The FT232H_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | AC_DriveCurrent | AC Bus - Drive current of IO pins.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO pins.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | CBus0 | CBus 0 signal
Public property | CBus1 | CBus 1 signal.
Public property | CBus2 | CBus 2 signal.
Public property | CBus3 | CBus 3 signal.
Public property | CBus4 | CBus 4 signal.
Public property | CBus5 | CBus 5 signal.
Public property | CBus6 | CBus 6 signal.
Public property | CBus7 | CBus 7 signal.
Public property | CBus8 | CBus 8 signal.
Public property | CBus9 | CBus 9 signal.
Public property | DeviceInterface | Device interface type.
Public property | FT1248_ClockPolarityHigh | FT1248 interface clock polarity.
Public property | FT1248_FlowControlEnable | FT1248 flow control enable.
Public property | FT1248_LSB | FT1248 Least Significant Byte first.
Public property | LoadVCP | Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | Suspend_BCBus7 |
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232H_EEPROM Class


AC_DriveCurrent Property

FT232H_EEPROM..::..AC_DriveCurrent Property

AC Bus - Drive current of IO pins.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AC_DriveCurrent { get; set; }
Public Property AC_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AC_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT232H_EEPROM Class


AC_SchmittInput Property

FT232H_EEPROM..::..AC_SchmittInput Property

AC Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SchmittInput { get; set; }
Public Property AC_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AC_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


AC_SlowSlew Property

FT232H_EEPROM..::..AC_SlowSlew Property

AC Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SlowSlew { get; set; }
Public Property AC_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AC_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


AD_DriveCurrent Property

FT232H_EEPROM..::..AD_DriveCurrent Property

AD Bus - Drive current of IO pins.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AD_DriveCurrent { get; set; }
Public Property AD_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AD_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT232H_EEPROM Class


AD_SchmittInput Property

FT232H_EEPROM..::..AD_SchmittInput Property

AD Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SchmittInput { get; set; }
Public Property AD_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AD_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


AD_SlowSlew Property

FT232H_EEPROM..::..AD_SlowSlew Property

AD Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SlowSlew { get; set; }
Public Property AD_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AD_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


CBus0 Property

FT232H_EEPROM..::..CBus0 Property

CBus 0 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus0 { get; set; }
Public Property CBus0 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus0 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus1 Property

FT232H_EEPROM..::..CBus1 Property

CBus 1 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus1 { get; set; }
Public Property CBus1 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus1 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus2 Property

FT232H_EEPROM..::..CBus2 Property

CBus 2 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus2 { get; set; }
Public Property CBus2 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus2 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus3 Property

FT232H_EEPROM..::..CBus3 Property

CBus 3 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus3 { get; set; }
Public Property CBus3 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus3 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus4 Property

FT232H_EEPROM..::..CBus4 Property

CBus 4 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus4 { get; set; }
Public Property CBus4 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus4 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus5 Property

FT232H_EEPROM..::..CBus5 Property

CBus 5 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus5 { get; set; }
Public Property CBus5 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus5 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus6 Property

FT232H_EEPROM..::..CBus6 Property

CBus 6 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus6 { get; set; }
Public Property CBus6 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus6 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus7 Property

FT232H_EEPROM..::..CBus7 Property

CBus 7 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus7 { get; set; }
Public Property CBus7 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus7 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus8 Property

FT232H_EEPROM..::..CBus8 Property

CBus 8 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus8 { get; set; }
Public Property CBus8 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus8 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


CBus9 Property

FT232H_EEPROM..::..CBus9 Property

CBus 9 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus9 { get; set; }
Public Property CBus9 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus9 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232H_EEPROM Class


DeviceInterface Property

FT232H_EEPROM..::..DeviceInterface Property

Device interface type.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DEVICE_INTERFACE DeviceInterface { get; set; }
Public Property DeviceInterface As DEVICE_INTERFACE
    Get
    Set
public:
property DEVICE_INTERFACE^ DeviceInterface {
    DEVICE_INTERFACE^ get ();
    void set (DEVICE_INTERFACE^ value);
}

See Also

FT232H_EEPROM Class


FT1248_ClockPolarityHigh Property

FT232H_EEPROM..::..FT1248_ClockPolarityHigh Property

FT1248 interface clock polarity.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_ClockPolarityHigh { get; set; }
Public Property FT1248_ClockPolarityHigh As System.Boolean
    Get
    Set
public:
property bool^ FT1248_ClockPolarityHigh {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


FT1248_FlowControlEnable Property

FT232H_EEPROM..::..FT1248_FlowControlEnable Property

FT1248 flow control enable.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_FlowControlEnable { get; set; }
Public Property FT1248_FlowControlEnable As System.Boolean
    Get
    Set
public:
property bool^ FT1248_FlowControlEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


FT1248_LSB Property

FT232H_EEPROM..::..FT1248_LSB Property

FT1248 Least Significant Byte first.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_LSB { get; set; }
Public Property FT1248_LSB As System.Boolean
    Get
    Set
public:
property bool^ FT1248_LSB {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


LoadVCP Property

FT232H_EEPROM..::..LoadVCP Property

Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool LoadVCP { get; set; }
Public Property LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


Manufacturer Property

FT232H_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232H_EEPROM Class


MaxPower Property

FT232H_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232H_EEPROM Class


PowerSaveEnable Property

FT232H_EEPROM..::..PowerSaveEnable Property

Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PowerSaveEnable { get; set; }
Public Property PowerSaveEnable As System.Boolean
    Get
    Set
public:
property bool^ PowerSaveEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


Product Property

FT232H_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232H_EEPROM Class


ProductID Property

FT232H_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232H_EEPROM Class


PullDownEnable Property

FT232H_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


RemoteWakeupEnable Property

FT232H_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


SelfPowered Property

FT232H_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


SerialNumber Property

FT232H_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232H_EEPROM Class


SerialNumberEnable Property

FT232H_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


Suspend_BCBus7 Property

FT232H_EEPROM..::..Suspend_BCBus7 Property

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool Suspend_BCBus7 { get; set; }
Public Property Suspend_BCBus7 As System.Boolean
    Get
    Set
public:
property bool^ Suspend_BCBus7 {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232H_EEPROM Class


UsbVersion Property

FT232H_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT232H_EEPROM Class


VendorID Property

FT232H_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232H_EEPROM Class


FT232R_EEPROM Class

Class that represents the contents of an FT232R device EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT232R_EEPROM : IFT_EEPROM
Public NotInheritable Class FT232R_EEPROM _
    Implements IFT_EEPROM
public ref class FT232R_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT232R_EEPROM

See Also

FT232R_EEPROM Members


FT232R_EEPROM Members

The FT232R_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | CBus0 | CBus0 signal
Public property | CBus1 | CBus1 signal
Public property | CBus2 | CBus2 signal
Public property | CBus3 | CBus3 signal
Public property | CBus4 | CBus4 signal
Public property | ExternalOscillatorEnable | If the design has an external oscillator fitted enable this property to turn the internal oscillator off. Warning: enabling this option without an external oscillator fitted will render the device unusable.
Public property | HighIO | High drive current of IO lines.
Public property | InvertCTS | Invert CTS UART line
Public property | InvertDCD | Invert DCD UART line
Public property | InvertDSR | Invert DSR UART line
Public property | InvertDTR | Invert DTR UART line
Public property | InvertRI | Invert RI UART line
Public property | InvertRTS | Invert RTS UART line
Public property | InvertRXD | Invert RXD UART line
Public property | InvertTXD | Invert TXD UART line
Public property | LoadVCP | D2xx driver will expose the Virtual COM Port (VCP) layer.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232R_EEPROM Class


FT232R_EEPROM Methods

The FT232R_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT232R_EEPROM Class


FT232R_EEPROM Properties

The FT232R_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | CBus0 | CBus0 signal
Public property | CBus1 | CBus1 signal
Public property | CBus2 | CBus2 signal
Public property | CBus3 | CBus3 signal
Public property | CBus4 | CBus4 signal
Public property | ExternalOscillatorEnable | If the design has an external oscillator fitted enable this property to turn the internal oscillator off. Warning: enabling this option without an external oscillator fitted will render the device unusable.
Public property | HighIO | High drive current of IO lines.
Public property | InvertCTS | Invert CTS UART line
Public property | InvertDCD | Invert DCD UART line
Public property | InvertDSR | Invert DSR UART line
Public property | InvertDTR | Invert DTR UART line
Public property | InvertRI | Invert RI UART line
Public property | InvertRTS | Invert RTS UART line
Public property | InvertRXD | Invert RXD UART line
Public property | InvertTXD | Invert TXD UART line
Public property | LoadVCP | D2xx driver will expose the Virtual COM Port (VCP) layer.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT232R_EEPROM Class


CBus0 Property

FT232R_EEPROM..::..CBus0 Property

CBus0 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus0 { get; set; }
Public Property CBus0 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus0 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232R_EEPROM Class


CBus1 Property

FT232R_EEPROM..::..CBus1 Property

CBus1 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus1 { get; set; }
Public Property CBus1 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus1 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232R_EEPROM Class


CBus2 Property

FT232R_EEPROM..::..CBus2 Property

CBus2 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus2 { get; set; }
Public Property CBus2 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus2 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232R_EEPROM Class


CBus3 Property

FT232R_EEPROM..::..CBus3 Property

CBus3 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus3 { get; set; }
Public Property CBus3 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus3 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232R_EEPROM Class


CBus4 Property

FT232R_EEPROM..::..CBus4 Property

CBus4 signal

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus4 { get; set; }
Public Property CBus4 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus4 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FT232R_EEPROM Class


ExternalOscillatorEnable Property

FT232R_EEPROM..::..ExternalOscillatorEnable Property

If the design has an external oscillator fitted enable this property to turn the internal oscillator off. Warning: enabling this option without an external oscillator fitted will render the device unusable.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool ExternalOscillatorEnable { get; set; }
Public Property ExternalOscillatorEnable As System.Boolean
    Get
    Set
public:
property bool^ ExternalOscillatorEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


HighIO Property

FT232R_EEPROM..::..HighIO Property

High drive current of IO lines.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool HighIO { get; set; }
Public Property HighIO As System.Boolean
    Get
    Set
public:
property bool^ HighIO {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertCTS Property

FT232R_EEPROM..::..InvertCTS Property

Invert CTS UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertCTS { get; set; }
Public Property InvertCTS As System.Boolean
    Get
    Set
public:
property bool^ InvertCTS {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertDCD Property

FT232R_EEPROM..::..InvertDCD Property

Invert DCD UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDCD { get; set; }
Public Property InvertDCD As System.Boolean
    Get
    Set
public:
property bool^ InvertDCD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertDSR Property

FT232R_EEPROM..::..InvertDSR Property

Invert DSR UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDSR { get; set; }
Public Property InvertDSR As System.Boolean
    Get
    Set
public:
property bool^ InvertDSR {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertDTR Property

FT232R_EEPROM..::..InvertDTR Property

Invert DTR UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDTR { get; set; }
Public Property InvertDTR As System.Boolean
    Get
    Set
public:
property bool^ InvertDTR {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertRI Property

FT232R_EEPROM..::..InvertRI Property

Invert RI UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRI { get; set; }
Public Property InvertRI As System.Boolean
    Get
    Set
public:
property bool^ InvertRI {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertRTS Property

FT232R_EEPROM..::..InvertRTS Property

Invert RTS UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRTS { get; set; }
Public Property InvertRTS As System.Boolean
    Get
    Set
public:
property bool^ InvertRTS {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertRXD Property

FT232R_EEPROM..::..InvertRXD Property

Invert RXD UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRXD { get; set; }
Public Property InvertRXD As System.Boolean
    Get
    Set
public:
property bool^ InvertRXD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


InvertTXD Property

FT232R_EEPROM..::..InvertTXD Property

Invert TXD UART line

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertTXD { get; set; }
Public Property InvertTXD As System.Boolean
    Get
    Set
public:
property bool^ InvertTXD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


LoadVCP Property

FT232R_EEPROM..::..LoadVCP Property

D2xx driver will expose the Virtual COM Port (VCP) layer.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool LoadVCP { get; set; }
Public Property LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


Manufacturer Property

FT232R_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232R_EEPROM Class


MaxPower Property

FT232R_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232R_EEPROM Class


Product Property

FT232R_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232R_EEPROM Class


ProductID Property

FT232R_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232R_EEPROM Class


PullDownEnable Property

FT232R_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


RemoteWakeupEnable Property

FT232R_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


SelfPowered Property

FT232R_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


SerialNumber Property

FT232R_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT232R_EEPROM Class


SerialNumberEnable Property

FT232R_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT232R_EEPROM Class


UsbVersion Property

FT232R_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT232R_EEPROM Class


VendorID Property

FT232R_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT232R_EEPROM Class


FT4232H_EEPROM Class

Class that represents the contents of an FT4232H EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FT4232H_EEPROM : IFT_EEPROM
Public NotInheritable Class FT4232H_EEPROM _
    Implements IFT_EEPROM
public ref class FT4232H_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FT4232H_EEPROM

See Also

FT4232H_EEPROM Members


FT4232H_EEPROM Members

The FT4232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | A_DriveCurrent | Channel A - Drive current.
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | A_RI_RS485_TXDEN | Channel A - Ring Indicator used as TXDEN for RS485.
Public property | A_SchmittInput | Channel A - Schmitt trigger input.
Public property | A_SlowSlew | Channel A - Slow slew rate.
Public property | B_DriveCurrent | Channel B - Drive current.
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | B_RI_RS485_TXDEN | Channel B - Ring Indicator used as TXDEN for RS485.
Public property | B_SchmittInput | Channel B - Schmitt trigger input.
Public property | B_SlowSlew | Channel B - Slow slew rate.
Public property | C_DriveCurrent | Channel C - Drive current.
Public property | C_LoadVCP | Channel C - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | C_RI_RS485_TXDEN | Channel C - Ring Indicator used as TXDEN for RS485.
Public property | C_SchmittInput | Channel C - Schmitt trigger input.
Public property | C_SlowSlew | Channel C - Slow slew rate.
Public property | D_DriveCurrent | Channel D - Drive current.
Public property | D_LoadVCP | Channel D - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | D_RI_RS485_TXDEN | Channel D - Ring Indicator used as TXDEN for RS485.
Public property | D_SchmittInput | Channel D - Schmitt trigger input.
Public property | D_SlowSlew | Channel D - Slow slew rate.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT4232H_EEPROM Class


FT4232H_EEPROM Methods

The FT4232H_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FT4232H_EEPROM Class


FT4232H_EEPROM Properties

The FT4232H_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | A_DriveCurrent | Channel A - Drive current.
Public property | A_LoadVCP | Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | A_RI_RS485_TXDEN | Channel A - Ring Indicator used as TXDEN for RS485.
Public property | A_SchmittInput | Channel A - Schmitt trigger input.
Public property | A_SlowSlew | Channel A - Slow slew rate.
Public property | B_DriveCurrent | Channel B - Drive current.
Public property | B_LoadVCP | Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | B_RI_RS485_TXDEN | Channel B - Ring Indicator used as TXDEN for RS485.
Public property | B_SchmittInput | Channel B - Schmitt trigger input.
Public property | B_SlowSlew | Channel B - Slow slew rate.
Public property | C_DriveCurrent | Channel C - Drive current.
Public property | C_LoadVCP | Channel C - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | C_RI_RS485_TXDEN | Channel C - Ring Indicator used as TXDEN for RS485.
Public property | C_SchmittInput | Channel C - Schmitt trigger input.
Public property | C_SlowSlew | Channel C - Slow slew rate.
Public property | D_DriveCurrent | Channel D - Drive current.
Public property | D_LoadVCP | Channel D - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | D_RI_RS485_TXDEN | Channel D - Ring Indicator used as TXDEN for RS485.
Public property | D_SchmittInput | Channel D - Schmitt trigger input.
Public property | D_SlowSlew | Channel D - Slow slew rate.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | PowerSaveEnable | Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

FT4232H_EEPROM Class


A_DriveCurrent Property

FT4232H_EEPROM..::..A_DriveCurrent Property

Channel A - Drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT A_DriveCurrent { get; set; }
Public Property A_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ A_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT4232H_EEPROM Class


A_LoadVCP Property

FT4232H_EEPROM..::..A_LoadVCP Property

Channel A - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_LoadVCP { get; set; }
Public Property A_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ A_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


A_RI_RS485_TXDEN Property

FT4232H_EEPROM..::..A_RI_RS485_TXDEN Property

Channel A - Ring Indicator used as TXDEN for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_RI_RS485_TXDEN { get; set; }
Public Property A_RI_RS485_TXDEN As System.Boolean
    Get
    Set
public:
property bool^ A_RI_RS485_TXDEN {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


A_SchmittInput Property

FT4232H_EEPROM..::..A_SchmittInput Property

Channel A - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_SchmittInput { get; set; }
Public Property A_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ A_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


A_SlowSlew Property

FT4232H_EEPROM..::..A_SlowSlew Property

Channel A - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool A_SlowSlew { get; set; }
Public Property A_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ A_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


B_DriveCurrent Property

FT4232H_EEPROM..::..B_DriveCurrent Property

Channel B - Drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT B_DriveCurrent { get; set; }
Public Property B_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ B_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT4232H_EEPROM Class


B_LoadVCP Property

FT4232H_EEPROM..::..B_LoadVCP Property

Channel B - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_LoadVCP { get; set; }
Public Property B_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ B_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


B_RI_RS485_TXDEN Property

FT4232H_EEPROM..::..B_RI_RS485_TXDEN Property

Channel B - Ring Indicator used as TXDEN for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_RI_RS485_TXDEN { get; set; }
Public Property B_RI_RS485_TXDEN As System.Boolean
    Get
    Set
public:
property bool^ B_RI_RS485_TXDEN {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


B_SchmittInput Property

FT4232H_EEPROM..::..B_SchmittInput Property

Channel B - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_SchmittInput { get; set; }
Public Property B_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ B_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


B_SlowSlew Property

FT4232H_EEPROM..::..B_SlowSlew Property

Channel B - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool B_SlowSlew { get; set; }
Public Property B_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ B_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


C_DriveCurrent Property

FT4232H_EEPROM..::..C_DriveCurrent Property

Channel C - Drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT C_DriveCurrent { get; set; }
Public Property C_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ C_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT4232H_EEPROM Class


C_LoadVCP Property

FT4232H_EEPROM..::..C_LoadVCP Property

Channel C - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool C_LoadVCP { get; set; }
Public Property C_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ C_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


C_RI_RS485_TXDEN Property

FT4232H_EEPROM..::..C_RI_RS485_TXDEN Property

Channel C - Ring Indicator used as TXDEN for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool C_RI_RS485_TXDEN { get; set; }
Public Property C_RI_RS485_TXDEN As System.Boolean
    Get
    Set
public:
property bool^ C_RI_RS485_TXDEN {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


C_SchmittInput Property

FT4232H_EEPROM..::..C_SchmittInput Property

Channel C - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool C_SchmittInput { get; set; }
Public Property C_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ C_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


C_SlowSlew Property

FT4232H_EEPROM..::..C_SlowSlew Property

Channel C - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool C_SlowSlew { get; set; }
Public Property C_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ C_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


D_DriveCurrent Property

FT4232H_EEPROM..::..D_DriveCurrent Property

Channel D - Drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT D_DriveCurrent { get; set; }
Public Property D_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ D_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FT4232H_EEPROM Class


D_LoadVCP Property

FT4232H_EEPROM..::..D_LoadVCP Property

Channel D - Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool D_LoadVCP { get; set; }
Public Property D_LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ D_LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


D_RI_RS485_TXDEN Property

FT4232H_EEPROM..::..D_RI_RS485_TXDEN Property

Channel D - Ring Indicator used as TXDEN for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool D_RI_RS485_TXDEN { get; set; }
Public Property D_RI_RS485_TXDEN As System.Boolean
    Get
    Set
public:
property bool^ D_RI_RS485_TXDEN {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


D_SchmittInput Property

FT4232H_EEPROM..::..D_SchmittInput Property

Channel D - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool D_SchmittInput { get; set; }
Public Property D_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ D_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


D_SlowSlew Property

FT4232H_EEPROM..::..D_SlowSlew Property

Channel D - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool D_SlowSlew { get; set; }
Public Property D_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ D_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


Manufacturer Property

FT4232H_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT4232H_EEPROM Class


MaxPower Property

FT4232H_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT4232H_EEPROM Class


PowerSaveEnable Property

FT4232H_EEPROM..::..PowerSaveEnable Property

Power Save Enable - When the FT2232H is used in self powered mode this feature prevents forcing current down the USB lines when the host or hub is powered off.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PowerSaveEnable { get; set; }
Public Property PowerSaveEnable As System.Boolean
    Get
    Set
public:
property bool^ PowerSaveEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


Product Property

FT4232H_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT4232H_EEPROM Class


ProductID Property

FT4232H_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT4232H_EEPROM Class


PullDownEnable Property

FT4232H_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


RemoteWakeupEnable Property

FT4232H_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


SelfPowered Property

FT4232H_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


SerialNumber Property

FT4232H_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FT4232H_EEPROM Class


SerialNumberEnable Property

FT4232H_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FT4232H_EEPROM Class


UsbVersion Property

FT4232H_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FT4232H_EEPROM Class


VendorID Property

FT4232H_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FT4232H_EEPROM Class


FTXSeries_EEPROM Class

Class that represents the EEPROM of an FT X-Series devices.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public sealed class FTXSeries_EEPROM : IFT_EEPROM
Public NotInheritable Class FTXSeries_EEPROM _
    Implements IFT_EEPROM
public ref class FTXSeries_EEPROM sealed : IFT_EEPROM

Inheritance Hierarchy

System.Object
FTDI.D2xx.WinRT.Device.EEPROM..::..FTXSeries_EEPROM

See Also

FTXSeries_EEPROM Members


FTXSeries_EEPROM Members

The FTXSeries_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | AC_DriveCurrent | AC Bus - Drive current of IO pins.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO pins.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | BCD_DeactivateSleep | Battery charge detection deactivate sleep.
Public property | BCD_Enable | Enable battery charge detection feature.
Public property | BCD_ForceCBusPowerEnable | Battery charge detection CBus power enable.
Public property | CBus0 | CBus 0 signal.
Public property | CBus1 | CBus 1 signal.
Public property | CBus2 | Cbus 2 signal.
Public property | CBus3 | CBus 3 signal.
Public property | CBus4 | CBus 4 signal.
Public property | CBus5 | CBus 5 signal.
Public property | CBus6 | CBus 6 signal.
Public property | FT1248_ClockPolarityEnable | FT1248 clock polarity enable.
Public property | FT1248_FlowControlEnable | FT1248 flow control enable
Public property | FT1248_LSB | FT1248 bit order.
Public property | I2C_DeviceID | I2C device ID.
Public property | I2C_DiableSchmitt | I2C disable schmitt trigger.
Public property | I2C_SlaveAddress | I2C slave address.
Public property | InvertCTS | Invert CTS UART line.
Public property | InvertDCD | Invert DCD UART line.
Public property | InvertDSR | Invert DSR UART line.
Public property | InvertDTR | Invert DTR UART line.
Public property | InvertRI | Invert RI UART line.
Public property | InvertRTS | Invert RTS UART line.
Public property | InvertRXD | Invert RXD UART line.
Public property | InvertTXD | Invert TXD UART line.
Public property | LoadVCP | Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | RS485EchoSuppress | RS485 echo suppression.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VBusSuspend | Input to detect when VBUS is present.
Public property | VendorID | Device Vendor ID (VID).

See Also

FTXSeries_EEPROM Class


FTXSeries_EEPROM Methods

The FTXSeries_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

FTXSeries_EEPROM Class


FTXSeries_EEPROM Properties

The FTXSeries_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | AC_DriveCurrent | AC Bus - Drive current of IO pins.
Public property | AC_SchmittInput | AC Bus - Schmitt trigger input.
Public property | AC_SlowSlew | AC Bus - Slow slew rate.
Public property | AD_DriveCurrent | AD Bus - Drive current of IO pins.
Public property | AD_SchmittInput | AD Bus - Schmitt trigger input.
Public property | AD_SlowSlew | AD Bus - Slow slew rate.
Public property | BCD_DeactivateSleep | Battery charge detection deactivate sleep.
Public property | BCD_Enable | Enable battery charge detection feature.
Public property | BCD_ForceCBusPowerEnable | Battery charge detection CBus power enable.
Public property | CBus0 | CBus 0 signal.
Public property | CBus1 | CBus 1 signal.
Public property | CBus2 | Cbus 2 signal.
Public property | CBus3 | CBus 3 signal.
Public property | CBus4 | CBus 4 signal.
Public property | CBus5 | CBus 5 signal.
Public property | CBus6 | CBus 6 signal.
Public property | FT1248_ClockPolarityEnable | FT1248 clock polarity enable.
Public property | FT1248_FlowControlEnable | FT1248 flow control enable
Public property | FT1248_LSB | FT1248 bit order.
Public property | I2C_DeviceID | I2C device ID.
Public property | I2C_DiableSchmitt | I2C disable schmitt trigger.
Public property | I2C_SlaveAddress | I2C slave address.
Public property | InvertCTS | Invert CTS UART line.
Public property | InvertDCD | Invert DCD UART line.
Public property | InvertDSR | Invert DSR UART line.
Public property | InvertDTR | Invert DTR UART line.
Public property | InvertRI | Invert RI UART line.
Public property | InvertRTS | Invert RTS UART line.
Public property | InvertRXD | Invert RXD UART line.
Public property | InvertTXD | Invert TXD UART line.
Public property | LoadVCP | Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | RS485EchoSuppress | RS485 echo suppression.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VBusSuspend | Input to detect when VBUS is present.
Public property | VendorID | Device Vendor ID (VID).

See Also

FTXSeries_EEPROM Class


AC_DriveCurrent Property

FTXSeries_EEPROM..::..AC_DriveCurrent Property

AC Bus - Drive current of IO pins.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AC_DriveCurrent { get; set; }
Public Property AC_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AC_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FTXSeries_EEPROM Class


AC_SchmittInput Property

FTXSeries_EEPROM..::..AC_SchmittInput Property

AC Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SchmittInput { get; set; }
Public Property AC_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AC_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


AC_SlowSlew Property

FTXSeries_EEPROM..::..AC_SlowSlew Property

AC Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AC_SlowSlew { get; set; }
Public Property AC_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AC_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


AD_DriveCurrent Property

FTXSeries_EEPROM..::..AD_DriveCurrent Property

AD Bus - Drive current of IO pins.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public DRIVE_CURRENT AD_DriveCurrent { get; set; }
Public Property AD_DriveCurrent As DRIVE_CURRENT
    Get
    Set
public:
property DRIVE_CURRENT^ AD_DriveCurrent {
    DRIVE_CURRENT^ get ();
    void set (DRIVE_CURRENT^ value);
}

See Also

FTXSeries_EEPROM Class


AD_SchmittInput Property

FTXSeries_EEPROM..::..AD_SchmittInput Property

AD Bus - Schmitt trigger input.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SchmittInput { get; set; }
Public Property AD_SchmittInput As System.Boolean
    Get
    Set
public:
property bool^ AD_SchmittInput {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


AD_SlowSlew Property

FTXSeries_EEPROM..::..AD_SlowSlew Property

AD Bus - Slow slew rate.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool AD_SlowSlew { get; set; }
Public Property AD_SlowSlew As System.Boolean
    Get
    Set
public:
property bool^ AD_SlowSlew {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


BCD_DeactivateSleep Property

FTXSeries_EEPROM..::..BCD_DeactivateSleep Property

Battery charge detection deactivate sleep.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BCD_DeactivateSleep { get; set; }
Public Property BCD_DeactivateSleep As System.Boolean
    Get
    Set
public:
property bool^ BCD_DeactivateSleep {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


BCD_Enable Property

FTXSeries_EEPROM..::..BCD_Enable Property

Enable battery charge detection feature.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BCD_Enable { get; set; }
Public Property BCD_Enable As System.Boolean
    Get
    Set
public:
property bool^ BCD_Enable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


BCD_ForceCBusPowerEnable Property

FTXSeries_EEPROM..::..BCD_ForceCBusPowerEnable Property

Battery charge detection CBus power enable.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool BCD_ForceCBusPowerEnable { get; set; }
Public Property BCD_ForceCBusPowerEnable As System.Boolean
    Get
    Set
public:
property bool^ BCD_ForceCBusPowerEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


CBus0 Property

FTXSeries_EEPROM..::..CBus0 Property

CBus 0 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus0 { get; set; }
Public Property CBus0 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus0 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus1 Property

FTXSeries_EEPROM..::..CBus1 Property

CBus 1 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus1 { get; set; }
Public Property CBus1 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus1 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus2 Property

FTXSeries_EEPROM..::..CBus2 Property

Cbus 2 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus2 { get; set; }
Public Property CBus2 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus2 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus3 Property

FTXSeries_EEPROM..::..CBus3 Property

CBus 3 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus3 { get; set; }
Public Property CBus3 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus3 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus4 Property

FTXSeries_EEPROM..::..CBus4 Property

CBus 4 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus4 { get; set; }
Public Property CBus4 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus4 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus5 Property

FTXSeries_EEPROM..::..CBus5 Property

CBus 5 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus5 { get; set; }
Public Property CBus5 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus5 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


CBus6 Property

FTXSeries_EEPROM..::..CBus6 Property

CBus 6 signal.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public CBUS_SIGNALS CBus6 { get; set; }
Public Property CBus6 As CBUS_SIGNALS
    Get
    Set
public:
property CBUS_SIGNALS^ CBus6 {
    CBUS_SIGNALS^ get ();
    void set (CBUS_SIGNALS^ value);
}

See Also

FTXSeries_EEPROM Class


FT1248_ClockPolarityEnable Property

FTXSeries_EEPROM..::..FT1248_ClockPolarityEnable Property

FT1248 clock polarity enable.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_ClockPolarityEnable { get; set; }
Public Property FT1248_ClockPolarityEnable As System.Boolean
    Get
    Set
public:
property bool^ FT1248_ClockPolarityEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


FT1248_FlowControlEnable Property

FTXSeries_EEPROM..::..FT1248_FlowControlEnable Property

FT1248 flow control enable

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_FlowControlEnable { get; set; }
Public Property FT1248_FlowControlEnable As System.Boolean
    Get
    Set
public:
property bool^ FT1248_FlowControlEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


FT1248_LSB Property

FTXSeries_EEPROM..::..FT1248_LSB Property

FT1248 bit order.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool FT1248_LSB { get; set; }
Public Property FT1248_LSB As System.Boolean
    Get
    Set
public:
property bool^ FT1248_LSB {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


I2C_DeviceID Property

FTXSeries_EEPROM..::..I2C_DeviceID Property

I2C device ID.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public uint I2C_DeviceID { get; set; }
Public Property I2C_DeviceID As UInteger
    Get
    Set
public:
property unsigned int^ I2C_DeviceID {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

See Also

FTXSeries_EEPROM Class


I2C_DiableSchmitt Property

FTXSeries_EEPROM..::..I2C_DiableSchmitt Property

I2C disable schmitt trigger.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool I2C_DiableSchmitt { get; set; }
Public Property I2C_DiableSchmitt As System.Boolean
    Get
    Set
public:
property bool^ I2C_DiableSchmitt {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


I2C_SlaveAddress Property

FTXSeries_EEPROM..::..I2C_SlaveAddress Property

I2C slave address.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort I2C_SlaveAddress { get; set; }
Public Property I2C_SlaveAddress As UShort
    Get
    Set
public:
property unsigned short^ I2C_SlaveAddress {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FTXSeries_EEPROM Class


InvertCTS Property

FTXSeries_EEPROM..::..InvertCTS Property

Invert CTS UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertCTS { get; set; }
Public Property InvertCTS As System.Boolean
    Get
    Set
public:
property bool^ InvertCTS {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertDCD Property

FTXSeries_EEPROM..::..InvertDCD Property

Invert DCD UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDCD { get; set; }
Public Property InvertDCD As System.Boolean
    Get
    Set
public:
property bool^ InvertDCD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertDSR Property

FTXSeries_EEPROM..::..InvertDSR Property

Invert DSR UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDSR { get; set; }
Public Property InvertDSR As System.Boolean
    Get
    Set
public:
property bool^ InvertDSR {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertDTR Property

FTXSeries_EEPROM..::..InvertDTR Property

Invert DTR UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertDTR { get; set; }
Public Property InvertDTR As System.Boolean
    Get
    Set
public:
property bool^ InvertDTR {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertRI Property

FTXSeries_EEPROM..::..InvertRI Property

Invert RI UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRI { get; set; }
Public Property InvertRI As System.Boolean
    Get
    Set
public:
property bool^ InvertRI {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertRTS Property

FTXSeries_EEPROM..::..InvertRTS Property

Invert RTS UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRTS { get; set; }
Public Property InvertRTS As System.Boolean
    Get
    Set
public:
property bool^ InvertRTS {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertRXD Property

FTXSeries_EEPROM..::..InvertRXD Property

Invert RXD UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertRXD { get; set; }
Public Property InvertRXD As System.Boolean
    Get
    Set
public:
property bool^ InvertRXD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


InvertTXD Property

FTXSeries_EEPROM..::..InvertTXD Property

Invert TXD UART line.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool InvertTXD { get; set; }
Public Property InvertTXD As System.Boolean
    Get
    Set
public:
property bool^ InvertTXD {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


LoadVCP Property

FTXSeries_EEPROM..::..LoadVCP Property

Load Virtual COM Port driver. If true the D2xx driver layer will expose the VCP layer of the driver.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool LoadVCP { get; set; }
Public Property LoadVCP As System.Boolean
    Get
    Set
public:
property bool^ LoadVCP {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


Manufacturer Property

FTXSeries_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Manufacturer { get; set; }
Public Property Manufacturer As System.String
    Get
    Set
public:
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FTXSeries_EEPROM Class


MaxPower Property

FTXSeries_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort MaxPower { get; set; }
Public Property MaxPower As UShort
    Get
    Set
public:
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FTXSeries_EEPROM Class


Product Property

FTXSeries_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As System.String
    Get
    Set
public:
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FTXSeries_EEPROM Class


ProductID Property

FTXSeries_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort ProductID { get; set; }
Public Property ProductID As UShort
    Get
    Set
public:
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FTXSeries_EEPROM Class


PullDownEnable Property

FTXSeries_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool PullDownEnable { get; set; }
Public Property PullDownEnable As System.Boolean
    Get
    Set
public:
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


RemoteWakeupEnable Property

FTXSeries_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RemoteWakeupEnable { get; set; }
Public Property RemoteWakeupEnable As System.Boolean
    Get
    Set
public:
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


RS485EchoSuppress Property

FTXSeries_EEPROM..::..RS485EchoSuppress Property

RS485 echo suppression.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool RS485EchoSuppress { get; set; }
Public Property RS485EchoSuppress As System.Boolean
    Get
    Set
public:
property bool^ RS485EchoSuppress {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


SelfPowered Property

FTXSeries_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SelfPowered { get; set; }
Public Property SelfPowered As System.Boolean
    Get
    Set
public:
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


SerialNumber Property

FTXSeries_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public string SerialNumber { get; set; }
Public Property SerialNumber As System.String
    Get
    Set
public:
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

FTXSeries_EEPROM Class


SerialNumberEnable Property

FTXSeries_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool SerialNumberEnable { get; set; }
Public Property SerialNumberEnable As System.Boolean
    Get
    Set
public:
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


UsbVersion Property

FTXSeries_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public USB_VERSION UsbVersion { get; set; }
Public Property UsbVersion As USB_VERSION
    Get
    Set
public:
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

FTXSeries_EEPROM Class


VBusSuspend Property

FTXSeries_EEPROM..::..VBusSuspend Property

Input to detect when VBUS is present.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public bool VBusSuspend { get; set; }
Public Property VBusSuspend As System.Boolean
    Get
    Set
public:
property bool^ VBusSuspend {
    bool^ get ();
    void set (bool^ value);
}

See Also

FTXSeries_EEPROM Class


VendorID Property

FTXSeries_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public ushort VendorID { get; set; }
Public Property VendorID As UShort
    Get
    Set
public:
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

FTXSeries_EEPROM Class


IFT_EEPROM Interface

Interface that represents the contents of a generic FTDI device EEPROM.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public interface IFT_EEPROM
Public Interface IFT_EEPROM
public interface class IFT_EEPROM

See Also

IFT_EEPROM Members


IFT_EEPROM Members

The IFT_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

IFT_EEPROM Interface


IFT_EEPROM Methods

The IFT_EEPROM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from System.Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from System.Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from System.Object.)
Public method | GetType | Gets the System.Type of the current instance. (Inherited from System.Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current System.Object. (Inherited from System.Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from System.Object.)

See Also

IFT_EEPROM Interface


IFT_EEPROM Properties

The IFT_EEPROM type exposes the following members.

Properties

 | Name | Description
Public property | Manufacturer | Manufacturer string descriptor.
Public property | MaxPower | USB max power. The max current that this device can draw from the USB port (500mA max).
Public property | Product | Product description string descriptor.
Public property | ProductID | Device Product ID (PID).
Public property | PullDownEnable | Pull down enable in USB suspend.
Public property | RemoteWakeupEnable | Remote wakeup enable. Allow the device to wake the machine from a low power state.
Public property | SelfPowered | Self powered device. This device must provide its own power source and cannot rely on USB power.
Public property | SerialNumber | Serial number string descriptor.
Public property | SerialNumberEnable | Enable the serial number on this device.
Public property | UsbVersion | The USB revision number.
Public property | VendorID | Device Vendor ID (VID).

See Also

IFT_EEPROM Interface


Manufacturer Property

IFT_EEPROM..::..Manufacturer Property

Manufacturer string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string Manufacturer { get; set; }
Property Manufacturer As System.String
    Get
    Set
property System.String^ Manufacturer {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

IFT_EEPROM Interface


MaxPower Property

IFT_EEPROM..::..MaxPower Property

USB max power. The max current that this device can draw from the USB port (500mA max).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
ushort MaxPower { get; set; }
Property MaxPower As UShort
    Get
    Set
property unsigned short^ MaxPower {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

IFT_EEPROM Interface


Product Property

IFT_EEPROM..::..Product Property

Product description string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string Product { get; set; }
Property Product As System.String
    Get
    Set
property System.String^ Product {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

IFT_EEPROM Interface


ProductID Property

IFT_EEPROM..::..ProductID Property

Device Product ID (PID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
ushort ProductID { get; set; }
Property ProductID As UShort
    Get
    Set
property unsigned short^ ProductID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

IFT_EEPROM Interface


PullDownEnable Property

IFT_EEPROM..::..PullDownEnable Property

Pull down enable in USB suspend.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool PullDownEnable { get; set; }
Property PullDownEnable As System.Boolean
    Get
    Set
property bool^ PullDownEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

IFT_EEPROM Interface


RemoteWakeupEnable Property

IFT_EEPROM..::..RemoteWakeupEnable Property

Remote wakeup enable. Allow the device to wake the machine from a low power state.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool RemoteWakeupEnable { get; set; }
Property RemoteWakeupEnable As System.Boolean
    Get
    Set
property bool^ RemoteWakeupEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

IFT_EEPROM Interface


SelfPowered Property

IFT_EEPROM..::..SelfPowered Property

Self powered device. This device must provide its own power source and cannot rely on USB power.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool SelfPowered { get; set; }
Property SelfPowered As System.Boolean
    Get
    Set
property bool^ SelfPowered {
    bool^ get ();
    void set (bool^ value);
}

See Also

IFT_EEPROM Interface


SerialNumber Property

IFT_EEPROM..::..SerialNumber Property

Serial number string descriptor.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
string SerialNumber { get; set; }
Property SerialNumber As System.String
    Get
    Set
property System.String^ SerialNumber {
    System.String^ get ();
    void set (System.String^ value);
}

See Also

IFT_EEPROM Interface


SerialNumberEnable Property

IFT_EEPROM..::..SerialNumberEnable Property

Enable the serial number on this device.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
bool SerialNumberEnable { get; set; }
Property SerialNumberEnable As System.Boolean
    Get
    Set
property bool^ SerialNumberEnable {
    bool^ get ();
    void set (bool^ value);
}

See Also

IFT_EEPROM Interface


UsbVersion Property

IFT_EEPROM..::..UsbVersion Property

The USB revision number.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
USB_VERSION UsbVersion { get; set; }
Property UsbVersion As USB_VERSION
    Get
    Set
property USB_VERSION^ UsbVersion {
    USB_VERSION^ get ();
    void set (USB_VERSION^ value);
}

See Also

IFT_EEPROM Interface


VendorID Property

IFT_EEPROM..::..VendorID Property

Device Vendor ID (VID).

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
ushort VendorID { get; set; }
Property VendorID As UShort
    Get
    Set
property unsigned short^ VendorID {
    unsigned short^ get ();
    void set (unsigned short^ value);
}

See Also

IFT_EEPROM Interface


USB_VERSION Enumeration

USB Version

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum USB_VERSION
Public Enumeration USB_VERSION
public enum class USB_VERSION

Members

Member name | Description
USB_20 | USB 2.0
USB_11 | USB 1.1

See Also


FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace

Enumerations

 | Enumeration | Description
Public enumeration | DEVICE_INTERFACE | FT2232D device interfaces


DEVICE_INTERFACE Enumeration

FT2232D device interfaces

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232D
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DEVICE_INTERFACE
Public Enumeration DEVICE_INTERFACE
public enum class DEVICE_INTERFACE

Members

Member name | Description
UART | UART mode.
FIFO | FIFO 245 mode.
FIFO_CPU_Target | FIFO CPU style interface.
FIFO_OPTO_ISOLATE | FIFO mode to optically isolate an external device from USB.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace


FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace

Enumerations

 | Enumeration | Description
Public enumeration | DEVICE_INTERFACE | Device interface mode.
Public enumeration | DRIVE_CURRENT | Device IO drive current.


DEVICE_INTERFACE Enumeration

Device interface mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DEVICE_INTERFACE
Public Enumeration DEVICE_INTERFACE
public enum class DEVICE_INTERFACE

Members

Member name | Description
UART | UART mode.
FIFO | FIFO 245 mode.
FIFO_CPU_Target | FIFO CPU style interface.
FIFO_OPTO_ISOLATE | FIFO mode to optically isolate an external device from USB.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


DRIVE_CURRENT Enumeration

Device IO drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DRIVE_CURRENT
Public Enumeration DRIVE_CURRENT
public enum class DRIVE_CURRENT

Members

Member name | Description
DRIVE_4mA | 4mA drive current.
DRIVE_8mA | 8mA drive current.
DRIVE_12mA | 12mA drive current.
DRIVE_16mA | 16mA drive current.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace

Enumerations

 | Enumeration | Description
Public enumeration | CBUS_SIGNALS | FT232H CBus signals.
Public enumeration | DEVICE_INTERFACE | FT232H device interfaces
Public enumeration | DRIVE_CURRENT | Device IO drive current.


CBUS_SIGNALS Enumeration

FT232H CBus signals.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum CBUS_SIGNALS
Public Enumeration CBUS_SIGNALS
public enum class CBUS_SIGNALS

Members

Member name | Description
TRISTATE | IO pad is tri-stated.
RXLED | Receive data LED drive – pulses low when receiving data via USB.
TXLED | Transmit data LED drive – pulses low when transmitting data via USB.
TXRXLED | Transmit data LED drive – pulses low when transmitting data via USB.
PWREN | Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.
SLEEP | Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.
DRIVE_0 | Output a constant 0.
DRIVE_1 | Output a constant 1.
GPIO_MODE | CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal MTP memory.
TXDEN | Enable transmit data for RS485.
CLK30MHZ | 30 MHz Clock output.
CLK15MHZ | 15 MHz Clock output.
CLK7_5MHZ | 7.5 MHz Clock output.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DEVICE_INTERFACE Enumeration

FT232H device interfaces

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DEVICE_INTERFACE
Public Enumeration DEVICE_INTERFACE
public enum class DEVICE_INTERFACE

Members

Member name | Description
UART | UART mode.
FIFO | FIFO 245 mode.
FIFO_CPU_Target | FIFO CPU style interface.
FIFO_OPTO_ISOLATE | FIFO mode to optically isolate an external device from USB.
FT1248 | FT1248 interface.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_CURRENT Enumeration

Device IO drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DRIVE_CURRENT
Public Enumeration DRIVE_CURRENT
public enum class DRIVE_CURRENT

Members

Member name | Description
DRIVE_4mA | 4mA drive current.
DRIVE_8mA | 8mA drive current.
DRIVE_12mA | 12mA drive current.
DRIVE_16mA | 16mA drive current.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace

Enumerations

 | Enumeration | Description
Public enumeration | CBUS_SIGNALS | FT232R CBus signals.


CBUS_SIGNALS Enumeration

FT232R CBus signals.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum CBUS_SIGNALS
Public Enumeration CBUS_SIGNALS
public enum class CBUS_SIGNALS

Members

Member name | Description
TXDEN | Enable transmit data for RS485.
PWREN | Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.
RXLED | Receive data LED drive: Data from FT232R to USB Host. Pulses low when receiving data via USB. See Section 7.5 for more details.
TXLED | Transmit data LED drive: Data from USB Host to FT232R. Pulses low when transmitting data via USB.
TXRXLED | LED drive – pulses low when transmitting or receiving data via USB.
SLEEP | Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.
CLK48MHZ | 48MHz ±0.7% Clock output.
CLK24MHZ | 24 MHz Clock output.
CLK12MHZ | 12 MHz Clock output.
CLK6MHZ | 6 MHz ±0.7% Clock output.
IO_MODE | CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal EEPROM. A separate application note, AN232R-01, available from FTDI website (www.ftdichip.com) describes in more detail how to use CBUS bit bang mode.
BITBANG_WR | Synchronous and asynchronous bit bang mode WR# strobe output.
BITBANG_RD | Synchronous and asynchronous bit bang mode RD# strobe output.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace

Enumerations

 | Enumeration | Description
Public enumeration | DRIVE_CURRENT | Device IO drive current.


DRIVE_CURRENT Enumeration

Device IO drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT4232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DRIVE_CURRENT
Public Enumeration DRIVE_CURRENT
public enum class DRIVE_CURRENT

Members

Member name | Description
DRIVE_4mA | 4mA drive current.
DRIVE_8mA | 8mA drive current.
DRIVE_12mA | 12mA drive current.
DRIVE_16mA | 16mA drive current.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace


FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace

Enumerations

 | Enumeration | Description
Public enumeration | CBUS_SIGNALS | FT X-Series CBus signals.
Public enumeration | DRIVE_CURRENT | FT X-Series drive current.


CBUS_SIGNALS Enumeration

FT X-Series CBus signals.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum CBUS_SIGNALS
Public Enumeration CBUS_SIGNALS
public enum class CBUS_SIGNALS

Members

Member name | Description
TRISTATE | IO pad is tri-stated.
RXLED | Receive data LED drive – pulses low when receiving data via USB.
TXLED | Transmit data LED drive – pulses low when transmitting data via USB.
TXRXLED | LED drive – pulses low when transmitting or receiving data via USB.
PWREN | Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.
SLEEP | Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.
DRIVE_0 | Output a constant 0.
DRIVE_1 | Output a constant 1.
GPIO_MODE | CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal MTP memory.
TXDEN | Enable transmit data for RS485.
CLK24MHZ | 24 MHz Clock output.
CLK12MHZ | 12 MHz Clock output.
CLK6MHZ | 6 MHz Clock output.
BCD_CHARGE | Battery charge Detect, indicates when the device is connected to a dedicated battery charger host. Active high output.
BCD_CHARGE_N | Inverse of BCD Charger.
I2C_TXE | Transmit buffer empty, used to indicate to I2C master device status of the FT200XD transmit buffer.
I2C_RXF | Receive buffer full, used to indicate to I2C master device status of FT200XD receive buffer
VBUS_SENSE | Input to detect when VBUS is present.
BITBANG_WR | Synchronous and asynchronous bit bang mode WR# strobe output.
BITBANG_RD | Synchronous and asynchronous bit bang mode RD# strobe output.
TIME_STAMP | Toggle signal which changes state each time a USB SOF is received
KEEP_AWAKE | Prevents the device from entering suspend state when unplugged.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_CURRENT Enumeration

FT X-Series drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public enum DRIVE_CURRENT
Public Enumeration DRIVE_CURRENT
public enum class DRIVE_CURRENT

Members

Member name | Description
DRIVE_4mA | Drive strength 4mA.
DRIVE_8mA | Drive strength 8mA.
DRIVE_12mA | Drive strength 12mA.
DRIVE_16mA | Drive strength 16mA.

See Also

FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_16mA Field

DRIVE_CURRENT..::..DRIVE_16mA Field

Drive strength 16mA.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_16mA
Public Const DRIVE_16mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_16mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


FIFO_OPTO_ISOLATE Field

DEVICE_INTERFACE..::..FIFO_OPTO_ISOLATE Field

FIFO mode to optically isolate an external device from USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232D
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_OPTO_ISOLATE
Public Const FIFO_OPTO_ISOLATE As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_OPTO_ISOLATE

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace


BITS_7 Field

WORD_LENGTH..::..BITS_7 Field

7 bit data length.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const WORD_LENGTH BITS_7
Public Const BITS_7 As WORD_LENGTH
public:
literal WORD_LENGTH BITS_7

See Also

WORD_LENGTH Enumeration
FTDI.D2xx.WinRT.Device Namespace


NONE Field

FLOW_CONTROL..::..NONE Field

No flow control.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const FLOW_CONTROL NONE
Public Const NONE As FLOW_CONTROL
public:
literal FLOW_CONTROL NONE

See Also

FLOW_CONTROL Enumeration
FTDI.D2xx.WinRT.Device Namespace


DRIVE_12mA Field

DRIVE_CURRENT..::..DRIVE_12mA Field

12mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_12mA
Public Const DRIVE_12mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_12mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_16mA Field

DRIVE_CURRENT..::..DRIVE_16mA Field

16mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_16mA
Public Const DRIVE_16mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_16mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


MARK Field

PARITY..::..MARK Field

Mark parity (bit is always 1).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const PARITY MARK
Public Const MARK As PARITY
public:
literal PARITY MARK

See Also

PARITY Enumeration
FTDI.D2xx.WinRT.Device Namespace


TXRXLED Field

CBUS_SIGNALS..::..TXRXLED Field

LED drive – pulses low when transmitting or receiving data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXRXLED
Public Const TXRXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXRXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


SYNC_FIFO Field

BIT_MODE..::..SYNC_FIFO Field

Single channel synchronous FIFO (FT2232H port A and FT232H only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE SYNC_FIFO
Public Const SYNC_FIFO As BIT_MODE
public:
literal BIT_MODE SYNC_FIFO

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


TIME_STAMP Field

CBUS_SIGNALS..::..TIME_STAMP Field

Toggle signal which changes state each time a USB SOF is received

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TIME_STAMP
Public Const TIME_STAMP As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TIME_STAMP

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


KEEP_AWAKE Field

CBUS_SIGNALS..::..KEEP_AWAKE Field

Prevents the device from entering suspend state when unplugged.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS KEEP_AWAKE
Public Const KEEP_AWAKE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS KEEP_AWAKE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


CLK12MHZ Field

CBUS_SIGNALS..::..CLK12MHZ Field

12 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK12MHZ
Public Const CLK12MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK12MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


UART Field

DEVICE_INTERFACE..::..UART Field

UART mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE UART
Public Const UART As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE UART

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


XON_XOFF Field

FLOW_CONTROL..::..XON_XOFF Field

XON/XOFF software flow control.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const FLOW_CONTROL XON_XOFF
Public Const XON_XOFF As FLOW_CONTROL
public:
literal FLOW_CONTROL XON_XOFF

See Also

FLOW_CONTROL Enumeration
FTDI.D2xx.WinRT.Device Namespace


CLK24MHZ Field

CBUS_SIGNALS..::..CLK24MHZ Field

24 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK24MHZ
Public Const CLK24MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK24MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


FT2232H Field

DEVICE_TYPE..::..FT2232H Field

FT2232H device (dual channel high speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT2232H
Public Const FT2232H As DEVICE_TYPE
public:
literal DEVICE_TYPE FT2232H

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


EVEN Field

PARITY..::..EVEN Field

Even parity.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const PARITY EVEN
Public Const EVEN As PARITY
public:
literal PARITY EVEN

See Also

PARITY Enumeration
FTDI.D2xx.WinRT.Device Namespace


FIFO Field

DEVICE_INTERFACE..::..FIFO Field

FIFO 245 mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO
Public Const FIFO As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


BITBANG_RD Field

CBUS_SIGNALS..::..BITBANG_RD Field

Synchronous and asynchronous bit bang mode RD# strobe output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BITBANG_RD
Public Const BITBANG_RD As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BITBANG_RD

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


BITBANG_WR Field

CBUS_SIGNALS..::..BITBANG_WR Field

Synchronous and asynchronous bit bang mode WR# strobe output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BITBANG_WR
Public Const BITBANG_WR As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BITBANG_WR

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


BITS_2 Field

STOP_BITS..::..BITS_2 Field

2 stop bits.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const STOP_BITS BITS_2
Public Const BITS_2 As STOP_BITS
public:
literal STOP_BITS BITS_2

See Also

STOP_BITS Enumeration
FTDI.D2xx.WinRT.Device Namespace


BITS_1 Field

STOP_BITS..::..BITS_1 Field

1 stop bit.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const STOP_BITS BITS_1
Public Const BITS_1 As STOP_BITS
public:
literal STOP_BITS BITS_1

See Also

STOP_BITS Enumeration
FTDI.D2xx.WinRT.Device Namespace


BITBANG_WR Field

CBUS_SIGNALS..::..BITBANG_WR Field

Synchronous and asynchronous bit bang mode WR# strobe output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BITBANG_WR
Public Const BITBANG_WR As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BITBANG_WR

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


FIFO_CPU_Target Field

DEVICE_INTERFACE..::..FIFO_CPU_Target Field

FIFO CPU style interface.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232D
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_CPU_Target
Public Const FIFO_CPU_Target As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_CPU_Target

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace


FIFO Field

DEVICE_INTERFACE..::..FIFO Field

FIFO 245 mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO
Public Const FIFO As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


ODD Field

PARITY..::..ODD Field

Odd parity.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const PARITY ODD
Public Const ODD As PARITY
public:
literal PARITY ODD

See Also

PARITY Enumeration
FTDI.D2xx.WinRT.Device Namespace


TXRXLED Field

CBUS_SIGNALS..::..TXRXLED Field

LED drive – pulses low when transmitting or receiving data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXRXLED
Public Const TXRXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXRXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


TRISTATE Field

CBUS_SIGNALS..::..TRISTATE Field

IO pad is tri-stated.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TRISTATE
Public Const TRISTATE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TRISTATE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


CLK48MHZ Field

CBUS_SIGNALS..::..CLK48MHZ Field

48MHz ±0.7% Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK48MHZ
Public Const CLK48MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK48MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


DRIVE_0 Field

CBUS_SIGNALS..::..DRIVE_0 Field

Output a constant 0.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS DRIVE_0
Public Const DRIVE_0 As CBUS_SIGNALS
public:
literal CBUS_SIGNALS DRIVE_0

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


FIFO_CPU_Target Field

DEVICE_INTERFACE..::..FIFO_CPU_Target Field

FIFO CPU style interface.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_CPU_Target
Public Const FIFO_CPU_Target As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_CPU_Target

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


FIFO Field

DEVICE_INTERFACE..::..FIFO Field

FIFO 245 mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232D
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO
Public Const FIFO As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace


CLK6MHZ Field

CBUS_SIGNALS..::..CLK6MHZ Field

6 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK6MHZ
Public Const CLK6MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK6MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


CLK30MHZ Field

CBUS_SIGNALS..::..CLK30MHZ Field

30 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK30MHZ
Public Const CLK30MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK30MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_0 Field

CBUS_SIGNALS..::..DRIVE_0 Field

Output a constant 0.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS DRIVE_0
Public Const DRIVE_0 As CBUS_SIGNALS
public:
literal CBUS_SIGNALS DRIVE_0

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_1 Field

CBUS_SIGNALS..::..DRIVE_1 Field

Output a constant 1.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS DRIVE_1
Public Const DRIVE_1 As CBUS_SIGNALS
public:
literal CBUS_SIGNALS DRIVE_1

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_12mA Field

DRIVE_CURRENT..::..DRIVE_12mA Field

Drive strength 12mA.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_12mA
Public Const DRIVE_12mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_12mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


SLEEP Field

CBUS_SIGNALS..::..SLEEP Field

Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS SLEEP
Public Const SLEEP As CBUS_SIGNALS
public:
literal CBUS_SIGNALS SLEEP

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


GPIO_MODE Field

CBUS_SIGNALS..::..GPIO_MODE Field

CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal MTP memory.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS GPIO_MODE
Public Const GPIO_MODE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS GPIO_MODE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


CLK6MHZ Field

CBUS_SIGNALS..::..CLK6MHZ Field

6 MHz ±0.7% Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK6MHZ
Public Const CLK6MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK6MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


IO_MODE Field

CBUS_SIGNALS..::..IO_MODE Field

CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal EEPROM. A separate application note, AN232R-01, available from FTDI website (www.ftdichip.com) describes in more detail how to use CBUS bit bang mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS IO_MODE
Public Const IO_MODE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS IO_MODE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


TXRXLED Field

CBUS_SIGNALS..::..TXRXLED Field

Transmit data LED drive – pulses low when transmitting data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXRXLED
Public Const TXRXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXRXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


MPSSE Field

BIT_MODE..::..MPSSE Field

MPSSE (FT2232D, FT2232H, FT4232H and FT232H only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE MPSSE
Public Const MPSSE As BIT_MODE
public:
literal BIT_MODE MPSSE

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


I2C_RXF Field

CBUS_SIGNALS..::..I2C_RXF Field

Receive buffer full, used to indicate to I2C master device status of FT200XD receive buffer

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS I2C_RXF
Public Const I2C_RXF As CBUS_SIGNALS
public:
literal CBUS_SIGNALS I2C_RXF

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_8mA Field

DRIVE_CURRENT..::..DRIVE_8mA Field

8mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_8mA
Public Const DRIVE_8mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_8mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


DRIVE_4mA Field

DRIVE_CURRENT..::..DRIVE_4mA Field

4mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_4mA
Public Const DRIVE_4mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_4mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


BCD_CHARGE_N Field

CBUS_SIGNALS..::..BCD_CHARGE_N Field

Inverse of BCD Charger.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BCD_CHARGE_N
Public Const BCD_CHARGE_N As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BCD_CHARGE_N

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


PWREN Field

CBUS_SIGNALS..::..PWREN Field

Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS PWREN
Public Const PWREN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS PWREN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


FT232H Field

DEVICE_TYPE..::..FT232H Field

FT232H device (single channel high speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT232H
Public Const FT232H As DEVICE_TYPE
public:
literal DEVICE_TYPE FT232H

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


SYNC_BITBANG Field

BIT_MODE..::..SYNC_BITBANG Field

Synchronous bit bang (FT2232D, FT232R, FT4232H, FT232H and FT X-Series only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE SYNC_BITBANG
Public Const SYNC_BITBANG As BIT_MODE
public:
literal BIT_MODE SYNC_BITBANG

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


UART Field

DEVICE_INTERFACE..::..UART Field

UART mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232D
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE UART
Public Const UART As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE UART

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232D Namespace


USB_11 Field

USB_VERSION..::..USB_11 Field

USB 1.1

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const USB_VERSION USB_11
Public Const USB_11 As USB_VERSION
public:
literal USB_VERSION USB_11

See Also

USB_VERSION Enumeration


USB_20 Field

USB_VERSION..::..USB_20 Field

USB 2.0

Namespace: FTDI.D2xx.WinRT.Device.EEPROM
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const USB_VERSION USB_20
Public Const USB_20 As USB_VERSION
public:
literal USB_VERSION USB_20

See Also

USB_VERSION Enumeration


FIFO_OPTO_ISOLATE Field

DEVICE_INTERFACE..::..FIFO_OPTO_ISOLATE Field

FIFO mode to optically isolate an external device from USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_OPTO_ISOLATE
Public Const FIFO_OPTO_ISOLATE As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_OPTO_ISOLATE

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


RXLED Field

CBUS_SIGNALS..::..RXLED Field

Receive data LED drive – pulses low when receiving data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS RXLED
Public Const RXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS RXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


ASYNC_BITBANG Field

BIT_MODE..::..ASYNC_BITBANG Field

Asynchronous bit bang.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE ASYNC_BITBANG
Public Const ASYNC_BITBANG As BIT_MODE
public:
literal BIT_MODE ASYNC_BITBANG

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


TXDEN Field

CBUS_SIGNALS..::..TXDEN Field

Enable transmit data for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXDEN
Public Const TXDEN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXDEN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


FIFO_OPTO_ISOLATE Field

DEVICE_INTERFACE..::..FIFO_OPTO_ISOLATE Field

FIFO mode to optically isolate an external device from USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_OPTO_ISOLATE
Public Const FIFO_OPTO_ISOLATE As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_OPTO_ISOLATE

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


PWREN Field

CBUS_SIGNALS..::..PWREN Field

Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS PWREN
Public Const PWREN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS PWREN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


RTS_CTS Field

FLOW_CONTROL..::..RTS_CTS Field

RTS/CTS hardware flow control.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const FLOW_CONTROL RTS_CTS
Public Const RTS_CTS As FLOW_CONTROL
public:
literal FLOW_CONTROL RTS_CTS

See Also

FLOW_CONTROL Enumeration
FTDI.D2xx.WinRT.Device Namespace


SLEEP Field

CBUS_SIGNALS..::..SLEEP Field

Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS SLEEP
Public Const SLEEP As CBUS_SIGNALS
public:
literal CBUS_SIGNALS SLEEP

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


SPACE Field

PARITY..::..SPACE Field

Space parity (bit is always 0).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const PARITY SPACE
Public Const SPACE As PARITY
public:
literal PARITY SPACE

See Also

PARITY Enumeration
FTDI.D2xx.WinRT.Device Namespace


FT232AM Field

DEVICE_TYPE..::..FT232AM Field

FT232AM device (single channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT232AM
Public Const FT232AM As DEVICE_TYPE
public:
literal DEVICE_TYPE FT232AM

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


TXDEN Field

CBUS_SIGNALS..::..TXDEN Field

Enable transmit data for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXDEN
Public Const TXDEN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXDEN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


FTXSeries Field

DEVICE_TYPE..::..FTXSeries Field

FT X-Series device (single channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FTXSeries
Public Const FTXSeries As DEVICE_TYPE
public:
literal DEVICE_TYPE FTXSeries

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


CLK15MHZ Field

CBUS_SIGNALS..::..CLK15MHZ Field

15 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK15MHZ
Public Const CLK15MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK15MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


CLK24MHZ Field

CBUS_SIGNALS..::..CLK24MHZ Field

24 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK24MHZ
Public Const CLK24MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK24MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_4mA Field

DRIVE_CURRENT..::..DRIVE_4mA Field

Drive strength 4mA.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_4mA
Public Const DRIVE_4mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_4mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


TXLED Field

CBUS_SIGNALS..::..TXLED Field

Transmit data LED drive – pulses low when transmitting data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXLED
Public Const TXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


BITS_8 Field

WORD_LENGTH..::..BITS_8 Field

8 bit data length.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const WORD_LENGTH BITS_8
Public Const BITS_8 As WORD_LENGTH
public:
literal WORD_LENGTH BITS_8

See Also

WORD_LENGTH Enumeration
FTDI.D2xx.WinRT.Device Namespace


I2C_TXE Field

CBUS_SIGNALS..::..I2C_TXE Field

Transmit buffer empty, used to indicate to I2C master device status of the FT200XD transmit buffer.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS I2C_TXE
Public Const I2C_TXE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS I2C_TXE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_4mA Field

DRIVE_CURRENT..::..DRIVE_4mA Field

4mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_4mA
Public Const DRIVE_4mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_4mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


RXLED Field

CBUS_SIGNALS..::..RXLED Field

Receive data LED drive – pulses low when receiving data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS RXLED
Public Const RXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS RXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


TXLED Field

CBUS_SIGNALS..::..TXLED Field

Transmit data LED drive – pulses low when transmitting data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXLED
Public Const TXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_8mA Field

DRIVE_CURRENT..::..DRIVE_8mA Field

Drive strength 8mA.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_8mA
Public Const DRIVE_8mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_8mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


UART Field

DEVICE_INTERFACE..::..UART Field

UART mode.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE UART
Public Const UART As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE UART

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


NONE Field

PARITY..::..NONE Field

No parity.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const PARITY NONE
Public Const NONE As PARITY
public:
literal PARITY NONE

See Also

PARITY Enumeration
FTDI.D2xx.WinRT.Device Namespace


FT232BM Field

DEVICE_TYPE..::..FT232BM Field

FT232BM device (single channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT232BM
Public Const FT232BM As DEVICE_TYPE
public:
literal DEVICE_TYPE FT232BM

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


RESET Field

BIT_MODE..::..RESET Field

Reset bit mode (off).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE RESET
Public Const RESET As BIT_MODE
public:
literal BIT_MODE RESET

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


DRIVE_16mA Field

DRIVE_CURRENT..::..DRIVE_16mA Field

16mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT4232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_16mA
Public Const DRIVE_16mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_16mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace


DRIVE_12mA Field

DRIVE_CURRENT..::..DRIVE_12mA Field

12mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT4232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_12mA
Public Const DRIVE_12mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_12mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace


BITBANG_RD Field

CBUS_SIGNALS..::..BITBANG_RD Field

Synchronous and asynchronous bit bang mode RD# strobe output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BITBANG_RD
Public Const BITBANG_RD As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BITBANG_RD

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


FT2232D Field

DEVICE_TYPE..::..FT2232D Field

FT2232D device (dual channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT2232D
Public Const FT2232D As DEVICE_TYPE
public:
literal DEVICE_TYPE FT2232D

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


SLEEP Field

CBUS_SIGNALS..::..SLEEP Field

Goes low during USB suspend mode. Typically used to power down an external TTL to RS232 level converter IC in USB to RS232 converter designs.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS SLEEP
Public Const SLEEP As CBUS_SIGNALS
public:
literal CBUS_SIGNALS SLEEP

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_8mA Field

DRIVE_CURRENT..::..DRIVE_8mA Field

8mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT4232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_8mA
Public Const DRIVE_8mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_8mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace


DRIVE_4mA Field

DRIVE_CURRENT..::..DRIVE_4mA Field

4mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT4232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_4mA
Public Const DRIVE_4mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_4mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT4232H Namespace


MCU_HOST Field

BIT_MODE..::..MCU_HOST Field

MPSSE CPU emulation (FT2232D, FT2232H, FT4232H and FT232H only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE MCU_HOST
Public Const MCU_HOST As BIT_MODE
public:
literal BIT_MODE MCU_HOST

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


VBUS_SENSE Field

CBUS_SIGNALS..::..VBUS_SENSE Field

Input to detect when VBUS is present.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS VBUS_SENSE
Public Const VBUS_SENSE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS VBUS_SENSE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


FT232R Field

DEVICE_TYPE..::..FT232R Field

FT232R device (single channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT232R
Public Const FT232R As DEVICE_TYPE
public:
literal DEVICE_TYPE FT232R

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


FT245R Field

DEVICE_TYPE..::..FT245R Field

FT245R device (single channel full speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT245R
Public Const FT245R As DEVICE_TYPE
public:
literal DEVICE_TYPE FT245R

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


CLK12MHZ Field

CBUS_SIGNALS..::..CLK12MHZ Field

12 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK12MHZ
Public Const CLK12MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK12MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DRIVE_12mA Field

DRIVE_CURRENT..::..DRIVE_12mA Field

12mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_12mA
Public Const DRIVE_12mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_12mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


DRIVE_16mA Field

DRIVE_CURRENT..::..DRIVE_16mA Field

16mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT2232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_16mA
Public Const DRIVE_16mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_16mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT2232H Namespace


TRISTATE Field

CBUS_SIGNALS..::..TRISTATE Field

IO pad is tri-stated.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TRISTATE
Public Const TRISTATE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TRISTATE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


PWREN Field

CBUS_SIGNALS..::..PWREN Field

Output is low after the device has been configured by USB, then high during USB suspend mode. This output can be used to control power to external logic P-Channel logic level MOSFET switch. Enable the interface pull-down option when using the PWREN# in this way.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS PWREN
Public Const PWREN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS PWREN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


CLK7_5MHZ Field

CBUS_SIGNALS..::..CLK7_5MHZ Field

7.5 MHz Clock output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS CLK7_5MHZ
Public Const CLK7_5MHZ As CBUS_SIGNALS
public:
literal CBUS_SIGNALS CLK7_5MHZ

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


CBUS_BITBANG Field

BIT_MODE..::..CBUS_BITBANG Field

CBus bit bang (FT232R, FT232H and FT X-Series only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE CBUS_BITBANG
Public Const CBUS_BITBANG As BIT_MODE
public:
literal BIT_MODE CBUS_BITBANG

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


FT4232H Field

DEVICE_TYPE..::..FT4232H Field

FT4232H device (quad channel high speed).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_TYPE FT4232H
Public Const FT4232H As DEVICE_TYPE
public:
literal DEVICE_TYPE FT4232H

See Also

DEVICE_TYPE Enumeration
FTDI.D2xx.WinRT.Device Namespace


FT1248 Field

DEVICE_INTERFACE..::..FT1248 Field

FT1248 interface.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FT1248
Public Const FT1248 As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FT1248

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


TXLED Field

CBUS_SIGNALS..::..TXLED Field

Transmit data LED drive: Data from USB Host to FT232R. Pulses low when transmitting data via USB.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXLED
Public Const TXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


RXLED Field

CBUS_SIGNALS..::..RXLED Field

Receive data LED drive: Data from FT232R to USB Host. Pulses low when receiving data via USB. See Section 7.5 for more details.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS RXLED
Public Const RXLED As CBUS_SIGNALS
public:
literal CBUS_SIGNALS RXLED

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


FIFO_CPU_Target Field

DEVICE_INTERFACE..::..FIFO_CPU_Target Field

FIFO CPU style interface.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DEVICE_INTERFACE FIFO_CPU_Target
Public Const FIFO_CPU_Target As DEVICE_INTERFACE
public:
literal DEVICE_INTERFACE FIFO_CPU_Target

See Also

DEVICE_INTERFACE Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


TXDEN Field

CBUS_SIGNALS..::..TXDEN Field

Enable transmit data for RS485.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232R
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS TXDEN
Public Const TXDEN As CBUS_SIGNALS
public:
literal CBUS_SIGNALS TXDEN

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232R Namespace


GPIO_MODE Field

CBUS_SIGNALS..::..GPIO_MODE Field

CBUS bit bang mode option. Allows up to 4 of the CBUS pins to be used as general purpose I/O. Configured individually for CBUS0, CBUS1, CBUS2 and CBUS3 in the internal MTP memory.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS GPIO_MODE
Public Const GPIO_MODE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS GPIO_MODE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


BCD_CHARGE Field

CBUS_SIGNALS..::..BCD_CHARGE Field

Battery charge Detect, indicates when the device is connected to a dedicated battery charger host. Active high output.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS BCD_CHARGE
Public Const BCD_CHARGE As CBUS_SIGNALS
public:
literal CBUS_SIGNALS BCD_CHARGE

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FTXSeries Namespace


DTR_DSR Field

FLOW_CONTROL..::..DTR_DSR Field

DTR/DSR hardware flow control.

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const FLOW_CONTROL DTR_DSR
Public Const DTR_DSR As FLOW_CONTROL
public:
literal FLOW_CONTROL DTR_DSR

See Also

FLOW_CONTROL Enumeration
FTDI.D2xx.WinRT.Device Namespace


FAST_SERIAL Field

BIT_MODE..::..FAST_SERIAL Field

Fast serial mode (FT2232D, FT2232H and FT232H only).

Namespace: FTDI.D2xx.WinRT.Device
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const BIT_MODE FAST_SERIAL
Public Const FAST_SERIAL As BIT_MODE
public:
literal BIT_MODE FAST_SERIAL

See Also

BIT_MODE Enumeration
FTDI.D2xx.WinRT.Device Namespace


DRIVE_8mA Field

DRIVE_CURRENT..::..DRIVE_8mA Field

8mA drive current.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const DRIVE_CURRENT DRIVE_8mA
Public Const DRIVE_8mA As DRIVE_CURRENT
public:
literal DRIVE_CURRENT DRIVE_8mA

See Also

DRIVE_CURRENT Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace


DRIVE_1 Field

CBUS_SIGNALS..::..DRIVE_1 Field

Output a constant 1.

Namespace: FTDI.D2xx.WinRT.Device.EEPROM.FT232H
Assembly: WinRT (in WinRT.dll)

Syntax

C#
VB
C++
public const CBUS_SIGNALS DRIVE_1
Public Const DRIVE_1 As CBUS_SIGNALS
public:
literal CBUS_SIGNALS DRIVE_1

See Also

CBUS_SIGNALS Enumeration
FTDI.D2xx.WinRT.Device.EEPROM.FT232H Namespace